Introduction

Collapse All Collapse All Expand All Expand All
SentiVeillance 9.0 SDK
Close
Introduction
See Also

SentiVeillance SDK is designed for developing software that performs biometric face identification, detects moving pedestrians or vehicles or other objects and performs automatic license plate recognition using live video streams from digital surveillance cameras. The SDK is used for passive identification – when passers-by do not make any efforts to be recognized. List of possible uses includes law enforcement, security, attendance control, visitor counting, traffic monitoring and other commercial applications.

This smart monitoring technology can be used for a variety of applications, including retail and commercial areas, entrance monitoring and counting, automated time-attendance systems, transportation, law enforcement and security systems.

SentiVeillance includes a robust, dynamic face model that can adapt to visual appearance changes as subjects move across the scene. Based on the biometric facial recognition engine from Neurotechnology, SentiVeillance provides fast face detection, improved face feature determination, gender determination and emotion detection, including detection of smiles, closed-eyes, open-mouths, clear and dark glasses. SentiVeillance matches face images against internal databases, such as authorized personnel or criminal watch lists, and the associated application can then lock or unlock a door, put a record into a time/attendance system or immediately trigger a report or alert for recognized (or un-recognized) faces.

In situations when video surveillance is monitoring a very large area or when cameras are in a position that does not allow some faces to be visible, SentiVeillance uses moving object detection and classification to identify objects vs. people in the scene. In addition to person identification, it can be used to identify and monitor objects such as cars, buses and trucks in the camera’s view.

SentiVeillance continues tracking of subjects even when their faces briefly disappear from the frame or when they are partially blocked by other objects or even other faces (a common problem while tracking multiple faces). The face recognition algorithm enables detection of faces with up to 45 degrees out-of-plane rotation in yaw angle and uses motion prediction models to re-localize faces that have undergone full occlusion, such as when a subject has been fully obstructed by a wall and emerged on the other side. The dynamic face model allows the system to efficiently and reliably track faces in front of complex backgrounds and ensures that subjects can be localized in all video frames, even under strenuous conditions.

The SentiVeillance SDK allows to create applications for Microsoft Windows and Linux platforms.

Collapse Expand Remarks
  • Breaking Changes:
    • Now faces modality events details (template, gender, and other attributes) are returned later, and should be checked for availabilityusing AttributesContainsDetails, otherwise face bounding box can be used.
  • Model optimization:
    • When using GPU for surveillance, AI models must be optimized before starting. Optimization is done for specific GPU and can not be reused on other PC, even if GPU is of same model.
    • Optimation can take 10 minutes or more, but is only required do be done once. Optimization is automatically done before starting, but can be done manually to avoid long initialization times before starting.
Collapse Expand See Also

Constraints for SentiVeillance


Features

Features

The SentiVeillance has these features for video surveillance:

  • Real time pedestrians and vehicles tracking and classification.
  • Biometric facial identification and matching against watchlist database.
  • Automated license plate recognition (ALPR) for moving vehicles.
  • Color, size and movement vector estimation for vehicles and other objects.
  • Gender classification, age evaluation, facial expression and attributes detection.
  • Automatic operation logs and reports events, adds new faces from video stream to watchlist.
  • Large surveillance systems support with multiple cameras.
  • Ready-to-use server for integration into video management systems (VMS) optionally available.
  • Reasonable prices, flexible licensing and free customer support.

The SentiVeillance technology has these specific capabilities:

  • Real time performance. SentiVeillance technology performs face recognition, pedestrian or vehicle classification and tracking in real time. The technology is designed to run on multi-core processors to achieve fast performance.
  • Three modalities for surveillance systems. Depending on the surveillance system design, one of these modalities may be used:
    • Biometric face recognition – based on deep neural networks and provides these capabilities for surveillance systems:
      • Multiple face detection, features extraction and template matching with the internal database in real time.
      • Facial identification reliability enables using large watchlist databases.
      • Face tracking is performed in all successive frames from the video source until they disappear from camera field of view. The face tracking algorithm uses dynamic face and motion prediction models that make it robust to occlusions like other objects or even other faces. The algorithm is able to continue tracking a face even when it re-appears after being fully covered by occlusions (like walls, furniture, posters etc).
      • Gender classification (optional) for each person in the frame.
      • Age determination (optional) for each person in the frame.
      • Smile, open-mouth, closed-eyes, glasses, dark-glasses, beard and mustache attributes detection (configurable).
    • Vehicle or human detection, classification and movement tracking – performs object detection of moving and static objects in the scene, their classification and tracking until they disappear. These features are available for surveillance systems:
      • Object classification. SentiVeillance allows to perform object classification, locations and tracking based on its type. Currently these classes are available: Person, Car, Bus, Truck, Bike.
      • Color estimation. The algorithm returns most likely color estimation for cars and pedestrians. The estimated color values are: red, orange, yellow, green, blue, silver, white, black, brown, grey.
      • Movement vector estimation. The algorithm returns movement vector estimation values like: "north", "south", "south-east" etc.
      • Tolerance to object visibility. The detection algorithm works with partially visible objects and from great distance.
    • Automated license plate recognition (ALPR) – once a vehicle has been detected, SentiVeillance ALPR algorithm detects and reads the license plate:
      • Traffic data processing. SentiVeillance algorithms can simultaneously read vehicle license plates from multiple moving vehicles.
      • Tolerance to camera position. Depending on camera resolution, the ALPR algorithm can read license plates from longer distance and higher angle.
      • Preventing cheating with replaced license plates. Integrators can use vehicle recognition and ALPR modalities together for making software logic which checks if recognized license plate corresponds other registration data, like vehicle color or type, and not being spoofed or moved from another vehicle.
  • Automatic operation. A system based on SentiVeillance SDK is able to log on the fly all events. It can be configured to automatically report events like match with a watch list, or perform automatic enroll from video.
  • Large surveillance systems support. SentiVeillance SDK allows to integrate its technology into surveillance systems with multiple cameras. A common PC with a GPU can process multiple video streams simultaneously.
  • Video files processing. SentiVeillance also accepts data from video files. The video files can be processed in real time as coming from a virtual camera or can be processed at maximum speed depending on hardware resources available.


Face Modality

Face Modality

The Face modality from the SentiVeillance component performs real-time detection, biometric identification and tracking of all detected faces:

  • Facial identification reliability enables using large watchlist databases (i.e. a watch-list of suspects or a list of company employees).
  • New faces may be enrolled to the database either automatically from video streams or manually as templates, which were created with VeriLook SDK.
  • Persons wearing face masks or respirators can be recognized without separate enrollment.

SentiVeillance algorithms allows to perform these advanced actions with the detected faces:

  • Face tracking, which is performed in all successive frames from the video source until they disappear from camera field of view. The face tracking algorithm uses dynamic face and motion prediction models that make it robust to occlusions like other objects or even other faces. The algorithm is able to continue tracking a face even when it re-appears after being fully covered by occlusions (like walls, furniture, posters etc).
  • Gender classification (optional) for each person in the frame.
  • Age determination (optional) for each person in the frame.
  • Face mask, smile, open-mouth, closed-eyes, glasses, dark-glasses, beard and mustache attributes detection (configurable).

VH modality can be used together with the Face modality to perform further tracking of the identified persons even when their faces no longer visible, as well as associating previous tracking history with the recognized person. Also, the VH modality can be used to obtain additional data about person's clothes.

Programming samples from the SDK show how to use this modality.


VH (vehicle-human) Modality

VH (vehicle-human) Modality

The Vehicle-Human (VH) modality from the SentiVeillance component performs real-time vehicle or human detection, classification and movement tracking. SentiVeillance algorithms allows to perform these actions with the detected objects:

  • Object classification. SentiVeillance allows to perform object classification, locations and tracking based on its type. Besides general classification between pedestrians, cars, busses, bikes and trucks, SentiVeillance 9.0 SDK performs advanced vehicle type classification with over 20 classes available, ranging from common (sedan, SUV, bus, truck etc.) to country-specific or historic (tuk-tuk, carriage etc)
  • Color estimation. The algorithm returns most likely color estimation for cars and pedestrians. The estimated color values are: red, orange, yellow, green, blue, silver, white, black, brown, grey.
  • Vehicle make and model estimation. SentiVeillance 9.0 SDK includes a neural networks-based estimation of the tracked vehicle's make (brand) and model. Besides general usage, this data can be combined with the recognized license plate and checked against the data in the vehicles registry.
  • Clothing analysis. When a pedestrian is detected, their appearance can be evaluated for the presence of different clothes or headwear types. Over 20 clothes and headwear classes are recognized, ranging from common (shirts, trousers, skirts, coats etc.) to national (i.e. sari, niqab, kimono etc.). Also, this algorithm can estimate if the person is partially or totally naked.
  • Movement direction estimation. The algorithm estimates vehicle or pedestrian movement direction as angle relative to camera orientation.
  • Tolerance to object visibility. The detection algorithm works with partially visible objects and from great distance.


ALPR Modality

ALPR Modality

The ALPR modality from the SentiVeillance component performs real-time vehicle license plate (number plate) detection and recognition. The deep neural networks based algorithms feature:

  • Reliable detection. License plates can be separated even in complex images, which contain objects like signboards or traffic signs. See the reliability tests below.
  • Traffic data processing. SentiVeillance algorithms can simultaneously read vehicle license plates from multiple moving vehicles in road traffic.
  • Tolerance to camera position. Depending on camera resolution, the ALPR algorithm can read license plates from longer distance and higher angle.

VH modality can be used together with the ALPR modality, especially in these cases:

  • Vehicle data detection. In certain scenarios a vehicle type (i.e. truck or bus) has to be detected before running the license plate recognition algorithm. Also, vehicle movement direction, color or model can be needed as a filter before running license plate recognition.
  • Preventing cheating with replaced license plates. Integrators can make software logic which checks if recognized license plate corresponds other registration data, like vehicle color or make and model, and not being spoofed or moved from another vehicle.


System Requirements

System Requirements
System requirements
  • PC or server with a compatible processor:
    • 3 GHz or better processor with 6 processor cores is recommended.
    • AVX2 support is highly recommended. Processors that do not support AVX2 will still run the SentiVeillance algorithms, but in a mode, which will not provide the specified performance. Most modern processors support this instruction set, but please check if a particular processor model supports it.
  • A graphical processing unit (GPU):
    • a GPU is required if a SentiVeillance component with any of the supported modalities is run to process more than 2 video streams simultaneously.
    • NVIDIA GeForce GTX 1080 GPU or better is recommended to process up to 10 video streams on a node.
    • Several GPUs can be used on the same machine to process larger number of video streams.
    • at least 6 GB of VRAM is recommended.
    • Compute Capability 3.5 or better should be supported by the GPU.
    • CUDA 11.2 toolkit or newer is required
    • cuDNN 7.5 library is required.
  • At least 8 GB of RAM.
  • A high-resolution digital camera. The camera resolution may vary depending on the actual application. The recommended resolution is about 2 MegaPixel, as processing video from cameras with higher resolution will require more free RAM and more powerful processor to keep the acceptable frame rate. These supported cameras are suitable for using with SentiVeillance SDK:
    • Any IP camera, that supports RTSP (Real Time Streaming Protocol):
      • Only RTP over UDP is supported.
      • VLC framework can be optionally used for reading video streams.
      • H.264/MPEG-4 AVC or Motion JPEG should be used for encoding the video stream.
    • Any high-resolution digital camera that is accessible using:
      • DirectShow or Windows Media or Media Foundation interfaces for Microsoft Windows platform;
      • GStreamer interface for Linux platform.
    • Any other device support can be added by customers using the provided Device Manager Plug-in Framework.
Microsoft Windows specific requirements
  • Microsoft Windows 7 / 8 / 10 / Server 2008 / Server 2008 R2 / Server 2012, 64-bit.
  • Microsoft .NET framework 4.5 or newer (for .NET components usage).
  • Microsoft DirectX 9.0 or later.
  • One of following development environments for application development:
    • Microsoft Visual Studio 2012 or newer (for application development under C/C++, C#, Visual Basic .Net)
    • Java SE JDK 8 or newer
Linux specific requirements
  • Ubuntu 20.04 OS
  • glibc 2.17 or newer
  • GStreamer 1.10.x or newer with gst-vaapi plugins installed for hardware accelerated video decoding
  • libgudev-1.0 219 or newer
  • wxWidgets 3.0.0 or newer libs and dev packages (to build and run SDK samples and applications based on them)
  • Java SE JDK 8 or newer (for application development with Java)
Linux specific Virtual machine (VM) requirements
  • VM must be connected to the network in bridge mode, so that UDP packets from camera can reach the VM.
  • The default vaapi plugin must be removed, because it's buggy and taking priority even when it can't function under MVs:
Copy Code
apt-get remove gstreamer1.0-vaapi
  • h264 codec must be installed
Copy Code
apt-get install gstreamer1.0-libav


Licensing

Licensing

To develop a product based on SentiVeillance 9.0 SDK technology, an integrator should obtain SentiVeillance 9.0 SDK. Integrators can develop only an end-user product using SentiVeillance 9.0 SDK and sell/install the product to their own customers.

For more information about licensing visit [image] http://www.neurotechnology.com/licensing_model.html.

Also you can refer to SentiVeillance 9.0 SDK Software License Agreement (bin\Documentation\license.html) for all licensing terms and conditions.


What's new

What's new
What's new in this update
  • Algorithms
    • Tuned default face algorithm properties for better operation.
  • Samples
    • Removed thermal camera samples.
    • Fix export functionality in SurveillanceSampleCS.
    • Fix java surveillance-sample crash and functionality.


Overview

Overview


Required Libraries

Required Libraries

The SentiVeillance uses the following main libraries:

Library
.NET Namespace
Java package
DLL and Libs
NBiometrics
(working with biometric data, standards and tools)
Neurotec.Biometrics
Neurotec.Biometrics.Gui
Neurotec.Biometrics.Standards
Neurotec.Biometrics.Standards.Interop
com.neurotec.biometrics
com.neurotec.biometrics.standards
com.neurotec.biometrics.tools
  • NBiometrics.dll
  • Neurotec.Biometrics.dll
  • libNBiometrics.so
NCore
(common infrastructure for all Neurotechnology components)
Neurotec
Neurotec.Collections.Generic
Neurotec.Collections.ObjectModel
Neurotec.ComponentModel
Neurotec.IO
Neurotec.Net.Sockets
Neurotec.Interop
Neurotec.Plugins
Neurotec.Plugins.ComponentModel
Neurotec.Reflection
Neurotec.Runtime.InteropServices
Neurotec.Security
Neurotec.Text
Neurotec.Threading
Neurotec.Threading.Tasks
com.neurotec.beans
com.neurotec.event
com.neurotec.io
com.neurotec.jna
com.neurotec.lang
com.neurotec.lang.event
com.neurotec.lang.impl
com.neurotec.lang.jna
com.neurotec.lang.reflect
com.neurotec.net
com.neurotec.plugins
com.neurotec.plugins.beans
com.neurotec.plugins.event
com.neurotec.plugins.impl
com.neurotec.text
com.neurotec.util
com.neurotec.util.concurrent
com.neurotec.util.event
com.neurotec.util.jna
  • NCore.dll
  • Neurotec.dll
  • libNCore.so
NDevices
(manages devices)
Neurotec.Devices
Neurotec.Devices.ComponentModel
com.neurotec.devices.beans
com.neurotec.devices.beans.event
com.neurotec.devices.event
com.neurotec.devices.impl
com.neurotec.devices.impl.jna
com.neurotec.devices
  • NDevices.dll
  • Neurotec.Devices.dll
  • libNDevices.so
NMedia
(loads, saves or converts media data in various formats)
Neurotec.Drawing
Neurotec.Geometry
Neurotec.Images
Neurotec.Media
Neurotec.SmartCards
Neurotec.SmartCards.Interop
Neurotec.Sound
com.neurotec.awt.geom
com.neurotec.geometry
com.neurotec.geometry.jna
com.neurotec.graphics
com.neurotec.images
com.neurotec.images.jna
com.neurotec.media
com.neurotec.smartcards
com.neurotec.smartcards.biometry
com.neurotec.sound
  • NMedia.dll
  • NSmartCards.dll
  • Neurotec.Media.dll
  • Neurotec.SmartCards.dll
  • libNMedia.so
NLicensing
(manages licenses of Neurotechnology products)
Neurotec.Licensing
com.neurotec.licensing
  • NLicensing.dll
  • Neurotec.Licensing.dll
  • libNLicensing.so
Surveillance
(performs real-time tracking)
Neurotec.Surveillance
com.neurotec.surveillance
  • NSurveillance.dll
  • Neurotec.Surveillance.dll
  • libNSurveillance.so

Libraries for Windows operating systems are saved in Bin\Win32_x86 and Bin\Win64_x64 directories.

Libraries for Linux are saved in Lib\Linux_x86 and Lib\Linux_x86_64 directories.


Licensed API functionality

Licensed API functionality

This section lists API functionality that is enabled by each license.

License name | API Component (functionality)
SentiVeillance | Devices.Cameras Surveillance Biometrics.FaceDetectionBase Biometrics.FaceDetection Biometrics.FaceExtractionBase Biometrics.FaceExtraction Biometrics.FaceSegmentsDetection Biometrics.FaceMatching Devices.Cameras


Matching Threshold and FAR/FRR

Matching Threshold and FAR/FRR

The biometric features matching algorithm provides a similarity score as a result. The higher is the score, the higher is the probability that features collections are obtained from the same person. The higher the threshold value, the more similar feature collections will have to be to yield positive results during matching.

Matching threshold - the minimum score that verification and identification functions accept to assume that the compared fingerprints, face, iris, or voice belong to the same person.

The matching threshold is linked to the false acceptance rate (FAR, different subjects erroneously accepted as of the same) of the matching algorithm. The higher is the threshold, the lower is FAR and higher FRR (false rejection rate, same subjects erroneously accepted as different) and vice versa.

The matching threshold should be determined from this table:

FAR (false acceptance rate) | Matching threshold (score)
100 % | 0
10 % | 12
1 % | 24
0.1 % | 36
0.01 % | 48
0.001 % | 60
0.0001 % | 72
0.00001 % | 84
0.000001 % | 96

or using this formula:

Copy Code
Threshold = -12 * log10(FAR); where FAR is NOT percentage value (e.g. 0.1% FAR is 0.001)

The matching threshold should be selected according to desired FAR (False Acceptance Rate). FAR is calculated for a single match (1:1) and during identification (1:N) false acceptance accumulates. Identification false acceptance probability can be calculated using this formula:

Copy Code
(1-(1-FAR/100)^N)*100, where N - DB size

For example:

If FAR=0.001% then the probability that a false acceptance situation will occur during 1:N identification (where N=10 000) is (1-(1-0.001/100)^100)*100=9.52%.

If FAR=0.0001% then the probability that a false acceptance situation will occur during 1:N identification (where N=10 000) is (1-(1-0.0001)^100)*100=1.00%.

Matching threshold/FAR should be selected according to the system's development requirements and taking into account mentioned identification of false acceptance accumulation.


Cameras

Cameras

High-resolution digital camera(s) is required for using with SentiVeillance SDK. Camera resolution may vary depending on the actual application. The recommended resolution is about 2 MegaPixel, as processing video from cameras with higher resolution will require more free RAM and more powerful processor to keep the acceptable frame rate.

These supported cameras are suitable for using with SentiVeillance SDK:

  • Any IP camera, that supports RTSP (Real Time Streaming Protocol):
    • Only RTP over UDP is supported.
    • VLC framework can be optionally used for reading video streams.
    • H.264/MPEG-4 AVC or Motion JPEG should be used for encoding the video stream.
  • Any high-resolution digital camera that is accessible using:
    • DirectShow or Windows Media or Media Foundation interfaces for Microsoft Windows platform;
    • GStreamer interface for Linux platform.
  • Mobotix M16 Thermal camera is supported for systems that need thermal imaging. SentiVeillance SDK includes a specific programming sample for processing video streams from this camera.

Any other device support can be added by customers using the provided Device Manager Plug-in Framewor (NdmMedia API).


Error codes

Error codes

In this chapter the possible error codes are listed:

Error code | Error | Description
0 | N_OK | No error.
-1 | N_E_FAILED | Operation failed.
-2 | N_E_CORE | Standard error has occurred (for internal use).
-3 | N_E_NULL_REFERENCE | Null reference has occurred (for internal use).
-4 | N_E_OUT_OF_MEMORY | There were not enough memory.
-5 | N_E_NOT_IMPLEMENTED | Functionality is not implemented.
-6 | N_E_NOT_SUPPORTED | Functionality is not supported.
-7 | N_E_INVALID_OPERATION | Attempted to perform invalid operation.
-8 | N_E_OVERFLOW | Arithmetic overflow has occurred.
-9 | N_E_INDEX_OUT_OF_RANGE | Index is out of range (for internal use).
-10 | N_E_ARGUMENT | Argument is invalid.
-11 | N_E_ARGUMENT_NULL | Argument value is NULL where non-NULL value was expected.
-12 | N_E_ARGUMENT_OUT_OF_RANGE | Argument value is out of range.
-13 | N_E_FORMAT | Format of argument value is invalid.
-14 | N_E_IO | Input/output error has occurred.
-15 | N_E_END_OF_STREAM | Attempted to read file or buffer after its end.
-16 | N_E_INVALID_ENUM_ARGUMENT | Argument is an invalid enum value.
-17 | N_E_ARITHMETIC | Arithmetic error occurred.
-18 | N_E_INVALID_CAST | The cast is invalid.
-19 | N_E_DIRECTORY_NOT_FOUND | Directory not found.
-20 | N_E_DRIVE_NOT_FOUND | Drive not found.
-21 | N_E_FILE_NOT_FOUND | File not found.
-22 | N_E_FILE_LOAD | Error loading module from file.
-23 | N_E_PATH_TOO_LONG | Path is too long.
-24 | N_E_SECURITY | Security error occurred.
-25 | N_E_ABANDONED_MUTEX | The wait completed due to an abandoned mutex.
-26 | N_E_BAD_IMAGE_FORMAT | Module has invalid format.
-27 | N_E_DLL_NOT_FOUND | Module was not found.
-28 | N_E_ENTRY_POINT_NOT_FOUND | Entry point not found in a module.
-29 | N_E_FILE_FORMAT | File or stream format is invalid.
-30 | N_E_TIMEOUT | Operation timed out.
-31 | N_E_SOCKET | Socket error occurred.
-32 | N_E_KEY_NOT_FOUND | Key not found.
-33 | N_E_AGGREGATE | One or more errors occurred.
-34 | N_E_OPERATION_CANCELED | Operation canceled.
-90 | N_E_EXTERNAL | Error in external code has occurred (for internal use).
-91 | N_E_WIN32 | Win32 error has occurred.
-92 | N_E_COM | COM error has occurred.
-93 | N_E_CLR | CLR exception has occurred.
-94 | N_E_SYS | Sys error occurred.
-95 | N_E_MAC | Mac OS error occurred.
-96 | N_E_CPP | C++ error occurred.
-97 | N_E_JVM | JVM error occurred.
-200 | N_E_NOT_ACTIVATED | Operation is not activated.


Tutorials

Tutorials

This section contains short tutorials description.

Biometrics
Tutorial | Description
CreateFaceTemplateOnServer | Demonstrates how to create face template from image on server.
CreateMultiFaceTemplate | Creates NTemplate that contains multiple faces templates (multiple NLRecord).
CreateTokenFaceImage | Demonstrates creation of token face image.
DetectFacialFeatures | Demonstrates detection of face and facial features in the image.
DetectFacialFeaturesFromCamera | Demonstrates face feature extraction from camera.
DetectFacialFeaturesFromImageStream | Demonstrates facial features detection from image stream.
EnrollFaceFromCamera | Demonstrates face feature extraction from camera.
EnrollFaceFromFile | Demonstrates how to write code for face enrollment to database from file.
EnrollFaceFromImageStream | Demonstrates enrollment from image stream.
GeneralizeFace | Demonstrates template creation and generalization of multiple faces.
IdentifyFace | Demonstrates how to write code for face identification against database.
VerifyFace | Demonstrates how to match (verify) two faces templates.
MatchMultipleFaces | Demonstrates how to write code for face identification against image containing multiple faces.
ShowTemplateContent | Demonstrates methods and functions to access internal template information.
Devices
Tutorial | Description
ImageCapture | Demonstrates capturing images from cameras.
Licensing
Tutorial | Description
DongleInfo | Demonstrates dongle information retrieval.
DongleUpdate | Demonstrates dongle online update using ticket.
IdGeneration | Demonstrates how to generate Id from serial number (either generated using LicenseManager API or given by Neurotechnology or distributor).
IdInfo | Demonstrates Id information retrieval from Id file.
LicenseActivation | Demonstrates license activation online using generated diagnostics Id.
LicenseActivationFromDongle | Demonstrates license activation from dongle.
LicenseDeactivation | Demonstrates license deactivation.
LicenseInfo | Demonstrates how to get information about specified license/hardware id/serial number.
SerialNumberGenerationFromDongle | Demonstrates serial number generation for given sequence number and product Id.
Media
Tutorial | Description
ReadVideo | Demonstrates reading video frames from specified filename or URL.l
ReadVideoFromDevice | Demonstrates capturing video frames from device.
ShowImageInfo | Displays information about an image.
Media Processing
Tutorial | Description
AdjustGrayscaleImage | Demonstrates how to adjust brightness and contrast of grayscale image.
AdjustRgbImage | Demonstrates how to adjust brightness and contrast of RGB image.
AlphaBlendRgbImage | Demonstrates RGB image Alpha channel blending.
InvertGrayscaleImage | Demonstrates grayscale image inversion.
InvertRgbImage | Demonstrates RGB image inversion.
ScaleGrayscaleImage | Demonstrates grayscale image scaling.
SentiVeillance
Tutorial | Description
CountSubjects | This tutorial uses NSurveillance library to count the number of subjects passed through the field of view of the camera. Tutorial runs for a fixed number of time and prints intermediate information. On exit prints final statistics.
CountVehiclesAndHumans | Demonstrates automatic counting of objects during surveillance.
DetectFromImage | Demonstrates Vehicle, Human, Face and License plate detection from image files
LicensePlateRecognition | Demonstrates license plate recognition.
WatchList | This tutorial uses NSurveillance library to create a watch list and log all the subjects who passed through the field of view of the camera and are present in the watch list. Tutorial runs for a fixed number of minutes and prints to console a list of best matches for each identified subject.

All tutorials are written in C#, Java and C programming languages. Almost all C tutorials are intended for Linux OS too.

Files

All tutorials are located in the /Tutorials folder.

Collapse Expand Notes

If you have User Account Control (UAC) enabled on Windows 7 / 8 you will not be able to compile Tutorials when installation folder is Program Files. Please, select different installation location in this case.


Samples

Samples

This chapter provides samples information.

Collapse Expand Notes

If you have User Account Control (UAC) enabled on Windows 7 / 8 you will not be able to compile Samples when installation folder is Program Files. Please, select different installation location in this case.

Some samples were compiled and saved in these directories: \Bin\Win64_x64\ and \Bin\Linux_x86_64\.


Faces Sample (C#)

Faces Sample (C#)

C# Simple faces sample program is used to detect facial features, extract templates from image or camera, save image from camera, identify face, verify face between images or templates and match multiple faces. The screenshot below shows the main window of Simple Faces Sample application:

Detect faces

Using this tab (image is shown above), you can detect facial features either of group's or a single person's image. After opening an image, it will automatically detect facial features depending on current 'Max roll and yaw angle deviations' settings. However, after editing these settings, click 'Detect facial features' in order to apply changes.

  • Max roll angle deviation – this value is used to define the maximum value in degrees of tilted face image which can be enrolled or identified.
  • Max yaw angle deviation – this value is used to define the maximum yaw value in degrees of face image which can be enrolled or identified.

Enroll from image

Using this tab, you can extract template from image. After opening an image, it will automatically detect facial features and extract template depending on current 'Max roll and yaw angle deviations' settings. However, after editing these settings, click 'Extract template' in order to apply changes.

Note: If image contains multiple faces, program will show only the best recognized face.

Enroll from camera

Using this tab, you can extract template or save image from camera. Select camera, press 'Start capturing' and then 'Start extraction', program will start extraction depending on 'Max stream duration in frames' setting. After it finishes, extracted image will be shown in this section and 'Save template', 'Save image' buttons will be available.

Identify face

Using this tab, you can find selected face ('Image for identification') in template(s). Score along with the file name where similar face was found is written at the bottom.

Note: Subjects are considered “similar” if their similarity value exceeds 'Matching FAR' (False acceptance rate).

Verify face

Using this tab, you can verify whether given faces are similar/identical or not. Faces can be loaded either from a template or an image. After verifying, score will be shown in the pop-up message box and below the 'Verify' button. 'Clear images' removes both images.

Note: Subjects are considered “similar” if their similarity value exceeds 'Matching FAR' (False acceptance rate).

Match multiple faces

Using this tab, you can search for a match of one face in multiple face image. Score is written below the face. If it is a match, '(match)' is written near the score. If single face image is changed, group image has to be reopened in order to rescan for a match.

Note: If reference image contains multiple faces, program will select only the best recognized face.

Create token face image

In this tab original face image is converted to token face image. At the bottom of the token face image quality, sharpness score, background uniformity score and grayscale density score are provided.

Collapse Expand Remarks

Source files for this sample application are located in the \Samples\Biometrics\CS\SimpleFacesSampleCS within SDK distribution. This sample can be built using Microsoft Visual Studio 2005 or later.

Collapse Expand Notes

Face is not detected if space between eyes is less than 40 pixels.


Devices

Devices

Devices sample applications are used to demonstrate how to use NDevices library functionality. Source code (C# and VB.NET programming languages) for Device samples is saved in Samples\Devices directory.


NdmSample - Adding support of custom device to NDeviceManager

NdmSample - Adding support of custom device to NDeviceManager

NdmSample is example of how to write NDeviceManger plugin. It demonstrates how to extend NDeviceManger with support of custom devices, such that they can be used from Neurotechnology API the same way as any other supported device.

Trying it out

Source code for this sample is saved in Samples\Devices\C\NdmSample directory and can be compiled with Visual Studio project located in the same directory. The compiled plugin library will be saved into NdmSample.dll in Bin\Win64_x64\ or Bin\Win32_x86 directories (depending on selected build configuration).

NdmSample supports interfaces for microphone, video camera, fingerprint and iris scanners. Provided devices are virtual, they are not tied to any specific hardware, instead when device is read (captured) the data from the sound, video or image file is returned. To use sample plugin the following files should be present in the compiled plugin directory:

  • NdmSampleMicrophone.wav – Sample microphone;
  • NdmSampleCamera.avi – Sample camera;
  • NdmSampleFingerScanner.png – Sample fingerprint scanner;
  • NdmSampleIrisScannerLeft.png and NdmSampleIrisScannerRight.png – Sample iris scanner.

When mentioned files are created, the sample plugin can be used as device from any Neurotechnology application. For the test it is recommended to use DevicesSampleCS.exe, as this is simple GUI application that allows to enumerate devices and perform capturing.

Customizing

The source code of the example can be used as reference for implementing support for custom device.

Please see the device manager interface documentation and the comments in the source file (NdmSample.c). One can also find the list of needed interface functions in Includes\NdmInterface.h.


wxWidgets Compilation

wxWidgets Compilation

wxWidgets are useful for creating cross-platform GUI applications. They are used for recent C++ samples and algorithm demos in Neurotechnology products. wxWidgets library can be downloaded from [image] http://www.wxwidgets.org/. Before using wxWidgets you should compile it.

wxWidgets compilation using command line tools

wxWidgets libraries also can be compiled using the command-line tool. Run these commands to compile 64-bit libraries:

64-bit Debug:

Copy Code
nmake /A /f makefile.vc UNICODE=1 USE_GDIPLUS=1 TARGET_CPU=amd64 RUNTIME_LIBS=static CPPFLAGS=/MTd BUILD=debug

64-bit Release:

Copy Code
nmake /A /f makefile.vc UNICODE=1 USE_GDIPLUS=1 TARGET_CPU=amd64 RUNTIME_LIBS=static CPPFLAGS=/MD BUILD=release

After these libraries were compiled Visual Studio include and library paths that have to be set up. See the information below.

wxWidgets compilation using Visual Studio

To compile wxWidgets as a static library do the following steps (Microsoft Visual Studio is required):

  1. Open Visual Studio command prompt.
  2. Select all projects and change C/C++/Code Generation/Runtime library to Multi Threaded DLL (/MD).
  3. Go to C:\wxWidgets-3.0.2\build\msw (in case wxWidgets are located in C disk).
  4. nmake /A /f makefile.vc UNICODE=1 RUNTIME_LIBS=static DEBUG_INFO=0 CPPFLAGS=/MDd BUILD=debug
  5. nmake /A /f makefile.vc UNICODE=1 RUNTIME_LIBS=static DEBUG_INFO=0 CPPFLAGS=/MD BUILD=release

For 64 bits systems:

  1. Open Visual Studio 64-bit command prompt.
  2. Go to C:\wxWidgets-3.0.2\build\msw (in case wxWidgets are located in C disk).
  3. nmake /A /f makefile.vc UNICODE=1 TARGET_CPU=x64 RUNTIME_LIBS=static DEBUG_INFO=0 CPPFLAGS=/MDd BUILD=debug
  4. nmake /A /f makefile.vc UNICODE=1 TARGET_CPU=x64 RUNTIME_LIBS=static DEBUG_INFO=0 CPPFLAGS=/MD BUILD=release

(Compile wxWidgets and your applications using the same Visual Studio that was used for sample compilation (Visual Studio 2005 or later) otherwise it will lead to compilation errors)

Finally, Visual Studio include and library paths have to be setup. Go to Tools->Options->Projects and Solutions->VC++ Directories and include these directories and library file from these directories:

  • C:\wxWidgets-3.0.2\include
  • C:\wxWidgets-3.0.2\include\msvc

Lib (x64):

  • C:\wxWidgets-3.0.2\lib\vc_x64_lib\


API Reference

API Reference

SentiVeillance 9.0 SDK consists of:

  • NBiometrics
  • NDevices
  • NMedia
  • NSurveillance

main libraries and libraries wrappers for .Net:

  • Neurotec.Biometrics
  • Neurotec.Devices
  • Neurotec.Media
  • Neurotec.Surveillance

NCore and NLicensing (Neurotec, Neurotec.Licensing in .NET) are auxiliary libraries that provides infrastructure.

Collapse Expand Modules
Name | Description
.NET Reference | ... more


C Reference

C Reference

In this section SentiVeillance 9.0 SDK C programming reference for API is provided.


NBiometrics Library

NBiometrics Library

Provides the main functionality for Neurotechnology SDK's:

  • Matching, extracting or comparing biometrical data.
  • Biometric standards support.
  • API Reference of the supported biometric tools.
Collapse Expand Remarks
Requirements (Windows)
  • Import Library: NBiometrics.dll.lib
  • DLLs: NBiometrics.dll

Requirements (Linux)

  • Shared objects: libNBiometrics.so
Collapse Expand Modules
Name | Description
NBiometric Unit | Provides general biometric functions.
NBiometricAttributes Unit | Provides functions to get and set biometric attributes.
NBiometricTypes Unit | Defines biometric types used by Neurotechnology components.
NFace Unit | Provides functions for biometric engine to deal with face templates.
NLAttributes Unit | Provides functions to retrieve face attributes (metadata which is not saved in face template).
NLMatchingDetails Unit | Provides functionality to retrieve face templates matching details.
NLRecord Unit | ... more
NLTemplate Unit | ... more
NMatchingDetails Unit | ... more
NMatchingDetailsBase Unit | Base unit for NMatchingDetails.
NMatchingResult Unit | Provides functions to retrieve information about matching results.
NSubject Unit | ... more
NTemplate Unit | ... more


NBiometric Unit

NBiometric Unit
Files Functions Legend Macros Structs, Records, Enums

Provides general biometric functions.

Collapse Expand Files
Name | Description
NBiometric.h | Header file for the NBiometric module.
Collapse Expand Functions
Name | Description
NBiometricCaptureOptionsIsValid | Checks whether the specified biometric capture options are valid.
NBiometricGetBiometricType | Retrieves the biometric type of the specified NBiometric object.
NBiometricGetCaptureOptions | Retrieves the capture options of the specified NBiometric object.
NBiometricGetError | Retrieves the last exception of the specified NBiometric object.
NBiometricGetFileName | Retrieves the file name of the specified NBiometric object.
NBiometricGetHasMoreSamples | Checks whether the specified NBiometric object has more samples.
NBiometricGetParentObject | Retrieves the parent object of the specified NBiometric object.
NBiometricGetSampleBuffer | ... more
NBiometricGetSessionId | Retrieves the session ID of the specified NBiometric object.
NBiometricGetStatus | Retrieves the biometric status of the specified NBiometric object.
NBiometricSetCaptureOptions | Sets the capture options of the specified NBiometric object.
NBiometricSetFileName | Sets the file name of the specified NBiometric object.
NBiometricSetHasMoreSamples | Sets whether the specified NBiometric object has more samples.
NBiometricSetSampleBuffer | ... more
NBiometricSetSessionId | Sets the session ID of the specified NBiometric object.
NBiometricSetStatus | Sets the biometric status of the specified NBiometric object.
Collapse Expand Macros
Name | Description
NBiometricSetFileName | Picks a Unicode (W) or ANSCII (A) version of the NBiometricSetFileName function.
Collapse Expand Structs, Records, Enums
Name | Description
NBiometricCaptureOptions_ | Enumerates biometric capture options.
NBiometricCaptureOptions | Enumerates biometric capture options.


NBiometricCaptureOptionsIsValid Function

NBiometricCaptureOptionsIsValid Function
NBiometric.h

Checks whether the specified biometric capture options are valid.

C++
NBool N_API NBiometricCaptureOptionsIsValid(NBiometricCaptureOptions value);
Collapse Expand Parameters
Parameters | Description
NBiometricCaptureOptions value | [in] The biometric capture options object.
Collapse Expand Returns

NTrue if the options are valid; else NFalse.

Container

File: NBiometric.h

Module: NBiometric Unit


NBiometricGetBiometricType Function

NBiometricGetBiometricType Function
NBiometric.h

Retrieves the biometric type of the specified NBiometric object.

C++
NResult N_API NBiometricGetBiometricType(HNBiometric hBiometric, NBiometricType * pValue);
Collapse Expand Parameters
Parameters | Description
HNBiometric hBiometric | [in] Handle to the NBiometric object.
NBiometricType * pValue | [out] Pointer to the biometric type.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBiometric.h

Module: NBiometric Unit


NBiometricGetCaptureOptions Function

NBiometricGetCaptureOptions Function
NBiometric.h

Retrieves the capture options of the specified NBiometric object.

C++
NResult N_API NBiometricGetCaptureOptions(HNBiometric hBiometric, NBiometricCaptureOptions * pValue);
Collapse Expand Parameters
Parameters | Description
HNBiometric hBiometric | [in] Handle to the NBiometric object.
NBiometricCaptureOptions * pValue | [out] Pointer to the capture options.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

Manual capture: does face detection from stream until NBiometricClient.Force/ForceStart is called, then does extraction or other required operations. Used only when performing capture operation (from camera or video file).

Stream capture: creates face template from multiple images. Used with capture operation or extraction from video file.

Container

File: NBiometric.h

Module: NBiometric Unit


NBiometricGetError Function

NBiometricGetError Function
NBiometric.h

Retrieves the last exception of the specified NBiometric object.

C++
NResult N_API NBiometricGetError(HNBiometric hBiometric, HNError * phValue);
Collapse Expand Parameters
Parameters | Description
HNBiometric hBiometric | [in] Handle to the NBiometric object.
HNError * phValue | [out] Pointer to the exception.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBiometric.h

Module: NBiometric Unit


NBiometricGetFileName Function

NBiometricGetFileName Function
NBiometric.h

Retrieves the file name of the specified NBiometric object.

C++
NResult N_API NBiometricGetFileName(HNBiometric hBiometric, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNBiometric hBiometric | [in] Handle to the NBiometric object.
HNString * phValue | [out] Pointer to the file name.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBiometric.h

Module: NBiometric Unit


NBiometricGetHasMoreSamples Function

NBiometricGetHasMoreSamples Function
NBiometric.h

Checks whether the specified NBiometric object has more samples.

C++
NResult N_API NBiometricGetHasMoreSamples(HNBiometric hBiometric, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNBiometric hBiometric | [in] Handle to the NBiometric object.
NBool * pValue | [out] NTrue if the object has more samples; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

Function is used for operations (stream extraction / detection) requiring multiple samples (images) to complete. When set to NTrue engine starts/continues stream extraction for each time task is performed. Changing Image does not clear NLAttributes when property is set to true. Set to NFalse when operation completed (face status != none), or when end of stream/images.

Container

File: NBiometric.h

Module: NBiometric Unit


NBiometricGetParentObject Function

NBiometricGetParentObject Function
NBiometric.h

Retrieves the parent object of the specified NBiometric object.

C++
NResult N_API NBiometricGetParentObject(HNBiometric hBiometric, HNBiometricAttributes * phValue);
Collapse Expand Parameters
Parameters | Description
HNBiometric hBiometric | [in] Handle to the NBiometric object.
HNBiometricAttributes * phValue | [out] Pointer to the parent object handle.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBiometric.h

Module: NBiometric Unit


NBiometricGetSampleBuffer Function

NBiometricGetSampleBuffer Function
NBiometric.h

Gets sample buffer. Use similar to NBiometricGetFileName function, but this is more efficient if file content is already loaded to memory.

C++
NResult N_API NBiometricGetSampleBuffer(HNBiometric hBiometric, HNBuffer * phValue);
Collapse Expand Parameters
Parameters | Description
HNBiometric hBiometric | [in] Handle to the NBiometric object.
HNBuffer * phValue | [out] Pointer to sample buffer.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBiometric.h

Module: NBiometric Unit


NBiometricGetSessionId Function

NBiometricGetSessionId Function
NBiometric.h

Retrieves the session ID of the specified NBiometric object.

C++
NResult N_API NBiometricGetSessionId(HNBiometric hBiometric, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNBiometric hBiometric | [in] Handle to the NBiometric object.
NInt * pValue | [out] Pointer to the session ID.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBiometric.h

Module: NBiometric Unit


NBiometricGetStatus Function

NBiometricGetStatus Function
NBiometric.h

Retrieves the biometric status of the specified NBiometric object.

C++
NResult N_API NBiometricGetStatus(HNBiometric hBiometric, NBiometricStatus * pValue);
Collapse Expand Parameters
Parameters | Description
HNBiometric hBiometric | [in] Handle to the NBiometric object.
NBiometricStatus * pValue | [out] Pointer to the biometric status.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBiometric.h

Module: NBiometric Unit


NBiometricSetCaptureOptions Function

NBiometricSetCaptureOptions Function
NBiometric.h

Sets the capture options of the specified NBiometric object.

C++
NResult N_API NBiometricSetCaptureOptions(HNBiometric hBiometric, NBiometricCaptureOptions value);
Collapse Expand Parameters
Parameters | Description
HNBiometric hBiometric | [in] Handle to the NBiometric object.
NBiometricCaptureOptions value | [in] The new capture options value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBiometric.h

Module: NBiometric Unit


NBiometricSetFileName Function

NBiometricSetFileName Function
NBiometric.h

Sets the file name of the specified NBiometric object.

C++
NResult N_API NBiometricSetFileName(HNBiometric hBiometric, const NChar * szValue);
Collapse Expand Parameters
Parameters | Description
HNBiometric hBiometric | [in] Handle to the NBiometric object.
const NChar * szValue | [in] The new file name.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBiometric.h

Module: NBiometric Unit


NBiometricSetHasMoreSamples Function

NBiometricSetHasMoreSamples Function
NBiometric.h

Sets whether the specified NBiometric object has more samples.

C++
NResult N_API NBiometricSetHasMoreSamples(HNBiometric hBiometric, NBool value);
Collapse Expand Parameters
Parameters | Description
HNBiometric hBiometric | [in] Handle to the NBiometric object.
NBool value | [in] NTrue if the object has more samples; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

Function is used for operations (stream extraction / detection) requiring multiple samples (images) to complete. When set to NTrue engine starts/continues stream extraction for each time task is performed. Changing Image does not clear NLAttributes when property is set to true. Set to NFalse when operation completed (face status != none), or when end of stream/images.

Container

File: NBiometric.h

Module: NBiometric Unit


NBiometricSetSampleBuffer Function

NBiometricSetSampleBuffer Function
NBiometric.h

Sets sample buffer. Use is similar to NBiometricSetFileName function, but this is more efficient if file content is already loaded to memory.

C++
NResult N_API NBiometricSetSampleBuffer(HNBiometric hBiometric, HNBuffer hValue);
Collapse Expand Parameters
Parameters | Description
HNBiometric hBiometric | [in] Handle to the NBiometric object.
HNBuffer hValue | [in] Sample buffer.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

Sample buffer is packed byte buffer loaded to memory from image file (e.g., WSQ, PNG using NFileReadAllBytes()).

Container

File: NBiometric.h

Module: NBiometric Unit


NBiometricSetSessionId Function

NBiometricSetSessionId Function
NBiometric.h

Sets the session ID of the specified NBiometric object.

C++
NResult N_API NBiometricSetSessionId(HNBiometric hBiometric, NInt value);
Collapse Expand Parameters
Parameters | Description
HNBiometric hBiometric | [in] Handle to the NBiometric object.
NInt value | [in] The new session ID value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBiometric.h

Module: NBiometric Unit


NBiometricSetStatus Function

NBiometricSetStatus Function
NBiometric.h

Sets the biometric status of the specified NBiometric object.

C++
NResult N_API NBiometricSetStatus(HNBiometric hBiometric, NBiometricStatus value);
Collapse Expand Parameters
Parameters | Description
HNBiometric hBiometric | [in] Handle to the NBiometric object.
NBiometricStatus value | [in] The new biometric status value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBiometric.h

Module: NBiometric Unit


NBiometricCaptureOptions Enumeration

NBiometricCaptureOptions Enumeration
NBiometric.h

Enumerates biometric capture options.

C++
typedef enum NBiometricCaptureOptions_ {
  nbcoNone = 0,
  nbcoManual = 1,
  nbcoStream = 2
} NBiometricCaptureOptions;
Collapse Expand Members
Members | Description
nbcoNone = 0 | Indicates that capture option is not specified.
nbcoManual = 1 | Indicates manual capture.
nbcoStream = 2 | Indicates stream capture.
Container

File: NBiometric.h

Module: NBiometric Unit


NBiometricSetFileName Macro

NBiometricSetFileName Macro
NBiometric.h

Picks a Unicode (W) or ANSCII (A) version of the NBiometricSetFileName function.

C++
#define NBiometricSetFileName N_FUNC_AW(NBiometricSetFileName)
Container

File: NBiometric.h

Module: NBiometric Unit


NBiometric.h

NBiometric.h
Enumerations Functions Legend Macros

Header file for the NBiometric module.

Collapse Expand Enumerations
Name | Description
NBiometricCaptureOptions_ | Enumerates biometric capture options.
NBiometricCaptureOptions | Enumerates biometric capture options.
Collapse Expand Functions
Name | Description
NBiometricCaptureOptionsIsValid | Checks whether the specified biometric capture options are valid.
NBiometricGetBiometricType | Retrieves the biometric type of the specified NBiometric object.
NBiometricGetCaptureOptions | Retrieves the capture options of the specified NBiometric object.
NBiometricGetError | Retrieves the last exception of the specified NBiometric object.
NBiometricGetFileName | Retrieves the file name of the specified NBiometric object.
NBiometricGetHasMoreSamples | Checks whether the specified NBiometric object has more samples.
NBiometricGetParentObject | Retrieves the parent object of the specified NBiometric object.
NBiometricGetSampleBuffer | ... more
NBiometricGetSessionId | Retrieves the session ID of the specified NBiometric object.
NBiometricGetStatus | Retrieves the biometric status of the specified NBiometric object.
NBiometricSetCaptureOptions | Sets the capture options of the specified NBiometric object.
NBiometricSetFileName | Sets the file name of the specified NBiometric object.
NBiometricSetHasMoreSamples | Sets whether the specified NBiometric object has more samples.
NBiometricSetSampleBuffer | ... more
NBiometricSetSessionId | Sets the session ID of the specified NBiometric object.
NBiometricSetStatus | Sets the biometric status of the specified NBiometric object.
Collapse Expand Macros
Name | Description
NBiometricSetFileName | Picks a Unicode (W) or ANSCII (A) version of the NBiometricSetFileName function.


NBiometricAttributes Unit

NBiometricAttributes Unit
Files Functions Legend

Provides functions to get and set biometric attributes.

Collapse Expand Files
Name | Description
NBiometricAttributes.h | Header file for NBiometricAttributes module.
Collapse Expand Functions
Name | Description
NBiometricAttributesGetBiometricType | Retrieves the biometric type of the specified biometric attributes.
NBiometricAttributesGetChild | Retrieves a child object of the specified NBiometricAttributes object.
NBiometricAttributesGetChildSubject | Gets child NSubject of the current NBiometricAttributes.
NBiometricAttributesGetDetectionConfidence | Gets detection confidence.
NBiometricAttributesGetQuality | Retrieves the quality value of the specified biometric attributes.
NBiometricAttributesGetStatus | Retrieves the biometric status of the specified biometric attributes.
NBiometricAttributesSetDetectionConfidence | Sets detection confidence.
NBiometricAttributesSetQuality | Sets the quality value of the specified biometric attributes.
NBiometricAttributesSetStatus | Sets the biometric status of the specified biometric attributes.


NBiometricAttributesGetBiometricType Function

NBiometricAttributesGetBiometricType Function
NBiometricAttributes.h

Retrieves the biometric type of the specified biometric attributes.

C++
NResult N_API NBiometricAttributesGetBiometricType(HNBiometricAttributes hAttributes, NBiometricType * pValue);
Collapse Expand Parameters
Parameters | Description
HNBiometricAttributes hAttributes | [in] Handle to the NBiometricAttributes object.
NBiometricType * pValue | [out] Pointer to the NBiometricType object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBiometricAttributes.h

Module: NBiometricAttributes Unit


NBiometricAttributesGetChild Function

NBiometricAttributesGetChild Function
NBiometricAttributes.h

Retrieves a child object of the specified NBiometricAttributes object.

C++
NResult N_API NBiometricAttributesGetChild(HNBiometricAttributes hAttributes, HNObject * phValue);
Collapse Expand Parameters
Parameters | Description
HNBiometricAttributes hAttributes | [in] Handle to the NBiometricAttributes object.
HNObject * phValue | [out] Pointer to child object handle.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBiometricAttributes.h

Module: NBiometricAttributes Unit


NBiometricAttributesGetChildSubject Function

NBiometricAttributesGetChildSubject Function
NBiometricAttributes.h

Gets child NSubject of the current NBiometricAttributes.

C++
NResult N_API NBiometricAttributesGetChildSubject(HNBiometricAttributes hAttributes, HNObject * phValue);
Collapse Expand Parameters
Parameters | Description
HNBiometricAttributes hAttributes | [in] Handle to the NBiometricAttributes object.
HNObject * phValue | [out] Child subject of the current NBiometricAttributes.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBiometricAttributes.h

Module: NBiometricAttributes Unit


NBiometricAttributesGetDetectionConfidence Function

NBiometricAttributesGetDetectionConfidence Function
NBiometricAttributes.h

Gets detection confidence.

C++
NResult N_API NBiometricAttributesGetDetectionConfidence(HNBiometricAttributes hAttributes, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNBiometricAttributes hAttributes | [in] Handle to the NBiometricAttributes object.
NByte * pValue | [out] Detection confidence value in bytes.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBiometricAttributes.h

Module: NBiometricAttributes Unit


NBiometricAttributesGetQuality Function

NBiometricAttributesGetQuality Function
NBiometricAttributes.h

Retrieves the quality value of the specified biometric attributes.

C++
NResult N_API NBiometricAttributesGetQuality(HNBiometricAttributes hAttributes, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNBiometricAttributes hAttributes | [in] Handle to the NBiometricAttributes object.
NByte * pValue | [out] Pointer to the quality value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBiometricAttributes.h

Module: NBiometricAttributes Unit


NBiometricAttributesGetStatus Function

NBiometricAttributesGetStatus Function
NBiometricAttributes.h

Retrieves the biometric status of the specified biometric attributes.

C++
NResult N_API NBiometricAttributesGetStatus(HNBiometricAttributes hAttributes, NBiometricStatus * pValue);
Collapse Expand Parameters
Parameters | Description
HNBiometricAttributes hAttributes | [in] Handle to the NBiometricAttributes object.
NBiometricStatus * pValue | [out] Pointer to the biometric status value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBiometricAttributes.h

Module: NBiometricAttributes Unit


NBiometricAttributesSetDetectionConfidence Function

NBiometricAttributesSetDetectionConfidence Function
NBiometricAttributes.h

Sets detection confidence.

C++
NResult N_API NBiometricAttributesSetDetectionConfidence(HNBiometricAttributes hAttributes, NByte value);
Collapse Expand Parameters
Parameters | Description
HNBiometricAttributes hAttributes | [in] Handle to the NBiometricAttributes object.
NByte value | [in] Detection confidence value in bytes.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBiometricAttributes.h

Module: NBiometricAttributes Unit


NBiometricAttributesSetQuality Function

NBiometricAttributesSetQuality Function
NBiometricAttributes.h

Sets the quality value of the specified biometric attributes.

C++
NResult N_API NBiometricAttributesSetQuality(HNBiometricAttributes hAttributes, NByte value);
Collapse Expand Parameters
Parameters | Description
HNBiometricAttributes hAttributes | [in] Handle to the NBiometricAttributes object.
NByte value | [in] The new quality value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBiometricAttributes.h

Module: NBiometricAttributes Unit


NBiometricAttributesSetStatus Function

NBiometricAttributesSetStatus Function
NBiometricAttributes.h

Sets the biometric status of the specified biometric attributes.

C++
NResult N_API NBiometricAttributesSetStatus(HNBiometricAttributes hAttributes, NBiometricStatus value);
Collapse Expand Parameters
Parameters | Description
HNBiometricAttributes hAttributes | [in] Handle to the NBiometricAttributes object.
NBiometricStatus value | [in] The new biometric status value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBiometricAttributes.h

Module: NBiometricAttributes Unit


NBiometricAttributes.h

NBiometricAttributes.h
Functions Legend

Header file for NBiometricAttributes module.

Collapse Expand Functions
Name | Description
NBiometricAttributesGetBiometricType | Retrieves the biometric type of the specified biometric attributes.
NBiometricAttributesGetChild | Retrieves a child object of the specified NBiometricAttributes object.
NBiometricAttributesGetChildSubject | Gets child NSubject of the current NBiometricAttributes.
NBiometricAttributesGetDetectionConfidence | Gets detection confidence.
NBiometricAttributesGetQuality | Retrieves the quality value of the specified biometric attributes.
NBiometricAttributesGetStatus | Retrieves the biometric status of the specified biometric attributes.
NBiometricAttributesSetDetectionConfidence | Sets detection confidence.
NBiometricAttributesSetQuality | Sets the quality value of the specified biometric attributes.
NBiometricAttributesSetStatus | Sets the biometric status of the specified biometric attributes.


NBiometricTypes Unit

NBiometricTypes Unit
Files Functions Legend Macros Structs, Records, Enums Types

Defines biometric types used by Neurotechnology components.

Collapse Expand Files
Name | Description
NBiometricTypes.h | Header file for NBiometricType module.
Collapse Expand Functions
Name | Description
NBiometricAngleFromDegrees | Converts the specified angle from degrees to radians.
NBiometricAngleFromRadians | Converts the specified angle from radians to degrees.
NBiometricAngleToDegrees | Converts the specified angle from radians to degrees.
NBiometricAngleToRadians | Converts the specified angle from degrees to radians.
NBiometricAngleToString | Gets a string representation of the specified angle.
NBiometricNfiq1ToNfiqQuality | Converts specified NFIQ 1.0 (NIST Fingerprint Image Quality) value to NfiqQuality value.
NBiometricNfiqQualityToNfiq1 | Converts specified NfiqQuality value to NFIQ 1.0 (NIST Fingerprint Image Quality) value.
NBiometricQualityBlockIsValid | Checks if specified NBiometricQualityBlock is valid.
NBiometricQualityBlockToString | Gets a string representation of the specified quality block.
NBiometricQualityIsValid | Checks whether the specified quality is valid.
NBiometricQualityToString | Gets a string representation of the specified quality.
NBiometricStatusIsFinal | Checks if the value passed as a parameter is denotes completed biometric operation rather then intermediate status of operation in progress.
NBiometricStatusIsValid | Checks if the value passed as a parameter is defined in NBiometricStatus.
NBiometricSubtypeIsValid | Checks if the value passed as a parameter is a valid NBiometricSubtype value.
NBiometricTypeIsValid | Checks if the value passed as a parameter is a valid NBiometricType value.
NEPositionGetAvailableParts | Determines available iris positions based on specified missing iris positions and base position.
NEPositionIsKnown | Checks whether the specified position is known.
NEPositionIsLeft | Checks whether the specified position is left.
NEPositionIsOneOf | Checks if specified NEPosition value matches one in an array.
NEPositionIsRight | Checks whether the specified position is right.
NEPositionIsRightAndLeft | Checks whether the specified position is both left and right.
NEPositionIsSingleEye | Checks whether the specified position represents a single eye.
NEPositionIsTheEye | Checks whether the specified position represents a separate eye.
NEPositionIsTwoEyes | Checks whether the specified position represents two eyes.
NEPositionIsValid | Checks if the value passed as a parameter is a valid NEPosition value.
NEPositionIsValidTheEye | Checks if the specified value is a valid NEPosition value.
NFCoreToString | Gets a string representation of the core.
NFDeltaToString | Gets a string representation of the delta.
NFDoubleCoreToString | Gets a string representation of the double core.
NFImpressionTypeIsCompatibleWith | Checks if two specified values are compatible.
NFImpressionTypeIsContact | ... more
NFImpressionTypeIsContactless | ... more
NFImpressionTypeIsFinger | Checks whether the specified value is fingerprint.
NFImpressionTypeIsGeneric | Checks whether the specified impression type is generic.
NFImpressionTypeIsLatent | Checks if the specified value is latent fingerprint or palmprint.
NFImpressionTypeIsLiveScan | Checks if the specified value is a live scan.
NFImpressionTypeIsNonOptical | ... more
NFImpressionTypeIsNonliveScan | Checks if the specified value is a non-live scan.
NFImpressionTypeIsOneOf | Checks if specified NFImpressionType value matches one in an array.
NFImpressionTypeIsOptical | ... more
NFImpressionTypeIsPalm | Checks if the specified value is a palmprint.
NFImpressionTypeIsPlain | Checks if the specified value is a plain scan or optical contact/contactless.
NFImpressionTypeIsRolled | Checks if the specified value is one of rolled biometric types.
NFImpressionTypeIsSwipe | ... more
NFImpressionTypeIsValid | Checks if the value passed as a parameter is a valid NFImpressionType value.
NFImpressionTypeIsValidFinger | Checks if the specified value is a valid fingerprint.
NFImpressionTypeIsValidPalm | Checks if the specified value is a valid palmprint.
NFImpressionTypeToFinger | Converts an impression type object into finger impression type object.
NFMinutiaNeighborToString | Gets a string representation of the minutia neighbor.
NFMinutiaToString | Gets a string representation of the minutia.
NFPatternClassIsValid | Checks whether a fingerprint pattern class is valid.
NFPatternClassIsValidForPosition | Checks whether a fingerprint pattern class is valid for the specified position.
NFPositionGetAvailableParts | Determines available finger positions based on specified missing finger positions and base position.
NFPositionIsCompatibleWith | Checks if two specified values are compatible.
NFPositionIsCompatibleWithImpressionType | Checks whether the specified position is compatible with the specified impression type.
NFPositionIsFinger | Checks if the specified value is fingerprint.
NFPositionIsFourFingers | Checks if the specified value is a type of 4 fingerprints data.
NFPositionIsKnown | ... more
NFPositionIsLeft | Checks if the specified position is left fingerprint.
NFPositionIsLeftAndRight | Checks if the specified position is left and right fingerprint.
NFPositionIsOneOf | Checks if specified NFPosition value matches one in an array.
NFPositionIsPalm | Checks if the specified value is a palmprint.
NFPositionIsRight | Checks if the specified position is right fingerprint.
NFPositionIsSingleFinger | Checks if the specified value is a single fingerprint.
NFPositionIsTheFinger | Checks if the specified value is the fingerprint.
NFPositionIsThePalm | Checks whether the specified position represents a separate palm.
NFPositionIsThreeFingers | Checks if the specified value is a type of 3 fingerprints data.
NFPositionIsTwoFingers | Checks if the specified value is a type of 2 fingerprints data.
NFPositionIsValid | Checks if the value passed as a parameter is a valid NFPosition value.
NFPositionIsValidFinger | Checks if the specified value is a valid fingerprint.
NFPositionIsValidPalm | Checks if the specified value is a valid palmprint.
NFPositionIsValidTheFinger | Checks if the specified value is a valid fingerprint.
NLFeaturePointToString | Gets a string representation of the feature point.
NfiqQualityIsValid | Checks whether a fingerprint quality value is valid.
Collapse Expand Macros
Name | Description
NBiometricAngleToString | Picks a Unicode (W) or ANSCII (A) version of the NBiometricAngleToString function.
NBiometricQualityBlockToString | Picks a Unicode (W) or ANSCII (A) version of the NBiometricQualityBlockToString function.
NBiometricQualityToString | Picks a Unicode (W) or ANSCII (A) version of the NBiometricQualityToString function.
NFCoreToString | Picks a Unicode (W) or ANSCII (A) version of the NFCoreToString function.
NFDeltaToString | Picks a Unicode (W) or ANSCII (A) version of the NFDeltaToString function.
NFDoubleCoreToString | Picks a Unicode (W) or ANSCII (A) version of the NFDoubleCoreToString function.
NFMinutiaNeighborToString | Picks a Unicode (W) or ANSCII (A) version of the NFMinutiaNeighborToString function.
NFMinutiaToString | Picks a Unicode (W) or ANSCII (A) version of the NFMinutiaToString function.
NLFeaturePointToString | Picks a Unicode (W) or ANSCII (A) version of the NLFeaturePointToString function.
N_BIOMETRIC_QUALITY_FAILED | Failed or unspecified quality.
N_BIOMETRIC_QUALITY_MAX | Maximal quality.
N_BIOMETRIC_QUALITY_MIN | Minimal quality.
N_BIOMETRIC_QUALITY_UNKNOWN | Unknown quality.
N_PHRASE_ID_UNKNOWN | Unknown phrase ID.
Collapse Expand Structs, Records, Enums
Name | Description
NBiometricQualityBlock_ | Enumerates a biometric quality block values.
NBiometricStatus_ | Enumerates biometric status values. These values are returned by NBiometricDevice.
NBiometricSubtype_ | Enumerates values which define the type of biometric data in the record. The values in this enumeration more specifically define the type of biometric data (NBiometricType) in the record.
NBiometricType_ | Enumerates types of biometric technology used in a record.
NEImageType_ | Enumerates iris image types.
NEPosition_ | Enumerates eye position values.
NFImpressionType_ | Specifies the impression type.
NFPosition_ | Specifies the finger position.
NGender_ | Specifies the gender.
NIcaoWarnings_ | Enumerates face Icao check warnings constants.
NLExpression_ | Specifies the facial expression.
NLFeaturePoint_ | ... more
NLProperties_ | Specified the facial properties.
NLivenessAction_ | Enumerates face liveness challenge action constants.
NLivenessMode_ | Enumerates face liveness mode constants.
NfiqQuality_ | Specifies the quality of a fingerprint image.
NBiometricStatus | Enumerates biometric status values. These values are returned by NBiometricDevice.
NBiometricSubtype | Enumerates values which define the type of biometric data in the record. The values in this enumeration more specifically define the type of biometric data (NBiometricType) in the record.
NBiometricType | Enumerates types of biometric technology used in a record.
NEImageType | Enumerates iris image types.
NEPosition | Enumerates eye position values.
NFImpressionType | Specifies the impression type.
NFPosition | Specifies the finger position.
NGender | Specifies the gender.
NIcaoWarnings | Enumerates face Icao check warnings constants.
NLExpression | Specifies the facial expression.
NLProperties | Specified the facial properties.
NLivenessAction | Enumerates face liveness challenge action constants.
NLivenessMode | Enumerates face liveness mode constants.
NfiqQuality | Specifies the quality of a fingerprint image.
Collapse Expand Types
Name | Description
NBiometricQualityBlock | Represents the biometric quality block.
NLFeaturePoint | Represents a facial feature point in a NLRecord.


NBiometricAngleFromDegrees Function

NBiometricAngleFromDegrees Function
NBiometricTypes.h

Converts the specified angle from degrees to radians.

C++
NInt N_API NBiometricAngleFromDegrees(NFloat value);
Collapse Expand Parameters
Parameters | Description
NFloat value | [in] Degree value.
Collapse Expand Returns

Radian value.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NBiometricAngleFromRadians Function

NBiometricAngleFromRadians Function
NBiometricTypes.h

Converts the specified angle from radians to degrees.

C++
NInt N_API NBiometricAngleFromRadians(NDouble value);
Collapse Expand Parameters
Parameters | Description
NDouble value | [in] Radian value.
Collapse Expand Returns

Degree value.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NBiometricAngleToDegrees Function

NBiometricAngleToDegrees Function
NBiometricTypes.h

Converts the specified angle from radians to degrees.

C++
NFloat N_API NBiometricAngleToDegrees(NInt value);
Collapse Expand Parameters
Parameters | Description
NInt value | [in] Radian value.
Collapse Expand Returns

Degree value.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NBiometricAngleToRadians Function

NBiometricAngleToRadians Function
NBiometricTypes.h

Converts the specified angle from degrees to radians.

C++
NDouble N_API NBiometricAngleToRadians(NInt value);
Collapse Expand Parameters
Parameters | Description
NInt value | [in] Degree value.
Collapse Expand Returns

Radian value.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NBiometricAngleToString Function

NBiometricAngleToString Function
NBiometricTypes.h

Gets a string representation of the specified angle.

C++
NResult N_API NBiometricAngleToString(NInt value, const NChar * szFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
NInt value | [in] Angle in degrees.
const NChar * szFormat | [in] Reserved.
HNString * phValue | [out] Pointer to a handle to the string representing the angle.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NBiometricNfiq1ToNfiqQuality Function

NBiometricNfiq1ToNfiqQuality Function
NBiometricTypes.h

Converts specified NFIQ 1.0 (NIST Fingerprint Image Quality) value to NfiqQuality value.

C++
NResult N_API NBiometricNfiq1ToNfiqQuality(NByte nfiq1, NfiqQuality * pNfiqQuality);
Collapse Expand Parameters
Parameters | Description
NByte nfiq1 | [in] NFIQ 1.0 value.
NfiqQuality * pNfiqQuality | [out] NfiqQuality type value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

Valid NFIQ 1.0 byte value can be 20, 40, 60, 80, 100, 254 (NFIQ 1.0 was not calculated) and 255 (failed to calculate NFIQ 1.0 value). 20 transforms into NfiqQuality.nfqPoor, 40 transforms into NfiqQuality.nfqFair, 60 transforms into NfiqQuality.nfqGood, 80 transforms into NfiqQuality.nfqVeryGood, 100 transforms into NfiqQuality.Enfqxcellent, 254 and 255 transforms into NfiqQuality.nfqUnknown.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NBiometricNfiqQualityToNfiq1 Function

NBiometricNfiqQualityToNfiq1 Function
NBiometricTypes.h

Converts specified NfiqQuality value to NFIQ 1.0 (NIST Fingerprint Image Quality) value.

C++
NResult N_API NBiometricNfiqQualityToNfiq1(NfiqQuality nfiqQuality, NByte * pNfiq1);
Collapse Expand Parameters
Parameters | Description
NfiqQuality nfiqQuality | [in] NfiqQuality value.
NByte * pNfiq1 | [out] Pointer to NByte type value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

Valid NFIQ 1.0 byte value can be 20, 40, 60, 80, 100, 254 (NFIQ 1.0 was not calculated) and 255 (failed to calculate NFIQ 1.0 value). NfiqQuality.nfqPoor transforms into 20, NfiqQuality.nfqFair transforms into 40, NfiqQuality.nfqGood transforms into 60, NfiqQuality.nfqVeryGood transforms into 80, NfiqQuality.nfqExcellent transforms into 100, NfiqQuality.nfqUnknown transforms into 254.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NBiometricQualityBlockIsValid Function

NBiometricQualityBlockIsValid Function
NBiometricTypes.h

Checks if specified NBiometricQualityBlock is valid.

C++
NResult N_API NBiometricQualityBlockIsValid(const struct NBiometricQualityBlock_ * pValue, NBool * pIsValid);
Collapse Expand Parameters
Parameters | Description
const struct NBiometricQualityBlock_ * pValue | [in] NBiometricQualityBlock object to check its validity.
NBool * pIsValid | [out] Pointer to NBool which receives check result (NTrue if valid, NFalse otherwise).
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NBiometricQualityBlockToString Function

NBiometricQualityBlockToString Function
NBiometricTypes.h

Gets a string representation of the specified quality block.

C++
NResult N_API NBiometricQualityBlockToString(const NBiometricQualityBlock * pValue, const NChar * szFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
const NBiometricQualityBlock * pValue | [in] NBiometricQualityBlock object to get its string representation.
const NChar * szFormat | [in] Reserved.
HNString * phValue | [out] Pointer to a handle to the string representing NBiometricQualityBlock.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NBiometricQualityIsValid Function

NBiometricQualityIsValid Function
NBiometricTypes.h

Checks whether the specified quality is valid.

C++
NBool N_API NBiometricQualityIsValid(NByte value);
Collapse Expand Parameters
Parameters | Description
NByte value | [in] The biometric quality to be checked.
Collapse Expand Returns

NBoolean value - NTrue or NFalse.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NBiometricQualityToString Function

NBiometricQualityToString Function
NBiometricTypes.h

Gets a string representation of the specified quality.

C++
NResult N_API NBiometricQualityToString(NByte value, const NChar * szFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
NByte value | Quality value.
const NChar * szFormat | [in] Reserved.
HNString * phValue | [out] Pointer to a handle to the string representing the angle.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NBiometricStatusIsFinal Function

NBiometricStatusIsFinal Function
NBiometricTypes.h

Checks if the value passed as a parameter is denotes completed biometric operation rather then intermediate status of operation in progress.

C++
NBool N_API NBiometricStatusIsFinal(NBiometricStatus value);
Collapse Expand Parameters
Parameters | Description
NBiometricStatus value | [in] One of NBiometricStatus values to check.
Collapse Expand Returns

NBool type value.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NBiometricStatusIsValid Function

NBiometricStatusIsValid Function
NBiometricTypes.h

Checks if the value passed as a parameter is defined in NBiometricStatus.

C++
NBool N_API NBiometricStatusIsValid(NBiometricStatus value);
Collapse Expand Parameters
Parameters | Description
NBiometricStatus value | [in] One of NBiometricStatus values to check.
Collapse Expand Returns

NBool type value - boolean value value which indicates status validation.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NBiometricSubtypeIsValid Function

NBiometricSubtypeIsValid Function
NBiometricTypes.h

Checks if the value passed as a parameter is a valid NBiometricSubtype value.

C++
NBool N_API NBiometricSubtypeIsValid(NBiometricSubtype value);
Collapse Expand Parameters
Parameters | Description
NBiometricSubtype value | [in] One of NBiometricSubtype values to check.
Collapse Expand Returns

NBool type value - boolean value value which indicates subtype validation.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NBiometricTypeIsValid Function

NBiometricTypeIsValid Function
NBiometricTypes.h

Checks if the value passed as a parameter is a valid NBiometricType value.

C++
NBool N_API NBiometricTypeIsValid(NBiometricType value);
Collapse Expand Parameters
Parameters | Description
NBiometricType value | [in] One of NBiometricType values to check.
Collapse Expand Returns

NBool type value - boolean value value which indicates biometric type validation.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NEPositionGetAvailableParts Function

NEPositionGetAvailableParts Function
NBiometricTypes.h

Determines available iris positions based on specified missing iris positions and base position.

C++
NResult N_API NEPositionGetAvailableParts(NEPosition value, const NEPosition * arMissingPositions, NInt missingPositionCount, NEPosition * arResults, NInt resultsLength);
Collapse Expand Parameters
Parameters | Description
NEPosition value | [in] NEPosition object, representing the general position.
const NEPosition * arMissingPositions | [in] Pointer to an array of NEPosition objects, representing missing position parts.
NInt missingPositionCount | [in] Number of missing positions.
NEPosition * arResults | [out] Pointer to an array of NEPosition objects, representing available position parts.
NInt resultsLength | [in] Length of memory buffer where item value is stored.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NEPositionIsKnown Function

NEPositionIsKnown Function
NBiometricTypes.h

Checks whether the specified position is known.

C++
NBool N_API NEPositionIsKnown(NEPosition value);
Collapse Expand Parameters
Parameters | Description
NEPosition value | [in] A position to be checked.
Collapse Expand Returns

NBoolean value - NTrue or NFalse.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NEPositionIsLeft Function

NEPositionIsLeft Function
NBiometricTypes.h

Checks whether the specified position is left.

C++
NBool N_API NEPositionIsLeft(NEPosition value);
Collapse Expand Parameters
Parameters | Description
NEPosition value | [in] The position to be checked.
Collapse Expand Returns

NBoolean value - NTrue or NFalse.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NEPositionIsOneOf Function

NEPositionIsOneOf Function
NBiometricTypes.h

Checks if specified NEPosition value matches one in an array.

C++
NResult N_API NEPositionIsOneOf(NEPosition value, NEPosition * arSupportedPositions, NInt supportedPositionCount, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
NEPosition value | [in] One of the NEPosition values to check.
NEPosition * arSupportedPositions | [in] NEPosition values array.
NInt supportedPositionCount | [in] Length of arSupportedPositions array.
NBool * pResult | [out] Check result (NTrue or NFalse).
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise error code is returned. NSucceeded or NFailed macros can be used to detect if the function succeeded or failed.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NEPositionIsRight Function

NEPositionIsRight Function
NBiometricTypes.h

Checks whether the specified position is right.

C++
NBool N_API NEPositionIsRight(NEPosition value);
Collapse Expand Parameters
Parameters | Description
NEPosition value | [in] The position to be checked.
Collapse Expand Returns

NBoolean value - NTrue or NFalse.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NEPositionIsRightAndLeft Function

NEPositionIsRightAndLeft Function
NBiometricTypes.h

Checks whether the specified position is both left and right.

C++
NBool N_API NEPositionIsRightAndLeft(NEPosition value);
Collapse Expand Parameters
Parameters | Description
NEPosition value | [in] The position to be checked.
Collapse Expand Returns

NBoolean value - NTrue or NFalse.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NEPositionIsSingleEye Function

NEPositionIsSingleEye Function
NBiometricTypes.h

Checks whether the specified position represents a single eye.

C++
NBool N_API NEPositionIsSingleEye(NEPosition value);
Collapse Expand Parameters
Parameters | Description
NEPosition value | [in] The position to be checked.
Collapse Expand Returns

NBoolean value - NTrue or NFalse.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NEPositionIsTheEye Function

NEPositionIsTheEye Function
NBiometricTypes.h

Checks whether the specified position represents a separate eye.

C++
NBool N_API NEPositionIsTheEye(NEPosition value);
Collapse Expand Parameters
Parameters | Description
NEPosition value | [in] The position to be checked.
Collapse Expand Returns

NBoolean value - NTrue or NFalse.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NEPositionIsTwoEyes Function

NEPositionIsTwoEyes Function
NBiometricTypes.h

Checks whether the specified position represents two eyes.

C++
NBool N_API NEPositionIsTwoEyes(NEPosition value);
Collapse Expand Parameters
Parameters | Description
NEPosition value | [in] The position to be checked.
Collapse Expand Returns

NBoolean value - NTrue or NFalse.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NEPositionIsValid Function

NEPositionIsValid Function
NBiometricTypes.h

Checks if the value passed as a parameter is a valid NEPosition value.

C++
NBool N_API NEPositionIsValid(NEPosition value);
Collapse Expand Parameters
Parameters | Description
NEPosition value | [in] One of NEPosition values to check.
Collapse Expand Returns

NBool type value - boolean value value which indicates biometric type validation.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NEPositionIsValidTheEye Function

NEPositionIsValidTheEye Function
NBiometricTypes.h

Checks if the specified value is a valid NEPosition value.

C++
NBool N_API NEPositionIsValidTheEye(NEPosition value);
Collapse Expand Parameters
Parameters | Description
NEPosition value | [in] NEPosition value to check.
Collapse Expand Returns

NBool type value - boolean value value which indicates biometric type validation.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFCoreToString Function

NFCoreToString Function
NBiometricTypes.h

Gets a string representation of the core.

C++
NResult N_API NFCoreToString(const NFCore * pValue, const NChar * szFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
const NFCore * pValue | [in] Pointer to the core.
const NChar * szFormat | [in] Reserved.
HNString * phValue | [out] Pointer to a handle to the string representing the core.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFDeltaToString Function

NFDeltaToString Function
NBiometricTypes.h

Gets a string representation of the delta.

C++
NResult N_API NFDeltaToString(const NFDelta * pValue, const NChar * szFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
const NFDelta * pValue | [in] Pointer to the delta.
const NChar * szFormat | [in] Reserved.
HNString * phValue | [out] Pointer to a handle to the string representing the delta.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFDoubleCoreToString Function

NFDoubleCoreToString Function
NBiometricTypes.h

Gets a string representation of the double core.

C++
NResult N_API NFDoubleCoreToString(const NFDoubleCore * pValue, const NChar * szFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
const NFDoubleCore * pValue | [in] Pointer to the double core.
const NChar * szFormat | [in] Reserved.
HNString * phValue | [out] Pointer to a handle to the string representing the double core.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFImpressionTypeIsCompatibleWith Function

NFImpressionTypeIsCompatibleWith Function
NBiometricTypes.h

Checks if two specified values are compatible.

C++
NBool N_API NFImpressionTypeIsCompatibleWith(NFImpressionType value, NFImpressionType otherValue);
Collapse Expand Parameters
Parameters | Description
NFImpressionType value | [in] Value to check if it is compatible with other value.
NFImpressionType otherValue | [in] Value which is used to check compatibility with value.
Collapse Expand Returns

NBool type value. NTrue - if types are compatible. NFalse - if types are incompatible.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFImpressionTypeIsContact Function

NFImpressionTypeIsContact Function
NBiometricTypes.h

Checks whether the specified NFImpressionType value is one of the following: nfitLiveScanOpticalContactPlain, nfitLiveScanOpticalContactRolled, nfitLiveScanNonOpticalContactPlain, nfitLiveScanNonOpticalContactRolled

C++
NBool N_API NFImpressionTypeIsContact(NFImpressionType value);
Collapse Expand Parameters
Parameters | Description
NFImpressionType value | [in] NFImpressionType value to check.
Collapse Expand Returns

NBool type value. NTrue - if type is contact. NFalse -otherwise.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFImpressionTypeIsContactless Function

NFImpressionTypeIsContactless Function
NBiometricTypes.h

Checks if the specified NFImpressionType value is one of the following: nfitLiveScanContactless, nfitLiveScanOpticalContactlessPlain, nfitLiveScanOpticalContactlessRolled, nfitLiveScanNonOpticalContactlessPlain, nfitLiveScanNonOpticalContactlessRolled.

C++
NBool N_API NFImpressionTypeIsContactless(NFImpressionType value);
Collapse Expand Parameters
Parameters | Description
NFImpressionType value | [in] NFImpressionType value to check.
Collapse Expand Returns

NBool type value. NTrue - if type is contactless. NFalse -otherwise.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFImpressionTypeIsFinger Function

NFImpressionTypeIsFinger Function
NBiometricTypes.h

Checks whether the specified value is fingerprint.

C++
NBool N_API NFImpressionTypeIsFinger(NFImpressionType value);
Collapse Expand Parameters
Parameters | Description
NFImpressionType value | [in] NFImpressionType value to check its type.
Collapse Expand Returns

NBool type value. NTrue - if type is a record contains fingerprint data. NFalse -otherwise.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFImpressionTypeIsGeneric Function

NFImpressionTypeIsGeneric Function
NBiometricTypes.h

Checks whether the specified impression type is generic.

C++
NBool N_API NFImpressionTypeIsGeneric(NFImpressionType value);
Collapse Expand Parameters
Parameters | Description
NFImpressionType value | [in] The impression type to be checked.
Collapse Expand Returns

NBoolean value - NTrue or NFalse.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFImpressionTypeIsLatent Function

NFImpressionTypeIsLatent Function
NBiometricTypes.h

Checks if the specified value is latent fingerprint or palmprint.

C++
NBool N_API NFImpressionTypeIsLatent(NFImpressionType value);
Collapse Expand Parameters
Parameters | Description
NFImpressionType value | [in] NFImpressionType value to check its type.
Collapse Expand Returns

NBool type value. NTrue - if type is a record contains latent fingerprint or palmprint data. NFalse -otherwise.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFImpressionTypeIsLiveScan Function

NFImpressionTypeIsLiveScan Function
NBiometricTypes.h

Checks if the specified value is a live scan.

C++
NBool N_API NFImpressionTypeIsLiveScan(NFImpressionType value);
Collapse Expand Parameters
Parameters | Description
NFImpressionType value | [in] NFImpressionType value to check its type.
Collapse Expand Returns

NBool type value. NTrue - if type is a record contains a live scan. NFalse -otherwise.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFImpressionTypeIsNonOptical Function

NFImpressionTypeIsNonOptical Function
NBiometricTypes.h

Checks if the specified NFImpressionType value is one of the following: nfitLiveScanNonOpticalContactPlain, nfitLiveScanNonOpticalContactRolled, nfitLiveScanNonOpticalContactlessPlain, nfitLiveScanNonOpticalContactlessRolled.

C++
NBool N_API NFImpressionTypeIsNonOptical(NFImpressionType value);
Collapse Expand Parameters
Parameters | Description
NFImpressionType value | [in] NFImpressionType value to check.
Collapse Expand Returns

NBool type value. NTrue - if type is non-optical. NFalse - otherwise.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFImpressionTypeIsNonliveScan Function

NFImpressionTypeIsNonliveScan Function
NBiometricTypes.h

Checks if the specified value is a non-live scan.

C++
NBool N_API NFImpressionTypeIsNonliveScan(NFImpressionType value);
Collapse Expand Parameters
Parameters | Description
NFImpressionType value | [in] NFImpressionType value to check its type.
Collapse Expand Returns

NBool type value. NTrue - if type is a record contains a non-live scan. NFalse - otherwise.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFImpressionTypeIsOneOf Function

NFImpressionTypeIsOneOf Function
NBiometricTypes.h

Checks if specified NFImpressionType value matches one in an array.

C++
NResult N_API NFImpressionTypeIsOneOf(NFImpressionType value, NFImpressionType * arSupportedImpressionTypes, NInt supportedImressionTypeCount, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
NFImpressionType value | [in] One of the NFImpressionType values to check.
NFImpressionType * arSupportedImpressionTypes | [in] NFImpressionType values array.
NInt supportedImressionTypeCount | [in] Length of arSupportedImpressionTypes array.
NBool * pResult | [out] Check result (NTrue or NFalse).
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise error code is returned. NSucceeded or NFailed macros can be used to detect if the function succeeded or failed.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFImpressionTypeIsOptical Function

NFImpressionTypeIsOptical Function
NBiometricTypes.h

Checks if the specified NFImpressionType value is one of the following: nfitLiveScanOpticalContactPlain, nfitLiveScanOpticalContactRolled, nfitLiveScanOpticalContactlessPlain, nfitLiveScanOpticalContactlessRolled.

C++
NBool N_API NFImpressionTypeIsOptical(NFImpressionType value);
Collapse Expand Parameters
Parameters | Description
NFImpressionType value | [in] NFImpressionType value to check.
Collapse Expand Returns

NBool type value. NTrue - if type is optical. NFalse - otherwise.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFImpressionTypeIsPalm Function

NFImpressionTypeIsPalm Function
NBiometricTypes.h

Checks if the specified value is a palmprint.

C++
NBool N_API NFImpressionTypeIsPalm(NFImpressionType value);
Collapse Expand Parameters
Parameters | Description
NFImpressionType value | [in] NFImpressionType value to check its type.
Collapse Expand Returns

NBool type value. NTrue - if record contains palmprint data. NFalse -otherwise.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFImpressionTypeIsPlain Function

NFImpressionTypeIsPlain Function
NBiometricTypes.h

Checks if the specified value is a plain scan or optical contact/contactless.

C++
NBool N_API NFImpressionTypeIsPlain(NFImpressionType value);
Collapse Expand Parameters
Parameters | Description
NFImpressionType value | [in] NFImpressionType value to check its type.
Collapse Expand Returns

NBool type value.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFImpressionTypeIsRolled Function

NFImpressionTypeIsRolled Function
NBiometricTypes.h

Checks if the specified value is one of rolled biometric types.

C++
NBool N_API NFImpressionTypeIsRolled(NFImpressionType value);
Collapse Expand Parameters
Parameters | Description
NFImpressionType value | [in] NFImpressionType value to check its type.
Collapse Expand Returns

NBool type value.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFImpressionTypeIsSwipe Function

NFImpressionTypeIsSwipe Function
NBiometricTypes.h

Checks if the specified NFImpressionType value is one of the following: nfitLiveScanVerticalSwipe.

C++
NBool N_API NFImpressionTypeIsSwipe(NFImpressionType value);
Collapse Expand Parameters
Parameters | Description
NFImpressionType value | [in] NFImpressionType value to check.
Collapse Expand Returns

NBool type value.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFImpressionTypeIsValid Function

NFImpressionTypeIsValid Function
NBiometricTypes.h

Checks if the value passed as a parameter is a valid NFImpressionType value.

C++
NBool N_API NFImpressionTypeIsValid(NFImpressionType value);
Collapse Expand Parameters
Parameters | Description
NFImpressionType value | [in] One of NFImpressionType values to check.
Collapse Expand Returns

NBool type value - boolean value value which indicates NFImpressionType validation.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFImpressionTypeIsValidFinger Function

NFImpressionTypeIsValidFinger Function
NBiometricTypes.h

Checks if the specified value is a valid fingerprint.

C++
NBool N_API NFImpressionTypeIsValidFinger(NFImpressionType value);
Collapse Expand Parameters
Parameters | Description
NFImpressionType value | [in] One of NFImpressionType values to check.
Collapse Expand Returns

NBool type value.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFImpressionTypeIsValidPalm Function

NFImpressionTypeIsValidPalm Function
NBiometricTypes.h

Checks if the specified value is a valid palmprint.

C++
NBool N_API NFImpressionTypeIsValidPalm(NFImpressionType value);
Collapse Expand Parameters
Parameters | Description
NFImpressionType value | [in] One of NFImpressionType values to check.
Collapse Expand Returns

NBool type value.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFImpressionTypeToFinger Function

NFImpressionTypeToFinger Function
NBiometricTypes.h

Converts an impression type object into finger impression type object.

C++
NFImpressionType N_API NFImpressionTypeToFinger(NFImpressionType value);
Collapse Expand Parameters
Parameters | Description
NFImpressionType value | [in] NFImpressionType to be converted.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFMinutiaNeighborToString Function

NFMinutiaNeighborToString Function
NBiometricTypes.h

Gets a string representation of the minutia neighbor.

C++
NResult N_API NFMinutiaNeighborToString(const NFMinutiaNeighbor * pValue, const NChar * szFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
const NFMinutiaNeighbor * pValue | [in] Pointer to the minutia neighbor.
const NChar * szFormat | [in] Reserved.
HNString * phValue | [out] Pointer to a handle to the string representing the minutia neighbor.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFMinutiaToString Function

NFMinutiaToString Function
NBiometricTypes.h

Gets a string representation of the minutia.

C++
NResult N_API NFMinutiaToString(const NFMinutia * pValue, const NChar * szFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
const NFMinutia * pValue | [in] Pointer to the minutia.
const NChar * szFormat | [in] Reserved.
HNString * phValue | [out] Pointer to a handle to the string representing the minutia.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFPatternClassIsValid Function

NFPatternClassIsValid Function
NBiometricTypes.h

Checks whether a fingerprint pattern class is valid.

C++
NBool N_API NFPatternClassIsValid(NFPatternClass value);
Collapse Expand Parameters
Parameters | Description
NFPatternClass value | [in] Fingerprint pattern class.
Collapse Expand Returns

NTrue if the value is valid, else NFalse.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFPatternClassIsValidForPosition Function

NFPatternClassIsValidForPosition Function
NBiometricTypes.h

Checks whether a fingerprint pattern class is valid for the specified position.

C++
NBool N_API NFPatternClassIsValidForPosition(NFPatternClass value, NFPosition pos);
Collapse Expand Parameters
Parameters | Description
NFPatternClass value | [in] Fingerprint pattern class.
NFPosition pos | [in] Finger position.
Collapse Expand Returns

NTrue if the value is valid, else NFalse.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFPositionGetAvailableParts Function

NFPositionGetAvailableParts Function
NBiometricTypes.h

Determines available finger positions based on specified missing finger positions and base position.

C++
NResult N_API NFPositionGetAvailableParts(NFPosition value, const NFPosition * arMissingPositions, NInt missingPositionCount, NFPosition * arResults, NInt resultsLength);
Collapse Expand Parameters
Parameters | Description
NFPosition value | [in] NFPosition object, representing the general position.
const NFPosition * arMissingPositions | [in] Pointer to an array of NFPosition objects, representing missing position parts.
NInt missingPositionCount | [in] Number of missing positions.
NFPosition * arResults | [out] Pointer to an array of NFPosition objects, representing available position parts.
NInt resultsLength | [in] Length of memory buffer where item value is stored.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFPositionIsCompatibleWith Function

NFPositionIsCompatibleWith Function
NBiometricTypes.h

Checks if two specified values are compatible.

C++
NBool N_API NFPositionIsCompatibleWith(NFPosition value, NFPosition otherValue);
Collapse Expand Parameters
Parameters | Description
NFPosition value | [in] Value to check if it is compatible with other value.
NFPosition otherValue | [in] Value which is used to check compatibility with value.
Collapse Expand Returns

NBool type value. NTrue - if types are compatible. NFalse - if types are incompatible.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFPositionIsCompatibleWithImpressionType Function

NFPositionIsCompatibleWithImpressionType Function
NBiometricTypes.h

Checks whether the specified position is compatible with the specified impression type.

C++
NBool N_API NFPositionIsCompatibleWithImpressionType(NFPosition value, NFImpressionType imp);
Collapse Expand Parameters
Parameters | Description
NFPosition value | [in] The position to be checked.
NFImpressionType imp | [in] Impression type.
Collapse Expand Returns

NBoolean value - NTrue or NFalse.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFPositionIsFinger Function

NFPositionIsFinger Function
NBiometricTypes.h

Checks if the specified value is fingerprint.

C++
NBool N_API NFPositionIsFinger(NFPosition value);
Collapse Expand Parameters
Parameters | Description
NFPosition value | [in] NFPosition value to check its type.
Collapse Expand Returns

NBool type value. NTrue - if type is a record contains fingerprint data. NFalse -otherwise.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFPositionIsFourFingers Function

NFPositionIsFourFingers Function
NBiometricTypes.h

Checks if the specified value is a type of 4 fingerprints data.

C++
NBool N_API NFPositionIsFourFingers(NFPosition value);
Collapse Expand Parameters
Parameters | Description
NFPosition value | [in] Value to check its type.
Collapse Expand Returns

NBool type value. NTrue - if record contains four fingerprints data. NFalse - otherwise.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFPositionIsKnown Function

NFPositionIsKnown Function
NBiometricTypes.h

Checks if the record contains biometric data which type is one of the known fingerprint types (thumb, palmprint, etc.).

C++
NBool N_API NFPositionIsKnown(NFPosition value);
Collapse Expand Parameters
Parameters | Description
NFPosition value | [in] Value to check its type.
Collapse Expand Returns

NBool type value. NTrue - if record contains biometric data of known fingerprint types.. NFalse - otherwise.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFPositionIsLeft Function

NFPositionIsLeft Function
NBiometricTypes.h

Checks if the specified position is left fingerprint.

C++
NBool N_API NFPositionIsLeft(NFPosition value);
Collapse Expand Parameters
Parameters | Description
NFPosition value | [in] Value to check its type.
Collapse Expand Returns

NBool type value. NTrue - if record contains biometric data of left fingerprint.. NFalse - otherwise.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFPositionIsLeftAndRight Function

NFPositionIsLeftAndRight Function
NBiometricTypes.h

Checks if the specified position is left and right fingerprint.

C++
NBool N_API NFPositionIsLeftAndRight(NFPosition value);
Collapse Expand Parameters
Parameters | Description
NFPosition value | [in] Fingerprint position to check its type.
Collapse Expand Returns

NBool type value. NTrue - if specified value is biometric data of left and right fingerprint type. NFalse - otherwise.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFPositionIsOneOf Function

NFPositionIsOneOf Function
NBiometricTypes.h

Checks if specified NFPosition value matches one in an array.

C++
NResult N_API NFPositionIsOneOf(NFPosition value, NFPosition * arSupportedPositions, NInt supportedPositionCount, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
NFPosition value | [in] One of the NFPosition values to check.
NFPosition * arSupportedPositions | [in] NFPosition values array.
NInt supportedPositionCount | [in] Length of arSupportedPositions array.
NBool * pResult | [out] Check result (NTrue or NFalse).
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise error code is returned. NSucceeded or NFailed macros can be used to detect if the function succeeded or failed.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFPositionIsPalm Function

NFPositionIsPalm Function
NBiometricTypes.h

Checks if the specified value is a palmprint.

C++
NBool N_API NFPositionIsPalm(NFPosition value);
Collapse Expand Parameters
Parameters | Description
NFPosition value | [in] NFPosition value to check its type.
Collapse Expand Returns

NBool type value. NTrue - if specified value is a palmprint. NFalse -otherwise.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFPositionIsRight Function

NFPositionIsRight Function
NBiometricTypes.h

Checks if the specified position is right fingerprint.

C++
NBool N_API NFPositionIsRight(NFPosition value);
Collapse Expand Parameters
Parameters | Description
NFPosition value | [in] Value to check its type.
Collapse Expand Returns

NBool type value. NTrue - if specified position is right\ fingerprint. NFalse - otherwise.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFPositionIsSingleFinger Function

NFPositionIsSingleFinger Function
NBiometricTypes.h

Checks if the specified value is a single fingerprint.

C++
NBool N_API NFPositionIsSingleFinger(NFPosition value);
Collapse Expand Parameters
Parameters | Description
NFPosition value | [in] NFPosition value to check its type.
Collapse Expand Returns

NBool type value. NTrue - if specified position is single fingerprint. NFalse - otherwise.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFPositionIsTheFinger Function

NFPositionIsTheFinger Function
NBiometricTypes.h

Checks if the specified value is the fingerprint.

C++
NBool N_API NFPositionIsTheFinger(NFPosition value);
Collapse Expand Parameters
Parameters | Description
NFPosition value | [in] NFPosition value to check its type.
Collapse Expand Returns

NBool type value. NTrue - if specified position the fingerprint. NFalse - otherwise.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFPositionIsThePalm Function

NFPositionIsThePalm Function
NBiometricTypes.h

Checks whether the specified position represents a separate palm.

C++
NBool N_API NFPositionIsThePalm(NFPosition value);
Collapse Expand Parameters
Parameters | Description
NFPosition value | [in] Position to be checked.
Collapse Expand Returns

NBoolean value - NTrue or NFalse.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFPositionIsThreeFingers Function

NFPositionIsThreeFingers Function
NBiometricTypes.h

Checks if the specified value is a type of 3 fingerprints data.

C++
NBool N_API NFPositionIsThreeFingers(NFPosition value);
Collapse Expand Parameters
Parameters | Description
NFPosition value | [in] Value to check its type.
Collapse Expand Returns

NBool type value. NTrue - if record contains three fingerprints data. NFalse - otherwise.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFPositionIsTwoFingers Function

NFPositionIsTwoFingers Function
NBiometricTypes.h

Checks if the specified value is a type of 2 fingerprints data.

C++
NBool N_API NFPositionIsTwoFingers(NFPosition value);
Collapse Expand Parameters
Parameters | Description
NFPosition value | [in] Value to check its type.
Collapse Expand Returns

NBool type value. NTrue - if record contains two fingerprints data. NFalse - otherwise.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFPositionIsValid Function

NFPositionIsValid Function
NBiometricTypes.h

Checks if the value passed as a parameter is a valid NFPosition value.

C++
NBool N_API NFPositionIsValid(NFPosition value);
Collapse Expand Parameters
Parameters | Description
NFPosition value | [in] One of NFPosition values to check.
Collapse Expand Returns

NBool type value - boolean value value which indicates biometric type validation.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFPositionIsValidFinger Function

NFPositionIsValidFinger Function
NBiometricTypes.h

Checks if the specified value is a valid fingerprint.

C++
NBool N_API NFPositionIsValidFinger(NFPosition value);
Collapse Expand Parameters
Parameters | Description
NFPosition value | [in] One of NFPosition values to check.
Collapse Expand Returns

NBool type value.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFPositionIsValidPalm Function

NFPositionIsValidPalm Function
NBiometricTypes.h

Checks if the specified value is a valid palmprint.

C++
NBool N_API NFPositionIsValidPalm(NFPosition value);
Collapse Expand Parameters
Parameters | Description
NFPosition value | [in] One of NFPosition values to check.
Collapse Expand Returns

NBool type value.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFPositionIsValidTheFinger Function

NFPositionIsValidTheFinger Function
NBiometricTypes.h

Checks if the specified value is a valid fingerprint.

C++
NBool N_API NFPositionIsValidTheFinger(NFPosition value);
Collapse Expand Parameters
Parameters | Description
NFPosition value | [in] One of NFPosition values to check.
Collapse Expand Returns

NBool type value.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NLFeaturePointToString Function

NLFeaturePointToString Function
NBiometricTypes.h

Gets a string representation of the feature point.

C++
NResult N_API NLFeaturePointToString(const NLFeaturePoint * pValue, const NChar * szFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
const NLFeaturePoint * pValue | [in] Pointer to the feature point.
const NChar * szFormat | [in] Reserved.
HNString * phValue | [out] Pointer to a handle to the string representing the feature point.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NfiqQualityIsValid Function

NfiqQualityIsValid Function
NBiometricTypes.h

Checks whether a fingerprint quality value is valid.

C++
NBool N_API NfiqQualityIsValid(NfiqQuality value);
Collapse Expand Parameters
Parameters | Description
NfiqQuality value | [in] Nfiq quality value.
Collapse Expand Returns

NTrue if the value is valid, else NFalse.

Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NBiometricQualityBlock_ Structure

NBiometricQualityBlock_ Structure
NBiometricTypes.h

Enumerates a biometric quality block values.

C++
struct NBiometricQualityBlock_ {
  NByte qualityScore;
  NUShort qualityAlgorithmVendorId;
  NUShort qualityAlgorithmId;
};
Collapse Expand Members
Members | Description
NByte qualityScore; | Quality score.
NUShort qualityAlgorithmVendorId; | Quality algorithm vendor Id.
NUShort qualityAlgorithmId; | Quality algorithm Id.
Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NLFeaturePoint_ Structure

NLFeaturePoint_ Structure
NBiometricTypes.h

Enumerates detected facial feature point values.

C++
struct NLFeaturePoint_ {
  NUShort Code;
  NUShort X;
  NUShort Y;
  NByte Confidence;
};
Collapse Expand Members
Members | Description
NUShort Code; | Facial feature point id.
NUShort X; | X coordinate of the point.
NUShort Y; | Y coordinate of the point.
NByte Confidence; | Detection confidence (0 – not available, [1..100] – detected).
Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NBiometricStatus Enumeration

NBiometricStatus Enumeration
NBiometricTypes.h

Enumerates biometric status values. These values are returned by NBiometricDevice.

C++
typedef enum NBiometricStatus_ {
  nbsNone = 0,
  nbsOk = 1,
  nbsCanceled = 2,
  nbsTimeout = 3,
  nbsSourceMissing = 9,
  nbsCleaningNeeded = 10,
  nbsObjectsNotRemoved = 20,
  nbsObjectMissing = 21,
  nbsObjectNotFound = 22,
  nbsTooFewObjects = 23,
  nbsTooManyObjects = 24,
  nbsBadObjectSequence = 25,
  nbsSpoofDetected = 30,
  nbsMaskDetected = 39,
  nbsBadObject = 40,
  nbsBadDynamicRange = 41,
  nbsBadExposure = 42,
  nbsBadSharpness = 43,
  nbsTooNoisy = 44,
  nbsBadContrast = 45,
  nbsBadLighting = 46,
  nbsOcclusion = 47,
  nbsBadPose = 48,
  nbsTooFewFeatures = 49,
  nbsTooSoft = 51,
  nbsTooHard = 52,
  nbsBadPosition = 60,
  nbsTooNorth = 61,
  nbsTooEast = 62,
  nbsTooSouth = 63,
  nbsTooWest = 64,
  nbsTooClose = 65,
  nbsTooFar = 66,
  nbsBadSpeed = 70,
  nbsTooSlow = 71,
  nbsTooFast = 72,
  nbsBadSize = 80,
  nbsTooShort = 81,
  nbsTooLong = 82,
  nbsTooNarrow = 83,
  nbsTooWide = 84,
  nbsTooSkewed = 91,
  nbsWrongDirection = 92,
  nbsWrongHand = 93,
  nbsTips = 94,
  nbsTooFewSamples = 100,
  nbsIncompatibleSamples = 101,
  nbsSourceNotFound = 501,
  nbsIncompatibleSource = 502,
  nbsIdNotFound = 601,
  nbsDuplicateId = 602,
  nbsMatchNotFound = 610,
  nbsDuplicateFound = 611,
  nbsConflict = 612,
  nbsInvalidOperations = 900,
  nbsInvalidId = 901,
  nbsInvalidQuery = 902,
  nbsInvalidPropertyValue = 903,
  nbsInvalidFieldValue = 904,
  nbsInvalidSampleResolution = 905,
  nbsOperationNotSupported = 990,
  nbsOperationNotActivated = 991,
  nbsSourceError = 996,
  nbsCaptureError = 997,
  nbsCommunicationError = 998,
  nbsInternalError = 999
} NBiometricStatus;
Collapse Expand Members
Members | Description
nbsNone = 0 |
nbsOk = 1 | Indicates succeeded operation.
nbsCanceled = 2 | Indicates canceled operation.
nbsTimeout = 3 | Indicates that operation timed-out.
nbsSourceMissing = 9 | Indicates that NFace or NFinger was not set with the image or capture device was not set for capture operation.
nbsCleaningNeeded = 10 | Indicates that biometric device should be cleaned.
nbsObjectsNotRemoved = 20 | Indicates that object(s) was not removed after/before NBiometricDevice finished/started capturing process, usually it is returned when finger is placed on fingerprint scanner sensor before capturing operation is started.
nbsObjectMissing = 21 | Indicates that object was marked as missing e.g. when you capture 4 fingerprints and you set one of them as missing (that NFinger will have this status), then scanner will expect only 3 fingers.
nbsObjectNotFound = 22 | Indicates that object(s) (e.g. face or iris) was not found – object(s) is found if it passes Confidence Threshold value.
nbsTooFewObjects = 23 |
nbsTooManyObjects = 24 | Indicates that too many objects were provided for NBiometricDevice to perform operation.
nbsBadObjectSequence = 25 | Indicates sequence of bad object(s).
nbsSpoofDetected = 30 | Indicates that spoof object was detected.
nbsMaskDetected = 39 | Indicates that mask was detected.
nbsBadObject = 40 | Indicates bad object (quality of detected object is lower than Quality Threshold).
nbsBadDynamicRange = 41 | Indicates that dynamic range of image is bad.
nbsBadExposure = 42 | Indicates bad exposure (e.g. too low light).
nbsBadSharpness = 43 | Indicates that image is too sharpen or too blurred.
nbsTooNoisy = 44 | Indicates that image is too noisy.
nbsBadContrast = 45 | Indicates bad contrast.
nbsBadLighting = 46 | Indicates bad lighting or lighting artifacts.
nbsOcclusion = 47 | Indicates occlusion.
nbsBadPose = 48 | Indicates bad pose.
nbsTooFewFeatures = 49 | Indicates that there are too few features to be extracted (e.g. fingerprint has less minutiaes than minimum number or voice recording is too short).
nbsTooSoft = 51 | Indicates that fingerprint was placed too soft on a device.
nbsTooHard = 52 | Indicates that fingerprint was placed too hard on a device.
nbsBadPosition = 60 | Indicates bad fingerprint position.
nbsTooNorth = 61 | Indicated that object was too north from device.
nbsTooEast = 62 | Indicated that object was too east from device.
nbsTooSouth = 63 | Indicated that object was too south from device.
nbsTooWest = 64 | Indicated that object was too west from device.
nbsTooClose = 65 | Indicated that object was too close to device.
nbsTooFar = 66 | Indicated that object was too far from device.
nbsBadSpeed = 70 |
nbsTooSlow = 71 |
nbsTooFast = 72 |
nbsBadSize = 80 | Indicates object's bad size.
nbsTooShort = 81 | Indicates that object is too short for NBiometricDevice to perform operation.
nbsTooLong = 82 | Indicates that object is too long for NBiometricDevice to perform operation.
nbsTooNarrow = 83 | Indicates that object is too narrow for NBiometricDevice to perform operation.
nbsTooWide = 84 | Indicates that object is too wide for NBiometricDevice to perform operation.
nbsTooSkewed = 91 | Indicates that object is too skewed.
nbsWrongDirection = 92 | Indicates that object was moving to wrong direction.
nbsWrongHand = 93 | Indicates that provided hand is wrong.
nbsTips = 94 | Indicates that tips were detected.
nbsTooFewSamples = 100 | Indicates that there are too few samples.
nbsIncompatibleSamples = 101 | Indicates that samples are incompatible.
nbsSourceNotFound = 501 | Indicates that source was not found i.e. image path set to NFace, NFinger, etc. does not exist.
nbsIncompatibleSource = 502 | Indicates that file set as an image to NFace, NFinger, etc. object is not an image or is of the format which is not supported.
nbsIdNotFound = 601 | NSubject with specified Id value was not found.
nbsDuplicateId = 602 | The Id specified in NSubject already exists in the database.
nbsMatchNotFound = 610 | Indicates that match was not found.
nbsDuplicateFound = 611 | Indicates that duplicate template was found.
nbsConflict = 612 | Indicates operation conflict.
nbsInvalidOperations = 900 | Indicates that operation is not possible for the object.
nbsInvalidId = 901 | Indicates invalid Id value i.e. signs “?”, “!” are not allowed in Id.
nbsInvalidQuery = 902 | Query specified in the NSubject cannot be executed.
nbsInvalidPropertyValue = 903 | Indicates that property value is invalid.
nbsInvalidFieldValue = 904 | Indicates invalid field value.
nbsInvalidSampleResolution = 905 | Indicates that image resolution is not set or is set with value lower than 250.
nbsOperationNotSupported = 990 | Indicates that operation cannot be use with that object.
nbsOperationNotActivated = 991 | Indicates that functionality is not enabled, as required licenses were not obtained.
nbsSourceError = 996 | Indicates source error.
nbsCaptureError = 997 | Indicates capture error.
nbsCommunicationError = 998 | Indicates communication error.
nbsInternalError = 999 | Indicates internal error.
Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NBiometricSubtype Enumeration

NBiometricSubtype Enumeration
NBiometricTypes.h

Enumerates values which define the type of biometric data in the record. The values in this enumeration more specifically define the type of biometric data (NBiometricType) in the record.

C++
typedef enum NBiometricSubtype_ {
  nbstNone = 0x000000,
  nbstLeft = 0x000001,
  nbstRight = 0x000002,
  nbstLeftThumb = 0x000004,
  nbstLeftPointerFinger = 0x000008,
  nbstLeftMiddleFinger = 0x000010,
  nbstLeftRingFinger = 0x000020,
  nbstLeftLittleFinger = 0x000040,
  nbstRightThumb = 0x000080,
  nbstRightPointerFinger = 0x000100,
  nbstRightMiddleFinger = 0x000200,
  nbstRightRingFinger = 0x000400,
  nbstRightLittleFinger = 0x000800,
  nbstLeftPalm = 0x001000,
  nbstLeftBackOfHand = 0x002000,
  nbstLeftWrist = 0x004000,
  nbstRightPalm = 0x008000,
  nbstRightBackOfHand = 0x010000,
  nbstRightWrist = 0x020000
} NBiometricSubtype;
Collapse Expand Members
Members | Description
nbstNone = 0x000000 | Indicates that none of the NBiometricSubtype values were set for the record.
nbstLeft = 0x000001 |
nbstRight = 0x000002 |
nbstLeftThumb = 0x000004 |
nbstLeftPointerFinger = 0x000008 |
nbstLeftMiddleFinger = 0x000010 | Identify the instance of biometric type related to left middle finger.
nbstLeftRingFinger = 0x000020 |
nbstLeftLittleFinger = 0x000040 | Identify the instance of biometric type related to left little finger.
nbstRightThumb = 0x000080 |
nbstRightPointerFinger = 0x000100 |
nbstRightMiddleFinger = 0x000200 | Identify the instance of biometric type related to right middle finger.
nbstRightRingFinger = 0x000400 |
nbstRightLittleFinger = 0x000800 | Identify the instance of biometric type related to right little finger.
nbstLeftPalm = 0x001000 |
nbstLeftBackOfHand = 0x002000 | Indicates that record contains left back of the palm data.
nbstLeftWrist = 0x004000 |
nbstRightPalm = 0x008000 |
nbstRightBackOfHand = 0x010000 | Indicates that record contains right back of the palm data.
nbstRightWrist = 0x020000 |
Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NBiometricType Enumeration

NBiometricType Enumeration
NBiometricTypes.h

Enumerates types of biometric technology used in a record.

C++
typedef enum NBiometricType_ {
  nbtNone = 0x000000,
  nbtMultipleBiometrics = 0x000001,
  nbtFace = 0x000002,
  nbtFacialFeatures = nbtFace,
  nbtVoice = 0x000004,
  nbtFinger = 0x000008,
  nbtFingerprint = nbtFinger,
  nbtIris = 0x000010,
  nbtRetina = 0x000020,
  nbtHandGeometry = 0x000040,
  nbtSignatureOrSign = 0x000080,
  nbtSignatureDynamics = nbtSignatureOrSign,
  nbtKeystroke = 0x000100,
  nbtKeystrokeDynamics = nbtKeystroke,
  nbtLipMovement = 0x000200,
  nbtThermalFace = 0x000400,
  nbtThermalHand = 0x000800,
  nbtThermalFaceImage = nbtThermalFace,
  nbtThermalHandImage = nbtThermalHand,
  nbtGait = 0x001000,
  nbtScent = 0x002000,
  nbtBodyOdor = nbtScent,
  nbtDna = 0x004000,
  nbtEar = 0x008000,
  nbtEarShape = nbtEar,
  nbtFingerGeometry = 0x010000,
  nbtPalm = 0x020000,
  nbtPalmPrint = nbtPalm,
  nbtVein = 0x040000,
  nbtVeinPattern = nbtVein,
  nbtFoot = 0x080000,
  nbtFootPrint = nbtFoot,
  nbtPalmGeometry = 0x100000,
  nbtAll = 0x1FFFFF
} NBiometricType;
Collapse Expand Members
Members | Description
nbtNone = 0x000000 | Record does not contain data of any biometric type.
nbtMultipleBiometrics = 0x000001 | Indicates that record contain data of multiple biometric types.
nbtFace = 0x000002 | Indicates face data.
nbtFacialFeatures = nbtFace | Indicates that record contain facial features data.
nbtVoice = 0x000004 | Indicates voice data.
nbtFinger = 0x000008 | Indicates finger data.
nbtFingerprint = nbtFinger | Indicates fingerprint data.
nbtIris = 0x000010 | Indicates iris data.
nbtRetina = 0x000020 | Indicates retina data.
nbtHandGeometry = 0x000040 | Indicates hand geometry.
nbtSignatureOrSign = 0x000080 | Indicates signature or sign.
nbtSignatureDynamics = nbtSignatureOrSign | Indicates signature dynamics.
nbtKeystroke = 0x000100 | Indicates keystroke.
nbtKeystrokeDynamics = nbtKeystroke | Indicates keystroke dynamics.
nbtLipMovement = 0x000200 | Indicates lip movement.
nbtThermalFace = 0x000400 | Indicates thermal face.
nbtThermalHand = 0x000800 | Indicates thermal hand.
nbtThermalFaceImage = nbtThermalFace | Indicates thermal face image.
nbtThermalHandImage = nbtThermalHand | Indicates thermal hand image.
nbtGait = 0x001000 | Indicates gait.
nbtScent = 0x002000 | Indicates scent.
nbtBodyOdor = nbtScent | Indicates body odor.
nbtDna = 0x004000 | Indicates DNA.
nbtEar = 0x008000 | Indicates ear.
nbtEarShape = nbtEar | Indicates that record contains ear shape object.
nbtFingerGeometry = 0x010000 | Indicates finger geometry.
nbtPalm = 0x020000 | Indicates palm data.
nbtPalmPrint = nbtPalm | Indicates palmprint data.
nbtVein = 0x040000 | Indicates vein data.
nbtVeinPattern = nbtVein | Indicates vein pattern.
nbtFoot = 0x080000 | Indicates foot data.
nbtFootPrint = nbtFoot | Indicates footprint data.
nbtPalmGeometry = 0x100000 | Indicates palm geometry.
nbtAll = 0x1FFFFF | Indicates all biometric types.
Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NEImageType Enumeration

NEImageType Enumeration
NBiometricTypes.h

Enumerates iris image types.

C++
typedef enum NEImageType_ {
  neitUncropped = 1,
  neitVga = 2,
  neitCropped = 3,
  neitCroppedAndMasked = 7
} NEImageType;
Collapse Expand Members
Members | Description
neitUncropped = 1 | Indicates an uncropped image.
neitVga = 2 | Indicates a VGA image.
neitCropped = 3 | Indicates a cropped image.
neitCroppedAndMasked = 7 | Indicates a cropped and masked image.
Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NEPosition Enumeration

NEPosition Enumeration
NBiometricTypes.h

Enumerates eye position values.

C++
typedef enum NEPosition_ {
  nepUnknown = 0,
  nepRight = 1,
  nepLeft = 2,
  nepBoth = 3
} NEPosition;
Collapse Expand Members
Members | Description
nepUnknown = 0 | Unknown eye.
nepRight = 1 | Right eye.
nepLeft = 2 | Left eye.
nepBoth = 3 | Both eyes.
Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFImpressionType Enumeration

NFImpressionType Enumeration
NBiometricTypes.h

Specifies the impression type.

C++
typedef enum NFImpressionType_ {
  nfitLiveScanPlain = 0,
  nfitLiveScanRolled = 1,
  nfitNonliveScanPlain = 2,
  nfitNonliveScanRolled = 3,
  nfitLatentImpression = 4,
  nfitLatentTracing = 5,
  nfitLatentPhoto = 6,
  nfitLatentLift = 7,
  nfitLiveScanVerticalSwipe = 8,
  nfitSwipe = nfitLiveScanVerticalSwipe,
  nfitLiveScanContactless = 9,
  nfitLiveScanPalm = 10,
  nfitNonliveScanPalm = 11,
  nfitLatentPalmImpression = 12,
  nfitLatentPalmTracing = 13,
  nfitLatentPalmPhoto = 14,
  nfitLatentPalmLift = 15,
  nfitLiveScanOpticalContactPlain = 20,
  nfitLiveScanOpticalContactRolled = 21,
  nfitLiveScanNonOpticalContactPlain = 22,
  nfitLiveScanNonOpticalContactRolled = 23,
  nfitLiveScanOpticalContactlessPlain = 24,
  nfitLiveScanOpticalContactlessRolled = 25,
  nfitLiveScanNonOpticalContactlessPlain = 26,
  nfitLiveScanNonOpticalContactlessRolled = 27,
  nfitOther = 28,
  nfitUnknown = 29,
  nfitRolledContactlessMoving = 41,
  nfitPlainContactlessMoving = 42
} NFImpressionType;
Collapse Expand Members
Members | Description
nfitLiveScanPlain = 0 | Live-scanned plain fingerprint.
nfitLiveScanRolled = 1 | Live-scanned rolled fingerprint.
nfitNonliveScanPlain = 2 | Non-live-scanned (from paper) plain fingerprint.
nfitNonliveScanRolled = 3 | Non-live-scanned (from paper) rolled fingerprint.
nfitLatentImpression = 4 | Latent impression fingerprint.
nfitLatentTracing = 5 | Latent tracing fingerprint.
nfitLatentPhoto = 6 | Latent photo fingerprint.
nfitLatentLift = 7 | Latent lift fingerprint.
nfitLiveScanVerticalSwipe = 8 | Fingerprint live-scanned by a vertical swipe across the scanner.
nfitSwipe = nfitLiveScanVerticalSwipe | Live-scanned fingerprint by sliding the finger across a "swipe" sensor.
nfitLiveScanContactless = 9 | Live-scanned fingerprint using contactless device.
nfitLiveScanPalm = 10 | Live scanned palm.
nfitNonliveScanPalm = 11 | Non-live scanned palm.
nfitLatentPalmImpression = 12 | Latent palm impression.
nfitLatentPalmTracing = 13 | Latent palm tracing.
nfitLatentPalmPhoto = 14 | Latent palm photo.
nfitLatentPalmLift = 15 | Latent palm lift.
nfitLiveScanOpticalContactPlain = 20 | Live-scanned plain fingerprint using an optical contact device.
nfitLiveScanOpticalContactRolled = 21 | Live-scanned rolled fingerprint using an optical contact device.
nfitLiveScanNonOpticalContactPlain = 22 | Live-scanned plain fingerprint using a non-optical contact device.
nfitLiveScanNonOpticalContactRolled = 23 | Live-scanned rolled fingerprint using a non-optical contact device.
nfitLiveScanOpticalContactlessPlain = 24 | Live-scanned plain fingerprint using an optical contactless device.
nfitLiveScanOpticalContactlessRolled = 25 | Live-scanned rolled fingerprint using an optical contactless device.
nfitLiveScanNonOpticalContactlessPlain = 26 | Live-scanned plain fingerprint using a non-optical contactless device.
nfitLiveScanNonOpticalContactlessRolled = 27 | Live-scanned rolled fingerprint using a non-optical contactless device.
nfitOther = 28 | Other impression type.
nfitUnknown = 29 | Unknown impression type.
nfitRolledContactlessMoving = 41 |
nfitPlainContactlessMoving = 42 |
Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFPosition Enumeration

NFPosition Enumeration
NBiometricTypes.h

Specifies the finger position.

C++
typedef enum NFPosition_ {
  nfpUnknown = 0,
  nfpRightThumb = 1,
  nfpRightIndexFinger = 2,
  nfpRightIndex = nfpRightIndexFinger,
  nfpRightMiddleFinger = 3,
  nfpRightMiddle = nfpRightMiddleFinger,
  nfpRightRingFinger = 4,
  nfpRightRing = nfpRightRingFinger,
  nfpRightLittleFinger = 5,
  nfpRightLittle = nfpRightLittleFinger,
  nfpLeftThumb = 6,
  nfpLeftIndexFinger = 7,
  nfpLeftIndex = nfpLeftIndexFinger,
  nfpLeftMiddleFinger = 8,
  nfpLeftMiddle = nfpLeftMiddleFinger,
  nfpLeftRingFinger = 9,
  nfpLeftRing = nfpLeftRingFinger,
  nfpLeftLittleFinger = 10,
  nfpLeftLittle = nfpLeftLittleFinger,
  nfpPlainRightThumb = 11,
  nfpPlainLeftThumb = 12,
  nfpPlainRightFourFingers = 13,
  nfpPlainLeftFourFingers = 14,
  nfpPlainThumbs = 15,
  nfpUnknownPalm = 20,
  nfpRightFullPalm = 21,
  nfpRightWritersPalm = 22,
  nfpLeftFullPalm = 23,
  nfpLeftWritersPalm = 24,
  nfpRightLowerPalm = 25,
  nfpRightUpperPalm = 26,
  nfpLeftLowerPalm = 27,
  nfpLeftUpperPalm = 28,
  nfpRightOther = 29,
  nfpLeftOther = 30,
  nfpRightInterdigital = 31,
  nfpRightThenar = 32,
  nfpRightHypothenar = 33,
  nfpLeftInterdigital = 34,
  nfpLeftThenar = 35,
  nfpLeftHypothenar = 36,
  nfpRightIndexMiddleFingers = 40,
  nfpRightMiddleRingFingers = 41,
  nfpRightRingLittleFingers = 42,
  nfpLeftIndexMiddleFingers = 43,
  nfpLeftMiddleRingFingers = 44,
  nfpLeftRingLittleFingers = 45,
  nfpRightIndexLeftIndexFingers = 46,
  nfpRightIndexMiddleRingFingers = 47,
  nfpRightMiddleRingLittleFingers = 48,
  nfpLeftIndexMiddleRingFingers = 49,
  nfpLeftMiddleRingLittleFingers = 50,
  nfpUnknownTwoFingers = -2,
  nfpUnknownThreeFingers = -3,
  nfpUnknownFourFingers = -4
} NFPosition;
Collapse Expand Members
Members | Description
nfpUnknown = 0 | Unknown finger.
nfpRightThumb = 1 | Thumb of the right hand.
nfpRightIndexFinger = 2 | Index finger of the right hand.
nfpRightIndex = nfpRightIndexFinger | Index finger of the right hand.
nfpRightMiddleFinger = 3 | Middle finger of the right hand.
nfpRightMiddle = nfpRightMiddleFinger | Middle finger of the right hand.
nfpRightRingFinger = 4 | Ring finger of the right hand.
nfpRightRing = nfpRightRingFinger | Ring finger of the right hand.
nfpRightLittleFinger = 5 | Little finger of the right hand.
nfpRightLittle = nfpRightLittleFinger | Little finger of the right hand.
nfpLeftThumb = 6 | Thumb of the left hand.
nfpLeftIndexFinger = 7 | Index finger of the left hand.
nfpLeftIndex = nfpLeftIndexFinger | Index finger of the left hand.
nfpLeftMiddleFinger = 8 | Middle finger of the left hand.
nfpLeftMiddle = nfpLeftMiddleFinger | Middle finger of the left hand.
nfpLeftRingFinger = 9 | Little finger of the left hand.
nfpLeftRing = nfpLeftRingFinger | Ring finger of the left hand.
nfpLeftLittleFinger = 10 | Little finger of the left hand.
nfpLeftLittle = nfpLeftLittleFinger | Little finger of the left hand.
nfpPlainRightThumb = 11 | Specifies plain right thumb.
nfpPlainLeftThumb = 12 | Specifies leftplain thumb.
nfpPlainRightFourFingers = 13 | Specifies plain right four fingers.
nfpPlainLeftFourFingers = 14 | Specifies left four fingers.
nfpPlainThumbs = 15 | Specifies plain thumbs.
nfpUnknownPalm = 20 | Specifies unknown palm.
nfpRightFullPalm = 21 | Specifies right full palm.
nfpRightWritersPalm = 22 | Specifies right writers palm.
nfpLeftFullPalm = 23 | Specifies full left palm.
nfpLeftWritersPalm = 24 | Specifies left writers palm.
nfpRightLowerPalm = 25 | Specifies right lower palm.
nfpRightUpperPalm = 26 | Specifies right upper palm.
nfpLeftLowerPalm = 27 | Specifies lower palm.
nfpLeftUpperPalm = 28 | Specifies left upper palm.
nfpRightOther = 29 | Unknown finger of the right arm .
nfpLeftOther = 30 | Unknown finger of the left arm .
nfpRightInterdigital = 31 | Specifies right interdigital.
nfpRightThenar = 32 | Specifies right thenar.
nfpRightHypothenar = 33 | Specifies right hypothenar.
nfpLeftInterdigital = 34 | Specifies left interdigital.
nfpLeftThenar = 35 | Specifies left thenar.
nfpLeftHypothenar = 36 | Specifies left hypothenar.
nfpRightIndexMiddleFingers = 40 | Index and middle fingers of the right hand.
nfpRightMiddleRingFingers = 41 | Middle and ring fingers of the right hand.
nfpRightRingLittleFingers = 42 | Ring and little fingers of the right hand.
nfpLeftIndexMiddleFingers = 43 | Index and middle fingers of the left hand.
nfpLeftMiddleRingFingers = 44 | Middle and ring fingers of the left hand.
nfpLeftRingLittleFingers = 45 | Ring and little fingers of the left hand.
nfpRightIndexLeftIndexFingers = 46 | Index fingers of the right and left hands.
nfpRightIndexMiddleRingFingers = 47 | Index, middle and ring fingers of the right hand.
nfpRightMiddleRingLittleFingers = 48 | Middle, ring and little fingers of the right hand.
nfpLeftIndexMiddleRingFingers = 49 | Index, middle and ring fingers of the left hand.
nfpLeftMiddleRingLittleFingers = 50 | Middle, ring and little fingers of the left hand.
nfpUnknownTwoFingers = -2 | Unknown two fingers.
nfpUnknownThreeFingers = -3 | Unknown three fingers.
nfpUnknownFourFingers = -4 | Unknown four fingers.
Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NGender Enumeration

NGender Enumeration
NBiometricTypes.h

Specifies the gender.

C++
typedef enum NGender_ {
  ngUnspecified = 0,
  ngMale = 1,
  ngFemale = 2,
  ngUnknown = 255
} NGender;
Collapse Expand Members
Members | Description
ngUnspecified = 0 | Unspecified gender.
ngMale = 1 | Male.
ngFemale = 2 | Female.
ngUnknown = 255 | Unknown gender.
Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NIcaoWarnings Enumeration

NIcaoWarnings Enumeration
NBiometricTypes.h

Enumerates face Icao check warnings constants.

C++
typedef enum NIcaoWarnings_ {
  niwNone = 0,
  niwFaceNotDetected = 1,
  niwRollLeft = 2,
  niwRollRight = 4,
  niwYawLeft = 8,
  niwYawRight = 16,
  niwPitchUp = 32,
  niwPitchDown = 64,
  niwTooNear = 128,
  niwTooFar = 256,
  niwTooNorth = 512,
  niwTooSouth = 1024,
  niwTooEast = 2048,
  niwTooWest = 4096,
  niwSharpness = 8192,
  niwBackgroundUniformity = 16384,
  niwGrayscaleDensity = 32768,
  niwSaturation = 65536,
  niwExpression = 131072,
  niwDarkGlasses = 262144,
  niwBlink = 524288,
  niwMouthOpen = 1048576,
  niwLookingAway = 2097152,
  niwRedEye = 4194304,
  niwFaceDarkness = 8388608,
  niwUnnaturalSkinTone = 16777216,
  niwWashedOut = 33554432,
  niwPixelation = 67108864,
  niwSkinReflection = 134217728,
  niwGlassesReflection = 268435456,
  niwHeavyFrame = 536870912
} NIcaoWarnings;
Collapse Expand Members
Members | Description
niwNone = 0 | None warnings.
niwFaceNotDetected = 1 | Indicates that was was not detected.
niwRollLeft = 2 | Indicates face roll left.
niwRollRight = 4 | Indicates face roll right.
niwYawLeft = 8 | Indicates face yaw left warning.
niwYawRight = 16 | Indicates face yaw right warning.
niwPitchUp = 32 | Indicates pitch up.
niwPitchDown = 64 | Indicates pitch down.
niwTooNear = 128 | Indicates that face is too near.
niwTooFar = 256 | Indicates that face is too far.
niwTooNorth = 512 | Indicates that face is too north.
niwTooSouth = 1024 | Indicates that face is too south.
niwTooEast = 2048 | Indicates that face is too east.
niwTooWest = 4096 | Indicates that face is too west.
niwSharpness = 8192 | Indicates sharpness warning.
niwBackgroundUniformity = 16384 | Indicates background uniformity.
niwGrayscaleDensity = 32768 | Indicates grayscale density.
niwSaturation = 65536 | Indicates saturation warning.
niwExpression = 131072 | Indicates face expression.
niwDarkGlasses = 262144 | Indicates that dark glasses detected.
niwBlink = 524288 | Indicates blink of eye.
niwMouthOpen = 1048576 | Indicates mouth is opened.
niwLookingAway = 2097152 | Indicates that face is looking away.
niwRedEye = 4194304 | Indicates red eye.
niwFaceDarkness = 8388608 | Indicates that face is dark.
niwUnnaturalSkinTone = 16777216 | Indicates that skin tone is unnatural.
niwWashedOut = 33554432 | Indicates a washed out face.
niwPixelation = 67108864 | Indicates that due to pixelation pixels are visible in an image.
niwSkinReflection = 134217728 | Indicates that skin reflection was detected.
niwGlassesReflection = 268435456 | Indicates that a reflection on glasses was detected.
niwHeavyFrame = 536870912 | Indicates that glasses have a thick frame.
Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NLExpression Enumeration

NLExpression Enumeration
NBiometricTypes.h

Specifies the facial expression.

C++
typedef enum NLExpression_ {
  nleUnspecified = 0,
  nleNeutral = 1,
  nleSmile = 2,
  nleSmileOpenedJaw = 3,
  nleRaisedBrows = 4,
  nleEyesAway = 5,
  nleSquinting = 6,
  nleFrowning = 7,
  nleUnknown = 0xFFFF
} NLExpression;
Collapse Expand Members
Members | Description
nleUnspecified = 0 | Unspecified expression.
nleNeutral = 1 | Neutral expression.
nleSmile = 2 | Smiling.
nleSmileOpenedJaw = 3 | Smiling with jaw open.
nleRaisedBrows = 4 | Eyebrows raised.
nleEyesAway = 5 | Eyes looking away.
nleSquinting = 6 | Squinting.
nleFrowning = 7 | Frowning.
nleUnknown = 0xFFFF | Unknown expression.
Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NLProperties Enumeration

NLProperties Enumeration
NBiometricTypes.h

Specified the facial properties.

C++
typedef enum NLProperties_ {
  nlpNotSpecified = 0,
  nlpSpecified = 0x000001,
  nlpGlasses = 0x000002,
  nlpMustache = 0x000004,
  nlpBeard = 0x000008,
  nlpTeethVisible = 0x000010,
  nlpBlink = 0x000020,
  nlpMouthOpen = 0x000040,
  nlpLeftEyePatch = 0x000080,
  nlpRightEyePatch = 0x000100,
  nlpBothEyePatch = 0x000200,
  nlpDarkGlasses = 0x000400,
  nlpDistortingCondition = 0x000800,
  nlpHat = 0x01000000,
  nlpScarf = 0x02000000,
  nlpNoEar = 0x04000000,
  nlpFaceMask = 0x08000000,
  nlpHeavyFrame = 0x10000000
} NLProperties;
Collapse Expand Members
Members | Description
nlpNotSpecified = 0 | Face properties not specified.
nlpSpecified = 0x000001 | Face properties specified. *
nlpGlasses = 0x000002 | Wearing glasses.
nlpMustache = 0x000004 | Moustache. *
nlpBeard = 0x000008 | Beard. *
nlpTeethVisible = 0x000010 | Teeth are visible. *
nlpBlink = 0x000020 | Eye blink.
nlpMouthOpen = 0x000040 | Mouth is open.
nlpLeftEyePatch = 0x000080 | Patch on left eye. *
nlpRightEyePatch = 0x000100 | Patch on right eye. *
nlpBothEyePatch = 0x000200 | Patch on both eyes. *
nlpDarkGlasses = 0x000400 | Wearing dark glasses.
nlpDistortingCondition = 0x000800 | Distorting conditions. *
nlpHat = 0x01000000 | Wearing a hat.
nlpScarf = 0x02000000 | Wearing a scarf. *
nlpNoEar = 0x04000000 | One ear missing. *
nlpFaceMask = 0x08000000 | Wearing a face mask.
nlpHeavyFrame = 0x10000000 | Wearing glasses with heavy frame.
Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NLivenessAction Enumeration

NLivenessAction Enumeration
NBiometricTypes.h

Enumerates face liveness challenge action constants.

C++
typedef enum NLivenessAction_ {
  nlaNone = 0,
  nlaKeepStill = 0x000001,
  nlaBlink = 0x000002,
  nlaRotateYaw = 0x000004,
  nlaKeepRotatingYaw = 0x000008,
  nlaTurnToCenter = 0x000010,
  nlaTurnLeft = 0x000020,
  nlaTurnRight = 0x000040,
  nlaTurnUp = 0x000080,
  nlaTurnDown = 0x000100,
  nlaMoveCloser = 0x000200,
  nlaMoveBack = 0x000400
} NLivenessAction;
Collapse Expand Members
Members | Description
nlaNone = 0 | No actions are required from the user.
nlaKeepStill = 0x000001 | The user should keep as still as possible.
nlaBlink = 0x000002 | The user should blink at least once.
nlaRotateYaw = 0x000004 | The user should rotate his face according to instructions.
nlaKeepRotatingYaw = 0x000008 | The user should keep turning face from side to side.
nlaTurnToCenter = 0x000010 | The user should center out his face.
nlaTurnLeft = 0x000020 | The user should turn his face left.
nlaTurnRight = 0x000040 | The user should turn his face right.
nlaTurnUp = 0x000080 | The user should turn his face up.
nlaTurnDown = 0x000100 | The user should turn his face down.
nlaMoveCloser = 0x000200 | The user should move his face closer to camera.
nlaMoveBack = 0x000400 | The user should move his face further away from camera.
Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NLivenessMode Enumeration

NLivenessMode Enumeration
NBiometricTypes.h

Enumerates face liveness mode constants.

C++
typedef enum NLivenessMode_ {
  nlmNone = 0,
  nlmPassive = 1,
  nlmActive = 2,
  nlmPassiveAndActive = 3,
  nlmSimple = 4,
  nlmCustom = 5,
  nlmPassiveWithBlink = 6
} NLivenessMode;
Collapse Expand Members
Members | Description
nlmNone = 0 | No liveness check is performed.
nlmPassive = 1 | User should passively stand still in front of the camera. It takes several seconds to measure the liveness signal.
nlmActive = 2 | User should perform several actions to prove his liveness.
nlmPassiveAndActive = 3 | A sequence of passive and active liveness detection modes. Active mode is used only if passive mode fails.
nlmSimple = 4 | User should turn his head left and right to prove his liveness.
nlmCustom = 5 | Customizable liveness action sequence. By default requires user to turn his head according to instructions.
nlmPassiveWithBlink = 6 |
Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NfiqQuality Enumeration

NfiqQuality Enumeration
NBiometricTypes.h

Specifies the quality of a fingerprint image.

C++
typedef enum NfiqQuality_ {
  nfqPoor = 5,
  nfqFair = 4,
  nfqGood = 3,
  nfqVeryGood = 2,
  nfqExcellent = 1,
  nfqUnknown = 0
} NfiqQuality;
Collapse Expand Members
Members | Description
nfqPoor = 5 | Poor fingerprint image quality.
nfqFair = 4 | Fair fingerprint image quality.
nfqGood = 3 | Good fingerprint image quality.
nfqVeryGood = 2 | Very good fingerprint image quality.
nfqExcellent = 1 | Excellent fingerprint image quality.
nfqUnknown = 0 | Unknown fingerprint image quality.
Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NBiometricQualityBlock Type

NBiometricQualityBlock Type
NBiometricTypes.h

Represents the biometric quality block.

C++
typedef struct NBiometricQualityBlock_ NBiometricQualityBlock;
Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NLFeaturePoint Type

NLFeaturePoint Type
NBiometricTypes.h

Represents a facial feature point in a NLRecord.

C++
typedef struct NLFeaturePoint_ NLFeaturePoint;
Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NBiometricAngleToString Macro

NBiometricAngleToString Macro
NBiometricTypes.h

Picks a Unicode (W) or ANSCII (A) version of the NBiometricAngleToString function.

C++
#define NBiometricAngleToString N_FUNC_AW(NBiometricAngleToString)
Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NBiometricQualityBlockToString Macro

NBiometricQualityBlockToString Macro
NBiometricTypes.h

Picks a Unicode (W) or ANSCII (A) version of the NBiometricQualityBlockToString function.

C++
#define NBiometricQualityBlockToString N_FUNC_AW(NBiometricQualityBlockToString)
Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NBiometricQualityToString Macro

NBiometricQualityToString Macro
NBiometricTypes.h

Picks a Unicode (W) or ANSCII (A) version of the NBiometricQualityToString function.

C++
#define NBiometricQualityToString N_FUNC_AW(NBiometricQualityToString)
Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFCoreToString Macro

NFCoreToString Macro
NBiometricTypes.h

Picks a Unicode (W) or ANSCII (A) version of the NFCoreToString function.

C++
#define NFCoreToString N_FUNC_AW(NFCoreToString)
Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFDeltaToString Macro

NFDeltaToString Macro
NBiometricTypes.h

Picks a Unicode (W) or ANSCII (A) version of the NFDeltaToString function.

C++
#define NFDeltaToString N_FUNC_AW(NFDeltaToString)
Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFDoubleCoreToString Macro

NFDoubleCoreToString Macro
NBiometricTypes.h

Picks a Unicode (W) or ANSCII (A) version of the NFDoubleCoreToString function.

C++
#define NFDoubleCoreToString N_FUNC_AW(NFDoubleCoreToString)
Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFMinutiaNeighborToString Macro

NFMinutiaNeighborToString Macro
NBiometricTypes.h

Picks a Unicode (W) or ANSCII (A) version of the NFMinutiaNeighborToString function.

C++
#define NFMinutiaNeighborToString N_FUNC_AW(NFMinutiaNeighborToString)
Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NFMinutiaToString Macro

NFMinutiaToString Macro
NBiometricTypes.h

Picks a Unicode (W) or ANSCII (A) version of the NFMinutiaToString function.

C++
#define NFMinutiaToString N_FUNC_AW(NFMinutiaToString)
Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NLFeaturePointToString Macro

NLFeaturePointToString Macro
NBiometricTypes.h

Picks a Unicode (W) or ANSCII (A) version of the NLFeaturePointToString function.

C++
#define NLFeaturePointToString N_FUNC_AW(NLFeaturePointToString)
Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


N_BIOMETRIC_QUALITY_FAILED Macro

N_BIOMETRIC_QUALITY_FAILED Macro
NBiometricTypes.h

Failed or unspecified quality.

C++
#define N_BIOMETRIC_QUALITY_FAILED 255
Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


N_BIOMETRIC_QUALITY_MAX Macro

N_BIOMETRIC_QUALITY_MAX Macro
NBiometricTypes.h

Maximal quality.

C++
#define N_BIOMETRIC_QUALITY_MAX 100
Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


N_BIOMETRIC_QUALITY_MIN Macro

N_BIOMETRIC_QUALITY_MIN Macro
NBiometricTypes.h

Minimal quality.

C++
#define N_BIOMETRIC_QUALITY_MIN 0
Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


N_BIOMETRIC_QUALITY_UNKNOWN Macro

N_BIOMETRIC_QUALITY_UNKNOWN Macro
NBiometricTypes.h

Unknown quality.

C++
#define N_BIOMETRIC_QUALITY_UNKNOWN 254
Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


N_PHRASE_ID_UNKNOWN Macro

N_PHRASE_ID_UNKNOWN Macro
NBiometricTypes.h

Unknown phrase ID.

C++
#define N_PHRASE_ID_UNKNOWN 0
Container

File: NBiometricTypes.h

Module: NBiometricTypes Unit


NBiometricTypes.h

NBiometricTypes.h
Enumerations Functions Legend Macros Structures Types

Header file for NBiometricType module.

Collapse Expand Enumerations
Name | Description
NBiometricStatus_ | Enumerates biometric status values. These values are returned by NBiometricDevice.
NBiometricSubtype_ | Enumerates values which define the type of biometric data in the record. The values in this enumeration more specifically define the type of biometric data (NBiometricType) in the record.
NBiometricType_ | Enumerates types of biometric technology used in a record.
NEImageType_ | Enumerates iris image types.
NEPosition_ | Enumerates eye position values.
NFImpressionType_ | Specifies the impression type.
NFPosition_ | Specifies the finger position.
NGender_ | Specifies the gender.
NIcaoWarnings_ | Enumerates face Icao check warnings constants.
NLExpression_ | Specifies the facial expression.
NLProperties_ | Specified the facial properties.
NLivenessAction_ | Enumerates face liveness challenge action constants.
NLivenessMode_ | Enumerates face liveness mode constants.
NfiqQuality_ | Specifies the quality of a fingerprint image.
NBiometricStatus | Enumerates biometric status values. These values are returned by NBiometricDevice.
NBiometricSubtype | Enumerates values which define the type of biometric data in the record. The values in this enumeration more specifically define the type of biometric data (NBiometricType) in the record.
NBiometricType | Enumerates types of biometric technology used in a record.
NEImageType | Enumerates iris image types.
NEPosition | Enumerates eye position values.
NFImpressionType | Specifies the impression type.
NFPosition | Specifies the finger position.
NGender | Specifies the gender.
NIcaoWarnings | Enumerates face Icao check warnings constants.
NLExpression | Specifies the facial expression.
NLProperties | Specified the facial properties.
NLivenessAction | Enumerates face liveness challenge action constants.
NLivenessMode | Enumerates face liveness mode constants.
NfiqQuality | Specifies the quality of a fingerprint image.
Collapse Expand Functions
Name | Description
NBiometricAngleFromDegrees | Converts the specified angle from degrees to radians.
NBiometricAngleFromRadians | Converts the specified angle from radians to degrees.
NBiometricAngleToDegrees | Converts the specified angle from radians to degrees.
NBiometricAngleToRadians | Converts the specified angle from degrees to radians.
NBiometricAngleToString | Gets a string representation of the specified angle.
NBiometricNfiq1ToNfiqQuality | Converts specified NFIQ 1.0 (NIST Fingerprint Image Quality) value to NfiqQuality value.
NBiometricNfiqQualityToNfiq1 | Converts specified NfiqQuality value to NFIQ 1.0 (NIST Fingerprint Image Quality) value.
NBiometricQualityBlockIsValid | Checks if specified NBiometricQualityBlock is valid.
NBiometricQualityBlockToString | Gets a string representation of the specified quality block.
NBiometricQualityIsValid | Checks whether the specified quality is valid.
NBiometricQualityToString | Gets a string representation of the specified quality.
NBiometricStatusIsFinal | Checks if the value passed as a parameter is denotes completed biometric operation rather then intermediate status of operation in progress.
NBiometricStatusIsValid | Checks if the value passed as a parameter is defined in NBiometricStatus.
NBiometricSubtypeIsValid | Checks if the value passed as a parameter is a valid NBiometricSubtype value.
NBiometricTypeIsValid | Checks if the value passed as a parameter is a valid NBiometricType value.
NEPositionGetAvailableParts | Determines available iris positions based on specified missing iris positions and base position.
NEPositionIsKnown | Checks whether the specified position is known.
NEPositionIsLeft | Checks whether the specified position is left.
NEPositionIsOneOf | Checks if specified NEPosition value matches one in an array.
NEPositionIsRight | Checks whether the specified position is right.
NEPositionIsRightAndLeft | Checks whether the specified position is both left and right.
NEPositionIsSingleEye | Checks whether the specified position represents a single eye.
NEPositionIsTheEye | Checks whether the specified position represents a separate eye.
NEPositionIsTwoEyes | Checks whether the specified position represents two eyes.
NEPositionIsValid | Checks if the value passed as a parameter is a valid NEPosition value.
NEPositionIsValidTheEye | Checks if the specified value is a valid NEPosition value.
NFCoreToString | Gets a string representation of the core.
NFDeltaToString | Gets a string representation of the delta.
NFDoubleCoreToString | Gets a string representation of the double core.
NFImpressionTypeIsCompatibleWith | Checks if two specified values are compatible.
NFImpressionTypeIsContact | ... more
NFImpressionTypeIsContactless | ... more
NFImpressionTypeIsFinger | Checks whether the specified value is fingerprint.
NFImpressionTypeIsGeneric | Checks whether the specified impression type is generic.
NFImpressionTypeIsLatent | Checks if the specified value is latent fingerprint or palmprint.
NFImpressionTypeIsLiveScan | Checks if the specified value is a live scan.
NFImpressionTypeIsNonOptical | ... more
NFImpressionTypeIsNonliveScan | Checks if the specified value is a non-live scan.
NFImpressionTypeIsOneOf | Checks if specified NFImpressionType value matches one in an array.
NFImpressionTypeIsOptical | ... more
NFImpressionTypeIsPalm | Checks if the specified value is a palmprint.
NFImpressionTypeIsPlain | Checks if the specified value is a plain scan or optical contact/contactless.
NFImpressionTypeIsRolled | Checks if the specified value is one of rolled biometric types.
NFImpressionTypeIsSwipe | ... more
NFImpressionTypeIsValid | Checks if the value passed as a parameter is a valid NFImpressionType value.
NFImpressionTypeIsValidFinger | Checks if the specified value is a valid fingerprint.
NFImpressionTypeIsValidPalm | Checks if the specified value is a valid palmprint.
NFImpressionTypeToFinger | Converts an impression type object into finger impression type object.
NFMinutiaNeighborToString | Gets a string representation of the minutia neighbor.
NFMinutiaToString | Gets a string representation of the minutia.
NFPatternClassIsValid | Checks whether a fingerprint pattern class is valid.
NFPatternClassIsValidForPosition | Checks whether a fingerprint pattern class is valid for the specified position.
NFPositionGetAvailableParts | Determines available finger positions based on specified missing finger positions and base position.
NFPositionIsCompatibleWith | Checks if two specified values are compatible.
NFPositionIsCompatibleWithImpressionType | Checks whether the specified position is compatible with the specified impression type.
NFPositionIsFinger | Checks if the specified value is fingerprint.
NFPositionIsFourFingers | Checks if the specified value is a type of 4 fingerprints data.
NFPositionIsKnown | ... more
NFPositionIsLeft | Checks if the specified position is left fingerprint.
NFPositionIsLeftAndRight | Checks if the specified position is left and right fingerprint.
NFPositionIsOneOf | Checks if specified NFPosition value matches one in an array.
NFPositionIsPalm | Checks if the specified value is a palmprint.
NFPositionIsRight | Checks if the specified position is right fingerprint.
NFPositionIsSingleFinger | Checks if the specified value is a single fingerprint.
NFPositionIsTheFinger | Checks if the specified value is the fingerprint.
NFPositionIsThePalm | Checks whether the specified position represents a separate palm.
NFPositionIsThreeFingers | Checks if the specified value is a type of 3 fingerprints data.
NFPositionIsTwoFingers | Checks if the specified value is a type of 2 fingerprints data.
NFPositionIsValid | Checks if the value passed as a parameter is a valid NFPosition value.
NFPositionIsValidFinger | Checks if the specified value is a valid fingerprint.
NFPositionIsValidPalm | Checks if the specified value is a valid palmprint.
NFPositionIsValidTheFinger | Checks if the specified value is a valid fingerprint.
NLFeaturePointToString | Gets a string representation of the feature point.
NfiqQualityIsValid | Checks whether a fingerprint quality value is valid.
Collapse Expand Macros
Name | Description
NBiometricAngleToString | Picks a Unicode (W) or ANSCII (A) version of the NBiometricAngleToString function.
NBiometricQualityBlockToString | Picks a Unicode (W) or ANSCII (A) version of the NBiometricQualityBlockToString function.
NBiometricQualityToString | Picks a Unicode (W) or ANSCII (A) version of the NBiometricQualityToString function.
NFCoreToString | Picks a Unicode (W) or ANSCII (A) version of the NFCoreToString function.
NFDeltaToString | Picks a Unicode (W) or ANSCII (A) version of the NFDeltaToString function.
NFDoubleCoreToString | Picks a Unicode (W) or ANSCII (A) version of the NFDoubleCoreToString function.
NFMinutiaNeighborToString | Picks a Unicode (W) or ANSCII (A) version of the NFMinutiaNeighborToString function.
NFMinutiaToString | Picks a Unicode (W) or ANSCII (A) version of the NFMinutiaToString function.
NLFeaturePointToString | Picks a Unicode (W) or ANSCII (A) version of the NLFeaturePointToString function.
N_BIOMETRIC_QUALITY_FAILED | Failed or unspecified quality.
N_BIOMETRIC_QUALITY_MAX | Maximal quality.
N_BIOMETRIC_QUALITY_MIN | Minimal quality.
N_BIOMETRIC_QUALITY_UNKNOWN | Unknown quality.
N_PHRASE_ID_UNKNOWN | Unknown phrase ID.
Collapse Expand Structures
Name | Description
NBiometricQualityBlock_ | Enumerates a biometric quality block values.
NLFeaturePoint_ | ... more
Collapse Expand Types
Name | Description
NBiometricQualityBlock | Represents the biometric quality block.
NLFeaturePoint | Represents a facial feature point in a NLRecord.


NFace Unit

NFace Unit
Files Functions Legend

Provides functions for biometric engine to deal with face templates.

Collapse Expand Files
Name | Description
NFace.h | Header file for the NFace unit.
Collapse Expand Functions
Name | Description
NFaceAddObjectsCollectionChanged | Adds user specified callback for "objects collection changed" event.
NFaceAddObjectsCollectionChangedCallback | Adds user specified callback for "objects collection changed" event.
NFaceCreate | Creates a new NFace object.
NFaceFromImageAndAttributes | Creates a new NFace object from face image and attributes.
NFaceGetImage | Retrieves the face image of the specified NFace object.
NFaceGetObject | Retrieves the specified NLAttributes object for the specified NFace object.
NFaceGetObjectCount | Retrieves the number of NLAttribute objects in the specified NFace object.
NFaceGetObjects | Retrieves all NLAttributes objects from the specified NFace object.
NFaceRemoveObjectsCollectionChanged | Removes user specified callback for "objects collection changed" event.
NFaceRemoveObjectsCollectionChangedCallback | Removes user specified callback for "objects collection changed" event.
NFaceSetImage | Sets the face image for the specified NFace object.


NFaceAddObjectsCollectionChanged Function

NFaceAddObjectsCollectionChanged Function
NFace.h

Adds user specified callback for "objects collection changed" event.

C++
NResult N_API NFaceAddObjectsCollectionChanged(HNFace hFace, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNFace hFace | [in] Handle to the NFace object.
HNCallback hCallback | [in] Pointer to user defined function (callback).
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NFace.h

Module: NFace Unit


NFaceAddObjectsCollectionChangedCallback Function

NFaceAddObjectsCollectionChangedCallback Function
NFace.h

Adds user specified callback for "objects collection changed" event.

C++
NResult N_API NFaceAddObjectsCollectionChangedCallback(HNFace hFace, N_COLLECTION_CHANGED_CALLBACK_ARG(HNLAttributes, pCallback), void * pParam);
Collapse Expand Parameters
Parameters | Description
HNFace hFace | [in] Handle to the NFace object.
void * pParam | [in] User data used by a callback function.
_nt_ | [in] Callback arguments.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NFace.h

Module: NFace Unit


NFaceCreate Function

NFaceCreate Function
NFace.h

Creates a new NFace object.

C++
NResult N_API NFaceCreate(HNFace * phFace);
Collapse Expand Parameters
Parameters | Description
HNFace * phFace | [out] Pointer to a handle to the NFace object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NFace.h

Module: NFace Unit


NFaceFromImageAndAttributes Function

NFaceFromImageAndAttributes Function
NFace.h

Creates a new NFace object from face image and attributes.

C++
NResult N_API NFaceFromImageAndAttributes(HNImage hImage, HNLAttributes hAttributes, HNFace * phFace);
Collapse Expand Parameters
Parameters | Description
HNImage hImage | [in] Handle to face image.
HNLAttributes hAttributes | [in] Face attributes.
HNFace * phFace | [out] Pointer to a handle to the NFace object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NFace.h

Module: NFace Unit


NFaceGetImage Function

NFaceGetImage Function
NFace.h

Retrieves the face image of the specified NFace object.

C++
NResult N_API NFaceGetImage(HNFace hFace, HNImage * phValue);
Collapse Expand Parameters
Parameters | Description
HNFace hFace | [in] Handle to the NFace object.
HNImage * phValue | [out] Pointer to a handle to the face image.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NFace.h

Module: NFace Unit


NFaceGetObject Function

NFaceGetObject Function
NFace.h

Retrieves the specified NLAttributes object for the specified NFace object.

C++
NResult N_API NFaceGetObject(HNFace hFace, NInt index, HNLAttributes * phValue);
Collapse Expand Parameters
Parameters | Description
HNFace hFace | [in] Handle to the NFace object.
NInt index | [in] Index of the object to be retrieved.
HNLAttributes * phValue | [out] Pointer to the NLAttributes object handle.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NFace.h

Module: NFace Unit


NFaceGetObjectCount Function

NFaceGetObjectCount Function
NFace.h

Retrieves the number of NLAttribute objects in the specified NFace object.

C++
NResult N_API NFaceGetObjectCount(HNFace hFace, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNFace hFace | [in] Handle to the NFace object.
NInt * pValue | [out] Pointer to the number of objects.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NFace.h

Module: NFace Unit


NFaceGetObjects Function

NFaceGetObjects Function
NFace.h

Retrieves all NLAttributes objects from the specified NFace object.

C++
NResult N_API NFaceGetObjects(HNFace hFace, HNLAttributes * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNFace hFace | [in] Handle to the NFace object.
HNLAttributes * * parhValues | [out] Pointer to an array of NLAttributes object handles.
NInt * pValueCount | [out] Pointer to the number of objects in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NFace.h

Module: NFace Unit


NFaceRemoveObjectsCollectionChanged Function

NFaceRemoveObjectsCollectionChanged Function
NFace.h

Removes user specified callback for "objects collection changed" event.

C++
NResult N_API NFaceRemoveObjectsCollectionChanged(HNFace hFace, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNFace hFace | [in] Handle to the NFace object.
HNCallback hCallback | [in] Pointer to user defined function (callback).
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NFace.h

Module: NFace Unit


NFaceRemoveObjectsCollectionChangedCallback Function

NFaceRemoveObjectsCollectionChangedCallback Function
NFace.h

Removes user specified callback for "objects collection changed" event.

C++
NResult N_API NFaceRemoveObjectsCollectionChangedCallback(HNFace hFace, N_COLLECTION_CHANGED_CALLBACK_ARG(HNLAttributes, pCallback), void * pParam);
Collapse Expand Parameters
Parameters | Description
HNFace hFace | [in] Handle to the NFace object.
void * pParam | [in] User data used by a callback function.
_nt_ | [in] Callback arguments.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NFace.h

Module: NFace Unit


NFaceSetImage Function

NFaceSetImage Function
NFace.h

Sets the face image for the specified NFace object.

C++
NResult N_API NFaceSetImage(HNFace hFace, HNImage hValue);
Collapse Expand Parameters
Parameters | Description
HNFace hFace | [in] Handle to the NFace object.
HNImage hValue | [in] Handle to the face image.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NFace.h

Module: NFace Unit


NFace.h

NFace.h
Functions Legend

Header file for the NFace unit.

Collapse Expand Functions
Name | Description
NFaceAddObjectsCollectionChanged | Adds user specified callback for "objects collection changed" event.
NFaceAddObjectsCollectionChangedCallback | Adds user specified callback for "objects collection changed" event.
NFaceCreate | Creates a new NFace object.
NFaceFromImageAndAttributes | Creates a new NFace object from face image and attributes.
NFaceGetImage | Retrieves the face image of the specified NFace object.
NFaceGetObject | Retrieves the specified NLAttributes object for the specified NFace object.
NFaceGetObjectCount | Retrieves the number of NLAttribute objects in the specified NFace object.
NFaceGetObjects | Retrieves all NLAttributes objects from the specified NFace object.
NFaceRemoveObjectsCollectionChanged | Removes user specified callback for "objects collection changed" event.
NFaceRemoveObjectsCollectionChangedCallback | Removes user specified callback for "objects collection changed" event.
NFaceSetImage | Sets the face image for the specified NFace object.


NLAttributes Unit

NLAttributes Unit
Files Functions Legend

Provides functions to retrieve face attributes (metadata which is not saved in face template).

Collapse Expand Notes

Many functions in this unit operate with feature points.

X, Y and Z axes are shown in the picture below:

Collapse Expand Files
Name | Description
NLAttributes.h | ... more
Collapse Expand Functions
Name | Description
NLAttributesAddFeaturePoint | Adds a feature point to the specified NLAttributes.
NLAttributesClearFeaturePoints | Removes all feature points from the specified NLAttributes.
NLAttributesCreate | Creates NLAttributes.
NLAttributesGetAdditionalFacesDetected | Gets if any additional faces were detected.
NLAttributesGetAge | Gets age value.
NLAttributesGetBackgroundUniformity | Retrieves the background uniformity value of the specified NLAttributes.
NLAttributesGetBaseFrameIndex | Gets the base frame index of the specified NLAttributes.
NLAttributesGetBeardConfidence | Gets the beard confidence value.
NLAttributesGetBlinkConfidence | Retrieves the blink confidence value of the specified NLAttributes.
NLAttributesGetBoundingRect | ... more
NLAttributesGetContrast | Gets contrast value.
NLAttributesGetDarkGlassesConfidence | Retrieves the dark glasses confidence value of the specified NLAttributes.
NLAttributesGetEmotionAngerConfidence | Retrieves anger confidence value of the specified NLAttributes.
NLAttributesGetEmotionContemptConfidence | Gets emotion contempt confidence value.
NLAttributesGetEmotionDisgustConfidence | Retrieves disgust confidence value of the specified NLAttributes.
NLAttributesGetEmotionFearConfidence | Retrieves fear confidence value of the specified NLAttributes.
NLAttributesGetEmotionHappinessConfidence | Retrieves happiness confidence value of the specified NLAttributes.
NLAttributesGetEmotionNeutralConfidence | Retrieves neutral emotion confidence value of the specified NLAttributes.
NLAttributesGetEmotionSadnessConfidence | Retrieves sadness confidence value of the specified NLAttributes.
NLAttributesGetEmotionSurpriseConfidence | Retrieves surprise confidence value of the specified NLAttributes.
NLAttributesGetEthnicityArabianConfidence | Gets the ethnicity Arabian confidence value.
NLAttributesGetEthnicityAsianConfidence | Gets the ethnicity Asian confidence value.
NLAttributesGetEthnicityBlackConfidence | Gets the ethnicity Black confidence value.
NLAttributesGetEthnicityHispanicConfidence | Gets the ethnicity Hispanic confidence value.
NLAttributesGetEthnicityIndianConfidence | Gets the ethnicity Indian confidence value.
NLAttributesGetEthnicityWhiteConfidence | Gets the ethnicity White confidence value.
NLAttributesGetExpression | Gets the expression value of the specified NLAttributes.
NLAttributesGetExpressionConfidence | Retrieves expression confidence value of the specified NLAttributes.
NLAttributesGetFaceDarknessConfidence | Gets the face darkness confidence value.
NLAttributesGetFaceMaskConfidence | Gets the face mask confidence value.
NLAttributesGetFeaturePoint | Retrieves the feature point specified by index.
NLAttributesGetFeaturePointCapacity | Retrieves the feature point capacity of the specified NLAttributes.
NLAttributesGetFeaturePointCount | Retrieves the number of feature points in the specified NLAttributes.
NLAttributesGetFeaturePoints | Retrieves the feature points of the specified NLAttributes.
NLAttributesGetGender | Retrieves the gender value of the specified NLAttributes.
NLAttributesGetGenderConfidence | Retrieves the gender confidence value of the specified NLAttributes.
NLAttributesGetGlassesConfidence | Retrieves the glasses confidence value of the specified NLAttributes.
NLAttributesGetGlassesReflectionConfidence | Gets the glasses reflection confidence value.
NLAttributesGetGrayscaleDensity | Retrieves the grayscale density value of the specified NLAttributes.
NLAttributesGetHatConfidence | Gets the hat confidence value.
NLAttributesGetHeavyFrameConfidence | Gets the heavy frame eyeglasses confidence value.
NLAttributesGetIcaoWarnings | Gets Icao warnings.
NLAttributesGetLeftEyeCenter | Retrieves the center of the left eye of the specified NLAttributes.
NLAttributesGetLivenessAction | Retrieves a liveness detection action.
NLAttributesGetLivenessScore | Retrieves the liveness score of the face.
NLAttributesGetLivenessTargetPitch | Gets liveness target pitch angle.
NLAttributesGetLivenessTargetYaw | Retrieves liveness detection yaw rotation angle.
NLAttributesGetLookingAwayConfidence | Gets the looking away confidence value.
NLAttributesGetMocTemplate | Gets Match-on-Card face template, if engine was configured to extract it.
NLAttributesGetMouthCenter | Retrieves the center of the mouth of the specified NLAttributes.
NLAttributesGetMouthOpenConfidence | Retrieves the mouth open confidence value of the specified NLAttributes.
NLAttributesGetMustacheConfidence | Gets the mustache confidence value.
NLAttributesGetNoise | Gets image noise value.
NLAttributesGetNoseTip | Retrieves the center of the nose tip of the specified NLAttributes.
NLAttributesGetPitch | ... more
NLAttributesGetPixelationConfidence | Gets the pixelation confidence value.
NLAttributesGetProperties | Retrieves the properties of the specified NLAttributes.
NLAttributesGetRedEyeConfidence | Gets the red eye confidence value.
NLAttributesGetRightEyeCenter | Retrieves the center of the right eye of the specified NLAttributes.
NLAttributesGetRoll | ... more
NLAttributesGetSaturation | Gets the saturation value of the specified NLAttributes.
NLAttributesGetSharpness | Retrieves the sharpness value of the specified NLAttributes.
NLAttributesGetSkinReflectionConfidence | Gets the skin reflection confidence value.
NLAttributesGetTemplate | Retrieves the biometric template of the specified NLAttributes.
NLAttributesGetThumbnail | Gets the thumbnail image of the specified NLAttributes.
NLAttributesGetTokenImageRect | Gets rectangle of token face image.
NLAttributesGetUnnaturalSkinToneConfidence | Gets the unnatural skin tone confidence value.
NLAttributesGetWashedOutConfidence | Gets the washed out confidence value.
NLAttributesGetYaw | ... more
NLAttributesInsertFeaturePoint | Adds a feature point to the specified NLAttributes at the specified index.
NLAttributesRemoveFeaturePointAt | Removes the specified feature point from the specified NLAttributes.
NLAttributesSetAdditionalFacesDetected | Sets if any additional faces were detected.
NLAttributesSetAge | Sets age value.
NLAttributesSetBackgroundUniformity | Sets the background uniformity value for the specified NLAttributes.
NLAttributesSetBaseFrameIndex | Sets the base frame index for the specified NLAttributes.
NLAttributesSetBeardConfidence | Sets the beard confidence value.
NLAttributesSetBlinkConfidence | Sets the blink confidence value for the specified NLAttributes.
NLAttributesSetBoundingRect | Sets the bounding rectangle that completely encloses the face in the image.
NLAttributesSetContrast | Sets contrast value.
NLAttributesSetDarkGlassesConfidence | Sets the dark glasses confidence value for the specified NLAttributes.
NLAttributesSetEmotionAngerConfidence | Sets anger confidence value for the specified NLAttributes.
NLAttributesSetEmotionContemptConfidence | Sets emotion contempt confidence value.
NLAttributesSetEmotionDisgustConfidence | Sets disgust confidence value for the specified NLAttributes.
NLAttributesSetEmotionFearConfidence | Sets fear confidence value for the specified NLAttributes.
NLAttributesSetEmotionHappinessConfidence | Sets happiness confidence value for the specified NLAttributes.
NLAttributesSetEmotionNeutralConfidence | Sets neutral emotion confidence value for the specified NLAttributes.
NLAttributesSetEmotionSadnessConfidence | Sets sadness confidence value for the specified NLAttributes.
NLAttributesSetEmotionSurpriseConfidence | Sets surprise emotion confidence value for the specified NLAttributes.
NLAttributesSetEthnicityArabianConfidence | Sets the ethnicity Arabian confidence value.
NLAttributesSetEthnicityAsianConfidence | Sets the ethnicity Asian confidence value.
NLAttributesSetEthnicityBlackConfidence | Sets the ethnicity Black confidence value.
NLAttributesSetEthnicityHispanicConfidence | Sets the ethnicity Hispanic confidence value.
NLAttributesSetEthnicityIndianConfidence | Sets the ethnicity Indian confidence value.
NLAttributesSetEthnicityWhiteConfidence | Sets the ethnicity White confidence value.
NLAttributesSetExpression | Sets the expression value of the specified NLAttributes.
NLAttributesSetExpressionConfidence | Sets expression confidence value for the specified NLAttributes.
NLAttributesSetFaceDarknessConfidence | Sets the face darkness confidence value.
NLAttributesSetFaceMaskConfidence | Sets the face mask confidence value.
NLAttributesSetFeaturePoint | Sets the value of the specified feature point for the specified NLAttributes.
NLAttributesSetFeaturePointCapacity | Sets feature point capacity for the specified NLAttributes.
NLAttributesSetGender | Sets the gender value for the specified NLAttributes.
NLAttributesSetGenderConfidence | Sets the gender confidence value for the specified NLAttributes.
NLAttributesSetGlassesConfidence | Sets the glasses confidence value for the specified NLAttributes.
NLAttributesSetGlassesReflectionConfidence | Sets the glasses reflection confidence value.
NLAttributesSetGrayscaleDensity | Sets the grayscale density value for the specified NLAttributes.
NLAttributesSetHatConfidence | Sets the hat confidence value for the specified NLAttributes.
NLAttributesSetHeavyFrameConfidence | Sets the heavy frame eyeglasses confidence value.
NLAttributesSetIcaoWarnings | Sets Icao warnings.
NLAttributesSetLeftEyeCenter | Sets the center of the left eye for the specified NLAttributes.
NLAttributesSetLookingAwayConfidence | Sets the looking away confidence value.
NLAttributesSetMouthCenter | Sets the center of the mouth for the specified NLAttributes.
NLAttributesSetMouthOpenConfidence | Sets the confidence value of mouth opened for the specified NLAttributes.
NLAttributesSetMustacheConfidence | Sets the mustache confidence value for the specified NLAttributes.
NLAttributesSetNoise | Sets image noise value.
NLAttributesSetNoseTip | Sets the center of the nose tip for the specified NLAttributes.
NLAttributesSetPitch | Sets the pitch value for the specified NLAttributes.
NLAttributesSetPixelationConfidence | Sets the pixelation confidence value.
NLAttributesSetProperties | Sets the properties of the specified NLAttributes.
NLAttributesSetRedEyeConfidence | Sets the red eye confidence value.
NLAttributesSetRightEyeCenter | Sets the center of the right eye for the specified NLAttributes.
NLAttributesSetRoll | Sets the roll value for the specified NLAttributes.
NLAttributesSetSaturation | Sets the saturation value of the specified NLAttributes.
NLAttributesSetSharpness | Sets the sharpness value of the specified NLAttributes.
NLAttributesSetSkinReflectionConfidence | Sets the skin reflection confidence value.
NLAttributesSetTemplate | Sets the biometric template of the specified NLAttributes.
NLAttributesSetThumbnail | Sets the thumbnail image for the specified NLAttributes.
NLAttributesSetTokenImageRect | Sets rectangle of token face image.
NLAttributesSetUnnaturalSkinToneConfidence | Sets the unnatural skin tone confidence value.
NLAttributesSetWashedOutConfidence | Sets the washed out confidence value.
NLAttributesSetYaw | Sets the yaw value for the specified NLAttributes.


NLAttributesAddFeaturePoint Function

NLAttributesAddFeaturePoint Function
NLAttributes.h

Adds a feature point to the specified NLAttributes.

C++
NResult N_API NLAttributesAddFeaturePoint(HNLAttributes hAttributes, const struct NLFeaturePoint_ * pValue, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
const struct NLFeaturePoint_ * pValue | [in] Pointer to the feature point to be added.
NInt * pIndex | [out] Pointer to the index of the added feature point.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesClearFeaturePoints Function

NLAttributesClearFeaturePoints Function
NLAttributes.h

Removes all feature points from the specified NLAttributes.

C++
NResult N_API NLAttributesClearFeaturePoints(HNLAttributes hAttributes);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesCreate Function

NLAttributesCreate Function
NLAttributes.h

Creates NLAttributes.

C++
NResult N_API NLAttributesCreate(HNLAttributes * phAttributes);
Collapse Expand Parameters
Parameters | Description
HNLAttributes * phAttributes | [out] Handle to NLAttributes which contains face attributes.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetAdditionalFacesDetected Function

NLAttributesGetAdditionalFacesDetected Function
NLAttributes.h

Gets if any additional faces were detected.

C++
NResult N_API NLAttributesGetAdditionalFacesDetected(HNLAttributes hAttributes, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NBool * pValue | [out] Pointer to NBool, which receives NTrue when an additional face was found, and NFalse otherwise.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetAge Function

NLAttributesGetAge Function
NLAttributes.h

Gets age value.

C++
NResult N_API NLAttributesGetAge(HNLAttributes hAttributes, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte * pValue | [out] Age value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetBackgroundUniformity Function

NLAttributesGetBackgroundUniformity Function
NLAttributes.h

Retrieves the background uniformity value of the specified NLAttributes.

C++
NResult N_API NLAttributesGetBackgroundUniformity(HNLAttributes hAttributes, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte * pValue | [out] Pointer to the background uniformity value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetBaseFrameIndex Function

NLAttributesGetBaseFrameIndex Function
NLAttributes.h

Gets the base frame index of the specified NLAttributes.

C++
NResult N_API NLAttributesGetBaseFrameIndex(HNLAttributes hAttributes, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NInt * pValue | [out] Pointer to the base frame index.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetBeardConfidence Function

NLAttributesGetBeardConfidence Function
NLAttributes.h

Gets the beard confidence value.

C++
NResult N_API NLAttributesGetBeardConfidence(HNLAttributes hAttributes, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte * pValue | [out] The beard confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetBlinkConfidence Function

NLAttributesGetBlinkConfidence Function
NLAttributes.h

Retrieves the blink confidence value of the specified NLAttributes.

C++
NResult N_API NLAttributesGetBlinkConfidence(HNLAttributes hAttributes, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte * pValue | [out] Pointer to the confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetBoundingRect Function

NLAttributesGetBoundingRect Function
NLAttributes.h

Retrieves the bounding rectangle that completely encloses the face in the image.

C++
NResult N_API NLAttributesGetBoundingRect(HNLAttributes hAttributes, struct NRect_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
struct NRect_ * pValue | [out] Pointer to the bounding rectangle.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetContrast Function

NLAttributesGetContrast Function
NLAttributes.h

Gets contrast value.

C++
NResult N_API NLAttributesGetContrast(HNLAttributes hAttributes, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte * pValue | [out] Contrast value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetDarkGlassesConfidence Function

NLAttributesGetDarkGlassesConfidence Function
NLAttributes.h

Retrieves the dark glasses confidence value of the specified NLAttributes.

C++
NResult N_API NLAttributesGetDarkGlassesConfidence(HNLAttributes hAttributes, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte * pValue | [out] Pointer to the confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetEmotionAngerConfidence Function

NLAttributesGetEmotionAngerConfidence Function
NLAttributes.h

Retrieves anger confidence value of the specified NLAttributes.

C++
NResult N_API NLAttributesGetEmotionAngerConfidence(HNLAttributes hAttributes, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte * pValue | [out] Pointer to the confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetEmotionContemptConfidence Function

NLAttributesGetEmotionContemptConfidence Function
NLAttributes.h

Gets emotion contempt confidence value.

C++
NResult N_API NLAttributesGetEmotionContemptConfidence(HNLAttributes hAttributes, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte * pValue | [out] Emotion contempt confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetEmotionDisgustConfidence Function

NLAttributesGetEmotionDisgustConfidence Function
NLAttributes.h

Retrieves disgust confidence value of the specified NLAttributes.

C++
NResult N_API NLAttributesGetEmotionDisgustConfidence(HNLAttributes hAttributes, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte * pValue | [out] Pointer to the confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetEmotionFearConfidence Function

NLAttributesGetEmotionFearConfidence Function
NLAttributes.h

Retrieves fear confidence value of the specified NLAttributes.

C++
NResult N_API NLAttributesGetEmotionFearConfidence(HNLAttributes hAttributes, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte * pValue | [out] Pointer to the confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetEmotionHappinessConfidence Function

NLAttributesGetEmotionHappinessConfidence Function
NLAttributes.h

Retrieves happiness confidence value of the specified NLAttributes.

C++
NResult N_API NLAttributesGetEmotionHappinessConfidence(HNLAttributes hAttributes, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte * pValue | [out] Pointer to the confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetEmotionNeutralConfidence Function

NLAttributesGetEmotionNeutralConfidence Function
NLAttributes.h

Retrieves neutral emotion confidence value of the specified NLAttributes.

C++
NResult N_API NLAttributesGetEmotionNeutralConfidence(HNLAttributes hAttributes, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte * pValue | [out] Pointer to the confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetEmotionSadnessConfidence Function

NLAttributesGetEmotionSadnessConfidence Function
NLAttributes.h

Retrieves sadness confidence value of the specified NLAttributes.

C++
NResult N_API NLAttributesGetEmotionSadnessConfidence(HNLAttributes hAttributes, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte * pValue | [out] Pointer to the confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetEmotionSurpriseConfidence Function

NLAttributesGetEmotionSurpriseConfidence Function
NLAttributes.h

Retrieves surprise confidence value of the specified NLAttributes.

C++
NResult N_API NLAttributesGetEmotionSurpriseConfidence(HNLAttributes hAttributes, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte * pValue | [out] Pointer to the confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetEthnicityArabianConfidence Function

NLAttributesGetEthnicityArabianConfidence Function
NLAttributes.h

Gets the ethnicity Arabian confidence value.

C++
NResult N_API NLAttributesGetEthnicityArabianConfidence(HNLAttributes hAttributes, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte * pValue | [out] Ethnicity Arabian confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetEthnicityAsianConfidence Function

NLAttributesGetEthnicityAsianConfidence Function
NLAttributes.h

Gets the ethnicity Asian confidence value.

C++
NResult N_API NLAttributesGetEthnicityAsianConfidence(HNLAttributes hAttributes, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte * pValue | [out] Ethnicity Asian confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetEthnicityBlackConfidence Function

NLAttributesGetEthnicityBlackConfidence Function
NLAttributes.h

Gets the ethnicity Black confidence value.

C++
NResult N_API NLAttributesGetEthnicityBlackConfidence(HNLAttributes hAttributes, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte * pValue | [out] Ethnicity Black confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetEthnicityHispanicConfidence Function

NLAttributesGetEthnicityHispanicConfidence Function
NLAttributes.h

Gets the ethnicity Hispanic confidence value.

C++
NResult N_API NLAttributesGetEthnicityHispanicConfidence(HNLAttributes hAttributes, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte * pValue | [out] Ethnicity Hispanic confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetEthnicityIndianConfidence Function

NLAttributesGetEthnicityIndianConfidence Function
NLAttributes.h

Gets the ethnicity Indian confidence value.

C++
NResult N_API NLAttributesGetEthnicityIndianConfidence(HNLAttributes hAttributes, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte * pValue | [out] Ethnicity Indian confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetEthnicityWhiteConfidence Function

NLAttributesGetEthnicityWhiteConfidence Function
NLAttributes.h

Gets the ethnicity White confidence value.

C++
NResult N_API NLAttributesGetEthnicityWhiteConfidence(HNLAttributes hAttributes, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte * pValue | [out] Ethnicity White confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetExpression Function

NLAttributesGetExpression Function
NLAttributes.h

Gets the expression value of the specified NLAttributes.

C++
NResult N_API NLAttributesGetExpression(HNLAttributes hAttributes, NLExpression * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NLExpression * pValue | [out] Pointer to the expression value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetExpressionConfidence Function

NLAttributesGetExpressionConfidence Function
NLAttributes.h

Retrieves expression confidence value of the specified NLAttributes.

C++
NResult N_API NLAttributesGetExpressionConfidence(HNLAttributes hAttributes, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte * pValue | [out] Pointer to the confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetFaceDarknessConfidence Function

NLAttributesGetFaceDarknessConfidence Function
NLAttributes.h

Gets the face darkness confidence value.

C++
NResult N_API NLAttributesGetFaceDarknessConfidence(HNLAttributes hAttributes, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte * pValue | [out] The face darkness confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetFaceMaskConfidence Function

NLAttributesGetFaceMaskConfidence Function
NLAttributes.h

Gets the face mask confidence value.

C++
NResult N_API NLAttributesGetFaceMaskConfidence(HNLAttributes hAttributes, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte * pValue | [out] Pointer to NByte which receives the face mask confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetFeaturePoint Function

NLAttributesGetFeaturePoint Function
NLAttributes.h

Retrieves the feature point specified by index.

C++
NResult N_API NLAttributesGetFeaturePoint(HNLAttributes hAttributes, NInt index, struct NLFeaturePoint_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NInt index | [in] Index of the feature point to be retrieved.
struct NLFeaturePoint_ * pValue | [out] Pointer to the feature point.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetFeaturePointCapacity Function

NLAttributesGetFeaturePointCapacity Function
NLAttributes.h

Retrieves the feature point capacity of the specified NLAttributes.

C++
NResult N_API NLAttributesGetFeaturePointCapacity(HNLAttributes hAttributes, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NInt * pValue | [out] Pointer to the feature point capacity value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetFeaturePointCount Function

NLAttributesGetFeaturePointCount Function
NLAttributes.h

Retrieves the number of feature points in the specified NLAttributes.

C++
NResult N_API NLAttributesGetFeaturePointCount(HNLAttributes hAttributes, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NInt * pValue | [out] Pointer to the feature point count.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetFeaturePoints Function

NLAttributesGetFeaturePoints Function
NLAttributes.h

Retrieves the feature points of the specified NLAttributes.

C++
NResult N_API NLAttributesGetFeaturePoints(HNLAttributes hAttributes, struct NLFeaturePoint_ * * parValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
struct NLFeaturePoint_ * * parValues | [out] Pointer to a feature point array.
NInt * pValueCount | [out] Pointer to the number of feature points in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetGender Function

NLAttributesGetGender Function
NLAttributes.h

Retrieves the gender value of the specified NLAttributes.

C++
NResult N_API NLAttributesGetGender(HNLAttributes hAttributes, NGender * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NGender * pValue | [out] Pointer to the gender value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetGenderConfidence Function

NLAttributesGetGenderConfidence Function
NLAttributes.h

Retrieves the gender confidence value of the specified NLAttributes.

C++
NResult N_API NLAttributesGetGenderConfidence(HNLAttributes hAttributes, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte * pValue | [out] Pointer to the confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetGlassesConfidence Function

NLAttributesGetGlassesConfidence Function
NLAttributes.h

Retrieves the glasses confidence value of the specified NLAttributes.

C++
NResult N_API NLAttributesGetGlassesConfidence(HNLAttributes hAttributes, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte * pValue | [out] Pointer to the confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetGlassesReflectionConfidence Function

NLAttributesGetGlassesReflectionConfidence Function
NLAttributes.h

Gets the glasses reflection confidence value.

C++
NResult N_API NLAttributesGetGlassesReflectionConfidence(HNLAttributes hAttributes, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte * pValue | [out] The glasses reflection confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetGrayscaleDensity Function

NLAttributesGetGrayscaleDensity Function
NLAttributes.h

Retrieves the grayscale density value of the specified NLAttributes.

C++
NResult N_API NLAttributesGetGrayscaleDensity(HNLAttributes hAttributes, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte * pValue | [out] Pointer to the grayscale density value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetHatConfidence Function

NLAttributesGetHatConfidence Function
NLAttributes.h

Gets the hat confidence value.

C++
NResult N_API NLAttributesGetHatConfidence(HNLAttributes hAttributes, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte * pValue | [out] The hat confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetHeavyFrameConfidence Function

NLAttributesGetHeavyFrameConfidence Function
NLAttributes.h

Gets the heavy frame eyeglasses confidence value.

C++
NResult N_API NLAttributesGetHeavyFrameConfidence(HNLAttributes hAttributes, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte * pValue | [out] Pointer to NByte which receives the heavy frame eyeglasses confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetIcaoWarnings Function

NLAttributesGetIcaoWarnings Function
NLAttributes.h

Gets Icao warnings.

C++
NResult N_API NLAttributesGetIcaoWarnings(HNLAttributes hAttributes, NIcaoWarnings * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NIcaoWarnings * pValue | [out] Icao warnings value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetLeftEyeCenter Function

NLAttributesGetLeftEyeCenter Function
NLAttributes.h

Retrieves the center of the left eye of the specified NLAttributes.

C++
NResult N_API NLAttributesGetLeftEyeCenter(HNLAttributes hAttributes, NLFeaturePoint * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NLFeaturePoint * pValue | [out] Pointer to the left eye center feature point.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetLivenessAction Function

NLAttributesGetLivenessAction Function
NLAttributes.h

Retrieves a liveness detection action.

C++
NResult N_API NLAttributesGetLivenessAction(HNLAttributes hAttributes, NLivenessAction * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NLivenessAction * pValue | [out] Pointer to the liveness action.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetLivenessScore Function

NLAttributesGetLivenessScore Function
NLAttributes.h

Retrieves the liveness score of the face.

C++
NResult N_API NLAttributesGetLivenessScore(HNLAttributes hAttributes, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte * pValue | [out] Pointer to the liveness score value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetLivenessTargetPitch Function

NLAttributesGetLivenessTargetPitch Function
NLAttributes.h

Gets liveness target pitch angle.

C++
NResult N_API NLAttributesGetLivenessTargetPitch(HNLAttributes hAttributes, NFloat * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NFloat * pValue | [out] Liveness target pitch angle.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetLivenessTargetYaw Function

NLAttributesGetLivenessTargetYaw Function
NLAttributes.h

Retrieves liveness detection yaw rotation angle.

C++
NResult N_API NLAttributesGetLivenessTargetYaw(HNLAttributes hAttributes, NFloat * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NFloat * pValue | [out] Pointer to the yaw value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetLookingAwayConfidence Function

NLAttributesGetLookingAwayConfidence Function
NLAttributes.h

Gets the looking away confidence value.

C++
NResult N_API NLAttributesGetLookingAwayConfidence(HNLAttributes hAttributes, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte * pValue | [out] The looking away confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetMocTemplate Function

NLAttributesGetMocTemplate Function
NLAttributes.h

Gets Match-on-Card face template, if engine was configured to extract it.

C++
NResult N_API NLAttributesGetMocTemplate(HNLAttributes hAttributes, HNBuffer * phValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
HNBuffer * phValue | [out] Pointer to NBuffer which receives Match-on-Card face template data.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetMouthCenter Function

NLAttributesGetMouthCenter Function
NLAttributes.h

Retrieves the center of the mouth of the specified NLAttributes.

C++
NResult N_API NLAttributesGetMouthCenter(HNLAttributes hAttributes, NLFeaturePoint * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NLFeaturePoint * pValue | [out] Pointer to the mouth center feature point.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetMouthOpenConfidence Function

NLAttributesGetMouthOpenConfidence Function
NLAttributes.h

Retrieves the mouth open confidence value of the specified NLAttributes.

C++
NResult N_API NLAttributesGetMouthOpenConfidence(HNLAttributes hAttributes, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte * pValue | [out] Pointer to the confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetMustacheConfidence Function

NLAttributesGetMustacheConfidence Function
NLAttributes.h

Gets the mustache confidence value.

C++
NResult N_API NLAttributesGetMustacheConfidence(HNLAttributes hAttributes, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte * pValue | [out] The mustache confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetNoise Function

NLAttributesGetNoise Function
NLAttributes.h

Gets image noise value.

C++
NResult N_API NLAttributesGetNoise(HNLAttributes hAttributes, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte * pValue | [out] Image noise value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetNoseTip Function

NLAttributesGetNoseTip Function
NLAttributes.h

Retrieves the center of the nose tip of the specified NLAttributes.

C++
NResult N_API NLAttributesGetNoseTip(HNLAttributes hAttributes, NLFeaturePoint * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NLFeaturePoint * pValue | [out] Pointer to the nose tip feature point.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetPitch Function

NLAttributesGetPitch Function
NLAttributes.h

Gets the image pitch value in degrees. The calculation of this value is not implemented.

C++
NResult N_API NLAttributesGetPitch(HNLAttributes hAttributes, NFloat * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NFloat * pValue | [out] Pointer to the pitch value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetPixelationConfidence Function

NLAttributesGetPixelationConfidence Function
NLAttributes.h

Gets the pixelation confidence value.

C++
NResult N_API NLAttributesGetPixelationConfidence(HNLAttributes hAttributes, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte * pValue | [out] Pixelation confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetProperties Function

NLAttributesGetProperties Function
NLAttributes.h

Retrieves the properties of the specified NLAttributes.

C++
NResult N_API NLAttributesGetProperties(HNLAttributes hAttributes, NLProperties * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NLProperties * pValue | [out] Pointer to the properties.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetRedEyeConfidence Function

NLAttributesGetRedEyeConfidence Function
NLAttributes.h

Gets the red eye confidence value.

C++
NResult N_API NLAttributesGetRedEyeConfidence(HNLAttributes hAttributes, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte * pValue | [out] The red eye confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetRightEyeCenter Function

NLAttributesGetRightEyeCenter Function
NLAttributes.h

Retrieves the center of the right eye of the specified NLAttributes.

C++
NResult N_API NLAttributesGetRightEyeCenter(HNLAttributes hAttributes, NLFeaturePoint * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NLFeaturePoint * pValue | [out] Pointer to the right eye center feature point.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetRoll Function

NLAttributesGetRoll Function
NLAttributes.h

Gets the image roll value in degrees. Positive angles represent faces tilted toward their left shoulder (a clockwise rotation around the z-axis).

C++
NResult N_API NLAttributesGetRoll(HNLAttributes hAttributes, NFloat * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NFloat * pValue | [out] Pointer to the roll value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetSaturation Function

NLAttributesGetSaturation Function
NLAttributes.h

Gets the saturation value of the specified NLAttributes.

C++
NResult N_API NLAttributesGetSaturation(HNLAttributes hAttributes, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte * pValue | [out] Pointer to the saturation value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetSharpness Function

NLAttributesGetSharpness Function
NLAttributes.h

Retrieves the sharpness value of the specified NLAttributes.

C++
NResult N_API NLAttributesGetSharpness(HNLAttributes hAttributes, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte * pValue | [out] Pointer to the sharpness value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetSkinReflectionConfidence Function

NLAttributesGetSkinReflectionConfidence Function
NLAttributes.h

Gets the skin reflection confidence value.

C++
NResult N_API NLAttributesGetSkinReflectionConfidence(HNLAttributes hAttributes, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte * pValue | [out] The skin reflection confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetTemplate Function

NLAttributesGetTemplate Function
NLAttributes.h

Retrieves the biometric template of the specified NLAttributes.

C++
NResult N_API NLAttributesGetTemplate(HNLAttributes hAttributes, HNLTemplate * phValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
HNLTemplate * phValue | [out] Pointer to the NLRecord containing the template.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetThumbnail Function

NLAttributesGetThumbnail Function
NLAttributes.h

Gets the thumbnail image of the specified NLAttributes.

C++
NResult N_API NLAttributesGetThumbnail(HNLAttributes hAttributes, HNImage * phValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
HNImage * phValue | [out] Pointer to the thumbnail image.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetTokenImageRect Function

NLAttributesGetTokenImageRect Function
NLAttributes.h

Gets rectangle of token face image.

C++
NResult N_API NLAttributesGetTokenImageRect(HNLAttributes hAttributes, struct NRect_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
struct NRect_ * pValue | [out] Rectangle of token face image.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetUnnaturalSkinToneConfidence Function

NLAttributesGetUnnaturalSkinToneConfidence Function
NLAttributes.h

Gets the unnatural skin tone confidence value.

C++
NResult N_API NLAttributesGetUnnaturalSkinToneConfidence(HNLAttributes hAttributes, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte * pValue | [out] The unnatural skin tone confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetWashedOutConfidence Function

NLAttributesGetWashedOutConfidence Function
NLAttributes.h

Gets the washed out confidence value.

C++
NResult N_API NLAttributesGetWashedOutConfidence(HNLAttributes hAttributes, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte * pValue | [out] The washed out confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesGetYaw Function

NLAttributesGetYaw Function
NLAttributes.h

Gets the image yaw value in degrees. Positive angles represent faces looking to their right (a clockwise rotation around the y-axis).

C++
NResult N_API NLAttributesGetYaw(HNLAttributes hAttributes, NFloat * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NFloat * pValue | [out] Pointer to the yaw value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesInsertFeaturePoint Function

NLAttributesInsertFeaturePoint Function
NLAttributes.h

Adds a feature point to the specified NLAttributes at the specified index.

C++
NResult N_API NLAttributesInsertFeaturePoint(HNLAttributes hAttributes, NInt index, const struct NLFeaturePoint_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NInt index | [in] Index of the added feature point.
const struct NLFeaturePoint_ * pValue | [in] Pointer to the feature point to be added.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesRemoveFeaturePointAt Function

NLAttributesRemoveFeaturePointAt Function
NLAttributes.h

Removes the specified feature point from the specified NLAttributes.

C++
NResult N_API NLAttributesRemoveFeaturePointAt(HNLAttributes hAttributes, NInt index);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NInt index | [in] Index of the feature point to be removed.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetAdditionalFacesDetected Function

NLAttributesSetAdditionalFacesDetected Function
NLAttributes.h

Sets if any additional faces were detected.

C++
NResult N_API NLAttributesSetAdditionalFacesDetected(HNLAttributes hAttributes, NBool value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NBool value | [in] NTrue when an additional face was found, and NFalse otherwise.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetAge Function

NLAttributesSetAge Function
NLAttributes.h

Sets age value.

C++
NResult N_API NLAttributesSetAge(HNLAttributes hAttributes, NByte value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte value | [in] Age value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetBackgroundUniformity Function

NLAttributesSetBackgroundUniformity Function
NLAttributes.h

Sets the background uniformity value for the specified NLAttributes.

C++
NResult N_API NLAttributesSetBackgroundUniformity(HNLAttributes hAttributes, NByte value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte value | [in] Background uniformity value to set.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetBaseFrameIndex Function

NLAttributesSetBaseFrameIndex Function
NLAttributes.h

Sets the base frame index for the specified NLAttributes.

C++
NResult N_API NLAttributesSetBaseFrameIndex(HNLAttributes hAttributes, NInt value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NInt value | [in] The base frame index.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetBeardConfidence Function

NLAttributesSetBeardConfidence Function
NLAttributes.h

Sets the beard confidence value.

C++
NResult N_API NLAttributesSetBeardConfidence(HNLAttributes hAttributes, NByte value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte value | [in] The beard confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetBlinkConfidence Function

NLAttributesSetBlinkConfidence Function
NLAttributes.h

Sets the blink confidence value for the specified NLAttributes.

C++
NResult N_API NLAttributesSetBlinkConfidence(HNLAttributes hAttributes, NByte value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte value | [in] Blink confidence value to set.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetBoundingRect Function

NLAttributesSetBoundingRect Function
NLAttributes.h

Sets the bounding rectangle that completely encloses the face in the image.

C++
NResult N_API NLAttributesSetBoundingRect(HNLAttributes hAttributes, const struct NRect_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
const struct NRect_ * pValue | [in] Pointer to the bounding rectangle.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetContrast Function

NLAttributesSetContrast Function
NLAttributes.h

Sets contrast value.

C++
NResult N_API NLAttributesSetContrast(HNLAttributes hAttributes, NByte value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte value | [in] Contrast value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetDarkGlassesConfidence Function

NLAttributesSetDarkGlassesConfidence Function
NLAttributes.h

Sets the dark glasses confidence value for the specified NLAttributes.

C++
NResult N_API NLAttributesSetDarkGlassesConfidence(HNLAttributes hAttributes, NByte value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte value | [in] Confidence value to set.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetEmotionAngerConfidence Function

NLAttributesSetEmotionAngerConfidence Function
NLAttributes.h

Sets anger confidence value for the specified NLAttributes.

C++
NResult N_API NLAttributesSetEmotionAngerConfidence(HNLAttributes hAttributes, NByte value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte value | [in] Confidence value to set.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetEmotionContemptConfidence Function

NLAttributesSetEmotionContemptConfidence Function
NLAttributes.h

Sets emotion contempt confidence value.

C++
NResult N_API NLAttributesSetEmotionContemptConfidence(HNLAttributes hAttributes, NByte value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte value | [in] Emotion contempt confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetEmotionDisgustConfidence Function

NLAttributesSetEmotionDisgustConfidence Function
NLAttributes.h

Sets disgust confidence value for the specified NLAttributes.

C++
NResult N_API NLAttributesSetEmotionDisgustConfidence(HNLAttributes hAttributes, NByte value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte value | [in] Confidence value to set.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetEmotionFearConfidence Function

NLAttributesSetEmotionFearConfidence Function
NLAttributes.h

Sets fear confidence value for the specified NLAttributes.

C++
NResult N_API NLAttributesSetEmotionFearConfidence(HNLAttributes hAttributes, NByte value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte value | [in] Confidence value to set.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetEmotionHappinessConfidence Function

NLAttributesSetEmotionHappinessConfidence Function
NLAttributes.h

Sets happiness confidence value for the specified NLAttributes.

C++
NResult N_API NLAttributesSetEmotionHappinessConfidence(HNLAttributes hAttributes, NByte value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte value | [in] Confidence value to set.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetEmotionNeutralConfidence Function

NLAttributesSetEmotionNeutralConfidence Function
NLAttributes.h

Sets neutral emotion confidence value for the specified NLAttributes.

C++
NResult N_API NLAttributesSetEmotionNeutralConfidence(HNLAttributes hAttributes, NByte value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte value | [in] Confidence value to set.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetEmotionSadnessConfidence Function

NLAttributesSetEmotionSadnessConfidence Function
NLAttributes.h

Sets sadness confidence value for the specified NLAttributes.

C++
NResult N_API NLAttributesSetEmotionSadnessConfidence(HNLAttributes hAttributes, NByte value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte value | [in] Confidence value to set.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetEmotionSurpriseConfidence Function

NLAttributesSetEmotionSurpriseConfidence Function
NLAttributes.h

Sets surprise emotion confidence value for the specified NLAttributes.

C++
NResult N_API NLAttributesSetEmotionSurpriseConfidence(HNLAttributes hAttributes, NByte value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte value | [in] Confidence value to set.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetEthnicityArabianConfidence Function

NLAttributesSetEthnicityArabianConfidence Function
NLAttributes.h

Sets the ethnicity Arabian confidence value.

C++
NResult N_API NLAttributesSetEthnicityArabianConfidence(HNLAttributes hAttributes, NByte value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte value | [in] Ethnicity Arabian confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetEthnicityAsianConfidence Function

NLAttributesSetEthnicityAsianConfidence Function
NLAttributes.h

Sets the ethnicity Asian confidence value.

C++
NResult N_API NLAttributesSetEthnicityAsianConfidence(HNLAttributes hAttributes, NByte value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte value | [in] Ethnicity Asian confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetEthnicityBlackConfidence Function

NLAttributesSetEthnicityBlackConfidence Function
NLAttributes.h

Sets the ethnicity Black confidence value.

C++
NResult N_API NLAttributesSetEthnicityBlackConfidence(HNLAttributes hAttributes, NByte value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte value | [in] Ethnicity Black confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetEthnicityHispanicConfidence Function

NLAttributesSetEthnicityHispanicConfidence Function
NLAttributes.h

Sets the ethnicity Hispanic confidence value.

C++
NResult N_API NLAttributesSetEthnicityHispanicConfidence(HNLAttributes hAttributes, NByte value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte value | [in] Ethnicity Hispanic confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetEthnicityIndianConfidence Function

NLAttributesSetEthnicityIndianConfidence Function
NLAttributes.h

Sets the ethnicity Indian confidence value.

C++
NResult N_API NLAttributesSetEthnicityIndianConfidence(HNLAttributes hAttributes, NByte value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte value | [in] Ethnicity Indian confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetEthnicityWhiteConfidence Function

NLAttributesSetEthnicityWhiteConfidence Function
NLAttributes.h

Sets the ethnicity White confidence value.

C++
NResult N_API NLAttributesSetEthnicityWhiteConfidence(HNLAttributes hAttributes, NByte value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte value | [in] Ethnicity White confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetExpression Function

NLAttributesSetExpression Function
NLAttributes.h

Sets the expression value of the specified NLAttributes.

C++
NResult N_API NLAttributesSetExpression(HNLAttributes hAttributes, NLExpression value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NLExpression value | [in] The new expression value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetExpressionConfidence Function

NLAttributesSetExpressionConfidence Function
NLAttributes.h

Sets expression confidence value for the specified NLAttributes.

C++
NResult N_API NLAttributesSetExpressionConfidence(HNLAttributes hAttributes, NByte value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte value | [in] Expression confidence value to set.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetFaceDarknessConfidence Function

NLAttributesSetFaceDarknessConfidence Function
NLAttributes.h

Sets the face darkness confidence value.

C++
NResult N_API NLAttributesSetFaceDarknessConfidence(HNLAttributes hAttributes, NByte value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte value | [in] The face darkness confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetFaceMaskConfidence Function

NLAttributesSetFaceMaskConfidence Function
NLAttributes.h

Sets the face mask confidence value.

C++
NResult N_API NLAttributesSetFaceMaskConfidence(HNLAttributes hAttributes, NByte value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte value | [in] The face mask confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetFeaturePoint Function

NLAttributesSetFeaturePoint Function
NLAttributes.h

Sets the value of the specified feature point for the specified NLAttributes.

C++
NResult N_API NLAttributesSetFeaturePoint(HNLAttributes hAttributes, NInt index, const struct NLFeaturePoint_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NInt index | [in] Index of the feature point to be set.
const struct NLFeaturePoint_ * pValue | [in] Pointer to the new feature point value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetFeaturePointCapacity Function

NLAttributesSetFeaturePointCapacity Function
NLAttributes.h

Sets feature point capacity for the specified NLAttributes.

C++
NResult N_API NLAttributesSetFeaturePointCapacity(HNLAttributes hAttributes, NInt value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NInt value | [in] Feature point capacity value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetGender Function

NLAttributesSetGender Function
NLAttributes.h

Sets the gender value for the specified NLAttributes.

C++
NResult N_API NLAttributesSetGender(HNLAttributes hAttributes, NGender value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NGender value | [in] Gender value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetGenderConfidence Function

NLAttributesSetGenderConfidence Function
NLAttributes.h

Sets the gender confidence value for the specified NLAttributes.

C++
NResult N_API NLAttributesSetGenderConfidence(HNLAttributes hAttributes, NByte value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte value | [in] Gender confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetGlassesConfidence Function

NLAttributesSetGlassesConfidence Function
NLAttributes.h

Sets the glasses confidence value for the specified NLAttributes.

C++
NResult N_API NLAttributesSetGlassesConfidence(HNLAttributes hAttributes, NByte value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte value | [in] Glasses confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetGlassesReflectionConfidence Function

NLAttributesSetGlassesReflectionConfidence Function
NLAttributes.h

Sets the glasses reflection confidence value.

C++
NResult N_API NLAttributesSetGlassesReflectionConfidence(HNLAttributes hAttributes, NByte value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte value | [in] The glasses reflection confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetGrayscaleDensity Function

NLAttributesSetGrayscaleDensity Function
NLAttributes.h

Sets the grayscale density value for the specified NLAttributes.

C++
NResult N_API NLAttributesSetGrayscaleDensity(HNLAttributes hAttributes, NByte value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte value | [in] Grayscale density value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetHatConfidence Function

NLAttributesSetHatConfidence Function
NLAttributes.h

Sets the hat confidence value for the specified NLAttributes.

C++
NResult N_API NLAttributesSetHatConfidence(HNLAttributes hAttributes, NByte value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte value | [in] Hat confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetHeavyFrameConfidence Function

NLAttributesSetHeavyFrameConfidence Function
NLAttributes.h

Sets the heavy frame eyeglasses confidence value.

C++
NResult N_API NLAttributesSetHeavyFrameConfidence(HNLAttributes hAttributes, NByte value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte value | [in] Heavy frame eyeglasses confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetIcaoWarnings Function

NLAttributesSetIcaoWarnings Function
NLAttributes.h

Sets Icao warnings.

C++
NResult N_API NLAttributesSetIcaoWarnings(HNLAttributes hAttributes, NIcaoWarnings value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NIcaoWarnings value | [in] Icao warnings value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetLeftEyeCenter Function

NLAttributesSetLeftEyeCenter Function
NLAttributes.h

Sets the center of the left eye for the specified NLAttributes.

C++
NResult N_API NLAttributesSetLeftEyeCenter(HNLAttributes hAttributes, const NLFeaturePoint * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
const NLFeaturePoint * pValue | [in] The left eye center feature point.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetLookingAwayConfidence Function

NLAttributesSetLookingAwayConfidence Function
NLAttributes.h

Sets the looking away confidence value.

C++
NResult N_API NLAttributesSetLookingAwayConfidence(HNLAttributes hAttributes, NByte value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte value | [in] The looking away confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetMouthCenter Function

NLAttributesSetMouthCenter Function
NLAttributes.h

Sets the center of the mouth for the specified NLAttributes.

C++
NResult N_API NLAttributesSetMouthCenter(HNLAttributes hAttributes, const NLFeaturePoint * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
const NLFeaturePoint * pValue | [in] The mouth center feature point.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetMouthOpenConfidence Function

NLAttributesSetMouthOpenConfidence Function
NLAttributes.h

Sets the confidence value of mouth opened for the specified NLAttributes.

C++
NResult N_API NLAttributesSetMouthOpenConfidence(HNLAttributes hAttributes, NByte value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte value | [in] Mouth opened confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetMustacheConfidence Function

NLAttributesSetMustacheConfidence Function
NLAttributes.h

Sets the mustache confidence value for the specified NLAttributes.

C++
NResult N_API NLAttributesSetMustacheConfidence(HNLAttributes hAttributes, NByte value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte value | [in] Mustache confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetNoise Function

NLAttributesSetNoise Function
NLAttributes.h

Sets image noise value.

C++
NResult N_API NLAttributesSetNoise(HNLAttributes hAttributes, NByte value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte value | [in] Image noise value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetNoseTip Function

NLAttributesSetNoseTip Function
NLAttributes.h

Sets the center of the nose tip for the specified NLAttributes.

C++
NResult N_API NLAttributesSetNoseTip(HNLAttributes hAttributes, const NLFeaturePoint * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
const NLFeaturePoint * pValue | [in] The nose tip feature point.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetPitch Function

NLAttributesSetPitch Function
NLAttributes.h

Sets the pitch value for the specified NLAttributes.

C++
NResult N_API NLAttributesSetPitch(HNLAttributes hAttributes, NFloat value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NFloat value | [in] New pitch value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetPixelationConfidence Function

NLAttributesSetPixelationConfidence Function
NLAttributes.h

Sets the pixelation confidence value.

C++
NResult N_API NLAttributesSetPixelationConfidence(HNLAttributes hAttributes, NByte value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte value | [in] Pixelation confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetProperties Function

NLAttributesSetProperties Function
NLAttributes.h

Sets the properties of the specified NLAttributes.

C++
NResult N_API NLAttributesSetProperties(HNLAttributes hAttributes, NLProperties value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NLProperties value | [in] New properties.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetRedEyeConfidence Function

NLAttributesSetRedEyeConfidence Function
NLAttributes.h

Sets the red eye confidence value.

C++
NResult N_API NLAttributesSetRedEyeConfidence(HNLAttributes hAttributes, NByte value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte value | [in] The red eye confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetRightEyeCenter Function

NLAttributesSetRightEyeCenter Function
NLAttributes.h

Sets the center of the right eye for the specified NLAttributes.

C++
NResult N_API NLAttributesSetRightEyeCenter(HNLAttributes hAttributes, const NLFeaturePoint * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
const NLFeaturePoint * pValue | [in] The right eye center feature point.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetRoll Function

NLAttributesSetRoll Function
NLAttributes.h

Sets the roll value for the specified NLAttributes.

C++
NResult N_API NLAttributesSetRoll(HNLAttributes hAttributes, NFloat value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NFloat value | [in] New roll value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetSaturation Function

NLAttributesSetSaturation Function
NLAttributes.h

Sets the saturation value of the specified NLAttributes.

C++
NResult N_API NLAttributesSetSaturation(HNLAttributes hAttributes, NByte value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte value | [in] The saturation value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetSharpness Function

NLAttributesSetSharpness Function
NLAttributes.h

Sets the sharpness value of the specified NLAttributes.

C++
NResult N_API NLAttributesSetSharpness(HNLAttributes hAttributes, NByte value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte value | [in] The sharpness value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetSkinReflectionConfidence Function

NLAttributesSetSkinReflectionConfidence Function
NLAttributes.h

Sets the skin reflection confidence value.

C++
NResult N_API NLAttributesSetSkinReflectionConfidence(HNLAttributes hAttributes, NByte value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte value | [in] The skin reflection confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetTemplate Function

NLAttributesSetTemplate Function
NLAttributes.h

Sets the biometric template of the specified NLAttributes.

C++
NResult N_API NLAttributesSetTemplate(HNLAttributes hAttributes, HNLTemplate hTemplate);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
HNLTemplate hTemplate | [in] Handle to the NLTemplate containing the template.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetThumbnail Function

NLAttributesSetThumbnail Function
NLAttributes.h

Sets the thumbnail image for the specified NLAttributes.

C++
NResult N_API NLAttributesSetThumbnail(HNLAttributes hAttributes, HNImage hValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
HNImage hValue | [in] Handle to the thumbnail image.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetTokenImageRect Function

NLAttributesSetTokenImageRect Function
NLAttributes.h

Sets rectangle of token face image.

C++
NResult N_API NLAttributesSetTokenImageRect(HNLAttributes hAttributes, const struct NRect_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
const struct NRect_ * pValue | [in] Rectangle of token face image.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetUnnaturalSkinToneConfidence Function

NLAttributesSetUnnaturalSkinToneConfidence Function
NLAttributes.h

Sets the unnatural skin tone confidence value.

C++
NResult N_API NLAttributesSetUnnaturalSkinToneConfidence(HNLAttributes hAttributes, NByte value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte value | [in] The unnatural skin tone confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetWashedOutConfidence Function

NLAttributesSetWashedOutConfidence Function
NLAttributes.h

Sets the washed out confidence value.

C++
NResult N_API NLAttributesSetWashedOutConfidence(HNLAttributes hAttributes, NByte value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NByte value | [in] The washed out confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributesSetYaw Function

NLAttributesSetYaw Function
NLAttributes.h

Sets the yaw value for the specified NLAttributes.

C++
NResult N_API NLAttributesSetYaw(HNLAttributes hAttributes, NFloat value);
Collapse Expand Parameters
Parameters | Description
HNLAttributes hAttributes | [in] Handle to NLAttributes object.
NFloat value | [in] New yaw value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLAttributes.h

Module: NLAttributes Unit


NLAttributes.h

NLAttributes.h
Functions Legend

Header file for the NLAttributes Unit.

Collapse Expand Functions
Name | Description
NLAttributesAddFeaturePoint | Adds a feature point to the specified NLAttributes.
NLAttributesClearFeaturePoints | Removes all feature points from the specified NLAttributes.
NLAttributesCreate | Creates NLAttributes.
NLAttributesGetAdditionalFacesDetected | Gets if any additional faces were detected.
NLAttributesGetAge | Gets age value.
NLAttributesGetBackgroundUniformity | Retrieves the background uniformity value of the specified NLAttributes.
NLAttributesGetBaseFrameIndex | Gets the base frame index of the specified NLAttributes.
NLAttributesGetBeardConfidence | Gets the beard confidence value.
NLAttributesGetBlinkConfidence | Retrieves the blink confidence value of the specified NLAttributes.
NLAttributesGetBoundingRect | ... more
NLAttributesGetContrast | Gets contrast value.
NLAttributesGetDarkGlassesConfidence | Retrieves the dark glasses confidence value of the specified NLAttributes.
NLAttributesGetEmotionAngerConfidence | Retrieves anger confidence value of the specified NLAttributes.
NLAttributesGetEmotionContemptConfidence | Gets emotion contempt confidence value.
NLAttributesGetEmotionDisgustConfidence | Retrieves disgust confidence value of the specified NLAttributes.
NLAttributesGetEmotionFearConfidence | Retrieves fear confidence value of the specified NLAttributes.
NLAttributesGetEmotionHappinessConfidence | Retrieves happiness confidence value of the specified NLAttributes.
NLAttributesGetEmotionNeutralConfidence | Retrieves neutral emotion confidence value of the specified NLAttributes.
NLAttributesGetEmotionSadnessConfidence | Retrieves sadness confidence value of the specified NLAttributes.
NLAttributesGetEmotionSurpriseConfidence | Retrieves surprise confidence value of the specified NLAttributes.
NLAttributesGetEthnicityArabianConfidence | Gets the ethnicity Arabian confidence value.
NLAttributesGetEthnicityAsianConfidence | Gets the ethnicity Asian confidence value.
NLAttributesGetEthnicityBlackConfidence | Gets the ethnicity Black confidence value.
NLAttributesGetEthnicityHispanicConfidence | Gets the ethnicity Hispanic confidence value.
NLAttributesGetEthnicityIndianConfidence | Gets the ethnicity Indian confidence value.
NLAttributesGetEthnicityWhiteConfidence | Gets the ethnicity White confidence value.
NLAttributesGetExpression | Gets the expression value of the specified NLAttributes.
NLAttributesGetExpressionConfidence | Retrieves expression confidence value of the specified NLAttributes.
NLAttributesGetFaceDarknessConfidence | Gets the face darkness confidence value.
NLAttributesGetFaceMaskConfidence | Gets the face mask confidence value.
NLAttributesGetFeaturePoint | Retrieves the feature point specified by index.
NLAttributesGetFeaturePointCapacity | Retrieves the feature point capacity of the specified NLAttributes.
NLAttributesGetFeaturePointCount | Retrieves the number of feature points in the specified NLAttributes.
NLAttributesGetFeaturePoints | Retrieves the feature points of the specified NLAttributes.
NLAttributesGetGender | Retrieves the gender value of the specified NLAttributes.
NLAttributesGetGenderConfidence | Retrieves the gender confidence value of the specified NLAttributes.
NLAttributesGetGlassesConfidence | Retrieves the glasses confidence value of the specified NLAttributes.
NLAttributesGetGlassesReflectionConfidence | Gets the glasses reflection confidence value.
NLAttributesGetGrayscaleDensity | Retrieves the grayscale density value of the specified NLAttributes.
NLAttributesGetHatConfidence | Gets the hat confidence value.
NLAttributesGetHeavyFrameConfidence | Gets the heavy frame eyeglasses confidence value.
NLAttributesGetIcaoWarnings | Gets Icao warnings.
NLAttributesGetLeftEyeCenter | Retrieves the center of the left eye of the specified NLAttributes.
NLAttributesGetLivenessAction | Retrieves a liveness detection action.
NLAttributesGetLivenessScore | Retrieves the liveness score of the face.
NLAttributesGetLivenessTargetPitch | Gets liveness target pitch angle.
NLAttributesGetLivenessTargetYaw | Retrieves liveness detection yaw rotation angle.
NLAttributesGetLookingAwayConfidence | Gets the looking away confidence value.
NLAttributesGetMocTemplate | Gets Match-on-Card face template, if engine was configured to extract it.
NLAttributesGetMouthCenter | Retrieves the center of the mouth of the specified NLAttributes.
NLAttributesGetMouthOpenConfidence | Retrieves the mouth open confidence value of the specified NLAttributes.
NLAttributesGetMustacheConfidence | Gets the mustache confidence value.
NLAttributesGetNoise | Gets image noise value.
NLAttributesGetNoseTip | Retrieves the center of the nose tip of the specified NLAttributes.
NLAttributesGetPitch | ... more
NLAttributesGetPixelationConfidence | Gets the pixelation confidence value.
NLAttributesGetProperties | Retrieves the properties of the specified NLAttributes.
NLAttributesGetRedEyeConfidence | Gets the red eye confidence value.
NLAttributesGetRightEyeCenter | Retrieves the center of the right eye of the specified NLAttributes.
NLAttributesGetRoll | ... more
NLAttributesGetSaturation | Gets the saturation value of the specified NLAttributes.
NLAttributesGetSharpness | Retrieves the sharpness value of the specified NLAttributes.
NLAttributesGetSkinReflectionConfidence | Gets the skin reflection confidence value.
NLAttributesGetTemplate | Retrieves the biometric template of the specified NLAttributes.
NLAttributesGetThumbnail | Gets the thumbnail image of the specified NLAttributes.
NLAttributesGetTokenImageRect | Gets rectangle of token face image.
NLAttributesGetUnnaturalSkinToneConfidence | Gets the unnatural skin tone confidence value.
NLAttributesGetWashedOutConfidence | Gets the washed out confidence value.
NLAttributesGetYaw | ... more
NLAttributesInsertFeaturePoint | Adds a feature point to the specified NLAttributes at the specified index.
NLAttributesRemoveFeaturePointAt | Removes the specified feature point from the specified NLAttributes.
NLAttributesSetAdditionalFacesDetected | Sets if any additional faces were detected.
NLAttributesSetAge | Sets age value.
NLAttributesSetBackgroundUniformity | Sets the background uniformity value for the specified NLAttributes.
NLAttributesSetBaseFrameIndex | Sets the base frame index for the specified NLAttributes.
NLAttributesSetBeardConfidence | Sets the beard confidence value.
NLAttributesSetBlinkConfidence | Sets the blink confidence value for the specified NLAttributes.
NLAttributesSetBoundingRect | Sets the bounding rectangle that completely encloses the face in the image.
NLAttributesSetContrast | Sets contrast value.
NLAttributesSetDarkGlassesConfidence | Sets the dark glasses confidence value for the specified NLAttributes.
NLAttributesSetEmotionAngerConfidence | Sets anger confidence value for the specified NLAttributes.
NLAttributesSetEmotionContemptConfidence | Sets emotion contempt confidence value.
NLAttributesSetEmotionDisgustConfidence | Sets disgust confidence value for the specified NLAttributes.
NLAttributesSetEmotionFearConfidence | Sets fear confidence value for the specified NLAttributes.
NLAttributesSetEmotionHappinessConfidence | Sets happiness confidence value for the specified NLAttributes.
NLAttributesSetEmotionNeutralConfidence | Sets neutral emotion confidence value for the specified NLAttributes.
NLAttributesSetEmotionSadnessConfidence | Sets sadness confidence value for the specified NLAttributes.
NLAttributesSetEmotionSurpriseConfidence | Sets surprise emotion confidence value for the specified NLAttributes.
NLAttributesSetEthnicityArabianConfidence | Sets the ethnicity Arabian confidence value.
NLAttributesSetEthnicityAsianConfidence | Sets the ethnicity Asian confidence value.
NLAttributesSetEthnicityBlackConfidence | Sets the ethnicity Black confidence value.
NLAttributesSetEthnicityHispanicConfidence | Sets the ethnicity Hispanic confidence value.
NLAttributesSetEthnicityIndianConfidence | Sets the ethnicity Indian confidence value.
NLAttributesSetEthnicityWhiteConfidence | Sets the ethnicity White confidence value.
NLAttributesSetExpression | Sets the expression value of the specified NLAttributes.
NLAttributesSetExpressionConfidence | Sets expression confidence value for the specified NLAttributes.
NLAttributesSetFaceDarknessConfidence | Sets the face darkness confidence value.
NLAttributesSetFaceMaskConfidence | Sets the face mask confidence value.
NLAttributesSetFeaturePoint | Sets the value of the specified feature point for the specified NLAttributes.
NLAttributesSetFeaturePointCapacity | Sets feature point capacity for the specified NLAttributes.
NLAttributesSetGender | Sets the gender value for the specified NLAttributes.
NLAttributesSetGenderConfidence | Sets the gender confidence value for the specified NLAttributes.
NLAttributesSetGlassesConfidence | Sets the glasses confidence value for the specified NLAttributes.
NLAttributesSetGlassesReflectionConfidence | Sets the glasses reflection confidence value.
NLAttributesSetGrayscaleDensity | Sets the grayscale density value for the specified NLAttributes.
NLAttributesSetHatConfidence | Sets the hat confidence value for the specified NLAttributes.
NLAttributesSetHeavyFrameConfidence | Sets the heavy frame eyeglasses confidence value.
NLAttributesSetIcaoWarnings | Sets Icao warnings.
NLAttributesSetLeftEyeCenter | Sets the center of the left eye for the specified NLAttributes.
NLAttributesSetLookingAwayConfidence | Sets the looking away confidence value.
NLAttributesSetMouthCenter | Sets the center of the mouth for the specified NLAttributes.
NLAttributesSetMouthOpenConfidence | Sets the confidence value of mouth opened for the specified NLAttributes.
NLAttributesSetMustacheConfidence | Sets the mustache confidence value for the specified NLAttributes.
NLAttributesSetNoise | Sets image noise value.
NLAttributesSetNoseTip | Sets the center of the nose tip for the specified NLAttributes.
NLAttributesSetPitch | Sets the pitch value for the specified NLAttributes.
NLAttributesSetPixelationConfidence | Sets the pixelation confidence value.
NLAttributesSetProperties | Sets the properties of the specified NLAttributes.
NLAttributesSetRedEyeConfidence | Sets the red eye confidence value.
NLAttributesSetRightEyeCenter | Sets the center of the right eye for the specified NLAttributes.
NLAttributesSetRoll | Sets the roll value for the specified NLAttributes.
NLAttributesSetSaturation | Sets the saturation value of the specified NLAttributes.
NLAttributesSetSharpness | Sets the sharpness value of the specified NLAttributes.
NLAttributesSetSkinReflectionConfidence | Sets the skin reflection confidence value.
NLAttributesSetTemplate | Sets the biometric template of the specified NLAttributes.
NLAttributesSetThumbnail | Sets the thumbnail image for the specified NLAttributes.
NLAttributesSetTokenImageRect | Sets rectangle of token face image.
NLAttributesSetUnnaturalSkinToneConfidence | Sets the unnatural skin tone confidence value.
NLAttributesSetWashedOutConfidence | Sets the washed out confidence value.
NLAttributesSetYaw | Sets the yaw value for the specified NLAttributes.


NLMatchingDetails Unit

NLMatchingDetails Unit
Files

Provides functionality to retrieve face templates matching details.

Collapse Expand Remarks

NLMatchingDetails inherit all functions from NXMatchingDetails and NMatchingDetailsBase.

Collapse Expand Files
Name | Description
NLMatchingDetails.h | Header file of NLMatchingDetails.


NLMatchingDetails.h

NLMatchingDetails.h

Header file of NLMatchingDetails.


NLRecord Unit

NLRecord Unit
Files Functions Legend

Provides functionality for packing, unpacking and editing Neurotechnology Face Records (NLRecords).

Collapse Expand Files
Name | Description
NLRecord.h | ... more
Collapse Expand Functions
Name | Description
NLRecordCheck | Checks whether packed NLRecord is valid.
NLRecordCreate | Creates an empty NLRecord.
NLRecordCreateFromMemory | Unpacks NLRecord from the specified memory buffer.
NLRecordGetCbeffProductType | Retrieves the Cbeff product type of the NLRecord.
NLRecordCreateFromNLRecord | Creates NLRecord from other NLRecord object.
NLRecordGetQuality | Retrieves the quality of the NLRecord.
NLRecordGetCbeffProductTypeMem | Retrieves the Cbeff product type of the packed NLRecord.
NLRecordGetQualityMem | Retrieves the quality of the packed NLRecord.
NLRecordSetCbeffProductType | Sets the Cbeff product type.
NLRecordGetSizeMem | Retrieves the image size of the packed NLRecord.
NLRecordSetQuality | Sets the quality of the NLRecord.
HNLRecord | Handle to NERecord object.


NLRecordCheck Function

NLRecordCheck Function
NLRecord.h

Checks whether packed NLRecord is valid.

C++
NResult N_API NLRecordCheck(const void * pBuffer, NSizeType bufferSize);
Collapse Expand Parameters
Parameters | Description
const void * pBuffer | [in] Pointer to memory buffer that contains packed NLRecord.
NSizeType bufferSize | [in] Size of memory buffer that contains packed NLRecord.
Collapse Expand Returns

If the function succeeds, the return value is N_OK.

Container

File: NLRecord.h

Module: NLRecord Unit


NLRecordCreate Function

NLRecordCreate Function
NLRecord.h

Creates an empty NLRecord.

C++
NResult N_API NLRecordCreate(NUInt flags, HNLRecord * phRecord);
Collapse Expand Parameters
Parameters | Description
NUInt flags | [in] Bitwise combination of zero or more flags that controls behavior of the function. This parameter is reserved, must be zero.
HNLRecord * phRecord | [out] Pointer to HNLRecord that receives handle to created NLRecord object.
Collapse Expand Returns

If the function succeeds, the return value is N_OK.

If the function fails, the return value is one of the following error codes:

Error code | Condition
N_E_ARGUMENT_NULL | pHRecord is NULL.
N_E_OUT_OF_MEMORY | There was not enough memory.
Collapse Expand Remarks

Created object must be deleted using NObjectUnref function.

Container

File: NLRecord.h

Module: NLRecord Unit


NLRecordCreateFromMemory Function

NLRecordCreateFromMemory Function
NLRecord.h

Unpacks NLRecord from the specified memory buffer.

C++
NResult N_API NLRecordCreateFromMemory(const void * pBuffer, NSizeType bufferSize, NUInt flags, NSizeType * pSize, HNLRecord * phRecord);
Collapse Expand Parameters
Parameters | Description
const void * pBuffer | [in] Pointer to memory buffer that contains packed NLRecord.
NSizeType bufferSize | [in] Size of memory buffer that contains packed NLRecord.
NUInt flags | [in] Bitwise combination of zero or more flags that controls behavior of the function.
NSizeType * pSize | [out] Actual size of data read from pBuffer (bytes).
HNLRecord * phRecord | [out] Pointer to HNLRecord that receives handle to newly created NLRecord object.
Collapse Expand Returns

If the function succeeds, the return value is N_OK.

If the function fails, the return value is one of the following error codes:

Error code | Condition
N_E_ARGUMENT_NULL | pHRecord or buffer is NULL.
N_E_END_OF_STREAM | bufferSize is less than expected.
N_E_FORMAT | Data in memory buffer buffer points to is inconsistent with NLRecord format.
N_E_OUT_OF_MEMORY | There was not enough memory.
Collapse Expand Remarks

Created object must be deleted using NObjectUnref function.

Container

File: NLRecord.h

Module: NLRecord Unit


NLRecordGetCbeffProductType Function

NLRecordGetCbeffProductType Function
NLRecord.h

Retrieves the Cbeff product type of the NLRecord.

C++
NResult N_API NLRecordGetCbeffProductType(HNLRecord hRecord, NUShort * pValue);
Collapse Expand Parameters
Parameters | Description
HNLRecord hRecord | [in] Handle of NLRecord to retrieve its Cbeff type.
NUShort * pValue | [out] Type value.
Collapse Expand Returns

If the function succeeds, the return value is N_OK.

If the function fails, the return value is one of the following error codes:

Error code | Condition
N_E_ARGUMENT_NULL | hRecord or pValue is NULL.
Container

File: NLRecord.h

Module: NLRecord Unit


NLRecordCreateFromNLRecord Function

NLRecordCreateFromNLRecord Function
NLRecord.h

Creates NLRecord from other NLRecord object.

C++
NResult N_API NLRecordCreateFromNLRecord(HNLRecord hSrcRecord, NTemplateSize dstTemplateSize, NUInt flags, HNLRecord * phDstRecord);
Collapse Expand Parameters
Parameters | Description
HNLRecord hSrcRecord | [in] Pointer to memory buffer that contains packed NLRecord.
NTemplateSize dstTemplateSize | [in] Size of destination template phDstRecord.
NUInt flags | [in] Bitwise combination of zero or more flags that controls behavior of the function.
HNLRecord * phDstRecord | [out] Pointer to NLRecord containing data to copy.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLRecord.h

Module: NLRecord Unit


NLRecordGetQuality Function

NLRecordGetQuality Function
NLRecord.h

Retrieves the quality of the NLRecord.

C++
NResult N_API NLRecordGetQuality(HNLRecord hRecord, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNLRecord hRecord | [in] Handle to the NLRecord object.
NByte * pValue | [out] Pointer to NByte that receives face quality. Quality value can be interval [0; 100], 254 (quality was not calculated) and 255 (failed to calculate quality value).
Collapse Expand Returns

If the function succeeds, the return value is N_OK.

If the function fails, the return value is one of the following error codes:

Error code | Condition
N_E_ARGUMENT_NULL | hRecord or pValue is NULL.
Container

File: NLRecord.h

Module: NLRecord Unit


NLRecordGetCbeffProductTypeMem Function

NLRecordGetCbeffProductTypeMem Function
NLRecord.h

Retrieves the Cbeff product type of the packed NLRecord.

C++
NResult N_API NLRecordGetCbeffProductTypeMem(const void * pBuffer, NSizeType bufferSize, NUShort * pValue);
Collapse Expand Parameters
Parameters | Description
const void * pBuffer | [out] Pointer to memory buffer that contains packed NLRecord.
NSizeType bufferSize | [in] Size of memory buffer that contains packed NLRecord.
NUShort * pValue | [out] Pointer to NUShort that receives Cbeff product type.
Collapse Expand Returns

If the function succeeds, the return value is N_OK.

If the function fails, the return value is one of the following error codes:

Error code | Condition
N_E_ARGUMENT_NULL | hRecord is NULL.
Container

File: NLRecord.h

Module: NLRecord Unit


NLRecordGetQualityMem Function

NLRecordGetQualityMem Function
NLRecord.h

Retrieves the quality of the packed NLRecord.

C++
NResult N_API NLRecordGetQualityMem(const void * pBuffer, NSizeType bufferSize, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
const void * pBuffer | [in] Pointer to memory buffer that contains packed NLRecord.
NSizeType bufferSize | [in] Size of memory buffer that contains packed NLRecord.
NByte * pValue | [out] Pointer to NByte that receives face quality. Quality value can be interval [0; 100], 254 (quality was not calculated) and 255 (failed to calculate quality value).
Collapse Expand Returns

If the function succeeds, the return value is N_OK.

If the function fails, the return value is one of the following error codes:

Error code | Condition
N_E_ARGUMENT_NULL | buffer or pValue is NULL.
N_E_END_OF_STREAM | bufferSize is less than expected.
N_E_FORMAT | Data in memory buffer buffer points to is inconsistent with NLRecord format.
Collapse Expand Remarks

This function supports both NLRecord version 1.0, 2.0 and 3.0 formats. Always returns 0 for version 1.0 format.

Container

File: NLRecord.h

Module: NLRecord Unit


NLRecordSetCbeffProductType Function

NLRecordSetCbeffProductType Function
NLRecord.h

Sets the Cbeff product type.

C++
NResult N_API NLRecordSetCbeffProductType(HNLRecord hRecord, NUShort value);
Collapse Expand Parameters
Parameters | Description
HNLRecord hRecord | [in] Handle to the NLRecord object.
NUShort value | [in] Cbeff product type.
Collapse Expand Returns

If the function succeeds, the return value is N_OK.

If the function fails, the return value is one of the following error codes:

Error code | Condition
N_E_ARGUMENT_NULL | hRecord is NULL.
Container

File: NLRecord.h

Module: NLRecord Unit


NLRecordGetSizeMem Function

NLRecordGetSizeMem Function
NLRecord.h

Retrieves the image size of the packed NLRecord.

C++
NResult N_API NLRecordGetSizeMem(const void * pBuffer, NSizeType bufferSize, NSizeType * pValue);
Collapse Expand Parameters
Parameters | Description
const void * pBuffer | [in] Pointer to memory buffer that contains packed NLRecord.
NSizeType bufferSize | [in] Size of memory buffer that contains packed NLRecord.
NSizeType * pValue | [out] Pointer to NSizeType that receives size of face image.
Collapse Expand Returns

If the function succeeds, the return value is N_OK.

If the function fails, the return value is one of the following error codes:

Error code | Condition
N_E_ARGUMENT_NULL | buffer or pValue is NULL.
Container

File: NLRecord.h

Module: NLRecord Unit


NLRecordSetQuality Function

NLRecordSetQuality Function
NLRecord.h

Sets the quality of the NLRecord.

C++
NResult N_API NLRecordSetQuality(HNLRecord hRecord, NByte value);
Collapse Expand Parameters
Parameters | Description
HNLRecord hRecord | [in] Handle to the NLRecord object.
NByte value | [in] New face quality value. Quality value can be interval [0; 100], 254 (quality was not calculated) and 255 (failed to calculate quality value).
Collapse Expand Returns

If the function succeeds, the return value is N_OK.

If the function fails, the return value is one of the following error codes:

Error code | Condition
N_E_ARGUMENT_NULL | hRecord is NULL.
Container

File: NLRecord.h

Module: NLRecord Unit


HNLRecord

HNLRecord

Handle to NERecord object.


NLRecord.h

NLRecord.h
Functions Legend

Header file for the NLRecord. Provides functionality for packing, unpacking and editing Neurotechnology Face Records (NLRecords).

Collapse Expand Functions
Name | Description
NLRecordCheck | Checks whether packed NLRecord is valid.
NLRecordCreate | Creates an empty NLRecord.
NLRecordCreateFromMemory | Unpacks NLRecord from the specified memory buffer.
NLRecordCreateFromNLRecord | Creates NLRecord from other NLRecord object.
NLRecordGetCbeffProductType | Retrieves the Cbeff product type of the NLRecord.
NLRecordGetCbeffProductTypeMem | Retrieves the Cbeff product type of the packed NLRecord.
NLRecordGetQuality | Retrieves the quality of the NLRecord.
NLRecordGetQualityMem | Retrieves the quality of the packed NLRecord.
NLRecordGetSizeMem | Retrieves the image size of the packed NLRecord.
NLRecordSetCbeffProductType | Sets the Cbeff product type.
NLRecordSetQuality | Sets the quality of the NLRecord.


NLTemplate Unit

NLTemplate Unit
Files Functions Legend Macros

Provides functionality for packing, unpacking and editing Neurotechnology Faces Templates (NLTemplates).

Collapse Expand Files
Name | Description
NLTemplate.h | ... more
Collapse Expand Functions
Name | Description
NLTemplateAddRecordEx | Adds a face record to the NLTemplate.
NLTemplateCalculateSize | Calculates the size of a packed NLTemplate containing the specified number of face records of specified size.
NLTemplateCheck | Checks if format of the packed NLTemplate is correct.
NLTemplateClearRecords | Removes all face records from the NLTemplate.
NLTemplateCreateFromMemory | Unpacks a NLTemplate from the specified memory buffer.
NLTemplateCreateEx | Creates an empty NLTemplate.
NLTemplateGetRecordCountMem | Retrieves the number of face records in the packed NLTemplate.
NLTemplateGetRecordCapacity | Retrieves the number of face records that the NLTemplate can contain..
NLTemplateGetRecordEx | Retrieves the face record at the specified index of the NLTemplate.
NLTemplateGetRecordCount | Retrieves the number of face records in the NLTemplate.
NLTemplateGetSizeMem | Retrieves the image size of the packed NLTemplate.
NLTemplateInsertRecord | Inserts the specified NLRecord to the specified NLTemplate at the specified index.
NLTemplatePack | Packs packed face records as NLTemplate into the specified memory buffer.
NLTemplateRemoveRecordAt | Removed record at specified index.
NLTemplateSetRecord | Sets the value of the specified NLRecord to the specified value.
NLTemplateUnpack | Unpacks packed face records from the packed NLTemplate.
NLTemplateSetRecordCapacity | Sets the number of face records that the NLTemplate can contain.
HNLTemplate | Handle to the NLTemplate object.
Collapse Expand Macros
Name | Description
NLT_MAX_RECORD_COUNT | The maximum number of face records NLTemplate can contain.
NLT_PROCESS_FIRST_RECORD_ONLY | ... more


NLTemplateAddRecordEx Function

NLTemplateAddRecordEx Function
NLTemplate.h

Adds a face record to the NLTemplate.

C++
NResult N_API NLTemplateAddRecordEx(HNLTemplate hTemplate, HNLRecord hValue, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
HNLTemplate hTemplate | [in] Handle to the NLTemplate object.
HNLRecord hValue | [in] A handle to the face record to be added.
NInt * pIndex | [out] A pointer to the index of the new record.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLTemplate.h

Module: NLTemplate Unit


NLTemplateCalculateSize Function

NLTemplateCalculateSize Function
NLTemplate.h

Calculates the size of a packed NLTemplate containing the specified number of face records of specified size.

C++
NResult N_API NLTemplateCalculateSize(NInt recordCount, NSizeType * arRecordSizes, NSizeType * pSize);
Collapse Expand Parameters
Parameters | Description
NInt recordCount | [in] The number of face records.
NSizeType * arRecordSizes | [out] Pointer to array of NSizeTypethat contains packed sizes of each face record.
NSizeType * pSize | [out] Pointer to NSizeType that receives calculated size of packed NLTemplate.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. If the function fails, the return value is one of the following error codes:

Error code | Condition
N_E_ARGUMENT | Any entry of the array arRecordSizes points to is less than minimal face record size.
N_E_ARGUMENT_NULL | arRecordSizes or pSize is NULL.
N_E_ARGUMENT_OUT_OF_RANGE | recordCount is less than zero or greater than NLT_MAX_RECORD_COUNT.
Collapse Expand Remarks

This is a low-level function and can be changed in future version of the library.

Use NLRecordGetMaxSize function to calculate packed size of an individual face record.

Container

File: NLTemplate.h

Module: NLTemplate Unit


NLTemplateCheck Function

NLTemplateCheck Function
NLTemplate.h

Checks if format of the packed NLTemplate is correct.

C++
NResult N_API NLTemplateCheck(const void * pBuffer, NSizeType bufferSize);
Collapse Expand Parameters
Parameters | Description
const void * pBuffer | [in] Pointer to memory buffer that contains packed NLTemplate.
NSizeType bufferSize | [in] Size of memory buffer that contains packed NLTemplate.
Collapse Expand Returns

If the function succeeds, the return value is N_OK.

If the function fails, the return value is one of the following error codes:

Error code | Condition
N_E_ARGUMENT_NULL | buffer is NULL.
N_E_END_OF_STREAM | bufferSize is less than expected.
N_E_FORMAT | Data in memory buffer buffer points to is inconsistent with NLTemplate format.
Container

File: NLTemplate.h

Module: NLTemplate Unit


NLTemplateClearRecords Function

NLTemplateClearRecords Function
NLTemplate.h

Removes all face records from the NLTemplate.

C++
NResult N_API NLTemplateClearRecords(HNLTemplate hTemplate);
Collapse Expand Parameters
Parameters | Description
HNLTemplate hTemplate | [in] Handle to the NLTemplate object.
Collapse Expand Returns

If the function succeeds, the return value is N_OK.

If the function fails, the return value is one of the following error codes:

Error code | Condition
N_E_ARGUMENT_NULL | hTemplate is NULL.
Container

File: NLTemplate.h

Module: NLTemplate Unit


NLTemplateCreateFromMemory Function

NLTemplateCreateFromMemory Function
NLTemplate.h

Unpacks a NLTemplate from the specified memory buffer.

C++
NResult N_API NLTemplateCreateFromMemory(const void * pBuffer, NSizeType bufferSize, NUInt flags, NSizeType * pSize, HNLTemplate * phTemplate);
Collapse Expand Parameters
Parameters | Description
const void * pBuffer | [in] Pointer to memory buffer that contains packed NLTemplate.
NSizeType bufferSize | [in] Size of memory buffer that contains packed NLTemplate.
NUInt flags | [in] Bitwise combination of zero or more flags that controls behavior of the function.
NSizeType * pSize | [out] Actual size of data read from pBuffer (bytes).
HNLTemplate * phTemplate | [out] Pointer to HNLTemplate that receives handle to newly created NLTemplate object.
Collapse Expand Returns

If the function succeeds, the return value is N_OK.

If the function fails, the return value is one of the following error codes:

Error code | Condition
N_E_ARGUMENT_NULL | phTemplate or buffer is NULL.
N_E_END_OF_STREAM | bufferSize is less than expected.
N_E_FORMAT | Data in memory buffer buffer points to is inconsistent with NLTemplate format.
N_E_OUT_OF_MEMORY | There was not enough memory.
Collapse Expand Remarks

The following flags are supported:

  • NLT_PROCESS_FIRST_RECORD_ONLY.

Flags supported by NLRecordCreateFromMemory function are applied to each face record contained in the NLTemplate.

Created object must be deleted using NObjectUnref function.

Container

File: NLTemplate.h

Module: NLTemplate Unit


NLTemplateCreateEx Function

NLTemplateCreateEx Function
NLTemplate.h

Creates an empty NLTemplate.

C++
NResult N_API NLTemplateCreateEx(NUInt flags, HNLTemplate * phTemplate);
Collapse Expand Parameters
Parameters | Description
NUInt flags | [in] Bitwise combination of zero or more flags that controls behavior of the function. This parameter is reserved, must be zero.
HNLTemplate * phTemplate | [out] Pointer to HNLTemplate that receives handle to created NLTemplate object.
Collapse Expand Returns

If the function succeeds, the return value is N_OK.

If the function fails, the return value is one of the following error codes:

Error code | Condition
N_E_ARGUMENT_NULL | phTemplate is NULL.
N_E_OUT_OF_MEMORY | There was not enough memory.
Collapse Expand Remarks

Created object must be deleted using NObjectUnref function.

Container

File: NLTemplate.h

Module: NLTemplate Unit


NLTemplateGetRecordCountMem Function

NLTemplateGetRecordCountMem Function
NLTemplate.h

Retrieves the number of face records in the packed NLTemplate.

C++
NResult N_API NLTemplateGetRecordCountMem(const void * pBuffer, NSizeType bufferSize, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
const void * pBuffer | [in] Pointer to memory buffer that contains packed NLTemplate.
NSizeType bufferSize | [in] Size of memory buffer that contains packed NLTemplate.
NInt * pValue | [out] Pointer to NInt that receives number of face records.
Collapse Expand Returns

If the function succeeds, the return value is N_OK.

If the function fails, the return value is one of the following error codes:

Error code | Condition
N_E_ARGUMENT_NULL | buffer or pValue is NULL.
N_E_END_OF_STREAM | bufferSize is less than expected.
N_E_FORMAT | Data in memory buffer buffer points to is inconsistent with NLTemplate format.
Container

File: NLTemplate.h

Module: NLTemplate Unit


NLTemplateGetRecordCapacity Function

NLTemplateGetRecordCapacity Function
NLTemplate.h

Retrieves the number of face records that the NLTemplate can contain..

C++
NResult N_API NLTemplateGetRecordCapacity(HNLTemplate hTemplate, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNLTemplate hTemplate | [in] Handle to the NLTemplate object.
NInt * pValue | [out] Pointer to NInt that receives number of face records NLTemplate can contain.
Collapse Expand Returns

If the function succeeds, the return value is N_OK.

If the function fails, the return value is one of the following error codes:

Error code | Condition
N_E_ARGUMENT_NULL | hTemplate or pValue is NULL.
Collapse Expand Remarks

Face record capacity is the number of face records that the NLTemplate can store. Face record count (see NLTemplateGetRecordCount function) is the number of face records that are actually in the NLTemplate.

Capacity is always greater than or equal to count. If count exceeds capacity while adding face records the capacity is automatically increased by reallocating the internal array before copying the old elements and adding the new elements.

Container

File: NLTemplate.h

Module: NLTemplate Unit


NLTemplateGetRecordEx Function

NLTemplateGetRecordEx Function
NLTemplate.h

Retrieves the face record at the specified index of the NLTemplate.

C++
NResult N_API NLTemplateGetRecordEx(HNLTemplate hTemplate, NInt index, HNLRecord * phValue);
Collapse Expand Parameters
Parameters | Description
HNLTemplate hTemplate | [in] Handle to the NLTemplate object.
NInt index | [in] Index of face record to retrieve.
HNLRecord * phValue | [out] Pointer to HNLRecord that receives handle to NLRecord object.
Collapse Expand Returns

If the function succeeds, the return value is N_OK.

If the function fails, the return value is one of the following error codes:

Error code | Condition
N_E_ARGUMENT_NULL | hTemplate or phValue is NULL.
N_E_ARGUMENT_OUT_OF_RANGE | index is less than zero or greater than or equal to face record count obtained using NLTemplateGetRecordCount function.
Container

File: NLTemplate.h

Module: NLTemplate Unit


NLTemplateGetRecordCount Function

NLTemplateGetRecordCount Function
NLTemplate.h

Retrieves the number of face records in the NLTemplate.

C++
NResult N_API NLTemplateGetRecordCount(HNLTemplate hTemplate, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNLTemplate hTemplate | [in] Handle to NLTemplate object.
NInt * pValue | [out] Pointer to NInt that receives number of face records.
Collapse Expand Returns

If the function succeeds, the return value is N_OK.

If the function fails, the return value is one of the following error codes:

Error code | Condition
N_E_ARGUMENT_NULL | hTemplate or pValue is NULL.
Collapse Expand Remarks

Face record capacity (see NLTemplateGetRecordCapacity and NLTemplateSetRecordCapacity functions) is the number of face records that the NLTemplate can store. Face record count is the number of face records that are actually in the NLTemplate.

Capacity is always greater than or equal to count. If count exceeds capacity while adding face records the capacity is automatically increased by reallocating the internal array before copying the old elements and adding the new elements.

Container

File: NLTemplate.h

Module: NLTemplate Unit


NLTemplateGetSizeMem Function

NLTemplateGetSizeMem Function
NLTemplate.h

Retrieves the image size of the packed NLTemplate.

C++
NResult N_API NLTemplateGetSizeMem(const void * pBuffer, NSizeType bufferSize, NSizeType * pValue);
Collapse Expand Parameters
Parameters | Description
const void * pBuffer | [in] Pointer to memory buffer that contains packed NLTemplate.
NSizeType bufferSize | [in] Size of memory buffer that contains packed NFTemplate.
NSizeType * pValue | [out] Pointer to NSizeType that receives size of face image template.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLTemplate.h

Module: NLTemplate Unit


NLTemplateInsertRecord Function

NLTemplateInsertRecord Function
NLTemplate.h

Inserts the specified NLRecord to the specified NLTemplate at the specified index.

C++
NResult N_API NLTemplateInsertRecord(HNLTemplate hTemplate, NInt index, HNLRecord hValue);
Collapse Expand Parameters
Parameters | Description
HNLTemplate hTemplate | [in] A handle to the NLTemplate.
NInt index | [in] Index at which the record is to be inserted.
HNLRecord hValue | [in] A handle to the NLRecord to be inserted.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLTemplate.h

Module: NLTemplate Unit


NLTemplatePack Function

NLTemplatePack Function
NLTemplate.h

Packs packed face records as NLTemplate into the specified memory buffer.

C++
NResult N_API NLTemplatePack(NInt recordCount, const void * * arpRecords, NSizeType * arRecordSizes, void * pBuffer, NSizeType bufferSize, NSizeType * pSize);
Collapse Expand Parameters
Parameters | Description
NInt recordCount | [in] Number of records to be packed.
const void * * arpRecords | [in] Pointer to array of void * that contains packed face records.
NSizeType * arRecordSizes | [out] Pointer to array of NSizeType that contains packed sizes of each face record.
void * pBuffer | [out] Pointer to memory buffer to store packed NLTemplate. If NULL is passed as a parameter an error occurs. To get buffer size use NLTemplateCalculateSize or NLTemplateGetSize functions.
NSizeType bufferSize | [in] Size of memory buffer to store packed NTemplate.
NSizeType * pSize | [out] Pointer to NSizeType that receives size of packed NTemplate.
Collapse Expand Returns

If the function succeeds, the return value is N_OK.

If the function fails, the return value is one of the following error codes:

Error code | Condition
N_E_ARGUMENT_NULL | arRecordSizes, recordCount, pBuffer or pSize is NULL.
N_E_ARGUMENT | bufferSize is less than size required to store packed NLTemplate. - or - Any entry of the array arRecordSizes points to is less than minimal face record size. - or - Any entry of the array arpRecords points to is NULL. - or - Any entry of the array arRecordSizes points to is not equal to size stored in memory buffer according entry of the array arpRecords points to, points to.
N_E_ARGUMENT_OUT_OF_RANGE | recordCount is less than zero or greater than NLT_MAX_RECORD_COUNT.
N_E_FORMAT | Data in memory buffer any entry of the array arpRecords points to is inconsistent with NLRecord format.
Collapse Expand Remarks

bufferSize must not be less than value calculated with NTemplateCalculateSize function with the same parameter values.

Container

File: NLTemplate.h

Module: NLTemplate Unit


NLTemplateRemoveRecordAt Function

NLTemplateRemoveRecordAt Function
NLTemplate.h

Removed record at specified index.

C++
NResult N_API NLTemplateRemoveRecordAt(HNLTemplate hTemplate, NInt index);
Collapse Expand Parameters
Parameters | Description
HNLTemplate hTemplate | [in] Handle to the NLTemplate object.
NInt index | [in] Position of a record to remove.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLTemplate.h

Module: NLTemplate Unit


NLTemplateSetRecord Function

NLTemplateSetRecord Function
NLTemplate.h

Sets the value of the specified NLRecord to the specified value.

C++
NResult N_API NLTemplateSetRecord(HNLTemplate hTemplate, NInt index, HNLRecord hValue);
Collapse Expand Parameters
Parameters | Description
HNLTemplate hTemplate | [in] Handle to the NLTemplate.
NInt index | [in] Index of the NLRecord to be set.
HNLRecord hValue | [in] The new NLRecord value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLTemplate.h

Module: NLTemplate Unit


NLTemplateUnpack Function

NLTemplateUnpack Function
NLTemplate.h

Unpacks packed face records from the packed NLTemplate.

C++
NResult N_API NLTemplateUnpack(const void * pBuffer, NSizeType bufferSize, NVersion_ * pVersion, NUInt * pSize, NByte * pHeaderSize, NInt * pRecordCount, const void * * arpRecords, NSizeType * arRecordSizes);
Collapse Expand Parameters
Parameters | Description
const void * pBuffer | [in] Pointer to memory buffer that contains packed NLTemplate.
NSizeType bufferSize | [in] Size of memory buffer that contains packed NLTemplate.
NVersion_ * pVersion | [out] Pointer to NByte that receives version of the packed NLTemplate. Can be NULL.
NUInt * pSize | [out] Pointer to NUInt that receives size of the packed NLTemplate. Can be NULL.
NByte * pHeaderSize | [out] Pointer to NByte that receives header size of the packed NLTemplate. Can be NULL.
NInt * pRecordCount | [out] Pointer to NInt that receives number of face records contained in the packed NLTemplate. Can be NULL.
const void * * arpRecords | [in] Pointer to array of void * that receives pointers to packed face records contained in the packed NLTemplate. Can be NULL.
NSizeType * arRecordSizes | [out] Pointer to array of NSizeType that receives sizes of packed face records contained in the packed NLTemplate. Can be NULL.
Collapse Expand Returns

If the function succeeds, the return value is N_OK.

If the function fails, the return value is one of the following error codes:

Error code | Condition
N_E_ARGUMENT_NULL | buffer is NULL.
N_E_END_OF_STREAM | bufferSize is less than expected.
N_E_FORMAT | Data in memory buffer buffer points to is inconsistent with NLTemplate format.
Collapse Expand Remarks

This is a low-level function and can be changed in future version of the library.

This function should be first called with arpRecords and arRecordSizes parameters set to NULL to receive face record count through pRecordCount parameter. Then arrays of face records count length should be allocated and this function should be called with these array passed in arpRecords and arRecordSizes parameters.

Container

File: NLTemplate.h

Module: NLTemplate Unit


NLTemplateSetRecordCapacity Function

NLTemplateSetRecordCapacity Function
NLTemplate.h

Sets the number of face records that the NLTemplate can contain.

C++
NResult N_API NLTemplateSetRecordCapacity(HNLTemplate hTemplate, NInt value);
Collapse Expand Parameters
Parameters | Description
HNLTemplate hTemplate | [in] Handle to the NLTemplate object.
NInt value | [in] New number of face records NLTemplate can contain.
Collapse Expand Returns

If the function succeeds, the return value is N_OK.

If the function fails, the return value is one of the following error codes:

Error code | Condition
N_E_ARGUMENT_NULL | hTemplate is NULL.
N_E_ARGUMENT_OUT_OF_RANGE | value is less than face record count obtained using NLTemplateGetRecordCount function.
Collapse Expand Remarks

Face record capacity is the number of face records that the NLTemplate can store. Face record count (see NLTemplateGetRecordCount function) is the number of face records that are actually in the NLTemplate.

Capacity is always greater than or equal to count. If count exceeds capacity while adding face records the capacity is automatically increased by reallocating the internal array before copying the old elements and adding the new elements.

Container

File: NLTemplate.h

Module: NLTemplate Unit


HNLTemplate

HNLTemplate

Handle to the NLTemplate object.


NLT_MAX_RECORD_COUNT Macro

NLT_MAX_RECORD_COUNT Macro
NLTemplate.h

The maximum number of face records NLTemplate can contain.

C++
#define NLT_MAX_RECORD_COUNT 255
Container

File: NLTemplate.h

Module: NLTemplate Unit


NLT_PROCESS_FIRST_RECORD_ONLY Macro

NLT_PROCESS_FIRST_RECORD_ONLY Macro
NLTemplate.h

The flag indicating whether only the first face record should be unpacked or packed while unpacking or packing NLTemplate.

C++
#define NLT_PROCESS_FIRST_RECORD_ONLY 0x00000100
Container

File: NLTemplate.h

Module: NLTemplate Unit


NLTemplate.h

NLTemplate.h
Functions Legend Macros

Header file for the NLTemplate. Provides functionality for packing, unpacking and editing Neurotechnology Faces Templates (NLTemplates).

Collapse Expand Functions
Name | Description
NLTemplateAddRecordEx | Adds a face record to the NLTemplate.
NLTemplateCalculateSize | Calculates the size of a packed NLTemplate containing the specified number of face records of specified size.
NLTemplateCheck | Checks if format of the packed NLTemplate is correct.
NLTemplateClearRecords | Removes all face records from the NLTemplate.
NLTemplateCreateEx | Creates an empty NLTemplate.
NLTemplateCreateFromMemory | Unpacks a NLTemplate from the specified memory buffer.
NLTemplateGetRecordCapacity | Retrieves the number of face records that the NLTemplate can contain..
NLTemplateGetRecordCount | Retrieves the number of face records in the NLTemplate.
NLTemplateGetRecordCountMem | Retrieves the number of face records in the packed NLTemplate.
NLTemplateGetRecordEx | Retrieves the face record at the specified index of the NLTemplate.
NLTemplateGetSizeMem | Retrieves the image size of the packed NLTemplate.
NLTemplateInsertRecord | Inserts the specified NLRecord to the specified NLTemplate at the specified index.
NLTemplatePack | Packs packed face records as NLTemplate into the specified memory buffer.
NLTemplateRemoveRecordAt | Removed record at specified index.
NLTemplateSetRecord | Sets the value of the specified NLRecord to the specified value.
NLTemplateSetRecordCapacity | Sets the number of face records that the NLTemplate can contain.
NLTemplateUnpack | Unpacks packed face records from the packed NLTemplate.
Collapse Expand Macros
Name | Description
NLT_MAX_RECORD_COUNT | The maximum number of face records NLTemplate can contain.
NLT_PROCESS_FIRST_RECORD_ONLY | ... more


NMatchingDetails Unit

NMatchingDetails Unit
Files Functions Legend

Provides functionality to retrieve Neurotechnology templates matching details (such as score, records count, etc.).

Collapse Expand Files
Name | Description
NMatchingDetails.h | ... more
Collapse Expand Functions
Name | Description
NMatchingDetailsCreateFromMemory | Creates NMatchingDetails from specified memory buffer.
NMatchingDetailsCreateFromMemoryN | Creates NMatchingDetails from specified memory buffer.
NMatchingDetailsCreateFromStream | Creates NMatchingDetails from specified stream.
NMatchingDetailsGetFaceCount | Gets face templates count in NMatchingDetails.
NMatchingDetailsGetFaceEx | Gets face matching details (NLMatchingDetails) from specified NMatchingDetails.
NMatchingDetailsGetFacesMatchedIndex | Gets index of matched face in the second matched NLTemplate (or NTemplate))
NMatchingDetailsGetFacesScore | Gets similarity score of two matched face templates (NLTemplate).
NMatchingDetailsGetFingerCount | Gets fingerprint templates count in NMatchingDetails.
NMatchingDetailsGetFingerEx | Gets fingerprint matching details (NFMatchingDetails) from specified NMatchingDetails.
NMatchingDetailsGetFingersScore | Gets similarity score of two matched fingerprint templates (NFTemplate).
NMatchingDetailsGetIrisCount | Gets iris templates count in NMatchingDetails.
NMatchingDetailsGetIrisEx | Gets iris matching details (NEMatchingDetails) from specified NMatchingDetails.
NMatchingDetailsGetIrisesScore | Gets similarity score of two matched iris templates (NETemplate).
NMatchingDetailsGetPalmCount | Gets palmprint templates count in NMatchingDetails.
NMatchingDetailsGetPalmEx | Gets palmprint matching details (NFMatchingDetails) from specified NMatchingDetails.
NMatchingDetailsGetPalmsScore | Gets similarity score of two matched palmprint templates (NFTemplate).
NMatchingDetailsGetVoiceCount | Gets voice templates count in NMatchingDetails.
NMatchingDetailsGetVoiceEx | Gets voice matching details (NSMatchingDetails) from specified NMatchingDetails.
NMatchingDetailsGetVoicesScore | Gets similarity score of two matched voice templates (NSTemplate).


NMatchingDetailsCreateFromMemory Function

NMatchingDetailsCreateFromMemory Function
NMatchingDetails.h

Creates NMatchingDetails from specified memory buffer.

C++
NResult N_API NMatchingDetailsCreateFromMemory(const void * pBuffer, NSizeType bufferSize, NUInt flags, NSizeType * pSize, HNMatchingDetails * phMatchingDetails);
Collapse Expand Parameters
Parameters | Description
const void * pBuffer | [in] Pointer to memory buffer that contains NMatchingDetails.
NSizeType bufferSize | [in] Size of memory buffer pBuffer.
NUInt flags | [in] Must be 0 (reserved for future use).
NSizeType * pSize | [out] Actual size of data read from pBuffer (bytes).
HNMatchingDetails * phMatchingDetails | [out] Pointer to HNMatchingDetails which received handle to newly created NMatchingDetails object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMatchingDetails.h

Module: NMatchingDetails Unit


NMatchingDetailsCreateFromMemoryN Function

NMatchingDetailsCreateFromMemoryN Function
NMatchingDetails.h

Creates NMatchingDetails from specified memory buffer.

C++
NResult N_API NMatchingDetailsCreateFromMemoryN(HNBuffer hBuffer, NUInt flags, NSizeType * pSize, HNMatchingDetails * phMatchingDetails);
Collapse Expand Parameters
Parameters | Description
HNBuffer hBuffer | [in] Handle to memory buffer that contains NMatchingDetails.
NUInt flags | [in] Must be 0 (reserved for future use).
NSizeType * pSize | [out] Actual size of data read from hBuffer (bytes).
HNMatchingDetails * phMatchingDetails | [out] Pointer to HNMatchingDetails which received handle to newly created NMatchingDetails object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMatchingDetails.h

Module: NMatchingDetails Unit


NMatchingDetailsCreateFromStream Function

NMatchingDetailsCreateFromStream Function
NMatchingDetails.h See Also

Creates NMatchingDetails from specified stream.

C++
NResult N_API NMatchingDetailsCreateFromStream(HNStream hStream, NUInt flags, HNMatchingDetails * phMatchingDetails);
Collapse Expand Parameters
Parameters | Description
HNStream hStream | [in] Handle to memory stream which contains matching details.
NUInt flags | [in] Must be 0 (reserved for future use).
HNMatchingDetails * phMatchingDetails | [out] Pointer to HNMatchingDetails which received handle to newly created NMatchingDetails object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand See Also

NMatchingDetailsCreateFromMemory

Container

File: NMatchingDetails.h

Module: NMatchingDetails Unit


NMatchingDetailsGetFaceCount Function

NMatchingDetailsGetFaceCount Function
NMatchingDetails.h See Also

Gets face templates count in NMatchingDetails.

C++
NResult N_API NMatchingDetailsGetFaceCount(HNMatchingDetails hMatchingDetails, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNMatchingDetails hMatchingDetails | [in] Handle to NMatchingDetails.
NInt * pValue | [out] Faces count in NMatchingDetails.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand See Also

NMatchingDetailsGetFacesScore

Container

File: NMatchingDetails.h

Module: NMatchingDetails Unit


NMatchingDetailsGetFaceEx Function

NMatchingDetailsGetFaceEx Function
NMatchingDetails.h

Gets face matching details (NLMatchingDetails) from specified NMatchingDetails.

C++
NResult N_API NMatchingDetailsGetFaceEx(HNMatchingDetails hMatchingDetails, NInt index, HNLMatchingDetails * phValue);
Collapse Expand Parameters
Parameters | Description
HNMatchingDetails hMatchingDetails | [in] Handle to NMatchingDetails.
NInt index | [in] Face index in NMatchingDetails (NLMatchingDetails will be returned for face template specified by index ). Index should be greater than 0 and less than face count in NMatchingDetails. Face count can be retrieved by calling NMatchingDetailsGetFaceCount function.
HNLMatchingDetails * phValue | [out] Pointer to HNLMatchingDetails which contains information about face templates matching (faces match result).
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMatchingDetails.h

Module: NMatchingDetails Unit


NMatchingDetailsGetFacesMatchedIndex Function

NMatchingDetailsGetFacesMatchedIndex Function
NMatchingDetails.h See Also

Gets index of matched face in the second matched NLTemplate (or NTemplate))

C++
NResult N_API NMatchingDetailsGetFacesMatchedIndex(HNMatchingDetails hMatchingDetails, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNMatchingDetails hMatchingDetails | [in] Handle to NMatchingDetails.
NInt * pValue | [out] Index of matched face in the second template.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand See Also

NMatchingDetailsGetFacesScore

Container

File: NMatchingDetails.h

Module: NMatchingDetails Unit


NMatchingDetailsGetFacesScore Function

NMatchingDetailsGetFacesScore Function
Example NMatchingDetails.h

Gets similarity score of two matched face templates (NLTemplate).

C++
NResult N_API NMatchingDetailsGetFacesScore(HNMatchingDetails hMatchingDetails, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNMatchingDetails hMatchingDetails | [in] Handle to NMatchingDetails.
NInt * pValue | [out] Faces similarity score.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Example

Function for printing matching details (face index and score):

Copy Code
//Prints faces similarity score and index from specified handle
static NResult PrintMatchingDetails(HNMatchingDetails hMatchingDetails)
{
  NResult nr;
  NBiometricType biometricType;
  NInt i, count, index, score;

  //Retrieves biometric type of specified NMatchingDetails (which template type matching details are saved)
  nr = NMatchingDetailsBaseGetBiometricType(hMatchingDetails, &biometricType);
  //If NMatchingDetails type detection failed an error code is returned. This value is less than 0.
  //To find more about error codes, read NResult Type
  if (NFailed(nr)) return nr;
  //Checks if NMatchingDetails saves data about faces matching
  if ((biometricType & nbtFace) == nbtFace)
  {
    //Trying to retrieve face templates similarity score
    nr = NMatchingDetailsGetFacesScore(hMatchingDetails, &score);
    //If failed to retrieve similarity score, an error code is returned
    if (NFailed(nr)) return nr;
    //Prints on a screen similarity score
    printf(N_T("    Faces match details:"));
    printf(N_T(" score = %d\n"), score);

    //Retrieving face count in specified NMatchingDetails
    nr = NMatchingDetailsGetFaceCount(hMatchingDetails, &count);
    if (NFailed(nr)) return nr;
    //Trying to get index of second matched face template
    for (i = 0; i < count; i++)
    {
      HNLMatchingDetails hFaceMatchingDetails;
      //Gets face matching details (NLMatchingDetails)
Copy Code
      nr = NMatchingDetailsGetFace(hMatchingDetails, i, &hFaceMatchingDetails);
      if (NFailed(nr)) return nr;
      //Using face matching details gets index
      nr = NXMatchingDetailsGetMatchedIndex(hFaceMatchingDetails, &index);
      if (NFailed(nr)) return nr;
      //Gets faces similarity score by calling base function for retrieving similarity score
      //Note: If handle to NMatchingDetails is specified, similarity score for all modalities is returned
      nr = NMatchingDetailsBaseGetScore(hFaceMatchingDetails, &score);
      if (NFailed(nr)) return nr;
      printf(N_T("    face index: %d; score: %d;\n"), index, score);
Copy Code
    }
  }

  return nr;
}

Note: This function should be called after templates identification (NMIdentifyNextEx and NMIdentifyNextEx) or verification (NMVerifyEx).

Container

File: NMatchingDetails.h

Module: NMatchingDetails Unit


NMatchingDetailsGetFingerCount Function

NMatchingDetailsGetFingerCount Function
NMatchingDetails.h See Also

Gets fingerprint templates count in NMatchingDetails.

C++
NResult N_API NMatchingDetailsGetFingerCount(HNMatchingDetails hMatchingDetails, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNMatchingDetails hMatchingDetails | [in] Handle to NMatchingDetails.
NInt * pValue | [out] Fingerprint count in NMatchingDetails.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand See Also

NMatchingDetailsGetFingerScore

Container

File: NMatchingDetails.h

Module: NMatchingDetails Unit


NMatchingDetailsGetFingerEx Function

NMatchingDetailsGetFingerEx Function
NMatchingDetails.h

Gets fingerprint matching details (NFMatchingDetails) from specified NMatchingDetails.

C++
NResult N_API NMatchingDetailsGetFingerEx(HNMatchingDetails hMatchingDetails, NInt index, HNFMatchingDetails * phValue);
Collapse Expand Parameters
Parameters | Description
HNMatchingDetails hMatchingDetails | [in] Handle to NMatchingDetails.
NInt index | [in] Fingerprint index in NMatchingDetails (NFMatchingDetails will be returned for fingerprint template specified by index ). Index should be greater than 0 and less than face count in NMatchingDetails. Fingerprint count can be retrieved by calling NMatchingDetailsGetFingerCount function.
HNFMatchingDetails * phValue | [out] Pointer to HNFMatchingDetails which contains information about fingerprint templates matching (fingerprints match result).
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMatchingDetails.h

Module: NMatchingDetails Unit


NMatchingDetailsGetFingersScore Function

NMatchingDetailsGetFingersScore Function
Example NMatchingDetails.h

Gets similarity score of two matched fingerprint templates (NFTemplate).

C++
NResult N_API NMatchingDetailsGetFingersScore(HNMatchingDetails hMatchingDetails, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNMatchingDetails hMatchingDetails | [in] Handle to NMatchingDetails.
NInt * pValue | [out] Fingerprints similarity score.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Example

Function for printing matching details (fingerprint index and score):

Copy Code
//Prints fingerprints similarity score and index from specified handle
static NResult PrintMatchingDetails(HNMatchingDetails hMatchingDetails)
{
  NResult nr;
  NBiometricType biometricType;
  NInt i, count, index, score;

  //Retrieves biometric type of specified NMatchingDetails (which template type matching details are saved)
  nr = NMatchingDetailsBaseGetBiometricType(hMatchingDetails, &biometricType);
  //If NMatchingDetails type detection failed an error code is returned. This value is less than 0.
  //To find more about error codes, read NResult Type
  if (NFailed(nr)) return nr;
  //Checks if NMatchingDetails saves data about fingerprints matching
  if ((biometricType & nbtFinger) == nbtFinger)
  {
    //Trying to retrieve fingerprint templates similarity score
    nr = NMatchingDetailsGetFingersScore(hMatchingDetails, &score);
    //If failed to retrieve similarity score, an error code is returned
    if (NFailed(nr)) return nr;
    //Prints on a screen similarity score
    printf(N_T("    Fingerprint match details:"));
    printf(N_T(" score = %d\n"), score);

    //Retrieving fingerprint count in specified NMatchingDetails
    nr = NMatchingDetailsGetFingerCount(hMatchingDetails, &count);
    if (NFailed(nr)) return nr;
    //Trying to get index of second matched fingerprint template
    for (i = 0; i < count; i++)
    {
      HNFMatchingDetails hFingerMatchingDetails;
      //Gets face matching details (NLMatchingDetails)
      nr = NMatchingDetailsGetFinger(hMatchingDetails, i, &hFingerMatchingDetails);
      if (NFailed(nr)) return nr;
      //Using fingerprint matching details gets index
      nr = NXMatchingDetailsGetMatchedIndex(hFingerMatchingDetails, &index);
      if (NFailed(nr)) return nr;
      //Gets fingerprints similarity score by calling base function for retrieving similarity score
      //Note: If handle to NMatchingDetails is specified, similarity score for all modalities is returned
      nr = NMatchingDetailsBaseGetScore(hFingerMatchingDetails, &score);
      if (NFailed(nr)) return nr;
      printf(N_T("    fingerprint index: %d; score: %d;\n"), index, score);
    }
  }

  return nr;
}

Note: This function should be called after templates identification (NMIdentifyNextEx and NMIdentifyNextEx) or verification (NMVerifyEx).

Container

File: NMatchingDetails.h

Module: NMatchingDetails Unit


NMatchingDetailsGetIrisCount Function

NMatchingDetailsGetIrisCount Function
NMatchingDetails.h See Also

Gets iris templates count in NMatchingDetails.

C++
NResult N_API NMatchingDetailsGetIrisCount(HNMatchingDetails hMatchingDetails, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNMatchingDetails hMatchingDetails | [in] Handle to NMatchingDetails.
NInt * pValue | [out] Irises count in NMatchingDetails.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand See Also

NMatchingDetailsGetIrisesScore

Container

File: NMatchingDetails.h

Module: NMatchingDetails Unit


NMatchingDetailsGetIrisEx Function

NMatchingDetailsGetIrisEx Function
NMatchingDetails.h

Gets iris matching details (NEMatchingDetails) from specified NMatchingDetails.

C++
NResult N_API NMatchingDetailsGetIrisEx(HNMatchingDetails hMatchingDetails, NInt index, HNEMatchingDetails * phValue);
Collapse Expand Parameters
Parameters | Description
HNMatchingDetails hMatchingDetails | [in] Handle to NMatchingDetails.
NInt index | [in] Iris index in NMatchingDetails (NEMatchingDetails will be returned for iris template specified by index ). Index should be greater than 0 and less than iris count in NMatchingDetails. Iris count can be retrieved by calling NMatchingDetailsGetIrisCount function.
HNEMatchingDetails * phValue | [out] Pointer to HNEMatchingDetails which contains information about iris templates matching (irises match result).
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMatchingDetails.h

Module: NMatchingDetails Unit


NMatchingDetailsGetIrisesScore Function

NMatchingDetailsGetIrisesScore Function
Example NMatchingDetails.h

Gets similarity score of two matched iris templates (NETemplate).

C++
NResult N_API NMatchingDetailsGetIrisesScore(HNMatchingDetails hMatchingDetails, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNMatchingDetails hMatchingDetails | [in] Handle to NMatchingDetails.
NInt * pValue | [out] Irises similarity score.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Example

Function for printing matching details (iris index and score):

Copy Code
//Prints irises similarity score and index from specified handle
static NResult PrintMatchingDetails(HNMatchingDetails hMatchingDetails)
{
  NResult nr;
  NBiometricType biometricType;
  NInt i, count, index, score;

  //Retrieves biometric type of specified NMatchingDetails (which template type matching details are saved)
  nr = NMatchingDetailsBaseGetBiometricType(hMatchingDetails, &biometricType);
  //If NMatchingDetails type detection failed an error code is returned. This value is less than 0.
  //To find more about error codes, read NResult Type
  if (NFailed(nr)) return nr;
  //Checks if NMatchingDetails saves data about irises matching
  if ((biometricType & nbtIris) == nbtIris)
  {
    //Trying to retrieve iris templates similarity score
    nr = NMatchingDetailsGetIrisesScore(hMatchingDetails, &score);
    //If failed to retrieve similarity score, an error code is returned
    if (NFailed(nr)) return nr;
    //Prints on a screen similarity score
    printf(N_T("    Irises match details:"));
    printf(N_T(" score = %d\n"), score);

    //Retrieving irises count in specified NMatchingDetails
    nr = NMatchingDetailsGetIrisCount(hMatchingDetails, &count);
    if (NFailed(nr)) return nr;
    //Trying to get index of second matched iris template
    for (i = 0; i < count; i++)
     {
      HNEMatchingDetails hIrisMatchingDetails;
      //Gets iris matching details (NEMatchingDetails)
      nr = NMatchingDetailsGetIris(hMatchingDetails, i, &hIrisMatchingDetails);
      if (NFailed(nr)) return nr;
      //Using iris matching details gets index
      nr = NXMatchingDetailsGetMatchedIndex(hIrisMatchingDetails, &index);
      if (NFailed(nr)) return nr;
      //Gets irises similarity score by calling base function for retrieving similarity score
      //Note: If handle to NMatchingDetails is specified, similarity score for all modalities is returned
      nr = NMatchingDetailsBaseGetScore(hIrisMatchingDetails, &score);
      if (NFailed(nr)) return nr;
      printf(N_T("    iris index: %d; score: %d;\n"), index, score);
    }
  }

  return nr;
}

Note: This function should be called after templates identification (NMIdentifyNextEx and NMIdentifyNextEx) or verification (NMVerifyEx).

Container

File: NMatchingDetails.h

Module: NMatchingDetails Unit


NMatchingDetailsGetPalmCount Function

NMatchingDetailsGetPalmCount Function
NMatchingDetails.h See Also

Gets palmprint templates count in NMatchingDetails.

C++
NResult N_API NMatchingDetailsGetPalmCount(HNMatchingDetails hMatchingDetails, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNMatchingDetails hMatchingDetails | [in] Handle to NMatchingDetails.
NInt * pValue | [out] Palmprints count in NMatchingDetails.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand See Also

NMatchingDetailsGetPalmsScore

Container

File: NMatchingDetails.h

Module: NMatchingDetails Unit


NMatchingDetailsGetPalmEx Function

NMatchingDetailsGetPalmEx Function
NMatchingDetails.h

Gets palmprint matching details (NFMatchingDetails) from specified NMatchingDetails.

C++
NResult N_API NMatchingDetailsGetPalmEx(HNMatchingDetails hMatchingDetails, NInt index, HNFMatchingDetails * phValue);
Collapse Expand Parameters
Parameters | Description
HNMatchingDetails hMatchingDetails | [in] Handle to NMatchingDetails.
NInt index | [in] Palmprint index in NMatchingDetails (NFMatchingDetails will be returned for palmprint template specified by index ). Index should be greater than 0 and less than palmprints count in NMatchingDetails. Palmprints count can be retrieved by calling NMatchingDetailsGetPalmCount function.
HNFMatchingDetails * phValue | [out] Pointer to HNFMatchingDetails which contains information about palmprint templates matching (palmprints match result).
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMatchingDetails.h

Module: NMatchingDetails Unit


NMatchingDetailsGetPalmsScore Function

NMatchingDetailsGetPalmsScore Function
Example NMatchingDetails.h

Gets similarity score of two matched palmprint templates (NFTemplate).

C++
NResult N_API NMatchingDetailsGetPalmsScore(HNMatchingDetails hMatchingDetails, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNMatchingDetails hMatchingDetails | [in] Handle to NMatchingDetails.
NInt * pValue | [out] Palmprints similarity score.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Example

Function for printing matching details (palmprint index and score):

Copy Code
//Prints palmprints similarity score and index from specified handle
static NResult PrintMatchingDetails(HNMatchingDetails hMatchingDetails)
{
  NResult nr;
  NBiometricType biometricType;
  NInt i, count, index, score;

  //Retrieves biometric type of specified NMatchingDetails (which template type matching details are saved)
  nr = NMatchingDetailsBaseGetBiometricType(hMatchingDetails, &biometricType);
  //If NMatchingDetails type detection failed an error code is returned. This value is less than 0.
  //To find more about error codes, read NResult Type
  if (NFailed(nr)) return nr;
  //Checks if NMatchingDetails saves data about palmprints matching
  if ((biometricType & nbtPalm) == nbtPalm)
  {
    //Trying to retrieve palmprint templates similarity score
    nr = NMatchingDetailsGetPalmsScore(hMatchingDetails, &score);
    //If failed to retrieve similarity score, an error code is returned
    if (NFailed(nr)) return nr;
    //Prints on a screen similarity score
    printf(N_T("    Palms match details:"));
    printf(N_T(" score = %d\n"), score);

    //Retrieving palmprints count in specified NMatchingDetails
    nr = NMatchingDetailsGetPalmCount(hMatchingDetails, &count);
    if (NFailed(nr)) return nr;
    //Trying to get index of second matched palmprint template
    for (i = 0; i < count; i++)
     {
      HNFMatchingDetails hPalmMatchingDetails;
      //Gets palmprint matching details (NFMatchingDetails)
      nr = NMatchingDetailsGetPalm(hMatchingDetails, i, &hPalmMatchingDetails);
      if (NFailed(nr)) return nr;
      //Using palmprint matching details gets index
      nr = NXMatchingDetailsGetMatchedIndex(hPalmMatchingDetails, &index);
      if (NFailed(nr)) return nr;
      //Gets palmprints similarity score by calling base function for retrieving similarity score
      //Note: If handle to NMatchingDetails is specified, similarity score for all modalities is returned
      nr = NMatchingDetailsBaseGetScore(hPalmMatchingDetails, &score);
      if (NFailed(nr)) return nr;
      printf(N_T("    palm index: %d; score: %d;\n"), index, score);
    }
  }

  return nr;
}

Note: This function should be called after templates identification (NMIdentifyNextEx and NMIdentifyNextEx) or verification (NMVerifyEx).

Container

File: NMatchingDetails.h

Module: NMatchingDetails Unit


NMatchingDetailsGetVoiceCount Function

NMatchingDetailsGetVoiceCount Function
NMatchingDetails.h See Also

Gets voice templates count in NMatchingDetails.

C++
NResult N_API NMatchingDetailsGetVoiceCount(HNMatchingDetails hMatchingDetails, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNMatchingDetails hMatchingDetails | [in] Handle to NMatchingDetails.
NInt * pValue | [out] Voice count in NMatchingDetails.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand See Also

NMatchingDetailsGetVoicesScore

Container

File: NMatchingDetails.h

Module: NMatchingDetails Unit


NMatchingDetailsGetVoiceEx Function

NMatchingDetailsGetVoiceEx Function
NMatchingDetails.h

Gets voice matching details (NSMatchingDetails) from specified NMatchingDetails.

C++
NResult N_API NMatchingDetailsGetVoiceEx(HNMatchingDetails hMatchingDetails, NInt index, HNSMatchingDetails * phValue);
Collapse Expand Parameters
Parameters | Description
HNMatchingDetails hMatchingDetails | [in] Handle to NMatchingDetails.
NInt index | [in] Voice template index in NMatchingDetails (NSMatchingDetails will be returned for voice template specified by index ). Index should be greater than 0 and less than voice templates count in NMatchingDetails. Voices count can be retrieved by calling NMatchingDetailsGetVoiceCount function.
HNSMatchingDetails * phValue | [out] Pointer to HNSMatchingDetails which contains information about voice templates matching (voices match result).
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMatchingDetails.h

Module: NMatchingDetails Unit


NMatchingDetailsGetVoicesScore Function

NMatchingDetailsGetVoicesScore Function
Example NMatchingDetails.h

Gets similarity score of two matched voice templates (NSTemplate).

C++
NResult N_API NMatchingDetailsGetVoicesScore(HNMatchingDetails hMatchingDetails, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNMatchingDetails hMatchingDetails | [in] Handle to NMatchingDetails.
NInt * pValue | [out] Voices similarity score.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Example

Function for printing matching details (voice index and score):

Copy Code
//Prints voices similarity score and index from specified handle
static NResult PrintMatchingDetails(HNMatchingDetails hMatchingDetails)
{
  NResult nr;
  NBiometricType biometricType;
  NInt i, count, index, score;

  //Retrieves biometric type of specified NMatchingDetails (which template type matching details are saved)
  nr = NMatchingDetailsBaseGetBiometricType(hMatchingDetails, &biometricType);
  //If NMatchingDetails type detection failed an error code is returned. This value is less than 0.
  //To find more about error codes, read NResult Type
  if (NFailed(nr)) return nr;
  //Checks if NMatchingDetails saves data about voices matching
  if ((biometricType & nbtVoice) == nbtVoice)
  {
    //Trying to retrieve voice templates similarity score
    nr = NMatchingDetailsGetVoicesScore(hMatchingDetails, &score);
    //If failed to retrieve similarity score, an error code is returned
    if (NFailed(nr)) return nr;
    //Prints on a screen similarity score
    printf(N_T("    Voices match details:"));
    printf(N_T(" score = %d\n"), score);

    //Retrieving voices count in specified NMatchingDetails
    nr = NMatchingDetailsGetVoiceCount(hMatchingDetails, &count);
    if (NFailed(nr)) return nr;
    //Trying to get index of second matched voice template
    for (i = 0; i < count; i++)
     {
      HNSMatchingDetails hVoiceMatchingDetails;
      //Gets voice matching details (NSMatchingDetails)
      nr = NMatchingDetailsGetVoice(hMatchingDetails, i, &hVoiceMatchingDetails);
      if (NFailed(nr)) return nr;
      //Using voice matching details gets index
      nr = NXMatchingDetailsGetMatchedIndex(hVoiceMatchingDetails, &index);
      if (NFailed(nr)) return nr;
      //Gets voices similarity score by calling base function for retrieving similarity score
      //Note: If handle to NMatchingDetails is specified, similarity score for all modalities is returned
      nr = NMatchingDetailsBaseGetScore(hVoiceMatchingDetails, &score);
      if (NFailed(nr)) return nr;
      printf(N_T("    voice index: %d; score: %d;\n"), index, score);
    }
  }

  return nr;
}

Note: This function should be called after templates identification (NMIdentifyNextEx and NMIdentifyNextEx) or verification (NMVerifyEx).

Container

File: NMatchingDetails.h

Module: NMatchingDetails Unit


NMatchingDetails.h

NMatchingDetails.h
Functions Legend

Header file for the NMatchingDetails.

Collapse Expand Functions
Name | Description
NMatchingDetailsCreateFromMemory | Creates NMatchingDetails from specified memory buffer.
NMatchingDetailsCreateFromMemoryN | Creates NMatchingDetails from specified memory buffer.
NMatchingDetailsCreateFromStream | Creates NMatchingDetails from specified stream.
NMatchingDetailsGetFaceCount | Gets face templates count in NMatchingDetails.
NMatchingDetailsGetFaceEx | Gets face matching details (NLMatchingDetails) from specified NMatchingDetails.
NMatchingDetailsGetFacesMatchedIndex | Gets index of matched face in the second matched NLTemplate (or NTemplate))
NMatchingDetailsGetFacesScore | Gets similarity score of two matched face templates (NLTemplate).
NMatchingDetailsGetFingerCount | Gets fingerprint templates count in NMatchingDetails.
NMatchingDetailsGetFingerEx | Gets fingerprint matching details (NFMatchingDetails) from specified NMatchingDetails.
NMatchingDetailsGetFingersScore | Gets similarity score of two matched fingerprint templates (NFTemplate).
NMatchingDetailsGetIrisCount | Gets iris templates count in NMatchingDetails.
NMatchingDetailsGetIrisEx | Gets iris matching details (NEMatchingDetails) from specified NMatchingDetails.
NMatchingDetailsGetIrisesScore | Gets similarity score of two matched iris templates (NETemplate).
NMatchingDetailsGetPalmCount | Gets palmprint templates count in NMatchingDetails.
NMatchingDetailsGetPalmEx | Gets palmprint matching details (NFMatchingDetails) from specified NMatchingDetails.
NMatchingDetailsGetPalmsScore | Gets similarity score of two matched palmprint templates (NFTemplate).
NMatchingDetailsGetVoiceCount | Gets voice templates count in NMatchingDetails.
NMatchingDetailsGetVoiceEx | Gets voice matching details (NSMatchingDetails) from specified NMatchingDetails.
NMatchingDetailsGetVoicesScore | Gets similarity score of two matched voice templates (NSTemplate).


NMatchingDetailsBase Unit

NMatchingDetailsBase Unit
Files Functions Legend

Base unit for NMatchingDetails.

Collapse Expand Files
Name | Description
NMatchingDetailsBase.h | Header file for NMatchingDetailsBase.
Collapse Expand Functions
Name | Description
NMatchingDetailsBaseGetBiometricType | Gets type of biometric modality saved in specified matching details.
NMatchingDetailsBaseGetScore | Gets similarity score of two matched templates.


NMatchingDetailsBaseGetBiometricType Function

NMatchingDetailsBaseGetBiometricType Function
NMatchingDetailsBase.h

Gets type of biometric modality saved in specified matching details.

C++
NResult N_API NMatchingDetailsBaseGetBiometricType(HNMatchingDetailsBase hMatchingDetails, NBiometricType * pValue);
Collapse Expand Parameters
Parameters | Description
HNMatchingDetailsBase hMatchingDetails | [in] Handle to NMatchingDetails.
NBiometricType * pValue | [out] Biometric type.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMatchingDetailsBase.h

Module: NMatchingDetailsBase Unit


NMatchingDetailsBaseGetScore Function

NMatchingDetailsBaseGetScore Function
NMatchingDetailsBase.h See Also

Gets similarity score of two matched templates.

C++
NResult N_API NMatchingDetailsBaseGetScore(HNMatchingDetailsBase hMatchingDetails, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNMatchingDetailsBase hMatchingDetails | [in] Handle to NMatchingDetails.
NInt * pValue | [out] Similarity score.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand See Also

NMatchingDetailsGetFacesScore

NMatchingDetailsGetFingersScore

NMatchingDetailsGetIrisesScore

NMatchingDetailsGetPalmsScore

NMatchingDetailsGetVoicesScore

Container

File: NMatchingDetailsBase.h

Module: NMatchingDetailsBase Unit


NMatchingDetailsBase.h

NMatchingDetailsBase.h
Functions Legend

Header file for NMatchingDetailsBase.

Collapse Expand Functions
Name | Description
NMatchingDetailsBaseGetBiometricType | Gets type of biometric modality saved in specified matching details.
NMatchingDetailsBaseGetScore | Gets similarity score of two matched templates.


NMatchingResult Unit

NMatchingResult Unit
Files Functions Legend

Provides functions to retrieve information about matching results.

Collapse Expand Files
Name | Description
NMatchingResult.h | Header file for the NMatchingResult unit.
Collapse Expand Functions
Name | Description
NMatchingResultGetConnection | Retrieves the biometric connection of the specified matching result.
NMatchingResultGetId | Retrieves the ID of the specified matching result.
NMatchingResultGetMatchingDetails | Retrieves the matching details of the specified matching result.
NMatchingResultGetMatchingDetailsBuffer | Retrieves the matching details buffer of the specified matching result.
NMatchingResultGetScore | Retrieves the matching score of the specified matching result.
NMatchingResultGetSubject | Retrieves the subject of the specified matching result.


NMatchingResultGetConnection Function

NMatchingResultGetConnection Function
NMatchingResult.h

Retrieves the biometric connection of the specified matching result.

C++
NResult N_API NMatchingResultGetConnection(HNMatchingResult hMatchingResult, HNBiometricConnection * phValue);
Collapse Expand Parameters
Parameters | Description
HNMatchingResult hMatchingResult | [in] Handle to the matching result.
HNBiometricConnection * phValue | [out] Pointer to the biometric connection.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMatchingResult.h

Module: NMatchingResult Unit


NMatchingResultGetId Function

NMatchingResultGetId Function
NMatchingResult.h

Retrieves the ID of the specified matching result.

C++
NResult N_API NMatchingResultGetId(HNMatchingResult hMatchingResult, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNMatchingResult hMatchingResult | [in] Handle to the matching result.
HNString * phValue | [out] Pointer to the ID.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMatchingResult.h

Module: NMatchingResult Unit


NMatchingResultGetMatchingDetails Function

NMatchingResultGetMatchingDetails Function
NMatchingResult.h

Retrieves the matching details of the specified matching result.

C++
NResult N_API NMatchingResultGetMatchingDetails(HNMatchingResult hMatchingResult, HNMatchingDetails * phValue);
Collapse Expand Parameters
Parameters | Description
HNMatchingResult hMatchingResult | [in] Handle to the matching result.
HNMatchingDetails * phValue | [out] Pointer to the matching details.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMatchingResult.h

Module: NMatchingResult Unit


NMatchingResultGetMatchingDetailsBuffer Function

NMatchingResultGetMatchingDetailsBuffer Function
NMatchingResult.h

Retrieves the matching details buffer of the specified matching result.

C++
NResult N_API NMatchingResultGetMatchingDetailsBuffer(HNMatchingResult hMatchingResult, HNBuffer * phValue);
Collapse Expand Parameters
Parameters | Description
HNMatchingResult hMatchingResult | [in] Handle to the matching result.
HNBuffer * phValue | [out] Pointer to the matching details buffer.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMatchingResult.h

Module: NMatchingResult Unit


NMatchingResultGetScore Function

NMatchingResultGetScore Function
NMatchingResult.h

Retrieves the matching score of the specified matching result.

C++
NResult N_API NMatchingResultGetScore(HNMatchingResult hMatchingResult, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNMatchingResult hMatchingResult | [in] Handle to the matching result.
NInt * pValue | [out] Pointer to the matching score.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMatchingResult.h

Module: NMatchingResult Unit


NMatchingResultGetSubject Function

NMatchingResultGetSubject Function
NMatchingResult.h

Retrieves the subject of the specified matching result.

C++
NResult N_API NMatchingResultGetSubject(HNMatchingResult hMatchingResult, HNSubject * phValue);
Collapse Expand Parameters
Parameters | Description
HNMatchingResult hMatchingResult | [in] Handle to the matching result.
HNSubject * phValue | [out] Pointer to the matching subject.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMatchingResult.h

Module: NMatchingResult Unit


NMatchingResult.h

NMatchingResult.h
Functions Legend

Header file for the NMatchingResult unit.

Collapse Expand Functions
Name | Description
NMatchingResultGetConnection | Retrieves the biometric connection of the specified matching result.
NMatchingResultGetId | Retrieves the ID of the specified matching result.
NMatchingResultGetMatchingDetails | Retrieves the matching details of the specified matching result.
NMatchingResultGetMatchingDetailsBuffer | Retrieves the matching details buffer of the specified matching result.
NMatchingResultGetScore | Retrieves the matching score of the specified matching result.
NMatchingResultGetSubject | Retrieves the subject of the specified matching result.


NSubject Unit

NSubject Unit
Files Functions Legend Macros

Represents a person (or, potentially, any living creature) and contains biometric information related that person, including templates, biometric operation (matching) results and objects like NFinger, which contain biometric data of specific kinds.

Collapse Expand Files
Name | Description
NSubject.h | Header file for the NSubject unit.
Collapse Expand Functions
Name | Description
NSubjectAddFace | Adds a NFace object to the specified NSubject.
NSubjectAddFacesCollectionChanged | Adds a FacesCollectionChanged event to the specified NSubject.
NSubjectAddFacesCollectionChangedCallback | Adds a FacesCollectionChanged event callback to the specified NSubject.
NSubjectAddFinger | Adds a NFinger object to the specified NSubject.
NSubjectAddFingersCollectionChanged | Adds a FingersCollectionChanged event to the specified NSubject.
NSubjectAddFingersCollectionChangedCallback | Adds a FingersCollectionChanged event callback to the specified NSubject.
NSubjectAddIris | Adds a NIris object to the specified NSubject.
NSubjectAddIrisesCollectionChanged | Adds a IrisesCollectionChanged event to the specified NSubject.
NSubjectAddIrisesCollectionChangedCallback | Adds a IrisesCollectionChanged event callback to the specified NSubject.
NSubjectAddMissingEye | Adds a NEPosition object representing a missing eye to the specified NSubject.
NSubjectAddMissingFinger | Adds a NFPosition object representing a missing finger(s) to the specified NSubject.
NSubjectAddPalm | Adds a NPalm object to the specified NSubject.
NSubjectAddPalmsCollectionChanged | Adds a PalmsCollectionChanged event to the specified NSubject.
NSubjectAddPalmsCollectionChangedCallback | Adds a PalmsCollectionChanged event callback to the specified NSubject.
NSubjectAddRelatedSubject | Adds a related NSubject object to the specified NSubject.
NSubjectAddRelatedSubjectsCollectionChanged | Adds a RelatedSubjectsCollectionChanged event to the specified NSubject.
NSubjectAddRelatedSubjectsCollectionChangedCallback | Adds a RelatedSubjectsCollectionChanged event callback to the specified NSubject.
NSubjectAddSignature | Adds a signature of the specified subject.
NSubjectAddSignaturesCollectionChanged | Adds the SignaturesCollectionChanged event to the specified NSubject.
NSubjectAddSignaturesCollectionChangedCallback | Adds the SignaturesCollectionChanged user's specified callback to the NSubject.
NSubjectAddVoice | Adds a NVoice object to the specified NSubject.
NSubjectAddVoicesCollectionChanged | Adds a VoicesCollectionChanged event to the specified NSubject.
NSubjectAddVoicesCollectionChangedCallback | Adds a VoicesCollectionChanged event callback to the specified NSubject.
NSubjectClear | Clears the specified NSubject of all data.
NSubjectClearFaces | Clears all NFace objects from the specified NSubject.
NSubjectClearFingers | Clears all NFinger objects from the specified NSubject.
NSubjectClearIrises | Clears all NIris objects from the specified NSubject.
NSubjectClearMissingEyes | Clears all NEPosition objects representing missing eyes from the specified NSubject.
NSubjectClearMissingFingers | Clears all NFPosition objects representing missing fingers from the specified NSubject.
NSubjectClearPalms | Clears all NPalm objects from the specified NSubject.
NSubjectClearRelatedSubjects | Clears all related NSubject objects from the specified NSubject.
NSubjectClearSignatures | Clears all signatures from the specified NSubject.
NSubjectClearVoices | Clears all NVoice objects from the specified NSubject.
NSubjectCreate | Creates a new NSubject object.
NSubjectCreateFromFile | Creates a new NSubject object from the specified file.
NSubjectCreateFromFileWithFormat | Creates a new NSubject object from the specified file with specified format.
NSubjectCreateFromMemory | Creates a new NSubject object from the specified buffer.
NSubjectCreateFromMemoryWithFormat | Creates a new NSubject object from the specified buffer with the specified format.
NSubjectCreateFromStream | Creates a new NSubject object from the specified memory stream.
NSubjectCreateFromStreamWithFormat | Creates a new NSubject object from the specified memory stream with the specified format.
NSubjectGetError | Retrieves the last exception of the specified NSubject.
NSubjectGetFace | Retrieves the specified NFace object from the specified NSubject.
NSubjectGetFaceCapacity | Retrieves the maximum number of NFace objects in the specified NSubject.
NSubjectGetFaceCount | Retrieves the number of NFace objects in the specified NSubject.
NSubjectGetFaces | Retrieves all NFace objects from the specified NSubject.
NSubjectGetFinger | Retrieves the specified NFinger object from the specified NSubject.
NSubjectGetFingerCapacity | Retrieves the maximum number of NFinger objects in the specified NSubject.
NSubjectGetFingerCount | Retrieves the number of NFinger objects in the specified NSubject.
NSubjectGetFingers | Retrieves all NFinger objects from the specified NSubject.
NSubjectGetGender | Gets the gender value of the specified NSubject.
NSubjectGetId | Retrieves the specified NSubject's ID.
NSubjectGetIris | Retrieves the specified NIris object from the specified NSubject.
NSubjectGetIrisCapacity | Retrieves the maximum number of NIris objects in the specified NSubject.
NSubjectGetIrisCount | Retrieves the number of NIris objects in the specified NSubject.
NSubjectGetIrises | Retrieves all NIris objects from the specified NSubject.
NSubjectGetMatchingResult | Retrieves the specified matching result from the specified NSubject.
NSubjectGetMatchingResultCount | Retrieves the number of matching results in the specified NSubject.
NSubjectGetMatchingResults | Retrieves all matching results from the specified NSubject.
NSubjectGetMissingEye | Retrieves the specified NEPosition object representing a missing eye from the specified NSubject.
NSubjectGetMissingEyeCapacity | Retrieves the maximum number of NEPosition objects in the specified NSubject.
NSubjectGetMissingEyeCount | Retrieves the number of NEPosition objects in the specified NSubject.
NSubjectGetMissingEyes | Retrieves all NEPosition objects representing missing eyes from the specified NSubject.
NSubjectGetMissingFinger | Retrieves the specified NFPosition object representing a missing finger from the specified NSubject.
NSubjectGetMissingFingerCapacity | Retrieves the maximum number of NFPosition objects in the specified NSubject.
NSubjectGetMissingFingerCount | Retrieves the number of NFPosition objects in the specified NSubject.
NSubjectGetMissingFingers | Retrieves all NFPosition objects representing missing fingers from the specified NSubject.
NSubjectGetPalm | Retrieves the specified NPalm object from the specified NSubject.
NSubjectGetPalmCapacity | Retrieves the maximum number of NPalm objects in the specified NSubject.
NSubjectGetPalmCount | Retrieves the number of NPalm objects in the specified NSubject.
NSubjectGetPalms | Retrieves all NPalm objects from the specified NSubject.
NSubjectGetQueryString | Gets the specified NSubject's query string. Query string is a string which can be invoked to retrieve a corresponding NSubject.
NSubjectGetRelatedSubject | Retrieves the specified related NSubject from the specified NSubject.
NSubjectGetRelatedSubjectCapacity | Retrieves the maximum number of related NSubjects in the specified NSubject.
NSubjectGetRelatedSubjectCount | Retrieves the number of related NSubjects in the specified NSubject.
NSubjectGetRelatedSubjects | Retrieves all related NSubjects from the specified NSubject.
NSubjectGetSignature | Gets signature by index from the specified NSubject object.
NSubjectGetSignatureCapacity | Gets the signatures capacity within the specified NSubject object.
NSubjectGetSignatureCount | Gets signatures count within the specified NSubject object.
NSubjectGetSignatures | Gets all signatures from the specified NSubject.
NSubjectGetStatistics | Retrieves the statistics (diagnostic information) of the specified NSubject.
NSubjectGetStatus | Retrieves the biometric status of the specified NSubject. Possible biometric status values can be found here.
NSubjectGetTemplate | Gets the template used by the specified NSubject.
NSubjectGetTemplateBuffer | Gets the buffer which contains templates for the specified NSubject.
NSubjectGetTemplateBufferWithFormatEx | Gets the buffer which contains templates with specified format for the specified NSubject.
NSubjectGetVoice | Retrieves the specified NVoice object from the specified NSubject.
NSubjectGetVoiceCapacity | Retrieves the maximum number of NVoice objects in the specified NSubject.
NSubjectGetVoiceCount | Retrieves the number of NVoice objects in the specified NSubject.
NSubjectGetVoices | Retrieves all NVoice objects from the specified NSubject.
NSubjectInsertFace | Adds a NFace object to the specified NSubject at the specified index.
NSubjectInsertFinger | Adds a NFinger object to the specified NSubject at the specified index.
NSubjectInsertIris | Adds a NIris object to the specified NSubject at the specified index.
NSubjectInsertMissingEye | Adds a NEPosition object representing a missing eye to the specified NSubject at the specified index.
NSubjectInsertMissingFinger | Adds a NFPosition object representing a missing eye to the specified NSubject at the specified index.
NSubjectInsertPalm | Adds a NPalm object to the specified NSubject at the specified index.
NSubjectInsertRelatedSubject | Adds a related NSubject to the specified NSubject at the specified index.
NSubjectInsertSignature | Inserts the NSignature object to the specified NSubject at the specified index.
NSubjectInsertVoice | Adds a NVoice object to the specified NSubject at the specified index.
NSubjectIsMultipleSubjects | Checks whether the specified NSubject consists of multiple NSubjects.
NSubjectRemoveFaceAt | Removes the specified NFace object from the specified NSubject.
NSubjectRemoveFacesCollectionChanged | Removes a FacesCollectionChanged event from the specified NSubject.
NSubjectRemoveFacesCollectionChangedCallback | Removes a FacesCollectionChanged event callback from the specified NSubject.
NSubjectRemoveFingerAt | Removes the specified NFinger object from the specified NSubject.
NSubjectRemoveFingersCollectionChanged | Removes a FingersCollectionChanged event from the specified NSubject.
NSubjectRemoveFingersCollectionChangedCallback | Removes a FingersCollectionChanged event callback from the specified NSubject.
NSubjectRemoveIrisAt | Removes the specified NIris object from the specified NSubject.
NSubjectRemoveIrisesCollectionChanged | Removes a IrisesCollectionChanged event from the specified NSubject.
NSubjectRemoveIrisesCollectionChangedCallback | Removes a IrisesCollectionChanged event callback from the specified NSubject.
NSubjectRemoveMissingEyeAt | Removes the specified NEPosition object representing a missing eye from the specified NSubject.
NSubjectRemoveMissingFingerAt | Removes the specified NFPosition object representing a missing finger from the specified NSubject.
NSubjectRemovePalmAt | Removes the specified NPalm object from the specified NSubject.
NSubjectRemovePalmsCollectionChanged | Removes a PalmsCollectionChanged event from the specified NSubject.
NSubjectRemovePalmsCollectionChangedCallback | Removes a PalmsCollectionChanged event callback from the specified NSubject.
NSubjectRemoveRelatedSubjectAt | Removes the specified related NSubject from the specified NSubject.
NSubjectRemoveRelatedSubjectsCollectionChanged | Removes a RelatedSubjectsCollectionChanged event from the specified NSubject.
NSubjectRemoveRelatedSubjectsCollectionChangedCallback | Removes a RelatedSubjectsCollectionChanged event callback from the specified NSubject.
NSubjectRemoveSignatureAt | Removes the signature specified by an index.
NSubjectRemoveSignaturesCollectionChanged | Removes the SignaturesCollectionChanged event from the specified NSubject.
NSubjectRemoveSignaturesCollectionChangedCallback | Removes the SignaturesCollectionChanged user's specified callback from the NSubject.
NSubjectRemoveVoiceAt | Removes the specified NVoice object from the specified NSubject.
NSubjectRemoveVoicesCollectionChanged | Removes a VoicesCollectionChanged event from the specified NSubject.
NSubjectRemoveVoicesCollectionChangedCallback | Removes a VoicesCollectionChanged event callback from the specified NSubject.
NSubjectSetFace | Sets the value of the specified NFace object in the specified NSubject.
NSubjectSetFaceCapacity | Sets the maximum number of NFace objects for the specified NSubject.
NSubjectSetFinger | Sets the value of the specified NFinger object in the specified NSubject.
NSubjectSetFingerCapacity | Sets the maximum number of NFinger objects for the specified NSubject.
NSubjectSetGender | Sets the gender value of the specified NSubject.
NSubjectSetId | Sets the specified NSubject's ID.
NSubjectSetIris | Sets the value of the specified NIris object in the specified NSubject.
NSubjectSetIrisCapacity | Sets the maximum number of NIris objects for the specified NSubject.
NSubjectSetMissingEye | Sets the value of the specified NEPosition object representing a missing eye in the specified NSubject.
NSubjectSetMissingEyeCapacity | Sets the maximum number of NEPosition objects for the specified NSubject.
NSubjectSetMissingFinger | Sets the value of the specified NFPosition object representing a missing finger in the specified NSubject.
NSubjectSetMissingFingerCapacity | Sets the maximum number of NFPosition objects for the specified NSubject.
NSubjectSetMultipleSubjects | Sets whether the specified NSubject consists of multiple NSubjects.
NSubjectSetPalm | Sets the value of the specified NPalm object in the specified NSubject.
NSubjectSetPalmCapacity | Sets the maximum number of NPalm objects for the specified NSubject.
NSubjectSetQueryString | Sets the specified NSubject's query string.
NSubjectSetRelatedSubject | Sets the value of the specified related NSubject in the specified NSubject.
NSubjectSetRelatedSubjectCapacity | Sets the maximum number of related NSubjects for the specified NSubject.
NSubjectSetSignature | Sets signature value (by index) for the NSubject object.
NSubjectSetSignatureCapacity | Sets the signatures capacity for the specified NSubject object.
NSubjectSetTemplate | Sets the template to be used by the specified NSubject.
NSubjectSetTemplateAN | Sets the ANTemplate to be used by the specified NSubject.
NSubjectSetTemplateBuffer | Sets the buffer to contain templates for the specified NSubject.
NSubjectSetTemplateBufferWithFormat | Sets the buffer to contain templates with specified format for the specified NSubject.
NSubjectSetTemplateCbeff | Sets the CbeffRecord to be used by the specified NSubject.
NSubjectSetTemplateFC | Sets the FCRecord to be used by the specified NSubject.
NSubjectSetTemplateFI | Sets the FIRecord to be used by the specified NSubject.
NSubjectSetTemplateFM | Sets the FMRecord to be used by the specified NSubject.
NSubjectSetTemplateFMC | Sets the FMCRecord to be used by the specified NSubject.
NSubjectSetTemplateII | Sets the IIRecord to be used by the specified NSubject.
NSubjectSetVoice | Sets the value of the specified NVoice object in the specified NSubject.
NSubjectSetVoiceCapacity | Sets the maximum number of NVoice objects for the specified NSubject.
NSubjectToANTemplate | Converts the biometric subject into a ANTemplate.
NSubjectToFCRecord | Converts the biometric subject into a FCRecord.
NSubjectToFIRecord | Converts the biometric subject into a FIRecord.
NSubjectToFMCRecord | Converts the biometric subject into a FMCRecord.
NSubjectToFMRecord | Converts the biometric subject into a FMRecord.
NSubjectToFMRecordEx | Converts the biometric subject into a FMRecord.
NSubjectToIIRecord | Converts the biometric subject into a IIRecord.
Collapse Expand Macros
Name | Description
NSubjectCreateFromFile | Picks a Unicode (W) or ANSCII (A) version of the NSubjectCreateFromFile function.
NSubjectCreateFromFileWithFormat | Picks a Unicode (W) or ANSCII (A) version of the NSubjectCreateFromFileWithFormat function.
NSubjectSetId | Picks a Unicode (W) or ANSCII (A) version of the NSubjectSetId function.
NSubjectSetQueryString | Picks a Unicode (W) or ANSCII (A) version of the NSubjectSetQueryString function.


NSubjectAddFace Function

NSubjectAddFace Function
NSubject.h

Adds a NFace object to the specified NSubject.

C++
NResult N_API NSubjectAddFace(HNSubject hSubject, HNFace hValue, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
HNFace hValue | [in] Handle to the NFace object.
NInt * pIndex | [out] Pointer to the index of the object added.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectAddFacesCollectionChanged Function

NSubjectAddFacesCollectionChanged Function
NSubject.h

Adds a FacesCollectionChanged event to the specified NSubject.

C++
NResult N_API NSubjectAddFacesCollectionChanged(HNSubject hSubject, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
HNCallback hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectAddFacesCollectionChangedCallback Function

NSubjectAddFacesCollectionChangedCallback Function
NSubject.h

Adds a FacesCollectionChanged event callback to the specified NSubject.

C++
NResult N_API NSubjectAddFacesCollectionChangedCallback(HNSubject hSubject, N_COLLECTION_CHANGED_CALLBACK_ARG(HNFace, pCallback), void * pParam);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
void * pParam | [out] Parameters passed to the callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectAddFinger Function

NSubjectAddFinger Function
NSubject.h

Adds a NFinger object to the specified NSubject.

C++
NResult N_API NSubjectAddFinger(HNSubject hSubject, HNFinger hValue, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
HNFinger hValue | [in] Handle to the NFinger object.
NInt * pIndex | [out] Pointer to the index of the object added.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectAddFingersCollectionChanged Function

NSubjectAddFingersCollectionChanged Function
NSubject.h

Adds a FingersCollectionChanged event to the specified NSubject.

C++
NResult N_API NSubjectAddFingersCollectionChanged(HNSubject hSubject, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
HNCallback hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectAddFingersCollectionChangedCallback Function

NSubjectAddFingersCollectionChangedCallback Function
NSubject.h

Adds a FingersCollectionChanged event callback to the specified NSubject.

C++
NResult N_API NSubjectAddFingersCollectionChangedCallback(HNSubject hSubject, N_COLLECTION_CHANGED_CALLBACK_ARG(HNFinger, pCallback), void * pParam);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
void * pParam | [out] Parameters passed to the callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectAddIris Function

NSubjectAddIris Function
NSubject.h

Adds a NIris object to the specified NSubject.

C++
NResult N_API NSubjectAddIris(HNSubject hSubject, HNIris hValue, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
HNIris hValue | [in] Handle to the NIris object.
NInt * pIndex | [out] Pointer to the index of the object added.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectAddIrisesCollectionChanged Function

NSubjectAddIrisesCollectionChanged Function
NSubject.h

Adds a IrisesCollectionChanged event to the specified NSubject.

C++
NResult N_API NSubjectAddIrisesCollectionChanged(HNSubject hSubject, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
HNCallback hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectAddIrisesCollectionChangedCallback Function

NSubjectAddIrisesCollectionChangedCallback Function
NSubject.h

Adds a IrisesCollectionChanged event callback to the specified NSubject.

C++
NResult N_API NSubjectAddIrisesCollectionChangedCallback(HNSubject hSubject, N_COLLECTION_CHANGED_CALLBACK_ARG(HNIris, pCallback), void * pParam);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
void * pParam | [out] Parameters passed to the callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectAddMissingEye Function

NSubjectAddMissingEye Function
NSubject.h

Adds a NEPosition object representing a missing eye to the specified NSubject.

C++
NResult N_API NSubjectAddMissingEye(HNSubject hSubject, NEPosition hValue, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NEPosition hValue | [in] Handle to the NEPosition object.
NInt * pIndex | [out] Pointer to the index of the object added.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectAddMissingFinger Function

NSubjectAddMissingFinger Function
NSubject.h

Adds a NFPosition object representing a missing finger(s) to the specified NSubject.

C++
NResult N_API NSubjectAddMissingFinger(HNSubject hSubject, NFPosition hValue, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NFPosition hValue | [in] Handle to the NFPosition object.
NInt * pIndex | [out] Pointer to the index of the object added.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectAddPalm Function

NSubjectAddPalm Function
NSubject.h

Adds a NPalm object to the specified NSubject.

C++
NResult N_API NSubjectAddPalm(HNSubject hSubject, HNPalm hValue, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
HNPalm hValue | [in] Handle to the NPalm object.
NInt * pIndex | [out] Pointer to the index of the object added.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectAddPalmsCollectionChanged Function

NSubjectAddPalmsCollectionChanged Function
NSubject.h

Adds a PalmsCollectionChanged event to the specified NSubject.

C++
NResult N_API NSubjectAddPalmsCollectionChanged(HNSubject hSubject, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
HNCallback hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectAddPalmsCollectionChangedCallback Function

NSubjectAddPalmsCollectionChangedCallback Function
NSubject.h

Adds a PalmsCollectionChanged event callback to the specified NSubject.

C++
NResult N_API NSubjectAddPalmsCollectionChangedCallback(HNSubject hSubject, N_COLLECTION_CHANGED_CALLBACK_ARG(HNPalm, pCallback), void * pParam);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
void * pParam | [out] Parameters passed to the callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectAddRelatedSubject Function

NSubjectAddRelatedSubject Function
NSubject.h

Adds a related NSubject object to the specified NSubject.

C++
NResult N_API NSubjectAddRelatedSubject(HNSubject hSubject, HNSubject hValue, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the basic NSubject object.
HNSubject hValue | [in] Handle to the added NSubject object.
NInt * pIndex | [out] Pointer to the index of the object added.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectAddRelatedSubjectsCollectionChanged Function

NSubjectAddRelatedSubjectsCollectionChanged Function
NSubject.h

Adds a RelatedSubjectsCollectionChanged event to the specified NSubject.

C++
NResult N_API NSubjectAddRelatedSubjectsCollectionChanged(HNSubject hSubject, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
HNCallback hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectAddRelatedSubjectsCollectionChangedCallback Function

NSubjectAddRelatedSubjectsCollectionChangedCallback Function
NSubject.h

Adds a RelatedSubjectsCollectionChanged event callback to the specified NSubject.

C++
NResult N_API NSubjectAddRelatedSubjectsCollectionChangedCallback(HNSubject hSubject, N_COLLECTION_CHANGED_CALLBACK_ARG(HNSubject, pCallback), void * pParam);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
void * pParam | [out] Parameters passed to the callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectAddSignature Function

NSubjectAddSignature Function
NSubject.h

Adds a signature of the specified subject.

C++
NResult N_API NSubjectAddSignature(HNSubject hSubject, HNSignature hValue, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
HNSignature hValue | [in] NSignature object containing subject's signature.
NInt * pIndex | [out] Pointer to the index of the signtaure added.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectAddSignaturesCollectionChanged Function

NSubjectAddSignaturesCollectionChanged Function
NSubject.h

Adds the SignaturesCollectionChanged event to the specified NSubject.

C++
NResult N_API NSubjectAddSignaturesCollectionChanged(HNSubject hSubject, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
HNCallback hCallback | [in] Handle to the event callback to add.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectAddSignaturesCollectionChangedCallback Function

NSubjectAddSignaturesCollectionChangedCallback Function
NSubject.h

Adds the SignaturesCollectionChanged user's specified callback to the NSubject.

C++
NResult N_API NSubjectAddSignaturesCollectionChangedCallback(HNSubject hSubject, N_COLLECTION_CHANGED_CALLBACK_ARG(HNSignature, pCallback), void * pParam);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
void * pParam | [out] Parameters passed to the callback.
_nt_ | [in] User's specified callback to add.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectAddVoice Function

NSubjectAddVoice Function
NSubject.h

Adds a NVoice object to the specified NSubject.

C++
NResult N_API NSubjectAddVoice(HNSubject hSubject, HNVoice hValue, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
HNVoice hValue | [in] Handle to the NVoice object.
NInt * pIndex | [out] Pointer to the index of the object added.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectAddVoicesCollectionChanged Function

NSubjectAddVoicesCollectionChanged Function
NSubject.h

Adds a VoicesCollectionChanged event to the specified NSubject.

C++
NResult N_API NSubjectAddVoicesCollectionChanged(HNSubject hSubject, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
HNCallback hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectAddVoicesCollectionChangedCallback Function

NSubjectAddVoicesCollectionChangedCallback Function
NSubject.h

Adds a VoicesCollectionChanged event callback to the specified NSubject.

C++
NResult N_API NSubjectAddVoicesCollectionChangedCallback(HNSubject hSubject, N_COLLECTION_CHANGED_CALLBACK_ARG(HNVoice, pCallback), void * pParam);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
void * pParam | [out] Parameters passed to the callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectClear Function

NSubjectClear Function
NSubject.h

Clears the specified NSubject of all data.

C++
NResult N_API NSubjectClear(HNSubject hSubject);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectClearFaces Function

NSubjectClearFaces Function
NSubject.h

Clears all NFace objects from the specified NSubject.

C++
NResult N_API NSubjectClearFaces(HNSubject hSubject);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectClearFingers Function

NSubjectClearFingers Function
NSubject.h

Clears all NFinger objects from the specified NSubject.

C++
NResult N_API NSubjectClearFingers(HNSubject hSubject);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectClearIrises Function

NSubjectClearIrises Function
NSubject.h

Clears all NIris objects from the specified NSubject.

C++
NResult N_API NSubjectClearIrises(HNSubject hSubject);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectClearMissingEyes Function

NSubjectClearMissingEyes Function
NSubject.h

Clears all NEPosition objects representing missing eyes from the specified NSubject.

C++
NResult N_API NSubjectClearMissingEyes(HNSubject hSubject);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectClearMissingFingers Function

NSubjectClearMissingFingers Function
NSubject.h

Clears all NFPosition objects representing missing fingers from the specified NSubject.

C++
NResult N_API NSubjectClearMissingFingers(HNSubject hSubject);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectClearPalms Function

NSubjectClearPalms Function
NSubject.h

Clears all NPalm objects from the specified NSubject.

C++
NResult N_API NSubjectClearPalms(HNSubject hSubject);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectClearRelatedSubjects Function

NSubjectClearRelatedSubjects Function
NSubject.h

Clears all related NSubject objects from the specified NSubject.

C++
NResult N_API NSubjectClearRelatedSubjects(HNSubject hSubject);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectClearSignatures Function

NSubjectClearSignatures Function
NSubject.h

Clears all signatures from the specified NSubject.

C++
NResult N_API NSubjectClearSignatures(HNSubject hSubject);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectClearVoices Function

NSubjectClearVoices Function
NSubject.h

Clears all NVoice objects from the specified NSubject.

C++
NResult N_API NSubjectClearVoices(HNSubject hSubject);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectCreate Function

NSubjectCreate Function
NSubject.h

Creates a new NSubject object.

C++
NResult N_API NSubjectCreate(HNSubject * phSubject);
Collapse Expand Parameters
Parameters | Description
HNSubject * phSubject | [out] Pointer to a handle to the new NSubject.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectCreateFromFile Function

NSubjectCreateFromFile Function
NSubject.h

Creates a new NSubject object from the specified file.

C++
NResult N_API NSubjectCreateFromFile(const NChar * szFileName, NUInt flags, HNSubject * phSubject);
Collapse Expand Parameters
Parameters | Description
const NChar * szFileName | [in] Pointer to the name of the file.
NUInt flags | [in] Bitwise combination of zero or more flags that controls behavior of the function.
HNSubject * phSubject | [out] Pointer to a handle to the new NSubject.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectCreateFromFileWithFormat Function

NSubjectCreateFromFileWithFormat Function
NSubject.h

Creates a new NSubject object from the specified file with specified format.

C++
NResult N_API NSubjectCreateFromFileWithFormat(const NChar * szFileName, NUShort formatOwner, NUShort formatType, NUInt flags, HNSubject * phSubject);
Collapse Expand Parameters
Parameters | Description
const NChar * szFileName | [in] Pointer to the name of the file.
NUShort formatOwner | [in] Owner of the file format.
NUShort formatType | [in] File format type.
NUInt flags | [in] Bitwise combination of zero or more flags that controls behavior of the function.
HNSubject * phSubject | [out] Pointer to a handle to the new NSubject.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectCreateFromMemory Function

NSubjectCreateFromMemory Function
NSubject.h

Creates a new NSubject object from the specified buffer.

C++
NResult N_API NSubjectCreateFromMemory(const void * pBuffer, NSizeType bufferSize, NUInt flags, NSizeType * pSize, HNSubject * phSubject);
Collapse Expand Parameters
Parameters | Description
const void * pBuffer | [in] Pointer to the buffer.
NSizeType bufferSize | [in] Size of the buffer.
NUInt flags | [in] Bitwise combination of zero or more flags that controls behavior of the function.
NSizeType * pSize | [out] Pointer to the size of the new NSubject.
HNSubject * phSubject | [out] Pointer to a handle to the new NSubject.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectCreateFromMemoryWithFormat Function

NSubjectCreateFromMemoryWithFormat Function
NSubject.h

Creates a new NSubject object from the specified buffer with the specified format.

C++
NResult N_API NSubjectCreateFromMemoryWithFormat(const void * pBuffer, NSizeType bufferSize, NUShort formatOwner, NUShort formatType, NUInt flags, NSizeType * pSize, HNSubject * phSubject);
Collapse Expand Parameters
Parameters | Description
const void * pBuffer | [in] Pointer to the buffer.
NSizeType bufferSize | [in] Size of the buffer.
NUShort formatOwner | [in] Owner of the buffer format.
NUShort formatType | [in] Buffer format type.
NUInt flags | [in] Bitwise combination of zero or more flags that controls behavior of the function.
NSizeType * pSize | [out] Pointer to the size of the new NSubject.
HNSubject * phSubject | [out] Pointer to a handle to the new NSubject.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectCreateFromStream Function

NSubjectCreateFromStream Function
NSubject.h

Creates a new NSubject object from the specified memory stream.

C++
NResult N_API NSubjectCreateFromStream(HNStream hStream, NUInt flags, HNSubject * phSubject);
Collapse Expand Parameters
Parameters | Description
HNStream hStream | [in] Handle to the memory stream.
NUInt flags | [in] Bitwise combination of zero or more flags that controls behavior of the function.
HNSubject * phSubject | [out] Pointer to a handle to the new NSubject.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectCreateFromStreamWithFormat Function

NSubjectCreateFromStreamWithFormat Function
NSubject.h

Creates a new NSubject object from the specified memory stream with the specified format.

C++
NResult N_API NSubjectCreateFromStreamWithFormat(HNStream hStream, NUShort formatOwner, NUShort formatType, NUInt flags, HNSubject * phSubject);
Collapse Expand Parameters
Parameters | Description
HNStream hStream | [in] Handle to the memory stream.
NUShort formatOwner | [in] Owner of the stream format.
NUShort formatType | [in] Stream format type.
NUInt flags | [in] Bitwise combination of zero or more flags that controls behavior of the function.
HNSubject * phSubject | [out] Pointer to a handle to the new NSubject.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetError Function

NSubjectGetError Function
NSubject.h

Retrieves the last exception of the specified NSubject.

C++
NResult N_API NSubjectGetError(HNSubject hSubject, HNError * phValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
HNError * phValue | [out] Pointer to the last exception caused by the NSubject.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetFace Function

NSubjectGetFace Function
NSubject.h

Retrieves the specified NFace object from the specified NSubject.

C++
NResult N_API NSubjectGetFace(HNSubject hSubject, NInt index, HNFace * phValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt index | [in] Index of the object to be retrieved.
HNFace * phValue | [out] Pointer to the NFace object handle.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetFaceCapacity Function

NSubjectGetFaceCapacity Function
NSubject.h

Retrieves the maximum number of NFace objects in the specified NSubject.

C++
NResult N_API NSubjectGetFaceCapacity(HNSubject hSubject, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt * pValue | [out] Pointer to the maximum number of NFace objects.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetFaceCount Function

NSubjectGetFaceCount Function
NSubject.h

Retrieves the number of NFace objects in the specified NSubject.

C++
NResult N_API NSubjectGetFaceCount(HNSubject hSubject, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt * pValue | [out] Pointer to the number of NFace objects.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetFaces Function

NSubjectGetFaces Function
NSubject.h

Retrieves all NFace objects from the specified NSubject.

C++
NResult N_API NSubjectGetFaces(HNSubject hSubject, HNFace * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
HNFace * * parhValues | [out] Pointer to an array of NFace objects.
NInt * pValueCount | [out] Pointer to the number of objects in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetFinger Function

NSubjectGetFinger Function
NSubject.h

Retrieves the specified NFinger object from the specified NSubject.

C++
NResult N_API NSubjectGetFinger(HNSubject hSubject, NInt index, HNFinger * phValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt index | [in] Index of the object to be retrieved.
HNFinger * phValue | [out] Pointer to the NFinger object handle.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetFingerCapacity Function

NSubjectGetFingerCapacity Function
NSubject.h

Retrieves the maximum number of NFinger objects in the specified NSubject.

C++
NResult N_API NSubjectGetFingerCapacity(HNSubject hSubject, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt * pValue | [out] Pointer to the maximum number of NFinger objects.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetFingerCount Function

NSubjectGetFingerCount Function
NSubject.h

Retrieves the number of NFinger objects in the specified NSubject.

C++
NResult N_API NSubjectGetFingerCount(HNSubject hSubject, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt * pValue | [out] Pointer to the number of NFinger objects.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetFingers Function

NSubjectGetFingers Function
NSubject.h

Retrieves all NFinger objects from the specified NSubject.

C++
NResult N_API NSubjectGetFingers(HNSubject hSubject, HNFinger * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
HNFinger * * parhValues | [out] Pointer to an array of NFinger objects.
NInt * pValueCount | [out] Pointer to the number of objects in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetGender Function

NSubjectGetGender Function
NSubject.h

Gets the gender value of the specified NSubject.

C++
NResult N_API NSubjectGetGender(HNSubject hSubject, NGender * pValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NGender * pValue | [out] Pointer to the NGender object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetId Function

NSubjectGetId Function
NSubject.h

Retrieves the specified NSubject's ID.

C++
NResult N_API NSubjectGetId(HNSubject hSubject, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
HNString * phValue | [out] Pointer to the ID string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetIris Function

NSubjectGetIris Function
NSubject.h

Retrieves the specified NIris object from the specified NSubject.

C++
NResult N_API NSubjectGetIris(HNSubject hSubject, NInt index, HNIris * phValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt index | [in] Index of the object to be retrieved.
HNIris * phValue | [out] Pointer to the NIris object handle.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetIrisCapacity Function

NSubjectGetIrisCapacity Function
NSubject.h

Retrieves the maximum number of NIris objects in the specified NSubject.

C++
NResult N_API NSubjectGetIrisCapacity(HNSubject hSubject, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt * pValue | [out] Pointer to the maximum number of NIris objects.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetIrisCount Function

NSubjectGetIrisCount Function
NSubject.h

Retrieves the number of NIris objects in the specified NSubject.

C++
NResult N_API NSubjectGetIrisCount(HNSubject hSubject, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt * pValue | [out] Pointer to the number of NIris objects.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetIrises Function

NSubjectGetIrises Function
NSubject.h

Retrieves all NIris objects from the specified NSubject.

C++
NResult N_API NSubjectGetIrises(HNSubject hSubject, HNIris * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
HNIris * * parhValues | [out] Pointer to an array of NIris objects.
NInt * pValueCount | [out] Pointer to the number of objects in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetMatchingResult Function

NSubjectGetMatchingResult Function
NSubject.h

Retrieves the specified matching result from the specified NSubject.

C++
NResult N_API NSubjectGetMatchingResult(HNSubject hSubject, NInt index, HNMatchingResult * phValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt index | [in] Index of the matching result to be retrieved.
HNMatchingResult * phValue | [out] Pointer to the matching result handle.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetMatchingResultCount Function

NSubjectGetMatchingResultCount Function
NSubject.h

Retrieves the number of matching results in the specified NSubject.

C++
NResult N_API NSubjectGetMatchingResultCount(HNSubject hSubject, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt * pValue | [out] Pointer to the number of matching results.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetMatchingResults Function

NSubjectGetMatchingResults Function
NSubject.h

Retrieves all matching results from the specified NSubject.

C++
NResult N_API NSubjectGetMatchingResults(HNSubject hSubject, HNMatchingResult * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
HNMatchingResult * * parhValues | [out] Pointer to an array of matching results.
NInt * pValueCount | [out] Pointer to the number of results in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetMissingEye Function

NSubjectGetMissingEye Function
NSubject.h

Retrieves the specified NEPosition object representing a missing eye from the specified NSubject.

C++
NResult N_API NSubjectGetMissingEye(HNSubject hSubject, NInt index, NEPosition * pValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt index | [in] Index of the object to be retrieved.
NEPosition * pValue | [out] Pointer to the NEPosition object handle.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetMissingEyeCapacity Function

NSubjectGetMissingEyeCapacity Function
NSubject.h

Retrieves the maximum number of NEPosition objects in the specified NSubject.

C++
NResult N_API NSubjectGetMissingEyeCapacity(HNSubject hSubject, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt * pValue | [out] Pointer to the maximum number of NFPosition objects.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetMissingEyeCount Function

NSubjectGetMissingEyeCount Function
NSubject.h

Retrieves the number of NEPosition objects in the specified NSubject.

C++
NResult N_API NSubjectGetMissingEyeCount(HNSubject hSubject, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt * pValue | [out] Pointer to the number of NFPosition objects.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetMissingEyes Function

NSubjectGetMissingEyes Function
NSubject.h

Retrieves all NEPosition objects representing missing eyes from the specified NSubject.

C++
NResult N_API NSubjectGetMissingEyes(HNSubject hSubject, NEPosition * * parValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NEPosition * * parValues | [out] Pointer to an array of NEPostion objects.
NInt * pValueCount | [out] Pointer to the number of objects in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetMissingFinger Function

NSubjectGetMissingFinger Function
NSubject.h

Retrieves the specified NFPosition object representing a missing finger from the specified NSubject.

C++
NResult N_API NSubjectGetMissingFinger(HNSubject hSubject, NInt index, NFPosition * pValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt index | [in] Index of the object to be retrieved.
NFPosition * pValue | [out] Pointer to the NFPosition object handle.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetMissingFingerCapacity Function

NSubjectGetMissingFingerCapacity Function
NSubject.h

Retrieves the maximum number of NFPosition objects in the specified NSubject.

C++
NResult N_API NSubjectGetMissingFingerCapacity(HNSubject hSubject, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt * pValue | [out] Pointer to the maximum number of NFPosition objects.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetMissingFingerCount Function

NSubjectGetMissingFingerCount Function
NSubject.h

Retrieves the number of NFPosition objects in the specified NSubject.

C++
NResult N_API NSubjectGetMissingFingerCount(HNSubject hSubject, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt * pValue | [out] Pointer to the number of NFPosition objects.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetMissingFingers Function

NSubjectGetMissingFingers Function
NSubject.h

Retrieves all NFPosition objects representing missing fingers from the specified NSubject.

C++
NResult N_API NSubjectGetMissingFingers(HNSubject hSubject, NFPosition * * parValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NFPosition * * parValues | [out] Pointer to an array of NFPostion objects.
NInt * pValueCount | [out] Pointer to the number of objects in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetPalm Function

NSubjectGetPalm Function
NSubject.h

Retrieves the specified NPalm object from the specified NSubject.

C++
NResult N_API NSubjectGetPalm(HNSubject hSubject, NInt index, HNPalm * phValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt index | [in] Index of the object to be retrieved.
HNPalm * phValue | [out] Pointer to the NPalm object handle.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetPalmCapacity Function

NSubjectGetPalmCapacity Function
NSubject.h

Retrieves the maximum number of NPalm objects in the specified NSubject.

C++
NResult N_API NSubjectGetPalmCapacity(HNSubject hSubject, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt * pValue | [out] Pointer to the maximum number of NPalm objects.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetPalmCount Function

NSubjectGetPalmCount Function
NSubject.h

Retrieves the number of NPalm objects in the specified NSubject.

C++
NResult N_API NSubjectGetPalmCount(HNSubject hSubject, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt * pValue | [out] Pointer to the number of NPalm objects.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetPalms Function

NSubjectGetPalms Function
NSubject.h

Retrieves all NPalm objects from the specified NSubject.

C++
NResult N_API NSubjectGetPalms(HNSubject hSubject, HNPalm * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
HNPalm * * parhValues | [out] Pointer to an array of NPalm objects.
NInt * pValueCount | [out] Pointer to the number of objects in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetQueryString Function

NSubjectGetQueryString Function
NSubject.h

Gets the specified NSubject's query string.

Query string is a string which can be invoked to retrieve a corresponding NSubject.

C++
NResult N_API NSubjectGetQueryString(HNSubject hSubject, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
HNString * phValue | [out] Pointer to the query string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetRelatedSubject Function

NSubjectGetRelatedSubject Function
NSubject.h

Retrieves the specified related NSubject from the specified NSubject.

C++
NResult N_API NSubjectGetRelatedSubject(HNSubject hSubject, NInt index, HNSubject * phValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt index | [in] Index of the related NSubject to be retrieved.
HNSubject * phValue | [out] Pointer to the related NSubject handle.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Notes

Multiple subjects are involved when, for example, a single image contains several faces.

After segmentation, related subjects are generated from it.

Currently this feature is provided only for image, in future in will involve voice files.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetRelatedSubjectCapacity Function

NSubjectGetRelatedSubjectCapacity Function
NSubject.h

Retrieves the maximum number of related NSubjects in the specified NSubject.

C++
NResult N_API NSubjectGetRelatedSubjectCapacity(HNSubject hSubject, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt * pValue | [out] Pointer to the maximum number of related NSubjects.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetRelatedSubjectCount Function

NSubjectGetRelatedSubjectCount Function
NSubject.h

Retrieves the number of related NSubjects in the specified NSubject.

C++
NResult N_API NSubjectGetRelatedSubjectCount(HNSubject hSubject, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt * pValue | [out] Pointer to the number of related NSubjects.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetRelatedSubjects Function

NSubjectGetRelatedSubjects Function
NSubject.h

Retrieves all related NSubjects from the specified NSubject.

C++
NResult N_API NSubjectGetRelatedSubjects(HNSubject hSubject, HNSubject * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
HNSubject * * parhValues | [out] Pointer to an array of related NSubjects.
NInt * pValueCount | [out] Pointer to the number of NSubjects in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Notes

Multiple subjects are involved when, for example, a single image contains several faces.

After segmentation, related subjects are generated from it.

Currently this feature is provided only for image, in future in will involve voice files.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetSignature Function

NSubjectGetSignature Function
NSubject.h

Gets signature by index from the specified NSubject object.

C++
NResult N_API NSubjectGetSignature(HNSubject hSubject, NInt index, HNSignature * phValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt index | [in] Index of NSignature object to retrieve.
HNSignature * phValue | [out] Pointer to a handle of NSignature object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetSignatureCapacity Function

NSubjectGetSignatureCapacity Function
NSubject.h

Gets the signatures capacity within the specified NSubject object.

C++
NResult N_API NSubjectGetSignatureCapacity(HNSubject hSubject, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt * pValue | [out] Pointer to NInt which receives the maximum signatures capacity value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetSignatureCount Function

NSubjectGetSignatureCount Function
NSubject.h

Gets signatures count within the specified NSubject object.

C++
NResult N_API NSubjectGetSignatureCount(HNSubject hSubject, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt * pValue | [out] Pointer to NInt which receives the signatures count
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetSignatures Function

NSubjectGetSignatures Function
NSubject.h

Gets all signatures from the specified NSubject.

C++
NResult N_API NSubjectGetSignatures(HNSubject hSubject, HNSignature * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
HNSignature * * parhValues | [out] Pointer to an array of NSignature objects.
NInt * pValueCount | [out] Pointer to the number of objects in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetStatistics Function

NSubjectGetStatistics Function
NSubject.h

Retrieves the statistics (diagnostic information) of the specified NSubject.

C++
NResult N_API NSubjectGetStatistics(HNSubject hSubject, HNPropertyBag * phValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
HNPropertyBag * phValue | [out] Pointer to the property bag containing the statistics.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetStatus Function

NSubjectGetStatus Function
NSubject.h

Retrieves the biometric status of the specified NSubject.

Possible biometric status values can be found here.

C++
NResult N_API NSubjectGetStatus(HNSubject hSubject, NBiometricStatus * pValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NBiometricStatus * pValue | [out] Pointer to the biometric status value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetTemplate Function

NSubjectGetTemplate Function
NSubject.h

Gets the template used by the specified NSubject.

C++
NResult N_API NSubjectGetTemplate(HNSubject hSubject, HNTemplate * phValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
HNTemplate * phValue | [out] Pointer to the NTemplate handle.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetTemplateBuffer Function

NSubjectGetTemplateBuffer Function
NSubject.h

Gets the buffer which contains templates for the specified NSubject.

C++
NResult N_API NSubjectGetTemplateBuffer(HNSubject hSubject, HNBuffer * phValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
HNBuffer * phValue | [out] Pointer to the NBuffer handle.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetTemplateBufferWithFormatEx Function

NSubjectGetTemplateBufferWithFormatEx Function
NSubject.h

Gets the buffer which contains templates with specified format for the specified NSubject.

C++
NResult N_API NSubjectGetTemplateBufferWithFormatEx(HNSubject hSubject, NUShort formatOwner, NUShort formatType, NVersion_ version, HNBuffer * phValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NUShort formatOwner | [in] Owner of the template format.
NUShort formatType | [in] Template format type.
NVersion_ version | [in] Template version.
HNBuffer * phValue | [out] Pointer to the NBuffer handle.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetVoice Function

NSubjectGetVoice Function
NSubject.h

Retrieves the specified NVoice object from the specified NSubject.

C++
NResult N_API NSubjectGetVoice(HNSubject hSubject, NInt index, HNVoice * phValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt index | [in] Index of the object to be retrieved.
HNVoice * phValue | [out] Pointer to the NVoice object handle.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetVoiceCapacity Function

NSubjectGetVoiceCapacity Function
NSubject.h

Retrieves the maximum number of NVoice objects in the specified NSubject.

C++
NResult N_API NSubjectGetVoiceCapacity(HNSubject hSubject, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt * pValue | [out] Pointer to the maximum number of NVoice objects.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetVoiceCount Function

NSubjectGetVoiceCount Function
NSubject.h

Retrieves the number of NVoice objects in the specified NSubject.

C++
NResult N_API NSubjectGetVoiceCount(HNSubject hSubject, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt * pValue | [out] Pointer to the number of NVoice objects.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectGetVoices Function

NSubjectGetVoices Function
NSubject.h

Retrieves all NVoice objects from the specified NSubject.

C++
NResult N_API NSubjectGetVoices(HNSubject hSubject, HNVoice * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
HNVoice * * parhValues | [out] Pointer to an array of NVoice objects.
NInt * pValueCount | [out] Pointer to the number of objects in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectInsertFace Function

NSubjectInsertFace Function
NSubject.h

Adds a NFace object to the specified NSubject at the specified index.

C++
NResult N_API NSubjectInsertFace(HNSubject hSubject, NInt index, HNFace hValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt index | [in] Index at which the object will be added.
HNFace hValue | [in] Handle to the NFace object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectInsertFinger Function

NSubjectInsertFinger Function
NSubject.h

Adds a NFinger object to the specified NSubject at the specified index.

C++
NResult N_API NSubjectInsertFinger(HNSubject hSubject, NInt index, HNFinger hValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt index | [in] Index at which the object will be added.
HNFinger hValue | [in] Handle to the NFinger object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectInsertIris Function

NSubjectInsertIris Function
NSubject.h

Adds a NIris object to the specified NSubject at the specified index.

C++
NResult N_API NSubjectInsertIris(HNSubject hSubject, NInt index, HNIris hValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt index | [in] Index at which the object will be added.
HNIris hValue | [in] Handle to the NIris object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectInsertMissingEye Function

NSubjectInsertMissingEye Function
NSubject.h

Adds a NEPosition object representing a missing eye to the specified NSubject at the specified index.

C++
NResult N_API NSubjectInsertMissingEye(HNSubject hSubject, NInt index, NEPosition value);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt index | [in] Index at which the object will be added.
NEPosition value | [in] Handle to the NEPosition object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectInsertMissingFinger Function

NSubjectInsertMissingFinger Function
NSubject.h

Adds a NFPosition object representing a missing eye to the specified NSubject at the specified index.

C++
NResult N_API NSubjectInsertMissingFinger(HNSubject hSubject, NInt index, NFPosition value);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt index | [in] Index at which the object will be added.
NFPosition value | [in] Handle to the NFPosition object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectInsertPalm Function

NSubjectInsertPalm Function
NSubject.h

Adds a NPalm object to the specified NSubject at the specified index.

C++
NResult N_API NSubjectInsertPalm(HNSubject hSubject, NInt index, HNPalm hValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt index | [in] Index at which the object will be added.
HNPalm hValue | [in] Handle to the NPalm object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectInsertRelatedSubject Function

NSubjectInsertRelatedSubject Function
NSubject.h

Adds a related NSubject to the specified NSubject at the specified index.

C++
NResult N_API NSubjectInsertRelatedSubject(HNSubject hSubject, NInt index, HNSubject hValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt index | [in] Index at which the NSubject will be added.
HNSubject hValue | [in] Handle to the added NSubject object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectInsertSignature Function

NSubjectInsertSignature Function
NSubject.h

Inserts the NSignature object to the specified NSubject at the specified index.

C++
NResult N_API NSubjectInsertSignature(HNSubject hSubject, NInt index, HNSignature hValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt index | [in] Index at which the object will be added.
HNSignature hValue | [in] NSignature object containing subject's signature.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectInsertVoice Function

NSubjectInsertVoice Function
NSubject.h

Adds a NVoice object to the specified NSubject at the specified index.

C++
NResult N_API NSubjectInsertVoice(HNSubject hSubject, NInt index, HNVoice hValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt index | [in] Index at which the object will be added.
HNVoice hValue | [in] Handle to the NVoice object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectIsMultipleSubjects Function

NSubjectIsMultipleSubjects Function
NSubject.h

Checks whether the specified NSubject consists of multiple NSubjects.

C++
NResult N_API NSubjectIsMultipleSubjects(HNSubject hSubject, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NBool * pValue | [out] NTrue in the NSubject consists of multiple NSubjects; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Notes

Multiple subjects are involved when, for example, a single image contains several faces.

After segmentation, related subjects are generated from it.

Currently this feature is provided only for image, in future in will involve voice files.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectRemoveFaceAt Function

NSubjectRemoveFaceAt Function
NSubject.h

Removes the specified NFace object from the specified NSubject.

C++
NResult N_API NSubjectRemoveFaceAt(HNSubject hSubject, NInt index);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt index | [in] Index of the object to be removed.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectRemoveFacesCollectionChanged Function

NSubjectRemoveFacesCollectionChanged Function
NSubject.h

Removes a FacesCollectionChanged event from the specified NSubject.

C++
NResult N_API NSubjectRemoveFacesCollectionChanged(HNSubject hSubject, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
HNCallback hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectRemoveFacesCollectionChangedCallback Function

NSubjectRemoveFacesCollectionChangedCallback Function
NSubject.h

Removes a FacesCollectionChanged event callback from the specified NSubject.

C++
NResult N_API NSubjectRemoveFacesCollectionChangedCallback(HNSubject hSubject, N_COLLECTION_CHANGED_CALLBACK_ARG(HNFace, pCallback), void * pParam);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
void * pParam | [out] Parameters passed to the callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectRemoveFingerAt Function

NSubjectRemoveFingerAt Function
NSubject.h

Removes the specified NFinger object from the specified NSubject.

C++
NResult N_API NSubjectRemoveFingerAt(HNSubject hSubject, NInt index);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt index | [in] Index of the object to be removed.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectRemoveFingersCollectionChanged Function

NSubjectRemoveFingersCollectionChanged Function
NSubject.h

Removes a FingersCollectionChanged event from the specified NSubject.

C++
NResult N_API NSubjectRemoveFingersCollectionChanged(HNSubject hSubject, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
HNCallback hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectRemoveFingersCollectionChangedCallback Function

NSubjectRemoveFingersCollectionChangedCallback Function
NSubject.h

Removes a FingersCollectionChanged event callback from the specified NSubject.

C++
NResult N_API NSubjectRemoveFingersCollectionChangedCallback(HNSubject hSubject, N_COLLECTION_CHANGED_CALLBACK_ARG(HNFinger, pCallback), void * pParam);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
void * pParam | [out] Parameters passed to the callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectRemoveIrisAt Function

NSubjectRemoveIrisAt Function
NSubject.h

Removes the specified NIris object from the specified NSubject.

C++
NResult N_API NSubjectRemoveIrisAt(HNSubject hSubject, NInt index);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt index | [in] Index of the object to be removed.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectRemoveIrisesCollectionChanged Function

NSubjectRemoveIrisesCollectionChanged Function
NSubject.h

Removes a IrisesCollectionChanged event from the specified NSubject.

C++
NResult N_API NSubjectRemoveIrisesCollectionChanged(HNSubject hSubject, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
HNCallback hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectRemoveIrisesCollectionChangedCallback Function

NSubjectRemoveIrisesCollectionChangedCallback Function
NSubject.h

Removes a IrisesCollectionChanged event callback from the specified NSubject.

C++
NResult N_API NSubjectRemoveIrisesCollectionChangedCallback(HNSubject hSubject, N_COLLECTION_CHANGED_CALLBACK_ARG(HNIris, pCallback), void * pParam);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
void * pParam | [out] Parameters passed to the callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectRemoveMissingEyeAt Function

NSubjectRemoveMissingEyeAt Function
NSubject.h

Removes the specified NEPosition object representing a missing eye from the specified NSubject.

C++
NResult N_API NSubjectRemoveMissingEyeAt(HNSubject hSubject, NInt index);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt index | [in] Index of the object to be removed.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectRemoveMissingFingerAt Function

NSubjectRemoveMissingFingerAt Function
NSubject.h

Removes the specified NFPosition object representing a missing finger from the specified NSubject.

C++
NResult N_API NSubjectRemoveMissingFingerAt(HNSubject hSubject, NInt index);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt index | [in] Index of the object to be removed.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectRemovePalmAt Function

NSubjectRemovePalmAt Function
NSubject.h

Removes the specified NPalm object from the specified NSubject.

C++
NResult N_API NSubjectRemovePalmAt(HNSubject hSubject, NInt index);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt index | [in] Index of the object to be removed.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectRemovePalmsCollectionChanged Function

NSubjectRemovePalmsCollectionChanged Function
NSubject.h

Removes a PalmsCollectionChanged event from the specified NSubject.

C++
NResult N_API NSubjectRemovePalmsCollectionChanged(HNSubject hSubject, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
HNCallback hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectRemovePalmsCollectionChangedCallback Function

NSubjectRemovePalmsCollectionChangedCallback Function
NSubject.h

Removes a PalmsCollectionChanged event callback from the specified NSubject.

C++
NResult N_API NSubjectRemovePalmsCollectionChangedCallback(HNSubject hSubject, N_COLLECTION_CHANGED_CALLBACK_ARG(HNPalm, pCallback), void * pParam);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
void * pParam | [out] Parameters passed to the callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectRemoveRelatedSubjectAt Function

NSubjectRemoveRelatedSubjectAt Function
NSubject.h

Removes the specified related NSubject from the specified NSubject.

C++
NResult N_API NSubjectRemoveRelatedSubjectAt(HNSubject hSubject, NInt index);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt index | [in] Index of the NSubject to be removed.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectRemoveRelatedSubjectsCollectionChanged Function

NSubjectRemoveRelatedSubjectsCollectionChanged Function
NSubject.h

Removes a RelatedSubjectsCollectionChanged event from the specified NSubject.

C++
NResult N_API NSubjectRemoveRelatedSubjectsCollectionChanged(HNSubject hSubject, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
HNCallback hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectRemoveRelatedSubjectsCollectionChangedCallback Function

NSubjectRemoveRelatedSubjectsCollectionChangedCallback Function
NSubject.h

Removes a RelatedSubjectsCollectionChanged event callback from the specified NSubject.

C++
NResult N_API NSubjectRemoveRelatedSubjectsCollectionChangedCallback(HNSubject hSubject, N_COLLECTION_CHANGED_CALLBACK_ARG(HNSubject, pCallback), void * pParam);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
void * pParam | [out] Parameters passed to the callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectRemoveSignatureAt Function

NSubjectRemoveSignatureAt Function
NSubject.h

Removes the signature specified by an index.

C++
NResult N_API NSubjectRemoveSignatureAt(HNSubject hSubject, NInt index);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt index | [in] Index of the NSubject to be removed.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectRemoveSignaturesCollectionChanged Function

NSubjectRemoveSignaturesCollectionChanged Function
NSubject.h

Removes the SignaturesCollectionChanged event from the specified NSubject.

C++
NResult N_API NSubjectRemoveSignaturesCollectionChanged(HNSubject hSubject, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
HNCallback hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectRemoveSignaturesCollectionChangedCallback Function

NSubjectRemoveSignaturesCollectionChangedCallback Function
NSubject.h

Removes the SignaturesCollectionChanged user's specified callback from the NSubject.

C++
NResult N_API NSubjectRemoveSignaturesCollectionChangedCallback(HNSubject hSubject, N_COLLECTION_CHANGED_CALLBACK_ARG(HNSignature, pCallback), void * pParam);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
void * pParam | [out] Parameters passed to the callback.
_nt_ | [in] User's specified callback to remove.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectRemoveVoiceAt Function

NSubjectRemoveVoiceAt Function
NSubject.h

Removes the specified NVoice object from the specified NSubject.

C++
NResult N_API NSubjectRemoveVoiceAt(HNSubject hSubject, NInt index);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt index | [in] Index of the object to be removed.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectRemoveVoicesCollectionChanged Function

NSubjectRemoveVoicesCollectionChanged Function
NSubject.h

Removes a VoicesCollectionChanged event from the specified NSubject.

C++
NResult N_API NSubjectRemoveVoicesCollectionChanged(HNSubject hSubject, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
HNCallback hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectRemoveVoicesCollectionChangedCallback Function

NSubjectRemoveVoicesCollectionChangedCallback Function
NSubject.h

Removes a VoicesCollectionChanged event callback from the specified NSubject.

C++
NResult N_API NSubjectRemoveVoicesCollectionChangedCallback(HNSubject hSubject, N_COLLECTION_CHANGED_CALLBACK_ARG(HNVoice, pCallback), void * pParam);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
void * pParam | [out] Parameters passed to the callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectSetFace Function

NSubjectSetFace Function
NSubject.h

Sets the value of the specified NFace object in the specified NSubject.

C++
NResult N_API NSubjectSetFace(HNSubject hSubject, NInt index, HNFace hValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt index | [in] Index of the object to be set.
HNFace hValue | [in] Handle to the new NFace object value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectSetFaceCapacity Function

NSubjectSetFaceCapacity Function
NSubject.h

Sets the maximum number of NFace objects for the specified NSubject.

C++
NResult N_API NSubjectSetFaceCapacity(HNSubject hSubject, NInt value);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt value | [in] The maximum number of NFace objects.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectSetFinger Function

NSubjectSetFinger Function
NSubject.h

Sets the value of the specified NFinger object in the specified NSubject.

C++
NResult N_API NSubjectSetFinger(HNSubject hSubject, NInt index, HNFinger hValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt index | [in] Index of the object to be set.
HNFinger hValue | [in] Handle to the new NFinger object value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectSetFingerCapacity Function

NSubjectSetFingerCapacity Function
NSubject.h

Sets the maximum number of NFinger objects for the specified NSubject.

C++
NResult N_API NSubjectSetFingerCapacity(HNSubject hSubject, NInt value);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt value | [in] The maximum number of NFinger objects.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectSetGender Function

NSubjectSetGender Function
NSubject.h

Sets the gender value of the specified NSubject.

C++
NResult N_API NSubjectSetGender(HNSubject hSubject, NGender value);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NGender value | [in] NGender object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectSetId Function

NSubjectSetId Function
NSubject.h

Sets the specified NSubject's ID.

C++
NResult N_API NSubjectSetId(HNSubject hSubject, const NChar * szValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
const NChar * szValue | [in] Pointer to the ID string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectSetIris Function

NSubjectSetIris Function
NSubject.h

Sets the value of the specified NIris object in the specified NSubject.

C++
NResult N_API NSubjectSetIris(HNSubject hSubject, NInt index, HNIris hValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt index | [in] Index of the object to be set.
HNIris hValue | [in] Handle to the new NIris object value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectSetIrisCapacity Function

NSubjectSetIrisCapacity Function
NSubject.h

Sets the maximum number of NIris objects for the specified NSubject.

C++
NResult N_API NSubjectSetIrisCapacity(HNSubject hSubject, NInt value);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt value | [in] The maximum number of NIris objects.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectSetMissingEye Function

NSubjectSetMissingEye Function
NSubject.h

Sets the value of the specified NEPosition object representing a missing eye in the specified NSubject.

C++
NResult N_API NSubjectSetMissingEye(HNSubject hSubject, NInt index, NEPosition value);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt index | [in] Index of the object to be set.
NEPosition value | [in] Handle to the new NEPosition object value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectSetMissingEyeCapacity Function

NSubjectSetMissingEyeCapacity Function
NSubject.h

Sets the maximum number of NEPosition objects for the specified NSubject.

C++
NResult N_API NSubjectSetMissingEyeCapacity(HNSubject hSubject, NInt value);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt value | [in] The maximum number of NEPosition objects.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectSetMissingFinger Function

NSubjectSetMissingFinger Function
NSubject.h

Sets the value of the specified NFPosition object representing a missing finger in the specified NSubject.

C++
NResult N_API NSubjectSetMissingFinger(HNSubject hSubject, NInt index, NFPosition value);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt index | [in] Index of the object to be set.
NFPosition value | [in] Handle to the new NFPosition object value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectSetMissingFingerCapacity Function

NSubjectSetMissingFingerCapacity Function
NSubject.h

Sets the maximum number of NFPosition objects for the specified NSubject.

C++
NResult N_API NSubjectSetMissingFingerCapacity(HNSubject hSubject, NInt value);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt value | [in] The maximum number of NFPosition objects.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectSetMultipleSubjects Function

NSubjectSetMultipleSubjects Function
NSubject.h

Sets whether the specified NSubject consists of multiple NSubjects.

C++
NResult N_API NSubjectSetMultipleSubjects(HNSubject hSubject, NBool value);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NBool value | [in] NTrue in the NSubject consists of multiple NSubjects; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Notes

Multiple subjects are involved when, for example, a single image contains several faces.

After segmentation, related subjects are generated from it.

Currently this feature is provided only for image, in future in will involve voice files.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectSetPalm Function

NSubjectSetPalm Function
NSubject.h

Sets the value of the specified NPalm object in the specified NSubject.

C++
NResult N_API NSubjectSetPalm(HNSubject hSubject, NInt index, HNPalm hValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt index | [in] Index of the object to be set.
HNPalm hValue | [in] Handle to the new NPalm object value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectSetPalmCapacity Function

NSubjectSetPalmCapacity Function
NSubject.h

Sets the maximum number of NPalm objects for the specified NSubject.

C++
NResult N_API NSubjectSetPalmCapacity(HNSubject hSubject, NInt value);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt value | [in] The maximum number of NPalm objects.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectSetQueryString Function

NSubjectSetQueryString Function
NSubject.h

Sets the specified NSubject's query string.

C++
NResult N_API NSubjectSetQueryString(HNSubject hSubject, const NChar * szValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
const NChar * szValue | [in] Pointer to the query string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectSetRelatedSubject Function

NSubjectSetRelatedSubject Function
NSubject.h

Sets the value of the specified related NSubject in the specified NSubject.

C++
NResult N_API NSubjectSetRelatedSubject(HNSubject hSubject, NInt index, HNSubject hValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt index | [in] Index of the NSubject to be set.
HNSubject hValue | [in] Handle to the new related NSubject value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Notes

Multiple subjects are involved when, for example, a single image contains several faces.

After segmentation, related subjects are generated from it.

Currently this feature is provided only for image, in future in will involve voice files.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectSetRelatedSubjectCapacity Function

NSubjectSetRelatedSubjectCapacity Function
NSubject.h

Sets the maximum number of related NSubjects for the specified NSubject.

C++
NResult N_API NSubjectSetRelatedSubjectCapacity(HNSubject hSubject, NInt value);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt value | [in] The maximum number of related NSubjects.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectSetSignature Function

NSubjectSetSignature Function
NSubject.h

Sets signature value (by index) for the NSubject object.

C++
NResult N_API NSubjectSetSignature(HNSubject hSubject, NInt index, HNSignature hValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt index | [in] Index of NSignature object to set.
HNSignature hValue | [in] NSignature object to set.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectSetSignatureCapacity Function

NSubjectSetSignatureCapacity Function
NSubject.h

Sets the signatures capacity for the specified NSubject object.

C++
NResult N_API NSubjectSetSignatureCapacity(HNSubject hSubject, NInt value);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt value | [in] The maximum signatures capacity value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectSetTemplate Function

NSubjectSetTemplate Function
NSubject.h

Sets the template to be used by the specified NSubject.

C++
NResult N_API NSubjectSetTemplate(HNSubject hSubject, HNTemplate hValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
HNTemplate hValue | [in] Handle to the NTemplate.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectSetTemplateAN Function

NSubjectSetTemplateAN Function
NSubject.h

Sets the ANTemplate to be used by the specified NSubject.

C++
NResult N_API NSubjectSetTemplateAN(HNSubject hSubject, HANTemplate hValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
HANTemplate hValue | [in] Handle to the ANTemplate.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectSetTemplateBuffer Function

NSubjectSetTemplateBuffer Function
NSubject.h

Sets the buffer to contain templates for the specified NSubject.

C++
NResult N_API NSubjectSetTemplateBuffer(HNSubject hSubject, HNBuffer hValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
HNBuffer hValue | [in] Handle to the NBuffer.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectSetTemplateBufferWithFormat Function

NSubjectSetTemplateBufferWithFormat Function
NSubject.h

Sets the buffer to contain templates with specified format for the specified NSubject.

C++
NResult N_API NSubjectSetTemplateBufferWithFormat(HNSubject hSubject, HNBuffer hValue, NUShort formatOwner, NUShort formatType);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
HNBuffer hValue | [in] Handle to the NBuffer.
NUShort formatOwner | [in] Owner of the template format.
NUShort formatType | [in] Template format type.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectSetTemplateCbeff Function

NSubjectSetTemplateCbeff Function
NSubject.h

Sets the CbeffRecord to be used by the specified NSubject.

C++
NResult N_API NSubjectSetTemplateCbeff(HNSubject hSubject, HCbeffRecord hValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
HCbeffRecord hValue | [in] Handle to the CbeffRecord.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectSetTemplateFC Function

NSubjectSetTemplateFC Function
NSubject.h

Sets the FCRecord to be used by the specified NSubject.

C++
NResult N_API NSubjectSetTemplateFC(HNSubject hSubject, HFCRecord hValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
HFCRecord hValue | [in] Handle to the FCRecord.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectSetTemplateFI Function

NSubjectSetTemplateFI Function
NSubject.h

Sets the FIRecord to be used by the specified NSubject.

C++
NResult N_API NSubjectSetTemplateFI(HNSubject hSubject, HFIRecord hValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
HFIRecord hValue | [in] Handle to the FIRecord.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectSetTemplateFM Function

NSubjectSetTemplateFM Function
NSubject.h

Sets the FMRecord to be used by the specified NSubject.

C++
NResult N_API NSubjectSetTemplateFM(HNSubject hSubject, HFMRecord hValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
HFMRecord hValue | [in] Handle to the FMRecord.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectSetTemplateFMC Function

NSubjectSetTemplateFMC Function
NSubject.h

Sets the FMCRecord to be used by the specified NSubject.

C++
NResult N_API NSubjectSetTemplateFMC(HNSubject hSubject, HFMCRecord hValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
HFMCRecord hValue | [in] Handle to the FMCRecord.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectSetTemplateII Function

NSubjectSetTemplateII Function
NSubject.h

Sets the IIRecord to be used by the specified NSubject.

C++
NResult N_API NSubjectSetTemplateII(HNSubject hSubject, HIIRecord hValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
HIIRecord hValue | [in] Handle to the IIRecord.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectSetVoice Function

NSubjectSetVoice Function
NSubject.h

Sets the value of the specified NVoice object in the specified NSubject.

C++
NResult N_API NSubjectSetVoice(HNSubject hSubject, NInt index, HNVoice hValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt index | [in] Index of the object to be set.
HNVoice hValue | [in] Handle to the new NVoice object value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectSetVoiceCapacity Function

NSubjectSetVoiceCapacity Function
NSubject.h

Sets the maximum number of NVoice objects for the specified NSubject.

C++
NResult N_API NSubjectSetVoiceCapacity(HNSubject hSubject, NInt value);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NInt value | [in] The maximum number of NVoice objects.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectToANTemplate Function

NSubjectToANTemplate Function
NSubject.h

Converts the biometric subject into a ANTemplate.

C++
NResult N_API NSubjectToANTemplate(HNSubject hSubject, NVersion_ version, const NChar * szTot, const NChar * szDai, const NChar * szOri, const NChar * szTcn, HANTemplate * phValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
NVersion_ version | [in] ANTemplate version.
const NChar * szTot | [in] Zero terminated string which contains transaction type identifier.
const NChar * szDai | [in] Zero terminated string which contains destination agency identifier.
const NChar * szOri | [in] Zero terminated string which contains originating agency identifier.
const NChar * szTcn | [in] Zero terminated string which contains transaction control identifier.
HANTemplate * phValue | [out] Pointer to the new ANTemplate.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectToFCRecord Function

NSubjectToFCRecord Function
NSubject.h

Converts the biometric subject into a FCRecord.

C++
NResult N_API NSubjectToFCRecord(HNSubject hSubject, BdifStandard standard, NVersion_ version, HFCRecord * phValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
BdifStandard standard | [in] BDIF standard.
NVersion_ version | [in] Record version.
HFCRecord * phValue | [out] Pointer to the FCRecord.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectToFIRecord Function

NSubjectToFIRecord Function
NSubject.h

Converts the biometric subject into a FIRecord.

C++
NResult N_API NSubjectToFIRecord(HNSubject hSubject, BdifStandard standard, NVersion_ version, HFIRecord * phValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
BdifStandard standard | [in] BDIF standard.
NVersion_ version | [in] Record version.
HFIRecord * phValue | [out] Pointer to the FIRecord.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectToFMCRecord Function

NSubjectToFMCRecord Function
NSubject.h

Converts the biometric subject into a FMCRecord.

C++
NResult N_API NSubjectToFMCRecord(HNSubject hSubject, BdifStandard standard, NVersion_ version, FmcrMinutiaFormat minutiaFormat, HFMCRecord * phValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
BdifStandard standard | [in] BDIF standard.
NVersion_ version | [in] Record version.
FmcrMinutiaFormat minutiaFormat | [in] The minutia format.
HFMCRecord * phValue | [out] Pointer to the FMCRecord.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectToFMRecord Function

NSubjectToFMRecord Function
NSubject.h

Converts the biometric subject into a FMRecord.

C++
NResult N_API NSubjectToFMRecord(HNSubject hSubject, BdifStandard standard, NVersion_ version, HFMRecord * phValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
BdifStandard standard | [in] BDIF standard.
NVersion_ version | [in] Record version.
HFMRecord * phValue | [out] Pointer to the FMRecord.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectToFMRecordEx Function

NSubjectToFMRecordEx Function
NSubject.h

Converts the biometric subject into a FMRecord.

C++
NResult N_API NSubjectToFMRecordEx(HNSubject hSubject, BdifStandard standard, NVersion_ version, NUInt flags, HFMRecord * phValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
BdifStandard standard | [in] BDIF standard.
NVersion_ version | [in] Record version.
NUInt flags | [in] Record flags.
HFMRecord * phValue | [out] Pointer to the FMRecord.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectToIIRecord Function

NSubjectToIIRecord Function
NSubject.h

Converts the biometric subject into a IIRecord.

C++
NResult N_API NSubjectToIIRecord(HNSubject hSubject, BdifStandard standard, NVersion_ version, HIIRecord * phValue);
Collapse Expand Parameters
Parameters | Description
HNSubject hSubject | [in] Handle to the NSubject object.
BdifStandard standard | [in] BDIF standard.
NVersion_ version | [in] Record version.
HIIRecord * phValue | [out] Pointer to the IIRecord.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSubject.h

Module: NSubject Unit


NSubjectCreateFromFile Macro

NSubjectCreateFromFile Macro
NSubject.h

Picks a Unicode (W) or ANSCII (A) version of the NSubjectCreateFromFile function.

C++
#define NSubjectCreateFromFile N_FUNC_AW(NSubjectCreateFromFile)
Container

File: NSubject.h

Module: NSubject Unit


NSubjectCreateFromFileWithFormat Macro

NSubjectCreateFromFileWithFormat Macro
NSubject.h

Picks a Unicode (W) or ANSCII (A) version of the NSubjectCreateFromFileWithFormat function.

C++
#define NSubjectCreateFromFileWithFormat N_FUNC_AW(NSubjectCreateFromFileWithFormat)
Container

File: NSubject.h

Module: NSubject Unit


NSubjectSetId Macro

NSubjectSetId Macro
NSubject.h

Picks a Unicode (W) or ANSCII (A) version of the NSubjectSetId function.

C++
#define NSubjectSetId N_FUNC_AW(NSubjectSetId)
Container

File: NSubject.h

Module: NSubject Unit


NSubjectSetQueryString Macro

NSubjectSetQueryString Macro
NSubject.h

Picks a Unicode (W) or ANSCII (A) version of the NSubjectSetQueryString function.

C++
#define NSubjectSetQueryString N_FUNC_AW(NSubjectSetQueryString)
Container

File: NSubject.h

Module: NSubject Unit


NSubject.h

NSubject.h
Functions Legend Macros

Header file for the NSubject unit.

Collapse Expand Functions
Name | Description
NSubjectAddFace | Adds a NFace object to the specified NSubject.
NSubjectAddFacesCollectionChanged | Adds a FacesCollectionChanged event to the specified NSubject.
NSubjectAddFacesCollectionChangedCallback | Adds a FacesCollectionChanged event callback to the specified NSubject.
NSubjectAddFinger | Adds a NFinger object to the specified NSubject.
NSubjectAddFingersCollectionChanged | Adds a FingersCollectionChanged event to the specified NSubject.
NSubjectAddFingersCollectionChangedCallback | Adds a FingersCollectionChanged event callback to the specified NSubject.
NSubjectAddIris | Adds a NIris object to the specified NSubject.
NSubjectAddIrisesCollectionChanged | Adds a IrisesCollectionChanged event to the specified NSubject.
NSubjectAddIrisesCollectionChangedCallback | Adds a IrisesCollectionChanged event callback to the specified NSubject.
NSubjectAddMissingEye | Adds a NEPosition object representing a missing eye to the specified NSubject.
NSubjectAddMissingFinger | Adds a NFPosition object representing a missing finger(s) to the specified NSubject.
NSubjectAddPalm | Adds a NPalm object to the specified NSubject.
NSubjectAddPalmsCollectionChanged | Adds a PalmsCollectionChanged event to the specified NSubject.
NSubjectAddPalmsCollectionChangedCallback | Adds a PalmsCollectionChanged event callback to the specified NSubject.
NSubjectAddRelatedSubject | Adds a related NSubject object to the specified NSubject.
NSubjectAddRelatedSubjectsCollectionChanged | Adds a RelatedSubjectsCollectionChanged event to the specified NSubject.
NSubjectAddRelatedSubjectsCollectionChangedCallback | Adds a RelatedSubjectsCollectionChanged event callback to the specified NSubject.
NSubjectAddSignature | Adds a signature of the specified subject.
NSubjectAddSignaturesCollectionChanged | Adds the SignaturesCollectionChanged event to the specified NSubject.
NSubjectAddSignaturesCollectionChangedCallback | Adds the SignaturesCollectionChanged user's specified callback to the NSubject.
NSubjectAddVoice | Adds a NVoice object to the specified NSubject.
NSubjectAddVoicesCollectionChanged | Adds a VoicesCollectionChanged event to the specified NSubject.
NSubjectAddVoicesCollectionChangedCallback | Adds a VoicesCollectionChanged event callback to the specified NSubject.
NSubjectClear | Clears the specified NSubject of all data.
NSubjectClearFaces | Clears all NFace objects from the specified NSubject.
NSubjectClearFingers | Clears all NFinger objects from the specified NSubject.
NSubjectClearIrises | Clears all NIris objects from the specified NSubject.
NSubjectClearMissingEyes | Clears all NEPosition objects representing missing eyes from the specified NSubject.
NSubjectClearMissingFingers | Clears all NFPosition objects representing missing fingers from the specified NSubject.
NSubjectClearPalms | Clears all NPalm objects from the specified NSubject.
NSubjectClearRelatedSubjects | Clears all related NSubject objects from the specified NSubject.
NSubjectClearSignatures | Clears all signatures from the specified NSubject.
NSubjectClearVoices | Clears all NVoice objects from the specified NSubject.
NSubjectCreate | Creates a new NSubject object.
NSubjectCreateFromFile | Creates a new NSubject object from the specified file.
NSubjectCreateFromFileWithFormat | Creates a new NSubject object from the specified file with specified format.
NSubjectCreateFromMemory | Creates a new NSubject object from the specified buffer.
NSubjectCreateFromMemoryWithFormat | Creates a new NSubject object from the specified buffer with the specified format.
NSubjectCreateFromStream | Creates a new NSubject object from the specified memory stream.
NSubjectCreateFromStreamWithFormat | Creates a new NSubject object from the specified memory stream with the specified format.
NSubjectGetError | Retrieves the last exception of the specified NSubject.
NSubjectGetFace | Retrieves the specified NFace object from the specified NSubject.
NSubjectGetFaceCapacity | Retrieves the maximum number of NFace objects in the specified NSubject.
NSubjectGetFaceCount | Retrieves the number of NFace objects in the specified NSubject.
NSubjectGetFaces | Retrieves all NFace objects from the specified NSubject.
NSubjectGetFinger | Retrieves the specified NFinger object from the specified NSubject.
NSubjectGetFingerCapacity | Retrieves the maximum number of NFinger objects in the specified NSubject.
NSubjectGetFingerCount | Retrieves the number of NFinger objects in the specified NSubject.
NSubjectGetFingers | Retrieves all NFinger objects from the specified NSubject.
NSubjectGetGender | Gets the gender value of the specified NSubject.
NSubjectGetId | Retrieves the specified NSubject's ID.
NSubjectGetIris | Retrieves the specified NIris object from the specified NSubject.
NSubjectGetIrisCapacity | Retrieves the maximum number of NIris objects in the specified NSubject.
NSubjectGetIrisCount | Retrieves the number of NIris objects in the specified NSubject.
NSubjectGetIrises | Retrieves all NIris objects from the specified NSubject.
NSubjectGetMatchingResult | Retrieves the specified matching result from the specified NSubject.
NSubjectGetMatchingResultCount | Retrieves the number of matching results in the specified NSubject.
NSubjectGetMatchingResults | Retrieves all matching results from the specified NSubject.
NSubjectGetMissingEye | Retrieves the specified NEPosition object representing a missing eye from the specified NSubject.
NSubjectGetMissingEyeCapacity | Retrieves the maximum number of NEPosition objects in the specified NSubject.
NSubjectGetMissingEyeCount | Retrieves the number of NEPosition objects in the specified NSubject.
NSubjectGetMissingEyes | Retrieves all NEPosition objects representing missing eyes from the specified NSubject.
NSubjectGetMissingFinger | Retrieves the specified NFPosition object representing a missing finger from the specified NSubject.
NSubjectGetMissingFingerCapacity | Retrieves the maximum number of NFPosition objects in the specified NSubject.
NSubjectGetMissingFingerCount | Retrieves the number of NFPosition objects in the specified NSubject.
NSubjectGetMissingFingers | Retrieves all NFPosition objects representing missing fingers from the specified NSubject.
NSubjectGetPalm | Retrieves the specified NPalm object from the specified NSubject.
NSubjectGetPalmCapacity | Retrieves the maximum number of NPalm objects in the specified NSubject.
NSubjectGetPalmCount | Retrieves the number of NPalm objects in the specified NSubject.
NSubjectGetPalms | Retrieves all NPalm objects from the specified NSubject.
NSubjectGetQueryString | Gets the specified NSubject's query string. Query string is a string which can be invoked to retrieve a corresponding NSubject.
NSubjectGetRelatedSubject | Retrieves the specified related NSubject from the specified NSubject.
NSubjectGetRelatedSubjectCapacity | Retrieves the maximum number of related NSubjects in the specified NSubject.
NSubjectGetRelatedSubjectCount | Retrieves the number of related NSubjects in the specified NSubject.
NSubjectGetRelatedSubjects | Retrieves all related NSubjects from the specified NSubject.
NSubjectGetSignature | Gets signature by index from the specified NSubject object.
NSubjectGetSignatureCapacity | Gets the signatures capacity within the specified NSubject object.
NSubjectGetSignatureCount | Gets signatures count within the specified NSubject object.
NSubjectGetSignatures | Gets all signatures from the specified NSubject.
NSubjectGetStatistics | Retrieves the statistics (diagnostic information) of the specified NSubject.
NSubjectGetStatus | Retrieves the biometric status of the specified NSubject. Possible biometric status values can be found here.
NSubjectGetTemplate | Gets the template used by the specified NSubject.
NSubjectGetTemplateBuffer | Gets the buffer which contains templates for the specified NSubject.
NSubjectGetTemplateBufferWithFormatEx | Gets the buffer which contains templates with specified format for the specified NSubject.
NSubjectGetVoice | Retrieves the specified NVoice object from the specified NSubject.
NSubjectGetVoiceCapacity | Retrieves the maximum number of NVoice objects in the specified NSubject.
NSubjectGetVoiceCount | Retrieves the number of NVoice objects in the specified NSubject.
NSubjectGetVoices | Retrieves all NVoice objects from the specified NSubject.
NSubjectInsertFace | Adds a NFace object to the specified NSubject at the specified index.
NSubjectInsertFinger | Adds a NFinger object to the specified NSubject at the specified index.
NSubjectInsertIris | Adds a NIris object to the specified NSubject at the specified index.
NSubjectInsertMissingEye | Adds a NEPosition object representing a missing eye to the specified NSubject at the specified index.
NSubjectInsertMissingFinger | Adds a NFPosition object representing a missing eye to the specified NSubject at the specified index.
NSubjectInsertPalm | Adds a NPalm object to the specified NSubject at the specified index.
NSubjectInsertRelatedSubject | Adds a related NSubject to the specified NSubject at the specified index.
NSubjectInsertSignature | Inserts the NSignature object to the specified NSubject at the specified index.
NSubjectInsertVoice | Adds a NVoice object to the specified NSubject at the specified index.
NSubjectIsMultipleSubjects | Checks whether the specified NSubject consists of multiple NSubjects.
NSubjectRemoveFaceAt | Removes the specified NFace object from the specified NSubject.
NSubjectRemoveFacesCollectionChanged | Removes a FacesCollectionChanged event from the specified NSubject.
NSubjectRemoveFacesCollectionChangedCallback | Removes a FacesCollectionChanged event callback from the specified NSubject.
NSubjectRemoveFingerAt | Removes the specified NFinger object from the specified NSubject.
NSubjectRemoveFingersCollectionChanged | Removes a FingersCollectionChanged event from the specified NSubject.
NSubjectRemoveFingersCollectionChangedCallback | Removes a FingersCollectionChanged event callback from the specified NSubject.
NSubjectRemoveIrisAt | Removes the specified NIris object from the specified NSubject.
NSubjectRemoveIrisesCollectionChanged | Removes a IrisesCollectionChanged event from the specified NSubject.
NSubjectRemoveIrisesCollectionChangedCallback | Removes a IrisesCollectionChanged event callback from the specified NSubject.
NSubjectRemoveMissingEyeAt | Removes the specified NEPosition object representing a missing eye from the specified NSubject.
NSubjectRemoveMissingFingerAt | Removes the specified NFPosition object representing a missing finger from the specified NSubject.
NSubjectRemovePalmAt | Removes the specified NPalm object from the specified NSubject.
NSubjectRemovePalmsCollectionChanged | Removes a PalmsCollectionChanged event from the specified NSubject.
NSubjectRemovePalmsCollectionChangedCallback | Removes a PalmsCollectionChanged event callback from the specified NSubject.
NSubjectRemoveRelatedSubjectAt | Removes the specified related NSubject from the specified NSubject.
NSubjectRemoveRelatedSubjectsCollectionChanged | Removes a RelatedSubjectsCollectionChanged event from the specified NSubject.
NSubjectRemoveRelatedSubjectsCollectionChangedCallback | Removes a RelatedSubjectsCollectionChanged event callback from the specified NSubject.
NSubjectRemoveSignatureAt | Removes the signature specified by an index.
NSubjectRemoveSignaturesCollectionChanged | Removes the SignaturesCollectionChanged event from the specified NSubject.
NSubjectRemoveSignaturesCollectionChangedCallback | Removes the SignaturesCollectionChanged user's specified callback from the NSubject.
NSubjectRemoveVoiceAt | Removes the specified NVoice object from the specified NSubject.
NSubjectRemoveVoicesCollectionChanged | Removes a VoicesCollectionChanged event from the specified NSubject.
NSubjectRemoveVoicesCollectionChangedCallback | Removes a VoicesCollectionChanged event callback from the specified NSubject.
NSubjectSetFace | Sets the value of the specified NFace object in the specified NSubject.
NSubjectSetFaceCapacity | Sets the maximum number of NFace objects for the specified NSubject.
NSubjectSetFinger | Sets the value of the specified NFinger object in the specified NSubject.
NSubjectSetFingerCapacity | Sets the maximum number of NFinger objects for the specified NSubject.
NSubjectSetGender | Sets the gender value of the specified NSubject.
NSubjectSetId | Sets the specified NSubject's ID.
NSubjectSetIris | Sets the value of the specified NIris object in the specified NSubject.
NSubjectSetIrisCapacity | Sets the maximum number of NIris objects for the specified NSubject.
NSubjectSetMissingEye | Sets the value of the specified NEPosition object representing a missing eye in the specified NSubject.
NSubjectSetMissingEyeCapacity | Sets the maximum number of NEPosition objects for the specified NSubject.
NSubjectSetMissingFinger | Sets the value of the specified NFPosition object representing a missing finger in the specified NSubject.
NSubjectSetMissingFingerCapacity | Sets the maximum number of NFPosition objects for the specified NSubject.
NSubjectSetMultipleSubjects | Sets whether the specified NSubject consists of multiple NSubjects.
NSubjectSetPalm | Sets the value of the specified NPalm object in the specified NSubject.
NSubjectSetPalmCapacity | Sets the maximum number of NPalm objects for the specified NSubject.
NSubjectSetQueryString | Sets the specified NSubject's query string.
NSubjectSetRelatedSubject | Sets the value of the specified related NSubject in the specified NSubject.
NSubjectSetRelatedSubjectCapacity | Sets the maximum number of related NSubjects for the specified NSubject.
NSubjectSetSignature | Sets signature value (by index) for the NSubject object.
NSubjectSetSignatureCapacity | Sets the signatures capacity for the specified NSubject object.
NSubjectSetTemplate | Sets the template to be used by the specified NSubject.
NSubjectSetTemplateAN | Sets the ANTemplate to be used by the specified NSubject.
NSubjectSetTemplateBuffer | Sets the buffer to contain templates for the specified NSubject.
NSubjectSetTemplateBufferWithFormat | Sets the buffer to contain templates with specified format for the specified NSubject.
NSubjectSetTemplateCbeff | Sets the CbeffRecord to be used by the specified NSubject.
NSubjectSetTemplateFC | Sets the FCRecord to be used by the specified NSubject.
NSubjectSetTemplateFI | Sets the FIRecord to be used by the specified NSubject.
NSubjectSetTemplateFM | Sets the FMRecord to be used by the specified NSubject.
NSubjectSetTemplateFMC | Sets the FMCRecord to be used by the specified NSubject.
NSubjectSetTemplateII | Sets the IIRecord to be used by the specified NSubject.
NSubjectSetVoice | Sets the value of the specified NVoice object in the specified NSubject.
NSubjectSetVoiceCapacity | Sets the maximum number of NVoice objects for the specified NSubject.
NSubjectToANTemplate | Converts the biometric subject into a ANTemplate.
NSubjectToFCRecord | Converts the biometric subject into a FCRecord.
NSubjectToFIRecord | Converts the biometric subject into a FIRecord.
NSubjectToFMCRecord | Converts the biometric subject into a FMCRecord.
NSubjectToFMRecord | Converts the biometric subject into a FMRecord.
NSubjectToFMRecordEx | Converts the biometric subject into a FMRecord.
NSubjectToIIRecord | Converts the biometric subject into a IIRecord.
Collapse Expand Macros
Name | Description
NSubjectCreateFromFile | Picks a Unicode (W) or ANSCII (A) version of the NSubjectCreateFromFile function.
NSubjectCreateFromFileWithFormat | Picks a Unicode (W) or ANSCII (A) version of the NSubjectCreateFromFileWithFormat function.
NSubjectSetId | Picks a Unicode (W) or ANSCII (A) version of the NSubjectSetId function.
NSubjectSetQueryString | Picks a Unicode (W) or ANSCII (A) version of the NSubjectSetQueryString function.


NTemplate Unit

NTemplate Unit
Files Functions Legend

Provides functionality for packing, unpacking and editing Neurotechnology Templates (NTemplates).

Collapse Expand Notes

When NTemplate contains palm records fusion is not available.

Collapse Expand Files
Name | Description
NTemplate.h | ... more
Collapse Expand Functions
Name | Description
NTemplateCheck | Checks if format of the packed NTemplate is correct.
NTemplateCheckN | Checks if format of the NTemplate is correct.
NTemplateCreateFromMemory | Unpacks a NTemplate from the specified memory buffer.
NTemplateCreateFromMemoryN | Creates NTemplate from the specified memory buffer.
NTemplateGetFacesEx | Retrieves the faces template of the NTemplate.
NTemplateGetFingersEx | Retrieves the fingers template of the NTemplate.
NTemplateGetIrisesEx | Retrieves the irises template of the NTemplate.
NTemplateGetPalmsEx | Retrieves the palms template of the NTemplate.
NTemplateGetSizeMem | Retrieves the size of the packed NTemplate.
NTemplateGetVoicesEx | Retrieves the voices template of the NTemplate.
NTemplateMerge | Merges several NTemplates from buffer array into a single NTemplate.
NTemplatePack | Packs specified templates as NTemplate into the specified memory buffer.
NTemplateSetFaces | Sets the faces template of the NTemplate to the specified value.
NTemplateSetFingers | Sets the fingers template of the NTemplate to the specified value.
NTemplateSetIrises | Sets the itises template of the NTemplate to the specified value.
NTemplateClear | Removes all templates from the NTemplate.
NTemplateSetPalms | Sets the palms template of the NTemplate to the specified value.
NTemplateSetVoices | Sets the voices template of the NTemplate to the specified value.
NTemplateCalculateSize | Calculates the size of a packed NTemplate containing fingers, palms, irises or faces templates of the specified size.
NTemplateUnpack | Unpacks packed fingers, palms, iris, face or voice template from the packed NTemplate.
NTemplateCreateEx | Creates an empty NTemplate with specified flags.
HNTemplate | Handle to NTemplate object.


NTemplateCheck Function

NTemplateCheck Function
NTemplate.h

Checks if format of the packed NTemplate is correct.

C++
NResult N_API NTemplateCheck(const void * pBuffer, NSizeType bufferSize);
Collapse Expand Parameters
Parameters | Description
const void * pBuffer | [in] Pointer to memory buffer that contains packed NTemplate.
NSizeType bufferSize | [in] Size of memory buffer that contains packed NTemplate.
Collapse Expand Returns

If the function succeeds, the return value is N_OK.

If the function fails, the return value is one of the following error codes:

Error code | Condition
N_E_ARGUMENT_NULL | buffer is NULL.
N_E_END_OF_STREAM | bufferSize is less than expected.
N_E_FORMAT | Data in memory buffer buffer points to is inconsistent with NTemplate format.
Container

File: NTemplate.h

Module: NTemplate Unit


NTemplateCheckN Function

NTemplateCheckN Function
NTemplate.h

Checks if format of the NTemplate is correct.

C++
NResult N_API NTemplateCheckN(HNBuffer hBuffer);
Collapse Expand Parameters
Parameters | Description
HNBuffer hBuffer | [in] NBuffer that contains packed NTemplate.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTemplate.h

Module: NTemplate Unit


NTemplateCreateFromMemory Function

NTemplateCreateFromMemory Function
NTemplate.h

Unpacks a NTemplate from the specified memory buffer.

C++
NResult N_API NTemplateCreateFromMemory(const void * pBuffer, NSizeType bufferSize, NUInt flags, NSizeType * pSize, HNTemplate * phTemplate);
Collapse Expand Parameters
Parameters | Description
const void * pBuffer | [in] Pointer to memory buffer that contains packed NTemplate.
NSizeType bufferSize | [in] Size of memory buffer that contains packed NTemplate.
NUInt flags | [in] Bitwise combination of zero or more flags that controls behavior of the function.
NSizeType * pSize | [out] Actual size of data read from pBuffer (bytes).
HNTemplate * phTemplate | [out] Pointer to HNTemplate that receives handle to newly created NTemplate object.
Collapse Expand Returns

If the function succeeds, the return value is N_OK.

If the function fails, the return value is one of the following error codes:

Error code | Condition
N_E_ARGUMENT_NULL | phTemplate or buffer is NULL.
N_E_END_OF_STREAM | bufferSize is less than expected.
N_E_FORMAT | Data in memory buffer buffer points to is inconsistent with NFTemplate format.
N_E_OUT_OF_MEMORY | There was not enough memory.
Collapse Expand Remarks

When created object is not necessary anymore it must be deleted using NObjectUnref function.

Container

File: NTemplate.h

Module: NTemplate Unit


NTemplateCreateFromMemoryN Function

NTemplateCreateFromMemoryN Function
NTemplate.h

Creates NTemplate from the specified memory buffer.

C++
NResult N_API NTemplateCreateFromMemoryN(HNBuffer hBuffer, NUInt flags, NSizeType * pSize, HNTemplate * phTemplate);
Collapse Expand Parameters
Parameters | Description
HNBuffer hBuffer | [in]Handle to memory buffer that contains NTemplate.
NUInt flags | [in] Bitwise combination of zero or more flags that controls behavior of the function.
NSizeType * pSize | [out] Actual size of data read from hBuffer (bytes).
HNTemplate * phTemplate | [out] Pointer to HNTemplate that receives handle to newly created NTemplate object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTemplate.h

Module: NTemplate Unit


NTemplateGetFacesEx Function

NTemplateGetFacesEx Function
NTemplate.h

Retrieves the faces template of the NTemplate.

C++
NResult N_API NTemplateGetFacesEx(HNTemplate hTemplate, HNLTemplate * phValue);
Collapse Expand Parameters
Parameters | Description
HNTemplate hTemplate | [in] Handle to the NTemplate object.
HNLTemplate * phValue | [out] Points to HNLTemplate that receives handle to NLTemplate object.
Collapse Expand Returns

If the function succeeds, the return value is N_OK.

If the function fails, the return value is one of the following error codes:

Error code | Condition
N_E_ARGUMENT_NULL | hTemplate or phValue is NULL.
Collapse Expand Remarks

If the NTemplate does not contain palms template (NLTemplate), the returned handle is NULL.

Container

File: NTemplate.h

Module: NTemplate Unit


NTemplateGetFingersEx Function

NTemplateGetFingersEx Function
NTemplate.h

Retrieves the fingers template of the NTemplate.

C++
NResult N_API NTemplateGetFingersEx(HNTemplate hTemplate, HNFTemplate * phValue);
Collapse Expand Parameters
Parameters | Description
HNTemplate hTemplate | [in] Handle to the NTemplate object.
HNFTemplate * phValue | [out] Points to HNFTemplate that receives handle to NFTemplate object.
Collapse Expand Returns

If the function succeeds, the return value is N_OK.

If the function fails, the return value is one of the following error codes:

Error code | Condition
N_E_ARGUMENT_NULL | hTemplate or phValue is NULL.
Collapse Expand Remarks

If the NTemplate does not contain fingers template (NFTemplate), the returned handle is NULL.

Container

File: NTemplate.h

Module: NTemplate Unit


NTemplateGetIrisesEx Function

NTemplateGetIrisesEx Function
NTemplate.h

Retrieves the irises template of the NTemplate.

C++
NResult N_API NTemplateGetIrisesEx(HNTemplate hTemplate, HNETemplate * phValue);
Collapse Expand Parameters
Parameters | Description
HNTemplate hTemplate | [in] Handle to the NTemplate object.
HNETemplate * phValue | [out] Points to HNETemplate that receives handle to NETemplate object.
Collapse Expand Returns

If the function succeeds, the return value is N_OK.

If the function fails, the return value is one of the following error codes:

Error code | Condition
N_E_ARGUMENT_NULL | hTemplate or phValue is NULL.
Collapse Expand Remarks

If the NTemplate does not contain irises template (NETemplate), the returned handle is NULL.

Container

File: NTemplate.h

Module: NTemplate Unit


NTemplateGetPalmsEx Function

NTemplateGetPalmsEx Function
NTemplate.h

Retrieves the palms template of the NTemplate.

C++
NResult N_API NTemplateGetPalmsEx(HNTemplate hTemplate, HNFTemplate * phValue);
Collapse Expand Parameters
Parameters | Description
HNTemplate hTemplate | [in] Handle to the NTemplate object.
HNFTemplate * phValue | [out] Points to HNFTemplate that receives handle to NFTemplate object.
Collapse Expand Returns

If the function succeeds, the return value is N_OK.

If the function fails, the return value is one of the following error codes:

Error code | Condition
N_E_ARGUMENT_NULL | hTemplate or phValue is NULL.
Collapse Expand Remarks

If the NTemplate does not contain palms template (NFTemplate), the returned handle is NULL.

Container

File: NTemplate.h

Module: NTemplate Unit


NTemplateGetSizeMem Function

NTemplateGetSizeMem Function
NTemplate.h

Retrieves the size of the packed NTemplate.

C++
NResult N_API NTemplateGetSizeMem(const void * pBuffer, NSizeType bufferSize, NSizeType * pValue);
Collapse Expand Parameters
Parameters | Description
const void * pBuffer | [in] Pointer to memory buffer that contains packed NTemplate.
NSizeType bufferSize | [in] Size of memory buffer that contains packed NTemplate.
NSizeType * pValue | [out] Pointer to NSizeType that receives size of sound template.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTemplate.h

Module: NTemplate Unit


NTemplateGetVoicesEx Function

NTemplateGetVoicesEx Function
NTemplate.h

Retrieves the voices template of the NTemplate.

C++
NResult N_API NTemplateGetVoicesEx(HNTemplate hTemplate, HNSTemplate * phValue);
Collapse Expand Parameters
Parameters | Description
HNTemplate hTemplate | [in] Handle to the NTemplate object.
HNSTemplate * phValue | [out] Points to HNSTemplate that receives handle to NSTemplate object.
Collapse Expand Returns

If the function succeeds, the return value is N_OK.

If the function fails, the return value is one of the following error codes:

Error code | Condition
N_E_ARGUMENT_NULL | hTemplate or phValue is NULL.
Collapse Expand Remarks

If the NTemplate does not contain voices template (NSTemplate), the returned handle is NULL.

Container

File: NTemplate.h

Module: NTemplate Unit


NTemplateMerge Function

NTemplateMerge Function
NTemplate.h

Merges several NTemplates from buffer array into a single NTemplate.

C++
NResult N_API NTemplateMerge(HNBuffer * arhBuffers, NInt buffersCount, NUInt flags, HNTemplate * phResult);
Collapse Expand Parameters
Parameters | Description
HNBuffer * arhBuffers | [in] Array of template buffers.
NInt buffersCount | [in] Buffers count.
NUInt flags | [in] Bitwise combination of zero or more flags that controls behavior of the function.
HNTemplate * phResult | [out] Pointer to NTemplate of merged NXTemplates.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTemplate.h

Module: NTemplate Unit


NTemplatePack Function

NTemplatePack Function
NTemplate.h

Packs specified templates as NTemplate into the specified memory buffer.

C++
NResult N_API NTemplatePack(const void * pFingersTemplate, NSizeType fingersTemplateSize, const void * pFacesTemplate, NSizeType facesTemplateSize, const void * pIrisesTemplate, NSizeType irisesTemplateSize, const void * pPalmsTemplate, NSizeType palmsTemplateSize, const void * pVoicesTemplate, NSizeType voicesTemplateSize, void * pBuffer, NSizeType bufferSize, NSizeType * pSize);
Collapse Expand Parameters
Parameters | Description
const void * pFingersTemplate | [in] Fingerprint template.
NSizeType fingersTemplateSize | [in] Fingerprints template size.
const void * pFacesTemplate | [in] Faces template.
NSizeType facesTemplateSize | [in] Faces template size.
const void * pIrisesTemplate | [in] Irises template.
NSizeType irisesTemplateSize | [in] Irises template size.
const void * pPalmsTemplate | [in] Palmprints template.
NSizeType palmsTemplateSize | [in] Palmprints template size.
const void * pVoicesTemplate | [in] Voices template.
NSizeType voicesTemplateSize | [in] Voices template size.
void * pBuffer | [out] Pointer to memory buffer to write packed NTemplate.
NSizeType bufferSize | [in] Size of memory buffer pBuffer.
NSizeType * pSize | [out] Pointer to NSizeType that receives size of pBuffer.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTemplate.h

Module: NTemplate Unit


NTemplateSetFaces Function

NTemplateSetFaces Function
NTemplate.h

Sets the faces template of the NTemplate to the specified value.

C++
NResult N_API NTemplateSetFaces(HNTemplate hTemplate, HNLTemplate hValue);
Collapse Expand Parameters
Parameters | Description
HNTemplate hTemplate | [in] Handle to the NTemplate.
HNLTemplate hValue | [in] Handle to the new NLTemplate value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTemplate.h

Module: NTemplate Unit


NTemplateSetFingers Function

NTemplateSetFingers Function
NTemplate.h

Sets the fingers template of the NTemplate to the specified value.

C++
NResult N_API NTemplateSetFingers(HNTemplate hTemplate, HNFTemplate hValue);
Collapse Expand Parameters
Parameters | Description
HNTemplate hTemplate | [in] Handle to the NTemplate.
HNFTemplate hValue | [in] Handle to the new NFTemplate value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTemplate.h

Module: NTemplate Unit


NTemplateSetIrises Function

NTemplateSetIrises Function
NTemplate.h

Sets the itises template of the NTemplate to the specified value.

C++
NResult N_API NTemplateSetIrises(HNTemplate hTemplate, HNETemplate hValue);
Collapse Expand Parameters
Parameters | Description
HNTemplate hTemplate | [in] Handle to the NTemplate.
HNETemplate hValue | [in] Handle to the new NETemplate value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTemplate.h

Module: NTemplate Unit


NTemplateClear Function

NTemplateClear Function
NTemplate.h

Removes all templates from the NTemplate.

C++
NResult N_API NTemplateClear(HNTemplate hTemplate);
Collapse Expand Parameters
Parameters | Description
HNTemplate hTemplate | [in] Handle to the NTemplate object.
Collapse Expand Returns

If the function succeeds, the return value is N_OK.

If the function fails, the return value is one of the following error codes:

Error code | Condition
N_E_ARGUMENT_NULL | hTemplate is NULL.
Container

File: NTemplate.h

Module: NTemplate Unit


NTemplateSetPalms Function

NTemplateSetPalms Function
NTemplate.h

Sets the palms template of the NTemplate to the specified value.

C++
NResult N_API NTemplateSetPalms(HNTemplate hTemplate, HNFTemplate hValue);
Collapse Expand Parameters
Parameters | Description
HNTemplate hTemplate | [in] Handle to the NTemplate.
HNFTemplate hValue | [in] Handle to the new NFTemplate value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTemplate.h

Module: NTemplate Unit


NTemplateSetVoices Function

NTemplateSetVoices Function
NTemplate.h

Sets the voices template of the NTemplate to the specified value.

C++
NResult N_API NTemplateSetVoices(HNTemplate hTemplate, HNSTemplate hValue);
Collapse Expand Parameters
Parameters | Description
HNTemplate hTemplate | [in] Handle to the NTemplate.
HNSTemplate hValue | [in] Handle to the new NSTemplate value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTemplate.h

Module: NTemplate Unit


NTemplateCalculateSize Function

NTemplateCalculateSize Function
NTemplate.h

Calculates the size of a packed NTemplate containing fingers, palms, irises or faces templates of the specified size.

C++
NResult N_API NTemplateCalculateSize(NSizeType fingersTemplateSize, NSizeType facesTemplateSize, NSizeType irisesTemplateSize, NSizeType palmsTemplateSize, NSizeType voicesTemplateSize, NSizeType * pSize);
Collapse Expand Parameters
Parameters | Description
NSizeType fingersTemplateSize | [in] The size of packed fingers template.
NSizeType facesTemplateSize | [in] The size of packed faces template.
NSizeType irisesTemplateSize | [in] The size of packed irises template.
NSizeType palmsTemplateSize | [in] The size of packed palms template.
NSizeType voicesTemplateSize | [in] The size of packed voices template.
NSizeType * pSize | [out] Pointer to NSizeType that receives calculated size of packed NTemplate.
Collapse Expand Returns

If the function succeeds, the return value is N_OK.

If the function fails, the return value is one of the following error codes:

Error code | Condition
N_E_ARGUMENT | fingersTemplateSize is not zero and is less than minimal size of packed fingers template. - or - facesTemplateSize is not zero and is less than minimal size of packed fingers template. - or - irisesTemplateSize is not zero and is less than minimal size of packed irises template. - or - palmsTemplateSize is not zero and is less than minimal size of packed palms template. - or - voicesTemplateSize is not zero and is less than minimal size of packed palms template.
N_E_ARGUMENT_NULL | pSize is NULL.
Collapse Expand Remarks

This is a low-level function and can be changed in future version of the library.

In order to calculate the size of the whole NTemplate you should know the size of each template. It can be achieved by using functions listed below:

  • For fingerprint and palmprint templates:
    • NTemplateGetFingers function is used to check if the NTemplate contains NFTemplate with fingerprint records. If the return value is not NULL the NTemplate contains NFTemplate with fingerprint records. The size of the NFTemplate can be calculated by using NFTemplateCalculateSize function.
    • NTemplateGetPalms function is used to check if the NTemplate contains NFTemplate with palmprint records. If the return value is not NULL the NTemplate contains NFTemplate with palmprint records. The size of the NFTemplate can be calculated by using NFTemplateCalculateSize function.
  • For face templates:
    • NTemplateGetFaces function is used to check if the NTemplate contains NLTemplate with face records. If the return value is not NULL the NTemplate contains NLTemplate with face records. The size of the NLTemplate can be calculated by using NLTemplateCalculateSize function.
  • For iris templates:
    • NTemplateGetIrises function is used to check if the NTemplate contains NFTemplate with fingerprint records. If the return value is not NULL the NTemplate contains NETemplate with iris records. The size of the NETemplate can be calculated by using NETemplateCalculateSize function.
  • For voice templates:
    • NTemplateGetVoices function is used to check if the NTemplate contains NSTemplate with voice records. If the return value is not NULL the NTemplate contains NSTemplate with voice records. The size of the NSTemplate can be calculated by using NSTemplateCalculateSize function.
Container

File: NTemplate.h

Module: NTemplate Unit


NTemplateUnpack Function

NTemplateUnpack Function
NTemplate.h

Unpacks packed fingers, palms, iris, face or voice template from the packed NTemplate.

C++
NResult N_API NTemplateUnpack(const void * pBuffer, NSizeType bufferSize, NVersion_ * pVersion, NUInt * pSize, NByte * pHeaderSize, const void * * ppFingersTemplate, NSizeType * pFingersTemplateSize, const void * * ppFacesTemplate, NSizeType * pFacesTemplateSize, const void * * ppIrisesTemplate, NSizeType * pIrisesTemplateSize, const void * * ppPalmsTemplate, NSizeType * pPalmsTemplateSize, const void * * ppVoicesTemplate, NSizeType * pVoicesTemplateSize);
Collapse Expand Parameters
Parameters | Description
const void * pBuffer | [in] Pointer to memory buffer that contains packed NTemplate.
NSizeType bufferSize | [in] Size of memory buffer that contains packed NTemplate.
NVersion_ * pVersion | [out] Pointer to NByte that receives version of the packed NTemplate. Can be NULL.
NUInt * pSize | [out] Pointer to NUInt that receives size of the packed NTemplate. Can be NULL.
NByte * pHeaderSize | [out] Pointer to NByte that receives header size of the packed NTemplate. Can be NULL.
const void * * ppFingersTemplate | [in] Pointer to void * that receives pointer to packed fingers template contained in the packed NTemplate. Can be NULL.
NSizeType * pFingersTemplateSize | [out] Pointer to NSizeType that receives size of packed fingers template contained in the packed NTemplate. Can be NULL.
const void * * ppFacesTemplate | [in] Pointer to void * that receives pointer to packed faces template contained in the packed NTemplate. Can be NULL.
NSizeType * pFacesTemplateSize | [out] Pointer to NSizeType that receives size of packed faces template contained in the packed NTemplate. Can be NULL.
const void * * ppIrisesTemplate | [out] Pointer to void * that receives pointer to packed irises template contained in the packed NTemplate. Can be NULL.
NSizeType * pIrisesTemplateSize | [in] Pointer to NSizeType that receives size of packed irises template contained in the packed NTemplate. Can be NULL.
const void * * ppPalmsTemplate | [in] Pointer to void * that receives pointer to packed palms template contained in the packed NTemplate. Can be NULL.
NSizeType * pPalmsTemplateSize | [out] Pointer to NSizeType that receives size of packed palms template contained in the packed NTemplate. Can be NULL.
const void * * ppVoicesTemplate | [in] Pointer to void * that receives pointer to packed voices template contained in the packed NTemplate. Can be NULL.
NSizeType * pVoicesTemplateSize | [out] Pointer to NSizeType that receives size of packed voices template contained in the packed NTemplate. Can be NULL.
pMinorVersion | [out] Pointer to NByte that receives minor version of the packed NTemplate. Can be NULL.
Collapse Expand Returns

If the function succeeds, the return value is N_OK.

If the function fails, the return value is one of the following error codes:

Error code | Condition
N_E_ARGUMENT_NULL | buffer is NULL.
N_E_END_OF_STREAM | bufferSize is less than expected.
N_E_FORMAT | Data in memory buffer buffer points to is inconsistent with NTemplate format.
Container

File: NTemplate.h

Module: NTemplate Unit


NTemplateCreateEx Function

NTemplateCreateEx Function
NTemplate.h

Creates an empty NTemplate with specified flags.

C++
NResult N_API NTemplateCreateEx(NUInt flags, HNTemplate * phTemplate);
Collapse Expand Parameters
Parameters | Description
NUInt flags | [in] Bitwise combination of zero or more flags that controls behavior of the function. This parameter is reserved, must be zero.
HNTemplate * phTemplate | [out] Pointer to HNTemplate that receives handle to created NTemplate object.
Collapse Expand Returns

If the function succeeds, the return value is N_OK.

If the function fails, the return value is one of the following error codes:

Error code | Condition
N_E_ARGUMENT_NULL | phTemplate is NULL.
N_E_OUT_OF_MEMORY | There was not enough memory.
Collapse Expand Remarks

Created object must be deleted using NObjectUnref function.

Container

File: NTemplate.h

Module: NTemplate Unit


HNTemplate

HNTemplate

Handle to NTemplate object.


NTemplate.h

NTemplate.h
Functions Legend

Header file for the NTemplate. Provides functionality for packing, unpacking and editing Neurotechnology Templates (NTemplates).

Collapse Expand Functions
Name | Description
NTemplateCalculateSize | Calculates the size of a packed NTemplate containing fingers, palms, irises or faces templates of the specified size.
NTemplateCheck | Checks if format of the packed NTemplate is correct.
NTemplateCheckN | Checks if format of the NTemplate is correct.
NTemplateClear | Removes all templates from the NTemplate.
NTemplateCreateEx | Creates an empty NTemplate with specified flags.
NTemplateCreateFromMemory | Unpacks a NTemplate from the specified memory buffer.
NTemplateCreateFromMemoryN | Creates NTemplate from the specified memory buffer.
NTemplateGetFacesEx | Retrieves the faces template of the NTemplate.
NTemplateGetFingersEx | Retrieves the fingers template of the NTemplate.
NTemplateGetIrisesEx | Retrieves the irises template of the NTemplate.
NTemplateGetPalmsEx | Retrieves the palms template of the NTemplate.
NTemplateGetSizeMem | Retrieves the size of the packed NTemplate.
NTemplateGetVoicesEx | Retrieves the voices template of the NTemplate.
NTemplateMerge | Merges several NTemplates from buffer array into a single NTemplate.
NTemplatePack | Packs specified templates as NTemplate into the specified memory buffer.
NTemplateSetFaces | Sets the faces template of the NTemplate to the specified value.
NTemplateSetFingers | Sets the fingers template of the NTemplate to the specified value.
NTemplateSetIrises | Sets the itises template of the NTemplate to the specified value.
NTemplateSetPalms | Sets the palms template of the NTemplate to the specified value.
NTemplateSetVoices | Sets the voices template of the NTemplate to the specified value.
NTemplateUnpack | Unpacks packed fingers, palms, iris, face or voice template from the packed NTemplate.


NCore Library

NCore Library
Enumerations Types

Provides infrastructure for Neurotechnology components.

Collapse Expand Remarks
Requirements (Windows)
  • Import Library: NCore.dll.lib.
  • DLL: NCore.dll.

Requirements (Linux)

  • Shared object: libNCore.so.
Collapse Expand Enumerations
Name | Description
NEncoding | Represents a character encoding.
Collapse Expand Modules
Name | Description
NArray Unit | Provides functionality for working with arrays.
NArrayCollection Unit | Provides functionality for working with collections of arrays.
NArrayCollectionInfo Unit | Provides functionality to retrieve information about array collections.
NAsyncOperation Unit | Provides functionality for working with asynchronous operations. Asynchronous operations are functions and methods which return instantly, providing an object which can be used for operation's proper completion.
NBinaryReader Unit | Provides functions to read primitive data types in specific encoding.
NBinaryWriter Unit | Provides functions to write primitive types in binary to a stream.
NBuffer Unit | ... more
NBufferedStream Unit | ... more
NCallback Unit | Provides function callback functionality.
NCollection Unit | Provides functionality for working with collections.
NCollectionInfo Unit | Provides functionality to retrieve information about collections.
NConsole Unit | Represents the standard input, output, and error streams for console applications.
NConstantInfo Unit | Provides functionality to retrieve information about constant values.
NCore Unit | Provides infrastructure/basic functionality for Neurotechnology components.
NCustomEventDescriptor Unit | Provides functionality to retrieve information about custom event descriptors.
NCustomMethodDescriptor Unit | Provides functionality to retrieve information about custom method descriptors.
NCustomParameterDescriptor Unit | Provides custom parameter descriptor management functionality.
NCustomPropertyDescriptor Unit | Provides custom property descriptor management functionality.
NCustomStream Unit | Represents a stream with custom parameters.
NDefs Unit | Enumerates Neurotechnology defines.
NDescriptor Unit | Provides descriptor management functionality.
NDictionary Unit | Provides information about tables, classes, extended data types, and other items in the Application Object Tree.
NDictionaryInfo Unit | Provides functionality to retrieve information about dictionaries.
NDirectory Unit | Provides NDirectory object functionality.
NEnum Unit | Provides base functionality for enumerations.
NEnumConstantInfo Unit | Provides functionality to retrieve information about enumeration constants.
NEnvironment Unit | Provides information about the current environment and platform. This class cannot be inherited.
NError Unit | Defines error codes used in Neurotechnology components.
NEvent Unit | Provides NEvent object functionality.
NEventDescriptor Unit | Provides information about an event.
NEventInfo Unit | Provides functionality to retrieve information about events.
NExpandableObject Unit | Provides functionality for retrieving information about specified object.
NFile Unit | Provides static methods for the creation, copying, deletion, moving, and opening of files, and aids in the creation of FileStream objects.
NFileStream Unit | ... more
NInterlocked Unit | Provides atomic operations for variables that are shared by multiple threads.
NIOTypes Unit | Defines input/output types used in Neurotechnology components.
NList Unit | Provides functionality for working with lists.
NListList Unit | Provides functionality for working with two-dimension lists.
NMemberDescriptor Unit | Provides member descriptor management functionality.
NMemberInfo Unit | Provides functionality to retrieve information about class members.
NMemory Unit | Provides memory management for Neurotechnology components.
NMemoryStream Unit | Provides functions for working with memory streams.
NMethodDescriptor Unit | Represents the information about a method.
NMethodInfo Unit | Provides functionality to retrieve information about methods.
NModule Unit | Each separate piece of code/functionality is a module. The functions in this unit allow to get the information about the module it's name, version, etc..
NModuleInternal Unit | Each separate piece of code/functionality is a module. The functions in this unit allow to set the information about the module it's name, version, etc..
NMonitor Unit | Lightweight, cross platform primitives for critical section.
NMutex Unit | Cross platform implementation of critical sections.
NNoDeprecate Unit |
NObject Unit | Provides functionality for retrieving information about specified object.
NObjectPartInfo Unit | Provides functionality to retrieve information about object parts.
NParameterBag Unit | A helper class that aids in implementation of PropertyBag for ParameterDescriptor class.
NParameterDescriptor Unit | Provides functions for getting information about parameter.
NParameterInfo Unit | Provides functionality to retrieve information about parameters.
NPath Unit | Performs operations on String instances that contain file or directory path information. These operations are performed in a cross-platform manner.
NPlugin Unit | Plug-in management framework for use in other Neurotechnology components.
NPluginEventDescriptor Unit | Provides functionality for creating plugin event descriptors.
NPluginInternal Unit |
NPluginManager Unit | Provides functions for managing plugins.
NPluginMethodDescriptor Unit | Provides functionality for creating plugin method descriptors.
NPluginModule Unit | Provides functions to retrieve information about plugins.
NPluginModuleInternal Unit | Provides functions to modify information about plugins.
NPluginPropertyDescriptor Unit | Provides functionality for creating plugin property descriptors.
NProcess Unit | Provides functions to retrieve information about processes and create new processes.
NProcessorInfo Unit | Provides functionality for getting processor information.
NPropertyInfo Unit | Provides functionality to retrieve and change information about properties.
NQueue Unit | Provides functionality for working with queues.
NReDeprecate Unit |
NRWLock Unit | Provides reader/writer functionality.
NSemaphore Unit | Cross platform semaphore (synchronization primitive) implementation.
NStack Unit | Provides functionality for working with stacks.
NStopwatch Unit | Provides a set of methods and properties that you can use to accurately measure elapsed time.
NStream Unit | Supports internal Neurotechnology libraries infrastructure and should not be used directly in your code.
NStreamReader Unit | Implements a TextReader that reads characters from a byte stream in a particular encoding.
NStreamWriter Unit | Implements a TextWriter for writing characters to a stream in a particular encoding.
NString Unit | Provides functionality for working with strings.
NStringBuilder Unit | Represents a mutable string of characters.
NStringReader Unit | Implements a TextReader that reads from a string.
NStringWriter Unit | Implements a TextWriter for writing information to a string. The information is stored in an underlying StringBuilder.
NSyncEvent Unit | Cross platform synchronization primitive. It allows for threads to wait for event without consuming CPU. The other thread(s) would notify waiting thread(s) of the event by setting it to signalled state. See the NSyncEventCreate function for more details.
NTextReader Unit | Represents a reader that can read a sequential series of characters.
NTextWriter Unit | Represents a writer that can write a sequential series of characters.
NThread Unit | Cross platform threading.
NTls Unit | Represents Thread Local Storage.
NType Unit | Manages object types.
NTypeDescriptor Unit | Provides information about the characteristics for a component, such as its attributes, properties, and events.
NTypes Unit | Defines types and macros used in Neurotechnology components.
NValue Unit | Provides functionality for management and conversion of values of different types.
NWaitObject Unit | Base unit for common functionality of some cross platform synchronization primitives (supporting timed wait). See derived units for complete description:... more
NWindows Unit |
Collapse Expand Types
Name | Description
NDateTime | Represents an instant in time, typically expressed as a date and time of day.
NTimeSpan | Represents a time interval.


NArray Unit

NArray Unit
Files Functions Legend Macros

Provides functionality for working with arrays.

Collapse Expand Files
Name | Description
NArray.h | Header file for the NArray unit.
Collapse Expand Functions
Name | Description
NArrayCopyTo | Copies the specified array into another array.
NArrayCopyToBooleanArray | Copies the specified Boolean array into another array.
NArrayCopyToByteArray | Copies the specified byte array into another array.
NArrayCopyToCharArray | Copies the specified char array into another array.
NArrayCopyToDoubleArray | Copies the specified double value array into another array.
NArrayCopyToInt16Array | Copies the specified short integer array into another array.
NArrayCopyToInt32Array | Copies the specified integer array into another array.
NArrayCopyToInt64Array | Copies the specified long integer array into another array.
NArrayCopyToObjectArray | Copies the specified object array into another array.
NArrayCopyToObjectArrayP | Copies the specified object array into another array.
NArrayCopyToP | Copies the specified array into another array.
NArrayCopyToPointerArray | Copies the specified pointer array into another array.
NArrayCopyToResultArray | Copies the specified NResult value array into another array.
NArrayCopyToSByteArray | Copies the specified signed byte array into another array.
NArrayCopyToSSizeTypeArray | Copies the specified NSSizeType value array into another array.
NArrayCopyToSingleArray | Copies the specified floating point value array into another array.
NArrayCopyToSizeTypeArray | Copies the specified NSizeType value array into another array.
NArrayCopyToStringArray | Copies the specified string array into another array.
NArrayCopyToUInt16Array | Copies the specified unsigned short integer array into another array.
NArrayCopyToUInt32Array | Copies the specified unsigned integer array into another array.
NArrayCopyToUInt64Array | Copies the specified unsigned long integer array into another array.
NArrayCreate | Creates an array of specified type populated by specified values.
NArrayCreateCustom | Creates an array of specified type with additional options populated by specified values.
NArrayCreateFromBooleanArray | Creates an array from an array of Boolean values.
NArrayCreateFromByteArray | Creates an array from an array of bytes.
NArrayCreateFromCharArray | Creates an array from an array of chars.
NArrayCreateFromDoubleArray | Creates an array from an array of double values.
NArrayCreateFromInt16Array | Creates an array from an array of short integer values.
NArrayCreateFromInt32Array | Creates an array from an array of integer values.
NArrayCreateFromInt64Array | Creates an array from an array of long integer values.
NArrayCreateFromObjectArray | Creates an array from an array of object values.
NArrayCreateFromObjectArrayP | Creates an array from an array of object values.
NArrayCreateFromPointerArray | Creates an array from an array of pointer values.
NArrayCreateFromResultArray | Creates an array from an array of NResult values.
NArrayCreateFromSByteArray | Creates an array from an array of signed byte values.
NArrayCreateFromSSizeTypeArray | Creates an array from an array of NSSizeType values.
NArrayCreateFromSingleArray | Creates an array from an array of floating point values.
NArrayCreateFromSizeTypeArray | Creates an array from an array of NSizeType values.
NArrayCreateFromStringArray | Creates an array from an array of string values.
NArrayCreateFromUInt16Array | Creates an array from an array of unsinged short integer values.
NArrayCreateFromUInt32Array | Creates an array from an array of unsinged integer values.
NArrayCreateFromUInt64Array | Creates an array from an array of unsinged long integer values.
NArrayCreateP | Creates an array of specified type populated by specified values.
NArrayGetLength | Retrieves the length of the array.
NArrayGetValue | Retrieves the specified value in the array.
NArrayGetValueAs | Retrieves the of the specified value of the specified type in the array.
NArrayGetValueAsBoolean | Retrieves the of the specified Boolean value in the array.
NArrayGetValueAsByte | Retrieves the of the specified byte value in the array.
NArrayGetValueAsChar | Retrieves the of the specified char value in the array.
NArrayGetValueAsDouble | Retrieves the of the specified double value in the array.
NArrayGetValueAsInt16 | Retrieves the of the specified short integer value in the array.
NArrayGetValueAsInt32 | Retrieves the of the specified integer value in the array.
NArrayGetValueAsInt64 | Retrieves the of the specified long integer value in the array.
NArrayGetValueAsObject | Retrieves the of the specified object value in the array.
NArrayGetValueAsObjectP | Retrieves the of the specified object value in the array.
NArrayGetValueAsP | Retrieves the of the specified value of the specified type in the array.
NArrayGetValueAsPointer | Retrieves the of the specified pointer value in the array.
NArrayGetValueAsResult | Retrieves the of the specified NResult value in the array.
NArrayGetValueAsSByte | Retrieves the of the specified signed byte value in the array.
NArrayGetValueAsSSizeType | Retrieves the of the specified NSSizeType value in the array.
NArrayGetValueAsSingle | Retrieves the of the specified floating point integer value in the array.
NArrayGetValueAsSizeType | Retrieves the of the specified NSizeType value in the array.
NArrayGetValueAsString | Retrieves the of the specified string value in the array.
NArrayGetValueAsUInt16 | Retrieves the of the specified unsigned short integer value in the array.
NArrayGetValueAsUInt32 | Retrieves the of the specified unsigned integer value in the array.
NArrayGetValueAsUInt64 | Retrieves the of the specified unsigned long integer value in the array.
Collapse Expand Macros
Name | Description
NArrayCopyToCharArray | Picks a Unicode (W) or ANSCII (A) version of the NArrayCopyToCharArray function.
NArrayCreateFromCharArray | Picks a Unicode (W) or ANSCII (A) version of the NArrayCreateFromCharArray function.
NArrayCreateFromStringArray | Picks a Unicode (W) or ANSCII (A) version of the NArrayCreateFromStringArray function.
NArrayGetValueAsChar | Picks a Unicode (W) or ANSCII (A) version of the NArrayGetValueAsChar function.


NArrayCopyTo Function

NArrayCopyTo Function
NArray.h

Copies the specified array into another array.

C++
NResult N_API NArrayCopyTo(HNArray hArray, HNType hType, NAttributes attributes, HNString hFormat, void * arValues, NSizeType valuesSize, NInt valuesLength);
Collapse Expand Parameters
Parameters | Description
HNArray hArray | [in] Handle to the source array.
HNType hType | [in] Handle to the type of values in the array.
NAttributes attributes | [in] Array attributes.
HNString hFormat | [in] Handle to the value format.
void * arValues | [out] Pointer to a the destination array.
NSizeType valuesSize | [in] Size of the values in the array.
NInt valuesLength | [in] Length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayCopyToBooleanArray Function

NArrayCopyToBooleanArray Function
NArray.h

Copies the specified Boolean array into another array.

C++
NResult N_API NArrayCopyToBooleanArray(HNArray hArray, NAttributes attributes, HNString hFormat, NBool * arValues, NInt valuesLength);
Collapse Expand Parameters
Parameters | Description
HNArray hArray | [in] Handle to the source array.
NAttributes attributes | [in] Array attributes.
HNString hFormat | [in] Handle to the value format.
NBool * arValues | [out] Pointer to the destination array.
NInt valuesLength | [in] Length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayCopyToByteArray Function

NArrayCopyToByteArray Function
NArray.h

Copies the specified byte array into another array.

C++
NResult N_API NArrayCopyToByteArray(HNArray hArray, NAttributes attributes, HNString hFormat, NByte * arValues, NInt valuesLength);
Collapse Expand Parameters
Parameters | Description
HNArray hArray | [in] Handle to the source array.
NAttributes attributes | [in] Array attributes.
HNString hFormat | [in] Handle to the value format.
NByte * arValues | [out] Pointer to the destination array.
NInt valuesLength | [in] Length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayCopyToCharArray Function

NArrayCopyToCharArray Function
NArray.h

Copies the specified char array into another array.

C++
NResult N_API NArrayCopyToCharArray(HNArray hArray, NAttributes attributes, HNString hFormat, NChar * arValues, NInt valuesLength);
Collapse Expand Parameters
Parameters | Description
HNArray hArray | [in] Handle to the source array.
NAttributes attributes | [in] Array attributes.
HNString hFormat | [in] Handle to the value format.
NChar * arValues | [out] Pointer to the destination array.
NInt valuesLength | [in] Length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayCopyToDoubleArray Function

NArrayCopyToDoubleArray Function
NArray.h

Copies the specified double value array into another array.

C++
NResult N_API NArrayCopyToDoubleArray(HNArray hArray, NAttributes attributes, HNString hFormat, NDouble * arValues, NInt valuesLength);
Collapse Expand Parameters
Parameters | Description
HNArray hArray | [in] Handle to the source array.
NAttributes attributes | [in] Array attributes.
HNString hFormat | [in] Handle to the value format.
NDouble * arValues | [out] Pointer to the destination array.
NInt valuesLength | [in] Length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayCopyToInt16Array Function

NArrayCopyToInt16Array Function
NArray.h

Copies the specified short integer array into another array.

C++
NResult N_API NArrayCopyToInt16Array(HNArray hArray, NAttributes attributes, HNString hFormat, NShort * arValues, NInt valuesLength);
Collapse Expand Parameters
Parameters | Description
HNArray hArray | [in] Handle to the source array.
NAttributes attributes | [in] Array attributes.
HNString hFormat | [in] Handle to the value format.
NShort * arValues | [out] Pointer to the destination array.
NInt valuesLength | [in] Length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayCopyToInt32Array Function

NArrayCopyToInt32Array Function
NArray.h

Copies the specified integer array into another array.

C++
NResult N_API NArrayCopyToInt32Array(HNArray hArray, NAttributes attributes, HNString hFormat, NInt * arValues, NInt valuesLength);
Collapse Expand Parameters
Parameters | Description
HNArray hArray | [in] Handle to the source array.
NAttributes attributes | [in] Array attributes.
HNString hFormat | [in] Handle to the value format.
NInt * arValues | [out] Pointer to the destination array.
NInt valuesLength | [in] Length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayCopyToInt64Array Function

NArrayCopyToInt64Array Function
NArray.h

Copies the specified long integer array into another array.

C++
NResult N_API NArrayCopyToInt64Array(HNArray hArray, NAttributes attributes, HNString hFormat, NLong * arValues, NInt valuesLength);
Collapse Expand Parameters
Parameters | Description
HNArray hArray | [in] Handle to the source array.
NAttributes attributes | [in] Array attributes.
HNString hFormat | [in] Handle to the value format.
NLong * arValues | [out] Pointer to the destination array.
NInt valuesLength | [in] Length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayCopyToObjectArray Function

NArrayCopyToObjectArray Function
NArray.h

Copies the specified object array into another array.

C++
NResult N_API NArrayCopyToObjectArray(HNArray hArray, HNType hType, NAttributes attributes, HNString hFormat, HNObject * arhValues, NInt valuesLength);
Collapse Expand Parameters
Parameters | Description
HNArray hArray | [in] Handle to the source array.
HNType hType | [in] Handle to the type of objects in the array.
NAttributes attributes | [in] Array attributes.
HNString hFormat | [in] Handle to the value format.
HNObject * arhValues | [out] Pointer to the destination array.
NInt valuesLength | [in] Length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayCopyToObjectArrayP Function

NArrayCopyToObjectArrayP Function
NArray.h

Copies the specified object array into another array.

C++
NResult N_API NArrayCopyToObjectArrayP(HNArray hArray, NTypeOfProc pTypeOf, NAttributes attributes, HNString hFormat, HNObject * arhValues, NInt valuesLength);
Collapse Expand Parameters
Parameters | Description
HNArray hArray | [in] Handle to the source array.
NTypeOfProc pTypeOf | [in] Pointer to the function that retrieves the type of the objects in the array.
NAttributes attributes | [in] Array attributes.
HNString hFormat | [in] Handle to the value format.
HNObject * arhValues | [out] Pointer to the destination array.
NInt valuesLength | [in] Length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayCopyToP Function

NArrayCopyToP Function
NArray.h

Copies the specified array into another array.

C++
NResult N_API NArrayCopyToP(HNArray hArray, NTypeOfProc pTypeOf, NAttributes attributes, HNString hFormat, void * arValues, NSizeType valuesSize, NInt valuesLength);
Collapse Expand Parameters
Parameters | Description
HNArray hArray | [in] Handle to the source array.
NTypeOfProc pTypeOf | [in] Pointer to the function that retrieves the type of the values in the array.
NAttributes attributes | [in] Array attributes.
HNString hFormat | [in] Handle to the value format.
void * arValues | [out] Pointer to the destination array.
NSizeType valuesSize | [in] Size of the values in the array.
NInt valuesLength | [in] Length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayCopyToPointerArray Function

NArrayCopyToPointerArray Function
NArray.h

Copies the specified pointer array into another array.

C++
NResult N_API NArrayCopyToPointerArray(HNArray hArray, NAttributes attributes, HNString hFormat, void * * arValues, NInt valuesLength);
Collapse Expand Parameters
Parameters | Description
HNArray hArray | [in] Handle to the source array.
NAttributes attributes | [in] Array attributes.
HNString hFormat | [in] Handle to the value format.
void * * arValues | [out] Pointer to the destination array.
NInt valuesLength | [in] Length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayCopyToResultArray Function

NArrayCopyToResultArray Function
NArray.h

Copies the specified NResult value array into another array.

C++
NResult N_API NArrayCopyToResultArray(HNArray hArray, NAttributes attributes, HNString hFormat, NResult * arValues, NInt valuesLength);
Collapse Expand Parameters
Parameters | Description
HNArray hArray | [in] Handle to the source array.
NAttributes attributes | [in] Array attributes.
HNString hFormat | [in] Handle to the value format.
NResult * arValues | [out] Pointer to the destination array.
NInt valuesLength | [in] Length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayCopyToSByteArray Function

NArrayCopyToSByteArray Function
NArray.h

Copies the specified signed byte array into another array.

C++
NResult N_API NArrayCopyToSByteArray(HNArray hArray, NAttributes attributes, HNString hFormat, NSByte * arValues, NInt valuesLength);
Collapse Expand Parameters
Parameters | Description
HNArray hArray | [in] Handle to the source array.
NAttributes attributes | [in] Array attributes.
HNString hFormat | [in] Handle to the value format.
NSByte * arValues | [out] Pointer to the destination array.
NInt valuesLength | [in] Length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayCopyToSSizeTypeArray Function

NArrayCopyToSSizeTypeArray Function
NArray.h

Copies the specified NSSizeType value array into another array.

C++
NResult N_API NArrayCopyToSSizeTypeArray(HNArray hArray, NAttributes attributes, HNString hFormat, NSSizeType * arValues, NInt valuesLength);
Collapse Expand Parameters
Parameters | Description
HNArray hArray | [in] Handle to the source array.
NAttributes attributes | [in] Array attributes.
HNString hFormat | [in] Handle to the value format.
NSSizeType * arValues | [out] Pointer to the destination array.
NInt valuesLength | [in] Length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayCopyToSingleArray Function

NArrayCopyToSingleArray Function
NArray.h

Copies the specified floating point value array into another array.

C++
NResult N_API NArrayCopyToSingleArray(HNArray hArray, NAttributes attributes, HNString hFormat, NFloat * arValues, NInt valuesLength);
Collapse Expand Parameters
Parameters | Description
HNArray hArray | [in] Handle to the source array.
NAttributes attributes | [in] Array attributes.
HNString hFormat | [in] Handle to the value format.
NFloat * arValues | [out] Pointer to the destination array.
NInt valuesLength | [in] Length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayCopyToSizeTypeArray Function

NArrayCopyToSizeTypeArray Function
NArray.h

Copies the specified NSizeType value array into another array.

C++
NResult N_API NArrayCopyToSizeTypeArray(HNArray hArray, NAttributes attributes, HNString hFormat, NSizeType * arValues, NInt valuesLength);
Collapse Expand Parameters
Parameters | Description
HNArray hArray | [in] Handle to the source array.
NAttributes attributes | [in] Array attributes.
HNString hFormat | [in] Handle to the value format.
NSizeType * arValues | [out] Pointer to the destination array.
NInt valuesLength | [in] Length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayCopyToStringArray Function

NArrayCopyToStringArray Function
NArray.h

Copies the specified string array into another array.

C++
NResult N_API NArrayCopyToStringArray(HNArray hArray, NAttributes attributes, HNString hFormat, HNString * arhValues, NInt valuesLength);
Collapse Expand Parameters
Parameters | Description
HNArray hArray | [in] Handle to the source array.
NAttributes attributes | [in] Array attributes.
HNString hFormat | [in] Handle to the value format.
HNString * arhValues | [out] Pointer to the destination array.
NInt valuesLength | [in] Length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayCopyToUInt16Array Function

NArrayCopyToUInt16Array Function
NArray.h

Copies the specified unsigned short integer array into another array.

C++
NResult N_API NArrayCopyToUInt16Array(HNArray hArray, NAttributes attributes, HNString hFormat, NUShort * arValues, NInt valuesLength);
Collapse Expand Parameters
Parameters | Description
HNArray hArray | [in] Handle to the source array.
NAttributes attributes | [in] Array attributes.
HNString hFormat | [in] Handle to the value format.
NUShort * arValues | [out] Pointer to the destination array.
NInt valuesLength | [in] Length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayCopyToUInt32Array Function

NArrayCopyToUInt32Array Function
NArray.h

Copies the specified unsigned integer array into another array.

C++
NResult N_API NArrayCopyToUInt32Array(HNArray hArray, NAttributes attributes, HNString hFormat, NUInt * arValues, NInt valuesLength);
Collapse Expand Parameters
Parameters | Description
HNArray hArray | [in] Handle to the source array.
NAttributes attributes | [in] Array attributes.
HNString hFormat | [in] Handle to the value format.
NUInt * arValues | [out] Pointer to the destination array.
NInt valuesLength | [in] Length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayCopyToUInt64Array Function

NArrayCopyToUInt64Array Function
NArray.h

Copies the specified unsigned long integer array into another array.

C++
NResult N_API NArrayCopyToUInt64Array(HNArray hArray, NAttributes attributes, HNString hFormat, NULong * arValues, NInt valuesLength);
Collapse Expand Parameters
Parameters | Description
HNArray hArray | [in] Handle to the source array.
NAttributes attributes | [in] Array attributes.
HNString hFormat | [in] Handle to the value format.
NULong * arValues | [out] Pointer to the destination array.
NInt valuesLength | [in] Length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayCreate Function

NArrayCreate Function
NArray.h

Creates an array of specified type populated by specified values.

C++
NResult N_API NArrayCreate(HNType hType, const void * arValues, NSizeType valuesSize, NInt valuesLength, NAttributes attributes, HNArray * phArray);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the type of values that the array will hold.
const void * arValues | [in] An array of pointers to the values that the new array will hold.
NSizeType valuesSize | [in] Size of the values that the array will hold.
NInt valuesLength | [in] Length of the array.
NAttributes attributes | [in] Array attributes.
HNArray * phArray | [out] Pointer to a handle to the new array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayCreateCustom Function

NArrayCreateCustom Function
NArray.h

Creates an array of specified type with additional options populated by specified values.

C++
NResult N_API NArrayCreateCustom(const void * const * arValues, NInt valuesLength, NPointerFreeProc pFree, void * pFreeParam, NPointerGetHashCodeProc pGetHashCode, void * pGetHashCodeParam, NPointerEqualsProc pEquals, void * pEqualsParam, NAttributes attributes, HNArray * phArray);
Collapse Expand Parameters
Parameters | Description
const void * const * arValues | [in] An array of pointers to the values that the new array will hold.
NInt valuesLength | [in] Length of the array.
NPointerFreeProc pFree | [in] Pointer to a function that frees an array element.
void * pFreeParam | [out] Parameters of a function that frees an array element.
NPointerGetHashCodeProc pGetHashCode | [in] Pointer to a function that retrieves the hash code of an array element
void * pGetHashCodeParam | [out] Parameters of a function that retrieves the hash code of an array element.
NPointerEqualsProc pEquals | [in] Pointer to a function that compares two array elements.
void * pEqualsParam | [out] Parameters of a function that compares two array elements.
NAttributes attributes | [in] Array attributes.
HNArray * phArray | [out] Pointer to a handle to the new array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayCreateFromBooleanArray Function

NArrayCreateFromBooleanArray Function
NArray.h

Creates an array from an array of Boolean values.

C++
NResult N_API NArrayCreateFromBooleanArray(const NBool * arValues, NInt valuesLength, NAttributes attributes, HNArray * phArray);
Collapse Expand Parameters
Parameters | Description
const NBool * arValues | [in] Pointer to the Boolean values that the new array will hold.
NInt valuesLength | [in] Length of the array.
NAttributes attributes | [in] Array attributes.
HNArray * phArray | [out] Pointer to a handle to the new array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayCreateFromByteArray Function

NArrayCreateFromByteArray Function
NArray.h

Creates an array from an array of bytes.

C++
NResult N_API NArrayCreateFromByteArray(const NByte * arValues, NInt valuesLength, NAttributes attributes, HNArray * phArray);
Collapse Expand Parameters
Parameters | Description
const NByte * arValues | [in] Pointer to the byte values that the new array will hold.
NInt valuesLength | [in] Length of the array.
NAttributes attributes | [in] Array attributes.
HNArray * phArray | [out] Pointer to a handle to the new array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayCreateFromCharArray Function

NArrayCreateFromCharArray Function
NArray.h

Creates an array from an array of chars.

C++
NResult N_API NArrayCreateFromCharArray(const NChar * arValues, NInt valuesLength, NAttributes attributes, HNArray * phArray);
Collapse Expand Parameters
Parameters | Description
const NChar * arValues | [in] Pointer to the char values that the new array will hold.
NInt valuesLength | [in] Length of the array.
NAttributes attributes | [in] Array attributes.
HNArray * phArray | [out] Pointer to a handle to the new array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayCreateFromDoubleArray Function

NArrayCreateFromDoubleArray Function
NArray.h

Creates an array from an array of double values.

C++
NResult N_API NArrayCreateFromDoubleArray(const NDouble * arValues, NInt valuesLength, NAttributes attributes, HNArray * phArray);
Collapse Expand Parameters
Parameters | Description
const NDouble * arValues | [in] Pointer to the double values that the new array will hold.
NInt valuesLength | [in] Length of the array.
NAttributes attributes | [in] Array attributes.
HNArray * phArray | [out] Pointer to a handle to the new array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayCreateFromInt16Array Function

NArrayCreateFromInt16Array Function
NArray.h

Creates an array from an array of short integer values.

C++
NResult N_API NArrayCreateFromInt16Array(const NShort * arValues, NInt valuesLength, NAttributes attributes, HNArray * phArray);
Collapse Expand Parameters
Parameters | Description
const NShort * arValues | [in] Pointer to the short integer values that the new array will hold.
NInt valuesLength | [in] Length of the array.
NAttributes attributes | [in] Array attributes.
HNArray * phArray | [out] Pointer to a handle to the new array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayCreateFromInt32Array Function

NArrayCreateFromInt32Array Function
NArray.h

Creates an array from an array of integer values.

C++
NResult N_API NArrayCreateFromInt32Array(const NInt * arValues, NInt valuesLength, NAttributes attributes, HNArray * phArray);
Collapse Expand Parameters
Parameters | Description
const NInt * arValues | [in] Pointer to the integer values that the new array will hold.
NInt valuesLength | [in] Length of the array.
NAttributes attributes | [in] Array attributes.
HNArray * phArray | [out] Pointer to a handle to the new array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayCreateFromInt64Array Function

NArrayCreateFromInt64Array Function
NArray.h

Creates an array from an array of long integer values.

C++
NResult N_API NArrayCreateFromInt64Array(const NLong * arValues, NInt valuesLength, NAttributes attributes, HNArray * phArray);
Collapse Expand Parameters
Parameters | Description
const NLong * arValues | [in] Pointer to the long integer values that the new array will hold.
NInt valuesLength | [in] Length of the array.
NAttributes attributes | [in] Array attributes.
HNArray * phArray | [out] Pointer to a handle to the new array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayCreateFromObjectArray Function

NArrayCreateFromObjectArray Function
NArray.h

Creates an array from an array of object values.

C++
NResult N_API NArrayCreateFromObjectArray(HNType hType, const HNObject * arhValues, NInt valuesLength, NAttributes attributes, HNArray * phArray);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the type of objects that the array will hold.
const HNObject * arhValues | [in] Pointer to the objects that the new array will hold.
NInt valuesLength | [in] Length of the array.
NAttributes attributes | [in] Array attributes.
HNArray * phArray | [out] Pointer to a handle to the new array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayCreateFromObjectArrayP Function

NArrayCreateFromObjectArrayP Function
NArray.h

Creates an array from an array of object values.

C++
NResult N_API NArrayCreateFromObjectArrayP(NTypeOfProc pTypeOf, const HNObject * arhValues, NInt valuesLength, NAttributes attributes, HNArray * phArray);
Collapse Expand Parameters
Parameters | Description
NTypeOfProc pTypeOf | [in] Pointer to the function that retrieves the type of the objects that the array will hold.
const HNObject * arhValues | [in] Pointer to the objects that the new array will hold.
NInt valuesLength | [in] Length of the array.
NAttributes attributes | [in] Array attributes.
HNArray * phArray | [out] Pointer to a handle to the new array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayCreateFromPointerArray Function

NArrayCreateFromPointerArray Function
NArray.h

Creates an array from an array of pointer values.

C++
NResult N_API NArrayCreateFromPointerArray(const void * const * arValues, NInt valuesLength, NAttributes attributes, HNArray * phArray);
Collapse Expand Parameters
Parameters | Description
const void * const * arValues | [in] Pointer to the an array of pointers that the new array will hold.
NInt valuesLength | [in] Length of the array.
NAttributes attributes | [in] Array attributes.
HNArray * phArray | [out] Pointer to a handle to the new array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayCreateFromResultArray Function

NArrayCreateFromResultArray Function
NArray.h

Creates an array from an array of NResult values.

C++
NResult N_API NArrayCreateFromResultArray(const NResult * arValues, NInt valuesLength, NAttributes attributes, HNArray * phArray);
Collapse Expand Parameters
Parameters | Description
const NResult * arValues | [in] Pointer to the NResult values that the new array will hold.
NInt valuesLength | [in] Length of the array.
NAttributes attributes | [in] Array attributes.
HNArray * phArray | [out] Pointer to a handle to the new array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayCreateFromSByteArray Function

NArrayCreateFromSByteArray Function
NArray.h

Creates an array from an array of signed byte values.

C++
NResult N_API NArrayCreateFromSByteArray(const NSByte * arValues, NInt valuesLength, NAttributes attributes, HNArray * phArray);
Collapse Expand Parameters
Parameters | Description
const NSByte * arValues | [in] Pointer to the signed byte values that the new array will hold.
NInt valuesLength | [in] Length of the array.
NAttributes attributes | [in] Array attributes.
HNArray * phArray | [out] Pointer to a handle to the new array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayCreateFromSSizeTypeArray Function

NArrayCreateFromSSizeTypeArray Function
NArray.h

Creates an array from an array of NSSizeType values.

C++
NResult N_API NArrayCreateFromSSizeTypeArray(const NSSizeType * arValues, NInt valuesLength, NAttributes attributes, HNArray * phArray);
Collapse Expand Parameters
Parameters | Description
const NSSizeType * arValues | [in] Pointer to the NSSizeType values that the new array will hold.
NInt valuesLength | [in] Length of the array.
NAttributes attributes | [in] Array attributes.
HNArray * phArray | [out] Pointer to a handle to the new array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayCreateFromSingleArray Function

NArrayCreateFromSingleArray Function
NArray.h

Creates an array from an array of floating point values.

C++
NResult N_API NArrayCreateFromSingleArray(const NFloat * arValues, NInt valuesLength, NAttributes attributes, HNArray * phArray);
Collapse Expand Parameters
Parameters | Description
const NFloat * arValues | [in] Pointer to the floating point values that the new array will hold.
NInt valuesLength | [in] Length of the array.
NAttributes attributes | [in] Array attributes.
HNArray * phArray | [out] Pointer to a handle to the new array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayCreateFromSizeTypeArray Function

NArrayCreateFromSizeTypeArray Function
NArray.h

Creates an array from an array of NSizeType values.

C++
NResult N_API NArrayCreateFromSizeTypeArray(const NSizeType * arValues, NInt valuesLength, NAttributes attributes, HNArray * phArray);
Collapse Expand Parameters
Parameters | Description
const NSizeType * arValues | [in] Pointer to the NSizeType values that the new array will hold.
NInt valuesLength | [in] Length of the array.
NAttributes attributes | [in] Array attributes.
HNArray * phArray | [out] Pointer to a handle to the new array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayCreateFromStringArray Function

NArrayCreateFromStringArray Function
NArray.h

Creates an array from an array of string values.

C++
NResult N_API NArrayCreateFromStringArray(const NChar * const * arszValues, NInt valuesLength, NAttributes attributes, HNArray * phArray);
Collapse Expand Parameters
Parameters | Description
const NChar * const * arszValues | [in] Pointer to the string values that the new array will hold.
NInt valuesLength | [in] Length of the array.
NAttributes attributes | [in] Array attributes.
HNArray * phArray | [out] Pointer to a handle to the new array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayCreateFromUInt16Array Function

NArrayCreateFromUInt16Array Function
NArray.h

Creates an array from an array of unsinged short integer values.

C++
NResult N_API NArrayCreateFromUInt16Array(const NUShort * arValues, NInt valuesLength, NAttributes attributes, HNArray * phArray);
Collapse Expand Parameters
Parameters | Description
const NUShort * arValues | [in] Pointer to the unsinged short integer values that the new array will hold.
NInt valuesLength | [in] Length of the array.
NAttributes attributes | [in] Array attributes.
HNArray * phArray | [out] Pointer to a handle to the new array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayCreateFromUInt32Array Function

NArrayCreateFromUInt32Array Function
NArray.h

Creates an array from an array of unsinged integer values.

C++
NResult N_API NArrayCreateFromUInt32Array(const NUInt * arValues, NInt valuesLength, NAttributes attributes, HNArray * phArray);
Collapse Expand Parameters
Parameters | Description
const NUInt * arValues | [in] Pointer to the unsinged integer values that the new array will hold.
NInt valuesLength | [in] Length of the array.
NAttributes attributes | [in] Array attributes.
HNArray * phArray | [out] Pointer to a handle to the new array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayCreateFromUInt64Array Function

NArrayCreateFromUInt64Array Function
NArray.h

Creates an array from an array of unsinged long integer values.

C++
NResult N_API NArrayCreateFromUInt64Array(const NULong * arValues, NInt valuesLength, NAttributes attributes, HNArray * phArray);
Collapse Expand Parameters
Parameters | Description
const NULong * arValues | [in] Pointer to the unsinged long integer values that the new array will hold.
NInt valuesLength | [in] Length of the array.
NAttributes attributes | [in] Array attributes.
HNArray * phArray | [out] Pointer to a handle to the new array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayCreateP Function

NArrayCreateP Function
NArray.h

Creates an array of specified type populated by specified values.

C++
NResult N_API NArrayCreateP(NTypeOfProc pTypeOf, const void * arValues, NSizeType valuesSize, NInt valuesLength, NAttributes attributes, HNArray * phArray);
Collapse Expand Parameters
Parameters | Description
NTypeOfProc pTypeOf | [in] Pointer to the function that retrieves the type of the values that the array will hold.
const void * arValues | [in] An array of pointers to the values that the new array will hold.
NSizeType valuesSize | [in] Size of the values that the array will hold.
NInt valuesLength | [in] Length of the array.
NAttributes attributes | [in] Array attributes.
HNArray * phArray | [out] Pointer to a handle to the new array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayGetLength Function

NArrayGetLength Function
NArray.h

Retrieves the length of the array.

C++
NResult N_API NArrayGetLength(HNArray hArray, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNArray hArray | [in] Handle to the array.
NInt * pValue | [out] Pointer to the length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayGetValue Function

NArrayGetValue Function
NArray.h

Retrieves the specified value in the array.

C++
NResult N_API NArrayGetValue(HNArray hArray, NInt index, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
HNArray hArray | [in] Handle to the array.
NInt index | [in] Index of the value.
HNValue * phValue | [out] Pointer to a handle to the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayGetValueAs Function

NArrayGetValueAs Function
NArray.h

Retrieves the of the specified value of the specified type in the array.

C++
NResult N_API NArrayGetValueAs(HNArray hArray, NInt index, HNType hType, NAttributes attributes, HNString hFormat, void * pValue, NSizeType elementSize);
Collapse Expand Parameters
Parameters | Description
HNArray hArray | [in] Handle to the array.
NInt index | [in] Index of the value.
HNType hType | [in] Handle to the type of the value.
NAttributes attributes | [in] Array attributes.
HNString hFormat | [in] Handle to the value format.
void * pValue | [out] Pointer to the value.
NSizeType elementSize | [in] Size of the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayGetValueAsBoolean Function

NArrayGetValueAsBoolean Function
NArray.h

Retrieves the of the specified Boolean value in the array.

C++
NResult N_API NArrayGetValueAsBoolean(HNArray hArray, NInt index, NAttributes attributes, HNString hFormat, NBoolean * pValue);
Collapse Expand Parameters
Parameters | Description
HNArray hArray | [in] Handle to the array.
NInt index | [in] Index of the value.
NAttributes attributes | [in] Array attributes.
HNString hFormat | [in] Handle to the value format.
NBoolean * pValue | [out] Pointer to the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayGetValueAsByte Function

NArrayGetValueAsByte Function
NArray.h

Retrieves the of the specified byte value in the array.

C++
NResult N_API NArrayGetValueAsByte(HNArray hArray, NInt index, NAttributes attributes, HNString hFormat, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNArray hArray | [in] Handle to the array.
NInt index | [in] Index of the value.
NAttributes attributes | [in] Array attributes.
HNString hFormat | [in] Handle to the value format.
NByte * pValue | [out] Pointer to the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayGetValueAsChar Function

NArrayGetValueAsChar Function
NArray.h

Retrieves the of the specified char value in the array.

C++
NResult N_API NArrayGetValueAsChar(HNArray hArray, NInt index, NAttributes attributes, HNString hFormat, NChar * pValue);
Collapse Expand Parameters
Parameters | Description
HNArray hArray | [in] Handle to the array.
NInt index | [in] Index of the value.
NAttributes attributes | [in] Array attributes.
HNString hFormat | [in] Handle to the value format.
NChar * pValue | [out] Pointer to the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayGetValueAsDouble Function

NArrayGetValueAsDouble Function
NArray.h

Retrieves the of the specified double value in the array.

C++
NResult N_API NArrayGetValueAsDouble(HNArray hArray, NInt index, NAttributes attributes, HNString hFormat, NDouble * pValue);
Collapse Expand Parameters
Parameters | Description
HNArray hArray | [in] Handle to the array.
NInt index | [in] Index of the value.
NAttributes attributes | [in] Array attributes.
HNString hFormat | [in] Handle to the value format.
NDouble * pValue | [out] Pointer to the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayGetValueAsInt16 Function

NArrayGetValueAsInt16 Function
NArray.h

Retrieves the of the specified short integer value in the array.

C++
NResult N_API NArrayGetValueAsInt16(HNArray hArray, NInt index, NAttributes attributes, HNString hFormat, NShort * pValue);
Collapse Expand Parameters
Parameters | Description
HNArray hArray | [in] Handle to the array.
NInt index | [in] Index of the value.
NAttributes attributes | [in] Array attributes.
HNString hFormat | [in] Handle to the value format.
NShort * pValue | [out] Pointer to the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayGetValueAsInt32 Function

NArrayGetValueAsInt32 Function
NArray.h

Retrieves the of the specified integer value in the array.

C++
NResult N_API NArrayGetValueAsInt32(HNArray hArray, NInt index, NAttributes attributes, HNString hFormat, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNArray hArray | [in] Handle to the array.
NInt index | [in] Index of the value.
NAttributes attributes | [in] Array attributes.
HNString hFormat | [in] Handle to the value format.
NInt * pValue | [out] Pointer to the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayGetValueAsInt64 Function

NArrayGetValueAsInt64 Function
NArray.h

Retrieves the of the specified long integer value in the array.

C++
NResult N_API NArrayGetValueAsInt64(HNArray hArray, NInt index, NAttributes attributes, HNString hFormat, NLong * pValue);
Collapse Expand Parameters
Parameters | Description
HNArray hArray | [in] Handle to the array.
NInt index | [in] Index of the value.
NAttributes attributes | [in] Array attributes.
HNString hFormat | [in] Handle to the value format.
NLong * pValue | [out] Pointer to the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayGetValueAsObject Function

NArrayGetValueAsObject Function
NArray.h

Retrieves the of the specified object value in the array.

C++
NResult N_API NArrayGetValueAsObject(HNArray hArray, NInt index, HNType hType, NAttributes attributes, HNString hFormat, HNObject * phValue);
Collapse Expand Parameters
Parameters | Description
HNArray hArray | [in] Handle to the array.
NInt index | [in] Index of the value.
HNType hType | [in] Handle to the type of object.
NAttributes attributes | [in] Array attributes.
HNString hFormat | [in] Handle to the value format.
HNObject * phValue | [out] Pointer to a handle to the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayGetValueAsObjectP Function

NArrayGetValueAsObjectP Function
NArray.h

Retrieves the of the specified object value in the array.

C++
NResult N_API NArrayGetValueAsObjectP(HNArray hArray, NInt index, NTypeOfProc pTypeOf, NAttributes attributes, HNString hFormat, HNObject * phValue);
Collapse Expand Parameters
Parameters | Description
HNArray hArray | [in] Handle to the array.
NInt index | [in] Index of the value.
NTypeOfProc pTypeOf | [in] Pointer to the function that retrieves the type of the object.
NAttributes attributes | [in] Array attributes.
HNString hFormat | [in] Handle to the value format.
HNObject * phValue | [out] Pointer to a handle to the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayGetValueAsP Function

NArrayGetValueAsP Function
NArray.h

Retrieves the of the specified value of the specified type in the array.

C++
NResult N_API NArrayGetValueAsP(HNArray hArray, NInt index, NTypeOfProc pTypeOf, NAttributes attributes, HNString hFormat, void * pValue, NSizeType elementSize);
Collapse Expand Parameters
Parameters | Description
HNArray hArray | [in] Handle to the array.
NInt index | [in] Index of the value.
NTypeOfProc pTypeOf | [in] Pointer to the function that retrieves the type of the value.
NAttributes attributes | [in] Array attributes.
HNString hFormat | [in] Handle to the value format.
void * pValue | [out] Pointer to the value.
NSizeType elementSize | [in] Size of the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayGetValueAsPointer Function

NArrayGetValueAsPointer Function
NArray.h

Retrieves the of the specified pointer value in the array.

C++
NResult N_API NArrayGetValueAsPointer(HNArray hArray, NInt index, NAttributes attributes, HNString hFormat, void * * pValue);
Collapse Expand Parameters
Parameters | Description
HNArray hArray | [in] Handle to the array.
NInt index | [in] Index of the value.
NAttributes attributes | [in] Array attributes.
HNString hFormat | [in] Handle to the value format.
void * * pValue | [out] Pointer to the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayGetValueAsResult Function

NArrayGetValueAsResult Function
NArray.h

Retrieves the of the specified NResult value in the array.

C++
NResult N_API NArrayGetValueAsResult(HNArray hArray, NInt index, NAttributes attributes, HNString hFormat, NResult * pValue);
Collapse Expand Parameters
Parameters | Description
HNArray hArray | [in] Handle to the array.
NInt index | [in] Index of the value.
NAttributes attributes | [in] Array attributes.
HNString hFormat | [in] Handle to the value format.
NResult * pValue | [out] Pointer to a handle to the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayGetValueAsSByte Function

NArrayGetValueAsSByte Function
NArray.h

Retrieves the of the specified signed byte value in the array.

C++
NResult N_API NArrayGetValueAsSByte(HNArray hArray, NInt index, NAttributes attributes, HNString hFormat, NSByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNArray hArray | [in] Handle to the array.
NInt index | [in] Index of the value.
NAttributes attributes | [in] Array attributes.
HNString hFormat | [in] Handle to the value format.
NSByte * pValue | [out] Pointer to the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayGetValueAsSSizeType Function

NArrayGetValueAsSSizeType Function
NArray.h

Retrieves the of the specified NSSizeType value in the array.

C++
NResult N_API NArrayGetValueAsSSizeType(HNArray hArray, NInt index, NAttributes attributes, HNString hFormat, NSSizeType * pValue);
Collapse Expand Parameters
Parameters | Description
HNArray hArray | [in] Handle to the array.
NInt index | [in] Index of the value.
NAttributes attributes | [in] Array attributes.
HNString hFormat | [in] Handle to the value format.
NSSizeType * pValue | [out] Pointer to the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayGetValueAsSingle Function

NArrayGetValueAsSingle Function
NArray.h

Retrieves the of the specified floating point integer value in the array.

C++
NResult N_API NArrayGetValueAsSingle(HNArray hArray, NInt index, NAttributes attributes, HNString hFormat, NFloat * pValue);
Collapse Expand Parameters
Parameters | Description
HNArray hArray | [in] Handle to the array.
NInt index | [in] Index of the value.
NAttributes attributes | [in] Array attributes.
HNString hFormat | [in] Handle to the value format.
NFloat * pValue | [out] Pointer to the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayGetValueAsSizeType Function

NArrayGetValueAsSizeType Function
NArray.h

Retrieves the of the specified NSizeType value in the array.

C++
NResult N_API NArrayGetValueAsSizeType(HNArray hArray, NInt index, NAttributes attributes, HNString hFormat, NSizeType * pValue);
Collapse Expand Parameters
Parameters | Description
HNArray hArray | [in] Handle to the array.
NInt index | [in] Index of the value.
NAttributes attributes | [in] Array attributes.
HNString hFormat | [in] Handle to the value format.
NSizeType * pValue | [out] Pointer to the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayGetValueAsString Function

NArrayGetValueAsString Function
NArray.h

Retrieves the of the specified string value in the array.

C++
NResult N_API NArrayGetValueAsString(HNArray hArray, NInt index, NAttributes attributes, HNString hFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNArray hArray | [in] Handle to the array.
NInt index | [in] Index of the value.
NAttributes attributes | [in] Array attributes.
HNString hFormat | [in] Handle to the value format.
HNString * phValue | [out] Pointer to a handle to the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayGetValueAsUInt16 Function

NArrayGetValueAsUInt16 Function
NArray.h

Retrieves the of the specified unsigned short integer value in the array.

C++
NResult N_API NArrayGetValueAsUInt16(HNArray hArray, NInt index, NAttributes attributes, HNString hFormat, NUShort * pValue);
Collapse Expand Parameters
Parameters | Description
HNArray hArray | [in] Handle to the array.
NInt index | [in] Index of the value.
NAttributes attributes | [in] Array attributes.
HNString hFormat | [in] Handle to the value format.
NUShort * pValue | [out] Pointer to the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayGetValueAsUInt32 Function

NArrayGetValueAsUInt32 Function
NArray.h

Retrieves the of the specified unsigned integer value in the array.

C++
NResult N_API NArrayGetValueAsUInt32(HNArray hArray, NInt index, NAttributes attributes, HNString hFormat, NUInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNArray hArray | [in] Handle to the array.
NInt index | [in] Index of the value.
NAttributes attributes | [in] Array attributes.
HNString hFormat | [in] Handle to the value format.
NUInt * pValue | [out] Pointer to the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayGetValueAsUInt64 Function

NArrayGetValueAsUInt64 Function
NArray.h

Retrieves the of the specified unsigned long integer value in the array.

C++
NResult N_API NArrayGetValueAsUInt64(HNArray hArray, NInt index, NAttributes attributes, HNString hFormat, NULong * pValue);
Collapse Expand Parameters
Parameters | Description
HNArray hArray | [in] Handle to the array.
NInt index | [in] Index of the value.
NAttributes attributes | [in] Array attributes.
HNString hFormat | [in] Handle to the value format.
NULong * pValue | [out] Pointer to the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArray.h

Module: NArray Unit


NArrayCopyToCharArray Macro

NArrayCopyToCharArray Macro
NArray.h

Picks a Unicode (W) or ANSCII (A) version of the NArrayCopyToCharArray function.

C++
#define NArrayCopyToCharArray N_FUNC_AW(NArrayCopyToCharArray)
Container

File: NArray.h

Module: NArray Unit


NArrayCreateFromCharArray Macro

NArrayCreateFromCharArray Macro
NArray.h

Picks a Unicode (W) or ANSCII (A) version of the NArrayCreateFromCharArray function.

C++
#define NArrayCreateFromCharArray N_FUNC_AW(NArrayCreateFromCharArray)
Container

File: NArray.h

Module: NArray Unit


NArrayCreateFromStringArray Macro

NArrayCreateFromStringArray Macro
NArray.h

Picks a Unicode (W) or ANSCII (A) version of the NArrayCreateFromStringArray function.

C++
#define NArrayCreateFromStringArray N_FUNC_AW(NArrayCreateFromStringArray)
Container

File: NArray.h

Module: NArray Unit


NArrayGetValueAsChar Macro

NArrayGetValueAsChar Macro
NArray.h

Picks a Unicode (W) or ANSCII (A) version of the NArrayGetValueAsChar function.

C++
#define NArrayGetValueAsChar N_FUNC_AW(NArrayGetValueAsChar)
Container

File: NArray.h

Module: NArray Unit


NArray.h

NArray.h
Functions Legend Macros

Header file for the NArray unit.

Collapse Expand Functions
Name | Description
NArrayCopyTo | Copies the specified array into another array.
NArrayCopyToBooleanArray | Copies the specified Boolean array into another array.
NArrayCopyToByteArray | Copies the specified byte array into another array.
NArrayCopyToCharArray | Copies the specified char array into another array.
NArrayCopyToDoubleArray | Copies the specified double value array into another array.
NArrayCopyToInt16Array | Copies the specified short integer array into another array.
NArrayCopyToInt32Array | Copies the specified integer array into another array.
NArrayCopyToInt64Array | Copies the specified long integer array into another array.
NArrayCopyToObjectArray | Copies the specified object array into another array.
NArrayCopyToObjectArrayP | Copies the specified object array into another array.
NArrayCopyToP | Copies the specified array into another array.
NArrayCopyToPointerArray | Copies the specified pointer array into another array.
NArrayCopyToResultArray | Copies the specified NResult value array into another array.
NArrayCopyToSByteArray | Copies the specified signed byte array into another array.
NArrayCopyToSSizeTypeArray | Copies the specified NSSizeType value array into another array.
NArrayCopyToSingleArray | Copies the specified floating point value array into another array.
NArrayCopyToSizeTypeArray | Copies the specified NSizeType value array into another array.
NArrayCopyToStringArray | Copies the specified string array into another array.
NArrayCopyToUInt16Array | Copies the specified unsigned short integer array into another array.
NArrayCopyToUInt32Array | Copies the specified unsigned integer array into another array.
NArrayCopyToUInt64Array | Copies the specified unsigned long integer array into another array.
NArrayCreate | Creates an array of specified type populated by specified values.
NArrayCreateCustom | Creates an array of specified type with additional options populated by specified values.
NArrayCreateFromBooleanArray | Creates an array from an array of Boolean values.
NArrayCreateFromByteArray | Creates an array from an array of bytes.
NArrayCreateFromCharArray | Creates an array from an array of chars.
NArrayCreateFromDoubleArray | Creates an array from an array of double values.
NArrayCreateFromInt16Array | Creates an array from an array of short integer values.
NArrayCreateFromInt32Array | Creates an array from an array of integer values.
NArrayCreateFromInt64Array | Creates an array from an array of long integer values.
NArrayCreateFromObjectArray | Creates an array from an array of object values.
NArrayCreateFromObjectArrayP | Creates an array from an array of object values.
NArrayCreateFromPointerArray | Creates an array from an array of pointer values.
NArrayCreateFromResultArray | Creates an array from an array of NResult values.
NArrayCreateFromSByteArray | Creates an array from an array of signed byte values.
NArrayCreateFromSSizeTypeArray | Creates an array from an array of NSSizeType values.
NArrayCreateFromSingleArray | Creates an array from an array of floating point values.
NArrayCreateFromSizeTypeArray | Creates an array from an array of NSizeType values.
NArrayCreateFromStringArray | Creates an array from an array of string values.
NArrayCreateFromUInt16Array | Creates an array from an array of unsinged short integer values.
NArrayCreateFromUInt32Array | Creates an array from an array of unsinged integer values.
NArrayCreateFromUInt64Array | Creates an array from an array of unsinged long integer values.
NArrayCreateP | Creates an array of specified type populated by specified values.
NArrayGetLength | Retrieves the length of the array.
NArrayGetValue | Retrieves the specified value in the array.
NArrayGetValueAs | Retrieves the of the specified value of the specified type in the array.
NArrayGetValueAsBoolean | Retrieves the of the specified Boolean value in the array.
NArrayGetValueAsByte | Retrieves the of the specified byte value in the array.
NArrayGetValueAsChar | Retrieves the of the specified char value in the array.
NArrayGetValueAsDouble | Retrieves the of the specified double value in the array.
NArrayGetValueAsInt16 | Retrieves the of the specified short integer value in the array.
NArrayGetValueAsInt32 | Retrieves the of the specified integer value in the array.
NArrayGetValueAsInt64 | Retrieves the of the specified long integer value in the array.
NArrayGetValueAsObject | Retrieves the of the specified object value in the array.
NArrayGetValueAsObjectP | Retrieves the of the specified object value in the array.
NArrayGetValueAsP | Retrieves the of the specified value of the specified type in the array.
NArrayGetValueAsPointer | Retrieves the of the specified pointer value in the array.
NArrayGetValueAsResult | Retrieves the of the specified NResult value in the array.
NArrayGetValueAsSByte | Retrieves the of the specified signed byte value in the array.
NArrayGetValueAsSSizeType | Retrieves the of the specified NSSizeType value in the array.
NArrayGetValueAsSingle | Retrieves the of the specified floating point integer value in the array.
NArrayGetValueAsSizeType | Retrieves the of the specified NSizeType value in the array.
NArrayGetValueAsString | Retrieves the of the specified string value in the array.
NArrayGetValueAsUInt16 | Retrieves the of the specified unsigned short integer value in the array.
NArrayGetValueAsUInt32 | Retrieves the of the specified unsigned integer value in the array.
NArrayGetValueAsUInt64 | Retrieves the of the specified unsigned long integer value in the array.
Collapse Expand Macros
Name | Description
NArrayCopyToCharArray | Picks a Unicode (W) or ANSCII (A) version of the NArrayCopyToCharArray function.
NArrayCreateFromCharArray | Picks a Unicode (W) or ANSCII (A) version of the NArrayCreateFromCharArray function.
NArrayCreateFromStringArray | Picks a Unicode (W) or ANSCII (A) version of the NArrayCreateFromStringArray function.
NArrayGetValueAsChar | Picks a Unicode (W) or ANSCII (A) version of the NArrayGetValueAsChar function.


NArrayCollection Unit

NArrayCollection Unit
Files Functions Legend

Provides functionality for working with collections of arrays.

Collapse Expand Files
Name | Description
NArrayCollection.h | Header file for the NArrayCollection module.
Collapse Expand Functions
Name | Description
NArrayCollectionAdd | Adds a value to the specified array collection.
NArrayCollectionAddItemRange | Adds an array of values to the specified array collection.
NArrayCollectionAddRange | Adds an array of values to the specified array collection.
NArrayCollectionClear | Clears the specified array in the collection.
NArrayCollectionContains | Checks whether the specified array collection contains the specified value.
NArrayCollectionGet | Retrieves the specified value from the array collection.
NArrayCollectionGetBaseCount | Retrieves the number of arrays in the array collection.
NArrayCollectionGetCount | Retrieves the number of values in the specified array.
NArrayCollectionIndexOf | Retrieves the index of the specified value in the array collection.
NArrayCollectionInsert | Adds a value to the specified array collection at the specified index.
NArrayCollectionInsertItemRange | Adds an array of values to the specified array collection at the specified index.
NArrayCollectionInsertRange | Adds an array of values to the specified array collection at the specified index.
NArrayCollectionIsReadOnly | Checks whether the specified array collection is read-only.
NArrayCollectionRemove | Removes a value from the specified array collection.
NArrayCollectionRemoveAt | Removes a value from the specified array collection.
NArrayCollectionRemoveRange | Removes a range of values from the specified array collection.
NArrayCollectionSet | Sets the specified value in the array collection.
NArrayCollectionToArray | Converts the specified array of the array collection into an independent array.
NArrayCollectionToItemArray | Converts the specified array of the array collection into an independent array.


NArrayCollectionAdd Function

NArrayCollectionAdd Function
NArrayCollection.h

Adds a value to the specified array collection.

C++
NResult N_API NArrayCollectionAdd(HNArrayCollection hArrayCollection, NInt baseIndex, HNType hValueType, NAttributes attributes, const void * pValue, NSizeType valueSize, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
HNArrayCollection hArrayCollection | [in] Handle to an array collection.
NInt baseIndex | [in] Index of the array in the collection.
HNType hValueType | [in] Handle to the value type.
NAttributes attributes | [in] Value attributes.
const void * pValue | [in] Pointer to the value to add.
NSizeType valueSize | [in] Size of the value.
NInt * pIndex | [out] Pointer to the value's index in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArrayCollection.h

Module: NArrayCollection Unit


NArrayCollectionAddItemRange Function

NArrayCollectionAddItemRange Function
NArrayCollection.h

Adds an array of values to the specified array collection.

C++
NResult N_API NArrayCollectionAddItemRange(HNArrayCollection hArrayCollection, NInt baseIndex, HNArray hValues, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
HNArrayCollection hArrayCollection | [in] Handle to an array collection.
NInt baseIndex | [in] Index of the destination array in the collection.
HNArray hValues | [in] Handle to the source array of values.
NInt * pIndex | [out] Pointer to the values' index in the destination array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArrayCollection.h

Module: NArrayCollection Unit


NArrayCollectionAddRange Function

NArrayCollectionAddRange Function
NArrayCollection.h

Adds an array of values to the specified array collection.

C++
NResult N_API NArrayCollectionAddRange(HNArrayCollection hArrayCollection, NInt baseIndex, HNType hValueType, NAttributes attributes, const void * arValues, NSizeType valuesSize, NInt valueCount, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
HNArrayCollection hArrayCollection | [in] Handle to an array collection.
NInt baseIndex | [in] Index of the destination array in the collection.
HNType hValueType | [in] Handle to the value type.
NAttributes attributes | [in] Value attributes.
const void * arValues | [in] Pointer to the source array of values.
NSizeType valuesSize | [in] Size of a value.
NInt valueCount | [in] Number of values in the array.
NInt * pIndex | [out] Pointer to the values' index in the destination array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArrayCollection.h

Module: NArrayCollection Unit


NArrayCollectionClear Function

NArrayCollectionClear Function
NArrayCollection.h

Clears the specified array in the collection.

C++
NResult N_API NArrayCollectionClear(HNArrayCollection hArrayCollection, NInt baseIndex);
Collapse Expand Parameters
Parameters | Description
HNArrayCollection hArrayCollection | [in] Handle to an array collection.
NInt baseIndex | [in] Index of the array in the collection.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArrayCollection.h

Module: NArrayCollection Unit


NArrayCollectionContains Function

NArrayCollectionContains Function
NArrayCollection.h

Checks whether the specified array collection contains the specified value.

C++
NResult N_API NArrayCollectionContains(HNArrayCollection hArrayCollection, NInt baseIndex, HNType hValueType, NAttributes attributes, const void * pValue, NSizeType valueSize, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNArrayCollection hArrayCollection | [in] Handle to an array collection.
NInt baseIndex | [in] Index of the array in the collection.
HNType hValueType | [in] Handle to the value type.
NAttributes attributes | [in] Value attributes.
const void * pValue | [in] Pointer to the value to find.
NSizeType valueSize | [in] Size of the value.
NBool * pResult | [out] NTrue if the array collection contains the value; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArrayCollection.h

Module: NArrayCollection Unit


NArrayCollectionGet Function

NArrayCollectionGet Function
NArrayCollection.h

Retrieves the specified value from the array collection.

C++
NResult N_API NArrayCollectionGet(HNArrayCollection hArrayCollection, NInt baseIndex, NInt index, HNType hValueType, NAttributes attributes, void * pValue, NSizeType valueSize);
Collapse Expand Parameters
Parameters | Description
HNArrayCollection hArrayCollection | [in] Handle to an array collection.
NInt baseIndex | [in] Index of the array in the collection.
NInt index | [in] Index of the value in the array.
HNType hValueType | [in] Handle to the value type.
NAttributes attributes | [in] Value attributes.
void * pValue | [out] Pointer to the value.
NSizeType valueSize | [in] Size of the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArrayCollection.h

Module: NArrayCollection Unit


NArrayCollectionGetBaseCount Function

NArrayCollectionGetBaseCount Function
NArrayCollection.h

Retrieves the number of arrays in the array collection.

C++
NResult N_API NArrayCollectionGetBaseCount(HNArrayCollection hArrayCollection, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNArrayCollection hArrayCollection | [in] Handle to an array collection.
NInt * pValue | [out] Pointer to the number of arrays in the collection.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArrayCollection.h

Module: NArrayCollection Unit


NArrayCollectionGetCount Function

NArrayCollectionGetCount Function
NArrayCollection.h

Retrieves the number of values in the specified array.

C++
NResult N_API NArrayCollectionGetCount(HNArrayCollection hArrayCollection, NInt baseIndex, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNArrayCollection hArrayCollection | [in] Handle to an array collection.
NInt baseIndex | [in] Index of the array in the collection.
NInt * pValue | [out] Pointer to the number of values in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArrayCollection.h

Module: NArrayCollection Unit


NArrayCollectionIndexOf Function

NArrayCollectionIndexOf Function
NArrayCollection.h

Retrieves the index of the specified value in the array collection.

C++
NResult N_API NArrayCollectionIndexOf(HNArrayCollection hArrayCollection, NInt baseIndex, HNType hValueType, NAttributes attributes, const void * pValue, NSizeType valueSize, NInt * pResult);
Collapse Expand Parameters
Parameters | Description
HNArrayCollection hArrayCollection | [in] Handle to an array collection.
NInt baseIndex | [in] Index of the array in the collection.
HNType hValueType | [in] Handle to the value type.
NAttributes attributes | [in] Value attributes.
const void * pValue | [in] Pointer to the value.
NSizeType valueSize | [in] Size of the value
NInt * pResult | [out] Pointer to the index of the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArrayCollection.h

Module: NArrayCollection Unit


NArrayCollectionInsert Function

NArrayCollectionInsert Function
NArrayCollection.h

Adds a value to the specified array collection at the specified index.

C++
NResult N_API NArrayCollectionInsert(HNArrayCollection hArrayCollection, NInt baseIndex, NInt index, HNType hValueType, NAttributes attributes, const void * pValue, NSizeType valueSize);
Collapse Expand Parameters
Parameters | Description
HNArrayCollection hArrayCollection | [in] Handle to an array collection.
NInt baseIndex | [in] Index of the array in the collection.
NInt index | [in] Index in the array at which to add the value.
HNType hValueType | [in] Handle to the value type.
NAttributes attributes | [in] Value attributes.
const void * pValue | [in] Pointer to the value to add.
NSizeType valueSize | [in] Size of the value.
pIndex | [out] Pointer to the value's index in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArrayCollection.h

Module: NArrayCollection Unit


NArrayCollectionInsertItemRange Function

NArrayCollectionInsertItemRange Function
NArrayCollection.h

Adds an array of values to the specified array collection at the specified index.

C++
NResult N_API NArrayCollectionInsertItemRange(HNArrayCollection hArrayCollection, NInt baseIndex, NInt index, HNArray hValues);
Collapse Expand Parameters
Parameters | Description
HNArrayCollection hArrayCollection | [in] Handle to an array collection.
NInt baseIndex | [in] Index of the destination array in the collection.
NInt index | [in] Index in the array at which to add the values.
HNArray hValues | [in] Handle to the source array of values.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArrayCollection.h

Module: NArrayCollection Unit


NArrayCollectionInsertRange Function

NArrayCollectionInsertRange Function
NArrayCollection.h

Adds an array of values to the specified array collection at the specified index.

C++
NResult N_API NArrayCollectionInsertRange(HNArrayCollection hArrayCollection, NInt baseIndex, NInt index, HNType hValueType, NAttributes attributes, const void * arValues, NSizeType valuesSize, NInt valueCount);
Collapse Expand Parameters
Parameters | Description
HNArrayCollection hArrayCollection | [in] Handle to an array collection.
NInt baseIndex | [in] Index of the destination array in the collection.
NInt index | [in] Index in the array at which to add the values.
HNType hValueType | [in] Handle to the value type.
NAttributes attributes | [in] Value attributes.
const void * arValues | [in] Pointer to the source array of values.
NSizeType valuesSize | [in] Size of a value.
NInt valueCount | [in] Number of values in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArrayCollection.h

Module: NArrayCollection Unit


NArrayCollectionIsReadOnly Function

NArrayCollectionIsReadOnly Function
NArrayCollection.h

Checks whether the specified array collection is read-only.

C++
NResult N_API NArrayCollectionIsReadOnly(HNArrayCollection hArrayCollection, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNArrayCollection hArrayCollection | [in] Handle to an array collection.
NBool * pValue | [out] NTrue if the array collection is read-only; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArrayCollection.h

Module: NArrayCollection Unit


NArrayCollectionRemove Function

NArrayCollectionRemove Function
NArrayCollection.h

Removes a value from the specified array collection.

C++
NResult N_API NArrayCollectionRemove(HNArrayCollection hArrayCollection, NInt baseIndex, HNType hValueType, NAttributes attributes, const void * pValue, NSizeType valueSize, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
HNArrayCollection hArrayCollection | [in] Handle to an array collection.
NInt baseIndex | [in] Index of the array in the collection.
HNType hValueType | [in] Handle to the value type.
NAttributes attributes | [in] Value attributes.
const void * pValue | [in] Pointer to the value to remove.
NSizeType valueSize | [in] Size of the value.
NInt * pIndex | [out] Pointer to the value's index in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArrayCollection.h

Module: NArrayCollection Unit


NArrayCollectionRemoveAt Function

NArrayCollectionRemoveAt Function
NArrayCollection.h

Removes a value from the specified array collection.

C++
NResult N_API NArrayCollectionRemoveAt(HNArrayCollection hArrayCollection, NInt baseIndex, NInt index);
Collapse Expand Parameters
Parameters | Description
HNArrayCollection hArrayCollection | [in] Handle to an array collection.
NInt baseIndex | [in] Index of the array in the collection.
NInt index | [in] Index of the value in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArrayCollection.h

Module: NArrayCollection Unit


NArrayCollectionRemoveRange Function

NArrayCollectionRemoveRange Function
NArrayCollection.h

Removes a range of values from the specified array collection.

C++
NResult N_API NArrayCollectionRemoveRange(HNArrayCollection hArrayCollection, NInt baseIndex, NInt startIndex, NInt count);
Collapse Expand Parameters
Parameters | Description
HNArrayCollection hArrayCollection | [in] Handle to an array collection.
NInt baseIndex | [in] Index of the array in the collection.
NInt startIndex | [in] Index of in the array at which to start removing.
NInt count | [in] Number of values to remove.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArrayCollection.h

Module: NArrayCollection Unit


NArrayCollectionSet Function

NArrayCollectionSet Function
NArrayCollection.h

Sets the specified value in the array collection.

C++
NResult N_API NArrayCollectionSet(HNArrayCollection hArrayCollection, NInt baseIndex, NInt index, HNType hValueType, NAttributes attributes, const void * pValue, NSizeType valueSize);
Collapse Expand Parameters
Parameters | Description
HNArrayCollection hArrayCollection | [in] Handle to an array collection.
NInt baseIndex | [in] Index of the array in the collection.
NInt index | [in] Index of the value in the array.
HNType hValueType | [in] Handle to the value type.
NAttributes attributes | [in] Value attributes.
const void * pValue | [in] Pointer to the new value.
NSizeType valueSize | [in] Size of the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArrayCollection.h

Module: NArrayCollection Unit


NArrayCollectionToArray Function

NArrayCollectionToArray Function
NArrayCollection.h

Converts the specified array of the array collection into an independent array.

C++
NResult N_API NArrayCollectionToArray(HNArrayCollection hArrayCollection, NInt baseIndex, HNType hValueType, NAttributes attributes, NSizeType valueSize, void * * parValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNArrayCollection hArrayCollection | [in] Handle to an array collection.
NInt baseIndex | [in] Index of the array in the collection.
HNType hValueType | [in] Handle to the value size.
NAttributes attributes | [in] Value attributes.
NSizeType valueSize | [in] Size of the value.
void * * parValues | [out] Pointer to the new array.
NInt * pValueCount | [out] Pointer to the number of values in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArrayCollection.h

Module: NArrayCollection Unit


NArrayCollectionToItemArray Function

NArrayCollectionToItemArray Function
NArrayCollection.h

Converts the specified array of the array collection into an independent array.

C++
NResult N_API NArrayCollectionToItemArray(HNArrayCollection hArrayCollection, NInt baseIndex, HNArray * phValues);
Collapse Expand Parameters
Parameters | Description
HNArrayCollection hArrayCollection | [in] Handle to an array collection.
NInt baseIndex | [in] Index of the array in the collection.
HNArray * phValues | [out] Pointer to the new array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArrayCollection.h

Module: NArrayCollection Unit


NArrayCollection.h

NArrayCollection.h
Functions Legend

Header file for the NArrayCollection module.

Collapse Expand Functions
Name | Description
NArrayCollectionAdd | Adds a value to the specified array collection.
NArrayCollectionAddItemRange | Adds an array of values to the specified array collection.
NArrayCollectionAddRange | Adds an array of values to the specified array collection.
NArrayCollectionClear | Clears the specified array in the collection.
NArrayCollectionContains | Checks whether the specified array collection contains the specified value.
NArrayCollectionGet | Retrieves the specified value from the array collection.
NArrayCollectionGetBaseCount | Retrieves the number of arrays in the array collection.
NArrayCollectionGetCount | Retrieves the number of values in the specified array.
NArrayCollectionIndexOf | Retrieves the index of the specified value in the array collection.
NArrayCollectionInsert | Adds a value to the specified array collection at the specified index.
NArrayCollectionInsertItemRange | Adds an array of values to the specified array collection at the specified index.
NArrayCollectionInsertRange | Adds an array of values to the specified array collection at the specified index.
NArrayCollectionIsReadOnly | Checks whether the specified array collection is read-only.
NArrayCollectionRemove | Removes a value from the specified array collection.
NArrayCollectionRemoveAt | Removes a value from the specified array collection.
NArrayCollectionRemoveRange | Removes a range of values from the specified array collection.
NArrayCollectionSet | Sets the specified value in the array collection.
NArrayCollectionToArray | Converts the specified array of the array collection into an independent array.
NArrayCollectionToItemArray | Converts the specified array of the array collection into an independent array.


NArrayCollectionInfo Unit

NArrayCollectionInfo Unit
Files Functions Legend

Provides functionality to retrieve information about array collections.

Collapse Expand Files
Name | Description
NArrayCollectionInfo.h | Header file for the NArrayCollectionInfo unit.
Collapse Expand Functions
Name | Description
NArrayCollectionInfoGetAddMethod | Retrieves the method which adds an item to an array collection.
NArrayCollectionInfoGetAddRangeMethod | Retrieves the method which adds a range of items to an array collection.
NArrayCollectionInfoGetBaseCollection | Retrieves the base collection of the array collection.
NArrayCollectionInfoGetClearMethod | Retrieves the method which clears the array collection.
NArrayCollectionInfoGetGetCountMethod | Retrieves the method which gets the number of items in the array collection.
NArrayCollectionInfoGetGetMethod | Retrieves the method which gets an item in the array collection.
NArrayCollectionInfoGetIndexOfMethod | Retrieves the method which gets an index of an item in the array collection.
NArrayCollectionInfoGetInsertMethod | Retrieves the method which adds an item to an array collection at a specific index.
NArrayCollectionInfoGetInsertRangeMethod | Retrieves the method which adds a range of items to an array collection at a specific index.
NArrayCollectionInfoGetItemAttributes | Retrieves the attributes of the items in the array collection.
NArrayCollectionInfoGetItemFormat | Retrieves the format of the items in the array collection.
NArrayCollectionInfoGetItemMaxValue | Retrieves the maximal item value of the array collection.
NArrayCollectionInfoGetItemMinValue | Retrieves the minimal item value of the array collection.
NArrayCollectionInfoGetItemStdValue | Retrieves the specified standard value of the array collection.
NArrayCollectionInfoGetItemStdValueCount | Retrieves the number of standard item values of the array collection.
NArrayCollectionInfoGetItemStdValues | Retrieves all standard item values of the array collection.
NArrayCollectionInfoGetItemType | Retrieves the type of the items in the array collection.
NArrayCollectionInfoGetRemoveAtMethod | Retrieves the method which removes an item with specific index from an array collection.
NArrayCollectionInfoGetRemoveMethod | Retrieves the method which removes an item from an array collection.
NArrayCollectionInfoGetRemoveRangeMethod | Retrieves the method which removes a range of items from an array collection.
NArrayCollectionInfoGetSetMethod | Retrieves the method which sets an item of the array collection.
NArrayCollectionInfoGetToArrayMethod | Retrieves the method which converts the array collection into a regular array.


NArrayCollectionInfoGetAddMethod Function

NArrayCollectionInfoGetAddMethod Function
NArrayCollectionInfo.h

Retrieves the method which adds an item to an array collection.

C++
NResult N_API NArrayCollectionInfoGetAddMethod(HNArrayCollectionInfo hArrayCollectionInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNArrayCollectionInfo hArrayCollectionInfo | [in] Handle to the array collection information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArrayCollectionInfo.h

Module: NArrayCollectionInfo Unit


NArrayCollectionInfoGetAddRangeMethod Function

NArrayCollectionInfoGetAddRangeMethod Function
NArrayCollectionInfo.h

Retrieves the method which adds a range of items to an array collection.

C++
NResult N_API NArrayCollectionInfoGetAddRangeMethod(HNArrayCollectionInfo hArrayCollectionInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNArrayCollectionInfo hArrayCollectionInfo | [in] Handle to the array collection information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArrayCollectionInfo.h

Module: NArrayCollectionInfo Unit


NArrayCollectionInfoGetBaseCollection Function

NArrayCollectionInfoGetBaseCollection Function
NArrayCollectionInfo.h

Retrieves the base collection of the array collection.

C++
NResult N_API NArrayCollectionInfoGetBaseCollection(HNArrayCollectionInfo hArrayCollectionInfo, HNCollectionInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNArrayCollectionInfo hArrayCollectionInfo | [in] Handle to the array collection information.
HNCollectionInfo * phValue | [out] Pointer to the base collection information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArrayCollectionInfo.h

Module: NArrayCollectionInfo Unit


NArrayCollectionInfoGetClearMethod Function

NArrayCollectionInfoGetClearMethod Function
NArrayCollectionInfo.h

Retrieves the method which clears the array collection.

C++
NResult N_API NArrayCollectionInfoGetClearMethod(HNArrayCollectionInfo hArrayCollectionInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNArrayCollectionInfo hArrayCollectionInfo | [in] Handle to the array collection information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArrayCollectionInfo.h

Module: NArrayCollectionInfo Unit


NArrayCollectionInfoGetGetCountMethod Function

NArrayCollectionInfoGetGetCountMethod Function
NArrayCollectionInfo.h

Retrieves the method which gets the number of items in the array collection.

C++
NResult N_API NArrayCollectionInfoGetGetCountMethod(HNArrayCollectionInfo hArrayCollectionInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNArrayCollectionInfo hArrayCollectionInfo | [in] Handle to the array collection information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArrayCollectionInfo.h

Module: NArrayCollectionInfo Unit


NArrayCollectionInfoGetGetMethod Function

NArrayCollectionInfoGetGetMethod Function
NArrayCollectionInfo.h

Retrieves the method which gets an item in the array collection.

C++
NResult N_API NArrayCollectionInfoGetGetMethod(HNArrayCollectionInfo hArrayCollectionInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNArrayCollectionInfo hArrayCollectionInfo | [in] Handle to the array collection information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArrayCollectionInfo.h

Module: NArrayCollectionInfo Unit


NArrayCollectionInfoGetIndexOfMethod Function

NArrayCollectionInfoGetIndexOfMethod Function
NArrayCollectionInfo.h

Retrieves the method which gets an index of an item in the array collection.

C++
NResult N_API NArrayCollectionInfoGetIndexOfMethod(HNArrayCollectionInfo hArrayCollectionInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNArrayCollectionInfo hArrayCollectionInfo | [in] Handle to the array collection information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArrayCollectionInfo.h

Module: NArrayCollectionInfo Unit


NArrayCollectionInfoGetInsertMethod Function

NArrayCollectionInfoGetInsertMethod Function
NArrayCollectionInfo.h

Retrieves the method which adds an item to an array collection at a specific index.

C++
NResult N_API NArrayCollectionInfoGetInsertMethod(HNArrayCollectionInfo hArrayCollectionInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNArrayCollectionInfo hArrayCollectionInfo | [in] Handle to the array collection information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArrayCollectionInfo.h

Module: NArrayCollectionInfo Unit


NArrayCollectionInfoGetInsertRangeMethod Function

NArrayCollectionInfoGetInsertRangeMethod Function
NArrayCollectionInfo.h

Retrieves the method which adds a range of items to an array collection at a specific index.

C++
NResult N_API NArrayCollectionInfoGetInsertRangeMethod(HNArrayCollectionInfo hArrayCollectionInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNArrayCollectionInfo hArrayCollectionInfo | [in] Handle to the array collection information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArrayCollectionInfo.h

Module: NArrayCollectionInfo Unit


NArrayCollectionInfoGetItemAttributes Function

NArrayCollectionInfoGetItemAttributes Function
NArrayCollectionInfo.h

Retrieves the attributes of the items in the array collection.

C++
NResult N_API NArrayCollectionInfoGetItemAttributes(HNArrayCollectionInfo hArrayCollectionInfo, NAttributes * pValue);
Collapse Expand Parameters
Parameters | Description
HNArrayCollectionInfo hArrayCollectionInfo | [in] Handle to the array collection information.
NAttributes * pValue | [out] Pointer to the attributes of the items.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArrayCollectionInfo.h

Module: NArrayCollectionInfo Unit


NArrayCollectionInfoGetItemFormat Function

NArrayCollectionInfoGetItemFormat Function
NArrayCollectionInfo.h

Retrieves the format of the items in the array collection.

C++
NResult N_API NArrayCollectionInfoGetItemFormat(HNArrayCollectionInfo hArrayCollectionInfo, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNArrayCollectionInfo hArrayCollectionInfo | [in] Handle to the array collection information.
HNString * phValue | [out] Pointer to the format of the items.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArrayCollectionInfo.h

Module: NArrayCollectionInfo Unit


NArrayCollectionInfoGetItemMaxValue Function

NArrayCollectionInfoGetItemMaxValue Function
NArrayCollectionInfo.h

Retrieves the maximal item value of the array collection.

C++
NResult N_API NArrayCollectionInfoGetItemMaxValue(HNArrayCollectionInfo hArrayCollectionInfo, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
HNArrayCollectionInfo hArrayCollectionInfo | [in] Handle to the array collection information.
HNValue * phValue | [out] Pointer to the maximal item value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArrayCollectionInfo.h

Module: NArrayCollectionInfo Unit


NArrayCollectionInfoGetItemMinValue Function

NArrayCollectionInfoGetItemMinValue Function
NArrayCollectionInfo.h

Retrieves the minimal item value of the array collection.

C++
NResult N_API NArrayCollectionInfoGetItemMinValue(HNArrayCollectionInfo hArrayCollectionInfo, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
HNArrayCollectionInfo hArrayCollectionInfo | [in] Handle to the array collection information.
HNValue * phValue | [out] Pointer to the minimal item value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArrayCollectionInfo.h

Module: NArrayCollectionInfo Unit


NArrayCollectionInfoGetItemStdValue Function

NArrayCollectionInfoGetItemStdValue Function
NArrayCollectionInfo.h

Retrieves the specified standard value of the array collection.

C++
NResult N_API NArrayCollectionInfoGetItemStdValue(HNArrayCollectionInfo hArrayCollectionInfo, NInt index, struct NNameValuePair_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNArrayCollectionInfo hArrayCollectionInfo | [in] Handle to the array collection information.
NInt index | [in] Index of the standard value.
struct NNameValuePair_ * pValue | [out] Pointer to the standard value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArrayCollectionInfo.h

Module: NArrayCollectionInfo Unit


NArrayCollectionInfoGetItemStdValueCount Function

NArrayCollectionInfoGetItemStdValueCount Function
NArrayCollectionInfo.h

Retrieves the number of standard item values of the array collection.

C++
NResult N_API NArrayCollectionInfoGetItemStdValueCount(HNArrayCollectionInfo hArrayCollectionInfo, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNArrayCollectionInfo hArrayCollectionInfo | [in] Handle to the array collection information.
NInt * pValue | [out] Pointer to the number of standard values.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArrayCollectionInfo.h

Module: NArrayCollectionInfo Unit


NArrayCollectionInfoGetItemStdValues Function

NArrayCollectionInfoGetItemStdValues Function
NArrayCollectionInfo.h

Retrieves all standard item values of the array collection.

C++
NResult N_API NArrayCollectionInfoGetItemStdValues(HNArrayCollectionInfo hArrayCollectionInfo, struct NNameValuePair_ * * parValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNArrayCollectionInfo hArrayCollectionInfo | [in] Handle to the array collection information.
struct NNameValuePair_ * * parValues | [out] Pointer to the array of standard values.
NInt * pValueCount | [out] Pointer to the number of standard values in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArrayCollectionInfo.h

Module: NArrayCollectionInfo Unit


NArrayCollectionInfoGetItemType Function

NArrayCollectionInfoGetItemType Function
NArrayCollectionInfo.h

Retrieves the type of the items in the array collection.

C++
NResult N_API NArrayCollectionInfoGetItemType(HNArrayCollectionInfo hArrayCollectionInfo, HNType * phValue);
Collapse Expand Parameters
Parameters | Description
HNArrayCollectionInfo hArrayCollectionInfo | [in] Handle to the array collection information.
HNType * phValue | [out] Pointer to the type of the items.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArrayCollectionInfo.h

Module: NArrayCollectionInfo Unit


NArrayCollectionInfoGetRemoveAtMethod Function

NArrayCollectionInfoGetRemoveAtMethod Function
NArrayCollectionInfo.h

Retrieves the method which removes an item with specific index from an array collection.

C++
NResult N_API NArrayCollectionInfoGetRemoveAtMethod(HNArrayCollectionInfo hArrayCollectionInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNArrayCollectionInfo hArrayCollectionInfo | [in] Handle to the array collection information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArrayCollectionInfo.h

Module: NArrayCollectionInfo Unit


NArrayCollectionInfoGetRemoveMethod Function

NArrayCollectionInfoGetRemoveMethod Function
NArrayCollectionInfo.h

Retrieves the method which removes an item from an array collection.

C++
NResult N_API NArrayCollectionInfoGetRemoveMethod(HNArrayCollectionInfo hArrayCollectionInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNArrayCollectionInfo hArrayCollectionInfo | [in] Handle to the array collection information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArrayCollectionInfo.h

Module: NArrayCollectionInfo Unit


NArrayCollectionInfoGetRemoveRangeMethod Function

NArrayCollectionInfoGetRemoveRangeMethod Function
NArrayCollectionInfo.h

Retrieves the method which removes a range of items from an array collection.

C++
NResult N_API NArrayCollectionInfoGetRemoveRangeMethod(HNArrayCollectionInfo hArrayCollectionInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNArrayCollectionInfo hArrayCollectionInfo | [in] Handle to the array collection information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArrayCollectionInfo.h

Module: NArrayCollectionInfo Unit


NArrayCollectionInfoGetSetMethod Function

NArrayCollectionInfoGetSetMethod Function
NArrayCollectionInfo.h

Retrieves the method which sets an item of the array collection.

C++
NResult N_API NArrayCollectionInfoGetSetMethod(HNArrayCollectionInfo hArrayCollectionInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNArrayCollectionInfo hArrayCollectionInfo | [in] Handle to the array collection information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArrayCollectionInfo.h

Module: NArrayCollectionInfo Unit


NArrayCollectionInfoGetToArrayMethod Function

NArrayCollectionInfoGetToArrayMethod Function
NArrayCollectionInfo.h

Retrieves the method which converts the array collection into a regular array.

C++
NResult N_API NArrayCollectionInfoGetToArrayMethod(HNArrayCollectionInfo hArrayCollectionInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNArrayCollectionInfo hArrayCollectionInfo | [in] Handle to the array collection information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NArrayCollectionInfo.h

Module: NArrayCollectionInfo Unit


NArrayCollectionInfo.h

NArrayCollectionInfo.h
Functions Legend

Header file for the NArrayCollectionInfo unit.

Collapse Expand Functions
Name | Description
NArrayCollectionInfoGetAddMethod | Retrieves the method which adds an item to an array collection.
NArrayCollectionInfoGetAddRangeMethod | Retrieves the method which adds a range of items to an array collection.
NArrayCollectionInfoGetBaseCollection | Retrieves the base collection of the array collection.
NArrayCollectionInfoGetClearMethod | Retrieves the method which clears the array collection.
NArrayCollectionInfoGetGetCountMethod | Retrieves the method which gets the number of items in the array collection.
NArrayCollectionInfoGetGetMethod | Retrieves the method which gets an item in the array collection.
NArrayCollectionInfoGetIndexOfMethod | Retrieves the method which gets an index of an item in the array collection.
NArrayCollectionInfoGetInsertMethod | Retrieves the method which adds an item to an array collection at a specific index.
NArrayCollectionInfoGetInsertRangeMethod | Retrieves the method which adds a range of items to an array collection at a specific index.
NArrayCollectionInfoGetItemAttributes | Retrieves the attributes of the items in the array collection.
NArrayCollectionInfoGetItemFormat | Retrieves the format of the items in the array collection.
NArrayCollectionInfoGetItemMaxValue | Retrieves the maximal item value of the array collection.
NArrayCollectionInfoGetItemMinValue | Retrieves the minimal item value of the array collection.
NArrayCollectionInfoGetItemStdValue | Retrieves the specified standard value of the array collection.
NArrayCollectionInfoGetItemStdValueCount | Retrieves the number of standard item values of the array collection.
NArrayCollectionInfoGetItemStdValues | Retrieves all standard item values of the array collection.
NArrayCollectionInfoGetItemType | Retrieves the type of the items in the array collection.
NArrayCollectionInfoGetRemoveAtMethod | Retrieves the method which removes an item with specific index from an array collection.
NArrayCollectionInfoGetRemoveMethod | Retrieves the method which removes an item from an array collection.
NArrayCollectionInfoGetRemoveRangeMethod | Retrieves the method which removes a range of items from an array collection.
NArrayCollectionInfoGetSetMethod | Retrieves the method which sets an item of the array collection.
NArrayCollectionInfoGetToArrayMethod | Retrieves the method which converts the array collection into a regular array.


NAsyncOperation Unit

NAsyncOperation Unit
Files Functions Legend Structs, Records, Enums

Provides functionality for working with asynchronous operations.

Asynchronous operations are functions and methods which return instantly, providing an object which can be used for operation's proper completion.

Collapse Expand Files
Name | Description
NAsyncOperation.h | Header file for the NAsyncOperation unit.
Collapse Expand Functions
Name | Description
NAsyncOperationAddCompleted | Adds a user-specified "completed" event to the specified asynchronous operation.
NAsyncOperationAddCompletedCallback | Adds a user-specified "completed" event callback to the specified asynchronous operation.
NAsyncOperationCancel | Cancels the specified asynchronous operation.
NAsyncOperationGetError | Retrieves the exception thrown by the specified asynchronous operation.
NAsyncOperationGetResult | Retrieves the value returned by the specified asynchronous operation.
NAsyncOperationGetStatus | Retrieves the status of the specified asynchronous operation.
NAsyncOperationIsCanceled | Checks whether the specified asynchronous operation has been canceled.
NAsyncOperationIsCompleted | Checks whether the specified asynchronous operation has been completed.
NAsyncOperationIsFaulted | Checks whether the specified asynchronous operation is faulted.
NAsyncOperationRemoveCompleted | Removes a user-specified "completed" event from the specified asynchronous operation.
NAsyncOperationRemoveCompletedCallback | Removes a user-specified "completed" event callback from the specified asynchronous operation.
NAsyncOperationWait | Waits until the specified asynchronous operation completes.
NAsyncOperationWaitAll | Waits until all asynchronous operations in the specified array complete.
NAsyncOperationWaitAllTimed | Waits until all asynchronous operations in the specified array complete or until the wait period times out.
NAsyncOperationWaitAny | Waits until at least one asynchronous operation in the specified array complete.
NAsyncOperationWaitAnyTimed | Waits until at least one asynchronous operation in the specified array complete or until the wait period times out.
NAsyncOperationWaitTimed | Waits until the specified asynchronous operation completes or until the wait period times out.
Collapse Expand Structs, Records, Enums
Name | Description
NAsyncStatus_ | Enumerates asynchronous operation statuses.
NAsyncStatus | Enumerates asynchronous operation statuses.


NAsyncOperationAddCompleted Function

NAsyncOperationAddCompleted Function
NAsyncOperation.h

Adds a user-specified "completed" event to the specified asynchronous operation.

C++
NResult N_API NAsyncOperationAddCompleted(HNAsyncOperation hAsyncOperation, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNAsyncOperation hAsyncOperation | [in] Handle to the async operation.
HNCallback hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NAsyncOperation.h

Module: NAsyncOperation Unit


NAsyncOperationAddCompletedCallback Function

NAsyncOperationAddCompletedCallback Function
NAsyncOperation.h

Adds a user-specified "completed" event callback to the specified asynchronous operation.

C++
NResult N_API NAsyncOperationAddCompletedCallback(HNAsyncOperation hAsyncOperation, NObjectCallback pCallback, void * pParam);
Collapse Expand Parameters
Parameters | Description
HNAsyncOperation hAsyncOperation | [in] Handle to the async operation.
NObjectCallback pCallback | [in] Pointer to the callback.
void * pParam | [out] User data used by a callback function.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NAsyncOperation.h

Module: NAsyncOperation Unit


NAsyncOperationCancel Function

NAsyncOperationCancel Function
NAsyncOperation.h

Cancels the specified asynchronous operation.

C++
NResult N_API NAsyncOperationCancel(HNAsyncOperation hAsyncOperation, NBool block);
Collapse Expand Parameters
Parameters | Description
HNAsyncOperation hAsyncOperation | [in] Handle to the async operation.
NBool block | [in] NTrue if exception thrown by the cancelling should be blocked; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NAsyncOperation.h

Module: NAsyncOperation Unit


NAsyncOperationGetError Function

NAsyncOperationGetError Function
NAsyncOperation.h

Retrieves the exception thrown by the specified asynchronous operation.

C++
NResult N_API NAsyncOperationGetError(HNAsyncOperation hAsyncOperation, HNError * phValue);
Collapse Expand Parameters
Parameters | Description
HNAsyncOperation hAsyncOperation | [in] Handle to the async operation.
HNError * phValue | [out] Pointer to the exception thrown by the specified async operation.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NAsyncOperation.h

Module: NAsyncOperation Unit


NAsyncOperationGetResult Function

NAsyncOperationGetResult Function
NAsyncOperation.h

Retrieves the value returned by the specified asynchronous operation.

C++
NResult N_API NAsyncOperationGetResult(HNAsyncOperation hAsyncOperation, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
HNAsyncOperation hAsyncOperation | [in] Handle to the async operation.
HNValue * phValue | [out] Pointer to the returned value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NAsyncOperation.h

Module: NAsyncOperation Unit


NAsyncOperationGetStatus Function

NAsyncOperationGetStatus Function
NAsyncOperation.h

Retrieves the status of the specified asynchronous operation.

C++
NResult N_API NAsyncOperationGetStatus(HNAsyncOperation hAsyncOperation, NAsyncStatus * pValue);
Collapse Expand Parameters
Parameters | Description
HNAsyncOperation hAsyncOperation | [in] Handle to the async operation.
NAsyncStatus * pValue | [out] Pointer to the status of the operation.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NAsyncOperation.h

Module: NAsyncOperation Unit


NAsyncOperationIsCanceled Function

NAsyncOperationIsCanceled Function
NAsyncOperation.h

Checks whether the specified asynchronous operation has been canceled.

C++
NResult N_API NAsyncOperationIsCanceled(HNAsyncOperation hAsyncOperation, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNAsyncOperation hAsyncOperation | [in] Handle to the async operation.
NBool * pValue | [out] NTrue if the operation can be canceled while running, else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NAsyncOperation.h

Module: NAsyncOperation Unit


NAsyncOperationIsCompleted Function

NAsyncOperationIsCompleted Function
NAsyncOperation.h

Checks whether the specified asynchronous operation has been completed.

C++
NResult N_API NAsyncOperationIsCompleted(HNAsyncOperation hAsyncOperation, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNAsyncOperation hAsyncOperation | [in] Handle to the async operation.
NBool * pValue | [out] NTrue if the async operation has been completed, else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NAsyncOperation.h

Module: NAsyncOperation Unit


NAsyncOperationIsFaulted Function

NAsyncOperationIsFaulted Function
NAsyncOperation.h

Checks whether the specified asynchronous operation is faulted.

C++
NResult N_API NAsyncOperationIsFaulted(HNAsyncOperation hAsyncOperation, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNAsyncOperation hAsyncOperation | [in] Handle to the async operation.
NBool * pValue | [out] NTrue if the async operation is faulted, else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NAsyncOperation.h

Module: NAsyncOperation Unit


NAsyncOperationRemoveCompleted Function

NAsyncOperationRemoveCompleted Function
NAsyncOperation.h

Removes a user-specified "completed" event from the specified asynchronous operation.

C++
NResult N_API NAsyncOperationRemoveCompleted(HNAsyncOperation hAsyncOperation, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNAsyncOperation hAsyncOperation | [in] Handle to the async operation.
HNCallback hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NAsyncOperation.h

Module: NAsyncOperation Unit


NAsyncOperationRemoveCompletedCallback Function

NAsyncOperationRemoveCompletedCallback Function
NAsyncOperation.h

Removes a user-specified "completed" event callback from the specified asynchronous operation.

C++
NResult N_API NAsyncOperationRemoveCompletedCallback(HNAsyncOperation hAsyncOperation, NObjectCallback pCallback, void * pParam);
Collapse Expand Parameters
Parameters | Description
HNAsyncOperation hAsyncOperation | [in] Handle to the async operation.
NObjectCallback pCallback | [in] Pointer to the callback.
void * pParam | [out] User data used by a callback function.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NAsyncOperation.h

Module: NAsyncOperation Unit


NAsyncOperationWait Function

NAsyncOperationWait Function
NAsyncOperation.h

Waits until the specified asynchronous operation completes.

C++
NResult N_API NAsyncOperationWait(HNAsyncOperation hAsyncOperation);
Collapse Expand Parameters
Parameters | Description
HNAsyncOperation hAsyncOperation | [in] Handle to the async operation.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NAsyncOperation.h

Module: NAsyncOperation Unit


NAsyncOperationWaitAll Function

NAsyncOperationWaitAll Function
NAsyncOperation.h

Waits until all asynchronous operations in the specified array complete.

C++
NResult N_API NAsyncOperationWaitAll(HNAsyncOperation * arhAsyncOperations, NInt asyncOperationCount);
Collapse Expand Parameters
Parameters | Description
HNAsyncOperation * arhAsyncOperations | [in/out] Pointer to an array of asynchronous operations.
NInt asyncOperationCount | [in] Number of operations in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NAsyncOperation.h

Module: NAsyncOperation Unit


NAsyncOperationWaitAllTimed Function

NAsyncOperationWaitAllTimed Function
NAsyncOperation.h

Waits until all asynchronous operations in the specified array complete or until the wait period times out.

C++
NResult N_API NAsyncOperationWaitAllTimed(HNAsyncOperation * arhAsyncOperations, NInt asyncOperationCount, NInt timeoutMilliseconds, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNAsyncOperation * arhAsyncOperations | [in/out] Pointer to an array of asynchronous operations.
NInt asyncOperationCount | [in] Number of operations in the array.
NInt timeoutMilliseconds | [in] Time out length.
NBool * pResult | [out] NTrue if the operations were completed before time out, else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NAsyncOperation.h

Module: NAsyncOperation Unit


NAsyncOperationWaitAny Function

NAsyncOperationWaitAny Function
NAsyncOperation.h

Waits until at least one asynchronous operation in the specified array complete.

C++
NResult N_API NAsyncOperationWaitAny(HNAsyncOperation * arhAsyncOperations, NInt asyncOperationCount, NInt * pResult);
Collapse Expand Parameters
Parameters | Description
HNAsyncOperation * arhAsyncOperations | [in/out] Pointer to an array of asynchronous operations.
NInt asyncOperationCount | [in] Number of operations in the array.
NInt * pResult | [out] Pointer to the index of the first completed operation.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NAsyncOperation.h

Module: NAsyncOperation Unit


NAsyncOperationWaitAnyTimed Function

NAsyncOperationWaitAnyTimed Function
NAsyncOperation.h

Waits until at least one asynchronous operation in the specified array complete or until the wait period times out.

C++
NResult N_API NAsyncOperationWaitAnyTimed(HNAsyncOperation * arhAsyncOperations, NInt asyncOperationCount, NInt timeoutMilliseconds, NInt * pResult);
Collapse Expand Parameters
Parameters | Description
HNAsyncOperation * arhAsyncOperations | [in/out] Pointer to an array of asynchronous operations.
NInt asyncOperationCount | [in] Number of operations in the array.
NInt timeoutMilliseconds | [in] Time out length.
NInt * pResult | [out] NTrue if the operation was completed before time out, else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NAsyncOperation.h

Module: NAsyncOperation Unit


NAsyncOperationWaitTimed Function

NAsyncOperationWaitTimed Function
NAsyncOperation.h

Waits until the specified asynchronous operation completes or until the wait period times out.

C++
NResult N_API NAsyncOperationWaitTimed(HNAsyncOperation hAsyncOperation, NInt timeoutMilliseconds, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNAsyncOperation hAsyncOperation | [in] Handle to the async operation.
NInt timeoutMilliseconds | [in] Time out length.
NBool * pResult | [out] NTrue if the operation was completed before time out, else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NAsyncOperation.h

Module: NAsyncOperation Unit


NAsyncStatus Enumeration

NAsyncStatus Enumeration
NAsyncOperation.h

Enumerates asynchronous operation statuses.

C++
typedef enum NAsyncStatus_ {
  nasNone = 0,
  nasStarted = 1,
  nasCompleted = 2,
  nasCanceled = 3,
  nasFaulted = 4
} NAsyncStatus;
Collapse Expand Members
Members | Description
nasNone = 0 | Indicates that no async operation is active.
nasStarted = 1 | Indicates that the async operation has started.
nasCompleted = 2 | Indicates that the async operation has been completed.
nasCanceled = 3 | Indicates that the async operation has been canceled.
nasFaulted = 4 | Indicates that the async operation is faulted and has thrown an exception.
Container

File: NAsyncOperation.h

Module: NAsyncOperation Unit


NAsyncOperation.h

NAsyncOperation.h
Enumerations Functions Legend

Header file for the NAsyncOperation unit.

Collapse Expand Enumerations
Name | Description
NAsyncStatus_ | Enumerates asynchronous operation statuses.
NAsyncStatus | Enumerates asynchronous operation statuses.
Collapse Expand Functions
Name | Description
NAsyncOperationAddCompleted | Adds a user-specified "completed" event to the specified asynchronous operation.
NAsyncOperationAddCompletedCallback | Adds a user-specified "completed" event callback to the specified asynchronous operation.
NAsyncOperationCancel | Cancels the specified asynchronous operation.
NAsyncOperationGetError | Retrieves the exception thrown by the specified asynchronous operation.
NAsyncOperationGetResult | Retrieves the value returned by the specified asynchronous operation.
NAsyncOperationGetStatus | Retrieves the status of the specified asynchronous operation.
NAsyncOperationIsCanceled | Checks whether the specified asynchronous operation has been canceled.
NAsyncOperationIsCompleted | Checks whether the specified asynchronous operation has been completed.
NAsyncOperationIsFaulted | Checks whether the specified asynchronous operation is faulted.
NAsyncOperationRemoveCompleted | Removes a user-specified "completed" event from the specified asynchronous operation.
NAsyncOperationRemoveCompletedCallback | Removes a user-specified "completed" event callback from the specified asynchronous operation.
NAsyncOperationWait | Waits until the specified asynchronous operation completes.
NAsyncOperationWaitAll | Waits until all asynchronous operations in the specified array complete.
NAsyncOperationWaitAllTimed | Waits until all asynchronous operations in the specified array complete or until the wait period times out.
NAsyncOperationWaitAny | Waits until at least one asynchronous operation in the specified array complete.
NAsyncOperationWaitAnyTimed | Waits until at least one asynchronous operation in the specified array complete or until the wait period times out.
NAsyncOperationWaitTimed | Waits until the specified asynchronous operation completes or until the wait period times out.


NBinaryReader Unit

NBinaryReader Unit
Functions Legend Macros

Provides functions to read primitive data types in specific encoding.

Collapse Expand Functions
Name | Description
NBinaryReaderCreate | Creates binary reader based on the specified stream and byte order.
NBinaryReaderCreateWithEncoding | Creates binary reader based on the specified stream, byte order and encoding.
NBinaryReaderGetBaseStream | Gets base stream (the one which was used to create NBinaryReader).
NBinaryReaderGetByteOrder | Gets byte order in specified NBinaryReader.
NBinaryReaderGetNull | Returns empty (null) NBinaryReader which can not be used for stream reading.
NBinaryReaderGetPosition | Gets position in base stream.
NBinaryReaderPeekChar | Returns the next available character in the NBinaryReader.
NBinaryReaderRead | Reads characters from base stream specified by NBinaryReader
NBinaryReaderReadBoolean | Reads NBoolean value from the stream and advances the current position of the stream by one byte.
NBinaryReaderReadByte | Reads one byte from the stream starting from the current position.
NBinaryReaderReadBytesDst | Reads bytes from the stream to memory buffer.
NBinaryReaderReadBytesDstN | Reads bytes from the stream to specified NBuffer.
NBinaryReaderReadBytesN | Reads bytes from the stream to specified NBuffer.
NBinaryReaderReadChar | Reads the next character from the stream and advances the current position of the stream.
NBinaryReaderReadChars | ... more
NBinaryReaderReadCharsDst | ... more
NBinaryReaderReadDouble | Reads an 8 byte floating point value (NDouble) from the stream and advances the current position of the stream.
NBinaryReaderReadInt16 | Reads a 2-byte signed integer from the stream and advances the current position of the stream.
NBinaryReaderReadInt32 | ... more
NBinaryReaderReadInt64 | ... more
NBinaryReaderReadSByte | Reads a signed byte from the stream and advances the current position of the stream by one byte.
NBinaryReaderReadSingle | Reads a 4-byte floating point value from the stream and advances the current position of the stream by four bytes.
NBinaryReaderReadUInt16 | ... more
NBinaryReaderReadUInt32 | Reads a 4-byte unsigned integer from the stream and advances the position of the stream by four bytes.
NBinaryReaderReadUInt64 | Reads an 8-byte unsigned integer from the stream and advances the position of the stream by eight bytes.
NBinaryReaderSeek | Sets the position in the stream.
NBinaryReaderSetPosition | Sets position in the base stream.
Collapse Expand Macros
Name | Description
NBinaryReaderPeekChar | Picks a Unicode (W) or ASCII (A) version of the NBinaryReaderPeekChar function.
NBinaryReaderRead | Picks a Unicode (W) or ASCII (A) version of the NBinaryReaderRead function.
NBinaryReaderReadChar | Picks a Unicode (W) or ASCII (A) version of the NBinaryReaderReadChar function.
NBinaryReaderReadChars | Picks a Unicode (W) or ASCII (A) version of the NBinaryReaderReadChars function.
NBinaryReaderReadCharsDst | Picks a Unicode (W) or ASCII (A) version of the NBinaryReaderReadCharsDst function.


NBinaryReaderCreate Function

NBinaryReaderCreate Function

Creates binary reader based on the specified stream and byte order.

C++
NResult N_API NBinaryReaderCreate(HNStream hStream, NByteOrder byteOrder, HNBinaryReader * phReader);
Collapse Expand Parameters
Parameters | Description
HNStream hStream | [in] Handle to input stream.
NByteOrder byteOrder | [in] Specifies byte order in the stream.
HNBinaryReader * phReader | [out] Pointer to created NBinaryReader.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBinaryReader.h

Module: NBinaryReader Unit


NBinaryReaderCreateWithEncoding Function

NBinaryReaderCreateWithEncoding Function

Creates binary reader based on the specified stream, byte order and encoding.

C++
NResult N_API NBinaryReaderCreateWithEncoding(HNStream hStream, NByteOrder byteOrder, NEncoding encoding, HNBinaryReader * phReader);
Collapse Expand Parameters
Parameters | Description
HNStream hStream | [in] Handle to input stream.
NByteOrder byteOrder | [in] Specifies byte order in the stream.
NEncoding encoding | [in] The character encoding to use.
HNBinaryReader * phReader | [out] Pointer to created NBinaryReader.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBinaryReader.h

Module: NBinaryReader Unit


NBinaryReaderGetBaseStream Function

NBinaryReaderGetBaseStream Function

Gets base stream (the one which was used to create NBinaryReader).

C++
NResult N_API NBinaryReaderGetBaseStream(HNBinaryReader hReader, HNStream * phValue);
Collapse Expand Parameters
Parameters | Description
HNBinaryReader hReader | [in] Handle to NBinaryReader.
HNStream * phValue | [out] Base stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

Using base stream while reading or while using the NBinaryReader can cause data loss and corruption. For example, the same bytes might be read more than once, bytes might be skipped, or character reading might become unpredictable.

NObjectUnref shall be called on returned objects when they are no longer used to prevent memory leaks.

Container

File: NBinaryReader.h

Module: NBinaryReader Unit


NBinaryReaderGetByteOrder Function

NBinaryReaderGetByteOrder Function

Gets byte order in specified NBinaryReader.

C++
NResult N_API NBinaryReaderGetByteOrder(HNBinaryReader hReader, NByteOrder * pValue);
Collapse Expand Parameters
Parameters | Description
HNBinaryReader hReader | [in] Handle to NBinaryReader.
NByteOrder * pValue | [out] Byte order.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBinaryReader.h

Module: NBinaryReader Unit


NBinaryReaderGetNull Function

NBinaryReaderGetNull Function

Returns empty (null) NBinaryReader which can not be used for stream reading.

C++
NResult N_API NBinaryReaderGetNull(HNBinaryReader * phValue);
Collapse Expand Parameters
Parameters | Description
HNBinaryReader * phValue | [out] Null NBinaryReader.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

NObjectUnref shall be called on returned objects when they are no longer used to prevent memory leaks.

Container

File: NBinaryReader.h

Module: NBinaryReader Unit


NBinaryReaderGetPosition Function

NBinaryReaderGetPosition Function

Gets position in base stream.

C++
NResult N_API NBinaryReaderGetPosition(HNBinaryReader hReader, NLong * pValue);
Collapse Expand Parameters
Parameters | Description
HNBinaryReader hReader | [in] Handle to NBinaryReader.
NLong * pValue | [out] The current position with base stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBinaryReader.h

Module: NBinaryReader Unit


NBinaryReaderPeekChar Function

NBinaryReaderPeekChar Function

Returns the next available character in the NBinaryReader.

C++
NResult N_API NBinaryReaderPeekChar(HNBinaryReader hReader, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNBinaryReader hReader | [in] Handle to NBinaryReader.
NInt * pValue | [out] The next available character or -1 if NBinaryReader (the stream) does not support seeking.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBinaryReader.h

Module: NBinaryReader Unit


NBinaryReaderRead Function

NBinaryReaderRead Function

Reads characters from base stream specified by NBinaryReader

C++
NResult N_API NBinaryReaderRead(HNBinaryReader hReader, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNBinaryReader hReader | [in] Handle to NBinaryReader.
NInt * pValue | [out] The next character from the base stream or -1 if no characters are available.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBinaryReader.h

Module: NBinaryReader Unit


NBinaryReaderReadBoolean Function

NBinaryReaderReadBoolean Function

Reads NBoolean value from the stream and advances the current position of the stream by one byte.

C++
NResult N_API NBinaryReaderReadBoolean(HNBinaryReader hReader, NBoolean * pValue);
Collapse Expand Parameters
Parameters | Description
HNBinaryReader hReader | [in] Handle to NBinaryReader.
NBoolean * pValue | [out] NTrue if the byte is nonzero; otherwise, NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBinaryReader.h

Module: NBinaryReader Unit


NBinaryReaderReadByte Function

NBinaryReaderReadByte Function

Reads one byte from the stream starting from the current position.

C++
NResult N_API NBinaryReaderReadByte(HNBinaryReader hReader, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNBinaryReader hReader | [in] Handle to NBinaryReader.
NByte * pValue | [out] Byte read from the stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBinaryReader.h

Module: NBinaryReader Unit


NBinaryReaderReadBytesDst Function

NBinaryReaderReadBytesDst Function

Reads bytes from the stream to memory buffer.

C++
NResult N_API NBinaryReaderReadBytesDst(HNBinaryReader hReader, void * pBuffer, NSizeType bufferSize, NBool readAll, NSizeType * pSizeRead);
Collapse Expand Parameters
Parameters | Description
HNBinaryReader hReader | [in] Handle to NBinaryReader.
void * pBuffer | [out] Pointer to memory buffer to read characters into.
NSizeType bufferSize | [in] Size of memory buffer pBuffer.
NBool readAll | [in] If NTrue N_E_END_OF_STREAM is returned when it is not possible to read specified number of bytes. If NFalse number of read bytes is returned through pSizeRead.
NSizeType * pSizeRead | [out] Number of read bytes.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBinaryReader.h

Module: NBinaryReader Unit


NBinaryReaderReadBytesDstN Function

NBinaryReaderReadBytesDstN Function

Reads bytes from the stream to specified NBuffer.

C++
NResult N_API NBinaryReaderReadBytesDstN(HNBinaryReader hReader, HNBuffer hBuffer, NBool readAll, NSizeType * pSizeRead);
Collapse Expand Parameters
Parameters | Description
HNBinaryReader hReader | [in] Handle to NBinaryReader.
HNBuffer hBuffer | [in] NBuffer to read data into.
NBool readAll | [in] If NTrue N_E_END_OF_STREAM is returned when it is not possible to read specified number of bytes. If NFalse number of read bytes is returned through pSizeRead.
NSizeType * pSizeRead | [out] Number of read bytes.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBinaryReader.h

Module: NBinaryReader Unit


NBinaryReaderReadBytesN Function

NBinaryReaderReadBytesN Function

Reads bytes from the stream to specified NBuffer.

C++
NResult N_API NBinaryReaderReadBytesN(HNBinaryReader hReader, NSizeType size, NBool readAll, HNBuffer * phBuffer);
Collapse Expand Parameters
Parameters | Description
HNBinaryReader hReader | [in] Handle to NBinaryReader.
NSizeType size | [in] Platform dependent size type of byte.
NBool readAll | [in] If NTrue N_E_END_OF_STREAM is returned when it is not possible to read specified number of bytes. If NFalse read bytes is returned through phBuffer.
HNBuffer * phBuffer | [out] Pointer to NBuffer containing read bytes.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBinaryReader.h

Module: NBinaryReader Unit


NBinaryReaderReadChar Function

NBinaryReaderReadChar Function

Reads the next character from the stream and advances the current position of the stream.

C++
NResult N_API NBinaryReaderReadChar(HNBinaryReader hReader, NChar * pValue);
Collapse Expand Parameters
Parameters | Description
HNBinaryReader hReader | [in] Handle to NBinaryReader.
NChar * pValue | [out] Character read from the stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBinaryReader.h

Module: NBinaryReader Unit


NBinaryReaderReadChars Function

NBinaryReaderReadChars Function

Reads the specified number of characters from the stream, and advances the current position in accordance with specific character being read from the stream.

C++
NResult N_API NBinaryReaderReadChars(HNBinaryReader hReader, NInt count, NBool readAll, NInt * pCharCount, NChar * * parChars);
Collapse Expand Parameters
Parameters | Description
HNBinaryReader hReader | [in] Handle to NBinaryReader.
NInt count | [in] Number of characters to read.
NBool readAll | [in] If NTrue N_E_END_OF_STREAM is returned when it is not possible to read specified number of bytes. If NFalse number of read bytes is returned through pCharCount.
NInt * pCharCount | [out] Actually read characters count.
NChar * * parChars | [out] Characters array containing data read from the stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBinaryReader.h

Module: NBinaryReader Unit


NBinaryReaderReadCharsDst Function

NBinaryReaderReadCharsDst Function

Reads the specified number of characters from the stream, and advances the current position in accordance with specific character being read from the stream.

C++
NResult N_API NBinaryReaderReadCharsDst(HNBinaryReader hReader, NChar * arChars, NInt count, NBool readAll, NInt * pCountRead);
Collapse Expand Parameters
Parameters | Description
HNBinaryReader hReader | [in] Handle to NBinaryReader.
NChar * arChars | [out] Characters array containing data read from the stream.
NInt count | [in] Number of characters to read.
NBool readAll | [in] If NTrue N_E_END_OF_STREAM is returned when it is not possible to read specified number of bytes. If NFalse number of read bytes is returned through pCharCount.
NInt * pCountRead | [out] Actually read characters count.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBinaryReader.h

Module: NBinaryReader Unit


NBinaryReaderReadDouble Function

NBinaryReaderReadDouble Function

Reads an 8 byte floating point value (NDouble) from the stream and advances the current position of the stream.

C++
NResult N_API NBinaryReaderReadDouble(HNBinaryReader hReader, NDouble * pValue);
Collapse Expand Parameters
Parameters | Description
HNBinaryReader hReader | [in] Handle to NBinaryReader.
NDouble * pValue | [out] NDouble value read from the stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBinaryReader.h

Module: NBinaryReader Unit


NBinaryReaderReadInt16 Function

NBinaryReaderReadInt16 Function

Reads a 2-byte signed integer from the stream and advances the current position of the stream.

C++
NResult N_API NBinaryReaderReadInt16(HNBinaryReader hReader, NInt16 * pValue);
Collapse Expand Parameters
Parameters | Description
HNBinaryReader hReader | [in] Handle to NBinaryReader.
NInt16 * pValue | [out] NInt16 value read from the stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBinaryReader.h

Module: NBinaryReader Unit


NBinaryReaderReadInt32 Function

NBinaryReaderReadInt32 Function

Reads a 4-byte signed integer from the stream and advances the current position of the stream by four bytes.

C++
NResult N_API NBinaryReaderReadInt32(HNBinaryReader hReader, NInt32 * pValue);
Collapse Expand Parameters
Parameters | Description
HNBinaryReader hReader | [in] Handle to NBinaryReader.
NInt32 * pValue | [out] NInt32 value read from the stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBinaryReader.h

Module: NBinaryReader Unit


NBinaryReaderReadInt64 Function

NBinaryReaderReadInt64 Function

Reads an 8-byte signed integer from the stream and advances the current position of the stream by eight bytes.

C++
NResult N_API NBinaryReaderReadInt64(HNBinaryReader hReader, NInt64 * pValue);
Collapse Expand Parameters
Parameters | Description
HNBinaryReader hReader | [in] Handle to NBinaryReader.
NInt64 * pValue | [out] NInt64 value read from the stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBinaryReader.h

Module: NBinaryReader Unit


NBinaryReaderReadSByte Function

NBinaryReaderReadSByte Function

Reads a signed byte from the stream and advances the current position of the stream by one byte.

C++
NResult N_API NBinaryReaderReadSByte(HNBinaryReader hReader, NSByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNBinaryReader hReader | [in] Handle to NBinaryReader.
NSByte * pValue | [out] NSByte value read from the stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBinaryReader.h

Module: NBinaryReader Unit


NBinaryReaderReadSingle Function

NBinaryReaderReadSingle Function

Reads a 4-byte floating point value from the stream and advances the current position of the stream by four bytes.

C++
NResult N_API NBinaryReaderReadSingle(HNBinaryReader hReader, NSingle * pValue);
Collapse Expand Parameters
Parameters | Description
HNBinaryReader hReader | [in] Handle to NBinaryReader.
NSingle * pValue | [out] NSingle value read from the stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBinaryReader.h

Module: NBinaryReader Unit


NBinaryReaderReadUInt16 Function

NBinaryReaderReadUInt16 Function

Reads a 2-byte unsigned integer from the stream and advances the position of the stream by two bytes.

C++
NResult N_API NBinaryReaderReadUInt16(HNBinaryReader hReader, NUInt16 * pValue);
Collapse Expand Parameters
Parameters | Description
HNBinaryReader hReader | [in] Handle to NBinaryReader.
NUInt16 * pValue | [out] NUInt16 value read from the stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBinaryReader.h

Module: NBinaryReader Unit


NBinaryReaderReadUInt32 Function

NBinaryReaderReadUInt32 Function

Reads a 4-byte unsigned integer from the stream and advances the position of the stream by four bytes.

C++
NResult N_API NBinaryReaderReadUInt32(HNBinaryReader hReader, NUInt32 * pValue);
Collapse Expand Parameters
Parameters | Description
HNBinaryReader hReader | [in] Handle to NBinaryReader.
NUInt32 * pValue | [out] NUInt32 value read from the stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBinaryReader.h

Module: NBinaryReader Unit


NBinaryReaderReadUInt64 Function

NBinaryReaderReadUInt64 Function

Reads an 8-byte unsigned integer from the stream and advances the position of the stream by eight bytes.

C++
NResult N_API NBinaryReaderReadUInt64(HNBinaryReader hReader, NUInt64 * pValue);
Collapse Expand Parameters
Parameters | Description
HNBinaryReader hReader | [in] Handle to NBinaryReader.
NUInt64 * pValue | [out] NUInt64 value read from the stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBinaryReader.h

Module: NBinaryReader Unit


NBinaryReaderSeek Function

NBinaryReaderSeek Function

Sets the position in the stream.

C++
NResult N_API NBinaryReaderSeek(HNBinaryReader hReader, NLong offset, NSeekOrigin origin);
Collapse Expand Parameters
Parameters | Description
HNBinaryReader hReader | [in] Handle to NBinaryReader.
NLong offset | [in] A byte offset.
NSeekOrigin origin | [in] NSeekOrigin indicating the reference point used to obtain the new position.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBinaryReader.h

Module: NBinaryReader Unit


NBinaryReaderSetPosition Function

NBinaryReaderSetPosition Function

Sets position in the base stream.

C++
NResult N_API NBinaryReaderSetPosition(HNBinaryReader hReader, NLong value);
Collapse Expand Parameters
Parameters | Description
HNBinaryReader hReader | [in] Handle to NBinaryReader.
NLong value | [in] Position to set.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBinaryReader.h

Module: NBinaryReader Unit


NBinaryReaderPeekChar Macro

NBinaryReaderPeekChar Macro

Picks a Unicode (W) or ASCII (A) version of the NBinaryReaderPeekChar function.

C++
#define NBinaryReaderPeekChar N_FUNC_AW(NBinaryReaderPeekChar)
Container

File: NBinaryReader.h

Module: NBinaryReader Unit


NBinaryReaderRead Macro

NBinaryReaderRead Macro

Picks a Unicode (W) or ASCII (A) version of the NBinaryReaderRead function.

C++
#define NBinaryReaderRead N_FUNC_AW(NBinaryReaderRead)
Container

File: NBinaryReader.h

Module: NBinaryReader Unit


NBinaryReaderReadChar Macro

NBinaryReaderReadChar Macro

Picks a Unicode (W) or ASCII (A) version of the NBinaryReaderReadChar function.

C++
#define NBinaryReaderReadChar N_FUNC_AW(NBinaryReaderReadChar)
Container

File: NBinaryReader.h

Module: NBinaryReader Unit


NBinaryReaderReadChars Macro

NBinaryReaderReadChars Macro

Picks a Unicode (W) or ASCII (A) version of the NBinaryReaderReadChars function.

C++
#define NBinaryReaderReadChars N_FUNC_AW(NBinaryReaderReadChars)
Container

File: NBinaryReader.h

Module: NBinaryReader Unit


NBinaryReaderReadCharsDst Macro

NBinaryReaderReadCharsDst Macro

Picks a Unicode (W) or ASCII (A) version of the NBinaryReaderReadCharsDst function.

C++
#define NBinaryReaderReadCharsDst N_FUNC_AW(NBinaryReaderReadCharsDst)
Container

File: NBinaryReader.h

Module: NBinaryReader Unit


NBinaryWriter Unit

NBinaryWriter Unit
Functions Legend Macros

Provides functions to write primitive types in binary to a stream.

Collapse Expand Functions
Name | Description
NBinaryWriterCreate | Creates binary writer based on the specified stream and byte order.
NBinaryWriterCreateWithEncoding | Creates binary writer based on the specified stream, byte order and encoding.
NBinaryWriterFlush | Clears all buffers for the current writer.
NBinaryWriterGetBaseStream | Gets the base stream of the NBinaryWriter.
NBinaryWriterGetByteOrder | Gets byte order in specified NBinaryWriter.
NBinaryWriterGetNull | Returns empty (null) NBinaryWriter which can not be used for stream reading.
NBinaryWriterGetPosition | Gets position in base stream.
NBinaryWriterSeek | Sets the position in the stream.
NBinaryWriterSetPosition | Sets position in the base stream.
NBinaryWriterWriteBoolean | Writes NBoolean value into the stream.
NBinaryWriterWriteByte | Writes one byte into the stream starting from the current position.
NBinaryWriterWriteBytes | Writes bytes into the stream from specified memory buffer.
NBinaryWriterWriteBytesN | Writes bytes into the stream from specified NBuffer.
NBinaryWriterWriteChar | Writes specified character into the stream and advances the current position of the stream.
NBinaryWriterWriteChars | Writes the specified number of characters into the stream, and advances the current position in accordance with specific character being written into the stream.
NBinaryWriterWriteDouble | ... more
NBinaryWriterWriteInt16 | Writes 2-byte signed integer to the stream and advances the current position of the stream by two bytes.
NBinaryWriterWriteInt32 | Writes a 4-byte signed integer to the stream and advances the position of the stream by four bytes.
NBinaryWriterWriteInt64 | Writes a 8-byte signed integer to the stream and advances the position of the stream by eight bytes.
NBinaryWriterWriteSByte | Writes a signed byte into the stream and advances the position of the stream by one byte.
NBinaryWriterWriteSingle | Writes a 4-byte floating point value into the stream and advances the current position of the stream by four bytes.
NBinaryWriterWriteUInt16 | Writes a 2-byte unsigned integer to the stream and advances the position of the stream by two bytes.
NBinaryWriterWriteUInt32 | Writes a 4-byte unsigned integer to the stream and advances the position of the stream by four bytes.
NBinaryWriterWriteUInt64 | Writes a 8-byte unsigned integer to the stream and advances the position of the stream by eight bytes.
Collapse Expand Macros
Name | Description
NBinaryWriterWriteChar | Picks a Unicode (W) or ASCII (A) version of the NBinaryWriterWriteChar function.
NBinaryWriterWriteChars | Picks a Unicode (W) or ASCII (A) version of the NBinaryWriterWriteChars function.


NBinaryWriterCreate Function

NBinaryWriterCreate Function

Creates binary writer based on the specified stream and byte order.

C++
NResult N_API NBinaryWriterCreate(HNStream hStream, NByteOrder byteOrder, HNBinaryWriter * phWriter);
Collapse Expand Parameters
Parameters | Description
HNStream hStream | [in] Handle to input stream.
NByteOrder byteOrder | [in] Specifies byte order in the stream.
HNBinaryWriter * phWriter | [out] Pointer to created NBinaryWriter.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBinaryWriter.h

Module: NBinaryWriter Unit


NBinaryWriterCreateWithEncoding Function

NBinaryWriterCreateWithEncoding Function

Creates binary writer based on the specified stream, byte order and encoding.

C++
NResult N_API NBinaryWriterCreateWithEncoding(HNStream hStream, NByteOrder byteOrder, NEncoding encoding, HNBinaryWriter * phWriter);
Collapse Expand Parameters
Parameters | Description
HNStream hStream | [in] Handle to input stream.
NByteOrder byteOrder | [in] Specifies byte order in the stream.
NEncoding encoding | [in] The character encoding to use.
HNBinaryWriter * phWriter | [out] Pointer to created NBinaryWriter.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBinaryWriter.h

Module: NBinaryWriter Unit


NBinaryWriterFlush Function

NBinaryWriterFlush Function

Clears all buffers for the current writer.

C++
NResult N_API NBinaryWriterFlush(HNBinaryWriter hWriter);
Collapse Expand Parameters
Parameters | Description
HNBinaryWriter hWriter | _nt_
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBinaryWriter.h

Module: NBinaryWriter Unit


NBinaryWriterGetBaseStream Function

NBinaryWriterGetBaseStream Function

Gets the base stream of the NBinaryWriter.

C++
NResult N_API NBinaryWriterGetBaseStream(HNBinaryWriter hWriter, HNStream * phValue);
Collapse Expand Parameters
Parameters | Description
HNBinaryWriter hWriter | [in] Handle to NBinaryReader.
HNStream * phValue | [out] Base stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

NObjectUnref shall be called on returned objects when they are no longer used to prevent memory leaks.

Container

File: NBinaryWriter.h

Module: NBinaryWriter Unit


NBinaryWriterGetByteOrder Function

NBinaryWriterGetByteOrder Function

Gets byte order in specified NBinaryWriter.

C++
NResult N_API NBinaryWriterGetByteOrder(HNBinaryWriter hWriter, NByteOrder * pValue);
Collapse Expand Parameters
Parameters | Description
HNBinaryWriter hWriter | [in] Handle to NBinaryWriter.
NByteOrder * pValue | [out] Byte order.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBinaryWriter.h

Module: NBinaryWriter Unit


NBinaryWriterGetNull Function

NBinaryWriterGetNull Function

Returns empty (null) NBinaryWriter which can not be used for stream reading.

C++
NResult N_API NBinaryWriterGetNull(HNBinaryWriter * phValue);
Collapse Expand Parameters
Parameters | Description
HNBinaryWriter * phValue | [out] Null NBinaryWriter.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

NObjectUnref shall be called on returned objects when they are no longer used to prevent memory leaks.

Container

File: NBinaryWriter.h

Module: NBinaryWriter Unit


NBinaryWriterGetPosition Function

NBinaryWriterGetPosition Function

Gets position in base stream.

C++
NResult N_API NBinaryWriterGetPosition(HNBinaryWriter hWriter, NLong * pValue);
Collapse Expand Parameters
Parameters | Description
HNBinaryWriter hWriter | [in] Handle to NBinaryWriter.
NLong * pValue | [out] The current position with base stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBinaryWriter.h

Module: NBinaryWriter Unit


NBinaryWriterSeek Function

NBinaryWriterSeek Function

Sets the position in the stream.

C++
NResult N_API NBinaryWriterSeek(HNBinaryWriter hWriter, NLong offset, NSeekOrigin origin);
Collapse Expand Parameters
Parameters | Description
HNBinaryWriter hWriter | [in] Handle to NBinaryWriter.
NLong offset | [in] A byte offset.
NSeekOrigin origin | [in] NSeekOrigin indicating the reference point used to obtain the new position.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBinaryWriter.h

Module: NBinaryWriter Unit


NBinaryWriterSetPosition Function

NBinaryWriterSetPosition Function

Sets position in the base stream.

C++
NResult N_API NBinaryWriterSetPosition(HNBinaryWriter hWriter, NLong value);
Collapse Expand Parameters
Parameters | Description
HNBinaryWriter hWriter | [in] Handle to NBinaryWriter.
NLong value | [in] Position to set.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBinaryWriter.h

Module: NBinaryWriter Unit


NBinaryWriterWriteBoolean Function

NBinaryWriterWriteBoolean Function

Writes NBoolean value into the stream.

C++
NResult N_API NBinaryWriterWriteBoolean(HNBinaryWriter hWriter, NBoolean value);
Collapse Expand Parameters
Parameters | Description
HNBinaryWriter hWriter | [in] Handle to NBinaryWriter.
NBoolean value | [in] NBoolean value to write.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBinaryWriter.h

Module: NBinaryWriter Unit


NBinaryWriterWriteByte Function

NBinaryWriterWriteByte Function

Writes one byte into the stream starting from the current position.

C++
NResult N_API NBinaryWriterWriteByte(HNBinaryWriter hWriter, NByte value);
Collapse Expand Parameters
Parameters | Description
HNBinaryWriter hWriter | [in] Handle to NBinaryWriter.
NByte value | [out] Byte written into the stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBinaryWriter.h

Module: NBinaryWriter Unit


NBinaryWriterWriteBytes Function

NBinaryWriterWriteBytes Function

Writes bytes into the stream from specified memory buffer.

C++
NResult N_API NBinaryWriterWriteBytes(HNBinaryWriter hWriter, const void * pBuffer, NSizeType bufferSize);
Collapse Expand Parameters
Parameters | Description
HNBinaryWriter hWriter | [in] Handle to NBinaryWriter.
const void * pBuffer | [out] Pointer to memory buffer to write characters from.
NSizeType bufferSize | [in] Size of memory buffer pBuffer.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBinaryWriter.h

Module: NBinaryWriter Unit


NBinaryWriterWriteBytesN Function

NBinaryWriterWriteBytesN Function

Writes bytes into the stream from specified NBuffer.

C++
NResult N_API NBinaryWriterWriteBytesN(HNBinaryWriter hWriter, HNBuffer hBuffer);
Collapse Expand Parameters
Parameters | Description
HNBinaryWriter hWriter | [in] Handle to NBinaryWriter.
HNBuffer hBuffer | [in] NBuffer to write data from.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBinaryWriter.h

Module: NBinaryWriter Unit


NBinaryWriterWriteChar Function

NBinaryWriterWriteChar Function

Writes specified character into the stream and advances the current position of the stream.

C++
NResult N_API NBinaryWriterWriteChar(HNBinaryWriter hWriter, NChar value);
Collapse Expand Parameters
Parameters | Description
HNBinaryWriter hWriter | [in] Handle to NBinaryWriter.
NChar value | [in] Character to write into the stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBinaryWriter.h

Module: NBinaryWriter Unit


NBinaryWriterWriteChars Function

NBinaryWriterWriteChars Function

Writes the specified number of characters into the stream, and advances the current position in accordance with specific character being written into the stream.

C++
NResult N_API NBinaryWriterWriteChars(HNBinaryWriter hWriter, const NChar * arChars, NInt count);
Collapse Expand Parameters
Parameters | Description
HNBinaryWriter hWriter | [in] Handle to NBinaryWriter.
const NChar * arChars | [in] Characters array containing data to write to the stream.
NInt count | [in] Number of characters to write.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBinaryWriter.h

Module: NBinaryWriter Unit


NBinaryWriterWriteDouble Function

NBinaryWriterWriteDouble Function

Writes a 8-byte floating point value (NDouble) into the stream and advances the current position of the stream by eight bytes.

C++
NResult N_API NBinaryWriterWriteDouble(HNBinaryWriter hWriter, NDouble value);
Collapse Expand Parameters
Parameters | Description
HNBinaryWriter hWriter | [in] Handle to NBinaryWriter.
NDouble value | [out] NDouble written into the stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBinaryWriter.h

Module: NBinaryWriter Unit


NBinaryWriterWriteInt16 Function

NBinaryWriterWriteInt16 Function

Writes 2-byte signed integer to the stream and advances the current position of the stream by two bytes.

C++
NResult N_API NBinaryWriterWriteInt16(HNBinaryWriter hWriter, NInt16 value);
Collapse Expand Parameters
Parameters | Description
HNBinaryWriter hWriter | [in] Handle to NBinaryWriter.
NInt16 value | [in] NInt16 written into the stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBinaryWriter.h

Module: NBinaryWriter Unit


NBinaryWriterWriteInt32 Function

NBinaryWriterWriteInt32 Function

Writes a 4-byte signed integer to the stream and advances the position of the stream by four bytes.

C++
NResult N_API NBinaryWriterWriteInt32(HNBinaryWriter hWriter, NInt32 value);
Collapse Expand Parameters
Parameters | Description
HNBinaryWriter hWriter | [in] Handle to NBinaryWriter.
NInt32 value | [in] NInt32 to write to the stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBinaryWriter.h

Module: NBinaryWriter Unit


NBinaryWriterWriteInt64 Function

NBinaryWriterWriteInt64 Function

Writes a 8-byte signed integer to the stream and advances the position of the stream by eight bytes.

C++
NResult N_API NBinaryWriterWriteInt64(HNBinaryWriter hWriter, NInt64 value);
Collapse Expand Parameters
Parameters | Description
HNBinaryWriter hWriter | [in] Handle to NBinaryWriter.
NInt64 value | [in] NInt64 to write to the stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBinaryWriter.h

Module: NBinaryWriter Unit


NBinaryWriterWriteSByte Function

NBinaryWriterWriteSByte Function

Writes a signed byte into the stream and advances the position of the stream by one byte.

C++
NResult N_API NBinaryWriterWriteSByte(HNBinaryWriter hWriter, NSByte value);
Collapse Expand Parameters
Parameters | Description
HNBinaryWriter hWriter | [in] Handle to NBinaryWriter.
NSByte value | [in] NSByte to write to the stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBinaryWriter.h

Module: NBinaryWriter Unit


NBinaryWriterWriteSingle Function

NBinaryWriterWriteSingle Function

Writes a 4-byte floating point value into the stream and advances the current position of the stream by four bytes.

C++
NResult N_API NBinaryWriterWriteSingle(HNBinaryWriter hWriter, NSingle value);
Collapse Expand Parameters
Parameters | Description
HNBinaryWriter hWriter | [in] Handle to NBinaryWriter.
NSingle value | [in] NSingle to write to the stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBinaryWriter.h

Module: NBinaryWriter Unit


NBinaryWriterWriteUInt16 Function

NBinaryWriterWriteUInt16 Function

Writes a 2-byte unsigned integer to the stream and advances the position of the stream by two bytes.

C++
NResult N_API NBinaryWriterWriteUInt16(HNBinaryWriter hWriter, NUInt16 value);
Collapse Expand Parameters
Parameters | Description
HNBinaryWriter hWriter | [in] Handle to NBinaryWriter.
NUInt16 value | [in] NUInt16 to write to the stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBinaryWriter.h

Module: NBinaryWriter Unit


NBinaryWriterWriteUInt32 Function

NBinaryWriterWriteUInt32 Function

Writes a 4-byte unsigned integer to the stream and advances the position of the stream by four bytes.

C++
NResult N_API NBinaryWriterWriteUInt32(HNBinaryWriter hWriter, NUInt32 value);
Collapse Expand Parameters
Parameters | Description
HNBinaryWriter hWriter | [in] Handle to NBinaryWriter.
NUInt32 value | [in] NUInt32 to write to the stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBinaryWriter.h

Module: NBinaryWriter Unit


NBinaryWriterWriteUInt64 Function

NBinaryWriterWriteUInt64 Function

Writes a 8-byte unsigned integer to the stream and advances the position of the stream by eight bytes.

C++
NResult N_API NBinaryWriterWriteUInt64(HNBinaryWriter hWriter, NUInt64 value);
Collapse Expand Parameters
Parameters | Description
HNBinaryWriter hWriter | [in] Handle to NBinaryWriter.
NUInt64 value | [in] NUInt64 to write to the stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBinaryWriter.h

Module: NBinaryWriter Unit


NBinaryWriterWriteChar Macro

NBinaryWriterWriteChar Macro

Picks a Unicode (W) or ASCII (A) version of the NBinaryWriterWriteChar function.

C++
#define NBinaryWriterWriteChar N_FUNC_AW(NBinaryWriterWriteChar)
Container

File: NBinaryWriter.h

Module: NBinaryWriter Unit


NBinaryWriterWriteChars Macro

NBinaryWriterWriteChars Macro

Picks a Unicode (W) or ASCII (A) version of the NBinaryWriterWriteChars function.

C++
#define NBinaryWriterWriteChars N_FUNC_AW(NBinaryWriterWriteChars)
Container

File: NBinaryWriter.h

Module: NBinaryWriter Unit


NBuffer Unit

NBuffer Unit
Files Functions Legend Macros

Provides access to unmanaged blocks of memory from managed code.

Collapse Expand Files
Name | Description
NBuffer.h | Header file for the NBuffer unit.
Collapse Expand Functions
Name | Description
NBufferCopy | Copies data into current NBuffer from a different NBuffer with specified offsets into both buffers and specified size.
NBufferCopyFromPtr | Copies data into current NBuffer from a different NBuffer with specified offsets into current NBuffer and specified size of the source NBuffer.
NBufferCopyTo | Reads the bytes from the current NBuffer and writes them to another buffer, using a specified offset.
NBufferCopyToPtr | ... more
NBufferCopyToPtrRange | Reads the bytes from the current NBuffer and writes them to another buffer, using a specified offset and buffer size.
NBufferCreate | Creates a new NBuffer using the specified memory location and size.
NBufferCreateFromBuffer | Creates a new NBuffer based on the specified byte array, with specified offset and size.
NBufferCreateFromPtr | Creates a new NBuffer using the specified memory location and size.
NBufferCreateFromPtrEx | Creates a new NBuffer using the specified size and a specified location of specified type.
NBufferCreateFromPtrWithFree | ... more
NBufferCreateFromPtrWithFreeProc | Creates a new NBuffer using the specified memory location and size; frees the memory in the source location.
NBufferGetEmpty | Returns an empty buffer.
NBufferGetPtr | Reads the bytes from the NBuffer and returns them as a pointer.
NBufferGetSize | Returns the size of the NBuffer in bytes.
NBufferToPtr | Copies the memory contained in NBuffer and returns it as a pointer.
Collapse Expand Macros
Name | Description
NBufferCreateFromConstPtr | Creates a new NBuffer using the specified memory location and size.


NBufferCopy Function

NBufferCopy Function
NBuffer.h

Copies data into current NBuffer from a different NBuffer with specified offsets into both buffers and specified size.

C++
NResult N_API NBufferCopy(HNBuffer hSrcBuffer, NSizeType srcOffset, HNBuffer hDstBuffer, NSizeType dstOffset, NSizeType size);
Collapse Expand Parameters
Parameters | Description
HNBuffer hSrcBuffer | [in] A handle to the source NBuffer.
NSizeType srcOffset | [in] The zero-based byte offset into the source NBuffer.
HNBuffer hDstBuffer | [in] A handle to the destination NBuffer.
NSizeType dstOffset | [in] The zero-based byte offset into the destination NBuffer.
NSizeType size | [in] The positive NInt32 value greater than 0 indicating the source NBuffer size in bytes.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBuffer.h

Module: NBuffer Unit


NBufferCopyFromPtr Function

NBufferCopyFromPtr Function
NBuffer.h

Copies data into current NBuffer from a different NBuffer with specified offsets into current NBuffer and specified size of the source NBuffer.

C++
NResult N_API NBufferCopyFromPtr(HNBuffer hBuffer, const void * pSrcBuffer, NSizeType srcBufferSize, NSizeType offset);
Collapse Expand Parameters
Parameters | Description
HNBuffer hBuffer | [in] A handle to NBuffer.
const void * pSrcBuffer | [in] A pointer to the source buffer.
NSizeType srcBufferSize | [in] The size of the source buffer in bytes.
NSizeType offset | [in] The zero-based byte offset into current NBuffer.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBuffer.h

Module: NBuffer Unit


NBufferCopyTo Function

NBufferCopyTo Function
NBuffer.h

Reads the bytes from the current NBuffer and writes them to another buffer, using a specified offset.

C++
NResult N_API NBufferCopyTo(HNBuffer hBuffer, HNBuffer hDstBuffer, NSizeType dstOffset);
Collapse Expand Parameters
Parameters | Description
HNBuffer hBuffer | [in] A handle to NBuffer.
HNBuffer hDstBuffer | [in] A handle to the destination buffer.
NSizeType dstOffset | [in] The zero-based byte offset into the destination NBuffer.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBuffer.h

Module: NBuffer Unit


NBufferCopyToPtr Function

NBufferCopyToPtr Function
NBuffer.h

Reads the bytes from the current NBuffer and writes them to another buffer, indicated by a pointer, using a specified buffer size.

C++
NResult N_API NBufferCopyToPtr(HNBuffer hBuffer, void * pDstBuffer, NSizeType dstBufferSize);
Collapse Expand Parameters
Parameters | Description
HNBuffer hBuffer | [in] A handle to NBuffer.
void * pDstBuffer | [in] A pointer to the destination buffer.
NSizeType dstBufferSize | [in] The positive value greater than 0 indicating the destination buffer size in bytes.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBuffer.h

Module: NBuffer Unit


NBufferCopyToPtrRange Function

NBufferCopyToPtrRange Function
NBuffer.h

Reads the bytes from the current NBuffer and writes them to another buffer, using a specified offset and buffer size.

C++
NResult N_API NBufferCopyToPtrRange(HNBuffer hBuffer, NSizeType offset, void * pDstBuffer, NSizeType dstBufferSize, NSizeType size);
Collapse Expand Parameters
Parameters | Description
HNBuffer hBuffer | [in] A handle to NBuffer.
NSizeType offset | [in] The zero-based byte offset into the NBuffer.
void * pDstBuffer | [in] A pointer to the destination buffer.
NSizeType dstBufferSize | [in] The destination buffer's size in bytes.
NSizeType size | [in] NBuffer's size in bytes.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBuffer.h

Module: NBuffer Unit


NBufferCreate Function

NBufferCreate Function
NBuffer.h

Creates a new NBuffer using the specified memory location and size.

C++
NResult N_API NBufferCreate(NSizeType size, HNBuffer * phBuffer);
Collapse Expand Parameters
Parameters | Description
NSizeType size | [in] The size of the NBuffer. This value must be greater than zero. The default size is 4096.
HNBuffer * phBuffer | [out] A pointer to the created NBuffer.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBuffer.h

Module: NBuffer Unit


NBufferCreateFromBuffer Function

NBufferCreateFromBuffer Function
NBuffer.h

Creates a new NBuffer based on the specified byte array, with specified offset and size.

C++
NResult N_API NBufferCreateFromBuffer(HNBuffer hSrcBuffer, NSizeType offset, NSizeType size, HNBuffer * phBuffer);
Collapse Expand Parameters
Parameters | Description
HNBuffer hSrcBuffer | [in] A handle to the source NBuffer.
NSizeType offset | [in] The byte position in the buffer at which to start the unmanaged memory stream.
NSizeType size | [in] The size of the NBuffer. This value must be greater than zero. The default size is 4096.
HNBuffer * phBuffer | [out] A pointer to the created NBuffer.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBuffer.h

Module: NBuffer Unit


NBufferCreateFromPtr Function

NBufferCreateFromPtr Function
NBuffer.h

Creates a new NBuffer using the specified memory location and size.

C++
NResult N_API NBufferCreateFromPtr(void * ptr, NSizeType size, NBool ownsPtr, HNBuffer * phBuffer);
Collapse Expand Parameters
Parameters | Description
void * ptr | [in] A pointer to the source memory location.
NSizeType size | [in] The size of the NBuffer. This value must be greater than zero. The default size is 4096.
NBool ownsPtr | [in] NTrue to reliably release the pointer during the finalization phase; NFalse to prevent reliable release (not recommended).
HNBuffer * phBuffer | [out] A pointer to the created NBuffer.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBuffer.h

Module: NBuffer Unit


NBufferCreateFromPtrEx Function

NBufferCreateFromPtrEx Function
NBuffer.h

Creates a new NBuffer using the specified size and a specified location of specified type.

C++
NResult N_API NBufferCreateFromPtrEx(void * ptr, NSizeType size, NMemoryType ptrType, HNBuffer * phBuffer);
Collapse Expand Parameters
Parameters | Description
void * ptr | [in] A pointer to the source memory location.
NSizeType size | [in] The size of the NBuffer. This value must be greater than zero. The default size is 4096.
NMemoryType ptrType | [in] The type of source memory location.
HNBuffer * phBuffer | [out] A pointer to the created NBuffer.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBuffer.h

Module: NBuffer Unit


NBufferCreateFromPtrWithFree Function

NBufferCreateFromPtrWithFree Function
NBuffer.h

Creates a new NBuffer using the specified memory location and size; frees the memory in the source location.

C++
NResult N_API NBufferCreateFromPtrWithFree(void * ptr, NSizeType size, HNCallback hFree, HNBuffer * phBuffer);
Collapse Expand Parameters
Parameters | Description
void * ptr | [in] A pointer to the source memory location.
NSizeType size | [in] The size of the NBuffer. This value must be greater than zero. The default size is 4096.
HNCallback hFree | [in] A callback called when NBuffer is freed.
HNBuffer * phBuffer | [out] A pointer to the created NBuffer.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBuffer.h

Module: NBuffer Unit


NBufferCreateFromPtrWithFreeProc Function

NBufferCreateFromPtrWithFreeProc Function
NBuffer.h

Creates a new NBuffer using the specified memory location and size; frees the memory in the source location.

C++
NResult N_API NBufferCreateFromPtrWithFreeProc(void * ptr, NSizeType size, NPointerFreeProc pFree, void * pFreeParam, HNBuffer * phBuffer);
Collapse Expand Parameters
Parameters | Description
void * ptr | [in] A pointer to the source memory location.
NSizeType size | [in] The size of the NBuffer. This value must be greater than zero. The default size is 4096.
NPointerFreeProc pFree | [in] A callback called when NBuffer is freed.
void * pFreeParam | [in] A pointer to user data provided to NPointerFreeProc.
HNBuffer * phBuffer | [out] A pointer to the created NBuffer.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBuffer.h

Module: NBuffer Unit


NBufferGetEmpty Function

NBufferGetEmpty Function
NBuffer.h

Returns an empty buffer.

C++
NResult N_API NBufferGetEmpty(HNBuffer * phValue);
Collapse Expand Parameters
Parameters | Description
HNBuffer * phValue | [out] A pointer to empty NBuffer.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

NObjectUnref shall be called on returned objects when they are no longer used to prevent memory leaks.

Container

File: NBuffer.h

Module: NBuffer Unit


NBufferGetPtr Function

NBufferGetPtr Function
NBuffer.h

Reads the bytes from the NBuffer and returns them as a pointer.

C++
NResult N_API NBufferGetPtr(HNBuffer hBuffer, void * * pValue);
Collapse Expand Parameters
Parameters | Description
HNBuffer hBuffer | [in] A handle to NBuffer.
void * * pValue | [out] A pointer to the NBuffer.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBuffer.h

Module: NBuffer Unit


NBufferGetSize Function

NBufferGetSize Function
NBuffer.h

Returns the size of the NBuffer in bytes.

C++
NResult N_API NBufferGetSize(HNBuffer hBuffer, NSizeType * pValue);
Collapse Expand Parameters
Parameters | Description
HNBuffer hBuffer | [in] A handle to NBuffer.
NSizeType * pValue | [out] A pointer to a positive NInt32 value greater than 0 indicating the buffer size.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBuffer.h

Module: NBuffer Unit


NBufferToPtr Function

NBufferToPtr Function
NBuffer.h

Copies the memory contained in NBuffer and returns it as a pointer.

C++
NResult N_API NBufferToPtr(HNBuffer hBuffer, NSizeType * pBufferSize, void * * ppBuffer);
Collapse Expand Parameters
Parameters | Description
HNBuffer hBuffer | [in] A handle to NBuffer.
NSizeType * pBufferSize | [out] A pointer to a positive NInt32 value greater than 0 indicating the buffer size.
void * * ppBuffer | [out] A pointer to the returned memory.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBuffer.h

Module: NBuffer Unit


NBufferCreateFromConstPtr Macro

NBufferCreateFromConstPtr Macro
NBuffer.h

Creates a new NBuffer using the specified memory location and size.

C++
#define NBufferCreateFromConstPtr(ptr, size, phBuffer) NBufferCreateFromPtr((void *)ptr, size, NFalse, phBuffer)
Collapse Expand Parameters
Parameters | Description
ptr | [in] A pointer to the source memory location.
size | [in] The size of the NBuffer. This value must be greater than zero. The default size is 4096.
phBuffer | [out] A pointer to the created NBuffer.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBuffer.h

Module: NBuffer Unit


NBuffer.h

NBuffer.h
Functions Legend Macros

Header file for the NBuffer unit.

Collapse Expand Functions
Name | Description
NBufferCopy | Copies data into current NBuffer from a different NBuffer with specified offsets into both buffers and specified size.
NBufferCopyFromPtr | Copies data into current NBuffer from a different NBuffer with specified offsets into current NBuffer and specified size of the source NBuffer.
NBufferCopyTo | Reads the bytes from the current NBuffer and writes them to another buffer, using a specified offset.
NBufferCopyToPtr | ... more
NBufferCopyToPtrRange | Reads the bytes from the current NBuffer and writes them to another buffer, using a specified offset and buffer size.
NBufferCreate | Creates a new NBuffer using the specified memory location and size.
NBufferCreateFromBuffer | Creates a new NBuffer based on the specified byte array, with specified offset and size.
NBufferCreateFromPtr | Creates a new NBuffer using the specified memory location and size.
NBufferCreateFromPtrEx | Creates a new NBuffer using the specified size and a specified location of specified type.
NBufferCreateFromPtrWithFree | ... more
NBufferCreateFromPtrWithFreeProc | Creates a new NBuffer using the specified memory location and size; frees the memory in the source location.
NBufferGetEmpty | Returns an empty buffer.
NBufferGetPtr | Reads the bytes from the NBuffer and returns them as a pointer.
NBufferGetSize | Returns the size of the NBuffer in bytes.
NBufferToPtr | Copies the memory contained in NBuffer and returns it as a pointer.
Collapse Expand Macros
Name | Description
NBufferCreateFromConstPtr | Creates a new NBuffer using the specified memory location and size.


NBufferedStream Unit

NBufferedStream Unit
Files Functions Legend

Provides functions for adding a buffering layer to read and write operations on another stream.

Collapse Expand Files
Name | Description
NBufferedStream.h | Header file for the NBufferedStream unit.
Collapse Expand Functions
Name | Description
NBufferedStreamCreate | Creates a new NBufferedStream with a default buffer size of 4096 bytes.
NBufferedStreamCreateWithBufferSize | Creates a new NBufferedStream with the specified buffer size.


NBufferedStreamCreate Function

NBufferedStreamCreate Function
NBufferedStream.h

Creates a new NBufferedStream with a default buffer size of 4096 bytes.

C++
NResult N_API NBufferedStreamCreate(HNStream hInnerStream, HNBufferedStream * phStream);
Collapse Expand Parameters
Parameters | Description
HNStream hInnerStream | [in] A handle to the current stream.
HNBufferedStream * phStream | [out] A pointer to the created NBufferedStream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBufferedStream.h

Module: NBufferedStream Unit


NBufferedStreamCreateWithBufferSize Function

NBufferedStreamCreateWithBufferSize Function
NBufferedStream.h

Creates a new NBufferedStream with the specified buffer size.

C++
NResult N_API NBufferedStreamCreateWithBufferSize(HNStream hInnerStream, NSizeType bufferSize, HNBufferedStream * phStream);
Collapse Expand Parameters
Parameters | Description
HNStream hInnerStream | [in] A handle to the current stream.
NSizeType bufferSize | [in] A buffer size in bytes.
HNBufferedStream * phStream | [out] A pointer to the created NBufferedStream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBufferedStream.h

Module: NBufferedStream Unit


NBufferedStream.h

NBufferedStream.h
Functions Legend

Header file for the NBufferedStream unit.

Collapse Expand Functions
Name | Description
NBufferedStreamCreate | Creates a new NBufferedStream with a default buffer size of 4096 bytes.
NBufferedStreamCreateWithBufferSize | Creates a new NBufferedStream with the specified buffer size.


NCallback Unit

NCallback Unit
Files Functions Legend Macros

Provides function callback functionality.

Collapse Expand Files
Name | Description
NCallback.h | Header file for the NCallback unit.
Collapse Expand Functions
Name | Description
NCallbackClone | Creates a copy of the specified callback.
NCallbackCreateCustomRaw | Creates a callback for the specified process with additional parameters.
NCallbackCreateRaw | Creates a callback for the specified process.
NCallbackCreateWithObjectRaw | Creates a callback for the specified process.
NCallbackEquals | Checks whether the specified callback equals the other specified callback.
NCallbackFree | Frees the specified callback.
NCallbackGetHashCode | Retrieves the hash code of the specified callback.
NCallbackGetParam | Retrieves the parameters of the specified callback.
NCallbackGetProcRaw | Retrieves the process that invokes the specified callback.
NCallbackSet | Sets the value of the specified variable to the value of the specified callback.
Collapse Expand Macros
Name | Description
NCallbackCreate | Creates a callback for the specified process.
NCallbackCreateCustom | Creates a callback for the specified process with additional parameters.
NCallbackGetProc | Retrieves the process that invokes the specified callback.
NCallbackInvoke0 | Invokes the specified callback.
NCallbackInvoke1 | Invokes the specified callback with specified arguments.
NCallbackInvoke2 | Invokes the specified callback with specified arguments.
NCallbackInvoke3 | Invokes the specified callback with specified arguments.
NCallbackInvoke4 | Invokes the specified callback with specified arguments.
NCallbackInvoke5 | Invokes the specified callback with specified arguments.
NCallbackInvoke6 | Invokes the specified callback with specified arguments.
NCallbackInvoke7 | Invokes the specified callback with specified arguments.
NCallbackInvoke8 | Invokes the specified callback with specified arguments.
NCallbackInvoke9 | Invokes the specified callback with specified arguments.
NCallbackInvokeRaw | Invokes the specified callback with specified arguments.


NCallbackClone Function

NCallbackClone Function
NCallback.h

Creates a copy of the specified callback.

C++
NResult N_API NCallbackClone(HNCallback hCallback, HNCallback * phClonedCallback);
Collapse Expand Parameters
Parameters | Description
HNCallback hCallback | [in] Handle to the callback to be cloned.
HNCallback * phClonedCallback | [out] Pointer to handle to the copy of the callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCallback.h

Module: NCallback Unit


NCallbackCreateCustomRaw Function

NCallbackCreateCustomRaw Function
NCallback.h

Creates a callback for the specified process with additional parameters.

C++
NResult N_API NCallbackCreateCustomRaw(void * pProc, void * pParam, NPointerFreeProc pFree, NPointerGetHashCodeProc pGetHashCode, NPointerEqualsProc pEquals, HNCallback * phCallback);
Collapse Expand Parameters
Parameters | Description
void * pProc | [in/out] Pointer to the process.
void * pParam | [in/out] Pointer to the callback parameters.
NPointerFreeProc pFree | [in] Pointer to the process that frees the callback.
NPointerGetHashCodeProc pGetHashCode | [in] Pointer to the process that retrieves the hash code of the callback.
NPointerEqualsProc pEquals | [in] Pointer to the process that retrieves the compares two callbacks.
HNCallback * phCallback | [out] Pointer to a handle to the callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Notes

Raw functions (i.e. NCallbackCreateRaw) represent the functions themselves.

Non-raw functions (i.e. NCallbackCreate) represent macros that call those functions for the convenience of using them in C++.

Container

File: NCallback.h

Module: NCallback Unit


NCallbackCreateRaw Function

NCallbackCreateRaw Function
NCallback.h

Creates a callback for the specified process.

C++
NResult N_API NCallbackCreateRaw(void * pProc, void * pParam, HNCallback * phCallback);
Collapse Expand Parameters
Parameters | Description
void * pProc | [in/out] Pointer to the process.
void * pParam | [in/out] Pointer to the callback parameters.
HNCallback * phCallback | [out] Pointer to a handle to the callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Notes

Raw functions (i.e. NCallbackCreateRaw) represent the functions themselves.

Non-raw functions (i.e. NCallbackCreate) represent macros that call those functions for the convenience of using them in C++.

Container

File: NCallback.h

Module: NCallback Unit


NCallbackCreateWithObjectRaw Function

NCallbackCreateWithObjectRaw Function
NCallback.h

Creates a callback for the specified process.

C++
NResult N_API NCallbackCreateWithObjectRaw(void * pProc, HNObject hObject, HNCallback * phCallback);
Collapse Expand Parameters
Parameters | Description
void * pProc | [in/out] Pointer to the process.
HNObject hObject | [in/out] Handle to the object containing callback parameters.
HNCallback * phCallback | [out] Pointer to a handle to the callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Notes

Raw functions (i.e. NCallbackCreateRaw) represent the functions themselves.

Non-raw functions (i.e. NCallbackCreate) represent macros that call those functions for the convenience of using them in C++.

Container

File: NCallback.h

Module: NCallback Unit


NCallbackEquals Function

NCallbackEquals Function
NCallback.h

Checks whether the specified callback equals the other specified callback.

C++
NResult N_API NCallbackEquals(HNCallback hCallback, HNCallback hOtherCallback, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNCallback hCallback | [in] Handle to the first callback.
HNCallback hOtherCallback | [in] Handle to the second callback.
NBool * pResult | [out] Pointer to NTrue if the callbacks are equal, else pointer to NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCallback.h

Module: NCallback Unit


NCallbackFree Function

NCallbackFree Function
NCallback.h

Frees the specified callback.

C++
NResult N_API NCallbackFree(HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNCallback hCallback | [in] Handle to the callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCallback.h

Module: NCallback Unit


NCallbackGetHashCode Function

NCallbackGetHashCode Function
NCallback.h

Retrieves the hash code of the specified callback.

C++
NResult N_API NCallbackGetHashCode(HNCallback hCallback, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNCallback hCallback | [in] Handle to the callback.
NInt * pValue | [out] Pointer to the hash code of the callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCallback.h

Module: NCallback Unit


NCallbackGetParam Function

NCallbackGetParam Function
NCallback.h

Retrieves the parameters of the specified callback.

C++
void * N_API_PTR_RET NCallbackGetParam(HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNCallback hCallback | [in] Handle to the callback.
Collapse Expand Returns

An array containing the parameters of the callback.

Container

File: NCallback.h

Module: NCallback Unit


NCallbackGetProcRaw Function

NCallbackGetProcRaw Function
NCallback.h

Retrieves the process that invokes the specified callback.

C++
void * N_API_PTR_RET NCallbackGetProcRaw(HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNCallback hCallback | [in] Handle to the callback.
Collapse Expand Returns

The process that invokes the callback.

Collapse Expand Notes

Raw functions (i.e. NCallbackCreateRaw) represent the functions themselves.

Non-raw functions (i.e. NCallbackCreate) represent macros that call those functions for the convenience of using them in C++.

Container

File: NCallback.h

Module: NCallback Unit


NCallbackSet Function

NCallbackSet Function
NCallback.h

Sets the value of the specified variable to the value of the specified callback.

C++
NResult N_API NCallbackSet(HNCallback hValue, HNCallback * phVariable);
Collapse Expand Parameters
Parameters | Description
HNCallback hValue | [in] Handle to the callback.
HNCallback * phVariable | [out] Pointer to a handle to a variable that will hold the callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCallback.h

Module: NCallback Unit


NCallbackCreate Macro

NCallbackCreate Macro
NCallback.h

Creates a callback for the specified process.

C++
#define NCallbackCreate(pProc, pParam, phCallback) NCallbackCreateRaw((void *)(NSizeType)pProc, pParam, phCallback)
Collapse Expand Parameters
Parameters | Description
pProc | [in/out] Pointer to the process.
pParam | [in/out] Pointer to the callback parameters.
phCallback | [out] Pointer to a handle to the callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Notes

Raw functions (i.e. NCallbackCreateRaw) represent the functions themselves.

Non-raw functions (i.e. NCallbackCreate) represent macros that call those functions for the convenience of using them in C++.

Container

File: NCallback.h

Module: NCallback Unit


NCallbackCreateCustom Macro

NCallbackCreateCustom Macro
NCallback.h

Creates a callback for the specified process with additional parameters.

C++
#define NCallbackCreateCustom(pProc, pParam, pFree, pGetHashCode, pEquals, phCallback) NCallbackCreateCustomRaw((void *)(NSizeType)pProc, pParam, pFree, pGetHashCode, pEquals, phCallback)
Collapse Expand Parameters
Parameters | Description
pProc | [in/out] Pointer to the process.
pParam | [in/out] Pointer to the callback parameters.
pFree | [in] Pointer to the process that frees the callback.
pGetHashCode | [in] Pointer to the process that retrieves the hash code of the callback.
pEquals | [in] Pointer to the process that retrieves the compares two callbacks.
phCallback | [out] Pointer to a handle to the callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Notes

Raw functions (i.e. NCallbackCreateRaw) represent the functions themselves.

Non-raw functions (i.e. NCallbackCreate) represent macros that call those functions for the convenience of using them in C++.

Container

File: NCallback.h

Module: NCallback Unit


NCallbackGetProc Macro

NCallbackGetProc Macro
NCallback.h

Retrieves the process that invokes the specified callback.

C++
#define NCallbackGetProc(callbackType, hCallback) ((callbackType)(NSizeType)NCallbackGetProcRaw(hCallback))
Collapse Expand Parameters
Parameters | Description
hCallback | [in] Handle to the callback.
Collapse Expand Returns

The process that invokes the callback.

Container

File: NCallback.h

Module: NCallback Unit


NCallbackInvoke0 Macro

NCallbackInvoke0 Macro
NCallback.h

Invokes the specified callback.

C++
#define NCallbackInvoke0(callbackType, hCallback) NCallbackInvokeRaw(callbackType, hCallback, (NCallbackGetParam(hCallback)))
Collapse Expand Parameters
Parameters | Description
callbackType | [in] The type of the callback.
hCallback | [in] Handle to the callback.
Collapse Expand Returns

The process that invokes the callback.

Container

File: NCallback.h

Module: NCallback Unit


NCallbackInvoke1 Macro

NCallbackInvoke1 Macro
NCallback.h

Invokes the specified callback with specified arguments.

C++
#define NCallbackInvoke1(callbackType, hCallback, arg1) NCallbackInvokeRaw(callbackType, hCallback, ((arg1), NCallbackGetParam(hCallback)))
Collapse Expand Parameters
Parameters | Description
callbackType | [in] The type of the callback.
hCallback | [in] Handle to the callback.
arg1 | [in] Callback argument.
Collapse Expand Returns

The process that invokes the callback.

Container

File: NCallback.h

Module: NCallback Unit


NCallbackInvoke2 Macro

NCallbackInvoke2 Macro
NCallback.h

Invokes the specified callback with specified arguments.

C++
#define NCallbackInvoke2(callbackType, hCallback, arg1, arg2) NCallbackInvokeRaw(callbackType, hCallback, ((arg1), (arg2), NCallbackGetParam(hCallback)))
Collapse Expand Parameters
Parameters | Description
callbackType | [in] The type of the callback.
hCallback | [in] Handle to the callback.
arg1 | [in] Callback argument.
arg2 | [in] Callback argument.
Collapse Expand Returns

The process that invokes the callback.

Container

File: NCallback.h

Module: NCallback Unit


NCallbackInvoke3 Macro

NCallbackInvoke3 Macro
NCallback.h

Invokes the specified callback with specified arguments.

C++
#define NCallbackInvoke3(callbackType, hCallback, arg1, arg2, arg3) NCallbackInvokeRaw(callbackType, hCallback, ((arg1), (arg2), (arg3), NCallbackGetParam(hCallback)))
Collapse Expand Parameters
Parameters | Description
callbackType | [in] The type of the callback.
hCallback | [in] Handle to the callback.
arg1 | [in] Callback argument.
arg2 | [in] Callback argument.
arg3 | [in] Callback argument.
Collapse Expand Returns

The process that invokes the callback.

Container

File: NCallback.h

Module: NCallback Unit


NCallbackInvoke4 Macro

NCallbackInvoke4 Macro
NCallback.h

Invokes the specified callback with specified arguments.

C++
#define NCallbackInvoke4(callbackType, hCallback, arg1, arg2, arg3, arg4) NCallbackInvokeRaw(callbackType, hCallback, ((arg1), (arg2), (arg3), (arg4), NCallbackGetParam(hCallback)))
Collapse Expand Parameters
Parameters | Description
callbackType | [in] The type of the callback.
hCallback | [in] Handle to the callback.
arg1 | [in] Callback argument.
arg2 | [in] Callback argument.
arg3 | [in] Callback argument.
arg4 | [in] Callback argument.
Collapse Expand Returns

The process that invokes the callback.

Container

File: NCallback.h

Module: NCallback Unit


NCallbackInvoke5 Macro

NCallbackInvoke5 Macro
NCallback.h

Invokes the specified callback with specified arguments.

C++
#define NCallbackInvoke5(callbackType, hCallback, arg1, arg2, arg3, arg4, arg5) NCallbackInvokeRaw(callbackType, hCallback, ((arg1), (arg2), (arg3), (arg4), (arg5), NCallbackGetParam(hCallback)))
Collapse Expand Parameters
Parameters | Description
callbackType | [in] The type of the callback.
hCallback | [in] Handle to the callback.
arg1 | [in] Callback argument.
arg2 | [in] Callback argument.
arg3 | [in] Callback argument.
arg4 | [in] Callback argument.
arg5 | [in] Callback argument.
Collapse Expand Returns

The process that invokes the callback.

Container

File: NCallback.h

Module: NCallback Unit


NCallbackInvoke6 Macro

NCallbackInvoke6 Macro
NCallback.h

Invokes the specified callback with specified arguments.

C++
#define NCallbackInvoke6(callbackType, hCallback, arg1, arg2, arg3, arg4, arg5, arg6) NCallbackInvokeRaw(callbackType, hCallback, ((arg1), (arg2), (arg3), (arg4), (arg5), (arg6), NCallbackGetParam(hCallback)))
Collapse Expand Parameters
Parameters | Description
callbackType | [in] The type of the callback.
hCallback | [in] Handle to the callback.
arg1 | [in] Callback argument.
arg2 | [in] Callback argument.
arg3 | [in] Callback argument.
arg4 | [in] Callback argument.
arg5 | [in] Callback argument.
arg6 | [in] Callback argument.
Collapse Expand Returns

The process that invokes the callback.

Container

File: NCallback.h

Module: NCallback Unit


NCallbackInvoke7 Macro

NCallbackInvoke7 Macro
NCallback.h

Invokes the specified callback with specified arguments.

C++
#define NCallbackInvoke7(callbackType, hCallback, arg1, arg2, arg3, arg4, arg5, arg6, arg7) NCallbackInvokeRaw(callbackType, hCallback, ((arg1), (arg2), (arg3), (arg4), (arg5), (arg6), (arg7), NCallbackGetParam(hCallback)))
Collapse Expand Parameters
Parameters | Description
callbackType | [in] The type of the callback.
hCallback | [in] Handle to the callback.
arg1 | [in] Callback argument.
arg2 | [in] Callback argument.
arg3 | [in] Callback argument.
arg4 | [in] Callback argument.
arg5 | [in] Callback argument.
arg6 | [in] Callback argument.
arg7 | [in] Callback argument.
Collapse Expand Returns

The process that invokes the callback.

Container

File: NCallback.h

Module: NCallback Unit


NCallbackInvoke8 Macro

NCallbackInvoke8 Macro
NCallback.h

Invokes the specified callback with specified arguments.

C++
#define NCallbackInvoke8(callbackType, hCallback, arg1, arg2, arg3, arg4, arg5, arg6, arg7, arg8) NCallbackInvokeRaw(callbackType, hCallback, ((arg1), (arg2), (arg3), (arg4), (arg5), (arg6), (arg7), (arg8), NCallbackGetParam(hCallback)))
Collapse Expand Parameters
Parameters | Description
callbackType | [in] The type of the callback.
hCallback | [in] Handle to the callback.
arg1 | [in] Callback argument.
arg2 | [in] Callback argument.
arg3 | [in] Callback argument.
arg4 | [in] Callback argument.
arg5 | [in] Callback argument.
arg6 | [in] Callback argument.
arg7 | [in] Callback argument.
arg8 | [in] Callback argument.
Collapse Expand Returns

The process that invokes the callback.

Container

File: NCallback.h

Module: NCallback Unit


NCallbackInvoke9 Macro

NCallbackInvoke9 Macro
NCallback.h

Invokes the specified callback with specified arguments.

C++
#define NCallbackInvoke9(callbackType, hCallback, arg1, arg2, arg3, arg4, arg5, arg6, arg7, arg8, arg9) NCallbackInvokeRaw(callbackType, hCallback, ((arg1), (arg2), (arg3), (arg4), (arg5), (arg6), (arg7), (arg8), (arg9), NCallbackGetParam(hCallback)))
Collapse Expand Parameters
Parameters | Description
callbackType | [in] The type of the callback.
hCallback | [in] Handle to the callback.
arg1 | [in] Callback argument.
arg2 | [in] Callback argument.
arg3 | [in] Callback argument.
arg4 | [in] Callback argument.
arg5 | [in] Callback argument.
arg6 | [in] Callback argument.
arg7 | [in] Callback argument.
arg8 | [in] Callback argument.
arg9 | [in] Callback argument.
Collapse Expand Returns

The process that invokes the callback.

Container

File: NCallback.h

Module: NCallback Unit


NCallbackInvokeRaw Macro

NCallbackInvokeRaw Macro
NCallback.h

Invokes the specified callback with specified arguments.

C++
#define NCallbackInvokeRaw(callbackType, hCallback, args) (NCallbackGetProc(callbackType, hCallback)args)
Collapse Expand Parameters
Parameters | Description
callbackType | [in] The type of the callback.
hCallback | [in] Handle to the callback.
args | [in] Callback arguments.
Collapse Expand Returns

The process that invokes the callback.

Collapse Expand Notes

Raw functions (i.e. NCallbackCreateRaw) represent the functions themselves.

Non-raw functions (i.e. NCallbackCreate) represent macros that call those functions for the convenience of using them in C++.

Container

File: NCallback.h

Module: NCallback Unit


NCallback.h

NCallback.h
Functions Legend Macros

Header file for the NCallback unit.

Collapse Expand Functions
Name | Description
NCallbackClone | Creates a copy of the specified callback.
NCallbackCreateCustomRaw | Creates a callback for the specified process with additional parameters.
NCallbackCreateRaw | Creates a callback for the specified process.
NCallbackCreateWithObjectRaw | Creates a callback for the specified process.
NCallbackEquals | Checks whether the specified callback equals the other specified callback.
NCallbackFree | Frees the specified callback.
NCallbackGetHashCode | Retrieves the hash code of the specified callback.
NCallbackGetParam | Retrieves the parameters of the specified callback.
NCallbackGetProcRaw | Retrieves the process that invokes the specified callback.
NCallbackSet | Sets the value of the specified variable to the value of the specified callback.
Collapse Expand Macros
Name | Description
NCallbackCreate | Creates a callback for the specified process.
NCallbackCreateCustom | Creates a callback for the specified process with additional parameters.
NCallbackGetProc | Retrieves the process that invokes the specified callback.
NCallbackInvoke0 | Invokes the specified callback.
NCallbackInvoke1 | Invokes the specified callback with specified arguments.
NCallbackInvoke2 | Invokes the specified callback with specified arguments.
NCallbackInvoke3 | Invokes the specified callback with specified arguments.
NCallbackInvoke4 | Invokes the specified callback with specified arguments.
NCallbackInvoke5 | Invokes the specified callback with specified arguments.
NCallbackInvoke6 | Invokes the specified callback with specified arguments.
NCallbackInvoke7 | Invokes the specified callback with specified arguments.
NCallbackInvoke8 | Invokes the specified callback with specified arguments.
NCallbackInvoke9 | Invokes the specified callback with specified arguments.
NCallbackInvokeRaw | Invokes the specified callback with specified arguments.


NCollection Unit

NCollection Unit
Files Functions Legend Structs, Records, Enums

Provides functionality for working with collections.

Collapse Expand Files
Name | Description
NCollection.h | Header file for the NCollection module.
Collapse Expand Functions
Name | Description
NCollectionAdd | Adds the specified value to the specified collection.
NCollectionAddCollectionChanged | Adds a user-specified "collection changed" event to the specified collection.
NCollectionAddCollectionChangedCallback | Adds a user-specified "collection changed" event callback to the specified collection.
NCollectionAddItemCollectionChanged | Adds a user-specified "item collection changed" event to the specified collection.
NCollectionAddItemCollectionChangedCallback | Adds a user-specified "item collection changed" event callback to the specified collection.
NCollectionAddItemRange | Adds an array of values to the specified collection.
NCollectionAddRange | Adds an array of values to the specified collection.
NCollectionClear | Clears the specified collection.
NCollectionContains | Checks whether the specified collection contains the specified value.
NCollectionGet | Retrieves the item specified by index from the specified collection.
NCollectionGetCapacity | Retrieves the capacity of the collection.
NCollectionGetCount | Retrieves the number of items in the collection.
NCollectionIndexOf | Retrieves the index of the specified value in the specified collection.
NCollectionInsert | Adds the specified value to the specified collection at the specified index.
NCollectionInsertItemRange | Adds an array of values to the specified collection at the specified index.
NCollectionInsertRange | Adds an array of values to the specified collection at the specified index.
NCollectionIsReadOnly | Checks whether the specified collection is read-only.
NCollectionRemove | Removes the specified value from the specified collection.
NCollectionRemoveAt | Removes the specified value from the specified collection.
NCollectionRemoveCollectionChanged | Removes a user-specified "collection changed" event from the specified collection.
NCollectionRemoveCollectionChangedCallback | Removes a user-specified "collection changed" event callback from the specified collection.
NCollectionRemoveItemCollectionChanged | Removes a user-specified "item collection changed" event from the specified collection.
NCollectionRemoveItemCollectionChangedCallback | Removes a user-specified "item collection changed" event callback from the specified collection.
NCollectionRemoveRange | Removes a range of values from the specified collection.
NCollectionSet | Sets the specified value in the specified collection.
NCollectionSetCapacity | Sets the capacity of the collection.
NCollectionToArray | Converts the specified collection to an array.
NCollectionToItemArray | Converts the specified collection to an item array.
N_DECLARE_TYPE | Declares type with specified name.
Collapse Expand Structs, Records, Enums
Name | Description
NCollectionChangedAction_ | Enumerates collection-changing actions.
NCollectionChangedAction | Enumerates collection-changing actions.


NCollectionAdd Function

NCollectionAdd Function
NCollection.h

Adds the specified value to the specified collection.

C++
NResult N_API NCollectionAdd(HNCollection hCollection, HNType hValueType, NAttributes attributes, const void * pValue, NSizeType valueSize, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
HNCollection hCollection | [in] Handle to the collection.
HNType hValueType | [in] Handle to the type of the value.
NAttributes attributes | [in] Value attributes.
const void * pValue | [in] Pointer to the value.
NSizeType valueSize | [in] Size of the value.
NInt * pIndex | [out] Pointer to the index of the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollection.h

Module: NCollection Unit


NCollectionAddCollectionChanged Function

NCollectionAddCollectionChanged Function
NCollection.h

Adds a user-specified "collection changed" event to the specified collection.

C++
NResult N_API NCollectionAddCollectionChanged(HNCollection hCollection, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNCollection hCollection | [in] Handle to the collection.
HNCallback hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollection.h

Module: NCollection Unit


NCollectionAddCollectionChangedCallback Function

NCollectionAddCollectionChangedCallback Function
NCollection.h

Adds a user-specified "collection changed" event callback to the specified collection.

C++
NResult N_API NCollectionAddCollectionChangedCallback(HNCollection hCollection, NCollectionCollectionChangedCallback pCallback, void * pParam);
Collapse Expand Parameters
Parameters | Description
HNCollection hCollection | [in] Handle to the collection.
NCollectionCollectionChangedCallback pCallback | [in] The event callback.
void * pParam | [out] Parameters provided to the callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollection.h

Module: NCollection Unit


NCollectionAddItemCollectionChanged Function

NCollectionAddItemCollectionChanged Function
NCollection.h

Adds a user-specified "item collection changed" event to the specified collection.

C++
NResult N_API NCollectionAddItemCollectionChanged(HNCollection hCollection, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNCollection hCollection | [in] Handle to the collection.
HNCallback hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollection.h

Module: NCollection Unit


NCollectionAddItemCollectionChangedCallback Function

NCollectionAddItemCollectionChangedCallback Function
NCollection.h

Adds a user-specified "item collection changed" event callback to the specified collection.

C++
NResult N_API NCollectionAddItemCollectionChangedCallback(HNCollection hCollection, NCollectionItemCollectionChangedCallback pCallback, void * pParam);
Collapse Expand Parameters
Parameters | Description
HNCollection hCollection | [in] Handle to the collection.
NCollectionItemCollectionChangedCallback pCallback | [in] The event callback.
void * pParam | [out] Parameters provided to the callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollection.h

Module: NCollection Unit


NCollectionAddItemRange Function

NCollectionAddItemRange Function
NCollection.h

Adds an array of values to the specified collection.

C++
NResult N_API NCollectionAddItemRange(HNCollection hCollection, HNArray hValues, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
HNCollection hCollection | [in] Handle to the collection.
HNArray hValues | [in] Handle to an array of values.
NInt * pIndex | [out] Pointer to the index of the first element.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollection.h

Module: NCollection Unit


NCollectionAddRange Function

NCollectionAddRange Function
NCollection.h

Adds an array of values to the specified collection.

C++
NResult N_API NCollectionAddRange(HNCollection hCollection, HNType hValueType, NAttributes attributes, const void * arValues, NSizeType valuesSize, NInt valueCount, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
HNCollection hCollection | [in] Handle to the collection.
HNType hValueType | [in] Handle to the type of values.
NAttributes attributes | [in] Value attributes.
const void * arValues | [in] Pointer to an array of values.
NSizeType valuesSize | [in] Size of a single value in the array.
NInt valueCount | [in] Number of values in the array.
NInt * pIndex | [out] Pointer to the index of the first element.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollection.h

Module: NCollection Unit


NCollectionClear Function

NCollectionClear Function
NCollection.h

Clears the specified collection.

C++
NResult N_API NCollectionClear(HNCollection hCollection);
Collapse Expand Parameters
Parameters | Description
HNCollection hCollection | [in] Handle to the collection to clear.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollection.h

Module: NCollection Unit


NCollectionContains Function

NCollectionContains Function
NCollection.h

Checks whether the specified collection contains the specified value.

C++
NResult N_API NCollectionContains(HNCollection hCollection, HNType hValueType, NAttributes attributes, const void * pValue, NSizeType valueSize, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNCollection hCollection | [in] Handle to the collection.
HNType hValueType | [in] Handle to the type of the value.
NAttributes attributes | [in] Value attributes.
const void * pValue | [in] Pointer to the value to check.
NSizeType valueSize | [in] Size of the value.
NBool * pResult | [out] NTrue if the collection contains the value; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollection.h

Module: NCollection Unit


NCollectionGet Function

NCollectionGet Function
NCollection.h

Retrieves the item specified by index from the specified collection.

C++
NResult N_API NCollectionGet(HNCollection hCollection, NInt index, HNType hValueType, NAttributes attributes, void * pValue, NSizeType valueSize);
Collapse Expand Parameters
Parameters | Description
HNCollection hCollection | [in] Handle to the collection.
NInt index | [in] Index of the item.
HNType hValueType | [in] Handle to the type of the item value.
NAttributes attributes | [in] Value attributes.
void * pValue | [out] Pointer to the item value.
NSizeType valueSize | [in] Size of the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollection.h

Module: NCollection Unit


NCollectionGetCapacity Function

NCollectionGetCapacity Function
NCollection.h

Retrieves the capacity of the collection.

C++
NResult N_API NCollectionGetCapacity(HNCollection hCollection, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNCollection hCollection | [in] Handle to the collection.
NInt * pValue | [out] Pointer to the capacity of the collection.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollection.h

Module: NCollection Unit


NCollectionGetCount Function

NCollectionGetCount Function
NCollection.h

Retrieves the number of items in the collection.

C++
NResult N_API NCollectionGetCount(HNCollection hCollection, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNCollection hCollection | [in] Handle to the collection.
NInt * pValue | [out] Pointer to the number of items in the collection.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollection.h

Module: NCollection Unit


NCollectionIndexOf Function

NCollectionIndexOf Function
NCollection.h

Retrieves the index of the specified value in the specified collection.

C++
NResult N_API NCollectionIndexOf(HNCollection hCollection, HNType hValueType, NAttributes attributes, const void * pValue, NSizeType valueSize, NInt * pResult);
Collapse Expand Parameters
Parameters | Description
HNCollection hCollection | [in] Handle to the collection.
HNType hValueType | [in] Handle to the type of the value.
NAttributes attributes | [in] Value attributes.
const void * pValue | [in] Pointer to the value.
NSizeType valueSize | [in] Size of the value.
NInt * pResult | [out] Pointer to the index of the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollection.h

Module: NCollection Unit


NCollectionInsert Function

NCollectionInsert Function
NCollection.h

Adds the specified value to the specified collection at the specified index.

C++
NResult N_API NCollectionInsert(HNCollection hCollection, NInt index, HNType hValueType, NAttributes attributes, const void * pValue, NSizeType valueSize);
Collapse Expand Parameters
Parameters | Description
HNCollection hCollection | [in] Handle to the collection.
NInt index | [in] The index of the value.
HNType hValueType | [in] Handle to the type of the value.
NAttributes attributes | [in] Value attributes.
const void * pValue | [in] Pointer to the value.
NSizeType valueSize | [in] Size of the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollection.h

Module: NCollection Unit


NCollectionInsertItemRange Function

NCollectionInsertItemRange Function
NCollection.h

Adds an array of values to the specified collection at the specified index.

C++
NResult N_API NCollectionInsertItemRange(HNCollection hCollection, NInt index, HNArray hValues);
Collapse Expand Parameters
Parameters | Description
HNCollection hCollection | [in] Handle to the collection.
NInt index | [in] The index of the value.
HNArray hValues | [in] Handle to an array of values.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollection.h

Module: NCollection Unit


NCollectionInsertRange Function

NCollectionInsertRange Function
NCollection.h

Adds an array of values to the specified collection at the specified index.

C++
NResult N_API NCollectionInsertRange(HNCollection hCollection, NInt index, HNType hValueType, NAttributes attributes, const void * arValues, NSizeType valuesSize, NInt valueCount);
Collapse Expand Parameters
Parameters | Description
HNCollection hCollection | [in] Handle to the collection.
NInt index | [in] The index of the value.
HNType hValueType | [in] Handle to the type of values.
NAttributes attributes | [in] Value attributes.
const void * arValues | [in] Pointer to an array of values.
NSizeType valuesSize | [in] Size of a single value in the array.
NInt valueCount | [in] Number of values in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollection.h

Module: NCollection Unit


NCollectionIsReadOnly Function

NCollectionIsReadOnly Function
NCollection.h

Checks whether the specified collection is read-only.

C++
NResult N_API NCollectionIsReadOnly(HNCollection hCollection, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNCollection hCollection | [in] Handle to the collection.
NBool * pValue | [out] NTrue if the collection is read-only; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollection.h

Module: NCollection Unit


NCollectionRemove Function

NCollectionRemove Function
NCollection.h

Removes the specified value from the specified collection.

C++
NResult N_API NCollectionRemove(HNCollection hCollection, HNType hValueType, NAttributes attributes, const void * pValue, NSizeType valueSize, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
HNCollection hCollection | [in] Handle to the collection.
HNType hValueType | [in] Handle to the type of the value.
NAttributes attributes | [in] Value attributes.
const void * pValue | [in] Pointer to the value to remove.
NSizeType valueSize | [in] Size of the value.
NInt * pIndex | [out] Pointer to the index freed by the removed value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollection.h

Module: NCollection Unit


NCollectionRemoveAt Function

NCollectionRemoveAt Function
NCollection.h

Removes the specified value from the specified collection.

C++
NResult N_API NCollectionRemoveAt(HNCollection hCollection, NInt index);
Collapse Expand Parameters
Parameters | Description
HNCollection hCollection | [in] Handle to the collection.
NInt index | [in] Index of the value to be removed.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollection.h

Module: NCollection Unit


NCollectionRemoveCollectionChanged Function

NCollectionRemoveCollectionChanged Function
NCollection.h

Removes a user-specified "collection changed" event from the specified collection.

C++
NResult N_API NCollectionRemoveCollectionChanged(HNCollection hCollection, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNCollection hCollection | [in] Handle to the collection.
HNCallback hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollection.h

Module: NCollection Unit


NCollectionRemoveCollectionChangedCallback Function

NCollectionRemoveCollectionChangedCallback Function
NCollection.h

Removes a user-specified "collection changed" event callback from the specified collection.

C++
NResult N_API NCollectionRemoveCollectionChangedCallback(HNCollection hCollection, NCollectionCollectionChangedCallback pCallback, void * pParam);
Collapse Expand Parameters
Parameters | Description
HNCollection hCollection | [in] Handle to the collection.
NCollectionCollectionChangedCallback pCallback | [in] The event callback.
void * pParam | [out] Parameters provided to the callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollection.h

Module: NCollection Unit


NCollectionRemoveItemCollectionChanged Function

NCollectionRemoveItemCollectionChanged Function
NCollection.h

Removes a user-specified "item collection changed" event from the specified collection.

C++
NResult N_API NCollectionRemoveItemCollectionChanged(HNCollection hCollection, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNCollection hCollection | [in] Handle to the collection.
HNCallback hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollection.h

Module: NCollection Unit


NCollectionRemoveItemCollectionChangedCallback Function

NCollectionRemoveItemCollectionChangedCallback Function
NCollection.h

Removes a user-specified "item collection changed" event callback from the specified collection.

C++
NResult N_API NCollectionRemoveItemCollectionChangedCallback(HNCollection hCollection, NCollectionItemCollectionChangedCallback pCallback, void * pParam);
Collapse Expand Parameters
Parameters | Description
HNCollection hCollection | [in] Handle to the collection.
NCollectionItemCollectionChangedCallback pCallback | [in] The event callback.
void * pParam | [out] Parameters provided to the callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollection.h

Module: NCollection Unit


NCollectionRemoveRange Function

NCollectionRemoveRange Function
NCollection.h

Removes a range of values from the specified collection.

C++
NResult N_API NCollectionRemoveRange(HNCollection hCollection, NInt startIndex, NInt count);
Collapse Expand Parameters
Parameters | Description
HNCollection hCollection | [in] Handle to the collection.
NInt startIndex | [in] Index in the collection, at which removing starts.
NInt count | [in] Number of values to remove.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollection.h

Module: NCollection Unit


NCollectionSet Function

NCollectionSet Function
NCollection.h

Sets the specified value in the specified collection.

C++
NResult N_API NCollectionSet(HNCollection hCollection, NInt index, HNType hValueType, NAttributes attributes, const void * pValue, NSizeType valueSize);
Collapse Expand Parameters
Parameters | Description
HNCollection hCollection | [in] Handle to the collection.
NInt index | [in] Index of the value to set.
HNType hValueType | [in] Handle to the type of the value.
NAttributes attributes | [in] Value attributes.
const void * pValue | [in] Pointer to the new value.
NSizeType valueSize | [in] Size of the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollection.h

Module: NCollection Unit


NCollectionSetCapacity Function

NCollectionSetCapacity Function
NCollection.h

Sets the capacity of the collection.

C++
NResult N_API NCollectionSetCapacity(HNCollection hCollection, NInt value);
Collapse Expand Parameters
Parameters | Description
HNCollection hCollection | [in] Handle to the collection.
NInt value | [in] The capacity of the collection.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollection.h

Module: NCollection Unit


NCollectionToArray Function

NCollectionToArray Function
NCollection.h

Converts the specified collection to an array.

C++
NResult N_API NCollectionToArray(HNCollection hCollection, HNType hValueType, NAttributes attributes, NSizeType valueSize, void * * parValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNCollection hCollection | [in] Handle to the collection.
HNType hValueType | [in] Handle to the type of the values.
NAttributes attributes | [in] Value attributes.
NSizeType valueSize | [in] Size of a single value.
void * * parValues | [out] Pointer to the new array.
NInt * pValueCount | [out] Pointer to the number of values in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollection.h

Module: NCollection Unit


NCollectionToItemArray Function

NCollectionToItemArray Function
NCollection.h

Converts the specified collection to an item array.

C++
NResult N_API NCollectionToItemArray(HNCollection hCollection, HNArray * phValues);
Collapse Expand Parameters
Parameters | Description
HNCollection hCollection | [in] Handle to the collection.
HNArray * phValues | [out] Pointer to an array of items.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollection.h

Module: NCollection Unit


N_DECLARE_TYPE Function

N_DECLARE_TYPE Function
NCollection.h

Declares type with specified name.

C++
N_DECLARE_TYPE(NCollectionCollectionChangedCallback);
Container

File: NCollection.h

Module: NCollection Unit


NCollectionChangedAction Enumeration

NCollectionChangedAction Enumeration
NCollection.h

Enumerates collection-changing actions.

C++
typedef enum NCollectionChangedAction_ {
  nccaAdd = 0,
  nccaRemove = 1,
  nccaReplace = 2,
  nccaMove = 3,
  nccaReset = 4
} NCollectionChangedAction;
Collapse Expand Members
Members | Description
nccaAdd = 0 | Indicates that an item was added to a collection.
nccaRemove = 1 | Indicates that an item was removed from a collection.
nccaReplace = 2 | Indicates that an item was replaced in a collection.
nccaMove = 3 | Indicates that an item was moved in a collection.
nccaReset = 4 | Indicates that the collection was reset.
Container

File: NCollection.h

Module: NCollection Unit


NCollection.h

NCollection.h
Enumerations Functions Legend

Header file for the NCollection module.

Collapse Expand Enumerations
Name | Description
NCollectionChangedAction_ | Enumerates collection-changing actions.
NCollectionChangedAction | Enumerates collection-changing actions.
Collapse Expand Functions
Name | Description
NCollectionAdd | Adds the specified value to the specified collection.
NCollectionAddCollectionChanged | Adds a user-specified "collection changed" event to the specified collection.
NCollectionAddCollectionChangedCallback | Adds a user-specified "collection changed" event callback to the specified collection.
NCollectionAddItemCollectionChanged | Adds a user-specified "item collection changed" event to the specified collection.
NCollectionAddItemCollectionChangedCallback | Adds a user-specified "item collection changed" event callback to the specified collection.
NCollectionAddItemRange | Adds an array of values to the specified collection.
NCollectionAddRange | Adds an array of values to the specified collection.
NCollectionClear | Clears the specified collection.
NCollectionContains | Checks whether the specified collection contains the specified value.
NCollectionGet | Retrieves the item specified by index from the specified collection.
NCollectionGetCapacity | Retrieves the capacity of the collection.
NCollectionGetCount | Retrieves the number of items in the collection.
NCollectionIndexOf | Retrieves the index of the specified value in the specified collection.
NCollectionInsert | Adds the specified value to the specified collection at the specified index.
NCollectionInsertItemRange | Adds an array of values to the specified collection at the specified index.
NCollectionInsertRange | Adds an array of values to the specified collection at the specified index.
NCollectionIsReadOnly | Checks whether the specified collection is read-only.
NCollectionRemove | Removes the specified value from the specified collection.
NCollectionRemoveAt | Removes the specified value from the specified collection.
NCollectionRemoveCollectionChanged | Removes a user-specified "collection changed" event from the specified collection.
NCollectionRemoveCollectionChangedCallback | Removes a user-specified "collection changed" event callback from the specified collection.
NCollectionRemoveItemCollectionChanged | Removes a user-specified "item collection changed" event from the specified collection.
NCollectionRemoveItemCollectionChangedCallback | Removes a user-specified "item collection changed" event callback from the specified collection.
NCollectionRemoveRange | Removes a range of values from the specified collection.
NCollectionSet | Sets the specified value in the specified collection.
NCollectionSetCapacity | Sets the capacity of the collection.
NCollectionToArray | Converts the specified collection to an array.
NCollectionToItemArray | Converts the specified collection to an item array.
N_DECLARE_TYPE | Declares type with specified name.


NCollectionInfo Unit

NCollectionInfo Unit
Files Functions Legend

Provides functionality to retrieve information about collections.

Collapse Expand Files
Name | Description
NCollectionInfo.h | Header file for the NCollectionInfo unit.
Collapse Expand Functions
Name | Description
NCollectionInfoGetAddCollectionChangedCallbackMethod | Retrieves the method which adds a "collection changed" event callback to a collection.
NCollectionInfoGetAddCollectionChangedMethod | Retrieves the method which adds a "collection changed" event to a collection.
NCollectionInfoGetAddMethod | Retrieves the method which adds an item to a collection.
NCollectionInfoGetAddRangeMethod | Retrieves the method which adds a range of items to a collection.
NCollectionInfoGetClearMethod | Retrieves the method which clears the collection.
NCollectionInfoGetGetCapacityMethod | Retrieves the method which gets the maximum number of items in the collection.
NCollectionInfoGetGetCountMethod | Retrieves the method which gets the number of items in the collection.
NCollectionInfoGetGetMethod | Retrieves the method which gets an item in the collection.
NCollectionInfoGetIndexOfMethod | Retrieves the method which gets an index of an item in the collection.
NCollectionInfoGetInsertMethod | Retrieves the method which adds an item to the collection at a specific index.
NCollectionInfoGetInsertRangeMethod | Retrieves the method which adds a range of items to the collection at a specific index.
NCollectionInfoGetItemAttributes | Retrieves the attributes of the items in the collection.
NCollectionInfoGetItemFormat | Retrieves the format of the items in the collection.
NCollectionInfoGetItemMaxValue | Retrieves the maximal item value of the collection.
NCollectionInfoGetItemMinValue | Retrieves the minimal item value of the collection.
NCollectionInfoGetItemStdValue | Retrieves the specified standard value of the collection.
NCollectionInfoGetItemStdValueCount | Retrieves the number of standard item values of the collection.
NCollectionInfoGetItemStdValues | Retrieves all standard item values of the collection.
NCollectionInfoGetItemType | Retrieves the type of the items in the collection.
NCollectionInfoGetRemoveAtMethod | Retrieves the method which removes an item with specific index from the collection.
NCollectionInfoGetRemoveCollectionChangedCallbackMethod | Retrieves the method which removes a "collection changed" event callback from a collection.
NCollectionInfoGetRemoveCollectionChangedMethod | Retrieves the method which removes a "collection changed" event from a collection.
NCollectionInfoGetRemoveMethod | Retrieves the method which removes an item from the collection.
NCollectionInfoGetRemoveRangeMethod | Retrieves the method which removes a range of items from the collection.
NCollectionInfoGetSetCapacityMethod | Retrieves the method which sets the maximum number of items in the collection.
NCollectionInfoGetSetMethod | Retrieves the method which sets a value of an item in the collection.
NCollectionInfoGetToArrayMethod | Retrieves the method which converts the collection into an array.


NCollectionInfoGetAddCollectionChangedCallbackMethod Function

NCollectionInfoGetAddCollectionChangedCallbackMethod Function
NCollectionInfo.h

Retrieves the method which adds a "collection changed" event callback to a collection.

C++
NResult N_API NCollectionInfoGetAddCollectionChangedCallbackMethod(HNCollectionInfo hCollectionInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNCollectionInfo hCollectionInfo | [in] Handle to the collection information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollectionInfo.h

Module: NCollectionInfo Unit


NCollectionInfoGetAddCollectionChangedMethod Function

NCollectionInfoGetAddCollectionChangedMethod Function
NCollectionInfo.h

Retrieves the method which adds a "collection changed" event to a collection.

C++
NResult N_API NCollectionInfoGetAddCollectionChangedMethod(HNCollectionInfo hCollectionInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNCollectionInfo hCollectionInfo | [in] Handle to the collection information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollectionInfo.h

Module: NCollectionInfo Unit


NCollectionInfoGetAddMethod Function

NCollectionInfoGetAddMethod Function
NCollectionInfo.h

Retrieves the method which adds an item to a collection.

C++
NResult N_API NCollectionInfoGetAddMethod(HNCollectionInfo hCollectionInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNCollectionInfo hCollectionInfo | [in] Handle to the collection information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollectionInfo.h

Module: NCollectionInfo Unit


NCollectionInfoGetAddRangeMethod Function

NCollectionInfoGetAddRangeMethod Function
NCollectionInfo.h

Retrieves the method which adds a range of items to a collection.

C++
NResult N_API NCollectionInfoGetAddRangeMethod(HNCollectionInfo hCollectionInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNCollectionInfo hCollectionInfo | [in] Handle to the collection information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollectionInfo.h

Module: NCollectionInfo Unit


NCollectionInfoGetClearMethod Function

NCollectionInfoGetClearMethod Function
NCollectionInfo.h

Retrieves the method which clears the collection.

C++
NResult N_API NCollectionInfoGetClearMethod(HNCollectionInfo hCollectionInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNCollectionInfo hCollectionInfo | [in] Handle to the collection information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollectionInfo.h

Module: NCollectionInfo Unit


NCollectionInfoGetGetCapacityMethod Function

NCollectionInfoGetGetCapacityMethod Function
NCollectionInfo.h

Retrieves the method which gets the maximum number of items in the collection.

C++
NResult N_API NCollectionInfoGetGetCapacityMethod(HNCollectionInfo hCollectionInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNCollectionInfo hCollectionInfo | [in] Handle to the collection information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollectionInfo.h

Module: NCollectionInfo Unit


NCollectionInfoGetGetCountMethod Function

NCollectionInfoGetGetCountMethod Function
NCollectionInfo.h

Retrieves the method which gets the number of items in the collection.

C++
NResult N_API NCollectionInfoGetGetCountMethod(HNCollectionInfo hCollectionInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNCollectionInfo hCollectionInfo | [in] Handle to the collection information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollectionInfo.h

Module: NCollectionInfo Unit


NCollectionInfoGetGetMethod Function

NCollectionInfoGetGetMethod Function
NCollectionInfo.h

Retrieves the method which gets an item in the collection.

C++
NResult N_API NCollectionInfoGetGetMethod(HNCollectionInfo hCollectionInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNCollectionInfo hCollectionInfo | [in] Handle to the collection information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollectionInfo.h

Module: NCollectionInfo Unit


NCollectionInfoGetIndexOfMethod Function

NCollectionInfoGetIndexOfMethod Function
NCollectionInfo.h

Retrieves the method which gets an index of an item in the collection.

C++
NResult N_API NCollectionInfoGetIndexOfMethod(HNCollectionInfo hCollectionInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNCollectionInfo hCollectionInfo | [in] Handle to the collection information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollectionInfo.h

Module: NCollectionInfo Unit


NCollectionInfoGetInsertMethod Function

NCollectionInfoGetInsertMethod Function
NCollectionInfo.h

Retrieves the method which adds an item to the collection at a specific index.

C++
NResult N_API NCollectionInfoGetInsertMethod(HNCollectionInfo hCollectionInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNCollectionInfo hCollectionInfo | [in] Handle to the collection information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollectionInfo.h

Module: NCollectionInfo Unit


NCollectionInfoGetInsertRangeMethod Function

NCollectionInfoGetInsertRangeMethod Function
NCollectionInfo.h

Retrieves the method which adds a range of items to the collection at a specific index.

C++
NResult N_API NCollectionInfoGetInsertRangeMethod(HNCollectionInfo hCollectionInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNCollectionInfo hCollectionInfo | [in] Handle to the collection information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollectionInfo.h

Module: NCollectionInfo Unit


NCollectionInfoGetItemAttributes Function

NCollectionInfoGetItemAttributes Function
NCollectionInfo.h

Retrieves the attributes of the items in the collection.

C++
NResult N_API NCollectionInfoGetItemAttributes(HNCollectionInfo hCollectionInfo, NAttributes * pValue);
Collapse Expand Parameters
Parameters | Description
HNCollectionInfo hCollectionInfo | [in] Handle to the collection information.
NAttributes * pValue | [out] Pointer to the attributes of the items.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollectionInfo.h

Module: NCollectionInfo Unit


NCollectionInfoGetItemFormat Function

NCollectionInfoGetItemFormat Function
NCollectionInfo.h

Retrieves the format of the items in the collection.

C++
NResult N_API NCollectionInfoGetItemFormat(HNCollectionInfo hCollectionInfo, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNCollectionInfo hCollectionInfo | [in] Handle to the collection information.
HNString * phValue | [out] Pointer to the format of the items.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollectionInfo.h

Module: NCollectionInfo Unit


NCollectionInfoGetItemMaxValue Function

NCollectionInfoGetItemMaxValue Function
NCollectionInfo.h

Retrieves the maximal item value of the collection.

C++
NResult N_API NCollectionInfoGetItemMaxValue(HNCollectionInfo hCollectionInfo, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
HNCollectionInfo hCollectionInfo | [in] Handle to the collection information.
HNValue * phValue | [out] Pointer to the maximal item value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollectionInfo.h

Module: NCollectionInfo Unit


NCollectionInfoGetItemMinValue Function

NCollectionInfoGetItemMinValue Function
NCollectionInfo.h

Retrieves the minimal item value of the collection.

C++
NResult N_API NCollectionInfoGetItemMinValue(HNCollectionInfo hCollectionInfo, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
HNCollectionInfo hCollectionInfo | [in] Handle to the collection information.
HNValue * phValue | [out] Pointer to the minimal item value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollectionInfo.h

Module: NCollectionInfo Unit


NCollectionInfoGetItemStdValue Function

NCollectionInfoGetItemStdValue Function
NCollectionInfo.h

Retrieves the specified standard value of the collection.

C++
NResult N_API NCollectionInfoGetItemStdValue(HNCollectionInfo hCollectionInfo, NInt index, struct NNameValuePair_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNCollectionInfo hCollectionInfo | [in] Handle to the collection information.
NInt index | [in] Index of the standard value.
struct NNameValuePair_ * pValue | [out] Pointer to the standard value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollectionInfo.h

Module: NCollectionInfo Unit


NCollectionInfoGetItemStdValueCount Function

NCollectionInfoGetItemStdValueCount Function
NCollectionInfo.h

Retrieves the number of standard item values of the collection.

C++
NResult N_API NCollectionInfoGetItemStdValueCount(HNCollectionInfo hCollectionInfo, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNCollectionInfo hCollectionInfo | [in] Handle to the collection information.
NInt * pValue | [out] Pointer to the number of standard values.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollectionInfo.h

Module: NCollectionInfo Unit


NCollectionInfoGetItemStdValues Function

NCollectionInfoGetItemStdValues Function
NCollectionInfo.h

Retrieves all standard item values of the collection.

C++
NResult N_API NCollectionInfoGetItemStdValues(HNCollectionInfo hCollectionInfo, struct NNameValuePair_ * * parValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNCollectionInfo hCollectionInfo | [in] Handle to the collection information.
struct NNameValuePair_ * * parValues | [out] Pointer to the array of standard values.
NInt * pValueCount | [out] Pointer to the number of standard values in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollectionInfo.h

Module: NCollectionInfo Unit


NCollectionInfoGetItemType Function

NCollectionInfoGetItemType Function
NCollectionInfo.h

Retrieves the type of the items in the collection.

C++
NResult N_API NCollectionInfoGetItemType(HNCollectionInfo hCollectionInfo, HNType * phValue);
Collapse Expand Parameters
Parameters | Description
HNCollectionInfo hCollectionInfo | [in] Handle to the collection information.
HNType * phValue | [out] Pointer to the type of the items.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollectionInfo.h

Module: NCollectionInfo Unit


NCollectionInfoGetRemoveAtMethod Function

NCollectionInfoGetRemoveAtMethod Function
NCollectionInfo.h

Retrieves the method which removes an item with specific index from the collection.

C++
NResult N_API NCollectionInfoGetRemoveAtMethod(HNCollectionInfo hCollectionInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNCollectionInfo hCollectionInfo | [in] Handle to the collection information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollectionInfo.h

Module: NCollectionInfo Unit


NCollectionInfoGetRemoveCollectionChangedCallbackMethod Function

NCollectionInfoGetRemoveCollectionChangedCallbackMethod Function
NCollectionInfo.h

Retrieves the method which removes a "collection changed" event callback from a collection.

C++
NResult N_API NCollectionInfoGetRemoveCollectionChangedCallbackMethod(HNCollectionInfo hCollectionInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNCollectionInfo hCollectionInfo | [in] Handle to the collection information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollectionInfo.h

Module: NCollectionInfo Unit


NCollectionInfoGetRemoveCollectionChangedMethod Function

NCollectionInfoGetRemoveCollectionChangedMethod Function
NCollectionInfo.h

Retrieves the method which removes a "collection changed" event from a collection.

C++
NResult N_API NCollectionInfoGetRemoveCollectionChangedMethod(HNCollectionInfo hCollectionInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNCollectionInfo hCollectionInfo | [in] Handle to the collection information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollectionInfo.h

Module: NCollectionInfo Unit


NCollectionInfoGetRemoveMethod Function

NCollectionInfoGetRemoveMethod Function
NCollectionInfo.h

Retrieves the method which removes an item from the collection.

C++
NResult N_API NCollectionInfoGetRemoveMethod(HNCollectionInfo hCollectionInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNCollectionInfo hCollectionInfo | [in] Handle to the collection information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollectionInfo.h

Module: NCollectionInfo Unit


NCollectionInfoGetRemoveRangeMethod Function

NCollectionInfoGetRemoveRangeMethod Function
NCollectionInfo.h

Retrieves the method which removes a range of items from the collection.

C++
NResult N_API NCollectionInfoGetRemoveRangeMethod(HNCollectionInfo hCollectionInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNCollectionInfo hCollectionInfo | [in] Handle to the collection information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollectionInfo.h

Module: NCollectionInfo Unit


NCollectionInfoGetSetCapacityMethod Function

NCollectionInfoGetSetCapacityMethod Function
NCollectionInfo.h

Retrieves the method which sets the maximum number of items in the collection.

C++
NResult N_API NCollectionInfoGetSetCapacityMethod(HNCollectionInfo hCollectionInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNCollectionInfo hCollectionInfo | [in] Handle to the collection information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollectionInfo.h

Module: NCollectionInfo Unit


NCollectionInfoGetSetMethod Function

NCollectionInfoGetSetMethod Function
NCollectionInfo.h

Retrieves the method which sets a value of an item in the collection.

C++
NResult N_API NCollectionInfoGetSetMethod(HNCollectionInfo hCollectionInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNCollectionInfo hCollectionInfo | [in] Handle to the collection information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollectionInfo.h

Module: NCollectionInfo Unit


NCollectionInfoGetToArrayMethod Function

NCollectionInfoGetToArrayMethod Function
NCollectionInfo.h

Retrieves the method which converts the collection into an array.

C++
NResult N_API NCollectionInfoGetToArrayMethod(HNCollectionInfo hCollectionInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNCollectionInfo hCollectionInfo | [in] Handle to the collection information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCollectionInfo.h

Module: NCollectionInfo Unit


NCollectionInfo.h

NCollectionInfo.h
Functions Legend

Header file for the NCollectionInfo unit.

Collapse Expand Functions
Name | Description
NCollectionInfoGetAddCollectionChangedCallbackMethod | Retrieves the method which adds a "collection changed" event callback to a collection.
NCollectionInfoGetAddCollectionChangedMethod | Retrieves the method which adds a "collection changed" event to a collection.
NCollectionInfoGetAddMethod | Retrieves the method which adds an item to a collection.
NCollectionInfoGetAddRangeMethod | Retrieves the method which adds a range of items to a collection.
NCollectionInfoGetClearMethod | Retrieves the method which clears the collection.
NCollectionInfoGetGetCapacityMethod | Retrieves the method which gets the maximum number of items in the collection.
NCollectionInfoGetGetCountMethod | Retrieves the method which gets the number of items in the collection.
NCollectionInfoGetGetMethod | Retrieves the method which gets an item in the collection.
NCollectionInfoGetIndexOfMethod | Retrieves the method which gets an index of an item in the collection.
NCollectionInfoGetInsertMethod | Retrieves the method which adds an item to the collection at a specific index.
NCollectionInfoGetInsertRangeMethod | Retrieves the method which adds a range of items to the collection at a specific index.
NCollectionInfoGetItemAttributes | Retrieves the attributes of the items in the collection.
NCollectionInfoGetItemFormat | Retrieves the format of the items in the collection.
NCollectionInfoGetItemMaxValue | Retrieves the maximal item value of the collection.
NCollectionInfoGetItemMinValue | Retrieves the minimal item value of the collection.
NCollectionInfoGetItemStdValue | Retrieves the specified standard value of the collection.
NCollectionInfoGetItemStdValueCount | Retrieves the number of standard item values of the collection.
NCollectionInfoGetItemStdValues | Retrieves all standard item values of the collection.
NCollectionInfoGetItemType | Retrieves the type of the items in the collection.
NCollectionInfoGetRemoveAtMethod | Retrieves the method which removes an item with specific index from the collection.
NCollectionInfoGetRemoveCollectionChangedCallbackMethod | Retrieves the method which removes a "collection changed" event callback from a collection.
NCollectionInfoGetRemoveCollectionChangedMethod | Retrieves the method which removes a "collection changed" event from a collection.
NCollectionInfoGetRemoveMethod | Retrieves the method which removes an item from the collection.
NCollectionInfoGetRemoveRangeMethod | Retrieves the method which removes a range of items from the collection.
NCollectionInfoGetSetCapacityMethod | Retrieves the method which sets the maximum number of items in the collection.
NCollectionInfoGetSetMethod | Retrieves the method which sets a value of an item in the collection.
NCollectionInfoGetToArrayMethod | Retrieves the method which converts the collection into an array.


NConsole Unit

NConsole Unit
Functions Legend Macros

Represents the standard input, output, and error streams for console applications.

Collapse Expand Functions
Name | Description
NConsoleGetError | Gets the standard error output stream.
NConsoleGetIn | Gets the standard input stream.
NConsoleGetOut | Gets the standard output stream.
NConsoleReadChar | Reads the next character from the standard input stream.
NConsoleReadLine | Reads the next line from the standard input stream.
NConsoleSetError | Sets the standard error output stream.
NConsoleSetIn | Sets the standard input stream.
NConsoleSetOut | Sets the standard output stream.
NConsoleWrite | Writes the specified character to the standard output stream.
NConsoleWriteBoolean | Writes the specified boolean value to the standard output stream.
NConsoleWriteBooleanLine | Writes the specified boolean value, followed by the current line terminator, to the standard output stream.
NConsoleWriteChar | Writes the specified char value to the standard output stream.
NConsoleWriteCharLine | Writes the specified char value, followed by the current line terminator, to the standard output stream.
NConsoleWriteChars | Writes the specified char array value to the standard output stream.
NConsoleWriteCharsLine | Writes the specified char array value, followed by the current line terminator, to the standard output stream.
NConsoleWriteDouble | Writes the specified double value to the standard output stream.
NConsoleWriteDoubleLine | Writes the specified double value, followed by the current line terminator, to the standard output stream.
NConsoleWriteEmptyLine | Writes an empty line to the standard output stream.
NConsoleWriteFormat | Writes the specified format string to the standard output stream.
NConsoleWriteFormatLine | Writes the specified format string, followed by the current line terminator, to the standard output stream.
NConsoleWriteFormatLineVA | Writes the specified format string, followed by the current line terminator, to the standard output stream.
NConsoleWriteFormatVA | Writes the specified format string to the standard output stream.
NConsoleWriteInt32 | Writes the specified Int32 value to the standard output stream.
NConsoleWriteInt32Line | Writes the specified Int32 value, followed by the current line terminator, to the standard output stream.
NConsoleWriteInt64 | Writes the specified Int64 value to the standard output stream.
NConsoleWriteInt64Line | Writes the specified Int64 value, followed by the current line terminator, to the standard output stream.
NConsoleWriteLine | Writes the specified character to the standard output stream.
NConsoleWriteObject | Writes the specified object to the standard output stream.
NConsoleWriteObjectLine | Writes the specified object, followed by the current line terminator, to the standard output stream.
NConsoleWritePointer | Writes the specified pointer value to the standard output stream.
NConsoleWritePointerLine | Writes the specified pointer value, followed by the current line terminator, to the standard output stream.
NConsoleWriteResult | Writes the specified NResult value to the standard output stream.
NConsoleWriteResultLine | Writes the specified NResult value, followed by the current line terminator, to the standard output stream.
NConsoleWriteSSizeType | Writes the specified SSizeType value to the standard output stream.
NConsoleWriteSSizeTypeLine | Writes the specified SSizeType value, followed by the current line terminator, to the standard output stream.
NConsoleWriteSingle | Writes the specified single value to the standard output stream.
NConsoleWriteSingleLine | Writes the specified single value, followed by the current line terminator, to the standard output stream.
NConsoleWriteSizeType | Writes the specified SizeType value to the standard output stream.
NConsoleWriteSizeTypeLine | Writes the specified SizeType value, followed by the current line terminator, to the standard output stream.
NConsoleWriteUInt32 | Writes the specified UInt32 value to the standard output stream.
NConsoleWriteUInt32Line | Writes the specified UInt32 value, followed by the current line terminator, to the standard output stream.
NConsoleWriteUInt64 | Writes the specified UInt64 value to the standard output stream.
NConsoleWriteUInt64Line | Writes the specified UInt64 value, followed by the current line terminator, to the standard output stream.
NConsoleWriteValue | Writes the specified value to the standard output stream.
NConsoleWriteValueLine | Writes the specified value, followed by the current line terminator, to the standard output stream.
NConsoleWriteValueLineP | Writes the specified value, followed by the current line terminator, to the standard output stream.
NConsoleWriteValueP | Writes the specified value to the standard output stream.
Collapse Expand Macros
Name | Description
NConsoleReadChar | Picks a Unicode (W) or ASCII (A) version of the NConsoleReadChar function.
NConsoleWrite | Picks a Unicode (W) or ASCII (A) version of the NConsoleWrite function.
NConsoleWriteChar | Picks a Unicode (W) or ASCII (A) version of the NConsoleWriteChar function.
NConsoleWriteCharLine | Picks a Unicode (W) or ASCII (A) version of the NConsoleWriteCharLine function.
NConsoleWriteChars | Picks a Unicode (W) or ASCII (A) version of the NConsoleWriteChars function.
NConsoleWriteCharsLine | Picks a Unicode (W) or ASCII (A) version of the NConsoleWriteCharsLine function.
NConsoleWriteFormat | Picks a Unicode (W) or ASCII (A) version of the NConsoleWriteFormat function.
NConsoleWriteFormatLine | Picks a Unicode (W) or ASCII (A) version of the NConsoleWriteFormatLine function.
NConsoleWriteFormatLineVA | Picks a Unicode (W) or ASCII (A) version of the NConsoleWriteFormatLineVA function.
NConsoleWriteFormatVA | Picks a Unicode (W) or ASCII (A) version of the NConsoleWriteFormatVA function.
NConsoleWriteLine | Picks a Unicode (W) or ASCII (A) version of the NConsoleWriteLine function.


NConsoleGetError Function

NConsoleGetError Function

Gets the standard error output stream.

C++
NResult N_API NConsoleGetError(HNTextWriter * phValue);
Collapse Expand Parameters
Parameters | Description
HNTextWriter * phValue | [out] Pointer to a handle to NTextWriter that represents the standard error output stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NConsole.h

Module: NConsole Unit


NConsoleGetIn Function

NConsoleGetIn Function

Gets the standard input stream.

C++
NResult N_API NConsoleGetIn(HNTextReader * phValue);
Collapse Expand Parameters
Parameters | Description
HNTextReader * phValue | [out] Pointer to a handle to NTextWriter that represents the standard input stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NConsole.h

Module: NConsole Unit


NConsoleGetOut Function

NConsoleGetOut Function

Gets the standard output stream.

C++
NResult N_API NConsoleGetOut(HNTextWriter * phValue);
Collapse Expand Parameters
Parameters | Description
HNTextWriter * phValue | [out] Pointer to a handle to NTextWriter that represents the standard output stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NConsole.h

Module: NConsole Unit


NConsoleReadChar Function

NConsoleReadChar Function

Reads the next character from the standard input stream.

C++
NResult N_API NConsoleReadChar(NInt * pValue);
Collapse Expand Parameters
Parameters | Description
NInt * pValue | [out] Pointer to the next character from the input stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NConsole.h

Module: NConsole Unit


NConsoleReadLine Function

NConsoleReadLine Function

Reads the next line from the standard input stream.

C++
NResult N_API NConsoleReadLine(HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNString * phValue | [out] Pointer to a handle to the next line from the standard input stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NConsole.h

Module: NConsole Unit


NConsoleSetError Function

NConsoleSetError Function

Sets the standard error output stream.

C++
NResult N_API NConsoleSetError(HNTextWriter hValue);
Collapse Expand Parameters
Parameters | Description
HNTextWriter hValue | [in] A handle to NTextWriter that represents the standard error output stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NConsole.h

Module: NConsole Unit


NConsoleSetIn Function

NConsoleSetIn Function

Sets the standard input stream.

C++
NResult N_API NConsoleSetIn(HNTextReader hValue);
Collapse Expand Parameters
Parameters | Description
HNTextReader hValue | [in] A handle to NTextWriter that represents the standard input stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NConsole.h

Module: NConsole Unit


NConsoleSetOut Function

NConsoleSetOut Function

Sets the standard output stream.

C++
NResult N_API NConsoleSetOut(HNTextWriter hValue);
Collapse Expand Parameters
Parameters | Description
HNTextWriter hValue | [in] A handle to NTextWriter that represents the standard output stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NConsole.h

Module: NConsole Unit


NConsoleWrite Function

NConsoleWrite Function

Writes the specified character to the standard output stream.

C++
NResult N_API NConsoleWrite(const NChar * szValue);
Collapse Expand Parameters
Parameters | Description
const NChar * szValue | [in] Pointer to the value to write.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NConsole.h

Module: NConsole Unit


NConsoleWriteBoolean Function

NConsoleWriteBoolean Function

Writes the specified boolean value to the standard output stream.

C++
NResult N_API NConsoleWriteBoolean(NBool value);
Collapse Expand Parameters
Parameters | Description
NBool value | [in] The value to write.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NConsole.h

Module: NConsole Unit


NConsoleWriteBooleanLine Function

NConsoleWriteBooleanLine Function

Writes the specified boolean value, followed by the current line terminator, to the standard output stream.

C++
NResult N_API NConsoleWriteBooleanLine(NBool value);
Collapse Expand Parameters
Parameters | Description
NBool value | [in] The value to write.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NConsole.h

Module: NConsole Unit


NConsoleWriteChar Function

NConsoleWriteChar Function

Writes the specified char value to the standard output stream.

C++
NResult N_API NConsoleWriteChar(NChar value);
Collapse Expand Parameters
Parameters | Description
NChar value | [in] The value to write.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NConsole.h

Module: NConsole Unit


NConsoleWriteCharLine Function

NConsoleWriteCharLine Function

Writes the specified char value, followed by the current line terminator, to the standard output stream.

C++
NResult N_API NConsoleWriteCharLine(NChar value);
Collapse Expand Parameters
Parameters | Description
NChar value | [in] The value to write.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NConsole.h

Module: NConsole Unit


NConsoleWriteChars Function

NConsoleWriteChars Function

Writes the specified char array value to the standard output stream.

C++
NResult N_API NConsoleWriteChars(const NChar * arValue, NInt valueLength);
Collapse Expand Parameters
Parameters | Description
const NChar * arValue | [in] The value to write.
NInt valueLength | [in] Length of char array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NConsole.h

Module: NConsole Unit


NConsoleWriteCharsLine Function

NConsoleWriteCharsLine Function

Writes the specified char array value, followed by the current line terminator, to the standard output stream.

C++
NResult N_API NConsoleWriteCharsLine(const NChar * arValue, NInt valueLength);
Collapse Expand Parameters
Parameters | Description
const NChar * arValue | [in] The value to write.
NInt valueLength | [in] Length of char array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NConsole.h

Module: NConsole Unit


NConsoleWriteDouble Function

NConsoleWriteDouble Function

Writes the specified double value to the standard output stream.

C++
NResult N_API NConsoleWriteDouble(NDouble value);
Collapse Expand Parameters
Parameters | Description
NDouble value | [in] The value to write.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NConsole.h

Module: NConsole Unit


NConsoleWriteDoubleLine Function

NConsoleWriteDoubleLine Function

Writes the specified double value, followed by the current line terminator, to the standard output stream.

C++
NResult N_API NConsoleWriteDoubleLine(NDouble value);
Collapse Expand Parameters
Parameters | Description
NDouble value | [in] The value to write.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NConsole.h

Module: NConsole Unit


NConsoleWriteEmptyLine Function

NConsoleWriteEmptyLine Function

Writes an empty line to the standard output stream.

C++
NResult N_API NConsoleWriteEmptyLine();
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NConsole.h

Module: NConsole Unit


NConsoleWriteFormat Function

NConsoleWriteFormat Function

Writes the specified format string to the standard output stream.

C++
NResult N_API NConsoleWriteFormat(const NChar * szFormat, ... multipleParameters);
Collapse Expand Parameters
Parameters | Description
const NChar * szFormat | [in] Pointer to the format string to write.
... multipleParameters | [in] Format parameters.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NConsole.h

Module: NConsole Unit


NConsoleWriteFormatLine Function

NConsoleWriteFormatLine Function

Writes the specified format string, followed by the current line terminator, to the standard output stream.

C++
NResult N_API NConsoleWriteFormatLine(const NChar * szFormat, ... multipleParameters);
Collapse Expand Parameters
Parameters | Description
const NChar * szFormat | [in] Pointer to the format string to write.
... multipleParameters | [in] Format parameters.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NConsole.h

Module: NConsole Unit


NConsoleWriteFormatLineVA Function

NConsoleWriteFormatLineVA Function

Writes the specified format string, followed by the current line terminator, to the standard output stream.

C++
NResult N_API NConsoleWriteFormatLineVA(const NChar * szFormat, va_list args);
Collapse Expand Parameters
Parameters | Description
const NChar * szFormat | [in] Pointer to the format string to write.
va_list args | [in] Format arguments.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NConsole.h

Module: NConsole Unit


NConsoleWriteFormatVA Function

NConsoleWriteFormatVA Function

Writes the specified format string to the standard output stream.

C++
NResult N_API NConsoleWriteFormatVA(const NChar * szFormat, va_list args);
Collapse Expand Parameters
Parameters | Description
const NChar * szFormat | [in] Pointer to the format string to write.
va_list args | [in] Format arguments.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NConsole.h

Module: NConsole Unit


NConsoleWriteInt32 Function

NConsoleWriteInt32 Function

Writes the specified Int32 value to the standard output stream.

C++
NResult N_API NConsoleWriteInt32(NInt value);
Collapse Expand Parameters
Parameters | Description
NInt value | [in] The value to write.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NConsole.h

Module: NConsole Unit


NConsoleWriteInt32Line Function

NConsoleWriteInt32Line Function

Writes the specified Int32 value, followed by the current line terminator, to the standard output stream.

C++
NResult N_API NConsoleWriteInt32Line(NInt value);
Collapse Expand Parameters
Parameters | Description
NInt value | [in] The value to write.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NConsole.h

Module: NConsole Unit


NConsoleWriteInt64 Function

NConsoleWriteInt64 Function

Writes the specified Int64 value to the standard output stream.

C++
NResult N_API NConsoleWriteInt64(NLong value);
Collapse Expand Parameters
Parameters | Description
NLong value | [in] The value to write.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NConsole.h

Module: NConsole Unit


NConsoleWriteInt64Line Function

NConsoleWriteInt64Line Function

Writes the specified Int64 value, followed by the current line terminator, to the standard output stream.

C++
NResult N_API NConsoleWriteInt64Line(NLong value);
Collapse Expand Parameters
Parameters | Description
NLong value | [in] The value to write.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NConsole.h

Module: NConsole Unit


NConsoleWriteLine Function

NConsoleWriteLine Function

Writes the specified character to the standard output stream.

C++
NResult N_API NConsoleWriteLine(const NChar * szValue);
Collapse Expand Parameters
Parameters | Description
const NChar * szValue | [in] Pointer to the value to write.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NConsole.h

Module: NConsole Unit


NConsoleWriteObject Function

NConsoleWriteObject Function

Writes the specified object to the standard output stream.

C++
NResult N_API NConsoleWriteObject(HNObject hObject);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] Handle to the object to write.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NConsole.h

Module: NConsole Unit


NConsoleWriteObjectLine Function

NConsoleWriteObjectLine Function

Writes the specified object, followed by the current line terminator, to the standard output stream.

C++
NResult N_API NConsoleWriteObjectLine(HNObject hObject);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] Handle to the object to write.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NConsole.h

Module: NConsole Unit


NConsoleWritePointer Function

NConsoleWritePointer Function

Writes the specified pointer value to the standard output stream.

C++
NResult N_API NConsoleWritePointer(const void * value);
Collapse Expand Parameters
Parameters | Description
const void * value | [in] The value to write.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NConsole.h

Module: NConsole Unit


NConsoleWritePointerLine Function

NConsoleWritePointerLine Function

Writes the specified pointer value, followed by the current line terminator, to the standard output stream.

C++
NResult N_API NConsoleWritePointerLine(const void * value);
Collapse Expand Parameters
Parameters | Description
const void * value | [in] The value to write.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NConsole.h

Module: NConsole Unit


NConsoleWriteResult Function

NConsoleWriteResult Function

Writes the specified NResult value to the standard output stream.

C++
NResult N_API NConsoleWriteResult(NResult value);
Collapse Expand Parameters
Parameters | Description
NResult value | [in] The value to write.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NConsole.h

Module: NConsole Unit


NConsoleWriteResultLine Function

NConsoleWriteResultLine Function

Writes the specified NResult value, followed by the current line terminator, to the standard output stream.

C++
NResult N_API NConsoleWriteResultLine(NResult value);
Collapse Expand Parameters
Parameters | Description
NResult value | [in] The value to write.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NConsole.h

Module: NConsole Unit


NConsoleWriteSSizeType Function

NConsoleWriteSSizeType Function

Writes the specified SSizeType value to the standard output stream.

C++
NResult N_API NConsoleWriteSSizeType(NSSizeType value);
Collapse Expand Parameters
Parameters | Description
NSSizeType value | [in] The value to write.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NConsole.h

Module: NConsole Unit


NConsoleWriteSSizeTypeLine Function

NConsoleWriteSSizeTypeLine Function

Writes the specified SSizeType value, followed by the current line terminator, to the standard output stream.

C++
NResult N_API NConsoleWriteSSizeTypeLine(NSSizeType value);
Collapse Expand Parameters
Parameters | Description
NSSizeType value | [in] The value to write.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NConsole.h

Module: NConsole Unit


NConsoleWriteSingle Function

NConsoleWriteSingle Function

Writes the specified single value to the standard output stream.

C++
NResult N_API NConsoleWriteSingle(NFloat value);
Collapse Expand Parameters
Parameters | Description
NFloat value | [in] The value to write.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NConsole.h

Module: NConsole Unit


NConsoleWriteSingleLine Function

NConsoleWriteSingleLine Function

Writes the specified single value, followed by the current line terminator, to the standard output stream.

C++
NResult N_API NConsoleWriteSingleLine(NFloat value);
Collapse Expand Parameters
Parameters | Description
NFloat value | [in] The value to write.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NConsole.h

Module: NConsole Unit


NConsoleWriteSizeType Function

NConsoleWriteSizeType Function

Writes the specified SizeType value to the standard output stream.

C++
NResult N_API NConsoleWriteSizeType(NSizeType value);
Collapse Expand Parameters
Parameters | Description
NSizeType value | [in] The value to write.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NConsole.h

Module: NConsole Unit


NConsoleWriteSizeTypeLine Function

NConsoleWriteSizeTypeLine Function

Writes the specified SizeType value, followed by the current line terminator, to the standard output stream.

C++
NResult N_API NConsoleWriteSizeTypeLine(NSizeType value);
Collapse Expand Parameters
Parameters | Description
NSizeType value | [in] The value to write.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NConsole.h

Module: NConsole Unit


NConsoleWriteUInt32 Function

NConsoleWriteUInt32 Function

Writes the specified UInt32 value to the standard output stream.

C++
NResult N_API NConsoleWriteUInt32(NUInt value);
Collapse Expand Parameters
Parameters | Description
NUInt value | [in] The value to write.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NConsole.h

Module: NConsole Unit


NConsoleWriteUInt32Line Function

NConsoleWriteUInt32Line Function

Writes the specified UInt32 value, followed by the current line terminator, to the standard output stream.

C++
NResult N_API NConsoleWriteUInt32Line(NUInt value);
Collapse Expand Parameters
Parameters | Description
NUInt value | [in] The value to write.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NConsole.h

Module: NConsole Unit


NConsoleWriteUInt64 Function

NConsoleWriteUInt64 Function

Writes the specified UInt64 value to the standard output stream.

C++
NResult N_API NConsoleWriteUInt64(NULong value);
Collapse Expand Parameters
Parameters | Description
NULong value | [in] The value to write.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NConsole.h

Module: NConsole Unit


NConsoleWriteUInt64Line Function

NConsoleWriteUInt64Line Function

Writes the specified UInt64 value, followed by the current line terminator, to the standard output stream.

C++
NResult N_API NConsoleWriteUInt64Line(NULong value);
Collapse Expand Parameters
Parameters | Description
NULong value | [in] The value to write.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NConsole.h

Module: NConsole Unit


NConsoleWriteValue Function

NConsoleWriteValue Function

Writes the specified value to the standard output stream.

C++
NResult N_API NConsoleWriteValue(HNType hType, const void * pValue, NSizeType valueSize);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to a function that retrieves the type of the value.
const void * pValue | [in] Pointer to the value.
NSizeType valueSize | [in] Size of the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NConsole.h

Module: NConsole Unit


NConsoleWriteValueLine Function

NConsoleWriteValueLine Function

Writes the specified value, followed by the current line terminator, to the standard output stream.

C++
NResult N_API NConsoleWriteValueLine(HNType hType, const void * pValue, NSizeType valueSize);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to a function that retrieves the type of the value.
const void * pValue | [in] Pointer to the value.
NSizeType valueSize | [in] Size of the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NConsole.h

Module: NConsole Unit


NConsoleWriteValueLineP Function

NConsoleWriteValueLineP Function

Writes the specified value, followed by the current line terminator, to the standard output stream.

C++
NResult N_API NConsoleWriteValueLineP(NTypeOfProc pTypeOf, const void * pValue, NSizeType valueSize);
Collapse Expand Parameters
Parameters | Description
NTypeOfProc pTypeOf | [in] Pointer to a function that retrieves the type of the value.
const void * pValue | [in] Pointer to the value.
NSizeType valueSize | [in] Size of the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NConsole.h

Module: NConsole Unit


NConsoleWriteValueP Function

NConsoleWriteValueP Function

Writes the specified value to the standard output stream.

C++
NResult N_API NConsoleWriteValueP(NTypeOfProc pTypeOf, const void * pValue, NSizeType valueSize);
Collapse Expand Parameters
Parameters | Description
NTypeOfProc pTypeOf | [in] Pointer to a function that retrieves the type of the value.
const void * pValue | [in] Pointer to the value.
NSizeType valueSize | [in] Size of the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NConsole.h

Module: NConsole Unit


NConsoleReadChar Macro

NConsoleReadChar Macro

Picks a Unicode (W) or ASCII (A) version of the NConsoleReadChar function.

C++
#define NConsoleReadChar N_FUNC_AW(NConsoleReadChar)
Container

File: NConsole.h

Module: NConsole Unit


NConsoleWrite Macro

NConsoleWrite Macro

Picks a Unicode (W) or ASCII (A) version of the NConsoleWrite function.

C++
#define NConsoleWrite N_FUNC_AW(NConsoleWrite)
Container

File: NConsole.h

Module: NConsole Unit


NConsoleWriteChar Macro

NConsoleWriteChar Macro

Picks a Unicode (W) or ASCII (A) version of the NConsoleWriteChar function.

C++
#define NConsoleWriteChar N_FUNC_AW(NConsoleWriteChar)
Container

File: NConsole.h

Module: NConsole Unit


NConsoleWriteCharLine Macro

NConsoleWriteCharLine Macro

Picks a Unicode (W) or ASCII (A) version of the NConsoleWriteCharLine function.

C++
#define NConsoleWriteCharLine N_FUNC_AW(NConsoleWriteCharLine)
Container

File: NConsole.h

Module: NConsole Unit


NConsoleWriteChars Macro

NConsoleWriteChars Macro

Picks a Unicode (W) or ASCII (A) version of the NConsoleWriteChars function.

C++
#define NConsoleWriteChars N_FUNC_AW(NConsoleWriteChars)
Container

File: NConsole.h

Module: NConsole Unit


NConsoleWriteCharsLine Macro

NConsoleWriteCharsLine Macro

Picks a Unicode (W) or ASCII (A) version of the NConsoleWriteCharsLine function.

C++
#define NConsoleWriteCharsLine N_FUNC_AW(NConsoleWriteCharsLine)
Container

File: NConsole.h

Module: NConsole Unit


NConsoleWriteFormat Macro

NConsoleWriteFormat Macro

Picks a Unicode (W) or ASCII (A) version of the NConsoleWriteFormat function.

C++
#define NConsoleWriteFormat N_FUNC_AW(NConsoleWriteFormat)
Container

File: NConsole.h

Module: NConsole Unit


NConsoleWriteFormatLine Macro

NConsoleWriteFormatLine Macro

Picks a Unicode (W) or ASCII (A) version of the NConsoleWriteFormatLine function.

C++
#define NConsoleWriteFormatLine N_FUNC_AW(NConsoleWriteFormatLine)
Container

File: NConsole.h

Module: NConsole Unit


NConsoleWriteFormatLineVA Macro

NConsoleWriteFormatLineVA Macro

Picks a Unicode (W) or ASCII (A) version of the NConsoleWriteFormatLineVA function.

C++
#define NConsoleWriteFormatLineVA N_FUNC_AW(NConsoleWriteFormatLineVA)
Container

File: NConsole.h

Module: NConsole Unit


NConsoleWriteFormatVA Macro

NConsoleWriteFormatVA Macro

Picks a Unicode (W) or ASCII (A) version of the NConsoleWriteFormatVA function.

C++
#define NConsoleWriteFormatVA N_FUNC_AW(NConsoleWriteFormatVA)
Container

File: NConsole.h

Module: NConsole Unit


NConsoleWriteLine Macro

NConsoleWriteLine Macro

Picks a Unicode (W) or ASCII (A) version of the NConsoleWriteLine function.

C++
#define NConsoleWriteLine N_FUNC_AW(NConsoleWriteLine)
Container

File: NConsole.h

Module: NConsole Unit


NConstantInfo Unit

NConstantInfo Unit
Files Functions Legend

Provides functionality to retrieve information about constant values.

Collapse Expand Files
Name | Description
NConstantInfo.h | Header file for the NConstantInfo unit.
Collapse Expand Functions
Name | Description
NConstantInfoGetConstantType | Retrieves the type of the specified constant.
NConstantInfoGetValue | Retrieves the value of the specified constant.


NConstantInfoGetConstantType Function

NConstantInfoGetConstantType Function
NConstantInfo.h

Retrieves the type of the specified constant.

C++
NResult N_API NConstantInfoGetConstantType(HNConstantInfo hConstantInfo, HNType * phValue);
Collapse Expand Parameters
Parameters | Description
HNConstantInfo hConstantInfo | [in] Handle to the constant information.
HNType * phValue | [out] Pointer to the type of the constant.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NConstantInfo.h

Module: NConstantInfo Unit


NConstantInfoGetValue Function

NConstantInfoGetValue Function
NConstantInfo.h

Retrieves the value of the specified constant.

C++
NResult N_API NConstantInfoGetValue(HNConstantInfo hConstantInfo, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
HNConstantInfo hConstantInfo | [in] Handle to the constant information.
HNValue * phValue | [out] Pointer to the constant value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NConstantInfo.h

Module: NConstantInfo Unit


NConstantInfo.h

NConstantInfo.h
Functions Legend

Header file for the NConstantInfo unit.

Collapse Expand Functions
Name | Description
NConstantInfoGetConstantType | Retrieves the type of the specified constant.
NConstantInfoGetValue | Retrieves the value of the specified constant.


NCore Unit

NCore Unit
Files Functions Legend

Provides infrastructure/basic functionality for Neurotechnology components.

Collapse Expand Files
Name | Description
NCore.h | Header file for the NCore module. Provides infrastructure/basic functionality for Neurotechnology components.
Collapse Expand Functions
Name | Description
NCoreAddErrorSuppressedCallback | Adds a suppressed error callback to NCore.
NCoreAddErrorSuppressed | Adds a suppressed error event to NCore.
NCoreOnExitEx | This function should be called on program's exit.
NCoreOnStart | This function should be called on program's start.
NCoreRemoveErrorSuppressed | Removes a suppressed error event from NCore.
NCoreOnThreadExit | This function should be called when program's thread finished its task.
NCoreOnThreadStart | This function should be called when new thread is created.
NCoreRemoveErrorSuppressedCallback | Removes a suppressed error callback from NCore.


NCoreAddErrorSuppressedCallback Function

NCoreAddErrorSuppressedCallback Function
NCore.h

Adds a suppressed error callback to NCore.

C++
NResult N_API NCoreAddErrorSuppressedCallback(NErrorSuppressedCallback pCallback, void * pParam);
Collapse Expand Parameters
Parameters | Description
NErrorSuppressedCallback pCallback | [in] The callback to be added.
void * pParam | [in] A pointer to data provided for the callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCore.h

Module: NCore Unit


NCoreAddErrorSuppressed Function

NCoreAddErrorSuppressed Function
NCore.h

Adds a suppressed error event to NCore.

C++
NResult N_API NCoreAddErrorSuppressed(HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNCallback hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCore.h

Module: NCore Unit


NCoreOnExitEx Function

NCoreOnExitEx Function
NCore.h

This function should be called on program's exit.

C++
NResult N_API NCoreOnExitEx(NBool isProcessTermination);
Collapse Expand Parameters
Parameters | Description
NBool isProcessTermination | [in] NTrue if the process exits; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCore.h

Module: NCore Unit


NCoreOnStart Function

NCoreOnStart Function
NCore.h

This function should be called on program's start.

C++
NResult N_API NCoreOnStart();
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Function result can be checked using NFailed and NSucceeded macros.

Collapse Expand Notes

This function works on Lib-No-Dll and VAR products.

Container

File: NCore.h

Module: NCore Unit


NCoreRemoveErrorSuppressed Function

NCoreRemoveErrorSuppressed Function
NCore.h

Removes a suppressed error event from NCore.

C++
NResult N_API NCoreRemoveErrorSuppressed(HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNCallback hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCore.h

Module: NCore Unit


NCoreOnThreadExit Function

NCoreOnThreadExit Function
NCore.h

This function should be called when program's thread finished its task.

C++
NResult N_API NCoreOnThreadExit();
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Function result can be checked using NFailed and NSucceeded macros.

Collapse Expand Notes

This function works on Lib-No-Dll and VAR products.

Container

File: NCore.h

Module: NCore Unit


NCoreOnThreadStart Function

NCoreOnThreadStart Function
NCore.h

This function should be called when new thread is created.

C++
NResult N_API NCoreOnThreadStart();
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Function result can be checked using NFailed and NSucceeded macros.

Collapse Expand Notes

This function works on Lib-No-Dll and VAR products.

Container

File: NCore.h

Module: NCore Unit


NCoreRemoveErrorSuppressedCallback Function

NCoreRemoveErrorSuppressedCallback Function
NCore.h

Removes a suppressed error callback from NCore.

C++
NResult N_API NCoreRemoveErrorSuppressedCallback(NErrorSuppressedCallback pCallback, void * pParam);
Collapse Expand Parameters
Parameters | Description
NErrorSuppressedCallback pCallback | [in] The callback to be removed.
void * pParam | [in] A pointer to data provided for the callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCore.h

Module: NCore Unit


NCore.h

NCore.h
Functions Legend

Header file for the NCore module. Provides infrastructure/basic functionality for Neurotechnology components.

Collapse Expand Functions
Name | Description
NCoreAddErrorSuppressed | Adds a suppressed error event to NCore.
NCoreAddErrorSuppressedCallback | Adds a suppressed error callback to NCore.
NCoreOnExitEx | This function should be called on program's exit.
NCoreOnStart | This function should be called on program's start.
NCoreOnThreadExit | This function should be called when program's thread finished its task.
NCoreOnThreadStart | This function should be called when new thread is created.
NCoreRemoveErrorSuppressed | Removes a suppressed error event from NCore.
NCoreRemoveErrorSuppressedCallback | Removes a suppressed error callback from NCore.


NCustomEventDescriptor Unit

NCustomEventDescriptor Unit
Files Functions Legend

Provides functionality to retrieve information about custom event descriptors.

Collapse Expand Files
Name | Description
NCustomEventDescriptor.h | Header file for the NCustomEventDescriptor unit.
Collapse Expand Functions
Name | Description
NCustomEventDescriptorGetData | Retrieves the data of the specified descriptor.


NCustomEventDescriptorGetData Function

NCustomEventDescriptorGetData Function
NCustomEventDescriptor.h

Retrieves the data of the specified descriptor.

C++
NResult N_API NCustomEventDescriptorGetData(HNCustomEventDescriptor hEventDescriptor, HNValue * phData);
Collapse Expand Parameters
Parameters | Description
HNCustomEventDescriptor hEventDescriptor | [in] Handle to the custom event descriptor.
HNValue * phData | [out] Pointer to a handle to the data of the descriptor.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCustomEventDescriptor.h

Module: NCustomEventDescriptor Unit


NCustomEventDescriptor.h

NCustomEventDescriptor.h
Functions Legend

Header file for the NCustomEventDescriptor unit.

Collapse Expand Functions
Name | Description
NCustomEventDescriptorGetData | Retrieves the data of the specified descriptor.


NCustomMethodDescriptor Unit

NCustomMethodDescriptor Unit
Files Functions Legend

Provides functionality to retrieve information about custom method descriptors.

Collapse Expand Files
Name | Description
NCustomMethodDescriptor.h | Header file for the NCustomMethodDescriptor unit.
Collapse Expand Functions
Name | Description
NCustomMethodDescriptorGetData | Retrieves the data of the specified descriptor.


NCustomMethodDescriptorGetData Function

NCustomMethodDescriptorGetData Function
NCustomMethodDescriptor.h

Retrieves the data of the specified descriptor.

C++
NResult N_API NCustomMethodDescriptorGetData(HNCustomMethodDescriptor hMethodDescriptor, HNValue * phData);
Collapse Expand Parameters
Parameters | Description
HNCustomMethodDescriptor hMethodDescriptor | [in] Handle to the custom method descriptor.
HNValue * phData | [out] Pointer to a handle to the data of the descriptor.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCustomMethodDescriptor.h

Module: NCustomMethodDescriptor Unit


NCustomMethodDescriptor.h

NCustomMethodDescriptor.h
Functions Legend

Header file for the NCustomMethodDescriptor unit.

Collapse Expand Functions
Name | Description
NCustomMethodDescriptorGetData | Retrieves the data of the specified descriptor.


NCustomParameterDescriptor Unit

NCustomParameterDescriptor Unit
Files Functions Legend

Provides custom parameter descriptor management functionality.

Collapse Expand Files
Name | Description
NCustomParameterDescriptor.h | Header file for the NCustomParameterDescriptor unit.
Collapse Expand Functions
Name | Description
NCustomParameterDescriptorCreate | Creates a new custom parameter descriptor.
NCustomParameterDescriptorGetData | Retrieves the data of the specified descriptor.


NCustomParameterDescriptorCreate Function

NCustomParameterDescriptorCreate Function
NCustomParameterDescriptor.h

Creates a new custom parameter descriptor.

C++
NResult N_API NCustomParameterDescriptorCreate(HNString hName, HNType hParameterType, NAttributes attributes, HNString hFormat, HNValue hDefaultValue, HNValue hMinValue, HNValue hMaxValue, const struct NNameValuePair_ * arStdValues, NInt stdValueCount, HNValue hData, HNCustomParameterDescriptor * phParameterDescriptor);
Collapse Expand Parameters
Parameters | Description
HNString hName | [in] Handle to the descriptor name.
HNType hParameterType | [in] Handle to the parameter type.
NAttributes attributes | [in] Descriptor attributes.
HNString hFormat | [in] Handle to the descriptor format.
HNValue hDefaultValue | [in] Handle to the default parameter value.
HNValue hMinValue | [in] Minimum parameter value.
HNValue hMaxValue | [in] Maximum parameter value.
const struct NNameValuePair_ * arStdValues | [in] Pointer to an array of standard values.
NInt stdValueCount | [in] Number of standard values.
HNValue hData | [in] Handle to the descriptor data.
HNCustomParameterDescriptor * phParameterDescriptor | [out] Pointer to a handle to the parameter descriptor.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCustomParameterDescriptor.h

Module: NCustomParameterDescriptor Unit


NCustomParameterDescriptorGetData Function

NCustomParameterDescriptorGetData Function
NCustomParameterDescriptor.h

Retrieves the data of the specified descriptor.

C++
NResult N_API NCustomParameterDescriptorGetData(HNCustomParameterDescriptor hParameterDescriptor, HNValue * phData);
Collapse Expand Parameters
Parameters | Description
HNCustomParameterDescriptor hParameterDescriptor | [in] Handle to the custom parameter descriptor.
HNValue * phData | [out] Pointer to a handle to the data of the descriptor.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCustomParameterDescriptor.h

Module: NCustomParameterDescriptor Unit


NCustomParameterDescriptor.h

NCustomParameterDescriptor.h
Functions Legend

Header file for the NCustomParameterDescriptor unit.

Collapse Expand Functions
Name | Description
NCustomParameterDescriptorCreate | Creates a new custom parameter descriptor.
NCustomParameterDescriptorGetData | Retrieves the data of the specified descriptor.


NCustomPropertyDescriptor Unit

NCustomPropertyDescriptor Unit
Files Functions Legend

Provides custom property descriptor management functionality.

Collapse Expand Files
Name | Description
NCustomPropertyDescriptor.h | Header file for the NCustomPropertyDescriptor unit.
Collapse Expand Functions
Name | Description
NCustomPropertyDescriptorGetData | Retrieves the data of the specified descriptor.


NCustomPropertyDescriptorGetData Function

NCustomPropertyDescriptorGetData Function
NCustomPropertyDescriptor.h

Retrieves the data of the specified descriptor.

C++
NResult N_API NCustomPropertyDescriptorGetData(HNCustomPropertyDescriptor hPropertyDescriptor, HNValue * phData);
Collapse Expand Parameters
Parameters | Description
HNCustomPropertyDescriptor hPropertyDescriptor | [in] Handle to the custom property descriptor.
HNValue * phData | [out] Pointer to a handle to the data of the descriptor.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCustomPropertyDescriptor.h

Module: NCustomPropertyDescriptor Unit


NCustomPropertyDescriptor.h

NCustomPropertyDescriptor.h
Functions Legend

Header file for the NCustomPropertyDescriptor unit.

Collapse Expand Functions
Name | Description
NCustomPropertyDescriptorGetData | Retrieves the data of the specified descriptor.


NCustomStream Unit

NCustomStream Unit
Functions Legend

Represents a stream with custom parameters.

Collapse Expand Functions
Name | Description
NCustomStreamCreate | Creates a custom stream.


NCustomStreamCreate Function

NCustomStreamCreate Function

Creates a custom stream.

C++
NResult N_API NCustomStreamCreate(NBool canRead, NBool canWrite, NBool canSeek, NCustomStreamFlushProc pFlush, void * pFlushParam, NCustomStreamGetLengthProc pGetLength, void * pGetLengthParam, NCustomStreamSetLengthProc pSetLength, void * pSetLengthParam, NCustomStreamGetPositionProc pGetPosition, void * pGetPositionParam, NCustomStreamSetPositionProc pSetPosition, void * pSetPositionParam, NCustomStreamSeekProc pSeek, void * pSeekParam, NCustomStreamReadByteProc pReadByte, void * pReadByteParam, NCustomStreamReadProc pRead, void * pReadParam, NCustomStreamWriteByteProc pWriteByte, void * pWriteByteParam, NCustomStreamWriteProc pWrite, void * pWriteParam, HNCustomStream * phStream);
Collapse Expand Parameters
Parameters | Description
NBool canRead | [in] NTrue if reading is permitted; else NFalse.
NBool canWrite | [in] NTrue if writing is permitted; else NFalse.
NBool canSeek | [in] NTrue if seeking is permitted; else NFalse.
NCustomStreamFlushProc pFlush | [in] NCustomStreamFlushProc object.
void * pFlushParam | [out] Pointer to NCustomStreamFlushProc parameters.
NCustomStreamGetLengthProc pGetLength | [in] NCustomStreamGetLengthProc object.
void * pGetLengthParam | [out] Pointer to NCustomStreamGetLengthProc parameters.
NCustomStreamSetLengthProc pSetLength | [in] NCustomStreamSetLengthProc object.
void * pSetLengthParam | [out] Pointer to NCustomStreamSetLengthProc parameters.
NCustomStreamGetPositionProc pGetPosition | [in] NCustomStreamGetPositionProc object.
void * pGetPositionParam | [out] Pointer to NCustomStreamGetPositionProc parameters.
NCustomStreamSetPositionProc pSetPosition | [in] NCustomStreamSetPositionProc object.
void * pSetPositionParam | [out] Pointer to NCustomStreamSetPositionProc parameters.
NCustomStreamSeekProc pSeek | [in] NCustomStreamSeekProc object.
void * pSeekParam | [out] Pointer to NCustomStreamSeekProc parameters.
NCustomStreamReadByteProc pReadByte | [in] NCustomStreamReadByteProc object.
void * pReadByteParam | [out] Pointer to NCustomStreamReadByteProc parameters.
NCustomStreamReadProc pRead | [in] NCustomStreamReadProc object.
void * pReadParam | [out] Pointer to NCustomStreamReadProc parameters.
NCustomStreamWriteByteProc pWriteByte | [in] NCustomStreamWriteByteProc object.
void * pWriteByteParam | [out] Pointer to NCustomStreamWriteByteProc parameters.
NCustomStreamWriteProc pWrite | [in] NCustomStreamWriteProc object.
void * pWriteParam | [out] Pointer to NCustomStreamWriteProc parameters.
HNCustomStream * phStream | [out] Pointer to a handle to the new custom stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCustomStream.h

Module: NCustomStream Unit


NDateTime Unit

NDateTime Unit
Functions Legend Macros Structs, Records, Enums Types

Represents an instant in time, typically expressed as a date and time of day.

C++
typedef NDateTime_ NDateTime;
Collapse Expand Functions
Name | Description
NDateTimeAddDays | Adds the specified number of days to the value of the specified instance.
NDateTimeAddHours | Adds the specified number of hours to the value of the specified instance.
NDateTimeAddMilliseconds | Adds the specified number of milliseconds to the value of the specified instance.
NDateTimeAddMinutes | Adds the specified number of minutes to the value of the specified instance.
NDateTimeAddMonths | Adds the specified number of months to the value of the specified instance.
NDateTimeAddSeconds | Adds the specified number of seconds to the value of the specified instance.
NDateTimeAddTicks | Adds the specified number of ticks to the value of the specified instance.
NDateTimeAddTimeSpan | Adds the specified TimeSpan to the value of the specified instance.
NDateTimeAddYears | Adds the specified number of years to the value of the specified instance.
NDateTimeCompare | Compares two instances of DateTime and returns an indication of their relative values.
NDateTimeCreate | Initializes a new instance of the DateTime structure to the specified year, month, day, hour, minute, second and millisecond.
NDateTimeCreateDate | Initializes a new instance of the DateTime structure to the specified year, month and day.
NDateTimeCreateFromTicks | Initializes a new instance of the DateTime structure from the specified number of ticks.
NDateTimeDaysInMonth | Gets the number of days the specified month of the specified year.
NDateTimeDecode | Decodes the specified DateTime instance.
NDateTimeGetDate | Gets the date (year, month and day) represented by the specified DateTime instance.
NDateTimeGetDay | Gets the day represented by the specified DateTime instance.
NDateTimeGetDayOfWeek | Gets the day of the week represented by the specified DateTime instance.
NDateTimeGetDayOfYear | Gets the day of the year represented by the specified DateTime instance.
NDateTimeGetHour | Gets the hour represented by the specified DateTime instance.
NDateTimeGetMillisecond | Gets the millisecond represented by the specified DateTime instance.
NDateTimeGetMinute | Gets the minute represented by the specified DateTime instance.
NDateTimeGetMonth | Gets the month represented by the specified DateTime instance.
NDateTimeGetNow | Gets current time of day.
NDateTimeGetSecond | Gets the second represented by the specified DateTime instance.
NDateTimeGetTicks | Gets the number of ticks that represent the specified DateTime instance.
NDateTimeGetTimeOfDay | Gets the time of the day (hour, minute and second) represented by the specified DateTime instance.
NDateTimeGetToday | Gets today's date.
NDateTimeGetUtcNow | Gets the current Coordinated Universal Time.
NDateTimeGetYear | Gets the year represented by the specified DateTime instance.
NDateTimeIsDateTimeValid | Checks whether the specified date and time are valid.
NDateTimeIsDateValid | Checks whether the specified date is valid.
NDateTimeIsLeapYear | Checks whether the specified year is a leap year (366 days).
NDateTimeIsValid | Checks whether the specified DateTime instance is valid.
NDateTimeSubtract | Subtracts a DateTime instance from another DateTime instance.
NDateTimeSubtractTimeSpan | Subtracts the specified TimeSpan from the specified DateTime.
NDateTimeToLocalTime | Converts the specified DateTime to local time.
NDateTimeToString | Gets a string representation of the specified DateTime.
NDateTimeToUniversalTime | Converts the specified DateTime to Coordinated Universal Time.
Collapse Expand Macros
Name | Description
NDateTimeToString | Picks a Unicode (W) or ASCII (A) version of the NDateTimeToString function.
N_DATE_TIME_MAX | Maximum DateTime value.
N_DATE_TIME_MIN | Minimum DateTime value.
Collapse Expand Structs, Records, Enums
Name | Description
NDayOfWeek_ | Enumerates the days of the week.
NDayOfWeek | Enumerates the days of the week.
Collapse Expand Types
Name | Description
NDateTime_ | The DateTime instance.
Container

File: NDateTime.h

Module: NDateTime Unit


NDateTimeAddDays Function

NDateTimeAddDays Function

Adds the specified number of days to the value of the specified instance.

C++
NResult N_API NDateTimeAddDays(NDateTime_ dateTime, NDouble value, NDateTime_ * pResult);
Collapse Expand Parameters
Parameters | Description
NDateTime_ dateTime | [in] The original DateTime instance.
NDouble value | [in] A number of whole and fractional days. This value can be negative or positive.
NDateTime_ * pResult | [out] Pointer to the modified DateTime instance.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDateTime.h

Module: NDateTime Unit


NDateTimeAddHours Function

NDateTimeAddHours Function

Adds the specified number of hours to the value of the specified instance.

C++
NResult N_API NDateTimeAddHours(NDateTime_ dateTime, NDouble value, NDateTime_ * pResult);
Collapse Expand Parameters
Parameters | Description
NDateTime_ dateTime | [in] The original DateTime instance.
NDouble value | [in] A number of whole and fractional hours. This value can be negative or positive.
NDateTime_ * pResult | [out] Pointer to the modified DateTime instance.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDateTime.h

Module: NDateTime Unit


NDateTimeAddMilliseconds Function

NDateTimeAddMilliseconds Function

Adds the specified number of milliseconds to the value of the specified instance.

C++
NResult N_API NDateTimeAddMilliseconds(NDateTime_ dateTime, NDouble value, NDateTime_ * pResult);
Collapse Expand Parameters
Parameters | Description
NDateTime_ dateTime | [in] The original DateTime instance.
NDouble value | [in] A number of whole and fractional milliseconds. This value can be negative or positive.
NDateTime_ * pResult | [out] Pointer to the modified DateTime instance.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDateTime.h

Module: NDateTime Unit


NDateTimeAddMinutes Function

NDateTimeAddMinutes Function

Adds the specified number of minutes to the value of the specified instance.

C++
NResult N_API NDateTimeAddMinutes(NDateTime_ dateTime, NDouble value, NDateTime_ * pResult);
Collapse Expand Parameters
Parameters | Description
NDateTime_ dateTime | [in] The original DateTime instance.
NDouble value | [in] A number of whole and fractional minutes. This value can be negative or positive.
NDateTime_ * pResult | [out] Pointer to the modified DateTime instance.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDateTime.h

Module: NDateTime Unit


NDateTimeAddMonths Function

NDateTimeAddMonths Function

Adds the specified number of months to the value of the specified instance.

C++
NResult N_API NDateTimeAddMonths(NDateTime_ dateTime, NInt value, NDateTime_ * pResult);
Collapse Expand Parameters
Parameters | Description
NDateTime_ dateTime | [in] The original DateTime instance.
NInt value | [in] A number of whole and fractional months. This value can be negative or positive.
NDateTime_ * pResult | [out] Pointer to the modified DateTime instance.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDateTime.h

Module: NDateTime Unit


NDateTimeAddSeconds Function

NDateTimeAddSeconds Function

Adds the specified number of seconds to the value of the specified instance.

C++
NResult N_API NDateTimeAddSeconds(NDateTime_ dateTime, NDouble value, NDateTime_ * pResult);
Collapse Expand Parameters
Parameters | Description
NDateTime_ dateTime | [in] The original DateTime instance.
NDouble value | [in] A number of whole and fractional seconds. This value can be negative or positive.
NDateTime_ * pResult | [out] Pointer to the modified DateTime instance.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDateTime.h

Module: NDateTime Unit


NDateTimeAddTicks Function

NDateTimeAddTicks Function

Adds the specified number of ticks to the value of the specified instance.

C++
NResult N_API NDateTimeAddTicks(NDateTime_ dateTime, NLong value, NDateTime_ * pResult);
Collapse Expand Parameters
Parameters | Description
NDateTime_ dateTime | [in] The original DateTime instance.
NLong value | [in] A number of 100-nanosecond ticks. This value can be negative or positive.
NDateTime_ * pResult | [out] Pointer to the modified DateTime instance.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDateTime.h

Module: NDateTime Unit


NDateTimeAddTimeSpan Function

NDateTimeAddTimeSpan Function

Adds the specified TimeSpan to the value of the specified instance.

C++
NResult N_API NDateTimeAddTimeSpan(NDateTime_ dateTime, NTimeSpan_ timeSpan, NDateTime_ * pResult);
Collapse Expand Parameters
Parameters | Description
NDateTime_ dateTime | [in] The original DateTime instance.
NTimeSpan_ timeSpan | [in] The TimeSpan that contains the interval to add.
NDateTime_ * pResult | [out] Pointer to the modified DateTime instance.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDateTime.h

Module: NDateTime Unit


NDateTimeAddYears Function

NDateTimeAddYears Function

Adds the specified number of years to the value of the specified instance.

C++
NResult N_API NDateTimeAddYears(NDateTime_ dateTime, NInt value, NDateTime_ * pResult);
Collapse Expand Parameters
Parameters | Description
NDateTime_ dateTime | [in] The original DateTime instance.
NInt value | [in] A number of whole and fractional years. This value can be negative or positive.
NDateTime_ * pResult | [out] Pointer to the modified DateTime instance.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDateTime.h

Module: NDateTime Unit


NDateTimeCompare Function

NDateTimeCompare Function

Compares two instances of DateTime and returns an indication of their relative values.

C++
NResult N_API NDateTimeCompare(NDateTime_ value1, NDateTime_ value2, NInt * pResult);
Collapse Expand Parameters
Parameters | Description
NDateTime_ value1 | [in] First DateTime instance.
NDateTime_ value2 | [in] Second DateTime instance.
NInt * pResult | [out] Pointer to an integer indicating the relative values of the instances.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDateTime.h

Module: NDateTime Unit


NDateTimeCreate Function

NDateTimeCreate Function

Initializes a new instance of the DateTime structure to the specified year, month, day, hour, minute, second and millisecond.

C++
NResult N_API NDateTimeCreate(NInt year, NInt month, NInt day, NInt hour, NInt minute, NInt second, NInt millisecond, NDateTime_ * pDateTime);
Collapse Expand Parameters
Parameters | Description
NInt year | [in] The year value.
NInt month | [in] The month value.
NInt day | [in] The day value.
NInt hour | [in] The hour value.
NInt minute | [in] The minute value.
NInt second | [in] The second value.
NInt millisecond | [in] The millisecond value.
NDateTime_ * pDateTime | [out] Pointer to the new DateTime instance.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDateTime.h

Module: NDateTime Unit


NDateTimeCreateDate Function

NDateTimeCreateDate Function

Initializes a new instance of the DateTime structure to the specified year, month and day.

C++
NResult N_API NDateTimeCreateDate(NInt year, NInt month, NInt day, NDateTime_ * pDateTime);
Collapse Expand Parameters
Parameters | Description
NInt year | [in] Years value.
NInt month | [in] Months value.
NInt day | [in] Days value.
NDateTime_ * pDateTime | [out] Pointer to the new DateTime instance.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDateTime.h

Module: NDateTime Unit


NDateTimeCreateFromTicks Function

NDateTimeCreateFromTicks Function

Initializes a new instance of the DateTime structure from the specified number of ticks.

C++
NResult N_API NDateTimeCreateFromTicks(NLong ticks, NDateTime_ * pDateTime);
Collapse Expand Parameters
Parameters | Description
NLong ticks | [in] Number of 100-nanosecond ticks.
NDateTime_ * pDateTime | [out] Pointer to the new DateTime instance.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDateTime.h

Module: NDateTime Unit


NDateTimeDaysInMonth Function

NDateTimeDaysInMonth Function

Gets the number of days the specified month of the specified year.

C++
NResult N_API NDateTimeDaysInMonth(NInt year, NInt month, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
NInt year | [in] The year.
NInt month | [in] The month.
NInt * pValue | [out] Pointer to the number of days.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDateTime.h

Module: NDateTime Unit


NDateTimeDecode Function

NDateTimeDecode Function

Decodes the specified DateTime instance.

C++
NResult N_API NDateTimeDecode(NDateTime_ dateTime, NInt * pYear, NInt * pDayOfYear, NInt * pMonth, NInt * pDay, NDayOfWeek * pDayOfWeek, NInt * pHour, NInt * pMinute, NInt * pSecond, NInt * pMillisecond);
Collapse Expand Parameters
Parameters | Description
NDateTime_ dateTime | [in] The DateTime instance to decode.
NInt * pYear | [out] Pointer to the years value.
NInt * pDayOfYear | [out] Pointer to the day of the year value.
NInt * pMonth | [out] Pointer to the months value.
NInt * pDay | [out] Pointer to the days value.
NDayOfWeek * pDayOfWeek | [out] Pointer to the day of week value.
NInt * pHour | [out] Pointer to the hours value.
NInt * pMinute | [out] Pointer to the minutes value.
NInt * pSecond | [out] Pointer to the seconds value.
NInt * pMillisecond | [out] Pointer to the milliseconds value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDateTime.h

Module: NDateTime Unit


NDateTimeGetDate Function

NDateTimeGetDate Function

Gets the date (year, month and day) represented by the specified DateTime instance.

C++
NResult N_API NDateTimeGetDate(NDateTime_ dateTime, NDateTime_ * pValue);
Collapse Expand Parameters
Parameters | Description
NDateTime_ dateTime | [in] The DateTime instance.
NDateTime_ * pValue | [out] Pointer to DateTime instance containing the date.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDateTime.h

Module: NDateTime Unit


NDateTimeGetDay Function

NDateTimeGetDay Function

Gets the day represented by the specified DateTime instance.

C++
NResult N_API NDateTimeGetDay(NDateTime_ dateTime, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
NDateTime_ dateTime | [in] The DateTime instance.
NInt * pValue | [out] Pointer to the day value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDateTime.h

Module: NDateTime Unit


NDateTimeGetDayOfWeek Function

NDateTimeGetDayOfWeek Function

Gets the day of the week represented by the specified DateTime instance.

C++
NResult N_API NDateTimeGetDayOfWeek(NDateTime_ dateTime, NDayOfWeek * pValue);
Collapse Expand Parameters
Parameters | Description
NDateTime_ dateTime | [in] The DateTime instance.
NDayOfWeek * pValue | [out] Pointer to the day of the week value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDateTime.h

Module: NDateTime Unit


NDateTimeGetDayOfYear Function

NDateTimeGetDayOfYear Function

Gets the day of the year represented by the specified DateTime instance.

C++
NResult N_API NDateTimeGetDayOfYear(NDateTime_ dateTime, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
NDateTime_ dateTime | [in] The DateTime instance.
NInt * pValue | [out] Pointer to the day of the year value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDateTime.h

Module: NDateTime Unit


NDateTimeGetHour Function

NDateTimeGetHour Function

Gets the hour represented by the specified DateTime instance.

C++
NResult N_API NDateTimeGetHour(NDateTime_ dateTime, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
NDateTime_ dateTime | [in] The DateTime instance.
NInt * pValue | [out] Pointer to the hour value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDateTime.h

Module: NDateTime Unit


NDateTimeGetMillisecond Function

NDateTimeGetMillisecond Function

Gets the millisecond represented by the specified DateTime instance.

C++
NResult N_API NDateTimeGetMillisecond(NDateTime_ dateTime, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
NDateTime_ dateTime | [in] The DateTime instance.
NInt * pValue | [out] Pointer to the millisecond value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDateTime.h

Module: NDateTime Unit


NDateTimeGetMinute Function

NDateTimeGetMinute Function

Gets the minute represented by the specified DateTime instance.

C++
NResult N_API NDateTimeGetMinute(NDateTime_ dateTime, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
NDateTime_ dateTime | [in] The DateTime instance.
NInt * pValue | [out] Pointer to the minute value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDateTime.h

Module: NDateTime Unit


NDateTimeGetMonth Function

NDateTimeGetMonth Function

Gets the month represented by the specified DateTime instance.

C++
NResult N_API NDateTimeGetMonth(NDateTime_ dateTime, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
NDateTime_ dateTime | [in] The DateTime instance.
NInt * pValue | [out] Pointer to the month value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDateTime.h

Module: NDateTime Unit


NDateTimeGetNow Function

NDateTimeGetNow Function

Gets current time of day.

C++
NResult N_API NDateTimeGetNow(NDateTime_ * pValue);
Collapse Expand Parameters
Parameters | Description
NDateTime_ * pValue | [out] Pointer to DateTime containing current time of day.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDateTime.h

Module: NDateTime Unit


NDateTimeGetSecond Function

NDateTimeGetSecond Function

Gets the second represented by the specified DateTime instance.

C++
NResult N_API NDateTimeGetSecond(NDateTime_ dateTime, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
NDateTime_ dateTime | [in] The DateTime instance.
NInt * pValue | [out] Pointer to the second value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDateTime.h

Module: NDateTime Unit


NDateTimeGetTicks Function

NDateTimeGetTicks Function

Gets the number of ticks that represent the specified DateTime instance.

C++
NResult N_API NDateTimeGetTicks(NDateTime_ dateTime, NLong * pValue);
Collapse Expand Parameters
Parameters | Description
NDateTime_ dateTime | [in] The DateTime instance.
NLong * pValue | [out] Pointer to the number of ticks.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDateTime.h

Module: NDateTime Unit


NDateTimeGetTimeOfDay Function

NDateTimeGetTimeOfDay Function

Gets the time of the day (hour, minute and second) represented by the specified DateTime instance.

C++
NResult N_API NDateTimeGetTimeOfDay(NDateTime_ dateTime, NTimeSpan_ * pValue);
Collapse Expand Parameters
Parameters | Description
NDateTime_ dateTime | [in] The DateTime instance.
NTimeSpan_ * pValue | [out] Pointer to DateTime containing the time of day.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDateTime.h

Module: NDateTime Unit


NDateTimeGetToday Function

NDateTimeGetToday Function

Gets today's date.

C++
NResult N_API NDateTimeGetToday(NDateTime_ * pValue);
Collapse Expand Parameters
Parameters | Description
NDateTime_ * pValue | [out] Pointer to DateTime containing today's date.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDateTime.h

Module: NDateTime Unit


NDateTimeGetUtcNow Function

NDateTimeGetUtcNow Function

Gets the current Coordinated Universal Time.

C++
NResult N_API NDateTimeGetUtcNow(NDateTime_ * pValue);
Collapse Expand Parameters
Parameters | Description
NDateTime_ * pValue | [out] Pointer to DateTime instance containing the current Coordinated Universal Time.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDateTime.h

Module: NDateTime Unit


NDateTimeGetYear Function

NDateTimeGetYear Function

Gets the year represented by the specified DateTime instance.

C++
NResult N_API NDateTimeGetYear(NDateTime_ dateTime, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
NDateTime_ dateTime | [in] The DateTime instance.
NInt * pValue | [out] Pointer to the year value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDateTime.h

Module: NDateTime Unit


NDateTimeIsDateTimeValid Function

NDateTimeIsDateTimeValid Function

Checks whether the specified date and time are valid.

C++
NBool N_API NDateTimeIsDateTimeValid(NInt year, NInt month, NInt day, NInt hour, NInt minute, NInt second, NInt millisecond);
Collapse Expand Parameters
Parameters | Description
NInt year | [in] Year value.
NInt month | [in] Month value.
NInt day | [in] Day value.
NInt hour | [in] Hour value.
NInt minute | [in] Minute value.
NInt second | [in] Second value.
NInt millisecond | [in] Millisecond value.
Collapse Expand Returns

NTrue if the date and time are valid; else NFalse.

Container

File: NDateTime.h

Module: NDateTime Unit


NDateTimeIsDateValid Function

NDateTimeIsDateValid Function

Checks whether the specified date is valid.

C++
NBool N_API NDateTimeIsDateValid(NInt year, NInt month, NInt day);
Collapse Expand Parameters
Parameters | Description
NInt year | [in] Year value.
NInt month | [in] Month value.
NInt day | [in] Day value.
Collapse Expand Returns

NTrue if the date is valid; else NFalse.

Container

File: NDateTime.h

Module: NDateTime Unit


NDateTimeIsLeapYear Function

NDateTimeIsLeapYear Function

Checks whether the specified year is a leap year (366 days).

C++
NResult N_API NDateTimeIsLeapYear(NInt year, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
NInt year | [in] The year to be checked.
NBool * pValue | [out] Pointer to NBool indicating whether the year is a leap year.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDateTime.h

Module: NDateTime Unit


NDateTimeIsValid Function

NDateTimeIsValid Function

Checks whether the specified DateTime instance is valid.

C++
NBool N_API NDateTimeIsValid(NDateTime_ value);
Collapse Expand Parameters
Parameters | Description
NDateTime_ value | [in] The DateTime instance.
Collapse Expand Returns

NTrue if the DateTime is valid; else NFalse.

Container

File: NDateTime.h

Module: NDateTime Unit


NDateTimeSubtract Function

NDateTimeSubtract Function

Subtracts a DateTime instance from another DateTime instance.

C++
NResult N_API NDateTimeSubtract(NDateTime_ value1, NDateTime_ value2, NTimeSpan_ * pTimeSpan);
Collapse Expand Parameters
Parameters | Description
NDateTime_ value1 | [in] The first DateTime instance.
NDateTime_ value2 | [in] The second DateTime instance.
NTimeSpan_ * pTimeSpan | [out] Pointer to the resulting DateTime instance.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDateTime.h

Module: NDateTime Unit


NDateTimeSubtractTimeSpan Function

NDateTimeSubtractTimeSpan Function

Subtracts the specified TimeSpan from the specified DateTime.

C++
NResult N_API NDateTimeSubtractTimeSpan(NDateTime_ dateTime, NTimeSpan_ timeSpan, NDateTime_ * pResult);
Collapse Expand Parameters
Parameters | Description
NDateTime_ dateTime | [in] The original DateTime instance.
NTimeSpan_ timeSpan | [in] The TimeSpan to subtract.
NDateTime_ * pResult | [out] Pointer to the resulting DateTime instance.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDateTime.h

Module: NDateTime Unit


NDateTimeToLocalTime Function

NDateTimeToLocalTime Function

Converts the specified DateTime to local time.

C++
NResult N_API NDateTimeToLocalTime(NDateTime_ dateTime, NDateTime_ * pValue);
Collapse Expand Parameters
Parameters | Description
NDateTime_ dateTime | [in] The DateTime instance to be coverted.
NDateTime_ * pValue | [out] Pointer to the converted DateTime instance.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDateTime.h

Module: NDateTime Unit


NDateTimeToString Function

NDateTimeToString Function

Gets a string representation of the specified DateTime.

C++
NResult N_API NDateTimeToString(NDateTime value, const NChar * szFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
NDateTime value | [in] DateTime object.
const NChar * szFormat | [in] Pointer to the format.
HNString * phValue | [out] Pointer to a handle to a string representing the DateTime object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDateTime.h

Module: NDateTime Unit


NDateTimeToUniversalTime Function

NDateTimeToUniversalTime Function

Converts the specified DateTime to Coordinated Universal Time.

C++
NResult N_API NDateTimeToUniversalTime(NDateTime_ dateTime, NDateTime_ * pValue);
Collapse Expand Parameters
Parameters | Description
NDateTime_ dateTime | [in] The DateTime instance to be coverted.
NDateTime_ * pValue | [out] Pointer to the converted DateTime instance.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDateTime.h

Module: NDateTime Unit


NDayOfWeek Enumeration

NDayOfWeek Enumeration

Enumerates the days of the week.

C++
typedef enum NDayOfWeek_ {
  ndowSunday = 0,
  ndowMonday = 1,
  ndowTuesday = 2,
  ndowWednesday = 3,
  ndowThursday = 4,
  ndowFriday = 5,
  ndowSaturday = 6
} NDayOfWeek;
Collapse Expand Members
Members | Description
ndowSunday = 0 | Sunday.
ndowMonday = 1 | Monday.
ndowTuesday = 2 | Tuesday.
ndowWednesday = 3 | Wednesday.
ndowThursday = 4 | Thursday.
ndowFriday = 5 | Friday.
ndowSaturday = 6 | Saturday.
Container

File: NDateTime.h

Module: NDateTime Unit


NDateTime_ Type

NDateTime_ Type

The DateTime instance.

C++
typedef NLong NDateTime_;
Container

File: NDateTime.h

Module: NDateTime Unit


NDateTimeToString Macro

NDateTimeToString Macro

Picks a Unicode (W) or ASCII (A) version of the NDateTimeToString function.

C++
#define NDateTimeToString N_FUNC_AW(NDateTimeToString)
Container

File: NDateTime.h

Module: NDateTime Unit


N_DATE_TIME_MAX Macro

N_DATE_TIME_MAX Macro

Maximum DateTime value.

C++
#define N_DATE_TIME_MAX 3155378975999999999LL
Container

File: NDateTime.h

Module: NDateTime Unit


N_DATE_TIME_MIN Macro

N_DATE_TIME_MIN Macro

Minimum DateTime value.

C++
#define N_DATE_TIME_MIN 0LL
Container

File: NDateTime.h

Module: NDateTime Unit


NDefs Unit

NDefs Unit
Macros

Enumerates Neurotechnology defines.

Collapse Expand Macros
Name | Description
N_64 | Defined if compiling for 64-bit architecture.
N_ALIGN | Controls the alignment of user-defined data
N_ANSI_C | Defined if ANSI C language compliance is enabled in compiler.
N_API | Defines calling conventions for functions. Tells the compiler that the declared function and the functions it calls never throw an exception.
N_API_PTR_RET | Defines calling conventions for functions. Tells the compiler that the declared function and the functions it calls never throw an exception. Used for functions that return a pointer.
N_AW | Picks either ANSI or Unicode (if N_UNICODE is defined) version in a macro (with either 'A' or 'W' suffix accordingly).
N_BIG_ENDIAN | Defined if compiling for big-endian processor architecture.
N_CALLBACK | Callback.
N_CALLBACK_AW | Picks either ANSI or Unicode (if N_UNICODE is defined) version of the callback (with either 'A' or 'W' suffix accordingly).
N_CALL_CONV | Defines calling conventions for functions.
N_CPP | Defined if compiling as C++ code.
N_DEBUG | Defined if compiling in debug mode.
N_DEPRECATED | Indicates that a function, type, or any other identifier may no longer be supported in a future release or should no longer be used.
N_EMPTY_STRING | ANSI or Unicode (if N_UNICODE is defined) string, representing empty string value.
N_EMPTY_STRINGA | ANSI string, representing empty string value.
N_EMPTY_STRINGW | Unicode (if N_UNICODE is defined) string, representing empty string value.
N_FIELD_AW | Picks either ANSI or Unicode (if N_UNICODE is defined) version of the field (with either 'A' or 'W' suffix accordingly).
N_FUNC_AW | Picks either ANSI or Unicode (if N_UNICODE is defined) version of the function (with either 'A' or 'W' suffix accordingly).
N_GCC | Defined if compiling with GCC.
N_JOIN_SYMBOLS | Concatenates two symbols, yielding a single concatenated symbol.
N_JOIN_SYMBOLS2 | Concatenates two symbols, yielding a single concatenated symbol.
N_JOIN_SYMBOLS2_ | Concatenates two symbols, yielding a single concatenated symbol. Can serve as a macro argument.
N_JOIN_SYMBOLS_ | Concatenates two symbols, yielding a single concatenated symbol. Can serve as a macro argument.
N_LIB | Defined if compiling static library.
N_LIKELY | Used for Linux branching optimization.
N_LINUX | Defined if compiling for Linux.
N_MAC | Defined if compiling for Mac OS.
N_MACRO_AW | Picks either ANSI or Unicode (if N_UNICODE is defined) version of the macro (with either 'A' or 'W' suffix accordingly).
N_MSVC | Defined if compiling with Microsoft Visual C++.
N_NEW_LINE | Picks a Unicode (W) or ASCII (A) version of the N_NEW_LINE macro.
N_NO_ANSI_FUNC | Defined if compiling for platform without ANSI versions of the functions support.
N_NO_INLINE | Tells the compiler to never inline a particular member function (function in a class).
N_NO_INT_64 | Defined if compiling for platform without 64-bit integer types support.
N_NO_RETURN | Tells the compiler that a function does not return.
N_NO_THROW | Tells the compiler that the declared function and the functions it calls never throw an exception.
N_NO_UNICODE | Defined if compiling for platform without Unicode versions of the functions support.
N_PACKED | Struct packing/alignment.
N_RETURN_ADDRESS | The memory address a return statement hands control of a computer program to.
N_STATIC_ASSERT | Evaluate an expression at compile time and generate an error when the result is NFalse.
N_STRINGIZE | Defines the size of ANSI or Unicode (if N_UNICODE is defined) string.
N_STRINGIZEA | Defines the size of ANSI string.
N_STRINGIZEW | Defines the size of Unicode (if N_UNICODE is defined) string.
N_STRINGIZE_ | Defines the size of ANSI or Unicode (if N_UNICODE is defined) string. Can serve as a macro argument.
N_STRINGIZE_A | Defines the size of ANSI string. Can serve as a macro argument.
N_STRINGIZE_W | Defines the size of Unicode (if N_UNICODE is defined) string. Can serve as a macro argument.
N_STRUCT_AW | Picks either ANSI or Unicode (if N_UNICODE is defined) version of the struct (with either 'A' or 'W' suffix accordingly).
N_SYMBOL_AW | Picks either ANSI or Unicode (if N_UNICODE is defined) version of the symbol (with either 'A' or 'W' suffix accordingly).
N_T | Makes either ANSI or Unicode (if N_UNICODE is defined) string or character constant.
N_TA | Makes ANSI string or character constant.
N_TRACE | Defined if trace output is enabled during compilation.
N_TW | Makes Unicode (if N_UNICODE is defined) string or character constant.
N_TYPE_AW | Picks either ANSI or Unicode (if N_UNICODE is defined) version of the type (with either 'A' or 'W' suffix accordingly).
N_T_A | Makes ANSI string or character constant. Can serve as a macro argument.
N_T_W | Makes Unicode (if N_UNICODE is defined) string or character constant. Can serve as a macro argument.
N_UNICODE | Defined if compiling with Unicode character set (affects NChar type).
N_UNLIKELY | Used for Linux branching optimization.
N_VAR_AW | Picks either ANSI or Unicode (if N_UNICODE is defined) version of the variable (with either 'A' or 'W' suffix accordingly).
N_WINDOWS | Defined if compiling for Windows.


N_64 Macro

N_64 Macro

Defined if compiling for 64-bit architecture.

C++
#define N_64
Container

File: NDefs.h

Module: NDefs Unit


N_ALIGN Macro

N_ALIGN Macro

Controls the alignment of user-defined data

C++
#define N_ALIGN(x)
Container

File: NDefs.h

Module: NDefs Unit


N_ANSI_C Macro

N_ANSI_C Macro

Defined if ANSI C language compliance is enabled in compiler.

C++
#define N_ANSI_C
Container

File: NDefs.h

Module: NDefs Unit


N_API Macro

N_API Macro

Defines calling conventions for functions. Tells the compiler that the declared function and the functions it calls never throw an exception.

C++
#define N_API N_NO_THROW N_CALL_CONV
Container

File: NDefs.h

Module: NDefs Unit


N_API_PTR_RET Macro

N_API_PTR_RET Macro

Defines calling conventions for functions. Tells the compiler that the declared function and the functions it calls never throw an exception.

Used for functions that return a pointer.

C++
#define N_API_PTR_RET N_NO_THROW N_CALL_CONV
Container

File: NDefs.h

Module: NDefs Unit


N_AW Macro

N_AW Macro

Picks either ANSI or Unicode (if N_UNICODE is defined) version in a macro (with either 'A' or 'W' suffix accordingly).

C++
#define N_AW A
Container

File: NDefs.h

Module: NDefs Unit


N_BIG_ENDIAN Macro

N_BIG_ENDIAN Macro

Defined if compiling for big-endian processor architecture.

C++
#define N_BIG_ENDIAN
Container

File: NDefs.h

Module: NDefs Unit


N_CALLBACK Macro

N_CALLBACK Macro

Callback.

C++
#define N_CALLBACK N_CALL_CONV *
Container

File: NDefs.h

Module: NDefs Unit


N_CALLBACK_AW Macro

N_CALLBACK_AW Macro

Picks either ANSI or Unicode (if N_UNICODE is defined) version of the callback (with either 'A' or 'W' suffix accordingly).

C++
#define N_CALLBACK_AW(name) N_SYMBOL_AW(name)
Container

File: NDefs.h

Module: NDefs Unit


N_CALL_CONV Macro

N_CALL_CONV Macro

Defines calling conventions for functions.

C++
#define N_CALL_CONV
Container

File: NDefs.h

Module: NDefs Unit


N_CPP Macro

N_CPP Macro

Defined if compiling as C++ code.

C++
#define N_CPP
Container

File: NDefs.h

Module: NDefs Unit


N_DEBUG Macro

N_DEBUG Macro

Defined if compiling in debug mode.

C++
#define N_DEBUG
Container

File: NDefs.h

Module: NDefs Unit


N_DEPRECATED Macro

N_DEPRECATED Macro

Indicates that a function, type, or any other identifier may no longer be supported in a future release or should no longer be used.

C++
#define N_DEPRECATED(message)
Container

File: NDefs.h

Module: NDefs Unit


N_EMPTY_STRING Macro

N_EMPTY_STRING Macro

ANSI or Unicode (if N_UNICODE is defined) string, representing empty string value.

C++
#define N_EMPTY_STRING N_EMPTY_STRINGA
Container

File: NDefs.h

Module: NDefs Unit


N_EMPTY_STRINGA Macro

N_EMPTY_STRINGA Macro

ANSI string, representing empty string value.

C++
#define N_EMPTY_STRINGA ""
Container

File: NDefs.h

Module: NDefs Unit


N_EMPTY_STRINGW Macro

N_EMPTY_STRINGW Macro

Unicode (if N_UNICODE is defined) string, representing empty string value.

C++
#define N_EMPTY_STRINGW L""
Container

File: NDefs.h

Module: NDefs Unit


N_FIELD_AW Macro

N_FIELD_AW Macro

Picks either ANSI or Unicode (if N_UNICODE is defined) version of the field (with either 'A' or 'W' suffix accordingly).

C++
#define N_FIELD_AW(name) N_SYMBOL_AW(name)
Container

File: NDefs.h

Module: NDefs Unit


N_FUNC_AW Macro

N_FUNC_AW Macro

Picks either ANSI or Unicode (if N_UNICODE is defined) version of the function (with either 'A' or 'W' suffix accordingly).

C++
#define N_FUNC_AW(name) N_SYMBOL_AW(name)
Container

File: NDefs.h

Module: NDefs Unit


N_GCC Macro

N_GCC Macro

Defined if compiling with GCC.

C++
#define N_GCC
Container

File: NDefs.h

Module: NDefs Unit


N_JOIN_SYMBOLS Macro

N_JOIN_SYMBOLS Macro

Concatenates two symbols, yielding a single concatenated symbol.

C++
#define N_JOIN_SYMBOLS(name1, name2) N_JOIN_SYMBOLS_(name1, name2)
Container

File: NDefs.h

Module: NDefs Unit


N_JOIN_SYMBOLS2 Macro

N_JOIN_SYMBOLS2 Macro

Concatenates two symbols, yielding a single concatenated symbol.

C++
#define N_JOIN_SYMBOLS2(name1, name2) N_JOIN_SYMBOLS2_(name1, name2)
Container

File: NDefs.h

Module: NDefs Unit


N_JOIN_SYMBOLS2_ Macro

N_JOIN_SYMBOLS2_ Macro

Concatenates two symbols, yielding a single concatenated symbol. Can serve as a macro argument.

C++
#define N_JOIN_SYMBOLS2_(name1, name2) name1##name2
Container

File: NDefs.h

Module: NDefs Unit


N_JOIN_SYMBOLS_ Macro

N_JOIN_SYMBOLS_ Macro

Concatenates two symbols, yielding a single concatenated symbol. Can serve as a macro argument.

C++
#define N_JOIN_SYMBOLS_(name1, name2) name1##name2
Container

File: NDefs.h

Module: NDefs Unit


N_LIB Macro

N_LIB Macro

Defined if compiling static library.

C++
#define N_LIB
Container

File: NDefs.h

Module: NDefs Unit


N_LIKELY Macro

N_LIKELY Macro

Used for Linux branching optimization.

C++
#define N_LIKELY(x) (x)
Container

File: NDefs.h

Module: NDefs Unit


N_LINUX Macro

N_LINUX Macro

Defined if compiling for Linux.

C++
#define N_LINUX
Container

File: NDefs.h

Module: NDefs Unit


N_MAC Macro

N_MAC Macro

Defined if compiling for Mac OS.

C++
#define N_MAC
Container

File: NDefs.h

Module: NDefs Unit


N_MACRO_AW Macro

N_MACRO_AW Macro

Picks either ANSI or Unicode (if N_UNICODE is defined) version of the macro (with either 'A' or 'W' suffix accordingly).

C++
#define N_MACRO_AW(name) N_SYMBOL_AW(name)
Container

File: NDefs.h

Module: NDefs Unit


N_MSVC Macro

N_MSVC Macro

Defined if compiling with Microsoft Visual C++.

C++
#define N_MSVC
Container

File: NDefs.h

Module: NDefs Unit


N_NEW_LINE Macro

N_NEW_LINE Macro

Picks a Unicode (W) or ASCII (A) version of the N_NEW_LINE macro.

C++
#define N_NEW_LINE N_MACRO_AW(N_NEW_LINE)
Container

File: NDefs.h

Module: NDefs Unit


N_NO_ANSI_FUNC Macro

N_NO_ANSI_FUNC Macro

Defined if compiling for platform without ANSI versions of the functions support.

C++
#define N_NO_ANSI_FUNC
Container

File: NDefs.h

Module: NDefs Unit


N_NO_INLINE Macro

N_NO_INLINE Macro

Tells the compiler to never inline a particular member function (function in a class).

C++
#define N_NO_INLINE
Container

File: NDefs.h

Module: NDefs Unit


N_NO_INT_64 Macro

N_NO_INT_64 Macro

Defined if compiling for platform without 64-bit integer types support.

C++
#define N_NO_INT_64
Container

File: NDefs.h

Module: NDefs Unit


N_NO_RETURN Macro

N_NO_RETURN Macro

Tells the compiler that a function does not return.

C++
#define N_NO_RETURN
Container

File: NDefs.h

Module: NDefs Unit


N_NO_THROW Macro

N_NO_THROW Macro

Tells the compiler that the declared function and the functions it calls never throw an exception.

C++
#define N_NO_THROW
Container

File: NDefs.h

Module: NDefs Unit


N_NO_UNICODE Macro

N_NO_UNICODE Macro

Defined if compiling for platform without Unicode versions of the functions support.

C++
#define N_NO_UNICODE
Container

File: NDefs.h

Module: NDefs Unit


N_PACKED Macro

N_PACKED Macro

Struct packing/alignment.

C++
#define N_PACKED
Container

File: NDefs.h

Module: NDefs Unit


N_RETURN_ADDRESS Macro

N_RETURN_ADDRESS Macro

The memory address a return statement hands control of a computer program to.

C++
#define N_RETURN_ADDRESS NULL
Container

File: NDefs.h

Module: NDefs Unit


N_STATIC_ASSERT Macro

N_STATIC_ASSERT Macro

Evaluate an expression at compile time and generate an error when the result is NFalse.

C++
#define N_STATIC_ASSERT(x) ((void)N_STATIC_ASSERT_EX(x))
Container

File: NDefs.h

Module: NDefs Unit


N_STRINGIZE Macro

N_STRINGIZE Macro

Defines the size of ANSI or Unicode (if N_UNICODE is defined) string.

C++
#define N_STRINGIZE N_STRINGIZEA
Container

File: NDefs.h

Module: NDefs Unit


N_STRINGIZEA Macro

N_STRINGIZEA Macro

Defines the size of ANSI string.

C++
#define N_STRINGIZEA(value) N_STRINGIZE_A(value)
Container

File: NDefs.h

Module: NDefs Unit


N_STRINGIZEW Macro

N_STRINGIZEW Macro

Defines the size of Unicode (if N_UNICODE is defined) string.

C++
#define N_STRINGIZEW(value) N_STRINGIZE_W(value)
Container

File: NDefs.h

Module: NDefs Unit


N_STRINGIZE_ Macro

N_STRINGIZE_ Macro

Defines the size of ANSI or Unicode (if N_UNICODE is defined) string. Can serve as a macro argument.

C++
#define N_STRINGIZE_ N_STRINGIZE_A
Container

File: NDefs.h

Module: NDefs Unit


N_STRINGIZE_A Macro

N_STRINGIZE_A Macro

Defines the size of ANSI string. Can serve as a macro argument.

C++
#define N_STRINGIZE_A(value) N_TA(#value)
Container

File: NDefs.h

Module: NDefs Unit


N_STRINGIZE_W Macro

N_STRINGIZE_W Macro

Defines the size of Unicode (if N_UNICODE is defined) string. Can serve as a macro argument.

C++
#define N_STRINGIZE_W(value) N_TW(#value)
Container

File: NDefs.h

Module: NDefs Unit


N_STRUCT_AW Macro

N_STRUCT_AW Macro

Picks either ANSI or Unicode (if N_UNICODE is defined) version of the struct (with either 'A' or 'W' suffix accordingly).

C++
#define N_STRUCT_AW(name) N_SYMBOL_AW(name)
Container

File: NDefs.h

Module: NDefs Unit


N_SYMBOL_AW Macro

N_SYMBOL_AW Macro

Picks either ANSI or Unicode (if N_UNICODE is defined) version of the symbol (with either 'A' or 'W' suffix accordingly).

C++
#define N_SYMBOL_AW(name) N_JOIN_SYMBOLS2(name, N_AW)
Container

File: NDefs.h

Module: NDefs Unit


N_T Macro

N_T Macro

Makes either ANSI or Unicode (if N_UNICODE is defined) string or character constant.

C++
#define N_T N_TA
Container

File: NDefs.h

Module: NDefs Unit


N_TA Macro

N_TA Macro

Makes ANSI string or character constant.

C++
#define N_TA(text) N_T_A(text)
Container

File: NDefs.h

Module: NDefs Unit


N_TRACE Macro

N_TRACE Macro

Defined if trace output is enabled during compilation.

C++
#define N_TRACE
Container

File: NDefs.h

Module: NDefs Unit


N_TW Macro

N_TW Macro

Makes Unicode (if N_UNICODE is defined) string or character constant.

C++
#define N_TW(text) N_T_W(text)
Container

File: NDefs.h

Module: NDefs Unit


N_TYPE_AW Macro

N_TYPE_AW Macro

Picks either ANSI or Unicode (if N_UNICODE is defined) version of the type (with either 'A' or 'W' suffix accordingly).

C++
#define N_TYPE_AW(name) N_SYMBOL_AW(name)
Container

File: NDefs.h

Module: NDefs Unit


N_T_A Macro

N_T_A Macro

Makes ANSI string or character constant. Can serve as a macro argument.

C++
#define N_T_A(text) text
Container

File: NDefs.h

Module: NDefs Unit


N_T_W Macro

N_T_W Macro

Makes Unicode (if N_UNICODE is defined) string or character constant. Can serve as a macro argument.

C++
#define N_T_W(text) L##text
Container

File: NDefs.h

Module: NDefs Unit


N_UNICODE Macro

N_UNICODE Macro

Defined if compiling with Unicode character set (affects NChar type).

C++
#define N_UNICODE
Container

File: NDefs.h

Module: NDefs Unit


N_UNLIKELY Macro

N_UNLIKELY Macro

Used for Linux branching optimization.

C++
#define N_UNLIKELY(x) (x)
Container

File: NDefs.h

Module: NDefs Unit


N_VAR_AW Macro

N_VAR_AW Macro

Picks either ANSI or Unicode (if N_UNICODE is defined) version of the variable (with either 'A' or 'W' suffix accordingly).

C++
#define N_VAR_AW(name) N_SYMBOL_AW(name)
Container

File: NDefs.h

Module: NDefs Unit


N_WINDOWS Macro

N_WINDOWS Macro

Defined if compiling for Windows.

C++
#define N_WINDOWS
Container

File: NDefs.h

Module: NDefs Unit


NDescriptor Unit

NDescriptor Unit
Files Functions Legend

Provides descriptor management functionality.

Collapse Expand Files
Name | Description
NDescriptor.h | Header file for the NDescriptor unit.
Collapse Expand Functions
Name | Description
NDescriptorGetAttributes | Retrieves the attributes of the specified descriptor.
NDescriptorGetName | Retrieves the name of the specified descriptor.


NDescriptorGetAttributes Function

NDescriptorGetAttributes Function
NDescriptor.h

Retrieves the attributes of the specified descriptor.

C++
NResult N_API NDescriptorGetAttributes(HNDescriptor hDescriptor, NAttributes * pValue);
Collapse Expand Parameters
Parameters | Description
HNDescriptor hDescriptor | [in] Handle to the descriptor.
NAttributes * pValue | [out] Pointer to the attributes of the descriptor.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDescriptor.h

Module: NDescriptor Unit


NDescriptorGetName Function

NDescriptorGetName Function
NDescriptor.h

Retrieves the name of the specified descriptor.

C++
NResult N_API NDescriptorGetName(HNDescriptor hDescriptor, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNDescriptor hDescriptor | [in] Handle to the descriptor.
HNString * phValue | [out] Pointer to the name of the descriptor.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDescriptor.h

Module: NDescriptor Unit


NDescriptor.h

NDescriptor.h
Functions Legend

Header file for the NDescriptor unit.

Collapse Expand Functions
Name | Description
NDescriptorGetAttributes | Retrieves the attributes of the specified descriptor.
NDescriptorGetName | Retrieves the name of the specified descriptor.


NDictionary Unit

NDictionary Unit
Files Functions Legend

Provides information about tables, classes, extended data types, and other items in the Application Object Tree.

Collapse Expand Files
Name | Description
NDictionary.h | Header file for the NDictionary module.
Collapse Expand Functions
Name | Description
NDictionaryAdd | Adds a value to the specified dictionary.
NDictionaryAddCollectionChanged | Adds a user-specified "collection changed" event to the specified dictionary.
NDictionaryAddCollectionChangedCallback | Adds a user-specified "collection changed" event callback to the specified dictionary.
NDictionaryAddItemCollectionChanged | Adds a user-specified "item collection changed" event to the specified dictionary.
NDictionaryAddItemCollectionChangedCallback | Adds a user-specified "item collection changed" event callback to the specified dictionary.
NDictionaryAddItemPair | Adds a pair item to the specified dictionary.
NDictionaryAddPair | Adds a pair item to the specified dictionary.
NDictionaryClear | Clears the specified dictionary.
NDictionaryContains | Checks whether the specified dictionary contains a value specified by its key.
NDictionaryGet | Retrieves the value specified by key from the specified dictionary.
NDictionaryGetAt | Retrieves the item specified by index from the specified dictionary.
NDictionaryGetCount | Retrieves the number of items in the specified dictionary.
NDictionaryGetItemAt | Retrieves the item specified by index from the specified dictionary.
NDictionaryGetKey | Retrieves the key of an item specified by index from the specified dictionary.
NDictionaryGetKeys | Retrieves all keys from the specified dictionary.
NDictionaryGetValue | Retrieves the value of an item specified by index from the specified dictionary.
NDictionaryGetValues | Retrieves all values from the specified dictionary.
NDictionaryIsReadOnly | Checks whether the specified dictionary is read-only.
NDictionaryRemove | Removes the value specified by key from the specified dictionary.
NDictionaryRemoveAt | Removes an item specified by index from the specified dictionary.
NDictionaryRemoveCollectionChanged | Removes a user-specified "collection changed" event from the specified dictionary.
NDictionaryRemoveCollectionChangedCallback |
NDictionaryRemoveItemCollectionChanged | Removes a user-specified "item collection changed" event from the specified dictionary.
NDictionaryRemoveItemCollectionChangedCallback |
NDictionarySet | Sets the value specified by key in the specified dictionary.
NDictionaryToArray | Converts the specified dictionary to an array.
NDictionaryToItemArray | Converts the specified dictionary to an array of items.
NDictionaryToKeyArray | Converts the specified dictionary to an array of keys.
NDictionaryToValueArray | Converts the specified dictionary to an array of values.
NDictionaryTryGet | Attempts to retrieve the value specified by key from the specified dictionary and returns a Boolean value indicating the success.


NDictionaryAdd Function

NDictionaryAdd Function
NDictionary.h

Adds a value to the specified dictionary.

C++
NResult N_API NDictionaryAdd(HNDictionary hDictionary, HNType hKeyType, NAttributes keyAttributes, const void * pKey, NSizeType keySize, HNType hValueType, NAttributes valueAttributes, const void * pValue, NSizeType valueSize);
Collapse Expand Parameters
Parameters | Description
HNDictionary hDictionary | [in] Handle to the dictionary.
HNType hKeyType | [in] Value key type.
NAttributes keyAttributes | [in] Value key attributes.
const void * pKey | [in] Pointer to the value key.
NSizeType keySize | [in] Size of the value key.
HNType hValueType | [in] Value type.
NAttributes valueAttributes | [in] Value attributes.
const void * pValue | [in] Pointer to the value.
NSizeType valueSize | [in] Size of the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionary.h

Module: NDictionary Unit


NDictionaryAddCollectionChanged Function

NDictionaryAddCollectionChanged Function
NDictionary.h

Adds a user-specified "collection changed" event to the specified dictionary.

C++
NResult N_API NDictionaryAddCollectionChanged(HNDictionary hDictionary, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNDictionary hDictionary | [in] Handle to the dictionary.
HNCallback hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionary.h

Module: NDictionary Unit


NDictionaryAddCollectionChangedCallback Function

NDictionaryAddCollectionChangedCallback Function
NDictionary.h

Adds a user-specified "collection changed" event callback to the specified dictionary.

C++
NResult N_API NDictionaryAddCollectionChangedCallback(HNDictionary hDictionary, NDictionaryCollectionChangedCallback pCallback, void * pParam);
Collapse Expand Parameters
Parameters | Description
HNDictionary hDictionary | [in] Handle to the dictionary.
NDictionaryCollectionChangedCallback pCallback | [in] The event callback.
void * pParam | [out] Parameters provided to the callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionary.h

Module: NDictionary Unit


NDictionaryAddItemCollectionChanged Function

NDictionaryAddItemCollectionChanged Function
NDictionary.h

Adds a user-specified "item collection changed" event to the specified dictionary.

C++
NResult N_API NDictionaryAddItemCollectionChanged(HNDictionary hDictionary, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNDictionary hDictionary | [in] Handle to the dictionary.
HNCallback hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionary.h

Module: NDictionary Unit


NDictionaryAddItemCollectionChangedCallback Function

NDictionaryAddItemCollectionChangedCallback Function
NDictionary.h

Adds a user-specified "item collection changed" event callback to the specified dictionary.

C++
NResult N_API NDictionaryAddItemCollectionChangedCallback(HNDictionary hDictionary, NCollectionItemCollectionChangedCallback pCallback, void * pParam);
Collapse Expand Parameters
Parameters | Description
HNDictionary hDictionary | [in] Handle to the dictionary.
NCollectionItemCollectionChangedCallback pCallback | [in] The event callback.
void * pParam | [out] Parameters provided to the callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionary.h

Module: NDictionary Unit


NDictionaryAddItemPair Function

NDictionaryAddItemPair Function
NDictionary.h

Adds a pair item to the specified dictionary.

C++
NResult N_API NDictionaryAddItemPair(HNDictionary hDictionary, HNValue hItem);
Collapse Expand Parameters
Parameters | Description
HNDictionary hDictionary | [in] Handle to the dictionary.
HNValue hItem | [in] Handle to the key-value pair item.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionary.h

Module: NDictionary Unit


NDictionaryAddPair Function

NDictionaryAddPair Function
NDictionary.h

Adds a pair item to the specified dictionary.

C++
NResult N_API NDictionaryAddPair(HNDictionary hDictionary, HNType hItemType, NAttributes itemAttributes, const void * pItem, NSizeType itemSize);
Collapse Expand Parameters
Parameters | Description
HNDictionary hDictionary | [in] Handle to the dictionary.
HNType hItemType | [in] Handle to the type of the item.
NAttributes itemAttributes | [in] Item attributes.
const void * pItem | [in] Pointer to the item.
NSizeType itemSize | [in] Size of the item.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionary.h

Module: NDictionary Unit


NDictionaryClear Function

NDictionaryClear Function
NDictionary.h

Clears the specified dictionary.

C++
NResult N_API NDictionaryClear(HNDictionary hDictionary);
Collapse Expand Parameters
Parameters | Description
HNDictionary hDictionary | [in] Handle to the dictionary.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionary.h

Module: NDictionary Unit


NDictionaryContains Function

NDictionaryContains Function
NDictionary.h

Checks whether the specified dictionary contains a value specified by its key.

C++
NResult N_API NDictionaryContains(HNDictionary hDictionary, HNType hKeyType, NAttributes keyAttributes, const void * pKey, NSizeType keySize, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNDictionary hDictionary | [in] Handle to the dictionary.
HNType hKeyType | [in] Value key type.
NAttributes keyAttributes | [in] Value key attributes.
const void * pKey | [in] Pointer to the value key.
NSizeType keySize | [in] Size of the value key.
NBool * pResult | [out] NTrue if the dictionary contains the value; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionary.h

Module: NDictionary Unit


NDictionaryGet Function

NDictionaryGet Function
NDictionary.h

Retrieves the value specified by key from the specified dictionary.

C++
NResult N_API NDictionaryGet(HNDictionary hDictionary, HNType hKeyType, NAttributes keyAttributes, const void * pKey, NSizeType keySize, HNType hValueType, NAttributes valueAttributes, void * pValue, NSizeType valueSize);
Collapse Expand Parameters
Parameters | Description
HNDictionary hDictionary | [in] Handle to the dictionary.
HNType hKeyType | [in] Value key type.
NAttributes keyAttributes | [in] Value key attributes.
const void * pKey | [in] Pointer to the value key.
NSizeType keySize | [in] Size of the value key.
HNType hValueType | [in] Value type.
NAttributes valueAttributes | [in] Value attributes.
void * pValue | [out] Pointer to the value.
NSizeType valueSize | [in] Size of the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionary.h

Module: NDictionary Unit


NDictionaryGetAt Function

NDictionaryGetAt Function
NDictionary.h

Retrieves the item specified by index from the specified dictionary.

C++
NResult N_API NDictionaryGetAt(HNDictionary hDictionary, NInt index, HNType hItemType, NAttributes itemAttributes, void * pItem, NSizeType itemSize);
Collapse Expand Parameters
Parameters | Description
HNDictionary hDictionary | [in] Handle to the dictionary.
NInt index | [in] Index of the item.
HNType hItemType | [in] Handle to the type of the item.
NAttributes itemAttributes | [in] Item attributes.
void * pItem | [out] Pointer to the item.
NSizeType itemSize | [in] Size of the item.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionary.h

Module: NDictionary Unit


NDictionaryGetCount Function

NDictionaryGetCount Function
NDictionary.h

Retrieves the number of items in the specified dictionary.

C++
NResult N_API NDictionaryGetCount(HNDictionary hDictionary, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNDictionary hDictionary | [in] Handle to the dictionary.
NInt * pValue | [out] Pointer to the number of items in the dictionary.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionary.h

Module: NDictionary Unit


NDictionaryGetItemAt Function

NDictionaryGetItemAt Function
NDictionary.h

Retrieves the item specified by index from the specified dictionary.

C++
NResult N_API NDictionaryGetItemAt(HNDictionary hDictionary, NInt index, HNValue * phItem);
Collapse Expand Parameters
Parameters | Description
HNDictionary hDictionary | [in] Handle to the dictionary.
NInt index | [in] Index of the item.
HNValue * phItem | [out] Pointer to the item value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionary.h

Module: NDictionary Unit


NDictionaryGetKey Function

NDictionaryGetKey Function
NDictionary.h

Retrieves the key of an item specified by index from the specified dictionary.

C++
NResult N_API NDictionaryGetKey(HNDictionary hDictionary, NInt index, HNType hKeyType, NAttributes keyAttributes, void * pKey, NSizeType keySize);
Collapse Expand Parameters
Parameters | Description
HNDictionary hDictionary | [in] Handle to the dictionary.
NInt index | [in] Index of the item.
HNType hKeyType | [in] Key type.
NAttributes keyAttributes | [in] Key attributes.
void * pKey | [out] Pointer to the key.
NSizeType keySize | [in] Size of the key.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionary.h

Module: NDictionary Unit


NDictionaryGetKeys Function

NDictionaryGetKeys Function
NDictionary.h

Retrieves all keys from the specified dictionary.

C++
NResult N_API NDictionaryGetKeys(HNDictionary hDictionary, HNType hKeyType, NAttributes keyAttributes, NSizeType keySize, void * * parKeys, NInt * pKeyCount);
Collapse Expand Parameters
Parameters | Description
HNDictionary hDictionary | [in] Handle to the dictionary.
HNType hKeyType | [in] Keys type.
NAttributes keyAttributes | [in] Keys attributes.
NSizeType keySize | [in] Size of a key.
void * * parKeys | [out] Pointer to the array of keys.
NInt * pKeyCount | [out] Pointer to the number of keys in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionary.h

Module: NDictionary Unit


NDictionaryGetValue Function

NDictionaryGetValue Function
NDictionary.h

Retrieves the value of an item specified by index from the specified dictionary.

C++
NResult N_API NDictionaryGetValue(HNDictionary hDictionary, NInt index, HNType hValueType, NAttributes valueAttributes, void * pValue, NSizeType valueSize);
Collapse Expand Parameters
Parameters | Description
HNDictionary hDictionary | [in] Handle to the dictionary.
NInt index | [in] Index of the item.
HNType hValueType | [in] Value type.
NAttributes valueAttributes | [in] Value attributes.
void * pValue | [out] Pointer to the value.
NSizeType valueSize | [in] Size of the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionary.h

Module: NDictionary Unit


NDictionaryGetValues Function

NDictionaryGetValues Function
NDictionary.h

Retrieves all values from the specified dictionary.

C++
NResult N_API NDictionaryGetValues(HNDictionary hDictionary, HNType hValueType, NAttributes valueAttributes, NSizeType valueSize, void * * parValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNDictionary hDictionary | [in] Handle to the dictionary.
HNType hValueType | [in] Values type.
NAttributes valueAttributes | [in] Values attributes.
NSizeType valueSize | [in] Size of a value.
void * * parValues | [out] Pointer to the array of values.
NInt * pValueCount | [out] Pointer to the number of values in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionary.h

Module: NDictionary Unit


NDictionaryIsReadOnly Function

NDictionaryIsReadOnly Function
NDictionary.h

Checks whether the specified dictionary is read-only.

C++
NResult N_API NDictionaryIsReadOnly(HNDictionary hDictionary, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNDictionary hDictionary | [in] Handle to the dictionary.
NBool * pValue | [out] NTrue if the dictionary is red-only; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionary.h

Module: NDictionary Unit


NDictionaryRemove Function

NDictionaryRemove Function
NDictionary.h

Removes the value specified by key from the specified dictionary.

C++
NResult N_API NDictionaryRemove(HNDictionary hDictionary, HNType hKeyType, NAttributes keyAttributes, const void * pKey, NSizeType keySize, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNDictionary hDictionary | [in] Handle to the dictionary.
HNType hKeyType | [in] Value key type.
NAttributes keyAttributes | [in] Value key attributes.
const void * pKey | [in] Pointer to the value key.
NSizeType keySize | [in] Size of the value key.
NBool * pResult | [out] NTrue if the value was successfully removed; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionary.h

Module: NDictionary Unit


NDictionaryRemoveAt Function

NDictionaryRemoveAt Function
NDictionary.h

Removes an item specified by index from the specified dictionary.

C++
NResult N_API NDictionaryRemoveAt(HNDictionary hDictionary, NInt index);
Collapse Expand Parameters
Parameters | Description
HNDictionary hDictionary | [in] Handle to the dictionary.
NInt index | [in] Index of the item to be removed.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionary.h

Module: NDictionary Unit


NDictionaryRemoveCollectionChanged Function

NDictionaryRemoveCollectionChanged Function
NDictionary.h

Removes a user-specified "collection changed" event from the specified dictionary.

C++
NResult N_API NDictionaryRemoveCollectionChanged(HNDictionary hDictionary, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNDictionary hDictionary | [in] Handle to the dictionary.
HNCallback hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionary.h

Module: NDictionary Unit


NDictionaryRemoveCollectionChangedCallback Function

NDictionaryRemoveCollectionChangedCallback Function
NDictionary.h
C++
NResult N_API NDictionaryRemoveCollectionChangedCallback(HNDictionary hDictionary, NDictionaryCollectionChangedCallback pCallback, void * pParam);
Collapse Expand Parameters
Parameters | Description
HNDictionary hDictionary | [in] Handle to the dictionary.
NDictionaryCollectionChangedCallback pCallback | [in] The event callback.
void * pParam | [out] Parameters provided to the callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionary.h

Module: NDictionary Unit


NDictionaryRemoveItemCollectionChanged Function

NDictionaryRemoveItemCollectionChanged Function
NDictionary.h

Removes a user-specified "item collection changed" event from the specified dictionary.

C++
NResult N_API NDictionaryRemoveItemCollectionChanged(HNDictionary hDictionary, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNDictionary hDictionary | [in] Handle to the dictionary.
HNCallback hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionary.h

Module: NDictionary Unit


NDictionaryRemoveItemCollectionChangedCallback Function

NDictionaryRemoveItemCollectionChangedCallback Function
NDictionary.h
C++
NResult N_API NDictionaryRemoveItemCollectionChangedCallback(HNDictionary hDictionary, NCollectionItemCollectionChangedCallback pCallback, void * pParam);
Collapse Expand Parameters
Parameters | Description
HNDictionary hDictionary | [in] Handle to the dictionary.
NCollectionItemCollectionChangedCallback pCallback | [in] The event callback.
void * pParam | [out] Parameters provided to the callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionary.h

Module: NDictionary Unit


NDictionarySet Function

NDictionarySet Function
NDictionary.h

Sets the value specified by key in the specified dictionary.

C++
NResult N_API NDictionarySet(HNDictionary hDictionary, HNType hKeyType, NAttributes keyAttributes, const void * pKey, NSizeType keySize, HNType hValueType, NAttributes valueAttributes, const void * pValue, NSizeType valueSize);
Collapse Expand Parameters
Parameters | Description
HNDictionary hDictionary | [in] Handle to the dictionary.
HNType hKeyType | [in] Value key type.
NAttributes keyAttributes | [in] Value key attributes.
const void * pKey | [in] Pointer to the value key.
NSizeType keySize | [in] Size of the value key.
HNType hValueType | [in] Value type.
NAttributes valueAttributes | [in] Value attributes.
const void * pValue | [in] Pointer to the new value.
NSizeType valueSize | [in] Size of the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionary.h

Module: NDictionary Unit


NDictionaryToArray Function

NDictionaryToArray Function
NDictionary.h

Converts the specified dictionary to an array.

C++
NResult N_API NDictionaryToArray(HNDictionary hDictionary, HNType hItemType, NAttributes itemAttributes, NSizeType itemSize, void * * parItems, NInt * pItemCount);
Collapse Expand Parameters
Parameters | Description
HNDictionary hDictionary | [in] Handle to the dictionary.
HNType hItemType | [in] Type of the item.
NAttributes itemAttributes | [in] Item attributes.
NSizeType itemSize | [in] Size of the item.
void * * parItems | [out] Pointer to the new array.
NInt * pItemCount | [out] Pointer to number of items in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionary.h

Module: NDictionary Unit


NDictionaryToItemArray Function

NDictionaryToItemArray Function
NDictionary.h

Converts the specified dictionary to an array of items.

C++
NResult N_API NDictionaryToItemArray(HNDictionary hDictionary, HNArray * phItems);
Collapse Expand Parameters
Parameters | Description
HNDictionary hDictionary | [in] Handle to the dictionary.
HNArray * phItems | [out] Pointer to the new array of items.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionary.h

Module: NDictionary Unit


NDictionaryToKeyArray Function

NDictionaryToKeyArray Function
NDictionary.h

Converts the specified dictionary to an array of keys.

C++
NResult N_API NDictionaryToKeyArray(HNDictionary hDictionary, HNArray * phKeys);
Collapse Expand Parameters
Parameters | Description
HNDictionary hDictionary | [in] Handle to the dictionary.
HNArray * phKeys | [out] Pointer to the new array of keys.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionary.h

Module: NDictionary Unit


NDictionaryToValueArray Function

NDictionaryToValueArray Function
NDictionary.h

Converts the specified dictionary to an array of values.

C++
NResult N_API NDictionaryToValueArray(HNDictionary hDictionary, HNArray * phValues);
Collapse Expand Parameters
Parameters | Description
HNDictionary hDictionary | [in] Handle to the dictionary.
HNArray * phValues | [out] Pointer to the new array of values.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionary.h

Module: NDictionary Unit


NDictionaryTryGet Function

NDictionaryTryGet Function
NDictionary.h

Attempts to retrieve the value specified by key from the specified dictionary and returns a Boolean value indicating the success.

C++
NResult N_API NDictionaryTryGet(HNDictionary hDictionary, HNType hKeyType, NAttributes keyAttributes, const void * pKey, NSizeType keySize, HNType hValueType, NAttributes valueAttributes, void * pValue, NSizeType valueSize, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNDictionary hDictionary | [in] Handle to the dictionary.
HNType hKeyType | [in] Value key type.
NAttributes keyAttributes | [in] Value key attributes.
const void * pKey | [in] Pointer to the value key.
NSizeType keySize | [in] Size of the value key.
HNType hValueType | [in] Value type.
NAttributes valueAttributes | [in] Value attributes.
void * pValue | [out] Pointer to the value.
NSizeType valueSize | [in] Size of the value.
NBool * pResult | [out] NTrue if the value was successfully retrieved; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionary.h

Module: NDictionary Unit


NDictionary.h

NDictionary.h
Functions Legend

Header file for the NDictionary module.

Collapse Expand Functions
Name | Description
NDictionaryAdd | Adds a value to the specified dictionary.
NDictionaryAddCollectionChanged | Adds a user-specified "collection changed" event to the specified dictionary.
NDictionaryAddCollectionChangedCallback | Adds a user-specified "collection changed" event callback to the specified dictionary.
NDictionaryAddItemCollectionChanged | Adds a user-specified "item collection changed" event to the specified dictionary.
NDictionaryAddItemCollectionChangedCallback | Adds a user-specified "item collection changed" event callback to the specified dictionary.
NDictionaryAddItemPair | Adds a pair item to the specified dictionary.
NDictionaryAddPair | Adds a pair item to the specified dictionary.
NDictionaryClear | Clears the specified dictionary.
NDictionaryContains | Checks whether the specified dictionary contains a value specified by its key.
NDictionaryGet | Retrieves the value specified by key from the specified dictionary.
NDictionaryGetAt | Retrieves the item specified by index from the specified dictionary.
NDictionaryGetCount | Retrieves the number of items in the specified dictionary.
NDictionaryGetItemAt | Retrieves the item specified by index from the specified dictionary.
NDictionaryGetKey | Retrieves the key of an item specified by index from the specified dictionary.
NDictionaryGetKeys | Retrieves all keys from the specified dictionary.
NDictionaryGetValue | Retrieves the value of an item specified by index from the specified dictionary.
NDictionaryGetValues | Retrieves all values from the specified dictionary.
NDictionaryIsReadOnly | Checks whether the specified dictionary is read-only.
NDictionaryRemove | Removes the value specified by key from the specified dictionary.
NDictionaryRemoveAt | Removes an item specified by index from the specified dictionary.
NDictionaryRemoveCollectionChanged | Removes a user-specified "collection changed" event from the specified dictionary.
NDictionaryRemoveCollectionChangedCallback |
NDictionaryRemoveItemCollectionChanged | Removes a user-specified "item collection changed" event from the specified dictionary.
NDictionaryRemoveItemCollectionChangedCallback |
NDictionarySet | Sets the value specified by key in the specified dictionary.
NDictionaryToArray | Converts the specified dictionary to an array.
NDictionaryToItemArray | Converts the specified dictionary to an array of items.
NDictionaryToKeyArray | Converts the specified dictionary to an array of keys.
NDictionaryToValueArray | Converts the specified dictionary to an array of values.
NDictionaryTryGet | Attempts to retrieve the value specified by key from the specified dictionary and returns a Boolean value indicating the success.


NDictionaryInfo Unit

NDictionaryInfo Unit
Files Functions Legend

Provides functionality to retrieve information about dictionaries.

Collapse Expand Files
Name | Description
NDictionaryInfo.h | Header file for the NDictionaryInfo unit.
Collapse Expand Functions
Name | Description
NDictionaryInfoGetAddCollectionChangedCallbackMethod | Retrieves the method which adds a "collection changed" event callback to a dictionary.
NDictionaryInfoGetAddCollectionChangedMethod | Retrieves the method which adds a "collection changed" event to a dictionary.
NDictionaryInfoGetAddMethod | Retrieves the method which adds an item to a dictionary.
NDictionaryInfoGetAddPairMethod | Retrieves the method which adds a key-value pair to a dictionary.
NDictionaryInfoGetClearMethod | Retrieves the method which clears the dictionary.
NDictionaryInfoGetContainsMethod | Retrieves the method which checks whether a dictionary contains a specific value.
NDictionaryInfoGetGetAtMethod | Retrieves the method which gets an item in the dictionary specified by index.
NDictionaryInfoGetGetCountMethod | Retrieves the method which gets the number of items in the dictionary.
NDictionaryInfoGetGetKeyMethod | Retrieves the method which gets a key of an item in the dictionary.
NDictionaryInfoGetGetMethod | Retrieves the method which gets an item in the dictionary.
NDictionaryInfoGetGetValueMethod | Retrieves the method which gets a value of an item in the dictionary.
NDictionaryInfoGetItemAttributes | Retrieves the attributes of the items in the dictionary.
NDictionaryInfoGetItemType | Retrieves the type of the items in the dictionary.
NDictionaryInfoGetKeyAttributes | Retrieves the attributes of the item keys in the dictionary.
NDictionaryInfoGetKeyFormat | Retrieves the format of the item keys in the dictionary.
NDictionaryInfoGetKeyMaxValue | Retrieves the maximal item key value of the dictionary.
NDictionaryInfoGetKeyMinValue | Retrieves the minimal item key value of the dictionary.
NDictionaryInfoGetKeyStdValue | Retrieves the specified standard item key value of the dictionary.
NDictionaryInfoGetKeyStdValueCount | Retrieves the number of standard item key values of the dictionary.
NDictionaryInfoGetKeyStdValues | Retrieves all standard item key values of the dictionary.
NDictionaryInfoGetKeyType | Retrieves the type of the item keys in the dictionary.
NDictionaryInfoGetRemoveAtMethod | Retrieves the method which removes an item with specific index from the dictionary.
NDictionaryInfoGetRemoveCollectionChangedCallbackMethod | Retrieves the method which removes a "collection changed" event callback from a dictionary.
NDictionaryInfoGetRemoveCollectionChangedMethod | Retrieves the method which removes a "collection changed" event from a dictionary.
NDictionaryInfoGetRemoveMethod | Retrieves the method which removes an item from the dictionary.
NDictionaryInfoGetSetMethod | Retrieves the method which sets a value of an item in the dictionary.
NDictionaryInfoGetToArrayMethod | Retrieves the method which converts the dictionary into an array.
NDictionaryInfoGetToKeyArrayMethod | Retrieves the method which converts the dictionary into an array of item keys.
NDictionaryInfoGetToValueArrayMethod | Retrieves the method which converts the dictionary into an array of item values.
NDictionaryInfoGetTryGetMethod | Retrieves the method which gets an item in the dictionary and returns a Boolean value indicating success.
NDictionaryInfoGetValueAttributes | Retrieves the attributes of the item values in the dictionary.
NDictionaryInfoGetValueFormat | Retrieves the format of the item values in the dictionary.
NDictionaryInfoGetValueMaxValue | Retrieves the maximal item value of the dictionary.
NDictionaryInfoGetValueMinValue | Retrieves the minimal item value of the dictionary.
NDictionaryInfoGetValueStdValue | Retrieves the specified standard item value of the dictionary.
NDictionaryInfoGetValueStdValueCount | Retrieves the number of standard item values of the dictionary.
NDictionaryInfoGetValueStdValues | Retrieves all standard item values of the dictionary.
NDictionaryInfoGetValueType | Retrieves the type of the item values in the dictionary.


NDictionaryInfoGetAddCollectionChangedCallbackMethod Function

NDictionaryInfoGetAddCollectionChangedCallbackMethod Function
NDictionaryInfo.h

Retrieves the method which adds a "collection changed" event callback to a dictionary.

C++
NResult N_API NDictionaryInfoGetAddCollectionChangedCallbackMethod(HNDictionaryInfo hDictionaryInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNDictionaryInfo hDictionaryInfo | [in] Handle to the dictionary information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionaryInfo.h

Module: NDictionaryInfo Unit


NDictionaryInfoGetAddCollectionChangedMethod Function

NDictionaryInfoGetAddCollectionChangedMethod Function
NDictionaryInfo.h

Retrieves the method which adds a "collection changed" event to a dictionary.

C++
NResult N_API NDictionaryInfoGetAddCollectionChangedMethod(HNDictionaryInfo hDictionaryInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNDictionaryInfo hDictionaryInfo | [in] Handle to the dictionary information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionaryInfo.h

Module: NDictionaryInfo Unit


NDictionaryInfoGetAddMethod Function

NDictionaryInfoGetAddMethod Function
NDictionaryInfo.h

Retrieves the method which adds an item to a dictionary.

C++
NResult N_API NDictionaryInfoGetAddMethod(HNDictionaryInfo hDictionaryInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNDictionaryInfo hDictionaryInfo | [in] Handle to the dictionary information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionaryInfo.h

Module: NDictionaryInfo Unit


NDictionaryInfoGetAddPairMethod Function

NDictionaryInfoGetAddPairMethod Function
NDictionaryInfo.h

Retrieves the method which adds a key-value pair to a dictionary.

C++
NResult N_API NDictionaryInfoGetAddPairMethod(HNDictionaryInfo hDictionaryInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNDictionaryInfo hDictionaryInfo | [in] Handle to the dictionary information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionaryInfo.h

Module: NDictionaryInfo Unit


NDictionaryInfoGetClearMethod Function

NDictionaryInfoGetClearMethod Function
NDictionaryInfo.h

Retrieves the method which clears the dictionary.

C++
NResult N_API NDictionaryInfoGetClearMethod(HNDictionaryInfo hDictionaryInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNDictionaryInfo hDictionaryInfo | [in] Handle to the dictionary information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionaryInfo.h

Module: NDictionaryInfo Unit


NDictionaryInfoGetContainsMethod Function

NDictionaryInfoGetContainsMethod Function
NDictionaryInfo.h

Retrieves the method which checks whether a dictionary contains a specific value.

C++
NResult N_API NDictionaryInfoGetContainsMethod(HNDictionaryInfo hDictionaryInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNDictionaryInfo hDictionaryInfo | [in] Handle to the dictionary information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionaryInfo.h

Module: NDictionaryInfo Unit


NDictionaryInfoGetGetAtMethod Function

NDictionaryInfoGetGetAtMethod Function
NDictionaryInfo.h

Retrieves the method which gets an item in the dictionary specified by index.

C++
NResult N_API NDictionaryInfoGetGetAtMethod(HNDictionaryInfo hDictionaryInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNDictionaryInfo hDictionaryInfo | [in] Handle to the dictionary information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionaryInfo.h

Module: NDictionaryInfo Unit


NDictionaryInfoGetGetCountMethod Function

NDictionaryInfoGetGetCountMethod Function
NDictionaryInfo.h

Retrieves the method which gets the number of items in the dictionary.

C++
NResult N_API NDictionaryInfoGetGetCountMethod(HNDictionaryInfo hDictionaryInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNDictionaryInfo hDictionaryInfo | [in] Handle to the dictionary information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionaryInfo.h

Module: NDictionaryInfo Unit


NDictionaryInfoGetGetKeyMethod Function

NDictionaryInfoGetGetKeyMethod Function
NDictionaryInfo.h

Retrieves the method which gets a key of an item in the dictionary.

C++
NResult N_API NDictionaryInfoGetGetKeyMethod(HNDictionaryInfo hDictionaryInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNDictionaryInfo hDictionaryInfo | [in] Handle to the dictionary information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionaryInfo.h

Module: NDictionaryInfo Unit


NDictionaryInfoGetGetMethod Function

NDictionaryInfoGetGetMethod Function
NDictionaryInfo.h

Retrieves the method which gets an item in the dictionary.

C++
NResult N_API NDictionaryInfoGetGetMethod(HNDictionaryInfo hDictionaryInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNDictionaryInfo hDictionaryInfo | [in] Handle to the dictionary information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionaryInfo.h

Module: NDictionaryInfo Unit


NDictionaryInfoGetGetValueMethod Function

NDictionaryInfoGetGetValueMethod Function
NDictionaryInfo.h

Retrieves the method which gets a value of an item in the dictionary.

C++
NResult N_API NDictionaryInfoGetGetValueMethod(HNDictionaryInfo hDictionaryInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNDictionaryInfo hDictionaryInfo | [in] Handle to the dictionary information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionaryInfo.h

Module: NDictionaryInfo Unit


NDictionaryInfoGetItemAttributes Function

NDictionaryInfoGetItemAttributes Function
NDictionaryInfo.h

Retrieves the attributes of the items in the dictionary.

C++
NResult N_API NDictionaryInfoGetItemAttributes(HNDictionaryInfo hDictionaryInfo, NAttributes * pValue);
Collapse Expand Parameters
Parameters | Description
HNDictionaryInfo hDictionaryInfo | [in] Handle to the dictionary information.
NAttributes * pValue | [out] Pointer to the attributes of the items.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionaryInfo.h

Module: NDictionaryInfo Unit


NDictionaryInfoGetItemType Function

NDictionaryInfoGetItemType Function
NDictionaryInfo.h

Retrieves the type of the items in the dictionary.

C++
NResult N_API NDictionaryInfoGetItemType(HNDictionaryInfo hDictionaryInfo, HNType * phValue);
Collapse Expand Parameters
Parameters | Description
HNDictionaryInfo hDictionaryInfo | [in] Handle to the dictionary information.
HNType * phValue | [out] Pointer to the type of the standard item.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionaryInfo.h

Module: NDictionaryInfo Unit


NDictionaryInfoGetKeyAttributes Function

NDictionaryInfoGetKeyAttributes Function
NDictionaryInfo.h

Retrieves the attributes of the item keys in the dictionary.

C++
NResult N_API NDictionaryInfoGetKeyAttributes(HNDictionaryInfo hDictionaryInfo, NAttributes * pValue);
Collapse Expand Parameters
Parameters | Description
HNDictionaryInfo hDictionaryInfo | [in] Handle to the dictionary information.
NAttributes * pValue | [out] Pointer to the attributes of the item keys.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionaryInfo.h

Module: NDictionaryInfo Unit


NDictionaryInfoGetKeyFormat Function

NDictionaryInfoGetKeyFormat Function
NDictionaryInfo.h

Retrieves the format of the item keys in the dictionary.

C++
NResult N_API NDictionaryInfoGetKeyFormat(HNDictionaryInfo hDictionaryInfo, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNDictionaryInfo hDictionaryInfo | [in] Handle to the dictionary information.
HNString * phValue | [out] Pointer to the format of the item keys.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionaryInfo.h

Module: NDictionaryInfo Unit


NDictionaryInfoGetKeyMaxValue Function

NDictionaryInfoGetKeyMaxValue Function
NDictionaryInfo.h

Retrieves the maximal item key value of the dictionary.

C++
NResult N_API NDictionaryInfoGetKeyMaxValue(HNDictionaryInfo hDictionaryInfo, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
HNDictionaryInfo hDictionaryInfo | [in] Handle to the dictionary information.
HNValue * phValue | [out] Pointer to the maximal item key value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionaryInfo.h

Module: NDictionaryInfo Unit


NDictionaryInfoGetKeyMinValue Function

NDictionaryInfoGetKeyMinValue Function
NDictionaryInfo.h

Retrieves the minimal item key value of the dictionary.

C++
NResult N_API NDictionaryInfoGetKeyMinValue(HNDictionaryInfo hDictionaryInfo, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
HNDictionaryInfo hDictionaryInfo | [in] Handle to the dictionary information.
HNValue * phValue | [out] Pointer to the minimal item key value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionaryInfo.h

Module: NDictionaryInfo Unit


NDictionaryInfoGetKeyStdValue Function

NDictionaryInfoGetKeyStdValue Function
NDictionaryInfo.h

Retrieves the specified standard item key value of the dictionary.

C++
NResult N_API NDictionaryInfoGetKeyStdValue(HNDictionaryInfo hDictionaryInfo, NInt index, struct NNameValuePair_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNDictionaryInfo hDictionaryInfo | [in] Handle to the dictionary information.
NInt index | [in] Index of the standard value.
struct NNameValuePair_ * pValue | [out] Pointer to the standard value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionaryInfo.h

Module: NDictionaryInfo Unit


NDictionaryInfoGetKeyStdValueCount Function

NDictionaryInfoGetKeyStdValueCount Function
NDictionaryInfo.h

Retrieves the number of standard item key values of the dictionary.

C++
NResult N_API NDictionaryInfoGetKeyStdValueCount(HNDictionaryInfo hDictionaryInfo, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNDictionaryInfo hDictionaryInfo | [in] Handle to the dictionary information.
NInt * pValue | [out] Pointer to the number of standard values.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionaryInfo.h

Module: NDictionaryInfo Unit


NDictionaryInfoGetKeyStdValues Function

NDictionaryInfoGetKeyStdValues Function
NDictionaryInfo.h

Retrieves all standard item key values of the dictionary.

C++
NResult N_API NDictionaryInfoGetKeyStdValues(HNDictionaryInfo hDictionaryInfo, struct NNameValuePair_ * * parValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNDictionaryInfo hDictionaryInfo | [in] Handle to the dictionary information.
struct NNameValuePair_ * * parValues | [out] Pointer to the array of standard values.
NInt * pValueCount | [out] Pointer to the number of standard values in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionaryInfo.h

Module: NDictionaryInfo Unit


NDictionaryInfoGetKeyType Function

NDictionaryInfoGetKeyType Function
NDictionaryInfo.h

Retrieves the type of the item keys in the dictionary.

C++
NResult N_API NDictionaryInfoGetKeyType(HNDictionaryInfo hDictionaryInfo, HNType * phValue);
Collapse Expand Parameters
Parameters | Description
HNDictionaryInfo hDictionaryInfo | [in] Handle to the dictionary information.
HNType * phValue | [out] Pointer to the type of the item keys.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionaryInfo.h

Module: NDictionaryInfo Unit


NDictionaryInfoGetRemoveAtMethod Function

NDictionaryInfoGetRemoveAtMethod Function
NDictionaryInfo.h

Retrieves the method which removes an item with specific index from the dictionary.

C++
NResult N_API NDictionaryInfoGetRemoveAtMethod(HNDictionaryInfo hDictionaryInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNDictionaryInfo hDictionaryInfo | [in] Handle to the dictionary information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionaryInfo.h

Module: NDictionaryInfo Unit


NDictionaryInfoGetRemoveCollectionChangedCallbackMethod Function

NDictionaryInfoGetRemoveCollectionChangedCallbackMethod Function
NDictionaryInfo.h

Retrieves the method which removes a "collection changed" event callback from a dictionary.

C++
NResult N_API NDictionaryInfoGetRemoveCollectionChangedCallbackMethod(HNDictionaryInfo hDictionaryInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNDictionaryInfo hDictionaryInfo | [in] Handle to the dictionary information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionaryInfo.h

Module: NDictionaryInfo Unit


NDictionaryInfoGetRemoveCollectionChangedMethod Function

NDictionaryInfoGetRemoveCollectionChangedMethod Function
NDictionaryInfo.h

Retrieves the method which removes a "collection changed" event from a dictionary.

C++
NResult N_API NDictionaryInfoGetRemoveCollectionChangedMethod(HNDictionaryInfo hDictionaryInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNDictionaryInfo hDictionaryInfo | [in] Handle to the dictionary information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionaryInfo.h

Module: NDictionaryInfo Unit


NDictionaryInfoGetRemoveMethod Function

NDictionaryInfoGetRemoveMethod Function
NDictionaryInfo.h

Retrieves the method which removes an item from the dictionary.

C++
NResult N_API NDictionaryInfoGetRemoveMethod(HNDictionaryInfo hDictionaryInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNDictionaryInfo hDictionaryInfo | [in] Handle to the dictionary information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionaryInfo.h

Module: NDictionaryInfo Unit


NDictionaryInfoGetSetMethod Function

NDictionaryInfoGetSetMethod Function
NDictionaryInfo.h

Retrieves the method which sets a value of an item in the dictionary.

C++
NResult N_API NDictionaryInfoGetSetMethod(HNDictionaryInfo hDictionaryInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNDictionaryInfo hDictionaryInfo | [in] Handle to the dictionary information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionaryInfo.h

Module: NDictionaryInfo Unit


NDictionaryInfoGetToArrayMethod Function

NDictionaryInfoGetToArrayMethod Function
NDictionaryInfo.h

Retrieves the method which converts the dictionary into an array.

C++
NResult N_API NDictionaryInfoGetToArrayMethod(HNDictionaryInfo hDictionaryInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNDictionaryInfo hDictionaryInfo | [in] Handle to the dictionary information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionaryInfo.h

Module: NDictionaryInfo Unit


NDictionaryInfoGetToKeyArrayMethod Function

NDictionaryInfoGetToKeyArrayMethod Function
NDictionaryInfo.h

Retrieves the method which converts the dictionary into an array of item keys.

C++
NResult N_API NDictionaryInfoGetToKeyArrayMethod(HNDictionaryInfo hDictionaryInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNDictionaryInfo hDictionaryInfo | [in] Handle to the dictionary information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionaryInfo.h

Module: NDictionaryInfo Unit


NDictionaryInfoGetToValueArrayMethod Function

NDictionaryInfoGetToValueArrayMethod Function
NDictionaryInfo.h

Retrieves the method which converts the dictionary into an array of item values.

C++
NResult N_API NDictionaryInfoGetToValueArrayMethod(HNDictionaryInfo hDictionaryInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNDictionaryInfo hDictionaryInfo | [in] Handle to the dictionary information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionaryInfo.h

Module: NDictionaryInfo Unit


NDictionaryInfoGetTryGetMethod Function

NDictionaryInfoGetTryGetMethod Function
NDictionaryInfo.h

Retrieves the method which gets an item in the dictionary and returns a Boolean value indicating success.

C++
NResult N_API NDictionaryInfoGetTryGetMethod(HNDictionaryInfo hDictionaryInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNDictionaryInfo hDictionaryInfo | [in] Handle to the dictionary information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionaryInfo.h

Module: NDictionaryInfo Unit


NDictionaryInfoGetValueAttributes Function

NDictionaryInfoGetValueAttributes Function
NDictionaryInfo.h

Retrieves the attributes of the item values in the dictionary.

C++
NResult N_API NDictionaryInfoGetValueAttributes(HNDictionaryInfo hDictionaryInfo, NAttributes * pValue);
Collapse Expand Parameters
Parameters | Description
HNDictionaryInfo hDictionaryInfo | [in] Handle to the dictionary information.
NAttributes * pValue | [out] Pointer to the attributes of the item values.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionaryInfo.h

Module: NDictionaryInfo Unit


NDictionaryInfoGetValueFormat Function

NDictionaryInfoGetValueFormat Function
NDictionaryInfo.h

Retrieves the format of the item values in the dictionary.

C++
NResult N_API NDictionaryInfoGetValueFormat(HNDictionaryInfo hDictionaryInfo, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNDictionaryInfo hDictionaryInfo | [in] Handle to the dictionary information.
HNString * phValue | [out] Pointer to the format of the item values.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionaryInfo.h

Module: NDictionaryInfo Unit


NDictionaryInfoGetValueMaxValue Function

NDictionaryInfoGetValueMaxValue Function
NDictionaryInfo.h

Retrieves the maximal item value of the dictionary.

C++
NResult N_API NDictionaryInfoGetValueMaxValue(HNDictionaryInfo hDictionaryInfo, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
HNDictionaryInfo hDictionaryInfo | [in] Handle to the dictionary information.
HNValue * phValue | [out] Pointer to the maximal item value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionaryInfo.h

Module: NDictionaryInfo Unit


NDictionaryInfoGetValueMinValue Function

NDictionaryInfoGetValueMinValue Function
NDictionaryInfo.h

Retrieves the minimal item value of the dictionary.

C++
NResult N_API NDictionaryInfoGetValueMinValue(HNDictionaryInfo hDictionaryInfo, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
HNDictionaryInfo hDictionaryInfo | [in] Handle to the dictionary information.
HNValue * phValue | [out] Pointer to the minimal item value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionaryInfo.h

Module: NDictionaryInfo Unit


NDictionaryInfoGetValueStdValue Function

NDictionaryInfoGetValueStdValue Function
NDictionaryInfo.h

Retrieves the specified standard item value of the dictionary.

C++
NResult N_API NDictionaryInfoGetValueStdValue(HNDictionaryInfo hDictionaryInfo, NInt index, struct NNameValuePair_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNDictionaryInfo hDictionaryInfo | [in] Handle to the dictionary information.
NInt index | [in] Index of the standard value.
struct NNameValuePair_ * pValue | [out] Pointer to the standard value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionaryInfo.h

Module: NDictionaryInfo Unit


NDictionaryInfoGetValueStdValueCount Function

NDictionaryInfoGetValueStdValueCount Function
NDictionaryInfo.h

Retrieves the number of standard item values of the dictionary.

C++
NResult N_API NDictionaryInfoGetValueStdValueCount(HNDictionaryInfo hDictionaryInfo, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNDictionaryInfo hDictionaryInfo | [in] Handle to the dictionary information.
NInt * pValue | [out] Pointer to the number of standard values.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionaryInfo.h

Module: NDictionaryInfo Unit


NDictionaryInfoGetValueStdValues Function

NDictionaryInfoGetValueStdValues Function
NDictionaryInfo.h

Retrieves all standard item values of the dictionary.

C++
NResult N_API NDictionaryInfoGetValueStdValues(HNDictionaryInfo hDictionaryInfo, struct NNameValuePair_ * * parValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNDictionaryInfo hDictionaryInfo | [in] Handle to the dictionary information.
struct NNameValuePair_ * * parValues | [out] Pointer to the array of standard values.
NInt * pValueCount | [out] Pointer to the number of standard values in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionaryInfo.h

Module: NDictionaryInfo Unit


NDictionaryInfoGetValueType Function

NDictionaryInfoGetValueType Function
NDictionaryInfo.h

Retrieves the type of the item values in the dictionary.

C++
NResult N_API NDictionaryInfoGetValueType(HNDictionaryInfo hDictionaryInfo, HNType * phValue);
Collapse Expand Parameters
Parameters | Description
HNDictionaryInfo hDictionaryInfo | [in] Handle to the dictionary information.
HNType * phValue | [out] Pointer to the type of the item values.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDictionaryInfo.h

Module: NDictionaryInfo Unit


NDictionaryInfo.h

NDictionaryInfo.h
Functions Legend

Header file for the NDictionaryInfo unit.

Collapse Expand Functions
Name | Description
NDictionaryInfoGetAddCollectionChangedCallbackMethod | Retrieves the method which adds a "collection changed" event callback to a dictionary.
NDictionaryInfoGetAddCollectionChangedMethod | Retrieves the method which adds a "collection changed" event to a dictionary.
NDictionaryInfoGetAddMethod | Retrieves the method which adds an item to a dictionary.
NDictionaryInfoGetAddPairMethod | Retrieves the method which adds a key-value pair to a dictionary.
NDictionaryInfoGetClearMethod | Retrieves the method which clears the dictionary.
NDictionaryInfoGetContainsMethod | Retrieves the method which checks whether a dictionary contains a specific value.
NDictionaryInfoGetGetAtMethod | Retrieves the method which gets an item in the dictionary specified by index.
NDictionaryInfoGetGetCountMethod | Retrieves the method which gets the number of items in the dictionary.
NDictionaryInfoGetGetKeyMethod | Retrieves the method which gets a key of an item in the dictionary.
NDictionaryInfoGetGetMethod | Retrieves the method which gets an item in the dictionary.
NDictionaryInfoGetGetValueMethod | Retrieves the method which gets a value of an item in the dictionary.
NDictionaryInfoGetItemAttributes | Retrieves the attributes of the items in the dictionary.
NDictionaryInfoGetItemType | Retrieves the type of the items in the dictionary.
NDictionaryInfoGetKeyAttributes | Retrieves the attributes of the item keys in the dictionary.
NDictionaryInfoGetKeyFormat | Retrieves the format of the item keys in the dictionary.
NDictionaryInfoGetKeyMaxValue | Retrieves the maximal item key value of the dictionary.
NDictionaryInfoGetKeyMinValue | Retrieves the minimal item key value of the dictionary.
NDictionaryInfoGetKeyStdValue | Retrieves the specified standard item key value of the dictionary.
NDictionaryInfoGetKeyStdValueCount | Retrieves the number of standard item key values of the dictionary.
NDictionaryInfoGetKeyStdValues | Retrieves all standard item key values of the dictionary.
NDictionaryInfoGetKeyType | Retrieves the type of the item keys in the dictionary.
NDictionaryInfoGetRemoveAtMethod | Retrieves the method which removes an item with specific index from the dictionary.
NDictionaryInfoGetRemoveCollectionChangedCallbackMethod | Retrieves the method which removes a "collection changed" event callback from a dictionary.
NDictionaryInfoGetRemoveCollectionChangedMethod | Retrieves the method which removes a "collection changed" event from a dictionary.
NDictionaryInfoGetRemoveMethod | Retrieves the method which removes an item from the dictionary.
NDictionaryInfoGetSetMethod | Retrieves the method which sets a value of an item in the dictionary.
NDictionaryInfoGetToArrayMethod | Retrieves the method which converts the dictionary into an array.
NDictionaryInfoGetToKeyArrayMethod | Retrieves the method which converts the dictionary into an array of item keys.
NDictionaryInfoGetToValueArrayMethod | Retrieves the method which converts the dictionary into an array of item values.
NDictionaryInfoGetTryGetMethod | Retrieves the method which gets an item in the dictionary and returns a Boolean value indicating success.
NDictionaryInfoGetValueAttributes | Retrieves the attributes of the item values in the dictionary.
NDictionaryInfoGetValueFormat | Retrieves the format of the item values in the dictionary.
NDictionaryInfoGetValueMaxValue | Retrieves the maximal item value of the dictionary.
NDictionaryInfoGetValueMinValue | Retrieves the minimal item value of the dictionary.
NDictionaryInfoGetValueStdValue | Retrieves the specified standard item value of the dictionary.
NDictionaryInfoGetValueStdValueCount | Retrieves the number of standard item values of the dictionary.
NDictionaryInfoGetValueStdValues | Retrieves all standard item values of the dictionary.
NDictionaryInfoGetValueType | Retrieves the type of the item values in the dictionary.


NDirectory Unit

NDirectory Unit
Functions Legend Macros

Provides NDirectory object functionality.

Collapse Expand Functions
Name | Description
NDirectoryExists | Checks whether the specified directory exists.
Collapse Expand Macros
Name | Description
NDirectoryExists | Picks a Unicode (W) or ASCII (A) version of the NDirectoryExists function.


NDirectoryExists Function

NDirectoryExists Function

Checks whether the specified directory exists.

C++
NResult N_API NDirectoryExists(const NChar * szPath, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
const NChar * szPath | [in] Pointer to the directory path.
NBool * pValue | [out] NTrue if the directory exists; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDirectory.h

Module: NDirectory Unit


NDirectoryExists Macro

NDirectoryExists Macro

Picks a Unicode (W) or ASCII (A) version of the NDirectoryExists function.

C++
#define NDirectoryExists N_FUNC_AW(NDirectoryExists)
Container

File: NDirectory.h

Module: NDirectory Unit


NEncoding Unit

NEncoding Unit
Functions Legend Macros Structs, Records, Enums

Represents a character encoding.

C++
typedef enum NEncoding_ {
  neDefault = 0,
  neUtf8 = 1,
  neAscii = 2,
  neUtf7 = 3,
  neUtf16BE = 4,
  neUtf16LE = 5,
  neUtf32BE = 6,
  neUtf32LE = 7
} NEncoding;
Collapse Expand Members
Members | Description
neDefault = 0 | Specified default encoding.
neUtf8 = 1 | Specified UTF-8 encoding.
neAscii = 2 | Specified ASCII encoding.
neUtf7 = 3 | Specified UTF-7 encoding.
neUtf16BE = 4 | Specified UTF-16 BE encoding.
neUtf16LE = 5 | Specified UTF-16 LE encoding.
neUtf32BE = 6 | Specified UTF-32 BE encoding.
neUtf32LE = 7 | Specified UTF-32 LE encoding.
Collapse Expand Functions
Name | Description
NEncodingConvert | Converts a range of bytes in a byte array from one encoding to another and writes the converted data to a new buffer.
NEncodingDetect | Detects the encoding of the specified data.
NEncodingGetBytes | Encodes a character into the specified byte array.
NEncodingGetBytesForChars | Encodes a set of characters from the specified character array into the specified byte array.
NEncodingGetChars | Decodes all the bytes in the specified byte array into a set of characters.
NEncodingGetMaxByteCount | Calculates the maximum number of bytes produced by encoding the specified number of characters.
NEncodingGetMaxCharCount | Calculates the maximum number of characters produced by decoding the specified number of bytes.
NEncodingGetMinBytesPerChar | Gets the minimum number of bytes used to encode one character.
NEncodingGetPreamble | Returns a sequence of bytes that specifies the encoding used.
NEncodingGetPreambleLength | Gets the length of the preamble of the specified encoding.
NEncodingGetStringN | Decodes all the bytes in the specified byte array into a string.
NEncodingIsSingleByte | Gets a value indicating whether the specified encoding uses single-byte code points.
NEncodingIsValid | Checks whether the specified encoding is valid.
Collapse Expand Macros
Name | Description
NEncodingGetBytes | Picks a Unicode (W) or ASCII (A) version of the NEncodingGetBytes function.
NEncodingGetBytesForChars | Picks a Unicode (W) or ASCII (A) version of the NEncodingGetBytesForChars function.
NEncodingGetChars | Picks a Unicode (W) or ASCII (A) version of the NEncodingGetChars function.
NEncodingGetMaxByteCount | Picks a Unicode (W) or ASCII (A) version of the NEncodingGetMaxByteCount function.
NEncodingGetMaxCharCount | Picks a Unicode (W) or ASCII (A) version of the NEncodingGetMaxCharCount function.
N_ACHAR_ENCODING | Specifies AChar encoding.
N_CHAR_ENCODING | Specifies Char encoding.
N_WCHAR_ENCODING | Specifies WChar encoding.
Collapse Expand Structs, Records, Enums
Name | Description
NEncoding_ | Enumerates encoding types.
Container

File: NEncoding.h

Module: NEncoding Unit


NEncodingConvert Function

NEncodingConvert Function

Converts a range of bytes in a byte array from one encoding to another and writes the converted data to a new buffer.

C++
NResult N_API NEncodingConvert(NEncoding srcEncoding, const void * pSrcData, NSizeType srcDataSize, NBool srcIsBlock, NSizeType * pSrcDataUsed, NEncoding dstEncoding, void * pDstData, NSizeType dstDataSize, NBool dstIsBlock, NSizeType * pDstDataUsed, NBool * pCompleted);
Collapse Expand Parameters
Parameters | Description
NEncoding srcEncoding | [in] The original data encoding.
const void * pSrcData | [in] Pointer to the buffer containing the original data.
NSizeType srcDataSize | [in] Size of the original data buffer.
NBool srcIsBlock | [in] NTrue if the original buffer is a block-level object; else NFalse.
NSizeType * pSrcDataUsed | [out] Pointer to the size of the data to be converted.
NEncoding dstEncoding | [in] The new data encoding.
void * pDstData | [out] Pointer to the buffer containing the converted data.
NSizeType dstDataSize | [out] Pointer to the size of the original data buffer.
NBool dstIsBlock | [in] NTrue if the destination buffer is a block-level object; else NFalse.
NSizeType * pDstDataUsed | [out] Pointer to the size of the converted data.
NBool * pCompleted | [out] NTrue if the conversion was successful; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NEncoding.h

Module: NEncoding Unit


NEncodingDetect Function

NEncodingDetect Function

Detects the encoding of the specified data.

C++
NResult N_API NEncodingDetect(const void * pData, NSizeType dataSize, NSizeType * pPreambleLength, NEncoding * pEncoding);
Collapse Expand Parameters
Parameters | Description
const void * pData | [in] Pointer to the data to detect the encoding of.
NSizeType dataSize | [in] Size of the data.
NSizeType * pPreambleLength | [out] Pointer to the length of the preamble.
NEncoding * pEncoding | [out] Pointer to the data encoding.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NEncoding.h

Module: NEncoding Unit


NEncodingGetBytes Function

NEncodingGetBytes Function

Encodes a character into the specified byte array.

C++
NResult N_API NEncodingGetBytes(NEncoding encoding, const NChar * szValue, void * pData, NSizeType dataSize, NSizeType * pDataUsed);
Collapse Expand Parameters
Parameters | Description
NEncoding encoding | [in] The encoding to be used.
const NChar * szValue | [in] Pointer to the char to be converted.
void * pData | [out] Pointer to the buffer to contain the converted bytes.
NSizeType dataSize | [in] Size of the buffer to contain the converted bytes.
NSizeType * pDataUsed | [out] Pointer to the number of bytes used.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NEncoding.h

Module: NEncoding Unit


NEncodingGetBytesForChars Function

NEncodingGetBytesForChars Function

Encodes a set of characters from the specified character array into the specified byte array.

C++
NResult N_API NEncodingGetBytesForChars(NEncoding encoding, const NChar * arChars, NInt charsLength, NBool charsAreBlock, NInt * pCharsUsed, void * pData, NSizeType dataSize, NSizeType * pDataUsed);
Collapse Expand Parameters
Parameters | Description
NEncoding encoding | [in] The encoding to be used.
const NChar * arChars | [in] Pointer to a char array to be encoded.
NInt charsLength | [in] Length of the char array.
NBool charsAreBlock | [in] NTrue if the char array is a block-level object; else NFalse.
NInt * pCharsUsed | [out] Pointer to the number of chars used.
void * pData | [out] Pointer to the buffer to contain the converted bytes.
NSizeType dataSize | [in] Size of the buffer to contain the converted bytes.
NSizeType * pDataUsed | [out] Pointer to the number of bytes used.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NEncoding.h

Module: NEncoding Unit


NEncodingGetChars Function

NEncodingGetChars Function

Decodes all the bytes in the specified byte array into a set of characters.

C++
NResult N_API NEncodingGetChars(NEncoding encoding, const void * pData, NSizeType dataSize, NBool dataIsBlock, NSizeType * pDataUsed, NChar * arChars, NInt charsLength, NInt * pCharsUsed);
Collapse Expand Parameters
Parameters | Description
NEncoding encoding | [in] The encoding to be used.
const void * pData | [in] Pointer to the buffer containing the converted bytes.
NSizeType dataSize | [in] Size of the buffer containing the converted bytes.
NBool dataIsBlock | [in] NTrue if the byte array is a block-level object; else NFalse.
NSizeType * pDataUsed | [out] Pointer to the number of bytes used.
NChar * arChars | [out] Pointer to the decoded character array.
NInt charsLength | [in] Length of the character array.
NInt * pCharsUsed | [out] Pointer to the number of chars used.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NEncoding.h

Module: NEncoding Unit


NEncodingGetMaxByteCount Function

NEncodingGetMaxByteCount Function

Calculates the maximum number of bytes produced by encoding the specified number of characters.

C++
NResult N_API NEncodingGetMaxByteCount(NEncoding encoding, NInt charCount, NSizeType * pByteCount);
Collapse Expand Parameters
Parameters | Description
NEncoding encoding | [in] The encoding to be used.
NInt charCount | [in] The number of characters.
NSizeType * pByteCount | [out] Pointer to the number of bytes.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NEncoding.h

Module: NEncoding Unit


NEncodingGetMaxCharCount Function

NEncodingGetMaxCharCount Function

Calculates the maximum number of characters produced by decoding the specified number of bytes.

C++
NResult N_API NEncodingGetMaxCharCount(NEncoding encoding, NSizeType byteCount, NInt * pCharCount);
Collapse Expand Parameters
Parameters | Description
NEncoding encoding | [in] The encoding to be used.
NSizeType byteCount | [in] The number of bytes.
NInt * pCharCount | [out] Pointer to the number of characters.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NEncoding.h

Module: NEncoding Unit


NEncodingGetMinBytesPerChar Function

NEncodingGetMinBytesPerChar Function

Gets the minimum number of bytes used to encode one character.

C++
NResult N_API NEncodingGetMinBytesPerChar(NEncoding encoding, NSizeType * pValue);
Collapse Expand Parameters
Parameters | Description
NEncoding encoding | [in] The encoding to be used.
NSizeType * pValue | [out] Pointer to the minimal size of an encoded char in bytes.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NEncoding.h

Module: NEncoding Unit


NEncodingGetPreamble Function

NEncodingGetPreamble Function

Returns a sequence of bytes that specifies the encoding used.

C++
NResult N_API NEncodingGetPreamble(NEncoding encoding, void * pData, NSizeType dataSize, NSizeType * pDataWritten);
Collapse Expand Parameters
Parameters | Description
NEncoding encoding | [in] The encoding to be used.
void * pData | [out] Pointer to the buffer containing the preamble.
NSizeType dataSize | [in] Size of the buffer.
NSizeType * pDataWritten | [out] Pointer to the size of the preamble.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NEncoding.h

Module: NEncoding Unit


NEncodingGetPreambleLength Function

NEncodingGetPreambleLength Function

Gets the length of the preamble of the specified encoding.

C++
NResult N_API NEncodingGetPreambleLength(NEncoding encoding, NSizeType * pValue);
Collapse Expand Parameters
Parameters | Description
NEncoding encoding | [in] The encoding to be used.
NSizeType * pValue | [out] Pointer to the size of the preamble.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NEncoding.h

Module: NEncoding Unit


NEncodingGetStringN Function

NEncodingGetStringN Function

Decodes all the bytes in the specified byte array into a string.

C++
NResult N_API NEncodingGetStringN(NEncoding encoding, const void * pData, NSizeType dataSize, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
NEncoding encoding | [in] The encoding to be used.
const void * pData | [in] Pointer to the buffer containing the converted bytes.
NSizeType dataSize | [in] Size of the buffer containing the converted bytes.
HNString * phValue | [out] Pointer to a handle to the decoded NString.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NEncoding.h

Module: NEncoding Unit


NEncodingIsSingleByte Function

NEncodingIsSingleByte Function

Gets a value indicating whether the specified encoding uses single-byte code points.

C++
NResult N_API NEncodingIsSingleByte(NEncoding encoding, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
NEncoding encoding | [in] The encoding to be checked.
NBool * pValue | [out] NTrue if the encoding uses single-byte code points; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NEncoding.h

Module: NEncoding Unit


NEncodingIsValid Function

NEncodingIsValid Function

Checks whether the specified encoding is valid.

C++
NBool N_API NEncodingIsValid(NEncoding value);
Collapse Expand Parameters
Parameters | Description
NEncoding value | [in] The encoding to be checked.
Collapse Expand Returns

NTrue if the encoding is valid; else NFalse.

Container

File: NEncoding.h

Module: NEncoding Unit


NEncoding_ Enumeration

NEncoding_ Enumeration

Enumerates encoding types.

C++
enum NEncoding_ {
  neDefault = 0,
  neUtf8 = 1,
  neAscii = 2,
  neUtf7 = 3,
  neUtf16BE = 4,
  neUtf16LE = 5,
  neUtf32BE = 6,
  neUtf32LE = 7
};
Collapse Expand Members
Members | Description
neDefault = 0 | Specified default encoding.
neUtf8 = 1 | Specified UTF-8 encoding.
neAscii = 2 | Specified ASCII encoding.
neUtf7 = 3 | Specified UTF-7 encoding.
neUtf16BE = 4 | Specified UTF-16 BE encoding.
neUtf16LE = 5 | Specified UTF-16 LE encoding.
neUtf32BE = 6 | Specified UTF-32 BE encoding.
neUtf32LE = 7 | Specified UTF-32 LE encoding.
Container

File: NEncoding.h

Module: NEncoding Unit


NEncodingGetBytes Macro

NEncodingGetBytes Macro

Picks a Unicode (W) or ASCII (A) version of the NEncodingGetBytes function.

C++
#define NEncodingGetBytes N_FUNC_AW(NEncodingGetBytes)
Container

File: NEncoding.h

Module: NEncoding Unit


NEncodingGetBytesForChars Macro

NEncodingGetBytesForChars Macro

Picks a Unicode (W) or ASCII (A) version of the NEncodingGetBytesForChars function.

C++
#define NEncodingGetBytesForChars N_FUNC_AW(NEncodingGetBytesForChars)
Container

File: NEncoding.h

Module: NEncoding Unit


NEncodingGetChars Macro

NEncodingGetChars Macro

Picks a Unicode (W) or ASCII (A) version of the NEncodingGetChars function.

C++
#define NEncodingGetChars N_FUNC_AW(NEncodingGetChars)
Container

File: NEncoding.h

Module: NEncoding Unit


NEncodingGetMaxByteCount Macro

NEncodingGetMaxByteCount Macro

Picks a Unicode (W) or ASCII (A) version of the NEncodingGetMaxByteCount function.

C++
#define NEncodingGetMaxByteCount N_FUNC_AW(NEncodingGetMaxByteCount)
Container

File: NEncoding.h

Module: NEncoding Unit


NEncodingGetMaxCharCount Macro

NEncodingGetMaxCharCount Macro

Picks a Unicode (W) or ASCII (A) version of the NEncodingGetMaxCharCount function.

C++
#define NEncodingGetMaxCharCount N_FUNC_AW(NEncodingGetMaxCharCount)
Container

File: NEncoding.h

Module: NEncoding Unit


N_ACHAR_ENCODING Macro

N_ACHAR_ENCODING Macro

Specifies AChar encoding.

C++
#define N_ACHAR_ENCODING neDefault
Container

File: NEncoding.h

Module: NEncoding Unit


N_CHAR_ENCODING Macro

N_CHAR_ENCODING Macro

Specifies Char encoding.

C++
#define N_CHAR_ENCODING N_ACHAR_ENCODING
Container

File: NEncoding.h

Module: NEncoding Unit


N_WCHAR_ENCODING Macro

N_WCHAR_ENCODING Macro

Specifies WChar encoding.

C++
#define N_WCHAR_ENCODING neUtf32LE
Container

File: NEncoding.h

Module: NEncoding Unit


NEnum Unit

NEnum Unit
Functions Legend

Provides base functionality for enumerations.

Collapse Expand Functions
Name | Description
NEnumGetValues | Gets NEnum values as an array.
NEnumParseN | ... more
NEnumParseP | ... more
NEnumToStringN | Converts NEnum value specified as NInt to string.
NEnumToStringP | Converts NEnum value specified as NInt to string.
NEnumTryParseN | Converts the string representation of the name of enumerated constant to an equivalent NInt.
NEnumTryParseP | Converts the string representation of the name of enumerated constant to an equivalent NInt.


NEnumGetValues Function

NEnumGetValues Function

Gets NEnum values as an array.

C++
NResult N_API NEnumGetValues(HNType hType, NInt * arValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Enumeration type.
NInt * arValues | [out] Pointer to an array containing values.
NInt * pValueCount | [out] Array items count.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NEnum.h

Module: NEnum Unit


NEnumParseN Function

NEnumParseN Function

Converts the string representation of the name or numeric value of enumerated constant to an equivalent NInt.

C++
NResult N_API NEnumParseN(HNType hType, HNString hValue, HNString hFormat, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Enumeration type.
HNString hValue | [in] Handle to NString containing the name or value to convert.
HNString hFormat | [in] Handle to NString containing format specifier.
NInt * pValue | [out] Pointer to NInt containing integer representation of hValue.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NEnum.h

Module: NEnum Unit


NEnumParseP Function

NEnumParseP Function

Converts the string representation of the name or numeric value of enumerated constant to an equivalent NInt.

C++
NResult N_API NEnumParseP(NTypeOfProc pTypeOf, const NChar * szValue, const NChar * szFormat, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
NTypeOfProc pTypeOf | [in] Enumeration type.
const NChar * szValue | [in] Zero-terminated string containing the name or value to convert.
const NChar * szFormat | [in] Zero-terminated string containing format specifier.
NInt * pValue | [out] Pointer to NInt containing integer representation of hValue.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NEnum.h

Module: NEnum Unit


NEnumToStringN Function

NEnumToStringN Function

Converts NEnum value specified as NInt to string.

C++
NResult N_API NEnumToStringN(HNType hType, NInt value, HNString hFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to NEnum type value.
NInt value | [in] NEnum value specified as NInt.
HNString hFormat | [in] Handle to NString containing format specifier.
HNString * phValue | [out] Pointer to NString containing string representation of the specified value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NEnum.h

Module: NEnum Unit


NEnumToStringP Function

NEnumToStringP Function

Converts NEnum value specified as NInt to string.

C++
NResult N_API NEnumToStringP(NTypeOfProc pTypeOf, NInt value, const NChar * szFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
NTypeOfProc pTypeOf | [in] Pointer to NEnum type value.
NInt value | [in] NEnum value specified as NInt to convert.
const NChar * szFormat | [in] Zero-terminated string containing format specifier.
HNString * phValue | [out] Pointer to NString containing string representation of the specified value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NEnum.h

Module: NEnum Unit


NEnumTryParseN Function

NEnumTryParseN Function

Converts the string representation of the name of enumerated constant to an equivalent NInt.

C++
NResult N_API NEnumTryParseN(HNType hType, HNString hValue, HNString hFormat, NInt * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to NEnum type value.
HNString hValue | [in] Handle to NString containing the name or value to convert.
HNString hFormat | [in] Handle to NString containing format specifier.
NInt * pValue | [out] Pointer to NInt containing integer representation of hValue.
NBool * pResult | [out] NTrue if the value was converted successfully; otherwise NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NEnum.h

Module: NEnum Unit


NEnumTryParseP Function

NEnumTryParseP Function

Converts the string representation of the name of enumerated constant to an equivalent NInt.

C++
NResult N_API NEnumTryParseP(NTypeOfProc pTypeOf, const NChar * szValue, const NChar * szFormat, NInt * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
NTypeOfProc pTypeOf | [in] NEnum type value.
const NChar * szValue | [in] Zero-terminated string containing the name or value to convert.
const NChar * szFormat | [in] Zero-terminated string containing format specifier.
NInt * pValue | [out] Pointer to NInt containing integer representation of hValue.
NBool * pResult | [out] NTrue if the value was converted successfully; otherwise NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NEnum.h

Module: NEnum Unit


NEnumConstantInfo Unit

NEnumConstantInfo Unit
Files Functions Legend

Provides functionality to retrieve information about enumeration constants.

Collapse Expand Files
Name | Description
NEnumConstantInfo.h | Header file for the NEnumConstantInfo unit.
Collapse Expand Functions
Name | Description
NEnumConstantInfoGetValue | Retrieves the value of the specified enumeration constant.


NEnumConstantInfoGetValue Function

NEnumConstantInfoGetValue Function
NEnumConstantInfo.h

Retrieves the value of the specified enumeration constant.

C++
NResult N_API NEnumConstantInfoGetValue(HNEnumConstantInfo hEnumConstantInfo, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
HNEnumConstantInfo hEnumConstantInfo | [in] Handle to the enum constant information.
HNValue * phValue | [out] Pointer to the enum constant value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NEnumConstantInfo.h

Module: NEnumConstantInfo Unit


NEnumConstantInfo.h

NEnumConstantInfo.h
Functions Legend

Header file for the NEnumConstantInfo unit.

Collapse Expand Functions
Name | Description
NEnumConstantInfoGetValue | Retrieves the value of the specified enumeration constant.


NEnvironment Unit

NEnvironment Unit
Files Functions Legend

Provides information about the current environment and platform. This class cannot be inherited.

Collapse Expand Files
Name | Description
NEnvironment.h | Header file for the NEnvironment unit.
Collapse Expand Functions
Name | Description
NEnvironmentGetCallStack | Retrieves the call stack information.
NEnvironmentGetCurrentDirectory | Retrieves the path of the current working directory.
NEnvironmentGetSystemDirectory | Retrieves the path of the system directory.


NEnvironmentGetCallStack Function

NEnvironmentGetCallStack Function
NEnvironment.h

Retrieves the call stack information.

C++
NResult N_NO_INLINE N_API NEnvironmentGetCallStack(NInt framesToSkip, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
NInt framesToSkip | [in] Number of call stack frames to skip.
HNString * phValue | [out] Pointer to the string containing call stack information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NEnvironment.h

Module: NEnvironment Unit


NEnvironmentGetCurrentDirectory Function

NEnvironmentGetCurrentDirectory Function
NEnvironment.h

Retrieves the path of the current working directory.

C++
NResult N_API NEnvironmentGetCurrentDirectory(HNString * phPath);
Collapse Expand Parameters
Parameters | Description
HNString * phPath | [out] Pointer to the directory path.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NEnvironment.h

Module: NEnvironment Unit


NEnvironmentGetSystemDirectory Function

NEnvironmentGetSystemDirectory Function
NEnvironment.h

Retrieves the path of the system directory.

C++
NResult N_API NEnvironmentGetSystemDirectory(HNString * phPath);
Collapse Expand Parameters
Parameters | Description
HNString * phPath | [out] Pointer to the directory path.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NEnvironment.h

Module: NEnvironment Unit


NEnvironment.h

NEnvironment.h
Functions Legend

Header file for the NEnvironment unit.

Collapse Expand Functions
Name | Description
NEnvironmentGetCallStack | Retrieves the call stack information.
NEnvironmentGetCurrentDirectory | Retrieves the path of the current working directory.
NEnvironmentGetSystemDirectory | Retrieves the path of the system directory.


NError Unit

NError Unit
Files Functions Legend Macros Structs, Records, Enums

Defines error codes used in Neurotechnology components.

Collapse Expand Files
Name | Description
NError.h | ... more
Collapse Expand Functions
Name | Description
NCallStackEntryCopy |
NCallStackEntryCreate | Creates a line and adds it to NCallStack.
NCallStackEntryDispose | Frees the specified call stack entry.
NCallStackEntrySet | Copies a call stack entry and returns a pointer to the new copy. Frees the source stack entry.
NErrorAppend | Adds a line to NCallStack.
NErrorCapture | Captures an exception thrown by the specified result.
NErrorCreate | Creates a new exception.
NErrorGetCallStackCount | Retrieves the count of call stack entries.
NErrorGetCallStackEntry | Retrieves a certain call stack entry.
NErrorGetCallStackN | Retrieves the last entry of the call stack.
NErrorGetCodeEx | Retrieves the code of the error.
NErrorGetDefaultMessageN | Retrieves the default error message.
NErrorGetExternalCallStackN | Retrieves an external call stack entry with specified size.
NErrorGetExternalErrorEx | Retrieves an external error.
NErrorGetInnerErrorAt | Retrieves the specified inner error from the specified exception.
NErrorGetInnerErrorCount | Retrieves the number of inner errors in the specified exception.
NErrorGetInnerErrorEx | Retrieves an inner error.
NErrorGetLastEx | Retrieves the error information pointer set by the previous call to NErrorSetLastEx
NErrorGetLastSysError | Retrieves the last system error.
NErrorGetLastWin32Error | Retrieves the last Win32 error.
NErrorGetMacErrorMessageN | Retrieves the message of the a specific Mac error.
NErrorGetMachErrorMessageN | Retrieves the message of the a specific Mach error.
NErrorGetMessageN | Retrieves the message of the a specific error.
NErrorGetParamN | Retrieves the parameters of an error.
NErrorGetSysErrorMessageN | Retrieves the message of the a specific system error.
NErrorGetWin32ErrorMessageN | Retrieves the message of the a specific Win32 error.
NErrorRaise | Raises the specified error.
NErrorReport | Prints the last error out in stderr or debugger output.
NErrorReportEx | Prints the specified error out in stderr or debugger output.
NErrorSetCom | Creates the error information object for the current logical thread of execution (COM error only).
NErrorSetComMPN | Creates the error information object for the current logical thread of execution (COM error only).
NErrorSetComN | Creates the error information object for the current logical thread of execution (COM error only).
NErrorSetComPN | Creates the error information object for the current logical thread of execution (COM error only).
NErrorSetLast | Creates the error information object for the current logical thread of execution.
NErrorSetLastEx | Sets the error information object for the current logical thread of execution.
NErrorSetLastMPN | Creates the error information object for the current logical thread of execution.
NErrorSetLastN | Creates the error information object for the current logical thread of execution.
NErrorSetLastPN | Creates the error information object for the current logical thread of execution.
NErrorSetMac | Creates the error information object for the current logical thread of execution (Mac only).
NErrorSetMacMPN | Creates the error information object for the current logical thread of execution (Mac only).
NErrorSetMacN | Creates the error information object for the current logical thread of execution (Mac only).
NErrorSetMacPN | Creates the error information object for the current logical thread of execution (Mac only).
NErrorSetMach | Creates the error information object for the current logical thread of execution (Mach only).
NErrorSetMachMPN | Creates the error information object for the current logical thread of execution (Mach only).
NErrorSetMachN | Creates the error information object for the current logical thread of execution (Mach only).
NErrorSetMachPN | Creates the error information object for the current logical thread of execution (Mach only).
NErrorSetSys | Creates the error information object for the current logical thread of execution (System errors only).
NErrorSetSysMPN | Creates the error information object for the current logical thread of execution (System errors only).
NErrorSetSysN | Creates the error information object for the current logical thread of execution (System errors only).
NErrorSetSysPN | Creates the error information object for the current logical thread of execution (System errors only).
NErrorSetWin32 | Creates the error information object for the current logical thread of execution (Win32 only).
NErrorSetWin32MPN | Creates the error information object for the current logical thread of execution (Win32 only).
NErrorSetWin32N | Creates the error information object for the current logical thread of execution (Win32 only).
NErrorSetWin32PN | Creates the error information object for the current logical thread of execution (Win32 only).
NErrorSuppress | Calls NCoreErrorSuppressed event with the error of the current thread.
Collapse Expand Macros
Name | Description
N_E_ARGUMENT | This error occurs when argument value is invalid.
NCallStackEntryCreate | Picks a Unicode (W) or ANSCII (A) version of the NCallStackEntryCreate function.
N_E_ARGUMENT_NULL | When argument value is NULL where non-NULL value was expected this error occurs.
NE_IS_DIRECTORY_ACCESS | ... more
N_E_ARGUMENT_OUT_OF_RANGE | Argument value is out of range.
NE_MERGE_CALL_STACK | Indicates that the current error's call stack must not be overridden, but merged with the current backtrace.
N_E_CLR | The Common language runtime (CLR) exception has occurred.
NE_NO_CALL_STACK | Indicates that the error's call stack does not get overridden when set (normally it gets overridden with the current backtrace).
N_E_COM | COM error has occurred.
NE_PRESERVE_INNER_ERROR | Indicates that the current error must not be overridden and that an InenrError must be created.
N_E_CORE | Standard error has occurred (for internal use).
NE_SKIP_ONE_FRAME | Indicates that additional frame(s) must be skipped.
N_E_END_OF_STREAM | This error occurs when is attempted to read file or buffer after its end.
NErrorAppend | Picks a Unicode (W) or ASCII (A) version of the NErrorAppend function.
N_E_EXTERNAL | Error in external code has occurred (for internal use).
NErrorSetCom | Picks a Unicode (W) or ASCII (A) version of the NErrorSetCom function.
N_E_FAILED | Unspecified error has occurred.
NErrorSetComMPN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetComMPN function.
N_E_FORMAT | This error occurs when format of argument value is invalid.
NErrorSetComPN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetComPN function.
N_E_INDEX_OUT_OF_RANGE | This error occurs when index is out of range (for internal use).
NErrorSetLast | Picks a Unicode (W) or ASCII (A) version of the NErrorSetLast function.
N_E_INVALID_OPERATION | Attempted to perform invalid operation.
NErrorSetLastMPN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetLastMPN function.
N_E_IO | Input/output error has occurred.
NErrorSetLastPN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetLastPN function.
N_E_NOT_ACTIVATED | Product not activated.
NErrorSetMac | Picks a Unicode (W) or ASCII (A) version of the NErrorSetMac function.
N_E_NOT_IMPLEMENTED | This error occurs when trying to use functionality which is not implemented yet.
NErrorSetMacMPN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetMacMPN function.
NErrorSetMacPN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetMacPN function.
N_E_NOT_SUPPORTED | This error occurs when trying to use functionality which is not supported.
NErrorSetMach | Picks a Unicode (W) or ASCII (A) version of the NErrorSetMach function.
N_E_NULL_REFERENCE | Null reference has occurred (for internal use).
NErrorSetMachMPN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetMachMPN function.
N_E_OUT_OF_MEMORY | This error occurs when there were not enough memory to proceed task.
NErrorSetMachPN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetMachPN function.
N_E_OVERFLOW | Arithmetic overflow has occurred.
NErrorSetSys | Picks a Unicode (W) or ASCII (A) version of the NErrorSetSys function.
NErrorSetSysMPN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetSysMPN function.
NErrorSetSysPN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetSysPN function.
N_E_SYS | System error.
NErrorSetWin32 | Picks a Unicode (W) or ASCII (A) version of the NErrorSetWin32 function.
N_E_WIN32 | Win32 error has occurred.
NErrorSetWin32MPN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetWin32MPN function.
NErrorSetWin32PN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetWin32PN function.
N_OK | This value is returned when no error has occurred.
N_E_ABANDONED_MUTEX | ... more
N_E_AGGREGATE | ... more
NFailed | Determines whether function result indicates error.
NSucceeded | Determines whether function result indicates success.
N_E_ARITHMETIC | The exception that is thrown for errors in an arithmetic, casting, or conversion operation.
N_E_BAD_IMAGE_FORMAT | The file image of a dynamic link library (DLL) or an executable program is invalid.
N_E_CPP | CPP error has occurred.
N_E_DIRECTORY_NOT_FOUND | A part of a file or directory cannot be found.
N_E_DLL_NOT_FOUND | The exception that is thrown when a DLL specified in a DLL import cannot be found.
N_E_DRIVE_NOT_FOUND | Trying to access a drive or share that is not available.
N_E_ENTRY_POINT_NOT_FOUND | An attempt to load a class failed due to the absence of an entry method.
N_E_FILE_FORMAT | This error occurs when an input file or a data stream that is supposed to conform to a certain file format specification is malformed.
N_E_FILE_LOAD | A managed assembly is found but cannot be loaded.
N_E_FILE_NOT_FOUND | The error that occurs when an attempt to access a file that does not exist on disk fails.
N_E_INVALID_CAST | The exception that is thrown for invalid casting or explicit conversion.
N_E_INVALID_ENUM_ARGUMENT | This error occurs when using invalid arguments that are enumerators.
N_E_JVM | JVM error has occurred.
N_E_KEY_NOT_FOUND | This error occurs when key was not found.
N_E_MAC | MAC error has occurred.
N_E_OPERATION_CANCELED | This error occurs when user operation was canceled.
N_E_PATH_TOO_LONG | A path or file name is longer than the system-defined maximum length.
N_E_SECURITY | The exception that is thrown when a security error is detected.
N_E_SOCKET | The exception that is thrown when a socket error occurs.
N_E_TIMEOUT | The time allotted for a process or operation has expired.
Collapse Expand Structs, Records, Enums
Name | Description
NCallStackEntry_ | Represents NCallStackEntry properties. Properties consist of address, function, file and line.


NCallStackEntryCopy Function

NCallStackEntryCopy Function
NError.h
C++
NResult N_API NCallStackEntryCopy(const struct NCallStackEntry_ * pSrcValue, struct NCallStackEntry_ * pDstValue);
Collapse Expand Parameters
Parameters | Description
const struct NCallStackEntry_ * pSrcValue | _nt_
struct NCallStackEntry_ * pDstValue | _nt_
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NCallStackEntryCreate Function

NCallStackEntryCreate Function
NError.h

Creates a line and adds it to NCallStack.

C++
NResult N_API NCallStackEntryCreate(void * addr, const NChar * szFunction, const NChar * szFile, NInt line, NCallStackEntry * pValue);
Collapse Expand Parameters
Parameters | Description
void * addr | [in] A pointer to NCallStack that the line is added to.
const NChar * szFunction | [in] A pointer to the function name.
const NChar * szFile | [in] A pointer to the file name.
NInt line | [in] A line to be added to NCallStack.
NCallStackEntry * pValue | [out] A pointer to the created NCallStackEntry.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NCallStackEntryDispose Function

NCallStackEntryDispose Function
NError.h

Frees the specified call stack entry.

C++
NResult N_API NCallStackEntryDispose(struct NCallStackEntry_ * pValue);
Collapse Expand Parameters
Parameters | Description
struct NCallStackEntry_ * pValue | [in] A pointer to the call stack entry to be freed.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NCallStackEntrySet Function

NCallStackEntrySet Function
NError.h

Copies a call stack entry and returns a pointer to the new copy. Frees the source stack entry.

C++
NResult N_API NCallStackEntrySet(const struct NCallStackEntry_ * pSrcValue, struct NCallStackEntry_ * pDstValue);
Collapse Expand Parameters
Parameters | Description
const struct NCallStackEntry_ * pSrcValue | [in] A pointer to the source call stack entry.
struct NCallStackEntry_ * pDstValue | [out] A pointer to the destination call stack entry.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorAppend Function

NErrorAppend Function
NError.h

Adds a line to NCallStack.

C++
void N_NO_INLINE N_API NErrorAppend(void * addr, const NAChar * szFunction, const NChar * szFile, NInt line);
Collapse Expand Parameters
Parameters | Description
void * addr | [in] A pointer to NCallStack that the line is added to.
const NAChar * szFunction | [in] A pointer to the function name.
const NChar * szFile | [in] A pointer to the file name.
NInt line | [in] A line to be added to NCallStack.
Container

File: NError.h

Module: NError Unit


NErrorCapture Function

NErrorCapture Function
NError.h

Captures an exception thrown by the specified result.

C++
NResult N_API NErrorCapture(NResult result, HNError * phError);
Collapse Expand Parameters
Parameters | Description
NResult result | [in] NResult value.
HNError * phError | [out] Pointer to the exception thrown.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorCreate Function

NErrorCreate Function
NError.h

Creates a new exception.

C++
NResult N_API NErrorCreate(NResult code, const NChar * szMessage, const NChar * szParam, NInt externalError, const NChar * szExternalCallStack, const HNError * arhInnerErrors, NInt innerErrorCount, HNError * phError);
Collapse Expand Parameters
Parameters | Description
NResult code | [in] Result code.
const NChar * szMessage | [in] Pointer to the error message.
const NChar * szParam | [in] Pointer to the exception parameters.
NInt externalError | [in] External error number.
const NChar * szExternalCallStack | [in] Pointer to the external call stack.
const HNError * arhInnerErrors | [in] Pointer to an array of inner errors.
NInt innerErrorCount | [in] Number of inner errors in the array.
HNError * phError | [out] Pointer to the new exception.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorGetCallStackCount Function

NErrorGetCallStackCount Function
NError.h

Retrieves the count of call stack entries.

C++
NResult N_API NErrorGetCallStackCount(HNError hError, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNError hError | [in] A handle to NError.
NInt * pValue | [out] A pointer to the number of call stack entries.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorGetCallStackEntry Function

NErrorGetCallStackEntry Function
NError.h

Retrieves a certain call stack entry.

C++
NResult N_API NErrorGetCallStackEntry(HNError hError, NInt index, struct NCallStackEntry_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNError hError | [in] A handle to NError.
NInt index | [in] Index of the call stack entry.
struct NCallStackEntry_ * pValue | [out] A pointer to the call stack entry.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorGetCallStackN Function

NErrorGetCallStackN Function
NError.h

Retrieves the last entry of the call stack.

C++
NResult N_API NErrorGetCallStackN(HNError hError, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNError hError | [in] A handle to NError.
HNString * phValue | [out] A pointer to the last line.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorGetCodeEx Function

NErrorGetCodeEx Function
NError.h

Retrieves the code of the error.

C++
NResult N_API NErrorGetCodeEx(HNError hError, NResult * pValue);
Collapse Expand Parameters
Parameters | Description
HNError hError | [in] A handle to NError.
NResult * pValue | [out] A pointer to the code of the error.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorGetDefaultMessageN Function

NErrorGetDefaultMessageN Function
NError.h

Retrieves the default error message.

C++
NResult N_API NErrorGetDefaultMessageN(NResult code, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
NResult code | [in] The code of NError.
HNString * phValue | [out] A pointer to a string containing the message of NError.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorGetExternalCallStackN Function

NErrorGetExternalCallStackN Function
NError.h

Retrieves an external call stack entry with specified size.

C++
NResult N_API NErrorGetExternalCallStackN(HNError hError, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNError hError | [in] A handle to NError.
HNString * phValue | [out] A pointer to a NString value representing the external call stack entry.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorGetExternalErrorEx Function

NErrorGetExternalErrorEx Function
NError.h

Retrieves an external error.

C++
NResult N_API NErrorGetExternalErrorEx(HNError hError, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNError hError | [in] A handle to NError.
NInt * pValue | [out] A pointer to the index of the error.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorGetInnerErrorAt Function

NErrorGetInnerErrorAt Function
NError.h

Retrieves the specified inner error from the specified exception.

C++
NResult N_API NErrorGetInnerErrorAt(HNError hError, NInt index, HNError * phValue);
Collapse Expand Parameters
Parameters | Description
HNError hError | [in] Handle to the exception to retrieve the inner error from.
NInt index | [in] Index of the inner error.
HNError * phValue | [out] Pointer to the inner error.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorGetInnerErrorCount Function

NErrorGetInnerErrorCount Function
NError.h

Retrieves the number of inner errors in the specified exception.

C++
NResult N_API NErrorGetInnerErrorCount(HNError hError, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNError hError | [in] Handle to the error.
NInt * pValue | [out] Pointer to the number of inner errors.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorGetInnerErrorEx Function

NErrorGetInnerErrorEx Function
NError.h

Retrieves an inner error.

C++
NResult N_API NErrorGetInnerErrorEx(HNError hError, HNError * phValue);
Collapse Expand Parameters
Parameters | Description
HNError hError | [in] A handle to NError.
HNError * phValue | [out] A pointer to the index of the error.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorGetLastEx Function

NErrorGetLastEx Function
NError.h

Retrieves the error information pointer set by the previous call to NErrorSetLastEx

C++
NResult N_API NErrorGetLastEx(NUInt flags, HNError * phError);
Collapse Expand Parameters
Parameters | Description
NUInt flags | [in] Any flags associated with the error.
HNError * phError | [out] A handle to the last NError.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorGetLastSysError Function

NErrorGetLastSysError Function
NError.h

Retrieves the last system error.

C++
NInt N_API NErrorGetLastSysError();
Collapse Expand Returns

0 on Windows CE; otherwise, error number.

Container

File: NError.h

Module: NError Unit


NErrorGetLastWin32Error Function

NErrorGetLastWin32Error Function
NError.h

Retrieves the last Win32 error.

C++
NUInt N_API NErrorGetLastWin32Error();
Collapse Expand Returns

Last error number.

Container

File: NError.h

Module: NError Unit


NErrorGetMacErrorMessageN Function

NErrorGetMacErrorMessageN Function
NError.h

Retrieves the message of the a specific Mac error.

C++
NResult N_API NErrorGetMacErrorMessageN(NInt err, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
NInt err | [in] A NInt value indicating the error.
HNString * phValue | [out] A pointer to a string containing the message of NError.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorGetMachErrorMessageN Function

NErrorGetMachErrorMessageN Function
NError.h

Retrieves the message of the a specific Mach error.

C++
NResult N_API NErrorGetMachErrorMessageN(NInt err, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
NInt err | [in] A NInt value indicating the error.
HNString * phValue | [out] A pointer to a string containing the message of NError.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorGetMessageN Function

NErrorGetMessageN Function
NError.h

Retrieves the message of the a specific error.

C++
NResult N_API NErrorGetMessageN(HNError hError, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNError hError | [in] A handle to NError.
HNString * phValue | [out] A pointer to a string containing the message of NError.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorGetParamN Function

NErrorGetParamN Function
NError.h

Retrieves the parameters of an error.

C++
NResult N_API NErrorGetParamN(HNError hError, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNError hError | [in] A handle to NError.
HNString * phValue | [out] A pointer to a string containing the parameters of the error.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorGetSysErrorMessageN Function

NErrorGetSysErrorMessageN Function
NError.h

Retrieves the message of the a specific system error.

C++
NResult N_API NErrorGetSysErrorMessageN(NInt errnum, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
NInt errnum | [in] A NInt value indicating the number of the NError.
HNString * phValue | [out] A pointer to a string containing the message of NError.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorGetWin32ErrorMessageN Function

NErrorGetWin32ErrorMessageN Function
NError.h

Retrieves the message of the a specific Win32 error.

C++
NResult N_API NErrorGetWin32ErrorMessageN(NUInt errorCode, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
NUInt errorCode | [in] A NUInt value containing the error code.
HNString * phValue | [out] A pointer to a string containing the message of NError.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorRaise Function

NErrorRaise Function
NError.h

Raises the specified error.

C++
NResult N_NO_INLINE N_API NErrorRaise(HNError hError);
Collapse Expand Parameters
Parameters | Description
HNError hError | [in] Handle to the error to raise.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorReport Function

NErrorReport Function
NError.h

Prints the last error out in stderr or debugger output.

C++
NResult N_NO_INLINE N_API NErrorReport(NResult res);
Collapse Expand Parameters
Parameters | Description
NResult res | [in] Value returned by the function with error.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorReportEx Function

NErrorReportEx Function
NError.h

Prints the specified error out in stderr or debugger output.

C++
NResult N_NO_INLINE N_API NErrorReportEx(NResult errorCode, HNError hError);
Collapse Expand Parameters
Parameters | Description
NResult errorCode | [in] Value returned by the function with error.
HNError hError | [in] A handle to NError.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorSetCom Function

NErrorSetCom Function
NError.h

Creates the error information object for the current logical thread of execution (COM error only).

C++
NResult N_NO_INLINE N_API NErrorSetCom(NInt comError, const NChar * szMessage, const NChar * szParam, const NChar * szExternalCallStack, NUInt flags);
Collapse Expand Parameters
Parameters | Description
NInt comError | [in] A NInt value indicating the error code.
const NChar * szMessage | [in] A pointer to the error message.
const NChar * szParam | [in] A pointer to the error parameters.
const NChar * szExternalCallStack | [in] A pointer to an external call stack.
NUInt flags | [in] Flags associated with the thread.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorSetComMPN Function

NErrorSetComMPN Function
NError.h

Creates the error information object for the current logical thread of execution (COM error only).

C++
NResult N_NO_INLINE N_API NErrorSetComMPN(NInt comError, HNString hMessage, HNString hParam, const NChar * szExternalCallStack, NUInt flags);
Collapse Expand Parameters
Parameters | Description
NInt comError | [in] A NInt value indicating the error code.
HNString hMessage | [in] A handle to the error message.
HNString hParam | [in] A handle to the error parameter.
const NChar * szExternalCallStack | [in] A pointer to an external call stack.
NUInt flags | [in] Flags associated with the thread.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorSetComN Function

NErrorSetComN Function
NError.h

Creates the error information object for the current logical thread of execution (COM error only).

C++
NResult N_NO_INLINE N_API NErrorSetComN(NInt comError, HNString hMessage, HNString hParam, HNString hExternalCallStack, NUInt flags);
Collapse Expand Parameters
Parameters | Description
NInt comError | [in] A NInt value indicating the error code.
HNString hMessage | [in] A handle to the error message.
HNString hParam | [in] A handle to the error parameter.
HNString hExternalCallStack | [in] A handle to an external call stack.
NUInt flags | [in] Flags associated with the thread.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorSetComPN Function

NErrorSetComPN Function
NError.h

Creates the error information object for the current logical thread of execution (COM error only).

C++
NResult N_NO_INLINE N_API NErrorSetComPN(NInt comError, const NChar * szMessage, HNString hParam, const NChar * szExternalCallStack, NUInt flags);
Collapse Expand Parameters
Parameters | Description
NInt comError | [in] A NInt value indicating the error code.
const NChar * szMessage | [in] A pointer to the error message.
HNString hParam | [in] A handle to the error parameter.
const NChar * szExternalCallStack | [in] A pointer to an external call stack.
NUInt flags | [in] Flags associated with the thread.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorSetLast Function

NErrorSetLast Function
NError.h

Creates the error information object for the current logical thread of execution.

C++
NResult N_NO_INLINE N_API NErrorSetLast(NResult code, const NChar * szMessage, const NChar * szParam, NInt externalError, const NChar * szExternalCallStack, NUInt flags);
Collapse Expand Parameters
Parameters | Description
NResult code | [in] The error code.
const NChar * szMessage | [in] A pointer to the error message.
const NChar * szParam | [in] A pointer to the error parameters.
NInt externalError | [in] A pointer to an external error code.
const NChar * szExternalCallStack | [in] A pointer to an external call stack.
NUInt flags | [in] Flags associated with the thread.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorSetLastEx Function

NErrorSetLastEx Function
NError.h

Sets the error information object for the current logical thread of execution.

C++
NResult N_NO_INLINE N_API NErrorSetLastEx(HNError hError, NUInt flags);
Collapse Expand Parameters
Parameters | Description
HNError hError | [in] A handle to the current error.
NUInt flags | [in] Flags associated with the thread.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorSetLastMPN Function

NErrorSetLastMPN Function
NError.h

Creates the error information object for the current logical thread of execution.

C++
NResult N_NO_INLINE N_API NErrorSetLastMPN(NResult code, HNString hMessage, HNString hParam, NInt externalError, const NChar * szExternalCallStack, NUInt flags);
Collapse Expand Parameters
Parameters | Description
NResult code | [in] The error code.
HNString hMessage | [in] A handle to the error message.
HNString hParam | [in] A handle to the error parameter.
NInt externalError | [in] A pointer to an external error code.
const NChar * szExternalCallStack | [in] A pointer to an external call stack.
NUInt flags | [in] Flags associated with the thread.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorSetLastN Function

NErrorSetLastN Function
NError.h

Creates the error information object for the current logical thread of execution.

C++
NResult N_NO_INLINE N_API NErrorSetLastN(NResult code, HNString hMessage, HNString hParam, NInt externalError, HNString hExternalCallStack, NUInt flags);
Collapse Expand Parameters
Parameters | Description
NResult code | [in] The error code.
HNString hMessage | [in] A handle to the error message.
HNString hParam | [in] A handle to the error parameter.
NInt externalError | [in] A handle to an external error code.
HNString hExternalCallStack | [in] A handle to an external call stack.
NUInt flags | [in] Flags associated with the thread.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorSetLastPN Function

NErrorSetLastPN Function
NError.h

Creates the error information object for the current logical thread of execution.

C++
NResult N_NO_INLINE N_API NErrorSetLastPN(NResult code, const NChar * szMessage, HNString hParam, NInt externalError, const NChar * szExternalCallStack, NUInt flags);
Collapse Expand Parameters
Parameters | Description
NResult code | [in] The error code.
const NChar * szMessage | [in] A pointer to the error message.
HNString hParam | [in] A handle to the error parameter.
NInt externalError | [in] A pointer to an external error code.
const NChar * szExternalCallStack | [in] A pointer to an external call stack.
NUInt flags | [in] Flags associated with the thread.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorSetMac Function

NErrorSetMac Function
NError.h

Creates the error information object for the current logical thread of execution (Mac only).

C++
NResult N_NO_INLINE N_API NErrorSetMac(NInt macError, const NChar * szMessage, const NChar * szParam, const NChar * szExternalCallStack, NUInt flags);
Collapse Expand Parameters
Parameters | Description
NInt macError | [in] A NInt value indicating the error code.
const NChar * szMessage | [in] A pointer to the error message.
const NChar * szParam | [in] A pointer to the error parameters.
const NChar * szExternalCallStack | [in] A pointer to an external call stack.
NUInt flags | [in] Flags associated with the thread.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorSetMacMPN Function

NErrorSetMacMPN Function
NError.h

Creates the error information object for the current logical thread of execution (Mac only).

C++
NResult N_API NErrorSetMacMPN(NInt macError, HNString hMessage, HNString hParam, const NChar * szExternalCallStack, NUInt flags);
Collapse Expand Parameters
Parameters | Description
NInt macError | [in] A NInt value indicating the error code.
HNString hMessage | [in] A handle to the error message.
HNString hParam | [in] A handle to the error parameter.
const NChar * szExternalCallStack | [in] A pointer to an external call stack.
NUInt flags | [in] Flags associated with the thread.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorSetMacN Function

NErrorSetMacN Function
NError.h

Creates the error information object for the current logical thread of execution (Mac only).

C++
NResult N_NO_INLINE N_API NErrorSetMacN(NInt macError, HNString hMessage, HNString hParam, HNString hExternalCallStack, NUInt flags);
Collapse Expand Parameters
Parameters | Description
NInt macError | [in] A NInt value indicating the error code.
HNString hMessage | [in] A handle to the error message.
HNString hParam | [in] A handle to the error parameter.
HNString hExternalCallStack | [in] A handle to an external call stack.
NUInt flags | [in] Flags associated with the thread.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorSetMacPN Function

NErrorSetMacPN Function
NError.h

Creates the error information object for the current logical thread of execution (Mac only).

C++
NResult N_NO_INLINE N_API NErrorSetMacPN(NInt macError, const NChar * szMessage, HNString hParam, const NChar * szExternalCallStack, NUInt flags);
Collapse Expand Parameters
Parameters | Description
NInt macError | [in] A NInt value indicating the error code.
const NChar * szMessage | [in] A pointer to the error message.
HNString hParam | [in] A handle to the error parameter.
const NChar * szExternalCallStack | [in] A pointer to an external call stack.
NUInt flags | [in] Flags associated with the thread.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorSetMach Function

NErrorSetMach Function
NError.h

Creates the error information object for the current logical thread of execution (Mach only).

C++
NResult N_NO_INLINE N_API NErrorSetMach(NInt32 machError, const NChar * szMessage, const NChar * szParam, const NChar * szExternalCallStack, NUInt flags);
Collapse Expand Parameters
Parameters | Description
NInt32 machError | [in] A NInt32 value indicating the error code.
const NChar * szMessage | [in] A pointer to the error message.
const NChar * szParam | [in] A pointer to the error parameters.
const NChar * szExternalCallStack | [in] A pointer to an external call stack.
NUInt flags | [in] Flags associated with the thread.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorSetMachMPN Function

NErrorSetMachMPN Function
NError.h

Creates the error information object for the current logical thread of execution (Mach only).

C++
NResult N_NO_INLINE N_API NErrorSetMachMPN(NInt32 machError, HNString hMessage, HNString hParam, const NChar * szExternalCallStack, NUInt flags);
Collapse Expand Parameters
Parameters | Description
NInt32 machError | [in] A NInt32 value indicating the error code.
HNString hMessage | [in] A handle to the error message.
HNString hParam | [in] A handle to the error parameter.
const NChar * szExternalCallStack | [in] A pointer to an external call stack.
NUInt flags | [in] Flags associated with the thread.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorSetMachN Function

NErrorSetMachN Function
NError.h

Creates the error information object for the current logical thread of execution (Mach only).

C++
NResult N_NO_INLINE N_API NErrorSetMachN(NInt32 machError, HNString hMessage, HNString hParam, HNString hExternalCallStack, NUInt flags);
Collapse Expand Parameters
Parameters | Description
NInt32 machError | [in] A NInt32 value indicating the error code.
HNString hMessage | [in] A handle to the error message.
HNString hParam | [in] A handle to the error parameter.
HNString hExternalCallStack | [in] A handle to an external call stack.
NUInt flags | [in] Flags associated with the thread.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorSetMachPN Function

NErrorSetMachPN Function
NError.h

Creates the error information object for the current logical thread of execution (Mach only).

C++
NResult N_NO_INLINE N_API NErrorSetMachPN(NInt32 machError, const NChar * szMessage, HNString hParam, const NChar * szExternalCallStack, NUInt flags);
Collapse Expand Parameters
Parameters | Description
NInt32 machError | [in] A NInt32 value indicating the error code.
const NChar * szMessage | [in] A pointer to the error message.
HNString hParam | [in] A handle to the error parameter.
const NChar * szExternalCallStack | [in] A pointer to an external call stack.
NUInt flags | [in] Flags associated with the thread.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorSetSys Function

NErrorSetSys Function
NError.h

Creates the error information object for the current logical thread of execution (System errors only).

C++
NResult N_NO_INLINE N_API NErrorSetSys(NInt sysError, const NChar * szMessage, const NChar * szParam, const NChar * szExternalCallStack, NUInt flags);
Collapse Expand Parameters
Parameters | Description
NInt sysError | [in] A NInt value indicating the error code.
const NChar * szMessage | [in] A pointer to the error message.
const NChar * szParam | [in] A pointer to the error parameters.
const NChar * szExternalCallStack | [in] A pointer to an external call stack.
NUInt flags | [in] Flags associated with the thread.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorSetSysMPN Function

NErrorSetSysMPN Function
NError.h

Creates the error information object for the current logical thread of execution (System errors only).

C++
NResult N_NO_INLINE N_API NErrorSetSysMPN(NInt sysError, HNString hMessage, HNString hParam, const NChar * szExternalCallStack, NUInt flags);
Collapse Expand Parameters
Parameters | Description
NInt sysError | [in] A NInt value indicating the error code.
HNString hMessage | [in] A handle to the error message.
HNString hParam | [in] A handle to the error parameter.
const NChar * szExternalCallStack | [in] A pointer to an external call stack.
NUInt flags | [in] Flags associated with the thread.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorSetSysN Function

NErrorSetSysN Function
NError.h

Creates the error information object for the current logical thread of execution (System errors only).

C++
NResult N_NO_INLINE N_API NErrorSetSysN(NInt sysError, HNString hMessage, HNString hParam, HNString hExternalCallStack, NUInt flags);
Collapse Expand Parameters
Parameters | Description
NInt sysError | [in] A NInt value indicating the error code.
HNString hMessage | [in] A handle to the error message.
HNString hParam | [in] A handle to the error parameter.
HNString hExternalCallStack | [in] A handle to an external call stack.
NUInt flags | [in] Flags associated with the thread.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorSetSysPN Function

NErrorSetSysPN Function
NError.h

Creates the error information object for the current logical thread of execution (System errors only).

C++
NResult N_NO_INLINE N_API NErrorSetSysPN(NInt sysError, const NChar * szMessage, HNString hParam, const NChar * szExternalCallStack, NUInt flags);
Collapse Expand Parameters
Parameters | Description
NInt sysError | [in] A NInt value indicating the error code.
const NChar * szMessage | [in] A pointer to the error message.
HNString hParam | [in] A handle to the error parameter.
const NChar * szExternalCallStack | [in] A pointer to an external call stack.
NUInt flags | [in] Flags associated with the thread.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorSetWin32 Function

NErrorSetWin32 Function
NError.h

Creates the error information object for the current logical thread of execution (Win32 only).

C++
NResult N_NO_INLINE N_API NErrorSetWin32(NUInt win32Error, const NChar * szMessage, const NChar * szParam, const NChar * szExternalCallStack, NUInt flags);
Collapse Expand Parameters
Parameters | Description
NUInt win32Error | [in] A NUInt value indicating the error code.
const NChar * szMessage | [in] A pointer to the error message.
const NChar * szParam | [in] A pointer to the error parameters.
const NChar * szExternalCallStack | [in] A pointer to an external call stack.
NUInt flags | [in] Flags associated with the thread.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorSetWin32MPN Function

NErrorSetWin32MPN Function
NError.h

Creates the error information object for the current logical thread of execution (Win32 only).

C++
NResult N_NO_INLINE N_API NErrorSetWin32MPN(NUInt win32Error, HNString hMessage, HNString hParam, const NChar * szExternalCallStack, NUInt flags);
Collapse Expand Parameters
Parameters | Description
NUInt win32Error | [in] A NUInt value indicating the error code.
HNString hMessage | [in] A handle to the error message.
HNString hParam | [in] A handle to the error parameter.
const NChar * szExternalCallStack | [in] A pointer to an external call stack.
NUInt flags | [in] Flags associated with the thread.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorSetWin32N Function

NErrorSetWin32N Function
NError.h

Creates the error information object for the current logical thread of execution (Win32 only).

C++
NResult N_NO_INLINE N_API NErrorSetWin32N(NUInt win32Error, HNString hMessage, HNString hParam, HNString hExternalCallStack, NUInt flags);
Collapse Expand Parameters
Parameters | Description
NUInt win32Error | [in] A NUInt value indicating the error code.
HNString hMessage | [in] A handle to the error message.
HNString hParam | [in] A handle to the error parameter.
HNString hExternalCallStack | [in] A handle to an external call stack.
NUInt flags | [in] Flags associated with the thread.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorSetWin32PN Function

NErrorSetWin32PN Function
NError.h

Creates the error information object for the current logical thread of execution (Win32 only).

C++
NResult N_NO_INLINE N_API NErrorSetWin32PN(NUInt win32Error, const NChar * szMessage, HNString hParam, const NChar * szExternalCallStack, NUInt flags);
Collapse Expand Parameters
Parameters | Description
NUInt win32Error | [in] A NUInt value indicating the error code.
const NChar * szMessage | [in] A pointer to the error message.
HNString hParam | [in] A handle to the error parameter.
const NChar * szExternalCallStack | [in] A pointer to an external call stack.
NUInt flags | [in] Flags associated with the thread.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NError.h

Module: NError Unit


NErrorSuppress Function

NErrorSuppress Function
NError.h

Calls NCoreErrorSuppressed event with the error of the current thread.

C++
void N_NO_INLINE N_API NErrorSuppress(NResult result);
Collapse Expand Parameters
Parameters | Description
NResult result | [in] Value returned by the function with error.
Container

File: NError.h

Module: NError Unit


NCallStackEntry_ Structure

NCallStackEntry_ Structure
NError.h

Represents NCallStackEntry properties. Properties consist of address, function, file and line.

C++
struct NCallStackEntry_ {
  void * addr;
  HNString hFunction;
  HNString hFile;
  NInt line;
};
Collapse Expand Members
Members | Description
void * addr; | Call stack entry address.
HNString hFunction; | Call stack entry function.
HNString hFile; | Call stack entry file.
NInt line; | Call stack entry line.
Container

File: NError.h

Module: NError Unit


N_E_ARGUMENT Macro

N_E_ARGUMENT Macro
NError.h

This error occurs when argument value is invalid.

C++
#define N_E_ARGUMENT -10
Container

File: NError.h

Module: NError Unit


NCallStackEntryCreate Macro

NCallStackEntryCreate Macro
NError.h

Picks a Unicode (W) or ANSCII (A) version of the NCallStackEntryCreate function.

C++
#define NCallStackEntryCreate N_FUNC_AW(NCallStackEntryCreate)
Container

File: NError.h

Module: NError Unit


N_E_ARGUMENT_NULL Macro

N_E_ARGUMENT_NULL Macro
NError.h

When argument value is NULL where non-NULL value was expected this error occurs.

C++
#define N_E_ARGUMENT_NULL -11
Container

File: NError.h

Module: NError Unit


NE_IS_DIRECTORY_ACCESS Macro

NE_IS_DIRECTORY_ACCESS Macro
NError.h

Indicates that the error has occurred due to directory access, rather than file access (For NErrorSetSys and NErrorSetMac).

C++
#define NE_IS_DIRECTORY_ACCESS 0x00000100
Container

File: NError.h

Module: NError Unit


N_E_ARGUMENT_OUT_OF_RANGE Macro

N_E_ARGUMENT_OUT_OF_RANGE Macro
NError.h

Argument value is out of range.

C++
#define N_E_ARGUMENT_OUT_OF_RANGE -12
Container

File: NError.h

Module: NError Unit


NE_MERGE_CALL_STACK Macro

NE_MERGE_CALL_STACK Macro
NError.h

Indicates that the current error's call stack must not be overridden, but merged with the current backtrace.

C++
#define NE_MERGE_CALL_STACK 0x00000004
Container

File: NError.h

Module: NError Unit


N_E_CLR Macro

N_E_CLR Macro
NError.h

The Common language runtime (CLR) exception has occurred.

C++
#define N_E_CLR -93
Container

File: NError.h

Module: NError Unit


NE_NO_CALL_STACK Macro

NE_NO_CALL_STACK Macro
NError.h

Indicates that the error's call stack does not get overridden when set (normally it gets overridden with the current backtrace).

C++
#define NE_NO_CALL_STACK 0x00000002
Container

File: NError.h

Module: NError Unit


N_E_COM Macro

N_E_COM Macro
NError.h

COM error has occurred.

C++
#define N_E_COM -92
Container

File: NError.h

Module: NError Unit


NE_PRESERVE_INNER_ERROR Macro

NE_PRESERVE_INNER_ERROR Macro
NError.h

Indicates that the current error must not be overridden and that an InenrError must be created.

C++
#define NE_PRESERVE_INNER_ERROR 0x00000001
Container

File: NError.h

Module: NError Unit


N_E_CORE Macro

N_E_CORE Macro
NError.h

Standard error has occurred (for internal use).

C++
#define N_E_CORE -2
Container

File: NError.h

Module: NError Unit


NE_SKIP_ONE_FRAME Macro

NE_SKIP_ONE_FRAME Macro
NError.h

Indicates that additional frame(s) must be skipped.

C++
#define NE_SKIP_ONE_FRAME 0x01000000
Container

File: NError.h

Module: NError Unit


N_E_END_OF_STREAM Macro

N_E_END_OF_STREAM Macro
NError.h

This error occurs when is attempted to read file or buffer after its end.

C++
#define N_E_END_OF_STREAM -15
Container

File: NError.h

Module: NError Unit


NErrorAppend Macro

NErrorAppend Macro
NError.h

Picks a Unicode (W) or ASCII (A) version of the NErrorAppend function.

C++
#define NErrorAppend N_FUNC_AW(NErrorAppend)
Container

File: NError.h

Module: NError Unit


N_E_EXTERNAL Macro

N_E_EXTERNAL Macro
NError.h

Error in external code has occurred (for internal use).

C++
#define N_E_EXTERNAL -90
Container

File: NError.h

Module: NError Unit


NErrorSetCom Macro

NErrorSetCom Macro
NError.h

Picks a Unicode (W) or ASCII (A) version of the NErrorSetCom function.

C++
#define NErrorSetCom N_FUNC_AW(NErrorSetCom)
Container

File: NError.h

Module: NError Unit


N_E_FAILED Macro

N_E_FAILED Macro
NError.h

Unspecified error has occurred.

C++
#define N_E_FAILED -1
Container

File: NError.h

Module: NError Unit


NErrorSetComMPN Macro

NErrorSetComMPN Macro
NError.h

Picks a Unicode (W) or ASCII (A) version of the NErrorSetComMPN function.

C++
#define NErrorSetComMPN N_FUNC_AW(NErrorSetComMPN)
Container

File: NError.h

Module: NError Unit


N_E_FORMAT Macro

N_E_FORMAT Macro
NError.h

This error occurs when format of argument value is invalid.

C++
#define N_E_FORMAT -13
Container

File: NError.h

Module: NError Unit


NErrorSetComPN Macro

NErrorSetComPN Macro
NError.h

Picks a Unicode (W) or ASCII (A) version of the NErrorSetComPN function.

C++
#define NErrorSetComPN N_FUNC_AW(NErrorSetComPN)
Container

File: NError.h

Module: NError Unit


N_E_INDEX_OUT_OF_RANGE Macro

N_E_INDEX_OUT_OF_RANGE Macro
NError.h

This error occurs when index is out of range (for internal use).

C++
#define N_E_INDEX_OUT_OF_RANGE -9
Container

File: NError.h

Module: NError Unit


NErrorSetLast Macro

NErrorSetLast Macro
NError.h

Picks a Unicode (W) or ASCII (A) version of the NErrorSetLast function.

C++
#define NErrorSetLast N_FUNC_AW(NErrorSetLast)
Container

File: NError.h

Module: NError Unit


N_E_INVALID_OPERATION Macro

N_E_INVALID_OPERATION Macro
NError.h

Attempted to perform invalid operation.

C++
#define N_E_INVALID_OPERATION -7
Container

File: NError.h

Module: NError Unit


NErrorSetLastMPN Macro

NErrorSetLastMPN Macro
NError.h

Picks a Unicode (W) or ASCII (A) version of the NErrorSetLastMPN function.

C++
#define NErrorSetLastMPN N_FUNC_AW(NErrorSetLastMPN)
Container

File: NError.h

Module: NError Unit


N_E_IO Macro

N_E_IO Macro
NError.h

Input/output error has occurred.

C++
#define N_E_IO -14
Container

File: NError.h

Module: NError Unit


NErrorSetLastPN Macro

NErrorSetLastPN Macro
NError.h

Picks a Unicode (W) or ASCII (A) version of the NErrorSetLastPN function.

C++
#define NErrorSetLastPN N_FUNC_AW(NErrorSetLastPN)
Container

File: NError.h

Module: NError Unit


N_E_NOT_ACTIVATED Macro

N_E_NOT_ACTIVATED Macro
NError.h See Also

Product not activated.

C++
#define N_E_NOT_ACTIVATED -200
Collapse Expand See Also

For more information about product activation see Activation.pdf within documentation folder of SDK.

Container

File: NError.h

Module: NError Unit


NErrorSetMac Macro

NErrorSetMac Macro
NError.h

Picks a Unicode (W) or ASCII (A) version of the NErrorSetMac function.

C++
#define NErrorSetMac N_FUNC_AW(NErrorSetMac)
Container

File: NError.h

Module: NError Unit


N_E_NOT_IMPLEMENTED Macro

N_E_NOT_IMPLEMENTED Macro
NError.h

This error occurs when trying to use functionality which is not implemented yet.

C++
#define N_E_NOT_IMPLEMENTED -5
Container

File: NError.h

Module: NError Unit


NErrorSetMacMPN Macro

NErrorSetMacMPN Macro
NError.h

Picks a Unicode (W) or ASCII (A) version of the NErrorSetMacMPN function.

C++
#define NErrorSetMacMPN N_FUNC_AW(NErrorSetMacMPN)
Container

File: NError.h

Module: NError Unit


NErrorSetMacPN Macro

NErrorSetMacPN Macro
NError.h

Picks a Unicode (W) or ASCII (A) version of the NErrorSetMacPN function.

C++
#define NErrorSetMacPN N_FUNC_AW(NErrorSetMacPN)
Container

File: NError.h

Module: NError Unit


N_E_NOT_SUPPORTED Macro

N_E_NOT_SUPPORTED Macro
NError.h

This error occurs when trying to use functionality which is not supported.

C++
#define N_E_NOT_SUPPORTED -6
Container

File: NError.h

Module: NError Unit


NErrorSetMach Macro

NErrorSetMach Macro
NError.h

Picks a Unicode (W) or ASCII (A) version of the NErrorSetMach function.

C++
#define NErrorSetMach N_FUNC_AW(NErrorSetMach)
Container

File: NError.h

Module: NError Unit


N_E_NULL_REFERENCE Macro

N_E_NULL_REFERENCE Macro
NError.h

Null reference has occurred (for internal use).

C++
#define N_E_NULL_REFERENCE -3
Container

File: NError.h

Module: NError Unit


NErrorSetMachMPN Macro

NErrorSetMachMPN Macro
NError.h

Picks a Unicode (W) or ASCII (A) version of the NErrorSetMachMPN function.

C++
#define NErrorSetMachMPN N_FUNC_AW(NErrorSetMachMPN)
Container

File: NError.h

Module: NError Unit


N_E_OUT_OF_MEMORY Macro

N_E_OUT_OF_MEMORY Macro
NError.h

This error occurs when there were not enough memory to proceed task.

C++
#define N_E_OUT_OF_MEMORY -4
Container

File: NError.h

Module: NError Unit


NErrorSetMachPN Macro

NErrorSetMachPN Macro
NError.h

Picks a Unicode (W) or ASCII (A) version of the NErrorSetMachPN function.

C++
#define NErrorSetMachPN N_FUNC_AW(NErrorSetMachPN)
Container

File: NError.h

Module: NError Unit


N_E_OVERFLOW Macro

N_E_OVERFLOW Macro
NError.h

Arithmetic overflow has occurred.

C++
#define N_E_OVERFLOW -8
Container

File: NError.h

Module: NError Unit


NErrorSetSys Macro

NErrorSetSys Macro
NError.h

Picks a Unicode (W) or ASCII (A) version of the NErrorSetSys function.

C++
#define NErrorSetSys N_FUNC_AW(NErrorSetSys)
Container

File: NError.h

Module: NError Unit


NErrorSetSysMPN Macro

NErrorSetSysMPN Macro
NError.h

Picks a Unicode (W) or ASCII (A) version of the NErrorSetSysMPN function.

C++
#define NErrorSetSysMPN N_FUNC_AW(NErrorSetSysMPN)
Container

File: NError.h

Module: NError Unit


NErrorSetSysPN Macro

NErrorSetSysPN Macro
NError.h

Picks a Unicode (W) or ASCII (A) version of the NErrorSetSysPN function.

C++
#define NErrorSetSysPN N_FUNC_AW(NErrorSetSysPN)
Container

File: NError.h

Module: NError Unit


N_E_SYS Macro

N_E_SYS Macro
NError.h

System error.

C++
#define N_E_SYS -94
Container

File: NError.h

Module: NError Unit


NErrorSetWin32 Macro

NErrorSetWin32 Macro
NError.h

Picks a Unicode (W) or ASCII (A) version of the NErrorSetWin32 function.

C++
#define NErrorSetWin32 N_FUNC_AW(NErrorSetWin32)
Container

File: NError.h

Module: NError Unit


N_E_WIN32 Macro

N_E_WIN32 Macro
NError.h

Win32 error has occurred.

C++
#define N_E_WIN32 -91
Container

File: NError.h

Module: NError Unit


NErrorSetWin32MPN Macro

NErrorSetWin32MPN Macro
NError.h

Picks a Unicode (W) or ASCII (A) version of the NErrorSetWin32MPN function.

C++
#define NErrorSetWin32MPN N_FUNC_AW(NErrorSetWin32MPN)
Container

File: NError.h

Module: NError Unit


NErrorSetWin32PN Macro

NErrorSetWin32PN Macro
NError.h

Picks a Unicode (W) or ASCII (A) version of the NErrorSetWin32PN function.

C++
#define NErrorSetWin32PN N_FUNC_AW(NErrorSetWin32PN)
Container

File: NError.h

Module: NError Unit


N_OK Macro

N_OK Macro
NError.h

This value is returned when no error has occurred.

C++
#define N_OK 0
Container

File: NError.h

Module: NError Unit


N_E_ABANDONED_MUTEX Macro

N_E_ABANDONED_MUTEX Macro
NError.h

This error occurs when one thread acquires a NMutex object that another thread has abandoned by exiting without releasing it.

C++
#define N_E_ABANDONED_MUTEX -25
Container

File: NError.h

Module: NError Unit


N_E_AGGREGATE Macro

N_E_AGGREGATE Macro
NError.h

This error occurs during some particular operations, when more than one error could occur. You should note that more than one error can be inside. You should check each of them when analyzing the cause of the error.

C++
#define N_E_AGGREGATE -33
Container

File: NError.h

Module: NError Unit


NFailed Macro

NFailed Macro
NError.h

Determines whether function result indicates error.

C++
#define NFailed(result) ((result) < 0)
Container

File: NError.h

Module: NError Unit


NSucceeded Macro

NSucceeded Macro
NError.h

Determines whether function result indicates success.

C++
#define NSucceeded(result) ((result) >= 0)
Container

File: NError.h

Module: NError Unit


N_E_ARITHMETIC Macro

N_E_ARITHMETIC Macro
NError.h

The exception that is thrown for errors in an arithmetic, casting, or conversion operation.

C++
#define N_E_ARITHMETIC -17
Container

File: NError.h

Module: NError Unit


N_E_BAD_IMAGE_FORMAT Macro

N_E_BAD_IMAGE_FORMAT Macro
NError.h

The file image of a dynamic link library (DLL) or an executable program is invalid.

C++
#define N_E_BAD_IMAGE_FORMAT -26
Container

File: NError.h

Module: NError Unit


N_E_CPP Macro

N_E_CPP Macro
NError.h

CPP error has occurred.

C++
#define N_E_CPP -96
Container

File: NError.h

Module: NError Unit


N_E_DIRECTORY_NOT_FOUND Macro

N_E_DIRECTORY_NOT_FOUND Macro
NError.h

A part of a file or directory cannot be found.

C++
#define N_E_DIRECTORY_NOT_FOUND -19
Container

File: NError.h

Module: NError Unit


N_E_DLL_NOT_FOUND Macro

N_E_DLL_NOT_FOUND Macro
NError.h

The exception that is thrown when a DLL specified in a DLL import cannot be found.

C++
#define N_E_DLL_NOT_FOUND -27
Container

File: NError.h

Module: NError Unit


N_E_DRIVE_NOT_FOUND Macro

N_E_DRIVE_NOT_FOUND Macro
NError.h

Trying to access a drive or share that is not available.

C++
#define N_E_DRIVE_NOT_FOUND -20
Container

File: NError.h

Module: NError Unit


N_E_ENTRY_POINT_NOT_FOUND Macro

N_E_ENTRY_POINT_NOT_FOUND Macro
NError.h

An attempt to load a class failed due to the absence of an entry method.

C++
#define N_E_ENTRY_POINT_NOT_FOUND -28
Container

File: NError.h

Module: NError Unit


N_E_FILE_FORMAT Macro

N_E_FILE_FORMAT Macro
NError.h

This error occurs when an input file or a data stream that is supposed to conform to a certain file format specification is malformed.

C++
#define N_E_FILE_FORMAT -29
Container

File: NError.h

Module: NError Unit


N_E_FILE_LOAD Macro

N_E_FILE_LOAD Macro
NError.h

A managed assembly is found but cannot be loaded.

C++
#define N_E_FILE_LOAD -22
Container

File: NError.h

Module: NError Unit


N_E_FILE_NOT_FOUND Macro

N_E_FILE_NOT_FOUND Macro
NError.h

The error that occurs when an attempt to access a file that does not exist on disk fails.

C++
#define N_E_FILE_NOT_FOUND -21
Container

File: NError.h

Module: NError Unit


N_E_INVALID_CAST Macro

N_E_INVALID_CAST Macro
NError.h

The exception that is thrown for invalid casting or explicit conversion.

C++
#define N_E_INVALID_CAST -18
Container

File: NError.h

Module: NError Unit


N_E_INVALID_ENUM_ARGUMENT Macro

N_E_INVALID_ENUM_ARGUMENT Macro
NError.h

This error occurs when using invalid arguments that are enumerators.

C++
#define N_E_INVALID_ENUM_ARGUMENT -16
Container

File: NError.h

Module: NError Unit


N_E_JVM Macro

N_E_JVM Macro
NError.h

JVM error has occurred.

C++
#define N_E_JVM -97
Container

File: NError.h

Module: NError Unit


N_E_KEY_NOT_FOUND Macro

N_E_KEY_NOT_FOUND Macro
NError.h

This error occurs when key was not found.

C++
#define N_E_KEY_NOT_FOUND -32
Container

File: NError.h

Module: NError Unit


N_E_MAC Macro

N_E_MAC Macro
NError.h

MAC error has occurred.

C++
#define N_E_MAC -95
Container

File: NError.h

Module: NError Unit


N_E_OPERATION_CANCELED Macro

N_E_OPERATION_CANCELED Macro
NError.h

This error occurs when user operation was canceled.

C++
#define N_E_OPERATION_CANCELED -34
Container

File: NError.h

Module: NError Unit


N_E_PATH_TOO_LONG Macro

N_E_PATH_TOO_LONG Macro
NError.h

A path or file name is longer than the system-defined maximum length.

C++
#define N_E_PATH_TOO_LONG -23
Container

File: NError.h

Module: NError Unit


N_E_SECURITY Macro

N_E_SECURITY Macro
NError.h

The exception that is thrown when a security error is detected.

C++
#define N_E_SECURITY -24
Container

File: NError.h

Module: NError Unit


N_E_SOCKET Macro

N_E_SOCKET Macro
NError.h

The exception that is thrown when a socket error occurs.

C++
#define N_E_SOCKET -31
Container

File: NError.h

Module: NError Unit


N_E_TIMEOUT Macro

N_E_TIMEOUT Macro
NError.h

The time allotted for a process or operation has expired.

C++
#define N_E_TIMEOUT -30
Container

File: NError.h

Module: NError Unit


NError.h

NError.h
Functions Legend Macros Structures

Header file for NError module. Defines error codes used in Neurotechnology components.

Collapse Expand Functions
Name | Description
NCallStackEntryCopy |
NCallStackEntryCreate | Creates a line and adds it to NCallStack.
NCallStackEntryDispose | Frees the specified call stack entry.
NCallStackEntrySet | Copies a call stack entry and returns a pointer to the new copy. Frees the source stack entry.
NErrorAppend | Adds a line to NCallStack.
NErrorCapture | Captures an exception thrown by the specified result.
NErrorCreate | Creates a new exception.
NErrorGetCallStackCount | Retrieves the count of call stack entries.
NErrorGetCallStackEntry | Retrieves a certain call stack entry.
NErrorGetCallStackN | Retrieves the last entry of the call stack.
NErrorGetCodeEx | Retrieves the code of the error.
NErrorGetDefaultMessageN | Retrieves the default error message.
NErrorGetExternalCallStackN | Retrieves an external call stack entry with specified size.
NErrorGetExternalErrorEx | Retrieves an external error.
NErrorGetInnerErrorAt | Retrieves the specified inner error from the specified exception.
NErrorGetInnerErrorCount | Retrieves the number of inner errors in the specified exception.
NErrorGetInnerErrorEx | Retrieves an inner error.
NErrorGetLastEx | Retrieves the error information pointer set by the previous call to NErrorSetLastEx
NErrorGetLastSysError | Retrieves the last system error.
NErrorGetLastWin32Error | Retrieves the last Win32 error.
NErrorGetMacErrorMessageN | Retrieves the message of the a specific Mac error.
NErrorGetMachErrorMessageN | Retrieves the message of the a specific Mach error.
NErrorGetMessageN | Retrieves the message of the a specific error.
NErrorGetParamN | Retrieves the parameters of an error.
NErrorGetSysErrorMessageN | Retrieves the message of the a specific system error.
NErrorGetWin32ErrorMessageN | Retrieves the message of the a specific Win32 error.
NErrorRaise | Raises the specified error.
NErrorReport | Prints the last error out in stderr or debugger output.
NErrorReportEx | Prints the specified error out in stderr or debugger output.
NErrorSetCom | Creates the error information object for the current logical thread of execution (COM error only).
NErrorSetComMPN | Creates the error information object for the current logical thread of execution (COM error only).
NErrorSetComN | Creates the error information object for the current logical thread of execution (COM error only).
NErrorSetComPN | Creates the error information object for the current logical thread of execution (COM error only).
NErrorSetLast | Creates the error information object for the current logical thread of execution.
NErrorSetLastEx | Sets the error information object for the current logical thread of execution.
NErrorSetLastMPN | Creates the error information object for the current logical thread of execution.
NErrorSetLastN | Creates the error information object for the current logical thread of execution.
NErrorSetLastPN | Creates the error information object for the current logical thread of execution.
NErrorSetMac | Creates the error information object for the current logical thread of execution (Mac only).
NErrorSetMacMPN | Creates the error information object for the current logical thread of execution (Mac only).
NErrorSetMacN | Creates the error information object for the current logical thread of execution (Mac only).
NErrorSetMacPN | Creates the error information object for the current logical thread of execution (Mac only).
NErrorSetMach | Creates the error information object for the current logical thread of execution (Mach only).
NErrorSetMachMPN | Creates the error information object for the current logical thread of execution (Mach only).
NErrorSetMachN | Creates the error information object for the current logical thread of execution (Mach only).
NErrorSetMachPN | Creates the error information object for the current logical thread of execution (Mach only).
NErrorSetSys | Creates the error information object for the current logical thread of execution (System errors only).
NErrorSetSysMPN | Creates the error information object for the current logical thread of execution (System errors only).
NErrorSetSysN | Creates the error information object for the current logical thread of execution (System errors only).
NErrorSetSysPN | Creates the error information object for the current logical thread of execution (System errors only).
NErrorSetWin32 | Creates the error information object for the current logical thread of execution (Win32 only).
NErrorSetWin32MPN | Creates the error information object for the current logical thread of execution (Win32 only).
NErrorSetWin32N | Creates the error information object for the current logical thread of execution (Win32 only).
NErrorSetWin32PN | Creates the error information object for the current logical thread of execution (Win32 only).
NErrorSuppress | Calls NCoreErrorSuppressed event with the error of the current thread.
Collapse Expand Macros
Name | Description
NCallStackEntryCreate | Picks a Unicode (W) or ANSCII (A) version of the NCallStackEntryCreate function.
NE_IS_DIRECTORY_ACCESS | ... more
NE_MERGE_CALL_STACK | Indicates that the current error's call stack must not be overridden, but merged with the current backtrace.
NE_NO_CALL_STACK | Indicates that the error's call stack does not get overridden when set (normally it gets overridden with the current backtrace).
NE_PRESERVE_INNER_ERROR | Indicates that the current error must not be overridden and that an InenrError must be created.
NE_SKIP_ONE_FRAME | Indicates that additional frame(s) must be skipped.
NErrorAppend | Picks a Unicode (W) or ASCII (A) version of the NErrorAppend function.
NErrorSetCom | Picks a Unicode (W) or ASCII (A) version of the NErrorSetCom function.
NErrorSetComMPN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetComMPN function.
NErrorSetComPN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetComPN function.
NErrorSetLast | Picks a Unicode (W) or ASCII (A) version of the NErrorSetLast function.
NErrorSetLastMPN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetLastMPN function.
NErrorSetLastPN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetLastPN function.
NErrorSetMac | Picks a Unicode (W) or ASCII (A) version of the NErrorSetMac function.
NErrorSetMacMPN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetMacMPN function.
NErrorSetMacPN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetMacPN function.
NErrorSetMach | Picks a Unicode (W) or ASCII (A) version of the NErrorSetMach function.
NErrorSetMachMPN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetMachMPN function.
NErrorSetMachPN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetMachPN function.
NErrorSetSys | Picks a Unicode (W) or ASCII (A) version of the NErrorSetSys function.
NErrorSetSysMPN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetSysMPN function.
NErrorSetSysPN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetSysPN function.
NErrorSetWin32 | Picks a Unicode (W) or ASCII (A) version of the NErrorSetWin32 function.
NErrorSetWin32MPN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetWin32MPN function.
NErrorSetWin32PN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetWin32PN function.
NFailed | Determines whether function result indicates error.
NSucceeded | Determines whether function result indicates success.
N_E_ABANDONED_MUTEX | ... more
N_E_AGGREGATE | ... more
N_E_ARGUMENT | This error occurs when argument value is invalid.
N_E_ARGUMENT_NULL | When argument value is NULL where non-NULL value was expected this error occurs.
N_E_ARGUMENT_OUT_OF_RANGE | Argument value is out of range.
N_E_ARITHMETIC | The exception that is thrown for errors in an arithmetic, casting, or conversion operation.
N_E_BAD_IMAGE_FORMAT | The file image of a dynamic link library (DLL) or an executable program is invalid.
N_E_CLR | The Common language runtime (CLR) exception has occurred.
N_E_COM | COM error has occurred.
N_E_CORE | Standard error has occurred (for internal use).
N_E_CPP | CPP error has occurred.
N_E_DIRECTORY_NOT_FOUND | A part of a file or directory cannot be found.
N_E_DLL_NOT_FOUND | The exception that is thrown when a DLL specified in a DLL import cannot be found.
N_E_DRIVE_NOT_FOUND | Trying to access a drive or share that is not available.
N_E_END_OF_STREAM | This error occurs when is attempted to read file or buffer after its end.
N_E_ENTRY_POINT_NOT_FOUND | An attempt to load a class failed due to the absence of an entry method.
N_E_EXTERNAL | Error in external code has occurred (for internal use).
N_E_FAILED | Unspecified error has occurred.
N_E_FILE_FORMAT | This error occurs when an input file or a data stream that is supposed to conform to a certain file format specification is malformed.
N_E_FILE_LOAD | A managed assembly is found but cannot be loaded.
N_E_FILE_NOT_FOUND | The error that occurs when an attempt to access a file that does not exist on disk fails.
N_E_FORMAT | This error occurs when format of argument value is invalid.
N_E_INDEX_OUT_OF_RANGE | This error occurs when index is out of range (for internal use).
N_E_INVALID_CAST | The exception that is thrown for invalid casting or explicit conversion.
N_E_INVALID_ENUM_ARGUMENT | This error occurs when using invalid arguments that are enumerators.
N_E_INVALID_OPERATION | Attempted to perform invalid operation.
N_E_IO | Input/output error has occurred.
N_E_JVM | JVM error has occurred.
N_E_KEY_NOT_FOUND | This error occurs when key was not found.
N_E_MAC | MAC error has occurred.
N_E_NOT_ACTIVATED | Product not activated.
N_E_NOT_IMPLEMENTED | This error occurs when trying to use functionality which is not implemented yet.
N_E_NOT_SUPPORTED | This error occurs when trying to use functionality which is not supported.
N_E_NULL_REFERENCE | Null reference has occurred (for internal use).
N_E_OPERATION_CANCELED | This error occurs when user operation was canceled.
N_E_OUT_OF_MEMORY | This error occurs when there were not enough memory to proceed task.
N_E_OVERFLOW | Arithmetic overflow has occurred.
N_E_PATH_TOO_LONG | A path or file name is longer than the system-defined maximum length.
N_E_SECURITY | The exception that is thrown when a security error is detected.
N_E_SOCKET | The exception that is thrown when a socket error occurs.
N_E_SYS | System error.
N_E_TIMEOUT | The time allotted for a process or operation has expired.
N_E_WIN32 | Win32 error has occurred.
N_OK | This value is returned when no error has occurred.
Collapse Expand Structures
Name | Description
NCallStackEntry_ | Represents NCallStackEntry properties. Properties consist of address, function, file and line.


NEvent Unit

NEvent Unit
Files Functions Legend Macros

Provides NEvent object functionality.

Collapse Expand Files
Name | Description
NEvent.h | Header file for the NEvent unit.
Collapse Expand Functions
Name | Description
NEventAddN | Adds a new event with the specified callback.
NEventAddRaw | Adds a new event.
NEventDispose | Disposes of the specified event.
NEventGetCallbacks | Retrieves all callbacks associated with the event.
NEventInit | Initializes the specified event.
NEventIsEmpty |
NEventReleaseCallbacks | Releases all callbacks associated with the event.
NEventRemoveN | Removes the specified event with the specified callback.
NEventRemoveRaw | Removes the specified event.
Collapse Expand Macros
Name | Description
NEventAdd | Adds a new event.
NEventRemove | Removes the specified event.
N_EVENT_RAISE_1 | Raises the specified event with specified arguments.
N_EVENT_RAISE_2 | Raises the specified event with specified arguments.
N_EVENT_RAISE_3 | Raises the specified event with specified arguments.
N_EVENT_RAISE_4 | Raises the specified event with specified arguments.
N_EVENT_RAISE_5 | Raises the specified event with specified arguments.
N_EVENT_RAISE_6 | Raises the specified event with specified arguments.
N_EVENT_RAISE_RAW | Raises the specified event with specified arguments.
N_EVENT_SIZE | Defines the size of the event.


NEventAddN Function

NEventAddN Function
NEvent.h

Adds a new event with the specified callback.

C++
NResult N_API NEventAddN(NEvent * pEvent, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
NEvent * pEvent | [in/out] Pointer to the event.
HNCallback hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Notes

Raw functions (i.e. NEventAddRaw) represent the functions themselves.

Non-raw functions (i.e. NEventAdd) represent macros that call those functions for the convenience of using them in C++.

Container

File: NEvent.h

Module: NEvent Unit


NEventAddRaw Function

NEventAddRaw Function
NEvent.h

Adds a new event.

C++
NResult N_API NEventAddRaw(NEvent * pEvent, void * pProc, void * pParam);
Collapse Expand Parameters
Parameters | Description
NEvent * pEvent | [in/out] Pointer to the event.
void * pProc | [in/out] Pointer to the process.
void * pParam | [in/out] Pointer to the parameters.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Notes

Raw functions (i.e. NEventAddRaw) represent the functions themselves.

Non-raw functions (i.e. NEventAdd) represent macros that call those functions for the convenience of using them in C++.

Container

File: NEvent.h

Module: NEvent Unit


NEventDispose Function

NEventDispose Function
NEvent.h

Disposes of the specified event.

C++
NResult N_API NEventDispose(NEvent * pEvent);
Collapse Expand Parameters
Parameters | Description
NEvent * pEvent | [in/out] Pointer to the event.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NEvent.h

Module: NEvent Unit


NEventGetCallbacks Function

NEventGetCallbacks Function
NEvent.h

Retrieves all callbacks associated with the event.

C++
NResult N_API NEventGetCallbacks(NEvent * pEvent, HNCallback * * parhCallbacks, NInt * pCount);
Collapse Expand Parameters
Parameters | Description
NEvent * pEvent | [in/out] Pointer to the event.
HNCallback * * parhCallbacks | [out] Pointer to an array of callback handles.
NInt * pCount | [out] Pointer to the number of callbacks.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NEvent.h

Module: NEvent Unit


NEventInit Function

NEventInit Function
NEvent.h

Initializes the specified event.

C++
NResult N_API NEventInit(NEvent * pEvent);
Collapse Expand Parameters
Parameters | Description
NEvent * pEvent | [in/out] Pointer to the event.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NEvent.h

Module: NEvent Unit


NEventIsEmpty Function

NEventIsEmpty Function
NEvent.h
C++
NResult N_API NEventIsEmpty(NEvent * pEvent, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
NEvent * pEvent | [in/out] Pointer to the event.
NBool * pResult | _nt_
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NEvent.h

Module: NEvent Unit


NEventReleaseCallbacks Function

NEventReleaseCallbacks Function
NEvent.h

Releases all callbacks associated with the event.

C++
NResult N_API NEventReleaseCallbacks(NEvent * pEvent, HNCallback * arhCallbacks, NInt count);
Collapse Expand Parameters
Parameters | Description
NEvent * pEvent | [in/out] Pointer to the event.
HNCallback * arhCallbacks | [out] Pointer to an array of callback handles.
NInt count | [in] Number of callbacks.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NEvent.h

Module: NEvent Unit


NEventRemoveN Function

NEventRemoveN Function
NEvent.h

Removes the specified event with the specified callback.

C++
NResult N_API NEventRemoveN(NEvent * pEvent, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
NEvent * pEvent | [in/out] Pointer to the event.
HNCallback hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Notes

Raw functions (i.e. NEventAddRaw) represent the functions themselves.

Non-raw functions (i.e. NEventAdd) represent macros that call those functions for the convenience of using them in C++.

Container

File: NEvent.h

Module: NEvent Unit


NEventRemoveRaw Function

NEventRemoveRaw Function
NEvent.h

Removes the specified event.

C++
NResult N_API NEventRemoveRaw(NEvent * pEvent, void * pProc, void * pParam);
Collapse Expand Parameters
Parameters | Description
NEvent * pEvent | [in/out] Pointer to the event.
void * pProc | [in/out] Pointer to the process.
void * pParam | [in/out] Pointer to the parameters.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Notes

Raw functions (i.e. NEventAddRaw) represent the functions themselves.

Non-raw functions (i.e. NEventAdd) represent macros that call those functions for the convenience of using them in C++.

Container

File: NEvent.h

Module: NEvent Unit


NEventAdd Macro

NEventAdd Macro
NEvent.h

Adds a new event.

C++
#define NEventAdd(pEvent, pProc, pParam) NEventAddRaw(pEvent, (void *)(NSizeType)pProc, pParam)
Collapse Expand Parameters
Parameters | Description
pEvent | [in/out] Pointer to the event.
pProc | [in/out] Pointer to the process.
pParam | [in/out] Pointer to the parameters.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Notes

Raw functions (i.e. NEventAddRaw) represent the functions themselves.

Non-raw functions (i.e. NEventAdd) represent macros that call those functions for the convenience of using them in C++.

Container

File: NEvent.h

Module: NEvent Unit


NEventRemove Macro

NEventRemove Macro
NEvent.h

Removes the specified event.

C++
#define NEventRemove(pEvent, pProc, pParam) NEventRemoveRaw(pEvent, (void *)(NSizeType)pProc, pParam)
Collapse Expand Parameters
Parameters | Description
pEvent | [in/out] Pointer to the event.
pProc | [in/out] Pointer to the process.
pParam | [in/out] Pointer to the parameters.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Notes

Raw functions (i.e. NEventAddRaw) represent the functions themselves.

Non-raw functions (i.e. NEventAdd) represent macros that call those functions for the convenience of using them in C++.

Container

File: NEvent.h

Module: NEvent Unit


N_EVENT_RAISE_1 Macro

N_EVENT_RAISE_1 Macro
NEvent.h

Raises the specified event with specified arguments.

C++
#define N_EVENT_RAISE_1(callbackType, pEvent, arg1) N_EVENT_RAISE_RAW(callbackType, pEvent, ((arg1), NCallbackGetParam(N_EVENT_RAISE_RAW_hCallback)))
Collapse Expand Parameters
Parameters | Description
callbackType | [in] The type of the callback.
pEvent | [in/out] Pointer to the event.
arg1 | [in] Event argument.
Collapse Expand Returns

The process that raises the event.

Container

File: NEvent.h

Module: NEvent Unit


N_EVENT_RAISE_2 Macro

N_EVENT_RAISE_2 Macro
NEvent.h

Raises the specified event with specified arguments.

C++
#define N_EVENT_RAISE_2(callbackType, pEvent, arg1, arg2) N_EVENT_RAISE_RAW(callbackType, pEvent, ((arg1), (arg2), NCallbackGetParam(N_EVENT_RAISE_RAW_hCallback)))
Collapse Expand Parameters
Parameters | Description
callbackType | [in] The type of the callback.
pEvent | [in/out] Pointer to the event.
arg1 | [in] Event argument.
arg2 | [in] Event argument.
Collapse Expand Returns

The process that raises the event.

Container

File: NEvent.h

Module: NEvent Unit


N_EVENT_RAISE_3 Macro

N_EVENT_RAISE_3 Macro
NEvent.h

Raises the specified event with specified arguments.

C++
#define N_EVENT_RAISE_3(callbackType, pEvent, arg1, arg2, arg3) N_EVENT_RAISE_RAW(callbackType, pEvent, ((arg1), (arg2), (arg3), NCallbackGetParam(N_EVENT_RAISE_RAW_hCallback)))
Collapse Expand Parameters
Parameters | Description
callbackType | [in] The type of the callback.
pEvent | [in/out] Pointer to the event.
arg1 | [in] Event argument.
arg2 | [in] Event argument.
arg3 | [in] Event argument.
Collapse Expand Returns

The process that raises the event.

Container

File: NEvent.h

Module: NEvent Unit


N_EVENT_RAISE_4 Macro

N_EVENT_RAISE_4 Macro
NEvent.h

Raises the specified event with specified arguments.

C++
#define N_EVENT_RAISE_4(callbackType, pEvent, arg1, arg2, arg3, arg4) N_EVENT_RAISE_RAW(callbackType, pEvent, ((arg1), (arg2), (arg3), (arg4), NCallbackGetParam(N_EVENT_RAISE_RAW_hCallback)))
Collapse Expand Parameters
Parameters | Description
callbackType | [in] The type of the callback.
pEvent | [in/out] Pointer to the event.
arg1 | [in] Event argument.
arg2 | [in] Event argument.
arg3 | [in] Event argument.
arg4 | [in] Event argument.
Collapse Expand Returns

The process that raises the event.

Container

File: NEvent.h

Module: NEvent Unit


N_EVENT_RAISE_5 Macro

N_EVENT_RAISE_5 Macro
NEvent.h

Raises the specified event with specified arguments.

C++
#define N_EVENT_RAISE_5(callbackType, pEvent, arg1, arg2, arg3, arg4, arg5) N_EVENT_RAISE_RAW(callbackType, pEvent, ((arg1), (arg2), (arg3), (arg4), (arg5), NCallbackGetParam(N_EVENT_RAISE_RAW_hCallback)))
Collapse Expand Parameters
Parameters | Description
callbackType | [in] The type of the callback.
pEvent | [in/out] Pointer to the event.
arg1 | [in] Event argument.
arg2 | [in] Event argument.
arg3 | [in] Event argument.
arg4 | [in] Event argument.
arg5 | [in] Event argument.
Collapse Expand Returns

The process that raises the event.

Container

File: NEvent.h

Module: NEvent Unit


N_EVENT_RAISE_6 Macro

N_EVENT_RAISE_6 Macro
NEvent.h

Raises the specified event with specified arguments.

C++
#define N_EVENT_RAISE_6(callbackType, pEvent, arg1, arg2, arg3, arg4, arg5, arg6) N_EVENT_RAISE_RAW(callbackType, pEvent, ((arg1), (arg2), (arg3), (arg4), (arg5), (arg6), NCallbackGetParam(N_EVENT_RAISE_RAW_hCallback)))
Collapse Expand Parameters
Parameters | Description
callbackType | [in] The type of the callback.
pEvent | [in/out] Pointer to the event.
arg1 | [in] Event argument.
arg2 | [in] Event argument.
arg3 | [in] Event argument.
arg4 | [in] Event argument.
arg5 | [in] Event argument.
arg6 | [in] Event argument.
Collapse Expand Returns

The process that raises the event.

Container

File: NEvent.h

Module: NEvent Unit


N_EVENT_RAISE_RAW Macro

N_EVENT_RAISE_RAW Macro
NEvent.h

Raises the specified event with specified arguments.

C++
#define N_EVENT_RAISE_RAW(callbackType, pEvent, args) \
    {\
        NResult N_EVENT_RAISE_RAW_res = N_OK;\
        HNCallback * N_EVENT_RAISE_RAW_arhCallbacks;\
        NInt N_EVENT_RAISE_RAW_count;\
        N_CHECK(NEventGetCallbacks(pEvent, &N_EVENT_RAISE_RAW_arhCallbacks, &N_EVENT_RAISE_RAW_count));\
        N_FOREACH(HNCallback, N_EVENT_RAISE_RAW_hCallback, N_EVENT_RAISE_RAW_arhCallbacks, N_EVENT_RAISE_RAW_count)\
            N_EVENT_RAISE_RAW_res = NCallbackInvokeRaw(callbackType, N_EVENT_RAISE_RAW_hCallback, args);\
            if (NFailed(N_EVENT_RAISE_RAW_res)) break;\
        N_FOREACH_END\
        N_CHECK(NEventReleaseCallbacks(pEvent, N_EVENT_RAISE_RAW_arhCallbacks, N_EVENT_RAISE_RAW_count));\
        N_CHECK(N_EVENT_RAISE_RAW_res);\
    }
Collapse Expand Parameters
Parameters | Description
callbackType | [in] The type of the callback.
pEvent | [in/out] Pointer to the event.
args | [in] Event arguments.
Collapse Expand Returns

The process that raises the event.

Collapse Expand Notes

Raw functions (i.e. NEventAddRaw) represent the functions themselves.

Non-raw functions (i.e. NEventAdd) represent macros that call those functions for the convenience of using them in C++.

Container

File: NEvent.h

Module: NEvent Unit


N_EVENT_SIZE Macro

N_EVENT_SIZE Macro
NEvent.h

Defines the size of the event.

C++
#define N_EVENT_SIZE 8
Container

File: NEvent.h

Module: NEvent Unit


NEvent.h

NEvent.h
Functions Legend Macros

Header file for the NEvent unit.

Collapse Expand Functions
Name | Description
NEventAddN | Adds a new event with the specified callback.
NEventAddRaw | Adds a new event.
NEventDispose | Disposes of the specified event.
NEventGetCallbacks | Retrieves all callbacks associated with the event.
NEventInit | Initializes the specified event.
NEventIsEmpty |
NEventReleaseCallbacks | Releases all callbacks associated with the event.
NEventRemoveN | Removes the specified event with the specified callback.
NEventRemoveRaw | Removes the specified event.
Collapse Expand Macros
Name | Description
NEventAdd | Adds a new event.
NEventRemove | Removes the specified event.
N_EVENT_RAISE_1 | Raises the specified event with specified arguments.
N_EVENT_RAISE_2 | Raises the specified event with specified arguments.
N_EVENT_RAISE_3 | Raises the specified event with specified arguments.
N_EVENT_RAISE_4 | Raises the specified event with specified arguments.
N_EVENT_RAISE_5 | Raises the specified event with specified arguments.
N_EVENT_RAISE_6 | Raises the specified event with specified arguments.
N_EVENT_RAISE_RAW | Raises the specified event with specified arguments.
N_EVENT_SIZE | Defines the size of the event.


NEventDescriptor Unit

NEventDescriptor Unit
Files Functions Legend

Provides information about an event.

Collapse Expand Files
Name | Description
NEventDescriptor.h | Header file for the NEventDescriptor unit.
Collapse Expand Functions
Name | Description
NEventDescriptorAddHandler | Binds the event to the component.
NEventDescriptorGetEventType | Retrieves the event type of the specified event.
NEventDescriptorRemoveHandler | Unbinds the delegate from the component so that the delegate will no longer receive events from the component.


NEventDescriptorAddHandler Function

NEventDescriptorAddHandler Function
NEventDescriptor.h

Binds the event to the component.

C++
NResult N_API NEventDescriptorAddHandler(HNEventDescriptor hEventDescriptor, HNObject hComponent, HNType hCallbackType, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNEventDescriptor hEventDescriptor | [in] Handle to the event descriptor.
HNObject hComponent | [in] Handle to the component the event binds to.
HNType hCallbackType | [in] Handle to the type of the callback.
HNCallback hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NEventDescriptor.h

Module: NEventDescriptor Unit


NEventDescriptorGetEventType Function

NEventDescriptorGetEventType Function
NEventDescriptor.h

Retrieves the event type of the specified event.

C++
NResult N_API NEventDescriptorGetEventType(HNEventDescriptor hEventDescriptor, HNType * phValue);
Collapse Expand Parameters
Parameters | Description
HNEventDescriptor hEventDescriptor | [in] Handle to the event descriptor.
HNType * phValue | [out] Pointer to the event type.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NEventDescriptor.h

Module: NEventDescriptor Unit


NEventDescriptorRemoveHandler Function

NEventDescriptorRemoveHandler Function
NEventDescriptor.h

Unbinds the delegate from the component so that the delegate will no longer receive events from the component.

C++
NResult N_API NEventDescriptorRemoveHandler(HNEventDescriptor hEventDescriptor, HNObject hComponent, HNType hCallbackType, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNEventDescriptor hEventDescriptor | [in] Handle to the event descriptor.
HNObject hComponent | [in] Handle to the component the event binds to.
HNType hCallbackType | [in] Handle to the type of the callback.
HNCallback hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NEventDescriptor.h

Module: NEventDescriptor Unit


NEventDescriptor.h

NEventDescriptor.h
Functions Legend

Header file for the NEventDescriptor unit.

Collapse Expand Functions
Name | Description
NEventDescriptorAddHandler | Binds the event to the component.
NEventDescriptorGetEventType | Retrieves the event type of the specified event.
NEventDescriptorRemoveHandler | Unbinds the delegate from the component so that the delegate will no longer receive events from the component.


NEventInfo Unit

NEventInfo Unit
Files Functions Legend

Provides functionality to retrieve information about events.

Collapse Expand Files
Name | Description
NEventInfo.h | Header file for the NEventInfo unit.
Collapse Expand Functions
Name | Description
NEventInfoAddHandler | Binds the event to the object.
NEventInfoGetAddCallbackMethod | Retrieves the method which adds a callback to the event.
NEventInfoGetAddMethod | Retrieves a method which adds an event.
NEventInfoGetEventType | Retrieves the event type of the specified event.
NEventInfoGetRemoveCallbackMethod | Retrieves the method which removes a callback from the event.
NEventInfoGetRemoveMethod | Retrieves a method which removes an event.
NEventInfoRemoveHandler | Unbinds the delegate from the object so that the delegate will no longer receive events from the object.


NEventInfoAddHandler Function

NEventInfoAddHandler Function
NEventInfo.h

Binds the event to the object.

C++
NResult N_API NEventInfoAddHandler(HNEventInfo hEventInfo, HNObject hObject, HNType hCallbackType, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNEventInfo hEventInfo | [in] Handle to the event information.
HNObject hObject | [in] Handle to the object the event binds to.
HNType hCallbackType | [in] Handle to the type of the callback.
HNCallback hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NEventInfo.h

Module: NEventInfo Unit


NEventInfoGetAddCallbackMethod Function

NEventInfoGetAddCallbackMethod Function
NEventInfo.h

Retrieves the method which adds a callback to the event.

C++
NResult N_API NEventInfoGetAddCallbackMethod(HNEventInfo hEventInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNEventInfo hEventInfo | [in] Handle to the event information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NEventInfo.h

Module: NEventInfo Unit


NEventInfoGetAddMethod Function

NEventInfoGetAddMethod Function
NEventInfo.h

Retrieves a method which adds an event.

C++
NResult N_API NEventInfoGetAddMethod(HNEventInfo hEventInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNEventInfo hEventInfo | [in] Handle to the event information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NEventInfo.h

Module: NEventInfo Unit


NEventInfoGetEventType Function

NEventInfoGetEventType Function
NEventInfo.h

Retrieves the event type of the specified event.

C++
NResult N_API NEventInfoGetEventType(HNEventInfo hEventInfo, HNType * phValue);
Collapse Expand Parameters
Parameters | Description
HNEventInfo hEventInfo | [in] Handle to the event information.
HNType * phValue | [out] Pointer to the event type.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NEventInfo.h

Module: NEventInfo Unit


NEventInfoGetRemoveCallbackMethod Function

NEventInfoGetRemoveCallbackMethod Function
NEventInfo.h

Retrieves the method which removes a callback from the event.

C++
NResult N_API NEventInfoGetRemoveCallbackMethod(HNEventInfo hEventInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNEventInfo hEventInfo | [in] Handle to the event information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NEventInfo.h

Module: NEventInfo Unit


NEventInfoGetRemoveMethod Function

NEventInfoGetRemoveMethod Function
NEventInfo.h

Retrieves a method which removes an event.

C++
NResult N_API NEventInfoGetRemoveMethod(HNEventInfo hEventInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNEventInfo hEventInfo | [in] Handle to the event information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NEventInfo.h

Module: NEventInfo Unit


NEventInfoRemoveHandler Function

NEventInfoRemoveHandler Function
NEventInfo.h

Unbinds the delegate from the object so that the delegate will no longer receive events from the object.

C++
NResult N_API NEventInfoRemoveHandler(HNEventInfo hEventInfo, HNObject hObject, HNType hCallbackType, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNEventInfo hEventInfo | [in] Handle to the event information.
HNObject hObject | [in] Handle to the object the event binds to.
HNType hCallbackType | [in] Handle to the type of the callback.
HNCallback hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NEventInfo.h

Module: NEventInfo Unit


NEventInfo.h

NEventInfo.h
Functions Legend

Header file for the NEventInfo unit.

Collapse Expand Functions
Name | Description
NEventInfoAddHandler | Binds the event to the object.
NEventInfoGetAddCallbackMethod | Retrieves the method which adds a callback to the event.
NEventInfoGetAddMethod | Retrieves a method which adds an event.
NEventInfoGetEventType | Retrieves the event type of the specified event.
NEventInfoGetRemoveCallbackMethod | Retrieves the method which removes a callback from the event.
NEventInfoGetRemoveMethod | Retrieves a method which removes an event.
NEventInfoRemoveHandler | Unbinds the delegate from the object so that the delegate will no longer receive events from the object.


NExpandableObject Unit

NExpandableObject Unit
Files Functions Legend

Provides functionality for retrieving information about specified object.

Collapse Expand Files
Name | Description
NExpandableObject.h | Header file for the NExpandableObject module.
Collapse Expand Functions
Name | Description
NExpandableObjectGetProperties | Retrieves the properties of the specified expandable object.


NExpandableObjectGetProperties Function

NExpandableObjectGetProperties Function
NExpandableObject.h

Retrieves the properties of the specified expandable object.

C++
NResult N_API NExpandableObjectGetProperties(HNExpandableObject hObject, HNPropertyBag * phValue);
Collapse Expand Parameters
Parameters | Description
HNExpandableObject hObject | [in] Handle to the expandable object.
HNPropertyBag * phValue | [out] Pointer to a handle to the property bag of the expandable object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NExpandableObject.h

Module: NExpandableObject Unit


NExpandableObject.h

NExpandableObject.h
Functions Legend

Header file for the NExpandableObject module.

Collapse Expand Functions
Name | Description
NExpandableObjectGetProperties | Retrieves the properties of the specified expandable object.


NFile Unit

NFile Unit
Functions Legend Macros Structs, Records, Enums

Provides static methods for the creation, copying, deletion, moving, and opening of files, and aids in the creation of FileStream objects.

Collapse Expand Functions
Name | Description
NFileAppendAllLines | Picks a Unicode (W) or ANSCII (A) version of the NFileAppendAllLines function.
NFileAppendAllLinesPN | Picks a Unicode (W) or ANSCII (A) version of the NFileAppendAllLinesPN function.
NFileAppendAllLinesWithEncoding | Picks a Unicode (W) or ANSCII (A) version of the NFileAppendAllLinesWithEncoding function.
NFileAppendAllLinesWithEncodingPN | Picks a Unicode (W) or ANSCII (A) version of the NFileAppendAllLinesWithEncodingPN function.
NFileAppendAllText | Opens a file, appends the specified string to the file, and then closes the file.
NFileAppendAllTextPN | Opens a file, appends the specified string to the file, and then closes the file.
NFileAppendAllTextWithEncoding | Opens a file, appends the specified string to the file, and then closes the file.
NFileAppendAllTextWithEncodingPN | Opens a file, appends the specified string to the file, and then closes the file.
NFileAppendText | Creates a StreamWriter that appends UTF-8 encoded text to an existing file.
NFileCreate | Creates a file in the specified path.
NFileCreateText | Creates or opens a file for writing UTF-8 encoded text.
NFileCreateWithBufferSize | Creates a file in the specified path with the specified buffer size.
NFileDelete | Deletes the specified file. An exception is not thrown if the specified file does not exist.
NFileExists | Determines whether the file with the specified path exists.
NFileGetAttributes | Gets the attributes of the file on the path.
NFileOpen | Opens a NFileStream on the specified path with read/write access.
NFileOpenRead | Opens an existing file for reading.
NFileOpenText | Opens an existing UTF-8 encoded text file for reading.
NFileOpenWithAccess | Opens a NFileStream on the specified path, with the specified mode and access.
NFileOpenWithAccessAndShare | Opens a NFileStream on the specified path, having the specified mode with read, write, or read/write access and the specified sharing option.
NFileOpenWrite | Opens an existing file for writing.
NFileReadAllBytesCN | Opens a binary file, reads the contents of the file into a byte array, and then closes the file.
NFileReadAllBytesN | Opens a binary file, reads the contents of the file into a byte array, and then closes the file.
NFileReadAllLinesCN | Opens a text file, reads all lines of the file, and then closes the file.
NFileReadAllLinesN | Opens a text file, reads all lines of the file, and then closes the file.
NFileReadAllLinesWithEncodingCN | Opens a file, reads all lines of the file with the specified encoding, and then closes the file.
NFileReadAllLinesWithEncodingN | Opens a file, reads all lines of the file with the specified encoding, and then closes the file.
NFileReadAllTextCN | Opens a text file, reads all lines of the file, and then closes the file.
NFileReadAllTextN | Opens a text file, reads all lines of the file, and then closes the file.
NFileReadAllTextWithEncodingCN | Opens a file, reads all lines of the file with the specified encoding, and then closes the file.
NFileReadAllTextWithEncodingN | Opens a file, reads all lines of the file with the specified encoding, and then closes the file.
NFileWriteAllBytes | Creates a new file, writes the specified byte array to the file, and then closes the file.
NFileWriteAllBytesCN | Creates a new file, writes the specified buffer to the file, and then closes the file.
NFileWriteAllBytesPN | Creates a new file, writes the specified byte array to the file, and then closes the file.
NFileWriteAllLines | Creates a new file, write the specified char array to the file, and then closes the file.
NFileWriteAllLinesPN | Creates a new file, write the specified char array to the file, and then closes the file.
NFileWriteAllLinesWithEncoding | Creates a new file, writes the specified char array to the file using the specified encoding, and then closes the file.
NFileWriteAllLinesWithEncodingPN | Creates a new file, writes the specified char array to the file using the specified encoding, and then closes the file.
NFileWriteAllText | Creates a new file, writes the specified char to the file, and then closes the file.
NFileWriteAllTextCN | Picks a Unicode (W) or ASCII (A) version of the NFileWriteAllTextCN function.
NFileWriteAllTextPN | Creates a new file, writes the specified string array to the file, and then closes the file.
NFileWriteAllTextWithEncoding | Creates a new file, writes the specified string array to the file using the specified encoding, and then closes the file.
NFileWriteAllTextWithEncodingPN | Creates a new file, writes the specified string array to the file using the specified encoding, and then closes the file.
Collapse Expand Macros
Name | Description
NFileAppendAllText | Picks a Unicode (W) or ASCII (A) version of the NFileAppendAllText function.
NFileAppendAllTextPN | Picks a Unicode (W) or ASCII (A) version of the NFileAppendAllTextPN function.
NFileAppendAllTextWithEncoding | Picks a Unicode (W) or ASCII (A) version of the NFileAppendAllTextWithEncoding function.
NFileAppendAllTextWithEncodingPN | Picks a Unicode (W) or ASCII (A) version of the NFileAppendAllTextWithEncodingPN function.
NFileAppendText | Picks a Unicode (W) or ASCII (A) version of the NFileAppendText function.
NFileCreate | Picks a Unicode (W) or ASCII (A) version of the NFileCreate function.
NFileCreateText | Picks a Unicode (W) or ASCII (A) version of the NFileAppendCreateText function.
NFileCreateWithBufferSize | Picks a Unicode (W) or ASCII (A) version of the NFileAppendCreateWithBufferSize function.
NFileDelete | Picks a Unicode (W) or ASCII (A) version of the NFileDelete function.
NFileExists | Picks a Unicode (W) or ASCII (A) version of the NFileExists function.
NFileGetAttributes | Picks a Unicode (W) or ASCII (A) version of the NFileGetAttributes function.
NFileOpen | Picks a Unicode (W) or ASCII (A) version of the NFileOpen function.
NFileOpenRead | Picks a Unicode (W) or ASCII (A) version of the NFileOpenRead function.
NFileOpenText | Picks a Unicode (W) or ASCII (A) version of the NFileOpenText function.
NFileOpenWithAccess | Picks a Unicode (W) or ASCII (A) version of the NFileOpenWithAccess function.
NFileOpenWithAccessAndShare | Picks a Unicode (W) or ASCII (A) version of the NFileOpenWithAccessAndShare function.
NFileOpenWrite | Picks a Unicode (W) or ASCII (A) version of the NFileOpenWrite function.
NFileReadAllBytesCN | Picks a Unicode (W) or ASCII (A) version of the NFileReadAllBytesCN function.
NFileReadAllLinesCN | Picks a Unicode (W) or ASCII (A) version of the NFileReadAllLinesCN function.
NFileReadAllLinesWithEncodingCN | Picks a Unicode (W) or ASCII (A) version of the NFileReadAllLinesWithEncodingCN function.
NFileReadAllTextCN | Picks a Unicode (W) or ASCII (A) version of the NFileReadAllTextCN function.
NFileReadAllTextWithEncodingCN | Picks a Unicode (W) or ASCII (A) version of the NFileReadAllTextWithEncodingCN function.
NFileWriteAllBytes | Picks a Unicode (W) or ASCII (A) version of the NFileWriteAllBytes function.
NFileWriteAllBytesCN | Picks a Unicode (W) or ASCII (A) version of the NFileWriteAllBytesCN function.
NFileWriteAllLines | Picks a Unicode (W) or ASCII (A) version of the NFileWriteAllLines function.
NFileWriteAllLinesPN | Picks a Unicode (W) or ASCII (A) version of the NFileWriteAllLinesPN function.
NFileWriteAllLinesWithEncoding | Picks a Unicode (W) or ASCII (A) version of the NFileWriteAllLinesWithEncoding function.
NFileWriteAllLinesWithEncodingPN | Picks a Unicode (W) or ASCII (A) version of the NFileWriteAllLinesWithEncodingPN function.
NFileWriteAllText | Picks a Unicode (W) or ASCII (A) version of the NFileWriteAllText function.
NFileWriteAllTextPN | Picks a Unicode (W) or ASCII (A) version of the NFileWriteAllTextPN function.
NFileWriteAllTextWithEncoding | Picks a Unicode (W) or ASCII (A) version of the NFileWriteAllTextWithEncoding function.
NFileWriteAllTextWithEncodingPN | Picks a Unicode (W) or ASCII (A) version of the NFileWriteAllTextWithEncodingPN function.
Collapse Expand Structs, Records, Enums
Name | Description
NFileAttributes_ | Enumerates file attributes.
NFileAttributes | Enumerates file attributes.


NFileAppendAllLines Function

NFileAppendAllLines Function

Picks a Unicode (W) or ANSCII (A) version of the NFileAppendAllLines function.

C++
NResult N_API NFileAppendAllLines(const NChar * szPath, const NChar * * arszContent, NInt contentLength);
Collapse Expand Parameters
Parameters | Description
const NChar * szPath | [in] File path.
const NChar * * arszContent | [in] Content of the file.
NInt contentLength | [in] Length of the content.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NFile.h

Module: NFile Unit


NFileAppendAllLinesPN Function

NFileAppendAllLinesPN Function

Picks a Unicode (W) or ANSCII (A) version of the NFileAppendAllLinesPN function.

C++
NResult N_API NFileAppendAllLinesPN(HNString hPath, const NChar * * arszContent, NInt contentLength);
Collapse Expand Parameters
Parameters | Description
HNString hPath | [in] File path.
const NChar * * arszContent | [in] NChar array containing file content.
NInt contentLength | [in] Length of the content.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NFile.h

Module: NFile Unit


NFileAppendAllLinesWithEncoding Function

NFileAppendAllLinesWithEncoding Function

Picks a Unicode (W) or ANSCII (A) version of the NFileAppendAllLinesWithEncoding function.

C++
NResult N_API NFileAppendAllLinesWithEncoding(const NChar * szPath, const NChar * * arszContent, NInt contentLength, NEncoding encoding);
Collapse Expand Parameters
Parameters | Description
const NChar * szPath | [in] File path.
const NChar * * arszContent | [in] NChar array containing file content.
NInt contentLength | [in] Length of the content.
NEncoding encoding | [in] File encoding.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NFile.h

Module: NFile Unit


NFileAppendAllLinesWithEncodingPN Function

NFileAppendAllLinesWithEncodingPN Function

Picks a Unicode (W) or ANSCII (A) version of the NFileAppendAllLinesWithEncodingPN function.

C++
NResult N_API NFileAppendAllLinesWithEncodingPN(HNString hPath, const NChar * * arszContent, NInt contentLength, NEncoding encoding);
Collapse Expand Parameters
Parameters | Description
HNString hPath | [in] File path.
const NChar * * arszContent | [in] NChar array containing file content.
NInt contentLength | [in] Length of the content.
NEncoding encoding | [in] File encoding.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NFile.h

Module: NFile Unit


NFileAppendAllText Function

NFileAppendAllText Function

Opens a file, appends the specified string to the file, and then closes the file.

C++
NResult N_API NFileAppendAllText(const NChar * szPath, const NChar * szContent);
Collapse Expand Parameters
Parameters | Description
const NChar * szPath | [in] Pointer to the path of the file to append the specified string to.
const NChar * szContent | [in] Pointer to the string to append to the file.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

If the file does not exist, this method creates a file, writes the specified string to the file, then closes the file.

Container

File: NFile.h

Module: NFile Unit


NFileAppendAllTextPN Function

NFileAppendAllTextPN Function

Opens a file, appends the specified string to the file, and then closes the file.

C++
NResult N_API NFileAppendAllTextPN(HNString hPath, const NChar * szContent);
Collapse Expand Parameters
Parameters | Description
HNString hPath | [in] Handle to the path of the file to append the specified string to.
const NChar * szContent | [in] Pointer to the string to append to the file.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

If the file does not exist, this method creates a file, writes the specified string to the file, then closes the file.

Container

File: NFile.h

Module: NFile Unit


NFileAppendAllTextWithEncoding Function

NFileAppendAllTextWithEncoding Function

Opens a file, appends the specified string to the file, and then closes the file.

C++
NResult N_API NFileAppendAllTextWithEncoding(const NChar * szPath, const NChar * szContent, NEncoding encoding);
Collapse Expand Parameters
Parameters | Description
const NChar * szPath | [in] Pointer to the path of the file to append the specified string to.
const NChar * szContent | [in] Pointer to the string to append to the file.
NEncoding encoding | [in] The encoding to be used.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

If the file does not exist, this method creates a file, writes the specified string to the file, then closes the file.

Container

File: NFile.h

Module: NFile Unit


NFileAppendAllTextWithEncodingPN Function

NFileAppendAllTextWithEncodingPN Function

Opens a file, appends the specified string to the file, and then closes the file.

C++
NResult N_API NFileAppendAllTextWithEncodingPN(HNString hPath, const NChar * szContent, NEncoding encoding);
Collapse Expand Parameters
Parameters | Description
HNString hPath | [in] Handle to the path of the file to append the specified string to.
const NChar * szContent | [in] Pointer to the string to append to the file.
NEncoding encoding | [in] The encoding to be used.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

If the file does not exist, this method creates a file, writes the specified string to the file, then closes the file.

Container

File: NFile.h

Module: NFile Unit


NFileAppendText Function

NFileAppendText Function

Creates a StreamWriter that appends UTF-8 encoded text to an existing file.

C++
NResult N_API NFileAppendText(const NChar * szPath, HNStreamWriter * phWriter);
Collapse Expand Parameters
Parameters | Description
const NChar * szPath | [in] Pointer to the path of the file to append the specified string to.
HNStreamWriter * phWriter | [out] Pointer to NStreamWriter that appends UTF-8 encoded text to an existing file.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NFile.h

Module: NFile Unit


NFileCreate Function

NFileCreate Function

Creates a file in the specified path.

C++
NResult N_API NFileCreate(const NChar * szPath, HNFileStream * phStream);
Collapse Expand Parameters
Parameters | Description
const NChar * szPath | [in] Pointer to the path and name of the file to create.
HNFileStream * phStream | [out] Pointer to a handle to a NFileStream that provides read/write access to the file specified in szPath.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NFile.h

Module: NFile Unit


NFileCreateText Function

NFileCreateText Function

Creates or opens a file for writing UTF-8 encoded text.

C++
NResult N_API NFileCreateText(const NChar * szPath, HNStreamWriter * phWriter);
Collapse Expand Parameters
Parameters | Description
const NChar * szPath | [in] Pointer to path of the file to be opened for writing.
HNStreamWriter * phWriter | [out] Pointer to a handle to a NStreamWriter that writes to the specified file using UTF-8 encoding.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NFile.h

Module: NFile Unit


NFileCreateWithBufferSize Function

NFileCreateWithBufferSize Function

Creates a file in the specified path with the specified buffer size.

C++
NResult N_API NFileCreateWithBufferSize(const NChar * szPath, NSizeType bufferSize, HNFileStream * phStream);
Collapse Expand Parameters
Parameters | Description
const NChar * szPath | [in] Pointer to the path and name of the file to create.
NSizeType bufferSize | [in] The buffer size.
HNFileStream * phStream | [out] Pointer to a handle to a NFileStream that provides read/write access to the file specified in szPath.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NFile.h

Module: NFile Unit


NFileDelete Function

NFileDelete Function

Deletes the specified file. An exception is not thrown if the specified file does not exist.

C++
NResult N_API NFileDelete(const NChar * szPath);
Collapse Expand Parameters
Parameters | Description
const NChar * szPath | [in] Pointer to the name of the file to be deleted.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NFile.h

Module: NFile Unit


NFileExists Function

NFileExists Function

Determines whether the file with the specified path exists.

C++
NResult N_API NFileExists(const NChar * szPath, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
const NChar * szPath | [in] Pointer to the file path to check.
NBool * pValue | [out] NTrue if the file exists; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NFile.h

Module: NFile Unit


NFileGetAttributes Function

NFileGetAttributes Function

Gets the attributes of the file on the path.

C++
NResult N_API NFileGetAttributes(const NChar * szPath, NFileAttributes * pValue);
Collapse Expand Parameters
Parameters | Description
const NChar * szPath | [in] Pointer to the path of the file.
NFileAttributes * pValue | [out] Pointer to the NFileAttributes object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NFile.h

Module: NFile Unit


NFileOpen Function

NFileOpen Function

Opens a NFileStream on the specified path with read/write access.

C++
NResult N_API NFileOpen(const NChar * szPath, NFileMode mode, HNFileStream * phStream);
Collapse Expand Parameters
Parameters | Description
const NChar * szPath | [in] Pointer to the path of the file to be opened.
NFileMode mode | [in] A FileMode value that specifies whether a file is created if one does not exist, and determines whether the contents of existing files are retained or overwritten.
HNFileStream * phStream | [out] Pointer to a handle to NFileStream opened in the specified mode and path, with read/write access and not shared.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NFile.h

Module: NFile Unit


NFileOpenRead Function

NFileOpenRead Function

Opens an existing file for reading.

C++
NResult N_API NFileOpenRead(const NChar * szPath, HNFileStream * phStream);
Collapse Expand Parameters
Parameters | Description
const NChar * szPath | [in] Pointer to the path of the file to be opened.
HNFileStream * phStream | [out] Pointer to a handle to a read-only NFileStream on the specified path.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NFile.h

Module: NFile Unit


NFileOpenText Function

NFileOpenText Function

Opens an existing UTF-8 encoded text file for reading.

C++
NResult N_API NFileOpenText(const NChar * szPath, HNStreamReader * phReader);
Collapse Expand Parameters
Parameters | Description
const NChar * szPath | [in] Pointer to the path of the file to be opened.
HNStreamReader * phReader | [out] Pointer to a handle to a NStreamReader on the specified path.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NFile.h

Module: NFile Unit


NFileOpenWithAccess Function

NFileOpenWithAccess Function

Opens a NFileStream on the specified path, with the specified mode and access.

C++
NResult N_API NFileOpenWithAccess(const NChar * szPath, NFileMode mode, NFileAccess access, HNFileStream * phStream);
Collapse Expand Parameters
Parameters | Description
const NChar * szPath | [in] Pointer to the path of the file to be opened.
NFileMode mode | [in] A FileMode value that specifies whether a file is created if one does not exist, and determines whether the contents of existing files are retained or overwritten.
NFileAccess access | [in] A FileAccess value that specifies the operations that can be performed on the file.
HNFileStream * phStream | [out] Pointer to a handle to an unshared NFileStream that provides access to the specified file, with the specified mode and access.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NFile.h

Module: NFile Unit


NFileOpenWithAccessAndShare Function

NFileOpenWithAccessAndShare Function

Opens a NFileStream on the specified path, having the specified mode with read, write, or read/write access and the specified sharing option.

C++
NResult N_API NFileOpenWithAccessAndShare(const NChar * szPath, NFileMode mode, NFileAccess access, NFileShare share, HNFileStream * phStream);
Collapse Expand Parameters
Parameters | Description
const NChar * szPath | [in] Pointer to the path of the file to be opened.
NFileMode mode | [in] A FileMode value that specifies whether a file is created if one does not exist, and determines whether the contents of existing files are retained or overwritten.
NFileAccess access | [in] A FileAccess value that specifies the operations that can be performed on the file.
NFileShare share | [in] A FileShare value specifying the type of access other threads have to the file.
HNFileStream * phStream | [out] Pointer to a handle to a NFileStream on the specified path, having the specified mode with read, write, or read/write access and the specified sharing option.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NFile.h

Module: NFile Unit


NFileOpenWrite Function

NFileOpenWrite Function

Opens an existing file for writing.

C++
NResult N_API NFileOpenWrite(const NChar * szPath, HNFileStream * phStream);
Collapse Expand Parameters
Parameters | Description
const NChar * szPath | [in] Pointer to the path of the file to be opened.
HNFileStream * phStream | [out] Pointer to a handle to an unshared NFileStream object on the specified path with Write access.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NFile.h

Module: NFile Unit


NFileReadAllBytesCN Function

NFileReadAllBytesCN Function

Opens a binary file, reads the contents of the file into a byte array, and then closes the file.

C++
NResult N_API NFileReadAllBytesCN(const NChar * szPath, HNBuffer * phContent);
Collapse Expand Parameters
Parameters | Description
const NChar * szPath | [in] Pointer to the path of the file to be opened for reading.
HNBuffer * phContent | [out] Pointer to a handle to NBuffer containing the read bytes.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NFile.h

Module: NFile Unit


NFileReadAllBytesN Function

NFileReadAllBytesN Function

Opens a binary file, reads the contents of the file into a byte array, and then closes the file.

C++
NResult N_API NFileReadAllBytesN(HNString hPath, HNBuffer * phContent);
Collapse Expand Parameters
Parameters | Description
HNString hPath | [in] Handle to the path of the file to be opened for reading.
HNBuffer * phContent | [out] Pointer to a handle to NBuffer containing the read bytes.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NFile.h

Module: NFile Unit


NFileReadAllLinesCN Function

NFileReadAllLinesCN Function

Opens a text file, reads all lines of the file, and then closes the file.

C++
NResult N_API NFileReadAllLinesCN(const NChar * szPath, HNString * * parhContent, NInt * pContentLength);
Collapse Expand Parameters
Parameters | Description
const NChar * szPath | [in] Pointer to the path of the file to be opened for reading.
HNString * * parhContent | [out] Pointer to an array of string handles containing all lines of the file.
NInt * pContentLength | [out] Pointer to the size of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NFile.h

Module: NFile Unit


NFileReadAllLinesN Function

NFileReadAllLinesN Function

Opens a text file, reads all lines of the file, and then closes the file.

C++
NResult N_API NFileReadAllLinesN(HNString hPath, HNString * * parhContent, NInt * pContentLength);
Collapse Expand Parameters
Parameters | Description
HNString hPath | [in] Handle to the path of the file to be opened for reading.
HNString * * parhContent | [out] Pointer to an array of string handles containing all lines of the file.
NInt * pContentLength | [out] Pointer to the size of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NFile.h

Module: NFile Unit


NFileReadAllLinesWithEncodingCN Function

NFileReadAllLinesWithEncodingCN Function

Opens a file, reads all lines of the file with the specified encoding, and then closes the file.

C++
NResult N_API NFileReadAllLinesWithEncodingCN(const NChar * szPath, NEncoding encoding, NBool detectEncodingFromByteOrderMarks, HNString * * parhContent, NInt * pContentLength);
Collapse Expand Parameters
Parameters | Description
const NChar * szPath | [in] Pointer to the path of the file to be opened for reading.
NEncoding encoding | [in] The encoding applied to the contents of the file.
NBool detectEncodingFromByteOrderMarks | [in] NTrue if the encoding should be detected form byte order marks; else NFalse.
HNString * * parhContent | [out] Pointer to an array of string handles containing all lines of the file.
NInt * pContentLength | [out] Pointer to the size of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NFile.h

Module: NFile Unit


NFileReadAllLinesWithEncodingN Function

NFileReadAllLinesWithEncodingN Function

Opens a file, reads all lines of the file with the specified encoding, and then closes the file.

C++
NResult N_API NFileReadAllLinesWithEncodingN(HNString hPath, NEncoding encoding, NBool detectEncodingFromByteOrderMarks, HNString * * parhContent, NInt * pContentLength);
Collapse Expand Parameters
Parameters | Description
HNString hPath | [in] Handle to the path of the file to be opened for reading.
NEncoding encoding | [in] The encoding applied to the contents of the file.
NBool detectEncodingFromByteOrderMarks | [in] NTrue if the encoding should be detected form byte order marks; else NFalse.
HNString * * parhContent | [out] Pointer to an array of string handles containing all lines of the file.
NInt * pContentLength | [out] Pointer to the size of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NFile.h

Module: NFile Unit


NFileReadAllTextCN Function

NFileReadAllTextCN Function

Opens a text file, reads all lines of the file, and then closes the file.

C++
NResult N_API NFileReadAllTextCN(const NChar * szPath, HNString * phContent);
Collapse Expand Parameters
Parameters | Description
const NChar * szPath | [in] Pointer to the path of the file to be opened for reading.
HNString * phContent | [out] Pointer to a handle to NString containing all lines of the file.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NFile.h

Module: NFile Unit


NFileReadAllTextN Function

NFileReadAllTextN Function

Opens a text file, reads all lines of the file, and then closes the file.

C++
NResult N_API NFileReadAllTextN(HNString hPath, HNString * phContent);
Collapse Expand Parameters
Parameters | Description
HNString hPath | [in] Handle to the path of the file to be opened for reading.
HNString * phContent | [out] Pointer to a handle to NString containing all lines of the file.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NFile.h

Module: NFile Unit


NFileReadAllTextWithEncodingCN Function

NFileReadAllTextWithEncodingCN Function

Opens a file, reads all lines of the file with the specified encoding, and then closes the file.

C++
NResult N_API NFileReadAllTextWithEncodingCN(const NChar * szPath, NEncoding encoding, NBool detectEncodingFromByteOrderMarks, HNString * phContent);
Collapse Expand Parameters
Parameters | Description
const NChar * szPath | [in] Pointer to the path of the file to be opened for reading.
NEncoding encoding | [in] The encoding applied to the contents of the file.
NBool detectEncodingFromByteOrderMarks | [in] NTrue if the encoding should be detected form byte order marks; else NFalse.
HNString * phContent | [out] Pointer to a handle to NString containing all lines of the file.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NFile.h

Module: NFile Unit


NFileReadAllTextWithEncodingN Function

NFileReadAllTextWithEncodingN Function

Opens a file, reads all lines of the file with the specified encoding, and then closes the file.

C++
NResult N_API NFileReadAllTextWithEncodingN(HNString hPath, NEncoding encoding, NBool detectEncodingFromByteOrderMarks, HNString * phContent);
Collapse Expand Parameters
Parameters | Description
HNString hPath | [in] Handle to the path of the file to be opened for reading.
NEncoding encoding | [in] The encoding applied to the contents of the file.
NBool detectEncodingFromByteOrderMarks | [in] NTrue if the encoding should be detected form byte order marks; else NFalse.
HNString * phContent | [out] Pointer to a handle to NString containing all lines of the file.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NFile.h

Module: NFile Unit


NFileWriteAllBytes Function

NFileWriteAllBytes Function

Creates a new file, writes the specified byte array to the file, and then closes the file.

C++
NResult N_API NFileWriteAllBytes(const NChar * szPath, const void * pContent, NSizeType contentSize);
Collapse Expand Parameters
Parameters | Description
const NChar * szPath | [in] Pointer to the path of the file to write to.
const void * pContent | [in] Pointer to a byte array to write the bytes from.
NSizeType contentSize | [in] Size of the byte array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Notes

If the target file already exists, it is overwritten.

Container

File: NFile.h

Module: NFile Unit


NFileWriteAllBytesCN Function

NFileWriteAllBytesCN Function

Creates a new file, writes the specified buffer to the file, and then closes the file.

C++
NResult N_API NFileWriteAllBytesCN(const NChar * szPath, HNBuffer hContent);
Collapse Expand Parameters
Parameters | Description
const NChar * szPath | [in] Pointer to the path of the file to write to.
HNBuffer hContent | [in] Handle to the buffer to write the bytes from.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Notes

If the target file already exists, it is overwritten.

Container

File: NFile.h

Module: NFile Unit


NFileWriteAllBytesPN Function

NFileWriteAllBytesPN Function

Creates a new file, writes the specified byte array to the file, and then closes the file.

C++
NResult N_API NFileWriteAllBytesPN(HNString hPath, const void * pContent, NSizeType contentSize);
Collapse Expand Parameters
Parameters | Description
HNString hPath | [in] Handle to the path of the file to write to.
const void * pContent | [in] Pointer to a byte array to write the bytes from.
NSizeType contentSize | [in] Size of the byte array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Notes

If the target file already exists, it is overwritten.

Container

File: NFile.h

Module: NFile Unit


NFileWriteAllLines Function

NFileWriteAllLines Function

Creates a new file, write the specified char array to the file, and then closes the file.

C++
NResult N_API NFileWriteAllLines(const NChar * szPath, const NChar * * arszContent, NInt contentLength);
Collapse Expand Parameters
Parameters | Description
const NChar * szPath | [in] Pointer to the path of the file to write to.
const NChar * * arszContent | [in] Pointer to the char array to write to the file.
NInt contentLength | [in] Size of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Notes

If the target file already exists, it is overwritten.

Container

File: NFile.h

Module: NFile Unit


NFileWriteAllLinesPN Function

NFileWriteAllLinesPN Function

Creates a new file, write the specified char array to the file, and then closes the file.

C++
NResult N_API NFileWriteAllLinesPN(HNString hPath, const NChar * * arszContent, NInt contentLength);
Collapse Expand Parameters
Parameters | Description
HNString hPath | [in] Handle to the path of the file to write to.
const NChar * * arszContent | [in] Pointer to the char array to write to the file.
NInt contentLength | [in] Size of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Notes

If the target file already exists, it is overwritten.

Container

File: NFile.h

Module: NFile Unit


NFileWriteAllLinesWithEncoding Function

NFileWriteAllLinesWithEncoding Function

Creates a new file, writes the specified char array to the file using the specified encoding, and then closes the file.

C++
NResult N_API NFileWriteAllLinesWithEncoding(const NChar * szPath, const NChar * * arszContent, NInt contentLength, NEncoding encoding);
Collapse Expand Parameters
Parameters | Description
const NChar * szPath | [in] Pointer to the path of the file to write to.
const NChar * * arszContent | [in] Pointer to the char array to write to the file.
NInt contentLength | [in] Size of the array.
NEncoding encoding | [in] Encoding applied to the characters written into the file.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Notes

If the target file already exists, it is overwritten.

Container

File: NFile.h

Module: NFile Unit


NFileWriteAllLinesWithEncodingPN Function

NFileWriteAllLinesWithEncodingPN Function

Creates a new file, writes the specified char array to the file using the specified encoding, and then closes the file.

C++
NResult N_API NFileWriteAllLinesWithEncodingPN(HNString hPath, const NChar * * arszContent, NInt contentLength, NEncoding encoding);
Collapse Expand Parameters
Parameters | Description
HNString hPath | [in] Handle to the path of the file to write to.
const NChar * * arszContent | [in] Pointer to the char array to write to the file.
NInt contentLength | [in] Size of the array.
NEncoding encoding | [in] Encoding applied to the characters written into the file.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Notes

If the target file already exists, it is overwritten.

Container

File: NFile.h

Module: NFile Unit


NFileWriteAllText Function

NFileWriteAllText Function

Creates a new file, writes the specified char to the file, and then closes the file.

C++
NResult N_API NFileWriteAllText(const NChar * szPath, const NChar * szContent);
Collapse Expand Parameters
Parameters | Description
const NChar * szPath | [in] Pointer to the path of the file to write to.
const NChar * szContent | [in] Pointer to char to write to the file.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Notes

If the target file already exists, it is overwritten.

Container

File: NFile.h

Module: NFile Unit


NFileWriteAllTextCN Function

NFileWriteAllTextCN Function

Picks a Unicode (W) or ASCII (A) version of the NFileWriteAllTextCN function.

C++
NResult N_API NFileWriteAllTextCN(const NChar * szPath, HNString hContent);
Collapse Expand Parameters
Parameters | Description
const NChar * szPath | [in] Path of the file to write to.
HNString hContent | [in] Handle to NString to write to the file.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NFile.h

Module: NFile Unit


NFileWriteAllTextPN Function

NFileWriteAllTextPN Function

Creates a new file, writes the specified string array to the file, and then closes the file.

C++
NResult N_API NFileWriteAllTextPN(HNString hPath, const NChar * szContent);
Collapse Expand Parameters
Parameters | Description
HNString hPath | [in] Handle to the path of the file to write to.
const NChar * szContent | [in] Pointer to char to write to the file.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Notes

If the target file already exists, it is overwritten.

Container

File: NFile.h

Module: NFile Unit


NFileWriteAllTextWithEncoding Function

NFileWriteAllTextWithEncoding Function

Creates a new file, writes the specified string array to the file using the specified encoding, and then closes the file.

C++
NResult N_API NFileWriteAllTextWithEncoding(const NChar * szPath, const NChar * szContent, NEncoding encoding);
Collapse Expand Parameters
Parameters | Description
const NChar * szPath | [in] Pointer to the path of the file to write to.
const NChar * szContent | [in] Pointer to char to write to the file.
NEncoding encoding | [in] Encoding applied to the characters written into the file.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Notes

If the target file already exists, it is overwritten.

Container

File: NFile.h

Module: NFile Unit


NFileWriteAllTextWithEncodingPN Function

NFileWriteAllTextWithEncodingPN Function

Creates a new file, writes the specified string array to the file using the specified encoding, and then closes the file.

C++
NResult N_API NFileWriteAllTextWithEncodingPN(HNString hPath, const NChar * szContent, NEncoding encoding);
Collapse Expand Parameters
Parameters | Description
HNString hPath | [in] Handle to the path of the file to write to.
const NChar * szContent | [in] Pointer to char to write to the file.
NEncoding encoding | [in] Encoding applied to the characters written into the file.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Notes

If the target file already exists, it is overwritten.

Container

File: NFile.h

Module: NFile Unit


NFileAttributes Enumeration

NFileAttributes Enumeration

Enumerates file attributes.

C++
typedef enum NFileAttributes_ {
  nfatNone = 0,
  nfatDirectory = 1
} NFileAttributes;
Collapse Expand Members
Members | Description
nfatNone = 0 | None.
nfatDirectory = 1 | Directory.
Container

File: NFile.h

Module: NFile Unit


NFileAppendAllText Macro

NFileAppendAllText Macro

Picks a Unicode (W) or ASCII (A) version of the NFileAppendAllText function.

C++
#define NFileAppendAllText N_FUNC_AW(NFileAppendAllText)
Container

File: NFile.h

Module: NFile Unit


NFileAppendAllTextPN Macro

NFileAppendAllTextPN Macro

Picks a Unicode (W) or ASCII (A) version of the NFileAppendAllTextPN function.

C++
#define NFileAppendAllTextPN N_FUNC_AW(NFileAppendAllTextPN)
Container

File: NFile.h

Module: NFile Unit


NFileAppendAllTextWithEncoding Macro

NFileAppendAllTextWithEncoding Macro

Picks a Unicode (W) or ASCII (A) version of the NFileAppendAllTextWithEncoding function.

C++
#define NFileAppendAllTextWithEncoding N_FUNC_AW(NFileAppendAllTextWithEncoding)
Container

File: NFile.h

Module: NFile Unit


NFileAppendAllTextWithEncodingPN Macro

NFileAppendAllTextWithEncodingPN Macro

Picks a Unicode (W) or ASCII (A) version of the NFileAppendAllTextWithEncodingPN function.

C++
#define NFileAppendAllTextWithEncodingPN N_FUNC_AW(NFileAppendAllTextWithEncodingPN)
Container

File: NFile.h

Module: NFile Unit


NFileAppendText Macro

NFileAppendText Macro

Picks a Unicode (W) or ASCII (A) version of the NFileAppendText function.

C++
#define NFileAppendText N_FUNC_AW(NFileAppendText)
Container

File: NFile.h

Module: NFile Unit


NFileCreate Macro

NFileCreate Macro

Picks a Unicode (W) or ASCII (A) version of the NFileCreate function.

C++
#define NFileCreate N_FUNC_AW(NFileCreate)
Container

File: NFile.h

Module: NFile Unit


NFileCreateText Macro

NFileCreateText Macro

Picks a Unicode (W) or ASCII (A) version of the NFileAppendCreateText function.

C++
#define NFileCreateText N_FUNC_AW(NFileCreateText)
Container

File: NFile.h

Module: NFile Unit


NFileCreateWithBufferSize Macro

NFileCreateWithBufferSize Macro

Picks a Unicode (W) or ASCII (A) version of the NFileAppendCreateWithBufferSize function.

C++
#define NFileCreateWithBufferSize N_FUNC_AW(NFileCreateWithBufferSize)
Container

File: NFile.h

Module: NFile Unit


NFileDelete Macro

NFileDelete Macro

Picks a Unicode (W) or ASCII (A) version of the NFileDelete function.

C++
#define NFileDelete N_FUNC_AW(NFileDelete)
Container

File: NFile.h

Module: NFile Unit


NFileExists Macro

NFileExists Macro

Picks a Unicode (W) or ASCII (A) version of the NFileExists function.

C++
#define NFileExists N_FUNC_AW(NFileExists)
Container

File: NFile.h

Module: NFile Unit


NFileGetAttributes Macro

NFileGetAttributes Macro

Picks a Unicode (W) or ASCII (A) version of the NFileGetAttributes function.

C++
#define NFileGetAttributes N_FUNC_AW(NFileGetAttributes)
Container

File: NFile.h

Module: NFile Unit


NFileOpen Macro

NFileOpen Macro

Picks a Unicode (W) or ASCII (A) version of the NFileOpen function.

C++
#define NFileOpen N_FUNC_AW(NFileOpen)
Container

File: NFile.h

Module: NFile Unit


NFileOpenRead Macro

NFileOpenRead Macro

Picks a Unicode (W) or ASCII (A) version of the NFileOpenRead function.

C++
#define NFileOpenRead N_FUNC_AW(NFileOpenRead)
Container

File: NFile.h

Module: NFile Unit


NFileOpenText Macro

NFileOpenText Macro

Picks a Unicode (W) or ASCII (A) version of the NFileOpenText function.

C++
#define NFileOpenText N_FUNC_AW(NFileOpenText)
Container

File: NFile.h

Module: NFile Unit


NFileOpenWithAccess Macro

NFileOpenWithAccess Macro

Picks a Unicode (W) or ASCII (A) version of the NFileOpenWithAccess function.

C++
#define NFileOpenWithAccess N_FUNC_AW(NFileOpenWithAccess)
Container

File: NFile.h

Module: NFile Unit


NFileOpenWithAccessAndShare Macro

NFileOpenWithAccessAndShare Macro

Picks a Unicode (W) or ASCII (A) version of the NFileOpenWithAccessAndShare function.

C++
#define NFileOpenWithAccessAndShare N_FUNC_AW(NFileOpenWithAccessAndShare)
Container

File: NFile.h

Module: NFile Unit


NFileOpenWrite Macro

NFileOpenWrite Macro

Picks a Unicode (W) or ASCII (A) version of the NFileOpenWrite function.

C++
#define NFileOpenWrite N_FUNC_AW(NFileOpenWrite)
Container

File: NFile.h

Module: NFile Unit


NFileReadAllBytesCN Macro

NFileReadAllBytesCN Macro

Picks a Unicode (W) or ASCII (A) version of the NFileReadAllBytesCN function.

C++
#define NFileReadAllBytesCN N_FUNC_AW(NFileReadAllBytesCN)
Container

File: NFile.h

Module: NFile Unit


NFileReadAllLinesCN Macro

NFileReadAllLinesCN Macro

Picks a Unicode (W) or ASCII (A) version of the NFileReadAllLinesCN function.

C++
#define NFileReadAllLinesCN N_FUNC_AW(NFileReadAllLinesCN)
Container

File: NFile.h

Module: NFile Unit


NFileReadAllLinesWithEncodingCN Macro

NFileReadAllLinesWithEncodingCN Macro

Picks a Unicode (W) or ASCII (A) version of the NFileReadAllLinesWithEncodingCN function.

C++
#define NFileReadAllLinesWithEncodingCN N_FUNC_AW(NFileReadAllLinesWithEncodingCN)
Container

File: NFile.h

Module: NFile Unit


NFileReadAllTextCN Macro

NFileReadAllTextCN Macro

Picks a Unicode (W) or ASCII (A) version of the NFileReadAllTextCN function.

C++
#define NFileReadAllTextCN N_FUNC_AW(NFileReadAllTextCN)
Container

File: NFile.h

Module: NFile Unit


NFileReadAllTextWithEncodingCN Macro

NFileReadAllTextWithEncodingCN Macro

Picks a Unicode (W) or ASCII (A) version of the NFileReadAllTextWithEncodingCN function.

C++
#define NFileReadAllTextWithEncodingCN N_FUNC_AW(NFileReadAllTextWithEncodingCN)
Container

File: NFile.h

Module: NFile Unit


NFileWriteAllBytes Macro

NFileWriteAllBytes Macro

Picks a Unicode (W) or ASCII (A) version of the NFileWriteAllBytes function.

C++
#define NFileWriteAllBytes N_FUNC_AW(NFileWriteAllBytes)
Container

File: NFile.h

Module: NFile Unit


NFileWriteAllBytesCN Macro

NFileWriteAllBytesCN Macro

Picks a Unicode (W) or ASCII (A) version of the NFileWriteAllBytesCN function.

C++
#define NFileWriteAllBytesCN N_FUNC_AW(NFileWriteAllBytesCN)
Container

File: NFile.h

Module: NFile Unit


NFileWriteAllLines Macro

NFileWriteAllLines Macro

Picks a Unicode (W) or ASCII (A) version of the NFileWriteAllLines function.

C++
#define NFileWriteAllLines N_FUNC_AW(NFileWriteAllLines)
Container

File: NFile.h

Module: NFile Unit


NFileWriteAllLinesPN Macro

NFileWriteAllLinesPN Macro

Picks a Unicode (W) or ASCII (A) version of the NFileWriteAllLinesPN function.

C++
#define NFileWriteAllLinesPN N_FUNC_AW(NFileWriteAllLinesPN)
Container

File: NFile.h

Module: NFile Unit


NFileWriteAllLinesWithEncoding Macro

NFileWriteAllLinesWithEncoding Macro

Picks a Unicode (W) or ASCII (A) version of the NFileWriteAllLinesWithEncoding function.

C++
#define NFileWriteAllLinesWithEncoding N_FUNC_AW(NFileWriteAllLinesWithEncoding)
Container

File: NFile.h

Module: NFile Unit


NFileWriteAllLinesWithEncodingPN Macro

NFileWriteAllLinesWithEncodingPN Macro

Picks a Unicode (W) or ASCII (A) version of the NFileWriteAllLinesWithEncodingPN function.

C++
#define NFileWriteAllLinesWithEncodingPN N_FUNC_AW(NFileWriteAllLinesWithEncodingPN)
Container

File: NFile.h

Module: NFile Unit


NFileWriteAllText Macro

NFileWriteAllText Macro

Picks a Unicode (W) or ASCII (A) version of the NFileWriteAllText function.

C++
#define NFileWriteAllText N_FUNC_AW(NFileWriteAllText)
Container

File: NFile.h

Module: NFile Unit


NFileWriteAllTextPN Macro

NFileWriteAllTextPN Macro

Picks a Unicode (W) or ASCII (A) version of the NFileWriteAllTextPN function.

C++
#define NFileWriteAllTextPN N_FUNC_AW(NFileWriteAllTextPN)
Container

File: NFile.h

Module: NFile Unit


NFileWriteAllTextWithEncoding Macro

NFileWriteAllTextWithEncoding Macro

Picks a Unicode (W) or ASCII (A) version of the NFileWriteAllTextWithEncoding function.

C++
#define NFileWriteAllTextWithEncoding N_FUNC_AW(NFileWriteAllTextWithEncoding)
Container

File: NFile.h

Module: NFile Unit


NFileWriteAllTextWithEncodingPN Macro

NFileWriteAllTextWithEncodingPN Macro

Picks a Unicode (W) or ASCII (A) version of the NFileWriteAllTextWithEncodingPN function.

C++
#define NFileWriteAllTextWithEncodingPN N_FUNC_AW(NFileWriteAllTextWithEncodingPN)
Container

File: NFile.h

Module: NFile Unit


NFileStream Unit

NFileStream Unit
Functions Legend Macros

Provides functions supporting both synchronous and asynchronous file read and write operations.

Collapse Expand Functions
Name | Description
NFileStreamCreate | Creates file stream with the specified path and creation mode.
NFileStreamCreateFromOSHandle | Creates a new NFileStream for the specified file handle, with the specified read/write permission.
NFileStreamCreateFromOSHandleWithBufferSize | Creates a new NFileStream for the specified file handle, with the specified read/write permission, and buffer size.
NFileStreamCreateWithAccess | Creates a new NFileStream with the specified path, creation mode, and read/write permission.
NFileStreamCreateWithAccessAndShare | Creates a new NFileStream with the specified path, creation mode, read/write permission, and sharing permission.
NFileStreamCreateWithAccessShareAndBufferSize | ... more
NFileStreamGetOSHandle | Gets OS handle for the specified file.
Collapse Expand Macros
Name | Description
NFileStreamCreate | Picks a Unicode (W) or ASCII (A) version of the NFileStreamCreate function.
NFileStreamCreateWithAccess | Picks a Unicode (W) or ASCII (A) version of the NFileStreamCreateWithAccess function.
NFileStreamCreateWithAccessAndShare | Picks a Unicode (W) or ASCII (A) version of the NFileStreamCreateWithAccessAndShare function.
NFileStreamCreateWithAccessShareAndBufferSize | Picks a Unicode (W) or ASCII (A) version of the NFileStreamCreateWithAccessShareAndBufferSize function.


NFileStreamCreate Function

NFileStreamCreate Function

Creates file stream with the specified path and creation mode.

C++
NResult N_API NFileStreamCreate(const NChar * szPath, NFileMode mode, HNFileStream * phStream);
Collapse Expand Parameters
Parameters | Description
const NChar * szPath | [in] Zero terminated string containing path for the file that the current NFileStream will encapsulate.
NFileMode mode | [in] File mode determining how to open or create the file.
HNFileStream * phStream | [out] A pointer to the created NFileStream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NFileStream.h

Module: NFileStream Unit


NFileStreamCreateFromOSHandle Function

NFileStreamCreateFromOSHandle Function

Creates a new NFileStream for the specified file handle, with the specified read/write permission.

C++
NResult N_API NFileStreamCreateFromOSHandle(NHandle handle, NBool ownsHandle, NFileAccess access, HNFileStream * phStream);
Collapse Expand Parameters
Parameters | Description
NHandle handle | [in] A file handle for the file that the current NFileStream will encapsulate.
NBool ownsHandle | [in] NTrue if the file handle will be owned by this NFileStream; otherwise, NFalse.
NFileAccess access | [in] File access value determing how the file can be accessed by the NFileStream.
HNFileStream * phStream | [out] A pointer to the created NFileStream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NFileStream.h

Module: NFileStream Unit


NFileStreamCreateFromOSHandleWithBufferSize Function

NFileStreamCreateFromOSHandleWithBufferSize Function

Creates a new NFileStream for the specified file handle, with the specified read/write permission, and buffer size.

C++
NResult N_API NFileStreamCreateFromOSHandleWithBufferSize(NHandle handle, NBool ownsHandle, NFileAccess access, NSizeType bufferSize, HNFileStream * phStream);
Collapse Expand Parameters
Parameters | Description
NHandle handle | [in] A file handle for the file that the current NFileStream will encapsulate.
NBool ownsHandle | [in] NTrue if the file handle will be owned by this NFileStream; otherwise, NFalse.
NFileAccess access | [in] File access value determining how the file can be accessed by the NFileStream.
NSizeType bufferSize | [in] A positive NInt32 value greater than 0 indicating the buffer size.
HNFileStream * phStream | [out] A pointer to the created NFileStream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NFileStream.h

Module: NFileStream Unit


NFileStreamCreateWithAccess Function

NFileStreamCreateWithAccess Function

Creates a new NFileStream with the specified path, creation mode, and read/write permission.

C++
NResult N_API NFileStreamCreateWithAccess(const NChar * szPath, NFileMode mode, NFileAccess access, HNFileStream * phStream);
Collapse Expand Parameters
Parameters | Description
const NChar * szPath | [in] Zero terminated string containing path for the file that the current NFileStream will encapsulate.
NFileMode mode | [in] File mode determining how to open or create the file.
NFileAccess access | [in] File access value determining how the file can be accessed by the NFileStream. This gets the NStreamCanRead and NStreamCanWrite properties of the NFileStream object. NStreamCanSeek is NTrue if szPath specifies a disk file.
HNFileStream * phStream | [out] A pointer to the created NFileStream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NFileStream.h

Module: NFileStream Unit


NFileStreamCreateWithAccessAndShare Function

NFileStreamCreateWithAccessAndShare Function

Creates a new NFileStream with the specified path, creation mode, read/write permission, and sharing permission.

C++
NResult N_API NFileStreamCreateWithAccessAndShare(const NChar * szPath, NFileMode mode, NFileAccess access, NFileShare share, HNFileStream * phStream);
Collapse Expand Parameters
Parameters | Description
const NChar * szPath | [in] Zero terminated string containing path for the file that the current NFileStream will encapsulate.
NFileMode mode | [in] File mode determining how to open or create the file.
NFileAccess access | [in] File access value determining how the file can be accessed by the NFileStream.
NFileShare share | [in] Value determining how the file will be shared by processes.
HNFileStream * phStream | [out] A pointer to the created NFileStream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NFileStream.h

Module: NFileStream Unit


NFileStreamCreateWithAccessShareAndBufferSize Function

NFileStreamCreateWithAccessShareAndBufferSize Function

Creates a new NFileStream with the specified path, creation mode, read/write and sharing permission, the access other NFileStreams can have to the same file, and the buffer size.

C++
NResult N_API NFileStreamCreateWithAccessShareAndBufferSize(const NChar * szPath, NFileMode mode, NFileAccess access, NFileShare share, NSizeType bufferSize, HNFileStream * phStream);
Collapse Expand Parameters
Parameters | Description
const NChar * szPath | [in] Zero terminated string containing path for the file that the current NFileStream will encapsulate.
NFileMode mode | [in] File mode determining how to open or create the file.
NFileAccess access | [in] File access value determining how the file can be accessed by the NFileStream. This gets the NStreamCanRead and NStreamCanWrite properties of the NFileStream object. NStreamCanSeek is NTrue if szPath specifies a disk file.
NFileShare share | [in] A constant that determines how the file will be shared by processes.
NSizeType bufferSize | [in] A positive NInt32 value greater than 0 indicating the buffer size.
HNFileStream * phStream | [out] A pointer to the created NFileStream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NFileStream.h

Module: NFileStream Unit


NFileStreamGetOSHandle Function

NFileStreamGetOSHandle Function

Gets OS handle for the specified file.

C++
NResult N_API NFileStreamGetOSHandle(HNFileStream hFileStream, NHandle * phValue);
Collapse Expand Parameters
Parameters | Description
HNFileStream hFileStream | [in] A handle to NFileStream.
NHandle * phValue | [out] OS handle to a file.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NFileStream.h

Module: NFileStream Unit


NFileStreamCreate Macro

NFileStreamCreate Macro

Picks a Unicode (W) or ASCII (A) version of the NFileStreamCreate function.

C++
#define NFileStreamCreate N_FUNC_AW(NFileStreamCreate)
Container

File: NFileStream.h

Module: NFileStream Unit


NFileStreamCreateWithAccess Macro

NFileStreamCreateWithAccess Macro

Picks a Unicode (W) or ASCII (A) version of the NFileStreamCreateWithAccess function.

C++
#define NFileStreamCreateWithAccess N_FUNC_AW(NFileStreamCreateWithAccess)
Container

File: NFileStream.h

Module: NFileStream Unit


NFileStreamCreateWithAccessAndShare Macro

NFileStreamCreateWithAccessAndShare Macro

Picks a Unicode (W) or ASCII (A) version of the NFileStreamCreateWithAccessAndShare function.

C++
#define NFileStreamCreateWithAccessAndShare N_FUNC_AW(NFileStreamCreateWithAccessAndShare)
Container

File: NFileStream.h

Module: NFileStream Unit


NFileStreamCreateWithAccessShareAndBufferSize Macro

NFileStreamCreateWithAccessShareAndBufferSize Macro

Picks a Unicode (W) or ASCII (A) version of the NFileStreamCreateWithAccessShareAndBufferSize function.

C++
#define NFileStreamCreateWithAccessShareAndBufferSize N_FUNC_AW(NFileStreamCreateWithAccessShareAndBufferSize)
Container

File: NFileStream.h

Module: NFileStream Unit


NInterlocked Unit

NInterlocked Unit
Macros

Provides atomic operations for variables that are shared by multiple threads.

Collapse Expand Macros
Name | Description
N_SLOW_INTERLOCKED | Determines whether the current platform has built-in interlocked functions. If the platform has inbuilt interlocked functions, it will use macros, which will directly map to the platform's interlocked functions. If the platform has no inbuilt interlocked functions, it will use the functions from the NInterlocked.


N_SLOW_INTERLOCKED Macro

N_SLOW_INTERLOCKED Macro

Determines whether the current platform has built-in interlocked functions.

If the platform has inbuilt interlocked functions, it will use macros, which will directly map to the platform's interlocked functions.

If the platform has no inbuilt interlocked functions, it will use the functions from the NInterlocked.

C++
#define N_SLOW_INTERLOCKED
Container

File: NInterlocked.h

Module: NInterlocked Unit


NIOTypes Unit

NIOTypes Unit
Files Functions Legend Structs, Records, Enums

Defines input/output types used in Neurotechnology components.

Collapse Expand Files
Name | Description
NIOTypes.h | Header file for NIOTypes Unit.
Collapse Expand Functions
Name | Description
NByteOrderGetSystem | Gets system byte order.
NByteOrderIsReverse | Checks if specified byte order is reverse.
NByteOrderIsValid | Checks whether enumeration value is valid.
NFileAccessIsValid | Checks whether enumeration value is valid.
NFileModeIsValid | Checks whether enumeration value is valid.
NFileShareIsValid | Checks whether enumeration value is valid.
NSeekOriginIsValid | Checks whether enumeration value is valid.
Collapse Expand Structs, Records, Enums
Name | Description
NByteOrder_ | Specifies byte order.
NFileAccess_ | Specifies access to a file.
NFileMode_ | Specifies how the operating system should open a file.
NFileShare_ | Specifies values for controlling the kind of access to a file.
NSeekOrigin_ | Specifies values that represent reference points in streams for seeking.
NByteOrder | Specifies byte order.
NFileAccess | Specifies access to a file.
NFileMode | Specifies how the operating system should open a file.
NFileShare | Specifies values for controlling the kind of access to a file.
NSeekOrigin | Specifies values that represent reference points in streams for seeking.


NByteOrderGetSystem Function

NByteOrderGetSystem Function
NIOTypes.h See Also

Gets system byte order.

C++
NByteOrder N_API NByteOrderGetSystem();
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand See Also

NByteOrder

Container

File: NIOTypes.h

Module: NIOTypes Unit


NByteOrderIsReverse Function

NByteOrderIsReverse Function
NIOTypes.h

Checks if specified byte order is reverse.

C++
NBool N_API NByteOrderIsReverse(NByteOrder value);
Collapse Expand Parameters
Parameters | Description
NByteOrder value | [in] NByteOrder to check.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NIOTypes.h

Module: NIOTypes Unit


NByteOrderIsValid Function

NByteOrderIsValid Function
NIOTypes.h

Checks whether enumeration value is valid.

C++
NBool N_API NByteOrderIsValid(NByteOrder value);
Collapse Expand Parameters
Parameters | Description
NByteOrder value | [in] Enumeration value to check.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NIOTypes.h

Module: NIOTypes Unit


NFileAccessIsValid Function

NFileAccessIsValid Function
NIOTypes.h

Checks whether enumeration value is valid.

C++
NBool N_API NFileAccessIsValid(NFileAccess value);
Collapse Expand Parameters
Parameters | Description
NFileAccess value | [in] Enumeration value to check.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NIOTypes.h

Module: NIOTypes Unit


NFileModeIsValid Function

NFileModeIsValid Function
NIOTypes.h

Checks whether enumeration value is valid.

C++
NBool N_API NFileModeIsValid(NFileMode value);
Collapse Expand Parameters
Parameters | Description
NFileMode value | [in] Enumeration value to check.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NIOTypes.h

Module: NIOTypes Unit


NFileShareIsValid Function

NFileShareIsValid Function
NIOTypes.h

Checks whether enumeration value is valid.

C++
NBool N_API NFileShareIsValid(NFileShare value);
Collapse Expand Parameters
Parameters | Description
NFileShare value | [in] Enumeration value to check.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NIOTypes.h

Module: NIOTypes Unit


NSeekOriginIsValid Function

NSeekOriginIsValid Function
NIOTypes.h

Checks whether enumeration value is valid.

C++
NBool N_API NSeekOriginIsValid(NSeekOrigin value);
Collapse Expand Parameters
Parameters | Description
NSeekOrigin value | [in] Enumeration value to check.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NIOTypes.h

Module: NIOTypes Unit


NByteOrder Enumeration

NByteOrder Enumeration
NIOTypes.h

Specifies byte order.

C++
typedef enum NByteOrder_ {
  nboLittleEndian = 0,
  nboBigEndian = 1
} NByteOrder;
Collapse Expand Members
Members | Description
nboLittleEndian = 0 | Little-endian byte order.
nboBigEndian = 1 | Big-endian byte order.
Container

File: NIOTypes.h

Module: NIOTypes Unit


NFileAccess Enumeration

NFileAccess Enumeration
NIOTypes.h

Specifies access to a file.

C++
typedef enum NFileAccess_ {
  nfaRead = 1,
  nfaWrite = 2,
  nfaReadWrite = nfaRead|nfaWrite
} NFileAccess;
Collapse Expand Members
Members | Description
nfaRead = 1 | Read access to the file.
nfaWrite = 2 | Write access to the file.
nfaReadWrite = nfaRead|nfaWrite | Read and write access to the file.
Container

File: NIOTypes.h

Module: NIOTypes Unit


NFileMode Enumeration

NFileMode Enumeration
NIOTypes.h

Specifies how the operating system should open a file.

C++
typedef enum NFileMode_ {
  nfmCreateNew = 1,
  nfmCreate = 2,
  nfmOpen = 3,
  nfmOpenOrCreate = 4,
  nfmTruncate = 5,
  nfmAppend = 6
} NFileMode;
Collapse Expand Members
Members | Description
nfmCreateNew = 1 | Specifies that the operating system should create a new file.
nfmCreate = 2 | Specifies that the operating system should create a new file. If the file already exists, it will be overwritten.
nfmOpen = 3 | Specifies that the operating system should open an existing file.
nfmOpenOrCreate = 4 | Specifies that the operating system should open a file if it exists; otherwise, a new file should be created.
nfmTruncate = 5 | Specifies that the operating system should open an existing file. When the file is opened, it should be truncated so that its size is zero bytes.
nfmAppend = 6 | File can be appended. Opens the file if it exists and seeks to the end of the file, or creates a new file.
Container

File: NIOTypes.h

Module: NIOTypes Unit


NFileShare Enumeration

NFileShare Enumeration
NIOTypes.h

Specifies values for controlling the kind of access to a file.

C++
typedef enum NFileShare_ {
  nfsNone = 0,
  nfsRead = 1,
  nfsWrite = 2,
  nfsReadWrite = nfsRead|nfsWrite
} NFileShare;
Collapse Expand Members
Members | Description
nfsNone = 0 | Declines sharing of the current file. Any request to open the file (by this process or another process) will fail until the file is closed.
nfsRead = 1 |
nfsWrite = 2 | Allows opening of the file for writing.
nfsReadWrite = nfsRead|nfsWrite | Allows opening of the file for reading or writing.
Container

File: NIOTypes.h

Module: NIOTypes Unit


NSeekOrigin Enumeration

NSeekOrigin Enumeration
NIOTypes.h

Specifies values that represent reference points in streams for seeking.

C++
typedef enum NSeekOrigin_ {
  nsoBegin = 0,
  nsoCurrent = 1,
  nsoEnd = 2
} NSeekOrigin;
Collapse Expand Members
Members | Description
nsoBegin = 0 | Specifies the beginning of a stream.
nsoCurrent = 1 | Specifies the current position within a stream.
nsoEnd = 2 | Specifies the end of a stream.
Container

File: NIOTypes.h

Module: NIOTypes Unit


NIOTypes.h

NIOTypes.h
Enumerations Functions Legend

Header file for NIOTypes Unit.

Collapse Expand Enumerations
Name | Description
NByteOrder_ | Specifies byte order.
NFileAccess_ | Specifies access to a file.
NFileMode_ | Specifies how the operating system should open a file.
NFileShare_ | Specifies values for controlling the kind of access to a file.
NSeekOrigin_ | Specifies values that represent reference points in streams for seeking.
NByteOrder | Specifies byte order.
NFileAccess | Specifies access to a file.
NFileMode | Specifies how the operating system should open a file.
NFileShare | Specifies values for controlling the kind of access to a file.
NSeekOrigin | Specifies values that represent reference points in streams for seeking.
Collapse Expand Functions
Name | Description
NByteOrderGetSystem | Gets system byte order.
NByteOrderIsReverse | Checks if specified byte order is reverse.
NByteOrderIsValid | Checks whether enumeration value is valid.
NFileAccessIsValid | Checks whether enumeration value is valid.
NFileModeIsValid | Checks whether enumeration value is valid.
NFileShareIsValid | Checks whether enumeration value is valid.
NSeekOriginIsValid | Checks whether enumeration value is valid.


NList Unit

NList Unit
Files Functions Legend Macros

Provides functionality for working with lists.

Collapse Expand Files
Name | Description
NList.h | Header file for the NList module.
Collapse Expand Functions
Name | Description
NListAdd | Adds a new value to the specified list.
NListAddList | Adds a list to another list.
NListAddRange | Adds an array of values to the specified list.
NListClear | Clears the specified list.
NListContains | Checks whether the specified list contains the specified value.
NListCopyTo | Copies the specified list to an array.
NListCopyToRange | Copies a part of the specified list to an array.
NListDetachArray | Detaches an inner array from the specified list.
NListDispose | Disposes of the specified list.
NListGet | Retrieves the specified value from the specified list.
NListGetCapacity | Gets the capacity of the specified list.
NListGetCount | Gets the number of values in the list.
NListGetEnd | Retrieves the last value in the specified list.
NListGetPtr | Retrieves a pointer to the specified value from the specified list.
NListGetStart | Retrieves the first value in the specified list.
NListIndexOf | Searches for the specified value and returns the index of the first occurrence within the specified list.
NListIndexOfFrom | Searches for the specified value and returns the index of the first occurrence within the specified part of the list. The part is limited by an index and the list's end.
NListIndexOfInRange | Searches for the specified value and returns the index of the first occurrence within the specified part of the list. The part is limited by an index and length.
NListInit | Initializes a new list.
NListInitEx | Initializes a new list.
NListInitWithCapacity | Initializes a new list.
NListInsert | Adds a new value to the specified list at the specified index.
NListInsertList | Adds a list to another list at the specified index.
NListInsertRange | Adds an array of values to the specified list at the specified index.
NListLastIndexOf | Searches for the specified object and returns the index of the last occurrence within the specified list
NListLastIndexOfFrom | Searches for the specified value and returns the index of the last occurrence within the specified part of the list. The part is limited by an index and the list's end.
NListLastIndexOfInRange | Searches for the specified value and returns the index of the last occurrence within the specified part of the list. The part is limited by an index and length.
NListRemove | Removes the specified value from the specified list.
NListRemoveAt | Removes the specified value from the specified list.
NListRemoveRange | Removes a range of values from the specified list.
NListSet | Sets the specified value in the specified list.
NListSetCapacity | Sets the capacity of the specified list.
NListSetCount | Sets the number of values in the list.
NListToArray | Converts the specified list to an array.
NListToArrayRange | Converts a part of the specified list to an array.
Collapse Expand Macros
Name | Description
N_LIST_SIZE | Defines the size of the list (default value 32).


NListAdd Function

NListAdd Function
NList.h

Adds a new value to the specified list.

C++
NResult N_API NListAdd(NList * pList, HNType hValueType, const void * pValue, NSizeType valueSize);
Collapse Expand Parameters
Parameters | Description
NList * pList | [in/out] Pointer to the list.
HNType hValueType | [in] Handle to the value type.
const void * pValue | [in] Pointer to the value.
NSizeType valueSize | [in] Size of the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NList.h

Module: NList Unit


NListAddList Function

NListAddList Function
NList.h

Adds a list to another list.

C++
NResult N_API NListAddList(NList * pList, NList * pSrcList);
Collapse Expand Parameters
Parameters | Description
NList * pList | [in/out] Pointer to the receiving list.
NList * pSrcList | [in/out] Pointer to the added list.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NList.h

Module: NList Unit


NListAddRange Function

NListAddRange Function
NList.h

Adds an array of values to the specified list.

C++
NResult N_API NListAddRange(NList * pList, HNType hValueType, const void * pValues, NSizeType valuesSize, NInt valuesLength);
Collapse Expand Parameters
Parameters | Description
NList * pList | [in/out] Pointer to the list.
HNType hValueType | [in] Handle to the type of the values.
const void * pValues | [in] Pointer to an array of values.
NSizeType valuesSize | [in] Size of a value.
NInt valuesLength | [in] Number of values in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NList.h

Module: NList Unit


NListClear Function

NListClear Function
NList.h

Clears the specified list.

C++
NResult N_API NListClear(NList * pList);
Collapse Expand Parameters
Parameters | Description
NList * pList | [in/out] Pointer to the list.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NList.h

Module: NList Unit


NListContains Function

NListContains Function
NList.h

Checks whether the specified list contains the specified value.

C++
NResult N_API NListContains(const NList * pList, HNType hValueType, const void * pValue, NSizeType valueSize, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
const NList * pList | [in/out] Pointer to the list.
HNType hValueType | [in] Handle to the value type.
const void * pValue | [in] Pointer to the value.
NSizeType valueSize | [in] Size of the value.
NBool * pResult | [out] NTrue if the list contains the value; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NList.h

Module: NList Unit


NListCopyTo Function

NListCopyTo Function
NList.h

Copies the specified list to an array.

C++
NResult N_API NListCopyTo(NList * pList, HNType hValueType, void * pValues, NSizeType valuesSize, NInt valuesLength);
Collapse Expand Parameters
Parameters | Description
NList * pList | [in/out] Pointer to the list.
HNType hValueType | [in] Handle to the value type.
void * pValues | [in/out] Pointer to the destination array.
NSizeType valuesSize | [in] Size of a value.
NInt valuesLength | [in] Length of the destination array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NList.h

Module: NList Unit


NListCopyToRange Function

NListCopyToRange Function
NList.h

Copies a part of the specified list to an array.

C++
NResult N_API NListCopyToRange(NList * pList, NInt index, NInt count, HNType hValueType, void * pValues, NSizeType valuesSize, NInt valuesLength);
Collapse Expand Parameters
Parameters | Description
NList * pList | [in/out] Pointer to the list.
NInt index | [in] Start index of the list part.
NInt count | [in] Length of the list part.
HNType hValueType | [in] Handle to the value type.
void * pValues | [in/out] Pointer to the destination array.
NSizeType valuesSize | [in] Size of a value.
NInt valuesLength | [in] Length of the destination array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NList.h

Module: NList Unit


NListDetachArray Function

NListDetachArray Function
NList.h

Detaches an inner array from the specified list.

C++
NResult N_API NListDetachArray(NList * pList, NSizeType elementSize, HNType hValueType, void * * ppValues, NInt * pValuesLength);
Collapse Expand Parameters
Parameters | Description
NList * pList | [in/out] Pointer to the list.
NSizeType elementSize | [in] Size of list element.
HNType hValueType | [in] Handle to the element value type.
void * * ppValues | [out] Pointer to the detached inner array.
NInt * pValuesLength | [out] Pointer to the number of elements in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NList.h

Module: NList Unit


NListDispose Function

NListDispose Function
NList.h

Disposes of the specified list.

C++
NResult N_API NListDispose(NList * pList);
Collapse Expand Parameters
Parameters | Description
NList * pList | [in/out] Pointer to the list.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NList.h

Module: NList Unit


NListGet Function

NListGet Function
NList.h

Retrieves the specified value from the specified list.

C++
NResult N_API NListGet(NList * pList, NInt index, HNType hValueType, void * pValue, NSizeType valueSize);
Collapse Expand Parameters
Parameters | Description
NList * pList | [in/out] Pointer to the list.
NInt index | [in] Index of the value.
HNType hValueType | [in] Handle to the type of the value.
void * pValue | [out] Pointer to the value.
NSizeType valueSize | [in] Size of the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NList.h

Module: NList Unit


NListGetCapacity Function

NListGetCapacity Function
NList.h

Gets the capacity of the specified list.

C++
NResult N_API NListGetCapacity(const NList * pList, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
const NList * pList | [in/out] Pointer to the list.
NInt * pValue | [out] Pointer to the capacity of the list.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NList.h

Module: NList Unit


NListGetCount Function

NListGetCount Function
NList.h

Gets the number of values in the list.

C++
NResult N_API NListGetCount(const NList * pList, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
const NList * pList | [in/out] Pointer to the list.
NInt * pValue | [out] Pointer to the number of values.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NList.h

Module: NList Unit


NListGetEnd Function

NListGetEnd Function
NList.h

Retrieves the last value in the specified list.

C++
NResult N_API NListGetEnd(NList * pList, NSizeType elementSize, HNType hValueType, void * * ppValue);
Collapse Expand Parameters
Parameters | Description
NList * pList | [in/out] Pointer to the list.
NSizeType elementSize | [in] Size of the value.
HNType hValueType | [in] Handle to the type of the value.
void * * ppValue | [out] Pointer to the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NList.h

Module: NList Unit


NListGetPtr Function

NListGetPtr Function
NList.h

Retrieves a pointer to the specified value from the specified list.

C++
NResult N_API NListGetPtr(NList * pList, NInt index, NSizeType elementSize, HNType hValueType, void * * ppValue);
Collapse Expand Parameters
Parameters | Description
NList * pList | [in/out] Pointer to the list.
NInt index | [in] Index of the value.
NSizeType elementSize | [in] Size of the value.
HNType hValueType | [in] Handle to the type of the value.
void * * ppValue | [out] Pointer to the value pointer.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NList.h

Module: NList Unit


NListGetStart Function

NListGetStart Function
NList.h

Retrieves the first value in the specified list.

C++
NResult N_API NListGetStart(NList * pList, NSizeType elementSize, HNType hValueType, void * * ppValue);
Collapse Expand Parameters
Parameters | Description
NList * pList | [in/out] Pointer to the list.
NSizeType elementSize | [in] Size of the value.
HNType hValueType | [in] Handle to the type of the value.
void * * ppValue | [out] Pointer to the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NList.h

Module: NList Unit


NListIndexOf Function

NListIndexOf Function
NList.h

Searches for the specified value and returns the index of the first occurrence within the specified list.

C++
NResult N_API NListIndexOf(const NList * pList, HNType hValueType, const void * pValue, NSizeType valueSize, NInt * pResult);
Collapse Expand Parameters
Parameters | Description
const NList * pList | [in/out] Pointer to the list.
HNType hValueType | [in] Handle to the type of the value.
const void * pValue | [in] Pointer to the value.
NSizeType valueSize | [in] Size of the value.
NInt * pResult | [out] Pointer to the index of the first occurrence.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NList.h

Module: NList Unit


NListIndexOfFrom Function

NListIndexOfFrom Function
NList.h

Searches for the specified value and returns the index of the first occurrence within the specified part of the list.

The part is limited by an index and the list's end.

C++
NResult N_API NListIndexOfFrom(const NList * pList, HNType hValueType, const void * pValue, NSizeType valueSize, NInt startIndex, NInt * pResult);
Collapse Expand Parameters
Parameters | Description
const NList * pList | [in/out] Pointer to the list.
HNType hValueType | [in] Handle to the type of the value.
const void * pValue | [in] Pointer to the value.
NSizeType valueSize | [in] Size of the value.
NInt startIndex | [in] Start index of the list part.
NInt * pResult | [out] Pointer to the index of the first occurrence.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NList.h

Module: NList Unit


NListIndexOfInRange Function

NListIndexOfInRange Function
NList.h

Searches for the specified value and returns the index of the first occurrence within the specified part of the list.

The part is limited by an index and length.

C++
NResult N_API NListIndexOfInRange(const NList * pList, HNType hValueType, const void * pValue, NSizeType valueSize, NInt startIndex, NInt count, NInt * pResult);
Collapse Expand Parameters
Parameters | Description
const NList * pList | [in/out] Pointer to the list.
HNType hValueType | [in] Handle to the type of the value.
const void * pValue | [in] Pointer to the value.
NSizeType valueSize | [in] Size of the value.
NInt startIndex | [in] Start index of the list part.
NInt count | [in] Length of the list part.
NInt * pResult | [out] Pointer to the index of the first occurrence.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NList.h

Module: NList Unit


NListInit Function

NListInit Function
NList.h

Initializes a new list.

C++
NResult N_API NListInit(NList * pList, NSizeType elementSize, HNType hElementType);
Collapse Expand Parameters
Parameters | Description
NList * pList | [in/out] Pointer to the list.
NSizeType elementSize | [in] Size of a list element.
HNType hElementType | [in] Handle to the element type.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NList.h

Module: NList Unit


NListInitEx Function

NListInitEx Function
NList.h

Initializes a new list.

C++
NResult N_API NListInitEx(NList * pList, NSizeType elementSize, HNType hElementType, NInt capacity, NInt maxCapacity, NInt growthDelta, NSizeType alignment);
Collapse Expand Parameters
Parameters | Description
NList * pList | [in/out] Pointer to the list.
NSizeType elementSize | [in] Size of a list element.
HNType hElementType | [in] Handle to the element type.
NInt capacity | [in] List capacity.
NInt maxCapacity | [in] Maximum list capacity.
NInt growthDelta | [in] List capacity growth.
NSizeType alignment | [in] List alignment.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NList.h

Module: NList Unit


NListInitWithCapacity Function

NListInitWithCapacity Function
NList.h

Initializes a new list.

C++
NResult N_API NListInitWithCapacity(NList * pList, NSizeType elementSize, HNType hElementType, NInt capacity);
Collapse Expand Parameters
Parameters | Description
NList * pList | [in/out] Pointer to the list.
NSizeType elementSize | [in] Size of a list element.
HNType hElementType | [in] Handle to the element type.
NInt capacity | [in] List capacity.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NList.h

Module: NList Unit


NListInsert Function

NListInsert Function
NList.h

Adds a new value to the specified list at the specified index.

C++
NResult N_API NListInsert(NList * pList, NInt index, HNType hValueType, const void * pValue, NSizeType valueSize);
Collapse Expand Parameters
Parameters | Description
NList * pList | [in/out] Pointer to the list.
NInt index | [in] Index at which the value will be added.
HNType hValueType | [in] Handle to the value type.
const void * pValue | [in] Pointer to the value.
NSizeType valueSize | [in] Size of the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NList.h

Module: NList Unit


NListInsertList Function

NListInsertList Function
NList.h

Adds a list to another list at the specified index.

C++
NResult N_API NListInsertList(NList * pList, NInt index, NList * pSrcList);
Collapse Expand Parameters
Parameters | Description
NList * pList | [in/out] Pointer to the receiving list.
NInt index | [in] Index at which the list will be added.
NList * pSrcList | [in/out] Pointer to the added list.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NList.h

Module: NList Unit


NListInsertRange Function

NListInsertRange Function
NList.h

Adds an array of values to the specified list at the specified index.

C++
NResult N_API NListInsertRange(NList * pList, NInt index, HNType hValueType, const void * pValues, NSizeType valuesSize, NInt valuesLength);
Collapse Expand Parameters
Parameters | Description
NList * pList | [in/out] Pointer to the receiving list.
NInt index | [in] Index at which the values will be added.
HNType hValueType | [in] Handle to the type of the values.
const void * pValues | [in] Pointer to an array of values.
NSizeType valuesSize | [in] Size of a value.
NInt valuesLength | [in] Number of values in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NList.h

Module: NList Unit


NListLastIndexOf Function

NListLastIndexOf Function
NList.h

Searches for the specified object and returns the index of the last occurrence within the specified list

C++
NResult N_API NListLastIndexOf(const NList * pList, HNType hValueType, const void * pValue, NSizeType valueSize, NInt * pResult);
Collapse Expand Parameters
Parameters | Description
const NList * pList | [in/out] Pointer to the list.
HNType hValueType | [in] Handle to the type of the value.
const void * pValue | [in] Pointer to the value.
NSizeType valueSize | [in] Size of the value.
NInt * pResult | [out] Pointer to the index of the last occurrence.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NList.h

Module: NList Unit


NListLastIndexOfFrom Function

NListLastIndexOfFrom Function
NList.h

Searches for the specified value and returns the index of the last occurrence within the specified part of the list.

The part is limited by an index and the list's end.

C++
NResult N_API NListLastIndexOfFrom(const NList * pList, HNType hValueType, const void * pValue, NSizeType valueSize, NInt startIndex, NInt * pResult);
Collapse Expand Parameters
Parameters | Description
const NList * pList | [in/out] Pointer to the list.
HNType hValueType | [in] Handle to the type of the value.
const void * pValue | [in] Pointer to the value.
NSizeType valueSize | [in] Size of the value.
NInt startIndex | [in] Start index of the list part.
NInt * pResult | [out] Pointer to the index of the last occurrence.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NList.h

Module: NList Unit


NListLastIndexOfInRange Function

NListLastIndexOfInRange Function
NList.h

Searches for the specified value and returns the index of the last occurrence within the specified part of the list.

The part is limited by an index and length.

C++
NResult N_API NListLastIndexOfInRange(const NList * pList, HNType hValueType, const void * pValue, NSizeType valueSize, NInt startIndex, NInt count, NInt * pResult);
Collapse Expand Parameters
Parameters | Description
const NList * pList | [in/out] Pointer to the list.
HNType hValueType | [in] Handle to the type of the value.
const void * pValue | [in] Pointer to the value.
NSizeType valueSize | [in] Size of the value.
NInt startIndex | [in] Start index of the list part.
NInt count | [in] Length of the list part.
NInt * pResult | [out] Pointer to the index of the last occurrence.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NList.h

Module: NList Unit


NListRemove Function

NListRemove Function
NList.h

Removes the specified value from the specified list.

C++
NResult N_API NListRemove(NList * pList, HNType hValueType, const void * pValue, NSizeType valueSize, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
NList * pList | [in/out] Pointer to the list.
HNType hValueType | [in] Handle to the value type.
const void * pValue | [in] Pointer to the new value.
NSizeType valueSize | [in] Size of the value.
NInt * pIndex | [out] Pointer to the index freed by the removed value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NList.h

Module: NList Unit


NListRemoveAt Function

NListRemoveAt Function
NList.h

Removes the specified value from the specified list.

C++
NResult N_API NListRemoveAt(NList * pList, NInt index);
Collapse Expand Parameters
Parameters | Description
NList * pList | [in/out] Pointer to the list.
NInt index | [in] Index of the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NList.h

Module: NList Unit


NListRemoveRange Function

NListRemoveRange Function
NList.h

Removes a range of values from the specified list.

C++
NResult N_API NListRemoveRange(NList * pList, NInt index, NInt count);
Collapse Expand Parameters
Parameters | Description
NList * pList | [in/out] Pointer to the list.
NInt index | _nt_
NInt count | _nt_
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NList.h

Module: NList Unit


NListSet Function

NListSet Function
NList.h

Sets the specified value in the specified list.

C++
NResult N_API NListSet(NList * pList, NInt index, HNType hValueType, const void * pValue, NSizeType valueSize);
Collapse Expand Parameters
Parameters | Description
NList * pList | [in/out] Pointer to the list.
NInt index | [in] Index of the value.
HNType hValueType | [in] Handle to the value type.
const void * pValue | [in] Pointer to the new value.
NSizeType valueSize | [in] Size of the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NList.h

Module: NList Unit


NListSetCapacity Function

NListSetCapacity Function
NList.h

Sets the capacity of the specified list.

C++
NResult N_API NListSetCapacity(NList * pList, NInt value);
Collapse Expand Parameters
Parameters | Description
NList * pList | [in/out] Pointer to the list.
NInt value | [in] The capacity of the list.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NList.h

Module: NList Unit


NListSetCount Function

NListSetCount Function
NList.h

Sets the number of values in the list.

C++
NResult N_API NListSetCount(NList * pList, NInt value);
Collapse Expand Parameters
Parameters | Description
NList * pList | [in/out] Pointer to the list.
NInt value | [in] The number of values.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NList.h

Module: NList Unit


NListToArray Function

NListToArray Function
NList.h

Converts the specified list to an array.

C++
NResult N_API NListToArray(NList * pList, NSizeType elementSize, HNType hValueType, void * * ppValues, NInt * pValuesLength);
Collapse Expand Parameters
Parameters | Description
NList * pList | [in/out] Pointer to the list.
NSizeType elementSize | [in] Size of a list element.
HNType hValueType | [in] Handle to the type of an element.
void * * ppValues | [out] Pointer to the new array.
NInt * pValuesLength | [out] Pointer to the number of values in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NList.h

Module: NList Unit


NListToArrayRange Function

NListToArrayRange Function
NList.h

Converts a part of the specified list to an array.

C++
NResult N_API NListToArrayRange(NList * pList, NInt index, NInt count, NSizeType elementSize, HNType hValueType, void * * ppValues, NInt * pValuesLength);
Collapse Expand Parameters
Parameters | Description
NList * pList | [in/out] Pointer to the list.
NInt index | [in] Index at which the part of the list starts.
NInt count | [in] Length of the part of the list.
NSizeType elementSize | [in] Size of a list element.
HNType hValueType | [in] Handle to the type of an element.
void * * ppValues | [out] Pointer to the new array.
NInt * pValuesLength | [out] Pointer to the number of values in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NList.h

Module: NList Unit


N_LIST_SIZE Macro

N_LIST_SIZE Macro
NList.h

Defines the size of the list (default value 32).

C++
#define N_LIST_SIZE 32
Container

File: NList.h

Module: NList Unit


NList.h

NList.h
Functions Legend Macros

Header file for the NList module.

Collapse Expand Functions
Name | Description
NListAdd | Adds a new value to the specified list.
NListAddList | Adds a list to another list.
NListAddRange | Adds an array of values to the specified list.
NListClear | Clears the specified list.
NListContains | Checks whether the specified list contains the specified value.
NListCopyTo | Copies the specified list to an array.
NListCopyToRange | Copies a part of the specified list to an array.
NListDetachArray | Detaches an inner array from the specified list.
NListDispose | Disposes of the specified list.
NListGet | Retrieves the specified value from the specified list.
NListGetCapacity | Gets the capacity of the specified list.
NListGetCount | Gets the number of values in the list.
NListGetEnd | Retrieves the last value in the specified list.
NListGetPtr | Retrieves a pointer to the specified value from the specified list.
NListGetStart | Retrieves the first value in the specified list.
NListIndexOf | Searches for the specified value and returns the index of the first occurrence within the specified list.
NListIndexOfFrom | Searches for the specified value and returns the index of the first occurrence within the specified part of the list. The part is limited by an index and the list's end.
NListIndexOfInRange | Searches for the specified value and returns the index of the first occurrence within the specified part of the list. The part is limited by an index and length.
NListInit | Initializes a new list.
NListInitEx | Initializes a new list.
NListInitWithCapacity | Initializes a new list.
NListInsert | Adds a new value to the specified list at the specified index.
NListInsertList | Adds a list to another list at the specified index.
NListInsertRange | Adds an array of values to the specified list at the specified index.
NListLastIndexOf | Searches for the specified object and returns the index of the last occurrence within the specified list
NListLastIndexOfFrom | Searches for the specified value and returns the index of the last occurrence within the specified part of the list. The part is limited by an index and the list's end.
NListLastIndexOfInRange | Searches for the specified value and returns the index of the last occurrence within the specified part of the list. The part is limited by an index and length.
NListRemove | Removes the specified value from the specified list.
NListRemoveAt | Removes the specified value from the specified list.
NListRemoveRange | Removes a range of values from the specified list.
NListSet | Sets the specified value in the specified list.
NListSetCapacity | Sets the capacity of the specified list.
NListSetCount | Sets the number of values in the list.
NListToArray | Converts the specified list to an array.
NListToArrayRange | Converts a part of the specified list to an array.
Collapse Expand Macros
Name | Description
N_LIST_SIZE | Defines the size of the list (default value 32).


NListList Unit

NListList Unit
Files Functions Legend Macros

Provides functionality for working with two-dimension lists.

Collapse Expand Notes

This class is largely similar to NList class, however instead of regular one-dimensional list pointers, here you will have to use two-dimension list pointers and indices, indicating a one-dimensional lists in a two-dimension list.

Documentation-wise, word list refers to a one-dimensional list, while two-dimensional lists are referred to as 2D lists.

Accordingly, list capacity refers to the maximum number of one-dimensional lists in a two-dimensional list, while item capacity refers to the maximum number of item in a one-dimensional list.

Collapse Expand Files
Name | Description
NListList.h | Header file for the NListList module.
Collapse Expand Functions
Name | Description
NListListAdd | Adds a regular list to the 2D list.
NListListAddItem | Adds an item to the 2D list.
NListListAddItemRange | Adds an array of items to the 2D list.
NListListAddListList | Adds the the specified 2D list to another specified 2D list.
NListListAddListListItems | Adds the contents of the specified 2D list to another specified 2D list.
NListListAddRange | Adds a number of regular lists to the 2D list.
NListListClear | Clears the specified 2D list.
NListListClearItems | Clears all items from the specified list.
NListListContainsItem | Checks whether the specified list contains the specified item.
NListListCopyItemsTo | Copies the specified list to an array.
NListListCopyItemsToRange | Copies a part of the specified list to an array.
NListListDetachItemsArray | Detaches an inner array from the specified array.
NListListDispose | Disposes of the specified 2D list.
NListListGetCapacity | Retrieves the maximum number of 1D lists in the specified 2D list.
NListListGetCount | Retrieves the number of 1D lists in the specified 2D list.
NListListGetItem | Retrieves the specified item from the specified 2D list.
NListListGetItemCapacity | Retrieves the maximum number of item in the specified list.
NListListGetItemCount | Retrieves the number of items in the specified list.
NListListGetItemPtr | Retrieves a pointer to the specified item from the specified 2D list.
NListListGetItemsEnd | Retrieves a pointer to the end of the inner array of the specified list.
NListListGetItemsStart | Retrieves a pointer to the start of the inner array of the specified list.
NListListIndexOfItem | Searches for the specified value and returns the index of the first occurrence within the specified list.
NListListIndexOfItemFrom | Searches for the specified value and returns the index of the first occurrence within the specified part of the list. The part is limited by an index and the list's end.
NListListIndexOfItemInRange | Searches for the specified value and returns the index of the first occurrence within the specified part of the list. The part is limited by an index and length.
NListListInit | Initializes the the specified 2D list.
NListListInitEx | Initializes the the specified 2D list.
NListListInitWithCapacity | Initializes the the specified 2D list.
NListListInsert | Adds a regular list to the 2D list at the specified index.
NListListInsertItem | Adds an item to the 2D list at the specified index.
NListListInsertItemRange | Adds an array of items to the 2D list at the specified index.
NListListInsertListList | Adds the the specified 2D list to another specified 2D list at the specified index..
NListListInsertListListItems | Adds the contents of the specified 2D list to another specified 2D list at the specified index.
NListListInsertRange | Adds a number of regular lists to the 2D list at the specified index.
NListListItemsToArray | Converts the specified list to an array.
NListListItemsToArrayRange | Converts a part of the specified list to an array.
NListListLastIndexOfItem | Searches for the specified value and returns the index of the last occurrence within the specified list.
NListListLastIndexOfItemFrom | Searches for the specified value and returns the index of the last occurrence within the specified part of the list. The part is limited by an index and the list's end.
NListListLastIndexOfItemInRange | Searches for the specified value and returns the index of the last occurrence within the specified part of the list. The part is limited by an index and length.
NListListRemoveAt | Removes a regular list from the 2D list.
NListListRemoveItem | Removes an item from the 2D list.
NListListRemoveItemAt | Removes an item from the 2D list.
NListListRemoveItemRange | Removes a range item from the 2D list.
NListListRemoveRange | Removes a number of regular lists from the 2D list.
NListListSetCapacity | Sets the maximum number of 1D lists in the specified 2D list.
NListListSetCount | Sets the number of 1D lists in the specified 2D list.
NListListSetItem | Sets the value of the specified item in the specified 2D list.
NListListSetItemCapacity |
NListListSetItemCount | Sets the number of items in the specified list.
Collapse Expand Macros
Name | Description
N_LIST_LIST_SIZE | Defines the size of the two-dimensional list (default value 4).


NListListAdd Function

NListListAdd Function
NListList.h

Adds a regular list to the 2D list.

C++
NResult N_API NListListAdd(NListList * pList, NInt itemCapacity);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the 2D list.
NInt itemCapacity | [in] New list's item capacity.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


NListListAddItem Function

NListListAddItem Function
NListList.h

Adds an item to the 2D list.

C++
NResult N_API NListListAddItem(NListList * pList, NInt listIndex, HNType hValueType, const void * pValue, NSizeType valueSize);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the 2D list.
NInt listIndex | [in] Index of the list.
HNType hValueType | [in] Handle to the value type.
const void * pValue | [in] Pointer to the item value.
NSizeType valueSize | [in] Size of the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


NListListAddItemRange Function

NListListAddItemRange Function
NListList.h

Adds an array of items to the 2D list.

C++
NResult N_API NListListAddItemRange(NListList * pList, NInt listIndex, HNType hValueType, const void * pValues, NSizeType valuesSize, NInt valuesLength);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the 2D list.
NInt listIndex | [in] Index of the list.
HNType hValueType | [in] Handle to the value type.
const void * pValues | [in] Pointer to an array of values.
NSizeType valuesSize | [in] Size of a value.
NInt valuesLength | [in] Number of values in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


NListListAddListList Function

NListListAddListList Function
NListList.h

Adds the the specified 2D list to another specified 2D list.

C++
NResult N_API NListListAddListList(NListList * pList, NListList * pSrcList);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the destination 2D list.
NListList * pSrcList | [in/out] Pointer to the source 2D list.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


NListListAddListListItems Function

NListListAddListListItems Function
NListList.h

Adds the contents of the specified 2D list to another specified 2D list.

C++
NResult N_API NListListAddListListItems(NListList * pList, NInt listIndex, NListList * pSrcList, NInt srcListIndex);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the destination 2D list.
NInt listIndex | [in] Index of the destination list.
NListList * pSrcList | [in/out] Pointer to the source 2D list.
NInt srcListIndex | [in] Index of the source list.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


NListListAddRange Function

NListListAddRange Function
NListList.h

Adds a number of regular lists to the 2D list.

C++
NResult N_API NListListAddRange(NListList * pList, NInt count, NInt itemCapacity);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the 2D list.
NInt count | [in] Number of lists to add.
NInt itemCapacity | [in] New lists' item capacity.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


NListListClear Function

NListListClear Function
NListList.h

Clears the specified 2D list.

C++
NResult N_API NListListClear(NListList * pList);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the 2D list.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


NListListClearItems Function

NListListClearItems Function
NListList.h

Clears all items from the specified list.

C++
NResult N_API NListListClearItems(NListList * pList, NInt listIndex);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the 2D list.
NInt listIndex | [in] List index.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


NListListContainsItem Function

NListListContainsItem Function
NListList.h

Checks whether the specified list contains the specified item.

C++
NResult N_API NListListContainsItem(NListList * pList, NInt listIndex, HNType hValueType, const void * pValue, NSizeType valueSize, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the 2D list.
NInt listIndex | [in] List index.
HNType hValueType | [in] Handle to the type of value.
const void * pValue | [in] Pointer to the value to find.
NSizeType valueSize | [in] Size of the value.
NBool * pResult | [out] NTrue if the list contains the item; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


NListListCopyItemsTo Function

NListListCopyItemsTo Function
NListList.h

Copies the specified list to an array.

C++
NResult N_API NListListCopyItemsTo(NListList * pList, NInt listIndex, HNType hValueType, void * pValues, NSizeType valuesSize, NInt valuesLength);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the 2D list.
NInt listIndex | [in] Index of the list to copy.
HNType hValueType | [in] Handle to the value type.
void * pValues | [in/out] Pointer to the destination array.
NSizeType valuesSize | [in] Size of a value.
NInt valuesLength | [in] Length of the destination array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


NListListCopyItemsToRange Function

NListListCopyItemsToRange Function
NListList.h

Copies a part of the specified list to an array.

C++
NResult N_API NListListCopyItemsToRange(NListList * pList, NInt listIndex, NInt index, NInt count, HNType hValueType, void * pValues, NSizeType valuesSize, NInt valuesLength);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the 2D list.
NInt listIndex | [in] Index of the list to copy.
NInt index | [in] Start index of the list part.
NInt count | [in] Length of the list part.
HNType hValueType | [in] Handle to the value type.
void * pValues | [in/out] Pointer to the destination array.
NSizeType valuesSize | [in] Size of a value.
NInt valuesLength | [in] Length of the destination array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


NListListDetachItemsArray Function

NListListDetachItemsArray Function
NListList.h

Detaches an inner array from the specified array.

C++
NResult N_API NListListDetachItemsArray(NListList * pList, NInt listIndex, NSizeType elementSize, HNType hValueType, void * * ppValues, NInt * pValuesLength);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the 2D list.
NInt listIndex | [in] Index of the list.
NSizeType elementSize | [in] Size of list element.
HNType hValueType | [in] Handle to the element value type.
void * * ppValues | [out] Pointer to the detached inner array.
NInt * pValuesLength | [out] Pointer to the number of elements in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


NListListDispose Function

NListListDispose Function
NListList.h

Disposes of the specified 2D list.

C++
NResult N_API NListListDispose(NListList * pList);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the 2D list to dispose.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


NListListGetCapacity Function

NListListGetCapacity Function
NListList.h

Retrieves the maximum number of 1D lists in the specified 2D list.

C++
NResult N_API NListListGetCapacity(NListList * pList, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the 2D list.
NInt * pValue | [out] Pointer to the list capacity.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


NListListGetCount Function

NListListGetCount Function
NListList.h

Retrieves the number of 1D lists in the specified 2D list.

C++
NResult N_API NListListGetCount(NListList * pList, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the 2D list.
NInt * pValue | [out] Pointer to the number of lists.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


NListListGetItem Function

NListListGetItem Function
NListList.h

Retrieves the specified item from the specified 2D list.

C++
NResult N_API NListListGetItem(NListList * pList, NInt listIndex, NInt index, HNType hValueType, void * pValue, NSizeType valueSize);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the 2D list.
NInt listIndex | [in] Index of the list.
NInt index | [in] Index of the item.
HNType hValueType | [in] Handle to the type of the value.
void * pValue | [out] Pointer to the item.
NSizeType valueSize | [in] Size of the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


NListListGetItemCapacity Function

NListListGetItemCapacity Function
NListList.h

Retrieves the maximum number of item in the specified list.

C++
NResult N_API NListListGetItemCapacity(NListList * pList, NInt listIndex, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the 2D list.
NInt listIndex | [in] List index.
NInt * pValue | [out] Pointer to the item capacity.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


NListListGetItemCount Function

NListListGetItemCount Function
NListList.h

Retrieves the number of items in the specified list.

C++
NResult N_API NListListGetItemCount(NListList * pList, NInt listIndex, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the 2D list.
NInt listIndex | [in] List index.
NInt * pValue | [out] Pointer to the number of items.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


NListListGetItemPtr Function

NListListGetItemPtr Function
NListList.h

Retrieves a pointer to the specified item from the specified 2D list.

C++
NResult N_API NListListGetItemPtr(NListList * pList, NInt listIndex, NInt index, NSizeType elementSize, HNType hValueType, void * * ppValue);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the 2D list.
NInt listIndex | [in] Index of the list.
NInt index | [in] Index of the item.
NSizeType elementSize | [in] Size of the value.
HNType hValueType | [in] Handle to the type of the value.
void * * ppValue | [out] Pointer to the item pointer.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


NListListGetItemsEnd Function

NListListGetItemsEnd Function
NListList.h

Retrieves a pointer to the end of the inner array of the specified list.

C++
NResult N_API NListListGetItemsEnd(NListList * pList, NInt listIndex, NSizeType elementSize, HNType hValueType, void * * ppValue);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the 2D list.
NInt listIndex | [in] Index of the list.
NSizeType elementSize | [in] Size of list element.
HNType hValueType | [in] Handle to the element value type.
void * * ppValue | [out] Pointer to the inner array end.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


NListListGetItemsStart Function

NListListGetItemsStart Function
NListList.h

Retrieves a pointer to the start of the inner array of the specified list.

C++
NResult N_API NListListGetItemsStart(NListList * pList, NInt listIndex, NSizeType elementSize, HNType hValueType, void * * ppValue);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the 2D list.
NInt listIndex | [in] Index of the list.
NSizeType elementSize | [in] Size of list element.
HNType hValueType | [in] Handle to the element value type.
void * * ppValue | [out] Pointer to the inner array start.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


NListListIndexOfItem Function

NListListIndexOfItem Function
NListList.h

Searches for the specified value and returns the index of the first occurrence within the specified list.

C++
NResult N_API NListListIndexOfItem(NListList * pList, NInt listIndex, HNType hValueType, const void * pValue, NSizeType valueSize, NInt * pResult);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the 2D list.
NInt listIndex | [in] Index of the list.
HNType hValueType | [in] Handle to the value type.
const void * pValue | [in] Pointer to the value.
NSizeType valueSize | [in] Size of the value.
NInt * pResult | [out] Pointer to the index of the first occurrence.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


NListListIndexOfItemFrom Function

NListListIndexOfItemFrom Function
NListList.h

Searches for the specified value and returns the index of the first occurrence within the specified part of the list.

The part is limited by an index and the list's end.

C++
NResult N_API NListListIndexOfItemFrom(NListList * pList, NInt listIndex, HNType hValueType, const void * pValue, NSizeType valueSize, NInt startIndex, NInt * pResult);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the 2D list.
NInt listIndex | [in] Index of the list.
HNType hValueType | [in] Handle to the value type.
const void * pValue | [in] Pointer to the value.
NSizeType valueSize | [in] Size of the value.
NInt startIndex | [in] Start index of the list part.
NInt * pResult | [out] Pointer to the index of the first occurrence.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


NListListIndexOfItemInRange Function

NListListIndexOfItemInRange Function
NListList.h

Searches for the specified value and returns the index of the first occurrence within the specified part of the list.

The part is limited by an index and length.

C++
NResult N_API NListListIndexOfItemInRange(NListList * pList, NInt listIndex, HNType hValueType, const void * pValue, NSizeType valueSize, NInt startIndex, NInt count, NInt * pResult);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the 2D list.
NInt listIndex | [in] Index of the list.
HNType hValueType | [in] Handle to the value type.
const void * pValue | [in] Pointer to the value.
NSizeType valueSize | [in] Size of the value.
NInt startIndex | [in] Start index of the list part.
NInt count | [in] Length of the list part.
NInt * pResult | [out] Pointer to the index of the first occurrence.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


NListListInit Function

NListListInit Function
NListList.h

Initializes the the specified 2D list.

C++
NResult N_API NListListInit(NListList * pList, NSizeType elementSize, HNType hElementType);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the 2D list.
NSizeType elementSize | [in] Size of a list element.
HNType hElementType | [in] Handle to the list element type.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


NListListInitEx Function

NListListInitEx Function
NListList.h

Initializes the the specified 2D list.

C++
NResult N_API NListListInitEx(NListList * pList, NSizeType elementSize, HNType hElementType, NInt capacity, NInt maxCapacity, NInt growthDelta, NInt itemDefaultCapacity, NInt itemMaxCapacity, NInt itemGrowthDelta, NSizeType itemAlignment);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the 2D list.
NSizeType elementSize | [in] Size of a list element.
HNType hElementType | [in] Handle to the list element type.
NInt capacity | [in] List capacity.
NInt maxCapacity | [in] Maximum lists capacity.
NInt growthDelta | [in] List capacity growth.
NInt itemDefaultCapacity | [in] Default item capacity.
NInt itemMaxCapacity | [in] Maximum item capacity.
NInt itemGrowthDelta | [in] Item capacity growth.
NSizeType itemAlignment | [in] One-dimensional list alignment.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


NListListInitWithCapacity Function

NListListInitWithCapacity Function
NListList.h

Initializes the the specified 2D list.

C++
NResult N_API NListListInitWithCapacity(NListList * pList, NSizeType elementSize, HNType hElementType, NInt capacity);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the 2D list.
NSizeType elementSize | [in] Size of a list element.
HNType hElementType | [in] Handle to the list element type.
NInt capacity | [in] List capacity.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


NListListInsert Function

NListListInsert Function
NListList.h

Adds a regular list to the 2D list at the specified index.

C++
NResult N_API NListListInsert(NListList * pList, NInt index, NInt itemCapacity);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the 2D list.
NInt index | [in] Index of the list.
NInt itemCapacity | [in] New list's item capacity.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


NListListInsertItem Function

NListListInsertItem Function
NListList.h

Adds an item to the 2D list at the specified index.

C++
NResult N_API NListListInsertItem(NListList * pList, NInt listIndex, NInt index, HNType hValueType, const void * pValue, NSizeType valueSize);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the 2D list.
NInt listIndex | [in] Index of the list.
NInt index | [in] Index of the item.
HNType hValueType | [in] Handle to the value type.
const void * pValue | [in] Pointer to the item value.
NSizeType valueSize | [in] Size of the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


NListListInsertItemRange Function

NListListInsertItemRange Function
NListList.h

Adds an array of items to the 2D list at the specified index.

C++
NResult N_API NListListInsertItemRange(NListList * pList, NInt listIndex, NInt index, HNType hValueType, const void * pValues, NSizeType valuesSize, NInt valuesLength);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the 2D list.
NInt listIndex | [in] Index of the list.
NInt index | [in] Index of the item.
HNType hValueType | [in] Handle to the value type.
const void * pValues | [in] Pointer to an array of values.
NSizeType valuesSize | [in] Size of a value.
NInt valuesLength | [in] Number of values in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


NListListInsertListList Function

NListListInsertListList Function
NListList.h

Adds the the specified 2D list to another specified 2D list at the specified index..

C++
NResult N_API NListListInsertListList(NListList * pList, NInt index, NListList * pSrcList);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the destination 2D list.
NInt index | [in] Index of the list.
NListList * pSrcList | [in/out] Pointer to the source 2D list.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


NListListInsertListListItems Function

NListListInsertListListItems Function
NListList.h

Adds the contents of the specified 2D list to another specified 2D list at the specified index.

C++
NResult N_API NListListInsertListListItems(NListList * pList, NInt listIndex, NInt index, NListList * pSrcList, NInt srcListIndex);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the destination 2D list.
NInt listIndex | [in] Index of the destination list.
NInt index | [in] Index of the item, at which inserting starts.
NListList * pSrcList | [in] Index of the source list.
NInt srcListIndex | [in/out] Pointer to the source 2D list.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


NListListInsertRange Function

NListListInsertRange Function
NListList.h

Adds a number of regular lists to the 2D list at the specified index.

C++
NResult N_API NListListInsertRange(NListList * pList, NInt index, NInt count, NInt itemCapacity);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the 2D list.
NInt index | [in] Index of the first list to add.
NInt count | [in] Number of lists to add.
NInt itemCapacity | [in] New lists' item capacity.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


NListListItemsToArray Function

NListListItemsToArray Function
NListList.h

Converts the specified list to an array.

C++
NResult N_API NListListItemsToArray(NListList * pList, NInt listIndex, NSizeType elementSize, HNType hValueType, void * * ppValues, NInt * pValuesLength);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the 2D list.
NInt listIndex | [in] Index of the list.
NSizeType elementSize | [in] Size of a list element.
HNType hValueType | [in] Handle to the type of an element.
void * * ppValues | [out] Pointer to the new array.
NInt * pValuesLength | [out] Pointer to the number of values in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


NListListItemsToArrayRange Function

NListListItemsToArrayRange Function
NListList.h

Converts a part of the specified list to an array.

C++
NResult N_API NListListItemsToArrayRange(NListList * pList, NInt listIndex, NInt index, NInt count, NSizeType elementSize, HNType hValueType, void * * ppValues, NInt * pValuesLength);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the 2D list.
NInt listIndex | [in] Index of the list.
NInt index | [in] Index at which the part of the list starts.
NInt count | [in] Length of the part of the list.
NSizeType elementSize | [in] Size of a list element.
HNType hValueType | [in] Handle to the type of an element.
void * * ppValues | [out] Pointer to the new array.
NInt * pValuesLength | [out] Pointer to the number of values in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


NListListLastIndexOfItem Function

NListListLastIndexOfItem Function
NListList.h

Searches for the specified value and returns the index of the last occurrence within the specified list.

C++
NResult N_API NListListLastIndexOfItem(NListList * pList, NInt listIndex, HNType hValueType, const void * pValue, NSizeType valueSize, NInt * pResult);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the 2D list.
NInt listIndex | [in] Index of the list.
HNType hValueType | [in] Handle to the value type.
const void * pValue | [in] Pointer to the value.
NSizeType valueSize | [in] Size of the value.
NInt * pResult | [out] Pointer to the index of the last occurrence.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


NListListLastIndexOfItemFrom Function

NListListLastIndexOfItemFrom Function
NListList.h

Searches for the specified value and returns the index of the last occurrence within the specified part of the list.

The part is limited by an index and the list's end.

C++
NResult N_API NListListLastIndexOfItemFrom(NListList * pList, NInt listIndex, HNType hValueType, const void * pValue, NSizeType valueSize, NInt startIndex, NInt * pResult);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the 2D list.
NInt listIndex | [in] Index of the list.
HNType hValueType | [in] Handle to the value type.
const void * pValue | [in] Pointer to the value.
NSizeType valueSize | [in] Size of the value.
NInt startIndex | [in] Start index of the list part.
NInt * pResult | [out] Pointer to the index of the last occurrence.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


NListListLastIndexOfItemInRange Function

NListListLastIndexOfItemInRange Function
NListList.h

Searches for the specified value and returns the index of the last occurrence within the specified part of the list.

The part is limited by an index and length.

C++
NResult N_API NListListLastIndexOfItemInRange(NListList * pList, NInt listIndex, HNType hValueType, const void * pValue, NSizeType valueSize, NInt startIndex, NInt count, NInt * pResult);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the 2D list.
NInt listIndex | [in] Index of the list.
HNType hValueType | [in] Handle to the value type.
const void * pValue | [in] Pointer to the value.
NSizeType valueSize | [in] Size of the value.
NInt startIndex | [in] Start index of the list part.
NInt count | [in] Length of the list part.
NInt * pResult | [out] Pointer to the index of the last occurrence.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


NListListRemoveAt Function

NListListRemoveAt Function
NListList.h

Removes a regular list from the 2D list.

C++
NResult N_API NListListRemoveAt(NListList * pList, NInt index);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the 2D list.
NInt index | [in] Index of the list to remove.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


NListListRemoveItem Function

NListListRemoveItem Function
NListList.h

Removes an item from the 2D list.

C++
NResult N_API NListListRemoveItem(NListList * pList, NInt listIndex, HNType hValueType, const void * pValue, NSizeType valueSize, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the 2D list.
NInt listIndex | [in] Index of the list.
HNType hValueType | [in] Handle to the value type.
const void * pValue | [in] Pointer to the item value to remove.
NSizeType valueSize | [in] Size of the value.
NInt * pIndex | [out] Index freed by the removed item.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


NListListRemoveItemAt Function

NListListRemoveItemAt Function
NListList.h

Removes an item from the 2D list.

C++
NResult N_API NListListRemoveItemAt(NListList * pList, NInt listIndex, NInt index);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the 2D list.
NInt listIndex | [in] Index of the list.
NInt index | [in] Index of the item to remove.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


NListListRemoveItemRange Function

NListListRemoveItemRange Function
NListList.h

Removes a range item from the 2D list.

C++
NResult N_API NListListRemoveItemRange(NListList * pList, NInt listIndex, NInt index, NInt count);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the 2D list.
NInt listIndex | [in] Index of the list.
NInt index | [in] Index of the starting item.
NInt count | [in] Number of items to remove.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


NListListRemoveRange Function

NListListRemoveRange Function
NListList.h

Removes a number of regular lists from the 2D list.

C++
NResult N_API NListListRemoveRange(NListList * pList, NInt index, NInt count);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the 2D list.
NInt index | [in] Index of the first list to remove.
NInt count | [in] Number of lists to remove.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


NListListSetCapacity Function

NListListSetCapacity Function
NListList.h

Sets the maximum number of 1D lists in the specified 2D list.

C++
NResult N_API NListListSetCapacity(NListList * pList, NInt value);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the 2D list.
NInt value | [in] List capacity value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


NListListSetCount Function

NListListSetCount Function
NListList.h

Sets the number of 1D lists in the specified 2D list.

C++
NResult N_API NListListSetCount(NListList * pList, NInt value);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the 2D list.
NInt value | [in] The number of lists.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


NListListSetItem Function

NListListSetItem Function
NListList.h

Sets the value of the specified item in the specified 2D list.

C++
NResult N_API NListListSetItem(NListList * pList, NInt listIndex, NInt index, HNType hValueType, const void * pValue, NSizeType valueSize);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the 2D list.
NInt listIndex | [in] Index of the list.
NInt index | [in] Index of the item.
HNType hValueType | [in] Handle to the value type.
const void * pValue | [in] Pointer to the new item value.
NSizeType valueSize | [in] Size of the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


NListListSetItemCapacity Function

NListListSetItemCapacity Function
NListList.h
C++
NResult N_API NListListSetItemCapacity(NListList * pList, NInt listIndex, NInt value);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the 2D list.
NInt listIndex | [in] Index of the list.
NInt value | [in] The item capacity.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


NListListSetItemCount Function

NListListSetItemCount Function
NListList.h

Sets the number of items in the specified list.

C++
NResult N_API NListListSetItemCount(NListList * pList, NInt listIndex, NInt value);
Collapse Expand Parameters
Parameters | Description
NListList * pList | [in/out] Pointer to the 2D list.
NInt listIndex | [in] Index of the list.
NInt value | [in] The number of items.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NListList.h

Module: NListList Unit


N_LIST_LIST_SIZE Macro

N_LIST_LIST_SIZE Macro
NListList.h

Defines the size of the two-dimensional list (default value 4).

C++
#define N_LIST_LIST_SIZE 44
Container

File: NListList.h

Module: NListList Unit


NListList.h

NListList.h
Functions Legend Macros

Header file for the NListList module.

Collapse Expand Functions
Name | Description
NListListAdd | Adds a regular list to the 2D list.
NListListAddItem | Adds an item to the 2D list.
NListListAddItemRange | Adds an array of items to the 2D list.
NListListAddListList | Adds the the specified 2D list to another specified 2D list.
NListListAddListListItems | Adds the contents of the specified 2D list to another specified 2D list.
NListListAddRange | Adds a number of regular lists to the 2D list.
NListListClear | Clears the specified 2D list.
NListListClearItems | Clears all items from the specified list.
NListListContainsItem | Checks whether the specified list contains the specified item.
NListListCopyItemsTo | Copies the specified list to an array.
NListListCopyItemsToRange | Copies a part of the specified list to an array.
NListListDetachItemsArray | Detaches an inner array from the specified array.
NListListDispose | Disposes of the specified 2D list.
NListListGetCapacity | Retrieves the maximum number of 1D lists in the specified 2D list.
NListListGetCount | Retrieves the number of 1D lists in the specified 2D list.
NListListGetItem | Retrieves the specified item from the specified 2D list.
NListListGetItemCapacity | Retrieves the maximum number of item in the specified list.
NListListGetItemCount | Retrieves the number of items in the specified list.
NListListGetItemPtr | Retrieves a pointer to the specified item from the specified 2D list.
NListListGetItemsEnd | Retrieves a pointer to the end of the inner array of the specified list.
NListListGetItemsStart | Retrieves a pointer to the start of the inner array of the specified list.
NListListIndexOfItem | Searches for the specified value and returns the index of the first occurrence within the specified list.
NListListIndexOfItemFrom | Searches for the specified value and returns the index of the first occurrence within the specified part of the list. The part is limited by an index and the list's end.
NListListIndexOfItemInRange | Searches for the specified value and returns the index of the first occurrence within the specified part of the list. The part is limited by an index and length.
NListListInit | Initializes the the specified 2D list.
NListListInitEx | Initializes the the specified 2D list.
NListListInitWithCapacity | Initializes the the specified 2D list.
NListListInsert | Adds a regular list to the 2D list at the specified index.
NListListInsertItem | Adds an item to the 2D list at the specified index.
NListListInsertItemRange | Adds an array of items to the 2D list at the specified index.
NListListInsertListList | Adds the the specified 2D list to another specified 2D list at the specified index..
NListListInsertListListItems | Adds the contents of the specified 2D list to another specified 2D list at the specified index.
NListListInsertRange | Adds a number of regular lists to the 2D list at the specified index.
NListListItemsToArray | Converts the specified list to an array.
NListListItemsToArrayRange | Converts a part of the specified list to an array.
NListListLastIndexOfItem | Searches for the specified value and returns the index of the last occurrence within the specified list.
NListListLastIndexOfItemFrom | Searches for the specified value and returns the index of the last occurrence within the specified part of the list. The part is limited by an index and the list's end.
NListListLastIndexOfItemInRange | Searches for the specified value and returns the index of the last occurrence within the specified part of the list. The part is limited by an index and length.
NListListRemoveAt | Removes a regular list from the 2D list.
NListListRemoveItem | Removes an item from the 2D list.
NListListRemoveItemAt | Removes an item from the 2D list.
NListListRemoveItemRange | Removes a range item from the 2D list.
NListListRemoveRange | Removes a number of regular lists from the 2D list.
NListListSetCapacity | Sets the maximum number of 1D lists in the specified 2D list.
NListListSetCount | Sets the number of 1D lists in the specified 2D list.
NListListSetItem | Sets the value of the specified item in the specified 2D list.
NListListSetItemCapacity |
NListListSetItemCount | Sets the number of items in the specified list.
Collapse Expand Macros
Name | Description
N_LIST_LIST_SIZE | Defines the size of the two-dimensional list (default value 4).


NMemberDescriptor Unit

NMemberDescriptor Unit
Files Functions Legend

Provides member descriptor management functionality.

Collapse Expand Files
Name | Description
NMemberDescriptor.h | Header file for the NMemberDescriptor unit.
Collapse Expand Functions
Name | Description
NMemberDescriptorGetComponentType | Retrieves the component type of the specified member descriptor.


NMemberDescriptorGetComponentType Function

NMemberDescriptorGetComponentType Function
NMemberDescriptor.h

Retrieves the component type of the specified member descriptor.

C++
NResult N_API NMemberDescriptorGetComponentType(HNMemberDescriptor hMemberDescriptor, HNType * phValue);
Collapse Expand Parameters
Parameters | Description
HNMemberDescriptor hMemberDescriptor | [in] Handle to the member descriptor.
HNType * phValue | [out] Pointer to a handle to the member descriptor type.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMemberDescriptor.h

Module: NMemberDescriptor Unit


NMemberDescriptor.h

NMemberDescriptor.h
Functions Legend

Header file for the NMemberDescriptor unit.

Collapse Expand Functions
Name | Description
NMemberDescriptorGetComponentType | Retrieves the component type of the specified member descriptor.


NMemberInfo Unit

NMemberInfo Unit
Files Functions Legend

Provides functionality to retrieve information about class members.

Collapse Expand Files
Name | Description
NMemberInfo.h | Header file for the NMemberInfo unit.
Collapse Expand Functions
Name | Description
NMemberInfoGetAttributes | Retrieves the attributes of the specified member.
NMemberInfoGetDeclaringType | Retrieves the declaring type of the specified member.
NMemberInfoGetId | Retrieves the ID of the specified member.
NMemberInfoGetName | Retrieves the name of the specified member.


NMemberInfoGetAttributes Function

NMemberInfoGetAttributes Function
NMemberInfo.h

Retrieves the attributes of the specified member.

C++
NResult N_API NMemberInfoGetAttributes(HNMemberInfo hMemberInfo, NAttributes * pValue);
Collapse Expand Parameters
Parameters | Description
HNMemberInfo hMemberInfo | [in] Handle to the member information.
NAttributes * pValue | [out] Pointer to the attributes of the member.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMemberInfo.h

Module: NMemberInfo Unit


NMemberInfoGetDeclaringType Function

NMemberInfoGetDeclaringType Function
NMemberInfo.h

Retrieves the declaring type of the specified member.

C++
NResult N_API NMemberInfoGetDeclaringType(HNMemberInfo hMemberInfo, HNType * phValue);
Collapse Expand Parameters
Parameters | Description
HNMemberInfo hMemberInfo | [in] Handle to the member information.
HNType * phValue | [out] Pointer to the declaring type of the member.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMemberInfo.h

Module: NMemberInfo Unit


NMemberInfoGetId Function

NMemberInfoGetId Function
NMemberInfo.h

Retrieves the ID of the specified member.

C++
NResult N_API NMemberInfoGetId(HNMemberInfo hMemberInfo, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNMemberInfo hMemberInfo | [in] Handle to the member information.
NInt * pValue | [out] Pointer to the ID of the member.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMemberInfo.h

Module: NMemberInfo Unit


NMemberInfoGetName Function

NMemberInfoGetName Function
NMemberInfo.h

Retrieves the name of the specified member.

C++
NResult N_API NMemberInfoGetName(HNMemberInfo hMemberInfo, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNMemberInfo hMemberInfo | [in] Handle to the member information.
HNString * phValue | [out] Pointer to the name of the member.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMemberInfo.h

Module: NMemberInfo Unit


NMemberInfo.h

NMemberInfo.h
Functions Legend

Header file for the NMemberInfo unit.

Collapse Expand Functions
Name | Description
NMemberInfoGetAttributes | Retrieves the attributes of the specified member.
NMemberInfoGetDeclaringType | Retrieves the declaring type of the specified member.
NMemberInfoGetId | Retrieves the ID of the specified member.
NMemberInfoGetName | Retrieves the name of the specified member.


NMemory Unit

NMemory Unit
Files Functions Legend Macros Structs, Records, Enums

Provides memory management for Neurotechnology components.

Collapse Expand Files
Name | Description
NMemory.h | ... more
Collapse Expand Functions
Name | Description
NAlignedFree | Frees an aligned memory resources.
NAlignedOffsetAlloc | Allocates an aligned memory block.
NAlignedOffsetAllocArray | Allocates an aligned memory block for array.
NAlignedOffsetCAlloc | Allocates an aligned memory block with all bytes set to zero.
NAlignedOffsetCAllocArray | Allocates an aligned array with all bytes set to zero.
NAlignedOffsetReAlloc | Reallocates an aligned memory block.
NAlignedOffsetReAllocArray | Reallocates an aligned array.
NAlloc | Allocates memory block.
NAllocArray | Allocates array.
NCAlloc | Allocates memory block with all bytes set to zero.
NCAllocArray | Allocates array with all bytes set to zero.
NClearArray | Clears array items.
NCompare | Compares bytes in two memory blocks.
NCopy | Copies data between memory blocks.
NCopyArray | Copies data between arrays.
NFill | Sets bytes of memory block to specified value.
NFree | Deallocates memory block.
NFreeEx | Deallocates memory block of a specified type.
NMemoryTypeIsValid | Checks if enumeration value is correct.
NMemoryTypeIsValidForFree | Checks if enumeration value for NFreeEx is correct.
NMove | Move data from one memory block to another.
NMoveArray | Move data from one array to another.
NPageAlloc | Allocates page.
NPageFree | Deallocates page memory.
NReAlloc | Reallocates memory block.
NReAllocArray | Reallocates array.
Collapse Expand Macros
Name | Description
NClear | Clears memory block.
Collapse Expand Structs, Records, Enums
Name | Description
NMemoryType_ | Enumerates memory types.
NMemoryType | Enumerates memory types.


NAlignedFree Function

NAlignedFree Function
NMemory.h

Frees an aligned memory resources.

C++
void N_API NAlignedFree(void * pBlock);
Collapse Expand Parameters
Parameters | Description
void * pBlock | [out] A pointer to previously allocated memory block to free.
Collapse Expand Remarks

If passed NULL as a parameter, function does nothing. Attempting to free an invalid pointer, can cause errors.

Container

File: NMemory.h

Module: NMemory Unit


NAlignedOffsetAlloc Function

NAlignedOffsetAlloc Function
NMemory.h

Allocates an aligned memory block.

C++
NResult N_API NAlignedOffsetAlloc(NSizeType size, NSizeType alignment, NSizeType offset, void * * ppBlock);
Collapse Expand Parameters
Parameters | Description
NSizeType size | [in] The size in bytes of memory to be allocated.
NSizeType alignment | [in] The alignment value, which must be an integer power of 2.
NSizeType offset | [in] The offset into the memory allocation to force the alignment.
void * * ppBlock | [out] A pointer to a newly allocated memory block.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMemory.h

Module: NMemory Unit


NAlignedOffsetAllocArray Function

NAlignedOffsetAllocArray Function
NMemory.h

Allocates an aligned memory block for array.

C++
NResult N_API NAlignedOffsetAllocArray(NSizeType elementSize, NInt length, NSizeType alignment, NInt offset, void * * ppValues);
Collapse Expand Parameters
Parameters | Description
NSizeType elementSize | [in] The size in bytes of memory to be allocated.
NInt length | [in] Array length.
NSizeType alignment | [in] The alignment value, which must be an integer power of 2.
NInt offset | [in] The offset into the memory allocation to force the alignment.
void * * ppValues | [out] A pointer to a newly allocated memory block for array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMemory.h

Module: NMemory Unit


NAlignedOffsetCAlloc Function

NAlignedOffsetCAlloc Function
NMemory.h

Allocates an aligned memory block with all bytes set to zero.

C++
NResult N_API NAlignedOffsetCAlloc(NSizeType size, NSizeType alignment, NSizeType offset, void * * ppBlock);
Collapse Expand Parameters
Parameters | Description
NSizeType size | [in] The size in bytes of memory to be allocated.
NSizeType alignment | [in] The alignment value, which must be an integer power of 2.
NSizeType offset | [in] The offset into the memory allocation to force the alignment.
void * * ppBlock | [out] A pointer to a newly allocated memory block.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMemory.h

Module: NMemory Unit


NAlignedOffsetCAllocArray Function

NAlignedOffsetCAllocArray Function
NMemory.h

Allocates an aligned array with all bytes set to zero.

C++
NResult N_API NAlignedOffsetCAllocArray(NSizeType elementSize, NInt length, NSizeType alignment, NInt offset, void * * ppValues);
Collapse Expand Parameters
Parameters | Description
NSizeType elementSize | [in] The size in bytes of memory to be allocated.
NInt length | [in] Array length.
NSizeType alignment | [in] The alignment value, which must be an integer power of 2.
NInt offset | [in] The offset into the memory allocation to force the alignment.
void * * ppValues | [out] A pointer to a newly allocated memory block. Returns
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMemory.h

Module: NMemory Unit


NAlignedOffsetReAlloc Function

NAlignedOffsetReAlloc Function
NMemory.h

Reallocates an aligned memory block.

C++
NResult N_API NAlignedOffsetReAlloc(void * * ppBlock, NSizeType size, NSizeType alignment, NSizeType offset);
Collapse Expand Parameters
Parameters | Description
void * * ppBlock | [in] A pointer to a previously allocated memory block which should be reallocated.
NSizeType size | [in] The size in bytes of a new memory block.
NSizeType alignment | [in] The alignment value, which must be an integer power of 2.
NSizeType offset | [in] The offset into the memory allocation to force the alignment.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMemory.h

Module: NMemory Unit


NAlignedOffsetReAllocArray Function

NAlignedOffsetReAllocArray Function
NMemory.h

Reallocates an aligned array.

C++
NResult N_API NAlignedOffsetReAllocArray(NSizeType elementSize, void * * ppValues, NInt length, NSizeType alignment, NInt offset);
Collapse Expand Parameters
Parameters | Description
NSizeType elementSize | [in] The size in bytes of array to be allocated.
void * * ppValues | [in] A pointer to a previously allocated array which should be reallocated.
NInt length | [in] Array length.
NSizeType alignment | [in] The alignment value, which must be an integer power of 2.
NInt offset | [in] The offset into the memory allocation to force the alignment.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMemory.h

Module: NMemory Unit


NAlloc Function

NAlloc Function
NMemory.h

Allocates memory block.

C++
NResult N_API NAlloc(NSizeType size, void * * ppBlock);
Collapse Expand Parameters
Parameters | Description
NSizeType size | [in] The size in bytes of memory to be allocated.
void * * ppBlock | [out] A pointer to a newly allocated memory block.
Collapse Expand Returns
Return value | Description
N_OK | If function succeeds it returns N_OK.
N_E_ARGUMENT_NULL | If provided ppBlock value is NULL, function fails and returns this error.
N_E_OUT_OF_MEMORY | If there was nor enough memory to allocate size bytes this error is returned.
Container

File: NMemory.h

Module: NMemory Unit


NAllocArray Function

NAllocArray Function
NMemory.h

Allocates array.

C++
NResult N_API NAllocArray(NSizeType elementSize, NInt length, void * * ppValues);
Collapse Expand Parameters
Parameters | Description
NSizeType elementSize | [in] The size in bytes of array to be allocated.
NInt length | [in] Array length.
void * * ppValues | [out] A pointer to a newly allocated memory block.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMemory.h

Module: NMemory Unit


NCAlloc Function

NCAlloc Function
NMemory.h

Allocates memory block with all bytes set to zero.

C++
NResult N_API NCAlloc(NSizeType size, void * * ppBlock);
Collapse Expand Parameters
Parameters | Description
NSizeType size | [in] The size in bytes of memory to be allocated.
void * * ppBlock | [out] A pointer to a newly allocated memory block.
Collapse Expand Returns
Return value | Description
N_OK | If function succeeds it returns N_OK.
N_E_ARGUMENT_NULL | If provided ppBlock value is NULL, function fails and returns this error.
N_E_OUT_OF_MEMORY | If there was nor enough memory to allocate size bytes this error is returned.
Container

File: NMemory.h

Module: NMemory Unit


NCAllocArray Function

NCAllocArray Function
NMemory.h

Allocates array with all bytes set to zero.

C++
NResult N_API NCAllocArray(NSizeType elementSize, NInt length, void * * ppValues);
Collapse Expand Parameters
Parameters | Description
NSizeType elementSize | [in] The size in bytes of array to be allocated.
NInt length | [in] Array length.
void * * ppValues | [out] A pointer to a newly allocated memory block.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMemory.h

Module: NMemory Unit


NClearArray Function

NClearArray Function
NMemory.h

Clears array items.

C++
NResult N_API NClearArray(NSizeType elementSize, void * pValues, NInt length);
Collapse Expand Parameters
Parameters | Description
NSizeType elementSize | [in] The size in bytes of array to be cleared.
void * pValues | [out] A pointer to a cleared array.
NInt length | [in] Array length.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMemory.h

Module: NMemory Unit


NCompare Function

NCompare Function
NMemory.h

Compares bytes in two memory blocks.

C++
NResult N_API NCompare(const void * pBlock1, const void * pBlock2, NSizeType size, NInt * pResult);
Collapse Expand Parameters
Parameters | Description
const void * pBlock1 | [in] A pointer to the first memory block.
const void * pBlock2 | [in] A pointer to the second memory block.
NSizeType size | [in] Number of bytes to be compared.
NInt * pResult | [out] Compare result.
Collapse Expand Returns
Return value | Description
N_OK | If function succeeds it returns N_OK.
N_E_ARGUMENT_NULL | If provided ppBlock1 or ppBlock2 value is NULL, function fails and returns this error.
Collapse Expand Remarks

If pResult value is less than zero then a block specified by pBlock1 is less than a block specified by pBlock2.

If pResult has a zero value then a block specified by pBlock1 is identical to a block specified by pBlock2.

If pResult is greater than zero then A block specified by pBlock1 is greater than a block specified by pBlock2.

Container

File: NMemory.h

Module: NMemory Unit


NCopy Function

NCopy Function
NMemory.h

Copies data between memory blocks.

C++
NResult N_API NCopy(void * pDstBlock, const void * pSrcBlock, NSizeType size);
Collapse Expand Parameters
Parameters | Description
void * pDstBlock | [in] A destination memory block (memory block to copy from).
const void * pSrcBlock | [in] A source memory block (memory block to copy to).
NSizeType size | [in] The size of memory block to be copied (the size is in bytes).
Collapse Expand Returns
Return value | Description
N_OK | If function succeeds it returns N_OK.
N_E_ARGUMENT_NULL | If provided pDstBlock or pDstBlock value is NULL, function fails and returns this error.
Container

File: NMemory.h

Module: NMemory Unit


NCopyArray Function

NCopyArray Function
NMemory.h

Copies data between arrays.

C++
NResult N_API NCopyArray(NSizeType elementSize, void * pDstValues, const void * pSrcValues, NInt length);
Collapse Expand Parameters
Parameters | Description
NSizeType elementSize | [in] The size in bytes of array.
void * pDstValues | [in] A destination array (memory block to copy from).
const void * pSrcValues | [in] A source array (memory block to copy to).
NInt length | [in] Array length.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMemory.h

Module: NMemory Unit


NFill Function

NFill Function
NMemory.h

Sets bytes of memory block to specified value.

C++
NResult N_API NFill(void * pBlock, NByte value, NSizeType size);
Collapse Expand Parameters
Parameters | Description
void * pBlock | [in] A pointer to a destination memory block that contains data.
NByte value | [in] A value to set.
NSizeType size | [in] The size in bytes of memory block to be set.
Collapse Expand Returns
Return value | Description
N_OK | If function succeeds it returns N_OK.
N_E_ARGUMENT_NULL | If provided pBlock value is NULL, function fails and returns this error.
Container

File: NMemory.h

Module: NMemory Unit


NFree Function

NFree Function
NMemory.h

Deallocates memory block.

C++
void N_API NFree(void * pBlock);
Collapse Expand Parameters
Parameters | Description
void * pBlock | [in] A pointer to memory block to be deallocated.
Collapse Expand Returns

If function succeeds the return value is N_OK.

Container

File: NMemory.h

Module: NMemory Unit


NFreeEx Function

NFreeEx Function
NMemory.h

Deallocates memory block of a specified type.

C++
void N_API NFreeEx(void * pBlock, NMemoryType memoryType);
Collapse Expand Parameters
Parameters | Description
void * pBlock | [in] A pointer to memory block to be deallocated.
NMemoryType memoryType | [in] Type of the memory block to be dealloacted.
Container

File: NMemory.h

Module: NMemory Unit


NMemoryTypeIsValid Function

NMemoryTypeIsValid Function
NMemory.h

Checks if enumeration value is correct.

C++
NBool N_API NMemoryTypeIsValid(NMemoryType value);
Collapse Expand Parameters
Parameters | Description
NMemoryType value | [in] Type of the memory block.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMemory.h

Module: NMemory Unit


NMemoryTypeIsValidForFree Function

NMemoryTypeIsValidForFree Function
NMemory.h

Checks if enumeration value for NFreeEx is correct.

C++
NBool N_API NMemoryTypeIsValidForFree(NMemoryType value);
Collapse Expand Parameters
Parameters | Description
NMemoryType value | [in] Type of the memory block.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMemory.h

Module: NMemory Unit


NMove Function

NMove Function
NMemory.h

Move data from one memory block to another.

C++
NResult N_API NMove(void * pDstBlock, const void * pSrcBlock, NSizeType size);
Collapse Expand Parameters
Parameters | Description
void * pDstBlock | [in] A pointer to destination memory block.
const void * pSrcBlock | [in] A pointer to source memory block.
NSizeType size | [in] Size in bytes to be copied.
Collapse Expand Returns

If the function succeeds, the return value is N_OK.

Collapse Expand Remarks

Copies size bytes from pDstBlock to pSrcBlock.

Make sure that the destination buffer is the same size or larger than the source buffer.

Container

File: NMemory.h

Module: NMemory Unit


NMoveArray Function

NMoveArray Function
NMemory.h

Move data from one array to another.

C++
NResult N_API NMoveArray(NSizeType elementSize, void * pDstValues, const void * pSrcValues, NInt length);
Collapse Expand Parameters
Parameters | Description
NSizeType elementSize | [in] The size in bytes of array.
void * pDstValues | [in] A pointer to destination array.
const void * pSrcValues | [in] A pointer to source array.
NInt length | [in] Array length.
Collapse Expand Returns

If the function succeeds, the return value is N_OK.

Collapse Expand Remarks

Copies size bytes from pDstBlock to pSrcBlock.

Make sure that the destination array is the same size or larger than the source array.

Container

File: NMemory.h

Module: NMemory Unit


NPageAlloc Function

NPageAlloc Function
NMemory.h

Allocates page.

C++
NResult N_API NPageAlloc(NSizeType size, void * * ppMem);
Collapse Expand Parameters
Parameters | Description
NSizeType size | [in] The size in bytes of page to be allocated.
void * * ppMem | [out] A pointer to a newly allocated page.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMemory.h

Module: NMemory Unit


NPageFree Function

NPageFree Function
NMemory.h

Deallocates page memory.

C++
NResult N_API NPageFree(void * pMem, NSizeType size);
Collapse Expand Parameters
Parameters | Description
void * pMem | [in] A pointer to page to be deallocated.
NSizeType size | [in] Size of memory block to be deallocated.
Collapse Expand Returns

If function succeeds the return value is N_OK.

Container

File: NMemory.h

Module: NMemory Unit


NReAlloc Function

NReAlloc Function
NMemory.h

Reallocates memory block.

C++
NResult N_API NReAlloc(void * * ppBlock, NSizeType size);
Collapse Expand Parameters
Parameters | Description
void * * ppBlock | [in] Pointer to previously allocated memory block which should be reallocated.
NSizeType size | [in] The size in bytes of a new memory block.
Collapse Expand Returns
Return value | Description
N_OK | If function succeeds it returns N_OK.
N_E_ARGUMENT_NULL | If provided ppBlock value is NULL, function fails and returns this error.
N_E_OUT_OF_MEMORY | If there was nor enough memory to allocate size bytes this error is returned.
Container

File: NMemory.h

Module: NMemory Unit


NReAllocArray Function

NReAllocArray Function
NMemory.h

Reallocates array.

C++
NResult N_API NReAllocArray(NSizeType elementSize, void * * ppValues, NInt length);
Collapse Expand Parameters
Parameters | Description
NSizeType elementSize | [in] The size in bytes of array.
void * * ppValues | [in] Pointer to previously allocated memory block which should be reallocated.
NInt length | [in] Array length.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMemory.h

Module: NMemory Unit


NMemoryType Enumeration

NMemoryType Enumeration
NMemory.h

Enumerates memory types.

C++
typedef enum NMemoryType_ {
  nmmtNone = 0,
  nmmtDefault = 1,
  nmmtAligned = 2,
  nmmtStandard = 3,
  nmmtWin32Local = 4,
  nmmtWin32Global = 5,
  nmmtCustom = 15
} NMemoryType;
Collapse Expand Members
Members | Description
nmmtNone = 0 | Indicates no memory.
nmmtDefault = 1 | Indicates default memory.
nmmtAligned = 2 | Indicates aligned memory.
nmmtStandard = 3 | Indicates standard memory.
nmmtWin32Local = 4 | Indicates Win32 Local memory.
nmmtWin32Global = 5 | Indicates Win32 Global memory.
nmmtCustom = 15 | Indicates custom memory.
Container

File: NMemory.h

Module: NMemory Unit


NClear Macro

NClear Macro
NMemory.h

Clears memory block.

C++
#define NClear(pBlock, size) NFill(pBlock, 0, size)
Container

File: NMemory.h

Module: NMemory Unit


NMemory.h

NMemory.h
Enumerations Functions Legend Macros

Header file for the NMemory module. Provides memory management for Neurotechnology components.

Collapse Expand Enumerations
Name | Description
NMemoryType_ | Enumerates memory types.
NMemoryType | Enumerates memory types.
Collapse Expand Functions
Name | Description
NAlignedFree | Frees an aligned memory resources.
NAlignedOffsetAlloc | Allocates an aligned memory block.
NAlignedOffsetAllocArray | Allocates an aligned memory block for array.
NAlignedOffsetCAlloc | Allocates an aligned memory block with all bytes set to zero.
NAlignedOffsetCAllocArray | Allocates an aligned array with all bytes set to zero.
NAlignedOffsetReAlloc | Reallocates an aligned memory block.
NAlignedOffsetReAllocArray | Reallocates an aligned array.
NAlloc | Allocates memory block.
NAllocArray | Allocates array.
NCAlloc | Allocates memory block with all bytes set to zero.
NCAllocArray | Allocates array with all bytes set to zero.
NClearArray | Clears array items.
NCompare | Compares bytes in two memory blocks.
NCopy | Copies data between memory blocks.
NCopyArray | Copies data between arrays.
NFill | Sets bytes of memory block to specified value.
NFree | Deallocates memory block.
NFreeEx | Deallocates memory block of a specified type.
NMemoryTypeIsValid | Checks if enumeration value is correct.
NMemoryTypeIsValidForFree | Checks if enumeration value for NFreeEx is correct.
NMove | Move data from one memory block to another.
NMoveArray | Move data from one array to another.
NPageAlloc | Allocates page.
NPageFree | Deallocates page memory.
NReAlloc | Reallocates memory block.
NReAllocArray | Reallocates array.
Collapse Expand Macros
Name | Description
NClear | Clears memory block.


NMemoryStream Unit

NMemoryStream Unit
Functions Legend Macros

Provides functions for working with memory streams.

Collapse Expand Functions
Name | Description
NMemoryStreamCreate | Creates a stream with an expandable capacity initialized to zero
NMemoryStreamCreateFromBuffer | ... more
NMemoryStreamCreateFromBufferN | ... more
NMemoryStreamCreateWithCapacity | ... more
NMemoryStreamGetBuffer | Returns NBuffer from which this stream was created.
NMemoryStreamGetCapacity | Returns the number of bytes allocated for this stream.
NMemoryStreamGetPositionPtr | Returns the current position within the stream.
NMemoryStreamSetCapacity | ... more
NMemoryStreamSetPositionPtr | Sets the current position within the stream.
NMemoryStreamToPtr | Copies the memory contained in the buffer and returns it as a pointer.
NMemoryStreamWriteTo | Writes the entire contents of NMemoryStream to another stream.
Collapse Expand Macros
Name | Description
NMemoryStreamCreateFromBufferForRead | Creates a new NMemoryStream based on the specified byte array.


NMemoryStreamCreate Function

NMemoryStreamCreate Function

Creates a stream with an expandable capacity initialized to zero

C++
NResult N_API NMemoryStreamCreate(HNMemoryStream * phStream);
Collapse Expand Parameters
Parameters | Description
HNMemoryStream * phStream | [out] A pointer to the created NMemoryStream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMemoryStream.h

Module: NMemoryStream Unit


NMemoryStreamCreateFromBuffer Function

NMemoryStreamCreateFromBuffer Function

Creates a new NMemoryStream based on the specified byte array, with the access other NMemoryStream (s) can have to the same file, and the buffer size.

C++
NResult N_API NMemoryStreamCreateFromBuffer(void * pBuffer, NSizeType bufferSize, NFileAccess access, NBool bufferExposable, HNMemoryStream * phStream);
Collapse Expand Parameters
Parameters | Description
void * pBuffer | [out] A pointer to an array of unsigned bytes from which to create this stream.
NSizeType bufferSize | [in] Size of memory buffer to store NMemoryStream. Can be zero.
NFileAccess access | [in] Value determining how the stream can be accessed by the NMemoryStream. NStreamCanRead and NStreamCanWrite function can be used to check stream access.
NBool bufferExposable | [in] NTrue to enable NStreamGetBuffer, which returns the unsigned byte array from which the stream was created; otherwise, NFalse.
HNMemoryStream * phStream | [out] A pointer to the created NMemoryStream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMemoryStream.h

Module: NMemoryStream Unit


NMemoryStreamCreateFromBufferN Function

NMemoryStreamCreateFromBufferN Function

Creates a new NMemoryStream with a the specified byte array and an access other NMemoryStreams can have to the same file.

C++
NResult N_API NMemoryStreamCreateFromBufferN(HNBuffer hBuffer, NFileAccess access, NBool bufferExposable, HNMemoryStream * phStream);
Collapse Expand Parameters
Parameters | Description
HNBuffer hBuffer | [in] A handle to an array of unsigned bytes from which to create this stream.
NFileAccess access | [in] File access value determining how the file can be accessed by the NMemoryStream. This gets the NStreamCanRead and NStreamCanWrite properties of the NMemoryStream object.
NBool bufferExposable | [in] NTrue to enable NMemoryStreamGetBuffer, which returns the NBuffer from which the stream was created; otherwise, NFalse.
HNMemoryStream * phStream | [out] A pointer to the created NMemoryStream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMemoryStream.h

Module: NMemoryStream Unit


NMemoryStreamCreateWithCapacity Function

NMemoryStreamCreateWithCapacity Function

Creates a new NMemoryStream with an expandable capacity initialized as specified.

C++
NResult N_API NMemoryStreamCreateWithCapacity(NSizeType capacity, HNMemoryStream * phStream);
Collapse Expand Parameters
Parameters | Description
NSizeType capacity | [in] Gets or sets the number of bytes allocated for this stream.
HNMemoryStream * phStream | [out] A pointer to the created NMemoryStream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMemoryStream.h

Module: NMemoryStream Unit


NMemoryStreamGetBuffer Function

NMemoryStreamGetBuffer Function

Returns NBuffer from which this stream was created.

C++
NResult N_API NMemoryStreamGetBuffer(HNMemoryStream hStream, HNBuffer * phValue);
Collapse Expand Parameters
Parameters | Description
HNMemoryStream hStream | [in] A handle to NMemoryStream.
HNBuffer * phValue | [out] A pointer NBuffer from which to create this stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMemoryStream.h

Module: NMemoryStream Unit


NMemoryStreamGetCapacity Function

NMemoryStreamGetCapacity Function

Returns the number of bytes allocated for this stream.

C++
NResult N_API NMemoryStreamGetCapacity(HNMemoryStream hStream, NSizeType * pValue);
Collapse Expand Parameters
Parameters | Description
HNMemoryStream hStream | [in] A handle to NMemoryStream.
NSizeType * pValue | [out] A pointer to the number of bytes allocated for this stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMemoryStream.h

Module: NMemoryStream Unit


NMemoryStreamGetPositionPtr Function

NMemoryStreamGetPositionPtr Function

Returns the current position within the stream.

C++
NResult N_API NMemoryStreamGetPositionPtr(HNMemoryStream hStream, void * * pValue);
Collapse Expand Parameters
Parameters | Description
HNMemoryStream hStream | [in] A handle to NMemoryStream.
void * * pValue | [out] A pointer to the current position within the stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMemoryStream.h

Module: NMemoryStream Unit


NMemoryStreamSetCapacity Function

NMemoryStreamSetCapacity Function

Sets the length of the usable portion of the buffer for the stream.

C++
NResult N_API NMemoryStreamSetCapacity(HNMemoryStream hStream, NSizeType value);
Collapse Expand Parameters
Parameters | Description
HNMemoryStream hStream | [in] A handle to NMemoryStream. value
NSizeType value | [in] The length of the usable portion of the buffer for the stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMemoryStream.h

Module: NMemoryStream Unit


NMemoryStreamSetPositionPtr Function

NMemoryStreamSetPositionPtr Function

Sets the current position within the stream.

C++
NResult N_API NMemoryStreamSetPositionPtr(HNMemoryStream hStream, void * value);
Collapse Expand Parameters
Parameters | Description
HNMemoryStream hStream | [in] A handle to NMemoryStream.
void * value | [out] A pointer to the current position within the stream to set.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMemoryStream.h

Module: NMemoryStream Unit


NMemoryStreamToPtr Function

NMemoryStreamToPtr Function

Copies the memory contained in the buffer and returns it as a pointer.

C++
NResult N_API NMemoryStreamToPtr(HNMemoryStream hStream, NSizeType * pBufferSize, void * * ppBuffer);
Collapse Expand Parameters
Parameters | Description
HNMemoryStream hStream | [in] A handle to NMemoryStream.
NSizeType * pBufferSize | [out] A NSizeType indicating the buffer size.
void * * ppBuffer | [out] A pointer to a pointer to an array of unsigned bytes from which this stream was created.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMemoryStream.h

Module: NMemoryStream Unit


NMemoryStreamWriteTo Function

NMemoryStreamWriteTo Function

Writes the entire contents of NMemoryStream to another stream.

C++
NResult N_API NMemoryStreamWriteTo(HNMemoryStream hStream, HNStream hDstStream);
Collapse Expand Parameters
Parameters | Description
HNMemoryStream hStream | [in] A handle to NMemoryStream.
HNStream hDstStream | [in] A handle to the destination stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMemoryStream.h

Module: NMemoryStream Unit


NMemoryStreamCreateFromBufferForRead Macro

NMemoryStreamCreateFromBufferForRead Macro

Creates a new NMemoryStream based on the specified byte array.

C++
#define NMemoryStreamCreateFromBufferForRead(pBuffer, bufferSize, phStream) NMemoryStreamCreateFromBuffer((void *)pBuffer, bufferSize, nfaRead, NFalse, phStream)
Collapse Expand Parameters
Parameters | Description
pBuffer | [out] A pointer to an array of unsigned bytes from which to create this stream.
bufferSize | [in] Size of memory buffer to store NMemoryStream. Can be zero.
phStream | [out] Pointer to a handle to the created memory stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMemoryStream.h

Module: NMemoryStream Unit


NMethodDescriptor Unit

NMethodDescriptor Unit
Files Functions Legend Macros

Represents the information about a method.

Collapse Expand Files
Name | Description
NMethodDescriptor.h | Header file for the NMethodDescriptor unit.
Collapse Expand Functions
Name | Description
NMethodDescriptorGetParameter | Retrieves the specified parameter of the method associated with the specified descriptor.
NMethodDescriptorGetParameterCount | Retrieves the number of parameters possessed by the method associated with the specified descriptor.
NMethodDescriptorGetParameters | Retrieves all parameters possessed by the method associated with the specified descriptor.
NMethodDescriptorGetReturnParameter | Retrieves the parameter returned by the method associated with the specified descriptor.
NMethodDescriptorInvoke | Invokes the method associated with the specified descriptor.
NMethodDescriptorInvokeWithPropertyBag | Invokes the method associated with the specified descriptor.
NMethodDescriptorInvokeWithString | Invokes the method associated with the specified descriptor.
Collapse Expand Macros
Name | Description
NMethodDescriptorInvokeWithString | Picks a Unicode (W) or ASCII (A) version of the NMethodDescriptorInvokeWithString function.


NMethodDescriptorGetParameter Function

NMethodDescriptorGetParameter Function
NMethodDescriptor.h

Retrieves the specified parameter of the method associated with the specified descriptor.

C++
NResult N_API NMethodDescriptorGetParameter(HNMethodDescriptor hMethodDescriptor, NInt index, HNParameterDescriptor * phValue);
Collapse Expand Parameters
Parameters | Description
HNMethodDescriptor hMethodDescriptor | [in] Handle to the method descriptor.
NInt index | [in] Index of the method parameter.
HNParameterDescriptor * phValue | [out] Pointer to the method parameter descriptor.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMethodDescriptor.h

Module: NMethodDescriptor Unit


NMethodDescriptorGetParameterCount Function

NMethodDescriptorGetParameterCount Function
NMethodDescriptor.h

Retrieves the number of parameters possessed by the method associated with the specified descriptor.

C++
NResult N_API NMethodDescriptorGetParameterCount(HNMethodDescriptor hMethodDescriptor, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNMethodDescriptor hMethodDescriptor | [in] Handle to the method descriptor.
NInt * pValue | [out] Pointer to the number of parameters.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMethodDescriptor.h

Module: NMethodDescriptor Unit


NMethodDescriptorGetParameters Function

NMethodDescriptorGetParameters Function
NMethodDescriptor.h

Retrieves all parameters possessed by the method associated with the specified descriptor.

C++
NResult N_API NMethodDescriptorGetParameters(HNMethodDescriptor hMethodDescriptor, HNParameterDescriptor * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNMethodDescriptor hMethodDescriptor | [in] Handle to the method descriptor.
HNParameterDescriptor * * parhValues | [out] Pointer to an array of parameter descriptors.
NInt * pValueCount | [out] Pointer to the number of parameters in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMethodDescriptor.h

Module: NMethodDescriptor Unit


NMethodDescriptorGetReturnParameter Function

NMethodDescriptorGetReturnParameter Function
NMethodDescriptor.h

Retrieves the parameter returned by the method associated with the specified descriptor.

C++
NResult N_API NMethodDescriptorGetReturnParameter(HNMethodDescriptor hMethodDescriptor, HNParameterDescriptor * phValue);
Collapse Expand Parameters
Parameters | Description
HNMethodDescriptor hMethodDescriptor | [in] Handle to the method descriptor.
HNParameterDescriptor * phValue | [out] Pointer to the returned parameter descriptor.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMethodDescriptor.h

Module: NMethodDescriptor Unit


NMethodDescriptorInvoke Function

NMethodDescriptorInvoke Function
NMethodDescriptor.h

Invokes the method associated with the specified descriptor.

C++
NResult N_API NMethodDescriptorInvoke(HNMethodDescriptor hMethodDescriptor, HNObject hComponent, HNValue * arhParameters, NInt parameterCount, HNValue * phResult);
Collapse Expand Parameters
Parameters | Description
HNMethodDescriptor hMethodDescriptor | [in] Handle to the method descriptor.
HNObject hComponent | [in] Handle to the object on which the method will be invoked.
HNValue * arhParameters | [in/out] Pointer to an array of values with the same number, order, and type as the parameters of the method or constructor to be invoked.
NInt parameterCount | [in] Number of parameters in the array.
HNValue * phResult | [out] Pointer to the value returned by the invoked method, or null in case of constructor.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMethodDescriptor.h

Module: NMethodDescriptor Unit


NMethodDescriptorInvokeWithPropertyBag Function

NMethodDescriptorInvokeWithPropertyBag Function
NMethodDescriptor.h

Invokes the method associated with the specified descriptor.

C++
NResult N_API NMethodDescriptorInvokeWithPropertyBag(HNMethodDescriptor hMethodDescriptor, HNObject hComponent, HNPropertyBag hParameters, HNValue * phResult);
Collapse Expand Parameters
Parameters | Description
HNMethodDescriptor hMethodDescriptor | [in] Handle to the method descriptor.
HNObject hComponent | [in] Handle to the object on which the method will be invoked.
HNPropertyBag hParameters | [in] Handle to a property bag containing values with the same number, order, and type as the parameters of the method or constructor to be invoked.
HNValue * phResult | [out] Pointer to the value returned by the invoked method, or null in case of constructor.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMethodDescriptor.h

Module: NMethodDescriptor Unit


NMethodDescriptorInvokeWithString Function

NMethodDescriptorInvokeWithString Function
NMethodDescriptor.h

Invokes the method associated with the specified descriptor.

C++
NResult N_API NMethodDescriptorInvokeWithString(HNMethodDescriptor hMethodDescriptor, HNObject hComponent, const NChar * szParameters, HNValue * phResult);
Collapse Expand Parameters
Parameters | Description
HNMethodDescriptor hMethodDescriptor | [in] Handle to the method descriptor.
HNObject hComponent | [in] Handle to the object on which the method will be invoked.
const NChar * szParameters | [in] Pointer to a string representing the parameters of the method or constructor to be invoked.
HNValue * phResult | [out] Pointer to the value returned by the invoked method, or null in case of constructor.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMethodDescriptor.h

Module: NMethodDescriptor Unit


NMethodDescriptorInvokeWithString Macro

NMethodDescriptorInvokeWithString Macro
NMethodDescriptor.h

Picks a Unicode (W) or ASCII (A) version of the NMethodDescriptorInvokeWithString function.

C++
#define NMethodDescriptorInvokeWithString N_FUNC_AW(NMethodDescriptorInvokeWithString)
Container

File: NMethodDescriptor.h

Module: NMethodDescriptor Unit


NMethodDescriptor.h

NMethodDescriptor.h
Functions Legend Macros

Header file for the NMethodDescriptor unit.

Collapse Expand Functions
Name | Description
NMethodDescriptorGetParameter | Retrieves the specified parameter of the method associated with the specified descriptor.
NMethodDescriptorGetParameterCount | Retrieves the number of parameters possessed by the method associated with the specified descriptor.
NMethodDescriptorGetParameters | Retrieves all parameters possessed by the method associated with the specified descriptor.
NMethodDescriptorGetReturnParameter | Retrieves the parameter returned by the method associated with the specified descriptor.
NMethodDescriptorInvoke | Invokes the method associated with the specified descriptor.
NMethodDescriptorInvokeWithPropertyBag | Invokes the method associated with the specified descriptor.
NMethodDescriptorInvokeWithString | Invokes the method associated with the specified descriptor.
Collapse Expand Macros
Name | Description
NMethodDescriptorInvokeWithString | Picks a Unicode (W) or ASCII (A) version of the NMethodDescriptorInvokeWithString function.


NMethodInfo Unit

NMethodInfo Unit
Files Functions Legend Macros

Provides functionality to retrieve information about methods.

Collapse Expand Files
Name | Description
NMethodInfo.h | Header file for the NMethodInfo unit.
Collapse Expand Functions
Name | Description
NMethodInfoGetNativeName | Retrieves the native name of the specified method.
NMethodInfoGetParameter | Retrieves the specified parameter of the specified method.
NMethodInfoGetParameterCount | Retrieves the number of parameters of the specified method.
NMethodInfoGetParameters | Retrieves all parameters of the specified method.
NMethodInfoGetReturnParameter | Retrieves the return parameter of the specified method.
NMethodInfoInvoke | Invokes the specified method.
NMethodInfoInvokeWithPropertyBag | Invokes the specified method.
NMethodInfoInvokeWithString | Invokes the specified method.
Collapse Expand Macros
Name | Description
NMethodInfoInvokeWithString | Picks a Unicode (W) or ASCII (A) version of the NMethodInfoInvokeWithString function.


NMethodInfoGetNativeName Function

NMethodInfoGetNativeName Function
NMethodInfo.h

Retrieves the native name of the specified method.

C++
NResult N_API NMethodInfoGetNativeName(HNMethodInfo hMethodInfo, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNMethodInfo hMethodInfo | [in] Handle to the method information.
HNString * phValue | [out] Pointer to the native name of the method.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMethodInfo.h

Module: NMethodInfo Unit


NMethodInfoGetParameter Function

NMethodInfoGetParameter Function
NMethodInfo.h

Retrieves the specified parameter of the specified method.

C++
NResult N_API NMethodInfoGetParameter(HNMethodInfo hMethodInfo, NInt index, HNParameterInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNMethodInfo hMethodInfo | [in] Handle to the method information.
NInt index | [in] Index of the parameter.
HNParameterInfo * phValue | [out] Pointer to the parameter.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMethodInfo.h

Module: NMethodInfo Unit


NMethodInfoGetParameterCount Function

NMethodInfoGetParameterCount Function
NMethodInfo.h

Retrieves the number of parameters of the specified method.

C++
NResult N_API NMethodInfoGetParameterCount(HNMethodInfo hMethodInfo, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNMethodInfo hMethodInfo | [in] Handle to the method information.
NInt * pValue | [out] Pointer to the number of parameters.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMethodInfo.h

Module: NMethodInfo Unit


NMethodInfoGetParameters Function

NMethodInfoGetParameters Function
NMethodInfo.h

Retrieves all parameters of the specified method.

C++
NResult N_API NMethodInfoGetParameters(HNMethodInfo hMethodInfo, HNParameterInfo * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNMethodInfo hMethodInfo | [in] Handle to the method information.
HNParameterInfo * * parhValues | [out] Pointer to an array of parameters.
NInt * pValueCount | [out] Pointer to the number of parameters in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMethodInfo.h

Module: NMethodInfo Unit


NMethodInfoGetReturnParameter Function

NMethodInfoGetReturnParameter Function
NMethodInfo.h

Retrieves the return parameter of the specified method.

C++
NResult N_API NMethodInfoGetReturnParameter(HNMethodInfo hMethodInfo, HNParameterInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNMethodInfo hMethodInfo | [in] Handle to the method information.
HNParameterInfo * phValue | [out] Pointer to the return parameter.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMethodInfo.h

Module: NMethodInfo Unit


NMethodInfoInvoke Function

NMethodInfoInvoke Function
NMethodInfo.h

Invokes the specified method.

C++
NResult N_API NMethodInfoInvoke(HNMethodInfo hMethodInfo, HNObject hObject, HNValue * arhParameters, NInt parameterCount, HNValue * phResult);
Collapse Expand Parameters
Parameters | Description
HNMethodInfo hMethodInfo | [in] Handle to the method information.
HNObject hObject | [in] Handle to the object on which the method will be invoked.
HNValue * arhParameters | [in/out] Pointer to an array of values with the same number, order, and type as the parameters of the method or constructor to be invoked.
NInt parameterCount | [in] Number of parameters in the array.
HNValue * phResult | [out] Pointer to the value returned by the invoked method, or null in case of constructor.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMethodInfo.h

Module: NMethodInfo Unit


NMethodInfoInvokeWithPropertyBag Function

NMethodInfoInvokeWithPropertyBag Function
NMethodInfo.h

Invokes the specified method.

C++
NResult N_API NMethodInfoInvokeWithPropertyBag(HNMethodInfo hMethodInfo, HNObject hObject, HNPropertyBag hParameters, HNValue * phResult);
Collapse Expand Parameters
Parameters | Description
HNMethodInfo hMethodInfo | [in] Handle to the method information.
HNObject hObject | [in] Handle to the object on which the method will be invoked.
HNPropertyBag hParameters | [in] Handle to a property bag containing values with the same number, order, and type as the parameters of the method or constructor to be invoked.
HNValue * phResult | [out] Pointer to the value returned by the invoked method, or null in case of constructor.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMethodInfo.h

Module: NMethodInfo Unit


NMethodInfoInvokeWithString Function

NMethodInfoInvokeWithString Function
NMethodInfo.h

Invokes the specified method.

C++
NResult N_API NMethodInfoInvokeWithString(HNMethodInfo hMethodInfo, HNObject hObject, const NChar * szParameters, HNValue * phResult);
Collapse Expand Parameters
Parameters | Description
HNMethodInfo hMethodInfo | [in] Handle to the method information.
HNObject hObject | [in] Handle to the object on which the method will be invoked.
const NChar * szParameters | [in] Pointer to a string representing the parameters of the method or constructor to be invoked.
HNValue * phResult | [out] Pointer to the value returned by the invoked method, or null in case of constructor.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMethodInfo.h

Module: NMethodInfo Unit


NMethodInfoInvokeWithString Macro

NMethodInfoInvokeWithString Macro
NMethodInfo.h

Picks a Unicode (W) or ASCII (A) version of the NMethodInfoInvokeWithString function.

C++
#define NMethodInfoInvokeWithString N_FUNC_AW(NMethodInfoInvokeWithString)
Container

File: NMethodInfo.h

Module: NMethodInfo Unit


NMethodInfo.h

NMethodInfo.h
Functions Legend Macros

Header file for the NMethodInfo unit.

Collapse Expand Functions
Name | Description
NMethodInfoGetNativeName | Retrieves the native name of the specified method.
NMethodInfoGetParameter | Retrieves the specified parameter of the specified method.
NMethodInfoGetParameterCount | Retrieves the number of parameters of the specified method.
NMethodInfoGetParameters | Retrieves all parameters of the specified method.
NMethodInfoGetReturnParameter | Retrieves the return parameter of the specified method.
NMethodInfoInvoke | Invokes the specified method.
NMethodInfoInvokeWithPropertyBag | Invokes the specified method.
NMethodInfoInvokeWithString | Invokes the specified method.
Collapse Expand Macros
Name | Description
NMethodInfoInvokeWithString | Picks a Unicode (W) or ASCII (A) version of the NMethodInfoInvokeWithString function.


NModule Unit

NModule Unit
Files Functions Legend Macros Structs, Records, Enums

Each separate piece of code/functionality is a module. The functions in this unit allow to get the information about the module it's name, version, etc..

Collapse Expand Files
Name | Description
NModule.h | Header file for the NModule unit.
Collapse Expand Functions
Name | Description
NModuleCheckInit | Checks whether the module is initialized and throws and exception if it is not.
NModuleCreate | Creates a new NModule.
NModuleCreateInstance | Creates a new instance of the specified module.
NModuleGetActivatedN | Get the activation status of a protected module.
NModuleGetCompanyN | Get the company name providing the component.
NModuleGetCopyrightN | Get the copyright string for the module.
NModuleGetDefinedType | Retrieves the defined type specified by index from the specified module.
NModuleGetDefinedTypeCount | Retrieves the number of defined types in the specified module.
NModuleGetDefinedTypes | Retrieves all defined types from the specified module.
NModuleGetDependences | Retrieves the module's dependencies.
NModuleGetFileName | Retrieves the name of the file the specified module was created from.
NModuleGetId | Retrieves the ID of the module.
NModuleGetLoadedModules | Get a list of loaded modules.
NModuleGetNameN | Get the short name of the given module.
NModuleGetNativeId | Retrieves the native ID of the specified module.
NModuleGetOptions | Get the set of component's flags.
NModuleGetProductN | Get the product name of the given module.
NModuleGetTitleN | Get the title string (long name with version) for the given module.
NModuleGetTypeWithName | Get the type with the specified name for the given module.
NModuleGetVersionBuild | Get the build number part of the version (Major.Minor.Revision.Build).
NModuleGetVersionMajor | Get the major number part of the version (Major.Minor.Revision.Build).
NModuleGetVersionMinor | Get the minor number part of the version (Major.Minor.Revision.Build).
NModuleGetVersionRevision | Get the revision number part of the version (Major.Minor.Revision.Build).
NModuleLoadFromFile | Loads a module from the specified file.
NModuleSetCompany | Sets company.
NModuleSetCompanyN | Sets the company for the specified NModule.
NModuleSetCopyright | Sets copyright string.
NModuleSetCopyrightN | Sets the copyright for the specified NModule.
NModuleSetId | Sets the ID of the specified module.
NModuleSetNameN | Sets the name for the specified NModule.
NModuleSetNativeId | Sets the native ID of the specified module.
NModuleSetOptions | Sets the options for the specified module.
NModuleSetProduct | Sets product name.
NModuleSetProductN | Sets the product of the specified module.
NModuleSetTitle | Sets NModule title.
NModuleSetTitleN | Sets the title for the specified NModule.
NModuleSetVersionBuild | Sets the version build value for the specified module.
NModuleSetVersionMajor | Sets the version major value for the specified module.
NModuleSetVersionMinor | Sets the version minor value for the specified module.
NModuleSetVersionRevision | Sets the version revision value for the specified module.
Collapse Expand Macros
Name | Description
NModuleCreateInstance | Picks a Unicode (W) or ASCII (A) version of the NModuleCreateInstance function.
NModuleGetTypeWithName | Picks a Unicode (W) or ASCII (A) version of the NModuleGetTypeWithName function.
NModuleLoadFromFile | Picks a Unicode (W) or ASCII (A) version of the NModuleLoadFromFile function.
NModuleSetId | Picks a Unicode (W) or ASCII (A) version of the NModuleSetId function.
NModuleSetName | Picks a Unicode (W) or ASCII (A) version of the NModuleSetName function.
NModuleSetNativeId | Picks a Unicode (W) or ASCII (A) version of the NModuleSetNativeId function.
N_DECLARE_MODULE | Declares the module.
N_MODULE_OF | Used to obtain a pointer to the function that retrieves NModule object for the specified module name.
Collapse Expand Structs, Records, Enums
Name | Description
NModuleOptions_ | Enumeration of possible module flags giving additional information about the module.
NModuleOptions | Enumeration of possible module flags giving additional information about the module.


NModuleCheckInit Function

NModuleCheckInit Function
NModule.h

Checks whether the module is initialized and throws and exception if it is not.

C++
NResult N_API NModuleCheckInit(HNModule hModule, NBool lazy);
Collapse Expand Parameters
Parameters | Description
HNModule hModule | [in] Handle to the NModule.
NBool lazy | [in] NTrue if the initialization is lazy; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NModule.h

Module: NModule Unit


NModuleCreate Function

NModuleCreate Function
NModule.h

Creates a new NModule.

C++
NResult N_API NModuleCreate(HNModule * phModule);
Collapse Expand Parameters
Parameters | Description
HNModule * phModule | [out] Pointer to a handle to the new NModule.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NModule.h

Module: NModule Unit


NModuleCreateInstance Function

NModuleCreateInstance Function
NModule.h

Creates a new instance of the specified module.

C++
NResult N_API NModuleCreateInstance(HNModule hModule, const NChar * szName, NAttributes attributes, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
HNModule hModule | [in] Handle of the module.
const NChar * szName | [in] Pointer to the name of the new module instance.
NAttributes attributes | [in] Module attributes.
HNValue * phValue | [out] Pointer to the new module instance.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NModule.h

Module: NModule Unit


NModuleGetActivatedN Function

NModuleGetActivatedN Function
NModule.h

Get the activation status of a protected module.

C++
NResult N_API NModuleGetActivatedN(HNModule hModule, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNModule hModule | [in] Handle of the module.
HNString * phValue | [out] Pointer to memory buffer that receives result as a string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

The format of the string returned through szValue:

  • "" (empty string) – for unprotected module;
  • "Yes" or "No" – in case the module provides single protected component;
  • "Component1:Yes/No, Component1:Yes/No, ..., ComponentN:Yes/No" – in case the module provides multiple protected components, the comma separated list of component names with "Yes" or "No" value for each component.
Container

File: NModule.h

Module: NModule Unit


NModuleGetCompanyN Function

NModuleGetCompanyN Function
NModule.h

Get the company name providing the component.

C++
NResult N_API NModuleGetCompanyN(HNModule hModule, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNModule hModule | [in] Handle of the module.
HNString * phValue | [out] Pointer to memory buffer that receives result as zero terminated string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NModule.h

Module: NModule Unit


NModuleGetCopyrightN Function

NModuleGetCopyrightN Function
NModule.h

Get the copyright string for the module.

C++
NResult N_API NModuleGetCopyrightN(HNModule hModule, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNModule hModule | [in] Handle of the module.
HNString * phValue | [out] Pointer to memory buffer that receives result as zero terminated string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NModule.h

Module: NModule Unit


NModuleGetDefinedType Function

NModuleGetDefinedType Function
NModule.h

Retrieves the defined type specified by index from the specified module.

C++
NResult N_API NModuleGetDefinedType(HNModule hModule, NInt index, HNType * phValue);
Collapse Expand Parameters
Parameters | Description
HNModule hModule | [in] Handle of the module.
NInt index | [in] Index of the type.
HNType * phValue | [out] Pointer to the defined type.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NModule.h

Module: NModule Unit


NModuleGetDefinedTypeCount Function

NModuleGetDefinedTypeCount Function
NModule.h

Retrieves the number of defined types in the specified module.

C++
NResult N_API NModuleGetDefinedTypeCount(HNModule hModule, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNModule hModule | [in] Handle of the module.
NInt * pValue | [out] Pointer to number of types.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NModule.h

Module: NModule Unit


NModuleGetDefinedTypes Function

NModuleGetDefinedTypes Function
NModule.h

Retrieves all defined types from the specified module.

C++
NResult N_API NModuleGetDefinedTypes(HNModule hModule, HNType * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNModule hModule | [in] Handle of the module.
HNType * * parhValues | [out] Pointer to an array of defined types.
NInt * pValueCount | [out] Pointer to the number of types in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NModule.h

Module: NModule Unit


NModuleGetDependences Function

NModuleGetDependences Function
NModule.h

Retrieves the module's dependencies.

C++
NResult N_API NModuleGetDependences(HNModule hModule, HNModule * arhValues, NInt valuesLength);
Collapse Expand Parameters
Parameters | Description
HNModule hModule | [in] A handle to the NModule.
HNModule * arhValues | [out] A pointer to an array of dependencies.
NInt valuesLength | [in] Length of the array of dependencies.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

NObjectUnref shall be called on returned objects when they are no longer used to prevent memory leaks.

Container

File: NModule.h

Module: NModule Unit


NModuleGetFileName Function

NModuleGetFileName Function
NModule.h

Retrieves the name of the file the specified module was created from.

C++
NResult N_API NModuleGetFileName(HNModule hModule, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNModule hModule | [in] Handle of the module.
HNString * phValue | [out] Pointer to the name of the file.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NModule.h

Module: NModule Unit


NModuleGetId Function

NModuleGetId Function
NModule.h

Retrieves the ID of the module.

C++
NResult N_API NModuleGetId(HNModule hModule, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNModule hModule | [in] Handle of the module.
HNString * phValue | [out] Pointer to the module ID.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NModule.h

Module: NModule Unit


NModuleGetLoadedModules Function

NModuleGetLoadedModules Function
NModule.h

Get a list of loaded modules.

C++
NResult N_API NModuleGetLoadedModules(HNModule * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNModule * * parhValues | Pointer which receives a newly allocated array.
NInt * pValueCount | Number of elements in the array allocated in parhValues.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NModule.h

Module: NModule Unit


NModuleGetNameN Function

NModuleGetNameN Function
NModule.h

Get the short name of the given module.

C++
NResult N_API NModuleGetNameN(HNModule hModule, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNModule hModule | [in] Handle of the module.
HNString * phValue | [out] Pointer to memory buffer that receives result as a string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NModule.h

Module: NModule Unit


NModuleGetNativeId Function

NModuleGetNativeId Function
NModule.h

Retrieves the native ID of the specified module.

C++
NResult N_API NModuleGetNativeId(HNModule hModule, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNModule hModule | [in] Handle of the module.
HNString * phValue | [out] Pointer to the native ID.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NModule.h

Module: NModule Unit


NModuleGetOptions Function

NModuleGetOptions Function
NModule.h

Get the set of component's flags.

C++
NResult N_API NModuleGetOptions(HNModule hModule, NModuleOptions * pValue);
Collapse Expand Parameters
Parameters | Description
HNModule hModule | [in] Handle of the module.
NModuleOptions * pValue | [out] Pointer to variable that receives options.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

The returned value is bitwise OR composition of individual NModuleOptions flags.

Container

File: NModule.h

Module: NModule Unit


NModuleGetProductN Function

NModuleGetProductN Function
NModule.h

Get the product name of the given module.

C++
NResult N_API NModuleGetProductN(HNModule hModule, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNModule hModule | [in] Handle of the module.
HNString * phValue | [out] Pointer to memory buffer that receives result as a string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NModule.h

Module: NModule Unit


NModuleGetTitleN Function

NModuleGetTitleN Function
NModule.h

Get the title string (long name with version) for the given module.

C++
NResult N_API NModuleGetTitleN(HNModule hModule, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNModule hModule | [in] Handle of the module.
HNString * phValue | [out] Pointer to memory buffer that receives result as a string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NModule.h

Module: NModule Unit


NModuleGetTypeWithName Function

NModuleGetTypeWithName Function
NModule.h

Get the type with the specified name for the given module.

C++
NResult N_API NModuleGetTypeWithName(HNModule hModule, const NChar * szName, NBool mustExist, HNType * phValue);
Collapse Expand Parameters
Parameters | Description
HNModule hModule | [in] Handle of the module.
const NChar * szName | [in] Pointer to the type name.
NBool mustExist | [in] NTrue if only existing types should be returned; else NFalse.
HNType * phValue | [out] Pointer to the type.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NModule.h

Module: NModule Unit


NModuleGetVersionBuild Function

NModuleGetVersionBuild Function
NModule.h

Get the build number part of the version (Major.Minor.Revision.Build).

C++
NResult N_API NModuleGetVersionBuild(HNModule hModule, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNModule hModule | [in] Handle of the module.
NInt * pValue | [out] Pointer to variable that receives requested value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NModule.h

Module: NModule Unit


NModuleGetVersionMajor Function

NModuleGetVersionMajor Function
NModule.h

Get the major number part of the version (Major.Minor.Revision.Build).

C++
NResult N_API NModuleGetVersionMajor(HNModule hModule, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNModule hModule | [in] Handle of the module.
NInt * pValue | [out] Pointer to variable that receives requested value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NModule.h

Module: NModule Unit


NModuleGetVersionMinor Function

NModuleGetVersionMinor Function
NModule.h

Get the minor number part of the version (Major.Minor.Revision.Build).

C++
NResult N_API NModuleGetVersionMinor(HNModule hModule, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNModule hModule | [in] Handle of the module.
NInt * pValue | [out] Pointer to variable that receives requested value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NModule.h

Module: NModule Unit


NModuleGetVersionRevision Function

NModuleGetVersionRevision Function
NModule.h

Get the revision number part of the version (Major.Minor.Revision.Build).

C++
NResult N_API NModuleGetVersionRevision(HNModule hModule, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNModule hModule | [in] Handle of the module.
NInt * pValue | [out] Pointer to variable that receives requested value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NModule.h

Module: NModule Unit


NModuleLoadFromFile Function

NModuleLoadFromFile Function
NModule.h

Loads a module from the specified file.

C++
NResult N_API NModuleLoadFromFile(const NChar * szFileName, HNModule * phModule);
Collapse Expand Parameters
Parameters | Description
const NChar * szFileName | [in] Pointer to the filename.
HNModule * phModule | [out] Pointer to the module handle.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NModule.h

Module: NModule Unit


NModuleSetCompany Function

NModuleSetCompany Function
NModule.h

Sets company.

C++
NResult N_API NModuleSetCompany(HNModule hModule, const NChar * szValue);
Collapse Expand Parameters
Parameters | Description
HNModule hModule | [in] Handle of the module.
const NChar * szValue | [in] Company name to set.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NModule.h

Module: NModule Unit


NModuleSetCompanyN Function

NModuleSetCompanyN Function
NModule.h

Sets the company for the specified NModule.

C++
NResult N_API NModuleSetCompanyN(HNModule hModule, HNString hValue);
Collapse Expand Parameters
Parameters | Description
HNModule hModule | [in] Handle to the NModule.
HNString hValue | [in] Handle to the new company string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NModule.h

Module: NModule Unit


NModuleSetCopyright Function

NModuleSetCopyright Function
NModule.h

Sets copyright string.

C++
NResult N_API NModuleSetCopyright(HNModule hModule, const NChar * szValue);
Collapse Expand Parameters
Parameters | Description
HNModule hModule | [in] Handle to the NModule.
const NChar * szValue | [in] Copyright information name to set.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NModule.h

Module: NModule Unit


NModuleSetCopyrightN Function

NModuleSetCopyrightN Function
NModule.h

Sets the copyright for the specified NModule.

C++
NResult N_API NModuleSetCopyrightN(HNModule hModule, HNString hValue);
Collapse Expand Parameters
Parameters | Description
HNModule hModule | [in] Handle to the NModule.
HNString hValue | [in] Handle to the new copyright string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NModule.h

Module: NModule Unit


NModuleSetId Function

NModuleSetId Function
NModule.h

Sets the ID of the specified module.

C++
NResult N_API NModuleSetId(HNModule hModule, const NChar * szValue);
Collapse Expand Parameters
Parameters | Description
HNModule hModule | [in] Handle of the module.
const NChar * szValue | [in] Pointer to the module ID.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NModule.h

Module: NModule Unit


NModuleSetNameN Function

NModuleSetNameN Function
NModule.h

Sets the name for the specified NModule.

C++
NResult N_API NModuleSetNameN(HNModule hModule, HNString hValue);
Collapse Expand Parameters
Parameters | Description
HNModule hModule | [in] Handle to the NModule.
HNString hValue | [in] Handle to the new name string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NModule.h

Module: NModule Unit


NModuleSetNativeId Function

NModuleSetNativeId Function
NModule.h

Sets the native ID of the specified module.

C++
NResult N_API NModuleSetNativeId(HNModule hModule, const NChar * szValue);
Collapse Expand Parameters
Parameters | Description
HNModule hModule | [in] Handle of the module.
const NChar * szValue | [out] Pointer to the native ID.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NModule.h

Module: NModule Unit


NModuleSetOptions Function

NModuleSetOptions Function
NModule.h

Sets the options for the specified module.

C++
NResult N_API NModuleSetOptions(HNModule hModule, NModuleOptions value);
Collapse Expand Parameters
Parameters | Description
HNModule hModule | [in] Handle to the NModule.
NModuleOptions value | [in] Module options.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NModule.h

Module: NModule Unit


NModuleSetProduct Function

NModuleSetProduct Function
NModule.h

Sets product name.

C++
NResult N_API NModuleSetProduct(HNModule hModule, const NChar * szValue);
Collapse Expand Parameters
Parameters | Description
HNModule hModule | [in] Handle to the NModule.
const NChar * szValue | [in] Zero-terminated string containing product name.s
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NModule.h

Module: NModule Unit


NModuleSetProductN Function

NModuleSetProductN Function
NModule.h

Sets the product of the specified module.

C++
NResult N_API NModuleSetProductN(HNModule hModule, HNString hValue);
Collapse Expand Parameters
Parameters | Description
HNModule hModule | [in] Handle to the NModule.
HNString hValue | [in] Handle to the new product string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NModule.h

Module: NModule Unit


NModuleSetTitle Function

NModuleSetTitle Function
NModule.h

Sets NModule title.

C++
NResult N_API NModuleSetTitle(HNModule hModule, const NChar * szValue);
Collapse Expand Parameters
Parameters | Description
HNModule hModule | [in] Handle to the NModule.
const NChar * szValue | [in] NModule title string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NModule.h

Module: NModule Unit


NModuleSetTitleN Function

NModuleSetTitleN Function
NModule.h

Sets the title for the specified NModule.

C++
NResult N_API NModuleSetTitleN(HNModule hModule, HNString hValue);
Collapse Expand Parameters
Parameters | Description
HNModule hModule | [in] Handle to the NModule.
HNString hValue | [in] Handle to the new title string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NModule.h

Module: NModule Unit


NModuleSetVersionBuild Function

NModuleSetVersionBuild Function
NModule.h

Sets the version build value for the specified module.

C++
NResult N_API NModuleSetVersionBuild(HNModule hModule, NInt value);
Collapse Expand Parameters
Parameters | Description
HNModule hModule | [in] Handle to the NModule.
NInt value | [in] New version build value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NModule.h

Module: NModule Unit


NModuleSetVersionMajor Function

NModuleSetVersionMajor Function
NModule.h

Sets the version major value for the specified module.

C++
NResult N_API NModuleSetVersionMajor(HNModule hModule, NInt value);
Collapse Expand Parameters
Parameters | Description
HNModule hModule | [in] Handle to the NModule.
NInt value | [in] New version major value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NModule.h

Module: NModule Unit


NModuleSetVersionMinor Function

NModuleSetVersionMinor Function
NModule.h

Sets the version minor value for the specified module.

C++
NResult N_API NModuleSetVersionMinor(HNModule hModule, NInt value);
Collapse Expand Parameters
Parameters | Description
HNModule hModule | [in] Handle to the NModule.
NInt value | [in] New version minor value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NModule.h

Module: NModule Unit


NModuleSetVersionRevision Function

NModuleSetVersionRevision Function
NModule.h

Sets the version revision value for the specified module.

C++
NResult N_API NModuleSetVersionRevision(HNModule hModule, NInt value);
Collapse Expand Parameters
Parameters | Description
HNModule hModule | [in] Handle to the NModule.
NInt value | [in] New version revision value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NModule.h

Module: NModule Unit


NModuleOptions Enumeration

NModuleOptions Enumeration
NModule.h

Enumeration of possible module flags giving additional information about the module.

C++
typedef enum NModuleOptions_ {
  nmoNone = 0,
  nmoDebug = 0x01,
  nmoProtected = 0x02,
  nmoUnicode = 0x04,
  nmoNoAnsiFunc = 0x08,
  nmoNoUnicode = 0x10,
  nmoLib = 0x20,
  nmoExe = 0x40
} NModuleOptions;
Collapse Expand Members
Members | Description
nmoNone = 0 | Module has no flags set.
nmoDebug = 0x01 | Module includes debug information.
nmoProtected = 0x02 | Module is protected and requires activation.
nmoUnicode = 0x04 | Module functions support Unicode strings.
nmoNoAnsiFunc = 0x08 | Module doesn't provide functions for ANSI encoded strings.
nmoNoUnicode = 0x10 | Module doesn't provide functions for Unicode encoded strings.
nmoLib = 0x20 | Module is compiled as a library.
nmoExe = 0x40 | Module is compiled into the executable.
Container

File: NModule.h

Module: NModule Unit


NModuleCreateInstance Macro

NModuleCreateInstance Macro
NModule.h

Picks a Unicode (W) or ASCII (A) version of the NModuleCreateInstance function.

C++
#define NModuleCreateInstance N_FUNC_AW(NModuleCreateInstance)
Container

File: NModule.h

Module: NModule Unit


NModuleGetTypeWithName Macro

NModuleGetTypeWithName Macro
NModule.h

Picks a Unicode (W) or ASCII (A) version of the NModuleGetTypeWithName function.

C++
#define NModuleGetTypeWithName N_FUNC_AW(NModuleGetTypeWithName)
Container

File: NModule.h

Module: NModule Unit


NModuleLoadFromFile Macro

NModuleLoadFromFile Macro
NModule.h

Picks a Unicode (W) or ASCII (A) version of the NModuleLoadFromFile function.

C++
#define NModuleLoadFromFile N_FUNC_AW(NModuleLoadFromFile)
Container

File: NModule.h

Module: NModule Unit


NModuleSetId Macro

NModuleSetId Macro
NModule.h

Picks a Unicode (W) or ASCII (A) version of the NModuleSetId function.

C++
#define NModuleSetId N_FUNC_AW(NModuleSetId)
Container

File: NModule.h

Module: NModule Unit


NModuleSetName Macro

NModuleSetName Macro
NModule.h

Picks a Unicode (W) or ASCII (A) version of the NModuleSetName function.

C++
#define NModuleSetName N_FUNC_AW(NModuleSetName)
Container

File: NModule.h

Module: NModule Unit


NModuleSetNativeId Macro

NModuleSetNativeId Macro
NModule.h

Picks a Unicode (W) or ASCII (A) version of the NModuleSetNativeId function.

C++
#define NModuleSetNativeId N_FUNC_AW(NModuleSetNativeId)
Container

File: NModule.h

Module: NModule Unit


N_DECLARE_MODULE Macro

N_DECLARE_MODULE Macro
NModule.h

Declares the module.

C++
#define N_DECLARE_MODULE(name) \
    NResult N_API name##ModuleOf(HNModule * phValue);
Container

File: NModule.h

Module: NModule Unit


N_MODULE_OF Macro

N_MODULE_OF Macro
NModule.h

Used to obtain a pointer to the function that retrieves NModule object for the specified module name.

C++
#define N_MODULE_OF(name) N_JOIN_SYMBOLS(name, ModuleOf)
Container

File: NModule.h

Module: NModule Unit


NModule.h

NModule.h
Enumerations Functions Legend Macros

Header file for the NModule unit.

Collapse Expand Enumerations
Name | Description
NModuleOptions_ | Enumeration of possible module flags giving additional information about the module.
NModuleOptions | Enumeration of possible module flags giving additional information about the module.
Collapse Expand Functions
Name | Description
NModuleCheckInit | Checks whether the module is initialized and throws and exception if it is not.
NModuleCreate | Creates a new NModule.
NModuleCreateInstance | Creates a new instance of the specified module.
NModuleGetActivatedN | Get the activation status of a protected module.
NModuleGetCompanyN | Get the company name providing the component.
NModuleGetCopyrightN | Get the copyright string for the module.
NModuleGetDefinedType | Retrieves the defined type specified by index from the specified module.
NModuleGetDefinedTypeCount | Retrieves the number of defined types in the specified module.
NModuleGetDefinedTypes | Retrieves all defined types from the specified module.
NModuleGetDependences | Retrieves the module's dependencies.
NModuleGetFileName | Retrieves the name of the file the specified module was created from.
NModuleGetId | Retrieves the ID of the module.
NModuleGetLoadedModules | Get a list of loaded modules.
NModuleGetNameN | Get the short name of the given module.
NModuleGetNativeId | Retrieves the native ID of the specified module.
NModuleGetOptions | Get the set of component's flags.
NModuleGetProductN | Get the product name of the given module.
NModuleGetTitleN | Get the title string (long name with version) for the given module.
NModuleGetTypeWithName | Get the type with the specified name for the given module.
NModuleGetVersionBuild | Get the build number part of the version (Major.Minor.Revision.Build).
NModuleGetVersionMajor | Get the major number part of the version (Major.Minor.Revision.Build).
NModuleGetVersionMinor | Get the minor number part of the version (Major.Minor.Revision.Build).
NModuleGetVersionRevision | Get the revision number part of the version (Major.Minor.Revision.Build).
NModuleLoadFromFile | Loads a module from the specified file.
NModuleSetCompany | Sets company.
NModuleSetCompanyN | Sets the company for the specified NModule.
NModuleSetCopyright | Sets copyright string.
NModuleSetCopyrightN | Sets the copyright for the specified NModule.
NModuleSetId | Sets the ID of the specified module.
NModuleSetNameN | Sets the name for the specified NModule.
NModuleSetNativeId | Sets the native ID of the specified module.
NModuleSetOptions | Sets the options for the specified module.
NModuleSetProduct | Sets product name.
NModuleSetProductN | Sets the product of the specified module.
NModuleSetTitle | Sets NModule title.
NModuleSetTitleN | Sets the title for the specified NModule.
NModuleSetVersionBuild | Sets the version build value for the specified module.
NModuleSetVersionMajor | Sets the version major value for the specified module.
NModuleSetVersionMinor | Sets the version minor value for the specified module.
NModuleSetVersionRevision | Sets the version revision value for the specified module.
Collapse Expand Macros
Name | Description
NModuleCreateInstance | Picks a Unicode (W) or ASCII (A) version of the NModuleCreateInstance function.
NModuleGetTypeWithName | Picks a Unicode (W) or ASCII (A) version of the NModuleGetTypeWithName function.
NModuleLoadFromFile | Picks a Unicode (W) or ASCII (A) version of the NModuleLoadFromFile function.
NModuleSetId | Picks a Unicode (W) or ASCII (A) version of the NModuleSetId function.
NModuleSetName | Picks a Unicode (W) or ASCII (A) version of the NModuleSetName function.
NModuleSetNativeId | Picks a Unicode (W) or ASCII (A) version of the NModuleSetNativeId function.
N_DECLARE_MODULE | Declares the module.
N_MODULE_OF | Used to obtain a pointer to the function that retrieves NModule object for the specified module name.


NModuleInternal Unit

NModuleInternal Unit
Functions Legend

Each separate piece of code/functionality is a module. The functions in this unit allow to set the information about the module it's name, version, etc..

Collapse Expand Functions
Name | Description
NModuleRegister | Register a created NModule.
NModuleSetActivatedProc | Sets the activated procedure for the specified module.
NModuleSetDependences | Sets the dependencies for the specified module.
NModuleSetInit | Sets the initialization procedure for the specified module.
NModuleSetLazyInit | Sets the lazy initialization procedure for the specified module.
NModuleSetThreadInit | Sets the thread initialization procedure for the specified module.
NModuleSetThreadUninit | Sets the thread uninitialization procedure for the specified module.
NModuleSetUninit | Sets the uninitialization procedure for the specified module.
NModuleUnregister | Unregisters a module.


NModuleRegister Function

NModuleRegister Function

Register a created NModule.

C++
NResult N_API NModuleRegister(NModuleCreateProc pCreate, HNModule * phModule);
Collapse Expand Parameters
Parameters | Description
NModuleCreateProc pCreate | [in] Pointer to a NModule creating function.
HNModule * phModule | [out] Pointer to a handle to the registered NModuel.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NModuleInternal.h

Module: NModuleInternal Unit


NModuleSetActivatedProc Function

NModuleSetActivatedProc Function

Sets the activated procedure for the specified module.

C++
NResult N_API NModuleSetActivatedProc(HNModule hModule, NModuleGetActivatedProc pValue);
Collapse Expand Parameters
Parameters | Description
HNModule hModule | [in] Handle to the NModule.
NModuleGetActivatedProc pValue | [in] Pointer to the activated procedure.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NModuleInternal.h

Module: NModuleInternal Unit


NModuleSetDependences Function

NModuleSetDependences Function

Sets the dependencies for the specified module.

C++
NResult N_API NModuleSetDependences(HNModule hModule, NModuleOfProc * arpValues, NInt count);
Collapse Expand Parameters
Parameters | Description
HNModule hModule | [in] Handle to the NModule.
NModuleOfProc * arpValues | [out] A pointer to an array of dependencies.
NInt count | [in] Length of the array of dependencies.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NModuleInternal.h

Module: NModuleInternal Unit


NModuleSetInit Function

NModuleSetInit Function

Sets the initialization procedure for the specified module.

C++
NResult N_API NModuleSetInit(HNModule hModule, NModuleInitProc pValue);
Collapse Expand Parameters
Parameters | Description
HNModule hModule | [in] Handle to the NModule.
NModuleInitProc pValue | [in] Pointer to the initialization procedure.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NModuleInternal.h

Module: NModuleInternal Unit


NModuleSetLazyInit Function

NModuleSetLazyInit Function

Sets the lazy initialization procedure for the specified module.

C++
NResult N_API NModuleSetLazyInit(HNModule hModule, NModuleLazyInitProc pValue);
Collapse Expand Parameters
Parameters | Description
HNModule hModule | [in] Handle to the NModule.
NModuleLazyInitProc pValue | [in] Pointer to the lazy initialization procedure.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NModuleInternal.h

Module: NModuleInternal Unit


NModuleSetThreadInit Function

NModuleSetThreadInit Function

Sets the thread initialization procedure for the specified module.

C++
NResult N_API NModuleSetThreadInit(HNModule hModule, NModuleThreadInitProc pValue);
Collapse Expand Parameters
Parameters | Description
HNModule hModule | [in] Handle to the NModule.
NModuleThreadInitProc pValue | [in] Pointer to the thread initialization procedure.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NModuleInternal.h

Module: NModuleInternal Unit


NModuleSetThreadUninit Function

NModuleSetThreadUninit Function

Sets the thread uninitialization procedure for the specified module.

C++
NResult N_API NModuleSetThreadUninit(HNModule hModule, NModuleThreadUninitProc pValue);
Collapse Expand Parameters
Parameters | Description
HNModule hModule | [in] Handle to the NModule.
NModuleThreadUninitProc pValue | [in] Pointer to the thread uninitialization procedure.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NModuleInternal.h

Module: NModuleInternal Unit


NModuleSetUninit Function

NModuleSetUninit Function

Sets the uninitialization procedure for the specified module.

C++
NResult N_API NModuleSetUninit(HNModule hModule, NModuleUninitProc pValue);
Collapse Expand Parameters
Parameters | Description
HNModule hModule | [in] Handle to the NModule.
NModuleUninitProc pValue | [in] Pointer to the uninitialization procedure.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NModuleInternal.h

Module: NModuleInternal Unit


NModuleUnregister Function

NModuleUnregister Function

Unregisters a module.

C++
NResult N_API NModuleUnregister(HNModule * phModule);
Collapse Expand Parameters
Parameters | Description
HNModule * phModule | [out] Pointer to a handle to the unregistered NModule.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NModuleInternal.h

Module: NModuleInternal Unit


NMonitor Unit

NMonitor Unit
Functions Legend Macros See Also

Lightweight, cross platform primitives for critical section.

Collapse Expand See Also

NMutex for alternative implementation.

Collapse Expand Functions
Name | Description
NMonitorDispose | Releases all resources used by a monitor.
NMonitorEnter | Waits for ownership of the specified monitor. The function returns when the calling thread is granted ownership (after thread currently owning the monitor calls NMonitorExit).
NMonitorExit | Releases ownership of the specified monitor.
NMonitorInit | Initializes a monitor.
NMonitorTryEnter | Gets ownership of the specified monitor without waiting if possible.
Collapse Expand Macros
Name | Description
N_MONITOR_SIZE | Defines the monitor size.


NMonitorDispose Function

NMonitorDispose Function

Releases all resources used by a monitor.

C++
void N_API NMonitorDispose(NMonitor * pMonitor);
Collapse Expand Parameters
Parameters | Description
NMonitor * pMonitor | [in] Pointer to the monitor.
Collapse Expand Remarks

The given monitor should have been initialized and must be not owned by any thread.

Container

File: NMonitor.h

Module: NMonitor Unit


NMonitorEnter Function

NMonitorEnter Function

Waits for ownership of the specified monitor. The function returns when the calling thread is granted ownership (after thread currently owning the monitor calls NMonitorExit).

C++
void N_API NMonitorEnter(NMonitor * pMonitor);
Collapse Expand Parameters
Parameters | Description
NMonitor * pMonitor | [in] Pointer to the monitor.
Collapse Expand Notes
  • The monitor primitive is recursive, i.e. the owning thread can call NMonitorEnter multiple times. It is however required that NMonitorExit is called for each successful NMonitorEnter/NMonitorTryEnter.
Container

File: NMonitor.h

Module: NMonitor Unit


NMonitorExit Function

NMonitorExit Function

Releases ownership of the specified monitor.

C++
void N_API NMonitorExit(NMonitor * pMonitor);
Collapse Expand Parameters
Parameters | Description
NMonitor * pMonitor | [in] Pointer to the monitor.
Collapse Expand Notes
  • The monitor primitive is recursive, i.e. the owning thread must call NMonitorExit for each successfull NMonitorEnter/NMonitorTryEnter call.
  • It is an error to call NMonitorExit on not owned monitor, and will result in undefined behaviour. Consider using NMutex if checking against such misuses is needed.
Container

File: NMonitor.h

Module: NMonitor Unit


NMonitorInit Function

NMonitorInit Function

Initializes a monitor.

C++
void N_API NMonitorInit(NMonitor * pMonitor);
Collapse Expand Parameters
Parameters | Description
NMonitor * pMonitor | [in,out] Pointer to the monitor that will be initialized.
Container

File: NMonitor.h

Module: NMonitor Unit


NMonitorTryEnter Function

NMonitorTryEnter Function

Gets ownership of the specified monitor without waiting if possible.

C++
NBool N_API NMonitorTryEnter(NMonitor * pMonitor);
Collapse Expand Parameters
Parameters | Description
NMonitor * pMonitor | [in] Pointer to the monitor.
Collapse Expand Returns

NFalse is returned if another thread currently owns the monitor. The non zero value is returned when the ownership was successfully acquired.

Collapse Expand Notes
  • The monitor primitive is recursive, i.e. the owning thread can successfully call NMonitorTryEnter multiple times. It is however required that NMonitorExit is called for each successful NMonitorEnter/NMonitorTryEnter.
Container

File: NMonitor.h

Module: NMonitor Unit


N_MONITOR_SIZE Macro

N_MONITOR_SIZE Macro

Defines the monitor size.

C++
#define N_MONITOR_SIZE 24
Container

File: NMonitor.h

Module: NMonitor Unit


NMutex Unit

NMutex Unit
Functions Legend See Also

Cross platform implementation of critical sections.

Collapse Expand See Also
  • NWaitObject for NMutex functionality shared with other synchronization objects.
  • NMonitor for alternative, more lightweight implementation.
Collapse Expand Functions
Name | Description
NMutexCreate | Creates and initializes a mutex object.
NMutexCreateFromOSHandle | Creates and initializes a mutex object with an OS handle.
NMutexGetOSHandle | Gets an OS handle to the specified mutex.
NMutexRelease | Releases ownership of the specified mutex.


NMutexCreate Function

NMutexCreate Function

Creates and initializes a mutex object.

C++
NResult N_API NMutexCreate(NBool initiallyOwned, HNMutex * phMutex);
Collapse Expand Parameters
Parameters | Description
NBool initiallyOwned | [in] Should the mutex be initially owned by creating thread.
HNMutex * phMutex | [out] Pointer to the variable that will receive the handle of the created object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

This is usual recursive mutex. It is owned by at most single thread at any point of time. The mutex can be acquired by NWaitObjectWaitFor/NWaitObjectTimedWaitFor and released by NMutexRelease functions.

Container

File: NMutex.h

Module: NMutex Unit


NMutexCreateFromOSHandle Function

NMutexCreateFromOSHandle Function

Creates and initializes a mutex object with an OS handle.

C++
NResult N_API NMutexCreateFromOSHandle(NHandle handle, NBool ownsHandle, HNMutex * phMutex);
Collapse Expand Parameters
Parameters | Description
NHandle handle | [in] A file handle for the file that the current NMutex will encapsulate.
NBool ownsHandle | [in] NTrue if the file handle will be owned by this NMutex; otherwise, NFalse.
HNMutex * phMutex | [out] Pointer to the variable that will receive the handle of the created object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMutex.h

Module: NMutex Unit


NMutexGetOSHandle Function

NMutexGetOSHandle Function

Gets an OS handle to the specified mutex.

C++
NResult N_API NMutexGetOSHandle(HNMutex hMutex, NHandle * phValue);
Collapse Expand Parameters
Parameters | Description
HNMutex hMutex | [in] Handle to NMutex object.
NHandle * phValue | [out] Pointer to the OS handle.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMutex.h

Module: NMutex Unit


NMutexRelease Function

NMutexRelease Function

Releases ownership of the specified mutex.

C++
NResult N_API NMutexRelease(HNMutex hMutex);
Collapse Expand Parameters
Parameters | Description
HNMutex hMutex | [in] Handle of the mutex.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Notes
  • The NMutex is derived from NWaitObject. The NWaitObjectWaitFor or NWaitObjectTimedWaitFor should be used with the mutex handle to obtain ownership of the mutex.
  • The NMutex is recursive, i.e. the owning thread must call NMutexRelease for each successfull NWaitObjectTimedWaitFor or NWaitObjectWaitFor call.
  • It is an error to call NMutexRelease on not owned mutex, the misuse will be checked and reported to the caller.
Container

File: NMutex.h

Module: NMutex Unit


NNoDeprecate Unit

NNoDeprecate Unit


NObject Unit

NObject Unit
Files Functions Legend Macros

Provides functionality for retrieving information about specified object.

Collapse Expand Files
Name | Description
NObject.h | Header file for NObject module. Provides functionality for retrieving information about specified object.
Collapse Expand Functions
Name | Description
NObjectAddDisposed | Adds a "Disposed" callback to NObject.
NObjectAddDisposedCallback | Adds a "Disposed" callback to NObject.
NObjectAddHandlerP | Picks a Unicode (W) or ASCII (A) version of the NObjectAddHandlerP function.
NObjectAddOwnerChanged | Adds an "Owner changed" callback to NObject.
NObjectAddOwnerChangedCallback | Adds an "Owner changed" callback to NObject.
NObjectAddPropertyChanged | Adds a "Property changed" callback to NObject.
NObjectAddPropertyChangedCallback | Adds a "Property changed" callback to NObject.
NObjectCaptureProperties | Adds the properties of the specified object to the specified property bag.
NObjectClone | Creates a copy of specified object.
NObjectCompareTo | Compares the specified object with another specified object and returns an indication of their relative values.
NObjectCopyProperties | Copies property values from one object to another.
NObjectEquals | Compares the objects.
NObjectGet | Retrieves the value of NObject.
NObjectGetArray | Retrieves an array of values of an array of objects.
NObjectGetConcurrent | Retrieves the value of NObject. This function is thread-safe.
NObjectGetElements | Retrieves all elements of the specified object array.
NObjectGetFlags | Gets any flags of specified object.
NObjectGetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
NObjectGetOwnerEx | Gets owner of specified object.
NObjectGetPropertyN | Retrieves the value of the specified property of the specified object.
NObjectGetPropertyNN | Retrieves the value of the specified property of the specified object.
NObjectGetPropertyP | Retrieves the value of the specified property of the specified object.
NObjectGetSize | Retrieves the size of specified object.
NObjectGetSizeMany | Retrieves the size of the array of objects.
NObjectGetType | Retrieves type of specified object.
NObjectInvoke | Invokes the specified method or constructor, using the specified parameters.
NObjectInvokeWithPropertyBag | Invokes the specified method or constructor, using the specified parameters.
NObjectInvokeWithString | Invokes the specified method or constructor, using the specified parameters.
NObjectRef | ... more
NObjectRemoveDisposed | Removes the "Disposed" callback from NObject.
NObjectRemoveDisposedCallback | Removes the "Disposed" callback from NObject.
NObjectRemoveHandlerP | Picks a Unicode (W) or ASCII (A) version of the NObjectRemoveHandlerP function.
NObjectRemoveOwnerChanged | Removes the "Owner changed" callback from NObject.
NObjectRemoveOwnerChangedCallback | Removes the "Owner changed" callback from NObject.
NObjectRemovePropertyChanged | Removes the "Property changed" callback from NObject.
NObjectRemovePropertyChangedCallback | Removes the "Property changed" callback from NObject.
NObjectReset | Sets default values for all parameters of the specified object.
NObjectResetProperty | Sets default values for the specified property of the specified object.
NObjectSaveManyToMemoryDst | Saves an array of objects to a memory location with a specified size.
NObjectSaveManyToMemoryDstN | Saves an array of objects to a specified memory location.
NObjectSaveManyToMemoryN | Saves an array of objects to a memory location.
NObjectSaveManyToStream | Saves a NObject array in a stream.
NObjectSaveToMemoryDst | Saves an objects to a memory location with specified size.
NObjectSaveToMemoryDstN | Save an object to a specified memory location.
NObjectSaveToMemoryN | Saves an object to a memory location.
NObjectSaveToStream | Saves NObject to a stream.
NObjectSet | Set the value of NObject.
NObjectSetConcurrent | Set the value of NObject. This function is tread-safe.
NObjectSetFlags | Sets the flags for the specified object.
NObjectSetPropertyN | Sets the specified property of the specified object to the specified value.
NObjectSetPropertyNN | Sets the specified property of the specified object to the specified value.
NObjectSetPropertyP | Sets the specified property of the specified object to the specified value.
NObjectToString | Returns string representation of the object.
NObjectUnref | ... more
NObjectUnrefArray | ... more
NObjectUnrefElements | ... more
Collapse Expand Macros
Name | Description
NObjectGetPropertyP | Picks a Unicode (W) or ASCII (A) version of the NObjectGetPropertyP function.
NObjectInvoke | Picks a Unicode (W) or ASCII (A) version of the NObjectInvoke function.
NObjectInvokeWithPropertyBag | Picks a Unicode (W) or ASCII (A) version of the NObjectInvokeWithPropertyBag function.
NObjectInvokeWithString | Picks a Unicode (W) or ASCII (A) version of the NObjectInvokeWithString function.
NObjectResetProperty | Picks a Unicode (W) or ASCII (A) version of the NObjectResetProperty function.
NObjectSetPropertyP | Picks a Unicode (W) or ASCII (A) version of the NObjectSetPropertyP function.
NObjectToString | Picks a Unicode (W) or ASCII (A) version of the NObjectToString function.
N_OBJECT_REF_RET | ... more


NObjectAddDisposed Function

NObjectAddDisposed Function
NObject.h

Adds a "Disposed" callback to NObject.

C++
NResult N_API NObjectAddDisposed(HNObject hObject, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] A handle to NObject.
HNCallback hCallback | [in] The callback to be added.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObject.h

Module: NObject Unit


NObjectAddDisposedCallback Function

NObjectAddDisposedCallback Function
NObject.h

Adds a "Disposed" callback to NObject.

C++
NResult N_API NObjectAddDisposedCallback(HNObject hObject, NObjectCallback pCallback, void * pParam);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] A handle to NObject.
NObjectCallback pCallback | [in] The callback to be added.
void * pParam | [in/out] A pointer to data provided for the callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObject.h

Module: NObject Unit


NObjectAddHandlerP Function

NObjectAddHandlerP Function
NObject.h

Picks a Unicode (W) or ASCII (A) version of the NObjectAddHandlerP function.

C++
NResult N_API NObjectAddHandlerP(HNObject hObject, const NChar * szName, NTypeOfProc pCallbackTypeOf, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] A handle to NObject.
const NChar * szName | [in] Handler name.
NTypeOfProc pCallbackTypeOf | [in] One of NTypeOfProc values.
HNCallback hCallback | [in] Handle of the callback to add.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObject.h

Module: NObject Unit


NObjectAddOwnerChanged Function

NObjectAddOwnerChanged Function
NObject.h

Adds an "Owner changed" callback to NObject.

C++
NResult N_API NObjectAddOwnerChanged(HNObject hObject, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] A handle to NObject.
HNCallback hCallback | [in] The callback to be added.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObject.h

Module: NObject Unit


NObjectAddOwnerChangedCallback Function

NObjectAddOwnerChangedCallback Function
NObject.h

Adds an "Owner changed" callback to NObject.

C++
NResult N_API NObjectAddOwnerChangedCallback(HNObject hObject, NObjectCallback pCallback, void * pParam);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] A handle to NObject.
NObjectCallback pCallback | [in] The callback to be added.
void * pParam | [in/out] A pointer to data provided for the callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObject.h

Module: NObject Unit


NObjectAddPropertyChanged Function

NObjectAddPropertyChanged Function
NObject.h

Adds a "Property changed" callback to NObject.

C++
NResult N_API NObjectAddPropertyChanged(HNObject hObject, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] A handle to NObject.
HNCallback hCallback | [in] The callback to be added.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObject.h

Module: NObject Unit


NObjectAddPropertyChangedCallback Function

NObjectAddPropertyChangedCallback Function
NObject.h

Adds a "Property changed" callback to NObject.

C++
NResult N_API NObjectAddPropertyChangedCallback(HNObject hObject, NObjectPropertyChangedCallback pCallback, void * pParam);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] A handle to NObject.
NObjectPropertyChangedCallback pCallback | [in] The callback to be added.
void * pParam | [in/out] A pointer to data provided for the callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObject.h

Module: NObject Unit


NObjectCaptureProperties Function

NObjectCaptureProperties Function
NObject.h

Adds the properties of the specified object to the specified property bag.

C++
NResult N_API NObjectCaptureProperties(HNObject hObject, HNPropertyBag hProperties);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] Handle to the object.
HNPropertyBag hProperties | [in/out] Handle to the property bag.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObject.h

Module: NObject Unit


NObjectClone Function

NObjectClone Function
NObject.h

Creates a copy of specified object.

C++
NResult N_API NObjectClone(HNObject hObject, HNObject * phClonedObject);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] Handle to object to clone.
HNObject * phClonedObject | [out] Pointer to cloned object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

Cloned object always should be disposed by calling NObjectUnref function.

Container

File: NObject.h

Module: NObject Unit


NObjectCompareTo Function

NObjectCompareTo Function
NObject.h

Compares the specified object with another specified object and returns an indication of their relative values.

C++
NResult N_API NObjectCompareTo(HNObject hObject, HNObject hOtherObject, NInt * pResult);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] Handle to the first object.
HNObject hOtherObject | [in] Handle to the second object.
NInt * pResult | [out] Pointer to value indicating the relative values of the objects.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObject.h

Module: NObject Unit


NObjectCopyProperties Function

NObjectCopyProperties Function
NObject.h

Copies property values from one object to another.

C++
NResult N_API NObjectCopyProperties(HNObject hDstObject, HNObject hSrcObject);
Collapse Expand Parameters
Parameters | Description
HNObject hDstObject | [in] Destination object. Source object will be copied to this object.
HNObject hSrcObject | [in] Source object to copy.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise, one of the following error codes is returned.

Container

File: NObject.h

Module: NObject Unit


NObjectEquals Function

NObjectEquals Function
NObject.h

Compares the objects.

C++
NResult N_API NObjectEquals(HNObject hObject, HNObject hOtherObject, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] Handle to first object to be compared.
HNObject hOtherObject | [in] Handle to second object to be compared.
NBool * pResult | [out] pointer to NBool variable where result of comparison will be saved.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObject.h

Module: NObject Unit


NObjectGet Function

NObjectGet Function
NObject.h

Retrieves the value of NObject.

C++
NResult N_API NObjectGet(HNObject hObject, HNObject * phValue);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] A handle to NObject.
HNObject * phValue | [out] A pointer to the value of NObject.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObject.h

Module: NObject Unit


NObjectGetArray Function

NObjectGetArray Function
NObject.h

Retrieves an array of values of an array of objects.

C++
NResult N_API NObjectGetArray(const HNObject * arhObjects, NInt objectCount, HNObject * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
const HNObject * arhObjects | [in] A pointer to an array of NObject handles.
NInt objectCount | [in] NObject array count.
HNObject * * parhValues | [out] A pointer to a pointer to an array of values of NObject array.
NInt * pValueCount | [out] parhValues values count.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObject.h

Module: NObject Unit


NObjectGetConcurrent Function

NObjectGetConcurrent Function
NObject.h

Retrieves the value of NObject. This function is thread-safe.

C++
NResult N_API NObjectGetConcurrent(volatile HNObject * phVariable, HNObject * phValue);
Collapse Expand Parameters
Parameters | Description
volatile HNObject * phVariable | [in] A handle to NObject.
HNObject * phValue | [out] A pointer to the value of NObject.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObject.h

Module: NObject Unit


NObjectGetElements Function

NObjectGetElements Function
NObject.h

Retrieves all elements of the specified object array.

C++
NResult N_API NObjectGetElements(const HNObject * arhObjects, NInt objectCount, HNObject * arhValues, NInt valuesLength);
Collapse Expand Parameters
Parameters | Description
const HNObject * arhObjects | [in] Pointer to an array of objects.
NInt objectCount | [in] Number of objects in the array.
HNObject * arhValues | [out] Pointer to an array of object elements.
NInt valuesLength | [in] Number of elements in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObject.h

Module: NObject Unit


NObjectGetFlags Function

NObjectGetFlags Function
NObject.h

Gets any flags of specified object.

C++
NResult N_API NObjectGetFlags(HNObject hObject, NUInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] Handle to object to retrieve its flags.
NUInt * pValue | [out] Pointer to memory block which contains flags from specified object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObject.h

Module: NObject Unit


NObjectGetHashCode Function

NObjectGetHashCode Function
NObject.h

Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.

C++
NResult N_API NObjectGetHashCode(HNObject hObject, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] Handle to object to retrieve the value.
NInt * pValue | [out] Pointer to variable where value will be stored.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObject.h

Module: NObject Unit


NObjectGetOwnerEx Function

NObjectGetOwnerEx Function
NObject.h

Gets owner of specified object.

C++
NResult N_API NObjectGetOwnerEx(HNObject hObject, HNObject * phValue);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] Handle to object to retrieve it's owner.
HNObject * phValue | [out] Pointer to owner object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObject.h

Module: NObject Unit


NObjectGetPropertyN Function

NObjectGetPropertyN Function
NObject.h

Retrieves the value of the specified property of the specified object.

C++
NResult N_API NObjectGetPropertyN(HNObject hObject, HNString hName, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] Handle to the object.
HNString hName | [in] Handle to the name of the property.
HNValue * phValue | [in] Pointer to a handle to the new value of the property.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObject.h

Module: NObject Unit


NObjectGetPropertyNN Function

NObjectGetPropertyNN Function
NObject.h

Retrieves the value of the specified property of the specified object.

C++
NResult N_API NObjectGetPropertyNN(HNObject hObject, HNString hName, HNType hValueType, NAttributes attributes, void * arValues, NSizeType valuesSize, NInt valuesLength, NBool * pHasValue);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] Handle to the object.
HNString hName | [in] Handle to the name of the property.
HNType hValueType | [in] Handle to the type of the value.
NAttributes attributes | [in] Property attributes.
void * arValues | [out] Pointer to an array of values.
NSizeType valuesSize | [in] Size of the value.
NInt valuesLength | [in] Length of the value array.
NBool * pHasValue | [out] NTrue if the array contains a value; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObject.h

Module: NObject Unit


NObjectGetPropertyP Function

NObjectGetPropertyP Function
NObject.h

Retrieves the value of the specified property of the specified object.

C++
NResult N_API NObjectGetPropertyP(HNObject hObject, const NChar * szName, NTypeOfProc pValueTypeOf, NAttributes attributes, void * arValues, NSizeType valuesSize, NInt valuesLength, NBool * pHasValue);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] Handle to the object.
const NChar * szName | [in] Pointer to the name of the property.
NTypeOfProc pValueTypeOf | [in] Pointer to the process that retrieves the type of the value.
NAttributes attributes | [in] Property attributes.
void * arValues | [out] Pointer to an array of values.
NSizeType valuesSize | [in] Size of the value.
NInt valuesLength | [in] Length of the value array.
NBool * pHasValue | [out] NTrue if the array contains a value; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObject.h

Module: NObject Unit


NObjectGetSize Function

NObjectGetSize Function
NObject.h

Retrieves the size of specified object.

C++
NResult N_API NObjectGetSize(HNObject hObject, NUInt flags, NSizeType * pValue);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] A handle to NObject.
NUInt flags | [in] Flags specific to NObject.
NSizeType * pValue | [out] A pointer to the size value of the NObject.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObject.h

Module: NObject Unit


NObjectGetSizeMany Function

NObjectGetSizeMany Function
NObject.h

Retrieves the size of the array of objects.

C++
NResult N_API NObjectGetSizeMany(const HNObject * arhObjects, NInt objectCount, NUInt flags, NSizeType * pValue);
Collapse Expand Parameters
Parameters | Description
const HNObject * arhObjects | [in] A pointer to an array of NObject handles.
NInt objectCount | [in] NObject array count.
NUInt flags | [in] Flags specific to NObject array.
NSizeType * pValue | [out] A pointer to the size of value of NObject array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObject.h

Module: NObject Unit


NObjectGetType Function

NObjectGetType Function
NObject.h

Retrieves type of specified object.

C++
NResult N_API NObjectGetType(HNObject hObject, HNType * phValue);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] Handle to object to retrieve it's type.
HNType * phValue | [out] Object's type value.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise, one of the following error codes is returned.

Collapse Expand Remarks

NObjectUnref shall be called on returned objects when they are no longer used to prevent memory leaks.

Container

File: NObject.h

Module: NObject Unit


NObjectInvoke Function

NObjectInvoke Function
NObject.h

Invokes the specified method or constructor, using the specified parameters.

C++
NResult N_API NObjectInvoke(HNObject hObject, const NChar * szName, HNValue * arhParameters, NInt parameterCount, HNValue * phResult);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] Handle to the object on which to invoke the method or constructor.
const NChar * szName | [in] Pointer to the name of method or constructor.
HNValue * arhParameters | [in/out] Pointer to an array of values with the same number, order, and type as the parameters of the method or constructor to be invoked.
NInt parameterCount | [in] Number of parameters in the array.
HNValue * phResult | [out] Pointer to the value returned by the invoked method, or null in case of constructor.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObject.h

Module: NObject Unit


NObjectInvokeWithPropertyBag Function

NObjectInvokeWithPropertyBag Function
NObject.h

Invokes the specified method or constructor, using the specified parameters.

C++
NResult N_API NObjectInvokeWithPropertyBag(HNObject hObject, const NChar * szName, HNPropertyBag hParameters, HNValue * phResult);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] Handle to the object on which to invoke the method or constructor.
const NChar * szName | [in] Pointer to the name of method or constructor.
HNPropertyBag hParameters | [in] Handle to a property bag containing values with the same number, order, and type as the parameters of the method or constructor to be invoked.
HNValue * phResult | [out] Pointer to the value returned by the invoked method, or null in case of constructor.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObject.h

Module: NObject Unit


NObjectInvokeWithString Function

NObjectInvokeWithString Function
NObject.h

Invokes the specified method or constructor, using the specified parameters.

C++
NResult N_API NObjectInvokeWithString(HNObject hObject, const NChar * szName, const NChar * szParameters, HNValue * phResult);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] Handle to the object on which to invoke the method or constructor.
const NChar * szName | [in] Pointer to the name of method or constructor.
const NChar * szParameters | [in] Pointer to a string representing the parameters of the method or constructor to be invoked.
HNValue * phResult | [out] Pointer to the value returned by the invoked method, or null in case of constructor.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObject.h

Module: NObject Unit


NObjectRef Function

NObjectRef Function
NObject.h

Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.

C++
NResult N_API NObjectRef(HNObject hObject);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] Handle to an object to increment its reference count.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

NResult > 0 is new reference count.

Container

File: NObject.h

Module: NObject Unit


NObjectRemoveDisposed Function

NObjectRemoveDisposed Function
NObject.h

Removes the "Disposed" callback from NObject.

C++
NResult N_API NObjectRemoveDisposed(HNObject hObject, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] A handle to NObject.
HNCallback hCallback | [in] The callback to be removed.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObject.h

Module: NObject Unit


NObjectRemoveDisposedCallback Function

NObjectRemoveDisposedCallback Function
NObject.h

Removes the "Disposed" callback from NObject.

C++
NResult N_API NObjectRemoveDisposedCallback(HNObject hObject, NObjectCallback pCallback, void * pParam);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] A handle to NObject.
NObjectCallback pCallback | [in] The callback to be removed.
void * pParam | [in/out] A pointer to data provided for the callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObject.h

Module: NObject Unit


NObjectRemoveHandlerP Function

NObjectRemoveHandlerP Function
NObject.h

Picks a Unicode (W) or ASCII (A) version of the NObjectRemoveHandlerP function.

C++
NResult N_API NObjectRemoveHandlerP(HNObject hObject, const NChar * szName, NTypeOfProc pCallbackTypeOf, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] A handle to NObject.
const NChar * szName | [in] Handler name.
NTypeOfProc pCallbackTypeOf | [in] One of NTypeOfProc values.
HNCallback hCallback | [in] Handle of the callback to remove.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObject.h

Module: NObject Unit


NObjectRemoveOwnerChanged Function

NObjectRemoveOwnerChanged Function
NObject.h

Removes the "Owner changed" callback from NObject.

C++
NResult N_API NObjectRemoveOwnerChanged(HNObject hObject, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] A handle to NObject.
HNCallback hCallback | [in] The callback to be removed.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObject.h

Module: NObject Unit


NObjectRemoveOwnerChangedCallback Function

NObjectRemoveOwnerChangedCallback Function
NObject.h

Removes the "Owner changed" callback from NObject.

C++
NResult N_API NObjectRemoveOwnerChangedCallback(HNObject hObject, NObjectCallback pCallback, void * pParam);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] A handle to NObject.
NObjectCallback pCallback | [in] The callback to be removed.
void * pParam | [in/out] A pointer to data provided for the callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObject.h

Module: NObject Unit


NObjectRemovePropertyChanged Function

NObjectRemovePropertyChanged Function
NObject.h

Removes the "Property changed" callback from NObject.

C++
NResult N_API NObjectRemovePropertyChanged(HNObject hObject, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] A handle to NObject.
HNCallback hCallback | [in] The callback to be removed.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObject.h

Module: NObject Unit


NObjectRemovePropertyChangedCallback Function

NObjectRemovePropertyChangedCallback Function
NObject.h

Removes the "Property changed" callback from NObject.

C++
NResult N_API NObjectRemovePropertyChangedCallback(HNObject hObject, NObjectPropertyChangedCallback pCallback, void * pParam);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] A handle to NObject.
NObjectPropertyChangedCallback pCallback | [in] The callback to be removed.
void * pParam | [in/out] A pointer to data provided for the callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObject.h

Module: NObject Unit


NObjectReset Function

NObjectReset Function
NObject.h

Sets default values for all parameters of the specified object.

C++
NResult N_API NObjectReset(HNObject hObject);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] Handle to object to reset values.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise, one of the following error codes is returned.

Container

File: NObject.h

Module: NObject Unit


NObjectResetProperty Function

NObjectResetProperty Function
NObject.h

Sets default values for the specified property of the specified object.

C++
NResult N_API NObjectResetProperty(HNObject hObject, const NChar * szName);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] Handle to object.
const NChar * szName | [in] Pointer to the name of the property to reset values.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObject.h

Module: NObject Unit


NObjectSaveManyToMemoryDst Function

NObjectSaveManyToMemoryDst Function
NObject.h

Saves an array of objects to a memory location with a specified size.

C++
NResult N_API NObjectSaveManyToMemoryDst(const HNObject * arhObjects, NInt objectCount, void * pBuffer, NSizeType bufferSize, NUInt flags, NSizeType * pSize);
Collapse Expand Parameters
Parameters | Description
const HNObject * arhObjects | [in] A pointer to an array of NObject handles.
NInt objectCount | [in] NObject array count.
void * pBuffer | [in] A pointer to the memory location.
NSizeType bufferSize | [in] The size of the memory location.
NUInt flags | [in] Flags specific to NObject array.
NSizeType * pSize | [out] A pointer to the size value of the saved array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObject.h

Module: NObject Unit


NObjectSaveManyToMemoryDstN Function

NObjectSaveManyToMemoryDstN Function
NObject.h

Saves an array of objects to a specified memory location.

C++
NResult N_API NObjectSaveManyToMemoryDstN(const HNObject * arhObjects, NInt objectCount, HNBuffer hBuffer, NUInt flags, NSizeType * pSize);
Collapse Expand Parameters
Parameters | Description
const HNObject * arhObjects | [in] A pointer to an array of NObject handles.
NInt objectCount | [in] NObject array count.
HNBuffer hBuffer | [in] A handle to the memory location.
NUInt flags | [in] Flags specific to NObject array.
NSizeType * pSize | [out] A pointer to the size value of the saved array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObject.h

Module: NObject Unit


NObjectSaveManyToMemoryN Function

NObjectSaveManyToMemoryN Function
NObject.h

Saves an array of objects to a memory location.

C++
NResult N_API NObjectSaveManyToMemoryN(const HNObject * arhObjects, NInt objectCount, NUInt flags, HNBuffer * phBuffer);
Collapse Expand Parameters
Parameters | Description
const HNObject * arhObjects | [in] A pointer to an array of NObject handles.
NInt objectCount | [in] NObject array count.
NUInt flags | [in] Flags specific to NObject array.
HNBuffer * phBuffer | [out] A pointer to a memory location.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObject.h

Module: NObject Unit


NObjectSaveManyToStream Function

NObjectSaveManyToStream Function
NObject.h

Saves a NObject array in a stream.

C++
NResult N_API NObjectSaveManyToStream(const HNObject * arhObjects, NInt objectCount, HNStream hStream, NUInt flags);
Collapse Expand Parameters
Parameters | Description
const HNObject * arhObjects | [in] A pointer to an array of NObject handles.
NInt objectCount | [in] NObject array count.
HNStream hStream | [in] A handle to the target stream.
NUInt flags | [in] Flags specific to NObject array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObject.h

Module: NObject Unit


NObjectSaveToMemoryDst Function

NObjectSaveToMemoryDst Function
NObject.h

Saves an objects to a memory location with specified size.

C++
NResult N_API NObjectSaveToMemoryDst(HNObject hObject, void * pBuffer, NSizeType bufferSize, NUInt flags, NSizeType * pSize);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] A handle to NObject.
void * pBuffer | [in] A pointer to the memory location.
NSizeType bufferSize | [in] The size of the memory location.
NUInt flags | [in] Flags specific to NObject.
NSizeType * pSize | [out] A pointer to the size value of the saved object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObject.h

Module: NObject Unit


NObjectSaveToMemoryDstN Function

NObjectSaveToMemoryDstN Function
NObject.h

Save an object to a specified memory location.

C++
NResult N_API NObjectSaveToMemoryDstN(HNObject hObject, HNBuffer hBuffer, NUInt flags, NSizeType * pSize);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] A handle to NObject.
HNBuffer hBuffer | [in] A handle to the memory location.
NUInt flags | [in] Flags specific to NObject.
NSizeType * pSize | [out] A pointer to the size value of the saved object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObject.h

Module: NObject Unit


NObjectSaveToMemoryN Function

NObjectSaveToMemoryN Function
NObject.h

Saves an object to a memory location.

C++
NResult N_API NObjectSaveToMemoryN(HNObject hObject, NUInt flags, HNBuffer * phBuffer);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] A handle to NObject.
NUInt flags | [in] Flags specific to NObject.
HNBuffer * phBuffer | [out] A pointer to a memory location.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObject.h

Module: NObject Unit


NObjectSaveToStream Function

NObjectSaveToStream Function
NObject.h

Saves NObject to a stream.

C++
NResult N_API NObjectSaveToStream(HNObject hObject, HNStream hStream, NUInt flags);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] A handle to NObject.
HNStream hStream | [in] A handle to the target stream.
NUInt flags | [in] Flags specific to NObject.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObject.h

Module: NObject Unit


NObjectSet Function

NObjectSet Function
NObject.h

Set the value of NObject.

C++
NResult N_API NObjectSet(HNObject hObject, HNObject * phVariable);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] A handle to NObject.
HNObject * phVariable | [in] A pointer to the value of NObject to set.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObject.h

Module: NObject Unit


NObjectSetConcurrent Function

NObjectSetConcurrent Function
NObject.h

Set the value of NObject. This function is tread-safe.

C++
NResult N_API NObjectSetConcurrent(HNObject hValue, volatile HNObject * phVariable);
Collapse Expand Parameters
Parameters | Description
HNObject hValue | [in] A handle to NObject.
volatile HNObject * phVariable | [in] A pointer to the value of NObject to set.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObject.h

Module: NObject Unit


NObjectSetFlags Function

NObjectSetFlags Function
NObject.h

Sets the flags for the specified object.

C++
NResult N_API NObjectSetFlags(HNObject hObject, NUInt value);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] Handle to NObject.
NUInt value | [in] The flags to set.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObject.h

Module: NObject Unit


NObjectSetPropertyN Function

NObjectSetPropertyN Function
NObject.h

Sets the specified property of the specified object to the specified value.

C++
NResult N_API NObjectSetPropertyN(HNObject hObject, HNString hName, HNValue hValue);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] Handle to the object.
HNString hName | [in] Handle to the name of the property.
HNValue hValue | [in] Handle to the new value of the property.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObject.h

Module: NObject Unit


NObjectSetPropertyNN Function

NObjectSetPropertyNN Function
NObject.h

Sets the specified property of the specified object to the specified value.

C++
NResult N_API NObjectSetPropertyNN(HNObject hObject, HNString hName, HNType hValueType, NAttributes attributes, const void * arValues, NSizeType valuesSize, NInt valuesLength, NBool hasValue);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] Handle to the object.
HNString hName | [in] Handle to the name of the property.
HNType hValueType | [in] Handle to the type of the value.
NAttributes attributes | [in] Property attributes.
const void * arValues | [in] Pointer to an array of values.
NSizeType valuesSize | [in] Size of the value.
NInt valuesLength | [in] Length of the value array.
NBool hasValue | [in] NTrue if the array contains a value; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObject.h

Module: NObject Unit


NObjectSetPropertyP Function

NObjectSetPropertyP Function
NObject.h

Sets the specified property of the specified object to the specified value.

C++
NResult N_API NObjectSetPropertyP(HNObject hObject, const NChar * szName, NTypeOfProc pValueTypeOf, NAttributes attributes, const void * arValues, NSizeType valuesSize, NInt valuesLength, NBool hasValue);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] Handle to the object.
const NChar * szName | [in] Pointer to the name of the property.
NTypeOfProc pValueTypeOf | [in] Pointer to the process that retrieves the type of the value.
NAttributes attributes | [in] Property attributes.
const void * arValues | [in] Pointer to an array of values.
NSizeType valuesSize | [in] Size of the value.
NInt valuesLength | [in] Length of the value array.
NBool hasValue | [in] NTrue if the array contains a value; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Notes

With this function mostly naNone NAttributes value should be applied.

Container

File: NObject.h

Module: NObject Unit


NObjectToString Function

NObjectToString Function
NObject.h

Returns string representation of the object.

C++
NResult N_API NObjectToString(HNObject hObject, const NChar * szFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] Handle to object to perform operation on.
const NChar * szFormat | [in] Pointer to a format string.
HNString * phValue | [out] Pointer to handle which contains string representation of NObject.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NObject.h

Module: NObject Unit


NObjectUnref Function

NObjectUnref Function
NObject.h

Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.

C++
NResult N_API NObjectUnref(HNObject hObject);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] Handle to an object to decrement its reference count.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

NResult > 0 is new reference count.

Container

File: NObject.h

Module: NObject Unit


NObjectUnrefArray Function

NObjectUnrefArray Function
NObject.h

Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.

C++
NResult N_API NObjectUnrefArray(HNObject * arhObjects, NInt objectCount);
Collapse Expand Parameters
Parameters | Description
HNObject * arhObjects | [in] Handle to array of objects which reference count should be decremented.
NInt objectCount | [in] Objects in arhObjects count.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

After calling this function the memory used by arhObjects is deallocated.

Container

File: NObject.h

Module: NObject Unit


NObjectUnrefElements Function

NObjectUnrefElements Function
NObject.h

Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.

C++
NResult N_API NObjectUnrefElements(HNObject * arhObjects, NInt objectCount);
Collapse Expand Parameters
Parameters | Description
HNObject * arhObjects | [in] Handle to array of objects which reference count should be decremented.
NInt objectCount | [in] Objects in arhObjects count.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObject.h

Module: NObject Unit


NObjectGetPropertyP Macro

NObjectGetPropertyP Macro
NObject.h

Picks a Unicode (W) or ASCII (A) version of the NObjectGetPropertyP function.

C++
#define NObjectGetPropertyP N_FUNC_AW(NObjectGetPropertyP)
Container

File: NObject.h

Module: NObject Unit


NObjectInvoke Macro

NObjectInvoke Macro
NObject.h

Picks a Unicode (W) or ASCII (A) version of the NObjectInvoke function.

C++
#define NObjectInvoke N_FUNC_AW(NObjectInvoke)
Container

File: NObject.h

Module: NObject Unit


NObjectInvokeWithPropertyBag Macro

NObjectInvokeWithPropertyBag Macro
NObject.h

Picks a Unicode (W) or ASCII (A) version of the NObjectInvokeWithPropertyBag function.

C++
#define NObjectInvokeWithPropertyBag N_FUNC_AW(NObjectInvokeWithPropertyBag)
Container

File: NObject.h

Module: NObject Unit


NObjectInvokeWithString Macro

NObjectInvokeWithString Macro
NObject.h

Picks a Unicode (W) or ASCII (A) version of the NObjectInvokeWithString function.

C++
#define NObjectInvokeWithString N_FUNC_AW(NObjectInvokeWithString)
Container

File: NObject.h

Module: NObject Unit


NObjectResetProperty Macro

NObjectResetProperty Macro
NObject.h

Picks a Unicode (W) or ASCII (A) version of the NObjectResetProperty function.

C++
#define NObjectResetProperty N_FUNC_AW(NObjectResetProperty)
Container

File: NObject.h

Module: NObject Unit


NObjectSetPropertyP Macro

NObjectSetPropertyP Macro
NObject.h

Picks a Unicode (W) or ASCII (A) version of the NObjectSetPropertyP function.

C++
#define NObjectSetPropertyP N_FUNC_AW(NObjectSetPropertyP)
Collapse Expand Remarks

With this function mostly naNone and NAttributes attributes should be applied.

Container

File: NObject.h

Module: NObject Unit


NObjectToString Macro

NObjectToString Macro
NObject.h

Picks a Unicode (W) or ASCII (A) version of the NObjectToString function.

C++
#define NObjectToString N_FUNC_AW(NObjectToString)
Container

File: NObject.h

Module: NObject Unit


N_OBJECT_REF_RET Macro

N_OBJECT_REF_RET Macro
NObject.h

Parameter used when object should be returned with incremented reference count. This parameter can be used with all *Add* functions accepting flags.

C++
#define N_OBJECT_REF_RET 0x00000010
Container

File: NObject.h

Module: NObject Unit


NObject.h

NObject.h
Functions Legend Macros

Header file for NObject module. Provides functionality for retrieving information about specified object.

Collapse Expand Functions
Name | Description
NObjectAddDisposed | Adds a "Disposed" callback to NObject.
NObjectAddDisposedCallback | Adds a "Disposed" callback to NObject.
NObjectAddHandlerP | Picks a Unicode (W) or ASCII (A) version of the NObjectAddHandlerP function.
NObjectAddOwnerChanged | Adds an "Owner changed" callback to NObject.
NObjectAddOwnerChangedCallback | Adds an "Owner changed" callback to NObject.
NObjectAddPropertyChanged | Adds a "Property changed" callback to NObject.
NObjectAddPropertyChangedCallback | Adds a "Property changed" callback to NObject.
NObjectCaptureProperties | Adds the properties of the specified object to the specified property bag.
NObjectClone | Creates a copy of specified object.
NObjectCompareTo | Compares the specified object with another specified object and returns an indication of their relative values.
NObjectCopyProperties | Copies property values from one object to another.
NObjectEquals | Compares the objects.
NObjectGet | Retrieves the value of NObject.
NObjectGetArray | Retrieves an array of values of an array of objects.
NObjectGetConcurrent | Retrieves the value of NObject. This function is thread-safe.
NObjectGetElements | Retrieves all elements of the specified object array.
NObjectGetFlags | Gets any flags of specified object.
NObjectGetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
NObjectGetOwnerEx | Gets owner of specified object.
NObjectGetPropertyN | Retrieves the value of the specified property of the specified object.
NObjectGetPropertyNN | Retrieves the value of the specified property of the specified object.
NObjectGetPropertyP | Retrieves the value of the specified property of the specified object.
NObjectGetSize | Retrieves the size of specified object.
NObjectGetSizeMany | Retrieves the size of the array of objects.
NObjectGetType | Retrieves type of specified object.
NObjectInvoke | Invokes the specified method or constructor, using the specified parameters.
NObjectInvokeWithPropertyBag | Invokes the specified method or constructor, using the specified parameters.
NObjectInvokeWithString | Invokes the specified method or constructor, using the specified parameters.
NObjectRef | ... more
NObjectRemoveDisposed | Removes the "Disposed" callback from NObject.
NObjectRemoveDisposedCallback | Removes the "Disposed" callback from NObject.
NObjectRemoveHandlerP | Picks a Unicode (W) or ASCII (A) version of the NObjectRemoveHandlerP function.
NObjectRemoveOwnerChanged | Removes the "Owner changed" callback from NObject.
NObjectRemoveOwnerChangedCallback | Removes the "Owner changed" callback from NObject.
NObjectRemovePropertyChanged | Removes the "Property changed" callback from NObject.
NObjectRemovePropertyChangedCallback | Removes the "Property changed" callback from NObject.
NObjectReset | Sets default values for all parameters of the specified object.
NObjectResetProperty | Sets default values for the specified property of the specified object.
NObjectSaveManyToMemoryDst | Saves an array of objects to a memory location with a specified size.
NObjectSaveManyToMemoryDstN | Saves an array of objects to a specified memory location.
NObjectSaveManyToMemoryN | Saves an array of objects to a memory location.
NObjectSaveManyToStream | Saves a NObject array in a stream.
NObjectSaveToMemoryDst | Saves an objects to a memory location with specified size.
NObjectSaveToMemoryDstN | Save an object to a specified memory location.
NObjectSaveToMemoryN | Saves an object to a memory location.
NObjectSaveToStream | Saves NObject to a stream.
NObjectSet | Set the value of NObject.
NObjectSetConcurrent | Set the value of NObject. This function is tread-safe.
NObjectSetFlags | Sets the flags for the specified object.
NObjectSetPropertyN | Sets the specified property of the specified object to the specified value.
NObjectSetPropertyNN | Sets the specified property of the specified object to the specified value.
NObjectSetPropertyP | Sets the specified property of the specified object to the specified value.
NObjectToString | Returns string representation of the object.
NObjectUnref | ... more
NObjectUnrefArray | ... more
NObjectUnrefElements | ... more
Collapse Expand Macros
Name | Description
NObjectGetPropertyP | Picks a Unicode (W) or ASCII (A) version of the NObjectGetPropertyP function.
NObjectInvoke | Picks a Unicode (W) or ASCII (A) version of the NObjectInvoke function.
NObjectInvokeWithPropertyBag | Picks a Unicode (W) or ASCII (A) version of the NObjectInvokeWithPropertyBag function.
NObjectInvokeWithString | Picks a Unicode (W) or ASCII (A) version of the NObjectInvokeWithString function.
NObjectResetProperty | Picks a Unicode (W) or ASCII (A) version of the NObjectResetProperty function.
NObjectSetPropertyP | Picks a Unicode (W) or ASCII (A) version of the NObjectSetPropertyP function.
NObjectToString | Picks a Unicode (W) or ASCII (A) version of the NObjectToString function.
N_OBJECT_REF_RET | ... more


NObjectPartInfo Unit

NObjectPartInfo Unit
Files Functions Legend Macros

Provides functionality to retrieve information about object parts.

Collapse Expand Files
Name | Description
NObjectPartInfo.h | Header file for the NObjectPartInfo unit.
Collapse Expand Functions
Name | Description
NObjectPartInfoGetDeclaredConstant | Retrieves the specified declared constant of the object part.
NObjectPartInfoGetDeclaredConstantCount | Retrieves the number of declared constants in the object part.
NObjectPartInfoGetDeclaredConstantWithName | Retrieves the specified declared constant of the object part.
NObjectPartInfoGetDeclaredConstants | Retrieves all declared constants in the object part.
NObjectPartInfoGetDeclaredEvent | Retrieves the specified declared event of the object part.
NObjectPartInfoGetDeclaredEventCount | Retrieves the number of declared events in the object part.
NObjectPartInfoGetDeclaredEventWithName | Retrieves the specified declared event of the object part.
NObjectPartInfoGetDeclaredEvents | Retrieves all declared events in the object part.
NObjectPartInfoGetDeclaredMethod | Retrieves the specified declared method of the object part.
NObjectPartInfoGetDeclaredMethodCount | Retrieves the number of declared methods in the object part.
NObjectPartInfoGetDeclaredMethodWithName | Retrieves the specified declared method of the object part.
NObjectPartInfoGetDeclaredMethods | Retrieves all declared methods in the object part.
NObjectPartInfoGetDeclaredMethodsWithName | Retrieves all declared methods in the object part.
NObjectPartInfoGetDeclaredProperties | Retrieves all declared properties in the object part.
NObjectPartInfoGetDeclaredProperty | Retrieves the specified declared property of the object part.
NObjectPartInfoGetDeclaredPropertyCount | Retrieves the number of declared properties in the object part.
NObjectPartInfoGetDeclaredPropertyWithName | Retrieves the specified declared property of the object part.
NObjectPartInfoGetObjectPart | Retrieves the specified object part.
NObjectPartInfoGetPropertyName | Retrieves the name of an object part property.
Collapse Expand Macros
Name | Description
NObjectPartInfoGetDeclaredConstantWithName | Picks a Unicode (W) or ASCII (A) version of the NObjectPartInfoGetDeclaredConstantWithName function.
NObjectPartInfoGetDeclaredEventWithName | Picks a Unicode (W) or ASCII (A) version of the NObjectPartInfoGetDeclaredEventWithName function.
NObjectPartInfoGetDeclaredMethodWithName | Picks a Unicode (W) or ASCII (A) version of the NObjectPartInfoGetDeclaredMethodWithName function.
NObjectPartInfoGetDeclaredMethodsWithName | Picks a Unicode (W) or ASCII (A) version of the NObjectPartInfoGetDeclaredMethodsWithName function.
NObjectPartInfoGetDeclaredPropertyWithName | Picks a Unicode (W) or ASCII (A) version of the NObjectPartInfoGetDeclaredPropertyWithName function.


NObjectPartInfoGetDeclaredConstant Function

NObjectPartInfoGetDeclaredConstant Function
NObjectPartInfo.h

Retrieves the specified declared constant of the object part.

C++
NResult N_API NObjectPartInfoGetDeclaredConstant(HNObjectPartInfo hObjectPartInfo, NInt index, HNConstantInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNObjectPartInfo hObjectPartInfo | [in] Handle to the object part information.
NInt index | [in] Index of the declared constant.
HNConstantInfo * phValue | [out] Pointer to the constant information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObjectPartInfo.h

Module: NObjectPartInfo Unit


NObjectPartInfoGetDeclaredConstantCount Function

NObjectPartInfoGetDeclaredConstantCount Function
NObjectPartInfo.h

Retrieves the number of declared constants in the object part.

C++
NResult N_API NObjectPartInfoGetDeclaredConstantCount(HNObjectPartInfo hObjectPartInfo, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNObjectPartInfo hObjectPartInfo | [in] Handle to the object part information.
NInt * pValue | [out] Pointer to the number of declared constants.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObjectPartInfo.h

Module: NObjectPartInfo Unit


NObjectPartInfoGetDeclaredConstantWithName Function

NObjectPartInfoGetDeclaredConstantWithName Function
NObjectPartInfo.h

Retrieves the specified declared constant of the object part.

C++
NResult N_API NObjectPartInfoGetDeclaredConstantWithName(HNObjectPartInfo hObjectPartInfo, const NChar * szName, HNConstantInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNObjectPartInfo hObjectPartInfo | [in] Handle to the object part information.
const NChar * szName | [in] Pointer to the name of the declared constant.
HNConstantInfo * phValue | [out] Pointer to the constant information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObjectPartInfo.h

Module: NObjectPartInfo Unit


NObjectPartInfoGetDeclaredConstants Function

NObjectPartInfoGetDeclaredConstants Function
NObjectPartInfo.h

Retrieves all declared constants in the object part.

C++
NResult N_API NObjectPartInfoGetDeclaredConstants(HNObjectPartInfo hObjectPartInfo, HNConstantInfo * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNObjectPartInfo hObjectPartInfo | [in] Handle to the object part information.
HNConstantInfo * * parhValues | [out] Pointer to the array of declared constants.
NInt * pValueCount | [out] Pointer to the number of declared constants in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObjectPartInfo.h

Module: NObjectPartInfo Unit


NObjectPartInfoGetDeclaredEvent Function

NObjectPartInfoGetDeclaredEvent Function
NObjectPartInfo.h

Retrieves the specified declared event of the object part.

C++
NResult N_API NObjectPartInfoGetDeclaredEvent(HNObjectPartInfo hObjectPartInfo, NInt index, HNEventInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNObjectPartInfo hObjectPartInfo | [in] Handle to the object part information.
NInt index | [in] Index of the declared event.
HNEventInfo * phValue | [out] Pointer to the event information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObjectPartInfo.h

Module: NObjectPartInfo Unit


NObjectPartInfoGetDeclaredEventCount Function

NObjectPartInfoGetDeclaredEventCount Function
NObjectPartInfo.h

Retrieves the number of declared events in the object part.

C++
NResult N_API NObjectPartInfoGetDeclaredEventCount(HNObjectPartInfo hObjectPartInfo, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNObjectPartInfo hObjectPartInfo | [in] Handle to the object part information.
NInt * pValue | [out] Pointer to the number of declared events.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObjectPartInfo.h

Module: NObjectPartInfo Unit


NObjectPartInfoGetDeclaredEventWithName Function

NObjectPartInfoGetDeclaredEventWithName Function
NObjectPartInfo.h

Retrieves the specified declared event of the object part.

C++
NResult N_API NObjectPartInfoGetDeclaredEventWithName(HNObjectPartInfo hObjectPartInfo, const NChar * szName, HNEventInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNObjectPartInfo hObjectPartInfo | [in] Handle to the object part information.
const NChar * szName | [in] Pointer to the name of the declared event.
HNEventInfo * phValue | [out] Pointer to the event information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObjectPartInfo.h

Module: NObjectPartInfo Unit


NObjectPartInfoGetDeclaredEvents Function

NObjectPartInfoGetDeclaredEvents Function
NObjectPartInfo.h

Retrieves all declared events in the object part.

C++
NResult N_API NObjectPartInfoGetDeclaredEvents(HNObjectPartInfo hObjectPartInfo, HNEventInfo * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNObjectPartInfo hObjectPartInfo | [in] Handle to the object part information.
HNEventInfo * * parhValues | [out] Pointer to the array of declared events.
NInt * pValueCount | [out] Pointer to the number of declared events in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObjectPartInfo.h

Module: NObjectPartInfo Unit


NObjectPartInfoGetDeclaredMethod Function

NObjectPartInfoGetDeclaredMethod Function
NObjectPartInfo.h

Retrieves the specified declared method of the object part.

C++
NResult N_API NObjectPartInfoGetDeclaredMethod(HNObjectPartInfo hObjectPartInfo, NInt index, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNObjectPartInfo hObjectPartInfo | [in] Handle to the object part information.
NInt index | [in] Index of the declared method.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObjectPartInfo.h

Module: NObjectPartInfo Unit


NObjectPartInfoGetDeclaredMethodCount Function

NObjectPartInfoGetDeclaredMethodCount Function
NObjectPartInfo.h

Retrieves the number of declared methods in the object part.

C++
NResult N_API NObjectPartInfoGetDeclaredMethodCount(HNObjectPartInfo hObjectPartInfo, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNObjectPartInfo hObjectPartInfo | [in] Handle to the object part information.
NInt * pValue | [out] Pointer to the number of declared methods.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObjectPartInfo.h

Module: NObjectPartInfo Unit


NObjectPartInfoGetDeclaredMethodWithName Function

NObjectPartInfoGetDeclaredMethodWithName Function
NObjectPartInfo.h

Retrieves the specified declared method of the object part.

C++
NResult N_API NObjectPartInfoGetDeclaredMethodWithName(HNObjectPartInfo hObjectPartInfo, const NChar * szName, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNObjectPartInfo hObjectPartInfo | [in] Handle to the object part information.
const NChar * szName | [in] Pointer to the name of the declared method.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObjectPartInfo.h

Module: NObjectPartInfo Unit


NObjectPartInfoGetDeclaredMethods Function

NObjectPartInfoGetDeclaredMethods Function
NObjectPartInfo.h

Retrieves all declared methods in the object part.

C++
NResult N_API NObjectPartInfoGetDeclaredMethods(HNObjectPartInfo hObjectPartInfo, HNMethodInfo * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNObjectPartInfo hObjectPartInfo | [in] Handle to the object part information.
HNMethodInfo * * parhValues | [out] Pointer to the array of declared methods.
NInt * pValueCount | [out] Pointer to the number of declared methods in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObjectPartInfo.h

Module: NObjectPartInfo Unit


NObjectPartInfoGetDeclaredMethodsWithName Function

NObjectPartInfoGetDeclaredMethodsWithName Function
NObjectPartInfo.h

Retrieves all declared methods in the object part.

C++
NResult N_API NObjectPartInfoGetDeclaredMethodsWithName(HNObjectPartInfo hObjectPartInfo, const NChar * szName, HNMethodInfo * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNObjectPartInfo hObjectPartInfo | [in] Handle to the object part information.
const NChar * szName | [in] Pointer to the names of the declared methods.
HNMethodInfo * * parhValues | [out] Pointer to the array of declared methods.
NInt * pValueCount | [out] Pointer to the number of declared methods in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObjectPartInfo.h

Module: NObjectPartInfo Unit


NObjectPartInfoGetDeclaredProperties Function

NObjectPartInfoGetDeclaredProperties Function
NObjectPartInfo.h

Retrieves all declared properties in the object part.

C++
NResult N_API NObjectPartInfoGetDeclaredProperties(HNObjectPartInfo hObjectPartInfo, HNPropertyInfo * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNObjectPartInfo hObjectPartInfo | [in] Handle to the object part information.
HNPropertyInfo * * parhValues | [out] Pointer to the array of declared properties.
NInt * pValueCount | [out] Pointer to the number of declared properties in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObjectPartInfo.h

Module: NObjectPartInfo Unit


NObjectPartInfoGetDeclaredProperty Function

NObjectPartInfoGetDeclaredProperty Function
NObjectPartInfo.h

Retrieves the specified declared property of the object part.

C++
NResult N_API NObjectPartInfoGetDeclaredProperty(HNObjectPartInfo hObjectPartInfo, NInt index, HNPropertyInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNObjectPartInfo hObjectPartInfo | [in] Handle to the object part information.
NInt index | [in] Index of the declared property.
HNPropertyInfo * phValue | [out] Pointer to the property information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObjectPartInfo.h

Module: NObjectPartInfo Unit


NObjectPartInfoGetDeclaredPropertyCount Function

NObjectPartInfoGetDeclaredPropertyCount Function
NObjectPartInfo.h

Retrieves the number of declared properties in the object part.

C++
NResult N_API NObjectPartInfoGetDeclaredPropertyCount(HNObjectPartInfo hObjectPartInfo, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNObjectPartInfo hObjectPartInfo | [in] Handle to the object part information.
NInt * pValue | [out] Pointer to the number of declared properties.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObjectPartInfo.h

Module: NObjectPartInfo Unit


NObjectPartInfoGetDeclaredPropertyWithName Function

NObjectPartInfoGetDeclaredPropertyWithName Function
NObjectPartInfo.h

Retrieves the specified declared property of the object part.

C++
NResult N_API NObjectPartInfoGetDeclaredPropertyWithName(HNObjectPartInfo hObjectPartInfo, const NChar * szName, HNPropertyInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNObjectPartInfo hObjectPartInfo | [in] Handle to the object part information.
const NChar * szName | [in] Pointer to the name of the declared property.
HNPropertyInfo * phValue | [out] Pointer to the property information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObjectPartInfo.h

Module: NObjectPartInfo Unit


NObjectPartInfoGetObjectPart Function

NObjectPartInfoGetObjectPart Function
NObjectPartInfo.h

Retrieves the specified object part.

C++
NResult N_API NObjectPartInfoGetObjectPart(HNObjectPartInfo hObjectPartInfo, HNObject hObject, HNObjectPart * phObjectPart);
Collapse Expand Parameters
Parameters | Description
HNObjectPartInfo hObjectPartInfo | [in] Handle to the object part information.
HNObject hObject | [in] Handle to the object.
HNObjectPart * phObjectPart | [out] Pointer to the object part.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObjectPartInfo.h

Module: NObjectPartInfo Unit


NObjectPartInfoGetPropertyName Function

NObjectPartInfoGetPropertyName Function
NObjectPartInfo.h

Retrieves the name of an object part property.

C++
NResult N_API NObjectPartInfoGetPropertyName(HNObjectPartInfo hObjectPartInfo, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNObjectPartInfo hObjectPartInfo | [in] Handle to the object part information.
HNString * phValue | [out] Pointer to the property name
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NObjectPartInfo.h

Module: NObjectPartInfo Unit


NObjectPartInfoGetDeclaredConstantWithName Macro

NObjectPartInfoGetDeclaredConstantWithName Macro
NObjectPartInfo.h

Picks a Unicode (W) or ASCII (A) version of the NObjectPartInfoGetDeclaredConstantWithName function.

C++
#define NObjectPartInfoGetDeclaredConstantWithName N_FUNC_AW(NObjectPartInfoGetDeclaredConstantWithName)
Container

File: NObjectPartInfo.h

Module: NObjectPartInfo Unit


NObjectPartInfoGetDeclaredEventWithName Macro

NObjectPartInfoGetDeclaredEventWithName Macro
NObjectPartInfo.h

Picks a Unicode (W) or ASCII (A) version of the NObjectPartInfoGetDeclaredEventWithName function.

C++
#define NObjectPartInfoGetDeclaredEventWithName N_FUNC_AW(NObjectPartInfoGetDeclaredEventWithName)
Container

File: NObjectPartInfo.h

Module: NObjectPartInfo Unit


NObjectPartInfoGetDeclaredMethodWithName Macro

NObjectPartInfoGetDeclaredMethodWithName Macro
NObjectPartInfo.h

Picks a Unicode (W) or ASCII (A) version of the NObjectPartInfoGetDeclaredMethodWithName function.

C++
#define NObjectPartInfoGetDeclaredMethodWithName N_FUNC_AW(NObjectPartInfoGetDeclaredMethodWithName)
Container

File: NObjectPartInfo.h

Module: NObjectPartInfo Unit


NObjectPartInfoGetDeclaredMethodsWithName Macro

NObjectPartInfoGetDeclaredMethodsWithName Macro
NObjectPartInfo.h

Picks a Unicode (W) or ASCII (A) version of the NObjectPartInfoGetDeclaredMethodsWithName function.

C++
#define NObjectPartInfoGetDeclaredMethodsWithName N_FUNC_AW(NObjectPartInfoGetDeclaredMethodsWithName)
Container

File: NObjectPartInfo.h

Module: NObjectPartInfo Unit


NObjectPartInfoGetDeclaredPropertyWithName Macro

NObjectPartInfoGetDeclaredPropertyWithName Macro
NObjectPartInfo.h

Picks a Unicode (W) or ASCII (A) version of the NObjectPartInfoGetDeclaredPropertyWithName function.

C++
#define NObjectPartInfoGetDeclaredPropertyWithName N_FUNC_AW(NObjectPartInfoGetDeclaredPropertyWithName)
Container

File: NObjectPartInfo.h

Module: NObjectPartInfo Unit


NObjectPartInfo.h

NObjectPartInfo.h
Functions Legend Macros

Header file for the NObjectPartInfo unit.

Collapse Expand Functions
Name | Description
NObjectPartInfoGetDeclaredConstant | Retrieves the specified declared constant of the object part.
NObjectPartInfoGetDeclaredConstantCount | Retrieves the number of declared constants in the object part.
NObjectPartInfoGetDeclaredConstantWithName | Retrieves the specified declared constant of the object part.
NObjectPartInfoGetDeclaredConstants | Retrieves all declared constants in the object part.
NObjectPartInfoGetDeclaredEvent | Retrieves the specified declared event of the object part.
NObjectPartInfoGetDeclaredEventCount | Retrieves the number of declared events in the object part.
NObjectPartInfoGetDeclaredEventWithName | Retrieves the specified declared event of the object part.
NObjectPartInfoGetDeclaredEvents | Retrieves all declared events in the object part.
NObjectPartInfoGetDeclaredMethod | Retrieves the specified declared method of the object part.
NObjectPartInfoGetDeclaredMethodCount | Retrieves the number of declared methods in the object part.
NObjectPartInfoGetDeclaredMethodWithName | Retrieves the specified declared method of the object part.
NObjectPartInfoGetDeclaredMethods | Retrieves all declared methods in the object part.
NObjectPartInfoGetDeclaredMethodsWithName | Retrieves all declared methods in the object part.
NObjectPartInfoGetDeclaredProperties | Retrieves all declared properties in the object part.
NObjectPartInfoGetDeclaredProperty | Retrieves the specified declared property of the object part.
NObjectPartInfoGetDeclaredPropertyCount | Retrieves the number of declared properties in the object part.
NObjectPartInfoGetDeclaredPropertyWithName | Retrieves the specified declared property of the object part.
NObjectPartInfoGetObjectPart | Retrieves the specified object part.
NObjectPartInfoGetPropertyName | Retrieves the name of an object part property.
Collapse Expand Macros
Name | Description
NObjectPartInfoGetDeclaredConstantWithName | Picks a Unicode (W) or ASCII (A) version of the NObjectPartInfoGetDeclaredConstantWithName function.
NObjectPartInfoGetDeclaredEventWithName | Picks a Unicode (W) or ASCII (A) version of the NObjectPartInfoGetDeclaredEventWithName function.
NObjectPartInfoGetDeclaredMethodWithName | Picks a Unicode (W) or ASCII (A) version of the NObjectPartInfoGetDeclaredMethodWithName function.
NObjectPartInfoGetDeclaredMethodsWithName | Picks a Unicode (W) or ASCII (A) version of the NObjectPartInfoGetDeclaredMethodsWithName function.
NObjectPartInfoGetDeclaredPropertyWithName | Picks a Unicode (W) or ASCII (A) version of the NObjectPartInfoGetDeclaredPropertyWithName function.


NParameterBag Unit

NParameterBag Unit
Files Functions Legend Macros

A helper class that aids in implementation of PropertyBag for ParameterDescriptor class.

Collapse Expand Files
Name | Description
NParameterBag.h | Header file for the NParameterBag unit.
Collapse Expand Functions
Name | Description
NParameterBagApplyPropertyBag | Applies the specified parameter bag to the specified property bag.
NParameterBagContains | Checks whether the specified parameter bag contains the parameter with specified key.
NParameterBagCreate | Creates a new parameter bag from an array of parameters.
NParameterBagGet | Retrieves the parameter specified by the key.
NParameterBagGetAt | Retrieves the parameter specified by an index.
NParameterBagGetCount | Retrieves the number of parameters in the specified parameter bag.
NParameterBagGetKey | Retrieves the key to the parameter specified by index.
NParameterBagGetKeys | Retrieves keys of all parameters in the bag.
NParameterBagGetValue | Retrieves the value of the parameter specified by an index.
NParameterBagGetValues | Retrieves values of all parameters in the bag.
NParameterBagSet | Sets the value of the parameter specified by the key.
NParameterBagSetValue | Sets the value of the parameter specified by an index.
NParameterBagToArray | Converts the specified parameter bag into a name-value pair array.
NParameterBagToPropertyBag | Converts a parameter bag to a property bag.
NParameterBagTryGet | Retrieves the parameter specified by the key. Returns a Boolean value indicating whether the operation succeeded.
Collapse Expand Macros
Name | Description
NParameterBagContains | Picks a Unicode (W) or ASCII (A) version of the NParameterBagContains function.
NParameterBagGet | Picks a Unicode (W) or ASCII (A) version of the NParameterBagGet function.
NParameterBagSet | Picks a Unicode (W) or ASCII (A) version of the NParameterBag function.
NParameterBagTryGet | Picks a Unicode (W) or ASCII (A) version of the NParameterBagTryGet function.


NParameterBagApplyPropertyBag Function

NParameterBagApplyPropertyBag Function
NParameterBag.h

Applies the specified parameter bag to the specified property bag.

C++
NResult N_API NParameterBagApplyPropertyBag(HNParameterBag hParameterBag, HNPropertyBag hValue, NBool ignoreUknown);
Collapse Expand Parameters
Parameters | Description
HNParameterBag hParameterBag | [in] Handle to the parameter bag.
HNPropertyBag hValue | [in] Handle to the property bag.
NBool ignoreUknown | [in] NTrue if unknown values should be ignored; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NParameterBag.h

Module: NParameterBag Unit


NParameterBagContains Function

NParameterBagContains Function
NParameterBag.h

Checks whether the specified parameter bag contains the parameter with specified key.

C++
NResult N_API NParameterBagContains(HNParameterBag hParameterBag, const NChar * szKey, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNParameterBag hParameterBag | [in] Handle to the parameter bag.
const NChar * szKey | [in] Pointer to the key to the parameter.
NBool * pResult | [out] NTrue if the bag contains the specified parameter; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NParameterBag.h

Module: NParameterBag Unit


NParameterBagCreate Function

NParameterBagCreate Function
NParameterBag.h

Creates a new parameter bag from an array of parameters.

C++
NResult N_API NParameterBagCreate(const HNParameterDescriptor * arhParameters, NInt parameterCount, HNParameterBag * phParameterBag);
Collapse Expand Parameters
Parameters | Description
const HNParameterDescriptor * arhParameters | [in] Pointer to an array of parameter descriptor handles.
NInt parameterCount | [in] Number of parameters.
HNParameterBag * phParameterBag | [out] Pointer to a handle to the new parameter bag.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NParameterBag.h

Module: NParameterBag Unit


NParameterBagGet Function

NParameterBagGet Function
NParameterBag.h

Retrieves the parameter specified by the key.

C++
NResult N_API NParameterBagGet(HNParameterBag hParameterBag, const NChar * szKey, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
HNParameterBag hParameterBag | [in] Handle to the parameter bag.
const NChar * szKey | [in] Pointer to the parameter key.
HNValue * phValue | [out] Pointer to a handle to the parameter.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NParameterBag.h

Module: NParameterBag Unit


NParameterBagGetAt Function

NParameterBagGetAt Function
NParameterBag.h

Retrieves the parameter specified by an index.

C++
NResult N_API NParameterBagGetAt(HNParameterBag hParameterBag, NInt index, struct NNameValuePair_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNParameterBag hParameterBag | [in] Handle to the parameter bag.
NInt index | [in] Index of the parameter.
struct NNameValuePair_ * pValue | [out] Pointer to a handle to the parameter.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NParameterBag.h

Module: NParameterBag Unit


NParameterBagGetCount Function

NParameterBagGetCount Function
NParameterBag.h

Retrieves the number of parameters in the specified parameter bag.

C++
NResult N_API NParameterBagGetCount(HNParameterBag hParameterBag, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNParameterBag hParameterBag | [in] Handle to the parameter bag.
NInt * pValue | [out] Pointer to the number of parameters in the bag.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NParameterBag.h

Module: NParameterBag Unit


NParameterBagGetKey Function

NParameterBagGetKey Function
NParameterBag.h

Retrieves the key to the parameter specified by index.

C++
NResult N_API NParameterBagGetKey(HNParameterBag hParameterBag, NInt index, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNParameterBag hParameterBag | [in] Handle to the parameter bag.
NInt index | [in] Index of the parameter.
HNString * phValue | [out] Pointer to a handle to the string representing the key of the parameter.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NParameterBag.h

Module: NParameterBag Unit


NParameterBagGetKeys Function

NParameterBagGetKeys Function
NParameterBag.h

Retrieves keys of all parameters in the bag.

C++
NResult N_API NParameterBagGetKeys(HNParameterBag hParameterBag, HNString * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNParameterBag hParameterBag | [in] Handle to the parameter bag.
HNString * * parhValues | [out] Pointer to an array of parameter keys.
NInt * pValueCount | [out] Pointer to the number of values in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NParameterBag.h

Module: NParameterBag Unit


NParameterBagGetValue Function

NParameterBagGetValue Function
NParameterBag.h

Retrieves the value of the parameter specified by an index.

C++
NResult N_API NParameterBagGetValue(HNParameterBag hParameterBag, NInt index, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
HNParameterBag hParameterBag | [in] Handle to the parameter bag.
NInt index | [in] Index of the parameter whose value is to be retrieved.
HNValue * phValue | [out] Pointer to a handle to the value of the parameter.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NParameterBag.h

Module: NParameterBag Unit


NParameterBagGetValues Function

NParameterBagGetValues Function
NParameterBag.h

Retrieves values of all parameters in the bag.

C++
NResult N_API NParameterBagGetValues(HNParameterBag hParameterBag, HNValue * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNParameterBag hParameterBag | [in] Handle to the parameter bag.
HNValue * * parhValues | [out] Pointer to an array of parameter values.
NInt * pValueCount | [out] Pointer to the number of values in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NParameterBag.h

Module: NParameterBag Unit


NParameterBagSet Function

NParameterBagSet Function
NParameterBag.h

Sets the value of the parameter specified by the key.

C++
NResult N_API NParameterBagSet(HNParameterBag hParameterBag, const NChar * szKey, HNValue hValue);
Collapse Expand Parameters
Parameters | Description
HNParameterBag hParameterBag | [in] Handle to the parameter bag.
const NChar * szKey | [in] Pointer to the parameter key.
HNValue hValue | [in] Handle to the new parameter value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NParameterBag.h

Module: NParameterBag Unit


NParameterBagSetValue Function

NParameterBagSetValue Function
NParameterBag.h

Sets the value of the parameter specified by an index.

C++
NResult N_API NParameterBagSetValue(HNParameterBag hParameterBag, NInt index, HNValue hValue);
Collapse Expand Parameters
Parameters | Description
HNParameterBag hParameterBag | [in] Handle to the parameter bag.
NInt index | [in] Index of the parameter.
HNValue hValue | [in] Handle to the new parameter value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NParameterBag.h

Module: NParameterBag Unit


NParameterBagToArray Function

NParameterBagToArray Function
NParameterBag.h

Converts the specified parameter bag into a name-value pair array.

C++
NResult N_API NParameterBagToArray(HNParameterBag hParameterBag, struct NNameValuePair_ * * parValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNParameterBag hParameterBag | [in] Handle to the parameter bag.
struct NNameValuePair_ * * parValues | [out] Pointer to the name-value pair structure array.
NInt * pValueCount | [out] Pointer to the number of pairs in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NParameterBag.h

Module: NParameterBag Unit


NParameterBagToPropertyBag Function

NParameterBagToPropertyBag Function
NParameterBag.h

Converts a parameter bag to a property bag.

C++
NResult N_API NParameterBagToPropertyBag(HNParameterBag hParameterBag, HNPropertyBag * phValue);
Collapse Expand Parameters
Parameters | Description
HNParameterBag hParameterBag | [in] Handle to the parameter bag.
HNPropertyBag * phValue | [out] Pointer to a the handle to the converted property bag.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NParameterBag.h

Module: NParameterBag Unit


NParameterBagTryGet Function

NParameterBagTryGet Function
NParameterBag.h

Retrieves the parameter specified by the key. Returns a Boolean value indicating whether the operation succeeded.

C++
NResult N_API NParameterBagTryGet(HNParameterBag hParameterBag, const NChar * szKey, HNValue * phValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNParameterBag hParameterBag | [in] Handle to the parameter bag.
const NChar * szKey | [in] Pointer to the parameter key.
HNValue * phValue | [out] Pointer to a handle to the parameter.
NBool * pResult | [out] NTrue if the operation was successful, else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NParameterBag.h

Module: NParameterBag Unit


NParameterBagContains Macro

NParameterBagContains Macro
NParameterBag.h

Picks a Unicode (W) or ASCII (A) version of the NParameterBagContains function.

C++
#define NParameterBagContains N_FUNC_AW(NParameterBagContains)
Container

File: NParameterBag.h

Module: NParameterBag Unit


NParameterBagGet Macro

NParameterBagGet Macro
NParameterBag.h

Picks a Unicode (W) or ASCII (A) version of the NParameterBagGet function.

C++
#define NParameterBagGet N_FUNC_AW(NParameterBagGet)
Container

File: NParameterBag.h

Module: NParameterBag Unit


NParameterBagSet Macro

NParameterBagSet Macro
NParameterBag.h

Picks a Unicode (W) or ASCII (A) version of the NParameterBag function.

C++
#define NParameterBagSet N_FUNC_AW(NParameterBag)
Container

File: NParameterBag.h

Module: NParameterBag Unit


NParameterBagTryGet Macro

NParameterBagTryGet Macro
NParameterBag.h

Picks a Unicode (W) or ASCII (A) version of the NParameterBagTryGet function.

C++
#define NParameterBagTryGet N_FUNC_AW(NParameterBagTryGet)
Container

File: NParameterBag.h

Module: NParameterBag Unit


NParameterBag.h

NParameterBag.h
Functions Legend Macros

Header file for the NParameterBag unit.

Collapse Expand Functions
Name | Description
NParameterBagApplyPropertyBag | Applies the specified parameter bag to the specified property bag.
NParameterBagContains | Checks whether the specified parameter bag contains the parameter with specified key.
NParameterBagCreate | Creates a new parameter bag from an array of parameters.
NParameterBagGet | Retrieves the parameter specified by the key.
NParameterBagGetAt | Retrieves the parameter specified by an index.
NParameterBagGetCount | Retrieves the number of parameters in the specified parameter bag.
NParameterBagGetKey | Retrieves the key to the parameter specified by index.
NParameterBagGetKeys | Retrieves keys of all parameters in the bag.
NParameterBagGetValue | Retrieves the value of the parameter specified by an index.
NParameterBagGetValues | Retrieves values of all parameters in the bag.
NParameterBagSet | Sets the value of the parameter specified by the key.
NParameterBagSetValue | Sets the value of the parameter specified by an index.
NParameterBagToArray | Converts the specified parameter bag into a name-value pair array.
NParameterBagToPropertyBag | Converts a parameter bag to a property bag.
NParameterBagTryGet | Retrieves the parameter specified by the key. Returns a Boolean value indicating whether the operation succeeded.
Collapse Expand Macros
Name | Description
NParameterBagContains | Picks a Unicode (W) or ASCII (A) version of the NParameterBagContains function.
NParameterBagGet | Picks a Unicode (W) or ASCII (A) version of the NParameterBagGet function.
NParameterBagSet | Picks a Unicode (W) or ASCII (A) version of the NParameterBag function.
NParameterBagTryGet | Picks a Unicode (W) or ASCII (A) version of the NParameterBagTryGet function.


NParameterDescriptor Unit

NParameterDescriptor Unit
Files Functions Legend

Provides functions for getting information about parameter.

Collapse Expand Files
Name | Description
NParameterDescriptor.h | Header file for the NParameterDescriptor module.
Collapse Expand Functions
Name | Description
NParameterDescriptorGetDefaultValue | Retrieves the default value of the specified parameter descriptor.
NParameterDescriptorGetFormat | Retrieves the format value of the specified parameter descriptor.
NParameterDescriptorGetMaxValue | Retrieves the maximum value of the specified parameter descriptor.
NParameterDescriptorGetMinValue | Retrieves the minimum value of the specified parameter descriptor.
NParameterDescriptorGetParameterType | Retrieves the parameter type of the specified parameter descriptor.
NParameterDescriptorGetStdValue | Retrieves the specified standard value of the specified parameter descriptor.
NParameterDescriptorGetStdValueCount | Retrieves the number of standard parameter descriptor values.
NParameterDescriptorGetStdValues | Gets all standard values of the specified parameter descriptor.


NParameterDescriptorGetDefaultValue Function

NParameterDescriptorGetDefaultValue Function
NParameterDescriptor.h

Retrieves the default value of the specified parameter descriptor.

C++
NResult N_API NParameterDescriptorGetDefaultValue(HNParameterDescriptor hParameterDescriptor, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
HNParameterDescriptor hParameterDescriptor | [in] Handle to the parameter.
HNValue * phValue | [out] Pointer to a handle to the default value of the parameter.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NParameterDescriptor.h

Module: NParameterDescriptor Unit


NParameterDescriptorGetFormat Function

NParameterDescriptorGetFormat Function
NParameterDescriptor.h

Retrieves the format value of the specified parameter descriptor.

C++
NResult N_API NParameterDescriptorGetFormat(HNParameterDescriptor hParameterDescriptor, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNParameterDescriptor hParameterDescriptor | [in] Handle to the parameter descriptor.
HNString * phValue | [out] Pointer to a handle to a string representing the format of the parameter descriptor.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NParameterDescriptor.h

Module: NParameterDescriptor Unit


NParameterDescriptorGetMaxValue Function

NParameterDescriptorGetMaxValue Function
NParameterDescriptor.h

Retrieves the maximum value of the specified parameter descriptor.

C++
NResult N_API NParameterDescriptorGetMaxValue(HNParameterDescriptor hParameterDescriptor, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
HNParameterDescriptor hParameterDescriptor | [in] Handle to the parameter descriptor.
HNValue * phValue | [out] Pointer to a handle to the maximum value of the parameter.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NParameterDescriptor.h

Module: NParameterDescriptor Unit


NParameterDescriptorGetMinValue Function

NParameterDescriptorGetMinValue Function
NParameterDescriptor.h

Retrieves the minimum value of the specified parameter descriptor.

C++
NResult N_API NParameterDescriptorGetMinValue(HNParameterDescriptor hParameterDescriptor, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
HNParameterDescriptor hParameterDescriptor | [in] Handle to the parameter descriptor.
HNValue * phValue | [out] Pointer to a handle to the minimum value of the parameter.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NParameterDescriptor.h

Module: NParameterDescriptor Unit


NParameterDescriptorGetParameterType Function

NParameterDescriptorGetParameterType Function
NParameterDescriptor.h

Retrieves the parameter type of the specified parameter descriptor.

C++
NResult N_API NParameterDescriptorGetParameterType(HNParameterDescriptor hParameterDescriptor, HNType * phValue);
Collapse Expand Parameters
Parameters | Description
HNParameterDescriptor hParameterDescriptor | [in] Handle to the parameter descriptor.
HNType * phValue | [out] Pointer to a handle to the parameter type.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NParameterDescriptor.h

Module: NParameterDescriptor Unit


NParameterDescriptorGetStdValue Function

NParameterDescriptorGetStdValue Function
NParameterDescriptor.h

Retrieves the specified standard value of the specified parameter descriptor.

C++
NResult N_API NParameterDescriptorGetStdValue(HNParameterDescriptor hParameterDescriptor, NInt index, struct NNameValuePair_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNParameterDescriptor hParameterDescriptor | [in] Handle to the parameter descriptor.
NInt index | [in] Index of the standard value.
struct NNameValuePair_ * pValue | [out] Pointer to the standard value of the parameter.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NParameterDescriptor.h

Module: NParameterDescriptor Unit


NParameterDescriptorGetStdValueCount Function

NParameterDescriptorGetStdValueCount Function
NParameterDescriptor.h

Retrieves the number of standard parameter descriptor values.

C++
NResult N_API NParameterDescriptorGetStdValueCount(HNParameterDescriptor hParameterDescriptor, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNParameterDescriptor hParameterDescriptor | [in] Handle to the parameter descriptor.
NInt * pValue | [out] Number of standard parameter descriptor values.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NParameterDescriptor.h

Module: NParameterDescriptor Unit


NParameterDescriptorGetStdValues Function

NParameterDescriptorGetStdValues Function
NParameterDescriptor.h

Gets all standard values of the specified parameter descriptor.

C++
NResult N_API NParameterDescriptorGetStdValues(HNParameterDescriptor hParameterDescriptor, struct NNameValuePair_ * * parValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNParameterDescriptor hParameterDescriptor | [in] Handle to NParameterDescriptor.
struct NNameValuePair_ * * parValues | [out] Pointer to the array of standard values.
NInt * pValueCount | [out] Pointer to the number of values in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NParameterDescriptor.h

Module: NParameterDescriptor Unit


NParameterDescriptor.h

NParameterDescriptor.h
Functions Legend

Header file for the NParameterDescriptor module.

Collapse Expand Functions
Name | Description
NParameterDescriptorGetDefaultValue | Retrieves the default value of the specified parameter descriptor.
NParameterDescriptorGetFormat | Retrieves the format value of the specified parameter descriptor.
NParameterDescriptorGetMaxValue | Retrieves the maximum value of the specified parameter descriptor.
NParameterDescriptorGetMinValue | Retrieves the minimum value of the specified parameter descriptor.
NParameterDescriptorGetParameterType | Retrieves the parameter type of the specified parameter descriptor.
NParameterDescriptorGetStdValue | Retrieves the specified standard value of the specified parameter descriptor.
NParameterDescriptorGetStdValueCount | Retrieves the number of standard parameter descriptor values.
NParameterDescriptorGetStdValues | Gets all standard values of the specified parameter descriptor.


NParameterInfo Unit

NParameterInfo Unit
Files Functions Legend

Provides functionality to retrieve information about parameters.

Collapse Expand Files
Name | Description
NParameterInfo.h | Header file for the NParameterInfo unit.
Collapse Expand Functions
Name | Description
NParameterInfoGetAttributes | Retrieves the attributes of the specified parameter.
NParameterInfoGetDefaultValue | Retrieves the default value of the specified parameter.
NParameterInfoGetFormat | Retrieves the format of the specified parameter.
NParameterInfoGetMaxValue | Retrieves the maximal value of the specified parameter.
NParameterInfoGetMinValue | Retrieves the minimal value of the specified parameter.
NParameterInfoGetName | Retrieves the name of the specified parameter.
NParameterInfoGetParameterType | Retrieves the type of the parameter.
NParameterInfoGetStdValue | Retrieves the specified standard value of the specified parameter.
NParameterInfoGetStdValueCount | Retrieves the number of standard values of the specified parameter.
NParameterInfoGetStdValues | Retrieves all standard values of the specified parameter.


NParameterInfoGetAttributes Function

NParameterInfoGetAttributes Function
NParameterInfo.h

Retrieves the attributes of the specified parameter.

C++
NResult N_API NParameterInfoGetAttributes(HNParameterInfo hParameterInfo, NAttributes * pValue);
Collapse Expand Parameters
Parameters | Description
HNParameterInfo hParameterInfo | [in] Handle to the parameter information.
NAttributes * pValue | [out] Pointer to the attributes of the parameter.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NParameterInfo.h

Module: NParameterInfo Unit


NParameterInfoGetDefaultValue Function

NParameterInfoGetDefaultValue Function
NParameterInfo.h

Retrieves the default value of the specified parameter.

C++
NResult N_API NParameterInfoGetDefaultValue(HNParameterInfo hParameterInfo, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
HNParameterInfo hParameterInfo | [in] Handle to the parameter information.
HNValue * phValue | [out] Pointer to the default value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NParameterInfo.h

Module: NParameterInfo Unit


NParameterInfoGetFormat Function

NParameterInfoGetFormat Function
NParameterInfo.h

Retrieves the format of the specified parameter.

C++
NResult N_API NParameterInfoGetFormat(HNParameterInfo hParameterInfo, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNParameterInfo hParameterInfo | [in] Handle to the parameter information.
HNString * phValue | [out] Pointer to the format string of the specified parameter.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NParameterInfo.h

Module: NParameterInfo Unit


NParameterInfoGetMaxValue Function

NParameterInfoGetMaxValue Function
NParameterInfo.h

Retrieves the maximal value of the specified parameter.

C++
NResult N_API NParameterInfoGetMaxValue(HNParameterInfo hParameterInfo, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
HNParameterInfo hParameterInfo | [in] Handle to the parameter information.
HNValue * phValue | [out] Pointer to the maximal value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NParameterInfo.h

Module: NParameterInfo Unit


NParameterInfoGetMinValue Function

NParameterInfoGetMinValue Function
NParameterInfo.h

Retrieves the minimal value of the specified parameter.

C++
NResult N_API NParameterInfoGetMinValue(HNParameterInfo hParameterInfo, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
HNParameterInfo hParameterInfo | [in] Handle to the parameter information.
HNValue * phValue | [out] Pointer to the minimal value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NParameterInfo.h

Module: NParameterInfo Unit


NParameterInfoGetName Function

NParameterInfoGetName Function
NParameterInfo.h

Retrieves the name of the specified parameter.

C++
NResult N_API NParameterInfoGetName(HNParameterInfo hParameterInfo, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNParameterInfo hParameterInfo | [in] Handle to the parameter information.
HNString * phValue | [out] Pointer to the name of the parameter.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NParameterInfo.h

Module: NParameterInfo Unit


NParameterInfoGetParameterType Function

NParameterInfoGetParameterType Function
NParameterInfo.h

Retrieves the type of the parameter.

C++
NResult N_API NParameterInfoGetParameterType(HNParameterInfo hParameterInfo, HNType * phValue);
Collapse Expand Parameters
Parameters | Description
HNParameterInfo hParameterInfo | [in] Handle to the parameter information.
HNType * phValue | [out] Pointer to the type of the parameter.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NParameterInfo.h

Module: NParameterInfo Unit


NParameterInfoGetStdValue Function

NParameterInfoGetStdValue Function
NParameterInfo.h

Retrieves the specified standard value of the specified parameter.

C++
NResult N_API NParameterInfoGetStdValue(HNParameterInfo hParameterInfo, NInt index, struct NNameValuePair_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNParameterInfo hParameterInfo | [in] Handle to the parameter information.
NInt index | [in] Index of the standard value.
struct NNameValuePair_ * pValue | [out] Pointer to the standard value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NParameterInfo.h

Module: NParameterInfo Unit


NParameterInfoGetStdValueCount Function

NParameterInfoGetStdValueCount Function
NParameterInfo.h

Retrieves the number of standard values of the specified parameter.

C++
NResult N_API NParameterInfoGetStdValueCount(HNParameterInfo hParameterInfo, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNParameterInfo hParameterInfo | [in] Handle to the parameter information.
NInt * pValue | [out] Pointer to the number of standard values.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NParameterInfo.h

Module: NParameterInfo Unit


NParameterInfoGetStdValues Function

NParameterInfoGetStdValues Function
NParameterInfo.h

Retrieves all standard values of the specified parameter.

C++
NResult N_API NParameterInfoGetStdValues(HNParameterInfo hParameterInfo, struct NNameValuePair_ * * parValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNParameterInfo hParameterInfo | [in] Handle to the parameter information.
struct NNameValuePair_ * * parValues | [out] Pointer to an array of standard values.
NInt * pValueCount | [out] Pointer to the number of values in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NParameterInfo.h

Module: NParameterInfo Unit


NParameterInfo.h

NParameterInfo.h
Functions Legend

Header file for the NParameterInfo unit.

Collapse Expand Functions
Name | Description
NParameterInfoGetAttributes | Retrieves the attributes of the specified parameter.
NParameterInfoGetDefaultValue | Retrieves the default value of the specified parameter.
NParameterInfoGetFormat | Retrieves the format of the specified parameter.
NParameterInfoGetMaxValue | Retrieves the maximal value of the specified parameter.
NParameterInfoGetMinValue | Retrieves the minimal value of the specified parameter.
NParameterInfoGetName | Retrieves the name of the specified parameter.
NParameterInfoGetParameterType | Retrieves the type of the parameter.
NParameterInfoGetStdValue | Retrieves the specified standard value of the specified parameter.
NParameterInfoGetStdValueCount | Retrieves the number of standard values of the specified parameter.
NParameterInfoGetStdValues | Retrieves all standard values of the specified parameter.


NPath Unit

NPath Unit
Files Functions Legend Macros

Performs operations on String instances that contain file or directory path information. These operations are performed in a cross-platform manner.

Collapse Expand Files
Name | Description
NPath.h | Header file for the NPath unit.
Collapse Expand Functions
Name | Description
NPathChangeExtension | Changes the extension of a path string.
NPathChangeExtensionPN | Changes the extension of a path string.
NPathCheck | Checks whether the specified path is valid and throws an exception if the path is not valid.
NPathCheckN | Checks whether the specified path is valid and throws an exception if the path is not valid.
NPathCombine | Combines two strings into a path.
NPathCombineP1N | Combines two strings into a path.
NPathCombineP2N | Combines two strings into a path.
NPathGetDirectoryName | Returns the directory information for the specified path string.
NPathGetExtension | Returns the extension of the specified path string.
NPathGetFileName | Returns the file name and extension of the specified path string.
NPathGetFileNameWithoutExtension | Returns the file name of the specified path string without the extension.
NPathGetTempFileName | Creates a uniquely named, zero-byte temporary file on disk and returns the full path of that file.
NPathGetTempPath | Returns the path of the current user's temporary folder.
NPathHasExtension | Determines whether a path includes a file name extension.
NPathIsRooted | Gets a value indicating whether the specified path string contains a root.
Collapse Expand Macros
Name | Description
NPathChangeExtension | Picks a Unicode (W) or ASCII (A) version of the NPathChangeExtension function.
NPathChangeExtensionPN | Picks a Unicode (W) or ASCII (A) version of the NPathChangeExtensionPN function.
NPathCheck | Picks a Unicode (W) or ASCII (A) version of the NPathCheck function.
NPathCombine | Picks a Unicode (W) or ASCII (A) version of the NPathCombine function.
NPathCombineP1N | Picks a Unicode (W) or ASCII (A) version of the NPathCombineP1N function.
NPathCombineP2N | Picks a Unicode (W) or ASCII (A) version of the NPathCombineP2N function.
NPathGetDirectoryName | Picks a Unicode (W) or ASCII (A) version of the NPathGetDirectoryName function.
NPathGetExtension | Picks a Unicode (W) or ASCII (A) version of the NPathGetExtension function.
NPathGetFileName | Picks a Unicode (W) or ASCII (A) version of the NPathGetFileName function.
NPathGetFileNameWithoutExtension | Picks a Unicode (W) or ASCII (A) version of the NPathGetFileNameWithoutExtension function.
NPathHasExtension | Picks a Unicode (W) or ASCII (A) version of the NPathHasExtension function.
NPathIsRooted | Picks a Unicode (W) or ASCII (A) version of the NPathIsRooted function.
N_MAX_FILE_NAME | Specifies the maximum file name length.
N_PATH_ALT_DIRECTORY_SEPARATOR | Picks a Unicode (W) or ANSCII (A) version of the N_PATH_PATH_SEPARATOR macro which specifies an alternate character used to separate directory levels in a path string that reflects a hierarchical file system organization.
N_PATH_DIRECTORY_SEPARATOR | Picks a Unicode (W) or ANSCII (A) version of the N_PATH_PATH_SEPARATOR macro which specifies a character used to separate directory levels in a path string that reflects a hierarchical file system organization.
N_PATH_IS_CASE_SENSITIVE | Specifies whether the path is case sensitive.
N_PATH_PATH_SEPARATOR | Picks a Unicode (W) or ANSCII (A) version of the N_PATH_PATH_SEPARATOR macro which specifies a separator character used to separate path strings in environment variables.
N_PATH_VOLUME_SEPARATOR | Picks a Unicode (W) or ANSCII (A) version of the N_PATH_PATH_SEPARATOR macro which specifies a volume separator character.


NPathChangeExtension Function

NPathChangeExtension Function
NPath.h

Changes the extension of a path string.

C++
NResult N_API NPathChangeExtension(const NChar * szPath, const NChar * szExtension, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
const NChar * szPath | [in] Pointer to the path string.
const NChar * szExtension | [in] Pointer to the new extension (with or without a leading period).
HNString * phValue | [out] Pointer to a handle to the modified path information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPath.h

Module: NPath Unit


NPathChangeExtensionPN Function

NPathChangeExtensionPN Function
NPath.h

Changes the extension of a path string.

C++
NResult N_API NPathChangeExtensionPN(HNString hPath, const NChar * szExtension, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNString hPath | [in] Handle to the path string.
const NChar * szExtension | [in] Pointer to the new extension (with or without a leading period).
HNString * phValue | [out] Pointer to a handle to the modified path information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPath.h

Module: NPath Unit


NPathCheck Function

NPathCheck Function
NPath.h

Checks whether the specified path is valid and throws an exception if the path is not valid.

C++
NResult N_API NPathCheck(const NChar * szValue);
Collapse Expand Parameters
Parameters | Description
const NChar * szValue | [in] Pointer to path to be checked.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPath.h

Module: NPath Unit


NPathCheckN Function

NPathCheckN Function
NPath.h

Checks whether the specified path is valid and throws an exception if the path is not valid.

C++
NResult N_API NPathCheckN(HNString hValue);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] Handle to path to be checked.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPath.h

Module: NPath Unit


NPathCombine Function

NPathCombine Function
NPath.h

Combines two strings into a path.

C++
NResult N_API NPathCombine(const NChar * szPath1, const NChar * szPath2, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
const NChar * szPath1 | [in] Pointer to the first path to combine.
const NChar * szPath2 | [in] Pointer to the second path to combine.
HNString * phValue | [out] Pointer to a handle to the combined paths.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Notes

If one of the specified paths is a zero-length string, this method returns the other path. If szPath2 contains an absolute path, this method returns szPath2.

Container

File: NPath.h

Module: NPath Unit


NPathCombineP1N Function

NPathCombineP1N Function
NPath.h

Combines two strings into a path.

C++
NResult N_API NPathCombineP1N(HNString hPath1, const NChar * szPath2, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNString hPath1 | [in] Handle to the first path to combine.
const NChar * szPath2 | [in] Pointer to the second path to combine.
HNString * phValue | [out] Pointer to a handle to the combined paths.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Notes

If one of the specified paths is a zero-length string, this method returns the other path. If szPath2 contains an absolute path, this method returns szPath2.

Container

File: NPath.h

Module: NPath Unit


NPathCombineP2N Function

NPathCombineP2N Function
NPath.h

Combines two strings into a path.

C++
NResult N_API NPathCombineP2N(const NChar * szPath1, HNString hPath2, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
const NChar * szPath1 | [in] Pointer to the first path to combine.
HNString hPath2 | [in] Handle to the second path to combine.
HNString * phValue | [out] Pointer to a handle to the combined paths.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Notes

If one of the specified paths is a zero-length string, this method returns the other path. If szPath2 contains an absolute path, this method returns szPath2.

Container

File: NPath.h

Module: NPath Unit


NPathGetDirectoryName Function

NPathGetDirectoryName Function
NPath.h

Returns the directory information for the specified path string.

C++
NResult N_API NPathGetDirectoryName(const NChar * szPath, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
const NChar * szPath | [in] Pointer to the path of a file or directory.
HNString * phValue | [out] Pointer to a handle to the directory information for path.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPath.h

Module: NPath Unit


NPathGetExtension Function

NPathGetExtension Function
NPath.h

Returns the extension of the specified path string.

C++
NResult N_API NPathGetExtension(const NChar * szPath, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
const NChar * szPath | [in] Pointer the path string from which to get the extension.
HNString * phValue | [out] Pointer to a handle to the extension of the specified path (including the period ".").
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPath.h

Module: NPath Unit


NPathGetFileName Function

NPathGetFileName Function
NPath.h

Returns the file name and extension of the specified path string.

C++
NResult N_API NPathGetFileName(const NChar * szPath, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
const NChar * szPath | [in] Pointer the path string from which to get the file name.
HNString * phValue | [out] Pointer to a handle to the file name and extension of the specified path (including the period ".").
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPath.h

Module: NPath Unit


NPathGetFileNameWithoutExtension Function

NPathGetFileNameWithoutExtension Function
NPath.h

Returns the file name of the specified path string without the extension.

C++
NResult N_API NPathGetFileNameWithoutExtension(const NChar * szPath, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
const NChar * szPath | [in] Pointer the path string from which to get the file name.
HNString * phValue | [out] Pointer to a handle to the file name.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPath.h

Module: NPath Unit


NPathGetTempFileName Function

NPathGetTempFileName Function
NPath.h

Creates a uniquely named, zero-byte temporary file on disk and returns the full path of that file.

C++
NResult N_API NPathGetTempFileName(HNString * phFileName);
Collapse Expand Parameters
Parameters | Description
HNString * phFileName | [out] Pointer to a handle to the path string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPath.h

Module: NPath Unit


NPathGetTempPath Function

NPathGetTempPath Function
NPath.h

Returns the path of the current user's temporary folder.

C++
NResult N_API NPathGetTempPath(HNString * phPath);
Collapse Expand Parameters
Parameters | Description
HNString * phPath | [out] Pointer to a handle to the path string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPath.h

Module: NPath Unit


NPathHasExtension Function

NPathHasExtension Function
NPath.h

Determines whether a path includes a file name extension.

C++
NResult N_API NPathHasExtension(const NChar * szPath, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
const NChar * szPath | [in] Pointer the path string to check.
NBool * pValue | [out] NTrue if the path includes a file name extension; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPath.h

Module: NPath Unit


NPathIsRooted Function

NPathIsRooted Function
NPath.h

Gets a value indicating whether the specified path string contains a root.

C++
NResult N_API NPathIsRooted(const NChar * szPath, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
const NChar * szPath | [in] Pointer the path string to check.
NBool * pValue | [out] NTrue if the path contains a root; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPath.h

Module: NPath Unit


NPathChangeExtension Macro

NPathChangeExtension Macro
NPath.h

Picks a Unicode (W) or ASCII (A) version of the NPathChangeExtension function.

C++
#define NPathChangeExtension N_FUNC_AW(NPathChangeExtension)
Container

File: NPath.h

Module: NPath Unit


NPathChangeExtensionPN Macro

NPathChangeExtensionPN Macro
NPath.h

Picks a Unicode (W) or ASCII (A) version of the NPathChangeExtensionPN function.

C++
#define NPathChangeExtensionPN N_FUNC_AW(NPathChangeExtensionPN)
Container

File: NPath.h

Module: NPath Unit


NPathCheck Macro

NPathCheck Macro
NPath.h

Picks a Unicode (W) or ASCII (A) version of the NPathCheck function.

C++
#define NPathCheck N_FUNC_AW(NPathCheck)
Container

File: NPath.h

Module: NPath Unit


NPathCombine Macro

NPathCombine Macro
NPath.h

Picks a Unicode (W) or ASCII (A) version of the NPathCombine function.

C++
#define NPathCombine N_FUNC_AW(NPathCombine)
Container

File: NPath.h

Module: NPath Unit


NPathCombineP1N Macro

NPathCombineP1N Macro
NPath.h

Picks a Unicode (W) or ASCII (A) version of the NPathCombineP1N function.

C++
#define NPathCombineP1N N_FUNC_AW(NPathCombineP1N)
Container

File: NPath.h

Module: NPath Unit


NPathCombineP2N Macro

NPathCombineP2N Macro
NPath.h

Picks a Unicode (W) or ASCII (A) version of the NPathCombineP2N function.

C++
#define NPathCombineP2N N_FUNC_AW(NPathCombineP2N)
Container

File: NPath.h

Module: NPath Unit


NPathGetDirectoryName Macro

NPathGetDirectoryName Macro
NPath.h

Picks a Unicode (W) or ASCII (A) version of the NPathGetDirectoryName function.

C++
#define NPathGetDirectoryName N_FUNC_AW(NPathGetDirectoryName)
Container

File: NPath.h

Module: NPath Unit


NPathGetExtension Macro

NPathGetExtension Macro
NPath.h

Picks a Unicode (W) or ASCII (A) version of the NPathGetExtension function.

C++
#define NPathGetExtension N_FUNC_AW(NPathGetExtension)
Container

File: NPath.h

Module: NPath Unit


NPathGetFileName Macro

NPathGetFileName Macro
NPath.h

Picks a Unicode (W) or ASCII (A) version of the NPathGetFileName function.

C++
#define NPathGetFileName N_FUNC_AW(NPathGetFileName)
Container

File: NPath.h

Module: NPath Unit


NPathGetFileNameWithoutExtension Macro

NPathGetFileNameWithoutExtension Macro
NPath.h

Picks a Unicode (W) or ASCII (A) version of the NPathGetFileNameWithoutExtension function.

C++
#define NPathGetFileNameWithoutExtension N_FUNC_AW(NPathGetFileNameWithoutExtension)
Container

File: NPath.h

Module: NPath Unit


NPathHasExtension Macro

NPathHasExtension Macro
NPath.h

Picks a Unicode (W) or ASCII (A) version of the NPathHasExtension function.

C++
#define NPathHasExtension N_FUNC_AW(NPathHasExtension)
Container

File: NPath.h

Module: NPath Unit


NPathIsRooted Macro

NPathIsRooted Macro
NPath.h

Picks a Unicode (W) or ASCII (A) version of the NPathIsRooted function.

C++
#define NPathIsRooted N_FUNC_AW(NPathIsRooted)
Container

File: NPath.h

Module: NPath Unit


N_MAX_FILE_NAME Macro

N_MAX_FILE_NAME Macro
NPath.h

Specifies the maximum file name length.

C++
#define N_MAX_FILE_NAME 256
Container

File: NPath.h

Module: NPath Unit


N_PATH_ALT_DIRECTORY_SEPARATOR Macro

N_PATH_ALT_DIRECTORY_SEPARATOR Macro
NPath.h

Picks a Unicode (W) or ANSCII (A) version of the N_PATH_PATH_SEPARATOR macro which specifies an alternate character used to separate directory levels in a path string that reflects a hierarchical file system organization.

C++
#define N_PATH_ALT_DIRECTORY_SEPARATOR N_MACRO_AW(N_PATH_ALT_DIRECTORY_SEPARATOR)
Container

File: NPath.h

Module: NPath Unit


N_PATH_DIRECTORY_SEPARATOR Macro

N_PATH_DIRECTORY_SEPARATOR Macro
NPath.h

Picks a Unicode (W) or ANSCII (A) version of the N_PATH_PATH_SEPARATOR macro which specifies a character used to separate directory levels in a path string that reflects a hierarchical file system organization.

C++
#define N_PATH_DIRECTORY_SEPARATOR N_MACRO_AW(N_PATH_DIRECTORY_SEPARATOR)
Container

File: NPath.h

Module: NPath Unit


N_PATH_IS_CASE_SENSITIVE Macro

N_PATH_IS_CASE_SENSITIVE Macro
NPath.h

Specifies whether the path is case sensitive.

C++
#define N_PATH_IS_CASE_SENSITIVE NTrue
Container

File: NPath.h

Module: NPath Unit


N_PATH_PATH_SEPARATOR Macro

N_PATH_PATH_SEPARATOR Macro
NPath.h

Picks a Unicode (W) or ANSCII (A) version of the N_PATH_PATH_SEPARATOR macro which specifies a separator character used to separate path strings in environment variables.

C++
#define N_PATH_PATH_SEPARATOR N_MACRO_AW(N_PATH_PATH_SEPARATOR)
Container

File: NPath.h

Module: NPath Unit


N_PATH_VOLUME_SEPARATOR Macro

N_PATH_VOLUME_SEPARATOR Macro
NPath.h

Picks a Unicode (W) or ANSCII (A) version of the N_PATH_PATH_SEPARATOR macro which specifies a volume separator character.

C++
#define N_PATH_VOLUME_SEPARATOR N_MACRO_AW(N_PATH_VOLUME_SEPARATOR)
Container

File: NPath.h

Module: NPath Unit


NPath.h

NPath.h
Functions Legend Macros

Header file for the NPath unit.

Collapse Expand Functions
Name | Description
NPathChangeExtension | Changes the extension of a path string.
NPathChangeExtensionPN | Changes the extension of a path string.
NPathCheck | Checks whether the specified path is valid and throws an exception if the path is not valid.
NPathCheckN | Checks whether the specified path is valid and throws an exception if the path is not valid.
NPathCombine | Combines two strings into a path.
NPathCombineP1N | Combines two strings into a path.
NPathCombineP2N | Combines two strings into a path.
NPathGetDirectoryName | Returns the directory information for the specified path string.
NPathGetExtension | Returns the extension of the specified path string.
NPathGetFileName | Returns the file name and extension of the specified path string.
NPathGetFileNameWithoutExtension | Returns the file name of the specified path string without the extension.
NPathGetTempFileName | Creates a uniquely named, zero-byte temporary file on disk and returns the full path of that file.
NPathGetTempPath | Returns the path of the current user's temporary folder.
NPathHasExtension | Determines whether a path includes a file name extension.
NPathIsRooted | Gets a value indicating whether the specified path string contains a root.
Collapse Expand Macros
Name | Description
NPathChangeExtension | Picks a Unicode (W) or ASCII (A) version of the NPathChangeExtension function.
NPathChangeExtensionPN | Picks a Unicode (W) or ASCII (A) version of the NPathChangeExtensionPN function.
NPathCheck | Picks a Unicode (W) or ASCII (A) version of the NPathCheck function.
NPathCombine | Picks a Unicode (W) or ASCII (A) version of the NPathCombine function.
NPathCombineP1N | Picks a Unicode (W) or ASCII (A) version of the NPathCombineP1N function.
NPathCombineP2N | Picks a Unicode (W) or ASCII (A) version of the NPathCombineP2N function.
NPathGetDirectoryName | Picks a Unicode (W) or ASCII (A) version of the NPathGetDirectoryName function.
NPathGetExtension | Picks a Unicode (W) or ASCII (A) version of the NPathGetExtension function.
NPathGetFileName | Picks a Unicode (W) or ASCII (A) version of the NPathGetFileName function.
NPathGetFileNameWithoutExtension | Picks a Unicode (W) or ASCII (A) version of the NPathGetFileNameWithoutExtension function.
NPathHasExtension | Picks a Unicode (W) or ASCII (A) version of the NPathHasExtension function.
NPathIsRooted | Picks a Unicode (W) or ASCII (A) version of the NPathIsRooted function.
N_MAX_FILE_NAME | Specifies the maximum file name length.
N_PATH_ALT_DIRECTORY_SEPARATOR | Picks a Unicode (W) or ANSCII (A) version of the N_PATH_PATH_SEPARATOR macro which specifies an alternate character used to separate directory levels in a path string that reflects a hierarchical file system organization.
N_PATH_DIRECTORY_SEPARATOR | Picks a Unicode (W) or ANSCII (A) version of the N_PATH_PATH_SEPARATOR macro which specifies a character used to separate directory levels in a path string that reflects a hierarchical file system organization.
N_PATH_IS_CASE_SENSITIVE | Specifies whether the path is case sensitive.
N_PATH_PATH_SEPARATOR | Picks a Unicode (W) or ANSCII (A) version of the N_PATH_PATH_SEPARATOR macro which specifies a separator character used to separate path strings in environment variables.
N_PATH_VOLUME_SEPARATOR | Picks a Unicode (W) or ANSCII (A) version of the N_PATH_PATH_SEPARATOR macro which specifies a volume separator character.


NPlugin Unit

NPlugin Unit
Files Functions Legend Structs, Records, Enums

Plug-in management framework for use in other Neurotechnology components.

Collapse Expand Files
Name | Description
NPlugin.h | Header file for plugins management framework.
Collapse Expand Functions
Name | Description
NPluginDisable | Adds plugin's name to disabled plugins collection.
NPluginEnable | Removes plugin's name from disabled plugins collection.
NPluginGetError | Returns the most recent error for the specified NPlugin.
NPluginGetFileNameN | Returns plug-in library name.
NPluginGetLoadTime | Returns plug-in load time.
NPluginGetModule | Gets module for specified NPlugin.
NPluginGetPlugTime | Returns plug-in plug time (nanoseconds).
NPluginGetSelectedInterfaceVersion | Returns current version of selected plugin interface.
NPluginGetState | Returns the state of specified plugin.
NPluginPlug | Plugs specified plug-in to the system.
NPluginUnplug | Unplugs specified plug-in from the system.
Collapse Expand Structs, Records, Enums
Name | Description
NPluginState_ | Enumerates NPlugin state values.
NPluginState | Enumerates NPlugin state values.


NPluginDisable Function

NPluginDisable Function
NPlugin.h

Adds plugin's name to disabled plugins collection.

C++
NResult N_API NPluginDisable(HNPlugin hPlugin);
Collapse Expand Parameters
Parameters | Description
HNPlugin hPlugin | [in] Handle to NPlugin to disable.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise error code is returned. NSucceeded or NFailed macros can be used to detect whether the function succeeded or failed.

Container

File: NPlugin.h

Module: NPlugin Unit


NPluginEnable Function

NPluginEnable Function
NPlugin.h

Removes plugin's name from disabled plugins collection.

C++
NResult N_API NPluginEnable(HNPlugin hPlugin);
Collapse Expand Parameters
Parameters | Description
HNPlugin hPlugin | [in] Handle to NPlugin to enable.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise error code is returned. NSucceeded or NFailed macros can be used to detect whether the function succeeded or failed.

Container

File: NPlugin.h

Module: NPlugin Unit


NPluginGetError Function

NPluginGetError Function
NPlugin.h

Returns the most recent error for the specified NPlugin.

C++
NResult N_API NPluginGetError(HNPlugin hPlugin, HNError * phValue);
Collapse Expand Parameters
Parameters | Description
HNPlugin hPlugin | [in] Handle to NPlugin to retrieve its error.
HNError * phValue | [out] Pointer to NError.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise error code is returned. NSucceeded or NFailed macros can be used to detect whether the function succeeded or failed.

Collapse Expand Remarks

NObjectUnref shall be called on returned objects when they are no longer used to prevent memory leaks.

Container

File: NPlugin.h

Module: NPlugin Unit


NPluginGetFileNameN Function

NPluginGetFileNameN Function
NPlugin.h

Returns plug-in library name.

C++
NResult N_API NPluginGetFileNameN(HNPlugin hPlugin, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNPlugin hPlugin | [in] Handle to NPlugin to retrieve its library name.
HNString * phValue | [out] Pointer to NString which contains library file name.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise error code is returned. NSucceeded or NFailed macros can be used to detect whether the function succeeded or failed.

Container

File: NPlugin.h

Module: NPlugin Unit


NPluginGetLoadTime Function

NPluginGetLoadTime Function
NPlugin.h

Returns plug-in load time.

C++
NResult N_API NPluginGetLoadTime(HNPlugin hPlugin, NTimeSpan_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNPlugin hPlugin | [in] Handle to NPlugin to retrieve its plugin load time.
NTimeSpan_ * pValue | [out] Plugin load time.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise error code is returned. NSucceeded or NFailed macros can be used to detect whether the function succeeded or failed.

Container

File: NPlugin.h

Module: NPlugin Unit


NPluginGetModule Function

NPluginGetModule Function
NPlugin.h

Gets module for specified NPlugin.

C++
NResult N_API NPluginGetModule(HNPlugin hPlugin, HNPluginModule * phValue);
Collapse Expand Parameters
Parameters | Description
HNPlugin hPlugin | [in] A handle to NPlugin.
HNPluginModule * phValue | [out] A pointer to NPluginModule.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

NObjectUnref shall be called on returned objects when they are no longer used to prevent memory leaks.

Container

File: NPlugin.h

Module: NPlugin Unit


NPluginGetPlugTime Function

NPluginGetPlugTime Function
NPlugin.h

Returns plug-in plug time (nanoseconds).

C++
NResult N_API NPluginGetPlugTime(HNPlugin hPlugin, NTimeSpan_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNPlugin hPlugin | [in] Handle to NPlugin.
NTimeSpan_ * pValue | [out] Plug time in nanoseconds.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise error code is returned. NSucceeded or NFailed macros can be used to detect whether the function succeeded or failed.

Container

File: NPlugin.h

Module: NPlugin Unit


NPluginGetSelectedInterfaceVersion Function

NPluginGetSelectedInterfaceVersion Function
NPlugin.h

Returns current version of selected plugin interface.

C++
NResult N_API NPluginGetSelectedInterfaceVersion(HNPlugin hPlugin, NVersion_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNPlugin hPlugin | [in] Handle to plugin to retrieve its version.
NVersion_ * pValue | [out] Interface version.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise error code is returned. NSucceeded or NFailed macros can be used to detect whether the function succeeded or failed.

Collapse Expand Notes

NVersionRange* and NVersion* macros can be used to parse version range.

Container

File: NPlugin.h

Module: NPlugin Unit


NPluginGetState Function

NPluginGetState Function
NPlugin.h

Returns the state of specified plugin.

C++
NResult N_API NPluginGetState(HNPlugin hPlugin, NPluginState * pValue);
Collapse Expand Parameters
Parameters | Description
HNPlugin hPlugin | [in] Handle to NPlugin to retrieve its state.
NPluginState * pValue | [out] Pointer to NPluginState enumeration.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise error code is returned. NSucceeded or NFailed macros can be used to detect whether the function succeeded or failed.

Container

File: NPlugin.h

Module: NPlugin Unit


NPluginPlug Function

NPluginPlug Function
NPlugin.h

Plugs specified plug-in to the system.

C++
NResult N_API NPluginPlug(HNPlugin hPlugin);
Collapse Expand Parameters
Parameters | Description
HNPlugin hPlugin | [in] Handle to NPlugin.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise error code is returned. NSucceeded or NFailed macros can be used to detect whether the function succeeded or failed.

Collapse Expand Notes

The requested plugin might not be plugged into the system immediately. If there is no potential users (device managers) for provided device types, the plugin's state will be set to npsUnused. The plugin will be automatically plugged later, once device manager of appropriate type is created.

Container

File: NPlugin.h

Module: NPlugin Unit


NPluginUnplug Function

NPluginUnplug Function
NPlugin.h

Unplugs specified plug-in from the system.

C++
NResult N_API NPluginUnplug(HNPlugin hPlugin);
Collapse Expand Parameters
Parameters | Description
HNPlugin hPlugin | [in] Handle to NPlugin.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise error code is returned. NSucceeded or NFailed macros can be used to detect whether the function succeeded or failed.

Collapse Expand Notes
  • The function is not mandatory as plugin will be unplugged automatically when it becomes unused. Not calling a function would have effect that plugin would be later plugged automatically when needed.
  • If the function is called the plugin's state will be set to npsUnplugged and plugin will not be automatically plugged later.
  • The function can be used to force unplug even if devices provided by the plugin are still in use.
Container

File: NPlugin.h

Module: NPlugin Unit


NPluginState Enumeration

NPluginState Enumeration
NPlugin.h

Enumerates NPlugin state values.

C++
typedef enum NPluginState_ {
  npsNone = 0,
  npsLoadError = 1,
  npsNotRecognized = 2,
  npsInvalidModule = 3,
  npsInterfaceTypeMismatch = 4,
  npsInterfaceVersionMismatch = 5,
  npsInvalidInterface = 6,
  npsUnplugged = 64,
  npsUnused = 65,
  npsDisabled = 66,
  npsDuplicate = 67,
  npsIncompatibleWithOtherPlugins = 68,
  npsPluggingError = 69,
  npsPlugged = 128
} NPluginState;
Collapse Expand Members
Members | Description
npsNone = 0 | Indicates that plugin has no state.
npsLoadError = 1 |
npsNotRecognized = 2 |
npsInvalidModule = 3 | Indicates invalid plugin module. The plugin's ModuleOf function (see: npsNotRecognized) was found, but the returned handle was wrong.
npsInterfaceTypeMismatch = 4 | Indicates that plugin's interface type differs from expected type. This means that the plugin is for other product/application. Interface type can be retrieved using NPluginModuleGetInterfaceType function.
npsInterfaceVersionMismatch = 5 | Indicates that plug-in interface version mismatches. This means that plugin is of the right type, but has version incompatible with versions supported by current plugin loader. Interface version can be retrieved using NPluginGetInterfaceVersions function.
npsInvalidInterface = 6 | Indicates that the plugin's interface didn't pass the validation check. This happens when some mandatory functions required for plugin are missing or return wrong value.
npsUnplugged = 64 | Indicates that plugin is not connected into the system. The plugin will not be used by the system unless activated with NPluginPlug or NPluginManagerPlugAll/NPluginManagerRefresh functions.
npsUnused = 65 | Indicates that plugin is activated (with NPluginPlug or NPluginManagerPlugAll/NPluginManagerRefresh) but not currently used (not plugged into the system because there are no potential users of the plugin). The plugin will be automatically plugged once device manager of appropriate type is created (see: npsPlugged).
npsDisabled = 66 | Indicates that plugin is disabled, i.e. it's name is present in disabled plugins collection.
npsDuplicate = 67 | Indicates that plugin is unusable because the NPluginManager already contains plugin with the same name.
npsIncompatibleWithOtherPlugins = 68 | Indicates that the current plugin is incompatible with other plugin in the system. Each plugin has a priority value which determines which of the incompatible plugins will be loaded. The plugin with the highest priority will be loaded, and other plugins will fail with npsIncompatibleWithOtherPlugins state.
npsPluggingError = 69 | Indicates that an error occurred when plugging the plugin. NPluginGetErrorCode and NPluginGetError can be used to retrieve error code and error message.
npsPlugged = 128 | Indicates that plugin is activated and the provided functionality can be used by the system. If all the device managers enumerating the devices provided by the current plugin are terminated, the plugin will be automatically unplugged and it's state changed to npsUnused.
Container

File: NPlugin.h

Module: NPlugin Unit


NPlugin.h

NPlugin.h
Enumerations Functions Legend

Header file for plugins management framework.

Collapse Expand Enumerations
Name | Description
NPluginState_ | Enumerates NPlugin state values.
NPluginState | Enumerates NPlugin state values.
Collapse Expand Functions
Name | Description
NPluginDisable | Adds plugin's name to disabled plugins collection.
NPluginEnable | Removes plugin's name from disabled plugins collection.
NPluginGetError | Returns the most recent error for the specified NPlugin.
NPluginGetFileNameN | Returns plug-in library name.
NPluginGetLoadTime | Returns plug-in load time.
NPluginGetModule | Gets module for specified NPlugin.
NPluginGetPlugTime | Returns plug-in plug time (nanoseconds).
NPluginGetSelectedInterfaceVersion | Returns current version of selected plugin interface.
NPluginGetState | Returns the state of specified plugin.
NPluginPlug | Plugs specified plug-in to the system.
NPluginUnplug | Unplugs specified plug-in from the system.


NPluginEventDescriptor Unit

NPluginEventDescriptor Unit
Files Functions Legend

Provides functionality for creating plugin event descriptors.

Collapse Expand Files
Name | Description
NPluginEventDescriptor.h | Header file for the NPluginEventDescriptor unit.
Collapse Expand Functions
Name | Description
NPluginEventDescriptorCreate | Creates a new plugin event descriptor.


NPluginEventDescriptorCreate Function

NPluginEventDescriptorCreate Function
NPluginEventDescriptor.h

Creates a new plugin event descriptor.

C++
NResult N_API NPluginEventDescriptorCreate(HNString hName, HNType hEventType, NAttributes attributes, HNValue hData, HNCallback hAddHandler, HNCallback hRemoveHandler, HNPluginEventDescriptor * phEventDescriptor);
Collapse Expand Parameters
Parameters | Description
HNString hName | [in] Handle to the descriptor name.
HNType hEventType | [in] Handle to the event type.
NAttributes attributes | [in] Descriptor attributes.
HNValue hData | [in] Handle to the descriptor data.
HNCallback hAddHandler | [in] Callback for "handler added" event.
HNCallback hRemoveHandler | [in] Callback for "handler removed" event.
HNPluginEventDescriptor * phEventDescriptor | [out] Pointer to the new plugin event descriptor.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPluginEventDescriptor.h

Module: NPluginEventDescriptor Unit


NPluginEventDescriptor.h

NPluginEventDescriptor.h
Functions Legend

Header file for the NPluginEventDescriptor unit.

Collapse Expand Functions
Name | Description
NPluginEventDescriptorCreate | Creates a new plugin event descriptor.


NPluginInternal Unit

NPluginInternal Unit
Functions Legend Macros Structs, Records, Enums
Collapse Expand Functions
Name | Description
NPluginGetSelectedInterface | Retrieves the selected plugin interface.
Collapse Expand Macros
Name | Description
NPluginInterfaceVersionInfoConst | Defines the plugin interface info constant.
Collapse Expand Structs, Records, Enums
Name | Description
NPluginInterfaceVersionInfo_ | Provides plugin interface version information.
NPluginInterfaceVersionInfo | Provides plugin interface version information.


NPluginGetSelectedInterface Function

NPluginGetSelectedInterface Function

Retrieves the selected plugin interface.

C++
NResult N_API NPluginGetSelectedInterface(HNPlugin hPlugin, const void * * ppValue);
Collapse Expand Parameters
Parameters | Description
HNPlugin hPlugin | [in] Handle to the plugin.
const void * * ppValue | [out] Double pointer to the selected interface.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPluginInternal.h

Module: NPluginInternal Unit


NPluginInterfaceVersionInfo Structure

NPluginInterfaceVersionInfo Structure

Provides plugin interface version information.

C++
typedef struct NPluginInterfaceVersionInfo_ {
  NVersionRange_ versionRange;
  const void * pInterface;
} NPluginInterfaceVersionInfo;
Collapse Expand Members
Members | Description
NVersionRange_ versionRange; | Plugin interface version range.
const void * pInterface; | Plugin interface.
Container

File: NPluginInternal.h

Module: NPluginInternal Unit


NPluginInterfaceVersionInfoConst Macro

NPluginInterfaceVersionInfoConst Macro

Defines the plugin interface info constant.

C++
#define NPluginInterfaceVersionInfoConst(majorVersion, minorVersionFrom, minorVersionTo, functionTable) { NVersionRangeMake(NVersionMake(majorVersion, minorVersionFrom), NVersionMake(majorVersion, minorVersionTo)), &(functionTable) }
Collapse Expand Parameters
Parameters | Description
majorVersion | [in] Major version value.
minorVersionFrom | [in] Minor version lower value.
minorVersionTo | [in] Minor version upper value.
functionTable | [in] The function table.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPluginInternal.h

Module: NPluginInternal Unit


NPluginManager Unit

NPluginManager Unit
Files Functions Legend Macros

Provides functions for managing plugins.

Collapse Expand Remarks

All NDeviceManager instances have one NPluginManager. One NPlugin instance can have more than one NDevice which will be visible in one or more NDeviceManagers.

Collapse Expand Files
Name | Description
NPluginManager.h | Header file for NPluginManager. Provides functions for working with NPlugin.
Collapse Expand Functions
Name | Description
NPluginManagerAddDisabledPlugin | Disables plugin specified by name and adds to disabled plugins collection.
NPluginManagerAddDisabledPluginsCollectionChanged | Adds user specified callback for "disabled plugins collection changed" event. This callback is called when disabled plugins collection was changed.
NPluginManagerAddDisabledPluginsCollectionChangedCallback | Adds user specified callback for "disabled plugins collection changed" event. This callback is called when disabled plugins collection was changed.
NPluginManagerAddPlugin | Loads plugin. It's dependencies are searched relative to specified directory.
NPluginManagerAddPluginFromFile | Loads plugin from user specified file.
NPluginManagerAllowsUnplug | Checks whether NPluginPlug and NPluginUnplug functions work
NPluginManagerClearDisabledPlugins | Clears the collection of disabled plugins.
NPluginManagerEnsurePluginSearchPerformed | Trigger plugin search in plugin directory if search hasn't been performed yet.
NPluginManagerGetDisabledPluginCount | Gets disabled plugins count.
NPluginManagerGetDisabledPlugins | Retrieves all disabled plugins in a plugin manager.
NPluginManagerGetInstances | Retrieves the instances of the plugin manager.
NPluginManagerGetInterfaceTypeN | Returns NPluginManager interface type name.
NPluginManagerGetInterfaceVersions | Returns the range of supported interface versions by specified NPluginManager.
NPluginManagerGetPlugin | Returns NPlugin specified by index.
NPluginManagerGetPluginByName | Gets plugin by specified name.
NPluginManagerGetPluginCount | Returns plugins count in specified NPluginManager.
NPluginManagerGetPluginSearchPathN | Gets plugin dependencies search path.
NPluginManagerGetPlugins | Retrieves all plugins in the plugin manager.
NPluginManagerPlugAll | Plugs all enabled plugins into the system.
NPluginManagerRefresh | Refreshes plugins list (search for added/removed plugin files).
NPluginManagerRemoveDisabledPlugin | Removes plugin specified by name from disabled plugins collection.
NPluginManagerRemoveDisabledPluginAt | Removes plugin specified by index from disabled plugins collection.
NPluginManagerRemoveDisabledPluginsCollectionChanged | Removes user specified "disabled plugins collection changed" event.
NPluginManagerRemoveDisabledPluginsCollectionChangedCallback | Removes user specified callback for "disabled plugins collection changed" event.
NPluginManagerRemovePluginsCollectionChanged | Removes user specified "plugins collection changed" event.
NPluginManagerRemovePluginsCollectionChangedCallback | Removes user specified callback for "plugins collection changed" event.
NPluginManagerSetPluginSearchPath | Sets directory which will be automatically searched for plugins.
NPluginManagerUnplugAll | Unplugs all plugins.
Collapse Expand Macros
Name | Description
NPluginManagerAddDisabledPlugin | Picks a Unicode (W) or ASCII (A) version of the NPluginManagerAddDisabledPlugin function.
NPluginManagerAddPlugin | Picks a Unicode (W) or ASCII (A) version of the NPluginManagerAddPlugin function.
NPluginManagerAddPluginFromFile | Picks a Unicode (W) or ASCII (A) version of the NPluginManagerAddPluginFromFile function.
NPluginManagerGetPluginByName | Picks a Unicode (W) or ASCII (A) version of the NPluginManagerGetPluginByName function.
NPluginManagerRemoveDisabledPlugin | Picks a Unicode (W) or ASCII (A) version of the NPluginManagerRemoveDisabledPlugin function.
NPluginManagerSetPluginSearchPath | Picks a Unicode (W) or ASCII (A) version of the NPluginManagerSetPluginSearchPath function.


NPluginManagerAddDisabledPlugin Function

NPluginManagerAddDisabledPlugin Function
NPluginManager.h See Also

Disables plugin specified by name and adds to disabled plugins collection.

C++
NResult N_API NPluginManagerAddDisabledPlugin(HNPluginManager hPluginManager, const NChar * szValue, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
HNPluginManager hPluginManager | [in] Handle to NPluginManager.
const NChar * szValue | [in] Plugin name.
NInt * pIndex | [out] Disabled plugin index in disabled plugins collection.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Notes

If plugin is not added to the framework, it will be disabled when it will be added.

Collapse Expand See Also

NPluginManagerPlugAll

NPluginManagerClearDisabledPlugin

NPluginManagerGetDisabledPluginCount

NPluginManagerGetDisabledPlugin

Container

File: NPluginManager.h

Module: NPluginManager Unit


NPluginManagerAddDisabledPluginsCollectionChanged Function

NPluginManagerAddDisabledPluginsCollectionChanged Function
NPluginManager.h

Adds user specified callback for "disabled plugins collection changed" event. This callback is called when disabled plugins collection was changed.

C++
NResult N_API NPluginManagerAddDisabledPluginsCollectionChanged(HNPluginManager hPluginManager, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNPluginManager hPluginManager | [in] Handle to NPluginManager.
HNCallback hCallback | [in] Pointer to user defined function (callback).
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPluginManager.h

Module: NPluginManager Unit


NPluginManagerAddDisabledPluginsCollectionChangedCallback Function

NPluginManagerAddDisabledPluginsCollectionChangedCallback Function
NPluginManager.h

Adds user specified callback for "disabled plugins collection changed" event. This callback is called when disabled plugins collection was changed.

C++
NResult N_API NPluginManagerAddDisabledPluginsCollectionChangedCallback(HNPluginManager hPluginManager, N_COLLECTION_CHANGED_CALLBACK_ARG(HNString, pCallback), void * pParam);
Collapse Expand Parameters
Parameters | Description
HNPluginManager hPluginManager | [in] Handle to NPluginManager.
void * pParam | [in] User data used by a callback function.
_nt_ | _nt_
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPluginManager.h

Module: NPluginManager Unit


NPluginManagerAddPlugin Function

NPluginManagerAddPlugin Function
NPluginManager.h

Loads plugin. It's dependencies are searched relative to specified directory.

C++
NResult N_API NPluginManagerAddPlugin(HNPluginManager hPluginManager, HNPluginModule hModule, const NChar * szDirectory, HNPlugin * phPlugin);
Collapse Expand Parameters
Parameters | Description
HNPluginManager hPluginManager | [in] Handle to NPluginManager.
HNPluginModule hModule | [in] Handle to NPluginModule.
const NChar * szDirectory | [in] Directory where plugin and its dependencies (if exist) are saved.
HNPlugin * phPlugin | [out] Handle to loaded plugin.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

The function is used when loading plugins compiled statically. The handle to the module is obtained from plugin's function having the ModuleOf name suffix. For more standard plugins (implemented in dynamic libraries) use NPluginManagerAddPluginFromFile function or NPluginManagerRefresh function to automatically load all plugins from a search directory (NPluginManagerGetPluginSearchPath).

NObjectUnref shall be called on returned objects when they are no longer used to prevent memory leaks.

Container

File: NPluginManager.h

Module: NPluginManager Unit


NPluginManagerAddPluginFromFile Function

NPluginManagerAddPluginFromFile Function
NPluginManager.h

Loads plugin from user specified file.

C++
NResult N_API NPluginManagerAddPluginFromFile(HNPluginManager hPluginManager, const NChar * szFileName, HNPlugin * phPlugin);
Collapse Expand Parameters
Parameters | Description
HNPluginManager hPluginManager | [in] Handle to NPluginManager.
const NChar * szFileName | [in] File name where plugin is saved.
HNPlugin * phPlugin | [out] Handle to loaded plugin.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

The library dependencies (additional libraries required for plugin and specified during it's compilation) will be searched relatively to the directory containing the specified (szFileName) file.

NObjectUnref shall be called on returned objects when they are no longer used to prevent memory leaks.

Container

File: NPluginManager.h

Module: NPluginManager Unit


NPluginManagerAllowsUnplug Function

NPluginManagerAllowsUnplug Function
NPluginManager.h

Checks whether NPluginPlug and NPluginUnplug functions work

C++
NResult N_API NPluginManagerAllowsUnplug(HNPluginManager hPluginManager, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNPluginManager hPluginManager | [in] Handle to NPluginManager.
NBool * pValue | [out] NBool value which indicates whether NPluginPlug and NPluginUnplug functions work. When NTrue is returned these functions works. Otherwise, an error is returned.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise error code is returned. NSucceeded or NFailed macros can be used to detect whether the function succeeded or failed.

Container

File: NPluginManager.h

Module: NPluginManager Unit


NPluginManagerClearDisabledPlugins Function

NPluginManagerClearDisabledPlugins Function
NPluginManager.h See Also

Clears the collection of disabled plugins.

C++
NResult N_API NPluginManagerClearDisabledPlugins(HNPluginManager hPluginManager);
Collapse Expand Parameters
Parameters | Description
HNPluginManager hPluginManager | [in] Handle to NPluginManager.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand See Also

NPluginManagerPlugAll

NPluginManagerAddDisabledPlugin

NPluginManagerGetDisabledPluginCount

NPluginManagerGetDisabledPlugin

Container

File: NPluginManager.h

Module: NPluginManager Unit


NPluginManagerEnsurePluginSearchPerformed Function

NPluginManagerEnsurePluginSearchPerformed Function
NPluginManager.h

Trigger plugin search in plugin directory if search hasn't been performed yet.

C++
NResult N_API NPluginManagerEnsurePluginSearchPerformed(HNPluginManager hPluginManager);
Collapse Expand Parameters
Parameters | Description
HNPluginManager hPluginManager | [in] Handle of the effected plugin manager.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

If plugins has not been loaded before, all plugin libraries (file names matching certain pattern) present in plugin directory will be loaded. To perform plugin search even if this has already been performed after application start use NPluginMangerRefresh.

Container

File: NPluginManager.h

Module: NPluginManager Unit


NPluginManagerGetDisabledPluginCount Function

NPluginManagerGetDisabledPluginCount Function
NPluginManager.h See Also

Gets disabled plugins count.

C++
NResult N_API NPluginManagerGetDisabledPluginCount(HNPluginManager hPluginManager, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNPluginManager hPluginManager | [in] Handle to NPluginManager.
NInt * pValue | [out] Disabled plugins count.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand See Also

NPluginManagerGetDisabledPlugin

NPluginManagerPlugAll

Container

File: NPluginManager.h

Module: NPluginManager Unit


NPluginManagerGetDisabledPlugins Function

NPluginManagerGetDisabledPlugins Function
NPluginManager.h

Retrieves all disabled plugins in a plugin manager.

C++
NResult N_API NPluginManagerGetDisabledPlugins(HNPluginManager hPluginManager, HNString * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNPluginManager hPluginManager | [in] Handle to the plugin manager.
HNString * * parhValues | [out] Pointer to an array of disabled plugins.
NInt * pValueCount | [out] Pointer to the number of plugins in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPluginManager.h

Module: NPluginManager Unit


NPluginManagerGetInstances Function

NPluginManagerGetInstances Function
NPluginManager.h

Retrieves the instances of the plugin manager.

C++
NResult N_API NPluginManagerGetInstances(HNPluginManager * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNPluginManager * * parhValues | [in] A pointer to an array of instances.
NInt * pValueCount | [in] A pointer to a number of the instances in an array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

NObjectUnref shall be called on returned objects when they are no longer used to prevent memory leaks.

Container

File: NPluginManager.h

Module: NPluginManager Unit


NPluginManagerGetInterfaceTypeN Function

NPluginManagerGetInterfaceTypeN Function
NPluginManager.h

Returns NPluginManager interface type name.

C++
NResult N_API NPluginManagerGetInterfaceTypeN(HNPluginManager hPluginManager, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNPluginManager hPluginManager | [in] Handle to NPluginManager.
HNString * phValue | [out] Pointer to memory block which contains interface type name.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

If szValue is NULL function returns size of item contained in field.

szValue memory block needs to be +1 byte bigger than value returned as NULL parameter has been passed. Additional space is used for zero termination of returned value.

Collapse Expand Notes

NPluginManager can plug in only these plugins which have the same interface type as NPluginManager. When interface types mismatch these plugins will be listed with status "interface type mismatch".

Container

File: NPluginManager.h

Module: NPluginManager Unit


NPluginManagerGetInterfaceVersions Function

NPluginManagerGetInterfaceVersions Function
NPluginManager.h

Returns the range of supported interface versions by specified NPluginManager.

C++
NResult N_API NPluginManagerGetInterfaceVersions(HNPluginManager hPluginManager, NVersionRange_ * arValues, NInt valuesLength);
Collapse Expand Parameters
Parameters | Description
HNPluginManager hPluginManager | [in] Handle to NPluginManager to check which interface versions it supports.
NVersionRange_ * arValues | [out] Pointer to memory buffer that receives supported interface versions. Can be NULL. When NULL is passed as parameter, the length of arValues array is returned by NResult. Every NUInt in the array is a pair of NUShort which specifies version range (from...to).
NInt valuesLength | [in] Size of arValues memory buffer.
Collapse Expand Returns

The length of arValues array.

Collapse Expand Notes

NVersionRange* and NVersion* macros can be used to parse version range.

Container

File: NPluginManager.h

Module: NPluginManager Unit


NPluginManagerGetPlugin Function

NPluginManagerGetPlugin Function
NPluginManager.h

Returns NPlugin specified by index.

C++
NResult N_API NPluginManagerGetPlugin(HNPluginManager hPluginManager, NInt index, HNPlugin * phValue);
Collapse Expand Parameters
Parameters | Description
HNPluginManager hPluginManager | [in] Handle to NPluginManager to retrieve one of its plugins.
NInt index | [in] Plugin index.
HNPlugin * phValue | [out] Pointer to plugin specified by index.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise error code is returned. NSucceeded or NFailed macros can be used to detect whether the function succeeded or failed.

Collapse Expand Remarks

NObjectUnref shall be called on returned objects when they are no longer used to prevent memory leaks.

Container

File: NPluginManager.h

Module: NPluginManager Unit


NPluginManagerGetPluginByName Function

NPluginManagerGetPluginByName Function
NPluginManager.h

Gets plugin by specified name.

C++
NResult N_API NPluginManagerGetPluginByName(HNPluginManager hPluginManager, const NChar * szName, HNPlugin * phValue);
Collapse Expand Parameters
Parameters | Description
HNPluginManager hPluginManager | [in] Handle to NPluginManager.
const NChar * szName | [in] Zero-terminated string containing plugin name (Id).
HNPlugin * phValue | [out] Pointer to NPlugin.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPluginManager.h

Module: NPluginManager Unit


NPluginManagerGetPluginCount Function

NPluginManagerGetPluginCount Function
NPluginManager.h

Returns plugins count in specified NPluginManager.

C++
NResult N_API NPluginManagerGetPluginCount(HNPluginManager hPluginManager, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNPluginManager hPluginManager | [in] Handle to NPluginManager.
NInt * pValue | [out] Plugins count.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise error code is returned. NSucceeded or NFailed macros can be used to detect whether the function succeeded or failed.

Container

File: NPluginManager.h

Module: NPluginManager Unit


NPluginManagerGetPluginSearchPathN Function

NPluginManagerGetPluginSearchPathN Function
NPluginManager.h

Gets plugin dependencies search path.

C++
NResult N_API NPluginManagerGetPluginSearchPathN(HNPluginManager hPluginManager, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNPluginManager hPluginManager | [in] Handle to NPluginManager.
HNString * phValue | [out] Plugin search path.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Notes

All the plugins present in directory will be loaded in NPluginManagerRefresh (or during first call to NPluginManagerPlugAll ir refresh function is not used). The dependencies of these plugins will be searched relatively to this directory.

Container

File: NPluginManager.h

Module: NPluginManager Unit


NPluginManagerGetPlugins Function

NPluginManagerGetPlugins Function
NPluginManager.h

Retrieves all plugins in the plugin manager.

C++
NResult N_API NPluginManagerGetPlugins(HNPluginManager hPluginManager, HNPlugin * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNPluginManager hPluginManager | [in] Handle to the plugin manager.
HNPlugin * * parhValues | [out] Pointer to the array of plugins.
NInt * pValueCount | [out] Pointer to the number of plugins in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPluginManager.h

Module: NPluginManager Unit


NPluginManagerPlugAll Function

NPluginManagerPlugAll Function
NPluginManager.h

Plugs all enabled plugins into the system.

C++
NResult N_API NPluginManagerPlugAll(HNPluginManager hPluginManager);
Collapse Expand Parameters
Parameters | Description
HNPluginManager hPluginManager | [in] Handle to NPluginManager to plug all of its plugins.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise error code is returned. NSucceeded or NFailed macros can be used to detect whether the function succeeded or failed.

Collapse Expand Notes
  • Only enabled plugins will be plugged, i.e. those with names not present in disabled plugins collection.
  • If the function is called for the first time and NPluginManagerEnsurePluginSearchPerformed/NPluginManagerRefresh haven't been called yet the plugin search will be performed before pluggin.
Container

File: NPluginManager.h

Module: NPluginManager Unit


NPluginManagerRefresh Function

NPluginManagerRefresh Function
NPluginManager.h

Refreshes plugins list (search for added/removed plugin files).

C++
NResult N_API NPluginManagerRefresh(HNPluginManager hPluginManager);
Collapse Expand Parameters
Parameters | Description
HNPluginManager hPluginManager | [in] Handle to NPluginManger to refresh its plugins list.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise error code is returned. NSucceeded or NFailed macros can be used to detect whether the function succeeded or failed.

Collapse Expand Notes
  • The function can be used when new plugins need to be searched after their library files are added to plugin directory. Alternatively the NPluginManagerAddPluginFromFile function can be used to activate plugins one by one.
  • On refresh enabled plugins will be unplugged, the plugin libraries located in plugin directory will be reloaded and again plugged into the system. This means that if function NPluginManagerAllowsUnplug returns NFalse, plugin manager will not be able to unplug and hence refresh plugins list.
  • New plugins discovered by this operation will not be automatically plugged, call to NPLuginMangerPlugAll might be needed in such case.
  • Different file name patterns might be employed by different users of NPluginManger, so that not all DLL present in the plugin directory are loaded. For example NPluginManger used by NDeviceManager automatically loads only files with "Ndm*.dll" name pattern.
Container

File: NPluginManager.h

Module: NPluginManager Unit


NPluginManagerRemoveDisabledPlugin Function

NPluginManagerRemoveDisabledPlugin Function
NPluginManager.h

Removes plugin specified by name from disabled plugins collection.

C++
NResult N_API NPluginManagerRemoveDisabledPlugin(HNPluginManager hPluginManager, const NChar * szValue, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
HNPluginManager hPluginManager | [in] Handle to NPluginManager.
const NChar * szValue | [in] Plugin name.
NInt * pIndex | [out] Index of removed plugin.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPluginManager.h

Module: NPluginManager Unit


NPluginManagerRemoveDisabledPluginAt Function

NPluginManagerRemoveDisabledPluginAt Function
NPluginManager.h

Removes plugin specified by index from disabled plugins collection.

C++
NResult N_API NPluginManagerRemoveDisabledPluginAt(HNPluginManager hPluginManager, NInt index);
Collapse Expand Parameters
Parameters | Description
HNPluginManager hPluginManager | [in] Handle to NPluginManager.
NInt index | [in] Index of plugin which should be removed.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPluginManager.h

Module: NPluginManager Unit


NPluginManagerRemoveDisabledPluginsCollectionChanged Function

NPluginManagerRemoveDisabledPluginsCollectionChanged Function
NPluginManager.h

Removes user specified "disabled plugins collection changed" event.

C++
NResult N_API NPluginManagerRemoveDisabledPluginsCollectionChanged(HNPluginManager hPluginManager, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNPluginManager hPluginManager | [in] Handle to NPluginManager.
HNCallback hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPluginManager.h

Module: NPluginManager Unit


NPluginManagerRemoveDisabledPluginsCollectionChangedCallback Function

NPluginManagerRemoveDisabledPluginsCollectionChangedCallback Function
NPluginManager.h

Removes user specified callback for "disabled plugins collection changed" event.

C++
NResult N_API NPluginManagerRemoveDisabledPluginsCollectionChangedCallback(HNPluginManager hPluginManager, N_COLLECTION_CHANGED_CALLBACK_ARG(HNString, pCallback), void * pParam);
Collapse Expand Parameters
Parameters | Description
HNPluginManager hPluginManager | [in] Handle to NPluginManager.
void * pParam | [in] User data used by a callback function.
_nt_ | _nt_
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPluginManager.h

Module: NPluginManager Unit


NPluginManagerRemovePluginsCollectionChanged Function

NPluginManagerRemovePluginsCollectionChanged Function
NPluginManager.h

Removes user specified "plugins collection changed" event.

C++
NResult N_API NPluginManagerRemovePluginsCollectionChanged(HNPluginManager hPluginManager, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNPluginManager hPluginManager | [in] Handle to NPluginManager.
HNCallback hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPluginManager.h

Module: NPluginManager Unit


NPluginManagerRemovePluginsCollectionChangedCallback Function

NPluginManagerRemovePluginsCollectionChangedCallback Function
NPluginManager.h

Removes user specified callback for "plugins collection changed" event.

C++
NResult N_API NPluginManagerRemovePluginsCollectionChangedCallback(HNPluginManager hPluginManager, N_COLLECTION_CHANGED_CALLBACK_ARG(HNPlugin, pCallback), void * pParam);
Collapse Expand Parameters
Parameters | Description
HNPluginManager hPluginManager | [in] Handle to NPluginManager.
void * pParam | [in] User data used by a callback function.
_nt_ | _nt_
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPluginManager.h

Module: NPluginManager Unit


NPluginManagerSetPluginSearchPath Function

NPluginManagerSetPluginSearchPath Function
NPluginManager.h

Sets directory which will be automatically searched for plugins.

C++
NResult N_API NPluginManagerSetPluginSearchPath(HNPluginManager hPluginManager, const NChar * szValue);
Collapse Expand Parameters
Parameters | Description
HNPluginManager hPluginManager | [in] Handle to NPluginManager.
const NChar * szValue | [in] Path to directory.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Notes

All the plugins present in specified directory will be loaded in NPluginManagerRefresh (or during first call to NPluginManagerPlugAll ir refresh function is not used). The dependencies of these plugins will be searched relatively to this directory.

Container

File: NPluginManager.h

Module: NPluginManager Unit


NPluginManagerUnplugAll Function

NPluginManagerUnplugAll Function
NPluginManager.h

Unplugs all plugins.

C++
NResult N_API NPluginManagerUnplugAll(HNPluginManager hPluginManager);
Collapse Expand Parameters
Parameters | Description
HNPluginManager hPluginManager | [in] Handle to NPluginManger to unplug its plugins.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise error code is returned. NSucceeded or NFailed macros can be used to detect whether the function succeeded or failed.

Container

File: NPluginManager.h

Module: NPluginManager Unit


NPluginManagerAddDisabledPlugin Macro

NPluginManagerAddDisabledPlugin Macro
NPluginManager.h

Picks a Unicode (W) or ASCII (A) version of the NPluginManagerAddDisabledPlugin function.

C++
#define NPluginManagerAddDisabledPlugin N_FUNC_AW(NPluginManagerAddDisabledPlugin)
Container

File: NPluginManager.h

Module: NPluginManager Unit


NPluginManagerAddPlugin Macro

NPluginManagerAddPlugin Macro
NPluginManager.h

Picks a Unicode (W) or ASCII (A) version of the NPluginManagerAddPlugin function.

C++
#define NPluginManagerAddPlugin N_FUNC_AW(NPluginManagerAddPlugin)
Container

File: NPluginManager.h

Module: NPluginManager Unit


NPluginManagerAddPluginFromFile Macro

NPluginManagerAddPluginFromFile Macro
NPluginManager.h

Picks a Unicode (W) or ASCII (A) version of the NPluginManagerAddPluginFromFile function.

C++
#define NPluginManagerAddPluginFromFile N_FUNC_AW(NPluginManagerAddPluginFromFile)
Container

File: NPluginManager.h

Module: NPluginManager Unit


NPluginManagerGetPluginByName Macro

NPluginManagerGetPluginByName Macro
NPluginManager.h

Picks a Unicode (W) or ASCII (A) version of the NPluginManagerGetPluginByName function.

C++
#define NPluginManagerGetPluginByName N_FUNC_AW(NPluginManagerGetPluginByName)
Container

File: NPluginManager.h

Module: NPluginManager Unit


NPluginManagerRemoveDisabledPlugin Macro

NPluginManagerRemoveDisabledPlugin Macro
NPluginManager.h

Picks a Unicode (W) or ASCII (A) version of the NPluginManagerRemoveDisabledPlugin function.

C++
#define NPluginManagerRemoveDisabledPlugin N_FUNC_AW(NPluginManagerRemoveDisabledPlugin)
Container

File: NPluginManager.h

Module: NPluginManager Unit


NPluginManagerSetPluginSearchPath Macro

NPluginManagerSetPluginSearchPath Macro
NPluginManager.h

Picks a Unicode (W) or ASCII (A) version of the NPluginManagerSetPluginSearchPath function.

C++
#define NPluginManagerSetPluginSearchPath N_FUNC_AW(NPluginManagerSetPluginSearchPath)
Container

File: NPluginManager.h

Module: NPluginManager Unit


NPluginManager.h

NPluginManager.h
Functions Legend Macros

Header file for NPluginManager. Provides functions for working with NPlugin.

Collapse Expand Functions
Name | Description
NPluginManagerAddDisabledPlugin | Disables plugin specified by name and adds to disabled plugins collection.
NPluginManagerAddDisabledPluginsCollectionChanged | Adds user specified callback for "disabled plugins collection changed" event. This callback is called when disabled plugins collection was changed.
NPluginManagerAddDisabledPluginsCollectionChangedCallback | Adds user specified callback for "disabled plugins collection changed" event. This callback is called when disabled plugins collection was changed.
NPluginManagerAddPlugin | Loads plugin. It's dependencies are searched relative to specified directory.
NPluginManagerAddPluginFromFile | Loads plugin from user specified file.
NPluginManagerAllowsUnplug | Checks whether NPluginPlug and NPluginUnplug functions work
NPluginManagerClearDisabledPlugins | Clears the collection of disabled plugins.
NPluginManagerEnsurePluginSearchPerformed | Trigger plugin search in plugin directory if search hasn't been performed yet.
NPluginManagerGetDisabledPluginCount | Gets disabled plugins count.
NPluginManagerGetDisabledPlugins | Retrieves all disabled plugins in a plugin manager.
NPluginManagerGetInstances | Retrieves the instances of the plugin manager.
NPluginManagerGetInterfaceTypeN | Returns NPluginManager interface type name.
NPluginManagerGetInterfaceVersions | Returns the range of supported interface versions by specified NPluginManager.
NPluginManagerGetPlugin | Returns NPlugin specified by index.
NPluginManagerGetPluginByName | Gets plugin by specified name.
NPluginManagerGetPluginCount | Returns plugins count in specified NPluginManager.
NPluginManagerGetPluginSearchPathN | Gets plugin dependencies search path.
NPluginManagerGetPlugins | Retrieves all plugins in the plugin manager.
NPluginManagerPlugAll | Plugs all enabled plugins into the system.
NPluginManagerRefresh | Refreshes plugins list (search for added/removed plugin files).
NPluginManagerRemoveDisabledPlugin | Removes plugin specified by name from disabled plugins collection.
NPluginManagerRemoveDisabledPluginAt | Removes plugin specified by index from disabled plugins collection.
NPluginManagerRemoveDisabledPluginsCollectionChanged | Removes user specified "disabled plugins collection changed" event.
NPluginManagerRemoveDisabledPluginsCollectionChangedCallback | Removes user specified callback for "disabled plugins collection changed" event.
NPluginManagerRemovePluginsCollectionChanged | Removes user specified "plugins collection changed" event.
NPluginManagerRemovePluginsCollectionChangedCallback | Removes user specified callback for "plugins collection changed" event.
NPluginManagerSetPluginSearchPath | Sets directory which will be automatically searched for plugins.
NPluginManagerUnplugAll | Unplugs all plugins.
Collapse Expand Macros
Name | Description
NPluginManagerAddDisabledPlugin | Picks a Unicode (W) or ASCII (A) version of the NPluginManagerAddDisabledPlugin function.
NPluginManagerAddPlugin | Picks a Unicode (W) or ASCII (A) version of the NPluginManagerAddPlugin function.
NPluginManagerAddPluginFromFile | Picks a Unicode (W) or ASCII (A) version of the NPluginManagerAddPluginFromFile function.
NPluginManagerGetPluginByName | Picks a Unicode (W) or ASCII (A) version of the NPluginManagerGetPluginByName function.
NPluginManagerRemoveDisabledPlugin | Picks a Unicode (W) or ASCII (A) version of the NPluginManagerRemoveDisabledPlugin function.
NPluginManagerSetPluginSearchPath | Picks a Unicode (W) or ASCII (A) version of the NPluginManagerSetPluginSearchPath function.


NPluginMethodDescriptor Unit

NPluginMethodDescriptor Unit
Files Functions Legend

Provides functionality for creating plugin method descriptors.

Collapse Expand Files
Name | Description
NPluginMethodDescriptor.h | Header file for the NPluginMethodDescriptor unit.
Collapse Expand Functions
Name | Description
NPluginMethodDescriptorCreate | Creates a new plugin method descriptor.


NPluginMethodDescriptorCreate Function

NPluginMethodDescriptorCreate Function
NPluginMethodDescriptor.h

Creates a new plugin method descriptor.

C++
NResult N_API NPluginMethodDescriptorCreate(HNString hName, NAttributes attributes, HNCustomParameterDescriptor hReturnParameter, HNCustomParameterDescriptor * arhParameters, NInt parameterCount, HNValue hData, HNCallback hInvoke, HNPluginMethodDescriptor * phMethodDescriptor);
Collapse Expand Parameters
Parameters | Description
HNString hName | [in] Handle to the descriptor name.
NAttributes attributes | [in] Descriptor attributes.
HNCustomParameterDescriptor hReturnParameter | [in] Handle to the method's returned parameter descriptor.
HNCustomParameterDescriptor * arhParameters | [in/out] Pointer to an array of the method's parameters.
NInt parameterCount | [in] Number of parameters in the array.
HNValue hData | [in] Handle to the descriptor data.
HNCallback hInvoke | [in] Handle to the "method invoked" event callback.
HNPluginMethodDescriptor * phMethodDescriptor | [out] Pointer to the new plugin method descriptor.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPluginMethodDescriptor.h

Module: NPluginMethodDescriptor Unit


NPluginMethodDescriptor.h

NPluginMethodDescriptor.h
Functions Legend

Header file for the NPluginMethodDescriptor unit.

Collapse Expand Functions
Name | Description
NPluginMethodDescriptorCreate | Creates a new plugin method descriptor.


NPluginModule Unit

NPluginModule Unit
Functions Legend Macros

Provides functions to retrieve information about plugins.

Collapse Expand Functions
Name | Description
NPluginModuleCreate | Creates a new NPluginModule.
NPluginModuleGetIncompatiblePluginsN | Gets incompatible plugins list.
NPluginModuleGetInterfaceTypeN | Gets plugin interface type name.
NPluginModuleGetInterfaceVersions | Returns the range of supported interface versions by specified NPluginModule.
NPluginModuleGetPluginNameN | Gets plugin name.
NPluginModuleSetIncompatiblePluginsN | Sets the list of incompatible plugins for the specified plugin module.
NPluginModuleSetInterfaceTypeN | Sets a new interface type for the specified plugin module.
NPluginModuleSetPluginNameN | Sets the name of the plugin for the specified plugin module.
NPluginModuleSetPriority | Sets the priority of the specified plugin module.
NPluginModuleGetPriority | Gets plugin priority over other plugins.
HNPluginModule | Handle to NPluginModule.
Collapse Expand Macros
Name | Description
NPluginModuleSetIncompatiblePlugins | Picks a Unicode (W) or ANSCII (A) version of the NPluginModuleSetIncompatiblePlugins function.
NPluginModuleSetInterfaceType | Picks a Unicode (W) or ANSCII (A) version of the NPluginModuleSetInterfaceTypes function.
NPluginModuleSetPluginName | Picks a Unicode (W) or ANSCII (A) version of the NPluginModuleSetPluginType function.


NPluginModuleCreate Function

NPluginModuleCreate Function

Creates a new NPluginModule.

C++
NResult N_API NPluginModuleCreate(HNPluginModule * phModule);
Collapse Expand Parameters
Parameters | Description
HNPluginModule * phModule | [out] Pointer to a handle to the new NPluginModule.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPluginModule.h

Module: NPluginModule Unit


NPluginModuleGetIncompatiblePluginsN Function

NPluginModuleGetIncompatiblePluginsN Function

Gets incompatible plugins list.

C++
NResult N_API NPluginModuleGetIncompatiblePluginsN(HNPluginModule hModule, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNPluginModule hModule | [in] Handle to NPluginModule.
HNString * phValue | [out] Pointer to incompatible plugins names separated by semicolon.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPluginModule.h

Module: NPluginModule Unit


NPluginModuleGetInterfaceTypeN Function

NPluginModuleGetInterfaceTypeN Function

Gets plugin interface type name.

C++
NResult N_API NPluginModuleGetInterfaceTypeN(HNPluginModule hModule, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNPluginModule hModule | [in] Handle to NPluginModule.
HNString * phValue | [out] Pointer to NString which contains interface type name.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

If szValue is NULL function returns size of item contained in field.

szValue memory block needs to be +1 byte bigger than value returned as NULL parameter has been passed. Additional space is used for zero termination of returned value.

Container

File: NPluginModule.h

Module: NPluginModule Unit


NPluginModuleGetInterfaceVersions Function

NPluginModuleGetInterfaceVersions Function

Returns the range of supported interface versions by specified NPluginModule.

C++
NResult N_API NPluginModuleGetInterfaceVersions(HNPluginModule hModule, NVersionRange_ * arValues, NInt valuesLength);
Collapse Expand Parameters
Parameters | Description
HNPluginModule hModule | [in] Handle to NPluginModule to check which interface versions it supports.
NVersionRange_ * arValues | [out] Pointer to memory buffer that receives supported interface versions. Can be NULL. When NULL is passed as parameter, the length of arValues array is returned by NResult. Every NUInt in the array is a pair of NUShort which specifies version range (from...to).
NInt valuesLength | [in] Size of arValues memory buffer.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

NVersionRange* and NVersion* macros can be used to parse version range.

Container

File: NPluginModule.h

Module: NPluginModule Unit


NPluginModuleGetPluginNameN Function

NPluginModuleGetPluginNameN Function

Gets plugin name.

C++
NResult N_API NPluginModuleGetPluginNameN(HNPluginModule hModule, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNPluginModule hModule | [in] Handle to NPluginModule.
HNString * phValue | [out] Pointer to NString where plugin name is saved.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPluginModule.h

Module: NPluginModule Unit


NPluginModuleSetIncompatiblePluginsN Function

NPluginModuleSetIncompatiblePluginsN Function

Sets the list of incompatible plugins for the specified plugin module.

C++
NResult N_API NPluginModuleSetIncompatiblePluginsN(HNPluginModule hModule, HNString hValue);
Collapse Expand Parameters
Parameters | Description
HNPluginModule hModule | [in] Handle to the NPluginModule.
HNString hValue | [in] Handle to the list of incompatible plugins.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPluginModule.h

Module: NPluginModule Unit


NPluginModuleSetInterfaceTypeN Function

NPluginModuleSetInterfaceTypeN Function

Sets a new interface type for the specified plugin module.

C++
NResult N_API NPluginModuleSetInterfaceTypeN(HNPluginModule hModule, HNString hValue);
Collapse Expand Parameters
Parameters | Description
HNPluginModule hModule | [in] Handle to the NPluginModule.
HNString hValue | [in] Handle to NString containing new interface type value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPluginModule.h

Module: NPluginModule Unit


NPluginModuleSetPluginNameN Function

NPluginModuleSetPluginNameN Function

Sets the name of the plugin for the specified plugin module.

C++
NResult N_API NPluginModuleSetPluginNameN(HNPluginModule hModule, HNString hValue);
Collapse Expand Parameters
Parameters | Description
HNPluginModule hModule | [in] Handle to the NPluginModule.
HNString hValue | [in] Handle to the string containing the name of the plugin.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPluginModule.h

Module: NPluginModule Unit


NPluginModuleSetPriority Function

NPluginModuleSetPriority Function

Sets the priority of the specified plugin module.

C++
NResult N_API NPluginModuleSetPriority(HNPluginModule hModule, NInt value);
Collapse Expand Parameters
Parameters | Description
HNPluginModule hModule | [in] Handle to the NPluginModule.
NInt value | [in] New priority value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPluginModule.h

Module: NPluginModule Unit


NPluginModuleGetPriority Function

NPluginModuleGetPriority Function

Gets plugin priority over other plugins.

C++
NResult N_API NPluginModuleGetPriority(HNPluginModule hModule, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNPluginModule hModule | [in] Handle to NPluginModule.
NInt * pValue | [out] Plugin priority.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

Priority influences plugins adding to the system. If two or more plugins are incompatible or duplicate plugins exist plugin with higher priority will be added to the system. Priority is set during plugin compilation.

Default plugin priority is 0.

Container

File: NPluginModule.h

Module: NPluginModule Unit


HNPluginModule

HNPluginModule

Handle to NPluginModule.


NPluginModuleSetIncompatiblePlugins Macro

NPluginModuleSetIncompatiblePlugins Macro

Picks a Unicode (W) or ANSCII (A) version of the NPluginModuleSetIncompatiblePlugins function.

C++
#define NPluginModuleSetIncompatiblePlugins N_FUNC_AW(NPluginModuleSetIncompatiblePlugins)
Container

File: NPluginModule.h

Module: NPluginModule Unit


NPluginModuleSetInterfaceType Macro

NPluginModuleSetInterfaceType Macro

Picks a Unicode (W) or ANSCII (A) version of the NPluginModuleSetInterfaceTypes function.

C++
#define NPluginModuleSetInterfaceType N_FUNC_AW(NPluginModuleSetInterfaceType)
Container

File: NPluginModule.h

Module: NPluginModule Unit


NPluginModuleSetPluginName Macro

NPluginModuleSetPluginName Macro

Picks a Unicode (W) or ANSCII (A) version of the NPluginModuleSetPluginType function.

C++
#define NPluginModuleSetPluginName N_FUNC_AW(NPluginModuleSetPluginName)
Container

File: NPluginModule.h

Module: NPluginModule Unit


NPluginModuleInternal Unit

NPluginModuleInternal Unit
Functions Legend

Provides functions to modify information about plugins.

Collapse Expand Functions
Name | Description
NPluginModuleSetGetEvents | Sets the process that retrieves events for the specified module.
NPluginModuleSetGetMethods | Sets the process that retrieves methods for the specified module.
NPluginModuleSetGetProperties | Sets the process that retrieves properties for the specified module.
NPluginModuleSetInterfaceVersions | Sets plugin interface versions for the specified plugin manager.
NPluginModuleSetPlug | Sets the plug process for the specified plugin module.
NPluginModuleSetUnplug | Sets the unplug process for the specified plugin module.


NPluginModuleSetGetEvents Function

NPluginModuleSetGetEvents Function

Sets the process that retrieves events for the specified module.

C++
NResult N_API NPluginModuleSetGetEvents(HNPluginModule hModule, NPluginGetEventsProc pValue);
Collapse Expand Parameters
Parameters | Description
HNPluginModule hModule | [in] Handle to the plugin module.
NPluginGetEventsProc pValue | [in] Process that retrieves events.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPluginModuleInternal.h

Module: NPluginModuleInternal Unit


NPluginModuleSetGetMethods Function

NPluginModuleSetGetMethods Function

Sets the process that retrieves methods for the specified module.

C++
NResult N_API NPluginModuleSetGetMethods(HNPluginModule hModule, NPluginGetMethodsProc pValue);
Collapse Expand Parameters
Parameters | Description
HNPluginModule hModule | [in] Handle to the plugin module.
NPluginGetMethodsProc pValue | [in] Process that retrieves methods.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPluginModuleInternal.h

Module: NPluginModuleInternal Unit


NPluginModuleSetGetProperties Function

NPluginModuleSetGetProperties Function

Sets the process that retrieves properties for the specified module.

C++
NResult N_API NPluginModuleSetGetProperties(HNPluginModule hModule, NPluginGetPropertiesProc pValue);
Collapse Expand Parameters
Parameters | Description
HNPluginModule hModule | [in] Handle to the plugin module.
NPluginGetPropertiesProc pValue | [in] Process that retrieves properties.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPluginModuleInternal.h

Module: NPluginModuleInternal Unit


NPluginModuleSetInterfaceVersions Function

NPluginModuleSetInterfaceVersions Function

Sets plugin interface versions for the specified plugin manager.

C++
NResult N_API NPluginModuleSetInterfaceVersions(HNPluginModule hModule, const NPluginInterfaceVersionInfo * arValues, NInt count);
Collapse Expand Parameters
Parameters | Description
HNPluginModule hModule | [in] Handle to the NPluginModule.
const NPluginInterfaceVersionInfo * arValues | [in] Pointer to an array of plugin interface versions.
NInt count | [in] The number of interface version.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPluginModuleInternal.h

Module: NPluginModuleInternal Unit


NPluginModuleSetPlug Function

NPluginModuleSetPlug Function

Sets the plug process for the specified plugin module.

C++
NResult N_API NPluginModuleSetPlug(HNPluginModule hModule, NPluginModulePlugProc pValue);
Collapse Expand Parameters
Parameters | Description
HNPluginModule hModule | [in] Handle to the NPluginModule.
NPluginModulePlugProc pValue | [in] The plug process.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPluginModuleInternal.h

Module: NPluginModuleInternal Unit


NPluginModuleSetUnplug Function

NPluginModuleSetUnplug Function

Sets the unplug process for the specified plugin module.

C++
NResult N_API NPluginModuleSetUnplug(HNPluginModule hModule, NPluginModuleUnplugProc pValue);
Collapse Expand Parameters
Parameters | Description
HNPluginModule hModule | [in] Handle to the NPluginModule.
NPluginModuleUnplugProc pValue | [in] The unplug process.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPluginModuleInternal.h

Module: NPluginModuleInternal Unit


NPluginPropertyDescriptor Unit

NPluginPropertyDescriptor Unit
Files Functions Legend

Provides functionality for creating plugin property descriptors.

Collapse Expand Files
Name | Description
NPluginPropertyDescriptor.h | Header file for the NPluginPropertyDescriptor unit.
Collapse Expand Functions
Name | Description
NPluginPropertyDescriptorCreate | Creates a new plugin property descriptor.


NPluginPropertyDescriptorCreate Function

NPluginPropertyDescriptorCreate Function
NPluginPropertyDescriptor.h

Creates a new plugin property descriptor.

C++
NResult N_API NPluginPropertyDescriptorCreate(HNString hName, HNType hPropertyType, NAttributes attributes, HNString hFormat, HNValue hDefaultValue, HNValue hMinValue, HNValue hMaxValue, const struct NNameValuePair_ * arStdValues, NInt stdValueCount, HNValue hData, HNCallback hGetValue, HNCallback hSetValue, HNCallback hResetValue, HNPluginPropertyDescriptor * phPropertyDescriptor);
Collapse Expand Parameters
Parameters | Description
HNString hName | [in] Handle to the descriptor name.
HNType hPropertyType | [in] Handle to the property type.
NAttributes attributes | [in] Descriptor attributes.
HNString hFormat | [in] Handle to the descriptor format.
HNValue hDefaultValue | [in] Handle to the default property value.
HNValue hMinValue | [in] Minimum property value.
HNValue hMaxValue | [in] Maximum property value.
const struct NNameValuePair_ * arStdValues | [in] Pointer to an array of standard values.
NInt stdValueCount | [in] Number of standard values.
HNValue hData | [in] Handle to the descriptor data.
HNCallback hGetValue | [in] Handle to "value retrieved" event callback.
HNCallback hSetValue | [in] Handle to "value set" event callback.
HNCallback hResetValue | [in] Handle to "value reset" event callback.
HNPluginPropertyDescriptor * phPropertyDescriptor | [out] Pointer to the new plugin property descriptor.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPluginPropertyDescriptor.h

Module: NPluginPropertyDescriptor Unit


NPluginPropertyDescriptor.h

NPluginPropertyDescriptor.h
Functions Legend

Header file for the NPluginPropertyDescriptor unit.

Collapse Expand Functions
Name | Description
NPluginPropertyDescriptorCreate | Creates a new plugin property descriptor.


NProcess Unit

NProcess Unit
Files Functions Legend

Provides functions to retrieve information about processes and create new processes.

Collapse Expand Files
Name | Description
NProcess.h | Header file for the NProcess unit.
Collapse Expand Functions
Name | Description
NProcessCreateFromOSHandle | Creates a new process from the specified operating system handle.
NProcessGetCurrent | Retrieves the current process.
NProcessGetFileName | Retrieves the file name of the specified process.
NProcessGetId | Retrieves the IDs of the specified process.
NProcessGetName | Retrieves the name of the specified process.
NProcessGetOSHandle | Retrieves the operating system handle used by the specified process.


NProcessCreateFromOSHandle Function

NProcessCreateFromOSHandle Function
NProcess.h

Creates a new process from the specified operating system handle.

C++
NResult N_API NProcessCreateFromOSHandle(NHandle handle, NBool ownsHandle, HNProcess * phProcess);
Collapse Expand Parameters
Parameters | Description
NHandle handle | [in] The OS handle.
NBool ownsHandle | [in] NTrue if the file handle will be owned by this process; otherwise, NFalse.
HNProcess * phProcess | [out] Pointer to the new process.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NProcess.h

Module: NProcess Unit


NProcessGetCurrent Function

NProcessGetCurrent Function
NProcess.h

Retrieves the current process.

C++
NResult N_API NProcessGetCurrent(HNProcess * phValue);
Collapse Expand Parameters
Parameters | Description
HNProcess * phValue | [out] Pointer to the current process.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NProcess.h

Module: NProcess Unit


NProcessGetFileName Function

NProcessGetFileName Function
NProcess.h

Retrieves the file name of the specified process.

C++
NResult N_API NProcessGetFileName(HNProcess hProcess, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNProcess hProcess | [in] Handle to the process.
HNString * phValue | [out] Pointer to the process file name.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NProcess.h

Module: NProcess Unit


NProcessGetId Function

NProcessGetId Function
NProcess.h

Retrieves the IDs of the specified process.

C++
NResult N_API NProcessGetId(HNProcess hProcess, NSSizeType * pValue);
Collapse Expand Parameters
Parameters | Description
HNProcess hProcess | [in] Handle to the process.
NSSizeType * pValue | [out] Pointer to the ID of the process.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NProcess.h

Module: NProcess Unit


NProcessGetName Function

NProcessGetName Function
NProcess.h

Retrieves the name of the specified process.

C++
NResult N_API NProcessGetName(HNProcess hProcess, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNProcess hProcess | [in] Handle to the process.
HNString * phValue | [out] Pointer to the name of the process.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NProcess.h

Module: NProcess Unit


NProcessGetOSHandle Function

NProcessGetOSHandle Function
NProcess.h

Retrieves the operating system handle used by the specified process.

C++
NResult N_API NProcessGetOSHandle(HNProcess hProcess, NHandle * phValue);
Collapse Expand Parameters
Parameters | Description
HNProcess hProcess | [in] Handle to the process.
NHandle * phValue | [out] Pointer to the OS handle.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NProcess.h

Module: NProcess Unit


NProcess.h

NProcess.h
Functions Legend

Header file for the NProcess unit.

Collapse Expand Functions
Name | Description
NProcessCreateFromOSHandle | Creates a new process from the specified operating system handle.
NProcessGetCurrent | Retrieves the current process.
NProcessGetFileName | Retrieves the file name of the specified process.
NProcessGetId | Retrieves the IDs of the specified process.
NProcessGetName | Retrieves the name of the specified process.
NProcessGetOSHandle | Retrieves the operating system handle used by the specified process.


NProcessorInfo Unit

NProcessorInfo Unit
Files Functions Legend Structs, Records, Enums

Provides functionality for getting processor information.

Collapse Expand Files
Name | Description
NProcessorInfo.h | Header file for the NProcessorInfo. Provides functionality for getting processor information.
Collapse Expand Functions
Name | Description
NProcessorInfoGetCount | Retrieves the number of logical processors in the current group.
NProcessorInfoGetModelInfo | Retrieves processor model information.
NProcessorInfoGetModelNameN | Retrieves processor model name.
NProcessorInfoGetVendor | Retrieves a pointer to enumeration that contains information about processor's vendor.
NProcessorInfoGetVendorNameN | Retrieves processor's vendor name.
NProcessorInfoIsFeatureSupported | Checks if current CPU supports the specified feature.
Collapse Expand Structs, Records, Enums
Name | Description
NProcessorVendor_ | Enumerates different processor vendors.
NProcessorVendor | Enumerates different processor vendors.


NProcessorInfoGetCount Function

NProcessorInfoGetCount Function
NProcessorInfo.h

Retrieves the number of logical processors in the current group.

C++
NResult N_API NProcessorInfoGetCount(NInt * pValue);
Collapse Expand Parameters
Parameters | Description
NInt * pValue | [out] A pointer to the number of processors.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NProcessorInfo.h

Module: NProcessorInfo Unit


NProcessorInfoGetModelInfo Function

NProcessorInfoGetModelInfo Function
NProcessorInfo.h

Retrieves processor model information.

C++
NResult N_API NProcessorInfoGetModelInfo(NInt * pFamily, NInt * pModel, NInt * pStepping);
Collapse Expand Parameters
Parameters | Description
NInt * pFamily | [out] A pointer to a value defining processor family.
NInt * pModel | [out] A pointer to a value defining processor model.
NInt * pStepping | [out] A pointer to a value defining processor stepping.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NProcessorInfo.h

Module: NProcessorInfo Unit


NProcessorInfoGetModelNameN Function

NProcessorInfoGetModelNameN Function
NProcessorInfo.h

Retrieves processor model name.

C++
NResult N_API NProcessorInfoGetModelNameN(HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNString * phValue | [out] A pointer to a string containing processor model name.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NProcessorInfo.h

Module: NProcessorInfo Unit


NProcessorInfoGetVendor Function

NProcessorInfoGetVendor Function
NProcessorInfo.h

Retrieves a pointer to enumeration that contains information about processor's vendor.

C++
NResult N_API NProcessorInfoGetVendor(NProcessorVendor * pValue);
Collapse Expand Parameters
Parameters | Description
NProcessorVendor * pValue | [out] A pointer to memory block that contains NProcessorVendor enumeration.
Collapse Expand Returns

If the function succeeds, the return value is N_OK.

If the function fails, the return value is one of the following error codes:

Error code | Condition
N_E_ARGUMENT_NULL | pValue is NULL.
Container

File: NProcessorInfo.h

Module: NProcessorInfo Unit


NProcessorInfoGetVendorNameN Function

NProcessorInfoGetVendorNameN Function
NProcessorInfo.h

Retrieves processor's vendor name.

C++
NResult N_API NProcessorInfoGetVendorNameN(HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNString * phValue | [out] A pointer to a string containing processor vendor name.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NProcessorInfo.h

Module: NProcessorInfo Unit


NProcessorInfoIsFeatureSupported Function

NProcessorInfoIsFeatureSupported Function
NProcessorInfo.h

Checks if current CPU supports the specified feature.

C++
NResult N_API NProcessorInfoIsFeatureSupported(NProcessorFeature feature, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
NProcessorFeature feature | [in] Feature to be checked.
NBool * pValue | [out] A pointer to a NBool value, indicating feature support.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NProcessorInfo.h

Module: NProcessorInfo Unit


NProcessorVendor Enumeration

NProcessorVendor Enumeration
NProcessorInfo.h

Enumerates different processor vendors.

C++
typedef enum NProcessorVendor_ {
  npvUnknown = 0,
  npvAmd = 1,
  npvCentaur = 2,
  npvCyrix = 3,
  npvIntel = 4,
  npvNationalSemiconductor = 5,
  npvNexGen = 6,
  npvRiseTechnology = 7,
  npvSiS = 8,
  npvTransmeta = 9,
  npvUmc = 10
} NProcessorVendor;
Collapse Expand Members
Members | Description
npvUnknown = 0 | Vendor is unknown.
npvAmd = 1 | Advanced Micro Devices, Inc. (AMD)
npvCentaur = 2 | Centaur Technology, Inc.
npvCyrix = 3 | Cyrix, Inc.
npvIntel = 4 | Intel Corporation.
npvNationalSemiconductor = 5 | National Semiconductor Corporation.
npvNexGen = 6 | NexGen Technologies, Inc.
npvRiseTechnology = 7 | Rise Technology, Inc.
npvSiS = 8 | Silicon Integrated Systems Corp.
npvTransmeta = 9 | Transmeta Corp.
npvUmc = 10 | United Microelectronics Corporation.
Container

File: NProcessorInfo.h

Module: NProcessorInfo Unit


NProcessorInfo.h

NProcessorInfo.h
Enumerations Functions Legend

Header file for the NProcessorInfo. Provides functionality for getting processor information.

Collapse Expand Enumerations
Name | Description
NProcessorVendor_ | Enumerates different processor vendors.
NProcessorVendor | Enumerates different processor vendors.
Collapse Expand Functions
Name | Description
NProcessorInfoGetCount | Retrieves the number of logical processors in the current group.
NProcessorInfoGetModelInfo | Retrieves processor model information.
NProcessorInfoGetModelNameN | Retrieves processor model name.
NProcessorInfoGetVendor | Retrieves a pointer to enumeration that contains information about processor's vendor.
NProcessorInfoGetVendorNameN | Retrieves processor's vendor name.
NProcessorInfoIsFeatureSupported | Checks if current CPU supports the specified feature.


NPropertyInfo Unit

NPropertyInfo Unit
Files Functions Legend

Provides functionality to retrieve and change information about properties.

Collapse Expand Files
Name | Description
NPropertyInfo.h | Header file for the NPropertyInfo unit.
Collapse Expand Functions
Name | Description
NPropertyInfoCanResetValue | Checks whether the specified property can reset its value to default value.
NPropertyInfoGetDefaultValue | Retrieves the default value of the specified property.
NPropertyInfoGetFormat | Retrieves the format of the specified property.
NPropertyInfoGetGetMethod | Retrieves the method which gets the value of the property.
NPropertyInfoGetMaxValue | Retrieves the maximal value of the specified property.
NPropertyInfoGetMinValue | Retrieves the minimal value of the specified property.
NPropertyInfoGetPropertyType | Retrieves the type of the property.
NPropertyInfoGetSetMethod | Retrieves the method which sets the value of the property.
NPropertyInfoGetStdValue | Retrieves the specified standard value of the specified property.
NPropertyInfoGetStdValueCount | Retrieves the number of standard values of the specified property.
NPropertyInfoGetStdValues | Retrieves all standard values of the specified property.
NPropertyInfoGetValue | Retrieves the value of the property.
NPropertyInfoResetValue | Resets the value of the property.
NPropertyInfoSetValue | Sets the value of the property.


NPropertyInfoCanResetValue Function

NPropertyInfoCanResetValue Function
NPropertyInfo.h

Checks whether the specified property can reset its value to default value.

C++
NResult N_API NPropertyInfoCanResetValue(HNPropertyInfo hPropertyInfo, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNPropertyInfo hPropertyInfo | [in] Handle to the property information.
NBool * pValue | [out] NTrue if the property can reset its value; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPropertyInfo.h

Module: NPropertyInfo Unit


NPropertyInfoGetDefaultValue Function

NPropertyInfoGetDefaultValue Function
NPropertyInfo.h

Retrieves the default value of the specified property.

C++
NResult N_API NPropertyInfoGetDefaultValue(HNPropertyInfo hPropertyInfo, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
HNPropertyInfo hPropertyInfo | [in] Handle to the property information.
HNValue * phValue | [out] Pointer to the default value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPropertyInfo.h

Module: NPropertyInfo Unit


NPropertyInfoGetFormat Function

NPropertyInfoGetFormat Function
NPropertyInfo.h

Retrieves the format of the specified property.

C++
NResult N_API NPropertyInfoGetFormat(HNPropertyInfo hPropertyInfo, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNPropertyInfo hPropertyInfo | [in] Handle to the property information.
HNString * phValue | [out] Pointer to the format string of the specified property.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPropertyInfo.h

Module: NPropertyInfo Unit


NPropertyInfoGetGetMethod Function

NPropertyInfoGetGetMethod Function
NPropertyInfo.h

Retrieves the method which gets the value of the property.

C++
NResult N_API NPropertyInfoGetGetMethod(HNPropertyInfo hPropertyInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNPropertyInfo hPropertyInfo | [in] Handle to the property information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPropertyInfo.h

Module: NPropertyInfo Unit


NPropertyInfoGetMaxValue Function

NPropertyInfoGetMaxValue Function
NPropertyInfo.h

Retrieves the maximal value of the specified property.

C++
NResult N_API NPropertyInfoGetMaxValue(HNPropertyInfo hPropertyInfo, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
HNPropertyInfo hPropertyInfo | [in] Handle to the property information.
HNValue * phValue | [out] Pointer to the maximal value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPropertyInfo.h

Module: NPropertyInfo Unit


NPropertyInfoGetMinValue Function

NPropertyInfoGetMinValue Function
NPropertyInfo.h

Retrieves the minimal value of the specified property.

C++
NResult N_API NPropertyInfoGetMinValue(HNPropertyInfo hPropertyInfo, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
HNPropertyInfo hPropertyInfo | [in] Handle to the property information.
HNValue * phValue | [out] Pointer to the minimal value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPropertyInfo.h

Module: NPropertyInfo Unit


NPropertyInfoGetPropertyType Function

NPropertyInfoGetPropertyType Function
NPropertyInfo.h

Retrieves the type of the property.

C++
NResult N_API NPropertyInfoGetPropertyType(HNPropertyInfo hPropertyInfo, HNType * phValue);
Collapse Expand Parameters
Parameters | Description
HNPropertyInfo hPropertyInfo | [in] Handle to the property information.
HNType * phValue | [out] Pointer to the type of the property.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPropertyInfo.h

Module: NPropertyInfo Unit


NPropertyInfoGetSetMethod Function

NPropertyInfoGetSetMethod Function
NPropertyInfo.h

Retrieves the method which sets the value of the property.

C++
NResult N_API NPropertyInfoGetSetMethod(HNPropertyInfo hPropertyInfo, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNPropertyInfo hPropertyInfo | [in] Handle to the property information.
HNMethodInfo * phValue | [out] Pointer to the method information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPropertyInfo.h

Module: NPropertyInfo Unit


NPropertyInfoGetStdValue Function

NPropertyInfoGetStdValue Function
NPropertyInfo.h

Retrieves the specified standard value of the specified property.

C++
NResult N_API NPropertyInfoGetStdValue(HNPropertyInfo hPropertyInfo, NInt index, struct NNameValuePair_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNPropertyInfo hPropertyInfo | [in] Handle to the property information.
NInt index | [in] Index of the standard value.
struct NNameValuePair_ * pValue | [out] Pointer to the standard value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPropertyInfo.h

Module: NPropertyInfo Unit


NPropertyInfoGetStdValueCount Function

NPropertyInfoGetStdValueCount Function
NPropertyInfo.h

Retrieves the number of standard values of the specified property.

C++
NResult N_API NPropertyInfoGetStdValueCount(HNPropertyInfo hPropertyInfo, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNPropertyInfo hPropertyInfo | [in] Handle to the property information.
NInt * pValue | [out] Pointer to the number of standard values.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPropertyInfo.h

Module: NPropertyInfo Unit


NPropertyInfoGetStdValues Function

NPropertyInfoGetStdValues Function
NPropertyInfo.h

Retrieves all standard values of the specified property.

C++
NResult N_API NPropertyInfoGetStdValues(HNPropertyInfo hPropertyInfo, struct NNameValuePair_ * * parValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNPropertyInfo hPropertyInfo | [in] Handle to the property information.
struct NNameValuePair_ * * parValues | [out] Pointer to an array of standard values.
NInt * pValueCount | [out] Pointer to the number of values in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPropertyInfo.h

Module: NPropertyInfo Unit


NPropertyInfoGetValue Function

NPropertyInfoGetValue Function
NPropertyInfo.h

Retrieves the value of the property.

C++
NResult N_API NPropertyInfoGetValue(HNPropertyInfo hPropertyInfo, HNObject hObject, HNType hValueType, NAttributes attributes, void * arValues, NSizeType valuesSize, NInt valuesLength, NBool * pHasValue);
Collapse Expand Parameters
Parameters | Description
HNPropertyInfo hPropertyInfo | [in] Handle to the property information.
HNObject hObject | [in] Handle to the object the property belongs to.
HNType hValueType | [in] Handle to the type of the property value.
NAttributes attributes | [in] Value attributes.
void * arValues | [out] Pointer to an array of values.
NSizeType valuesSize | [in] Size of a value.
NInt valuesLength | [in] Number of values in the array.
NBool * pHasValue | [out] NFalse is arValues is null, else NTrue.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPropertyInfo.h

Module: NPropertyInfo Unit


NPropertyInfoResetValue Function

NPropertyInfoResetValue Function
NPropertyInfo.h

Resets the value of the property.

C++
NResult N_API NPropertyInfoResetValue(HNPropertyInfo hPropertyInfo, HNObject hObject);
Collapse Expand Parameters
Parameters | Description
HNPropertyInfo hPropertyInfo | [in] Handle to the property information.
HNObject hObject | [in] Handle to the object the property belongs to.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPropertyInfo.h

Module: NPropertyInfo Unit


NPropertyInfoSetValue Function

NPropertyInfoSetValue Function
NPropertyInfo.h

Sets the value of the property.

C++
NResult N_API NPropertyInfoSetValue(HNPropertyInfo hPropertyInfo, HNObject hObject, HNType hValueType, NAttributes attributes, const void * arValues, NSizeType valuesSize, NInt valuesLength, NBool hasValue);
Collapse Expand Parameters
Parameters | Description
HNPropertyInfo hPropertyInfo | [in] Handle to the property information.
HNObject hObject | [in] Handle to the object the property belongs to.
HNType hValueType | [in] Handle to the type of the property value.
NAttributes attributes | [in] Value attributes.
const void * arValues | [in] Pointer to an array of values.
NSizeType valuesSize | [in] Size of a value.
NInt valuesLength | [in] Number of values in the array.
NBool hasValue | [in] NFalse is arValues is null, else NTrue.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPropertyInfo.h

Module: NPropertyInfo Unit


NPropertyInfo.h

NPropertyInfo.h
Functions Legend

Header file for the NPropertyInfo unit.

Collapse Expand Functions
Name | Description
NPropertyInfoCanResetValue | Checks whether the specified property can reset its value to default value.
NPropertyInfoGetDefaultValue | Retrieves the default value of the specified property.
NPropertyInfoGetFormat | Retrieves the format of the specified property.
NPropertyInfoGetGetMethod | Retrieves the method which gets the value of the property.
NPropertyInfoGetMaxValue | Retrieves the maximal value of the specified property.
NPropertyInfoGetMinValue | Retrieves the minimal value of the specified property.
NPropertyInfoGetPropertyType | Retrieves the type of the property.
NPropertyInfoGetSetMethod | Retrieves the method which sets the value of the property.
NPropertyInfoGetStdValue | Retrieves the specified standard value of the specified property.
NPropertyInfoGetStdValueCount | Retrieves the number of standard values of the specified property.
NPropertyInfoGetStdValues | Retrieves all standard values of the specified property.
NPropertyInfoGetValue | Retrieves the value of the property.
NPropertyInfoResetValue | Resets the value of the property.
NPropertyInfoSetValue | Sets the value of the property.


NQueue Unit

NQueue Unit
Files Functions Legend Macros

Provides functionality for working with queues.

Collapse Expand Files
Name | Description
NQueue.h | Header file for the NQueue module.
Collapse Expand Functions
Name | Description
NQueueClear | Clears the specified queue.
NQueueContains | Checks whether the specified queue contains the specified value.
NQueueCopyTo | Copies the specified queue to an array.
NQueueDequeue | Retrieves and removes the front element of the specified queue.
NQueueDispose | Disposes of the specified queue.
NQueueEnqueue | Adds the specified value to the end of the specified queue.
NQueueGetCapacity | Retrieves the capacity of the specified queue.
NQueueGetCount | Retrieves the number of values in the specified queue.
NQueueGetFront | Retrieves the front element of the queue.
NQueueInit | Initializes the specified queue.
NQueueInitEx | Initializes the specified queue.
NQueueInitWithCapacity | Initializes the specified queue.
NQueuePeek | Retrieves the front element of the specified queue without removing it.
NQueueSetCapacity | Sets the capacity of the specified queue.
NQueueToArray | Converts the specified queue into an array.
Collapse Expand Macros
Name | Description
N_QUEUE_SIZE | Defines the size of the queue (default value 36).


NQueueClear Function

NQueueClear Function
NQueue.h

Clears the specified queue.

C++
NResult N_API NQueueClear(NQueue * pQueue);
Collapse Expand Parameters
Parameters | Description
NQueue * pQueue | [in/out] Pointer to the queue.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NQueue.h

Module: NQueue Unit


NQueueContains Function

NQueueContains Function
NQueue.h

Checks whether the specified queue contains the specified value.

C++
NResult N_API NQueueContains(NQueue * pQueue, HNType hValueType, const void * pValue, NSizeType valueSize, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
NQueue * pQueue | [in/out] Pointer to the queue.
HNType hValueType | [in] Handle to the type of the value.
const void * pValue | [in] Pointer to the value.
NSizeType valueSize | [in] Size of the value.
NBool * pResult | [out] NTrue if the queue contains the value; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NQueue.h

Module: NQueue Unit


NQueueCopyTo Function

NQueueCopyTo Function
NQueue.h

Copies the specified queue to an array.

C++
NResult N_API NQueueCopyTo(NQueue * pQueue, HNType hValueType, void * pValues, NSizeType valuesSize, NInt valuesLength);
Collapse Expand Parameters
Parameters | Description
NQueue * pQueue | [in/out] Pointer to the queue.
HNType hValueType | [in] Handle to the type of values in the stack.
void * pValues | [out] Pointer to the array.
NSizeType valuesSize | [in] Size of the array.
NInt valuesLength | [in] Length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NQueue.h

Module: NQueue Unit


NQueueDequeue Function

NQueueDequeue Function
NQueue.h

Retrieves and removes the front element of the specified queue.

C++
NResult N_API NQueueDequeue(NQueue * pQueue, HNType hValueType, void * pValue, NSizeType valueSize);
Collapse Expand Parameters
Parameters | Description
NQueue * pQueue | [in/out] Pointer to the queue.
HNType hValueType | [in] Handle to the type of the value.
void * pValue | [in] Pointer to the value.
NSizeType valueSize | [in] Size of the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NQueue.h

Module: NQueue Unit


NQueueDispose Function

NQueueDispose Function
NQueue.h

Disposes of the specified queue.

C++
NResult N_API NQueueDispose(NQueue * pQueue);
Collapse Expand Parameters
Parameters | Description
NQueue * pQueue | [in/out] Pointer to the queue to dispose of.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NQueue.h

Module: NQueue Unit


NQueueEnqueue Function

NQueueEnqueue Function
NQueue.h

Adds the specified value to the end of the specified queue.

C++
NResult N_API NQueueEnqueue(NQueue * pQueue, HNType hValueType, const void * pValue, NSizeType valueSize);
Collapse Expand Parameters
Parameters | Description
NQueue * pQueue | [in/out] Pointer to the queue.
HNType hValueType | [in] Handle to the type of the value.
const void * pValue | [in] Pointer to the value.
NSizeType valueSize | [in] Size of the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NQueue.h

Module: NQueue Unit


NQueueGetCapacity Function

NQueueGetCapacity Function
NQueue.h

Retrieves the capacity of the specified queue.

C++
NResult N_API NQueueGetCapacity(NQueue * pQueue, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
NQueue * pQueue | [in/out] Pointer to the queue.
NInt * pValue | [out] Pointer to the capacity of the queue.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NQueue.h

Module: NQueue Unit


NQueueGetCount Function

NQueueGetCount Function
NQueue.h

Retrieves the number of values in the specified queue.

C++
NResult N_API NQueueGetCount(NQueue * pQueue, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
NQueue * pQueue | [in/out] Pointer to the queue.
NInt * pValue | [out] Pointer to the number of values in the queue.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NQueue.h

Module: NQueue Unit


NQueueGetFront Function

NQueueGetFront Function
NQueue.h

Retrieves the front element of the queue.

C++
NResult N_API NQueueGetFront(NQueue * pQueue, NSizeType elementSize, HNType hValueType, void * * ppValue);
Collapse Expand Parameters
Parameters | Description
NQueue * pQueue | [in/out] Pointer to the queue.
NSizeType elementSize | [in] The size of the element.
HNType hValueType | [in] Handle to the type of the element value.
void * * ppValue | [out] Pointer to the value of the front element
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NQueue.h

Module: NQueue Unit


NQueueInit Function

NQueueInit Function
NQueue.h

Initializes the specified queue.

C++
NResult N_API NQueueInit(NQueue * pQueue, NSizeType elementSize, HNType hElementType);
Collapse Expand Parameters
Parameters | Description
NQueue * pQueue | [in/out] Pointer to the queue.
NSizeType elementSize | [in] Size of a queue element.
HNType hElementType | [in] Handle to the type of values in the queue.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NQueue.h

Module: NQueue Unit


NQueueInitEx Function

NQueueInitEx Function
NQueue.h

Initializes the specified queue.

C++
NResult N_API NQueueInitEx(NQueue * pQueue, NSizeType elementSize, HNType hElementType, NInt capacity, NInt maxCapacity, NInt growthDelta, NSizeType alignment);
Collapse Expand Parameters
Parameters | Description
NQueue * pQueue | [in/out] Pointer to the queue.
NSizeType elementSize | [in] Size of a queue element.
HNType hElementType | [in] Handle to the type of values in the queue.
NInt capacity | [in] Capacity of the queue.
NInt maxCapacity | [in] Maximal capacity of the queue.
NInt growthDelta | [in] Queue capacity growth.
NSizeType alignment | [in] Queue alignment.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NQueue.h

Module: NQueue Unit


NQueueInitWithCapacity Function

NQueueInitWithCapacity Function
NQueue.h

Initializes the specified queue.

C++
NResult N_API NQueueInitWithCapacity(NQueue * pQueue, NSizeType elementSize, HNType hElementType, NInt capacity);
Collapse Expand Parameters
Parameters | Description
NQueue * pQueue | [in/out] Pointer to the queue.
NSizeType elementSize | [in] Size of a queue element.
HNType hElementType | [in] Handle to the type of values in the queue.
NInt capacity | [in] Capacity of the queue.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NQueue.h

Module: NQueue Unit


NQueuePeek Function

NQueuePeek Function
NQueue.h

Retrieves the front element of the specified queue without removing it.

C++
NResult N_API NQueuePeek(NQueue * pQueue, HNType hValueType, void * pValue, NSizeType valueSize);
Collapse Expand Parameters
Parameters | Description
NQueue * pQueue | [in/out] Pointer to the queue.
HNType hValueType | [in] Handle to the type of the element value.
void * pValue | [out] Pointer to the front element value.
NSizeType valueSize | [in] The size of the element.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NQueue.h

Module: NQueue Unit


NQueueSetCapacity Function

NQueueSetCapacity Function
NQueue.h

Sets the capacity of the specified queue.

C++
NResult N_API NQueueSetCapacity(NQueue * pQueue, NInt value);
Collapse Expand Parameters
Parameters | Description
NQueue * pQueue | [in/out] Pointer to the queue.
NInt value | [in] The capacity of the queue.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NQueue.h

Module: NQueue Unit


NQueueToArray Function

NQueueToArray Function
NQueue.h

Converts the specified queue into an array.

C++
NResult N_API NQueueToArray(NQueue * pQueue, NSizeType elementSize, HNType hValueType, void * * ppValues, NInt * pValuesLength);
Collapse Expand Parameters
Parameters | Description
NQueue * pQueue | [in/out] Pointer to the queue.
NSizeType elementSize | [in] Size of a queue element.
HNType hValueType | [in] Handle to the type of values in the queue.
void * * ppValues | [out] Pointer to the new array.
NInt * pValuesLength | [out] Pointer to length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NQueue.h

Module: NQueue Unit


N_QUEUE_SIZE Macro

N_QUEUE_SIZE Macro
NQueue.h

Defines the size of the queue (default value 36).

C++
#define N_QUEUE_SIZE 36
Container

File: NQueue.h

Module: NQueue Unit


NQueue.h

NQueue.h
Functions Legend Macros

Header file for the NQueue module.

Collapse Expand Functions
Name | Description
NQueueClear | Clears the specified queue.
NQueueContains | Checks whether the specified queue contains the specified value.
NQueueCopyTo | Copies the specified queue to an array.
NQueueDequeue | Retrieves and removes the front element of the specified queue.
NQueueDispose | Disposes of the specified queue.
NQueueEnqueue | Adds the specified value to the end of the specified queue.
NQueueGetCapacity | Retrieves the capacity of the specified queue.
NQueueGetCount | Retrieves the number of values in the specified queue.
NQueueGetFront | Retrieves the front element of the queue.
NQueueInit | Initializes the specified queue.
NQueueInitEx | Initializes the specified queue.
NQueueInitWithCapacity | Initializes the specified queue.
NQueuePeek | Retrieves the front element of the specified queue without removing it.
NQueueSetCapacity | Sets the capacity of the specified queue.
NQueueToArray | Converts the specified queue into an array.
Collapse Expand Macros
Name | Description
N_QUEUE_SIZE | Defines the size of the queue (default value 36).


NReDeprecate Unit

NReDeprecate Unit


NRWLock Unit

NRWLock Unit
Functions Legend

Provides reader/writer functionality.

Collapse Expand Functions
Name | Description
NRWLockDispose | Disposes a reader/writer lock.
NRWLockEnterRead | Acquires a reader/writer lock in shared mode.
NRWLockEnterWrite | Acquires a reader/writer lock in exclusive mode.
NRWLockExitRead | Releases a reader/writer lock that was acquired in shared mode.
NRWLockExitWrite | Releases a reader/writer lock that was acquired in exclusive mode.
NRWLockInit | Initializes a reader/writer lock.
NRWLockTryEnterRead | Acquires a reader/writer lock in shared mode. A NBool value indicates whether the function succeeded.
NRWLockTryEnterWrite | Acquires a reader/writer lock in exclusive mode. A NBool value indicates whether the function succeeded.


NRWLockDispose Function

NRWLockDispose Function

Disposes a reader/writer lock.

C++
void N_API NRWLockDispose(NRWLock * pLock);
Collapse Expand Parameters
Parameters | Description
NRWLock * pLock | [in, out] A pointer to the RW lock.
Container

File: NRWLock.h

Module: NRWLock Unit


NRWLockEnterRead Function

NRWLockEnterRead Function

Acquires a reader/writer lock in shared mode.

C++
void N_API NRWLockEnterRead(NRWLock * pLock);
Collapse Expand Parameters
Parameters | Description
NRWLock * pLock | [in, out] A pointer to the RW lock.
Container

File: NRWLock.h

Module: NRWLock Unit


NRWLockEnterWrite Function

NRWLockEnterWrite Function

Acquires a reader/writer lock in exclusive mode.

C++
void N_API NRWLockEnterWrite(NRWLock * pLock);
Collapse Expand Parameters
Parameters | Description
NRWLock * pLock | [in, out] A pointer to the RW lock.
Container

File: NRWLock.h

Module: NRWLock Unit


NRWLockExitRead Function

NRWLockExitRead Function

Releases a reader/writer lock that was acquired in shared mode.

C++
void N_API NRWLockExitRead(NRWLock * pLock);
Collapse Expand Parameters
Parameters | Description
NRWLock * pLock | [in, out] A pointer to the RW lock.
Container

File: NRWLock.h

Module: NRWLock Unit


NRWLockExitWrite Function

NRWLockExitWrite Function

Releases a reader/writer lock that was acquired in exclusive mode.

C++
void N_API NRWLockExitWrite(NRWLock * pLock);
Collapse Expand Parameters
Parameters | Description
NRWLock * pLock | [in, out] A pointer to the RW lock.
Container

File: NRWLock.h

Module: NRWLock Unit


NRWLockInit Function

NRWLockInit Function

Initializes a reader/writer lock.

C++
void N_API NRWLockInit(NRWLock * pLock);
Collapse Expand Parameters
Parameters | Description
NRWLock * pLock | [in, out] A pointer to the RW lock.
Container

File: NRWLock.h

Module: NRWLock Unit


NRWLockTryEnterRead Function

NRWLockTryEnterRead Function

Acquires a reader/writer lock in shared mode. A NBool value indicates whether the function succeeded.

C++
NBool N_API NRWLockTryEnterRead(NRWLock * pLock);
Collapse Expand Parameters
Parameters | Description
NRWLock * pLock | [in, out] A pointer to the RW lock.
Collapse Expand Returns

NTrue if the function succeeded; else NFalse.

Container

File: NRWLock.h

Module: NRWLock Unit


NRWLockTryEnterWrite Function

NRWLockTryEnterWrite Function

Acquires a reader/writer lock in exclusive mode. A NBool value indicates whether the function succeeded.

C++
NBool N_API NRWLockTryEnterWrite(NRWLock * pLock);
Collapse Expand Parameters
Parameters | Description
NRWLock * pLock | [in, out] A pointer to the RW lock.
Collapse Expand Returns

NTrue if the function succeeded; else NFalse.

Container

File: NRWLock.h

Module: NRWLock Unit


NSemaphore Unit

NSemaphore Unit
Functions Legend See Also

Cross platform semaphore (synchronization primitive) implementation.

Collapse Expand See Also
  • NWaitObject for NSemaphore functionality shared with other synchronization objects.
Collapse Expand Functions
Name | Description
NSemaphoreCreate | Creates and initializes a semaphore object.
NSemaphoreCreateFromOSHandle | Creates a new NSemaphore for the specified semaphore handle.
NSemaphoreGetOSHandle | Gets OS handle for the specified semaphore.
NSemaphoreRelease | Increments the value of the semaphore by one.


NSemaphoreCreate Function

NSemaphoreCreate Function

Creates and initializes a semaphore object.

C++
NResult N_API NSemaphoreCreate(NInt initialCount, HNSemaphore * phSemaphore);
Collapse Expand Parameters
Parameters | Description
NInt initialCount | [in] The initial value of the semaphore (0: non signalled; positive: signalled).
HNSemaphore * phSemaphore | [out] Pointer to the variable that will receive the handle of the created object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

This is usual synchronization semaphore. It's state is described by nonnegative number, the count of wait operations what will complete without blocking. The value is decremented on each successful return from NWaitObjectWaitFor/NWaitObjectTimedWaitFor and when it reaches zero, the threads performing wait operation will block until semaphore value is raised by other threads with NSemaphoreRelease function.

Container

File: NSemaphore.h

Module: NSemaphore Unit


NSemaphoreCreateFromOSHandle Function

NSemaphoreCreateFromOSHandle Function

Creates a new NSemaphore for the specified semaphore handle.

C++
NResult N_API NSemaphoreCreateFromOSHandle(NHandle handle, NBool ownsHandle, HNSemaphore * phSemaphore);
Collapse Expand Parameters
Parameters | Description
NHandle handle | [in] A semaphore handle for the semaphore that the current NSemaphore will encapsulate.
NBool ownsHandle | [in] NTrue if the semaphore handle will be owned by this NSemaphore; otherwise, NFalse.
HNSemaphore * phSemaphore | [out] A pointer to the created NSemaphore.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSemaphore.h

Module: NSemaphore Unit


NSemaphoreGetOSHandle Function

NSemaphoreGetOSHandle Function

Gets OS handle for the specified semaphore.

C++
NResult N_API NSemaphoreGetOSHandle(HNSemaphore hSemaphore, NHandle * phValue);
Collapse Expand Parameters
Parameters | Description
HNSemaphore hSemaphore | [in] A handle to NSemaphore.
NHandle * phValue | [out] OS handle to a semaphore.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSemaphore.h

Module: NSemaphore Unit


NSemaphoreRelease Function

NSemaphoreRelease Function

Increments the value of the semaphore by one.

C++
NResult N_API NSemaphoreRelease(HNSemaphore hSemaphore);
Collapse Expand Parameters
Parameters | Description
HNSemaphore hSemaphore | [in] Handle of the semaphore.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks
  • The NSemaphore is derived from NWaitObject. The NWaitObjectWaitFor or NWaitObjectTimedWaitFor should be used with the semaphore handle to wait until value can be decremented.
  • If upon the call the value of the semaphore was 0 (nonsignalled) and some threads are blocked waiting for the semaphore to become signalled one thread will be woken and wait function will return successfully decrementing the value back to 0.
Container

File: NSemaphore.h

Module: NSemaphore Unit


NStack Unit

NStack Unit
Files Functions Legend Macros

Provides functionality for working with stacks.

Collapse Expand Files
Name | Description
NStack.h | Header file for the NStack module.
Collapse Expand Functions
Name | Description
NStackClear | Clears the specified stack.
NStackContains | Checks whether the specified stack contains the specified value.
NStackCopyTo | Copies the specified stack to an array.
NStackDispose | Disposes of the specified stack.
NStackGetCapacity | Retrieves the capacity of the specified stack.
NStackGetCount | Retrieves the number of values in the specified stack.
NStackGetTop | Retrieves the top element of the stack.
NStackInit | Initializes the specified stack.
NStackInitEx | Initializes the specified stack.
NStackInitWithCapacity | Initializes the specified stack.
NStackPeek | Retrieves the top element of the specified stack without removing it.
NStackPop | Retrieves and removes the top element of the specified stack.
NStackPush | Inserts an object at the top of the specified stack.
NStackSetCapacity | Sets the capacity of the specified stack.
NStackToArray | Converts the specified stack into an array.
Collapse Expand Macros
Name | Description
N_STACK_SIZE | Defines the size of the stack (default value 32).


NStackClear Function

NStackClear Function
NStack.h

Clears the specified stack.

C++
NResult N_API NStackClear(NStack * pStack);
Collapse Expand Parameters
Parameters | Description
NStack * pStack | [in/out] Pointer to the cleared stack.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStack.h

Module: NStack Unit


NStackContains Function

NStackContains Function
NStack.h

Checks whether the specified stack contains the specified value.

C++
NResult N_API NStackContains(NStack * pStack, HNType hValueType, const void * pValue, NSizeType valueSize, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
NStack * pStack | [in/out] Pointer to the stack.
HNType hValueType | [in] Handle to the type of the value.
const void * pValue | [in] Pointer to the value.
NSizeType valueSize | [in] Size of the value.
NBool * pResult | [out] NTrue if the stack contains the value; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStack.h

Module: NStack Unit


NStackCopyTo Function

NStackCopyTo Function
NStack.h

Copies the specified stack to an array.

C++
NResult N_API NStackCopyTo(NStack * pStack, HNType hValueType, void * pValues, NSizeType valuesSize, NInt valuesLength);
Collapse Expand Parameters
Parameters | Description
NStack * pStack | [in/out] Pointer to the stack.
HNType hValueType | [in] Handle to the type of values in the stack.
void * pValues | [out] Pointer to the array.
NSizeType valuesSize | [in] Size of the array.
NInt valuesLength | [in] Length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStack.h

Module: NStack Unit


NStackDispose Function

NStackDispose Function
NStack.h

Disposes of the specified stack.

C++
NResult N_API NStackDispose(NStack * pStack);
Collapse Expand Parameters
Parameters | Description
NStack * pStack | [in/out] Pointer to the stack to dispose of.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStack.h

Module: NStack Unit


NStackGetCapacity Function

NStackGetCapacity Function
NStack.h

Retrieves the capacity of the specified stack.

C++
NResult N_API NStackGetCapacity(NStack * pStack, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
NStack * pStack | [in/out] Pointer to the stack.
NInt * pValue | [out] Pointer to the capacity of the stack.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStack.h

Module: NStack Unit


NStackGetCount Function

NStackGetCount Function
NStack.h

Retrieves the number of values in the specified stack.

C++
NResult N_API NStackGetCount(NStack * pStack, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
NStack * pStack | [in/out] Pointer to the stack.
NInt * pValue | [out] Pointer to the number of values in the stack.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStack.h

Module: NStack Unit


NStackGetTop Function

NStackGetTop Function
NStack.h

Retrieves the top element of the stack.

C++
NResult N_API NStackGetTop(NStack * pStack, NSizeType elementSize, HNType hValueType, void * * ppValue);
Collapse Expand Parameters
Parameters | Description
NStack * pStack | [in/out] Pointer to the stack.
NSizeType elementSize | [in] The size of the element.
HNType hValueType | [in] Handle to the type of the element value.
void * * ppValue | [out] Pointer to the value of the top element
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStack.h

Module: NStack Unit


NStackInit Function

NStackInit Function
NStack.h

Initializes the specified stack.

C++
NResult N_API NStackInit(NStack * pStack, NSizeType elementSize, HNType hElementType);
Collapse Expand Parameters
Parameters | Description
NStack * pStack | [in/out] Pointer to the stack.
NSizeType elementSize | [in] Size of a stack element.
HNType hElementType | [in] Handle to the type of values in the stack.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStack.h

Module: NStack Unit


NStackInitEx Function

NStackInitEx Function
NStack.h

Initializes the specified stack.

C++
NResult N_API NStackInitEx(NStack * pStack, NSizeType elementSize, HNType hElementType, NInt capacity, NInt maxCapacity, NInt growthDelta, NSizeType alignment);
Collapse Expand Parameters
Parameters | Description
NStack * pStack | [in/out] Pointer to the stack.
NSizeType elementSize | [in] Size of a stack element.
HNType hElementType | [in] Handle to the type of values in the stack.
NInt capacity | [in] Capacity of the stack.
NInt maxCapacity | [in] Maximal capacity of the stack.
NInt growthDelta | [in] Stack capacity growth.
NSizeType alignment | [in] Stack alignment.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStack.h

Module: NStack Unit


NStackInitWithCapacity Function

NStackInitWithCapacity Function
NStack.h

Initializes the specified stack.

C++
NResult N_API NStackInitWithCapacity(NStack * pStack, NSizeType elementSize, HNType hElementType, NInt capacity);
Collapse Expand Parameters
Parameters | Description
NStack * pStack | [in/out] Pointer to the stack.
NSizeType elementSize | [in] Size of a stack element.
HNType hElementType | [in] Handle to the type of values in the stack.
NInt capacity | [in] Capacity of the stack.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStack.h

Module: NStack Unit


NStackPeek Function

NStackPeek Function
NStack.h

Retrieves the top element of the specified stack without removing it.

C++
NResult N_API NStackPeek(NStack * pStack, HNType hValueType, void * pValue, NSizeType valueSize);
Collapse Expand Parameters
Parameters | Description
NStack * pStack | [in/out] Pointer to the stack.
HNType hValueType | [in] Handle to the type of the element value.
void * pValue | [out] Pointer to the top element value.
NSizeType valueSize | [in] The size of the element.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStack.h

Module: NStack Unit


NStackPop Function

NStackPop Function
NStack.h

Retrieves and removes the top element of the specified stack.

C++
NResult N_API NStackPop(NStack * pStack, HNType hValueType, void * pValue, NSizeType valueSize);
Collapse Expand Parameters
Parameters | Description
NStack * pStack | [in/out] Pointer to the stack.
HNType hValueType | [in] Handle to the type of the element value.
void * pValue | [out] Pointer to the top element value.
NSizeType valueSize | [in] The size of the element.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStack.h

Module: NStack Unit


NStackPush Function

NStackPush Function
NStack.h

Inserts an object at the top of the specified stack.

C++
NResult N_API NStackPush(NStack * pStack, HNType hValueType, const void * pValue, NSizeType valueSize);
Collapse Expand Parameters
Parameters | Description
NStack * pStack | [in/out] Pointer to the stack.
HNType hValueType | [in] Handle to the type of the value.
const void * pValue | [in] Pointer to the value to be inserted.
NSizeType valueSize | [in] The size of the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStack.h

Module: NStack Unit


NStackSetCapacity Function

NStackSetCapacity Function
NStack.h

Sets the capacity of the specified stack.

C++
NResult N_API NStackSetCapacity(NStack * pStack, NInt value);
Collapse Expand Parameters
Parameters | Description
NStack * pStack | [in/out] Pointer to the stack.
NInt value | [in] The capacity of the stack.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStack.h

Module: NStack Unit


NStackToArray Function

NStackToArray Function
NStack.h

Converts the specified stack into an array.

C++
NResult N_API NStackToArray(NStack * pStack, NSizeType elementSize, HNType hValueType, void * * ppValues, NInt * pValuesLength);
Collapse Expand Parameters
Parameters | Description
NStack * pStack | [in/out] Pointer to the stack.
NSizeType elementSize | [in] Size of a stack element.
HNType hValueType | [in] Handle to the type of values in the stack.
void * * ppValues | [out] Pointer to the new array.
NInt * pValuesLength | [out] Pointer to length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStack.h

Module: NStack Unit


N_STACK_SIZE Macro

N_STACK_SIZE Macro
NStack.h

Defines the size of the stack (default value 32).

C++
#define N_STACK_SIZE 32
Container

File: NStack.h

Module: NStack Unit


NStack.h

NStack.h
Functions Legend Macros

Header file for the NStack module.

Collapse Expand Functions
Name | Description
NStackClear | Clears the specified stack.
NStackContains | Checks whether the specified stack contains the specified value.
NStackCopyTo | Copies the specified stack to an array.
NStackDispose | Disposes of the specified stack.
NStackGetCapacity | Retrieves the capacity of the specified stack.
NStackGetCount | Retrieves the number of values in the specified stack.
NStackGetTop | Retrieves the top element of the stack.
NStackInit | Initializes the specified stack.
NStackInitEx | Initializes the specified stack.
NStackInitWithCapacity | Initializes the specified stack.
NStackPeek | Retrieves the top element of the specified stack without removing it.
NStackPop | Retrieves and removes the top element of the specified stack.
NStackPush | Inserts an object at the top of the specified stack.
NStackSetCapacity | Sets the capacity of the specified stack.
NStackToArray | Converts the specified stack into an array.
Collapse Expand Macros
Name | Description
N_STACK_SIZE | Defines the size of the stack (default value 32).


NStopwatch Unit

NStopwatch Unit
Functions Legend

Provides a set of methods and properties that you can use to accurately measure elapsed time.

Collapse Expand Functions
Name | Description
NStopwatchCreate | Creates a new NStopwatch object.
NStopwatchGetElapsed | Gets the total elapsed time measured by the specified NStopwatch.
NStopwatchGetElapsedMilliseconds | Gets the total elapsed time measured by the specified NStopwatch, in milliseconds.
NStopwatchGetElapsedTicks | Gets the total elapsed time measured by the specified NStopwatch, in timer ticks.
NStopwatchGetFrequency | Gets the frequency of the timer as the number of ticks per second.
NStopwatchGetTimestamp | Gets the current number of ticks in the timer mechanism.
NStopwatchIsHighResolution | Indicates whether the timer is based on a high-resolution performance counter.
NStopwatchIsRunning | Gets a value indicating whether the NStopwatch timer is running.
NStopwatchReset | Stops time interval measurement and resets the elapsed time to zero.
NStopwatchRestart | Stops time interval measurement, resets the elapsed time to zero, and starts measuring elapsed time.
NStopwatchStart | Starts, or resumes, measuring elapsed time for an interval.
NStopwatchStartNew | Creates a new NStopwatch object, sets the elapsed time property to zero, and starts measuring elapsed time.
NStopwatchStop | Stops measuring elapsed time for an interval.
NStopwatchTicksToMilliseconds | Converts elapsed time in ticks to milliseconds.


NStopwatchCreate Function

NStopwatchCreate Function

Creates a new NStopwatch object.

C++
NResult N_API NStopwatchCreate(HNStopwatch * phStopwatch);
Collapse Expand Parameters
Parameters | Description
HNStopwatch * phStopwatch | [out] Pointer to a handle to the new NStopwatch object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStopwatch.h

Module: NStopwatch Unit


NStopwatchGetElapsed Function

NStopwatchGetElapsed Function

Gets the total elapsed time measured by the specified NStopwatch.

C++
NResult N_API NStopwatchGetElapsed(HNStopwatch hStopwatch, NTimeSpan_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNStopwatch hStopwatch | [in] Handle to the NStopwatch.
NTimeSpan_ * pValue | [out] Pointer to the TimeSpan representing the elapsed time.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStopwatch.h

Module: NStopwatch Unit


NStopwatchGetElapsedMilliseconds Function

NStopwatchGetElapsedMilliseconds Function

Gets the total elapsed time measured by the specified NStopwatch, in milliseconds.

C++
NResult N_API NStopwatchGetElapsedMilliseconds(HNStopwatch hStopwatch, NLong * pValue);
Collapse Expand Parameters
Parameters | Description
HNStopwatch hStopwatch | [in] Handle to the NStopwatch.
NLong * pValue | [out] Pointer to the elapsed time in milliseconds.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStopwatch.h

Module: NStopwatch Unit


NStopwatchGetElapsedTicks Function

NStopwatchGetElapsedTicks Function

Gets the total elapsed time measured by the specified NStopwatch, in timer ticks.

C++
NResult N_API NStopwatchGetElapsedTicks(HNStopwatch hStopwatch, NLong * pValue);
Collapse Expand Parameters
Parameters | Description
HNStopwatch hStopwatch | [in] Handle to the NStopwatch.
NLong * pValue | [out] Number of timer ticks representing the elapsed time.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStopwatch.h

Module: NStopwatch Unit


NStopwatchGetFrequency Function

NStopwatchGetFrequency Function

Gets the frequency of the timer as the number of ticks per second.

C++
NResult N_API NStopwatchGetFrequency(NLong * pValue);
Collapse Expand Parameters
Parameters | Description
NLong * pValue | [out] Pointer to the number of ticks per second.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStopwatch.h

Module: NStopwatch Unit


NStopwatchGetTimestamp Function

NStopwatchGetTimestamp Function

Gets the current number of ticks in the timer mechanism.

C++
NResult N_API NStopwatchGetTimestamp(NLong * pValue);
Collapse Expand Parameters
Parameters | Description
NLong * pValue | [out] Pointer to the tick counter value of the underlying timer mechanism.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStopwatch.h

Module: NStopwatch Unit


NStopwatchIsHighResolution Function

NStopwatchIsHighResolution Function

Indicates whether the timer is based on a high-resolution performance counter.

C++
NResult N_API NStopwatchIsHighResolution(NBool * pValue);
Collapse Expand Parameters
Parameters | Description
NBool * pValue | [out] Pointer to NBool value indicating whether the timer is based on a high-resolution performance counter.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStopwatch.h

Module: NStopwatch Unit


NStopwatchIsRunning Function

NStopwatchIsRunning Function

Gets a value indicating whether the NStopwatch timer is running.

C++
NResult N_API NStopwatchIsRunning(HNStopwatch hStopwatch, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNStopwatch hStopwatch | [in] Handle to the NStopwatch.
NBool * pValue | [out] NTrue if NStopwatch is running; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStopwatch.h

Module: NStopwatch Unit


NStopwatchReset Function

NStopwatchReset Function

Stops time interval measurement and resets the elapsed time to zero.

C++
NResult N_API NStopwatchReset(HNStopwatch hStopwatch);
Collapse Expand Parameters
Parameters | Description
HNStopwatch hStopwatch | [in] Handle to the NStopwatch object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStopwatch.h

Module: NStopwatch Unit


NStopwatchRestart Function

NStopwatchRestart Function

Stops time interval measurement, resets the elapsed time to zero, and starts measuring elapsed time.

C++
NResult N_API NStopwatchRestart(HNStopwatch hStopwatch);
Collapse Expand Parameters
Parameters | Description
HNStopwatch hStopwatch | [in] Handle to the NStopwatch object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStopwatch.h

Module: NStopwatch Unit


NStopwatchStart Function

NStopwatchStart Function

Starts, or resumes, measuring elapsed time for an interval.

C++
NResult N_API NStopwatchStart(HNStopwatch hStopwatch);
Collapse Expand Parameters
Parameters | Description
HNStopwatch hStopwatch | [in] Handle to the NStopwatch object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStopwatch.h

Module: NStopwatch Unit


NStopwatchStartNew Function

NStopwatchStartNew Function

Creates a new NStopwatch object, sets the elapsed time property to zero, and starts measuring elapsed time.

C++
NResult N_API NStopwatchStartNew(HNStopwatch * phStopwatch);
Collapse Expand Parameters
Parameters | Description
HNStopwatch * phStopwatch | [out] Pointer to a handle to the new NStopwatch object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStopwatch.h

Module: NStopwatch Unit


NStopwatchStop Function

NStopwatchStop Function

Stops measuring elapsed time for an interval.

C++
NResult N_API NStopwatchStop(HNStopwatch hStopwatch);
Collapse Expand Parameters
Parameters | Description
HNStopwatch hStopwatch | [in] Handle to the NStopwatch object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStopwatch.h

Module: NStopwatch Unit


NStopwatchTicksToMilliseconds Function

NStopwatchTicksToMilliseconds Function

Converts elapsed time in ticks to milliseconds.

C++
NResult N_API NStopwatchTicksToMilliseconds(NLong ticks, NLong * pValue);
Collapse Expand Parameters
Parameters | Description
NLong ticks | [in] Elapsed time in ticks.
NLong * pValue | [out] Elapsed time in milliseconds.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStopwatch.h

Module: NStopwatch Unit


NStream Unit

NStream Unit
Functions Legend

Supports internal Neurotechnology libraries infrastructure and should not be used directly in your code.

Collapse Expand Functions
Name | Description
NStreamCanRead | Gets a value indicating whether the current stream supports reading.
NStreamCanSeek | Gets a value indicating whether the current stream supports seeking.
NStreamCanWrite | Gets a value indicating whether the current stream supports writing.
NStreamCopyTo | Reads the bytes from the current NStream and writes them to another NStream.
NStreamCopyToWithBufferSize | Reads the bytes from the current NStream and writes them to another NStream, using a specified buffer size.
NStreamFlush | Clears all buffers for this stream and causes any buffered data to be written to the underlying device.
NStreamGetLength | Gets the length in bytes of the NStream.
NStreamGetNull | Returns NStream with no backing store.
NStreamGetPosition | Gets the position within the current NStream.
NStreamRead | Reads a sequence of bytes from the NStream and advances the position within the stream by the number of bytes read.
NStreamReadByte | Reads a byte from NStream and advances the position within NStream by one byte, or returns -1 if at the end of NStream.
NStreamReadN | ... more
NStreamSeek | Sets the position within NStream.
NStreamSetLength | Sets the length in bytes of the NStream.
NStreamSetPosition | Sets the position within the current NStream.
NStreamSynchronized | Creates a thread-safe (synchronized) wrapper around the NStream.
NStreamWrite | Writes a sequence of bytes from an array to NStream and advances the current position within NStream by the number of bytes written.
NStreamWriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte.
NStreamWriteN | Writes a sequence of bytes from NBuffer to NStream and advances the current position within NStream by the number of bytes written.


NStreamCanRead Function

NStreamCanRead Function

Gets a value indicating whether the current stream supports reading.

C++
NResult N_API NStreamCanRead(HNStream hStream, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNStream hStream | [in] A handle to NStream.
NBool * pValue | [out] A pointer to NTrue if the NStream supports reading; otherwise, to NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStream.h

Module: NStream Unit


NStreamCanSeek Function

NStreamCanSeek Function

Gets a value indicating whether the current stream supports seeking.

C++
NResult N_API NStreamCanSeek(HNStream hStream, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNStream hStream | [in] A handle to NStream.
NBool * pValue | [out] A pointer to NTrue if the NStream supports seeking; otherwise, to NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStream.h

Module: NStream Unit


NStreamCanWrite Function

NStreamCanWrite Function

Gets a value indicating whether the current stream supports writing.

C++
NResult N_API NStreamCanWrite(HNStream hStream, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNStream hStream | [in] A handle to NStream.
NBool * pValue | [out] A pointer to NTrue if the NStream supports writing; otherwise, to NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStream.h

Module: NStream Unit


NStreamCopyTo Function

NStreamCopyTo Function

Reads the bytes from the current NStream and writes them to another NStream.

C++
NResult N_API NStreamCopyTo(HNStream hStream, HNStream hDstStream);
Collapse Expand Parameters
Parameters | Description
HNStream hStream | [in] A handle to the current NStream.
HNStream hDstStream | [in] A handle to the destination NStream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStream.h

Module: NStream Unit


NStreamCopyToWithBufferSize Function

NStreamCopyToWithBufferSize Function

Reads the bytes from the current NStream and writes them to another NStream, using a specified buffer size.

C++
NResult N_API NStreamCopyToWithBufferSize(HNStream hStream, HNStream hDstStream, NSizeType bufferSize);
Collapse Expand Parameters
Parameters | Description
HNStream hStream | [in] A handle to the current NStream.
HNStream hDstStream | [in] A handle to the destination NStream.
NSizeType bufferSize | [in] The size of the buffer. This value must be greater than zero. The default size is 4096.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStream.h

Module: NStream Unit


NStreamFlush Function

NStreamFlush Function

Clears all buffers for this stream and causes any buffered data to be written to the underlying device.

C++
NResult N_API NStreamFlush(HNStream hStream);
Collapse Expand Parameters
Parameters | Description
HNStream hStream | [in] A handle to NStream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStream.h

Module: NStream Unit


NStreamGetLength Function

NStreamGetLength Function

Gets the length in bytes of the NStream.

C++
NResult N_API NStreamGetLength(HNStream hStream, NLong * pValue);
Collapse Expand Parameters
Parameters | Description
HNStream hStream | [in] A handle to NStream.
NLong * pValue | [out] A pointer to a long value representing the length of the NStream in bytes.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStream.h

Module: NStream Unit


NStreamGetNull Function

NStreamGetNull Function

Returns NStream with no backing store.

C++
NResult N_API NStreamGetNull(HNStream * phValue);
Collapse Expand Parameters
Parameters | Description
HNStream * phValue | [out] A pointer to NStream with no backing store.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

NObjectUnref shall be called on returned objects when they are no longer used to prevent memory leaks.

Container

File: NStream.h

Module: NStream Unit


NStreamGetPosition Function

NStreamGetPosition Function

Gets the position within the current NStream.

C++
NResult N_API NStreamGetPosition(HNStream hStream, NLong * pValue);
Collapse Expand Parameters
Parameters | Description
HNStream hStream | [in] A handle to NStream.
NLong * pValue | [out] A pointer to the current position within NStream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStream.h

Module: NStream Unit


NStreamRead Function

NStreamRead Function

Reads a sequence of bytes from the NStream and advances the position within the stream by the number of bytes read.

C++
NResult N_API NStreamRead(HNStream hStream, void * pBuffer, NSizeType bufferSize, NSizeType * pSizeRead);
Collapse Expand Parameters
Parameters | Description
HNStream hStream | [in] A handle to NStream.
void * pBuffer | [in] A pointer to NBuffer to write the data into.
NSizeType bufferSize | [in] Size of NBuffer in bytes.
NSizeType * pSizeRead | [out] A pointer to the number of bytes read.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStream.h

Module: NStream Unit


NStreamReadByte Function

NStreamReadByte Function

Reads a byte from NStream and advances the position within NStream by one byte, or returns -1 if at the end of NStream.

C++
NResult N_API NStreamReadByte(HNStream hStream, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNStream hStream | [in] A handle to NStream.
NInt * pValue | [out] A pointer to the unsigned byte cast to a NInt32, or -1 if at the end of NStream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStream.h

Module: NStream Unit


NStreamReadN Function

NStreamReadN Function

Reads a sequence of bytes from NBuffer to NStream and advances the current position within NStream by the number of bytes read.

C++
NResult N_API NStreamReadN(HNStream hStream, HNBuffer hBuffer, NSizeType * pSizeRead);
Collapse Expand Parameters
Parameters | Description
HNStream hStream | [in] A handle to NStream.
HNBuffer hBuffer | [in] A handle to NBuffer to write the data into.
NSizeType * pSizeRead | [out] A pointer to the number of bytes read.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStream.h

Module: NStream Unit


NStreamSeek Function

NStreamSeek Function

Sets the position within NStream.

C++
NResult N_API NStreamSeek(HNStream hStream, NLong offset, NSeekOrigin origin);
Collapse Expand Parameters
Parameters | Description
HNStream hStream | [in] A handle to NStream.
NLong offset | [in] A byte offset relative to the origin parameter.
NSeekOrigin origin | [in] A value of type NSeekOrigin indicating the reference point used to obtain the new position.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStream.h

Module: NStream Unit


NStreamSetLength Function

NStreamSetLength Function

Sets the length in bytes of the NStream.

C++
NResult N_API NStreamSetLength(HNStream hStream, NLong value);
Collapse Expand Parameters
Parameters | Description
HNStream hStream | [in] A handle to NStream.
NLong value | [in] A long value representing the length of the NStream in bytes.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStream.h

Module: NStream Unit


NStreamSetPosition Function

NStreamSetPosition Function

Sets the position within the current NStream.

C++
NResult N_API NStreamSetPosition(HNStream hStream, NLong value);
Collapse Expand Parameters
Parameters | Description
HNStream hStream | [in] A handle to NStream.
NLong value | [in] The position within NStream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStream.h

Module: NStream Unit


NStreamSynchronized Function

NStreamSynchronized Function

Creates a thread-safe (synchronized) wrapper around the NStream.

C++
NResult N_API NStreamSynchronized(HNStream hStream, HNStream * phValue);
Collapse Expand Parameters
Parameters | Description
HNStream hStream | [in] A handle to NStream to synchronize
HNStream * phValue | [out] A pointer to synchronized NStream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStream.h

Module: NStream Unit


NStreamWrite Function

NStreamWrite Function

Writes a sequence of bytes from an array to NStream and advances the current position within NStream by the number of bytes written.

C++
NResult N_API NStreamWrite(HNStream hStream, const void * pBuffer, NSizeType bufferSize);
Collapse Expand Parameters
Parameters | Description
HNStream hStream | [in] A handle to NStream.
const void * pBuffer | [in] A pointer to an array of bytes.
NSizeType bufferSize | [in] The size of the array of bytes.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStream.h

Module: NStream Unit


NStreamWriteByte Function

NStreamWriteByte Function

Writes a byte to the current position in the stream and advances the position within the stream by one byte.

C++
NResult N_API NStreamWriteByte(HNStream hStream, NByte value);
Collapse Expand Parameters
Parameters | Description
HNStream hStream | [in] A handle to NStream.
NByte value | [in] The byte to write to the stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStream.h

Module: NStream Unit


NStreamWriteN Function

NStreamWriteN Function

Writes a sequence of bytes from NBuffer to NStream and advances the current position within NStream by the number of bytes written.

C++
NResult N_API NStreamWriteN(HNStream hStream, HNBuffer hBuffer);
Collapse Expand Parameters
Parameters | Description
HNStream hStream | [in] A handle to NStream.
HNBuffer hBuffer | [in] A handle to NBuffer to write data from.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStream.h

Module: NStream Unit


NStreamReader Unit

NStreamReader Unit
Functions Legend Macros

Implements a TextReader that reads characters from a byte stream in a particular encoding.

Collapse Expand Functions
Name | Description
NStreamReaderCreate | Creates a new NStreamReader class for the specified NStream.
NStreamReaderCreateFromFile | Creates a new NStreamReader for the specified file.
NStreamReaderCreateFromFileWithEncoding | Creates a new NStreamReader for the specified file with specified encoding.
NStreamReaderCreateFromFileWithEncodingAndBufferSize | Creates a new NStreamReader for the specified file with specified encoding and buffer size.
NStreamReaderCreateWithEncoding | Creates a new NStreamReader for the specified NStream with specified encoding.
NStreamReaderCreateWithEncodingAndBufferSize | Creates a new NStreamReader for the specified NStream with specified encoding and buffer size.
NStreamReaderGetBaseStream | Returns the underlying stream of the specified stream reader.
NStreamReaderGetCurrentEncoding | Gets the current encoding of the specified stream reader.
NStreamReaderGetNull | Creates a NStreamReader object around an empty stream.
NStreamReaderIsEndOfStream | Checks whether the current stream position is at the end of the stream.
Collapse Expand Macros
Name | Description
NStreamReaderCreateFromFile | Picks a Unicode (W) or ASCII (A) version of the NStreamReaderCreateFromFile function.
NStreamReaderCreateFromFileWithEncoding | Picks a Unicode (W) or ASCII (A) version of the NStreamReaderCreateFromFileWithEncoding function.
NStreamReaderCreateFromFileWithEncodingAndBufferSize | Picks a Unicode (W) or ASCII (A) version of the NStreamReaderCreateFromFileWithEncodingAndBufferSize function.


NStreamReaderCreate Function

NStreamReaderCreate Function

Creates a new NStreamReader class for the specified NStream.

C++
NResult N_API NStreamReaderCreate(HNStream hStream, HNStreamReader * phReader);
Collapse Expand Parameters
Parameters | Description
HNStream hStream | [in] Handle to the NStream.
HNStreamReader * phReader | [out] Pointer to a handle to the new NStreamReader.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStreamReader.h

Module: NStreamReader Unit


NStreamReaderCreateFromFile Function

NStreamReaderCreateFromFile Function

Creates a new NStreamReader for the specified file.

C++
NResult N_API NStreamReaderCreateFromFile(const NChar * szFileName, HNStreamReader * phReader);
Collapse Expand Parameters
Parameters | Description
const NChar * szFileName | [in] Pointer to the name of the file.
HNStreamReader * phReader | [out] Pointer to a handle to the new NStreamReader.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStreamReader.h

Module: NStreamReader Unit


NStreamReaderCreateFromFileWithEncoding Function

NStreamReaderCreateFromFileWithEncoding Function

Creates a new NStreamReader for the specified file with specified encoding.

C++
NResult N_API NStreamReaderCreateFromFileWithEncoding(const NChar * szFileName, NEncoding encoding, NBool detectEncodingFromByteOrderMarks, HNStreamReader * phReader);
Collapse Expand Parameters
Parameters | Description
const NChar * szFileName | [in] Pointer to the name of the file.
NEncoding encoding | [in] The encoding.
NBool detectEncodingFromByteOrderMarks | [in] NTrue if the encoding should be detected from byte order marks; else NFalse.
HNStreamReader * phReader | [out] Pointer to a handle to the new NStreamReader.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStreamReader.h

Module: NStreamReader Unit


NStreamReaderCreateFromFileWithEncodingAndBufferSize Function

NStreamReaderCreateFromFileWithEncodingAndBufferSize Function

Creates a new NStreamReader for the specified file with specified encoding and buffer size.

C++
NResult N_API NStreamReaderCreateFromFileWithEncodingAndBufferSize(const NChar * szFileName, NEncoding encoding, NBool detectEncodingFromByteOrderMarks, NSizeType bufferSize, HNStreamReader * phReader);
Collapse Expand Parameters
Parameters | Description
const NChar * szFileName | [in] Pointer to the name of the file.
NEncoding encoding | [in] The encoding.
NBool detectEncodingFromByteOrderMarks | [in] NTrue if the encoding should be detected from byte order marks; else NFalse.
NSizeType bufferSize | [in] The buffer size.
HNStreamReader * phReader | [out] Pointer to a handle to the new NStreamReader.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStreamReader.h

Module: NStreamReader Unit


NStreamReaderCreateWithEncoding Function

NStreamReaderCreateWithEncoding Function

Creates a new NStreamReader for the specified NStream with specified encoding.

C++
NResult N_API NStreamReaderCreateWithEncoding(HNStream hStream, NEncoding encoding, NBool detectEncodingFromByteOrderMarks, HNStreamReader * phReader);
Collapse Expand Parameters
Parameters | Description
HNStream hStream | [in] Handle to the NStream.
NEncoding encoding | [in] The encoding.
NBool detectEncodingFromByteOrderMarks | [in] NTrue if the encoding should be detected from byte order marks; else NFalse.
HNStreamReader * phReader | [out] Pointer to a handle to the new NStreamReader.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStreamReader.h

Module: NStreamReader Unit


NStreamReaderCreateWithEncodingAndBufferSize Function

NStreamReaderCreateWithEncodingAndBufferSize Function

Creates a new NStreamReader for the specified NStream with specified encoding and buffer size.

C++
NResult N_API NStreamReaderCreateWithEncodingAndBufferSize(HNStream hStream, NEncoding encoding, NBool detectEncodingFromByteOrderMarks, NSizeType bufferSize, HNStreamReader * phReader);
Collapse Expand Parameters
Parameters | Description
HNStream hStream | [in] Handle to the NStream.
NEncoding encoding | [in] The encoding.
NBool detectEncodingFromByteOrderMarks | [in] NTrue if the encoding should be detected from byte order marks; else NFalse.
NSizeType bufferSize | [in] The buffer size.
HNStreamReader * phReader | [out] Pointer to a handle to the new NStreamReader.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStreamReader.h

Module: NStreamReader Unit


NStreamReaderGetBaseStream Function

NStreamReaderGetBaseStream Function

Returns the underlying stream of the specified stream reader.

C++
NResult N_API NStreamReaderGetBaseStream(HNStreamReader hReader, HNStream * phValue);
Collapse Expand Parameters
Parameters | Description
HNStreamReader hReader | [in] Handle to the NStreamReader.
HNStream * phValue | [out] Pointer to a handle to the underlying NStream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStreamReader.h

Module: NStreamReader Unit


NStreamReaderGetCurrentEncoding Function

NStreamReaderGetCurrentEncoding Function

Gets the current encoding of the specified stream reader.

C++
NResult N_API NStreamReaderGetCurrentEncoding(HNStreamReader hReader, NEncoding * pValue);
Collapse Expand Parameters
Parameters | Description
HNStreamReader hReader | [in] Handle to the NStreamReader.
NEncoding * pValue | [out] Pointer to the encoding of the stream reader.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStreamReader.h

Module: NStreamReader Unit


NStreamReaderGetNull Function

NStreamReaderGetNull Function

Creates a NStreamReader object around an empty stream.

C++
NResult N_API NStreamReaderGetNull(HNStreamReader * phValue);
Collapse Expand Parameters
Parameters | Description
HNStreamReader * phValue | [out] Pointer to a handle to the NStreamReader.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStreamReader.h

Module: NStreamReader Unit


NStreamReaderIsEndOfStream Function

NStreamReaderIsEndOfStream Function

Checks whether the current stream position is at the end of the stream.

C++
NResult N_API NStreamReaderIsEndOfStream(HNStreamReader hReader, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNStreamReader hReader | [in] Handle to the NStreamReader.
NBool * pValue | [out] Pointer to a value indicating whether the current stream position is at the end of the stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStreamReader.h

Module: NStreamReader Unit


NStreamReaderCreateFromFile Macro

NStreamReaderCreateFromFile Macro

Picks a Unicode (W) or ASCII (A) version of the NStreamReaderCreateFromFile function.

C++
#define NStreamReaderCreateFromFile N_FUNC_AW(NStreamReaderCreateFromFile)
Container

File: NStreamReader.h

Module: NStreamReader Unit


NStreamReaderCreateFromFileWithEncoding Macro

NStreamReaderCreateFromFileWithEncoding Macro

Picks a Unicode (W) or ASCII (A) version of the NStreamReaderCreateFromFileWithEncoding function.

C++
#define NStreamReaderCreateFromFileWithEncoding N_FUNC_AW(NStreamReaderCreateFromFileWithEncoding)
Container

File: NStreamReader.h

Module: NStreamReader Unit


NStreamReaderCreateFromFileWithEncodingAndBufferSize Macro

NStreamReaderCreateFromFileWithEncodingAndBufferSize Macro

Picks a Unicode (W) or ASCII (A) version of the NStreamReaderCreateFromFileWithEncodingAndBufferSize function.

C++
#define NStreamReaderCreateFromFileWithEncodingAndBufferSize N_FUNC_AW(NStreamReaderCreateFromFileWithEncodingAndBufferSize)
Container

File: NStreamReader.h

Module: NStreamReader Unit


NStreamWriter Unit

NStreamWriter Unit
Functions Legend Macros

Implements a TextWriter for writing characters to a stream in a particular encoding.

Collapse Expand Functions
Name | Description
NStreamWriterCreate | Creates a new NStreamWriter for the specified NStream.
NStreamWriterCreateFromFile | Creates a new NStreamWriter for the specified file.
NStreamWriterCreateFromFileWithEncoding | Creates a new NStreamWriter for the specified file with specified encoding.
NStreamWriterCreateFromFileWithEncodingAndBufferSize | Creates a new NStreamWriter for the specified file with specified encoding and buffer size.
NStreamWriterCreateWithEncoding | Creates a new NStreamWriter for the specified NStream with specified encoding.
NStreamWriterCreateWithEncodingAndBufferSize | Creates a new NStreamWriter for the specified NStream with specified encoding and buffer size.
NStreamWriterGetAutoFlush | Gets a value indicating whether the StreamWriter will flush its buffer to the underlying stream after every call to StreamWriter.Write.
NStreamWriterGetBaseStream | Returns the underlying stream of the specified stream writer.
NStreamWriterGetNull | Creates a NStreamWriter object around an empty stream.
NStreamWriterSetAutoFlush | Sets a value indicating whether the StreamWriter will flush its buffer to the underlying stream after every call to StreamWriter.Write.
Collapse Expand Macros
Name | Description
NStreamWriterCreateFromFile | Picks a Unicode (W) or ASCII (A) version of the NStreamWriterCreateFromFile function.
NStreamWriterCreateFromFileWithEncoding | Picks a Unicode (W) or ASCII (A) version of the NStreamWriterCreateFromFileWithEncoding function.
NStreamWriterCreateFromFileWithEncodingAndBufferSize | Picks a Unicode (W) or ASCII (A) version of the NStreamWriterCreateFromFileWithEncodingAndBufferSize function.


NStreamWriterCreate Function

NStreamWriterCreate Function

Creates a new NStreamWriter for the specified NStream.

C++
NResult N_API NStreamWriterCreate(HNStream hStream, HNStreamWriter * phWriter);
Collapse Expand Parameters
Parameters | Description
HNStream hStream | [in] Handle to the NStream.
HNStreamWriter * phWriter | [out] Pointer to a handle to the new NStreamWriter.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStreamWriter.h

Module: NStreamWriter Unit


NStreamWriterCreateFromFile Function

NStreamWriterCreateFromFile Function

Creates a new NStreamWriter for the specified file.

C++
NResult N_API NStreamWriterCreateFromFile(const NChar * szFileName, NBool append, HNStreamWriter * phWriter);
Collapse Expand Parameters
Parameters | Description
const NChar * szFileName | [in] Pointer to the name of the file.
NBool append | [in] NTrue if the writer should append byte to the file; else NFalse.
HNStreamWriter * phWriter | [out] Pointer to a handle to the new NStreamWriter.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStreamWriter.h

Module: NStreamWriter Unit


NStreamWriterCreateFromFileWithEncoding Function

NStreamWriterCreateFromFileWithEncoding Function

Creates a new NStreamWriter for the specified file with specified encoding.

C++
NResult N_API NStreamWriterCreateFromFileWithEncoding(const NChar * szFileName, NBool append, NEncoding encoding, HNStreamWriter * phWriter);
Collapse Expand Parameters
Parameters | Description
const NChar * szFileName | [in] Pointer to the name of the file.
NBool append | [in] NTrue if the writer should append byte to the file; else NFalse.
NEncoding encoding | [in] The encoding.
HNStreamWriter * phWriter | [out] Pointer to a handle to the new NStreamWriter.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStreamWriter.h

Module: NStreamWriter Unit


NStreamWriterCreateFromFileWithEncodingAndBufferSize Function

NStreamWriterCreateFromFileWithEncodingAndBufferSize Function

Creates a new NStreamWriter for the specified file with specified encoding and buffer size.

C++
NResult N_API NStreamWriterCreateFromFileWithEncodingAndBufferSize(const NChar * szFileName, NBool append, NEncoding encoding, NSizeType bufferSize, HNStreamWriter * phWriter);
Collapse Expand Parameters
Parameters | Description
const NChar * szFileName | [in] Pointer to the name of the file.
NBool append | [in] NTrue if the writer should append byte to the file; else NFalse.
NEncoding encoding | [in] The encoding.
NSizeType bufferSize | [in] The buffer size.
HNStreamWriter * phWriter | [out] Pointer to a handle to the new NStreamWriter.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStreamWriter.h

Module: NStreamWriter Unit


NStreamWriterCreateWithEncoding Function

NStreamWriterCreateWithEncoding Function

Creates a new NStreamWriter for the specified NStream with specified encoding.

C++
NResult N_API NStreamWriterCreateWithEncoding(HNStream hStream, NEncoding encoding, HNStreamWriter * phWriter);
Collapse Expand Parameters
Parameters | Description
HNStream hStream | [in] Handle to the NStream.
NEncoding encoding | [in] The encoding.
HNStreamWriter * phWriter | [out] Pointer to a handle to the new NStreamWriter.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStreamWriter.h

Module: NStreamWriter Unit


NStreamWriterCreateWithEncodingAndBufferSize Function

NStreamWriterCreateWithEncodingAndBufferSize Function

Creates a new NStreamWriter for the specified NStream with specified encoding and buffer size.

C++
NResult N_API NStreamWriterCreateWithEncodingAndBufferSize(HNStream hStream, NEncoding encoding, NSizeType bufferSize, HNStreamWriter * phWriter);
Collapse Expand Parameters
Parameters | Description
HNStream hStream | [in] Handle to the NStream.
NEncoding encoding | [in] The encoding.
NSizeType bufferSize | [in] The buffer size.
HNStreamWriter * phWriter | [out] Pointer to a handle to the new NStreamWriter.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStreamWriter.h

Module: NStreamWriter Unit


NStreamWriterGetAutoFlush Function

NStreamWriterGetAutoFlush Function

Gets a value indicating whether the StreamWriter will flush its buffer to the underlying stream after every call to StreamWriter.Write.

C++
NResult N_API NStreamWriterGetAutoFlush(HNStreamWriter hWriter, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNStreamWriter hWriter | [in] Handle to the NStreamWriter.
NBool * pValue | [out] NTrue if the NStreamWriter flushes its buffer; otherwise, NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStreamWriter.h

Module: NStreamWriter Unit


NStreamWriterGetBaseStream Function

NStreamWriterGetBaseStream Function

Returns the underlying stream of the specified stream writer.

C++
NResult N_API NStreamWriterGetBaseStream(HNStreamWriter hWriter, HNStream * phValue);
Collapse Expand Parameters
Parameters | Description
HNStreamWriter hWriter | [in] Handle to the NStreamWriter.
HNStream * phValue | _nt_
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStreamWriter.h

Module: NStreamWriter Unit


NStreamWriterGetNull Function

NStreamWriterGetNull Function

Creates a NStreamWriter object around an empty stream.

C++
NResult N_API NStreamWriterGetNull(HNStreamWriter * phValue);
Collapse Expand Parameters
Parameters | Description
HNStreamWriter * phValue | [out] Pointer to a handle to the new NStreamWriter.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStreamWriter.h

Module: NStreamWriter Unit


NStreamWriterSetAutoFlush Function

NStreamWriterSetAutoFlush Function

Sets a value indicating whether the StreamWriter will flush its buffer to the underlying stream after every call to StreamWriter.Write.

C++
NResult N_API NStreamWriterSetAutoFlush(HNStreamWriter hWriter, NBool value);
Collapse Expand Parameters
Parameters | Description
HNStreamWriter hWriter | [in] Handle to the NStreamWriter.
NBool value | [in] NTrue to force NStreamWriter to flush its buffer; otherwise, NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStreamWriter.h

Module: NStreamWriter Unit


NStreamWriterCreateFromFile Macro

NStreamWriterCreateFromFile Macro

Picks a Unicode (W) or ASCII (A) version of the NStreamWriterCreateFromFile function.

C++
#define NStreamWriterCreateFromFile N_FUNC_AW(NStreamWriterCreateFromFile)
Container

File: NStreamWriter.h

Module: NStreamWriter Unit


NStreamWriterCreateFromFileWithEncoding Macro

NStreamWriterCreateFromFileWithEncoding Macro

Picks a Unicode (W) or ASCII (A) version of the NStreamWriterCreateFromFileWithEncoding function.

C++
#define NStreamWriterCreateFromFileWithEncoding N_FUNC_AW(NStreamWriterCreateFromFileWithEncoding)
Container

File: NStreamWriter.h

Module: NStreamWriter Unit


NStreamWriterCreateFromFileWithEncodingAndBufferSize Macro

NStreamWriterCreateFromFileWithEncodingAndBufferSize Macro

Picks a Unicode (W) or ASCII (A) version of the NStreamWriterCreateFromFileWithEncodingAndBufferSize function.

C++
#define NStreamWriterCreateFromFileWithEncodingAndBufferSize N_FUNC_AW(NStreamWriterCreateFromFileWithEncodingAndBufferSize)
Container

File: NStreamWriter.h

Module: NStreamWriter Unit


NString Unit

NString Unit
Files Functions Legend Macros

Provides functionality for working with strings.

Collapse Expand Files
Name | Description
NString.h | Header file for the NString unit.
Collapse Expand Functions
Name | Description
NStringAppendStrOrChars | Extends specified string content by adding an additional string or chars at its end.
NStringClone | Clones specified NString.
NStringCompareRangeNA | Compares substrings of the two specified strings and retrieves their relative position in the sort order.
NStringCompareRangeNW | Compares substrings of the two specified strings and retrieves their relative position in the sort order.
NStringCompareRangeStrOrCharsA | Compares substrings of a string and a string or a charset and retrieves their relative position in the sort order.
NStringCompareRangeStrOrCharsW | Compares substrings of a string and a string or a charset and retrieves their relative position in the sort order.
NStringConcatArray | Concatenates specified string.
NStringConcatMany | Concatenates specified strings.
NStringConcatManyVA | Concatenates specified strings.
NStringConcatN | Concatenates strings specified by handles.
NStringConcatStrOrChars | Concatenates strings or charsets specified by handles.
NStringContainsStrN | Checks whether specified string occurs within other string.
NStringContainsStrOrChars | Returns a value indicating whether specified chars or string occurs within string specified by handle.
NStringCopyToStrOrChars | Copies a specified number of characters from a specified position in handle to a specified array.
NStringCreateFromChar | Creates string from specified character.
NStringCreateFromStrOrChars | Creates string from specified array of characters.
NStringCreateWrapper | Creates a new string handle based on the specified string.
NStringEndsWithN | Checks whether the end of the string matches the specified string.
NStringEndsWithStrOrCharsA | Checks whether the end of the string matches the specified string or charset.
NStringEndsWithStrOrCharsW | Checks whether the end of the string matches the specified string or charset.
NStringEqualsN | Checks whether two specified strings have the same value.
NStringEqualsStrOrCharsA | Checks whether two specified strings or charsets have the same value.
NStringEqualsStrOrCharsW | Checks whether two specified strings or charsets have the same value.
NStringFormat | Returns a string representing the specified format and parameters.
NStringFormatVA | Returns a string representing the specified format and arguments.
NStringFree | Deletes the string specified by handle. After the string is deleted the specified handle is no longer valid.
NStringFreeArray | Deletes array of strings specified by handles. After the strings is deleted the specified object handles are no longer valid.
NStringFreeElements | ... more
NStringGetBuffer | Gets characters buffer (string) from specified handle to NString.
NStringGetConcurrent | Retrieves the string concurrent to the specified string.
NStringGetElements | Retrieves the elements of the specified string array.
NStringGetEmpty | Gets empty string.
NStringGetHashCode | Gets the hash code
NStringGetLength | Gets length of specified string.
NStringHasEmbeddedNull | Checked whether the specified string has an embedded null value.
NStringIndexOf | Returns the zero-based index of the first occurrence of the specified character in the string.
NStringIndexOfAny | ... more
NStringIndexOfAnyFrom | ... more
NStringIndexOfAnyInRange | ... more
NStringIndexOfFrom | Returns the zero-based index of the first occurrence of the specified character in the string starting from specified index.
NStringIndexOfInRange | ... more
NStringIndexOfStrFromN | ... more
NStringIndexOfStrInRangeN | ... more
NStringIndexOfStrN | Returns the zero-based index of the first occurrence of the specified NString in the string.
NStringIndexOfStrOrChars | Returns the zero-based index of the first occurrence of the specified string or character in the string.
NStringIndexOfStrOrCharsFrom | Returns the zero-based index of the first occurrence of the specified string or character in the string.
NStringIndexOfStrOrCharsInRange | Returns the zero-based index of the first occurrence of the specified string or character in the string.
NStringInsertN | Returns a new string in which a specified string is inserted at a specified index position.
NStringInsertStrOrChars | Returns a new string in which a specified string or characters is inserted at a specified index position.
NStringIsA | Checks whether specified string contains ANSI characters.
NStringIsEmpty | Checks whether specified string is empty string.
NStringIsW | Checks whether specified string contains Unicode characters.
NStringIsWhiteSpace | Checks whether specified string consists only of white-space characters.
NStringJoinArray | Concatenates all the elements of a string array, using the specified separator between each element.
NStringJoinArrayVN | Concatenates all the elements of a string array, using the specified separator between each element.
NStringJoinMany | Concatenates all the elements of a string arrays, using the specified separator between each element.
NStringJoinManyVA | Concatenates all the elements of a string arrays, using the specified separator between each element.
NStringJoinManyVAVN | Concatenates all the elements of a string arrays, using the specified separator between each element.
NStringJoinManyVN | Concatenates all the elements of a string arrays, using the specified separator between each element.
NStringLastIndexOf | Returns the zero-based index position of the last occurrence of a specified character within string.
NStringLastIndexOfAny | ... more
NStringLastIndexOfAnyFrom | ... more
NStringLastIndexOfAnyInRange | ... more
NStringLastIndexOfFrom | ... more
NStringLastIndexOfInRange | ... more
NStringLastIndexOfStrFromN | ... more
NStringLastIndexOfStrInRangeN | Returns the zero-based index of the last occurrence of the specified string in the NString in specified range.
NStringLastIndexOfStrN | Returns the zero-based index of the last occurrence of the specified NString in the string.
NStringLastIndexOfStrOrChars | Returns the zero-based index of the last occurrence of the specified string or character in the string.
NStringLastIndexOfStrOrCharsFrom | Returns the zero-based index of the last occurrence of the specified string or character in the string.
NStringLastIndexOfStrOrCharsInRange | Returns the zero-based index of the last occurrence of the specified string or character in the string.
NStringPadLeft | ... more
NStringPadLeftWith | ... more
NStringPadRight | ... more
NStringPadRightWith | ... more
NStringPrependStrOrChars | Prepends a string or a charset to another string.
NStringPromoteBuffer | Creates a new NString which takes ownership of the memory buffer.
NStringRemove | ... more
NStringRemoveFrom | ... more
NStringReplace | ... more
NStringReplaceStrOrChars | Replaces a part of a string or a char array with new values.
NStringSet | Sets the value of the specified string.
NStringSplitWithCount | ... more
NStringSplitWithStrsAndCount | Returns a string array that contains the substrings that are delimited by elements of a specified character array. A parameter specifies the maximum number of substrings to return.
NStringSplitWithStrsAndCountN | Returns a string array that contains the substrings that are delimited by elements of a specified string array. A parameter specifies the maximum number of substrings to return.
NStringStartsWithN | ... more
NStringStartsWithStrOrCharsA | Checks whether the beginning of hString matches the specified string or chars.
NStringStartsWithStrOrCharsW | Checks whether the beginning of hString matches the specified string or chars.
NStringSubstring | Gets a substring from hString. The substring starts at a specified character position.
NStringSubstringFrom | Gets a substring from hString. The substring starts at a specified character position.
NStringToLower | Converts specified string to lowercase.
NStringToStrOrCharArray | Converts a string to another string or a character array.
NStringToStrOrCharArrayRange | Converts a string to another string or a part of character array.
NStringToString | Converts the specified string to another string with specified format.
NStringToUpper | Converts specified string to uppercase.
NStringTrim | Removes all leading and trailing white-space characters from specified string.
NStringTrimAny | Removes all leading and trailing occurrences of a sets of characters from specified string.
NStringTrimEnd | Removes all trailing characters from hString.
NStringTrimEndAny | Removes all trailing occurrences of a set of characters specified in an array from hString.
NStringTrimStart | Removes all trailing characters from hString.
NStringTrimStartAny | Removes all leading occurrences of a set of characters specified in an array from hString.
Collapse Expand Macros
Name | Description
NStringAppend | Extends specified string content by adding an additional string at its end.
NStringAppendChars | Extends specified string content by adding additional chars at its end.
NStringAppendStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringAppendStrOrChars function.
NStringCompare | Compares two strings and retrieves their relative position in the sort order.
NStringCompareChars | Compares a string with a char array and retrieves their relative position in the sort order.
NStringCompareN | Compares two strings and retrieves their relative position in the sort order.
NStringCompareRange | Compares substrings of the two specified strings and retrieves their relative position in the sort order.
NStringCompareRangeChars | Compares substrings of a string and a charset and retrieves their relative position in the sort order.
NStringCompareRangeN | Picks a Unicode (W) or ASCII (A) version of the NStringCompareRangeN function.
NStringCompareRangeStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringCompareRangeStrOrChars function.
NStringCompareStrOrChars | Compares a string with a string or char array and retrieves their relative position in the sort order.
NStringConcat | Concatenates strings specified by handles.
NStringConcatChars | Concatenates charsets specified by handles.
NStringConcatMany | Picks a Unicode (W) or ASCII (A) version of the NStringConcatMany function.
NStringConcatManyVA | Picks a Unicode (W) or ASCII (A) version of the NStringConcatManyVA function.
NStringConcatStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringConcatStrOrChars function.
NStringContainsChars | Returns a value indicating whether specified chars occur within string specified by handle.
NStringContainsStr | Returns a value indicating whether specified string occurs within string specified by handle.
NStringContainsStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringContainsStrOrChars function.
NStringCopyTo | Copies a specified number of characters from a specified position in handle to a specified array.
NStringCopyToStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringCopyToStrOrChars function.
NStringCopyToString | Copies a specified number of characters from a specified position in handle to a specified string.
NStringCreate | Creates a string with the specified value.
NStringCreateFromChar | Picks a Unicode (W) or ASCII (A) version of the NStringCreateFromChar function.
NStringCreateFromChars | Creates a string from the specified array of characters.
NStringCreateFromStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringCreateFromStrOrChars function.
NStringCreateWrapper | Picks a Unicode (W) or ASCII (A) version of the NStringCreateWrapper function.
NStringEndsWith | Checks whether the end of the string matches the specified string.
NStringEndsWithChars | Checks whether the end of the string matches the specified string or charset.
NStringEndsWithStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringEndsWithStrOrChars function.
NStringEquals | Checks whether two specified stings have the same value.
NStringEqualsChars | Checks whether the specified string and the specified charset have the same value.
NStringEqualsStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringEqualsStrOrChars function.
NStringFormat | Picks a Unicode (W) or ASCII (A) version of the NStringFormat function.
NStringFormatVA | Picks a Unicode (W) or ASCII (A) version of the NStringFormatVA function.
NStringGetBuffer | Picks a Unicode (W) or ASCII (A) version of the NStringGetBuffer function.
NStringGetChar | Picks a Unicode (W) or ASCII (A) version of the NStringGetChar function.
NStringGetLength | Picks a Unicode (W) or ASCII (A) version of the NStringGetLength function.
NStringIndexOf | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOf function.
NStringIndexOfAny | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfAny function.
NStringIndexOfAnyFrom | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfAnyFrom function.
NStringIndexOfAnyInRange | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfAnyInRange function.
NStringIndexOfChars | Returns the zero-based index of the first occurrence of the specified character in the string.
NStringIndexOfCharsFrom | Returns the zero-based index of the first occurrence of the specified character in the string.
NStringIndexOfCharsInRange | Returns the zero-based index of the first occurrence of the specified character in the string.
NStringIndexOfFrom | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfFrom function.
NStringIndexOfInRange | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfInRange function.
NStringIndexOfStr | Returns the zero-based index of the first occurrence of the specified string in the string.
NStringIndexOfStrFrom | Returns the zero-based index of the first occurrence of the specified string in the string.
NStringIndexOfStrFromN | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfStrFromN function.
NStringIndexOfStrInRange | Returns the zero-based index of the first occurrence of the specified string in the string.
NStringIndexOfStrInRangeN | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfStrInRangeN function.
NStringIndexOfStrN | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfStrN function.
NStringIndexOfStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfStrOrChars function.
NStringIndexOfStrOrCharsFrom | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfStrOrCharsFrom function.
NStringIndexOfStrOrCharsInRange | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfStrOrCharsInRange function.
NStringInsert | Returns a new string in which a specified string is inserted at a specified index position.
NStringInsertChars | Returns a new string in which a specified characters are inserted at a specified index position.
NStringInsertN | Picks a Unicode (W) or ASCII (A) version of the NStringInsertN function.
NStringInsertStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringInsertStrOrChars function.
NStringJoinArray | Picks a Unicode (W) or ASCII (A) version of the NStringJoinArray function.
NStringJoinArrayVN | Picks a Unicode (W) or ASCII (A) version of the NStringJoinArrayVN function.
NStringJoinMany | Picks a Unicode (W) or ASCII (A) version of the NStringJoinMany function.
NStringJoinManyVAVN | Picks a Unicode (W) or ASCII (A) version of the NStringJoinManyVAVN function.
NStringJoinManyVN | Picks a Unicode (W) or ASCII (A) version of the NStringJoinManyVN function.
NStringLastIndexOf | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOf function.
NStringLastIndexOfAny | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfAny function.
NStringLastIndexOfAnyFrom | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfAnyFrom function.
NStringLastIndexOfAnyInRange | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfAnyInRange function.
NStringLastIndexOfChars | Returns the zero-based index of the last occurrence of the specified character in the string.
NStringLastIndexOfCharsFrom | Returns the zero-based index of the last occurrence of the specified character in the string.
NStringLastIndexOfCharsInRange | Returns the zero-based index of the last occurrence of the specified character in the string.
NStringLastIndexOfFrom | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfFrom function.
NStringLastIndexOfInRange | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfInRange function.
NStringLastIndexOfStr | Returns the zero-based index of the last occurrence of the specified string in the string.
NStringLastIndexOfStrFrom | Returns the zero-based index of the last occurrence of the specified string in the string.
NStringLastIndexOfStrFromN | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfStrFromN function.
NStringLastIndexOfStrInRange | Returns the zero-based index of the last occurrence of the specified string in the string.
NStringLastIndexOfStrInRangeN | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfStrInRangeN function.
NStringLastIndexOfStrN | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfStrN function.
NStringLastIndexOfStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfStrOrChars function.
NStringLastIndexOfStrOrCharsFrom | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfStrOrCharsFrom function.
NStringLastIndexOfStrOrCharsInRange | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfStrOrCharsInRange function.
NStringPadLeft | Picks a Unicode (W) or ASCII (A) version of the NStringPadLeft function.
NStringPadLeftWith | Picks a Unicode (W) or ASCII (A) version of the NStringPadLeftWith function.
NStringPadRight | Picks a Unicode (W) or ASCII (A) version of the NStringPadRight function.
NStringPadRightWith | Picks a Unicode (W) or ASCII (A) version of the NStringPadRightWith function.
NStringPrepend | Prepends a string to another string.
NStringPrependChars | Prepends a charset to another string.
NStringPrependStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringPrependStrOrChars function.
NStringPromoteBuffer | Picks a Unicode (W) or ASCII (A) version of the NStringPromoteBuffer function.
NStringRemove | Picks a Unicode (W) or ASCII (A) version of the NStringRemove function.
NStringRemoveFrom | Picks a Unicode (W) or ASCII (A) version of the NStringRemoveFrom function.
NStringReplace | Picks a Unicode (W) or ASCII (A) version of the NStringReplace function.
NStringReplaceChars | Replaces a part of a char array with new values.
NStringReplaceStr | Replaces a part of a string with new values.
NStringReplaceStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringReplaceStrOrChars function.
NStringSplit | ... more
NStringSplitWithCount | Picks a Unicode (W) or ASCII (A) version of the NStringSplitWithCount function.
NStringSplitWithStrs | Returns a string array that contains the substrings that are delimited by elements of a specified character array.
NStringSplitWithStrsAndCount | Picks a Unicode (W) or ASCII (A) version of the NStringSplitWithStrsAndCount function.
NStringSplitWithStrsN | Returns a string array that contains the substrings that are delimited by elements of a specified string array.
NStringStartsWith | Checks whether the beginning of hString matches the specified string.
NStringStartsWithChars | Checks whether the beginning of hString matches the specified charset.
NStringStartsWithStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringStartsWithStrOrChars function.
NStringSubstring | Picks a Unicode (W) or ASCII (A) version of the NStringSubstring function.
NStringSubstringFrom | Picks a Unicode (W) or ASCII (A) version of the NStringSubstringFrom function.
NStringToCharArray | Converts a string to character array.
NStringToCharArrayRange | Converts a string to a part of character array.
NStringToNewString | Converts a string to another string.
NStringToNewStringRange | Converts a string to another string or a part of character array.
NStringToStrOrCharArray | Picks a Unicode (W) or ASCII (A) version of the NStringToStrOrCharArray function.
NStringToStrOrCharArrayRange | Picks a Unicode (W) or ASCII (A) version of the NStringToStrOrCharArrayRange function.
NStringToString | Picks a Unicode (W) or ASCII (A) version of the NStringToString function.
NStringTrimAny | Picks a Unicode (W) or ASCII (A) version of the NStringTrimAny function.
NStringTrimEndAny | Picks a Unicode (W) or ASCII (A) version of the NStringTrimEndAny function.
NStringTrimStartAny | Picks a Unicode (W) or ASCII (A) version of the NStringTrimStartAny function.
N_STRING_SIZE | Defines the string size.


Format Specifications

Format Specifications

Format Specifications

Format line takes the form of {type[,length]:formatString}

  • type component defines the type of the value formatted. It is a mandatory component. A list of all types used in formatting can be found in NString.c
  • length component defines the minimum number of characters in the string representation of the parameter. If positive, the parameter is right-aligned; if negative, it is left-aligned. It as an optional component.
  • formatString component represents a format string that is appropriate for the type of object being formatted. It is a mandatory component.

Text format strings

NAChar, NWChar, const NAChar *, const NWChar *, HNString ignore format strings and as such, format string need be supplied for their formatting.

Boolean format strings

NBoolean uses format string of type X/Y, where X is a string for NTrue and Y is a string for NFalse.

Polymorphic format strings

NObject, NValue - format strings used depend on the type of the object/value formatted. Refer to NXxx for the list of supported format strings.

Numeric format strings

- are used to format numeric types (NInt#, NUInt#, NSingle, NDouble, NSizeType and NSSizeType; NPointer is formatted as numeric, however, "G" for it equals X8/X16 (for 32-bit/64-bit); NResult is formatted as NInt32 but ignores the format strings).

(# = 8/16/32/64)

They consist of a single alphabetic character called the format specifier, an optional integer (maximum two digits), called the precision specifier. The precision specifier ranges from 0 to 99 and affects the number of digits in the result.

Standard format specifiers are listed below.

Format specifier | Name | Description
"C" or "c" | Currency | Results in a currency value. Supported by all numeric types. Precision specifier indicates the number of decimal digits.
"D" or "d" | Decimal | Results in integer digits with optional negative sign. Supported by integral types only. Precision specifier indicates the minimum number of digits.
"E" or "e" | Scientific | Results in an exponential notation. Supported by all numeric types. Precision specifier indicates the number of decimal digits.
"F" or "f" | Fixed-point | Results in integral and decimal digits with optional negative sign. Supported by all numeric types. Precision specifier indicates the number of decimal digits.
"G" or "g" | General | Results in the most compact of either fixed-point or scientific notation. Supported by all numeric types. Precision specifier indicates the number of significant digits.
"N" or "n" | Number | Results in integral and decimal digits, group separators, and a decimal separator with optional negative sign. Supported by all numeric types. Precision specifier indicates the desired number of decimal places.
"P" or "p" | Percent | Results in the number multiplied by 100 and displayed with a percent symbol. Supported by all numeric types. Precision specifier indicates the desired number of decimal places.
"R" or "r" | Round-trip | Results in a string that can round-trip to an identical number. Supported by NSingle and NDouble. Precision specifier is ignored and not required.
"X" or "x" | Hexadecimal | Results in a hexadecimal string. Supported by integral types only. Precision specifier indicates the number of digits in the result string.
Other | Unknown | Throws a FormatException at runtime.


NStringAppendStrOrChars Function

NStringAppendStrOrChars Function
NString.h

Extends specified string content by adding an additional string or chars at its end.

C++
NResult N_API NStringAppendStrOrChars(HNString hString, const NChar * arValue, NInt valueLength, HNString * phResultString);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString which should be appended.
const NChar * arValue | [in] Array with a sequence of characters. These characters will be appended at the end of hString.
NInt valueLength | [in] Size of arValue memory buffer.
HNString * phResultString | [out] Result string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringClone Function

NStringClone Function
NString.h

Clones specified NString.

C++
NResult N_API NStringClone(HNString hString, HNString * phResultString);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString which should be cloned.
HNString * phResultString | [out] Instance of NString.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringCompareRangeNA Function

NStringCompareRangeNA Function
NString.h

Compares substrings of the two specified strings and retrieves their relative position in the sort order.

C++
NResult N_API NStringCompareRangeNA(HNString hString, NInt index, HNString hOtherString, NInt otherIndex, NInt length, NBool ignoreCase, NInt * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to the first string to use in comparison.
NInt index | [in] Position of the substring in hString.
HNString hOtherString | [in] Handle to the second string to use in comparison.
NInt otherIndex | [in] Position of the substring in hOtherString.
NInt length | [in] The maximum number of characters in the substrings to compare.
NBool ignoreCase | [in] NTrue to ignore letter case during comparison; else NFalse.
NInt * pResult | [out] Pointer to NInt value that indicates the lexical relationship between the two comparands.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

This is an ANSCII version of the function.

Container

File: NString.h

Module: NString Unit


NStringCompareRangeNW Function

NStringCompareRangeNW Function
NString.h

Compares substrings of the two specified strings and retrieves their relative position in the sort order.

C++
NResult N_API NStringCompareRangeNW(HNString hString, NInt index, HNString hOtherString, NInt otherIndex, NInt length, NBool ignoreCase, NInt * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to the first string to use in comparison.
NInt index | [in] Position of the substring in hString.
HNString hOtherString | [in] Handle to the second string to use in comparison.
NInt otherIndex | [in] Position of the substring in hOtherString.
NInt length | [in] The maximum number of characters in the substrings to compare.
NBool ignoreCase | [in] NTrue to ignore letter case during comparison; else NFalse.
NInt * pResult | [out] Pointer to NInt value that indicates the lexical relationship between the two comparands.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

This is a Unicode version of the function.

Container

File: NString.h

Module: NString Unit


NStringCompareRangeStrOrCharsA Function

NStringCompareRangeStrOrCharsA Function
NString.h

Compares substrings of a string and a string or a charset and retrieves their relative position in the sort order.

C++
NResult N_API NStringCompareRangeStrOrCharsA(HNString hString, NInt index, const NAChar * arValue, NInt valueLength, NInt length, NBool ignoreCase, NInt * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to the string to use in comparison.
NInt index | [in] Position of the substring in hString.
const NAChar * arValue | [in] Handle to the charset to use in comparison.
NInt valueLength | [in] Length of the charset.
NInt length | [in] The maximum number of characters in the substrings to compare.
NBool ignoreCase | [in] NTrue to ignore letter case during comparison; else NFalse.
NInt * pResult | [out] Pointer to NInt value that indicates the lexical relationship between the two comparands.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

This is an ANSCII version of the function.

Container

File: NString.h

Module: NString Unit


NStringCompareRangeStrOrCharsW Function

NStringCompareRangeStrOrCharsW Function
NString.h

Compares substrings of a string and a string or a charset and retrieves their relative position in the sort order.

C++
NResult N_API NStringCompareRangeStrOrCharsW(HNString hString, NInt index, const NWChar * arValue, NInt valueLength, NInt length, NBool ignoreCase, NInt * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to the string to use in comparison.
NInt index | [in] Position of the substring in hString.
const NWChar * arValue | [in] Handle to the charset to use in comparison.
NInt valueLength | [in] Length of the charset.
NInt length | [in] The maximum number of characters in the substrings to compare.
NBool ignoreCase | [in] NTrue to ignore letter case during comparison; else NFalse.
NInt * pResult | [out] Pointer to NInt value that indicates the lexical relationship between the two comparands.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

This is a Unicode version of the function.

Container

File: NString.h

Module: NString Unit


NStringConcatArray Function

NStringConcatArray Function
NString.h

Concatenates specified string.

C++
NResult N_API NStringConcatArray(const NChar * const * arszValues, NInt count, HNString * phResultString);
Collapse Expand Parameters
Parameters | Description
const NChar * const * arszValues | [in] Array of string values.
NInt count | [in] Array items count.
HNString * phResultString | [out] Pointer to NString.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringConcatMany Function

NStringConcatMany Function
NString.h

Concatenates specified strings.

C++
NResult N_API NStringConcatMany(HNString * phResultString, NInt count, ... multipleParameters);
Collapse Expand Parameters
Parameters | Description
HNString * phResultString | [out] The concatenated elements.
NInt count | [in] NChar elements count.
... multipleParameters | [in] Function parameters.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

This function must specify as many const NChar * elements as specified by count parameter.

Container

File: NString.h

Module: NString Unit


NStringConcatManyVA Function

NStringConcatManyVA Function
NString.h

Concatenates specified strings.

C++
NResult N_API NStringConcatManyVA(HNString * phResultString, NInt count, va_list args);
Collapse Expand Parameters
Parameters | Description
HNString * phResultString | [out] The concatenated elements.
NInt count | [in] NChar elements count.
va_list args | [in] Function arguments.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringConcatN Function

NStringConcatN Function
NString.h

Concatenates strings specified by handles.

C++
NResult N_API NStringConcatN(HNString hValue1, HNString hValue2, HNString * phResultString);
Collapse Expand Parameters
Parameters | Description
HNString hValue1 | [in] Handle to first string to concatenate.
HNString hValue2 | [in] Handle to second string to concatenate.
HNString * phResultString | [out] The concatenated strings.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringConcatStrOrChars Function

NStringConcatStrOrChars Function
NString.h

Concatenates strings or charsets specified by handles.

C++
NResult N_API NStringConcatStrOrChars(const NChar * arValue1, NInt value1Length, const NChar * arValue2, NInt value2Length, HNString * phResultString);
Collapse Expand Parameters
Parameters | Description
const NChar * arValue1 | [in] Pointer to the first string or charset.
NInt value1Length | [in] Length of the first string or charset.
const NChar * arValue2 | [in] Pointer to the second string or charset.
NInt value2Length | [in] Length of the second string or charset.
HNString * phResultString | [out] Pointer to a handle to the resulting string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringContainsStrN Function

NStringContainsStrN Function
NString.h

Checks whether specified string occurs within other string.

C++
NResult N_API NStringContainsStrN(HNString hString, HNString hValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] String specified by handle where hValue string will be sought.
HNString hValue | [in] String specified by handle to seek.
NBool * pResult | [out] Pointer to hValue seek result.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringContainsStrOrChars Function

NStringContainsStrOrChars Function
NString.h

Returns a value indicating whether specified chars or string occurs within string specified by handle.

C++
NResult N_API NStringContainsStrOrChars(HNString hString, const NChar * arValue, NInt valueLength, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString to check.
const NChar * arValue | [in] NChar array which contains chars to check in hString.
NInt valueLength | [in] Length of memory buffer where arValue is stored.
NBool * pResult | [out] Strings check result.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringCopyToStrOrChars Function

NStringCopyToStrOrChars Function
NString.h

Copies a specified number of characters from a specified position in handle to a specified array.

C++
NResult N_API NStringCopyToStrOrChars(HNString hString, NInt sourceIndex, NChar * arValue, NInt valueLength, NBool nullTerminate, NInt count);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString which contains characters to copy.
NInt sourceIndex | [in] The index of the first character in this handle to copy.
NChar * arValue | [out] Pointer to memory buffer which contains copied characters.
NInt valueLength | [in] Size of arValue memory buffer
NBool nullTerminate | [in] If NTrue, null terminated string will be copied.
NInt count | [in] The number of characters in hString to copy to arValue.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringCreateFromChar Function

NStringCreateFromChar Function
NString.h

Creates string from specified character.

C++
NResult N_API NStringCreateFromChar(NChar value, NInt count, HNString * phString);
Collapse Expand Parameters
Parameters | Description
NChar value | [in] Character which will be used to create the string.
NInt count | [in] Characters count in string. If count > 1, characters will be duplicated in the string.
HNString * phString | [out] Pointer to handle which contains created string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringCreateFromStrOrChars Function

NStringCreateFromStrOrChars Function
NString.h

Creates string from specified array of characters.

C++
NResult N_API NStringCreateFromStrOrChars(const NChar * arValue, NInt length, HNString * phString);
Collapse Expand Parameters
Parameters | Description
const NChar * arValue | [in] Array of chars.
NInt length | [in] Size of arValue memory buffer.
HNString * phString | [out] Pointer to handle which contains created string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringCreateWrapper Function

NStringCreateWrapper Function
NString.h

Creates a new string handle based on the specified string.

C++
NResult N_API NStringCreateWrapper(const NChar * szValue, NInt length, NStringHeader * pStringHeader, HNString * phString);
Collapse Expand Parameters
Parameters | Description
const NChar * szValue | [in] Source array of characters (string) for new handle.
NInt length | [in] The length of source array.
NStringHeader * pStringHeader | [out] Pointer to NStringHeader which represents header for NString.
HNString * phString | [out] Pointer to newly created string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringEndsWithN Function

NStringEndsWithN Function
NString.h

Checks whether the end of the string matches the specified string.

C++
NResult N_API NStringEndsWithN(HNString hString, HNString hOtherString, NBool ignoreCase, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to string to check.
HNString hOtherString | [in] Handle to the string to compare to the hString.
NBool ignoreCase | [in] If NTrue strings comparison is not case sensitive.
NBool * pResult | [out] Strings check result.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringEndsWithStrOrCharsA Function

NStringEndsWithStrOrCharsA Function
NString.h

Checks whether the end of the string matches the specified string or charset.

C++
NResult N_API NStringEndsWithStrOrCharsA(HNString hString, const NAChar * arValue, NInt valueLength, NBool ignoreCase, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to string to check.
const NAChar * arValue | [in] Pointer to the char array to compare to the hString.
NInt valueLength | [in] Length of arValue.
NBool ignoreCase | [in] If NTrue strings comparison is not case sensitive.
NBool * pResult | [out] Strings check result.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

This is an ANSCII version of the function.

Container

File: NString.h

Module: NString Unit


NStringEndsWithStrOrCharsW Function

NStringEndsWithStrOrCharsW Function
NString.h

Checks whether the end of the string matches the specified string or charset.

C++
NResult N_API NStringEndsWithStrOrCharsW(HNString hString, const NWChar * arValue, NInt valueLength, NBool ignoreCase, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to string to check.
const NWChar * arValue | [in] Pointer to the char array to compare to the hString.
NInt valueLength | [in] Length of arValue.
NBool ignoreCase | [in] If NTrue strings comparison is not case sensitive.
NBool * pResult | [out] Strings check result.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

This is a Unicode version of the function.

Container

File: NString.h

Module: NString Unit


NStringEqualsN Function

NStringEqualsN Function
NString.h

Checks whether two specified strings have the same value.

C++
NResult N_API NStringEqualsN(HNString hString, HNString hOtherString, NBool ignoreCase, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to the first string to compare.
HNString hOtherString | [in] Handle to the second string to compare.
NBool ignoreCase | [in] If NTrue strings comparison is not case sensitive.
NBool * pResult | [out] Strings check result.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringEqualsStrOrCharsA Function

NStringEqualsStrOrCharsA Function
NString.h

Checks whether two specified strings or charsets have the same value.

C++
NResult N_API NStringEqualsStrOrCharsA(HNString hString, const NAChar * arValue, NInt valueLength, NBool ignoreCase, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to the string to compare.
const NAChar * arValue | [in] Pointer to the char array to compare.
NInt valueLength | [in] Length of arValue.
NBool ignoreCase | [in] If NTrue strings comparison is not case sensitive.
NBool * pResult | [out] Strings check result.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

This is an ANSCII version of the function.

Container

File: NString.h

Module: NString Unit


NStringEqualsStrOrCharsW Function

NStringEqualsStrOrCharsW Function
NString.h

Checks whether two specified strings or charsets have the same value.

C++
NResult N_API NStringEqualsStrOrCharsW(HNString hString, const NWChar * arValue, NInt valueLength, NBool ignoreCase, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to the string to compare.
const NWChar * arValue | [in] Pointer to the char array to compare.
NInt valueLength | [in] Length of arValue.
NBool ignoreCase | [in] If NTrue strings comparison is not case sensitive.
NBool * pResult | [out] Strings check result.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

This is a Unicode version of the function.

Container

File: NString.h

Module: NString Unit


NStringFormat Function

NStringFormat Function
NString.h

Returns a string representing the specified format and parameters.

C++
NResult N_API NStringFormat(HNString * phValue, const NChar * szFormat, ... multipleParameters);
Collapse Expand Parameters
Parameters | Description
HNString * phValue | [out] Pointer to a handle to NString.
const NChar * szFormat | [in] Pointer to composite format string.
... multipleParameters | [in] Format parameters.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Notes

These return values are available:

  • "C" - NChar
  • "AC" - NAChar
  • "WC" - NWChar
  • "UI8","I8", "UI16", "I16", "UI32", "I32", "UI64", "I64" - for NIntX, NUIntX
  • "F", "D" - float, double
  • "B" - NBool
  • "S" - NChar *
  • "AS" - NAChar *
  • "WS" - NWChar *
  • "NS" - HNString
  • "O" - HNObject
Container

File: NString.h

Module: NString Unit


NStringFormatVA Function

NStringFormatVA Function
NString.h

Returns a string representing the specified format and arguments.

C++
NResult N_API NStringFormatVA(HNString * phValue, const NChar * szFormat, va_list args);
Collapse Expand Parameters
Parameters | Description
HNString * phValue | [out] Pointer to a handle to NString.
const NChar * szFormat | [in] Pointer to composite format string.
va_list args | [in] Format argument list.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringFree Function

NStringFree Function
NString.h

Deletes the string specified by handle. After the string is deleted the specified handle is no longer valid.

C++
void N_API NStringFree(HNString hString);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to string to be deleted.
Container

File: NString.h

Module: NString Unit


NStringFreeArray Function

NStringFreeArray Function
NString.h

Deletes array of strings specified by handles. After the strings is deleted the specified object handles are no longer valid.

C++
void N_API NStringFreeArray(HNString * arhStrings, NInt count);
Collapse Expand Parameters
Parameters | Description
HNString * arhStrings | [in] Handle to strings array to be deleted.
NInt count | [in] Strings array count.
Container

File: NString.h

Module: NString Unit


NStringFreeElements Function

NStringFreeElements Function
NString.h

Deletes strings specified by handles in array. After the strings is deleted the specified string handles are no longer valid.

C++
void N_API NStringFreeElements(HNString * arhStrings, NInt count);
Collapse Expand Parameters
Parameters | Description
HNString * arhStrings | [in] Handle to strings array to be deleted.
NInt count | [in] arhStrings array count.
Collapse Expand Remarks

This function does not free array where strings are saved. If you need to dispose all array use NStringtFreeArray.

Container

File: NString.h

Module: NString Unit


NStringGetBuffer Function

NStringGetBuffer Function
NString.h

Gets characters buffer (string) from specified handle to NString.

C++
NResult N_API NStringGetBuffer(HNString hString, NInt * pLength, const NChar * * pszBuffer);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString to retrieve string buffer.
NInt * pLength | [out] Size of pszBuffer.
const NChar * * pszBuffer | [out] Pointer to zero terminated string from hString.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringGetConcurrent Function

NStringGetConcurrent Function
NString.h

Retrieves the string concurrent to the specified string.

C++
NResult N_API NStringGetConcurrent(volatile HNString * phVariable, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
volatile HNString * phVariable | [in] Pointer to the original string.
HNString * phValue | [out] Pointer to the concurrent string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringGetElements Function

NStringGetElements Function
NString.h

Retrieves the elements of the specified string array.

C++
NResult N_API NStringGetElements(const HNString * arhStrings, NInt stringCount, HNString * arhValues, NInt valuesLength);
Collapse Expand Parameters
Parameters | Description
const HNString * arhStrings | [in] Pointer to an array of strings.
NInt stringCount | [in] Number of strings in the array.
HNString * arhValues | [out] Pointer to an array of elements.
NInt valuesLength | [out] Number of elements in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringGetEmpty Function

NStringGetEmpty Function
NString.h

Gets empty string.

C++
NResult N_API NStringGetEmpty(HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNString * phValue | [out] Handle to empty string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringGetHashCode Function

NStringGetHashCode Function
NString.h

Gets the hash code

C++
NResult N_API NStringGetHashCode(HNString hString, NInt * pHashCode);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString to retrieve its hash code.
NInt * pHashCode | [out] String hash code.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringGetLength Function

NStringGetLength Function
NString.h

Gets length of specified string.

C++
NResult N_API NStringGetLength(HNString hString, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
NInt * pValue | [out] String length.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringHasEmbeddedNull Function

NStringHasEmbeddedNull Function
NString.h

Checked whether the specified string has an embedded null value.

C++
NResult N_API NStringHasEmbeddedNull(HNString hString, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to the string.
NBool * pValue | [out] Pointer to NTrue if the string has an embedded null; else pointer to NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringIndexOf Function

NStringIndexOf Function
NString.h

Returns the zero-based index of the first occurrence of the specified character in the string.

C++
NResult N_API NStringIndexOf(HNString hString, NChar value, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
NChar value | [in] Character to seek.
NInt * pIndex | [out] The zero-based index position of value if that character is found, or -1 if it is not. Note: Index numbering starts from 0.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringIndexOfAny Function

NStringIndexOfAny Function
NString.h

Returns the zero-based index of the first occurrence in the string of any character in a specified array of characters.

C++
NResult N_API NStringIndexOfAny(HNString hString, const NChar * arAnyOf, NInt anyOfLength, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
const NChar * arAnyOf | [in] Character array containing one or more characters to seek.
NInt anyOfLength | [in] Length of arAnyOf array.
NInt * pIndex | [out] The zero-based index position of the first occurrence in this string where any character in arAnyOf was found; -1 if no character in arAnyOf was found. Note: Index numbering starts from 0.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringIndexOfAnyFrom Function

NStringIndexOfAnyFrom Function
NString.h

Returns the zero-based index of the first occurrence in the string of any character in a specified array of characters.

C++
NResult N_API NStringIndexOfAnyFrom(HNString hString, const NChar * arAnyOf, NInt anyOfLength, NInt startIndex, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
const NChar * arAnyOf | [in] Character array containing one or more characters to seek.
NInt anyOfLength | [in] Length of arAnyOf array.
NInt startIndex | [in] Seek start index.
NInt * pIndex | [out] The zero-based index position of the first occurrence in this string where any character in arAnyOf was found; -1 if no character in arAnyOf was found. Note: Index numbering starts from 0.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringIndexOfAnyInRange Function

NStringIndexOfAnyInRange Function
NString.h

Returns the zero-based index of the first occurrence in the string of any character in a specified array of characters.

C++
NResult N_API NStringIndexOfAnyInRange(HNString hString, const NChar * arAnyOf, NInt anyOfLength, NInt startIndex, NInt count, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
const NChar * arAnyOf | [in] Character array containing one or more characters to seek.
NInt anyOfLength | [in] Length of arAnyOf array.
NInt startIndex | [in] Seek start index.
NInt count | [in] Characters count (range to perform search).
NInt * pIndex | [out] The zero-based index position of the first occurrence in this string where any character in arAnyOf was found; -1 if no character in arAnyOf was found. Note: Index numbering starts from 0.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringIndexOfFrom Function

NStringIndexOfFrom Function
NString.h

Returns the zero-based index of the first occurrence of the specified character in the string starting from specified index.

C++
NResult N_API NStringIndexOfFrom(HNString hString, NChar value, NInt startIndex, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
NChar value | [in] Character to seek.
NInt startIndex | [in] Seek start index in hString.
NInt * pIndex | [out] The zero-based index position of value if that character is found, or -1 if it is not. Note: Index numbering starts from 0.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringIndexOfInRange Function

NStringIndexOfInRange Function
NString.h

Returns the zero-based index of the first character's occurrence in string's range.

C++
NResult N_API NStringIndexOfInRange(HNString hString, NChar value, NInt startIndex, NInt count, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
NChar value | [in] Character to seek.
NInt startIndex | [in] Seek start index.
NInt count | [in] Characters count (range to perform search).
NInt * pIndex | [out] The zero-based index position of the first occurrence in this string range where specified character was found; -1 if no character was found. Note: Index numbering starts from 0.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringIndexOfStrFromN Function

NStringIndexOfStrFromN Function
NString.h

Returns the zero-based index of the first occurrence of the specified string in the string starting from specified index.

C++
NResult N_API NStringIndexOfStrFromN(HNString hString, HNString hValue, NInt startIndex, NBool ignoreCase, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
HNString hValue | [in] Handle to string to seek.
NInt startIndex | [in] Seek start index in hString.
NBool ignoreCase | [in] If NTrue strings comparison is not case sensitive.
NInt * pIndex | [out] The zero-based index position of hValue if that string is found, or -1 if it is not. Note: Index numbering starts from 0.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringIndexOfStrInRangeN Function

NStringIndexOfStrInRangeN Function
NString.h

Returns the zero-based index of the first occurrence of the specified string in the string's range.

C++
NResult N_API NStringIndexOfStrInRangeN(HNString hString, HNString hValue, NInt startIndex, NInt count, NBool ignoreCase, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
HNString hValue | [in] Handle to string to seek.
NInt startIndex | [in] Seek start index in hString.
NInt count | [in] hString range to seek (characters count starting with startIndex).
NBool ignoreCase | [in] If NTrue strings comparison is not case sensitive.
NInt * pIndex | [out] The zero-based index position of hValue if that string is found, or -1 if it is not. Note: Index numbering starts from 0.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringIndexOfStrN Function

NStringIndexOfStrN Function
NString.h

Returns the zero-based index of the first occurrence of the specified NString in the string.

C++
NResult N_API NStringIndexOfStrN(HNString hString, HNString hValue, NBool ignoreCase, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
HNString hValue | [in] NString to seek.
NBool ignoreCase | [in] If NTrue strings comparison is not case sensitive.
NInt * pIndex | [out] The zero-based index position of NString if found, or -1 if it is not. Note: Index numbering starts from 0.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringIndexOfStrOrChars Function

NStringIndexOfStrOrChars Function
NString.h

Returns the zero-based index of the first occurrence of the specified string or character in the string.

C++
NResult N_API NStringIndexOfStrOrChars(HNString hString, const NChar * arValue, NInt valueLength, NBool ignoreCase, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
const NChar * arValue | [in] NChar array which contains chars or string to check in hString.
NInt valueLength | [in] Size of arValue memory buffer.
NBool ignoreCase | [in] If NTrue strings comparison is not case sensitive.
NInt * pIndex | [out] The zero-based index position of NString if found, or -1 if it is not. Note: Index numbering starts from 0.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringIndexOfStrOrCharsFrom Function

NStringIndexOfStrOrCharsFrom Function
NString.h

Returns the zero-based index of the first occurrence of the specified string or character in the string.

C++
NResult N_API NStringIndexOfStrOrCharsFrom(HNString hString, const NChar * arValue, NInt valueLength, NInt startIndex, NBool ignoreCase, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
const NChar * arValue | [in] NChar array which contains chars or string to check in hString.
NInt valueLength | [in] Size of arValue memory buffer.
NInt startIndex | [in] Seek start index.
NBool ignoreCase | [in] If NTrue strings comparison is not case sensitive.
NInt * pIndex | [out] The zero-based index position of NString if found, or -1 if it is not. Note: Index numbering starts from 0.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringIndexOfStrOrCharsInRange Function

NStringIndexOfStrOrCharsInRange Function
NString.h

Returns the zero-based index of the first occurrence of the specified string or character in the string.

C++
NResult N_API NStringIndexOfStrOrCharsInRange(HNString hString, const NChar * arValue, NInt valueLength, NInt startIndex, NInt count, NBool ignoreCase, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
const NChar * arValue | [in] NChar array which contains chars or string to check in hString.
NInt valueLength | [in] Size of arValue memory buffer.
NInt startIndex | [in] Seek start index.
NInt count | [in] Range to perform search.
NBool ignoreCase | [in] If NTrue strings comparison is not case sensitive.
NInt * pIndex | [out] The zero-based index position of NString if found, or -1 if it is not. Note: Index numbering starts from 0.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringInsertN Function

NStringInsertN Function
NString.h

Returns a new string in which a specified string is inserted at a specified index position.

C++
NResult N_API NStringInsertN(HNString hString, NInt index, HNString hValue, HNString * phResultString);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
NInt index | [in] The zero-based index position of the insertion.
HNString hValue | [in] NString to insert.
HNString * phResultString | [out] Pointer to new string that is equivalent to hString, but with hValue inserted at position index.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringInsertStrOrChars Function

NStringInsertStrOrChars Function
NString.h

Returns a new string in which a specified string or characters is inserted at a specified index position.

C++
NResult N_API NStringInsertStrOrChars(HNString hString, NInt index, const NChar * arValue, NInt valueLength, HNString * phResultString);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
NInt index | [in] The zero-based index position of the insertion.
const NChar * arValue | [in] NChar array containing chars or string to insert.
NInt valueLength | [in] Size of arValue memory buffer.
HNString * phResultString | [out] Pointer to new string that is equivalent to hString, but with hValue inserted at position index.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringIsA Function

NStringIsA Function
NString.h

Checks whether specified string contains ANSI characters.

C++
NBool N_API NStringIsA(HNString hString);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringIsEmpty Function

NStringIsEmpty Function
NString.h

Checks whether specified string is empty string.

C++
NBool N_API NStringIsEmpty(HNString hString);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringIsW Function

NStringIsW Function
NString.h

Checks whether specified string contains Unicode characters.

C++
NBool N_API NStringIsW(HNString hString);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringIsWhiteSpace Function

NStringIsWhiteSpace Function
NString.h

Checks whether specified string consists only of white-space characters.

C++
NResult N_API NStringIsWhiteSpace(HNString hString, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
NBool * pValue | [out] Check result.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringJoinArray Function

NStringJoinArray Function
NString.h

Concatenates all the elements of a string array, using the specified separator between each element.

C++
NResult N_API NStringJoinArray(const NChar * szSeparator, const NChar * const * arszValues, NInt count, HNString * phResultString);
Collapse Expand Parameters
Parameters | Description
const NChar * szSeparator | [in] Zero terminated string to use as a separator.
const NChar * const * arszValues | [in] String array to concatenate.
NInt count | [in] Length of the array.
HNString * phResultString | [out] Pointer to a handle to the resulting string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringJoinArrayVN Function

NStringJoinArrayVN Function
NString.h

Concatenates all the elements of a string array, using the specified separator between each element.

C++
NResult N_API NStringJoinArrayVN(const NChar * szSeparator, const HNString * arhValues, NInt count, HNString * phResultString);
Collapse Expand Parameters
Parameters | Description
const NChar * szSeparator | [in] Zero terminated string to use as a separator.
const HNString * arhValues | [in] String handle array to concatenate.
NInt count | [in] Length of the array.
HNString * phResultString | [out] Pointer to a handle to the resulting string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringJoinMany Function

NStringJoinMany Function
NString.h

Concatenates all the elements of a string arrays, using the specified separator between each element.

C++
NResult N_API NStringJoinMany(const NChar * szSeparator, HNString * phResultString, NInt count, ... multipleParameters);
Collapse Expand Parameters
Parameters | Description
const NChar * szSeparator | [in] Zero terminated string to use as a separator.
HNString * phResultString | [out] The concatenated elements of specified strings.
NInt count | [in] Array items count.
... multipleParameters | [in] Function parameters.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringJoinManyVA Function

NStringJoinManyVA Function
NString.h

Concatenates all the elements of a string arrays, using the specified separator between each element.

C++
NResult N_API NStringJoinManyVA(const NChar * szSeparator, HNString * phResultString, NInt count, va_list args);
Collapse Expand Parameters
Parameters | Description
const NChar * szSeparator | [in] Zero terminated string to use as a separator.
HNString * phResultString | [out] The concatenated elements of specified strings.
NInt count | [in] Array items count.
va_list args | [in] Function argument list.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringJoinManyVAVN Function

NStringJoinManyVAVN Function
NString.h

Concatenates all the elements of a string arrays, using the specified separator between each element.

C++
NResult N_API NStringJoinManyVAVN(const NChar * szSeparator, HNString * phResultString, NInt count, va_list args);
Collapse Expand Parameters
Parameters | Description
const NChar * szSeparator | [in] Zero terminated string to use as a separator.
HNString * phResultString | [out] The concatenated elements of specified strings.
NInt count | [in] Array items count.
va_list args | [in] Function argument list.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringJoinManyVN Function

NStringJoinManyVN Function
NString.h

Concatenates all the elements of a string arrays, using the specified separator between each element.

C++
NResult N_API NStringJoinManyVN(const NChar * szSeparator, HNString * phResultString, NInt count, ... multipleParameters);
Collapse Expand Parameters
Parameters | Description
const NChar * szSeparator | [in] Zero terminated string to use as a separator.
HNString * phResultString | [out] The concatenated elements of specified strings.
NInt count | [in] Array items count.
... multipleParameters | [in] Function parameters.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringLastIndexOf Function

NStringLastIndexOf Function
NString.h

Returns the zero-based index position of the last occurrence of a specified character within string.

C++
NResult N_API NStringLastIndexOf(HNString hString, NChar value, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
NChar value | [in] Character to seek.
NInt * pIndex | [out] The zero-based index position of value if that character was found, or -1 if it is not.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringLastIndexOfAny Function

NStringLastIndexOfAny Function
NString.h

Returns the zero-based index position of the last occurrence in the string of one or more characters specified in an array.

C++
NResult N_API NStringLastIndexOfAny(HNString hString, const NChar * arAnyOf, NInt anyOfLength, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
const NChar * arAnyOf | [in] Characters array containing one or more characters to seek.
NInt anyOfLength | [in] Length of arAnyOf array.
NInt * pIndex | [out] The zero-based index position of the last occurrence in this string where any character in arAnyOf was found; -1 if no character in arAnyOf was found. Note: Index numbering starts from 0.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringLastIndexOfAnyFrom Function

NStringLastIndexOfAnyFrom Function
NString.h

Returns the zero-based index position of the last occurrence in the string of one or more characters specified in an array.

C++
NResult N_API NStringLastIndexOfAnyFrom(HNString hString, const NChar * arAnyOf, NInt anyOfLength, NInt startIndex, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
const NChar * arAnyOf | [in] Characters array containing one or more characters to seek.
NInt anyOfLength | [in] Length of arAnyOf array.
NInt startIndex | [in] Seek start index in hString.
NInt * pIndex | [out] The zero-based index position of the last occurrence in this string where any character in arAnyOf was found; -1 if no character in arAnyOf was found. Note: Index numbering starts from 0.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringLastIndexOfAnyInRange Function

NStringLastIndexOfAnyInRange Function
NString.h

Returns the zero-based index position of the last occurrence in the string's range of one or more characters specified in an array.

C++
NResult N_API NStringLastIndexOfAnyInRange(HNString hString, const NChar * arAnyOf, NInt anyOfLength, NInt startIndex, NInt count, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
const NChar * arAnyOf | [in] Characters array containing one or more characters to seek.
NInt anyOfLength | [in] Length of arAnyOf array.
NInt startIndex | [in] Seek start index in hString.
NInt count | [in] hString range to seek (characters count starting with startIndex).
NInt * pIndex | [out] The zero-based index position of the last occurrence in this string where any character in arAnyOf was found; -1 if no character in arAnyOf was found. Note: Index numbering starts from 0.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringLastIndexOfFrom Function

NStringLastIndexOfFrom Function
NString.h

Returns the zero-based index of the last occurrence of the specified character in the string starting from specified index.

C++
NResult N_API NStringLastIndexOfFrom(HNString hString, NChar value, NInt startIndex, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
NChar value | [in] [in] Character to seek.
NInt startIndex | [in] Seek start index in hString.
NInt * pIndex | [out] The zero-based index position of the last occurrence in this string where any character in arAnyOf was found; -1 if no character in arAnyOf was found. Note: Index numbering starts from 0.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringLastIndexOfInRange Function

NStringLastIndexOfInRange Function
NString.h

Returns the zero-based index of the last character's occurrence in string's range.

C++
NResult N_API NStringLastIndexOfInRange(HNString hString, NChar value, NInt startIndex, NInt count, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
NChar value | [in] Character to seek.
NInt startIndex | [in] Seek start index in hString.
NInt count | [in] Characters count (range to perform search).
NInt * pIndex | [out] The zero-based index position of the last occurrence in this string where any character in arAnyOf was found; -1 if no character in arAnyOf was found. Note: Index numbering starts from 0.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringLastIndexOfStrFromN Function

NStringLastIndexOfStrFromN Function
NString.h

Returns the zero-based index of the last occurrence of the specified string in the NString starting from specified index.

C++
NResult N_API NStringLastIndexOfStrFromN(HNString hString, HNString hValue, NInt startIndex, NBool ignoreCase, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
HNString hValue | [in] Handle to string to seek.
NInt startIndex | [in] Seek start index in hString.
NBool ignoreCase | [in] If NTrue strings comparison is not case sensitive.
NInt * pIndex | [out] The zero-based index position of hValue if that string is found, or -1 if it is not. Note: Index numbering starts from 0.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringLastIndexOfStrInRangeN Function

NStringLastIndexOfStrInRangeN Function
NString.h

Returns the zero-based index of the last occurrence of the specified string in the NString in specified range.

C++
NResult N_API NStringLastIndexOfStrInRangeN(HNString hString, HNString hValue, NInt startIndex, NInt count, NBool ignoreCase, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
HNString hValue | [in] Handle to string to seek.
NInt startIndex | [in] Seeking range starting index.
NInt count | [in] Seeking range length.
NBool ignoreCase | [in] If NTrue strings comparison is not case sensitive.
NInt * pIndex | [out] The zero-based index position of hValue if that string is found, or -1 if it is not. Note: Index numbering starts from 0.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringLastIndexOfStrN Function

NStringLastIndexOfStrN Function
NString.h

Returns the zero-based index of the last occurrence of the specified NString in the string.

C++
NResult N_API NStringLastIndexOfStrN(HNString hString, HNString hValue, NBool ignoreCase, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
HNString hValue | [in] NString to seek.
NBool ignoreCase | [in] If NTrue strings comparison is not case sensitive.
NInt * pIndex | [out] The zero-based index position of NString if found, or -1 if it is not. Note: Index numbering starts from 0.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringLastIndexOfStrOrChars Function

NStringLastIndexOfStrOrChars Function
NString.h

Returns the zero-based index of the last occurrence of the specified string or character in the string.

C++
NResult N_API NStringLastIndexOfStrOrChars(HNString hString, const NChar * arValue, NInt valueLength, NBool ignoreCase, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
const NChar * arValue | [in] NChar array which contains chars or string to check in hString.
NInt valueLength | [in] Size of arValue memory buffer.
NBool ignoreCase | [in] If NTrue strings comparison is not case sensitive.
NInt * pIndex | [out] The zero-based index position of NString if found, or -1 if it is not. Note: Index numbering starts from 0.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringLastIndexOfStrOrCharsFrom Function

NStringLastIndexOfStrOrCharsFrom Function
NString.h

Returns the zero-based index of the last occurrence of the specified string or character in the string.

C++
NResult N_API NStringLastIndexOfStrOrCharsFrom(HNString hString, const NChar * arValue, NInt valueLength, NInt startIndex, NBool ignoreCase, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
const NChar * arValue | [in] NChar array which contains chars or string to check in hString.
NInt valueLength | [in] Size of arValue memory buffer.
NInt startIndex | [in] Seek start index.
NBool ignoreCase | [in] If NTrue strings comparison is not case sensitive.
NInt * pIndex | [out] The zero-based index position of NString if found, or -1 if it is not. Note: Index numbering starts from 0.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringLastIndexOfStrOrCharsInRange Function

NStringLastIndexOfStrOrCharsInRange Function
NString.h

Returns the zero-based index of the last occurrence of the specified string or character in the string.

C++
NResult N_API NStringLastIndexOfStrOrCharsInRange(HNString hString, const NChar * arValue, NInt valueLength, NInt startIndex, NInt count, NBool ignoreCase, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
const NChar * arValue | [in] NChar array which contains chars or string to check in hString.
NInt valueLength | [in] Size of arValue memory buffer.
NInt startIndex | [in] Seek start index.
NInt count | [in] Range to perform search.
NBool ignoreCase | [in] If NTrue strings comparison is not case sensitive.
NInt * pIndex | [out] The zero-based index position of NString if found, or -1 if it is not. Note: Index numbering starts from 0.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringPadLeft Function

NStringPadLeft Function
NString.h

Returns a new string that right-aligns the characters by padding them with spaces on the left, for a specified total length.

C++
NResult N_API NStringPadLeft(HNString hString, NInt totalWidth, HNString * phResultString);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
NInt totalWidth | [in] The number of characters in the resulting string, equal to the number of original characters plus any additional padding characters.
HNString * phResultString | [out] A new string that is equivalent to hString, but right-aligned and padded on the left with as many spaces as needed to create a length of totalWidth. However, if totalWidth is less than the length of hString, the existing hString is returned. If totalWidth is equal to the length of hString, a new string that is identical to hString is returned.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringPadLeftWith Function

NStringPadLeftWith Function
NString.h

Returns a new string that right-aligns the characters by padding them on the left with a specified character, for a specified total length.

C++
NResult N_API NStringPadLeftWith(HNString hString, NInt totalWidth, NChar paddingChar, HNString * phResultString);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
NInt totalWidth | [in] The number of characters in the resulting string, equal to the number of original characters plus any additional padding characters.
NChar paddingChar | [in] Padding character.
HNString * phResultString | [out] A new string that is equivalent to hString, but right-aligned and padded on the left with as many spaces as needed to create a length of totalWidth. However, if totalWidth is less than the length of hString, the existing hString is returned. If totalWidth is equal to the length of hString, a new string that is identical to hString is returned.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringPadRight Function

NStringPadRight Function
NString.h

Returns a new string that left-aligns the characters by padding them with spaces on the right, for a specified total length.

C++
NResult N_API NStringPadRight(HNString hString, NInt totalWidth, HNString * phResultString);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
NInt totalWidth | [in] The number of characters in the resulting string, equal to the number of original characters plus any additional padding characters.
HNString * phResultString | [out] A new string that is equivalent to hString, but left-aligned and padded on the right with as many spaces as needed to create a length of totalWidth. However, if totalWidth is less than the length of hString, the function returns hString. If totalWidth is equal to the length hString, the function returns a new string that is identical to hString.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringPadRightWith Function

NStringPadRightWith Function
NString.h

Returns a new string that left-aligns the characters by padding them on the right with a specified character, for a specified total length.

C++
NResult N_API NStringPadRightWith(HNString hString, NInt totalWidth, NChar paddingChar, HNString * phResultString);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
NInt totalWidth | [in] The number of characters in the resulting string, equal to the number of original characters plus any additional padding characters.
NChar paddingChar | [in] Padding character.
HNString * phResultString | [out] A new string that is equivalent to hString, but left-aligned and padded on the right with as many spaces as needed to create a length of totalWidth. However, if totalWidth is less than the length of hString, the function returns hString. If totalWidth is equal to the length hString, the function returns a new string that is identical to hString.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringPrependStrOrChars Function

NStringPrependStrOrChars Function
NString.h

Prepends a string or a charset to another string.

C++
NResult N_API NStringPrependStrOrChars(HNString hString, const NChar * arValue, NInt valueLength, HNString * phResultString);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString which should be prepended.
const NChar * arValue | [in] Array with a sequence of characters. These characters will be prepended at the beginning of hString.
NInt valueLength | [in] Size of arValue memory buffer.
HNString * phResultString | [out] Result string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringPromoteBuffer Function

NStringPromoteBuffer Function
NString.h

Creates a new NString which takes ownership of the memory buffer.

C++
NResult N_API NStringPromoteBuffer(NChar * szValue, NInt length, NMemoryType memoryType, HNString * phString);
Collapse Expand Parameters
Parameters | Description
NChar * szValue | [out] Pointer to the characters from which the string is to be created.
NInt length | [in] Length of the new string.
NMemoryType memoryType | [in] Memory type of the block containing source characters.
HNString * phString | [out] Pointer to handle to the new NString.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringRemove Function

NStringRemove Function
NString.h

Returns a new string in which all the characters in hString, beginning at a specified position and continuing through the last position, have been deleted.

C++
NResult N_API NStringRemove(HNString hString, NInt startIndex, NInt count, HNString * phResultString);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
NInt startIndex | [in] The zero-based position to begin deleting characters.
NInt count | [in] The number of characters to delete from hString.
HNString * phResultString | [out] A new string that is equivalent to hString except for the removed characters.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringRemoveFrom Function

NStringRemoveFrom Function
NString.h

Returns a new string in which all the characters in hString, beginning at a specified position have been deleted.

C++
NResult N_API NStringRemoveFrom(HNString hString, NInt startIndex, HNString * phResultString);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
NInt startIndex | [in] The zero-based position to begin deleting characters.
HNString * phResultString | [out] A new string that is equivalent to hString except for the removed characters.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringReplace Function

NStringReplace Function
NString.h

Returns a new string in which all occurrences of a specified character in hString are replaced with another specified character.

C++
NResult N_API NStringReplace(HNString hString, NChar oldChar, NChar newChar, HNString * phResultString);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
NChar oldChar | [in] Character to be replaced.
NChar newChar | [in] Character to replace all occurrences of oldChar.
HNString * phResultString | [out] String that is equivalent to hString except that all instances of oldChar are replaced with newChar.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringReplaceStrOrChars Function

NStringReplaceStrOrChars Function
NString.h

Replaces a part of a string or a char array with new values.

C++
NResult N_API NStringReplaceStrOrChars(HNString hString, const NChar * arOldValue, NInt oldValueLength, const NChar * arNewValue, NInt newValueLength, HNString * phResultString);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to the original NString.
const NChar * arOldValue | [in] Char array representing values to be replaced.
NInt oldValueLength | [in] Length of the old value array.
const NChar * arNewValue | [in] Char array representing replacement values.
NInt newValueLength | [in] Length of the new value array.
HNString * phResultString | [out] Pointer to a handle to the modified NString.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringSet Function

NStringSet Function
NString.h

Sets the value of the specified string.

C++
NResult N_API NStringSet(HNString hValue, HNString * phVariable);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] Handle to the NString.
HNString * phVariable | [out] Pointer to a handle to the new NString value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringSplitWithCount Function

NStringSplitWithCount Function
NString.h

Returns a string array that contains the substrings that are delimited by elements of a specified character array. A parameter specifies the maximum number of substrings to return.

C++
NResult N_API NStringSplitWithCount(HNString hString, const NChar * arSeparators, NInt separatorCount, NInt count, NBool removeEmptyEntries, HNString * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
const NChar * arSeparators | [in] An array of characters that delimit the substrings in hString.
NInt separatorCount | [in] Separators count in arSeparators.
NInt count | [in] The maximum number of substrings to return.
NBool removeEmptyEntries | [in] NTrue - empty array elements from the array returned are omitted; NFalse - empty array elements in the array returned are included.
HNString * * parhValues | [out] An array whose elements contain the substrings in hString that are delimited by one or more chars in separator.
NInt * pValueCount | [out] parhValues array size.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringSplitWithStrsAndCount Function

NStringSplitWithStrsAndCount Function
NString.h

Returns a string array that contains the substrings that are delimited by elements of a specified character array. A parameter specifies the maximum number of substrings to return.

C++
NResult N_API NStringSplitWithStrsAndCount(HNString hString, const NChar * const * arszSeparators, NInt separatorCount, NInt count, NBool removeEmptyEntries, HNString * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
const NChar * const * arszSeparators | [in] A pointer to an array of characters that delimit the substrings in hString.
NInt separatorCount | [in] Separators count in arszSeparators.
NInt count | [in] The maximum number of substrings to return.
NBool removeEmptyEntries | [in] NTrue - empty array elements from the array returned are omitted; NFalse - empty array elements in the array returned are included.
HNString * * parhValues | [out] An array whose elements contain the substrings in hString that are delimited by one or more chars in separator.
NInt * pValueCount | [out] parhValues array size.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringSplitWithStrsAndCountN Function

NStringSplitWithStrsAndCountN Function
NString.h

Returns a string array that contains the substrings that are delimited by elements of a specified string array. A parameter specifies the maximum number of substrings to return.

C++
NResult N_API NStringSplitWithStrsAndCountN(HNString hString, const HNString * arhSeparators, NInt separatorCount, NInt count, NBool removeEmptyEntries, HNString * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
const HNString * arhSeparators | [in] A pointer to an array of string handles that delimit the substrings in hString.
NInt separatorCount | [in] Separators count in arhSeparators.
NInt count | [in] The maximum number of substrings to return.
NBool removeEmptyEntries | [in] NTrue - empty array elements from the array returned are omitted; NFalse - empty array elements in the array returned are included.
HNString * * parhValues | [out] An array whose elements contain the substrings in hString that are delimited by one or more chars in separator.
NInt * pValueCount | [out] parhValues array size.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringStartsWithN Function

NStringStartsWithN Function
NString.h

Checks whether the beginning of hString matches the specified string.

C++
NResult N_API NStringStartsWithN(HNString hString, HNString hOtherString, NBool ignoreCase, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
HNString hOtherString | [in] Handle to NString to compare.
NBool ignoreCase | [in] If NTrue strings comparison is not case sensitive.
NBool * pResult | [out] Check result.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringStartsWithStrOrCharsA Function

NStringStartsWithStrOrCharsA Function
NString.h

Checks whether the beginning of hString matches the specified string or chars.

C++
NResult N_API NStringStartsWithStrOrCharsA(HNString hString, const NAChar * arValue, NInt valueLength, NBool ignoreCase, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
const NAChar * arValue | [in] Pointer to a char array to compare.
NInt valueLength | [in] Length of arValue.
NBool ignoreCase | [in] If NTrue strings comparison is not case sensitive.
NBool * pResult | [out] Check result.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

This is an ANSCII version of the function.

Container

File: NString.h

Module: NString Unit


NStringStartsWithStrOrCharsW Function

NStringStartsWithStrOrCharsW Function
NString.h

Checks whether the beginning of hString matches the specified string or chars.

C++
NResult N_API NStringStartsWithStrOrCharsW(HNString hString, const NWChar * arValue, NInt valueLength, NBool ignoreCase, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
const NWChar * arValue | [in] Pointer to a char array to compare.
NInt valueLength | [in] Length of arValue.
NBool ignoreCase | [in] If NTrue strings comparison is not case sensitive.
NBool * pResult | [out] Check result.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringSubstring Function

NStringSubstring Function
NString.h

Gets a substring from hString. The substring starts at a specified character position.

C++
NResult N_API NStringSubstring(HNString hString, NInt startIndex, NInt length, HNString * phResultString);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
NInt startIndex | [in] The zero-based starting character position of a substring in hString.
NInt length | [in] The number of characters in the substring.
HNString * phResultString | [out] A string that is equivalent to the substring of length length that begins at startIndex in hString, or Empty if startIndex is equal to the length of hString and length is zero.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringSubstringFrom Function

NStringSubstringFrom Function
NString.h

Gets a substring from hString. The substring starts at a specified character position.

C++
NResult N_API NStringSubstringFrom(HNString hString, NInt startIndex, HNString * phResultString);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
NInt startIndex | [in] The zero-based starting character position of a substring in hString.
HNString * phResultString | [out] A pointer to handle to a string, equal to substring from startIndex to the end of the NString.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringToLower Function

NStringToLower Function
NString.h

Converts specified string to lowercase.

C++
NResult N_API NStringToLower(HNString hString, HNString * phResultString);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
HNString * phResultString | [out] A string in lowercase.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringToStrOrCharArray Function

NStringToStrOrCharArray Function
NString.h

Converts a string to another string or a character array.

C++
NResult N_API NStringToStrOrCharArray(HNString hString, NBool nullTerminate, NChar * * parValues, NInt * pLength);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
NBool nullTerminate | [in] NTrue if null values are to be terminated; else NFalse.
NChar * * parValues | [out] Pointer to a pointer to the resulting char array.
NInt * pLength | [out] Pointer to the length of the resulting char array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringToStrOrCharArrayRange Function

NStringToStrOrCharArrayRange Function
NString.h

Converts a string to another string or a part of character array.

C++
NResult N_API NStringToStrOrCharArrayRange(HNString hString, NBool nullTerminate, NInt startIndex, NInt length, NChar * * parValues, NInt * pLength);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
NBool nullTerminate | [in] NTrue if null values are to be terminated; else NFalse.
NInt startIndex | [in] Starting index in the array, at which the converted characters are being inserted.
NInt length | [in] Length of the range into which the converted characters are being inserted.
NChar * * parValues | [out] Pointer to a pointer to the resulting char array.
NInt * pLength | [out] Pointer to the length of the resulting char array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringToString Function

NStringToString Function
NString.h

Converts the specified string to another string with specified format.

C++
NResult N_API NStringToString(HNString hString, const NChar * szFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to the original NString.
const NChar * szFormat | [in] Pointer to the new format.
HNString * phValue | [out] Pointer to a handle to the converted string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringToUpper Function

NStringToUpper Function
NString.h

Converts specified string to uppercase.

C++
NResult N_API NStringToUpper(HNString hString, HNString * phResultString);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
HNString * phResultString | [out] A string in uppercase.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringTrim Function

NStringTrim Function
NString.h

Removes all leading and trailing white-space characters from specified string.

C++
NResult N_API NStringTrim(HNString hString, HNString * phResultString);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
HNString * phResultString | [out] hString with white-space characters removed from the start and end.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringTrimAny Function

NStringTrimAny Function
NString.h

Removes all leading and trailing occurrences of a sets of characters from specified string.

C++
NResult N_API NStringTrimAny(HNString hString, const NChar * arChars, NInt charCount, HNString * phResultString);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
const NChar * arChars | [in] An array of characters to remove.
NInt charCount | [in] Characters in arChars array count.
HNString * phResultString | [out] String with all trailing characters removed.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringTrimEnd Function

NStringTrimEnd Function
NString.h

Removes all trailing characters from hString.

C++
NResult N_API NStringTrimEnd(HNString hString, HNString * phResultString);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
HNString * phResultString | [out] String with all trailing characters removed.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringTrimEndAny Function

NStringTrimEndAny Function
NString.h

Removes all trailing occurrences of a set of characters specified in an array from hString.

C++
NResult N_API NStringTrimEndAny(HNString hString, const NChar * arChars, NInt charCount, HNString * phResultString);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
const NChar * arChars | [in] An array of characters to remove.
NInt charCount | [in] Characters in arChars array count.
HNString * phResultString | [out] String with all trailing characters removed.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringTrimStart Function

NStringTrimStart Function
NString.h

Removes all trailing characters from hString.

C++
NResult N_API NStringTrimStart(HNString hString, HNString * phResultString);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
HNString * phResultString | [out] String with all trailing characters removed.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringTrimStartAny Function

NStringTrimStartAny Function
NString.h

Removes all leading occurrences of a set of characters specified in an array from hString.

C++
NResult N_API NStringTrimStartAny(HNString hString, const NChar * arChars, NInt charCount, HNString * phResultString);
Collapse Expand Parameters
Parameters | Description
HNString hString | [in] Handle to NString.
const NChar * arChars | [in] An array of characters to remove.
NInt charCount | [in] Characters in arChars array count.
HNString * phResultString | [out] String with all trailing characters removed.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringAppend Macro

NStringAppend Macro
NString.h

Extends specified string content by adding an additional string at its end.

C++
#define NStringAppend(hString, szValue, phResultString) NStringAppendStrOrChars(hString, szValue, -1, phResultString)
Collapse Expand Parameters
Parameters | Description
hString | [in] Handle to NString which should be appended.
szValue | [in] Pointer to a string that will be appended at the end of hString.
phResultString | [out] Result string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringAppendChars Macro

NStringAppendChars Macro
NString.h

Extends specified string content by adding additional chars at its end.

C++
#define NStringAppendChars(hString, arValue, valueLength, phResultString) NStringAppendStrOrChars(hString, arValue, valueLength, phResultString)
Collapse Expand Parameters
Parameters | Description
hString | [in] Handle to NString which should be appended.
arValue | [in] Array with a sequence of characters. These characters will be appended at the end of hString.
valueLength | [in] Size of arValue memory buffer.
phResultString | [out] Result string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringAppendStrOrChars Macro

NStringAppendStrOrChars Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringAppendStrOrChars function.

C++
#define NStringAppendStrOrChars N_FUNC_AW(NStringAppendStrOrChars)
Container

File: NString.h

Module: NString Unit


NStringCompare Macro

NStringCompare Macro
NString.h

Compares two strings and retrieves their relative position in the sort order.

C++
#define NStringCompare(hString, szValue, ignoreCase, pResult) NStringCompareStrOrChars(hString, szValue, -1, ignoreCase, pResult)
Collapse Expand Parameters
Parameters | Description
hString | [in] Handle to the first string to use in comparison.
szValue | [in] Pointer to the second string to use in comparison.
ignoreCase | [in] NTrue to ignore letter case during comparison; else NFalse.
pResult | [out] Pointer to NInt value that indicates the lexical relationship between the two comparands.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringCompareChars Macro

NStringCompareChars Macro
NString.h

Compares a string with a char array and retrieves their relative position in the sort order.

C++
#define NStringCompareChars(hString, arValue, valueLength, ignoreCase, pResult) NStringCompareStrOrChars(hString, arValue, valueLength, ignoreCase, pResult)
Collapse Expand Parameters
Parameters | Description
hString | [in] Handle to the string to use in comparison.
arValue | [in] Pointer to the char array to use in comparison.
valueLength | [in] Length of the char array.
ignoreCase | [in] NTrue to ignore letter case during comparison; else NFalse.
pResult | [out] Pointer to NInt value that indicates the lexical relationship between the two comparands.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringCompareN Macro

NStringCompareN Macro
NString.h

Compares two strings and retrieves their relative position in the sort order.

C++
#define NStringCompareN(hString, hOtherString, ignoreCase, pResult) NStringCompareRangeN(hString, 0, hOtherString, 0, N_INT_MAX, ignoreCase, pResult)
Collapse Expand Parameters
Parameters | Description
hString | [in] Handle to the first string to use in comparison.
hOtherString | [in] Handle to the second string to use in comparison.
ignoreCase | [in] NTrue to ignore letter case during comparison; else NFalse.
pResult | [out] Pointer to NInt value that indicates the lexical relationship between the two comparands.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringCompareRange Macro

NStringCompareRange Macro
NString.h

Compares substrings of the two specified strings and retrieves their relative position in the sort order.

C++
#define NStringCompareRange(hString, index, szValue, length, ignoreCase, pResult) NStringCompareRangeStrOrChars(hString, index, szValue, -1, length, ignoreCase, pResult)
Collapse Expand Parameters
Parameters | Description
hString | [in] Handle to the first string to use in comparison.
index | [in] Position of the substring in hString.
szValue | [in] Pointer to the second string to use in comparison.
length | [in] The maximum number of characters in the substrings to compare.
ignoreCase | [in] NTrue to ignore letter case during comparison; else NFalse.
pResult | [out] Pointer to NInt value that indicates the lexical relationship between the two comparands.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringCompareRangeChars Macro

NStringCompareRangeChars Macro
NString.h

Compares substrings of a string and a charset and retrieves their relative position in the sort order.

C++
#define NStringCompareRangeChars(hString, index, arValue, valueLength, length, ignoreCase, pResult) NStringCompareRangeStrOrChars(hString, index, arValue, valueLength, length, ignoreCase, pResult)
Collapse Expand Parameters
Parameters | Description
hString | [in] Handle to the string to use in comparison.
index | [in] Position of the substring in hString.
arValue | [in] Handle to the charset to use in comparison.
valueLength | [in] Length of the charset.
length | [in] The maximum number of characters in the substrings to compare.
ignoreCase | [in] NTrue to ignore letter case during comparison; else NFalse.
pResult | [out] Pointer to NInt value that indicates the lexical relationship between the two comparands.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringCompareRangeN Macro

NStringCompareRangeN Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringCompareRangeN function.

C++
#define NStringCompareRangeN N_FUNC_AW(NStringCompareRangeN)
Container

File: NString.h

Module: NString Unit


NStringCompareRangeStrOrChars Macro

NStringCompareRangeStrOrChars Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringCompareRangeStrOrChars function.

C++
#define NStringCompareRangeStrOrChars N_FUNC_AW(NStringCompareRangeStrOrChars)
Container

File: NString.h

Module: NString Unit


NStringCompareStrOrChars Macro

NStringCompareStrOrChars Macro
NString.h

Compares a string with a string or char array and retrieves their relative position in the sort order.

C++
#define NStringCompareStrOrChars(hString, arValue, valueLength, ignoreCase, pResult) NStringCompareRangeStrOrChars(hString, 0, arValue, valueLength, N_INT_MAX, ignoreCase, pResult)
Collapse Expand Parameters
Parameters | Description
hString | [in] Handle to the string to use in comparison.
arValue | [in] Pointer to the char array to use in comparison.
valueLength | [in] Length of the char array.
ignoreCase | [in] NTrue to ignore letter case during comparison; else NFalse.
pResult | [out] Pointer to NInt value that indicates the lexical relationship between the two comparands.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringConcat Macro

NStringConcat Macro
NString.h

Concatenates strings specified by handles.

C++
#define NStringConcat(szValue1, szValue2, phResultString) NStringConcatStrOrChars(szValue1, -1, szValue2, -1, phResultString)
Collapse Expand Parameters
Parameters | Description
hValue1 | [in] Handle to first string to concatenate.
hValue2 | [in] Handle to second string to concatenate.
phResultString | [out] The concatenated strings.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringConcatChars Macro

NStringConcatChars Macro
NString.h

Concatenates charsets specified by handles.

C++
#define NStringConcatChars(arValue1, value1Length, arValue2, value2Length, phResultString) NStringConcatStrOrChars(arValue1, value1Length, arValue2, value2Length, phResultString)
Collapse Expand Parameters
Parameters | Description
arValue1 | [in] Pointer to the first charset.
value1Length | [in] Length of the first charset.
arValue2 | [in] Pointer to the second charset.
value2Length | [in] Length of the second charset.
phResultString | [out] Pointer to a handle to the resulting string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringConcatMany Macro

NStringConcatMany Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringConcatMany function.

C++
#define NStringConcatMany N_FUNC_AW(NStringConcatMany)
Container

File: NString.h

Module: NString Unit


NStringConcatManyVA Macro

NStringConcatManyVA Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringConcatManyVA function.

C++
#define NStringConcatManyVA N_FUNC_AW(NStringConcatManyVA)
Container

File: NString.h

Module: NString Unit


NStringConcatStrOrChars Macro

NStringConcatStrOrChars Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringConcatStrOrChars function.

C++
#define NStringConcatStrOrChars N_FUNC_AW(NStringConcatStrOrChars)
Container

File: NString.h

Module: NString Unit


NStringContainsChars Macro

NStringContainsChars Macro
NString.h

Returns a value indicating whether specified chars occur within string specified by handle.

C++
#define NStringContainsChars(hString, arValue, valueLength, pResult) NStringContainsStrOrChars(hString, arValue, valueLength, pResult)
Collapse Expand Parameters
Parameters | Description
hString | [in] Handle to NString to check.
arValue | [in] NChar array which contains chars to check in hString.
valueLength | [in] Length of memory buffer where arValue is stored.
pResult | [out] Strings check result.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringContainsStr Macro

NStringContainsStr Macro
NString.h

Returns a value indicating whether specified string occurs within string specified by handle.

C++
#define NStringContainsStr(hString, szValue, pResult) NStringContainsStrOrChars(hString, szValue, -1, pResult)
Collapse Expand Parameters
Parameters | Description
hString | [in] Handle to NString to check.
szValue | [in] Pointer to NString to check in hString.
valueLength | [in] Length of NString pointed to by szValue.
pResult | [out] Strings check result.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringContainsStrOrChars Macro

NStringContainsStrOrChars Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringContainsStrOrChars function.

C++
#define NStringContainsStrOrChars N_FUNC_AW(NStringContainsStrOrChars)
Container

File: NString.h

Module: NString Unit


NStringCopyTo Macro

NStringCopyTo Macro
NString.h

Copies a specified number of characters from a specified position in handle to a specified array.

C++
#define NStringCopyTo(hString, sourceIndex, arValue, valueLength, count) NStringCopyToStrOrChars(hString, sourceIndex, arValue, valueLength, NFalse, count)
Collapse Expand Parameters
Parameters | Description
hString | [in] Handle to NString which contains characters to copy.
sourceIndex | [in] The index of the first character in this handle to copy.
arValue | [out] Pointer to memory buffer which contains copied characters.
valueLength | [in] Size of arValue memory buffer.
count | [in] The number of characters in hString to copy to arValue.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringCopyToStrOrChars Macro

NStringCopyToStrOrChars Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringCopyToStrOrChars function.

C++
#define NStringCopyToStrOrChars N_FUNC_AW(NStringCopyToStrOrChars)
Container

File: NString.h

Module: NString Unit


NStringCopyToString Macro

NStringCopyToString Macro
NString.h

Copies a specified number of characters from a specified position in handle to a specified string.

C++
#define NStringCopyToString(hString, sourceIndex, szValue, valueSize, count) NStringCopyToStrOrChars(hString, sourceIndex, szValue, valueSize, NTrue, count)
Collapse Expand Parameters
Parameters | Description
hString | [in] Handle to NString which contains characters to copy.
sourceIndex | [in] The index of the first character in this handle to copy.
szValue | [out] Pointer to NString which contains copied characters.
valueSize | [in] Size of szValue string.
count | [in] The number of characters in hString to copy to szValue.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringCreate Macro

NStringCreate Macro
NString.h

Creates a string with the specified value.

C++
#define NStringCreate(szValue, phString) NStringCreateFromStrOrChars(szValue, -1, phString)
Collapse Expand Parameters
Parameters | Description
szValue | [in] Pointer to the string value.
phString | [out] Pointer to a handle to the new string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringCreateFromChar Macro

NStringCreateFromChar Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringCreateFromChar function.

C++
#define NStringCreateFromChar N_FUNC_AW(NStringCreateFromChar)
Container

File: NString.h

Module: NString Unit


NStringCreateFromChars Macro

NStringCreateFromChars Macro
NString.h

Creates a string from the specified array of characters.

C++
#define NStringCreateFromChars(arValue, length, phString) NStringCreateFromStrOrChars(arValue, length, phString)
Collapse Expand Parameters
Parameters | Description
arValue | [in] Array of chars.
length | [in] Size of arValue memory buffer.
phString | [out] Pointer to a handle to the new string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringCreateFromStrOrChars Macro

NStringCreateFromStrOrChars Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringCreateFromStrOrChars function.

C++
#define NStringCreateFromStrOrChars N_FUNC_AW(NStringCreateFromStrOrChars)
Container

File: NString.h

Module: NString Unit


NStringCreateWrapper Macro

NStringCreateWrapper Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringCreateWrapper function.

C++
#define NStringCreateWrapper N_FUNC_AW(NStringCreateWrapper)
Container

File: NString.h

Module: NString Unit


NStringEndsWith Macro

NStringEndsWith Macro
NString.h

Checks whether the end of the string matches the specified string.

C++
#define NStringEndsWith(hString, szValue, ignoreCase, pResult) NStringEndsWithStrOrChars(hString, szValue, -1, ignoreCase, pResult)
Collapse Expand Parameters
Parameters | Description
hString | [in] Handle to string to check.
szValue | [in] Pointer to the string to compare to the hString.
ignoreCase | [in] If NTrue strings comparison is not case sensitive.
pResult | [out] Strings check result.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringEndsWithChars Macro

NStringEndsWithChars Macro
NString.h

Checks whether the end of the string matches the specified string or charset.

C++
#define NStringEndsWithChars(hString, arValue, valueLength, ignoreCase, pResult) NStringEndsWithStrOrChars(hString, arValue, valueLength, ignoreCase, pResult)
Collapse Expand Parameters
Parameters | Description
hString | [in] Handle to string to check.
arValue | [in] Pointer to the char array to compare to the hString.
valueLength | [in] Length of arValue.
ignoreCase | [in] If NTrue strings comparison is not case sensitive.
pResult | [out] Strings check result.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringEndsWithStrOrChars Macro

NStringEndsWithStrOrChars Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringEndsWithStrOrChars function.

C++
#define NStringEndsWithStrOrChars N_FUNC_AW(NStringEndsWithStrOrChars)
Container

File: NString.h

Module: NString Unit


NStringEquals Macro

NStringEquals Macro
NString.h

Checks whether two specified stings have the same value.

C++
#define NStringEquals(hString, szValue, ignoreCase, pResult) NStringEqualsStrOrChars(hString, szValue, -1, ignoreCase, pResult)
Collapse Expand Parameters
Parameters | Description
hString | [in] Handle to the first string to compare.
szValue | [in] Pointer to the second string to compare.
ignoreCase | [in] If NTrue strings comparison is not case sensitive.
pResult | [out] Strings check result.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringEqualsChars Macro

NStringEqualsChars Macro
NString.h

Checks whether the specified string and the specified charset have the same value.

C++
#define NStringEqualsChars(hString, arValue, valueLength, ignoreCase, pResult) NStringEqualsStrOrChars(hString, arValue, valueLength, ignoreCase, pResult)
Collapse Expand Parameters
Parameters | Description
hString | [in] Handle to the string to compare.
arValue | [in] Pointer to the char array to compare.
valueLength | [in] Length of arValue.
ignoreCase | [in] If NTrue strings comparison is not case sensitive.
pResult | [out] Strings check result.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringEqualsStrOrChars Macro

NStringEqualsStrOrChars Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringEqualsStrOrChars function.

C++
#define NStringEqualsStrOrChars N_FUNC_AW(NStringEqualsStrOrChars)
Container

File: NString.h

Module: NString Unit


NStringFormat Macro

NStringFormat Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringFormat function.

C++
#define NStringFormat N_FUNC_AW(NStringFormat)
Container

File: NString.h

Module: NString Unit


NStringFormatVA Macro

NStringFormatVA Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringFormatVA function.

C++
#define NStringFormatVA N_FUNC_AW(NStringFormatVA)
Container

File: NString.h

Module: NString Unit


NStringGetBuffer Macro

NStringGetBuffer Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringGetBuffer function.

C++
#define NStringGetBuffer N_FUNC_AW(NStringGetBuffer)
Container

File: NString.h

Module: NString Unit


NStringGetChar Macro

NStringGetChar Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringGetChar function.

C++
#define NStringGetChar N_FUNC_AW(NStringGetChar)
Container

File: NString.h

Module: NString Unit


NStringGetLength Macro

NStringGetLength Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringGetLength function.

C++
#define NStringGetLength N_FUNC_AW(NStringGetLength)
Container

File: NString.h

Module: NString Unit


NStringIndexOf Macro

NStringIndexOf Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringIndexOf function.

C++
#define NStringIndexOf N_FUNC_AW(NStringIndexOf)
Container

File: NString.h

Module: NString Unit


NStringIndexOfAny Macro

NStringIndexOfAny Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfAny function.

C++
#define NStringIndexOfAny N_FUNC_AW(NStringIndexOfAny)
Container

File: NString.h

Module: NString Unit


NStringIndexOfAnyFrom Macro

NStringIndexOfAnyFrom Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfAnyFrom function.

C++
#define NStringIndexOfAnyFrom N_FUNC_AW(NStringIndexOfAnyFrom)
Container

File: NString.h

Module: NString Unit


NStringIndexOfAnyInRange Macro

NStringIndexOfAnyInRange Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfAnyInRange function.

C++
#define NStringIndexOfAnyInRange N_FUNC_AW(NStringIndexOfAnyInRange)
Container

File: NString.h

Module: NString Unit


NStringIndexOfChars Macro

NStringIndexOfChars Macro
NString.h

Returns the zero-based index of the first occurrence of the specified character in the string.

C++
#define NStringIndexOfChars(hString, arValue, valueLength, ignoreCase, pIndex) NStringIndexOfStrOrChars(hString, arValue, valueLength, ignoreCase, pIndex)
Collapse Expand Parameters
Parameters | Description
hString | [in] Handle to NString.
arValue | [in] NChar array which contains chars to check in hString.
valueLength | [in] Size of arValue memory buffer.
ignoreCase | [in] If NTrue strings comparison is not case sensitive.
pIndex | [out] The zero-based index position of NString if found, or -1 if it is not. Note: Index numbering starts from 0.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringIndexOfCharsFrom Macro

NStringIndexOfCharsFrom Macro
NString.h

Returns the zero-based index of the first occurrence of the specified character in the string.

C++
#define NStringIndexOfCharsFrom(hString, arValue, valueLength, startIndex, ignoreCase, pIndex) NStringIndexOfStrOrCharsFrom(hString, arValue, valueLength, startIndex, ignoreCase, pIndex)
Collapse Expand Parameters
Parameters | Description
hString | [in] Handle to NString.
arValue | [in] NChar array which contains chars to check in hString.
valueLength | [in] Size of arValue memory buffer.
startIndex | [in] Seek start index.
ignoreCase | [in] If NTrue strings comparison is not case sensitive.
pIndex | [out] The zero-based index position of NString if found, or -1 if it is not. Note: Index numbering starts from 0.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringIndexOfCharsInRange Macro

NStringIndexOfCharsInRange Macro
NString.h

Returns the zero-based index of the first occurrence of the specified character in the string.

C++
#define NStringIndexOfCharsInRange(hString, arValue, valueLength, startIndex, count, ignoreCase, pIndex) NStringIndexOfStrOrCharsInRange(hString, arValue, valueLength, startIndex, count, ignoreCase, pIndex)
Collapse Expand Parameters
Parameters | Description
hString | [in] Handle to NString.
arValue | [in] NChar array which contains chars to check in hString.
valueLength | [in] Size of arValue memory buffer.
startIndex | [in] Seek start index.
count | [in] Range to perform search.
ignoreCase | [in] If NTrue strings comparison is not case sensitive.
pIndex | [out] The zero-based index position of NString if found, or -1 if it is not. Note: Index numbering starts from 0.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringIndexOfFrom Macro

NStringIndexOfFrom Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfFrom function.

C++
#define NStringIndexOfFrom N_FUNC_AW(NStringIndexOfFrom)
Container

File: NString.h

Module: NString Unit


NStringIndexOfInRange Macro

NStringIndexOfInRange Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfInRange function.

C++
#define NStringIndexOfInRange N_FUNC_AW(NStringIndexOfInRange)
Container

File: NString.h

Module: NString Unit


NStringIndexOfStr Macro

NStringIndexOfStr Macro
NString.h

Returns the zero-based index of the first occurrence of the specified string in the string.

C++
#define NStringIndexOfStr(hString, szValue, ignoreCase, pIndex) NStringIndexOfStrOrChars(hString, szValue, -1, ignoreCase, pIndex)
Collapse Expand Parameters
Parameters | Description
hString | [in] Handle to NString.
szValue | [in] Pointer to a string to check in hString.
ignoreCase | [in] If NTrue strings comparison is not case sensitive.
pIndex | [out] The zero-based index position of NString if found, or -1 if it is not. Note: Index numbering starts from 0.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringIndexOfStrFrom Macro

NStringIndexOfStrFrom Macro
NString.h

Returns the zero-based index of the first occurrence of the specified string in the string.

C++
#define NStringIndexOfStrFrom(hString, szValue, startIndex, ignoreCase, pIndex) NStringIndexOfStrOrCharsFrom(hString, szValue, -1, startIndex, ignoreCase, pIndex)
Collapse Expand Parameters
Parameters | Description
hString | [in] Handle to NString.
szValue | [in] Pointer to a string to check in hString.
startIndex | [in] Seek start index.
ignoreCase | [in] If NTrue strings comparison is not case sensitive.
pIndex | [out] The zero-based index position of NString if found, or -1 if it is not. Note: Index numbering starts from 0.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringIndexOfStrFromN Macro

NStringIndexOfStrFromN Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfStrFromN function.

C++
#define NStringIndexOfStrFromN N_FUNC_AW(NStringIndexOfStrFromN)
Container

File: NString.h

Module: NString Unit


NStringIndexOfStrInRange Macro

NStringIndexOfStrInRange Macro
NString.h

Returns the zero-based index of the first occurrence of the specified string in the string.

C++
#define NStringIndexOfStrInRange(hString, szValue, startIndex, count, ignoreCase, pIndex) NStringIndexOfStrOrCharsInRange(hString, szValue, -1, startIndex, count, ignoreCase, pIndex)
Collapse Expand Parameters
Parameters | Description
hString | [in] Handle to NString.
arValue | [in] Pointer to a string to check in hString.
startIndex | [in] Seek start index.
count | [in] Range to perform search.
ignoreCase | [in] If NTrue strings comparison is not case sensitive.
pIndex | [out] The zero-based index position of NString if found, or -1 if it is not. Note: Index numbering starts from 0.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringIndexOfStrInRangeN Macro

NStringIndexOfStrInRangeN Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfStrInRangeN function.

C++
#define NStringIndexOfStrInRangeN N_FUNC_AW(NStringIndexOfStrInRangeN)
Container

File: NString.h

Module: NString Unit


NStringIndexOfStrN Macro

NStringIndexOfStrN Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfStrN function.

C++
#define NStringIndexOfStrN N_FUNC_AW(NStringIndexOfStrN)
Container

File: NString.h

Module: NString Unit


NStringIndexOfStrOrChars Macro

NStringIndexOfStrOrChars Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfStrOrChars function.

C++
#define NStringIndexOfStrOrChars N_FUNC_AW(NStringIndexOfStrOrChars)
Container

File: NString.h

Module: NString Unit


NStringIndexOfStrOrCharsFrom Macro

NStringIndexOfStrOrCharsFrom Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfStrOrCharsFrom function.

C++
#define NStringIndexOfStrOrCharsFrom N_FUNC_AW(NStringIndexOfStrOrCharsFrom)
Container

File: NString.h

Module: NString Unit


NStringIndexOfStrOrCharsInRange Macro

NStringIndexOfStrOrCharsInRange Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfStrOrCharsInRange function.

C++
#define NStringIndexOfStrOrCharsInRange N_FUNC_AW(NStringIndexOfStrOrCharsInRange)
Container

File: NString.h

Module: NString Unit


NStringInsert Macro

NStringInsert Macro
NString.h

Returns a new string in which a specified string is inserted at a specified index position.

C++
#define NStringInsert(hString, index, szValue, phResultString) NStringInsertStrOrChars(hString, index, szValue, -1, phResultString)
Collapse Expand Parameters
Parameters | Description
hString | [in] Handle to NString.
index | [in] The zero-based index position of the insertion.
szValue | [in] Pointer to the string to insert.
phResultString | [out] Pointer to new string that is equivalent to hString, but with szValue inserted at position index.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringInsertChars Macro

NStringInsertChars Macro
NString.h

Returns a new string in which a specified characters are inserted at a specified index position.

C++
#define NStringInsertChars(hString, index, arValue, valueLength, phResultString) NStringInsertStrOrChars(hString, index, arValue, valueLength, phResultString)
Collapse Expand Parameters
Parameters | Description
hString | [in] Handle to NString.
index | [in] The zero-based index position of the insertion.
arValue | [in] NChar array containing chars to insert.
valueLength | [in] Size of arValue memory buffer.
phResultString | [out] Pointer to new string that is equivalent to hString, but with arValue inserted at position index.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringInsertN Macro

NStringInsertN Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringInsertN function.

C++
#define NStringInsertN N_FUNC_AW(NStringInsertN)
Container

File: NString.h

Module: NString Unit


NStringInsertStrOrChars Macro

NStringInsertStrOrChars Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringInsertStrOrChars function.

C++
#define NStringInsertStrOrChars N_FUNC_AW(NStringInsertStrOrChars)
Container

File: NString.h

Module: NString Unit


NStringJoinArray Macro

NStringJoinArray Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringJoinArray function.

C++
#define NStringJoinArray N_FUNC_AW(NStringJoinArray)
Container

File: NString.h

Module: NString Unit


NStringJoinArrayVN Macro

NStringJoinArrayVN Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringJoinArrayVN function.

C++
#define NStringJoinArrayVN N_FUNC_AW(NStringJoinArrayVN)
Container

File: NString.h

Module: NString Unit


NStringJoinMany Macro

NStringJoinMany Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringJoinMany function.

C++
#define NStringJoinMany N_FUNC_AW(NStringJoinMany)
Container

File: NString.h

Module: NString Unit


NStringJoinManyVAVN Macro

NStringJoinManyVAVN Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringJoinManyVAVN function.

C++
#define NStringJoinManyVAVN N_FUNC_AW(NStringJoinManyVAVN)
Container

File: NString.h

Module: NString Unit


NStringJoinManyVN Macro

NStringJoinManyVN Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringJoinManyVN function.

C++
#define NStringJoinManyVN N_FUNC_AW(NStringJoinManyVN)
Container

File: NString.h

Module: NString Unit


NStringLastIndexOf Macro

NStringLastIndexOf Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOf function.

C++
#define NStringLastIndexOf N_FUNC_AW(NStringLastIndexOf)
Container

File: NString.h

Module: NString Unit


NStringLastIndexOfAny Macro

NStringLastIndexOfAny Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfAny function.

C++
#define NStringLastIndexOfAny N_FUNC_AW(NStringLastIndexOfAny)
Container

File: NString.h

Module: NString Unit


NStringLastIndexOfAnyFrom Macro

NStringLastIndexOfAnyFrom Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfAnyFrom function.

C++
#define NStringLastIndexOfAnyFrom N_FUNC_AW(NStringLastIndexOfAnyFrom)
Container

File: NString.h

Module: NString Unit


NStringLastIndexOfAnyInRange Macro

NStringLastIndexOfAnyInRange Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfAnyInRange function.

C++
#define NStringLastIndexOfAnyInRange N_FUNC_AW(NStringLastIndexOfAnyInRange)
Container

File: NString.h

Module: NString Unit


NStringLastIndexOfChars Macro

NStringLastIndexOfChars Macro
NString.h

Returns the zero-based index of the last occurrence of the specified character in the string.

C++
#define NStringLastIndexOfChars(hString, arValue, valueLength, ignoreCase, pIndex) NStringLastIndexOfStrOrChars(hString, arValue, valueLength, ignoreCase, pIndex)
Collapse Expand Parameters
Parameters | Description
hString | [in] Handle to NString.
arValue | [in] NChar array which contains chars to check in hString.
valueLength | [in] Size of arValue memory buffer.
ignoreCase | [in] If NTrue strings comparison is not case sensitive.
pIndex | [out] The zero-based index position of NString if found, or -1 if it is not. Note: Index numbering starts from 0.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringLastIndexOfCharsFrom Macro

NStringLastIndexOfCharsFrom Macro
NString.h

Returns the zero-based index of the last occurrence of the specified character in the string.

C++
#define NStringLastIndexOfCharsFrom(hString, arValue, valueLength, startIndex, ignoreCase, pIndex) NStringLastIndexOfStrOrCharsFrom(hString, arValue, valueLength, startIndex, ignoreCase, pIndex)
Collapse Expand Parameters
Parameters | Description
hString | [in] Handle to NString.
arValue | [in] NChar array which contains chars to check in hString.
valueLength | [in] Size of arValue memory buffer.
startIndex | [in] Seek start index.
ignoreCase | [in] If NTrue strings comparison is not case sensitive.
pIndex | [out] The zero-based index position of NString if found, or -1 if it is not. Note: Index numbering starts from 0.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringLastIndexOfCharsInRange Macro

NStringLastIndexOfCharsInRange Macro
NString.h

Returns the zero-based index of the last occurrence of the specified character in the string.

C++
#define NStringLastIndexOfCharsInRange(hString, arValue, valueLength, startIndex, count, ignoreCase, pIndex) NStringLastIndexOfStrOrCharsInRange(hString, arValue, valueLength, startIndex, count, ignoreCase, pIndex)
Collapse Expand Parameters
Parameters | Description
hString | [in] Handle to NString.
arValue | [in] NChar array which contains chars to check in hString.
valueLength | [in] Size of arValue memory buffer.
startIndex | [in] Seek start index.
count | [in] Range to perform search.
ignoreCase | [in] If NTrue strings comparison is not case sensitive.
pIndex | [out] The zero-based index position of NString if found, or -1 if it is not. Note: Index numbering starts from 0.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringLastIndexOfFrom Macro

NStringLastIndexOfFrom Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfFrom function.

C++
#define NStringLastIndexOfFrom N_FUNC_AW(NStringLastIndexOfFrom)
Container

File: NString.h

Module: NString Unit


NStringLastIndexOfInRange Macro

NStringLastIndexOfInRange Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfInRange function.

C++
#define NStringLastIndexOfInRange N_FUNC_AW(NStringLastIndexOfInRange)
Container

File: NString.h

Module: NString Unit


NStringLastIndexOfStr Macro

NStringLastIndexOfStr Macro
NString.h

Returns the zero-based index of the last occurrence of the specified string in the string.

C++
#define NStringLastIndexOfStr(hString, szValue, ignoreCase, pIndex) NStringLastIndexOfStrOrChars(hString, szValue, -1, ignoreCase, pIndex)
Collapse Expand Parameters
Parameters | Description
hString | [in] Handle to NString.
szValue | [in] Pointer to a string to check in hString.
ignoreCase | [in] If NTrue strings comparison is not case sensitive.
pIndex | [out] The zero-based index position of NString if found, or -1 if it is not. Note: Index numbering starts from 0.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringLastIndexOfStrFrom Macro

NStringLastIndexOfStrFrom Macro
NString.h

Returns the zero-based index of the last occurrence of the specified string in the string.

C++
#define NStringLastIndexOfStrFrom(hString, szValue, startIndex, ignoreCase, pIndex) NStringLastIndexOfStrOrCharsFrom(hString, szValue, -1, startIndex, ignoreCase, pIndex)
Collapse Expand Parameters
Parameters | Description
hString | [in] Handle to NString.
szValue | [in] Pointer to a string to check in hString.
startIndex | [in] Seek start index.
ignoreCase | [in] If NTrue strings comparison is not case sensitive.
pIndex | [out] The zero-based index position of NString if found, or -1 if it is not. Note: Index numbering starts from 0.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringLastIndexOfStrFromN Macro

NStringLastIndexOfStrFromN Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfStrFromN function.

C++
#define NStringLastIndexOfStrFromN N_FUNC_AW(NStringLastIndexOfStrFromN)
Container

File: NString.h

Module: NString Unit


NStringLastIndexOfStrInRange Macro

NStringLastIndexOfStrInRange Macro
NString.h

Returns the zero-based index of the last occurrence of the specified string in the string.

C++
#define NStringLastIndexOfStrInRange(hString, szValue, startIndex, count, ignoreCase, pIndex) NStringLastIndexOfStrOrCharsInRange(hString, szValue, -1, startIndex, count, ignoreCase, pIndex)
Collapse Expand Parameters
Parameters | Description
hString | [in] Handle to NString.
arValue | [in] Pointer to a string to check in hString.
startIndex | [in] Seek start index.
count | [in] Range to perform search.
ignoreCase | [in] If NTrue strings comparison is not case sensitive.
pIndex | [out] The zero-based index position of NString if found, or -1 if it is not. Note: Index numbering starts from 0.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringLastIndexOfStrInRangeN Macro

NStringLastIndexOfStrInRangeN Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfStrInRangeN function.

C++
#define NStringLastIndexOfStrInRangeN N_FUNC_AW(NStringLastIndexOfStrInRangeN)
Container

File: NString.h

Module: NString Unit


NStringLastIndexOfStrN Macro

NStringLastIndexOfStrN Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfStrN function.

C++
#define NStringLastIndexOfStrN N_FUNC_AW(NStringLastIndexOfStrN)
Container

File: NString.h

Module: NString Unit


NStringLastIndexOfStrOrChars Macro

NStringLastIndexOfStrOrChars Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfStrOrChars function.

C++
#define NStringLastIndexOfStrOrChars N_FUNC_AW(NStringLastIndexOfStrOrChars)
Container

File: NString.h

Module: NString Unit


NStringLastIndexOfStrOrCharsFrom Macro

NStringLastIndexOfStrOrCharsFrom Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfStrOrCharsFrom function.

C++
#define NStringLastIndexOfStrOrCharsFrom N_FUNC_AW(NStringLastIndexOfStrOrCharsFrom)
Container

File: NString.h

Module: NString Unit


NStringLastIndexOfStrOrCharsInRange Macro

NStringLastIndexOfStrOrCharsInRange Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfStrOrCharsInRange function.

C++
#define NStringLastIndexOfStrOrCharsInRange N_FUNC_AW(NStringLastIndexOfStrOrCharsInRange)
Container

File: NString.h

Module: NString Unit


NStringPadLeft Macro

NStringPadLeft Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringPadLeft function.

C++
#define NStringPadLeft N_FUNC_AW(NStringPadLeft)
Container

File: NString.h

Module: NString Unit


NStringPadLeftWith Macro

NStringPadLeftWith Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringPadLeftWith function.

C++
#define NStringPadLeftWith N_FUNC_AW(NStringPadLeftWith)
Container

File: NString.h

Module: NString Unit


NStringPadRight Macro

NStringPadRight Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringPadRight function.

C++
#define NStringPadRight N_FUNC_AW(NStringPadRight)
Container

File: NString.h

Module: NString Unit


NStringPadRightWith Macro

NStringPadRightWith Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringPadRightWith function.

C++
#define NStringPadRightWith N_FUNC_AW(NStringPadRightWith)
Container

File: NString.h

Module: NString Unit


NStringPrepend Macro

NStringPrepend Macro
NString.h

Prepends a string to another string.

C++
#define NStringPrepend(hString, szValue, phResultString) NStringPrependStrOrChars(hString, szValue, -1, phResultString)
Collapse Expand Parameters
Parameters | Description
hString | [in] Handle to NString which should be prepended.
szValue | [in] Pointer to a string that will be prepended at the beginning of hString.
phResultString | [out] Result string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringPrependChars Macro

NStringPrependChars Macro
NString.h

Prepends a charset to another string.

C++
#define NStringPrependChars(hString, arValue, valueLength, phResultString) NStringPrependStrOrChars(hString, arValue, valueLength, phResultString)
Collapse Expand Parameters
Parameters | Description
hString | [in] Handle to NString which should be prepended.
arValue | [in] Array with a sequence of characters. These characters will be prepended at the beginning of hString.
valueLength | [in] Size of arValue memory buffer.
phResultString | [out] Result string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringPrependStrOrChars Macro

NStringPrependStrOrChars Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringPrependStrOrChars function.

C++
#define NStringPrependStrOrChars N_FUNC_AW(NStringPrependStrOrChars)
Container

File: NString.h

Module: NString Unit


NStringPromoteBuffer Macro

NStringPromoteBuffer Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringPromoteBuffer function.

C++
#define NStringPromoteBuffer N_FUNC_AW(NStringPromoteBuffer)
Container

File: NString.h

Module: NString Unit


NStringRemove Macro

NStringRemove Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringRemove function.

C++
#define NStringRemove N_FUNC_AW(NStringRemove)
Container

File: NString.h

Module: NString Unit


NStringRemoveFrom Macro

NStringRemoveFrom Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringRemoveFrom function.

C++
#define NStringRemoveFrom N_FUNC_AW(NStringRemoveFrom)
Container

File: NString.h

Module: NString Unit


NStringReplace Macro

NStringReplace Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringReplace function.

C++
#define NStringReplace N_FUNC_AW(NStringReplace)
Container

File: NString.h

Module: NString Unit


NStringReplaceChars Macro

NStringReplaceChars Macro
NString.h

Replaces a part of a char array with new values.

C++
#define NStringReplaceChars(hString, arOldValue, oldValueLength, arNewValue, newValueLength, phResultString) NStringReplaceStrOrChars(hString, arOldValue, oldValueLength, arNewValue, newValueLength, phResultString)
Collapse Expand Parameters
Parameters | Description
hString | [in] Handle to the original NString.
arOldValue | [in] Char array representing values to be replaced.
oldValueLength | [in] Length of the old value array.
arNewValue | [in] Char array representing replacement values.
newValueLength | [in] Length of the new value array.
phResultString | [out] Pointer to a handle to the modified NString.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringReplaceStr Macro

NStringReplaceStr Macro
NString.h

Replaces a part of a string with new values.

C++
#define NStringReplaceStr(hString, szOldValue, szNewValue, phResultString) NStringReplaceStrOrChars(hString, szOldValue, -1, szNewValue, -1, phResultString)
Collapse Expand Parameters
Parameters | Description
hString | [in] Handle to the original NString.
arOldValue | [in] Char array representing values to be replaced.
oldValueLength | [in] Length of the old value array.
arNewValue | [in] Char array representing replacement values.
newValueLength | [in] Length of the new value array.
phResultString | [out] Pointer to a handle to the modified NString.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringReplaceStrOrChars Macro

NStringReplaceStrOrChars Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringReplaceStrOrChars function.

C++
#define NStringReplaceStrOrChars N_FUNC_AW(NStringReplaceStrOrChars)
Container

File: NString.h

Module: NString Unit


NStringSplit Macro

NStringSplit Macro
NString.h

Returns a string array that contains the substrings that are delimited by elements of a specified character array.

C++
#define NStringSplit(hString, arSeparators, separatorCount, removeEmptyEntries, parhValues, pValueCount) NStringSplitWithCount(hString, arSeparators, separatorCount, N_INT_MAX, removeEmptyEntries, parhValues, pValueCount)
Collapse Expand Parameters
Parameters | Description
hString | [in] Handle to NString.
arSeparators | [in] An array of characters that delimit the substrings in hString.
separatorCount | [in] Separators count in arSeparators.
removeEmptyEntries | [in] NTrue - empty array elements from the array returned are omitted; NFalse - empty array elements in the array returned are included.
parhValues | [out] An array whose elements contain the substrings in hString that are delimited by one or more chars in separator.
pValueCount | [out] parhValues array size.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringSplitWithCount Macro

NStringSplitWithCount Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringSplitWithCount function.

C++
#define NStringSplitWithCount N_FUNC_AW(NStringSplitWithCount)
Container

File: NString.h

Module: NString Unit


NStringSplitWithStrs Macro

NStringSplitWithStrs Macro
NString.h

Returns a string array that contains the substrings that are delimited by elements of a specified character array.

C++
#define NStringSplitWithStrs(hString, arszSeparators, separatorCount, removeEmptyEntries, parhValues, pValueCount) NStringSplitWithStrsAndCount(hString, arszSeparators, separatorCount, N_INT_MAX, removeEmptyEntries, parhValues, pValueCount)
Collapse Expand Parameters
Parameters | Description
hString | [in] Handle to NString.
arszSeparators | [in] A pointer to an array of characters that delimit the substrings in hString.
separatorCount | [in] Separators count in arszSeparators.
removeEmptyEntries | [in] NTrue - empty array elements from the array returned are omitted; NFalse - empty array elements in the array returned are included.
parhValues | [out] An array whose elements contain the substrings in hString that are delimited by one or more chars in separator.
pValueCount | [out] parhValues array size.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringSplitWithStrsAndCount Macro

NStringSplitWithStrsAndCount Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringSplitWithStrsAndCount function.

C++
#define NStringSplitWithStrsAndCount N_FUNC_AW(NStringSplitWithStrsAndCount)
Container

File: NString.h

Module: NString Unit


NStringSplitWithStrsN Macro

NStringSplitWithStrsN Macro
NString.h

Returns a string array that contains the substrings that are delimited by elements of a specified string array.

C++
#define NStringSplitWithStrsN(hString, arhSeparators, separatorCount, removeEmptyEntries, parhValues, pValueCount) NStringSplitWithStrsAndCountN(hString, arhSeparators, separatorCount, N_INT_MAX, removeEmptyEntries, parhValues, pValueCount)
Collapse Expand Parameters
Parameters | Description
hString | [in] Handle to NString.
arhSeparators | [in] A pointer to an array of string handles that delimit the substrings in hString.
separatorCount | [in] Separators count in arhSeparators.
removeEmptyEntries | [in] NTrue - empty array elements from the array returned are omitted; NFalse - empty array elements in the array returned are included.
parhValues | [out] An array whose elements contain the substrings in hString that are delimited by one or more chars in separator.
pValueCount | [out] parhValues array size.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringStartsWith Macro

NStringStartsWith Macro
NString.h

Checks whether the beginning of hString matches the specified string.

C++
#define NStringStartsWith(hString, szValue, ignoreCase, pResult) NStringStartsWithStrOrChars(hString, szValue, -1, ignoreCase, pResult)
Collapse Expand Parameters
Parameters | Description
hString | [in] Handle to NString.
szValue | [in] Pointer to a string to compare.
ignoreCase | [in] If NTrue strings comparison is not case sensitive.
pResult | [out] Check result.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringStartsWithChars Macro

NStringStartsWithChars Macro
NString.h

Checks whether the beginning of hString matches the specified charset.

C++
#define NStringStartsWithChars(hString, arValue, valueLength, ignoreCase, pResult) NStringStartsWithStrOrChars(hString, arValue, valueLength, ignoreCase, pResult)
Collapse Expand Parameters
Parameters | Description
hString | [in] Handle to NString.
arValue | [in] Pointer to a char array to compare.
valueLength | [in] Length of arValue.
ignoreCase | [in] If NTrue strings comparison is not case sensitive.
pResult | [out] Check result.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringStartsWithStrOrChars Macro

NStringStartsWithStrOrChars Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringStartsWithStrOrChars function.

C++
#define NStringStartsWithStrOrChars N_FUNC_AW(NStringStartsWithStrOrChars)
Container

File: NString.h

Module: NString Unit


NStringSubstring Macro

NStringSubstring Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringSubstring function.

C++
#define NStringSubstring N_FUNC_AW(NStringSubstring)
Container

File: NString.h

Module: NString Unit


NStringSubstringFrom Macro

NStringSubstringFrom Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringSubstringFrom function.

C++
#define NStringSubstringFrom N_FUNC_AW(NStringSubstringFrom)
Container

File: NString.h

Module: NString Unit


NStringToCharArray Macro

NStringToCharArray Macro
NString.h

Converts a string to character array.

C++
#define NStringToCharArray(hString, parValue, pLength) NStringToStrOrCharArray(hString, NFalse, parValue, pLength)
Collapse Expand Parameters
Parameters | Description
hString | [in] Handle to NString.
parValue | [out] Pointer to a pointer to the resulting char array.
pLength | [out] Pointer to the length of the resulting char array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringToCharArrayRange Macro

NStringToCharArrayRange Macro
NString.h

Converts a string to a part of character array.

C++
#define NStringToCharArrayRange(hString, startIndex, length, parValue, pLength) NStringToStrOrCharArrayRange(hString, NFalse, startIndex, length, parValue, pLength)
Collapse Expand Parameters
Parameters | Description
hString | [in] Handle to NString.
nullTerminate | [in] NTrue if null values are to be terminated; else NFalse.
startIndex | [in] Starting index in the array, at which the converted characters are being inserted.
length | [in] Length of the range into which the converted characters are being inserted.
parValue | [out] Pointer to a pointer to the resulting char array.
pLength | [out] Pointer to the length of the resulting char array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringToNewString Macro

NStringToNewString Macro
NString.h

Converts a string to another string.

C++
#define NStringToNewString(hString, pszValue, pLength) NStringToStrOrCharArray(hString, NTrue, pszValue, pLength)
Collapse Expand Parameters
Parameters | Description
hString | [in] Handle to NString.
pszValues | [out] Pointer to a pointer to the resulting string.
pLength | [out] Pointer to the length of the resulting string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringToNewStringRange Macro

NStringToNewStringRange Macro
NString.h

Converts a string to another string or a part of character array.

C++
#define NStringToNewStringRange(hString, startIndex, length, pszValue, pLength) NStringToStrOrCharArrayRange(hString, NTrue, startIndex, length, pszValue, pLength)
Collapse Expand Parameters
Parameters | Description
hString | [in] Handle to NString.
startIndex | [in] Starting index in the string, at which the converted characters are being inserted.
length | [in] Length of the range into which the converted characters are being inserted.
pszValues | [out] Pointer to a pointer to the resulting string.
pLength | [out] Pointer to the length of the resulting string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NString.h

Module: NString Unit


NStringToStrOrCharArray Macro

NStringToStrOrCharArray Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringToStrOrCharArray function.

C++
#define NStringToStrOrCharArray N_FUNC_AW(NStringToStrOrCharArray)
Container

File: NString.h

Module: NString Unit


NStringToStrOrCharArrayRange Macro

NStringToStrOrCharArrayRange Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringToStrOrCharArrayRange function.

C++
#define NStringToStrOrCharArrayRange N_FUNC_AW(NStringToStrOrCharArrayRange)
Container

File: NString.h

Module: NString Unit


NStringToString Macro

NStringToString Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringToString function.

C++
#define NStringToString N_FUNC_AW(NStringToString)
Container

File: NString.h

Module: NString Unit


NStringTrimAny Macro

NStringTrimAny Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringTrimAny function.

C++
#define NStringTrimAny N_FUNC_AW(NStringTrimAny)
Container

File: NString.h

Module: NString Unit


NStringTrimEndAny Macro

NStringTrimEndAny Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringTrimEndAny function.

C++
#define NStringTrimEndAny N_FUNC_AW(NStringTrimEndAny)
Container

File: NString.h

Module: NString Unit


NStringTrimStartAny Macro

NStringTrimStartAny Macro
NString.h

Picks a Unicode (W) or ASCII (A) version of the NStringTrimStartAny function.

C++
#define NStringTrimStartAny N_FUNC_AW(NStringTrimStartAny)
Container

File: NString.h

Module: NString Unit


N_STRING_SIZE Macro

N_STRING_SIZE Macro
NString.h

Defines the string size.

C++
#define N_STRING_SIZE 24
Container

File: NString.h

Module: NString Unit


NString.h

NString.h
Functions Legend Macros

Header file for the NString unit.

Collapse Expand Functions
Name | Description
NStringAppendStrOrChars | Extends specified string content by adding an additional string or chars at its end.
NStringClone | Clones specified NString.
NStringCompareRangeNA | Compares substrings of the two specified strings and retrieves their relative position in the sort order.
NStringCompareRangeNW | Compares substrings of the two specified strings and retrieves their relative position in the sort order.
NStringCompareRangeStrOrCharsA | Compares substrings of a string and a string or a charset and retrieves their relative position in the sort order.
NStringCompareRangeStrOrCharsW | Compares substrings of a string and a string or a charset and retrieves their relative position in the sort order.
NStringConcatArray | Concatenates specified string.
NStringConcatMany | Concatenates specified strings.
NStringConcatManyVA | Concatenates specified strings.
NStringConcatN | Concatenates strings specified by handles.
NStringConcatStrOrChars | Concatenates strings or charsets specified by handles.
NStringContainsStrN | Checks whether specified string occurs within other string.
NStringContainsStrOrChars | Returns a value indicating whether specified chars or string occurs within string specified by handle.
NStringCopyToStrOrChars | Copies a specified number of characters from a specified position in handle to a specified array.
NStringCreateFromChar | Creates string from specified character.
NStringCreateFromStrOrChars | Creates string from specified array of characters.
NStringCreateWrapper | Creates a new string handle based on the specified string.
NStringEndsWithN | Checks whether the end of the string matches the specified string.
NStringEndsWithStrOrCharsA | Checks whether the end of the string matches the specified string or charset.
NStringEndsWithStrOrCharsW | Checks whether the end of the string matches the specified string or charset.
NStringEqualsN | Checks whether two specified strings have the same value.
NStringEqualsStrOrCharsA | Checks whether two specified strings or charsets have the same value.
NStringEqualsStrOrCharsW | Checks whether two specified strings or charsets have the same value.
NStringFormat | Returns a string representing the specified format and parameters.
NStringFormatVA | Returns a string representing the specified format and arguments.
NStringFree | Deletes the string specified by handle. After the string is deleted the specified handle is no longer valid.
NStringFreeArray | Deletes array of strings specified by handles. After the strings is deleted the specified object handles are no longer valid.
NStringFreeElements | ... more
NStringGetBuffer | Gets characters buffer (string) from specified handle to NString.
NStringGetConcurrent | Retrieves the string concurrent to the specified string.
NStringGetElements | Retrieves the elements of the specified string array.
NStringGetEmpty | Gets empty string.
NStringGetHashCode | Gets the hash code
NStringGetLength | Gets length of specified string.
NStringHasEmbeddedNull | Checked whether the specified string has an embedded null value.
NStringIndexOf | Returns the zero-based index of the first occurrence of the specified character in the string.
NStringIndexOfAny | ... more
NStringIndexOfAnyFrom | ... more
NStringIndexOfAnyInRange | ... more
NStringIndexOfFrom | Returns the zero-based index of the first occurrence of the specified character in the string starting from specified index.
NStringIndexOfInRange | ... more
NStringIndexOfStrFromN | ... more
NStringIndexOfStrInRangeN | ... more
NStringIndexOfStrN | Returns the zero-based index of the first occurrence of the specified NString in the string.
NStringIndexOfStrOrChars | Returns the zero-based index of the first occurrence of the specified string or character in the string.
NStringIndexOfStrOrCharsFrom | Returns the zero-based index of the first occurrence of the specified string or character in the string.
NStringIndexOfStrOrCharsInRange | Returns the zero-based index of the first occurrence of the specified string or character in the string.
NStringInsertN | Returns a new string in which a specified string is inserted at a specified index position.
NStringInsertStrOrChars | Returns a new string in which a specified string or characters is inserted at a specified index position.
NStringIsA | Checks whether specified string contains ANSI characters.
NStringIsEmpty | Checks whether specified string is empty string.
NStringIsW | Checks whether specified string contains Unicode characters.
NStringIsWhiteSpace | Checks whether specified string consists only of white-space characters.
NStringJoinArray | Concatenates all the elements of a string array, using the specified separator between each element.
NStringJoinArrayVN | Concatenates all the elements of a string array, using the specified separator between each element.
NStringJoinMany | Concatenates all the elements of a string arrays, using the specified separator between each element.
NStringJoinManyVA | Concatenates all the elements of a string arrays, using the specified separator between each element.
NStringJoinManyVAVN | Concatenates all the elements of a string arrays, using the specified separator between each element.
NStringJoinManyVN | Concatenates all the elements of a string arrays, using the specified separator between each element.
NStringLastIndexOf | Returns the zero-based index position of the last occurrence of a specified character within string.
NStringLastIndexOfAny | ... more
NStringLastIndexOfAnyFrom | ... more
NStringLastIndexOfAnyInRange | ... more
NStringLastIndexOfFrom | ... more
NStringLastIndexOfInRange | ... more
NStringLastIndexOfStrFromN | ... more
NStringLastIndexOfStrInRangeN | Returns the zero-based index of the last occurrence of the specified string in the NString in specified range.
NStringLastIndexOfStrN | Returns the zero-based index of the last occurrence of the specified NString in the string.
NStringLastIndexOfStrOrChars | Returns the zero-based index of the last occurrence of the specified string or character in the string.
NStringLastIndexOfStrOrCharsFrom | Returns the zero-based index of the last occurrence of the specified string or character in the string.
NStringLastIndexOfStrOrCharsInRange | Returns the zero-based index of the last occurrence of the specified string or character in the string.
NStringPadLeft | ... more
NStringPadLeftWith | ... more
NStringPadRight | ... more
NStringPadRightWith | ... more
NStringPrependStrOrChars | Prepends a string or a charset to another string.
NStringPromoteBuffer | Creates a new NString which takes ownership of the memory buffer.
NStringRemove | ... more
NStringRemoveFrom | ... more
NStringReplace | ... more
NStringReplaceStrOrChars | Replaces a part of a string or a char array with new values.
NStringSet | Sets the value of the specified string.
NStringSplitWithCount | ... more
NStringSplitWithStrsAndCount | Returns a string array that contains the substrings that are delimited by elements of a specified character array. A parameter specifies the maximum number of substrings to return.
NStringSplitWithStrsAndCountN | Returns a string array that contains the substrings that are delimited by elements of a specified string array. A parameter specifies the maximum number of substrings to return.
NStringStartsWithN | ... more
NStringStartsWithStrOrCharsA | Checks whether the beginning of hString matches the specified string or chars.
NStringStartsWithStrOrCharsW | Checks whether the beginning of hString matches the specified string or chars.
NStringSubstring | Gets a substring from hString. The substring starts at a specified character position.
NStringSubstringFrom | Gets a substring from hString. The substring starts at a specified character position.
NStringToLower | Converts specified string to lowercase.
NStringToStrOrCharArray | Converts a string to another string or a character array.
NStringToStrOrCharArrayRange | Converts a string to another string or a part of character array.
NStringToString | Converts the specified string to another string with specified format.
NStringToUpper | Converts specified string to uppercase.
NStringTrim | Removes all leading and trailing white-space characters from specified string.
NStringTrimAny | Removes all leading and trailing occurrences of a sets of characters from specified string.
NStringTrimEnd | Removes all trailing characters from hString.
NStringTrimEndAny | Removes all trailing occurrences of a set of characters specified in an array from hString.
NStringTrimStart | Removes all trailing characters from hString.
NStringTrimStartAny | Removes all leading occurrences of a set of characters specified in an array from hString.
Collapse Expand Macros
Name | Description
NStringAppend | Extends specified string content by adding an additional string at its end.
NStringAppendChars | Extends specified string content by adding additional chars at its end.
NStringAppendStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringAppendStrOrChars function.
NStringCompare | Compares two strings and retrieves their relative position in the sort order.
NStringCompareChars | Compares a string with a char array and retrieves their relative position in the sort order.
NStringCompareN | Compares two strings and retrieves their relative position in the sort order.
NStringCompareRange | Compares substrings of the two specified strings and retrieves their relative position in the sort order.
NStringCompareRangeChars | Compares substrings of a string and a charset and retrieves their relative position in the sort order.
NStringCompareRangeN | Picks a Unicode (W) or ASCII (A) version of the NStringCompareRangeN function.
NStringCompareRangeStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringCompareRangeStrOrChars function.
NStringCompareStrOrChars | Compares a string with a string or char array and retrieves their relative position in the sort order.
NStringConcat | Concatenates strings specified by handles.
NStringConcatChars | Concatenates charsets specified by handles.
NStringConcatMany | Picks a Unicode (W) or ASCII (A) version of the NStringConcatMany function.
NStringConcatManyVA | Picks a Unicode (W) or ASCII (A) version of the NStringConcatManyVA function.
NStringConcatStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringConcatStrOrChars function.
NStringContainsChars | Returns a value indicating whether specified chars occur within string specified by handle.
NStringContainsStr | Returns a value indicating whether specified string occurs within string specified by handle.
NStringContainsStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringContainsStrOrChars function.
NStringCopyTo | Copies a specified number of characters from a specified position in handle to a specified array.
NStringCopyToStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringCopyToStrOrChars function.
NStringCopyToString | Copies a specified number of characters from a specified position in handle to a specified string.
NStringCreate | Creates a string with the specified value.
NStringCreateFromChar | Picks a Unicode (W) or ASCII (A) version of the NStringCreateFromChar function.
NStringCreateFromChars | Creates a string from the specified array of characters.
NStringCreateFromStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringCreateFromStrOrChars function.
NStringCreateWrapper | Picks a Unicode (W) or ASCII (A) version of the NStringCreateWrapper function.
NStringEndsWith | Checks whether the end of the string matches the specified string.
NStringEndsWithChars | Checks whether the end of the string matches the specified string or charset.
NStringEndsWithStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringEndsWithStrOrChars function.
NStringEquals | Checks whether two specified stings have the same value.
NStringEqualsChars | Checks whether the specified string and the specified charset have the same value.
NStringEqualsStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringEqualsStrOrChars function.
NStringFormat | Picks a Unicode (W) or ASCII (A) version of the NStringFormat function.
NStringFormatVA | Picks a Unicode (W) or ASCII (A) version of the NStringFormatVA function.
NStringGetBuffer | Picks a Unicode (W) or ASCII (A) version of the NStringGetBuffer function.
NStringGetChar | Picks a Unicode (W) or ASCII (A) version of the NStringGetChar function.
NStringGetLength | Picks a Unicode (W) or ASCII (A) version of the NStringGetLength function.
NStringIndexOf | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOf function.
NStringIndexOfAny | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfAny function.
NStringIndexOfAnyFrom | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfAnyFrom function.
NStringIndexOfAnyInRange | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfAnyInRange function.
NStringIndexOfChars | Returns the zero-based index of the first occurrence of the specified character in the string.
NStringIndexOfCharsFrom | Returns the zero-based index of the first occurrence of the specified character in the string.
NStringIndexOfCharsInRange | Returns the zero-based index of the first occurrence of the specified character in the string.
NStringIndexOfFrom | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfFrom function.
NStringIndexOfInRange | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfInRange function.
NStringIndexOfStr | Returns the zero-based index of the first occurrence of the specified string in the string.
NStringIndexOfStrFrom | Returns the zero-based index of the first occurrence of the specified string in the string.
NStringIndexOfStrFromN | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfStrFromN function.
NStringIndexOfStrInRange | Returns the zero-based index of the first occurrence of the specified string in the string.
NStringIndexOfStrInRangeN | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfStrInRangeN function.
NStringIndexOfStrN | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfStrN function.
NStringIndexOfStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfStrOrChars function.
NStringIndexOfStrOrCharsFrom | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfStrOrCharsFrom function.
NStringIndexOfStrOrCharsInRange | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfStrOrCharsInRange function.
NStringInsert | Returns a new string in which a specified string is inserted at a specified index position.
NStringInsertChars | Returns a new string in which a specified characters are inserted at a specified index position.
NStringInsertN | Picks a Unicode (W) or ASCII (A) version of the NStringInsertN function.
NStringInsertStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringInsertStrOrChars function.
NStringJoinArray | Picks a Unicode (W) or ASCII (A) version of the NStringJoinArray function.
NStringJoinArrayVN | Picks a Unicode (W) or ASCII (A) version of the NStringJoinArrayVN function.
NStringJoinMany | Picks a Unicode (W) or ASCII (A) version of the NStringJoinMany function.
NStringJoinManyVAVN | Picks a Unicode (W) or ASCII (A) version of the NStringJoinManyVAVN function.
NStringJoinManyVN | Picks a Unicode (W) or ASCII (A) version of the NStringJoinManyVN function.
NStringLastIndexOf | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOf function.
NStringLastIndexOfAny | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfAny function.
NStringLastIndexOfAnyFrom | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfAnyFrom function.
NStringLastIndexOfAnyInRange | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfAnyInRange function.
NStringLastIndexOfChars | Returns the zero-based index of the last occurrence of the specified character in the string.
NStringLastIndexOfCharsFrom | Returns the zero-based index of the last occurrence of the specified character in the string.
NStringLastIndexOfCharsInRange | Returns the zero-based index of the last occurrence of the specified character in the string.
NStringLastIndexOfFrom | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfFrom function.
NStringLastIndexOfInRange | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfInRange function.
NStringLastIndexOfStr | Returns the zero-based index of the last occurrence of the specified string in the string.
NStringLastIndexOfStrFrom | Returns the zero-based index of the last occurrence of the specified string in the string.
NStringLastIndexOfStrFromN | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfStrFromN function.
NStringLastIndexOfStrInRange | Returns the zero-based index of the last occurrence of the specified string in the string.
NStringLastIndexOfStrInRangeN | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfStrInRangeN function.
NStringLastIndexOfStrN | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfStrN function.
NStringLastIndexOfStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfStrOrChars function.
NStringLastIndexOfStrOrCharsFrom | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfStrOrCharsFrom function.
NStringLastIndexOfStrOrCharsInRange | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfStrOrCharsInRange function.
NStringPadLeft | Picks a Unicode (W) or ASCII (A) version of the NStringPadLeft function.
NStringPadLeftWith | Picks a Unicode (W) or ASCII (A) version of the NStringPadLeftWith function.
NStringPadRight | Picks a Unicode (W) or ASCII (A) version of the NStringPadRight function.
NStringPadRightWith | Picks a Unicode (W) or ASCII (A) version of the NStringPadRightWith function.
NStringPrepend | Prepends a string to another string.
NStringPrependChars | Prepends a charset to another string.
NStringPrependStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringPrependStrOrChars function.
NStringPromoteBuffer | Picks a Unicode (W) or ASCII (A) version of the NStringPromoteBuffer function.
NStringRemove | Picks a Unicode (W) or ASCII (A) version of the NStringRemove function.
NStringRemoveFrom | Picks a Unicode (W) or ASCII (A) version of the NStringRemoveFrom function.
NStringReplace | Picks a Unicode (W) or ASCII (A) version of the NStringReplace function.
NStringReplaceChars | Replaces a part of a char array with new values.
NStringReplaceStr | Replaces a part of a string with new values.
NStringReplaceStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringReplaceStrOrChars function.
NStringSplit | ... more
NStringSplitWithCount | Picks a Unicode (W) or ASCII (A) version of the NStringSplitWithCount function.
NStringSplitWithStrs | Returns a string array that contains the substrings that are delimited by elements of a specified character array.
NStringSplitWithStrsAndCount | Picks a Unicode (W) or ASCII (A) version of the NStringSplitWithStrsAndCount function.
NStringSplitWithStrsN | Returns a string array that contains the substrings that are delimited by elements of a specified string array.
NStringStartsWith | Checks whether the beginning of hString matches the specified string.
NStringStartsWithChars | Checks whether the beginning of hString matches the specified charset.
NStringStartsWithStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringStartsWithStrOrChars function.
NStringSubstring | Picks a Unicode (W) or ASCII (A) version of the NStringSubstring function.
NStringSubstringFrom | Picks a Unicode (W) or ASCII (A) version of the NStringSubstringFrom function.
NStringToCharArray | Converts a string to character array.
NStringToCharArrayRange | Converts a string to a part of character array.
NStringToNewString | Converts a string to another string.
NStringToNewStringRange | Converts a string to another string or a part of character array.
NStringToStrOrCharArray | Picks a Unicode (W) or ASCII (A) version of the NStringToStrOrCharArray function.
NStringToStrOrCharArrayRange | Picks a Unicode (W) or ASCII (A) version of the NStringToStrOrCharArrayRange function.
NStringToString | Picks a Unicode (W) or ASCII (A) version of the NStringToString function.
NStringTrimAny | Picks a Unicode (W) or ASCII (A) version of the NStringTrimAny function.
NStringTrimEndAny | Picks a Unicode (W) or ASCII (A) version of the NStringTrimEndAny function.
NStringTrimStartAny | Picks a Unicode (W) or ASCII (A) version of the NStringTrimStartAny function.
N_STRING_SIZE | Defines the string size.


NStringBuilder Unit

NStringBuilder Unit
Functions Legend Macros

Represents a mutable string of characters.

Collapse Expand Functions
Name | Description
NStringBuilderAppend | Appends a the copy of the specified string to the specified string builder.
NStringBuilderAppendBoolean | Appends a the string representation of specified Boolean value to the specified string builder.
NStringBuilderAppendByte | Appends a the string representation of specified unsigned byte integer to the specified string builder.
NStringBuilderAppendChar | Appends a the string representation of specified char to the specified string builder.
NStringBuilderAppendCharRepeat | Appends a the string representation of specified char to the specified string builder a set amount of times.
NStringBuilderAppendChars | Appends a the string representation of specified char arry to the specified string builder.
NStringBuilderAppendDouble | Appends a the string representation of specified double integer to the specified string builder.
NStringBuilderAppendEmptyLine | Appends the default line terminator to the end of the specified NStringBuilder object.
NStringBuilderAppendFormat | Appends a format string with specified parameters to the specified string builder.
NStringBuilderAppendFormatN | Appends a format string with specified parameters to the specified string builder.
NStringBuilderAppendFormatVA | Appends a format string with specified arguments to the specified string builder.
NStringBuilderAppendFormatVAN | Appends a format string with specified arguments to the specified string builder.
NStringBuilderAppendInt16 | Appends a the string representation of specified short integer to the specified string builder.
NStringBuilderAppendInt32 | Appends a the string representation of specified integer to the specified string builder.
NStringBuilderAppendInt64 | Appends a the string representation of specified long integer to the specified string builder.
NStringBuilderAppendLine | Appends a the copy of the specified string followed by the default line terminator to the end of the specified string builder.
NStringBuilderAppendLineN | Appends a the copy of the specified string followed by the default line terminator to the end of the specified string builder.
NStringBuilderAppendN | Appends a the copy of the specified string to the specified string builder.
NStringBuilderAppendObject | Appends a the string representation of specified object to the specified string builder.
NStringBuilderAppendPointer | Appends a the string representation of specified pointer to the specified string builder.
NStringBuilderAppendResult | Appends a string representation of a NResult value to the specified string builder.
NStringBuilderAppendSByte | Appends a the string representation of specified integer to the specified string builder.
NStringBuilderAppendSSizeType | Appends a the string representation of specified SSizeType to the specified string builder.
NStringBuilderAppendSingle | Appends a the string representation of specified floating point number to the specified string builder.
NStringBuilderAppendSizeType | Appends a the string representation of specified SizeType to the specified string builder.
NStringBuilderAppendUInt16 | Appends a the string representation of specified unsigned short integer to the specified string builder.
NStringBuilderAppendUInt32 | Appends a the string representation of specified unsigned integer to the specified string builder.
NStringBuilderAppendUInt64 | Appends a the string representation of specified unsigned long integer to the specified string builder.
NStringBuilderAppendValue | Appends a string representation of a value of specified type to the specified string builder.
NStringBuilderAppendValueP | Appends a the string representation of specified value to the specified string builder.
NStringBuilderClear | Removes all characters from the specified NStringBuilder.
NStringBuilderCopyToStrOrChars | Copies the characters from a specified segment of the NStringBuilder to a specified segment of a destination Char array.
NStringBuilderDetachStrOrChars | Detaches a string or a char array from the NStringBuilder.
NStringBuilderDetachStringN | Detaches a string from the NStringBuilder.
NStringBuilderDispose | Releases the unused resources of the specified NStringBuilder.
NStringBuilderGetCapacity | Gets the capacity of the specified NStringBuilder.
NStringBuilderGetChar | Gets the character at the specified position in the specified NStringBuilder.
NStringBuilderGetLength | Gets the length of the specified NStringBuilder.
NStringBuilderGetStrOrCharsBuffer | Gets the string or character array buffer of the specified NStringBuilder.
NStringBuilderGetStringWrapper | Gets the string wrapper of the specified NStringBuilder.
NStringBuilderInit | Creates a new NStringBuilder.
NStringBuilderInitEx | Creates a new NStringBuilder with specified capacity, maximum capacity and growth delta.
NStringBuilderInitWithCapacity | Creates a new NStringBuilder using the specified capacity.
NStringBuilderInitWithStrOrChars | Creates a new NStringBuilder using the specified string or char array.
NStringBuilderInitWithStringN | Creates a new NStringBuilder using the specified string.
NStringBuilderInsert | Inserts a string into the specified NStringBuilder at the specified character position.
NStringBuilderInsertBoolean |
NStringBuilderInsertByte | Inserts a string representation of the specified unsigned byte integer into the specified NStringBuilder at the specified character position.
NStringBuilderInsertChar | Inserts a string representation of the specified char into the specified NStringBuilder at the specified character position.
NStringBuilderInsertChars | Inserts a string representation of the specified char array into the specified NStringBuilder at the specified character position.
NStringBuilderInsertDouble | Inserts a string representation of the specified double integer into the specified NStringBuilder at the specified character position.
NStringBuilderInsertInt16 | Inserts a string representation of the specified short integer into the specified NStringBuilder at the specified character position.
NStringBuilderInsertInt32 | Inserts a string representation of the specified integer into the specified NStringBuilder at the specified character position.
NStringBuilderInsertInt64 | Inserts a string representation of the specified long integer into the specified NStringBuilder at the specified character position.
NStringBuilderInsertN | Inserts a string into the specified NStringBuilder at the specified character position.
NStringBuilderInsertObject | Inserts a string representation of the specified object into the specified NStringBuilder at the specified character position.
NStringBuilderInsertPointer | Inserts a string representation of the specified pointer into the specified NStringBuilder at the specified character position.
NStringBuilderInsertResult | Inserts a string representation of a NResult value into the specified NStringBuilder at the specified character position.
NStringBuilderInsertSByte | Inserts a string representation of the specified byte integer into the specified NStringBuilder at the specified character position.
NStringBuilderInsertSSizeType | Inserts a string representation of the specified SSizeType into the specified NStringBuilder at the specified character position.
NStringBuilderInsertSingle | Inserts a string representation of the specified floating point number into the specified NStringBuilder at the specified character position.
NStringBuilderInsertSizeType | Inserts a string representation of the specified SizeType into the specified NStringBuilder at the specified character position.
NStringBuilderInsertUInt16 | Inserts a string representation of the specified unsigned short integer into the specified NStringBuilder at the specified character position.
NStringBuilderInsertUInt32 | Inserts a string representation of the specified unsigned integer into the specified NStringBuilder at the specified character position.
NStringBuilderInsertUInt64 | Inserts a string representation of the specified long integer into the specified NStringBuilder at the specified character position.
NStringBuilderInsertValue | Inserts a string representation of a value of specified type into the specified NStringBuilder at the specified character position.
NStringBuilderInsertValueP | Inserts a string representation of the specified value into the specified NStringBuilder at the specified character position.
NStringBuilderRemove | Removes the specified range of characters from the specified NStringBuilder.
NStringBuilderReplace | Replaces all occurrences of a specified character in the specified NStringBuilder with another specified character.
NStringBuilderReplaceInRange | Replaces, within a substring of the specified NStringBuilder, all occurrences of a specified character with another specified character.
NStringBuilderReplaceStrOrChars | Replaces all occurrences of a specified string or char array in the specified NStringBuilder with another specified string or char array.
NStringBuilderReplaceStrOrCharsInRange | Replaces, within a substring of the specified NStringBuilder, all occurrences of a specified string or char array with another specified string or char array.
NStringBuilderReplaceStringInRangeN | Replaces, within a substring of the specified NStringBuilder, all occurrences of a specified string with another specified string.
NStringBuilderReplaceStringN | Replaces all occurrences of a specified string in the specified NStringBuilder with another specified character.
NStringBuilderSetCapacity | Sets the capacity of the specified NStringBuilder.
NStringBuilderSetChar | Sets the value of the character at the specified position in the specified NStringBuilder.
NStringBuilderSetLength | Sets the length of the specified NStringBuilder.
NStringBuilderToString | Converts the specified NStringBuilder to a string.
NStringBuilderToStringRange | Converts the specified NStringBuilder to a string range.
Collapse Expand Macros
Name | Description
NStringBuilderAppend | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppend function.
NStringBuilderAppendBoolean | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendBoolean function.
NStringBuilderAppendByte | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendByte function.
NStringBuilderAppendChar | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendChar function.
NStringBuilderAppendCharRepeat | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendCharRepeat function.
NStringBuilderAppendChars | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendChars function.
NStringBuilderAppendDouble | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendDouble function.
NStringBuilderAppendEmptyLine | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendEmptyLine function.
NStringBuilderAppendFormat | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendFormat function.
NStringBuilderAppendFormatN | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendFormatN function.
NStringBuilderAppendFormatVA | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendFormatVA function.
NStringBuilderAppendFormatVAN | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendFormatVAN function.
NStringBuilderAppendInt16 | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendInt16 function.
NStringBuilderAppendInt32 | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendInt32 function.
NStringBuilderAppendInt64 | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendInt64 function.
NStringBuilderAppendLine | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendLine function.
NStringBuilderAppendLineN | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendLineN function.
NStringBuilderAppendN | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendN function.
NStringBuilderAppendObject | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendObject function.
NStringBuilderAppendPointer | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendPointer function.
NStringBuilderAppendResult | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendResult function.
NStringBuilderAppendSByte | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendSByte function.
NStringBuilderAppendSSizeType | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendSSizeType function.
NStringBuilderAppendSingle | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendSingle function.
NStringBuilderAppendSizeType | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendSizeType function.
NStringBuilderAppendUInt16 | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendUInt16 function.
NStringBuilderAppendUInt32 | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendUInt32 function.
NStringBuilderAppendUInt64 | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendUInt64 function.
NStringBuilderAppendValue | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendValue function.
NStringBuilderAppendValueP | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendValueP function.
NStringBuilderClear | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderClear function.
NStringBuilderCopyTo | Copies the characters from a specified segment of the NStringBuilder to a specified segment of a destination Char array.
NStringBuilderCopyToStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringCopyToStrOrChars function.
NStringBuilderCopyToString | Copies the characters from a specified segment of the NStringBuilder to a specified segment of a destination string.
NStringBuilderDetachCharArray | Detaches a char array from the NStringBuilder.
NStringBuilderDetachStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderDetachStrOrChars function.
NStringBuilderDetachString | Detaches a string from the NStringBuilder.
NStringBuilderDispose | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderDispose function.
NStringBuilderGetBuffer | Gets the string buffer of the specified NStringBuilder.
NStringBuilderGetCapacity | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderGetCapacity function.
NStringBuilderGetChar | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderGetChar function.
NStringBuilderGetCharsBuffer | Gets the character array buffer of the specified NStringBuilder.
NStringBuilderGetLength | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderGetLength function.
NStringBuilderGetStrOrCharsBuffer | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderGetStrOrCharsBuffer function.
NStringBuilderGetStringWrapper | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderGetStringWrapper function.
NStringBuilderInit | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInit function.
NStringBuilderInitEx | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInitEx function.
NStringBuilderInitWithCapacity | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInitWithCapacity function.
NStringBuilderInitWithChars | Creates a new NStringBuilder using the specified char array.
NStringBuilderInitWithStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInitWithStrOrChars function.
NStringBuilderInitWithString | Creates a new NStringBuilder using the specified string.
NStringBuilderInitWithStringN | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInitWithStringN function.
NStringBuilderInsert | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsert function.
NStringBuilderInsertBoolean | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertBoolean function.
NStringBuilderInsertByte | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertByte function.
NStringBuilderInsertChar | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertChar function.
NStringBuilderInsertChars | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertChars function.
NStringBuilderInsertDouble | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertDouble function.
NStringBuilderInsertInt16 | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertInsertInt16 function.
NStringBuilderInsertInt32 | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertInt32 function.
NStringBuilderInsertInt64 | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertInt64 function.
NStringBuilderInsertN | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertN function.
NStringBuilderInsertObject | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertObject function.
NStringBuilderInsertPointer | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertPointer function.
NStringBuilderInsertResult | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertResult function.
NStringBuilderInsertSByte | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertSByte function.
NStringBuilderInsertSSizeType | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertSSizeType function.
NStringBuilderInsertSingle | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertSingle function.
NStringBuilderInsertSizeType | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertSizeType function.
NStringBuilderInsertUInt16 | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertUInt16 function.
NStringBuilderInsertUInt32 | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertUInt32 function.
NStringBuilderInsertUInt64 | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertUInt64 function.
NStringBuilderInsertValue | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertValue function.
NStringBuilderInsertValueP | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertValueP function.
NStringBuilderRemove | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderRemove function.
NStringBuilderReplace | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderReplace function.
NStringBuilderReplaceChars | Replaces all occurrences of a specified char array in the specified NStringBuilder with another specified char array.
NStringBuilderReplaceCharsInRange | Replaces, within a substring of the specified NStringBuilder, all occurrences of a specified char array with another specified char array.
NStringBuilderReplaceInRange | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderReplaceInRange function.
NStringBuilderReplaceStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderReplaceStrOrChars function.
NStringBuilderReplaceStrOrCharsInRange | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderReplaceStrOrCharsInRange function.
NStringBuilderReplaceString | Replaces all occurrences of a specified string in the specified NStringBuilder with another specified character.
NStringBuilderReplaceStringInRange | Replaces, within a substring of the specified NStringBuilder, all occurrences of a specified string with another specified string.
NStringBuilderReplaceStringN | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderReplaceStringN function.
NStringBuilderSetCapacity | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderSetCapacity function.
NStringBuilderSetChar | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderSetChar function.
NStringBuilderSetLength | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderSetLength function.
NStringBuilderToString | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderToString function.
NStringBuilderToStringRange | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderToStringRange function.
N_STRING_BUILDER_SIZE | Defines the NStringBuilder size.


NStringBuilderAppend Function

NStringBuilderAppend Function

Appends a the copy of the specified string to the specified string builder.

C++
NResult N_API NStringBuilderAppend(NStringBuilder * pStringBuilder, const NChar * szValue);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
const NChar * szValue | [in] Pointer to the string to append.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendBoolean Function

NStringBuilderAppendBoolean Function

Appends a the string representation of specified Boolean value to the specified string builder.

C++
NResult N_API NStringBuilderAppendBoolean(NStringBuilder * pStringBuilder, NBool value);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NBool value | [in] The NBool to append.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendByte Function

NStringBuilderAppendByte Function

Appends a the string representation of specified unsigned byte integer to the specified string builder.

C++
NResult N_API NStringBuilderAppendByte(NStringBuilder * pStringBuilder, NByte value);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NByte value | [in] NByte to append.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendChar Function

NStringBuilderAppendChar Function

Appends a the string representation of specified char to the specified string builder.

C++
NResult N_API NStringBuilderAppendChar(NStringBuilder * pStringBuilder, NChar value);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NChar value | [in] NChar to append.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendCharRepeat Function

NStringBuilderAppendCharRepeat Function

Appends a the string representation of specified char to the specified string builder a set amount of times.

C++
NResult N_API NStringBuilderAppendCharRepeat(NStringBuilder * pStringBuilder, NChar value, NInt repeatCount);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NChar value | [in] NChar to append.
NInt repeatCount | [in] Number of times the NChar must be appended.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendChars Function

NStringBuilderAppendChars Function

Appends a the string representation of specified char arry to the specified string builder.

C++
NResult N_API NStringBuilderAppendChars(NStringBuilder * pStringBuilder, const NChar * arValue, NInt valueLength);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
const NChar * arValue | [in] Pointer to the char array to append.
NInt valueLength | [in] Length of the char array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendDouble Function

NStringBuilderAppendDouble Function

Appends a the string representation of specified double integer to the specified string builder.

C++
NResult N_API NStringBuilderAppendDouble(NStringBuilder * pStringBuilder, NDouble value);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NDouble value | [in] The NDouble to append.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendEmptyLine Function

NStringBuilderAppendEmptyLine Function

Appends the default line terminator to the end of the specified NStringBuilder object.

C++
NResult N_API NStringBuilderAppendEmptyLine(NStringBuilder * pStringBuilder);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendFormat Function

NStringBuilderAppendFormat Function

Appends a format string with specified parameters to the specified string builder.

C++
NResult N_API NStringBuilderAppendFormat(NStringBuilder * pStringBuilder, const NChar * szFormat, ... multipleParameters);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
const NChar * szFormat | [in] Pointer to the composite format string.
... multipleParameters | [in] Format parameters.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendFormatN Function

NStringBuilderAppendFormatN Function

Appends a format string with specified parameters to the specified string builder.

C++
NResult N_API NStringBuilderAppendFormatN(NStringBuilder * pStringBuilder, HNString hFormat, ... multipleParameters);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
HNString hFormat | [in] Handle to the composite format string.
... multipleParameters | [in] Format parameters.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendFormatVA Function

NStringBuilderAppendFormatVA Function

Appends a format string with specified arguments to the specified string builder.

C++
NResult N_API NStringBuilderAppendFormatVA(NStringBuilder * pStringBuilder, const NChar * szFormat, va_list args);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
const NChar * szFormat | [in] Pointer to the composite format string.
va_list args | [in] Format argument list.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendFormatVAN Function

NStringBuilderAppendFormatVAN Function

Appends a format string with specified arguments to the specified string builder.

C++
NResult N_API NStringBuilderAppendFormatVAN(NStringBuilder * pStringBuilder, HNString hFormat, va_list args);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
HNString hFormat | [in] Handle to the composite format string.
va_list args | [in] Format argument list.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendInt16 Function

NStringBuilderAppendInt16 Function

Appends a the string representation of specified short integer to the specified string builder.

C++
NResult N_API NStringBuilderAppendInt16(NStringBuilder * pStringBuilder, NShort value);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NShort value | [in] NShort to append.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendInt32 Function

NStringBuilderAppendInt32 Function

Appends a the string representation of specified integer to the specified string builder.

C++
NResult N_API NStringBuilderAppendInt32(NStringBuilder * pStringBuilder, NInt value);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NInt value | [in] NInt to append.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendInt64 Function

NStringBuilderAppendInt64 Function

Appends a the string representation of specified long integer to the specified string builder.

C++
NResult N_API NStringBuilderAppendInt64(NStringBuilder * pStringBuilder, NLong value);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NLong value | [in] NLong to append.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendLine Function

NStringBuilderAppendLine Function

Appends a the copy of the specified string followed by the default line terminator to the end of the specified string builder.

C++
NResult N_API NStringBuilderAppendLine(NStringBuilder * pStringBuilder, const NChar * szValue);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
const NChar * szValue | [in] Pointer to the string to append.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendLineN Function

NStringBuilderAppendLineN Function

Appends a the copy of the specified string followed by the default line terminator to the end of the specified string builder.

C++
NResult N_API NStringBuilderAppendLineN(NStringBuilder * pStringBuilder, HNString hValue);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
HNString hValue | [in] Handle to the string to append.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendN Function

NStringBuilderAppendN Function

Appends a the copy of the specified string to the specified string builder.

C++
NResult N_API NStringBuilderAppendN(NStringBuilder * pStringBuilder, HNString hValue);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
HNString hValue | [in] Handle to the string to append.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendObject Function

NStringBuilderAppendObject Function

Appends a the string representation of specified object to the specified string builder.

C++
NResult N_API NStringBuilderAppendObject(NStringBuilder * pStringBuilder, HNObject hObject);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
HNObject hObject | [in] Handle to the object to append.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendPointer Function

NStringBuilderAppendPointer Function

Appends a the string representation of specified pointer to the specified string builder.

C++
NResult N_API NStringBuilderAppendPointer(NStringBuilder * pStringBuilder, const void * value);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
const void * value | [in] The pointer to append.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendResult Function

NStringBuilderAppendResult Function

Appends a string representation of a NResult value to the specified string builder.

C++
NResult N_API NStringBuilderAppendResult(NStringBuilder * pStringBuilder, NResult value);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NResult value | [in] The NResult value to be appended.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendSByte Function

NStringBuilderAppendSByte Function

Appends a the string representation of specified integer to the specified string builder.

C++
NResult N_API NStringBuilderAppendSByte(NStringBuilder * pStringBuilder, NSByte value);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NSByte value | [in] NSByte to append.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendSSizeType Function

NStringBuilderAppendSSizeType Function

Appends a the string representation of specified SSizeType to the specified string builder.

C++
NResult N_API NStringBuilderAppendSSizeType(NStringBuilder * pStringBuilder, NSSizeType value);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NSSizeType value | [in] SSizeType to append.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendSingle Function

NStringBuilderAppendSingle Function

Appends a the string representation of specified floating point number to the specified string builder.

C++
NResult N_API NStringBuilderAppendSingle(NStringBuilder * pStringBuilder, NFloat value);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NFloat value | [in] NFloat to append.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendSizeType Function

NStringBuilderAppendSizeType Function

Appends a the string representation of specified SizeType to the specified string builder.

C++
NResult N_API NStringBuilderAppendSizeType(NStringBuilder * pStringBuilder, NSizeType value);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NSizeType value | [in] SizeType to append.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendUInt16 Function

NStringBuilderAppendUInt16 Function

Appends a the string representation of specified unsigned short integer to the specified string builder.

C++
NResult N_API NStringBuilderAppendUInt16(NStringBuilder * pStringBuilder, NUShort value);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NUShort value | [in] NUShort to append.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendUInt32 Function

NStringBuilderAppendUInt32 Function

Appends a the string representation of specified unsigned integer to the specified string builder.

C++
NResult N_API NStringBuilderAppendUInt32(NStringBuilder * pStringBuilder, NUInt value);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NUInt value | [in] NUInt to append.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendUInt64 Function

NStringBuilderAppendUInt64 Function

Appends a the string representation of specified unsigned long integer to the specified string builder.

C++
NResult N_API NStringBuilderAppendUInt64(NStringBuilder * pStringBuilder, NULong value);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NULong value | [in] NULong to append.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendValue Function

NStringBuilderAppendValue Function

Appends a string representation of a value of specified type to the specified string builder.

C++
NResult N_API NStringBuilderAppendValue(NStringBuilder * pStringBuilder, HNType hType, const void * pValue, NSizeType valueSize);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
HNType hType | [in] Handle to the type of value to be appended.
const void * pValue | [in] Pointer to the value to be appended.
NSizeType valueSize | [in] Size of the value to be appended.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendValueP Function

NStringBuilderAppendValueP Function

Appends a the string representation of specified value to the specified string builder.

C++
NResult N_API NStringBuilderAppendValueP(NStringBuilder * pStringBuilder, NTypeOfProc pTypeOf, const void * pValue, NSizeType valueSize);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NTypeOfProc pTypeOf | [in] Type of the value.
const void * pValue | [in] Pointer to the value to append.
NSizeType valueSize | [in] Size of the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderClear Function

NStringBuilderClear Function

Removes all characters from the specified NStringBuilder.

C++
NResult N_API NStringBuilderClear(NStringBuilder * pStringBuilder);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderCopyToStrOrChars Function

NStringBuilderCopyToStrOrChars Function

Copies the characters from a specified segment of the NStringBuilder to a specified segment of a destination Char array.

C++
NResult N_API NStringBuilderCopyToStrOrChars(NStringBuilder * pStringBuilder, NInt sourceIndex, NChar * arValue, NInt valueLength, NBool nullTerminate, NInt count);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NInt sourceIndex | [in] Index in the NStringBuilder at which the copying will start.
NChar * arValue | [out] The destination char array.
NInt valueLength | [in] Char array length.
NBool nullTerminate | [in] If NTrue, null terminated string will be copied.
NInt count | [in] The number of characters to be copied.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderDetachStrOrChars Function

NStringBuilderDetachStrOrChars Function

Detaches a string or a char array from the NStringBuilder.

C++
NResult N_API NStringBuilderDetachStrOrChars(NStringBuilder * pStringBuilder, NBool nullTerminate, NChar * * parValue, NInt * pValueLength);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NBool nullTerminate | [in] If NTrue, null terminated string will be returned.
NChar * * parValue | [out] Pointer to a detached char array.
NInt * pValueLength | [out] Detached char array length.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderDetachStringN Function

NStringBuilderDetachStringN Function

Detaches a string from the NStringBuilder.

C++
NResult N_API NStringBuilderDetachStringN(NStringBuilder * pStringBuilder, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
HNString * phValue | [out] Pointer to a handle to the detached string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderDispose Function

NStringBuilderDispose Function

Releases the unused resources of the specified NStringBuilder.

C++
NResult N_API NStringBuilderDispose(NStringBuilder * pStringBuilder);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderGetCapacity Function

NStringBuilderGetCapacity Function

Gets the capacity of the specified NStringBuilder.

C++
NResult N_API NStringBuilderGetCapacity(NStringBuilder * pStringBuilder, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NInt * pValue | [out] Pointer to the capacity of the NStringBuilder.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderGetChar Function

NStringBuilderGetChar Function

Gets the character at the specified position in the specified NStringBuilder.

C++
NResult N_API NStringBuilderGetChar(NStringBuilder * pStringBuilder, NInt index, NChar * pValue);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NInt index | [in] Index of the character.
NChar * pValue | [out] Pointer to the character.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderGetLength Function

NStringBuilderGetLength Function

Gets the length of the specified NStringBuilder.

C++
NResult N_API NStringBuilderGetLength(NStringBuilder * pStringBuilder, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NInt * pValue | [out] Pointer to the length of the NStringBuilder.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderGetStrOrCharsBuffer Function

NStringBuilderGetStrOrCharsBuffer Function

Gets the string or character array buffer of the specified NStringBuilder.

C++
NResult N_API NStringBuilderGetStrOrCharsBuffer(NStringBuilder * pStringBuilder, NBool nullTerminate, NInt * pValueLength, NChar * * parValue);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NBool nullTerminate | [in] If NTrue, null terminated string will be returned.
NInt * pValueLength | [out] Pointer to the length of the char array.
NChar * * parValue | [out] Pointer to the char array buffer.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderGetStringWrapper Function

NStringBuilderGetStringWrapper Function

Gets the string wrapper of the specified NStringBuilder.

C++
NResult N_API NStringBuilderGetStringWrapper(NStringBuilder * pStringBuilder, NStringHeader * pStringHeader, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NStringHeader * pStringHeader | [out] Pointer to the string header.
HNString * phValue | [out] Pointer to the string wrapper.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInit Function

NStringBuilderInit Function

Creates a new NStringBuilder.

C++
NResult N_API NStringBuilderInit(NStringBuilder * pStringBuilder);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Pointer to a handle to the new NStringBuilder.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInitEx Function

NStringBuilderInitEx Function

Creates a new NStringBuilder with specified capacity, maximum capacity and growth delta.

C++
NResult N_API NStringBuilderInitEx(NStringBuilder * pStringBuilder, NInt capacity, NInt maxCapacity, NInt growthDelta);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Pointer to a handle to the new NStringBuilder.
NInt capacity | [in] Capacity value.
NInt maxCapacity | [in] Maximum capacity value.
NInt growthDelta | [in] Growth delta.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInitWithCapacity Function

NStringBuilderInitWithCapacity Function

Creates a new NStringBuilder using the specified capacity.

C++
NResult N_API NStringBuilderInitWithCapacity(NStringBuilder * pStringBuilder, NInt capacity);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Pointer to a handle to the new NStringBuilder.
NInt capacity | [in] Capacity value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInitWithStrOrChars Function

NStringBuilderInitWithStrOrChars Function

Creates a new NStringBuilder using the specified string or char array.

C++
NResult N_API NStringBuilderInitWithStrOrChars(NStringBuilder * pStringBuilder, const NChar * arValue, NInt valueLength);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in] Pointer to NStringBuilder.
const NChar * arValue | [in] NChar array.
NInt valueLength | [in] Length of the char array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInitWithStringN Function

NStringBuilderInitWithStringN Function

Creates a new NStringBuilder using the specified string.

C++
NResult N_API NStringBuilderInitWithStringN(NStringBuilder * pStringBuilder, HNString hString);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Pointer to a handle to the new NStringBuilder.
HNString hString | [in] Handle to the string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInsert Function

NStringBuilderInsert Function

Inserts a string into the specified NStringBuilder at the specified character position.

C++
NResult N_API NStringBuilderInsert(NStringBuilder * pStringBuilder, NInt index, const NChar * szValue);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NInt index | [in] The position in the string builder where insertion begins.
const NChar * szValue | [in] Pointer to the string to insert.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInsertBoolean Function

NStringBuilderInsertBoolean Function
C++
NResult N_API NStringBuilderInsertBoolean(NStringBuilder * pStringBuilder, NInt index, NBool value);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NInt index | [in] The position in the string builder where insertion begins.
NBool value | [in] NBool to insert.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInsertByte Function

NStringBuilderInsertByte Function

Inserts a string representation of the specified unsigned byte integer into the specified NStringBuilder at the specified character position.

C++
NResult N_API NStringBuilderInsertByte(NStringBuilder * pStringBuilder, NInt index, NByte value);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NInt index | [in] The position in the string builder where insertion begins.
NByte value | [in] NByte to insert.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInsertChar Function

NStringBuilderInsertChar Function

Inserts a string representation of the specified char into the specified NStringBuilder at the specified character position.

C++
NResult N_API NStringBuilderInsertChar(NStringBuilder * pStringBuilder, NInt index, NChar value);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NInt index | [in] The position in the string builder where insertion begins.
NChar value | [in] NChar to insert.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInsertChars Function

NStringBuilderInsertChars Function

Inserts a string representation of the specified char array into the specified NStringBuilder at the specified character position.

C++
NResult N_API NStringBuilderInsertChars(NStringBuilder * pStringBuilder, NInt index, const NChar * arValue, NInt valueLength);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NInt index | [in] The position in the string builder where insertion begins.
const NChar * arValue | [in] Pointer to the char array to insert.
NInt valueLength | [in] Length of the char array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInsertDouble Function

NStringBuilderInsertDouble Function

Inserts a string representation of the specified double integer into the specified NStringBuilder at the specified character position.

C++
NResult N_API NStringBuilderInsertDouble(NStringBuilder * pStringBuilder, NInt index, NDouble value);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NInt index | [in] The position in the string builder where insertion begins.
NDouble value | [in] NDouble to insert.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInsertInt16 Function

NStringBuilderInsertInt16 Function

Inserts a string representation of the specified short integer into the specified NStringBuilder at the specified character position.

C++
NResult N_API NStringBuilderInsertInt16(NStringBuilder * pStringBuilder, NInt index, NShort value);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NInt index | [in] The position in the string builder where insertion begins.
NShort value | [in] NShort to insert.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInsertInt32 Function

NStringBuilderInsertInt32 Function

Inserts a string representation of the specified integer into the specified NStringBuilder at the specified character position.

C++
NResult N_API NStringBuilderInsertInt32(NStringBuilder * pStringBuilder, NInt index, NInt value);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NInt index | [in] The position in the string builder where insertion begins.
NInt value | [in] NInt to insert.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInsertInt64 Function

NStringBuilderInsertInt64 Function

Inserts a string representation of the specified long integer into the specified NStringBuilder at the specified character position.

C++
NResult N_API NStringBuilderInsertInt64(NStringBuilder * pStringBuilder, NInt index, NLong value);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NInt index | [in] The position in the string builder where insertion begins.
NLong value | [in] NLong to insert.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInsertN Function

NStringBuilderInsertN Function

Inserts a string into the specified NStringBuilder at the specified character position.

C++
NResult N_API NStringBuilderInsertN(NStringBuilder * pStringBuilder, NInt index, HNString hValue);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NInt index | [in] The position in the string builder where insertion begins.
HNString hValue | [in] Handle to the string to insert.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInsertObject Function

NStringBuilderInsertObject Function

Inserts a string representation of the specified object into the specified NStringBuilder at the specified character position.

C++
NResult N_API NStringBuilderInsertObject(NStringBuilder * pStringBuilder, NInt index, HNObject hObject);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NInt index | [in] The position in the string builder where insertion begins.
HNObject hObject | [in] Handle to the object to insert.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInsertPointer Function

NStringBuilderInsertPointer Function

Inserts a string representation of the specified pointer into the specified NStringBuilder at the specified character position.

C++
NResult N_API NStringBuilderInsertPointer(NStringBuilder * pStringBuilder, NInt index, const void * value);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NInt index | [in] The position in the string builder where insertion begins.
const void * value | [in] The pointer to insert.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInsertResult Function

NStringBuilderInsertResult Function

Inserts a string representation of a NResult value into the specified NStringBuilder at the specified character position.

C++
NResult N_API NStringBuilderInsertResult(NStringBuilder * pStringBuilder, NInt index, NResult value);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NInt index | [in] The position in the string builder where insertion begins.
NResult value | [in] The NResult value to be inserted.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInsertSByte Function

NStringBuilderInsertSByte Function

Inserts a string representation of the specified byte integer into the specified NStringBuilder at the specified character position.

C++
NResult N_API NStringBuilderInsertSByte(NStringBuilder * pStringBuilder, NInt index, NSByte value);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NInt index | [in] The position in the string builder where insertion begins.
NSByte value | [in] NSByte to insert.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInsertSSizeType Function

NStringBuilderInsertSSizeType Function

Inserts a string representation of the specified SSizeType into the specified NStringBuilder at the specified character position.

C++
NResult N_API NStringBuilderInsertSSizeType(NStringBuilder * pStringBuilder, NInt index, NSSizeType value);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NInt index | [in] The position in the string builder where insertion begins.
NSSizeType value | [in] NSSizeType to insert.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInsertSingle Function

NStringBuilderInsertSingle Function

Inserts a string representation of the specified floating point number into the specified NStringBuilder at the specified character position.

C++
NResult N_API NStringBuilderInsertSingle(NStringBuilder * pStringBuilder, NInt index, NFloat value);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NInt index | [in] The position in the string builder where insertion begins.
NFloat value | [in] NFloat to insert.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInsertSizeType Function

NStringBuilderInsertSizeType Function

Inserts a string representation of the specified SizeType into the specified NStringBuilder at the specified character position.

C++
NResult N_API NStringBuilderInsertSizeType(NStringBuilder * pStringBuilder, NInt index, NSizeType value);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NInt index | [in] The position in the string builder where insertion begins.
NSizeType value | [in] NSizeType to insert.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInsertUInt16 Function

NStringBuilderInsertUInt16 Function

Inserts a string representation of the specified unsigned short integer into the specified NStringBuilder at the specified character position.

C++
NResult N_API NStringBuilderInsertUInt16(NStringBuilder * pStringBuilder, NInt index, NUShort value);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NInt index | [in] The position in the string builder where insertion begins.
NUShort value | [in] NUShort to insert.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInsertUInt32 Function

NStringBuilderInsertUInt32 Function

Inserts a string representation of the specified unsigned integer into the specified NStringBuilder at the specified character position.

C++
NResult N_API NStringBuilderInsertUInt32(NStringBuilder * pStringBuilder, NInt index, NUInt value);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NInt index | [in] The position in the string builder where insertion begins.
NUInt value | [in] NUInt to insert.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInsertUInt64 Function

NStringBuilderInsertUInt64 Function

Inserts a string representation of the specified long integer into the specified NStringBuilder at the specified character position.

C++
NResult N_API NStringBuilderInsertUInt64(NStringBuilder * pStringBuilder, NInt index, NULong value);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NInt index | [in] The position in the string builder where insertion begins.
NULong value | [in] NULong to insert.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInsertValue Function

NStringBuilderInsertValue Function

Inserts a string representation of a value of specified type into the specified NStringBuilder at the specified character position.

C++
NResult N_API NStringBuilderInsertValue(NStringBuilder * pStringBuilder, NInt index, HNType hType, const void * pValue, NSizeType valueSize);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NInt index | [in] The position in the string builder where insertion begins.
HNType hType | [in] Handle to the type of value to be appended.
const void * pValue | [in] Pointer to the value to be appended.
NSizeType valueSize | [in] Size of the value to be appended.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInsertValueP Function

NStringBuilderInsertValueP Function

Inserts a string representation of the specified value into the specified NStringBuilder at the specified character position.

C++
NResult N_API NStringBuilderInsertValueP(NStringBuilder * pStringBuilder, NInt index, NTypeOfProc pTypeOf, const void * pValue, NSizeType valueSize);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NInt index | [in] The position in the string builder where insertion begins.
NTypeOfProc pTypeOf | [in] Type of the value.
const void * pValue | [in] Pointer to the value to insert.
NSizeType valueSize | [in] Size of the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderRemove Function

NStringBuilderRemove Function

Removes the specified range of characters from the specified NStringBuilder.

C++
NResult N_API NStringBuilderRemove(NStringBuilder * pStringBuilder, NInt startIndex, NInt count);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NInt startIndex | [in] The zero-based position in this instance where removal begins.
NInt count | [in] The number of characters to remove.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderReplace Function

NStringBuilderReplace Function

Replaces all occurrences of a specified character in the specified NStringBuilder with another specified character.

C++
NResult N_API NStringBuilderReplace(NStringBuilder * pStringBuilder, NChar oldValue, NChar newValue);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NChar oldValue | [in] The character to replace.
NChar newValue | [in] The character that replaces oldValue.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderReplaceInRange Function

NStringBuilderReplaceInRange Function

Replaces, within a substring of the specified NStringBuilder, all occurrences of a specified character with another specified character.

C++
NResult N_API NStringBuilderReplaceInRange(NStringBuilder * pStringBuilder, NChar oldValue, NChar newValue, NInt startIndex, NInt count);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NChar oldValue | [in] The character to replace.
NChar newValue | [in] The character that replaces oldValue.
NInt startIndex | [in] The position in the NStringBuilder where the substring begins.
NInt count | [in] The length of the substring.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderReplaceStrOrChars Function

NStringBuilderReplaceStrOrChars Function

Replaces all occurrences of a specified string or char array in the specified NStringBuilder with another specified string or char array.

C++
NResult N_API NStringBuilderReplaceStrOrChars(NStringBuilder * pStringBuilder, const NChar * arOldValue, NInt oldValueLength, const NChar * arNewValue, NInt newValueLength);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
const NChar * arOldValue | [in] Pointer to the char array to replace.
NInt oldValueLength | [in] arOldValue array length.
const NChar * arNewValue | [in] Pointer to the char array that replaces arOldValue.
NInt newValueLength | [in] arNewValue array length.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderReplaceStrOrCharsInRange Function

NStringBuilderReplaceStrOrCharsInRange Function

Replaces, within a substring of the specified NStringBuilder, all occurrences of a specified string or char array with another specified string or char array.

C++
NResult N_API NStringBuilderReplaceStrOrCharsInRange(NStringBuilder * pStringBuilder, const NChar * arOldValue, NInt oldValueLength, const NChar * arNewValue, NInt newValueLength, NInt startIndex, NInt count);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
const NChar * arOldValue | [in] Pointer to the char array to replace.
NInt oldValueLength | [in] arOldValue array length.
const NChar * arNewValue | [in] Pointer to the char array that replaces arOldValue.
NInt newValueLength | [in] arNewValue array length.
NInt startIndex | [in] The position in the NStringBuilder where the substring begins.
NInt count | [in] The length of the substring.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderReplaceStringInRangeN Function

NStringBuilderReplaceStringInRangeN Function

Replaces, within a substring of the specified NStringBuilder, all occurrences of a specified string with another specified string.

C++
NResult N_API NStringBuilderReplaceStringInRangeN(NStringBuilder * pStringBuilder, HNString hOldValue, HNString hNewValue, NInt startIndex, NInt count);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
HNString hOldValue | [in] Handle to the string to replace.
HNString hNewValue | [in] The string that replaces hOldValue.
NInt startIndex | [in] The position in the NStringBuilder where the substring begins.
NInt count | [in] The length of the substring.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderReplaceStringN Function

NStringBuilderReplaceStringN Function

Replaces all occurrences of a specified string in the specified NStringBuilder with another specified character.

C++
NResult N_API NStringBuilderReplaceStringN(NStringBuilder * pStringBuilder, HNString hOldValue, HNString hNewValue);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
HNString hOldValue | [in] Handle to the string to replace.
HNString hNewValue | [in] The string that replaces hOldValue.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderSetCapacity Function

NStringBuilderSetCapacity Function

Sets the capacity of the specified NStringBuilder.

C++
NResult N_API NStringBuilderSetCapacity(NStringBuilder * pStringBuilder, NInt value);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NInt value | [in] The new capacity value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderSetChar Function

NStringBuilderSetChar Function

Sets the value of the character at the specified position in the specified NStringBuilder.

C++
NResult N_API NStringBuilderSetChar(NStringBuilder * pStringBuilder, NInt index, NChar value);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NInt index | [in] Index of the character.
NChar value | [in] New character value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderSetLength Function

NStringBuilderSetLength Function

Sets the length of the specified NStringBuilder.

C++
NResult N_API NStringBuilderSetLength(NStringBuilder * pStringBuilder, NInt value);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NInt value | [in] The new length value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderToString Function

NStringBuilderToString Function

Converts the specified NStringBuilder to a string.

C++
NResult N_API NStringBuilderToString(NStringBuilder * pStringBuilder, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
HNString * phValue | [out] Pointer to a handle to the string representing the NStringBuilder.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderToStringRange Function

NStringBuilderToStringRange Function

Converts the specified NStringBuilder to a string range.

C++
NResult N_API NStringBuilderToStringRange(NStringBuilder * pStringBuilder, NInt startIndex, NInt length, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
NStringBuilder * pStringBuilder | [in/out] Handle to the NStringBuilder.
NInt startIndex | [in] Starting index of the string range.
NInt length | [in] Length of the string range.
HNString * phValue | [out] Pointer to a handle to the string representing the NStringBuilder.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppend Macro

NStringBuilderAppend Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppend function.

C++
#define NStringBuilderAppend N_FUNC_AW(NStringBuilderAppend)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendBoolean Macro

NStringBuilderAppendBoolean Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendBoolean function.

C++
#define NStringBuilderAppendBoolean N_FUNC_AW(NStringBuilderAppendBoolean)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendByte Macro

NStringBuilderAppendByte Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendByte function.

C++
#define NStringBuilderAppendByte N_FUNC_AW(NStringBuilderAppendByte)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendChar Macro

NStringBuilderAppendChar Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendChar function.

C++
#define NStringBuilderAppendChar N_FUNC_AW(NStringBuilderAppendChar)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendCharRepeat Macro

NStringBuilderAppendCharRepeat Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendCharRepeat function.

C++
#define NStringBuilderAppendCharRepeat N_FUNC_AW(NStringBuilderAppendCharRepeat)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendChars Macro

NStringBuilderAppendChars Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendChars function.

C++
#define NStringBuilderAppendChars N_FUNC_AW(NStringBuilderAppendChars)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendDouble Macro

NStringBuilderAppendDouble Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendDouble function.

C++
#define NStringBuilderAppendDouble N_FUNC_AW(NStringBuilderAppendDouble)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendEmptyLine Macro

NStringBuilderAppendEmptyLine Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendEmptyLine function.

C++
#define NStringBuilderAppendEmptyLine N_FUNC_AW(NStringBuilderAppendEmptyLine)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendFormat Macro

NStringBuilderAppendFormat Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendFormat function.

C++
#define NStringBuilderAppendFormat N_FUNC_AW(NStringBuilderAppendFormat)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendFormatN Macro

NStringBuilderAppendFormatN Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendFormatN function.

C++
#define NStringBuilderAppendFormatN N_FUNC_AW(NStringBuilderAppendFormatN)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendFormatVA Macro

NStringBuilderAppendFormatVA Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendFormatVA function.

C++
#define NStringBuilderAppendFormatVA N_FUNC_AW(NStringBuilderAppendFormatVA)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendFormatVAN Macro

NStringBuilderAppendFormatVAN Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendFormatVAN function.

C++
#define NStringBuilderAppendFormatVAN N_FUNC_AW(NStringBuilderAppendFormatVAN)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendInt16 Macro

NStringBuilderAppendInt16 Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendInt16 function.

C++
#define NStringBuilderAppendInt16 N_FUNC_AW(NStringBuilderAppendInt16)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendInt32 Macro

NStringBuilderAppendInt32 Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendInt32 function.

C++
#define NStringBuilderAppendInt32 N_FUNC_AW(NStringBuilderAppendInt32)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendInt64 Macro

NStringBuilderAppendInt64 Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendInt64 function.

C++
#define NStringBuilderAppendInt64 N_FUNC_AW(NStringBuilderAppendInt64)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendLine Macro

NStringBuilderAppendLine Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendLine function.

C++
#define NStringBuilderAppendLine N_FUNC_AW(NStringBuilderAppendLine)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendLineN Macro

NStringBuilderAppendLineN Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendLineN function.

C++
#define NStringBuilderAppendLineN N_FUNC_AW(NStringBuilderAppendLineN)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendN Macro

NStringBuilderAppendN Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendN function.

C++
#define NStringBuilderAppendN N_FUNC_AW(NStringBuilderAppendN)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendObject Macro

NStringBuilderAppendObject Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendObject function.

C++
#define NStringBuilderAppendObject N_FUNC_AW(NStringBuilderAppendObject)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendPointer Macro

NStringBuilderAppendPointer Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendPointer function.

C++
#define NStringBuilderAppendPointer N_FUNC_AW(NStringBuilderAppendPointer)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendResult Macro

NStringBuilderAppendResult Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendResult function.

C++
#define NStringBuilderAppendResult N_FUNC_AW(NStringBuilderAppendResult)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendSByte Macro

NStringBuilderAppendSByte Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendSByte function.

C++
#define NStringBuilderAppendSByte N_FUNC_AW(NStringBuilderAppendSByte)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendSSizeType Macro

NStringBuilderAppendSSizeType Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendSSizeType function.

C++
#define NStringBuilderAppendSSizeType N_FUNC_AW(NStringBuilderAppendSSizeType)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendSingle Macro

NStringBuilderAppendSingle Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendSingle function.

C++
#define NStringBuilderAppendSingle N_FUNC_AW(NStringBuilderAppendSingle)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendSizeType Macro

NStringBuilderAppendSizeType Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendSizeType function.

C++
#define NStringBuilderAppendSizeType N_FUNC_AW(NStringBuilderAppendSizeType)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendUInt16 Macro

NStringBuilderAppendUInt16 Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendUInt16 function.

C++
#define NStringBuilderAppendUInt16 N_FUNC_AW(NStringBuilderAppendUInt16)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendUInt32 Macro

NStringBuilderAppendUInt32 Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendUInt32 function.

C++
#define NStringBuilderAppendUInt32 N_FUNC_AW(NStringBuilderAppendUInt32)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendUInt64 Macro

NStringBuilderAppendUInt64 Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendUInt64 function.

C++
#define NStringBuilderAppendUInt64 N_FUNC_AW(NStringBuilderAppendUInt64)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendValue Macro

NStringBuilderAppendValue Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendValue function.

C++
#define NStringBuilderAppendValue N_FUNC_AW(NStringBuilderAppendValue)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderAppendValueP Macro

NStringBuilderAppendValueP Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendValueP function.

C++
#define NStringBuilderAppendValueP N_FUNC_AW(NStringBuilderAppendValueP)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderClear Macro

NStringBuilderClear Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderClear function.

C++
#define NStringBuilderClear N_FUNC_AW(NStringBuilderClear)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderCopyTo Macro

NStringBuilderCopyTo Macro

Copies the characters from a specified segment of the NStringBuilder to a specified segment of a destination Char array.

C++
#define NStringBuilderCopyTo(pStringBuilder, sourceIndex, arValue, valueLength, count) NStringBuilderCopyToStrOrChars(pStringBuilder, sourceIndex, arValue, valueLength, NFalse, count)
Collapse Expand Parameters
Parameters | Description
pStringBuilder | [in/out] Handle to the NStringBuilder.
sourceIndex | [in] Index in the NStringBuilder at which the copying will start.
arValue | [in] Destination char array.
valueLength | [in] Length of the char array.
count | [in] The number of characters to be copied.
Collapse Expand Returns
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderCopyToStrOrChars Macro

NStringBuilderCopyToStrOrChars Macro

Picks a Unicode (W) or ASCII (A) version of the NStringCopyToStrOrChars function.

C++
#define NStringBuilderCopyToStrOrChars N_FUNC_AW(NStringBuilderCopyToStrOrChars)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderCopyToString Macro

NStringBuilderCopyToString Macro

Copies the characters from a specified segment of the NStringBuilder to a specified segment of a destination string.

C++
#define NStringBuilderCopyToString(pStringBuilder, sourceIndex, szValue, valueSize, count) NStringBuilderCopyToStrOrChars(pStringBuilder, sourceIndex, szValue, valueSize, NTrue, count)
Collapse Expand Parameters
Parameters | Description
pStringBuilder | [in/out] Handle to the NStringBuilder.
sourceIndex | [in] Index in the NStringBuilder at which the copying will start.
szValue | [in] Destination string.
valueSize | [in] Size of the string.
count | [in] The number of characters to be copied.
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderDetachCharArray Macro

NStringBuilderDetachCharArray Macro

Detaches a char array from the NStringBuilder.

C++
#define NStringBuilderDetachCharArray(pStringBuilder, parValue, pValueLength) NStringBuilderDetachStrOrChars(pStringBuilder, NFalse, parValue, pValueLength)
Collapse Expand Parameters
Parameters | Description
pStringBuilder | [in/out] Handle to the NStringBuilder.
nullTerminate | [in] If NTrue, null terminated string will be returned.
parValue | [out] Pointer to a detached char array.
pValueLength | [out] Detached char array length.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderDetachStrOrChars Macro

NStringBuilderDetachStrOrChars Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderDetachStrOrChars function.

C++
#define NStringBuilderDetachStrOrChars N_FUNC_AW(NStringBuilderDetachStrOrChars)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderDetachString Macro

NStringBuilderDetachString Macro

Detaches a string from the NStringBuilder.

C++
#define NStringBuilderDetachString(pStringBuilder, pszValue, pValueLength) NStringBuilderDetachStrOrChars(pStringBuilder, NTrue, pszValue, pValueLength)
Collapse Expand Parameters
Parameters | Description
pStringBuilder | [in/out] Handle to the NStringBuilder.
pszValue | [out] Pointer to the detached string.
pValueLength | [out] Length of the detached string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderDispose Macro

NStringBuilderDispose Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderDispose function.

C++
#define NStringBuilderDispose N_FUNC_AW(NStringBuilderDispose)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderGetBuffer Macro

NStringBuilderGetBuffer Macro

Gets the string buffer of the specified NStringBuilder.

C++
#define NStringBuilderGetBuffer(pStringBuilder, pValueLength, pszValue) NStringBuilderGetStrOrCharsBuffer(pStringBuilder, NTrue, pValueLength, pszValue)
Collapse Expand Parameters
Parameters | Description
pStringBuilder | [in/out] Handle to the NStringBuilder.
pValueLength | [out] Pointer to the length of the char array.
pszValue | [out] Pointer to the string buffer.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderGetCapacity Macro

NStringBuilderGetCapacity Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderGetCapacity function.

C++
#define NStringBuilderGetCapacity N_FUNC_AW(NStringBuilderGetCapacity)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderGetChar Macro

NStringBuilderGetChar Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderGetChar function.

C++
#define NStringBuilderGetChar N_FUNC_AW(NStringBuilderGetChar)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderGetCharsBuffer Macro

NStringBuilderGetCharsBuffer Macro

Gets the character array buffer of the specified NStringBuilder.

C++
#define NStringBuilderGetCharsBuffer(pStringBuilder, pValueLength, parValue) NStringBuilderGetStrOrCharsBuffer(pStringBuilder, NFalse, pValueLength, parValue)
Collapse Expand Parameters
Parameters | Description
pStringBuilder | [in/out] Handle to the NStringBuilder.
pValueLength | [out] Pointer to the length of the char array.
parValue | [out] Pointer to the char array buffer.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderGetLength Macro

NStringBuilderGetLength Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderGetLength function.

C++
#define NStringBuilderGetLength N_FUNC_AW(NStringBuilderGetLength)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderGetStrOrCharsBuffer Macro

NStringBuilderGetStrOrCharsBuffer Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderGetStrOrCharsBuffer function.

C++
#define NStringBuilderGetStrOrCharsBuffer N_FUNC_AW(NStringBuilderGetStrOrCharsBuffer)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderGetStringWrapper Macro

NStringBuilderGetStringWrapper Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderGetStringWrapper function.

C++
#define NStringBuilderGetStringWrapper N_FUNC_AW(NStringBuilderGetStringWrapper)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInit Macro

NStringBuilderInit Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInit function.

C++
#define NStringBuilderInit N_FUNC_AW(NStringBuilderInit)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInitEx Macro

NStringBuilderInitEx Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInitEx function.

C++
#define NStringBuilderInitEx N_FUNC_AW(NStringBuilderInitEx)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInitWithCapacity Macro

NStringBuilderInitWithCapacity Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInitWithCapacity function.

C++
#define NStringBuilderInitWithCapacity N_FUNC_AW(NStringBuilderInitWithCapacity)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInitWithChars Macro

NStringBuilderInitWithChars Macro

Creates a new NStringBuilder using the specified char array.

C++
#define NStringBuilderInitWithChars(pStringBuilder, arValue, valueLength) NStringBuilderInitWithStrOrChars(pStringBuilder, arValue, valueLength)
Collapse Expand Parameters
Parameters | Description
arValue | [in] Pointer to the char array.
valueLength | [in] Length of the array.
phStringBuilder | [out] Pointer to a handle to the new NStringBuilder.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInitWithStrOrChars Macro

NStringBuilderInitWithStrOrChars Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInitWithStrOrChars function.

C++
#define NStringBuilderInitWithStrOrChars N_FUNC_AW(NStringBuilderInitWithStrOrChars)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInitWithString Macro

NStringBuilderInitWithString Macro

Creates a new NStringBuilder using the specified string.

C++
#define NStringBuilderInitWithString(pStringBuilder, szValue) NStringBuilderInitWithStrOrChars(pStringBuilder, szValue, -1)
Collapse Expand Parameters
Parameters | Description
szValue | [in] Pointer to the string.
phStringBuilder | [out] Pointer to a handle to the new NStringBuilder.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInitWithStringN Macro

NStringBuilderInitWithStringN Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInitWithStringN function.

C++
#define NStringBuilderInitWithStringN N_FUNC_AW(NStringBuilderInitWithStringN)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInsert Macro

NStringBuilderInsert Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsert function.

C++
#define NStringBuilderInsert N_FUNC_AW(NStringBuilderInsert)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInsertBoolean Macro

NStringBuilderInsertBoolean Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertBoolean function.

C++
#define NStringBuilderInsertBoolean N_FUNC_AW(NStringBuilderInsertBoolean)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInsertByte Macro

NStringBuilderInsertByte Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertByte function.

C++
#define NStringBuilderInsertByte N_FUNC_AW(NStringBuilderInsertByte)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInsertChar Macro

NStringBuilderInsertChar Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertChar function.

C++
#define NStringBuilderInsertChar N_FUNC_AW(NStringBuilderInsertChar)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInsertChars Macro

NStringBuilderInsertChars Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertChars function.

C++
#define NStringBuilderInsertChars N_FUNC_AW(NStringBuilderInsertChars)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInsertDouble Macro

NStringBuilderInsertDouble Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertDouble function.

C++
#define NStringBuilderInsertDouble N_FUNC_AW(NStringBuilderInsertDouble)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInsertInt16 Macro

NStringBuilderInsertInt16 Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertInsertInt16 function.

C++
#define NStringBuilderInsertInt16 N_FUNC_AW(NStringBuilderInsertInt16)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInsertInt32 Macro

NStringBuilderInsertInt32 Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertInt32 function.

C++
#define NStringBuilderInsertInt32 N_FUNC_AW(NStringBuilderInsertInt32)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInsertInt64 Macro

NStringBuilderInsertInt64 Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertInt64 function.

C++
#define NStringBuilderInsertInt64 N_FUNC_AW(NStringBuilderInsertInt64)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInsertN Macro

NStringBuilderInsertN Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertN function.

C++
#define NStringBuilderInsertN N_FUNC_AW(NStringBuilderInsertN)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInsertObject Macro

NStringBuilderInsertObject Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertObject function.

C++
#define NStringBuilderInsertObject N_FUNC_AW(NStringBuilderInsertObject)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInsertPointer Macro

NStringBuilderInsertPointer Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertPointer function.

C++
#define NStringBuilderInsertPointer N_FUNC_AW(NStringBuilderInsertPointer)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInsertResult Macro

NStringBuilderInsertResult Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertResult function.

C++
#define NStringBuilderInsertResult N_FUNC_AW(NStringBuilderInsertResult)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInsertSByte Macro

NStringBuilderInsertSByte Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertSByte function.

C++
#define NStringBuilderInsertSByte N_FUNC_AW(NStringBuilderInsertSByte)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInsertSSizeType Macro

NStringBuilderInsertSSizeType Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertSSizeType function.

C++
#define NStringBuilderInsertSSizeType N_FUNC_AW(NStringBuilderInsertSSizeType)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInsertSingle Macro

NStringBuilderInsertSingle Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertSingle function.

C++
#define NStringBuilderInsertSingle N_FUNC_AW(NStringBuilderInsertSingle)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInsertSizeType Macro

NStringBuilderInsertSizeType Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertSizeType function.

C++
#define NStringBuilderInsertSizeType N_FUNC_AW(NStringBuilderInsertSizeType)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInsertUInt16 Macro

NStringBuilderInsertUInt16 Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertUInt16 function.

C++
#define NStringBuilderInsertUInt16 N_FUNC_AW(NStringBuilderInsertUInt16)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInsertUInt32 Macro

NStringBuilderInsertUInt32 Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertUInt32 function.

C++
#define NStringBuilderInsertUInt32 N_FUNC_AW(NStringBuilderInsertUInt32)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInsertUInt64 Macro

NStringBuilderInsertUInt64 Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertUInt64 function.

C++
#define NStringBuilderInsertUInt64 N_FUNC_AW(NStringBuilderInsertUInt64)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInsertValue Macro

NStringBuilderInsertValue Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertValue function.

C++
#define NStringBuilderInsertValue N_FUNC_AW(NStringBuilderInsertValue)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderInsertValueP Macro

NStringBuilderInsertValueP Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertValueP function.

C++
#define NStringBuilderInsertValueP N_FUNC_AW(NStringBuilderInsertValueP)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderRemove Macro

NStringBuilderRemove Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderRemove function.

C++
#define NStringBuilderRemove N_FUNC_AW(NStringBuilderRemove)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderReplace Macro

NStringBuilderReplace Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderReplace function.

C++
#define NStringBuilderReplace N_FUNC_AW(NStringBuilderReplace)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderReplaceChars Macro

NStringBuilderReplaceChars Macro

Replaces all occurrences of a specified char array in the specified NStringBuilder with another specified char array.

C++
#define NStringBuilderReplaceChars(pStringBuilder, arOldValue, oldValueLength, arNewValue, newValueLength) NStringBuilderReplaceStrOrChars(pStringBuilder, arOldValue, oldValueLength, arNewValue, newValueLength)
Collapse Expand Parameters
Parameters | Description
pStringBuilder | [in/out] Handle to the NStringBuilder.
arOldValue | [in] Pointer to the char array to replace.
oldValueLength | [in] arOldValue array length.
arNewValue | [in] Pointer to the char array that replaces arOldValue.
newValueLength | [in] arNewValue array length.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderReplaceCharsInRange Macro

NStringBuilderReplaceCharsInRange Macro

Replaces, within a substring of the specified NStringBuilder, all occurrences of a specified char array with another specified char array.

C++
#define NStringBuilderReplaceCharsInRange(pStringBuilder, arOldValue, oldValueLength, arNewValue, newValueLength, startIndex, count) NStringBuilderReplaceStrOrCharsInRange(pStringBuilder, arOldValue, oldValueLength, arNewValue, newValueLength, startIndex, count)
Collapse Expand Parameters
Parameters | Description
pStringBuilder | [in/out] Handle to the NStringBuilder.
arOldValue | [in] Pointer to the char array to replace.
oldValueLength | [in] arOldValue array length.
arNewValue | [in] Pointer to the char array that replaces arOldValue.
newValueLength | [in] arNewValue array length.
startIndex | [in] The position in the NStringBuilder where the substring begins.
count | [in] The length of the substring.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderReplaceInRange Macro

NStringBuilderReplaceInRange Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderReplaceInRange function.

C++
#define NStringBuilderReplaceInRange N_FUNC_AW(NStringBuilderReplaceInRange)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderReplaceStrOrChars Macro

NStringBuilderReplaceStrOrChars Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderReplaceStrOrChars function.

C++
#define NStringBuilderReplaceStrOrChars N_FUNC_AW(NStringBuilderReplaceStrOrChars)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderReplaceStrOrCharsInRange Macro

NStringBuilderReplaceStrOrCharsInRange Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderReplaceStrOrCharsInRange function.

C++
#define NStringBuilderReplaceStrOrCharsInRange N_FUNC_AW(NStringBuilderReplaceStrOrCharsInRange)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderReplaceString Macro

NStringBuilderReplaceString Macro

Replaces all occurrences of a specified string in the specified NStringBuilder with another specified character.

C++
#define NStringBuilderReplaceString(pStringBuilder, szOldValue, szNewValue) NStringBuilderReplaceStrOrChars(pStringBuilder, szOldValue, -1, szNewValue, -1)
Collapse Expand Parameters
Parameters | Description
pStringBuilder | [in/out] Pointer to the NStringBuilder.
szOldValue | [in] Pointer to the string to replace.
szNewValue | [in] The string that replaces szOldValue.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderReplaceStringInRange Macro

NStringBuilderReplaceStringInRange Macro

Replaces, within a substring of the specified NStringBuilder, all occurrences of a specified string with another specified string.

C++
#define NStringBuilderReplaceStringInRange(pStringBuilder, szOldValue, szNewValue, startIndex, count) NStringBuilderReplaceStrOrCharsInRange(pStringBuilder, szOldValue, -1, szNewValue, -1, startIndex, count)
Collapse Expand Parameters
Parameters | Description
szStringBuilder | [in] Pointer to the NStringBuilder.
szOldValue | [in] Pointer to the string to replace.
hNewValue | [in] The string that replaces szOldValue.
startIndex | [in] The position in the NStringBuilder where the substring begins.
count | [in] The length of the substring.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderReplaceStringN Macro

NStringBuilderReplaceStringN Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderReplaceStringN function.

C++
#define NStringBuilderReplaceStringN N_FUNC_AW(NStringBuilderReplaceStringN)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderSetCapacity Macro

NStringBuilderSetCapacity Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderSetCapacity function.

C++
#define NStringBuilderSetCapacity N_FUNC_AW(NStringBuilderSetCapacity)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderSetChar Macro

NStringBuilderSetChar Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderSetChar function.

C++
#define NStringBuilderSetChar N_FUNC_AW(NStringBuilderSetChar)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderSetLength Macro

NStringBuilderSetLength Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderSetLength function.

C++
#define NStringBuilderSetLength N_FUNC_AW(NStringBuilderSetLength)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderToString Macro

NStringBuilderToString Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderToString function.

C++
#define NStringBuilderToString N_FUNC_AW(NStringBuilderToString)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringBuilderToStringRange Macro

NStringBuilderToStringRange Macro

Picks a Unicode (W) or ASCII (A) version of the NStringBuilderToStringRange function.

C++
#define NStringBuilderToStringRange N_FUNC_AW(NStringBuilderToStringRange)
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


N_STRING_BUILDER_SIZE Macro

N_STRING_BUILDER_SIZE Macro

Defines the NStringBuilder size.

C++
#define N_STRING_BUILDER_SIZE 20
Container

File: NStringBuilder.h

Module: NStringBuilder Unit


NStringReader Unit

NStringReader Unit
Functions Legend Macros

Implements a TextReader that reads from a string.

Collapse Expand Functions
Name | Description
NStringReaderCreateFromStrOrChars | Creates a new NStringReader that reads from the specified string or char array.
NStringReaderCreateN | Creates a new NStringReader that reads from the specified NString.
Collapse Expand Macros
Name | Description
NStringReaderCreate | Creates a new NStringReader that reads from the specified string.
NStringReaderCreateFromChars | Creates a new NStringReader that reads from the specified char array.
NStringReaderCreateFromStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringReaderCreateFromStrOrChars function.


NStringReaderCreateFromStrOrChars Function

NStringReaderCreateFromStrOrChars Function

Creates a new NStringReader that reads from the specified string or char array.

C++
NResult N_API NStringReaderCreateFromStrOrChars(const NChar * arValue, NInt valueLength, HNStringReader * phReader);
Collapse Expand Parameters
Parameters | Description
const NChar * arValue | [in] Pointer to the char array or string.
NInt valueLength | [in] Length of the char array.
HNStringReader * phReader | [out] Pointer to a handle to the new NStringReader.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringReader.h

Module: NStringReader Unit


NStringReaderCreateN Function

NStringReaderCreateN Function

Creates a new NStringReader that reads from the specified NString.

C++
NResult N_API NStringReaderCreateN(HNString hValue, HNStringReader * phReader);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] Handle to the NString.
HNStringReader * phReader | [out] Pointer to a handle to the new NStringReader.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringReader.h

Module: NStringReader Unit


NStringReaderCreate Macro

NStringReaderCreate Macro

Creates a new NStringReader that reads from the specified string.

C++
#define NStringReaderCreate(szValue, phReader) NStringReaderCreateFromStrOrChars(szValue, -1, phReader)
Collapse Expand Parameters
Parameters | Description
szValue | [in] Pointer to the string.
phReader | [out] Pointer to a handle to the new NStringReader.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringReader.h

Module: NStringReader Unit


NStringReaderCreateFromChars Macro

NStringReaderCreateFromChars Macro

Creates a new NStringReader that reads from the specified char array.

C++
#define NStringReaderCreateFromChars(arValue, valueLength, phReader) NStringReaderCreateFromStrOrChars(arValue, valueLength, phReader)
Collapse Expand Parameters
Parameters | Description
arValue | [in] Pointer to the char array or string.
valueLength | [in] Length of the char array.
phReader | [out] Pointer to a handle to the new NStringReader.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringReader.h

Module: NStringReader Unit


NStringReaderCreateFromStrOrChars Macro

NStringReaderCreateFromStrOrChars Macro

Picks a Unicode (W) or ASCII (A) version of the NStringReaderCreateFromStrOrChars function.

C++
#define NStringReaderCreateFromStrOrChars N_FUNC_AW(NStringReaderCreateFromStrOrChars)
Container

File: NStringReader.h

Module: NStringReader Unit


NStringWriter Unit

NStringWriter Unit
Files Functions Legend

Implements a TextWriter for writing information to a string. The information is stored in an underlying StringBuilder.

Collapse Expand Files
Name | Description
NStringWriter.h | Header file for the NStringWriter module.
Collapse Expand Functions
Name | Description
NStringWriterCreate | Creates a new NStringWriter.
NStringWriterCreateEx | Creates a new NStringWriter with specified capacity and growth delta.
NStringWriterCreateWithCapacity | Creates a new NStringWriter with specified capacity.
NStringWriterDetachString | Detaches the specified string from the specified string writer.


NStringWriterCreate Function

NStringWriterCreate Function
NStringWriter.h

Creates a new NStringWriter.

C++
NResult N_API NStringWriterCreate(HNStringWriter * phWriter);
Collapse Expand Parameters
Parameters | Description
HNStringWriter * phWriter | [out] Pointer to a handle to the new NStringWriter.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

A new NStringBuilder is automatically created and associated with the new NStringWriter.

Container

File: NStringWriter.h

Module: NStringWriter Unit


NStringWriterCreateEx Function

NStringWriterCreateEx Function
NStringWriter.h

Creates a new NStringWriter with specified capacity and growth delta.

C++
NResult N_API NStringWriterCreateEx(NInt capacity, NInt maxCapacity, NInt growthDelta, HNStringWriter * phWriter);
Collapse Expand Parameters
Parameters | Description
NInt capacity | [in] Capacity value of the new string writer.
NInt maxCapacity | [in] Maximum capacity value of the new string writer.
NInt growthDelta | [in] Growth delta of the new string writer.
HNStringWriter * phWriter | [out] Pointer to a handle to the new NStringWriter.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

A new NStringBuilder is automatically created and associated with the new NStringWriter.

Container

File: NStringWriter.h

Module: NStringWriter Unit


NStringWriterCreateWithCapacity Function

NStringWriterCreateWithCapacity Function
NStringWriter.h

Creates a new NStringWriter with specified capacity.

C++
NResult N_API NStringWriterCreateWithCapacity(NInt capacity, HNStringWriter * phWriter);
Collapse Expand Parameters
Parameters | Description
NInt capacity | [in] Capacity value of the new string writer.
HNStringWriter * phWriter | [out] Pointer to a handle to the new NStringWriter.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

A new NStringBuilder is automatically created and associated with the new NStringWriter.

Container

File: NStringWriter.h

Module: NStringWriter Unit


NStringWriterDetachString Function

NStringWriterDetachString Function
NStringWriter.h

Detaches the specified string from the specified string writer.

C++
NResult N_API NStringWriterDetachString(HNStringWriter hWriter, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNStringWriter hWriter | [in] Handle to the string writer.
HNString * phValue | [out] Pointer to a handle to the string to be detached.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NStringWriter.h

Module: NStringWriter Unit


NStringWriter.h

NStringWriter.h
Functions Legend

Header file for the NStringWriter module.

Collapse Expand Functions
Name | Description
NStringWriterCreate | Creates a new NStringWriter.
NStringWriterCreateEx | Creates a new NStringWriter with specified capacity and growth delta.
NStringWriterCreateWithCapacity | Creates a new NStringWriter with specified capacity.
NStringWriterDetachString | Detaches the specified string from the specified string writer.


NSyncEvent Unit

NSyncEvent Unit
Functions Legend Macros

Cross platform synchronization primitive. It allows for threads to wait for event without consuming CPU. The other thread(s) would notify waiting thread(s) of the event by setting it to signalled state. See the NSyncEventCreate function for more details.

Collapse Expand Functions
Name | Description
NSyncEventCreate | Creates and initializes a sync event object.
NSyncEventCreateFromOSHandle | Creates a new NSyncEvent for the specified sync event handle.
NSyncEventGetOSHandle | Gets OS handle for the specified sync event.
NSyncEventSet | Post event to the waiting thread(s), i.e. make the event object signalled.
Collapse Expand Macros
Name | Description
NSyncEventReset | Resets the specified sync event.


NSyncEventCreate Function

NSyncEventCreate Function

Creates and initializes a sync event object.

C++
NResult N_API NSyncEventCreate(NBool manualReset, NBool initialState, HNSyncEvent * phSyncEvent);
Collapse Expand Parameters
Parameters | Description
NBool manualReset | [in] Should the event be of manual-reset type. Auto-reset event will be created if parameter is NFalse.
NBool initialState | [in] Initial state: NTrue - signalled, NFalse - nonsignalled.
HNSyncEvent * phSyncEvent | [out] Pointer to the variable that will receive the handle of the created object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

The NSyncEvent's state can be characterized by the flag, which can be set (NSyncEventSet), cleared (NSyncEventReset) or waited to be set (NWaitObjectWaitFor/NWaitObjectTimedWaitFor). The event will be delivered to expecting thread even if it is set to signalled state before expecting thread starts to wait.

Two kinds of NSyncEvent are possible: auto-reset and manual-reset. Auto-reset event is reset to nonsignalled state automatically when waiting thread gets the event. As a result the event is always delivered to only single expecting thread. If other waiting threads are present they would remain waiting until event is signalled again and delivered to single waiting thread.

Manual-reset event must to be manually reset to nonsignalled state. As result all the waiting threads will receive the event and continue execution. Also subsequent wait operations will complete immediately until the event is cleared with NSyncEventReset function.

Collapse Expand Notes

Note that event object doesn't buffer the events, ie. the set operation on already signalled event has no effect. Check NSemaphore for alternative synchronization object.

Container

File: NSyncEvent.h

Module: NSyncEvent Unit


NSyncEventCreateFromOSHandle Function

NSyncEventCreateFromOSHandle Function
See Also

Creates a new NSyncEvent for the specified sync event handle.

C++
NResult N_API NSyncEventCreateFromOSHandle(NHandle handle, NBool ownsHandle, HNSyncEvent * phSyncEvent);
Collapse Expand Parameters
Parameters | Description
NHandle handle | [in] A sync event handle for the sync event that the current NSyncEvent will encapsulate.
NBool ownsHandle | [in] NTrue if the sync event handle will be owned by this NSyncEvent; otherwise, NFalse.
HNSyncEvent * phSyncEvent | [out] A pointer to the created NSyncEvent.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand See Also

NSyncEventGetOSHandle

Container

File: NSyncEvent.h

Module: NSyncEvent Unit


NSyncEventGetOSHandle Function

NSyncEventGetOSHandle Function

Gets OS handle for the specified sync event.

C++
NResult N_API NSyncEventGetOSHandle(HNSyncEvent hSyncEvent, NHandle * phValue);
Collapse Expand Parameters
Parameters | Description
HNSyncEvent hSyncEvent | [in] A handle to NSyncEvent.
NHandle * phValue | [out] OS handle to a sync event.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSyncEvent.h

Module: NSyncEvent Unit


NSyncEventSet Function

NSyncEventSet Function

Post event to the waiting thread(s), i.e. make the event object signalled.

C++
NResult N_API NSyncEventSet(HNSyncEvent hSyncEvent);
Collapse Expand Parameters
Parameters | Description
HNSyncEvent hSyncEvent | [in] Handle of the sync event.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

The effect of this operation depends on event kind. For auto-reset event this would unblock at most single thread waiting for the event. For manual-reset event all waiting threads will resume untill the event flag is cleared with NSyncEventReset. See allso NSyncEventCreate

Collapse Expand Notes

The events are not buffered. If the NSyncEvent is already in signalled state, the operation has no effect. So if we have event of auto-reset kind and no threads were waiting for event, when it is set two times, only the first thread that will wait for event will continue uninterrupted. The second thread would block until event is set again. Consider using the NSemaphore where it is important to preserve count of events set.

Container

File: NSyncEvent.h

Module: NSyncEvent Unit


NSyncEventReset Macro

NSyncEventReset Macro

Resets the specified sync event.

C++
#define NSyncEventReset(hSyncEvent) NObjectReset(hSyncEvent)
Collapse Expand Parameters
Parameters | Description
hSyncEvent | [in] Handle to the sync event.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSyncEvent.h

Module: NSyncEvent Unit


NTextReader Unit

NTextReader Unit
Functions Legend Macros

Represents a reader that can read a sequential series of characters.

Collapse Expand Functions
Name | Description
NTextReaderGetNull | Retrieves a NTextReader with no data to read from.
NTextReaderPeekChar | Reads the next character without changing the state of the reader or the character source. Returns the next available character without actually reading it from the reader.
NTextReaderReadChar | Reads the next character from the text reader and advances the character position by one character.
NTextReaderReadChars | Reads a specified maximum number of characters from the current reader and writes the data to a buffer.
NTextReaderReadLine | Reads a line of characters from the text reader and returns the data as NString.
NTextReaderReadToEnd | Reads all characters from the current position to the end of the text reader and returns them as NString.
NTextReaderSynchronized | Creates a thread-safe wrapper around the specified NTextReader.
Collapse Expand Macros
Name | Description
NTextReaderPeekChar | Picks a Unicode (W) or ASCII (A) version of the NTextReaderPeekChar function.
NTextReaderReadChar | Picks a Unicode (W) or ASCII (A) version of the NTextReaderReadChar function.
NTextReaderReadChars | Picks a Unicode (W) or ASCII (A) version of the NTextReaderReadChars function.


NTextReaderGetNull Function

NTextReaderGetNull Function

Retrieves a NTextReader with no data to read from.

C++
NResult N_API NTextReaderGetNull(HNTextReader * phValue);
Collapse Expand Parameters
Parameters | Description
HNTextReader * phValue | [out] Pointer to a handle to the NTextReader with no data to read from.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextReader.h

Module: NTextReader Unit


NTextReaderPeekChar Function

NTextReaderPeekChar Function

Reads the next character without changing the state of the reader or the character source. Returns the next available character without actually reading it from the reader.

C++
NResult N_API NTextReaderPeekChar(HNTextReader hReader, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNTextReader hReader | [in] Handle to the NTextReader.
NInt * pValue | [out] Pointer to the integer representing the next character to be read.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextReader.h

Module: NTextReader Unit


NTextReaderReadChar Function

NTextReaderReadChar Function

Reads the next character from the text reader and advances the character position by one character.

C++
NResult N_API NTextReaderReadChar(HNTextReader hReader, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNTextReader hReader | [in] Handle to the NTextReader.
NInt * pValue | [out] Pointer to the next character from the text reader
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextReader.h

Module: NTextReader Unit


NTextReaderReadChars Function

NTextReaderReadChars Function

Reads a specified maximum number of characters from the current reader and writes the data to a buffer.

C++
NResult N_API NTextReaderReadChars(HNTextReader hReader, NChar * szBuffer, NInt count, NInt * pCharsRead);
Collapse Expand Parameters
Parameters | Description
HNTextReader hReader | [in] Handle to the NTextReader.
NChar * szBuffer | [out] Pointer to the buffer containing the characters read.
NInt count | [in] The maximum number of characters to read.
NInt * pCharsRead | [out] Pointer to the number of characters read.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextReader.h

Module: NTextReader Unit


NTextReaderReadLine Function

NTextReaderReadLine Function

Reads a line of characters from the text reader and returns the data as NString.

C++
NResult N_API NTextReaderReadLine(HNTextReader hReader, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNTextReader hReader | [in] Handle to the NTextReader.
HNString * phValue | [out] Pointer to a handle to NString containing the line of characters.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextReader.h

Module: NTextReader Unit


NTextReaderReadToEnd Function

NTextReaderReadToEnd Function

Reads all characters from the current position to the end of the text reader and returns them as NString.

C++
NResult N_API NTextReaderReadToEnd(HNTextReader hReader, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNTextReader hReader | [in] Handle to the NTextReader.
HNString * phValue | [out] Pointer to a handle to NString containing the characters.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextReader.h

Module: NTextReader Unit


NTextReaderSynchronized Function

NTextReaderSynchronized Function

Creates a thread-safe wrapper around the specified NTextReader.

C++
NResult N_API NTextReaderSynchronized(HNTextReader hReader, HNTextReader * phValue);
Collapse Expand Parameters
Parameters | Description
HNTextReader hReader | [in] Handle to the NTextReader.
HNTextReader * phValue | [out] Pointer to a handle to a NTextReader wrapper.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextReader.h

Module: NTextReader Unit


NTextReaderPeekChar Macro

NTextReaderPeekChar Macro

Picks a Unicode (W) or ASCII (A) version of the NTextReaderPeekChar function.

C++
#define NTextReaderPeekChar N_FUNC_AW(NTextReaderPeekChar)
Container

File: NTextReader.h

Module: NTextReader Unit


NTextReaderReadChar Macro

NTextReaderReadChar Macro

Picks a Unicode (W) or ASCII (A) version of the NTextReaderReadChar function.

C++
#define NTextReaderReadChar N_FUNC_AW(NTextReaderReadChar)
Container

File: NTextReader.h

Module: NTextReader Unit


NTextReaderReadChars Macro

NTextReaderReadChars Macro

Picks a Unicode (W) or ASCII (A) version of the NTextReaderReadChars function.

C++
#define NTextReaderReadChars N_FUNC_AW(NTextReaderReadChars)
Container

File: NTextReader.h

Module: NTextReader Unit


NTextWriter Unit

NTextWriter Unit
Functions Legend Macros

Represents a writer that can write a sequential series of characters.

Collapse Expand Functions
Name | Description
NTextWriterFlush | Clears all buffers for the specified writer and causes any buffered data to be written to the underlying device.
NTextWriterGetEncoding | Retrieves the encoding of the specified NTextWriter.
NTextWriterGetNewLine | Sets the line terminator string used by the current NTextWriter.
NTextWriterGetNull | Creates a NTextWriter with no backing store that can be written to, but not read from.
NTextWriterSetNewLine | Sets the line terminator string used by the current NTextWriter.
NTextWriterSynchronized | Creates a thread-safe wrapper around the specified NTextWriter.
NTextWriterWrite | Writes a character to the text string or stream.
NTextWriterWriteBoolean | Writes a Boolean to the text string or stream.
NTextWriterWriteBooleanLine | Writes a Boolean followed by a line terminator to the text string or stream.
NTextWriterWriteChar | Writes a character to the text string or stream.
NTextWriterWriteCharLine | Writes a character followed by a line terminator to the text string or stream.
NTextWriterWriteChars | Writes a character array to the text string or stream.
NTextWriterWriteCharsLine | Writes a character array followed by a line terminator to the text string or stream.
NTextWriterWriteDouble | Writes a double to the text string or stream.
NTextWriterWriteDoubleLine | Writes a double followed by a line terminator to the text string or stream.
NTextWriterWriteEmptyLine | Writes a line terminator to the text string or stream.
NTextWriterWriteFormat | Creates a format string with the specified parameters and writes it to the text string or stream.
NTextWriterWriteFormatLine | Creates a format string with the specified parameters and writes it followed by a line terminator to the text string or stream.
NTextWriterWriteFormatLineVA | Creates a format string with the specified arguments and writes it followed by a line terminator to the text string or stream.
NTextWriterWriteFormatVA | Creates a format string with the specified arguments and writes it to the text string or stream.
NTextWriterWriteInt32 | Writes a Int32 to the text string or stream.
NTextWriterWriteInt32Line | Writes a Int32 followed by a line terminator to the text string or stream.
NTextWriterWriteInt64 | Writes a Int64 to the text string or stream.
NTextWriterWriteInt64Line | Writes a Int64 followed by a line terminator to the text string or stream.
NTextWriterWriteLine | Writes a character followed by a line terminator to the text string or stream.
NTextWriterWriteObject | Writes an object to the text string or stream.
NTextWriterWriteObjectLine | Writes an object followed by a line terminator to the text string or stream.
NTextWriterWritePointer | Writes a pointer to the text string or stream.
NTextWriterWritePointerLine | Writes a pointer followed by a line terminator to the text string or stream.
NTextWriterWriteResult | Writes a NResult value to the text string or stream.
NTextWriterWriteResultLine | Writes a NResult value followed by a line terminator to the text string or stream.
NTextWriterWriteSSizeType | Writes a SSizeType to the text string or stream.
NTextWriterWriteSSizeTypeLine | Writes a SSizeType followed by a line terminator to the text string or stream.
NTextWriterWriteSingle | Writes a single to the text string or stream.
NTextWriterWriteSingleLine | Writes a single followed by a line terminator to the text string or stream.
NTextWriterWriteSizeType | Writes a SizeType to the text string or stream.
NTextWriterWriteSizeTypeLine | Writes a SizeType followed by a line terminator to the text string or stream.
NTextWriterWriteUInt32 | Writes a UInt32 to the text string or stream.
NTextWriterWriteUInt32Line | Writes a UInt32 followed by a line terminator to the text string or stream.
NTextWriterWriteUInt64 | Writes a UInt64 to the text string or stream.
NTextWriterWriteUInt64Line | Writes a UInt64 followed by a line terminator to the text string or stream.
NTextWriterWriteValue | Writes a value of specified type to the text string or stream.
NTextWriterWriteValueLine | Writes a value of specified type followed by a line terminator to the text string or stream.
NTextWriterWriteValueLineP | Writes a specified value followed by a line terminator to the text string or stream.
NTextWriterWriteValueP | Writes a specified value to the text string or stream.
Collapse Expand Macros
Name | Description
NTextWriterSetNewLine | Picks a Unicode (W) or ASCII (A) version of the NTextWriterSetNewLine function.
NTextWriterWrite | Picks a Unicode (W) or ASCII (A) version of the NTextWriterWrite function.
NTextWriterWriteChar | Picks a Unicode (W) or ASCII (A) version of the NTextWriterWriteChar function.
NTextWriterWriteCharLine | Picks a Unicode (W) or ASCII (A) version of the NTextWriterWriteCharLine function.
NTextWriterWriteChars | Picks a Unicode (W) or ASCII (A) version of the NTextWriterWriteChars function.
NTextWriterWriteCharsLine | Picks a Unicode (W) or ASCII (A) version of the NTextWriterWriteCharsLine function.
NTextWriterWriteFormat | Picks a Unicode (W) or ASCII (A) version of the NTextWriterWriteFormat function.
NTextWriterWriteFormatLine | Picks a Unicode (W) or ASCII (A) version of the NTextWriterWriteFormatLine function.
NTextWriterWriteFormatLineVA | Picks a Unicode (W) or ASCII (A) version of the NTextWriterWriteFormatLineVA function.
NTextWriterWriteFormatVA | Picks a Unicode (W) or ASCII (A) version of the NTextWriterWriteFormatVA function.
NTextWriterWriteLine | Picks a Unicode (W) or ASCII (A) version of the NTextWriterWriteLine function.


NTextWriterFlush Function

NTextWriterFlush Function

Clears all buffers for the specified writer and causes any buffered data to be written to the underlying device.

C++
NResult N_API NTextWriterFlush(HNTextWriter hWriter);
Collapse Expand Parameters
Parameters | Description
HNTextWriter hWriter | [in] Handle to the NTextWriter.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterGetEncoding Function

NTextWriterGetEncoding Function

Retrieves the encoding of the specified NTextWriter.

C++
NResult N_API NTextWriterGetEncoding(HNTextWriter hWriter, NEncoding * pValue);
Collapse Expand Parameters
Parameters | Description
HNTextWriter hWriter | [in] Handle to the NTextWriter.
NEncoding * pValue | [out] Pointer to the encoding value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterGetNewLine Function

NTextWriterGetNewLine Function

Sets the line terminator string used by the current NTextWriter.

C++
NResult N_API NTextWriterGetNewLine(HNTextWriter hWriter, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNTextWriter hWriter | [in] Handle to the NTextWriter.
HNString * phValue | [in] Pointer to a handle to the line terminator string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterGetNull Function

NTextWriterGetNull Function

Creates a NTextWriter with no backing store that can be written to, but not read from.

C++
NResult N_API NTextWriterGetNull(HNTextWriter * phValue);
Collapse Expand Parameters
Parameters | Description
HNTextWriter * phValue | [out] Pointer to a handle to the NTextWriter with no backing store that can be written to, but not read from..
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterSetNewLine Function

NTextWriterSetNewLine Function

Sets the line terminator string used by the current NTextWriter.

C++
NResult N_API NTextWriterSetNewLine(HNTextWriter hWriter, const NChar * szValue);
Collapse Expand Parameters
Parameters | Description
HNTextWriter hWriter | [in] Handle to the NTextWriter.
const NChar * szValue | [in] Pointer to new line terminator string value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterSynchronized Function

NTextWriterSynchronized Function

Creates a thread-safe wrapper around the specified NTextWriter.

C++
NResult N_API NTextWriterSynchronized(HNTextWriter hWriter, HNTextWriter * phValue);
Collapse Expand Parameters
Parameters | Description
HNTextWriter hWriter | [in] Handle to the NTextWriter.
HNTextWriter * phValue | [out] Pointer to a handle to the thread-safe wrapper.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWrite Function

NTextWriterWrite Function

Writes a character to the text string or stream.

C++
NResult N_API NTextWriterWrite(HNTextWriter hWriter, const NChar * szValue);
Collapse Expand Parameters
Parameters | Description
HNTextWriter hWriter | [in] Handle to the NTextWriter.
const NChar * szValue | [in] Pointer to the character to write to the text stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWriteBoolean Function

NTextWriterWriteBoolean Function

Writes a Boolean to the text string or stream.

C++
NResult N_API NTextWriterWriteBoolean(HNTextWriter hWriter, NBool value);
Collapse Expand Parameters
Parameters | Description
HNTextWriter hWriter | [in] Handle to the NTextWriter.
NBool value | [in] The Boolean to write to the text stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWriteBooleanLine Function

NTextWriterWriteBooleanLine Function

Writes a Boolean followed by a line terminator to the text string or stream.

C++
NResult N_API NTextWriterWriteBooleanLine(HNTextWriter hWriter, NBool value);
Collapse Expand Parameters
Parameters | Description
HNTextWriter hWriter | [in] Handle to the NTextWriter.
NBool value | [in] The Boolean to write to the text stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWriteChar Function

NTextWriterWriteChar Function

Writes a character to the text string or stream.

C++
NResult N_API NTextWriterWriteChar(HNTextWriter hWriter, NChar value);
Collapse Expand Parameters
Parameters | Description
HNTextWriter hWriter | [in] Handle to the NTextWriter.
NChar value | [in] Pointer to the character to write to the text stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWriteCharLine Function

NTextWriterWriteCharLine Function

Writes a character followed by a line terminator to the text string or stream.

C++
NResult N_API NTextWriterWriteCharLine(HNTextWriter hWriter, NChar value);
Collapse Expand Parameters
Parameters | Description
HNTextWriter hWriter | [in] Handle to the NTextWriter.
NChar value | [in] Pointer to the character to write to the text stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWriteChars Function

NTextWriterWriteChars Function

Writes a character array to the text string or stream.

C++
NResult N_API NTextWriterWriteChars(HNTextWriter hWriter, const NChar * arValue, NInt valueLength);
Collapse Expand Parameters
Parameters | Description
HNTextWriter hWriter | [in] Handle to the NTextWriter.
const NChar * arValue | [in] Pointer to the character array to write to the text stream.
NInt valueLength | [in] Length of the char array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWriteCharsLine Function

NTextWriterWriteCharsLine Function

Writes a character array followed by a line terminator to the text string or stream.

C++
NResult N_API NTextWriterWriteCharsLine(HNTextWriter hWriter, const NChar * arValue, NInt valueLength);
Collapse Expand Parameters
Parameters | Description
HNTextWriter hWriter | [in] Handle to the NTextWriter.
const NChar * arValue | [in] Pointer to the character array to write to the text stream.
NInt valueLength | [in] Length of the char array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWriteDouble Function

NTextWriterWriteDouble Function

Writes a double to the text string or stream.

C++
NResult N_API NTextWriterWriteDouble(HNTextWriter hWriter, NDouble value);
Collapse Expand Parameters
Parameters | Description
HNTextWriter hWriter | [in] Handle to the NTextWriter.
NDouble value | [in] The double to write to the text stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWriteDoubleLine Function

NTextWriterWriteDoubleLine Function

Writes a double followed by a line terminator to the text string or stream.

C++
NResult N_API NTextWriterWriteDoubleLine(HNTextWriter hWriter, NDouble value);
Collapse Expand Parameters
Parameters | Description
HNTextWriter hWriter | [in] Handle to the NTextWriter.
NDouble value | [in] The double to write to the text stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWriteEmptyLine Function

NTextWriterWriteEmptyLine Function

Writes a line terminator to the text string or stream.

C++
NResult N_API NTextWriterWriteEmptyLine(HNTextWriter hWriter);
Collapse Expand Parameters
Parameters | Description
HNTextWriter hWriter | [in] Handle to the NTextWriter.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWriteFormat Function

NTextWriterWriteFormat Function

Creates a format string with the specified parameters and writes it to the text string or stream.

C++
NResult N_API NTextWriterWriteFormat(HNTextWriter hWriter, const NChar * szFormat, ... multipleParameters);
Collapse Expand Parameters
Parameters | Description
HNTextWriter hWriter | [in] Handle to the NTextWriter.
const NChar * szFormat | [in] Pointer to composite format string.
... multipleParameters | [in] Format parameters.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWriteFormatLine Function

NTextWriterWriteFormatLine Function

Creates a format string with the specified parameters and writes it followed by a line terminator to the text string or stream.

C++
NResult N_API NTextWriterWriteFormatLine(HNTextWriter hWriter, const NChar * szFormat, ... multipleParameters);
Collapse Expand Parameters
Parameters | Description
HNTextWriter hWriter | [in] Handle to the NTextWriter.
const NChar * szFormat | [in] Pointer to composite format string.
... multipleParameters | [in] Format parameters.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWriteFormatLineVA Function

NTextWriterWriteFormatLineVA Function

Creates a format string with the specified arguments and writes it followed by a line terminator to the text string or stream.

C++
NResult N_API NTextWriterWriteFormatLineVA(HNTextWriter hWriter, const NChar * szFormat, va_list args);
Collapse Expand Parameters
Parameters | Description
HNTextWriter hWriter | [in] Handle to the NTextWriter.
const NChar * szFormat | [in] Pointer to composite format string.
va_list args | [in] Format arguments.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWriteFormatVA Function

NTextWriterWriteFormatVA Function

Creates a format string with the specified arguments and writes it to the text string or stream.

C++
NResult N_API NTextWriterWriteFormatVA(HNTextWriter hWriter, const NChar * szFormat, va_list args);
Collapse Expand Parameters
Parameters | Description
HNTextWriter hWriter | [in] Handle to the NTextWriter.
const NChar * szFormat | [in] Pointer to composite format string.
va_list args | [in] Format arguments.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWriteInt32 Function

NTextWriterWriteInt32 Function

Writes a Int32 to the text string or stream.

C++
NResult N_API NTextWriterWriteInt32(HNTextWriter hWriter, NInt value);
Collapse Expand Parameters
Parameters | Description
HNTextWriter hWriter | [in] Handle to the NTextWriter.
NInt value | [in] The Int32 to write to the text stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWriteInt32Line Function

NTextWriterWriteInt32Line Function

Writes a Int32 followed by a line terminator to the text string or stream.

C++
NResult N_API NTextWriterWriteInt32Line(HNTextWriter hWriter, NInt value);
Collapse Expand Parameters
Parameters | Description
HNTextWriter hWriter | [in] Handle to the NTextWriter.
NInt value | [in] The Int32 to write to the text stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWriteInt64 Function

NTextWriterWriteInt64 Function

Writes a Int64 to the text string or stream.

C++
NResult N_API NTextWriterWriteInt64(HNTextWriter hWriter, NLong value);
Collapse Expand Parameters
Parameters | Description
HNTextWriter hWriter | [in] Handle to the NTextWriter.
NLong value | [in] The Int64 to write to the text stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWriteInt64Line Function

NTextWriterWriteInt64Line Function

Writes a Int64 followed by a line terminator to the text string or stream.

C++
NResult N_API NTextWriterWriteInt64Line(HNTextWriter hWriter, NLong value);
Collapse Expand Parameters
Parameters | Description
HNTextWriter hWriter | [in] Handle to the NTextWriter.
NLong value | [in] The Int64 to write to the text stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWriteLine Function

NTextWriterWriteLine Function

Writes a character followed by a line terminator to the text string or stream.

C++
NResult N_API NTextWriterWriteLine(HNTextWriter hWriter, const NChar * szValue);
Collapse Expand Parameters
Parameters | Description
HNTextWriter hWriter | [in] Handle to the NTextWriter.
const NChar * szValue | [in] Pointer to the character to write to the text stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWriteObject Function

NTextWriterWriteObject Function

Writes an object to the text string or stream.

C++
NResult N_API NTextWriterWriteObject(HNTextWriter hWriter, HNObject hObject);
Collapse Expand Parameters
Parameters | Description
HNTextWriter hWriter | [in] Handle to the NTextWriter.
HNObject hObject | [in] Handle to the object to write to the text stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWriteObjectLine Function

NTextWriterWriteObjectLine Function

Writes an object followed by a line terminator to the text string or stream.

C++
NResult N_API NTextWriterWriteObjectLine(HNTextWriter hWriter, HNObject hObject);
Collapse Expand Parameters
Parameters | Description
HNTextWriter hWriter | [in] Handle to the NTextWriter.
HNObject hObject | [in] Handle to the object to write to the text stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWritePointer Function

NTextWriterWritePointer Function

Writes a pointer to the text string or stream.

C++
NResult N_API NTextWriterWritePointer(HNTextWriter hWriter, const void * value);
Collapse Expand Parameters
Parameters | Description
HNTextWriter hWriter | [in] Handle to the NTextWriter.
const void * value | [in] The pointer to write to the text stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWritePointerLine Function

NTextWriterWritePointerLine Function

Writes a pointer followed by a line terminator to the text string or stream.

C++
NResult N_API NTextWriterWritePointerLine(HNTextWriter hWriter, const void * value);
Collapse Expand Parameters
Parameters | Description
HNTextWriter hWriter | [in] Handle to the NTextWriter.
const void * value | [in] The pointer to write to the text stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWriteResult Function

NTextWriterWriteResult Function

Writes a NResult value to the text string or stream.

C++
NResult N_API NTextWriterWriteResult(HNTextWriter hWriter, NResult value);
Collapse Expand Parameters
Parameters | Description
HNTextWriter hWriter | [in] Handle to the NTextWriter.
NResult value | [in] The NResult to write to the text stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWriteResultLine Function

NTextWriterWriteResultLine Function

Writes a NResult value followed by a line terminator to the text string or stream.

C++
NResult N_API NTextWriterWriteResultLine(HNTextWriter hWriter, NResult value);
Collapse Expand Parameters
Parameters | Description
HNTextWriter hWriter | [in] Handle to the NTextWriter.
NResult value | [in] The NResult to write to the text stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWriteSSizeType Function

NTextWriterWriteSSizeType Function

Writes a SSizeType to the text string or stream.

C++
NResult N_API NTextWriterWriteSSizeType(HNTextWriter hWriter, NSSizeType value);
Collapse Expand Parameters
Parameters | Description
HNTextWriter hWriter | [in] Handle to the NTextWriter.
NSSizeType value | [in] The SSizeType to write to the text stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWriteSSizeTypeLine Function

NTextWriterWriteSSizeTypeLine Function

Writes a SSizeType followed by a line terminator to the text string or stream.

C++
NResult N_API NTextWriterWriteSSizeTypeLine(HNTextWriter hWriter, NSSizeType value);
Collapse Expand Parameters
Parameters | Description
HNTextWriter hWriter | [in] Handle to the NTextWriter.
NSSizeType value | [in] The SSizeType to write to the text stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWriteSingle Function

NTextWriterWriteSingle Function

Writes a single to the text string or stream.

C++
NResult N_API NTextWriterWriteSingle(HNTextWriter hWriter, NFloat value);
Collapse Expand Parameters
Parameters | Description
HNTextWriter hWriter | [in] Handle to the NTextWriter.
NFloat value | [in] The single to write to the text stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWriteSingleLine Function

NTextWriterWriteSingleLine Function

Writes a single followed by a line terminator to the text string or stream.

C++
NResult N_API NTextWriterWriteSingleLine(HNTextWriter hWriter, NFloat value);
Collapse Expand Parameters
Parameters | Description
HNTextWriter hWriter | [in] Handle to the NTextWriter.
NFloat value | [in] The single to write to the text stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWriteSizeType Function

NTextWriterWriteSizeType Function

Writes a SizeType to the text string or stream.

C++
NResult N_API NTextWriterWriteSizeType(HNTextWriter hWriter, NSizeType value);
Collapse Expand Parameters
Parameters | Description
HNTextWriter hWriter | [in] Handle to the NTextWriter.
NSizeType value | [in] The SizeType to write to the text stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWriteSizeTypeLine Function

NTextWriterWriteSizeTypeLine Function

Writes a SizeType followed by a line terminator to the text string or stream.

C++
NResult N_API NTextWriterWriteSizeTypeLine(HNTextWriter hWriter, NSizeType value);
Collapse Expand Parameters
Parameters | Description
HNTextWriter hWriter | [in] Handle to the NTextWriter.
NSizeType value | [in] The SizeType to write to the text stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWriteUInt32 Function

NTextWriterWriteUInt32 Function

Writes a UInt32 to the text string or stream.

C++
NResult N_API NTextWriterWriteUInt32(HNTextWriter hWriter, NUInt value);
Collapse Expand Parameters
Parameters | Description
HNTextWriter hWriter | [in] Handle to the NTextWriter.
NUInt value | [in] The UInt32 to write to the text stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWriteUInt32Line Function

NTextWriterWriteUInt32Line Function

Writes a UInt32 followed by a line terminator to the text string or stream.

C++
NResult N_API NTextWriterWriteUInt32Line(HNTextWriter hWriter, NUInt value);
Collapse Expand Parameters
Parameters | Description
HNTextWriter hWriter | [in] Handle to the NTextWriter.
NUInt value | [in] The UInt32 to write to the text stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWriteUInt64 Function

NTextWriterWriteUInt64 Function

Writes a UInt64 to the text string or stream.

C++
NResult N_API NTextWriterWriteUInt64(HNTextWriter hWriter, NULong value);
Collapse Expand Parameters
Parameters | Description
HNTextWriter hWriter | [in] Handle to the NTextWriter.
NULong value | [in] The UInt64 to write to the text stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWriteUInt64Line Function

NTextWriterWriteUInt64Line Function

Writes a UInt64 followed by a line terminator to the text string or stream.

C++
NResult N_API NTextWriterWriteUInt64Line(HNTextWriter hWriter, NULong value);
Collapse Expand Parameters
Parameters | Description
HNTextWriter hWriter | [in] Handle to the NTextWriter.
NULong value | [in] The UInt64 to write to the text stream.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWriteValue Function

NTextWriterWriteValue Function

Writes a value of specified type to the text string or stream.

C++
NResult N_API NTextWriterWriteValue(HNTextWriter hWriter, HNType hType, const void * pValue, NSizeType valueSize);
Collapse Expand Parameters
Parameters | Description
HNTextWriter hWriter | [in] Handle to the NTextWriter.
HNType hType | [in] Handle to the value type.
const void * pValue | [in] Pointer to the value to write to the text stream.
NSizeType valueSize | [in] Size of the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWriteValueLine Function

NTextWriterWriteValueLine Function

Writes a value of specified type followed by a line terminator to the text string or stream.

C++
NResult N_API NTextWriterWriteValueLine(HNTextWriter hWriter, HNType hType, const void * pValue, NSizeType valueSize);
Collapse Expand Parameters
Parameters | Description
HNTextWriter hWriter | [in] Handle to the NTextWriter.
HNType hType | [in] Handle to the value type.
const void * pValue | [in] Pointer to the value to write to the text stream.
NSizeType valueSize | [in] Size of the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWriteValueLineP Function

NTextWriterWriteValueLineP Function

Writes a specified value followed by a line terminator to the text string or stream.

C++
NResult N_API NTextWriterWriteValueLineP(HNTextWriter hWriter, NTypeOfProc pTypeOf, const void * pValue, NSizeType valueSize);
Collapse Expand Parameters
Parameters | Description
HNTextWriter hWriter | [in] Handle to the NTextWriter.
NTypeOfProc pTypeOf | _nt_
const void * pValue | [in] The value to write to the text stream.
NSizeType valueSize | _nt_
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWriteValueP Function

NTextWriterWriteValueP Function

Writes a specified value to the text string or stream.

C++
NResult N_API NTextWriterWriteValueP(HNTextWriter hWriter, NTypeOfProc pTypeOf, const void * pValue, NSizeType valueSize);
Collapse Expand Parameters
Parameters | Description
HNTextWriter hWriter | [in] Handle to the NTextWriter.
NTypeOfProc pTypeOf | [in] Type of the value.
const void * pValue | [in] The value to write to the text stream.
NSizeType valueSize | [in] Size of the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterSetNewLine Macro

NTextWriterSetNewLine Macro

Picks a Unicode (W) or ASCII (A) version of the NTextWriterSetNewLine function.

C++
#define NTextWriterSetNewLine N_FUNC_AW(NTextWriterSetNewLine)
Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWrite Macro

NTextWriterWrite Macro

Picks a Unicode (W) or ASCII (A) version of the NTextWriterWrite function.

C++
#define NTextWriterWrite N_FUNC_AW(NTextWriterWrite)
Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWriteChar Macro

NTextWriterWriteChar Macro

Picks a Unicode (W) or ASCII (A) version of the NTextWriterWriteChar function.

C++
#define NTextWriterWriteChar N_FUNC_AW(NTextWriterWriteChar)
Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWriteCharLine Macro

NTextWriterWriteCharLine Macro

Picks a Unicode (W) or ASCII (A) version of the NTextWriterWriteCharLine function.

C++
#define NTextWriterWriteCharLine N_FUNC_AW(NTextWriterWriteCharLine)
Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWriteChars Macro

NTextWriterWriteChars Macro

Picks a Unicode (W) or ASCII (A) version of the NTextWriterWriteChars function.

C++
#define NTextWriterWriteChars N_FUNC_AW(NTextWriterWriteChars)
Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWriteCharsLine Macro

NTextWriterWriteCharsLine Macro

Picks a Unicode (W) or ASCII (A) version of the NTextWriterWriteCharsLine function.

C++
#define NTextWriterWriteCharsLine N_FUNC_AW(NTextWriterWriteCharsLine)
Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWriteFormat Macro

NTextWriterWriteFormat Macro

Picks a Unicode (W) or ASCII (A) version of the NTextWriterWriteFormat function.

C++
#define NTextWriterWriteFormat N_FUNC_AW(NTextWriterWriteFormat)
Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWriteFormatLine Macro

NTextWriterWriteFormatLine Macro

Picks a Unicode (W) or ASCII (A) version of the NTextWriterWriteFormatLine function.

C++
#define NTextWriterWriteFormatLine N_FUNC_AW(NTextWriterWriteFormatLine)
Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWriteFormatLineVA Macro

NTextWriterWriteFormatLineVA Macro

Picks a Unicode (W) or ASCII (A) version of the NTextWriterWriteFormatLineVA function.

C++
#define NTextWriterWriteFormatLineVA N_FUNC_AW(NTextWriterWriteFormatLineVA)
Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWriteFormatVA Macro

NTextWriterWriteFormatVA Macro

Picks a Unicode (W) or ASCII (A) version of the NTextWriterWriteFormatVA function.

C++
#define NTextWriterWriteFormatVA N_FUNC_AW(NTextWriterWriteFormatVA)
Container

File: NTextWriter.h

Module: NTextWriter Unit


NTextWriterWriteLine Macro

NTextWriterWriteLine Macro

Picks a Unicode (W) or ASCII (A) version of the NTextWriterWriteLine function.

C++
#define NTextWriterWriteLine N_FUNC_AW(NTextWriterWriteLine)
Container

File: NTextWriter.h

Module: NTextWriter Unit


NThread Unit

NThread Unit
Files Functions Legend

Cross platform threading.

Collapse Expand Files
Name | Description
NThread.h | Header file for the NThread unit.
Collapse Expand Functions
Name | Description
NThreadCreate | Execute function in parallel in new thread.
NThreadCreateFromOSHandle | Creates a new NThread for the specified thread handle.
NThreadCreateParameterized | Execute function in parallel in new thread with specified additional parameters.
NThreadGetCurrent | Gets the currently running thread.
NThreadGetCurrentId | Gets the identifier of the currently running thread.
NThreadGetId | Gets the identifier of a specified NThread.
NThreadGetOSHandle | Gets OS handle for the specified thread.
NThreadJoin | Suspend the execution of current thread until the given thread terminates.
NThreadSleep | Suspend the execution of current thread for some time.


NThreadCreate Function

NThreadCreate Function
NThread.h

Execute function in parallel in new thread.

C++
NResult N_API NThreadCreate(NThreadStartProc pThreadStart, void * pThreadStartParam, HNThread * phThread);
Collapse Expand Parameters
Parameters | Description
NThreadStartProc pThreadStart | [in] Pointer to a function that will be executed in new thread.
void * pThreadStartParam | [in] Parameter that will be passed to pThreadStart function.
HNThread * phThread | [out] Pointer to a variable that will receive handle of the created thread.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NThread.h

Module: NThread Unit


NThreadCreateFromOSHandle Function

NThreadCreateFromOSHandle Function
NThread.h See Also

Creates a new NThread for the specified thread handle.

C++
NResult N_API NThreadCreateFromOSHandle(NHandle handle, NBool ownsHandle, HNThread * phThread);
Collapse Expand Parameters
Parameters | Description
NHandle handle | [in] A thread handle for the thread that the current NThread will encapsulate.
NBool ownsHandle | [in] NTrue if the thread handle will be owned by this NThread; otherwise, NFalse.
HNThread * phThread | [out] A pointer to the created NThread.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand See Also

NThreadGetOSHandle

Container

File: NThread.h

Module: NThread Unit


NThreadCreateParameterized Function

NThreadCreateParameterized Function
NThread.h

Execute function in parallel in new thread with specified additional parameters.

C++
NResult N_API NThreadCreateParameterized(NParameterizedThreadStartProc pThreadStart, void * pThreadStartParam, HNObject hParameter, HNThread * phThread);
Collapse Expand Parameters
Parameters | Description
NParameterizedThreadStartProc pThreadStart | [in] A thread handle for the thread that the current NThread will encapsulate.
void * pThreadStartParam | [in] Parameter that will be passed to pThreadStart function.
HNObject hParameter | [in] Additional parameters.
HNThread * phThread | [out] Pointer to a variable that will receive handle of the created thread.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NThread.h

Module: NThread Unit


NThreadGetCurrent Function

NThreadGetCurrent Function
NThread.h

Gets the currently running thread.

C++
NResult N_API NThreadGetCurrent(HNThread * phValue);
Collapse Expand Parameters
Parameters | Description
HNThread * phValue | [out] A pointer to the currently running thread.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

NObjectUnref shall be called on returned objects when they are no longer used to prevent memory leaks.

Container

File: NThread.h

Module: NThread Unit


NThreadGetCurrentId Function

NThreadGetCurrentId Function
NThread.h

Gets the identifier of the currently running thread.

C++
NResult N_API NThreadGetCurrentId(NSizeType * pValue);
Collapse Expand Parameters
Parameters | Description
NSizeType * pValue | [out] A pointer to the identifier of the currently running thread.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NThread.h

Module: NThread Unit


NThreadGetId Function

NThreadGetId Function
NThread.h

Gets the identifier of a specified NThread.

C++
NResult N_API NThreadGetId(HNThread hThread, NSizeType * pValue);
Collapse Expand Parameters
Parameters | Description
HNThread hThread | [in] A handle to NThread.
NSizeType * pValue | [out] A pointer to the identifier of NThread.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NThread.h

Module: NThread Unit


NThreadGetOSHandle Function

NThreadGetOSHandle Function
NThread.h

Gets OS handle for the specified thread.

C++
NResult N_API NThreadGetOSHandle(HNThread hThread, NHandle * phValue);
Collapse Expand Parameters
Parameters | Description
HNThread hThread | [in] A handle to NThread.
NHandle * phValue | [out] OS handle to a thread.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NThread.h

Module: NThread Unit


NThreadJoin Function

NThreadJoin Function
NThread.h

Suspend the execution of current thread until the given thread terminates.

C++
NResult N_API NThreadJoin(HNThread hThread);
Collapse Expand Parameters
Parameters | Description
HNThread hThread | [in] Handle of the thread to wait for.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NThread.h

Module: NThread Unit


NThreadSleep Function

NThreadSleep Function
NThread.h

Suspend the execution of current thread for some time.

C++
NResult N_API NThreadSleep(NInt milliseconds);
Collapse Expand Parameters
Parameters | Description
NInt milliseconds | [in] Number of milliseconds to wait before the calling thread can continue.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NThread.h

Module: NThread Unit


NThread.h

NThread.h
Functions Legend

Header file for the NThread unit.

Collapse Expand Functions
Name | Description
NThreadCreate | Execute function in parallel in new thread.
NThreadCreateFromOSHandle | Creates a new NThread for the specified thread handle.
NThreadCreateParameterized | Execute function in parallel in new thread with specified additional parameters.
NThreadGetCurrent | Gets the currently running thread.
NThreadGetCurrentId | Gets the identifier of the currently running thread.
NThreadGetId | Gets the identifier of a specified NThread.
NThreadGetOSHandle | Gets OS handle for the specified thread.
NThreadJoin | Suspend the execution of current thread until the given thread terminates.
NThreadSleep | Suspend the execution of current thread for some time.


NTimeSpan Unit

NTimeSpan Unit
Functions Legend Macros Types

Represents a time interval.

C++
typedef NTimeSpan_ NTimeSpan;
Collapse Expand Functions
Name | Description
NTimeSpanAdd | Adds two TimeSpan instances.
NTimeSpanCompare | Compares two instances of TimeSpan and returns an indication of their relative values.
NTimeSpanCreate | Initializes a new instance of NTimeSpan structure.
NTimeSpanCreateFromDays | Initializes a new instance of NTimeSpan structure with the number of days only specified.
NTimeSpanCreateFromHours | Initializes a new instance of NTimeSpan structure with the number of hours only specified.
NTimeSpanCreateFromMilliseconds | Initializes a new instance of NTimeSpan structure with the number of milliseconds only specified.
NTimeSpanCreateFromMinutes | Initializes a new instance of NTimeSpan structure with the number of minutes only specified.
NTimeSpanCreateFromSeconds | Initializes a new instance of NTimeSpan structure with the number of seconds only specified.
NTimeSpanCreateFromTicks | Initializes a new instance of NTimeSpan structure with the specified number of timer ticks.
NTimeSpanDecode | Decodes the specified TimeSpan instance.
NTimeSpanDuration | Returns a new TimeSpan object whose value is the absolute value of the current TimeSpan object.
NTimeSpanGetDays | Gets the days component of the specified TimeSpan.
NTimeSpanGetHours | Gets the hours component of the specified TimeSpan.
NTimeSpanGetMilliseconds | Gets the milliseconds component of the specified TimeSpan.
NTimeSpanGetMinutes | Gets the minutes component of the specified TimeSpan.
NTimeSpanGetSeconds | Gets the seconds component of the specified TimeSpan.
NTimeSpanGetTicks | Gets the number of ticks that represent the value of the specified TimeSpan instance.
NTimeSpanGetTotalDays | Gets the value of the specified TimeSpan instance expressed in whole and fractional days.
NTimeSpanGetTotalHours | Gets the value of the specified TimeSpan instance expressed in whole and fractional hours.
NTimeSpanGetTotalMilliseconds | Gets the value of the specified TimeSpan instance expressed in whole and fractional milliseconds.
NTimeSpanGetTotalMinutes | Gets the value of the specified TimeSpan instance expressed in whole and fractional minutes.
NTimeSpanGetTotalSeconds | Gets the value of the specified TimeSpan instance expressed in whole and fractional seconds.
NTimeSpanIsTimeValid | Checks whether the specified time values are valid.
NTimeSpanIsValid | Checks whether the specified TimeSpan values are valid.
NTimeSpanNegate | Returns a new TimeSpan object whose value is the negated value of the specified instance.
NTimeSpanSubtract | Subtracts one TimeSpan instance from another.
NTimeSpanToString | Gets a string representation of the specified TimeSpan instance.
Collapse Expand Macros
Name | Description
NTimeSpanToString | Picks a Unicode (W) or ASCII (A) version of the NTimeSpanToString function.
N_TIME_SPAN_MAX | Maximum TimeSpan value.
N_TIME_SPAN_MIN | Minimum TimeSpan value.
N_TIME_SPAN_TICKS_PER_DAY | Number of timer ticks in one day.
N_TIME_SPAN_TICKS_PER_HOUR | Number of timer ticks in one hour.
N_TIME_SPAN_TICKS_PER_MILLISECOND | Number of timer ticks in one millisecond.
N_TIME_SPAN_TICKS_PER_MINUTE | Number of timer ticks in one minute.
N_TIME_SPAN_TICKS_PER_SECOND | Number of timer ticks in one second.
Collapse Expand Types
Name | Description
NTimeSpan_ | The TimeSpan instance.
Container

File: NTimeSpan.h

Module: NTimeSpan Unit


NTimeSpanAdd Function

NTimeSpanAdd Function

Adds two TimeSpan instances.

C++
NResult N_API NTimeSpanAdd(NTimeSpan_ value1, NTimeSpan_ value2, NTimeSpan_ * pResult);
Collapse Expand Parameters
Parameters | Description
NTimeSpan_ value1 | [in] The first TimeSpan instance.
NTimeSpan_ value2 | [in] The second TimeSpan instance.
NTimeSpan_ * pResult | [out] The resulting TimeSpan instance.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTimeSpan.h

Module: NTimeSpan Unit


NTimeSpanCompare Function

NTimeSpanCompare Function

Compares two instances of TimeSpan and returns an indication of their relative values.

C++
NResult N_API NTimeSpanCompare(NTimeSpan_ value1, NTimeSpan_ value2, NInt * pResult);
Collapse Expand Parameters
Parameters | Description
NTimeSpan_ value1 | [in] The first TimeSpan instance.
NTimeSpan_ value2 | [in] The second TimeSpan instance.
NInt * pResult | [out] Pointer to an integer indicating the relative values of the instances.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTimeSpan.h

Module: NTimeSpan Unit


NTimeSpanCreate Function

NTimeSpanCreate Function

Initializes a new instance of NTimeSpan structure.

C++
NResult N_API NTimeSpanCreate(NInt days, NInt hours, NInt minutes, NInt seconds, NInt milliseconds, NTimeSpan_ * pTimeSpan);
Collapse Expand Parameters
Parameters | Description
NInt days | [in] The days value.
NInt hours | [in] The hours value.
NInt minutes | [in] The minutes value.
NInt seconds | [in] The seconds value.
NInt milliseconds | [in] The milliseconds value.
NTimeSpan_ * pTimeSpan | [out] Pointer to the new instance of NTimeSpan structure.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTimeSpan.h

Module: NTimeSpan Unit


NTimeSpanCreateFromDays Function

NTimeSpanCreateFromDays Function

Initializes a new instance of NTimeSpan structure with the number of days only specified.

C++
NResult N_API NTimeSpanCreateFromDays(NDouble value, NTimeSpan_ * pTimeSpan);
Collapse Expand Parameters
Parameters | Description
NDouble value | [in] The days value.
NTimeSpan_ * pTimeSpan | [out] Pointer to the new instance of NTimeSpan structure.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTimeSpan.h

Module: NTimeSpan Unit


NTimeSpanCreateFromHours Function

NTimeSpanCreateFromHours Function

Initializes a new instance of NTimeSpan structure with the number of hours only specified.

C++
NResult N_API NTimeSpanCreateFromHours(NDouble value, NTimeSpan_ * pTimeSpan);
Collapse Expand Parameters
Parameters | Description
NDouble value | [in] The hours value.
NTimeSpan_ * pTimeSpan | [out] Pointer to the new instance of NTimeSpan structure.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTimeSpan.h

Module: NTimeSpan Unit


NTimeSpanCreateFromMilliseconds Function

NTimeSpanCreateFromMilliseconds Function

Initializes a new instance of NTimeSpan structure with the number of milliseconds only specified.

C++
NResult N_API NTimeSpanCreateFromMilliseconds(NDouble value, NTimeSpan_ * pTimeSpan);
Collapse Expand Parameters
Parameters | Description
NDouble value | [in] The milliseconds value.
NTimeSpan_ * pTimeSpan | [out] Pointer to the new instance of NTimeSpan structure.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTimeSpan.h

Module: NTimeSpan Unit


NTimeSpanCreateFromMinutes Function

NTimeSpanCreateFromMinutes Function

Initializes a new instance of NTimeSpan structure with the number of minutes only specified.

C++
NResult N_API NTimeSpanCreateFromMinutes(NDouble value, NTimeSpan_ * pTimeSpan);
Collapse Expand Parameters
Parameters | Description
NDouble value | [in] The minutes value.
NTimeSpan_ * pTimeSpan | [out] Pointer to the new instance of NTimeSpan structure.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTimeSpan.h

Module: NTimeSpan Unit


NTimeSpanCreateFromSeconds Function

NTimeSpanCreateFromSeconds Function

Initializes a new instance of NTimeSpan structure with the number of seconds only specified.

C++
NResult N_API NTimeSpanCreateFromSeconds(NDouble value, NTimeSpan_ * pTimeSpan);
Collapse Expand Parameters
Parameters | Description
NDouble value | [in] The seconds value.
NTimeSpan_ * pTimeSpan | [out] Pointer to the new instance of NTimeSpan structure.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTimeSpan.h

Module: NTimeSpan Unit


NTimeSpanCreateFromTicks Function

NTimeSpanCreateFromTicks Function

Initializes a new instance of NTimeSpan structure with the specified number of timer ticks.

C++
NResult N_API NTimeSpanCreateFromTicks(NLong value, NTimeSpan_ * pTimeSpan);
Collapse Expand Parameters
Parameters | Description
NLong value | [in] The number of timer ticks.
NTimeSpan_ * pTimeSpan | [out] Pointer to the new instance of NTimeSpan structure.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTimeSpan.h

Module: NTimeSpan Unit


NTimeSpanDecode Function

NTimeSpanDecode Function

Decodes the specified TimeSpan instance.

C++
NResult N_API NTimeSpanDecode(NTimeSpan_ timeSpan, NInt * pDays, NInt * pHours, NInt * pMinutes, NInt * pSeconds, NInt * pMilliseconds);
Collapse Expand Parameters
Parameters | Description
NTimeSpan_ timeSpan | [in] The TimeSpan instance to be decoded.
NInt * pDays | [out] Pointer to the days value.
NInt * pHours | [out] Pointer to the hours value.
NInt * pMinutes | [out] Pointer to the minutes value.
NInt * pSeconds | [out] Pointer to the seconds value.
NInt * pMilliseconds | [out] Pointer to the milliseconds value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTimeSpan.h

Module: NTimeSpan Unit


NTimeSpanDuration Function

NTimeSpanDuration Function

Returns a new TimeSpan object whose value is the absolute value of the current TimeSpan object.

C++
NResult N_API NTimeSpanDuration(NTimeSpan_ value, NTimeSpan_ * pResult);
Collapse Expand Parameters
Parameters | Description
NTimeSpan_ value | [in] The original TimeSpan instance.
NTimeSpan_ * pResult | [out] Pointer to the new TimeSpan representing the absolute value of the original TimeSpan.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTimeSpan.h

Module: NTimeSpan Unit


NTimeSpanGetDays Function

NTimeSpanGetDays Function

Gets the days component of the specified TimeSpan.

C++
NResult N_API NTimeSpanGetDays(NTimeSpan_ timeSpan, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
NTimeSpan_ timeSpan | [in] The TimeSpan instance.
NInt * pValue | [out] Pointer to the days value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTimeSpan.h

Module: NTimeSpan Unit


NTimeSpanGetHours Function

NTimeSpanGetHours Function

Gets the hours component of the specified TimeSpan.

C++
NResult N_API NTimeSpanGetHours(NTimeSpan_ timeSpan, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
NTimeSpan_ timeSpan | [in] The TimeSpan instance.
NInt * pValue | [out] Pointer to the hours value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTimeSpan.h

Module: NTimeSpan Unit


NTimeSpanGetMilliseconds Function

NTimeSpanGetMilliseconds Function

Gets the milliseconds component of the specified TimeSpan.

C++
NResult N_API NTimeSpanGetMilliseconds(NTimeSpan_ timeSpan, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
NTimeSpan_ timeSpan | [in] The TimeSpan instance.
NInt * pValue | [out] Pointer to the milliseconds value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTimeSpan.h

Module: NTimeSpan Unit


NTimeSpanGetMinutes Function

NTimeSpanGetMinutes Function

Gets the minutes component of the specified TimeSpan.

C++
NResult N_API NTimeSpanGetMinutes(NTimeSpan_ timeSpan, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
NTimeSpan_ timeSpan | [in] The TimeSpan instance.
NInt * pValue | [out] Pointer to the minutes value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTimeSpan.h

Module: NTimeSpan Unit


NTimeSpanGetSeconds Function

NTimeSpanGetSeconds Function

Gets the seconds component of the specified TimeSpan.

C++
NResult N_API NTimeSpanGetSeconds(NTimeSpan_ timeSpan, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
NTimeSpan_ timeSpan | [in] The TimeSpan instance.
NInt * pValue | [out] Pointer to the seconds value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTimeSpan.h

Module: NTimeSpan Unit


NTimeSpanGetTicks Function

NTimeSpanGetTicks Function

Gets the number of ticks that represent the value of the specified TimeSpan instance.

C++
NResult N_API NTimeSpanGetTicks(NTimeSpan_ timeSpan, NLong * pValue);
Collapse Expand Parameters
Parameters | Description
NTimeSpan_ timeSpan | [in] The TimeSpan instance.
NLong * pValue | [out] Pointer to the number of ticks.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTimeSpan.h

Module: NTimeSpan Unit


NTimeSpanGetTotalDays Function

NTimeSpanGetTotalDays Function

Gets the value of the specified TimeSpan instance expressed in whole and fractional days.

C++
NResult N_API NTimeSpanGetTotalDays(NTimeSpan_ timeSpan, NDouble * pValue);
Collapse Expand Parameters
Parameters | Description
NTimeSpan_ timeSpan | [in] The TimeSpan instance.
NDouble * pValue | [out] Pointer to the number of days.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTimeSpan.h

Module: NTimeSpan Unit


NTimeSpanGetTotalHours Function

NTimeSpanGetTotalHours Function

Gets the value of the specified TimeSpan instance expressed in whole and fractional hours.

C++
NResult N_API NTimeSpanGetTotalHours(NTimeSpan_ timeSpan, NDouble * pValue);
Collapse Expand Parameters
Parameters | Description
NTimeSpan_ timeSpan | [in] The TimeSpan instance.
NDouble * pValue | [out] Pointer to the number of hours.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTimeSpan.h

Module: NTimeSpan Unit


NTimeSpanGetTotalMilliseconds Function

NTimeSpanGetTotalMilliseconds Function

Gets the value of the specified TimeSpan instance expressed in whole and fractional milliseconds.

C++
NResult N_API NTimeSpanGetTotalMilliseconds(NTimeSpan_ timeSpan, NDouble * pValue);
Collapse Expand Parameters
Parameters | Description
NTimeSpan_ timeSpan | [in] The TimeSpan instance.
NDouble * pValue | [out] Pointer to the number of milliseconds.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTimeSpan.h

Module: NTimeSpan Unit


NTimeSpanGetTotalMinutes Function

NTimeSpanGetTotalMinutes Function

Gets the value of the specified TimeSpan instance expressed in whole and fractional minutes.

C++
NResult N_API NTimeSpanGetTotalMinutes(NTimeSpan_ timeSpan, NDouble * pValue);
Collapse Expand Parameters
Parameters | Description
NTimeSpan_ timeSpan | [in] The TimeSpan instance.
NDouble * pValue | [out] Pointer to the number of minutes.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTimeSpan.h

Module: NTimeSpan Unit


NTimeSpanGetTotalSeconds Function

NTimeSpanGetTotalSeconds Function

Gets the value of the specified TimeSpan instance expressed in whole and fractional seconds.

C++
NResult N_API NTimeSpanGetTotalSeconds(NTimeSpan_ timeSpan, NDouble * pValue);
Collapse Expand Parameters
Parameters | Description
NTimeSpan_ timeSpan | [in] The TimeSpan instance.
NDouble * pValue | [out] Pointer to the number of seconds.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTimeSpan.h

Module: NTimeSpan Unit


NTimeSpanIsTimeValid Function

NTimeSpanIsTimeValid Function

Checks whether the specified time values are valid.

C++
NBool N_API NTimeSpanIsTimeValid(NInt days, NInt hours, NInt minutes, NInt seconds, NInt milliseconds);
Collapse Expand Parameters
Parameters | Description
NInt days | [in] The days value.
NInt hours | [in] The hours value.
NInt minutes | [in] The minutes value.
NInt seconds | [in] The seconds value.
NInt milliseconds | [in] The milliseconds value.
Collapse Expand Returns

NTrue if the time is valid; else NFalse.

Container

File: NTimeSpan.h

Module: NTimeSpan Unit


NTimeSpanIsValid Function

NTimeSpanIsValid Function

Checks whether the specified TimeSpan values are valid.

C++
NBool N_API NTimeSpanIsValid(NTimeSpan_ value);
Collapse Expand Parameters
Parameters | Description
NTimeSpan_ value | [in] The TimeSpan to be checked.
Collapse Expand Returns

NTrue if the TimeSpan is valid; else NFalse.

Container

File: NTimeSpan.h

Module: NTimeSpan Unit


NTimeSpanNegate Function

NTimeSpanNegate Function

Returns a new TimeSpan object whose value is the negated value of the specified instance.

C++
NResult N_API NTimeSpanNegate(NTimeSpan_ value, NTimeSpan_ * pResult);
Collapse Expand Parameters
Parameters | Description
NTimeSpan_ value | [in] The original TimeSpan instance.
NTimeSpan_ * pResult | [out] Pointer to the negative TimeSpan instance.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTimeSpan.h

Module: NTimeSpan Unit


NTimeSpanSubtract Function

NTimeSpanSubtract Function

Subtracts one TimeSpan instance from another.

C++
NResult N_API NTimeSpanSubtract(NTimeSpan_ value1, NTimeSpan_ value2, NTimeSpan_ * pResult);
Collapse Expand Parameters
Parameters | Description
NTimeSpan_ value1 | [in] The first TimeSpan instance.
NTimeSpan_ value2 | [in] The second TimeSpan instance.
NTimeSpan_ * pResult | [out] The resulting TimeSpan instance.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTimeSpan.h

Module: NTimeSpan Unit


NTimeSpanToString Function

NTimeSpanToString Function

Gets a string representation of the specified TimeSpan instance.

C++
NResult N_API NTimeSpanToString(NTimeSpan value, const NChar * szFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
NTimeSpan value | [in] The TimeSpan instance.
const NChar * szFormat | [in] Pointer to format string.
HNString * phValue | [out] Pointer to a handle to the string representing the TimeSpan.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTimeSpan.h

Module: NTimeSpan Unit


NTimeSpan_ Type

NTimeSpan_ Type

The TimeSpan instance.

C++
typedef NLong NTimeSpan_;
Container

File: NTimeSpan.h

Module: NTimeSpan Unit


NTimeSpanToString Macro

NTimeSpanToString Macro

Picks a Unicode (W) or ASCII (A) version of the NTimeSpanToString function.

C++
#define NTimeSpanToString N_FUNC_AW(NTimeSpanToString)
Container

File: NTimeSpan.h

Module: NTimeSpan Unit


N_TIME_SPAN_MAX Macro

N_TIME_SPAN_MAX Macro

Maximum TimeSpan value.

C++
#define N_TIME_SPAN_MAX N_LONG_MAX
Container

File: NTimeSpan.h

Module: NTimeSpan Unit


N_TIME_SPAN_MIN Macro

N_TIME_SPAN_MIN Macro

Minimum TimeSpan value.

C++
#define N_TIME_SPAN_MIN N_LONG_MIN
Container

File: NTimeSpan.h

Module: NTimeSpan Unit


N_TIME_SPAN_TICKS_PER_DAY Macro

N_TIME_SPAN_TICKS_PER_DAY Macro

Number of timer ticks in one day.

C++
#define N_TIME_SPAN_TICKS_PER_DAY 864000000000LL
Container

File: NTimeSpan.h

Module: NTimeSpan Unit


N_TIME_SPAN_TICKS_PER_HOUR Macro

N_TIME_SPAN_TICKS_PER_HOUR Macro

Number of timer ticks in one hour.

C++
#define N_TIME_SPAN_TICKS_PER_HOUR 36000000000LL
Container

File: NTimeSpan.h

Module: NTimeSpan Unit


N_TIME_SPAN_TICKS_PER_MILLISECOND Macro

N_TIME_SPAN_TICKS_PER_MILLISECOND Macro

Number of timer ticks in one millisecond.

C++
#define N_TIME_SPAN_TICKS_PER_MILLISECOND 10000LL
Container

File: NTimeSpan.h

Module: NTimeSpan Unit


N_TIME_SPAN_TICKS_PER_MINUTE Macro

N_TIME_SPAN_TICKS_PER_MINUTE Macro

Number of timer ticks in one minute.

C++
#define N_TIME_SPAN_TICKS_PER_MINUTE 600000000LL
Container

File: NTimeSpan.h

Module: NTimeSpan Unit


N_TIME_SPAN_TICKS_PER_SECOND Macro

N_TIME_SPAN_TICKS_PER_SECOND Macro

Number of timer ticks in one second.

C++
#define N_TIME_SPAN_TICKS_PER_SECOND 10000000LL
Container

File: NTimeSpan.h

Module: NTimeSpan Unit


NTls Unit

NTls Unit
Functions Legend

Represents Thread Local Storage.

Collapse Expand Functions
Name | Description
NTlsCreate | Creates a new Thread Local Storage.
NTlsCreateForObject | Creates a new Thread Local Storage for the current object.
NTlsFree | Release the dynamic memory before the thread returns.
NTlsGetObject | Retrieves the object associated with the specified Thread Local Storage.
NTlsGetValue | Retrieves the value of the specified Thread Local Storage.
NTlsSetObject | Sets the object for the specified Thread Local Storage.
NTlsSetValue | Sets the Thread Local Storage value.
Collapse Expand Variables
Name | Description
pValue | Thread Local Storage value.


NTlsCreate Function

NTlsCreate Function

Creates a new Thread Local Storage.

C++
NResult N_API NTlsCreate(NTlsDisposeProc pDispose, HNTls * pHTls);
Collapse Expand Parameters
Parameters | Description
NTlsDisposeProc pDispose | [in] Pointer to the NTls dispose procedure.
HNTls * pHTls | [out] Pointer to a handle to the new NTls.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTls.h

Module: NTls Unit


NTlsCreateForObject Function

NTlsCreateForObject Function

Creates a new Thread Local Storage for the current object.

C++
NResult N_API NTlsCreateForObject(HNTls * phTls);
Collapse Expand Parameters
Parameters | Description
HNTls * phTls | [out] Pointer to a handle to the new NTls.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTls.h

Module: NTls Unit


NTlsFree Function

NTlsFree Function

Release the dynamic memory before the thread returns.

C++
NResult N_API NTlsFree(HNTls hTls);
Collapse Expand Parameters
Parameters | Description
HNTls hTls | [in] Handle to the NTls.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTls.h

Module: NTls Unit


NTlsGetObject Function

NTlsGetObject Function

Retrieves the object associated with the specified Thread Local Storage.

C++
NResult N_API NTlsGetObject(HNTls hTls, HNObject * phValue);
Collapse Expand Parameters
Parameters | Description
HNTls hTls | [in] Handle to the NTls.
HNObject * phValue | [out] Pointer to a handle to the NObject.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTls.h

Module: NTls Unit


NTlsGetValue Function

NTlsGetValue Function

Retrieves the value of the specified Thread Local Storage.

C++
NResult N_API NTlsGetValue(HNTls hTls, void * * ppValue);
Collapse Expand Parameters
Parameters | Description
HNTls hTls | [in] Handle to the NTls.
void * * ppValue | [out] Double pointer to a buffer containing NTls value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTls.h

Module: NTls Unit


NTlsSetObject Function

NTlsSetObject Function

Sets the object for the specified Thread Local Storage.

C++
NResult N_API NTlsSetObject(HNTls hTls, HNObject hValue);
Collapse Expand Parameters
Parameters | Description
HNTls hTls | [in] Handle to the NTls.
HNObject hValue | [in] Handle to the NObject.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTls.h

Module: NTls Unit


NTlsSetValue Function

NTlsSetValue Function

Sets the Thread Local Storage value.

C++
NResult N_API NTlsSetValue(HNTls hTls, void * pValue);
Collapse Expand Parameters
Parameters | Description
HNTls hTls | [in] Handle to the NTls.
void * pValue | [out] Pointer to a buffer containing the new NTls value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTls.h

Module: NTls Unit


pValue Variable

pValue Variable

Thread Local Storage value.

C++
void * pValue;
Container

File: NTls.h

Module: NTls Unit


NType Unit

NType Unit
Files Functions Legend Macros Structs, Records, Enums

Manages object types.

Collapse Expand Files
Name | Description
NType.h | Header file for the NType module.
Collapse Expand Functions
Name | Description
NTypeAddEventHandlerN | Adds a handler for the specified event to the specified object.
NTypeAddEventHandlerP | Adds a handler for the specified event to the specified object.
NTypeAreValuesEqual | Checks whether the values of the specified type are equal.
NTypeCapturePropertyValues | Captures property values of the specified object.
NTypeCompareValues | Compares two values of the specified type and returns an integer that indicates their relative position in the sort order.
NTypeCopyPropertyValues | Copies property values of the specified object to another object.
NTypeCopyValue | Copies the specified value.
NTypeCreateInstance | Creates an instance of the specified type.
NTypeCreateInstanceWithName | Creates an instance of the type specified by name.
NTypeDisposeValue | Disposes the specified value.
NTypeDisposeValues | Disposes the specified value.
NTypeFreeValues | Frees the specified values.
NTypeGetAttributes | Retrieves the attributes of the specified type.
NTypeGetBaseType | Gets the base type of the specified type.
NTypeGetDeclaredConstant | Retrieves the declared constant specified by index.
NTypeGetDeclaredConstantCount | Retrieves the number of declared constants of the specified type.
NTypeGetDeclaredConstantWithName | Retrieves the declared constant specified by name.
NTypeGetDeclaredConstants | Retrieves all declared constants of the specified type.
NTypeGetDeclaredConstructor | Retrieves the declared constructor specified by index.
NTypeGetDeclaredConstructorCount | Retrieves the number of declared constructors of the specified type.
NTypeGetDeclaredConstructors | Retrieves all declared constructors of the specified type.
NTypeGetDeclaredEnumConstant | Retrieves the declared enumeration constant specified by index.
NTypeGetDeclaredEnumConstantCount | Retrieves the number of declared enumeration constants of the specified type.
NTypeGetDeclaredEnumConstantWithName | Retrieves the declared enumeration constant specified by name.
NTypeGetDeclaredEnumConstants | Retrieves all declared enumeration constants of the specified type.
NTypeGetDeclaredEvent | Retrieves the declared event specified by index.
NTypeGetDeclaredEventCount | Retrieves the number of declared events of the specified type.
NTypeGetDeclaredEventWithName | Retrieves the declared event specified by name.
NTypeGetDeclaredEvents | Retrieves all declared events of the specified type.
NTypeGetDeclaredField | Retrieves the declared field specified by index.
NTypeGetDeclaredFieldCount | Retrieves the number of declared fields of the specified type.
NTypeGetDeclaredFieldWithName | Retrieves the declared field specified by name.
NTypeGetDeclaredFields | Retrieves all declared fields of the specified type.
NTypeGetDeclaredMethod | Retrieves the declared method specified by index.
NTypeGetDeclaredMethodCount | Retrieves the number of declared methods of the specified type.
NTypeGetDeclaredMethodWithName | Retrieves the declared method specified by name.
NTypeGetDeclaredMethods | Retrieves all declared methods of the specified type.
NTypeGetDeclaredMethodsWithName | Retrieves a number of declared methods specified by names.
NTypeGetDeclaredPart | Retrieves the declared part specified by index.
NTypeGetDeclaredPartCount | Retrieves the number of declared part of the specified type.
NTypeGetDeclaredPartWithName | Retrieves the declared part specified by name.
NTypeGetDeclaredParts | Retrieves all declared parts of the specified type.
NTypeGetDeclaredProperties | Retrieves all declared properties of the specified type.
NTypeGetDeclaredProperty | Retrieves the declared property specified by index.
NTypeGetDeclaredPropertyCount | Retrieves the number of declared property of the specified type.
NTypeGetDeclaredPropertyWithName | Retrieves the declared property specified by name.
NTypeGetEnumAlternative | Retrieves alternative enumeration for the specified type.
NTypeGetModule | Gets the module of the specified type.
NTypeGetNameN | Gets the name of the specified type.
NTypeGetOwnerType | Gets the owner type of the specified type.
NTypeGetPropertyValueN | Retrieves the value of the specified property of the specified object.
NTypeGetPropertyValueP | Retrieves the value of the specified property of the specified object.
NTypeGetRootType | Retrieves the root type of the specified type.
NTypeGetRootTypeCode | Retrieves the code of the root type of the specified type.
NTypeGetTypeCode | Retrieves the type code for the specified type.
NTypeGetTypeWithName | Retrieves the type specified by name.
NTypeGetUseInsteadType | Gets the use-instead type of the specified type.
NTypeGetValueHashCode | Gets the hash code of the specified value.
NTypeGetValueSize | Gets the size of the specified value type.
NTypeHasOwnerType | Checks whether the specified type has an owner type.
NTypeIdentifierToString | Converts the specified type identifier into a string.
NTypeIdentifierToStringFN | Converts the specified type identifier into a string.
NTypeIdentifierToStringVN | Converts the specified type identifier into a string.
NTypeInvokeMethod | Invokes the specified method on the specified object.
NTypeInvokeMethodWithPropertyBag | Invokes the specified method on the specified object.
NTypeInvokeMethodWithString | Invokes the specified method on the specified object.
NTypeIsAbstract | Checks whether the specified type is abstract.
NTypeIsAssignableFrom | Checks whether the specified type is abstract from another type.
NTypeIsBasic | Checks whether the specified value is basic.
NTypeIsCallback | Checks whether the specified value is a callback.
NTypeIsCloneable | Checks whether the specified type is cloneable.
NTypeIsComparable | Checks whether the specified type is comparable.
NTypeIsDeprecated | Checks whether the specified type is deprecated.
NTypeIsDisposable | Checks whether the specified type is disposable.
NTypeIsEnum | Checks whether the specified type is an enumeration.
NTypeIsEquatable | Checks whether the specified type is equatable.
NTypeIsFlagsEnum | Checks whether the specified value is flag enumerated.
NTypeIsHandle | Checks whether the specified type is a handle.
NTypeIsInstanceOfType | Checks whether the specified object is an instance of the specified type.
NTypeIsInstanceOfTypeP | Checks whether the specified object is an instance of the specified type.
NTypeIsMemorySerializable | Checks whether the specified type is memory serializable.
NTypeIsObject | Checks whether the specified type is an object.
NTypeIsParsable | Checks whether the specified type is parsable.
NTypeIsPrimitive | Checks whether the specified type is primitive.
NTypeIsPublic | Checks whether the specified type is public.
NTypeIsSealed | Checks whether the specified type is sealed.
NTypeIsSerializable | Checks whether the specified type is serializable.
NTypeIsSignNeutral | Checks whether the specified type is sign neutral.
NTypeIsStatic | Checks whether the specified type is static.
NTypeIsStruct | Checks whether the specified type is a structure.
NTypeIsSubclassOf | Checks whether the specified type is a subclass of another type.
NTypeParseValue | Converts the specified string to a value of the specified type.
NTypeParseValueVN | Converts the specified string to a value of the specified type.
NTypeRemoveEventHandlerN | Removes an event handler from the specified object.
NTypeRemoveEventHandlerP | Removes an event handler from the specified object.
NTypeReset | Resets the type of the specified object.
NTypeResetPropertyValue | Resets the value of the specified property of the specified object.
NTypeSetPropertyValueN | Sets the value of the specified property of the specified object.
NTypeSetPropertyValueP | Sets the value of the specified property of the specified object.
NTypeSetValue | Sets the specified value.
NTypeTryParseValue | Converts the specified string to a value of the specified type. Returns a Boolean value indicating whether the conversion succeeded.
NTypeTryParseValueVN | Converts the specified string to a value of the specified type. Returns a Boolean value indicating whether the conversion succeeded.
NTypeValueToString | Converts the specified value to string.
NTypeValueToStringN | Converts the specified value to string.
Collapse Expand Macros
Name | Description
NTypeAddEventHandlerP | Picks a Unicode (W) or ASCII (A) version of the NTypeAddEventHandlerP function.
NTypeCreateInstanceWithName | Picks a Unicode (W) or ASCII (A) version of the NTypeCreateInstanceWithName function.
NTypeGetDeclaredConstantWithName | Picks a Unicode (W) or ASCII (A) version of the NTypeGetDeclaredConstantWithName function.
NTypeGetDeclaredEnumConstantWithName | Picks a Unicode (W) or ASCII (A) version of the NTypeGetDeclaredEnumConstantWithName function.
NTypeGetDeclaredEventWithName | Picks a Unicode (W) or ASCII (A) version of the NTypeGetDeclaredEventWithName function.
NTypeGetDeclaredFieldWithName | Picks a Unicode (W) or ASCII (A) version of the NTypeGetDeclaredFieldWithName function.
NTypeGetDeclaredMethodWithName | Picks a Unicode (W) or ASCII (A) version of the NTypeGetDeclaredMethodWithName function.
NTypeGetDeclaredMethodsWithName | Picks a Unicode (W) or ASCII (A) version of the NTypeGetDeclaredMethodsWithName function.
NTypeGetDeclaredPartWithName | Picks a Unicode (W) or ASCII (A) version of the NTypeGetDeclaredPartWithName function.
NTypeGetDeclaredPropertyWithName | Picks a Unicode (W) or ASCII (A) version of the NTypeGetDeclaredPropertyWithName function.
NTypeGetPropertyValueP | Picks a Unicode (W) or ASCII (A) version of the NTypeGetPropertyValueP function.
NTypeGetTypeWithName | Picks a Unicode (W) or ASCII (A) version of the NTypeGetTypeWithName function.
NTypeIdentifierToString | Picks a Unicode (W) or ASCII (A) version of the NTypeIdentifierToString function.
NTypeIdentifierToStringFN | Picks a Unicode (W) or ASCII (A) version of the NTypeIdentifierToStringFN function.
NTypeIdentifierToStringVN | Picks a Unicode (W) or ASCII (A) version of the NTypeIdentifierToStringVN function.
NTypeInvokeMethod | Picks a Unicode (W) or ASCII (A) version of the NTypeInvokeMethod function.
NTypeInvokeMethodWithPropertyBag | Picks a Unicode (W) or ASCII (A) version of the NTypeInvokeMethodWithPropertyBag function.
NTypeInvokeMethodWithString | Picks a Unicode (W) or ASCII (A) version of the NTypeInvokeMethodWithString function.
NTypeParseValue | Picks a Unicode (W) or ASCII (A) version of the NTypeParseValue function.
NTypeParseValueVN | Picks a Unicode (W) or ASCII (A) version of the NTypeParseValueVN function.
NTypeRemoveEventHandlerP | Picks a Unicode (W) or ASCII (A) version of the NTypeRemoveEventHandlerP function.
NTypeResetPropertyValueP | Picks a Unicode (W) or ASCII (A) version of the NTypeResetPropertyValue function.
NTypeSetPropertyValueP | Picks a Unicode (W) or ASCII (A) version of the NTypeSetPropertyValueP function.
NTypeTryParseValue | Picks a Unicode (W) or ASCII (A) version of the NTypeTryParseValue function.
NTypeTryParseValueVN | Picks a Unicode (W) or ASCII (A) version of the NTypeTryParseValueVN function.
NTypeValueToString | Picks a Unicode (W) or ASCII (A) version of the NTypeValueToString function.
Collapse Expand Structs, Records, Enums
Name | Description
NTypeCode_ | Enumerates type codes.
NTypeCode | Enumerates type codes.


NTypeAddEventHandlerN Function

NTypeAddEventHandlerN Function
NType.h

Adds a handler for the specified event to the specified object.

C++
NResult N_API NTypeAddEventHandlerN(HNType hType, HNObject hObject, HNString hName, HNValue hCallback);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the object type.
HNObject hObject | [in] Handle to the object.
HNString hName | [in] Handle to the event name.
HNValue hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeAddEventHandlerP Function

NTypeAddEventHandlerP Function
NType.h

Adds a handler for the specified event to the specified object.

C++
NResult N_API NTypeAddEventHandlerP(HNType hType, HNObject hObject, const NChar * szName, NTypeOfProc pCallbackTypeOf, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the object type.
HNObject hObject | [in] Handle to the object.
const NChar * szName | [in] Pointer to the event name.
NTypeOfProc pCallbackTypeOf | [in] Pointer to the process that receives the type of the callback.
HNCallback hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeAreValuesEqual Function

NTypeAreValuesEqual Function
NType.h

Checks whether the values of the specified type are equal.

C++
NResult N_API NTypeAreValuesEqual(HNType hType, const void * pValue1, NSizeType value1Size, const void * pValue2, NSizeType value2Size, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the NType.
const void * pValue1 | [in] Pointer to the first value.
NSizeType value1Size | [in] Size of the first value.
const void * pValue2 | [in] Pointer to the second value.
NSizeType value2Size | [in] Size of the second value.
NBool * pResult | [out] NTrue if the values are equal; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeCapturePropertyValues Function

NTypeCapturePropertyValues Function
NType.h

Captures property values of the specified object.

C++
NResult N_API NTypeCapturePropertyValues(HNType hType, HNObject hObject, HNPropertyBag hProperties);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the object type.
HNObject hObject | [in] Handle to the object.
HNPropertyBag hProperties | [in/out] Property bag that receives the properties from the object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeCompareValues Function

NTypeCompareValues Function
NType.h

Compares two values of the specified type and returns an integer that indicates their relative position in the sort order.

C++
NResult N_API NTypeCompareValues(HNType hType, const void * pValue1, NSizeType value1Size, const void * pValue2, NSizeType value2Size, NInt * pResult);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the NType.
const void * pValue1 | [in] Pointer to the first value.
NSizeType value1Size | [in] Size of the first value.
const void * pValue2 | [in] Pointer to the second value.
NSizeType value2Size | [in] Size of the second value.
NInt * pResult | [out] Pointer to an integer that indicates their relative position in the sort order.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeCopyPropertyValues Function

NTypeCopyPropertyValues Function
NType.h

Copies property values of the specified object to another object.

C++
NResult N_API NTypeCopyPropertyValues(HNType hType, HNObject hDstObject, HNObject hSrcObject);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the object type.
HNObject hDstObject | [in] Handle to the destination object.
HNObject hSrcObject | [in] Handle to the source object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeCopyValue Function

NTypeCopyValue Function
NType.h

Copies the specified value.

C++
NResult N_API NTypeCopyValue(HNType hType, const void * pSrcValue, NSizeType srcValueSize, void * pDstValue, NSizeType dstValueSize);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the type of the value.
const void * pSrcValue | [in] Pointer to the original value.
NSizeType srcValueSize | [in] Size of the original value.
void * pDstValue | [out] Pointer to the copied value.
NSizeType dstValueSize | [in] Size of the copied value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeCreateInstance Function

NTypeCreateInstance Function
NType.h

Creates an instance of the specified type.

C++
NResult N_API NTypeCreateInstance(HNType hType, NAttributes attributes, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the type.
NAttributes attributes | [in] Type attributes.
HNValue * phValue | [out] Pointer to the type instance.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeCreateInstanceWithName Function

NTypeCreateInstanceWithName Function
NType.h

Creates an instance of the type specified by name.

C++
NResult N_API NTypeCreateInstanceWithName(const NChar * szName, NAttributes attributes, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
const NChar * szName | [in] Pointer to the name type.
NAttributes attributes | [in] Type attributes.
HNValue * phValue | [out] Pointer to the type instance.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeDisposeValue Function

NTypeDisposeValue Function
NType.h

Disposes the specified value.

C++
NResult N_API NTypeDisposeValue(HNType hType, void * pValue, NSizeType valueSize);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the value type.
void * pValue | [in/out] Pointer to the value to be disposed.
NSizeType valueSize | [in] Size of the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeDisposeValues Function

NTypeDisposeValues Function
NType.h

Disposes the specified value.

C++
NResult N_API NTypeDisposeValues(HNType hType, void * arValues, NSizeType valuesSize, NInt valuesLength);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the value type.
void * arValues | [in/out] Pointer to the array of values to be disposed.
NSizeType valuesSize | [in] Size of the value.
NInt valuesLength | [in] Length of the value array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeFreeValues Function

NTypeFreeValues Function
NType.h

Frees the specified values.

C++
NResult N_API NTypeFreeValues(HNType hType, void * arValues, NSizeType valuesSize, NInt valuesLength);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the value type.
void * arValues | [in/out] Pointer to the array of values to be disposed.
NSizeType valuesSize | [in] Size of the value.
NInt valuesLength | [in] Length of the value array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeGetAttributes Function

NTypeGetAttributes Function
NType.h

Retrieves the attributes of the specified type.

C++
NResult N_API NTypeGetAttributes(HNType hType, NAttributes * pValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the type.
NAttributes * pValue | [out] Pointer to the type attributes.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeGetBaseType Function

NTypeGetBaseType Function
NType.h

Gets the base type of the specified type.

C++
NResult N_API NTypeGetBaseType(HNType hType, HNType * phValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the specified type.
HNType * phValue | [out] Pointer to a handle to the base class.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeGetDeclaredConstant Function

NTypeGetDeclaredConstant Function
NType.h

Retrieves the declared constant specified by index.

C++
NResult N_API NTypeGetDeclaredConstant(HNType hType, NInt index, HNConstantInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the constant type.
NInt index | [in] Index of the constant.
HNConstantInfo * phValue | [out] Pointer to the constant.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeGetDeclaredConstantCount Function

NTypeGetDeclaredConstantCount Function
NType.h

Retrieves the number of declared constants of the specified type.

C++
NResult N_API NTypeGetDeclaredConstantCount(HNType hType, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the constant type.
NInt * pValue | [out] Pointer to the number of constants.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeGetDeclaredConstantWithName Function

NTypeGetDeclaredConstantWithName Function
NType.h

Retrieves the declared constant specified by name.

C++
NResult N_API NTypeGetDeclaredConstantWithName(HNType hType, const NChar * szName, HNConstantInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the constant type.
const NChar * szName | [in] Pointer to the name of the constant.
HNConstantInfo * phValue | [out] Pointer to the constant.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeGetDeclaredConstants Function

NTypeGetDeclaredConstants Function
NType.h

Retrieves all declared constants of the specified type.

C++
NResult N_API NTypeGetDeclaredConstants(HNType hType, HNConstantInfo * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the constant type.
HNConstantInfo * * parhValues | [out] Pointer to an array of declared constants.
NInt * pValueCount | [out] Pointer to the number of constants in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeGetDeclaredConstructor Function

NTypeGetDeclaredConstructor Function
NType.h

Retrieves the declared constructor specified by index.

C++
NResult N_API NTypeGetDeclaredConstructor(HNType hType, NInt index, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the constructor type.
NInt index | [in] Index of the constructor.
HNMethodInfo * phValue | [out] Pointer to the constructor.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeGetDeclaredConstructorCount Function

NTypeGetDeclaredConstructorCount Function
NType.h

Retrieves the number of declared constructors of the specified type.

C++
NResult N_API NTypeGetDeclaredConstructorCount(HNType hType, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the constructor type.
NInt * pValue | [out] Pointer to the number of constructors.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeGetDeclaredConstructors Function

NTypeGetDeclaredConstructors Function
NType.h

Retrieves all declared constructors of the specified type.

C++
NResult N_API NTypeGetDeclaredConstructors(HNType hType, HNMethodInfo * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the constructor type.
HNMethodInfo * * parhValues | [out] Pointer to an array of declared constructors.
NInt * pValueCount | [out] Pointer to the number of constructors in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeGetDeclaredEnumConstant Function

NTypeGetDeclaredEnumConstant Function
NType.h

Retrieves the declared enumeration constant specified by index.

C++
NResult N_API NTypeGetDeclaredEnumConstant(HNType hType, NInt index, HNEnumConstantInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the constant type.
NInt index | [in] Index of the constant.
HNEnumConstantInfo * phValue | [out] Pointer to the constant.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeGetDeclaredEnumConstantCount Function

NTypeGetDeclaredEnumConstantCount Function
NType.h

Retrieves the number of declared enumeration constants of the specified type.

C++
NResult N_API NTypeGetDeclaredEnumConstantCount(HNType hType, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the constant type.
NInt * pValue | [out] Pointer to the number of constants.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeGetDeclaredEnumConstantWithName Function

NTypeGetDeclaredEnumConstantWithName Function
NType.h

Retrieves the declared enumeration constant specified by name.

C++
NResult N_API NTypeGetDeclaredEnumConstantWithName(HNType hType, const NChar * szName, HNEnumConstantInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the constant type.
const NChar * szName | [in] Pointer to the name of the constant.
HNEnumConstantInfo * phValue | [out] Pointer to the constant.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeGetDeclaredEnumConstants Function

NTypeGetDeclaredEnumConstants Function
NType.h

Retrieves all declared enumeration constants of the specified type.

C++
NResult N_API NTypeGetDeclaredEnumConstants(HNType hType, HNEnumConstantInfo * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the constant type.
HNEnumConstantInfo * * parhValues | [out] Pointer to an array of declared constants.
NInt * pValueCount | [out] Pointer to the number of constants in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeGetDeclaredEvent Function

NTypeGetDeclaredEvent Function
NType.h

Retrieves the declared event specified by index.

C++
NResult N_API NTypeGetDeclaredEvent(HNType hType, NInt index, HNEventInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the event type.
NInt index | [in] Index of the event.
HNEventInfo * phValue | [out] Pointer to the event.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeGetDeclaredEventCount Function

NTypeGetDeclaredEventCount Function
NType.h

Retrieves the number of declared events of the specified type.

C++
NResult N_API NTypeGetDeclaredEventCount(HNType hType, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the event type.
NInt * pValue | [out] Pointer to the number of events.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeGetDeclaredEventWithName Function

NTypeGetDeclaredEventWithName Function
NType.h

Retrieves the declared event specified by name.

C++
NResult N_API NTypeGetDeclaredEventWithName(HNType hType, const NChar * szName, HNEventInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the event type.
const NChar * szName | [in] Pointer to the name of the event.
HNEventInfo * phValue | [out] Pointer to the event.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeGetDeclaredEvents Function

NTypeGetDeclaredEvents Function
NType.h

Retrieves all declared events of the specified type.

C++
NResult N_API NTypeGetDeclaredEvents(HNType hType, HNEventInfo * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the event type.
HNEventInfo * * parhValues | [out] Pointer to an array of declared events.
NInt * pValueCount | [out] Pointer to the number of events in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeGetDeclaredField Function

NTypeGetDeclaredField Function
NType.h

Retrieves the declared field specified by index.

C++
NResult N_API NTypeGetDeclaredField(HNType hType, NInt index, HNPropertyInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the field type.
NInt index | [in] Index of the field.
HNPropertyInfo * phValue | [out] Pointer to the field.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeGetDeclaredFieldCount Function

NTypeGetDeclaredFieldCount Function
NType.h

Retrieves the number of declared fields of the specified type.

C++
NResult N_API NTypeGetDeclaredFieldCount(HNType hType, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the field type.
NInt * pValue | [out] Pointer to the number of fields.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeGetDeclaredFieldWithName Function

NTypeGetDeclaredFieldWithName Function
NType.h

Retrieves the declared field specified by name.

C++
NResult N_API NTypeGetDeclaredFieldWithName(HNType hType, const NChar * szName, HNPropertyInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the field type.
const NChar * szName | [in] Pointer to the name of the field.
HNPropertyInfo * phValue | [out] Pointer to the field.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeGetDeclaredFields Function

NTypeGetDeclaredFields Function
NType.h

Retrieves all declared fields of the specified type.

C++
NResult N_API NTypeGetDeclaredFields(HNType hType, HNPropertyInfo * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the field type.
HNPropertyInfo * * parhValues | [out] Pointer to an array of declared fields.
NInt * pValueCount | [out] Pointer to the number of fields in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeGetDeclaredMethod Function

NTypeGetDeclaredMethod Function
NType.h

Retrieves the declared method specified by index.

C++
NResult N_API NTypeGetDeclaredMethod(HNType hType, NInt index, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the method type.
NInt index | [in] Index of the method.
HNMethodInfo * phValue | [out] Pointer to the method.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeGetDeclaredMethodCount Function

NTypeGetDeclaredMethodCount Function
NType.h

Retrieves the number of declared methods of the specified type.

C++
NResult N_API NTypeGetDeclaredMethodCount(HNType hType, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the method type.
NInt * pValue | [out] Pointer to the number of methods.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeGetDeclaredMethodWithName Function

NTypeGetDeclaredMethodWithName Function
NType.h

Retrieves the declared method specified by name.

C++
NResult N_API NTypeGetDeclaredMethodWithName(HNType hType, const NChar * szName, HNMethodInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the method type.
const NChar * szName | [in] Pointer to the name of the method.
HNMethodInfo * phValue | [out] Pointer to the method.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeGetDeclaredMethods Function

NTypeGetDeclaredMethods Function
NType.h

Retrieves all declared methods of the specified type.

C++
NResult N_API NTypeGetDeclaredMethods(HNType hType, HNMethodInfo * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the method type.
HNMethodInfo * * parhValues | [out] Pointer to an array of declared methods.
NInt * pValueCount | [out] Pointer to the number of methods in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeGetDeclaredMethodsWithName Function

NTypeGetDeclaredMethodsWithName Function
NType.h

Retrieves a number of declared methods specified by names.

C++
NResult N_API NTypeGetDeclaredMethodsWithName(HNType hType, const NChar * szName, HNMethodInfo * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the method type.
const NChar * szName | [in] Pointer to the names of the methods.
HNMethodInfo * * parhValues | [out] Pointer to an array of declared methods.
NInt * pValueCount | [out] Pointer to the number of methods in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeGetDeclaredPart Function

NTypeGetDeclaredPart Function
NType.h

Retrieves the declared part specified by index.

C++
NResult N_API NTypeGetDeclaredPart(HNType hType, NInt index, HNObjectPartInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the part type.
NInt index | [in] Index of the part.
HNObjectPartInfo * phValue | [out] Pointer to the part.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeGetDeclaredPartCount Function

NTypeGetDeclaredPartCount Function
NType.h

Retrieves the number of declared part of the specified type.

C++
NResult N_API NTypeGetDeclaredPartCount(HNType hType, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the part type.
NInt * pValue | [out] Pointer to the number of parts.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeGetDeclaredPartWithName Function

NTypeGetDeclaredPartWithName Function
NType.h

Retrieves the declared part specified by name.

C++
NResult N_API NTypeGetDeclaredPartWithName(HNType hType, const NChar * szName, HNObjectPartInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the part type.
const NChar * szName | [in] Pointer to the name of the part.
HNObjectPartInfo * phValue | [out] Pointer to the part.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeGetDeclaredParts Function

NTypeGetDeclaredParts Function
NType.h

Retrieves all declared parts of the specified type.

C++
NResult N_API NTypeGetDeclaredParts(HNType hType, HNObjectPartInfo * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the part type.
HNObjectPartInfo * * parhValues | [out] Pointer to an array of declared parts.
NInt * pValueCount | [out] Pointer to the number of parts in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeGetDeclaredProperties Function

NTypeGetDeclaredProperties Function
NType.h

Retrieves all declared properties of the specified type.

C++
NResult N_API NTypeGetDeclaredProperties(HNType hType, HNPropertyInfo * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the property type.
HNPropertyInfo * * parhValues | [out] Pointer to an array of declared properties.
NInt * pValueCount | [out] Pointer to the number of properties in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeGetDeclaredProperty Function

NTypeGetDeclaredProperty Function
NType.h

Retrieves the declared property specified by index.

C++
NResult N_API NTypeGetDeclaredProperty(HNType hType, NInt index, HNPropertyInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the property type.
NInt index | [in] Index of the property.
HNPropertyInfo * phValue | [out] Pointer to the property.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeGetDeclaredPropertyCount Function

NTypeGetDeclaredPropertyCount Function
NType.h

Retrieves the number of declared property of the specified type.

C++
NResult N_API NTypeGetDeclaredPropertyCount(HNType hType, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the property type.
NInt * pValue | [out] Pointer to the number of properties.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeGetDeclaredPropertyWithName Function

NTypeGetDeclaredPropertyWithName Function
NType.h

Retrieves the declared property specified by name.

C++
NResult N_API NTypeGetDeclaredPropertyWithName(HNType hType, const NChar * szName, HNPropertyInfo * phValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the property type.
const NChar * szName | [in] Pointer to the name of the property.
HNPropertyInfo * phValue | [out] Pointer to the property.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeGetEnumAlternative Function

NTypeGetEnumAlternative Function
NType.h

Retrieves alternative enumeration for the specified type.

C++
NResult N_API NTypeGetEnumAlternative(HNType hType, HNType * phValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the original type.
HNType * phValue | [out] Pointer to the alternative enumeration type.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeGetModule Function

NTypeGetModule Function
NType.h

Gets the module of the specified type.

C++
NResult N_API NTypeGetModule(HNType hType, HNModule * phValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the NType.
HNModule * phValue | [out] Pointer to a handle to the module of the type.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeGetNameN Function

NTypeGetNameN Function
NType.h

Gets the name of the specified type.

C++
NResult N_API NTypeGetNameN(HNType hType, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the NType.
HNString * phValue | [out] Pointer to a handle to the name of the type.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeGetOwnerType Function

NTypeGetOwnerType Function
NType.h

Gets the owner type of the specified type.

C++
NResult N_API NTypeGetOwnerType(HNType hType, HNType * phValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the specified type.
HNType * phValue | [out] Pointer to a handle to the owner type.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeGetPropertyValueN Function

NTypeGetPropertyValueN Function
NType.h

Retrieves the value of the specified property of the specified object.

C++
NResult N_API NTypeGetPropertyValueN(HNType hType, HNObject hObject, HNString hName, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the object type.
HNObject hObject | [in] Handle to the object.
HNString hName | [in] Handle to the name of the property.
HNValue * phValue | [out] Pointer to the property value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeGetPropertyValueP Function

NTypeGetPropertyValueP Function
NType.h

Retrieves the value of the specified property of the specified object.

C++
NResult N_API NTypeGetPropertyValueP(HNType hType, HNObject hObject, const NChar * szName, NTypeOfProc pValueTypeOf, NAttributes attributes, void * arValues, NSizeType valuesSize, NInt valuesLength, NBool * pHasValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the object type.
HNObject hObject | [in] Handle to the object.
const NChar * szName | [in] Pointer to the name of the property.
NTypeOfProc pValueTypeOf | [in] Pointer to a process that retrieves the type of a property.
NAttributes attributes | [in] Property attributes.
void * arValues | [out] Pointer to an array of properties.
NSizeType valuesSize | [in] Size of a property.
NInt valuesLength | [in] Number of properties in the array.
NBool * pHasValue | [in] NTrue if the arValues contains any values, else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeGetRootType Function

NTypeGetRootType Function
NType.h

Retrieves the root type of the specified type.

C++
NResult N_API NTypeGetRootType(HNType hType, HNType * phValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the type.
HNType * phValue | [out] Pointer to a handle to the root type.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeGetRootTypeCode Function

NTypeGetRootTypeCode Function
NType.h

Retrieves the code of the root type of the specified type.

C++
NResult N_API NTypeGetRootTypeCode(HNType hType, NTypeCode * pValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the type.
NTypeCode * pValue | [out] Pointer to the code of the root type.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeGetTypeCode Function

NTypeGetTypeCode Function
NType.h

Retrieves the type code for the specified type.

C++
NResult N_API NTypeGetTypeCode(HNType hType, NTypeCode * pValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the type value.
NTypeCode * pValue | [out] Pointer to the code of the type.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeGetTypeWithName Function

NTypeGetTypeWithName Function
NType.h

Retrieves the type specified by name.

C++
NResult N_API NTypeGetTypeWithName(const NChar * szName, NBool mustExist, HNType * phValue);
Collapse Expand Parameters
Parameters | Description
const NChar * szName | [in] Pointer to the name of the type.
NBool mustExist | [in] NTrue if the type must already exist; NFalse if the type may be created if no such type existed before.
HNType * phValue | [out] Pointer to the type.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeGetUseInsteadType Function

NTypeGetUseInsteadType Function
NType.h

Gets the use-instead type of the specified type.

C++
NResult N_API NTypeGetUseInsteadType(HNType hType, HNType * phValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the specified type.
HNType * phValue | [out] Pointer to a handle to the use-instead class.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeGetValueHashCode Function

NTypeGetValueHashCode Function
NType.h

Gets the hash code of the specified value.

C++
NResult N_API NTypeGetValueHashCode(HNType hType, const void * pValue, NSizeType valueSize, NInt * pResult);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the NType.
const void * pValue | [in] Pointer to the value.
NSizeType valueSize | [in] Value size.
NInt * pResult | [out] Pointer to the hash code.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeGetValueSize Function

NTypeGetValueSize Function
NType.h

Gets the size of the specified value type.

C++
NResult N_API NTypeGetValueSize(HNType hType, NSizeType * pValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the NType.
NSizeType * pValue | [out] Pointer to the size of the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeHasOwnerType Function

NTypeHasOwnerType Function
NType.h

Checks whether the specified type has an owner type.

C++
NResult N_API NTypeHasOwnerType(HNType hType, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the NType.
NBool * pValue | [out] NTrue if the type has an owner type; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeIdentifierToString Function

NTypeIdentifierToString Function
NType.h

Converts the specified type identifier into a string.

C++
NResult N_API NTypeIdentifierToString(const NChar * szValue, const NChar * szFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
const NChar * szValue | [in] Pointer to the type identifier string.
const NChar * szFormat | [in] Pointer to the format string.
HNString * phValue | [out] Pointer to the new string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NType.h

Module: NType Unit


NTypeIdentifierToStringFN Function

NTypeIdentifierToStringFN Function
NType.h

Converts the specified type identifier into a string.

C++
NResult N_API NTypeIdentifierToStringFN(const NChar * szValue, HNString hFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
const NChar * szValue | [in] Pointer to the type identifier string.
HNString hFormat | [in] Handle to the format string.
HNString * phValue | [out] Pointer to the new string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NType.h

Module: NType Unit


NTypeIdentifierToStringVN Function

NTypeIdentifierToStringVN Function
NType.h

Converts the specified type identifier into a string.

C++
NResult N_API NTypeIdentifierToStringVN(HNString hValue, const NChar * szFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] Handle to the type identifier string.
const NChar * szFormat | [in] Pointer to the format string.
HNString * phValue | [out] Pointer to the new string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NType.h

Module: NType Unit


NTypeInvokeMethod Function

NTypeInvokeMethod Function
NType.h

Invokes the specified method on the specified object.

C++
NResult N_API NTypeInvokeMethod(HNType hType, HNObject hObject, const NChar * szName, HNValue * arhParameters, NInt parameterCount, HNValue * phResult);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the object type.
HNObject hObject | [in] Handle to the object.
const NChar * szName | [in] Pointer to the method name.
HNValue * arhParameters | [in/out] Pointer to an array of method parameters.
NInt parameterCount | [in] Number of parameters in the array.
HNValue * phResult | [out] Pointer to the result returned by the invoked method.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeInvokeMethodWithPropertyBag Function

NTypeInvokeMethodWithPropertyBag Function
NType.h

Invokes the specified method on the specified object.

C++
NResult N_API NTypeInvokeMethodWithPropertyBag(HNType hType, HNObject hObject, const NChar * szName, HNPropertyBag hParameters, HNValue * phResult);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the object type.
HNObject hObject | [in] Handle to the object.
const NChar * szName | [in] Pointer to the method name.
HNPropertyBag hParameters | [in] Handle to the property bag containing method parameters.
HNValue * phResult | [out] Pointer to the result returned by the invoked method.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeInvokeMethodWithString Function

NTypeInvokeMethodWithString Function
NType.h

Invokes the specified method on the specified object.

C++
NResult N_API NTypeInvokeMethodWithString(HNType hType, HNObject hObject, const NChar * szName, const NChar * szParameters, HNValue * phResult);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the object type.
HNObject hObject | [in] Handle to the object.
const NChar * szName | [in] Pointer to the method name.
const NChar * szParameters | [in/out] Pointer to a string containing method parameters.
HNValue * phResult | [out] Pointer to the result returned by the invoked method.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeIsAbstract Function

NTypeIsAbstract Function
NType.h

Checks whether the specified type is abstract.

C++
NResult N_API NTypeIsAbstract(HNType hType, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the NType.
NBool * pValue | [out] NTrue if the type is abstract; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeIsAssignableFrom Function

NTypeIsAssignableFrom Function
NType.h

Checks whether the specified type is abstract from another type.

C++
NResult N_API NTypeIsAssignableFrom(HNType hType, HNType hOtherType, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the NType.
HNType hOtherType | [in] Handle to the other NType.
NBool * pValue | [out] NTrue if the first type is assignable from the second type; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeIsBasic Function

NTypeIsBasic Function
NType.h

Checks whether the specified value is basic.

C++
NResult N_API NTypeIsBasic(HNType hType, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the NType.
NBool * pValue | [out] NTrue if the value is basic; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeIsCallback Function

NTypeIsCallback Function
NType.h

Checks whether the specified value is a callback.

C++
NResult N_API NTypeIsCallback(HNType hType, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the NType.
NBool * pValue | [out] NTrue if the value is a callback; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeIsCloneable Function

NTypeIsCloneable Function
NType.h

Checks whether the specified type is cloneable.

C++
NResult N_API NTypeIsCloneable(HNType hType, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the NType.
NBool * pValue | [out] NTrue if the type is cloneable; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeIsComparable Function

NTypeIsComparable Function
NType.h

Checks whether the specified type is comparable.

C++
NResult N_API NTypeIsComparable(HNType hType, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the NType.
NBool * pValue | [out] NTrue if the type is comparable; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeIsDeprecated Function

NTypeIsDeprecated Function
NType.h

Checks whether the specified type is deprecated.

C++
NResult N_API NTypeIsDeprecated(HNType hType, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the NType.
NBool * pValue | [out] NTrue if the type is deprecated; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeIsDisposable Function

NTypeIsDisposable Function
NType.h

Checks whether the specified type is disposable.

C++
NResult N_API NTypeIsDisposable(HNType hType, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the type value.
NBool * pValue | [out] NTrue if the value is disposable; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeIsEnum Function

NTypeIsEnum Function
NType.h

Checks whether the specified type is an enumeration.

C++
NResult N_API NTypeIsEnum(HNType hType, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the type value.
NBool * pValue | [out] NTrue if the value is an enumeration; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeIsEquatable Function

NTypeIsEquatable Function
NType.h

Checks whether the specified type is equatable.

C++
NResult N_API NTypeIsEquatable(HNType hType, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the NType.
NBool * pValue | [out] NTrue if the type is equatable; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeIsFlagsEnum Function

NTypeIsFlagsEnum Function
NType.h

Checks whether the specified value is flag enumerated.

C++
NResult N_API NTypeIsFlagsEnum(HNType hType, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the NType.
NBool * pValue | [out] NTrue if the value is flag enumerated; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeIsHandle Function

NTypeIsHandle Function
NType.h

Checks whether the specified type is a handle.

C++
NResult N_API NTypeIsHandle(HNType hType, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the type value.
NBool * pValue | [out] NTrue if the value is a handle; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeIsInstanceOfType Function

NTypeIsInstanceOfType Function
NType.h

Checks whether the specified object is an instance of the specified type.

C++
NResult N_API NTypeIsInstanceOfType(HNType hType, HNObject hObject, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the NType.
HNObject hObject | [in] Handle to the object.
NBool * pValue | [out] NTrue if the object is an instance of the type; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeIsInstanceOfTypeP Function

NTypeIsInstanceOfTypeP Function
NType.h

Checks whether the specified object is an instance of the specified type.

C++
NResult N_API NTypeIsInstanceOfTypeP(NTypeOfProc pTypeOf, HNObject hObject, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
NTypeOfProc pTypeOf | [in] Pointer to a function that retrieves the NType.
HNObject hObject | [in] Handle to the object.
NBool * pValue | [out] NTrue if the object is an instance of the type; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeIsMemorySerializable Function

NTypeIsMemorySerializable Function
NType.h

Checks whether the specified type is memory serializable.

C++
NResult N_API NTypeIsMemorySerializable(HNType hType, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the NType.
NBool * pValue | [out] NTrue if the type is memory serializable; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeIsObject Function

NTypeIsObject Function
NType.h

Checks whether the specified type is an object.

C++
NResult N_API NTypeIsObject(HNType hType, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the type value.
NBool * pValue | [out] NTrue if the value is an object; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeIsParsable Function

NTypeIsParsable Function
NType.h

Checks whether the specified type is parsable.

C++
NResult N_API NTypeIsParsable(HNType hType, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the NType.
NBool * pValue | [out] NTrue if the type is parsable; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeIsPrimitive Function

NTypeIsPrimitive Function
NType.h

Checks whether the specified type is primitive.

C++
NResult N_API NTypeIsPrimitive(HNType hType, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the type value.
NBool * pValue | [out] NTrue if the value is primitive; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeIsPublic Function

NTypeIsPublic Function
NType.h

Checks whether the specified type is public.

C++
NResult N_API NTypeIsPublic(HNType hType, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the NType.
NBool * pValue | [out] NTrue if the type is public; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeIsSealed Function

NTypeIsSealed Function
NType.h

Checks whether the specified type is sealed.

C++
NResult N_API NTypeIsSealed(HNType hType, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the NType.
NBool * pValue | [out] NTrue if the type is sealed; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeIsSerializable Function

NTypeIsSerializable Function
NType.h

Checks whether the specified type is serializable.

C++
NResult N_API NTypeIsSerializable(HNType hType, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the NType.
NBool * pValue | [out] NTrue if the type is serializable; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeIsSignNeutral Function

NTypeIsSignNeutral Function
NType.h

Checks whether the specified type is sign neutral.

C++
NResult N_API NTypeIsSignNeutral(HNType hType, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the type value.
NBool * pValue | [out] NTrue if the type is sign neutral; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeIsStatic Function

NTypeIsStatic Function
NType.h

Checks whether the specified type is static.

C++
NResult N_API NTypeIsStatic(HNType hType, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the NType.
NBool * pValue | [out] NTrue if the type is static; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeIsStruct Function

NTypeIsStruct Function
NType.h

Checks whether the specified type is a structure.

C++
NResult N_API NTypeIsStruct(HNType hType, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the type value.
NBool * pValue | [out] NTrue if the value is a structure; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeIsSubclassOf Function

NTypeIsSubclassOf Function
NType.h

Checks whether the specified type is a subclass of another type.

C++
NResult N_API NTypeIsSubclassOf(HNType hType, HNType hOtherType, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the first NType.
HNType hOtherType | [in] Handle to the second NType.
NBool * pValue | [out] NTrue if the first type is subclass of the second type; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeParseValue Function

NTypeParseValue Function
NType.h

Converts the specified string to a value of the specified type.

C++
NResult N_API NTypeParseValue(HNType hType, const NChar * szValue, const NChar * szFormat, void * pValue, NSizeType valueSize);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the NType.
const NChar * szValue | [in] Pointer to the string to parse.
const NChar * szFormat | [in] Pointer to format string.
void * pValue | [out] Pointer to the parsed value.
NSizeType valueSize | [in] Value size.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NType.h

Module: NType Unit


NTypeParseValueVN Function

NTypeParseValueVN Function
NType.h

Converts the specified string to a value of the specified type.

C++
NResult N_API NTypeParseValueVN(HNType hType, HNString hValue, const NChar * szFormat, void * pValue, NSizeType valueSize);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the NType.
HNString hValue | [in] Handle to the string to parse.
const NChar * szFormat | [in] Pointer to format string.
void * pValue | [out] Pointer to the parsed value.
NSizeType valueSize | [in] Value size.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NType.h

Module: NType Unit


NTypeRemoveEventHandlerN Function

NTypeRemoveEventHandlerN Function
NType.h

Removes an event handler from the specified object.

C++
NResult N_API NTypeRemoveEventHandlerN(HNType hType, HNObject hObject, HNString hName, HNValue hCallback);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the object type.
HNObject hObject | [in] Handle to the object.
HNString hName | [in] Handle to the event name.
HNValue hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeRemoveEventHandlerP Function

NTypeRemoveEventHandlerP Function
NType.h

Removes an event handler from the specified object.

C++
NResult N_API NTypeRemoveEventHandlerP(HNType hType, HNObject hObject, const NChar * szName, NTypeOfProc pCallbackTypeOf, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the object type.
HNObject hObject | [in] Handle to the object.
const NChar * szName | [in] Pointer to the event name.
NTypeOfProc pCallbackTypeOf | [in] Pointer to the process that receives the type of the callback.
HNCallback hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeReset Function

NTypeReset Function
NType.h

Resets the type of the specified object.

C++
NResult N_API NTypeReset(HNType hType, HNObject hObject);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the NType.
HNObject hObject | [in] Handle to the NObject.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeResetPropertyValue Function

NTypeResetPropertyValue Function
NType.h

Resets the value of the specified property of the specified object.

C++
NResult N_API NTypeResetPropertyValue(HNType hType, HNObject hObject, const NChar * szName);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to object type.
HNObject hObject | [in] Handle to the object.
const NChar * szName | [in] Pointer to the name of the property.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeSetPropertyValueN Function

NTypeSetPropertyValueN Function
NType.h

Sets the value of the specified property of the specified object.

C++
NResult N_API NTypeSetPropertyValueN(HNType hType, HNObject hObject, HNString hName, HNValue hValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the object type.
HNObject hObject | [in] Handle to the object.
HNString hName | [in] Handle to the property name.
HNValue hValue | [in] Handle to the new property value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeSetPropertyValueP Function

NTypeSetPropertyValueP Function
NType.h

Sets the value of the specified property of the specified object.

C++
NResult N_API NTypeSetPropertyValueP(HNType hType, HNObject hObject, const NChar * szName, NTypeOfProc pValueTypeOf, NAttributes attributes, const void * arValues, NSizeType valuesSize, NInt valuesLength, NBool hasValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the object type.
HNObject hObject | [in] Handle to the object.
const NChar * szName | [in] Pointer to the property name.
NTypeOfProc pValueTypeOf | [in] Pointer to the process that receives the type of the property.
NAttributes attributes | [in] Property attributes.
const void * arValues | [in] Pointer to an array of new property values.
NSizeType valuesSize | [in] Size of a property.
NInt valuesLength | [in] Number of properties in the array.
NBool hasValue | [in] NTrue if the arValues contains any values, else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeSetValue Function

NTypeSetValue Function
NType.h

Sets the specified value.

C++
NResult N_API NTypeSetValue(HNType hType, const void * pSrcValue, NSizeType srcValueSize, void * pDstValue, NSizeType dstValueSize);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the value type.
const void * pSrcValue | [in] Pointer to the source value.
NSizeType srcValueSize | [in] Size of the source value.
void * pDstValue | [out] Pointer to the destination value.
NSizeType dstValueSize | [in] Size of the destination value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NType.h

Module: NType Unit


NTypeTryParseValue Function

NTypeTryParseValue Function
NType.h

Converts the specified string to a value of the specified type. Returns a Boolean value indicating whether the conversion succeeded.

C++
NResult N_API NTypeTryParseValue(HNType hType, const NChar * szValue, const NChar * szFormat, void * pValue, NSizeType valueSize, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the NType.
const NChar * szValue | [in] Pointer to the string to parse.
const NChar * szFormat | [in] Pointer to format string.
void * pValue | [out] Pointer to the parsed value.
NSizeType valueSize | [in] Value size.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NType.h

Module: NType Unit


NTypeTryParseValueVN Function

NTypeTryParseValueVN Function
NType.h

Converts the specified string to a value of the specified type. Returns a Boolean value indicating whether the conversion succeeded.

C++
NResult N_API NTypeTryParseValueVN(HNType hType, HNString hValue, const NChar * szFormat, void * pValue, NSizeType valueSize, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the NType.
HNString hValue | [in] Handle to the string to parse.
const NChar * szFormat | [in] Pointer to format string.
void * pValue | [out] Pointer to the parsed value.
NSizeType valueSize | [in] Value size.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NType.h

Module: NType Unit


NTypeValueToString Function

NTypeValueToString Function
NType.h

Converts the specified value to string.

C++
NResult N_API NTypeValueToString(HNType hType, const void * pValue, NSizeType valueSize, const NChar * szFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the NType.
const void * pValue | [in] Pointer to the value to convert.
NSizeType valueSize | [in] Value size.
const NChar * szFormat | [in] Pointer to format string.
HNString * phValue | [out] Pointer to a handle to the converted string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NType.h

Module: NType Unit


NTypeValueToStringN Function

NTypeValueToStringN Function
NType.h

Converts the specified value to string.

C++
NResult N_API NTypeValueToStringN(HNType hType, const void * pValue, NSizeType valueSize, HNString hFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the NType.
const void * pValue | [in] Pointer to the value to convert.
NSizeType valueSize | [in] Value size.
HNString hFormat | [in] Handle to format string.
HNString * phValue | [out] Pointer to a handle to the converted string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NType.h

Module: NType Unit


NTypeCode Enumeration

NTypeCode Enumeration
NType.h

Enumerates type codes.

C++
typedef enum NTypeCode_ {
  ntcNone = 0,
  ntcOther = 1,
  ntcByte = 2,
  ntcSByte = 3,
  ntcUInt16 = 4,
  ntcInt16 = 5,
  ntcUInt32 = 6,
  ntcInt32 = 7,
  ntcUInt64 = 8,
  ntcInt64 = 9,
  ntcSingle = 10,
  ntcDouble = 11,
  ntcBoolean = 12,
  ntcSizeType = 13,
  ntcSSizeType = 14,
  ntcPointer = 15,
  ntcResult = 16,
  ntcAChar = 17,
  ntcWChar = 18,
  ntcChar = ntcAChar,
  ntcString = 19,
  ntcObject = 20,
  ntcValue = 21,
  ntcArray = 22,
  ntcTimeSpan = 23,
  ntcDateTime = 24,
  ntcURational = 25,
  ntcRational = 26,
  ntcComplex = 27,
  ntcGuid = 28,
  ntcBuffer = 29,
  ntcCallback = 30,
  ntcAsyncOperation = 31,
  ntcObjectPart = 32,
  ntcCollection = 33,
  ntcDictionary = 34,
  ntcArrayCollection = 35
} NTypeCode;
Collapse Expand Members
Members | Description
ntcNone = 0 | Empty value.
ntcOther = 1 | Other value type.
ntcByte = 2 | Byte.
ntcSByte = 3 | Signed byte.
ntcUInt16 = 4 | Unsigned short integer value.
ntcInt16 = 5 | Short integer value.
ntcUInt32 = 6 | Unsigned integer value.
ntcInt32 = 7 | Integer value.
ntcUInt64 = 8 | Unsigned long integer value.
ntcInt64 = 9 | Long integer value.
ntcSingle = 10 | Single value.
ntcDouble = 11 | Double value.
ntcBoolean = 12 | Boolean value.
ntcSizeType = 13 | NSizeType value.
ntcSSizeType = 14 | NSSizeType value.
ntcPointer = 15 | A pointer.
ntcResult = 16 | NResult value.
ntcAChar = 17 | ASCII character.
ntcWChar = 18 | Unicode character.
ntcChar = ntcAChar | Character.
ntcString = 19 | String value.
ntcObject = 20 | An object.
ntcValue = 21 | Custom type value.
ntcArray = 22 | Array.
ntcTimeSpan = 23 | NTimeSpan value.
ntcDateTime = 24 | Date-time value.
ntcURational = 25 | Unsigned rational number value.
ntcRational = 26 | A rational number value.
ntcComplex = 27 | Complex number.
ntcGuid = 28 | Global unique identifier.
ntcBuffer = 29 | Buffer.
ntcCallback = 30 | A callback.
ntcAsyncOperation = 31 | Asynchronous operation.
ntcObjectPart = 32 | A part of an object.
ntcCollection = 33 | A collection.
ntcDictionary = 34 | A dictionary.
ntcArrayCollection = 35 | Collection of arrays.
Container

File: NType.h

Module: NType Unit


NTypeAddEventHandlerP Macro

NTypeAddEventHandlerP Macro
NType.h

Picks a Unicode (W) or ASCII (A) version of the NTypeAddEventHandlerP function.

C++
#define NTypeAddEventHandlerP N_FUNC_AW(NTypeAddEventHandlerP)
Container

File: NType.h

Module: NType Unit


NTypeCreateInstanceWithName Macro

NTypeCreateInstanceWithName Macro
NType.h

Picks a Unicode (W) or ASCII (A) version of the NTypeCreateInstanceWithName function.

C++
#define NTypeCreateInstanceWithName N_FUNC_AW(NTypeCreateInstanceWithName)
Container

File: NType.h

Module: NType Unit


NTypeGetDeclaredConstantWithName Macro

NTypeGetDeclaredConstantWithName Macro
NType.h

Picks a Unicode (W) or ASCII (A) version of the NTypeGetDeclaredConstantWithName function.

C++
#define NTypeGetDeclaredConstantWithName N_FUNC_AW(NTypeGetDeclaredConstantWithName)
Container

File: NType.h

Module: NType Unit


NTypeGetDeclaredEnumConstantWithName Macro

NTypeGetDeclaredEnumConstantWithName Macro
NType.h

Picks a Unicode (W) or ASCII (A) version of the NTypeGetDeclaredEnumConstantWithName function.

C++
#define NTypeGetDeclaredEnumConstantWithName N_FUNC_AW(NTypeGetDeclaredEnumConstantWithName)
Container

File: NType.h

Module: NType Unit


NTypeGetDeclaredEventWithName Macro

NTypeGetDeclaredEventWithName Macro
NType.h

Picks a Unicode (W) or ASCII (A) version of the NTypeGetDeclaredEventWithName function.

C++
#define NTypeGetDeclaredEventWithName N_FUNC_AW(NTypeGetDeclaredEventWithName)
Container

File: NType.h

Module: NType Unit


NTypeGetDeclaredFieldWithName Macro

NTypeGetDeclaredFieldWithName Macro
NType.h

Picks a Unicode (W) or ASCII (A) version of the NTypeGetDeclaredFieldWithName function.

C++
#define NTypeGetDeclaredFieldWithName N_FUNC_AW(NTypeGetDeclaredFieldWithName)
Container

File: NType.h

Module: NType Unit


NTypeGetDeclaredMethodWithName Macro

NTypeGetDeclaredMethodWithName Macro
NType.h

Picks a Unicode (W) or ASCII (A) version of the NTypeGetDeclaredMethodWithName function.

C++
#define NTypeGetDeclaredMethodWithName N_FUNC_AW(NTypeGetDeclaredMethodWithName)
Container

File: NType.h

Module: NType Unit


NTypeGetDeclaredMethodsWithName Macro

NTypeGetDeclaredMethodsWithName Macro
NType.h

Picks a Unicode (W) or ASCII (A) version of the NTypeGetDeclaredMethodsWithName function.

C++
#define NTypeGetDeclaredMethodsWithName N_FUNC_AW(NTypeGetDeclaredMethodsWithName)
Container

File: NType.h

Module: NType Unit


NTypeGetDeclaredPartWithName Macro

NTypeGetDeclaredPartWithName Macro
NType.h

Picks a Unicode (W) or ASCII (A) version of the NTypeGetDeclaredPartWithName function.

C++
#define NTypeGetDeclaredPartWithName N_FUNC_AW(NTypeGetDeclaredPartWithName)
Container

File: NType.h

Module: NType Unit


NTypeGetDeclaredPropertyWithName Macro

NTypeGetDeclaredPropertyWithName Macro
NType.h

Picks a Unicode (W) or ASCII (A) version of the NTypeGetDeclaredPropertyWithName function.

C++
#define NTypeGetDeclaredPropertyWithName N_FUNC_AW(NTypeGetDeclaredPropertyWithName)
Container

File: NType.h

Module: NType Unit


NTypeGetPropertyValueP Macro

NTypeGetPropertyValueP Macro
NType.h

Picks a Unicode (W) or ASCII (A) version of the NTypeGetPropertyValueP function.

C++
#define NTypeGetPropertyValueP N_FUNC_AW(NTypeGetPropertyValueP)
Container

File: NType.h

Module: NType Unit


NTypeGetTypeWithName Macro

NTypeGetTypeWithName Macro
NType.h

Picks a Unicode (W) or ASCII (A) version of the NTypeGetTypeWithName function.

C++
#define NTypeGetTypeWithName N_FUNC_AW(NTypeGetTypeWithName)
Container

File: NType.h

Module: NType Unit


NTypeIdentifierToString Macro

NTypeIdentifierToString Macro
NType.h

Picks a Unicode (W) or ASCII (A) version of the NTypeIdentifierToString function.

C++
#define NTypeIdentifierToString N_FUNC_AW(NTypeIdentifierToString)
Container

File: NType.h

Module: NType Unit


NTypeIdentifierToStringFN Macro

NTypeIdentifierToStringFN Macro
NType.h

Picks a Unicode (W) or ASCII (A) version of the NTypeIdentifierToStringFN function.

C++
#define NTypeIdentifierToStringFN N_FUNC_AW(NTypeIdentifierToStringFN)
Container

File: NType.h

Module: NType Unit


NTypeIdentifierToStringVN Macro

NTypeIdentifierToStringVN Macro
NType.h

Picks a Unicode (W) or ASCII (A) version of the NTypeIdentifierToStringVN function.

C++
#define NTypeIdentifierToStringVN N_FUNC_AW(NTypeIdentifierToStringVN)
Container

File: NType.h

Module: NType Unit


NTypeInvokeMethod Macro

NTypeInvokeMethod Macro
NType.h

Picks a Unicode (W) or ASCII (A) version of the NTypeInvokeMethod function.

C++
#define NTypeInvokeMethod N_FUNC_AW(NTypeInvokeMethod)
Container

File: NType.h

Module: NType Unit


NTypeInvokeMethodWithPropertyBag Macro

NTypeInvokeMethodWithPropertyBag Macro
NType.h

Picks a Unicode (W) or ASCII (A) version of the NTypeInvokeMethodWithPropertyBag function.

C++
#define NTypeInvokeMethodWithPropertyBag N_FUNC_AW(NTypeInvokeMethodWithPropertyBag)
Container

File: NType.h

Module: NType Unit


NTypeInvokeMethodWithString Macro

NTypeInvokeMethodWithString Macro
NType.h

Picks a Unicode (W) or ASCII (A) version of the NTypeInvokeMethodWithString function.

C++
#define NTypeInvokeMethodWithString N_FUNC_AW(NTypeInvokeMethodWithString)
Container

File: NType.h

Module: NType Unit


NTypeParseValue Macro

NTypeParseValue Macro
NType.h

Picks a Unicode (W) or ASCII (A) version of the NTypeParseValue function.

C++
#define NTypeParseValue N_FUNC_AW(NTypeParseValue)
Container

File: NType.h

Module: NType Unit


NTypeParseValueVN Macro

NTypeParseValueVN Macro
NType.h

Picks a Unicode (W) or ASCII (A) version of the NTypeParseValueVN function.

C++
#define NTypeParseValueVN N_FUNC_AW(NTypeParseValueVN)
Container

File: NType.h

Module: NType Unit


NTypeRemoveEventHandlerP Macro

NTypeRemoveEventHandlerP Macro
NType.h

Picks a Unicode (W) or ASCII (A) version of the NTypeRemoveEventHandlerP function.

C++
#define NTypeRemoveEventHandlerP N_FUNC_AW(NTypeRemoveEventHandlerP)
Container

File: NType.h

Module: NType Unit


NTypeResetPropertyValueP Macro

NTypeResetPropertyValueP Macro
NType.h

Picks a Unicode (W) or ASCII (A) version of the NTypeResetPropertyValue function.

C++
#define NTypeResetPropertyValueP N_FUNC_AW(NTypeResetPropertyValue)
Container

File: NType.h

Module: NType Unit


NTypeSetPropertyValueP Macro

NTypeSetPropertyValueP Macro
NType.h

Picks a Unicode (W) or ASCII (A) version of the NTypeSetPropertyValueP function.

C++
#define NTypeSetPropertyValueP N_FUNC_AW(NTypeSetPropertyValueP)
Container

File: NType.h

Module: NType Unit


NTypeTryParseValue Macro

NTypeTryParseValue Macro
NType.h

Picks a Unicode (W) or ASCII (A) version of the NTypeTryParseValue function.

C++
#define NTypeTryParseValue N_FUNC_AW(NTypeTryParseValue)
Container

File: NType.h

Module: NType Unit


NTypeTryParseValueVN Macro

NTypeTryParseValueVN Macro
NType.h

Picks a Unicode (W) or ASCII (A) version of the NTypeTryParseValueVN function.

C++
#define NTypeTryParseValueVN N_FUNC_AW(NTypeTryParseValueVN)
Container

File: NType.h

Module: NType Unit


NTypeValueToString Macro

NTypeValueToString Macro
NType.h

Picks a Unicode (W) or ASCII (A) version of the NTypeValueToString function.

C++
#define NTypeValueToString N_FUNC_AW(NTypeValueToString)
Container

File: NType.h

Module: NType Unit


NType.h

NType.h
Enumerations Functions Legend Macros

Header file for the NType module.

Collapse Expand Enumerations
Name | Description
NTypeCode_ | Enumerates type codes.
NTypeCode | Enumerates type codes.
Collapse Expand Functions
Name | Description
NTypeAddEventHandlerN | Adds a handler for the specified event to the specified object.
NTypeAddEventHandlerP | Adds a handler for the specified event to the specified object.
NTypeAreValuesEqual | Checks whether the values of the specified type are equal.
NTypeCapturePropertyValues | Captures property values of the specified object.
NTypeCompareValues | Compares two values of the specified type and returns an integer that indicates their relative position in the sort order.
NTypeCopyPropertyValues | Copies property values of the specified object to another object.
NTypeCopyValue | Copies the specified value.
NTypeCreateInstance | Creates an instance of the specified type.
NTypeCreateInstanceWithName | Creates an instance of the type specified by name.
NTypeDisposeValue | Disposes the specified value.
NTypeDisposeValues | Disposes the specified value.
NTypeFreeValues | Frees the specified values.
NTypeGetAttributes | Retrieves the attributes of the specified type.
NTypeGetBaseType | Gets the base type of the specified type.
NTypeGetDeclaredConstant | Retrieves the declared constant specified by index.
NTypeGetDeclaredConstantCount | Retrieves the number of declared constants of the specified type.
NTypeGetDeclaredConstantWithName | Retrieves the declared constant specified by name.
NTypeGetDeclaredConstants | Retrieves all declared constants of the specified type.
NTypeGetDeclaredConstructor | Retrieves the declared constructor specified by index.
NTypeGetDeclaredConstructorCount | Retrieves the number of declared constructors of the specified type.
NTypeGetDeclaredConstructors | Retrieves all declared constructors of the specified type.
NTypeGetDeclaredEnumConstant | Retrieves the declared enumeration constant specified by index.
NTypeGetDeclaredEnumConstantCount | Retrieves the number of declared enumeration constants of the specified type.
NTypeGetDeclaredEnumConstantWithName | Retrieves the declared enumeration constant specified by name.
NTypeGetDeclaredEnumConstants | Retrieves all declared enumeration constants of the specified type.
NTypeGetDeclaredEvent | Retrieves the declared event specified by index.
NTypeGetDeclaredEventCount | Retrieves the number of declared events of the specified type.
NTypeGetDeclaredEventWithName | Retrieves the declared event specified by name.
NTypeGetDeclaredEvents | Retrieves all declared events of the specified type.
NTypeGetDeclaredField | Retrieves the declared field specified by index.
NTypeGetDeclaredFieldCount | Retrieves the number of declared fields of the specified type.
NTypeGetDeclaredFieldWithName | Retrieves the declared field specified by name.
NTypeGetDeclaredFields | Retrieves all declared fields of the specified type.
NTypeGetDeclaredMethod | Retrieves the declared method specified by index.
NTypeGetDeclaredMethodCount | Retrieves the number of declared methods of the specified type.
NTypeGetDeclaredMethodWithName | Retrieves the declared method specified by name.
NTypeGetDeclaredMethods | Retrieves all declared methods of the specified type.
NTypeGetDeclaredMethodsWithName | Retrieves a number of declared methods specified by names.
NTypeGetDeclaredPart | Retrieves the declared part specified by index.
NTypeGetDeclaredPartCount | Retrieves the number of declared part of the specified type.
NTypeGetDeclaredPartWithName | Retrieves the declared part specified by name.
NTypeGetDeclaredParts | Retrieves all declared parts of the specified type.
NTypeGetDeclaredProperties | Retrieves all declared properties of the specified type.
NTypeGetDeclaredProperty | Retrieves the declared property specified by index.
NTypeGetDeclaredPropertyCount | Retrieves the number of declared property of the specified type.
NTypeGetDeclaredPropertyWithName | Retrieves the declared property specified by name.
NTypeGetEnumAlternative | Retrieves alternative enumeration for the specified type.
NTypeGetModule | Gets the module of the specified type.
NTypeGetNameN | Gets the name of the specified type.
NTypeGetOwnerType | Gets the owner type of the specified type.
NTypeGetPropertyValueN | Retrieves the value of the specified property of the specified object.
NTypeGetPropertyValueP | Retrieves the value of the specified property of the specified object.
NTypeGetRootType | Retrieves the root type of the specified type.
NTypeGetRootTypeCode | Retrieves the code of the root type of the specified type.
NTypeGetTypeCode | Retrieves the type code for the specified type.
NTypeGetTypeWithName | Retrieves the type specified by name.
NTypeGetUseInsteadType | Gets the use-instead type of the specified type.
NTypeGetValueHashCode | Gets the hash code of the specified value.
NTypeGetValueSize | Gets the size of the specified value type.
NTypeHasOwnerType | Checks whether the specified type has an owner type.
NTypeIdentifierToString | Converts the specified type identifier into a string.
NTypeIdentifierToStringFN | Converts the specified type identifier into a string.
NTypeIdentifierToStringVN | Converts the specified type identifier into a string.
NTypeInvokeMethod | Invokes the specified method on the specified object.
NTypeInvokeMethodWithPropertyBag | Invokes the specified method on the specified object.
NTypeInvokeMethodWithString | Invokes the specified method on the specified object.
NTypeIsAbstract | Checks whether the specified type is abstract.
NTypeIsAssignableFrom | Checks whether the specified type is abstract from another type.
NTypeIsBasic | Checks whether the specified value is basic.
NTypeIsCallback | Checks whether the specified value is a callback.
NTypeIsCloneable | Checks whether the specified type is cloneable.
NTypeIsComparable | Checks whether the specified type is comparable.
NTypeIsDeprecated | Checks whether the specified type is deprecated.
NTypeIsDisposable | Checks whether the specified type is disposable.
NTypeIsEnum | Checks whether the specified type is an enumeration.
NTypeIsEquatable | Checks whether the specified type is equatable.
NTypeIsFlagsEnum | Checks whether the specified value is flag enumerated.
NTypeIsHandle | Checks whether the specified type is a handle.
NTypeIsInstanceOfType | Checks whether the specified object is an instance of the specified type.
NTypeIsInstanceOfTypeP | Checks whether the specified object is an instance of the specified type.
NTypeIsMemorySerializable | Checks whether the specified type is memory serializable.
NTypeIsObject | Checks whether the specified type is an object.
NTypeIsParsable | Checks whether the specified type is parsable.
NTypeIsPrimitive | Checks whether the specified type is primitive.
NTypeIsPublic | Checks whether the specified type is public.
NTypeIsSealed | Checks whether the specified type is sealed.
NTypeIsSerializable | Checks whether the specified type is serializable.
NTypeIsSignNeutral | Checks whether the specified type is sign neutral.
NTypeIsStatic | Checks whether the specified type is static.
NTypeIsStruct | Checks whether the specified type is a structure.
NTypeIsSubclassOf | Checks whether the specified type is a subclass of another type.
NTypeParseValue | Converts the specified string to a value of the specified type.
NTypeParseValueVN | Converts the specified string to a value of the specified type.
NTypeRemoveEventHandlerN | Removes an event handler from the specified object.
NTypeRemoveEventHandlerP | Removes an event handler from the specified object.
NTypeReset | Resets the type of the specified object.
NTypeResetPropertyValue | Resets the value of the specified property of the specified object.
NTypeSetPropertyValueN | Sets the value of the specified property of the specified object.
NTypeSetPropertyValueP | Sets the value of the specified property of the specified object.
NTypeSetValue | Sets the specified value.
NTypeTryParseValue | Converts the specified string to a value of the specified type. Returns a Boolean value indicating whether the conversion succeeded.
NTypeTryParseValueVN | Converts the specified string to a value of the specified type. Returns a Boolean value indicating whether the conversion succeeded.
NTypeValueToString | Converts the specified value to string.
NTypeValueToStringN | Converts the specified value to string.
Collapse Expand Macros
Name | Description
NTypeAddEventHandlerP | Picks a Unicode (W) or ASCII (A) version of the NTypeAddEventHandlerP function.
NTypeCreateInstanceWithName | Picks a Unicode (W) or ASCII (A) version of the NTypeCreateInstanceWithName function.
NTypeGetDeclaredConstantWithName | Picks a Unicode (W) or ASCII (A) version of the NTypeGetDeclaredConstantWithName function.
NTypeGetDeclaredEnumConstantWithName | Picks a Unicode (W) or ASCII (A) version of the NTypeGetDeclaredEnumConstantWithName function.
NTypeGetDeclaredEventWithName | Picks a Unicode (W) or ASCII (A) version of the NTypeGetDeclaredEventWithName function.
NTypeGetDeclaredFieldWithName | Picks a Unicode (W) or ASCII (A) version of the NTypeGetDeclaredFieldWithName function.
NTypeGetDeclaredMethodWithName | Picks a Unicode (W) or ASCII (A) version of the NTypeGetDeclaredMethodWithName function.
NTypeGetDeclaredMethodsWithName | Picks a Unicode (W) or ASCII (A) version of the NTypeGetDeclaredMethodsWithName function.
NTypeGetDeclaredPartWithName | Picks a Unicode (W) or ASCII (A) version of the NTypeGetDeclaredPartWithName function.
NTypeGetDeclaredPropertyWithName | Picks a Unicode (W) or ASCII (A) version of the NTypeGetDeclaredPropertyWithName function.
NTypeGetPropertyValueP | Picks a Unicode (W) or ASCII (A) version of the NTypeGetPropertyValueP function.
NTypeGetTypeWithName | Picks a Unicode (W) or ASCII (A) version of the NTypeGetTypeWithName function.
NTypeIdentifierToString | Picks a Unicode (W) or ASCII (A) version of the NTypeIdentifierToString function.
NTypeIdentifierToStringFN | Picks a Unicode (W) or ASCII (A) version of the NTypeIdentifierToStringFN function.
NTypeIdentifierToStringVN | Picks a Unicode (W) or ASCII (A) version of the NTypeIdentifierToStringVN function.
NTypeInvokeMethod | Picks a Unicode (W) or ASCII (A) version of the NTypeInvokeMethod function.
NTypeInvokeMethodWithPropertyBag | Picks a Unicode (W) or ASCII (A) version of the NTypeInvokeMethodWithPropertyBag function.
NTypeInvokeMethodWithString | Picks a Unicode (W) or ASCII (A) version of the NTypeInvokeMethodWithString function.
NTypeParseValue | Picks a Unicode (W) or ASCII (A) version of the NTypeParseValue function.
NTypeParseValueVN | Picks a Unicode (W) or ASCII (A) version of the NTypeParseValueVN function.
NTypeRemoveEventHandlerP | Picks a Unicode (W) or ASCII (A) version of the NTypeRemoveEventHandlerP function.
NTypeResetPropertyValueP | Picks a Unicode (W) or ASCII (A) version of the NTypeResetPropertyValue function.
NTypeSetPropertyValueP | Picks a Unicode (W) or ASCII (A) version of the NTypeSetPropertyValueP function.
NTypeTryParseValue | Picks a Unicode (W) or ASCII (A) version of the NTypeTryParseValue function.
NTypeTryParseValueVN | Picks a Unicode (W) or ASCII (A) version of the NTypeTryParseValueVN function.
NTypeValueToString | Picks a Unicode (W) or ASCII (A) version of the NTypeValueToString function.


NTypeDescriptor Unit

NTypeDescriptor Unit
Files Functions Legend

Provides information about the characteristics for a component, such as its attributes, properties, and events.

Collapse Expand Files
Name | Description
NTypeDescriptor.h | Header file for the NTypeDescriptor module.
Collapse Expand Functions
Name | Description
NTypeDescriptorGetDefaultPropertyName | Retrieves the default property name of the specified object.
NTypeDescriptorGetDefaultPropertyNameForType | Retrieves the default property name of the specified type.
NTypeDescriptorGetEvents | Retrieves the events of the specified object.
NTypeDescriptorGetEventsForType | Retrieves the events of the specified type.
NTypeDescriptorGetMethods | Retrieves the methods of the specified object.
NTypeDescriptorGetMethodsForType | Retrieves the methods of the specified type.
NTypeDescriptorGetProperties | Retrieves the properties of the specified object.
NTypeDescriptorGetPropertiesForType | Retrieves the properties of the specified type.


NTypeDescriptorGetDefaultPropertyName Function

NTypeDescriptorGetDefaultPropertyName Function
NTypeDescriptor.h

Retrieves the default property name of the specified object.

C++
NResult N_API NTypeDescriptorGetDefaultPropertyName(HNObject hObject, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] Handle to the object.
HNString * phValue | [out] Pointer to a handle to the string with default property name.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypeDescriptor.h

Module: NTypeDescriptor Unit


NTypeDescriptorGetDefaultPropertyNameForType Function

NTypeDescriptorGetDefaultPropertyNameForType Function
NTypeDescriptor.h

Retrieves the default property name of the specified type.

C++
NResult N_API NTypeDescriptorGetDefaultPropertyNameForType(HNType hType, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the type.
HNString * phValue | [out] Pointer to a handle to the string with default property name.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypeDescriptor.h

Module: NTypeDescriptor Unit


NTypeDescriptorGetEvents Function

NTypeDescriptorGetEvents Function
NTypeDescriptor.h

Retrieves the events of the specified object.

C++
NResult N_API NTypeDescriptorGetEvents(HNObject hObject, HNEventDescriptor * * parhEvents, NInt * pEventCount);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] Handle to the object.
HNEventDescriptor * * parhEvents | [out] Pointer to an array containing the handles to the events of the object.
NInt * pEventCount | [out] Pointer to the number of event handles in an array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypeDescriptor.h

Module: NTypeDescriptor Unit


NTypeDescriptorGetEventsForType Function

NTypeDescriptorGetEventsForType Function
NTypeDescriptor.h

Retrieves the events of the specified type.

C++
NResult N_API NTypeDescriptorGetEventsForType(HNType hType, HNEventDescriptor * * parhEvents, NInt * pEventCount);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the type.
HNEventDescriptor * * parhEvents | [out] Pointer to an array containing the handles to the events of the type.
NInt * pEventCount | [out] Pointer to the number of event handles in an array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypeDescriptor.h

Module: NTypeDescriptor Unit


NTypeDescriptorGetMethods Function

NTypeDescriptorGetMethods Function
NTypeDescriptor.h

Retrieves the methods of the specified object.

C++
NResult N_API NTypeDescriptorGetMethods(HNObject hObject, HNMethodDescriptor * * parhMethods, NInt * pMethodCount);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] Handle to the object.
HNMethodDescriptor * * parhMethods | [out] Pointer to an array containing the handles to the methods of the object.
NInt * pMethodCount | [out] Pointer to the number of method handles in an array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypeDescriptor.h

Module: NTypeDescriptor Unit


NTypeDescriptorGetMethodsForType Function

NTypeDescriptorGetMethodsForType Function
NTypeDescriptor.h

Retrieves the methods of the specified type.

C++
NResult N_API NTypeDescriptorGetMethodsForType(HNType hType, HNMethodDescriptor * * parhMethods, NInt * pMethodCount);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the type.
HNMethodDescriptor * * parhMethods | [out] Pointer to an array containing the handles to the methods of the type.
NInt * pMethodCount | [out] Pointer to the number of method handles in an array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypeDescriptor.h

Module: NTypeDescriptor Unit


NTypeDescriptorGetProperties Function

NTypeDescriptorGetProperties Function
NTypeDescriptor.h

Retrieves the properties of the specified object.

C++
NResult N_API NTypeDescriptorGetProperties(HNObject hObject, HNPropertyDescriptor * * parhProperties, NInt * pPropertyCount);
Collapse Expand Parameters
Parameters | Description
HNObject hObject | [in] Handle to the object.
HNPropertyDescriptor * * parhProperties | [out] Pointer to an array containing the handles to the properties of the object.
NInt * pPropertyCount | [out] Pointer to the number of property handles in an array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypeDescriptor.h

Module: NTypeDescriptor Unit


NTypeDescriptorGetPropertiesForType Function

NTypeDescriptorGetPropertiesForType Function
NTypeDescriptor.h

Retrieves the properties of the specified type.

C++
NResult N_API NTypeDescriptorGetPropertiesForType(HNType hType, HNPropertyDescriptor * * parhProperties, NInt * pPropertyCount);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the type.
HNPropertyDescriptor * * parhProperties | [out] Pointer to an array containing the handles to the properties of the type.
NInt * pPropertyCount | [out] Pointer to the number of property handles in an array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypeDescriptor.h

Module: NTypeDescriptor Unit


NTypeDescriptor.h

NTypeDescriptor.h
Functions Legend

Header file for the NTypeDescriptor module.

Collapse Expand Functions
Name | Description
NTypeDescriptorGetDefaultPropertyName | Retrieves the default property name of the specified object.
NTypeDescriptorGetDefaultPropertyNameForType | Retrieves the default property name of the specified type.
NTypeDescriptorGetEvents | Retrieves the events of the specified object.
NTypeDescriptorGetEventsForType | Retrieves the events of the specified type.
NTypeDescriptorGetMethods | Retrieves the methods of the specified object.
NTypeDescriptorGetMethodsForType | Retrieves the methods of the specified type.
NTypeDescriptorGetProperties | Retrieves the properties of the specified object.
NTypeDescriptorGetPropertiesForType | Retrieves the properties of the specified type.


NTypes Unit

NTypes Unit
Files Functions Legend Macros Structs, Records, Enums Types

Defines types and macros used in Neurotechnology components.

Collapse Expand Files
Name | Description
NTypes.h | Header file for NTypes module. Defines types and macros used in Neurotechnology components.
Collapse Expand Functions
Name | Description
NACharParseN | Converts a NString to NAChar.
NACharParseStrOrChars | Converts an array of NChars to NAChar.
NACharParseVN | Converts a NString to NAChar.
NACharToChars | Converts NAChar to an array of NAChars.
NACharToString | Converts NAChar to NString
NACharTryParseN | Converts NString to NAChar. A NBool value indicates whether the conversion succeeded.
NACharTryParseStrOrChars | Converts an array of NChars to NAChar. A NBool value indicates whether the conversion succeeded.
NACharTryParseVN | Converts NString to NAChar. A NBool value indicates whether the conversion succeeded.
NBooleanParseN | Converts NString to NBoolean.
NBooleanParseStrOrChars | Converts an array of NChars to NBoolean.
NBooleanParseVN | Converts NString to NBoolean.
NBooleanToChars | Converts NBoolean to an array of NChars.
NBooleanToString | Converts NBoolean to NString.
NBooleanTryParseN | Converts a NString to NBoolean. A NBool value indicates whether the conversion succeeded.
NBooleanTryParseStrOrChars | Converts an array of NStrings or NChars into NBoolean. A NBool value indicates whether the conversion succeeded.
NBooleanTryParseVN | Converts a NString to NBoolean. A NBool value indicates whether the conversion succeeded.
NCharFromBinDigit | Converts a binary digit to NChar.
NCharFromDigit | Converts a digit to NChar.
NCharFromHexDigit | Converts a hexadecimal digit to NChar.
NCharFromOctDigit | Converts an octal digit to NChar.
NCharIsAscii | Checks whether the specified char is ASCII.
NCharIsBinDigit | Checks whether the specified character is a binary digit.
NCharIsDigit | Checks whether the specified character is a digit.
NCharIsHexDigit | Checks whether the specified character is a hexadecimal digit.
NCharIsLetter | Checks whether the specified character is a letter.
NCharIsLower | Checks whether the specified character is a lower value.
NCharIsOctDigit | Checks whether the specified character is an octal digit.
NCharIsUpper | Checks whether the specified character is an upper value.
NCharIsWhiteSpace | Checks whether the specified character is a whitespace.
NCharParseN | Converts a NString to a NChar.
NCharParseStrOrChars | Converts an array of NStrings or NChars into NChar.
NCharParseVN | Converts a NString to a NChar.
NCharToBinDigit | Converts a NChar to a binary digit.
NCharToChars | Converts a NChar into an array of NChars.
NCharToDigit | Converts a NChar to a digit.
NCharToHexDigit | Converts a NChar to a hexadecimal digit.
NCharToLower | Converts a NChar to lowercase.
NCharToOctDigit | Converts a NChar to an octal digit.
NCharToString | Converts NChar to NString.
NCharToUpper | Converts NChar to uppercase.
NCharTryParseN | Converts a NString to a NChar. A NBool value indicates whether the conversion succeeded.
NCharTryParseStrOrChars | Converts an array of NChars into NChar. A NBool value indicates whether the conversion succeeded.
NCharTryParseVN | Converts a NString to a NChar. A NBool value indicates whether the conversion succeeded.
NComplexToString | Converts NComplex to NString.
NDoubleGetNaN | Retrieves a NDouble that is Not a Number (NaN).
NDoubleGetNegativeInfinity | Retrieves a NDouble that is NegativeInfinity.
NDoubleGetPositiveInfinity | Retrieves a NDouble that is PositiveInfinity.
NDoubleIsInfinity | Checks if NDouble evaluates to NegativeInfinity or PositiveInfinity.
NDoubleIsNaN | Checks if NDouble is Not a Number (NaN).
NDoubleIsNegativeInfinity | Checks if NDouble evaluates to NegativeInfinity.
NDoubleIsPositiveInfinity | Checks if NDouble evaluates to PositiveInfinity
NDoubleParseN | Converts a NString into NDouble.
NDoubleParseStrOrChars | Converted an array of NChars to NDouble.
NDoubleParseVN | Converts a NString into NDouble.
NDoubleToChars | Converts NDouble to an array of NChars.
NDoubleToString | Converts NDouble to NString.
NDoubleTryParseN | Converts a NString to NDouble. A NBool value indicates whether the conversion succeeded.
NDoubleTryParseStrOrChars | Converts an array of NChars to NDouble. A NBool value indicates whether the conversion succeeded.
NDoubleTryParseVN | Converts a NString to NDouble. A NBool value indicates whether the conversion succeeded.
NGuidParse | Converts a NChar to NGuid.
NGuidParseVN | Converts a NString to NGuid.
NGuidToString | Converts a NGuid to NString.
NGuidTryParse | Converts a NChar to NGuid. A NBool value indicates whether the conversion succeeded.
NGuidTryParseVN | Converts a NString to NGuid. A NBool value indicates whether the conversion succeeded.
NIndexPairToString | Convertes NIndexPair to NString.
NInt16ParseN | Convertes NString to NInt16.
NInt16ParseStrOrChars | Converts an array of NChars to NInt16.
NInt16ParseVN | Convertes NString to NInt16.
NInt16ToChars | Converts NInt16 to an array of NChars.
NInt16ToString | Converts NInt16 to NString.
NInt16TryParseN | Converts NString to NInt16. A NBool value indicates whether the conversion succeeded.
NInt16TryParseStrOrChars | Converts an array of NChars to NInt16. A NBool value indicates whether the conversion succeeded.
NInt16TryParseVN | Converts NString to NInt16. A NBool value indicates whether the conversion succeeded.
NInt32ParseN | Converts NString to NInt32.
NInt32ParseStrOrChars | Converts an array of NChars to NInt32.
NInt32ParseVN | Converts NString to NInt32.
NInt32ToChars | Converts NInt32 to an array of NChars.
NInt32ToString | Converts NInt32 to NString.
NInt32TryParseN | Converts NString to NInt32. A NBool value indicates whether the conversion succeeded.
NInt32TryParseStrOrChars | Converts an array of NChars to NInt32. A NBool value indicates whether the conversion succeeded.
NInt32TryParseVN | Converts NString to NInt32. A NBool value indicates whether the conversion succeeded.
NInt64ParseN | Converts NString to NInt64.
NInt64ParseStrOrChars | Converts an array of NChars to NInt64.
NInt64ParseVN | Converts NString to NInt64.
NInt64ToChars | Converts NInt64 to an array of NChars.
NInt64ToString | Converts NInt64 to NString.
NInt64TryParseN | Converts NString to NInt64. A NBool value indicates whether the conversion succeeded.
NInt64TryParseStrOrChars | Converts an array of NChars to NInt64. A NBool value indicates whether the conversion succeeded.
NInt64TryParseVN | Converts NString to NInt64. A NBool value indicates whether the conversion succeeded.
NInt8ParseN | Converts NString to NInt8.
NInt8ParseStrOrChars | Converts an array of NChars to NInt8.
NInt8ParseVN | Converts NString to NInt8.
NInt8ToChars | Converts NInt8 to an array of NChars.
NInt8ToString | Converts NInt8 to NString.
NInt8TryParseN | Converts NString to NInt8. A NBool value indicates whether the conversion succeeded.
NInt8TryParseStrOrChars | Converts an array of NChars to NInt8. A NBool value indicates whether the conversion succeeded.
NInt8TryParseVN | Converts NString to NInt8. A NBool value indicates whether the conversion succeeded.
NNameStringPairCopy | Creates a copy of string pair structure.
NNameStringPairCreate | Creates a new string pair structure.
NNameStringPairDispose | Disposes of the specified string pair structure.
NNameStringPairSet | Sets the value of the specified string pair structure.
NOSFamilyGetCurrent | Retrieves the current operating system family.
NPointerParseN | Converts NString to NPointer.
NPointerParseStrOrChars | Converts an array of NChars to NPointer.
NPointerParseVN | Converts NString to NPointer.
NPointerToChars | Converts NPointer to an array of NChars.
NPointerToString | Converts NPointer to NString.
NPointerTryParseN | Converts NString to NPointer. A NBool value indicates whether the conversion succeeded.
NPointerTryParseStrOrChars | Converts an array of NChars to NPointer. A NBool value indicates whether the conversion succeeded.
NPointerTryParseVN | Converts NString to NPointer. A NBool value indicates whether the conversion succeeded.
NRangeToString | Converts NRange to NString.
NRationalToString | Converts NRational to NString.
NResultParseN | Converts NString to NResult.
NResultParseStrOrChars | Converts an array of NChars to NResult.
NResultParseVN | Converts NString to NResult.
NResultToChars | Converts NResult to an array of NChars.
NResultToString | Converts NResult to NString.
NResultTryParseN | Converts NString to NResult. A NBool value indicates whether the conversion succeeded.
NResultTryParseStrOrChars | Converts an array of NChars to NResult. A NBool value indicates whether the conversion succeeded.
NResultTryParseVN | Converts NString to NResult. A NBool value indicates whether the conversion succeeded.
NSSizeTypeParseN | Converts NString to NSSizeType.
NSSizeTypeParseStrOrChars | Converts an array of NChars to NSSizeType.
NSSizeTypeParseVN | Converts NString to NSSizeType.
NSSizeTypeToChars | Converts NSSizeType to an array of NChars.
NSSizeTypeToString | Converts NSSizeType to NString.
NSSizeTypeTryParseN | Converts NString to NSSizeType. A NBool value indicates whether the conversion succeeded.
NSSizeTypeTryParseStrOrChars | Converts an array of NChars to NSSizeType. A NBool value indicates whether the conversion succeeded.
NSSizeTypeTryParseVN | Converts NString to NSSizeType. A NBool value indicates whether the conversion succeeded.
NSingleGetNaN | Retrieves a NSingle that is Not a Number (NaN).
NSingleGetNegativeInfinity | Retrieves a NSingle that is NegativeInfinity.
NSingleGetPositiveInfinity | Retrieves a NSingle that is PositiveInfinity.
NSingleIsInfinity | Checks if NSingle evaluates to NegativeInfinity or PositiveInfinity.
NSingleIsNaN | Checks if NSingle Not a Number (NaN).
NSingleIsNegativeInfinity | Checks if NSingle evaluates to NegativeInfinity.
NSingleIsPositiveInfinity | Checks if NSingle evaluates to PositiveInfinity.
NSingleParseN | Converts NString to NSingle.
NSingleParseStrOrChars | Converts an array of NChars to NSingle.
NSingleParseVN | Converts NString to NSingle.
NSingleToChars | Converts NSingle to an array of NChars.
NSingleToString | Converts NSingle to NString.
NSingleTryParseN | Converts NString to NSingle. A NBool value indicates whether the conversion succeeded.
NSingleTryParseStrOrChars | Converts an array of NChars to NSingle. A NBool value indicates whether the conversion succeeded.
NSingleTryParseVN | Converts NString to NSingle. A NBool value indicates whether the conversion succeeded.
NSizeTypeParseN | Converts NString to NSizeType.
NSizeTypeParseStrOrChars | Converts an array of NChars to NSizeType.
NSizeTypeParseVN | Converts NString to NSizeType.
NSizeTypeToChars | Converts NSizeType to an array of NChars.
NSizeTypeToString | Converts NSizeType to NString.
NSizeTypeTryParseN | Converts NString to NSizeType. A NBool value indicates whether the conversion succeeded.
NSizeTypeTryParseStrOrChars | Converts an array of NChars to NSizeType. A NBool value indicates whether the conversion succeeded.
NSizeTypeTryParseVN | Converts NString to NSizeType. A NBool value indicates whether the conversion succeeded.
NSwapDWordArray | Swaps the element order of the specified array of unsigned integers from little Endian to big Endian, or vice-versa.
NSwapDouble | Swaps the byte order of the specified double value from little Endian to big Endian, or vice-versa.
NSwapDoubleArray | Swaps the element order of the specified array of single values from little Endian to big Endian, or vice-versa.
NSwapQWordArray | Swaps the element order of the specified array of unsigned long integers from little Endian to big Endian, or vice-versa.
NSwapSingle | Swaps the byte order of the specified single value from little Endian to big Endian, or vice-versa.
NSwapSingleArray | Swaps the element order of the specified array of single values from little Endian to big Endian, or vice-versa.
NSwapWordArray | Swaps the element order of the specified array of unsigned short integers from little Endian to big Endian, or vice-versa.
NTypesGetPointer | Retrieves a pointer to object.
NUInt16ParseN | Converts NString to NUInt16.
NUInt16ParseStrOrChars | Converts an array of NChars to NUInt16.
NUInt16ParseVN | Converts NString to NUInt16.
NUInt16ToChars | Converts NUInt16 to an array of NChars.
NUInt16ToString | Converts NUInt16 to NString.
NUInt16TryParseN | Converts NString to NUInt16. A NBool value indicates whether the conversion succeeded.
NUInt16TryParseStrOrChars | Converts an array of NChars to NUInt16. A NBool value indicates whether the conversion succeeded.
NUInt16TryParseVN | Converts NString to NUInt16. A NBool value indicates whether the conversion succeeded.
NUInt32ParseN | Converts NString to NUInt32.
NUInt32ParseStrOrChars | Converts an array of NChars to NUInt32.
NUInt32ParseVN | Converts NString to NUInt32.
NUInt32ToChars | Converts NUInt32 to an array of NChars.
NUInt32ToString | Converts NUInt32 to NString.
NUInt32TryParseN | Converts NString to NUInt32. A NBool value indicates whether the conversion succeeded.
NUInt32TryParseStrOrChars | Converts an array of NChars to NUInt32. A NBool value indicates whether the conversion succeeded.
NUInt32TryParseVN | Converts NString to NUInt32. A NBool value indicates whether the conversion succeeded.
NUInt64ParseN | Converts NString to NUInt64.
NUInt64ParseStrOrChars | Converts an array of NChars to NUInt64.
NUInt64ParseVN | Converts NString to NUInt64.
NUInt64ToChars | Converts NUInt64 to an array of NChars.
NUInt64ToString | Converts NUInt64 to NString.
NUInt64TryParseN | Converts NString to NUInt64. A NBool value indicates whether the conversion succeeded.
NUInt64TryParseStrOrChars | Converts an array of NChars to NUInt64. A NBool value indicates whether the conversion succeeded.
NUInt64TryParseVN | Converts NString to NUInt64. A NBool value indicates whether the conversion succeeded.
NUInt8ParseN | Converts NString to NUInt8.
NUInt8ParseStrOrChars | Converts an array of NChars to NUInt8.
NUInt8ParseVN | Converts NString to NUInt8.
NUInt8ToChars | Converts NUInt8 to an array of NChars.
NUInt8ToString | Converts NUInt8 to NString.
NUInt8TryParseN | Converts NString to NUInt8. A NBool value indicates whether the conversion succeeded.
NUInt8TryParseStrOrChars | Converts an array of NChars to NUInt8. A NBool value indicates whether the conversion succeeded.
NUInt8TryParseVN | Converts NString to NUInt8. A NBool value indicates whether the conversion succeeded.
NURationalToString | Converts NURational to NString.
NVersionRangeContains | Checks if NVersionRange contains a certain version.
NVersionRangeContainsRange | Checks if NVersionRange contains a certain version range.
NVersionRangeIntersect | Replaces NVersionRange with the intersection of itself and another NVersionRange.
NVersionRangeIntersectsWith | Returns third NVersionRange that represents the intersection of two other NVersionRanges. If there is no intersection, an empty NVersionRange is returned.
NVersionRangeToString | Converts NVersionRange to NString.
NVersionToString | Converts NVersion to NString.
NWCharParseN | Converts NString to NWChar.
NWCharParseStrOrChars | Converts an array of NChars to NWChar.
NWCharParseVN | Converts NString to NWChar.
NWCharToChars | Converts NWChar to an array of NChars.
NWCharToString | Converts NWChar to NString.
NWCharTryParseN | Converts NString to NWChar. A NBool value indicates whether the conversion succeeded.
NWCharTryParseStrOrChars | Converts an array of NChars to NWChar. A NBool value indicates whether the conversion succeeded.
NWCharTryParseVN | Converts NString to NWChar. A NBool value indicates whether the conversion succeeded.
Collapse Expand Macros
Name | Description
N_DECLARE_HANDLE | Declares handle with specified name.
NACharParse | Converts a NString to NAChar.
NACharParseChars | Converts an array of NChars to NAChar.
NACharParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NACharParseStrOrChars function.
NACharParseVN | Picks a Unicode (W) or ASCII (A) version of the NACharParseVN function.
NACharToChars | Picks a Unicode (W) or ASCII (A) version of the NACharToChars function.
NACharToString | Picks a Unicode (W) or ASCII (A) version of the NACharToString function.
NACharTryParse | Converts NString to NAChar. A NBool value indicates whether the conversion succeeded.
NACharTryParseChars | Converts an array of NChars to NAChar. A NBool value indicates whether the conversion succeeded.
NACharTryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NACharTryParseStrOrChars function.
NACharTryParseVN | Picks a Unicode (W) or ASCII (A) version of the NACharTryParseVN function.
NBooleanParse | Converts NString to NBoolean.
NBooleanParseChars | Converts an array of NChars to NBoolean.
NBooleanParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NBooleanParseStrOrChars function.
NBooleanParseVN | Picks a Unicode (W) or ASCII (A) version of the NBooleanParseVN function.
NBooleanToChars | Picks a Unicode (W) or ASCII (A) version of the NBooleanToChars function.
NBooleanToString | Picks a Unicode (W) or ASCII (A) version of the NBooleanToString function.
NBooleanTryParse | Converts NString to NBoolean. A NBool value indicates whether the conversion succeeded.
NBooleanTryParseChars | Converts an array of NChars to NBoolean. A NBool value indicates whether the conversion succeeded.
NBooleanTryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NBooleanTryParseStrOrChars function.
NBooleanTryParseVN | Picks a Unicode (W) or ASCII (A) version of the NBooleanTryParseVN function.
NCharFromBinDigit | Picks a Unicode (W) or ASCII (A) version of the NCharFromBinDigit function.
NCharFromDigit | Picks a Unicode (W) or ASCII (A) version of the NCharFromDigit function.
NCharFromHexDigit | Picks a Unicode (W) or ASCII (A) version of the NCharFromHexDigit function.
NCharFromOctDigit | Picks a Unicode (W) or ASCII (A) version of the NCharFromOctDigit function.
NCharIsAscii | Picks a Unicode (W) or ASCII (A) version of the NCharIsAscii function.
NCharIsBinDigit | Picks a Unicode (W) or ASCII (A) version of the NCharIsBinDigit function.
NCharIsDigit | Picks a Unicode (W) or ASCII (A) version of the NCharIsDigit function.
NCharIsHexDigit | Picks a Unicode (W) or ASCII (A) version of the NCharIsHexDigit function.
NCharIsLetter | Picks a Unicode (W) or ASCII (A) version of the NCharIsLetter function.
NCharIsLower | Picks a Unicode (W) or ASCII (A) version of the NCharIsLower function.
NCharIsOctDigit | Picks a Unicode (W) or ASCII (A) version of the NCharIsOctDigit function.
NCharIsUpper | Picks a Unicode (W) or ASCII (A) version of the NCharIsUpper function.
NCharIsWhiteSpace | Picks a Unicode (W) or ASCII (A) version of the NCharIsWhiteSpace function.
NCharParse | Converts NString to NChar.
NCharParseChars | Converts an array of NChars to NBoolean.
NCharToBinDigit | Picks a Unicode (W) or ASCII (A) version of the NCharToBinDigit function.
NCharToDigit | Picks a Unicode (W) or ASCII (A) version of the NCharToDigit function.
NCharToHexDigit | Picks a Unicode (W) or ASCII (A) version of the NCharToHexDigit function.
NCharToLower | Picks a Unicode (W) or ASCII (A) version of the NCharToLower function.
NCharToOctDigit | Picks a Unicode (W) or ASCII (A) version of the NCharToOctDigit function.
NCharToUpper | Picks a Unicode (W) or ASCII (A) version of the NCharToUpper function.
NCharTryParse | Converts NString to NChar. A NBool value indicates whether the conversion succeeded.
NCharTryParseChars | Converts an array of NChars to NChar. A NBool value indicates whether the conversion succeeded.
NDoubleParse | Converts NString to NDouble.
NDoubleParseChars | Converts an array of NChars to NChar.
NDoubleParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NDoubleParseStrOrChars function.
NDoubleParseVN | Picks a Unicode (W) or ASCII (A) version of the NDoubleParseVN function.
NDoubleToChars | Picks a Unicode (W) or ASCII (A) version of the NDoubleToChars function.
NDoubleToString | Picks a Unicode (W) or ASCII (A) version of the NDoubleToString function.
NDoubleTryParse | Converts NString to NDouble. A NBool value indicates whether the conversion succeeded.
NDoubleTryParseChars | Converts an array of NChars to NDouble. A NBool value indicates whether the conversion succeeded.
NDoubleTryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NDoubleTryParseStrOrChars function.
NDoubleTryParseVN | Picks a Unicode (W) or ASCII (A) version of the NDoubleTryParseVN function.
NFalse | False value for NBoolean.
NGuidParse | Picks a Unicode (W) or ASCII (A) version of the NGuidParse function.
NGuidParseVN | Picks a Unicode (W) or ASCII (A) version of the NGuidParseVN function.
NGuidToString | Picks a Unicode (W) or ASCII (A) version of the NGuidToString function.
NGuidTryParse | Picks a Unicode (W) or ASCII (A) version of the NGuidTryParse function.
NGuidTryParseVN | Picks a Unicode (W) or ASCII (A) version of the NGuidTryParseVN function.
NIndexPairToString | Picks a Unicode (W) or ASCII (A) version of the NIndexPairToString function.
NInt16Parse | Converts NString to NInt16.
NInt16ParseChars | Converts an array of NChars to NInt16.
NInt16ParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NInt16ParseStrOrChars function.
NInt16ParseVN | Picks a Unicode (W) or ASCII (A) version of the NInt16ParseVN function.
NInt16ToChars | Picks a Unicode (W) or ASCII (A) version of the NInt16ToChars function.
NInt16ToString | Picks a Unicode (W) or ASCII (A) version of the NInt16ToString function.
NInt16TryParse | Converts NString to NInt16. A NBool value indicates whether the conversion succeeded.
NInt16TryParseChars | Converts an array of NChars to NInt16. A NBool value indicates whether the conversion succeeded.
NInt16TryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NInt16TryParseStrOrChars function.
NInt16TryParseVN | Picks a Unicode (W) or ASCII (A) version of the NInt16TryParseVN function.
NInt32Parse | Converts NString to NInt32.
NInt32ParseChars | Converts an array of NChars to NInt32.
NInt32ParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NInt32ParseStrOrChars function.
NInt32ParseVN | Picks a Unicode (W) or ASCII (A) version of the NInt32ParseVN function.
NInt32ToChars | Picks a Unicode (W) or ASCII (A) version of the NInt32ToChars function.
NInt32ToString | Picks a Unicode (W) or ASCII (A) version of the NInt32ToString function.
NInt32TryParse | Converts NString to NInt32. A NBool value indicates whether the conversion succeeded.
NInt32TryParseChars | Converts an array of NChars to NInt32. A NBool value indicates whether the conversion succeeded.
NInt32TryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NInt32TryParseStrOrChars function.
NInt32TryParseVN | Picks a Unicode (W) or ASCII (A) version of the NInt32tryParseVN function.
NInt64Parse | Converts NString to NInt64.
NInt64ParseChars | Converts an array of NChars to NInt64.
NInt64ParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NInt64ParseStrOrChars function.
NInt64ParseVN | Picks a Unicode (W) or ASCII (A) version of the NInt64ParseVN function.
NInt64ToChars | Picks a Unicode (W) or ASCII (A) version of the NInt64ToChars function.
NInt64ToString | Picks a Unicode (W) or ASCII (A) version of the NInt64ToString function.
NInt64TryParse | Converts NString to NInt64. A NBool value indicates whether the conversion succeeded.
NInt64TryParseChars | Converts an array of NChars to NInt64. A NBool value indicates whether the conversion succeeded.
NInt64TryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NInt64TryParseStrOrChars function.
NInt64TryParseVN | Picks a Unicode (W) or ASCII (A) version of the NInt64TryParseVN function.
NInt8Parse | Converts NString to NInt8.
NInt8ParseChars | Converts an array of NChars to NInt8.
NInt8ParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NInt8ParseStrOrChars function.
NInt8ParseVN | Picks a Unicode (W) or ASCII (A) version of the NInt8ParseVN function.
NInt8ToChars | Picks a Unicode (W) or ASCII (A) version of the NInt8ToChars function.
NInt8ToString | Picks a Unicode (W) or ASCII (A) version of the NInt8ToString function.
NInt8TryParse | Converts NString to NInt8. A NBool value indicates whether the conversion succeeded.
NInt8TryParseChars | Converts an array of NChars to NInt8. A NBool value indicates whether the conversion succeeded.
NInt8TryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NInt8TryParseStrOrChars function.
NInt8TryParseVN | Picks a Unicode (W) or ASCII (A) version of the NInt8TryParseVN function.
NPointerParse | Converts NString to NPointer.
NPointerParseChars | Converts an array of NChars to NPointer.
NPointerParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NPointerParseStrOrChars function.
NPointerParseVN | Picks a Unicode (W) or ASCII (A) version of the NPointerParseVN function.
NPointerToChars | Picks a Unicode (W) or ASCII (A) version of the NPointerToChars function.
NPointerToString | Picks a Unicode (W) or ASCII (A) version of the NPointerToString function.
NPointerTryParse | Converts NString to NInt8. A NBool value indicates whether the conversion succeeded.
NPointerTryParseChars | Converts an array of NChars to NPointer. A NBool value indicates whether the conversion succeeded.
NPointerTryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NPointerTryParseStrOrChars function.
NPointerTryParseVN | Picks a Unicode (W) or ASCII (A) version of the NPointerTryParseVN function.
NRangeToString | Picks a Unicode (W) or ASCII (A) version of the NRangeToString function.
NRationalToString | Picks a Unicode (W) or ASCII (A) version of the NRationalToString function.
NResultParseVN | Picks a Unicode (W) or ASCII (A) version of the NResultParseVN function.
NResultToChars | Picks a Unicode (W) or ASCII (A) version of the NResultToChars function.
NResultToString | Picks a Unicode (W) or ASCII (A) version of the ResultToString function.
NResultTryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NResultTryParseStrOrChars function.
NResultTryParseVN | Picks a Unicode (W) or ASCII (A) version of the NResultTryParseVN function.
NSSizeTypeParse | Converts NString to NSSizeType.
NSSizeTypeParseChars | Converts an array of NChars to NSSizeType.
NSSizeTypeParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NSSizeTypeParseStrOrChars function.
NSSizeTypeParseVN | Picks a Unicode (W) or ASCII (A) version of the NSSizeTypeParseVN function.
NSSizeTypeToChars | Picks a Unicode (W) or ASCII (A) version of the NSSizeTypeToChars function.
NSSizeTypeToString | Picks a Unicode (W) or ASCII (A) version of the NSSizeTypeToString function.
NSSizeTypeTryParse | Converts NString to NSSizeType. A NBool value indicates whether the conversion succeeded.
NSSizeTypeTryParseChars | Converts an array of NChars to NSSizeType. A NBool value indicates whether the conversion succeeded.
NSSizeTypeTryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NSSizeTypeTryParseStrOrChars function.
NSSizeTypeTryParseVN | Picks a Unicode (W) or ASCII (A) version of the NSSizeTypeTryParseVN function.
NSingleParse | Converts NString to NSingle.
NSingleParseChars | Converts an array of NChars to NSingle.
NSingleParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NSingleParseStrOrChars function.
NSingleParseVN | Picks a Unicode (W) or ASCII (A) version of the NSingleParseVN function.
NSingleToChars | Picks a Unicode (W) or ASCII (A) version of the NSingleToChars function.
NSingleToString | Picks a Unicode (W) or ASCII (A) version of the NSingleToString function.
NSingleTryParse | Converts NString to NSingle. A NBool value indicates whether the conversion succeeded.
NSingleTryParseChars | Converts an array of NChars to NSingle. A NBool value indicates whether the conversion succeeded.
NSingleTryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NSingleTryParseStrOrChars function.
NSingleTryParseVN | Picks a Unicode (W) or ASCII (A) version of the NSingleTryParseVN function.
NSizeTypeParse | Converts NString to NSizeType.
NSizeTypeParseChars | Converts an array of NChars to NSizeType.
NSizeTypeParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NSizeTypeParseStrOrChars function.
NSizeTypeParseVN | Picks a Unicode (W) or ASCII (A) version of the NSizeTypeParseVN function.
NSizeTypeToChars | Picks a Unicode (W) or ASCII (A) version of the NSizeTypeToChars function.
NSizeTypeToString | Picks a Unicode (W) or ASCII (A) version of the NSizeTypeToString function.
NSizeTypeTryParse | Converts NString to NSizeType. A NBool value indicates whether the conversion succeeded.
NSizeTypeTryParseChars | Converts an array of NChars to NSizeType. A NBool value indicates whether the conversion succeeded.
NSizeTypeTryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NSizeTypeTryParseStrOrChars function.
NSizeTypeTryParseVN | Picks a Unicode (W) or ASCII (A) version of the NSizeTypeTryParseVN function.
NTrue | True value for NBoolean.
NUInt16Parse | Converts NString to NUInt16.
NUInt16ParseChars | Converts an array of NChars to NUInt16.
NUInt16ParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NUInt16ParseStrOrChars function.
NUInt16ParseVN | Picks a Unicode (W) or ASCII (A) version of the NUInt16ParseVN function.
NUInt16ToChars | Picks a Unicode (W) or ASCII (A) version of the NUInt16ToChars function.
NUInt16ToString | Picks a Unicode (W) or ASCII (A) version of the NUInt16ParseToString function.
NUInt16TryParse | Converts NString to NUInt16. A NBool value indicates whether the conversion succeeded.
NUInt16TryParseChars | Converts an array of NChars to NUInt16. A NBool value indicates whether the conversion succeeded.
NUInt16TryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NUInt16TryParseStrOrChars function.
NUInt16TryParseVN | Picks a Unicode (W) or ASCII (A) version of the NUInt16TryParseVN function.
NUInt32Parse | Converts NString to NUInt32.
NUInt32ParseChars | Converts an array of NChars to NUInt32.
NUInt32ParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NUInt32ParseStrOrChars function.
NUInt32ParseVN | Picks a Unicode (W) or ASCII (A) version of the NUInt32ParseVN function.
NUInt32ToChars | Picks a Unicode (W) or ASCII (A) version of the NUInt32ToChars function.
NUInt32ToString | Picks a Unicode (W) or ASCII (A) version of the NUInt32ToString function.
NUInt32TryParse | Converts NString to NUInt32. A NBool value indicates whether the conversion succeeded.
NUInt32TryParseChars | Converts an array of NChars to NUInt32. A NBool value indicates whether the conversion succeeded.
NUInt32TryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NUInt32TryParseStrOrChars function.
NUInt32TryParseVN | Picks a Unicode (W) or ASCII (A) version of the NUInt32TryParseVN function.
NUInt64Parse | Converts NString to NUInt64.
NUInt64ParseChars | Converts an array of NChars to NUInt64.
NUInt64ParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NUInt64ParseStrOrChars function.
NUInt64ParseVN | Picks a Unicode (W) or ASCII (A) version of the NUInt64ParseVN function.
NUInt64ToChars | Picks a Unicode (W) or ASCII (A) version of the NUInt64ToChars function.
NUInt64ToString | Picks a Unicode (W) or ASCII (A) version of the NUInt64ToString function.
NUInt64TryParse | Converts NString to NUInt64. A NBool value indicates whether the conversion succeeded.
NUInt64TryParseChars | Converts an array of NChars to NUInt64. A NBool value indicates whether the conversion succeeded.
NUInt64TryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NUInt64TryParseStrOrChars function.
NUInt64TryParseVN | Picks a Unicode (W) or ASCII (A) version of the NUInt64TryParseVN function.
NUInt8Parse | Converts NString to NUInt8.
NUInt8ParseChars | Converts an array of NChars to NUInt8.
NUInt8ParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NUInt8ParseStrOrChars function.
NUInt8ParseVN | Picks a Unicode (W) or ASCII (A) version of the NUInt8ParseVN function.
NUInt8ToChars | Picks a Unicode (W) or ASCII (A) version of the NUInt8ToChars function.
NUInt8ToString | Picks a Unicode (W) or ASCII (A) version of the NUInt8ToString function.
NUInt8TryParse | Converts NString to NUInt8. A NBool value indicates whether the conversion succeeded.
NUInt8TryParseChars | Converts an array of NChars to NUInt8. A NBool value indicates whether the conversion succeeded.
NUInt8TryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NUInt8TryParseStrOrChars function.
NUInt8TryParseVN | Picks a Unicode (W) or ASCII (A) version of the NUInt8TryParseVN function.
NULL | Null value for pointer.
NURationalToString | Picks a Unicode (W) or ASCII (A) version of the NURationalToString function.
NVersionRangeToString | Picks a Unicode (W) or ASCII (A) version of the NVersionRangeToString function.
NVersionToString | Picks a Unicode (W) or ASCII (A) version of the NVersionToString function.
NWCharParse | Converts NString to NWChar.
NWCharParseChars | Converts an array of NChars to NWChar.
NWCharParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NWCharParseStrOrChars function.
NWCharParseVN | Picks a Unicode (W) or ASCII (A) version of the NWCharParseVN function.
NWCharToChars | Picks a Unicode (W) or ASCII (A) version of the NWCharToChars function.
NWCharToString | Picks a Unicode (W) or ASCII (A) version of the NWCharToString function.
NWCharTryParse | Converts NString to NWChar. A NBool value indicates whether the conversion succeeded.
NWCharTryParseChars | Converts an array of NChars to NWChar. A NBool value indicates whether the conversion succeeded.
NWCharTryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NWCharTryParseStrOrChars function.
NWCharTryParseVN | Picks a Unicode (W) or ASCII (A) version of the NWCharTryParseVN function.
N_BOOLEAN_FALSE_STRING | ANSI or Unicode (if N_UNICODE is defined) string, representing NFalse Boolean value.
N_BOOLEAN_FALSE_STRINGA | ANSI string, representing NFalse Boolean value.
N_BOOLEAN_FALSE_STRINGW | Unicode (if N_UNICODE is defined) string, representing NFalse Boolean value.
N_BOOLEAN_TRUE_STRING | ANSI or Unicode (if N_UNICODE is defined) string, representing NTrue Boolean value.
N_BOOLEAN_TRUE_STRINGA | ANSI string, representing NTrue Boolean value.
N_BOOLEAN_TRUE_STRINGW | Unicode (if N_UNICODE is defined) string, representing NTrue Boolean value.
N_BYTE_MAX | Maximum value for NByte.
N_BYTE_MIN | Minimum value for NByte.
N_DECLARE_HANDLE_TYPE | Declares handle type with specified name.
N_DECLARE_OBJECT_TYPE | Declares object type with specified name.
N_DECLARE_STATIC_OBJECT_TYPE | Declares static object type with specified name.
N_DECLARE_TYPE | Declares type with specified name.
N_DECLATE_PRIMITIVE | Declares primitive with specified name.
N_DOUBLE_EPSILON | Epsilon value for NDouble.
N_DOUBLE_MAX | Maximum value for NDouble.
N_DOUBLE_MIN | Minimum value for NDouble.
N_FLOAT_EPSILON | Epsilon value for NFloat.
N_FLOAT_INFINITY_STRING | ANSI or Unicode (if N_UNICODE is defined) string, representing "Infinity" floating-point value.
N_FLOAT_INFINITY_STRINGA | ANSI string, representing "Infinity" floating-point value.
N_FLOAT_INFINITY_STRINGW | Unicode (if N_UNICODE is defined) string, representing "Infinity" floating-point value.
N_FLOAT_MAX | Maximum value for NFloat.
N_FLOAT_MIN | Minimum value for NFloat.
N_FLOAT_NAN_STRING | ANSI or Unicode (if N_UNICODE is defined) string, representing "NaN" floating-point value.
N_FLOAT_NAN_STRINGA | ANSI string, representing "NaN" floating-point value.
N_FLOAT_NAN_STRINGW | Unicode (if N_UNICODE is defined) string, representing "NaN" floating-point value.
N_INT16_MAX | Maximum value for NShort.
N_INT16_MIN | Minimum value for NShort.
N_INT32_MAX | Maximum value for NInt.
N_INT32_MIN | Minimum value for NInt.
N_INT64_MAX | Maximum value for NInt64.
N_INT64_MIN | Minimum value for NInt64.
N_INT8_MAX | Maximum value for NSByte.
N_INT8_MIN | Minimum value for NSByte.
N_INT_MAX | Maximum value for NInt.
N_INT_MIN | Minimum value for NInt.
N_LONG_MAX | Maximum value for NLong.
N_LONG_MIN | Minimum value for NLong.
N_PTR_SIZE | Defines pointer size.
N_SBYTE_MAX | Maximum value for NSByte.
N_SBYTE_MIN | Minimum value for NSByte.
N_SHORT_MAX | Maximum value for NShort.
N_SHORT_MIN | Minimum value for NShort.
N_SINGLE_EPSILON | Epsilon value for NSingle.
N_SINGLE_MAX | Maximum value for NSingle.
N_SINGLE_MIN | Minimum value for NSingle.
N_SIZE_TYPE_MAX | Maximum value for NSizeType.
N_SIZE_TYPE_MIN | Minimum value for NSizeType.
N_SSIZE_TYPE_MAX | Maximum value for NSSizeType.
N_SSIZE_TYPE_MIN | Minimum value for NSSizeType.
N_TYPE_OF | Used to obtain a pointer to the function that retrieves NType object for the specified type name.",
N_UINT16_MAX | Maximum value for NUShort.
N_UINT16_MIN | Minimum value for NUShort.
N_UINT32_MAX | Maximum value for NUInt.
N_UINT32_MIN | Minimum value for NUInt.
N_UINT64_MAX | Maximum value for NULong.
N_UINT64_MIN | Minimum value for NULong.
N_UINT8_MAX | Maximum value for NUInt8.
N_UINT8_MIN | Minimum value for NUInt8.
N_UINT_MAX | Maximum value for NUInt.
N_UINT_MIN | Minimum value for NUInt.
N_ULONG_MAX | Maximum value for NULong.
N_ULONG_MIN | Minimum value for NULong.
N_UNREFERENCED_PARAMETER | Suppresses the warning "unreferenced parameter".
N_UNUSED_VARIABLE | Suppresses the warning "unused variable".
N_USHORT_MAX | Maximum value for NUShort.
N_USHORT_MIN | Minimum value for NUShort.
N_WCHAR_SIZE | Defines the size of Unicode char.
Collapse Expand Structs, Records, Enums
Name | Description
NAttributes_ | Enumerates value attributes.
NComplex_ | Represents a complex number value.
NIndexPair_ | Represents a pair of indexes.
NNameStringPair_ | Represents a pair of name strings.
NOSFamily_ | Enumerates OS families.
NRational_ | Represents a signed rational number.
NURational_ | Represents an unsigned rational number.
NAttributes | Enumerates value attributes.
NOSFamily | Enumerates OS families.
Collapse Expand Types
Name | Description
NAChar | ANSI character (8-bit).
NBool | Same as NBoolean.
NBoolean | 32-bit boolean value. See also NTrue and NFalse.
NByte | Same as NUInt8.
NChar | ANSI character (8-bit). See also NAChar.
NComplex | Complex number.
NDouble | Double precision floating point number.
NFloat | Same as NSingle.
NHandle | Pointer to unspecified data (same as void *).
NIndexPair | Represents a pair of indexes.
NInt | Same as NInt32.
NInt16 | 16-bit signed integer (short).
NInt32 | 32-bit signed integer (int).
NInt64 | 64-bit signed integer (long). Not available on some 32-bit platforms.
NInt8 | 8-bit signed integer (signed byte).
NLong | Same as NInt64.
NNameStringPair | Two linked strings.
NRational | Represents a signed rational number.
NResult | Result of a function (same as NInt). See also NErrors module.
NSByte | Same as NInt8.
NSSizeType | Platform dependent size type. Signed 32-bit integer on 32-bit platform, signed 64-bit integer on 64-bit platform.
NShort | Same as NInt16.
NSingle | Single precision floating point number.
NSizeType | Platform dependent size type. Unsigned 32-bit integer on 32-bit platform, unsigned 64-bit integer on 64-bit platform.
NUInt | Same as NUInt32.
NUInt16 | 16-bit unsigned integer (unsigned short).
NUInt32 | 32-bit unsigned integer (unsigned int).
NUInt64 | 64-bit unsigned integer (unsigned long). Not available on some 32-bit platforms.
NUInt8 | 8-bit unsigned integer (byte).
NULong | Same as NUInt64.
NURational | Represents an unsigned rational number.
NUShort | Same as NUInt16.
NVersion | Two NInt32 values defining a version.
NVersionRange | Four NInt32 values defining a version range.
NVersionRange_ | A NUInt typedef defining a version range.
NVersion_ | A NUShort typedef defining a version.


NACharParseN Function

NACharParseN Function
NTypes.h

Converts a NString to NAChar.

C++
NResult N_API NACharParseN(HNString hValue, HNString hFormat, NAChar * pValue);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
HNString hFormat | [in] Handle to format string.
NAChar * pValue | [out] A pointer to the converted NAChar.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NACharParseStrOrChars Function

NACharParseStrOrChars Function
NTypes.h

Converts an array of NChars to NAChar.

C++
NResult N_API NACharParseStrOrChars(const NChar * arValue, NInt valueLength, const NChar * szFormat, NAChar * pValue);
Collapse Expand Parameters
Parameters | Description
const NChar * arValue | [in] A pointer to NChar array.
NInt valueLength | [in] Length of the array.
const NChar * szFormat | [in] Pointer to format string.
NAChar * pValue | [out] A pointer to the converted NAChar.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NACharParseVN Function

NACharParseVN Function
NTypes.h

Converts a NString to NAChar.

C++
NResult N_API NACharParseVN(HNString hValue, const NChar * szFormat, NAChar * pValue);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
const NChar * szFormat | [in] Pointer to format string.
NAChar * pValue | [out] A pointer to the converted NAChar.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NACharToChars Function

NACharToChars Function
NTypes.h

Converts NAChar to an array of NAChars.

C++
NResult N_API NACharToChars(NAChar value, const NChar * szFormat, NChar * arValue, NInt valueLength);
Collapse Expand Parameters
Parameters | Description
NAChar value | [in] The NAChar to be converted.
const NChar * szFormat | [in] Pointer to format string.
NChar * arValue | [out] A pointer the converted array of NAChars.
NInt valueLength | [in] Length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NACharToString Function

NACharToString Function
NTypes.h

Converts NAChar to NString

C++
NResult N_API NACharToString(NAChar value, const NChar * szFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
NAChar value | [in] NAChar to be converted.
const NChar * szFormat | [in] Pointer to format string.
HNString * phValue | [out] A pointer to the converted NString.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NACharTryParseN Function

NACharTryParseN Function
NTypes.h

Converts NString to NAChar. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NACharTryParseN(HNString hValue, HNString hFormat, NAChar * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
HNString hFormat | [in] Handle to format string.
NAChar * pValue | [out] A pointer to the converted NAChar.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NACharTryParseStrOrChars Function

NACharTryParseStrOrChars Function
NTypes.h

Converts an array of NChars to NAChar. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NACharTryParseStrOrChars(const NChar * arValue, NInt valueLength, const NChar * szFormat, NAChar * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
const NChar * arValue | [in] A pointer to NChar array.
NInt valueLength | [in] Length of the array.
const NChar * szFormat | [in] Pointer to format string.
NAChar * pValue | [out] A pointer to the converted NAChar.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NACharTryParseVN Function

NACharTryParseVN Function
NTypes.h

Converts NString to NAChar. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NACharTryParseVN(HNString hValue, const NChar * szFormat, NAChar * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
const NChar * szFormat | [in] Pointer to format string.
NAChar * pValue | [out] A pointer to the converted NAChar.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NBooleanParseN Function

NBooleanParseN Function
NTypes.h

Converts NString to NBoolean.

C++
NResult N_API NBooleanParseN(HNString hValue, HNString hFormat, NBoolean * pValue);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted..
HNString hFormat | [in] Handle to format string.
NBoolean * pValue | [out] A pointer to the converted NBoolean.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NBooleanParseStrOrChars Function

NBooleanParseStrOrChars Function
NTypes.h

Converts an array of NChars to NBoolean.

C++
NResult N_API NBooleanParseStrOrChars(const NChar * arValue, NInt valueLength, const NChar * szFormat, NBoolean * pValue);
Collapse Expand Parameters
Parameters | Description
const NChar * arValue | [in] A pointer to NChar array.
NInt valueLength | [in] Length of the array.
const NChar * szFormat | [in] Pointer to format string.
NBoolean * pValue | [out] A pointer to the converted NBoolean.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NBooleanParseVN Function

NBooleanParseVN Function
NTypes.h

Converts NString to NBoolean.

C++
NResult N_API NBooleanParseVN(HNString hValue, const NChar * szFormat, NBoolean * pValue);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
const NChar * szFormat | [in] Pointer to format string.
NBoolean * pValue | [out] A pointer to the converted NBoolean.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NBooleanToChars Function

NBooleanToChars Function
NTypes.h

Converts NBoolean to an array of NChars.

C++
NResult N_API NBooleanToChars(NBoolean value, const NChar * szFormat, NChar * arValue, NInt valueLength);
Collapse Expand Parameters
Parameters | Description
NBoolean value | [in] The NBoolean to be converted.
const NChar * szFormat | [in] Pointer to format string.
NChar * arValue | [out] A pointer to the converted array of NAChars.
NInt valueLength | [in] Length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NBooleanToString Function

NBooleanToString Function
NTypes.h

Converts NBoolean to NString.

C++
NResult N_API NBooleanToString(NBoolean value, const NChar * szFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
NBoolean value | [in] NBoolean to be converted.
const NChar * szFormat | [in] Pointer to format string.
HNString * phValue | [out] A pointer to the converted NString.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NBooleanTryParseN Function

NBooleanTryParseN Function
NTypes.h

Converts a NString to NBoolean. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NBooleanTryParseN(HNString hValue, HNString hFormat, NBoolean * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to convert.
HNString hFormat | [in] Handle to format string.
NBoolean * pValue | [out] A pointer to the converted NBoolean.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NBooleanTryParseStrOrChars Function

NBooleanTryParseStrOrChars Function
NTypes.h

Converts an array of NStrings or NChars into NBoolean. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NBooleanTryParseStrOrChars(const NChar * arValue, NInt valueLength, const NChar * szFormat, NBoolean * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
const NChar * arValue | [in] A pointer to a NChar array.
NInt valueLength | [in] Length of the array.
const NChar * szFormat | [in] Pointer to format string.
NBoolean * pValue | [out] A pointer to the converted NBoolean.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NBooleanTryParseVN Function

NBooleanTryParseVN Function
NTypes.h

Converts a NString to NBoolean. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NBooleanTryParseVN(HNString hValue, const NChar * szFormat, NBoolean * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to convert.
const NChar * szFormat | [in] Pointer to format string.
NBoolean * pValue | [out] A pointer to the converted NBoolean.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NCharFromBinDigit Function

NCharFromBinDigit Function
NTypes.h

Converts a binary digit to NChar.

C++
NChar N_API NCharFromBinDigit(NInt value);
Collapse Expand Parameters
Parameters | Description
NInt value | [in] NInt value to be converted.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NCharFromDigit Function

NCharFromDigit Function
NTypes.h

Converts a digit to NChar.

C++
NChar N_API NCharFromDigit(NInt value);
Collapse Expand Parameters
Parameters | Description
NInt value | [in] NInt value to be converted.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NCharFromHexDigit Function

NCharFromHexDigit Function
NTypes.h

Converts a hexadecimal digit to NChar.

C++
NChar N_API NCharFromHexDigit(NInt value, NBool lowercase);
Collapse Expand Parameters
Parameters | Description
NInt value | [in] NInt value to be converted.
NBool lowercase | [in] NTrue if lowercase; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NCharFromOctDigit Function

NCharFromOctDigit Function
NTypes.h

Converts an octal digit to NChar.

C++
NChar N_API NCharFromOctDigit(NInt value);
Collapse Expand Parameters
Parameters | Description
NInt value | [in] NInt value to be converted.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NCharIsAscii Function

NCharIsAscii Function
NTypes.h

Checks whether the specified char is ASCII.

C++
NBool N_API NCharIsAscii(NChar value);
Collapse Expand Parameters
Parameters | Description
NChar value | [in] Character to be checked.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NCharIsBinDigit Function

NCharIsBinDigit Function
NTypes.h

Checks whether the specified character is a binary digit.

C++
NBool N_API NCharIsBinDigit(NChar value);
Collapse Expand Parameters
Parameters | Description
NChar value | [in] Character to be checked.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NCharIsDigit Function

NCharIsDigit Function
NTypes.h

Checks whether the specified character is a digit.

C++
NBool N_API NCharIsDigit(NChar value);
Collapse Expand Parameters
Parameters | Description
NChar value | [in] Character to be checked.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NCharIsHexDigit Function

NCharIsHexDigit Function
NTypes.h

Checks whether the specified character is a hexadecimal digit.

C++
NBool N_API NCharIsHexDigit(NChar value);
Collapse Expand Parameters
Parameters | Description
NChar value | [in] Character to be checked.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NCharIsLetter Function

NCharIsLetter Function
NTypes.h

Checks whether the specified character is a letter.

C++
NBool N_API NCharIsLetter(NChar value);
Collapse Expand Parameters
Parameters | Description
NChar value | [in] Character to be checked.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NCharIsLower Function

NCharIsLower Function
NTypes.h

Checks whether the specified character is a lower value.

C++
NBool N_API NCharIsLower(NChar value);
Collapse Expand Parameters
Parameters | Description
NChar value | [in] Character to be checked.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NCharIsOctDigit Function

NCharIsOctDigit Function
NTypes.h

Checks whether the specified character is an octal digit.

C++
NBool N_API NCharIsOctDigit(NChar value);
Collapse Expand Parameters
Parameters | Description
NChar value | [in] Character to be checked.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NCharIsUpper Function

NCharIsUpper Function
NTypes.h

Checks whether the specified character is an upper value.

C++
NBool N_API NCharIsUpper(NChar value);
Collapse Expand Parameters
Parameters | Description
NChar value | [in] Character to be checked.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NCharIsWhiteSpace Function

NCharIsWhiteSpace Function
NTypes.h

Checks whether the specified character is a whitespace.

C++
NBool N_API NCharIsWhiteSpace(NChar value);
Collapse Expand Parameters
Parameters | Description
NChar value | [in] Character to be checked.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NCharParseN Function

NCharParseN Function
NTypes.h

Converts a NString to a NChar.

C++
NResult N_API NCharParseN(HNString hValue, HNString hFormat, NChar * pValue);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to convert.
HNString hFormat | For internal use.
NChar * pValue | [out] A pointer to converted NChar.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NCharParseStrOrChars Function

NCharParseStrOrChars Function
NTypes.h

Converts an array of NStrings or NChars into NChar.

C++
NResult N_API NCharParseStrOrChars(const NChar * arValue, NInt valueLength, const NChar * szFormat, NChar * pValue);
Collapse Expand Parameters
Parameters | Description
const NChar * arValue | [in] A pointer to a NChar array.
NInt valueLength | [in] Length of the array.
const NChar * szFormat | [in] Pointer to format string.
NChar * pValue | [out] A pointer to converted NChar.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NCharParseVN Function

NCharParseVN Function
NTypes.h

Converts a NString to a NChar.

C++
NResult N_API NCharParseVN(HNString hValue, const NChar * szFormat, NChar * pValue);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to convert.
const NChar * szFormat | [in] Pointer to format string.
NChar * pValue | [out] A pointer to converted NChar.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NCharToBinDigit Function

NCharToBinDigit Function
NTypes.h

Converts a NChar to a binary digit.

C++
NInt N_API NCharToBinDigit(NChar value);
Collapse Expand Parameters
Parameters | Description
NChar value | [in] NChar to convert.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NCharToChars Function

NCharToChars Function
NTypes.h

Converts a NChar into an array of NChars.

C++
NResult N_API NCharToChars(NChar value, const NChar * szFormat, NChar * arValue, NInt valueLength);
Collapse Expand Parameters
Parameters | Description
NChar value | [in] A NChar to convert.
const NChar * szFormat | For internal use.
NChar * arValue | [out] A pointer to the converted NChar array.
NInt valueLength | [in] The length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NCharToDigit Function

NCharToDigit Function
NTypes.h

Converts a NChar to a digit.

C++
NInt N_API NCharToDigit(NChar value);
Collapse Expand Parameters
Parameters | Description
NChar value | [in] NChar to convert.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NCharToHexDigit Function

NCharToHexDigit Function
NTypes.h

Converts a NChar to a hexadecimal digit.

C++
NInt N_API NCharToHexDigit(NChar value);
Collapse Expand Parameters
Parameters | Description
NChar value | [in] NChar to convert.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NCharToLower Function

NCharToLower Function
NTypes.h

Converts a NChar to lowercase.

C++
NChar N_API NCharToLower(NChar value);
Collapse Expand Parameters
Parameters | Description
NChar value | [in] NChar to convert.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NCharToOctDigit Function

NCharToOctDigit Function
NTypes.h

Converts a NChar to an octal digit.

C++
NInt N_API NCharToOctDigit(NChar value);
Collapse Expand Parameters
Parameters | Description
NChar value | [in] NChar to convert.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NCharToString Function

NCharToString Function
NTypes.h

Converts NChar to NString.

C++
NResult N_API NCharToString(NChar value, const NChar * szFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
NChar value | [in] NChar to convert.
const NChar * szFormat | [in] Pointer to format string.
HNString * phValue | [out] A pointer to the converted NString.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NCharToUpper Function

NCharToUpper Function
NTypes.h

Converts NChar to uppercase.

C++
NChar N_API NCharToUpper(NChar value);
Collapse Expand Parameters
Parameters | Description
NChar value | [in] NChar to convert.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NCharTryParseN Function

NCharTryParseN Function
NTypes.h

Converts a NString to a NChar. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NCharTryParseN(HNString hValue, HNString hFormat, NChar * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to convert.
HNString hFormat | For internal use.
NChar * pValue | [out] A pointer to converted NChar.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NCharTryParseStrOrChars Function

NCharTryParseStrOrChars Function
NTypes.h

Converts an array of NChars into NChar. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NCharTryParseStrOrChars(const NChar * arValue, NInt valueLength, const NChar * szFormat, NChar * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
const NChar * arValue | [in] A pointer to a NChar array.
NInt valueLength | [in] Length of the array.
const NChar * szFormat | [in] Pointer to format string.
NChar * pValue | [out] A pointer to converted NChar.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NCharTryParseVN Function

NCharTryParseVN Function
NTypes.h

Converts a NString to a NChar. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NCharTryParseVN(HNString hValue, const NChar * szFormat, NChar * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to convert.
const NChar * szFormat | [in] Pointer to format string.
NChar * pValue | [out] A pointer to converted NChar.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NComplexToString Function

NComplexToString Function
NTypes.h

Converts NComplex to NString.

C++
NResult N_API NComplexToString(const NComplex * pValue, const NChar * szFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
const NComplex * pValue | [in] NComplex to be converted.
const NChar * szFormat | [in] Pointer to format string.
HNString * phValue | [out] A pointer to the converted NString.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NDoubleGetNaN Function

NDoubleGetNaN Function
NTypes.h

Retrieves a NDouble that is Not a Number (NaN).

C++
NDouble N_API NDoubleGetNaN();
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NDoubleGetNegativeInfinity Function

NDoubleGetNegativeInfinity Function
NTypes.h

Retrieves a NDouble that is NegativeInfinity.

C++
NDouble N_API NDoubleGetNegativeInfinity();
Collapse Expand Returns

NDouble value.

Container

File: NTypes.h

Module: NTypes Unit


NDoubleGetPositiveInfinity Function

NDoubleGetPositiveInfinity Function
NTypes.h

Retrieves a NDouble that is PositiveInfinity.

C++
NDouble N_API NDoubleGetPositiveInfinity();
Collapse Expand Returns

NDouble value.

Container

File: NTypes.h

Module: NTypes Unit


NDoubleIsInfinity Function

NDoubleIsInfinity Function
NTypes.h

Checks if NDouble evaluates to NegativeInfinity or PositiveInfinity.

C++
NBool N_API NDoubleIsInfinity(NDouble value);
Collapse Expand Parameters
Parameters | Description
NDouble value | [in] NDouble to be checked.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NDoubleIsNaN Function

NDoubleIsNaN Function
NTypes.h

Checks if NDouble is Not a Number (NaN).

C++
NBool N_API NDoubleIsNaN(NDouble value);
Collapse Expand Parameters
Parameters | Description
NDouble value | [in] NDouble to be checked.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NDoubleIsNegativeInfinity Function

NDoubleIsNegativeInfinity Function
NTypes.h

Checks if NDouble evaluates to NegativeInfinity.

C++
NBool N_API NDoubleIsNegativeInfinity(NDouble value);
Collapse Expand Parameters
Parameters | Description
NDouble value | [in] NDouble to be checked.
Collapse Expand Returns

NTrue if the value is negative infinity, else NFalse.

Container

File: NTypes.h

Module: NTypes Unit


NDoubleIsPositiveInfinity Function

NDoubleIsPositiveInfinity Function
NTypes.h

Checks if NDouble evaluates to PositiveInfinity

C++
NBool N_API NDoubleIsPositiveInfinity(NDouble value);
Collapse Expand Parameters
Parameters | Description
NDouble value | [in] NDouble to be checked.
Collapse Expand Returns

NTrue if the value is positive infinity, else NFalse.

Container

File: NTypes.h

Module: NTypes Unit


NDoubleParseN Function

NDoubleParseN Function
NTypes.h

Converts a NString into NDouble.

C++
NResult N_API NDoubleParseN(HNString hValue, HNString hFormat, NDouble * pValue);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
HNString hFormat | [in] Handle to numeric format string.
NDouble * pValue | [out] A pointer to the converted NDouble.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NDoubleParseStrOrChars Function

NDoubleParseStrOrChars Function
NTypes.h

Converted an array of NChars to NDouble.

C++
NResult N_API NDoubleParseStrOrChars(const NChar * arValue, NInt valueLength, const NChar * szFormat, NDouble * pValue);
Collapse Expand Parameters
Parameters | Description
const NChar * arValue | [in] A pointer to NChar array.
NInt valueLength | [in] Length of the array.
const NChar * szFormat | [in] Pointer to numeric format string.
NDouble * pValue | [out] A pointer to the converted NDouble.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NDoubleParseVN Function

NDoubleParseVN Function
NTypes.h

Converts a NString into NDouble.

C++
NResult N_API NDoubleParseVN(HNString hValue, const NChar * szFormat, NDouble * pValue);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
const NChar * szFormat | [in] Pointer to numeric format string.
NDouble * pValue | [out] A pointer to the converted NDouble.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NDoubleToChars Function

NDoubleToChars Function
NTypes.h

Converts NDouble to an array of NChars.

C++
NResult N_API NDoubleToChars(NDouble value, const NChar * szFormat, NChar * arValue, NInt valueLength);
Collapse Expand Parameters
Parameters | Description
NDouble value | [in] NDouble to be converted.
const NChar * szFormat | [in] Pointer to numeric format string.
NChar * arValue | [out] A pointer to the converted array of NChars.
NInt valueLength | [in] Length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NDoubleToString Function

NDoubleToString Function
NTypes.h

Converts NDouble to NString.

C++
NResult N_API NDoubleToString(NDouble value, const NChar * szFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
NDouble value | [in] NDouble to be converted.
const NChar * szFormat | [in] Pointer to numeric format string.
HNString * phValue | [out] A pointer to the converted NString.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NDoubleTryParseN Function

NDoubleTryParseN Function
NTypes.h

Converts a NString to NDouble. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NDoubleTryParseN(HNString hValue, HNString hFormat, NDouble * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
HNString hFormat | [in] Handle to numeric format string.
NDouble * pValue | [out] A pointer to the converted NDouble.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NDoubleTryParseStrOrChars Function

NDoubleTryParseStrOrChars Function
NTypes.h

Converts an array of NChars to NDouble. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NDoubleTryParseStrOrChars(const NChar * arValue, NInt valueLength, const NChar * szFormat, NDouble * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
const NChar * arValue | [in] A pointer to NChar array.
NInt valueLength | [in] Length of the array.
const NChar * szFormat | [in] Pointer to numeric format string.
NDouble * pValue | [out] A pointer to the converted NDouble.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NDoubleTryParseVN Function

NDoubleTryParseVN Function
NTypes.h

Converts a NString to NDouble. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NDoubleTryParseVN(HNString hValue, const NChar * szFormat, NDouble * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
const NChar * szFormat | [in] Pointer to numeric format string.
NDouble * pValue | [out] A pointer to the converted NDouble.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NGuidParse Function

NGuidParse Function
NTypes.h

Converts a NChar to NGuid.

C++
NResult N_API NGuidParse(const NChar * szValue, const NChar * szFormat, NGuid * pValue);
Collapse Expand Parameters
Parameters | Description
const NChar * szValue | [in] A pointer to NChar to be converted.
const NChar * szFormat | [in] Pointer to format string.
NGuid * pValue | [out] A pointer to the converted NGuid.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NGuidParseVN Function

NGuidParseVN Function
NTypes.h

Converts a NString to NGuid.

C++
NResult N_API NGuidParseVN(HNString hValue, const NChar * szFormat, NGuid * pValue);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
const NChar * szFormat | [in] Pointer to format string.
NGuid * pValue | [out] A pointer to the converted NGuid.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NGuidToString Function

NGuidToString Function
NTypes.h

Converts a NGuid to NString.

C++
NResult N_API NGuidToString(const NGuid * pValue, const NChar * szFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
const NGuid * pValue | [in] A pointer to NGuid to be converted.
const NChar * szFormat | [in] Pointer to format string.
HNString * phValue | [out] A pointer to the converted NString.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NGuidTryParse Function

NGuidTryParse Function
NTypes.h

Converts a NChar to NGuid. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NGuidTryParse(const NChar * szValue, const NChar * szFormat, NGuid * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
const NChar * szValue | [in] A pointer to NChar to be converted.
const NChar * szFormat | [in] Pointer to format string.
NGuid * pValue | [out] A pointer to the converted NGuide.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NGuidTryParseVN Function

NGuidTryParseVN Function
NTypes.h

Converts a NString to NGuid. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NGuidTryParseVN(HNString hValue, const NChar * szFormat, NGuid * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
const NChar * szFormat | [in] Pointer to format string.
NGuid * pValue | [out] A pointer to the converted NGuide.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NIndexPairToString Function

NIndexPairToString Function
NTypes.h

Convertes NIndexPair to NString.

C++
NResult N_API NIndexPairToString(const NIndexPair * pValue, const NChar * szFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
const NIndexPair * pValue | [in] A pointer to NIndexPair to be converted.
const NChar * szFormat | [in] Pointer to numeric format string.
HNString * phValue | [out] A pointer to the converted NString.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NInt16ParseN Function

NInt16ParseN Function
NTypes.h

Convertes NString to NInt16.

C++
NResult N_API NInt16ParseN(HNString hValue, HNString hFormat, NInt16 * pValue);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
HNString hFormat | [in] Handle to numeric format string.
NInt16 * pValue | [out] A pointer to the converted NInt16.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NInt16ParseStrOrChars Function

NInt16ParseStrOrChars Function
NTypes.h

Converts an array of NChars to NInt16.

C++
NResult N_API NInt16ParseStrOrChars(const NChar * arValue, NInt valueLength, const NChar * szFormat, NInt16 * pValue);
Collapse Expand Parameters
Parameters | Description
const NChar * arValue | [in] A pointer to NChar array.
NInt valueLength | [in] Length of the array.
const NChar * szFormat | [in] Pointer to numeric format string.
NInt16 * pValue | [out] A pointer to the converted NInt16.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NInt16ParseVN Function

NInt16ParseVN Function
NTypes.h

Convertes NString to NInt16.

C++
NResult N_API NInt16ParseVN(HNString hValue, const NChar * szFormat, NInt16 * pValue);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
const NChar * szFormat | [in] Pointer to numeric format string.
NInt16 * pValue | [out] A pointer to the converted NInt16.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NInt16ToChars Function

NInt16ToChars Function
NTypes.h

Converts NInt16 to an array of NChars.

C++
NResult N_API NInt16ToChars(NInt16 value, const NChar * szFormat, NChar * arValue, NInt valueLength);
Collapse Expand Parameters
Parameters | Description
NInt16 value | [in] NInt16 to be converted.
const NChar * szFormat | [in] Pointer to numeric format string.
NChar * arValue | [out] A pointer to the converted NChar array.
NInt valueLength | [in] Length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NInt16ToString Function

NInt16ToString Function
NTypes.h

Converts NInt16 to NString.

C++
NResult N_API NInt16ToString(NInt16 value, const NChar * szFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
NInt16 value | [in] NInt16 to be converted.
const NChar * szFormat | [in] Pointer to numeric format string.
HNString * phValue | [out] A pointer to the converted NString.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NInt16TryParseN Function

NInt16TryParseN Function
NTypes.h

Converts NString to NInt16. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NInt16TryParseN(HNString hValue, HNString hFormat, NInt16 * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
HNString hFormat | [in] Handle to numeric format string.
NInt16 * pValue | [out] A pointer to the converted NInt16.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NInt16TryParseStrOrChars Function

NInt16TryParseStrOrChars Function
NTypes.h

Converts an array of NChars to NInt16. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NInt16TryParseStrOrChars(const NChar * arValue, NInt valueLength, const NChar * szFormat, NInt16 * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
const NChar * arValue | [in] A pointer to NChar array.
NInt valueLength | [in] Length of the array.
const NChar * szFormat | [in] Pointer to numeric format string.
NInt16 * pValue | [out] A pointer to the converted NInt16.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NInt16TryParseVN Function

NInt16TryParseVN Function
NTypes.h

Converts NString to NInt16. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NInt16TryParseVN(HNString hValue, const NChar * szFormat, NInt16 * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
const NChar * szFormat | [in] Pointer to numeric format string.
NInt16 * pValue | [out] A pointer to the converted NInt16.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NInt32ParseN Function

NInt32ParseN Function
NTypes.h

Converts NString to NInt32.

C++
NResult N_API NInt32ParseN(HNString hValue, HNString hFormat, NInt32 * pValue);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
HNString hFormat | [in] Handle to numeric format string.
NInt32 * pValue | [out] A pointer to the converted NInt32.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NInt32ParseStrOrChars Function

NInt32ParseStrOrChars Function
NTypes.h

Converts an array of NChars to NInt32.

C++
NResult N_API NInt32ParseStrOrChars(const NChar * arValue, NInt valueLength, const NChar * szFormat, NInt32 * pValue);
Collapse Expand Parameters
Parameters | Description
const NChar * arValue | [in] A pointer to NChar array.
NInt valueLength | [in] Length of the array.
const NChar * szFormat | [in] Pointer to numeric format string.
NInt32 * pValue | [out] A pointer to the converted NInt32.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NInt32ParseVN Function

NInt32ParseVN Function
NTypes.h

Converts NString to NInt32.

C++
NResult N_API NInt32ParseVN(HNString hValue, const NChar * szFormat, NInt32 * pValue);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
const NChar * szFormat | [in] Pointer to numeric format string.
NInt32 * pValue | [out] A pointer to the converted NInt32.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NInt32ToChars Function

NInt32ToChars Function
NTypes.h

Converts NInt32 to an array of NChars.

C++
NResult N_API NInt32ToChars(NInt32 value, const NChar * szFormat, NChar * arValue, NInt valueLength);
Collapse Expand Parameters
Parameters | Description
NInt32 value | [in] NInt32 to be converted.
const NChar * szFormat | [in] Pointer to numeric format string.
NChar * arValue | [out] A pointer to the converted NChar array.
NInt valueLength | [in] Length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NInt32ToString Function

NInt32ToString Function
NTypes.h

Converts NInt32 to NString.

C++
NResult N_API NInt32ToString(NInt32 value, const NChar * szFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
NInt32 value | [in] NInt32 to be converted.
const NChar * szFormat | [in] Pointer to numeric format string.
HNString * phValue | [out] A pointer to the converted NString.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NInt32TryParseN Function

NInt32TryParseN Function
NTypes.h

Converts NString to NInt32. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NInt32TryParseN(HNString hValue, HNString hFormat, NInt32 * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
HNString hFormat | [in] Handle to numeric format string.
NInt32 * pValue | [out] A pointer to the converted NInt32.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NInt32TryParseStrOrChars Function

NInt32TryParseStrOrChars Function
NTypes.h

Converts an array of NChars to NInt32. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NInt32TryParseStrOrChars(const NChar * arValue, NInt valueLength, const NChar * szFormat, NInt32 * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
const NChar * arValue | [in] A pointer to NChar array.
NInt valueLength | [in] Length of the array.
const NChar * szFormat | [in] Pointer to numeric format string.
NInt32 * pValue | [out] A pointer to the converted NInt32.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NInt32TryParseVN Function

NInt32TryParseVN Function
NTypes.h

Converts NString to NInt32. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NInt32TryParseVN(HNString hValue, const NChar * szFormat, NInt32 * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
const NChar * szFormat | [in] Pointer to numeric format string.
NInt32 * pValue | [out] A pointer to the converted NInt32.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NInt64ParseN Function

NInt64ParseN Function
NTypes.h

Converts NString to NInt64.

C++
NResult N_API NInt64ParseN(HNString hValue, HNString hFormat, NInt64 * pValue);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
HNString hFormat | [in] Handle to numeric format string.
NInt64 * pValue | [out] A pointer to the converted NInt64.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NInt64ParseStrOrChars Function

NInt64ParseStrOrChars Function
NTypes.h

Converts an array of NChars to NInt64.

C++
NResult N_API NInt64ParseStrOrChars(const NChar * arValue, NInt valueLength, const NChar * szFormat, NInt64 * pValue);
Collapse Expand Parameters
Parameters | Description
const NChar * arValue | [in] A pointer to NChar array.
NInt valueLength | [in] Length of the array.
const NChar * szFormat | [in] Pointer to numeric format string.
NInt64 * pValue | [out] A pointer to the converted NInt64.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NInt64ParseVN Function

NInt64ParseVN Function
NTypes.h

Converts NString to NInt64.

C++
NResult N_API NInt64ParseVN(HNString hValue, const NChar * szFormat, NInt64 * pValue);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
const NChar * szFormat | [in] Pointer to numeric format string.
NInt64 * pValue | [out] A pointer to the converted NInt64.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NInt64ToChars Function

NInt64ToChars Function
NTypes.h

Converts NInt64 to an array of NChars.

C++
NResult N_API NInt64ToChars(NInt64 value, const NChar * szFormat, NChar * arValue, NInt valueLength);
Collapse Expand Parameters
Parameters | Description
NInt64 value | [in] NInt64 to be converted.
const NChar * szFormat | [in] Pointer to numeric format string.
NChar * arValue | [out] A pointer to the converted NChar array.
NInt valueLength | [in] Length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NInt64ToString Function

NInt64ToString Function
NTypes.h

Converts NInt64 to NString.

C++
NResult N_API NInt64ToString(NInt64 value, const NChar * szFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
NInt64 value | [in] NInt64 to be converted.
const NChar * szFormat | [in] Pointer to numeric format string.
HNString * phValue | [out] A pointer to the converted NString.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NInt64TryParseN Function

NInt64TryParseN Function
NTypes.h

Converts NString to NInt64. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NInt64TryParseN(HNString hValue, HNString hFormat, NInt64 * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
HNString hFormat | [in] Handle to numeric format string.
NInt64 * pValue | [out] A pointer to the converted NInt64.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NInt64TryParseStrOrChars Function

NInt64TryParseStrOrChars Function
NTypes.h

Converts an array of NChars to NInt64. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NInt64TryParseStrOrChars(const NChar * arValue, NInt valueLength, const NChar * szFormat, NInt64 * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
const NChar * arValue | [in] A pointer to NChar array.
NInt valueLength | [in] Length of the array.
const NChar * szFormat | [in] Pointer to numeric format string.
NInt64 * pValue | [out] A pointer to the converted NInt64.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NInt64TryParseVN Function

NInt64TryParseVN Function
NTypes.h

Converts NString to NInt64. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NInt64TryParseVN(HNString hValue, const NChar * szFormat, NInt64 * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
const NChar * szFormat | [in] Pointer to numeric format string.
NInt64 * pValue | [out] A pointer to the converted NInt64.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NInt8ParseN Function

NInt8ParseN Function
NTypes.h

Converts NString to NInt8.

C++
NResult N_API NInt8ParseN(HNString hValue, HNString hFormat, NInt8 * pValue);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
HNString hFormat | [in] Handle to numeric format string.
NInt8 * pValue | [out] A pointer to the converted NInt8.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NInt8ParseStrOrChars Function

NInt8ParseStrOrChars Function
NTypes.h

Converts an array of NChars to NInt8.

C++
NResult N_API NInt8ParseStrOrChars(const NChar * arValue, NInt valueLength, const NChar * szFormat, NInt8 * pValue);
Collapse Expand Parameters
Parameters | Description
const NChar * arValue | [in] A pointer to NChar array.
NInt valueLength | [in] Length of the array.
const NChar * szFormat | [in] Pointer to numeric format string.
NInt8 * pValue | [out] A pointer to the converted NInt8.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NInt8ParseVN Function

NInt8ParseVN Function
NTypes.h

Converts NString to NInt8.

C++
NResult N_API NInt8ParseVN(HNString hValue, const NChar * szFormat, NInt8 * pValue);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
const NChar * szFormat | [in] Pointer to numeric format string.
NInt8 * pValue | [out] A pointer to the converted NInt8.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NInt8ToChars Function

NInt8ToChars Function
NTypes.h

Converts NInt8 to an array of NChars.

C++
NResult N_API NInt8ToChars(NInt8 value, const NChar * szFormat, NChar * arValue, NInt valueLength);
Collapse Expand Parameters
Parameters | Description
NInt8 value | [in] NInt8 to be converted.
const NChar * szFormat | [in] Pointer to numeric format string.
NChar * arValue | [out] A pointer to the converted NChar array.
NInt valueLength | [in] Length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NInt8ToString Function

NInt8ToString Function
NTypes.h

Converts NInt8 to NString.

C++
NResult N_API NInt8ToString(NInt8 value, const NChar * szFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
NInt8 value | [in] NInt8 to be converted.
const NChar * szFormat | [in] Pointer to numeric format string.
HNString * phValue | [out] A pointer to the converted NString.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NInt8TryParseN Function

NInt8TryParseN Function
NTypes.h

Converts NString to NInt8. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NInt8TryParseN(HNString hValue, HNString hFormat, NInt8 * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
HNString hFormat | [in] Handle to numeric format string.
NInt8 * pValue | [out] A pointer to the converted NInt8.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NInt8TryParseStrOrChars Function

NInt8TryParseStrOrChars Function
NTypes.h

Converts an array of NChars to NInt8. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NInt8TryParseStrOrChars(const NChar * arValue, NInt valueLength, const NChar * szFormat, NInt8 * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
const NChar * arValue | [in] A pointer to NChar array.
NInt valueLength | [in] Length of the array.
const NChar * szFormat | [in] Pointer to numeric format string.
NInt8 * pValue | [out] A pointer to the converted NInt8.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NInt8TryParseVN Function

NInt8TryParseVN Function
NTypes.h

Converts NString to NInt8. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NInt8TryParseVN(HNString hValue, const NChar * szFormat, NInt8 * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
const NChar * szFormat | [in] Pointer to numeric format string.
NInt8 * pValue | [out] A pointer to the converted NInt8.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NNameStringPairCopy Function

NNameStringPairCopy Function
NTypes.h

Creates a copy of string pair structure.

C++
NResult N_API NNameStringPairCopy(const struct NNameStringPair_ * pSrcValue, struct NNameStringPair_ * pDstValue);
Collapse Expand Parameters
Parameters | Description
const struct NNameStringPair_ * pSrcValue | [in] Pointer to the original string pair structure.
struct NNameStringPair_ * pDstValue | [out] Pointer to the copied string pair structure.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NNameStringPairCreate Function

NNameStringPairCreate Function
NTypes.h

Creates a new string pair structure.

C++
NResult N_API NNameStringPairCreate(const NChar * szKey, const NChar * szValue, NNameStringPair * pValue);
Collapse Expand Parameters
Parameters | Description
const NChar * szKey | [in] Pointer to the key string for the pair.
const NChar * szValue | [in] Pointer to the value string for the pair.
NNameStringPair * pValue | [out] Pointer to the new string pair structure.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NNameStringPairDispose Function

NNameStringPairDispose Function
NTypes.h

Disposes of the specified string pair structure.

C++
NResult N_API NNameStringPairDispose(struct NNameStringPair_ * pValue);
Collapse Expand Parameters
Parameters | Description
struct NNameStringPair_ * pValue | [in/out] Pointer to the string pair structure to be disposed of.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NNameStringPairSet Function

NNameStringPairSet Function
NTypes.h

Sets the value of the specified string pair structure.

C++
NResult N_API NNameStringPairSet(const struct NNameStringPair_ * pSrcValue, struct NNameStringPair_ * pDstValue);
Collapse Expand Parameters
Parameters | Description
const struct NNameStringPair_ * pSrcValue | [in] Pointer to string pair structure containing new value.
struct NNameStringPair_ * pDstValue | [in/out] Pointer to the string pair structure to be changed.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NOSFamilyGetCurrent Function

NOSFamilyGetCurrent Function
NTypes.h

Retrieves the current operating system family.

C++
NOSFamily N_API NOSFamilyGetCurrent();
Collapse Expand Returns

OS family value.

Container

File: NTypes.h

Module: NTypes Unit


NPointerParseN Function

NPointerParseN Function
NTypes.h

Converts NString to NPointer.

C++
NResult N_API NPointerParseN(HNString hValue, HNString hFormat, void * * pValue);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
HNString hFormat | [in] Handle to format string.
void * * pValue | [out] A pointer to the converted NPointer.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NPointerParseStrOrChars Function

NPointerParseStrOrChars Function
NTypes.h

Converts an array of NChars to NPointer.

C++
NResult N_API NPointerParseStrOrChars(const NChar * arValue, NInt valueLength, const NChar * szFormat, void * * pValue);
Collapse Expand Parameters
Parameters | Description
const NChar * arValue | [in] A pointer to NChar array.
NInt valueLength | [in] Length of the array.
const NChar * szFormat | [in] Pointer to format string.
void * * pValue | [out] A pointer to the converted NPointer.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NPointerParseVN Function

NPointerParseVN Function
NTypes.h

Converts NString to NPointer.

C++
NResult N_API NPointerParseVN(HNString hValue, const NChar * szFormat, void * * pValue);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
const NChar * szFormat | [in] Pointer to format string.
void * * pValue | [out] A pointer to the converted NPointer.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NPointerToChars Function

NPointerToChars Function
NTypes.h

Converts NPointer to an array of NChars.

C++
NResult N_API NPointerToChars(const void * value, const NChar * szFormat, NChar * arValue, NInt valueLength);
Collapse Expand Parameters
Parameters | Description
const void * value | [in] NPointer to be converted.
const NChar * szFormat | [in] Pointer to format string.
NChar * arValue | [out] A pointer to the converted NChar array.
NInt valueLength | [in] Length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NPointerToString Function

NPointerToString Function
NTypes.h

Converts NPointer to NString.

C++
NResult N_API NPointerToString(const void * value, const NChar * szFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
const void * value | [in] NPointer to be converted.
const NChar * szFormat | [in] Pointer to format string.
HNString * phValue | [out] A pointer to the converted NString.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NPointerTryParseN Function

NPointerTryParseN Function
NTypes.h

Converts NString to NPointer. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NPointerTryParseN(HNString hValue, HNString hFormat, void * * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
HNString hFormat | [in] Handle to format string.
void * * pValue | [out] A pointer to the converted NPointer.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NPointerTryParseStrOrChars Function

NPointerTryParseStrOrChars Function
NTypes.h

Converts an array of NChars to NPointer. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NPointerTryParseStrOrChars(const NChar * arValue, NInt valueLength, const NChar * szFormat, void * * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
const NChar * arValue | [in] A pointer to NChar array.
NInt valueLength | [in] Length of the array.
const NChar * szFormat | [in] Pointer to format string.
void * * pValue | [out] A pointer to the converted NPointer.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NPointerTryParseVN Function

NPointerTryParseVN Function
NTypes.h

Converts NString to NPointer. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NPointerTryParseVN(HNString hValue, const NChar * szFormat, void * * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
const NChar * szFormat | [in] Pointer to format string.
void * * pValue | [out] A pointer to the converted NPointer.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NRangeToString Function

NRangeToString Function
NTypes.h

Converts NRange to NString.

C++
NResult N_API NRangeToString(const NRange * pValue, const NChar * szFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
const NRange * pValue | [in] A pointer to NRange to be converted.
const NChar * szFormat | [in] Pointer to numeric format string.
HNString * phValue | [out] A pointer to the converted NString.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NRationalToString Function

NRationalToString Function
NTypes.h

Converts NRational to NString.

C++
NResult N_API NRationalToString(const NRational * pValue, const NChar * szFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
const NRational * pValue | [in] A pointer to NRational to be converted.
const NChar * szFormat | [in] Pointer to numeric format string.
HNString * phValue | [out] A pointer to the converted NString.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NResultParseN Function

NResultParseN Function
NTypes.h

Converts NString to NResult.

C++
NResult N_API NResultParseN(HNString hValue, HNString hFormat, NResult * pValue);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
HNString hFormat | [in] Handle to format string.
NResult * pValue | [out] A pointer to the converted NResult.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NResultParseStrOrChars Function

NResultParseStrOrChars Function
NTypes.h

Converts an array of NChars to NResult.

C++
NResult N_API NResultParseStrOrChars(const NChar * arValue, NInt valueLength, const NChar * szFormat, NResult * pValue);
Collapse Expand Parameters
Parameters | Description
const NChar * arValue | [in] A pointer to NChar array.
NInt valueLength | [in] Length of the array.
const NChar * szFormat | [in] Pointer to format string.
NResult * pValue | [out] A pointer to the converted NResult.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NResultParseVN Function

NResultParseVN Function
NTypes.h

Converts NString to NResult.

C++
NResult N_API NResultParseVN(HNString hValue, const NChar * szFormat, NResult * pValue);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
const NChar * szFormat | [in] Pointer to format string.
NResult * pValue | [out] A pointer to the converted NResult.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NResultToChars Function

NResultToChars Function
NTypes.h

Converts NResult to an array of NChars.

C++
NResult N_API NResultToChars(NResult value, const NChar * szFormat, NChar * arValue, NInt valueLength);
Collapse Expand Parameters
Parameters | Description
NResult value | [in] NResult to be converted.
const NChar * szFormat | [in] Pointer to format string.
NChar * arValue | [out] A pointer to the converted NChar array.
NInt valueLength | [in] Length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NResultToString Function

NResultToString Function
NTypes.h

Converts NResult to NString.

C++
NResult N_API NResultToString(NResult value, const NChar * szFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
NResult value | [in] NResult to be converted.
const NChar * szFormat | [in] Pointer to format string.
HNString * phValue | [out] A pointer to the converted NString.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NResultTryParseN Function

NResultTryParseN Function
NTypes.h

Converts NString to NResult. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NResultTryParseN(HNString hValue, HNString hFormat, NResult * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
HNString hFormat | [in] Handle to format string.
NResult * pValue | [out] A pointer to the converted NResult.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NResultTryParseStrOrChars Function

NResultTryParseStrOrChars Function
NTypes.h

Converts an array of NChars to NResult. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NResultTryParseStrOrChars(const NChar * arValue, NInt valueLength, const NChar * szFormat, NResult * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
const NChar * arValue | [in] A pointer to NChar array.
NInt valueLength | [in] Length of the array.
const NChar * szFormat | [in] Pointer to format string.
NResult * pValue | [out] A pointer to the converted NResult.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NResultTryParseVN Function

NResultTryParseVN Function
NTypes.h

Converts NString to NResult. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NResultTryParseVN(HNString hValue, const NChar * szFormat, NResult * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
const NChar * szFormat | [in] Pointer to format string.
NResult * pValue | [out] A pointer to the converted NResult.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NSSizeTypeParseN Function

NSSizeTypeParseN Function
NTypes.h

Converts NString to NSSizeType.

C++
NResult N_API NSSizeTypeParseN(HNString hValue, HNString hFormat, NSSizeType * pValue);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
HNString hFormat | [in] Handle to format string.
NSSizeType * pValue | [out] A pointer to the converted NSSizeType.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NSSizeTypeParseStrOrChars Function

NSSizeTypeParseStrOrChars Function
NTypes.h

Converts an array of NChars to NSSizeType.

C++
NResult N_API NSSizeTypeParseStrOrChars(const NChar * arValue, NInt valueLength, const NChar * szFormat, NSSizeType * pValue);
Collapse Expand Parameters
Parameters | Description
const NChar * arValue | [in] A pointer to NChar array.
NInt valueLength | [in] Length of the array.
const NChar * szFormat | [in] Pointer to format string.
NSSizeType * pValue | [out] A pointer to the converted NSSizeType.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NSSizeTypeParseVN Function

NSSizeTypeParseVN Function
NTypes.h

Converts NString to NSSizeType.

C++
NResult N_API NSSizeTypeParseVN(HNString hValue, const NChar * szFormat, NSSizeType * pValue);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
const NChar * szFormat | [in] Pointer to format string.
NSSizeType * pValue | [out] A pointer to the converted NSSizeType.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NSSizeTypeToChars Function

NSSizeTypeToChars Function
NTypes.h

Converts NSSizeType to an array of NChars.

C++
NResult N_API NSSizeTypeToChars(NSSizeType value, const NChar * szFormat, NChar * arValue, NInt valueLength);
Collapse Expand Parameters
Parameters | Description
NSSizeType value | [in] NSSizeType to be converted.
const NChar * szFormat | [in] Pointer to format string.
NChar * arValue | [out] A pointer to the converted NChar array.
NInt valueLength | [in] Length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NSSizeTypeToString Function

NSSizeTypeToString Function
NTypes.h

Converts NSSizeType to NString.

C++
NResult N_API NSSizeTypeToString(NSSizeType value, const NChar * szFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
NSSizeType value | [in] NSSizeType to be converted.
const NChar * szFormat | [in] Pointer to format string.
HNString * phValue | [out] A pointer to the converted NString.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NSSizeTypeTryParseN Function

NSSizeTypeTryParseN Function
NTypes.h

Converts NString to NSSizeType. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NSSizeTypeTryParseN(HNString hValue, HNString hFormat, NSSizeType * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
HNString hFormat | [in] Handle to format string.
NSSizeType * pValue | [out] A pointer to the converted NSSizeType.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NSSizeTypeTryParseStrOrChars Function

NSSizeTypeTryParseStrOrChars Function
NTypes.h

Converts an array of NChars to NSSizeType. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NSSizeTypeTryParseStrOrChars(const NChar * arValue, NInt valueLength, const NChar * szFormat, NSSizeType * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
const NChar * arValue | [in] A pointer to NChar array.
NInt valueLength | [in] Length of the array.
const NChar * szFormat | [in] Pointer to format string.
NSSizeType * pValue | [out] A pointer to the converted NSSizeType.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NSSizeTypeTryParseVN Function

NSSizeTypeTryParseVN Function
NTypes.h

Converts NString to NSSizeType. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NSSizeTypeTryParseVN(HNString hValue, const NChar * szFormat, NSSizeType * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
const NChar * szFormat | [in] Pointer to format string.
NSSizeType * pValue | [out] A pointer to the converted NSSizeType.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NSingleGetNaN Function

NSingleGetNaN Function
NTypes.h

Retrieves a NSingle that is Not a Number (NaN).

C++
NSingle N_API NSingleGetNaN();
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NSingleGetNegativeInfinity Function

NSingleGetNegativeInfinity Function
NTypes.h

Retrieves a NSingle that is NegativeInfinity.

C++
NSingle N_API NSingleGetNegativeInfinity();
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NSingleGetPositiveInfinity Function

NSingleGetPositiveInfinity Function
NTypes.h

Retrieves a NSingle that is PositiveInfinity.

C++
NSingle N_API NSingleGetPositiveInfinity();
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NSingleIsInfinity Function

NSingleIsInfinity Function
NTypes.h

Checks if NSingle evaluates to NegativeInfinity or PositiveInfinity.

C++
NBool N_API NSingleIsInfinity(NSingle value);
Collapse Expand Parameters
Parameters | Description
NSingle value | [in] NDouble to be checked.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NSingleIsNaN Function

NSingleIsNaN Function
NTypes.h

Checks if NSingle Not a Number (NaN).

C++
NBool N_API NSingleIsNaN(NSingle value);
Collapse Expand Parameters
Parameters | Description
NSingle value | [in] NDouble to be checked.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NSingleIsNegativeInfinity Function

NSingleIsNegativeInfinity Function
NTypes.h

Checks if NSingle evaluates to NegativeInfinity.

C++
NBool N_API NSingleIsNegativeInfinity(NSingle value);
Collapse Expand Parameters
Parameters | Description
NSingle value | [in] NDouble to be checked.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NSingleIsPositiveInfinity Function

NSingleIsPositiveInfinity Function
NTypes.h

Checks if NSingle evaluates to PositiveInfinity.

C++
NBool N_API NSingleIsPositiveInfinity(NSingle value);
Collapse Expand Parameters
Parameters | Description
NSingle value | [in] NDouble to be checked.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NSingleParseN Function

NSingleParseN Function
NTypes.h

Converts NString to NSingle.

C++
NResult N_API NSingleParseN(HNString hValue, HNString hFormat, NSingle * pValue);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
HNString hFormat | [in] Handle to numeric format string.
NSingle * pValue | [out] A pointer to the converted NSingle.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NSingleParseStrOrChars Function

NSingleParseStrOrChars Function
NTypes.h

Converts an array of NChars to NSingle.

C++
NResult N_API NSingleParseStrOrChars(const NChar * arValue, NInt valueLength, const NChar * szFormat, NSingle * pValue);
Collapse Expand Parameters
Parameters | Description
const NChar * arValue | [in] A pointer to NChar array.
NInt valueLength | [in] Length of the array.
const NChar * szFormat | [in] Pointer to numeric format string.
NSingle * pValue | [out] A pointer to the converted NSingle.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NSingleParseVN Function

NSingleParseVN Function
NTypes.h

Converts NString to NSingle.

C++
NResult N_API NSingleParseVN(HNString hValue, const NChar * szFormat, NSingle * pValue);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
const NChar * szFormat | [in] Pointer to numeric format string.
NSingle * pValue | [out] A pointer to the converted NSingle.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NSingleToChars Function

NSingleToChars Function
NTypes.h

Converts NSingle to an array of NChars.

C++
NResult N_API NSingleToChars(NSingle value, const NChar * szFormat, NChar * arValue, NInt valueLength);
Collapse Expand Parameters
Parameters | Description
NSingle value | [in] NSingle to be converted.
const NChar * szFormat | [in] Pointer to numeric format string.
NChar * arValue | [out] A pointer to the converted NChar array.
NInt valueLength | [in] Length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NSingleToString Function

NSingleToString Function
NTypes.h

Converts NSingle to NString.

C++
NResult N_API NSingleToString(NSingle value, const NChar * szFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
NSingle value | [in] NSingle to be converted.
const NChar * szFormat | [in] Pointer to numeric format string.
HNString * phValue | [out] A pointer to the converted NString.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NSingleTryParseN Function

NSingleTryParseN Function
NTypes.h

Converts NString to NSingle. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NSingleTryParseN(HNString hValue, HNString hFormat, NSingle * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
HNString hFormat | [in] Handle to numeric format string.
NSingle * pValue | [out] A pointer to the converted NSingle.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NSingleTryParseStrOrChars Function

NSingleTryParseStrOrChars Function
NTypes.h

Converts an array of NChars to NSingle. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NSingleTryParseStrOrChars(const NChar * arValue, NInt valueLength, const NChar * szFormat, NSingle * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
const NChar * arValue | [in] A pointer to NChar array.
NInt valueLength | [in] Length of the array.
const NChar * szFormat | [in] Pointer to numeric format string.
NSingle * pValue | [out] A pointer to the converted NSingle.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NSingleTryParseVN Function

NSingleTryParseVN Function
NTypes.h

Converts NString to NSingle. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NSingleTryParseVN(HNString hValue, const NChar * szFormat, NSingle * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
const NChar * szFormat | [in] Pointer to numeric format string.
NSingle * pValue | [out] A pointer to the converted NSingle.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NSizeTypeParseN Function

NSizeTypeParseN Function
NTypes.h

Converts NString to NSizeType.

C++
NResult N_API NSizeTypeParseN(HNString hValue, HNString hFormat, NSizeType * pValue);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
HNString hFormat | [in] Handle to format string.
NSizeType * pValue | [out] A pointer to the converted NSizeType.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NSizeTypeParseStrOrChars Function

NSizeTypeParseStrOrChars Function
NTypes.h

Converts an array of NChars to NSizeType.

C++
NResult N_API NSizeTypeParseStrOrChars(const NChar * arValue, NInt valueLength, const NChar * szFormat, NSizeType * pValue);
Collapse Expand Parameters
Parameters | Description
const NChar * arValue | [in] A pointer to NChar array.
NInt valueLength | [in] Length of the array.
const NChar * szFormat | [in] Pointer to format string.
NSizeType * pValue | [out] A pointer to the converted NSizeType.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NSizeTypeParseVN Function

NSizeTypeParseVN Function
NTypes.h

Converts NString to NSizeType.

C++
NResult N_API NSizeTypeParseVN(HNString hValue, const NChar * szFormat, NSizeType * pValue);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
const NChar * szFormat | [in] Pointer to format string.
NSizeType * pValue | [out] A pointer to the converted NSizeType.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NSizeTypeToChars Function

NSizeTypeToChars Function
NTypes.h

Converts NSizeType to an array of NChars.

C++
NResult N_API NSizeTypeToChars(NSizeType value, const NChar * szFormat, NChar * arValue, NInt valueLength);
Collapse Expand Parameters
Parameters | Description
NSizeType value | [in] NSizeType to be converted.
const NChar * szFormat | [in] Pointer to format string.
NChar * arValue | [out] A pointer to the converted NChar array.
NInt valueLength | [in] Length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NSizeTypeToString Function

NSizeTypeToString Function
NTypes.h

Converts NSizeType to NString.

C++
NResult N_API NSizeTypeToString(NSizeType value, const NChar * szFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
NSizeType value | [in] NSizeType to be converted.
const NChar * szFormat | [in] Pointer to format string.
HNString * phValue | [out] A pointer to the converted NString.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NSizeTypeTryParseN Function

NSizeTypeTryParseN Function
NTypes.h

Converts NString to NSizeType. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NSizeTypeTryParseN(HNString hValue, HNString hFormat, NSizeType * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
HNString hFormat | [in] Handle to format string.
NSizeType * pValue | [out] A pointer to the converted NSizeType.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NSizeTypeTryParseStrOrChars Function

NSizeTypeTryParseStrOrChars Function
NTypes.h

Converts an array of NChars to NSizeType. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NSizeTypeTryParseStrOrChars(const NChar * arValue, NInt valueLength, const NChar * szFormat, NSizeType * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
const NChar * arValue | [in] A pointer to NChar array.
NInt valueLength | [in] Length of the array.
const NChar * szFormat | [in] Pointer to format string.
NSizeType * pValue | [out] A pointer to the converted NSizeType.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NSizeTypeTryParseVN Function

NSizeTypeTryParseVN Function
NTypes.h

Converts NString to NSizeType. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NSizeTypeTryParseVN(HNString hValue, const NChar * szFormat, NSizeType * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
const NChar * szFormat | [in] Pointer to format string.
NSizeType * pValue | [out] A pointer to the converted NSizeType.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NSwapDWordArray Function

NSwapDWordArray Function
NTypes.h

Swaps the element order of the specified array of unsigned integers from little Endian to big Endian, or vice-versa.

C++
NResult N_API NSwapDWordArray(NUInt * pDstArray, const NUInt * pSrcArray, NInt length);
Collapse Expand Parameters
Parameters | Description
NUInt * pDstArray | [in/out] Pointer to the result array.
const NUInt * pSrcArray | [in] Pointer to the original array.
NInt length | [in] Length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NSwapDouble Function

NSwapDouble Function
NTypes.h

Swaps the byte order of the specified double value from little Endian to big Endian, or vice-versa.

C++
NDouble N_API NSwapDouble(NDouble value);
Collapse Expand Parameters
Parameters | Description
NDouble value | [in] The original double value.
Collapse Expand Returns

The double value with swapped byte order.

Container

File: NTypes.h

Module: NTypes Unit


NSwapDoubleArray Function

NSwapDoubleArray Function
NTypes.h

Swaps the element order of the specified array of single values from little Endian to big Endian, or vice-versa.

C++
NResult N_API NSwapDoubleArray(NDouble * pDstArray, const NDouble * pSrcArray, NInt length);
Collapse Expand Parameters
Parameters | Description
NDouble * pDstArray | [in/out] Pointer to the result array.
const NDouble * pSrcArray | [in] Pointer to the original array.
NInt length | [in] Length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NSwapQWordArray Function

NSwapQWordArray Function
NTypes.h

Swaps the element order of the specified array of unsigned long integers from little Endian to big Endian, or vice-versa.

C++
NResult N_API NSwapQWordArray(NULong * pDstArray, const NULong * pSrcArray, NInt length);
Collapse Expand Parameters
Parameters | Description
NULong * pDstArray | [in/out] Pointer to the result array.
const NULong * pSrcArray | [in] Pointer to the original array.
NInt length | [in] Length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NSwapSingle Function

NSwapSingle Function
NTypes.h

Swaps the byte order of the specified single value from little Endian to big Endian, or vice-versa.

C++
NSingle N_API NSwapSingle(NSingle value);
Collapse Expand Parameters
Parameters | Description
NSingle value | [in] The original single value.
Collapse Expand Returns

The signle value with swapped byte order.

Container

File: NTypes.h

Module: NTypes Unit


NSwapSingleArray Function

NSwapSingleArray Function
NTypes.h

Swaps the element order of the specified array of single values from little Endian to big Endian, or vice-versa.

C++
NResult N_API NSwapSingleArray(NFloat * pDstArray, const NFloat * pSrcArray, NInt length);
Collapse Expand Parameters
Parameters | Description
NFloat * pDstArray | [in/out] Pointer to the result array.
const NFloat * pSrcArray | [in] Pointer to the original array.
NInt length | [in] Length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NSwapWordArray Function

NSwapWordArray Function
NTypes.h

Swaps the element order of the specified array of unsigned short integers from little Endian to big Endian, or vice-versa.

C++
NResult N_API NSwapWordArray(NUShort * pDstArray, const NUShort * pSrcArray, NInt length);
Collapse Expand Parameters
Parameters | Description
NUShort * pDstArray | [in/out] Pointer to the result array.
const NUShort * pSrcArray | [in] Pointer to the original array.
NInt length | [in] Length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NTypesGetPointer Function

NTypesGetPointer Function
NTypes.h

Retrieves a pointer to object.

C++
void * N_API_PTR_RET NTypesGetPointer(void * value);
Collapse Expand Parameters
Parameters | Description
void * value | [out] A pointer to object.
Container

File: NTypes.h

Module: NTypes Unit


NUInt16ParseN Function

NUInt16ParseN Function
NTypes.h

Converts NString to NUInt16.

C++
NResult N_API NUInt16ParseN(HNString hValue, HNString hFormat, NUInt16 * pValue);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
HNString hFormat | [in] Handle to numeric format string.
NUInt16 * pValue | [out] A pointer to the converted NUInt16.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NUInt16ParseStrOrChars Function

NUInt16ParseStrOrChars Function
NTypes.h

Converts an array of NChars to NUInt16.

C++
NResult N_API NUInt16ParseStrOrChars(const NChar * arValue, NInt valueLength, const NChar * szFormat, NUInt16 * pValue);
Collapse Expand Parameters
Parameters | Description
const NChar * arValue | [in] A pointer to NChar array.
NInt valueLength | [in] Length of the array.
const NChar * szFormat | [in] Pointer to numeric format string.
NUInt16 * pValue | [out] A pointer to the converted NUInt16.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NUInt16ParseVN Function

NUInt16ParseVN Function
NTypes.h

Converts NString to NUInt16.

C++
NResult N_API NUInt16ParseVN(HNString hValue, const NChar * szFormat, NUInt16 * pValue);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
const NChar * szFormat | [in] Pointer to numeric format string.
NUInt16 * pValue | [out] A pointer to the converted NUInt16.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NUInt16ToChars Function

NUInt16ToChars Function
NTypes.h

Converts NUInt16 to an array of NChars.

C++
NResult N_API NUInt16ToChars(NUInt16 value, const NChar * szFormat, NChar * arValue, NInt valueLength);
Collapse Expand Parameters
Parameters | Description
NUInt16 value | [in] NUInt16 to be converted.
const NChar * szFormat | [in] Pointer to numeric format string.
NChar * arValue | [out] A pointer to the converted NChar array.
NInt valueLength | [in] Length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NUInt16ToString Function

NUInt16ToString Function
NTypes.h

Converts NUInt16 to NString.

C++
NResult N_API NUInt16ToString(NUInt16 value, const NChar * szFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
NUInt16 value | [in] NUInt16 to be converted.
const NChar * szFormat | [in] Pointer to numeric format string.
HNString * phValue | [out] A pointer to the converted NString.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NUInt16TryParseN Function

NUInt16TryParseN Function
NTypes.h

Converts NString to NUInt16. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NUInt16TryParseN(HNString hValue, HNString hFormat, NUInt16 * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
HNString hFormat | [in] Handle to numeric format string.
NUInt16 * pValue | [out] A pointer to the converted NUInt16.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NUInt16TryParseStrOrChars Function

NUInt16TryParseStrOrChars Function
NTypes.h

Converts an array of NChars to NUInt16. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NUInt16TryParseStrOrChars(const NChar * arValue, NInt valueLength, const NChar * szFormat, NUInt16 * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
const NChar * arValue | [in] A pointer to NChar array.
NInt valueLength | [in] Length of the array.
const NChar * szFormat | [in] Pointer to numeric format string.
NUInt16 * pValue | [out] A pointer to the converted NUInt16.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NUInt16TryParseVN Function

NUInt16TryParseVN Function
NTypes.h

Converts NString to NUInt16. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NUInt16TryParseVN(HNString hValue, const NChar * szFormat, NUInt16 * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
const NChar * szFormat | [in] Pointer to numeric format string.
NUInt16 * pValue | [out] A pointer to the converted NUInt16.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NUInt32ParseN Function

NUInt32ParseN Function
NTypes.h

Converts NString to NUInt32.

C++
NResult N_API NUInt32ParseN(HNString hValue, HNString hFormat, NUInt32 * pValue);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
HNString hFormat | [in] Handle to numeric format string.
NUInt32 * pValue | [out] A pointer to the converted NUInt32.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NUInt32ParseStrOrChars Function

NUInt32ParseStrOrChars Function
NTypes.h

Converts an array of NChars to NUInt32.

C++
NResult N_API NUInt32ParseStrOrChars(const NChar * arValue, NInt valueLength, const NChar * szFormat, NUInt32 * pValue);
Collapse Expand Parameters
Parameters | Description
const NChar * arValue | [in] A pointer to NChar array.
NInt valueLength | [in] Length of the array.
const NChar * szFormat | [in] Pointer to numeric format string.
NUInt32 * pValue | [out] A pointer to the converted NUInt32.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NUInt32ParseVN Function

NUInt32ParseVN Function
NTypes.h

Converts NString to NUInt32.

C++
NResult N_API NUInt32ParseVN(HNString hValue, const NChar * szFormat, NUInt32 * pValue);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
const NChar * szFormat | [in] Pointer to numeric format string.
NUInt32 * pValue | [out] A pointer to the converted NUInt32.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NUInt32ToChars Function

NUInt32ToChars Function
NTypes.h

Converts NUInt32 to an array of NChars.

C++
NResult N_API NUInt32ToChars(NUInt32 value, const NChar * szFormat, NChar * arValue, NInt valueLength);
Collapse Expand Parameters
Parameters | Description
NUInt32 value | [in] NUInt32 to be converted.
const NChar * szFormat | [in] Pointer to numeric format string.
NChar * arValue | [out] A pointer to the converted NChar array.
NInt valueLength | [in] Length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NUInt32ToString Function

NUInt32ToString Function
NTypes.h

Converts NUInt32 to NString.

C++
NResult N_API NUInt32ToString(NUInt32 value, const NChar * szFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
NUInt32 value | [in] NUInt32 to be converted.
const NChar * szFormat | [in] Pointer to numeric format string.
HNString * phValue | [out] A pointer to the converted NString.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NUInt32TryParseN Function

NUInt32TryParseN Function
NTypes.h

Converts NString to NUInt32. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NUInt32TryParseN(HNString hValue, HNString hFormat, NUInt32 * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
HNString hFormat | [in] Handle to numeric format string.
NUInt32 * pValue | [out] A pointer to the converted NUInt32.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NUInt32TryParseStrOrChars Function

NUInt32TryParseStrOrChars Function
NTypes.h

Converts an array of NChars to NUInt32. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NUInt32TryParseStrOrChars(const NChar * arValue, NInt valueLength, const NChar * szFormat, NUInt32 * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
const NChar * arValue | [in] A pointer to NChar array.
NInt valueLength | [in] Length of the array.
const NChar * szFormat | [in] Pointer to numeric format string.
NUInt32 * pValue | [out] A pointer to the converted NUInt32.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NUInt32TryParseVN Function

NUInt32TryParseVN Function
NTypes.h

Converts NString to NUInt32. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NUInt32TryParseVN(HNString hValue, const NChar * szFormat, NUInt32 * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
const NChar * szFormat | [in] Pointer to numeric format string.
NUInt32 * pValue | [out] A pointer to the converted NUInt32.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NUInt64ParseN Function

NUInt64ParseN Function
NTypes.h

Converts NString to NUInt64.

C++
NResult N_API NUInt64ParseN(HNString hValue, HNString hFormat, NUInt64 * pValue);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
HNString hFormat | [in] Handle to numeric format string.
NUInt64 * pValue | [out] A pointer to the converted NUInt64.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NUInt64ParseStrOrChars Function

NUInt64ParseStrOrChars Function
NTypes.h

Converts an array of NChars to NUInt64.

C++
NResult N_API NUInt64ParseStrOrChars(const NChar * arValue, NInt valueLength, const NChar * szFormat, NUInt64 * pValue);
Collapse Expand Parameters
Parameters | Description
const NChar * arValue | [in] A pointer to NChar array.
NInt valueLength | [in] Length of the array.
const NChar * szFormat | [in] Pointer to numeric format string.
NUInt64 * pValue | [out] A pointer to the converted NUInt64.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NUInt64ParseVN Function

NUInt64ParseVN Function
NTypes.h

Converts NString to NUInt64.

C++
NResult N_API NUInt64ParseVN(HNString hValue, const NChar * szFormat, NUInt64 * pValue);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
const NChar * szFormat | [in] Pointer to numeric format string.
NUInt64 * pValue | [out] A pointer to the converted NUInt64.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NUInt64ToChars Function

NUInt64ToChars Function
NTypes.h

Converts NUInt64 to an array of NChars.

C++
NResult N_API NUInt64ToChars(NUInt64 value, const NChar * szFormat, NChar * arValue, NInt valueLength);
Collapse Expand Parameters
Parameters | Description
NUInt64 value | [in] NUInt64 to be converted.
const NChar * szFormat | [in] Pointer to numeric format string.
NChar * arValue | [out] A pointer to the converted NChar array.
NInt valueLength | [in] Length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NUInt64ToString Function

NUInt64ToString Function
NTypes.h

Converts NUInt64 to NString.

C++
NResult N_API NUInt64ToString(NUInt64 value, const NChar * szFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
NUInt64 value | [in] NUInt64 to be converted.
const NChar * szFormat | [in] Pointer to numeric format string.
HNString * phValue | [out] A pointer to the converted NString.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NUInt64TryParseN Function

NUInt64TryParseN Function
NTypes.h

Converts NString to NUInt64. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NUInt64TryParseN(HNString hValue, HNString hFormat, NUInt64 * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
HNString hFormat | [in] Handle to numeric format string.
NUInt64 * pValue | [out] A pointer to the converted NUInt64.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NUInt64TryParseStrOrChars Function

NUInt64TryParseStrOrChars Function
NTypes.h

Converts an array of NChars to NUInt64. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NUInt64TryParseStrOrChars(const NChar * arValue, NInt valueLength, const NChar * szFormat, NUInt64 * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
const NChar * arValue | [in] A pointer to NChar array.
NInt valueLength | [in] Length of the array.
const NChar * szFormat | [in] Pointer to numeric format string.
NUInt64 * pValue | [out] A pointer to the converted NUInt64.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NUInt64TryParseVN Function

NUInt64TryParseVN Function
NTypes.h

Converts NString to NUInt64. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NUInt64TryParseVN(HNString hValue, const NChar * szFormat, NUInt64 * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
const NChar * szFormat | [in] Pointer to numeric format string.
NUInt64 * pValue | [out] A pointer to the converted NUInt64.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NUInt8ParseN Function

NUInt8ParseN Function
NTypes.h

Converts NString to NUInt8.

C++
NResult N_API NUInt8ParseN(HNString hValue, HNString hFormat, NUInt8 * pValue);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
HNString hFormat | [in] Handle to numeric format string.
NUInt8 * pValue | [out] A pointer to the converted NUInt8.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NUInt8ParseStrOrChars Function

NUInt8ParseStrOrChars Function
NTypes.h

Converts an array of NChars to NUInt8.

C++
NResult N_API NUInt8ParseStrOrChars(const NChar * arValue, NInt valueLength, const NChar * szFormat, NUInt8 * pValue);
Collapse Expand Parameters
Parameters | Description
const NChar * arValue | [in] A pointer to NChar array.
NInt valueLength | [in] Length of the array.
const NChar * szFormat | [in] Pointer to numeric format string.
NUInt8 * pValue | [out] A pointer to the converted NUInt8.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NUInt8ParseVN Function

NUInt8ParseVN Function
NTypes.h

Converts NString to NUInt8.

C++
NResult N_API NUInt8ParseVN(HNString hValue, const NChar * szFormat, NUInt8 * pValue);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
const NChar * szFormat | [in] Pointer to numeric format string.
NUInt8 * pValue | [out] A pointer to the converted NUInt8.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NUInt8ToChars Function

NUInt8ToChars Function
NTypes.h

Converts NUInt8 to an array of NChars.

C++
NResult N_API NUInt8ToChars(NUInt8 value, const NChar * szFormat, NChar * arValue, NInt valueLength);
Collapse Expand Parameters
Parameters | Description
NUInt8 value | [in] NUInt8 to be converted.
const NChar * szFormat | [in] Pointer to numeric format string.
NChar * arValue | [out] A pointer to the converted NChar array.
NInt valueLength | [in] Length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NUInt8ToString Function

NUInt8ToString Function
NTypes.h

Converts NUInt8 to NString.

C++
NResult N_API NUInt8ToString(NUInt8 value, const NChar * szFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
NUInt8 value | [in] NUInt8 to be converted.
const NChar * szFormat | [in] Pointer to numeric format string.
HNString * phValue | [out] A pointer to the converted NString.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NUInt8TryParseN Function

NUInt8TryParseN Function
NTypes.h

Converts NString to NUInt8. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NUInt8TryParseN(HNString hValue, HNString hFormat, NUInt8 * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
HNString hFormat | [in] Handle to numeric format string.
NUInt8 * pValue | [out] A pointer to the converted NUInt8.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NUInt8TryParseStrOrChars Function

NUInt8TryParseStrOrChars Function
NTypes.h

Converts an array of NChars to NUInt8. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NUInt8TryParseStrOrChars(const NChar * arValue, NInt valueLength, const NChar * szFormat, NUInt8 * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
const NChar * arValue | [in] A pointer to NChar array.
NInt valueLength | [in] Length of the array.
const NChar * szFormat | [in] Pointer to numeric format string.
NUInt8 * pValue | [out] A pointer to the converted NUInt8.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NUInt8TryParseVN Function

NUInt8TryParseVN Function
NTypes.h

Converts NString to NUInt8. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NUInt8TryParseVN(HNString hValue, const NChar * szFormat, NUInt8 * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
const NChar * szFormat | [in] Pointer to numeric format string.
NUInt8 * pValue | [out] A pointer to the converted NUInt8.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NURationalToString Function

NURationalToString Function
NTypes.h

Converts NURational to NString.

C++
NResult N_API NURationalToString(const NURational * pValue, const NChar * szFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
const NURational * pValue | [in] A pointer to NURational to be converted.
const NChar * szFormat | [in] Pointer to numeric format string.
HNString * phValue | [out] A pointer to the converted NString.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NVersionRangeContains Function

NVersionRangeContains Function
NTypes.h

Checks if NVersionRange contains a certain version.

C++
NBool N_API NVersionRangeContains(NVersionRange_ value, NVersion_ version);
Collapse Expand Parameters
Parameters | Description
NVersionRange_ value | [in] NVersionRange to be checked.
NVersion_ version | [in] NVersion that may be contained in NVersionRange.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NVersionRangeContainsRange Function

NVersionRangeContainsRange Function
NTypes.h

Checks if NVersionRange contains a certain version range.

C++
NBool N_API NVersionRangeContainsRange(NVersionRange_ value, NVersionRange_ versionRange);
Collapse Expand Parameters
Parameters | Description
NVersionRange_ value | [in] NVersionRange to be checked.
NVersionRange_ versionRange | [in] The version range that may be contained in NVersionRange.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NVersionRangeIntersect Function

NVersionRangeIntersect Function
NTypes.h

Replaces NVersionRange with the intersection of itself and another NVersionRange.

C++
NVersionRange_ N_API NVersionRangeIntersect(NVersionRange_ value1, NVersionRange_ value2);
Collapse Expand Parameters
Parameters | Description
NVersionRange_ value1 | [in] Basic NVersionRange.
NVersionRange_ value2 | [in] Intersecting NVersionRange.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NVersionRangeIntersectsWith Function

NVersionRangeIntersectsWith Function
NTypes.h

Returns third NVersionRange that represents the intersection of two other NVersionRanges. If there is no intersection, an empty NVersionRange is returned.

C++
NBool N_API NVersionRangeIntersectsWith(NVersionRange_ value, NVersionRange_ otherValue);
Collapse Expand Parameters
Parameters | Description
NVersionRange_ value | [in] First NVersionRange to intersect.
NVersionRange_ otherValue | [in] Second NVersionRange to intersect.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NVersionRangeToString Function

NVersionRangeToString Function
NTypes.h

Converts NVersionRange to NString.

C++
NResult N_API NVersionRangeToString(NVersionRange value, const NChar * szFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
NVersionRange value | [in] NVersionRange to be converted.
const NChar * szFormat | [in] Pointer to format string.
HNString * phValue | [out] A pointer to the converted NString.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NVersionToString Function

NVersionToString Function
NTypes.h

Converts NVersion to NString.

C++
NResult N_API NVersionToString(NVersion value, const NChar * szFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
NVersion value | [in] NVersion to be converted.
const NChar * szFormat | [in] Pointer to format string.
HNString * phValue | [out] A pointer to the converted NString.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NWCharParseN Function

NWCharParseN Function
NTypes.h

Converts NString to NWChar.

C++
NResult N_API NWCharParseN(HNString hValue, HNString hFormat, NWChar * pValue);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
HNString hFormat | [in] Handle to format string.
NWChar * pValue | [out] A pointer to the converted NWChar.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NWCharParseStrOrChars Function

NWCharParseStrOrChars Function
NTypes.h

Converts an array of NChars to NWChar.

C++
NResult N_API NWCharParseStrOrChars(const NChar * arValue, NInt valueLength, const NChar * szFormat, NWChar * pValue);
Collapse Expand Parameters
Parameters | Description
const NChar * arValue | [in] A pointer to NChar array.
NInt valueLength | [in] Length of the array.
const NChar * szFormat | [in] Pointer to format string.
NWChar * pValue | [out] A pointer to the converted NWChar.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NWCharParseVN Function

NWCharParseVN Function
NTypes.h

Converts NString to NWChar.

C++
NResult N_API NWCharParseVN(HNString hValue, const NChar * szFormat, NWChar * pValue);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
const NChar * szFormat | [in] Pointer to format string.
NWChar * pValue | [out] A pointer to the converted NWChar.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NWCharToChars Function

NWCharToChars Function
NTypes.h

Converts NWChar to an array of NChars.

C++
NResult N_API NWCharToChars(NWChar value, const NChar * szFormat, NChar * arValue, NInt valueLength);
Collapse Expand Parameters
Parameters | Description
NWChar value | [in] NWChar to be converted.
const NChar * szFormat | [in] Pointer to format string.
NChar * arValue | [out] A pointer to the converted NChar array.
NInt valueLength | [in] Length of the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NWCharToString Function

NWCharToString Function
NTypes.h

Converts NWChar to NString.

C++
NResult N_API NWCharToString(NWChar value, const NChar * szFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
NWChar value | [in] NWChar to be converted.
const NChar * szFormat | [in] Pointer to format string.
HNString * phValue | [out] A pointer to the converted NString.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NWCharTryParseN Function

NWCharTryParseN Function
NTypes.h

Converts NString to NWChar. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NWCharTryParseN(HNString hValue, HNString hFormat, NWChar * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
HNString hFormat | [in] Handle to format string.
NWChar * pValue | [out] A pointer to the converted NWChar.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NWCharTryParseStrOrChars Function

NWCharTryParseStrOrChars Function
NTypes.h

Converts an array of NChars to NWChar. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NWCharTryParseStrOrChars(const NChar * arValue, NInt valueLength, const NChar * szFormat, NWChar * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
const NChar * arValue | [in] A pointer to NChar array.
NInt valueLength | [in] Length of the array.
const NChar * szFormat | [in] Pointer to format string.
NWChar * pValue | [out] A pointer to the converted NWChar.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NWCharTryParseVN Function

NWCharTryParseVN Function
NTypes.h

Converts NString to NWChar. A NBool value indicates whether the conversion succeeded.

C++
NResult N_API NWCharTryParseVN(HNString hValue, const NChar * szFormat, NWChar * pValue, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] A handle to NString to be converted.
const NChar * szFormat | [in] Pointer to format string.
NWChar * pValue | [out] A pointer to the converted NWChar.
NBool * pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For format specifications see Format Specifications.

Container

File: NTypes.h

Module: NTypes Unit


NComplex_ Structure

NComplex_ Structure
NTypes.h

Represents a complex number value.

C++
struct NComplex_ {
  NDouble Real;
  NDouble Imaginary;
};
Collapse Expand Members
Members | Description
NDouble Real; | Real part of the complex number.
NDouble Imaginary; | Imaginary part of the complex number.
Container

File: NTypes.h

Module: NTypes Unit


NIndexPair_ Structure

NIndexPair_ Structure
NTypes.h

Represents a pair of indexes.

C++
struct NIndexPair_ {
  NInt Index1;
  NInt Index2;
};
Collapse Expand Members
Members | Description
NInt Index1; | First index of this NIndexPair.
NInt Index2; | Second index of this NIndexPair.
Container

File: NTypes.h

Module: NTypes Unit


NNameStringPair_ Structure

NNameStringPair_ Structure
NTypes.h

Represents a pair of name strings.

C++
struct NNameStringPair_ {
  HNString hKey;
  HNString hValue;
};
Collapse Expand Members
Members | Description
HNString hKey; | Key string of the name string pair.
HNString hValue; | Value string of the name string pair.
Container

File: NTypes.h

Module: NTypes Unit


NRational_ Structure

NRational_ Structure
NTypes.h

Represents a signed rational number.

C++
struct NRational_ {
  NInt Numerator;
  NInt Denominator;
};
Collapse Expand Members
Members | Description
NInt Numerator; | Numerator of this NRational.
NInt Denominator; | Denominator of this NRational.
Container

File: NTypes.h

Module: NTypes Unit


NURational_ Structure

NURational_ Structure
NTypes.h

Represents an unsigned rational number.

C++
struct NURational_ {
  NUInt Numerator;
  NUInt Denominator;
};
Collapse Expand Members
Members | Description
NUInt Numerator; | Numerator of this NURational.
NUInt Denominator; | Denominator of this NURational.
Container

File: NTypes.h

Module: NTypes Unit


NAttributes Enumeration

NAttributes Enumeration
NTypes.h

Enumerates value attributes.

C++
typedef enum NAttributes_ {
  naNone = 0,
  naSignNeutral = 0x00000001,
  naSingleValue = 0x00000002,
  naArray = 0x00000004,
  naNullable = 0x00000008,
  naLocal = 0x00000010,
  naGlobal = 0x00000020,
  naSet = 0x00000040,
  naCache = 0x00000080,
  naDeprecated = 0x00000100,
  naStatic = 0x00002000,
  naPublic = 0x00004000,
  naSealed = 0x00008000,
  naMinValue = 0x00100000,
  naMaxValue = 0x00200000,
  naStdValues = 0x00400000,
  naStdValuesExclusive = 0x00800000,
  naNoRead = 0x01000000,
  naNoWrite = 0x02000000,
  naByRef = 0x04000000,
  naRetValue = 0x08000000,
  naDefaultValue = 0x10000000,
  naOptional = 0x20000000,
  naPromoteValue = 0x80000000
} NAttributes;
Collapse Expand Members
Members | Description
naNone = 0 | Indicates no attributes.
naSignNeutral = 0x00000001 | Indicates that unsigned integer value can be interpreted as signed and vice versa
naSingleValue = 0x00000002 | Indicates that the value is a single value.
naArray = 0x00000004 | Indicates that the value is an array.
naNullable = 0x00000008 | Indicates that the value is nullable.
naLocal = 0x00000010 | Indicates that the value is local.
naGlobal = 0x00000020 | Indicates that the value is global.
naSet = 0x00000040 | Indicates that several values (from standard ones) can be combined.
naCache = 0x00000080 | Indicates that the object wrapper has to be cached.
naDeprecated = 0x00000100 | Indicates that the value is deprecated.
naStatic = 0x00002000 | Indicates that the value is static.
naPublic = 0x00004000 | Indicates that the value is public.
naSealed = 0x00008000 | Indicates that the value is sealed.
naMinValue = 0x00100000 | Indicates that the value is the minimum value.
naMaxValue = 0x00200000 | Indicates that the value is the maximum value.
naStdValues = 0x00400000 | Indicates that standard values are used.
naStdValuesExclusive = 0x00800000 | Indicates that standard values are exclusive.
naNoRead = 0x01000000 | Indicates that the value can't be read.
naNoWrite = 0x02000000 | Indicates that the value can't be written.
naByRef = 0x04000000 | Indicates that parameters are passed by reference.
naRetValue = 0x08000000 | Indicates a return value.
naDefaultValue = 0x10000000 | Indicates that the value is the default value.
naOptional = 0x20000000 | Indicates that the value is optional.
naPromoteValue = 0x80000000 | For NValueCreate/NArrayCreate specifies that the created object takes ownership of the provided pointer.
Container

File: NTypes.h

Module: NTypes Unit


NOSFamily Enumeration

NOSFamily Enumeration
NTypes.h

Enumerates OS families.

C++
typedef enum NOSFamily_ {
  nosfNone = 0,
  nosfWindows = 1,
  nosfWindowsCE = 2,
  nosfWindowsPhone = 4,
  nosfMacOSX = 8,
  nosfIOS = 16,
  nosfLinux = 32,
  nosfEmbeddedLinux = 64,
  nosfAndroid = 128,
  nosfUnix = 256
} NOSFamily;
Collapse Expand Members
Members | Description
nosfNone = 0 | Indicates no OS.
nosfWindows = 1 | Indicates Windows OS.
nosfWindowsCE = 2 | Indicates Windows CE OS.
nosfWindowsPhone = 4 | Indicates Windows Phone OS.
nosfMacOSX = 8 | Indicates Mac OS X.
nosfIOS = 16 | Indicates iOS.
nosfLinux = 32 | Indicates Linux OS.
nosfEmbeddedLinux = 64 | Indicates embedded Linux OS.
nosfAndroid = 128 | Indicates Android OS.
nosfUnix = 256 | Indicates Unix OS.
Container

File: NTypes.h

Module: NTypes Unit


NAChar Type

NAChar Type
NTypes.h

ANSI character (8-bit).

C++
typedef char NAChar;
Container

File: NTypes.h

Module: NTypes Unit


NBool Type

NBool Type
NTypes.h

Same as NBoolean.

C++
typedef NBoolean NBool;
Container

File: NTypes.h

Module: NTypes Unit


NBoolean Type

NBoolean Type
NTypes.h

32-bit boolean value. See also NTrue and NFalse.

C++
typedef NInt NBoolean;
Container

File: NTypes.h

Module: NTypes Unit


NByte Type

NByte Type
NTypes.h

Same as NUInt8.

C++
typedef NUInt8 NByte;
Container

File: NTypes.h

Module: NTypes Unit


NChar Type

NChar Type
NTypes.h

ANSI character (8-bit). See also NAChar.

C++
typedef NAChar NChar;
Container

File: NTypes.h

Module: NTypes Unit


NComplex Type

NComplex Type
NTypes.h

Complex number.

C++
typedef struct NComplex_ NComplex;
Container

File: NTypes.h

Module: NTypes Unit


NDouble Type

NDouble Type
NTypes.h

Double precision floating point number.

C++
typedef double NDouble;
Container

File: NTypes.h

Module: NTypes Unit


NFloat Type

NFloat Type
NTypes.h

Same as NSingle.

C++
typedef NSingle NFloat;
Container

File: NTypes.h

Module: NTypes Unit


NHandle Type

NHandle Type
NTypes.h

Pointer to unspecified data (same as void *).

C++
typedef void * NHandle;
Container

File: NTypes.h

Module: NTypes Unit


NIndexPair Type

NIndexPair Type
NTypes.h

Represents a pair of indexes.

C++
typedef struct NIndexPair_ NIndexPair;
Container

File: NTypes.h

Module: NTypes Unit


NInt Type

NInt Type
NTypes.h

Same as NInt32.

C++
typedef NInt32 NInt;
Container

File: NTypes.h

Module: NTypes Unit


NInt16 Type

NInt16 Type
NTypes.h

16-bit signed integer (short).

C++
typedef signed short NInt16;
Container

File: NTypes.h

Module: NTypes Unit


NInt32 Type

NInt32 Type
NTypes.h

32-bit signed integer (int).

C++
typedef signed int NInt32;
Container

File: NTypes.h

Module: NTypes Unit


NInt64 Type

NInt64 Type
NTypes.h

64-bit signed integer (long). Not available on some 32-bit platforms.

C++
typedef signed long long NInt64;
Container

File: NTypes.h

Module: NTypes Unit


NInt8 Type

NInt8 Type
NTypes.h

8-bit signed integer (signed byte).

C++
typedef signed char NInt8;
Container

File: NTypes.h

Module: NTypes Unit


NLong Type

NLong Type
NTypes.h

Same as NInt64.

C++
typedef NInt64 NLong;
Container

File: NTypes.h

Module: NTypes Unit


NNameStringPair Type

NNameStringPair Type
NTypes.h

Two linked strings.

C++
typedef struct NNameStringPair_ NNameStringPair;
Container

File: NTypes.h

Module: NTypes Unit


NRational Type

NRational Type
NTypes.h

Represents a signed rational number.

C++
typedef struct NRational_ NRational;
Container

File: NTypes.h

Module: NTypes Unit


NResult Type

NResult Type
NTypes.h

Result of a function (same as NInt). See also NErrors module.

C++
typedef signed int NResult;
Collapse Expand Remarks

Function result can be checked using NFailed and NSucceeded macros. When an error occurs NFailed(function_result) returns value which is less than zero. When function succeeds NSucceeded(function_result) returns value which is greater or equal to zero. So function result (NResult) can be checked using the following code:

Copy Code
/* ... */
if (NSucceeded(function_result))
{
   /* code which should be executed when function succeeds */
}
Copy Code
if (NFailed(function_result))
{
   /* code which should be executed when function fails */
}
/* ... */

When an error occurs function returns an error code. All error codes have negative values and can be checked in the error codes list.

Some functions that create memory buffer when succeed can return the size of created memory buffer (for example the number of NChar values in memory buffer). You should note that all NChar memory buffers are zero terminated so the length of these buffers are length of a string plus 1 (result = GetValue(buffer, length + 1)). The pattern for functions with NChar parameters is as the following:

Copy Code
NInt length = GetValue(NULL, 0);
if (NFailed(length)) { /* handle error */ }
malloc((length + 1) * sizeof(NChar))
result = GetValue(buffer, length + 1);

Container

File: NTypes.h

Module: NTypes Unit


NSByte Type

NSByte Type
NTypes.h

Same as NInt8.

C++
typedef NInt8 NSByte;
Container

File: NTypes.h

Module: NTypes Unit


NSSizeType Type

NSSizeType Type
NTypes.h

Platform dependent size type. Signed 32-bit integer on 32-bit platform, signed 64-bit integer on 64-bit platform.

C++
typedef NInt32 NSSizeType;
Container

File: NTypes.h

Module: NTypes Unit


NShort Type

NShort Type
NTypes.h

Same as NInt16.

C++
typedef NInt16 NShort;
Container

File: NTypes.h

Module: NTypes Unit


NSingle Type

NSingle Type
NTypes.h

Single precision floating point number.

C++
typedef float NSingle;
Container

File: NTypes.h

Module: NTypes Unit


NSizeType Type

NSizeType Type
NTypes.h

Platform dependent size type. Unsigned 32-bit integer on 32-bit platform, unsigned 64-bit integer on 64-bit platform.

C++
typedef NUInt32 NSizeType;
Container

File: NTypes.h

Module: NTypes Unit


NUInt Type

NUInt Type
NTypes.h

Same as NUInt32.

C++
typedef NUInt32 NUInt;
Container

File: NTypes.h

Module: NTypes Unit


NUInt16 Type

NUInt16 Type
NTypes.h

16-bit unsigned integer (unsigned short).

C++
typedef unsigned short NUInt16;
Container

File: NTypes.h

Module: NTypes Unit


NUInt32 Type

NUInt32 Type
NTypes.h

32-bit unsigned integer (unsigned int).

C++
typedef unsigned int NUInt32;
Container

File: NTypes.h

Module: NTypes Unit


NUInt64 Type

NUInt64 Type
NTypes.h

64-bit unsigned integer (unsigned long). Not available on some 32-bit platforms.

C++
typedef unsigned long long NUInt64;
Container

File: NTypes.h

Module: NTypes Unit


NUInt8 Type

NUInt8 Type
NTypes.h

8-bit unsigned integer (byte).

C++
typedef unsigned char NUInt8;
Container

File: NTypes.h

Module: NTypes Unit


NULong Type

NULong Type
NTypes.h

Same as NUInt64.

C++
typedef NUInt64 NULong;
Container

File: NTypes.h

Module: NTypes Unit


NURational Type

NURational Type
NTypes.h

Represents an unsigned rational number.

C++
typedef struct NURational_ NURational;
Container

File: NTypes.h

Module: NTypes Unit


NUShort Type

NUShort Type
NTypes.h

Same as NUInt16.

C++
typedef NUInt16 NUShort;
Container

File: NTypes.h

Module: NTypes Unit


NVersion Type

NVersion Type
NTypes.h

Two NInt32 values defining a version.

C++
typedef NVersion_ NVersion;
Container

File: NTypes.h

Module: NTypes Unit


NVersionRange Type

NVersionRange Type
NTypes.h

Four NInt32 values defining a version range.

C++
typedef NVersionRange_ NVersionRange;
Container

File: NTypes.h

Module: NTypes Unit


NVersionRange_ Type

NVersionRange_ Type
NTypes.h

A NUInt typedef defining a version range.

C++
typedef NUInt NVersionRange_;
Container

File: NTypes.h

Module: NTypes Unit


NVersion_ Type

NVersion_ Type
NTypes.h

A NUShort typedef defining a version.

C++
typedef NUShort NVersion_;
Container

File: NTypes.h

Module: NTypes Unit


N_DECLARE_HANDLE Macro

N_DECLARE_HANDLE Macro
NTypes.h

Declares handle with specified name.

C++
#define N_DECLARE_HANDLE(name) typedef struct name##_ { int unused; } * name;
Container

File: NTypes.h

Module: NTypes Unit


NACharParse Macro

NACharParse Macro
NTypes.h

Converts a NString to NAChar.

C++
#define NACharParse(szValue, szFormat, pValue) NACharParseStrOrChars(szValue, -1, szFormat, pValue)
Collapse Expand Parameters
Parameters | Description
szValue | [in] A pointer to NString to be converted.
szFormat | [in] Pointer to format string.
pValue | [out] A pointer to the converted NAChar.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NACharParseChars Macro

NACharParseChars Macro
NTypes.h

Converts an array of NChars to NAChar.

C++
#define NACharParseChars(arValue, valueLength, szFormat, pValue) NACharParseStrOrChars(arValue, valueLength, szFormat, pValue)
Collapse Expand Parameters
Parameters | Description
arValue | [in] A pointer to NChar array.
valueLength | [in] Length of the array.
szFormat | [in] Pointer to numeric format string.
pValue | [out] A pointer to the converted NAChar.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NACharParseStrOrChars Macro

NACharParseStrOrChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NACharParseStrOrChars function.

C++
#define NACharParseStrOrChars N_FUNC_AW(NACharParseStrOrChars)
Container

File: NTypes.h

Module: NTypes Unit


NACharParseVN Macro

NACharParseVN Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NACharParseVN function.

C++
#define NACharParseVN N_FUNC_AW(NACharParseVN)
Container

File: NTypes.h

Module: NTypes Unit


NACharToChars Macro

NACharToChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NACharToChars function.

C++
#define NACharToChars N_FUNC_AW(NACharToChars)
Container

File: NTypes.h

Module: NTypes Unit


NACharToString Macro

NACharToString Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NACharToString function.

C++
#define NACharToString N_FUNC_AW(NACharToString)
Container

File: NTypes.h

Module: NTypes Unit


NACharTryParse Macro

NACharTryParse Macro
NTypes.h

Converts NString to NAChar. A NBool value indicates whether the conversion succeeded.

C++
#define NACharTryParse(szValue, szFormat, pValue, pResult) NACharTryParseStrOrChars(szValue, -1, szFormat, pValue, pResult)
Collapse Expand Parameters
Parameters | Description
hValue | [in] A handle to NString to be converted.
szFormat | [in] Pointer to numeric format string.
pValue | [out] A pointer to the converted NAChar.
pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NACharTryParseChars Macro

NACharTryParseChars Macro
NTypes.h

Converts an array of NChars to NAChar. A NBool value indicates whether the conversion succeeded.

C++
#define NACharTryParseChars(arValue, valueLength, szFormat, pValue, pResult) NACharTryParseStrOrChars(arValue, valueLength, szFormat, pValue, pResult)
Collapse Expand Parameters
Parameters | Description
arValue | [in] A pointer to NChar array.
valueLength | [in] Length of the array.
szFormat | [in] Pointer to numeric format string.
pValue | [out] A pointer to the converted NAChar.
pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NACharTryParseStrOrChars Macro

NACharTryParseStrOrChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NACharTryParseStrOrChars function.

C++
#define NACharTryParseStrOrChars N_FUNC_AW(NACharTryParseStrOrChars)
Container

File: NTypes.h

Module: NTypes Unit


NACharTryParseVN Macro

NACharTryParseVN Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NACharTryParseVN function.

C++
#define NACharTryParseVN N_FUNC_AW(NACharTryParseVN)
Container

File: NTypes.h

Module: NTypes Unit


NBooleanParse Macro

NBooleanParse Macro
NTypes.h

Converts NString to NBoolean.

C++
#define NBooleanParse(szValue, szFormat, pValue) NBooleanParseStrOrChars(szValue, -1, szFormat, pValue)
Collapse Expand Parameters
Parameters | Description
szValue | [in] A pointer to NString to be converted.
szFormat | [in] Pointer to numeric format string.
pValue | [out] A pointer to the converted NBoolean.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NBooleanParseChars Macro

NBooleanParseChars Macro
NTypes.h

Converts an array of NChars to NBoolean.

C++
#define NBooleanParseChars(arValue, szFormat, szFalseString, pValue) NBooleanParseStrOrChars(arValue, valueLength, szFormat, pValue)
Collapse Expand Parameters
Parameters | Description
arValue | [in] A pointer to NChar array.
szFormat | [in] Pointer to numeric format string.
szFalseString | [in] String for NFalse.
pValue | [out] A pointer to the converted NBoolean.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NBooleanParseStrOrChars Macro

NBooleanParseStrOrChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NBooleanParseStrOrChars function.

C++
#define NBooleanParseStrOrChars N_FUNC_AW(NBooleanParseStrOrChars)
Container

File: NTypes.h

Module: NTypes Unit


NBooleanParseVN Macro

NBooleanParseVN Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NBooleanParseVN function.

C++
#define NBooleanParseVN N_FUNC_AW(NBooleanParseVN)
Container

File: NTypes.h

Module: NTypes Unit


NBooleanToChars Macro

NBooleanToChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NBooleanToChars function.

C++
#define NBooleanToChars N_FUNC_AW(NBooleanToChars)
Container

File: NTypes.h

Module: NTypes Unit


NBooleanToString Macro

NBooleanToString Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NBooleanToString function.

C++
#define NBooleanToString N_FUNC_AW(NBooleanToString)
Container

File: NTypes.h

Module: NTypes Unit


NBooleanTryParse Macro

NBooleanTryParse Macro
NTypes.h

Converts NString to NBoolean. A NBool value indicates whether the conversion succeeded.

C++
#define NBooleanTryParse(szValue, szFormat, pValue, pResult) NBooleanTryParseStrOrChars(szValue, -1, szFormat, pValue, pResult)
Collapse Expand Parameters
Parameters | Description
hValue | [in] A handle to NString to be converted.
szFormat | [in] Pointer to numeric format string.
pValue | [out] A pointer to the converted NBoolean.
pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NBooleanTryParseChars Macro

NBooleanTryParseChars Macro
NTypes.h

Converts an array of NChars to NBoolean. A NBool value indicates whether the conversion succeeded.

C++
#define NBooleanTryParseChars(arValue, valueLength, szFormat, pValue, pResult) NBooleanTryParseStrOrChars(arValue, valueLength, szFormat, pValue, pResult)
Collapse Expand Parameters
Parameters | Description
arValue | [in] A pointer to NChar array.
valueLength | [in] Length of the array.
szFormat | [in] Pointer to numeric format string.
pValue | [out] A pointer to the converted NAChar.
pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NBooleanTryParseStrOrChars Macro

NBooleanTryParseStrOrChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NBooleanTryParseStrOrChars function.

C++
#define NBooleanTryParseStrOrChars N_FUNC_AW(NBooleanTryParseStrOrChars)
Container

File: NTypes.h

Module: NTypes Unit


NBooleanTryParseVN Macro

NBooleanTryParseVN Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NBooleanTryParseVN function.

C++
#define NBooleanTryParseVN N_FUNC_AW(NBooleanTryParseVN)
Container

File: NTypes.h

Module: NTypes Unit


NCharFromBinDigit Macro

NCharFromBinDigit Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NCharFromBinDigit function.

C++
#define NCharFromBinDigit N_FUNC_AW(NCharFromBinDigit)
Container

File: NTypes.h

Module: NTypes Unit


NCharFromDigit Macro

NCharFromDigit Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NCharFromDigit function.

C++
#define NCharFromDigit N_FUNC_AW(NCharFromDigit)
Container

File: NTypes.h

Module: NTypes Unit


NCharFromHexDigit Macro

NCharFromHexDigit Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NCharFromHexDigit function.

C++
#define NCharFromHexDigit N_FUNC_AW(NCharFromHexDigit)
Container

File: NTypes.h

Module: NTypes Unit


NCharFromOctDigit Macro

NCharFromOctDigit Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NCharFromOctDigit function.

C++
#define NCharFromOctDigit N_FUNC_AW(NCharFromOctDigit)
Container

File: NTypes.h

Module: NTypes Unit


NCharIsAscii Macro

NCharIsAscii Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NCharIsAscii function.

C++
#define NCharIsAscii N_FUNC_AW(NCharIsAscii)
Container

File: NTypes.h

Module: NTypes Unit


NCharIsBinDigit Macro

NCharIsBinDigit Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NCharIsBinDigit function.

C++
#define NCharIsBinDigit N_FUNC_AW(NCharIsBinDigit)
Container

File: NTypes.h

Module: NTypes Unit


NCharIsDigit Macro

NCharIsDigit Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NCharIsDigit function.

C++
#define NCharIsDigit N_FUNC_AW(NCharIsDigit)
Container

File: NTypes.h

Module: NTypes Unit


NCharIsHexDigit Macro

NCharIsHexDigit Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NCharIsHexDigit function.

C++
#define NCharIsHexDigit N_FUNC_AW(NCharIsHexDigit)
Container

File: NTypes.h

Module: NTypes Unit


NCharIsLetter Macro

NCharIsLetter Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NCharIsLetter function.

C++
#define NCharIsLetter N_FUNC_AW(NCharIsLetter)
Container

File: NTypes.h

Module: NTypes Unit


NCharIsLower Macro

NCharIsLower Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NCharIsLower function.

C++
#define NCharIsLower N_FUNC_AW(NCharIsLower)
Container

File: NTypes.h

Module: NTypes Unit


NCharIsOctDigit Macro

NCharIsOctDigit Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NCharIsOctDigit function.

C++
#define NCharIsOctDigit N_FUNC_AW(NCharIsOctDigit)
Container

File: NTypes.h

Module: NTypes Unit


NCharIsUpper Macro

NCharIsUpper Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NCharIsUpper function.

C++
#define NCharIsUpper N_FUNC_AW(NCharIsUpper)
Container

File: NTypes.h

Module: NTypes Unit


NCharIsWhiteSpace Macro

NCharIsWhiteSpace Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NCharIsWhiteSpace function.

C++
#define NCharIsWhiteSpace N_FUNC_AW(NCharIsWhiteSpace)
Container

File: NTypes.h

Module: NTypes Unit


NCharParse Macro

NCharParse Macro
NTypes.h

Converts NString to NChar.

C++
#define NCharParse(szValue, szFormat, pValue) NCharParseStrOrChars(szValue, -1, szFormat, pValue)
Collapse Expand Parameters
Parameters | Description
szValue | [in] A pointer to NString to be converted.
szFormat | [in] Pointer to format string.
pValue | [out] A pointer to the converted NChar.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NCharParseChars Macro

NCharParseChars Macro
NTypes.h

Converts an array of NChars to NBoolean.

C++
#define NCharParseChars(arValue, valueLength, szFormat, pValue) NCharParseStrOrChars(arValue, valueLength, szFormat, pValue)
Collapse Expand Parameters
Parameters | Description
arValue | [in] A pointer to NChar array.
valueLength | [in] Length of the array.
szFormat | [in] Pointer to format string.
pValue | [out] A pointer to the converted NChar.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NCharToBinDigit Macro

NCharToBinDigit Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NCharToBinDigit function.

C++
#define NCharToBinDigit N_FUNC_AW(NCharToBinDigit)
Container

File: NTypes.h

Module: NTypes Unit


NCharToDigit Macro

NCharToDigit Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NCharToDigit function.

C++
#define NCharToDigit N_FUNC_AW(NCharToDigit)
Container

File: NTypes.h

Module: NTypes Unit


NCharToHexDigit Macro

NCharToHexDigit Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NCharToHexDigit function.

C++
#define NCharToHexDigit N_FUNC_AW(NCharToHexDigit)
Container

File: NTypes.h

Module: NTypes Unit


NCharToLower Macro

NCharToLower Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NCharToLower function.

C++
#define NCharToLower N_FUNC_AW(NCharToLower)
Container

File: NTypes.h

Module: NTypes Unit


NCharToOctDigit Macro

NCharToOctDigit Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NCharToOctDigit function.

C++
#define NCharToOctDigit N_FUNC_AW(NCharToOctDigit)
Container

File: NTypes.h

Module: NTypes Unit


NCharToUpper Macro

NCharToUpper Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NCharToUpper function.

C++
#define NCharToUpper N_FUNC_AW(NCharToUpper)
Container

File: NTypes.h

Module: NTypes Unit


NCharTryParse Macro

NCharTryParse Macro
NTypes.h

Converts NString to NChar. A NBool value indicates whether the conversion succeeded.

C++
#define NCharTryParse(szValue, szFormat, pValue, pResult) NCharTryParseStrOrChars(szValue, -1, szFormat, pValue, pResult)
Collapse Expand Parameters
Parameters | Description
szValue | [in] A pointer to NString to be converted.
szFormat | [in] Pointer to format string.
pValue | [out] A pointer to the converted NChar.
pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NCharTryParseChars Macro

NCharTryParseChars Macro
NTypes.h

Converts an array of NChars to NChar. A NBool value indicates whether the conversion succeeded.

C++
#define NCharTryParseChars(arValue, valueLength, szFormat, pValue, pResult) NCharTryParseStrOrChars(arValue, valueLength, szFormat, pValue, pResult)
Collapse Expand Parameters
Parameters | Description
arValue | [in] A pointer to NChar array.
valueLength | [in] Length of the array.
szFormat | [in] Pointer to format string.
pValue | [out] A pointer to the converted NChar.
pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NDoubleParse Macro

NDoubleParse Macro
NTypes.h

Converts NString to NDouble.

C++
#define NDoubleParse(szValue, szFormat, pValue) NDoubleParseStrOrChars(szValue, -1, szFormat, pValue)
Collapse Expand Parameters
Parameters | Description
szValue | [in] A pointer to NString to be converted.
szFormat | [in] Pointer to format string.
pValue | [out] A pointer to the converted NDouble.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NDoubleParseChars Macro

NDoubleParseChars Macro
NTypes.h

Converts an array of NChars to NChar.

C++
#define NDoubleParseChars(arValue, valueLength, szFormat, pValue) NDoubleParseStrOrChars(arValue, valueLength, szFormat, pValue)
Collapse Expand Parameters
Parameters | Description
arValue | [in] A pointer to NChar array.
valueLength | [in] Length of the array.
szFormat | [in] Pointer to format string.
pValue | [out] A pointer to the converted NDouble.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NDoubleParseStrOrChars Macro

NDoubleParseStrOrChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NDoubleParseStrOrChars function.

C++
#define NDoubleParseStrOrChars N_FUNC_AW(NDoubleParseStrOrChars)
Container

File: NTypes.h

Module: NTypes Unit


NDoubleParseVN Macro

NDoubleParseVN Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NDoubleParseVN function.

C++
#define NDoubleParseVN N_FUNC_AW(NDoubleParseVN)
Container

File: NTypes.h

Module: NTypes Unit


NDoubleToChars Macro

NDoubleToChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NDoubleToChars function.

C++
#define NDoubleToChars N_FUNC_AW(NDoubleToChars)
Container

File: NTypes.h

Module: NTypes Unit


NDoubleToString Macro

NDoubleToString Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NDoubleToString function.

C++
#define NDoubleToString N_FUNC_AW(NDoubleToString)
Container

File: NTypes.h

Module: NTypes Unit


NDoubleTryParse Macro

NDoubleTryParse Macro
NTypes.h

Converts NString to NDouble. A NBool value indicates whether the conversion succeeded.

C++
#define NDoubleTryParse(szValue, szFormat, pValue, pResult) NDoubleTryParseStrOrChars(szValue, -1, szFormat, pValue, pResult)
Collapse Expand Parameters
Parameters | Description
szValue | [in] A pointer to NString to be converted.
szFormat | [in] Pointer to format string.
pValue | [out] A pointer to the converted NDouble.
pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NDoubleTryParseChars Macro

NDoubleTryParseChars Macro
NTypes.h

Converts an array of NChars to NDouble. A NBool value indicates whether the conversion succeeded.

C++
#define NDoubleTryParseChars(arValue, valueLength, szFormat, pValue, pResult) NDoubleTryParseStrOrChars(arValue, valueLength, szFormat, pValue, pResult)
Collapse Expand Parameters
Parameters | Description
arValue | [in] A pointer to NChar array.
valueLength | [in] Length of the array.
szFormat | [in] Pointer to format string.
pValue | [out] A pointer to the converted NDouble.
pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NDoubleTryParseStrOrChars Macro

NDoubleTryParseStrOrChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NDoubleTryParseStrOrChars function.

C++
#define NDoubleTryParseStrOrChars N_FUNC_AW(NDoubleTryParseStrOrChars)
Container

File: NTypes.h

Module: NTypes Unit


NDoubleTryParseVN Macro

NDoubleTryParseVN Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NDoubleTryParseVN function.

C++
#define NDoubleTryParseVN N_FUNC_AW(NDoubleTryParseVN)
Container

File: NTypes.h

Module: NTypes Unit


NFalse Macro

NFalse Macro
NTypes.h

False value for NBoolean.

C++
#define NFalse 0
Container

File: NTypes.h

Module: NTypes Unit


NGuidParse Macro

NGuidParse Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NGuidParse function.

C++
#define NGuidParse N_FUNC_AW(NGuidParse)
Container

File: NTypes.h

Module: NTypes Unit


NGuidParseVN Macro

NGuidParseVN Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NGuidParseVN function.

C++
#define NGuidParseVN N_FUNC_AW(NGuidParseVN)
Container

File: NTypes.h

Module: NTypes Unit


NGuidToString Macro

NGuidToString Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NGuidToString function.

C++
#define NGuidToString N_FUNC_AW(NGuidToString)
Container

File: NTypes.h

Module: NTypes Unit


NGuidTryParse Macro

NGuidTryParse Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NGuidTryParse function.

C++
#define NGuidTryParse N_FUNC_AW(NGuidTryParse)
Container

File: NTypes.h

Module: NTypes Unit


NGuidTryParseVN Macro

NGuidTryParseVN Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NGuidTryParseVN function.

C++
#define NGuidTryParseVN N_FUNC_AW(NGuidTryParseVN)
Container

File: NTypes.h

Module: NTypes Unit


NIndexPairToString Macro

NIndexPairToString Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NIndexPairToString function.

C++
#define NIndexPairToString N_FUNC_AW(NIndexPairToString)
Container

File: NTypes.h

Module: NTypes Unit


NInt16Parse Macro

NInt16Parse Macro
NTypes.h

Converts NString to NInt16.

C++
#define NInt16Parse(szValue, szFormat, pValue) NInt16ParseStrOrChars(szValue, -1, szFormat, pValue)
Collapse Expand Parameters
Parameters | Description
szValue | [in] A pointer to NString to be converted.
szFormat | [in] Pointer to numeric format string.
pValue | [out] A pointer to the converted NInt16.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NInt16ParseChars Macro

NInt16ParseChars Macro
NTypes.h

Converts an array of NChars to NInt16.

C++
#define NInt16ParseChars(arValue, valueLength, szFormat, pValue) NInt16ParseStrOrChars(arValue, valueLength, szFormat, pValue)
Collapse Expand Parameters
Parameters | Description
arValue | [in] A pointer to NChar array.
valueLength | [in] Length of the array.
szFormat | [in] Pointer to numeric format string.
pValue | [out] A pointer to the converted NInt16.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NInt16ParseStrOrChars Macro

NInt16ParseStrOrChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NInt16ParseStrOrChars function.

C++
#define NInt16ParseStrOrChars N_FUNC_AW(NInt16ParseStrOrChars)
Container

File: NTypes.h

Module: NTypes Unit


NInt16ParseVN Macro

NInt16ParseVN Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NInt16ParseVN function.

C++
#define NInt16ParseVN N_FUNC_AW(NInt16ParseVN)
Container

File: NTypes.h

Module: NTypes Unit


NInt16ToChars Macro

NInt16ToChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NInt16ToChars function.

C++
#define NInt16ToChars N_FUNC_AW(NInt16ToChars)
Container

File: NTypes.h

Module: NTypes Unit


NInt16ToString Macro

NInt16ToString Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NInt16ToString function.

C++
#define NInt16ToString N_FUNC_AW(NInt16ToString)
Container

File: NTypes.h

Module: NTypes Unit


NInt16TryParse Macro

NInt16TryParse Macro
NTypes.h

Converts NString to NInt16. A NBool value indicates whether the conversion succeeded.

C++
#define NInt16TryParse(szValue, szFormat, pValue, pResult) NInt16TryParseStrOrChars(szValue, -1, szFormat, pValue, pResult)
Collapse Expand Parameters
Parameters | Description
szValue | [in] A pointer to NString to be converted.
szFormat | [in] Pointer to numeric format string.
pValue | [out] A pointer to the converted NInt16.
pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NInt16TryParseChars Macro

NInt16TryParseChars Macro
NTypes.h

Converts an array of NChars to NInt16. A NBool value indicates whether the conversion succeeded.

C++
#define NInt16TryParseChars(arValue, valueLength, szFormat, pValue, pResult) NInt16TryParseStrOrChars(arValue, valueLength, szFormat, pValue, pResult)
Collapse Expand Parameters
Parameters | Description
arValue | [in] A pointer to NChar array.
valueLength | [in] Length of the array.
szFormat | [in] Pointer to numeric format string.
pValue | [out] A pointer to the converted NInt16.
pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NInt16TryParseStrOrChars Macro

NInt16TryParseStrOrChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NInt16TryParseStrOrChars function.

C++
#define NInt16TryParseStrOrChars N_FUNC_AW(NInt16TryParseStrOrChars)
Container

File: NTypes.h

Module: NTypes Unit


NInt16TryParseVN Macro

NInt16TryParseVN Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NInt16TryParseVN function.

C++
#define NInt16TryParseVN N_FUNC_AW(NInt16TryParseVN)
Container

File: NTypes.h

Module: NTypes Unit


NInt32Parse Macro

NInt32Parse Macro
NTypes.h

Converts NString to NInt32.

C++
#define NInt32Parse(szValue, szFormat, pValue) NInt32ParseStrOrChars(szValue, -1, szFormat, pValue)
Collapse Expand Parameters
Parameters | Description
szValue | [in] A pointer to NString to be converted.
szFormat | [in] Pointer to numeric format string.
pValue | [out] A pointer to the converted NInt32.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NInt32ParseChars Macro

NInt32ParseChars Macro
NTypes.h

Converts an array of NChars to NInt32.

C++
#define NInt32ParseChars(arValue, valueLength, szFormat, pValue) NInt32ParseStrOrChars(arValue, valueLength, szFormat, pValue)
Collapse Expand Parameters
Parameters | Description
arValue | [in] A pointer to NChar array.
valueLength | [in] Length of the array.
szFormat | [in] Pointer to numeric format string.
pValue | [out] A pointer to the converted NInt32.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NInt32ParseStrOrChars Macro

NInt32ParseStrOrChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NInt32ParseStrOrChars function.

C++
#define NInt32ParseStrOrChars N_FUNC_AW(NInt32ParseStrOrChars)
Container

File: NTypes.h

Module: NTypes Unit


NInt32ParseVN Macro

NInt32ParseVN Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NInt32ParseVN function.

C++
#define NInt32ParseVN N_FUNC_AW(NInt32ParseVN)
Container

File: NTypes.h

Module: NTypes Unit


NInt32ToChars Macro

NInt32ToChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NInt32ToChars function.

C++
#define NInt32ToChars N_FUNC_AW(NInt32ToChars)
Container

File: NTypes.h

Module: NTypes Unit


NInt32ToString Macro

NInt32ToString Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NInt32ToString function.

C++
#define NInt32ToString N_FUNC_AW(NInt32ToString)
Container

File: NTypes.h

Module: NTypes Unit


NInt32TryParse Macro

NInt32TryParse Macro
NTypes.h

Converts NString to NInt32. A NBool value indicates whether the conversion succeeded.

C++
#define NInt32TryParse(szValue, szFormat, pValue, pResult) NInt32TryParseStrOrChars(szValue, -1, szFormat, pValue, pResult)
Collapse Expand Parameters
Parameters | Description
szValue | [in] A pointer to NString to be converted.
szFormat | [in] Pointer to numeric format string.
pValue | [out] A pointer to the converted NInt32.
pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NInt32TryParseChars Macro

NInt32TryParseChars Macro
NTypes.h

Converts an array of NChars to NInt32. A NBool value indicates whether the conversion succeeded.

C++
#define NInt32TryParseChars(arValue, valueLength, szFormat, pValue, pResult) NInt32TryParseStrOrChars(arValue, valueLength, szFormat, pValue, pResult)
Collapse Expand Parameters
Parameters | Description
arValue | [in] A pointer to NChar array.
valueLength | [in] Length of the array.
szFormat | [in] Pointer to numeric format string.
pValue | [out] A pointer to the converted NInt32.
pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NInt32TryParseStrOrChars Macro

NInt32TryParseStrOrChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NInt32TryParseStrOrChars function.

C++
#define NInt32TryParseStrOrChars N_FUNC_AW(NInt32TryParseStrOrChars)
Container

File: NTypes.h

Module: NTypes Unit


NInt32TryParseVN Macro

NInt32TryParseVN Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NInt32tryParseVN function.

C++
#define NInt32TryParseVN N_FUNC_AW(NInt32TryParseVN)
Container

File: NTypes.h

Module: NTypes Unit


NInt64Parse Macro

NInt64Parse Macro
NTypes.h

Converts NString to NInt64.

C++
#define NInt64Parse(szValue, szFormat, pValue) NInt64ParseStrOrChars(szValue, -1, szFormat, pValue)
Collapse Expand Parameters
Parameters | Description
szValue | [in] A pointer to NString to be converted.
szFormat | [in] Pointer to numeric format string.
pValue | [out] A pointer to the converted NInt64.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NInt64ParseChars Macro

NInt64ParseChars Macro
NTypes.h

Converts an array of NChars to NInt64.

C++
#define NInt64ParseChars(arValue, valueLength, szFormat, pValue) NInt64ParseStrOrChars(arValue, valueLength, szFormat, pValue)
Collapse Expand Parameters
Parameters | Description
arValue | [in] A pointer to NChar array.
valueLength | [in] Length of the array.
szFormat | [in] Pointer to numeric format string.
pValue | [out] A pointer to the converted NInt64.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NInt64ParseStrOrChars Macro

NInt64ParseStrOrChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NInt64ParseStrOrChars function.

C++
#define NInt64ParseStrOrChars N_FUNC_AW(NInt64ParseStrOrChars)
Container

File: NTypes.h

Module: NTypes Unit


NInt64ParseVN Macro

NInt64ParseVN Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NInt64ParseVN function.

C++
#define NInt64ParseVN N_FUNC_AW(NInt64ParseVN)
Container

File: NTypes.h

Module: NTypes Unit


NInt64ToChars Macro

NInt64ToChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NInt64ToChars function.

C++
#define NInt64ToChars N_FUNC_AW(NInt64ToChars)
Container

File: NTypes.h

Module: NTypes Unit


NInt64ToString Macro

NInt64ToString Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NInt64ToString function.

C++
#define NInt64ToString N_FUNC_AW(NInt64ToString)
Container

File: NTypes.h

Module: NTypes Unit


NInt64TryParse Macro

NInt64TryParse Macro
NTypes.h

Converts NString to NInt64. A NBool value indicates whether the conversion succeeded.

C++
#define NInt64TryParse(szValue, szFormat, pValue, pResult) NInt64TryParseStrOrChars(szValue, -1, szFormat, pValue, pResult)
Collapse Expand Parameters
Parameters | Description
szValue | [in] A pointer to NString to be converted.
szFormat | [in] Pointer to numeric format string.
pValue | [out] A pointer to the converted NInt64.
pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NInt64TryParseChars Macro

NInt64TryParseChars Macro
NTypes.h

Converts an array of NChars to NInt64. A NBool value indicates whether the conversion succeeded.

C++
#define NInt64TryParseChars(arValue, valueLength, szFormat, pValue, pResult) NInt64TryParseStrOrChars(arValue, valueLength, szFormat, pValue, pResult)
Collapse Expand Parameters
Parameters | Description
arValue | [in] A pointer to NChar array.
valueLength | [in] Length of the array.
szFormat | [in] Pointer to numeric string format.
pValue | [out] A pointer to the converted NInt64.
pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NInt64TryParseStrOrChars Macro

NInt64TryParseStrOrChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NInt64TryParseStrOrChars function.

C++
#define NInt64TryParseStrOrChars N_FUNC_AW(NInt64TryParseStrOrChars)
Container

File: NTypes.h

Module: NTypes Unit


NInt64TryParseVN Macro

NInt64TryParseVN Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NInt64TryParseVN function.

C++
#define NInt64TryParseVN N_FUNC_AW(NInt64TryParseVN)
Container

File: NTypes.h

Module: NTypes Unit


NInt8Parse Macro

NInt8Parse Macro
NTypes.h

Converts NString to NInt8.

C++
#define NInt8Parse(szValue, szFormat, pValue) NInt8ParseStrOrChars(szValue, -1, szFormat, pValue)
Collapse Expand Parameters
Parameters | Description
szValue | [in] A pointer to NString to be converted.
szFormat | [in] Pointer to numeric format string.
pValue | [out] A pointer to the converted NInt8.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NInt8ParseChars Macro

NInt8ParseChars Macro
NTypes.h

Converts an array of NChars to NInt8.

C++
#define NInt8ParseChars(arValue, valueLength, szFormat, pValue) NInt8ParseStrOrChars(arValue, valueLength, szFormat, pValue)
Collapse Expand Parameters
Parameters | Description
arValue | [in] A pointer to NChar array.
valueLength | [in] Length of the array.
szFormat | [in] Pointer to numeric format string.
pValue | [out] A pointer to the converted NInt8.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NInt8ParseStrOrChars Macro

NInt8ParseStrOrChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NInt8ParseStrOrChars function.

C++
#define NInt8ParseStrOrChars N_FUNC_AW(NInt8ParseStrOrChars)
Container

File: NTypes.h

Module: NTypes Unit


NInt8ParseVN Macro

NInt8ParseVN Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NInt8ParseVN function.

C++
#define NInt8ParseVN N_FUNC_AW(NInt8ParseVN)
Container

File: NTypes.h

Module: NTypes Unit


NInt8ToChars Macro

NInt8ToChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NInt8ToChars function.

C++
#define NInt8ToChars N_FUNC_AW(NInt8ToChars)
Container

File: NTypes.h

Module: NTypes Unit


NInt8ToString Macro

NInt8ToString Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NInt8ToString function.

C++
#define NInt8ToString N_FUNC_AW(NInt8ToString)
Container

File: NTypes.h

Module: NTypes Unit


NInt8TryParse Macro

NInt8TryParse Macro
NTypes.h

Converts NString to NInt8. A NBool value indicates whether the conversion succeeded.

C++
#define NInt8TryParse(szValue, szFormat, pValue, pResult) NInt8TryParseStrOrChars(szValue, -1, szFormat, pValue, pResult)
Collapse Expand Parameters
Parameters | Description
szValue | [in] A pointer to NString to be converted.
szFormat | [in] Pointer to numeric format string.
pValue | [out] A pointer to the converted NInt8.
pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NInt8TryParseChars Macro

NInt8TryParseChars Macro
NTypes.h

Converts an array of NChars to NInt8. A NBool value indicates whether the conversion succeeded.

C++
#define NInt8TryParseChars(arValue, valueLength, szFormat, pValue, pResult) NInt8TryParseStrOrChars(arValue, valueLength, szFormat, pValue, pResult)
Collapse Expand Parameters
Parameters | Description
arValue | [in] A pointer to NChar array.
valueLength | [in] Length of the array.
szFormat | [in] Pointer to numeric format string.
pValue | [out] A pointer to the converted NInt8.
pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NInt8TryParseStrOrChars Macro

NInt8TryParseStrOrChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NInt8TryParseStrOrChars function.

C++
#define NInt8TryParseStrOrChars N_FUNC_AW(NInt8TryParseStrOrChars)
Container

File: NTypes.h

Module: NTypes Unit


NInt8TryParseVN Macro

NInt8TryParseVN Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NInt8TryParseVN function.

C++
#define NInt8TryParseVN N_FUNC_AW(NInt8TryParseVN)
Container

File: NTypes.h

Module: NTypes Unit


NPointerParse Macro

NPointerParse Macro
NTypes.h

Converts NString to NPointer.

C++
#define NPointerParse(szValue, szFormat, pValue) NPointerParseStrOrChars(szValue, -1, szFormat, pValue)
Collapse Expand Parameters
Parameters | Description
szValue | [in] A pointer to NString to be converted.
szFormat | [in] Pointer to format string.
pValue | [out] A pointer to the converted NPointer.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NPointerParseChars Macro

NPointerParseChars Macro
NTypes.h

Converts an array of NChars to NPointer.

C++
#define NPointerParseChars(arValue, szFormat, szFalseString, pValue) NPointerParseStrOrChars(arValue, valueLength, szFormat, pValue)
Collapse Expand Parameters
Parameters | Description
arValue | [in] A pointer to NChar array.
valueLength | [in] Length of the array.
szFormat | [in] Pointer to format string.
pValue | [out] A pointer to the converted NPointer.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NPointerParseStrOrChars Macro

NPointerParseStrOrChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NPointerParseStrOrChars function.

C++
#define NPointerParseStrOrChars N_FUNC_AW(NPointerParseStrOrChars)
Container

File: NTypes.h

Module: NTypes Unit


NPointerParseVN Macro

NPointerParseVN Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NPointerParseVN function.

C++
#define NPointerParseVN N_FUNC_AW(NPointerParseVN)
Container

File: NTypes.h

Module: NTypes Unit


NPointerToChars Macro

NPointerToChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NPointerToChars function.

C++
#define NPointerToChars N_FUNC_AW(NPointerToChars)
Container

File: NTypes.h

Module: NTypes Unit


NPointerToString Macro

NPointerToString Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NPointerToString function.

C++
#define NPointerToString N_FUNC_AW(NPointerToString)
Container

File: NTypes.h

Module: NTypes Unit


NPointerTryParse Macro

NPointerTryParse Macro
NTypes.h

Converts NString to NInt8. A NBool value indicates whether the conversion succeeded.

C++
#define NPointerTryParse(szValue, szFormat, pValue, pResult) NPointerTryParseStrOrChars(szValue, -1, szFormat, pValue, pResult)
Collapse Expand Parameters
Parameters | Description
szValue | [in] A pointer to NString to be converted.
szFormat | [in] Pointer to format string.
pValue | [out] A pointer to the converted NPointer.
pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NPointerTryParseChars Macro

NPointerTryParseChars Macro
NTypes.h

Converts an array of NChars to NPointer. A NBool value indicates whether the conversion succeeded.

C++
#define NPointerTryParseChars(arValue, valueLength, szFormat, pValue, pResult) NPointerTryParseStrOrChars(arValue, valueLength, szFormat, pValue, pResult)
Collapse Expand Parameters
Parameters | Description
arValue | [in] A pointer to NChar array.
valueLength | [in] Length of the array.
szFormat | [in] Pointer to format string.
pValue | [out] A pointer to the converted NPointer.
pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NPointerTryParseStrOrChars Macro

NPointerTryParseStrOrChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NPointerTryParseStrOrChars function.

C++
#define NPointerTryParseStrOrChars N_FUNC_AW(NPointerTryParseStrOrChars)
Container

File: NTypes.h

Module: NTypes Unit


NPointerTryParseVN Macro

NPointerTryParseVN Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NPointerTryParseVN function.

C++
#define NPointerTryParseVN N_FUNC_AW(NPointerTryParseVN)
Container

File: NTypes.h

Module: NTypes Unit


NRangeToString Macro

NRangeToString Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NRangeToString function.

C++
#define NRangeToString N_FUNC_AW(NRangeToString)
Container

File: NTypes.h

Module: NTypes Unit


NRationalToString Macro

NRationalToString Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NRationalToString function.

C++
#define NRationalToString N_FUNC_AW(NRationalToString)
Container

File: NTypes.h

Module: NTypes Unit


NResultParseVN Macro

NResultParseVN Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NResultParseVN function.

C++
#define NResultParseVN N_FUNC_AW(NResultParseVN)
Container

File: NTypes.h

Module: NTypes Unit


NResultToChars Macro

NResultToChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NResultToChars function.

C++
#define NResultToChars N_FUNC_AW(NResultToChars)
Container

File: NTypes.h

Module: NTypes Unit


NResultToString Macro

NResultToString Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the ResultToString function.

C++
#define NResultToString N_FUNC_AW(NResultToString)
Container

File: NTypes.h

Module: NTypes Unit


NResultTryParseStrOrChars Macro

NResultTryParseStrOrChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NResultTryParseStrOrChars function.

C++
#define NResultTryParseStrOrChars N_FUNC_AW(NResultTryParseStrOrChars)
Container

File: NTypes.h

Module: NTypes Unit


NResultTryParseVN Macro

NResultTryParseVN Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NResultTryParseVN function.

C++
#define NResultTryParseVN N_FUNC_AW(NResultTryParseVN)
Container

File: NTypes.h

Module: NTypes Unit


NSSizeTypeParse Macro

NSSizeTypeParse Macro
NTypes.h

Converts NString to NSSizeType.

C++
#define NSSizeTypeParse(szValue, szFormat, pValue) NSSizeTypeParseStrOrChars(szValue, -1, szFormat, pValue)
Collapse Expand Parameters
Parameters | Description
szValue | [in] A pointer to NString to be converted.
szFormat | [in] Pointer to format string.
pValue | [out] A pointer to the converted NSSizeType.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NSSizeTypeParseChars Macro

NSSizeTypeParseChars Macro
NTypes.h

Converts an array of NChars to NSSizeType.

C++
#define NSSizeTypeParseChars(arValue, valueLength, szFormat, pValue) NSSizeTypeParseStrOrChars(arValue, valueLength, szFormat, pValue)
Collapse Expand Parameters
Parameters | Description
arValue | [in] A pointer to NChar array.
valueLength | [in] Length of the array.
szFormat | [in] Pointer to format string.
pValue | [out] A pointer to the converted NSSizeType.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NSSizeTypeParseStrOrChars Macro

NSSizeTypeParseStrOrChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NSSizeTypeParseStrOrChars function.

C++
#define NSSizeTypeParseStrOrChars N_FUNC_AW(NSSizeTypeParseStrOrChars)
Container

File: NTypes.h

Module: NTypes Unit


NSSizeTypeParseVN Macro

NSSizeTypeParseVN Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NSSizeTypeParseVN function.

C++
#define NSSizeTypeParseVN N_FUNC_AW(NSSizeTypeParseVN)
Container

File: NTypes.h

Module: NTypes Unit


NSSizeTypeToChars Macro

NSSizeTypeToChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NSSizeTypeToChars function.

C++
#define NSSizeTypeToChars N_FUNC_AW(NSSizeTypeToChars)
Container

File: NTypes.h

Module: NTypes Unit


NSSizeTypeToString Macro

NSSizeTypeToString Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NSSizeTypeToString function.

C++
#define NSSizeTypeToString N_FUNC_AW(NSSizeTypeToString)
Container

File: NTypes.h

Module: NTypes Unit


NSSizeTypeTryParse Macro

NSSizeTypeTryParse Macro
NTypes.h

Converts NString to NSSizeType. A NBool value indicates whether the conversion succeeded.

C++
#define NSSizeTypeTryParse(szValue, szFormat, pValue, pResult) NSSizeTypeTryParseStrOrChars(szValue, -1, szFormat, pValue, pResult)
Collapse Expand Parameters
Parameters | Description
arValue | [in] A pointer to NChar array.
valueLength | [in] Length of the array.
szFormat | [in] Pointer to format string.
pValue | [out] A pointer to the converted NSSizeType.
pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NSSizeTypeTryParseChars Macro

NSSizeTypeTryParseChars Macro
NTypes.h

Converts an array of NChars to NSSizeType. A NBool value indicates whether the conversion succeeded.

C++
#define NSSizeTypeTryParseChars(arValue, valueLength, szFormat, pValue, pResult) NSSizeTypeTryParseStrOrChars(arValue, valueLength, szFormat, pValue, pResult)
Collapse Expand Parameters
Parameters | Description
arValue | [in] A pointer to NChar array.
valueLength | [in] Length of the array.
szFormat | [in] Pointer to format string.
pValue | [out] A pointer to the converted NSSizeType.
pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NSSizeTypeTryParseStrOrChars Macro

NSSizeTypeTryParseStrOrChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NSSizeTypeTryParseStrOrChars function.

C++
#define NSSizeTypeTryParseStrOrChars N_FUNC_AW(NSSizeTypeTryParseStrOrChars)
Container

File: NTypes.h

Module: NTypes Unit


NSSizeTypeTryParseVN Macro

NSSizeTypeTryParseVN Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NSSizeTypeTryParseVN function.

C++
#define NSSizeTypeTryParseVN N_FUNC_AW(NSSizeTypeTryParseVN)
Container

File: NTypes.h

Module: NTypes Unit


NSingleParse Macro

NSingleParse Macro
NTypes.h

Converts NString to NSingle.

C++
#define NSingleParse(szValue, szFormat, pValue) NSingleParseStrOrChars(szValue, -1, szFormat, pValue)
Collapse Expand Parameters
Parameters | Description
szValue | [in] A pointer to NString to be converted.
szFormat | [in] Pointer to numeric format string.
pValue | [out] A pointer to the converted NSingle.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NSingleParseChars Macro

NSingleParseChars Macro
NTypes.h

Converts an array of NChars to NSingle.

C++
#define NSingleParseChars(arValue, valueLength, szFormat, pValue) NSingleParseStrOrChars(arValue, valueLength, szFormat, pValue)
Collapse Expand Parameters
Parameters | Description
arValue | [in] A pointer to NChar array.
valueLength | [in] Length of the array.
szFormat | [in] Pointer to numeric format string.
pValue | [out] A pointer to the converted NSingle.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NSingleParseStrOrChars Macro

NSingleParseStrOrChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NSingleParseStrOrChars function.

C++
#define NSingleParseStrOrChars N_FUNC_AW(NSingleParseStrOrChars)
Container

File: NTypes.h

Module: NTypes Unit


NSingleParseVN Macro

NSingleParseVN Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NSingleParseVN function.

C++
#define NSingleParseVN N_FUNC_AW(NSingleParseVN)
Container

File: NTypes.h

Module: NTypes Unit


NSingleToChars Macro

NSingleToChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NSingleToChars function.

C++
#define NSingleToChars N_FUNC_AW(NSingleToChars)
Container

File: NTypes.h

Module: NTypes Unit


NSingleToString Macro

NSingleToString Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NSingleToString function.

C++
#define NSingleToString N_FUNC_AW(NSingleToString)
Container

File: NTypes.h

Module: NTypes Unit


NSingleTryParse Macro

NSingleTryParse Macro
NTypes.h

Converts NString to NSingle. A NBool value indicates whether the conversion succeeded.

C++
#define NSingleTryParse(szValue, szFormat, pValue, pResult) NSingleTryParseStrOrChars(szValue, -1, szFormat, pValue, pResult)
Collapse Expand Parameters
Parameters | Description
szValue | [in] A pointer to NString to be converted.
szFormat | [in] Pointer to numeric format string.
pValue | [out] A pointer to the converted NSingle.
pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NSingleTryParseChars Macro

NSingleTryParseChars Macro
NTypes.h

Converts an array of NChars to NSingle. A NBool value indicates whether the conversion succeeded.

C++
#define NSingleTryParseChars(arValue, valueLength, szFormat, pValue, pResult) NSingleTryParseStrOrChars(arValue, valueLength, szFormat, pValue, pResult)
Collapse Expand Parameters
Parameters | Description
arValue | [in] A pointer to NChar array.
valueLength | [in] Length of the array.
szFormat | [in] Pointer to numeric format string.
pValue | [out] A pointer to the converted NSingle.
pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NSingleTryParseStrOrChars Macro

NSingleTryParseStrOrChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NSingleTryParseStrOrChars function.

C++
#define NSingleTryParseStrOrChars N_FUNC_AW(NSingleTryParseStrOrChars)
Container

File: NTypes.h

Module: NTypes Unit


NSingleTryParseVN Macro

NSingleTryParseVN Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NSingleTryParseVN function.

C++
#define NSingleTryParseVN N_FUNC_AW(NSingleTryParseVN)
Container

File: NTypes.h

Module: NTypes Unit


NSizeTypeParse Macro

NSizeTypeParse Macro
NTypes.h

Converts NString to NSizeType.

C++
#define NSizeTypeParse(szValue, szFormat, pValue) NSizeTypeParseStrOrChars(szValue, -1, szFormat, pValue)
Collapse Expand Parameters
Parameters | Description
szValue | [in] A pointer to NString to be converted.
szFormat | [in] Pointer to format string.
pValue | [out] A pointer to the converted NSizeType.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NSizeTypeParseChars Macro

NSizeTypeParseChars Macro
NTypes.h

Converts an array of NChars to NSizeType.

C++
#define NSizeTypeParseChars(arValue, valueLength, szFormat, pValue) NSizeTypeParseStrOrChars(arValue, valueLength, szFormat, pValue)
Collapse Expand Parameters
Parameters | Description
arValue | [in] A pointer to NChar array.
valueLength | [in] Length of the array.
szFormat | [in] Pointer to format string.
pValue | [out] A pointer to the converted NSizeType.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NSizeTypeParseStrOrChars Macro

NSizeTypeParseStrOrChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NSizeTypeParseStrOrChars function.

C++
#define NSizeTypeParseStrOrChars N_FUNC_AW(NSizeTypeParseStrOrChars)
Container

File: NTypes.h

Module: NTypes Unit


NSizeTypeParseVN Macro

NSizeTypeParseVN Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NSizeTypeParseVN function.

C++
#define NSizeTypeParseVN N_FUNC_AW(NSizeTypeParseVN)
Container

File: NTypes.h

Module: NTypes Unit


NSizeTypeToChars Macro

NSizeTypeToChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NSizeTypeToChars function.

C++
#define NSizeTypeToChars N_FUNC_AW(NSizeTypeToChars)
Container

File: NTypes.h

Module: NTypes Unit


NSizeTypeToString Macro

NSizeTypeToString Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NSizeTypeToString function.

C++
#define NSizeTypeToString N_FUNC_AW(NSizeTypeToString)
Container

File: NTypes.h

Module: NTypes Unit


NSizeTypeTryParse Macro

NSizeTypeTryParse Macro
NTypes.h

Converts NString to NSizeType. A NBool value indicates whether the conversion succeeded.

C++
#define NSizeTypeTryParse(szValue, szFormat, pValue, pResult) NSizeTypeTryParseStrOrChars(szValue, -1, szFormat, pValue, pResult)
Collapse Expand Parameters
Parameters | Description
szValue | [in] A pointer to NString to be converted.
szFormat | [in] Pointer to format string.
pValue | [out] A pointer to the converted NSizeType.
pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NSizeTypeTryParseChars Macro

NSizeTypeTryParseChars Macro
NTypes.h

Converts an array of NChars to NSizeType. A NBool value indicates whether the conversion succeeded.

C++
#define NSizeTypeTryParseChars(arValue, valueLength, szFormat, pValue, pResult) NSizeTypeTryParseStrOrChars(arValue, valueLength, szFormat, pValue, pResult)
Collapse Expand Parameters
Parameters | Description
arValue | [in] A pointer to NChar array.
valueLength | [in] Length of the array.
szFormat | [in] Pointer to format string.
pValue | [out] A pointer to the converted NSizeType.
pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NSizeTypeTryParseStrOrChars Macro

NSizeTypeTryParseStrOrChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NSizeTypeTryParseStrOrChars function.

C++
#define NSizeTypeTryParseStrOrChars N_FUNC_AW(NSizeTypeTryParseStrOrChars)
Container

File: NTypes.h

Module: NTypes Unit


NSizeTypeTryParseVN Macro

NSizeTypeTryParseVN Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NSizeTypeTryParseVN function.

C++
#define NSizeTypeTryParseVN N_FUNC_AW(NSizeTypeTryParseVN)
Container

File: NTypes.h

Module: NTypes Unit


NTrue Macro

NTrue Macro
NTypes.h

True value for NBoolean.

C++
#define NTrue 1
Container

File: NTypes.h

Module: NTypes Unit


NUInt16Parse Macro

NUInt16Parse Macro
NTypes.h

Converts NString to NUInt16.

C++
#define NUInt16Parse(szValue, szFormat, pValue) NUInt16ParseStrOrChars(szValue, -1, szFormat, pValue)
Collapse Expand Parameters
Parameters | Description
szValue | [in] A pointer to NString to be converted.
szFormat | [in] For internal use.
pValue | [out] A pointer to the converted NUInt16.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NUInt16ParseChars Macro

NUInt16ParseChars Macro
NTypes.h

Converts an array of NChars to NUInt16.

C++
#define NUInt16ParseChars(arValue, valueLength, szFormat, pValue) NUInt16ParseStrOrChars(arValue, valueLength, szFormat, pValue)
Collapse Expand Parameters
Parameters | Description
arValue | [in] A pointer to NChar array.
valueLength | [in] Length of the array.
szFormat | [in] Pointer to numeric format string.
pValue | [out] A pointer to the converted NUInt16.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NUInt16ParseStrOrChars Macro

NUInt16ParseStrOrChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NUInt16ParseStrOrChars function.

C++
#define NUInt16ParseStrOrChars N_FUNC_AW(NUInt16ParseStrOrChars)
Container

File: NTypes.h

Module: NTypes Unit


NUInt16ParseVN Macro

NUInt16ParseVN Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NUInt16ParseVN function.

C++
#define NUInt16ParseVN N_FUNC_AW(NUInt16ParseVN)
Container

File: NTypes.h

Module: NTypes Unit


NUInt16ToChars Macro

NUInt16ToChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NUInt16ToChars function.

C++
#define NUInt16ToChars N_FUNC_AW(NUInt16ToChars)
Container

File: NTypes.h

Module: NTypes Unit


NUInt16ToString Macro

NUInt16ToString Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NUInt16ParseToString function.

C++
#define NUInt16ToString N_FUNC_AW(NUInt16ToString)
Container

File: NTypes.h

Module: NTypes Unit


NUInt16TryParse Macro

NUInt16TryParse Macro
NTypes.h

Converts NString to NUInt16. A NBool value indicates whether the conversion succeeded.

C++
#define NUInt16TryParse(szValue, szFormat, pValue, pResult) NUInt16TryParseStrOrChars(szValue, -1, szFormat, pValue, pResult)
Collapse Expand Parameters
Parameters | Description
arValue | [in] A pointer to NChar array.
valueLength | [in] Length of the array.
szFormat | [in] Pointer to numeric format string.
pValue | [out] A pointer to the converted NUInt16.
pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NUInt16TryParseChars Macro

NUInt16TryParseChars Macro
NTypes.h

Converts an array of NChars to NUInt16. A NBool value indicates whether the conversion succeeded.

C++
#define NUInt16TryParseChars(arValue, valueLength, szFormat, pValue, pResult) NUInt16TryParseStrOrChars(arValue, valueLength, szFormat, pValue, pResult)
Collapse Expand Parameters
Parameters | Description
arValue | [in] A pointer to NChar array.
valueLength | [in] Length of the array.
szFormat | [in] Pointer to numeric format string.
pValue | [out] A pointer to the converted NUInt16.
pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NUInt16TryParseStrOrChars Macro

NUInt16TryParseStrOrChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NUInt16TryParseStrOrChars function.

C++
#define NUInt16TryParseStrOrChars N_FUNC_AW(NUInt16TryParseStrOrChars)
Container

File: NTypes.h

Module: NTypes Unit


NUInt16TryParseVN Macro

NUInt16TryParseVN Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NUInt16TryParseVN function.

C++
#define NUInt16TryParseVN N_FUNC_AW(NUInt16TryParseVN)
Container

File: NTypes.h

Module: NTypes Unit


NUInt32Parse Macro

NUInt32Parse Macro
NTypes.h

Converts NString to NUInt32.

C++
#define NUInt32Parse(szValue, szFormat, pValue) NUInt32ParseStrOrChars(szValue, -1, szFormat, pValue)
Collapse Expand Parameters
Parameters | Description
szValue | [in] A pointer to NString to be converted.
szFormat | [in] Pointer to numeric format string.
pValue | [out] A pointer to the converted NUInt32.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NUInt32ParseChars Macro

NUInt32ParseChars Macro
NTypes.h

Converts an array of NChars to NUInt32.

C++
#define NUInt32ParseChars(arValue, valueLength, szFormat, pValue) NUInt32ParseStrOrChars(arValue, valueLength, szFormat, pValue)
Collapse Expand Parameters
Parameters | Description
arValue | [in] A pointer to NChar array.
valueLength | [in] Length of the array.
szFormat | [in] Pointer to numeric format string.
pValue | [out] A pointer to the converted NUInt32.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NUInt32ParseStrOrChars Macro

NUInt32ParseStrOrChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NUInt32ParseStrOrChars function.

C++
#define NUInt32ParseStrOrChars N_FUNC_AW(NUInt32ParseStrOrChars)
Container

File: NTypes.h

Module: NTypes Unit


NUInt32ParseVN Macro

NUInt32ParseVN Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NUInt32ParseVN function.

C++
#define NUInt32ParseVN N_FUNC_AW(NUInt32ParseVN)
Container

File: NTypes.h

Module: NTypes Unit


NUInt32ToChars Macro

NUInt32ToChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NUInt32ToChars function.

C++
#define NUInt32ToChars N_FUNC_AW(NUInt32ToChars)
Container

File: NTypes.h

Module: NTypes Unit


NUInt32ToString Macro

NUInt32ToString Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NUInt32ToString function.

C++
#define NUInt32ToString N_FUNC_AW(NUInt32ToString)
Container

File: NTypes.h

Module: NTypes Unit


NUInt32TryParse Macro

NUInt32TryParse Macro
NTypes.h

Converts NString to NUInt32. A NBool value indicates whether the conversion succeeded.

C++
#define NUInt32TryParse(szValue, szFormat, pValue, pResult) NUInt32TryParseStrOrChars(szValue, -1, szFormat, pValue, pResult)
Collapse Expand Parameters
Parameters | Description
arValue | [in] A pointer to NChar array.
valueLength | [in] Length of the array.
szFormat | [in] Pointer to numeric format string.
pValue | [out] A pointer to the converted NUInt32.
pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NUInt32TryParseChars Macro

NUInt32TryParseChars Macro
NTypes.h

Converts an array of NChars to NUInt32. A NBool value indicates whether the conversion succeeded.

C++
#define NUInt32TryParseChars(arValue, valueLength, szFormat, pValue, pResult) NUInt32TryParseStrOrChars(arValue, valueLength, szFormat, pValue, pResult)
Collapse Expand Parameters
Parameters | Description
arValue | [in] A pointer to NChar array.
valueLength | [in] Length of the array.
szFormat | [in] Pointer to numeric format string.
pValue | [out] A pointer to the converted NUInt32.
pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NUInt32TryParseStrOrChars Macro

NUInt32TryParseStrOrChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NUInt32TryParseStrOrChars function.

C++
#define NUInt32TryParseStrOrChars N_FUNC_AW(NUInt32TryParseStrOrChars)
Container

File: NTypes.h

Module: NTypes Unit


NUInt32TryParseVN Macro

NUInt32TryParseVN Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NUInt32TryParseVN function.

C++
#define NUInt32TryParseVN N_FUNC_AW(NUInt32TryParseVN)
Container

File: NTypes.h

Module: NTypes Unit


NUInt64Parse Macro

NUInt64Parse Macro
NTypes.h

Converts NString to NUInt64.

C++
#define NUInt64Parse(szValue, szFormat, pValue) NUInt64ParseStrOrChars(szValue, -1, szFormat, pValue)
Collapse Expand Parameters
Parameters | Description
szValue | [in] A pointer to NString to be converted.
szFormat | [in] Pointer to numeric format string.
pValue | [out] A pointer to the converted NUInt64.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NUInt64ParseChars Macro

NUInt64ParseChars Macro
NTypes.h

Converts an array of NChars to NUInt64.

C++
#define NUInt64ParseChars(arValue, valueLength, szFormat, pValue) NUInt64ParseStrOrChars(arValue, valueLength, szFormat, pValue)
Collapse Expand Parameters
Parameters | Description
arValue | [in] A pointer to NChar array.
valueLength | [in] Length of the array.
szFormat | [in] Pointer to numeric format string..
pValue | [out] A pointer to the converted NUInt64.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NUInt64ParseStrOrChars Macro

NUInt64ParseStrOrChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NUInt64ParseStrOrChars function.

C++
#define NUInt64ParseStrOrChars N_FUNC_AW(NUInt64ParseStrOrChars)
Container

File: NTypes.h

Module: NTypes Unit


NUInt64ParseVN Macro

NUInt64ParseVN Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NUInt64ParseVN function.

C++
#define NUInt64ParseVN N_FUNC_AW(NUInt64ParseVN)
Container

File: NTypes.h

Module: NTypes Unit


NUInt64ToChars Macro

NUInt64ToChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NUInt64ToChars function.

C++
#define NUInt64ToChars N_FUNC_AW(NUInt64ToChars)
Container

File: NTypes.h

Module: NTypes Unit


NUInt64ToString Macro

NUInt64ToString Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NUInt64ToString function.

C++
#define NUInt64ToString N_FUNC_AW(NUInt64ToString)
Container

File: NTypes.h

Module: NTypes Unit


NUInt64TryParse Macro

NUInt64TryParse Macro
NTypes.h

Converts NString to NUInt64. A NBool value indicates whether the conversion succeeded.

C++
#define NUInt64TryParse(szValue, szFormat, pValue, pResult) NUInt64TryParseStrOrChars(szValue, -1, szFormat, pValue, pResult)
Collapse Expand Parameters
Parameters | Description
arValue | [in] A pointer to NChar array.
valueLength | [in] Length of the array.
szFormat | [in] Pointer to numeric format string.
pValue | [out] A pointer to the converted NUInt64.
pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NUInt64TryParseChars Macro

NUInt64TryParseChars Macro
NTypes.h

Converts an array of NChars to NUInt64. A NBool value indicates whether the conversion succeeded.

C++
#define NUInt64TryParseChars(arValue, valueLength, szFormat, pValue, pResult) NUInt64TryParseStrOrChars(arValue, valueLength, szFormat, pValue, pResult)
Collapse Expand Parameters
Parameters | Description
arValue | [in] A pointer to NChar array.
valueLength | [in] Length of the array.
szFormat | [in] Pointer to numeric format string.
pValue | [out] A pointer to the converted NUInt64.
pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NUInt64TryParseStrOrChars Macro

NUInt64TryParseStrOrChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NUInt64TryParseStrOrChars function.

C++
#define NUInt64TryParseStrOrChars N_FUNC_AW(NUInt64TryParseStrOrChars)
Container

File: NTypes.h

Module: NTypes Unit


NUInt64TryParseVN Macro

NUInt64TryParseVN Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NUInt64TryParseVN function.

C++
#define NUInt64TryParseVN N_FUNC_AW(NUInt64TryParseVN)
Container

File: NTypes.h

Module: NTypes Unit


NUInt8Parse Macro

NUInt8Parse Macro
NTypes.h

Converts NString to NUInt8.

C++
#define NUInt8Parse(szValue, szFormat, pValue) NUInt8ParseStrOrChars(szValue, -1, szFormat, pValue)
Collapse Expand Parameters
Parameters | Description
szValue | [in] A pointer to NString to be converted.
szFormat | [in] Pointer to numeric format string.
pValue | [out] A pointer to the converted NUInt8.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NUInt8ParseChars Macro

NUInt8ParseChars Macro
NTypes.h

Converts an array of NChars to NUInt8.

C++
#define NUInt8ParseChars(arValue, valueLength, szFormat, pValue) NUInt8ParseStrOrChars(arValue, valueLength, szFormat, pValue)
Collapse Expand Parameters
Parameters | Description
arValue | [in] A pointer to NChar array.
valueLength | [in] Length of the array.
szFormat | [in] Pointer to numeric format string.
pValue | [out] A pointer to the converted NUInt8.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NUInt8ParseStrOrChars Macro

NUInt8ParseStrOrChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NUInt8ParseStrOrChars function.

C++
#define NUInt8ParseStrOrChars N_FUNC_AW(NUInt8ParseStrOrChars)
Container

File: NTypes.h

Module: NTypes Unit


NUInt8ParseVN Macro

NUInt8ParseVN Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NUInt8ParseVN function.

C++
#define NUInt8ParseVN N_FUNC_AW(NUInt8ParseVN)
Container

File: NTypes.h

Module: NTypes Unit


NUInt8ToChars Macro

NUInt8ToChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NUInt8ToChars function.

C++
#define NUInt8ToChars N_FUNC_AW(NUInt8ToChars)
Container

File: NTypes.h

Module: NTypes Unit


NUInt8ToString Macro

NUInt8ToString Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NUInt8ToString function.

C++
#define NUInt8ToString N_FUNC_AW(NUInt8ToString)
Container

File: NTypes.h

Module: NTypes Unit


NUInt8TryParse Macro

NUInt8TryParse Macro
NTypes.h

Converts NString to NUInt8. A NBool value indicates whether the conversion succeeded.

C++
#define NUInt8TryParse(szValue, szFormat, pValue, pResult) NUInt8TryParseStrOrChars(szValue, -1, szFormat, pValue, pResult)
Collapse Expand Parameters
Parameters | Description
arValue | [in] A pointer to NChar array.
valueLength | [in] Length of the array.
szFormat | [in] Pointer to numeric format string.
pValue | [out] A pointer to the converted NUInt8.
pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NUInt8TryParseChars Macro

NUInt8TryParseChars Macro
NTypes.h

Converts an array of NChars to NUInt8. A NBool value indicates whether the conversion succeeded.

C++
#define NUInt8TryParseChars(arValue, valueLength, szFormat, pValue, pResult) NUInt8TryParseStrOrChars(arValue, valueLength, szFormat, pValue, pResult)
Collapse Expand Parameters
Parameters | Description
arValue | [in] A pointer to NChar array.
valueLength | [in] Length of the array.
szFormat | [in] Pointer to numeric format string.
pValue | [out] A pointer to the converted NUInt8.
pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NUInt8TryParseStrOrChars Macro

NUInt8TryParseStrOrChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NUInt8TryParseStrOrChars function.

C++
#define NUInt8TryParseStrOrChars N_FUNC_AW(NUInt8TryParseStrOrChars)
Container

File: NTypes.h

Module: NTypes Unit


NUInt8TryParseVN Macro

NUInt8TryParseVN Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NUInt8TryParseVN function.

C++
#define NUInt8TryParseVN N_FUNC_AW(NUInt8TryParseVN)
Container

File: NTypes.h

Module: NTypes Unit


NULL Macro

NULL Macro
NTypes.h

Null value for pointer.

C++
#define NULL 0
Container

File: NTypes.h

Module: NTypes Unit


NURationalToString Macro

NURationalToString Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NURationalToString function.

C++
#define NURationalToString N_FUNC_AW(NURationalToString)
Container

File: NTypes.h

Module: NTypes Unit


NVersionRangeToString Macro

NVersionRangeToString Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NVersionRangeToString function.

C++
#define NVersionRangeToString N_FUNC_AW(NVersionRangeToString)
Container

File: NTypes.h

Module: NTypes Unit


NVersionToString Macro

NVersionToString Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NVersionToString function.

C++
#define NVersionToString N_FUNC_AW(NVersionToString)
Container

File: NTypes.h

Module: NTypes Unit


NWCharParse Macro

NWCharParse Macro
NTypes.h

Converts NString to NWChar.

C++
#define NWCharParse(szValue, szFormat, pValue) NWCharParseStrOrChars(szValue, -1, szFormat, pValue)
Collapse Expand Parameters
Parameters | Description
szValue | [in] A pointer to NString to be converted.
szFormat | [in] Pointer to format string.
pValue | [out] A pointer to the converted NWChar.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NWCharParseChars Macro

NWCharParseChars Macro
NTypes.h

Converts an array of NChars to NWChar.

C++
#define NWCharParseChars(arValue, valueLength, szFormat, pValue) NWCharParseStrOrChars(arValue, valueLength, szFormat, pValue)
Collapse Expand Parameters
Parameters | Description
arValue | [in] A pointer to NChar array.
valueLength | [in] Length of the array.
szFormat | [in] Pointer to format string.
pValue | [out] A pointer to the converted NWChar.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NWCharParseStrOrChars Macro

NWCharParseStrOrChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NWCharParseStrOrChars function.

C++
#define NWCharParseStrOrChars N_FUNC_AW(NWCharParseStrOrChars)
Container

File: NTypes.h

Module: NTypes Unit


NWCharParseVN Macro

NWCharParseVN Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NWCharParseVN function.

C++
#define NWCharParseVN N_FUNC_AW(NWCharParseVN)
Container

File: NTypes.h

Module: NTypes Unit


NWCharToChars Macro

NWCharToChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NWCharToChars function.

C++
#define NWCharToChars N_FUNC_AW(NWCharToChars)
Container

File: NTypes.h

Module: NTypes Unit


NWCharToString Macro

NWCharToString Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NWCharToString function.

C++
#define NWCharToString N_FUNC_AW(NWCharToString)
Container

File: NTypes.h

Module: NTypes Unit


NWCharTryParse Macro

NWCharTryParse Macro
NTypes.h

Converts NString to NWChar. A NBool value indicates whether the conversion succeeded.

C++
#define NWCharTryParse(szValue, szFormat, pValue, pResult) NWCharTryParseStrOrChars(szValue, -1, szFormat, pValue, pResult)
Collapse Expand Parameters
Parameters | Description
arValue | [in] A pointer to NChar array.
valueLength | [in] Length of the array.
szFormat | [in] Pointer to format string.
pValue | [out] A pointer to the converted NWChar.
pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NWCharTryParseChars Macro

NWCharTryParseChars Macro
NTypes.h

Converts an array of NChars to NWChar. A NBool value indicates whether the conversion succeeded.

C++
#define NWCharTryParseChars(arValue, valueLength, szFormat, pValue, pResult) NWCharTryParseStrOrChars(arValue, valueLength, szFormat, pValue, pResult)
Collapse Expand Parameters
Parameters | Description
arValue | [in] A pointer to NChar array.
valueLength | [in] Length of the array.
szFormat | [in] Pointer to format string.
pValue | [out] A pointer to the converted NWChar.
pResult | [out] NTrue if the conversion succeeded; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTypes.h

Module: NTypes Unit


NWCharTryParseStrOrChars Macro

NWCharTryParseStrOrChars Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NWCharTryParseStrOrChars function.

C++
#define NWCharTryParseStrOrChars N_FUNC_AW(NWCharTryParseStrOrChars)
Container

File: NTypes.h

Module: NTypes Unit


NWCharTryParseVN Macro

NWCharTryParseVN Macro
NTypes.h

Picks a Unicode (W) or ASCII (A) version of the NWCharTryParseVN function.

C++
#define NWCharTryParseVN N_FUNC_AW(NWCharTryParseVN)
Container

File: NTypes.h

Module: NTypes Unit


N_BOOLEAN_FALSE_STRING Macro

N_BOOLEAN_FALSE_STRING Macro
NTypes.h

ANSI or Unicode (if N_UNICODE is defined) string, representing NFalse Boolean value.

C++
#define N_BOOLEAN_FALSE_STRING N_MACRO_AW(N_BOOLEAN_FALSE_STRING)
Container

File: NTypes.h

Module: NTypes Unit


N_BOOLEAN_FALSE_STRINGA Macro

N_BOOLEAN_FALSE_STRINGA Macro
NTypes.h

ANSI string, representing NFalse Boolean value.

C++
#define N_BOOLEAN_FALSE_STRINGA "False"
Container

File: NTypes.h

Module: NTypes Unit


N_BOOLEAN_FALSE_STRINGW Macro

N_BOOLEAN_FALSE_STRINGW Macro
NTypes.h

Unicode (if N_UNICODE is defined) string, representing NFalse Boolean value.

C++
#define N_BOOLEAN_FALSE_STRINGW L"False"
Container

File: NTypes.h

Module: NTypes Unit


N_BOOLEAN_TRUE_STRING Macro

N_BOOLEAN_TRUE_STRING Macro
NTypes.h

ANSI or Unicode (if N_UNICODE is defined) string, representing NTrue Boolean value.

C++
#define N_BOOLEAN_TRUE_STRING N_MACRO_AW(N_BOOLEAN_TRUE_STRING)
Container

File: NTypes.h

Module: NTypes Unit


N_BOOLEAN_TRUE_STRINGA Macro

N_BOOLEAN_TRUE_STRINGA Macro
NTypes.h

ANSI string, representing NTrue Boolean value.

C++
#define N_BOOLEAN_TRUE_STRINGA "True"
Container

File: NTypes.h

Module: NTypes Unit


N_BOOLEAN_TRUE_STRINGW Macro

N_BOOLEAN_TRUE_STRINGW Macro
NTypes.h

Unicode (if N_UNICODE is defined) string, representing NTrue Boolean value.

C++
#define N_BOOLEAN_TRUE_STRINGW L"True"
Container

File: NTypes.h

Module: NTypes Unit


N_BYTE_MAX Macro

N_BYTE_MAX Macro
NTypes.h

Maximum value for NByte.

C++
#define N_BYTE_MAX N_UINT8_MAX
Container

File: NTypes.h

Module: NTypes Unit


N_BYTE_MIN Macro

N_BYTE_MIN Macro
NTypes.h

Minimum value for NByte.

C++
#define N_BYTE_MIN N_UINT8_MIN
Container

File: NTypes.h

Module: NTypes Unit


N_DECLARE_HANDLE_TYPE Macro

N_DECLARE_HANDLE_TYPE Macro
NTypes.h

Declares handle type with specified name.

C++
#define N_DECLARE_HANDLE_TYPE(name) \
    N_DECLARE_HANDLE(H##name)\
    N_DECLARE_TYPE(name)
Container

File: NTypes.h

Module: NTypes Unit


N_DECLARE_OBJECT_TYPE Macro

N_DECLARE_OBJECT_TYPE Macro
NTypes.h

Declares object type with specified name.

C++
#define N_DECLARE_OBJECT_TYPE(name, baseName) \
        typedef H##baseName H##name;\
        N_DECLARE_STATIC_OBJECT_TYPE(name)
Container

File: NTypes.h

Module: NTypes Unit


N_DECLARE_STATIC_OBJECT_TYPE Macro

N_DECLARE_STATIC_OBJECT_TYPE Macro
NTypes.h

Declares static object type with specified name.

C++
#define N_DECLARE_STATIC_OBJECT_TYPE(name) \
    N_DECLARE_TYPE(name)
Container

File: NTypes.h

Module: NTypes Unit


N_DECLARE_TYPE Macro

N_DECLARE_TYPE Macro
NTypes.h

Declares type with specified name.

C++
#define N_DECLARE_TYPE(name) \
    NResult N_API name##TypeOf(HNType * phValue);
Container

File: NTypes.h

Module: NTypes Unit


N_DECLATE_PRIMITIVE Macro

N_DECLATE_PRIMITIVE Macro
NTypes.h

Declares primitive with specified name.

C++
#define N_DECLATE_PRIMITIVE(name, size) typedef struct { union { void * ptr; /* for correct alignment */ NByte data[size]; } unused; } name;
Container

File: NTypes.h

Module: NTypes Unit


N_DOUBLE_EPSILON Macro

N_DOUBLE_EPSILON Macro
NTypes.h

Epsilon value for NDouble.

C++
#define N_DOUBLE_EPSILON 2.2204460492503131e-016
Container

File: NTypes.h

Module: NTypes Unit


N_DOUBLE_MAX Macro

N_DOUBLE_MAX Macro
NTypes.h

Maximum value for NDouble.

C++
#define N_DOUBLE_MAX 1.7976931348623158e+308
Container

File: NTypes.h

Module: NTypes Unit


N_DOUBLE_MIN Macro

N_DOUBLE_MIN Macro
NTypes.h

Minimum value for NDouble.

C++
#define N_DOUBLE_MIN -1.7976931348623158e+308
Container

File: NTypes.h

Module: NTypes Unit


N_FLOAT_EPSILON Macro

N_FLOAT_EPSILON Macro
NTypes.h

Epsilon value for NFloat.

C++
#define N_FLOAT_EPSILON N_SINGLE_EPSILON
Container

File: NTypes.h

Module: NTypes Unit


N_FLOAT_INFINITY_STRING Macro

N_FLOAT_INFINITY_STRING Macro
NTypes.h

ANSI or Unicode (if N_UNICODE is defined) string, representing "Infinity" floating-point value.

C++
#define N_FLOAT_INFINITY_STRING N_MACRO_AW(N_FLOAT_INFINITY_STRING)
Container

File: NTypes.h

Module: NTypes Unit


N_FLOAT_INFINITY_STRINGA Macro

N_FLOAT_INFINITY_STRINGA Macro
NTypes.h

ANSI string, representing "Infinity" floating-point value.

C++
#define N_FLOAT_INFINITY_STRINGA "Infinity"
Container

File: NTypes.h

Module: NTypes Unit


N_FLOAT_INFINITY_STRINGW Macro

N_FLOAT_INFINITY_STRINGW Macro
NTypes.h

Unicode (if N_UNICODE is defined) string, representing "Infinity" floating-point value.

C++
#define N_FLOAT_INFINITY_STRINGW L"Infinity"
Container

File: NTypes.h

Module: NTypes Unit


N_FLOAT_MAX Macro

N_FLOAT_MAX Macro
NTypes.h

Maximum value for NFloat.

C++
#define N_FLOAT_MAX N_SINGLE_MAX
Container

File: NTypes.h

Module: NTypes Unit


N_FLOAT_MIN Macro

N_FLOAT_MIN Macro
NTypes.h

Minimum value for NFloat.

C++
#define N_FLOAT_MIN N_SINGLE_MIN
Container

File: NTypes.h

Module: NTypes Unit


N_FLOAT_NAN_STRING Macro

N_FLOAT_NAN_STRING Macro
NTypes.h

ANSI or Unicode (if N_UNICODE is defined) string, representing "NaN" floating-point value.

C++
#define N_FLOAT_NAN_STRING N_MACRO_AW(N_FLOAT_NAN_STRING)
Container

File: NTypes.h

Module: NTypes Unit


N_FLOAT_NAN_STRINGA Macro

N_FLOAT_NAN_STRINGA Macro
NTypes.h

ANSI string, representing "NaN" floating-point value.

C++
#define N_FLOAT_NAN_STRINGA "NaN"
Container

File: NTypes.h

Module: NTypes Unit


N_FLOAT_NAN_STRINGW Macro

N_FLOAT_NAN_STRINGW Macro
NTypes.h

Unicode (if N_UNICODE is defined) string, representing "NaN" floating-point value.

C++
#define N_FLOAT_NAN_STRINGW L"NaN"
Container

File: NTypes.h

Module: NTypes Unit


N_INT16_MAX Macro

N_INT16_MAX Macro
NTypes.h

Maximum value for NShort.

C++
#define N_INT16_MAX ((NInt16)0x7FFF)
Container

File: NTypes.h

Module: NTypes Unit


N_INT16_MIN Macro

N_INT16_MIN Macro
NTypes.h

Minimum value for NShort.

C++
#define N_INT16_MIN ((NInt16)0x8000)
Container

File: NTypes.h

Module: NTypes Unit


N_INT32_MAX Macro

N_INT32_MAX Macro
NTypes.h

Maximum value for NInt.

C++
#define N_INT32_MAX 0x7FFFFFFF
Container

File: NTypes.h

Module: NTypes Unit


N_INT32_MIN Macro

N_INT32_MIN Macro
NTypes.h

Minimum value for NInt.

C++
#define N_INT32_MIN ((NInt32)0x80000000)
Container

File: NTypes.h

Module: NTypes Unit


N_INT64_MAX Macro

N_INT64_MAX Macro
NTypes.h

Maximum value for NInt64.

C++
#define N_INT64_MAX 0x7FFFFFFFFFFFFFFFll
Container

File: NTypes.h

Module: NTypes Unit


N_INT64_MIN Macro

N_INT64_MIN Macro
NTypes.h

Minimum value for NInt64.

C++
#define N_INT64_MIN ((NInt64)0x8000000000000000ull)
Container

File: NTypes.h

Module: NTypes Unit


N_INT8_MAX Macro

N_INT8_MAX Macro
NTypes.h

Maximum value for NSByte.

C++
#define N_INT8_MAX ((NInt8)0x7F)
Container

File: NTypes.h

Module: NTypes Unit


N_INT8_MIN Macro

N_INT8_MIN Macro
NTypes.h

Minimum value for NSByte.

C++
#define N_INT8_MIN ((NInt8)0x80)
Container

File: NTypes.h

Module: NTypes Unit


N_INT_MAX Macro

N_INT_MAX Macro
NTypes.h

Maximum value for NInt.

C++
#define N_INT_MAX N_INT32_MAX
Container

File: NTypes.h

Module: NTypes Unit


N_INT_MIN Macro

N_INT_MIN Macro
NTypes.h

Minimum value for NInt.

C++
#define N_INT_MIN N_INT32_MIN
Container

File: NTypes.h

Module: NTypes Unit


N_LONG_MAX Macro

N_LONG_MAX Macro
NTypes.h

Maximum value for NLong.

C++
#define N_LONG_MAX N_INT64_MAX
Container

File: NTypes.h

Module: NTypes Unit


N_LONG_MIN Macro

N_LONG_MIN Macro
NTypes.h

Minimum value for NLong.

C++
#define N_LONG_MIN N_INT64_MIN
Container

File: NTypes.h

Module: NTypes Unit


N_PTR_SIZE Macro

N_PTR_SIZE Macro
NTypes.h

Defines pointer size.

C++
#define N_PTR_SIZE sizeof(void *)
Container

File: NTypes.h

Module: NTypes Unit


N_SBYTE_MAX Macro

N_SBYTE_MAX Macro
NTypes.h

Maximum value for NSByte.

C++
#define N_SBYTE_MAX N_INT8_MAX
Container

File: NTypes.h

Module: NTypes Unit


N_SBYTE_MIN Macro

N_SBYTE_MIN Macro
NTypes.h

Minimum value for NSByte.

C++
#define N_SBYTE_MIN N_INT8_MIN
Container

File: NTypes.h

Module: NTypes Unit


N_SHORT_MAX Macro

N_SHORT_MAX Macro
NTypes.h

Maximum value for NShort.

C++
#define N_SHORT_MAX N_INT16_MAX
Container

File: NTypes.h

Module: NTypes Unit


N_SHORT_MIN Macro

N_SHORT_MIN Macro
NTypes.h

Minimum value for NShort.

C++
#define N_SHORT_MIN N_INT16_MIN
Container

File: NTypes.h

Module: NTypes Unit


N_SINGLE_EPSILON Macro

N_SINGLE_EPSILON Macro
NTypes.h

Epsilon value for NSingle.

C++
#define N_SINGLE_EPSILON 1.192092896e-07F
Container

File: NTypes.h

Module: NTypes Unit


N_SINGLE_MAX Macro

N_SINGLE_MAX Macro
NTypes.h

Maximum value for NSingle.

C++
#define N_SINGLE_MAX 3.402823466e+38F
Container

File: NTypes.h

Module: NTypes Unit


N_SINGLE_MIN Macro

N_SINGLE_MIN Macro
NTypes.h

Minimum value for NSingle.

C++
#define N_SINGLE_MIN -3.402823466e+38F
Container

File: NTypes.h

Module: NTypes Unit


N_SIZE_TYPE_MAX Macro

N_SIZE_TYPE_MAX Macro
NTypes.h

Maximum value for NSizeType.

C++
#define N_SIZE_TYPE_MAX N_UINT32_MAX
Container

File: NTypes.h

Module: NTypes Unit


N_SIZE_TYPE_MIN Macro

N_SIZE_TYPE_MIN Macro
NTypes.h

Minimum value for NSizeType.

C++
#define N_SIZE_TYPE_MIN N_UINT32_MIN
Container

File: NTypes.h

Module: NTypes Unit


N_SSIZE_TYPE_MAX Macro

N_SSIZE_TYPE_MAX Macro
NTypes.h

Maximum value for NSSizeType.

C++
#define N_SSIZE_TYPE_MAX N_INT32_MAX
Container

File: NTypes.h

Module: NTypes Unit


N_SSIZE_TYPE_MIN Macro

N_SSIZE_TYPE_MIN Macro
NTypes.h

Minimum value for NSSizeType.

C++
#define N_SSIZE_TYPE_MIN N_INT32_MIN
Container

File: NTypes.h

Module: NTypes Unit


N_TYPE_OF Macro

N_TYPE_OF Macro
NTypes.h

Used to obtain a pointer to the function that retrieves NType object for the specified type name.",

C++
#define N_TYPE_OF(name) N_JOIN_SYMBOLS(name, TypeOf)
Container

File: NTypes.h

Module: NTypes Unit


N_UINT16_MAX Macro

N_UINT16_MAX Macro
NTypes.h

Maximum value for NUShort.

C++
#define N_UINT16_MAX ((NUInt16)0xFFFFu)
Container

File: NTypes.h

Module: NTypes Unit


N_UINT16_MIN Macro

N_UINT16_MIN Macro
NTypes.h

Minimum value for NUShort.

C++
#define N_UINT16_MIN ((NUInt16)0x0000u)
Container

File: NTypes.h

Module: NTypes Unit


N_UINT32_MAX Macro

N_UINT32_MAX Macro
NTypes.h

Maximum value for NUInt.

C++
#define N_UINT32_MAX 0xFFFFFFFFu
Container

File: NTypes.h

Module: NTypes Unit


N_UINT32_MIN Macro

N_UINT32_MIN Macro
NTypes.h

Minimum value for NUInt.

C++
#define N_UINT32_MIN 0x00000000u
Container

File: NTypes.h

Module: NTypes Unit


N_UINT64_MAX Macro

N_UINT64_MAX Macro
NTypes.h

Maximum value for NULong.

C++
#define N_UINT64_MAX 0xFFFFFFFFFFFFFFFFull
Container

File: NTypes.h

Module: NTypes Unit


N_UINT64_MIN Macro

N_UINT64_MIN Macro
NTypes.h

Minimum value for NULong.

C++
#define N_UINT64_MIN 0x0000000000000000ull
Container

File: NTypes.h

Module: NTypes Unit


N_UINT8_MAX Macro

N_UINT8_MAX Macro
NTypes.h

Maximum value for NUInt8.

C++
#define N_UINT8_MAX ((NUInt8)0xFFu)
Container

File: NTypes.h

Module: NTypes Unit


N_UINT8_MIN Macro

N_UINT8_MIN Macro
NTypes.h

Minimum value for NUInt8.

C++
#define N_UINT8_MIN ((NUInt8)0x00u)
Container

File: NTypes.h

Module: NTypes Unit


N_UINT_MAX Macro

N_UINT_MAX Macro
NTypes.h

Maximum value for NUInt.

C++
#define N_UINT_MAX N_UINT32_MAX
Container

File: NTypes.h

Module: NTypes Unit


N_UINT_MIN Macro

N_UINT_MIN Macro
NTypes.h

Minimum value for NUInt.

C++
#define N_UINT_MIN N_UINT32_MIN
Container

File: NTypes.h

Module: NTypes Unit


N_ULONG_MAX Macro

N_ULONG_MAX Macro
NTypes.h

Maximum value for NULong.

C++
#define N_ULONG_MAX N_UINT64_MAX
Container

File: NTypes.h

Module: NTypes Unit


N_ULONG_MIN Macro

N_ULONG_MIN Macro
NTypes.h

Minimum value for NULong.

C++
#define N_ULONG_MIN N_UINT64_MIN
Container

File: NTypes.h

Module: NTypes Unit


N_UNREFERENCED_PARAMETER Macro

N_UNREFERENCED_PARAMETER Macro
NTypes.h

Suppresses the warning "unreferenced parameter".

C++
#define N_UNREFERENCED_PARAMETER(parameter) (void)(parameter)
Container

File: NTypes.h

Module: NTypes Unit


N_UNUSED_VARIABLE Macro

N_UNUSED_VARIABLE Macro
NTypes.h

Suppresses the warning "unused variable".

C++
#define N_UNUSED_VARIABLE(variable) N_UNREFERENCED_PARAMETER(variable)
Container

File: NTypes.h

Module: NTypes Unit


N_USHORT_MAX Macro

N_USHORT_MAX Macro
NTypes.h

Maximum value for NUShort.

C++
#define N_USHORT_MAX N_UINT16_MAX
Container

File: NTypes.h

Module: NTypes Unit


N_USHORT_MIN Macro

N_USHORT_MIN Macro
NTypes.h

Minimum value for NUShort.

C++
#define N_USHORT_MIN N_UINT16_MIN
Container

File: NTypes.h

Module: NTypes Unit


N_WCHAR_SIZE Macro

N_WCHAR_SIZE Macro
NTypes.h

Defines the size of Unicode char.

C++
#define N_WCHAR_SIZE 4
Container

File: NTypes.h

Module: NTypes Unit


NTypes.h

NTypes.h
Enumerations Functions Legend Macros Structures Types

Header file for NTypes module. Defines types and macros used in Neurotechnology components.

Collapse Expand Enumerations
Name | Description
NAttributes_ | Enumerates value attributes.
NOSFamily_ | Enumerates OS families.
NAttributes | Enumerates value attributes.
NOSFamily | Enumerates OS families.
Collapse Expand Functions
Name | Description
NACharParseN | Converts a NString to NAChar.
NACharParseStrOrChars | Converts an array of NChars to NAChar.
NACharParseVN | Converts a NString to NAChar.
NACharToChars | Converts NAChar to an array of NAChars.
NACharToString | Converts NAChar to NString
NACharTryParseN | Converts NString to NAChar. A NBool value indicates whether the conversion succeeded.
NACharTryParseStrOrChars | Converts an array of NChars to NAChar. A NBool value indicates whether the conversion succeeded.
NACharTryParseVN | Converts NString to NAChar. A NBool value indicates whether the conversion succeeded.
NBooleanParseN | Converts NString to NBoolean.
NBooleanParseStrOrChars | Converts an array of NChars to NBoolean.
NBooleanParseVN | Converts NString to NBoolean.
NBooleanToChars | Converts NBoolean to an array of NChars.
NBooleanToString | Converts NBoolean to NString.
NBooleanTryParseN | Converts a NString to NBoolean. A NBool value indicates whether the conversion succeeded.
NBooleanTryParseStrOrChars | Converts an array of NStrings or NChars into NBoolean. A NBool value indicates whether the conversion succeeded.
NBooleanTryParseVN | Converts a NString to NBoolean. A NBool value indicates whether the conversion succeeded.
NCharFromBinDigit | Converts a binary digit to NChar.
NCharFromDigit | Converts a digit to NChar.
NCharFromHexDigit | Converts a hexadecimal digit to NChar.
NCharFromOctDigit | Converts an octal digit to NChar.
NCharIsAscii | Checks whether the specified char is ASCII.
NCharIsBinDigit | Checks whether the specified character is a binary digit.
NCharIsDigit | Checks whether the specified character is a digit.
NCharIsHexDigit | Checks whether the specified character is a hexadecimal digit.
NCharIsLetter | Checks whether the specified character is a letter.
NCharIsLower | Checks whether the specified character is a lower value.
NCharIsOctDigit | Checks whether the specified character is an octal digit.
NCharIsUpper | Checks whether the specified character is an upper value.
NCharIsWhiteSpace | Checks whether the specified character is a whitespace.
NCharParseN | Converts a NString to a NChar.
NCharParseStrOrChars | Converts an array of NStrings or NChars into NChar.
NCharParseVN | Converts a NString to a NChar.
NCharToBinDigit | Converts a NChar to a binary digit.
NCharToChars | Converts a NChar into an array of NChars.
NCharToDigit | Converts a NChar to a digit.
NCharToHexDigit | Converts a NChar to a hexadecimal digit.
NCharToLower | Converts a NChar to lowercase.
NCharToOctDigit | Converts a NChar to an octal digit.
NCharToString | Converts NChar to NString.
NCharToUpper | Converts NChar to uppercase.
NCharTryParseN | Converts a NString to a NChar. A NBool value indicates whether the conversion succeeded.
NCharTryParseStrOrChars | Converts an array of NChars into NChar. A NBool value indicates whether the conversion succeeded.
NCharTryParseVN | Converts a NString to a NChar. A NBool value indicates whether the conversion succeeded.
NComplexToString | Converts NComplex to NString.
NDoubleGetNaN | Retrieves a NDouble that is Not a Number (NaN).
NDoubleGetNegativeInfinity | Retrieves a NDouble that is NegativeInfinity.
NDoubleGetPositiveInfinity | Retrieves a NDouble that is PositiveInfinity.
NDoubleIsInfinity | Checks if NDouble evaluates to NegativeInfinity or PositiveInfinity.
NDoubleIsNaN | Checks if NDouble is Not a Number (NaN).
NDoubleIsNegativeInfinity | Checks if NDouble evaluates to NegativeInfinity.
NDoubleIsPositiveInfinity | Checks if NDouble evaluates to PositiveInfinity
NDoubleParseN | Converts a NString into NDouble.
NDoubleParseStrOrChars | Converted an array of NChars to NDouble.
NDoubleParseVN | Converts a NString into NDouble.
NDoubleToChars | Converts NDouble to an array of NChars.
NDoubleToString | Converts NDouble to NString.
NDoubleTryParseN | Converts a NString to NDouble. A NBool value indicates whether the conversion succeeded.
NDoubleTryParseStrOrChars | Converts an array of NChars to NDouble. A NBool value indicates whether the conversion succeeded.
NDoubleTryParseVN | Converts a NString to NDouble. A NBool value indicates whether the conversion succeeded.
NGuidParse | Converts a NChar to NGuid.
NGuidParseVN | Converts a NString to NGuid.
NGuidToString | Converts a NGuid to NString.
NGuidTryParse | Converts a NChar to NGuid. A NBool value indicates whether the conversion succeeded.
NGuidTryParseVN | Converts a NString to NGuid. A NBool value indicates whether the conversion succeeded.
NIndexPairToString | Convertes NIndexPair to NString.
NInt16ParseN | Convertes NString to NInt16.
NInt16ParseStrOrChars | Converts an array of NChars to NInt16.
NInt16ParseVN | Convertes NString to NInt16.
NInt16ToChars | Converts NInt16 to an array of NChars.
NInt16ToString | Converts NInt16 to NString.
NInt16TryParseN | Converts NString to NInt16. A NBool value indicates whether the conversion succeeded.
NInt16TryParseStrOrChars | Converts an array of NChars to NInt16. A NBool value indicates whether the conversion succeeded.
NInt16TryParseVN | Converts NString to NInt16. A NBool value indicates whether the conversion succeeded.
NInt32ParseN | Converts NString to NInt32.
NInt32ParseStrOrChars | Converts an array of NChars to NInt32.
NInt32ParseVN | Converts NString to NInt32.
NInt32ToChars | Converts NInt32 to an array of NChars.
NInt32ToString | Converts NInt32 to NString.
NInt32TryParseN | Converts NString to NInt32. A NBool value indicates whether the conversion succeeded.
NInt32TryParseStrOrChars | Converts an array of NChars to NInt32. A NBool value indicates whether the conversion succeeded.
NInt32TryParseVN | Converts NString to NInt32. A NBool value indicates whether the conversion succeeded.
NInt64ParseN | Converts NString to NInt64.
NInt64ParseStrOrChars | Converts an array of NChars to NInt64.
NInt64ParseVN | Converts NString to NInt64.
NInt64ToChars | Converts NInt64 to an array of NChars.
NInt64ToString | Converts NInt64 to NString.
NInt64TryParseN | Converts NString to NInt64. A NBool value indicates whether the conversion succeeded.
NInt64TryParseStrOrChars | Converts an array of NChars to NInt64. A NBool value indicates whether the conversion succeeded.
NInt64TryParseVN | Converts NString to NInt64. A NBool value indicates whether the conversion succeeded.
NInt8ParseN | Converts NString to NInt8.
NInt8ParseStrOrChars | Converts an array of NChars to NInt8.
NInt8ParseVN | Converts NString to NInt8.
NInt8ToChars | Converts NInt8 to an array of NChars.
NInt8ToString | Converts NInt8 to NString.
NInt8TryParseN | Converts NString to NInt8. A NBool value indicates whether the conversion succeeded.
NInt8TryParseStrOrChars | Converts an array of NChars to NInt8. A NBool value indicates whether the conversion succeeded.
NInt8TryParseVN | Converts NString to NInt8. A NBool value indicates whether the conversion succeeded.
NNameStringPairCopy | Creates a copy of string pair structure.
NNameStringPairCreate | Creates a new string pair structure.
NNameStringPairDispose | Disposes of the specified string pair structure.
NNameStringPairSet | Sets the value of the specified string pair structure.
NOSFamilyGetCurrent | Retrieves the current operating system family.
NPointerParseN | Converts NString to NPointer.
NPointerParseStrOrChars | Converts an array of NChars to NPointer.
NPointerParseVN | Converts NString to NPointer.
NPointerToChars | Converts NPointer to an array of NChars.
NPointerToString | Converts NPointer to NString.
NPointerTryParseN | Converts NString to NPointer. A NBool value indicates whether the conversion succeeded.
NPointerTryParseStrOrChars | Converts an array of NChars to NPointer. A NBool value indicates whether the conversion succeeded.
NPointerTryParseVN | Converts NString to NPointer. A NBool value indicates whether the conversion succeeded.
NRangeToString | Converts NRange to NString.
NRationalToString | Converts NRational to NString.
NResultParseN | Converts NString to NResult.
NResultParseStrOrChars | Converts an array of NChars to NResult.
NResultParseVN | Converts NString to NResult.
NResultToChars | Converts NResult to an array of NChars.
NResultToString | Converts NResult to NString.
NResultTryParseN | Converts NString to NResult. A NBool value indicates whether the conversion succeeded.
NResultTryParseStrOrChars | Converts an array of NChars to NResult. A NBool value indicates whether the conversion succeeded.
NResultTryParseVN | Converts NString to NResult. A NBool value indicates whether the conversion succeeded.
NSSizeTypeParseN | Converts NString to NSSizeType.
NSSizeTypeParseStrOrChars | Converts an array of NChars to NSSizeType.
NSSizeTypeParseVN | Converts NString to NSSizeType.
NSSizeTypeToChars | Converts NSSizeType to an array of NChars.
NSSizeTypeToString | Converts NSSizeType to NString.
NSSizeTypeTryParseN | Converts NString to NSSizeType. A NBool value indicates whether the conversion succeeded.
NSSizeTypeTryParseStrOrChars | Converts an array of NChars to NSSizeType. A NBool value indicates whether the conversion succeeded.
NSSizeTypeTryParseVN | Converts NString to NSSizeType. A NBool value indicates whether the conversion succeeded.
NSingleGetNaN | Retrieves a NSingle that is Not a Number (NaN).
NSingleGetNegativeInfinity | Retrieves a NSingle that is NegativeInfinity.
NSingleGetPositiveInfinity | Retrieves a NSingle that is PositiveInfinity.
NSingleIsInfinity | Checks if NSingle evaluates to NegativeInfinity or PositiveInfinity.
NSingleIsNaN | Checks if NSingle Not a Number (NaN).
NSingleIsNegativeInfinity | Checks if NSingle evaluates to NegativeInfinity.
NSingleIsPositiveInfinity | Checks if NSingle evaluates to PositiveInfinity.
NSingleParseN | Converts NString to NSingle.
NSingleParseStrOrChars | Converts an array of NChars to NSingle.
NSingleParseVN | Converts NString to NSingle.
NSingleToChars | Converts NSingle to an array of NChars.
NSingleToString | Converts NSingle to NString.
NSingleTryParseN | Converts NString to NSingle. A NBool value indicates whether the conversion succeeded.
NSingleTryParseStrOrChars | Converts an array of NChars to NSingle. A NBool value indicates whether the conversion succeeded.
NSingleTryParseVN | Converts NString to NSingle. A NBool value indicates whether the conversion succeeded.
NSizeTypeParseN | Converts NString to NSizeType.
NSizeTypeParseStrOrChars | Converts an array of NChars to NSizeType.
NSizeTypeParseVN | Converts NString to NSizeType.
NSizeTypeToChars | Converts NSizeType to an array of NChars.
NSizeTypeToString | Converts NSizeType to NString.
NSizeTypeTryParseN | Converts NString to NSizeType. A NBool value indicates whether the conversion succeeded.
NSizeTypeTryParseStrOrChars | Converts an array of NChars to NSizeType. A NBool value indicates whether the conversion succeeded.
NSizeTypeTryParseVN | Converts NString to NSizeType. A NBool value indicates whether the conversion succeeded.
NSwapDWordArray | Swaps the element order of the specified array of unsigned integers from little Endian to big Endian, or vice-versa.
NSwapDouble | Swaps the byte order of the specified double value from little Endian to big Endian, or vice-versa.
NSwapDoubleArray | Swaps the element order of the specified array of single values from little Endian to big Endian, or vice-versa.
NSwapQWordArray | Swaps the element order of the specified array of unsigned long integers from little Endian to big Endian, or vice-versa.
NSwapSingle | Swaps the byte order of the specified single value from little Endian to big Endian, or vice-versa.
NSwapSingleArray | Swaps the element order of the specified array of single values from little Endian to big Endian, or vice-versa.
NSwapWordArray | Swaps the element order of the specified array of unsigned short integers from little Endian to big Endian, or vice-versa.
NTypesGetPointer | Retrieves a pointer to object.
NUInt16ParseN | Converts NString to NUInt16.
NUInt16ParseStrOrChars | Converts an array of NChars to NUInt16.
NUInt16ParseVN | Converts NString to NUInt16.
NUInt16ToChars | Converts NUInt16 to an array of NChars.
NUInt16ToString | Converts NUInt16 to NString.
NUInt16TryParseN | Converts NString to NUInt16. A NBool value indicates whether the conversion succeeded.
NUInt16TryParseStrOrChars | Converts an array of NChars to NUInt16. A NBool value indicates whether the conversion succeeded.
NUInt16TryParseVN | Converts NString to NUInt16. A NBool value indicates whether the conversion succeeded.
NUInt32ParseN | Converts NString to NUInt32.
NUInt32ParseStrOrChars | Converts an array of NChars to NUInt32.
NUInt32ParseVN | Converts NString to NUInt32.
NUInt32ToChars | Converts NUInt32 to an array of NChars.
NUInt32ToString | Converts NUInt32 to NString.
NUInt32TryParseN | Converts NString to NUInt32. A NBool value indicates whether the conversion succeeded.
NUInt32TryParseStrOrChars | Converts an array of NChars to NUInt32. A NBool value indicates whether the conversion succeeded.
NUInt32TryParseVN | Converts NString to NUInt32. A NBool value indicates whether the conversion succeeded.
NUInt64ParseN | Converts NString to NUInt64.
NUInt64ParseStrOrChars | Converts an array of NChars to NUInt64.
NUInt64ParseVN | Converts NString to NUInt64.
NUInt64ToChars | Converts NUInt64 to an array of NChars.
NUInt64ToString | Converts NUInt64 to NString.
NUInt64TryParseN | Converts NString to NUInt64. A NBool value indicates whether the conversion succeeded.
NUInt64TryParseStrOrChars | Converts an array of NChars to NUInt64. A NBool value indicates whether the conversion succeeded.
NUInt64TryParseVN | Converts NString to NUInt64. A NBool value indicates whether the conversion succeeded.
NUInt8ParseN | Converts NString to NUInt8.
NUInt8ParseStrOrChars | Converts an array of NChars to NUInt8.
NUInt8ParseVN | Converts NString to NUInt8.
NUInt8ToChars | Converts NUInt8 to an array of NChars.
NUInt8ToString | Converts NUInt8 to NString.
NUInt8TryParseN | Converts NString to NUInt8. A NBool value indicates whether the conversion succeeded.
NUInt8TryParseStrOrChars | Converts an array of NChars to NUInt8. A NBool value indicates whether the conversion succeeded.
NUInt8TryParseVN | Converts NString to NUInt8. A NBool value indicates whether the conversion succeeded.
NURationalToString | Converts NURational to NString.
NVersionRangeContains | Checks if NVersionRange contains a certain version.
NVersionRangeContainsRange | Checks if NVersionRange contains a certain version range.
NVersionRangeIntersect | Replaces NVersionRange with the intersection of itself and another NVersionRange.
NVersionRangeIntersectsWith | Returns third NVersionRange that represents the intersection of two other NVersionRanges. If there is no intersection, an empty NVersionRange is returned.
NVersionRangeToString | Converts NVersionRange to NString.
NVersionToString | Converts NVersion to NString.
NWCharParseN | Converts NString to NWChar.
NWCharParseStrOrChars | Converts an array of NChars to NWChar.
NWCharParseVN | Converts NString to NWChar.
NWCharToChars | Converts NWChar to an array of NChars.
NWCharToString | Converts NWChar to NString.
NWCharTryParseN | Converts NString to NWChar. A NBool value indicates whether the conversion succeeded.
NWCharTryParseStrOrChars | Converts an array of NChars to NWChar. A NBool value indicates whether the conversion succeeded.
NWCharTryParseVN | Converts NString to NWChar. A NBool value indicates whether the conversion succeeded.
Collapse Expand Macros
Name | Description
NACharParse | Converts a NString to NAChar.
NACharParseChars | Converts an array of NChars to NAChar.
NACharParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NACharParseStrOrChars function.
NACharParseVN | Picks a Unicode (W) or ASCII (A) version of the NACharParseVN function.
NACharToChars | Picks a Unicode (W) or ASCII (A) version of the NACharToChars function.
NACharToString | Picks a Unicode (W) or ASCII (A) version of the NACharToString function.
NACharTryParse | Converts NString to NAChar. A NBool value indicates whether the conversion succeeded.
NACharTryParseChars | Converts an array of NChars to NAChar. A NBool value indicates whether the conversion succeeded.
NACharTryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NACharTryParseStrOrChars function.
NACharTryParseVN | Picks a Unicode (W) or ASCII (A) version of the NACharTryParseVN function.
NBooleanParse | Converts NString to NBoolean.
NBooleanParseChars | Converts an array of NChars to NBoolean.
NBooleanParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NBooleanParseStrOrChars function.
NBooleanParseVN | Picks a Unicode (W) or ASCII (A) version of the NBooleanParseVN function.
NBooleanToChars | Picks a Unicode (W) or ASCII (A) version of the NBooleanToChars function.
NBooleanToString | Picks a Unicode (W) or ASCII (A) version of the NBooleanToString function.
NBooleanTryParse | Converts NString to NBoolean. A NBool value indicates whether the conversion succeeded.
NBooleanTryParseChars | Converts an array of NChars to NBoolean. A NBool value indicates whether the conversion succeeded.
NBooleanTryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NBooleanTryParseStrOrChars function.
NBooleanTryParseVN | Picks a Unicode (W) or ASCII (A) version of the NBooleanTryParseVN function.
NCharFromBinDigit | Picks a Unicode (W) or ASCII (A) version of the NCharFromBinDigit function.
NCharFromDigit | Picks a Unicode (W) or ASCII (A) version of the NCharFromDigit function.
NCharFromHexDigit | Picks a Unicode (W) or ASCII (A) version of the NCharFromHexDigit function.
NCharFromOctDigit | Picks a Unicode (W) or ASCII (A) version of the NCharFromOctDigit function.
NCharIsAscii | Picks a Unicode (W) or ASCII (A) version of the NCharIsAscii function.
NCharIsBinDigit | Picks a Unicode (W) or ASCII (A) version of the NCharIsBinDigit function.
NCharIsDigit | Picks a Unicode (W) or ASCII (A) version of the NCharIsDigit function.
NCharIsHexDigit | Picks a Unicode (W) or ASCII (A) version of the NCharIsHexDigit function.
NCharIsLetter | Picks a Unicode (W) or ASCII (A) version of the NCharIsLetter function.
NCharIsLower | Picks a Unicode (W) or ASCII (A) version of the NCharIsLower function.
NCharIsOctDigit | Picks a Unicode (W) or ASCII (A) version of the NCharIsOctDigit function.
NCharIsUpper | Picks a Unicode (W) or ASCII (A) version of the NCharIsUpper function.
NCharIsWhiteSpace | Picks a Unicode (W) or ASCII (A) version of the NCharIsWhiteSpace function.
NCharParse | Converts NString to NChar.
NCharParseChars | Converts an array of NChars to NBoolean.
NCharToBinDigit | Picks a Unicode (W) or ASCII (A) version of the NCharToBinDigit function.
NCharToDigit | Picks a Unicode (W) or ASCII (A) version of the NCharToDigit function.
NCharToHexDigit | Picks a Unicode (W) or ASCII (A) version of the NCharToHexDigit function.
NCharToLower | Picks a Unicode (W) or ASCII (A) version of the NCharToLower function.
NCharToOctDigit | Picks a Unicode (W) or ASCII (A) version of the NCharToOctDigit function.
NCharToUpper | Picks a Unicode (W) or ASCII (A) version of the NCharToUpper function.
NCharTryParse | Converts NString to NChar. A NBool value indicates whether the conversion succeeded.
NCharTryParseChars | Converts an array of NChars to NChar. A NBool value indicates whether the conversion succeeded.
NDoubleParse | Converts NString to NDouble.
NDoubleParseChars | Converts an array of NChars to NChar.
NDoubleParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NDoubleParseStrOrChars function.
NDoubleParseVN | Picks a Unicode (W) or ASCII (A) version of the NDoubleParseVN function.
NDoubleToChars | Picks a Unicode (W) or ASCII (A) version of the NDoubleToChars function.
NDoubleToString | Picks a Unicode (W) or ASCII (A) version of the NDoubleToString function.
NDoubleTryParse | Converts NString to NDouble. A NBool value indicates whether the conversion succeeded.
NDoubleTryParseChars | Converts an array of NChars to NDouble. A NBool value indicates whether the conversion succeeded.
NDoubleTryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NDoubleTryParseStrOrChars function.
NDoubleTryParseVN | Picks a Unicode (W) or ASCII (A) version of the NDoubleTryParseVN function.
NFalse | False value for NBoolean.
NGuidParse | Picks a Unicode (W) or ASCII (A) version of the NGuidParse function.
NGuidParseVN | Picks a Unicode (W) or ASCII (A) version of the NGuidParseVN function.
NGuidToString | Picks a Unicode (W) or ASCII (A) version of the NGuidToString function.
NGuidTryParse | Picks a Unicode (W) or ASCII (A) version of the NGuidTryParse function.
NGuidTryParseVN | Picks a Unicode (W) or ASCII (A) version of the NGuidTryParseVN function.
NIndexPairToString | Picks a Unicode (W) or ASCII (A) version of the NIndexPairToString function.
NInt16Parse | Converts NString to NInt16.
NInt16ParseChars | Converts an array of NChars to NInt16.
NInt16ParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NInt16ParseStrOrChars function.
NInt16ParseVN | Picks a Unicode (W) or ASCII (A) version of the NInt16ParseVN function.
NInt16ToChars | Picks a Unicode (W) or ASCII (A) version of the NInt16ToChars function.
NInt16ToString | Picks a Unicode (W) or ASCII (A) version of the NInt16ToString function.
NInt16TryParse | Converts NString to NInt16. A NBool value indicates whether the conversion succeeded.
NInt16TryParseChars | Converts an array of NChars to NInt16. A NBool value indicates whether the conversion succeeded.
NInt16TryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NInt16TryParseStrOrChars function.
NInt16TryParseVN | Picks a Unicode (W) or ASCII (A) version of the NInt16TryParseVN function.
NInt32Parse | Converts NString to NInt32.
NInt32ParseChars | Converts an array of NChars to NInt32.
NInt32ParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NInt32ParseStrOrChars function.
NInt32ParseVN | Picks a Unicode (W) or ASCII (A) version of the NInt32ParseVN function.
NInt32ToChars | Picks a Unicode (W) or ASCII (A) version of the NInt32ToChars function.
NInt32ToString | Picks a Unicode (W) or ASCII (A) version of the NInt32ToString function.
NInt32TryParse | Converts NString to NInt32. A NBool value indicates whether the conversion succeeded.
NInt32TryParseChars | Converts an array of NChars to NInt32. A NBool value indicates whether the conversion succeeded.
NInt32TryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NInt32TryParseStrOrChars function.
NInt32TryParseVN | Picks a Unicode (W) or ASCII (A) version of the NInt32tryParseVN function.
NInt64Parse | Converts NString to NInt64.
NInt64ParseChars | Converts an array of NChars to NInt64.
NInt64ParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NInt64ParseStrOrChars function.
NInt64ParseVN | Picks a Unicode (W) or ASCII (A) version of the NInt64ParseVN function.
NInt64ToChars | Picks a Unicode (W) or ASCII (A) version of the NInt64ToChars function.
NInt64ToString | Picks a Unicode (W) or ASCII (A) version of the NInt64ToString function.
NInt64TryParse | Converts NString to NInt64. A NBool value indicates whether the conversion succeeded.
NInt64TryParseChars | Converts an array of NChars to NInt64. A NBool value indicates whether the conversion succeeded.
NInt64TryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NInt64TryParseStrOrChars function.
NInt64TryParseVN | Picks a Unicode (W) or ASCII (A) version of the NInt64TryParseVN function.
NInt8Parse | Converts NString to NInt8.
NInt8ParseChars | Converts an array of NChars to NInt8.
NInt8ParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NInt8ParseStrOrChars function.
NInt8ParseVN | Picks a Unicode (W) or ASCII (A) version of the NInt8ParseVN function.
NInt8ToChars | Picks a Unicode (W) or ASCII (A) version of the NInt8ToChars function.
NInt8ToString | Picks a Unicode (W) or ASCII (A) version of the NInt8ToString function.
NInt8TryParse | Converts NString to NInt8. A NBool value indicates whether the conversion succeeded.
NInt8TryParseChars | Converts an array of NChars to NInt8. A NBool value indicates whether the conversion succeeded.
NInt8TryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NInt8TryParseStrOrChars function.
NInt8TryParseVN | Picks a Unicode (W) or ASCII (A) version of the NInt8TryParseVN function.
NPointerParse | Converts NString to NPointer.
NPointerParseChars | Converts an array of NChars to NPointer.
NPointerParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NPointerParseStrOrChars function.
NPointerParseVN | Picks a Unicode (W) or ASCII (A) version of the NPointerParseVN function.
NPointerToChars | Picks a Unicode (W) or ASCII (A) version of the NPointerToChars function.
NPointerToString | Picks a Unicode (W) or ASCII (A) version of the NPointerToString function.
NPointerTryParse | Converts NString to NInt8. A NBool value indicates whether the conversion succeeded.
NPointerTryParseChars | Converts an array of NChars to NPointer. A NBool value indicates whether the conversion succeeded.
NPointerTryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NPointerTryParseStrOrChars function.
NPointerTryParseVN | Picks a Unicode (W) or ASCII (A) version of the NPointerTryParseVN function.
NRangeToString | Picks a Unicode (W) or ASCII (A) version of the NRangeToString function.
NRationalToString | Picks a Unicode (W) or ASCII (A) version of the NRationalToString function.
NResultParseVN | Picks a Unicode (W) or ASCII (A) version of the NResultParseVN function.
NResultToChars | Picks a Unicode (W) or ASCII (A) version of the NResultToChars function.
NResultToString | Picks a Unicode (W) or ASCII (A) version of the ResultToString function.
NResultTryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NResultTryParseStrOrChars function.
NResultTryParseVN | Picks a Unicode (W) or ASCII (A) version of the NResultTryParseVN function.
NSSizeTypeParse | Converts NString to NSSizeType.
NSSizeTypeParseChars | Converts an array of NChars to NSSizeType.
NSSizeTypeParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NSSizeTypeParseStrOrChars function.
NSSizeTypeParseVN | Picks a Unicode (W) or ASCII (A) version of the NSSizeTypeParseVN function.
NSSizeTypeToChars | Picks a Unicode (W) or ASCII (A) version of the NSSizeTypeToChars function.
NSSizeTypeToString | Picks a Unicode (W) or ASCII (A) version of the NSSizeTypeToString function.
NSSizeTypeTryParse | Converts NString to NSSizeType. A NBool value indicates whether the conversion succeeded.
NSSizeTypeTryParseChars | Converts an array of NChars to NSSizeType. A NBool value indicates whether the conversion succeeded.
NSSizeTypeTryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NSSizeTypeTryParseStrOrChars function.
NSSizeTypeTryParseVN | Picks a Unicode (W) or ASCII (A) version of the NSSizeTypeTryParseVN function.
NSingleParse | Converts NString to NSingle.
NSingleParseChars | Converts an array of NChars to NSingle.
NSingleParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NSingleParseStrOrChars function.
NSingleParseVN | Picks a Unicode (W) or ASCII (A) version of the NSingleParseVN function.
NSingleToChars | Picks a Unicode (W) or ASCII (A) version of the NSingleToChars function.
NSingleToString | Picks a Unicode (W) or ASCII (A) version of the NSingleToString function.
NSingleTryParse | Converts NString to NSingle. A NBool value indicates whether the conversion succeeded.
NSingleTryParseChars | Converts an array of NChars to NSingle. A NBool value indicates whether the conversion succeeded.
NSingleTryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NSingleTryParseStrOrChars function.
NSingleTryParseVN | Picks a Unicode (W) or ASCII (A) version of the NSingleTryParseVN function.
NSizeTypeParse | Converts NString to NSizeType.
NSizeTypeParseChars | Converts an array of NChars to NSizeType.
NSizeTypeParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NSizeTypeParseStrOrChars function.
NSizeTypeParseVN | Picks a Unicode (W) or ASCII (A) version of the NSizeTypeParseVN function.
NSizeTypeToChars | Picks a Unicode (W) or ASCII (A) version of the NSizeTypeToChars function.
NSizeTypeToString | Picks a Unicode (W) or ASCII (A) version of the NSizeTypeToString function.
NSizeTypeTryParse | Converts NString to NSizeType. A NBool value indicates whether the conversion succeeded.
NSizeTypeTryParseChars | Converts an array of NChars to NSizeType. A NBool value indicates whether the conversion succeeded.
NSizeTypeTryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NSizeTypeTryParseStrOrChars function.
NSizeTypeTryParseVN | Picks a Unicode (W) or ASCII (A) version of the NSizeTypeTryParseVN function.
NTrue | True value for NBoolean.
NUInt16Parse | Converts NString to NUInt16.
NUInt16ParseChars | Converts an array of NChars to NUInt16.
NUInt16ParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NUInt16ParseStrOrChars function.
NUInt16ParseVN | Picks a Unicode (W) or ASCII (A) version of the NUInt16ParseVN function.
NUInt16ToChars | Picks a Unicode (W) or ASCII (A) version of the NUInt16ToChars function.
NUInt16ToString | Picks a Unicode (W) or ASCII (A) version of the NUInt16ParseToString function.
NUInt16TryParse | Converts NString to NUInt16. A NBool value indicates whether the conversion succeeded.
NUInt16TryParseChars | Converts an array of NChars to NUInt16. A NBool value indicates whether the conversion succeeded.
NUInt16TryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NUInt16TryParseStrOrChars function.
NUInt16TryParseVN | Picks a Unicode (W) or ASCII (A) version of the NUInt16TryParseVN function.
NUInt32Parse | Converts NString to NUInt32.
NUInt32ParseChars | Converts an array of NChars to NUInt32.
NUInt32ParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NUInt32ParseStrOrChars function.
NUInt32ParseVN | Picks a Unicode (W) or ASCII (A) version of the NUInt32ParseVN function.
NUInt32ToChars | Picks a Unicode (W) or ASCII (A) version of the NUInt32ToChars function.
NUInt32ToString | Picks a Unicode (W) or ASCII (A) version of the NUInt32ToString function.
NUInt32TryParse | Converts NString to NUInt32. A NBool value indicates whether the conversion succeeded.
NUInt32TryParseChars | Converts an array of NChars to NUInt32. A NBool value indicates whether the conversion succeeded.
NUInt32TryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NUInt32TryParseStrOrChars function.
NUInt32TryParseVN | Picks a Unicode (W) or ASCII (A) version of the NUInt32TryParseVN function.
NUInt64Parse | Converts NString to NUInt64.
NUInt64ParseChars | Converts an array of NChars to NUInt64.
NUInt64ParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NUInt64ParseStrOrChars function.
NUInt64ParseVN | Picks a Unicode (W) or ASCII (A) version of the NUInt64ParseVN function.
NUInt64ToChars | Picks a Unicode (W) or ASCII (A) version of the NUInt64ToChars function.
NUInt64ToString | Picks a Unicode (W) or ASCII (A) version of the NUInt64ToString function.
NUInt64TryParse | Converts NString to NUInt64. A NBool value indicates whether the conversion succeeded.
NUInt64TryParseChars | Converts an array of NChars to NUInt64. A NBool value indicates whether the conversion succeeded.
NUInt64TryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NUInt64TryParseStrOrChars function.
NUInt64TryParseVN | Picks a Unicode (W) or ASCII (A) version of the NUInt64TryParseVN function.
NUInt8Parse | Converts NString to NUInt8.
NUInt8ParseChars | Converts an array of NChars to NUInt8.
NUInt8ParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NUInt8ParseStrOrChars function.
NUInt8ParseVN | Picks a Unicode (W) or ASCII (A) version of the NUInt8ParseVN function.
NUInt8ToChars | Picks a Unicode (W) or ASCII (A) version of the NUInt8ToChars function.
NUInt8ToString | Picks a Unicode (W) or ASCII (A) version of the NUInt8ToString function.
NUInt8TryParse | Converts NString to NUInt8. A NBool value indicates whether the conversion succeeded.
NUInt8TryParseChars | Converts an array of NChars to NUInt8. A NBool value indicates whether the conversion succeeded.
NUInt8TryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NUInt8TryParseStrOrChars function.
NUInt8TryParseVN | Picks a Unicode (W) or ASCII (A) version of the NUInt8TryParseVN function.
NULL | Null value for pointer.
NURationalToString | Picks a Unicode (W) or ASCII (A) version of the NURationalToString function.
NVersionRangeToString | Picks a Unicode (W) or ASCII (A) version of the NVersionRangeToString function.
NVersionToString | Picks a Unicode (W) or ASCII (A) version of the NVersionToString function.
NWCharParse | Converts NString to NWChar.
NWCharParseChars | Converts an array of NChars to NWChar.
NWCharParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NWCharParseStrOrChars function.
NWCharParseVN | Picks a Unicode (W) or ASCII (A) version of the NWCharParseVN function.
NWCharToChars | Picks a Unicode (W) or ASCII (A) version of the NWCharToChars function.
NWCharToString | Picks a Unicode (W) or ASCII (A) version of the NWCharToString function.
NWCharTryParse | Converts NString to NWChar. A NBool value indicates whether the conversion succeeded.
NWCharTryParseChars | Converts an array of NChars to NWChar. A NBool value indicates whether the conversion succeeded.
NWCharTryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NWCharTryParseStrOrChars function.
NWCharTryParseVN | Picks a Unicode (W) or ASCII (A) version of the NWCharTryParseVN function.
N_BOOLEAN_FALSE_STRING | ANSI or Unicode (if N_UNICODE is defined) string, representing NFalse Boolean value.
N_BOOLEAN_FALSE_STRINGA | ANSI string, representing NFalse Boolean value.
N_BOOLEAN_FALSE_STRINGW | Unicode (if N_UNICODE is defined) string, representing NFalse Boolean value.
N_BOOLEAN_TRUE_STRING | ANSI or Unicode (if N_UNICODE is defined) string, representing NTrue Boolean value.
N_BOOLEAN_TRUE_STRINGA | ANSI string, representing NTrue Boolean value.
N_BOOLEAN_TRUE_STRINGW | Unicode (if N_UNICODE is defined) string, representing NTrue Boolean value.
N_BYTE_MAX | Maximum value for NByte.
N_BYTE_MIN | Minimum value for NByte.
N_DECLARE_HANDLE | Declares handle with specified name.
N_DECLARE_HANDLE_TYPE | Declares handle type with specified name.
N_DECLARE_OBJECT_TYPE | Declares object type with specified name.
N_DECLARE_STATIC_OBJECT_TYPE | Declares static object type with specified name.
N_DECLARE_TYPE | Declares type with specified name.
N_DECLATE_PRIMITIVE | Declares primitive with specified name.
N_DOUBLE_EPSILON | Epsilon value for NDouble.
N_DOUBLE_MAX | Maximum value for NDouble.
N_DOUBLE_MIN | Minimum value for NDouble.
N_FLOAT_EPSILON | Epsilon value for NFloat.
N_FLOAT_INFINITY_STRING | ANSI or Unicode (if N_UNICODE is defined) string, representing "Infinity" floating-point value.
N_FLOAT_INFINITY_STRINGA | ANSI string, representing "Infinity" floating-point value.
N_FLOAT_INFINITY_STRINGW | Unicode (if N_UNICODE is defined) string, representing "Infinity" floating-point value.
N_FLOAT_MAX | Maximum value for NFloat.
N_FLOAT_MIN | Minimum value for NFloat.
N_FLOAT_NAN_STRING | ANSI or Unicode (if N_UNICODE is defined) string, representing "NaN" floating-point value.
N_FLOAT_NAN_STRINGA | ANSI string, representing "NaN" floating-point value.
N_FLOAT_NAN_STRINGW | Unicode (if N_UNICODE is defined) string, representing "NaN" floating-point value.
N_INT16_MAX | Maximum value for NShort.
N_INT16_MIN | Minimum value for NShort.
N_INT32_MAX | Maximum value for NInt.
N_INT32_MIN | Minimum value for NInt.
N_INT64_MAX | Maximum value for NInt64.
N_INT64_MIN | Minimum value for NInt64.
N_INT8_MAX | Maximum value for NSByte.
N_INT8_MIN | Minimum value for NSByte.
N_INT_MAX | Maximum value for NInt.
N_INT_MIN | Minimum value for NInt.
N_LONG_MAX | Maximum value for NLong.
N_LONG_MIN | Minimum value for NLong.
N_PTR_SIZE | Defines pointer size.
N_SBYTE_MAX | Maximum value for NSByte.
N_SBYTE_MIN | Minimum value for NSByte.
N_SHORT_MAX | Maximum value for NShort.
N_SHORT_MIN | Minimum value for NShort.
N_SINGLE_EPSILON | Epsilon value for NSingle.
N_SINGLE_MAX | Maximum value for NSingle.
N_SINGLE_MIN | Minimum value for NSingle.
N_SIZE_TYPE_MAX | Maximum value for NSizeType.
N_SIZE_TYPE_MIN | Minimum value for NSizeType.
N_SSIZE_TYPE_MAX | Maximum value for NSSizeType.
N_SSIZE_TYPE_MIN | Minimum value for NSSizeType.
N_TYPE_OF | Used to obtain a pointer to the function that retrieves NType object for the specified type name.",
N_UINT16_MAX | Maximum value for NUShort.
N_UINT16_MIN | Minimum value for NUShort.
N_UINT32_MAX | Maximum value for NUInt.
N_UINT32_MIN | Minimum value for NUInt.
N_UINT64_MAX | Maximum value for NULong.
N_UINT64_MIN | Minimum value for NULong.
N_UINT8_MAX | Maximum value for NUInt8.
N_UINT8_MIN | Minimum value for NUInt8.
N_UINT_MAX | Maximum value for NUInt.
N_UINT_MIN | Minimum value for NUInt.
N_ULONG_MAX | Maximum value for NULong.
N_ULONG_MIN | Minimum value for NULong.
N_UNREFERENCED_PARAMETER | Suppresses the warning "unreferenced parameter".
N_UNUSED_VARIABLE | Suppresses the warning "unused variable".
N_USHORT_MAX | Maximum value for NUShort.
N_USHORT_MIN | Minimum value for NUShort.
N_WCHAR_SIZE | Defines the size of Unicode char.
Collapse Expand Structures
Name | Description
NComplex_ | Represents a complex number value.
NIndexPair_ | Represents a pair of indexes.
NNameStringPair_ | Represents a pair of name strings.
NRational_ | Represents a signed rational number.
NURational_ | Represents an unsigned rational number.
Collapse Expand Types
Name | Description
NAChar | ANSI character (8-bit).
NBool | Same as NBoolean.
NBoolean | 32-bit boolean value. See also NTrue and NFalse.
NByte | Same as NUInt8.
NChar | ANSI character (8-bit). See also NAChar.
NComplex | Complex number.
NDouble | Double precision floating point number.
NFloat | Same as NSingle.
NHandle | Pointer to unspecified data (same as void *).
NIndexPair | Represents a pair of indexes.
NInt | Same as NInt32.
NInt16 | 16-bit signed integer (short).
NInt32 | 32-bit signed integer (int).
NInt64 | 64-bit signed integer (long). Not available on some 32-bit platforms.
NInt8 | 8-bit signed integer (signed byte).
NLong | Same as NInt64.
NNameStringPair | Two linked strings.
NRational | Represents a signed rational number.
NResult | Result of a function (same as NInt). See also NErrors module.
NSByte | Same as NInt8.
NSSizeType | Platform dependent size type. Signed 32-bit integer on 32-bit platform, signed 64-bit integer on 64-bit platform.
NShort | Same as NInt16.
NSingle | Single precision floating point number.
NSizeType | Platform dependent size type. Unsigned 32-bit integer on 32-bit platform, unsigned 64-bit integer on 64-bit platform.
NUInt | Same as NUInt32.
NUInt16 | 16-bit unsigned integer (unsigned short).
NUInt32 | 32-bit unsigned integer (unsigned int).
NUInt64 | 64-bit unsigned integer (unsigned long). Not available on some 32-bit platforms.
NUInt8 | 8-bit unsigned integer (byte).
NULong | Same as NUInt64.
NURational | Represents an unsigned rational number.
NUShort | Same as NUInt16.
NVersion | Two NInt32 values defining a version.
NVersionRange | Four NInt32 values defining a version range.
NVersionRange_ | A NUInt typedef defining a version range.
NVersion_ | A NUShort typedef defining a version.


NValue Unit

NValue Unit
Files Functions Legend Macros Structs, Records, Enums

Provides functionality for management and conversion of values of different types.

Collapse Expand Files
Name | Description
NValue.h | Header file for the NValue unit.
Collapse Expand Functions
Name | Description
NKeyValuePairCopy | Creates a copy of the specified key value pair structure.
NKeyValuePairCreate | Creates a new key value pair structure.
NKeyValuePairDispose | Disposes of the specified key value pair structure.
NKeyValuePairSet | Sets the value of the specified key value pair structure.
NNameValuePairCopy | Creates a copy of the specified name value pair structure.
NNameValuePairCreate | Creates a new name value pair structure.
NNameValuePairDispose | Disposes of the specified name value pair structure.
NNameValuePairSet | Sets the value of the specified name value pair structure.
NValueChangeType | Changes the type of the specified value to the new type.
NValueChangeTypeP | Changes the type of the specified value to the new type.
NValueCreate | Creates a new value of the specified type.
NValueCreateCustom | Creates a new value with specified callbacks.
NValueCreateCustomN | Creates a new value with specified callbacks.
NValueCreateFromBoolean | Creates a new value from the specified Boolean value.
NValueCreateFromByte | Creates a new value from the specified byte.
NValueCreateFromCallback | Creates a new value from specified callback.
NValueCreateFromChar | Creates a new value from the specified char.
NValueCreateFromDouble | Creates a new value from the specified double value.
NValueCreateFromInt16 | Creates a new value from the specified short integer.
NValueCreateFromInt32 | Creates a new value from the specified integer.
NValueCreateFromInt64 | Creates a new value from the specified long integer.
NValueCreateFromObject | Creates a new value from the specified object.
NValueCreateFromObjectP | Creates a new value from the specified object.
NValueCreateFromPointer | Creates a new value from the specified pointer.
NValueCreateFromResult | Creates a new value from the specified NResult value.
NValueCreateFromSByte | Creates a new value from the specified signed byte.
NValueCreateFromSSizeType | Creates a new value from the specified NSSizeType value.
NValueCreateFromSingle | Creates a new value from the specified floating point value.
NValueCreateFromSizeType | Creates a new value from the specified NSizeType value.
NValueCreateFromString | Creates a new value from the specified string.
NValueCreateFromUInt16 | Creates a new value from the specified unsigned short integer.
NValueCreateFromUInt32 | Creates a new value from the specified unsigned integer.
NValueCreateFromUInt64 | Creates a new value from the specified unsigned long integer.
NValueCreateP | Creates a new value of the specified type.
NValueGetAttributes | Retrieves the attributes of the specified value.
NValueGetFree | Frees the specified value.
NValueGetPtr | Retrieves a pointer to the specified value.
NValueGetSize | Retrieves the size of the specified value.
NValueGetTypeCode | Retrieves the type code of the specified value.
NValueGetValueType | Retrieves the type of the specified value.
NValueSet | Sets the specified value.
NValueSetP | Sets the specified value.
NValueToBoolean | Converts the specified value into a Boolean value.
NValueToByte | Converts the specified value into a byte.
NValueToCallback | Converts the specified value into a callback.
NValueToChar | Converts the specified value into a char.
NValueToDouble | Converts the specified value into a double value.
NValueToInt16 | Converts the specified value into a short integer.
NValueToInt32 | Converts the specified value to into integer.
NValueToInt64 | Converts the specified value into a long value.
NValueToObject | Converts the specified value into an object.
NValueToObjectP | Converts the specified value into an object.
NValueToPointer | Converts the specified value into a pointer.
NValueToResult | Converts the specified value into a NResult value.
NValueToSByte | Converts the specified value into a signed byte.
NValueToSSizeType | Converts the specified value into a NSSizeType value.
NValueToSingle | Converts the specified value into a floating point value.
NValueToSizeType | Converts the specified value into a NSizeType value.
NValueToString | Converts the specified value into a string.
NValueToUInt16 | Converts the specified value into an unsigned short integer.
NValueToUInt32 | Converts the specified value into an unsigned integer.
NValueToUInt64 | Converts the specified value into an unsigned long integer.
NValueToValue | Converts the specified value into a value of the specified type.
NValueToValueP | Converts the specified value into a value of the specified type.
Collapse Expand Macros
Name | Description
NNameValuePairCreate | Picks a Unicode (W) or ASCII (A) version of the NNameValuePairCreate function.
NValueCreateFromChar | Picks a Unicode (W) or ASCII (A) version of the NValueCreateFromChar function.
NValueCreateFromString | Picks a Unicode (W) or ASCII (A) version of the NValueCreateFromString function.
NValueToChar | Picks a Unicode (W) or ASCII (A) version of the NValueToChar function.
Collapse Expand Structs, Records, Enums
Name | Description
NKeyValuePair_ | Represents the key value pair structure.
NNameValuePair_ | Represents the name key value pair structure.


NKeyValuePairCopy Function

NKeyValuePairCopy Function
NValue.h

Creates a copy of the specified key value pair structure.

C++
NResult N_API NKeyValuePairCopy(const struct NKeyValuePair_ * pSrcValue, struct NKeyValuePair_ * pDstValue);
Collapse Expand Parameters
Parameters | Description
const struct NKeyValuePair_ * pSrcValue | [in] Pointer to the original key value pair.
struct NKeyValuePair_ * pDstValue | [out] Pointer to the copied key value pair.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NKeyValuePairCreate Function

NKeyValuePairCreate Function
NValue.h

Creates a new key value pair structure.

C++
NResult N_API NKeyValuePairCreate(HNValue hKey, HNValue hValue, struct NKeyValuePair_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNValue hKey | [in] Handle to the key part of the pair.
HNValue hValue | [in] Handle to the value part of the pair.
struct NKeyValuePair_ * pValue | [out] Pointer to the new key value pair.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NKeyValuePairDispose Function

NKeyValuePairDispose Function
NValue.h

Disposes of the specified key value pair structure.

C++
NResult N_API NKeyValuePairDispose(struct NKeyValuePair_ * pValue);
Collapse Expand Parameters
Parameters | Description
struct NKeyValuePair_ * pValue | [in/out] Pointer to the key value pair to be disposed of.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NKeyValuePairSet Function

NKeyValuePairSet Function
NValue.h

Sets the value of the specified key value pair structure.

C++
NResult N_API NKeyValuePairSet(const struct NKeyValuePair_ * pSrcValue, struct NKeyValuePair_ * pDstValue);
Collapse Expand Parameters
Parameters | Description
const struct NKeyValuePair_ * pSrcValue | [in] Pointer to the new key value pair value.
struct NKeyValuePair_ * pDstValue | [in] Pointer to the key value pair to be changed.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NNameValuePairCopy Function

NNameValuePairCopy Function
NValue.h

Creates a copy of the specified name value pair structure.

C++
NResult N_API NNameValuePairCopy(const struct NNameValuePair_ * pSrcValue, struct NNameValuePair_ * pDstValue);
Collapse Expand Parameters
Parameters | Description
const struct NNameValuePair_ * pSrcValue | [in] Pointer to the original name value pair.
struct NNameValuePair_ * pDstValue | [out] Pointer to the copied name value pair.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NNameValuePairCreate Function

NNameValuePairCreate Function
NValue.h

Creates a new name value pair structure.

C++
NResult N_API NNameValuePairCreate(const NChar * szKey, HNValue hValue, NNameValuePair * pValue);
Collapse Expand Parameters
Parameters | Description
const NChar * szKey | [in] Pointer to the key part of the pair.
HNValue hValue | [in] Handle to the value part of the pair.
NNameValuePair * pValue | [out] Pointer to the new name value pair.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NNameValuePairDispose Function

NNameValuePairDispose Function
NValue.h

Disposes of the specified name value pair structure.

C++
NResult N_API NNameValuePairDispose(struct NNameValuePair_ * pValue);
Collapse Expand Parameters
Parameters | Description
struct NNameValuePair_ * pValue | [in/out] Pointer to the name value pair to be disposed of.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NNameValuePairSet Function

NNameValuePairSet Function
NValue.h

Sets the value of the specified name value pair structure.

C++
NResult N_API NNameValuePairSet(const struct NNameValuePair_ * pSrcValue, struct NNameValuePair_ * pDstValue);
Collapse Expand Parameters
Parameters | Description
const struct NNameValuePair_ * pSrcValue | [in] Pointer to the new name value pair value.
struct NNameValuePair_ * pDstValue | [in] Pointer to the name value pair to be changed.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueChangeType Function

NValueChangeType Function
NValue.h

Changes the type of the specified value to the new type.

C++
NResult N_API NValueChangeType(HNValue hSrcValue, HNType hType, NAttributes attributes, HNString hFormat, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
HNValue hSrcValue | [in] Handle to the original value.
HNType hType | [in] Handle to the new value type.
NAttributes attributes | [in] Value attributes.
HNString hFormat | [in] Handle to the format string.
HNValue * phValue | [out] Pointer to a handle to the new value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueChangeTypeP Function

NValueChangeTypeP Function
NValue.h

Changes the type of the specified value to the new type.

C++
NResult N_API NValueChangeTypeP(HNValue hSrcValue, NTypeOfProc pTypeOf, NAttributes attributes, HNString hFormat, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
HNValue hSrcValue | [in] Handle to the original value.
NTypeOfProc pTypeOf | [in] Pointer to a function that retrieves the new value type.
NAttributes attributes | [in] Value attributes.
HNString hFormat | [in] Handle to the format string.
HNValue * phValue | [out] Pointer to a handle to the new value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueCreate Function

NValueCreate Function
NValue.h

Creates a new value of the specified type.

C++
NResult N_API NValueCreate(HNType hType, const void * pValue, NSizeType valueSize, NBool hasValue, NAttributes attributes, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the type of the value.
const void * pValue | [in] Pointer to the value of the new value.
NSizeType valueSize | [in] Size of the new value.
NBool hasValue | [in] NTrue if pValue contains a value, else NFalse.
NAttributes attributes | [in] Value attributes.
HNValue * phValue | [out] Pointer to a handle to the new value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueCreateCustom Function

NValueCreateCustom Function
NValue.h

Creates a new value with specified callbacks.

C++
NResult N_API NValueCreateCustom(const void * value, NPointerFreeProc pFree, void * pFreeParam, NPointerGetHashCodeProc pGetHashCode, void * pGetHashCodeParam, NPointerEqualsProc pEquals, void * pEqualsParam, NAttributes attributes, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
const void * value | [in] Pointer to the value of the new value.
NPointerFreeProc pFree | [in] Pointer to the "Free" function for the new value.
void * pFreeParam | [in] Pointer to the parameters for the "Free" function for the new value.
NPointerGetHashCodeProc pGetHashCode | [in] Pointer to the "Get Hash Code" function for the new value.
void * pGetHashCodeParam | [in] Pointer to the parameters for the "Get Hash Code" function for the new value.
NPointerEqualsProc pEquals | [in] Pointer to the "Equals" function for the new value.
void * pEqualsParam | [in] Pointer to the parameters for the "Equals" function for the new value.
NAttributes attributes | [in] Value attributes.
HNValue * phValue | [out] Pointer to a handle to the new value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueCreateCustomN Function

NValueCreateCustomN Function
NValue.h

Creates a new value with specified callbacks.

C++
NResult N_API NValueCreateCustomN(const void * value, HNCallback hFree, HNCallback hGetHashCode, HNCallback hEquals, NAttributes attributes, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
const void * value | [in] Pointer to the value of the new value.
HNCallback hFree | [in] Handle to the "Free" function callback for the new value.
HNCallback hGetHashCode | [in] Handle to the "Get Hash Code" function callback for the new value.
HNCallback hEquals | [in] Handle to the "Equals" function callback for the new value.
NAttributes attributes | [in] Value attributes.
HNValue * phValue | [out] Pointer to a handle to the new value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueCreateFromBoolean Function

NValueCreateFromBoolean Function
NValue.h

Creates a new value from the specified Boolean value.

C++
NResult N_API NValueCreateFromBoolean(NBool value, NAttributes attributes, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
NBool value | [in] The original Boolean value.
NAttributes attributes | [in] Value attributes.
HNValue * phValue | [out] Pointer to a handle to the new value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueCreateFromByte Function

NValueCreateFromByte Function
NValue.h

Creates a new value from the specified byte.

C++
NResult N_API NValueCreateFromByte(NByte value, NAttributes attributes, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
NByte value | [in] The original byte.
NAttributes attributes | [in] Value attributes.
HNValue * phValue | [out] Pointer to a handle to the new value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueCreateFromCallback Function

NValueCreateFromCallback Function
NValue.h

Creates a new value from specified callback.

C++
NResult N_API NValueCreateFromCallback(HNType hType, HNCallback hValue, NAttributes attributes, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the type of the value.
HNCallback hValue | [in] Handle of the callback with the new value.
NAttributes attributes | [in] Value attributes.
HNValue * phValue | [out] Pointer to a handle to the new value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueCreateFromChar Function

NValueCreateFromChar Function
NValue.h

Creates a new value from the specified char.

C++
NResult N_API NValueCreateFromChar(NChar value, NAttributes attributes, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
NChar value | [in] The original char.
NAttributes attributes | [in] Value attributes.
HNValue * phValue | [out] Pointer to a handle to the new value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueCreateFromDouble Function

NValueCreateFromDouble Function
NValue.h

Creates a new value from the specified double value.

C++
NResult N_API NValueCreateFromDouble(NDouble value, NAttributes attributes, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
NDouble value | [in] The original double value.
NAttributes attributes | [in] Value attributes.
HNValue * phValue | [out] Pointer to a handle to the new value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueCreateFromInt16 Function

NValueCreateFromInt16 Function
NValue.h

Creates a new value from the specified short integer.

C++
NResult N_API NValueCreateFromInt16(NShort value, NAttributes attributes, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
NShort value | [in] The original short integer.
NAttributes attributes | [in] Value attributes.
HNValue * phValue | [out] Pointer to a handle to the new value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueCreateFromInt32 Function

NValueCreateFromInt32 Function
NValue.h

Creates a new value from the specified integer.

C++
NResult N_API NValueCreateFromInt32(NInt value, NAttributes attributes, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
NInt value | [in] The original integer.
NAttributes attributes | [in] Value attributes.
HNValue * phValue | [out] Pointer to a handle to the new value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueCreateFromInt64 Function

NValueCreateFromInt64 Function
NValue.h

Creates a new value from the specified long integer.

C++
NResult N_API NValueCreateFromInt64(NLong value, NAttributes attributes, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
NLong value | [in] The original long integer.
NAttributes attributes | [in] Value attributes.
HNValue * phValue | [out] Pointer to a handle to the new value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueCreateFromObject Function

NValueCreateFromObject Function
NValue.h

Creates a new value from the specified object.

C++
NResult N_API NValueCreateFromObject(HNType hType, HNObject hValue, NAttributes attributes, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
HNType hType | [in] Handle to the type of the object.
HNObject hValue | [in] The original object.
NAttributes attributes | [in] Value attributes.
HNValue * phValue | [out] Pointer to a handle to the new value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueCreateFromObjectP Function

NValueCreateFromObjectP Function
NValue.h

Creates a new value from the specified object.

C++
NResult N_API NValueCreateFromObjectP(NTypeOfProc pTypeOf, HNObject hValue, NAttributes attributes, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
NTypeOfProc pTypeOf | [in] Pointer to a function that retrieves the type of the object.
HNObject hValue | [in] The original object.
NAttributes attributes | [in] Value attributes.
HNValue * phValue | [out] Pointer to a handle to the new value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueCreateFromPointer Function

NValueCreateFromPointer Function
NValue.h

Creates a new value from the specified pointer.

C++
NResult N_API NValueCreateFromPointer(const void * value, NAttributes attributes, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
const void * value | [in] The original pointer.
NAttributes attributes | [in] Value attributes.
HNValue * phValue | [out] Pointer to a handle to the new value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueCreateFromResult Function

NValueCreateFromResult Function
NValue.h

Creates a new value from the specified NResult value.

C++
NResult N_API NValueCreateFromResult(NResult value, NAttributes attributes, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
NResult value | [in] The original NResult value.
NAttributes attributes | [in] Value attributes.
HNValue * phValue | [out] Pointer to a handle to the new value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueCreateFromSByte Function

NValueCreateFromSByte Function
NValue.h

Creates a new value from the specified signed byte.

C++
NResult N_API NValueCreateFromSByte(NSByte value, NAttributes attributes, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
NSByte value | [in] The original signed byte.
NAttributes attributes | [in] Value attributes.
HNValue * phValue | [out] Pointer to a handle to the new value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueCreateFromSSizeType Function

NValueCreateFromSSizeType Function
NValue.h

Creates a new value from the specified NSSizeType value.

C++
NResult N_API NValueCreateFromSSizeType(NSSizeType value, NAttributes attributes, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
NSSizeType value | [in] The original NSSizeType value.
NAttributes attributes | [in] Value attributes.
HNValue * phValue | [out] Pointer to a handle to the new value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueCreateFromSingle Function

NValueCreateFromSingle Function
NValue.h

Creates a new value from the specified floating point value.

C++
NResult N_API NValueCreateFromSingle(NFloat value, NAttributes attributes, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
NFloat value | [in] The original floating point value.
NAttributes attributes | [in] Value attributes.
HNValue * phValue | [out] Pointer to a handle to the new value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueCreateFromSizeType Function

NValueCreateFromSizeType Function
NValue.h

Creates a new value from the specified NSizeType value.

C++
NResult N_API NValueCreateFromSizeType(NSizeType value, NAttributes attributes, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
NSizeType value | [in] The original NSizeType value.
NAttributes attributes | [in] Value attributes.
HNValue * phValue | [out] Pointer to a handle to the new value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueCreateFromString Function

NValueCreateFromString Function
NValue.h

Creates a new value from the specified string.

C++
NResult N_API NValueCreateFromString(const NChar * szValue, NAttributes attributes, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
const NChar * szValue | [in] The original string.
NAttributes attributes | [in] Value attributes.
HNValue * phValue | [out] Pointer to a handle to the new value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueCreateFromUInt16 Function

NValueCreateFromUInt16 Function
NValue.h

Creates a new value from the specified unsigned short integer.

C++
NResult N_API NValueCreateFromUInt16(NUShort value, NAttributes attributes, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
NUShort value | [in] The original unsigned short integer.
NAttributes attributes | [in] Value attributes.
HNValue * phValue | [out] Pointer to a handle to the new value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueCreateFromUInt32 Function

NValueCreateFromUInt32 Function
NValue.h

Creates a new value from the specified unsigned integer.

C++
NResult N_API NValueCreateFromUInt32(NUInt value, NAttributes attributes, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
NUInt value | [in] The original unsigned integer.
NAttributes attributes | [in] Value attributes.
HNValue * phValue | [out] Pointer to a handle to the new value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueCreateFromUInt64 Function

NValueCreateFromUInt64 Function
NValue.h

Creates a new value from the specified unsigned long integer.

C++
NResult N_API NValueCreateFromUInt64(NULong value, NAttributes attributes, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
NULong value | [in] The original unsigned long integer.
NAttributes attributes | [in] Value attributes.
HNValue * phValue | [out] Pointer to a handle to the new value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueCreateP Function

NValueCreateP Function
NValue.h

Creates a new value of the specified type.

C++
NResult N_API NValueCreateP(NTypeOfProc pTypeOf, const void * pValue, NSizeType valueSize, NBool hasValue, NAttributes attributes, HNValue * phValue);
Collapse Expand Parameters
Parameters | Description
NTypeOfProc pTypeOf | [in] Pointer to a function that retrieves the value type.
const void * pValue | [in] Pointer to the value of the new value.
NSizeType valueSize | [in] Size of the new value.
NBool hasValue | [in] NTrue if pValue contains a value, else NFalse.
NAttributes attributes | [in] Value attributes.
HNValue * phValue | [out] Pointer to a handle to the new value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueGetAttributes Function

NValueGetAttributes Function
NValue.h

Retrieves the attributes of the specified value.

C++
NResult N_API NValueGetAttributes(HNValue hValue, NAttributes * pResult);
Collapse Expand Parameters
Parameters | Description
HNValue hValue | [in] Handle to the value.
NAttributes * pResult | [out] Pointer to the attributes of the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueGetFree Function

NValueGetFree Function
NValue.h

Frees the specified value.

C++
NResult N_API NValueGetFree(HNValue hValue, HNCallback * phResult);
Collapse Expand Parameters
Parameters | Description
HNValue hValue | [in] Handle to the value to be freed.
HNCallback * phResult | [out] Pointer to a handle to the callback for the "Free" function for the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueGetPtr Function

NValueGetPtr Function
NValue.h

Retrieves a pointer to the specified value.

C++
NResult N_API NValueGetPtr(HNValue hValue, const void * * pResult);
Collapse Expand Parameters
Parameters | Description
HNValue hValue | [in] Handle to the value.
const void * * pResult | [out] Pointer to the pointer to the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueGetSize Function

NValueGetSize Function
NValue.h

Retrieves the size of the specified value.

C++
NResult N_API NValueGetSize(HNValue hValue, NSizeType * pResult);
Collapse Expand Parameters
Parameters | Description
HNValue hValue | [in] Handle to the value.
NSizeType * pResult | [out] Pointer to the size of the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueGetTypeCode Function

NValueGetTypeCode Function
NValue.h

Retrieves the type code of the specified value.

C++
NResult N_API NValueGetTypeCode(HNValue hValue, NTypeCode * pResult);
Collapse Expand Parameters
Parameters | Description
HNValue hValue | [in] Handle to the value.
NTypeCode * pResult | [out] Pointer to the type code of the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueGetValueType Function

NValueGetValueType Function
NValue.h

Retrieves the type of the specified value.

C++
NResult N_API NValueGetValueType(HNValue hValue, HNType * phResult);
Collapse Expand Parameters
Parameters | Description
HNValue hValue | [in] Handle to the value.
HNType * phResult | [out] Pointer to a handle to the type of the value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueSet Function

NValueSet Function
NValue.h

Sets the specified value.

C++
NResult N_API NValueSet(HNValue hValue, HNType hType, NAttributes attributes, void * pValue, NSizeType valueSize, NBool * pHasValue);
Collapse Expand Parameters
Parameters | Description
HNValue hValue | [in] Handle to the value to be set.
HNType hType | [in] Handle to the type of the value.
NAttributes attributes | [in] Value attributes.
void * pValue | [in] Pointer to the new value.
NSizeType valueSize | [in] Size of the value.
NBool * pHasValue | [out] NTrue if pValue contains a value; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueSetP Function

NValueSetP Function
NValue.h

Sets the specified value.

C++
NResult N_API NValueSetP(HNValue hValue, NTypeOfProc pTypeOf, NAttributes attributes, void * pValue, NSizeType valueSize, NBool * pHasValue);
Collapse Expand Parameters
Parameters | Description
HNValue hValue | [in] Handle to the value to be set.
NTypeOfProc pTypeOf | [in] Pointer to a function that retrieves the type of the value.
NAttributes attributes | [in] Value attributes.
void * pValue | [in] Pointer to the new value.
NSizeType valueSize | [in] Size of the value.
NBool * pHasValue | [out] NTrue if pValue contains a value; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueToBoolean Function

NValueToBoolean Function
NValue.h

Converts the specified value into a Boolean value.

C++
NResult N_API NValueToBoolean(HNValue hValue, NAttributes attributes, HNString hFormat, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNValue hValue | [in] Handle to the original value.
NAttributes attributes | [in] Value attributes.
HNString hFormat | [in] Handle to the format string.
NBool * pResult | [out] Pointer to the result Boolean value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueToByte Function

NValueToByte Function
NValue.h

Converts the specified value into a byte.

C++
NResult N_API NValueToByte(HNValue hValue, NAttributes attributes, HNString hFormat, NByte * pResult);
Collapse Expand Parameters
Parameters | Description
HNValue hValue | [in] Handle to the original value.
NAttributes attributes | [in] Value attributes.
HNString hFormat | [in] Handle to the format string.
NByte * pResult | [out] Pointer to the result byte.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueToCallback Function

NValueToCallback Function
NValue.h

Converts the specified value into a callback.

C++
NResult N_API NValueToCallback(HNValue hValue, HNType hType, NAttributes attributes, HNString hFormat, HNCallback * phResult);
Collapse Expand Parameters
Parameters | Description
HNValue hValue | [in] Handle to the original value.
HNType hType | [in] Handle to the type of the value.
NAttributes attributes | [in] Value attributes.
HNString hFormat | [in] String format.
HNCallback * phResult | [out] Pointer to the result callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueToChar Function

NValueToChar Function
NValue.h

Converts the specified value into a char.

C++
NResult N_API NValueToChar(HNValue hValue, NAttributes attributes, HNString hFormat, NChar * pResult);
Collapse Expand Parameters
Parameters | Description
HNValue hValue | [in] Handle to the original value.
NAttributes attributes | [in] Value attributes.
HNString hFormat | [in] Handle to the format string.
NChar * pResult | [out] Pointer to the result char.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueToDouble Function

NValueToDouble Function
NValue.h

Converts the specified value into a double value.

C++
NResult N_API NValueToDouble(HNValue hValue, NAttributes attributes, HNString hFormat, NDouble * pResult);
Collapse Expand Parameters
Parameters | Description
HNValue hValue | [in] Handle to the original value.
NAttributes attributes | [in] Value attributes.
HNString hFormat | [in] Handle to the format string.
NDouble * pResult | [out] Pointer to the result double value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueToInt16 Function

NValueToInt16 Function
NValue.h

Converts the specified value into a short integer.

C++
NResult N_API NValueToInt16(HNValue hValue, NAttributes attributes, HNString hFormat, NShort * pResult);
Collapse Expand Parameters
Parameters | Description
HNValue hValue | [in] Handle to the original value.
NAttributes attributes | [in] Value attributes.
HNString hFormat | [in] Handle to the format string.
NShort * pResult | [out] Pointer to the result short integer.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueToInt32 Function

NValueToInt32 Function
NValue.h

Converts the specified value to into integer.

C++
NResult N_API NValueToInt32(HNValue hValue, NAttributes attributes, HNString hFormat, NInt * pResult);
Collapse Expand Parameters
Parameters | Description
HNValue hValue | [in] Handle to the original value.
NAttributes attributes | [in] Value attributes.
HNString hFormat | [in] Handle to the format string.
NInt * pResult | [out] Pointer to the result integer.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueToInt64 Function

NValueToInt64 Function
NValue.h

Converts the specified value into a long value.

C++
NResult N_API NValueToInt64(HNValue hValue, NAttributes attributes, HNString hFormat, NLong * pResult);
Collapse Expand Parameters
Parameters | Description
HNValue hValue | [in] Handle to the original value.
NAttributes attributes | [in] Value attributes.
HNString hFormat | [in] Handle to the format string.
NLong * pResult | [out] Pointer to the result long integer.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueToObject Function

NValueToObject Function
NValue.h

Converts the specified value into an object.

C++
NResult N_API NValueToObject(HNValue hValue, HNType hType, NAttributes attributes, HNString hFormat, HNObject * phResult);
Collapse Expand Parameters
Parameters | Description
HNValue hValue | [in] Handle to the original value.
HNType hType | [in] Handle to the type of the object.
NAttributes attributes | [in] Value attributes.
HNString hFormat | [in] Handle to the format string.
HNObject * phResult | [out] Pointer to the result object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueToObjectP Function

NValueToObjectP Function
NValue.h

Converts the specified value into an object.

C++
NResult N_API NValueToObjectP(HNValue hValue, NTypeOfProc pTypeOf, NAttributes attributes, HNString hFormat, HNObject * phResult);
Collapse Expand Parameters
Parameters | Description
HNValue hValue | [in] Handle to the original value.
NTypeOfProc pTypeOf | [in] Pointer to a function that retrieves the type of the object.
NAttributes attributes | [in] Value attributes.
HNString hFormat | [in] Handle to the format string.
HNObject * phResult | [out] Pointer to the result object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueToPointer Function

NValueToPointer Function
NValue.h

Converts the specified value into a pointer.

C++
NResult N_API NValueToPointer(HNValue hValue, NAttributes attributes, HNString hFormat, void * * pResult);
Collapse Expand Parameters
Parameters | Description
HNValue hValue | [in] Handle to the original value.
NAttributes attributes | [in] Value attributes.
HNString hFormat | [in] Handle to the format string.
void * * pResult | [out] Pointer to the result pointer.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueToResult Function

NValueToResult Function
NValue.h

Converts the specified value into a NResult value.

C++
NResult N_API NValueToResult(HNValue hValue, NAttributes attributes, HNString hFormat, NResult * pResult);
Collapse Expand Parameters
Parameters | Description
HNValue hValue | [in] Handle to the original value.
NAttributes attributes | [in] Value attributes.
HNString hFormat | [in] Handle to the format string.
NResult * pResult | [out] Pointer to the result NResult value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueToSByte Function

NValueToSByte Function
NValue.h

Converts the specified value into a signed byte.

C++
NResult N_API NValueToSByte(HNValue hValue, NAttributes attributes, HNString hFormat, NSByte * pResult);
Collapse Expand Parameters
Parameters | Description
HNValue hValue | [in] Handle to the original value.
NAttributes attributes | [in] Value attributes.
HNString hFormat | [in] Handle to the format string.
NSByte * pResult | [out] Pointer to the result signed byte.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueToSSizeType Function

NValueToSSizeType Function
NValue.h

Converts the specified value into a NSSizeType value.

C++
NResult N_API NValueToSSizeType(HNValue hValue, NAttributes attributes, HNString hFormat, NSSizeType * pResult);
Collapse Expand Parameters
Parameters | Description
HNValue hValue | [in] Handle to the original value.
NAttributes attributes | [in] Value attributes.
HNString hFormat | [in] Handle to the format string.
NSSizeType * pResult | [out] Pointer to the result NSSizeType value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueToSingle Function

NValueToSingle Function
NValue.h

Converts the specified value into a floating point value.

C++
NResult N_API NValueToSingle(HNValue hValue, NAttributes attributes, HNString hFormat, NFloat * pResult);
Collapse Expand Parameters
Parameters | Description
HNValue hValue | [in] Handle to the original value.
NAttributes attributes | [in] Value attributes.
HNString hFormat | [in] Handle to the format string.
NFloat * pResult | [out] Pointer to the result floating point value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueToSizeType Function

NValueToSizeType Function
NValue.h

Converts the specified value into a NSizeType value.

C++
NResult N_API NValueToSizeType(HNValue hValue, NAttributes attributes, HNString hFormat, NSizeType * pResult);
Collapse Expand Parameters
Parameters | Description
HNValue hValue | [in] Handle to the original value.
NAttributes attributes | [in] Value attributes.
HNString hFormat | [in] Handle to the format string.
NSizeType * pResult | [out] Pointer to the result NSizeType value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueToString Function

NValueToString Function
NValue.h

Converts the specified value into a string.

C++
NResult N_API NValueToString(HNValue hValue, NAttributes attributes, HNString hFormat, HNString * phResult);
Collapse Expand Parameters
Parameters | Description
HNValue hValue | [in] Handle to the original value.
NAttributes attributes | [in] Value attributes.
HNString hFormat | [in] Handle to the format string.
HNString * phResult | [out] Pointer to the result string.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueToUInt16 Function

NValueToUInt16 Function
NValue.h

Converts the specified value into an unsigned short integer.

C++
NResult N_API NValueToUInt16(HNValue hValue, NAttributes attributes, HNString hFormat, NUShort * pResult);
Collapse Expand Parameters
Parameters | Description
HNValue hValue | [in] Handle to the original value.
NAttributes attributes | [in] Value attributes.
HNString hFormat | [in] Handle to the format string.
NUShort * pResult | [out] Pointer to the result unsigned short integer.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueToUInt32 Function

NValueToUInt32 Function
NValue.h

Converts the specified value into an unsigned integer.

C++
NResult N_API NValueToUInt32(HNValue hValue, NAttributes attributes, HNString hFormat, NUInt * pResult);
Collapse Expand Parameters
Parameters | Description
HNValue hValue | [in] Handle to the original value.
NAttributes attributes | [in] Value attributes.
HNString hFormat | [in] Handle to the format string.
NUInt * pResult | [out] Pointer to the result unsigned integer.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueToUInt64 Function

NValueToUInt64 Function
NValue.h

Converts the specified value into an unsigned long integer.

C++
NResult N_API NValueToUInt64(HNValue hValue, NAttributes attributes, HNString hFormat, NULong * pResult);
Collapse Expand Parameters
Parameters | Description
HNValue hValue | [in] Handle to the original value.
NAttributes attributes | [in] Value attributes.
HNString hFormat | [in] Handle to the format string.
NULong * pResult | [out] Pointer to the result unsigned long integer.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueToValue Function

NValueToValue Function
NValue.h

Converts the specified value into a value of the specified type.

C++
NResult N_API NValueToValue(HNValue hValue, HNType hType, NAttributes attributes, HNString hFormat, void * pResult, NSizeType resultSize);
Collapse Expand Parameters
Parameters | Description
HNValue hValue | [in] Handle to the original value.
HNType hType | [in] Handle to the type of the value.
NAttributes attributes | [in] Value attributes.
HNString hFormat | [in] Handle to the format string.
void * pResult | [out] Pointer to the result value.
NSizeType resultSize | [in] Size of the resulting value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NValueToValueP Function

NValueToValueP Function
NValue.h

Converts the specified value into a value of the specified type.

C++
NResult N_API NValueToValueP(HNValue hValue, NTypeOfProc pTypeOf, NAttributes attributes, HNString hFormat, void * pResult, NSizeType resultSize);
Collapse Expand Parameters
Parameters | Description
HNValue hValue | [in] Handle to the original value.
NTypeOfProc pTypeOf | [in] Pointer to a function that retrieves the type of the value.
NAttributes attributes | [in] Value attributes.
HNString hFormat | [in] Handle to the format string.
void * pResult | [out] Pointer to the result value.
NSizeType resultSize | [in] Size of the resulting value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NValue.h

Module: NValue Unit


NKeyValuePair_ Structure

NKeyValuePair_ Structure
NValue.h

Represents the key value pair structure.

C++
struct NKeyValuePair_ {
  HNValue hKey;
  HNValue hValue;
};
Collapse Expand Members
Members | Description
HNValue hKey; | Handle to the key part of the pair.
HNValue hValue; | Handle to the value part of the pair.
Container

File: NValue.h

Module: NValue Unit


NNameValuePair_ Structure

NNameValuePair_ Structure
NValue.h

Represents the name key value pair structure.

C++
struct NNameValuePair_ {
  HNString hKey;
  HNValue hValue;
};
Collapse Expand Members
Members | Description
HNString hKey; | Handle to the key part of the pair.
HNValue hValue; | Handle to the value part of the pair.
Container

File: NValue.h

Module: NValue Unit


NNameValuePairCreate Macro

NNameValuePairCreate Macro
NValue.h

Picks a Unicode (W) or ASCII (A) version of the NNameValuePairCreate function.

C++
#define NNameValuePairCreate N_FUNC_AW(NNameValuePairCreate)
Container

File: NValue.h

Module: NValue Unit


NValueCreateFromChar Macro

NValueCreateFromChar Macro
NValue.h

Picks a Unicode (W) or ASCII (A) version of the NValueCreateFromChar function.

C++
#define NValueCreateFromChar N_FUNC_AW(NValueCreateFromChar)
Container

File: NValue.h

Module: NValue Unit


NValueCreateFromString Macro

NValueCreateFromString Macro
NValue.h

Picks a Unicode (W) or ASCII (A) version of the NValueCreateFromString function.

C++
#define NValueCreateFromString N_FUNC_AW(NValueCreateFromString)
Container

File: NValue.h

Module: NValue Unit


NValueToChar Macro

NValueToChar Macro
NValue.h

Picks a Unicode (W) or ASCII (A) version of the NValueToChar function.

C++
#define NValueToChar N_FUNC_AW(NValueToChar)
Container

File: NValue.h

Module: NValue Unit


NValue.h

NValue.h
Functions Legend Macros Structures

Header file for the NValue unit.

Collapse Expand Functions
Name | Description
NKeyValuePairCopy | Creates a copy of the specified key value pair structure.
NKeyValuePairCreate | Creates a new key value pair structure.
NKeyValuePairDispose | Disposes of the specified key value pair structure.
NKeyValuePairSet | Sets the value of the specified key value pair structure.
NNameValuePairCopy | Creates a copy of the specified name value pair structure.
NNameValuePairCreate | Creates a new name value pair structure.
NNameValuePairDispose | Disposes of the specified name value pair structure.
NNameValuePairSet | Sets the value of the specified name value pair structure.
NValueChangeType | Changes the type of the specified value to the new type.
NValueChangeTypeP | Changes the type of the specified value to the new type.
NValueCreate | Creates a new value of the specified type.
NValueCreateCustom | Creates a new value with specified callbacks.
NValueCreateCustomN | Creates a new value with specified callbacks.
NValueCreateFromBoolean | Creates a new value from the specified Boolean value.
NValueCreateFromByte | Creates a new value from the specified byte.
NValueCreateFromCallback | Creates a new value from specified callback.
NValueCreateFromChar | Creates a new value from the specified char.
NValueCreateFromDouble | Creates a new value from the specified double value.
NValueCreateFromInt16 | Creates a new value from the specified short integer.
NValueCreateFromInt32 | Creates a new value from the specified integer.
NValueCreateFromInt64 | Creates a new value from the specified long integer.
NValueCreateFromObject | Creates a new value from the specified object.
NValueCreateFromObjectP | Creates a new value from the specified object.
NValueCreateFromPointer | Creates a new value from the specified pointer.
NValueCreateFromResult | Creates a new value from the specified NResult value.
NValueCreateFromSByte | Creates a new value from the specified signed byte.
NValueCreateFromSSizeType | Creates a new value from the specified NSSizeType value.
NValueCreateFromSingle | Creates a new value from the specified floating point value.
NValueCreateFromSizeType | Creates a new value from the specified NSizeType value.
NValueCreateFromString | Creates a new value from the specified string.
NValueCreateFromUInt16 | Creates a new value from the specified unsigned short integer.
NValueCreateFromUInt32 | Creates a new value from the specified unsigned integer.
NValueCreateFromUInt64 | Creates a new value from the specified unsigned long integer.
NValueCreateP | Creates a new value of the specified type.
NValueGetAttributes | Retrieves the attributes of the specified value.
NValueGetFree | Frees the specified value.
NValueGetPtr | Retrieves a pointer to the specified value.
NValueGetSize | Retrieves the size of the specified value.
NValueGetTypeCode | Retrieves the type code of the specified value.
NValueGetValueType | Retrieves the type of the specified value.
NValueSet | Sets the specified value.
NValueSetP | Sets the specified value.
NValueToBoolean | Converts the specified value into a Boolean value.
NValueToByte | Converts the specified value into a byte.
NValueToCallback | Converts the specified value into a callback.
NValueToChar | Converts the specified value into a char.
NValueToDouble | Converts the specified value into a double value.
NValueToInt16 | Converts the specified value into a short integer.
NValueToInt32 | Converts the specified value to into integer.
NValueToInt64 | Converts the specified value into a long value.
NValueToObject | Converts the specified value into an object.
NValueToObjectP | Converts the specified value into an object.
NValueToPointer | Converts the specified value into a pointer.
NValueToResult | Converts the specified value into a NResult value.
NValueToSByte | Converts the specified value into a signed byte.
NValueToSSizeType | Converts the specified value into a NSSizeType value.
NValueToSingle | Converts the specified value into a floating point value.
NValueToSizeType | Converts the specified value into a NSizeType value.
NValueToString | Converts the specified value into a string.
NValueToUInt16 | Converts the specified value into an unsigned short integer.
NValueToUInt32 | Converts the specified value into an unsigned integer.
NValueToUInt64 | Converts the specified value into an unsigned long integer.
NValueToValue | Converts the specified value into a value of the specified type.
NValueToValueP | Converts the specified value into a value of the specified type.
Collapse Expand Macros
Name | Description
NNameValuePairCreate | Picks a Unicode (W) or ASCII (A) version of the NNameValuePairCreate function.
NValueCreateFromChar | Picks a Unicode (W) or ASCII (A) version of the NValueCreateFromChar function.
NValueCreateFromString | Picks a Unicode (W) or ASCII (A) version of the NValueCreateFromString function.
NValueToChar | Picks a Unicode (W) or ASCII (A) version of the NValueToChar function.
Collapse Expand Structures
Name | Description
NKeyValuePair_ | Represents the key value pair structure.
NNameValuePair_ | Represents the name key value pair structure.


NWaitObject Unit

NWaitObject Unit
Functions Legend Macros

Base unit for common functionality of some cross platform synchronization primitives (supporting timed wait). See derived units for complete description:

  • NMutex
  • NSemaphore
  • NSyncEvent
Collapse Expand Functions
Name | Description
NWaitObjectWaitFor | Waits (blocks the calling thread) until the specified object is in signalled state (for example NMutex is not owned by any threads).
NWaitObjectWaitForTimed | Waits (blocks the calling thread) until the specified object is in signalled state or timeout expires.
Collapse Expand Macros
Name | Description
N_INFINITE | Constant to be used as infinite time value (for example in NWaitObjectTimedWaitFor function).


NWaitObjectWaitFor Function

NWaitObjectWaitFor Function

Waits (blocks the calling thread) until the specified object is in signalled state (for example NMutex is not owned by any threads).

C++
NResult N_API NWaitObjectWaitFor(HNWaitObject hWaitObject);
Collapse Expand Parameters
Parameters | Description
HNWaitObject hWaitObject | [in] Handle to the synchronization object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

The successful operation would also perform necessary updated to the object state:

  • NMutex will be locked;
  • NSemaphore will be decremented;
  • NSyncEvent with auto-reset will be reset.

As a result the object might become nonsignalled. Use the functions form the derived unit to make object signalled again.

Container

File: NWaitObject.h

Module: NWaitObject Unit


NWaitObjectWaitForTimed Function

NWaitObjectWaitForTimed Function

Waits (blocks the calling thread) until the specified object is in signalled state or timeout expires.

C++
NResult N_API NWaitObjectWaitForTimed(HNWaitObject hWaitObject, NInt timeOutMilliseconds, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNWaitObject hWaitObject | [in] Handle to the synchronization object.
NInt timeOutMilliseconds | [in] Maximum time to wait.
NBool * pResult | [out] Is set to NTrue on successful operation (the lock is acquired), to NFalse on timeout.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

The successful operation would also perform necessary updated to the object state. See NWaitObjectWaitFor.

Container

File: NWaitObject.h

Module: NWaitObject Unit


N_INFINITE Macro

N_INFINITE Macro

Constant to be used as infinite time value (for example in NWaitObjectTimedWaitFor function).

C++
#define N_INFINITE -1
Container

File: NWaitObject.h

Module: NWaitObject Unit


NWindows Unit

NWindows Unit
Files
Collapse Expand Files
Name | Description
NWindows.h | Header file for the NWindows unit.


NWindows.h

NWindows.h

Header file for the NWindows unit.


NDevices Library

NDevices Library

Provides functionality for managing devices, like cameras or fingerprint scanners.

Collapse Expand Remarks
Requirements (Windows)
  • Import Library: NDevices.dll.lib
  • DLL: NDevices.dll

Requirements (Linux)

  • Shared object: libNDevices.so
Collapse Expand Notes

The library's NDeviceManager unit is used to enumerate available devices of particular type. The device handle obtained from the manager can than be used with functions from appropriate unit to work with the device and to get the information it and it's capabilities.

The devices of the library form type hierarchy, where functionality common to different classes of devices is grouped into separate unit. The diagram below shows the relations between different units:

NDevice is the main entity in NDevices library. It provides functions to retrieve parent/child entities, plugins or device name/serial number.

NDevice entity has two child units: NCaptureDevice and NBiometricDevice. NCaptureDevice is used for capture devices (cameras and microphones) to retrieve device formats, media types and to start/stop capturing. Child entities NMicrophone and NCamera are used to retrieve sound samples or video frames.

NBiometricDevice is the main unit of fingerprints, irises palmprint and signature scanning devices. This unit can be used to retrieve device vendor Id, check spoof detection and to start/stop capturing sequence. NFScanner, NIrisScanner and NSignatureScanner are children of NBiometricDevice. These entities are used to capture fingerprint, iris and signature images.

Device availability

Device manager keeps track of the devices available in the system, and devices can be connected and disconnected from the computer during runtime. In addition the library uses flexible plugin system. Each particular device is provided to the library by a special plugin (dynamic library). The plugins used can be controlled dynamically through NPluginManager unit (from NCore library). New plugins can also be written by the integrators to add support for custom devices.

Collapse Expand Modules
Name | Description
NBiometricDevice Unit | ... more
NCamera Unit | ... more
NCaptureDevice Unit | Provides functions for working with capture devices.
NDevice Unit | ... more
NDeviceEventDescriptor Unit | Provides functionality for creating device event descriptors.
NDeviceManager Unit | ... more
NDeviceMethodDescriptor Unit | Provides functionality for creating device method descriptors.
NDevicePropertyDescriptor Unit | Provides functionality for creating device property descriptors.
NDevices Unit | Provides information about NDevices library.


NBiometricDevice Unit

NBiometricDevice Unit
Files Functions Legend

NBiometricDevice is the main unit of fingerprint and palmprint scanning devices. This unit can be used to retrieve device vendor Id, check spoof detection and to start/stop capturing sequence.

Collapse Expand Files
Name | Description
NBiometricDevice.h | Header file for the NBiometricDevice module.
Collapse Expand Functions
Name | Description
NBiometricDeviceAddCapturePreview | Adds a "capture preview" event to the specified biometric device.
NBiometricDeviceAddCapturePreviewCallback | Adds a "capture preview" event callback to the specified biometric device.
NBiometricDeviceCancel | Cancels (stops) current capture operation of NBiometricDevice (NFScanner or NIrisScanner).
NBiometricDeviceCapture | The biometric devices starts capturing biometric data.
NBiometricDeviceEndSequence | Ends multiple images capturing sequence.
NBiometricDeviceGetBiometricType | Gets biometric types supported by specified device.
NBiometricDeviceGetProductId | Gets device Id.
NBiometricDeviceGetSpoofDetection | Checks if the device is set to detect spoof objects.
NBiometricDeviceGetVendorId | Gets device vendor Id.
NBiometricDeviceIsSpoofDetectionSupported | Checks if the device is capable to detect spoof objects.
NBiometricDeviceRemoveCapturePreview | Removes a "capture preview" event from the specified biometric device.
NBiometricDeviceRemoveCapturePreviewCallback | Removes a "capture preview" event callback from the specified biometric device.
NBiometricDeviceSetSpoofDetection | Sets the device to detect spoof objects.
NBiometricDeviceStartSequence | Starts sequence which prepares device for multiple capture operations.


NBiometricDeviceAddCapturePreview Function

NBiometricDeviceAddCapturePreview Function
NBiometricDevice.h

Adds a "capture preview" event to the specified biometric device.

C++
NResult N_API NBiometricDeviceAddCapturePreview(HNBiometricDevice hDevice, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNBiometricDevice hDevice | [in] Handle to the biometric device.
HNCallback hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBiometricDevice.h

Module: NBiometricDevice Unit


NBiometricDeviceAddCapturePreviewCallback Function

NBiometricDeviceAddCapturePreviewCallback Function
NBiometricDevice.h

Adds a "capture preview" event callback to the specified biometric device.

C++
NResult N_API NBiometricDeviceAddCapturePreviewCallback(HNBiometricDevice hDevice, NBiometricDeviceCapturePreviewCallback pCallback, void * pParam);
Collapse Expand Parameters
Parameters | Description
HNBiometricDevice hDevice | [in] Handle to the biometric device.
NBiometricDeviceCapturePreviewCallback pCallback | [in] Handle to the callback to be added.
void * pParam | [out] Pointer to the parameters provided to the callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBiometricDevice.h

Module: NBiometricDevice Unit


NBiometricDeviceCancel Function

NBiometricDeviceCancel Function
NBiometricDevice.h

Cancels (stops) current capture operation of NBiometricDevice (NFScanner or NIrisScanner).

C++
NResult N_API NBiometricDeviceCancel(HNBiometricDevice hDevice);
Collapse Expand Parameters
Parameters | Description
HNBiometricDevice hDevice | [in] Handle to NBiometricDevice which should be canceled.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

Also NBiometricDeviceEndSequence function can be called which cancels capturing and finishes the sequence.

Container

File: NBiometricDevice.h

Module: NBiometricDevice Unit


NBiometricDeviceCapture Function

NBiometricDeviceCapture Function
NBiometricDevice.h

The biometric devices starts capturing biometric data.

C++
NResult N_API NBiometricDeviceCapture(HNBiometricDevice hDevice, HNBiometric hBiometric, NInt timeoutMilliseconds, NBiometricStatus * pStatus);
Collapse Expand Parameters
Parameters | Description
HNBiometricDevice hDevice | [in] Handle to the biometric device.
HNBiometric hBiometric | [in] Handle to the NBiometric object which receives captured biometric data.
NInt timeoutMilliseconds | [in] Capture timeout period in milliseconds.
NBiometricStatus * pStatus | [out] Pointer to the biometric status.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBiometricDevice.h

Module: NBiometricDevice Unit


NBiometricDeviceEndSequence Function

NBiometricDeviceEndSequence Function
NBiometricDevice.h See Also

Ends multiple images capturing sequence.

C++
NResult N_API NBiometricDeviceEndSequence(HNBiometricDevice hDevice);
Collapse Expand Parameters
Parameters | Description
HNBiometricDevice hDevice | [in] Handle to NBiometricDevice .
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

If some capturing has not finished yet, it will be interrupted (see NBiometricDeviceCancel).

Collapse Expand See Also

NBiometricDeviceStartSequence

Container

File: NBiometricDevice.h

Module: NBiometricDevice Unit


NBiometricDeviceGetBiometricType Function

NBiometricDeviceGetBiometricType Function
NBiometricDevice.h

Gets biometric types supported by specified device.

C++
NResult N_API NBiometricDeviceGetBiometricType(HNBiometricDevice hDevice, NBiometricType * pValue);
Collapse Expand Parameters
Parameters | Description
HNBiometricDevice hDevice | [in] Handle to NBiometricDevice to retrieve supported biometric types.
NBiometricType * pValue | [out]Supported biometric types.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBiometricDevice.h

Module: NBiometricDevice Unit


NBiometricDeviceGetProductId Function

NBiometricDeviceGetProductId Function
NBiometricDevice.h

Gets device Id.

C++
NResult N_API NBiometricDeviceGetProductId(HNBiometricDevice hDevice, NUShort * pValue);
Collapse Expand Parameters
Parameters | Description
HNBiometricDevice hDevice | [in] Handle to NBiometricDevice.
NUShort * pValue | [out] Device product Id.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBiometricDevice.h

Module: NBiometricDevice Unit


NBiometricDeviceGetSpoofDetection Function

NBiometricDeviceGetSpoofDetection Function
NBiometricDevice.h

Checks if the device is set to detect spoof objects.

C++
NResult N_API NBiometricDeviceGetSpoofDetection(HNBiometricDevice hDevice, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNBiometricDevice hDevice | [in] Handle to NBiometricDevice.
NBool * pValue | [out] NBool type value which indicates if the device is set to detect spoof objects.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBiometricDevice.h

Module: NBiometricDevice Unit


NBiometricDeviceGetVendorId Function

NBiometricDeviceGetVendorId Function
NBiometricDevice.h

Gets device vendor Id.

C++
NResult N_API NBiometricDeviceGetVendorId(HNBiometricDevice hDevice, NUShort * pValue);
Collapse Expand Parameters
Parameters | Description
HNBiometricDevice hDevice | [in] Handle to NBiometricDevice.
NUShort * pValue | [out] Device vendor Id.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBiometricDevice.h

Module: NBiometricDevice Unit


NBiometricDeviceIsSpoofDetectionSupported Function

NBiometricDeviceIsSpoofDetectionSupported Function
NBiometricDevice.h

Checks if the device is capable to detect spoof objects.

C++
NResult N_API NBiometricDeviceIsSpoofDetectionSupported(HNBiometricDevice hDevice, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNBiometricDevice hDevice | [in] Handle to NBiometricDevice.
NBool * pValue | [out] NBool type value which indicates if the device is capable to detect spoof objects.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBiometricDevice.h

Module: NBiometricDevice Unit


NBiometricDeviceRemoveCapturePreview Function

NBiometricDeviceRemoveCapturePreview Function
NBiometricDevice.h

Removes a "capture preview" event from the specified biometric device.

C++
NResult N_API NBiometricDeviceRemoveCapturePreview(HNBiometricDevice hDevice, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNBiometricDevice hDevice | [in] Handle to the biometric device.
HNCallback hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBiometricDevice.h

Module: NBiometricDevice Unit


NBiometricDeviceRemoveCapturePreviewCallback Function

NBiometricDeviceRemoveCapturePreviewCallback Function
NBiometricDevice.h

Removes a "capture preview" event callback from the specified biometric device.

C++
NResult N_API NBiometricDeviceRemoveCapturePreviewCallback(HNBiometricDevice hDevice, NBiometricDeviceCapturePreviewCallback pCallback, void * pParam);
Collapse Expand Parameters
Parameters | Description
HNBiometricDevice hDevice | [in] Handle to the biometric device.
NBiometricDeviceCapturePreviewCallback pCallback | [in] Handle to the callback to be added.
void * pParam | [out] Pointer to the parameters provided to the callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBiometricDevice.h

Module: NBiometricDevice Unit


NBiometricDeviceSetSpoofDetection Function

NBiometricDeviceSetSpoofDetection Function
NBiometricDevice.h

Sets the device to detect spoof objects.

C++
NResult N_API NBiometricDeviceSetSpoofDetection(HNBiometricDevice hDevice, NBool value);
Collapse Expand Parameters
Parameters | Description
HNBiometricDevice hDevice | [in] Handle to NBiometricDevice.
NBool value | [out] NBool type value: NTrue - to enable spoof objects detection; NFalse - to disable spoof objects detection.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NBiometricDevice.h

Module: NBiometricDevice Unit


NBiometricDeviceStartSequence Function

NBiometricDeviceStartSequence Function
NBiometricDevice.h

Starts sequence which prepares device for multiple capture operations.

C++
NResult N_API NBiometricDeviceStartSequence(HNBiometricDevice hDevice);
Collapse Expand Parameters
Parameters | Description
HNBiometricDevice hDevice | [in] Handle to NBiometricDevice which should be prepared for multiple capturing.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

Some devices do not support multiple capturing (sequences). When called for such devices, this function does nothing.

NBiometricDeviceStartSequence function does not start capturing. Capturing should be started using NFScannerCaptureEx or NIrisScannerCaptureEx functions. These functions should be called for each fingerprint/palmprint or iris image.

If capturing sequence was started, after capturing it should be ended by calling NBiometricDeviceEndSequence function.

Note: It is not recommended but user can capture multiple images without calling NBiometricDeviceStartSequence and NBiometricDeviceEndSequence functions.

Container

File: NBiometricDevice.h

Module: NBiometricDevice Unit


NBiometricDevice.h

NBiometricDevice.h
Functions Legend

Header file for the NBiometricDevice module.

Collapse Expand Functions
Name | Description
NBiometricDeviceAddCapturePreview | Adds a "capture preview" event to the specified biometric device.
NBiometricDeviceAddCapturePreviewCallback | Adds a "capture preview" event callback to the specified biometric device.
NBiometricDeviceCancel | Cancels (stops) current capture operation of NBiometricDevice (NFScanner or NIrisScanner).
NBiometricDeviceCapture | The biometric devices starts capturing biometric data.
NBiometricDeviceEndSequence | Ends multiple images capturing sequence.
NBiometricDeviceGetBiometricType | Gets biometric types supported by specified device.
NBiometricDeviceGetProductId | Gets device Id.
NBiometricDeviceGetSpoofDetection | Checks if the device is set to detect spoof objects.
NBiometricDeviceGetVendorId | Gets device vendor Id.
NBiometricDeviceIsSpoofDetectionSupported | Checks if the device is capable to detect spoof objects.
NBiometricDeviceRemoveCapturePreview | Removes a "capture preview" event from the specified biometric device.
NBiometricDeviceRemoveCapturePreviewCallback | Removes a "capture preview" event callback from the specified biometric device.
NBiometricDeviceSetSpoofDetection | Sets the device to detect spoof objects.
NBiometricDeviceStartSequence | Starts sequence which prepares device for multiple capture operations.


NCamera Unit

NCamera Unit
Functions Legend Structs, Records, Enums

Provides functions for working with cameras.

Collapse Expand Functions
Name | Description
NCameraAddStillCaptured | Adds user specified callback (controlling captured still image event) to NCamera.
NCameraAddStillCapturedCallback | ... more
NCameraCaptureStill | Gets still image from capture device (camera).
NCameraFocus | Adjusts camera focus.
NCameraGetCurrentStillFormat | Gets current still image format.
NCameraGetFocusRegion | Gets coordinates of rectangular camera focus area.
NCameraGetFrame | Gets current frame from the capture device.
NCameraGetFrameEx | Gets current frame from the capture device.
NCameraGetStillFormats | Gets still image formats supported by specified camera.
NCameraGetVideoSample | Gets video sample from the capture device.
NCameraIsFocusRegionSupported | Checks if focus region is supported on specified camera.
NCameraIsFocusSupported | Checks if specified camera supports autofocus.
NCameraIsStillCaptureSupported | Checks if still image obtain from camera is supported.
NCameraIsVideoSampleSupported | Checks whether video sample is supported.
NCameraRemoveStillCaptured | Removed user specified callback (controlling captured still image event) to NCamera.
NCameraRemoveStillCapturedCallback | ... more
NCameraResetFocus | Resets camera focus.
NCameraSetCurrentStillFormat | Sets current still image format.
NCameraSetFocusRegion | Sets coordinates of rectangular camera focus area.
Collapse Expand Structs, Records, Enums
Name | Description
NCameraStatus_ | Enumerates camera status values.
NCameraStatus | Enumerates camera status values.


NCameraAddStillCaptured Function

NCameraAddStillCaptured Function

Adds user specified callback (controlling captured still image event) to NCamera.

C++
NResult N_API NCameraAddStillCaptured(HNCamera hDevice, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNCamera hDevice | [in] Handle to NCamera object.
HNCallback hCallback | [in] Pointer to user defined function (callback) for handling captured still images.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCamera.h

Module: NCamera Unit


NCameraAddStillCapturedCallback Function

NCameraAddStillCapturedCallback Function

Adds user specified callback for captured still image event. It is called when still image is captured. User can specify how to handle captured image.

C++
NResult N_API NCameraAddStillCapturedCallback(HNCamera hDevice, NCameraStillCapturedCallback pCallback, void * pParam);
Collapse Expand Parameters
Parameters | Description
HNCamera hDevice | [in] Handle to NCamera object.
NCameraStillCapturedCallback pCallback | [in] Pointer to user defined function (callback) for handling captured still images.
void * pParam | [in] User data used by a callback function.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCamera.h

Module: NCamera Unit


NCameraCaptureStill Function

NCameraCaptureStill Function

Gets still image from capture device (camera).

C++
NResult N_API NCameraCaptureStill(HNCamera hDevice, NCameraStatus * pStatus);
Collapse Expand Parameters
Parameters | Description
HNCamera hDevice | [in] Handle to the NCamera object.
NCameraStatus * pStatus | [out] Camera status.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Notes

Captured still image (NImage) is retrieved by calling NCameraAddStillCapturedCallback (user defined function).

Container

File: NCamera.h

Module: NCamera Unit


NCameraFocus Function

NCameraFocus Function

Adjusts camera focus.

C++
NResult N_API NCameraFocus(HNCamera hDevice, NCameraStatus * pStatus);
Collapse Expand Parameters
Parameters | Description
HNCamera hDevice | [in] Handle to the NCamera object.
NCameraStatus * pStatus | [out] Camera status.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCamera.h

Module: NCamera Unit


NCameraGetCurrentStillFormat Function

NCameraGetCurrentStillFormat Function

Gets current still image format.

C++
NResult N_API NCameraGetCurrentStillFormat(HNCamera hDevice, HNVideoFormat * phFormat);
Collapse Expand Parameters
Parameters | Description
HNCamera hDevice | [in] Handle to the NCamera object.
HNVideoFormat * phFormat | [out] One of NVideoFormat values.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCamera.h

Module: NCamera Unit


NCameraGetFocusRegion Function

NCameraGetFocusRegion Function

Gets coordinates of rectangular camera focus area.

C++
NResult N_API NCameraGetFocusRegion(HNCamera hDevice, struct NRectF_ * pValue, NBool * pHasValue);
Collapse Expand Parameters
Parameters | Description
HNCamera hDevice | [in] Handle to the NCamera object.
struct NRectF_ * pValue | [out] NRectF type structure defining a rectangle of focus region.
NBool * pHasValue | [out] Nullable structure indicating if pValue has value. If pHasValue == NTrue, *pValue has a value. If pHasValue == NFalse, *pValue has not a value. If pHasValue == NULL, no value for *pValue was returned.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCamera.h

Module: NCamera Unit


NCameraGetFrame Function

NCameraGetFrame Function

Gets current frame from the capture device.

C++
NResult N_API NCameraGetFrame(HNCamera hDevice, HNImage * phImage);
Collapse Expand Parameters
Parameters | Description
HNCamera hDevice | [in] Handle to the Camera object.
HNImage * phImage | [out] Points to HNImage object which receives current frame from the camera.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

The function always returns recent frame only. I.e. if all the frames are required, the NCameraGetFrame function should be called often enough, otherwise the older frames are dropped.

Container

File: NCamera.h

Module: NCamera Unit


NCameraGetFrameEx Function

NCameraGetFrameEx Function

Gets current frame from the capture device.

C++
NResult N_API NCameraGetFrameEx(HNCamera hDevice, NTimeSpan_ * pTimeStamp, NTimeSpan_ * pDuration, HNImage * phImage);
Collapse Expand Parameters
Parameters | Description
HNCamera hDevice | [in] Handle to the Camera object.
NTimeSpan_ * pTimeStamp | [out] Frame time span.
NTimeSpan_ * pDuration | [out] Frame duration.
HNImage * phImage | [out] Points to HNImage object which receives current frame from the camera.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

The function always returns recent frame only. I.e. if all the frames are required, the NCameraGetFrame function should be called often enough, otherwise the older frames are dropped.

Container

File: NCamera.h

Module: NCamera Unit


NCameraGetStillFormats Function

NCameraGetStillFormats Function

Gets still image formats supported by specified camera.

C++
NResult N_API NCameraGetStillFormats(HNCamera hDevice, HNVideoFormat * * parhFormats, NInt * pFormatCount);
Collapse Expand Parameters
Parameters | Description
HNCamera hDevice | [in] Handle to the NCamera object.
HNVideoFormat * * parhFormats | [out] The allocated array of NVideoFormat structures describing all supported formats for the current capture device (camera).
NInt * pFormatCount | [out] Number of items returned in parhFormats.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCamera.h

Module: NCamera Unit


NCameraGetVideoSample Function

NCameraGetVideoSample Function

Gets video sample from the capture device.

C++
NResult N_API NCameraGetVideoSample(HNCamera hDevice, HNVideoSample * phSample);
Collapse Expand Parameters
Parameters | Description
HNCamera hDevice | [in] Handle to the NCamera object.
HNVideoSample * phSample | [out] Pointer to video sample object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCamera.h

Module: NCamera Unit


NCameraIsFocusRegionSupported Function

NCameraIsFocusRegionSupported Function

Checks if focus region is supported on specified camera.

C++
NResult N_API NCameraIsFocusRegionSupported(HNCamera hDevice, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNCamera hDevice | [in] Handle to the NCamera object.
NBool * pValue | [out] NBool type value indicating if focus region is supported on the camera.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCamera.h

Module: NCamera Unit


NCameraIsFocusSupported Function

NCameraIsFocusSupported Function

Checks if specified camera supports autofocus.

C++
NResult N_API NCameraIsFocusSupported(HNCamera hDevice, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNCamera hDevice | [in] Handle to the NCamera object.
NBool * pValue | [out] NBool type value indicating if autofocus is supported on the specified camera.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCamera.h

Module: NCamera Unit


NCameraIsStillCaptureSupported Function

NCameraIsStillCaptureSupported Function

Checks if still image obtain from camera is supported.

C++
NResult N_API NCameraIsStillCaptureSupported(HNCamera hDevice, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNCamera hDevice | [in] Handle to the NCamera object.
NBool * pValue | [out] NBool type value indicating if still image obtain is supported on the specified camera.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCamera.h

Module: NCamera Unit


NCameraIsVideoSampleSupported Function

NCameraIsVideoSampleSupported Function

Checks whether video sample is supported.

C++
NResult N_API NCameraIsVideoSampleSupported(HNCamera hDevice, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNCamera hDevice | [in] Handle to the NCamera object.
NBool * pValue | [out] Pointer to NBool which contain check result.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCamera.h

Module: NCamera Unit


NCameraRemoveStillCaptured Function

NCameraRemoveStillCaptured Function

Removed user specified callback (controlling captured still image event) to NCamera.

C++
NResult N_API NCameraRemoveStillCaptured(HNCamera hDevice, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNCamera hDevice | [in] Handle to NCamera object.
HNCallback hCallback | [in] Pointer to user defined function (callback) for handling captured still images.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCamera.h

Module: NCamera Unit


NCameraRemoveStillCapturedCallback Function

NCameraRemoveStillCapturedCallback Function
See Also

Removes user specified callback for captured still image event.

C++
NResult N_API NCameraRemoveStillCapturedCallback(HNCamera hDevice, NCameraStillCapturedCallback pCallback, void * pParam);
Collapse Expand Parameters
Parameters | Description
HNCamera hDevice | [in] Handle to NCamera object.
NCameraStillCapturedCallback pCallback | [in] Pointer to user defined function (callback) for handling captured still images.
void * pParam | [in] User data used by a callback function.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand See Also

NCameraRemoveStillCapturedCallback

Container

File: NCamera.h

Module: NCamera Unit


NCameraResetFocus Function

NCameraResetFocus Function

Resets camera focus.

C++
NResult N_API NCameraResetFocus(HNCamera hDevice);
Collapse Expand Parameters
Parameters | Description
HNCamera hDevice | [in] Handle to the NCamera object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCamera.h

Module: NCamera Unit


NCameraSetCurrentStillFormat Function

NCameraSetCurrentStillFormat Function

Sets current still image format.

C++
NResult N_API NCameraSetCurrentStillFormat(HNCamera hDevice, HNVideoFormat hFormat);
Collapse Expand Parameters
Parameters | Description
HNCamera hDevice | [in] Handle to the NCamera object.
HNVideoFormat hFormat | [in] One of NVideoFormat values.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCamera.h

Module: NCamera Unit


NCameraSetFocusRegion Function

NCameraSetFocusRegion Function

Sets coordinates of rectangular camera focus area.

C++
NResult N_API NCameraSetFocusRegion(HNCamera hDevice, const struct NRectF_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNCamera hDevice | [in] Handle to the NCamera object.
const struct NRectF_ * pValue | [in] NRectF type structure defining a rectangle of focus region.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCamera.h

Module: NCamera Unit


NCameraStatus Enumeration

NCameraStatus Enumeration

Enumerates camera status values.

C++
typedef enum NCameraStatus_ {
  ncsNone = 0,
  ncsOk = 1,
  ncsAutoFocusFailure = 2,
  ncsLensClosed = 3,
  ncsMirrorUp = 4,
  ncsSensorCleaning = 5,
  ncsSilentOperation = 6,
  ncsStroboCharge = 7,
  ncsNoLens = 8
} NCameraStatus;
Collapse Expand Members
Members | Description
ncsNone = 0 | Reserved for future use.
ncsOk = 1 | Indicates that camera is ready to use.
ncsAutoFocusFailure = 2 | Indicates that camera failed to auto focus an object.
ncsLensClosed = 3 | Indicates that camera lens are closed.
ncsMirrorUp = 4 | Indicates that camera mirror is up (when DSLR is used).
ncsSensorCleaning = 5 | Indicates that camera is performing sensor cleaning.
ncsSilentOperation = 6 | Indicates that camera is operating in silent mode.
ncsStroboCharge = 7 | Indicates that camera strobe is charging.
ncsNoLens = 8 | Indicates that no lens were attached to the camera.
Container

File: NCamera.h

Module: NCamera Unit


NCaptureDevice Unit

NCaptureDevice Unit
Functions Legend

Provides functions for working with capture devices.

Collapse Expand Functions
Name | Description
NCaptureDeviceAddIsCapturingChanged | Adds user specified callback (controlling capturing changed event) to NCaptureDevice.
NCaptureDeviceAddIsCapturingChangedCallback | Adds user specified callback (controlling capturing changed event) to NCaptureDevice.
NCaptureDeviceGetCurrentFormat | Gets current media format of the capture device.
NCaptureDeviceGetFormats | Gets all supported formats by the capture device.
NCaptureDeviceGetMediaType | Gets device media type.
NCaptureDeviceIsCapturing | Checks if the device is capturing.
NCaptureDeviceRemoveIsCapturingChanged | Removes user specified callback (controlling capturing changed event) from NCaptureDevice.
NCaptureDeviceRemoveIsCapturingChangedCallback | Removes user specified callback (controlling capturing changed event) from NCaptureDevice.
NCaptureDeviceSetCurrentFormat | Sets current media format for the capture device.
NCaptureDeviceStartCapturing | Starts capturing.
NCaptureDeviceStopCapturing | Stops capturing.


NCaptureDeviceAddIsCapturingChanged Function

NCaptureDeviceAddIsCapturingChanged Function

Adds user specified callback (controlling capturing changed event) to NCaptureDevice.

C++
NResult N_API NCaptureDeviceAddIsCapturingChanged(HNCaptureDevice hDevice, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNCaptureDevice hDevice | [in] Handle to the NCaptureDevice object.
HNCallback hCallback | [in] Pointer to user defined function (callback).
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCaptureDevice.h

Module: NCaptureDevice Unit


NCaptureDeviceAddIsCapturingChangedCallback Function

NCaptureDeviceAddIsCapturingChangedCallback Function

Adds user specified callback (controlling capturing changed event) to NCaptureDevice.

C++
NResult N_API NCaptureDeviceAddIsCapturingChangedCallback(HNCaptureDevice hDevice, NObjectCallback pCallback, void * pParam);
Collapse Expand Parameters
Parameters | Description
HNCaptureDevice hDevice | [in] Handle to the NCaptureDevice object.
NObjectCallback pCallback | [in] Pointer to user defined function (callback).
void * pParam | [in] User data used by a callback function.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCaptureDevice.h

Module: NCaptureDevice Unit


NCaptureDeviceGetCurrentFormat Function

NCaptureDeviceGetCurrentFormat Function
See Also

Gets current media format of the capture device.

C++
NResult N_API NCaptureDeviceGetCurrentFormat(HNCaptureDevice hDevice, HNMediaFormat * phFormat);
Collapse Expand Parameters
Parameters | Description
HNCaptureDevice hDevice | [in] Handle to the NCaptureDevice object.
HNMediaFormat * phFormat | [out] Current media format of capture device.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand See Also

See NMediaFormat unit for more information on how to retrieve information about media format from handle.

Container

File: NCaptureDevice.h

Module: NCaptureDevice Unit


NCaptureDeviceGetFormats Function

NCaptureDeviceGetFormats Function

Gets all supported formats by the capture device.

C++
NResult N_API NCaptureDeviceGetFormats(HNCaptureDevice hDevice, HNMediaFormat * * parhFormats, NInt * pFormatCount);
Collapse Expand Parameters
Parameters | Description
HNCaptureDevice hDevice | [in] Handle to the NCaptureDevice object.
HNMediaFormat * * parhFormats | [out] Address of the array pointer. The allocated array of NMediaFormat structures describing all supported formats for the current capture device.
NInt * pFormatCount | [out] Number of items returned in parhFormats.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCaptureDevice.h

Module: NCaptureDevice Unit


NCaptureDeviceGetMediaType Function

NCaptureDeviceGetMediaType Function

Gets device media type.

C++
NResult N_API NCaptureDeviceGetMediaType(HNCaptureDevice hDevice, NMediaType * pValue);
Collapse Expand Parameters
Parameters | Description
HNCaptureDevice hDevice | [in] Handle to the NCaptureDevice object.
NMediaType * pValue | [out] Device media type value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCaptureDevice.h

Module: NCaptureDevice Unit


NCaptureDeviceIsCapturing Function

NCaptureDeviceIsCapturing Function

Checks if the device is capturing.

C++
NResult N_API NCaptureDeviceIsCapturing(HNCaptureDevice hDevice, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNCaptureDevice hDevice | [in] Handle to the NCaptureDevice object.
NBool * pValue | [out] NBool type value which indicates if the specified NCaptureDevice is capturing media data.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCaptureDevice.h

Module: NCaptureDevice Unit


NCaptureDeviceRemoveIsCapturingChanged Function

NCaptureDeviceRemoveIsCapturingChanged Function

Removes user specified callback (controlling capturing changed event) from NCaptureDevice.

C++
NResult N_API NCaptureDeviceRemoveIsCapturingChanged(HNCaptureDevice hDevice, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNCaptureDevice hDevice | [in] Handle to the NCaptureDevice object.
HNCallback hCallback | [in] Pointer to user defined function (callback).
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCaptureDevice.h

Module: NCaptureDevice Unit


NCaptureDeviceRemoveIsCapturingChangedCallback Function

NCaptureDeviceRemoveIsCapturingChangedCallback Function

Removes user specified callback (controlling capturing changed event) from NCaptureDevice.

C++
NResult N_API NCaptureDeviceRemoveIsCapturingChangedCallback(HNCaptureDevice hDevice, NObjectCallback pCallback, void * pParam);
Collapse Expand Parameters
Parameters | Description
HNCaptureDevice hDevice | [in] Handle to the NCaptureDevice object.
NObjectCallback pCallback | [in] Pointer to user defined function (callback).
void * pParam | [in] User data used by a callback function.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCaptureDevice.h

Module: NCaptureDevice Unit


NCaptureDeviceSetCurrentFormat Function

NCaptureDeviceSetCurrentFormat Function

Sets current media format for the capture device.

C++
NResult N_API NCaptureDeviceSetCurrentFormat(HNCaptureDevice hDevice, HNMediaFormat hFormat);
Collapse Expand Parameters
Parameters | Description
HNCaptureDevice hDevice | [in] Handle to the NCaptureDevice object.
HNMediaFormat hFormat | [in] Current media format to set.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCaptureDevice.h

Module: NCaptureDevice Unit


NCaptureDeviceStartCapturing Function

NCaptureDeviceStartCapturing Function

Starts capturing.

C++
NResult N_API NCaptureDeviceStartCapturing(HNCaptureDevice hDevice);
Collapse Expand Parameters
Parameters | Description
HNCaptureDevice hDevice | [in] Handle to the NCaptureDevice object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCaptureDevice.h

Module: NCaptureDevice Unit


NCaptureDeviceStopCapturing Function

NCaptureDeviceStopCapturing Function

Stops capturing.

C++
NResult N_API NCaptureDeviceStopCapturing(HNCaptureDevice hDevice);
Collapse Expand Parameters
Parameters | Description
HNCaptureDevice hDevice | [in] Handle to the NCaptureDevice object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NCaptureDevice.h

Module: NCaptureDevice Unit


NDevice Unit

NDevice Unit
Files Functions Legend Structs, Records, Enums

Provides functionality for retrieving general device information.

Collapse Expand Files
Name | Description
NDevice.h | Header file for NDevice Module.
Collapse Expand Functions
Name | Description
NDeviceGetChild | Returns the child of the specified multimodal device.
NDeviceGetChildCount | Returns the child count of specified multimodal device.
NDeviceGetChildren | Gets all children of the specified multimodal device.
NDeviceGetDeviceType | Returns the type of specified multimodal device.
NDeviceGetDisplayNameN | Returns device name.
NDeviceGetIdN | Returns device Id,
NDeviceGetMakeN | Returns the manufacturer of the specified device.
NDeviceGetModelN | Returns model of current biometric device..
NDeviceGetParent | Returns the parent of specified multimodal device module.
NDeviceGetPlugin | Returns handle to device plugin.
NDeviceGetSerialNumberN | Returns serial number of current biometric device..
NDeviceIsAvailable | Checks if the device is available.
NDeviceIsDisconnectable | Checks if specified device can be disconnected.
NDeviceIsPrivate | Checks whether the specified device is private.
Collapse Expand Structs, Records, Enums
Name | Description
NDeviceType_ | Enumerates device type values.
NDeviceType | Enumerates device type values.


NDeviceGetChild Function

NDeviceGetChild Function
NDevice.h

Returns the child of the specified multimodal device.

C++
NResult N_API NDeviceGetChild(HNDevice hDevice, NInt index, HNDevice * phValue);
Collapse Expand Parameters
Parameters | Description
HNDevice hDevice | [in] Handle to NDevice to retrieve its child.
NInt index | [in] Index of child element.
HNDevice * phValue | [out] Pointer to HNDevice which receives child of multimodal device.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise error code is returned. NSucceeded or NFailed macros can be used to detect if the function succeeded or failed.

Collapse Expand Remarks

NObjectUnref shall be called on returned objects when they are no longer used to prevent memory leaks.

Container

File: NDevice.h

Module: NDevice Unit


NDeviceGetChildCount Function

NDeviceGetChildCount Function
NDevice.h

Returns the child count of specified multimodal device.

C++
NResult N_API NDeviceGetChildCount(HNDevice hDevice, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNDevice hDevice | [in] Handle to NDevice to retrieve its child count.
NInt * pValue | [out] Child count.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise error code is returned. NSucceeded or NFailed macros can be used to detect if the function succeeded or failed.

Container

File: NDevice.h

Module: NDevice Unit


NDeviceGetChildren Function

NDeviceGetChildren Function
NDevice.h

Gets all children of the specified multimodal device.

C++
NResult N_API NDeviceGetChildren(HNDevice hDevice, HNDevice * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNDevice hDevice | [in] Handle to NDevice to retrieve its children.
HNDevice * * parhValues | [out] Pointer to an array of device children.
NInt * pValueCount | [out] Pointer to the number of children in the array.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise error code is returned. NSucceeded or NFailed macros can be used to detect if the function succeeded or failed.

Container

File: NDevice.h

Module: NDevice Unit


NDeviceGetDeviceType Function

NDeviceGetDeviceType Function
NDevice.h

Returns the type of specified multimodal device.

C++
NResult N_API NDeviceGetDeviceType(HNDevice hDevice, NDeviceType * pValue);
Collapse Expand Parameters
Parameters | Description
HNDevice hDevice | [in] Handle to NDevice to retrieve its type.
NDeviceType * pValue | [out] Pointer to HNDevice which receives type multimodal device.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise error code is returned. NSucceeded or NFailed macros can be used to detect if the function succeeded or failed.

Container

File: NDevice.h

Module: NDevice Unit


NDeviceGetDisplayNameN Function

NDeviceGetDisplayNameN Function
NDevice.h

Returns device name.

C++
NResult N_API NDeviceGetDisplayNameN(HNDevice hDevice, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNDevice hDevice | [in] Handle to NDevice to retrieve its display name.
HNString * phValue | [out] Pointer to HNString which receives display name of the device.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise error code is returned. NSucceeded or NFailed macros can be used to detect if the function succeeded or failed.

Container

File: NDevice.h

Module: NDevice Unit


NDeviceGetIdN Function

NDeviceGetIdN Function
NDevice.h

Returns device Id,

C++
NResult N_API NDeviceGetIdN(HNDevice hDevice, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNDevice hDevice | [in] Handle to NDevice to retrieve its Id.
HNString * phValue | [out] Device Id.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise error code is returned. NSucceeded or NFailed macros can be used to detect if the function succeeded or failed.

Container

File: NDevice.h

Module: NDevice Unit


NDeviceGetMakeN Function

NDeviceGetMakeN Function
NDevice.h

Returns the manufacturer of the specified device.

C++
NResult N_API NDeviceGetMakeN(HNDevice hDevice, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNDevice hDevice | [in] Handle to NDevice to retrieve its manufacturer.
HNString * phValue | [out] Pointer to device manufacturer name.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise error code is returned. NSucceeded or NFailed macros can be used to detect if the function succeeded or failed.

Container

File: NDevice.h

Module: NDevice Unit


NDeviceGetModelN Function

NDeviceGetModelN Function
NDevice.h

Returns model of current biometric device..

C++
NResult N_API NDeviceGetModelN(HNDevice hDevice, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNDevice hDevice | [in] Handle to NDevice to retrieve its model.
HNString * phValue | [out] Pointer to device model.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise error code is returned. NSucceeded or NFailed macros can be used to detect if the function succeeded or failed.

Container

File: NDevice.h

Module: NDevice Unit


NDeviceGetParent Function

NDeviceGetParent Function
NDevice.h

Returns the parent of specified multimodal device module.

C++
NResult N_API NDeviceGetParent(HNDevice hDevice, HNDevice * phValue);
Collapse Expand Parameters
Parameters | Description
HNDevice hDevice | [in] Handle to NDevice to retrieve its parent.
HNDevice * phValue | [out] Pointer to HNDevice handle which receives parent of specified child device.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise error code is returned. NSucceeded or NFailed macros can be used to detect if the function succeeded or failed.

Collapse Expand Remarks

NObjectUnref shall be called on returned objects when they are no longer used to prevent memory leaks.

Container

File: NDevice.h

Module: NDevice Unit


NDeviceGetPlugin Function

NDeviceGetPlugin Function
NDevice.h

Returns handle to device plugin.

C++
NResult N_API NDeviceGetPlugin(HNDevice hDevice, HNPlugin * phValue);
Collapse Expand Parameters
Parameters | Description
HNDevice hDevice | [in] Handle to NDevice to retrieve its handle.
HNPlugin * phValue | [out] Pointer to HNPlugin handle which receives plugin of specified device.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise error code is returned. NSucceeded or NFailed macros can be used to detect if the function succeeded or failed.

Collapse Expand Remarks

NObjectUnref shall be called on returned objects when they are no longer used to prevent memory leaks.

Container

File: NDevice.h

Module: NDevice Unit


NDeviceGetSerialNumberN Function

NDeviceGetSerialNumberN Function
NDevice.h

Returns serial number of current biometric device..

C++
NResult N_API NDeviceGetSerialNumberN(HNDevice hDevice, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNDevice hDevice | [in] Handle to NDevice to retrieve its serial number.
HNString * phValue | [out] Pointer to device serial number.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise error code is returned. NSucceeded or NFailed macros can be used to detect if the function succeeded or failed.

Container

File: NDevice.h

Module: NDevice Unit


NDeviceIsAvailable Function

NDeviceIsAvailable Function
NDevice.h

Checks if the device is available.

C++
NResult N_API NDeviceIsAvailable(HNDevice hDevice, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNDevice hDevice | [in] Handle to NDevice to check if it is available.
NBool * pValue | [out] NBool value indicating whether or not specified device is available.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise error code is returned. NSucceeded or NFailed macros can be used to detect if the function succeeded or failed.

Container

File: NDevice.h

Module: NDevice Unit


NDeviceIsDisconnectable Function

NDeviceIsDisconnectable Function
NDevice.h

Checks if specified device can be disconnected.

C++
NResult N_API NDeviceIsDisconnectable(HNDevice hDevice, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNDevice hDevice | [in] Handle to NDevice.
NBool * pValue | [out] NBool value indicating whether or not specified device is disconnectable.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDevice.h

Module: NDevice Unit


NDeviceIsPrivate Function

NDeviceIsPrivate Function
NDevice.h

Checks whether the specified device is private.

C++
NResult N_API NDeviceIsPrivate(HNDevice hDevice, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNDevice hDevice | [in] Handle to the NDevice object to be checked.
NBool * pValue | [out] Pointer to a Boolean value: NTrue if the device is private; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDevice.h

Module: NDevice Unit


NDeviceType Enumeration

NDeviceType Enumeration
NDevice.h

Enumerates device type values.

C++
typedef enum NDeviceType_ {
  ndtNone = 0,
  ndtCamera = 0x01,
  ndtBiometricDevice = 0x02,
  ndtFScanner = 0x04,
  ndtFingerScanner = 0x08,
  ndtPalmScanner = 0x10,
  ndtIrisScanner = 0x20,
  ndtCaptureDevice = 0x40,
  ndtMicrophone = 0x80,
  ndtSignatureScanner = 0x100,
  ndtAny = 0x80000000
} NDeviceType;
Collapse Expand Members
Members | Description
ndtNone = 0 |
ndtCamera = 0x01 | Indicates that device type is camera.
ndtBiometricDevice = 0x02 |
ndtFScanner = 0x04 |
ndtFingerScanner = 0x08 | Indicates that device type is fingerprints scanner (ndtFScanner scanner which can also scan fingerprints).
ndtPalmScanner = 0x10 | Indicates that device type is palmprints scanner (ndtFScanner scanner which can also scan palmprints).
ndtIrisScanner = 0x20 | Indicates that device type is iris scanner.
ndtCaptureDevice = 0x40 |
ndtMicrophone = 0x80 | Indicates that device type is microphone.
ndtSignatureScanner = 0x100 | Indicates that device is signature scanner.
ndtAny = 0x80000000 |
Container

File: NDevice.h

Module: NDevice Unit


NDevice.h

NDevice.h
Enumerations Functions Legend

Header file for NDevice Module.

Collapse Expand Enumerations
Name | Description
NDeviceType_ | Enumerates device type values.
NDeviceType | Enumerates device type values.
Collapse Expand Functions
Name | Description
NDeviceGetChild | Returns the child of the specified multimodal device.
NDeviceGetChildCount | Returns the child count of specified multimodal device.
NDeviceGetChildren | Gets all children of the specified multimodal device.
NDeviceGetDeviceType | Returns the type of specified multimodal device.
NDeviceGetDisplayNameN | Returns device name.
NDeviceGetIdN | Returns device Id,
NDeviceGetMakeN | Returns the manufacturer of the specified device.
NDeviceGetModelN | Returns model of current biometric device..
NDeviceGetParent | Returns the parent of specified multimodal device module.
NDeviceGetPlugin | Returns handle to device plugin.
NDeviceGetSerialNumberN | Returns serial number of current biometric device..
NDeviceIsAvailable | Checks if the device is available.
NDeviceIsDisconnectable | Checks if specified device can be disconnected.
NDeviceIsPrivate | Checks whether the specified device is private.


NDeviceEventDescriptor Unit

NDeviceEventDescriptor Unit
Files Functions Legend

Provides functionality for creating device event descriptors.

Collapse Expand Files
Name | Description
NDeviceEventDescriptor.h | Header file for the NDeviceEventDescriptor module.
Collapse Expand Functions
Name | Description
NDeviceEventDescriptorCreate | Creates a new device event descriptor.


NDeviceEventDescriptorCreate Function

NDeviceEventDescriptorCreate Function
NDeviceEventDescriptor.h

Creates a new device event descriptor.

C++
NResult N_API NDeviceEventDescriptorCreate(HNString hName, HNType hEventType, NAttributes attributes, HNValue hData, HNCallback hAddHandler, HNCallback hRemoveHandler, HNDeviceEventDescriptor * phEventDescriptor);
Collapse Expand Parameters
Parameters | Description
HNString hName | [in] Handle to the descriptor name.
HNType hEventType | [in] Handle to the event type.
NAttributes attributes | [in] Descriptor attributes.
HNValue hData | [in] Handle to the descriptor data.
HNCallback hAddHandler | [in] Callback for "handler added" event.
HNCallback hRemoveHandler | [in] Callback for "handler removed" event.
HNDeviceEventDescriptor * phEventDescriptor | [out] Pointer to the new device event descriptor.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDeviceEventDescriptor.h

Module: NDeviceEventDescriptor Unit


NDeviceEventDescriptor.h

NDeviceEventDescriptor.h
Functions Legend

Header file for the NDeviceEventDescriptor module.

Collapse Expand Functions
Name | Description
NDeviceEventDescriptorCreate | Creates a new device event descriptor.


NDeviceManager Unit

NDeviceManager Unit
Files Functions Legend Macros

Provides functions for device enumeration (listing the devices available in the system) and getting events when device is added or removed.

Collapse Expand Files
Name | Description
NDeviceManager.h | Header file for NDeviceManager library. Provides general functions for working with devices.
Collapse Expand Functions
Name | Description
NDeviceManagerAddDevicesCollectionChanged | Adds a user specified "collection changed" event to NDeviceManager.
NDeviceManagerAddDevicesCollectionChangedCallback | Adds a user specified "collection changed" event callback to NDeviceManager.
NDeviceManagerConnectToDevice | Connects the device manager to a device.
NDeviceManagerConnectToDeviceWithString | Connects the device manager to a device.
NDeviceManagerCreateEx | Creates a new NDeviceManager.
NDeviceManagerDisconnectFromDevice | Disconnects the device manager from the specified device.
NDeviceManagerGetAutoPlug | Checks if a device can be auto-plugged to device manager.
NDeviceManagerGetBiometricEngine | Retrieves the biometric engine used by the specified device manager.
NDeviceManagerGetConnectToDeviceParameters | Retrieves device connection parameters.
NDeviceManagerGetDevice | Retrieves device by specified index.
NDeviceManagerGetDeviceById | Retrieves device by specified Id.
NDeviceManagerGetDeviceCount | Retrieves the count of connected devices.
NDeviceManagerGetDeviceTypes | Returns supported device types by specified NDeviceManager.
NDeviceManagerGetDevices | Retrieves all devices connected to the device manager.
NDeviceManagerGetPluginManager | Returns handle to NPluginManager.
NDeviceManagerInitialize | Initializes the specified device manager.
NDeviceManagerIsConnectToDeviceSupported | Checks whether specified device connection is supported.
NDeviceManagerIsInitialized | Checks whether the specialized device manager is initialized.
NDeviceManagerRemoveDevicesCollectionChanged | Removes a user specified "collection changed" event to NDeviceManager.
NDeviceManagerRemoveDevicesCollectionChangedCallback | Removes a user specified "collection changed" event callback to NDeviceManager.
NDeviceManagerSetAutoPlug | Sets if a device can be auto-plugged to device manager.
NDeviceManagerSetBiometricEngine | Sets the biometric engine used by the specified manager.
NDeviceManagerSetDeviceTypes | Sets the device type for the specified device manager.
Collapse Expand Macros
Name | Description
NDeviceManagerGetDeviceById | Picks a Unicode (W) or ANSCII (A) version of the NDeviceManagerGetDeviceById function.


NDeviceManagerAddDevicesCollectionChanged Function

NDeviceManagerAddDevicesCollectionChanged Function
NDeviceManager.h

Adds a user specified "collection changed" event to NDeviceManager.

C++
NResult N_API NDeviceManagerAddDevicesCollectionChanged(HNDeviceManager hDeviceManager, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNDeviceManager hDeviceManager | [in] Handle to NDeviceManager.
HNCallback hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDeviceManager.h

Module: NDeviceManager Unit


NDeviceManagerAddDevicesCollectionChangedCallback Function

NDeviceManagerAddDevicesCollectionChangedCallback Function
NDeviceManager.h

Adds a user specified "collection changed" event callback to NDeviceManager.

C++
NResult N_API NDeviceManagerAddDevicesCollectionChangedCallback(HNDeviceManager hDeviceManager, N_COLLECTION_CHANGED_CALLBACK_ARG(HNDevice, pCallback), void * pParam);
Collapse Expand Parameters
Parameters | Description
HNDeviceManager hDeviceManager | [in] Handle to NDeviceManager.
void * pParam | [in] User data used by a callback function.
_nt_ | _nt_
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDeviceManager.h

Module: NDeviceManager Unit


NDeviceManagerConnectToDevice Function

NDeviceManagerConnectToDevice Function
NDeviceManager.h

Connects the device manager to a device.

C++
NResult N_API NDeviceManagerConnectToDevice(HNDeviceManager hDeviceManager, HNPlugin hPlugin, HNPropertyBag hParameters, HNDevice * phDevice);
Collapse Expand Parameters
Parameters | Description
HNDeviceManager hDeviceManager | [in] Handle to the device manager.
HNPlugin hPlugin | [in] Handle to the device plugin.
HNPropertyBag hParameters | [in] Handle to the device parameters.
HNDevice * phDevice | [out] Pointer to the device handle.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDeviceManager.h

Module: NDeviceManager Unit


NDeviceManagerConnectToDeviceWithString Function

NDeviceManagerConnectToDeviceWithString Function
NDeviceManager.h

Connects the device manager to a device.

C++
NResult N_API NDeviceManagerConnectToDeviceWithString(HNDeviceManager hDeviceManager, const NChar * szPlugin, const NChar * szParameters, HNDevice * phDevice);
Collapse Expand Parameters
Parameters | Description
HNDeviceManager hDeviceManager | [in] Handle to the device manager.
const NChar * szPlugin | [in] Pointer to the device plugin string.
const NChar * szParameters | [in] Pointer to the device parameters string.
HNDevice * phDevice | [out] Pointer to the device handle.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDeviceManager.h

Module: NDeviceManager Unit


NDeviceManagerCreateEx Function

NDeviceManagerCreateEx Function
NDeviceManager.h

Creates a new NDeviceManager.

C++
NResult N_API NDeviceManagerCreateEx(HNDeviceManager * phDeviceManager);
Collapse Expand Parameters
Parameters | Description
HNDeviceManager * phDeviceManager | [out] Pointer to HNDeviceManager handle which receives created device.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise error code is returned. NSucceeded or NFailed macros can be used to detect if the function succeeded or failed.

Collapse Expand Notes

All created device managers use the same plugin manager (NDeviceManagerGetPluginManager function). It can be used to refresh the device manager plugins or to manually select which plugins should be activated.

Container

File: NDeviceManager.h

Module: NDeviceManager Unit


NDeviceManagerDisconnectFromDevice Function

NDeviceManagerDisconnectFromDevice Function
NDeviceManager.h

Disconnects the device manager from the specified device.

C++
NResult N_API NDeviceManagerDisconnectFromDevice(HNDeviceManager hDeviceManager, HNDevice hDevice);
Collapse Expand Parameters
Parameters | Description
HNDeviceManager hDeviceManager | [in] Handle to the device manager.
HNDevice hDevice | [in] Handle to the device to disconnect from.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDeviceManager.h

Module: NDeviceManager Unit


NDeviceManagerGetAutoPlug Function

NDeviceManagerGetAutoPlug Function
NDeviceManager.h

Checks if a device can be auto-plugged to device manager.

C++
NResult N_API NDeviceManagerGetAutoPlug(HNDeviceManager hDeviceManager, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNDeviceManager hDeviceManager | [in] Handle to the device manager.
NBool * pValue | [out] Check value. NTrue, if device can be auto-plugged; NFalse, otherwise.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDeviceManager.h

Module: NDeviceManager Unit


NDeviceManagerGetBiometricEngine Function

NDeviceManagerGetBiometricEngine Function
NDeviceManager.h

Retrieves the biometric engine used by the specified device manager.

C++
NResult N_API NDeviceManagerGetBiometricEngine(HNDeviceManager hDeviceManager, HNBiometricEngine * phValue);
Collapse Expand Parameters
Parameters | Description
HNDeviceManager hDeviceManager | [in] Handle to the device manager.
HNBiometricEngine * phValue | [in] Pointer to the biometric engine.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDeviceManager.h

Module: NDeviceManager Unit


NDeviceManagerGetConnectToDeviceParameters Function

NDeviceManagerGetConnectToDeviceParameters Function
NDeviceManager.h

Retrieves device connection parameters.

C++
NResult N_API NDeviceManagerGetConnectToDeviceParameters(HNPlugin hPlugin, HNParameterDescriptor * * parhParameters, NInt * pParameterCount);
Collapse Expand Parameters
Parameters | Description
HNPlugin hPlugin | [in] Handle to the connection plugin.
HNParameterDescriptor * * parhParameters | [out] Array of connection parameters.
NInt * pParameterCount | [out] Pointer to the number of parameters in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDeviceManager.h

Module: NDeviceManager Unit


NDeviceManagerGetDevice Function

NDeviceManagerGetDevice Function
NDeviceManager.h

Retrieves device by specified index.

C++
NResult N_API NDeviceManagerGetDevice(HNDeviceManager hDeviceManager, NInt index, HNDevice * phValue);
Collapse Expand Parameters
Parameters | Description
HNDeviceManager hDeviceManager | [in] Handle to NDeviceManager.
NInt index | [in] Device index within NDeviceManager.
HNDevice * phValue | [out] Pointer to HNDevice handle which receives device specified by index.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise error code is returned. NSucceeded or NFailed macros can be used to detect whether the function succeeded or failed.

Collapse Expand Remarks

NObjectUnref shall be called on returned objects when they are no longer used to prevent memory leaks.

Container

File: NDeviceManager.h

Module: NDeviceManager Unit


NDeviceManagerGetDeviceById Function

NDeviceManagerGetDeviceById Function
NDeviceManager.h

Retrieves device by specified Id.

C++
NResult N_API NDeviceManagerGetDeviceById(HNDeviceManager hDeviceManager, const NChar * szId, HNDevice * phValue);
Collapse Expand Parameters
Parameters | Description
HNDeviceManager hDeviceManager | [in] Handle to NDeviceManager.
const NChar * szId | [in] Device identifier.
HNDevice * phValue | [out] Pointer to HNDevice handle which receives device specified by Id.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise error code is returned. NSucceeded or NFailed macros can be used to detect whether the function succeeded or failed.

Collapse Expand Remarks

NObjectUnref shall be called on returned objects when they are no longer used to prevent memory leaks.

Container

File: NDeviceManager.h

Module: NDeviceManager Unit


NDeviceManagerGetDeviceCount Function

NDeviceManagerGetDeviceCount Function
NDeviceManager.h

Retrieves the count of connected devices.

C++
NResult N_API NDeviceManagerGetDeviceCount(HNDeviceManager hDeviceManager, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNDeviceManager hDeviceManager | [in] Handle to NDeviceManager.
NInt * pValue | [out] Connected devices count. If 0 is returned, it means that no devices are connected.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise error code is returned. NSucceeded or NFailed macros can be used to detect whether the function succeeded or failed.

Collapse Expand Notes

If NDeviceManagerCreate parameter autoPlug has NFalse value assigned, connected devices count is not updated when new device is connected.

Container

File: NDeviceManager.h

Module: NDeviceManager Unit


NDeviceManagerGetDeviceTypes Function

NDeviceManagerGetDeviceTypes Function
NDeviceManager.h

Returns supported device types by specified NDeviceManager.

C++
NResult N_API NDeviceManagerGetDeviceTypes(HNDeviceManager hDeviceManager, NDeviceType * pValue);
Collapse Expand Parameters
Parameters | Description
HNDeviceManager hDeviceManager | [in] Handle to NDeviceManager.
NDeviceType * pValue | [out] Pointer to NDeviceType enumeration which contains supported device types.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise error code is returned. NSucceeded or NFailed macros can be used to detect whether the function succeeded or failed.

Container

File: NDeviceManager.h

Module: NDeviceManager Unit


NDeviceManagerGetDevices Function

NDeviceManagerGetDevices Function
NDeviceManager.h

Retrieves all devices connected to the device manager.

C++
NResult N_API NDeviceManagerGetDevices(HNDeviceManager hDeviceManager, HNDevice * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNDeviceManager hDeviceManager | [in] Handel to the device manager.
HNDevice * * parhValues | [out] Pointer to an array of device handles.
NInt * pValueCount | [out] Pointer to the number of devices in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDeviceManager.h

Module: NDeviceManager Unit


NDeviceManagerGetPluginManager Function

NDeviceManagerGetPluginManager Function
NDeviceManager.h

Returns handle to NPluginManager.

C++
NResult N_API NDeviceManagerGetPluginManager(HNPluginManager * phValue);
Collapse Expand Parameters
Parameters | Description
HNPluginManager * phValue | [out] Pointer to handle of current device NPluginManager.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise error code is returned. NSucceeded or NFailed macros can be used to detect whether the function succeeded or failed.

Collapse Expand Remarks

NObjectUnref shall be called on returned objects when they are no longer used to prevent memory leaks.

Container

File: NDeviceManager.h

Module: NDeviceManager Unit


NDeviceManagerInitialize Function

NDeviceManagerInitialize Function
NDeviceManager.h

Initializes the specified device manager.

C++
NResult N_API NDeviceManagerInitialize(HNDeviceManager hDeviceManager);
Collapse Expand Parameters
Parameters | Description
HNDeviceManager hDeviceManager | [in] Handle to the device manager to initialize.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDeviceManager.h

Module: NDeviceManager Unit


NDeviceManagerIsConnectToDeviceSupported Function

NDeviceManagerIsConnectToDeviceSupported Function
NDeviceManager.h

Checks whether specified device connection is supported.

C++
NResult N_API NDeviceManagerIsConnectToDeviceSupported(HNPlugin hPlugin, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNPlugin hPlugin | [in] Handle to the connection plugin.
NBool * pValue | [out] NTrue if the connection is supported; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDeviceManager.h

Module: NDeviceManager Unit


NDeviceManagerIsInitialized Function

NDeviceManagerIsInitialized Function
NDeviceManager.h

Checks whether the specialized device manager is initialized.

C++
NResult N_API NDeviceManagerIsInitialized(HNDeviceManager hDeviceManager, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNDeviceManager hDeviceManager | [in] Handle to the device manager.
NBool * pValue | [out] NTrue if the device manager is initialized; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDeviceManager.h

Module: NDeviceManager Unit


NDeviceManagerRemoveDevicesCollectionChanged Function

NDeviceManagerRemoveDevicesCollectionChanged Function
NDeviceManager.h

Removes a user specified "collection changed" event to NDeviceManager.

C++
NResult N_API NDeviceManagerRemoveDevicesCollectionChanged(HNDeviceManager hDeviceManager, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNDeviceManager hDeviceManager | [in] Handle to NDeviceManager.
HNCallback hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDeviceManager.h

Module: NDeviceManager Unit


NDeviceManagerRemoveDevicesCollectionChangedCallback Function

NDeviceManagerRemoveDevicesCollectionChangedCallback Function
NDeviceManager.h

Removes a user specified "collection changed" event callback to NDeviceManager.

C++
NResult N_API NDeviceManagerRemoveDevicesCollectionChangedCallback(HNDeviceManager hDeviceManager, N_COLLECTION_CHANGED_CALLBACK_ARG(HNDevice, pCallback), void * pParam);
Collapse Expand Parameters
Parameters | Description
HNDeviceManager hDeviceManager | [in] Handle to NDeviceManager.
void * pParam | [in] User data used by a callback function.
_nt_ | _nt_
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDeviceManager.h

Module: NDeviceManager Unit


NDeviceManagerSetAutoPlug Function

NDeviceManagerSetAutoPlug Function
NDeviceManager.h

Sets if a device can be auto-plugged to device manager.

C++
NResult N_API NDeviceManagerSetAutoPlug(HNDeviceManager hDeviceManager, NBool value);
Collapse Expand Parameters
Parameters | Description
HNDeviceManager hDeviceManager | [in] Handle to the device manager.
NBool value | [in] NTrue, if device can be auto-plugged; NFalse, otherwise.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDeviceManager.h

Module: NDeviceManager Unit


NDeviceManagerSetBiometricEngine Function

NDeviceManagerSetBiometricEngine Function
NDeviceManager.h

Sets the biometric engine used by the specified manager.

C++
NResult N_API NDeviceManagerSetBiometricEngine(HNDeviceManager hDeviceManager, HNBiometricEngine hValue);
Collapse Expand Parameters
Parameters | Description
HNDeviceManager hDeviceManager | [in] Handle to the device manager.
HNBiometricEngine hValue | [in] Handle to the biometric engine.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDeviceManager.h

Module: NDeviceManager Unit


NDeviceManagerSetDeviceTypes Function

NDeviceManagerSetDeviceTypes Function
NDeviceManager.h

Sets the device type for the specified device manager.

C++
NResult N_API NDeviceManagerSetDeviceTypes(HNDeviceManager hDeviceManager, NDeviceType value);
Collapse Expand Parameters
Parameters | Description
HNDeviceManager hDeviceManager | [in] Handle to the device manager.
NDeviceType value | [in] NDeviceType value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDeviceManager.h

Module: NDeviceManager Unit


NDeviceManagerGetDeviceById Macro

NDeviceManagerGetDeviceById Macro
NDeviceManager.h

Picks a Unicode (W) or ANSCII (A) version of the NDeviceManagerGetDeviceById function.

C++
#define NDeviceManagerGetDeviceById N_FUNC_AW(NDeviceManagerGetDeviceById)
Container

File: NDeviceManager.h

Module: NDeviceManager Unit


NDeviceManager.h

NDeviceManager.h
Functions Legend Macros

Header file for NDeviceManager library. Provides general functions for working with devices.

Collapse Expand Functions
Name | Description
NDeviceManagerAddDevicesCollectionChanged | Adds a user specified "collection changed" event to NDeviceManager.
NDeviceManagerAddDevicesCollectionChangedCallback | Adds a user specified "collection changed" event callback to NDeviceManager.
NDeviceManagerConnectToDevice | Connects the device manager to a device.
NDeviceManagerConnectToDeviceWithString | Connects the device manager to a device.
NDeviceManagerCreateEx | Creates a new NDeviceManager.
NDeviceManagerDisconnectFromDevice | Disconnects the device manager from the specified device.
NDeviceManagerGetAutoPlug | Checks if a device can be auto-plugged to device manager.
NDeviceManagerGetBiometricEngine | Retrieves the biometric engine used by the specified device manager.
NDeviceManagerGetConnectToDeviceParameters | Retrieves device connection parameters.
NDeviceManagerGetDevice | Retrieves device by specified index.
NDeviceManagerGetDeviceById | Retrieves device by specified Id.
NDeviceManagerGetDeviceCount | Retrieves the count of connected devices.
NDeviceManagerGetDeviceTypes | Returns supported device types by specified NDeviceManager.
NDeviceManagerGetDevices | Retrieves all devices connected to the device manager.
NDeviceManagerGetPluginManager | Returns handle to NPluginManager.
NDeviceManagerInitialize | Initializes the specified device manager.
NDeviceManagerIsConnectToDeviceSupported | Checks whether specified device connection is supported.
NDeviceManagerIsInitialized | Checks whether the specialized device manager is initialized.
NDeviceManagerRemoveDevicesCollectionChanged | Removes a user specified "collection changed" event to NDeviceManager.
NDeviceManagerRemoveDevicesCollectionChangedCallback | Removes a user specified "collection changed" event callback to NDeviceManager.
NDeviceManagerSetAutoPlug | Sets if a device can be auto-plugged to device manager.
NDeviceManagerSetBiometricEngine | Sets the biometric engine used by the specified manager.
NDeviceManagerSetDeviceTypes | Sets the device type for the specified device manager.
Collapse Expand Macros
Name | Description
NDeviceManagerGetDeviceById | Picks a Unicode (W) or ANSCII (A) version of the NDeviceManagerGetDeviceById function.


NDeviceMethodDescriptor Unit

NDeviceMethodDescriptor Unit
Files Functions Legend

Provides functionality for creating device method descriptors.

Collapse Expand Files
Name | Description
NDeviceMethodDescriptor.h | Header file for the NDeviceMethodDescriptor module.
Collapse Expand Functions
Name | Description
NDeviceMethodDescriptorCreate | Creates a new device method descriptor.


NDeviceMethodDescriptorCreate Function

NDeviceMethodDescriptorCreate Function
NDeviceMethodDescriptor.h

Creates a new device method descriptor.

C++
NResult N_API NDeviceMethodDescriptorCreate(HNString hName, NAttributes attributes, HNCustomParameterDescriptor hReturnParameter, HNCustomParameterDescriptor * arhParameters, NInt parameterCount, HNValue hData, HNCallback hInvoke, HNDeviceMethodDescriptor * phMethodDescriptor);
Collapse Expand Parameters
Parameters | Description
HNString hName | [in] Handle to the descriptor name.
NAttributes attributes | [in] Descriptor attributes.
HNCustomParameterDescriptor hReturnParameter | [in] Handle to the method's returned parameter descriptor.
HNCustomParameterDescriptor * arhParameters | [in/out] Pointer to an array of the method's parameters.
NInt parameterCount | [in] Number of parameters in the array.
HNValue hData | [in] Handle to the descriptor data.
HNCallback hInvoke | [in] Handle to the "method invoked" event callback.
HNDeviceMethodDescriptor * phMethodDescriptor | [out] Pointer to the new device method descriptor.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDeviceMethodDescriptor.h

Module: NDeviceMethodDescriptor Unit


NDeviceMethodDescriptor.h

NDeviceMethodDescriptor.h
Functions Legend

Header file for the NDeviceMethodDescriptor module.

Collapse Expand Functions
Name | Description
NDeviceMethodDescriptorCreate | Creates a new device method descriptor.


NDevicePropertyDescriptor Unit

NDevicePropertyDescriptor Unit
Files Functions Legend

Provides functionality for creating device property descriptors.

Collapse Expand Files
Name | Description
NDevicePropertyDescriptor.h | Header file for the NDevicePropertyDescriptor module.
Collapse Expand Functions
Name | Description
NDevicePropertyDescriptorCreate | Creates a new device property descriptor.


NDevicePropertyDescriptorCreate Function

NDevicePropertyDescriptorCreate Function
NDevicePropertyDescriptor.h

Creates a new device property descriptor.

C++
NResult N_API NDevicePropertyDescriptorCreate(HNString hName, HNType hPropertyType, NAttributes attributes, HNString hFormat, HNValue hDefaultValue, HNValue hMinValue, HNValue hMaxValue, const struct NNameValuePair_ * arStdValues, NInt stdValueCount, HNValue hData, HNCallback hGetValue, HNCallback hSetValue, HNCallback hResetValue, HNDevicePropertyDescriptor * phPropertyDescriptor);
Collapse Expand Parameters
Parameters | Description
HNString hName | [in] Handle to the descriptor name.
HNType hPropertyType | [in] Handle to the property type.
NAttributes attributes | [in] Descriptor attributes.
HNString hFormat | [in] Handle to the descriptor format.
HNValue hDefaultValue | [in] Handle to the default property value.
HNValue hMinValue | [in] Minimum property value.
HNValue hMaxValue | [in] Maximum property value.
const struct NNameValuePair_ * arStdValues | [in] Pointer to an array of standard values.
NInt stdValueCount | [in] Number of standard values.
HNValue hData | [in] Handle to the descriptor data.
HNCallback hGetValue | [in] Handle to "value retrieved" event callback.
HNCallback hSetValue | [in] Handle to "value set" event callback.
HNCallback hResetValue | [in] Handle to "value reset" event callback.
HNDevicePropertyDescriptor * phPropertyDescriptor | [out] Pointer to the new device property descriptor.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NDevicePropertyDescriptor.h

Module: NDevicePropertyDescriptor Unit


NDevicePropertyDescriptor.h

NDevicePropertyDescriptor.h
Functions Legend

Header file for the NDevicePropertyDescriptor module.

Collapse Expand Functions
Name | Description
NDevicePropertyDescriptorCreate | Creates a new device property descriptor.


NDevices Unit

NDevices Unit

Provides information about NDevices library.


NLicensing Library

NLicensing Library

Provides functionality for getting, releasing licenses.

Collapse Expand Remarks
Requirements (Windows)
  • Import Library: NLicensing.dll.lib
  • DLLs: NLicensing.dll

Requirements (Linux)

  • Shared objects: libNLicensing.so

Collapse Expand Modules
Name | Description
NLicense Unit | Main functions for working with licenses.
NLicenseInfo Unit | Provides functionality for license info retrieval.
NLicenseManager Unit | Provides functionality for licenses management.
NLicensing Unit | Provides functionality for getting, releasing licenses.
NLicensingService Unit | Manages licensing services.


NLicense Unit

NLicense Unit
Files Functions Legend Macros Structs, Records, Enums

Main functions for working with licenses.

Collapse Expand Files
Name | Description
NLicense.h | Header file for the NLicense library. Provides internal license functionality.
Collapse Expand Functions
Name | Description
NLicenseActivateOnline | ... more
NLicenseAdd | Adds the activated license content (the content of *.lic file) to be used in application.
NLicenseDeactivateOnline | ... more
NLicenseDeactivateOnlineWithId | ... more
NLicenseGenerateDeactivationId | Generates deactivation Id for specified provided product on current computer.
NLicenseGenerateDeactivationIdForLicense | Generates deactivation Id for specified license on current computer.
NLicenseGenerateId | Generates Id for activation from serial number for a particular machine.
NLicenseGetLicenseInfoOnline | Retrieves info online about specified license.
NLicenseGetObtainedComponentStatus | Gets licensing status for obtained component.
NLicenseGetObtainedLicenseInfo | Retrieves information about obtained license.
NLicenseGetObtainedLicenseInfoForComponent | Retrieves information about obtained license for component.
NLicenseGetObtainedStatus | Gets licensing status for the specified product.
NLicenseIsComponentActivated | Checks if component specified by name is activated.
NLicenseObtain | Obtains product license from the specified server.
NLicenseObtainComponents | Obtains component license from the specified server.
NLicenseRelease | Releases license.
NLicenseReleaseComponents | Releases component license.
Collapse Expand Macros
Name | Description
NLicenseActivateOnline | Picks a Unicode (W) or ANSCII (A) version of the NLicenseActivateOnline function.
NLicenseAdd | Picks a Unicode (W) or ANSCII (A) version of the NLicenseAdd function.
NLicenseDeactivateOnline | Picks a Unicode (W) or ANSCII (A) version of the NLicenseDeactivateOnline function.
NLicenseDeactivateOnlineWithId | Picks a Unicode (W) or ANSCII (A) version of the NLicenseDeactivateOnlineWithId function.
NLicenseGenerateDeactivationId | Picks a Unicode (W) or ANSCII (A) version of the NLicenseGenerateDeactivationId function.
NLicenseGenerateDeactivationIdForLicense | Picks a Unicode (W) or ANSCII (A) version of the NLicenseGenerateDeactivationIdForLicense function.
NLicenseGenerateId | Picks a Unicode (W) or ANSCII (A) version of the NLicenseGenerateId function.
NLicenseGetLicenseInfoOnline | Picks a Unicode (W) or ANSCII (A) version of the NLicenseGetLicenseInfoOnline function.
NLicenseGetObtainedComponentStatus | Picks a Unicode (W) or ANSCII (A) version of the NLicenseGetObtainedComponentStatus function.
NLicenseGetObtainedLicenseInfo | Picks a Unicode (W) or ANSCII (A) version of the NLicenseGetObtainedLicenseInfo function.
NLicenseGetObtainedLicenseInfoForComponent | Picks a Unicode (W) or ANSCII (A) version of the NLicenseGetObtainedLicenseInfoForComponent function.
NLicenseGetObtainedStatus | Picks a Unicode (W) or ANSCII (A) version of the NLicenseGetObtainedStatus function.
NLicenseIsComponentActivated | Picks a Unicode (W) or ANSCII (A) version of the NLicenseIsComponentActivated function.
NLicenseObtainComponents | Picks a Unicode (W) or ANSCII (A) version of the NLicenseObtainComponents function.
NLicenseReleaseComponents | Picks a Unicode (W) or ANSCII (A) version of the NLicenseReleaseComponents function.
Collapse Expand Structs, Records, Enums
Name | Description
NLicenseObtainedStatus_ | Enumerates licensing status values.
NLicenseObtainedStatus | Enumerates licensing status values.


NLicenseActivateOnline Function

NLicenseActivateOnline Function
NLicense.h

Activates specified Id (that was obtained through calling NLicenseGenerateId function or using ActivationWizardDotNet) and obtains license file for this Id via internet.

C++
NResult N_API NLicenseActivateOnline(const NChar * szId, NChar ** pszLicense);
Collapse Expand Parameters
Parameters | Description
const NChar * szId | [in] Id generated from serial number.
NChar ** pszLicense | [out] Char buffer that contains activated license data.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. If an error appears one of NError value is returned.

Collapse Expand Remarks

Important! Internet connection is required for this function to succeed.

NLicenseActivateOnline returns internally allocated char array for activated license (pszLicense). pszLicense must be freed using NObjectUnref function from NCore library after it is no longer used.

Container

File: NLicense.h

Module: NLicense Unit


NLicenseAdd Function

NLicenseAdd Function
NLicense.h

Adds the activated license content (the content of *.lic file) to be used in application.

C++
NResult N_API NLicenseAdd(const NChar * szLicense);
Collapse Expand Parameters
Parameters | Description
const NChar * szLicense | [in] Zero-terminated string containing activated license content.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicense.h

Module: NLicense Unit


NLicenseDeactivateOnline Function

NLicenseDeactivateOnline Function
NLicense.h

Deactivates specified license via internet using specified Id generator.

C++
NResult N_API NLicenseDeactivateOnline(const NChar * szIdGenPath, const NChar * szLicense);
Collapse Expand Parameters
Parameters | Description
const NChar * szIdGenPath | [in] Reserved, must be NULL.
const NChar * szLicense | [in] Char buffer that contains activated license's full product name OR license file content.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. If an error appears one of NError value is returned.

Container

File: NLicense.h

Module: NLicense Unit


NLicenseDeactivateOnlineWithId Function

NLicenseDeactivateOnlineWithId Function
NLicense.h

Deactivates specified license via internet using specified deactivation Id.

C++
NResult N_API NLicenseDeactivateOnlineWithId(const NChar * szLicense, const NChar * szDeactivationId);
Collapse Expand Parameters
Parameters | Description
const NChar * szLicense | [in] Char buffer that contains activated license name.
const NChar * szDeactivationId | [in] Deactivation Id.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. If an error appears one of NError value is returned.

Collapse Expand Remarks

Important! Both license and generated deactivation Id should be sent to support@neurotechnology.com in order to complete deactivation process. Deactivation on Neurotechnology side is done manually.

Important! Deactivation must be performed on the same computer supplied license was generated for. If license is deactivated on another computer, although call to this function will succeed, but deactivation might be refused by support@neurotechnology.com.

Important! If function succeeds - license will be deactivated on this computer and will not be usable.

Collapse Expand Notes

Deactivation Id for product can be retrieved using NLicenseGenerateDeactivationId function.

Container

File: NLicense.h

Module: NLicense Unit


NLicenseGenerateDeactivationId Function

NLicenseGenerateDeactivationId Function
NLicense.h

Generates deactivation Id for specified provided product on current computer.

C++
NResult N_API NLicenseGenerateDeactivationId(const NChar * szIdGenPath, const NChar * szProductName, NChar ** pszDeactivationId);
Collapse Expand Parameters
Parameters | Description
const NChar * szIdGenPath | [in] Reserved, must be NULL.
const NChar * szProductName | [in] Long product name (i.e. Face Extractor, Finger Matcher and etc.).
NChar ** pszDeactivationId | [out] Generated deactivation Id.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. If an error appears one of NError value is returned.

Collapse Expand Remarks

Important! Both license and generated deactivation Id should be sent to support@neurotechnology.com in order to complete deactivation process. Deactivation on Neurotechnology side is done manually.

Important! Deactivation must be performed on the same computer supplied license was generated for. If license is deactivated on another computer, although call to this function will succeed, but deactivation might be refused by support@neurotechnology.com.

Important! If function succeeds - license will be deactivated on this computer and will not be usable.

NLicenseGenerateDeactivationId returns internally allocated char array for generated Id (pszDeactivationId). pszDeactivationId must be freed using NObjectFree function from NCore library after it is no longer used.

Container

File: NLicense.h

Module: NLicense Unit


NLicenseGenerateDeactivationIdForLicense Function

NLicenseGenerateDeactivationIdForLicense Function
NLicense.h

Generates deactivation Id for specified license on current computer.

C++
NResult N_API NLicenseGenerateDeactivationIdForLicense(const NChar * szIdGenPath, const NChar * szLicense, NChar ** pszDeactivationId);
Collapse Expand Parameters
Parameters | Description
const NChar * szIdGenPath | [in] Reserved, must be NULL.
const NChar * szLicense | [in] License to be deactivated.
NChar ** pszDeactivationId | [out] Generated deactivation Id.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. If an error appears one of NError value is returned.

Collapse Expand Remarks

Important! Internet connection is required for this function to succeed.

Important! Both license and generated deactivation Id should be sent to support@neurotechnology.com in order to complete deactivation process. Deactivation on Neurotechnology side is done manually.

Important! Deactivation must be performed on the same computer supplied license was generated for. If license is deactivated on another computer, although call to this function will succeed, but deactivation might be refused by support@neurotechnology.com.

NLicenseGenerateDeactivationIdForLicense returns internally allocated char array for generated Id (pszDeactivationId). pszDeactivationId must be freed using NObjectUnref function from NCore library after it is no longer used.

Container

File: NLicense.h

Module: NLicense Unit


NLicenseGenerateId Function

NLicenseGenerateId Function
Example NLicense.h

Generates Id for activation from serial number for a particular machine.

C++
NResult N_API NLicenseGenerateId(const NChar * szIdGenPath, const NChar * szSerial, NChar ** pszId);
Collapse Expand Parameters
Parameters | Description
const NChar * szIdGenPath | [in] Reserved, must be NULL.
const NChar * szSerial | [in] Serial number used for generating Id.
NChar ** pszId | [out] Generated Id.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. If an error appears one of NError value is returned.

Collapse Expand Remarks

NLicenseGenerateId returns internally allocated char array for generated Id (pszId). pszId must be freed using NObjectUnref function from NCore library after it is no longer used.

Collapse Expand Example
Copy Code
NChar * szSerial = N_T("3502-266E-60C6-6738-7D1C-3872-5AD8-3C42");
NChar * szId = NULL;
NGenerateId(N_T("d:\\Activation\\id_gen.exe"), szSerial, &szId);
Container

File: NLicense.h

Module: NLicense Unit


NLicenseGetLicenseInfoOnline Function

NLicenseGetLicenseInfoOnline Function
NLicense.h

Retrieves info online about specified license.

C++
NResult N_API NLicenseGetLicenseInfoOnline(const NChar * szLicense, HNLicenseInfo * phLicenseInfo);
Collapse Expand Parameters
Parameters | Description
const NChar * szLicense | [in] Zero terminated string which contains license content.
HNLicenseInfo * phLicenseInfo | [out] Pointer to NLicenseInfo structure.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. If an error appears one of NError value is returned.

Container

File: NLicense.h

Module: NLicense Unit


NLicenseGetObtainedComponentStatus Function

NLicenseGetObtainedComponentStatus Function
NLicense.h

Gets licensing status for obtained component.

C++
NResult N_API NLicenseGetObtainedComponentStatus(const NChar * szAddress, const NChar * szPort, const NChar * szComponent, NLicenseObtainedStatus * pStatus);
Collapse Expand Parameters
Parameters | Description
const NChar * szAddress | [in] Zero-terminated string containing an address of licensing server.
const NChar * szPort | [in] Zero-terminated string containing a port of licensing server.
const NChar * szComponent | [in] Zero-terminated string containing component name.
NLicenseObtainedStatus * pStatus | [out] Pointer to NLicenseObtainedStatus containing licensing status for the specified component (unknown status, license obtained, license not obtained or licensing server is offline).
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

Even if the license for the specified component was obtained, this license may become unavailable or the remote server is disconnected. Use this function to get the current status for the license of the specified component.

Note: NLicensing automatically tries to reobtain the license in case of failure, so failure status may change to nlosLicenseObtained.

Container

File: NLicense.h

Module: NLicense Unit


NLicenseGetObtainedLicenseInfo Function

NLicenseGetObtainedLicenseInfo Function
NLicense.h

Retrieves information about obtained license.

C++
NResult N_API NLicenseGetObtainedLicenseInfo(const NChar * szProduct, HNLicenseInfo * phLicenseInfo);
Collapse Expand Parameters
Parameters | Description
const NChar * szProduct | [in] Zero terminated string which contains license name.
HNLicenseInfo * phLicenseInfo | [out] Pointer to NLicenseInfo structure.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicense.h

Module: NLicense Unit


NLicenseGetObtainedLicenseInfoForComponent Function

NLicenseGetObtainedLicenseInfoForComponent Function
NLicense.h

Retrieves information about obtained license for component.

C++
NResult N_API NLicenseGetObtainedLicenseInfoForComponent(const NChar * szComponent, HNLicenseInfo * phLicenseInfo);
Collapse Expand Parameters
Parameters | Description
const NChar * szComponent | [in] Zero terminated string which contains license name.
HNLicenseInfo * phLicenseInfo | [out] Pointer to NLicenseInfo structure.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicense.h

Module: NLicense Unit


NLicenseGetObtainedStatus Function

NLicenseGetObtainedStatus Function
NLicense.h

Gets licensing status for the specified product.

C++
NResult N_API NLicenseGetObtainedStatus(const NChar * szAddress, const NChar * szPort, const NChar * szProduct, NLicenseObtainedStatus * pStatus);
Collapse Expand Parameters
Parameters | Description
const NChar * szAddress | [in] Zero-terminated string containing an address of licensing server.
const NChar * szPort | [in] Zero-terminated string containing a port of licensing server.
const NChar * szProduct | [in] Zero-terminated string containing product name.
NLicenseObtainedStatus * pStatus | [out] Pointer to NLicenseObtainedStatus containing licensing status for the specified product (unknown status, license obtained, license not obtained or licensing server is offline).
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

Even if the license for the specified product was obtained, this license may become unavailable or the remote server is disconnected. Use this function to get the current status for the license of the specified product.

Note: NLicensing automatically tries to reobtain the license in case of failure, so failure status may change to nlosLicenseObtained.

Container

File: NLicense.h

Module: NLicense Unit


NLicenseIsComponentActivated Function

NLicenseIsComponentActivated Function
NLicense.h

Checks if component specified by name is activated.

C++
NResult N_API NLicenseIsComponentActivated(const NChar * szName, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
const NChar * szName | [in] Zero terminated string which contains component name. See NLicenseObtainComponents function remarks for the list of supported component names for this parameter.
NBool * pValue | [out] NBool value indicating if the component was activated.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. If application working folder does not contain required files, N_E_FILE_NOT_FOUND error is thrown.

Container

File: NLicense.h

Module: NLicense Unit


NLicenseObtain Function

NLicenseObtain Function
NLicense.h

Obtains product license from the specified server.

C++
NResult N_API NLicenseObtain(const NChar * szAddress, const NChar * szPort, const NChar * szProducts, NBool * pAvailable);
Collapse Expand Parameters
Parameters | Description
const NChar * szAddress | [in] Server address where license manager is installed as a server. License manager can be in the same or in other computer. /local used when license is tied with the computer using serial number.
const NChar * szPort | [in] License manager server port.
const NChar * szProducts | [in] Zero terminated string which contains license name. For a complete list of available values for this parameter see Remarks section.
NBool * pAvailable | [out] Returns NTrue if license available; otherwise, NFalse.
Collapse Expand Returns

If the function succeeds, the return value is N_OK.

If the function fails, the return value is one of the following error codes:

Error code | Condition
N_E_ARGUMENT_NULL | szAddress, szPort, szProducts or pAvailable is NULL.
N_E_FORMAT | szProducts incorrect format.
N_E_FAILED | Unspecified error has occurred.
Collapse Expand Remarks

These values are available for szProducts parameter:

  • SingleComputerLicense:VeriFinger
  • SingleComputerLicense:VeriLook
  • SingleComputerLicense:FingerCell
  • SingleComputerLicense:FaceCell

  • SingleComputerLicense:FingersCardExtractor
  • SingleComputerLicense:FacesCardExtractor

  • SingleComputerLicense:Special
  • SingleComputerLicense:Cluster
  • SingleComputerLicense:Server

  • SingleComputerLicense:FingerCapturer
  • SingleComputerLicense:FingerExtractor
  • SingleComputerLicense:FingerCardExtractor
  • SingleComputerLicense:FingerMatcher
  • SingleComputerLicense:FingerFastMatcher
  • SingleComputerLicense:FingerSegmenter
  • SingleComputerLicense:WSQ
  • SingleComputerLicense:FingerBSS
  • SingleComputerLicense:FingerClient

  • SingleComputerLicense:FaceCapturer
  • SingleComputerLicense:FaceExtractor
  • SingleComputerLicense:FaceCardExtractor
  • SingleComputerLicense:FaceMatcher
  • SingleComputerLicense:FaceFastMatcher
  • SingleComputerLicense:FaceBSS
  • SingleComputerLicense:FaceClient

  • SingleComputerLicense:IrisCapturer
  • SingleComputerLicense:IrisExtractor
  • SingleComputerLicense:IrisCardExtractor
  • SingleComputerLicense:IrisMatcher
  • SingleComputerLicense:IrisFastMatcher
  • SingleComputerLicense:IrisBSS
  • SingleComputerLicense:IrisClient

  • SingleComputerLicense:PalmCapturer
  • SingleComputerLicense:PalmMatcher
  • SingleComputerLicense:PalmClient

  • SingleComputerLicense:VoiceCapturer
  • SingleComputerLicense:VoiceExtractor
  • SingleComputerLicense:VoiceMatcher
  • SingleComputerLicense:VoiceClient

  • SingleComputerLicense:MMAFingerEx
  • SingleComputerLicense:MMAFinger
  • SingleComputerLicense:MMAIrisEx
  • SingleComputerLicense:MMAIris
  • SingleComputerLicense:MMAFaceEx
  • SingleComputerLicense:MMAFace
  • SingleComputerLicense:MMAFaceDev
  • SingleComputerLicense:MMAFingerDev
  • SingleComputerLicense:MMAIrisDev

  • SingleComputerLicense:FingerFastExtractor
  • SingleComputerLicense:FingerFastSegmenter
  • SingleComputerLicense:FaceFastExtractor
  • SingleComputerLicense:FaceTokenImage
  • SingleComputerLicense:FaceFastTokenImage
  • SingleComputerLicense:IrisFastExtractor
  • SingleComputerLicense:VoiceFastExtractor

  • SingleComputerLicense:SentiSculpt
  • SingleComputerLicense:SentiGaze
  • SingleComputerLicense:SentiSight

These values are older SDK versions:

  • SingleComputerLicense:VFExtractor
  • SingleComputerLicense:VFMatcher
  • SingleComputerLicense:VFExtended
  • SingleComputerLicense:VLExtractor
  • SingleComputerLicense:VLMatcher
  • SingleComputerLicense:VLExtended
  • SingleComputerLicense:VFExtractorV
  • SingleComputerLicense:VFMatcherV
  • SingleComputerLicense:VLExtractorV
  • SingleComputerLicense:VLMatcherV
  • SingleComputerLicense:VEExtractor
  • SingleComputerLicense:VEMatcher
  • SingleComputerLicense:VEExtended
  • SingleComputerLicense:VEExtractorV
  • SingleComputerLicense:VEMatcherV
  • SingleComputerLicense:VFExtractorS
  • SingleComputerLicense:VFMatcherS
  • SingleComputerLicense:VLExtractorS
  • SingleComputerLicense:VLMatcherS
  • SingleComputerLicense:VEExtractorS
  • SingleComputerLicense:VEMatcherS
  • SingleComputerLicense:VLSurveillance
  • SingleComputerLicense:VPExtractor
  • SingleComputerLicense:VPMatcher

  • SingleComputerLicense:VFBSS
  • SingleComputerLicense:VLBSS
  • SingleComputerLicense:VEBSS
  • SingleComputerLicense:VFBSS_S
  • SingleComputerLicense:VLBSS_S
  • SingleComputerLicense:VEBSS_S

  • SingleComputerLicense:MegaMatcherServer
  • SingleComputerLicense:MegaMatcherClusterServer
  • SingleComputerLicense:MegaMatcherClusterNode
  • SingleComputerLicense:MegaMatcherClient
Collapse Expand Notes

This function should be called when license name is known. Otherwise, NLicenseObtainComponents should be called.

Container

File: NLicense.h

Module: NLicense Unit


NLicenseObtainComponents Function

NLicenseObtainComponents Function
NLicense.h

Obtains component license from the specified server.

C++
NResult N_API NLicenseObtainComponents(const NChar * szAddress, const NChar * szPort, const NChar * szComponents, NBool * pAvailable);
Collapse Expand Parameters
Parameters | Description
const NChar * szAddress | [in] Server address where license manager is installed as a server. License manager can be in the same or in other computer. /local is used when license is tied with the computer using serial number.
const NChar * szPort | [in] License manager server port.
const NChar * szComponents | [in] Zero terminated string which contains license name for component. For a complete list of available values for this parameter see Remarks section.
NBool * pAvailable | [out] Returns NTrue if license for component isavailable; otherwise, NFalse.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise error code is returned. NSucceeded or NFailed macros can be used to detect whether the function succeeded or failed.

Collapse Expand Remarks

NLicenseObtainComponents is a wrapper of NLicenseObtain function. This function should be used when a license(-s) for component(-s) (not a product) is required. NLicenseObtainComponents function starts by attempting to retrieve licenses for specified components.

Collapse Expand Notes
  • NLicenseObtainComponents needs to check availability of all the licenses which can provide requested functionality. As an optimization NLicensing.cfg file can be used to limit the checks to be performed. The file is saved to current directory by the Activation Wizard on Windows platform, on other OS the file can be created manually by a user. Each line of the file specifies functionality name (supported by NLicenseObtainComponents) and the list of the licenses to check for. For example:
    • Images.WSQ = FingerClient, WSQ, PalmClient
  • NLicenseObtainComponents checks all available licenses so it can take time to find a required license.
  • If license name is known it is recommended to call NLicenseObtain function.
Container

File: NLicense.h

Module: NLicense Unit


NLicenseRelease Function

NLicenseRelease Function
NLicense.h

Releases license.

C++
NResult N_API NLicenseRelease(const NChar * szProducts);
Collapse Expand Parameters
Parameters | Description
const NChar * szProducts | [in] Product names to release licenses. See NLicenseObtain function remarks for the list of supported values of this parameter.
Collapse Expand Returns

If the function succeeds, the return value is N_OK.

If the function fails, the return value is one of the following error codes:

Error code | Condition
N_E_ARGUMENT_NULL | szProducts is NULL.
N_E_FORMAT | szProducts incorrect format.
N_E_FAILED | Unspecified error has occurred.
Collapse Expand Remarks

NLicenseRelease function should be called before program exits.

Container

File: NLicense.h

Module: NLicense Unit


NLicenseReleaseComponents Function

NLicenseReleaseComponents Function
NLicense.h

Releases component license.

C++
NResult N_API NLicenseReleaseComponents(const NChar * szComponents);
Collapse Expand Parameters
Parameters | Description
const NChar * szComponents | [in] Zero terminated string which contains component name.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise error code is returned. NSucceeded or NFailed macros can be used to detect whether the function succeeded or failed.

Collapse Expand Remarks
  • See NLicenseObtainComponents function remarks for the list of supported component names for this parameter.
  • This function should be called as many times as function NLicenseObtainComponents was called.
Container

File: NLicense.h

Module: NLicense Unit


NLicenseObtainedStatus Enumeration

NLicenseObtainedStatus Enumeration
NLicense.h

Enumerates licensing status values.

C++
typedef enum NLicenseObtainedStatus_ {
  nlosUnknown = 0,
  nlosLicenseObtained = 1,
  nlosLicenseNotObtained = 2,
  nlosServerOffline = 3
} NLicenseObtainedStatus;
Collapse Expand Members
Members | Description
nlosUnknown = 0 | Indicates unknown licensing status.
nlosLicenseObtained = 1 | Indicates that license was obtained.
nlosLicenseNotObtained = 2 | Indicates that license was not obtained.
nlosServerOffline = 3 | Indicates that licensing server is offline.
Container

File: NLicense.h

Module: NLicense Unit


NLicenseActivateOnline Macro

NLicenseActivateOnline Macro
NLicense.h

Picks a Unicode (W) or ANSCII (A) version of the NLicenseActivateOnline function.

C++
#define NLicenseActivateOnline N_FUNC_AW(NLicenseActivateOnline)
Container

File: NLicense.h

Module: NLicense Unit


NLicenseAdd Macro

NLicenseAdd Macro
NLicense.h

Picks a Unicode (W) or ANSCII (A) version of the NLicenseAdd function.

C++
#define NLicenseAdd N_FUNC_AW(NLicenseAdd)
Container

File: NLicense.h

Module: NLicense Unit


NLicenseDeactivateOnline Macro

NLicenseDeactivateOnline Macro
NLicense.h

Picks a Unicode (W) or ANSCII (A) version of the NLicenseDeactivateOnline function.

C++
#define NLicenseDeactivateOnline N_FUNC_AW(NLicenseDeactivateOnline)
Container

File: NLicense.h

Module: NLicense Unit


NLicenseDeactivateOnlineWithId Macro

NLicenseDeactivateOnlineWithId Macro
NLicense.h

Picks a Unicode (W) or ANSCII (A) version of the NLicenseDeactivateOnlineWithId function.

C++
#define NLicenseDeactivateOnlineWithId N_FUNC_AW(NLicenseDeactivateOnlineWithId)
Container

File: NLicense.h

Module: NLicense Unit


NLicenseGenerateDeactivationId Macro

NLicenseGenerateDeactivationId Macro
NLicense.h

Picks a Unicode (W) or ANSCII (A) version of the NLicenseGenerateDeactivationId function.

C++
#define NLicenseGenerateDeactivationId N_FUNC_AW(NLicenseGenerateDeactivationId)
Container

File: NLicense.h

Module: NLicense Unit


NLicenseGenerateDeactivationIdForLicense Macro

NLicenseGenerateDeactivationIdForLicense Macro
NLicense.h

Picks a Unicode (W) or ANSCII (A) version of the NLicenseGenerateDeactivationIdForLicense function.

C++
#define NLicenseGenerateDeactivationIdForLicense N_FUNC_AW(NLicenseGenerateDeactivationIdForLicense)
Container

File: NLicense.h

Module: NLicense Unit


NLicenseGenerateId Macro

NLicenseGenerateId Macro
NLicense.h

Picks a Unicode (W) or ANSCII (A) version of the NLicenseGenerateId function.

C++
#define NLicenseGenerateId N_FUNC_AW(NLicenseGenerateId)
Container

File: NLicense.h

Module: NLicense Unit


NLicenseGetLicenseInfoOnline Macro

NLicenseGetLicenseInfoOnline Macro
NLicense.h

Picks a Unicode (W) or ANSCII (A) version of the NLicenseGetLicenseInfoOnline function.

C++
#define NLicenseGetLicenseInfoOnline N_FUNC_AW(NLicenseGetLicenseInfoOnline)
Container

File: NLicense.h

Module: NLicense Unit


NLicenseGetObtainedComponentStatus Macro

NLicenseGetObtainedComponentStatus Macro
NLicense.h

Picks a Unicode (W) or ANSCII (A) version of the NLicenseGetObtainedComponentStatus function.

C++
#define NLicenseGetObtainedComponentStatus N_FUNC_AW(NLicenseGetObtainedComponentStatus)
Container

File: NLicense.h

Module: NLicense Unit


NLicenseGetObtainedLicenseInfo Macro

NLicenseGetObtainedLicenseInfo Macro
NLicense.h

Picks a Unicode (W) or ANSCII (A) version of the NLicenseGetObtainedLicenseInfo function.

C++
#define NLicenseGetObtainedLicenseInfo N_FUNC_AW(NLicenseGetObtainedLicenseInfo)
Container

File: NLicense.h

Module: NLicense Unit


NLicenseGetObtainedLicenseInfoForComponent Macro

NLicenseGetObtainedLicenseInfoForComponent Macro
NLicense.h

Picks a Unicode (W) or ANSCII (A) version of the NLicenseGetObtainedLicenseInfoForComponent function.

C++
#define NLicenseGetObtainedLicenseInfoForComponent N_FUNC_AW(NLicenseGetObtainedLicenseInfoForComponent)
Container

File: NLicense.h

Module: NLicense Unit


NLicenseGetObtainedStatus Macro

NLicenseGetObtainedStatus Macro
NLicense.h

Picks a Unicode (W) or ANSCII (A) version of the NLicenseGetObtainedStatus function.

C++
#define NLicenseGetObtainedStatus N_FUNC_AW(NLicenseGetObtainedStatus)
Container

File: NLicense.h

Module: NLicense Unit


NLicenseIsComponentActivated Macro

NLicenseIsComponentActivated Macro
NLicense.h

Picks a Unicode (W) or ANSCII (A) version of the NLicenseIsComponentActivated function.

C++
#define NLicenseIsComponentActivated N_FUNC_AW(NLicenseIsComponentActivated)
Container

File: NLicense.h

Module: NLicense Unit


NLicenseObtainComponents Macro

NLicenseObtainComponents Macro
NLicense.h

Picks a Unicode (W) or ANSCII (A) version of the NLicenseObtainComponents function.

C++
#define NLicenseObtainComponents N_FUNC_AW(NLicenseObtainComponents)
Container

File: NLicense.h

Module: NLicense Unit


NLicenseReleaseComponents Macro

NLicenseReleaseComponents Macro
NLicense.h

Picks a Unicode (W) or ANSCII (A) version of the NLicenseReleaseComponents function.

C++
#define NLicenseReleaseComponents N_FUNC_AW(NLicenseReleaseComponents)
Container

File: NLicense.h

Module: NLicense Unit


NLicense.h

NLicense.h
Enumerations Functions Legend Macros

Header file for the NLicense library. Provides internal license functionality.

Collapse Expand Enumerations
Name | Description
NLicenseObtainedStatus_ | Enumerates licensing status values.
NLicenseObtainedStatus | Enumerates licensing status values.
Collapse Expand Functions
Name | Description
NLicenseActivateOnline | ... more
NLicenseAdd | Adds the activated license content (the content of *.lic file) to be used in application.
NLicenseDeactivateOnline | ... more
NLicenseDeactivateOnlineWithId | ... more
NLicenseGenerateDeactivationId | Generates deactivation Id for specified provided product on current computer.
NLicenseGenerateDeactivationIdForLicense | Generates deactivation Id for specified license on current computer.
NLicenseGenerateId | Generates Id for activation from serial number for a particular machine.
NLicenseGetLicenseInfoOnline | Retrieves info online about specified license.
NLicenseGetObtainedComponentStatus | Gets licensing status for obtained component.
NLicenseGetObtainedLicenseInfo | Retrieves information about obtained license.
NLicenseGetObtainedLicenseInfoForComponent | Retrieves information about obtained license for component.
NLicenseGetObtainedStatus | Gets licensing status for the specified product.
NLicenseIsComponentActivated | Checks if component specified by name is activated.
NLicenseObtain | Obtains product license from the specified server.
NLicenseObtainComponents | Obtains component license from the specified server.
NLicenseRelease | Releases license.
NLicenseReleaseComponents | Releases component license.
Collapse Expand Macros
Name | Description
NLicenseActivateOnline | Picks a Unicode (W) or ANSCII (A) version of the NLicenseActivateOnline function.
NLicenseAdd | Picks a Unicode (W) or ANSCII (A) version of the NLicenseAdd function.
NLicenseDeactivateOnline | Picks a Unicode (W) or ANSCII (A) version of the NLicenseDeactivateOnline function.
NLicenseDeactivateOnlineWithId | Picks a Unicode (W) or ANSCII (A) version of the NLicenseDeactivateOnlineWithId function.
NLicenseGenerateDeactivationId | Picks a Unicode (W) or ANSCII (A) version of the NLicenseGenerateDeactivationId function.
NLicenseGenerateDeactivationIdForLicense | Picks a Unicode (W) or ANSCII (A) version of the NLicenseGenerateDeactivationIdForLicense function.
NLicenseGenerateId | Picks a Unicode (W) or ANSCII (A) version of the NLicenseGenerateId function.
NLicenseGetLicenseInfoOnline | Picks a Unicode (W) or ANSCII (A) version of the NLicenseGetLicenseInfoOnline function.
NLicenseGetObtainedComponentStatus | Picks a Unicode (W) or ANSCII (A) version of the NLicenseGetObtainedComponentStatus function.
NLicenseGetObtainedLicenseInfo | Picks a Unicode (W) or ANSCII (A) version of the NLicenseGetObtainedLicenseInfo function.
NLicenseGetObtainedLicenseInfoForComponent | Picks a Unicode (W) or ANSCII (A) version of the NLicenseGetObtainedLicenseInfoForComponent function.
NLicenseGetObtainedStatus | Picks a Unicode (W) or ANSCII (A) version of the NLicenseGetObtainedStatus function.
NLicenseIsComponentActivated | Picks a Unicode (W) or ANSCII (A) version of the NLicenseIsComponentActivated function.
NLicenseObtainComponents | Picks a Unicode (W) or ANSCII (A) version of the NLicenseObtainComponents function.
NLicenseReleaseComponents | Picks a Unicode (W) or ANSCII (A) version of the NLicenseReleaseComponents function.


NLicenseInfo Unit

NLicenseInfo Unit
Functions Legend Structs, Records, Enums

Provides functionality for license info retrieval.

Collapse Expand Functions
Name | Description
NLicenseInfoGetDistributorId | Gets distributor id.
NLicenseInfoGetLicenseId | Gets license Id.
NLicenseInfoGetLicenses | Gets all licenses from specified NLicenseInfo.
NLicenseInfoGetSequenceNumber | Gets sequence number of specified HNLicenseInfo.
NLicenseInfoGetSourceType | Gets license source type.
NLicenseInfoGetStatus | Gets license status value.
NLicenseInfoGetType | Gets license type.
NLicenseProductInfoGetId | Gets product Id.
NLicenseProductInfoGetLicenseCount | Gets license count in specified NLicenseProductInfo.
NLicenseProductInfoGetLicenseType | Gets license type of specified NLicenseProductInfo.
NLicenseProductInfoGetOSFamily | Gets OS family of specified NLicenseProductInfo.
NLicenseProductInfoGetParameters | Gets the product parameters of specified NLicenseProductInfo.
Collapse Expand Structs, Records, Enums
Name | Description
NLicenseInfoSourceType_ | Specifies license source.
NLicenseInfoStatus_ | Enumerates license status values.
NLicenseInfoType_ | Specifies licensing type.
NLicenseType_ | Specifies license type.
NLicenseInfoSourceType | Specifies license source.
NLicenseInfoStatus | Enumerates license status values.
NLicenseInfoType | Specifies licensing type.
NLicenseType | Specifies license type.


NLicenseInfoGetDistributorId Function

NLicenseInfoGetDistributorId Function

Gets distributor id.

C++
NResult N_API NLicenseInfoGetDistributorId(HNLicenseInfo hLicenseInfo, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNLicenseInfo hLicenseInfo | [in] Handle to NLicenseInfo.
NInt * pValue | [out] Distributor Id.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicenseInfo.h

Module: NLicenseInfo Unit


NLicenseInfoGetLicenseId Function

NLicenseInfoGetLicenseId Function

Gets license Id.

C++
NResult N_API NLicenseInfoGetLicenseId(HNLicenseInfo hLicenseInfo, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNLicenseInfo hLicenseInfo | [in] Handle to NLicenseInfo.
HNString * phValue | [out] Pointer to string containing license Id.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicenseInfo.h

Module: NLicenseInfo Unit


NLicenseInfoGetLicenses Function

NLicenseInfoGetLicenses Function

Gets all licenses from specified NLicenseInfo.

C++
NResult N_API NLicenseInfoGetLicenses(HNLicenseInfo hLicenseInfo, HNLicenseProductInfo * * parhProductInfo, NInt * pProductInfoCount);
Collapse Expand Parameters
Parameters | Description
HNLicenseInfo hLicenseInfo | [in] Handle to NLicenseInfo.
HNLicenseProductInfo * * parhProductInfo | [out] Pointer to an array containing licenses.
NInt * pProductInfoCount | [out] Products in parhProductInfo count.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicenseInfo.h

Module: NLicenseInfo Unit


NLicenseInfoGetSequenceNumber Function

NLicenseInfoGetSequenceNumber Function

Gets sequence number of specified HNLicenseInfo.

C++
NResult N_API NLicenseInfoGetSequenceNumber(HNLicenseInfo hLicenseInfo, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNLicenseInfo hLicenseInfo | [in] Handle to NLicenseInfo.
NInt * pValue | [out] Sequence number.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicenseInfo.h

Module: NLicenseInfo Unit


NLicenseInfoGetSourceType Function

NLicenseInfoGetSourceType Function

Gets license source type.

C++
NResult N_API NLicenseInfoGetSourceType(HNLicenseInfo hLicenseInfo, NLicenseInfoSourceType * pValue);
Collapse Expand Parameters
Parameters | Description
HNLicenseInfo hLicenseInfo | [in] Handle to NLicenseInfo.
NLicenseInfoSourceType * pValue | [out] One of license source values.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicenseInfo.h

Module: NLicenseInfo Unit


NLicenseInfoGetStatus Function

NLicenseInfoGetStatus Function

Gets license status value.

C++
NResult N_API NLicenseInfoGetStatus(HNLicenseInfo hLicenseInfo, NLicenseInfoStatus * pValue);
Collapse Expand Parameters
Parameters | Description
HNLicenseInfo hLicenseInfo | [in] Handle to NLicenseInfo.
NLicenseInfoStatus * pValue | [out] Pointer to one of NLicenseInfoStatus values.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicenseInfo.h

Module: NLicenseInfo Unit


NLicenseInfoGetType Function

NLicenseInfoGetType Function

Gets license type.

C++
NResult N_API NLicenseInfoGetType(HNLicenseInfo hLicenseInfo, NLicenseInfoType * pValue);
Collapse Expand Parameters
Parameters | Description
HNLicenseInfo hLicenseInfo | [in] Handle to NLicenseInfo.
NLicenseInfoType * pValue | [out] License type.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicenseInfo.h

Module: NLicenseInfo Unit


NLicenseProductInfoGetId Function

NLicenseProductInfoGetId Function

Gets product Id.

C++
NResult N_API NLicenseProductInfoGetId(HNLicenseProductInfo hProductInfo, NUInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNLicenseProductInfo hProductInfo | [in] Handle to NLicenseProductInfo.
NUInt * pValue | [out] Product Id.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicenseProductInfo.h

Module: NLicenseInfo Unit


NLicenseProductInfoGetLicenseCount Function

NLicenseProductInfoGetLicenseCount Function

Gets license count in specified NLicenseProductInfo.

C++
NResult N_API NLicenseProductInfoGetLicenseCount(HNLicenseProductInfo hProductInfo, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNLicenseProductInfo hProductInfo | [in] Handle to NLicenseProductInfo.
NInt * pValue | [out] License count.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicenseProductInfo.h

Module: NLicenseInfo Unit


NLicenseProductInfoGetLicenseType Function

NLicenseProductInfoGetLicenseType Function

Gets license type of specified NLicenseProductInfo.

C++
NResult N_API NLicenseProductInfoGetLicenseType(HNLicenseProductInfo hProductInfo, NLicenseType * pValue);
Collapse Expand Parameters
Parameters | Description
HNLicenseProductInfo hProductInfo | [in] Handle to NLicenseProductInfo.
NLicenseType * pValue | [out] License type.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicenseProductInfo.h

Module: NLicenseInfo Unit


NLicenseProductInfoGetOSFamily Function

NLicenseProductInfoGetOSFamily Function

Gets OS family of specified NLicenseProductInfo.

C++
NResult N_API NLicenseProductInfoGetOSFamily(HNLicenseProductInfo hProductInfo, NOSFamily * pValue);
Collapse Expand Parameters
Parameters | Description
HNLicenseProductInfo hProductInfo | [in] Handle to NLicenseProductInfo.
NOSFamily * pValue | [out] OS family.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicenseProductInfo.h

Module: NLicenseInfo Unit


NLicenseProductInfoGetParameters Function

NLicenseProductInfoGetParameters Function

Gets the product parameters of specified NLicenseProductInfo.

C++
NResult N_API NLicenseProductInfoGetParameters(HNLicenseProductInfo hProductInfo, HNPropertyBag * pValue);
Collapse Expand Parameters
Parameters | Description
HNLicenseProductInfo hProductInfo | [in] Handle to NLicenseProductInfo.
HNPropertyBag * pValue | [out] Handle to the pointer of NPropertyBag containing product parameters.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicenseProductInfo.h

Module: NLicenseInfo Unit


NLicenseInfoSourceType Enumeration

NLicenseInfoSourceType Enumeration

Specifies license source.

C++
typedef enum NLicenseInfoSourceType_ {
  nlistUnknown = 0,
  nlistFile = 1,
  nlistDongle = 2,
  nlistInternet = 3
} NLicenseInfoSourceType;
Collapse Expand Members
Members | Description
nlistUnknown = 0 | License source is unknown.
nlistFile = 1 | License source is file.
nlistDongle = 2 | License source is dongle.
nlistInternet = 3 | License source is internet.
Container

File: NLicenseInfo.h

Module: NLicenseInfo Unit


NLicenseInfoStatus Enumeration

NLicenseInfoStatus Enumeration

Enumerates license status values.

C++
typedef enum NLicenseInfoStatus_ {
  nlisUnknown = 0,
  nlisValid = 1,
  nlisInvalid = 2
} NLicenseInfoStatus;
Collapse Expand Members
Members | Description
nlisUnknown = 0 | License status is unknown.
nlisValid = 1 | License status is valid.
nlisInvalid = 2 | License status is invalid.
Container

File: NLicenseInfo.h

Module: NLicenseInfo Unit


NLicenseInfoType Enumeration

NLicenseInfoType Enumeration

Specifies licensing type.

C++
typedef enum NLicenseInfoType_ {
  nlitUnknown = 0,
  nlitSerialNumber = 1,
  nlitHardwareId = 2,
  nlitLicense = 3,
  nlitParametricLicense = 6,
  nlitParametricHardwareId = 7,
  nlitParametricSerial = 8
} NLicenseInfoType;
Collapse Expand Members
Members | Description
nlitUnknown = 0 | Licensing type is unknown.
nlitSerialNumber = 1 | Licensing is based on a serial number.
nlitHardwareId = 2 | Licensing is based on hardware Id.
nlitLicense = 3 | Licensing is based on a license.
nlitParametricLicense = 6 | Parametric licensing is based on a license file usage.
nlitParametricHardwareId = 7 | Parametric licensing is based on hardware Id.
nlitParametricSerial = 8 | Parametric licensing is based on a serial number usage.
Container

File: NLicenseInfo.h

Module: NLicenseInfo Unit


NLicenseType Enumeration

NLicenseType Enumeration

Specifies license type.

C++
typedef enum NLicenseType_ {
  nltSingleComputer = 0,
  nltConcurrent = 1,
  nltSigned = 2
} NLicenseType;
Collapse Expand Members
Members | Description
nltSingleComputer = 0 | Single computer license.
nltConcurrent = 1 | Concurrent license.
nltSigned = 2 | Signed license.
Container

File: NLicenseProductInfo.h

Module: NLicenseInfo Unit


NLicenseManager Unit

NLicenseManager Unit
Functions Legend Macros

Provides functionality for licenses management.

Collapse Expand Functions
Name | Description
NLicManFindFirstDongle | Retrieves handle to the first attached dongle.
NLicManFindNextDongle | Retrieves next attached dongle.
NLicManGenerateLicenseExN | Generates product license using the specified computer Id from a dongle.
NLicManGenerateLicenseN | Generates product license from computer Id.
NLicManGenerateSerialExN | Generates serial number from a dongle.
NLicManGenerateSerialN | Generates serial number for a specified product.
NLicManGetClientId | Gets application identifier (Id) if more than one application is used.
NLicManGetDongles | Retrieves an array of connected dongles containing licenses for Neurotechnology products.
NLicManGetLicenseData | Retrieves license data for a specified product license.
NLicManGetLicenseDataEx | Retrieves license data for a specified product license.
NLicManGetLongProductNameForProductInfoN | Retrieves full name of a product specified by product info.
NLicManGetLongProductNameN | Retrieves full name of a product specified by product Id.
NLicManGetProductIds | Retrieves a list of all Neurotechnology products Ids.
NLicManGetProxyHost | Retrieves proxy server host name.
NLicManGetProxyPassword | Retrieves proxy server password.
NLicManGetProxyPort | Retrieves proxy port number of licensing server.
NLicManGetProxyUsername | Retrieves proxy server username.
NLicManGetShortProductNameForProductInfoN | Retrieves short name of a product from NLicenseProductInfo.
NLicManGetShortProductNameN | Retrieves short name of a product specified by product Id.
NLicManGetTrialMode | Gets trial mode value.
NLicManGetUpdateTicketInfo | Updates specified ticket info.
NLicManGetUseHttps | ... more
NLicManGetWritableStoragePath | Gets writeable storage path.
NLicManInitialize | Initializes NLicenseManager.
NLicManIsLicenseTypeSupported | Checks whether the specified license type is supported.
NLicManSetClientIdN | Sets application identifier (Id) if more than one application is used.
NLicManSetProxyHostN | Sets proxy server host name.
NLicManSetProxyPasswordN | Sets password to use for proxy server authentication.
NLicManSetProxyPort | Sets proxy port number of licensing server.
NLicManSetProxyUsernameN | Sets username to use for proxy server authentication.
NLicManSetTrialMode | Sets trial mode value.
NLicManSetUseHttps | Enables or disables use of HTTPS protocol.
NLicManSetWritableStoragePathN | Sets writeable storage path value.
Collapse Expand Macros
Name | Description
NLicManGetLicenseData | Picks a Unicode (W) or ANSCII (A) version of the NLicManGetLicenseData function.
NLicManGetLicenseDataEx | Picks a Unicode (W) or ANSCII (A) version of the NLicManGetLicenseDataEx function.
NLicManGetUpdateTicketInfo | Picks a Unicode (W) or ANSCII (A) version of the NLicManGetUpdateTicketInfo function.
N_LIC_MAN_MAX_LICENSE_LENGTH | Defines maximal length of generated license.
N_LIC_MAN_MAX_SERIAL_LENGTH | Defines maximal length of serial number.


NLicManFindFirstDongle Function

NLicManFindFirstDongle Function

Retrieves handle to the first attached dongle.

C++
NResult N_API NLicManFindFirstDongle(HNLicManDongle * phDongle);
Collapse Expand Parameters
Parameters | Description
HNLicManDongle * phDongle | [out] Pointer to a handle of attached dongle. If function fails, the return value is NULL.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicenseManager.h

Module: NLicenseManager Unit


NLicManFindNextDongle Function

NLicManFindNextDongle Function

Retrieves next attached dongle.

C++
NResult N_API NLicManFindNextDongle(HNLicManDongle * phDongle);
Collapse Expand Parameters
Parameters | Description
HNLicManDongle * phDongle | [out] Pointer to a handle of next attached dongle. If function fails, the return value is NULL.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicenseManager.h

Module: NLicenseManager Unit


NLicManGenerateLicenseExN Function

NLicManGenerateLicenseExN Function

Generates product license using the specified computer Id from a dongle.

C++
NResult N_API NLicManGenerateLicenseExN(HNLicManDongle hDongle, HNString hId, NInt * pSequenceNumber, NUInt * pProductId, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNLicManDongle hDongle | [in] Handle to the dongle containing licenses.
HNString hId | [in] Handle to string that contains computer Id file data. You should read computer Id file to this string.
NInt * pSequenceNumber | [out] Pointer to sequence number used for licenses accounting.
NUInt * pProductId | [out] Pointer to Id of a product for which license was generated.
HNString * phValue | [out] Handle to a string that contains generated license data.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For every generated license count of licenses in a dongle will be decreased by 1.

When generating licenses these constraints should be considered:

  1. Only one instance of license generating process should be present.
  2. pg.exe can not be started.
Container

File: NLicenseManager.h

Module: NLicenseManager Unit


NLicManGenerateLicenseN Function

NLicManGenerateLicenseN Function

Generates product license from computer Id.

C++
NResult N_API NLicManGenerateLicenseN(HNString hId, NInt * pSequenceNumber, NUInt * pProductId, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNString hId | [in] Handle to string that contains computer Id file data. You should read computer Id file to this string.
NInt * pSequenceNumber | [out] Pointer to sequence number used for licenses accounting.
NUInt * pProductId | [out] Pointer to Id of a product for which license was generated.
HNString * phValue | [out] Handle to a string that contains generated license data.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For every generated license count of licenses in a dongle will be decreased by 1.

When generating licenses these constraints should be considered:

  1. Only one instance of license generating process should be present.
  2. pg.exe can not be started.
Container

File: NLicenseManager.h

Module: NLicenseManager Unit


NLicManGenerateSerialExN Function

NLicManGenerateSerialExN Function

Generates serial number from a dongle.

C++
NResult N_API NLicManGenerateSerialExN(HNLicManDongle hDongle, NUInt productId, NInt sequenceNumber, NInt * pDistributorId, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNLicManDongle hDongle | [in] Handle to the dongle containing licenses.
NUInt productId | [in] Id of a product to generate license.
NInt sequenceNumber | [in] Sequence number used for licenses accounting. User must store sequence number in your own database.
NInt * pDistributorId | [out] Pointer to Id of a distributor for which serial number should be generated.
HNString * phValue | [out] Handle to the pointer of NString that contains generated serial number.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicenseManager.h

Module: NLicenseManager Unit


NLicManGenerateSerialN Function

NLicManGenerateSerialN Function

Generates serial number for a specified product.

C++
NResult N_API NLicManGenerateSerialN(NUInt productId, NInt sequenceNumber, NInt * pDistributorId, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
NUInt productId | [in] Id of a product to generate serial number.
NInt sequenceNumber | [in] Sequence number used for licenses accounting. User must store sequence number in your own database.
NInt * pDistributorId | [out] Pointer to Id of a distributor for which serial number should be generated.
HNString * phValue | [out] Handle to a string which contains generated serial number.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicenseManager.h

Module: NLicenseManager Unit


NLicManGetClientId Function

NLicManGetClientId Function

Gets application identifier (Id) if more than one application is used.

C++
NResult N_API NLicManGetClientId(HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNString * phValue | [out] Handle to the pointer of NString containing application Id.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicenseManager.h

Module: NLicenseManager Unit


NLicManGetDongles Function

NLicManGetDongles Function

Retrieves an array of connected dongles containing licenses for Neurotechnology products.

C++
NResult N_API NLicManGetDongles(HNLicManDongle ** parhDongles, NInt * pCount);
Collapse Expand Parameters
Parameters | Description
HNLicManDongle ** parhDongles | [out] Pointer to an array of NLicManDongle containing connected dongles.
NInt * pCount | [out] parhDongles items count.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicenseManager.h

Module: NLicenseManager Unit


NLicManGetLicenseData Function

NLicManGetLicenseData Function

Retrieves license data for a specified product license.

C++
NResult N_API NLicManGetLicenseData(const NChar * szId, NInt * pSequenceNumber, NUInt * pProductId, NInt * pDistributorId);
Collapse Expand Parameters
Parameters | Description
const NChar * szId | [in] A string that contains computer Id file data. Computer Id file should be scanned before passing it to a function. String passed to function should contain null terminating character.
NInt * pSequenceNumber | [out] Pointer to a sequence number used for licenses accounting.
NUInt * pProductId | [out] Pointer to product Id.
NInt * pDistributorId | [out] Pointer to distributor Id.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicenseManager.h

Module: NLicenseManager Unit


NLicManGetLicenseDataEx Function

NLicManGetLicenseDataEx Function

Retrieves license data for a specified product license.

C++
NResult N_API NLicManGetLicenseDataEx(HNLicManDongle hDongle, const NChar * szId, NInt * pSequenceNumber, NUInt * pProductId, NInt * pDistributorId);
Collapse Expand Parameters
Parameters | Description
HNLicManDongle hDongle | [in] Handle to the dongle containing licenses.
const NChar * szId | [in] A string that contains computer Id file data. Computer Id file should be scanned before passing it to a function. String passed to function should contain null terminating character.
NInt * pSequenceNumber | [out] Pointer to a sequence number used for licenses accounting.
NUInt * pProductId | [out] Pointer to product Id.
NInt * pDistributorId | [out] Pointer to distributor Id.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicenseManager.h

Module: NLicenseManager Unit


NLicManGetLongProductNameForProductInfoN Function

NLicManGetLongProductNameForProductInfoN Function

Retrieves full name of a product specified by product info.

C++
NResult N_API NLicManGetLongProductNameForProductInfoN(HNLicenseProductInfo hProductInfo, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNLicenseProductInfo hProductInfo | [in] Handle to NLicenseProductInfo.
HNString * phValue | [out] Pointer to a string which contains full product name.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicenseManager.h

Module: NLicenseManager Unit


NLicManGetLongProductNameN Function

NLicManGetLongProductNameN Function

Retrieves full name of a product specified by product Id.

C++
NResult N_API NLicManGetLongProductNameN(NUInt productId, NLicenseType type, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
NUInt productId | [in] Id of a product to retrieve full name.
NLicenseType type | [in] Type of the licenses.
HNString * phValue | [out] Pointer to s string which contains full product name.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicenseManager.h

Module: NLicenseManager Unit


NLicManGetProductIds Function

NLicManGetProductIds Function

Retrieves a list of all Neurotechnology products Ids.

C++
NResult N_API NLicManGetProductIds(NUInt * arProductsIds);
Collapse Expand Parameters
Parameters | Description
NUInt * arProductsIds | [out] Pointer to an NUInt array that contains all products Ids.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicenseManager.h

Module: NLicenseManager Unit


NLicManGetProxyHost Function

NLicManGetProxyHost Function

Retrieves proxy server host name.

C++
NResult N_API NLicManGetProxyHost(HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNString * phValue | [out] Pointer to string containing proxy server host name.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicenseManager.h

Module: NLicenseManager Unit


NLicManGetProxyPassword Function

NLicManGetProxyPassword Function

Retrieves proxy server password.

C++
NResult N_API NLicManGetProxyPassword(HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNString * phValue | [out] Pointer to NString containing proxy server password.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicenseManager.h

Module: NLicenseManager Unit


NLicManGetProxyPort Function

NLicManGetProxyPort Function

Retrieves proxy port number of licensing server.

C++
NResult N_API NLicManGetProxyPort(NInt * pValue);
Collapse Expand Parameters
Parameters | Description
NInt * pValue | [out] Proxy port number.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicenseManager.h

Module: NLicenseManager Unit


NLicManGetProxyUsername Function

NLicManGetProxyUsername Function

Retrieves proxy server username.

C++
NResult N_API NLicManGetProxyUsername(HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNString * phValue | [out] Pointer to NString containing proxy server username.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicenseManager.h

Module: NLicenseManager Unit


NLicManGetShortProductNameForProductInfoN Function

NLicManGetShortProductNameForProductInfoN Function

Retrieves short name of a product from NLicenseProductInfo.

C++
NResult N_API NLicManGetShortProductNameForProductInfoN(HNLicenseProductInfo hProductInfo, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNLicenseProductInfo hProductInfo | [in] Handle to NLicenseProductInfo.
HNString * phValue | [out] Pointer to a string which contains a short product name.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicenseManager.h

Module: NLicenseManager Unit


NLicManGetShortProductNameN Function

NLicManGetShortProductNameN Function

Retrieves short name of a product specified by product Id.

C++
NResult N_API NLicManGetShortProductNameN(NUInt productId, NLicenseType type, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
NUInt productId | [in] Id of a product to retrieve short name.
NLicenseType type | [in] Type of the licenses.
HNString * phValue | [out] Pointer to s string which contains short product name.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicenseManager.h

Module: NLicenseManager Unit


NLicManGetTrialMode Function

NLicManGetTrialMode Function

Gets trial mode value.

C++
NResult N_API NLicManGetTrialMode(NBool * pValue);
Collapse Expand Parameters
Parameters | Description
NBool * pValue | [out] Pointer to NBool which receives trial mode value. NTrue, if trial mode is enabled; NFalse, otherwise.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

Trial mode of SDK is set in Bin/Licenses/TrialFlag.txt

Container

File: NLicenseManager.h

Module: NLicenseManager Unit


NLicManGetUpdateTicketInfo Function

NLicManGetUpdateTicketInfo Function

Updates specified ticket info.

C++
NResult N_API NLicManGetUpdateTicketInfo(const NChar * szTicketNumber, HNLicManDongleUpdateTicketInfo * phTicket);
Collapse Expand Parameters
Parameters | Description
const NChar * szTicketNumber | [in] Zero terminated string containing ticket number.
HNLicManDongleUpdateTicketInfo * phTicket | [out] Pointer to ticket info.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicenseManager.h

Module: NLicenseManager Unit


NLicManGetUseHttps Function

NLicManGetUseHttps Function

Gets if HTTPS/SSL (port 443) protocol between application and the remote Neurotechnology licensing server is used.

C++
NResult N_API NLicManGetUseHttps(NBool * pValue);
Collapse Expand Parameters
Parameters | Description
NBool * pValue | [out] Pointer to NBool which receives HTTPS/SSL value. NTrue, if HTTPS/SSL protocol is enabled; NFalse, otherwise.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

This feature is used only with trial or Internet License for nopg mode (when Neurotechnology Licensing Service is not used).

Container

File: NLicenseManager.h

Module: NLicenseManager Unit


NLicManGetWritableStoragePath Function

NLicManGetWritableStoragePath Function

Gets writeable storage path.

C++
NResult N_API NLicManGetWritableStoragePath(HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNString * phValue | [out] Pointer to string containing writeable storage path.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicenseManager.h

Module: NLicenseManager Unit


NLicManInitialize Function

NLicManInitialize Function

Initializes NLicenseManager.

C++
NResult N_API NLicManInitialize();
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicenseManager.h

Module: NLicenseManager Unit


NLicManIsLicenseTypeSupported Function

NLicManIsLicenseTypeSupported Function

Checks whether the specified license type is supported.

C++
NResult N_API NLicManIsLicenseTypeSupported(NUInt productId, NLicenseType type, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
NUInt productId | [in] Id of a product to check.
NLicenseType type | [in] Type of the license to check.
NBool * pValue | [out] Pointer to NBool which receives check value. NTrue, if license type is supported. Otherwise, NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicenseManager.h

Module: NLicenseManager Unit


NLicManSetClientIdN Function

NLicManSetClientIdN Function

Sets application identifier (Id) if more than one application is used.

C++
NResult N_API NLicManSetClientIdN(HNString hValue);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] Handle to the NString containing client application Id.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicenseManager.h

Module: NLicenseManager Unit


NLicManSetProxyHostN Function

NLicManSetProxyHostN Function

Sets proxy server host name.

C++
NResult N_API NLicManSetProxyHostN(HNString hValue);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] String containing proxy server host name.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

Calling this function with a non-empty string will enable the use of a proxy server. Used for trial and Internet licenses only and only HTTP proxy type is supported.

Container

File: NLicenseManager.h

Module: NLicenseManager Unit


NLicManSetProxyPasswordN Function

NLicManSetProxyPasswordN Function

Sets password to use for proxy server authentication.

C++
NResult N_API NLicManSetProxyPasswordN(HNString hValue);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] String containing password for proxy server authentication.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicenseManager.h

Module: NLicenseManager Unit


NLicManSetProxyPort Function

NLicManSetProxyPort Function

Sets proxy port number of licensing server.

C++
NResult N_API NLicManSetProxyPort(NInt value);
Collapse Expand Parameters
Parameters | Description
NInt value | [in] Proxy port number.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicenseManager.h

Module: NLicenseManager Unit


NLicManSetProxyUsernameN Function

NLicManSetProxyUsernameN Function

Sets username to use for proxy server authentication.

C++
NResult N_API NLicManSetProxyUsernameN(HNString hValue);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] String containing username for proxy server authentication.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

Calling this function with a non-empty string will enable basic proxy authentication using the supplied string as an username. Only Basic authentication method is supported.

Container

File: NLicenseManager.h

Module: NLicenseManager Unit


NLicManSetTrialMode Function

NLicManSetTrialMode Function

Sets trial mode value.

C++
NResult N_API NLicManSetTrialMode(NBool value);
Collapse Expand Parameters
Parameters | Description
NBool value | [in] Trial mode value. NTrue, if trial mode is enabled; NFalse, otherwise.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

Trial mode of SDK is set in Bin/Licenses/TrialFlag.txt

Container

File: NLicenseManager.h

Module: NLicenseManager Unit


NLicManSetUseHttps Function

NLicManSetUseHttps Function

Enables or disables use of HTTPS protocol.

C++
NResult N_API NLicManSetUseHttps(NBool value);
Collapse Expand Parameters
Parameters | Description
NBool value | [in] If true, specifies that HTTPS protocol should be used, else HTTP.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicenseManager.h

Module: NLicenseManager Unit


NLicManSetWritableStoragePathN Function

NLicManSetWritableStoragePathN Function

Sets writeable storage path value.

C++
NResult N_API NLicManSetWritableStoragePathN(HNString hValue);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] String containing writeable storage path.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicenseManager.h

Module: NLicenseManager Unit


NLicManGetLicenseData Macro

NLicManGetLicenseData Macro

Picks a Unicode (W) or ANSCII (A) version of the NLicManGetLicenseData function.

C++
#define NLicManGetLicenseData N_FUNC_AW(NLicManGetLicenseData)
Container

File: NLicenseManager.h

Module: NLicenseManager Unit


NLicManGetLicenseDataEx Macro

NLicManGetLicenseDataEx Macro

Picks a Unicode (W) or ANSCII (A) version of the NLicManGetLicenseDataEx function.

C++
#define NLicManGetLicenseDataEx N_FUNC_AW(NLicManGetLicenseDataEx)
Container

File: NLicenseManager.h

Module: NLicenseManager Unit


NLicManGetUpdateTicketInfo Macro

NLicManGetUpdateTicketInfo Macro

Picks a Unicode (W) or ANSCII (A) version of the NLicManGetUpdateTicketInfo function.

C++
#define NLicManGetUpdateTicketInfo N_FUNC_AW(NLicManGetUpdateTicketInfo)
Container

File: NLicenseManager.h

Module: NLicenseManager Unit


N_LIC_MAN_MAX_LICENSE_LENGTH Macro

N_LIC_MAN_MAX_LICENSE_LENGTH Macro

Defines maximal length of generated license.

C++
#define N_LIC_MAN_MAX_LICENSE_LENGTH 6400
Collapse Expand Remarks

User should allocate N_LIC_MAN_MAX_LICENSE_LENGTH size buffer before generating license (calling NLicManGenerateLicenseN function).

Container

File: NLicenseManager.h

Module: NLicenseManager Unit


N_LIC_MAN_MAX_SERIAL_LENGTH Macro

N_LIC_MAN_MAX_SERIAL_LENGTH Macro

Defines maximal length of serial number.

C++
#define N_LIC_MAN_MAX_SERIAL_LENGTH 39
Collapse Expand Remarks

User should allocate N_LIC_MAN_MAX_SERIAL_LENGTH size buffer before generating serial number (calling NLicManGenerateSerialN function).

Container

File: NLicenseManager.h

Module: NLicenseManager Unit


NLicensing Unit

NLicensing Unit
Files

Provides functionality for getting, releasing licenses.

Collapse Expand Files
Name | Description
NLicensing.h | Header file for the NLicensing library. Provides functionality for getting and releasing licenses.


NLicensing.h

NLicensing.h

Header file for the NLicensing library. Provides functionality for getting and releasing licenses.


NLicensingService Unit

NLicensingService Unit

Manages licensing services.


NMedia Library

NMedia Library

Provides functionality for working with various type of media items: images, audio, video and smart cards. This library has functions you can use to manipulate media.

Collapse Expand Remarks

Requirements (Windows)

  • Import Library:
    • NMedia.dll.lib
    • NMediaProc.dll.lib
  • DLL:
    • NMedia.dll
    • NMediaProc.dll

Requirements (Linux)

  • Shared object:
    • libNMedia.so
    • libNMediaProc.so
Collapse Expand Modules
Name | Description
Bmp Unit | Provides functionality for loading and saving images in BMP format.
IHead Unit | Provides functionality for loading and saving images in NIST IHead format.
Jpeg Unit | Provides functionality for loading and saving images in JPEG format.
Jpeg2K Unit | Provides functionality for loading and saving images in JPEG 2000 format.
NGeometry Unit | Provides definitions of geometrical structures types.
NImageInfo Unit | Retrieves information about images and provides functionality for managing image transformations.
NImageReader Unit | Provides functions which can be used to read image data.
NImages Unit | ... more
NImageWriter Unit | Provides functionality for writing data to an image.
NMediaFormat Unit | Provides functions to retrieve information about media formats
NMediaReader Unit | Provides functions which can be used to read media data.
NMediaSource Unit | Provides functions for working with media source.
NMediaTypes Unit | Enumerates media types and provides functions to check if media type is valid.
NPixelFormat Unit | Provides functionality for working with image pixel format.
NRgb Unit | Provides functionality for working with Rgb image data.
NVideoFormat Unit |
Png Unit | Provides functionality for loading and saving images in PNG format.
Tiff Unit | Provides functionality for loading images in TIFF format.
Wsq Unit | Provides functionality for loading and saving images in WSQ format.


Bmp Unit

Bmp Unit
Files

Provides functionality for loading and saving images in BMP format.

Collapse Expand Files
Name | Description
Bmp.h | Header file for Bmp module. Provides functionality for loading and saving images in BMP format.


Bmp.h

Bmp.h

Header file for Bmp module. Provides functionality for loading and saving images in BMP format.


IHead Unit

IHead Unit
Files

Provides functionality for loading and saving images in NIST IHead format.

Collapse Expand Files
Name | Description
IHead.h | Header file for IHead Module. Provides functionality for loading and saving images in NIST IHead format.


IHead.h

IHead.h

Header file for IHead Module. Provides functionality for loading and saving images in NIST IHead format.


Jpeg Unit

Jpeg Unit
Files Functions Legend Macros

Provides functionality for loading and saving images in JPEG format.

Collapse Expand Files
Name | Description
Jpeg.h | Header file for Jpeg module. Provides functionality for loading and saving images in JPEG format.
Collapse Expand Functions
Name | Description
JpegInfoGetQuality | Retrieves a NInt value which defines the quality of a specified JPEG image.
JpegInfoIsLossless | Checks if a JPEG image is lossless.
JpegInfoSetLossless | Defines if a JPEG image is lossless.
JpegInfoSetQuality | Sets the quality value for a JPEG image.
Collapse Expand Macros
Name | Description
JPEG_DEFAULT_QUALITY | Specifies default JPEG quality.


JpegInfoGetQuality Function

JpegInfoGetQuality Function
Jpeg.h

Retrieves a NInt value which defines the quality of a specified JPEG image.

C++
NResult N_API JpegInfoGetQuality(HJpegInfo hInfo, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HJpegInfo hInfo | [in] A handle to JpegInfo.
NInt * pValue | [out] A pointer to the quality value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: Jpeg.h

Module: Jpeg Unit


JpegInfoIsLossless Function

JpegInfoIsLossless Function
Jpeg.h

Checks if a JPEG image is lossless.

C++
NResult N_API JpegInfoIsLossless(HJpegInfo hInfo, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HJpegInfo hInfo | [in] A handle to the JpegInfo.
NBool * pValue | [out] A pointer to a NBool value. NTrue if the image is lossless; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: Jpeg.h

Module: Jpeg Unit


JpegInfoSetLossless Function

JpegInfoSetLossless Function
Jpeg.h

Defines if a JPEG image is lossless.

C++
NResult N_API JpegInfoSetLossless(HJpegInfo hInfo, NBool value);
Collapse Expand Parameters
Parameters | Description
HJpegInfo hInfo | [in] A handle to the JpegInfo.
NBool value | [in] A NBool value to be set. NTrue for lossless; else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: Jpeg.h

Module: Jpeg Unit


JpegInfoSetQuality Function

JpegInfoSetQuality Function
Jpeg.h

Sets the quality value for a JPEG image.

C++
NResult N_API JpegInfoSetQuality(HJpegInfo hInfo, NInt value);
Collapse Expand Parameters
Parameters | Description
HJpegInfo hInfo | [in] A handle to the JpegInfo.
NInt value | [in] NInt to be set as quality value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: Jpeg.h

Module: Jpeg Unit


JPEG_DEFAULT_QUALITY Macro

JPEG_DEFAULT_QUALITY Macro
Jpeg.h

Specifies default JPEG quality.

C++
#define JPEG_DEFAULT_QUALITY 75
Container

File: Jpeg.h

Module: Jpeg Unit


Jpeg.h

Jpeg.h
Functions Legend Macros

Header file for Jpeg module. Provides functionality for loading and saving images in JPEG format.

Collapse Expand Functions
Name | Description
JpegInfoGetQuality | Retrieves a NInt value which defines the quality of a specified JPEG image.
JpegInfoIsLossless | Checks if a JPEG image is lossless.
JpegInfoSetLossless | Defines if a JPEG image is lossless.
JpegInfoSetQuality | Sets the quality value for a JPEG image.
Collapse Expand Macros
Name | Description
JPEG_DEFAULT_QUALITY | Specifies default JPEG quality.


Jpeg2K Unit

Jpeg2K Unit
Files Functions Legend Macros Structs, Records, Enums

Provides functionality for loading and saving images in JPEG 2000 format.

Collapse Expand Files
Name | Description
Jpeg2K.h | Header file for Jpeg2K Module. Provides functionality for loading and saving images in JPEG 2000 format.
Collapse Expand Functions
Name | Description
Jpeg2KInfoGetProfile | Returns Jpeg 2000 profile.
Jpeg2KInfoGetRatio | Returns Jpeg 2000 image compression ration.
Jpeg2KInfoSetProfile | Sets Jpeg 2000 profile value.
Jpeg2KInfoSetRatio | Sets Jpeg 2000 image compression ration.
Collapse Expand Macros
Name | Description
JPEG_2K_DEFAULT_RATIO | Specifies default JPEG 2000 quality.
Collapse Expand Structs, Records, Enums
Name | Description
Jpeg2KProfile_ | Enumerates Jpeg 2000 Profile values.
Jpeg2KProfile | Enumerates Jpeg 2000 Profile values.


Jpeg2KInfoGetProfile Function

Jpeg2KInfoGetProfile Function
Jpeg2K.h

Returns Jpeg 2000 profile.

C++
NResult N_API Jpeg2KInfoGetProfile(HJpeg2KInfo hInfo, Jpeg2KProfile * pValue);
Collapse Expand Parameters
Parameters | Description
HJpeg2KInfo hInfo | [in] Handle to Jpeg2KInfo.
Jpeg2KProfile * pValue | [out] Pointer to Jpeg2KProfile.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise error code is returned. NSucceeded or NFailed macros can be used to detect whether the function succeeded or failed.

Container

File: Jpeg2K.h

Module: Jpeg2K Unit


Jpeg2KInfoGetRatio Function

Jpeg2KInfoGetRatio Function
Jpeg2K.h

Returns Jpeg 2000 image compression ration.

C++
NResult N_API Jpeg2KInfoGetRatio(HJpeg2KInfo hInfo, NFloat * pValue);
Collapse Expand Parameters
Parameters | Description
HJpeg2KInfo hInfo | [in] Handle to Jpeg2KInfo.
NFloat * pValue | [out] Jpeg 2000 image compression ratio.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise error code is returned. NSucceeded or NFailed macros can be used to detect whether the function succeeded or failed.

Container

File: Jpeg2K.h

Module: Jpeg2K Unit


Jpeg2KInfoSetProfile Function

Jpeg2KInfoSetProfile Function
Jpeg2K.h

Sets Jpeg 2000 profile value.

C++
NResult N_API Jpeg2KInfoSetProfile(HJpeg2KInfo hInfo, Jpeg2KProfile value);
Collapse Expand Parameters
Parameters | Description
HJpeg2KInfo hInfo | [in] Handle to Jpeg2KInfo.
Jpeg2KProfile value | [in] Jpeg2KProfile value to set.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise error code is returned. NSucceeded or NFailed macros can be used to detect whether the function succeeded or failed.

Collapse Expand Notes

When one of Jpeg2KProfile values are used (except jpeg2kpNone), then JPEG_2K_DEFAULT_RATIO parameter value is ignored.

Container

File: Jpeg2K.h

Module: Jpeg2K Unit


Jpeg2KInfoSetRatio Function

Jpeg2KInfoSetRatio Function
Jpeg2K.h

Sets Jpeg 2000 image compression ration.

C++
NResult N_API Jpeg2KInfoSetRatio(HJpeg2KInfo hInfo, NFloat value);
Collapse Expand Parameters
Parameters | Description
HJpeg2KInfo hInfo | [in] Handle to Jpeg2KInfo.
NFloat value | [in] Jpeg 2000 image compression ratio to set.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise error code is returned. NSucceeded or NFailed macros can be used to detect whether the function succeeded or failed.

Container

File: Jpeg2K.h

Module: Jpeg2K Unit


Jpeg2KProfile Enumeration

Jpeg2KProfile Enumeration
Jpeg2K.h

Enumerates Jpeg 2000 Profile values.

C++
typedef enum Jpeg2KProfile_ {
  jpeg2kpNone = 0,
  jpeg2kpFingerprint1000Ppi = 1000,
  jpeg2kpFingerprintLossless = 1001,
  jpeg2kpFaceLossy = 2000,
  jpeg2kpFaceLossless = 2001
} Jpeg2KProfile;
Collapse Expand Members
Members | Description
jpeg2kpNone = 0 | Default JPEG profile.
jpeg2kpFingerprint1000Ppi = 1000 | MTR 04B0000022 (Mitre Technical Report), Margaret Lepley, Profile for 1000ppi Fingerprint Compression, Version 1.1, April 2004.
jpeg2kpFingerprintLossless = 1001 | Fingerprint image, lossless.
jpeg2kpFaceLossy = 2000 | ANSI/NIST-ITL 1-2007
jpeg2kpFaceLossless = 2001 | ANSI/NIST-ITL 1-2007
Container

File: Jpeg2K.h

Module: Jpeg2K Unit


JPEG_2K_DEFAULT_RATIO Macro

JPEG_2K_DEFAULT_RATIO Macro
Jpeg2K.h

Specifies default JPEG 2000 quality.

C++
#define JPEG_2K_DEFAULT_RATIO 10.0f
Collapse Expand Notes

This parameter controls compression ratio when saving images to a file. E.g., when 10 is specified compressed image will have 10:1 size ratio compared to that of the uncompressed file. If lossless image is required, then 0 for JPEG_2K_DEFAULT_RATIO parameter should be specified.

Compression ratio can be set using Jpeg2KInfoSetRatio function.

When one of Jpeg2KProfile values are used (except jpeg2kpNone), then JPEG_2K_DEFAULT_RATIO parameter value is ignored.

Container

File: Jpeg2K.h

Module: Jpeg2K Unit


Jpeg2K.h

Jpeg2K.h
Enumerations Functions Legend Macros

Header file for Jpeg2K Module. Provides functionality for loading and saving images in JPEG 2000 format.

Collapse Expand Enumerations
Name | Description
Jpeg2KProfile_ | Enumerates Jpeg 2000 Profile values.
Jpeg2KProfile | Enumerates Jpeg 2000 Profile values.
Collapse Expand Functions
Name | Description
Jpeg2KInfoGetProfile | Returns Jpeg 2000 profile.
Jpeg2KInfoGetRatio | Returns Jpeg 2000 image compression ration.
Jpeg2KInfoSetProfile | Sets Jpeg 2000 profile value.
Jpeg2KInfoSetRatio | Sets Jpeg 2000 image compression ration.
Collapse Expand Macros
Name | Description
JPEG_2K_DEFAULT_RATIO | Specifies default JPEG 2000 quality.


NGeometry Unit

NGeometry Unit
Files Legend Structs, Records, Enums Types

Provides definitions of geometrical structures types.

Collapse Expand Files
Name | Description
NGeometry.h | Header file for the NGeometry module. Provides definitions of geometrical structures types.
Collapse Expand Structs, Records, Enums
Name | Description
NInterpolationMode_ | Enumerates interpolation modes.
NPoint3F_ | Structure defining point coordinates in 3D space.
NRect_ | Structure defining a rectangle figure in 2D space.
NPoint_ | Structure defining point coordinates in 2D space.
NSize_ | Structure defining rectangle size.
NInterpolationMode | Enumerates interpolation modes.
NPointD_ | Structure defining point coordinates in 2D space.
NPointF_ | Structure defining point coordinates in 2D space.
NRectD_ | Structure defining a rectangle figure in 2D space.
NRectF_ | Structure defining a rectangle figure in 2D space.
NSizeD_ | Structure defining rectangle size.
NSizeF_ | Structure defining rectangle size.
Collapse Expand Types
Name | Description
NPoint | Structure defining point coordinates in 2D space.
NPoint3F | Structure defining point coordinates in 3D space.
NRect | Structure defining a rectangle figure in 2D space.
NSize | Structure defining rectangle size.
NPointD | Structure defining point coordinates in 2D space.
NPointF | Structure defining point coordinates in 2D space.
NRectD | Structure defining a rectangle figure in 2D space.
NRectF | Structure defining a rectangle figure in 2D space.
NSizeD | Structure defining rectangle size.
NSizeF | Structure defining rectangle size.


NPoint3F_ Structure

NPoint3F_ Structure
NGeometry.h

Structure defining point coordinates in 3D space.

C++
struct NPoint3F_ {
  NFloat X;
  NFloat Y;
  NFloat Z;
};
Collapse Expand Members
Members | Description
NFloat X; | Point coordinate on x axis.
NFloat Y; | Point coordinate on Y axis.
NFloat Z; | Point coordinate on Z axis.
Container

File: NGeometry.h

Module: NGeometry Unit


NRect_ Structure

NRect_ Structure
NGeometry.h

Structure defining a rectangle figure in 2D space.

C++
struct NRect_ {
  NInt X;
  NInt Y;
  NInt Width;
  NInt Height;
};
Collapse Expand Members
Members | Description
NInt X; | Upper left rectangle corner coordinate on x axis.
NInt Y; | Upper left rectangle corner coordinate on y axis.
NInt Width; | Rectangle width.
NInt Height; | Rectangle height.
Container

File: NGeometry.h

Module: NGeometry Unit


NPoint_ Structure

NPoint_ Structure
NGeometry.h

Structure defining point coordinates in 2D space.

C++
struct NPoint_ {
  NInt X;
  NInt Y;
};
Collapse Expand Members
Members | Description
NInt X; | Point coordinate on x axis.
NInt Y; | Point coordinate on y axis.
Container

File: NGeometry.h

Module: NGeometry Unit


NSize_ Structure

NSize_ Structure
NGeometry.h

Structure defining rectangle size.

C++
struct NSize_ {
  NInt Width;
  NInt Height;
};
Collapse Expand Members
Members | Description
NInt Width; | Width.
NInt Height; | Height.
Container

File: NGeometry.h

Module: NGeometry Unit


NInterpolationMode Enumeration

NInterpolationMode Enumeration
NGeometry.h

Enumerates interpolation modes.

C++
typedef enum NInterpolationMode_ {
  nimBilinear = 3,
  nimBicubic = 4,
  nimNearestNeighbor = 5
} NInterpolationMode;
Collapse Expand Members
Members | Description
nimBilinear = 3 | Bilinear interpolation.
nimBicubic = 4 | Bicubic interpolation.
nimNearestNeighbor = 5 | Nearest neighbor interpolation.
Container

File: NGeometry.h

Module: NGeometry Unit


NPointD_ Structure

NPointD_ Structure
NGeometry.h

Structure defining point coordinates in 2D space.

C++
struct NPointD_ {
  NDouble X;
  NDouble Y;
};
Collapse Expand Members
Members | Description
NDouble X; | Point coordinate on x axis.
NDouble Y; | Point coordinate on y axis.
Container

File: NGeometry.h

Module: NGeometry Unit


NPointF_ Structure

NPointF_ Structure
NGeometry.h

Structure defining point coordinates in 2D space.

C++
struct NPointF_ {
  NFloat X;
  NFloat Y;
};
Collapse Expand Members
Members | Description
NFloat X; | Point coordinate on x axis.
NFloat Y; | Point coordinate on y axis.
Container

File: NGeometry.h

Module: NGeometry Unit


NRectD_ Structure

NRectD_ Structure
NGeometry.h

Structure defining a rectangle figure in 2D space.

C++
struct NRectD_ {
  NDouble X;
  NDouble Y;
  NDouble Width;
  NDouble Height;
};
Collapse Expand Members
Members | Description
NDouble X; | Upper left rectangle corner coordinate on x axis.
NDouble Y; | Upper left rectangle corner coordinate on y axis.
NDouble Width; | Rectangle width.
NDouble Height; | Rectangle height.
Container

File: NGeometry.h

Module: NGeometry Unit


NRectF_ Structure

NRectF_ Structure
NGeometry.h

Structure defining a rectangle figure in 2D space.

C++
struct NRectF_ {
  NFloat X;
  NFloat Y;
  NFloat Width;
  NFloat Height;
};
Collapse Expand Members
Members | Description
NFloat X; | Upper left rectangle corner coordinate on x axis.
NFloat Y; | Upper left rectangle corner coordinate on y axis.
NFloat Width; | Rectangle width.
NFloat Height; | Rectangle height.
Container

File: NGeometry.h

Module: NGeometry Unit


NSizeD_ Structure

NSizeD_ Structure
NGeometry.h

Structure defining rectangle size.

C++
struct NSizeD_ {
  NDouble Width;
  NDouble Height;
};
Collapse Expand Members
Members | Description
NDouble Width; | Width.
NDouble Height; | Height.
Container

File: NGeometry.h

Module: NGeometry Unit


NSizeF_ Structure

NSizeF_ Structure
NGeometry.h

Structure defining rectangle size.

C++
struct NSizeF_ {
  NFloat Width;
  NFloat Height;
};
Collapse Expand Members
Members | Description
NFloat Width; | Width.
NFloat Height; | Height.
Container

File: NGeometry.h

Module: NGeometry Unit


NPoint Type

NPoint Type
NGeometry.h

Structure defining point coordinates in 2D space.

C++
typedef struct NPoint_ NPoint;
Container

File: NGeometry.h

Module: NGeometry Unit


NPoint3F Type

NPoint3F Type
NGeometry.h

Structure defining point coordinates in 3D space.

C++
typedef struct NPoint3F_ NPoint3F;
Container

File: NGeometry.h

Module: NGeometry Unit


NRect Type

NRect Type
NGeometry.h

Structure defining a rectangle figure in 2D space.

C++
typedef struct NRect_ NRect;
Container

File: NGeometry.h

Module: NGeometry Unit


NSize Type

NSize Type
NGeometry.h

Structure defining rectangle size.

C++
typedef struct NSize_ NSize;
Container

File: NGeometry.h

Module: NGeometry Unit


NPointD Type

NPointD Type
NGeometry.h

Structure defining point coordinates in 2D space.

C++
typedef struct NPointD_ NPointD;
Container

File: NGeometry.h

Module: NGeometry Unit


NPointF Type

NPointF Type
NGeometry.h

Structure defining point coordinates in 2D space.

C++
typedef struct NPointF_ NPointF;
Container

File: NGeometry.h

Module: NGeometry Unit


NRectD Type

NRectD Type
NGeometry.h

Structure defining a rectangle figure in 2D space.

C++
typedef struct NRectD_ NRectD;
Container

File: NGeometry.h

Module: NGeometry Unit


NRectF Type

NRectF Type
NGeometry.h

Structure defining a rectangle figure in 2D space.

C++
typedef struct NRectF_ NRectF;
Container

File: NGeometry.h

Module: NGeometry Unit


NSizeD Type

NSizeD Type
NGeometry.h

Structure defining rectangle size.

C++
typedef struct NSizeD_ NSizeD;
Container

File: NGeometry.h

Module: NGeometry Unit


NSizeF Type

NSizeF Type
NGeometry.h

Structure defining rectangle size.

C++
typedef struct NSizeF_ NSizeF;
Container

File: NGeometry.h

Module: NGeometry Unit


NGeometry.h

NGeometry.h
Enumerations Legend Structures Types

Header file for the NGeometry module. Provides definitions of geometrical structures types.

Collapse Expand Enumerations
Name | Description
NInterpolationMode_ | Enumerates interpolation modes.
NInterpolationMode | Enumerates interpolation modes.
Collapse Expand Structures
Name | Description
NPoint3F_ | Structure defining point coordinates in 3D space.
NPointD_ | Structure defining point coordinates in 2D space.
NPointF_ | Structure defining point coordinates in 2D space.
NPoint_ | Structure defining point coordinates in 2D space.
NRectD_ | Structure defining a rectangle figure in 2D space.
NRectF_ | Structure defining a rectangle figure in 2D space.
NRect_ | Structure defining a rectangle figure in 2D space.
NSizeD_ | Structure defining rectangle size.
NSizeF_ | Structure defining rectangle size.
NSize_ | Structure defining rectangle size.
Collapse Expand Types
Name | Description
NPoint | Structure defining point coordinates in 2D space.
NPoint3F | Structure defining point coordinates in 3D space.
NPointD | Structure defining point coordinates in 2D space.
NPointF | Structure defining point coordinates in 2D space.
NRect | Structure defining a rectangle figure in 2D space.
NRectD | Structure defining a rectangle figure in 2D space.
NRectF | Structure defining a rectangle figure in 2D space.
NSize | Structure defining rectangle size.
NSizeD | Structure defining rectangle size.
NSizeF | Structure defining rectangle size.


NImageInfo Unit

NImageInfo Unit
Files Functions Legend Structs, Records, Enums

Retrieves information about images and provides functionality for managing image transformations.

Collapse Expand Files
Name | Description
NImageInfo.h | Header file for the NImageInfo module.
Collapse Expand Functions
Name | Description
NImageInfoCreate | Creates a new image information object.
NImageInfoGetFormatEx | Retrieves the format of the image.
NImageInfoGetHeight | Retrieves the height of the image.
NImageInfoGetTransform | Retrieves the transformation of the image.
NImageInfoGetWidth | Retrieves the width of the image.
NImageInfoSetTransform | Sets the transformation of the image.
NImageRotateFlipTypeCreate | Creates a new object which holds image transformation information.
NImageRotateFlipTypeFlipTypeIsValid | Checks whether the specified image flip value is valid.
NImageRotateFlipTypeGetFlipType | Retrieves the image rotation value from the image transformation information.
NImageRotateFlipTypeGetRotateType | Retrieves the image rotation value from the image transformation information.
NImageRotateFlipTypeIsValid | Checks whether the image transformation information is valid.
NImageRotateFlipTypeMinimizeFlip | Minimizes the specified image flip value.
NImageRotateFlipTypeMinimizeRotation | Minimizes the specified image rotation value.
NImageRotateFlipTypeRotateTypeIsValid | Checks whether the specified image rotation value is valid.
Collapse Expand Structs, Records, Enums
Name | Description
NImageRotateFlipType_ | Enumerates image transformations.
NImageCompressionAlgorithm_ | Enumerates image compression algorithms.
NImageRotateFlipType | Enumerates image transformations.
NImageCompressionAlgorithm | Enumerates image compression algorithms.


NImageInfoCreate Function

NImageInfoCreate Function
NImageInfo.h

Creates a new image information object.

C++
NResult N_API NImageInfoCreate(HNImageInfo * phInfo);
Collapse Expand Parameters
Parameters | Description
HNImageInfo * phInfo | [out] Pointer to the image information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NImageInfo.h

Module: NImageInfo Unit


NImageInfoGetFormatEx Function

NImageInfoGetFormatEx Function
NImageInfo.h

Retrieves the format of the image.

C++
NResult N_API NImageInfoGetFormatEx(HNImageInfo hInfo, HNImageFormat * phValue);
Collapse Expand Parameters
Parameters | Description
HNImageInfo hInfo | [in] Handle to the image information.
HNImageFormat * phValue | [out] Pointer to the image format.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NImageInfo.h

Module: NImageInfo Unit


NImageInfoGetHeight Function

NImageInfoGetHeight Function
NImageInfo.h

Retrieves the height of the image.

C++
NResult N_API NImageInfoGetHeight(HNImageInfo hInfo, NUInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNImageInfo hInfo | [in] Handle to the image information.
NUInt * pValue | [out] Pointer to the image height.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NImageInfo.h

Module: NImageInfo Unit


NImageInfoGetTransform Function

NImageInfoGetTransform Function
NImageInfo.h

Retrieves the transformation of the image.

C++
NResult N_API NImageInfoGetTransform(HNImageInfo hInfo, NImageRotateFlipType * pValue);
Collapse Expand Parameters
Parameters | Description
HNImageInfo hInfo | [in] Handle to the image information.
NImageRotateFlipType * pValue | [out] Pointer to the image transformation value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NImageInfo.h

Module: NImageInfo Unit


NImageInfoGetWidth Function

NImageInfoGetWidth Function
NImageInfo.h

Retrieves the width of the image.

C++
NResult N_API NImageInfoGetWidth(HNImageInfo hInfo, NUInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNImageInfo hInfo | [in] Handle to the image information.
NUInt * pValue | [out] Pointer to the image width.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NImageInfo.h

Module: NImageInfo Unit


NImageInfoSetTransform Function

NImageInfoSetTransform Function
NImageInfo.h

Sets the transformation of the image.

C++
NResult N_API NImageInfoSetTransform(HNImageInfo hInfo, NImageRotateFlipType value);
Collapse Expand Parameters
Parameters | Description
HNImageInfo hInfo | [in] Handle to the image information.
NImageRotateFlipType value | [in] Image transformation value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NImageInfo.h

Module: NImageInfo Unit


NImageRotateFlipTypeCreate Function

NImageRotateFlipTypeCreate Function
NImageInfo.h

Creates a new object which holds image transformation information.

C++
NResult N_API NImageRotateFlipTypeCreate(NImageRotateFlipType rotate, NImageRotateFlipType flip, NImageRotateFlipType * pValue);
Collapse Expand Parameters
Parameters | Description
NImageRotateFlipType rotate | [in] Image rotation value.
NImageRotateFlipType flip | [in] Image flip value.
NImageRotateFlipType * pValue | [out] Pointer to the image transformation information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NImageInfo.h

Module: NImageInfo Unit


NImageRotateFlipTypeFlipTypeIsValid Function

NImageRotateFlipTypeFlipTypeIsValid Function
NImageInfo.h

Checks whether the specified image flip value is valid.

C++
NBool N_API NImageRotateFlipTypeFlipTypeIsValid(NImageRotateFlipType value);
Collapse Expand Parameters
Parameters | Description
NImageRotateFlipType value | [in] Image flip value.
Collapse Expand Returns

NTrue if the value is valid; else NFalse.

Container

File: NImageInfo.h

Module: NImageInfo Unit


NImageRotateFlipTypeGetFlipType Function

NImageRotateFlipTypeGetFlipType Function
NImageInfo.h

Retrieves the image rotation value from the image transformation information.

C++
NImageRotateFlipType N_API NImageRotateFlipTypeGetFlipType(NImageRotateFlipType value);
Collapse Expand Parameters
Parameters | Description
NImageRotateFlipType value | [in] The image transformation information.
Collapse Expand Returns

Image rotation value.

Container

File: NImageInfo.h

Module: NImageInfo Unit


NImageRotateFlipTypeGetRotateType Function

NImageRotateFlipTypeGetRotateType Function
NImageInfo.h

Retrieves the image rotation value from the image transformation information.

C++
NImageRotateFlipType N_API NImageRotateFlipTypeGetRotateType(NImageRotateFlipType value);
Collapse Expand Parameters
Parameters | Description
NImageRotateFlipType value | [in] The image transformation information.
Collapse Expand Returns

Image flip value.

Container

File: NImageInfo.h

Module: NImageInfo Unit


NImageRotateFlipTypeIsValid Function

NImageRotateFlipTypeIsValid Function
NImageInfo.h

Checks whether the image transformation information is valid.

C++
NBool N_API NImageRotateFlipTypeIsValid(NImageRotateFlipType value);
Collapse Expand Parameters
Parameters | Description
NImageRotateFlipType value | [in] The image transformation information.
Collapse Expand Returns

NTrue if the information is valid; else NFalse.

Container

File: NImageInfo.h

Module: NImageInfo Unit


NImageRotateFlipTypeMinimizeFlip Function

NImageRotateFlipTypeMinimizeFlip Function
NImageInfo.h

Minimizes the specified image flip value.

C++
NImageRotateFlipType N_API NImageRotateFlipTypeMinimizeFlip(NImageRotateFlipType value);
Collapse Expand Parameters
Parameters | Description
NImageRotateFlipType value | [in] Image flip value.
Collapse Expand Returns

The minimized image flip value.

Container

File: NImageInfo.h

Module: NImageInfo Unit


NImageRotateFlipTypeMinimizeRotation Function

NImageRotateFlipTypeMinimizeRotation Function
NImageInfo.h

Minimizes the specified image rotation value.

C++
NImageRotateFlipType N_API NImageRotateFlipTypeMinimizeRotation(NImageRotateFlipType value);
Collapse Expand Parameters
Parameters | Description
NImageRotateFlipType value | [in] Image rotation value.
Collapse Expand Returns

The minimized image rotation value.

Container

File: NImageInfo.h

Module: NImageInfo Unit


NImageRotateFlipTypeRotateTypeIsValid Function

NImageRotateFlipTypeRotateTypeIsValid Function
NImageInfo.h

Checks whether the specified image rotation value is valid.

C++
NBool N_API NImageRotateFlipTypeRotateTypeIsValid(NImageRotateFlipType value);
Collapse Expand Parameters
Parameters | Description
NImageRotateFlipType value | [in] Image flip value.
Collapse Expand Returns

NTrue if the value is valid; else NFalse.

Container

File: NImageInfo.h

Module: NImageInfo Unit


NImageRotateFlipType Enumeration

NImageRotateFlipType Enumeration
NImageInfo.h

Enumerates image transformations.

C++
typedef enum NImageRotateFlipType_ {
  nirftRotateNone = 0,
  nirftRotate90 = 1,
  nirftRotate180 = 2,
  nirftRotate270 = 3,
  nirftFlipNone = 0,
  nirftFlipX = 4,
  nirftFlipY = 8,
  nirftFlipXY = nirftFlipX|nirftFlipY,
  nirftNone = nirftRotateNone|nirftFlipNone,
  nirftUnspecified = -1
} NImageRotateFlipType;
Collapse Expand Members
Members | Description
nirftRotateNone = 0 | Indicates no rotation.
nirftRotate90 = 1 | Indicates 90-degree rotation.
nirftRotate180 = 2 | Indicates 180-degree rotation.
nirftRotate270 = 3 | Indicates 270-degree rotation.
nirftFlipNone = 0 | Indicates no flip.
nirftFlipX = 4 | Indicates flip along X-axis.
nirftFlipY = 8 | Indicates flip along Y-axis.
nirftFlipXY = nirftFlipX|nirftFlipY | Indicates flip along both X and Y-axes.
nirftNone = nirftRotateNone|nirftFlipNone | Indicates no transformation.
nirftUnspecified = -1 | Indicates that transformation was not specified.
Container

File: NImageInfo.h

Module: NImageInfo Unit


NImageCompressionAlgorithm Enumeration

NImageCompressionAlgorithm Enumeration
NImageInfo.h

Enumerates image compression algorithms.

C++
typedef enum NImageCompressionAlgorithm_ {
  nicaUnspecified = -1,
  nicaNone = 0,
  nicaWsq20 = 1,
  nicaJpeg = 2,
  nicaJpegL = 3,
  nicaJP2 = 4,
  nicaJP2L = 5,
  nicaPng = 6,
  nicaUnknown = 255
} NImageCompressionAlgorithm;
Collapse Expand Members
Members | Description
nicaUnspecified = -1 | Image compression algorithm is not specified.
nicaNone = 0 | None of image compression algorithms.
nicaWsq20 = 1 | Wsq 2.0 image compression algorithm.
nicaJpeg = 2 | Jpeg image compression algorithm.
nicaJpegL = 3 | Lossless Jpeg image compression algorithm.
nicaJP2 = 4 | Jpeg 2000 (JP2) image compression algorithm.
nicaJP2L = 5 | Lossless JPEG 2000 image compression algorithm.
nicaPng = 6 | PNG (Portable Network Graphics) image compression algorithm.
nicaUnknown = 255 | Image compression algorithm is unknown.
Container

File: NImageInfo.h

Module: NImageInfo Unit


NImageInfo.h

NImageInfo.h
Enumerations Functions Legend

Header file for the NImageInfo module.

Collapse Expand Enumerations
Name | Description
NImageCompressionAlgorithm_ | Enumerates image compression algorithms.
NImageRotateFlipType_ | Enumerates image transformations.
NImageCompressionAlgorithm | Enumerates image compression algorithms.
NImageRotateFlipType | Enumerates image transformations.
Collapse Expand Functions
Name | Description
NImageInfoCreate | Creates a new image information object.
NImageInfoGetFormatEx | Retrieves the format of the image.
NImageInfoGetHeight | Retrieves the height of the image.
NImageInfoGetTransform | Retrieves the transformation of the image.
NImageInfoGetWidth | Retrieves the width of the image.
NImageInfoSetTransform | Sets the transformation of the image.
NImageRotateFlipTypeCreate | Creates a new object which holds image transformation information.
NImageRotateFlipTypeFlipTypeIsValid | Checks whether the specified image flip value is valid.
NImageRotateFlipTypeGetFlipType | Retrieves the image rotation value from the image transformation information.
NImageRotateFlipTypeGetRotateType | Retrieves the image rotation value from the image transformation information.
NImageRotateFlipTypeIsValid | Checks whether the image transformation information is valid.
NImageRotateFlipTypeMinimizeFlip | Minimizes the specified image flip value.
NImageRotateFlipTypeMinimizeRotation | Minimizes the specified image rotation value.
NImageRotateFlipTypeRotateTypeIsValid | Checks whether the specified image rotation value is valid.


NImageReader Unit

NImageReader Unit
Files Functions Legend

Provides functions which can be used to read image data.

Collapse Expand Files
Name | Description
NImageReader.h | Header file for the NImageReader module.
Collapse Expand Functions
Name | Description
NImageReaderGetFormatEx | Retrieves the format of the image read by the image reader.
NImageReaderGetReadSize | Retrieves the size of the image read by the image reader.
NImageReaderRead | Reads the image and image information.
NImageReaderReadInfo | Reads the information of an image.


NImageReaderGetFormatEx Function

NImageReaderGetFormatEx Function
NImageReader.h

Retrieves the format of the image read by the image reader.

C++
NResult N_API NImageReaderGetFormatEx(HNImageReader hReader, HNImageFormat * phValue);
Collapse Expand Parameters
Parameters | Description
HNImageReader hReader | [in] Handle to the image reader.
HNImageFormat * phValue | [out] Pointer to the image format.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NImageReader.h

Module: NImageReader Unit


NImageReaderGetReadSize Function

NImageReaderGetReadSize Function
NImageReader.h

Retrieves the size of the image read by the image reader.

C++
NResult N_API NImageReaderGetReadSize(HNImageReader hReader, NSizeType * pSize);
Collapse Expand Parameters
Parameters | Description
HNImageReader hReader | [in] Handle to the image reader.
NSizeType * pSize | [out] Pointer to the image size.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NImageReader.h

Module: NImageReader Unit


NImageReaderRead Function

NImageReaderRead Function
NImageReader.h

Reads the image and image information.

C++
NResult N_API NImageReaderRead(HNImageReader hReader, NUInt flags, HNImageInfo * phInfo, HNImage * phImage);
Collapse Expand Parameters
Parameters | Description
HNImageReader hReader | [in] Handle to the image reader.
NUInt flags | [in] Flags controlling the function. Must be zero.
HNImageInfo * phInfo | [out] Pointer to the image information.
HNImage * phImage | [out] Pointer to the read image.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NImageReader.h

Module: NImageReader Unit


NImageReaderReadInfo Function

NImageReaderReadInfo Function
NImageReader.h

Reads the information of an image.

C++
NResult N_API NImageReaderReadInfo(HNImageReader hReader, NUInt flags, HNImageInfo * phInfo);
Collapse Expand Parameters
Parameters | Description
HNImageReader hReader | [in] Handle to the image reader.
NUInt flags | [in] Flags controlling the function. Must be zero.
HNImageInfo * phInfo | [out] Pointer to the image information.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NImageReader.h

Module: NImageReader Unit


NImageReader.h

NImageReader.h
Functions Legend

Header file for the NImageReader module.

Collapse Expand Functions
Name | Description
NImageReaderGetFormatEx | Retrieves the format of the image read by the image reader.
NImageReaderGetReadSize | Retrieves the size of the image read by the image reader.
NImageReaderRead | Reads the image and image information.
NImageReaderReadInfo | Reads the information of an image.


NImages Unit

NImages Unit
Files Functions Legend

Provides library registration and other additional functionality.

Collapse Expand Files
Name | Description
NImages.h | Header file for NImages module. Provides library registration and other additional functionality.
Collapse Expand Functions
Name | Description
NImagesGetGrayscaleColorWrapperEx | Creates color wrapper for a grayscale image.
NImagesRecolorImage | Recolors the specified image.


NImagesGetGrayscaleColorWrapperEx Function

NImagesGetGrayscaleColorWrapperEx Function
NImages.h

Creates color wrapper for a grayscale image.

C++
NResult N_API NImagesGetGrayscaleColorWrapperEx(HNImage hImage, const struct NRgb_ * pMinColor, const struct NRgb_ * pMaxColor, HNImage * phDstImage);
Collapse Expand Parameters
Parameters | Description
HNImage hImage | [in] Handle to image.
const struct NRgb_ * pMinColor | [out] Specifies color to be used for black color.
const struct NRgb_ * pMaxColor | [out] Specifies color to be used for white color.
HNImage * phDstImage | [out] Pointer to HNImage that receives handle to created image.
Collapse Expand Returns
Return values | Description
N_OK | If the function succeeds, the return value is N_OK.
N_E_ARGUMENT | This error code is returned when image specified by hImage has non-grayscale pixel format (not npfGrayscale or npfMonochrome).
N_E_ARGUMENT_NULL | If the function fails, this error can be returned. This error code is returned when hImage or phDstImage is NULL.
Collapse Expand Remarks

Created image must be deleted using NObjectUnref function.

Created image is a thin wrapper for specified grayscale image. Therefore hImage must not be freed before created image.

Gray values in source image are replaced with according RGB values from range [minColor, maxColor] in created image.

Container

File: NImages.h

Module: NImages Unit


NImagesRecolorImage Function

NImagesRecolorImage Function
NImages.h

Recolors the specified image.

C++
NResult N_API NImagesRecolorImage(HNImage hImage, NPixelFormat_ pixelFormat, HNArray hMinValue, HNArray hMaxValue, HNImage * phDstImage);
Collapse Expand Parameters
Parameters | Description
HNImage hImage | [in] Handle to the image.
NPixelFormat_ pixelFormat | [in] Format of the pixels.
HNArray hMinValue | [in] Handle to the minimum pixel value in the image.
HNArray hMaxValue | [in] Handle to the maximum pixel value in the image.
HNImage * phDstImage | [out] Pointer to a handle to the recolored image.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NImages.h

Module: NImages Unit


NImages.h

NImages.h
Functions Legend

Header file for NImages module. Provides library registration and other additional functionality.

Collapse Expand Functions
Name | Description
NImagesGetGrayscaleColorWrapperEx | Creates color wrapper for a grayscale image.
NImagesRecolorImage | Recolors the specified image.


NImageWriter Unit

NImageWriter Unit
Files Functions Legend

Provides functionality for writing data to an image.

Collapse Expand Files
Name | Description
NImageWriter.h | Header file for the NImageWriter module.
Collapse Expand Functions
Name | Description
NImageWriterGetBuffer | Gets a memory buffer to write data from.
NImageWriterGetFormatEx | Retrieves the format of the image written by the image writer.
NImageWriterWrite | Writes image information to an image.


NImageWriterGetBuffer Function

NImageWriterGetBuffer Function
NImageWriter.h

Gets a memory buffer to write data from.

C++
NResult N_API NImageWriterGetBuffer(HNImageWriter hWriter, HNBuffer * phValue);
Collapse Expand Parameters
Parameters | Description
HNImageWriter hWriter | [in] Handle to the image writer.
HNBuffer * phValue | [out] Pointer to the buffer.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NImageWriter.h

Module: NImageWriter Unit


NImageWriterGetFormatEx Function

NImageWriterGetFormatEx Function
NImageWriter.h

Retrieves the format of the image written by the image writer.

C++
NResult N_API NImageWriterGetFormatEx(HNImageWriter hWriter, HNImageFormat * phValue);
Collapse Expand Parameters
Parameters | Description
HNImageWriter hWriter | [in] Handle to the image writer.
HNImageFormat * phValue | [out] Pointer to the image format.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Notes

This function is deprecated. Use NImageWriterGetFormatEx instead.

Container

File: NImageWriter.h

Module: NImageWriter Unit


NImageWriterWrite Function

NImageWriterWrite Function
NImageWriter.h

Writes image information to an image.

C++
NResult N_API NImageWriterWrite(HNImageWriter hWriter, HNImage hImage, HNImageInfo hInfo, NUInt flags);
Collapse Expand Parameters
Parameters | Description
HNImageWriter hWriter | [in] Handle to the image writer.
HNImage hImage | [in] Handle to the image.
HNImageInfo hInfo | [in] Handle to the image information.
NUInt flags | [in] Flags controlling the function. Must be zero.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NImageWriter.h

Module: NImageWriter Unit


NImageWriter.h

NImageWriter.h
Functions Legend

Header file for the NImageWriter module.

Collapse Expand Functions
Name | Description
NImageWriterGetBuffer | Gets a memory buffer to write data from.
NImageWriterGetFormatEx | Retrieves the format of the image written by the image writer.
NImageWriterWrite | Writes image information to an image.


NMediaFormat Unit

NMediaFormat Unit
Files Functions Legend

Provides functions to retrieve information about media formats

Collapse Expand Files
Name | Description
NMediaFormat.h | Header file for NMediaFormat Unit.
Collapse Expand Functions
Name | Description
NMediaFormatGetMediaSubtype | Gets media subtype from specified media format.
NMediaFormatGetMediaType | Gets media type from specified NMediaFormat.
NMediaFormatIsCompatibleWith | Checks if specified media format is compatible with other media format.
NMediaFormatSetMediaSubtype | Sets media subtype for specified media format.
HNMediaFormat | Handle to HNMediaFormat.


NMediaFormatGetMediaSubtype Function

NMediaFormatGetMediaSubtype Function
NMediaFormat.h

Gets media subtype from specified media format.

C++
NResult N_API NMediaFormatGetMediaSubtype(HNMediaFormat hFormat, NUInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNMediaFormat hFormat | [in] Handle to NMediaFormat to retrieve its subtype.
NUInt * pValue | [out] Media format subtype value (numeric constant).
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For NAudioFormat one of N_AUDIO_FORMAT_* constants is returned as pValue. For NVideoFormat one of N_VIDEO_FORMAT_* constants is returned as pValue. These constants can be converted to string using these functions: NAudioFormatMediaSubtypeToString and NVideoFormatMediaSubtypeToString.

Container

File: NMediaFormat.h

Module: NMediaFormat Unit


NMediaFormatGetMediaType Function

NMediaFormatGetMediaType Function
NMediaFormat.h

Gets media type from specified NMediaFormat.

C++
NResult N_API NMediaFormatGetMediaType(HNMediaFormat hFormat, NMediaType * pValue);
Collapse Expand Parameters
Parameters | Description
HNMediaFormat hFormat | [in] Handle to NMediaFormat to retrieve its type.
NMediaType * pValue | [out] One of media type values. At the moment only nmtAudio and nmtVideo can be returned.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMediaFormat.h

Module: NMediaFormat Unit


NMediaFormatIsCompatibleWith Function

NMediaFormatIsCompatibleWith Function
NMediaFormat.h

Checks if specified media format is compatible with other media format.

C++
NResult N_API NMediaFormatIsCompatibleWith(HNMediaFormat hFormat, HNMediaFormat hOtherFormat, NBool * pResult);
Collapse Expand Parameters
Parameters | Description
HNMediaFormat hFormat | [in] Handle to NMediaFormat to check if it is compatible wither other media format.
HNMediaFormat hOtherFormat | [in] Handle to other media format to check if it is compatible with the first one.
NBool * pResult | [out] Two media formats compatibility check value (NBool).
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMediaFormat.h

Module: NMediaFormat Unit


NMediaFormatSetMediaSubtype Function

NMediaFormatSetMediaSubtype Function
NMediaFormat.h

Sets media subtype for specified media format.

C++
NResult N_API NMediaFormatSetMediaSubtype(HNMediaFormat hFormat, NUInt value);
Collapse Expand Parameters
Parameters | Description
HNMediaFormat hFormat | [in] Handle to NMediaFormat to set its subtype.
NUInt value | [in] Subtype constant to set.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

For NAudioFormat one of N_AUDIO_FORMAT_* constant values should be used as value parameter. For NVideoFormat one of N_VIDEO_FORMAT_* constant values should be used as value parameter.

Container

File: NMediaFormat.h

Module: NMediaFormat Unit


HNMediaFormat

HNMediaFormat

Handle to HNMediaFormat.


NMediaFormat.h

NMediaFormat.h
Functions Legend

Header file for NMediaFormat Unit.

Collapse Expand Functions
Name | Description
NMediaFormatGetMediaSubtype | Gets media subtype from specified media format.
NMediaFormatGetMediaType | Gets media type from specified NMediaFormat.
NMediaFormatIsCompatibleWith | Checks if specified media format is compatible with other media format.
NMediaFormatSetMediaSubtype | Sets media subtype for specified media format.


NMediaReader Unit

NMediaReader Unit
Files Functions Legend Macros

Provides functions which can be used to read media data.

Collapse Expand Files
Name | Description
NMediaReader.h | Header file for NMediaReader Unit.
Collapse Expand Functions
Name | Description
NMediaReaderCreate | Creates media reader object.
NMediaReaderCreateFromFile | Creates NMediaReader from file.
NMediaReaderCreateFromUrl | Creates NMediaReader from URL.
NMediaReaderGetLength | Gets file length (100 ns units) when NMediaReader source is file.
NMediaReaderGetPosition | Gets NMediaReader position in media source (file).
NMediaReaderGetSource | Gets media source (file or device) of the specified NMediaReader.
NMediaReaderGetState | Gets NMediaReader state.
NMediaReaderReadAudioSample | Reads audio sample using specified NMediaReader.
NMediaReaderIsLive | Checks if media source which is used by specified NMediaReader is live.
NMediaReaderReadVideoSample | Reads video sample using specified NMediaReader.
NMediaReaderPause | Pauses specified NMediaReader.
NMediaReaderReadVideoSampleData | Reads video sample data using specified NMediaReader.
NMediaReaderSetPosition | Sets NMediaReader position in media source (file).
NMediaReaderStart | Starts NMediaReader.
NMediaReaderStop | Stops NMediaReader.
HNMediaReader | Handle to NMediaReader
Collapse Expand Macros
Name | Description
NMediaReaderCreateFromFile | Picks a Unicode (W) or ANSCII (A) version of the NMediaReaderFromFile function.
NMediaReaderCreateFromUrl | Picks a Unicode (W) or ANSCII (A) version of the NMediaReaderFromUrl function.


NMediaReaderCreate Function

NMediaReaderCreate Function
NMediaReader.h

Creates media reader object.

C++
NResult N_API NMediaReaderCreate(HNMediaSource hMediaSource, NMediaType mediaTypes, NBool isLive, NUInt flags, HNMediaReader * phReader);
Collapse Expand Parameters
Parameters | Description
HNMediaSource hMediaSource | [in] Handle to media source.
NMediaType mediaTypes | [in] Media types supported by NMediaReader. Can be nmtAudio and nmtVideo (only one at a time or both).
NBool isLive | [in] Flag indicating if media source is live. If set to NTrue media from source will be read in real time (from devices). In this case video or audio samples will be dropped until user calls NMediaReaderReadAudioSample or NMediaReaderReadVideoSample functions. If user calls these functions too quickly they are blocked until new video frame or audio sample appears. If set to NFalse video frames or audio samples are not dropped and user can read them in any speed (gets all samples/frames). When set to NFalse, NMediaReader works only with video/audio data saved in files.
NUInt flags | [in] Flags controlling NMediaReader.
HNMediaReader * phReader | [out] Handle to created media reader.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

These flags can be used (for flags parameter):

  • NMS_DO_NOT_USE_DIRECT_SHOW
  • NMS_DO_NOT_USE_WINDOWS_MEDIA_FOUNDATION
  • NMS_PREFER_DIRECT_SHOW

Note: these flags work only on Windows OS.

Container

File: NMediaReader.h

Module: NMediaReader Unit


NMediaReaderCreateFromFile Function

NMediaReaderCreateFromFile Function
NMediaReader.h

Creates NMediaReader from file.

C++
NResult N_API NMediaReaderCreateFromFile(const NChar * szFileName, NMediaType mediaTypes, NBool isLive, NUInt flags, HNMediaReader * phReader);
Collapse Expand Parameters
Parameters | Description
const NChar * szFileName | [in] Zero-terminated string containing file name.
NMediaType mediaTypes | [in] Media types supported by NMediaReader. Can be nmtAudio and nmtVideo (only one at a time or both).
NBool isLive | [in] Flag indicating if media source is live. If set to NTrue media from source will be read in real time (from devices). In this case video or audio samples will be dropped until user calls NMediaReaderReadAudioSample or NMediaReaderReadVideoSample functions. If user calls these functions too quickly they are blocked until new video frame or audio sample appears. If set to NFalse video frames or audio samples are not dropped and user can read them in any speed (gets all samples/frames). When set to NFalse, NMediaReader works only with video/audio data saved in files.
NUInt flags | [in] Flags controlling NMediaReader.
HNMediaReader * phReader | [out] Handle to created media reader.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

These flags can be used (for flags parameter):

  • NMS_DO_NOT_USE_DIRECT_SHOW
  • NMS_DO_NOT_USE_WINDOWS_MEDIA_FOUNDATION
  • NMS_PREFER_DIRECT_SHOW

Note: these flags work only on Windows OS.

Collapse Expand Notes

This function also creates NMediaSource from file (does the same as NMediaSourceCreateFromFile).

Container

File: NMediaReader.h

Module: NMediaReader Unit


NMediaReaderCreateFromUrl Function

NMediaReaderCreateFromUrl Function
NMediaReader.h

Creates NMediaReader from URL.

C++
NResult N_API NMediaReaderCreateFromUrl(const NChar * szUrl, NMediaType mediaTypes, NBool isLive, NUInt flags, HNMediaReader * phReader);
Collapse Expand Parameters
Parameters | Description
const NChar * szUrl | [in] Zero-terminated string which contains URL address (address of IP camera).
NMediaType mediaTypes | [in] Media types supported by NMediaReader. Can be nmtAudio and nmtVideo (only one at a time or both).
NBool isLive | [in] Flag indicating if media source is live. If set to NTrue media from source will be read in real time (from URL address). In this case video or audio samples will be dropped until user calls NMediaReaderReadAudioSample or NMediaReaderReadVideoSample functions. If user calls these functions too quickly they are blocked until new video frame or audio sample appears. If set to NFalse video frames or audio samples are not dropped and user can read them in any speed (gets all samples/frames). When set to NFalse, NMediaReader works only with video/audio data saved in files. In this case setting NFalse will cause function error.
NUInt flags | [in] Flags controlling NMediaReader.
HNMediaReader * phReader | [out] Handle to created media reader.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

These flags can be used (for flags parameter):

  • NMS_DO_NOT_USE_DIRECT_SHOW
  • NMS_DO_NOT_USE_WINDOWS_MEDIA_FOUNDATION
  • NMS_PREFER_DIRECT_SHOW

Note: these flags work only on Windows OS.

Collapse Expand Notes

This function does the same as NMediaSourceCreateFromUrl.

Container

File: NMediaReader.h

Module: NMediaReader Unit


NMediaReaderGetLength Function

NMediaReaderGetLength Function
NMediaReader.h

Gets file length (100 ns units) when NMediaReader source is file.

C++
NResult N_API NMediaReaderGetLength(HNMediaReader hReader, NTimeSpan_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNMediaReader hReader | [in] Handle to NMediaReader.
NTimeSpan_ * pValue | [out] File length (100ns - nano second units).
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

If media source is device, this function returns length equal to 0.

Container

File: NMediaReader.h

Module: NMediaReader Unit


NMediaReaderGetPosition Function

NMediaReaderGetPosition Function
NMediaReader.h

Gets NMediaReader position in media source (file).

C++
NResult N_API NMediaReaderGetPosition(HNMediaReader hReader, NTimeSpan_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNMediaReader hReader | [in] Handle to NMediaReader.
NTimeSpan_ * pValue | [out] Current position of NMediaReader. Position is time in nano seconds (100ns units)
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMediaReader.h

Module: NMediaReader Unit


NMediaReaderGetSource Function

NMediaReaderGetSource Function
NMediaReader.h

Gets media source (file or device) of the specified NMediaReader.

C++
NResult N_API NMediaReaderGetSource(HNMediaReader hReader, HNMediaSource * phValue);
Collapse Expand Parameters
Parameters | Description
HNMediaReader hReader | [in] Handle to NMediaReader.
HNMediaSource * phValue | [out] Handle to NMediaSource.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMediaReader.h

Module: NMediaReader Unit


NMediaReaderGetState Function

NMediaReaderGetState Function
NMediaReader.h

Gets NMediaReader state.

C++
NResult N_API NMediaReaderGetState(HNMediaReader hReader, NMediaState * pValue);
Collapse Expand Parameters
Parameters | Description
HNMediaReader hReader | [in] Handle to NMediaReader.
NMediaState * pValue | [out] NMediaReader state value (paused, running or stopped).
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMediaReader.h

Module: NMediaReader Unit


NMediaReaderReadAudioSample Function

NMediaReaderReadAudioSample Function
NMediaReader.h

Reads audio sample using specified NMediaReader.

C++
NResult N_API NMediaReaderReadAudioSample(HNMediaReader hReader, NTimeSpan_ * pTimeStamp, NTimeSpan_ * pDuration, HNSoundBuffer * phSoundBuffer);
Collapse Expand Parameters
Parameters | Description
HNMediaReader hReader | [in] Handle to NMediaReader.
NTimeSpan_ * pTimeStamp | [out] Time stamp (from the beginning). 100ns units.
NTimeSpan_ * pDuration | [out] Audio sample duration (100ns units).
HNSoundBuffer * phSoundBuffer | [out] Handle to NSoundBuffer which contains audio sample.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

Before using this function user should start NMediaReader using NMediaReaderStart.

For more information on how to use this function see ReadAudio and ReadAudioFromDevice tutorials.

Container

File: NMediaReader.h

Module: NMediaReader Unit


NMediaReaderIsLive Function

NMediaReaderIsLive Function
NMediaReader.h

Checks if media source which is used by specified NMediaReader is live.

C++
NResult N_API NMediaReaderIsLive(HNMediaReader hReader, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNMediaReader hReader | [in] Handle to NMediaReader.
NBool * pValue | [out] Media source liveness check result. NTrue - media source is live (device). NFalse - media source is not live (file).
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMediaReader.h

Module: NMediaReader Unit


NMediaReaderReadVideoSample Function

NMediaReaderReadVideoSample Function
NMediaReader.h

Reads video sample using specified NMediaReader.

C++
NResult N_API NMediaReaderReadVideoSample(HNMediaReader hReader, NTimeSpan_ * pTimeStamp, NTimeSpan_ * pDuration, HNImage * phImage);
Collapse Expand Parameters
Parameters | Description
HNMediaReader hReader | [in] Handle to NMediaReader.
NTimeSpan_ * pTimeStamp | [out] Time stamp (from the beginning). 100ns units.
NTimeSpan_ * pDuration | [out] Video sample duration (100ns units).
HNImage * phImage | [out] Handle to NImage which contains video sample.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

Before using this function user should start NMediaReader using NMediaReaderStart.

For more information on how to use this function see ReadVideo and ReadVideoFromDevice tutorials.

Container

File: NMediaReader.h

Module: NMediaReader Unit


NMediaReaderPause Function

NMediaReaderPause Function
NMediaReader.h

Pauses specified NMediaReader.

C++
NResult N_API NMediaReaderPause(HNMediaReader hReader);
Collapse Expand Parameters
Parameters | Description
HNMediaReader hReader | [in] Handle to NMediaReader.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMediaReader.h

Module: NMediaReader Unit


NMediaReaderReadVideoSampleData Function

NMediaReaderReadVideoSampleData Function
NMediaReader.h

Reads video sample data using specified NMediaReader.

C++
NResult N_API NMediaReaderReadVideoSampleData(HNMediaReader hReader, HNVideoSample * phSample);
Collapse Expand Parameters
Parameters | Description
HNMediaReader hReader | [in] Handle to NMediaReader.
HNVideoSample * phSample | [out] Pointer to NVideoSample which receives video sample data.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

Before using this function user should start NMediaReader using NMediaReaderStart function.

For more information on how to use this function see ReadVideo and ReadVideoFromDevice tutorials form \Tutorials directory of this SDK.

Container

File: NMediaReader.h

Module: NMediaReader Unit


NMediaReaderSetPosition Function

NMediaReaderSetPosition Function
NMediaReader.h

Sets NMediaReader position in media source (file).

C++
NResult N_API NMediaReaderSetPosition(HNMediaReader hReader, NTimeSpan_ value);
Collapse Expand Parameters
Parameters | Description
HNMediaReader hReader | [in] Handle to NMediaReader.
NTimeSpan_ value | [in] Position of NMediaReader to set. Position is time in nano seconds (100ns units)
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMediaReader.h

Module: NMediaReader Unit


NMediaReaderStart Function

NMediaReaderStart Function
NMediaReader.h

Starts NMediaReader.

C++
NResult N_API NMediaReaderStart(HNMediaReader hReader);
Collapse Expand Parameters
Parameters | Description
HNMediaReader hReader | [in] Handle to NMediaReader to start.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMediaReader.h

Module: NMediaReader Unit


NMediaReaderStop Function

NMediaReaderStop Function
NMediaReader.h

Stops NMediaReader.

C++
NResult N_API NMediaReaderStop(HNMediaReader hReader);
Collapse Expand Parameters
Parameters | Description
HNMediaReader hReader | [in] Handle to NMediaReader to stop.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMediaReader.h

Module: NMediaReader Unit


HNMediaReader

HNMediaReader

Handle to NMediaReader


NMediaReaderCreateFromFile Macro

NMediaReaderCreateFromFile Macro
NMediaReader.h

Picks a Unicode (W) or ANSCII (A) version of the NMediaReaderFromFile function.

C++
#define NMediaReaderCreateFromFile N_FUNC_AW(NMediaReaderCreateFromFile)
Container

File: NMediaReader.h

Module: NMediaReader Unit


NMediaReaderCreateFromUrl Macro

NMediaReaderCreateFromUrl Macro
NMediaReader.h

Picks a Unicode (W) or ANSCII (A) version of the NMediaReaderFromUrl function.

C++
#define NMediaReaderCreateFromUrl N_FUNC_AW(NMediaReaderCreateFromUrl)
Container

File: NMediaReader.h

Module: NMediaReader Unit


NMediaReader.h

NMediaReader.h
Functions Legend Macros

Header file for NMediaReader Unit.

Collapse Expand Functions
Name | Description
NMediaReaderCreate | Creates media reader object.
NMediaReaderCreateFromFile | Creates NMediaReader from file.
NMediaReaderCreateFromUrl | Creates NMediaReader from URL.
NMediaReaderGetLength | Gets file length (100 ns units) when NMediaReader source is file.
NMediaReaderGetPosition | Gets NMediaReader position in media source (file).
NMediaReaderGetSource | Gets media source (file or device) of the specified NMediaReader.
NMediaReaderGetState | Gets NMediaReader state.
NMediaReaderIsLive | Checks if media source which is used by specified NMediaReader is live.
NMediaReaderPause | Pauses specified NMediaReader.
NMediaReaderReadAudioSample | Reads audio sample using specified NMediaReader.
NMediaReaderReadVideoSample | Reads video sample using specified NMediaReader.
NMediaReaderReadVideoSampleData | Reads video sample data using specified NMediaReader.
NMediaReaderSetPosition | Sets NMediaReader position in media source (file).
NMediaReaderStart | Starts NMediaReader.
NMediaReaderStop | Stops NMediaReader.
Collapse Expand Macros
Name | Description
NMediaReaderCreateFromFile | Picks a Unicode (W) or ANSCII (A) version of the NMediaReaderFromFile function.
NMediaReaderCreateFromUrl | Picks a Unicode (W) or ANSCII (A) version of the NMediaReaderFromUrl function.


NMediaSource Unit

NMediaSource Unit
Files Functions Legend Macros

Provides functions for working with media source.

Collapse Expand Files
Name | Description
NMediaSource.h | Header file for NMediaSource Unit.
Collapse Expand Functions
Name | Description
NMediaSourceCreateFromFile | Creates NMediaSource from specified file.
NMediaSourceCreateFromUrl | Creates media source from URL.
NMediaSourceGetDisplayNameN | Gets display name of specified media source.
NMediaSourceEnumDevices | Enumerates all source devices by specified media type.
NMediaSourceGetCurrentFormat | Gets media source format for specified media type.
NMediaSourceGetIdN | Gets media source Id.
NMediaSourceGetFormats | Gets media source formats.
NMediaSourceGetMediaType | Gets media type of specified media source.
NMediaSourceSetCurrentFormat | Sets media source format for specified media type.
HNmediaSource | Handle to NMediaSource unit.
Collapse Expand Macros
Name | Description
NMS_ALLOW_DUPLICATE_DEVICES | ... more
NMS_DO_NOT_USE_DIRECT_SHOW | Used when user prefers not to use DirecShow for NMediaSource.
NMS_DO_NOT_USE_VLC | Used when user prefers not to use VLC for NMediaSource.
NMS_DO_NOT_USE_WINDOWS_MEDIA | Used when user prefers not to use Windows Media for NMediaSource.
NMS_DO_NOT_USE_WINDOWS_MEDIA_FOUNDATION | Used when user prefers not to use Windows Media Foundation for NMediaSource.
NMS_PREFER_DIRECT_SHOW | Used when user prefers to use DirectShow for NMediaSource.
NMS_PREFER_VLC | Used when user prefers to use VLC for NMediaSource.
NMS_PREFER_WINDOWS_MEDIA | Used when user prefers to use Windows Media for NMediaSource.
NMS_PREFER_WINDOWS_MEDIA_FOUNDATION | Used when user prefers to use Media Foundation for NMediaSource.


NMediaSourceCreateFromFile Function

NMediaSourceCreateFromFile Function
NMediaSource.h

Creates NMediaSource from specified file.

C++
NResult N_API NMediaSourceCreateFromFile(const NChar * szFileName, NUInt flags, HNMediaSource * phSource);
Collapse Expand Parameters
Parameters | Description
const NChar * szFileName | [in] Zero terminated string which contains file name.
NUInt flags | [in] Flags controlling NMediaSource.
HNMediaSource * phSource | [out] Handle to created media source.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

Created NMediaSource is used by NMediaReader to read data.

These flags can be used (for flags parameter):

  • NMS_DO_NOT_USE_DIRECT_SHOW
  • NMS_DO_NOT_USE_WINDOWS_MEDIA_FOUNDATION
  • NMS_PREFER_DIRECT_SHOW

Note: these flags work only on Windows OS.

Collapse Expand Notes

User also can call NMediaReaderCreateFromFile function which creates NMediaSource and NMediaReader at the same time.

Container

File: NMediaSource.h

Module: NMediaSource Unit


NMediaSourceCreateFromUrl Function

NMediaSourceCreateFromUrl Function
NMediaSource.h

Creates media source from URL.

C++
NResult N_API NMediaSourceCreateFromUrl(const NChar * szUrl, NUInt flags, HNMediaSource * phSource);
Collapse Expand Parameters
Parameters | Description
const NChar * szUrl | [in] Zero-terminated string which contains URL address (address of IP camera).
NUInt flags | [in] Flags controlling NMediaSource.
HNMediaSource * phSource | [out] Handle to created media source.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

These flags can be used (for flags parameter):

  • NMS_DO_NOT_USE_DIRECT_SHOW
  • NMS_DO_NOT_USE_WINDOWS_MEDIA_FOUNDATION
  • NMS_PREFER_DIRECT_SHOW

Note: these flags work only on Windows OS.

Collapse Expand Notes

User also can call NMediaReaderCreateFromUrl function which creates NMediaSource and NMediaReader at the same time.

Container

File: NMediaSource.h

Module: NMediaSource Unit


NMediaSourceGetDisplayNameN Function

NMediaSourceGetDisplayNameN Function
NMediaSource.h

Gets display name of specified media source.

C++
NResult N_API NMediaSourceGetDisplayNameN(HNMediaSource hSource, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNMediaSource hSource | [in] Handle to NMediaSource to retrieve display name of it source (file or live stream).
HNString * phValue | [out] NString containing media source display name.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

Returned string can be used to display media source name on a screen.

Container

File: NMediaSource.h

Module: NMediaSource Unit


NMediaSourceEnumDevices Function

NMediaSourceEnumDevices Function
NMediaSource.h

Enumerates all source devices by specified media type.

C++
NResult N_API NMediaSourceEnumDevices(NMediaType mediaType, NUInt flags, HNMediaSource * * parhDevices, NInt * pDeviceCount);
Collapse Expand Parameters
Parameters | Description
NMediaType mediaType | [in] Device media type.
NUInt flags | [in] Flags controlling NMediaSource.
HNMediaSource * * parhDevices | [out] Pointer to array of handles to media sources.
NInt * pDeviceCount | [out] Devices count.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Notes

User should free all resources (array and handles) used by this function. NObjectFreeArray function is used for this purpose.

Container

File: NMediaSource.h

Module: NMediaSource Unit


NMediaSourceGetCurrentFormat Function

NMediaSourceGetCurrentFormat Function
NMediaSource.h

Gets media source format for specified media type.

C++
NResult N_API NMediaSourceGetCurrentFormat(HNMediaSource hSource, NMediaType mediaType, HNMediaFormat * phFormat);
Collapse Expand Parameters
Parameters | Description
HNMediaSource hSource | [in] Handle to NMediaSource.
NMediaType mediaType | [in] Media type to retrieve its format.
HNMediaFormat * phFormat | [out] Handle to NMediaFormat which defines format of current media source.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

NMediaSourceGetMediaType function can be used to determine NMediaSource type. This function can be called only when media source is inside NMediaReader.

Container

File: NMediaSource.h

Module: NMediaSource Unit


NMediaSourceGetIdN Function

NMediaSourceGetIdN Function
NMediaSource.h

Gets media source Id.

C++
NResult N_API NMediaSourceGetIdN(HNMediaSource hSource, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNMediaSource hSource | [in] Handle to NMediaSource.
HNString * phValue | [out] Media source Id.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMediaSource.h

Module: NMediaSource Unit


NMediaSourceGetFormats Function

NMediaSourceGetFormats Function
NMediaSource.h

Gets media source formats.

C++
NResult N_API NMediaSourceGetFormats(HNMediaSource hSource, NMediaType mediaType, HNMediaFormat * * parhFormats, NInt * pFormatCount);
Collapse Expand Parameters
Parameters | Description
HNMediaSource hSource | [in] Handle to NMediaSource.
NMediaType mediaType | [in] Media type to retrieve its formats.
HNMediaFormat * * parhFormats | [out] Pointer to array which contains handles to NMediaFormat.
NInt * pFormatCount | [out] Array items count.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMediaSource.h

Module: NMediaSource Unit


NMediaSourceGetMediaType Function

NMediaSourceGetMediaType Function
NMediaSource.h

Gets media type of specified media source.

C++
NResult N_API NMediaSourceGetMediaType(HNMediaSource hSource, NMediaType * pValue);
Collapse Expand Parameters
Parameters | Description
HNMediaSource hSource | [in] Handle to NMediaSource.
NMediaType * pValue | [out] Pointer to NMediaType which contains the type of current media source.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMediaSource.h

Module: NMediaSource Unit


NMediaSourceSetCurrentFormat Function

NMediaSourceSetCurrentFormat Function
NMediaSource.h

Sets media source format for specified media type.

C++
NResult N_API NMediaSourceSetCurrentFormat(HNMediaSource hSource, NMediaType mediaType, HNMediaFormat hFormat);
Collapse Expand Parameters
Parameters | Description
HNMediaSource hSource | [in] Handle to NMediaSource.
NMediaType mediaType | [in] Media type for which format should be set.
HNMediaFormat hFormat | [in] Handle to media format to set.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMediaSource.h

Module: NMediaSource Unit


HNmediaSource

HNmediaSource

Handle to NMediaSource unit.


NMS_ALLOW_DUPLICATE_DEVICES Macro

NMS_ALLOW_DUPLICATE_DEVICES Macro
NMediaSource.h

This flag is used to allow enumerating duplicate devices. If this flag was set and the same device is accessible through DirectShow and Windows Media Foundation (Windows 7) then this device will be enumerated twice.

C++
#define NMS_ALLOW_DUPLICATE_DEVICES 0x00000008
Container

File: NMediaSource.h

Module: NMediaSource Unit


NMS_DO_NOT_USE_DIRECT_SHOW Macro

NMS_DO_NOT_USE_DIRECT_SHOW Macro
NMediaSource.h

Used when user prefers not to use DirecShow for NMediaSource.

C++
#define NMS_DO_NOT_USE_DIRECT_SHOW 0x00000001
Container

File: NMediaSource.h

Module: NMediaSource Unit


NMS_DO_NOT_USE_VLC Macro

NMS_DO_NOT_USE_VLC Macro
NMediaSource.h

Used when user prefers not to use VLC for NMediaSource.

C++
#define NMS_DO_NOT_USE_VLC 0x00000020
Container

File: NMediaSource.h

Module: NMediaSource Unit


NMS_DO_NOT_USE_WINDOWS_MEDIA Macro

NMS_DO_NOT_USE_WINDOWS_MEDIA Macro
NMediaSource.h

Used when user prefers not to use Windows Media for NMediaSource.

C++
#define NMS_DO_NOT_USE_WINDOWS_MEDIA 0x00000010
Container

File: NMediaSource.h

Module: NMediaSource Unit


NMS_DO_NOT_USE_WINDOWS_MEDIA_FOUNDATION Macro

NMS_DO_NOT_USE_WINDOWS_MEDIA_FOUNDATION Macro
NMediaSource.h

Used when user prefers not to use Windows Media Foundation for NMediaSource.

C++
#define NMS_DO_NOT_USE_WINDOWS_MEDIA_FOUNDATION 0x00000002
Container

File: NMediaSource.h

Module: NMediaSource Unit


NMS_PREFER_DIRECT_SHOW Macro

NMS_PREFER_DIRECT_SHOW Macro
NMediaSource.h

Used when user prefers to use DirectShow for NMediaSource.

C++
#define NMS_PREFER_DIRECT_SHOW 0x00000004
Container

File: NMediaSource.h

Module: NMediaSource Unit


NMS_PREFER_VLC Macro

NMS_PREFER_VLC Macro
NMediaSource.h

Used when user prefers to use VLC for NMediaSource.

C++
#define NMS_PREFER_VLC 0x00000100
Container

File: NMediaSource.h

Module: NMediaSource Unit


NMS_PREFER_WINDOWS_MEDIA Macro

NMS_PREFER_WINDOWS_MEDIA Macro
NMediaSource.h

Used when user prefers to use Windows Media for NMediaSource.

C++
#define NMS_PREFER_WINDOWS_MEDIA 0x00000080
Container

File: NMediaSource.h

Module: NMediaSource Unit


NMS_PREFER_WINDOWS_MEDIA_FOUNDATION Macro

NMS_PREFER_WINDOWS_MEDIA_FOUNDATION Macro
NMediaSource.h

Used when user prefers to use Media Foundation for NMediaSource.

C++
#define NMS_PREFER_WINDOWS_MEDIA_FOUNDATION 0x00000040
Container

File: NMediaSource.h

Module: NMediaSource Unit


NMediaSource.h

NMediaSource.h
Functions Legend Macros

Header file for NMediaSource Unit.

Collapse Expand Functions
Name | Description
NMediaSourceCreateFromFile | Creates NMediaSource from specified file.
NMediaSourceCreateFromUrl | Creates media source from URL.
NMediaSourceEnumDevices | Enumerates all source devices by specified media type.
NMediaSourceGetCurrentFormat | Gets media source format for specified media type.
NMediaSourceGetDisplayNameN | Gets display name of specified media source.
NMediaSourceGetFormats | Gets media source formats.
NMediaSourceGetIdN | Gets media source Id.
NMediaSourceGetMediaType | Gets media type of specified media source.
NMediaSourceSetCurrentFormat | Sets media source format for specified media type.
Collapse Expand Macros
Name | Description
NMS_ALLOW_DUPLICATE_DEVICES | ... more
NMS_DO_NOT_USE_DIRECT_SHOW | Used when user prefers not to use DirecShow for NMediaSource.
NMS_DO_NOT_USE_VLC | Used when user prefers not to use VLC for NMediaSource.
NMS_DO_NOT_USE_WINDOWS_MEDIA | Used when user prefers not to use Windows Media for NMediaSource.
NMS_DO_NOT_USE_WINDOWS_MEDIA_FOUNDATION | Used when user prefers not to use Windows Media Foundation for NMediaSource.
NMS_PREFER_DIRECT_SHOW | Used when user prefers to use DirectShow for NMediaSource.
NMS_PREFER_VLC | Used when user prefers to use VLC for NMediaSource.
NMS_PREFER_WINDOWS_MEDIA | Used when user prefers to use Windows Media for NMediaSource.
NMS_PREFER_WINDOWS_MEDIA_FOUNDATION | Used when user prefers to use Media Foundation for NMediaSource.


NMediaTypes Unit

NMediaTypes Unit
Files Functions Legend Structs, Records, Enums

Enumerates media types and provides functions to check if media type is valid.

Collapse Expand Files
Name | Description
NMediaTypes.h | Header file for NMediaTypes unit.
Collapse Expand Functions
Name | Description
NMediaTypeIsValid | Checks if the value passed to a function is a valid media type.
NMediaTypeIsValidSingle | Checks if the single value passed to a function is a valid media type.
NVideoInterlaceModeIsValid | Checks if video interlace mode is valid.
Collapse Expand Structs, Records, Enums
Name | Description
NMediaState_ | Enumerates media state values.
NMediaType_ | Enumerates media type values.
NVideoInterlaceMode_ | Enumerates video scan mode values.
NMediaState | Enumerates media state values.
NMediaType | Enumerates media type values.
NVideoInterlaceMode | Enumerates video scan mode values.


NMediaTypeIsValid Function

NMediaTypeIsValid Function
NMediaTypes.h

Checks if the value passed to a function is a valid media type.

C++
NBool N_API NMediaTypeIsValid(NMediaType value);
Collapse Expand Parameters
Parameters | Description
NMediaType value | [in] On of NMediaTypes values to check.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMediaTypes.h

Module: NMediaTypes Unit


NMediaTypeIsValidSingle Function

NMediaTypeIsValidSingle Function
NMediaTypes.h

Checks if the single value passed to a function is a valid media type.

C++
NBool N_API NMediaTypeIsValidSingle(NMediaType value);
Collapse Expand Parameters
Parameters | Description
NMediaType value | [in] On of NMediaTypes values to check.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMediaTypes.h

Module: NMediaTypes Unit


NVideoInterlaceModeIsValid Function

NVideoInterlaceModeIsValid Function
NMediaTypes.h

Checks if video interlace mode is valid.

C++
NBool N_API NVideoInterlaceModeIsValid(NVideoInterlaceMode value);
Collapse Expand Parameters
Parameters | Description
NVideoInterlaceMode value | in] On of NVideoInterlaceMode values to check.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NMediaTypes.h

Module: NMediaTypes Unit


NMediaState Enumeration

NMediaState Enumeration
NMediaTypes.h

Enumerates media state values.

C++
typedef enum NMediaState_ {
  nmsStopped = 0,
  nmsPaused = 1,
  nmsRunning = 2
} NMediaState;
Collapse Expand Members
Members | Description
nmsStopped = 0 | Indicates stopped media stream.
nmsPaused = 1 | Indicates paused media stream.
nmsRunning = 2 | Indicates running media stream.
Container

File: NMediaTypes.h

Module: NMediaTypes Unit


NMediaType Enumeration

NMediaType Enumeration
NMediaTypes.h

Enumerates media type values.

C++
typedef enum NMediaType_ {
  nmtNone = 0,
  nmtAudio = 1,
  nmtVideo = 2
} NMediaType;
Collapse Expand Members
Members | Description
nmtNone = 0 | Media type was not recognized.
nmtAudio = 1 | Indicates that media type is audio.
nmtVideo = 2 | Indicates that media type is video.
Container

File: NMediaTypes.h

Module: NMediaTypes Unit


NVideoInterlaceMode Enumeration

NVideoInterlaceMode Enumeration
NMediaTypes.h

Enumerates video scan mode values.

C++
typedef enum NVideoInterlaceMode_ {
  nvimUnknown = 0,
  nvimInterlaced = 1,
  nvimProgressive = 2
} NVideoInterlaceMode;
Collapse Expand Members
Members | Description
nvimUnknown = 0 | Indicates that video modes is unknown.
nvimInterlaced = 1 | Indicates that video is displayed in interlaced scan.
nvimProgressive = 2 | Indicates that video is displayed in progressive scan.
Container

File: NMediaTypes.h

Module: NMediaTypes Unit


NMediaTypes.h

NMediaTypes.h
Enumerations Functions Legend

Header file for NMediaTypes unit.

Collapse Expand Enumerations
Name | Description
NMediaState_ | Enumerates media state values.
NMediaType_ | Enumerates media type values.
NVideoInterlaceMode_ | Enumerates video scan mode values.
NMediaState | Enumerates media state values.
NMediaType | Enumerates media type values.
NVideoInterlaceMode | Enumerates video scan mode values.
Collapse Expand Functions
Name | Description
NMediaTypeIsValid | Checks if the value passed to a function is a valid media type.
NMediaTypeIsValidSingle | Checks if the single value passed to a function is a valid media type.
NVideoInterlaceModeIsValid | Checks if video interlace mode is valid.


NPixelFormat Unit

NPixelFormat Unit
Files Functions Legend Macros Structs, Records, Enums Types

Provides functionality for working with image pixel format.

Collapse Expand Files
Name | Description
NPixelFormat.h | Header file for NPixelFormat module. Provides functionality for working with image pixel format.
Collapse Expand Functions
Name | Description
NPixelFormatCalcRowSize | Calculates number of bytes needed to store line of specified length of pixels with specified NPixelFormat.
NPixelFormatCreate | Creates a new NPixelFormat.
NPixelFormatGetBitsPerPixel | Retrieves number of bits used to store a pixel from NPixelFormat.
NPixelFormatGetBytesPerPixel | Retrieves number of bytes used to store a pixel from NPixelFormat.
NPixelFormatGetIndexed | Retrieves an indexed version of the NPixelFormat.
NPixelFormatGetNonIndexed | Retrieves a non-indexed version of the NPixelFormat.
NPixelFormatGetNonSeparated | Retrieves a non-separated version of the NPixelFormat.
NPixelFormatGetPaletteSize | Retrieves the palette size for the pixel format.
NPixelFormatGetPixelType | Retrieves the pixel type for the specified pixel format.
NPixelFormatGetRowSize | Calculates number of bytes needed to store line of specified length of pixels with specified NPixelFormat.
NPixelFormatGetSeparated | Retrieves a separated version of the NPixelFormat.
NPixelFormatGetWithExtraChannel | Retrieves a version of the NPixelFormat with an extra channel.
NPixelFormatIsValid | Checks if specified pixel format is valid.
NPixelFormatToString | Converts a pixel format into a string.
NPixelTypeCanBeIndexed | Checks if specified pixel type can be indexed.
NPixelTypeIsValid | Checks if specified pixel type is valid.
Collapse Expand Macros
Name | Description
NPF_GRAYSCALE_16S | ... more
NPF_GRAYSCALE_16U | ... more
NPF_GRAYSCALE_1U | ... more
NPF_GRAYSCALE_2U | ... more
NPF_GRAYSCALE_32F | ... more
NPF_GRAYSCALE_32S | ... more
NPF_GRAYSCALE_32U | ... more
NPF_GRAYSCALE_4U | ... more
NPF_GRAYSCALE_64F | ... more
NPF_GRAYSCALE_64S | ... more
NPF_GRAYSCALE_64U | ... more
NPF_GRAYSCALE_8S | ... more
NPF_GRAYSCALE_8U | ... more
NPF_GRAYSCALE_A_16S | ... more
NPF_GRAYSCALE_A_16U | ... more
NPF_GRAYSCALE_A_32F | ... more
NPF_GRAYSCALE_A_32S | ... more
NPF_GRAYSCALE_A_32U | ... more
NPF_GRAYSCALE_A_64F | ... more
NPF_GRAYSCALE_A_64S | ... more
NPF_GRAYSCALE_A_64U | ... more
NPF_GRAYSCALE_A_8S | ... more
NPF_GRAYSCALE_A_8U | ... more
NPF_GRAYSCALE_PA_16S | ... more
NPF_GRAYSCALE_PA_16U | ... more
NPF_GRAYSCALE_PA_32F | ... more
NPF_GRAYSCALE_PA_32S | ... more
NPF_GRAYSCALE_PA_32U | ... more
NPF_GRAYSCALE_PA_64F | ... more
NPF_GRAYSCALE_PA_64S | ... more
NPF_GRAYSCALE_PA_64U | ... more
NPF_GRAYSCALE_PA_8S | ... more
NPF_GRAYSCALE_PA_8U | ... more
NPF_RGB_16S | ... more
NPF_RGB_16U | ... more
NPF_RGB_32F | ... more
NPF_RGB_32S | ... more
NPF_RGB_32U | ... more
NPF_RGB_64F | ... more
NPF_RGB_64S | ... more
NPF_RGB_64U | ... more
NPF_RGB_8S | ... more
NPF_RGB_8U | ... more
NPF_RGB_8U_INDEXED_1 | ... more
NPF_RGB_8U_INDEXED_2 | ... more
NPF_RGB_8U_INDEXED_4 | ... more
NPF_RGB_8U_INDEXED_8 | ... more
NPF_RGB_A_16S | ... more
NPF_RGB_A_16U | ... more
NPF_RGB_A_32F | ... more
NPF_RGB_A_32S | ... more
NPF_RGB_A_32U | ... more
NPF_RGB_A_64F | ... more
NPF_RGB_A_64S | ... more
NPF_RGB_A_64U | ... more
NPF_RGB_A_8S | ... more
NPF_RGB_A_8U | ... more
NPF_RGB_A_8U_INDEXED_1 | ... more
NPF_RGB_A_8U_INDEXED_2 | ... more
NPF_RGB_A_8U_INDEXED_4 | ... more
NPF_RGB_A_8U_INDEXED_8 | ... more
NPF_RGB_PA_16S | ... more
NPF_RGB_PA_16U | ... more
NPF_RGB_PA_32F | ... more
NPF_RGB_PA_32S | ... more
NPF_RGB_PA_32U | ... more
NPF_RGB_PA_64F | ... more
NPF_RGB_PA_64S | ... more
NPF_RGB_PA_64U | ... more
NPF_RGB_PA_8S | ... more
NPF_RGB_PA_8U | ... more
NPF_UNDEFINED | Indicates undefined pixel format.
NPixelFormatToString | Picks a Unicode (W) or ANSCII (A) version of the NPixelFormatToString function.
Collapse Expand Structs, Records, Enums
Name | Description
NPixelType_ | Specifies pixel type of each pixel in the image.
NPixelType | Specifies pixel type of each pixel in the image.
Collapse Expand Types
Name | Description
NPixelFormat | Specifies pixel format of each pixel in the image.
NPixelFormat_ | Specifies pixel format of each pixel in the image.


NPixelFormatCalcRowSize Function

NPixelFormatCalcRowSize Function
NPixelFormat.h

Calculates number of bytes needed to store line of specified length of pixels with specified NPixelFormat.

C++
NResult N_API NPixelFormatCalcRowSize(NInt bitsPerPixel, NUInt length, NSizeType alignment, NSizeType * pValue);
Collapse Expand Parameters
Parameters | Description
NInt bitsPerPixel | [in] A number of bits per pixel.
NUInt length | [in] Length of pixels.
NSizeType alignment | [in] Alignment.
NSizeType * pValue | [out] Pointer to NSizeType that receives the number of bytes needed to store line of specified length of pixels.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPixelFormatCreate Function

NPixelFormatCreate Function
NPixelFormat.h

Creates a new NPixelFormat.

C++
NResult N_API NPixelFormatCreate(NPixelType pixelType, NExtraChannel extraChannel, NInt channelCount, NChannelFormat channelFormat, NInt bitsPerChannel, NInt bitsPerIndex, NBool isSeparated, NPixelFormat_ * pValue);
Collapse Expand Parameters
Parameters | Description
NPixelType pixelType | [in] The specified type of the pixels.
NExtraChannel extraChannel | [in] The extra channel.
NInt channelCount | [in] The number of channels.
NChannelFormat channelFormat | [in] The format of the channel.
NInt bitsPerChannel | [in] The number of bits per chanel
NInt bitsPerIndex | [in] The number of bits per index.
NBool isSeparated | [in] NTrue if seprated; else NFalse.
NPixelFormat_ * pValue | [out] A pointer to the created NPixelFormat.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPixelFormatGetBitsPerPixel Function

NPixelFormatGetBitsPerPixel Function
NPixelFormat.h

Retrieves number of bits used to store a pixel from NPixelFormat.

C++
NInt N_API NPixelFormatGetBitsPerPixel(NPixelFormat_ pixelFormat);
Collapse Expand Parameters
Parameters | Description
NPixelFormat_ pixelFormat | [in] Specifies pixel format of the image.
Collapse Expand Returns

Number of bits used to store a pixel from NPixelFormat.

Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPixelFormatGetBytesPerPixel Function

NPixelFormatGetBytesPerPixel Function
NPixelFormat.h

Retrieves number of bytes used to store a pixel from NPixelFormat.

C++
NSizeType N_API NPixelFormatGetBytesPerPixel(NPixelFormat_ pixelFormat);
Collapse Expand Parameters
Parameters | Description
NPixelFormat_ pixelFormat | [in] Specifies pixel format of the image.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPixelFormatGetIndexed Function

NPixelFormatGetIndexed Function
NPixelFormat.h

Retrieves an indexed version of the NPixelFormat.

C++
NResult N_API NPixelFormatGetIndexed(NPixelFormat_ pixelFormat, NInt bitsPerIndex, NPixelFormat_ * pValue);
Collapse Expand Parameters
Parameters | Description
NPixelFormat_ pixelFormat | [in] Specifies pixel format of the image.
NInt bitsPerIndex | [in] The number of bits per index.
NPixelFormat_ * pValue | [out] A pointer to the
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPixelFormatGetNonIndexed Function

NPixelFormatGetNonIndexed Function
NPixelFormat.h

Retrieves a non-indexed version of the NPixelFormat.

C++
NResult N_API NPixelFormatGetNonIndexed(NPixelFormat_ pixelFormat, NPixelFormat_ * pValue);
Collapse Expand Parameters
Parameters | Description
NPixelFormat_ pixelFormat | [in] Specifies pixel format of the image.
NPixelFormat_ * pValue | [out] A pointer to the
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPixelFormatGetNonSeparated Function

NPixelFormatGetNonSeparated Function
NPixelFormat.h

Retrieves a non-separated version of the NPixelFormat.

C++
NResult N_API NPixelFormatGetNonSeparated(NPixelFormat_ pixelFormat, NPixelFormat_ * pValue);
Collapse Expand Parameters
Parameters | Description
NPixelFormat_ pixelFormat | [in] Specifies pixel format of the image.
NPixelFormat_ * pValue | [out] A pointer to the
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPixelFormatGetPaletteSize Function

NPixelFormatGetPaletteSize Function
NPixelFormat.h

Retrieves the palette size for the pixel format.

C++
NResult N_API NPixelFormatGetPaletteSize(NPixelFormat_ pixelFormat, NInt length, NSizeType * pValue);
Collapse Expand Parameters
Parameters | Description
NPixelFormat_ pixelFormat | [in] Specifies pixel format of the image.
NInt length | [in] Length of pixels.
NSizeType * pValue | [out] A pointer to the size of the palette.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPixelFormatGetPixelType Function

NPixelFormatGetPixelType Function
NPixelFormat.h

Retrieves the pixel type for the specified pixel format.

C++
NPixelType N_API NPixelFormatGetPixelType(NPixelFormat_ pixelFormat);
Collapse Expand Parameters
Parameters | Description
NPixelFormat_ pixelFormat | [in] Specifies pixel format of the image.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPixelFormatGetRowSize Function

NPixelFormatGetRowSize Function
NPixelFormat.h

Calculates number of bytes needed to store line of specified length of pixels with specified NPixelFormat.

C++
NResult N_API NPixelFormatGetRowSize(NPixelFormat_ pixelFormat, NUInt length, NSizeType alignment, NSizeType * pValue);
Collapse Expand Parameters
Parameters | Description
NPixelFormat_ pixelFormat | [in] Specifies pixel format of the image.
NUInt length | [in] Length of pixels.
NSizeType alignment | [in] Alignment.
NSizeType * pValue | [out] Pointer to NSizeType that receives the number of bytes needed to store line of specified length of pixels.
Collapse Expand Returns

If the function succeeds and pValue is not NULL, the return value is N_OK.

N_E_ARGUMENT_OUT_OF_RANGE error code is returned when alignment is less than 0.

Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPixelFormatGetSeparated Function

NPixelFormatGetSeparated Function
NPixelFormat.h

Retrieves a separated version of the NPixelFormat.

C++
NResult N_API NPixelFormatGetSeparated(NPixelFormat_ pixelFormat, NPixelFormat_ * pValue);
Collapse Expand Parameters
Parameters | Description
NPixelFormat_ pixelFormat | [in] Specifies pixel format of the image.
NPixelFormat_ * pValue | [out] A pointer to the
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPixelFormatGetWithExtraChannel Function

NPixelFormatGetWithExtraChannel Function
NPixelFormat.h

Retrieves a version of the NPixelFormat with an extra channel.

C++
NResult N_API NPixelFormatGetWithExtraChannel(NPixelFormat_ pixelFormat, NExtraChannel extraChannel, NPixelFormat_ * pValue);
Collapse Expand Parameters
Parameters | Description
NPixelFormat_ pixelFormat | [in] Specifies pixel format of the image.
NExtraChannel extraChannel | [in] The extra channel.
NPixelFormat_ * pValue | [out] A pointer to the
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPixelFormatIsValid Function

NPixelFormatIsValid Function
NPixelFormat.h

Checks if specified pixel format is valid.

C++
NBool N_API NPixelFormatIsValid(NPixelFormat_ value);
Collapse Expand Parameters
Parameters | Description
NPixelFormat_ value | The NPixelFormat object.
Collapse Expand Returns

True, if pixel format is valid; false otherwise.

Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPixelFormatToString Function

NPixelFormatToString Function
NPixelFormat.h

Converts a pixel format into a string.

C++
NResult N_API NPixelFormatToString(NPixelFormat pixelFormat, const NChar * szFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
NPixelFormat pixelFormat | [in] Specifies pixel format of the image.
const NChar * szFormat | [in] For internal use.
HNString * phValue | [out] A pointer to the converted NString.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPixelTypeCanBeIndexed Function

NPixelTypeCanBeIndexed Function
NPixelFormat.h

Checks if specified pixel type can be indexed.

C++
NBool N_API NPixelTypeCanBeIndexed(NPixelType pixelType);
Collapse Expand Parameters
Parameters | Description
NPixelType pixelType | The NPixelType object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPixelTypeIsValid Function

NPixelTypeIsValid Function
NPixelFormat.h

Checks if specified pixel type is valid.

C++
NBool N_API NPixelTypeIsValid(NPixelType value);
Collapse Expand Parameters
Parameters | Description
NPixelType value | The NPixelType object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPixelType Enumeration

NPixelType Enumeration
NPixelFormat.h

Specifies pixel type of each pixel in the image.

C++
typedef enum NPixelType_ {
  nptUndefined = 0,
  nptGrayscale = 1,
  nptRgb = 3
} NPixelType;
Collapse Expand Members
Members | Description
nptUndefined = 0 | Pixel type is undefined.
nptGrayscale = 1 | Each pixel value is stored in 8 bits representing 256 shades of gray.
nptRgb = 3 | Each pixel value is stored in 24 bits consisting of three 8-bit values representing red, green and blue color components.
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPixelFormat Type

NPixelFormat Type
NPixelFormat.h

Specifies pixel format of each pixel in the image.

C++
typedef NPixelFormat_ NPixelFormat;
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPixelFormat_ Type

NPixelFormat_ Type
NPixelFormat.h

Specifies pixel format of each pixel in the image.

C++
typedef NSampleFormat_ NPixelFormat_;
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_GRAYSCALE_16S Macro

NPF_GRAYSCALE_16S Macro
NPixelFormat.h

Specifies grayscale image pixel format where each pixel is represented by 16 bits per channel (channel format - signed integer).

C++
#define NPF_GRAYSCALE_16S 0x00411001
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_GRAYSCALE_16U Macro

NPF_GRAYSCALE_16U Macro
NPixelFormat.h

Specifies grayscale image pixel format where each pixel is represented by 16 bits per channel (channel format - unsigned integer).

C++
#define NPF_GRAYSCALE_16U 0x00401001
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_GRAYSCALE_1U Macro

NPF_GRAYSCALE_1U Macro
NPixelFormat.h

Specifies grayscale image pixel format where each pixel is represented by 1 bit per channel (channel format - unsigned integer).

C++
#define NPF_GRAYSCALE_1U 0x00001001
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_GRAYSCALE_2U Macro

NPF_GRAYSCALE_2U Macro
NPixelFormat.h

Specifies grayscale image pixel format where each pixel is represented by 2 bits per channel (channel format - unsigned integer).

C++
#define NPF_GRAYSCALE_2U 0x00101001
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_GRAYSCALE_32F Macro

NPF_GRAYSCALE_32F Macro
NPixelFormat.h

Specifies grayscale image pixel format where each pixel is represented by 32 bits per channel (channel format - floating point).

C++
#define NPF_GRAYSCALE_32F 0x00521001
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_GRAYSCALE_32S Macro

NPF_GRAYSCALE_32S Macro
NPixelFormat.h

Specifies grayscale image pixel format where each pixel is represented by 32 bits per channel (channel format - signed integer).

C++
#define NPF_GRAYSCALE_32S 0x00511001
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_GRAYSCALE_32U Macro

NPF_GRAYSCALE_32U Macro
NPixelFormat.h

Specifies grayscale image pixel format where each pixel is represented by 32 bits per channel (channel format - unsigned integer).

C++
#define NPF_GRAYSCALE_32U 0x00501001
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_GRAYSCALE_4U Macro

NPF_GRAYSCALE_4U Macro
NPixelFormat.h

Specifies grayscale image pixel format where each pixel is represented by 4 bits per channel (channel format - unsigned integer).

C++
#define NPF_GRAYSCALE_4U 0x00201001
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_GRAYSCALE_64F Macro

NPF_GRAYSCALE_64F Macro
NPixelFormat.h

Specifies grayscale image pixel format where each pixel is represented by 64 bits per channel (channel format - floating point).

C++
#define NPF_GRAYSCALE_64F 0x00621001
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_GRAYSCALE_64S Macro

NPF_GRAYSCALE_64S Macro
NPixelFormat.h

Specifies grayscale image pixel format where each pixel is represented by 64 bits per channel (channel format - signed integer).

C++
#define NPF_GRAYSCALE_64S 0x00611001
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_GRAYSCALE_64U Macro

NPF_GRAYSCALE_64U Macro
NPixelFormat.h

Specifies grayscale image pixel format where each pixel is represented by 64 bits per channel (channel format - unsigned integer).

C++
#define NPF_GRAYSCALE_64U 0x00601001
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_GRAYSCALE_8S Macro

NPF_GRAYSCALE_8S Macro
NPixelFormat.h

Specifies grayscale image pixel format where each pixel is represented by 8 bits per channel (channel format - signed integer).

C++
#define NPF_GRAYSCALE_8S 0x00311001
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_GRAYSCALE_8U Macro

NPF_GRAYSCALE_8U Macro
NPixelFormat.h

Specifies grayscale image pixel format where each pixel is represented by 8 bits per channel (channel format - unsigned integer).

C++
#define NPF_GRAYSCALE_8U 0x00301001
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_GRAYSCALE_A_16S Macro

NPF_GRAYSCALE_A_16S Macro
NPixelFormat.h

Specifies grayscale image pixel format where each pixel is represented by 16 bits per alpha channel (channel format - signed integer). Alpha channel specifies pixel transparency.

C++
#define NPF_GRAYSCALE_A_16S 0x00412101
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_GRAYSCALE_A_16U Macro

NPF_GRAYSCALE_A_16U Macro
NPixelFormat.h

Specifies grayscale image pixel format where each pixel is represented by 16 bits per alpha channel (channel format - unsigned integer). Alpha channel specifies pixel transparency.

C++
#define NPF_GRAYSCALE_A_16U 0x00402101
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_GRAYSCALE_A_32F Macro

NPF_GRAYSCALE_A_32F Macro
NPixelFormat.h

Specifies grayscale image pixel format where each pixel is represented by 32 bits per alpha channel (channel format - floating point). Alpha channel specifies pixel transparency.

C++
#define NPF_GRAYSCALE_A_32F 0x00522101
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_GRAYSCALE_A_32S Macro

NPF_GRAYSCALE_A_32S Macro
NPixelFormat.h

Specifies grayscale image pixel format where each pixel is represented by 32 bits per alpha channel (channel format - signed integer). Alpha channel specifies pixel transparency.

C++
#define NPF_GRAYSCALE_A_32S 0x00512101
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_GRAYSCALE_A_32U Macro

NPF_GRAYSCALE_A_32U Macro
NPixelFormat.h

Specifies grayscale image pixel format where each pixel is represented by 32 bits per alpha channel (channel format - unsigned integer). Alpha channel specifies pixel transparency.

C++
#define NPF_GRAYSCALE_A_32U 0x00502101
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_GRAYSCALE_A_64F Macro

NPF_GRAYSCALE_A_64F Macro
NPixelFormat.h

Specifies grayscale image pixel format where each pixel is represented by 64 bits per alpha channel (channel format - floating point). Alpha channel specifies pixel transparency.

C++
#define NPF_GRAYSCALE_A_64F 0x00622101
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_GRAYSCALE_A_64S Macro

NPF_GRAYSCALE_A_64S Macro
NPixelFormat.h

Specifies grayscale image pixel format where each pixel is represented by 64 bits per alpha channel (channel format - signed integer). Alpha channel specifies pixel transparency.

C++
#define NPF_GRAYSCALE_A_64S 0x00612101
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_GRAYSCALE_A_64U Macro

NPF_GRAYSCALE_A_64U Macro
NPixelFormat.h

Specifies grayscale image pixel format where each pixel is represented by 64 bits per alpha channel (channel format - unsigned integer). Alpha channel specifies pixel transparency.

C++
#define NPF_GRAYSCALE_A_64U 0x00602101
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_GRAYSCALE_A_8S Macro

NPF_GRAYSCALE_A_8S Macro
NPixelFormat.h

Specifies grayscale image pixel format where each pixel is represented by 8 bits per alpha channel (channel format - signed integer). Alpha channel specifies pixel transparency.

C++
#define NPF_GRAYSCALE_A_8S 0x00312101
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_GRAYSCALE_A_8U Macro

NPF_GRAYSCALE_A_8U Macro
NPixelFormat.h

Specifies grayscale image pixel format where each pixel is represented by 8 bits per alpha channel (channel format - unsigned integer). Alpha channel specifies pixel transparency.

C++
#define NPF_GRAYSCALE_A_8U 0x00302101
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_GRAYSCALE_PA_16S Macro

NPF_GRAYSCALE_PA_16S Macro
NPixelFormat.h

Specifies grayscale image pixel format where each pixel is represented by 16 bits per pre-multiplied alpha channel (channel format - signed integer).

C++
#define NPF_GRAYSCALE_PA_16S 0x00412201
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_GRAYSCALE_PA_16U Macro

NPF_GRAYSCALE_PA_16U Macro
NPixelFormat.h

Specifies grayscale image pixel format where each pixel is represented by 16 bits per pre-multiplied alpha channel (channel format - unsigned integer).

C++
#define NPF_GRAYSCALE_PA_16U 0x00402201
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_GRAYSCALE_PA_32F Macro

NPF_GRAYSCALE_PA_32F Macro
NPixelFormat.h

Specifies grayscale image pixel format where each pixel is represented by 32 bits per pre-multiplied alpha channel (channel format - floating point).

C++
#define NPF_GRAYSCALE_PA_32F 0x00522201
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_GRAYSCALE_PA_32S Macro

NPF_GRAYSCALE_PA_32S Macro
NPixelFormat.h

Specifies grayscale image pixel format where each pixel is represented by 32 bits per pre-multiplied alpha channel (channel format - signed integer).

C++
#define NPF_GRAYSCALE_PA_32S 0x00512201
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_GRAYSCALE_PA_32U Macro

NPF_GRAYSCALE_PA_32U Macro
NPixelFormat.h

Specifies grayscale image pixel format where each pixel is represented by 32 bits per pre-multiplied alpha channel (channel format - unsigned integer).

C++
#define NPF_GRAYSCALE_PA_32U 0x00502201
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_GRAYSCALE_PA_64F Macro

NPF_GRAYSCALE_PA_64F Macro
NPixelFormat.h

Specifies grayscale image pixel format where each pixel is represented by 64 bits per pre-multiplied alpha channel (channel format - floating point).

C++
#define NPF_GRAYSCALE_PA_64F 0x00622201
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_GRAYSCALE_PA_64S Macro

NPF_GRAYSCALE_PA_64S Macro
NPixelFormat.h

Specifies grayscale image pixel format where each pixel is represented by 64 bits per pre-multiplied alpha channel (channel format - signed integer).

C++
#define NPF_GRAYSCALE_PA_64S 0x00612201
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_GRAYSCALE_PA_64U Macro

NPF_GRAYSCALE_PA_64U Macro
NPixelFormat.h

Specifies grayscale image pixel format where each pixel is represented by 64 bits per pre-multiplied alpha channel (channel format - unsigned integer).

C++
#define NPF_GRAYSCALE_PA_64U 0x00602201
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_GRAYSCALE_PA_8S Macro

NPF_GRAYSCALE_PA_8S Macro
NPixelFormat.h

Specifies grayscale image pixel format where each pixel is represented by 8 bits per pre-multiplied alpha channel (channel format - signed integer).

C++
#define NPF_GRAYSCALE_PA_8S 0x00312201
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_GRAYSCALE_PA_8U Macro

NPF_GRAYSCALE_PA_8U Macro
NPixelFormat.h

Specifies grayscale image pixel format where each pixel is represented by 8 bits per pre-multiplied alpha channel (channel format - unsigned integer).

C++
#define NPF_GRAYSCALE_PA_8U 0x00302201
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_RGB_16S Macro

NPF_RGB_16S Macro
NPixelFormat.h

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 16 bits per channel (channel format - signed integer).

C++
#define NPF_RGB_16S 0x00413003
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_RGB_16U Macro

NPF_RGB_16U Macro
NPixelFormat.h

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 16 bits per channel (channel format - unsigned integer).

C++
#define NPF_RGB_16U 0x00403003
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_RGB_32F Macro

NPF_RGB_32F Macro
NPixelFormat.h

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 32 bits per channel (channel format - floating point).

C++
#define NPF_RGB_32F 0x00523003
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_RGB_32S Macro

NPF_RGB_32S Macro
NPixelFormat.h

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 32 bits per channel (channel format - signed integer).

C++
#define NPF_RGB_32S 0x00513003
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_RGB_32U Macro

NPF_RGB_32U Macro
NPixelFormat.h

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 16 bits per channel (channel format - unsigned integer).

C++
#define NPF_RGB_32U 0x00503003
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_RGB_64F Macro

NPF_RGB_64F Macro
NPixelFormat.h

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 64 bits per channel (channel format - floating point).

C++
#define NPF_RGB_64F 0x00623003
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_RGB_64S Macro

NPF_RGB_64S Macro
NPixelFormat.h

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 64 bits per channel (channel format - signed integer).

C++
#define NPF_RGB_64S 0x00613003
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_RGB_64U Macro

NPF_RGB_64U Macro
NPixelFormat.h

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 64 bits per channel (channel format - unsigned integer).

C++
#define NPF_RGB_64U 0x00603003
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_RGB_8S Macro

NPF_RGB_8S Macro
NPixelFormat.h

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 8 bits per channel (channel format - signed integer).

C++
#define NPF_RGB_8S 0x00313003
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_RGB_8U Macro

NPF_RGB_8U Macro
NPixelFormat.h

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 8 bits per channel (channel format - unsigned integer).

C++
#define NPF_RGB_8U 0x00303003
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_RGB_8U_INDEXED_1 Macro

NPF_RGB_8U_INDEXED_1 Macro
NPixelFormat.h

Specifies indexed Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 8 bits per channel (channel format - unsigned integer). Also 1 bit is for saving index to image palette.

C++
#define NPF_RGB_8U_INDEXED_1 0x01303003
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_RGB_8U_INDEXED_2 Macro

NPF_RGB_8U_INDEXED_2 Macro
NPixelFormat.h

Specifies indexed Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 8 bits per channel (channel format - unsigned integer). Also 2 bits is for saving index to image palette.

C++
#define NPF_RGB_8U_INDEXED_2 0x02303003
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_RGB_8U_INDEXED_4 Macro

NPF_RGB_8U_INDEXED_4 Macro
NPixelFormat.h

Specifies indexed Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 8 bits per channel (channel format - unsigned integer). Also 4 bits is for saving index to image palette.

C++
#define NPF_RGB_8U_INDEXED_4 0x03303003
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_RGB_8U_INDEXED_8 Macro

NPF_RGB_8U_INDEXED_8 Macro
NPixelFormat.h

Specifies indexed Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 8 bits per channel (channel format - unsigned integer). Also 8 bits is for saving index to image palette.

C++
#define NPF_RGB_8U_INDEXED_8 0x04303003
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_RGB_A_16S Macro

NPF_RGB_A_16S Macro
NPixelFormat.h

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 16 bits per alpha channel (channel format - signed integer). Alpha channel specifies pixel transparency.

C++
#define NPF_RGB_A_16S 0x00414103
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_RGB_A_16U Macro

NPF_RGB_A_16U Macro
NPixelFormat.h

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 16 bits per alpha channel (channel format - unsigned integer). Alpha channel specifies pixel transparency.

C++
#define NPF_RGB_A_16U 0x00404103
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_RGB_A_32F Macro

NPF_RGB_A_32F Macro
NPixelFormat.h

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 32 bits per alpha channel (channel format - floating point). Alpha channel specifies pixel transparency.

C++
#define NPF_RGB_A_32F 0x00524103
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_RGB_A_32S Macro

NPF_RGB_A_32S Macro
NPixelFormat.h

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 32 bits per alpha channel (channel format - signed integer). Alpha channel specifies pixel transparency.

C++
#define NPF_RGB_A_32S 0x00514103
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_RGB_A_32U Macro

NPF_RGB_A_32U Macro
NPixelFormat.h

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 32 bits per alpha channel (channel format - unsigned integer). Alpha channel specifies pixel transparency.

C++
#define NPF_RGB_A_32U 0x00504103
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_RGB_A_64F Macro

NPF_RGB_A_64F Macro
NPixelFormat.h

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 64 bits per alpha channel (channel format - floating point). Alpha channel specifies pixel transparency.

C++
#define NPF_RGB_A_64F 0x00624103
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_RGB_A_64S Macro

NPF_RGB_A_64S Macro
NPixelFormat.h

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 64 bits per alpha channel (channel format - signed integer). Alpha channel specifies pixel transparency.

C++
#define NPF_RGB_A_64S 0x00614103
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_RGB_A_64U Macro

NPF_RGB_A_64U Macro
NPixelFormat.h

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 64 bits per alpha channel (channel format - unsigned integer). Alpha channel specifies pixel transparency.

C++
#define NPF_RGB_A_64U 0x00604103
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_RGB_A_8S Macro

NPF_RGB_A_8S Macro
NPixelFormat.h

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 8 bits per alpha channel (channel format - signed integer). Alpha channel specifies pixel transparency.

C++
#define NPF_RGB_A_8S 0x00314103
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_RGB_A_8U Macro

NPF_RGB_A_8U Macro
NPixelFormat.h

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 8 bits per alpha channel (channel format - unsigned integer). Alpha channel specifies pixel transparency.

C++
#define NPF_RGB_A_8U 0x00304103
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_RGB_A_8U_INDEXED_1 Macro

NPF_RGB_A_8U_INDEXED_1 Macro
NPixelFormat.h

Specifies indexed Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 8 bits per alpha channel (channel format - unsigned integer). Also 1 bit is for saving index to image palette.

C++
#define NPF_RGB_A_8U_INDEXED_1 0x01304103
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_RGB_A_8U_INDEXED_2 Macro

NPF_RGB_A_8U_INDEXED_2 Macro
NPixelFormat.h

Specifies indexed Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 8 bits per alpha channel (channel format - unsigned integer). Also 2 bits is for saving index to image palette.

C++
#define NPF_RGB_A_8U_INDEXED_2 0x02304103
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_RGB_A_8U_INDEXED_4 Macro

NPF_RGB_A_8U_INDEXED_4 Macro
NPixelFormat.h

Specifies indexed Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 8 bits per alpha channel (channel format - unsigned integer). Also 4 bits is for saving index to image palette.

C++
#define NPF_RGB_A_8U_INDEXED_4 0x03304103
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_RGB_A_8U_INDEXED_8 Macro

NPF_RGB_A_8U_INDEXED_8 Macro
NPixelFormat.h

Specifies indexed Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 8 bits per alpha channel (channel format - unsigned integer). Also 8 bits is for saving index to image palette.

C++
#define NPF_RGB_A_8U_INDEXED_8 0x04304103
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_RGB_PA_16S Macro

NPF_RGB_PA_16S Macro
NPixelFormat.h

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 16 bits per pre-multiplied alpha channel (channel format - signed integer).

C++
#define NPF_RGB_PA_16S 0x00414203
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_RGB_PA_16U Macro

NPF_RGB_PA_16U Macro
NPixelFormat.h

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 16 bits per pre-multiplied alpha channel (channel format - unsigned integer).

C++
#define NPF_RGB_PA_16U 0x00404203
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_RGB_PA_32F Macro

NPF_RGB_PA_32F Macro
NPixelFormat.h

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 32 bits per pre-multiplied alpha channel (channel format - floating point).

C++
#define NPF_RGB_PA_32F 0x00524203
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_RGB_PA_32S Macro

NPF_RGB_PA_32S Macro
NPixelFormat.h

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 32 bits per pre-multiplied alpha channel (channel format - signed integer).

C++
#define NPF_RGB_PA_32S 0x00514203
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_RGB_PA_32U Macro

NPF_RGB_PA_32U Macro
NPixelFormat.h

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 32 bits per pre-multiplied alpha channel (channel format - unsigned integer).

C++
#define NPF_RGB_PA_32U 0x00504203
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_RGB_PA_64F Macro

NPF_RGB_PA_64F Macro
NPixelFormat.h

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 64 bits per pre-multiplied alpha channel (channel format - floating point).

C++
#define NPF_RGB_PA_64F 0x00624203
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_RGB_PA_64S Macro

NPF_RGB_PA_64S Macro
NPixelFormat.h

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 64 bits per pre-multiplied alpha channel (channel format - signed integer).

C++
#define NPF_RGB_PA_64S 0x00614203
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_RGB_PA_64U Macro

NPF_RGB_PA_64U Macro
NPixelFormat.h

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 64 bits per pre-multiplied alpha channel (channel format - unsigned integer).

C++
#define NPF_RGB_PA_64U 0x00604203
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_RGB_PA_8S Macro

NPF_RGB_PA_8S Macro
NPixelFormat.h

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 8 bits per pre-multiplied alpha channel (channel format - signed integer).

C++
#define NPF_RGB_PA_8S 0x00314203
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_RGB_PA_8U Macro

NPF_RGB_PA_8U Macro
NPixelFormat.h

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 8 bits per pre-multiplied alpha channel (channel format - unsigned integer).

C++
#define NPF_RGB_PA_8U 0x00304203
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPF_UNDEFINED Macro

NPF_UNDEFINED Macro
NPixelFormat.h

Indicates undefined pixel format.

C++
#define NPF_UNDEFINED 0
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPixelFormatToString Macro

NPixelFormatToString Macro
NPixelFormat.h

Picks a Unicode (W) or ANSCII (A) version of the NPixelFormatToString function.

C++
#define NPixelFormatToString N_FUNC_AW(NPixelFormatToString)
Container

File: NPixelFormat.h

Module: NPixelFormat Unit


NPixelFormat.h

NPixelFormat.h
Enumerations Functions Legend Macros Types

Header file for NPixelFormat module. Provides functionality for working with image pixel format.

Collapse Expand Enumerations
Name | Description
NPixelType_ | Specifies pixel type of each pixel in the image.
NPixelType | Specifies pixel type of each pixel in the image.
Collapse Expand Functions
Name | Description
NPixelFormatCalcRowSize | Calculates number of bytes needed to store line of specified length of pixels with specified NPixelFormat.
NPixelFormatCreate | Creates a new NPixelFormat.
NPixelFormatGetBitsPerPixel | Retrieves number of bits used to store a pixel from NPixelFormat.
NPixelFormatGetBytesPerPixel | Retrieves number of bytes used to store a pixel from NPixelFormat.
NPixelFormatGetIndexed | Retrieves an indexed version of the NPixelFormat.
NPixelFormatGetNonIndexed | Retrieves a non-indexed version of the NPixelFormat.
NPixelFormatGetNonSeparated | Retrieves a non-separated version of the NPixelFormat.
NPixelFormatGetPaletteSize | Retrieves the palette size for the pixel format.
NPixelFormatGetPixelType | Retrieves the pixel type for the specified pixel format.
NPixelFormatGetRowSize | Calculates number of bytes needed to store line of specified length of pixels with specified NPixelFormat.
NPixelFormatGetSeparated | Retrieves a separated version of the NPixelFormat.
NPixelFormatGetWithExtraChannel | Retrieves a version of the NPixelFormat with an extra channel.
NPixelFormatIsValid | Checks if specified pixel format is valid.
NPixelFormatToString | Converts a pixel format into a string.
NPixelTypeCanBeIndexed | Checks if specified pixel type can be indexed.
NPixelTypeIsValid | Checks if specified pixel type is valid.
Collapse Expand Macros
Name | Description
NPF_GRAYSCALE_16S | ... more
NPF_GRAYSCALE_16U | ... more
NPF_GRAYSCALE_1U | ... more
NPF_GRAYSCALE_2U | ... more
NPF_GRAYSCALE_32F | ... more
NPF_GRAYSCALE_32S | ... more
NPF_GRAYSCALE_32U | ... more
NPF_GRAYSCALE_4U | ... more
NPF_GRAYSCALE_64F | ... more
NPF_GRAYSCALE_64S | ... more
NPF_GRAYSCALE_64U | ... more
NPF_GRAYSCALE_8S | ... more
NPF_GRAYSCALE_8U | ... more
NPF_GRAYSCALE_A_16S | ... more
NPF_GRAYSCALE_A_16U | ... more
NPF_GRAYSCALE_A_32F | ... more
NPF_GRAYSCALE_A_32S | ... more
NPF_GRAYSCALE_A_32U | ... more
NPF_GRAYSCALE_A_64F | ... more
NPF_GRAYSCALE_A_64S | ... more
NPF_GRAYSCALE_A_64U | ... more
NPF_GRAYSCALE_A_8S | ... more
NPF_GRAYSCALE_A_8U | ... more
NPF_GRAYSCALE_PA_16S | ... more
NPF_GRAYSCALE_PA_16U | ... more
NPF_GRAYSCALE_PA_32F | ... more
NPF_GRAYSCALE_PA_32S | ... more
NPF_GRAYSCALE_PA_32U | ... more
NPF_GRAYSCALE_PA_64F | ... more
NPF_GRAYSCALE_PA_64S | ... more
NPF_GRAYSCALE_PA_64U | ... more
NPF_GRAYSCALE_PA_8S | ... more
NPF_GRAYSCALE_PA_8U | ... more
NPF_RGB_16S | ... more
NPF_RGB_16U | ... more
NPF_RGB_32F | ... more
NPF_RGB_32S | ... more
NPF_RGB_32U | ... more
NPF_RGB_64F | ... more
NPF_RGB_64S | ... more
NPF_RGB_64U | ... more
NPF_RGB_8S | ... more
NPF_RGB_8U | ... more
NPF_RGB_8U_INDEXED_1 | ... more
NPF_RGB_8U_INDEXED_2 | ... more
NPF_RGB_8U_INDEXED_4 | ... more
NPF_RGB_8U_INDEXED_8 | ... more
NPF_RGB_A_16S | ... more
NPF_RGB_A_16U | ... more
NPF_RGB_A_32F | ... more
NPF_RGB_A_32S | ... more
NPF_RGB_A_32U | ... more
NPF_RGB_A_64F | ... more
NPF_RGB_A_64S | ... more
NPF_RGB_A_64U | ... more
NPF_RGB_A_8S | ... more
NPF_RGB_A_8U | ... more
NPF_RGB_A_8U_INDEXED_1 | ... more
NPF_RGB_A_8U_INDEXED_2 | ... more
NPF_RGB_A_8U_INDEXED_4 | ... more
NPF_RGB_A_8U_INDEXED_8 | ... more
NPF_RGB_PA_16S | ... more
NPF_RGB_PA_16U | ... more
NPF_RGB_PA_32F | ... more
NPF_RGB_PA_32S | ... more
NPF_RGB_PA_32U | ... more
NPF_RGB_PA_64F | ... more
NPF_RGB_PA_64S | ... more
NPF_RGB_PA_64U | ... more
NPF_RGB_PA_8S | ... more
NPF_RGB_PA_8U | ... more
NPF_UNDEFINED | Indicates undefined pixel format.
NPixelFormatToString | Picks a Unicode (W) or ANSCII (A) version of the NPixelFormatToString function.
Collapse Expand Types
Name | Description
NPixelFormat | Specifies pixel format of each pixel in the image.
NPixelFormat_ | Specifies pixel format of each pixel in the image.


NRgb Unit

NRgb Unit
Files Functions Legend Macros Structs, Records, Enums Types

Provides functionality for working with Rgb image data.

Collapse Expand Files
Name | Description
NRgb.h | Header file for NRgb Unit.
Collapse Expand Functions
Name | Description
NRgbToString | Converts RGB value into NString.
Collapse Expand Macros
Name | Description
NRgbToString | Picks a Unicode (W) or ANSCII (A) version of the NRgbToString function.
Collapse Expand Structs, Records, Enums
Name | Description
NRgb_ | Represents an RGB color.
Collapse Expand Types
Name | Description
NRgb | Defines the RGB color.


NRgbToString Function

NRgbToString Function
NRgb.h

Converts RGB value into NString.

C++
NResult N_API NRgbToString(const NRgb * pValue, const NChar * szFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
const NRgb * pValue | [in] A pointer to the RGB value to be converted.
const NChar * szFormat | [in] For internal use.
HNString * phValue | [out] A pointer to the converted NString.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NRgb.h

Module: NRgb Unit


NRgb_ Structure

NRgb_ Structure
NRgb.h

Represents an RGB color.

C++
struct NRgb_ {
  NByte Red;
  NByte Green;
  NByte Blue;
};
Collapse Expand Members
Members | Description
NByte Red; | Red component value of this NRgb_.
NByte Green; | Green component value of this NRgb_.
NByte Blue; | Blue component value of this NRgb_.
Container

File: NRgb.h

Module: NRgb Unit


NRgb Type

NRgb Type
NRgb.h

Defines the RGB color.

C++
typedef struct NRgb_ NRgb;
Container

File: NRgb.h

Module: NRgb Unit


NRgbToString Macro

NRgbToString Macro
NRgb.h

Picks a Unicode (W) or ANSCII (A) version of the NRgbToString function.

C++
#define NRgbToString N_FUNC_AW(NRgbToString)
Container

File: NRgb.h

Module: NRgb Unit


NRgb.h

NRgb.h
Functions Legend Macros Structures Types

Header file for NRgb Unit.

Collapse Expand Functions
Name | Description
NRgbToString | Converts RGB value into NString.
Collapse Expand Macros
Name | Description
NRgbToString | Picks a Unicode (W) or ANSCII (A) version of the NRgbToString function.
Collapse Expand Structures
Name | Description
NRgb_ | Represents an RGB color.
Collapse Expand Types
Name | Description
NRgb | Defines the RGB color.


NVideoFormat Unit

NVideoFormat Unit
Files Functions Legend Macros
Collapse Expand Files
Name | Description
NVideoFormat.h | Header file for NVideoFormat module. Provides functionality for managing video formats.
Collapse Expand Functions
Name | Description
NVideoFormatCreate | Creates default video format. Video format properties can be modified and retrieved using following functions:... more
NVideoFormatGetFrameRate | Gets frame rate of video format.
NVideoFormatGetHeight | Gets frame height in pixels for specified video format.
NVideoFormatGetInterlaceMode | Gets interlace mode for specified video format.
NVideoFormatGetPixelAspectRatio | Gets frame aspect ratio for specified video format.
NVideoFormatGetStride | Gets stride for specified video format.
NVideoFormatGetWidth | Gets frame width of specified video format.
NVideoFormatMediaSubtypeToString | Writes video format string into memory buffer.
NVideoFormatSetFrameRate | Sets video format frame rate.
NVideoFormatSetHeight | Sets video format frame height (in pixels).
NVideoFormatSetInterlaceMode | Sets video format interlace mode.
NVideoFormatSetPixelAspectRatio | Sets video format aspect ratio.
NVideoFormatSetStride | Sets stride for specified video format.
NVideoFormatSetWidth | Sets video format frame width (in pixels).
Collapse Expand Macros
Name | Description
NVideoFormatMediaSubtypeToString | Picks a Unicode (W) or ANSCII (A) version of the NVideoFormatMediaSubtype function.
N_VIDEO_FORMAT_AI44 | Video format AI44
N_VIDEO_FORMAT_ARGB32 | Video format ARGB32.
N_VIDEO_FORMAT_AVC1 | Video format AVC1.
N_VIDEO_FORMAT_AYUV | Video format AYUV.
N_VIDEO_FORMAT_DV25 | Video format DVCPRO 25 (525-60 or 625-50).
N_VIDEO_FORMAT_DV50 | Video format DVCPRO 50 (525-60 or 625-50).
N_VIDEO_FORMAT_DVC | Video format DVC/DV Video.
N_VIDEO_FORMAT_DVH1 | Video format DVCPRO 100 (1080/60i, 1080/50i, or 720/60P).
N_VIDEO_FORMAT_DVHD | Video format HD-DVCR (1125-60 or 1250-50).
N_VIDEO_FORMAT_DVSD | Video format SDL-DVCR (525-60 or 625-50).
N_VIDEO_FORMAT_DVSL | Video format SD-DVCR (525-60 or 625-50).
N_VIDEO_FORMAT_DX50 | Video format DX50.
N_VIDEO_FORMAT_H264 | Video format H.264.
N_VIDEO_FORMAT_I420 | Video format I420.
N_VIDEO_FORMAT_IYUV | Video format IYUV.
N_VIDEO_FORMAT_L16 | Video format L16.
N_VIDEO_FORMAT_L8 | Video format L8.
N_VIDEO_FORMAT_M4S2 | Video format MPEG-4 part 2.
N_VIDEO_FORMAT_MJPG | Video format Motion JPEG.
N_VIDEO_FORMAT_MP43 | Video format Microsoft MPEG 4 codec version 3.
N_VIDEO_FORMAT_MP4S | Video format ISO MPEG 4 codec version 1.
N_VIDEO_FORMAT_MP4V | Video format MPEG-4 part 2 video.
N_VIDEO_FORMAT_MPG1 | Video format MPEG-1.
N_VIDEO_FORMAT_MSS1 | Video format Windows Media Screen codec version 1.
N_VIDEO_FORMAT_MSS2 | Video format Windows Media Video 9 Screen codec.
N_VIDEO_FORMAT_NV11 | Video format NV11.
N_VIDEO_FORMAT_NV12 | Video format NV12.
N_VIDEO_FORMAT_NV21 | Video format NV21.
N_VIDEO_FORMAT_P010 | Video format P010.
N_VIDEO_FORMAT_P016 | Video format P016.
N_VIDEO_FORMAT_P210 | Video format P210.
N_VIDEO_FORMAT_P216 | Video format P216.
N_VIDEO_FORMAT_RGB24 | Video format RGB, 24 bpp.
N_VIDEO_FORMAT_RGB32 | Video format RGB, 32 bpp.
N_VIDEO_FORMAT_RGB555 | Video format RGB 555, 16 bpp.
N_VIDEO_FORMAT_RGB565 | Video format RGB 565, 16 bpp.
N_VIDEO_FORMAT_RGB8 | Video format RGB, 8 bits per pixel.
N_VIDEO_FORMAT_UNKNOWN | Unknown video format.
N_VIDEO_FORMAT_UYVY | Video format UYVY.
N_VIDEO_FORMAT_V210 | Video format V210.
N_VIDEO_FORMAT_V216 | Video format V216.
N_VIDEO_FORMAT_V410 | Video format V40.
N_VIDEO_FORMAT_WMV1 | Video format Windows Media Video codec version 7.
N_VIDEO_FORMAT_WMV2 | Video format Windows Media Video 8 codec.
N_VIDEO_FORMAT_WMV3 | Video format Windows Media Video 9 codec.
N_VIDEO_FORMAT_WVC1 | Video format SMPTE 421M ("VC-1").
N_VIDEO_FORMAT_Y210 | Video format Y210.
N_VIDEO_FORMAT_Y216 | Video format Y216.
N_VIDEO_FORMAT_Y410 | Video format Y40.
N_VIDEO_FORMAT_Y416 | Video format Y416.
N_VIDEO_FORMAT_Y41P | Video format Y41P.
N_VIDEO_FORMAT_Y41T | Video format Y41T.
N_VIDEO_FORMAT_Y42T | Video format Y42T.
N_VIDEO_FORMAT_YUY2 | Video format YUY2.
N_VIDEO_FORMAT_YV12 | Video format YV12.
N_VIDEO_FORMAT_YVU9 | Video format YVU9.
N_VIDEO_FORMAT_YVYU | Video format YVYU.


NVideoFormatCreate Function

NVideoFormatCreate Function
NVideoFormat.h

Creates default video format. Video format properties can be modified and retrieved using following functions:

  • NVideoFormatGetFrameRate
  • NVideoFormatGetHeight
  • NVideoFormatGetInterlaceMode
  • NVideoFormatGetPixelAspectRatio
  • NVideoFormatGetWidth
  • NVideoFormatSetFrameRate
  • NVideoFormatSetHeight
  • NVideoFormatSetInterlaceMode
  • NVideoFormatSetPixelAspectRatio
  • NVideoFormatSetWidth
C++
NResult N_API NVideoFormatCreate(HNVideoFormat * phVideoFormat);
Collapse Expand Parameters
Parameters | Description
HNVideoFormat * phVideoFormat | Pointer to video format handle. Handle will be initialized if function succeeds.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NVideoFormat.h

Module: NVideoFormat Unit


NVideoFormatGetFrameRate Function

NVideoFormatGetFrameRate Function
NVideoFormat.h

Gets frame rate of video format.

C++
NResult N_API NVideoFormatGetFrameRate(HNVideoFormat hVideoFormat, struct NURational_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNVideoFormat hVideoFormat | [in] Handle to video format.
struct NURational_ * pValue | [out] Frame rate value (frames per second).
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NVideoFormat.h

Module: NVideoFormat Unit


NVideoFormatGetHeight Function

NVideoFormatGetHeight Function
NVideoFormat.h

Gets frame height in pixels for specified video format.

C++
NResult N_API NVideoFormatGetHeight(HNVideoFormat hVideoFormat, NUInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNVideoFormat hVideoFormat | [in] Handle to video format.
NUInt * pValue | [out] Frame height (in pixels).
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NVideoFormat.h

Module: NVideoFormat Unit


NVideoFormatGetInterlaceMode Function

NVideoFormatGetInterlaceMode Function
NVideoFormat.h

Gets interlace mode for specified video format.

C++
NResult N_API NVideoFormatGetInterlaceMode(HNVideoFormat hVideoFormat, NVideoInterlaceMode * pValue);
Collapse Expand Parameters
Parameters | Description
HNVideoFormat hVideoFormat | [in] Handle to video format.
NVideoInterlaceMode * pValue | [out] Interlace mode value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NVideoFormat.h

Module: NVideoFormat Unit


NVideoFormatGetPixelAspectRatio Function

NVideoFormatGetPixelAspectRatio Function
NVideoFormat.h

Gets frame aspect ratio for specified video format.

C++
NResult N_API NVideoFormatGetPixelAspectRatio(HNVideoFormat hVideoFormat, struct NURational_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNVideoFormat hVideoFormat | [in] Handle to video format.
struct NURational_ * pValue | [out] Aspect ratio.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NVideoFormat.h

Module: NVideoFormat Unit


NVideoFormatGetStride Function

NVideoFormatGetStride Function
NVideoFormat.h

Gets stride for specified video format.

C++
NResult N_API NVideoFormatGetStride(HNVideoFormat hVideoFormat, NSSizeType * pValue);
Collapse Expand Parameters
Parameters | Description
HNVideoFormat hVideoFormat | [in] Handle to video format.
NSSizeType * pValue | [out] Video stride value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NVideoFormat.h

Module: NVideoFormat Unit


NVideoFormatGetWidth Function

NVideoFormatGetWidth Function
NVideoFormat.h

Gets frame width of specified video format.

C++
NResult N_API NVideoFormatGetWidth(HNVideoFormat hVideoFormat, NUInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNVideoFormat hVideoFormat | [in] Handle to video format.
NUInt * pValue | [out] Frame width (in pixels).
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NVideoFormat.h

Module: NVideoFormat Unit


NVideoFormatMediaSubtypeToString Function

NVideoFormatMediaSubtypeToString Function
NVideoFormat.h

Writes video format string into memory buffer.

C++
NResult N_API NVideoFormatMediaSubtypeToString(NUInt value, const NChar * szFormat, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
NUInt value | [in] Video format value.
const NChar * szFormat | [in] String format. Value can be NULL.
HNString * phValue | [out] Pointer to handle which contains string representation of NVideoFormat media subtype.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NVideoFormat.h

Module: NVideoFormat Unit


NVideoFormatSetFrameRate Function

NVideoFormatSetFrameRate Function
NVideoFormat.h

Sets video format frame rate.

C++
NResult N_API NVideoFormatSetFrameRate(HNVideoFormat hVideoFormat, const struct NURational_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNVideoFormat hVideoFormat | [in] Handle to video format.
const struct NURational_ * pValue | [in] Frame rate.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NVideoFormat.h

Module: NVideoFormat Unit


NVideoFormatSetHeight Function

NVideoFormatSetHeight Function
NVideoFormat.h

Sets video format frame height (in pixels).

C++
NResult N_API NVideoFormatSetHeight(HNVideoFormat hVideoFormat, NUInt value);
Collapse Expand Parameters
Parameters | Description
HNVideoFormat hVideoFormat | [in] Handle to video format.
NUInt value | [in] Frame height (in pixels).
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NVideoFormat.h

Module: NVideoFormat Unit


NVideoFormatSetInterlaceMode Function

NVideoFormatSetInterlaceMode Function
NVideoFormat.h

Sets video format interlace mode.

C++
NResult N_API NVideoFormatSetInterlaceMode(HNVideoFormat hVideoFormat, NVideoInterlaceMode value);
Collapse Expand Parameters
Parameters | Description
HNVideoFormat hVideoFormat | [in] Handle to video format.
NVideoInterlaceMode value | [in] Interlace mode.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NVideoFormat.h

Module: NVideoFormat Unit


NVideoFormatSetPixelAspectRatio Function

NVideoFormatSetPixelAspectRatio Function
NVideoFormat.h

Sets video format aspect ratio.

C++
NResult N_API NVideoFormatSetPixelAspectRatio(HNVideoFormat hVideoFormat, const struct NURational_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNVideoFormat hVideoFormat | [in] Handle to video format.
const struct NURational_ * pValue | [in] Aspect ratio.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NVideoFormat.h

Module: NVideoFormat Unit


NVideoFormatSetStride Function

NVideoFormatSetStride Function
NVideoFormat.h

Sets stride for specified video format.

C++
NResult N_API NVideoFormatSetStride(HNVideoFormat hVideoFormat, NSSizeType value);
Collapse Expand Parameters
Parameters | Description
HNVideoFormat hVideoFormat | [in] Handle to video format.
NSSizeType value | [in] Video stride value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NVideoFormat.h

Module: NVideoFormat Unit


NVideoFormatSetWidth Function

NVideoFormatSetWidth Function
NVideoFormat.h

Sets video format frame width (in pixels).

C++
NResult N_API NVideoFormatSetWidth(HNVideoFormat hVideoFormat, NUInt value);
Collapse Expand Parameters
Parameters | Description
HNVideoFormat hVideoFormat | [in] Handle to video format.
NUInt value | [in] Frame width (in pixels).
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NVideoFormat.h

Module: NVideoFormat Unit


NVideoFormatMediaSubtypeToString Macro

NVideoFormatMediaSubtypeToString Macro
NVideoFormat.h

Picks a Unicode (W) or ANSCII (A) version of the NVideoFormatMediaSubtype function.

C++
#define NVideoFormatMediaSubtypeToString N_FUNC_AW(NVideoFormatMediaSubtypeToString)
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_AI44 Macro

N_VIDEO_FORMAT_AI44 Macro
NVideoFormat.h

Video format AI44

C++
#define N_VIDEO_FORMAT_AI44 0x34344941
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_ARGB32 Macro

N_VIDEO_FORMAT_ARGB32 Macro
NVideoFormat.h

Video format ARGB32.

C++
#define N_VIDEO_FORMAT_ARGB32 21
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_AVC1 Macro

N_VIDEO_FORMAT_AVC1 Macro
NVideoFormat.h

Video format AVC1.

C++
#define N_VIDEO_FORMAT_AVC1 0x31435641
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_AYUV Macro

N_VIDEO_FORMAT_AYUV Macro
NVideoFormat.h

Video format AYUV.

C++
#define N_VIDEO_FORMAT_AYUV 0x56555941
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_DV25 Macro

N_VIDEO_FORMAT_DV25 Macro
NVideoFormat.h

Video format DVCPRO 25 (525-60 or 625-50).

C++
#define N_VIDEO_FORMAT_DV25 0x35327664
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_DV50 Macro

N_VIDEO_FORMAT_DV50 Macro
NVideoFormat.h

Video format DVCPRO 50 (525-60 or 625-50).

C++
#define N_VIDEO_FORMAT_DV50 0x30357664
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_DVC Macro

N_VIDEO_FORMAT_DVC Macro
NVideoFormat.h

Video format DVC/DV Video.

C++
#define N_VIDEO_FORMAT_DVC 0x20637664
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_DVH1 Macro

N_VIDEO_FORMAT_DVH1 Macro
NVideoFormat.h

Video format DVCPRO 100 (1080/60i, 1080/50i, or 720/60P).

C++
#define N_VIDEO_FORMAT_DVH1 0x31687664
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_DVHD Macro

N_VIDEO_FORMAT_DVHD Macro
NVideoFormat.h

Video format HD-DVCR (1125-60 or 1250-50).

C++
#define N_VIDEO_FORMAT_DVHD 0x64687664
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_DVSD Macro

N_VIDEO_FORMAT_DVSD Macro
NVideoFormat.h

Video format SDL-DVCR (525-60 or 625-50).

C++
#define N_VIDEO_FORMAT_DVSD 0x64737664
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_DVSL Macro

N_VIDEO_FORMAT_DVSL Macro
NVideoFormat.h

Video format SD-DVCR (525-60 or 625-50).

C++
#define N_VIDEO_FORMAT_DVSL 0x6C737664
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_DX50 Macro

N_VIDEO_FORMAT_DX50 Macro
NVideoFormat.h

Video format DX50.

C++
#define N_VIDEO_FORMAT_DX50 0x30355844
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_H264 Macro

N_VIDEO_FORMAT_H264 Macro
NVideoFormat.h

Video format H.264.

C++
#define N_VIDEO_FORMAT_H264 0x34363248
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_I420 Macro

N_VIDEO_FORMAT_I420 Macro
NVideoFormat.h

Video format I420.

C++
#define N_VIDEO_FORMAT_I420 0x30323449
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_IYUV Macro

N_VIDEO_FORMAT_IYUV Macro
NVideoFormat.h

Video format IYUV.

C++
#define N_VIDEO_FORMAT_IYUV 0x56555949
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_L16 Macro

N_VIDEO_FORMAT_L16 Macro
NVideoFormat.h

Video format L16.

C++
#define N_VIDEO_FORMAT_L16 81
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_L8 Macro

N_VIDEO_FORMAT_L8 Macro
NVideoFormat.h

Video format L8.

C++
#define N_VIDEO_FORMAT_L8 50
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_M4S2 Macro

N_VIDEO_FORMAT_M4S2 Macro
NVideoFormat.h

Video format MPEG-4 part 2.

C++
#define N_VIDEO_FORMAT_M4S2 0x3253344D
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_MJPG Macro

N_VIDEO_FORMAT_MJPG Macro
NVideoFormat.h

Video format Motion JPEG.

C++
#define N_VIDEO_FORMAT_MJPG 0x47504A4D
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_MP43 Macro

N_VIDEO_FORMAT_MP43 Macro
NVideoFormat.h

Video format Microsoft MPEG 4 codec version 3.

C++
#define N_VIDEO_FORMAT_MP43 0x3334504D
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_MP4S Macro

N_VIDEO_FORMAT_MP4S Macro
NVideoFormat.h

Video format ISO MPEG 4 codec version 1.

C++
#define N_VIDEO_FORMAT_MP4S 0x5334504D
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_MP4V Macro

N_VIDEO_FORMAT_MP4V Macro
NVideoFormat.h

Video format MPEG-4 part 2 video.

C++
#define N_VIDEO_FORMAT_MP4V 0x5634504D
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_MPG1 Macro

N_VIDEO_FORMAT_MPG1 Macro
NVideoFormat.h

Video format MPEG-1.

C++
#define N_VIDEO_FORMAT_MPG1 0x3147504D
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_MSS1 Macro

N_VIDEO_FORMAT_MSS1 Macro
NVideoFormat.h

Video format Windows Media Screen codec version 1.

C++
#define N_VIDEO_FORMAT_MSS1 0x3153534D
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_MSS2 Macro

N_VIDEO_FORMAT_MSS2 Macro
NVideoFormat.h

Video format Windows Media Video 9 Screen codec.

C++
#define N_VIDEO_FORMAT_MSS2 0x3253534D
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_NV11 Macro

N_VIDEO_FORMAT_NV11 Macro
NVideoFormat.h

Video format NV11.

C++
#define N_VIDEO_FORMAT_NV11 0x3131564E
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_NV12 Macro

N_VIDEO_FORMAT_NV12 Macro
NVideoFormat.h

Video format NV12.

C++
#define N_VIDEO_FORMAT_NV12 0x3231564E
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_NV21 Macro

N_VIDEO_FORMAT_NV21 Macro
NVideoFormat.h

Video format NV21.

C++
#define N_VIDEO_FORMAT_NV21 0x3132564E
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_P010 Macro

N_VIDEO_FORMAT_P010 Macro
NVideoFormat.h

Video format P010.

C++
#define N_VIDEO_FORMAT_P010 0x30313050
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_P016 Macro

N_VIDEO_FORMAT_P016 Macro
NVideoFormat.h

Video format P016.

C++
#define N_VIDEO_FORMAT_P016 0x36313050
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_P210 Macro

N_VIDEO_FORMAT_P210 Macro
NVideoFormat.h

Video format P210.

C++
#define N_VIDEO_FORMAT_P210 0x30313250
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_P216 Macro

N_VIDEO_FORMAT_P216 Macro
NVideoFormat.h

Video format P216.

C++
#define N_VIDEO_FORMAT_P216 0x36313250
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_RGB24 Macro

N_VIDEO_FORMAT_RGB24 Macro
NVideoFormat.h

Video format RGB, 24 bpp.

C++
#define N_VIDEO_FORMAT_RGB24 20
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_RGB32 Macro

N_VIDEO_FORMAT_RGB32 Macro
NVideoFormat.h

Video format RGB, 32 bpp.

C++
#define N_VIDEO_FORMAT_RGB32 22
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_RGB555 Macro

N_VIDEO_FORMAT_RGB555 Macro
NVideoFormat.h

Video format RGB 555, 16 bpp.

C++
#define N_VIDEO_FORMAT_RGB555 24
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_RGB565 Macro

N_VIDEO_FORMAT_RGB565 Macro
NVideoFormat.h

Video format RGB 565, 16 bpp.

C++
#define N_VIDEO_FORMAT_RGB565 23
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_RGB8 Macro

N_VIDEO_FORMAT_RGB8 Macro
NVideoFormat.h

Video format RGB, 8 bits per pixel.

C++
#define N_VIDEO_FORMAT_RGB8 41
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_UNKNOWN Macro

N_VIDEO_FORMAT_UNKNOWN Macro
NVideoFormat.h

Unknown video format.

C++
#define N_VIDEO_FORMAT_UNKNOWN 0
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_UYVY Macro

N_VIDEO_FORMAT_UYVY Macro
NVideoFormat.h

Video format UYVY.

C++
#define N_VIDEO_FORMAT_UYVY 0x59565955
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_V210 Macro

N_VIDEO_FORMAT_V210 Macro
NVideoFormat.h

Video format V210.

C++
#define N_VIDEO_FORMAT_V210 0x30313276
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_V216 Macro

N_VIDEO_FORMAT_V216 Macro
NVideoFormat.h

Video format V216.

C++
#define N_VIDEO_FORMAT_V216 0x36313276
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_V410 Macro

N_VIDEO_FORMAT_V410 Macro
NVideoFormat.h

Video format V40.

C++
#define N_VIDEO_FORMAT_V410 0x30313476
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_WMV1 Macro

N_VIDEO_FORMAT_WMV1 Macro
NVideoFormat.h

Video format Windows Media Video codec version 7.

C++
#define N_VIDEO_FORMAT_WMV1 0x31564D57
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_WMV2 Macro

N_VIDEO_FORMAT_WMV2 Macro
NVideoFormat.h

Video format Windows Media Video 8 codec.

C++
#define N_VIDEO_FORMAT_WMV2 0x32564D57
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_WMV3 Macro

N_VIDEO_FORMAT_WMV3 Macro
NVideoFormat.h

Video format Windows Media Video 9 codec.

C++
#define N_VIDEO_FORMAT_WMV3 0x33564D57
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_WVC1 Macro

N_VIDEO_FORMAT_WVC1 Macro
NVideoFormat.h

Video format SMPTE 421M ("VC-1").

C++
#define N_VIDEO_FORMAT_WVC1 0x31435657
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_Y210 Macro

N_VIDEO_FORMAT_Y210 Macro
NVideoFormat.h

Video format Y210.

C++
#define N_VIDEO_FORMAT_Y210 0x30313259
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_Y216 Macro

N_VIDEO_FORMAT_Y216 Macro
NVideoFormat.h

Video format Y216.

C++
#define N_VIDEO_FORMAT_Y216 0x36313259
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_Y410 Macro

N_VIDEO_FORMAT_Y410 Macro
NVideoFormat.h

Video format Y40.

C++
#define N_VIDEO_FORMAT_Y410 0x30313459
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_Y416 Macro

N_VIDEO_FORMAT_Y416 Macro
NVideoFormat.h

Video format Y416.

C++
#define N_VIDEO_FORMAT_Y416 0x36313459
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_Y41P Macro

N_VIDEO_FORMAT_Y41P Macro
NVideoFormat.h

Video format Y41P.

C++
#define N_VIDEO_FORMAT_Y41P 0x50313459
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_Y41T Macro

N_VIDEO_FORMAT_Y41T Macro
NVideoFormat.h

Video format Y41T.

C++
#define N_VIDEO_FORMAT_Y41T 0x54313459
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_Y42T Macro

N_VIDEO_FORMAT_Y42T Macro
NVideoFormat.h

Video format Y42T.

C++
#define N_VIDEO_FORMAT_Y42T 0x54323459
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_YUY2 Macro

N_VIDEO_FORMAT_YUY2 Macro
NVideoFormat.h

Video format YUY2.

C++
#define N_VIDEO_FORMAT_YUY2 0x32595559
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_YV12 Macro

N_VIDEO_FORMAT_YV12 Macro
NVideoFormat.h

Video format YV12.

C++
#define N_VIDEO_FORMAT_YV12 0x32315659
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_YVU9 Macro

N_VIDEO_FORMAT_YVU9 Macro
NVideoFormat.h

Video format YVU9.

C++
#define N_VIDEO_FORMAT_YVU9 0x39555659
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


N_VIDEO_FORMAT_YVYU Macro

N_VIDEO_FORMAT_YVYU Macro
NVideoFormat.h

Video format YVYU.

C++
#define N_VIDEO_FORMAT_YVYU 0x55595659
Container

File: NVideoFormat.h

Module: NVideoFormat Unit


NVideoFormat.h

NVideoFormat.h
Functions Legend Macros

Header file for NVideoFormat module. Provides functionality for managing video formats.

Collapse Expand Functions
Name | Description
NVideoFormatCreate | Creates default video format. Video format properties can be modified and retrieved using following functions:... more
NVideoFormatGetFrameRate | Gets frame rate of video format.
NVideoFormatGetHeight | Gets frame height in pixels for specified video format.
NVideoFormatGetInterlaceMode | Gets interlace mode for specified video format.
NVideoFormatGetPixelAspectRatio | Gets frame aspect ratio for specified video format.
NVideoFormatGetStride | Gets stride for specified video format.
NVideoFormatGetWidth | Gets frame width of specified video format.
NVideoFormatMediaSubtypeToString | Writes video format string into memory buffer.
NVideoFormatSetFrameRate | Sets video format frame rate.
NVideoFormatSetHeight | Sets video format frame height (in pixels).
NVideoFormatSetInterlaceMode | Sets video format interlace mode.
NVideoFormatSetPixelAspectRatio | Sets video format aspect ratio.
NVideoFormatSetStride | Sets stride for specified video format.
NVideoFormatSetWidth | Sets video format frame width (in pixels).
Collapse Expand Macros
Name | Description
NVideoFormatMediaSubtypeToString | Picks a Unicode (W) or ANSCII (A) version of the NVideoFormatMediaSubtype function.
N_VIDEO_FORMAT_AI44 | Video format AI44
N_VIDEO_FORMAT_ARGB32 | Video format ARGB32.
N_VIDEO_FORMAT_AVC1 | Video format AVC1.
N_VIDEO_FORMAT_AYUV | Video format AYUV.
N_VIDEO_FORMAT_DV25 | Video format DVCPRO 25 (525-60 or 625-50).
N_VIDEO_FORMAT_DV50 | Video format DVCPRO 50 (525-60 or 625-50).
N_VIDEO_FORMAT_DVC | Video format DVC/DV Video.
N_VIDEO_FORMAT_DVH1 | Video format DVCPRO 100 (1080/60i, 1080/50i, or 720/60P).
N_VIDEO_FORMAT_DVHD | Video format HD-DVCR (1125-60 or 1250-50).
N_VIDEO_FORMAT_DVSD | Video format SDL-DVCR (525-60 or 625-50).
N_VIDEO_FORMAT_DVSL | Video format SD-DVCR (525-60 or 625-50).
N_VIDEO_FORMAT_DX50 | Video format DX50.
N_VIDEO_FORMAT_H264 | Video format H.264.
N_VIDEO_FORMAT_I420 | Video format I420.
N_VIDEO_FORMAT_IYUV | Video format IYUV.
N_VIDEO_FORMAT_L16 | Video format L16.
N_VIDEO_FORMAT_L8 | Video format L8.
N_VIDEO_FORMAT_M4S2 | Video format MPEG-4 part 2.
N_VIDEO_FORMAT_MJPG | Video format Motion JPEG.
N_VIDEO_FORMAT_MP43 | Video format Microsoft MPEG 4 codec version 3.
N_VIDEO_FORMAT_MP4S | Video format ISO MPEG 4 codec version 1.
N_VIDEO_FORMAT_MP4V | Video format MPEG-4 part 2 video.
N_VIDEO_FORMAT_MPG1 | Video format MPEG-1.
N_VIDEO_FORMAT_MSS1 | Video format Windows Media Screen codec version 1.
N_VIDEO_FORMAT_MSS2 | Video format Windows Media Video 9 Screen codec.
N_VIDEO_FORMAT_NV11 | Video format NV11.
N_VIDEO_FORMAT_NV12 | Video format NV12.
N_VIDEO_FORMAT_NV21 | Video format NV21.
N_VIDEO_FORMAT_P010 | Video format P010.
N_VIDEO_FORMAT_P016 | Video format P016.
N_VIDEO_FORMAT_P210 | Video format P210.
N_VIDEO_FORMAT_P216 | Video format P216.
N_VIDEO_FORMAT_RGB24 | Video format RGB, 24 bpp.
N_VIDEO_FORMAT_RGB32 | Video format RGB, 32 bpp.
N_VIDEO_FORMAT_RGB555 | Video format RGB 555, 16 bpp.
N_VIDEO_FORMAT_RGB565 | Video format RGB 565, 16 bpp.
N_VIDEO_FORMAT_RGB8 | Video format RGB, 8 bits per pixel.
N_VIDEO_FORMAT_UNKNOWN | Unknown video format.
N_VIDEO_FORMAT_UYVY | Video format UYVY.
N_VIDEO_FORMAT_V210 | Video format V210.
N_VIDEO_FORMAT_V216 | Video format V216.
N_VIDEO_FORMAT_V410 | Video format V40.
N_VIDEO_FORMAT_WMV1 | Video format Windows Media Video codec version 7.
N_VIDEO_FORMAT_WMV2 | Video format Windows Media Video 8 codec.
N_VIDEO_FORMAT_WMV3 | Video format Windows Media Video 9 codec.
N_VIDEO_FORMAT_WVC1 | Video format SMPTE 421M ("VC-1").
N_VIDEO_FORMAT_Y210 | Video format Y210.
N_VIDEO_FORMAT_Y216 | Video format Y216.
N_VIDEO_FORMAT_Y410 | Video format Y40.
N_VIDEO_FORMAT_Y416 | Video format Y416.
N_VIDEO_FORMAT_Y41P | Video format Y41P.
N_VIDEO_FORMAT_Y41T | Video format Y41T.
N_VIDEO_FORMAT_Y42T | Video format Y42T.
N_VIDEO_FORMAT_YUY2 | Video format YUY2.
N_VIDEO_FORMAT_YV12 | Video format YV12.
N_VIDEO_FORMAT_YVU9 | Video format YVU9.
N_VIDEO_FORMAT_YVYU | Video format YVYU.


Png Unit

Png Unit
Files Functions Legend Macros

Provides functionality for loading and saving images in PNG format.

Collapse Expand Files
Name | Description
Png.h | Header file for Png module. Provides functionality for loading and saving images in PNG format.
Collapse Expand Functions
Name | Description
PngInfoGetCompressionLevel | Retrieves compression level of a PNG image.
PngInfoSetCompressionLevel | Sets compression level of a PNG image.
Collapse Expand Macros
Name | Description
PNG_DEFAULT_COMPRESSION_LEVEL | Specifies default PNG compression level.


PngInfoGetCompressionLevel Function

PngInfoGetCompressionLevel Function
Png.h

Retrieves compression level of a PNG image.

C++
NResult N_API PngInfoGetCompressionLevel(HPngInfo hInfo, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HPngInfo hInfo | [in] A handle to PngInfo.
NInt * pValue | [out] A pointer to NInt value defining the compression level.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: Png.h

Module: Png Unit


PngInfoSetCompressionLevel Function

PngInfoSetCompressionLevel Function
Png.h

Sets compression level of a PNG image.

C++
NResult N_API PngInfoSetCompressionLevel(HPngInfo hInfo, NInt value);
Collapse Expand Parameters
Parameters | Description
HPngInfo hInfo | [in] A handle to PngInfo.
NInt value | [in] New compression level value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: Png.h

Module: Png Unit


PNG_DEFAULT_COMPRESSION_LEVEL Macro

PNG_DEFAULT_COMPRESSION_LEVEL Macro
Png.h

Specifies default PNG compression level.

C++
#define PNG_DEFAULT_COMPRESSION_LEVEL 6
Container

File: Png.h

Module: Png Unit


Png.h

Png.h
Functions Legend Macros

Header file for Png module. Provides functionality for loading and saving images in PNG format.

Collapse Expand Functions
Name | Description
PngInfoGetCompressionLevel | Retrieves compression level of a PNG image.
PngInfoSetCompressionLevel | Sets compression level of a PNG image.
Collapse Expand Macros
Name | Description
PNG_DEFAULT_COMPRESSION_LEVEL | Specifies default PNG compression level.


Tiff Unit

Tiff Unit
Files

Provides functionality for loading images in TIFF format.

Collapse Expand Files
Name | Description
Tiff.h | Header file for Tiff module. Provides functionality for loading images in TIFF format.


Tiff.h

Tiff.h

Header file for Tiff module. Provides functionality for loading images in TIFF format.


Wsq Unit

Wsq Unit
Files Functions Legend Macros

Provides functionality for loading and saving images in WSQ format.

Collapse Expand Remarks

WSQ images can be saved compressed. Compression is controlled using bit rate which can be calculated using this formula: 11.25/N where N is compression ratio. Typical compression ratios:

Compression ratio | Bit rate
1:15 | 0.75
1:5 | 2.25
1:N | 11.25/N

WSQ image bit rate is set using WsqInfoSetBitRate function.

Collapse Expand Files
Name | Description
Wsq.h | Header file for Wsq module. Provides functionality for loading and saving images in WSQ format.
Collapse Expand Functions
Name | Description
WsqInfoGetBitRate | Gets WSQ image bit rate (compression level)
WsqInfoGetImplementationNumber | Gets WSQ image implementation number.
WsqInfoGetNistCom | Retrieves the NIST comment of the specified WSQ info file.
WsqInfoHasNistCom | Checks whether the WSQ info file has a NIST comment.
WsqInfoSetBitRate | Sets WSQ image bit rate (compression level)
WsqInfoSetHasNistCom | Sets whether the WSQ info file has a NIST comment.
Collapse Expand Macros
Name | Description
WSQ_DEFAULT_BIT_RATE | Specifies default bit rate (compression level).
WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_DEBIAN_AMD64_LEGACY | Represents Neurotechnology Debian AMD64 (Legacy version) implementation.
WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_DEBIAN_I386_LEGACY | Represents Neurotechnology Debian I386 (Legacy version) implementation.
WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_MACOSX_INTEL64 | Represents Neurotechnology MacOS X Intel 64 implementation.
WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_MACOSX_INTEL_LEGACY | Represents Neurotechnology MacOS X Intel (Legacy version) implementation.
WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_MACOSX_POWERPC_LEGACY | Represents Neurotechnology MacOS X PowerPC (Legacy version) implementation.
WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_WIN32_X86 | Represents Neurotechnology Windows 32 x86 implementation.
WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_WIN64_X64 | Represents Neurotechnology Windows 64 x64 implementation.
WSQ_RECOVER_CORRUPT_FILE | Image loading flag which attempts to load an image even if it cannot be fully read.


WsqInfoGetBitRate Function

WsqInfoGetBitRate Function
Wsq.h

Gets WSQ image bit rate (compression level)

C++
NResult N_API WsqInfoGetBitRate(HWsqInfo hInfo, NFloat * pValue);
Collapse Expand Parameters
Parameters | Description
HWsqInfo hInfo | [in] Handle to WsqInfo.
NFloat * pValue | [out] WSQ image bit rate.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise error code is returned. NSucceeded or NFailed macros can be used to detect whether the function succeeded or failed.

Container

File: Wsq.h

Module: Wsq Unit


WsqInfoGetImplementationNumber Function

WsqInfoGetImplementationNumber Function
Wsq.h

Gets WSQ image implementation number.

C++
NResult N_API WsqInfoGetImplementationNumber(HWsqInfo hInfo, NUShort * pValue);
Collapse Expand Parameters
Parameters | Description
HWsqInfo hInfo | [in] Handle to WsqInfo.
NUShort * pValue | [out] A pointer to WSQ image implementation number.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: Wsq.h

Module: Wsq Unit


WsqInfoGetNistCom Function

WsqInfoGetNistCom Function
Wsq.h

Retrieves the NIST comment of the specified WSQ info file.

C++
NResult N_API WsqInfoGetNistCom(HWsqInfo hInfo, HNistCom * phValue);
Collapse Expand Parameters
Parameters | Description
HWsqInfo hInfo | [in] Handle to the WsqInfo object.
HNistCom * phValue | [out] Pointer to a handle to the NIST comment.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: Wsq.h

Module: Wsq Unit


WsqInfoHasNistCom Function

WsqInfoHasNistCom Function
Wsq.h

Checks whether the WSQ info file has a NIST comment.

C++
NResult N_API WsqInfoHasNistCom(HWsqInfo hInfo, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HWsqInfo hInfo | [in] Handle to the WsqInfo object.
NBool * pValue | [out] Pointer to NTrue value if the WSQ info file contains NIST comment. Otherwise, pointer to NFalse value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: Wsq.h

Module: Wsq Unit


WsqInfoSetBitRate Function

WsqInfoSetBitRate Function
Wsq.h

Sets WSQ image bit rate (compression level)

C++
NResult N_API WsqInfoSetBitRate(HWsqInfo hInfo, NFloat value);
Collapse Expand Parameters
Parameters | Description
HWsqInfo hInfo | [in] Handle to WsqInfo.
NFloat value | [out] WSQ image bit rate to set.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Otherwise error code is returned. NSucceeded or NFailed macros can be used to detect whether the function succeeded or failed.

Container

File: Wsq.h

Module: Wsq Unit


WsqInfoSetHasNistCom Function

WsqInfoSetHasNistCom Function
Wsq.h

Sets whether the WSQ info file has a NIST comment.

C++
NResult N_API WsqInfoSetHasNistCom(HWsqInfo hInfo, NBool value);
Collapse Expand Parameters
Parameters | Description
HWsqInfo hInfo | [in] Handle to the WsqInfo object.
NBool value | [in] NTrue if the WSQ info file contains NIST comment, else NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: Wsq.h

Module: Wsq Unit


WSQ_DEFAULT_BIT_RATE Macro

WSQ_DEFAULT_BIT_RATE Macro
Wsq.h

Specifies default bit rate (compression level).

C++
#define WSQ_DEFAULT_BIT_RATE 0.75f
Container

File: Wsq.h

Module: Wsq Unit


WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_DEBIAN_AMD64_LEGACY Macro

WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_DEBIAN_AMD64_LEGACY Macro
Wsq.h

Represents Neurotechnology Debian AMD64 (Legacy version) implementation.

C++
#define WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_DEBIAN_AMD64_LEGACY 10153
Container

File: Wsq.h

Module: Wsq Unit


WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_DEBIAN_I386_LEGACY Macro

WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_DEBIAN_I386_LEGACY Macro
Wsq.h

Represents Neurotechnology Debian I386 (Legacy version) implementation.

C++
#define WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_DEBIAN_I386_LEGACY 10152
Container

File: Wsq.h

Module: Wsq Unit


WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_MACOSX_INTEL64 Macro

WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_MACOSX_INTEL64 Macro
Wsq.h

Represents Neurotechnology MacOS X Intel 64 implementation.

C++
#define WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_MACOSX_INTEL64 10163
Container

File: Wsq.h

Module: Wsq Unit


WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_MACOSX_INTEL_LEGACY Macro

WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_MACOSX_INTEL_LEGACY Macro
Wsq.h

Represents Neurotechnology MacOS X Intel (Legacy version) implementation.

C++
#define WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_MACOSX_INTEL_LEGACY 10154
Container

File: Wsq.h

Module: Wsq Unit


WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_MACOSX_POWERPC_LEGACY Macro

WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_MACOSX_POWERPC_LEGACY Macro
Wsq.h

Represents Neurotechnology MacOS X PowerPC (Legacy version) implementation.

C++
#define WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_MACOSX_POWERPC_LEGACY 10156
Container

File: Wsq.h

Module: Wsq Unit


WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_WIN32_X86 Macro

WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_WIN32_X86 Macro
Wsq.h

Represents Neurotechnology Windows 32 x86 implementation.

C++
#define WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_WIN32_X86 10158
Container

File: Wsq.h

Module: Wsq Unit


WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_WIN64_X64 Macro

WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_WIN64_X64 Macro
Wsq.h

Represents Neurotechnology Windows 64 x64 implementation.

C++
#define WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_WIN64_X64 10157
Container

File: Wsq.h

Module: Wsq Unit


WSQ_RECOVER_CORRUPT_FILE Macro

WSQ_RECOVER_CORRUPT_FILE Macro
Wsq.h

Image loading flag which attempts to load an image even if it cannot be fully read.

C++
#define WSQ_RECOVER_CORRUPT_FILE 0x000100000
Container

File: Wsq.h

Module: Wsq Unit


Wsq.h

Wsq.h
Functions Legend Macros

Header file for Wsq module. Provides functionality for loading and saving images in WSQ format.

Collapse Expand Functions
Name | Description
WsqInfoGetBitRate | Gets WSQ image bit rate (compression level)
WsqInfoGetImplementationNumber | Gets WSQ image implementation number.
WsqInfoGetNistCom | Retrieves the NIST comment of the specified WSQ info file.
WsqInfoHasNistCom | Checks whether the WSQ info file has a NIST comment.
WsqInfoSetBitRate | Sets WSQ image bit rate (compression level)
WsqInfoSetHasNistCom | Sets whether the WSQ info file has a NIST comment.
Collapse Expand Macros
Name | Description
WSQ_DEFAULT_BIT_RATE | Specifies default bit rate (compression level).
WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_DEBIAN_AMD64_LEGACY | Represents Neurotechnology Debian AMD64 (Legacy version) implementation.
WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_DEBIAN_I386_LEGACY | Represents Neurotechnology Debian I386 (Legacy version) implementation.
WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_MACOSX_INTEL64 | Represents Neurotechnology MacOS X Intel 64 implementation.
WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_MACOSX_INTEL_LEGACY | Represents Neurotechnology MacOS X Intel (Legacy version) implementation.
WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_MACOSX_POWERPC_LEGACY | Represents Neurotechnology MacOS X PowerPC (Legacy version) implementation.
WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_WIN32_X86 | Represents Neurotechnology Windows 32 x86 implementation.
WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_WIN64_X64 | Represents Neurotechnology Windows 64 x64 implementation.
WSQ_RECOVER_CORRUPT_FILE | Image loading flag which attempts to load an image even if it cannot be fully read.


NSurveillance Library

NSurveillance Library

Provides functionality for biometric face identification, detection of moving pedestrians or vehicles or other objects and performs automatic license plate recognition using live video streams from digital surveillance cameras.

Collapse Expand Remarks
DLL
  • NSurveillance.dll
Import library
  • NSurveillance.dll.lib
Shared object (Linux)
  • libNSurveillance.so
Collapse Expand Modules
Name | Description
NClothingDetails Unit | Represents subject's clothing and gender details.
NLicensePlate Unit | Provides car's license plate recognition functionality.
NNameConfidencePair Unit | Structure containing name and/or confidence values.
NSurveillance Unit | Provides the main SentiVeillance functions.
NSurveillanceSource Unit | Provides functions for managing SentiVeillance sources - cameras and video files.
NTrackingDetails Unit | Represents objects tracking details.
NVehicleDetails Unit | Represents vehicle details.
NGpuJpegEncoder Unit | Provides functionality for converting Nimage to Jpeg using GPU.


NClothingDetails Unit

NClothingDetails Unit
Functions Legend

Represents subject's clothing and gender details.

Collapse Expand Functions
Name | Description
NClothingDetailsGetGender | Gets subject's gender.
NClothingDetailsGetGenderConfidence | Gets subject's gender confidence value.
NClothingDetailsGetKnownValues | Gets known values from NClothingDetails.
NClothingDetailsGetValue | Gets a value specified by index from NClothingDetails.
NClothingDetailsGetValueCount | Gets count of values in NClothingDetails.
NClothingDetailsGetValues | Gets all values from NClothingDetails.
N_DECLARE_OBJECT_TYPE | Declares object type with specified name.


NClothingDetailsGetGender Function

NClothingDetailsGetGender Function

Gets subject's gender.

C++
NResult N_API NClothingDetailsGetGender(HNClothingDetails hDetails, NGender * pValue);
Collapse Expand Parameters
Parameters | Description
HNClothingDetails hDetails | [in] Handle to NClothingDetails.
NGender * pValue | [out] Pointer to NGender containing subject's gender value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NClothingDetails.h

Module: NClothingDetails Unit


NClothingDetailsGetGenderConfidence Function

NClothingDetailsGetGenderConfidence Function

Gets subject's gender confidence value.

C++
NResult N_API NClothingDetailsGetGenderConfidence(HNClothingDetails hDetails, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNClothingDetails hDetails | [in] Handle to NClothingDetails.
NByte * pValue | [out] Subject's gender confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NClothingDetails.h

Module: NClothingDetails Unit


NClothingDetailsGetKnownValues Function

NClothingDetailsGetKnownValues Function

Gets known values from NClothingDetails.

C++
NResult N_API NClothingDetailsGetKnownValues(HNString * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNString * * parhValues | [out] Pointer to an array of NString values containing known values from NClothingDetails.
NInt * pValueCount | [out] Array items count.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NClothingDetails.h

Module: NClothingDetails Unit


NClothingDetailsGetValue Function

NClothingDetailsGetValue Function

Gets a value specified by index from NClothingDetails.

C++
NResult N_API NClothingDetailsGetValue(HNClothingDetails hDetails, NInt index, struct NNameConfidencePair_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNClothingDetails hDetails | [in] Handle to NClothingDetails.
NInt index | [in] Index of an item.
struct NNameConfidencePair_ * pValue | [out] Pointer to a returned value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NClothingDetails.h

Module: NClothingDetails Unit


NClothingDetailsGetValueCount Function

NClothingDetailsGetValueCount Function

Gets count of values in NClothingDetails.

C++
NResult N_API NClothingDetailsGetValueCount(HNClothingDetails hDetails, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNClothingDetails hDetails | [in] Handle to NClothingDetails.
NInt * pValue | [out] Values count inside NClothingDetails.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NClothingDetails.h

Module: NClothingDetails Unit


NClothingDetailsGetValues Function

NClothingDetailsGetValues Function

Gets all values from NClothingDetails.

C++
NResult N_API NClothingDetailsGetValues(HNClothingDetails hDetails, struct NNameConfidencePair_ * * parValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNClothingDetails hDetails | [in] Handle to NClothingDetails.
struct NNameConfidencePair_ * * parValues | [out] Pointer to array of NNameConfidencePair values.
NInt * pValueCount | [out] Pointer to array items count.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NClothingDetails.h

Module: NClothingDetails Unit


N_DECLARE_OBJECT_TYPE Function

N_DECLARE_OBJECT_TYPE Function

Declares object type with specified name.

C++
N_DECLARE_OBJECT_TYPE(NClothingDetails, NObject);
Container

File: NClothingDetails.h

Module: NClothingDetails Unit


NLicensePlate Unit

NLicensePlate Unit
Functions Legend

Provides car's license plate recognition functionality.

Collapse Expand Functions
Name | Description
NLicensePlateDetailsGetBestLicensePlate | Gets the best license plate specified by an index.
NLicensePlateDetailsGetBestLicensePlateCount | Gets the best license plates count in NLicensePlateDetails.
NLicensePlateDetailsGetBestLicensePlates | Gets all best license plates.
NLicensePlateDetailsGetCurrentLicensePlate | Gets the current license plate specified by an index.
NLicensePlateDetailsGetCurrentLicensePlateCount | Gets the current license plates count in NLicensePlateDetails.
NLicensePlateDetailsGetCurrentLicensePlates | Gets all current license plates.
NLicensePlateGetBoundingBox | Gets license plate's bounding box rectangle.
NLicensePlateGetDetectionConfidence | Gets license plate detection confidence value.
NLicensePlateGetFrameIndex | Gets index of a frame where license plate was found.
NLicensePlateGetOcrConfidence | Gets license plate's characters recognition confidence value.
NLicensePlateGetOrigin | Gets licence plate country code value (3 characters).
NLicensePlateGetRectangle | Gets license plate's bounding box rectangle.
NLicensePlateGetRotation | Gets rotation of the Rectangle.
NLicensePlateGetType | Gets license plate's type value (general, taxi, military, etc.).
NLicensePlateGetValue | Gets vehicle's number from a license plate.


NLicensePlateDetailsGetBestLicensePlate Function

NLicensePlateDetailsGetBestLicensePlate Function

Gets the best license plate specified by an index.

C++
NResult N_API NLicensePlateDetailsGetBestLicensePlate(HNLicensePlateDetails hDetails, NInt index, HNLicensePlate * phValue);
Collapse Expand Parameters
Parameters | Description
HNLicensePlateDetails hDetails | [in] Handle to NLicensePlateDetails object.
NInt index | [in] Index of a license plate.
HNLicensePlate * phValue | [out] Pointer to NLicensePlate object containing the best license plate.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicensePlateDetails.h

Module: NLicensePlate Unit


NLicensePlateDetailsGetBestLicensePlateCount Function

NLicensePlateDetailsGetBestLicensePlateCount Function

Gets the best license plates count in NLicensePlateDetails.

C++
NResult N_API NLicensePlateDetailsGetBestLicensePlateCount(HNLicensePlateDetails hDetails, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNLicensePlateDetails hDetails | [in] Handle to NLicensePlateDetails object.
NInt * pValue | [out] The best license plates count.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicensePlateDetails.h

Module: NLicensePlate Unit


NLicensePlateDetailsGetBestLicensePlates Function

NLicensePlateDetailsGetBestLicensePlates Function

Gets all best license plates.

C++
NResult N_API NLicensePlateDetailsGetBestLicensePlates(HNLicensePlateDetails hDetails, HNLicensePlate * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNLicensePlateDetails hDetails | [in] Handle to NLicensePlateDetails object.
HNLicensePlate * * parhValues | [out] Pointer to an array of NLicensePlate objects.
NInt * pValueCount | [out] Array items count.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicensePlateDetails.h

Module: NLicensePlate Unit


NLicensePlateDetailsGetCurrentLicensePlate Function

NLicensePlateDetailsGetCurrentLicensePlate Function

Gets the current license plate specified by an index.

C++
NResult N_API NLicensePlateDetailsGetCurrentLicensePlate(HNLicensePlateDetails hDetails, NInt index, HNLicensePlate * phValue);
Collapse Expand Parameters
Parameters | Description
HNLicensePlateDetails hDetails | [in] Handle to NLicensePlateDetails object.
NInt index | [in] Index of the current license plate.
HNLicensePlate * phValue | [out] Pointer to NLicensePlate object containing the current license plate.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicensePlateDetails.h

Module: NLicensePlate Unit


NLicensePlateDetailsGetCurrentLicensePlateCount Function

NLicensePlateDetailsGetCurrentLicensePlateCount Function

Gets the current license plates count in NLicensePlateDetails.

C++
NResult N_API NLicensePlateDetailsGetCurrentLicensePlateCount(HNLicensePlateDetails hDetails, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNLicensePlateDetails hDetails | [in] Handle to NLicensePlateDetails object.
NInt * pValue | [out] The current license plates count.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicensePlateDetails.h

Module: NLicensePlate Unit


NLicensePlateDetailsGetCurrentLicensePlates Function

NLicensePlateDetailsGetCurrentLicensePlates Function

Gets all current license plates.

C++
NResult N_API NLicensePlateDetailsGetCurrentLicensePlates(HNLicensePlateDetails hDetails, HNLicensePlate * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNLicensePlateDetails hDetails | [in] Handle to NLicensePlateDetails object.
HNLicensePlate * * parhValues | [out] Pointer to an array of NLicensePlate objects.
NInt * pValueCount | [out] Array items count.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicensePlateDetails.h

Module: NLicensePlate Unit


NLicensePlateGetBoundingBox Function

NLicensePlateGetBoundingBox Function

Gets license plate's bounding box rectangle.

C++
NResult N_API NLicensePlateGetBoundingBox(HNLicensePlate hLicensePlate, struct NRect_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNLicensePlate hLicensePlate | [in] Handle to NLicensePlateDetails object.
struct NRect_ * pValue | [out] Pointer to rectangle object containing coordinates, width and height of license plate's bounding box.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicensePlate.h

Module: NLicensePlate Unit


NLicensePlateGetDetectionConfidence Function

NLicensePlateGetDetectionConfidence Function

Gets license plate detection confidence value.

C++
NResult N_API NLicensePlateGetDetectionConfidence(HNLicensePlate hLicensePlate, NFloat * pValue);
Collapse Expand Parameters
Parameters | Description
HNLicensePlate hLicensePlate | [in] Handle to NLicensePlateDetails object.
NFloat * pValue | [out] License plate detection confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicensePlate.h

Module: NLicensePlate Unit


NLicensePlateGetFrameIndex Function

NLicensePlateGetFrameIndex Function

Gets index of a frame where license plate was found.

C++
NResult N_API NLicensePlateGetFrameIndex(HNLicensePlate hLicensePlate, NULong * pValue);
Collapse Expand Parameters
Parameters | Description
HNLicensePlate hLicensePlate | [in] Handle to NLicensePlateDetails object.
NULong * pValue | [out] Index of a frame where license plate was found.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicensePlate.h

Module: NLicensePlate Unit


NLicensePlateGetOcrConfidence Function

NLicensePlateGetOcrConfidence Function

Gets license plate's characters recognition confidence value.

C++
NResult N_API NLicensePlateGetOcrConfidence(HNLicensePlate hLicensePlate, NFloat * pValue);
Collapse Expand Parameters
Parameters | Description
HNLicensePlate hLicensePlate | [in] Handle to NLicensePlateDetails object.
NFloat * pValue | [out] Pointer to NFloat containing license plate's characters recognition confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicensePlate.h

Module: NLicensePlate Unit


NLicensePlateGetOrigin Function

NLicensePlateGetOrigin Function

Gets licence plate country code value (3 characters).

C++
NResult N_API NLicensePlateGetOrigin(HNLicensePlate hLicensePlate, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNLicensePlate hLicensePlate | [in] Handle to NLicensePlateDetails object.
HNString * phValue | [out] Pointer to NString containing licence plate country code value (3 characters).
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicensePlate.h

Module: NLicensePlate Unit


NLicensePlateGetRectangle Function

NLicensePlateGetRectangle Function
See Also

Gets license plate's bounding box rectangle.

C++
NResult N_API NLicensePlateGetRectangle(HNLicensePlate hLicensePlate, struct NRect_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNLicensePlate hLicensePlate | [in] Handle to NLicensePlateDetails object.
struct NRect_ * pValue | [out] Pointer to NRect structure containing coordinates, width and height of license plate's bounding box.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand See Also

NLicensePlateGetBoundingBox Function

Container

File: NLicensePlate.h

Module: NLicensePlate Unit


NLicensePlateGetRotation Function

NLicensePlateGetRotation Function

Gets rotation of the Rectangle.

C++
NResult N_API NLicensePlateGetRotation(HNLicensePlate hLicensePlate, NFloat * pValue);
Collapse Expand Parameters
Parameters | Description
HNLicensePlate hLicensePlate | [in] Handle to NLicensePlateDetails object.
NFloat * pValue | [out] Pointer to NFloat which receives rectangle rotation value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicensePlate.h

Module: NLicensePlate Unit


NLicensePlateGetType Function

NLicensePlateGetType Function

Gets license plate's type value (general, taxi, military, etc.).

C++
NResult N_API NLicensePlateGetType(HNLicensePlate hLicensePlate, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNLicensePlate hLicensePlate | [in] Handle to NLicensePlateDetails object.
HNString * phValue | [out] license plate's type value (general, taxi, military, etc.).
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicensePlate.h

Module: NLicensePlate Unit


NLicensePlateGetValue Function

NLicensePlateGetValue Function

Gets vehicle's number from a license plate.

C++
NResult N_API NLicensePlateGetValue(HNLicensePlate hLicensePlate, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNLicensePlate hLicensePlate | [in] Handle to NLicensePlateDetails object.
HNString * phValue | [out] Pointer to NString object which receives vehicle's number from a license plate.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicensePlate.h

Module: NLicensePlate Unit


NNameConfidencePair Unit

NNameConfidencePair Unit
Functions Legend Structs, Records, Enums

Structure containing name and/or confidence values.

Collapse Expand Functions
Name | Description
NNameConfidencePairCopy | Copies one NNameConfidencePair structure to another.
NNameConfidencePairCreate | Creates a new instance of NNameConfidencePair.
NNameConfidencePairDispose | Disposes specified NNameConfidencePair object.
NNameConfidencePairSet | Sets NNameConfidencePair value.
Collapse Expand Structs, Records, Enums
Name | Description
NNameConfidencePair_ | Structure containing name and/or confidence values.


NNameConfidencePairCopy Function

NNameConfidencePairCopy Function

Copies one NNameConfidencePair structure to another.

C++
NResult N_API NNameConfidencePairCopy(const struct NNameConfidencePair_ * pSrcValue, struct NNameConfidencePair_ * pDstValue);
Collapse Expand Parameters
Parameters | Description
const struct NNameConfidencePair_ * pSrcValue | [in] NNameConfidencePair source object.
struct NNameConfidencePair_ * pDstValue | [in] NNameConfidencePair destination object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NNameConfidencePair.h

Module: NNameConfidencePair Unit


NNameConfidencePairCreate Function

NNameConfidencePairCreate Function

Creates a new instance of NNameConfidencePair.

C++
NResult N_API NNameConfidencePairCreate(const NChar * szName, NFloat confidence, NNameConfidencePair * pValue);
Collapse Expand Parameters
Parameters | Description
const NChar * szName | [in] Zero-terminates string containing name.
NFloat confidence | [in] Confidence value.
NNameConfidencePair * pValue | [out] Pointer to a created NNameConfidencePair object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NNameConfidencePair.h

Module: NNameConfidencePair Unit


NNameConfidencePairDispose Function

NNameConfidencePairDispose Function

Disposes specified NNameConfidencePair object.

C++
NResult N_API NNameConfidencePairDispose(struct NNameConfidencePair_ * pValue);
Collapse Expand Parameters
Parameters | Description
struct NNameConfidencePair_ * pValue | [in] NNameConfidencePair object to dispose.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NNameConfidencePair.h

Module: NNameConfidencePair Unit


NNameConfidencePairSet Function

NNameConfidencePairSet Function

Sets NNameConfidencePair value.

C++
NResult N_API NNameConfidencePairSet(const struct NNameConfidencePair_ * pSrcValue, struct NNameConfidencePair_ * pDstValue);
Collapse Expand Parameters
Parameters | Description
const struct NNameConfidencePair_ * pSrcValue | [in] NNameConfidencePair source object.
struct NNameConfidencePair_ * pDstValue | [in] NNameConfidencePair destination object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NNameConfidencePair.h

Module: NNameConfidencePair Unit


NNameConfidencePair_ Structure

NNameConfidencePair_ Structure

Structure containing name and/or confidence values.

C++
struct NNameConfidencePair_ {
  HNString hName;
  NFloat confidence;
};
Collapse Expand Members
Members | Description
HNString hName; | Name value as NString.
NFloat confidence; | Confidence value.
Container

File: NNameConfidencePair.h

Module: NNameConfidencePair Unit


NSurveillance Unit

NSurveillance Unit
Files Functions Legend Structs, Records, Enums

Provides the main SentiVeillance functions.

Collapse Expand Files
Name | Description
NSurveillanceEventDetails.h | A header file containing containing EventDetails functions.
NsedMatchResult.h | A header file containing containing functions for surveillance matching results.
NSurveillance.h | Main NSurveillance library C header file containing function declaration and event type declarations.
Collapse Expand Functions
Name | Description
NSurveillanceAddEventCallbackEx | ... more
NSurveillanceAddEventEx | Adds an event to Surveillance framework.
NSurveillanceAddIsRunningChanged | Adds user specified event for managing Surveillance changed events.
NSurveillanceAddIsRunningChangedCallback | Adds user specified callback for managing Surveillance changed events.
NSurveillanceAddSource | Adds capturing source to the Surveillance framework. The capturing source must not be capturing or being already in use by other library.
NSurveillanceAddSourceCollectionChanged | Adds user specified event for managing source collection changed events.
NSurveillanceAddSourceCollectionChangedCallback | Adds user specified callback for managing source collection events.
NSurveillanceAddTemplate | ... more
NSurveillanceClearSources | ... more
NSurveillanceCreate | Creates NSurveillance object.
NSurveillanceDetectionDetailsCreate | Creates a new instance of surveillance detection details object.
NSurveillanceDetectionDetailsGetClothingDetails | Gets subject's clothing details.
NSurveillanceDetectionDetailsGetDetectionConfidence | Gets detection confidence value.
NSurveillanceDetectionDetailsGetFace | Gets detected face object.
NSurveillanceDetectionDetailsGetFaceRectangle | Gets bounding box rectangle of a detected subject's face.
NSurveillanceDetectionDetailsGetLicensePlateDetails | Gets vehicle's license plate details.
NSurveillanceDetectionDetailsGetObjectColor | Gets color of a detected surveillance object.
NSurveillanceDetectionDetailsGetObjectType | Gets type of a detected surveillance object.
NSurveillanceDetectionDetailsGetRectangle | Gets bounding box rectangle of a detected object.
NSurveillanceDetectionDetailsGetSubjectType | ... more
NSurveillanceDetectionDetailsGetVehicleDetails | Gets vehicle details.
NSurveillanceDetectionDetailsSetClothingDetails | Sets subject's clothing details.
NSurveillanceDetectionDetailsSetDetectionConfidence | Sets detection confidence value.
NSurveillanceDetectionDetailsSetFace | Sets face object.
NSurveillanceDetectionDetailsSetFaceRectangle | Sets bounding box rectangle of a detected subject's face.
NSurveillanceDetectionDetailsSetLicensePlateDetails | Sets vehicle's license plate details.
NSurveillanceDetectionDetailsSetObjectColor | Sets color of a detected surveillance object.
NSurveillanceDetectionDetailsSetObjectType | Sets type of a detected surveillance object.
NSurveillanceDetectionDetailsSetRectangle | Sets bounding box rectangle of a detected object.
NSurveillanceDetectionDetailsSetSubjectType | ... more
NSurveillanceDetectionDetailsSetVehicleDetails | Sets vehicle details.
NSurveillanceDetectionResultGetDetails | Gets an array of all detection results.
NSurveillanceDetectionResultGetDetailsAt | Gets surveillance detection result by an index.
NSurveillanceDetectionResultGetDetailsCount | Gets detection results count.
NSurveillanceDetectionResultGetImage | Gets an image containing a detected surveillance object.
NSurveillanceDetectionResultGetModalityType | Gets a type of modality used for surveillance and objects detection.
NSurveillanceEngineCreate | Creates a new instance of NSurveillanceEngine.
NSurveillanceEngineDetect | Detects Surveillance object from the specified image.
NSurveillanceEngineDetectAsync | Detects Surveillance object from the specified image (asynchronous operation).
NSurveillanceEngineInit | Initializes specified NSurveillanceEngine.
NSurveillanceGetDeviceManager | Gets NDeviceManager associated with specified NSurveillance handle.
NSurveillanceGetSource | Retrieves a handle for previously added capturing source.
NSurveillanceGetSourceCount | ... more
NSurveillanceGetSources | Retrieves the surveillance sources of the specified NSurveillance object.
NSurveillanceGetTemplateIdsN | ... more
NSurveillanceIsRunning | Checks if NSurveillance object is running.
NSurveillanceOptimizeAllModelsAsync | Optimizes specified NSureveillance models by specified modalities (asynchronous operation).
NSurveillanceOptimizeModelsAsync | Optimizes all NSureveillance models by specified modalities (asynchronous operation).
NSurveillanceRemoveAllTemplates | Removed templates from internal Surveillance database.
NSurveillanceRemoveEventCallbackEx | ... more
NSurveillanceRemoveEventEx | Removes an event from Surveillance framework.
NSurveillanceRemoveIsRunningChanged | Removes user specified event for managing Surveillance changed events.
NSurveillanceRemoveIsRunningChangedCallback | Removes user specified callback for managing Surveillance changed events.
NSurveillanceRemoveSourceAt | ... more
NSurveillanceRemoveSourceCollectionChanged | Removes user specified event for managing source collection changed events.
NSurveillanceRemoveSourceCollectionChangedCallback | Removes user specified callback for managing source collection changed events.
NSurveillanceRemoveTemplateN | Removes a template from Surveillance internal database.
NSurveillanceStart | ... more
NSurveillanceStartAsync | Enables callbacks and starts Surveillance (asynchronous operation). After surveillance is no longer needed NSurveillanceStop should be called.
NSurveillanceStartSource | Starts specified surveillance source.
NSurveillanceStartSourceAsync | Starts specified surveillance source (asynchronous operation).
NSurveillanceStop | ... more
NSurveillanceStopAsync | Stops surveillance and all sources (asynchronous operation).
NSurveillanceStopSource | Stops specified surveillance source.
NSurveillanceStopSourceAsync | Stops specified surveillance source (asynchronous operation).
NsedGetAttributes | Gets face attributes from specified surveillance event details.
NsedGetAttributesContainsDetails | Checks whether specified surveillance event contains extraction details.
NsedGetBestDetails | Gets an event containing best details for a tracked subject.
NsedGetBestMatchResult | Gets best face match results from the specified frame.
NsedGetBestMatchResultCount | Gets best face match results count from the specified frame.
NsedGetBestMatchResults | Gets best face match results from the specified frame.
NsedGetClothingDetails | Gets ClothingDetails object containing subject's clothing details and gender.
NsedGetCurrentMatchResult | Gets match result by an index.
NsedGetCurrentMatchResultCount | Gets match results count.
NsedGetCurrentMatchResults | Gets all current match results.
NsedGetDetectedFaces | Gets the list of detected faces attributes.
NsedGetDetectionConfidence | Gets detection confidence value (NFloat type).
NsedGetError | Returns the most recent error for the specified surveillance event.
NsedGetFace | Gets face of the specified event.
NsedGetFaceConfidence | Retrieves face confidence value of the specified event. Indicates whether the event object is a face.
NsedGetFaceRectangle | Gets bounding box rectangle of a detected subject's face.
NsedGetFrameIndex | Gets frame index (the number of captured images prior to this event).
NsedGetLicensePlateDetails | Gets vehicle's license plate details.
NsedGetMergedSubject | Gets a subject that was merged with current subject. Only applicable during SubjectMerged event.
NsedGetModalityType | ... more
NsedGetObjectColor | Gets color of a detected surveillance object.
NsedGetObjectDirection | Gets NSurveillanceObjectDirection object.
NsedGetObjectType | Gets type of a detected surveillance object.
NsedGetOriginalImageEx | Retrieves the originally captured image.
NsedGetRectangle | Retrieves the rectangle selection of the original image.
NsedGetSource | Gets Surveillance source.
NsedGetSplitFromSubject | ... more
NsedGetSubjectTemplate | Gets generalized Subject template.
NsedGetSubjectType | ... more
NsedGetTemplateEx | Retrieves the extracted face template.
NsedGetTimeStamp | Gets the date and time of the captured image.
NsedGetTraceIndex | Gets an index of the current subject being tracked. The index is zero-based and represents unique id of subject being tracked at the current moment. After subject disappears this index becomes invalid.
NsedGetVehicleDetails | Gets vehicle details.
NsedMatchResultCreate | Creates a new instance of NsedMatchResult.
NsedMatchResultCreateEx | Creates a new instance of NsedMatchResult.
NsedMatchResultGetId | Gets the Id (string) of matched object.
NsedMatchResultGetMatchingDetails | Gets matching details from NsedMatchResult.
NsedMatchResultGetScore | Gets surveillance matching score.
Collapse Expand Structs, Records, Enums
Name | Description
NDetectorScaleCount_ | Enumerates detector scale count. Bigger values improves quality, but requires more processing power.
NGpuIndex_ | Enumerates GPU units by index.
NSurveillanceEventType_ | ... more
NSurveillanceObjectColorDetails_ | Enumerates object color and color confidence values.
NSurveillanceObjectColor_ | Enumerates tracked object color values.
NSurveillanceObjectDirectionDetails_ | Represents detected or tracked object direction confidence values.
NSurveillanceObjectDirection_ | Represents detected or tracked object direction values.
NSurveillanceObjectTypeDetails_ | Enumerates surveillance object type confidence values.
NSurveillanceObjectType_ | Enumerates surveillance objects.
NDetectorScaleCount | Enumerates detector scale count. Bigger values improves quality, but requires more processing power.
NGpuIndex | Enumerates GPU units by index.
NSurveillanceObjectColor | Enumerates tracked object color values.
NSurveillanceObjectDirection | Represents detected or tracked object direction values.
NSurveillanceObjectType | Enumerates surveillance objects.
NSurveillanceEventType | ... more


NSurveillanceAddEventCallbackEx Function

NSurveillanceAddEventCallbackEx Function
NSurveillance.h

Adds callback function to Surveillance framework.

C++
NResult N_API NSurveillanceAddEventCallbackEx(HNSurveillance hSurveillance, NSurveillanceCompositeEventCallback pCallback, NSurveillanceEventType eventType, void * pParam);
Collapse Expand Parameters
Parameters | Description
HNSurveillance hSurveillance | [in] Handle to NSurveillance object.
NSurveillanceCompositeEventCallback pCallback | [in] Callback function to be added. The type of the callback function is NSurveillanceEventCallbackEx.
NSurveillanceEventType eventType | [in] Event Type for which to add callback function.
void * pParam | [in] Parameter which was supplied to the callback function.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Also NSucceeded macro can be used to check if function succeeded.

Container

File: NSurveillance.h

Module: NSurveillance Unit


NSurveillanceAddEventEx Function

NSurveillanceAddEventEx Function
NSurveillance.h

Adds an event to Surveillance framework.

C++
NResult N_API NSurveillanceAddEventEx(HNSurveillance hSurveillance, NSurveillanceEventType eventType, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNSurveillance hSurveillance | [in] Handle to NSurveillance object.
NSurveillanceEventType eventType | [in] Event type which to add.
HNCallback hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillance.h

Module: NSurveillance Unit


NSurveillanceAddIsRunningChanged Function

NSurveillanceAddIsRunningChanged Function
NSurveillance.h

Adds user specified event for managing Surveillance changed events.

C++
NResult N_API NSurveillanceAddIsRunningChanged(HNSurveillance hSurveillance, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNSurveillance hSurveillance | [in] Handle to NSurveillance object.
HNCallback hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillance.h

Module: NSurveillance Unit


NSurveillanceAddIsRunningChangedCallback Function

NSurveillanceAddIsRunningChangedCallback Function
NSurveillance.h

Adds user specified callback for managing Surveillance changed events.

C++
NResult N_API NSurveillanceAddIsRunningChangedCallback(HNSurveillance hSurveillance, NObjectCallback pCallback, void * pParam);
Collapse Expand Parameters
Parameters | Description
HNSurveillance hSurveillance | [in] Handle to NSurveillance object.
NObjectCallback pCallback | [in] Callback function to be added. The type of the callback function is NObjectCallback.
void * pParam | [in] User data used by a callback function.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillance.h

Module: NSurveillance Unit


NSurveillanceAddSource Function

NSurveillanceAddSource Function
NSurveillance.h

Adds capturing source to the Surveillance framework. The capturing source must not be capturing or being already in use by other library.

C++
NResult N_API NSurveillanceAddSource(HNSurveillance hSurveillance, HNSurveillanceSource hSource, NInt * pIndex);
Collapse Expand Parameters
Parameters | Description
HNSurveillance hSurveillance | [in] Handle of Surveillance object.
HNSurveillanceSource hSource | [in] Handle of NSurveillanceSource object.
NInt * pIndex | [out] Source index.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Notes

The same capturing source must be added only once.

Surveillance must be stopped prior calling this function.

Container

File: NSurveillance.h

Module: NSurveillance Unit


NSurveillanceAddSourceCollectionChanged Function

NSurveillanceAddSourceCollectionChanged Function
NSurveillance.h

Adds user specified event for managing source collection changed events.

C++
NResult N_API NSurveillanceAddSourceCollectionChanged(HNSurveillance hSurveillance, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNSurveillance hSurveillance | [in] Handle to NSurveillance object.
HNCallback hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillance.h

Module: NSurveillance Unit


NSurveillanceAddSourceCollectionChangedCallback Function

NSurveillanceAddSourceCollectionChangedCallback Function
NSurveillance.h

Adds user specified callback for managing source collection events.

C++
NResult N_API NSurveillanceAddSourceCollectionChangedCallback(HNSurveillance hSurveillance, N_COLLECTION_CHANGED_CALLBACK_ARG(HNSurveillanceSource, pCallback), void * pParam);
Collapse Expand Parameters
Parameters | Description
HNSurveillance hSurveillance | [in] Handle to NSurveillance object.
void * pParam | [in] User data used by a callback function.
pCallback | [in] Callback function to be added. The type of the callback function is NObjectCallback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillance.h

Module: NSurveillance Unit


NSurveillanceAddTemplate Function

NSurveillanceAddTemplate Function
NSurveillance.h

Adds serialized NLTemplate to the surveillance framework's internal database.

C++
NResult N_API NSurveillanceAddTemplate(HNSurveillance hSurveillance, const NChar * szTemplateId, HNBuffer hTemplate);
Collapse Expand Parameters
Parameters | Description
HNSurveillance hSurveillance | [in] Handle of Surveillance object.
const NChar * szTemplateId | [in] Pointer to the ID of the template
HNBuffer hTemplate | [in] Handle to memory location where serialized template is stored.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Also NSucceeded macro can be used to check if function succeeded.

Collapse Expand Remarks

Serialized template will be copied to the internal database. Only templateId is stored internally.

Container

File: NSurveillance.h

Module: NSurveillance Unit


NSurveillanceClearSources Function

NSurveillanceClearSources Function
NSurveillance.h

Removes any added capturing sources from surveillance framework.

C++
NResult N_API NSurveillanceClearSources(HNSurveillance hSurveillance);
Collapse Expand Parameters
Parameters | Description
HNSurveillance hSurveillance | [in] Handle of Surveillance object from which any added capturing sources should be removed.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Also NSucceeded macro can be used to check if function succeeded.

Collapse Expand Notes

Surveillance must be stopped prior calling this function.

Container

File: NSurveillance.h

Module: NSurveillance Unit


NSurveillanceCreate Function

NSurveillanceCreate Function
NSurveillance.h

Creates NSurveillance object.

C++
NResult N_API NSurveillanceCreate(HNSurveillance * phSurveillance);
Collapse Expand Parameters
Parameters | Description
pHSurveillance | [out] Pointer to handle of created Surveillance object.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Also NSucceeded macro can be used to check if function succeeded.

Container

File: NSurveillance.h

Module: NSurveillance Unit


NSurveillanceDetectionDetailsCreate Function

NSurveillanceDetectionDetailsCreate Function

Creates a new instance of surveillance detection details object.

C++
NResult N_API NSurveillanceDetectionDetailsCreate(HNSurveillanceDetectionDetails * phValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceDetectionDetails * phValue | [out] Pointer to NSurveillanceDetectionDetails object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceDetectionDetails.h

Module: NSurveillance Unit


NSurveillanceDetectionDetailsGetClothingDetails Function

NSurveillanceDetectionDetailsGetClothingDetails Function

Gets subject's clothing details.

C++
NResult N_API NSurveillanceDetectionDetailsGetClothingDetails(HNSurveillanceDetectionDetails hDetails, HNClothingDetails * phValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceDetectionDetails hDetails | [in] Handle to NSurveillanceDetectionDetails object.
HNClothingDetails * phValue | [out] Pointer to NClothingDetails which receives subject's clothing details.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceDetectionDetails.h

Module: NSurveillance Unit


NSurveillanceDetectionDetailsGetDetectionConfidence Function

NSurveillanceDetectionDetailsGetDetectionConfidence Function

Gets detection confidence value.

C++
NResult N_API NSurveillanceDetectionDetailsGetDetectionConfidence(HNSurveillanceDetectionDetails hDetails, NFloat * pValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceDetectionDetails hDetails | [in] Handle to NSurveillanceDetectionDetails object.
NFloat * pValue | [out] Detection confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceDetectionDetails.h

Module: NSurveillance Unit


NSurveillanceDetectionDetailsGetFace Function

NSurveillanceDetectionDetailsGetFace Function

Gets detected face object.

C++
NResult N_API NSurveillanceDetectionDetailsGetFace(HNSurveillanceDetectionDetails hDetails, HNFace * phValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceDetectionDetails hDetails | [in] Handle to NSurveillanceDetectionDetails object.
HNFace * phValue | [out] Pointer to NFace object which receives detected face object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceDetectionDetails.h

Module: NSurveillance Unit


NSurveillanceDetectionDetailsGetFaceRectangle Function

NSurveillanceDetectionDetailsGetFaceRectangle Function

Gets bounding box rectangle of a detected subject's face.

C++
NResult N_API NSurveillanceDetectionDetailsGetFaceRectangle(HNSurveillanceDetectionDetails hDetails, struct NRect_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceDetectionDetails hDetails | [in] Handle to NSurveillanceDetectionDetails object.
struct NRect_ * pValue | [out] Bounding box rectangle of a detected subject's face.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceDetectionDetails.h

Module: NSurveillance Unit


NSurveillanceDetectionDetailsGetLicensePlateDetails Function

NSurveillanceDetectionDetailsGetLicensePlateDetails Function

Gets vehicle's license plate details.

C++
NResult N_API NSurveillanceDetectionDetailsGetLicensePlateDetails(HNSurveillanceDetectionDetails hDetails, HNLicensePlateDetails * phValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceDetectionDetails hDetails | [in] Handle to NSurveillanceDetectionDetails object.
HNLicensePlateDetails * phValue | [out] Pointer to vehicle's license plate details.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceDetectionDetails.h

Module: NSurveillance Unit


NSurveillanceDetectionDetailsGetObjectColor Function

NSurveillanceDetectionDetailsGetObjectColor Function

Gets color of a detected surveillance object.

C++
NResult N_API NSurveillanceDetectionDetailsGetObjectColor(HNSurveillanceDetectionDetails hDetails, struct NSurveillanceObjectColorDetails_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceDetectionDetails hDetails | [in] Handle to NSurveillanceDetectionDetails object.
struct NSurveillanceObjectColorDetails_ * pValue | [out] Pointer to SurveillanceObjectColorDetails containing color of a detected surveillance object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceDetectionDetails.h

Module: NSurveillance Unit


NSurveillanceDetectionDetailsGetObjectType Function

NSurveillanceDetectionDetailsGetObjectType Function

Gets type of a detected surveillance object.

C++
NResult N_API NSurveillanceDetectionDetailsGetObjectType(HNSurveillanceDetectionDetails hDetails, struct NSurveillanceObjectTypeDetails_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceDetectionDetails hDetails | [in] Handle to NSurveillanceDetectionDetails object.
struct NSurveillanceObjectTypeDetails_ * pValue | [out] Pointer to NSurveillanceObjectTypeDetails.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceDetectionDetails.h

Module: NSurveillance Unit


NSurveillanceDetectionDetailsGetRectangle Function

NSurveillanceDetectionDetailsGetRectangle Function

Gets bounding box rectangle of a detected object.

C++
NResult N_API NSurveillanceDetectionDetailsGetRectangle(HNSurveillanceDetectionDetails hDetails, struct NRect_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceDetectionDetails hDetails | [in] Handle to NSurveillanceDetectionDetails object.
struct NRect_ * pValue | [out] Pointer to NRect object containing coordinates, width and height of object's bounding box rectangle.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceDetectionDetails.h

Module: NSurveillance Unit


NSurveillanceDetectionDetailsGetSubjectType Function

NSurveillanceDetectionDetailsGetSubjectType Function

Gets NSurveillanceModalityType object containing one of surveillance modality values (None, Faces, Vehicles and Humans or License Plate Recognition).

C++
NResult N_API NSurveillanceDetectionDetailsGetSubjectType(HNSurveillanceDetectionDetails hDetails, NSurveillanceModalityType * pValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceDetectionDetails hDetails | [in] Handle to NSurveillanceDetectionDetails object.
NSurveillanceModalityType * pValue | [out] Pointer to NSurveillanceModalityType object containing one of surveillance modality values.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceDetectionDetails.h

Module: NSurveillance Unit


NSurveillanceDetectionDetailsGetVehicleDetails Function

NSurveillanceDetectionDetailsGetVehicleDetails Function

Gets vehicle details.

C++
NResult N_API NSurveillanceDetectionDetailsGetVehicleDetails(HNSurveillanceDetectionDetails hDetails, HNVehicleDetails * phValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceDetectionDetails hDetails | [in] Handle to NSurveillanceDetectionDetails object.
HNVehicleDetails * phValue | [out] Pointer to NVehicleDetails.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceDetectionDetails.h

Module: NSurveillance Unit


NSurveillanceDetectionDetailsSetClothingDetails Function

NSurveillanceDetectionDetailsSetClothingDetails Function

Sets subject's clothing details.

C++
NResult N_API NSurveillanceDetectionDetailsSetClothingDetails(HNSurveillanceDetectionDetails hDetails, HNClothingDetails hValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceDetectionDetails hDetails | [in] Handle to NSurveillanceDetectionDetails object.
HNClothingDetails hValue | [in] Subject's clothing details to set.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceDetectionDetails.h

Module: NSurveillance Unit


NSurveillanceDetectionDetailsSetDetectionConfidence Function

NSurveillanceDetectionDetailsSetDetectionConfidence Function

Sets detection confidence value.

C++
NResult N_API NSurveillanceDetectionDetailsSetDetectionConfidence(HNSurveillanceDetectionDetails hDetails, NFloat value);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceDetectionDetails hDetails | [in] Handle to NSurveillanceDetectionDetails object.
NFloat value | [in] Detection confidence value to set.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceDetectionDetails.h

Module: NSurveillance Unit


NSurveillanceDetectionDetailsSetFace Function

NSurveillanceDetectionDetailsSetFace Function

Sets face object.

C++
NResult N_API NSurveillanceDetectionDetailsSetFace(HNSurveillanceDetectionDetails hDetails, HNFace hValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceDetectionDetails hDetails | [in] Handle to NSurveillanceDetectionDetails object.
HNFace hValue | [in] NFace object to set.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceDetectionDetails.h

Module: NSurveillance Unit


NSurveillanceDetectionDetailsSetFaceRectangle Function

NSurveillanceDetectionDetailsSetFaceRectangle Function

Sets bounding box rectangle of a detected subject's face.

C++
NResult N_API NSurveillanceDetectionDetailsSetFaceRectangle(HNSurveillanceDetectionDetails hDetails, const struct NRect_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceDetectionDetails hDetails | [in] Handle to NSurveillanceDetectionDetails object.
const struct NRect_ * pValue | [in] Bounding box rectangle of a detected subject's face to set.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceDetectionDetails.h

Module: NSurveillance Unit


NSurveillanceDetectionDetailsSetLicensePlateDetails Function

NSurveillanceDetectionDetailsSetLicensePlateDetails Function

Sets vehicle's license plate details.

C++
NResult N_API NSurveillanceDetectionDetailsSetLicensePlateDetails(HNSurveillanceDetectionDetails hDetails, HNLicensePlateDetails hValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceDetectionDetails hDetails | [in] Handle to NSurveillanceDetectionDetails object.
HNLicensePlateDetails hValue | [in] Vehicle's license plate details to set.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceDetectionDetails.h

Module: NSurveillance Unit


NSurveillanceDetectionDetailsSetObjectColor Function

NSurveillanceDetectionDetailsSetObjectColor Function

Sets color of a detected surveillance object.

C++
NResult N_API NSurveillanceDetectionDetailsSetObjectColor(HNSurveillanceDetectionDetails hDetails, const struct NSurveillanceObjectColorDetails_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceDetectionDetails hDetails | [in] Handle to NSurveillanceDetectionDetails object.
const struct NSurveillanceObjectColorDetails_ * pValue | [in] SurveillanceObjectColorDetails containing color of a detected surveillance object to set.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceDetectionDetails.h

Module: NSurveillance Unit


NSurveillanceDetectionDetailsSetObjectType Function

NSurveillanceDetectionDetailsSetObjectType Function

Sets type of a detected surveillance object.

C++
NResult N_API NSurveillanceDetectionDetailsSetObjectType(HNSurveillanceDetectionDetails hDetails, const struct NSurveillanceObjectTypeDetails_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceDetectionDetails hDetails | [in] Handle to NSurveillanceDetectionDetails object.
const struct NSurveillanceObjectTypeDetails_ * pValue | [in] NSurveillanceObjectTypeDetails to set.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceDetectionDetails.h

Module: NSurveillance Unit


NSurveillanceDetectionDetailsSetRectangle Function

NSurveillanceDetectionDetailsSetRectangle Function

Sets bounding box rectangle of a detected object.

C++
NResult N_API NSurveillanceDetectionDetailsSetRectangle(HNSurveillanceDetectionDetails hDetails, const struct NRect_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceDetectionDetails hDetails | [in] Handle to NSurveillanceDetectionDetails object.
const struct NRect_ * pValue | [in] NRect object containing coordinates, width and height of object's bounding box rectangle to set.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceDetectionDetails.h

Module: NSurveillance Unit


NSurveillanceDetectionDetailsSetSubjectType Function

NSurveillanceDetectionDetailsSetSubjectType Function

Sets NSurveillanceModalityType object containing one of surveillance modality values (None, Faces, Vehicles and Humans or License Plate Recognition).

C++
NResult N_API NSurveillanceDetectionDetailsSetSubjectType(HNSurveillanceDetectionDetails hDetails, NSurveillanceModalityType value);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceDetectionDetails hDetails | [in] Handle to NSurveillanceDetectionDetails object.
NSurveillanceModalityType value | [in] NSurveillanceModalityType object containing one of surveillance modality values.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceDetectionDetails.h

Module: NSurveillance Unit


NSurveillanceDetectionDetailsSetVehicleDetails Function

NSurveillanceDetectionDetailsSetVehicleDetails Function

Sets vehicle details.

C++
NResult N_API NSurveillanceDetectionDetailsSetVehicleDetails(HNSurveillanceDetectionDetails hDetails, HNVehicleDetails hValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceDetectionDetails hDetails | [in] Handle to NSurveillanceDetectionDetails object.
HNVehicleDetails hValue | [in] Vehicle details to set.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceDetectionDetails.h

Module: NSurveillance Unit


NSurveillanceDetectionResultGetDetails Function

NSurveillanceDetectionResultGetDetails Function

Gets an array of all detection results.

C++
NResult N_API NSurveillanceDetectionResultGetDetails(HNSurveillanceDetectionResult hDetails, HNSurveillanceDetectionDetails * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceDetectionResult hDetails | [in] Handle to NSurveillanceDetectionResult object.
HNSurveillanceDetectionDetails * * parhValues | [out] Pointer to NSurveillanceDetectionDetails containing detection result values.
NInt * pValueCount | [out] Array items count.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceDetectionResult.h

Module: NSurveillance Unit


NSurveillanceDetectionResultGetDetailsAt Function

NSurveillanceDetectionResultGetDetailsAt Function

Gets surveillance detection result by an index.

C++
NResult N_API NSurveillanceDetectionResultGetDetailsAt(HNSurveillanceDetectionResult hDetails, NInt index, HNSurveillanceDetectionDetails * phValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceDetectionResult hDetails | [in] Handle to NSurveillanceDetectionResult object.
NInt index | [in] Index of a detection result to retrieve a value.
HNSurveillanceDetectionDetails * phValue | [out] Pointer to NSurveillanceDetectionDetails containing a detection result.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceDetectionResult.h

Module: NSurveillance Unit


NSurveillanceDetectionResultGetDetailsCount Function

NSurveillanceDetectionResultGetDetailsCount Function

Gets detection results count.

C++
NResult N_API NSurveillanceDetectionResultGetDetailsCount(HNSurveillanceDetectionResult hDetails, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceDetectionResult hDetails | [in] Handle to NSurveillanceDetectionResult object.
NInt * pValue | [out] Detection results count.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceDetectionResult.h

Module: NSurveillance Unit


NSurveillanceDetectionResultGetImage Function

NSurveillanceDetectionResultGetImage Function

Gets an image containing a detected surveillance object.

C++
NResult N_API NSurveillanceDetectionResultGetImage(HNSurveillanceDetectionResult hDetails, HNImage * phValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceDetectionResult hDetails | [in] Handle to NSurveillanceDetectionResult object.
HNImage * phValue | [out] Pointer to NImage containing a detected surveillance object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceDetectionResult.h

Module: NSurveillance Unit


NSurveillanceDetectionResultGetModalityType Function

NSurveillanceDetectionResultGetModalityType Function

Gets a type of modality used for surveillance and objects detection.

C++
NResult N_API NSurveillanceDetectionResultGetModalityType(HNSurveillanceDetectionResult hDetails, NSurveillanceModalityType * pValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceDetectionResult hDetails | [in] Handle to NSurveillanceDetectionResult object.
NSurveillanceModalityType * pValue | [out] Pointer to NSurveillanceModalityType.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceDetectionResult.h

Module: NSurveillance Unit


NSurveillanceEngineCreate Function

NSurveillanceEngineCreate Function

Creates a new instance of NSurveillanceEngine.

C++
NResult N_API NSurveillanceEngineCreate(HNSurveillanceEngine * phValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceEngine * phValue | [out] Pointer to a created NSurveillanceEngine.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceEngine.h

Module: NSurveillance Unit


NSurveillanceEngineDetect Function

NSurveillanceEngineDetect Function

Detects Surveillance object from the specified image.

C++
NResult N_API NSurveillanceEngineDetect(HNSurveillanceEngine hEngine, HNImage hImage, HNSurveillanceDetectionResult * phValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceEngine hEngine | [in] Handle to NSurveillanceEngine.
HNImage hImage | [in] NImage containing an image for detection by Surveillance engine.
HNSurveillanceDetectionResult * phValue | [out] Pointer to NSurveillanceDetectionResult containing detection result from a specified image.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceEngine.h

Module: NSurveillance Unit


NSurveillanceEngineDetectAsync Function

NSurveillanceEngineDetectAsync Function

Detects Surveillance object from the specified image (asynchronous operation).

C++
NResult N_API NSurveillanceEngineDetectAsync(HNSurveillanceEngine hEngine, HNImage hImage, HNAsyncOperation * phAsyncOpetation);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceEngine hEngine | [in] Handle to NSurveillanceEngine.
HNImage hImage | [in] NImage containing an image for detection by Surveillance engine.
HNAsyncOperation * phAsyncOpetation | [out] Pointer to NAsyncOperation.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceEngine.h

Module: NSurveillance Unit


NSurveillanceEngineInit Function

NSurveillanceEngineInit Function

Initializes specified NSurveillanceEngine.

C++
NResult N_API NSurveillanceEngineInit(HNSurveillanceEngine hEngine);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceEngine hEngine | [in] Handle to NSurveillanceEngine.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceEngine.h

Module: NSurveillance Unit


NSurveillanceGetDeviceManager Function

NSurveillanceGetDeviceManager Function
NSurveillance.h

Gets NDeviceManager associated with specified NSurveillance handle.

C++
NResult N_API NSurveillanceGetDeviceManager(HNSurveillance hSurveillance, HNDeviceManager * phValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillance hSurveillance | [in] Handle of NSurveillance object.
phDeviceManager | [out] Surveillance device manager.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillance.h

Module: NSurveillance Unit


NSurveillanceGetSource Function

NSurveillanceGetSource Function
NSurveillance.h

Retrieves a handle for previously added capturing source.

C++
NResult N_API NSurveillanceGetSource(HNSurveillance hSurveillance, NInt index, HNSurveillanceSource * phValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillance hSurveillance | [in] Handle of NSurveillance object.
NInt index | [in] Index of capturing source.
HNSurveillanceSource * phValue | [out] Pointer to NSurveillanceSource object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillance.h

Module: NSurveillance Unit


NSurveillanceGetSourceCount Function

NSurveillanceGetSourceCount Function
NSurveillance.h

Retrieves the number of capturing sources previously added to the Surveillance framework.

C++
NResult N_API NSurveillanceGetSourceCount(HNSurveillance hSurveillance, NInt * pCount);
Collapse Expand Parameters
Parameters | Description
HNSurveillance hSurveillance | [in] Handle of Surveillance object.
NInt * pCount | [out] Pointer to the count of the capturing sources. The type of the variable is NInt.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Also NSucceeded macro can be used to check if function succeeded.

Container

File: NSurveillance.h

Module: NSurveillance Unit


NSurveillanceGetSources Function

NSurveillanceGetSources Function
NSurveillance.h

Retrieves the surveillance sources of the specified NSurveillance object.

C++
NResult N_API NSurveillanceGetSources(HNSurveillance hSurveillance, HNSurveillanceSource * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNSurveillance hSurveillance | [in] Handle of Surveillance object.
HNSurveillanceSource * * parhValues | [out] Pointer to the array of surveillance sources.
NInt * pValueCount | [out] Number of sources in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillance.h

Module: NSurveillance Unit


NSurveillanceGetTemplateIdsN Function

NSurveillanceGetTemplateIdsN Function
NSurveillance.h

Retrieves an array of stored in the database template Ids. You must call this function twice: first to retrieve the number of elements in the array, and second to retrieve the array itself.

C++
NResult N_API NSurveillanceGetTemplateIdsN(HNSurveillance hSurveillance, HNString * arhTemplateIds, NInt templateIdsLength);
Collapse Expand Parameters
Parameters | Description
HNSurveillance hSurveillance | [in] Handle of Surveillance object.
NInt templateIdsLength | [in] Length of arTemplateIds.
arTemplateIds | [out] Pointer to the previously allocated array of void pointers.
Collapse Expand Returns

If the function succeeds and supplied arTemplateIds is NULL, the return value is the number of array elements.

If the function succeeds and supplied arTemplateIds is not NULL, the return value is N_OK.

If the function fails, the return value is one of the following error codes:

Error code | Condition
N_E_FAILED | Failed to complete operation.
Collapse Expand Remarks

To retrieve the array, you must call this function twice. First call must be made with arTemplateIds set to NULL. The return value will be either negative error or positive value indicating the size of the array to be filled. Second call must be made with arTemplateIds pointing to the newly allocated array. To ensure that the number of entries in the internal database do not change between these two function calls one must never manipulate it in any way. Best is to implement a way of synchronization.

Container

File: NSurveillance.h

Module: NSurveillance Unit


NSurveillanceIsRunning Function

NSurveillanceIsRunning Function
NSurveillance.h

Checks if NSurveillance object is running.

C++
NResult N_API NSurveillanceIsRunning(HNSurveillance hSurveillance, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillance hSurveillance | [in] Handle to NSurveillance object to check.
NBool * pValue | [out] Boolean value indicating if NSurveillance object is running.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Also NSucceeded macro can be used to check if function succeeded.

Container

File: NSurveillance.h

Module: NSurveillance Unit


NSurveillanceOptimizeAllModelsAsync Function

NSurveillanceOptimizeAllModelsAsync Function
NSurveillance.h

Optimizes specified NSureveillance models by specified modalities (asynchronous operation).

C++
NResult N_API NSurveillanceOptimizeAllModelsAsync(NSurveillanceModalityType modalities, NBool lowGpuMemoryMode, NGpuIndex gpuIndices, HNAsyncOperation * phAsyncOperation);
Collapse Expand Parameters
Parameters | Description
NSurveillanceModalityType modalities | [in] Surveillance modalities to optimize.
NBool lowGpuMemoryMode | [in] NTue if low GPU memory mode is used.
NGpuIndex gpuIndices | [in] Indices of used GPUs.
HNAsyncOperation * phAsyncOperation | [out] Pointer to NAsyncOperation.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillance.h

Module: NSurveillance Unit


NSurveillanceOptimizeModelsAsync Function

NSurveillanceOptimizeModelsAsync Function
NSurveillance.h

Optimizes all NSureveillance models by specified modalities (asynchronous operation).

C++
NResult N_API NSurveillanceOptimizeModelsAsync(HNSurveillance hSurveillance, NSurveillanceModalityType modalities, HNAsyncOperation * phAsyncOperation);
Collapse Expand Parameters
Parameters | Description
HNSurveillance hSurveillance | [in] Handle to NSurveillance.
NSurveillanceModalityType modalities | [in] Surveillance modalities to optimize.
HNAsyncOperation * phAsyncOperation | [out] Pointer to NAsyncOperation.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillance.h

Module: NSurveillance Unit


NSurveillanceRemoveAllTemplates Function

NSurveillanceRemoveAllTemplates Function
NSurveillance.h

Removed templates from internal Surveillance database.

C++
NResult N_API NSurveillanceRemoveAllTemplates(HNSurveillance hSurveillance);
Collapse Expand Parameters
Parameters | Description
HNSurveillance hSurveillance | [in] Handle to Surveillance object.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Also NSucceeded macro can be used to check if function succeeded.

Container

File: NSurveillance.h

Module: NSurveillance Unit


NSurveillanceRemoveEventCallbackEx Function

NSurveillanceRemoveEventCallbackEx Function
NSurveillance.h

Removes callback function from Surveillance framework.

C++
NResult N_API NSurveillanceRemoveEventCallbackEx(HNSurveillance hSurveillance, NSurveillanceCompositeEventCallback pCallback, NSurveillanceEventType eventType, void * pParam);
Collapse Expand Parameters
Parameters | Description
HNSurveillance hSurveillance | [in] Handle to Surveillance object to remove callback function.
NSurveillanceCompositeEventCallback pCallback | [in] Callback function to be removed. The type of the callback function is NSurveillanceEventCallback.
NSurveillanceEventType eventType | [in] Event Type for which to remove callback function.
void * pParam | [in] pParam that was supplied to the callback function.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Also NSucceeded macro can be used to check if function succeeded.

Collapse Expand Remarks

If supplied eventType parameter is nsetAny then every event with such callback and pParam combination will be removed from callback list for every event type.

Container

File: NSurveillance.h

Module: NSurveillance Unit


NSurveillanceRemoveEventEx Function

NSurveillanceRemoveEventEx Function
NSurveillance.h

Removes an event from Surveillance framework.

C++
NResult N_API NSurveillanceRemoveEventEx(HNSurveillance hSurveillance, NSurveillanceEventType eventType, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNSurveillance hSurveillance | [in] Handle to Surveillance object to remove callback function.
NSurveillanceEventType eventType | [in] Event type which to remove.
HNCallback hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillance.h

Module: NSurveillance Unit


NSurveillanceRemoveIsRunningChanged Function

NSurveillanceRemoveIsRunningChanged Function
NSurveillance.h

Removes user specified event for managing Surveillance changed events.

C++
NResult N_API NSurveillanceRemoveIsRunningChanged(HNSurveillance hSurveillance, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNSurveillance hSurveillance | [in] Handle to NSurveillance object.
HNCallback hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillance.h

Module: NSurveillance Unit


NSurveillanceRemoveIsRunningChangedCallback Function

NSurveillanceRemoveIsRunningChangedCallback Function
NSurveillance.h

Removes user specified callback for managing Surveillance changed events.

C++
NResult N_API NSurveillanceRemoveIsRunningChangedCallback(HNSurveillance hSurveillance, NObjectCallback pCallback, void * pParam);
Collapse Expand Parameters
Parameters | Description
HNSurveillance hSurveillance | [in] Handle to NSurveillance object.
NObjectCallback pCallback | [in] Callback function to remove. The type of the callback function is NObjectCallback.
void * pParam | [in] User data used by a callback function.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillance.h

Module: NSurveillance Unit


NSurveillanceRemoveSourceAt Function

NSurveillanceRemoveSourceAt Function
NSurveillance.h

Removes capturing source from Surveillance framework.

C++
NResult N_API NSurveillanceRemoveSourceAt(HNSurveillance hSurveillance, NInt index);
Collapse Expand Parameters
Parameters | Description
HNSurveillance hSurveillance | [in] Handle to Surveillance object.
NInt index | [in] Index of the capturing source to be removed.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Also NSucceeded macro can be used to check if function succeeded.

Collapse Expand Notes

Surveillance must be stopped prior calling this function.

Container

File: NSurveillance.h

Module: NSurveillance Unit


NSurveillanceRemoveSourceCollectionChanged Function

NSurveillanceRemoveSourceCollectionChanged Function
NSurveillance.h

Removes user specified event for managing source collection changed events.

C++
NResult N_API NSurveillanceRemoveSourceCollectionChanged(HNSurveillance hSurveillance, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNSurveillance hSurveillance | [in] Handle to NSurveillance object.
HNCallback hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillance.h

Module: NSurveillance Unit


NSurveillanceRemoveSourceCollectionChangedCallback Function

NSurveillanceRemoveSourceCollectionChangedCallback Function
NSurveillance.h

Removes user specified callback for managing source collection changed events.

C++
NResult N_API NSurveillanceRemoveSourceCollectionChangedCallback(HNSurveillance hSurveillance, N_COLLECTION_CHANGED_CALLBACK_ARG(HNSurveillanceSource, pCallback), void * pParam);
Collapse Expand Parameters
Parameters | Description
HNSurveillance hSurveillance | [in] Handle to NSurveillance object.
void * pParam | [in] User data used by a callback function.
pCallback | [in] Callback function to remove. The type of the callback function is NObjectCallback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillance.h

Module: NSurveillance Unit


NSurveillanceRemoveTemplateN Function

NSurveillanceRemoveTemplateN Function
NSurveillance.h

Removes a template from Surveillance internal database.

C++
NResult N_API NSurveillanceRemoveTemplateN(HNSurveillance hSurveillance, HNString hTemplateId);
Collapse Expand Parameters
Parameters | Description
HNSurveillance hSurveillance | [in] Handle to Surveillance object.
templateId | [in] Id of the template to be removed from internal database.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Also NSucceeded macro can be used to check if function succeeded.

Container

File: NSurveillance.h

Module: NSurveillance Unit


NSurveillanceStart Function

NSurveillanceStart Function
NSurveillance.h

Enables callbacks and starts Surveillance. After surveillance is no longer needed NSurveillanceStop should be called.

C++
NResult N_API NSurveillanceStart(HNSurveillance hSurveillance);
Collapse Expand Parameters
Parameters | Description
HNSurveillance hSurveillance | [in] Handle to Surveillance object.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Also NSucceeded macro can be used to check if function succeeded.

Container

File: NSurveillance.h

Module: NSurveillance Unit


NSurveillanceStartAsync Function

NSurveillanceStartAsync Function
NSurveillance.h

Enables callbacks and starts Surveillance (asynchronous operation). After surveillance is no longer needed NSurveillanceStop should be called.

C++
NResult N_API NSurveillanceStartAsync(HNSurveillance hSurveillance, HNAsyncOperation * phAsyncOperation);
Collapse Expand Parameters
Parameters | Description
HNSurveillance hSurveillance | [in] Handle to Surveillance object.
HNAsyncOperation * phAsyncOperation | [out] Pointer to NAsyncOperation.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillance.h

Module: NSurveillance Unit


NSurveillanceStartSource Function

NSurveillanceStartSource Function
NSurveillance.h

Starts specified surveillance source.

C++
NResult N_API NSurveillanceStartSource(HNSurveillance hSurveillance, HNSurveillanceSource hSource);
Collapse Expand Parameters
Parameters | Description
HNSurveillance hSurveillance | [in] Handle to Surveillance object.
HNSurveillanceSource hSource | [in] NSurveillanceSource object to start.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillance.h

Module: NSurveillance Unit


NSurveillanceStartSourceAsync Function

NSurveillanceStartSourceAsync Function
NSurveillance.h

Starts specified surveillance source (asynchronous operation).

C++
NResult N_API NSurveillanceStartSourceAsync(HNSurveillance hSurveillance, HNSurveillanceSource hSource, HNAsyncOperation * phAsyncOperation);
Collapse Expand Parameters
Parameters | Description
HNSurveillance hSurveillance | [in] Handle to Surveillance object.
HNSurveillanceSource hSource | [in] NSurveillanceSource object to start.
HNAsyncOperation * phAsyncOperation | [out] Pointer to NAsyncOperation object which can be used to wait for an actual result.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillance.h

Module: NSurveillance Unit


NSurveillanceStop Function

NSurveillanceStop Function
NSurveillance.h

Stops surveillance and disables callbacks.

C++
NResult N_API NSurveillanceStop(HNSurveillance hSurveillance);
Collapse Expand Parameters
Parameters | Description
HNSurveillance hSurveillance | [in] Handle to Surveillance object.
Collapse Expand Returns

If the function succeeds, the return value is N_OK. Also NSucceeded macro can be used to check if function succeeded.

Collapse Expand Remarks

Additional synchronization is needed if any of the set callbacks synchronously calls to the main thread. A deadlock can occur if NSurveilanceStop is called in the same time as callback.

Container

File: NSurveillance.h

Module: NSurveillance Unit


NSurveillanceStopAsync Function

NSurveillanceStopAsync Function
NSurveillance.h

Stops surveillance and all sources (asynchronous operation).

C++
NResult N_API NSurveillanceStopAsync(HNSurveillance hSurveillance, HNAsyncOperation * phAsyncOperation);
Collapse Expand Parameters
Parameters | Description
HNSurveillance hSurveillance | [in] Handle to NSurveillance object.
HNAsyncOperation * phAsyncOperation | [out] Pointer to NAsyncOperation object which can be used to wait for an actual result.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillance.h

Module: NSurveillance Unit


NSurveillanceStopSource Function

NSurveillanceStopSource Function
NSurveillance.h

Stops specified surveillance source.

C++
NResult N_API NSurveillanceStopSource(HNSurveillance hSurveillance, HNSurveillanceSource hSource);
Collapse Expand Parameters
Parameters | Description
HNSurveillance hSurveillance | [in] Handle to NSurveillance object.
HNSurveillanceSource hSource | [in] NSurveillanceSource object to stop.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillance.h

Module: NSurveillance Unit


NSurveillanceStopSourceAsync Function

NSurveillanceStopSourceAsync Function
NSurveillance.h

Stops specified surveillance source (asynchronous operation).

C++
NResult N_API NSurveillanceStopSourceAsync(HNSurveillance hSurveillance, HNSurveillanceSource hSource, HNAsyncOperation * phAsyncOperation);
Collapse Expand Parameters
Parameters | Description
HNSurveillance hSurveillance | [in] Handle to NSurveillance object.
HNSurveillanceSource hSource | [in] NSurveillanceSource object to stop.
HNAsyncOperation * phAsyncOperation | [out] Pointer to NAsyncOperation object which can be used to wait for an actual result.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillance.h

Module: NSurveillance Unit


NsedGetAttributes Function

NsedGetAttributes Function
NSurveillanceEventDetails.h

Gets face attributes from specified surveillance event details.

C++
NResult N_API NsedGetAttributes(HNSurveillanceEventDetails hDetails, HNLAttributes * phValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceEventDetails hDetails | [in] Handle to NSurveillanceEventDetails.
HNLAttributes * phValue | [out] Pointer to the NLAttributes object handle.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceEventDetails.h

Module: NSurveillance Unit


NsedGetAttributesContainsDetails Function

NsedGetAttributesContainsDetails Function
NSurveillanceEventDetails.h

Checks whether specified surveillance event contains extraction details.

C++
NResult N_API NsedGetAttributesContainsDetails(HNSurveillanceEventDetails hDetails, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceEventDetails hDetails | [in] Handle to NSurveillanceEventDetails.
NBool * pValue | [out] If NTrue, specified event contains extraction details (object was extracted); if NFalse, object was not extracted yet and extraction details are not available (but still object tracking rectangle can be drawn).
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceEventDetails.h

Module: NSurveillance Unit


NsedGetBestDetails Function

NsedGetBestDetails Function
NSurveillanceEventDetails.h

Gets an event containing best details for a tracked subject.

C++
NResult N_API NsedGetBestDetails(HNSurveillanceEventDetails hDetails, HNSurveillanceEventDetails * phValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceEventDetails hDetails | [in] Handle to NSurveillanceEventDetails.
HNSurveillanceEventDetails * phValue | [out] Pointer to NSurveillanceEventDetails.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceEventDetails.h

Module: NSurveillance Unit


NsedGetBestMatchResult Function

NsedGetBestMatchResult Function
NSurveillanceEventDetails.h

Gets best face match results from the specified frame.

C++
NResult N_API NsedGetBestMatchResult(HNSurveillanceEventDetails hDetails, NInt index, HNsedMatchResult * phValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceEventDetails hDetails | [in] Handle to NSurveillanceEventDetails.
NInt index | [in] Index of the frame.
HNsedMatchResult * phValue | [out] Pointer to the HNsedMatchResult.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceEventDetails.h

Module: NSurveillance Unit


NsedGetBestMatchResultCount Function

NsedGetBestMatchResultCount Function
NSurveillanceEventDetails.h

Gets best face match results count from the specified frame.

C++
NResult N_API NsedGetBestMatchResultCount(HNSurveillanceEventDetails hDetails, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceEventDetails hDetails | [in] Handle to NSurveillanceEventDetails.
NInt * pValue | [out] Match result count.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceEventDetails.h

Module: NSurveillance Unit


NsedGetBestMatchResults Function

NsedGetBestMatchResults Function
NSurveillanceEventDetails.h

Gets best face match results from the specified frame.

C++
NResult N_API NsedGetBestMatchResults(HNSurveillanceEventDetails hDetails, HNsedMatchResult * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceEventDetails hDetails | [in] Handle to NSurveillanceEventDetails.
HNsedMatchResult * * parhValues | [out] Pointer to the array of match results.
NInt * pValueCount | [out] parhValues items count.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceEventDetails.h

Module: NSurveillance Unit


NsedGetClothingDetails Function

NsedGetClothingDetails Function
NSurveillanceEventDetails.h

Gets ClothingDetails object containing subject's clothing details and gender.

C++
NResult N_API NsedGetClothingDetails(HNSurveillanceEventDetails hDetails, HNClothingDetails * phValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceEventDetails hDetails | [in] Handle to NSurveillanceEventDetails.
HNClothingDetails * phValue | [out] Pointer to NClothingDetails.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceEventDetails.h

Module: NSurveillance Unit


NsedGetCurrentMatchResult Function

NsedGetCurrentMatchResult Function
NSurveillanceEventDetails.h

Gets match result by an index.

C++
NResult N_API NsedGetCurrentMatchResult(HNSurveillanceEventDetails hDetails, NInt index, HNsedMatchResult * phValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceEventDetails hDetails | [in] Handle to NSurveillanceEventDetails.
NInt index | [in] Index of a match to retrieve its value.
HNsedMatchResult * phValue | [out] Pointer to NsedMatchResult.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceEventDetails.h

Module: NSurveillance Unit


NsedGetCurrentMatchResultCount Function

NsedGetCurrentMatchResultCount Function
NSurveillanceEventDetails.h

Gets match results count.

C++
NResult N_API NsedGetCurrentMatchResultCount(HNSurveillanceEventDetails hDetails, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceEventDetails hDetails | [in] Handle to NSurveillanceEventDetails.
NInt * pValue | [out] Match results count.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceEventDetails.h

Module: NSurveillance Unit


NsedGetCurrentMatchResults Function

NsedGetCurrentMatchResults Function
NSurveillanceEventDetails.h

Gets all current match results.

C++
NResult N_API NsedGetCurrentMatchResults(HNSurveillanceEventDetails hDetails, HNsedMatchResult * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceEventDetails hDetails | [in] Handle to NSurveillanceEventDetails.
HNsedMatchResult * * parhValues | [out] Pointer to array containing all match results.
NInt * pValueCount | [out] Array items count.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceEventDetails.h

Module: NSurveillance Unit


NsedGetDetectedFaces Function

NsedGetDetectedFaces Function
NSurveillanceEventDetails.h

Gets the list of detected faces attributes.

C++
NResult N_API NsedGetDetectedFaces(HNSurveillanceEventDetails hDetails, HNLAttributes * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceEventDetails hDetails | [in] Handle to NSurveillanceEventDetails.
HNLAttributes * * parhValues | [out] Pointer to the array of face attributes.
NInt * pValueCount | [out] parhValues items count.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceEventDetails.h

Module: NSurveillance Unit


NsedGetDetectionConfidence Function

NsedGetDetectionConfidence Function
NSurveillanceEventDetails.h

Gets detection confidence value (NFloat type).

C++
NResult N_API NsedGetDetectionConfidence(HNSurveillanceEventDetails hDetails, NFloat * pValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceEventDetails hDetails | [in] Handle to NSurveillanceEventDetails.
NFloat * pValue | [out] Detection confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceEventDetails.h

Module: NSurveillance Unit


NsedGetError Function

NsedGetError Function
NSurveillanceEventDetails.h

Returns the most recent error for the specified surveillance event.

C++
NResult N_API NsedGetError(HNSurveillanceEventDetails hDetails, HNError * phValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceEventDetails hDetails | [in] Handle to NSurveillanceEventDetails.
HNError * phValue | [out] Pointer to the error thrown by the specified surveillance event.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceEventDetails.h

Module: NSurveillance Unit


NsedGetFace Function

NsedGetFace Function
NSurveillanceEventDetails.h

Gets face of the specified event.

C++
NResult N_API NsedGetFace(HNSurveillanceEventDetails hDetails, HNFace * phValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceEventDetails hDetails | [in] Handle to the NSurveillanceEventDetails object.
HNFace * phValue | [out] Handle to the NFace object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceEventDetails.h

Module: NSurveillance Unit


NsedGetFaceConfidence Function

NsedGetFaceConfidence Function
NSurveillanceEventDetails.h

Retrieves face confidence value of the specified event. Indicates whether the event object is a face.

C++
NResult N_API NsedGetFaceConfidence(HNSurveillanceEventDetails hDetails, NByte * pValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceEventDetails hDetails | [in] Handle to the NSurveillanceEventDetails object.
NByte * pValue | [out] Pointer to the face confidence value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceEventDetails.h

Module: NSurveillance Unit


NsedGetFaceRectangle Function

NsedGetFaceRectangle Function
NSurveillanceEventDetails.h

Gets bounding box rectangle of a detected subject's face.

C++
NResult N_API NsedGetFaceRectangle(HNSurveillanceEventDetails hDetails, struct NRect_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceEventDetails hDetails | [in] Handle to the NSurveillanceEventDetails object.
struct NRect_ * pValue | [out] Pointer to NRect which receives bounding box rectangle of a detected subject's face.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceEventDetails.h

Module: NSurveillance Unit


NsedGetFrameIndex Function

NsedGetFrameIndex Function
NSurveillanceEventDetails.h

Gets frame index (the number of captured images prior to this event).

C++
NResult N_API NsedGetFrameIndex(HNSurveillanceEventDetails hDetails, NULong * pValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceEventDetails hDetails | [in] Handle to NSurveillanceEventDetails.
NULong * pValue | [out] Frame index.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceEventDetails.h

Module: NSurveillance Unit


NsedGetLicensePlateDetails Function

NsedGetLicensePlateDetails Function
NSurveillanceEventDetails.h

Gets vehicle's license plate details.

C++
NResult N_API NsedGetLicensePlateDetails(HNSurveillanceEventDetails hDetails, HNLicensePlateDetails * phValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceEventDetails hDetails | [in] Handle to NSurveillanceEventDetails.
HNLicensePlateDetails * phValue | [out] Pointer to vehicle's license plate details.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceEventDetails.h

Module: NSurveillance Unit


NsedGetMergedSubject Function

NsedGetMergedSubject Function
NSurveillanceEventDetails.h

Gets a subject that was merged with current subject. Only applicable during SubjectMerged event.

C++
NResult N_API NsedGetMergedSubject(HNSurveillanceEventDetails hDetails, HNSurveillanceEventDetails * phValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceEventDetails hDetails | [in] Handle to NSurveillanceEventDetails.
HNSurveillanceEventDetails * phValue | [out] Pointer to NSurveillanceEventDetails containing merged subject.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceEventDetails.h

Module: NSurveillance Unit


NsedGetModalityType Function

NsedGetModalityType Function
NSurveillanceEventDetails.h

Gets NSurveillanceModalityType object containing one of surveillance modality values (None, Faces, Vehicles and Humans or License Plate Recognition).

C++
NResult N_API NsedGetModalityType(HNSurveillanceEventDetails hDetails, NSurveillanceModalityType * pValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceEventDetails hDetails | [in] Handle to NSurveillanceEventDetails.
NSurveillanceModalityType * pValue | [out] Surveillance modality type value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceEventDetails.h

Module: NSurveillance Unit


NsedGetObjectColor Function

NsedGetObjectColor Function
NSurveillanceEventDetails.h

Gets color of a detected surveillance object.

C++
NResult N_API NsedGetObjectColor(HNSurveillanceEventDetails hDetails, struct NSurveillanceObjectColorDetails_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceEventDetails hDetails | [in] Handle to NSurveillanceEventDetails.
struct NSurveillanceObjectColorDetails_ * pValue | [out] Pointer to NSurveillanceObjectColorDetails object containing color and color confidence values.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceEventDetails.h

Module: NSurveillance Unit


NsedGetObjectDirection Function

NsedGetObjectDirection Function
NSurveillanceEventDetails.h

Gets NSurveillanceObjectDirection object.

C++
NResult N_API NsedGetObjectDirection(HNSurveillanceEventDetails hDetails, struct NSurveillanceObjectDirectionDetails_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceEventDetails hDetails | [in] Handle to NSurveillanceEventDetails.
struct NSurveillanceObjectDirectionDetails_ * pValue | [out] Pointer to NSurveillanceObjectDirectionDetails.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceEventDetails.h

Module: NSurveillance Unit


NsedGetObjectType Function

NsedGetObjectType Function
NSurveillanceEventDetails.h

Gets type of a detected surveillance object.

C++
NResult N_API NsedGetObjectType(HNSurveillanceEventDetails hDetails, struct NSurveillanceObjectTypeDetails_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceEventDetails hDetails | [in] Handle to NSurveillanceEventDetails.
struct NSurveillanceObjectTypeDetails_ * pValue | [out] Pointer to NSurveillanceObjectTypeDetails containing type of a detected surveillance object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceEventDetails.h

Module: NSurveillance Unit


NsedGetOriginalImageEx Function

NsedGetOriginalImageEx Function
NSurveillanceEventDetails.h

Retrieves the originally captured image.

C++
NResult N_API NsedGetOriginalImageEx(HNSurveillanceEventDetails hDetails, HNImage * phValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceEventDetails hDetails | [in] Handle to NSurveillanceEventDetails.
HNImage * phValue | [out] Pointer to the originally captured image.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceEventDetails.h

Module: NSurveillance Unit


NsedGetRectangle Function

NsedGetRectangle Function
NSurveillanceEventDetails.h

Retrieves the rectangle selection of the original image.

C++
NResult N_API NsedGetRectangle(HNSurveillanceEventDetails hDetails, struct NRect_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceEventDetails hDetails | [in] Handle to the NSurveillanceEventDetails object.
struct NRect_ * pValue | [out] Pointer to the NRect_ structure.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceEventDetails.h

Module: NSurveillance Unit


NsedGetSource Function

NsedGetSource Function
NSurveillanceEventDetails.h

Gets Surveillance source.

C++
NResult N_API NsedGetSource(HNSurveillanceEventDetails hDetails, HNSurveillanceSource * phValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceEventDetails hDetails | [in] Handle to the NSurveillanceEventDetails object.
HNSurveillanceSource * phValue | [out] Pointer to NSurveillanceSource object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceEventDetails.h

Module: NSurveillance Unit


NsedGetSplitFromSubject Function

NsedGetSplitFromSubject Function
NSurveillanceEventDetails.h

Get a subject from which the current subject was split. Only applicable during SubjectSplit event.

C++
NResult N_API NsedGetSplitFromSubject(HNSurveillanceEventDetails hDetails, HNSurveillanceEventDetails * phValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceEventDetails hDetails | [in] Handle to the NSurveillanceEventDetails object.
HNSurveillanceEventDetails * phValue | [out] Pointer to NSurveillanceEventDetails containing a subject from which the current subject was split.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceEventDetails.h

Module: NSurveillance Unit


NsedGetSubjectTemplate Function

NsedGetSubjectTemplate Function
NSurveillanceEventDetails.h

Gets generalized Subject template.

C++
NResult N_API NsedGetSubjectTemplate(HNSurveillanceEventDetails hDetails, HNLTemplate * phValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceEventDetails hDetails | [in] Handle to NSurveillanceEventDetails.
phTemplate | [out] Face template.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

Subject template is a compressed generalized template of all extracted faces during subject tracking whose Id matches that of the best matched Id. If there is no best match, then it includes all templates into generalization.

The template is updated every time a new face is determined to belong to the tracked subject.

Collapse Expand Notes

Returned handle must be freed in order to avoid memory leaks.

Container

File: NSurveillanceEventDetails.h

Module: NSurveillance Unit


NsedGetSubjectType Function

NsedGetSubjectType Function
NSurveillanceEventDetails.h

Gets NSurveillanceModalityType object containing one of surveillance modality values (None, Faces, Vehicles and Humans or License Plate Recognition).

C++
NResult N_API NsedGetSubjectType(HNSurveillanceEventDetails hDetails, NSurveillanceModalityType * pValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceEventDetails hDetails | [in] Handle to the NSurveillanceEventDetails object.
NSurveillanceModalityType * pValue | [out] Pointer to NSurveillanceModalityType object containing one of surveillance modality values.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceEventDetails.h

Module: NSurveillance Unit


NsedGetTemplateEx Function

NsedGetTemplateEx Function
NSurveillanceEventDetails.h

Retrieves the extracted face template.

C++
NResult N_API NsedGetTemplateEx(HNSurveillanceEventDetails hDetails, HNLTemplate * phValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceEventDetails hDetails | [in] Handle to the NSurveillanceEventDetails object.
HNLTemplate * phValue | [out] Pointer to the face template.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceEventDetails.h

Module: NSurveillance Unit


NsedGetTimeStamp Function

NsedGetTimeStamp Function
NSurveillanceEventDetails.h

Gets the date and time of the captured image.

C++
NResult N_API NsedGetTimeStamp(HNSurveillanceEventDetails hDetails, NDateTime_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceEventDetails hDetails | [in] Handle to NSurveillanceEventDetails.
NDateTime_ * pValue | [out] Timestamp of captured image.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceEventDetails.h

Module: NSurveillance Unit


NsedGetTraceIndex Function

NsedGetTraceIndex Function
NSurveillanceEventDetails.h

Gets an index of the current subject being tracked. The index is zero-based and represents unique id of subject being tracked at the current moment. After subject disappears this index becomes invalid.

C++
NResult N_API NsedGetTraceIndex(HNSurveillanceEventDetails hDetails, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceEventDetails hDetails | [in] Handle to NSurveillanceEventDetails.
NInt * pValue | [out] Index of subject being traced.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceEventDetails.h

Module: NSurveillance Unit


NsedGetVehicleDetails Function

NsedGetVehicleDetails Function
NSurveillanceEventDetails.h

Gets vehicle details.

C++
NResult N_API NsedGetVehicleDetails(HNSurveillanceEventDetails hDetails, HNVehicleDetails * phValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceEventDetails hDetails | [in] Handle to NSurveillanceEventDetails.
HNVehicleDetails * phValue | [out] Pointer to NVehicleDetails object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceEventDetails.h

Module: NSurveillance Unit


NsedMatchResultCreate Function

NsedMatchResultCreate Function
NsedMatchResult.h

Creates a new instance of NsedMatchResult.

C++
NResult N_API NsedMatchResultCreate(HNString hValue, NInt score, HNsedMatchResult * phResult);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] Handle to NSurveillanceEventDetails.
NInt score | [in] Matching score.
HNsedMatchResult * phResult | [out] Pointer to the created NsedMatchResult object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NsedMatchResult.h

Module: NSurveillance Unit


NsedMatchResultCreateEx Function

NsedMatchResultCreateEx Function
NsedMatchResult.h

Creates a new instance of NsedMatchResult.

C++
NResult N_API NsedMatchResultCreateEx(HNString hValue, NInt score, HNMatchingDetails hMatchingDetails, HNsedMatchResult * phResult);
Collapse Expand Parameters
Parameters | Description
HNString hValue | [in] Handle to NSurveillanceEventDetails.
NInt score | [in] Matching score.
HNMatchingDetails hMatchingDetails | [in] Matching details to add.
HNsedMatchResult * phResult | [out] Pointer to the created NsedMatchResult object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NsedMatchResult.h

Module: NSurveillance Unit


NsedMatchResultGetId Function

NsedMatchResultGetId Function
NsedMatchResult.h

Gets the Id (string) of matched object.

C++
NResult N_API NsedMatchResultGetId(HNsedMatchResult hResult, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNsedMatchResult hResult | [in] Handle to NsedMatchResult.
HNString * phValue | [out] Id of a matched object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NsedMatchResult.h

Module: NSurveillance Unit


NsedMatchResultGetMatchingDetails Function

NsedMatchResultGetMatchingDetails Function
NsedMatchResult.h

Gets matching details from NsedMatchResult.

C++
NResult N_API NsedMatchResultGetMatchingDetails(HNsedMatchResult hResult, HNMatchingDetails * phValue);
Collapse Expand Parameters
Parameters | Description
HNsedMatchResult hResult | [in] Handle to NsedMatchResult.
HNMatchingDetails * phValue | [out] Pointer to NMatchingDetails containing matching details.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NsedMatchResult.h

Module: NSurveillance Unit


NsedMatchResultGetScore Function

NsedMatchResultGetScore Function
NsedMatchResult.h

Gets surveillance matching score.

C++
NResult N_API NsedMatchResultGetScore(HNsedMatchResult hResult, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNsedMatchResult hResult | [in] Handle to NsedMatchResult.
NInt * pValue | [out] Matching score.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NsedMatchResult.h

Module: NSurveillance Unit


NSurveillanceObjectColorDetails_ Structure

NSurveillanceObjectColorDetails_ Structure
NSurveillanceEventDetails.h

Enumerates object color and color confidence values.

C++
struct NSurveillanceObjectColorDetails_ {
  NSurveillanceObjectColor Color;
  NFloat RedColorConfidence;
  NFloat OrangeColorConfidence;
  NFloat YellowColorConfidence;
  NFloat GreenColorConfidence;
  NFloat BlueColorConfidence;
  NFloat SilverColorConfidence;
  NFloat WhiteColorConfidence;
  NFloat BlackColorConfidence;
  NFloat BrownColorConfidence;
  NFloat GrayColorConfidence;
};
Collapse Expand Members
Members | Description
NSurveillanceObjectColor Color; | Represents object's color.
NFloat RedColorConfidence; | Red color confidence value.
NFloat OrangeColorConfidence; | Orange color confidence value.
NFloat YellowColorConfidence; | Yellow color confidence value.
NFloat GreenColorConfidence; | Green color confidence value.
NFloat BlueColorConfidence; | Blue color confidence value.
NFloat SilverColorConfidence; | Silver color confidence value.
NFloat WhiteColorConfidence; | White color confidence value.
NFloat BlackColorConfidence; | Black color confidence value.
NFloat BrownColorConfidence; | Brown color confidence value.
NFloat GrayColorConfidence; | Gray color confidence value.
Container

File: NSurveillanceEventDetails.h

Module: NSurveillance Unit


NSurveillanceObjectDirectionDetails_ Structure

NSurveillanceObjectDirectionDetails_ Structure
NSurveillanceEventDetails.h

Represents detected or tracked object direction confidence values.

C++
struct NSurveillanceObjectDirectionDetails_ {
  NSurveillanceObjectDirection Direction;
  NFloat NorthConfidence;
  NFloat NorthEastConfidence;
  NFloat EastConfidence;
  NFloat SouthEastConfidence;
  NFloat SouthConfidence;
  NFloat SouthWestConfidence;
  NFloat WestConfidence;
  NFloat NorthWestConfidence;
};
Collapse Expand Members
Members | Description
NSurveillanceObjectDirection Direction; | NSurveillanceObjectDirection object representing object moving direction.
NFloat NorthConfidence; | Confidence that object was/is moving north.
NFloat NorthEastConfidence; | Confidence that object was/is moving north east.
NFloat EastConfidence; | Confidence that object was/is moving east.
NFloat SouthEastConfidence; | Confidence that object was/is moving south east.
NFloat SouthConfidence; | Confidence that object was/is moving south.
NFloat SouthWestConfidence; | Confidence that object was/is moving south west.
NFloat WestConfidence; | Confidence that object was/is moving west.
NFloat NorthWestConfidence; | Confidence that object was/is moving north west.
Container

File: NSurveillanceEventDetails.h

Module: NSurveillance Unit


NSurveillanceObjectTypeDetails_ Structure

NSurveillanceObjectTypeDetails_ Structure
NSurveillanceEventDetails.h

Enumerates surveillance object type confidence values.

C++
struct NSurveillanceObjectTypeDetails_ {
  NSurveillanceObjectType Type;
  NFloat CarConfidence;
  NFloat PersonConfidence;
  NFloat BusConfidence;
  NFloat TruckConfidence;
  NFloat BikeConfidence;
};
Collapse Expand Members
Members | Description
NSurveillanceObjectType Type; | Represents surveillance object type.
NFloat CarConfidence; | Car confidence value.
NFloat PersonConfidence; | Person confidence value.
NFloat BusConfidence; | Bus confidence value.
NFloat TruckConfidence; | Truck confidence value.
NFloat BikeConfidence; | Bike confidence value.
Container

File: NSurveillanceEventDetails.h

Module: NSurveillance Unit


NDetectorScaleCount Enumeration

NDetectorScaleCount Enumeration
NSurveillance.h

Enumerates detector scale count. Bigger values improves quality, but requires more processing power.

C++
typedef enum NDetectorScaleCount_ {
} NDetectorScaleCount;
Container

File: NSurveillance.h

Module: NSurveillance Unit


NGpuIndex Enumeration

NGpuIndex Enumeration
NSurveillance.h

Enumerates GPU units by index.

C++
typedef enum NGpuIndex_ {
  ngiAll = -1,
  ngiNone = 0,
  ngiGpu0 = 1,
  ngiGpu1 = 2,
  ngiGpu2 = 4,
  ngiGpu3 = 8,
  ngiGpu4 = 16,
  ngiGpu5 = 32,
  ngiGpu6 = 64,
  ngiGpu7 = 128
} NGpuIndex;
Collapse Expand Members
Members | Description
ngiAll = -1 | All GPU units.
ngiNone = 0 | No GPU index was specified.
ngiGpu0 = 1 | GPU index 0.
ngiGpu1 = 2 | GPU index 1.
ngiGpu2 = 4 | GPU index 2.
ngiGpu3 = 8 | GPU index 3.
ngiGpu4 = 16 | GPU index 4.
ngiGpu5 = 32 | GPU index 5.
ngiGpu6 = 64 | GPU index 6.
ngiGpu7 = 128 | GPU index 7.
Container

File: NSurveillance.h

Module: NSurveillance Unit


NSurveillanceObjectColor Enumeration

NSurveillanceObjectColor Enumeration
NSurveillanceEventDetails.h

Enumerates tracked object color values.

C++
typedef enum NSurveillanceObjectColor_ {
  nsocAny = -1,
  nsocNone = 0,
  nsocRed = 1,
  nsocOrange = 2,
  nsocYellow = 4,
  nsocGreen = 8,
  nsocBlue = 16,
  nsocSilver = 32,
  nsocWhite = 64,
  nsocBlack = 128,
  nsocBrown = 256,
  nsocGray = 512
} NSurveillanceObjectColor;
Collapse Expand Members
Members | Description
nsocAny = -1 | Any color.
nsocNone = 0 | None of defined colors.
nsocRed = 1 | Red.
nsocOrange = 2 | Orange.
nsocYellow = 4 | Yellow.
nsocGreen = 8 | Green.
nsocBlue = 16 | Blue
nsocSilver = 32 | Silver.
nsocWhite = 64 | White.
nsocBlack = 128 | Black.
nsocBrown = 256 | Brown.
nsocGray = 512 | Gray.
Container

File: NSurveillanceEventDetails.h

Module: NSurveillance Unit


NSurveillanceObjectDirection Enumeration

NSurveillanceObjectDirection Enumeration
NSurveillanceEventDetails.h

Represents detected or tracked object direction values.

C++
typedef enum NSurveillanceObjectDirection_ {
  nsodAny = -1,
  nsodNone = 0,
  nsodNorth = 1,
  nsodNorthEast = 2,
  nsodEast = 4,
  nsodSouthEast = 8,
  nsodSouth = 16,
  nsodSouthWest = 32,
  nsodWest = 64,
  nsodNorthWest = 128
} NSurveillanceObjectDirection;
Collapse Expand Members
Members | Description
nsodAny = -1 | Any direction.
nsodNone = 0 | None of defined direction values.
nsodNorth = 1 | Object was/is moving north.
nsodNorthEast = 2 | Object was/is moving north east.
nsodEast = 4 | Object was/is moving east.
nsodSouthEast = 8 | Object was/is moving south east.
nsodSouth = 16 | Object was/is moving south.
nsodSouthWest = 32 | Object was/is moving south west.
nsodWest = 64 | Object was/is moving west.
nsodNorthWest = 128 | Object was/is moving north west.
Container

File: NSurveillanceEventDetails.h

Module: NSurveillance Unit


NSurveillanceObjectType Enumeration

NSurveillanceObjectType Enumeration
NSurveillanceEventDetails.h

Enumerates surveillance objects.

C++
typedef enum NSurveillanceObjectType_ {
  nsotAny = -1,
  nsotNone = 0,
  nsotCar = 1,
  nsotPerson = 2,
  nsotBus = 4,
  nsotTruck = 8,
  nsotBike = 16
} NSurveillanceObjectType;
Collapse Expand Members
Members | Description
nsotAny = -1 | Any object.
nsotNone = 0 | None of these defined objects.
nsotCar = 1 | Object is a car.
nsotPerson = 2 | Object is a person.
nsotBus = 4 | Object is a bus.
nsotTruck = 8 | Object is a truck.
nsotBike = 16 | Object is a bike.
Container

File: NSurveillanceEventDetails.h

Module: NSurveillance Unit


NSurveillanceEventType Enumeration

NSurveillanceEventType Enumeration
NSurveillance.h

Enumeration type for different Surveillance events. Different information is available inside callback function being called depending on the event type. Events are asynchronous, so no assumption on the order of events fired or callbacks called should be made. It is possible to set several callback functions for a single event. Data available during event should be retrieved using Nsed* functions. The table below explains what data is available during different events.

 | nsetImageCaptured | nsetFacesDetected | nsetSubjectAppeared | nsetSubjectTrack | nsetSubjectDisappeared
NsedGetOriginalImage | + | + | + | + |
NsedGetGrayscaleImage | + | + | + | + |
NsedGetFrameIndex | + | + | + | + |
NsedGetTimeStamp | + | + | + | + |
NsedGetFaces |  | + |  |  |
NsedGetDetectionDetails |  |  | +* | +* |
NsedGetTemplate |  |  | +* | +* |
NsedGetTraceIndex |  |  | + | + | +
NsedGetSubjectTemplate |  |  | + | + | +
NsedGetBestMatchCount |  |  | + | + | +
NsedGetBestMatch |  |  | + | + | +
NsedGetBestMatchesEx |  |  | + | + | +

* - This data is available for the latest processing image that the event corresponds to.

Minimal thread count should be N*3 + 2 where N is running cameras count.

C++
typedef enum NSurveillanceEventType_ {
  nsetImageCaptured = 1,
  nsetFacesDetected = 2,
  nsetSubjectAppeared = 3,
  nsetSubjectTrack = 4,
  nsetSubjectDisappeared = 5,
  nsetSubjectMerged = 12,
  nsetSubjectSplit = 13,
  nsetAny = -1
} NSurveillanceEventType;
Collapse Expand Members
Members | Description
nsetImageCaptured = 1 |
nsetFacesDetected = 2 |
nsetSubjectAppeared = 3 |
nsetSubjectTrack = 4 |
nsetSubjectDisappeared = 5 |
nsetSubjectMerged = 12 | Indicates that a subject was merged with another subject.
nsetSubjectSplit = 13 | Indicates that a subject was split into two subjects.
nsetAny = -1 |
Container

File: NSurveillance.h

Module: NSurveillance Unit


NSurveillanceEventDetails.h

NSurveillanceEventDetails.h
Enumerations Functions Legend Structures

A header file containing containing EventDetails functions.

Collapse Expand Enumerations
Name | Description
NSurveillanceObjectColor_ | Enumerates tracked object color values.
NSurveillanceObjectDirection_ | Represents detected or tracked object direction values.
NSurveillanceObjectType_ | Enumerates surveillance objects.
NSurveillanceObjectColor | Enumerates tracked object color values.
NSurveillanceObjectDirection | Represents detected or tracked object direction values.
NSurveillanceObjectType | Enumerates surveillance objects.
Collapse Expand Functions
Name | Description
NsedGetAttributes | Gets face attributes from specified surveillance event details.
NsedGetAttributesContainsDetails | Checks whether specified surveillance event contains extraction details.
NsedGetBestDetails | Gets an event containing best details for a tracked subject.
NsedGetBestMatchResult | Gets best face match results from the specified frame.
NsedGetBestMatchResultCount | Gets best face match results count from the specified frame.
NsedGetBestMatchResults | Gets best face match results from the specified frame.
NsedGetClothingDetails | Gets ClothingDetails object containing subject's clothing details and gender.
NsedGetCurrentMatchResult | Gets match result by an index.
NsedGetCurrentMatchResultCount | Gets match results count.
NsedGetCurrentMatchResults | Gets all current match results.
NsedGetDetectedFaces | Gets the list of detected faces attributes.
NsedGetDetectionConfidence | Gets detection confidence value (NFloat type).
NsedGetError | Returns the most recent error for the specified surveillance event.
NsedGetFace | Gets face of the specified event.
NsedGetFaceConfidence | Retrieves face confidence value of the specified event. Indicates whether the event object is a face.
NsedGetFaceRectangle | Gets bounding box rectangle of a detected subject's face.
NsedGetFrameIndex | Gets frame index (the number of captured images prior to this event).
NsedGetLicensePlateDetails | Gets vehicle's license plate details.
NsedGetMergedSubject | Gets a subject that was merged with current subject. Only applicable during SubjectMerged event.
NsedGetModalityType | ... more
NsedGetObjectColor | Gets color of a detected surveillance object.
NsedGetObjectDirection | Gets NSurveillanceObjectDirection object.
NsedGetObjectType | Gets type of a detected surveillance object.
NsedGetOriginalImageEx | Retrieves the originally captured image.
NsedGetRectangle | Retrieves the rectangle selection of the original image.
NsedGetSource | Gets Surveillance source.
NsedGetSplitFromSubject | ... more
NsedGetSubjectTemplate | Gets generalized Subject template.
NsedGetSubjectType | ... more
NsedGetTemplateEx | Retrieves the extracted face template.
NsedGetTimeStamp | Gets the date and time of the captured image.
NsedGetTraceIndex | Gets an index of the current subject being tracked. The index is zero-based and represents unique id of subject being tracked at the current moment. After subject disappears this index becomes invalid.
NsedGetVehicleDetails | Gets vehicle details.
Collapse Expand Structures
Name | Description
NSurveillanceObjectColorDetails_ | Enumerates object color and color confidence values.
NSurveillanceObjectDirectionDetails_ | Represents detected or tracked object direction confidence values.
NSurveillanceObjectTypeDetails_ | Enumerates surveillance object type confidence values.


NsedMatchResult.h

NsedMatchResult.h
Functions Legend

A header file containing containing functions for surveillance matching results.

Collapse Expand Functions
Name | Description
NsedMatchResultCreate | Creates a new instance of NsedMatchResult.
NsedMatchResultCreateEx | Creates a new instance of NsedMatchResult.
NsedMatchResultGetId | Gets the Id (string) of matched object.
NsedMatchResultGetMatchingDetails | Gets matching details from NsedMatchResult.
NsedMatchResultGetScore | Gets surveillance matching score.


NSurveillance.h

NSurveillance.h
Enumerations Functions Legend

Main NSurveillance library C header file containing function declaration and event type declarations.

Collapse Expand Enumerations
Name | Description
NDetectorScaleCount_ | Enumerates detector scale count. Bigger values improves quality, but requires more processing power.
NGpuIndex_ | Enumerates GPU units by index.
NSurveillanceEventType_ | ... more
NDetectorScaleCount | Enumerates detector scale count. Bigger values improves quality, but requires more processing power.
NGpuIndex | Enumerates GPU units by index.
NSurveillanceEventType | ... more
Collapse Expand Functions
Name | Description
NSurveillanceAddEventCallbackEx | ... more
NSurveillanceAddEventEx | Adds an event to Surveillance framework.
NSurveillanceAddIsRunningChanged | Adds user specified event for managing Surveillance changed events.
NSurveillanceAddIsRunningChangedCallback | Adds user specified callback for managing Surveillance changed events.
NSurveillanceAddSource | Adds capturing source to the Surveillance framework. The capturing source must not be capturing or being already in use by other library.
NSurveillanceAddSourceCollectionChanged | Adds user specified event for managing source collection changed events.
NSurveillanceAddSourceCollectionChangedCallback | Adds user specified callback for managing source collection events.
NSurveillanceAddTemplate | ... more
NSurveillanceClearSources | ... more
NSurveillanceCreate | Creates NSurveillance object.
NSurveillanceGetDeviceManager | Gets NDeviceManager associated with specified NSurveillance handle.
NSurveillanceGetSource | Retrieves a handle for previously added capturing source.
NSurveillanceGetSourceCount | ... more
NSurveillanceGetSources | Retrieves the surveillance sources of the specified NSurveillance object.
NSurveillanceGetTemplateIdsN | ... more
NSurveillanceIsRunning | Checks if NSurveillance object is running.
NSurveillanceOptimizeAllModelsAsync | Optimizes specified NSureveillance models by specified modalities (asynchronous operation).
NSurveillanceOptimizeModelsAsync | Optimizes all NSureveillance models by specified modalities (asynchronous operation).
NSurveillanceRemoveAllTemplates | Removed templates from internal Surveillance database.
NSurveillanceRemoveEventCallbackEx | ... more
NSurveillanceRemoveEventEx | Removes an event from Surveillance framework.
NSurveillanceRemoveIsRunningChanged | Removes user specified event for managing Surveillance changed events.
NSurveillanceRemoveIsRunningChangedCallback | Removes user specified callback for managing Surveillance changed events.
NSurveillanceRemoveSourceAt | ... more
NSurveillanceRemoveSourceCollectionChanged | Removes user specified event for managing source collection changed events.
NSurveillanceRemoveSourceCollectionChangedCallback | Removes user specified callback for managing source collection changed events.
NSurveillanceRemoveTemplateN | Removes a template from Surveillance internal database.
NSurveillanceStart | ... more
NSurveillanceStartAsync | Enables callbacks and starts Surveillance (asynchronous operation). After surveillance is no longer needed NSurveillanceStop should be called.
NSurveillanceStartSource | Starts specified surveillance source.
NSurveillanceStartSourceAsync | Starts specified surveillance source (asynchronous operation).
NSurveillanceStop | ... more
NSurveillanceStopAsync | Stops surveillance and all sources (asynchronous operation).
NSurveillanceStopSource | Stops specified surveillance source.
NSurveillanceStopSourceAsync | Stops specified surveillance source (asynchronous operation).


NSurveillanceSource Unit

NSurveillanceSource Unit
Files Functions Legend Structs, Records, Enums

Provides functions for managing SentiVeillance sources - cameras and video files.

Collapse Expand Files
Name | Description
NSurveillanceSource.h | A header file containing containing functions operating NSurveillanceSource objects.
Collapse Expand Functions
Name | Description
NSurveillanceSourceAddIsCapturingChanged | Adds user specified event for managing Surveillance capturing changed events.
NSurveillanceSourceAddIsCapturingChangedCallback | Adds user specified callback for managing Surveillance changed events.
NSurveillanceSourceCreate | Creates a new NSurveillanceSource object.
NSurveillanceSourceCreateFromCameraEx | Creates a new NSurveillanceSource object from the specified camera.
NSurveillanceSourceCreateFromMediaReaderEx | Creates a new NSurveillanceSource object from the specified media reader.
NSurveillanceSourceGetCamera | Gets a camera associated with the specified NSurveillanceSource.
NSurveillanceSourceGetCurrentFormat | Gets current media format used in surveillance.
NSurveillanceSourceGetError | Retrieves the exception thrown by the specified NSurveillanceSource.
NSurveillanceSourceGetFormats | Gets all formats supported by camera or video.
NSurveillanceSourceGetLength | Retrieves the length of the specified NSurveillanceSource.
NSurveillanceSourceGetModalityType | Gets a type of modality used for surveillance source.
NSurveillanceSourceGetPosition | Retrieves the position in the specified NSurveillanceSource.
NSurveillanceSourceGetRegionOfInterest | Gets region of interest rectangle.
NSurveillanceSourceGetState | Gets the state of the specified NSurveillanceSource object.
NSurveillanceSourceGetType | Gets the type of the specified NSurveillanceSource object.
NSurveillanceSourceGetVideo | Gets the video associated with specified NSurveillanceSource.
NSurveillanceSourceGetWarning | Gets the warning set internally by processing NSurveillanceSource.
NSurveillanceSourceRemoveIsCapturingChanged | Adds user specified event for managing Surveillance changed events.
NSurveillanceSourceRemoveIsCapturingChangedCallback | Adds user specified callback for managing Surveillance changed events.
NSurveillanceSourceSetCamera | Sets the camera associated with the specified NSurveillanceSource.
NSurveillanceSourceSetCurrentFormat | Sets current media format used in surveillance.
NSurveillanceSourceSetModalityType | Sets a type of modality used for surveillance source.
NSurveillanceSourceSetRegionOfInterest | Sets region of interest rectangle.
NSurveillanceSourceSetVideo | Sets the video associated with the specified NSurveillanceSource.
Collapse Expand Structs, Records, Enums
Name | Description
NSurveillanceModalityType_ | Enumerates surveillance modality types.
NSurveillanceSourceType_ | Enumerates NSurveillanceSource types.
NSurveillanceModalityType | Enumerates surveillance modality types.
NSurveillanceSourceType | Enumerates NSurveillanceSource types.


NSurveillanceSourceAddIsCapturingChanged Function

NSurveillanceSourceAddIsCapturingChanged Function
NSurveillanceSource.h

Adds user specified event for managing Surveillance capturing changed events.

C++
NResult N_API NSurveillanceSourceAddIsCapturingChanged(HNSurveillanceSource hSource, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceSource hSource | [in] Handle to the NSurveillanceSource.
HNCallback hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceSource.h

Module: NSurveillanceSource Unit


NSurveillanceSourceAddIsCapturingChangedCallback Function

NSurveillanceSourceAddIsCapturingChangedCallback Function
NSurveillanceSource.h

Adds user specified callback for managing Surveillance changed events.

C++
NResult N_API NSurveillanceSourceAddIsCapturingChangedCallback(HNSurveillanceSource hSource, NObjectCallback pCallback, void * pParam);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceSource hSource | [in] Handle to the NSurveillanceSource.
NObjectCallback pCallback | [in] Callback function to be added. The type of the callback function is NObjectCallback.
void * pParam | [in] User data used by a callback function.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceSource.h

Module: NSurveillanceSource Unit


NSurveillanceSourceCreate Function

NSurveillanceSourceCreate Function
NSurveillanceSource.h

Creates a new NSurveillanceSource object.

C++
NResult N_API NSurveillanceSourceCreate(HNSurveillanceSource * phSource);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceSource * phSource | [out] Pointer to handle to the new NSurveillanceSource object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceSource.h

Module: NSurveillanceSource Unit


NSurveillanceSourceCreateFromCameraEx Function

NSurveillanceSourceCreateFromCameraEx Function
NSurveillanceSource.h

Creates a new NSurveillanceSource object from the specified camera.

C++
NResult N_API NSurveillanceSourceCreateFromCameraEx(HNCamera hCamera, NSurveillanceModalityType modalities, HNSurveillanceSource * phSource);
Collapse Expand Parameters
Parameters | Description
HNCamera hCamera | [in] Handle to the NCamera object.
NSurveillanceModalityType modalities | [in] Surveillance modality type - faces or license plate recognition.
HNSurveillanceSource * phSource | [out] Pointer to a handle the new NSurveillanceSource object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceSource.h

Module: NSurveillanceSource Unit


NSurveillanceSourceCreateFromMediaReaderEx Function

NSurveillanceSourceCreateFromMediaReaderEx Function
NSurveillanceSource.h

Creates a new NSurveillanceSource object from the specified media reader.

C++
NResult N_API NSurveillanceSourceCreateFromMediaReaderEx(HNMediaReader hMediaReader, NSurveillanceModalityType modalities, HNSurveillanceSource * phSource);
Collapse Expand Parameters
Parameters | Description
HNMediaReader hMediaReader | [in] Handle to the NMediaReader object.
NSurveillanceModalityType modalities | [in] Surveillance modality type - faces or license plate recognition.
HNSurveillanceSource * phSource | [out] Pointer to a handle the new NSurveillanceSource object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceSource.h

Module: NSurveillanceSource Unit


NSurveillanceSourceGetCamera Function

NSurveillanceSourceGetCamera Function
NSurveillanceSource.h

Gets a camera associated with the specified NSurveillanceSource.

C++
NResult N_API NSurveillanceSourceGetCamera(HNSurveillanceSource hSource, HNCamera * phValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceSource hSource | [in] Handle to the NSurveillanceSource.
HNCamera * phValue | [out] Pointer to a handle to the NCamera.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceSource.h

Module: NSurveillanceSource Unit


NSurveillanceSourceGetCurrentFormat Function

NSurveillanceSourceGetCurrentFormat Function
NSurveillanceSource.h

Gets current media format used in surveillance.

C++
NResult N_API NSurveillanceSourceGetCurrentFormat(HNSurveillanceSource hSource, HNMediaFormat * phValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceSource hSource | [in] Handle to the NSurveillanceSource.
HNMediaFormat * phValue | [out] Media format value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceSource.h

Module: NSurveillanceSource Unit


NSurveillanceSourceGetError Function

NSurveillanceSourceGetError Function
NSurveillanceSource.h

Retrieves the exception thrown by the specified NSurveillanceSource.

C++
NResult N_API NSurveillanceSourceGetError(HNSurveillanceSource hSource, HNError * phError);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceSource hSource | [in] Handle to the NSurveillanceSource.
HNError * phError | [out] Pointer to a handle to the exception.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceSource.h

Module: NSurveillanceSource Unit


NSurveillanceSourceGetFormats Function

NSurveillanceSourceGetFormats Function
NSurveillanceSource.h

Gets all formats supported by camera or video.

C++
NResult N_API NSurveillanceSourceGetFormats(HNSurveillanceSource hSource, HNMediaFormat * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceSource hSource | [in] Handle to the NSurveillanceSource.
HNMediaFormat * * parhValues | [out] Pointer to the array of media formats.
NInt * pValueCount | [out] Number of values in the array.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceSource.h

Module: NSurveillanceSource Unit


NSurveillanceSourceGetLength Function

NSurveillanceSourceGetLength Function
NSurveillanceSource.h

Retrieves the length of the specified NSurveillanceSource.

C++
NResult N_API NSurveillanceSourceGetLength(HNSurveillanceSource hSource, NTimeSpan_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceSource hSource | [in] Handle to the NSurveillanceSource.
NTimeSpan_ * pValue | [out] Pointer to the NTimeSpan_ structure representing the length of the source.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceSource.h

Module: NSurveillanceSource Unit


NSurveillanceSourceGetModalityType Function

NSurveillanceSourceGetModalityType Function
NSurveillanceSource.h

Gets a type of modality used for surveillance source.

C++
NResult N_API NSurveillanceSourceGetModalityType(HNSurveillanceSource hSource, NSurveillanceModalityType * pValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceSource hSource | [in] Handle to the NSurveillanceSource.
NSurveillanceModalityType * pValue | [out] NSurveillanceModalityType object containing modality type.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceSource.h

Module: NSurveillanceSource Unit


NSurveillanceSourceGetPosition Function

NSurveillanceSourceGetPosition Function
NSurveillanceSource.h

Retrieves the position in the specified NSurveillanceSource.

C++
NResult N_API NSurveillanceSourceGetPosition(HNSurveillanceSource hSource, NTimeSpan_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceSource hSource | [in] Handle to the NSurveillanceSource.
NTimeSpan_ * pValue | [out] Pointer to NTimeSpan_ structure representing position in the source.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceSource.h

Module: NSurveillanceSource Unit


NSurveillanceSourceGetRegionOfInterest Function

NSurveillanceSourceGetRegionOfInterest Function
NSurveillanceSource.h

Gets region of interest rectangle.

C++
NResult N_API NSurveillanceSourceGetRegionOfInterest(HNSurveillanceSource hSource, struct NRectF_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceSource hSource | [in] Handle to the NSurveillanceSource.
struct NRectF_ * pValue | [out] Region of interest rectangle.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceSource.h

Module: NSurveillanceSource Unit


NSurveillanceSourceGetState Function

NSurveillanceSourceGetState Function
NSurveillanceSource.h

Gets the state of the specified NSurveillanceSource object.

C++
NResult N_API NSurveillanceSourceGetState(HNSurveillanceSource hSource, NMediaState * pValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceSource hSource | _nt_
NMediaState * pValue | _nt_
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceSource.h

Module: NSurveillanceSource Unit


NSurveillanceSourceGetType Function

NSurveillanceSourceGetType Function
NSurveillanceSource.h

Gets the type of the specified NSurveillanceSource object.

C++
NResult N_API NSurveillanceSourceGetType(HNSurveillanceSource hSource, NSurveillanceSourceType * pValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceSource hSource | [in] Handle to the NSurveillanceSource.
NSurveillanceSourceType * pValue | [out] Pointer to the NSurveillanceSourceType object.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceSource.h

Module: NSurveillanceSource Unit


NSurveillanceSourceGetVideo Function

NSurveillanceSourceGetVideo Function
NSurveillanceSource.h

Gets the video associated with specified NSurveillanceSource.

C++
NResult N_API NSurveillanceSourceGetVideo(HNSurveillanceSource hSource, HNMediaReader * phValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceSource hSource | [in] Handle to the NSurveillanceSource.
HNMediaReader * phValue | [out] Pointer to a handle to the NMediaReader containing the video.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceSource.h

Module: NSurveillanceSource Unit


NSurveillanceSourceGetWarning Function

NSurveillanceSourceGetWarning Function
NSurveillanceSource.h

Gets the warning set internally by processing NSurveillanceSource.

C++
NResult N_API NSurveillanceSourceGetWarning(HNSurveillanceSource hSource, HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceSource hSource | [in] Handle to the NSurveillanceSource.
HNString * phValue | [out] Warning message.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceSource.h

Module: NSurveillanceSource Unit


NSurveillanceSourceRemoveIsCapturingChanged Function

NSurveillanceSourceRemoveIsCapturingChanged Function
NSurveillanceSource.h

Adds user specified event for managing Surveillance changed events.

C++
NResult N_API NSurveillanceSourceRemoveIsCapturingChanged(HNSurveillanceSource hSource, HNCallback hCallback);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceSource hSource | [in] Handle to the NSurveillanceSource.
HNCallback hCallback | [in] Handle to the event callback.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceSource.h

Module: NSurveillanceSource Unit


NSurveillanceSourceRemoveIsCapturingChangedCallback Function

NSurveillanceSourceRemoveIsCapturingChangedCallback Function
NSurveillanceSource.h

Adds user specified callback for managing Surveillance changed events.

C++
NResult N_API NSurveillanceSourceRemoveIsCapturingChangedCallback(HNSurveillanceSource hSource, NObjectCallback pCallback, void * pParam);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceSource hSource | [in] Handle to the NSurveillanceSource.
NObjectCallback pCallback | [in] Callback function to remove. The type of the callback function is NObjectCallback.
void * pParam | [in] User data used by a callback function.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceSource.h

Module: NSurveillanceSource Unit


NSurveillanceSourceSetCamera Function

NSurveillanceSourceSetCamera Function
NSurveillanceSource.h

Sets the camera associated with the specified NSurveillanceSource.

C++
NResult N_API NSurveillanceSourceSetCamera(HNSurveillanceSource hSource, HNCamera hCamera);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceSource hSource | [in] Handle to the NSurveillanceSource.
HNCamera hCamera | [in] Handle to the NCamera.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceSource.h

Module: NSurveillanceSource Unit


NSurveillanceSourceSetCurrentFormat Function

NSurveillanceSourceSetCurrentFormat Function
NSurveillanceSource.h

Sets current media format used in surveillance.

C++
NResult N_API NSurveillanceSourceSetCurrentFormat(HNSurveillanceSource hSource, HNMediaFormat hValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceSource hSource | [in] Handle to the NSurveillanceSource.
HNMediaFormat hValue | [in] Media format value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceSource.h

Module: NSurveillanceSource Unit


NSurveillanceSourceSetModalityType Function

NSurveillanceSourceSetModalityType Function
NSurveillanceSource.h

Sets a type of modality used for surveillance source.

C++
NResult N_API NSurveillanceSourceSetModalityType(HNSurveillanceSource hSource, NSurveillanceModalityType value);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceSource hSource | [in] Handle to the NSurveillanceSource.
NSurveillanceModalityType value | [in] NSurveillanceModalityType object containing modality type.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceSource.h

Module: NSurveillanceSource Unit


NSurveillanceSourceSetRegionOfInterest Function

NSurveillanceSourceSetRegionOfInterest Function
NSurveillanceSource.h

Sets region of interest rectangle.

C++
NResult N_API NSurveillanceSourceSetRegionOfInterest(HNSurveillanceSource hSource, const struct NRectF_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceSource hSource | [in] Handle to the NSurveillanceSource.
const struct NRectF_ * pValue | [in] Region of interest rectangle.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceSource.h

Module: NSurveillanceSource Unit


NSurveillanceSourceSetVideo Function

NSurveillanceSourceSetVideo Function
NSurveillanceSource.h

Sets the video associated with the specified NSurveillanceSource.

C++
NResult N_API NSurveillanceSourceSetVideo(HNSurveillanceSource hSource, HNMediaReader hVideo);
Collapse Expand Parameters
Parameters | Description
HNSurveillanceSource hSource | [in] Handle to the NSurveillanceSource.
HNMediaReader hVideo | [in] Handle to the NMediaReader containing the video.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NSurveillanceSource.h

Module: NSurveillanceSource Unit


NSurveillanceModalityType Enumeration

NSurveillanceModalityType Enumeration
NSurveillanceSource.h

Enumerates surveillance modality types.

C++
typedef enum NSurveillanceModalityType_ {
  nsmtNone = 0,
  nsmtFaces = 1,
  nsmtVehiclesAndHumans = 2,
  nsmtLicensePlateRecognition = 4
} NSurveillanceModalityType;
Collapse Expand Members
Members | Description
nsmtNone = 0 | None of these modalities were selected.
nsmtFaces = 1 | Indicates that faces should be processed.
nsmtVehiclesAndHumans = 2 | Indicates that vehicles and humans should be processed.
nsmtLicensePlateRecognition = 4 | Indicates that license plates should be processed.
Container

File: NSurveillanceSource.h

Module: NSurveillanceSource Unit


NSurveillanceSourceType Enumeration

NSurveillanceSourceType Enumeration
NSurveillanceSource.h

Enumerates NSurveillanceSource types.

C++
typedef enum NSurveillanceSourceType_ {
  nsstCamera = 1,
  nsstVideo = 2,
  nsstUnknown = -1
} NSurveillanceSourceType;
Collapse Expand Members
Members | Description
nsstCamera = 1 | Indicates a camera.
nsstVideo = 2 | Indicates a video.
nsstUnknown = -1 | Indicates an unknown source type.
Container

File: NSurveillanceSource.h

Module: NSurveillanceSource Unit


NSurveillanceSource.h

NSurveillanceSource.h
Enumerations Functions Legend

A header file containing containing functions operating NSurveillanceSource objects.

Collapse Expand Enumerations
Name | Description
NSurveillanceModalityType_ | Enumerates surveillance modality types.
NSurveillanceSourceType_ | Enumerates NSurveillanceSource types.
NSurveillanceModalityType | Enumerates surveillance modality types.
NSurveillanceSourceType | Enumerates NSurveillanceSource types.
Collapse Expand Functions
Name | Description
NSurveillanceSourceAddIsCapturingChanged | Adds user specified event for managing Surveillance capturing changed events.
NSurveillanceSourceAddIsCapturingChangedCallback | Adds user specified callback for managing Surveillance changed events.
NSurveillanceSourceCreate | Creates a new NSurveillanceSource object.
NSurveillanceSourceCreateFromCameraEx | Creates a new NSurveillanceSource object from the specified camera.
NSurveillanceSourceCreateFromMediaReaderEx | Creates a new NSurveillanceSource object from the specified media reader.
NSurveillanceSourceGetCamera | Gets a camera associated with the specified NSurveillanceSource.
NSurveillanceSourceGetCurrentFormat | Gets current media format used in surveillance.
NSurveillanceSourceGetError | Retrieves the exception thrown by the specified NSurveillanceSource.
NSurveillanceSourceGetFormats | Gets all formats supported by camera or video.
NSurveillanceSourceGetLength | Retrieves the length of the specified NSurveillanceSource.
NSurveillanceSourceGetModalityType | Gets a type of modality used for surveillance source.
NSurveillanceSourceGetPosition | Retrieves the position in the specified NSurveillanceSource.
NSurveillanceSourceGetRegionOfInterest | Gets region of interest rectangle.
NSurveillanceSourceGetState | Gets the state of the specified NSurveillanceSource object.
NSurveillanceSourceGetType | Gets the type of the specified NSurveillanceSource object.
NSurveillanceSourceGetVideo | Gets the video associated with specified NSurveillanceSource.
NSurveillanceSourceGetWarning | Gets the warning set internally by processing NSurveillanceSource.
NSurveillanceSourceRemoveIsCapturingChanged | Adds user specified event for managing Surveillance changed events.
NSurveillanceSourceRemoveIsCapturingChangedCallback | Adds user specified callback for managing Surveillance changed events.
NSurveillanceSourceSetCamera | Sets the camera associated with the specified NSurveillanceSource.
NSurveillanceSourceSetCurrentFormat | Sets current media format used in surveillance.
NSurveillanceSourceSetModalityType | Sets a type of modality used for surveillance source.
NSurveillanceSourceSetRegionOfInterest | Sets region of interest rectangle.
NSurveillanceSourceSetVideo | Sets the video associated with the specified NSurveillanceSource.


NTrackingDetails Unit

NTrackingDetails Unit
Functions Legend

Represents objects tracking details.

Collapse Expand Functions
Name | Description
NTrackingDetailsGetAttributes | Gets face attributes (like age, gender, emotions and other) of a detected face.
NTrackingDetailsGetAttributesContainsDetails | ... more
NTrackingDetailsGetFrameIndex | Gets frame index.
NTrackingDetailsGetLicensePlate | Gets license plate specified by an index.
NTrackingDetailsGetLicensePlateCount | Gets license plates count in license plates collection.
NTrackingDetailsGetLicensePlates | Gets all license plates.
NTrackingDetailsGetMatchResult | Gets subject's matching result specified by an index.
NTrackingDetailsGetMatchResultCount | Gets subject's matching result count.
NTrackingDetailsGetMatchResults | Gets all subject's matching results.
NTrackingDetailsGetRectangle | Gets rectangle of bounding box of a tracked object.
NTrackingDetailsGetSubjectType | Gets which surveillance modalities was detected for a subject.
NTrackingDetailsGetTimeStamp | Gets time stamp from tracking details.


NTrackingDetailsGetAttributes Function

NTrackingDetailsGetAttributes Function

Gets face attributes (like age, gender, emotions and other) of a detected face.

C++
NResult N_API NTrackingDetailsGetAttributes(HNTrackingDetails hDetails, HNLAttributes * phValue);
Collapse Expand Parameters
Parameters | Description
HNTrackingDetails hDetails | [in] Handle to NTrackingDetails.
HNLAttributes * phValue | [out] Pointer to NLAttributes object containing face attributes of a detected face.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTrackingDetails.h

Module: NTrackingDetails Unit


NTrackingDetailsGetAttributesContainsDetails Function

NTrackingDetailsGetAttributesContainsDetails Function

Gets whether face template was extracted and contains faces attributes such as gender or face expression.

C++
NResult N_API NTrackingDetailsGetAttributesContainsDetails(HNTrackingDetails hDetails, NBool * pValue);
Collapse Expand Parameters
Parameters | Description
HNTrackingDetails hDetails | [in] Handle to NTrackingDetails.
NBool * pValue | [out] NTue, if extracted face template contains face attributes; otherwise, NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTrackingDetails.h

Module: NTrackingDetails Unit


NTrackingDetailsGetFrameIndex Function

NTrackingDetailsGetFrameIndex Function

Gets frame index.

C++
NResult N_API NTrackingDetailsGetFrameIndex(HNTrackingDetails hDetails, NULong * pValue);
Collapse Expand Parameters
Parameters | Description
HNTrackingDetails hDetails | [in] Handle to NTrackingDetails.
NULong * pValue | [out] Pointer to NULong containing frame index.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTrackingDetails.h

Module: NTrackingDetails Unit


NTrackingDetailsGetLicensePlate Function

NTrackingDetailsGetLicensePlate Function

Gets license plate specified by an index.

C++
NResult N_API NTrackingDetailsGetLicensePlate(HNTrackingDetails hDetails, NInt index, HNLicensePlate * phValue);
Collapse Expand Parameters
Parameters | Description
HNTrackingDetails hDetails | [in] Handle to NTrackingDetails.
NInt index | [in] License plate index.
HNLicensePlate * phValue | [out] Pointer to NLicensePlate object containing a retrieved license plate.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTrackingDetails.h

Module: NTrackingDetails Unit


NTrackingDetailsGetLicensePlateCount Function

NTrackingDetailsGetLicensePlateCount Function

Gets license plates count in license plates collection.

C++
NResult N_API NTrackingDetailsGetLicensePlateCount(HNTrackingDetails hDetails, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNTrackingDetails hDetails | [in] Handle to NTrackingDetails.
NInt * pValue | [out] Pointer to NInt which receives license plates count.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTrackingDetails.h

Module: NTrackingDetails Unit


NTrackingDetailsGetLicensePlates Function

NTrackingDetailsGetLicensePlates Function

Gets all license plates.

C++
NResult N_API NTrackingDetailsGetLicensePlates(HNTrackingDetails hDetails, HNLicensePlate * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNTrackingDetails hDetails | [in] Handle to NTrackingDetails.
HNLicensePlate * * parhValues | [out] Pointer to an array of NLicensePlate containing all license plates.
NInt * pValueCount | [out] Array items count.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTrackingDetails.h

Module: NTrackingDetails Unit


NTrackingDetailsGetMatchResult Function

NTrackingDetailsGetMatchResult Function

Gets subject's matching result specified by an index.

C++
NResult N_API NTrackingDetailsGetMatchResult(HNTrackingDetails hDetails, NInt index, HNsedMatchResult * phValue);
Collapse Expand Parameters
Parameters | Description
HNTrackingDetails hDetails | [in] Handle to NTrackingDetails.
NInt index | [in] Matching result index.
HNsedMatchResult * phValue | [out] Pointer to NsedMatchResult which receives subject's matching result.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTrackingDetails.h

Module: NTrackingDetails Unit


NTrackingDetailsGetMatchResultCount Function

NTrackingDetailsGetMatchResultCount Function

Gets subject's matching result count.

C++
NResult N_API NTrackingDetailsGetMatchResultCount(HNTrackingDetails hDetails, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNTrackingDetails hDetails | [in] Handle to NTrackingDetails.
NInt * pValue | [out] Pointer to NInt which receives matching results count.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTrackingDetails.h

Module: NTrackingDetails Unit


NTrackingDetailsGetMatchResults Function

NTrackingDetailsGetMatchResults Function

Gets all subject's matching results.

C++
NResult N_API NTrackingDetailsGetMatchResults(HNTrackingDetails hDetails, HNsedMatchResult * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNTrackingDetails hDetails | [in] Handle to NTrackingDetails.
HNsedMatchResult * * parhValues | [out] Pointer to an array of NsedMatchResult containing all matching results.
NInt * pValueCount | [out] Array items count.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTrackingDetails.h

Module: NTrackingDetails Unit


NTrackingDetailsGetRectangle Function

NTrackingDetailsGetRectangle Function

Gets rectangle of bounding box of a tracked object.

C++
NResult N_API NTrackingDetailsGetRectangle(HNTrackingDetails hDetails, struct NRect_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNTrackingDetails hDetails | [in] Handle to NTrackingDetails.
struct NRect_ * pValue | [out] Pointer to NRect object containing coordinates, width and height.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTrackingDetails.h

Module: NTrackingDetails Unit


NTrackingDetailsGetSubjectType Function

NTrackingDetailsGetSubjectType Function

Gets which surveillance modalities was detected for a subject.

C++
NResult N_API NTrackingDetailsGetSubjectType(HNTrackingDetails hDetails, NSurveillanceModalityType * pValue);
Collapse Expand Parameters
Parameters | Description
HNTrackingDetails hDetails | [in] Handle to NTrackingDetails.
NSurveillanceModalityType * pValue | [out] NSurveillanceModalityType object containing subject modality type.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Collapse Expand Remarks

E.g., when vehicle and human detector is enabled and subject is turned away, only vehicle type is returned. Or when a face and a vehicle is detected, vehicle + human type is returned.

These surveillance subject modalities are available: None, Faces, VehiclesAndHumans.

Container

File: NTrackingDetails.h

Module: NTrackingDetails Unit


NTrackingDetailsGetTimeStamp Function

NTrackingDetailsGetTimeStamp Function

Gets time stamp from tracking details.

C++
NResult N_API NTrackingDetailsGetTimeStamp(HNTrackingDetails hDetails, NDateTime * pValue);
Collapse Expand Parameters
Parameters | Description
HNTrackingDetails hDetails | [in] Handle to NTrackingDetails.
NDateTime * pValue | [out[ Pointer to NDateTime containing time stamp value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NTrackingDetails.h

Module: NTrackingDetails Unit


NVehicleDetails Unit

NVehicleDetails Unit
Functions Legend Structs, Records, Enums

Represents vehicle details.

Collapse Expand Functions
Name | Description
NVehicleDetailsGetKnownMakes | Gets the array of known vehicle makes (names of vehicle manufacturers).
NVehicleDetailsGetKnownModels | Gets the array of all known vehicle models.
NVehicleDetailsGetKnownModelsByMake | Gets the array of known vehicle models of the specified vehicle make.
NVehicleDetailsGetKnownTags | Gets all known vehicle body types (like sedan, coupe, bus, tractor, etc.).
NVehicleDetailsGetModel | Gets vehicle model specified by an index.
NVehicleDetailsGetModelCount | Gets vehicle models count.
NVehicleDetailsGetModels | Gets all vehicle models.
NVehicleDetailsGetOrientation | Gets vehicle orientation value (Front, Back, Left, FrontLeft, etc.).
NVehicleDetailsGetOrientationAngle | Gets an angle of vehicle orientation.
NVehicleDetailsGetOrientationConfidence | Gets confidence value of vehicle's orientation.
NVehicleDetailsGetTag | Gets vehicle body type (tag).
NVehicleDetailsGetTagCount | Gets vehicle body types count.
NVehicleDetailsGetTags | Gets vehicle body types (tags).
NVehicleModelGetMake | Gets vehicle's make by vehicle model.
Collapse Expand Structs, Records, Enums
Name | Description
NVehicleOrientation_ | Enumerates vehicle orientation values.
NVehicleOrientation | Enumerates vehicle orientation values.


NVehicleDetailsGetKnownMakes Function

NVehicleDetailsGetKnownMakes Function

Gets the array of known vehicle makes (names of vehicle manufacturers).

C++
NResult N_API NVehicleDetailsGetKnownMakes(HNString * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNString * * parhValues | [out] Pointer to an array of NString containing known vehicle makes.
NInt * pValueCount | [out] Array items count.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NVehicleDetails.h

Module: NVehicleDetails Unit


NVehicleDetailsGetKnownModels Function

NVehicleDetailsGetKnownModels Function

Gets the array of all known vehicle models.

C++
NResult N_API NVehicleDetailsGetKnownModels(HNString * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNString * * parhValues | [out] Pointer to an array of NString which receives all known vehicle models.
NInt * pValueCount | [out] Array items count.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NVehicleDetails.h

Module: NVehicleDetails Unit


NVehicleDetailsGetKnownModelsByMake Function

NVehicleDetailsGetKnownModelsByMake Function

Gets the array of known vehicle models of the specified vehicle make.

C++
NResult N_API NVehicleDetailsGetKnownModelsByMake(HNString hMake, HNString * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNString hMake | [in] Vehicle make to retrieve its known models.
HNString * * parhValues | [out] Pointer to an array of NString which receives all known vehicle models.
NInt * pValueCount | [out] Array items count.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NVehicleDetails.h

Module: NVehicleDetails Unit


NVehicleDetailsGetKnownTags Function

NVehicleDetailsGetKnownTags Function

Gets all known vehicle body types (like sedan, coupe, bus, tractor, etc.).

C++
NResult N_API NVehicleDetailsGetKnownTags(HNString * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNString * * parhValues | [out] Pointer to array of NString containing all known vehicle body types.
NInt * pValueCount | [out] Array items count.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NVehicleDetails.h

Module: NVehicleDetails Unit


NVehicleDetailsGetModel Function

NVehicleDetailsGetModel Function

Gets vehicle model specified by an index.

C++
NResult N_API NVehicleDetailsGetModel(HNVehicleDetails hDetails, NInt index, HNVehicleModel * phValue);
Collapse Expand Parameters
Parameters | Description
HNVehicleDetails hDetails | [in] Handle to NVehicleDetails.
NInt index | [in] Index of a model.
HNVehicleModel * phValue | [out] Pointer to NVehicleModel.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NVehicleDetails.h

Module: NVehicleDetails Unit


NVehicleDetailsGetModelCount Function

NVehicleDetailsGetModelCount Function

Gets vehicle models count.

C++
NResult N_API NVehicleDetailsGetModelCount(HNVehicleDetails hDetails, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNVehicleDetails hDetails | [in] Handle to NVehicleDetails.
NInt * pValue | [out] Vehicle models count.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NVehicleDetails.h

Module: NVehicleDetails Unit


NVehicleDetailsGetModels Function

NVehicleDetailsGetModels Function

Gets all vehicle models.

C++
NResult N_API NVehicleDetailsGetModels(HNVehicleDetails hDetails, HNVehicleModel * * parhValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNVehicleDetails hDetails | [in] Handle to NVehicleDetails.
HNVehicleModel * * parhValues | [out] Pointer to an array of NVehicleModel which receives all vehicle models.
NInt * pValueCount | [out] Array items count.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NVehicleDetails.h

Module: NVehicleDetails Unit


NVehicleDetailsGetOrientation Function

NVehicleDetailsGetOrientation Function

Gets vehicle orientation value (Front, Back, Left, FrontLeft, etc.).

C++
NResult N_API NVehicleDetailsGetOrientation(HNVehicleDetails hDetails, NVehicleOrientation * pValue);
Collapse Expand Parameters
Parameters | Description
HNVehicleDetails hDetails | [in] Handle to NVehicleDetails.
NVehicleOrientation * pValue | [out] Pointer to NVehicleOrientation.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NVehicleDetails.h

Module: NVehicleDetails Unit


NVehicleDetailsGetOrientationAngle Function

NVehicleDetailsGetOrientationAngle Function

Gets an angle of vehicle orientation.

C++
NResult N_API NVehicleDetailsGetOrientationAngle(HNVehicleDetails hDetails, NFloat * pValue);
Collapse Expand Parameters
Parameters | Description
HNVehicleDetails hDetails | [in] Handle to NVehicleDetails.
NFloat * pValue | [out] Pointer to NFloat which receives vehicle orientation value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NVehicleDetails.h

Module: NVehicleDetails Unit


NVehicleDetailsGetOrientationConfidence Function

NVehicleDetailsGetOrientationConfidence Function

Gets confidence value of vehicle's orientation.

C++
NResult N_API NVehicleDetailsGetOrientationConfidence(HNVehicleDetails hDetails, NFloat * pValue);
Collapse Expand Parameters
Parameters | Description
HNVehicleDetails hDetails | [in] Handle to NVehicleDetails.
NFloat * pValue | [out] Confidence value of vehicle's orientation
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NVehicleDetails.h

Module: NVehicleDetails Unit


NVehicleDetailsGetTag Function

NVehicleDetailsGetTag Function

Gets vehicle body type (tag).

C++
NResult N_API NVehicleDetailsGetTag(HNVehicleDetails hDetails, NInt index, struct NNameConfidencePair_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNVehicleDetails hDetails | [in] Handle to NVehicleDetails.
NInt index | [in] Index of a vehicle.
struct NNameConfidencePair_ * pValue | [out] Pointer to NNameConfidencePair containing vehicle body type value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NVehicleDetails.h

Module: NVehicleDetails Unit


NVehicleDetailsGetTagCount Function

NVehicleDetailsGetTagCount Function

Gets vehicle body types count.

C++
NResult N_API NVehicleDetailsGetTagCount(HNVehicleDetails hDetails, NInt * pValue);
Collapse Expand Parameters
Parameters | Description
HNVehicleDetails hDetails | [in] Handle to NVehicleDetails.
NInt * pValue | [out] Vehicle body types count.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NVehicleDetails.h

Module: NVehicleDetails Unit


NVehicleDetailsGetTags Function

NVehicleDetailsGetTags Function

Gets vehicle body types (tags).

C++
NResult N_API NVehicleDetailsGetTags(HNVehicleDetails hDetails, struct NNameConfidencePair_ * * parValues, NInt * pValueCount);
Collapse Expand Parameters
Parameters | Description
HNVehicleDetails hDetails | [in] Handle to NVehicleDetails.
struct NNameConfidencePair_ * * parValues | [out] Pointer to array of NNameConfidencePair containing vehicle body types.
NInt * pValueCount | [out] Array items count.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NVehicleDetails.h

Module: NVehicleDetails Unit


NVehicleModelGetMake Function

NVehicleModelGetMake Function

Gets vehicle's make by vehicle model.

C++
NResult N_API NVehicleModelGetMake(HNVehicleModel hModel, struct NNameConfidencePair_ * pValue);
Collapse Expand Parameters
Parameters | Description
HNVehicleModel hModel | [in] Handle to NVehicleModel.
struct NNameConfidencePair_ * pValue | [out] Pointer to NNameConfidencePair which receives vehicle's make.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NVehicleDetails.h

Module: NVehicleDetails Unit


NVehicleOrientation Enumeration

NVehicleOrientation Enumeration

Enumerates vehicle orientation values.

C++
typedef enum NVehicleOrientation_ {
  nvoRight = 0,
  nvoRearRight = 45,
  nvoRear = 90,
  nvoRearLeft = 135,
  nvoLeft = 180,
  nvoFrontLeft = 225,
  nvoFront = 270,
  nvoFrontRight = 315
} NVehicleOrientation;
Collapse Expand Members
Members | Description
nvoRight = 0 | Right side of a vehicle is visible.
nvoRearRight = 45 | Rear right side of a vehicle is visible.
nvoRear = 90 | Rear side of a vehicle is visible.
nvoRearLeft = 135 | Rear side of a vehicle is visible.
nvoLeft = 180 | Left side of a vehicle is visible.
nvoFrontLeft = 225 | Front left side of a vehicle is visible.
nvoFront = 270 | Front side of a vehicle is visible.
nvoFrontRight = 315 | Front right side of a vehicle is visible.
Container

File: NVehicleDetails.h

Module: NVehicleDetails Unit


NGpuJpegEncoder Unit

NGpuJpegEncoder Unit
Functions Legend Structs, Records, Enums

Provides functionality for converting Nimage to Jpeg using GPU.

Collapse Expand Functions
Name | Description
NGpuJpegEncoderCreate | Creates a new instance NGpuJpegEncoder by specified index.
NGpuJpegEncoderEncode | Converts provided NImage object to Jpeg using GPU and returns as NBuffer object.
NGpuJpegEncoderScaleAndEncode | Rescales and converts provided NImage object to Jpeg using GPU and returns as NBuffer object.
Collapse Expand Structs, Records, Enums
Name | Description
NScaleMethod_ | Image rescale algorithm.
NScaleMethod | Image rescale algorithm.


NGpuJpegEncoderCreate Function

NGpuJpegEncoderCreate Function

Creates a new instance NGpuJpegEncoder by specified index.

C++
NResult N_API NGpuJpegEncoderCreate(NInt gpuIndex, HNGpuJpegEncoder * phValue);
Collapse Expand Parameters
Parameters | Description
NInt gpuIndex | [in] Index of GPU.
HNGpuJpegEncoder * phValue | [out] Pointer to a handle of created NGpuJpegEncoder.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NGpuJpegEncoder.h

Module: NGpuJpegEncoder Unit


NGpuJpegEncoderEncode Function

NGpuJpegEncoderEncode Function

Converts provided NImage object to Jpeg using GPU and returns as NBuffer object.

C++
NResult N_API NGpuJpegEncoderEncode(HNGpuJpegEncoder hEncoder, HNImage hImage, HNBuffer * phValue);
Collapse Expand Parameters
Parameters | Description
HNGpuJpegEncoder hEncoder | [in] Handle to NGpuJpegEncoder.
HNImage hImage | [in] NImage object containing image to convert to to Jpeg.
HNBuffer * phValue | [out] Pointer to NBuffer object containing a converted Jpeg image.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NGpuJpegEncoder.h

Module: NGpuJpegEncoder Unit


NGpuJpegEncoderScaleAndEncode Function

NGpuJpegEncoderScaleAndEncode Function

Rescales and converts provided NImage object to Jpeg using GPU and returns as NBuffer object.

C++
NResult N_API NGpuJpegEncoderScaleAndEncode(HNGpuJpegEncoder hEncoder, HNImage hImage, NUInt outputWidth, NUInt outputHeight, NScaleMethod scaleMethod, HNBuffer * phValue);
Collapse Expand Parameters
Parameters | Description
HNGpuJpegEncoder hEncoder | [in] Handle to NGpuJpegEncoder.
HNImage hImage | [in] NImage object containing image to convert to to Jpeg.
NUInt outputWidth | [in] Width of an output Jpeg image.
NUInt outputHeight | [in] Height of an output Jpeg image.
NScaleMethod scaleMethod | [in] Rescale method.
HNBuffer * phValue | [out] NBuffer object containing a converted Jpeg image.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NGpuJpegEncoder.h

Module: NGpuJpegEncoder Unit


NScaleMethod Enumeration

NScaleMethod Enumeration

Image rescale algorithm.

C++
typedef enum NScaleMethod_ {
  nsmNearestNeighbor = 1,
  nsmLinear = 2,
  nsmCubic = 3,
  nsmCubicSpline = 4,
  nsmCubicCatmullRom = 5,
  nsmCubicB05C03 = 6,
  nsmSuperSampling = 7,
  nsmLanczos = 8,
  nsmLanczosAdvanced = 9,
  nsmSmoothEdge = 10
} NScaleMethod;
Collapse Expand Members
Members | Description
nsmNearestNeighbor = 1 | Nearest Neighbor algorithm.
nsmLinear = 2 | Linear algorithm.
nsmCubic = 3 | Cubic algorithm.
nsmCubicSpline = 4 | Cubic Spline algorithm.
nsmCubicCatmullRom = 5 | Cubic Catmull Rom algorithm.
nsmCubicB05C03 = 6 | Cubic B05C03 algorithm.
nsmSuperSampling = 7 | Super resampling algorithm.
nsmLanczos = 8 | Lanczos resampling.
nsmLanczosAdvanced = 9 | Lanczos advanced resampling.
nsmSmoothEdge = 10 | Smooth edge algorithm.
Container

File: NGpuJpegEncoder.h

Module: NGpuJpegEncoder Unit


.NET Reference

.NET Reference
Functions Legend Macros Structs, Records, Enums

In this section SentiVeillance 9.0 SDK .NET programming reference for API is provided.

The required libraries for namespaces are listed in the table bellow:

Namespace | Managed Dll (for .NET) | Unmanaged Dll
Neurotec | Neurotec.dll | NCore.dll
Neurotec.Biometrics | Neurotec.Biometrics.dll | NBiometrics.dll
Neurotec.Devices | Neurotec.Devices.dll | NDevices.dll
Neurotec.Media | Neurotec.Media.dll | NMedia.dll
Neurotec.Licensing | Neurotec.Licensing.dll | NLicensing.dll
Neurotec.Surveillance | Neurotec.Surveillance.dll | NSurveillance.dll
Collapse Expand Functions
Name | Description
NLicensingServiceGetBinPath | Gets the binary path (path to pg.exe/pgd) to the license.
NLicensingServiceGetConfPath | Gets path to licensing service configuration file (pgd.conf).
NLicensingServiceGetStatus | Gets the status of the licensing service.
NLicensingServiceInstall | Installs licensing service.
NLicensingServiceIsTrial | Checks whether the licensing service is trial.
NLicensingServiceStart | Starts licensing service.
NLicensingServiceStop | Stops licensing service.
NLicensingServiceUninstall | Uninstalls licensing service.
Collapse Expand Macros
Name | Description
NLicensingServiceInstall | Picks a Unicode (W) or ANSCII (A) version of the NLicensingServiceInstall function.
Collapse Expand Structs, Records, Enums
Name | Description
NLicensingServiceStatus_ | Enumerates licensing service status values.
NLicensingServiceStatus | Enumerates licensing service status values.


Neurotec Namespace

Neurotec Namespace
Classes Legend Structs, Records, Enums

Contains classes that provide infrastructure for Neurotechnology components.

Collapse Expand Classes
Name | Description
ErrorSuppressedEventArgs | Provides functionality for a suppressed error.
NArray | Provides functionality for working with arrays.
NAsyncOperation | Provides functionality for working with asynchronous operations. Asynchronous operations are functions and methods which return instantly, providing an object which can be used for operation's proper completion.
NComplex | Represents a complex number.
NCore | This class supports internal Neurotechnology libraries infrastructure and should not be used directly in your code.
NDisposable | Provides a method to release allocated resources.
NError | Defines error codes used in Neurotechnology components.
NExpandableObject | Provides functionality for retrieving information about specified object.
NIndexPair | Represents pair of indexes.
NModule | Performs reflection on a module.
NObject | Provides functionality for retrieving information about specified object.
NProcessorInfo | Provides functionality for getting processor information.
NPropertyBag | Represents a property bag in which the object can persistently save its properties.
NRange | Represents range.
NRational | Represents a signed rational number.
NType | Manages object types.
NTypes | Manages object types.
NURational | Represents an unsigned rational number.
NValue | Provides functionality for management and conversion of values of different types.
NVersion | Manages version information.
NVersionRange | Manages version ranges.
Collapse Expand Structs, Records, Enums
Name | Description
NAsyncStatus | Enumerates asynchronous operation statuses.
NAttributes | Enumerates value attributes.
NMemoryType | Enumerates memory type options.
NModuleOptions | Enumerates module options.
NOSFamily | Enumerates operating system families.
NProcessorFeature | Specifies the processor's feature flag.
NProcessorVendor | Specifies the processor's vendor name.
NTypeCode | Enumerates type codes.


ErrorSuppressedEventArgs Class

ErrorSuppressedEventArgs Class
Legend Members Methods ErrorSuppressedEventArgs Properties

Provides functionality for a suppressed error.

C#
public class ErrorSuppressedEventArgs : EventArgs;
Collapse Expand ErrorSuppressedEventArgs Properties
Name | Description
Error | Gets the suppressed error.
Container

File: NCore.cs

Namespace: Neurotec

Module: .NET Reference


ErrorSuppressedEventArgs.ErrorSuppressedEventArgs Constructor

ErrorSuppressedEventArgs.ErrorSuppressedEventArgs Constructor
ErrorSuppressedEventArgs Class Neurotec Namespace

Initializes a new instance of ErrorSuppressedEventArgs class.

C#
public ErrorSuppressedEventArgs(Exception error);
Collapse Expand Parameters
Parameters | Description
Exception error | The suppressed error.


ErrorSuppressedEventArgs.Error Property

ErrorSuppressedEventArgs.Error Property
ErrorSuppressedEventArgs Class Neurotec Namespace

Gets the suppressed error.

C#
public Exception Error;
Property value

The suppressed error.


NArray Class

NArray Class
NObject Delegates NObject Events NObject Fields Legend Members Methods NDisposable Methods NDisposable Properties

Provides functionality for working with arrays.

C#
public sealed class NArray : NValue, IEnumerable;
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NValue Class
Show:
No members matching the current filter
Name | Description
ChangeType | Changes the type of the specified value to the new type.
FromDelegate | Creates a new value from the specified delegate.
FromObject | Creates a new value from the specified object.
FromPointer | Creates a new value from the specified pointer.
FromResult | Creates a new value from the specified result.
FromString | Creates a new value from the specified string.
FromType<T> | Creates a new value from the specified type.
ToBoolean | Converts the specified value into a Boolean value.
ToByte | Converts the specified value into a byte.
ToChar | Converts the specified value into a char.
ToDouble | Converts the specified value into a double number.
ToInt16 | Converts the specified value into a short integer.
ToInt32 | Converts the specified value into an integer.
ToInt64 | Converts the specified value into a long integer.
ToIntPtr | Converts the specified value into a pointer.
ToObject | Converts the specified value into an object.
ToPointer | Converts the specified value into a pointer.
ToResult | Converts the specified value into a result.
ToSByte | Converts the specified value into a signed byte.
ToSingle | Converts the specified value into a floating point value.
ToString | Converts the specified value into a string.
ToType<T> | Converts the specified value into a value of specified type.
ToUInt16 | Converts the specified value into an unsigned short integer.
ToUInt32 | Converts the specified value into an unsigned integer.
ToUInt64 | Converts the specified value into an unsigned long integer.
ToUIntPtr | Converts the specified value into a pointer.
NArray Class
Name | Description
FromArray | Creates a new array from the specified array.
FromPointerArray | Creates a new array from the specified integer pointer value array.
FromResultArray | Creates a new array from the specified result array.
GetEnumerator | Retrieves an enumerator for the current array.
GetValueAs<T> | Retrieves the of the specified value of the specified type in the array.
GetValueAsBoolean | Retrieves the specified Boolean value in the array.
GetValueAsByte | Retrieves the specified byte value in the array.
GetValueAsChar | Retrieves the specified char value in the array.
GetValueAsDouble | Retrieves the specified double value in the array.
GetValueAsInt16 | Retrieves the specified short integer value in the array.
GetValueAsInt32 | Retrieves the specified integer value in the array.
GetValueAsInt64 | Retrieves the specified long integer value in the array.
GetValueAsIntPtr | Retrieves the specified integer pointer value in the array.
GetValueAsObject | Retrieves the specified object in the array.
GetValueAsPointer | Retrieves the specified integer pointer value in the array.
GetValueAsResult | Retrieves the specified result value in the array.
GetValueAsSByte | Retrieves the specified signed byte value in the array.
GetValueAsSingle | Retrieves the specified floating point value in the array.
GetValueAsString | Retrieves the specified string value in the array.
GetValueAsUInt16 | Retrieves the specified unsigned short integer value in the array.
GetValueAsUInt32 | Retrieves the specified unsigned integer value in the array.
GetValueAsUInt64 | Retrieves the specified unsigned long integer value in the array.
GetValueAsUIntPtr | Retrieves the specified unsigned integer pointer value in the array.
ToArray<T> | Copies the current array into another array of the specified type.
ToBooleanArray | Copies the current array into a Boolean value array.
ToByteArray | Copies the current array into a byte array.
ToCharArray | Copies the current array into a char array.
ToDoubleArray | Copies the current array into a double value array.
ToInt16Array | Copies the current array into a short integer array.
ToInt32Array | Copies the current array into an integer array.
ToInt64Array | Copies the current array into a long integer array.
ToIntPtrArray | Copies the current array into an integer pointer array.
ToObjectArray | Copies the current array into an object array.
ToPointerArray | Copies the current array into a pointer array.
ToResultArray | Copies the current array into a result array.
ToSByteArray | Copies the current array into a signed byte array.
ToSingleArray | Copies the current array into a floating point value array.
ToStringArray | Copies the current array into a string array.
ToUInt16Array | Copies the current array into an unsigned short integer array.
ToUInt32Array | Copies the current array into an unsigned integer array.
ToUInt64Array | Copies the current unsigned long integer array into another array.
ToUIntPtrArray | Copies the current array into an unsigned integer pointer array.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NValue Class
Show:
No members matching the current filter
Name | Description
Attributes | Gets the value attributes.
IsWrapper | Checks whether the value is a wrapper.
KeyValuePairNativeType | Defines the native type of the key value pair structure.
LongSize | Gets the size of the value (64-bit).
NameValuePairNativeType | Defines the native type of the name value pair structure.
NativeSize | Gets the native size of the value.
NativeType | Defines the native type of the object.
Ptr | Gets a pointer to the value.
Size | Gets the size of the value.
TypeCode | Gets the type code of the value.
ValueType | Gets the type of the value.
NArray Class
Name | Description
Length | Retrieves the length of the array.
NativeType | Defines the native type of the object.
Container

File: NArray.cs

Namespace: Neurotec

Module: .NET Reference


NArray.FromArray Method (Array)

NArray.FromArray Method (Array)
NArray Class Neurotec Namespace

Creates a new array from the specified array.

C#
public static NArray FromArray(Array value);
Collapse Expand Parameters
Parameters | Description
Array value | The original array.
Collapse Expand Returns

The new array.


NArray.FromArray Method (Array, NAttributes)

NArray.FromArray Method (Array, NAttributes)
NArray Class Neurotec Namespace

Creates a new array from the specified array with specified attributes.

C#
public static NArray FromArray(Array value, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
Array value | The original array.
NAttributes attributes | Array attributes.
Collapse Expand Returns

The new array.


NArray.FromArray Method (IntPtr[])

NArray.FromArray Method (IntPtr[])
NArray Class Neurotec Namespace

Creates a new array from the specified integer pointer value array.

C#
public static NArray FromArray(IntPtr[] value);
Collapse Expand Parameters
Parameters | Description
IntPtr[] value | The original integer pointer array.
Collapse Expand Returns

The new array.


NArray.FromArray Method (IntPtr[], NAttributes)

NArray.FromArray Method (IntPtr[], NAttributes)
NArray Class Neurotec Namespace

Creates a new array from the specified integer pointer value array.

C#
public static NArray FromArray(IntPtr[] value, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
IntPtr[] value | The original integer pointer array.
NAttributes attributes | Array attributes.
Collapse Expand Returns

The new array.


NArray.FromArray Method (NType, NObject[])

NArray.FromArray Method (NType, NObject[])
NArray Class Neurotec Namespace

Creates a new array from the specified object array.

C#
public static NArray FromArray(NType type, NObject[] value);
Collapse Expand Parameters
Parameters | Description
NType type | Type of the objects the array.
NObject[] value | The original object array.
Collapse Expand Returns

The new array.


NArray.FromArray Method (NType, NObject[], NAttributes)

NArray.FromArray Method (NType, NObject[], NAttributes)
NArray Class Neurotec Namespace

Creates a new array from the specified object array.

C#
public static NArray FromArray(NType type, NObject[] value, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
NType type | Type of the objects in the array.
NObject[] value | The original object array.
NAttributes attributes | Array attributes.
Collapse Expand Returns

The new array.


NArray.FromArray<T> Method (T[])

NArray.FromArray<T> Method (T[])
NArray Class Neurotec Namespace

Creates a new array from the specified array of the specified type.

C#
public static NArray FromArray<T>(T[] value);
Collapse Expand Parameters
Parameters | Description
T[] value | The original array.
T | Array type.
Collapse Expand Returns

The new array.


NArray.FromArray<T> Method (T[], NAttributes)

NArray.FromArray<T> Method (T[], NAttributes)
NArray Class Neurotec Namespace

Creates a new array from the specified array of the specified type.

C#
public static NArray FromArray<T>(T[] value, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
T[] value | The original array.
NAttributes attributes | Array attributes.
T | Array type.
Collapse Expand Returns

The new array.


NArray.FromArray Method (UIntPtr[])

NArray.FromArray Method (UIntPtr[])
NArray Class Neurotec Namespace

Creates a new array from the specified unsigned integer pointer array.

C#
public static NArray FromArray(UIntPtr[] value);
Collapse Expand Parameters
Parameters | Description
UIntPtr[] value | The original unsigned integer pointer array.
Collapse Expand Returns

The new array.


NArray.FromArray Method (UIntPtr[], NAttributes)

NArray.FromArray Method (UIntPtr[], NAttributes)
NArray Class Neurotec Namespace

Creates a new array from the specified unsigned integer pointer array.

C#
public static NArray FromArray(UIntPtr[] value, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
UIntPtr[] value | The original unsigned integer pointer array.
NAttributes attributes | Array attributes.
Collapse Expand Returns

The new array.


NArray.FromArray Method (bool[])

NArray.FromArray Method (bool[])
NArray Class Neurotec Namespace

Creates a new array from the specified Boolean value array.

C#
public static NArray FromArray(bool[] value);
Collapse Expand Parameters
Parameters | Description
bool[] value | The original Boolean value array.
Collapse Expand Returns

The new array.


NArray.FromArray Method (bool[], NAttributes)

NArray.FromArray Method (bool[], NAttributes)
NArray Class Neurotec Namespace

Creates a new array from the specified Boolean value array.

C#
public static NArray FromArray(bool[] value, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
bool[] value | The original Boolean value array.
NAttributes attributes | Array attributes.
Collapse Expand Returns

The new array.


NArray.FromArray Method (byte[])

NArray.FromArray Method (byte[])
NArray Class Neurotec Namespace

Creates a new array from the specified byte array.

C#
public static NArray FromArray(byte[] value);
Collapse Expand Parameters
Parameters | Description
byte[] value | The original byte array.
Collapse Expand Returns

The new array.


NArray.FromArray Method (byte[], NAttributes)

NArray.FromArray Method (byte[], NAttributes)
NArray Class Neurotec Namespace

Creates a new array from the specified byte array.

C#
public static NArray FromArray(byte[] value, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
byte[] value | The original byte array.
NAttributes attributes | Array attributes.
Collapse Expand Returns

The new array.


NArray.FromArray Method (char[])

NArray.FromArray Method (char[])
NArray Class Neurotec Namespace

Creates a new array from the specified char array.

C#
public static NArray FromArray(char[] value);
Collapse Expand Parameters
Parameters | Description
char[] value | The original char array.
Collapse Expand Returns

The new array.


NArray.FromArray Method (char[], NAttributes)

NArray.FromArray Method (char[], NAttributes)
NArray Class Neurotec Namespace

Creates a new array from the specified char array.

C#
public static NArray FromArray(char[] value, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
char[] value | The original char array.
NAttributes attributes | Array attributes.
Collapse Expand Returns

The new array.


NArray.FromArray Method (double[])

NArray.FromArray Method (double[])
NArray Class Neurotec Namespace

Creates a new array from the specified double value array.

C#
public static NArray FromArray(double[] value);
Collapse Expand Parameters
Parameters | Description
double[] value | The original double value array.
Collapse Expand Returns

The new array.


NArray.FromArray Method (double[], NAttributes)

NArray.FromArray Method (double[], NAttributes)
NArray Class Neurotec Namespace

Creates a new array from the specified double value array.

C#
public static NArray FromArray(double[] value, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
double[] value | The original double value array.
NAttributes attributes | Array attributes.
Collapse Expand Returns

The new array.


NArray.FromArray Method (float[])

NArray.FromArray Method (float[])
NArray Class Neurotec Namespace

Creates a new array from the specified floating point value array.

C#
public static NArray FromArray(float[] value);
Collapse Expand Parameters
Parameters | Description
float[] value | The original floating point value array.
Collapse Expand Returns

The new array.


NArray.FromArray Method (float[], NAttributes)

NArray.FromArray Method (float[], NAttributes)
NArray Class Neurotec Namespace

Creates a new array from the specified floating point value array.

C#
public static NArray FromArray(float[] value, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
float[] value | The original floating point value array.
NAttributes attributes | Array attributes.
Collapse Expand Returns

The new array.


NArray.FromArray Method (int[])

NArray.FromArray Method (int[])
NArray Class Neurotec Namespace

Creates a new array from the specified integer array.

C#
public static NArray FromArray(int[] value);
Collapse Expand Parameters
Parameters | Description
int[] value | The original integer array.
Collapse Expand Returns

The new array.


NArray.FromArray Method (int[], NAttributes)

NArray.FromArray Method (int[], NAttributes)
NArray Class Neurotec Namespace

Creates a new array from the specified integer array.

C#
public static NArray FromArray(int[] value, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
int[] value | The original integer array.
NAttributes attributes | Array attributes.
Collapse Expand Returns

The new array.


NArray.FromArray Method (long[])

NArray.FromArray Method (long[])
NArray Class Neurotec Namespace

Creates a new array from the specified long integer array.

C#
public static NArray FromArray(long[] value);
Collapse Expand Parameters
Parameters | Description
long[] value | The original long integer array.
Collapse Expand Returns

The new array.


NArray.FromArray Method (long[], NAttributes)

NArray.FromArray Method (long[], NAttributes)
NArray Class Neurotec Namespace

Creates a new array from the specified long integer array.

C#
public static NArray FromArray(long[] value, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
long[] value | The original long integer array.
NAttributes attributes | Array attributes.
Collapse Expand Returns

The new array.


NArray.FromArray Method (sbyte[])

NArray.FromArray Method (sbyte[])
NArray Class Neurotec Namespace

Creates a new array from the specified signed byte array.

C#
public static NArray FromArray(sbyte[] value);
Collapse Expand Parameters
Parameters | Description
sbyte[] value | The original signed byte array.
Collapse Expand Returns

The new array.


NArray.FromArray Method (sbyte[], NAttributes)

NArray.FromArray Method (sbyte[], NAttributes)
NArray Class Neurotec Namespace

Creates a new array from the specified signed byte array.

C#
public static NArray FromArray(sbyte[] value, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
sbyte[] value | The original signed byte array.
NAttributes attributes | Array attributes.
Collapse Expand Returns

The new array.


NArray.FromArray Method (short[])

NArray.FromArray Method (short[])
NArray Class Neurotec Namespace

Creates a new array from the specified short integer array.

C#
public static NArray FromArray(short[] value);
Collapse Expand Parameters
Parameters | Description
short[] value | The original short integer array.
Collapse Expand Returns

The new array.


NArray.FromArray Method (short[], NAttributes)

NArray.FromArray Method (short[], NAttributes)
NArray Class Neurotec Namespace

Creates a new array from the specified short integer array.

C#
public static NArray FromArray(short[] value, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
short[] value | The original short integer array.
NAttributes attributes | Array attributes.
Collapse Expand Returns

The new array.


NArray.FromArray Method (string[])

NArray.FromArray Method (string[])
NArray Class Neurotec Namespace

Creates a new array from the specified string array.

C#
public static NArray FromArray(string[] value);
Collapse Expand Parameters
Parameters | Description
string[] value | The original string array.
Collapse Expand Returns

The new array.


NArray.FromArray Method (string[], NAttributes)

NArray.FromArray Method (string[], NAttributes)
NArray Class Neurotec Namespace

Creates a new array from the specified string array.

C#
public static NArray FromArray(string[] value, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
string[] value | The original string array.
NAttributes attributes | Array attributes.
Collapse Expand Returns

The new array.


NArray.FromArray Method (uint[])

NArray.FromArray Method (uint[])
NArray Class Neurotec Namespace

Creates a new array from the specified unsigned integer array.

C#
public static NArray FromArray(uint[] value);
Collapse Expand Parameters
Parameters | Description
uint[] value | The original unsigned integer array.
Collapse Expand Returns

The new array.


NArray.FromArray Method (uint[], NAttributes)

NArray.FromArray Method (uint[], NAttributes)
NArray Class Neurotec Namespace

Creates a new array from the specified unsigned integer array.

C#
public static NArray FromArray(uint[] value, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
uint[] value | The original unsigned integer array.
NAttributes attributes | Array attributes.
Collapse Expand Returns

The new array.


NArray.FromArray Method (ulong[])

NArray.FromArray Method (ulong[])
NArray Class Neurotec Namespace

Creates a new array from the specified unsigned long integer array.

C#
public static NArray FromArray(ulong[] value);
Collapse Expand Parameters
Parameters | Description
ulong[] value | The original unsigned long integer array.
Collapse Expand Returns

The new array.


NArray.FromArray Method (ulong[], NAttributes)

NArray.FromArray Method (ulong[], NAttributes)
NArray Class Neurotec Namespace

Creates a new array from the specified unsigned long integer array.

C#
public static NArray FromArray(ulong[] value, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
ulong[] value | The original unsigned long integer array.
NAttributes attributes | Array attributes.
Collapse Expand Returns

The new array.


NArray.FromArray Method (ushort[])

NArray.FromArray Method (ushort[])
NArray Class Neurotec Namespace

Creates a new array from the specified unsigned short integer array.

C#
public static NArray FromArray(ushort[] value);
Collapse Expand Parameters
Parameters | Description
ushort[] value | The original unsigned short integer array.
Collapse Expand Returns

The new array.


NArray.FromArray Method (ushort[], NAttributes)

NArray.FromArray Method (ushort[], NAttributes)
NArray Class Neurotec Namespace

Creates a new array from the specified unsigned short integer array.

C#
public static NArray FromArray(ushort[] value, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
ushort[] value | The original unsigned short integer array.
NAttributes attributes | Array attributes.
Collapse Expand Returns

The new array.


NArray.FromPointerArray Method (IntPtr[])

NArray.FromPointerArray Method (IntPtr[])
NArray Class Neurotec Namespace

Creates a new array from the specified integer pointer value array.

C#
public static NArray FromPointerArray(IntPtr[] value);
Collapse Expand Parameters
Parameters | Description
IntPtr[] value | The original integer pointer array.
Collapse Expand Returns

The new pointer array.


NArray.FromPointerArray Method (IntPtr[], NAttributes)

NArray.FromPointerArray Method (IntPtr[], NAttributes)
NArray Class Neurotec Namespace

Creates a new array from the specified integer pointer value array.

C#
public static NArray FromPointerArray(IntPtr[] value, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
IntPtr[] value | The original integer pointer array.
NAttributes attributes | Array attributes.
Collapse Expand Returns

The new pointer array.


NArray.FromResultArray Method (int[])

NArray.FromResultArray Method (int[])
NArray Class Neurotec Namespace

Creates a new array from the specified result array.

C#
public static NArray FromResultArray(int[] value);
Collapse Expand Parameters
Parameters | Description
int[] value | The original result array.
Collapse Expand Returns

The new result array.


NArray.FromResultArray Method (int[], NAttributes)

NArray.FromResultArray Method (int[], NAttributes)
NArray Class Neurotec Namespace

Creates a new array from the specified result array.

C#
public static NArray FromResultArray(int[] value, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
int[] value | The original result array.
NAttributes attributes | Array attributes.
Collapse Expand Returns

The new result array.


NArray.GetEnumerator Method

NArray.GetEnumerator Method
NArray Class Neurotec Namespace

Retrieves an enumerator for the current array.

C#
public IEnumerator GetEnumerator();
Collapse Expand Returns

The enumerator.


NArray.GetValueAs<T> Method (int)

NArray.GetValueAs<T> Method (int)
NArray Class Neurotec Namespace

Retrieves the of the specified value of the specified type in the array.

C#
public T GetValueAs<T>(int index);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
T | Type of the value.
Collapse Expand Returns

The value.


NArray.GetValueAs<T> Method (int, NAttributes)

NArray.GetValueAs<T> Method (int, NAttributes)
NArray Class Neurotec Namespace

Retrieves the of the specified value of the specified type in the array.

C#
public T GetValueAs<T>(int index, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
NAttributes attributes | Array attributes.
T | Type of the value.
Collapse Expand Returns

The value.


NArray.GetValueAs<T> Method (int, NAttributes, string)

NArray.GetValueAs<T> Method (int, NAttributes, string)
NArray Class Neurotec Namespace

Retrieves the of the specified value of the specified type in the array.

C#
public T GetValueAs<T>(int index, NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
NAttributes attributes | Array attributes.
string format | Value format.
T | Type of the value.
Collapse Expand Returns

The value.


NArray.GetValueAs Method (int, Type)

NArray.GetValueAs Method (int, Type)
NArray Class Neurotec Namespace
C#
public object GetValueAs(int index, Type type);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
Type type | Type of the value.
Collapse Expand Returns

The value.


NArray.GetValueAs Method (int, Type, NAttributes)

NArray.GetValueAs Method (int, Type, NAttributes)
NArray Class Neurotec Namespace

Retrieves the specified value in the array.

C#
public object GetValueAs(int index, Type type, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
Type type | Type of the value.
NAttributes attributes | Array attributes.
Collapse Expand Returns

The value.


NArray.GetValueAs Method (int, Type, NAttributes, string)

NArray.GetValueAs Method (int, Type, NAttributes, string)
NArray Class Neurotec Namespace

Retrieves the specified value in the array.

C#
public object GetValueAs(int index, Type type, NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
Type type | Type of the value.
NAttributes attributes | Array attributes.
string format | Value format.
Collapse Expand Returns

The value.


NArray.GetValueAsBoolean Method (int)

NArray.GetValueAsBoolean Method (int)
NArray Class Neurotec Namespace

Retrieves the specified Boolean value in the array.

C#
public bool GetValueAsBoolean(int index);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
Collapse Expand Returns

The Boolean value.


NArray.GetValueAsBoolean Method (int, NAttributes)

NArray.GetValueAsBoolean Method (int, NAttributes)
NArray Class Neurotec Namespace

Retrieves the specified Boolean value in the array.

C#
public bool GetValueAsBoolean(int index, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
NAttributes attributes | Array attributes.
Collapse Expand Returns

The Boolean value.


NArray.GetValueAsBoolean Method (int, NAttributes, string)

NArray.GetValueAsBoolean Method (int, NAttributes, string)
NArray Class Neurotec Namespace

Retrieves the specified Boolean value in the array.

C#
public bool GetValueAsBoolean(int index, NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
NAttributes attributes | Array attributes.
string format | Value format.
Collapse Expand Returns

The Boolean value.


NArray.GetValueAsByte Method (int)

NArray.GetValueAsByte Method (int)
NArray Class Neurotec Namespace

Retrieves the specified byte value in the array.

C#
public byte GetValueAsByte(int index);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
Collapse Expand Returns

The byte value.


NArray.GetValueAsByte Method (int, NAttributes)

NArray.GetValueAsByte Method (int, NAttributes)
NArray Class Neurotec Namespace

Retrieves the specified byte value in the array.

C#
public byte GetValueAsByte(int index, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
NAttributes attributes | Array attributes.
Collapse Expand Returns

The byte value.


NArray.GetValueAsByte Method (int, NAttributes, string)

NArray.GetValueAsByte Method (int, NAttributes, string)
NArray Class Neurotec Namespace

Retrieves the specified byte value in the array.

C#
public byte GetValueAsByte(int index, NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
NAttributes attributes | Array attributes.
string format | Value format.
Collapse Expand Returns

The byte value.


NArray.GetValueAsChar Method (int)

NArray.GetValueAsChar Method (int)
NArray Class Neurotec Namespace

Retrieves the specified char value in the array.

C#
public char GetValueAsChar(int index);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
Collapse Expand Returns

The string value.


NArray.GetValueAsChar Method (int, NAttributes)

NArray.GetValueAsChar Method (int, NAttributes)
NArray Class Neurotec Namespace

Retrieves the specified char value in the array.

C#
public char GetValueAsChar(int index, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
NAttributes attributes | Array attributes.
Collapse Expand Returns

The char value.


NArray.GetValueAsChar Method (int, NAttributes, string)

NArray.GetValueAsChar Method (int, NAttributes, string)
NArray Class Neurotec Namespace

Retrieves the specified char value in the array.

C#
public char GetValueAsChar(int index, NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
NAttributes attributes | Array attributes.
string format | Value format.
Collapse Expand Returns

The char value.


NArray.GetValueAsDouble Method (int)

NArray.GetValueAsDouble Method (int)
NArray Class Neurotec Namespace

Retrieves the specified double value in the array.

C#
public double GetValueAsDouble(int index);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
Collapse Expand Returns

The double value.


NArray.GetValueAsDouble Method (int, NAttributes)

NArray.GetValueAsDouble Method (int, NAttributes)
NArray Class Neurotec Namespace

Retrieves the specified double value in the array.

C#
public double GetValueAsDouble(int index, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
NAttributes attributes | Array attributes.
Collapse Expand Returns

The double value.


NArray.GetValueAsDouble Method (int, NAttributes, string)

NArray.GetValueAsDouble Method (int, NAttributes, string)
NArray Class Neurotec Namespace

Retrieves the specified double value in the array.

C#
public double GetValueAsDouble(int index, NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
NAttributes attributes | Array attributes.
string format | Value format.
Collapse Expand Returns

The double value.


NArray.GetValueAsInt16 Method (int)

NArray.GetValueAsInt16 Method (int)
NArray Class Neurotec Namespace

Retrieves the specified short integer value in the array.

C#
public short GetValueAsInt16(int index);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
Collapse Expand Returns

The short integer value.


NArray.GetValueAsInt16 Method (int, NAttributes)

NArray.GetValueAsInt16 Method (int, NAttributes)
NArray Class Neurotec Namespace

Retrieves the specified short integer value in the array.

C#
public short GetValueAsInt16(int index, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
NAttributes attributes | Array attributes.
Collapse Expand Returns

The short integer value.


NArray.GetValueAsInt16 Method (int, NAttributes, string)

NArray.GetValueAsInt16 Method (int, NAttributes, string)
NArray Class Neurotec Namespace

Retrieves the specified short integer value in the array.

C#
public short GetValueAsInt16(int index, NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
NAttributes attributes | Array attributes.
string format | Value format.
Collapse Expand Returns

The short integer value.


NArray.GetValueAsInt32 Method (int)

NArray.GetValueAsInt32 Method (int)
NArray Class Neurotec Namespace

Retrieves the specified integer value in the array.

C#
public int GetValueAsInt32(int index);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
Collapse Expand Returns

The integer value.


NArray.GetValueAsInt32 Method (int, NAttributes)

NArray.GetValueAsInt32 Method (int, NAttributes)
NArray Class Neurotec Namespace

Retrieves the specified integer value in the array.

C#
public int GetValueAsInt32(int index, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
NAttributes attributes | Array attributes.
Collapse Expand Returns

The integer value.


NArray.GetValueAsInt32 Method (int, NAttributes, string)

NArray.GetValueAsInt32 Method (int, NAttributes, string)
NArray Class Neurotec Namespace

Retrieves the specified integer value in the array.

C#
public int GetValueAsInt32(int index, NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
NAttributes attributes | Array attributes.
string format | Value format.
Collapse Expand Returns

The integer value.


NArray.GetValueAsInt64 Method (int)

NArray.GetValueAsInt64 Method (int)
NArray Class Neurotec Namespace

Retrieves the specified long integer value in the array.

C#
public long GetValueAsInt64(int index);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
Collapse Expand Returns

The long integer value.


NArray.GetValueAsInt64 Method (int, NAttributes)

NArray.GetValueAsInt64 Method (int, NAttributes)
NArray Class Neurotec Namespace

Retrieves the specified long integer value in the array.

C#
public long GetValueAsInt64(int index, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
NAttributes attributes | Array attributes.
Collapse Expand Returns

The long integer value.


NArray.GetValueAsInt64 Method (int, NAttributes, string)

NArray.GetValueAsInt64 Method (int, NAttributes, string)
NArray Class Neurotec Namespace

Retrieves the specified long integer value in the array.

C#
public long GetValueAsInt64(int index, NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
NAttributes attributes | Array attributes.
string format | Value format.
Collapse Expand Returns

The long integer value.


NArray.GetValueAsIntPtr Method (int)

NArray.GetValueAsIntPtr Method (int)
NArray Class Neurotec Namespace

Retrieves the specified integer pointer value in the array.

C#
public IntPtr GetValueAsIntPtr(int index);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
Collapse Expand Returns

The integer pointer value.


NArray.GetValueAsIntPtr Method (int, NAttributes)

NArray.GetValueAsIntPtr Method (int, NAttributes)
NArray Class Neurotec Namespace

Retrieves the specified integer pointer value in the array.

C#
public IntPtr GetValueAsIntPtr(int index, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
NAttributes attributes | Array attributes.
Collapse Expand Returns

The integer pointer value.


NArray.GetValueAsIntPtr Method (int, NAttributes, string)

NArray.GetValueAsIntPtr Method (int, NAttributes, string)
NArray Class Neurotec Namespace

Retrieves the specified integer pointer value in the array.

C#
public IntPtr GetValueAsIntPtr(int index, NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
NAttributes attributes | Array attributes.
string format | Value format.
Collapse Expand Returns

The integer pointer value.


NArray.GetValueAsObject Method (int, NType)

NArray.GetValueAsObject Method (int, NType)
NArray Class Neurotec Namespace

Retrieves the specified object in the array.

C#
public NObject GetValueAsObject(int index, NType type);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
NType type | Type of the object.
Collapse Expand Returns

The object.


NArray.GetValueAsObject Method (int, NType, NAttributes)

NArray.GetValueAsObject Method (int, NType, NAttributes)
NArray Class Neurotec Namespace

Retrieves the specified object in the array.

C#
public NObject GetValueAsObject(int index, NType type, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
NType type | Type of the object.
NAttributes attributes | Array attributes.
Collapse Expand Returns

The object.


NArray.GetValueAsObject Method (int, NType, NAttributes, string)

NArray.GetValueAsObject Method (int, NType, NAttributes, string)
NArray Class Neurotec Namespace

Retrieves the specified object in the array.

C#
public NObject GetValueAsObject(int index, NType type, NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
NType type | Type of the object.
NAttributes attributes | Array attributes.
string format | Value format.
Collapse Expand Returns

The object.


NArray.GetValueAsPointer Method (int)

NArray.GetValueAsPointer Method (int)
NArray Class Neurotec Namespace

Retrieves the specified integer pointer value in the array.

C#
public IntPtr GetValueAsPointer(int index);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
Collapse Expand Returns

The pointer value.


NArray.GetValueAsPointer Method (int, NAttributes)

NArray.GetValueAsPointer Method (int, NAttributes)
NArray Class Neurotec Namespace

Retrieves the specified integer pointer value in the array.

C#
public IntPtr GetValueAsPointer(int index, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
NAttributes attributes | Array attributes.
Collapse Expand Returns

The pointer value.


NArray.GetValueAsPointer Method (int, NAttributes, string)

NArray.GetValueAsPointer Method (int, NAttributes, string)
NArray Class Neurotec Namespace

Retrieves the specified integer pointer value in the array.

C#
public IntPtr GetValueAsPointer(int index, NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
NAttributes attributes | Array attributes.
string format | Value format.
Collapse Expand Returns

The pointer value.


NArray.GetValueAsResult Method (int)

NArray.GetValueAsResult Method (int)
NArray Class Neurotec Namespace

Retrieves the specified result value in the array.

C#
public int GetValueAsResult(int index);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
Collapse Expand Returns

The result value.


NArray.GetValueAsResult Method (int, NAttributes)

NArray.GetValueAsResult Method (int, NAttributes)
NArray Class Neurotec Namespace

Retrieves the specified result value in the array.

C#
public int GetValueAsResult(int index, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
NAttributes attributes | Array attributes.
Collapse Expand Returns

The result value.


NArray.GetValueAsResult Method (int, NAttributes, string)

NArray.GetValueAsResult Method (int, NAttributes, string)
NArray Class Neurotec Namespace

Retrieves the specified result value in the array.

C#
public int GetValueAsResult(int index, NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
NAttributes attributes | Array attributes.
string format | Value format.
Collapse Expand Returns

The result value.


NArray.GetValueAsSByte Method (int)

NArray.GetValueAsSByte Method (int)
NArray Class Neurotec Namespace

Retrieves the specified signed byte value in the array.

C#
public sbyte GetValueAsSByte(int index);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
Collapse Expand Returns

The signed byte value.


NArray.GetValueAsSByte Method (int, NAttributes)

NArray.GetValueAsSByte Method (int, NAttributes)
NArray Class Neurotec Namespace

Retrieves the specified signed byte value in the array.

C#
public sbyte GetValueAsSByte(int index, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
NAttributes attributes | Array attributes.
Collapse Expand Returns

The signed byte value.


NArray.GetValueAsSByte Method (int, NAttributes, string)

NArray.GetValueAsSByte Method (int, NAttributes, string)
NArray Class Neurotec Namespace

Retrieves the specified signed byte value in the array.

C#
public sbyte GetValueAsSByte(int index, NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
NAttributes attributes | Array attributes.
string format | Value format.
Collapse Expand Returns

The signed byte value.


NArray.GetValueAsSingle Method (int)

NArray.GetValueAsSingle Method (int)
NArray Class Neurotec Namespace

Retrieves the specified floating point value in the array.

C#
public float GetValueAsSingle(int index);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
Collapse Expand Returns

The floating point value.


NArray.GetValueAsSingle Method (int, NAttributes)

NArray.GetValueAsSingle Method (int, NAttributes)
NArray Class Neurotec Namespace

Retrieves the specified floating point value in the array.

C#
public float GetValueAsSingle(int index, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
NAttributes attributes | Array attributes.
Collapse Expand Returns

The floating point value.


NArray.GetValueAsSingle Method (int, NAttributes, string)

NArray.GetValueAsSingle Method (int, NAttributes, string)
NArray Class Neurotec Namespace

Retrieves the specified floating point value in the array.

C#
public float GetValueAsSingle(int index, NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
NAttributes attributes | Array attributes.
string format | Value format.
Collapse Expand Returns

The floating point value.


NArray.GetValueAsString Method (int)

NArray.GetValueAsString Method (int)
NArray Class Neurotec Namespace

Retrieves the specified string value in the array.

C#
public string GetValueAsString(int index);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
Collapse Expand Returns

The string value.


NArray.GetValueAsString Method (int, NAttributes)

NArray.GetValueAsString Method (int, NAttributes)
NArray Class Neurotec Namespace

Retrieves the specified string value in the array.

C#
public string GetValueAsString(int index, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
NAttributes attributes | Array attributes.
Collapse Expand Returns

The specified string value in the array.


NArray.GetValueAsString Method (int, NAttributes, string)

NArray.GetValueAsString Method (int, NAttributes, string)
NArray Class Neurotec Namespace

Retrieves the specified string value in the array.

C#
public string GetValueAsString(int index, NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
NAttributes attributes | Array attributes.
string format | Value format.
Collapse Expand Returns

The string value.


NArray.GetValueAsUInt16 Method (int)

NArray.GetValueAsUInt16 Method (int)
NArray Class Neurotec Namespace

Retrieves the specified unsigned short integer value in the array.

C#
public ushort GetValueAsUInt16(int index);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
Collapse Expand Returns

The unsigned short integer value.


NArray.GetValueAsUInt16 Method (int, NAttributes)

NArray.GetValueAsUInt16 Method (int, NAttributes)
NArray Class Neurotec Namespace

Retrieves the specified unsigned short integer value in the array.

C#
public ushort GetValueAsUInt16(int index, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
NAttributes attributes | Array attributes.
Collapse Expand Returns

The unsigned short integer value.


NArray.GetValueAsUInt16 Method (int, NAttributes, string)

NArray.GetValueAsUInt16 Method (int, NAttributes, string)
NArray Class Neurotec Namespace

Retrieves the specified unsigned short integer value in the array.

C#
public ushort GetValueAsUInt16(int index, NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
NAttributes attributes | Array attributes.
string format | Value format.
Collapse Expand Returns

The unsigned short integer value.


NArray.GetValueAsUInt32 Method (int)

NArray.GetValueAsUInt32 Method (int)
NArray Class Neurotec Namespace

Retrieves the specified unsigned integer value in the array.

C#
public uint GetValueAsUInt32(int index);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
Collapse Expand Returns

The unsigned integer value.


NArray.GetValueAsUInt32 Method (int, NAttributes)

NArray.GetValueAsUInt32 Method (int, NAttributes)
NArray Class Neurotec Namespace

Retrieves the specified unsigned integer value in the array.

C#
public uint GetValueAsUInt32(int index, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
NAttributes attributes | Array attributes.
Collapse Expand Returns

The unsigned integer value.


NArray.GetValueAsUInt32 Method (int, NAttributes, string)

NArray.GetValueAsUInt32 Method (int, NAttributes, string)
NArray Class Neurotec Namespace

Retrieves the specified unsigned integer value in the array.

C#
public uint GetValueAsUInt32(int index, NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
NAttributes attributes | Array attributes.
string format | Value format.
Collapse Expand Returns

The unsigned integer value.


NArray.GetValueAsUInt64 Method (int)

NArray.GetValueAsUInt64 Method (int)
NArray Class Neurotec Namespace

Retrieves the specified unsigned long integer value in the array.

C#
public ulong GetValueAsUInt64(int index);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
Collapse Expand Returns

The unsigned long integer value.


NArray.GetValueAsUInt64 Method (int, NAttributes)

NArray.GetValueAsUInt64 Method (int, NAttributes)
NArray Class Neurotec Namespace

Retrieves the specified unsigned long integer value in the array.

C#
public ulong GetValueAsUInt64(int index, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
NAttributes attributes | Array attributes.
Collapse Expand Returns

The unsigned long integer value.


NArray.GetValueAsUInt64 Method (int, NAttributes, string)

NArray.GetValueAsUInt64 Method (int, NAttributes, string)
NArray Class Neurotec Namespace

Retrieves the specified unsigned long integer value in the array.

C#
public ulong GetValueAsUInt64(int index, NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
NAttributes attributes | Array attributes.
string format | Value format.
Collapse Expand Returns

The unsigned long integer value.


NArray.GetValueAsUIntPtr Method (int)

NArray.GetValueAsUIntPtr Method (int)
NArray Class Neurotec Namespace

Retrieves the specified unsigned integer pointer value in the array.

C#
public UIntPtr GetValueAsUIntPtr(int index);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
Collapse Expand Returns

The unsigned integer pointer value.


NArray.GetValueAsUIntPtr Method (int, NAttributes)

NArray.GetValueAsUIntPtr Method (int, NAttributes)
NArray Class Neurotec Namespace

Retrieves the specified unsigned integer pointer value in the array.

C#
public UIntPtr GetValueAsUIntPtr(int index, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
NAttributes attributes | Array attributes.
Collapse Expand Returns

The unsigned integer pointer value.


NArray.GetValueAsUIntPtr Method (int, NAttributes, string)

NArray.GetValueAsUIntPtr Method (int, NAttributes, string)
NArray Class Neurotec Namespace

Retrieves the specified unsigned integer pointer value in the array.

C#
public UIntPtr GetValueAsUIntPtr(int index, NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
int index | Index of the value.
NAttributes attributes | Array attributes.
string format | Value format.
Collapse Expand Returns

The unsigned integer pointer value.


NArray.ToArray<T> Method ()

NArray.ToArray<T> Method ()
NArray Class Neurotec Namespace

Copies the current array into another array of the specified type.

C#
public T[] ToArray<T>();
Collapse Expand Parameters
Parameters | Description
T | Type of the array.
Collapse Expand Returns

Destination array.


NArray.ToArray Method (NArray)

NArray.ToArray Method (NArray)
NArray Class Neurotec Namespace

Creates a new array from the specified NArray.

C#
public static Array ToArray(NArray value);
Collapse Expand Parameters
Parameters | Description
NArray value | The original NArray
Collapse Expand Returns

The new array.


NArray.ToArray<T> Method (NAttributes)

NArray.ToArray<T> Method (NAttributes)
NArray Class Neurotec Namespace

Copies the current array into another array of the specified type.

C#
public T[] ToArray<T>(NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Array attributes.
T | Type of the array.
Collapse Expand Returns

Destination array.


NArray.ToArray<T> Method (NAttributes, string)

NArray.ToArray<T> Method (NAttributes, string)
NArray Class Neurotec Namespace

Copies the current array into another array of the specified type.

C#
public T[] ToArray<T>(NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Array attributes.
string format | Value format.
T | Type of the array.
Collapse Expand Returns

Destination array.


NArray.ToArray Method (Type)

NArray.ToArray Method (Type)
NArray Class Neurotec Namespace

Copies the current array of the specified type into another array.

C#
public Array ToArray(Type type);
Collapse Expand Parameters
Parameters | Description
Type type | Type of the array.
Collapse Expand Returns

Destination array.


NArray.ToArray Method (Type, NAttributes)

NArray.ToArray Method (Type, NAttributes)
NArray Class Neurotec Namespace

Copies the current array of the specified type into another array.

C#
public Array ToArray(Type type, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
Type type | Type of the array.
NAttributes attributes | Array attributes.
Collapse Expand Returns

Destination array.


NArray.ToArray Method (Type, NAttributes, string)

NArray.ToArray Method (Type, NAttributes, string)
NArray Class Neurotec Namespace

Copies the current array of the specified type into another array.

C#
public Array ToArray(Type type, NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
Type type | Type of the array.
NAttributes attributes | Array attributes.
string format | Value format.
Collapse Expand Returns

Destination array.


NArray.ToBooleanArray Method ()

NArray.ToBooleanArray Method ()
NArray Class Neurotec Namespace

Copies the current array into a Boolean value array.

C#
public bool[] ToBooleanArray();
Collapse Expand Returns

Destination Boolean value array.


NArray.ToBooleanArray Method (NAttributes)

NArray.ToBooleanArray Method (NAttributes)
NArray Class Neurotec Namespace

Copies the current array into a Boolean value array.

C#
public bool[] ToBooleanArray(NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Array attributes.
Collapse Expand Returns

Destination Boolean value array.


NArray.ToBooleanArray Method (NAttributes, string)

NArray.ToBooleanArray Method (NAttributes, string)
NArray Class Neurotec Namespace

Copies the current array into a Boolean value array.

C#
public bool[] ToBooleanArray(NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Array attributes.
string format | Value format.
Collapse Expand Returns

Destination Boolean value array.


NArray.ToByteArray Method ()

NArray.ToByteArray Method ()
NArray Class Neurotec Namespace

Copies the current array into a byte array.

C#
public byte[] ToByteArray();
Collapse Expand Returns

Destination byte array.


NArray.ToByteArray Method (NAttributes)

NArray.ToByteArray Method (NAttributes)
NArray Class Neurotec Namespace

Copies the current array into a byte array.

C#
public byte[] ToByteArray(NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Array attributes.
Collapse Expand Returns

Destination byte array.


NArray.ToByteArray Method (NAttributes, string)

NArray.ToByteArray Method (NAttributes, string)
NArray Class Neurotec Namespace

Copies the current array into a byte array.

C#
public byte[] ToByteArray(NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Array attributes.
string format | Value format.
Collapse Expand Returns

Destination byte array.


NArray.ToCharArray Method ()

NArray.ToCharArray Method ()
NArray Class Neurotec Namespace

Copies the current array into a char array.

C#
public char[] ToCharArray();
Collapse Expand Returns

Destination char array.


NArray.ToCharArray Method (NAttributes)

NArray.ToCharArray Method (NAttributes)
NArray Class Neurotec Namespace

Copies the current array into a char array.

C#
public char[] ToCharArray(NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Array attributes.
Collapse Expand Returns

Destination char array.


NArray.ToCharArray Method (NAttributes, string)

NArray.ToCharArray Method (NAttributes, string)
NArray Class Neurotec Namespace

Copies the current array into a char array.

C#
public char[] ToCharArray(NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Array attributes.
string format | Value format.
Collapse Expand Returns

Destination char array.


NArray.ToDoubleArray Method ()

NArray.ToDoubleArray Method ()
NArray Class Neurotec Namespace

Copies the current array into a double value array.

C#
public double[] ToDoubleArray();
Collapse Expand Returns

Destination double value array.


NArray.ToDoubleArray Method (NAttributes)

NArray.ToDoubleArray Method (NAttributes)
NArray Class Neurotec Namespace

Copies the current array into a double value array.

C#
public double[] ToDoubleArray(NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Array attributes.
Collapse Expand Returns

Destination double value array.


NArray.ToDoubleArray Method (NAttributes, string)

NArray.ToDoubleArray Method (NAttributes, string)
NArray Class Neurotec Namespace

Copies the current array into a double value array.

C#
public double[] ToDoubleArray(NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Array attributes.
string format | Value format.
Collapse Expand Returns

Destination double value array.


NArray.ToInt16Array Method ()

NArray.ToInt16Array Method ()
NArray Class Neurotec Namespace

Copies the current array into a short integer array.

C#
public short[] ToInt16Array();
Collapse Expand Returns

Destination short integer array.


NArray.ToInt16Array Method (NAttributes)

NArray.ToInt16Array Method (NAttributes)
NArray Class Neurotec Namespace

Copies the current array into a short integer array.

C#
public short[] ToInt16Array(NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Array attributes.
Collapse Expand Returns

Destination short integer array.


NArray.ToInt16Array Method (NAttributes, string)

NArray.ToInt16Array Method (NAttributes, string)
NArray Class Neurotec Namespace

Copies the current array into a short integer array.

C#
public short[] ToInt16Array(NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Array attributes.
string format | Value format.
Collapse Expand Returns

Destination short integer array.


NArray.ToInt32Array Method ()

NArray.ToInt32Array Method ()
NArray Class Neurotec Namespace

Copies the current array into an integer array.

C#
public int[] ToInt32Array();
Collapse Expand Returns

Destination integer array.


NArray.ToInt32Array Method (NAttributes)

NArray.ToInt32Array Method (NAttributes)
NArray Class Neurotec Namespace

Copies the current array into an integer array.

C#
public int[] ToInt32Array(NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Array attributes.
Collapse Expand Returns

Destination integer array.


NArray.ToInt32Array Method (NAttributes, string)

NArray.ToInt32Array Method (NAttributes, string)
NArray Class Neurotec Namespace

Copies the current array into an integer array.

C#
public int[] ToInt32Array(NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Array attributes.
string format | Value format.
Collapse Expand Returns

Destination unsigned integer array.


NArray.ToInt64Array Method ()

NArray.ToInt64Array Method ()
NArray Class Neurotec Namespace

Copies the current array into a long integer array.

C#
public long[] ToInt64Array();
Collapse Expand Returns

Destination long integer array.


NArray.ToInt64Array Method (NAttributes)

NArray.ToInt64Array Method (NAttributes)
NArray Class Neurotec Namespace

Copies the current array into a long integer array.

C#
public long[] ToInt64Array(NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Array attributes.
Collapse Expand Returns

Destination long integer array.


NArray.ToInt64Array Method (NAttributes, string)

NArray.ToInt64Array Method (NAttributes, string)
NArray Class Neurotec Namespace

Copies the current array into a long integer array.

C#
public long[] ToInt64Array(NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Array attributes.
string format | Value format.
Collapse Expand Returns

Destination long integer array.


NArray.ToIntPtrArray Method ()

NArray.ToIntPtrArray Method ()
NArray Class Neurotec Namespace

Copies the current array into an integer pointer array.

C#
public IntPtr[] ToIntPtrArray();
Collapse Expand Returns

Destination integer pointer array.


NArray.ToIntPtrArray Method (NAttributes)

NArray.ToIntPtrArray Method (NAttributes)
NArray Class Neurotec Namespace

Copies the current array into an integer pointer array.

C#
public IntPtr[] ToIntPtrArray(NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Array attributes.
Collapse Expand Returns

Destination integer pointer array.


NArray.ToIntPtrArray Method (NAttributes, string)

NArray.ToIntPtrArray Method (NAttributes, string)
NArray Class Neurotec Namespace

Copies the current array into an integer pointer array.

C#
public IntPtr[] ToIntPtrArray(NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Array attributes.
string format | Value format.
Collapse Expand Returns

Destination integer pointer array.


NArray.ToObjectArray Method (NType)

NArray.ToObjectArray Method (NType)
NArray Class Neurotec Namespace

Copies the current array into an object array.

C#
public NObject[] ToObjectArray(NType type);
Collapse Expand Parameters
Parameters | Description
NType type | Object type.
Collapse Expand Returns

Destination object array.


NArray.ToObjectArray Method (NType, NAttributes)

NArray.ToObjectArray Method (NType, NAttributes)
NArray Class Neurotec Namespace

Copies the current array into an object array.

C#
public NObject[] ToObjectArray(NType type, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
NType type | Object type.
NAttributes attributes | Array attributes.
Collapse Expand Returns

Destination object array.


NArray.ToObjectArray Method (NType, NAttributes, string)

NArray.ToObjectArray Method (NType, NAttributes, string)
NArray Class Neurotec Namespace

Copies the current array into an object array.

C#
public NObject[] ToObjectArray(NType type, NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
NType type | Object type.
NAttributes attributes | Array attributes.
string format | Value format.
Collapse Expand Returns

Destination object array.


NArray.ToPointerArray Method ()

NArray.ToPointerArray Method ()
NArray Class Neurotec Namespace

Copies the current array into a pointer array.

C#
public IntPtr[] ToPointerArray();
Collapse Expand Returns

Destination pointer array.


NArray.ToPointerArray Method (NAttributes)

NArray.ToPointerArray Method (NAttributes)
NArray Class Neurotec Namespace

Copies the current array into a pointer array.

C#
public IntPtr[] ToPointerArray(NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Array attributes.
Collapse Expand Returns

Destination pointer array.


NArray.ToPointerArray Method (NAttributes, string)

NArray.ToPointerArray Method (NAttributes, string)
NArray Class Neurotec Namespace

Copies the current array into a pointer array.

C#
public IntPtr[] ToPointerArray(NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Array attributes.
string format | Value format.
Collapse Expand Returns

Destination pointer array.


NArray.ToResultArray Method ()

NArray.ToResultArray Method ()
NArray Class Neurotec Namespace

Copies the current array into a result array.

C#
public int[] ToResultArray();
Collapse Expand Returns

Destination result array.


NArray.ToResultArray Method (NAttributes)

NArray.ToResultArray Method (NAttributes)
NArray Class Neurotec Namespace

Copies the current array into a result array.

C#
public int[] ToResultArray(NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Array attributes.
Collapse Expand Returns

Destination result array.


NArray.ToResultArray Method (NAttributes, string)

NArray.ToResultArray Method (NAttributes, string)
NArray Class Neurotec Namespace

Copies the current array into a result array.

C#
public int[] ToResultArray(NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Array attributes.
string format | Value format.
Collapse Expand Returns

Destination result array.


NArray.ToSByteArray Method ()

NArray.ToSByteArray Method ()
NArray Class Neurotec Namespace

Copies the current array into a signed byte array.

C#
public sbyte[] ToSByteArray();
Collapse Expand Returns

Destination signed byte array.


NArray.ToSByteArray Method (NAttributes)

NArray.ToSByteArray Method (NAttributes)
NArray Class Neurotec Namespace

Copies the current array into a signed byte array.

C#
public sbyte[] ToSByteArray(NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Array attributes.
Collapse Expand Returns

Destination signed byte array.


NArray.ToSByteArray Method (NAttributes, string)

NArray.ToSByteArray Method (NAttributes, string)
NArray Class Neurotec Namespace

Copies the current array into a signed byte array.

C#
public sbyte[] ToSByteArray(NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Array attributes.
string format | Value format.
Collapse Expand Returns

Destination signed byte array.


NArray.ToSingleArray Method ()

NArray.ToSingleArray Method ()
NArray Class Neurotec Namespace

Copies the current array into a floating point value array.

C#
public float[] ToSingleArray();
Collapse Expand Returns

Destination floating point value array.


NArray.ToSingleArray Method (NAttributes)

NArray.ToSingleArray Method (NAttributes)
NArray Class Neurotec Namespace

Copies the current array into a floating point value array.

C#
public float[] ToSingleArray(NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Array attributes.
Collapse Expand Returns

Destination floating point value array.


NArray.ToSingleArray Method (NAttributes, string)

NArray.ToSingleArray Method (NAttributes, string)
NArray Class Neurotec Namespace

Copies the current array into a floating point value array.

C#
public float[] ToSingleArray(NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Array attributes.
string format | Value format.
Collapse Expand Returns

Destination floating point value array.


NArray.ToStringArray Method ()

NArray.ToStringArray Method ()
NArray Class Neurotec Namespace

Copies the current array into a string array.

C#
public string[] ToStringArray();
Collapse Expand Returns

Destination string array.


NArray.ToStringArray Method (NAttributes)

NArray.ToStringArray Method (NAttributes)
NArray Class Neurotec Namespace

Copies the current array into a string array.

C#
public string[] ToStringArray(NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Array attributes.
Collapse Expand Returns

Destination string array.


NArray.ToStringArray Method (NAttributes, string)

NArray.ToStringArray Method (NAttributes, string)
NArray Class Neurotec Namespace

Copies the current array into a string array.

C#
public string[] ToStringArray(NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Array attributes.
string format | Value format.
Collapse Expand Returns

Destination string array.


NArray.ToUInt16Array Method ()

NArray.ToUInt16Array Method ()
NArray Class Neurotec Namespace

Copies the current array into an unsigned short integer array.

C#
public ushort[] ToUInt16Array();
Collapse Expand Returns

Destination unsigned short integer array.


NArray.ToUInt16Array Method (NAttributes)

NArray.ToUInt16Array Method (NAttributes)
NArray Class Neurotec Namespace

Copies the current array into an unsigned short integer array.

C#
public ushort[] ToUInt16Array(NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Array attributes.
Collapse Expand Returns

Destination unsigned short integer array.


NArray.ToUInt16Array Method (NAttributes, string)

NArray.ToUInt16Array Method (NAttributes, string)
NArray Class Neurotec Namespace

Copies the current array into an unsigned short integer array.

C#
public ushort[] ToUInt16Array(NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Array attributes.
string format | Value format.
Collapse Expand Returns

Destination unsigned short integer array.


NArray.ToUInt32Array Method ()

NArray.ToUInt32Array Method ()
NArray Class Neurotec Namespace

Copies the current array into an unsigned integer array.

C#
public uint[] ToUInt32Array();
Collapse Expand Returns

Destination unsigned integer array.


NArray.ToUInt32Array Method (NAttributes)

NArray.ToUInt32Array Method (NAttributes)
NArray Class Neurotec Namespace

Copies the current array into an unsigned integer array.

C#
public uint[] ToUInt32Array(NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Array attributes.
Collapse Expand Returns

Destination unsigned integer array.


NArray.ToUInt32Array Method (NAttributes, string)

NArray.ToUInt32Array Method (NAttributes, string)
NArray Class Neurotec Namespace

Copies the current array into an unsigned integer array.

C#
public uint[] ToUInt32Array(NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Array attributes.
string format | Value format.
Collapse Expand Returns

Destination unsigned integer array.


NArray.ToUInt64Array Method ()

NArray.ToUInt64Array Method ()
NArray Class Neurotec Namespace

Copies the current unsigned long integer array into another array.

C#
public ulong[] ToUInt64Array();
Collapse Expand Returns

Destination unsigned long integer array.


NArray.ToUInt64Array Method (NAttributes)

NArray.ToUInt64Array Method (NAttributes)
NArray Class Neurotec Namespace

Copies the current array into an unsigned long integer array.

C#
public ulong[] ToUInt64Array(NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Array attributes.
Collapse Expand Returns

Destination unsigned long integer array.


NArray.ToUInt64Array Method (NAttributes, string)

NArray.ToUInt64Array Method (NAttributes, string)
NArray Class Neurotec Namespace

Copies the current array into an unsigned long integer array.

C#
public ulong[] ToUInt64Array(NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Array attributes.
string format | Value format.
Collapse Expand Returns

Destination unsigned long integer array.


NArray.ToUIntPtrArray Method ()

NArray.ToUIntPtrArray Method ()
NArray Class Neurotec Namespace

Copies the current array into an unsigned integer pointer array.

C#
public UIntPtr[] ToUIntPtrArray();
Collapse Expand Returns

Destination unsigned integer pointer array.


NArray.ToUIntPtrArray Method (NAttributes)

NArray.ToUIntPtrArray Method (NAttributes)
NArray Class Neurotec Namespace

Copies the current array into an unsigned integer pointer array.

C#
public UIntPtr[] ToUIntPtrArray(NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Array attributes.
Collapse Expand Returns

Destination unsigned integer pointer array.


NArray.ToUIntPtrArray Method (NAttributes, string)

NArray.ToUIntPtrArray Method (NAttributes, string)
NArray Class Neurotec Namespace

Copies the current array into an unsigned integer pointer array.

C#
public UIntPtr[] ToUIntPtrArray(NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Array attributes.
string format | Value format.
Collapse Expand Returns

Destination unsigned integer pointer array.


NArray.Length Property

NArray.Length Property
NArray Class Neurotec Namespace

Retrieves the length of the array.

C#
public int Length;


NArray.NativeType Property

NArray.NativeType Property
NArray Class Neurotec Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NAsyncOperation Class

NAsyncOperation Class
NObject Delegates NObject Events NObject Fields Legend Members NDisposable Methods NDisposable Properties

Provides functionality for working with asynchronous operations. Asynchronous operations are functions and methods which return instantly, providing an object which can be used for operation's proper completion.

C#
public class NAsyncOperation : NObject, IConvertible;
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
NAsyncOperation Class
Name | Description
Completed | Adds or removes a user-specified "asynchronous operation completed" event callback.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NAsyncOperation Class
Name | Description
AsTyped<T> | Creates a new async operation with the specified return value type.
Cancel | Cancels the asynchronous operation.
GetAwaiter | Returns TaskAwaiter object.
Wait | Waits until the asynchronous operation completes.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NAsyncOperation Class
Name | Description
Error | Retrieves the exception thrown by the async operation.
IsCanceled | Checks whether the async operation has been canceled.
IsCompleted | Checks whether the async operation has been completed.
IsFaulted | Checks whether the async operation has been faulted.
NAsyncStatusNativeType | Defines the native type of the async operation status.
NativeType | Defines the native type of the object.
Result | Retireves the value returned by the async operation.
Status | Retrieves the status of the async operation.
Container

File: NAsyncOperation.cs

Namespace: Neurotec

Module: .NET Reference


NAsyncOperation.AsTyped<T> Method

NAsyncOperation.AsTyped<T> Method
NAsyncOperation Class Neurotec Namespace

Creates a new async operation with the specified return value type.

C#
public NAsyncOperation<T> AsTyped<T>();
Collapse Expand Parameters
Parameters | Description
T | Type of values returned by the async operation.
Collapse Expand Returns

A new async operation with the specified return value type.


NAsyncOperation.Cancel Method

NAsyncOperation.Cancel Method
NAsyncOperation Class Neurotec Namespace

Cancels the asynchronous operation.

C#
public void Cancel(bool block);
Collapse Expand Parameters
Parameters | Description
bool block | true if the operation can be canceled while running; else false.


NAsyncOperation.GetAwaiter Method

NAsyncOperation.GetAwaiter Method
NAsyncOperation Class Neurotec Namespace

Returns TaskAwaiter object.

C#
public TaskAwaiter GetAwaiter();
Collapse Expand Returns

TaskAwaiter object.


NAsyncOperation.Wait Method ()

NAsyncOperation.Wait Method ()
NAsyncOperation Class Neurotec Namespace

Waits until the asynchronous operation completes.

C#
public void Wait();


NAsyncOperation.Wait Method (int)

NAsyncOperation.Wait Method (int)
NAsyncOperation Class Neurotec Namespace

Waits until the asynchronous operation completes or until the wait period times out.

C#
public bool Wait(int timeOutMilliseconds);
Collapse Expand Parameters
Parameters | Description
int timeOutMilliseconds | Time out length.
Collapse Expand Returns

true if the operation was completed before time out, else false.


NAsyncOperation.Error Property

NAsyncOperation.Error Property
NAsyncOperation Class Neurotec Namespace

Retrieves the exception thrown by the async operation.

C#
public Exception Error;


NAsyncOperation.IsCanceled Property

NAsyncOperation.IsCanceled Property
NAsyncOperation Class Neurotec Namespace

Checks whether the async operation has been canceled.

C#
public bool IsCanceled;


NAsyncOperation.IsCompleted Property

NAsyncOperation.IsCompleted Property
NAsyncOperation Class Neurotec Namespace

Checks whether the async operation has been completed.

C#
public bool IsCompleted;


NAsyncOperation.IsFaulted Property

NAsyncOperation.IsFaulted Property
NAsyncOperation Class Neurotec Namespace

Checks whether the async operation has been faulted.

C#
public bool IsFaulted;


NAsyncOperation.NAsyncStatusNativeType Property

NAsyncOperation.NAsyncStatusNativeType Property
NAsyncOperation Class Neurotec Namespace

Defines the native type of the async operation status.

C#
public static NType NAsyncStatusNativeType;


NAsyncOperation.NativeType Property

NAsyncOperation.NativeType Property
NAsyncOperation Class Neurotec Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NAsyncOperation.Result Property

NAsyncOperation.Result Property
NAsyncOperation Class Neurotec Namespace

Retireves the value returned by the async operation.

C#
public object Result;


NAsyncOperation.Status Property

NAsyncOperation.Status Property
NAsyncOperation Class Neurotec Namespace

Retrieves the status of the async operation.

C#
public NAsyncStatus Status;


NAsyncOperation.Completed Event

NAsyncOperation.Completed Event
NAsyncOperation Class Neurotec Namespace

Adds or removes a user-specified "asynchronous operation completed" event callback.

C#
public event EventHandler<EventArgs> Completed;


NComplex Structure

NComplex Structure
NComplex Fields Legend Members Methods NComplex Methods NComplex Properties

Represents a complex number.

C#
[Serializable]
[StructLayout(LayoutKind.Sequential)]
public struct NComplex : IFormattable {
  public static readonly NComplex Zero = new NComplex(0, 0);
  public static readonly NComplex One = new NComplex(1, 0);
  public static readonly NComplex ImaginaryOne = new NComplex(0, 1);
}
Collapse Expand NComplex Fields
Name | Description
ImaginaryOne | Represents a NComplex with real part equal to zero and imaginary part equal to one.
One | Represents NComplex with real part equal to one and imaginary part equal to zero.
Zero | Represents a NComplex with real part equal to zero and imaginary part equal to zero.
Collapse Expand NComplex Methods
Name | Description
ToString | Retrieves a string representation of the object.
Collapse Expand NComplex Properties
Name | Description
Imaginary | Sets or retrieves the imaginary part of NComplex value.
NativeType | Defines the native type of the type.
Real | Sets or retrieves the real part of NComplex value.
Container

File: NTypes.cs

Namespace: Neurotec

Module: .NET Reference


NComplex.NComplex Constructor

NComplex.NComplex Constructor
NComplex Structure Neurotec Namespace

Initializes a new instance of the NComplex structure.

C#
public NComplex(double real, double imaginary);
Collapse Expand Parameters
Parameters | Description
double real | Real part of this NComplex.
double imaginary | Imaginary part of this NComplex.


NComplex.ImaginaryOne Field

NComplex.ImaginaryOne Field
NComplex Structure Neurotec Namespace

Represents a NComplex with real part equal to zero and imaginary part equal to one.

C#
public static readonly NComplex ImaginaryOne = new NComplex(0, 1);


NComplex.One Field

NComplex.One Field
NComplex Structure Neurotec Namespace

Represents NComplex with real part equal to one and imaginary part equal to zero.

C#
public static readonly NComplex One = new NComplex(1, 0);


NComplex.Zero Field

NComplex.Zero Field
NComplex Structure Neurotec Namespace

Represents a NComplex with real part equal to zero and imaginary part equal to zero.

C#
public static readonly NComplex Zero = new NComplex(0, 0);


NComplex.ToString Method ()

NComplex.ToString Method ()
NComplex Structure Neurotec Namespace

Retrieves a string representation of the object.

C#
public override string ToString();
Collapse Expand Returns

A string representation of an object.


NComplex.ToString Method (string)

NComplex.ToString Method (string)
NComplex Structure Neurotec Namespace

Retrieves a string representation of the object.

C#
public string ToString(string format);
Collapse Expand Parameters
Parameters | Description
string format | Format string.
Collapse Expand Returns

A string representation of an object.


NComplex.Imaginary Property

NComplex.Imaginary Property
NComplex Structure Neurotec Namespace

Sets or retrieves the imaginary part of NComplex value.

C#
public double Imaginary;


NComplex.NativeType Property

NComplex.NativeType Property
NComplex Structure Neurotec Namespace

Defines the native type of the type.

C#
public static NType NativeType;


NComplex.Real Property

NComplex.Real Property
NComplex Structure Neurotec Namespace

Sets or retrieves the real part of NComplex value.

C#
public double Real;


NCore Class

NCore Class
NCore Events NCore Fields Legend Members NCore Methods NCore Properties

This class supports internal Neurotechnology libraries infrastructure and should not be used directly in your code.

C#
public static class NCore;
Collapse Expand NCore Events
Name | Description
ErrorSuppressed | Occurs when an error is suppressed.
Collapse Expand NCore Fields
Name | Description
DllName | NCore library name.
Collapse Expand NCore Methods
Name | Description
AlignedAlloc | Allocates a block of memory and makes sure that the returned pointer can be divided evenly by alignment.
AlignedCAlloc | Allocates an array in memory with elements initialized to 0 and makes sure that the returned pointer can be divided evenly by alignment.
AlignedFree | Frees a specified aligned memory block.
AlignedReAlloc | Reallocate memory blocks, represented by a pointer that can be divided evenly by the alignment.
Alloc | Allocates a block of memory.
CAlloc | Allocates an array in memory with elements initialized to 0.
Clear | Clears all elements in the specified array.
Compare | Compares two memory blocks.
Copy | Copies data from one memory block to other.
Fill | Sets memory block to a specified value.
Free | Frees a specified memory block.
Move | Moves one memory block to another.
ReAlloc | Reallocate memory blocks.
Shutdown | Disables sends and receives on a socket.
ShutdownThread | Disables sends and receives on a thread.
Collapse Expand NCore Properties
Name | Description
NativeModule | Defines the native module of the object.
NativeType | Defines the native type of the object.
Container

File: NCore.cs

Namespace: Neurotec

Module: .NET Reference


NCore.DllName Field

NCore.DllName Field
NCore Class Neurotec Namespace

NCore library name.

C#
public const string DllName = NVersionInfo.CoreDllName;


NCore.AlignedAlloc Method (UIntPtr, UIntPtr)

NCore.AlignedAlloc Method (UIntPtr, UIntPtr)
NCore Class Neurotec Namespace

Allocates a block of memory and makes sure that the returned pointer can be divided evenly by alignment.

C#
public static IntPtr AlignedAlloc(UIntPtr size, UIntPtr alignment);
Collapse Expand Parameters
Parameters | Description
UIntPtr size | Size in bytes of memory to be allocated.
UIntPtr alignment | The alignment.
Collapse Expand Returns

A representation of a pointer (IntPtr type) to the allocated memory block. Can be divided evenly by the alignment.


NCore.AlignedAlloc Method (UIntPtr, UIntPtr, UIntPtr)

NCore.AlignedAlloc Method (UIntPtr, UIntPtr, UIntPtr)
NCore Class Neurotec Namespace

Allocates a block of memory and makes sure that the sum of returned pointer and the offset can be divided evenly by alignment.

C#
public static IntPtr AlignedAlloc(UIntPtr size, UIntPtr alignment, UIntPtr offset);
Collapse Expand Parameters
Parameters | Description
UIntPtr size | Size in bytes of memory to be allocated.
UIntPtr alignment | The alignment.
UIntPtr offset | The offset.
Collapse Expand Returns

A representation of a pointer (IntPtr type) to the allocated memory block. Its sum with offset can be divided evenly by the alignment.


NCore.AlignedAlloc Method (int, int)

NCore.AlignedAlloc Method (int, int)
NCore Class Neurotec Namespace

Allocates a block of memory and makes sure that the returned pointer can be divided evenly by alignment.

C#
public static IntPtr AlignedAlloc(int size, int alignment);
Collapse Expand Parameters
Parameters | Description
int size | Size in bytes of memory to be allocated.
int alignment | The alignment.
Collapse Expand Returns

A representation of a pointer (IntPtr type) to the allocated memory block. Can be divided evenly by the alignment.


NCore.AlignedAlloc Method (int, int, int)

NCore.AlignedAlloc Method (int, int, int)
NCore Class Neurotec Namespace

Allocates a block of memory and makes sure that the sum of returned pointer and the offset can be divided evenly by alignment.

C#
public static IntPtr AlignedAlloc(int size, int alignment, int offset);
Collapse Expand Parameters
Parameters | Description
int size | Size in bytes of memory to be allocated.
int alignment | The alignment.
int offset | The offset.
Collapse Expand Returns

A representation of a pointer (IntPtr type) to the allocated memory block. Its sum with offset can be divided evenly by the alignment.


NCore.AlignedAlloc Method (long, long)

NCore.AlignedAlloc Method (long, long)
NCore Class Neurotec Namespace

Allocates a block of memory and makes sure that the returned pointer can be divided evenly by alignment.

C#
public static IntPtr AlignedAlloc(long size, long alignment);
Collapse Expand Parameters
Parameters | Description
long size | Size in bytes of memory to be allocated.
long alignment | The alignment.
Collapse Expand Returns

A representation of a pointer (IntPtr type) to the allocated memory block. Can be divided evenly by the alignment.


NCore.AlignedAlloc Method (long, long, long)

NCore.AlignedAlloc Method (long, long, long)
NCore Class Neurotec Namespace

Allocates a block of memory and makes sure that the sum of returned pointer and the offset can be divided evenly by alignment.

C#
public static IntPtr AlignedAlloc(long size, long alignment, long offset);
Collapse Expand Parameters
Parameters | Description
long size | Size in bytes of memory to be allocated.
long alignment | The alignment.
long offset | The offset.
Collapse Expand Returns

A representation of a pointer (IntPtr type) to the allocated memory block. Its sum with offset can be divided evenly by the alignment.


NCore.AlignedCAlloc Method (UIntPtr, UIntPtr)

NCore.AlignedCAlloc Method (UIntPtr, UIntPtr)
NCore Class Neurotec Namespace

Allocates an array in memory with elements initialized to 0 and makes sure that the returned pointer can be divided evenly by alignment.

C#
public static IntPtr AlignedCAlloc(UIntPtr size, UIntPtr alignment);
Collapse Expand Parameters
Parameters | Description
UIntPtr size | Size in bytes of memory to be allocated.
UIntPtr alignment | The alignment.
Collapse Expand Returns

A representation of a pointer (IntPtr type) to the allocated memory block. Can be divided evenly by the alignment.


NCore.AlignedCAlloc Method (UIntPtr, UIntPtr, UIntPtr)

NCore.AlignedCAlloc Method (UIntPtr, UIntPtr, UIntPtr)
NCore Class Neurotec Namespace

Allocates an array in memory with elements initialized to 0 and makes sure that the sum of returned pointer and the offset can be divided evenly by alignment.

C#
public static IntPtr AlignedCAlloc(UIntPtr size, UIntPtr alignment, UIntPtr offset);
Collapse Expand Parameters
Parameters | Description
UIntPtr size | Size in bytes of memory to be allocated.
UIntPtr alignment | The alignment.
UIntPtr offset | The offset.
Collapse Expand Returns

A representation of a pointer (IntPtr type) to the allocated memory block. Its sum with offset can be divided evenly by the alignment.


NCore.AlignedCAlloc Method (int, int)

NCore.AlignedCAlloc Method (int, int)
NCore Class Neurotec Namespace

Allocates an array in memory with elements initialized to 0 and makes sure that the returned pointer can be divided evenly by alignment.

C#
public static IntPtr AlignedCAlloc(int size, int alignment);
Collapse Expand Parameters
Parameters | Description
int size | Size in bytes of memory to be allocated.
int alignment | The alignment.
Collapse Expand Returns

A representation of a pointer (IntPtr type) to the allocated memory block. Can be divided evenly by the alignment.


NCore.AlignedCAlloc Method (int, int, int)

NCore.AlignedCAlloc Method (int, int, int)
NCore Class Neurotec Namespace

Allocates an array in memory with elements initialized to 0 and makes sure that the sum of returned pointer and the offset can be divided evenly by alignment.

C#
public static IntPtr AlignedCAlloc(int size, int alignment, int offset);
Collapse Expand Parameters
Parameters | Description
int size | Size in bytes of memory to be allocated.
int alignment | The alignment.
int offset | The offset.
Collapse Expand Returns

A representation of a pointer (IntPtr type) to the allocated memory block. Its sum with offset can be divided evenly by the alignment.


NCore.AlignedCAlloc Method (long, long)

NCore.AlignedCAlloc Method (long, long)
NCore Class Neurotec Namespace

Allocates an array in memory with elements initialized to 0 and makes sure that the returned pointer can be divided evenly by alignment.

C#
public static IntPtr AlignedCAlloc(long size, long alignment);
Collapse Expand Parameters
Parameters | Description
long size | Size in bytes of memory to be allocated.
long alignment | The alignment.
Collapse Expand Returns

A representation of a pointer (IntPtr type) to the allocated memory block. Can be divided evenly by the alignment.


NCore.AlignedCAlloc Method (long, long, long)

NCore.AlignedCAlloc Method (long, long, long)
NCore Class Neurotec Namespace

Allocates an array in memory with elements initialized to 0 and makes sure that the sum of returned pointer and the offset can be divided evenly by alignment.

C#
public static IntPtr AlignedCAlloc(long size, long alignment, long offset);
Collapse Expand Parameters
Parameters | Description
long size | Size in bytes of memory to be allocated.
long alignment | The alignment.
long offset | The offset.
Collapse Expand Returns

A representation of a pointer (IntPtr type) to the allocated memory block. Its sum with offset can be divided evenly by the alignment.


NCore.AlignedFree Method

NCore.AlignedFree Method
NCore Class Neurotec Namespace

Frees a specified aligned memory block.

C#
public static void AlignedFree(IntPtr pBlock);
Collapse Expand Parameters
Parameters | Description
IntPtr pBlock | A representation of a pointer (IntPtr type) to the memory block. Its sum with the offset an be divided evenly by the memory block's alignment.


NCore.AlignedReAlloc Method (IntPtr, UIntPtr, UIntPtr)

NCore.AlignedReAlloc Method (IntPtr, UIntPtr, UIntPtr)
NCore Class Neurotec Namespace

Reallocate memory blocks, represented by a pointer that can be divided evenly by the alignment.

C#
public static void AlignedReAlloc(ref IntPtr pBlock, UIntPtr size, UIntPtr alignment);
Collapse Expand Parameters
Parameters | Description
ref IntPtr pBlock | A representation of a pointer (IntPtr type) to the allocated memory block. Can be divided evenly by the alignment.
UIntPtr size | Size in bytes of memory to be allocated.
UIntPtr alignment | The alignment.


NCore.AlignedReAlloc Method (IntPtr, UIntPtr, UIntPtr, UIntPtr)

NCore.AlignedReAlloc Method (IntPtr, UIntPtr, UIntPtr, UIntPtr)
NCore Class Neurotec Namespace

Reallocate memory blocks, represented by a pointer. A sum of the pointer and an offset can be divided evenly by the alignment.

C#
public static void AlignedReAlloc(ref IntPtr pBlock, UIntPtr size, UIntPtr alignment, UIntPtr offset);
Collapse Expand Parameters
Parameters | Description
ref IntPtr pBlock | A representation of a pointer (IntPtr type) to the allocated memory block. Its sum with the offset an be divided evenly by the alignment.
UIntPtr size | Size in bytes of memory to be allocated.
UIntPtr alignment | The alignment.
UIntPtr offset | The offset.


NCore.AlignedReAlloc Method (IntPtr, int, int)

NCore.AlignedReAlloc Method (IntPtr, int, int)
NCore Class Neurotec Namespace

Reallocate memory blocks, represented by a pointer that can be divided evenly by the alignment.

C#
public static void AlignedReAlloc(ref IntPtr pBlock, int size, int alignment);
Collapse Expand Parameters
Parameters | Description
ref IntPtr pBlock | A representation of a pointer (IntPtr type) to the allocated memory block. Can be divided evenly by the alignment.
int size | Size in bytes of memory to be allocated.
int alignment | The alignment.


NCore.AlignedReAlloc Method (IntPtr, int, int, int)

NCore.AlignedReAlloc Method (IntPtr, int, int, int)
NCore Class Neurotec Namespace

Reallocate memory blocks, represented by a pointer. A sum of the pointer and an offset can be divided evenly by the alignment.

C#
public static void AlignedReAlloc(ref IntPtr pBlock, int size, int alignment, int offset);
Collapse Expand Parameters
Parameters | Description
ref IntPtr pBlock | A representation of a pointer (IntPtr type) to the allocated memory block. Its sum with the offset an be divided evenly by the alignment.
int size | Size in bytes of memory to be allocated.
int alignment | The alignment.
int offset | The offset.


NCore.AlignedReAlloc Method (IntPtr, long, long)

NCore.AlignedReAlloc Method (IntPtr, long, long)
NCore Class Neurotec Namespace

Reallocate memory blocks, represented by a pointer that can be divided evenly by the alignment.

C#
public static void AlignedReAlloc(ref IntPtr pBlock, long size, long alignment);
Collapse Expand Parameters
Parameters | Description
ref IntPtr pBlock | A representation of a pointer (IntPtr type) to the allocated memory block. Can be divided evenly by the alignment.
long size | Size in bytes of memory to be allocated.
long alignment | The alignment.


NCore.AlignedReAlloc Method (IntPtr, long, long, long)

NCore.AlignedReAlloc Method (IntPtr, long, long, long)
NCore Class Neurotec Namespace

Reallocate memory blocks, represented by a pointer. A sum of the pointer and an offset can be divided evenly by the alignment.

C#
public static void AlignedReAlloc(ref IntPtr pBlock, long size, long alignment, long offset);
Collapse Expand Parameters
Parameters | Description
ref IntPtr pBlock | A representation of a pointer (IntPtr type) to the allocated memory block. Its sum with the offset an be divided evenly by the alignment.
long size | Size in bytes of memory to be allocated.
long alignment | The alignment.
long offset | The offset.


NCore.Alloc Method (UIntPtr)

NCore.Alloc Method (UIntPtr)
NCore Class Neurotec Namespace

Allocates a block of memory.

C#
public static IntPtr Alloc(UIntPtr size);
Collapse Expand Parameters
Parameters | Description
UIntPtr size | Size in bytes of memory to be allocated.
Collapse Expand Returns

A representation of a pointer (IntPtr type) to the allocated memory block.


NCore.Alloc Method (int)

NCore.Alloc Method (int)
NCore Class Neurotec Namespace

Allocates a block of memory.

C#
public static IntPtr Alloc(int size);
Collapse Expand Parameters
Parameters | Description
int size | Size in bytes of memory to be allocated.
Collapse Expand Returns

A representation of a pointer (IntPtr type) to the allocated memory block.


NCore.Alloc Method (long)

NCore.Alloc Method (long)
NCore Class Neurotec Namespace

Allocates a block of memory.

C#
public static IntPtr Alloc(long size);
Collapse Expand Parameters
Parameters | Description
long size | Size in bytes of memory to be allocated.
Collapse Expand Returns

A representation of a pointer (IntPtr type) to the allocated memory block.


NCore.CAlloc Method (UIntPtr)

NCore.CAlloc Method (UIntPtr)
NCore Class Neurotec Namespace

Allocates an array in memory with elements initialized to 0.

C#
public static IntPtr CAlloc(UIntPtr size);
Collapse Expand Parameters
Parameters | Description
UIntPtr size | Size in bytes of memory to be allocated.
Collapse Expand Returns

Pointer to allocated memory block.


NCore.CAlloc Method (int)

NCore.CAlloc Method (int)
NCore Class Neurotec Namespace

Allocates an array in memory with elements initialized to 0.

C#
public static IntPtr CAlloc(int size);
Collapse Expand Parameters
Parameters | Description
int size | Size in bytes of memory to be allocated.
Collapse Expand Returns

Pointer to allocated memory block.


NCore.CAlloc Method (long)

NCore.CAlloc Method (long)
NCore Class Neurotec Namespace

Allocates an array in memory with elements initialized to 0.

C#
public static IntPtr CAlloc(long size);
Collapse Expand Parameters
Parameters | Description
long size | Size in bytes of memory to be allocated.
Collapse Expand Returns

Pointer to allocated memory block.


NCore.Clear Method (IntPtr, UIntPtr)

NCore.Clear Method (IntPtr, UIntPtr)
NCore Class Neurotec Namespace

Clears all elements in the specified array.

C#
public static void Clear(IntPtr pBlock, UIntPtr size);
Collapse Expand Parameters
Parameters | Description
IntPtr pBlock | A pointer to memory block that contains an array.
UIntPtr size | The size in bytes of an array.


NCore.Clear Method (IntPtr, int)

NCore.Clear Method (IntPtr, int)
NCore Class Neurotec Namespace

Clears all elements in the specified array.

C#
public static void Clear(IntPtr pBlock, int size);
Collapse Expand Parameters
Parameters | Description
IntPtr pBlock | A pointer to memory block that contains an array.
int size | The size in bytes of an array.


NCore.Clear Method (IntPtr, long)

NCore.Clear Method (IntPtr, long)
NCore Class Neurotec Namespace

Clears all elements in the specified array.

C#
public static void Clear(IntPtr pBlock, long size);
Collapse Expand Parameters
Parameters | Description
IntPtr pBlock | A pointer to memory block that contains an array.
long size | The size in bytes of an array.


NCore.Compare Method (IntPtr, IntPtr, UIntPtr)

NCore.Compare Method (IntPtr, IntPtr, UIntPtr)
NCore Class Neurotec Namespace

Compares two memory blocks.

C#
public static int Compare(IntPtr pBlock1, IntPtr pBlock2, UIntPtr size);
Collapse Expand Parameters
Parameters | Description
IntPtr pBlock1 | A pointer to the first memory block.
IntPtr pBlock2 | A pointer to the second memory block.
UIntPtr size | Number of characters to be compared.
Collapse Expand Returns

The value indicating the relationship between the memory blocks.

If return value is less than zero a block specified by pBlock1 is less than a block specified by pBlock2.

if return value is zero a block specified by pBlock1 is identical to a block specified by pBlock2.

If return value is greater than zero a block specified by pBlock1 is greater than a block specified by pBlock2.


NCore.Compare Method (IntPtr, IntPtr, int)

NCore.Compare Method (IntPtr, IntPtr, int)
NCore Class Neurotec Namespace

Compares two memory blocks.

C#
public static int Compare(IntPtr pBlock1, IntPtr pBlock2, int size);
Collapse Expand Parameters
Parameters | Description
IntPtr pBlock1 | A pointer to the first memory block.
IntPtr pBlock2 | A pointer to the second memory block.
int size | Number of characters to be compared.
Collapse Expand Returns

The value indicating the relationship between the memory blocks.

If return value is less than zero a block specified by pBlock1 is less than a block specified by pBlock2.

if return value is zero a block specified by pBlock1 is identical to a block specified by pBlock2.

If return value is greater than zero a block specified by pBlock1 is greater than a block specified by pBlock2.


NCore.Compare Method (IntPtr, IntPtr, long)

NCore.Compare Method (IntPtr, IntPtr, long)
NCore Class Neurotec Namespace

Compares two memory blocks.

C#
public static int Compare(IntPtr pBlock1, IntPtr pBlock2, long size);
Collapse Expand Parameters
Parameters | Description
IntPtr pBlock1 | A pointer to the first memory block.
IntPtr pBlock2 | A pointer to the second memory block.
long size | Number of characters to be compared.
Collapse Expand Returns

The value indicating the relationship between the memory blocks.

If return value is less than zero a block specified by pBlock1 is less than a block specified by pBlock2.

if return value is zero a block specified by pBlock1 is identical to a block specified by pBlock2.

If return value is greater than zero a block specified by pBlock1 is greater than a block specified by pBlock2.


NCore.Copy Method (IntPtr, IntPtr, UIntPtr)

NCore.Copy Method (IntPtr, IntPtr, UIntPtr)
NCore Class Neurotec Namespace

Copies data from one memory block to other.

C#
public static void Copy(IntPtr pDstBlock, IntPtr pSrcBlock, UIntPtr size);
Collapse Expand Parameters
Parameters | Description
IntPtr pDstBlock | A pointer to destination memory block (a memory block where the data from source memory block will be copied).
IntPtr pSrcBlock | A pointer to memory block to be copied to another memory block.
UIntPtr size | The size of memory block to be copied (the size is in bytes).


NCore.Copy Method (IntPtr, IntPtr, int)

NCore.Copy Method (IntPtr, IntPtr, int)
NCore Class Neurotec Namespace

Copies data from one memory block to other.

C#
public static void Copy(IntPtr pDstBlock, IntPtr pSrcBlock, int size);
Collapse Expand Parameters
Parameters | Description
IntPtr pDstBlock | A pointer to destination memory block (a memory block where the data from source memory block will be copied).
IntPtr pSrcBlock | A pointer to memory block to be copied to another memory block.
int size | The size of memory block to be copied (the size is in bytes).


NCore.Copy Method (IntPtr, IntPtr, long)

NCore.Copy Method (IntPtr, IntPtr, long)
NCore Class Neurotec Namespace

Copies data from one memory block to other.

C#
public static void Copy(IntPtr pDstBlock, IntPtr pSrcBlock, long size);
Collapse Expand Parameters
Parameters | Description
IntPtr pDstBlock | A pointer to destination memory block (a memory block where the data from source memory block will be copied).
IntPtr pSrcBlock | A pointer to memory block to be copied to another memory block.
long size | The size of memory block to be copied (the size is in bytes).


NCore.Fill Method (IntPtr, byte, UIntPtr)

NCore.Fill Method (IntPtr, byte, UIntPtr)
NCore Class Neurotec Namespace

Sets memory block to a specified value.

C#
public static void Fill(IntPtr pBlock, byte value, UIntPtr size);
Collapse Expand Parameters
Parameters | Description
IntPtr pBlock | A pointer to a destination memory block that contains data.
byte value | A value to set.
UIntPtr size | The size in bytes of memory block to be set.


NCore.Fill Method (IntPtr, byte, int)

NCore.Fill Method (IntPtr, byte, int)
NCore Class Neurotec Namespace

Sets memory block to a specified value.

C#
public static void Fill(IntPtr pBlock, byte value, int size);
Collapse Expand Parameters
Parameters | Description
IntPtr pBlock | A pointer to a destination memory block that contains data.
byte value | A value to set.
int size | The size in bytes of memory block to be set.


NCore.Fill Method (IntPtr, byte, long)

NCore.Fill Method (IntPtr, byte, long)
NCore Class Neurotec Namespace

Sets memory block to a specified value.

C#
public static void Fill(IntPtr pBlock, byte value, long size);
Collapse Expand Parameters
Parameters | Description
IntPtr pBlock | A pointer to a destination memory block that contains data.
byte value | A value to set.
long size | The size in bytes of memory block to be set.


NCore.Free Method (IntPtr)

NCore.Free Method (IntPtr)
NCore Class Neurotec Namespace

Frees a specified memory block.

C#
public static void Free(IntPtr pBlock);
Collapse Expand Parameters
Parameters | Description
IntPtr pBlock | A pointer to previously allocated memory block to be freed.
Collapse Expand Remarks

The Free method frees a memory block that was previously allocated by a call to Alloc, CAlloc or ReAlloc methods. The number of freed bytes is equivalent to the number of bytes requested when the block was allocated (or reallocated, in the case of ReAlloc).


NCore.Free Method (IntPtr, NMemoryType)

NCore.Free Method (IntPtr, NMemoryType)
NCore Class Neurotec Namespace

Frees a specified memory block.

C#
public static void Free(IntPtr pBlock, NMemoryType memoryType);
Collapse Expand Parameters
Parameters | Description
IntPtr pBlock | A pointer to previously allocated memory block to be freed.
NMemoryType memoryType | Type of the memory block to be freed.
Collapse Expand Remarks

The Free method frees a memory block that was previously allocated by a call to Alloc, CAlloc or ReAlloc methods. The number of freed bytes is equivalent to the number of bytes requested when the block was allocated (or reallocated, in the case of ReAlloc).


NCore.Move Method (IntPtr, IntPtr, UIntPtr)

NCore.Move Method (IntPtr, IntPtr, UIntPtr)
NCore Class Neurotec Namespace

Moves one memory block to another.

C#
public static void Move(IntPtr pDstBlock, IntPtr pSrcBlock, UIntPtr size);
Collapse Expand Parameters
Parameters | Description
IntPtr pDstBlock | A pointer to destination memory block.
IntPtr pSrcBlock | A pointer to source memory block.
UIntPtr size | Size in bytes to be copied.
Collapse Expand Remarks

Copies size bytes from pDstBlock to pSrcBlock.

Make sure that the destination buffer is the same size or larger than the source buffer.


NCore.Move Method (IntPtr, IntPtr, int)

NCore.Move Method (IntPtr, IntPtr, int)
NCore Class Neurotec Namespace

Moves one memory block to another.

C#
public static void Move(IntPtr pDstBlock, IntPtr pSrcBlock, int size);
Collapse Expand Parameters
Parameters | Description
IntPtr pDstBlock | A pointer to destination memory block.
IntPtr pSrcBlock | A pointer to source memory block.
int size | Size in bytes to be copied.
Collapse Expand Remarks

Copies size bytes from pDstBlock to pSrcBlock.

Make sure that the destination buffer is the same size or larger than the source buffer.


NCore.Move Method (IntPtr, IntPtr, long)

NCore.Move Method (IntPtr, IntPtr, long)
NCore Class Neurotec Namespace

Moves one memory block to another.

C#
public static void Move(IntPtr pDstBlock, IntPtr pSrcBlock, long size);
Collapse Expand Parameters
Parameters | Description
IntPtr pDstBlock | A pointer to destination memory block.
IntPtr pSrcBlock | A pointer to source memory block.
long size | Size in bytes to be copied.
Collapse Expand Remarks

Copies size bytes from pDstBlock to pSrcBlock.

Make sure that the destination buffer is the same size or larger than the source buffer.


NCore.ReAlloc Method (IntPtr, UIntPtr)

NCore.ReAlloc Method (IntPtr, UIntPtr)
NCore Class Neurotec Namespace

Reallocate memory blocks.

C#
public static void ReAlloc(ref IntPtr pBlock, UIntPtr size);
Collapse Expand Parameters
Parameters | Description
ref IntPtr pBlock | Pointer to memory block to be allocated.
UIntPtr size | Size in bytes of new memory block.


NCore.ReAlloc Method (IntPtr, int)

NCore.ReAlloc Method (IntPtr, int)
NCore Class Neurotec Namespace

Reallocate memory blocks.

C#
public static void ReAlloc(ref IntPtr pBlock, int size);
Collapse Expand Parameters
Parameters | Description
ref IntPtr pBlock | Pointer to memory block to be allocated.
int size | Size in bytes of new memory block.


NCore.ReAlloc Method (IntPtr, long)

NCore.ReAlloc Method (IntPtr, long)
NCore Class Neurotec Namespace

Reallocate memory blocks.

C#
public static void ReAlloc(ref IntPtr pBlock, long size);
Collapse Expand Parameters
Parameters | Description
ref IntPtr pBlock | Pointer to memory block to be allocated.
long size | Size in bytes of new memory block.


NCore.Shutdown Method

NCore.Shutdown Method
NCore Class Neurotec Namespace

Disables sends and receives on a socket.

C#
public static void Shutdown();


NCore.ShutdownThread Method

NCore.ShutdownThread Method
NCore Class Neurotec Namespace

Disables sends and receives on a thread.

C#
public static void ShutdownThread();


NCore.NativeModule Property

NCore.NativeModule Property
NCore Class Neurotec Namespace

Defines the native module of the object.

C#
public static NModule NativeModule;


NCore.NativeType Property

NCore.NativeType Property
NCore Class Neurotec Namespace

Defines the native type of the object.

C#
public static NType NativeType;


NCore.ErrorSuppressed Event

NCore.ErrorSuppressed Event
NCore Class Neurotec Namespace

Occurs when an error is suppressed.

C#
public static event EventHandler<ErrorSuppressedEventArgs> ErrorSuppressed;


NDisposable Class

NDisposable Class
Legend Members NDisposable Methods NDisposable Properties

Provides a method to release allocated resources.

C#
public abstract class NDisposable : MarshalByRefObject, IDisposable;
Collapse Expand NDisposable Methods
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
Collapse Expand NDisposable Properties
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
Container

File: NDisposable.cs

Namespace: Neurotec

Module: .NET Reference


NDisposable.Dispose Method

NDisposable.Dispose Method
NDisposable Class Neurotec Namespace

Performs tasks associated with freeing, releasing, or resetting unmanaged resources.

C#
public virtual void Dispose();
Collapse Expand Remarks

This method is used to close or release unmanaged resources. By convention, this method is used for all tasks associated with freeing resources held by an object.


NDisposable.IsDisposed Property

NDisposable.IsDisposed Property
NDisposable Class Neurotec Namespace

Gets whether allocated resources were released previously.

C#
public virtual bool IsDisposed;


NError Class

NError Class
Legend Members NError Methods

Defines error codes used in Neurotechnology components.

C#
public static class NError;
Collapse Expand NError Methods
Name | Description
Get | Gets the specified exception.
GetDefaultMessage | Gets the default error message.
GetLast | Gets the last exception.
GetMacErrorMessage | Gets Mac OS X error message.
GetMessage | Retrieves an exception message.
GetSysErrorMessage | Gets system error message.
SetLast | Sets the last exception.
Suppress | Suppressed the specified exception.
ToString | Retrieves a string representation of the specified exception.
Container

File: NError.cs

Namespace: Neurotec

Module: .NET Reference


NError.Get Method (HNObject)

NError.Get Method (HNObject)
NError Class Neurotec Namespace

Gets the specified exception.

C#
public static Exception Get(HNObject hError);
Collapse Expand Parameters
Parameters | Description
HNObject hError | Handle to the error object.
Collapse Expand Returns

The exception.


NError.Get Method (int, HNObject)

NError.Get Method (int, HNObject)
NError Class Neurotec Namespace

Gets the specified exception.

C#
public static Exception Get(int code, HNObject hError);
Collapse Expand Parameters
Parameters | Description
int code | Exception code.
HNObject hError | Handle to the error object.
Collapse Expand Returns

The exception.


NError.GetDefaultMessage Method

NError.GetDefaultMessage Method
NError Class Neurotec Namespace

Gets the default error message.

C#
public static string GetDefaultMessage(int code);
Collapse Expand Parameters
Parameters | Description
int code | Exception code.
Collapse Expand Returns

The error message.


NError.GetLast Method

NError.GetLast Method
NError Class Neurotec Namespace

Gets the last exception.

C#
public static Exception GetLast(int code);
Collapse Expand Parameters
Parameters | Description
int code | Exception code.
Collapse Expand Returns

The exception.


NError.GetMacErrorMessage Method

NError.GetMacErrorMessage Method
NError Class Neurotec Namespace

Gets Mac OS X error message.

C#
public static string GetMacErrorMessage(int err);
Collapse Expand Parameters
Parameters | Description
int err | Exception number.
Collapse Expand Returns

The error message.


NError.GetMessage Method

NError.GetMessage Method
NError Class Neurotec Namespace

Retrieves an exception message.

C#
public static string GetMessage(string message, string paramName, string param);
Collapse Expand Parameters
Parameters | Description
string message | Base message.
string paramName | Parameter name.
string param | Parameter value.
Collapse Expand Returns

Exception message.


NError.GetSysErrorMessage Method

NError.GetSysErrorMessage Method
NError Class Neurotec Namespace

Gets system error message.

C#
public static string GetSysErrorMessage(int errno);
Collapse Expand Parameters
Parameters | Description
int errno | Exception number.
Collapse Expand Returns

The error message.


NError.SetLast Method

NError.SetLast Method
NError Class Neurotec Namespace

Sets the last exception.

C#
[MethodImpl(MethodImplOptions.NoInlining)]
public static int SetLast(Exception error);
Collapse Expand Parameters
Parameters | Description
Exception error | The last exception.
Collapse Expand Returns

Exception code.


NError.Suppress Method

NError.Suppress Method
NError Class Neurotec Namespace

Suppressed the specified exception.

C#
public static void Suppress(Exception error);
Collapse Expand Parameters
Parameters | Description
Exception error | The exception to be suppressed.


NError.ToString Method

NError.ToString Method
NError Class Neurotec Namespace

Retrieves a string representation of the specified exception.

C#
public static string ToString(Exception e, string additionalCode);
Collapse Expand Parameters
Parameters | Description
Exception e | The exception.
string additionalCode | Additional exception code.
Collapse Expand Returns

String representation of the exception.


NExpandableObject Class

NExpandableObject Class
NObject Delegates NObject Events NObject Fields Legend Members NDisposable Methods NDisposable Properties

Provides functionality for retrieving information about specified object.

C#
public class NExpandableObject : NObject, ICloneable;
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NExpandableObject Class
Name | Description
NativeType | Defines the native type of the object.
Properties | Gets the property bag of the expandable object.
Container

File: NExpandableObject.cs

Namespace: Neurotec

Module: .NET Reference


NExpandableObject.NativeType Property

NExpandableObject.NativeType Property
NExpandableObject Class Neurotec Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NExpandableObject.Properties Property

NExpandableObject.Properties Property
NExpandableObject Class Neurotec Namespace

Gets the property bag of the expandable object.

C#
public NPropertyBag Properties;


NIndexPair Structure

NIndexPair Structure
Legend Members Methods NIndexPair Methods NIndexPair Properties

Represents pair of indexes.

C#
[Serializable]
[StructLayout(LayoutKind.Sequential)]
public struct NIndexPair : IFormattable {
}
Collapse Expand NIndexPair Methods
Name | Description
ToString | Retrieves a string representation of the object.
Collapse Expand NIndexPair Properties
Name | Description
Index1 | Gets or sets first index of this NIndexPair.
Index2 | Gets or sets second index of this NIndexPair.
NativeType | Defines the native type of the type.
Container

File: NTypes.cs

Namespace: Neurotec

Module: .NET Reference


NIndexPair.NIndexPair Constructor

NIndexPair.NIndexPair Constructor
NIndexPair Structure Neurotec Namespace

Initializes a new instance of the NIndexPair structure.

C#
public NIndexPair(int index1, int index2);
Collapse Expand Parameters
Parameters | Description
int index1 | First index of this NIndexPair.
int index2 | Second index of this NIndexPair.


NIndexPair.ToString Method ()

NIndexPair.ToString Method ()
NIndexPair Structure Neurotec Namespace

Retrieves a string representation of the object.

C#
public override string ToString();
Collapse Expand Returns

A string representation of an object.


NIndexPair.ToString Method (string)

NIndexPair.ToString Method (string)
NIndexPair Structure Neurotec Namespace

Retrieves a string representation of the object.

C#
public string ToString(string format);
Collapse Expand Parameters
Parameters | Description
string format | Reserved.
Collapse Expand Returns

A string representation of an object.


NIndexPair.Index1 Property

NIndexPair.Index1 Property
NIndexPair Structure Neurotec Namespace

Gets or sets first index of this NIndexPair.

C#
public int Index1;


NIndexPair.Index2 Property

NIndexPair.Index2 Property
NIndexPair Structure Neurotec Namespace

Gets or sets second index of this NIndexPair.

C#
public int Index2;


NIndexPair.NativeType Property

NIndexPair.NativeType Property
NIndexPair Structure Neurotec Namespace

Defines the native type of the type.

C#
public static NType NativeType;


NModule Class

NModule Class
NObject Delegates NObject Events NObject Fields Legend Members Methods NDisposable Methods NDisposable Properties

Performs reflection on a module.

C#
public class NModule : NObject;
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NModule Class
Name | Description
CheckInit | Checks whether the current module is initialized and throws and exception if it is not.
CreateInstance | Creates a new instance of the specified module.
GetDependences | Retrieves dependencies of the module.
GetLoadedModules | Gets all the loaded modules that are part of this assembly.
GetType | Retrieves the NType object from module specified by name.
LoadFromFile | Loads module from the specified file.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NModule Class
Name | Description
Activated | Checks if the module is registered.
Company | Retrieves company name.
Copyright | Retrieves copyright notice of this module.
DefinedTypes | Retrieves all defined types from the specified module.
FileName | Retrieves the name of the file the specified module was created from.
Id | Gets or sets the ID of the module.
NModuleOptionsNativeType | Defines the native type of the module options.
Name | Retrieves module name.
NativeId | Gets or sets the native ID of the specified module.
NativeType | Defines the native type of the object.
Options | Retrieves module options.
Product | Retrieves product name.
Title | Retrieves module's title.
Version | Retrieves module version number.
VersionBuild | Retrieves the build of the current version.
VersionMajor | Retrieves the major version value.
VersionMinor | Retrieves the minor version value.
VersionRevision | Retrieves revision of the current version.
Container

File: NModule.cs

Namespace: Neurotec

Module: .NET Reference


NModule.NModule Constructor

NModule.NModule Constructor
NModule Class Neurotec Namespace

Initializes a new instance of NModule class.

C#
public NModule();


NModule.CheckInit Method

NModule.CheckInit Method
NModule Class Neurotec Namespace

Checks whether the current module is initialized and throws and exception if it is not.

C#
public void CheckInit(bool lazy);
Collapse Expand Parameters
Parameters | Description
bool lazy | true if the initialization is lazy; else false.


NModule.CreateInstance Method (string)

NModule.CreateInstance Method (string)
NModule Class Neurotec Namespace

Creates a new instance of the specified module.

C#
public object CreateInstance(string name);
Collapse Expand Parameters
Parameters | Description
string name | The name of the new module instance.
Collapse Expand Returns

Created module object.


NModule.CreateInstance Method (string, NAttributes)

NModule.CreateInstance Method (string, NAttributes)
NModule Class Neurotec Namespace

Creates a new instance of the specified module.

C#
public object CreateInstance(string name, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
string name | The name of the new module instance.
NAttributes attributes | Module attributes.
Collapse Expand Returns

Created module object.


NModule.GetDependences Method

NModule.GetDependences Method
NModule Class Neurotec Namespace

Retrieves dependencies of the module.

C#
public NModule[] GetDependences();
Collapse Expand Returns

A pointer to an array of dependencies.

Collapse Expand Remarks

NObjectUnref shall be called on returned objects when they are no longer used to prevent memory leaks.


NModule.GetLoadedModules Method

NModule.GetLoadedModules Method
NModule Class Neurotec Namespace

Gets all the loaded modules that are part of this assembly.

C#
public static NModule[] GetLoadedModules();
Collapse Expand Returns

An array of modules.

Collapse Expand Remarks

NObjectUnref shall be called on returned objects when they are no longer used to prevent memory leaks.


NModule.GetType Method (string)

NModule.GetType Method (string)
NModule Class Neurotec Namespace

Retrieves the NType object from module specified by name.

C#
public NType GetType(string name);
Collapse Expand Parameters
Parameters | Description
string name | Type name.
Collapse Expand Returns

NType object.


NModule.GetType Method (string, bool)

NModule.GetType Method (string, bool)
NModule Class Neurotec Namespace

Retrieves the NType object from module specified by name.

C#
public NType GetType(string name, bool mustExist);
Collapse Expand Parameters
Parameters | Description
string name | Type name.
bool mustExist | Variable defining if type must exist.
Collapse Expand Returns

NType object.


NModule.LoadFromFile Method

NModule.LoadFromFile Method
NModule Class Neurotec Namespace

Loads module from the specified file.

C#
public static NModule LoadFromFile(string fileName);
Collapse Expand Parameters
Parameters | Description
string fileName | Name of a file or full path to file.
Collapse Expand Returns

NModule object.


NModule.Activated Property

NModule.Activated Property
NModule Class Neurotec Namespace

Checks if the module is registered.

C#
public string Activated;


NModule.Company Property

NModule.Company Property
NModule Class Neurotec Namespace

Retrieves company name.

C#
public string Company;


NModule.Copyright Property

NModule.Copyright Property
NModule Class Neurotec Namespace

Retrieves copyright notice of this module.

C#
public string Copyright;


NModule.DefinedTypes Property

NModule.DefinedTypes Property
NModule Class Neurotec Namespace

Retrieves all defined types from the specified module.

C#
public DefinedTypeCollection DefinedTypes;
Property value

Collection of all defined types.


NModule.FileName Property

NModule.FileName Property
NModule Class Neurotec Namespace

Retrieves the name of the file the specified module was created from.

C#
public string FileName;
Property value

String of a file name.


NModule.Id Property

NModule.Id Property
NModule Class Neurotec Namespace

Gets or sets the ID of the module.

C#
public string Id;
Property value

String containing module Id.


NModule.NModuleOptionsNativeType Property

NModule.NModuleOptionsNativeType Property
NModule Class Neurotec Namespace

Defines the native type of the module options.

C#
public static NType NModuleOptionsNativeType;


NModule.Name Property

NModule.Name Property
NModule Class Neurotec Namespace

Retrieves module name.

C#
public string Name;


NModule.NativeId Property

NModule.NativeId Property
NModule Class Neurotec Namespace

Gets or sets the native ID of the specified module.

C#
public string NativeId;
Property value

String containing native Id.


NModule.NativeType Property

NModule.NativeType Property
NModule Class Neurotec Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NModule.Options Property

NModule.Options Property
NModule Class Neurotec Namespace

Retrieves module options.

C#
public NModuleOptions Options;


NModule.Product Property

NModule.Product Property
NModule Class Neurotec Namespace

Retrieves product name.

C#
public string Product;


NModule.Title Property

NModule.Title Property
NModule Class Neurotec Namespace

Retrieves module's title.

C#
public string Title;


NModule.Version Property

NModule.Version Property
NModule Class Neurotec Namespace

Retrieves module version number.

C#
public Version Version;


NModule.VersionBuild Property

NModule.VersionBuild Property
NModule Class Neurotec Namespace

Retrieves the build of the current version.

C#
public int VersionBuild;


NModule.VersionMajor Property

NModule.VersionMajor Property
NModule Class Neurotec Namespace

Retrieves the major version value.

C#
public int VersionMajor;


NModule.VersionMinor Property

NModule.VersionMinor Property
NModule Class Neurotec Namespace

Retrieves the minor version value.

C#
public int VersionMinor;


NModule.VersionRevision Property

NModule.VersionRevision Property
NModule Class Neurotec Namespace

Retrieves revision of the current version.

C#
public int VersionRevision;


NObject Class

NObject Class
NObject Delegates NObject Events NObject Fields Legend Members NDisposable Methods NDisposable Properties

Provides functionality for retrieving information about specified object.

C#
[TypeConverter(typeof(ExpandableObjectConverter))]
public class NObject : NDisposable, IFormattable, INotifyPropertyChanged;
Collapse Expand NObject Delegates
NObject Class
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
Container

File: NObject.cs

Namespace: Neurotec

Module: .NET Reference


NObject.FlagRefRet Field

NObject.FlagRefRet Field
NObject Class Neurotec Namespace

This flag indicates that an object should be returned with incremented ref count.

C#
public const uint FlagRefRet = 0x00000010;


NObject.CaptureProperties Method

NObject.CaptureProperties Method
NObject Class Neurotec Namespace

Adds the properties of the specified object to the specified property bag.

C#
public void CaptureProperties(NPropertyBag properties);
Collapse Expand Parameters
Parameters | Description
NPropertyBag properties | Property bag to add.


NObject.Clone Method

NObject.Clone Method
NObject Class Neurotec Namespace

Creates a copy of specified object.

C#
public object Clone();
Collapse Expand Returns

Reference to cloned object.


NObject.CompareTo Method

NObject.CompareTo Method
NObject Class Neurotec Namespace

Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.

C#
public int CompareTo(object obj);
Collapse Expand Parameters
Parameters | Description
object obj | The other object.
Collapse Expand Returns

Integer that indicates their relative position in the sort order.


NObject.CopyProperties Method

NObject.CopyProperties Method
NObject Class Neurotec Namespace

Copies property values from one NObject object to another.

C#
public static void CopyProperties(NObject srcObj, NObject dstObj);
Collapse Expand Parameters
Parameters | Description
NObject srcObj | Source NObject object which should be copied.
NObject dstObj | Destination NObject object where source object will be copied.


NObject.DisposeArray<T> Method

NObject.DisposeArray<T> Method
NObject Class Neurotec Namespace

Frees an array of objects.

C#
public static void DisposeArray<T>(T[] objects) where T : NObject;
Collapse Expand Parameters
Parameters | Description
T[] objects | The array to be freed.


NObject.Equals Method

NObject.Equals Method
NObject Class Neurotec Namespace

Compares the objects.

C#
public override bool Equals(object obj);
Collapse Expand Parameters
Parameters | Description
object obj | Other object to be compared with.
Collapse Expand Returns

true if objects are equal.


NObject.FromHandle<T> Method (HNObject)

NObject.FromHandle<T> Method (HNObject)
NObject Class Neurotec Namespace

Create C# object from native API objects handle.

This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.

C#
public static T FromHandle<T>(HNObject handle) where T : NObject;
Collapse Expand Parameters
Parameters | Description
HNObject handle | Handle of the object in native API.
Collapse Expand Returns

C# object associated with native API object.


NObject.FromHandle<T> Method (HNObject, bool)

NObject.FromHandle<T> Method (HNObject, bool)
NObject Class Neurotec Namespace

Create C# object from native API objects handle.

This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.

C#
public static T FromHandle<T>(HNObject handle, bool cache) where T : NObject;
Collapse Expand Parameters
Parameters | Description
HNObject handle | Handle of the object in native API.
bool cache | Will the created C# object use cache.
Collapse Expand Returns

C# object associated with native API object.


NObject.FromHandle<T> Method (HNObject, bool, object)

NObject.FromHandle<T> Method (HNObject, bool, object)
NObject Class Neurotec Namespace

Create C# object from native API objects handle.

This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.

C#
public static T FromHandle<T>(HNObject handle, bool cache, object owner) where T : NObject;
Collapse Expand Parameters
Parameters | Description
HNObject handle | Handle of the object in native API.
bool cache | Will the created C# object use cache.
object owner | Object owner.
Collapse Expand Returns

C# object associated with native API object.


NObject.FromHandle<T> Method (IntPtr)

NObject.FromHandle<T> Method (IntPtr)
NObject Class Neurotec Namespace

Create C# object from native API objects handle.

This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.

C#
public static T FromHandle<T>(IntPtr hObject) where T : NObject;
Collapse Expand Parameters
Parameters | Description
IntPtr hObject | Handle of the object in native API.
Collapse Expand Returns

C# object associated with native API object.


NObject.FromHandle<T> Method (IntPtr, bool, bool)

NObject.FromHandle<T> Method (IntPtr, bool, bool)
NObject Class Neurotec Namespace

Create C# object from native API objects handle.

This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.

C#
public static T FromHandle<T>(IntPtr hObject, bool ownsHandle, bool cache) where T : NObject;
Collapse Expand Parameters
Parameters | Description
IntPtr hObject | Handle of the object in native API.
bool ownsHandle | Will the created C# object become the owner of the handle.
bool cache | Whether the object is created from a cache.
Collapse Expand Returns

C# object associated with native API object.


NObject.FromObject Method

NObject.FromObject Method
NObject Class Neurotec Namespace

Creates a new NObject from the specified object.

C#
public static NObject FromObject(object obj);
Collapse Expand Parameters
Parameters | Description
object obj | The original object.
Collapse Expand Returns

The new NObject.


NObject.GetArray<T> Method (GetArrayPlain)

NObject.GetArray<T> Method (GetArrayPlain)
NObject Class Neurotec Namespace

Helper function for getting data from the native object.

This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.

C#
public static T[] GetArray<T>(GetArrayPlain getArray) where T : struct;
Collapse Expand Parameters
Parameters | Description
GetArrayPlain getArray | The getter function of the native object.
T | Type of the array's element.
Collapse Expand Returns

The array of elements returned by delegate specified in getArray argument.


NObject.GetArray<T> Method (GetOutArrayPlain)

NObject.GetArray<T> Method (GetOutArrayPlain)
NObject Class Neurotec Namespace

Helper function for getting data from the native object.

This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.

C#
public static T[] GetArray<T>(GetOutArrayPlain getArray) where T : struct;
Collapse Expand Parameters
Parameters | Description
GetOutArrayPlain getArray | The getter function of the native object.
Collapse Expand Returns

The array of elements returned by delegate specified in getArray argument.


NObject.GetHashCode Method

NObject.GetHashCode Method
NObject Class Neurotec Namespace

Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.

C#
public override int GetHashCode();
Collapse Expand Returns

Hash code for the object.


NObject.GetNativeType Method

NObject.GetNativeType Method
NObject Class Neurotec Namespace

Retrieves native type of object.

C#
public NType GetNativeType();
Collapse Expand Returns

NativeType value.


NObject.GetObject<T> Method (GetObjectPlain)

NObject.GetObject<T> Method (GetObjectPlain)
NObject Class Neurotec Namespace

Helper function for getting data from the native object.

This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.

C#
public static T GetObject<T>(GetObjectPlain getObject) where T : NObject;
Collapse Expand Parameters
Parameters | Description
GetObjectPlain getObject | The getter function of the native object.
Collapse Expand Returns

The object returned by delegate specified in getObject argument.


NObject.GetObject<T> Method (GetObjectPlain, bool)

NObject.GetObject<T> Method (GetObjectPlain, bool)
NObject Class Neurotec Namespace

Helper function for getting data from the native object.

This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.

C#
public static T GetObject<T>(GetObjectPlain getObject, bool cache) where T : NObject;
Collapse Expand Parameters
Parameters | Description
GetObjectPlain getObject | The getter function of the native object.
bool cache | Whether a cache is used.
Collapse Expand Returns

Data from the native object.


NObject.GetObjects<T> Method (GetArrayPlain)

NObject.GetObjects<T> Method (GetArrayPlain)
NObject Class Neurotec Namespace

Helper function for getting data from the native object.

This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.

C#
public static T[] GetObjects<T>(GetArrayPlain getArray) where T : NObject;
Collapse Expand Parameters
Parameters | Description
GetArrayPlain getArray | The getter function of the native object.
Collapse Expand Returns

The array of elements returned by delegate specified in getArray argument.


NObject.GetObjects<T> Method (GetArrayPlain, bool, bool)

NObject.GetObjects<T> Method (GetArrayPlain, bool, bool)
NObject Class Neurotec Namespace

Helper function for getting data from the native object.

This method supports the .NET Framework infrastructure and is not intended to be used directly.

C#
public static T[] GetObjects<T>(GetArrayPlain getArray, bool ownsHandles, bool cache) where T : NObject;
Collapse Expand Parameters
Parameters | Description
GetArrayPlain getArray | The getter function of the native object.
bool ownsHandles | Whether the objects own handles.
bool cache | Whether a cache is used.
Collapse Expand Returns

The array of objects returned by delegate specified in getObjects argument.


NObject.GetObjects<T> Method (GetOutArrayPlain)

NObject.GetObjects<T> Method (GetOutArrayPlain)
NObject Class Neurotec Namespace

Helper function for getting data from the native object.

This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.

C#
public static T[] GetObjects<T>(GetOutArrayPlain getArray) where T : NObject;
Collapse Expand Parameters
Parameters | Description
GetOutArrayPlain getArray | The getter function of the native object.
Collapse Expand Returns

The array of objects returned by delegate specified in getObjects argument.


NObject.GetObjects<T> Method (GetOutArrayPlain, bool, bool)

NObject.GetObjects<T> Method (GetOutArrayPlain, bool, bool)
NObject Class Neurotec Namespace

Helper function for getting data from the native object.

This method supports the .NET Framework infrastructure and is not intended to be used directly.

C#
public static T[] GetObjects<T>(GetOutArrayPlain getArray, bool ownsHandles, bool cache) where T : NObject;
Collapse Expand Parameters
Parameters | Description
GetOutArrayPlain getArray | The getter function of the native object.
bool ownsHandles | Whether the objects own handles.
bool cache | Whether a cache is used.
Collapse Expand Returns

The array of objects returned by delegate specified in getObjects argument.


NObject.GetProperty<T> Method

NObject.GetProperty<T> Method
NObject Class Neurotec Namespace

Retrieves the specified property of the current object.

C#
public T GetProperty<T>(string name);
Collapse Expand Parameters
Parameters | Description
string name | Name of the property.
Collapse Expand Returns

The specified property.


NObject.GetSize Method ()

NObject.GetSize Method ()
NObject Class Neurotec Namespace

Returns the size of the current object.

C#
public int GetSize();
Collapse Expand Returns

The object's size.


NObject.GetSize Method (uint)

NObject.GetSize Method (uint)
NObject Class Neurotec Namespace

Returns the size of the current object.

C#
public int GetSize(uint flags);
Collapse Expand Parameters
Parameters | Description
uint flags | Object's flags.
Collapse Expand Returns

The object's size.


NObject.GetSizeMany<T> Method (T[])

NObject.GetSizeMany<T> Method (T[])
NObject Class Neurotec Namespace

Returns the size of objects in the array.

C#
public static int GetSizeMany<T>(T[] objects) where T : NObject;
Collapse Expand Parameters
Parameters | Description
T[] objects | An array of objects.
Collapse Expand Returns

Objects' size.


NObject.GetSizeMany<T> Method (T[], uint)

NObject.GetSizeMany<T> Method (T[], uint)
NObject Class Neurotec Namespace

Returns the size of objects in the array.

C#
public static int GetSizeMany<T>(T[] objects, uint flags) where T: NObject;
Collapse Expand Parameters
Parameters | Description
T[] objects | An array of objects.
uint flags | Objects' flags.
Collapse Expand Returns

Objects' size.


NObject.GetString Method

NObject.GetString Method
NObject Class Neurotec Namespace

Helper function for getting data from the native object.

This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.

C#
public static string GetString(GetStringPlainN getString);
Collapse Expand Parameters
Parameters | Description
GetStringPlainN getString | The getter function of the native object.
Collapse Expand Returns

The text returned by delegate specified in getString argument.


NObject.Ref Method

NObject.Ref Method
NObject Class Neurotec Namespace

Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.

C#
public static void Ref(IntPtr hObject);
Collapse Expand Parameters
Parameters | Description
IntPtr hObject | Handle to an object to increment its reference count.


NObject.Reset Method

NObject.Reset Method
NObject Class Neurotec Namespace

Resets all NObject parameters to default values.

C#
public void Reset();


NObject.ResetProperty Method

NObject.ResetProperty Method
NObject Class Neurotec Namespace

Resets the value of the specified property.

C#
public void ResetProperty(string name);
Collapse Expand Parameters
Parameters | Description
string name | Name of the property to be reset.


NObject.Save Method ()

NObject.Save Method ()
NObject Class Neurotec Namespace

Saves the current object into a buffer.

C#
public NBuffer Save();
Collapse Expand Returns

The destination NBuffer.


NObject.Save Method (NBuffer)

NObject.Save Method (NBuffer)
NObject Class Neurotec Namespace

Saves the current object into a buffer.

C#
public int Save(NBuffer buffer);
Collapse Expand Parameters
Parameters | Description
NBuffer buffer | The destination buffer.
Collapse Expand Returns

The buffer size.


NObject.Save Method (NBuffer, uint)

NObject.Save Method (NBuffer, uint)
NObject Class Neurotec Namespace

Saves the current object into a buffer.

C#
public int Save(NBuffer buffer, uint flags);
Collapse Expand Parameters
Parameters | Description
NBuffer buffer | The destination buffer.
uint flags | Must be zero.
Collapse Expand Returns

The buffer size.


NObject.Save Method (NStream)

NObject.Save Method (NStream)
NObject Class Neurotec Namespace

Saves the current object into a stream.

C#
public void Save(NStream stream);
Collapse Expand Parameters
Parameters | Description
NStream stream | The destination stream.


NObject.Save Method (NStream, uint)

NObject.Save Method (NStream, uint)
NObject Class Neurotec Namespace

Saves the current object into a stream.

C#
public void Save(NStream stream, uint flags);
Collapse Expand Parameters
Parameters | Description
NStream stream | The destination stream.
uint flags | Must be zero.


NObject.Save Method (uint)

NObject.Save Method (uint)
NObject Class Neurotec Namespace

Saves the current object into a buffer.

C#
public NBuffer Save(uint flags);
Collapse Expand Parameters
Parameters | Description
uint flags | Must be zero.
Collapse Expand Returns

The destination NBuffer.


NObject.SaveMany<T> Method (T[])

NObject.SaveMany<T> Method (T[])
NObject Class Neurotec Namespace

Saves an array of objects into a buffer.

C#
public static NBuffer SaveMany<T>(T[] objects) where T : NObject;
Collapse Expand Parameters
Parameters | Description
T[] objects | An object array.
Collapse Expand Returns

The destination buffer.


NObject.SaveMany<T> Method (T[], NBuffer)

NObject.SaveMany<T> Method (T[], NBuffer)
NObject Class Neurotec Namespace

Saves an array of objects into a buffer.

C#
public static int SaveMany<T>(T[] objects, NBuffer buffer) where T : NObject;
Collapse Expand Parameters
Parameters | Description
T[] objects | An object array.
NBuffer buffer | Destination buffer.
Collapse Expand Returns

Buffer size.


NObject.SaveMany<T> Method (T[], NBuffer, uint)

NObject.SaveMany<T> Method (T[], NBuffer, uint)
NObject Class Neurotec Namespace

Saves an array of objects into a buffer.

C#
public static int SaveMany<T>(T[] objects, NBuffer buffer, uint flags) where T : NObject;
Collapse Expand Parameters
Parameters | Description
T[] objects | An object array.
NBuffer buffer | Destination buffer.
uint flags | Must be zero.
Collapse Expand Returns

Buffer size.


NObject.SaveMany<T> Method (T[], NStream)

NObject.SaveMany<T> Method (T[], NStream)
NObject Class Neurotec Namespace

Saves an array of objects into a stream.

C#
public static void SaveMany<T>(T[] objects, NStream stream) where T : NObject;
Collapse Expand Parameters
Parameters | Description
T[] objects | An object array.
NStream stream | NStream object.
Collapse Expand Returns

Buffer size.


NObject.SaveMany<T> Method (T[], NStream, uint)

NObject.SaveMany<T> Method (T[], NStream, uint)
NObject Class Neurotec Namespace

Saves an array of objects into a stream.

C#
public static void SaveMany<T>(T[] objects, NStream stream, uint flags) where T : NObject;
Collapse Expand Parameters
Parameters | Description
T[] objects | An object array.
NStream stream | NStream object.
uint flags | Must be zero.
Collapse Expand Returns

Buffer size.


NObject.SaveMany<T> Method (T[], uint)

NObject.SaveMany<T> Method (T[], uint)
NObject Class Neurotec Namespace

Saves an array of objects into a buffer.

C#
public static NBuffer SaveMany<T>(T[] objects, uint flags) where T : NObject;
Collapse Expand Parameters
Parameters | Description
T[] objects | An object array.
uint flags | Must be zero.
Collapse Expand Returns

The destination buffer.


NObject.SetArray<T> Method

NObject.SetArray<T> Method
NObject Class Neurotec Namespace

Helper function for setting data of the native object.

This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.

C#
public static void SetArray<T>(SetArrayPlain setArray, T[] value) where T : struct;
Collapse Expand Parameters
Parameters | Description
SetArrayPlain setArray | The setter function of the native object.
T[] value | The new value to set.
T | Type of the array's element.


NObject.SetObject<T> Method

NObject.SetObject<T> Method
NObject Class Neurotec Namespace

Helper function for setting data of the native object.

This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.

C#
public static void SetObject<T>(SetObjectPlain setObject, T value) where T : NObject;
Collapse Expand Parameters
Parameters | Description
SetObjectPlain setObject | The setter function of the native object.
T value | The new value to set.


NObject.SetProperty<T> Method (string, T)

NObject.SetProperty<T> Method (string, T)
NObject Class Neurotec Namespace

Sets the value of the specified property.

C#
public void SetProperty<T>(string name, T value);
Collapse Expand Parameters
Parameters | Description
string name | Name of the property to be set.
T value | The new value of the property.
T | Type of the property.


NObject.SetProperty Method (string, object)

NObject.SetProperty Method (string, object)
NObject Class Neurotec Namespace

Sets the value of the specified property.

C#
public void SetProperty(string name, object value);
Collapse Expand Parameters
Parameters | Description
string name | Name of the property to be set.
object value | The new value of the property.


NObject.SetString Method

NObject.SetString Method
NObject Class Neurotec Namespace

Helper function for setting data of the native object.

This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.

C#
public static void SetString(SetStringPlainN setString, string value);
Collapse Expand Parameters
Parameters | Description
SetStringPlainN setString | The setter function of the native object.
string value | The new value to set.


NObject.ToHandle Method

NObject.ToHandle Method
NObject Class Neurotec Namespace

Gets the representation of native API handle corresponding to the C# object.

C#
public static HNObject ToHandle(NObject obj);
Collapse Expand Parameters
Parameters | Description
NObject obj | C# level object.
Collapse Expand Returns

C# wrapper of native API handle.


NObject.ToObject Method

NObject.ToObject Method
NObject Class Neurotec Namespace

Creates a new object from the specified NObject.

C#
public static object ToObject(NObject obj);
Collapse Expand Parameters
Parameters | Description
NObject obj | The original NObject.
Collapse Expand Returns

The new object.


NObject.ToString Method ()

NObject.ToString Method ()
NObject Class Neurotec Namespace

Returns string representation of the object.

C#
public sealed override string ToString();
Collapse Expand Returns

String representation of the object.


NObject.ToString Method (string)

NObject.ToString Method (string)
NObject Class Neurotec Namespace

Retrieves a string representation of the object.

C#
public string ToString(string format);
Collapse Expand Parameters
Parameters | Description
string format | Reserved.
Collapse Expand Returns

A string representation of the object.


NObject.Unref Method

NObject.Unref Method
NObject Class Neurotec Namespace

Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.

C#
public static void Unref(IntPtr hObject);
Collapse Expand Parameters
Parameters | Description
IntPtr hObject | Handle to an object to decrement its reference count.


NObject.UnrefArray Method

NObject.UnrefArray Method
NObject Class Neurotec Namespace

Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.

C#
public static void UnrefArray(IntPtr arhValues, int count);
Collapse Expand Parameters
Parameters | Description
IntPtr arhValues | Handle to array of objects which reference count should be decremented.
int count | Objects in arhObjects count.


NObject.UnrefElements Method

NObject.UnrefElements Method
NObject Class Neurotec Namespace

Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.

C#
public static void UnrefElements(IntPtr arhValues, int count);
Collapse Expand Parameters
Parameters | Description
IntPtr arhValues | Handle to array of objects which reference count should be decremented.
int count | Objects in arhObjects count.


NObject.Flags Property

NObject.Flags Property
NObject Class Neurotec Namespace

Gets flags from object.

C#
public uint Flags;
Property value

Object flags.


NObject.IsDisposed Property

NObject.IsDisposed Property
NObject Class Neurotec Namespace

Gets whether allocated resources were released previously.

C#
[Browsable(false)]
public sealed override bool IsDisposed;


NObject.NativeType Property

NObject.NativeType Property
NObject Class Neurotec Namespace

Neurotechnology framework type of the object.

C#
public static NType NativeType;


NObject.Owner Property

NObject.Owner Property
NObject Class Neurotec Namespace

Gets owner of the object.

C#
[Browsable(false)]
public NObject Owner;
Property value

Object (owner) of NObject type.


NObject.EventInvoker Delegate

NObject.EventInvoker Delegate
NObject Class Neurotec Namespace

Creates a delegate to an event invoker function.

C#
public delegate void EventInvoker<T>(T ea) where T : EventArgs;
Collapse Expand Parameters
Parameters | Description
ea | The event to be invoked.


NObject.FromHandlePlain Delegate

NObject.FromHandlePlain Delegate
NObject Class Neurotec Namespace

Creates a delegate to FromHandlePlain function.

C#
public delegate NObject FromHandlePlain(HNObject handle);
Collapse Expand Parameters
Parameters | Description
handle | Object handle.
Collapse Expand Returns

NObject value.


NObject.GetArrayPlain Delegate

NObject.GetArrayPlain Delegate
NObject Class Neurotec Namespace

Creates a delegate to a function, which gets a plain array.

C#
public delegate int GetArrayPlain(IntPtr arValues, int valuesLength);
Collapse Expand Parameters
Parameters | Description
arValues | Pointer to an array of values.
valuesLength | Length of values.
Collapse Expand Returns

NResult.


NObject.GetArrayWithHandle Delegate

NObject.GetArrayWithHandle Delegate
NObject Class Neurotec Namespace

Creates a delegate to a function, which gets an array with handle.

C#
public delegate int GetArrayWithHandle(HNObject handle, IntPtr arValues, int valuesLength);
Collapse Expand Parameters
Parameters | Description
handle | Array handle.
arValues | Pointer to an array of values.
valuesLength | Length of values.
Collapse Expand Returns

NResult.


NObject.GetObjectPlain Delegate

NObject.GetObjectPlain Delegate
NObject Class Neurotec Namespace

Creates a delegate to a function which returns a plain object.

C#
public delegate int GetObjectPlain(out HNObject hValue);
Collapse Expand Parameters
Parameters | Description
hValue | [out] Object value.
Collapse Expand Returns

NResult.


NObject.GetObjectWithHandle Delegate

NObject.GetObjectWithHandle Delegate
NObject Class Neurotec Namespace

Creates a delegate to a function, which returns an object with handle.

C#
public delegate int GetObjectWithHandle(HNObject handle, out HNObject hValue);
Collapse Expand Parameters
Parameters | Description
handle | Object handle.
hValue | [out] Object value.
Collapse Expand Returns

NResult.


NObject.GetOutArrayPlain Delegate

NObject.GetOutArrayPlain Delegate
NObject Class Neurotec Namespace

Creates a delegate to a function, which gets a plain out array.

C#
public delegate int GetOutArrayPlain(out IntPtr arValues, out int count);
Collapse Expand Parameters
Parameters | Description
arValues | [out] Pointer to an array of values.
count | [out] Number of elements in the array.
Collapse Expand Returns

NResult.


NObject.GetOutArrayWithHandle Delegate

NObject.GetOutArrayWithHandle Delegate
NObject Class Neurotec Namespace

Creates a delegate to a function, which gets an out array with a handle.

C#
public delegate int GetOutArrayWithHandle(HNObject handle, out IntPtr arValues, out int count);
Collapse Expand Parameters
Parameters | Description
handle | Array handle.
arValues | Pointer to an array of values.
count | [out] Number of elements in the array.
Collapse Expand Returns

NResult.


NObject.GetStringPlainN Delegate

NObject.GetStringPlainN Delegate
NObject Class Neurotec Namespace

Creates a delegate to a function, which gets a plain string.

C#
public delegate int GetStringPlainN(out HNString hValue);
Collapse Expand Parameters
Parameters | Description
hValue | [out] String value.
Collapse Expand Returns

NResult.


NObject.GetStringWithHandleN Delegate

NObject.GetStringWithHandleN Delegate
NObject Class Neurotec Namespace

Creates a delegate to a function, which gets a string with handle.

C#
public delegate int GetStringWithHandleN(HNObject handle, out HNString hValue);
Collapse Expand Parameters
Parameters | Description
handle | String handle.
hValue | [out] String value.
Collapse Expand Returns

NResult.


NObject.SetArrayPlain Delegate

NObject.SetArrayPlain Delegate
NObject Class Neurotec Namespace

Creates a delegate to a function, which sets values of a plain array.

C#
public delegate int SetArrayPlain(IntPtr arValues, int valueCount);
Collapse Expand Parameters
Parameters | Description
arValues | Pointer to an array of values.
valueCount | Number of values.
Collapse Expand Returns

NResult.


NObject.SetArrayWithHandle Delegate

NObject.SetArrayWithHandle Delegate
NObject Class Neurotec Namespace

Creates a delegate to a function, which sets values of an array with handle.

C#
public delegate int SetArrayWithHandle(HNObject handle, IntPtr arValues, int valueCount);
Collapse Expand Parameters
Parameters | Description
handle | Array handle.
arValues | Pointer to an array of values.
valueCount | Number of values.
Collapse Expand Returns

NResult.


NObject.SetObjectPlain Delegate

NObject.SetObjectPlain Delegate
NObject Class Neurotec Namespace

Creates a delegate to a function, which sets a value of a plain object.

C#
public delegate int SetObjectPlain(HNObject hValue);
Collapse Expand Parameters
Parameters | Description
hValue | Object value.
Collapse Expand Returns

NResult.


NObject.SetObjectWithHandle Delegate

NObject.SetObjectWithHandle Delegate
NObject Class Neurotec Namespace

Creates a delegate to a function, which sets a value of an object with handle.

C#
public delegate int SetObjectWithHandle(HNObject handle, HNObject hValue);
Collapse Expand Parameters
Parameters | Description
handle | Object handle.
hValue | Object value.
Collapse Expand Returns

NResult.


NObject.SetStringPlainN Delegate

NObject.SetStringPlainN Delegate
NObject Class Neurotec Namespace

Creates a delegate to a function, which sets a plain string.

C#
public delegate int SetStringPlainN(HNString value);
Collapse Expand Parameters
Parameters | Description
value | String value.
Collapse Expand Returns

NResult.


NObject.SetStringWithHandleN Delegate

NObject.SetStringWithHandleN Delegate
NObject Class Neurotec Namespace

Creates a delegate to a function, which sets a string with handle.

C#
public delegate int SetStringWithHandleN(HNObject handle, HNString value);
Collapse Expand Parameters
Parameters | Description
handle | String handle.
value | String value.
Collapse Expand Returns

NResult.


NObject.PropertyChanged Event

NObject.PropertyChanged Event
NObject Class Neurotec Namespace

Adds or removes a "Property Changed" event.

C#
public event PropertyChangedEventHandler PropertyChanged;


NProcessorInfo Class

NProcessorInfo Class
Legend Members NProcessorInfo Methods NProcessorInfo Properties

Provides functionality for getting processor information.

C#
public static class NProcessorInfo;
Collapse Expand NProcessorInfo Methods
Name | Description
GetModelInfo | Retrieves processor model information.
IsFeatureSupported | Checks if current CPU supports the specified feature.
Collapse Expand NProcessorInfo Properties
Name | Description
Count | Retrieves the number of logical processors in the current group.
ModelName | Gets a string representing processor model's name.
NProcessorVendorNativeType | Defines the native type of the processor vendor.
NativeType | Defines the native type of the object.
Vendor | Gets current processor's vendor value in vendor's enumeration.
VendorName | Gets a string representing processor vendor's name.
Container

File: NProcessorInfo.cs

Namespace: Neurotec

Module: .NET Reference


NProcessorInfo.GetModelInfo Method

NProcessorInfo.GetModelInfo Method
NProcessorInfo Class Neurotec Namespace

Retrieves processor model information.

C#
public static void GetModelInfo(out int family, out int model, out int stepping);
Collapse Expand Parameters
Parameters | Description
out int family | Integer representing processor's family.
out int model | Integer representing processor's model name.
out int stepping | Integer representing processor's stepping.


NProcessorInfo.IsFeatureSupported Method

NProcessorInfo.IsFeatureSupported Method
NProcessorInfo Class Neurotec Namespace

Checks if current CPU supports the specified feature.

C#
public static bool IsFeatureSupported(NProcessorFeature feature);
Collapse Expand Parameters
Parameters | Description
NProcessorFeature feature | Feature to be checked.
Collapse Expand Returns

true if the feature is supported, else false.


NProcessorInfo.Count Property

NProcessorInfo.Count Property
NProcessorInfo Class Neurotec Namespace

Retrieves the number of logical processors in the current group.

C#
public static int Count;
Property value

The number of logical processors in the current group.


NProcessorInfo.ModelName Property

NProcessorInfo.ModelName Property
NProcessorInfo Class Neurotec Namespace

Gets a string representing processor model's name.

C#
public static string ModelName;


NProcessorInfo.NProcessorVendorNativeType Property

NProcessorInfo.NProcessorVendorNativeType Property
NProcessorInfo Class Neurotec Namespace

Defines the native type of the processor vendor.

C#
public static NType NProcessorVendorNativeType;


NProcessorInfo.NativeType Property

NProcessorInfo.NativeType Property
NProcessorInfo Class Neurotec Namespace

Defines the native type of the object.

C#
public static NType NativeType;


NProcessorInfo.Vendor Property

NProcessorInfo.Vendor Property
NProcessorInfo Class Neurotec Namespace

Gets current processor's vendor value in vendor's enumeration.

C#
public static NProcessorVendor Vendor;


NProcessorInfo.VendorName Property

NProcessorInfo.VendorName Property
NProcessorInfo Class Neurotec Namespace

Gets a string representing processor vendor's name.

C#
public static string VendorName;


NPropertyBag Class

NPropertyBag Class
NPropertyBag Classes NObject Delegates NObject Events NObject Fields Legend Members Methods NDisposable Methods NDisposable Properties

Represents a property bag in which the object can persistently save its properties.

C#
public sealed class NPropertyBag : NObject, IDictionary, IList, ICollection, IEnumerable, INotifyCollectionChanged, ICloneable;
Collapse Expand NPropertyBag Classes
NPropertyBag Class
Name | Description
KeyCollection | Represents the collection of key parts of the key value pair.
ValueCollection | Represents the collection of value parts of the key value pair.
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
NPropertyBag Class
Name | Description
CollectionChanged | Adds or removes a handler for an event which occurs when collection is changed.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NPropertyBag Class
Name | Description
Add | Adds a key value pair to the current property bag.
AddRange | Adds a range of key value pair values to the current property bag.
ApplyTo | Applies the current property bag to the specified object.
Clear | Clears the current property bag.
Contains | Checks whether the current property bag contains the specified key value pair.
ContainsKey | Checks whether the property bag contains a property specified by key.
CopyTo | Copies the current property bag into a key value pair array.
GetEnumerator | Gets the enumerator for the current key value pair.
Parse | Converts the specified string to a property bag.
Remove | Removes the specified key value pair from the current property bag.
RemoveAt | Removes the property specified by index.
TryGetValue | Retrieves the value of a property specified by the key. Returns a Boolean value indicating whether the operation succeeded.
TryParse | Converts the specified string to a property bag. Returns a Boolean value indicating whether the conversion succeeded.
this | Gets the specified key vale pair.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NPropertyBag Class
Name | Description
Count | Retrieves the number of properties in the property bag.
IsReadOnly | Checks whether the property bag is read-only.
Keys | Gets the collection of key values.
NativeType | Defines the native type of the object.
Values | Gets the collection of values.
Container

File: NPropertyBag.cs

Namespace: Neurotec

Module: .NET Reference


NPropertyBag.NPropertyBag Constructor ()

NPropertyBag.NPropertyBag Constructor ()
NPropertyBag Class Neurotec Namespace

Creates a new instance of NPropertyBag class.

C#
public NPropertyBag();


NPropertyBag.NPropertyBag Constructor (IEnumerable<KeyValuePair<string, object>>)

NPropertyBag.NPropertyBag Constructor (IEnumerable<KeyValuePair<string, object>>)
NPropertyBag Class Neurotec Namespace

Creates a new instance of NPropertyBag class.

C#
public NPropertyBag(IEnumerable<KeyValuePair<string, object>> values);
Collapse Expand Parameters
Parameters | Description
IEnumerable<KeyValuePair<string, object>> values | Property values.


NPropertyBag.KeyCollection Class

NPropertyBag.KeyCollection Class
Legend Members KeyCollection Methods

Represents the collection of key parts of the key value pair.

C#
public sealed class KeyCollection : StringReadOnlyCollection;
Collapse Expand KeyCollection Methods
Name | Description
Contains | Checks whether the key collection contains the specified key.
Container

File: NPropertyBag.cs

Namespace: Neurotec

Module: .NET Reference


NPropertyBag.KeyCollection.Contains Method

NPropertyBag.KeyCollection.Contains Method
NPropertyBag.KeyCollection Class Neurotec Namespace

Checks whether the key collection contains the specified key.

C#
public override bool Contains(string value);
Collapse Expand Parameters
Parameters | Description
string value | Key string.
Collapse Expand Returns

true if the collection contains the key; else false.


NPropertyBag.ValueCollection Class

NPropertyBag.ValueCollection Class

Represents the collection of value parts of the key value pair.

C#
public sealed class ValueCollection : ObjectReadOnlyCollection;
Container

File: NPropertyBag.cs

Namespace: Neurotec

Module: .NET Reference


NPropertyBag.Add Method (KeyValuePair<string, object>)

NPropertyBag.Add Method (KeyValuePair<string, object>)
NPropertyBag Class Neurotec Namespace

Adds a key value pair to the current property bag.

C#
public void Add(KeyValuePair<string, object> item);
Collapse Expand Parameters
Parameters | Description
KeyValuePair<string, object> item | The key value pair to add.


NPropertyBag.Add Method (string, object)

NPropertyBag.Add Method (string, object)
NPropertyBag Class Neurotec Namespace

Adds a new key value pair.

C#
public void Add(string key, object value);
Collapse Expand Parameters
Parameters | Description
string key | Key part of the pair.
object value | Value part of the pair.


NPropertyBag.AddRange Method

NPropertyBag.AddRange Method
NPropertyBag Class Neurotec Namespace

Adds a range of key value pair values to the current property bag.

C#
public void AddRange(IEnumerable<KeyValuePair<string, object>> values);
Collapse Expand Parameters
Parameters | Description
IEnumerable<KeyValuePair<string, object>> values | Key value pair values to be added.


NPropertyBag.ApplyTo Method

NPropertyBag.ApplyTo Method
NPropertyBag Class Neurotec Namespace

Applies the current property bag to the specified object.

C#
public void ApplyTo(NObject @object);
Collapse Expand Parameters
Parameters | Description
NObject @object | The object to apply the property bag to.


NPropertyBag.Clear Method

NPropertyBag.Clear Method
NPropertyBag Class Neurotec Namespace

Clears the current property bag.

C#
public void Clear();


NPropertyBag.Contains Method

NPropertyBag.Contains Method
NPropertyBag Class Neurotec Namespace

Checks whether the current property bag contains the specified key value pair.

C#
public bool Contains(KeyValuePair<string, object> item);
Collapse Expand Parameters
Parameters | Description
KeyValuePair<string, object> item | The key value pair.
Collapse Expand Returns

true if the property bag contains the key value pair; else false.


NPropertyBag.ContainsKey Method

NPropertyBag.ContainsKey Method
NPropertyBag Class Neurotec Namespace

Checks whether the property bag contains a property specified by key.

C#
public bool ContainsKey(string key);
Collapse Expand Parameters
Parameters | Description
string key | Key of the property.
Collapse Expand Returns

true if the property bag contains the property, else false.


NPropertyBag.CopyTo Method (Array, int)

NPropertyBag.CopyTo Method (Array, int)
NPropertyBag Class Neurotec Namespace

Copies the current property bag into a key value pair array.

C#
public void CopyTo(Array array, int index);
Collapse Expand Parameters
Parameters | Description
Array array | The key value pair array.
int index | Index in the array, at which the copying starts.


NPropertyBag.CopyTo Method (KeyValuePair<string, object>[], int)

NPropertyBag.CopyTo Method (KeyValuePair<string, object>[], int)
NPropertyBag Class Neurotec Namespace

Copies the current property bag into a key value pair array.

C#
public void CopyTo(KeyValuePair<string, object>[] array, int arrayIndex);
Collapse Expand Parameters
Parameters | Description
KeyValuePair<string, object>[] array | The key value pair array.
int arrayIndex | Index in the array, at which the copying starts.


NPropertyBag.CopyTo Method (NObject)

NPropertyBag.CopyTo Method (NObject)
NPropertyBag Class Neurotec Namespace

Copies the current property bag into the specified property bag.

C#
public void CopyTo(NObject otherPropertyBag);
Collapse Expand Parameters
Parameters | Description
NObject otherPropertyBag | Property bag to copy to.


NPropertyBag.GetEnumerator Method

NPropertyBag.GetEnumerator Method
NPropertyBag Class Neurotec Namespace

Gets the enumerator for the current key value pair.

C#
public IEnumerator<KeyValuePair<string, object>> GetEnumerator();
Collapse Expand Returns

The new enumerator.


NPropertyBag.Parse Method (string)

NPropertyBag.Parse Method (string)
NPropertyBag Class Neurotec Namespace

Converts the specified string to a property bag.

C#
public static NPropertyBag Parse(string value);
Collapse Expand Parameters
Parameters | Description
string value | The string to parse.
Collapse Expand Returns

The parsed property bag.


NPropertyBag.Parse Method (string, string)

NPropertyBag.Parse Method (string, string)
NPropertyBag Class Neurotec Namespace

Converts the specified string to a property bag.

C#
public static NPropertyBag Parse(string value, string format);
Collapse Expand Parameters
Parameters | Description
string value | The string to parse.
string format | The format string.
Collapse Expand Returns

The parsed property bag.


NPropertyBag.Remove Method (KeyValuePair<string, object>)

NPropertyBag.Remove Method (KeyValuePair<string, object>)
NPropertyBag Class Neurotec Namespace

Removes the specified key value pair from the current property bag.

C#
public bool Remove(KeyValuePair<string, object> item);
Collapse Expand Parameters
Parameters | Description
KeyValuePair<string, object> item | The key value pair to be removed.
Collapse Expand Returns

true if the operation was successful, else false.


NPropertyBag.Remove Method (string)

NPropertyBag.Remove Method (string)
NPropertyBag Class Neurotec Namespace

Removes the property specified by key.

C#
public bool Remove(string key);
Collapse Expand Parameters
Parameters | Description
string key | Key of the property.
Collapse Expand Returns

true if the operation was successful, else false.


NPropertyBag.RemoveAt Method

NPropertyBag.RemoveAt Method
NPropertyBag Class Neurotec Namespace

Removes the property specified by index.

C#
public void RemoveAt(int index);
Collapse Expand Parameters
Parameters | Description
int index | Index of the property to be removed.


NPropertyBag.TryGetValue Method

NPropertyBag.TryGetValue Method
NPropertyBag Class Neurotec Namespace

Retrieves the value of a property specified by the key. Returns a Boolean value indicating whether the operation succeeded.

C#
public bool TryGetValue(string key, out object value);
Collapse Expand Parameters
Parameters | Description
string key | Key to the property to be retrieved.
out object value | [out] The property.
Collapse Expand Returns

true if the operation was successful, else false.


NPropertyBag.TryParse Method (string, out NPropertyBag)

NPropertyBag.TryParse Method (string, out NPropertyBag)
NPropertyBag Class Neurotec Namespace

Converts the specified string to a property bag. Returns a Boolean value indicating whether the conversion succeeded.

C#
public static bool TryParse(string value, out NPropertyBag result);
Collapse Expand Parameters
Parameters | Description
string value | The string to parse.
out NPropertyBag result | [out] The parsed property bag.
Collapse Expand Returns

true if the operation was successful, else false.


NPropertyBag.TryParse Method (string, string, out NPropertyBag)

NPropertyBag.TryParse Method (string, string, out NPropertyBag)
NPropertyBag Class Neurotec Namespace

Converts the specified string to a property bag. Returns a Boolean value indicating whether the conversion succeeded.

C#
public static bool TryParse(string value, string format, out NPropertyBag result);
Collapse Expand Parameters
Parameters | Description
string value | The string to parse.
string format | The format string.
out NPropertyBag result | [out] The parsed property bag.
Collapse Expand Returns

true if the operation was successful, else false.


NPropertyBag.this Indexer (int)

NPropertyBag.this Indexer (int)
NPropertyBag Class Neurotec Namespace

Gets the specified key vale pair.

C#
public KeyValuePair<string, object> this[int index];
Collapse Expand Parameters
Parameters | Description
int index | Index of the key value pair.
Collapse Expand Returns

The key value pair.


NPropertyBag.this Indexer (string)

NPropertyBag.this Indexer (string)
NPropertyBag Class Neurotec Namespace

Gets or sets the value specified by key.

C#
public object this[string key];
Collapse Expand Parameters
Parameters | Description
string key | Key of the property.
Collapse Expand Returns

The value.


NPropertyBag.Count Property

NPropertyBag.Count Property
NPropertyBag Class Neurotec Namespace

Retrieves the number of properties in the property bag.

C#
public int Count;


NPropertyBag.IsReadOnly Property

NPropertyBag.IsReadOnly Property
NPropertyBag Class Neurotec Namespace

Checks whether the property bag is read-only.

C#
public bool IsReadOnly;


NPropertyBag.Keys Property

NPropertyBag.Keys Property
NPropertyBag Class Neurotec Namespace

Gets the collection of key values.

C#
public KeyCollection Keys;


NPropertyBag.NativeType Property

NPropertyBag.NativeType Property
NPropertyBag Class Neurotec Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NPropertyBag.Values Property

NPropertyBag.Values Property
NPropertyBag Class Neurotec Namespace

Gets the collection of values.

C#
public ValueCollection Values;


NPropertyBag.CollectionChanged Event

NPropertyBag.CollectionChanged Event
NPropertyBag Class Neurotec Namespace

Adds or removes a handler for an event which occurs when collection is changed.

C#
public event NotifyCollectionChangedEventHandler CollectionChanged;


NRange Structure

NRange Structure
Legend Members Methods NRange Methods NRange Properties

Represents range.

C#
[Serializable]
[StructLayout(LayoutKind.Sequential)]
public struct NRange : IFormattable {
}
Collapse Expand NRange Methods
Name | Description
ToString | Retrieves a string representation of the range object.
Collapse Expand NRange Properties
Name | Description
From | Gets or sets lower bound of a range.
NativeType | Defines the native type of the type.
To | Gets or sets upper bound of a range.
Container

File: NTypes.cs

Namespace: Neurotec

Module: .NET Reference


NRange.NRange Constructor

NRange.NRange Constructor
NRange Structure Neurotec Namespace

Initializes a new instance of the NRange structure.

C#
public NRange(int from, int to);
Collapse Expand Parameters
Parameters | Description
int from | lower bound of a range to be created.
int to | upper bound of a range to be created.


NRange.ToString Method ()

NRange.ToString Method ()
NRange Structure Neurotec Namespace

Retrieves a string representation of the range object.

C#
public override string ToString();
Collapse Expand Returns

String representation of the range.


NRange.ToString Method (string)

NRange.ToString Method (string)
NRange Structure Neurotec Namespace

Retrieves a string representation of the range object.

C#
public string ToString(string format);
Collapse Expand Parameters
Parameters | Description
string format | Reserved.
Collapse Expand Returns

A string representation of the range.


NRange.From Property

NRange.From Property
NRange Structure Neurotec Namespace

Gets or sets lower bound of a range.

C#
public int From;


NRange.NativeType Property

NRange.NativeType Property
NRange Structure Neurotec Namespace

Defines the native type of the type.

C#
public static NType NativeType;


NRange.To Property

NRange.To Property
NRange Structure Neurotec Namespace

Gets or sets upper bound of a range.

C#
public int To;


NRational Structure

NRational Structure
NRational Fields Legend Members Methods NRational Methods NRational Properties

Represents a signed rational number.

C#
[Serializable]
[StructLayout(LayoutKind.Sequential)]
public struct NRational : IFormattable {
  public static readonly NRational Empty = new NRational(0, 0);
}
Collapse Expand NRational Fields
Name | Description
Empty | Represents that NRational is a null reference.
Collapse Expand NRational Methods
Name | Description
ToString | Retrieves a string representation of the object.
Collapse Expand NRational Properties
Name | Description
Denominator | Sets or retrieves the NRational value Denominator.
NativeType | Defines the native type of the type.
Numerator | Sets or retrieves the NRational value Numerator.
Container

File: NTypes.cs

Namespace: Neurotec

Module: .NET Reference


NRational.NRational Constructor

NRational.NRational Constructor
NRational Structure Neurotec Namespace

Initializes a new instance of the NRational structure.

C#
public NRational(int numerator, int denominator);
Collapse Expand Parameters
Parameters | Description
int numerator | Numerator of this NRational.
int denominator | Denominator of this NRational.


NRational.Empty Field

NRational.Empty Field
NRational Structure Neurotec Namespace

Represents that NRational is a null reference.

C#
public static readonly NRational Empty = new NRational(0, 0);


NRational.ToString Method ()

NRational.ToString Method ()
NRational Structure Neurotec Namespace

Retrieves a string representation of the object.

C#
public override string ToString();
Collapse Expand Returns

A string representation of an object.


NRational.ToString Method (string)

NRational.ToString Method (string)
NRational Structure Neurotec Namespace

Retrieves a string representation of the object.

C#
public string ToString(string format);
Collapse Expand Parameters
Parameters | Description
string format | Format string.
Collapse Expand Returns

A string representation of an object.


NRational.Denominator Property

NRational.Denominator Property
NRational Structure Neurotec Namespace

Sets or retrieves the NRational value Denominator.

C#
public int Denominator;


NRational.NativeType Property

NRational.NativeType Property
NRational Structure Neurotec Namespace

Defines the native type of the type.

C#
public static NType NativeType;


NRational.Numerator Property

NRational.Numerator Property
NRational Structure Neurotec Namespace

Sets or retrieves the NRational value Numerator.

C#
public int Numerator;


NType Class

NType Class
NObject Delegates NObject Events NObject Fields Legend Members NDisposable Methods NDisposable Properties

Manages object types.

C#
public sealed class NType : NObject;
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NType Class
Name | Description
AddEventHandler | Adds a handler for the specified event to the specified object.
CapturePropertyValues | Captures property values of the specified object.
CopyPropertyValues | Copies properties from one object to another object.
CreateInstance | Creates an instance of the specified type.
GetDeclaredConstant | Retrieves the declared constant specified by name.
GetDeclaredEnumConstant | Retrieves the declared enumeration constant specified by name.
GetDeclaredEvent | Retrieves the declared event specified by name.
GetDeclaredField | Retrieves the declared field specified by name.
GetDeclaredMethod | Retrieves the declared method specified by index.
GetDeclaredMethods | Retrieves all declared methods of the specified type.
GetDeclaredPart | Retrieves the declared part specified by name.
GetDeclaredProperty | Retrieves the declared property specified by name.
GetPropertyValue<T> | Retrieves the specified property of the specified object.
GetType | Retrieves the type specified by name.
IdentifierToString | Converts the specified identifier into a string.
InvokeMethod | Invokes the specified method on the specified object.
IsAssignableFrom | Checks whether the current type is assignable from the specified type.
IsInstanceOfType | Checks whether the current type is an instance of the specified object.
IsSubclassOf | Checks whether the current type is a subclass of the specified type.
RemoveEventHandler | Removes a handler for the specified event to the specified object.
Reset | Resets the specified object.
ResetPropertyValue | Resets the specified property.
SetPropertyValue<T> | Sets the value of the specified property.
ToNativeType | Converts the specified type to a native type.
ToType | Converts the current value into a type.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NType Class
Name | Description
Attributes | Gets attributes of the specified type.
BaseType | Gets the base type of the current type.
DeclaredConstants | Gets all declared constants of the specified type.
DeclaredConstructors | Gets all declared constructors of the specified type.
DeclaredEnumConstants | Retrieves all declared enumeration constants of the specified type.
DeclaredEvents | Retrieves all declared events of the specified type.
DeclaredFields | Retrieves all declared fields of the specified type.
DeclaredMethods | Retrieves all declared methods of the specified type.
DeclaredParts | Retrieves all declared parts of the specified type.
DeclaredProperties | Retrieves all declared properties of the specified type.
EnumAlternative | Retrieves alternative enumeration for the specified type.
HasOwnerType | Checks whether the current type has an owner type.
IsAbstract | Checks whether the current type is abstract.
IsBasic | Checks whether the current type is a basic type.
IsCallback | Checks whether the current type is a callback type.
IsCloneable | Checks whether the current type is cloneable.
IsComparable | Checks whether the current type is comparable.
IsDeprecated | Checks whether the current type is deprecated.
IsDisposable | Checks whether the current type is disposable.
IsEnum | Checks whether the current type is an enum type.
IsEquatable | Checks whether the current type is equatable.
IsFlagsEnum | Checks whether the current type is a flags enum.
IsHandle | Checks whether the current type is a handle type.
IsMemorySerializable | Checks whether the current type is memory serializable.
IsObject | Checks whether the current type is an object type.
IsParsable | Checks whether the current type is parsable.
IsPrimitive | Checks whether the current type is a primitive type.
IsPublic | Checks whether the current type is public.
IsSealed | Checks whether the current type is sealed.
IsSerializable | Checks whether the current type is serializable.
IsSignNeutral | Checks whether the current type is sign-neutral.
IsStatic | Checks whether the current type is static.
IsStruct | Checks whether the current type is a struct type.
Module | Gets the module of the current type.
NTypeCodeNativeType | Defines the native type of the type code.
Name | Gets the name of the current type.
NativeType | Defines the native type of the object.
OwnerType | Gets the owner type of the current type.
RootType | Gets the root type of the current type.
RootTypeCode | Returns NTypeCode for the root type of the current type.
TypeCode | Returns NTypeCode for the current type.
UseInsteadType | Gets the type to be used instead of current type.
ValueSize | Gets the size of the current value.
Container

File: NType.cs

Namespace: Neurotec

Module: .NET Reference


NType.AddEventHandler Method

NType.AddEventHandler Method
NType Class Neurotec Namespace

Adds a handler for the specified event to the specified object.

C#
public void AddEventHandler(NObject @object, string name, Delegate value);
Collapse Expand Parameters
Parameters | Description
NObject @object | Object to add a handler.
string name | Event name.
Delegate value | Delegate value.


NType.CapturePropertyValues Method

NType.CapturePropertyValues Method
NType Class Neurotec Namespace

Captures property values of the specified object.

C#
public void CapturePropertyValues(NObject @object, NPropertyBag properties);
Collapse Expand Parameters
Parameters | Description
NObject @object | Object to capture its property values.
NPropertyBag properties | Property bag that receives the properties from the object.


NType.CopyPropertyValues Method

NType.CopyPropertyValues Method
NType Class Neurotec Namespace

Copies properties from one object to another object.

C#
public void CopyPropertyValues(NObject dstObject, NObject srcObject);
Collapse Expand Parameters
Parameters | Description
NObject dstObject | The destination object.
NObject srcObject | The source object.


NType.CreateInstance Method ()

NType.CreateInstance Method ()
NType Class Neurotec Namespace

Creates an instance of the specified type.

C#
public object CreateInstance();
Collapse Expand Returns

Created object.


NType.CreateInstance Method (NAttributes)

NType.CreateInstance Method (NAttributes)
NType Class Neurotec Namespace

Creates an instance of the specified type.

C#
public object CreateInstance(NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Type attributes.
Collapse Expand Returns

Created object.


NType.CreateInstance Method (string)

NType.CreateInstance Method (string)
NType Class Neurotec Namespace

Creates an instance of the specified type.

C#
public static object CreateInstance(string name);
Collapse Expand Parameters
Parameters | Description
string name | Type name.
Collapse Expand Returns

Created object.


NType.CreateInstance Method (string, NAttributes)

NType.CreateInstance Method (string, NAttributes)
NType Class Neurotec Namespace

Creates an instance of the specified type.

C#
public static object CreateInstance(string name, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
string name | Type name.
NAttributes attributes | Type attributes.
Collapse Expand Returns

Created object.


NType.GetDeclaredConstant Method

NType.GetDeclaredConstant Method
NType Class Neurotec Namespace

Retrieves the declared constant specified by name.

C#
public NConstantInfo GetDeclaredConstant(string name);
Collapse Expand Parameters
Parameters | Description
string name | Constant name.
Collapse Expand Returns

NConstantInfo object.


NType.GetDeclaredEnumConstant Method

NType.GetDeclaredEnumConstant Method
NType Class Neurotec Namespace

Retrieves the declared enumeration constant specified by name.

C#
public NEnumConstantInfo GetDeclaredEnumConstant(string name);
Collapse Expand Parameters
Parameters | Description
string name | Enumeration constant name.
Collapse Expand Returns

NEnumConstantInfo object.


NType.GetDeclaredEvent Method

NType.GetDeclaredEvent Method
NType Class Neurotec Namespace

Retrieves the declared event specified by name.

C#
public NEventInfo GetDeclaredEvent(string name);
Collapse Expand Parameters
Parameters | Description
string name | Declared event name.
Collapse Expand Returns

NEventInfo object.


NType.GetDeclaredField Method

NType.GetDeclaredField Method
NType Class Neurotec Namespace

Retrieves the declared field specified by name.

C#
public NPropertyInfo GetDeclaredField(string name);
Collapse Expand Parameters
Parameters | Description
string name | Declared field name.
Collapse Expand Returns

NPropertyInfo object.


NType.GetDeclaredMethod Method

NType.GetDeclaredMethod Method
NType Class Neurotec Namespace

Retrieves the declared method specified by index.

C#
public NMethodInfo GetDeclaredMethod(string name);
Collapse Expand Parameters
Parameters | Description
string name | Declared method name.
Collapse Expand Returns

NMethodInfo object.


NType.GetDeclaredMethods Method

NType.GetDeclaredMethods Method
NType Class Neurotec Namespace

Retrieves all declared methods of the specified type.

C#
public NMethodInfo[] GetDeclaredMethods(string name);
Collapse Expand Parameters
Parameters | Description
string name | Declared methods name.
Collapse Expand Returns

Array of declared methods objects.


NType.GetDeclaredPart Method

NType.GetDeclaredPart Method
NType Class Neurotec Namespace

Retrieves the declared part specified by name.

C#
public NObjectPartInfo GetDeclaredPart(string name);
Collapse Expand Parameters
Parameters | Description
string name | Declared part name.
Collapse Expand Returns

NObjectPartInfo object.


NType.GetDeclaredProperty Method

NType.GetDeclaredProperty Method
NType Class Neurotec Namespace

Retrieves the declared property specified by name.

C#
public NPropertyInfo GetDeclaredProperty(string name);
Collapse Expand Parameters
Parameters | Description
string name | Declared property name.
Collapse Expand Returns

NPropertyInfo object.


NType.GetPropertyValue<T> Method

NType.GetPropertyValue<T> Method
NType Class Neurotec Namespace

Retrieves the specified property of the specified object.

C#
public T GetPropertyValue<T>(NObject obj, string name);
Collapse Expand Parameters
Parameters | Description
NObject obj | The object to retrieve a property of.
string name | Name of the property.
T | Type of the property.
Collapse Expand Returns

The property value.


NType.GetType Method (string)

NType.GetType Method (string)
NType Class Neurotec Namespace

Retrieves the type specified by name.

C#
public static NType GetType(string name);
Collapse Expand Parameters
Parameters | Description
string name | Type name.
Collapse Expand Returns

NType object.


NType.GetType Method (string, bool)

NType.GetType Method (string, bool)
NType Class Neurotec Namespace

Retrieves the type specified by name.

C#
public static NType GetType(string name, bool mustExist);
Collapse Expand Parameters
Parameters | Description
string name | Type name.
bool mustExist | Variable defining if type must exist.
Collapse Expand Returns

NType object.


NType.IdentifierToString Method (string)

NType.IdentifierToString Method (string)
NType Class Neurotec Namespace

Converts the specified identifier into a string.

C#
public static string IdentifierToString(string value);
Collapse Expand Parameters
Parameters | Description
string value | The identifier.
Collapse Expand Returns

String, representing the identifier.


NType.IdentifierToString Method (string, string)

NType.IdentifierToString Method (string, string)
NType Class Neurotec Namespace

Converts the specified identifier into a string.

C#
public static string IdentifierToString(string value, string format);
Collapse Expand Parameters
Parameters | Description
string value | The identifier.
string format | Format string.
Collapse Expand Returns

String, representing the identifier.


NType.InvokeMethod Method (NObject, string, NPropertyBag)

NType.InvokeMethod Method (NObject, string, NPropertyBag)
NType Class Neurotec Namespace

Invokes the specified method on the specified object.

C#
public object InvokeMethod(NObject @object, string name, NPropertyBag parameters);
Collapse Expand Parameters
Parameters | Description
NObject @object | Object to invoke method from.
string name | Method name to invoke.
NPropertyBag parameters | Method parameters
Collapse Expand Returns

Result returned by the invoked method.


NType.InvokeMethod Method (NObject, string, object[])

NType.InvokeMethod Method (NObject, string, object[])
NType Class Neurotec Namespace

Invokes the specified method on the specified object.

C#
public object InvokeMethod(NObject @object, string name, object[] parameters);
Collapse Expand Parameters
Parameters | Description
NObject @object | Object to invoke method from.
string name | Method name to invoke.
object[] parameters | Array of method parameters
Collapse Expand Returns

Result returned by the invoked method.


NType.InvokeMethod Method (NObject, string, string)

NType.InvokeMethod Method (NObject, string, string)
NType Class Neurotec Namespace

Invokes the specified method on the specified object.

C#
public object InvokeMethod(NObject @object, string name, string parameters);
Collapse Expand Parameters
Parameters | Description
NObject @object | Object to invoke method from.
string name | Method name to invoke.
string parameters | Method parameters.
Collapse Expand Returns

Result returned by the invoked method.


NType.IsAssignableFrom Method

NType.IsAssignableFrom Method
NType Class Neurotec Namespace

Checks whether the current type is assignable from the specified type.

C#
public bool IsAssignableFrom(NType type);
Collapse Expand Parameters
Parameters | Description
NType type | The specified type.
Collapse Expand Returns

NTrue if the current type is assignable from another type; else false.


NType.IsInstanceOfType Method

NType.IsInstanceOfType Method
NType Class Neurotec Namespace

Checks whether the current type is an instance of the specified object.

C#
public bool IsInstanceOfType(NObject obj);
Collapse Expand Parameters
Parameters | Description
NObject obj | The specified object.
Collapse Expand Returns

true if the current type is an instance of the object; else false


NType.IsSubclassOf Method

NType.IsSubclassOf Method
NType Class Neurotec Namespace

Checks whether the current type is a subclass of the specified type.

C#
public bool IsSubclassOf(NType type);
Collapse Expand Parameters
Parameters | Description
NType type | The specified type.
Collapse Expand Returns

NTrue if the current type is a subclass of another type; else NFalse.


NType.RemoveEventHandler Method

NType.RemoveEventHandler Method
NType Class Neurotec Namespace

Removes a handler for the specified event to the specified object.

C#
public void RemoveEventHandler(NObject @object, string name, Delegate value);
Collapse Expand Parameters
Parameters | Description
NObject @object | Object to from which to remove a handler.
string name | Event name.
Delegate value | Delegate value.


NType.Reset Method

NType.Reset Method
NType Class Neurotec Namespace

Resets the specified object.

C#
public void Reset(NObject obj);
Collapse Expand Parameters
Parameters | Description
NObject obj | The specified object.


NType.ResetPropertyValue Method

NType.ResetPropertyValue Method
NType Class Neurotec Namespace

Resets the specified property.

C#
public void ResetPropertyValue(NObject obj, string name);
Collapse Expand Parameters
Parameters | Description
NObject obj | The object to reset the property of.
string name | Name of the property.


NType.SetPropertyValue<T> Method (NObject, string, T)

NType.SetPropertyValue<T> Method (NObject, string, T)
NType Class Neurotec Namespace

Sets the value of the specified property.

C#
public void SetPropertyValue<T>(NObject obj, string name, T value);
Collapse Expand Parameters
Parameters | Description
NObject obj | The object to set the property of.
string name | Name of the property.
T value | New value of the property.
T | Type of the property.


NType.SetPropertyValue Method (NObject, string, object)

NType.SetPropertyValue Method (NObject, string, object)
NType Class Neurotec Namespace

Sets the value of the specified property.

C#
public void SetPropertyValue(NObject obj, string name, object value);
Collapse Expand Parameters
Parameters | Description
NObject obj | The object to set the property of.
string name | Name of the property.
object value | New value of the property.


NType.ToNativeType Method

NType.ToNativeType Method
NType Class Neurotec Namespace

Converts the specified type to a native type.

C#
public static NType ToNativeType(Type value, NAttributes attributes, bool deepMap);
Collapse Expand Parameters
Parameters | Description
Type value | The type to be converted.
NAttributes attributes | Type attributes.
bool deepMap | true if deep map is to be used; else false
Collapse Expand Returns

The native type.


NType.ToType Method ()

NType.ToType Method ()
NType Class Neurotec Namespace

Converts the current value into a type.

C#
public Type ToType();
Collapse Expand Returns

The type value.


NType.ToType Method (NAttributes, bool)

NType.ToType Method (NAttributes, bool)
NType Class Neurotec Namespace

Converts the current value into a type.

C#
public Type ToType(NAttributes attributes, bool deepMap);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Type attributes.
bool deepMap | true if deep map is to be used; else false
Collapse Expand Returns

The type value.


NType.ToType Method (NType, NAttributes, bool)

NType.ToType Method (NType, NAttributes, bool)
NType Class Neurotec Namespace

Converts the native type to a regular type.

C#
public static Type ToType(NType value, NAttributes attributes, bool deepMap);
Collapse Expand Parameters
Parameters | Description
NType value | The native type to be converted.
NAttributes attributes | Type attributes.
bool deepMap | true if deep map is to be used; else false
Collapse Expand Returns

Type value.


NType.Attributes Property

NType.Attributes Property
NType Class Neurotec Namespace

Gets attributes of the specified type.

C#
public NAttributes Attributes;
Property value

NAttributes object.


NType.BaseType Property

NType.BaseType Property
NType Class Neurotec Namespace

Gets the base type of the current type.

C#
public NType BaseType;


NType.DeclaredConstants Property

NType.DeclaredConstants Property
NType Class Neurotec Namespace

Gets all declared constants of the specified type.

C#
public DeclaredConstantCollection DeclaredConstants;
Property value

DeclaredConstantCollection object.


NType.DeclaredConstructors Property

NType.DeclaredConstructors Property
NType Class Neurotec Namespace

Gets all declared constructors of the specified type.

C#
public DeclaredConstructorCollection DeclaredConstructors;
Property value

DeclaredConstructorCollection object.


NType.DeclaredEnumConstants Property

NType.DeclaredEnumConstants Property
NType Class Neurotec Namespace

Retrieves all declared enumeration constants of the specified type.

C#
public DeclaredEnumConstantCollection DeclaredEnumConstants;
Property value

DeclaredEnumConstantCollection object.


NType.DeclaredEvents Property

NType.DeclaredEvents Property
NType Class Neurotec Namespace

Retrieves all declared events of the specified type.

C#
public DeclaredEventCollection DeclaredEvents;
Property value

DeclaredEventCollection object.


NType.DeclaredFields Property

NType.DeclaredFields Property
NType Class Neurotec Namespace

Retrieves all declared fields of the specified type.

C#
public DeclaredFieldCollection DeclaredFields;
Property value

DeclaredFieldCollection object.


NType.DeclaredMethods Property

NType.DeclaredMethods Property
NType Class Neurotec Namespace

Retrieves all declared methods of the specified type.

C#
public DeclaredMethodCollection DeclaredMethods;
Property value

DeclaredMethodCollection object.


NType.DeclaredParts Property

NType.DeclaredParts Property
NType Class Neurotec Namespace

Retrieves all declared parts of the specified type.

C#
public DeclaredPartCollection DeclaredParts;
Property value

DeclaredPartCollection object.


NType.DeclaredProperties Property

NType.DeclaredProperties Property
NType Class Neurotec Namespace

Retrieves all declared properties of the specified type.

C#
public DeclaredPropertyCollection DeclaredProperties;
Property value

DeclaredPropertyCollection object.


NType.EnumAlternative Property

NType.EnumAlternative Property
NType Class Neurotec Namespace

Retrieves alternative enumeration for the specified type.

C#
public NType EnumAlternative;
Property value

NType object.


NType.HasOwnerType Property

NType.HasOwnerType Property
NType Class Neurotec Namespace

Checks whether the current type has an owner type.

C#
public bool HasOwnerType;


NType.IsAbstract Property

NType.IsAbstract Property
NType Class Neurotec Namespace

Checks whether the current type is abstract.

C#
public bool IsAbstract;


NType.IsBasic Property

NType.IsBasic Property
NType Class Neurotec Namespace

Checks whether the current type is a basic type.

C#
public bool IsBasic;


NType.IsCallback Property

NType.IsCallback Property
NType Class Neurotec Namespace

Checks whether the current type is a callback type.

C#
public bool IsCallback;


NType.IsCloneable Property

NType.IsCloneable Property
NType Class Neurotec Namespace

Checks whether the current type is cloneable.

C#
public bool IsCloneable;


NType.IsComparable Property

NType.IsComparable Property
NType Class Neurotec Namespace

Checks whether the current type is comparable.

C#
public bool IsComparable;


NType.IsDeprecated Property

NType.IsDeprecated Property
NType Class Neurotec Namespace

Checks whether the current type is deprecated.

C#
public bool IsDeprecated;


NType.IsDisposable Property

NType.IsDisposable Property
NType Class Neurotec Namespace

Checks whether the current type is disposable.

C#
public bool IsDisposable;


NType.IsEnum Property

NType.IsEnum Property
NType Class Neurotec Namespace

Checks whether the current type is an enum type.

C#
public bool IsEnum;


NType.IsEquatable Property

NType.IsEquatable Property
NType Class Neurotec Namespace

Checks whether the current type is equatable.

C#
public bool IsEquatable;


NType.IsFlagsEnum Property

NType.IsFlagsEnum Property
NType Class Neurotec Namespace

Checks whether the current type is a flags enum.

C#
public bool IsFlagsEnum;


NType.IsHandle Property

NType.IsHandle Property
NType Class Neurotec Namespace

Checks whether the current type is a handle type.

C#
public bool IsHandle;


NType.IsMemorySerializable Property

NType.IsMemorySerializable Property
NType Class Neurotec Namespace

Checks whether the current type is memory serializable.

C#
public bool IsMemorySerializable;


NType.IsObject Property

NType.IsObject Property
NType Class Neurotec Namespace

Checks whether the current type is an object type.

C#
public bool IsObject;


NType.IsParsable Property

NType.IsParsable Property
NType Class Neurotec Namespace

Checks whether the current type is parsable.

C#
public bool IsParsable;


NType.IsPrimitive Property

NType.IsPrimitive Property
NType Class Neurotec Namespace

Checks whether the current type is a primitive type.

C#
public bool IsPrimitive;


NType.IsPublic Property

NType.IsPublic Property
NType Class Neurotec Namespace

Checks whether the current type is public.

C#
public bool IsPublic;


NType.IsSealed Property

NType.IsSealed Property
NType Class Neurotec Namespace

Checks whether the current type is sealed.

C#
public bool IsSealed;


NType.IsSerializable Property

NType.IsSerializable Property
NType Class Neurotec Namespace

Checks whether the current type is serializable.

C#
public bool IsSerializable;


NType.IsSignNeutral Property

NType.IsSignNeutral Property
NType Class Neurotec Namespace

Checks whether the current type is sign-neutral.

C#
public bool IsSignNeutral;


NType.IsStatic Property

NType.IsStatic Property
NType Class Neurotec Namespace

Checks whether the current type is static.

C#
public bool IsStatic;


NType.IsStruct Property

NType.IsStruct Property
NType Class Neurotec Namespace

Checks whether the current type is a struct type.

C#
public bool IsStruct;


NType.Module Property

NType.Module Property
NType Class Neurotec Namespace

Gets the module of the current type.

C#
public NModule Module;


NType.NTypeCodeNativeType Property

NType.NTypeCodeNativeType Property
NType Class Neurotec Namespace

Defines the native type of the type code.

C#
public static NType NTypeCodeNativeType;


NType.Name Property

NType.Name Property
NType Class Neurotec Namespace

Gets the name of the current type.

C#
public string Name;


NType.NativeType Property

NType.NativeType Property
NType Class Neurotec Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NType.OwnerType Property

NType.OwnerType Property
NType Class Neurotec Namespace

Gets the owner type of the current type.

C#
public NType OwnerType;


NType.RootType Property

NType.RootType Property
NType Class Neurotec Namespace

Gets the root type of the current type.

C#
public NType RootType;


NType.RootTypeCode Property

NType.RootTypeCode Property
NType Class Neurotec Namespace

Returns NTypeCode for the root type of the current type.

C#
public NTypeCode RootTypeCode;


NType.TypeCode Property

NType.TypeCode Property
NType Class Neurotec Namespace

Returns NTypeCode for the current type.

C#
public NTypeCode TypeCode;


NType.UseInsteadType Property

NType.UseInsteadType Property
NType Class Neurotec Namespace

Gets the type to be used instead of current type.

C#
public NType UseInsteadType;


NType.ValueSize Property

NType.ValueSize Property
NType Class Neurotec Namespace

Gets the size of the current value.

C#
public int ValueSize;


NTypes Class

NTypes Class
NTypes Fields Legend Members NTypes Methods NTypes Properties

Manages object types.

C#
public static class NTypes;
Collapse Expand NTypes Fields
Name | Description
StringEncoding | The string encoding.
WCharApi | Whether the Unicode char API is supported.
Collapse Expand NTypes Methods
Name | Description
CreateCallback | Creates a new callback.
FreeObjectPointer | Decrements the reference count for a specified pointer.
FreeStringArray | Frees specified strings.
FreeStringElements | Frees specified string elements.
GetObjectFromPointer | Retrieves an object from a pointer.
GetPointerForObject | Increments the reference count for a pointer to a specified object.
IsMemoryTypeValid | Checks whether the memory type is valid.
IsMemoryTypeValidForFree | Checks whether the memory type is valid for freeing.
Collapse Expand NTypes Properties
Name | Description
NACharNativeType | Gets the native type of the ASCII char.
NAttributesNativeType | Gets the native type of the NAttributes value.
NBooleanNativeType | Gets the native type of the Boolean value.
NCallbackNativeType | Gets the native type of the callback.
NCharNativeType | Gets the native type of the char.
NDateTimeNativeType | Gets the native type of the NDateTime object.
NDoubleNativeType | Gets the native type of the double number.
NGuidNativeType | Gets the native type of the global unique identifier.
NInt16NativeType | Gets the native type of the 16-bit integer.
NInt32NativeType | Gets the native type of the 32-bit integer.
NInt64NativeType | Gets the native type of the 64-bit integer.
NInt8NativeType | Gets the native type of the 8-bit integer.
NMemoryTypeNativeType | Gets the native type of the memory type.
NOSFamilyNativeType | Gets the native type of the OS family.
NPointerNativeType | Gets the native type of the pointer.
NResultNativeType | Gets the native type of the NResult value.
NSSizeTypeNativeType | Gets the native type of the integer pointer.
NSingleNativeType | Gets the native type of the floating point value.
NSizeTypeNativeType | Gets the native type of the unsigned integer pointer.
NStringNativeType | Gets the native type of the string.
NTimeSpanNativeType | Gets the native type of the NTimeSpan value.
NUInt16NativeType | Gets the native type of the unsigned 16-bit integer.
NUInt32NativeType | Gets the native type of the unsigned 32-bit integer.
NUInt64NativeType | Gets the native type of the unsigned 64-bit integer.
NUInt8NativeType | Gets the native type of the unsigned 8-bit integer.
NWCharNativeType | Gets the native type of the Unicode char.
NameStringPairNativeType | Gets the native type of the name string pair.
NativeType | Gets the native type of the object.
OSFamilyCurrent | Gets the current OS family.
Container

File: NTypes.cs

Namespace: Neurotec

Module: .NET Reference


NTypes.StringEncoding Field

NTypes.StringEncoding Field
NTypes Class Neurotec Namespace

The string encoding.

C#
public static readonly NEncoding StringEncoding;


NTypes.WCharApi Field

NTypes.WCharApi Field
NTypes Class Neurotec Namespace

Whether the Unicode char API is supported.

C#
public static readonly bool WCharApi;


NTypes.CreateCallback Method (Delegate, Delegate)

NTypes.CreateCallback Method (Delegate, Delegate)
NTypes Class Neurotec Namespace

Creates a new callback.

C#
public static HNCallback CreateCallback(Delegate callback, Delegate del);
Collapse Expand Parameters
Parameters | Description
Delegate callback | Native callback delegate.
Delegate del | Managed delegate.
Collapse Expand Returns

The new callback.


NTypes.CreateCallback Method (Delegate, NObject, Delegate)

NTypes.CreateCallback Method (Delegate, NObject, Delegate)
NTypes Class Neurotec Namespace

Creates a new callback.

C#
public static HNCallback CreateCallback(Delegate callback, NObject target, Delegate del);
Collapse Expand Parameters
Parameters | Description
Delegate callback | Native callback delegate.
NObject target | Target object.
Delegate del | Managed delegate.
Collapse Expand Returns

The new callback.


NTypes.CreateCallback Method (Delegate, NObject, Func<NObject, object>, object, Delegate)

NTypes.CreateCallback Method (Delegate, NObject, Func<NObject, object>, object, Delegate)
NTypes Class Neurotec Namespace

Creates a new callback.

C#
public static HNCallback CreateCallback(Delegate callback, NObject target, Func<NObject, object> targetTransform, object param, Delegate del);
Collapse Expand Parameters
Parameters | Description
Delegate callback | Native callback delegate.
NObject target | Target object.
Func<NObject, object> targetTransform | Target transformation function.
object param | Parameter for target transformation function.
Delegate del | Managed delegate.
Collapse Expand Returns

The new callback.


NTypes.CreateCallback Method (Delegate, object)

NTypes.CreateCallback Method (Delegate, object)
NTypes Class Neurotec Namespace

Creates a new callback.

C#
public static HNCallback CreateCallback(Delegate callback, object param);
Collapse Expand Parameters
Parameters | Description
Delegate callback | Native callback delegate.
object param | Callback parameters.
Collapse Expand Returns

The new callback.


NTypes.FreeObjectPointer Method

NTypes.FreeObjectPointer Method
NTypes Class Neurotec Namespace

Decrements the reference count for a specified pointer.

C#
public static void FreeObjectPointer(IntPtr ptr);
Collapse Expand Parameters
Parameters | Description
IntPtr ptr | The pointer.


NTypes.FreeStringArray Method

NTypes.FreeStringArray Method
NTypes Class Neurotec Namespace

Frees specified strings.

C#
public static void FreeStringArray(IntPtr arhStrings, int count);
Collapse Expand Parameters
Parameters | Description
IntPtr arhStrings | Pointer to an array of strings.
int count | Number of strings in the array.


NTypes.FreeStringElements Method

NTypes.FreeStringElements Method
NTypes Class Neurotec Namespace

Frees specified string elements.

C#
public static void FreeStringElements(IntPtr arhStrings, int count);
Collapse Expand Parameters
Parameters | Description
IntPtr arhStrings | Pointer to an array of string elements.
int count | Number of string elements in the array.


NTypes.GetObjectFromPointer Method

NTypes.GetObjectFromPointer Method
NTypes Class Neurotec Namespace

Retrieves an object from a pointer.

C#
public static object GetObjectFromPointer(IntPtr ptr);
Collapse Expand Parameters
Parameters | Description
IntPtr ptr | A pointer indicating the object.
Collapse Expand Returns

A pointer to the object.


NTypes.GetPointerForObject Method

NTypes.GetPointerForObject Method
NTypes Class Neurotec Namespace

Increments the reference count for a pointer to a specified object.

C#
public static IntPtr GetPointerForObject(object obj);
Collapse Expand Parameters
Parameters | Description
object obj | The object.
Collapse Expand Returns

The pointer to the object.


NTypes.IsMemoryTypeValid Method

NTypes.IsMemoryTypeValid Method
NTypes Class Neurotec Namespace

Checks whether the memory type is valid.

C#
public static bool IsMemoryTypeValid(NMemoryType value);
Collapse Expand Parameters
Parameters | Description
NMemoryType value | The memory type.
Collapse Expand Returns

NTrue if the memory type is valid; else NFalse.


NTypes.IsMemoryTypeValidForFree Method

NTypes.IsMemoryTypeValidForFree Method
NTypes Class Neurotec Namespace

Checks whether the memory type is valid for freeing.

C#
public static bool IsMemoryTypeValidForFree(NMemoryType value);
Collapse Expand Parameters
Parameters | Description
NMemoryType value | The memory type.
Collapse Expand Returns

NTrue if the memory type is valid; else NFalse.


NTypes.NACharNativeType Property

NTypes.NACharNativeType Property
NTypes Class Neurotec Namespace

Gets the native type of the ASCII char.

C#
public static NType NACharNativeType;


NTypes.NAttributesNativeType Property

NTypes.NAttributesNativeType Property
NTypes Class Neurotec Namespace

Gets the native type of the NAttributes value.

C#
public static NType NAttributesNativeType;


NTypes.NBooleanNativeType Property

NTypes.NBooleanNativeType Property
NTypes Class Neurotec Namespace

Gets the native type of the Boolean value.

C#
public static NType NBooleanNativeType;


NTypes.NCallbackNativeType Property

NTypes.NCallbackNativeType Property
NTypes Class Neurotec Namespace

Gets the native type of the callback.

C#
public static NType NCallbackNativeType;


NTypes.NCharNativeType Property

NTypes.NCharNativeType Property
NTypes Class Neurotec Namespace

Gets the native type of the char.

C#
public static NType NCharNativeType;


NTypes.NDateTimeNativeType Property

NTypes.NDateTimeNativeType Property
NTypes Class Neurotec Namespace

Gets the native type of the NDateTime object.

C#
public static NType NDateTimeNativeType;


NTypes.NDoubleNativeType Property

NTypes.NDoubleNativeType Property
NTypes Class Neurotec Namespace

Gets the native type of the double number.

C#
public static NType NDoubleNativeType;


NTypes.NGuidNativeType Property

NTypes.NGuidNativeType Property
NTypes Class Neurotec Namespace

Gets the native type of the global unique identifier.

C#
public static NType NGuidNativeType;


NTypes.NInt16NativeType Property

NTypes.NInt16NativeType Property
NTypes Class Neurotec Namespace

Gets the native type of the 16-bit integer.

C#
public static NType NInt16NativeType;


NTypes.NInt32NativeType Property

NTypes.NInt32NativeType Property
NTypes Class Neurotec Namespace

Gets the native type of the 32-bit integer.

C#
public static NType NInt32NativeType;


NTypes.NInt64NativeType Property

NTypes.NInt64NativeType Property
NTypes Class Neurotec Namespace

Gets the native type of the 64-bit integer.

C#
public static NType NInt64NativeType;


NTypes.NInt8NativeType Property

NTypes.NInt8NativeType Property
NTypes Class Neurotec Namespace

Gets the native type of the 8-bit integer.

C#
public static NType NInt8NativeType;


NTypes.NMemoryTypeNativeType Property

NTypes.NMemoryTypeNativeType Property
NTypes Class Neurotec Namespace

Gets the native type of the memory type.

C#
public static NType NMemoryTypeNativeType;


NTypes.NOSFamilyNativeType Property

NTypes.NOSFamilyNativeType Property
NTypes Class Neurotec Namespace

Gets the native type of the OS family.

C#
public static NType NOSFamilyNativeType;


NTypes.NPointerNativeType Property

NTypes.NPointerNativeType Property
NTypes Class Neurotec Namespace

Gets the native type of the pointer.

C#
public static NType NPointerNativeType;


NTypes.NResultNativeType Property

NTypes.NResultNativeType Property
NTypes Class Neurotec Namespace

Gets the native type of the NResult value.

C#
public static NType NResultNativeType;


NTypes.NSSizeTypeNativeType Property

NTypes.NSSizeTypeNativeType Property
NTypes Class Neurotec Namespace

Gets the native type of the integer pointer.

C#
public static NType NSSizeTypeNativeType;


NTypes.NSingleNativeType Property

NTypes.NSingleNativeType Property
NTypes Class Neurotec Namespace

Gets the native type of the floating point value.

C#
public static NType NSingleNativeType;


NTypes.NSizeTypeNativeType Property

NTypes.NSizeTypeNativeType Property
NTypes Class Neurotec Namespace

Gets the native type of the unsigned integer pointer.

C#
public static NType NSizeTypeNativeType;


NTypes.NStringNativeType Property

NTypes.NStringNativeType Property
NTypes Class Neurotec Namespace

Gets the native type of the string.

C#
public static NType NStringNativeType;


NTypes.NTimeSpanNativeType Property

NTypes.NTimeSpanNativeType Property
NTypes Class Neurotec Namespace

Gets the native type of the NTimeSpan value.

C#
public static NType NTimeSpanNativeType;


NTypes.NUInt16NativeType Property

NTypes.NUInt16NativeType Property
NTypes Class Neurotec Namespace

Gets the native type of the unsigned 16-bit integer.

C#
public static NType NUInt16NativeType;


NTypes.NUInt32NativeType Property

NTypes.NUInt32NativeType Property
NTypes Class Neurotec Namespace

Gets the native type of the unsigned 32-bit integer.

C#
public static NType NUInt32NativeType;


NTypes.NUInt64NativeType Property

NTypes.NUInt64NativeType Property
NTypes Class Neurotec Namespace

Gets the native type of the unsigned 64-bit integer.

C#
public static NType NUInt64NativeType;


NTypes.NUInt8NativeType Property

NTypes.NUInt8NativeType Property
NTypes Class Neurotec Namespace

Gets the native type of the unsigned 8-bit integer.

C#
public static NType NUInt8NativeType;


NTypes.NWCharNativeType Property

NTypes.NWCharNativeType Property
NTypes Class Neurotec Namespace

Gets the native type of the Unicode char.

C#
public static NType NWCharNativeType;


NTypes.NameStringPairNativeType Property

NTypes.NameStringPairNativeType Property
NTypes Class Neurotec Namespace

Gets the native type of the name string pair.

C#
public static NType NameStringPairNativeType;


NTypes.NativeType Property

NTypes.NativeType Property
NTypes Class Neurotec Namespace

Gets the native type of the object.

C#
public static NType NativeType;


NTypes.OSFamilyCurrent Property

NTypes.OSFamilyCurrent Property
NTypes Class Neurotec Namespace

Gets the current OS family.

C#
public static NOSFamily OSFamilyCurrent;


NURational Structure

NURational Structure
NURational Fields Legend Members Methods NURational Methods NURational Properties

Represents an unsigned rational number.

C#
[Serializable]
[StructLayout(LayoutKind.Sequential)]
public struct NURational : IFormattable {
  public static readonly NURational Empty = new NURational(0, 0);
}
Collapse Expand NURational Fields
Name | Description
Empty | Represents a NURational that is a null reference.
Collapse Expand NURational Methods
Name | Description
ToString | Retrieves a string representation of the object.
Collapse Expand NURational Properties
Name | Description
Denominator | Sets or retrieves the NRational value Denominator.
NativeType | Defines the native type of the type.
Numerator | Sets or retrieves the NRational value Numerator.
Container

File: NTypes.cs

Namespace: Neurotec

Module: .NET Reference


NURational.NURational Constructor

NURational.NURational Constructor
NURational Structure Neurotec Namespace

Initializes a new instance of the NURational structure.

C#
public NURational(uint numerator, uint denominator);
Collapse Expand Parameters
Parameters | Description
uint numerator | Numerator of this NURational.
uint denominator | Denominator of this NURational.


NURational.Empty Field

NURational.Empty Field
NURational Structure Neurotec Namespace

Represents a NURational that is a null reference.

C#
public static readonly NURational Empty = new NURational(0, 0);


NURational.ToString Method ()

NURational.ToString Method ()
NURational Structure Neurotec Namespace

Retrieves a string representation of the object.

C#
public override string ToString();
Collapse Expand Returns

A string representation of an object.


NURational.ToString Method (string)

NURational.ToString Method (string)
NURational Structure Neurotec Namespace

Retrieves a string representation of the object.

C#
public string ToString(string format);
Collapse Expand Parameters
Parameters | Description
string format | Format string.
Collapse Expand Returns

A string representation of an object.


NURational.Denominator Property

NURational.Denominator Property
NURational Structure Neurotec Namespace

Sets or retrieves the NRational value Denominator.

C#
public uint Denominator;


NURational.NativeType Property

NURational.NativeType Property
NURational Structure Neurotec Namespace

Defines the native type of the type.

C#
public static NType NativeType;


NURational.Numerator Property

NURational.Numerator Property
NURational Structure Neurotec Namespace

Sets or retrieves the NRational value Numerator.

C#
public uint Numerator;


NValue Class

NValue Class
NObject Delegates NObject Events NObject Fields Legend Members Methods NDisposable Methods NDisposable Properties

Provides functionality for management and conversion of values of different types.

C#
public class NValue : NObject, IConvertible;
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NValue Class
Name | Description
ChangeType | Changes the type of the specified value to the new type.
FromDelegate | Creates a new value from the specified delegate.
FromObject | Creates a new value from the specified object.
FromPointer | Creates a new value from the specified pointer.
FromResult | Creates a new value from the specified result.
FromString | Creates a new value from the specified string.
FromType<T> | Creates a new value from the specified type.
ToBoolean | Converts the specified value into a Boolean value.
ToByte | Converts the specified value into a byte.
ToChar | Converts the specified value into a char.
ToDouble | Converts the specified value into a double number.
ToInt16 | Converts the specified value into a short integer.
ToInt32 | Converts the specified value into an integer.
ToInt64 | Converts the specified value into a long integer.
ToIntPtr | Converts the specified value into a pointer.
ToObject | Converts the specified value into an object.
ToPointer | Converts the specified value into a pointer.
ToResult | Converts the specified value into a result.
ToSByte | Converts the specified value into a signed byte.
ToSingle | Converts the specified value into a floating point value.
ToString | Converts the specified value into a string.
ToType<T> | Converts the specified value into a value of specified type.
ToUInt16 | Converts the specified value into an unsigned short integer.
ToUInt32 | Converts the specified value into an unsigned integer.
ToUInt64 | Converts the specified value into an unsigned long integer.
ToUIntPtr | Converts the specified value into a pointer.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NValue Class
Name | Description
Attributes | Gets the value attributes.
IsWrapper | Checks whether the value is a wrapper.
KeyValuePairNativeType | Defines the native type of the key value pair structure.
LongSize | Gets the size of the value (64-bit).
NameValuePairNativeType | Defines the native type of the name value pair structure.
NativeSize | Gets the native size of the value.
NativeType | Defines the native type of the object.
Ptr | Gets a pointer to the value.
Size | Gets the size of the value.
TypeCode | Gets the type code of the value.
ValueType | Gets the type of the value.
Container

File: NValue.cs

Namespace: Neurotec

Module: .NET Reference


NValue.NValue Constructor (IntPtr)

NValue.NValue Constructor (IntPtr)
NValue Class Neurotec Namespace

Initializes a new instance of the NValue class.

C#
public NValue(IntPtr value);
Collapse Expand Parameters
Parameters | Description
IntPtr value | The original pointer.


NValue.NValue Constructor (IntPtr, NAttributes)

NValue.NValue Constructor (IntPtr, NAttributes)
NValue Class Neurotec Namespace

Initializes a new instance of the NValue class.

C#
public NValue(IntPtr value, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
IntPtr value | The original pointer.
NAttributes attributes | Value attributes.


NValue.NValue Constructor (UIntPtr)

NValue.NValue Constructor (UIntPtr)
NValue Class Neurotec Namespace

Initializes a new instance of the NValue class.

C#
public NValue(UIntPtr value);
Collapse Expand Parameters
Parameters | Description
UIntPtr value | The original pointer.


NValue.NValue Constructor (UIntPtr, NAttributes)

NValue.NValue Constructor (UIntPtr, NAttributes)
NValue Class Neurotec Namespace

Initializes a new instance of the NValue class.

C#
public NValue(UIntPtr value, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
UIntPtr value | The original pointer.
NAttributes attributes | Value attributes.


NValue.NValue Constructor (bool)

NValue.NValue Constructor (bool)
NValue Class Neurotec Namespace

Initializes a new instance of the NValue class.

C#
public NValue(bool value);
Collapse Expand Parameters
Parameters | Description
bool value | The original Boolean value.


NValue.NValue Constructor (bool, NAttributes)

NValue.NValue Constructor (bool, NAttributes)
NValue Class Neurotec Namespace

Initializes a new instance of the NValue class.

C#
public NValue(bool value, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
bool value | The original Boolean value.
NAttributes attributes | Value attributes.


NValue.NValue Constructor (byte)

NValue.NValue Constructor (byte)
NValue Class Neurotec Namespace

Initializes a new instance of the NValue class.

C#
public NValue(byte value);
Collapse Expand Parameters
Parameters | Description
byte value | The original byte.


NValue.NValue Constructor (byte, NAttributes)

NValue.NValue Constructor (byte, NAttributes)
NValue Class Neurotec Namespace

Initializes a new instance of the NValue class.

C#
public NValue(byte value, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
byte value | The original byte.
NAttributes attributes | Value attributes.


NValue.NValue Constructor (char)

NValue.NValue Constructor (char)
NValue Class Neurotec Namespace

Initializes a new instance of the NValue class.

C#
public NValue(char value);
Collapse Expand Parameters
Parameters | Description
char value | The original char.


NValue.NValue Constructor (char, NAttributes)

NValue.NValue Constructor (char, NAttributes)
NValue Class Neurotec Namespace

Initializes a new instance of the NValue class.

C#
public NValue(char value, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
char value | The original char.
NAttributes attributes | Value attributes.


NValue.NValue Constructor (double)

NValue.NValue Constructor (double)
NValue Class Neurotec Namespace

Initializes a new instance of the NValue class.

C#
public NValue(double value);
Collapse Expand Parameters
Parameters | Description
double value | The original double value.


NValue.NValue Constructor (double, NAttributes)

NValue.NValue Constructor (double, NAttributes)
NValue Class Neurotec Namespace

Initializes a new instance of the NValue class.

C#
public NValue(double value, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
double value | The original double value.
NAttributes attributes | Value attributes.


NValue.NValue Constructor (float)

NValue.NValue Constructor (float)
NValue Class Neurotec Namespace

Initializes a new instance of the NValue class.

C#
public NValue(float value);
Collapse Expand Parameters
Parameters | Description
float value | The original floating point value.


NValue.NValue Constructor (float, NAttributes)

NValue.NValue Constructor (float, NAttributes)
NValue Class Neurotec Namespace

Initializes a new instance of the NValue class.

C#
public NValue(float value, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
float value | The original floating point value.
NAttributes attributes | Value attributes.


NValue.NValue Constructor (int)

NValue.NValue Constructor (int)
NValue Class Neurotec Namespace

Initializes a new instance of the NValue class.

C#
public NValue(int value);
Collapse Expand Parameters
Parameters | Description
int value | The original integer.


NValue.NValue Constructor (int, NAttributes)

NValue.NValue Constructor (int, NAttributes)
NValue Class Neurotec Namespace

Initializes a new instance of the NValue class.

C#
public NValue(int value, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
int value | The original integer.
NAttributes attributes | Value attributes.


NValue.NValue Constructor (long)

NValue.NValue Constructor (long)
NValue Class Neurotec Namespace

Initializes a new instance of the NValue class.

C#
public NValue(long value);
Collapse Expand Parameters
Parameters | Description
long value | The original long integer.


NValue.NValue Constructor (long, NAttributes)

NValue.NValue Constructor (long, NAttributes)
NValue Class Neurotec Namespace

Initializes a new instance of the NValue class.

C#
public NValue(long value, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
long value | The original long integer.
NAttributes attributes | Value attributes.


NValue.NValue Constructor (sbyte)

NValue.NValue Constructor (sbyte)
NValue Class Neurotec Namespace

Initializes a new instance of the NValue class.

C#
public NValue(sbyte value);
Collapse Expand Parameters
Parameters | Description
sbyte value | The original signed byte.


NValue.NValue Constructor (sbyte, NAttributes)

NValue.NValue Constructor (sbyte, NAttributes)
NValue Class Neurotec Namespace

Initializes a new instance of the NValue class.

C#
public NValue(sbyte value, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
sbyte value | The original signed byte.
NAttributes attributes | Value attributes.


NValue.NValue Constructor (short)

NValue.NValue Constructor (short)
NValue Class Neurotec Namespace

Initializes a new instance of the NValue class.

C#
public NValue(short value);
Collapse Expand Parameters
Parameters | Description
short value | The original short integer.


NValue.NValue Constructor (short, NAttributes)

NValue.NValue Constructor (short, NAttributes)
NValue Class Neurotec Namespace

Initializes a new instance of the NValue class.

C#
public NValue(short value, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
short value | The original short integer.
NAttributes attributes | Value attributes.


NValue.NValue Constructor (uint)

NValue.NValue Constructor (uint)
NValue Class Neurotec Namespace

Initializes a new instance of the NValue class.

C#
public NValue(uint value);
Collapse Expand Parameters
Parameters | Description
uint value | The original unsigned integer.


NValue.NValue Constructor (uint, NAttributes)

NValue.NValue Constructor (uint, NAttributes)
NValue Class Neurotec Namespace

Initializes a new instance of the NValue class.

C#
public NValue(uint value, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
uint value | The original integer.
NAttributes attributes | Value attributes.


NValue.NValue Constructor (ulong)

NValue.NValue Constructor (ulong)
NValue Class Neurotec Namespace

Initializes a new instance of the NValue class.

C#
public NValue(ulong value);
Collapse Expand Parameters
Parameters | Description
ulong value | The original unsigned long integer.


NValue.NValue Constructor (ulong, NAttributes)

NValue.NValue Constructor (ulong, NAttributes)
NValue Class Neurotec Namespace

Initializes a new instance of the NValue class.

C#
public NValue(ulong value, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
ulong value | The original unsigned long integer.
NAttributes attributes | Value attributes.


NValue.NValue Constructor (ushort)

NValue.NValue Constructor (ushort)
NValue Class Neurotec Namespace

Initializes a new instance of the NValue class.

C#
public NValue(ushort value);
Collapse Expand Parameters
Parameters | Description
ushort value | The original unsigned short integer.


NValue.NValue Constructor (ushort, NAttributes)

NValue.NValue Constructor (ushort, NAttributes)
NValue Class Neurotec Namespace

Initializes a new instance of the NValue class.

C#
public NValue(ushort value, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
ushort value | The original unsigned short integer.
NAttributes attributes | Value attributes.


NValue.ChangeType Method (NValue, NType)

NValue.ChangeType Method (NValue, NType)
NValue Class Neurotec Namespace

Changes the type of the specified value to the new type.

C#
public static NValue ChangeType(NValue srcValue, NType type);
Collapse Expand Parameters
Parameters | Description
NValue srcValue | The original value.
NType type | The new type of the value.
Collapse Expand Returns

The new value.


NValue.ChangeType Method (NValue, NType, NAttributes)

NValue.ChangeType Method (NValue, NType, NAttributes)
NValue Class Neurotec Namespace

Changes the type of the specified value to the new type.

C#
public static NValue ChangeType(NValue srcValue, NType type, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
NValue srcValue | The original value.
NType type | The new type of the value.
NAttributes attributes | Value attributes.
Collapse Expand Returns

The new value.


NValue.ChangeType Method (NValue, NType, NAttributes, string)

NValue.ChangeType Method (NValue, NType, NAttributes, string)
NValue Class Neurotec Namespace

Changes the type of the specified value to the new type.

C#
public static NValue ChangeType(NValue srcValue, NType type, NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
NValue srcValue | The original value.
NType type | The new type of the value.
NAttributes attributes | Value attributes.
string format | Format string.
Collapse Expand Returns

NValue object.


NValue.FromDelegate Method (Delegate)

NValue.FromDelegate Method (Delegate)
NValue Class Neurotec Namespace

Creates a new value from the specified delegate.

C#
public static NValue FromDelegate(Delegate value);
Collapse Expand Parameters
Parameters | Description
Delegate value | Delegate object.
Collapse Expand Returns

NValue object.


NValue.FromDelegate Method (Delegate, NAttributes)

NValue.FromDelegate Method (Delegate, NAttributes)
NValue Class Neurotec Namespace

Creates a new value from the specified delegate with attributes.

C#
public static NValue FromDelegate(Delegate value, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
Delegate value | Delegate object.
NAttributes attributes | Value attributes.
Collapse Expand Returns

NValue object.


NValue.FromDelegate Method (Delegate, NAttributes, NObject)

NValue.FromDelegate Method (Delegate, NAttributes, NObject)
NValue Class Neurotec Namespace

Creates a new value from the specified delegate with attributes.

C#
public static NValue FromDelegate(Delegate value, NAttributes attributes, NObject target);
Collapse Expand Parameters
Parameters | Description
Delegate value | Delegate object.
NAttributes attributes | Value attributes.
NObject target | Target (original) object.
Collapse Expand Returns

NValue object.


NValue.FromDelegate Method (Delegate, NObject)

NValue.FromDelegate Method (Delegate, NObject)
NValue Class Neurotec Namespace

Creates a new value from the specified delegate and target object with no attributes.

C#
public static NValue FromDelegate(Delegate value, NObject target);
Collapse Expand Parameters
Parameters | Description
Delegate value | Delegate object.
NObject target | Target (original) object.
Collapse Expand Returns

NValue object.


NValue.FromObject Method (NType, NObject)

NValue.FromObject Method (NType, NObject)
NValue Class Neurotec Namespace

Creates a new value from the specified object.

C#
public static NValue FromObject(NType type, NObject value);
Collapse Expand Parameters
Parameters | Description
NType type | Type of the object.
NObject value | The original object.
Collapse Expand Returns

The new value.


NValue.FromObject Method (NType, NObject, NAttributes)

NValue.FromObject Method (NType, NObject, NAttributes)
NValue Class Neurotec Namespace

Creates a new value from the specified object.

C#
public static NValue FromObject(NType type, NObject value, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
NType type | Type of the object.
NObject value | The original object.
NAttributes attributes | Value attributes.
Collapse Expand Returns

The new value.


NValue.FromObject Method (object)

NValue.FromObject Method (object)
NValue Class Neurotec Namespace

Creates a new value from the specified object.

C#
public static new NValue FromObject(object value);
Collapse Expand Parameters
Parameters | Description
object value | The original object.
Collapse Expand Returns

The new value.


NValue.FromObject Method (object, NAttributes)

NValue.FromObject Method (object, NAttributes)
NValue Class Neurotec Namespace

Creates a new value from the specified object.

C#
public static NValue FromObject(object value, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
object value | The original object.
NAttributes attributes | Value attributes.
Collapse Expand Returns

The new value.


NValue.FromPointer Method (IntPtr)

NValue.FromPointer Method (IntPtr)
NValue Class Neurotec Namespace

Creates a new value from the specified pointer.

C#
public static NValue FromPointer(IntPtr value);
Collapse Expand Parameters
Parameters | Description
IntPtr value | The original pointer.
Collapse Expand Returns

The new value.


NValue.FromPointer Method (IntPtr, NAttributes)

NValue.FromPointer Method (IntPtr, NAttributes)
NValue Class Neurotec Namespace

Creates a new value from the specified pointer.

C#
public static NValue FromPointer(IntPtr value, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
IntPtr value | The original pointer.
NAttributes attributes | Value attributes.
Collapse Expand Returns

The new value.


NValue.FromResult Method (int)

NValue.FromResult Method (int)
NValue Class Neurotec Namespace

Creates a new value from the specified result.

C#
public static NValue FromResult(int value);
Collapse Expand Parameters
Parameters | Description
int value | The original result.
Collapse Expand Returns

The new value.


NValue.FromResult Method (int, NAttributes)

NValue.FromResult Method (int, NAttributes)
NValue Class Neurotec Namespace

Creates a new value from the specified result.

C#
public static NValue FromResult(int value, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
int value | The original result.
NAttributes attributes | Value attributes.
Collapse Expand Returns

The new value.


NValue.FromString Method (string)

NValue.FromString Method (string)
NValue Class Neurotec Namespace

Creates a new value from the specified string.

C#
public static NValue FromString(string value);
Collapse Expand Parameters
Parameters | Description
string value | The original string.
Collapse Expand Returns

The new value.


NValue.FromString Method (string, NAttributes)

NValue.FromString Method (string, NAttributes)
NValue Class Neurotec Namespace

Creates a new value from the specified string.

C#
public static NValue FromString(string value, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
string value | The original string.
NAttributes attributes | Value attributes.
Collapse Expand Returns

The new value.


NValue.FromType<T> Method (T)

NValue.FromType<T> Method (T)
NValue Class Neurotec Namespace

Creates a new value from the specified type.

C#
public static NValue FromType<T>(T value);
Collapse Expand Parameters
Parameters | Description
T value | The original type.
T | Type of the value.
Collapse Expand Returns

The new value.


NValue.FromType<T> Method (T, NAttributes)

NValue.FromType<T> Method (T, NAttributes)
NValue Class Neurotec Namespace

Creates a new value from the specified type.

C#
public static NValue FromType<T>(T value, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
T value | The original type.
NAttributes attributes | Value attributes.
T | Type of the value.
Collapse Expand Returns

The new value.


NValue.ToBoolean Method ()

NValue.ToBoolean Method ()
NValue Class Neurotec Namespace

Converts the specified value into a Boolean value.

C#
public bool ToBoolean();
Collapse Expand Returns

New Boolean value.


NValue.ToBoolean Method (NAttributes)

NValue.ToBoolean Method (NAttributes)
NValue Class Neurotec Namespace

Converts the specified value into a Boolean value.

C#
public bool ToBoolean(NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Value attributes.
Collapse Expand Returns

New Boolean value.


NValue.ToBoolean Method (NAttributes, string)

NValue.ToBoolean Method (NAttributes, string)
NValue Class Neurotec Namespace

Converts the specified value into a Boolean value.

C#
public bool ToBoolean(NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Value attributes.
string format | Format string.
Collapse Expand Returns

New Boolean value.


NValue.ToByte Method ()

NValue.ToByte Method ()
NValue Class Neurotec Namespace

Converts the specified value into a byte.

C#
public byte ToByte();
Collapse Expand Returns

New byte.


NValue.ToByte Method (NAttributes)

NValue.ToByte Method (NAttributes)
NValue Class Neurotec Namespace

Converts the specified value into a byte.

C#
public byte ToByte(NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Value attributes.
Collapse Expand Returns

New byte.


NValue.ToByte Method (NAttributes, string)

NValue.ToByte Method (NAttributes, string)
NValue Class Neurotec Namespace

Converts the specified value into a byte.

C#
public byte ToByte(NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Value attributes.
string format | Format string.
Collapse Expand Returns

New byte.


NValue.ToChar Method ()

NValue.ToChar Method ()
NValue Class Neurotec Namespace

Converts the specified value into a char.

C#
public char ToChar();
Collapse Expand Returns

New char.


NValue.ToChar Method (NAttributes)

NValue.ToChar Method (NAttributes)
NValue Class Neurotec Namespace

Converts the specified value into a char.

C#
public char ToChar(NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Value attributes.
Collapse Expand Returns

New char.


NValue.ToChar Method (NAttributes, string)

NValue.ToChar Method (NAttributes, string)
NValue Class Neurotec Namespace

Converts the specified value into a char.

C#
public char ToChar(NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Value attributes.
string format | Format string.
Collapse Expand Returns

New char.


NValue.ToDouble Method ()

NValue.ToDouble Method ()
NValue Class Neurotec Namespace

Converts the specified value into a double number.

C#
public double ToDouble();
Collapse Expand Returns

New double number.


NValue.ToDouble Method (NAttributes)

NValue.ToDouble Method (NAttributes)
NValue Class Neurotec Namespace

Converts the specified value into a double number.

C#
public double ToDouble(NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Value attributes.
Collapse Expand Returns

New double number.


NValue.ToDouble Method (NAttributes, string)

NValue.ToDouble Method (NAttributes, string)
NValue Class Neurotec Namespace

Converts the specified value into a double number.

C#
public double ToDouble(NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Value attributes.
string format | Format string.
Collapse Expand Returns

New double number.


NValue.ToInt16 Method ()

NValue.ToInt16 Method ()
NValue Class Neurotec Namespace

Converts the specified value into a short integer.

C#
public short ToInt16();
Collapse Expand Returns

New short integer.


NValue.ToInt16 Method (NAttributes)

NValue.ToInt16 Method (NAttributes)
NValue Class Neurotec Namespace

Converts the specified value into a short integer.

C#
public short ToInt16(NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Value attributes.
Collapse Expand Returns

New short integer.


NValue.ToInt16 Method (NAttributes, string)

NValue.ToInt16 Method (NAttributes, string)
NValue Class Neurotec Namespace

Converts the specified value into a short integer.

C#
public short ToInt16(NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Value attributes.
string format | Format string.
Collapse Expand Returns

New short integer.


NValue.ToInt32 Method ()

NValue.ToInt32 Method ()
NValue Class Neurotec Namespace

Converts the specified value into an integer.

C#
public int ToInt32();
Collapse Expand Returns

New integer.


NValue.ToInt32 Method (NAttributes)

NValue.ToInt32 Method (NAttributes)
NValue Class Neurotec Namespace

Converts the specified value into an integer.

C#
public int ToInt32(NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Value attributes.
Collapse Expand Returns

New integer.


NValue.ToInt32 Method (NAttributes, string)

NValue.ToInt32 Method (NAttributes, string)
NValue Class Neurotec Namespace

Converts the specified value into an integer.

C#
public int ToInt32(NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Value attributes.
string format | Format string.
Collapse Expand Returns

New integer.


NValue.ToInt64 Method ()

NValue.ToInt64 Method ()
NValue Class Neurotec Namespace

Converts the specified value into a long integer.

C#
public long ToInt64();
Collapse Expand Returns

New long integer.


NValue.ToInt64 Method (NAttributes)

NValue.ToInt64 Method (NAttributes)
NValue Class Neurotec Namespace

Converts the specified value into a long integer.

C#
public long ToInt64(NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Value attributes.
Collapse Expand Returns

New long integer.


NValue.ToInt64 Method (NAttributes, string)

NValue.ToInt64 Method (NAttributes, string)
NValue Class Neurotec Namespace

Converts the specified value into a long integer.

C#
public long ToInt64(NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Value attributes.
string format | Format string.
Collapse Expand Returns

New long integer.


NValue.ToIntPtr Method ()

NValue.ToIntPtr Method ()
NValue Class Neurotec Namespace

Converts the specified value into a pointer.

C#
public IntPtr ToIntPtr();
Collapse Expand Returns

New integer pointer.


NValue.ToIntPtr Method (NAttributes)

NValue.ToIntPtr Method (NAttributes)
NValue Class Neurotec Namespace

Converts the specified value into a pointer.

C#
public IntPtr ToIntPtr(NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Value attributes.
Collapse Expand Returns

New integer pointer.


NValue.ToIntPtr Method (NAttributes, string)

NValue.ToIntPtr Method (NAttributes, string)
NValue Class Neurotec Namespace

Converts the specified value into a pointer.

C#
public IntPtr ToIntPtr(NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Value attributes.
string format | Format string.
Collapse Expand Returns

New integer pointer.


NValue.ToObject Method ()

NValue.ToObject Method ()
NValue Class Neurotec Namespace

Converts the specified value into an object.

C#
public object ToObject();
Collapse Expand Returns

New object.


NValue.ToObject Method (NType)

NValue.ToObject Method (NType)
NValue Class Neurotec Namespace

Converts the specified value into an object.

C#
public NObject ToObject(NType type);
Collapse Expand Parameters
Parameters | Description
NType type | Type of the object.
Collapse Expand Returns

New object.


NValue.ToObject Method (NType, NAttributes)

NValue.ToObject Method (NType, NAttributes)
NValue Class Neurotec Namespace

Converts the specified value into an object.

C#
public NObject ToObject(NType type, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
NType type | Type of the object.
NAttributes attributes | Value attributes.
Collapse Expand Returns

New object.


NValue.ToObject Method (NType, NAttributes, string)

NValue.ToObject Method (NType, NAttributes, string)
NValue Class Neurotec Namespace

Converts the specified value into an object.

C#
public NObject ToObject(NType type, NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
NType type | Type of the object.
NAttributes attributes | Value attributes.
string format | Format string.
Collapse Expand Returns

New object.


NValue.ToObject Method (NValue)

NValue.ToObject Method (NValue)
NValue Class Neurotec Namespace

Converts the specified value into an object.

C#
public static object ToObject(NValue value);
Collapse Expand Parameters
Parameters | Description
NValue value | The original value.
Collapse Expand Returns

The new value.


NValue.ToPointer Method ()

NValue.ToPointer Method ()
NValue Class Neurotec Namespace

Converts the specified value into a pointer.

C#
public IntPtr ToPointer();
Collapse Expand Returns

New pointer.


NValue.ToPointer Method (NAttributes)

NValue.ToPointer Method (NAttributes)
NValue Class Neurotec Namespace

Converts the specified value into a pointer.

C#
public IntPtr ToPointer(NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Value attributes.
Collapse Expand Returns

New pointer.


NValue.ToPointer Method (NAttributes, string)

NValue.ToPointer Method (NAttributes, string)
NValue Class Neurotec Namespace

Converts the specified value into a pointer.

C#
public IntPtr ToPointer(NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Value attributes.
string format | Format string.
Collapse Expand Returns

New pointer.


NValue.ToResult Method ()

NValue.ToResult Method ()
NValue Class Neurotec Namespace

Converts the specified value into a result.

C#
public int ToResult();
Collapse Expand Returns

New result.


NValue.ToResult Method (NAttributes)

NValue.ToResult Method (NAttributes)
NValue Class Neurotec Namespace

Converts the specified value into a result.

C#
public int ToResult(NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Value attributes.
Collapse Expand Returns

New result.


NValue.ToResult Method (NAttributes, string)

NValue.ToResult Method (NAttributes, string)
NValue Class Neurotec Namespace

Converts the specified value into a result.

C#
public int ToResult(NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Value attributes.
string format | Format string.
Collapse Expand Returns

New result.


NValue.ToSByte Method ()

NValue.ToSByte Method ()
NValue Class Neurotec Namespace

Converts the specified value into a signed byte.

C#
public sbyte ToSByte();
Collapse Expand Returns

New signed byte.


NValue.ToSByte Method (NAttributes)

NValue.ToSByte Method (NAttributes)
NValue Class Neurotec Namespace

Converts the specified value into a signed byte.

C#
public sbyte ToSByte(NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Value attributes.
Collapse Expand Returns

New signed byte.


NValue.ToSByte Method (NAttributes, string)

NValue.ToSByte Method (NAttributes, string)
NValue Class Neurotec Namespace

Converts the specified value into a signed byte.

C#
public sbyte ToSByte(NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Value attributes.
string format | Format string.
Collapse Expand Returns

New signed byte.


NValue.ToSingle Method ()

NValue.ToSingle Method ()
NValue Class Neurotec Namespace

Converts the specified value into a floating point value.

C#
public float ToSingle();
Collapse Expand Returns

New floating point value.


NValue.ToSingle Method (NAttributes)

NValue.ToSingle Method (NAttributes)
NValue Class Neurotec Namespace

Converts the specified value into a floating point value.

C#
public float ToSingle(NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Value attributes.
Collapse Expand Returns

New floating point value.


NValue.ToSingle Method (NAttributes, string)

NValue.ToSingle Method (NAttributes, string)
NValue Class Neurotec Namespace

Converts the specified value into a floating point value.

C#
public float ToSingle(NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Value attributes.
string format | Format string.
Collapse Expand Returns

New floating point value.


NValue.ToString Method (NAttributes)

NValue.ToString Method (NAttributes)
NValue Class Neurotec Namespace

Converts the specified value into a string.

C#
public string ToString(NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Value attributes.
Collapse Expand Returns

New string.


NValue.ToString Method (NAttributes, string)

NValue.ToString Method (NAttributes, string)
NValue Class Neurotec Namespace

Converts the specified value into a string.

C#
public string ToString(NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Value attributes.
string format | Format string.
Collapse Expand Returns

New string.


NValue.ToType<T> Method ()

NValue.ToType<T> Method ()
NValue Class Neurotec Namespace

Converts the specified value into a value of specified type.

C#
public T ToType<T>();
Collapse Expand Parameters
Parameters | Description
T | Type of the value.
Collapse Expand Returns

New value.


NValue.ToType<T> Method (NAttributes)

NValue.ToType<T> Method (NAttributes)
NValue Class Neurotec Namespace

Converts the specified value into a value of specified type.

C#
public T ToType<T>(NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Value attributes.
T | Type of the value.
Collapse Expand Returns

New value.


NValue.ToType<T> Method (NAttributes, string)

NValue.ToType<T> Method (NAttributes, string)
NValue Class Neurotec Namespace

Converts the specified value into a value of specified type.

C#
public T ToType<T>(NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Value attributes.
string format | Format string.
T | Type of the value.
Collapse Expand Returns

New value.


NValue.ToType Method (Type)

NValue.ToType Method (Type)
NValue Class Neurotec Namespace

Converts the specified value into a value of specified type.

C#
public object ToType(Type type);
Collapse Expand Parameters
Parameters | Description
Type type | Type of the value.
Collapse Expand Returns

New value.


NValue.ToType Method (Type, NAttributes)

NValue.ToType Method (Type, NAttributes)
NValue Class Neurotec Namespace

Converts the specified value into a value of specified type.

C#
public object ToType(Type type, NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
Type type | Type of the value.
NAttributes attributes | Value attributes.
Collapse Expand Returns

New value.


NValue.ToType Method (Type, NAttributes, string)

NValue.ToType Method (Type, NAttributes, string)
NValue Class Neurotec Namespace

Converts the specified value into a value of specified type.

C#
public object ToType(Type type, NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
Type type | Type of the value.
NAttributes attributes | Value attributes.
string format | Format string.
Collapse Expand Returns

New value.


NValue.ToUInt16 Method ()

NValue.ToUInt16 Method ()
NValue Class Neurotec Namespace

Converts the specified value into an unsigned short integer.

C#
public ushort ToUInt16();
Collapse Expand Returns

New unsigned short integer.


NValue.ToUInt16 Method (NAttributes)

NValue.ToUInt16 Method (NAttributes)
NValue Class Neurotec Namespace

Converts the specified value into an unsigned short integer.

C#
public ushort ToUInt16(NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Value attributes.
Collapse Expand Returns

New unsigned short integer.


NValue.ToUInt16 Method (NAttributes, string)

NValue.ToUInt16 Method (NAttributes, string)
NValue Class Neurotec Namespace

Converts the specified value into an unsigned short integer.

C#
public ushort ToUInt16(NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Value attributes.
string format | Format string.
Collapse Expand Returns

New unsigned short integer.


NValue.ToUInt32 Method ()

NValue.ToUInt32 Method ()
NValue Class Neurotec Namespace

Converts the specified value into an unsigned integer.

C#
public uint ToUInt32();
Collapse Expand Returns

New unsigned integer.


NValue.ToUInt32 Method (NAttributes)

NValue.ToUInt32 Method (NAttributes)
NValue Class Neurotec Namespace

Converts the specified value into an unsigned integer.

C#
public uint ToUInt32(NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Value attributes.
Collapse Expand Returns

New unsigned integer.


NValue.ToUInt32 Method (NAttributes, string)

NValue.ToUInt32 Method (NAttributes, string)
NValue Class Neurotec Namespace

Converts the specified value into an unsigned integer.

C#
public uint ToUInt32(NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Value attributes.
string format | Format string.
Collapse Expand Returns

New unsigned integer.


NValue.ToUInt64 Method ()

NValue.ToUInt64 Method ()
NValue Class Neurotec Namespace

Converts the specified value into an unsigned long integer.

C#
public ulong ToUInt64();
Collapse Expand Returns

New unsigned long integer.


NValue.ToUInt64 Method (NAttributes)

NValue.ToUInt64 Method (NAttributes)
NValue Class Neurotec Namespace

Converts the specified value into an unsigned long integer.

C#
public ulong ToUInt64(NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Value attributes.
Collapse Expand Returns

New unsigned long integer.


NValue.ToUInt64 Method (NAttributes, string)

NValue.ToUInt64 Method (NAttributes, string)
NValue Class Neurotec Namespace

Converts the specified value into an unsigned long integer.

C#
public ulong ToUInt64(NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Value attributes.
string format | Format string.
Collapse Expand Returns

New unsigned long integer.


NValue.ToUIntPtr Method ()

NValue.ToUIntPtr Method ()
NValue Class Neurotec Namespace

Converts the specified value into a pointer.

C#
public UIntPtr ToUIntPtr();
Collapse Expand Returns

New unsigned integer pointer.


NValue.ToUIntPtr Method (NAttributes)

NValue.ToUIntPtr Method (NAttributes)
NValue Class Neurotec Namespace

Converts the specified value into a pointer.

C#
public UIntPtr ToUIntPtr(NAttributes attributes);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Value attributes.
Collapse Expand Returns

New unsigned integer pointer.


NValue.ToUIntPtr Method (NAttributes, string)

NValue.ToUIntPtr Method (NAttributes, string)
NValue Class Neurotec Namespace

Converts the specified value into a pointer.

C#
public UIntPtr ToUIntPtr(NAttributes attributes, string format);
Collapse Expand Parameters
Parameters | Description
NAttributes attributes | Value attributes.
string format | Format string.
Collapse Expand Returns

New unsigned integer pointer.


NValue.Attributes Property

NValue.Attributes Property
NValue Class Neurotec Namespace

Gets the value attributes.

C#
public NAttributes Attributes;


NValue.IsWrapper Property

NValue.IsWrapper Property
NValue Class Neurotec Namespace

Checks whether the value is a wrapper.

C#
public bool IsWrapper;


NValue.KeyValuePairNativeType Property

NValue.KeyValuePairNativeType Property
NValue Class Neurotec Namespace

Defines the native type of the key value pair structure.

C#
public static NType KeyValuePairNativeType;


NValue.LongSize Property

NValue.LongSize Property
NValue Class Neurotec Namespace

Gets the size of the value (64-bit).

C#
public long LongSize;


NValue.NameValuePairNativeType Property

NValue.NameValuePairNativeType Property
NValue Class Neurotec Namespace

Defines the native type of the name value pair structure.

C#
public static NType NameValuePairNativeType;


NValue.NativeSize Property

NValue.NativeSize Property
NValue Class Neurotec Namespace

Gets the native size of the value.

C#
public UIntPtr NativeSize;


NValue.NativeType Property

NValue.NativeType Property
NValue Class Neurotec Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NValue.Ptr Property

NValue.Ptr Property
NValue Class Neurotec Namespace

Gets a pointer to the value.

C#
public IntPtr Ptr;


NValue.Size Property

NValue.Size Property
NValue Class Neurotec Namespace

Gets the size of the value.

C#
public int Size;


NValue.TypeCode Property

NValue.TypeCode Property
NValue Class Neurotec Namespace

Gets the type code of the value.

C#
public NTypeCode TypeCode;


NValue.ValueType Property

NValue.ValueType Property
NValue Class Neurotec Namespace

Gets the type of the value.

C#
public NType ValueType;


NVersion Structure

NVersion Structure
NVersion Fields Legend Members Methods NVersion Methods NVersion Operators NVersion Properties

Manages version information.

C#
[Serializable]
public struct NVersion : IFormattable, IEquatable<NVersion>, IComparable {
  public static readonly NVersion Empty = new NVersion(0);
}
Collapse Expand NVersion Fields
Name | Description
Empty | New NVersion object.
Collapse Expand NVersion Methods
Name | Description
CompareTo | Compares the current version with the specified version and returns an integer that indicates their relative position in the sort order.
Equals | Checks whether the current version equals the specified version.
GetHashCode | Gets the hash code.
ToString | Gets the string representation of the current version.
Collapse Expand NVersion Operators
Name | Description
!= | Checks whether the two NVersion values are not equal.
< | Checks whether the first NVersion value is smaller than the second NVersion value.
<= | Checks whether the first NVersion value is smaller than or equal to the second NVersion value.
== | Checks whether the two NVersion values are equal.
> | Checks whether the first NVersion value is larger than the second NVersion value.
>= | Checks whether the first NVersion value is larger than or equal to the second NVersion value.
NVersion | Converts an unsigned short value to NVersion value.
ushort | Converts NVersion value to an unsigned short value.
Collapse Expand NVersion Properties
Name | Description
Major | Gets the major version value.
Minor | Gets the minor version value.
NativeType | Defines the native type of the type.
Container

File: NTypes.cs

Namespace: Neurotec

Module: .NET Reference


NVersion.NVersion Constructor (int, int)

NVersion.NVersion Constructor (int, int)
NVersion Structure Neurotec Namespace

Initializes a new instance of NVersion structure.

C#
public NVersion(int major, int minor);
Collapse Expand Parameters
Parameters | Description
int major | Major version number.
int minor | Minor version number.


NVersion.NVersion Constructor (ushort)

NVersion.NVersion Constructor (ushort)
NVersion Structure Neurotec Namespace

Initializes a new instance of NVersion structure.

C#
public NVersion(ushort value);
Collapse Expand Parameters
Parameters | Description
ushort value | Version value.


NVersion.Empty Field

NVersion.Empty Field
NVersion Structure Neurotec Namespace

New NVersion object.

C#
public static readonly NVersion Empty = new NVersion(0);


NVersion.CompareTo Method

NVersion.CompareTo Method
NVersion Structure Neurotec Namespace

Compares the current version with the specified version and returns an integer that indicates their relative position in the sort order.

C#
public int CompareTo(NVersion other);
Collapse Expand Parameters
Parameters | Description
NVersion other | The other version.
Collapse Expand Returns

Integer that indicates their relative position in the sort order.


NVersion.Equals Method (NVersion)

NVersion.Equals Method (NVersion)
NVersion Structure Neurotec Namespace

Checks whether the current version equals the specified version.

C#
public bool Equals(NVersion other);
Collapse Expand Parameters
Parameters | Description
NVersion other | The other version.
Collapse Expand Returns

true if the versions are equal; else false.


NVersion.Equals Method (object)

NVersion.Equals Method (object)
NVersion Structure Neurotec Namespace

Checks whether the current version equals the specified version object.

C#
public override bool Equals(object obj);
Collapse Expand Parameters
Parameters | Description
object obj | Version object.
Collapse Expand Returns

NTrue if the versions are equal; else NFalse.


NVersion.GetHashCode Method

NVersion.GetHashCode Method
NVersion Structure Neurotec Namespace

Gets the hash code.

C#
public override int GetHashCode();
Collapse Expand Returns

The hash code.


NVersion.ToString Method ()

NVersion.ToString Method ()
NVersion Structure Neurotec Namespace

Gets the string representation of the current version.

C#
public override string ToString();
Collapse Expand Returns

A string representing the current version.


NVersion.ToString Method (string)

NVersion.ToString Method (string)
NVersion Structure Neurotec Namespace

Retrieves a string representation of the current version.

C#
public string ToString(string format);
Collapse Expand Parameters
Parameters | Description
string format | Reserved.
Collapse Expand Returns

A string representation of the current version.


NVersion.!= Operator

NVersion.!= Operator
NVersion Structure Neurotec Namespace

Checks whether the two NVersion values are not equal.

C#
public static bool operator !=(NVersion v1, NVersion v2);
Collapse Expand Parameters
Parameters | Description
NVersion v1 | First NVersion value.
NVersion v2 | Second NVersion value.
Collapse Expand Returns

NTrue if the values are not equal; else NFalse.


NVersion.< Operator

NVersion.< Operator
NVersion Structure Neurotec Namespace

Checks whether the first NVersion value is smaller than the second NVersion value.

C#
public static bool operator <(NVersion v1, NVersion v2);
Collapse Expand Parameters
Parameters | Description
NVersion v1 | First NVersion value.
NVersion v2 | Second NVersion value.
Collapse Expand Returns

>NTrue if the first NVersion is smaller; else NFalse.


NVersion.<= Operator

NVersion.<= Operator
NVersion Structure Neurotec Namespace

Checks whether the first NVersion value is smaller than or equal to the second NVersion value.

C#
public static bool operator <=(NVersion v1, NVersion v2);
Collapse Expand Parameters
Parameters | Description
NVersion v1 | First NVersion value.
NVersion v2 | Second NVersion value.
Collapse Expand Returns

>NTrue if the first NVersion is smaller or the values are equal; else NFalse.


NVersion.== Operator

NVersion.== Operator
NVersion Structure Neurotec Namespace

Checks whether the two NVersion values are equal.

C#
public static bool operator ==(NVersion v1, NVersion v2);
Collapse Expand Parameters
Parameters | Description
NVersion v1 | First NVersion value.
NVersion v2 | Second NVersion value.
Collapse Expand Returns

NTrue if the values are equal; else NFalse.


NVersion.> Operator

NVersion.> Operator
NVersion Structure Neurotec Namespace

Checks whether the first NVersion value is larger than the second NVersion value.

C#
public static bool operator >(NVersion v1, NVersion v2);
Collapse Expand Parameters
Parameters | Description
NVersion v1 | First NVersion value.
NVersion v2 | Second NVersion value.
Collapse Expand Returns

>NTrue if the first NVersion is larger; else NFalse.


NVersion.>= Operator

NVersion.>= Operator
NVersion Structure Neurotec Namespace

Checks whether the first NVersion value is larger than or equal to the second NVersion value.

C#
public static bool operator >=(NVersion v1, NVersion v2);
Collapse Expand Parameters
Parameters | Description
NVersion v1 | First NVersion value.
NVersion v2 | Second NVersion value.
Collapse Expand Returns

>NTrue if the first NVersion is larger or the values are equal; else NFalse.


NVersion.NVersion Operator (ushort)

NVersion.NVersion Operator (ushort)
NVersion Structure Neurotec Namespace

Converts an unsigned short value to NVersion value.

C#
public static explicit operator NVersion(ushort value);
Collapse Expand Parameters
Parameters | Description
ushort value | An unsigned short value.
Collapse Expand Returns

NVersion value.


NVersion.ushort Operator

NVersion.ushort Operator
NVersion Structure Neurotec Namespace

Converts NVersion value to an unsigned short value.

C#
public static explicit operator ushort(NVersion value);
Collapse Expand Parameters
Parameters | Description
NVersion value | NVersion value.
Collapse Expand Returns

Unsigned short value.


NVersion.Major Property

NVersion.Major Property
NVersion Structure Neurotec Namespace

Gets the major version value.

C#
public int Major;


NVersion.Minor Property

NVersion.Minor Property
NVersion Structure Neurotec Namespace

Gets the minor version value.

C#
public int Minor;


NVersion.NativeType Property

NVersion.NativeType Property
NVersion Structure Neurotec Namespace

Defines the native type of the type.

C#
public static NType NativeType;


NVersionRange Structure

NVersionRange Structure
NVersionRange Fields Legend Members Methods NVersionRange Methods NVersionRange Operators NVersionRange Properties

Manages version ranges.

C#
[Serializable]
public struct NVersionRange : IFormattable, IEquatable<NVersionRange> {
  public static readonly NVersionRange Empty = new NVersionRange(0);
}
Collapse Expand NVersionRange Fields
Name | Description
Empty | New version range object.
Collapse Expand NVersionRange Methods
Name | Description
Contains | Checks whether the current version range contain the specified version.
Equals | Checks whether the current version range equals the specified version range.
GetHashCode | Gets the hash code.
Intersect | Gets the intersection of the current version range and specified version range.
IntersectsWith | Checks whether the current version range intersects with the specified version range.
ToString | Gets a string representation of the version range.
Collapse Expand NVersionRange Operators
Name | Description
!= | Checks whether the two NVersionRange values are not equal.
== | Checks whether the two NVersionRange values are equal.
NVersionRange | Converts an unsigned short value to NVersionRange value.
uint | Converts NVersionRange value to an unsigned short value.
Collapse Expand NVersionRange Properties
Name | Description
From | Lower NVersion value.
NativeType | Defines the native type of the type.
To | Upper NVersion value.
Container

File: NTypes.cs

Namespace: Neurotec

Module: .NET Reference


NVersionRange.NVersionRange Constructor (NVersion, NVersion)

NVersionRange.NVersionRange Constructor (NVersion, NVersion)
NVersionRange Structure Neurotec Namespace

Initializes a new instance of NVersionRange structure.

C#
public NVersionRange(NVersion from, NVersion to);
Collapse Expand Parameters
Parameters | Description
NVersion from | Lower version value.
NVersion to | Upper version value.


NVersionRange.NVersionRange Constructor (uint)

NVersionRange.NVersionRange Constructor (uint)
NVersionRange Structure Neurotec Namespace

Initializes a new instance of NVersionRange structure.

C#
public NVersionRange(uint value);
Collapse Expand Parameters
Parameters | Description
uint value | Version range.


NVersionRange.Empty Field

NVersionRange.Empty Field
NVersionRange Structure Neurotec Namespace

New version range object.

C#
public static readonly NVersionRange Empty = new NVersionRange(0);


NVersionRange.Contains Method (NVersion)

NVersionRange.Contains Method (NVersion)
NVersionRange Structure Neurotec Namespace

Checks whether the current version range contain the specified version.

C#
public bool Contains(NVersion value);
Collapse Expand Parameters
Parameters | Description
NVersion value | Version value.
Collapse Expand Returns

NTrue if the version range contain the version value; else NFalse.


NVersionRange.Contains Method (NVersionRange)

NVersionRange.Contains Method (NVersionRange)
NVersionRange Structure Neurotec Namespace

Checks whether the current version range contain the specified version range.

C#
public bool Contains(NVersionRange value);
Collapse Expand Parameters
Parameters | Description
NVersionRange value | Version range value.
Collapse Expand Returns

NTrue if the current version range contain the specified version rang; else NFalse.


NVersionRange.Equals Method (NVersionRange)

NVersionRange.Equals Method (NVersionRange)
NVersionRange Structure Neurotec Namespace

Checks whether the current version range equals the specified version range.

C#
public bool Equals(NVersionRange other);
Collapse Expand Parameters
Parameters | Description
NVersionRange other | The other version range.
Collapse Expand Returns

true if the version ranges are equal; else false.


NVersionRange.Equals Method (object)

NVersionRange.Equals Method (object)
NVersionRange Structure Neurotec Namespace

Checks whether the current version range equals the specified version range object.

C#
public override bool Equals(object obj);
Collapse Expand Parameters
Parameters | Description
object obj | Version range object.
Collapse Expand Returns

NTrue if version ranges are equal; else NFalse.


NVersionRange.GetHashCode Method

NVersionRange.GetHashCode Method
NVersionRange Structure Neurotec Namespace

Gets the hash code.

C#
public override int GetHashCode();
Collapse Expand Returns

The hash code.


NVersionRange.Intersect Method (NVersionRange)

NVersionRange.Intersect Method (NVersionRange)
NVersionRange Structure Neurotec Namespace

Gets the intersection of the current version range and specified version range.

C#
public NVersionRange Intersect(NVersionRange value);
Collapse Expand Parameters
Parameters | Description
NVersionRange value | Version range object.
Collapse Expand Returns

Intersection of the version ranges.


NVersionRange.Intersect Method (NVersionRange, NVersionRange)

NVersionRange.Intersect Method (NVersionRange, NVersionRange)
NVersionRange Structure Neurotec Namespace

Gets the intersection of the two specified version ranges.

C#
public static NVersionRange Intersect(NVersionRange value1, NVersionRange value2);
Collapse Expand Parameters
Parameters | Description
NVersionRange value1 | First NVersionRange.
NVersionRange value2 | Second NVersionRange.
Collapse Expand Returns

The resulting NVersionRange.


NVersionRange.IntersectsWith Method

NVersionRange.IntersectsWith Method
NVersionRange Structure Neurotec Namespace

Checks whether the current version range intersects with the specified version range.

C#
public bool IntersectsWith(NVersionRange value);
Collapse Expand Parameters
Parameters | Description
NVersionRange value | Version range value.
Collapse Expand Returns

NTrue if the version ranges intersect; else NFalse.


NVersionRange.ToString Method ()

NVersionRange.ToString Method ()
NVersionRange Structure Neurotec Namespace

Gets a string representation of the version range.

C#
public override string ToString();
Collapse Expand Returns

A string representing the version range.


NVersionRange.ToString Method (string)

NVersionRange.ToString Method (string)
NVersionRange Structure Neurotec Namespace

Retrieves a string representation of the version range.

C#
public string ToString(string format);
Collapse Expand Parameters
Parameters | Description
string format | Reserved.
Collapse Expand Returns

A string representation of version range.


NVersionRange.!= Operator

NVersionRange.!= Operator
NVersionRange Structure Neurotec Namespace

Checks whether the two NVersionRange values are not equal.

C#
public static bool operator !=(NVersionRange v1, NVersionRange v2);
Collapse Expand Parameters
Parameters | Description
NVersionRange v1 | First NVersionRange value.
NVersionRange v2 | Second NVersionRange value.
Collapse Expand Returns

NTrue if the values are not equal; else NFalse.


NVersionRange.== Operator

NVersionRange.== Operator
NVersionRange Structure Neurotec Namespace

Checks whether the two NVersionRange values are equal.

C#
public static bool operator ==(NVersionRange v1, NVersionRange v2);
Collapse Expand Parameters
Parameters | Description
NVersionRange v1 | First NVersionRange value.
NVersionRange v2 | Second NVersionRange value.
Collapse Expand Returns

NTrue if the values are equal; else NFalse.


NVersionRange.NVersionRange Operator (uint)

NVersionRange.NVersionRange Operator (uint)
NVersionRange Structure Neurotec Namespace

Converts an unsigned short value to NVersionRange value.

C#
public static explicit operator NVersionRange(uint value);
Collapse Expand Parameters
Parameters | Description
uint value | Unsigned short value.
Collapse Expand Returns

NVersionRange value


NVersionRange.uint Operator

NVersionRange.uint Operator
NVersionRange Structure Neurotec Namespace

Converts NVersionRange value to an unsigned short value.

C#
public static explicit operator uint(NVersionRange value);
Collapse Expand Parameters
Parameters | Description
NVersionRange value | NVersionRange value.
Collapse Expand Returns

Unsigned short value.


NVersionRange.From Property

NVersionRange.From Property
NVersionRange Structure Neurotec Namespace

Lower NVersion value.

C#
public NVersion From;


NVersionRange.NativeType Property

NVersionRange.NativeType Property
NVersionRange Structure Neurotec Namespace

Defines the native type of the type.

C#
public static NType NativeType;


NVersionRange.To Property

NVersionRange.To Property
NVersionRange Structure Neurotec Namespace

Upper NVersion value.

C#
public NVersion To;


Neurotec.NAsyncStatus Enumeration

Neurotec.NAsyncStatus Enumeration

Enumerates asynchronous operation statuses.

C#
public enum NAsyncStatus {
  None = 0,
  Started = 1,
  Completed = 2,
  Canceled = 3,
  Faulted = 4
}
Collapse Expand Members
Members | Description
None = 0 | Indicates that no async operation is active.
Started = 1 | Indicates that the async operation has started.
Completed = 2 | Indicates that the async operation has been completed.
Canceled = 3 | Indicates that the async operation has been canceled.
Faulted = 4 | Indicates that the async operation is faulted and has thrown an exception.
Container

File: NAsyncOperation.cs

Namespace: Neurotec

Module: .NET Reference


Neurotec.NAttributes Enumeration

Neurotec.NAttributes Enumeration

Enumerates value attributes.

C#
[Flags]
public enum NAttributes {
  None = 0,
  SignNeutral = 0x00000001,
  SingleValue = 0x00000002,
  Array = 0x00000004,
  Nullable = 0x00000008,
  Local = 0x00000010,
  Global = 0x00000020,
  Set = 0x00000040,
  Cache = 0x00000080,
  Deprecated = 0x00000100,
  Abstract = 0x00001000,
  Static = 0x00002000,
  Public = 0x00004000,
  Sealed = 0x00008000,
  MinValue = 0x00100000,
  MaxValue = 0x00200000,
  StdValues = 0x00400000,
  StdValuesExclusive = 0x00800000,
  NoRead = 0x01000000,
  NoWrite = 0x02000000,
  ByRef = 0x04000000,
  RetValue = 0x08000000,
  DefaultValue = 0x10000000,
  Optional = 0x20000000,
  PromoteValue = unchecked((int)0x80000000)
}
Collapse Expand Members
Members | Description
None = 0 | Indicates no attributes.
SignNeutral = 0x00000001 | Indicates that unsigned integer value can be interpreted as signed and vice versa
SingleValue = 0x00000002 | Indicates that the value is a single value.
Array = 0x00000004 | Indicates that the value is an array.
Nullable = 0x00000008 | Indicates that the value is nullable.
Local = 0x00000010 | Indicates that the value is local.
Global = 0x00000020 | Indicates that the value is global.
Set = 0x00000040 | Indicates that several values (from standard ones) can be combined.
Cache = 0x00000080 | Indicates that the object wrapper has to be cached.
Deprecated = 0x00000100 | Indicates that the value is deprecated.
Abstract = 0x00001000 | Indicates that the value is abstract.
Static = 0x00002000 | Indicates that the value is static.
Public = 0x00004000 | Indicates that the value is public.
Sealed = 0x00008000 | Indicates that the value is sealed.
MinValue = 0x00100000 | Indicates that the value is the minimum value.
MaxValue = 0x00200000 | Indicates that the value is the maximum value.
StdValues = 0x00400000 | Indicates that standard values are used.
StdValuesExclusive = 0x00800000 | Indicates that standard values are exclusive.
NoRead = 0x01000000 | Indicates that the value can't be read.
NoWrite = 0x02000000 | Indicates that the value can't be written.
ByRef = 0x04000000 | Indicates that parameters are passed by reference.
RetValue = 0x08000000 | Indicates a return value.
DefaultValue = 0x10000000 | Indicates that the value is the default value.
Optional = 0x20000000 | Indicates that the value is optional.
PromoteValue = unchecked((int)0x80000000) | For NValueCreate/NArrayCreate specifies that the created object takes ownership of the provided pointer.
Container

File: NTypes.cs

Namespace: Neurotec

Module: .NET Reference


Neurotec.NMemoryType Enumeration

Neurotec.NMemoryType Enumeration

Enumerates memory type options.

C#
public enum NMemoryType {
  None = 0,
  Default = 1,
  Aligned = 2,
  Standard = 3,
  Win32Local = 4,
  Win32Global = 5,
  Custom = 15
}
Collapse Expand Members
Members | Description
None = 0 | No memory type.
Default = 1 | Default memory type.
Aligned = 2 | Aligned memory type.
Standard = 3 | Standard memory type.
Win32Local = 4 | Win32Local memory type.
Win32Global = 5 | Win32Global memory type.
Custom = 15 | Custom memory type.
Container

File: NTypes.cs

Namespace: Neurotec

Module: .NET Reference


Neurotec.NModuleOptions Enumeration

Neurotec.NModuleOptions Enumeration

Enumerates module options.

C#
[Flags]
public enum NModuleOptions {
  None = 0,
  Debug = 0x01,
  Protected = 0x02,
  Unicode = 0x04,
  NoAnsiFunc = 0x08,
  NoUnicode = 0x10,
  Lib = 0x20,
  Exe = 0x40
}
Collapse Expand Members
Members | Description
None = 0 | No option for the module.
Debug = 0x01 | The module is a debug version.
Protected = 0x02 | The module is copy-protected.
Unicode = 0x04 | The module in compiled with Unicode in it.
NoAnsiFunc = 0x08 | The module has no ANSI versions for function.
NoUnicode = 0x10 | The module has no Unicode versions for functions.
Lib = 0x20 | The module is in a static library.
Exe = 0x40 | The module is in an executable file.
Container

File: NModule.cs

Namespace: Neurotec

Module: .NET Reference


Neurotec.NOSFamily Enumeration

Neurotec.NOSFamily Enumeration

Enumerates operating system families.

C#
[Flags]
public enum NOSFamily {
  None = 0,
  Windows = 1,
  WindowsCE = 2,
  WindowsPhone = 4,
  MacOSX = 8,
  IOS = 16,
  Linux = 32,
  EmbeddedLinux = 64,
  Android = 128,
  Unix = 256,
  Mobile = 512
}
Collapse Expand Members
Members | Description
None = 0 | Indicates no OS.
Windows = 1 | Indicates Windows OS.
WindowsCE = 2 | Indicates Windows CE OS.
WindowsPhone = 4 | Indicates Windows Phone OS.
MacOSX = 8 | Indicates MacOS X.
IOS = 16 | Indicates iOS.
Linux = 32 | Indicates Linux OS.
EmbeddedLinux = 64 | Indicates embedded Linux OS.
Android = 128 | Indicates Android OS.
Unix = 256 | Indicates Unix OS.
Mobile = 512 | Indicates any Mobile OS.
Container

File: NTypes.cs

Namespace: Neurotec

Module: .NET Reference


Neurotec.NProcessorFeature Enumeration

Neurotec.NProcessorFeature Enumeration

Specifies the processor's feature flag.

C#
[Serializable]
public enum NProcessorFeature {
}
Container

File: NProcessorInfo.cs

Namespace: Neurotec

Module: .NET Reference


Neurotec.NProcessorVendor Enumeration

Neurotec.NProcessorVendor Enumeration

Specifies the processor's vendor name.

C#
[Serializable]
public enum NProcessorVendor {
  Unknown = 0,
  Amd = 1,
  Centaur = 2,
  Cyrix = 3,
  Intel = 4,
  NationalSemiconductor = 5,
  NexGen = 6,
  RiseTechnology = 7,
  SiS = 8,
  Transmeta = 9,
  Umc = 10,
  Via = 11
}
Collapse Expand Members
Members | Description
Unknown = 0 | The processor's vendor is unknown.
Amd = 1 | Advanced Micro Devices, Inc. (AMD).
Centaur = 2 | Centaur Technology.
Cyrix = 3 | Cyrix.
Intel = 4 | Intel Corporation.
NationalSemiconductor = 5 | National Semiconductor.
NexGen = 6 | NexGen.
RiseTechnology = 7 | Rise Technology.
SiS = 8 | Silicon Integrated Systems (SIS) Corp.
Transmeta = 9 | Transmeta Corporation.
Umc = 10 | UMC.
Via = 11 | VIA.
Container

File: NProcessorInfo.cs

Namespace: Neurotec

Module: .NET Reference


Neurotec.NTypeCode Enumeration

Neurotec.NTypeCode Enumeration

Enumerates type codes.

C#
public enum NTypeCode {
  None = 0,
  Other = 1,
  Byte = 2,
  SByte = 3,
  UInt16 = 4,
  Int16 = 5,
  UInt32 = 6,
  Int32 = 7,
  UInt64 = 8,
  Int64 = 9,
  Single = 10,
  Double = 11,
  Boolean = 12,
  SizeType = 13,
  SSizeType = 14,
  Pointer = 15,
  Result = 16,
  AChar = 17,
  WChar = 18,
  String = 19,
  Object = 20,
  Value = 21,
  Array = 22,
  TimeSpan = 23,
  DateTime = 24,
  URational = 25,
  Rational = 26,
  Complex = 27,
  Guid = 28,
  Buffer = 29,
  Callback = 30,
  AsyncOperation = 31,
  ObjectPart = 32,
  Collection = 33,
  Dictionary = 34,
  ArrayCollection = 35
}
Collapse Expand Members
Members | Description
None = 0 | Empty value.
Other = 1 | Other value type.
Byte = 2 | A byte.
SByte = 3 | Signed byte.
UInt16 = 4 | Unsigned 16-bit integer.
Int16 = 5 | 16-bit integer.
UInt32 = 6 | Unsigned 32-bit integer.
Int32 = 7 | 32-bit integer.
UInt64 = 8 | Unsigned 64-bit integer.
Int64 = 9 | 64-bit integer.
Single = 10 | Single value.
Double = 11 | Double number.
Boolean = 12 | Boolean value.
SizeType = 13 | NSizeType value.
SSizeType = 14 | Signed NSizeType value.
Pointer = 15 | Pointer.
Result = 16 | NResult value.
AChar = 17 | ASCII character.
WChar = 18 | Unicode character.
String = 19 | String.
Object = 20 | An object.
Value = 21 | Custom type value.
Array = 22 | Array.
TimeSpan = 23 | NTimeSpan value.
DateTime = 24 | NDateTime value.
URational = 25 | Unsigned rational number.
Rational = 26 | Rational number.
Complex = 27 | Complex number.
Guid = 28 | Global unique identifier.
Buffer = 29 | Buffer.
Callback = 30 | A callback.
AsyncOperation = 31 | Asynchronous operation.
ObjectPart = 32 | A part of an object.
Collection = 33 | A collection.
Dictionary = 34 | A dictionary.
ArrayCollection = 35 | Collection of arrays.
Container

File: NType.cs

Namespace: Neurotec

Module: .NET Reference


Neurotec.Biometrics Namespace

Neurotec.Biometrics Namespace
Classes Legend Structs, Records, Enums

Classes under this namespace provide methods for working with biometric data.

Collapse Expand Classes
Name | Description
NBiometric | Provides general biometric methods.
NBiometricAttributes | Represents the biometric attributes.
NBiometricQualityBlock | Provides properties for getting and setting a biometric quality block.
NBiometricTypes | Defines biometric types used by Neurotechnology components.
NBiometrics | Provides methods for retrieving NBiometrics Library information.
NFCore | The structure contains information of core.
NFDelta | The structure contains information of delta.
NFDoubleCore | The structure contains information of double core.
NFMinutia | The structure contains information of minutia.
NFMinutiaNeighbor | The structure contains information of minutia neighbor.
NFace | Provides methods for biometric engine to deal with face templates.
NLAttributes | Provides methods to retrieve face template attributes.
NLFeaturePoint | Structure defining facial feature point.
NLMatchingDetails | Provides functionality to retrieve face templates matching details.
NLRecord | Provides functionality for packing, unpacking and editing Neurotechnology Face Records (NLRecords).
NLTemplate | Provides functionality for packing, unpacking and editing Neurotechnology Faces Templates (NLTemplates).
NMatchingDetails | Provides functionality for retrieving Neurotechnology templates matching details.
NMatchingDetailsBase | Base class for NMatchingDetails.
NMatchingResult | Provides methods to retrieve information about matching results.
NSubject | Represents a person (or, potentially, any living creature) and contains biometric information related that person, including templates, biometric operation (matching) results and objects like NFace, which contain biometric data of specific kinds.
NTemplate | Provides functionality for packing, unpacking and editing Neurotechnology Templates (NTemplates).
Collapse Expand Structs, Records, Enums
Name | Description
NBiometricCaptureOptions | Enumerates biometric capture options.
NBiometricStatus | Enumerates biometric status values. These values are returned by NBiometricDevice.
NBiometricSubtype | Specifies the subtype of biometric data.
NBiometricType | Specifies the type of biometric data.
NEImageType | Enumerates iris image types.
NEPosition | Holds information on iris image position.
NFImpressionType | Specifies the impression types.
NFMinutiaFormat | Specifies minutia format.
NFMinutiaType | Specifies types of minutia.
NFPatternClass | Specifies pattern class of the fingerprint.
NFPosition | Specifies finger position.
NFRidgeCountsType | Specifies type of ridge counts contained in NFRecord.
NGender | Enumerates gender constants.
NIcaoWarnings | Enumerates face Icao check warnings constants.
NLExpression | Enumerates facial expression constants.
NLProperties | Enumerates basic face properties constants
NLivenessAction | Enumerates face liveness challenge action constants.
NLivenessMode | Enumerates face liveness mode constants.
NfiqQuality | Specifies the quality of a fingerprint image.


NBiometric Class

NBiometric Class
NObject Delegates NObject Events NObject Fields Legend Members NDisposable Methods NDisposable Properties

Provides general biometric methods.

C#
public class NBiometric : NObject;
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NBiometric Class
Name | Description
IsBiometricCaptureOptionsValid | Checks whether the specified biometric capture options are valid.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NBiometric Class
Name | Description
BiometricType | Gets the biometric type.
CaptureOptions | Gets or sets the biometric capture options.
Error | Gets the last exception.
FileName | Gets or sets the file name.
HasMoreSamples | Gets or sets whether the NBioemtric object has more samples.
NBiometricCaptureOptionsNativeType | Defines the native type of the capture options.
NativeType | Defines the native type of the object.
Owner | Gets owner of the object.
ParentObject | Gets the parent object.
SampleBuffer | Gets or sets sample buffer. Use similar to FileName property, but this is more efficient if file contents are already loaded to memory.
SessionId | Gets or sets the session ID.
Status | Gets or sets the biometric status.
Container

File: NBiometric.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


NBiometric.IsBiometricCaptureOptionsValid Method

NBiometric.IsBiometricCaptureOptionsValid Method
NBiometric Class Neurotec.Biometrics Namespace

Checks whether the specified biometric capture options are valid.

C#
public static bool IsBiometricCaptureOptionsValid(NBiometricCaptureOptions value);
Collapse Expand Parameters
Parameters | Description
NBiometricCaptureOptions value | The biometric capture options object.
Collapse Expand Returns

true if the options are valid; else false.


NBiometric.BiometricType Property

NBiometric.BiometricType Property
NBiometric Class Neurotec.Biometrics Namespace

Gets the biometric type.

C#
public NBiometricType BiometricType;


NBiometric.CaptureOptions Property

NBiometric.CaptureOptions Property
NBiometric Class Neurotec.Biometrics Namespace

Gets or sets the biometric capture options.

C#
public NBiometricCaptureOptions CaptureOptions;
Collapse Expand Remarks

Manual capture: does face detection from stream until NBiometricClient.Force/ForceStart is called, then does extraction or other required operations. Used only when performing capture operation (from camera or video file).

Stream capture: creates face template from multiple images. Used with capture operation or extraction from video file.


NBiometric.Error Property

NBiometric.Error Property
NBiometric Class Neurotec.Biometrics Namespace

Gets the last exception.

C#
public Exception Error;


NBiometric.FileName Property

NBiometric.FileName Property
NBiometric Class Neurotec.Biometrics Namespace

Gets or sets the file name.

C#
public string FileName;


NBiometric.HasMoreSamples Property

NBiometric.HasMoreSamples Property
NBiometric Class Neurotec.Biometrics Namespace

Gets or sets whether the NBioemtric object has more samples.

C#
public bool HasMoreSamples;
Collapse Expand Remarks

Property is used for operations (stream extraction / detection) requiring multiple samples (images) to complete. When set to true engine starts/continues stream extraction for each time task is performed. Changing Image does not clear NLAttributes when property is set to true. Set to false when operation completed (face status != none), or when end of stream/images.


NBiometric.NBiometricCaptureOptionsNativeType Property

NBiometric.NBiometricCaptureOptionsNativeType Property
NBiometric Class Neurotec.Biometrics Namespace

Defines the native type of the capture options.

C#
public static NType NBiometricCaptureOptionsNativeType;


NBiometric.NativeType Property

NBiometric.NativeType Property
NBiometric Class Neurotec.Biometrics Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NBiometric.Owner Property

NBiometric.Owner Property
NBiometric Class Neurotec.Biometrics Namespace

Gets owner of the object.

C#
public new NSubject Owner;
Property value

Object (owner) of NObject type.


NBiometric.ParentObject Property

NBiometric.ParentObject Property
NBiometric Class Neurotec.Biometrics Namespace

Gets the parent object.

C#
public NBiometricAttributes ParentObject;


NBiometric.SampleBuffer Property

NBiometric.SampleBuffer Property
NBiometric Class Neurotec.Biometrics Namespace

Gets or sets sample buffer. Use similar to FileName property, but this is more efficient if file contents are already loaded to memory.

C#
public NBuffer SampleBuffer;


NBiometric.SessionId Property

NBiometric.SessionId Property
NBiometric Class Neurotec.Biometrics Namespace

Gets or sets the session ID.

C#
public int SessionId;


NBiometric.Status Property

NBiometric.Status Property
NBiometric Class Neurotec.Biometrics Namespace

Gets or sets the biometric status.

C#
public NBiometricStatus Status;


NBiometricAttributes Class

NBiometricAttributes Class
NObject Delegates NObject Events NObject Fields Legend Members NDisposable Methods NDisposable Properties

Represents the biometric attributes.

C#
public class NBiometricAttributes : NObject, System.Collections.Generic.IReadOnlyDictionary<NBiometricAttributeId, NBiometricAttributes.Attribute>;
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NBiometricAttributes Class
Name | Description
BiometricType | Gets the biometric type.
Child | Gets child NBiometric object of the current NBiometricAttributes.
ChildSubject | Gets child NSubject of the current NBiometricAttributes.
DetectionConfidence | Gets or sets the detection confidence.
LivenessConfidence | Gets or sets presentation attack detection confidence value.
NativeType | Defines the native type of the object.
Quality | Gets or sets the quality.
Status | Gets or sets the biometric status.
Container

File: NBiometricAttributes.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


NBiometricAttributes.BiometricType Property

NBiometricAttributes.BiometricType Property
NBiometricAttributes Class Neurotec.Biometrics Namespace

Gets the biometric type.

C#
public NBiometricType BiometricType;


NBiometricAttributes.Child Property

NBiometricAttributes.Child Property
NBiometricAttributes Class Neurotec.Biometrics Namespace

Gets child NBiometric object of the current NBiometricAttributes.

C#
public NBiometric Child;


NBiometricAttributes.ChildSubject Property

NBiometricAttributes.ChildSubject Property
NBiometricAttributes Class Neurotec.Biometrics Namespace

Gets child NSubject of the current NBiometricAttributes.

C#
public NSubject ChildSubject;


NBiometricAttributes.DetectionConfidence Property

NBiometricAttributes.DetectionConfidence Property
NBiometricAttributes Class Neurotec.Biometrics Namespace

Gets or sets the detection confidence.

C#
public byte DetectionConfidence;


NBiometricAttributes.LivenessConfidence Property

NBiometricAttributes.LivenessConfidence Property
NBiometricAttributes Class Neurotec.Biometrics Namespace

Gets or sets presentation attack detection confidence value.

C#
public byte LivenessConfidence;
Property value

Presentation attack detection confidence value.


NBiometricAttributes.NativeType Property

NBiometricAttributes.NativeType Property
NBiometricAttributes Class Neurotec.Biometrics Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NBiometricAttributes.Quality Property

NBiometricAttributes.Quality Property
NBiometricAttributes Class Neurotec.Biometrics Namespace

Gets or sets the quality.

C#
public byte Quality;


NBiometricAttributes.Status Property

NBiometricAttributes.Status Property
NBiometricAttributes Class Neurotec.Biometrics Namespace

Gets or sets the biometric status.

C#
public NBiometricStatus Status;


NBiometricQualityBlock Structure

NBiometricQualityBlock Structure
Legend Members Methods NBiometricQualityBlock Methods NBiometricQualityBlock Properties

Provides properties for getting and setting a biometric quality block.

C#
[Serializable]
[StructLayout(LayoutKind.Sequential)]
public struct NBiometricQualityBlock : IFormattable {
}
Collapse Expand NBiometricQualityBlock Methods
Name | Description
ToString | Returns a string that represents the current structure.
Collapse Expand NBiometricQualityBlock Properties
Name | Description
NativeType | Defines the native type of the object.
QualityAlgorithmId | Gets or sets the CBEFF Quality Algorithm Identifier.
QualityAlgorithmVendorId | Gets or sets the CBEFF Biometric Quality Algorithm Vendor Identifier (CBEFF Biometric Organization Identifier).
QualityScore | Gets or sets the quality score.
Container

File: NBiometricTypes.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


NBiometricQualityBlock.NBiometricQualityBlock Constructor

NBiometricQualityBlock.NBiometricQualityBlock Constructor
NBiometricQualityBlock Structure Neurotec.Biometrics Namespace

Initializes a new instance of the NBiometricQualityBlock class.

C#
public NBiometricQualityBlock(byte qualityScore, ushort qualityAlgorithmVendorId, ushort qualityAlgorithmId);
Collapse Expand Parameters
Parameters | Description
byte qualityScore | Quality score.
ushort qualityAlgorithmVendorId | Quality algorithm vendor id.
ushort qualityAlgorithmId | Quality algorithm id.


NBiometricQualityBlock.ToString Method ()

NBiometricQualityBlock.ToString Method ()
NBiometricQualityBlock Structure Neurotec.Biometrics Namespace

Returns a string that represents the current structure.

C#
public override string ToString();
Collapse Expand Returns

String representation of the NBiometricQualityBlock object.


NBiometricQualityBlock.ToString Method (string)

NBiometricQualityBlock.ToString Method (string)
NBiometricQualityBlock Structure Neurotec.Biometrics Namespace

Returns a string that represents the current structure.

C#
public string ToString(string format);
Collapse Expand Parameters
Parameters | Description
string format | String format.
Collapse Expand Returns

String representation of the NBiometricQualityBlock object.


NBiometricQualityBlock.NativeType Property

NBiometricQualityBlock.NativeType Property
NBiometricQualityBlock Structure Neurotec.Biometrics Namespace

Defines the native type of the object.

C#
public static NType NativeType;


NBiometricQualityBlock.QualityAlgorithmId Property

NBiometricQualityBlock.QualityAlgorithmId Property
NBiometricQualityBlock Structure Neurotec.Biometrics Namespace

Gets or sets the CBEFF Quality Algorithm Identifier.

C#
public ushort QualityAlgorithmId;
Property value

Quality algorithm identifier.


NBiometricQualityBlock.QualityAlgorithmVendorId Property

NBiometricQualityBlock.QualityAlgorithmVendorId Property
NBiometricQualityBlock Structure Neurotec.Biometrics Namespace

Gets or sets the CBEFF Biometric Quality Algorithm Vendor Identifier (CBEFF Biometric Organization Identifier).

C#
public ushort QualityAlgorithmVendorId;
Property value

Quality algorithm vendor identifier.


NBiometricQualityBlock.QualityScore Property

NBiometricQualityBlock.QualityScore Property
NBiometricQualityBlock Structure Neurotec.Biometrics Namespace

Gets or sets the quality score.

C#
public byte QualityScore;
Property value

Quality score.


NBiometricTypes Class

NBiometricTypes Class
NBiometricTypes Fields Legend Members NBiometricTypes Methods NBiometricTypes Properties

Defines biometric types used by Neurotechnology components.

C#
public static class NBiometricTypes;
Collapse Expand NBiometricTypes Fields
Name | Description
PhraseIdUnknown | Unknown phrase ID.
QualityFailed | Failed or unspecified quality.
QualityMax | Maximal quality.
QualityMin | Minimal quality.
QualityUnknown | Unknown quality.
Collapse Expand NBiometricTypes Methods
Name | Description
AngleFromDegrees | Converts the specified degrees top angle.
AngleFromRadians | Converts the specified angle from radians to degrees.
AngleToDegrees | Converts the specified angle from degrees.
AngleToRadians | Converts the specified angle from degrees to radians.
AngleToString | Gets a string representation of the specified angle.
GetPositionAvailableParts | Determines available iris positions based on specified missing iris positions and base position.
IsBiometricStatusFinal | Checks whether the biometric status is final.
IsBiometricStatusValid | Checks whether the value passed as a parameter is defined in NBiometricStatus.
IsBiometricSubtypeValid | Checks whether the value passed as a parameter is defined in NBiometricSubtype.
IsBiometricTypeValid | Checks whether the value passed as a parameter is defined in NBiometricType.
IsImpressionTypeCompatibleWith | Gets the Bool value that specify whether two values are compatible.
IsImpressionTypeContact | ... more
IsImpressionTypeContactless | Checks if the specified NFImpressionType value is one of the following: nfitLiveScanContactless, nfitLiveScanOpticalContactlessPlain, nfitLiveScanOpticalContactlessRolled, nfitLiveScanNonOpticalContactlessPlain, nfitLiveScanNonOpticalContactlessRolled.
IsImpressionTypeFinger | Checks whether the specified value is fingerprint.
IsImpressionTypeGeneric | Checks whether the impression type is generic.
IsImpressionTypeLatent | Checks whether the specified value is a latent scan.
IsImpressionTypeLiveScan | Checks whether the specified value is a live scan.
IsImpressionTypeNonOptical | ... more
IsImpressionTypeNonliveScan | Checks whether the specified value is a non-live scan.
IsImpressionTypeOneOf | Checks whether specified NFImpressionType value matches one in an array.
IsImpressionTypeOptical | ... more
IsImpressionTypePalm | Checks whether the specified value is a palmprint.
IsImpressionTypePlain | Checks whether the specified value is a plain scan or optical contact/contactless.
IsImpressionTypeRolled | Checks whether the specified value is one of rolled biometric types.
IsImpressionTypeSwipe | ... more
IsImpressionTypeValid | Checks whether the value passed as a parameter is a valid NFImpressionType value.
IsImpressionTypeValidFinger | Checks whether the specified value is a valid fingerprint.
IsImpressionTypeValidPalm | Checks whether the specified value is a valid palmprint.
IsNfiqQualityValid | Checks whether the specified value is a valid NfiqQuality value.
IsNfiqValid | Checks whether the specified value is a valid NIST Fingerprint Image Quality (NFIQ 1.0 or NFIQ 2.0) value. NFIQ 1.0 valid byte value can be 20 (poor), 40 (fair), 60 (good), 80 (very good), 100 (excellent), 254 (NFIQ 1.0 was not calculated) and 255 (failed to calculate NFIQ 1.0 value). NFIQ 2.0 valid byte value can be from interval [0; 100], 254 (NFIQ 2.0 was not calculated) and 255 (failed to calculate NFIQ 2.0 value).
IsPatternClassValid | Checks whether the specified value is a valid NFPatternClass value.
IsPatternClassValidFor | Checks whether the specified NFPatternClass value is valid for specified NFPosition.
IsPositionCompatibleWith | Gets the Bool value that specify whether two values are compatible.
IsPositionFinger | Checks whether the specified value is fingerprint.
IsPositionFourFingers | Checks if the specified value is a type of 4 fingerprints data.
IsPositionKnown | Checks whether the specified position is known.
IsPositionLeft | Checks whether the specified position is left.
IsPositionLeftAndRight | Checks whether the specified position is left and right fingerprint.
IsPositionOneOf | Checks whether specified NEPosition value matches one in an array.
IsPositionPalm | Checks whether the specified value is a palmprint.
IsPositionRight | Checks whether the specified position is right.
IsPositionRightAndLeft | Checks whether the specified position is both right and left.
IsPositionSingleEye | Checks whether the specified position represents a single eye.
IsPositionSingleFinger | Checks whether the specified value is a single fingerprint.
IsPositionTheEye | Checks whether the specified position represents an eye.
IsPositionTheFinger | Checks whether the specified value is the fingerprint.
IsPositionThePalm | Checks whether the specified value is a palmprint.
IsPositionThreeFingers | Checks whether the specified value is a type of 3 fingerprints data.
IsPositionTwoEyes | Checks whether the specified position represents two eyes.
IsPositionTwoFingers | Checks whether the specified value is a type of 2 fingerprints data.
IsPositionValid | Checks whether the value passed as a parameter is a valid NEPosition value.
IsPositionValidFinger | Checks whether the specified value is a valid fingerprint.
IsPositionValidPalm | Checks whether the specified value is a valid palmprint.
IsPositionValidTheEye | Checks whether the specified value is a valid NEPosition value.
IsPositionValidTheFinger | Checks whether the specified value is a valid fingerprint.
IsQualityValid | Checks whether the quality value is valid.
Nfiq1ToNfiqQuality | Converts specified NFIQ 1.0 (NIST Fingerprint Image Quality) value to NfiqQuality value.
NfiqQualityToNfiq1 | Converts specified NfiqQuality value to NFIQ 1.0 (NIST Fingerprint Image Quality) value.
QualityToString | Gets a string representation of the specified quality value.
ToImpressionTypeFinger | Converts an impression type to finger impression type.
Collapse Expand NBiometricTypes Properties
Name | Description
NBiometricStatusNativeType | Defines the native type of the biometric status.
NBiometricSubtypeNativeType | Defines the native type of the biometric subtype.
NBiometricTypeNativeType | Defines the native type of the biometric type.
NEImageTypeNativeType | Defines the native type of the iris image type.
NEPositionNativeType | Defines the native type of the iris position.
NFImpressionTypeNativeType | Defines the native type of the finger impression type.
NFMinutiaFormatNativeType | Defines the native type of the fingerprint minutia format.
NFMinutiaTypeNativeType | Defines the native type of the fingerprint minutia type.
NFPatternClassNativeType | Defines the native type of the pattern class.
NFPositionNativeType | Defines the native type of the finger position.
NFRidgeCountsTypeNativeType | Defines the native type of the fingerprint ridge count.
NGenderNativeType | Defines the native type of the gender.
NIcaoWarningsNativeType | Defines the native type of the icao warnings.
NLExpressionNativeType | Defines the native type of the face expression.
NLPropertiesNativeType | Defines the native type of the face properties.
NLivenessActionNativeType | Defines the native type of the liveness action.
NLivenessModeNativeType | Defines the native type of the liveness mode.
NTemplateSizeNativeType | Defines the native type of the template size.
NativeType | Defines the native type of the object.
NfiqQualityNativeType | Defines the native type of the fingerprint image quality.
Container

File: NBiometricTypes.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


NBiometricTypes.PhraseIdUnknown Field

NBiometricTypes.PhraseIdUnknown Field
NBiometricTypes Class Neurotec.Biometrics Namespace

Unknown phrase ID.

C#
public const int PhraseIdUnknown = 0;


NBiometricTypes.QualityFailed Field

NBiometricTypes.QualityFailed Field
NBiometricTypes Class Neurotec.Biometrics Namespace

Failed or unspecified quality.

C#
public const byte QualityFailed = 255;


NBiometricTypes.QualityMax Field

NBiometricTypes.QualityMax Field
NBiometricTypes Class Neurotec.Biometrics Namespace

Maximal quality.

C#
public const byte QualityMax = 100;


NBiometricTypes.QualityMin Field

NBiometricTypes.QualityMin Field
NBiometricTypes Class Neurotec.Biometrics Namespace

Minimal quality.

C#
public const byte QualityMin = 0;


NBiometricTypes.QualityUnknown Field

NBiometricTypes.QualityUnknown Field
NBiometricTypes Class Neurotec.Biometrics Namespace

Unknown quality.

C#
public const byte QualityUnknown = 254;


NBiometricTypes.AngleFromDegrees Method

NBiometricTypes.AngleFromDegrees Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Converts the specified degrees top angle.

C#
public static int AngleFromDegrees(float value);
Collapse Expand Parameters
Parameters | Description
float value | Degrees value of the angle.
Collapse Expand Returns

Degree value of the angle.


NBiometricTypes.AngleFromRadians Method

NBiometricTypes.AngleFromRadians Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Converts the specified angle from radians to degrees.

C#
public static int AngleFromRadians(double value);
Collapse Expand Parameters
Parameters | Description
double value | Radian value of the angle.
Collapse Expand Returns

Degree value of the angle.


NBiometricTypes.AngleToDegrees Method

NBiometricTypes.AngleToDegrees Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Converts the specified angle from degrees.

C#
public static float AngleToDegrees(int value);
Collapse Expand Parameters
Parameters | Description
int value | Degree value of the angle.
Collapse Expand Returns

Angle value.


NBiometricTypes.AngleToRadians Method

NBiometricTypes.AngleToRadians Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Converts the specified angle from degrees to radians.

C#
public static double AngleToRadians(int value);
Collapse Expand Parameters
Parameters | Description
int value | Degree value of the angle.
Collapse Expand Returns

Radian value of the angle.


NBiometricTypes.AngleToString Method (int)

NBiometricTypes.AngleToString Method (int)
NBiometricTypes Class Neurotec.Biometrics Namespace

Gets a string representation of the specified angle.

C#
public static string AngleToString(int value);
Collapse Expand Parameters
Parameters | Description
int value | Degree value of the angle.
Collapse Expand Returns

A string representing the angle.


NBiometricTypes.AngleToString Method (int, string)

NBiometricTypes.AngleToString Method (int, string)
NBiometricTypes Class Neurotec.Biometrics Namespace

Gets a string representation of the specified angle.

C#
public static string AngleToString(int value, string format);
Collapse Expand Parameters
Parameters | Description
int value | Degree value of the angle.
string format | Conversion format.
Collapse Expand Returns

A string representing the angle.


NBiometricTypes.GetPositionAvailableParts Method (NEPosition, NEPosition[])

NBiometricTypes.GetPositionAvailableParts Method (NEPosition, NEPosition[])
NBiometricTypes Class Neurotec.Biometrics Namespace

Determines available iris positions based on specified missing iris positions and base position.

C#
public static NEPosition[] GetPositionAvailableParts(NEPosition value, NEPosition[] missingPositions);
Collapse Expand Parameters
Parameters | Description
NEPosition value | NEPosition object, representing the general position.
NEPosition[] missingPositions | An array of NEPosition objects, representing missing position parts.
Collapse Expand Returns

An array of NEPosition objects, representing available position parts.


NBiometricTypes.GetPositionAvailableParts Method (NFPosition, NFPosition[])

NBiometricTypes.GetPositionAvailableParts Method (NFPosition, NFPosition[])
NBiometricTypes Class Neurotec.Biometrics Namespace

Determines available finger positions based on specified missing finger positions and base position.

C#
public static NFPosition[] GetPositionAvailableParts(NFPosition value, NFPosition[] missingPositions);
Collapse Expand Parameters
Parameters | Description
NFPosition value | NFPosition object, representing the general position.
NFPosition[] missingPositions | An array of NFPosition objects, representing missing position parts.
Collapse Expand Returns

An array of NFPosition objects, representing available position parts.


NBiometricTypes.IsBiometricStatusFinal Method

NBiometricTypes.IsBiometricStatusFinal Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether the biometric status is final.

C#
public static bool IsBiometricStatusFinal(NBiometricStatus value);
Collapse Expand Parameters
Parameters | Description
NBiometricStatus value | One of NBiometricStatus values to check.
Collapse Expand Returns

NTrue if the value is final; else NFalse.


NBiometricTypes.IsBiometricStatusValid Method

NBiometricTypes.IsBiometricStatusValid Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether the value passed as a parameter is defined in NBiometricStatus.

C#
public static bool IsBiometricStatusValid(NBiometricStatus value);
Collapse Expand Parameters
Parameters | Description
NBiometricStatus value | One of NBiometricStatus values to check.
Collapse Expand Returns

Bool type value.


NBiometricTypes.IsBiometricSubtypeValid Method

NBiometricTypes.IsBiometricSubtypeValid Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether the value passed as a parameter is defined in NBiometricSubtype.

C#
public static bool IsBiometricSubtypeValid(NBiometricSubtype value);
Collapse Expand Parameters
Parameters | Description
NBiometricSubtype value | One of NBiometricSubtype values to check.
Collapse Expand Returns

Bool type value.


NBiometricTypes.IsBiometricTypeValid Method

NBiometricTypes.IsBiometricTypeValid Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether the value passed as a parameter is defined in NBiometricType.

C#
public static bool IsBiometricTypeValid(NBiometricType value);
Collapse Expand Parameters
Parameters | Description
NBiometricType value | One of NBiometricType values to check.
Collapse Expand Returns

Bool type value.


NBiometricTypes.IsImpressionTypeCompatibleWith Method

NBiometricTypes.IsImpressionTypeCompatibleWith Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Gets the Bool value that specify whether two values are compatible.

C#
public static bool IsImpressionTypeCompatibleWith(NFImpressionType value, NFImpressionType otherValue);
Collapse Expand Parameters
Parameters | Description
NFImpressionType value | Value to check if it is compatible with other value.
NFImpressionType otherValue | Value which is used to check compatibility with value.
Collapse Expand Returns

A Bool value that specifies whether two values are compatible.


NBiometricTypes.IsImpressionTypeContact Method

NBiometricTypes.IsImpressionTypeContact Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether the specified NFImpressionType value is one of the following: nfitLiveScanOpticalContactPlain, nfitLiveScanOpticalContactRolled, nfitLiveScanNonOpticalContactPlain, nfitLiveScanNonOpticalContactRolled

C#
public static bool IsImpressionTypeContact(NFImpressionType value);
Collapse Expand Parameters
Parameters | Description
NFImpressionType value | NFImpressionType value to check.
Collapse Expand Returns

A Bool value that specifies whether the specified value is a contact type.


NBiometricTypes.IsImpressionTypeContactless Method

NBiometricTypes.IsImpressionTypeContactless Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks if the specified NFImpressionType value is one of the following: nfitLiveScanContactless, nfitLiveScanOpticalContactlessPlain, nfitLiveScanOpticalContactlessRolled, nfitLiveScanNonOpticalContactlessPlain, nfitLiveScanNonOpticalContactlessRolled.

C#
public static bool IsImpressionTypeContactless(NFImpressionType value);
Collapse Expand Parameters
Parameters | Description
NFImpressionType value | NFImpressionType value to check.
Collapse Expand Returns

A Bool value that specifies whether the specified value is a contactless type.


NBiometricTypes.IsImpressionTypeFinger Method

NBiometricTypes.IsImpressionTypeFinger Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether the specified value is fingerprint.

C#
public static bool IsImpressionTypeFinger(NFImpressionType value);
Collapse Expand Parameters
Parameters | Description
NFImpressionType value | NFImpressionType value to check its type.
Collapse Expand Returns

A Bool value that specifies whether the value is a fingerprint.


NBiometricTypes.IsImpressionTypeGeneric Method

NBiometricTypes.IsImpressionTypeGeneric Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether the impression type is generic.

C#
public static bool IsImpressionTypeGeneric(NFImpressionType value);
Collapse Expand Parameters
Parameters | Description
NFImpressionType value | Impression type value.
Collapse Expand Returns

NTrue if the value is generic; else NFalse.


NBiometricTypes.IsImpressionTypeLatent Method

NBiometricTypes.IsImpressionTypeLatent Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether the specified value is a latent scan.

C#
public static bool IsImpressionTypeLatent(NFImpressionType value);
Collapse Expand Parameters
Parameters | Description
NFImpressionType value | NFImpressionType value to check its type.
Collapse Expand Returns

Bool type value.


NBiometricTypes.IsImpressionTypeLiveScan Method

NBiometricTypes.IsImpressionTypeLiveScan Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether the specified value is a live scan.

C#
public static bool IsImpressionTypeLiveScan(NFImpressionType value);
Collapse Expand Parameters
Parameters | Description
NFImpressionType value | NFImpressionType value to check its type.
Collapse Expand Returns

Bool type value.


NBiometricTypes.IsImpressionTypeNonOptical Method

NBiometricTypes.IsImpressionTypeNonOptical Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether the specified NFImpressionType value is one of the following: nfitLiveScanNonOpticalContactPlain, nfitLiveScanNonOpticalContactRolled, nfitLiveScanNonOpticalContactlessPlain, nfitLiveScanNonOpticalContactlessRolled.

C#
public static bool IsImpressionTypeNonOptical(NFImpressionType value);
Collapse Expand Parameters
Parameters | Description
NFImpressionType value | NFImpressionType value to check.
Collapse Expand Returns

Bool type value.


NBiometricTypes.IsImpressionTypeNonliveScan Method

NBiometricTypes.IsImpressionTypeNonliveScan Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether the specified value is a non-live scan.

C#
public static bool IsImpressionTypeNonliveScan(NFImpressionType value);
Collapse Expand Parameters
Parameters | Description
NFImpressionType value | NFImpressionType value to check its type.
Collapse Expand Returns

Bool type value specifying whether the value is a non-live scan.


NBiometricTypes.IsImpressionTypeOneOf Method

NBiometricTypes.IsImpressionTypeOneOf Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether specified NFImpressionType value matches one in an array.

C#
public static bool IsImpressionTypeOneOf(NFImpressionType value, NFImpressionType[] supportedImpressionTypes);
Collapse Expand Parameters
Parameters | Description
NFImpressionType value | One of the NFImpressionType values to check.
NFImpressionType[] supportedImpressionTypes | NFImpressionType values array.
Collapse Expand Returns

Bool type value specifying whether value is on of the values in an array.


NBiometricTypes.IsImpressionTypeOptical Method

NBiometricTypes.IsImpressionTypeOptical Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks if the specified NFImpressionType value is one of the following: nfitLiveScanOpticalContactPlain, nfitLiveScanOpticalContactRolled, nfitLiveScanOpticalContactlessPlain, nfitLiveScanOpticalContactlessRolled.

C#
public static bool IsImpressionTypeOptical(NFImpressionType value);
Collapse Expand Parameters
Parameters | Description
NFImpressionType value | NFImpressionType value to check.
Collapse Expand Returns

Bool type value.


NBiometricTypes.IsImpressionTypePalm Method

NBiometricTypes.IsImpressionTypePalm Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether the specified value is a palmprint.

C#
public static bool IsImpressionTypePalm(NFImpressionType value);
Collapse Expand Parameters
Parameters | Description
NFImpressionType value | NFImpressionType value to check its type.
Collapse Expand Returns

Bool type value.


NBiometricTypes.IsImpressionTypePlain Method

NBiometricTypes.IsImpressionTypePlain Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether the specified value is a plain scan or optical contact/contactless.

C#
public static bool IsImpressionTypePlain(NFImpressionType value);
Collapse Expand Parameters
Parameters | Description
NFImpressionType value | NFImpressionType value to check its type.
Collapse Expand Returns

Bool type value.


NBiometricTypes.IsImpressionTypeRolled Method

NBiometricTypes.IsImpressionTypeRolled Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether the specified value is one of rolled biometric types.

C#
public static bool IsImpressionTypeRolled(NFImpressionType value);
Collapse Expand Parameters
Parameters | Description
NFImpressionType value | NFImpressionType value to check its type.
Collapse Expand Returns

Bool type value.


NBiometricTypes.IsImpressionTypeSwipe Method

NBiometricTypes.IsImpressionTypeSwipe Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether the specified NFImpressionType value is one of the following: nfitLiveScanVerticalSwipe.

C#
public static bool IsImpressionTypeSwipe(NFImpressionType value);
Collapse Expand Parameters
Parameters | Description
NFImpressionType value | NFImpressionType value to check.
Collapse Expand Returns

Bool type value.


NBiometricTypes.IsImpressionTypeValid Method

NBiometricTypes.IsImpressionTypeValid Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether the value passed as a parameter is a valid NFImpressionType value.

C#
public static bool IsImpressionTypeValid(NFImpressionType value);
Collapse Expand Parameters
Parameters | Description
NFImpressionType value | One of NFImpressionType values to check.
Collapse Expand Returns

Bool type value.


NBiometricTypes.IsImpressionTypeValidFinger Method

NBiometricTypes.IsImpressionTypeValidFinger Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether the specified value is a valid fingerprint.

C#
public static bool IsImpressionTypeValidFinger(NFImpressionType value);
Collapse Expand Parameters
Parameters | Description
NFImpressionType value | One of NFImpressionType values to check.
Collapse Expand Returns

Bool type value.


NBiometricTypes.IsImpressionTypeValidPalm Method

NBiometricTypes.IsImpressionTypeValidPalm Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether the specified value is a valid palmprint.

C#
public static bool IsImpressionTypeValidPalm(NFImpressionType value);
Collapse Expand Parameters
Parameters | Description
NFImpressionType value | One of NFImpressionType values to check.
Collapse Expand Returns

Bool type value.


NBiometricTypes.IsNfiqQualityValid Method

NBiometricTypes.IsNfiqQualityValid Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether the specified value is a valid NfiqQuality value.

C#
public static bool IsNfiqQualityValid(NfiqQuality value);
Collapse Expand Parameters
Parameters | Description
NfiqQuality value | NfiqQuality value to check.
Collapse Expand Returns

Bool type value.


NBiometricTypes.IsNfiqValid Method

NBiometricTypes.IsNfiqValid Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether the specified value is a valid NIST Fingerprint Image Quality (NFIQ 1.0 or NFIQ 2.0) value. NFIQ 1.0 valid byte value can be 20 (poor), 40 (fair), 60 (good), 80 (very good), 100 (excellent), 254 (NFIQ 1.0 was not calculated) and 255 (failed to calculate NFIQ 1.0 value). NFIQ 2.0 valid byte value can be from interval [0; 100], 254 (NFIQ 2.0 was not calculated) and 255 (failed to calculate NFIQ 2.0 value).

C#
public static bool IsNfiqValid(NVersion version, byte value);
Collapse Expand Parameters
Parameters | Description
NVersion version | Version of NFIQ.
byte value | NFIQ value to check.
Collapse Expand Returns

Bool type value.


NBiometricTypes.IsPatternClassValid Method

NBiometricTypes.IsPatternClassValid Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether the specified value is a valid NFPatternClass value.

C#
public static bool IsPatternClassValid(NFPatternClass value);
Collapse Expand Parameters
Parameters | Description
NFPatternClass value | NFPatternClass value to check.
Collapse Expand Returns

Bool type value.


NBiometricTypes.IsPatternClassValidFor Method

NBiometricTypes.IsPatternClassValidFor Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether the specified NFPatternClass value is valid for specified NFPosition.

C#
public static bool IsPatternClassValidFor(NFPatternClass value, NFPosition pos);
Collapse Expand Parameters
Parameters | Description
NFPatternClass value | NFPatternClass value to check.
NFPosition pos | NFPosition value.
Collapse Expand Returns

Bool type value.


NBiometricTypes.IsPositionCompatibleWith Method (NFPosition, NFImpressionType)

NBiometricTypes.IsPositionCompatibleWith Method (NFPosition, NFImpressionType)
NBiometricTypes Class Neurotec.Biometrics Namespace

Gets the Bool value that specify whether two values are compatible.

C#
public static bool IsPositionCompatibleWith(NFPosition value, NFImpressionType imp);
Collapse Expand Parameters
Parameters | Description
NFPosition value | Value to check if it is compatible with other value.
NFImpressionType imp | Value which is used to check compatibility with value.
Collapse Expand Returns

A Bool value that specifies whether two values are compatible.


NBiometricTypes.IsPositionCompatibleWith Method (NFPosition, NFPosition)

NBiometricTypes.IsPositionCompatibleWith Method (NFPosition, NFPosition)
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether two position value are compatible.

C#
public static bool IsPositionCompatibleWith(NFPosition value, NFPosition otherValue);
Collapse Expand Parameters
Parameters | Description
NFPosition value | First position value.
NFPosition otherValue | Second position value.
Collapse Expand Returns

NTrue if the values are compatible; else NFalse.


NBiometricTypes.IsPositionFinger Method

NBiometricTypes.IsPositionFinger Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether the specified value is fingerprint.

C#
public static bool IsPositionFinger(NFPosition value);
Collapse Expand Parameters
Parameters | Description
NFPosition value | NFPosition value to check its type.
Collapse Expand Returns

A Bool value that specifies whether the value is a fingerprint.


NBiometricTypes.IsPositionFourFingers Method

NBiometricTypes.IsPositionFourFingers Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks if the specified value is a type of 4 fingerprints data.

C#
public static bool IsPositionFourFingers(NFPosition value);
Collapse Expand Parameters
Parameters | Description
NFPosition value | Value to check its type.
Collapse Expand Returns

A bool type value.


NBiometricTypes.IsPositionKnown Method (NEPosition)

NBiometricTypes.IsPositionKnown Method (NEPosition)
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether the specified position is known.

C#
public static bool IsPositionKnown(NEPosition value);
Collapse Expand Parameters
Parameters | Description
NEPosition value | The position to check.
Collapse Expand Returns

NTrue if the position is known; else NFalse.


NBiometricTypes.IsPositionKnown Method (NFPosition)

NBiometricTypes.IsPositionKnown Method (NFPosition)
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether the record contains biometric data that type is one of the known fingerprint types (thumb, palmprint, etc.).

C#
public static bool IsPositionKnown(NFPosition value);
Collapse Expand Parameters
Parameters | Description
NFPosition value | Value to check its type.
Collapse Expand Returns

Bool value - check result.


NBiometricTypes.IsPositionLeft Method (NEPosition)

NBiometricTypes.IsPositionLeft Method (NEPosition)
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether the specified position is left.

C#
public static bool IsPositionLeft(NEPosition value);
Collapse Expand Parameters
Parameters | Description
NEPosition value | The position to check.
Collapse Expand Returns

NTrue if the position is left; else NFalse.


NBiometricTypes.IsPositionLeft Method (NFPosition)

NBiometricTypes.IsPositionLeft Method (NFPosition)
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether the specified position is left fingerprint.

C#
public static bool IsPositionLeft(NFPosition value);
Collapse Expand Parameters
Parameters | Description
NFPosition value | NFImpressionType value to check its type.
Collapse Expand Returns

Bool type value.


NBiometricTypes.IsPositionLeftAndRight Method

NBiometricTypes.IsPositionLeftAndRight Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether the specified position is left and right fingerprint.

C#
public static bool IsPositionLeftAndRight(NFPosition value);
Collapse Expand Parameters
Parameters | Description
NFPosition value | Fingerprint position to check its type.
Collapse Expand Returns

Bool type value.


NBiometricTypes.IsPositionOneOf Method (NEPosition, NEPosition[])

NBiometricTypes.IsPositionOneOf Method (NEPosition, NEPosition[])
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether specified NEPosition value matches one in an array.

C#
public static bool IsPositionOneOf(NEPosition value, NEPosition[] supportedPositions);
Collapse Expand Parameters
Parameters | Description
NEPosition value | One of the NEPosition values to check.
NEPosition[] supportedPositions | NEPosition values array.
Collapse Expand Returns

Bool type value specifying whether NEPosition value is on of the values in an array.


NBiometricTypes.IsPositionOneOf Method (NFPosition, NFPosition[])

NBiometricTypes.IsPositionOneOf Method (NFPosition, NFPosition[])
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether specified NFPosition value matches one in an array.

C#
public static bool IsPositionOneOf(NFPosition value, NFPosition[] supportedPositions);
Collapse Expand Parameters
Parameters | Description
NFPosition value | One of the NFPosition values to check.
NFPosition[] supportedPositions | NFPosition values array.
Collapse Expand Returns

Bool type value specifying whether NFPosition value is on of the values in an array.


NBiometricTypes.IsPositionPalm Method

NBiometricTypes.IsPositionPalm Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether the specified value is a palmprint.

C#
public static bool IsPositionPalm(NFPosition value);
Collapse Expand Parameters
Parameters | Description
NFPosition value | NFPosition value to check its type.
Collapse Expand Returns

Bool type value.


NBiometricTypes.IsPositionRight Method (NEPosition)

NBiometricTypes.IsPositionRight Method (NEPosition)
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether the specified position is right.

C#
public static bool IsPositionRight(NEPosition value);
Collapse Expand Parameters
Parameters | Description
NEPosition value |
Collapse Expand Returns

NTrue if the position is right; else NFalse.


NBiometricTypes.IsPositionRight Method (NFPosition)

NBiometricTypes.IsPositionRight Method (NFPosition)
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether the specified position is right fingerprint.

C#
public static bool IsPositionRight(NFPosition value);
Collapse Expand Parameters
Parameters | Description
NFPosition value | Value to check its type.
Collapse Expand Returns

Bool type value.


NBiometricTypes.IsPositionRightAndLeft Method

NBiometricTypes.IsPositionRightAndLeft Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether the specified position is both right and left.

C#
public static bool IsPositionRightAndLeft(NEPosition value);
Collapse Expand Parameters
Parameters | Description
NEPosition value | The position to check.
Collapse Expand Returns

NTrue if the position is both right and left.; else NFalse.


NBiometricTypes.IsPositionSingleEye Method

NBiometricTypes.IsPositionSingleEye Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether the specified position represents a single eye.

C#
public static bool IsPositionSingleEye(NEPosition value);
Collapse Expand Parameters
Parameters | Description
NEPosition value | The position to check.
Collapse Expand Returns

NTrue if the position represents a single eye; else NFalse.


NBiometricTypes.IsPositionSingleFinger Method

NBiometricTypes.IsPositionSingleFinger Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether the specified value is a single fingerprint.

C#
public static bool IsPositionSingleFinger(NFPosition value);
Collapse Expand Parameters
Parameters | Description
NFPosition value | NFPosition value to check its type.
Collapse Expand Returns

Bool type value.


NBiometricTypes.IsPositionTheEye Method

NBiometricTypes.IsPositionTheEye Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether the specified position represents an eye.

C#
public static bool IsPositionTheEye(NEPosition value);
Collapse Expand Parameters
Parameters | Description
NEPosition value | The position to check.
Collapse Expand Returns

NTrue if the position represents an eye; else NFalse.


NBiometricTypes.IsPositionTheFinger Method

NBiometricTypes.IsPositionTheFinger Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether the specified value is the fingerprint.

C#
public static bool IsPositionTheFinger(NFPosition value);
Collapse Expand Parameters
Parameters | Description
NFPosition value | NFPosition value to check its type.
Collapse Expand Returns

Bool type value.


NBiometricTypes.IsPositionThePalm Method

NBiometricTypes.IsPositionThePalm Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether the specified value is a palmprint.

C#
public static bool IsPositionThePalm(NFPosition value);
Collapse Expand Parameters
Parameters | Description
NFPosition value | NFPosition value to check its type.
Collapse Expand Returns

Bool type value.


NBiometricTypes.IsPositionThreeFingers Method

NBiometricTypes.IsPositionThreeFingers Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether the specified value is a type of 3 fingerprints data.

C#
public static bool IsPositionThreeFingers(NFPosition value);
Collapse Expand Parameters
Parameters | Description
NFPosition value | Value to check its type.
Collapse Expand Returns

Bool type value.


NBiometricTypes.IsPositionTwoEyes Method

NBiometricTypes.IsPositionTwoEyes Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether the specified position represents two eyes.

C#
public static bool IsPositionTwoEyes(NEPosition value);
Collapse Expand Parameters
Parameters | Description
NEPosition value | The position to check.
Collapse Expand Returns

NTrue if the position represents two eyes; else NFalse.


NBiometricTypes.IsPositionTwoFingers Method

NBiometricTypes.IsPositionTwoFingers Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether the specified value is a type of 2 fingerprints data.

C#
public static bool IsPositionTwoFingers(NFPosition value);
Collapse Expand Parameters
Parameters | Description
NFPosition value | Value to check its type.
Collapse Expand Returns

Bool type value.


NBiometricTypes.IsPositionValid Method (NEPosition)

NBiometricTypes.IsPositionValid Method (NEPosition)
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether the value passed as a parameter is a valid NEPosition value.

C#
public static bool IsPositionValid(NEPosition value);
Collapse Expand Parameters
Parameters | Description
NEPosition value | One of NEPosition values to check.
Collapse Expand Returns

Bool type value.


NBiometricTypes.IsPositionValid Method (NFPosition)

NBiometricTypes.IsPositionValid Method (NFPosition)
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether the value passed as a parameter is a valid NFPosition value.

C#
public static bool IsPositionValid(NFPosition value);
Collapse Expand Parameters
Parameters | Description
NFPosition value | One of NFPosition values to check.
Collapse Expand Returns

Bool type value.


NBiometricTypes.IsPositionValidFinger Method

NBiometricTypes.IsPositionValidFinger Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether the specified value is a valid fingerprint.

C#
public static bool IsPositionValidFinger(NFPosition value);
Collapse Expand Parameters
Parameters | Description
NFPosition value | One of NFPosition values to check.
Collapse Expand Returns

Bool type value.


NBiometricTypes.IsPositionValidPalm Method

NBiometricTypes.IsPositionValidPalm Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether the specified value is a valid palmprint.

C#
public static bool IsPositionValidPalm(NFPosition value);
Collapse Expand Parameters
Parameters | Description
NFPosition value | One of NFPosition values to check.
Collapse Expand Returns

Bool type value.


NBiometricTypes.IsPositionValidTheEye Method

NBiometricTypes.IsPositionValidTheEye Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether the specified value is a valid NEPosition value.

C#
public static bool IsPositionValidTheEye(NEPosition value);
Collapse Expand Parameters
Parameters | Description
NEPosition value | NEPosition value to check.
Collapse Expand Returns

Bool type value.


NBiometricTypes.IsPositionValidTheFinger Method

NBiometricTypes.IsPositionValidTheFinger Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether the specified value is a valid fingerprint.

C#
public static bool IsPositionValidTheFinger(NFPosition value);
Collapse Expand Parameters
Parameters | Description
NFPosition value | One of NFPosition values to check.
Collapse Expand Returns

Bool type value.


NBiometricTypes.IsQualityValid Method

NBiometricTypes.IsQualityValid Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Checks whether the quality value is valid.

C#
public static bool IsQualityValid(byte value);
Collapse Expand Parameters
Parameters | Description
byte value | The quality value to checks.
Collapse Expand Returns

NTrue if the quality value is valid; else NFalse.


NBiometricTypes.Nfiq1ToNfiqQuality Method

NBiometricTypes.Nfiq1ToNfiqQuality Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Converts specified NFIQ 1.0 (NIST Fingerprint Image Quality) value to NfiqQuality value.

C#
public static NfiqQuality Nfiq1ToNfiqQuality(byte nfiq1);
Collapse Expand Parameters
Parameters | Description
byte nfiq1 | NFIQ 1.0 value.
Collapse Expand Returns

NfiqQuality type value.

Collapse Expand Remarks

Valid NFIQ 1.0 byte value can be 20, 40, 60, 80, 100, 254 (NFIQ 1.0 was not calculated) and 255 (failed to calculate NFIQ 1.0 value). 20 transforms into NfiqQuality.Poor, 40 transforms into NfiqQuality.Fair, 60 transforms into NfiqQuality.Good, 80 transforms into NfiqQuality.VeryGood, 100 transforms into NfiqQuality.Excellent, 254 and 255 transforms into NfiqQuality.Unknown.


NBiometricTypes.NfiqQualityToNfiq1 Method

NBiometricTypes.NfiqQualityToNfiq1 Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Converts specified NfiqQuality value to NFIQ 1.0 (NIST Fingerprint Image Quality) value.

C#
public static byte NfiqQualityToNfiq1(NfiqQuality nfiqQuality);
Collapse Expand Parameters
Parameters | Description
NfiqQuality nfiqQuality | NfiqQuality value.
Collapse Expand Returns

Byte type value.

Collapse Expand Remarks

Valid NFIQ 1.0 byte value can be 20, 40, 60, 80, 100, 254 (NFIQ 1.0 was not calculated) and 255 (failed to calculate NFIQ 1.0 value). NfiqQuality.Poor transforms into 20, NfiqQuality.Fair transforms into 40, NfiqQuality.Good transforms into 60, NfiqQuality.VeryGood transforms into 80, NfiqQuality.Excellent transforms into 100, NfiqQuality.Unknown transforms into 254.


NBiometricTypes.QualityToString Method (byte)

NBiometricTypes.QualityToString Method (byte)
NBiometricTypes Class Neurotec.Biometrics Namespace

Gets a string representation of the specified quality value.

C#
public static string QualityToString(byte value);
Collapse Expand Parameters
Parameters | Description
byte value | Quality value.
Collapse Expand Returns

A string representation of the quality.


NBiometricTypes.QualityToString Method (byte, string)

NBiometricTypes.QualityToString Method (byte, string)
NBiometricTypes Class Neurotec.Biometrics Namespace

Gets a string representation of the specified quality value.

C#
public static string QualityToString(byte value, string format);
Collapse Expand Parameters
Parameters | Description
byte value | Quality value.
string format | Conversion format.
Collapse Expand Returns

A string representation of the quality.


NBiometricTypes.ToImpressionTypeFinger Method

NBiometricTypes.ToImpressionTypeFinger Method
NBiometricTypes Class Neurotec.Biometrics Namespace

Converts an impression type to finger impression type.

C#
public static NFImpressionType ToImpressionTypeFinger(NFImpressionType value);
Collapse Expand Parameters
Parameters | Description
NFImpressionType value | Impression type to convert.
Collapse Expand Returns

Finger impression type.


NBiometricTypes.NBiometricStatusNativeType Property

NBiometricTypes.NBiometricStatusNativeType Property
NBiometricTypes Class Neurotec.Biometrics Namespace

Defines the native type of the biometric status.

C#
public static NType NBiometricStatusNativeType;


NBiometricTypes.NBiometricSubtypeNativeType Property

NBiometricTypes.NBiometricSubtypeNativeType Property
NBiometricTypes Class Neurotec.Biometrics Namespace

Defines the native type of the biometric subtype.

C#
public static NType NBiometricSubtypeNativeType;


NBiometricTypes.NBiometricTypeNativeType Property

NBiometricTypes.NBiometricTypeNativeType Property
NBiometricTypes Class Neurotec.Biometrics Namespace

Defines the native type of the biometric type.

C#
public static NType NBiometricTypeNativeType;


NBiometricTypes.NEImageTypeNativeType Property

NBiometricTypes.NEImageTypeNativeType Property
NBiometricTypes Class Neurotec.Biometrics Namespace

Defines the native type of the iris image type.

C#
public static NType NEImageTypeNativeType;


NBiometricTypes.NEPositionNativeType Property

NBiometricTypes.NEPositionNativeType Property
NBiometricTypes Class Neurotec.Biometrics Namespace

Defines the native type of the iris position.

C#
public static NType NEPositionNativeType;


NBiometricTypes.NFImpressionTypeNativeType Property

NBiometricTypes.NFImpressionTypeNativeType Property
NBiometricTypes Class Neurotec.Biometrics Namespace

Defines the native type of the finger impression type.

C#
public static NType NFImpressionTypeNativeType;


NBiometricTypes.NFMinutiaFormatNativeType Property

NBiometricTypes.NFMinutiaFormatNativeType Property
NBiometricTypes Class Neurotec.Biometrics Namespace

Defines the native type of the fingerprint minutia format.

C#
public static NType NFMinutiaFormatNativeType;


NBiometricTypes.NFMinutiaTypeNativeType Property

NBiometricTypes.NFMinutiaTypeNativeType Property
NBiometricTypes Class Neurotec.Biometrics Namespace

Defines the native type of the fingerprint minutia type.

C#
public static NType NFMinutiaTypeNativeType;


NBiometricTypes.NFPatternClassNativeType Property

NBiometricTypes.NFPatternClassNativeType Property
NBiometricTypes Class Neurotec.Biometrics Namespace

Defines the native type of the pattern class.

C#
public static NType NFPatternClassNativeType;


NBiometricTypes.NFPositionNativeType Property

NBiometricTypes.NFPositionNativeType Property
NBiometricTypes Class Neurotec.Biometrics Namespace

Defines the native type of the finger position.

C#
public static NType NFPositionNativeType;


NBiometricTypes.NFRidgeCountsTypeNativeType Property

NBiometricTypes.NFRidgeCountsTypeNativeType Property
NBiometricTypes Class Neurotec.Biometrics Namespace

Defines the native type of the fingerprint ridge count.

C#
public static NType NFRidgeCountsTypeNativeType;


NBiometricTypes.NGenderNativeType Property

NBiometricTypes.NGenderNativeType Property
NBiometricTypes Class Neurotec.Biometrics Namespace

Defines the native type of the gender.

C#
public static NType NGenderNativeType;


NBiometricTypes.NIcaoWarningsNativeType Property

NBiometricTypes.NIcaoWarningsNativeType Property
NBiometricTypes Class Neurotec.Biometrics Namespace

Defines the native type of the icao warnings.

C#
public static NType NIcaoWarningsNativeType;


NBiometricTypes.NLExpressionNativeType Property

NBiometricTypes.NLExpressionNativeType Property
NBiometricTypes Class Neurotec.Biometrics Namespace

Defines the native type of the face expression.

C#
public static NType NLExpressionNativeType;


NBiometricTypes.NLPropertiesNativeType Property

NBiometricTypes.NLPropertiesNativeType Property
NBiometricTypes Class Neurotec.Biometrics Namespace

Defines the native type of the face properties.

C#
public static NType NLPropertiesNativeType;


NBiometricTypes.NLivenessActionNativeType Property

NBiometricTypes.NLivenessActionNativeType Property
NBiometricTypes Class Neurotec.Biometrics Namespace

Defines the native type of the liveness action.

C#
public static NType NLivenessActionNativeType;


NBiometricTypes.NLivenessModeNativeType Property

NBiometricTypes.NLivenessModeNativeType Property
NBiometricTypes Class Neurotec.Biometrics Namespace

Defines the native type of the liveness mode.

C#
public static NType NLivenessModeNativeType;


NBiometricTypes.NTemplateSizeNativeType Property

NBiometricTypes.NTemplateSizeNativeType Property
NBiometricTypes Class Neurotec.Biometrics Namespace

Defines the native type of the template size.

C#
public static NType NTemplateSizeNativeType;


NBiometricTypes.NativeType Property

NBiometricTypes.NativeType Property
NBiometricTypes Class Neurotec.Biometrics Namespace

Defines the native type of the object.

C#
public static NType NativeType;


NBiometricTypes.NfiqQualityNativeType Property

NBiometricTypes.NfiqQualityNativeType Property
NBiometricTypes Class Neurotec.Biometrics Namespace

Defines the native type of the fingerprint image quality.

C#
public static NType NfiqQualityNativeType;


NBiometrics Class

NBiometrics Class
NBiometrics Fields Legend Members NBiometrics Properties

Provides methods for retrieving NBiometrics Library information.

C#
public static class NBiometrics;
Collapse Expand NBiometrics Fields
Name | Description
DllName | Name of DLL containing unmanaged part of this class.
Collapse Expand NBiometrics Properties
Name | Description
NativeModule | Gets or sets a pointer to the function that retrieves NModule object for the specified module name.
Container

File: NBiometrics.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


NBiometrics.DllName Field

NBiometrics.DllName Field
NBiometrics Class Neurotec.Biometrics Namespace

Name of DLL containing unmanaged part of this class.

C#
public const string DllName = NVersionInfo.BiometricsDllName;


NBiometrics.NativeModule Property

NBiometrics.NativeModule Property
NBiometrics Class Neurotec.Biometrics Namespace

Gets or sets a pointer to the function that retrieves NModule object for the specified module name.

C#
public static NModule NativeModule;
Property value

A pointer to the function that retrieves NModule object for the specified module name.


NFCore Structure

NFCore Structure
Legend Members Methods NFCore Methods NFCore Properties

The structure contains information of core.

C#
[Serializable]
[StructLayout(LayoutKind.Sequential)]
public struct NFCore : IFormattable {
}
Collapse Expand NFCore Methods
Name | Description
ToString | Retrieves string representation of the specified object.
Collapse Expand NFCore Properties
Name | Description
Angle | Gets or sets Angle of core.
AngleDeg | Gets or sets angle in degrees.
NativeType | Defines the native type of the object.
RawAngle | Gets or sets raw angle of core
X | Gets or sets x coordinate of core.
Y | Gets or sets y coordinate of core.
Container

File: NBiometricTypes.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


NFCore.NFCore Constructor (ushort, ushort)

NFCore.NFCore Constructor (ushort, ushort)
NFCore Structure Neurotec.Biometrics Namespace

Initializes a new instance of the NFCore structure.

C#
public NFCore(ushort x, ushort y);
Collapse Expand Parameters
Parameters | Description
ushort x | The x - coordinate of the core.
ushort y | The y - coordinate of the core.


NFCore.NFCore Constructor (ushort, ushort, double)

NFCore.NFCore Constructor (ushort, ushort, double)
NFCore Structure Neurotec.Biometrics Namespace

Initializes a new instance of the NFCore class.

C#
public NFCore(ushort x, ushort y, double angle);
Collapse Expand Parameters
Parameters | Description
ushort x | The x - coordinate of the core.
ushort y | The y - coordinate of the core.
double angle | The angle of the core.


NFCore.NFCore Constructor (ushort, ushort, int)

NFCore.NFCore Constructor (ushort, ushort, int)
NFCore Structure Neurotec.Biometrics Namespace

Initializes a new instance of the NFCore class.

C#
public NFCore(ushort x, ushort y, int angle);
Collapse Expand Parameters
Parameters | Description
ushort x | The x - coordinate of the core.
ushort y | The y - coordinate of the core.
int angle | The angle of the core.


NFCore.ToString Method ()

NFCore.ToString Method ()
NFCore Structure Neurotec.Biometrics Namespace

Retrieves string representation of the specified object.

C#
public override string ToString();
Collapse Expand Returns

String representation of an object.


NFCore.ToString Method (string)

NFCore.ToString Method (string)
NFCore Structure Neurotec.Biometrics Namespace

Retrieves string representation of the specified object.

C#
public string ToString(string format);
Collapse Expand Parameters
Parameters | Description
string format | Reserved for future use.
Collapse Expand Returns

No tables or formatting elements here!!!


NFCore.Angle Property

NFCore.Angle Property
NFCore Structure Neurotec.Biometrics Namespace

Gets or sets Angle of core.

C#
public double Angle;
Property value

The angle of the core.


NFCore.AngleDeg Property

NFCore.AngleDeg Property
NFCore Structure Neurotec.Biometrics Namespace

Gets or sets angle in degrees.

C#
public float AngleDeg;
Property value

Float value of angles degrees.


NFCore.NativeType Property

NFCore.NativeType Property
NFCore Structure Neurotec.Biometrics Namespace

Defines the native type of the object.

C#
public static NType NativeType;


NFCore.RawAngle Property

NFCore.RawAngle Property
NFCore Structure Neurotec.Biometrics Namespace

Gets or sets raw angle of core

C#
public int RawAngle;
Property value

The raw angle of the core.

Collapse Expand Remarks

The angle of the core is specified in 180/128 degrees units in counterclockwise order and cannot be less than zero or greater than 256 minus one. The value of -1 can be specified if the angle of the core is unknown.


NFCore.X Property

NFCore.X Property
NFCore Structure Neurotec.Biometrics Namespace

Gets or sets x coordinate of core.

C#
public ushort X;
Property value

The x coordinate of the core.

Collapse Expand Remarks

The x coordinate of the core is specified in pixels at resolution and "X * [NFRecord horizontal resolution] / Resolution" cannot be greater than MaxDimension or NFRecord width minus one.


NFCore.Y Property

NFCore.Y Property
NFCore Structure Neurotec.Biometrics Namespace

Gets or sets y coordinate of core.

C#
public ushort Y;
Property value

The y coordinate of the core.

Collapse Expand Remarks

The y coordinate of the core is specified in pixels at resolution and "Y * [NFRecord vertical resolution] / Resolution" cannot be greater than MaxDimension or NFRecord width minus one.


NFDelta Structure

NFDelta Structure
Legend Members Methods NFDelta Methods NFDelta Properties

The structure contains information of delta.

C#
[Serializable]
[StructLayout(LayoutKind.Sequential)]
public struct NFDelta : IFormattable {
}
Collapse Expand NFDelta Methods
Name | Description
ToString | Returns a string that represents the current NFDelta object.
Collapse Expand NFDelta Properties
Name | Description
Angle1 | Gets or sets the first angle of delta.
Angle2 | Gets or sets the second angle of delta.
Angle3 | Gets or sets the third angle of delta.
AngleDeg1 | Gets or sets the first angle of delta in degrees.
AngleDeg2 | Gets or sets the second angle of delta in degrees.
AngleDeg3 | Gets or sets the third angle of delta in degrees.
NativeType | Defines the native type of the object.
RawAngle1 | Gets or sets the first row angle of the delta.
RawAngle2 | Gets or sets the second row angle of the delta.
RawAngle3 | Gets or sets the third row angle of the delta.
X | Gets or sets x coordinate of delta.
Y | Gets or sets y coordinate of delta.
Container

File: NBiometricTypes.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


NFDelta.NFDelta Constructor (ushort, ushort)

NFDelta.NFDelta Constructor (ushort, ushort)
NFDelta Structure Neurotec.Biometrics Namespace

Initializes a new instance of the NFDelta structure.

C#
public NFDelta(ushort x, ushort y);
Collapse Expand Parameters
Parameters | Description
ushort x | The x - coordinate of the delta.
ushort y | The y - coordinate of the delta.


NFDelta.NFDelta Constructor (ushort, ushort, double, double, double)

NFDelta.NFDelta Constructor (ushort, ushort, double, double, double)
NFDelta Structure Neurotec.Biometrics Namespace

Initializes a new instance of the NFDelta structure.

C#
public NFDelta(ushort x, ushort y, double angle1, double angle2, double angle3);
Collapse Expand Parameters
Parameters | Description
ushort x | The x - coordinate of the delta.
ushort y | The y - coordinate of the delta.
double angle1 | The first angle of the delta.
double angle2 | The second angle of the delta.
double angle3 | The third angle of the delta.


NFDelta.NFDelta Constructor (ushort, ushort, int, int, int)

NFDelta.NFDelta Constructor (ushort, ushort, int, int, int)
NFDelta Structure Neurotec.Biometrics Namespace

Initializes a new instance of the NFDelta structure.

C#
public NFDelta(ushort x, ushort y, int angle1, int angle2, int angle3);
Collapse Expand Parameters
Parameters | Description
ushort x | The x - coordinate of the delta.
ushort y | The y - coordinate of the delta.
int angle1 | The first angle of the delta.
int angle2 | The second angle of the delta.
int angle3 | The third angle of the delta.


NFDelta.ToString Method ()

NFDelta.ToString Method ()
NFDelta Structure Neurotec.Biometrics Namespace

Returns a string that represents the current NFDelta object.

C#
public override string ToString();
Collapse Expand Returns

String that represents NFDelta object.


NFDelta.ToString Method (string)

NFDelta.ToString Method (string)
NFDelta Structure Neurotec.Biometrics Namespace

Returns a string that represents the current NFDelta object.

C#
public string ToString(string format);
Collapse Expand Parameters
Parameters | Description
string format | Reserved for future use..
Collapse Expand Returns

String that represents NFDelta object.


NFDelta.Angle1 Property

NFDelta.Angle1 Property
NFDelta Structure Neurotec.Biometrics Namespace

Gets or sets the first angle of delta.

C#
public double Angle1;
Property value

The first angle of the delta.

Collapse Expand Remarks

The angle of the delta is specified in 180/128 degrees units in counterclockwise order and cannot be less than zero or greater than 256 minus one. The value of -1 can be specified if the first angle of the delta is unknown.


NFDelta.Angle2 Property

NFDelta.Angle2 Property
NFDelta Structure Neurotec.Biometrics Namespace

Gets or sets the second angle of delta.

C#
public double Angle2;
Property value

The second angle of the delta.

Collapse Expand Remarks

The angle of the delta is specified in 180/128 degrees units in counterclockwise order and cannot be less than zero or greater than 256 minus one. The value of -1 can be specified if the first angle of the delta is unknown.


NFDelta.Angle3 Property

NFDelta.Angle3 Property
NFDelta Structure Neurotec.Biometrics Namespace

Gets or sets the third angle of delta.

C#
public double Angle3;
Property value

The third angle of the delta.

Collapse Expand Remarks

The angle of the delta is specified in 180/128 degrees units in counterclockwise order and cannot be less than zero or greater than 256 minus one. The value of -1 can be specified if the first angle of the delta is unknown.


NFDelta.AngleDeg1 Property

NFDelta.AngleDeg1 Property
NFDelta Structure Neurotec.Biometrics Namespace

Gets or sets the first angle of delta in degrees.

C#
public float AngleDeg1;
Property value

The first angle of the delta in degrees.


NFDelta.AngleDeg2 Property

NFDelta.AngleDeg2 Property
NFDelta Structure Neurotec.Biometrics Namespace

Gets or sets the second angle of delta in degrees.

C#
public float AngleDeg2;
Property value

The second angle of the delta in degrees.


NFDelta.AngleDeg3 Property

NFDelta.AngleDeg3 Property
NFDelta Structure Neurotec.Biometrics Namespace

Gets or sets the third angle of delta in degrees.

C#
public float AngleDeg3;
Property value

The third angle of the delta in degrees.


NFDelta.NativeType Property

NFDelta.NativeType Property
NFDelta Structure Neurotec.Biometrics Namespace

Defines the native type of the object.

C#
public static NType NativeType;


NFDelta.RawAngle1 Property

NFDelta.RawAngle1 Property
NFDelta Structure Neurotec.Biometrics Namespace

Gets or sets the first row angle of the delta.

C#
public int RawAngle1;
Property value

The first raw angle of the delta.


NFDelta.RawAngle2 Property

NFDelta.RawAngle2 Property
NFDelta Structure Neurotec.Biometrics Namespace

Gets or sets the second row angle of the delta.

C#
public int RawAngle2;
Property value

The second raw angle of the delta.


NFDelta.RawAngle3 Property

NFDelta.RawAngle3 Property
NFDelta Structure Neurotec.Biometrics Namespace

Gets or sets the third row angle of the delta.

C#
public int RawAngle3;
Property value

The third raw angle fog the delta.


NFDelta.X Property

NFDelta.X Property
NFDelta Structure Neurotec.Biometrics Namespace

Gets or sets x coordinate of delta.

C#
public ushort X;
Property value

The x coordinate of the delta.

Collapse Expand Remarks

The x coordinate of the delta is specified in pixels at resolution and "X * [NFRecord horizontal resolution] / Resolution" cannot be greater than MaxDimension or NFRecord width minus one.


NFDelta.Y Property

NFDelta.Y Property
NFDelta Structure Neurotec.Biometrics Namespace

Gets or sets y coordinate of delta.

C#
public ushort Y;
Property value

The x coordinate of the delta.

Collapse Expand Remarks

The y coordinate of the delta is specified in pixels at resolution and "Y * [NFRecord vertical resolution] / Resolution" cannot be greater than MaxDimension or NFRecord width minus one.


NFDoubleCore Structure

NFDoubleCore Structure
Legend Members Methods NFDoubleCore Methods NFDoubleCore Properties

The structure contains information of double core.

C#
[Serializable]
[StructLayout(LayoutKind.Sequential)]
public struct NFDoubleCore : IFormattable {
}
Collapse Expand NFDoubleCore Methods
Name | Description
ToString | Returns a string that represents the current NFDoubleCore object.
Collapse Expand NFDoubleCore Properties
Name | Description
NativeType | Defines the native type of the object.
X | Gets or sets x coordinate of the double core.
Y | Gets or sets y coordinate of the double core.
Container

File: NBiometricTypes.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


NFDoubleCore.NFDoubleCore Constructor

NFDoubleCore.NFDoubleCore Constructor
NFDoubleCore Structure Neurotec.Biometrics Namespace

Initializes a new instance of the NFDoubleCore class.

C#
public NFDoubleCore(ushort x, ushort y);
Collapse Expand Parameters
Parameters | Description
ushort x | The x coordinate of the double core.
ushort y | The y coordinate of the double core.


NFDoubleCore.ToString Method ()

NFDoubleCore.ToString Method ()
NFDoubleCore Structure Neurotec.Biometrics Namespace

Returns a string that represents the current NFDoubleCore object.

C#
public override string ToString();
Collapse Expand Returns

String that represents NFDoubleCore object.


NFDoubleCore.ToString Method (string)

NFDoubleCore.ToString Method (string)
NFDoubleCore Structure Neurotec.Biometrics Namespace

Returns a string that represents the current NFDoubleCore object.

C#
public string ToString(string format);
Collapse Expand Parameters
Parameters | Description
string format | Reserved for future use.
Collapse Expand Returns

String that represents NFDoubleCore object.


NFDoubleCore.NativeType Property

NFDoubleCore.NativeType Property
NFDoubleCore Structure Neurotec.Biometrics Namespace

Defines the native type of the object.

C#
public static NType NativeType;


NFDoubleCore.X Property

NFDoubleCore.X Property
NFDoubleCore Structure Neurotec.Biometrics Namespace

Gets or sets x coordinate of the double core.

C#
public ushort X;
Property value

The X coordinate of the double core.


NFDoubleCore.Y Property

NFDoubleCore.Y Property
NFDoubleCore Structure Neurotec.Biometrics Namespace

Gets or sets y coordinate of the double core.

C#
public ushort Y;
Property value

The Y coordinate of the double core.


NFMinutia Structure

NFMinutia Structure
Legend Members Methods NFMinutia Methods NFMinutia Properties

The structure contains information of minutia.

C#
[Serializable]
[StructLayout(LayoutKind.Sequential)]
public struct NFMinutia : IFormattable {
}
Collapse Expand NFMinutia Methods
Name | Description
ToString | Returns a string that represents the current NFMinutia object.
Collapse Expand NFMinutia Properties
Name | Description
Angle | Gets or sets the angle of the minutia.
AngleDeg | Gets or sets the angle in degrees of the minutia.
Curvature | Gets or sets the ridge curvature near minutia.
G | Gets or sets the G (ridge density) near minutia.
NativeType | Defines the native type of the object.
Quality | Gets or sets quality of the minutia.
RawAngle | Gets or sets the raw angle of the minutia.
Type | Gets or sets the type of the minutia.
X | Gets or sets x coordinate of the minutia.
Y | Gets or sets y coordinate of the minutia.
Container

File: NBiometricTypes.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


NFMinutia.NFMinutia Constructor (ushort, ushort, NFMinutiaType, byte)

NFMinutia.NFMinutia Constructor (ushort, ushort, NFMinutiaType, byte)
NFMinutia Structure Neurotec.Biometrics Namespace

Initializes a new instance of the NFMinutia class.

C#
public NFMinutia(ushort x, ushort y, NFMinutiaType type, byte angle);
Collapse Expand Parameters
Parameters | Description
ushort x | The x coordinate of the minutia.
ushort y | The y coordinate of the minutia.
NFMinutiaType type | One of the NFMinutiaType values.
byte angle | The angle of the minutia.


NFMinutia.NFMinutia Constructor (ushort, ushort, NFMinutiaType, byte, byte, byte, byte)

NFMinutia.NFMinutia Constructor (ushort, ushort, NFMinutiaType, byte, byte, byte, byte)
NFMinutia Structure Neurotec.Biometrics Namespace

Initializes a new instance of the NFMinutia class.

C#
public NFMinutia(ushort x, ushort y, NFMinutiaType type, byte angle, byte quality, byte curvature, byte g);
Collapse Expand Parameters
Parameters | Description
ushort x | The x - coordinate of the minutia.
ushort y | The y - coordinate of the minutia.
NFMinutiaType type | One of the NFMinutiaType values.
byte angle | The angle of the minutia.
byte quality | The quality of the minutia.
byte curvature | The ridge curvature near minutia.
byte g | The G (ridge density) near minutia.


NFMinutia.NFMinutia Constructor (ushort, ushort, NFMinutiaType, double)

NFMinutia.NFMinutia Constructor (ushort, ushort, NFMinutiaType, double)
NFMinutia Structure Neurotec.Biometrics Namespace

Initializes a new instance of the NFMinutia class.

C#
public NFMinutia(ushort x, ushort y, NFMinutiaType type, double angle);
Collapse Expand Parameters
Parameters | Description
ushort x | The x - coordinate of the minutia.
ushort y | The y - coordinate of the minutia.
NFMinutiaType type | One of the NFMinutiaType values.
double angle | The angle of the minutia.


NFMinutia.NFMinutia Constructor (ushort, ushort, NFMinutiaType, double, byte, byte, byte)

NFMinutia.NFMinutia Constructor (ushort, ushort, NFMinutiaType, double, byte, byte, byte)
NFMinutia Structure Neurotec.Biometrics Namespace

Initializes a new instance of the NFMinutia class.

C#
public NFMinutia(ushort x, ushort y, NFMinutiaType type, double angle, byte quality, byte curvature, byte g);
Collapse Expand Parameters
Parameters | Description
ushort x | The x - coordinate of the minutia.
ushort y | The y - coordinate of the minutia.
NFMinutiaType type | One of the NFMinutiaType values.
double angle | The angle of the minutia.
byte quality | The quality of the minutia.
byte curvature | The ridge curvature near minutia.
byte g | The G (ridge density) near minutia.


NFMinutia.ToString Method ()

NFMinutia.ToString Method ()
NFMinutia Structure Neurotec.Biometrics Namespace

Returns a string that represents the current NFMinutia object.

C#
public override string ToString();
Collapse Expand Returns

String representation of NFMinutia object.


NFMinutia.ToString Method (string)

NFMinutia.ToString Method (string)
NFMinutia Structure Neurotec.Biometrics Namespace

Returns a string that represents the current NFMinutia object.

C#
public string ToString(string format);
Collapse Expand Parameters
Parameters | Description
string format | String format.
Collapse Expand Returns

String representation of NFMinutia object.


NFMinutia.Angle Property

NFMinutia.Angle Property
NFMinutia Structure Neurotec.Biometrics Namespace

Gets or sets the angle of the minutia.

C#
public double Angle;
Property value

The angle of the minutia.

Collapse Expand Remarks

The angle of the minutia is specified in 180/128 degrees units in counterclockwise order and cannot be greater than 256 minus one.


NFMinutia.AngleDeg Property

NFMinutia.AngleDeg Property
NFMinutia Structure Neurotec.Biometrics Namespace

Gets or sets the angle in degrees of the minutia.

C#
public float AngleDeg;
Property value

The angle in degrees of the minutia.


NFMinutia.Curvature Property

NFMinutia.Curvature Property
NFMinutia Structure Neurotec.Biometrics Namespace

Gets or sets the ridge curvature near minutia.

C#
public byte Curvature;
Property value

The ridge curvature near minutia.

Collapse Expand Remarks

If curvature of the minutia is unknown it must be set to 255.


NFMinutia.G Property

NFMinutia.G Property
NFMinutia Structure Neurotec.Biometrics Namespace

Gets or sets the G (ridge density) near minutia.

C#
public byte G;
Property value

The G (ridge density) near minutia.

Collapse Expand Remarks

If G of the minutia is unknown it must be set to 255.


NFMinutia.NativeType Property

NFMinutia.NativeType Property
NFMinutia Structure Neurotec.Biometrics Namespace

Defines the native type of the object.

C#
public static NType NativeType;


NFMinutia.Quality Property

NFMinutia.Quality Property
NFMinutia Structure Neurotec.Biometrics Namespace

Gets or sets quality of the minutia.

C#
public byte Quality;
Property value

The quality of the minutia.

Collapse Expand Remarks

The quality of the minutia must be in the range [0, 100].The higher it is, the better the quality of the minutia is. If quality of the minutia is unknown it must be set to zero.


NFMinutia.RawAngle Property

NFMinutia.RawAngle Property
NFMinutia Structure Neurotec.Biometrics Namespace

Gets or sets the raw angle of the minutia.

C#
public byte RawAngle;
Property value

The raw angle of the minutia.


NFMinutia.Type Property

NFMinutia.Type Property
NFMinutia Structure Neurotec.Biometrics Namespace

Gets or sets the type of the minutia.

C#
public NFMinutiaType Type;
Property value

One of the NFMinutiaType values.


NFMinutia.X Property

NFMinutia.X Property
NFMinutia Structure Neurotec.Biometrics Namespace

Gets or sets x coordinate of the minutia.

C#
public ushort X;
Property value

The X coordinate of the minutia.

Collapse Expand Remarks

The x coordinate of the minutia is specified in pixels at resolution and "X * [NFRecord horizontal resolution] / Resolution" cannot be greater than MaxDimension or NFRecord width minus one.


NFMinutia.Y Property

NFMinutia.Y Property
NFMinutia Structure Neurotec.Biometrics Namespace

Gets or sets y coordinate of the minutia.

C#
public ushort Y;
Property value

The Y coordinate of the minutia.

Collapse Expand Remarks

The y coordinate of the minutia is specified in pixels at resolution and "Y * [NFRecord vertical resolution] / Resolution" cannot be greater than MaxDimension or NFRecord width minus one.


NFMinutiaNeighbor Structure

NFMinutiaNeighbor Structure
NFMinutiaNeighbor Fields Legend Members Methods NFMinutiaNeighbor Methods NFMinutiaNeighbor Properties

The structure contains information of minutia neighbor.

C#
[Serializable]
[StructLayout(LayoutKind.Sequential)]
public struct NFMinutiaNeighbor : IFormattable {
  public static readonly NFMinutiaNeighbor Empty = new NFMinutiaNeighbor(-1, 255);
}
Collapse Expand NFMinutiaNeighbor Fields
Name | Description
Empty | Represents a NFMinutiaNeighbor that is a null reference.
Collapse Expand NFMinutiaNeighbor Methods
Name | Description
ToString | Returns a string that represents the current NFMinutiaNeighbor object.
Collapse Expand NFMinutiaNeighbor Properties
Name | Description
Index | Gets or sets the index of minutia neighbor.
NativeType | Defines the native type of the object.
RidgeCount | Gets or sets the ridge count between the minutia and minutia neighbor.
Container

File: NBiometricTypes.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


NFMinutiaNeighbor.NFMinutiaNeighbor Constructor

NFMinutiaNeighbor.NFMinutiaNeighbor Constructor
NFMinutiaNeighbor Structure Neurotec.Biometrics Namespace

Initializes a new instance of the NFMinutiaNeighbor class.

C#
public NFMinutiaNeighbor(int index, byte ridgeCount);
Collapse Expand Parameters
Parameters | Description
int index | The index of neighbor.
byte ridgeCount | The ridge count of neighbor.


NFMinutiaNeighbor.Empty Field

NFMinutiaNeighbor.Empty Field
NFMinutiaNeighbor Structure Neurotec.Biometrics Namespace

Represents a NFMinutiaNeighbor that is a null reference.

C#
public static readonly NFMinutiaNeighbor Empty = new NFMinutiaNeighbor(-1, 255);


NFMinutiaNeighbor.ToString Method ()

NFMinutiaNeighbor.ToString Method ()
NFMinutiaNeighbor Structure Neurotec.Biometrics Namespace

Returns a string that represents the current NFMinutiaNeighbor object.

C#
public override string ToString();
Collapse Expand Returns

String representation of NFMinutiaNeighbor object.


NFMinutiaNeighbor.ToString Method (string)

NFMinutiaNeighbor.ToString Method (string)
NFMinutiaNeighbor Structure Neurotec.Biometrics Namespace

Returns a string that represents the current NFMinutiaNeighbor object.

C#
public string ToString(string format);
Collapse Expand Parameters
Parameters | Description
string format | String format.
Collapse Expand Returns

String representation of NFMinutiaNeighbor object.


NFMinutiaNeighbor.Index Property

NFMinutiaNeighbor.Index Property
NFMinutiaNeighbor Structure Neurotec.Biometrics Namespace

Gets or sets the index of minutia neighbor.

C#
public int Index;
Property value

The index of minutia neighbor.


NFMinutiaNeighbor.NativeType Property

NFMinutiaNeighbor.NativeType Property
NFMinutiaNeighbor Structure Neurotec.Biometrics Namespace

Defines the native type of the object.

C#
public static NType NativeType;


NFMinutiaNeighbor.RidgeCount Property

NFMinutiaNeighbor.RidgeCount Property
NFMinutiaNeighbor Structure Neurotec.Biometrics Namespace

Gets or sets the ridge count between the minutia and minutia neighbor.

C#
public byte RidgeCount;
Property value

The ridge count between the minutia and minutia neighbor.


NFace Class

NFace Class
NFace Classes NObject Delegates NObject Events NObject Fields Legend Members Methods NDisposable Methods NDisposable Properties

Provides methods for biometric engine to deal with face templates.

C#
public sealed class NFace : NBiometric;
Collapse Expand NFace Classes
NFace Class
Name | Description
ObjectCollection | Collection of NLAttributes objects.
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NBiometric Class
Show:
No members matching the current filter
Name | Description
IsBiometricCaptureOptionsValid | Checks whether the specified biometric capture options are valid.
NFace Class
Name | Description
FromImageAndAttributes | Creates NFace object from specified face image and attributes.
GetImage | Retrieves the face image of the specified NFace object.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NBiometric Class
Show:
No members matching the current filter
Name | Description
BiometricType | Gets the biometric type.
CaptureOptions | Gets or sets the biometric capture options.
Error | Gets the last exception.
FileName | Gets or sets the file name.
HasMoreSamples | Gets or sets whether the NBioemtric object has more samples.
NBiometricCaptureOptionsNativeType | Defines the native type of the capture options.
NativeType | Defines the native type of the object.
Owner | Gets owner of the object.
ParentObject | Gets the parent object.
SampleBuffer | Gets or sets sample buffer. Use similar to FileName property, but this is more efficient if file contents are already loaded to memory.
SessionId | Gets or sets the session ID.
Status | Gets or sets the biometric status.
NFace Class
Name | Description
Image | Gets or sets the face image of the NFace object.
NativeType | Defines the native type of the object.
Objects | Retrieves the collection of NLAttributes of the NFace object.
Container

File: NFace.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


NFace.NFace Constructor

NFace.NFace Constructor
NFace Class Neurotec.Biometrics Namespace

Creates a new NFace object.

C#
public NFace();


NFace.ObjectCollection Class

NFace.ObjectCollection Class

Collection of NLAttributes objects.

C#
public sealed class ObjectCollection : NObjectReadOnlyCollection<NLAttributes>;
Container

File: NFace.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


NFace.FromImageAndAttributes Method

NFace.FromImageAndAttributes Method
NFace Class Neurotec.Biometrics Namespace

Creates NFace object from specified face image and attributes.

C#
public static NFace FromImageAndAttributes(NImage image, NLAttributes attributes);
Collapse Expand Parameters
Parameters | Description
NImage image | Face image.
NLAttributes attributes | Face attributes.
Collapse Expand Returns

NFace object.


NFace.GetImage Method

NFace.GetImage Method
NFace Class Neurotec.Biometrics Namespace

Retrieves the face image of the specified NFace object.

C#
public NImage GetImage(bool cache);
Collapse Expand Parameters
Parameters | Description
bool cache | If true, the same native object will be assigned the same .NET object.
Collapse Expand Returns

Face image.


NFace.Image Property

NFace.Image Property
NFace Class Neurotec.Biometrics Namespace

Gets or sets the face image of the NFace object.

C#
public NImage Image;


NFace.NativeType Property

NFace.NativeType Property
NFace Class Neurotec.Biometrics Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NFace.Objects Property

NFace.Objects Property
NFace Class Neurotec.Biometrics Namespace

Retrieves the collection of NLAttributes of the NFace object.

C#
public ObjectCollection Objects;


NLAttributes Class

NLAttributes Class
NLAttributes Classes NObject Delegates NObject Events NObject Fields Legend Members Methods NDisposable Methods NDisposable Properties

Provides methods to retrieve face template attributes.

C#
public sealed class NLAttributes : NBiometricAttributes;
Collapse Expand NLAttributes Classes
NLAttributes Class
Name | Description
FeaturePointCollection | Collection of feature points.
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NBiometricAttributes Class
Show:
No members matching the current filter
Name | Description
BiometricType | Gets the biometric type.
Child | Gets child NBiometric object of the current NBiometricAttributes.
ChildSubject | Gets child NSubject of the current NBiometricAttributes.
DetectionConfidence | Gets or sets the detection confidence.
LivenessConfidence | Gets or sets presentation attack detection confidence value.
NativeType | Defines the native type of the object.
Quality | Gets or sets the quality.
Status | Gets or sets the biometric status.
NLAttributes Class
Name | Description
AdditionalFacesDetected | Gets or sets if any additioanl faces were detected.
Age | Gets or sets age value.
BackgroundUniformity | Gets or sets the image background uniformity value.
BaseFrameIndex | Gets or sets base frame index value.
BeardConfidence | Gets or sets the beard confidence value.
BlinkConfidence | Gets or sets the blink confidence value.
BoundingRect | Gets or sets the bounding rectangle that completely encloses face.
Contrast | Gets or sets the contrast value.
DarkGlassesConfidence | Gets or sets the dark glasses confidence value.
EmotionAngerConfidence | Gets or sets anger confidence value.
EmotionContemptConfidence | Gets or sets anger confidence value.
EmotionDisgustConfidence | Gets or sets disgust confidence value.
EmotionFearConfidence | Gets or sets fear confidence value.
EmotionHappinessConfidence | Gets or sets happiness confidence value.
EmotionNeutralConfidence | Gets or sets the neutral emotion confidence value.
EmotionSadnessConfidence | Gets or sets sadness confidence value.
EmotionSurpriseConfidence | Gets or sets surprise confidence value.
EthnicityArabianConfidence | Gets or sets ethnicity Arabian confidence value.
EthnicityAsianConfidence | Gets or sets ethnicity Asian confidence value.
EthnicityBlackConfidence | Gets or sets ethnicity Black confidence value.
EthnicityHispanicConfidence | Gets or sets ethnicity Hispanic confidence value.
EthnicityIndianConfidence | Gets or sets ethnicity Indian confidence value.
EthnicityWhiteConfidence | Gets or sets ethnicity White confidence value.
Expression | Gets or sets the expression value.
ExpressionConfidence | Gets or sets the expression confidence value.
FaceDarknessConfidence | Gets the face darkness confidence value.
FaceMaskConfidence | Gets or sets the face mask confidence value.
FeaturePoints | Retrieves the feature point collection.
Gender | Gets or set the gender value.
GenderConfidence | Gets the gender confidence value. Setter is deprecated.
GlassesConfidence | Gets or sets the glasses confidence value.
GlassesReflectionConfidence | Gets the glasses reflection confidence value.
GrayscaleDensity | Gets or sets the image grayscale density value.
HatConfidence | Gets or sets the hat confidence value.
HeavyFrameConfidence | Gets or sets the heavy frame confidence value.
IcaoWarnings | Gets or sets one of NIcaoWarnings values.
LeftEyeCenter | Gets or sets the center of the left eye.
LivenessAction | Gets or sets face liveness action value.
LivenessScore | Gets or sets face liveness score value.
LivenessTargetPitch | Gets liveness detection pitch angle.
LivenessTargetYaw | Gets or sets liveness detection yaw rotation angle.
LookingAwayConfidence | Gets the eye look confidence value.
MocTemplate | Gets Match-on-Card face template, if engine was configured to extract it.
MouthCenter | Gets or sets the center of the mouth.
MouthOpenConfidence | Gets or sets the mouth open confidence value.
MustacheConfidence | Gets or sets the mustache confidence value.
NativeType | Defines the native type of the object.
Noise | Gets or sets the noise value.
NoseTip | Gets or sets the tip of the nose.
Owner | Gets the owner object.
Pitch | Gets or sets the image pitch value in degrees. The calculation of this value is not implemented.
PixelationConfidence | Gets the pixelation confidence value.
Properties | Gets or sets NLAttributes properties.
RedEyeConfidence | Gets the red eye confidence value.
RightEyeCenter | Gets or sets the center of the right eye.
Roll | Gets or sets the image roll value in degrees. Positive angles represent faces tilted toward their left shoulder (a clockwise rotation around the z-axis).
Saturation | Gets or sets the saturation value.
Sharpness | Gets or sets the image sharpness value.
SkinReflectionConfidence | Gets the skin reflection confidence value.
Template | Gets a face template contained in a NLTemplate object.
Thumbnail | Gets or sets the thumbnail image.
TokenImageRect | Gets or sets face token image rectangle.
UnnaturalSkinToneConfidence | Gets the skin tone confidence value.
WashedOutConfidence | Gets the washed out confidence value.
Yaw | Gets or sets the image yaw value in degrees. Positive angles represent faces looking to their right (a clockwise rotation around the y-axis).
Container

File: NLAttributes.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


NLAttributes.NLAttributes Constructor

NLAttributes.NLAttributes Constructor
NLAttributes Class Neurotec.Biometrics Namespace

Initializes a new instance of NLAttributes class.

C#
public NLAttributes();


NLAttributes.FeaturePointCollection Class

NLAttributes.FeaturePointCollection Class

Collection of feature points.

C#
public sealed class FeaturePointCollection : StructCollection<NLFeaturePoint>;
Container

File: NLAttributes.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


NLAttributes.AdditionalFacesDetected Property

NLAttributes.AdditionalFacesDetected Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets if any additioanl faces were detected.

C#
[Obsolete("Use GetAttributeValue(NBiometricAttributeId.AdditionalFacesDetected) instead.")]
public bool AdditionalFacesDetected;
Property value

True if additional face was found.


NLAttributes.Age Property

NLAttributes.Age Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets age value.

C#
[Obsolete("Use GetAttributeValue(NBiometricAttributeId.Age) instead.")]
public byte Age;


NLAttributes.BackgroundUniformity Property

NLAttributes.BackgroundUniformity Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets the image background uniformity value.

C#
[Obsolete("Use GetAttributeValue(NBiometricAttributeId.BackgroundUniformity) instead.")]
public byte BackgroundUniformity;


NLAttributes.BaseFrameIndex Property

NLAttributes.BaseFrameIndex Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets base frame index value.

C#
public int BaseFrameIndex;


NLAttributes.BeardConfidence Property

NLAttributes.BeardConfidence Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets the beard confidence value.

C#
[Obsolete("Use GetAttributeValue(NBiometricAttributeId.Beard) instead.")]
public byte BeardConfidence;


NLAttributes.BlinkConfidence Property

NLAttributes.BlinkConfidence Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets the blink confidence value.

C#
[Obsolete("Use GetAttributeValue(NBiometricAttributeId.EyesOpen) instead.")]
public byte BlinkConfidence;


NLAttributes.BoundingRect Property

NLAttributes.BoundingRect Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets the bounding rectangle that completely encloses face.

C#
public Rectangle BoundingRect;
Property value

Rectangle type value containing coordinates, width and height.


NLAttributes.Contrast Property

NLAttributes.Contrast Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets the contrast value.

C#
[Obsolete("Use GetAttributeValue(NBiometricAttributeId.Contrast) instead.")]
public byte Contrast;


NLAttributes.DarkGlassesConfidence Property

NLAttributes.DarkGlassesConfidence Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets the dark glasses confidence value.

C#
[Obsolete("Use GetAttributeValue(NBiometricAttributeId.DarkGlasses) instead.")]
public byte DarkGlassesConfidence;


NLAttributes.EmotionAngerConfidence Property

NLAttributes.EmotionAngerConfidence Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets anger confidence value.

C#
[Obsolete("Use GetAttributeValue(NBiometricAttributeId.EmotionAnger) instead.")]
public byte EmotionAngerConfidence;


NLAttributes.EmotionContemptConfidence Property

NLAttributes.EmotionContemptConfidence Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets anger confidence value.

C#
[Obsolete("Use GetAttributeValue(NBiometricAttributeId.EmotionContempt) instead.")]
public byte EmotionContemptConfidence;


NLAttributes.EmotionDisgustConfidence Property

NLAttributes.EmotionDisgustConfidence Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets disgust confidence value.

C#
[Obsolete("Use GetAttributeValue(NBiometricAttributeId.EmotionDisgust) instead.")]
public byte EmotionDisgustConfidence;


NLAttributes.EmotionFearConfidence Property

NLAttributes.EmotionFearConfidence Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets fear confidence value.

C#
[Obsolete("Use GetAttributeValue(NBiometricAttributeId.EmotionFear) instead.")]
public byte EmotionFearConfidence;


NLAttributes.EmotionHappinessConfidence Property

NLAttributes.EmotionHappinessConfidence Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets happiness confidence value.

C#
[Obsolete("Use GetAttributeValue(NBiometricAttributeId.EmotionHappiness) instead.")]
public byte EmotionHappinessConfidence;


NLAttributes.EmotionNeutralConfidence Property

NLAttributes.EmotionNeutralConfidence Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets the neutral emotion confidence value.

C#
[Obsolete("Use GetAttributeValue(NBiometricAttributeId.EmotionNeutral) instead.")]
public byte EmotionNeutralConfidence;


NLAttributes.EmotionSadnessConfidence Property

NLAttributes.EmotionSadnessConfidence Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets sadness confidence value.

C#
[Obsolete("Use GetAttributeValue(NBiometricAttributeId.EmotionSadness) instead.")]
public byte EmotionSadnessConfidence;


NLAttributes.EmotionSurpriseConfidence Property

NLAttributes.EmotionSurpriseConfidence Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets surprise confidence value.

C#
[Obsolete("Use GetAttributeValue(NBiometricAttributeId.EmotionSurprise) instead.")]
public byte EmotionSurpriseConfidence;


NLAttributes.EthnicityArabianConfidence Property

NLAttributes.EthnicityArabianConfidence Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets ethnicity Arabian confidence value.

C#
[Obsolete("Use GetAttributeValue(NBiometricAttributeId.EthnicityArabian) instead.")]
public byte EthnicityArabianConfidence;


NLAttributes.EthnicityAsianConfidence Property

NLAttributes.EthnicityAsianConfidence Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets ethnicity Asian confidence value.

C#
[Obsolete("Use GetAttributeValue(NBiometricAttributeId.EthnicityAsian) instead.")]
public byte EthnicityAsianConfidence;


NLAttributes.EthnicityBlackConfidence Property

NLAttributes.EthnicityBlackConfidence Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets ethnicity Black confidence value.

C#
[Obsolete("Use GetAttributeValue(NBiometricAttributeId.EthnicityBlack) instead.")]
public byte EthnicityBlackConfidence;


NLAttributes.EthnicityHispanicConfidence Property

NLAttributes.EthnicityHispanicConfidence Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets ethnicity Hispanic confidence value.

C#
[Obsolete("Use GetAttributeValue(NBiometricAttributeId.EthnicityHispanic) instead.")]
public byte EthnicityHispanicConfidence;


NLAttributes.EthnicityIndianConfidence Property

NLAttributes.EthnicityIndianConfidence Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets ethnicity Indian confidence value.

C#
[Obsolete("Use GetAttributeValue(NBiometricAttributeId.EthnicityIndian) instead.")]
public byte EthnicityIndianConfidence;


NLAttributes.EthnicityWhiteConfidence Property

NLAttributes.EthnicityWhiteConfidence Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets ethnicity White confidence value.

C#
[Obsolete("Use GetAttributeValue(NBiometricAttributeId.EthnicityWhite) instead.")]
public byte EthnicityWhiteConfidence;


NLAttributes.Expression Property

NLAttributes.Expression Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets the expression value.

C#
[Obsolete("Use GetAttributeValue(NBiometricAttributeId.AppropriateAttributeId) instead.")]
public NLExpression Expression;


NLAttributes.ExpressionConfidence Property

NLAttributes.ExpressionConfidence Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets the expression confidence value.

C#
[Obsolete("Use GetAttributeValue(NBiometricAttributeId.AppropriateAttributeId) instead.")]
public byte ExpressionConfidence;


NLAttributes.FaceDarknessConfidence Property

NLAttributes.FaceDarknessConfidence Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets the face darkness confidence value.

C#
[Obsolete("Use GetAttributeValue(NBiometricAttributeId.FaceDarkness) instead.")]
public byte FaceDarknessConfidence;


NLAttributes.FaceMaskConfidence Property

NLAttributes.FaceMaskConfidence Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets the face mask confidence value.

C#
[Obsolete("Use GetAttributeValue(NBiometricAttributeId.FaceMask) instead.")]
public byte FaceMaskConfidence;


NLAttributes.FeaturePoints Property

NLAttributes.FeaturePoints Property
NLAttributes Class Neurotec.Biometrics Namespace

Retrieves the feature point collection.

C#
public FeaturePointCollection FeaturePoints;


NLAttributes.Gender Property

NLAttributes.Gender Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or set the gender value.

C#
public NGender Gender;


NLAttributes.GenderConfidence Property

NLAttributes.GenderConfidence Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets the gender confidence value. Setter is deprecated.

C#
public byte GenderConfidence;


NLAttributes.GlassesConfidence Property

NLAttributes.GlassesConfidence Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets the glasses confidence value.

C#
[Obsolete("Use GetAttributeValue(NBiometricAttributeId.Glasses) instead.")]
public byte GlassesConfidence;


NLAttributes.GlassesReflectionConfidence Property

NLAttributes.GlassesReflectionConfidence Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets the glasses reflection confidence value.

C#
[Obsolete("Use GetAttributeValue(NBiometricAttributeId.GlassesReflection) instead.")]
public byte GlassesReflectionConfidence;


NLAttributes.GrayscaleDensity Property

NLAttributes.GrayscaleDensity Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets the image grayscale density value.

C#
[Obsolete("Use GetAttributeValue(NBiometricAttributeId.GrayscaleDensity) instead.")]
public byte GrayscaleDensity;


NLAttributes.HatConfidence Property

NLAttributes.HatConfidence Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets the hat confidence value.

C#
[Obsolete("Use GetAttributeValue(NBiometricAttributeId.HeadCovering) instead.")]
public byte HatConfidence;


NLAttributes.HeavyFrameConfidence Property

NLAttributes.HeavyFrameConfidence Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets the heavy frame confidence value.

C#
[Obsolete("Use GetAttributeValue(NBiometricAttributeId.HeavyFrameGlasses) instead.")]
public byte HeavyFrameConfidence;


NLAttributes.IcaoWarnings Property

NLAttributes.IcaoWarnings Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets one of NIcaoWarnings values.

C#
public NIcaoWarnings IcaoWarnings;
Property value

NIcaoWarnings value.


NLAttributes.LeftEyeCenter Property

NLAttributes.LeftEyeCenter Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets the center of the left eye.

C#
public NLFeaturePoint LeftEyeCenter;


NLAttributes.LivenessAction Property

NLAttributes.LivenessAction Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets face liveness action value.

C#
public NLivenessAction LivenessAction;
Property value

One of NLivenessAction values.


NLAttributes.LivenessScore Property

NLAttributes.LivenessScore Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets face liveness score value.

C#
public byte LivenessScore;
Property value

Liveness score value.


NLAttributes.LivenessTargetPitch Property

NLAttributes.LivenessTargetPitch Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets liveness detection pitch angle.

C#
public float LivenessTargetPitch;
Property value

Liveness detection pitch angle.


NLAttributes.LivenessTargetYaw Property

NLAttributes.LivenessTargetYaw Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets liveness detection yaw rotation angle.

C#
public float LivenessTargetYaw;
Property value

Liveness detection yaw rotation angle.


NLAttributes.LookingAwayConfidence Property

NLAttributes.LookingAwayConfidence Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets the eye look confidence value.

C#
[Obsolete("Use GetAttributeValue(NBiometricAttributeId.LookingAway) instead.")]
public byte LookingAwayConfidence;


NLAttributes.MocTemplate Property

NLAttributes.MocTemplate Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets Match-on-Card face template, if engine was configured to extract it.

C#
public NBuffer MocTemplate;


NLAttributes.MouthCenter Property

NLAttributes.MouthCenter Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets the center of the mouth.

C#
public NLFeaturePoint MouthCenter;


NLAttributes.MouthOpenConfidence Property

NLAttributes.MouthOpenConfidence Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets the mouth open confidence value.

C#
[Obsolete("Use GetAttributeValue(NBiometricAttributeId.MouthOpen) instead.")]
public byte MouthOpenConfidence;


NLAttributes.MustacheConfidence Property

NLAttributes.MustacheConfidence Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets the mustache confidence value.

C#
[Obsolete("Use GetAttributeValue(NBiometricAttributeId.Mustache) instead.")]
public byte MustacheConfidence;


NLAttributes.NativeType Property

NLAttributes.NativeType Property
NLAttributes Class Neurotec.Biometrics Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NLAttributes.Noise Property

NLAttributes.Noise Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets the noise value.

C#
[Obsolete("Use GetAttributeValue(NBiometricAttributeId.Noise) instead.")]
public byte Noise;


NLAttributes.NoseTip Property

NLAttributes.NoseTip Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets the tip of the nose.

C#
public NLFeaturePoint NoseTip;


NLAttributes.Owner Property

NLAttributes.Owner Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets the owner object.

C#
public new NFace Owner;
Property value

NFace object.


NLAttributes.Pitch Property

NLAttributes.Pitch Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets the image pitch value in degrees. The calculation of this value is not implemented.

C#
public float Pitch;


NLAttributes.PixelationConfidence Property

NLAttributes.PixelationConfidence Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets the pixelation confidence value.

C#
[Obsolete("Use GetAttributeValue(NBiometricAttributeId.Pixelation) instead.")]
public byte PixelationConfidence;


NLAttributes.Properties Property

NLAttributes.Properties Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets NLAttributes properties.

C#
[Obsolete("Use GetAttributeValue(NBiometricAttributeId.AppropriateAttributeId) instead.")]
public NLProperties Properties;


NLAttributes.RedEyeConfidence Property

NLAttributes.RedEyeConfidence Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets the red eye confidence value.

C#
[Obsolete("Use GetAttributeValue(NBiometricAttributeId.RedEye) instead.")]
public byte RedEyeConfidence;


NLAttributes.RightEyeCenter Property

NLAttributes.RightEyeCenter Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets the center of the right eye.

C#
public NLFeaturePoint RightEyeCenter;


NLAttributes.Roll Property

NLAttributes.Roll Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets the image roll value in degrees. Positive angles represent faces tilted toward their left shoulder (a clockwise rotation around the z-axis).

C#
public float Roll;


NLAttributes.Saturation Property

NLAttributes.Saturation Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets the saturation value.

C#
[Obsolete("Use GetAttributeValue(NBiometricAttributeId.Saturation) instead.")]
public byte Saturation;


NLAttributes.Sharpness Property

NLAttributes.Sharpness Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets the image sharpness value.

C#
[Obsolete("Use GetAttributeValue(NBiometricAttributeId.Sharpness) instead.")]
public byte Sharpness;


NLAttributes.SkinReflectionConfidence Property

NLAttributes.SkinReflectionConfidence Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets the skin reflection confidence value.

C#
[Obsolete("Use GetAttributeValue(NBiometricAttributeId.SkinReflection) instead.")]
public byte SkinReflectionConfidence;


NLAttributes.Template Property

NLAttributes.Template Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets a face template contained in a NLTemplate object.

C#
public NLTemplate Template;


NLAttributes.Thumbnail Property

NLAttributes.Thumbnail Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets the thumbnail image.

C#
public NImage Thumbnail;


NLAttributes.TokenImageRect Property

NLAttributes.TokenImageRect Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets face token image rectangle.

C#
public Rectangle TokenImageRect;
Property value

Rectangle object defining rectangle.


NLAttributes.UnnaturalSkinToneConfidence Property

NLAttributes.UnnaturalSkinToneConfidence Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets the skin tone confidence value.

C#
[Obsolete("Use GetAttributeValue(NBiometricAttributeId.SkinTone) instead.")]
public byte UnnaturalSkinToneConfidence;


NLAttributes.WashedOutConfidence Property

NLAttributes.WashedOutConfidence Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets the washed out confidence value.

C#
[Obsolete("Use GetAttributeValue(NBiometricAttributeId.WashedOut) instead.")]
public byte WashedOutConfidence;


NLAttributes.Yaw Property

NLAttributes.Yaw Property
NLAttributes Class Neurotec.Biometrics Namespace

Gets or sets the image yaw value in degrees. Positive angles represent faces looking to their right (a clockwise rotation around the y-axis).

C#
public float Yaw;


NLFeaturePoint Structure

NLFeaturePoint Structure
Legend Members Methods NLFeaturePoint Methods NLFeaturePoint Properties

Structure defining facial feature point.

C#
[Serializable]
[StructLayout(LayoutKind.Sequential)]
public struct NLFeaturePoint : IFormattable {
}
Collapse Expand NLFeaturePoint Methods
Name | Description
ToString | Retrieves a string representation of the object.
Collapse Expand NLFeaturePoint Properties
Name | Description
Code | Gets or sets the feature code.
Confidence | Gets or sets the feature confidence.
NativeType | Defines the native type of the object.
X | Gets or sets the X-coordinate of the feature point.
Y | Gets or sets the Y-coordinate of the feature point.
Container

File: NBiometricTypes.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


NLFeaturePoint.NLFeaturePoint Constructor (ushort, ushort, ushort)

NLFeaturePoint.NLFeaturePoint Constructor (ushort, ushort, ushort)
NLFeaturePoint Structure Neurotec.Biometrics Namespace

Initializes a new instance of NLFeaturePoint structure.

C#
public NLFeaturePoint(ushort code, ushort x, ushort y);
Collapse Expand Parameters
Parameters | Description
ushort code | Feature code.
ushort x | X-coordinate of the the feature point.
ushort y | Y-coordinate of the the feature point.


NLFeaturePoint.NLFeaturePoint Constructor (ushort, ushort, ushort, byte)

NLFeaturePoint.NLFeaturePoint Constructor (ushort, ushort, ushort, byte)
NLFeaturePoint Structure Neurotec.Biometrics Namespace

Initializes a new instance of NLFeaturePoint structure.

C#
public NLFeaturePoint(ushort code, ushort x, ushort y, byte confidence);
Collapse Expand Parameters
Parameters | Description
ushort code | Feature code.
ushort x | X-coordinate of the the feature point.
ushort y | Y-coordinate of the the feature point.
byte confidence | Feature confidence.


NLFeaturePoint.ToString Method ()

NLFeaturePoint.ToString Method ()
NLFeaturePoint Structure Neurotec.Biometrics Namespace

Retrieves a string representation of the object.

C#
public override string ToString();
Collapse Expand Returns

A string representation of an object.


NLFeaturePoint.ToString Method (string)

NLFeaturePoint.ToString Method (string)
NLFeaturePoint Structure Neurotec.Biometrics Namespace

Retrieves a string representation of the object.

C#
public string ToString(string format);
Collapse Expand Parameters
Parameters | Description
string format | String format
Collapse Expand Returns

A string representation of an object.


NLFeaturePoint.Code Property

NLFeaturePoint.Code Property
NLFeaturePoint Structure Neurotec.Biometrics Namespace

Gets or sets the feature code.

C#
public ushort Code;


NLFeaturePoint.Confidence Property

NLFeaturePoint.Confidence Property
NLFeaturePoint Structure Neurotec.Biometrics Namespace

Gets or sets the feature confidence.

C#
public byte Confidence;


NLFeaturePoint.NativeType Property

NLFeaturePoint.NativeType Property
NLFeaturePoint Structure Neurotec.Biometrics Namespace

Defines the native type of the object.

C#
public static NType NativeType;


NLFeaturePoint.X Property

NLFeaturePoint.X Property
NLFeaturePoint Structure Neurotec.Biometrics Namespace

Gets or sets the X-coordinate of the feature point.

C#
public ushort X;


NLFeaturePoint.Y Property

NLFeaturePoint.Y Property
NLFeaturePoint Structure Neurotec.Biometrics Namespace

Gets or sets the Y-coordinate of the feature point.

C#
public ushort Y;


NLMatchingDetails Class

NLMatchingDetails Class
Legend Members NLMatchingDetails Properties

Provides functionality to retrieve face templates matching details.

C#
public sealed class NLMatchingDetails : NXMatchingDetails;
Collapse Expand NLMatchingDetails Properties
Name | Description
NativeType | Defines the native type of the object.
Container

File: NLMatchingDetails.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


NLMatchingDetails.NativeType Property

NLMatchingDetails.NativeType Property
NLMatchingDetails Class Neurotec.Biometrics Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NLRecord Class

NLRecord Class
NObject Delegates NObject Events NObject Fields Legend Members Methods NDisposable Methods NDisposable Properties

Provides functionality for packing, unpacking and editing Neurotechnology Face Records (NLRecords).

C#
public sealed class NLRecord : NObject, ICloneable;
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NLRecord Class
Name | Description
Check | Checks if format of packed NLRecord is correct. Checks if format of packed NLRecord is correct.
GetQuality | Retrieves face quality from packed NLRecord.
GetSize | Gets the size of packed NLRecord.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NLRecord Class
Name | Description
CbeffProductType | Gets or sets the Cbeff product type of the NLRecord.
NativeType | Defines the native type of the object.
Quality | Gets or sets face quality.
Container

File: NLRecord.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


NLRecord.NLRecord Constructor ()

NLRecord.NLRecord Constructor ()
NLRecord Class Neurotec.Biometrics Namespace

Initializes a new instance of the NLRecord class.

C#
public NLRecord();


NLRecord.NLRecord Constructor (NBuffer)

NLRecord.NLRecord Constructor (NBuffer)
NLRecord Class Neurotec.Biometrics Namespace

Initializes a new instance of the NLRecord class.

C#
public NLRecord(NBuffer buffer);
Collapse Expand Parameters
Parameters | Description
NBuffer buffer | The packed NLRecord object.


NLRecord.NLRecord Constructor (NBuffer, uint)

NLRecord.NLRecord Constructor (NBuffer, uint)
NLRecord Class Neurotec.Biometrics Namespace

Initializes a new instance of the NLRecord class.

C#
public NLRecord(NBuffer buffer, uint flags);
Collapse Expand Parameters
Parameters | Description
NBuffer buffer | The packed NLRecord object.
uint flags | Bitwise combination of zero or more flags that controls behavior of the constructor.


NLRecord.NLRecord Constructor (NBuffer, uint, out int)

NLRecord.NLRecord Constructor (NBuffer, uint, out int)
NLRecord Class Neurotec.Biometrics Namespace

Initializes a new instance of the NLRecord class.

C#
public NLRecord(NBuffer buffer, uint flags, out int size);
Collapse Expand Parameters
Parameters | Description
NBuffer buffer | The packed NLRecord object.
uint flags | Bitwise combination of zero or more flags that controls behavior of the constructor.
out int size | [out] NLRecord size.


NLRecord.NLRecord Constructor (NLRecord, NTemplateSize)

NLRecord.NLRecord Constructor (NLRecord, NTemplateSize)
NLRecord Class Neurotec.Biometrics Namespace

Initializes a new instance of the NLRecord class from existing NLRecord with specified size.

C#
public NLRecord(NLRecord record, NTemplateSize templateSize);
Collapse Expand Parameters
Parameters | Description
NLRecord record | Source NLRecord.
NTemplateSize templateSize | Template size of NLRecord to be created.
Collapse Expand Remarks

Can be used to decrease the size of NLRecord.


NLRecord.NLRecord Constructor (NLRecord, NTemplateSize, uint)

NLRecord.NLRecord Constructor (NLRecord, NTemplateSize, uint)
NLRecord Class Neurotec.Biometrics Namespace

Initializes a new instance of the NLRecord class from existing NLRecord with specified size.

C#
public NLRecord(NLRecord record, NTemplateSize templateSize, uint flags);
Collapse Expand Parameters
Parameters | Description
NLRecord record | Source NLRecord.
NTemplateSize templateSize | Template size of NLRecord to be created.
uint flags | Bitwise combination of zero or more flags that controls behavior of the constructor.
Collapse Expand Remarks

Can be used to decrease the size of NLRecord.


NLRecord.NLRecord Constructor (byte[])

NLRecord.NLRecord Constructor (byte[])
NLRecord Class Neurotec.Biometrics Namespace

Initializes a new instance of the NLRecord class.

C#
public NLRecord(byte[] buffer);
Collapse Expand Parameters
Parameters | Description
byte[] buffer | The packed NLRecord object.


NLRecord.NLRecord Constructor (uint)

NLRecord.NLRecord Constructor (uint)
NLRecord Class Neurotec.Biometrics Namespace

Initializes a new instance of the NLRecord class.

C#
public NLRecord(uint flags);
Collapse Expand Parameters
Parameters | Description
uint flags | Bitwise combination of zero or more flags that controls behavior of the constructor. Exclusive-OR is performed when few flags needed.
Collapse Expand Remarks

The following flags are supported:

  • FlagSkipBlockedOrients
  • FlagSkipGs
  • FlagSkipQualities


NLRecord.Check Method (NBuffer)

NLRecord.Check Method (NBuffer)
NLRecord Class Neurotec.Biometrics Namespace

Checks if format of packed NLRecord is correct.

Checks if format of packed NLRecord is correct.

C#
public static void Check(NBuffer buffer);
Collapse Expand Parameters
Parameters | Description
NBuffer buffer | The packed NLRecord object.


NLRecord.Check Method (byte[])

NLRecord.Check Method (byte[])
NLRecord Class Neurotec.Biometrics Namespace

Checks if format of packed NLRecord is correct.

Checks if format of packed NLRecord is correct.

C#
public static void Check(byte[] buffer);
Collapse Expand Parameters
Parameters | Description
byte[] buffer | The packed NLRecord object.


NLRecord.GetQuality Method (NBuffer)

NLRecord.GetQuality Method (NBuffer)
NLRecord Class Neurotec.Biometrics Namespace

Retrieves face quality from packed NLRecord.

C#
public static byte GetQuality(NBuffer buffer);
Collapse Expand Parameters
Parameters | Description
NBuffer buffer | NBuffer of packed NLRecord.
Collapse Expand Returns

The value of face quality.


NLRecord.GetQuality Method (byte[])

NLRecord.GetQuality Method (byte[])
NLRecord Class Neurotec.Biometrics Namespace

Retrieves face quality from packed NLRecord.

C#
public static byte GetQuality(byte[] buffer);
Collapse Expand Parameters
Parameters | Description
byte[] buffer | The byte array of packed NLRecord.
Collapse Expand Returns

The value of face quality.


NLRecord.GetSize Method (NBuffer)

NLRecord.GetSize Method (NBuffer)
NLRecord Class Neurotec.Biometrics Namespace

Gets the size of packed NLRecord.

C#
public static int GetSize(NBuffer buffer);
Collapse Expand Parameters
Parameters | Description
NBuffer buffer | The packed NLRecord.
Collapse Expand Returns

Size of NLRecord.


NLRecord.GetSize Method (byte[])

NLRecord.GetSize Method (byte[])
NLRecord Class Neurotec.Biometrics Namespace

Gets the size of packed NLRecord.

C#
public static int GetSize(byte[] buffer);
Collapse Expand Parameters
Parameters | Description
byte[] buffer | The packed NLRecord.
Collapse Expand Returns

Size of NLRecord.


NLRecord.CbeffProductType Property

NLRecord.CbeffProductType Property
NLRecord Class Neurotec.Biometrics Namespace

Gets or sets the Cbeff product type of the NLRecord.

C#
public ushort CbeffProductType;
Property value

The Cbeff product type.


NLRecord.NativeType Property

NLRecord.NativeType Property
NLRecord Class Neurotec.Biometrics Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NLRecord.Quality Property

NLRecord.Quality Property
NLRecord Class Neurotec.Biometrics Namespace

Gets or sets face quality.

C#
public byte Quality;
Property value

Face quality. Quality value can be interval [0; 100], 254 (quality was not calculated) and 255 (failed to calculate quality value).


NLTemplate Class

NLTemplate Class
NLTemplate Classes NObject Delegates NObject Events NObject Fields Legend Members Methods NDisposable Methods NDisposable Properties

Provides functionality for packing, unpacking and editing Neurotechnology Faces Templates (NLTemplates).

C#
public sealed class NLTemplate : NObject, ICloneable;
Collapse Expand NLTemplate Classes
NLTemplate Class
Name | Description
RecordCollection | Collection of NLRecords.
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NLTemplate Class
Name | Description
FlagProcessFirstRecordOnly | The flag indicating whether only the first face record should be unpacked or packed while unpacking or packing NLTemplate.
MaxRecordCount | The maximum number of face records NLTemplate can contain.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NLTemplate Class
Name | Description
CalculateSize | Calculates NLTemplate size.
Check | Checks if format of packed NLTemplate format is correct.
GetRecordCount | Retrieves records count.
GetSize | Gets the size of packed NLTemplate.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NLTemplate Class
Name | Description
NativeType | Defines the native type of the object.
Records | Gets Records collection.
Container

File: NLTemplate.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


NLTemplate.NLTemplate Constructor ()

NLTemplate.NLTemplate Constructor ()
NLTemplate Class Neurotec.Biometrics Namespace

Initializes a new instance of the NLTemplate class.

C#
public NLTemplate();


NLTemplate.NLTemplate Constructor (NBuffer)

NLTemplate.NLTemplate Constructor (NBuffer)
NLTemplate Class Neurotec.Biometrics Namespace

Initializes a new instance of the NLTemplate class.

C#
public NLTemplate(NBuffer buffer);
Collapse Expand Parameters
Parameters | Description
NBuffer buffer | NBuffer with packed NLTemplate objects.


NLTemplate.NLTemplate Constructor (NBuffer, uint)

NLTemplate.NLTemplate Constructor (NBuffer, uint)
NLTemplate Class Neurotec.Biometrics Namespace

Initializes a new instance of the NLTemplate class.

C#
public NLTemplate(NBuffer buffer, uint flags);
Collapse Expand Parameters
Parameters | Description
NBuffer buffer | NBuffer with packed NLTemplate objects.
uint flags | Reserved for future use. Must be zero.


NLTemplate.NLTemplate Constructor (NBuffer, uint, out int)

NLTemplate.NLTemplate Constructor (NBuffer, uint, out int)
NLTemplate Class Neurotec.Biometrics Namespace

Initializes a new instance of the NLTemplate class.

C#
public NLTemplate(NBuffer buffer, uint flags, out int size);
Collapse Expand Parameters
Parameters | Description
NBuffer buffer | NBuffer with packed NLTemplate objects.
uint flags | Reserved for future use. Must be zero.
out int size | [out] NLTemplate size.


NLTemplate.NLTemplate Constructor (byte[])

NLTemplate.NLTemplate Constructor (byte[])
NLTemplate Class Neurotec.Biometrics Namespace

Initializes a new instance of the NLTemplate class.

C#
public NLTemplate(byte[] buffer);
Collapse Expand Parameters
Parameters | Description
byte[] buffer | A byte array with packed NLTemplate objects.


NLTemplate.NLTemplate Constructor (uint)

NLTemplate.NLTemplate Constructor (uint)
NLTemplate Class Neurotec.Biometrics Namespace

Initializes a new instance of the NLTemplate class.

C#
public NLTemplate(uint flags);
Collapse Expand Parameters
Parameters | Description
uint flags | Bitwise combination of zero or more flags that controls behavior of the constructor.


NLTemplate.RecordCollection Class

NLTemplate.RecordCollection Class

Collection of NLRecords.

C#
public sealed class RecordCollection : NObjectCollection<NLRecord>;
Container

File: NLTemplate.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


NLTemplate.FlagProcessFirstRecordOnly Field

NLTemplate.FlagProcessFirstRecordOnly Field
NLTemplate Class Neurotec.Biometrics Namespace

The flag indicating whether only the first face record should be unpacked or packed while unpacking or packing NLTemplate.

C#
public const uint FlagProcessFirstRecordOnly = 0x00000100;


NLTemplate.MaxRecordCount Field

NLTemplate.MaxRecordCount Field
NLTemplate Class Neurotec.Biometrics Namespace

The maximum number of face records NLTemplate can contain.

C#
public const int MaxRecordCount = 255;


NLTemplate.CalculateSize Method

NLTemplate.CalculateSize Method
NLTemplate Class Neurotec.Biometrics Namespace

Calculates NLTemplate size.

C#
public static int CalculateSize(int[] recordSizes);
Collapse Expand Parameters
Parameters | Description
int[] recordSizes | An array that contains NLRecords sizes.
Collapse Expand Returns

A size of records.


NLTemplate.Check Method (NBuffer)

NLTemplate.Check Method (NBuffer)
NLTemplate Class Neurotec.Biometrics Namespace

Checks if format of packed NLTemplate format is correct.

C#
public static void Check(NBuffer buffer);
Collapse Expand Parameters
Parameters | Description
NBuffer buffer | NBuffer with packed NLTemplate.


NLTemplate.Check Method (byte[])

NLTemplate.Check Method (byte[])
NLTemplate Class Neurotec.Biometrics Namespace

Checks if format of packed NLTemplate format is correct.

C#
public static void Check(byte[] buffer);
Collapse Expand Parameters
Parameters | Description
byte[] buffer | A byte array with packed NLTemplate.
Collapse Expand Returns

true if NLTemplate format is correct, false otherwise.


NLTemplate.GetRecordCount Method (NBuffer)

NLTemplate.GetRecordCount Method (NBuffer)
NLTemplate Class Neurotec.Biometrics Namespace

Retrieves records count.

C#
public static int GetRecordCount(NBuffer buffer);
Collapse Expand Parameters
Parameters | Description
NBuffer buffer | NBuffer with NLTemplate.
Collapse Expand Returns

Records count.


NLTemplate.GetRecordCount Method (byte[])

NLTemplate.GetRecordCount Method (byte[])
NLTemplate Class Neurotec.Biometrics Namespace

Retrieves records count.

C#
public static int GetRecordCount(byte[] buffer);
Collapse Expand Parameters
Parameters | Description
byte[] buffer | A byte array with NLTemplate.
Collapse Expand Returns

Records count.


NLTemplate.GetSize Method (NBuffer)

NLTemplate.GetSize Method (NBuffer)
NLTemplate Class Neurotec.Biometrics Namespace

Gets the size of packed NLTemplate.

C#
public static int GetSize(NBuffer buffer);
Collapse Expand Parameters
Parameters | Description
NBuffer buffer | The packed NLTemplate.
Collapse Expand Returns

NLTemplate size.


NLTemplate.GetSize Method (byte[])

NLTemplate.GetSize Method (byte[])
NLTemplate Class Neurotec.Biometrics Namespace

Gets the size of packed NLTemplate.

C#
public static int GetSize(byte[] buffer);
Collapse Expand Parameters
Parameters | Description
byte[] buffer | The packed NLTemplate.
Collapse Expand Returns

NLTemplate size.


NLTemplate.NativeType Property

NLTemplate.NativeType Property
NLTemplate Class Neurotec.Biometrics Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NLTemplate.Records Property

NLTemplate.Records Property
NLTemplate Class Neurotec.Biometrics Namespace

Gets Records collection.

C#
public RecordCollection Records;
Property value

A RecordCollection collection.


NMatchingDetails Class

NMatchingDetails Class
NMatchingDetails Classes NObject Delegates NObject Events NObject Fields Legend Members Methods NDisposable Methods NDisposable Properties

Provides functionality for retrieving Neurotechnology templates matching details.

C#
public sealed class NMatchingDetails : NMatchingDetailsBase;
Collapse Expand NMatchingDetails Classes
NMatchingDetails Class
Name | Description
FaceCollection | Face templates matching details collection.
FingerCollection | Finger templates matching details collection.
IrisCollection | Iris templates matching details collection.
PalmCollection | Palm templates matching details collection.
VoiceCollection | Voice templates matching details collection.
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NMatchingDetails Class
Name | Description
FlagSaveCompatible12Line | This flag results in output compatible with 12.X line. Not all fields can be preserved when this flag is used.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NMatchingDetailsBase Class
Show:
No members matching the current filter
Name | Description
BiometricType | Gets type of biometric modality saved in specified matching details.
NativeType | Defines the native type of the object.
Score | Gets similarity score of two matched templates.
NMatchingDetails Class
Name | Description
Faces | Gets collection of faces matching details.
FacesMatchedIndex | Gets index of matched face in the second matched NLTemplate (or NTemplate)).
FacesScore | Gets similarity score of two matched face templates (NLTemplate).
Fingers | Gets collection of fingers matching details.
FingersScore | Gets similarity score of two matched finger templates (NFTemplate).
Irises | Gets collection of irises matching details.
IrisesScore | Gets similarity score of two matched iris templates (NETemplate).
NativeType | Defines the native type of the object.
Palms | Gets collection of palms matching details.
PalmsScore | Gets similarity score of two matched palm templates (NFTemplate).
Voices | Gets collection of voices matching details.
VoicesScore | Gets similarity score of two matched voice templates (NSTemplate).
Container

File: NMatchingDetails.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


NMatchingDetails.NMatchingDetails Constructor (NBuffer)

NMatchingDetails.NMatchingDetails Constructor (NBuffer)
NMatchingDetails Class Neurotec.Biometrics Namespace

Creates new instance of NMatchingDetails class.

C#
public NMatchingDetails(NBuffer buffer);
Collapse Expand Parameters
Parameters | Description
NBuffer buffer | Memory buffer which contains templates matching details.


NMatchingDetails.NMatchingDetails Constructor (NBuffer, uint)

NMatchingDetails.NMatchingDetails Constructor (NBuffer, uint)
NMatchingDetails Class Neurotec.Biometrics Namespace

Creates new instance of NMatchingDetails class.

C#
public NMatchingDetails(NBuffer buffer, uint flags);
Collapse Expand Parameters
Parameters | Description
NBuffer buffer | Memory buffer which contains templates matching details.
uint flags | Bitwise combination of zero or more flags that controls behavior of the constructor. Should be zero.


NMatchingDetails.NMatchingDetails Constructor (NBuffer, uint, out int)

NMatchingDetails.NMatchingDetails Constructor (NBuffer, uint, out int)
NMatchingDetails Class Neurotec.Biometrics Namespace

Creates new instance of NMatchingDetails class.

C#
public NMatchingDetails(NBuffer buffer, uint flags, out int size);
Collapse Expand Parameters
Parameters | Description
NBuffer buffer | Memory buffer which contains templates matching details.
uint flags | Bitwise combination of zero or more flags that controls behavior of the constructor. Should be zero.
out int size | Size of actually read buffer (in bytes).


NMatchingDetails.NMatchingDetails Constructor (NStream)

NMatchingDetails.NMatchingDetails Constructor (NStream)
NMatchingDetails Class Neurotec.Biometrics Namespace

Creates new instance of NMatchingDetails class.

C#
public NMatchingDetails(NStream stream);
Collapse Expand Parameters
Parameters | Description
NStream stream | Stream containing matching details.


NMatchingDetails.NMatchingDetails Constructor (NStream, uint)

NMatchingDetails.NMatchingDetails Constructor (NStream, uint)
NMatchingDetails Class Neurotec.Biometrics Namespace

Creates new instance of NMatchingDetails class.

C#
public NMatchingDetails(NStream stream, uint flags);
Collapse Expand Parameters
Parameters | Description
NStream stream | Stream containing matching details.
uint flags | Bitwise combination of zero or more flags that controls behavior of the constructor. Should be zero.


NMatchingDetails.NMatchingDetails Constructor (byte[])

NMatchingDetails.NMatchingDetails Constructor (byte[])
NMatchingDetails Class Neurotec.Biometrics Namespace

Creates new instance of NMatchingDetails class.

C#
public NMatchingDetails(byte[] buffer);
Collapse Expand Parameters
Parameters | Description
byte[] buffer | Byte buffer which contains templates matching details.


NMatchingDetails.FaceCollection Class

NMatchingDetails.FaceCollection Class

Face templates matching details collection.

C#
public sealed class FaceCollection : NObjectReadOnlyCollection<NLMatchingDetails>;
Container

File: NMatchingDetails.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


NMatchingDetails.FingerCollection Class

NMatchingDetails.FingerCollection Class

Finger templates matching details collection.

C#
public sealed class FingerCollection : NObjectReadOnlyCollection<NFMatchingDetails>;
Container

File: NMatchingDetails.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


NMatchingDetails.IrisCollection Class

NMatchingDetails.IrisCollection Class

Iris templates matching details collection.

C#
public sealed class IrisCollection : NObjectReadOnlyCollection<NEMatchingDetails>;
Container

File: NMatchingDetails.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


NMatchingDetails.PalmCollection Class

NMatchingDetails.PalmCollection Class

Palm templates matching details collection.

C#
public sealed class PalmCollection : NObjectReadOnlyCollection<NFMatchingDetails>;
Container

File: NMatchingDetails.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


NMatchingDetails.VoiceCollection Class

NMatchingDetails.VoiceCollection Class

Voice templates matching details collection.

C#
public sealed class VoiceCollection : NObjectReadOnlyCollection<NSMatchingDetails>;
Container

File: NMatchingDetails.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


NMatchingDetails.FlagSaveCompatible12Line Field

NMatchingDetails.FlagSaveCompatible12Line Field
NMatchingDetails Class Neurotec.Biometrics Namespace

This flag results in output compatible with 12.X line. Not all fields can be preserved when this flag is used.

C#
public const uint FlagSaveCompatible12Line = 0x00000001;


NMatchingDetails.Faces Property

NMatchingDetails.Faces Property
NMatchingDetails Class Neurotec.Biometrics Namespace

Gets collection of faces matching details.

C#
public FaceCollection Faces;
Property value

Faces matching details collection (FaceCollection).


NMatchingDetails.FacesMatchedIndex Property

NMatchingDetails.FacesMatchedIndex Property
NMatchingDetails Class Neurotec.Biometrics Namespace

Gets index of matched face in the second matched NLTemplate (or NTemplate)).

C#
public int FacesMatchedIndex;
Property value

Index of matched face in the second template.


NMatchingDetails.FacesScore Property

NMatchingDetails.FacesScore Property
NMatchingDetails Class Neurotec.Biometrics Namespace

Gets similarity score of two matched face templates (NLTemplate).

C#
public int FacesScore;
Property value

Similarity (matching) score.


NMatchingDetails.Fingers Property

NMatchingDetails.Fingers Property
NMatchingDetails Class Neurotec.Biometrics Namespace

Gets collection of fingers matching details.

C#
public FingerCollection Fingers;
Property value

Fingers matching details collection (FingerCollection).


NMatchingDetails.FingersScore Property

NMatchingDetails.FingersScore Property
NMatchingDetails Class Neurotec.Biometrics Namespace

Gets similarity score of two matched finger templates (NFTemplate).

C#
public int FingersScore;
Property value

Similarity (matching) score. of two fingerprint templates.


NMatchingDetails.Irises Property

NMatchingDetails.Irises Property
NMatchingDetails Class Neurotec.Biometrics Namespace

Gets collection of irises matching details.

C#
public IrisCollection Irises;
Property value

Irises matching details collection (IrisCollection).


NMatchingDetails.IrisesScore Property

NMatchingDetails.IrisesScore Property
NMatchingDetails Class Neurotec.Biometrics Namespace

Gets similarity score of two matched iris templates (NETemplate).

C#
public int IrisesScore;
Property value

Similarity (matching) score. of two iris templates.


NMatchingDetails.NativeType Property

NMatchingDetails.NativeType Property
NMatchingDetails Class Neurotec.Biometrics Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NMatchingDetails.Palms Property

NMatchingDetails.Palms Property
NMatchingDetails Class Neurotec.Biometrics Namespace

Gets collection of palms matching details.

C#
public PalmCollection Palms;
Property value

Palmprints matching details collection (PalmCollection).


NMatchingDetails.PalmsScore Property

NMatchingDetails.PalmsScore Property
NMatchingDetails Class Neurotec.Biometrics Namespace

Gets similarity score of two matched palm templates (NFTemplate).

C#
public int PalmsScore;
Property value

Similarity (matching) score. of two palm templates.


NMatchingDetails.Voices Property

NMatchingDetails.Voices Property
NMatchingDetails Class Neurotec.Biometrics Namespace

Gets collection of voices matching details.

C#
public VoiceCollection Voices;
Property value

Voices matching details collection (VoiceCollection).


NMatchingDetails.VoicesScore Property

NMatchingDetails.VoicesScore Property
NMatchingDetails Class Neurotec.Biometrics Namespace

Gets similarity score of two matched voice templates (NSTemplate).

C#
public int VoicesScore;
Property value

Similarity (matching) score. of two voice templates.


NMatchingDetailsBase Class

NMatchingDetailsBase Class
NObject Delegates NObject Events NObject Fields Legend Members NDisposable Methods NDisposable Properties

Base class for NMatchingDetails.

C#
public class NMatchingDetailsBase : NObject;
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NMatchingDetailsBase Class
Name | Description
BiometricType | Gets type of biometric modality saved in specified matching details.
NativeType | Defines the native type of the object.
Score | Gets similarity score of two matched templates.
Container

File: NMatchingDetailsBase.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


NMatchingDetailsBase.BiometricType Property

NMatchingDetailsBase.BiometricType Property
NMatchingDetailsBase Class Neurotec.Biometrics Namespace

Gets type of biometric modality saved in specified matching details.

C#
public NBiometricType BiometricType;
Property value

NBiometricType object containing information about template biometric type.


NMatchingDetailsBase.NativeType Property

NMatchingDetailsBase.NativeType Property
NMatchingDetailsBase Class Neurotec.Biometrics Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NMatchingDetailsBase.Score Property

NMatchingDetailsBase.Score Property
NMatchingDetailsBase Class Neurotec.Biometrics Namespace

Gets similarity score of two matched templates.

C#
public int Score;
Property value

Similarity score of two matched templates.


NMatchingResult Class

NMatchingResult Class
NObject Delegates NObject Events NObject Fields Legend Members NDisposable Methods NDisposable Properties

Provides methods to retrieve information about matching results.

C#
public sealed class NMatchingResult : NObject;
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NMatchingResult Class
Name | Description
Connection | Retrieves the biometric connection of the matching result.
Id | Retrieves the ID of the matching result.
MatchingDetails | Retrieves the matching details of the matching result.
MatchingDetailsBuffer | Retrieves the matching details buffer of the matching result.
NativeType | Defines the native type of the object.
Owner | Retrieves the owner object of the matching result.
Score | Retrieves the matching score of the matching result.
Subject | Retrieves the subject of the matching result.
Container

File: NMatchingResult.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


NMatchingResult.Connection Property

NMatchingResult.Connection Property
NMatchingResult Class Neurotec.Biometrics Namespace

Retrieves the biometric connection of the matching result.

C#
public NBiometricConnection Connection;


NMatchingResult.Id Property

NMatchingResult.Id Property
NMatchingResult Class Neurotec.Biometrics Namespace

Retrieves the ID of the matching result.

C#
public string Id;


NMatchingResult.MatchingDetails Property

NMatchingResult.MatchingDetails Property
NMatchingResult Class Neurotec.Biometrics Namespace

Retrieves the matching details of the matching result.

C#
public NMatchingDetails MatchingDetails;


NMatchingResult.MatchingDetailsBuffer Property

NMatchingResult.MatchingDetailsBuffer Property
NMatchingResult Class Neurotec.Biometrics Namespace

Retrieves the matching details buffer of the matching result.

C#
public NBuffer MatchingDetailsBuffer;


NMatchingResult.NativeType Property

NMatchingResult.NativeType Property
NMatchingResult Class Neurotec.Biometrics Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NMatchingResult.Owner Property

NMatchingResult.Owner Property
NMatchingResult Class Neurotec.Biometrics Namespace

Retrieves the owner object of the matching result.

C#
public new NSubject Owner;


NMatchingResult.Score Property

NMatchingResult.Score Property
NMatchingResult Class Neurotec.Biometrics Namespace

Retrieves the matching score of the matching result.

C#
public int Score;


NMatchingResult.Subject Property

NMatchingResult.Subject Property
NMatchingResult Class Neurotec.Biometrics Namespace

Retrieves the subject of the matching result.

C#
public NSubject Subject;


NSubject Class

NSubject Class
NSubject Classes NObject Delegates NObject Events NObject Fields Legend Members Methods NDisposable Methods NDisposable Properties

Represents a person (or, potentially, any living creature) and contains biometric information related that person, including templates, biometric operation (matching) results and objects like NFace, which contain biometric data of specific kinds.

C#
public sealed class NSubject : NExpandableObject;
Collapse Expand NSubject Classes
NSubject Class
Name | Description
FaceCollection | Collection of NFace objects containing face image data.
FingerCollection | Collection of NFinger objects containing fingerprint data.
IrisCollection | Collection of NIris objects containing iris image data.
MatchingResultCollection | Collection of NMatchingResult objects containing the results of matching operations involving the subject.
MissingEyeCollection | Collection of NEPosition objects containing data about missing eye positions.
MissingFingerCollection | Collection of NFPosition objects containing data about missing finger positions.
PalmCollection | Collection of NPalm objects containing palmprint data.
RelatedSubjectCollection | Collection of NSubject objects representing related subjects.
SignatureCollection | Collection of NSignature objects containing signature image data.
VoiceCollection | Collection of NVoice objects containing voice sample data.
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NSubject Class
Name | Description
Clear | Clears the NSubject of all data.
FromFile | Creates a new NSubject object from the specified file.
FromMemory | Creates a new NSubject object from the specified buffer.
FromStream | Creates a new NSubject object from the specified memory stream.
GetTemplate | Gets the template used by the NSubject.
GetTemplateBuffer | Gets the buffer which contains templates for the NSubject.
SetTemplate | Sets ANTemplate to be used by the NSubject.
SetTemplateBuffer | Sets the buffer to contain templates for the NSubject.
ToANTemplate | Converts NSubject to ANTemplate.
ToFCRecord | Converts NSubject to FCRecord.
ToFIRecord | Converts NSubject to FIRecord.
ToFMCRecord | Converts NSubject to FMCRecord.
ToFMRecord | Converts NSubject to FMRecord.
ToIIRecord | Converts NSubject to IIRecord.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NExpandableObject Class
Show:
No members matching the current filter
Name | Description
NativeType | Defines the native type of the object.
Properties | Gets the property bag of the expandable object.
NSubject Class
Name | Description
Error | Gets the exception thrown by the subject.
Faces | Retrieves the collection of NFace objects.
Fingers | Retrieves the collection of NFinger objects.
Gender | Gets or sets the gender value of the subject.
Id | Gets or sets the ID of the subject.
Irises | Retrieves the collection of NIris objects.
IsMultipleSubjects | Gets or sets whether the subject consists of multiple NSubjects.
MatchingResults | Retrieves the collection of subject's matching results.
MissingEyes | Retrieves the collection of NEPosition objects representing missing eye positions.
MissingFingers | Retrieves the collection of NFPosition objects representing missing finger positions.
NativeType | Defines the native type of the object.
Palms | Retrieves the collection of NPalm objects.
QueryString | Gets or sets the query string for the subject.
RelatedSubjects | Retrieves the collection of related NSubject objects.
Signatures | Retrieves the collection of NSignature objects.
Statistics | Gets the property bag containing the subject's statistics (diagnostic information).
Status | Gets or sets the biometric status of the subject.
Voices | Retrieves the collection of NVoice objects.
Container

File: NSubject.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


NSubject.NSubject Constructor

NSubject.NSubject Constructor
NSubject Class Neurotec.Biometrics Namespace

Creates a new NSubject object.

C#
public NSubject();


NSubject.FaceCollection Class

NSubject.FaceCollection Class

Collection of NFace objects containing face image data.

C#
public sealed class FaceCollection : NObjectCollection<NFace>;
Container

File: NSubject.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


NSubject.FingerCollection Class

NSubject.FingerCollection Class

Collection of NFinger objects containing fingerprint data.

C#
public sealed class FingerCollection : NObjectCollection<NFinger>;
Container

File: NSubject.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


NSubject.IrisCollection Class

NSubject.IrisCollection Class

Collection of NIris objects containing iris image data.

C#
public sealed class IrisCollection : NObjectCollection<NIris>;
Container

File: NSubject.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


NSubject.MatchingResultCollection Class

NSubject.MatchingResultCollection Class

Collection of NMatchingResult objects containing the results of matching operations involving the subject.

C#
public sealed class MatchingResultCollection : NObjectReadOnlyCollection<NMatchingResult>;
Container

File: NSubject.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


NSubject.MissingEyeCollection Class

NSubject.MissingEyeCollection Class

Collection of NEPosition objects containing data about missing eye positions.

C#
public sealed class MissingEyeCollection : ValueTypeCollection<NEPosition>;
Container

File: NSubject.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


NSubject.MissingFingerCollection Class

NSubject.MissingFingerCollection Class

Collection of NFPosition objects containing data about missing finger positions.

C#
public sealed class MissingFingerCollection : ValueTypeCollection<NFPosition>;
Container

File: NSubject.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


NSubject.PalmCollection Class

NSubject.PalmCollection Class

Collection of NPalm objects containing palmprint data.

C#
public sealed class PalmCollection : NObjectCollection<NPalm>;
Container

File: NSubject.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


NSubject.RelatedSubjectCollection Class

NSubject.RelatedSubjectCollection Class

Collection of NSubject objects representing related subjects.

C#
public sealed class RelatedSubjectCollection : NObjectCollection<NSubject>;
Collapse Expand Remarks

Multiple subjects are involved when, for example, a single image contains several faces. After segmentation, related subjects are generated from it. Currently this feature is provided only for image, in future in will involve voice files.

Container

File: NSubject.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


NSubject.SignatureCollection Class

NSubject.SignatureCollection Class

Collection of NSignature objects containing signature image data.

C#
public sealed class SignatureCollection : NObjectCollection<NSignature>;
Container

File: NSubject.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


NSubject.VoiceCollection Class

NSubject.VoiceCollection Class

Collection of NVoice objects containing voice sample data.

C#
public sealed class VoiceCollection : NObjectCollection<NVoice>;
Container

File: NSubject.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


NSubject.Clear Method

NSubject.Clear Method
NSubject Class Neurotec.Biometrics Namespace

Clears the NSubject of all data.

C#
public void Clear();


NSubject.FromFile Method (string)

NSubject.FromFile Method (string)
NSubject Class Neurotec.Biometrics Namespace

Creates a new NSubject object from the specified file.

C#
public static NSubject FromFile(string fileName);
Collapse Expand Parameters
Parameters | Description
string fileName | The name of the file.
Collapse Expand Returns

The new NSubject.


NSubject.FromFile Method (string, uint)

NSubject.FromFile Method (string, uint)
NSubject Class Neurotec.Biometrics Namespace

Creates a new NSubject object from the specified file.

C#
public static NSubject FromFile(string fileName, uint flags);
Collapse Expand Parameters
Parameters | Description
string fileName | The name of the file.
uint flags | Bitwise combination of zero or more flags that controls behavior of the function.
Collapse Expand Returns

The new NSubject.


NSubject.FromFile Method (string, ushort, ushort)

NSubject.FromFile Method (string, ushort, ushort)
NSubject Class Neurotec.Biometrics Namespace

Creates a new NSubject object from the specified file with specified format.

C#
public static NSubject FromFile(string fileName, ushort formatOwner, ushort formatType);
Collapse Expand Parameters
Parameters | Description
string fileName | The name of the file.
ushort formatOwner | Owner of the file format.
ushort formatType | File format type.
Collapse Expand Returns

The new NSubject.


NSubject.FromFile Method (string, ushort, ushort, uint)

NSubject.FromFile Method (string, ushort, ushort, uint)
NSubject Class Neurotec.Biometrics Namespace

Creates a new NSubject object from the specified file with specified format.

C#
public static NSubject FromFile(string fileName, ushort formatOwner, ushort formatType, uint flags);
Collapse Expand Parameters
Parameters | Description
string fileName | The name of the file.
ushort formatOwner | Owner of the file format.
ushort formatType | File format type.
uint flags | Bitwise combination of zero or more flags that controls behavior of the function.
Collapse Expand Returns

The new NSubject.


NSubject.FromMemory Method (NBuffer)

NSubject.FromMemory Method (NBuffer)
NSubject Class Neurotec.Biometrics Namespace

Creates a new NSubject object from the specified buffer.

C#
public static NSubject FromMemory(NBuffer buffer);
Collapse Expand Parameters
Parameters | Description
NBuffer buffer | The buffer.
Collapse Expand Returns

The new NSubject.


NSubject.FromMemory Method (NBuffer, uint)

NSubject.FromMemory Method (NBuffer, uint)
NSubject Class Neurotec.Biometrics Namespace

Creates a new NSubject object from the specified buffer.

C#
public static NSubject FromMemory(NBuffer buffer, uint flags);
Collapse Expand Parameters
Parameters | Description
NBuffer buffer | The buffer.
uint flags | Bitwise combination of zero or more flags that controls behavior of the function.
Collapse Expand Returns

The new NSubject.


NSubject.FromMemory Method (NBuffer, uint, out int)

NSubject.FromMemory Method (NBuffer, uint, out int)
NSubject Class Neurotec.Biometrics Namespace

Creates a new NSubject object from the specified buffer.

C#
public static NSubject FromMemory(NBuffer buffer, uint flags, out int size);
Collapse Expand Parameters
Parameters | Description
NBuffer buffer | The buffer.
uint flags | Bitwise combination of zero or more flags that controls behavior of the function.
out int size | The size of the new NSubject.
Collapse Expand Returns

The new NSubject.


NSubject.FromMemory Method (NBuffer, ushort, ushort)

NSubject.FromMemory Method (NBuffer, ushort, ushort)
NSubject Class Neurotec.Biometrics Namespace

Creates a new NSubject object from the specified buffer with specified format.

C#
public static NSubject FromMemory(NBuffer buffer, ushort formatOwner, ushort formatType);
Collapse Expand Parameters
Parameters | Description
NBuffer buffer | The buffer.
ushort formatOwner | Owner of the buffer format.
ushort formatType | Buffer format type.
Collapse Expand Returns

The new NSubject.


NSubject.FromMemory Method (NBuffer, ushort, ushort, uint)

NSubject.FromMemory Method (NBuffer, ushort, ushort, uint)
NSubject Class Neurotec.Biometrics Namespace

Creates a new NSubject object from the specified buffer with specified format.

C#
public static NSubject FromMemory(NBuffer buffer, ushort formatOwner, ushort formatType, uint flags);
Collapse Expand Parameters
Parameters | Description
NBuffer buffer | The buffer.
ushort formatOwner | Owner of the buffer format.
ushort formatType | Buffer format type.
uint flags | Bitwise combination of zero or more flags that controls behavior of the function.
Collapse Expand Returns

The new NSubject.


NSubject.FromMemory Method (NBuffer, ushort, ushort, uint, out int)

NSubject.FromMemory Method (NBuffer, ushort, ushort, uint, out int)
NSubject Class Neurotec.Biometrics Namespace

Creates a new NSubject object from the specified buffer with specified format.

C#
public static NSubject FromMemory(NBuffer buffer, ushort formatOwner, ushort formatType, uint flags, out int size);
Collapse Expand Parameters
Parameters | Description
NBuffer buffer | The buffer.
ushort formatOwner | Owner of the buffer format.
ushort formatType | Buffer format type.
uint flags | Bitwise combination of zero or more flags that controls behavior of the function.
out int size | The size of the new NSubject.
Collapse Expand Returns

The new NSubject.


NSubject.FromMemory Method (byte[])

NSubject.FromMemory Method (byte[])
NSubject Class Neurotec.Biometrics Namespace

Creates a new NSubject object from the specified buffer.

C#
public static NSubject FromMemory(byte[] buffer);
Collapse Expand Parameters
Parameters | Description
byte[] buffer | The buffer.
Collapse Expand Returns

The new NSubject.


NSubject.FromMemory Method (byte[], ushort, ushort)

NSubject.FromMemory Method (byte[], ushort, ushort)
NSubject Class Neurotec.Biometrics Namespace

Creates a new NSubject object from the specified buffer with specified format.

C#
public static NSubject FromMemory(byte[] buffer, ushort formatOwner, ushort formatType);
Collapse Expand Parameters
Parameters | Description
byte[] buffer | The buffer.
ushort formatOwner | Owner of the buffer format.
ushort formatType | Buffer format type.
Collapse Expand Returns

The new NSubject.


NSubject.FromStream Method (NStream)

NSubject.FromStream Method (NStream)
NSubject Class Neurotec.Biometrics Namespace

Creates a new NSubject object from the specified memory stream.

C#
public static NSubject FromStream(NStream stream);
Collapse Expand Parameters
Parameters | Description
NStream stream | The memory stream.
Collapse Expand Returns

The new NSubject.


NSubject.FromStream Method (NStream, uint)

NSubject.FromStream Method (NStream, uint)
NSubject Class Neurotec.Biometrics Namespace

Creates a new NSubject object from the specified memory stream.

C#
public static NSubject FromStream(NStream stream, uint flags);
Collapse Expand Parameters
Parameters | Description
NStream stream | The memory stream.
uint flags | Bitwise combination of zero or more flags that controls behavior of the function.
Collapse Expand Returns

The new NSubject.


NSubject.FromStream Method (NStream, ushort, ushort)

NSubject.FromStream Method (NStream, ushort, ushort)
NSubject Class Neurotec.Biometrics Namespace

Creates a new NSubject object from the specified memory stream with specified format.

C#
public static NSubject FromStream(NStream stream, ushort formatOwner, ushort formatType);
Collapse Expand Parameters
Parameters | Description
NStream stream | The memory stream.
ushort formatOwner | Owner of the stream format.
ushort formatType | Stream format type.
Collapse Expand Returns

The new NSubject.


NSubject.FromStream Method (NStream, ushort, ushort, uint)

NSubject.FromStream Method (NStream, ushort, ushort, uint)
NSubject Class Neurotec.Biometrics Namespace

Creates a new NSubject object from the specified memory stream with specified format.

C#
public static NSubject FromStream(NStream stream, ushort formatOwner, ushort formatType, uint flags);
Collapse Expand Parameters
Parameters | Description
NStream stream | The memory stream.
ushort formatOwner | Owner of the stream format.
ushort formatType | Stream format type.
uint flags | Bitwise combination of zero or more flags that controls behavior of the function.
Collapse Expand Returns

The new NSubject.


NSubject.GetTemplate Method

NSubject.GetTemplate Method
NSubject Class Neurotec.Biometrics Namespace

Gets the template used by the NSubject.

C#
public NTemplate GetTemplate();
Collapse Expand Returns

The template.


NSubject.GetTemplateBuffer Method ()

NSubject.GetTemplateBuffer Method ()
NSubject Class Neurotec.Biometrics Namespace

Gets the buffer which contains templates for the NSubject.

C#
public NBuffer GetTemplateBuffer();
Collapse Expand Returns

NBuffer with the templates.


NSubject.GetTemplateBuffer Method (ushort, ushort, NVersion)

NSubject.GetTemplateBuffer Method (ushort, ushort, NVersion)
NSubject Class Neurotec.Biometrics Namespace

Gets the buffer which contains templates for the NSubject.

C#
public NBuffer GetTemplateBuffer(ushort formatOwner, ushort formatType, NVersion version);
Collapse Expand Parameters
Parameters | Description
ushort formatOwner | Format owner of biometric data block.
ushort formatType | Format type of biometric data block.
NVersion version | Standard version used for biometric data block.
Collapse Expand Returns

NBuffer with the templates.


NSubject.SetTemplate Method (ANTemplate)

NSubject.SetTemplate Method (ANTemplate)
NSubject Class Neurotec.Biometrics Namespace

Sets ANTemplate to be used by the NSubject.

C#
public void SetTemplate(ANTemplate value);
Collapse Expand Parameters
Parameters | Description
ANTemplate value | Template to set.


NSubject.SetTemplate Method (CbeffRecord)

NSubject.SetTemplate Method (CbeffRecord)
NSubject Class Neurotec.Biometrics Namespace

Sets CbeffRecord to be used by the NSubject.

C#
public void SetTemplate(CbeffRecord value);
Collapse Expand Parameters
Parameters | Description
CbeffRecord value | Record to set.


NSubject.SetTemplate Method (FCRecord)

NSubject.SetTemplate Method (FCRecord)
NSubject Class Neurotec.Biometrics Namespace

Sets FCRecord to be used by the NSubject.

C#
public void SetTemplate(FCRecord value);
Collapse Expand Parameters
Parameters | Description
FCRecord value | Record to set.


NSubject.SetTemplate Method (FIRecord)

NSubject.SetTemplate Method (FIRecord)
NSubject Class Neurotec.Biometrics Namespace

Sets FIRecord to be used by the NSubject.

C#
public void SetTemplate(FIRecord value);
Collapse Expand Parameters
Parameters | Description
FIRecord value | Record to set.


NSubject.SetTemplate Method (FMCRecord)

NSubject.SetTemplate Method (FMCRecord)
NSubject Class Neurotec.Biometrics Namespace

Sets FMCRecord to be used by the NSubject.

C#
public void SetTemplate(FMCRecord value);
Collapse Expand Parameters
Parameters | Description
FMCRecord value | Record to set.


NSubject.SetTemplate Method (FMRecord)

NSubject.SetTemplate Method (FMRecord)
NSubject Class Neurotec.Biometrics Namespace

Sets FMRecord to be used by the NSubject.

C#
public void SetTemplate(FMRecord value);
Collapse Expand Parameters
Parameters | Description
FMRecord value | Record to set.


NSubject.SetTemplate Method (IIRecord)

NSubject.SetTemplate Method (IIRecord)
NSubject Class Neurotec.Biometrics Namespace

Sets IIRecord to be used by the NSubject.

C#
public void SetTemplate(IIRecord value);
Collapse Expand Parameters
Parameters | Description
IIRecord value | Record to set.


NSubject.SetTemplate Method (NTemplate)

NSubject.SetTemplate Method (NTemplate)
NSubject Class Neurotec.Biometrics Namespace

Sets the template to be used by the NSubject.

C#
public void SetTemplate(NTemplate value);
Collapse Expand Parameters
Parameters | Description
NTemplate value | The template.


NSubject.SetTemplateBuffer Method (NBuffer)

NSubject.SetTemplateBuffer Method (NBuffer)
NSubject Class Neurotec.Biometrics Namespace

Sets the buffer to contain templates for the NSubject.

C#
public void SetTemplateBuffer(NBuffer value);
Collapse Expand Parameters
Parameters | Description
NBuffer value | NBuffer with the templates.


NSubject.SetTemplateBuffer Method (NBuffer, ushort, ushort)

NSubject.SetTemplateBuffer Method (NBuffer, ushort, ushort)
NSubject Class Neurotec.Biometrics Namespace

Sets the buffer to contain templates for the NSubject.

C#
public void SetTemplateBuffer(NBuffer value, ushort formatOwner, ushort formatType);
Collapse Expand Parameters
Parameters | Description
NBuffer value | NBuffer with the templates.
ushort formatOwner | Owner of the buffer format.
ushort formatType | Buffer format type.


NSubject.ToANTemplate Method

NSubject.ToANTemplate Method
NSubject Class Neurotec.Biometrics Namespace

Converts NSubject to ANTemplate.

C#
public ANTemplate ToANTemplate(NVersion version, string tot, string dai, string ori, string tcn);
Collapse Expand Parameters
Parameters | Description
NVersion version | Specifies the version of the ANTemplate.
string tot | String which contains transaction type identifier.
string dai | String which contains destination agency identifier.
string ori | String which contains originating agency identifier.
string tcn | String which contains transaction control identifier.
Collapse Expand Returns

ANTemplate object.


NSubject.ToFCRecord Method

NSubject.ToFCRecord Method
NSubject Class Neurotec.Biometrics Namespace

Converts NSubject to FCRecord.

C#
public FCRecord ToFCRecord(BdifStandard standard, NVersion version);
Collapse Expand Parameters
Parameters | Description
BdifStandard standard | Specifies the standard of the FCRecord.
NVersion version | Specifies the version of the FCRecord.
Collapse Expand Returns

FCRecord object.


NSubject.ToFIRecord Method

NSubject.ToFIRecord Method
NSubject Class Neurotec.Biometrics Namespace

Converts NSubject to FIRecord.

C#
public FIRecord ToFIRecord(BdifStandard standard, NVersion version);
Collapse Expand Parameters
Parameters | Description
BdifStandard standard | Specifies the standard of the FIRecord.
NVersion version | Specifies the version of the FIRecord.
Collapse Expand Returns

FIRecord object.


NSubject.ToFMCRecord Method

NSubject.ToFMCRecord Method
NSubject Class Neurotec.Biometrics Namespace

Converts NSubject to FMCRecord.

C#
public FMCRecord ToFMCRecord(BdifStandard standard, NVersion version, FmcrMinutiaFormat minutiaFormat);
Collapse Expand Parameters
Parameters | Description
BdifStandard standard | Specifies the standard of the FMCRecord.
NVersion version | Specifies the version of the FMCRecord.
FmcrMinutiaFormat minutiaFormat | The minutia format.
Collapse Expand Returns

FIRecord object.


NSubject.ToFMRecord Method (BdifStandard, NVersion)

NSubject.ToFMRecord Method (BdifStandard, NVersion)
NSubject Class Neurotec.Biometrics Namespace

Converts NSubject to FMRecord.

C#
public FMRecord ToFMRecord(BdifStandard standard, NVersion version);
Collapse Expand Parameters
Parameters | Description
BdifStandard standard | Specifies the standard of the FMRecord.
NVersion version | Specifies the version of the FMRecord.
Collapse Expand Returns

FMRecord object.


NSubject.ToFMRecord Method (BdifStandard, NVersion, uint)

NSubject.ToFMRecord Method (BdifStandard, NVersion, uint)
NSubject Class Neurotec.Biometrics Namespace

Converts NSubject to FMRecord.

C#
public FMRecord ToFMRecord(BdifStandard standard, NVersion version, uint flags);
Collapse Expand Parameters
Parameters | Description
BdifStandard standard | Specifies the standard of the FMRecord.
NVersion version | Specifies the version of the FMRecord.
uint flags | Bitwise combination of zero or more flags that controls behavior of the constructor.
Collapse Expand Returns

FMRecord object.

Collapse Expand Remarks

The following flags are supported: FlagDoNotCheckCbeffProductId, FlagAllowOutOfBoundsFeatures.


NSubject.ToIIRecord Method

NSubject.ToIIRecord Method
NSubject Class Neurotec.Biometrics Namespace

Converts NSubject to IIRecord.

C#
public IIRecord ToIIRecord(BdifStandard standard, NVersion version);
Collapse Expand Parameters
Parameters | Description
BdifStandard standard | Specifies one of BdifStandard values.
NVersion version | Specifies the version of the IIRecord.
Collapse Expand Returns

IIRecord object.

Collapse Expand Remarks

IIRecord object.


NSubject.Error Property

NSubject.Error Property
NSubject Class Neurotec.Biometrics Namespace

Gets the exception thrown by the subject.

C#
public Exception Error;


NSubject.Faces Property

NSubject.Faces Property
NSubject Class Neurotec.Biometrics Namespace

Retrieves the collection of NFace objects.

C#
public FaceCollection Faces;


NSubject.Fingers Property

NSubject.Fingers Property
NSubject Class Neurotec.Biometrics Namespace

Retrieves the collection of NFinger objects.

C#
public FingerCollection Fingers;


NSubject.Gender Property

NSubject.Gender Property
NSubject Class Neurotec.Biometrics Namespace

Gets or sets the gender value of the subject.

C#
public NGender Gender;


NSubject.Id Property

NSubject.Id Property
NSubject Class Neurotec.Biometrics Namespace

Gets or sets the ID of the subject.

C#
public string Id;


NSubject.Irises Property

NSubject.Irises Property
NSubject Class Neurotec.Biometrics Namespace

Retrieves the collection of NIris objects.

C#
public IrisCollection Irises;


NSubject.IsMultipleSubjects Property

NSubject.IsMultipleSubjects Property
NSubject Class Neurotec.Biometrics Namespace

Gets or sets whether the subject consists of multiple NSubjects.

C#
public bool IsMultipleSubjects;
Collapse Expand Remarks

Multiple subjects are involved when, for example, a single image contains several faces. After segmentation, related subjects are generated from it. Currently this feature is provided only for image, in future in will involve voice files.


NSubject.MatchingResults Property

NSubject.MatchingResults Property
NSubject Class Neurotec.Biometrics Namespace

Retrieves the collection of subject's matching results.

C#
public MatchingResultCollection MatchingResults;


NSubject.MissingEyes Property

NSubject.MissingEyes Property
NSubject Class Neurotec.Biometrics Namespace

Retrieves the collection of NEPosition objects representing missing eye positions.

C#
public MissingEyeCollection MissingEyes;


NSubject.MissingFingers Property

NSubject.MissingFingers Property
NSubject Class Neurotec.Biometrics Namespace

Retrieves the collection of NFPosition objects representing missing finger positions.

C#
public MissingFingerCollection MissingFingers;


NSubject.NativeType Property

NSubject.NativeType Property
NSubject Class Neurotec.Biometrics Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NSubject.Palms Property

NSubject.Palms Property
NSubject Class Neurotec.Biometrics Namespace

Retrieves the collection of NPalm objects.

C#
public PalmCollection Palms;


NSubject.QueryString Property

NSubject.QueryString Property
NSubject Class Neurotec.Biometrics Namespace

Gets or sets the query string for the subject.

C#
public string QueryString;
Property value

Query string is a string which can be invoked to retrieve a corresponding NSubject.


NSubject.RelatedSubjects Property

NSubject.RelatedSubjects Property
NSubject Class Neurotec.Biometrics Namespace

Retrieves the collection of related NSubject objects.

C#
public RelatedSubjectCollection RelatedSubjects;


NSubject.Signatures Property

NSubject.Signatures Property
NSubject Class Neurotec.Biometrics Namespace

Retrieves the collection of NSignature objects.

C#
public SignatureCollection Signatures;


NSubject.Statistics Property

NSubject.Statistics Property
NSubject Class Neurotec.Biometrics Namespace

Gets the property bag containing the subject's statistics (diagnostic information).

C#
public NPropertyBag Statistics;


NSubject.Status Property

NSubject.Status Property
NSubject Class Neurotec.Biometrics Namespace

Gets or sets the biometric status of the subject.

C#
public NBiometricStatus Status;


NSubject.Voices Property

NSubject.Voices Property
NSubject Class Neurotec.Biometrics Namespace

Retrieves the collection of NVoice objects.

C#
public VoiceCollection Voices;


NTemplate Class

NTemplate Class
NObject Delegates NObject Events NObject Fields Legend Members Methods NDisposable Methods NDisposable Properties

Provides functionality for packing, unpacking and editing Neurotechnology Templates (NTemplates).

C#
public sealed class NTemplate : NObject, ICloneable;
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NTemplate Class
Name | Description
CalculateSize | Calculates the size of a packed NTemplate containing fingers, faces. irises and palms templates of the specified size.
Check | Checks if format of packed NTemplate format is correct.
Clear | Removes all NFRecord objects.
GetSize | Gets the size of packed NTemplate.
Merge | Merges several NXTemplates from buffer array.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NTemplate Class
Name | Description
Faces | Gets NLTemplate object.
Fingers | Gets NFTemplate object.
Irises | Gets NETemplate object.
NativeType | Defines the native type of the object.
Palms | Gets NFTemplate object.
Voices | Gets NSTemplate object.
Container

File: NTemplate.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


NTemplate.NTemplate Constructor ()

NTemplate.NTemplate Constructor ()
NTemplate Class Neurotec.Biometrics Namespace

Initializes a new instance of the NTemplate class.

C#
public NTemplate();


NTemplate.NTemplate Constructor (NBuffer)

NTemplate.NTemplate Constructor (NBuffer)
NTemplate Class Neurotec.Biometrics Namespace

Initializes a new instance of the NTemplate class from byte array.

C#
public NTemplate(NBuffer buffer);
Collapse Expand Parameters
Parameters | Description
NBuffer buffer | NBuffer that contains packed NTemplate.


NTemplate.NTemplate Constructor (NBuffer, uint)

NTemplate.NTemplate Constructor (NBuffer, uint)
NTemplate Class Neurotec.Biometrics Namespace

Initializes a new instance of the NTemplate class from byte array.

C#
public NTemplate(NBuffer buffer, uint flags);
Collapse Expand Parameters
Parameters | Description
NBuffer buffer | NBuffer that contains packed NTemplate.
uint flags | Reserved for future use. Must be zero.


NTemplate.NTemplate Constructor (NBuffer, uint, out int)

NTemplate.NTemplate Constructor (NBuffer, uint, out int)
NTemplate Class Neurotec.Biometrics Namespace

Initializes a new instance of the NTemplate class from byte array.

C#
public NTemplate(NBuffer buffer, uint flags, out int size);
Collapse Expand Parameters
Parameters | Description
NBuffer buffer | NBuffer that contains packed NTemplate.
uint flags | Reserved for future use. Must be zero.
out int size | [out] NTemplate size.


NTemplate.NTemplate Constructor (byte[])

NTemplate.NTemplate Constructor (byte[])
NTemplate Class Neurotec.Biometrics Namespace

Initializes a new instance of the NTemplate class from byte array.

C#
public NTemplate(byte[] buffer);
Collapse Expand Parameters
Parameters | Description
byte[] buffer | Byte array that contains packed NTemplate.


NTemplate.NTemplate Constructor (uint)

NTemplate.NTemplate Constructor (uint)
NTemplate Class Neurotec.Biometrics Namespace

Initializes a new instance of the NTemplate class.

C#
public NTemplate(uint flags);
Collapse Expand Parameters
Parameters | Description
uint flags | Bitwise combination of zero or more flags that controls behavior of the constructor. This parameter is reserved, must be zero.


NTemplate.CalculateSize Method

NTemplate.CalculateSize Method
NTemplate Class Neurotec.Biometrics Namespace

Calculates the size of a packed NTemplate containing fingers, faces. irises and palms templates of the specified size.

C#
public static int CalculateSize(int fingersTemplateSize, int facesTemplateSize, int irisesTemplateSize, int palmsTemplateSize, int voicesTemplateSize);
Collapse Expand Parameters
Parameters | Description
int fingersTemplateSize | Size of packed NFTemplate.
int facesTemplateSize | Size of packed NLTemplate.
int irisesTemplateSize | Size of packed NETemplate.
int palmsTemplateSize | Size of packed NFTemplate.
int voicesTemplateSize | Size of packed NSTemplate.
Collapse Expand Returns

The value of NTemplate size.


NTemplate.Check Method (NBuffer)

NTemplate.Check Method (NBuffer)
NTemplate Class Neurotec.Biometrics Namespace

Checks if format of packed NTemplate format is correct.

C#
public static void Check(NBuffer buffer);
Collapse Expand Parameters
Parameters | Description
NBuffer buffer | NBuffer that contains packed NTemplate.


NTemplate.Check Method (byte[])

NTemplate.Check Method (byte[])
NTemplate Class Neurotec.Biometrics Namespace

Checks if format of packed NTemplate format is correct.

C#
public static void Check(byte[] buffer);
Collapse Expand Parameters
Parameters | Description
byte[] buffer | Memory buffer that contains packed NTemplate.
Collapse Expand Returns

True if NTemplate format is correct; false otherwise.


NTemplate.Clear Method

NTemplate.Clear Method
NTemplate Class Neurotec.Biometrics Namespace

Removes all NFRecord objects.

C#
public void Clear();


NTemplate.GetSize Method (NBuffer)

NTemplate.GetSize Method (NBuffer)
NTemplate Class Neurotec.Biometrics Namespace

Gets the size of packed NTemplate.

C#
public static int GetSize(NBuffer buffer);
Collapse Expand Parameters
Parameters | Description
NBuffer buffer | Packed NTemplate.
Collapse Expand Returns

Size of NTemplate.


NTemplate.GetSize Method (byte[])

NTemplate.GetSize Method (byte[])
NTemplate Class Neurotec.Biometrics Namespace

Gets the size of packed NTemplate.

C#
public static int GetSize(byte[] buffer);
Collapse Expand Parameters
Parameters | Description
byte[] buffer | Packed NTemplate.
Collapse Expand Returns

Size of NTemplate.


NTemplate.Merge Method (NBuffer[])

NTemplate.Merge Method (NBuffer[])
NTemplate Class Neurotec.Biometrics Namespace

Merges several NXTemplates from buffer array.

C#
public static NTemplate Merge(NBuffer[] buffers);
Collapse Expand Parameters
Parameters | Description
NBuffer[] buffers | Array of buffers.
Collapse Expand Returns

NTemplate of merged NXTemplates.


NTemplate.Merge Method (NBuffer[], uint)

NTemplate.Merge Method (NBuffer[], uint)
NTemplate Class Neurotec.Biometrics Namespace

Merges several NXTemplates from buffer array.

C#
public static NTemplate Merge(NBuffer[] buffers, uint flags);
Collapse Expand Parameters
Parameters | Description
NBuffer[] buffers | Array of buffers.
uint flags | Bitwise combination of zero or more flags that controls behavior of the constructor. This parameter is reserved, must be zero.
Collapse Expand Returns

NTemplate of merged NXTemplates.


NTemplate.Faces Property

NTemplate.Faces Property
NTemplate Class Neurotec.Biometrics Namespace

Gets NLTemplate object.

C#
public NLTemplate Faces;
Property value

A NLTemplate object.


NTemplate.Fingers Property

NTemplate.Fingers Property
NTemplate Class Neurotec.Biometrics Namespace

Gets NFTemplate object.

C#
public NFTemplate Fingers;
Property value

A NFTemplate object.


NTemplate.Irises Property

NTemplate.Irises Property
NTemplate Class Neurotec.Biometrics Namespace

Gets NETemplate object.

C#
public NETemplate Irises;
Property value

A NETemplate object.


NTemplate.NativeType Property

NTemplate.NativeType Property
NTemplate Class Neurotec.Biometrics Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NTemplate.Palms Property

NTemplate.Palms Property
NTemplate Class Neurotec.Biometrics Namespace

Gets NFTemplate object.

C#
public NFTemplate Palms;
Property value

A NFTemplate object.


NTemplate.Voices Property

NTemplate.Voices Property
NTemplate Class Neurotec.Biometrics Namespace

Gets NSTemplate object.

C#
public NSTemplate Voices;
Property value

A NSTemplate object.


Neurotec.Biometrics.NBiometricCaptureOptions Enumeration

Neurotec.Biometrics.NBiometricCaptureOptions Enumeration

Enumerates biometric capture options.

C#
[Flags]
public enum NBiometricCaptureOptions {
  None = 0,
  Manual = 1,
  Stream = 2
}
Collapse Expand Members
Members | Description
None = 0 | Indicates that capture option is not specified.
Manual = 1 | Indicates manual capture.
Stream = 2 | Indicates stream capture.
Container

File: NBiometric.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


Neurotec.Biometrics.NBiometricStatus Enumeration

Neurotec.Biometrics.NBiometricStatus Enumeration

Enumerates biometric status values. These values are returned by NBiometricDevice.

C#
[Serializable]
public enum NBiometricStatus {
  None = 0,
  Ok = 1,
  Canceled = 2,
  Timeout = 3,
  SourceMissing = 9,
  CleaningNeeded = 10,
  ObjectsNotRemoved = 20,
  ObjectMissing = 21,
  ObjectNotFound = 22,
  TooFewObjects = 23,
  TooManyObjects = 24,
  BadObjectSequence = 25,
  SpoofDetected = 30,
  MaskDetected = 39,
  BadObject = 40,
  BadDynamicRange = 41,
  BadExposure = 42,
  BadSharpness = 43,
  TooNoisy = 44,
  BadContrast = 45,
  BadLighting = 46,
  Occlusion = 47,
  BadPose = 48,
  TooFewFeatures = 49,
  TooSoft = 51,
  TooHard = 52,
  MotionBlur = 53,
  CompressionArtifacts = 54,
  BadPosition = 60,
  TooNorth = 61,
  TooEast = 62,
  TooSouth = 63,
  TooWest = 64,
  TooClose = 65,
  TooFar = 66,
  BadSpeed = 70,
  TooSlow = 71,
  TooFast = 72,
  BadSize = 80,
  TooShort = 81,
  TooLong = 82,
  TooNarrow = 83,
  TooWide = 84,
  TooSkewed = 91,
  WrongDirection = 92,
  WrongHand = 93,
  Tips = 94,
  TooFewSamples = 100,
  IncompatibleSamples = 101,
  SourceNotFound = 501,
  IncompatibleSource = 502,
  IdNotFound = 601,
  DuplicateId = 602,
  MatchNotFound = 610,
  DuplicateFound = 611,
  Conflict = 612,
  InvalidOperations = 900,
  InvalidId = 901,
  InvalidQuery = 902,
  InvalidPropertyValue = 903,
  InvalidFieldValue = 904,
  InvalidSampleResolution = 905,
  OperationNotSupported = 990,
  OperationNotActivated = 991,
  SourceError = 996,
  CaptureError = 997,
  CommunicationError = 998,
  InternalError = 999
}
Collapse Expand Members
Members | Description
None = 0 |
Ok = 1 | Indicates succeeded operation.
Canceled = 2 | Indicates canceled operation.
Timeout = 3 | Indicates that operation timed-out.
SourceMissing = 9 | Indicates that NFace or NFinger was not set with the image or capture device was not set for capture operation.
CleaningNeeded = 10 | Indicates that biometric device should be cleaned.
ObjectsNotRemoved = 20 | Indicates that object(s) was not removed after/before NBiometricDevice finished/started capturing process, usually it is returned when finger is placed on fingerprint scanner sensor before capturing operation is started.
ObjectMissing = 21 | Indicates that object was marked as missing e.g. when you capture 4 fingerprints and you set one of them as missing (that NFinger will have this status), then scanner will expect only 3 fingers.
ObjectNotFound = 22 | Indicates that object(s) (e.g. face or iris) was not found – object(s) is found if it passes Confidence Threshold value.
TooFewObjects = 23 |
TooManyObjects = 24 | Indicates that too many objects were provided for NBiometricDevice to perform operation.
BadObjectSequence = 25 | Indicates sequence of bad object(s).
SpoofDetected = 30 | Indicates that spoof object was detected.
MaskDetected = 39 | Indicates that mask detected
BadObject = 40 | Indicates bad object (quality of detected object is lower than Quality Threshold).
BadDynamicRange = 41 | Indicates that dynamic range of image is bad.
BadExposure = 42 | Indicates bad exposure (e.g. too low light).
BadSharpness = 43 | Indicates that image is too sharpen or too blurred.
TooNoisy = 44 | Indicates that image is too noisy.
BadContrast = 45 | Indicates bad contrast.
BadLighting = 46 | Indicates bad lighting or lighting artifacts.
Occlusion = 47 | Indicates that part of the face is not visible(e.g. forehead covered by a hat or long hair).
BadPose = 48 | Indicates bad pose(e.g. large deviation from frontal face position).
TooFewFeatures = 49 | Indicates that there are too few features to be extracted (e.g. fingerprint has less minutiaes than minimum number or voice recording is too short).
TooSoft = 51 | Indicates that fingerprint was placed too soft on a device.
TooHard = 52 | Indicates that fingerprint was placed too hard on a device.
MotionBlur = 53 | Indicates how much face is blurred out.
CompressionArtifacts = 54 | Indicates a presence of lossy compression artifacts.
BadPosition = 60 | Indicates bad fingerprint position.
TooNorth = 61 | Indicated that object was too north from device.
TooEast = 62 | Indicated that object was too east from device.
TooSouth = 63 | Indicated that object was too south from device.
TooWest = 64 | Indicated that object was too west from device.
TooClose = 65 | Indicated that object was too close to device.
TooFar = 66 | Indicated that object was too far from device.
BadSpeed = 70 |
TooSlow = 71 |
TooFast = 72 |
BadSize = 80 | Indicates object's bad size.
TooShort = 81 | Indicates that object is too short for NBiometricDevice to perform operation.
TooLong = 82 | Indicates that object is too long for NBiometricDevice to perform operation.
TooNarrow = 83 | Indicates that object is too narrow for NBiometricDevice to perform operation.
TooWide = 84 | Indicates that object is too wide for NBiometricDevice to perform operation.
TooSkewed = 91 | Indicates that object is too skewed.
WrongDirection = 92 | Indicates that object was moving to wrong direction.
WrongHand = 93 | Indicates that the wrong hand was used.
Tips = 94 | Indicates that tips were detected.
TooFewSamples = 100 | Indicates that some samples are mutually incompatible.
IncompatibleSamples = 101 | Indicates that samples are incompatible i.e. images used for generalization are not of the same size.
SourceNotFound = 501 | Indicates that source was not found i.e. image path set to NFace, NFinger, etc. does not exist.
IncompatibleSource = 502 | Indicates that file set as an image to NFace, NFinger, etc. object is not an image or is of the format which is not supported.
IdNotFound = 601 | NSubject with specified Id value was not found.
DuplicateId = 602 | The Id specified in NSubject already exists in the database.
MatchNotFound = 610 | Match was not found.
DuplicateFound = 611 | Indicates that duplicate was found.
Conflict = 612 | Indicates conflict.
InvalidOperations = 900 | Indicates that operation is not possible for the object.
InvalidId = 901 | Indicates invalid Id value i.e. signs “?”, “!” are not allowed in Id.
InvalidQuery = 902 | Query specified in the NSubject cannot be executed.
InvalidPropertyValue = 903 | Indicates invalid property value.
InvalidFieldValue = 904 | Indicates invalid field value.
InvalidSampleResolution = 905 | Indicates that image resolution is not set or is set with value lower than 250.
OperationNotSupported = 990 | Indicates that operation cannot be use with that object.
OperationNotActivated = 991 | Indicates that functionality is not enabled, as required licenses were not obtained.
SourceError = 996 | Indicates that error happened during video file or stream reading.
CaptureError = 997 | Indicates capture error.
CommunicationError = 998 | Indicates communication error.
InternalError = 999 | Indicates internal error.
Container

File: NBiometricTypes.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


Neurotec.Biometrics.NBiometricSubtype Enumeration

Neurotec.Biometrics.NBiometricSubtype Enumeration

Specifies the subtype of biometric data.

C#
[Serializable]
[Flags]
public enum NBiometricSubtype {
  None = 0x000000,
  Left = 0x000001,
  Right = 0x000002,
  LeftThumb = 0x000004,
  LeftPointerFinger = 0x000008,
  LeftMiddleFinger = 0x000010,
  LeftRingFinger = 0x000020,
  LeftLittleFinger = 0x000040,
  RightThumb = 0x000080,
  RightPointerFinger = 0x000100,
  RightMiddleFinger = 0x000200,
  RightRingFinger = 0x000400,
  RightLittleFinger = 0x000800,
  LeftPalm = 0x001000,
  LeftBackOfHand = 0x002000,
  LeftWrist = 0x004000,
  RightPalm = 0x008000,
  RightBackOfHand = 0x010000,
  RightWrist = 0x020000
}
Collapse Expand Members
Members | Description
None = 0x000000 | Undefined.
Left = 0x000001 | Left.
Right = 0x000002 | Right.
LeftThumb = 0x000004 | Left thumb.
LeftPointerFinger = 0x000008 | Left pointer finger.
LeftMiddleFinger = 0x000010 | Left pointer finger.
LeftRingFinger = 0x000020 | Left ring finger.
LeftLittleFinger = 0x000040 | Left little finger.
RightThumb = 0x000080 | Right thumb.
RightPointerFinger = 0x000100 | Right pointer finger.
RightMiddleFinger = 0x000200 | Right middle finger.
RightRingFinger = 0x000400 | Right ring finger.
RightLittleFinger = 0x000800 | Right little finger.
LeftPalm = 0x001000 | Left palm.
LeftBackOfHand = 0x002000 | Left back of hand.
LeftWrist = 0x004000 | Left wrist.
RightPalm = 0x008000 | Right palm.
RightBackOfHand = 0x010000 | Right back of hand.
RightWrist = 0x020000 | Right wrist.
Container

File: NBiometricTypes.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


Neurotec.Biometrics.NBiometricType Enumeration

Neurotec.Biometrics.NBiometricType Enumeration

Specifies the type of biometric data.

C#
[Serializable]
[Flags]
public enum NBiometricType {
  None = 0x000000,
  MultipleBiometrics = 0x000001,
  Face = 0x000002,
  FacialFeatures = Face,
  Voice = 0x000004,
  Finger = 0x000008,
  Fingerprint = Finger,
  Iris = 0x000010,
  Retina = 0x000020,
  HandGeometry = 0x000040,
  SignatureOrSign = 0x000080,
  SignatureDynamics = SignatureOrSign,
  Keystroke = 0x000100,
  KeystrokeDynamics = Keystroke,
  LipMovement = 0x000200,
  ThermalFace = 0x000400,
  ThermalHand = 0x000800,
  ThermalFaceImage = ThermalFace,
  ThermalHandImage = ThermalHand,
  Gait = 0x001000,
  Scent = 0x002000,
  BodyOdor = Scent,
  Dna = 0x004000,
  Ear = 0x008000,
  EarShape = Ear,
  FingerGeometry = 0x010000,
  Palm = 0x020000,
  PalmPrint = Palm,
  Vein = 0x040000,
  VeinPattern = Vein,
  Foot = 0x080000,
  FootPrint = Foot,
  PalmGeometry = 0x100000,
  All = 0x1FFFFF
}
Collapse Expand Members
Members | Description
None = 0x000000 | Undefined.
MultipleBiometrics = 0x000001 | Multiple biometrics.
Face = 0x000002 | Face matching.
FacialFeatures = Face | Facial features (same as face).
Voice = 0x000004 | Voice matching.
Finger = 0x000008 | Finger matching.
Fingerprint = Finger | Fingerprint matching (same as finger).
Iris = 0x000010 | Iris matching.
Retina = 0x000020 | Retina matching.
HandGeometry = 0x000040 | Hand geometry.
SignatureOrSign = 0x000080 | Signature or sign.
SignatureDynamics = SignatureOrSign | Signature dynamics (same as signature or sign).
Keystroke = 0x000100 | Keystroke matching.
KeystrokeDynamics = Keystroke | Keystroke dynamics (same as keystroke).
LipMovement = 0x000200 | Lip movement.
ThermalFace = 0x000400 | Thermal face matching.
ThermalHand = 0x000800 | Thermal hand matching.
ThermalFaceImage = ThermalFace | Thermal face image (same as thermal face).
ThermalHandImage = ThermalHand | Thermal hand image (same as thermal hand).
Gait = 0x001000 | Gait matching.
Scent = 0x002000 | Scent matching.
BodyOdor = Scent | Body odor (same as scent).
Dna = 0x004000 | DNA matching.
Ear = 0x008000 | Ear matching.
EarShape = Ear | Ear shape (same as ear).
FingerGeometry = 0x010000 | Finger geometry.
Palm = 0x020000 | Palm matching.
PalmPrint = Palm | Palm print (same as palm).
Vein = 0x040000 | Vein matching.
VeinPattern = Vein | Vein pattern (same as vein).
Foot = 0x080000 | Foot matching.
FootPrint = Foot | Foot print (same as foot).
PalmGeometry = 0x100000 | Palm geometry.
All = 0x1FFFFF | All biometric types.
Container

File: NBiometricTypes.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


Neurotec.Biometrics.NEImageType Enumeration

Neurotec.Biometrics.NEImageType Enumeration

Enumerates iris image types.

C#
[Serializable]
public enum NEImageType {
  Uncropped = 1,
  Vga = 2,
  Cropped = 3,
  CroppedAndMasked = 7
}
Collapse Expand Members
Members | Description
Uncropped = 1 | Indicates an uncropped image.
Vga = 2 | Indicates a VGA image.
Cropped = 3 | Indicates a cropped image.
CroppedAndMasked = 7 | Indicates a cropped and masked image.
Container

File: NBiometricTypes.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


Neurotec.Biometrics.NEPosition Enumeration

Neurotec.Biometrics.NEPosition Enumeration

Holds information on iris image position.

C#
[Serializable]
public enum NEPosition {
  Unknown = 0,
  Right = 1,
  Left = 2,
  Both = 3
}
Collapse Expand Remarks

When both eyes are returned (Both), it can be cropped using NImage.Crop method. Rectangle coordinates can be retrieved using NEAttributes.BoundingRect property.

Collapse Expand Members
Members | Description
Unknown = 0 | Unknown iris position.
Right = 1 | Right eye.
Left = 2 | Left eye.
Both = 3 | Both eyes.
Container

File: NBiometricTypes.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


Neurotec.Biometrics.NFImpressionType Enumeration

Neurotec.Biometrics.NFImpressionType Enumeration

Specifies the impression types.

C#
[Serializable]
public enum NFImpressionType {
  LiveScanPlain = 0,
  LiveScanRolled = 1,
  NonliveScanPlain = 2,
  NonliveScanRolled = 3,
  LatentImpression = 4,
  LatentTracing = 5,
  LatentPhoto = 6,
  LatentLift = 7,
  LiveScanVerticalSwipe = 8,
  Swipe = LiveScanVerticalSwipe,
  LiveScanContactless = 9,
  LiveScanPalm = 10,
  NonliveScanPalm = 11,
  LatentPalmImpression = 12,
  LatentPalmTracing = 13,
  LatentPalmPhoto = 14,
  LatentPalmLift = 15,
  LiveScanOpticalContactPlain = 20,
  LiveScanOpticalContactRolled = 21,
  LiveScanNonOpticalContactPlain = 22,
  LiveScanNonOpticalContactRolled = 23,
  LiveScanOpticalContactlessPlain = 24,
  LiveScanOpticalContactlessRolled = 25,
  LiveScanNonOpticalContactlessPlain = 26,
  LiveScanNonOpticalContactlessRolled = 27,
  Other = 28,
  Unknown = 29
}
Collapse Expand Members
Members | Description
LiveScanPlain = 0 | Live-scanned plain fingerprint.
LiveScanRolled = 1 | Live-scanned rolled fingerprint.
NonliveScanPlain = 2 | Nonlive-scanned (from paper) plain fingerprint.
NonliveScanRolled = 3 | Nonlive-scanned (from paper) rolled fingerprint.
LatentImpression = 4 | Latent impression fingerprint.
LatentTracing = 5 | Latent tracing fingerprint.
LatentPhoto = 6 | Latent photo fingerprint.
LatentLift = 7 | Latent lift fingerprint.
LiveScanVerticalSwipe = 8 | Live-scanned fingerprint by sliding the finger across a "swipe" sensor.
Swipe = LiveScanVerticalSwipe | Live-scanned fingerprint by sliding the finger across a "swipe" sensor.
LiveScanContactless = 9 | Live-scanned fingerprint using contactless device.
LiveScanPalm = 10 | Live scanned palm.
NonliveScanPalm = 11 | Non-live scanned palm.
LatentPalmImpression = 12 | Latent palm impression.
LatentPalmTracing = 13 | Latent palm tracing.
LatentPalmPhoto = 14 | Latent palm photo.
LatentPalmLift = 15 | Latent palm lift.
LiveScanOpticalContactPlain = 20 | Live plain optical scan with contact.
LiveScanOpticalContactRolled = 21 | Live rolled optical scan with contact.
LiveScanNonOpticalContactPlain = 22 | Live plain non-optical scan with contact.
LiveScanNonOpticalContactRolled = 23 | Live rolled non-optical scan with contact.
LiveScanOpticalContactlessPlain = 24 | Live plain optical contactless scan.
LiveScanOpticalContactlessRolled = 25 | Live rolled optical contactless scan.
LiveScanNonOpticalContactlessPlain = 26 | Live plain non-optical contactless scan.
LiveScanNonOpticalContactlessRolled = 27 | Live rolled non-optical contactless scan.
Other = 28 | Other impression types.
Unknown = 29 | Unknown impression type.
Container

File: NBiometricTypes.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


Neurotec.Biometrics.NFMinutiaFormat Enumeration

Neurotec.Biometrics.NFMinutiaFormat Enumeration

Specifies minutia format.

C#
[Serializable]
[Flags]
public enum NFMinutiaFormat {
  None = 0,
  HasQuality = 1,
  HasCurvature = 2,
  HasG = 4
}
Collapse Expand Members
Members | Description
None = 0 | None of other values.
HasQuality = 1 | Indicates that Neurotec.Biometrics.NFMinutia.Quality field contains meaningful value and is preserved during unpacking/packing of NFRecord.
HasCurvature = 2 | Indicates that Neurotec.Biometrics.NFMinutia.Curvature field contains meaningful value and is preserved during unpacking/packing of NFRecord.
HasG = 4 | Indicates that Neurotec.Biometrics.NFMinutia.G field contains meaningful value and is preserved during unpacking/packing of NFRecord.
Container

File: NBiometricTypes.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


Neurotec.Biometrics.NFMinutiaType Enumeration

Neurotec.Biometrics.NFMinutiaType Enumeration

Specifies types of minutia.

C#
[Serializable]
public enum NFMinutiaType {
  Unknown = 0,
  End = 1,
  Bifurcation = 2,
  Other = 3
}
Collapse Expand Members
Members | Description
Unknown = 0 | The type of the minutia is unknown.
End = 1 | The minutia that is an end of a ridge.
Bifurcation = 2 | The minutia that is a bifurcation of a ridge.
Other = 3 | Other.
Container

File: NBiometricTypes.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


Neurotec.Biometrics.NFPatternClass Enumeration

Neurotec.Biometrics.NFPatternClass Enumeration

Specifies pattern class of the fingerprint.

C#
[Serializable]
public enum NFPatternClass {
  Unknown = 0,
  PlainArch = 1,
  TentedArch = 2,
  RadialLoop = 3,
  UlnarLoop = 4,
  PlainWhorl = 5,
  CentralPocketLoop = 6,
  DoubleLoop = 7,
  AccidentalWhorl = 8,
  Whorl = 9,
  RightSlantLoop = 10,
  LeftSlantLoop = 11,
  Scar = 12,
  Amputation = 15
}
Collapse Expand Remarks

This enumeration is implemented according to ANSI/NIST-ITL 1-2000 standard.

Collapse Expand Members
Members | Description
Unknown = 0 | Unknown pattern class.
PlainArch = 1 | Plain arch pattern class.
TentedArch = 2 | Tented arch pattern class.
RadialLoop = 3 | Radial loop pattern class.
UlnarLoop = 4 | Ulnar loop pattern class.
PlainWhorl = 5 | Plain whorl pattern class.
CentralPocketLoop = 6 | Central pocket loop pattern class.
DoubleLoop = 7 | Double loop pattern class.
AccidentalWhorl = 8 | Accidental whorl pattern class.
Whorl = 9 | Whorl pattern class.
RightSlantLoop = 10 | Right slant loop pattern class.
LeftSlantLoop = 11 | Left slant loop pattern class.
Scar = 12 | Scar. Pattern class is not available.
Amputation = 15 | Amputation. Pattern class is not available.
Container

File: NBiometricTypes.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


Neurotec.Biometrics.NFPosition Enumeration

Neurotec.Biometrics.NFPosition Enumeration

Specifies finger position.

C#
[Serializable]
public enum NFPosition {
  Unknown = 0,
  RightThumb = 1,
  RightIndexFinger = 2,
  RightIndex = RightIndexFinger,
  RightMiddleFinger = 3,
  RightMiddle = RightMiddleFinger,
  RightRingFinger = 4,
  RightRing = RightRingFinger,
  RightLittleFinger = 5,
  RightLittle = RightLittleFinger,
  LeftThumb = 6,
  LeftIndexFinger = 7,
  LeftIndex = LeftIndexFinger,
  LeftMiddleFinger = 8,
  LeftMiddle = LeftMiddleFinger,
  LeftRingFinger = 9,
  LeftRing = LeftRingFinger,
  LeftLittleFinger = 10,
  LeftLittle = LeftLittleFinger,
  PlainRightThumb = 11,
  PlainLeftThumb = 12,
  PlainRightFourFingers = 13,
  PlainLeftFourFingers = 14,
  PlainThumbs = 15,
  UnknownPalm = 20,
  RightFullPalm = 21,
  RightWritersPalm = 22,
  LeftFullPalm = 23,
  LeftWritersPalm = 24,
  RightLowerPalm = 25,
  RightUpperPalm = 26,
  LeftLowerPalm = 27,
  LeftUpperPalm = 28,
  RightOther = 29,
  LeftOther = 30,
  RightInterdigital = 31,
  RightThenar = 32,
  RightHypothenar = 33,
  LeftInterdigital = 34,
  LeftThenar = 35,
  LeftHypothenar = 36,
  RightIndexMiddleFingers = 40,
  RightMiddleRingFingers = 41,
  RightRingLittleFingers = 42,
  LeftIndexMiddleFingers = 43,
  LeftMiddleRingFingers = 44,
  LeftRingLittleFingers = 45,
  RightIndexLeftIndexFingers = 46,
  RightIndexMiddleRingFingers = 47,
  RightMiddleRingLittleFingers = 48,
  LeftIndexMiddleRingFingers = 49,
  LeftMiddleRingLittleFingers = 50,
  UnknownTwoFingers = -2,
  UnknownThreeFingers = -3,
  UnknownFourFingers = -4,
  UnknownLatentFingers = -5
}
Collapse Expand Members
Members | Description
Unknown = 0 | Unknown finger.
RightThumb = 1 | Thumb of the right hand.
RightIndexFinger = 2 | Index finger of the right hand.
RightIndex = RightIndexFinger | Index finger of the right hand.
RightMiddleFinger = 3 | Middle finger of the right hand.
RightMiddle = RightMiddleFinger | Middle finger of the right hand.
RightRingFinger = 4 | Ring finger of the right hand.
RightRing = RightRingFinger | Ring finger of the right hand.
RightLittleFinger = 5 | Little finger of the right hand.
RightLittle = RightLittleFinger | LIttle finger of the right hand.
LeftThumb = 6 | Thumb of the left hand.
LeftIndexFinger = 7 | Index finger of the left hand.
LeftIndex = LeftIndexFinger | Index finger of the left hand.
LeftMiddleFinger = 8 | Middle finger of the left hand.
LeftMiddle = LeftMiddleFinger | Middle finger of the left hand.
LeftRingFinger = 9 | Ring finger of the left hand.
LeftRing = LeftRingFinger | Ring finger of the left hand.
LeftLittleFinger = 10 | Little finger of the left hand.
LeftLittle = LeftLittleFinger | Little finger of the left hand.
PlainRightThumb = 11 | Specifies plain right thumb.
PlainLeftThumb = 12 | Specifies left plain thumb.
PlainRightFourFingers = 13 | Specifies plain right four fingers.
PlainLeftFourFingers = 14 | Specifies left four fingers.
PlainThumbs = 15 | Specifies plain thumbs.
UnknownPalm = 20 | Unknown palm.
RightFullPalm = 21 | Specifies full left palm.
RightWritersPalm = 22 | Specifies right writers palm.
LeftFullPalm = 23 | Specifies full left palm.
LeftWritersPalm = 24 | Specifies left writers palm.
RightLowerPalm = 25 | Specifies right lower palm.
RightUpperPalm = 26 | Specifies right upper palm.
LeftLowerPalm = 27 | Specifies left lower palm.
LeftUpperPalm = 28 | Specifies left upper palm.
RightOther = 29 | Some other right palm.
LeftOther = 30 | Some other left hand palm.
RightInterdigital = 31 | Specifies right interdigital.
RightThenar = 32 | Specifies right thenar.
RightHypothenar = 33 | Specifies right hypothenar.
LeftInterdigital = 34 | Specifies left interdigital.
LeftThenar = 35 | Specifies left thenar.
LeftHypothenar = 36 | Specifies left hypothenar.
RightIndexMiddleFingers = 40 | Specifies right index and middle fingers.
RightMiddleRingFingers = 41 | Specifies right middle and ring fingers.
RightRingLittleFingers = 42 | Specifies right ring and little fingers.
LeftIndexMiddleFingers = 43 | Specifies left index and middle fingers.
LeftMiddleRingFingers = 44 | Specifies left middle and ring fingers.
LeftRingLittleFingers = 45 | Specifies left ring and little fingers.
RightIndexLeftIndexFingers = 46 | Specifies right and left index fingers.
RightIndexMiddleRingFingers = 47 | Specifies right index, middle and ring fingers.
RightMiddleRingLittleFingers = 48 | Specifies right middle, ring and little fingers.
LeftIndexMiddleRingFingers = 49 | Specifies left index, middle and ring fingers.
LeftMiddleRingLittleFingers = 50 | Specifies left middle, ring and little fingers.
UnknownTwoFingers = -2 | Specifies two unknown fingers.
UnknownThreeFingers = -3 | Specifies three unknown fingers.
UnknownFourFingers = -4 | Specifies four unknown fingers.
UnknownLatentFingers = -5 | Specifies latent unknown fingers.
Container

File: NBiometricTypes.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


Neurotec.Biometrics.NFRidgeCountsType Enumeration

Neurotec.Biometrics.NFRidgeCountsType Enumeration

Specifies type of ridge counts contained in NFRecord.

C#
[Serializable]
public enum NFRidgeCountsType {
  None = 0,
  FourNeighbors = 1,
  EightNeighbors = 2,
  FourNeighborsWithIndexes = 5,
  EightNeighborsWithIndexes = 6,
  Unspecified = 128+4
}
Collapse Expand Remarks

Extracted template with EightNeighborsWithIndexes parameter is bigger than the template extracted with EightNeighbors parameter. Templates extracted with EightNeighborsWithIndexes parameter is faster than the templates extracted with EightNeighbors parameter. Extracted template with FourNeighborsWithIndexes parameter is bigger than the template extracted with FourNeighbors parameter. Templates extracted with FourNeighborsWithIndexes parameter is faster than the templates extracted with FourNeighbors parameter.

Collapse Expand Members
Members | Description
None = 0 | The NFRecord does not contain ridge counts.
FourNeighbors = 1 | The NFRecord contains ridge counts to closest minutia in each of the four sectors of each minutia. First sector starts at minutia angle.
EightNeighbors = 2 | The NFRecord contains ridge counts to closest minutia in each of the eight sectors of each minutia. First sector starts at minutia angle.
FourNeighborsWithIndexes = 5 | The NFRecord contains ridge counts to four neighbors of each minutia.
EightNeighborsWithIndexes = 6 | The NFRecord contains ridge counts to eight neighbors of each minutia.
Unspecified = 128+4 | For internal use.
Container

File: NBiometricTypes.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


Neurotec.Biometrics.NGender Enumeration

Neurotec.Biometrics.NGender Enumeration

Enumerates gender constants.

C#
[Serializable]
public enum NGender {
  Unspecified = 0,
  Male = 1,
  Female = 2,
  Unknown = 255
}
Collapse Expand Remarks

See NGender in Reference (C/C++) chapter.

Collapse Expand Members
Members | Description
Unspecified = 0 | Unspecified gender.
Male = 1 | Male.
Female = 2 | Female.
Unknown = 255 | Unknown.
Container

File: NBiometricTypes.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


Neurotec.Biometrics.NIcaoWarnings Enumeration

Neurotec.Biometrics.NIcaoWarnings Enumeration

Enumerates face Icao check warnings constants.

C#
[Serializable]
[Flags]
public enum NIcaoWarnings {
  None = 0,
  FaceNotDetected = 1,
  RollLeft = 2,
  RollRight = 4,
  YawLeft = 8,
  YawRight = 16,
  PitchUp = 32,
  PitchDown = 64,
  TooNear = 128,
  TooFar = 256,
  TooNorth = 512,
  TooSouth = 1024,
  TooEast = 2048,
  TooWest = 4096,
  Sharpness = 8192,
  BackgroundUniformity = 16384,
  GrayscaleDensity = 32768,
  Saturation = 65536,
  Expression = 131072,
  DarkGlasses = 262144,
  Blink = 524288,
  MouthOpen = 1048576,
  LookingAway = 2097152,
  RedEye = 4194304,
  FaceDarkness = 8388608,
  UnnaturalSkinTone = 16777216,
  WashedOut = 33554432,
  Pixelation = 67108864,
  SkinReflection = 134217728,
  GlassesReflection = 268435456,
  HeavyFrame = 536870912,
  Liveness = 1073741824
}
Collapse Expand Members
Members | Description
None = 0 | No warnings.
FaceNotDetected = 1 | Indicates that face was not detected.
RollLeft = 2 | Indicates face roll left.
RollRight = 4 | Indicates face roll right.
YawLeft = 8 | Indicates face yaw left warning.
YawRight = 16 | Indicates face yaw right warning.
PitchUp = 32 | Indicates pitch up.
PitchDown = 64 | Indicates pitch down.
TooNear = 128 | Indicates that face is too near.
TooFar = 256 | Indicates that face is too far.
TooNorth = 512 | Indicates that face is too north.
TooSouth = 1024 | Indicates that face is too south.
TooEast = 2048 | Indicates that face is too east.
TooWest = 4096 | Indicates that face is too west.
Sharpness = 8192 | Indicates sharpness warning.
BackgroundUniformity = 16384 | Indicates background uniformity.
GrayscaleDensity = 32768 | Indicates grayscale density.
Saturation = 65536 | Indicates saturation warning.
Expression = 131072 | Indicates face expression.
DarkGlasses = 262144 | Indicates that dark glasses detected.
Blink = 524288 | Indicates blink of eye.
MouthOpen = 1048576 | Indicates opened mouth.
LookingAway = 2097152 | Indicates subject looking away.
RedEye = 4194304 | Red eye was detected.
FaceDarkness = 8388608 | Indicates that face is too dark.
UnnaturalSkinTone = 16777216 | Skin tone is unnatural color.
WashedOut = 33554432 | Face is washed out.
Pixelation = 67108864 | Pixelation of an image.
SkinReflection = 134217728 | Light reflection on skin was detected.
GlassesReflection = 268435456 | Indicates reflection on glasses.
HeavyFrame = 536870912 | Indicates that glasses have a thick frame.
Liveness = 1073741824 | Indicates that face is live.
Container

File: NBiometricTypes.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


Neurotec.Biometrics.NLExpression Enumeration

Neurotec.Biometrics.NLExpression Enumeration

Enumerates facial expression constants.

C#
[Serializable]
public enum NLExpression {
  Unspecified = 0,
  Neutral = 1,
  Smile = 2,
  SmileOpenedJaw = 3,
  RaisedBrows = 4,
  EyesAway = 5,
  Squinting = 6,
  Frowning = 7,
  Unknown = 0xFFFF
}
Collapse Expand Remarks

See NLExpression in Reference (C/C++) chapter.

Collapse Expand Members
Members | Description
Unspecified = 0 | Unspecified expression.
Neutral = 1 | Neutral.
Smile = 2 | Smiling.
SmileOpenedJaw = 3 | Smiling with jaw open.
RaisedBrows = 4 | Eyebrows raised.
EyesAway = 5 | Eyes looking away.
Squinting = 6 | Squinting.
Frowning = 7 | Frowning.
Unknown = 0xFFFF | Unknown expression.
Container

File: NBiometricTypes.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


Neurotec.Biometrics.NLProperties Enumeration

Neurotec.Biometrics.NLProperties Enumeration

Enumerates basic face properties constants

C#
[Serializable]
[Flags]
public enum NLProperties {
  NotSpecified = 0,
  Specified = 0x000001,
  Glasses = 0x000002,
  Mustache = 0x000004,
  Beard = 0x000008,
  TeethVisible = 0x000010,
  Blink = 0x000020,
  MouthOpen = 0x000040,
  LeftEyePatch = 0x000080,
  RightEyePatch = 0x000100,
  BothEyePatch = 0x000200,
  DarkGlasses = 0x000400,
  DistortingCondition = 0x000800,
  Hat = 0x01000000,
  Scarf = 0x02000000,
  NoEar = 0x04000000,
  FaceMask = 0x08000000,
  HeavyFrame = 0x10000000
}
Collapse Expand Remarks

See NLProperties in Reference (C/C++) chapter.

Collapse Expand Members
Members | Description
NotSpecified = 0 | Face properties not specified.
Specified = 0x000001 | Face properties specified.
Glasses = 0x000002 | Wearing glasses.
Mustache = 0x000004 | Mustache.
Beard = 0x000008 | Beard.
TeethVisible = 0x000010 | Teeth are visible.
Blink = 0x000020 | Eye blink.
MouthOpen = 0x000040 | Mouth is open.
LeftEyePatch = 0x000080 | Patch on left eye.
RightEyePatch = 0x000100 | Patch on right eye.
BothEyePatch = 0x000200 | Patch on both eyes.
DarkGlasses = 0x000400 | Wearing dark glasses.
DistortingCondition = 0x000800 | Distorting conditions.
Hat = 0x01000000 | Wearing a hat.
Scarf = 0x02000000 | Wearing a scarf.
NoEar = 0x04000000 | One ear missing.
FaceMask = 0x08000000 | Wearing a face mask.
HeavyFrame = 0x10000000 | Wearing glasses with heavy frame.
Container

File: NBiometricTypes.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


Neurotec.Biometrics.NLivenessAction Enumeration

Neurotec.Biometrics.NLivenessAction Enumeration

Enumerates face liveness challenge action constants.

C#
[Serializable]
[Flags]
public enum NLivenessAction {
  None = 0,
  KeepStill = 0x000001,
  Blink = 0x000002,
  RotateYaw = 0x000004,
  KeepRotatingYaw = 0x000008,
  TurnToCenter = 0x000010,
  TurnLeft = 0x000020,
  TurnRight = 0x000040,
  TurnUp = 0x000080,
  TurnDown = 0x000100,
  MoveCloser = 0x000200,
  MoveBack = 0x000400
}
Collapse Expand Remarks

See NLivenessAction in Reference (C/C++) chapter.

Collapse Expand Members
Members | Description
None = 0 | No actions is required from the user.
KeepStill = 0x000001 | The user should keep as still as possible.
Blink = 0x000002 | The user should blink at least once.
RotateYaw = 0x000004 | The user should rotate his face according to instructions.
KeepRotatingYaw = 0x000008 | The user should keep turning face from side to side.
TurnToCenter = 0x000010 | The user should center out his face.
TurnLeft = 0x000020 | The user should turn his face left.
TurnRight = 0x000040 | The user should turn his face right.
TurnUp = 0x000080 | The user should turn his face up.
TurnDown = 0x000100 | The user should turn his face down.
MoveCloser = 0x000200 | The user should move his face closer to camera.
MoveBack = 0x000400 | The user should move his face further away from camera.
Container

File: NBiometricTypes.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


Neurotec.Biometrics.NLivenessMode Enumeration

Neurotec.Biometrics.NLivenessMode Enumeration

Enumerates face liveness mode constants.

C#
[Serializable]
public enum NLivenessMode {
  None = 0,
  Passive = 1,
  Active = 2,
  PassiveAndActive = 3,
  Simple = 4,
  Custom = 5,
  PassiveWithBlink = 6
}
Collapse Expand Remarks

See NLivenessMode in Reference (C/C++) chapter.

Collapse Expand Members
Members | Description
None = 0 | No liveness check is performed.
Passive = 1 | User should passively stand still in front of the camera. It takes several seconds to measure the liveness signal.
Active = 2 | User should perform several actions to prove his liveness.
PassiveAndActive = 3 | A sequence of passive and active liveness detection modes.
Simple = 4 | User should stand still in front of the camera.
Custom = 5 | Customizable liveness action sequence. By default requires user to turn head according to instructions.
PassiveWithBlink = 6 | User should passively stand still in front of the camera. It takes several seconds to measure the liveness signal.
Container

File: NBiometricTypes.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


Neurotec.Biometrics.NfiqQuality Enumeration

Neurotec.Biometrics.NfiqQuality Enumeration

Specifies the quality of a fingerprint image.

C#
[Serializable]
public enum NfiqQuality {
  Poor = 5,
  Fair = 4,
  Good = 3,
  VeryGood = 2,
  Excellent = 1,
  Unknown = 0
}
Collapse Expand Members
Members | Description
Poor = 5 | Poor fingerprint image quality.
Fair = 4 | Fair fingerprint image quality.
Good = 3 | Good fingerprint image quality.
VeryGood = 2 | Very good fingerprint image quality.
Excellent = 1 | Excellent fingerprint image quality.
Unknown = 0 | Unknown fingerprint image quality.
Container

File: NBiometricTypes.cs

Namespace: Neurotec.Biometrics

Module: .NET Reference


Neurotec.Collections.ObjectModel Namespace

Neurotec.Collections.ObjectModel Namespace
Classes Legend Structs, Records, Enums

Classes under this namespace provide methods and properties for working with collections and dictionaries.

Collapse Expand Classes
Name | Description
NArrayCollection | Provides functionality for working with collections of arrays.
NCollection | Provides functionality for working with collections.
NDictionary | Provides information about tables, classes, extended data types, and other items in the Application Object Tree.
Collapse Expand Structs, Records, Enums
Name | Description
NCollectionChangedAction | Enumerates collection-changing actions.


NArrayCollection Class

NArrayCollection Class
Legend Members NArrayCollection Methods NArrayCollection Properties

Provides functionality for working with collections of arrays.

C#
public sealed class NArrayCollection : NObjectPart, IList, ICollection, IEnumerable;
Collapse Expand NArrayCollection Methods
Name | Description
Add | Adds an item to the array.
AddRange | Adds an array of item to the array.
Clear | Clears the specified array.
Contains | Checks whether the array contains the specified item.
CopyTo | Copies the array into an array object.
GetCount | Gets the number of items in the array.
GetEnumerator | Retrieves the enumerator of the collection.
IndexOf | Retrieves the index of the specified item in the array.
Insert | Inserts a value in the array.
InsertRange | Inserts an array of values in the array.
Remove | Removes the specified item from the array.
RemoveAt | Removes the specified value from the array.
RemoveRange | Removes a range of values from the array.
ToArray | Converts the array into an independent array.
ToItemArray | Converts the array into an independent array.
this | Gets or sets the item specified by index.
Collapse Expand NArrayCollection Properties
Name | Description
Count | Gets the number of items in the collection.
IsReadOnly | Checks whether the collection is read-only.
NativeType | Defines the native type of the object.
this | Gets the array specified by index.
Container

File: NArrayCollection.cs

Namespace: Neurotec.Collections.ObjectModel

Module: .NET Reference


NArrayCollection.Add Method

NArrayCollection.Add Method
NArrayCollection Class Neurotec.Collections.ObjectModel Namespace

Adds an item to the array.

C#
public int Add(int baseIndex, object item);
Collapse Expand Parameters
Parameters | Description
int baseIndex | Index of the array in the collection.
object item | The item to add.
Collapse Expand Returns

Index of the item.


NArrayCollection.AddRange Method (int, Array)

NArrayCollection.AddRange Method (int, Array)
NArrayCollection Class Neurotec.Collections.ObjectModel Namespace

Adds an array of item to the array.

C#
public int AddRange(int baseIndex, Array items);
Collapse Expand Parameters
Parameters | Description
int baseIndex | Index of the array in the collection.
Array items | Array of item to add.
Collapse Expand Returns

Index of the last added item.


NArrayCollection.AddRange Method (int, object[])

NArrayCollection.AddRange Method (int, object[])
NArrayCollection Class Neurotec.Collections.ObjectModel Namespace

Adds an array of item to the array.

C#
public int AddRange(int baseIndex, object[] items);
Collapse Expand Parameters
Parameters | Description
int baseIndex | Index of the array in the collection.
object[] items | Array of item to add.
Collapse Expand Returns

Index of the last added item.


NArrayCollection.Clear Method

NArrayCollection.Clear Method
NArrayCollection Class Neurotec.Collections.ObjectModel Namespace

Clears the specified array.

C#
public void Clear(int baseIndex);
Collapse Expand Parameters
Parameters | Description
int baseIndex | Index of the array in the collection.


NArrayCollection.Contains Method

NArrayCollection.Contains Method
NArrayCollection Class Neurotec.Collections.ObjectModel Namespace

Checks whether the array contains the specified item.

C#
public bool Contains(int baseIndex, object item);
Collapse Expand Parameters
Parameters | Description
int baseIndex | Index of the array in the collection.
object item | The item to find.
Collapse Expand Returns

true if the array contains the item, else false.


NArrayCollection.CopyTo Method (Array, int)

NArrayCollection.CopyTo Method (Array, int)
NArrayCollection Class Neurotec.Collections.ObjectModel Namespace

Copies the array into an array object.

C#
public void CopyTo(Array array, int index);
Collapse Expand Parameters
Parameters | Description
Array array | Array to copy items to.
int index | IIndex in the array, at which the data will be inserted.


NArrayCollection.CopyTo Method (int, Array, int)

NArrayCollection.CopyTo Method (int, Array, int)
NArrayCollection Class Neurotec.Collections.ObjectModel Namespace

Copies the array into an independent array.

C#
public void CopyTo(int baseIndex, Array array, int index);
Collapse Expand Parameters
Parameters | Description
int baseIndex | Index of the array in the collection.
Array array | The destination array.
int index | Index in the destination array at which to insert.


NArrayCollection.CopyTo Method (int, object[], int)

NArrayCollection.CopyTo Method (int, object[], int)
NArrayCollection Class Neurotec.Collections.ObjectModel Namespace

Copies the array into an independent array.

C#
public void CopyTo(int baseIndex, object[] array, int arrayIndex);
Collapse Expand Parameters
Parameters | Description
int baseIndex | Index of the array in the collection.
object[] array | The destination array.
int arrayIndex | Index in the destination array at which to insert.


NArrayCollection.CopyTo Method (object[], int)

NArrayCollection.CopyTo Method (object[], int)
NArrayCollection Class Neurotec.Collections.ObjectModel Namespace

Copies the array into an independent two-dimensional array.

C#
public void CopyTo(object[] array, int index);
Collapse Expand Parameters
Parameters | Description
object[] array | Array to copy items to.
int index | Index in the array, at which the data will be inserted.


NArrayCollection.GetCount Method

NArrayCollection.GetCount Method
NArrayCollection Class Neurotec.Collections.ObjectModel Namespace

Gets the number of items in the array.

C#
public int GetCount(int baseIndex);
Collapse Expand Parameters
Parameters | Description
int baseIndex | Index of the array in the collection.
Collapse Expand Returns

The number of items in the array.


NArrayCollection.GetEnumerator Method

NArrayCollection.GetEnumerator Method
NArrayCollection Class Neurotec.Collections.ObjectModel Namespace

Retrieves the enumerator of the collection.

C#
public IEnumerator<object[]> GetEnumerator();
Collapse Expand Returns

The enumerator.


NArrayCollection.IndexOf Method

NArrayCollection.IndexOf Method
NArrayCollection Class Neurotec.Collections.ObjectModel Namespace

Retrieves the index of the specified item in the array.

C#
public int IndexOf(int baseIndex, object item);
Collapse Expand Parameters
Parameters | Description
int baseIndex | Index of the array in the collection.
object item | Item to retrieve index of.
Collapse Expand Returns

Index of the item.


NArrayCollection.Insert Method

NArrayCollection.Insert Method
NArrayCollection Class Neurotec.Collections.ObjectModel Namespace

Inserts a value in the array.

C#
public void Insert(int baseIndex, int index, object item);
Collapse Expand Parameters
Parameters | Description
int baseIndex | Index of the array in the collection.
int index | Index of value.
object item | Value to insert.


NArrayCollection.InsertRange Method (int, int, Array)

NArrayCollection.InsertRange Method (int, int, Array)
NArrayCollection Class Neurotec.Collections.ObjectModel Namespace

Inserts an array of values in the array.

C#
public void InsertRange(int baseIndex, int index, Array items);
Collapse Expand Parameters
Parameters | Description
int baseIndex | Index of the array in the collection.
int index | Index of the first value.
Array items | Array of values to insert.


NArrayCollection.InsertRange Method (int, int, object[])

NArrayCollection.InsertRange Method (int, int, object[])
NArrayCollection Class Neurotec.Collections.ObjectModel Namespace

Inserts an array of values in the array.

C#
public void InsertRange(int baseIndex, int index, object[] items);
Collapse Expand Parameters
Parameters | Description
int baseIndex | Index of the array in the collection.
int index | Index of the first value.
object[] items | Array of values to insert.


NArrayCollection.Remove Method

NArrayCollection.Remove Method
NArrayCollection Class Neurotec.Collections.ObjectModel Namespace

Removes the specified item from the array.

C#
public int Remove(int baseIndex, object item);
Collapse Expand Parameters
Parameters | Description
int baseIndex | Index of the array in the collection.
object item | The item to remove.
Collapse Expand Returns

Index freed by the removed item.


NArrayCollection.RemoveAt Method

NArrayCollection.RemoveAt Method
NArrayCollection Class Neurotec.Collections.ObjectModel Namespace

Removes the specified value from the array.

C#
public void RemoveAt(int baseIndex, int index);
Collapse Expand Parameters
Parameters | Description
int baseIndex | Index of the array in the collection.
int index | Index of the value to remove.


NArrayCollection.RemoveRange Method

NArrayCollection.RemoveRange Method
NArrayCollection Class Neurotec.Collections.ObjectModel Namespace

Removes a range of values from the array.

C#
public void RemoveRange(int baseIndex, int startIndex, int count);
Collapse Expand Parameters
Parameters | Description
int baseIndex | Index of the array in the collection.
int startIndex | Index of the first value to remove.
int count | Number of values to remove.


NArrayCollection.ToArray Method

NArrayCollection.ToArray Method
NArrayCollection Class Neurotec.Collections.ObjectModel Namespace

Converts the array into an independent array.

C#
public object[] ToArray(int baseIndex);
Collapse Expand Parameters
Parameters | Description
int baseIndex | Index of the array in the collection.
Collapse Expand Returns

The new array.


NArrayCollection.ToItemArray Method

NArrayCollection.ToItemArray Method
NArrayCollection Class Neurotec.Collections.ObjectModel Namespace

Converts the array into an independent array.

C#
public Array ToItemArray(int baseIndex);
Collapse Expand Parameters
Parameters | Description
int baseIndex | Index of the array in the collection.
Collapse Expand Returns

The new array.


NArrayCollection.this Indexer

NArrayCollection.this Indexer
NArrayCollection Class Neurotec.Collections.ObjectModel Namespace

Gets or sets the item specified by index.

C#
public object this[int baseIndex, int index];
Collapse Expand Parameters
Parameters | Description
int baseIndex | Index of the array in the collection.
int index | Index of the item.
Collapse Expand Returns

The item.


NArrayCollection.Count Property

NArrayCollection.Count Property
NArrayCollection Class Neurotec.Collections.ObjectModel Namespace

Gets the number of items in the collection.

C#
public int Count;


NArrayCollection.IsReadOnly Property

NArrayCollection.IsReadOnly Property
NArrayCollection Class Neurotec.Collections.ObjectModel Namespace

Checks whether the collection is read-only.

C#
public bool IsReadOnly;


NArrayCollection.NativeType Property

NArrayCollection.NativeType Property
NArrayCollection Class Neurotec.Collections.ObjectModel Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NArrayCollection.this Property

NArrayCollection.this Property
NArrayCollection Class Neurotec.Collections.ObjectModel Namespace

Gets the array specified by index.

C#
public object[][int baseIndex] this;
Collapse Expand Parameters
Parameters | Description
baseIndex | Index of the array in the collection.
Collapse Expand Returns

The array.


NCollection Class

NCollection Class
NCollection Events Legend Members NCollection Methods NCollection Properties

Provides functionality for working with collections.

C#
public sealed class NCollection : NObjectPart, IList, ICollection, IEnumerable, INotifyCollectionChanged;
Collapse Expand NCollection Events
Name | Description
CollectionChanged | Adds or removes a handler for an event which occurs when collection is changed.
Collapse Expand NCollection Methods
Name | Description
Add | Adds an item to the collection.
AddRange | Adds an array of items to the collection.
Clear | Clears the current collection.
Contains | Checks whether the collection contains the specified item.
CopyTo | Copies the collection to the specified array.
GetEnumerator | Retrieves the enumerator of the collection.
IndexOf | Retrieves the index of the specified item.
Insert | Adds an item to the collection at specified index.
InsertRange | Adds an array of items to the collection at specified index.
Remove | Removes the specified value from the collection.
RemoveAt | Removes the specified item from the collection.
RemoveRange | Removes the specified items from the collection.
ToArray | Converts the collection to an array.
ToItemArray | Converts the collection to an array.
this | Gets or sets the item specified by index.
Collapse Expand NCollection Properties
Name | Description
Capacity | Gets or sets the maximum number of items in the collection.
Count | Gets the number of items in the collection.
IsReadOnly | Checks whether the collection is read-only.
NCollectionChangedActionNativeType | Defines the native type of the "collection changed" action.
NCollectionCollectionChangedCallbackNativeType | Defines the native type of the "collection changed" callback.
NativeType | Defines the native type of the object.
Container

File: NCollection.cs

Namespace: Neurotec.Collections.ObjectModel

Module: .NET Reference


NCollection.Add Method

NCollection.Add Method
NCollection Class Neurotec.Collections.ObjectModel Namespace

Adds an item to the collection.

C#
public int Add(object item);
Collapse Expand Parameters
Parameters | Description
object item | The item to add.
Collapse Expand Returns

Index of the item.


NCollection.AddRange Method (Array)

NCollection.AddRange Method (Array)
NCollection Class Neurotec.Collections.ObjectModel Namespace

Adds an array of items to the collection.

C#
public int AddRange(Array items);
Collapse Expand Parameters
Parameters | Description
Array items | Array of items to add.
Collapse Expand Returns

Index of the first item.


NCollection.AddRange Method (object[])

NCollection.AddRange Method (object[])
NCollection Class Neurotec.Collections.ObjectModel Namespace

Adds an array of items to the collection.

C#
public int AddRange(object[] items);
Collapse Expand Parameters
Parameters | Description
object[] items | Array of items to add.
Collapse Expand Returns

Index of the first item.


NCollection.Clear Method

NCollection.Clear Method
NCollection Class Neurotec.Collections.ObjectModel Namespace

Clears the current collection.

C#
public void Clear();


NCollection.Contains Method

NCollection.Contains Method
NCollection Class Neurotec.Collections.ObjectModel Namespace

Checks whether the collection contains the specified item.

C#
public bool Contains(object item);
Collapse Expand Parameters
Parameters | Description
object item | The item to find.
Collapse Expand Returns

true if the collection contains the item; else false


NCollection.CopyTo Method (Array, int)

NCollection.CopyTo Method (Array, int)
NCollection Class Neurotec.Collections.ObjectModel Namespace

Copies the collection to the specified array.

C#
public void CopyTo(Array array, int index);
Collapse Expand Parameters
Parameters | Description
Array array | The destination array.
int index | Index in the array at which to insert values.


NCollection.CopyTo Method (object[], int)

NCollection.CopyTo Method (object[], int)
NCollection Class Neurotec.Collections.ObjectModel Namespace

Copies the collection to the specified array.

C#
public void CopyTo(object[] array, int arrayIndex);
Collapse Expand Parameters
Parameters | Description
object[] array | The destination array.
int arrayIndex | Index in the array at which to insert values.


NCollection.GetEnumerator Method

NCollection.GetEnumerator Method
NCollection Class Neurotec.Collections.ObjectModel Namespace

Retrieves the enumerator of the collection.

C#
public IEnumerator<object> GetEnumerator();
Collapse Expand Returns

The enumerator.


NCollection.IndexOf Method

NCollection.IndexOf Method
NCollection Class Neurotec.Collections.ObjectModel Namespace

Retrieves the index of the specified item.

C#
public int IndexOf(object item);
Collapse Expand Parameters
Parameters | Description
object item | Item to retrieve index of.
Collapse Expand Returns

The index of the item.


NCollection.Insert Method

NCollection.Insert Method
NCollection Class Neurotec.Collections.ObjectModel Namespace

Adds an item to the collection at specified index.

C#
public void Insert(int index, object item);
Collapse Expand Parameters
Parameters | Description
int index | Index of the item.
object item | The item to add.


NCollection.InsertRange Method (int, Array)

NCollection.InsertRange Method (int, Array)
NCollection Class Neurotec.Collections.ObjectModel Namespace

Adds an array of items to the collection at specified index.

C#
public void InsertRange(int index, Array items);
Collapse Expand Parameters
Parameters | Description
int index | Index of the first item.
Array items | Array of items to add.


NCollection.InsertRange Method (int, object[])

NCollection.InsertRange Method (int, object[])
NCollection Class Neurotec.Collections.ObjectModel Namespace

Adds an array of items to the collection at specified index.

C#
public void InsertRange(int index, object[] items);
Collapse Expand Parameters
Parameters | Description
int index | Index of the first item.
object[] items | Array of items to add.


NCollection.Remove Method

NCollection.Remove Method
NCollection Class Neurotec.Collections.ObjectModel Namespace

Removes the specified value from the collection.

C#
public int Remove(object item);
Collapse Expand Parameters
Parameters | Description
object item | The value to remove.
Collapse Expand Returns

Index freed by the removed value.


NCollection.RemoveAt Method

NCollection.RemoveAt Method
NCollection Class Neurotec.Collections.ObjectModel Namespace

Removes the specified item from the collection.

C#
public void RemoveAt(int index);
Collapse Expand Parameters
Parameters | Description
int index | Index of the item to remove.


NCollection.RemoveRange Method

NCollection.RemoveRange Method
NCollection Class Neurotec.Collections.ObjectModel Namespace

Removes the specified items from the collection.

C#
public void RemoveRange(int startIndex, int count);
Collapse Expand Parameters
Parameters | Description
int startIndex | Index of the first item to remove.
int count | Number of items to remove.


NCollection.ToArray Method

NCollection.ToArray Method
NCollection Class Neurotec.Collections.ObjectModel Namespace

Converts the collection to an array.

C#
public object[] ToArray();
Collapse Expand Returns

The new array.


NCollection.ToItemArray Method

NCollection.ToItemArray Method
NCollection Class Neurotec.Collections.ObjectModel Namespace

Converts the collection to an array.

C#
public Array ToItemArray();
Collapse Expand Returns

The new array.


NCollection.this Indexer

NCollection.this Indexer
NCollection Class Neurotec.Collections.ObjectModel Namespace

Gets or sets the item specified by index.

C#
public object this[int index];
Collapse Expand Parameters
Parameters | Description
int index | Index of the item.
Collapse Expand Returns

The item.


NCollection.Capacity Property

NCollection.Capacity Property
NCollection Class Neurotec.Collections.ObjectModel Namespace

Gets or sets the maximum number of items in the collection.

C#
public int Capacity;


NCollection.Count Property

NCollection.Count Property
NCollection Class Neurotec.Collections.ObjectModel Namespace

Gets the number of items in the collection.

C#
public int Count;


NCollection.IsReadOnly Property

NCollection.IsReadOnly Property
NCollection Class Neurotec.Collections.ObjectModel Namespace

Checks whether the collection is read-only.

C#
public bool IsReadOnly;


NCollection.NCollectionChangedActionNativeType Property

NCollection.NCollectionChangedActionNativeType Property
NCollection Class Neurotec.Collections.ObjectModel Namespace

Defines the native type of the "collection changed" action.

C#
public static NType NCollectionChangedActionNativeType;


NCollection.NCollectionCollectionChangedCallbackNativeType Property

NCollection.NCollectionCollectionChangedCallbackNativeType Property
NCollection Class Neurotec.Collections.ObjectModel Namespace

Defines the native type of the "collection changed" callback.

C#
public static NType NCollectionCollectionChangedCallbackNativeType;


NCollection.NativeType Property

NCollection.NativeType Property
NCollection Class Neurotec.Collections.ObjectModel Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NCollection.CollectionChanged Event

NCollection.CollectionChanged Event
NCollection Class Neurotec.Collections.ObjectModel Namespace

Adds or removes a handler for an event which occurs when collection is changed.

C#
public event NotifyCollectionChangedEventHandler CollectionChanged;


NDictionary Class

NDictionary Class
NDictionary Classes NDictionary Events Legend Members NDictionary Methods NDictionary Properties

Provides information about tables, classes, extended data types, and other items in the Application Object Tree.

C#
public sealed class NDictionary : NObjectPart, IDictionary, IList, ICollection, IEnumerable, INotifyCollectionChanged;
Collapse Expand NDictionary Classes
Name | Description
KeyCollection | Represents a collection of value keys.
ValueCollection | Represents a collection of values.
Collapse Expand NDictionary Events
Name | Description
CollectionChanged | Adds or removes a handler for an event which occurs when collection is changed.
Collapse Expand NDictionary Methods
Name | Description
Add | Adds the specified item to the dictionary.
Clear | Clears the dictionary.
ContainsKey | Checks whether the dictionary contains the specified key.
CopyTo | Copies the dictionary to an array.
GetEnumerator | Retrieves the enumerator of the collection.
GetItemAt | Retrieves the specified item.
Remove | Removes a value specified by key from the dictionary.
RemoveAt | Removes the specified item from the dictionary.
ToArray | Converts the dictionary to an array.
ToItemArray | Converts the dictionary to an array.
TryGetValue | Attempts to retrieve a value specified by key. Return a Boolean value indicating success.
this | Gets or sets the item specified by index.
Collapse Expand NDictionary Properties
Name | Description
Count | Gets the number of items in the dictionary.
IsReadOnly | Checks whether the collection is read-only.
Keys | Gets the collection of value keys.
NativeType | Defines the native type of the object.
Values | Gets the collection of values.
Container

File: NDictionary.cs

Namespace: Neurotec.Collections.ObjectModel

Module: .NET Reference


NDictionary.KeyCollection Class

NDictionary.KeyCollection Class
Legend Members KeyCollection Methods

Represents a collection of value keys.

C#
public sealed class KeyCollection : ObjectReadOnlyCollection;
Collapse Expand KeyCollection Methods
Name | Description
ToItemArray | Converts the key collection to an item array.
Container

File: NDictionary.cs

Namespace: Neurotec.Collections.ObjectModel

Module: .NET Reference


NDictionary.KeyCollection.ToItemArray Method

NDictionary.KeyCollection.ToItemArray Method
NDictionary.KeyCollection Class Neurotec.Collections.ObjectModel Namespace

Converts the key collection to an item array.

C#
public Array ToItemArray();
Collapse Expand Returns

The new array.


NDictionary.ValueCollection Class

NDictionary.ValueCollection Class
Legend Members ValueCollection Methods

Represents a collection of values.

C#
public sealed class ValueCollection : ObjectReadOnlyCollection;
Collapse Expand ValueCollection Methods
Name | Description
ToItemArray | Converts the value collection to an item array.
Container

File: NDictionary.cs

Namespace: Neurotec.Collections.ObjectModel

Module: .NET Reference


NDictionary.ValueCollection.ToItemArray Method

NDictionary.ValueCollection.ToItemArray Method
NDictionary.ValueCollection Class Neurotec.Collections.ObjectModel Namespace

Converts the value collection to an item array.

C#
public Array ToItemArray();
Collapse Expand Returns

The new array.


NDictionary.Add Method (KeyValuePair<object, object>)

NDictionary.Add Method (KeyValuePair<object, object>)
NDictionary Class Neurotec.Collections.ObjectModel Namespace

Adds the specified item to the dictionary.

C#
public void Add(KeyValuePair<object, object> item);
Collapse Expand Parameters
Parameters | Description
KeyValuePair<object, object> item | The item to add.


NDictionary.Add Method (object)

NDictionary.Add Method (object)
NDictionary Class Neurotec.Collections.ObjectModel Namespace

Adds the specified item to the dictionary.

C#
public void Add(object item);
Collapse Expand Parameters
Parameters | Description
object item | The item to add.


NDictionary.Add Method (object, object)

NDictionary.Add Method (object, object)
NDictionary Class Neurotec.Collections.ObjectModel Namespace

Adds the specified value to the dictionary.

C#
public void Add(object key, object value);
Collapse Expand Parameters
Parameters | Description
object key | Key of the value.
object value | The value to add.


NDictionary.Clear Method

NDictionary.Clear Method
NDictionary Class Neurotec.Collections.ObjectModel Namespace

Clears the dictionary.

C#
public void Clear();


NDictionary.ContainsKey Method

NDictionary.ContainsKey Method
NDictionary Class Neurotec.Collections.ObjectModel Namespace

Checks whether the dictionary contains the specified key.

C#
public bool ContainsKey(object key);
Collapse Expand Parameters
Parameters | Description
object key | The key to find.
Collapse Expand Returns

true if the dictionary contains the key, else false.


NDictionary.CopyTo Method (Array, int)

NDictionary.CopyTo Method (Array, int)
NDictionary Class Neurotec.Collections.ObjectModel Namespace

Copies the dictionary to an array.

C#
public void CopyTo(Array array, int index);
Collapse Expand Parameters
Parameters | Description
Array array | The array to copy to.
int index | Index in the array, at which the data will be inserted.


NDictionary.CopyTo Method (KeyValuePair<object, object>[], int)

NDictionary.CopyTo Method (KeyValuePair<object, object>[], int)
NDictionary Class Neurotec.Collections.ObjectModel Namespace

Copies the dictionary to an array.

C#
public void CopyTo(KeyValuePair<object, object>[] array, int index);
Collapse Expand Parameters
Parameters | Description
KeyValuePair<object, object>[] array | The array to copy to.
int index | Index in the array, at which the data will be inserted.


NDictionary.GetEnumerator Method

NDictionary.GetEnumerator Method
NDictionary Class Neurotec.Collections.ObjectModel Namespace

Retrieves the enumerator of the collection.

C#
public IEnumerator<KeyValuePair<object, object>> GetEnumerator();
Collapse Expand Returns

The enumerator.


NDictionary.GetItemAt Method

NDictionary.GetItemAt Method
NDictionary Class Neurotec.Collections.ObjectModel Namespace

Retrieves the specified item.

C#
public object GetItemAt(int index);
Collapse Expand Parameters
Parameters | Description
int index | Index of the item.
Collapse Expand Returns

The item.


NDictionary.Remove Method

NDictionary.Remove Method
NDictionary Class Neurotec.Collections.ObjectModel Namespace

Removes a value specified by key from the dictionary.

C#
public bool Remove(object key);
Collapse Expand Parameters
Parameters | Description
object key | Key of the value to remove.
Collapse Expand Returns

true if the value was removed successfully, else false


NDictionary.RemoveAt Method

NDictionary.RemoveAt Method
NDictionary Class Neurotec.Collections.ObjectModel Namespace

Removes the specified item from the dictionary.

C#
public void RemoveAt(int index);
Collapse Expand Parameters
Parameters | Description
int index | Index of the item to remove.


NDictionary.ToArray Method

NDictionary.ToArray Method
NDictionary Class Neurotec.Collections.ObjectModel Namespace

Converts the dictionary to an array.

C#
public KeyValuePair<object, object>[] ToArray();
Collapse Expand Returns

The new array.


NDictionary.ToItemArray Method

NDictionary.ToItemArray Method
NDictionary Class Neurotec.Collections.ObjectModel Namespace

Converts the dictionary to an array.

C#
public Array ToItemArray();
Collapse Expand Returns

The new array.


NDictionary.TryGetValue Method

NDictionary.TryGetValue Method
NDictionary Class Neurotec.Collections.ObjectModel Namespace

Attempts to retrieve a value specified by key. Return a Boolean value indicating success.

C#
public bool TryGetValue(object key, out object value);
Collapse Expand Parameters
Parameters | Description
object key | Key of the value to retrieve.
out object value | [out] The retrieved value.
Collapse Expand Returns

true if the value was retrieved successfully, else false


NDictionary.this Indexer (int)

NDictionary.this Indexer (int)
NDictionary Class Neurotec.Collections.ObjectModel Namespace

Gets or sets the item specified by index.

C#
public KeyValuePair<object, object> this[int index];
Collapse Expand Parameters
Parameters | Description
int index | Index of the item.
Collapse Expand Returns

The item.


NDictionary.this Indexer (object)

NDictionary.this Indexer (object)
NDictionary Class Neurotec.Collections.ObjectModel Namespace

Gets or sets the value specified by key.

C#
public object this[object key];
Collapse Expand Parameters
Parameters | Description
object key | Key of the value.
Collapse Expand Returns

The value.


NDictionary.Count Property

NDictionary.Count Property
NDictionary Class Neurotec.Collections.ObjectModel Namespace

Gets the number of items in the dictionary.

C#
public int Count;


NDictionary.IsReadOnly Property

NDictionary.IsReadOnly Property
NDictionary Class Neurotec.Collections.ObjectModel Namespace

Checks whether the collection is read-only.

C#
public bool IsReadOnly;


NDictionary.Keys Property

NDictionary.Keys Property
NDictionary Class Neurotec.Collections.ObjectModel Namespace

Gets the collection of value keys.

C#
public KeyCollection Keys;


NDictionary.NativeType Property

NDictionary.NativeType Property
NDictionary Class Neurotec.Collections.ObjectModel Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NDictionary.Values Property

NDictionary.Values Property
NDictionary Class Neurotec.Collections.ObjectModel Namespace

Gets the collection of values.

C#
public ValueCollection Values;


NDictionary.CollectionChanged Event

NDictionary.CollectionChanged Event
NDictionary Class Neurotec.Collections.ObjectModel Namespace

Adds or removes a handler for an event which occurs when collection is changed.

C#
public event NotifyCollectionChangedEventHandler CollectionChanged;


Neurotec.Collections.ObjectModel.NCollectionChangedAction Enumeration

Neurotec.Collections.ObjectModel.NCollectionChangedAction Enumeration

Enumerates collection-changing actions.

C#
public enum NCollectionChangedAction {
  Add = 0,
  Remove = 1,
  Replace = 2,
  Move = 3,
  Reset = 4
}
Collapse Expand Members
Members | Description
Add = 0 | Indicates that an item was added to a collection.
Remove = 1 | Indicates that an item was removed from a collection.
Replace = 2 | Indicates that an item was replaced in a collection.
Move = 3 | Indicates that an item was moved in a collection.
Reset = 4 | Indicates that the collection was reset.
Container

File: NCollection.cs

Namespace: Neurotec.Collections.ObjectModel

Module: .NET Reference


Neurotec.Devices Namespace

Neurotec.Devices Namespace
Classes Legend Structs, Records, Enums

Provides functionality for managing devices, like cameras, fingerprint or irises scanners.

Collapse Expand Classes
Name | Description
NBiometricDevice | Provides methods to retrieve information about biometric device.
NBiometricDeviceCapturePreviewEventArgs | Contains NBiometricDevice capture preview event arguments.
NCamera | Provides methods for working with cameras.
NCameraStillCapturedEventArgs | Contains NCamera still image capture event arguments.
NCaptureDevice | Provides methods for working with capture devices.
NDevice | Provides functionality for retrieving device information.
NDeviceManager | Provides functionality for managing devices.
NDeviceManagerDeviceEventArgs | Contains device manager device event arguments.
NDevices | Provides functionality for retrieving information about NDevices library.
Collapse Expand Structs, Records, Enums
Name | Description
NCameraStatus | Enumerates camera status values.
NDeviceType | Enumerates device type values.


NBiometricDevice Class

NBiometricDevice Class
NDevice Classes NObject Delegates NObject Events NObject Fields Legend Members NDisposable Methods NDisposable Properties

Provides methods to retrieve information about biometric device.

C#
public class NBiometricDevice : NDevice;
Collapse Expand NDevice Classes
NDevice Class
Name | Description
ChildCollection | Children collection of specified multimodal device.
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
NBiometricDevice Class
Name | Description
CapturePreview | Adds or removes capture preview event to the specified biometric device.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NBiometricDevice Class
Name | Description
Cancel | Stops capturing and cancels NBiometricDevice (NFScanner or NIrisScanner)
Capture | Starts capturing biometric data.
EndSequence | Ends multiple images capturing sequence.
StartSequence | Starts sequence which prepares device for multiple capture operations.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NDevice Class
Show:
No members matching the current filter
Name | Description
Children | Gets children collections of specified multimodal device.
DeviceType | Gets the type of multimodal device.
DisplayName | Gets device name
Id | Gets device Id.
IsAvailable | Checks if the device is available.
IsDisconnectable | Checks whether the device is disconnectable.
IsPrivate | Checks if the device is private.
Make | Gets device manufacturer.
Model | Gets model of current biometric device.
NDeviceTypeNativeType | Defines the native type of the device type.
NativeType | Defines the native type of the object.
Owner | Gets the owner of the device manager.
Parent | Gets the parent of specified multimodal device module.
Plugin | Gets device plugin.
SerialNumber | Gets serial number of current biometric device.
NBiometricDevice Class
Name | Description
BiometricType | Gets the type of biometric device.
IsSpoofDetectionSupported | Checks if the device is capable to detect spoof objects.
NativeType | Defines the native type of the object.
ProductId | Gets product device Id.
SpoofDetection | Gets or sets spoof detection value for biometric device.
VendorId | Gets device vendor Id.
Container

File: NBiometricDevice.cs

Namespace: Neurotec.Devices

Module: .NET Reference


NBiometricDevice.Cancel Method

NBiometricDevice.Cancel Method
NBiometricDevice Class Neurotec.Devices Namespace

Stops capturing and cancels NBiometricDevice (NFScanner or NIrisScanner)

C#
public void Cancel();
Collapse Expand Remarks

Also EndSequence method can be called which cancels device and stops sequence.


NBiometricDevice.Capture Method (NBiometric)

NBiometricDevice.Capture Method (NBiometric)
NBiometricDevice Class Neurotec.Devices Namespace

Starts capturing biometric data.

C#
public NBiometricStatus Capture(NBiometric biometric);
Collapse Expand Parameters
Parameters | Description
NBiometric biometric | NBiometric object.
Collapse Expand Returns

NBiometricStatus containing capture status.


NBiometricDevice.Capture Method (NBiometric, TimeSpan)

NBiometricDevice.Capture Method (NBiometric, TimeSpan)
NBiometricDevice Class Neurotec.Devices Namespace

Starts capturing biometric data.

C#
public NBiometricStatus Capture(NBiometric biometric, TimeSpan timeout);
Collapse Expand Parameters
Parameters | Description
NBiometric biometric | NBiometric object.
TimeSpan timeout | Capture timeout period in milliseconds.
Collapse Expand Returns

NBiometricStatus containing capture status.


NBiometricDevice.Capture Method (NBiometric, int)

NBiometricDevice.Capture Method (NBiometric, int)
NBiometricDevice Class Neurotec.Devices Namespace

Starts capturing biometric data.

C#
public NBiometricStatus Capture(NBiometric biometric, int timeoutMilliseconds);
Collapse Expand Parameters
Parameters | Description
NBiometric biometric | NBiometric object.
int timeoutMilliseconds | Capture timeout period in milliseconds.
Collapse Expand Returns

NBiometricStatus containing capture status.


NBiometricDevice.EndSequence Method

NBiometricDevice.EndSequence Method
NBiometricDevice Class Neurotec.Devices Namespace

Ends multiple images capturing sequence.

C#
public void EndSequence();


NBiometricDevice.StartSequence Method

NBiometricDevice.StartSequence Method
NBiometricDevice Class Neurotec.Devices Namespace

Starts sequence which prepares device for multiple capture operations.

C#
public void StartSequence();
Collapse Expand Remarks

Some devices do not support multiple capturing (sequences). When called for such devices, this method does nothing.

StartSequence method does not start capturing. Capturing should be started using Capture methods. This method should be called for each fingerprint/palmprint or iris image.

If capturing sequence was started, after capturing it should be ended by calling EndSequence method.


NBiometricDevice.BiometricType Property

NBiometricDevice.BiometricType Property
NBiometricDevice Class Neurotec.Devices Namespace

Gets the type of biometric device.

C#
public NBiometricType BiometricType;
Property value

Device biometric type.


NBiometricDevice.IsSpoofDetectionSupported Property

NBiometricDevice.IsSpoofDetectionSupported Property
NBiometricDevice Class Neurotec.Devices Namespace

Checks if the device is capable to detect spoof objects.

C#
public bool IsSpoofDetectionSupported;
Property value

true if device is capable to detect spoof objects; otherwise false.


NBiometricDevice.NativeType Property

NBiometricDevice.NativeType Property
NBiometricDevice Class Neurotec.Devices Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NBiometricDevice.ProductId Property

NBiometricDevice.ProductId Property
NBiometricDevice Class Neurotec.Devices Namespace

Gets product device Id.

C#
public ushort ProductId;
Property value

Product Id.


NBiometricDevice.SpoofDetection Property

NBiometricDevice.SpoofDetection Property
NBiometricDevice Class Neurotec.Devices Namespace

Gets or sets spoof detection value for biometric device.

C#
public bool SpoofDetection;
Property value

true if device is used to detect spoof objects; otherwise false.


NBiometricDevice.VendorId Property

NBiometricDevice.VendorId Property
NBiometricDevice Class Neurotec.Devices Namespace

Gets device vendor Id.

C#
public ushort VendorId;
Property value

Device vendor Id.


NBiometricDevice.CapturePreview Event

NBiometricDevice.CapturePreview Event
NBiometricDevice Class Neurotec.Devices Namespace

Adds or removes capture preview event to the specified biometric device.

C#
public event EventHandler<NBiometricDeviceCapturePreviewEventArgs> CapturePreview;


NBiometricDeviceCapturePreviewEventArgs Class

NBiometricDeviceCapturePreviewEventArgs Class
Legend Members Methods NBiometricDeviceCapturePreviewEventArgs Properties

Contains NBiometricDevice capture preview event arguments.

C#
public class NBiometricDeviceCapturePreviewEventArgs : EventArgs;
Collapse Expand NBiometricDeviceCapturePreviewEventArgs Properties
Name | Description
Biometric | Gets NBiometric object.
Container

File: NBiometricDevice.cs

Namespace: Neurotec.Devices

Module: .NET Reference


NBiometricDeviceCapturePreviewEventArgs.NBiometricDeviceCapturePreviewEventArgs Constructor

NBiometricDeviceCapturePreviewEventArgs.NBiometricDeviceCapturePreviewEventArgs Constructor
NBiometricDeviceCapturePreviewEventArgs Class Neurotec.Devices Namespace

Creates a new instance of NBiometricDeviceCapturePreviewEventArgs class.

C#
public NBiometricDeviceCapturePreviewEventArgs(NBiometric biometric);
Collapse Expand Parameters
Parameters | Description
NBiometric biometric | NBiometric object.


NBiometricDeviceCapturePreviewEventArgs.Biometric Property

NBiometricDeviceCapturePreviewEventArgs.Biometric Property
NBiometricDeviceCapturePreviewEventArgs Class Neurotec.Devices Namespace

Gets NBiometric object.

C#
public NBiometric Biometric;
Property value

NBiometric object.


NCamera Class

NCamera Class
NDevice Classes NObject Delegates NObject Events NObject Fields Legend Members NDisposable Methods NDisposable Properties

Provides methods for working with cameras.

C#
public sealed class NCamera : NCaptureDevice;
Collapse Expand NDevice Classes
NDevice Class
Name | Description
ChildCollection | Children collection of specified multimodal device.
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
NCaptureDevice Class
Show:
No members matching the current filter
Name | Description
IsCapturingChanged | Gets or sets
NCamera Class
Name | Description
StillCaptured | Adds or removes user specified event handler (controlling captured still image event) to NCamera.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NCaptureDevice Class
Show:
No members matching the current filter
Name | Description
GetCurrentFormat | Gets current media format of the capture device.
GetFormats | Gets all supported formats by the capture device.
SetCurrentFormat | Sets current media format for the capture device.
StartCapturing | Starts capturing.
StopCapturing | Stops capturing.
NCamera Class
Name | Description
CaptureStill | Gets a still image from capture device (camera).
Focus | Adjusts camera focus.
GetCurrentStillFormat | Gets the current still image format.
GetFrame | Gets current frame from the capture device.
GetStillFormats | Gets still image formats supported by specified camera.
GetVideoSample | Gets video sample from the capture device.
ResetFocus | Resets camera focus.
SetCurrentStillFormat | Sets the current still image format.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NDevice Class
Show:
No members matching the current filter
Name | Description
Children | Gets children collections of specified multimodal device.
DeviceType | Gets the type of multimodal device.
DisplayName | Gets device name
Id | Gets device Id.
IsAvailable | Checks if the device is available.
IsDisconnectable | Checks whether the device is disconnectable.
IsPrivate | Checks if the device is private.
Make | Gets device manufacturer.
Model | Gets model of current biometric device.
NDeviceTypeNativeType | Defines the native type of the device type.
NativeType | Defines the native type of the object.
Owner | Gets the owner of the device manager.
Parent | Gets the parent of specified multimodal device module.
Plugin | Gets device plugin.
SerialNumber | Gets serial number of current biometric device.
NCaptureDevice Class
Show:
No members matching the current filter
Name | Description
IsCapturing | Checks if the device is capturing.
MediaType | Gets the media type.
NativeType | Defines the native type of the object.
NCamera Class
Name | Description
FocusRegion | Gets or sets the focus region.
IsFocusRegionSupported | Checks whether the focus region is supported.
IsFocusSupported | Checks whether the focus is supported.
IsStillCaptureSupported | Checks whether still capture is supported.
IsVideoSampleSupported | Checks whether video sample captre is supported.
NCameraStatusNativeType | Defines the native type of the camera status.
NativeType | Defines the native type of the object.
Container

File: NCamera.cs

Namespace: Neurotec.Devices

Module: .NET Reference


NCamera.CaptureStill Method

NCamera.CaptureStill Method
NCamera Class Neurotec.Devices Namespace

Gets a still image from capture device (camera).

C#
public NCameraStatus CaptureStill();
Collapse Expand Returns

NCameraStatus object.

Collapse Expand Remarks

Captured still image (NImage) is retrieved by calling NCameraAddStillCapturedCallback (user defined function).


NCamera.Focus Method

NCamera.Focus Method
NCamera Class Neurotec.Devices Namespace

Adjusts camera focus.

C#
public NCameraStatus Focus();
Collapse Expand Returns

NCameraStatus object.


NCamera.GetCurrentStillFormat Method

NCamera.GetCurrentStillFormat Method
NCamera Class Neurotec.Devices Namespace

Gets the current still image format.

C#
public NVideoFormat GetCurrentStillFormat();
Collapse Expand Returns

One of NVideoFormat values.


NCamera.GetFrame Method ()

NCamera.GetFrame Method ()
NCamera Class Neurotec.Devices Namespace

Gets current frame from the capture device.

C#
public NImage GetFrame();
Collapse Expand Returns

Frame image.


NCamera.GetFrame Method (out TimeSpan, out TimeSpan)

NCamera.GetFrame Method (out TimeSpan, out TimeSpan)
NCamera Class Neurotec.Devices Namespace

Gets current frame from the capture device.

C#
public NImage GetFrame(out TimeSpan timeStamp, out TimeSpan duration);
Collapse Expand Parameters
Parameters | Description
out TimeSpan timeStamp | Time stamp (from the beginning). 100ns units.
out TimeSpan duration | Video sample duration (100ns units).
Collapse Expand Returns

Frame image.


NCamera.GetStillFormats Method

NCamera.GetStillFormats Method
NCamera Class Neurotec.Devices Namespace

Gets still image formats supported by specified camera.

C#
public NVideoFormat[] GetStillFormats();
Collapse Expand Returns

The allocated array of NVideoFormat structures describing all supported formats for the current capture device (camera).


NCamera.GetVideoSample Method

NCamera.GetVideoSample Method
NCamera Class Neurotec.Devices Namespace

Gets video sample from the capture device.

C#
public NVideoSample GetVideoSample();
Collapse Expand Returns

Video sample.


NCamera.ResetFocus Method

NCamera.ResetFocus Method
NCamera Class Neurotec.Devices Namespace

Resets camera focus.

C#
public void ResetFocus();


NCamera.SetCurrentStillFormat Method

NCamera.SetCurrentStillFormat Method
NCamera Class Neurotec.Devices Namespace

Sets the current still image format.

C#
public void SetCurrentStillFormat(NVideoFormat format);
Collapse Expand Parameters
Parameters | Description
NVideoFormat format | One of NVideoFormat values.


NCamera.FocusRegion Property

NCamera.FocusRegion Property
NCamera Class Neurotec.Devices Namespace

Gets or sets the focus region.

C#
[TypeConverter(typeof(ExpandableObjectConverter))]
public Nullable<RectangleF> FocusRegion;


NCamera.IsFocusRegionSupported Property

NCamera.IsFocusRegionSupported Property
NCamera Class Neurotec.Devices Namespace

Checks whether the focus region is supported.

C#
public bool IsFocusRegionSupported;


NCamera.IsFocusSupported Property

NCamera.IsFocusSupported Property
NCamera Class Neurotec.Devices Namespace

Checks whether the focus is supported.

C#
public bool IsFocusSupported;


NCamera.IsStillCaptureSupported Property

NCamera.IsStillCaptureSupported Property
NCamera Class Neurotec.Devices Namespace

Checks whether still capture is supported.

C#
public bool IsStillCaptureSupported;


NCamera.IsVideoSampleSupported Property

NCamera.IsVideoSampleSupported Property
NCamera Class Neurotec.Devices Namespace

Checks whether video sample captre is supported.

C#
public bool IsVideoSampleSupported;


NCamera.NCameraStatusNativeType Property

NCamera.NCameraStatusNativeType Property
NCamera Class Neurotec.Devices Namespace

Defines the native type of the camera status.

C#
public static NType NCameraStatusNativeType;


NCamera.NativeType Property

NCamera.NativeType Property
NCamera Class Neurotec.Devices Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NCamera.StillCaptured Event

NCamera.StillCaptured Event
NCamera Class Neurotec.Devices Namespace

Adds or removes user specified event handler (controlling captured still image event) to NCamera.

C#
public event EventHandler<NCameraStillCapturedEventArgs> StillCaptured;
Property value

User specified callback for still image captured event.


NCameraStillCapturedEventArgs Class

NCameraStillCapturedEventArgs Class
Legend Members Methods NCameraStillCapturedEventArgs Properties

Contains NCamera still image capture event arguments.

C#
public class NCameraStillCapturedEventArgs : EventArgs;
Collapse Expand NCameraStillCapturedEventArgs Properties
Name | Description
Id | Retrieves the camera ID.
Properties | Retrieves the event properties.
Stream | Retrieves the data stream.
Container

File: NCamera.cs

Namespace: Neurotec.Devices

Module: .NET Reference


NCameraStillCapturedEventArgs.NCameraStillCapturedEventArgs Constructor

NCameraStillCapturedEventArgs.NCameraStillCapturedEventArgs Constructor
NCameraStillCapturedEventArgs Class Neurotec.Devices Namespace

Creates a new instance of NCameraStillCapturedEventArgs class.

C#
public NCameraStillCapturedEventArgs(NStream stream, object id, NPropertyBag properties);
Collapse Expand Parameters
Parameters | Description
NStream stream | Data stream.
object id | Camera ID.
NPropertyBag properties | Event properties.


NCameraStillCapturedEventArgs.Id Property

NCameraStillCapturedEventArgs.Id Property
NCameraStillCapturedEventArgs Class Neurotec.Devices Namespace

Retrieves the camera ID.

C#
public object Id;


NCameraStillCapturedEventArgs.Properties Property

NCameraStillCapturedEventArgs.Properties Property
NCameraStillCapturedEventArgs Class Neurotec.Devices Namespace

Retrieves the event properties.

C#
public NPropertyBag Properties;


NCameraStillCapturedEventArgs.Stream Property

NCameraStillCapturedEventArgs.Stream Property
NCameraStillCapturedEventArgs Class Neurotec.Devices Namespace

Retrieves the data stream.

C#
public NStream Stream;


NCaptureDevice Class

NCaptureDevice Class
NDevice Classes NObject Delegates NObject Events NObject Fields Legend Members NDisposable Methods NDisposable Properties

Provides methods for working with capture devices.

C#
public class NCaptureDevice : NDevice;
Collapse Expand NDevice Classes
NDevice Class
Name | Description
ChildCollection | Children collection of specified multimodal device.
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
NCaptureDevice Class
Name | Description
IsCapturingChanged | Gets or sets
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NCaptureDevice Class
Name | Description
GetCurrentFormat | Gets current media format of the capture device.
GetFormats | Gets all supported formats by the capture device.
SetCurrentFormat | Sets current media format for the capture device.
StartCapturing | Starts capturing.
StopCapturing | Stops capturing.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NDevice Class
Show:
No members matching the current filter
Name | Description
Children | Gets children collections of specified multimodal device.
DeviceType | Gets the type of multimodal device.
DisplayName | Gets device name
Id | Gets device Id.
IsAvailable | Checks if the device is available.
IsDisconnectable | Checks whether the device is disconnectable.
IsPrivate | Checks if the device is private.
Make | Gets device manufacturer.
Model | Gets model of current biometric device.
NDeviceTypeNativeType | Defines the native type of the device type.
NativeType | Defines the native type of the object.
Owner | Gets the owner of the device manager.
Parent | Gets the parent of specified multimodal device module.
Plugin | Gets device plugin.
SerialNumber | Gets serial number of current biometric device.
NCaptureDevice Class
Name | Description
IsCapturing | Checks if the device is capturing.
MediaType | Gets the media type.
NativeType | Defines the native type of the object.
Container

File: NCaptureDevice.cs

Namespace: Neurotec.Devices

Module: .NET Reference


NCaptureDevice.GetCurrentFormat Method

NCaptureDevice.GetCurrentFormat Method
NCaptureDevice Class Neurotec.Devices Namespace

Gets current media format of the capture device.

C#
public NMediaFormat GetCurrentFormat();
Collapse Expand Returns

Current media format of capture device.


NCaptureDevice.GetFormats Method

NCaptureDevice.GetFormats Method
NCaptureDevice Class Neurotec.Devices Namespace

Gets all supported formats by the capture device.

C#
public NMediaFormat[] GetFormats();
Collapse Expand Returns

Array of supported media formats for the current capture device.


NCaptureDevice.SetCurrentFormat Method

NCaptureDevice.SetCurrentFormat Method
NCaptureDevice Class Neurotec.Devices Namespace

Sets current media format for the capture device.

C#
public void SetCurrentFormat(NMediaFormat format);
Collapse Expand Parameters
Parameters | Description
NMediaFormat format | Current media format to set.


NCaptureDevice.StartCapturing Method

NCaptureDevice.StartCapturing Method
NCaptureDevice Class Neurotec.Devices Namespace

Starts capturing.

C#
public void StartCapturing();


NCaptureDevice.StopCapturing Method

NCaptureDevice.StopCapturing Method
NCaptureDevice Class Neurotec.Devices Namespace

Stops capturing.

C#
public void StopCapturing();


NCaptureDevice.IsCapturing Property

NCaptureDevice.IsCapturing Property
NCaptureDevice Class Neurotec.Devices Namespace

Checks if the device is capturing.

C#
public bool IsCapturing;
Property value

bool type value indicating if the device is capturing.


NCaptureDevice.MediaType Property

NCaptureDevice.MediaType Property
NCaptureDevice Class Neurotec.Devices Namespace

Gets the media type.

C#
public NMediaType MediaType;


NCaptureDevice.NativeType Property

NCaptureDevice.NativeType Property
NCaptureDevice Class Neurotec.Devices Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NCaptureDevice.IsCapturingChanged Event

NCaptureDevice.IsCapturingChanged Event
NCaptureDevice Class Neurotec.Devices Namespace

Gets or sets

C#
public event EventHandler<EventArgs> IsCapturingChanged;
Property value

Value


NDevice Class

NDevice Class
NDevice Classes NObject Delegates NObject Events NObject Fields Legend Members NDisposable Methods NDisposable Properties

Provides functionality for retrieving device information.

C#
public class NDevice : NObject;
Collapse Expand NDevice Classes
NDevice Class
Name | Description
ChildCollection | Children collection of specified multimodal device.
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NDevice Class
Name | Description
Children | Gets children collections of specified multimodal device.
DeviceType | Gets the type of multimodal device.
DisplayName | Gets device name
Id | Gets device Id.
IsAvailable | Checks if the device is available.
IsDisconnectable | Checks whether the device is disconnectable.
IsPrivate | Checks if the device is private.
Make | Gets device manufacturer.
Model | Gets model of current biometric device.
NDeviceTypeNativeType | Defines the native type of the device type.
NativeType | Defines the native type of the object.
Owner | Gets the owner of the device manager.
Parent | Gets the parent of specified multimodal device module.
Plugin | Gets device plugin.
SerialNumber | Gets serial number of current biometric device.
Container

File: NDevice.cs

Namespace: Neurotec.Devices

Module: .NET Reference


NDevice.ChildCollection Class

NDevice.ChildCollection Class

Children collection of specified multimodal device.

C#
public class ChildCollection : NObjectReadOnlyCollection<NDevice>;
Container

File: NDevice.cs

Namespace: Neurotec.Devices

Module: .NET Reference


NDevice.Children Property

NDevice.Children Property
NDevice Class Neurotec.Devices Namespace

Gets children collections of specified multimodal device.

C#
public ChildCollection Children;
Property value

Device children collection.


NDevice.DeviceType Property

NDevice.DeviceType Property
NDevice Class Neurotec.Devices Namespace

Gets the type of multimodal device.

C#
public NDeviceType DeviceType;
Property value

Device type value.


NDevice.DisplayName Property

NDevice.DisplayName Property
NDevice Class Neurotec.Devices Namespace

Gets device name

C#
public string DisplayName;
Property value

String containing device display name.


NDevice.Id Property

NDevice.Id Property
NDevice Class Neurotec.Devices Namespace

Gets device Id.

C#
public string Id;
Property value

String containing device Id.


NDevice.IsAvailable Property

NDevice.IsAvailable Property
NDevice Class Neurotec.Devices Namespace

Checks if the device is available.

C#
public bool IsAvailable;
Property value

Boolean value indicating if the device is available.


NDevice.IsDisconnectable Property

NDevice.IsDisconnectable Property
NDevice Class Neurotec.Devices Namespace

Checks whether the device is disconnectable.

C#
public bool IsDisconnectable;


NDevice.IsPrivate Property

NDevice.IsPrivate Property
NDevice Class Neurotec.Devices Namespace

Checks if the device is private.

C#
public bool IsPrivate;
Property value

Boolean value indicating if the device is private.


NDevice.Make Property

NDevice.Make Property
NDevice Class Neurotec.Devices Namespace

Gets device manufacturer.

C#
public string Make;
Property value

String containing device manufacturer.


NDevice.Model Property

NDevice.Model Property
NDevice Class Neurotec.Devices Namespace

Gets model of current biometric device.

C#
public string Model;
Property value

String containing device model name.


NDevice.NDeviceTypeNativeType Property

NDevice.NDeviceTypeNativeType Property
NDevice Class Neurotec.Devices Namespace

Defines the native type of the device type.

C#
public static NType NDeviceTypeNativeType;


NDevice.NativeType Property

NDevice.NativeType Property
NDevice Class Neurotec.Devices Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NDevice.Owner Property

NDevice.Owner Property
NDevice Class Neurotec.Devices Namespace

Gets the owner of the device manager.

C#
[Browsable(false)]
public new NDeviceManager Owner;


NDevice.Parent Property

NDevice.Parent Property
NDevice Class Neurotec.Devices Namespace

Gets the parent of specified multimodal device module.

C#
public NDevice Parent;
Property value

Parent of multimodal device.


NDevice.Plugin Property

NDevice.Plugin Property
NDevice Class Neurotec.Devices Namespace

Gets device plugin.

C#
public NPlugin Plugin;
Property value

Device plugin.


NDevice.SerialNumber Property

NDevice.SerialNumber Property
NDevice Class Neurotec.Devices Namespace

Gets serial number of current biometric device.

C#
public string SerialNumber;
Property value

String containing device serial number.


NDeviceManager Class

NDeviceManager Class
NDeviceManager Classes NObject Delegates NObject Events NObject Fields Legend Members Methods NDisposable Methods NDisposable Properties

Provides functionality for managing devices.

C#
public sealed class NDeviceManager : NObject;
Collapse Expand NDeviceManager Classes
NDeviceManager Class
Name | Description
DeviceCollection | Holds all devices data of the current NDeviceManager object.
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NDeviceManager Class
Name | Description
ConnectToDevice | Connects to specified device using NPlugin and NPropertyBag parameters.
DisconnectFromDevice | Disconnects from specified device.
GetConnectToDeviceParameters | Gets connection parameters for a device from a specified plugin.
Initialize | Initializes a device manager.
IsConnectToDeviceSupported | Checks whether the specified plugin supports connection to device.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NDeviceManager Class
Name | Description
AutoPlug | Gets or sets if a device can be auto-plugged to device manager.
BiometricEngine | Gets or sets the biometric engine used by the device manager.
DeviceTypes | Gets supported device types by NDeviceManager.
Devices | Gets devices collection of the current NDeviceManager object.
IsInitialized | Checks whether the specialized device manager is initialized.
NativeType | Defines the native type of the object.
PluginManager | Gets the plugin manager of the current object.
Container

File: NDeviceManager.cs

Namespace: Neurotec.Devices

Module: .NET Reference


NDeviceManager.NDeviceManager Constructor

NDeviceManager.NDeviceManager Constructor
NDeviceManager Class Neurotec.Devices Namespace

Initializes a new instance of the NDeviceManager class.

C#
public NDeviceManager();


NDeviceManager.DeviceCollection Class

NDeviceManager.DeviceCollection Class
Legend Members DeviceCollection Methods

Holds all devices data of the current NDeviceManager object.

C#
public sealed class DeviceCollection : NObjectReadOnlyCollection<NDevice>;
Collapse Expand DeviceCollection Methods
Name | Description
IndexOf | Retrieves device's index in a collection by specified device Id.
this | Gets NDevice object specified by Id.
Container

File: NDeviceManager.cs

Namespace: Neurotec.Devices

Module: .NET Reference


NDeviceManager.DeviceCollection.IndexOf Method

NDeviceManager.DeviceCollection.IndexOf Method
NDeviceManager.DeviceCollection Class Neurotec.Devices Namespace

Retrieves device's index in a collection by specified device Id.

C#
public int IndexOf(string id);
Collapse Expand Parameters
Parameters | Description
string id | Device identifier.
Collapse Expand Returns

Device index in the collection.


NDeviceManager.DeviceCollection.this Indexer

NDeviceManager.DeviceCollection.this Indexer
NDeviceManager.DeviceCollection Class Neurotec.Devices Namespace

Gets NDevice object specified by Id.

C#
public NDevice this[string id];
Collapse Expand Parameters
Parameters | Description
string id | Device Id.
Collapse Expand Returns

NDevice object.


NDeviceManager.ConnectToDevice Method (NPlugin, NPropertyBag)

NDeviceManager.ConnectToDevice Method (NPlugin, NPropertyBag)
NDeviceManager Class Neurotec.Devices Namespace

Connects to specified device using NPlugin and NPropertyBag parameters.

C#
public NDevice ConnectToDevice(NPlugin plugin, NPropertyBag parameters);
Collapse Expand Parameters
Parameters | Description
NPlugin plugin | Device plugin used to establish a connection.
NPropertyBag parameters | Properties used for connection.
Collapse Expand Returns

NDevice to which a connection was established.


NDeviceManager.ConnectToDevice Method (string, string)

NDeviceManager.ConnectToDevice Method (string, string)
NDeviceManager Class Neurotec.Devices Namespace

Connects to a device using specified plugin and connection parameters.

C#
public NDevice ConnectToDevice(string plugin, string parameters);
Collapse Expand Parameters
Parameters | Description
string plugin | String containing plugin name (e.g. "Media").
string parameters | String containing camera parameters (e.g. "FileName=C:video.avi;MediaType=nmtVideo").
Collapse Expand Returns

NDevice to which a connection was established.


NDeviceManager.DisconnectFromDevice Method

NDeviceManager.DisconnectFromDevice Method
NDeviceManager Class Neurotec.Devices Namespace

Disconnects from specified device.

C#
public void DisconnectFromDevice(NDevice device);
Collapse Expand Parameters
Parameters | Description
NDevice device | The device to disconnect.


NDeviceManager.GetConnectToDeviceParameters Method

NDeviceManager.GetConnectToDeviceParameters Method
NDeviceManager Class Neurotec.Devices Namespace

Gets connection parameters for a device from a specified plugin.

C#
public static NParameterDescriptor[] GetConnectToDeviceParameters(NPlugin plugin);
Collapse Expand Parameters
Parameters | Description
NPlugin plugin | The device plugin.
Collapse Expand Returns

An array of connection parameters supported by specified plugin.


NDeviceManager.Initialize Method

NDeviceManager.Initialize Method
NDeviceManager Class Neurotec.Devices Namespace

Initializes a device manager.

C#
public void Initialize();


NDeviceManager.IsConnectToDeviceSupported Method

NDeviceManager.IsConnectToDeviceSupported Method
NDeviceManager Class Neurotec.Devices Namespace

Checks whether the specified plugin supports connection to device.

C#
public static bool IsConnectToDeviceSupported(NPlugin plugin);
Collapse Expand Parameters
Parameters | Description
NPlugin plugin | The device plugin.
Collapse Expand Returns

true if connection is supported; else false.


NDeviceManager.AutoPlug Property

NDeviceManager.AutoPlug Property
NDeviceManager Class Neurotec.Devices Namespace

Gets or sets if a device can be auto-plugged to device manager.

C#
public bool AutoPlug;
Property value

true if a device can be auto-plugged' otherwise - false.


NDeviceManager.BiometricEngine Property

NDeviceManager.BiometricEngine Property
NDeviceManager Class Neurotec.Devices Namespace

Gets or sets the biometric engine used by the device manager.

C#
public NBiometricEngine BiometricEngine;
Property value

NBiometricEngine object.


NDeviceManager.DeviceTypes Property

NDeviceManager.DeviceTypes Property
NDeviceManager Class Neurotec.Devices Namespace

Gets supported device types by NDeviceManager.

C#
public NDeviceType DeviceTypes;
Property value

Supported device types.


NDeviceManager.Devices Property

NDeviceManager.Devices Property
NDeviceManager Class Neurotec.Devices Namespace

Gets devices collection of the current NDeviceManager object.

C#
public DeviceCollection Devices;
Property value

Device collection containing all devices of the current NDeviceManager.


NDeviceManager.IsInitialized Property

NDeviceManager.IsInitialized Property
NDeviceManager Class Neurotec.Devices Namespace

Checks whether the specialized device manager is initialized.

C#
public bool IsInitialized;
Property value

true if the device manager was initialized; otherwise - false.


NDeviceManager.NativeType Property

NDeviceManager.NativeType Property
NDeviceManager Class Neurotec.Devices Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NDeviceManager.PluginManager Property

NDeviceManager.PluginManager Property
NDeviceManager Class Neurotec.Devices Namespace

Gets the plugin manager of the current object.

C#
public static NPluginManager PluginManager;


NDeviceManagerDeviceEventArgs Class

NDeviceManagerDeviceEventArgs Class
Legend Members Methods NDeviceManagerDeviceEventArgs Properties

Contains device manager device event arguments.

C#
[Serializable]
public class NDeviceManagerDeviceEventArgs : EventArgs;
Collapse Expand NDeviceManagerDeviceEventArgs Properties
Name | Description
Device | Gets the device.
Container

File: NDeviceManager.cs

Namespace: Neurotec.Devices

Module: .NET Reference


NDeviceManagerDeviceEventArgs.NDeviceManagerDeviceEventArgs Constructor

NDeviceManagerDeviceEventArgs.NDeviceManagerDeviceEventArgs Constructor
NDeviceManagerDeviceEventArgs Class Neurotec.Devices Namespace

Initializes a new instance of NDeviceManagerDeviceEventArgs class.

C#
public NDeviceManagerDeviceEventArgs(NDevice device);
Collapse Expand Parameters
Parameters | Description
NDevice device | The device.


NDeviceManagerDeviceEventArgs.Device Property

NDeviceManagerDeviceEventArgs.Device Property
NDeviceManagerDeviceEventArgs Class Neurotec.Devices Namespace

Gets the device.

C#
public NDevice Device;


NDevices Class

NDevices Class
NDevices Fields Legend Members NDevices Properties

Provides functionality for retrieving information about NDevices library.

C#
public static class NDevices;
Collapse Expand NDevices Fields
Name | Description
DllName | NDevices library's Dll name.
Collapse Expand NDevices Properties
Name | Description
NativeModule | Defines the native module of the object.
Container

File: NDevices.cs

Namespace: Neurotec.Devices

Module: .NET Reference


NDevices.DllName Field

NDevices.DllName Field
NDevices Class Neurotec.Devices Namespace

NDevices library's Dll name.

C#
public const string DllName = NVersionInfo.DevicesDllName;


NDevices.NativeModule Property

NDevices.NativeModule Property
NDevices Class Neurotec.Devices Namespace

Defines the native module of the object.

C#
public static NModule NativeModule;


Neurotec.Devices.NCameraStatus Enumeration

Neurotec.Devices.NCameraStatus Enumeration

Enumerates camera status values.

C#
[Serializable]
public enum NCameraStatus {
  None = 0,
  Ok = 1,
  AutoFocusFailure = 2,
  LensClosed = 3,
  MirrorUp = 4,
  SensorCleaning = 5,
  SilentOperation = 6,
  StroboCharge = 7,
  NoLens = 8
}
Collapse Expand Members
Members | Description
None = 0 | Reserved for future use.
Ok = 1 | Indicates that camera is ready to use.
AutoFocusFailure = 2 | Indicates that camera failed to auto focus an object.
LensClosed = 3 | Indicates that camera lens are closed.
MirrorUp = 4 | Indicates that camera mirror is up (when DSLR is used).
SensorCleaning = 5 | Indicates that camera is performing sensor cleaning.
SilentOperation = 6 | Indicates that camera is operating in silent mode.
StroboCharge = 7 | Indicates that camera strobe is charging.
NoLens = 8 | Indicates that no lens were attached to the camera.
Container

File: NCamera.cs

Namespace: Neurotec.Devices

Module: .NET Reference


Neurotec.Devices.NDeviceType Enumeration

Neurotec.Devices.NDeviceType Enumeration

Enumerates device type values.

C#
[Serializable]
[Flags]
public enum NDeviceType {
  None = 0,
  Camera = 0x01,
  BiometricDevice = 0x02,
  FScanner = 0x04,
  FingerScanner = 0x08,
  PalmScanner = 0x10,
  IrisScanner = 0x20,
  CaptureDevice = 0x40,
  Microphone = 0x80,
  SignatureScanner = 0x100,
  Any = unchecked((int)0x80000000)
}
Collapse Expand Members
Members | Description
None = 0 | This value is used for primitive devices (e.g. for parent devices). NDeviceManager has such devices only if NDeviceManager was created using Any value for NDeviceType.
Camera = 0x01 | Indicates that device type is camera.
BiometricDevice = 0x02 | Indicates FingerScanner, IrisScanner and SignatureScanner values of this enumeration. For instance, if this value is returned by DeviceTypes property, it means that NDeviceManager type is one of the following: FingerScanner, IrisScanner or SignatureScanner.
FScanner = 0x04 | Indicates that device is a scanner which can be used for friction ridges (fingers or palms) scanning. If FScanner value is passed to on of NDeviceManager constructors, it means that device which supports all friction ridge scanning devices will be created.
FingerScanner = 0x08 | Indicates that device type is fingerprints scanner (FScanner scanner which can also scan fingerprints).
PalmScanner = 0x10 | Indicates that device type is palmprints scanner (FScanner scanner which can also scan palmprints).
IrisScanner = 0x20 | Indicates that device type is iris scanner.
CaptureDevice = 0x40 | Indicates that device type is capture device.
Microphone = 0x80 | Indicates that device type is microphone.
SignatureScanner = 0x100 | Indicates that device type is signature scanner.
Any = unchecked((int)0x80000000) | This value indicates that NDeviceManager supports all available device types. For instance, when Any value is passed to one of NDeviceManager constructors, new NDeviceManager which supports all device modules (cameras, fingerprint, iris, palmprint scanners, etc.) is created. Also this value is returned when NDeviceManager does not recognize device's type (e.g. device's module version is newer than NDeviceManager). NDeviceManager type can be retrieved using DeviceTypes property.
Container

File: NDevice.cs

Namespace: Neurotec.Devices

Module: .NET Reference


Neurotec.Devices.ComponentModel Namespace

Neurotec.Devices.ComponentModel Namespace
Classes Legend

Classes under this namespace provide devices component model.

Collapse Expand Classes
Name | Description
NDeviceEventDescriptor | Provides functionality for creating device event descriptors.
NDeviceMethodDescriptor | Provides functionality for creating device method descriptors.
NDevicePropertyDescriptor | Provides functionality for creating device property descriptors.


NDeviceEventDescriptor Class

NDeviceEventDescriptor Class
Legend Members NDeviceEventDescriptor Properties

Provides functionality for creating device event descriptors.

C#
public sealed class NDeviceEventDescriptor : NCustomEventDescriptor;
Collapse Expand NDeviceEventDescriptor Properties
Name | Description
NativeType | Defines the native type of the object.
Container

File: NDeviceEventDescriptor.cs

Namespace: Neurotec.Devices.ComponentModel

Module: .NET Reference


NDeviceEventDescriptor.NativeType Property

NDeviceEventDescriptor.NativeType Property
NDeviceEventDescriptor Class Neurotec.Devices.ComponentModel Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NDeviceMethodDescriptor Class

NDeviceMethodDescriptor Class
Legend Members NDeviceMethodDescriptor Properties

Provides functionality for creating device method descriptors.

C#
public sealed class NDeviceMethodDescriptor : NCustomMethodDescriptor;
Collapse Expand NDeviceMethodDescriptor Properties
Name | Description
NativeType | Defines the native type of the object.
Container

File: NDeviceMethodDescriptor.cs

Namespace: Neurotec.Devices.ComponentModel

Module: .NET Reference


NDeviceMethodDescriptor.NativeType Property

NDeviceMethodDescriptor.NativeType Property
NDeviceMethodDescriptor Class Neurotec.Devices.ComponentModel Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NDevicePropertyDescriptor Class

NDevicePropertyDescriptor Class
Legend Members NDevicePropertyDescriptor Properties

Provides functionality for creating device property descriptors.

C#
public sealed class NDevicePropertyDescriptor : NCustomPropertyDescriptor;
Collapse Expand NDevicePropertyDescriptor Properties
Name | Description
NativeType | Defines the native type of the object.
Container

File: NDevicePropertyDescriptor.cs

Namespace: Neurotec.Devices.ComponentModel

Module: .NET Reference


NDevicePropertyDescriptor.NativeType Property

NDevicePropertyDescriptor.NativeType Property
NDevicePropertyDescriptor Class Neurotec.Devices.ComponentModel Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


Neurotec.Geometry Namespace

Neurotec.Geometry Namespace
Classes Legend

Provides definitions of geometrical structures types.

Collapse Expand Classes
Name | Description
NGeometry | Provides definitions of geometrical structures types.


NGeometry Class

NGeometry Class
Legend Members NGeometry Properties

Provides definitions of geometrical structures types.

C#
public static class NGeometry;
Collapse Expand NGeometry Properties
Name | Description
InterpolationModeNativeType | Defines the native type of the interpolation mode.
NativeType | Defines the native type of the object.
PointDNativeType | Defines the native type of the point D.
PointFNativeType | Defines the native type of the point F.
PointNativeType | Defines the native type of the point.
RectangleDNativeType | Defines the native type of the rectangle D.
RectangleFNativeType | Defines the native type of the rectangle F.
RectangleNativeType | Defines the native type of the rectangle.
SizeDNativeType | Defines the native type of the size D.
SizeFNativeType | Defines the native type of the size F.
SizeNativeType | Defines the native type of the size.
Container

File: NGeometry.cs

Namespace: Neurotec.Geometry

Module: .NET Reference


NGeometry.InterpolationModeNativeType Property

NGeometry.InterpolationModeNativeType Property
NGeometry Class Neurotec.Geometry Namespace

Defines the native type of the interpolation mode.

C#
public static NType InterpolationModeNativeType;


NGeometry.NativeType Property

NGeometry.NativeType Property
NGeometry Class Neurotec.Geometry Namespace

Defines the native type of the object.

C#
public static NType NativeType;


NGeometry.PointDNativeType Property

NGeometry.PointDNativeType Property
NGeometry Class Neurotec.Geometry Namespace

Defines the native type of the point D.

C#
public static NType PointDNativeType;


NGeometry.PointFNativeType Property

NGeometry.PointFNativeType Property
NGeometry Class Neurotec.Geometry Namespace

Defines the native type of the point F.

C#
public static NType PointFNativeType;


NGeometry.PointNativeType Property

NGeometry.PointNativeType Property
NGeometry Class Neurotec.Geometry Namespace

Defines the native type of the point.

C#
public static NType PointNativeType;


NGeometry.RectangleDNativeType Property

NGeometry.RectangleDNativeType Property
NGeometry Class Neurotec.Geometry Namespace

Defines the native type of the rectangle D.

C#
public static NType RectangleDNativeType;


NGeometry.RectangleFNativeType Property

NGeometry.RectangleFNativeType Property
NGeometry Class Neurotec.Geometry Namespace

Defines the native type of the rectangle F.

C#
public static NType RectangleFNativeType;


NGeometry.RectangleNativeType Property

NGeometry.RectangleNativeType Property
NGeometry Class Neurotec.Geometry Namespace

Defines the native type of the rectangle.

C#
public static NType RectangleNativeType;


NGeometry.SizeDNativeType Property

NGeometry.SizeDNativeType Property
NGeometry Class Neurotec.Geometry Namespace

Defines the native type of the size D.

C#
public static NType SizeDNativeType;


NGeometry.SizeFNativeType Property

NGeometry.SizeFNativeType Property
NGeometry Class Neurotec.Geometry Namespace

Defines the native type of the size F.

C#
public static NType SizeFNativeType;


NGeometry.SizeNativeType Property

NGeometry.SizeNativeType Property
NGeometry Class Neurotec.Geometry Namespace

Defines the native type of the size.

C#
public static NType SizeNativeType;


Neurotec.IO Namespace

Neurotec.IO Namespace
Classes Legend

Classes under this namespace provide infrastructure for Neurotechnology components.

Collapse Expand Classes
Name | Description
NBuffer | Provides buffer management functionality.
NMemoryStream | Provides access to unmanaged blocks of memory from managed code.
NStream | This class supports internal Neurotechnology libraries infrastructure and should not be used directly in your code.


NBuffer Class

NBuffer Class
NObject Delegates NObject Events NObject Fields Legend Members Methods NDisposable Methods NDisposable Properties

Provides buffer management functionality.

C#
public sealed class NBuffer : NObject;
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NBuffer Class
Name | Description
Copy | Copies bytes from one buffer into another with specified offsets into both buffers and size.
CopyFrom | Copies bytes from the specified buffer into the current buffer.
CopyTo | Copies bytes from the current buffer into the buffer specified by pointer with specified size.
ToArray | Copies the elements of the NBuffer to a new byte array.
WriteTo | Writes the contents of NBuffer to memory stream.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NBuffer Class
Name | Description
Empty | Gets or sets an empty NBuffer.
LongSize | Gets a 64-bit integer that represents the length of NBuffer.
NativeSize | Gets UIntPtr that represents the length of NBuffer.
NativeType | Defines the native type of the object.
Ptr | Gets a representation of NBuffer pointer.
Size | Gets the length of NBuffer.
Container

File: NBuffer.cs

Namespace: Neurotec.IO

Module: .NET Reference


NBuffer.NBuffer Constructor (IntPtr, UIntPtr)

NBuffer.NBuffer Constructor (IntPtr, UIntPtr)
NBuffer Class Neurotec.IO Namespace
C#
public NBuffer(IntPtr ptr, UIntPtr size);
Collapse Expand Parameters
Parameters | Description
IntPtr ptr | _nt_
UIntPtr size | _nt_


NBuffer.NBuffer Constructor (IntPtr, UIntPtr, NMemoryType)

NBuffer.NBuffer Constructor (IntPtr, UIntPtr, NMemoryType)
NBuffer Class Neurotec.IO Namespace
C#
public NBuffer(IntPtr ptr, UIntPtr size, NMemoryType ptrType);
Collapse Expand Parameters
Parameters | Description
IntPtr ptr | _nt_
UIntPtr size | _nt_
NMemoryType ptrType | _nt_


NBuffer.NBuffer Constructor (IntPtr, UIntPtr, bool)

NBuffer.NBuffer Constructor (IntPtr, UIntPtr, bool)
NBuffer Class Neurotec.IO Namespace
C#
public NBuffer(IntPtr ptr, UIntPtr size, bool ownsPtr);
Collapse Expand Parameters
Parameters | Description
IntPtr ptr | _nt_
UIntPtr size | _nt_
bool ownsPtr | _nt_


NBuffer.NBuffer Constructor (IntPtr, int)

NBuffer.NBuffer Constructor (IntPtr, int)
NBuffer Class Neurotec.IO Namespace

Initializes a new instance of the NBuffer class.

C#
public NBuffer(IntPtr ptr, int size);
Collapse Expand Parameters
Parameters | Description
IntPtr ptr | A pointer to buffer.
int size | Size of a buffer.


NBuffer.NBuffer Constructor (IntPtr, int, NMemoryType)

NBuffer.NBuffer Constructor (IntPtr, int, NMemoryType)
NBuffer Class Neurotec.IO Namespace
C#
public NBuffer(IntPtr ptr, int size, NMemoryType ptrType);
Collapse Expand Parameters
Parameters | Description
IntPtr ptr | _nt_
int size | _nt_
NMemoryType ptrType | _nt_


NBuffer.NBuffer Constructor (IntPtr, int, bool)

NBuffer.NBuffer Constructor (IntPtr, int, bool)
NBuffer Class Neurotec.IO Namespace
C#
public NBuffer(IntPtr ptr, int size, bool ownsPtr);
Collapse Expand Parameters
Parameters | Description
IntPtr ptr | _nt_
int size | _nt_
bool ownsPtr | _nt_


NBuffer.NBuffer Constructor (IntPtr, long)

NBuffer.NBuffer Constructor (IntPtr, long)
NBuffer Class Neurotec.IO Namespace
C#
public NBuffer(IntPtr ptr, long size);
Collapse Expand Parameters
Parameters | Description
IntPtr ptr | _nt_
long size | _nt_


NBuffer.NBuffer Constructor (IntPtr, long, NMemoryType)

NBuffer.NBuffer Constructor (IntPtr, long, NMemoryType)
NBuffer Class Neurotec.IO Namespace
C#
public NBuffer(IntPtr ptr, long size, NMemoryType ptrType);
Collapse Expand Parameters
Parameters | Description
IntPtr ptr | _nt_
long size | _nt_
NMemoryType ptrType | _nt_


NBuffer.NBuffer Constructor (IntPtr, long, bool)

NBuffer.NBuffer Constructor (IntPtr, long, bool)
NBuffer Class Neurotec.IO Namespace
C#
public NBuffer(IntPtr ptr, long size, bool ownsPtr);
Collapse Expand Parameters
Parameters | Description
IntPtr ptr | _nt_
long size | _nt_
bool ownsPtr | _nt_


NBuffer.NBuffer Constructor (NBuffer, UIntPtr, UIntPtr)

NBuffer.NBuffer Constructor (NBuffer, UIntPtr, UIntPtr)
NBuffer Class Neurotec.IO Namespace
C#
public NBuffer(NBuffer srcBuffer, UIntPtr offset, UIntPtr size);
Collapse Expand Parameters
Parameters | Description
NBuffer srcBuffer | _nt_
UIntPtr offset | _nt_
UIntPtr size | _nt_


NBuffer.NBuffer Constructor (NBuffer, int, int)

NBuffer.NBuffer Constructor (NBuffer, int, int)
NBuffer Class Neurotec.IO Namespace
C#
public NBuffer(NBuffer srcBuffer, int offset, int size);
Collapse Expand Parameters
Parameters | Description
NBuffer srcBuffer | _nt_
int offset | _nt_
int size | _nt_


NBuffer.NBuffer Constructor (NBuffer, long, long)

NBuffer.NBuffer Constructor (NBuffer, long, long)
NBuffer Class Neurotec.IO Namespace
C#
public NBuffer(NBuffer srcBuffer, long offset, long size);
Collapse Expand Parameters
Parameters | Description
NBuffer srcBuffer | _nt_
long offset | _nt_
long size | _nt_


NBuffer.NBuffer Constructor (UIntPtr)

NBuffer.NBuffer Constructor (UIntPtr)
NBuffer Class Neurotec.IO Namespace
C#
public NBuffer(UIntPtr size);
Collapse Expand Parameters
Parameters | Description
UIntPtr size | _nt_


NBuffer.NBuffer Constructor (byte[])

NBuffer.NBuffer Constructor (byte[])
NBuffer Class Neurotec.IO Namespace
C#
public NBuffer(byte[] array);
Collapse Expand Parameters
Parameters | Description
byte[] array | _nt_


NBuffer.NBuffer Constructor (byte[], int, int)

NBuffer.NBuffer Constructor (byte[], int, int)
NBuffer Class Neurotec.IO Namespace
C#
public NBuffer(byte[] array, int arrayIndex, int arrayCount);
Collapse Expand Parameters
Parameters | Description
byte[] array | _nt_
int arrayIndex | _nt_
int arrayCount | _nt_


NBuffer.NBuffer Constructor (int)

NBuffer.NBuffer Constructor (int)
NBuffer Class Neurotec.IO Namespace
C#
public NBuffer(int size);
Collapse Expand Parameters
Parameters | Description
int size | _nt_


NBuffer.NBuffer Constructor (long)

NBuffer.NBuffer Constructor (long)
NBuffer Class Neurotec.IO Namespace
C#
public NBuffer(long size);
Collapse Expand Parameters
Parameters | Description
long size | _nt_


NBuffer.Copy Method (NBuffer, UIntPtr, NBuffer, UIntPtr, UIntPtr)

NBuffer.Copy Method (NBuffer, UIntPtr, NBuffer, UIntPtr, UIntPtr)
NBuffer Class Neurotec.IO Namespace

Copies bytes from one buffer into another with specified offsets into both buffers and size.

C#
public static void Copy(NBuffer srcBuffer, UIntPtr srcOffset, NBuffer dstBuffer, UIntPtr dstOffset, UIntPtr size);
Collapse Expand Parameters
Parameters | Description
NBuffer srcBuffer | The source buffer.
UIntPtr srcOffset | Offset into the source buffer.
NBuffer dstBuffer | The destination buffer.
UIntPtr dstOffset | Offset into the destination buffer.
UIntPtr size | The buffer size.


NBuffer.Copy Method (NBuffer, int, NBuffer, int, int)

NBuffer.Copy Method (NBuffer, int, NBuffer, int, int)
NBuffer Class Neurotec.IO Namespace

Copies bytes from one buffer into another with specified offsets into both buffers and size.

C#
public static void Copy(NBuffer srcBuffer, int srcOffset, NBuffer dstBuffer, int dstOffset, int size);
Collapse Expand Parameters
Parameters | Description
NBuffer srcBuffer | The source buffer.
int srcOffset | Offset into the source buffer.
NBuffer dstBuffer | The destination buffer.
int dstOffset | Offset into the destination buffer.
int size | The buffer size.


NBuffer.Copy Method (NBuffer, long, NBuffer, long, long)

NBuffer.Copy Method (NBuffer, long, NBuffer, long, long)
NBuffer Class Neurotec.IO Namespace

Copies bytes from one buffer into another with specified offsets into both buffers and size.

C#
public static void Copy(NBuffer srcBuffer, long srcOffset, NBuffer dstBuffer, long dstOffset, long size);
Collapse Expand Parameters
Parameters | Description
NBuffer srcBuffer | The source buffer.
long srcOffset | Offset into the source buffer.
NBuffer dstBuffer | The destination buffer.
long dstOffset | Offset into the destination buffer.
long size | The buffer size.


NBuffer.CopyFrom Method (IntPtr, UIntPtr, UIntPtr)

NBuffer.CopyFrom Method (IntPtr, UIntPtr, UIntPtr)
NBuffer Class Neurotec.IO Namespace

Copies bytes from the specified buffer into the current buffer.

C#
public void CopyFrom(IntPtr pSrcBuffer, UIntPtr srcBufferSize, UIntPtr offset);
Collapse Expand Parameters
Parameters | Description
IntPtr pSrcBuffer | Pointer to the source buffer.
UIntPtr srcBufferSize | Size of the source buffer.
UIntPtr offset | Offset into the current buffer.


NBuffer.CopyFrom Method (IntPtr, int, int)

NBuffer.CopyFrom Method (IntPtr, int, int)
NBuffer Class Neurotec.IO Namespace

Copies bytes from the specified buffer into the current buffer.

C#
public void CopyFrom(IntPtr pSrcBuffer, int srcBufferSize, int offset);
Collapse Expand Parameters
Parameters | Description
IntPtr pSrcBuffer | Pointer to the source buffer.
int srcBufferSize | Size of the source buffer.
int offset | Offset into the current buffer.


NBuffer.CopyFrom Method (IntPtr, long, long)

NBuffer.CopyFrom Method (IntPtr, long, long)
NBuffer Class Neurotec.IO Namespace

Copies bytes from the specified buffer into the current buffer.

C#
public void CopyFrom(IntPtr pSrcBuffer, long srcBufferSize, long offset);
Collapse Expand Parameters
Parameters | Description
IntPtr pSrcBuffer | Pointer to the source buffer.
long srcBufferSize | Size of the source buffer.
long offset | Offset into the current buffer.


NBuffer.CopyFrom Method (byte[], int, int, int)

NBuffer.CopyFrom Method (byte[], int, int, int)
NBuffer Class Neurotec.IO Namespace

Copies bytes from the specified byte array at specified index to the current buffer.

C#
public void CopyFrom(byte[] array, int arrayIndex, int arrayCount, int offset);
Collapse Expand Parameters
Parameters | Description
byte[] array | The source byte array.
int arrayIndex | Index in the source array.
int arrayCount | Size of the source array.
int offset | Offset into the current buffer.


NBuffer.CopyTo Method (IntPtr, UIntPtr)

NBuffer.CopyTo Method (IntPtr, UIntPtr)
NBuffer Class Neurotec.IO Namespace

Copies bytes from the current buffer into the buffer specified by pointer with specified size.

C#
public void CopyTo(IntPtr pDstBuffer, UIntPtr dstBufferSize);
Collapse Expand Parameters
Parameters | Description
IntPtr pDstBuffer | Pointer to the destination buffer.
UIntPtr dstBufferSize | Size if the destination buffer.


NBuffer.CopyTo Method (IntPtr, int)

NBuffer.CopyTo Method (IntPtr, int)
NBuffer Class Neurotec.IO Namespace

Copies bytes from the current buffer into the buffer specified by pointer with specified size.

C#
public void CopyTo(IntPtr pDstBuffer, int dstBufferSize);
Collapse Expand Parameters
Parameters | Description
IntPtr pDstBuffer | Pointer to the destination buffer.
int dstBufferSize | Size if the destination buffer.


NBuffer.CopyTo Method (IntPtr, long)

NBuffer.CopyTo Method (IntPtr, long)
NBuffer Class Neurotec.IO Namespace

Copies bytes from the current buffer into the buffer specified by pointer with specified size.

C#
public void CopyTo(IntPtr pDstBuffer, long dstBufferSize);
Collapse Expand Parameters
Parameters | Description
IntPtr pDstBuffer | Pointer to the destination buffer.
long dstBufferSize | Size if the destination buffer.


NBuffer.CopyTo Method (NBuffer, UIntPtr)

NBuffer.CopyTo Method (NBuffer, UIntPtr)
NBuffer Class Neurotec.IO Namespace

Copies bytes from the current buffer into the specified buffer with specified offset.

C#
public void CopyTo(NBuffer dstBuffer, UIntPtr dstOffset);
Collapse Expand Parameters
Parameters | Description
NBuffer dstBuffer | The destination buffer.
UIntPtr dstOffset | The destination offset.


NBuffer.CopyTo Method (NBuffer, int)

NBuffer.CopyTo Method (NBuffer, int)
NBuffer Class Neurotec.IO Namespace

Copies bytes from the current buffer into the specified buffer with specified offset.

C#
public void CopyTo(NBuffer dstBuffer, int dstOffset);
Collapse Expand Parameters
Parameters | Description
NBuffer dstBuffer | The destination buffer.
int dstOffset | The destination offset.


NBuffer.CopyTo Method (NBuffer, long)

NBuffer.CopyTo Method (NBuffer, long)
NBuffer Class Neurotec.IO Namespace

Copies bytes from the current buffer into the specified buffer with specified offset.

C#
public void CopyTo(NBuffer dstBuffer, long dstOffset);
Collapse Expand Parameters
Parameters | Description
NBuffer dstBuffer | The destination buffer.
long dstOffset | The destination offset.


NBuffer.CopyTo Method (UIntPtr, IntPtr, UIntPtr, UIntPtr)

NBuffer.CopyTo Method (UIntPtr, IntPtr, UIntPtr, UIntPtr)
NBuffer Class Neurotec.IO Namespace

Copies bytes from the current buffer into a different buffer with specified size and offset.

C#
public void CopyTo(UIntPtr offset, IntPtr pDstBuffer, UIntPtr dstBufferSize, UIntPtr size);
Collapse Expand Parameters
Parameters | Description
UIntPtr offset | Offset into the current buffer.
IntPtr pDstBuffer | The destination buffer.
UIntPtr dstBufferSize | Size of the destination buffer.
UIntPtr size | Size of the current buffer.


NBuffer.CopyTo Method (byte[], int)

NBuffer.CopyTo Method (byte[], int)
NBuffer Class Neurotec.IO Namespace

Copies bytes from the current buffer into a byte array at specified index.

C#
public void CopyTo(byte[] array, int arrayIndex);
Collapse Expand Parameters
Parameters | Description
byte[] array | The destination byte array.
int arrayIndex | The specified index.


NBuffer.CopyTo Method (int, IntPtr, int, int)

NBuffer.CopyTo Method (int, IntPtr, int, int)
NBuffer Class Neurotec.IO Namespace

Copies bytes from the current buffer into a different buffer with specified size and offset.

C#
public void CopyTo(int offset, IntPtr pDstBuffer, int dstBufferSize, int size);
Collapse Expand Parameters
Parameters | Description
int offset | Offset into the current buffer.
IntPtr pDstBuffer | The destination buffer.
int dstBufferSize | Size of the destination buffer.
int size | Size of the current buffer.


NBuffer.CopyTo Method (int, byte[], int, int)

NBuffer.CopyTo Method (int, byte[], int, int)
NBuffer Class Neurotec.IO Namespace

Copies bytes from the current buffer into a byte array at specified index.

C#
public void CopyTo(int offset, byte[] array, int arrayIndex, int size);
Collapse Expand Parameters
Parameters | Description
int offset | Offset into the current buffer.
byte[] array | The destination byte array.
int arrayIndex | The index in the array.
int size | Sized of the current buffer.


NBuffer.CopyTo Method (long, IntPtr, long, long)

NBuffer.CopyTo Method (long, IntPtr, long, long)
NBuffer Class Neurotec.IO Namespace

Copies bytes from the current buffer into a different buffer with specified size and offset.

C#
public void CopyTo(long offset, IntPtr pDstBuffer, long dstBufferSize, long size);
Collapse Expand Parameters
Parameters | Description
long offset | Offset into the current buffer.
IntPtr pDstBuffer | The destination buffer.
long dstBufferSize | Size of the destination buffer.
long size | Size of the current buffer.


NBuffer.ToArray Method

NBuffer.ToArray Method
NBuffer Class Neurotec.IO Namespace

Copies the elements of the NBuffer to a new byte array.

C#
public byte[] ToArray();
Collapse Expand Returns

A byte array containing copies of the elements of the NBuffer.


NBuffer.WriteTo Method

NBuffer.WriteTo Method
NBuffer Class Neurotec.IO Namespace

Writes the contents of NBuffer to memory stream.

C#
public void WriteTo(Stream stream);
Collapse Expand Parameters
Parameters | Description
Stream stream | The stream to write the contents of NBuffer to.


NBuffer.Empty Property

NBuffer.Empty Property
NBuffer Class Neurotec.IO Namespace

Gets or sets an empty NBuffer.

C#
public static NBuffer Empty;
Property value

Empty NBuffer.


NBuffer.LongSize Property

NBuffer.LongSize Property
NBuffer Class Neurotec.IO Namespace

Gets a 64-bit integer that represents the length of NBuffer.

C#
public long LongSize;


NBuffer.NativeSize Property

NBuffer.NativeSize Property
NBuffer Class Neurotec.IO Namespace

Gets UIntPtr that represents the length of NBuffer.

C#
public UIntPtr NativeSize;


NBuffer.NativeType Property

NBuffer.NativeType Property
NBuffer Class Neurotec.IO Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NBuffer.Ptr Property

NBuffer.Ptr Property
NBuffer Class Neurotec.IO Namespace

Gets a representation of NBuffer pointer.

C#
public IntPtr Ptr;


NBuffer.Size Property

NBuffer.Size Property
NBuffer Class Neurotec.IO Namespace

Gets the length of NBuffer.

C#
public int Size;
Property value

The length of NBuffer.


NMemoryStream Class

NMemoryStream Class
NObject Delegates NObject Events NObject Fields Legend Members Methods NDisposable Methods NDisposable Properties

Provides access to unmanaged blocks of memory from managed code.

C#
public sealed class NMemoryStream : NStream;
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NStream Class
Show:
No members matching the current filter
Name | Description
AsStream | Converts the current NStream into a data stream.
CopyTo | Copies the current stream to another stream.
Flush | Clears all buffers for this stream and causes any buffered data to be written to the underlying device.
FromStream | Creates new NStream from Stream object.
Read | Reads a sequence of bytes from the current stream.
ReadByte | Reads a byte from the stream.
Seek | Sets the position within the current stream.
SetLength | Sets the length of the current stream.
Synchronized | Creates a synchronized NStream from a Stream object.
Write | Writes a content of a buffer to the current stream.
WriteByte | Writes a byte to the current position in the stream.
NMemoryStream Class
Name | Description
GetBuffer | Retrieves the buffer.
ToArray | Saves stream to byte array.
WriteTo | Writes NMemoryStream to Stream.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NStream Class
Show:
No members matching the current filter
Name | Description
CanRead | Gets a value indicating whether the current stream supports reading.
CanSeek | Gets a value indicating whether the current stream supports seeking.
CanWrite | Gets a value indicating whether the current stream supports writing.
Length | Gets size of a stream in bytes.
NativeType | Defines the native type of the object.
Null | Gets an empty NStream.
Position | Gets number of bytes from the start of the data to the current position in a stream.
NMemoryStream Class
Name | Description
Capacity | Gets the stream size of memory assigned to a stream (capacity).
LongCapacity | Gets the stream size of memory assigned to a stream (capacity), as a long number.
NativeCapacity | Gets the stream size of memory assigned to a stream (capacity), as an unsigned integer.
NativeType | Defines the native type of the object.
PositionPtr | Gets the pointer to a certain position.
Container

File: NMemoryStream.cs

Namespace: Neurotec.IO

Module: .NET Reference


NMemoryStream.NMemoryStream Constructor ()

NMemoryStream.NMemoryStream Constructor ()
NMemoryStream Class Neurotec.IO Namespace

Initializes a new, empty instance of the NMemoryStream class.

C#
public NMemoryStream();


NMemoryStream.NMemoryStream Constructor (NBuffer)

NMemoryStream.NMemoryStream Constructor (NBuffer)
NMemoryStream Class Neurotec.IO Namespace

Initializes a new instance of the NMemoryStream class using the specified buffer.

C#
public NMemoryStream(NBuffer buffer);
Collapse Expand Parameters
Parameters | Description
NBuffer buffer | NBuffer specified.


NMemoryStream.NMemoryStream Constructor (NBuffer, FileAccess, bool)

NMemoryStream.NMemoryStream Constructor (NBuffer, FileAccess, bool)
NMemoryStream Class Neurotec.IO Namespace

Initializes a new instance of the NMemoryStream class using the specified buffer, file access and exposability.

C#
public NMemoryStream(NBuffer buffer, FileAccess access, bool bufferExposable);
Collapse Expand Parameters
Parameters | Description
NBuffer buffer | NBuffer specified.
FileAccess access | File access.
bool bufferExposable | true if the buffer is exposable; else false.


NMemoryStream.NMemoryStream Constructor (NBuffer, bool)

NMemoryStream.NMemoryStream Constructor (NBuffer, bool)
NMemoryStream Class Neurotec.IO Namespace

Initializes a new instance of the NMemoryStream class using the specified buffer and writing permission.

C#
public NMemoryStream(NBuffer buffer, bool canWrite);
Collapse Expand Parameters
Parameters | Description
NBuffer buffer | NBuffer specified.
bool canWrite | true if writing is permitted; else false.


NMemoryStream.NMemoryStream Constructor (UIntPtr)

NMemoryStream.NMemoryStream Constructor (UIntPtr)
NMemoryStream Class Neurotec.IO Namespace

Initializes a new instance of the NMemoryStream class using the specified memory length.

C#
public NMemoryStream(UIntPtr capacity);
Collapse Expand Parameters
Parameters | Description
UIntPtr capacity | The length of the memory to use.


NMemoryStream.NMemoryStream Constructor (byte[])

NMemoryStream.NMemoryStream Constructor (byte[])
NMemoryStream Class Neurotec.IO Namespace

Initializes a new instance of the NMemoryStream class using the specified buffer.

C#
public NMemoryStream(byte[] buffer);
Collapse Expand Parameters
Parameters | Description
byte[] buffer | Byte buffer specified.


NMemoryStream.NMemoryStream Constructor (byte[], bool)

NMemoryStream.NMemoryStream Constructor (byte[], bool)
NMemoryStream Class Neurotec.IO Namespace

Initializes a new instance of the NMemoryStream class using the specified buffer and writing permission.

C#
public NMemoryStream(byte[] buffer, bool canWrite);
Collapse Expand Parameters
Parameters | Description
byte[] buffer | Byte buffer specified.
bool canWrite | true if writing is permitted; else false.


NMemoryStream.NMemoryStream Constructor (int)

NMemoryStream.NMemoryStream Constructor (int)
NMemoryStream Class Neurotec.IO Namespace

Initializes a new instance of the NMemoryStream class using the specified memory length.

C#
public NMemoryStream(int capacity);
Collapse Expand Parameters
Parameters | Description
int capacity | The length of the memory to use.


NMemoryStream.NMemoryStream Constructor (long)

NMemoryStream.NMemoryStream Constructor (long)
NMemoryStream Class Neurotec.IO Namespace

Initializes a new instance of the NMemoryStream class using the specified memory length.

C#
public NMemoryStream(long capacity);
Collapse Expand Parameters
Parameters | Description
long capacity | The length of the memory to use.


NMemoryStream.GetBuffer Method

NMemoryStream.GetBuffer Method
NMemoryStream Class Neurotec.IO Namespace

Retrieves the buffer.

C#
public NBuffer GetBuffer();
Collapse Expand Returns

NBuffer object.


NMemoryStream.ToArray Method

NMemoryStream.ToArray Method
NMemoryStream Class Neurotec.IO Namespace

Saves stream to byte array.

C#
public byte[] ToArray();
Collapse Expand Returns

Byte array.


NMemoryStream.WriteTo Method

NMemoryStream.WriteTo Method
NMemoryStream Class Neurotec.IO Namespace

Writes NMemoryStream to Stream.

C#
public void WriteTo(NStream stream);
Collapse Expand Parameters
Parameters | Description
NStream stream | Stream object.


NMemoryStream.Capacity Property

NMemoryStream.Capacity Property
NMemoryStream Class Neurotec.IO Namespace

Gets the stream size of memory assigned to a stream (capacity).

C#
public int Capacity;


NMemoryStream.LongCapacity Property

NMemoryStream.LongCapacity Property
NMemoryStream Class Neurotec.IO Namespace

Gets the stream size of memory assigned to a stream (capacity), as a long number.

C#
public long LongCapacity;


NMemoryStream.NativeCapacity Property

NMemoryStream.NativeCapacity Property
NMemoryStream Class Neurotec.IO Namespace

Gets the stream size of memory assigned to a stream (capacity), as an unsigned integer.

C#
public UIntPtr NativeCapacity;


NMemoryStream.NativeType Property

NMemoryStream.NativeType Property
NMemoryStream Class Neurotec.IO Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NMemoryStream.PositionPtr Property

NMemoryStream.PositionPtr Property
NMemoryStream Class Neurotec.IO Namespace

Gets the pointer to a certain position.

C#
public IntPtr PositionPtr;


NStream Class

NStream Class
NObject Delegates NObject Events NObject Fields Legend Members NDisposable Methods NDisposable Properties

This class supports internal Neurotechnology libraries infrastructure and should not be used directly in your code.

C#
public class NStream : NObject;
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NStream Class
Name | Description
AsStream | Converts the current NStream into a data stream.
CopyTo | Copies the current stream to another stream.
Flush | Clears all buffers for this stream and causes any buffered data to be written to the underlying device.
FromStream | Creates new NStream from Stream object.
Read | Reads a sequence of bytes from the current stream.
ReadByte | Reads a byte from the stream.
Seek | Sets the position within the current stream.
SetLength | Sets the length of the current stream.
Synchronized | Creates a synchronized NStream from a Stream object.
Write | Writes a content of a buffer to the current stream.
WriteByte | Writes a byte to the current position in the stream.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NStream Class
Name | Description
CanRead | Gets a value indicating whether the current stream supports reading.
CanSeek | Gets a value indicating whether the current stream supports seeking.
CanWrite | Gets a value indicating whether the current stream supports writing.
Length | Gets size of a stream in bytes.
NativeType | Defines the native type of the object.
Null | Gets an empty NStream.
Position | Gets number of bytes from the start of the data to the current position in a stream.
Container

File: NStream.cs

Namespace: Neurotec.IO

Module: .NET Reference


NStream.AsStream Method

NStream.AsStream Method
NStream Class Neurotec.IO Namespace

Converts the current NStream into a data stream.

C#
public Stream AsStream();
Collapse Expand Returns

The data stream.


NStream.CopyTo Method (NStream)

NStream.CopyTo Method (NStream)
NStream Class Neurotec.IO Namespace

Copies the current stream to another stream.

C#
public void CopyTo(NStream dstStream);
Collapse Expand Parameters
Parameters | Description
NStream dstStream | Destination stream.


NStream.CopyTo Method (NStream, int)

NStream.CopyTo Method (NStream, int)
NStream Class Neurotec.IO Namespace

Copies the current stream to another stream with specified buffer size.

C#
public void CopyTo(NStream dstStream, int bufferSize);
Collapse Expand Parameters
Parameters | Description
NStream dstStream | Destination stream.
int bufferSize | Buffer size.


NStream.Flush Method

NStream.Flush Method
NStream Class Neurotec.IO Namespace

Clears all buffers for this stream and causes any buffered data to be written to the underlying device.

C#
public void Flush();


NStream.FromStream Method

NStream.FromStream Method
NStream Class Neurotec.IO Namespace

Creates new NStream from Stream object.

C#
public static NStream FromStream(Stream stream);
Collapse Expand Parameters
Parameters | Description
Stream stream | Memory stream.
Collapse Expand Returns

NStream object.


NStream.Read Method (NBuffer)

NStream.Read Method (NBuffer)
NStream Class Neurotec.IO Namespace

Reads a sequence of bytes from the current stream.

C#
public int Read(NBuffer buffer);
Collapse Expand Parameters
Parameters | Description
NBuffer buffer | Memory buffer.
Collapse Expand Returns

Number of bytes successfully read.


NStream.Read Method (byte[], int, int)

NStream.Read Method (byte[], int, int)
NStream Class Neurotec.IO Namespace

Reads a sequence of bytes from the current stream.

C#
public int Read(byte[] buffer, int offset, int count);
Collapse Expand Parameters
Parameters | Description
byte[] buffer | Destination array. The locations with index range from offset to (offset+count-1) will be replaced by the bytes read from the current source.
int offset | The zero-based byte offset in buffer at which to begin storing the data read from the current stream.
int count | Number of bytes to be read from the current stream.
Collapse Expand Returns

Number of bytes successfully read.


NStream.ReadByte Method

NStream.ReadByte Method
NStream Class Neurotec.IO Namespace

Reads a byte from the stream.

C#
public int ReadByte();
Collapse Expand Returns

Value of byte at current position in a stream.


NStream.Seek Method

NStream.Seek Method
NStream Class Neurotec.IO Namespace

Sets the position within the current stream.

C#
public void Seek(long offset, SeekOrigin origin);
Collapse Expand Parameters
Parameters | Description
long offset | A byte offset relative to the origin parameter.
SeekOrigin origin | A value indicating the reference point used to obtain the new position.
Collapse Expand Returns

The new position within the current stream.


NStream.SetLength Method

NStream.SetLength Method
NStream Class Neurotec.IO Namespace

Sets the length of the current stream.

C#
public void SetLength(long value);
Collapse Expand Parameters
Parameters | Description
long value | New desired length of the current stream in bytes.


NStream.Synchronized Method

NStream.Synchronized Method
NStream Class Neurotec.IO Namespace

Creates a synchronized NStream from a Stream object.

C#
public static NStream Synchronized(NStream stream);
Collapse Expand Parameters
Parameters | Description
NStream stream | Memory stream.
Collapse Expand Returns

NStream object.


NStream.Write Method (NBuffer)

NStream.Write Method (NBuffer)
NStream Class Neurotec.IO Namespace

Writes a content of a buffer to the current stream.

C#
public void Write(NBuffer buffer);
Collapse Expand Parameters
Parameters | Description
NBuffer buffer | Memory buffer.


NStream.Write Method (byte[], int, int)

NStream.Write Method (byte[], int, int)
NStream Class Neurotec.IO Namespace

Writes a sequence of bytes to the current stream.

C#
public void Write(byte[] buffer, int offset, int count);
Collapse Expand Parameters
Parameters | Description
byte[] buffer | An array of bytes.
int offset | The zero-based byte offset in buffer at which to begin copying bytes to the current stream.
int count | Number of bytes to be written to the current stream.


NStream.WriteByte Method

NStream.WriteByte Method
NStream Class Neurotec.IO Namespace

Writes a byte to the current position in the stream.

C#
public void WriteByte(byte value);
Collapse Expand Parameters
Parameters | Description
byte value | The byte to write to the stream.


NStream.CanRead Property

NStream.CanRead Property
NStream Class Neurotec.IO Namespace

Gets a value indicating whether the current stream supports reading.

C#
public bool CanRead;


NStream.CanSeek Property

NStream.CanSeek Property
NStream Class Neurotec.IO Namespace

Gets a value indicating whether the current stream supports seeking.

C#
public bool CanSeek;


NStream.CanWrite Property

NStream.CanWrite Property
NStream Class Neurotec.IO Namespace

Gets a value indicating whether the current stream supports writing.

C#
public bool CanWrite;


NStream.Length Property

NStream.Length Property
NStream Class Neurotec.IO Namespace

Gets size of a stream in bytes.

C#
public long Length;


NStream.NativeType Property

NStream.NativeType Property
NStream Class Neurotec.IO Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NStream.Null Property

NStream.Null Property
NStream Class Neurotec.IO Namespace

Gets an empty NStream.

C#
public static NStream Null;


NStream.Position Property

NStream.Position Property
NStream Class Neurotec.IO Namespace

Gets number of bytes from the start of the data to the current position in a stream.

C#
public long Position;


Neurotec.Images Namespace

Neurotec.Images Namespace
Classes Legend Structs, Records, Enums

Classes under this namespace provide functionality that enable loading, saving and converting images in various formats.

Collapse Expand Classes
Name | Description
BmpInfo | Provides information about BMP format images.
IHeadInfo | Provides information about NIST IHead format images.
Jpeg2KInfo | Provides information about Jpeg 2000 images.
JpegInfo | Provides information about JPEG images.
NImage | Provides functionality for managing images.
NImageFormat | Provides functionality for loading and saving images in format-neutral style.
NImageInfo | Retrieves the object information.
NImageReader | Provides methods which can be used to read image data.
NImageWriter | Provides methods which can be used to write image data.
NImages | Provides library registration and other additional functionality.
NPixelFormat | Provides functionality for working with pixel format.
NRgb | Represents an RGB color.
PngInfo | Provides information about PNG format images.
TiffInfo | Provides information about TIFF format images.
Collapse Expand Structs, Records, Enums
Name | Description
Jpeg2KProfile | Enumerates JPEG2000 image types.
NImageRotateFlipType | Enumerates NImage rotation and flip values.
NPixelType | Enumerates the pixel types.


BmpInfo Class

BmpInfo Class
NObject Delegates NObject Events NObject Fields Legend Members Methods NDisposable Methods NDisposable Properties

Provides information about BMP format images.

C#
public sealed class BmpInfo : NImageInfo;
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NExpandableObject Class
Show:
No members matching the current filter
Name | Description
NativeType | Defines the native type of the object.
Properties | Gets the property bag of the expandable object.
NImageInfo Class
Show:
No members matching the current filter
Name | Description
Format | Gets or sets the image format.
Height | Gets image height.
NImageRotateFlipTypeNativeType | Defines the native type of the image rotation.
NativeType | Defines the native type of the object.
Transform | Gets or sets the transformation of the image.
Width | Gets image height.
BmpInfo Class
Name | Description
NativeType | Gets or sets a function that retrieves NType object for the enclosing type.
Container

File: Bmp.cs

Namespace: Neurotec.Images

Module: .NET Reference


BmpInfo.NativeType Property

BmpInfo.NativeType Property
BmpInfo Class Neurotec.Images Namespace

Gets or sets a function that retrieves NType object for the enclosing type.

C#
public static new NType NativeType;
Property value

The function that retrieves NType object for the enclosing type.


IHeadInfo Class

IHeadInfo Class
NObject Delegates NObject Events NObject Fields Legend Members Methods NDisposable Methods NDisposable Properties

Provides information about NIST IHead format images.

C#
public sealed class IHeadInfo : NImageInfo;
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NExpandableObject Class
Show:
No members matching the current filter
Name | Description
NativeType | Defines the native type of the object.
Properties | Gets the property bag of the expandable object.
NImageInfo Class
Show:
No members matching the current filter
Name | Description
Format | Gets or sets the image format.
Height | Gets image height.
NImageRotateFlipTypeNativeType | Defines the native type of the image rotation.
NativeType | Defines the native type of the object.
Transform | Gets or sets the transformation of the image.
Width | Gets image height.
IHeadInfo Class
Name | Description
NativeType | Gets or sets
Container

File: IHead.cs

Namespace: Neurotec.Images

Module: .NET Reference


IHeadInfo.NativeType Property

IHeadInfo.NativeType Property
IHeadInfo Class Neurotec.Images Namespace

Gets or sets

C#
public static new NType NativeType;
Property value

The function that retrieves NType object for the enclosing type.


Jpeg2KInfo Class

Jpeg2KInfo Class
NObject Delegates NObject Events NObject Fields Legend Members Methods NDisposable Methods NDisposable Properties

Provides information about Jpeg 2000 images.

C#
public sealed class Jpeg2KInfo : NImageInfo;
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Jpeg2KInfo Class
Name | Description
DefaultRatio | Specifies default JPEG 2000 quality.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NExpandableObject Class
Show:
No members matching the current filter
Name | Description
NativeType | Defines the native type of the object.
Properties | Gets the property bag of the expandable object.
NImageInfo Class
Show:
No members matching the current filter
Name | Description
Format | Gets or sets the image format.
Height | Gets image height.
NImageRotateFlipTypeNativeType | Defines the native type of the image rotation.
NativeType | Defines the native type of the object.
Transform | Gets or sets the transformation of the image.
Width | Gets image height.
Jpeg2KInfo Class
Name | Description
Jpeg2KProfileNativeType | Defines the native type of the JPEG2000 profile.
NativeType | Gets or sets Gets or sets
Profile | Gets or sets Jpeg 2000 profile value.
Ratio | Gets or sets Jpeg 2000 compression ration.
Container

File: Jpeg2K.cs

Namespace: Neurotec.Images

Module: .NET Reference


Jpeg2KInfo.DefaultRatio Field

Jpeg2KInfo.DefaultRatio Field
Jpeg2KInfo Class Neurotec.Images Namespace

Specifies default JPEG 2000 quality.

C#
public const float DefaultRatio = 10.0f;
Collapse Expand Remarks

This parameter controls compression ratio when saving images to a file. E.g., when 10 is specified compressed image will have 10:1 size ratio compared to that of the uncompressed file. If lossless image is required, then 0 for DefaultRatio parameter should be specified.

Compression ratio can be set using Ratio property.

When one of Jpeg2KProfile values are used (except jNone), then DefaultRatio parameter value is ignored.


Jpeg2KInfo.Jpeg2KProfileNativeType Property

Jpeg2KInfo.Jpeg2KProfileNativeType Property
Jpeg2KInfo Class Neurotec.Images Namespace

Defines the native type of the JPEG2000 profile.

C#
public static NType Jpeg2KProfileNativeType;


Jpeg2KInfo.NativeType Property

Jpeg2KInfo.NativeType Property
Jpeg2KInfo Class Neurotec.Images Namespace

Gets or sets

Gets or sets

C#
public static new NType NativeType;
Property value

The function that retrieves NType object for the enclosing type.

The function that retrieves NType object for the enclosing type.


Jpeg2KInfo.Profile Property

Jpeg2KInfo.Profile Property
Jpeg2KInfo Class Neurotec.Images Namespace

Gets or sets Jpeg 2000 profile value.

C#
public Jpeg2KProfile Profile;
Property value

Jpeg2KProfile enumeration.


Jpeg2KInfo.Ratio Property

Jpeg2KInfo.Ratio Property
Jpeg2KInfo Class Neurotec.Images Namespace See Also

Gets or sets Jpeg 2000 compression ration.

C#
public float Ratio;
Property value

Jpeg 2000 image compression ratio.

Collapse Expand See Also

DefaultRatio


JpegInfo Class

JpegInfo Class
NObject Delegates NObject Events NObject Fields Legend Members Methods NDisposable Methods NDisposable Properties

Provides information about JPEG images.

C#
public sealed class JpegInfo : NImageInfo;
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
JpegInfo Class
Name | Description
DefaultQuality | Specifies default JPEG quality.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NExpandableObject Class
Show:
No members matching the current filter
Name | Description
NativeType | Defines the native type of the object.
Properties | Gets the property bag of the expandable object.
NImageInfo Class
Show:
No members matching the current filter
Name | Description
Format | Gets or sets the image format.
Height | Gets image height.
NImageRotateFlipTypeNativeType | Defines the native type of the image rotation.
NativeType | Defines the native type of the object.
Transform | Gets or sets the transformation of the image.
Width | Gets image height.
JpegInfo Class
Name | Description
IsLossless | Check or sets whether a JPEG image is lossless.
NativeType | Gets or sets
Quality | Gets or sets JPEG image quality
Container

File: Jpeg.cs

Namespace: Neurotec.Images

Module: .NET Reference


JpegInfo.DefaultQuality Field

JpegInfo.DefaultQuality Field
JpegInfo Class Neurotec.Images Namespace

Specifies default JPEG quality.

C#
public const int DefaultQuality = 75;


JpegInfo.IsLossless Property

JpegInfo.IsLossless Property
JpegInfo Class Neurotec.Images Namespace

Check or sets whether a JPEG image is lossless.

C#
public bool IsLossless;
Property value

true if the image is lossless; else false


JpegInfo.NativeType Property

JpegInfo.NativeType Property
JpegInfo Class Neurotec.Images Namespace

Gets or sets

C#
public static new NType NativeType;
Property value

The function that retrieves NType object for the enclosing type.


JpegInfo.Quality Property

JpegInfo.Quality Property
JpegInfo Class Neurotec.Images Namespace

Gets or sets JPEG image quality

C#
public int Quality;
Property value

JPEG image quality


NImage Class

NImage Class
NImage Classes NObject Delegates NObject Events NObject Fields Legend Members NDisposable Methods NDisposable Properties

Provides functionality for managing images.

C#
public class NImage : NObject, ICloneable;
Collapse Expand NImage Classes
NImage Class
Name | Description
ImagePalette | Represents an image palette.
PlaneCollection | Represents a collection of image data planes.
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NImage Class
Name | Description
FlagAllDst | For internal use.
FlagAllDstAndSrc | For internal use.
FlagAllSrc | For internal use.
FlagDstAlphaChannelFirst | This flag is used when NImage should be copied using Rgb Alpha channel first method (ARGB color space).
FlagDstBottomToTop | This flag is used when NImage should be copied changing pixels order bottom to top (bottom lines become top and vice versa).
FlagDstSwapChannels | This flag is used when NImage should be copied swapping RGB channels (Ex. RGB to BRG).
FlagReadUnknownImage | Flag specifying whether unknown images should be read.
FlagSrcAlphaChannelFirst | This flag is used when NImage should be copied using Rgb Alpha channel first method (ARGB color space).
FlagSrcBottomToTop | This flag is used when NImage should be copied changing pixels order bottom to top (bottom lines become top and vice versa).
FlagSrcSwapChannels | This flag is used when NImage should be copied swapping RGB channels (Ex. RGB to BRG).
FlagWriteUnknownImage | Flag specifying whether unknown images should be written.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NImage Class
Name | Description
Copy | Copies specified rectangular area of the NImage to other NImage object.
CopyFrom | Copies planes from memory buffer.
CopyFromYCbCrData | Copies NImage data using YCbCr color space.
CopyTo | Copies specified rectangular area of the NImage to other NImage object.
Create | Creates NImage with specified pixel format, size and stride.
Crop | Crops an image.
ExportPalette | Exports the palette from the current image.
FlipDiagonally | Flips image diagonally.
FlipHorizontally | Flips image horizontally.
FlipVertically | Flips image vertically.
FromData | Creates NImage object from data with specified parameters.
FromFile | Creates NImage object from file.
FromImage | Creates NImage object from another NImage object.
FromMemory | Creates NImage object from another memory buffer.
FromStream | Reads NImage from the specified stream
FromVideoSample | Creates NImage object from specified video sample.
GetIndex | Retrieves the palette entry index of the specified pixel.
GetPixel | Retrieves the specified pixel.
GetPixels | Gets buffer which contains image pixels.
GetSupportedVideoSubtypes | Gets supported videos subtypes.
GetWrapper | Creates NImage object wrapper.
IsVideoFormatSupported | Checks if specified video format is supported.
IsVideoSubtypeSupported | Checks if specified video subtype is supported.
RotateFlip | Rotates image using rotation type.
Save | Saves image to memory buffer using specified format.
SetIndex | Sets the palette entry index for the specified pixel.
SetPixel | Sets specified pixel's value to the specified value.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NImage Class
Name | Description
Height | Gets height of image from NImage object.
HorzResolution | Gets horizontal resolution in pixels per inch of image.
ImageSize | Gets size of NImage object.
Info | Retrieves a NImageInfo object for the current image.
LongImageSize | Gets size of NImage object.
LongPlaneSize | Gets the plane size.
LongStride | Gets stride of image from NImage object.
MaxValue | Gets or sets the maximum value of a pixel.
MinValue | Gets or sets the minimum value of a pixel.
NativeImageSize | Gets size of NImage object.
NativePlaneSize | Gets the native plane size.
NativeStride | Gets stride of image from NImage object.
NativeType | Defines the native type of the object.
Palette | Retrieves the palette of the current image.
PixelFormat | Gets NPixelFormat of NImage object.
PlaneSize | Gets the plane size.
Planes | Gets the collection of planes.
ResolutionIsAspectRatio | Gets or sets NImage resolution aspect ratio.
Stride | Gets stride of image from NImage object.
VertResolution | Gets vertical resolution in pixels per inch of image.
Width | Gets width of image from NImage object.
Container

File: NImage.cs

Namespace: Neurotec.Images

Module: .NET Reference


NImage.ImagePalette Class

NImage.ImagePalette Class
Legend Members ImagePalette Methods ImagePalette Properties

Represents an image palette.

C#
public sealed class ImagePalette : ArrayCollection;
Collapse Expand ImagePalette Methods
Name | Description
GetEntries | Gets the palette entries.
SetEntries | Sets palette entries.
Collapse Expand ImagePalette Properties
Name | Description
EntriesSize | Gets the palette size.
NativeEntriesSize | Gets the native palette size.
Container

File: NImage.cs

Namespace: Neurotec.Images

Module: .NET Reference


NImage.ImagePalette.GetEntries Method

NImage.ImagePalette.GetEntries Method
NImage.ImagePalette Class Neurotec.Images Namespace

Gets the palette entries.

C#
public NBuffer GetEntries();
Collapse Expand Returns

NBuffer containing palette entries.


NImage.ImagePalette.SetEntries Method

NImage.ImagePalette.SetEntries Method
NImage.ImagePalette Class Neurotec.Images Namespace

Sets palette entries.

C#
public void SetEntries(NBuffer value, int length);
Collapse Expand Parameters
Parameters | Description
NBuffer value | NBuffer containing palette entries.
int length | Entries' length.


NImage.ImagePalette.EntriesSize Property

NImage.ImagePalette.EntriesSize Property
NImage.ImagePalette Class Neurotec.Images Namespace

Gets the palette size.

C#
public int EntriesSize;


NImage.ImagePalette.NativeEntriesSize Property

NImage.ImagePalette.NativeEntriesSize Property
NImage.ImagePalette Class Neurotec.Images Namespace

Gets the native palette size.

C#
public UIntPtr NativeEntriesSize;


NImage.PlaneCollection Class

NImage.PlaneCollection Class

Represents a collection of image data planes.

C#
public sealed class PlaneCollection : NObjectReadOnlyCollection<NBuffer>;
Container

File: NImage.cs

Namespace: Neurotec.Images

Module: .NET Reference


NImage.FlagAllDst Field

NImage.FlagAllDst Field
NImage Class Neurotec.Images Namespace

For internal use.

C#
public const uint FlagAllDst = 0x00000F00;


NImage.FlagAllDstAndSrc Field

NImage.FlagAllDstAndSrc Field
NImage Class Neurotec.Images Namespace

For internal use.

C#
public const uint FlagAllDstAndSrc = FlagAllDst | FlagAllSrc;


NImage.FlagAllSrc Field

NImage.FlagAllSrc Field
NImage Class Neurotec.Images Namespace

For internal use.

C#
public const uint FlagAllSrc = 0x0000F000;


NImage.FlagDstAlphaChannelFirst Field

NImage.FlagDstAlphaChannelFirst Field
NImage Class Neurotec.Images Namespace

This flag is used when NImage should be copied using Rgb Alpha channel first method (ARGB color space).

C#
public const uint FlagDstAlphaChannelFirst = 0x00000200;


NImage.FlagDstBottomToTop Field

NImage.FlagDstBottomToTop Field
NImage Class Neurotec.Images Namespace

This flag is used when NImage should be copied changing pixels order bottom to top (bottom lines become top and vice versa).

C#
public const uint FlagDstBottomToTop = 0x00000400;


NImage.FlagDstSwapChannels Field

NImage.FlagDstSwapChannels Field
NImage Class Neurotec.Images Namespace

This flag is used when NImage should be copied swapping RGB channels (Ex. RGB to BRG).

C#
public const uint FlagDstSwapChannels = 0x00000100;


NImage.FlagReadUnknownImage Field

NImage.FlagReadUnknownImage Field
NImage Class Neurotec.Images Namespace

Flag specifying whether unknown images should be read.

C#
public const uint FlagReadUnknownImage = 0x00000001;


NImage.FlagSrcAlphaChannelFirst Field

NImage.FlagSrcAlphaChannelFirst Field
NImage Class Neurotec.Images Namespace

This flag is used when NImage should be copied using Rgb Alpha channel first method (ARGB color space).

C#
public const uint FlagSrcAlphaChannelFirst = 0x00002000;


NImage.FlagSrcBottomToTop Field

NImage.FlagSrcBottomToTop Field
NImage Class Neurotec.Images Namespace

This flag is used when NImage should be copied changing pixels order bottom to top (bottom lines become top and vice versa).

C#
public const uint FlagSrcBottomToTop = 0x00004000;


NImage.FlagSrcSwapChannels Field

NImage.FlagSrcSwapChannels Field
NImage Class Neurotec.Images Namespace

This flag is used when NImage should be copied swapping RGB channels (Ex. RGB to BRG).

C#
public const uint FlagSrcSwapChannels = 0x00001000;


NImage.FlagWriteUnknownImage Field

NImage.FlagWriteUnknownImage Field
NImage Class Neurotec.Images Namespace

Flag specifying whether unknown images should be written.

C#
public const uint FlagWriteUnknownImage = 0x00000001;


NImage.Copy Method (NImage, uint, uint, uint, uint, NImage, uint, uint)

NImage.Copy Method (NImage, uint, uint, uint, uint, NImage, uint, uint)
NImage Class Neurotec.Images Namespace

Copies specified rectangular area of the NImage to other NImage object.

C#
public static void Copy(NImage srcImage, uint left, uint top, uint width, uint height, NImage dstImage, uint dstLeft, uint dstTop);
Collapse Expand Parameters
Parameters | Description
NImage srcImage | NImage object to copy.
uint left | The x coordinate of source rectangle.
uint top | The y coordinate of source rectangle.
uint width | The width of source rectangle.
uint height | The height of source rectangle.
NImage dstImage | A destination NImage object. Specified rectangular area will be copied to this object.
uint dstLeft | The x coordinate in the destination NImage object. Copied NImage will be placed starting by this coordinate.
uint dstTop | The y coordinate in the destination NImage object. Copied NImage will be placed starting by this coordinate.
Collapse Expand Exceptions
Exceptions | Description
ArgumentNullException | srcImage or dstImage has null value.


NImage.Copy Method (NPixelFormat, Array, Array, NBuffer, int, uint, uint, long, NBuffer[], uint, uint, NPixelFormat, Array, Array, NBuffer, int, uint, uint, long, NBuffer[], uint, uint, uint, uint, uint)

NImage.Copy Method (NPixelFormat, Array, Array, NBuffer, int, uint, uint, long, NBuffer[], uint, uint, NPixelFormat, Array, Array, NBuffer, int, uint, uint, long, NBuffer[], uint, uint, uint, uint, uint)
NImage Class Neurotec.Images Namespace

Copies planes from one memory buffer to another.

C#
public static void Copy(NPixelFormat srcPixelFormat, Array srcMinValue, Array srcMaxValue, NBuffer srcPalette, int srcPaletteLength, uint srcWidth, uint srcHeight, long srcStride, NBuffer[] srcPlanes, uint srcLeft, uint srcTop, NPixelFormat dstPixelFormat, Array dstMinValue, Array dstMaxValue, NBuffer dstPalette, int dstPaletteLength, uint dstWidth, uint dstHeight, long dstStride, NBuffer[] dstPlanes, uint dstLeft, uint dstTop, uint width, uint height, uint flags);
Collapse Expand Parameters
Parameters | Description
NPixelFormat srcPixelFormat | The source pixel format.
Array srcMinValue | Minimum source pixel values.
Array srcMaxValue | Maximum source pixel values.
NBuffer srcPalette | Source image palette.
int srcPaletteLength | Source image palette length.
uint srcWidth | The width of the source image data.
uint srcHeight | The height of the source image data.
long srcStride | The stride of the source image data.
NBuffer[] srcPlanes | The source memory block.
uint srcLeft | The left coordinate of the source image data.
uint srcTop | The top coordinate of the source image data.
NPixelFormat dstPixelFormat | The destination pixel format.
Array dstMinValue | Minimum destination pixel values.
Array dstMaxValue | Maximum destination pixel values.
NBuffer dstPalette | Destination image palette.
int dstPaletteLength | Destination image palette length.
uint dstWidth | The width of the destination image data.
uint dstHeight | The height of the destination image data.
long dstStride | The stride of the destination image data.
NBuffer[] dstPlanes | The destination memory block.
uint dstLeft | The left coordinate of the destination image data.
uint dstTop | The top coordinate of the destination image data.
uint width | Image width.
uint height | Image height.
uint flags | Flags controlling function. These flags can be used: NI_DST_ALPHA_CHANNEL_FIRST, NI_DST_BOTTOM_TO_TOP, NI_DST_SWAP_CHANNELS.


NImage.Copy Method (NPixelFormat, uint, uint, int, NBuffer, uint, uint, NPixelFormat, uint, uint, int, NBuffer, uint, uint, uint, uint)

NImage.Copy Method (NPixelFormat, uint, uint, int, NBuffer, uint, uint, NPixelFormat, uint, uint, int, NBuffer, uint, uint, uint, uint)
NImage Class Neurotec.Images Namespace

Copies pixels from one memory buffer to another.

C#
public static void Copy(NPixelFormat srcPixelFormat, uint srcWidth, uint srcHeight, int srcStride, NBuffer srcPixels, uint srcLeft, uint srcTop, NPixelFormat dstPixelFormat, uint dstWidth, uint dstHeight, int dstStride, NBuffer dstPixels, uint dstLeft, uint dstTop, uint width, uint height);
Collapse Expand Parameters
Parameters | Description
NPixelFormat srcPixelFormat | The source pixel format.
uint srcWidth | The width of the source image data.
uint srcHeight | The height of the source image data.
int srcStride | The stride of the source image data.
NBuffer srcPixels | Source memory block.
uint srcLeft | The left coordinate of the source image data.
uint srcTop | The top coordinate of the source image data.
NPixelFormat dstPixelFormat | The destination pixel format.
uint dstWidth | The width of the destination image data.
uint dstHeight | The height of the destination image data.
int dstStride | The stride of the destination image data.
NBuffer dstPixels | Destination memory block.
uint dstLeft | The left coordinate of the destination image data.
uint dstTop | The top coordinate of the destination image data.
uint width | Image width.
uint height | Image height.


NImage.Copy Method (NPixelFormat, uint, uint, long, NBuffer, uint, uint, NPixelFormat, uint, uint, long, NBuffer, uint, uint, uint, uint, uint)

NImage.Copy Method (NPixelFormat, uint, uint, long, NBuffer, uint, uint, NPixelFormat, uint, uint, long, NBuffer, uint, uint, uint, uint, uint)
NImage Class Neurotec.Images Namespace

Copies pixels from one memory buffer to another.

C#
public static void Copy(NPixelFormat srcPixelFormat, uint srcWidth, uint srcHeight, long srcStride, NBuffer srcPixels, uint srcLeft, uint srcTop, NPixelFormat dstPixelFormat, uint dstWidth, uint dstHeight, long dstStride, NBuffer dstPixels, uint dstLeft, uint dstTop, uint width, uint height, uint flags);
Collapse Expand Parameters
Parameters | Description
NPixelFormat srcPixelFormat | The source pixel format.
uint srcWidth | The width of the source image data.
uint srcHeight | The height of the source image data.
long srcStride | The stride of the source image data.
NBuffer srcPixels | Source memory block.
uint srcLeft | The left coordinate of the source image data.
uint srcTop | The top coordinate of the source image data.
NPixelFormat dstPixelFormat | The destination pixel format.
uint dstWidth | The width of the destination image data.
uint dstHeight | The height of the destination image data.
long dstStride | The stride of the destination image data.
NBuffer dstPixels | Destination memory block.
uint dstLeft | The left coordinate of the destination image data.
uint dstTop | The top coordinate of the destination image data.
uint width | Image width.
uint height | Image height.
uint flags | Flags controlling function. These flags can be used: NI_DST_ALPHA_CHANNEL_FIRST, NI_DST_BOTTOM_TO_TOP, NI_DST_SWAP_CHANNELS.


NImage.Copy Method (NPixelFormat, uint, uint, long, NBuffer[], uint, uint, NPixelFormat, uint, uint, long, NBuffer[], uint, uint, uint, uint, uint)

NImage.Copy Method (NPixelFormat, uint, uint, long, NBuffer[], uint, uint, NPixelFormat, uint, uint, long, NBuffer[], uint, uint, uint, uint, uint)
NImage Class Neurotec.Images Namespace

Copies planes from one memory buffer to another.

C#
public static void Copy(NPixelFormat srcPixelFormat, uint srcWidth, uint srcHeight, long srcStride, NBuffer[] srcPlanes, uint srcLeft, uint srcTop, NPixelFormat dstPixelFormat, uint dstWidth, uint dstHeight, long dstStride, NBuffer[] dstPlanes, uint dstLeft, uint dstTop, uint width, uint height, uint flags);
Collapse Expand Parameters
Parameters | Description
NPixelFormat srcPixelFormat | The source pixel format.
uint srcWidth | The width of the source image data.
uint srcHeight | The height of the source image data.
long srcStride | The stride of the source image data.
NBuffer[] srcPlanes | Source memory block.
uint srcLeft | The left coordinate of the source image data.
uint srcTop | The top coordinate of the source image data.
NPixelFormat dstPixelFormat | The destination pixel format.
uint dstWidth | The width of the destination image data.
uint dstHeight | The height of the destination image data.
long dstStride | The stride of the destination image data.
NBuffer[] dstPlanes | Destination memory block.
uint dstLeft | The left coordinate of the destination image data.
uint dstTop | The top coordinate of the destination image data.
uint width | Image width.
uint height | Image height.
uint flags | Flags controlling function. These flags can be used: NI_DST_ALPHA_CHANNEL_FIRST, NI_DST_BOTTOM_TO_TOP, NI_DST_SWAP_CHANNELS.


NImage.CopyFrom Method (NPixelFormat, Array, Array, NBuffer, int, uint, uint, long, NBuffer[], uint, uint, uint, uint, uint, uint, uint)

NImage.CopyFrom Method (NPixelFormat, Array, Array, NBuffer, int, uint, uint, long, NBuffer[], uint, uint, uint, uint, uint, uint, uint)
NImage Class Neurotec.Images Namespace

Copies planes from memory buffer.

C#
public void CopyFrom(NPixelFormat srcPixelFormat, Array srcMinValue, Array srcMaxValue, NBuffer srcPalette, int srcPaletteLength, uint srcWidth, uint srcHeight, long srcStride, NBuffer[] srcPlanes, uint srcLeft, uint srcTop, uint left, uint top, uint width, uint height, uint flags);
Collapse Expand Parameters
Parameters | Description
NPixelFormat srcPixelFormat | The source pixel format.
Array srcMinValue | Minimum source pixel values.
Array srcMaxValue | Maximum source pixel values.
NBuffer srcPalette | Source image palette.
int srcPaletteLength | Source image palette length.
uint srcWidth | The width of the source image data.
uint srcHeight | The height of the source image data.
long srcStride | The stride of the source image data.
NBuffer[] srcPlanes | The source memory block.
uint srcLeft | The left coordinate of the source image data.
uint srcTop | The top coordinate of the source image data.
uint left | The left coordinate of the image.
uint top | The top coordinate of the image.
uint width | The width of the image.
uint height | The height of the image.
uint flags | Flags controlling function. These flags can be used: NI_DST_ALPHA_CHANNEL_FIRST, NI_DST_BOTTOM_TO_TOP, NI_DST_SWAP_CHANNELS.


NImage.CopyFrom Method (NPixelFormat, uint, uint, int, NBuffer, uint, uint)

NImage.CopyFrom Method (NPixelFormat, uint, uint, int, NBuffer, uint, uint)
NImage Class Neurotec.Images Namespace

Copies pixels to from memory buffer.

C#
public void CopyFrom(NPixelFormat srcPixelFormat, uint srcWidth, uint srcHeight, int srcStride, NBuffer srcPixels, uint left, uint top);
Collapse Expand Parameters
Parameters | Description
NPixelFormat srcPixelFormat | The source pixel format.
uint srcWidth | The width of the source image data.
uint srcHeight | The height of the source image data.
int srcStride | The stride of the source image data.
NBuffer srcPixels | The source memory block.
uint left | The left coordinate of the image data.
uint top | The top coordinate of the image data.


NImage.CopyFrom Method (NPixelFormat, uint, uint, long, NBuffer, uint, uint, uint)

NImage.CopyFrom Method (NPixelFormat, uint, uint, long, NBuffer, uint, uint, uint)
NImage Class Neurotec.Images Namespace

Copies pixels to from memory buffer.

C#
public void CopyFrom(NPixelFormat srcPixelFormat, uint srcWidth, uint srcHeight, long srcStride, NBuffer srcPixels, uint left, uint top, uint flags);
Collapse Expand Parameters
Parameters | Description
NPixelFormat srcPixelFormat | The source pixel format.
uint srcWidth | The width of the source image data.
uint srcHeight | The height of the source image data.
long srcStride | The stride of the source image data.
NBuffer srcPixels | The source memory block.
uint left | The left coordinate of the image data.
uint top | The top coordinate of the image data.
uint flags | Flags controlling function. These flags can be used: NI_DST_ALPHA_CHANNEL_FIRST, NI_DST_BOTTOM_TO_TOP, NI_DST_SWAP_CHANNELS.


NImage.CopyFrom Method (NPixelFormat, uint, uint, long, NBuffer, uint, uint, uint, uint, uint, uint, uint)

NImage.CopyFrom Method (NPixelFormat, uint, uint, long, NBuffer, uint, uint, uint, uint, uint, uint, uint)
NImage Class Neurotec.Images Namespace

Copies pixels to from memory buffer.

C#
public void CopyFrom(NPixelFormat srcPixelFormat, uint srcWidth, uint srcHeight, long srcStride, NBuffer srcPixels, uint srcLeft, uint srcTop, uint left, uint top, uint width, uint height, uint flags);
Collapse Expand Parameters
Parameters | Description
NPixelFormat srcPixelFormat | The source pixel format.
uint srcWidth | The width of the source image data.
uint srcHeight | The height of the source image data.
long srcStride | The stride of the source image data.
NBuffer srcPixels | The source memory block.
uint srcLeft | The left coordinate of the source image data.
uint srcTop | The top coordinate of the source image data.
uint left | The left coordinate of the image.
uint top | The top coordinate of the image.
uint width | The width of the image.
uint height | The height of the image.
uint flags | Flags controlling function. These flags can be used: NI_DST_ALPHA_CHANNEL_FIRST, NI_DST_BOTTOM_TO_TOP, NI_DST_SWAP_CHANNELS.


NImage.CopyFrom Method (NPixelFormat, uint, uint, long, NBuffer[], uint, uint, uint, uint, uint, uint, uint)

NImage.CopyFrom Method (NPixelFormat, uint, uint, long, NBuffer[], uint, uint, uint, uint, uint, uint, uint)
NImage Class Neurotec.Images Namespace

Copies planes to from memory buffer.

C#
public void CopyFrom(NPixelFormat srcPixelFormat, uint srcWidth, uint srcHeight, long srcStride, NBuffer[] srcPlanes, uint srcLeft, uint srcTop, uint left, uint top, uint width, uint height, uint flags);
Collapse Expand Parameters
Parameters | Description
NPixelFormat srcPixelFormat | The source pixel format.
uint srcWidth | The width of the source image data.
uint srcHeight | The height of the source image data.
long srcStride | The stride of the source image data.
NBuffer[] srcPlanes | The source memory block.
uint srcLeft | The left coordinate of the source image data.
uint srcTop | The top coordinate of the source image data.
uint left | The left coordinate of the image.
uint top | The top coordinate of the image.
uint width | The width of the image.
uint height | The height of the image.
uint flags | Flags controlling function. These flags can be used: NI_DST_ALPHA_CHANNEL_FIRST, NI_DST_BOTTOM_TO_TOP, NI_DST_SWAP_CHANNELS.


NImage.CopyFromYCbCrData Method

NImage.CopyFromYCbCrData Method
NImage Class Neurotec.Images Namespace

Copies NImage data using YCbCr color space.

C#
public void CopyFromYCbCrData(NBuffer planeY, int rowStrideY, int pixelStrideY, NBuffer planeCr, int rowStrideCr, int pixelStrideCr, NBuffer planeCb, int rowStrideCb, int pixelStrideCb);
Collapse Expand Parameters
Parameters | Description
NBuffer planeY | Buffer containing the luma component (Y).
int rowStrideY | Luma component (Y) row stride value.
int pixelStrideY | Luma component (Y) pixel stride value.
NBuffer planeCr | Buffer containing red-difference chroma component (Cr).
int rowStrideCr | Red-difference chroma component (Cr) row stride value.
int pixelStrideCr | Red-difference chroma component (Cr) pixel stride value.
NBuffer planeCb | Buffer containing blue-difference chroma component (Cb).
int rowStrideCb | Blue-difference chroma component (Cb) row stride value.
int pixelStrideCb | Blue-difference chroma component (Cb) pixel stride value.


NImage.CopyTo Method (NImage, uint, uint)

NImage.CopyTo Method (NImage, uint, uint)
NImage Class Neurotec.Images Namespace

Copies specified rectangular area of the NImage to other NImage object.

C#
public void CopyTo(NImage dstImage, uint dstLeft, uint dstTop);
Collapse Expand Parameters
Parameters | Description
NImage dstImage | Destination NImage object. Specified NImage will be copied to this object.
uint dstLeft | The x coordinate in the destination NImage object. Copied NImage will be placed starting by this coordinate.
uint dstTop | The y coordinate in the destination NImage object. Copied NImage will be placed starting by this coordinate.


NImage.CopyTo Method (NPixelFormat, uint, uint, int, NBuffer, uint, uint)

NImage.CopyTo Method (NPixelFormat, uint, uint, int, NBuffer, uint, uint)
NImage Class Neurotec.Images Namespace

Copies specified rectangular area of the NImage to other NImage object.

C#
public void CopyTo(NPixelFormat dstPixelFormat, uint dstWidth, uint dstHeight, int dstStride, NBuffer dstPixels, uint dstLeft, uint dstTop);
Collapse Expand Parameters
Parameters | Description
NPixelFormat dstPixelFormat | Destination pixel format.
uint dstWidth | The width of source image data.
uint dstHeight | The height of source image data.
int dstStride | The stride of source image data.
NBuffer dstPixels | Memory buffer where NImage data is saved.
uint dstLeft | The x coordinate in the destination NImage object. Copied NImage will be placed starting by this coordinate.
uint dstTop | The y coordinate in the destination NImage object. Copied NImage will be placed starting by this coordinate.


NImage.CopyTo Method (NPixelFormat, uint, uint, long, NBuffer, uint, uint, uint)

NImage.CopyTo Method (NPixelFormat, uint, uint, long, NBuffer, uint, uint, uint)
NImage Class Neurotec.Images Namespace

Copies specified rectangular area of the NImage to other NImage object.

C#
public void CopyTo(NPixelFormat dstPixelFormat, uint dstWidth, uint dstHeight, long dstStride, NBuffer dstPixels, uint dstLeft, uint dstTop, uint flags);
Collapse Expand Parameters
Parameters | Description
NPixelFormat dstPixelFormat | Destination pixel format.
uint dstWidth | The width of source image data.
uint dstHeight | The height of source image data.
long dstStride | The stride of source image data.
NBuffer dstPixels | Memory buffer where NImage data is saved.
uint dstLeft | The x coordinate in the destination NImage object. Copied NImage will be placed starting by this coordinate.
uint dstTop | The y coordinate in the destination NImage object. Copied NImage will be placed starting by this coordinate.
uint flags | Flags controlling this method. These flags can be used: FlagDstAlphaChannelFirst, FlagDstBottomToTop, FlagDstSwapChannels.


NImage.CopyTo Method (uint, uint, NPixelFormat, Array, Array, NBuffer, int, uint, uint, long, NBuffer[], uint, uint, uint, uint, uint)

NImage.CopyTo Method (uint, uint, NPixelFormat, Array, Array, NBuffer, int, uint, uint, long, NBuffer[], uint, uint, uint, uint, uint)
NImage Class Neurotec.Images Namespace

Copies part of planes of specified NImage to memory buffer.

C#
public void CopyTo(uint left, uint top, NPixelFormat dstPixelFormat, Array dstMinValue, Array dstMaxValue, NBuffer dstPalette, int dstPaletteLength, uint dstWidth, uint dstHeight, long dstStride, NBuffer[] dstPlanes, uint dstLeft, uint dstTop, uint width, uint height, uint flags);
Collapse Expand Parameters
Parameters | Description
uint left | Left coordinate of the image part.
uint top | Top coordinate of the image part.
NPixelFormat dstPixelFormat | Destination pixel format.
Array dstMinValue | Minimum destination pixel values.
Array dstMaxValue | Maximum destination pixel values.
NBuffer dstPalette | Destination image palette.
int dstPaletteLength | Destination image palette length.
uint dstWidth | The width of destination image data.
uint dstHeight | The height of destination image data.
long dstStride | The stride of destination image data.
NBuffer[] dstPlanes | The memory block where NImage data is saved.
uint dstLeft | The x coordinate in the destination NImage object. Copied data will be placed starting by this coordinate.
uint dstTop | The y coordinate in the destination NImage object. Copied data will be placed starting by this coordinate.
uint width | Width of the image part.
uint height | Height of the image part.
uint flags | Flags controlling function. These flags can be used: NI_DST_ALPHA_CHANNEL_FIRST, NI_DST_BOTTOM_TO_TOP, NI_DST_SWAP_CHANNELS.


NImage.CopyTo Method (uint, uint, NPixelFormat, uint, uint, long, NBuffer, uint, uint, uint, uint, uint)

NImage.CopyTo Method (uint, uint, NPixelFormat, uint, uint, long, NBuffer, uint, uint, uint, uint, uint)
NImage Class Neurotec.Images Namespace

Copies part of pixels of specified NImage to memory buffer.

C#
public void CopyTo(uint left, uint top, NPixelFormat dstPixelFormat, uint dstWidth, uint dstHeight, long dstStride, NBuffer dstPixels, uint dstLeft, uint dstTop, uint width, uint height, uint flags);
Collapse Expand Parameters
Parameters | Description
uint left | Left coordinate of the image part.
uint top | Top coordinate of the image part.
NPixelFormat dstPixelFormat | Destination pixel format.
uint dstWidth | The width of source image data.
uint dstHeight | The height of source image data.
long dstStride | The stride of source image data.
NBuffer dstPixels | The memory block where NImage data is saved.
uint dstLeft | The x coordinate in the destination NImage object. Copied data will be placed starting by this coordinate.
uint dstTop | The y coordinate in the destination NImage object. Copied data will be placed starting by this coordinate.
uint width | Width of the image part.
uint height | Height of the image part.
uint flags | Flags controlling function. These flags can be used: NI_DST_ALPHA_CHANNEL_FIRST, NI_DST_BOTTOM_TO_TOP, NI_DST_SWAP_CHANNELS.


NImage.CopyTo Method (uint, uint, NPixelFormat, uint, uint, long, NBuffer[], uint, uint, uint, uint, uint)

NImage.CopyTo Method (uint, uint, NPixelFormat, uint, uint, long, NBuffer[], uint, uint, uint, uint, uint)
NImage Class Neurotec.Images Namespace

Copies part of planes of specified NImage to memory buffer.

C#
public void CopyTo(uint left, uint top, NPixelFormat dstPixelFormat, uint dstWidth, uint dstHeight, long dstStride, NBuffer[] dstPlanes, uint dstLeft, uint dstTop, uint width, uint height, uint flags);
Collapse Expand Parameters
Parameters | Description
uint left | Left coordinate of the image part.
uint top | Top coordinate of the image part.
NPixelFormat dstPixelFormat | Destination pixel format.
uint dstWidth | The width of destination image data.
uint dstHeight | The height of destination image data.
long dstStride | The stride of destination image data.
NBuffer[] dstPlanes | The memory block where NImage data is saved.
uint dstLeft | The x coordinate in the destination NImage object. Copied data will be placed starting by this coordinate.
uint dstTop | The y coordinate in the destination NImage object. Copied data will be placed starting by this coordinate.
uint width | Width of the image part.
uint height | Height of the image part.
uint flags | Flags controlling function. These flags can be used: NI_DST_ALPHA_CHANNEL_FIRST, NI_DST_BOTTOM_TO_TOP, NI_DST_SWAP_CHANNELS.


NImage.Create Method (NPixelFormat, uint, uint, int)

NImage.Create Method (NPixelFormat, uint, uint, int)
NImage Class Neurotec.Images Namespace

Creates NImage with specified pixel format, size and stride.

C#
public static NImage Create(NPixelFormat pixelFormat, uint width, uint height, int stride);
Collapse Expand Parameters
Parameters | Description
NPixelFormat pixelFormat | Image pixel format.
uint width | Image width.
uint height | Image height.
int stride | Image stride.
Collapse Expand Returns

NImage object.


NImage.Create Method (NPixelFormat, uint, uint, long, uint)

NImage.Create Method (NPixelFormat, uint, uint, long, uint)
NImage Class Neurotec.Images Namespace

Creates NImage with specified pixel format, size, stride and flags.

C#
public static NImage Create(NPixelFormat pixelFormat, uint width, uint height, long stride, uint flags);
Collapse Expand Parameters
Parameters | Description
NPixelFormat pixelFormat | Image pixel format.
uint width | Image width.
uint height | Image height.
long stride | Image stride.
uint flags | Flags controlling object creation. See section "Fileds" for the list of available to use flags.
Collapse Expand Returns

NImage object.


NImage.Crop Method

NImage.Crop Method
NImage Class Neurotec.Images Namespace

Crops an image.

C#
public NImage Crop(uint left, uint top, uint width, uint height);
Collapse Expand Parameters
Parameters | Description
uint left | X-coordinate of the cropping rectangle.
uint top | Y-coordinate of the cropping rectangle.
uint width | Width of the cropping rectangle.
uint height | Height of the cropping rectangle.
Collapse Expand Returns

Cropped NImage object.


NImage.ExportPalette Method

NImage.ExportPalette Method
NImage Class Neurotec.Images Namespace

Exports the palette from the current image.

C#
public NBuffer ExportPalette(NPixelFormat dstPixelFormat, Array dstMinValue, Array dstMaxValue, uint flags, out int paletteLength);
Collapse Expand Parameters
Parameters | Description
NPixelFormat dstPixelFormat | The destination pixel format.
Array dstMinValue | Minimum destination pixel values.
Array dstMaxValue | Maximum destination pixel values.
uint flags | Flags controlling function. These flags can be used: NI_DST_ALPHA_CHANNEL_FIRST, NI_DST_BOTTOM_TO_TOP, NI_DST_SWAP_CHANNELS.
out int paletteLength | [out] Palette length.
Collapse Expand Returns

NBuffer containing the palette.


NImage.FlipDiagonally Method

NImage.FlipDiagonally Method
NImage Class Neurotec.Images Namespace

Flips image diagonally.

C#
public void FlipDiagonally();


NImage.FlipHorizontally Method

NImage.FlipHorizontally Method
NImage Class Neurotec.Images Namespace

Flips image horizontally.

C#
public void FlipHorizontally();


NImage.FlipVertically Method

NImage.FlipVertically Method
NImage Class Neurotec.Images Namespace

Flips image vertically.

C#
public void FlipVertically();


NImage.FromData Method (NPixelFormat, int, uint, uint, int, NBuffer, uint, uint, uint, uint)

NImage.FromData Method (NPixelFormat, int, uint, uint, int, NBuffer, uint, uint, uint, uint)
NImage Class Neurotec.Images Namespace

Creates NImage object from data with specified parameters.

C#
public static NImage FromData(NPixelFormat pixelFormat, int stride, uint srcWidth, uint srcHeight, int srcStride, NBuffer srcPixels, uint left, uint top, uint width, uint height);
Collapse Expand Parameters
Parameters | Description
NPixelFormat pixelFormat | A NPixelFormat of image.
int stride | A stride of image.
uint srcWidth | A width of source image.
uint srcHeight | A height o source image.
int srcStride | A stride of source image.
NBuffer srcPixels | Source image pixel array.
uint left | X coordinate of the image.
uint top | Y coordinate of the image.
uint width | Specifies width of the image.
uint height | Specifies height of the image.
Collapse Expand Returns

A NImage object.

Collapse Expand Remarks

If stride is zero then image stride is automatically calculated. For more information on image stride see Stride property.

Format of memory block srcPixels points to must be the same as described in Pixels property, only stride is equal to srcStride.


NImage.FromData Method (NPixelFormat, long, uint, uint, long, NBuffer, uint, uint, uint, uint, uint)

NImage.FromData Method (NPixelFormat, long, uint, uint, long, NBuffer, uint, uint, uint, uint, uint)
NImage Class Neurotec.Images Namespace

Creates NImage object from data with specified parameters.

C#
public static NImage FromData(NPixelFormat pixelFormat, long stride, uint srcWidth, uint srcHeight, long srcStride, NBuffer srcPixels, uint left, uint top, uint width, uint height, uint flags);
Collapse Expand Parameters
Parameters | Description
NPixelFormat pixelFormat | A NPixelFormat of image.
long stride | A stride of image.
uint srcWidth | A width of source image.
uint srcHeight | A height of source image.
long srcStride | A stride of source image.
NBuffer srcPixels | Source image pixel array.
uint left | X coordinate of the image.
uint top | Y coordinate of the image.
uint width | Specifies width of the image.
uint height | Specifies height of the image.
uint flags | Flags controlling NImage creation. These flags can be used: FlagSrcAlphaChannelFirst, FlagSrcBottomToTop, FlagSrcSwapChannels.
Collapse Expand Returns

A NImage object.

Collapse Expand Remarks

If stride is zero then image stride is automatically calculated. For more information on image stride see Stride property.

Format of memory block srcPixels points to must be the same as described in Pixels property, only stride is equal to srcStride.


NImage.FromData Method (NPixelFormat, long, uint, uint, long, NBuffer[], uint, uint, uint, uint, uint)

NImage.FromData Method (NPixelFormat, long, uint, uint, long, NBuffer[], uint, uint, uint, uint, uint)
NImage Class Neurotec.Images Namespace

Creates NImage object from data with specified parameters.

C#
public static NImage FromData(NPixelFormat pixelFormat, long stride, uint srcWidth, uint srcHeight, long srcStride, NBuffer[] srcPlanes, uint srcLeft, uint srcTop, uint width, uint height, uint flags);
Collapse Expand Parameters
Parameters | Description
NPixelFormat pixelFormat | A NPixelFormat of image.
long stride | A stride of image.
uint srcWidth | A width of source image.
uint srcHeight | A height of source image.
long srcStride | A stride of source image.
NBuffer[] srcPlanes | NBuffer containing source planes.
uint srcLeft | X coordinate of the image.
uint srcTop | Y coordinate of the image.
uint width | Specifies width of the image.
uint height | Specifies height of the image.
uint flags | Flags controlling NImage creation. These flags can be used: FlagSrcAlphaChannelFirst, FlagSrcBottomToTop, FlagSrcSwapChannels.
Collapse Expand Returns

NImage object.


NImage.FromData Method (NPixelFormat, uint, uint, int, uint, NBuffer)

NImage.FromData Method (NPixelFormat, uint, uint, int, uint, NBuffer)
NImage Class Neurotec.Images Namespace

Creates NImage object from data with specified parameters.

C#
public static NImage FromData(NPixelFormat pixelFormat, uint width, uint height, int stride, uint srcStride, NBuffer srcPixels);
Collapse Expand Parameters
Parameters | Description
NPixelFormat pixelFormat | A NPixelFormat of image.
uint width | Specifies width of the image.
uint height | Specifies height of the image.
int stride | A stride of image.
uint srcStride | A stride of source image.
NBuffer srcPixels | Source image pixel array.
Collapse Expand Returns

A NImage object.

Collapse Expand Remarks

If stride is zero then image stride is automatically calculated. For more information on image stride see Stride property.

Format of memory block srcPixels points to must be the same as described in Pixels property, only stride is equal to srcStride.


NImage.FromData Method (NPixelFormat, uint, uint, long, long, NBuffer, uint)

NImage.FromData Method (NPixelFormat, uint, uint, long, long, NBuffer, uint)
NImage Class Neurotec.Images Namespace

Creates NImage object from data with specified parameters.

C#
public static NImage FromData(NPixelFormat pixelFormat, uint width, uint height, long stride, long srcStride, NBuffer srcPixels, uint flags);
Collapse Expand Parameters
Parameters | Description
NPixelFormat pixelFormat | A NPixelFormat of image.
uint width | Specifies width of the image.
uint height | Specifies height of the image.
long stride | A stride of image.
long srcStride | A stride of source image.
NBuffer srcPixels | Source image pixel array.
uint flags | Flags controlling NImage creation. These flags can be used: FlagSrcAlphaChannelFirst, FlagSrcBottomToTop, FlagSrcSwapChannels.
Collapse Expand Returns

A NImage object.

Collapse Expand Remarks

If stride is zero then image stride is automatically calculated. For more information on image stride see Stride property.

Format of memory block srcPixels points to must be the same as described in Pixels property, only stride is equal to srcStride.


NImage.FromFile Method (string)

NImage.FromFile Method (string)
NImage Class Neurotec.Images Namespace

Creates NImage object from file.

C#
public static NImage FromFile(string fileName);
Collapse Expand Parameters
Parameters | Description
string fileName | A string that contains the name of the file.
Collapse Expand Returns

A NImage object.


NImage.FromFile Method (string, NImageFormat)

NImage.FromFile Method (string, NImageFormat)
NImage Class Neurotec.Images Namespace

Creates NImage object from file with specified NImageFormat.

C#
public static NImage FromFile(string fileName, NImageFormat imageFormat);
Collapse Expand Parameters
Parameters | Description
string fileName | A string that contains the name of the file.
NImageFormat imageFormat | An image NImageFormat object.
Collapse Expand Returns

A NImage object.


NImage.FromFile Method (string, NImageFormat, uint)

NImage.FromFile Method (string, NImageFormat, uint)
NImage Class Neurotec.Images Namespace

Creates NImage object from file with specified NImageFormat.

C#
public static NImage FromFile(string fileName, NImageFormat imageFormat, uint flags);
Collapse Expand Parameters
Parameters | Description
string fileName | A string that contains the name of the file.
NImageFormat imageFormat | An image NImageFormat object.
uint flags | Flags controlling method. Reserved for future use. Must be 0.
Collapse Expand Returns

A NImage object.


NImage.FromImage Method (NPixelFormat, int, NImage)

NImage.FromImage Method (NPixelFormat, int, NImage)
NImage Class Neurotec.Images Namespace

Creates NImage object from another NImage object.

C#
public static NImage FromImage(NPixelFormat pixelFormat, int stride, NImage srcImage);
Collapse Expand Parameters
Parameters | Description
NPixelFormat pixelFormat | A NPixelFormat of image.
int stride | A stride of image.
NImage srcImage | A NImage source object.
Collapse Expand Returns

A NImage object.

Collapse Expand Remarks

If stride is zero then image stride is automatically calculated. For more information on image stride see Stride property.


NImage.FromImage Method (NPixelFormat, int, NImage, uint, uint, uint, uint)

NImage.FromImage Method (NPixelFormat, int, NImage, uint, uint, uint, uint)
NImage Class Neurotec.Images Namespace

Creates NImage object from another NImage object.

C#
public static NImage FromImage(NPixelFormat pixelFormat, int stride, NImage srcImage, uint left, uint top, uint width, uint height);
Collapse Expand Parameters
Parameters | Description
NPixelFormat pixelFormat | A NPixelFormat of image.
int stride | A stride of image.
NImage srcImage | A NImage source object.
uint left | X-coordinate of the image rectangle.
uint top | Y-coordinate of the image rectangle.
uint width | A width of image.
uint height | A height of image.
Collapse Expand Returns

A NImage object.

Collapse Expand Remarks

If stride is zero then image stride is automatically calculated. For more information on image stride see Stride property.


NImage.FromImage Method (NPixelFormat, long, NImage, uint)

NImage.FromImage Method (NPixelFormat, long, NImage, uint)
NImage Class Neurotec.Images Namespace

Creates NImage object from another NImage object.

C#
public static NImage FromImage(NPixelFormat pixelFormat, long stride, NImage srcImage, uint flags);
Collapse Expand Parameters
Parameters | Description
NPixelFormat pixelFormat | A NPixelFormat of image.
long stride | A stride of image.
NImage srcImage | A NImage source object.
uint flags | Flags controlling method. Reserved for future use. Must be 0.
Collapse Expand Returns

A NImage object.

Collapse Expand Remarks

If stride is zero then image stride is automatically calculated. For more information on image stride see Stride property.


NImage.FromImage Method (NPixelFormat, long, NImage, uint, uint, uint, uint, uint)

NImage.FromImage Method (NPixelFormat, long, NImage, uint, uint, uint, uint, uint)
NImage Class Neurotec.Images Namespace

Creates NImage object from another NImage object.

C#
public static NImage FromImage(NPixelFormat pixelFormat, long stride, NImage srcImage, uint left, uint top, uint width, uint height, uint flags);
Collapse Expand Parameters
Parameters | Description
NPixelFormat pixelFormat | A NPixelFormat of image.
long stride | A stride of image.
NImage srcImage | A NImage source object.
uint left | X-coordinate of the image rectangle.
uint top | Y-coordinate of the image rectangle.
uint width | A width of image.
uint height | A height of image.
uint flags | Flags controlling method. Reserved for future use. Must be 0.
Collapse Expand Returns

A NImage object.

Collapse Expand Remarks

If stride is zero then image stride is automatically calculated. For more information on image stride see Stride property.


NImage.FromMemory Method (NBuffer)

NImage.FromMemory Method (NBuffer)
NImage Class Neurotec.Images Namespace

Creates NImage object from another memory buffer.

C#
public static NImage FromMemory(NBuffer buffer);
Collapse Expand Parameters
Parameters | Description
NBuffer buffer | Memory buffer containing NImage data.
Collapse Expand Returns

Created NImage object.


NImage.FromMemory Method (NBuffer, NImageFormat)

NImage.FromMemory Method (NBuffer, NImageFormat)
NImage Class Neurotec.Images Namespace

Creates NImage object from another memory buffer.

C#
public static NImage FromMemory(NBuffer buffer, NImageFormat imageFormat);
Collapse Expand Parameters
Parameters | Description
NBuffer buffer | Memory buffer containing NImage data.
NImageFormat imageFormat | Image format.
Collapse Expand Returns

Created NImage object.


NImage.FromMemory Method (NBuffer, NImageFormat, uint)

NImage.FromMemory Method (NBuffer, NImageFormat, uint)
NImage Class Neurotec.Images Namespace

Creates NImage object from another memory buffer.

C#
public static NImage FromMemory(NBuffer buffer, NImageFormat imageFormat, uint flags);
Collapse Expand Parameters
Parameters | Description
NBuffer buffer | Memory buffer containing NImage data.
NImageFormat imageFormat | Image format.
uint flags | Flags controlling method. Reserved for future use. Must be 0.
Collapse Expand Returns

Created NImage object.


NImage.FromMemory Method (byte[])

NImage.FromMemory Method (byte[])
NImage Class Neurotec.Images Namespace

Creates NImage object from a byte array.

C#
public static NImage FromMemory(byte[] buffer);
Collapse Expand Parameters
Parameters | Description
byte[] buffer | The source byte array.
Collapse Expand Returns

Created NImage object.


NImage.FromMemory Method (byte[], NImageFormat)

NImage.FromMemory Method (byte[], NImageFormat)
NImage Class Neurotec.Images Namespace

Creates NImage object from a byte array.

C#
public static NImage FromMemory(byte[] buffer, NImageFormat format);
Collapse Expand Parameters
Parameters | Description
byte[] buffer | The source byte array.
NImageFormat format | Image format.
Collapse Expand Returns

Created NImage object.


NImage.FromStream Method (NStream)

NImage.FromStream Method (NStream)
NImage Class Neurotec.Images Namespace

Reads NImage from the specified stream

C#
public static NImage FromStream(NStream stream);
Collapse Expand Parameters
Parameters | Description
NStream stream | Stream which contains NImage data.
Collapse Expand Returns

NImage object.


NImage.FromStream Method (NStream, NImageFormat)

NImage.FromStream Method (NStream, NImageFormat)
NImage Class Neurotec.Images Namespace

Reads NImage from the specified stream with specified image format.

C#
public static NImage FromStream(NStream stream, NImageFormat imageFormat);
Collapse Expand Parameters
Parameters | Description
NStream stream | Stream which contains NImage data.
NImageFormat imageFormat | Image format.
Collapse Expand Returns

NImage object.


NImage.FromStream Method (NStream, NImageFormat, uint)

NImage.FromStream Method (NStream, NImageFormat, uint)
NImage Class Neurotec.Images Namespace

Reads NImage from the specified stream with specified image format.

C#
public static NImage FromStream(NStream stream, NImageFormat imageFormat, uint flags);
Collapse Expand Parameters
Parameters | Description
NStream stream | Stream which contains NImage data.
NImageFormat imageFormat | Image format.
uint flags | Flags controlling method. Reserved for future use. Must be 0.
Collapse Expand Returns

NImage object.


NImage.FromVideoSample Method (NVideoFormat, NBuffer)

NImage.FromVideoSample Method (NVideoFormat, NBuffer)
NImage Class Neurotec.Images Namespace

Creates NImage object from specified video sample.

C#
public static NImage FromVideoSample(NVideoFormat format, NBuffer sample);
Collapse Expand Parameters
Parameters | Description
NVideoFormat format | Video format value.
NBuffer sample | Memory buffer containing video sample.
Collapse Expand Returns

Created NImage object.


NImage.FromVideoSample Method (NVideoFormat, byte[])

NImage.FromVideoSample Method (NVideoFormat, byte[])
NImage Class Neurotec.Images Namespace

Creates NImage object from specified video sample.

C#
public static NImage FromVideoSample(NVideoFormat format, byte[] sample);
Collapse Expand Parameters
Parameters | Description
NVideoFormat format | Video format value.
byte[] sample | Bytes array containing video sample.
Collapse Expand Returns

Created NImage object.


NImage.GetIndex Method

NImage.GetIndex Method
NImage Class Neurotec.Images Namespace

Retrieves the palette entry index of the specified pixel.

C#
public int GetIndex(uint x, uint y);
Collapse Expand Parameters
Parameters | Description
uint x | X-coordinate of the pixel.
uint y | Y-coordinate of the pixel.
Collapse Expand Returns

Palette entry index.


NImage.GetPixel Method

NImage.GetPixel Method
NImage Class Neurotec.Images Namespace

Retrieves the specified pixel.

C#
public Array GetPixel(uint x, uint y);
Collapse Expand Parameters
Parameters | Description
uint x | X-coordinate of the pixel.
uint y | Y-coordinate of the pixel.
Collapse Expand Returns

An array representing the pixel.


NImage.GetPixels Method

NImage.GetPixels Method
NImage Class Neurotec.Images Namespace

Gets buffer which contains image pixels.

C#
public NBuffer GetPixels();
Collapse Expand Returns

Memory buffer containing image pixels.


NImage.GetSupportedVideoSubtypes Method

NImage.GetSupportedVideoSubtypes Method
NImage Class Neurotec.Images Namespace

Gets supported videos subtypes.

C#
public static uint[] GetSupportedVideoSubtypes();
Collapse Expand Returns

Array of supported video subtypes.


NImage.GetWrapper Method (NImage, uint, uint, uint, uint)

NImage.GetWrapper Method (NImage, uint, uint, uint, uint)
NImage Class Neurotec.Images Namespace

Creates NImage object wrapper.

C#
public static NImage GetWrapper(NImage srcImage, uint left, uint top, uint width, uint height);
Collapse Expand Parameters
Parameters | Description
NImage srcImage | A NImage source object.
uint left | X-coordinate of the image rectangle.
uint top | Y-coordinate of the image rectangle.
uint width | A width of image.
uint height | A height of image.
Collapse Expand Returns

A NImage object.

Collapse Expand Remarks

For more information on image stride see Stride property.

Format of memory block pixels points to must be the same as described in Pixels property.

horzResolution and vertResolution can be zero if resolution is not applicable for the image.

Collapse Expand Exceptions
Exceptions | Description
ArgumentNullException | srcImage is null.


NImage.GetWrapper Method (NImage, uint, uint, uint, uint, uint)

NImage.GetWrapper Method (NImage, uint, uint, uint, uint, uint)
NImage Class Neurotec.Images Namespace

Creates NImage object wrapper.

C#
public static NImage GetWrapper(NImage srcImage, uint left, uint top, uint width, uint height, uint flags);
Collapse Expand Parameters
Parameters | Description
NImage srcImage | A NImage source object.
uint left | X-coordinate of the image rectangle.
uint top | Y-coordinate of the image rectangle.
uint width | A width of image.
uint height | A height of image.
uint flags | Must be zero.
Collapse Expand Returns

A NImage object.

Collapse Expand Remarks

For more information on image stride see Stride property.

Format of memory block pixels points to must be the same as described in Pixels property.

horzResolution and vertResolution can be zero if resolution is not applicable for the image.


NImage.GetWrapper Method (NPixelFormat, uint, uint, int, NBuffer)

NImage.GetWrapper Method (NPixelFormat, uint, uint, int, NBuffer)
NImage Class Neurotec.Images Namespace

Creates NImage object wrapper.

C#
public static NImage GetWrapper(NPixelFormat pixelFormat, uint width, uint height, int stride, NBuffer pixels);
Collapse Expand Parameters
Parameters | Description
NPixelFormat pixelFormat | Format of the pixels.
uint width | A width of image.
uint height | A height of image.
int stride | The stride of the image.
NBuffer pixels | The source pixels.
Collapse Expand Returns

A NImage object.

Collapse Expand Remarks

For more information on image stride see Stride property.

Format of memory block pixels points to must be the same as described in Pixels property.

horzResolution and vertResolution can be zero if resolution is not applicable for the image.


NImage.GetWrapper Method (NPixelFormat, uint, uint, int, NBuffer, uint, uint, uint, uint)

NImage.GetWrapper Method (NPixelFormat, uint, uint, int, NBuffer, uint, uint, uint, uint)
NImage Class Neurotec.Images Namespace

Creates NImage object wrapper.

C#
public static NImage GetWrapper(NPixelFormat pixelFormat, uint srcWidth, uint srcHeight, int stride, NBuffer pixels, uint left, uint top, uint width, uint height);
Collapse Expand Parameters
Parameters | Description
NPixelFormat pixelFormat | Format of the pixels.
uint srcWidth | Width of the source image.
uint srcHeight | Height of the source image.
int stride | The stride of the image.
NBuffer pixels | The source pixels.
uint left | X-coordinate of the image rectangle.
uint top | Y-coordinate of the image rectangle.
uint width | A width of image.
uint height | A height of image.
Collapse Expand Returns

A NImage object.

Collapse Expand Remarks

For more information on image stride see Stride property.

Format of memory block pixels points to must be the same as described in Pixels property.

horzResolution and vertResolution can be zero if resolution is not applicable for the image


NImage.GetWrapper Method (NPixelFormat, uint, uint, long, NBuffer, uint)

NImage.GetWrapper Method (NPixelFormat, uint, uint, long, NBuffer, uint)
NImage Class Neurotec.Images Namespace

Creates NImage object wrapper.

C#
public static NImage GetWrapper(NPixelFormat pixelFormat, uint width, uint height, long stride, NBuffer pixels, uint flags);
Collapse Expand Parameters
Parameters | Description
NPixelFormat pixelFormat | Format of the pixels.
uint width | A width of image.
uint height | A height of image.
long stride | The stride of the image.
NBuffer pixels | The source pixels.
uint flags | Must be zero.
Collapse Expand Returns

A NImage object.

Collapse Expand Remarks

For more information on image stride see Stride property.

Format of memory block pixels points to must be the same as described in Pixels property.

horzResolution and vertResolution can be zero if resolution is not applicable for the image


NImage.GetWrapper Method (NPixelFormat, uint, uint, long, NBuffer, uint, uint, uint, uint, uint)

NImage.GetWrapper Method (NPixelFormat, uint, uint, long, NBuffer, uint, uint, uint, uint, uint)
NImage Class Neurotec.Images Namespace

Creates NImage object wrapper.

C#
public static NImage GetWrapper(NPixelFormat pixelFormat, uint srcWidth, uint srcHeight, long stride, NBuffer pixels, uint left, uint top, uint width, uint height, uint flags);
Collapse Expand Parameters
Parameters | Description
NPixelFormat pixelFormat | Format of the pixels.
uint srcWidth | Width of the source image.
uint srcHeight | Height of the source image.
long stride | The stride of the image.
NBuffer pixels | The source pixels.
uint left | X-coordinate of the image rectangle.
uint top | Y-coordinate of the image rectangle.
uint width | A width of image.
uint height | A height of image.
uint flags | Must be zero.
Collapse Expand Returns

A NImage object.

Collapse Expand Remarks

For more information on image stride see Stride property.

Format of memory block pixels points to must be the same as described in Pixels property.

horzResolution and vertResolution can be zero if resolution is not applicable for the image


NImage.GetWrapper Method (NPixelFormat, uint, uint, long, NBuffer[], uint, uint, uint, uint, uint)

NImage.GetWrapper Method (NPixelFormat, uint, uint, long, NBuffer[], uint, uint, uint, uint, uint)
NImage Class Neurotec.Images Namespace

Creates NImage object wrapper.

C#
public static NImage GetWrapper(NPixelFormat pixelFormat, uint srcWidth, uint srcHeight, long stride, NBuffer[] planes, uint left, uint top, uint width, uint height, uint flags);
Collapse Expand Parameters
Parameters | Description
NPixelFormat pixelFormat | Format of the pixels.
uint srcWidth | Width of the source image.
uint srcHeight | Height of the source image.
long stride | The stride of the image.
NBuffer[] planes | The source planes.
uint left | X-coordinate of the image rectangle.
uint top | Y-coordinate of the image rectangle.
uint width | A width of image.
uint height | A height of image.
uint flags | Must be zero.
Collapse Expand Returns

A NImage object.


NImage.IsVideoFormatSupported Method

NImage.IsVideoFormatSupported Method
NImage Class Neurotec.Images Namespace

Checks if specified video format is supported.

C#
public static bool IsVideoFormatSupported(NVideoFormat format);
Collapse Expand Parameters
Parameters | Description
NVideoFormat format | One of video formats.
Collapse Expand Returns

true if video format is supported; otherwise - false.


NImage.IsVideoSubtypeSupported Method

NImage.IsVideoSubtypeSupported Method
NImage Class Neurotec.Images Namespace

Checks if specified video subtype is supported.

C#
public static bool IsVideoSubtypeSupported(uint value);
Collapse Expand Parameters
Parameters | Description
uint value | One of video subtype values.
Collapse Expand Returns

true if video subtype is supported; otherwise - false.


NImage.RotateFlip Method

NImage.RotateFlip Method
NImage Class Neurotec.Images Namespace

Rotates image using rotation type.

C#
public NImage RotateFlip(NImageRotateFlipType rotateFlipType);
Collapse Expand Parameters
Parameters | Description
NImageRotateFlipType rotateFlipType | One of the rotation type value.
Collapse Expand Returns

Rotated NImage object.


NImage.Save Method (NImageFormat)

NImage.Save Method (NImageFormat)
NImage Class Neurotec.Images Namespace

Saves image to memory buffer using specified format.

C#
public NBuffer Save(NImageFormat imageFormat);
Collapse Expand Parameters
Parameters | Description
NImageFormat imageFormat | Image format.
Collapse Expand Returns

NBuffer type memory buffer which contains saved image data.


NImage.Save Method (NImageFormat, NImageInfo, uint)

NImage.Save Method (NImageFormat, NImageInfo, uint)
NImage Class Neurotec.Images Namespace

Saves image to memory buffer using specified format.

C#
public NBuffer Save(NImageFormat imageFormat, NImageInfo info, uint flags);
Collapse Expand Parameters
Parameters | Description
NImageFormat imageFormat | Image format.
NImageInfo info | Image info.
uint flags | Flags controlling method. Reserved for future use. Must be 0.
Collapse Expand Returns

NBuffer type memory buffer which contains saved image data.


NImage.Save Method (NImageInfo)

NImage.Save Method (NImageInfo)
NImage Class Neurotec.Images Namespace

Saves image to memory buffer using specified image info.

C#
public NBuffer Save(NImageInfo info);
Collapse Expand Parameters
Parameters | Description
NImageInfo info | Image info.
Collapse Expand Returns

NBuffer type memory buffer which contains saved image data.


NImage.Save Method (NStream, NImageFormat)

NImage.Save Method (NStream, NImageFormat)
NImage Class Neurotec.Images Namespace

Saves image to stream using specified format.

C#
public void Save(NStream stream, NImageFormat imageFormat);
Collapse Expand Parameters
Parameters | Description
NStream stream | Data stream used to save the image.
NImageFormat imageFormat | Image format.


NImage.Save Method (NStream, NImageFormat, NImageInfo, uint)

NImage.Save Method (NStream, NImageFormat, NImageInfo, uint)
NImage Class Neurotec.Images Namespace

Saves image to stream using specified format and image info.

C#
public void Save(NStream stream, NImageFormat imageFormat, NImageInfo info, uint flags);
Collapse Expand Parameters
Parameters | Description
NStream stream | Data stream used to save the image.
NImageFormat imageFormat | Image format.
NImageInfo info | Image info.
uint flags | Flags controlling method. Reserved for future use. Must be 0.


NImage.Save Method (NStream, NImageInfo)

NImage.Save Method (NStream, NImageInfo)
NImage Class Neurotec.Images Namespace

Saves image to stream using specified image info.

C#
public void Save(NStream stream, NImageInfo info);
Collapse Expand Parameters
Parameters | Description
NStream stream | Data stream used to save the image.
NImageInfo info | Image info.


NImage.Save Method (string)

NImage.Save Method (string)
NImage Class Neurotec.Images Namespace

Saves NImage object to file.

C#
public void Save(string fileName);
Collapse Expand Parameters
Parameters | Description
string fileName | A string that contains the name of the file.


NImage.Save Method (string, NImageFormat)

NImage.Save Method (string, NImageFormat)
NImage Class Neurotec.Images Namespace

Saves NImage object to file with specified NImageFormat.

C#
public void Save(string fileName, NImageFormat imageFormat);
Collapse Expand Parameters
Parameters | Description
string fileName | A string that contains the name of the file.
NImageFormat imageFormat | An image NImageFormat object.


NImage.Save Method (string, NImageFormat, NImageInfo, uint)

NImage.Save Method (string, NImageFormat, NImageInfo, uint)
NImage Class Neurotec.Images Namespace

Saves image to file using specified format and image info.

C#
public void Save(string fileName, NImageFormat imageFormat, NImageInfo info, uint flags);
Collapse Expand Parameters
Parameters | Description
string fileName | A string that contains the name of the file.
NImageFormat imageFormat | Image format.
NImageInfo info | Image info.
uint flags | Flags controlling method. Reserved for future use. Must be 0.


NImage.Save Method (string, NImageInfo)

NImage.Save Method (string, NImageInfo)
NImage Class Neurotec.Images Namespace

Saves image to file using specified image info.

C#
public void Save(string fileName, NImageInfo info);
Collapse Expand Parameters
Parameters | Description
string fileName | A string that contains the name of the file.
NImageInfo info | Image info.


NImage.SetIndex Method

NImage.SetIndex Method
NImage Class Neurotec.Images Namespace

Sets the palette entry index for the specified pixel.

C#
public void SetIndex(uint x, uint y, int value);
Collapse Expand Parameters
Parameters | Description
uint x | X-coordinate of the pixel.
uint y | Y-coordinate of the pixel.
int value | Index of the palette entry.


NImage.SetPixel Method

NImage.SetPixel Method
NImage Class Neurotec.Images Namespace

Sets specified pixel's value to the specified value.

C#
public void SetPixel(uint x, uint y, Array value);
Collapse Expand Parameters
Parameters | Description
uint x | X-coordinate of the pixel.
uint y | Y-coordinate of the pixel.
Array value | An array representing the new pixel value.


NImage.Height Property

NImage.Height Property
NImage Class Neurotec.Images Namespace

Gets height of image from NImage object.

C#
public uint Height;
Property value

A height of image.


NImage.HorzResolution Property

NImage.HorzResolution Property
NImage Class Neurotec.Images Namespace

Gets horizontal resolution in pixels per inch of image.

C#
public float HorzResolution;
Property value

A horizontal resolution in pixels per inch of image.

Collapse Expand Remarks

Horizontal resolution equal to zero means that it is not applicable for the image.


NImage.ImageSize Property

NImage.ImageSize Property
NImage Class Neurotec.Images Namespace

Gets size of NImage object.

C#
public int ImageSize;
Property value

A size of NImage object.

Collapse Expand Remarks

Size of memory block containing image pixels is equal to image height multiplied by image stride. For more information see Height and Stride properties.


NImage.Info Property

NImage.Info Property
NImage Class Neurotec.Images Namespace

Retrieves a NImageInfo object for the current image.

C#
public NImageInfo Info;


NImage.LongImageSize Property

NImage.LongImageSize Property
NImage Class Neurotec.Images Namespace

Gets size of NImage object.

C#
public long LongImageSize;
Property value

A size of NImage object.

Collapse Expand Remarks

Size of memory block containing image pixels is equal to image height multiplied by image stride. For more information see Height and Stride properties.


NImage.LongPlaneSize Property

NImage.LongPlaneSize Property
NImage Class Neurotec.Images Namespace

Gets the plane size.

C#
public long LongPlaneSize;
Property value

Long number representing plane size.


NImage.LongStride Property

NImage.LongStride Property
NImage Class Neurotec.Images Namespace

Gets stride of image from NImage object.

C#
public long LongStride;
Property value

A stride of image.

Collapse Expand Remarks

Stride (size of one row) of the image depends on image pixel format and width. It cannot be less than value obtained with GetRowLongSize or GetRowSize methods with arguments obtained with PixelFormat and Width properties.


NImage.MaxValue Property

NImage.MaxValue Property
NImage Class Neurotec.Images Namespace

Gets or sets the maximum value of a pixel.

C#
public Array MaxValue;


NImage.MinValue Property

NImage.MinValue Property
NImage Class Neurotec.Images Namespace

Gets or sets the minimum value of a pixel.

C#
public Array MinValue;


NImage.NativeImageSize Property

NImage.NativeImageSize Property
NImage Class Neurotec.Images Namespace

Gets size of NImage object.

C#
public UIntPtr NativeImageSize;
Property value

A size of NImage object.

Collapse Expand Remarks

Size of memory block containing image pixels is equal to image height multiplied by image stride. For more information see Height and Stride properties.


NImage.NativePlaneSize Property

NImage.NativePlaneSize Property
NImage Class Neurotec.Images Namespace

Gets the native plane size.

C#
public UIntPtr NativePlaneSize;
Property value

UIntPtr representing plane size.


NImage.NativeStride Property

NImage.NativeStride Property
NImage Class Neurotec.Images Namespace

Gets stride of image from NImage object.

C#
public UIntPtr NativeStride;
Property value

A stride of image.

Collapse Expand Remarks

Stride (size of one row) of the image depends on image pixel format and width. It cannot be less than value obtained with GetRowLongSize or GetRowSize methods with arguments obtained with PixelFormat and Width properties.


NImage.NativeType Property

NImage.NativeType Property
NImage Class Neurotec.Images Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NImage.Palette Property

NImage.Palette Property
NImage Class Neurotec.Images Namespace

Retrieves the palette of the current image.

C#
public ImagePalette Palette;


NImage.PixelFormat Property

NImage.PixelFormat Property
NImage Class Neurotec.Images Namespace

Gets NPixelFormat of NImage object.

C#
public NPixelFormat PixelFormat;
Property value

A NPixelFormat structure.


NImage.PlaneSize Property

NImage.PlaneSize Property
NImage Class Neurotec.Images Namespace

Gets the plane size.

C#
public int PlaneSize;
Property value

Int number representing plane size.


NImage.Planes Property

NImage.Planes Property
NImage Class Neurotec.Images Namespace

Gets the collection of planes.

C#
public PlaneCollection Planes;


NImage.ResolutionIsAspectRatio Property

NImage.ResolutionIsAspectRatio Property
NImage Class Neurotec.Images Namespace

Gets or sets NImage resolution aspect ratio.

C#
public bool ResolutionIsAspectRatio;
Property value

True, if resolution aspect ratio is used. False, otherwise.

Collapse Expand Remarks

NImage resolution can have 2 modes: physical height and width in pixels or aspect ratio. Picture aspect ratio defines the shape of displayed image. Picture aspect ratio is notated X:Y, where X:Y is the ration of picture width to height. If this property has True value it means that NImage shape is defined using width and height ratio (aspect ratio).


NImage.Stride Property

NImage.Stride Property
NImage Class Neurotec.Images Namespace

Gets stride of image from NImage object.

C#
public int Stride;
Property value

A stride of image.

Collapse Expand Remarks

Stride (size of one row) of the image depends on image pixel format and width. It cannot be less than value obtained with GetRowLongSize or GetRowSize methods with arguments obtained with PixelFormat and Width properties.


NImage.VertResolution Property

NImage.VertResolution Property
NImage Class Neurotec.Images Namespace

Gets vertical resolution in pixels per inch of image.

C#
public float VertResolution;
Property value

A vertical resolution in pixels per inch of image.

Collapse Expand Remarks

Vertical resolution equal to zero means that it is not applicable for the image.


NImage.Width Property

NImage.Width Property
NImage Class Neurotec.Images Namespace

Gets width of image from NImage object.

C#
public uint Width;
Property value

A width of image.


NImageFormat Class

NImageFormat Class
NImageFormat Classes NObject Delegates NObject Events NObject Fields Legend Members NDisposable Methods NDisposable Properties

Provides functionality for loading and saving images in format-neutral style.

C#
public sealed class NImageFormat : NObject;
Collapse Expand NImageFormat Classes
NImageFormat Class
Name | Description
ImageFormatCollection | Represents the collection of formats in a NImageFormat.
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NImageFormat Class
Name | Description
CreateInfo | Creates image info object for the specified image.
OpenReader | Opens an image reader from a specified buffer.
OpenWriter | Opens an image writer.
Select | Retrieves supported image format registered with file extension of specified file name and supporting reading/writing as specified.
SelectByInternetMediaType | Retrieves supported image format by specified internet media type and supporting specified file access.
SelectReader | Retrieves an image reader from a specified buffer.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NImageFormat Class
Name | Description
Bmp | Specifies the BMP image format.
CanRead | Gets a value indicating whether the current image format supports reading.
CanWrite | Gets a value indicating whether the current image format supports writing.
CanWriteMultiple | Retrieves a value indicating whether the image format supports writing of multiple images.
DefaultFileExtension | Gets default file extension of the current image format.
DefaultInternetMediaType | Gets Default Internet media type of the current image format.
FileFilter | Gets file filter of the current image format.
Formats | Specifies collection of supported image formats.
Gif | Specifies the GIF image format.
IHead | Specifies the NIST IHead image format.
InternetMediaType | Gets Internet media type of the current image format.
Jpeg | Specifies the JPEG image format.
Jpeg2K | Specifies the JPEG2000 image format.
Name | Gets name of the current image format.
NativeType | Defines the native type of the object.
Png | Specifies the PNG image format.
Tiff | Specifies the TIFF image format.
WebP | Specifies the WEBP image format.
Wsq | Specifies the WSQ image format.
Container

File: NImageFormat.cs

Namespace: Neurotec.Images

Module: .NET Reference


NImageFormat.ImageFormatCollection Class

NImageFormat.ImageFormatCollection Class

Represents the collection of formats in a NImageFormat.

C#
public sealed class ImageFormatCollection : NObjectReadOnlyCollection<NImageFormat>;
Container

File: NImageFormat.cs

Namespace: Neurotec.Images

Module: .NET Reference


NImageFormat.CreateInfo Method (NImage)

NImageFormat.CreateInfo Method (NImage)
NImageFormat Class Neurotec.Images Namespace

Creates image info object for the specified image.

C#
public NImageInfo CreateInfo(NImage image);
Collapse Expand Parameters
Parameters | Description
NImage image | The specified image.
Collapse Expand Returns

NImageInfo object.


NImageFormat.CreateInfo Method (NImage, uint)

NImageFormat.CreateInfo Method (NImage, uint)
NImageFormat Class Neurotec.Images Namespace

Creates image info object for the specified image.

C#
public NImageInfo CreateInfo(NImage image, uint flags);
Collapse Expand Parameters
Parameters | Description
NImage image | The specified image.
uint flags | Must be zero.
Collapse Expand Returns

NImageInfo object.


NImageFormat.OpenReader Method (NBuffer)

NImageFormat.OpenReader Method (NBuffer)
NImageFormat Class Neurotec.Images Namespace

Opens an image reader from a specified buffer.

C#
public NImageReader OpenReader(NBuffer buffer);
Collapse Expand Parameters
Parameters | Description
NBuffer buffer | The buffer containing the reader.
Collapse Expand Returns

NImageReader object.


NImageFormat.OpenReader Method (NBuffer, uint)

NImageFormat.OpenReader Method (NBuffer, uint)
NImageFormat Class Neurotec.Images Namespace

Opens an image reader from a specified buffer.

C#
public NImageReader OpenReader(NBuffer buffer, uint flags);
Collapse Expand Parameters
Parameters | Description
NBuffer buffer | The buffer containing the reader.
uint flags | Must be zero.
Collapse Expand Returns

NImageReader object.


NImageFormat.OpenReader Method (NStream)

NImageFormat.OpenReader Method (NStream)
NImageFormat Class Neurotec.Images Namespace

Opens an image reader from a specified stream.

C#
public NImageReader OpenReader(NStream stream);
Collapse Expand Parameters
Parameters | Description
NStream stream | The stream containing the reader.
Collapse Expand Returns

NImageReader object.


NImageFormat.OpenReader Method (NStream, uint)

NImageFormat.OpenReader Method (NStream, uint)
NImageFormat Class Neurotec.Images Namespace

Opens an image reader from a specified stream.

C#
public NImageReader OpenReader(NStream stream, uint flags);
Collapse Expand Parameters
Parameters | Description
NStream stream | The stream containing the reader.
uint flags | Must be zero.
Collapse Expand Returns

NImageReader object.


NImageFormat.OpenReader Method (string)

NImageFormat.OpenReader Method (string)
NImageFormat Class Neurotec.Images Namespace

Opens an image reader from a specified file.

C#
public NImageReader OpenReader(string fileName);
Collapse Expand Parameters
Parameters | Description
string fileName | Name of the file.
Collapse Expand Returns

NImageReader object.


NImageFormat.OpenReader Method (string, uint)

NImageFormat.OpenReader Method (string, uint)
NImageFormat Class Neurotec.Images Namespace

Opens an image reader from a specified file.

C#
public NImageReader OpenReader(string fileName, uint flags);
Collapse Expand Parameters
Parameters | Description
string fileName | Name of the file.
uint flags | Must be zero.
Collapse Expand Returns

NImageReader object.


NImageFormat.OpenWriter Method ()

NImageFormat.OpenWriter Method ()
NImageFormat Class Neurotec.Images Namespace

Opens an image writer.

C#
public NImageWriter OpenWriter();
Collapse Expand Returns

NImageWriter object.


NImageFormat.OpenWriter Method (NStream)

NImageFormat.OpenWriter Method (NStream)
NImageFormat Class Neurotec.Images Namespace

Opens an image writer to a specified stream.

C#
public NImageWriter OpenWriter(NStream stream);
Collapse Expand Parameters
Parameters | Description
NStream stream | The stream.
Collapse Expand Returns

NImageWriter object.


NImageFormat.OpenWriter Method (NStream, uint)

NImageFormat.OpenWriter Method (NStream, uint)
NImageFormat Class Neurotec.Images Namespace

Opens an image writer to a specified stream.

C#
public NImageWriter OpenWriter(NStream stream, uint flags);
Collapse Expand Parameters
Parameters | Description
NStream stream | The stream.
uint flags | Must be zero.
Collapse Expand Returns

NImageWriter object.


NImageFormat.OpenWriter Method (string)

NImageFormat.OpenWriter Method (string)
NImageFormat Class Neurotec.Images Namespace

Opens an image writer to a specified file.

C#
public NImageWriter OpenWriter(string fileName);
Collapse Expand Parameters
Parameters | Description
string fileName | The name of the file.
Collapse Expand Returns

NImageWriter object.


NImageFormat.OpenWriter Method (string, uint)

NImageFormat.OpenWriter Method (string, uint)
NImageFormat Class Neurotec.Images Namespace

Opens an image writer to a specified file.

C#
public NImageWriter OpenWriter(string fileName, uint flags);
Collapse Expand Parameters
Parameters | Description
string fileName | The name of the file.
uint flags | Must be zero.
Collapse Expand Returns

NImageWriter object.


NImageFormat.OpenWriter Method (uint)

NImageFormat.OpenWriter Method (uint)
NImageFormat Class Neurotec.Images Namespace

Opens an image writer.

C#
public NImageWriter OpenWriter(uint flags);
Collapse Expand Parameters
Parameters | Description
uint flags | Must be zero.
Collapse Expand Returns

NImageWriter object.


NImageFormat.Select Method

NImageFormat.Select Method
NImageFormat Class Neurotec.Images Namespace

Retrieves supported image format registered with file extension of specified file name and supporting reading/writing as specified.

C#
public static NImageFormat Select(string fileName, FileAccess fileAccess);
Collapse Expand Parameters
Parameters | Description
string fileName | A string that contains the name of the file.
FileAccess fileAccess | A file access.
Collapse Expand Returns

A NImageFormat object.


NImageFormat.SelectByInternetMediaType Method

NImageFormat.SelectByInternetMediaType Method
NImageFormat Class Neurotec.Images Namespace

Retrieves supported image format by specified internet media type and supporting specified file access.

C#
public static NImageFormat SelectByInternetMediaType(string internetMediaType, FileAccess fileAccess);
Collapse Expand Parameters
Parameters | Description
string internetMediaType | A string that contains the internet media type.
FileAccess fileAccess | A file access.
Collapse Expand Returns

A NImageFormat object.


NImageFormat.SelectReader Method (NBuffer)

NImageFormat.SelectReader Method (NBuffer)
NImageFormat Class Neurotec.Images Namespace

Retrieves an image reader from a specified buffer.

C#
public static NImageReader SelectReader(NBuffer buffer);
Collapse Expand Parameters
Parameters | Description
NBuffer buffer | The buffer containing the reader.
Collapse Expand Returns

NImageReader object.


NImageFormat.SelectReader Method (NBuffer, uint)

NImageFormat.SelectReader Method (NBuffer, uint)
NImageFormat Class Neurotec.Images Namespace

Retrieves an image reader from a specified buffer.

C#
public static NImageReader SelectReader(NBuffer buffer, uint flags);
Collapse Expand Parameters
Parameters | Description
NBuffer buffer | The buffer containing the reader.
uint flags | Must be zero.
Collapse Expand Returns

NImageReader object.


NImageFormat.SelectReader Method (NStream)

NImageFormat.SelectReader Method (NStream)
NImageFormat Class Neurotec.Images Namespace

Retrieves an image reader from a specified stream.

C#
public static NImageReader SelectReader(NStream stream);
Collapse Expand Parameters
Parameters | Description
NStream stream | The stream containing the reader.
Collapse Expand Returns

NImageReader object.


NImageFormat.SelectReader Method (NStream, uint)

NImageFormat.SelectReader Method (NStream, uint)
NImageFormat Class Neurotec.Images Namespace

Retrieves an image reader from a specified stream.

C#
public static NImageReader SelectReader(NStream stream, uint flags);
Collapse Expand Parameters
Parameters | Description
NStream stream | The stream containing the reader.
uint flags | Must be zero.
Collapse Expand Returns

NImageReader object.


NImageFormat.SelectReader Method (string)

NImageFormat.SelectReader Method (string)
NImageFormat Class Neurotec.Images Namespace

Retrieves an image reader from a specified file.

C#
public static NImageReader SelectReader(string fileName);
Collapse Expand Parameters
Parameters | Description
string fileName | Name of the file.
Collapse Expand Returns

NImageReader object.


NImageFormat.SelectReader Method (string, uint)

NImageFormat.SelectReader Method (string, uint)
NImageFormat Class Neurotec.Images Namespace

Retrieves an image reader from a specified file.

C#
public static NImageReader SelectReader(string fileName, uint flags);
Collapse Expand Parameters
Parameters | Description
string fileName | Name of the file.
uint flags | Must be zero.
Collapse Expand Returns

NImageReader object.


NImageFormat.Bmp Property

NImageFormat.Bmp Property
NImageFormat Class Neurotec.Images Namespace

Specifies the BMP image format.

C#
public static NImageFormat Bmp;


NImageFormat.CanRead Property

NImageFormat.CanRead Property
NImageFormat Class Neurotec.Images Namespace

Gets a value indicating whether the current image format supports reading.

C#
public bool CanRead;
Property value

true if image format can read, false if image format cannot read.


NImageFormat.CanWrite Property

NImageFormat.CanWrite Property
NImageFormat Class Neurotec.Images Namespace

Gets a value indicating whether the current image format supports writing.

C#
public bool CanWrite;
Property value

true if image format can write, false if image format cannot write.


NImageFormat.CanWriteMultiple Property

NImageFormat.CanWriteMultiple Property
NImageFormat Class Neurotec.Images Namespace

Retrieves a value indicating whether the image format supports writing of multiple images.

C#
public bool CanWriteMultiple;
Property value

true if image format can write, false if image format cannot write.


NImageFormat.DefaultFileExtension Property

NImageFormat.DefaultFileExtension Property
NImageFormat Class Neurotec.Images Namespace

Gets default file extension of the current image format.

C#
public string DefaultFileExtension;
Property value

Default file extension.


NImageFormat.DefaultInternetMediaType Property

NImageFormat.DefaultInternetMediaType Property
NImageFormat Class Neurotec.Images Namespace

Gets Default Internet media type of the current image format.

C#
public string DefaultInternetMediaType;
Property value

An image format default Internet media type.


NImageFormat.FileFilter Property

NImageFormat.FileFilter Property
NImageFormat Class Neurotec.Images Namespace

Gets file filter of the current image format.

C#
public string FileFilter;
Property value

An image format file filter.


NImageFormat.Formats Property

NImageFormat.Formats Property
NImageFormat Class Neurotec.Images Namespace

Specifies collection of supported image formats.

C#
public static ImageFormatCollection Formats;


NImageFormat.Gif Property

NImageFormat.Gif Property
NImageFormat Class Neurotec.Images Namespace

Specifies the GIF image format.

C#
public static NImageFormat Gif;


NImageFormat.IHead Property

NImageFormat.IHead Property
NImageFormat Class Neurotec.Images Namespace

Specifies the NIST IHead image format.

C#
public static NImageFormat IHead;


NImageFormat.InternetMediaType Property

NImageFormat.InternetMediaType Property
NImageFormat Class Neurotec.Images Namespace

Gets Internet media type of the current image format.

C#
public string InternetMediaType;
Property value

An image format Internet media type.


NImageFormat.Jpeg Property

NImageFormat.Jpeg Property
NImageFormat Class Neurotec.Images Namespace

Specifies the JPEG image format.

C#
public static NImageFormat Jpeg;


NImageFormat.Jpeg2K Property

NImageFormat.Jpeg2K Property
NImageFormat Class Neurotec.Images Namespace

Specifies the JPEG2000 image format.

C#
public static NImageFormat Jpeg2K;


NImageFormat.Name Property

NImageFormat.Name Property
NImageFormat Class Neurotec.Images Namespace

Gets name of the current image format.

C#
public string Name;
Property value

An image format name.


NImageFormat.NativeType Property

NImageFormat.NativeType Property
NImageFormat Class Neurotec.Images Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NImageFormat.Png Property

NImageFormat.Png Property
NImageFormat Class Neurotec.Images Namespace

Specifies the PNG image format.

C#
public static NImageFormat Png;


NImageFormat.Tiff Property

NImageFormat.Tiff Property
NImageFormat Class Neurotec.Images Namespace

Specifies the TIFF image format.

C#
public static NImageFormat Tiff;


NImageFormat.WebP Property

NImageFormat.WebP Property
NImageFormat Class Neurotec.Images Namespace

Specifies the WEBP image format.

C#
public static NImageFormat WebP;


NImageFormat.Wsq Property

NImageFormat.Wsq Property
NImageFormat Class Neurotec.Images Namespace

Specifies the WSQ image format.

C#
public static NImageFormat Wsq;


NImageInfo Class

NImageInfo Class
NObject Delegates NObject Events NObject Fields Legend Members Methods NDisposable Methods NDisposable Properties

Retrieves the object information.

C#
public class NImageInfo : NExpandableObject;
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NExpandableObject Class
Show:
No members matching the current filter
Name | Description
NativeType | Defines the native type of the object.
Properties | Gets the property bag of the expandable object.
NImageInfo Class
Name | Description
Format | Gets or sets the image format.
Height | Gets image height.
NImageRotateFlipTypeNativeType | Defines the native type of the image rotation.
NativeType | Defines the native type of the object.
Transform | Gets or sets the transformation of the image.
Width | Gets image height.
Container

File: NImageInfo.cs

Namespace: Neurotec.Images

Module: .NET Reference


NImageInfo.NImageInfo Constructor

NImageInfo.NImageInfo Constructor
NImageInfo Class Neurotec.Images Namespace

Creates a new instance of NImageInfo class.

C#
public NImageInfo();


NImageInfo.Format Property

NImageInfo.Format Property
NImageInfo Class Neurotec.Images Namespace

Gets or sets the image format.

C#
public NImageFormat Format;
Property value

The image format.


NImageInfo.Height Property

NImageInfo.Height Property
NImageInfo Class Neurotec.Images Namespace

Gets image height.

C#
public uint Height;
Property value

Image height.


NImageInfo.NImageRotateFlipTypeNativeType Property

NImageInfo.NImageRotateFlipTypeNativeType Property
NImageInfo Class Neurotec.Images Namespace

Defines the native type of the image rotation.

C#
public static NType NImageRotateFlipTypeNativeType;


NImageInfo.NativeType Property

NImageInfo.NativeType Property
NImageInfo Class Neurotec.Images Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NImageInfo.Transform Property

NImageInfo.Transform Property
NImageInfo Class Neurotec.Images Namespace

Gets or sets the transformation of the image.

C#
public NImageRotateFlipType Transform;
Property value

Image transformation value.


NImageInfo.Width Property

NImageInfo.Width Property
NImageInfo Class Neurotec.Images Namespace

Gets image height.

C#
public uint Width;
Property value

Image width.


NImageReader Class

NImageReader Class
NObject Delegates NObject Events NObject Fields Legend Members NDisposable Methods NDisposable Properties

Provides methods which can be used to read image data.

C#
public sealed class NImageReader : NObject;
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NImageReader Class
Name | Description
Read | Reads an image.
ReadInfo | Retrieves image info.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NImageReader Class
Name | Description
Format | Gets or sets the image format.
NativeType | Defines the native type of the object.
ReadSize | Gets or sets the size of read image info.
Container

File: NImageReader.cs

Namespace: Neurotec.Images

Module: .NET Reference


NImageReader.Read Method ()

NImageReader.Read Method ()
NImageReader Class Neurotec.Images Namespace

Reads an image.

C#
public NImage Read();
Collapse Expand Returns

NImage object.


NImageReader.Read Method (uint)

NImageReader.Read Method (uint)
NImageReader Class Neurotec.Images Namespace

Reads an image.

C#
public NImage Read(uint flags);
Collapse Expand Parameters
Parameters | Description
uint flags | [in] Must be zero.
Collapse Expand Returns

NImage object.


NImageReader.ReadInfo Method ()

NImageReader.ReadInfo Method ()
NImageReader Class Neurotec.Images Namespace

Retrieves image info.

C#
public NImageInfo ReadInfo();
Collapse Expand Returns

NImageInfo object.


NImageReader.ReadInfo Method (uint)

NImageReader.ReadInfo Method (uint)
NImageReader Class Neurotec.Images Namespace

Retrieves image info.

C#
public NImageInfo ReadInfo(uint flags);
Collapse Expand Parameters
Parameters | Description
uint flags | [in] Must be zero.
Collapse Expand Returns

NImageInfo object.


NImageReader.Format Property

NImageReader.Format Property
NImageReader Class Neurotec.Images Namespace

Gets or sets the image format.

C#
public NImageFormat Format;
Property value

The image format.


NImageReader.NativeType Property

NImageReader.NativeType Property
NImageReader Class Neurotec.Images Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NImageReader.ReadSize Property

NImageReader.ReadSize Property
NImageReader Class Neurotec.Images Namespace

Gets or sets the size of read image info.

C#
public int ReadSize;
Property value

The size of read image info.


NImageWriter Class

NImageWriter Class
NObject Delegates NObject Events NObject Fields Legend Members NDisposable Methods NDisposable Properties

Provides methods which can be used to write image data.

C#
public sealed class NImageWriter : NObject;
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NImageWriter Class
Name | Description
GetBuffer | Gets a memory buffer to write data from.
Write | Writes data into a specified image.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NImageWriter Class
Name | Description
Format | Gets or sets the image format.
NativeType | Defines the native type of the object.
Container

File: NImageWriter.cs

Namespace: Neurotec.Images

Module: .NET Reference


NImageWriter.GetBuffer Method

NImageWriter.GetBuffer Method
NImageWriter Class Neurotec.Images Namespace

Gets a memory buffer to write data from.

C#
public NBuffer GetBuffer();
Collapse Expand Returns

ByteBuffer object.


NImageWriter.Write Method

NImageWriter.Write Method
NImageWriter Class Neurotec.Images Namespace

Writes data into a specified image.

C#
public void Write(NImage image, NImageInfo info, uint flags);
Collapse Expand Parameters
Parameters | Description
NImage image | The specified image.
NImageInfo info | The image info.
uint flags | Must be zero.


NImageWriter.Format Property

NImageWriter.Format Property
NImageWriter Class Neurotec.Images Namespace

Gets or sets the image format.

C#
public NImageFormat Format;
Property value

NImageFormat object.


NImageWriter.NativeType Property

NImageWriter.NativeType Property
NImageWriter Class Neurotec.Images Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NImages Class

NImages Class
Legend Members NImages Methods NImages Properties

Provides library registration and other additional functionality.

C#
public static class NImages;
Collapse Expand NImages Methods
Name | Description
GetGrayscaleColorWrapper | Creates NImage object wrapper.
GetOpenFileFilter | Gets a list with names of all NImageFormats, which support reading. Names in the list are separated by semicolon.
GetOpenFileFilterString | Gets a list with names of all NImageFormats, which support reading. Names in the list are separated by semicolon.
GetSaveFileFilter | Gets a list with names of all NImageFormats, which support writing. Names in the list are separated by semicolon.
GetSaveFileFilterString | Gets a list with names of all NImageFormats, which support writing. Names in the list are separated by semicolon.
RecolorImage | Recolors the specified image.
Collapse Expand NImages Properties
Name | Description
NativeType | Defines the native type of the object.
Container

File: NImages.cs

Namespace: Neurotec.Images

Module: .NET Reference


NImages.GetGrayscaleColorWrapper Method

NImages.GetGrayscaleColorWrapper Method
NImages Class Neurotec.Images Namespace

Creates NImage object wrapper.

C#
public static NImage GetGrayscaleColorWrapper(NImage image, NRgb minColor, NRgb maxColor);
Collapse Expand Parameters
Parameters | Description
NImage image | A NImage object.
NRgb minColor | Specifies color to be used for black color.
NRgb maxColor | Specifies color to be used for white color.
Collapse Expand Returns

An NImage object.

Collapse Expand Remarks

Gray values in source image are replaced with according RGB values from range [minColor, maxColor] in created image.


NImages.GetOpenFileFilter Method

NImages.GetOpenFileFilter Method
NImages Class Neurotec.Images Namespace

Gets a list with names of all NImageFormats, which support reading. Names in the list are separated by semicolon.

C#
public static string GetOpenFileFilter();
Collapse Expand Returns

String with NImageFormat names separated by semicolon.


NImages.GetOpenFileFilterString Method

NImages.GetOpenFileFilterString Method
NImages Class Neurotec.Images Namespace

Gets a list with names of all NImageFormats, which support reading. Names in the list are separated by semicolon.

C#
public static string GetOpenFileFilterString(bool addAllImage, bool addAllFiles);
Collapse Expand Parameters
Parameters | Description
bool addAllImage | Boolean indicating whether to add "All image files" to the list.
bool addAllFiles | Boolean indicating whether to add "All files" to the list.
Collapse Expand Returns

String with NImageFormat names separated by semicolon.


NImages.GetSaveFileFilter Method

NImages.GetSaveFileFilter Method
NImages Class Neurotec.Images Namespace

Gets a list with names of all NImageFormats, which support writing. Names in the list are separated by semicolon.

C#
public static string GetSaveFileFilter();
Collapse Expand Returns

String with NImageFormat names separated by semicolon.


NImages.GetSaveFileFilterString Method

NImages.GetSaveFileFilterString Method
NImages Class Neurotec.Images Namespace

Gets a list with names of all NImageFormats, which support writing. Names in the list are separated by semicolon.

C#
public static string GetSaveFileFilterString();
Collapse Expand Returns

String with NImageFormat names separated by semicolon.


NImages.RecolorImage Method

NImages.RecolorImage Method
NImages Class Neurotec.Images Namespace

Recolors the specified image.

C#
public static NImage RecolorImage(NImage image, NPixelFormat pixelFormat, Array minValue, Array maxValue);
Collapse Expand Parameters
Parameters | Description
NImage image | The image to be recolored.
NPixelFormat pixelFormat | Image pixel format.
Array minValue | Minimum pixel value in the image.
Array maxValue | Maximum pixel value in the image.
Collapse Expand Returns

The recolored image.


NImages.NativeType Property

NImages.NativeType Property
NImages Class Neurotec.Images Namespace

Defines the native type of the object.

C#
public static NType NativeType;


NPixelFormat Structure

NPixelFormat Structure
NPixelFormat Fields Legend Members Methods NPixelFormat Methods NPixelFormat Operators NPixelFormat Properties

Provides functionality for working with pixel format.

C#
[Serializable]
[StructLayout(LayoutKind.Sequential)]
public struct NPixelFormat : INSampleFormat, IEquatable<NPixelFormat> {
  public static readonly NPixelFormat Undefined = (NPixelFormat)0;
  public static readonly NPixelFormat Grayscale1U = (NPixelFormat)0x00001001;
  public static readonly NPixelFormat Grayscale2U = (NPixelFormat)0x00101001;
  public static readonly NPixelFormat Grayscale4U = (NPixelFormat)0x00201001;
  public static readonly NPixelFormat Grayscale8U = (NPixelFormat)0x00301001;
  public static readonly NPixelFormat Grayscale8S = (NPixelFormat)0x00311001;
  public static readonly NPixelFormat GrayscaleA8U = (NPixelFormat)0x00302101;
  public static readonly NPixelFormat GrayscaleA8S = (NPixelFormat)0x00312101;
  public static readonly NPixelFormat GrayscalePA8U = (NPixelFormat)0x00302201;
  public static readonly NPixelFormat GrayscalePA8S = (NPixelFormat)0x00312201;
  public static readonly NPixelFormat Grayscale16U = (NPixelFormat)0x00401001;
  public static readonly NPixelFormat Grayscale16S = (NPixelFormat)0x00411001;
  public static readonly NPixelFormat GrayscaleA16U = (NPixelFormat)0x00402101;
  public static readonly NPixelFormat GrayscaleA16S = (NPixelFormat)0x00412101;
  public static readonly NPixelFormat GrayscalePA16U = (NPixelFormat)0x00402201;
  public static readonly NPixelFormat GrayscalePA16S = (NPixelFormat)0x00412201;
  public static readonly NPixelFormat Grayscale32U = (NPixelFormat)0x00501001;
  public static readonly NPixelFormat Grayscale32S = (NPixelFormat)0x00511001;
  public static readonly NPixelFormat GrayscaleA32U = (NPixelFormat)0x00502101;
  public static readonly NPixelFormat GrayscaleA32S = (NPixelFormat)0x00512101;
  public static readonly NPixelFormat GrayscalePA32U = (NPixelFormat)0x00502201;
  public static readonly NPixelFormat GrayscalePA32S = (NPixelFormat)0x00512201;
  public static readonly NPixelFormat Grayscale64U = (NPixelFormat)0x00601001;
  public static readonly NPixelFormat Grayscale64S = (NPixelFormat)0x00611001;
  public static readonly NPixelFormat GrayscaleA64U = (NPixelFormat)0x00602101;
  public static readonly NPixelFormat GrayscaleA64S = (NPixelFormat)0x00612101;
  public static readonly NPixelFormat GrayscalePA64U = (NPixelFormat)0x00602201;
  public static readonly NPixelFormat GrayscalePA64S = (NPixelFormat)0x00612201;
  public static readonly NPixelFormat Grayscale32F = (NPixelFormat)0x00521001;
  public static readonly NPixelFormat GrayscaleA32F = (NPixelFormat)0x00522101;
  public static readonly NPixelFormat GrayscalePA32F = (NPixelFormat)0x00522201;
  public static readonly NPixelFormat Grayscale64F = (NPixelFormat)0x00621001;
  public static readonly NPixelFormat GrayscaleA64F = (NPixelFormat)0x00622101;
  public static readonly NPixelFormat GrayscalePA64F = (NPixelFormat)0x00622201;
  public static readonly NPixelFormat Rgb8U = (NPixelFormat)0x00303003;
  public static readonly NPixelFormat Rgb8S = (NPixelFormat)0x00313003;
  public static readonly NPixelFormat RgbA8U = (NPixelFormat)0x00304103;
  public static readonly NPixelFormat RgbA8S = (NPixelFormat)0x00314103;
  public static readonly NPixelFormat RgbPA8U = (NPixelFormat)0x00304203;
  public static readonly NPixelFormat RgbPA8S = (NPixelFormat)0x00314203;
  public static readonly NPixelFormat Rgb16U = (NPixelFormat)0x00403003;
  public static readonly NPixelFormat Rgb16S = (NPixelFormat)0x00413003;
  public static readonly NPixelFormat RgbA16U = (NPixelFormat)0x00404103;
  public static readonly NPixelFormat RgbA16S = (NPixelFormat)0x00414103;
  public static readonly NPixelFormat RgbPA16U = (NPixelFormat)0x00404203;
  public static readonly NPixelFormat RgbPA16S = (NPixelFormat)0x00414203;
  public static readonly NPixelFormat Rgb32U = (NPixelFormat)0x00503003;
  public static readonly NPixelFormat Rgb32S = (NPixelFormat)0x00513003;
  public static readonly NPixelFormat RgbA32U = (NPixelFormat)0x00504103;
  public static readonly NPixelFormat RgbA32S = (NPixelFormat)0x00514103;
  public static readonly NPixelFormat RgbPA32U = (NPixelFormat)0x00504203;
  public static readonly NPixelFormat RgbPA32S = (NPixelFormat)0x00514203;
  public static readonly NPixelFormat Rgb64U = (NPixelFormat)0x00603003;
  public static readonly NPixelFormat Rgb64S = (NPixelFormat)0x00613003;
  public static readonly NPixelFormat RgbA64U = (NPixelFormat)0x00604103;
  public static readonly NPixelFormat RgbA64S = (NPixelFormat)0x00614103;
  public static readonly NPixelFormat RgbPA64U = (NPixelFormat)0x00604203;
  public static readonly NPixelFormat RgbPA64S = (NPixelFormat)0x00614203;
  public static readonly NPixelFormat Rgb32F = (NPixelFormat)0x00523003;
  public static readonly NPixelFormat RgbA32F = (NPixelFormat)0x00524103;
  public static readonly NPixelFormat RgbPA32F = (NPixelFormat)0x00524203;
  public static readonly NPixelFormat Rgb64F = (NPixelFormat)0x00623003;
  public static readonly NPixelFormat RgbA64F = (NPixelFormat)0x00624103;
  public static readonly NPixelFormat RgbPA64F = (NPixelFormat)0x00624203;
  public static readonly NPixelFormat Rgb8UIndexed1 = (NPixelFormat)0x01303003;
  public static readonly NPixelFormat Rgb8UIndexed2 = (NPixelFormat)0x02303003;
  public static readonly NPixelFormat Rgb8UIndexed4 = (NPixelFormat)0x03303003;
  public static readonly NPixelFormat Rgb8UIndexed8 = (NPixelFormat)0x04303003;
  public static readonly NPixelFormat RgbA8UIndexed1 = (NPixelFormat)0x01304103;
  public static readonly NPixelFormat RgbA8UIndexed2 = (NPixelFormat)0x02304103;
  public static readonly NPixelFormat RgbA8UIndexed4 = (NPixelFormat)0x03304103;
  public static readonly NPixelFormat RgbA8UIndexed8 = (NPixelFormat)0x04304103;
}
Collapse Expand Remarks

Image pixel format is not limited to these fields. However only these fields are provided for usage with this SDK.

Collapse Expand NPixelFormat Fields
Name | Description
Grayscale16S | ... more
Grayscale16U | ... more
Grayscale1U | ... more
Grayscale2U | ... more
Grayscale32F | ... more
Grayscale32S | ... more
Grayscale32U | ... more
Grayscale4U | ... more
Grayscale64F | ... more
Grayscale64S | ... more
Grayscale64U | ... more
Grayscale8S | ... more
Grayscale8U | ... more
GrayscaleA16S | ... more
GrayscaleA16U | ... more
GrayscaleA32F | ... more
GrayscaleA32S | ... more
GrayscaleA32U | ... more
GrayscaleA64F | ... more
GrayscaleA64S | ... more
GrayscaleA64U | ... more
GrayscaleA8S | ... more
GrayscaleA8U | ... more
GrayscalePA16S | ... more
GrayscalePA16U | ... more
GrayscalePA32F | ... more
GrayscalePA32S | ... more
GrayscalePA32U | ... more
GrayscalePA64F | ... more
GrayscalePA64S | ... more
GrayscalePA64U | ... more
GrayscalePA8S | ... more
GrayscalePA8U | ... more
Rgb16S | ... more
Rgb16U | ... more
Rgb32F | ... more
Rgb32S | ... more
Rgb32U | ... more
Rgb64F | ... more
Rgb64S | ... more
Rgb64U | ... more
Rgb8S | ... more
Rgb8U | ... more
Rgb8UIndexed1 | ... more
Rgb8UIndexed2 | ... more
Rgb8UIndexed4 | ... more
Rgb8UIndexed8 | ... more
RgbA16S | ... more
RgbA16U | ... more
RgbA32F | ... more
RgbA32S | ... more
RgbA32U | ... more
RgbA64F | ... more
RgbA64S | ... more
RgbA64U | ... more
RgbA8S | ... more
RgbA8U | ... more
RgbA8UIndexed1 | ... more
RgbA8UIndexed2 | ... more
RgbA8UIndexed4 | ... more
RgbA8UIndexed8 | ... more
RgbPA16S | ... more
RgbPA16U | ... more
RgbPA32F | ... more
RgbPA32S | ... more
RgbPA32U | ... more
RgbPA64F | ... more
RgbPA64S | ... more
RgbPA64U | ... more
RgbPA8S | ... more
RgbPA8U | ... more
Undefined | Indicates undefined pixel format.
Collapse Expand NPixelFormat Methods
Name | Description
CalcRowLongSize | Calculates number of bytes needed to store line of specified length of pixels with specified bits per pixel.
CalcRowNativeSize | Calculates number of bytes needed to store line of specified length of pixels with specified bits per pixel.
CalcRowSize | Calculates number of bytes needed to store line of specified length of pixels with specified bits per pixel.
CanPixelTypeBeIndexed | Checks whether the specified pixel type can be indexed.
Equals | Checks whether the current pixel format equals the other pixel format.
GetChannelType | Retrieves the current channel type.
GetHashCode | Gets the hash code. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetIndexed | Retrieves an indexed version of the NPixelFormat.
GetNonIndexed | Retrieves a non-indexed version of the NPixelFormat.
GetNonSeparated | Retrieves a non-separated version of the NPixelFormat.
GetPaletteSize | Retrieves the palette size.
GetRowLongSize | Calculates number of bytes needed to store line of specified length of pixels with specified NPixelFormat.
GetRowNativeSize | Calculates number of bytes needed to store line of specified length of pixels with specified NPixelFormat and alignment.
GetRowSize | Calculates number of bytes needed to store line of specified length of pixels with specified NPixelFormat.
GetSeparated | Retrieves a separated version of the NPixelFormat.
GetWithExtraChannel | Retrieves a version of the NPixelFormat with an extra channel.
IsPixelTypeValid | Checks whether current NPixelType value is valid.
ToString | Retrieves string representation of NPixelFormat object.
Collapse Expand NPixelFormat Operators
Name | Description
!= | Checks if two pixelFormats are not equal.
== | Checks if two pixelFormats are equal.
NPixelFormat | This conversion operator converts from a uint type to a NPixelFormat type
uint | Gets value field of NPixelFormat object.
Collapse Expand NPixelFormat Properties
Name | Description
BitsPerChannel | Gets or sets the number of bits per channel.
BitsPerIndex | Gets or sets the number of bits per index.
BitsPerPaletteEntry | Gets or sets the number of bits per palette entry.
BitsPerPixel | Each pixel value is stored in 24 bits consisting of three 8-bit values representing red, green and blue color components.
BitsPerValue | Gets or sets the number of bits per value.
BytesPerChannel | Gets or sets the number of bytes per channel.
BytesPerPaletteEntry | Gets or sets the number of bytes per palette entry.
BytesPerPixel | Gets or sets the number of bytes per pixel.
BytesPerValue | Gets or sets the number of bytes per value.
ChannelCount | Gets or sets the number of channels.
ChannelFormat | Gets or sets the format of the channel.
ExtraChannel | Gets or sets the extra channel.
IsIndexed | Checks whether current NPixelFormat value is indexed.
IsSeparated | Checks whether current NPixelFormat value is separated.
IsValid | Checks whether current NPixelFormat value is valid.
MaxPaletteLength | Gets or sets the maximum palette length.
NPixelTypeNativeType | Defines the native type of the pixel type.
NativeType | Defines the native type of the object.
PixelType | Gets or sets the type of the pixel.
PlaneCount | Gets or sets the number of the planes.
Container

File: NPixelFormat.cs

Namespace: Neurotec.Images

Module: .NET Reference


NPixelFormat.NPixelFormat Constructor (NPixelType, NExtraChannel, int, NChannelFormat, int, int, bool)

NPixelFormat.NPixelFormat Constructor (NPixelType, NExtraChannel, int, NChannelFormat, int, int, bool)
NPixelFormat Structure Neurotec.Images Namespace

Initializes a new instance of NPixelFormat class.

C#
public NPixelFormat(NPixelType pixelType, NExtraChannel extraChannel, int channelCount, NChannelFormat channelFormat, int bitsPerChannel, int bitsPerIndex, bool isSeparated);
Collapse Expand Parameters
Parameters | Description
NPixelType pixelType | Type of pixels.
NExtraChannel extraChannel | The extra channel.
int channelCount | The number of channels.
NChannelFormat channelFormat | Format of the channel.
int bitsPerChannel | Number of bits per channel.
int bitsPerIndex | Number of bits per index.
bool isSeparated | true if separated; else false.


NPixelFormat.NPixelFormat Constructor (uint)

NPixelFormat.NPixelFormat Constructor (uint)
NPixelFormat Structure Neurotec.Images Namespace

Initializes a new instance of NPixelFormat class.

C#
public NPixelFormat(uint value);
Collapse Expand Parameters
Parameters | Description
uint value | The pixel format.


NPixelFormat.Grayscale16S Field

NPixelFormat.Grayscale16S Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies grayscale image pixel format where each pixel is represented by 16 bits per channel (channel format - signed integer).

C#
public static readonly NPixelFormat Grayscale16S = (NPixelFormat)0x00411001;


NPixelFormat.Grayscale16U Field

NPixelFormat.Grayscale16U Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies grayscale image pixel format where each pixel is represented by 16 bits per channel (channel format - unsigned integer).

C#
public static readonly NPixelFormat Grayscale16U = (NPixelFormat)0x00401001;


NPixelFormat.Grayscale1U Field

NPixelFormat.Grayscale1U Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies grayscale image pixel format where each pixel is represented by 1 bit per channel (channel format - unsigned integer).

C#
public static readonly NPixelFormat Grayscale1U = (NPixelFormat)0x00001001;


NPixelFormat.Grayscale2U Field

NPixelFormat.Grayscale2U Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies grayscale image pixel format where each pixel is represented by 2 bits per channel (channel format - unsigned integer).

C#
public static readonly NPixelFormat Grayscale2U = (NPixelFormat)0x00101001;


NPixelFormat.Grayscale32F Field

NPixelFormat.Grayscale32F Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies grayscale image pixel format where each pixel is represented by 16 bits per channel (channel format - floating point).

C#
public static readonly NPixelFormat Grayscale32F = (NPixelFormat)0x00521001;


NPixelFormat.Grayscale32S Field

NPixelFormat.Grayscale32S Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies grayscale image pixel format where each pixel is represented by 32 bits per channel (channel format - signed integer).

C#
public static readonly NPixelFormat Grayscale32S = (NPixelFormat)0x00511001;


NPixelFormat.Grayscale32U Field

NPixelFormat.Grayscale32U Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies grayscale image pixel format where each pixel is represented by 32 bits per channel (channel format - unsigned integer).

C#
public static readonly NPixelFormat Grayscale32U = (NPixelFormat)0x00501001;


NPixelFormat.Grayscale4U Field

NPixelFormat.Grayscale4U Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies grayscale image pixel format where each pixel is represented by 4 bits per channel (channel format - unsigned integer).

C#
public static readonly NPixelFormat Grayscale4U = (NPixelFormat)0x00201001;


NPixelFormat.Grayscale64F Field

NPixelFormat.Grayscale64F Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies grayscale image pixel format where each pixel is represented by 64 bits per channel (channel format - floating point).

C#
public static readonly NPixelFormat Grayscale64F = (NPixelFormat)0x00621001;


NPixelFormat.Grayscale64S Field

NPixelFormat.Grayscale64S Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies grayscale image pixel format where each pixel is represented by 64 bits per channel (channel format - signed integer).

C#
public static readonly NPixelFormat Grayscale64S = (NPixelFormat)0x00611001;


NPixelFormat.Grayscale64U Field

NPixelFormat.Grayscale64U Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies grayscale image pixel format where each pixel is represented by 64 bits per channel (channel format - unsigned integer).

C#
public static readonly NPixelFormat Grayscale64U = (NPixelFormat)0x00601001;


NPixelFormat.Grayscale8S Field

NPixelFormat.Grayscale8S Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies grayscale image pixel format where each pixel is represented by 8 bits per channel (channel format - signed integer).

C#
public static readonly NPixelFormat Grayscale8S = (NPixelFormat)0x00311001;


NPixelFormat.Grayscale8U Field

NPixelFormat.Grayscale8U Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies grayscale image pixel format where each pixel is represented by 8 bits per channel (channel format - unsigned integer).

C#
public static readonly NPixelFormat Grayscale8U = (NPixelFormat)0x00301001;


NPixelFormat.GrayscaleA16S Field

NPixelFormat.GrayscaleA16S Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies grayscale image pixel format where each pixel is represented by 16 bits per alpha channel (channel format - signed integer). Alpha channel specifies pixel transparency.

C#
public static readonly NPixelFormat GrayscaleA16S = (NPixelFormat)0x00412101;


NPixelFormat.GrayscaleA16U Field

NPixelFormat.GrayscaleA16U Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies grayscale image pixel format where each pixel is represented by 16 bits per alpha channel (channel format - unsigned integer). Alpha channel specifies pixel transparency.

C#
public static readonly NPixelFormat GrayscaleA16U = (NPixelFormat)0x00402101;


NPixelFormat.GrayscaleA32F Field

NPixelFormat.GrayscaleA32F Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies grayscale image pixel format where each pixel is represented by 32 bits per alpha channel (channel format - floating point). Alpha channel specifies pixel transparency.

C#
public static readonly NPixelFormat GrayscaleA32F = (NPixelFormat)0x00522101;


NPixelFormat.GrayscaleA32S Field

NPixelFormat.GrayscaleA32S Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies grayscale image pixel format where each pixel is represented by 32 bits per alpha channel (channel format - signed integer). Alpha channel specifies pixel transparency.

C#
public static readonly NPixelFormat GrayscaleA32S = (NPixelFormat)0x00512101;


NPixelFormat.GrayscaleA32U Field

NPixelFormat.GrayscaleA32U Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies grayscale image pixel format where each pixel is represented by 32 bits per alpha channel (channel format - unsigned integer). Alpha channel specifies pixel transparency.

C#
public static readonly NPixelFormat GrayscaleA32U = (NPixelFormat)0x00502101;


NPixelFormat.GrayscaleA64F Field

NPixelFormat.GrayscaleA64F Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies grayscale image pixel format where each pixel is represented by 64 bits per alpha channel (channel format - floating point). Alpha channel specifies pixel transparency.

C#
public static readonly NPixelFormat GrayscaleA64F = (NPixelFormat)0x00622101;


NPixelFormat.GrayscaleA64S Field

NPixelFormat.GrayscaleA64S Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies grayscale image pixel format where each pixel is represented by 64 bits per alpha channel (channel format - signed integer). Alpha channel specifies pixel transparency.

C#
public static readonly NPixelFormat GrayscaleA64S = (NPixelFormat)0x00612101;


NPixelFormat.GrayscaleA64U Field

NPixelFormat.GrayscaleA64U Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies grayscale image pixel format where each pixel is represented by 64 bits per alpha channel (channel format - unsigned integer). Alpha channel specifies pixel transparency.

C#
public static readonly NPixelFormat GrayscaleA64U = (NPixelFormat)0x00602101;


NPixelFormat.GrayscaleA8S Field

NPixelFormat.GrayscaleA8S Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies grayscale image pixel format where each pixel is represented by 8 bits per alpha channel (channel format - signed integer). Alpha channel specifies pixel transparency.

C#
public static readonly NPixelFormat GrayscaleA8S = (NPixelFormat)0x00312101;


NPixelFormat.GrayscaleA8U Field

NPixelFormat.GrayscaleA8U Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies grayscale image pixel format where each pixel is represented by 8 bits per alpha channel (channel format - unsigned integer). Alpha channel specifies pixel transparency.

C#
public static readonly NPixelFormat GrayscaleA8U = (NPixelFormat)0x00302101;


NPixelFormat.GrayscalePA16S Field

NPixelFormat.GrayscalePA16S Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies grayscale image pixel format where each pixel is represented by 16 bits per pre-multiplied alpha channel (channel format - signed integer).

C#
public static readonly NPixelFormat GrayscalePA16S = (NPixelFormat)0x00412201;


NPixelFormat.GrayscalePA16U Field

NPixelFormat.GrayscalePA16U Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies grayscale image pixel format where each pixel is represented by 16 bits per pre-multiplied alpha channel (channel format - unsigned integer).

C#
public static readonly NPixelFormat GrayscalePA16U = (NPixelFormat)0x00402201;


NPixelFormat.GrayscalePA32F Field

NPixelFormat.GrayscalePA32F Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies grayscale image pixel format where each pixel is represented by 32 bits per pre-multiplied alpha channel (channel format - floating point).

C#
public static readonly NPixelFormat GrayscalePA32F = (NPixelFormat)0x00522201;


NPixelFormat.GrayscalePA32S Field

NPixelFormat.GrayscalePA32S Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies grayscale image pixel format where each pixel is represented by 32 bits per pre-multiplied alpha channel (channel format - signed integer).

C#
public static readonly NPixelFormat GrayscalePA32S = (NPixelFormat)0x00512201;


NPixelFormat.GrayscalePA32U Field

NPixelFormat.GrayscalePA32U Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies grayscale image pixel format where each pixel is represented by 32 bits per pre-multiplied alpha channel (channel format - unsigned integer).

C#
public static readonly NPixelFormat GrayscalePA32U = (NPixelFormat)0x00502201;


NPixelFormat.GrayscalePA64F Field

NPixelFormat.GrayscalePA64F Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies grayscale image pixel format where each pixel is represented by 64 bits per pre-multiplied alpha channel (channel format - floating point).

C#
public static readonly NPixelFormat GrayscalePA64F = (NPixelFormat)0x00622201;


NPixelFormat.GrayscalePA64S Field

NPixelFormat.GrayscalePA64S Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies grayscale image pixel format where each pixel is represented by 64 bits per pre-multiplied alpha channel (channel format - signed integer).

C#
public static readonly NPixelFormat GrayscalePA64S = (NPixelFormat)0x00612201;


NPixelFormat.GrayscalePA64U Field

NPixelFormat.GrayscalePA64U Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies grayscale image pixel format where each pixel is represented by 64 bits per pre-multiplied alpha channel (channel format - unsigned integer).

C#
public static readonly NPixelFormat GrayscalePA64U = (NPixelFormat)0x00602201;


NPixelFormat.GrayscalePA8S Field

NPixelFormat.GrayscalePA8S Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies grayscale image pixel format where each pixel is represented by 8 bits per pre-multiplied alpha channel (channel format - signed integer).

C#
public static readonly NPixelFormat GrayscalePA8S = (NPixelFormat)0x00312201;


NPixelFormat.GrayscalePA8U Field

NPixelFormat.GrayscalePA8U Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies grayscale image pixel format where each pixel is represented by 8 bits per pre-multiplied alpha channel (channel format - unsigned integer).

C#
public static readonly NPixelFormat GrayscalePA8U = (NPixelFormat)0x00302201;


NPixelFormat.Rgb16S Field

NPixelFormat.Rgb16S Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 16 bits per channel (channel format - signed integer).

C#
public static readonly NPixelFormat Rgb16S = (NPixelFormat)0x00413003;


NPixelFormat.Rgb16U Field

NPixelFormat.Rgb16U Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 16 bits per channel (channel format - unsigned integer).

C#
public static readonly NPixelFormat Rgb16U = (NPixelFormat)0x00403003;


NPixelFormat.Rgb32F Field

NPixelFormat.Rgb32F Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 32 bits per channel (channel format - floating point).

C#
public static readonly NPixelFormat Rgb32F = (NPixelFormat)0x00523003;


NPixelFormat.Rgb32S Field

NPixelFormat.Rgb32S Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 32 bits per channel (channel format - signed integer).

C#
public static readonly NPixelFormat Rgb32S = (NPixelFormat)0x00513003;


NPixelFormat.Rgb32U Field

NPixelFormat.Rgb32U Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 32 bits per channel (channel format - unsigned integer).

C#
public static readonly NPixelFormat Rgb32U = (NPixelFormat)0x00503003;


NPixelFormat.Rgb64F Field

NPixelFormat.Rgb64F Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 64 bits per channel (channel format - floating point).

C#
public static readonly NPixelFormat Rgb64F = (NPixelFormat)0x00623003;


NPixelFormat.Rgb64S Field

NPixelFormat.Rgb64S Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 64 bits per channel (channel format - signed integer).

C#
public static readonly NPixelFormat Rgb64S = (NPixelFormat)0x00613003;


NPixelFormat.Rgb64U Field

NPixelFormat.Rgb64U Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 64 bits per channel (channel format - unsigned integer).

C#
public static readonly NPixelFormat Rgb64U = (NPixelFormat)0x00603003;


NPixelFormat.Rgb8S Field

NPixelFormat.Rgb8S Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 8 bits per channel (channel format - signed integer).

C#
public static readonly NPixelFormat Rgb8S = (NPixelFormat)0x00313003;


NPixelFormat.Rgb8U Field

NPixelFormat.Rgb8U Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 8 bits per channel (channel format - unsigned integer).

C#
public static readonly NPixelFormat Rgb8U = (NPixelFormat)0x00303003;


NPixelFormat.Rgb8UIndexed1 Field

NPixelFormat.Rgb8UIndexed1 Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies indexed Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 8 bits per channel (channel format - unsigned integer). Also 1 bit is for saving index to image palette.

C#
public static readonly NPixelFormat Rgb8UIndexed1 = (NPixelFormat)0x01303003;


NPixelFormat.Rgb8UIndexed2 Field

NPixelFormat.Rgb8UIndexed2 Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies indexed Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 8 bits per channel (channel format - unsigned integer). Also 2 bits is for saving index to image palette.

C#
public static readonly NPixelFormat Rgb8UIndexed2 = (NPixelFormat)0x02303003;


NPixelFormat.Rgb8UIndexed4 Field

NPixelFormat.Rgb8UIndexed4 Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies indexed Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 8 bits per channel (channel format - unsigned integer). Also 4 bits is for saving index to image palette.

C#
public static readonly NPixelFormat Rgb8UIndexed4 = (NPixelFormat)0x03303003;


NPixelFormat.Rgb8UIndexed8 Field

NPixelFormat.Rgb8UIndexed8 Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies indexed Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 8 bits per channel (channel format - unsigned integer). Also 8 bits is for saving index to image palette.

C#
public static readonly NPixelFormat Rgb8UIndexed8 = (NPixelFormat)0x04303003;


NPixelFormat.RgbA16S Field

NPixelFormat.RgbA16S Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 16 bits per alpha channel (channel format - signed integer). Alpha channel specifies pixel transparency.

C#
public static readonly NPixelFormat RgbA16S = (NPixelFormat)0x00414103;


NPixelFormat.RgbA16U Field

NPixelFormat.RgbA16U Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 16 bits per alpha channel (channel format - unsigned integer). Alpha channel specifies pixel transparency.

C#
public static readonly NPixelFormat RgbA16U = (NPixelFormat)0x00404103;


NPixelFormat.RgbA32F Field

NPixelFormat.RgbA32F Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 32 bits per alpha channel (channel format - floating point). Alpha channel specifies pixel transparency.

C#
public static readonly NPixelFormat RgbA32F = (NPixelFormat)0x00524103;


NPixelFormat.RgbA32S Field

NPixelFormat.RgbA32S Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 32 bits per alpha channel (channel format - signed integer). Alpha channel specifies pixel transparency.

C#
public static readonly NPixelFormat RgbA32S = (NPixelFormat)0x00514103;


NPixelFormat.RgbA32U Field

NPixelFormat.RgbA32U Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 32 bits per alpha channel (channel format - unsigned integer). Alpha channel specifies pixel transparency.

C#
public static readonly NPixelFormat RgbA32U = (NPixelFormat)0x00504103;


NPixelFormat.RgbA64F Field

NPixelFormat.RgbA64F Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 64 bits per alpha channel (channel format - floating point). Alpha channel specifies pixel transparency.

C#
public static readonly NPixelFormat RgbA64F = (NPixelFormat)0x00624103;


NPixelFormat.RgbA64S Field

NPixelFormat.RgbA64S Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 64 bits per alpha channel (channel format - signed integer). Alpha channel specifies pixel transparency.

C#
public static readonly NPixelFormat RgbA64S = (NPixelFormat)0x00614103;


NPixelFormat.RgbA64U Field

NPixelFormat.RgbA64U Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 64 bits per alpha channel (channel format - unsigned integer). Alpha channel specifies pixel transparency.

C#
public static readonly NPixelFormat RgbA64U = (NPixelFormat)0x00604103;


NPixelFormat.RgbA8S Field

NPixelFormat.RgbA8S Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 8 bits per alpha channel (channel format - signed integer). Alpha channel specifies pixel transparency.

C#
public static readonly NPixelFormat RgbA8S = (NPixelFormat)0x00314103;


NPixelFormat.RgbA8U Field

NPixelFormat.RgbA8U Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 8 bits per alpha channel (channel format - unsigned integer). Alpha channel specifies pixel transparency.

C#
public static readonly NPixelFormat RgbA8U = (NPixelFormat)0x00304103;


NPixelFormat.RgbA8UIndexed1 Field

NPixelFormat.RgbA8UIndexed1 Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies indexed Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 8 bits per alpha channel (channel format - unsigned integer). Also 1 bit is for saving index to image palette.

C#
public static readonly NPixelFormat RgbA8UIndexed1 = (NPixelFormat)0x01304103;


NPixelFormat.RgbA8UIndexed2 Field

NPixelFormat.RgbA8UIndexed2 Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies indexed Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 8 bits per alpha channel (channel format - unsigned integer). Also 2 bits is for saving index to image palette.

C#
public static readonly NPixelFormat RgbA8UIndexed2 = (NPixelFormat)0x02304103;


NPixelFormat.RgbA8UIndexed4 Field

NPixelFormat.RgbA8UIndexed4 Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies indexed Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 8 bits per alpha channel (channel format - unsigned integer). Also 4 bits is for saving index to image palette.

C#
public static readonly NPixelFormat RgbA8UIndexed4 = (NPixelFormat)0x03304103;


NPixelFormat.RgbA8UIndexed8 Field

NPixelFormat.RgbA8UIndexed8 Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies indexed Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 8 bits per alpha channel (channel format - unsigned integer). Also 8 bits is for saving index to image palette.

C#
public static readonly NPixelFormat RgbA8UIndexed8 = (NPixelFormat)0x04304103;


NPixelFormat.RgbPA16S Field

NPixelFormat.RgbPA16S Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 16 bits per pre-multiplied alpha channel (channel format - signed integer).

C#
public static readonly NPixelFormat RgbPA16S = (NPixelFormat)0x00414203;


NPixelFormat.RgbPA16U Field

NPixelFormat.RgbPA16U Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 16 bits per pre-multiplied alpha channel (channel format - unsigned integer).

C#
public static readonly NPixelFormat RgbPA16U = (NPixelFormat)0x00404203;


NPixelFormat.RgbPA32F Field

NPixelFormat.RgbPA32F Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 32 bits per pre-multiplied alpha channel (channel format - floating point).

C#
public static readonly NPixelFormat RgbPA32F = (NPixelFormat)0x00524203;


NPixelFormat.RgbPA32S Field

NPixelFormat.RgbPA32S Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 32 bits per pre-multiplied alpha channel (channel format - signed integer).

C#
public static readonly NPixelFormat RgbPA32S = (NPixelFormat)0x00514203;


NPixelFormat.RgbPA32U Field

NPixelFormat.RgbPA32U Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 32 bits per pre-multiplied alpha channel (channel format - unsigned integer).

C#
public static readonly NPixelFormat RgbPA32U = (NPixelFormat)0x00504203;


NPixelFormat.RgbPA64F Field

NPixelFormat.RgbPA64F Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 64 bits per pre-multiplied alpha channel (channel format - floating point).

C#
public static readonly NPixelFormat RgbPA64F = (NPixelFormat)0x00624203;


NPixelFormat.RgbPA64S Field

NPixelFormat.RgbPA64S Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 64 bits per pre-multiplied alpha channel (channel format - signed integer).

C#
public static readonly NPixelFormat RgbPA64S = (NPixelFormat)0x00614203;


NPixelFormat.RgbPA64U Field

NPixelFormat.RgbPA64U Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 64 bits per pre-multiplied alpha channel (channel format - unsigned integer).

C#
public static readonly NPixelFormat RgbPA64U = (NPixelFormat)0x00604203;


NPixelFormat.RgbPA8S Field

NPixelFormat.RgbPA8S Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 8 bits per pre-multiplied alpha channel (channel format - signed integer).

C#
public static readonly NPixelFormat RgbPA8S = (NPixelFormat)0x00314203;


NPixelFormat.RgbPA8U Field

NPixelFormat.RgbPA8U Field
NPixelFormat Structure Neurotec.Images Namespace

Specifies Rgb image pixel format where each pixel (Red, Green, Blue) is represented by 8 bits per pre-multiplied alpha channel (channel format - unsigned integer).

C#
public static readonly NPixelFormat RgbPA8U = (NPixelFormat)0x00304203;


NPixelFormat.Undefined Field

NPixelFormat.Undefined Field
NPixelFormat Structure Neurotec.Images Namespace

Indicates undefined pixel format.

C#
public static readonly NPixelFormat Undefined = (NPixelFormat)0;


NPixelFormat.CalcRowLongSize Method (int, uint)

NPixelFormat.CalcRowLongSize Method (int, uint)
NPixelFormat Structure Neurotec.Images Namespace

Calculates number of bytes needed to store line of specified length of pixels with specified bits per pixel.

C#
public static long CalcRowLongSize(int bitsPerPixel, uint length);
Collapse Expand Parameters
Parameters | Description
int bitsPerPixel | A number of bytes needed to store line of pixels.
uint length | A length of pixels.
Collapse Expand Returns

The number of bytes needed to store line of specified length of pixels with specified bits per pixel.


NPixelFormat.CalcRowLongSize Method (int, uint, int)

NPixelFormat.CalcRowLongSize Method (int, uint, int)
NPixelFormat Structure Neurotec.Images Namespace

Calculates number of bytes needed to store line of specified length of pixels with specified bits per pixel and alignment.

C#
public static long CalcRowLongSize(int bitsPerPixel, uint length, int alignment);
Collapse Expand Parameters
Parameters | Description
int bitsPerPixel | A number of bytes needed to store line of pixels.
uint length | A length of pixels.
int alignment | Alignment.
Collapse Expand Returns

The number of bytes needed to store line of specified length of pixels with specified bits per pixel.


NPixelFormat.CalcRowNativeSize Method (int, uint)

NPixelFormat.CalcRowNativeSize Method (int, uint)
NPixelFormat Structure Neurotec.Images Namespace

Calculates number of bytes needed to store line of specified length of pixels with specified bits per pixel.

C#
public static UIntPtr CalcRowNativeSize(int bitsPerPixel, uint length);
Collapse Expand Parameters
Parameters | Description
int bitsPerPixel | A number of bytes needed to store line of pixels.
uint length | A length of pixels.
Collapse Expand Returns

The number of bytes needed to store line of specified length of pixels with specified bits per pixel.


NPixelFormat.CalcRowNativeSize Method (int, uint, int)

NPixelFormat.CalcRowNativeSize Method (int, uint, int)
NPixelFormat Structure Neurotec.Images Namespace

Calculates number of bytes needed to store line of specified length of pixels with specified bits per pixel and alignment.

C#
public static UIntPtr CalcRowNativeSize(int bitsPerPixel, uint length, int alignment);
Collapse Expand Parameters
Parameters | Description
int bitsPerPixel | A number of bytes needed to store line of pixels.
uint length | A length of pixels.
int alignment | Alignment.
Collapse Expand Returns

The number of bytes needed to store line of specified length of pixels with specified bits per pixel.


NPixelFormat.CalcRowSize Method (int, uint)

NPixelFormat.CalcRowSize Method (int, uint)
NPixelFormat Structure Neurotec.Images Namespace

Calculates number of bytes needed to store line of specified length of pixels with specified bits per pixel.

C#
public static int CalcRowSize(int bitsPerPixel, uint length);
Collapse Expand Parameters
Parameters | Description
int bitsPerPixel | A number of bytes needed to store line of pixels.
uint length | A length of pixels.
Collapse Expand Returns

The number of bytes needed to store line of specified length of pixels with specified bits per pixel.


NPixelFormat.CalcRowSize Method (int, uint, int)

NPixelFormat.CalcRowSize Method (int, uint, int)
NPixelFormat Structure Neurotec.Images Namespace

Calculates number of bytes needed to store line of specified length of pixels with specified bits per pixel and alignment.

C#
public static int CalcRowSize(int bitsPerPixel, uint length, int alignment);
Collapse Expand Parameters
Parameters | Description
int bitsPerPixel | A number of bytes needed to store line of pixels.
uint length | A length of pixels.
int alignment | Alignment.
Collapse Expand Returns

The number of bytes needed to store line of specified length of pixels with specified bits per pixel.


NPixelFormat.CanPixelTypeBeIndexed Method

NPixelFormat.CanPixelTypeBeIndexed Method
NPixelFormat Structure Neurotec.Images Namespace

Checks whether the specified pixel type can be indexed.

C#
public static bool CanPixelTypeBeIndexed(NPixelType pixelType);
Collapse Expand Parameters
Parameters | Description
NPixelType pixelType | The specified pixel type.
Collapse Expand Returns

true, if the pixel type can be indexed; else false.


NPixelFormat.Equals Method (NPixelFormat)

NPixelFormat.Equals Method (NPixelFormat)
NPixelFormat Structure Neurotec.Images Namespace

Checks whether the current pixel format equals the other pixel format.

C#
public bool Equals(NPixelFormat other);
Collapse Expand Parameters
Parameters | Description
NPixelFormat other | The other pixel format.
Collapse Expand Returns

true if the specified Object is equal to the current Object; otherwise, false.


NPixelFormat.Equals Method (object)

NPixelFormat.Equals Method (object)
NPixelFormat Structure Neurotec.Images Namespace

Determines whether the specified Object is equal to the current Object.

C#
public override bool Equals(object obj);
Collapse Expand Parameters
Parameters | Description
object obj | The Object to compare with the current Object.
Collapse Expand Returns

true if the specified Object is equal to the current Object; otherwise, false.


NPixelFormat.GetChannelType Method

NPixelFormat.GetChannelType Method
NPixelFormat Structure Neurotec.Images Namespace

Retrieves the current channel type.

C#
public NType GetChannelType();
Collapse Expand Returns

The current channel type.


NPixelFormat.GetHashCode Method

NPixelFormat.GetHashCode Method
NPixelFormat Structure Neurotec.Images Namespace

Gets the hash code. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.

C#
public override int GetHashCode();
Collapse Expand Returns

A hash code for the current Object.


NPixelFormat.GetIndexed Method

NPixelFormat.GetIndexed Method
NPixelFormat Structure Neurotec.Images Namespace

Retrieves an indexed version of the NPixelFormat.

C#
public NPixelFormat GetIndexed(int bitsPerIndex);
Collapse Expand Parameters
Parameters | Description
int bitsPerIndex | Number of bits per index.
Collapse Expand Returns

Indexed NPixelFormat.


NPixelFormat.GetNonIndexed Method

NPixelFormat.GetNonIndexed Method
NPixelFormat Structure Neurotec.Images Namespace

Retrieves a non-indexed version of the NPixelFormat.

C#
public NPixelFormat GetNonIndexed();
Collapse Expand Returns

Non-indexed NPixelFormat.


NPixelFormat.GetNonSeparated Method

NPixelFormat.GetNonSeparated Method
NPixelFormat Structure Neurotec.Images Namespace

Retrieves a non-separated version of the NPixelFormat.

C#
public NPixelFormat GetNonSeparated();
Collapse Expand Returns

Non-separated NPixelFormat.


NPixelFormat.GetPaletteSize Method

NPixelFormat.GetPaletteSize Method
NPixelFormat Structure Neurotec.Images Namespace

Retrieves the palette size.

C#
public int GetPaletteSize(int length);
Collapse Expand Parameters
Parameters | Description
int length | The length of pixels.
Collapse Expand Returns

Palette size.


NPixelFormat.GetRowLongSize Method (uint)

NPixelFormat.GetRowLongSize Method (uint)
NPixelFormat Structure Neurotec.Images Namespace

Calculates number of bytes needed to store line of specified length of pixels with specified NPixelFormat.

C#
public long GetRowLongSize(uint length);
Collapse Expand Parameters
Parameters | Description
uint length | A length of pixels.
Collapse Expand Returns

The number of bytes needed to store line of specified length of pixels with specified NPixel Format.


NPixelFormat.GetRowLongSize Method (uint, int)

NPixelFormat.GetRowLongSize Method (uint, int)
NPixelFormat Structure Neurotec.Images Namespace

Calculates number of bytes needed to store line of specified length of pixels with specified NPixelFormat and alignment.

C#
public long GetRowLongSize(uint length, int alignment);
Collapse Expand Parameters
Parameters | Description
uint length | A length of pixels.
int alignment | Alignment.
Collapse Expand Returns

The number of bytes needed to store line of specified length of pixels with specified NPixel Format.


NPixelFormat.GetRowNativeSize Method (uint)

NPixelFormat.GetRowNativeSize Method (uint)
NPixelFormat Structure Neurotec.Images Namespace

Calculates number of bytes needed to store line of specified length of pixels with specified NPixelFormat and alignment.

C#
public UIntPtr GetRowNativeSize(uint length);
Collapse Expand Parameters
Parameters | Description
uint length | A length of pixels.
Collapse Expand Returns

The number of bytes needed to store line of specified length of pixels with specified NPixel Format.


NPixelFormat.GetRowNativeSize Method (uint, int)

NPixelFormat.GetRowNativeSize Method (uint, int)
NPixelFormat Structure Neurotec.Images Namespace

Calculates number of bytes needed to store line of specified length of pixels with specified NPixelFormat and alignment.

C#
public UIntPtr GetRowNativeSize(uint length, int alignment);
Collapse Expand Parameters
Parameters | Description
uint length | A length of pixels.
int alignment | Alignment.
Collapse Expand Returns

No tables or formatting elements here!!!


NPixelFormat.GetRowSize Method (uint)

NPixelFormat.GetRowSize Method (uint)
NPixelFormat Structure Neurotec.Images Namespace

Calculates number of bytes needed to store line of specified length of pixels with specified NPixelFormat.

C#
public int GetRowSize(uint length);
Collapse Expand Parameters
Parameters | Description
uint length | A length of pixels.
Collapse Expand Returns

The number of bytes needed to store line of specified length of pixels with specified NPixel Format.


NPixelFormat.GetRowSize Method (uint, int)

NPixelFormat.GetRowSize Method (uint, int)
NPixelFormat Structure Neurotec.Images Namespace

Calculates number of bytes needed to store line of specified length of pixels with specified NPixelFormat and alignment.

C#
public int GetRowSize(uint length, int alignment);
Collapse Expand Parameters
Parameters | Description
uint length | A length of pixels.
int alignment | Alignment.
Collapse Expand Returns

The number of bytes needed to store line of specified length of pixels with specified NPixel Format.


NPixelFormat.GetSeparated Method

NPixelFormat.GetSeparated Method
NPixelFormat Structure Neurotec.Images Namespace

Retrieves a separated version of the NPixelFormat.

C#
public NPixelFormat GetSeparated();
Collapse Expand Returns

Separated NPixelFormat.


NPixelFormat.GetWithExtraChannel Method

NPixelFormat.GetWithExtraChannel Method
NPixelFormat Structure Neurotec.Images Namespace

Retrieves a version of the NPixelFormat with an extra channel.

C#
public NPixelFormat GetWithExtraChannel(NExtraChannel extraChannel);
Collapse Expand Parameters
Parameters | Description
NExtraChannel extraChannel | The extra channel.
Collapse Expand Returns

NPixelFormat with an extra channel.


NPixelFormat.IsPixelTypeValid Method

NPixelFormat.IsPixelTypeValid Method
NPixelFormat Structure Neurotec.Images Namespace

Checks whether current NPixelType value is valid.

C#
public static bool IsPixelTypeValid(NPixelType value);
Collapse Expand Parameters
Parameters | Description
NPixelType value | The pixel type to be checked.
Collapse Expand Returns

true if valid; else false.


NPixelFormat.ToString Method ()

NPixelFormat.ToString Method ()
NPixelFormat Structure Neurotec.Images Namespace

Retrieves string representation of NPixelFormat object.

C#
public override string ToString();
Collapse Expand Returns

String representation of NPixelFormat object.


NPixelFormat.ToString Method (string)

NPixelFormat.ToString Method (string)
NPixelFormat Structure Neurotec.Images Namespace

Retrieves string representation of NPixelFormat object.

C#
public string ToString(string format);
Collapse Expand Parameters
Parameters | Description
string format | Reserved.
Collapse Expand Returns

String representation of NPixelFormat object.


NPixelFormat.!= Operator

NPixelFormat.!= Operator
NPixelFormat Structure Neurotec.Images Namespace

Checks if two pixelFormats are not equal.

C#
public static bool operator !=(NPixelFormat pixelFormat1, NPixelFormat pixelFormat2);
Collapse Expand Parameters
Parameters | Description
NPixelFormat pixelFormat1 | first pixelFormat to be compared.
NPixelFormat pixelFormat2 | second pixelFormat to be compared.
Collapse Expand Returns

True if pixelFormats are not equal, false if equal.


NPixelFormat.== Operator

NPixelFormat.== Operator
NPixelFormat Structure Neurotec.Images Namespace

Checks if two pixelFormats are equal.

C#
public static bool operator ==(NPixelFormat pixelFormat1, NPixelFormat pixelFormat2);
Collapse Expand Parameters
Parameters | Description
NPixelFormat pixelFormat1 | first pixelFormat to be compared.
NPixelFormat pixelFormat2 | second pixelFormat to be compared.
Collapse Expand Returns

True if pixelFormats are equal, false otherwise.


NPixelFormat.NPixelFormat Operator (uint)

NPixelFormat.NPixelFormat Operator (uint)
NPixelFormat Structure Neurotec.Images Namespace

This conversion operator converts from a uint type to a NPixelFormat type

C#
public static explicit operator NPixelFormat(uint value);
Collapse Expand Parameters
Parameters | Description
uint value | value to be converted


NPixelFormat.uint Operator

NPixelFormat.uint Operator
NPixelFormat Structure Neurotec.Images Namespace

Gets value field of NPixelFormat object.

C#
public static explicit operator uint(NPixelFormat pixelFormat);
Collapse Expand Parameters
Parameters | Description
NPixelFormat pixelFormat | NPixelFormat object.


NPixelFormat.BitsPerChannel Property

NPixelFormat.BitsPerChannel Property
NPixelFormat Structure Neurotec.Images Namespace

Gets or sets the number of bits per channel.

C#
public int BitsPerChannel;
Property value

The number of bits per channel.


NPixelFormat.BitsPerIndex Property

NPixelFormat.BitsPerIndex Property
NPixelFormat Structure Neurotec.Images Namespace

Gets or sets the number of bits per index.

C#
public int BitsPerIndex;
Property value

The number of bits per index.


NPixelFormat.BitsPerPaletteEntry Property

NPixelFormat.BitsPerPaletteEntry Property
NPixelFormat Structure Neurotec.Images Namespace

Gets or sets the number of bits per palette entry.

C#
public int BitsPerPaletteEntry;
Property value

The number of bits per palette entry.


NPixelFormat.BitsPerPixel Property

NPixelFormat.BitsPerPixel Property
NPixelFormat Structure Neurotec.Images Namespace

Each pixel value is stored in 24 bits consisting of three 8-bit values representing red, green and blue color components.

C#
public int BitsPerPixel;
Property value

A number of bits per NPixelFormat.


NPixelFormat.BitsPerValue Property

NPixelFormat.BitsPerValue Property
NPixelFormat Structure Neurotec.Images Namespace

Gets or sets the number of bits per value.

C#
public int BitsPerValue;
Property value

The number of bits per value.


NPixelFormat.BytesPerChannel Property

NPixelFormat.BytesPerChannel Property
NPixelFormat Structure Neurotec.Images Namespace

Gets or sets the number of bytes per channel.

C#
public int BytesPerChannel;
Property value

The number of bytes per channel.


NPixelFormat.BytesPerPaletteEntry Property

NPixelFormat.BytesPerPaletteEntry Property
NPixelFormat Structure Neurotec.Images Namespace

Gets or sets the number of bytes per palette entry.

C#
public int BytesPerPaletteEntry;
Property value

The number of bytes per palette entry.


NPixelFormat.BytesPerPixel Property

NPixelFormat.BytesPerPixel Property
NPixelFormat Structure Neurotec.Images Namespace

Gets or sets the number of bytes per pixel.

C#
public int BytesPerPixel;
Property value

The number of bytes per pixel.


NPixelFormat.BytesPerValue Property

NPixelFormat.BytesPerValue Property
NPixelFormat Structure Neurotec.Images Namespace

Gets or sets the number of bytes per value.

C#
public int BytesPerValue;
Property value

The number of bytes per value.


NPixelFormat.ChannelCount Property

NPixelFormat.ChannelCount Property
NPixelFormat Structure Neurotec.Images Namespace

Gets or sets the number of channels.

C#
public int ChannelCount;
Property value

The number of channels.


NPixelFormat.ChannelFormat Property

NPixelFormat.ChannelFormat Property
NPixelFormat Structure Neurotec.Images Namespace

Gets or sets the format of the channel.

C#
public NChannelFormat ChannelFormat;
Property value

The format of the channel.


NPixelFormat.ExtraChannel Property

NPixelFormat.ExtraChannel Property
NPixelFormat Structure Neurotec.Images Namespace

Gets or sets the extra channel.

C#
public NExtraChannel ExtraChannel;
Property value

The extra channel.


NPixelFormat.IsIndexed Property

NPixelFormat.IsIndexed Property
NPixelFormat Structure Neurotec.Images Namespace

Checks whether current NPixelFormat value is indexed.

C#
public bool IsIndexed;
Property value

true if current NPixelFormat is indexed, false if not.


NPixelFormat.IsSeparated Property

NPixelFormat.IsSeparated Property
NPixelFormat Structure Neurotec.Images Namespace

Checks whether current NPixelFormat value is separated.

C#
public bool IsSeparated;
Property value

true if current NPixelFormat is separated, false if not.


NPixelFormat.IsValid Property

NPixelFormat.IsValid Property
NPixelFormat Structure Neurotec.Images Namespace

Checks whether current NPixelFormat value is valid.

C#
public bool IsValid;
Collapse Expand Returns

true if the object is valid NPixelFormat, false if not.


NPixelFormat.MaxPaletteLength Property

NPixelFormat.MaxPaletteLength Property
NPixelFormat Structure Neurotec.Images Namespace

Gets or sets the maximum palette length.

C#
public int MaxPaletteLength;
Property value

The maximum palette length.


NPixelFormat.NPixelTypeNativeType Property

NPixelFormat.NPixelTypeNativeType Property
NPixelFormat Structure Neurotec.Images Namespace

Defines the native type of the pixel type.

C#
public static NType NPixelTypeNativeType;


NPixelFormat.NativeType Property

NPixelFormat.NativeType Property
NPixelFormat Structure Neurotec.Images Namespace

Defines the native type of the object.

C#
public static NType NativeType;


NPixelFormat.PixelType Property

NPixelFormat.PixelType Property
NPixelFormat Structure Neurotec.Images Namespace

Gets or sets the type of the pixel.

C#
public NPixelType PixelType;
Property value

The type of the pixel.


NPixelFormat.PlaneCount Property

NPixelFormat.PlaneCount Property
NPixelFormat Structure Neurotec.Images Namespace

Gets or sets the number of the planes.

C#
public int PlaneCount;
Property value

The number of the planes.


NRgb Structure

NRgb Structure
Legend Members Methods NRgb Methods NRgb Properties

Represents an RGB color.

C#
[Serializable]
[StructLayout(LayoutKind.Sequential)]
public struct NRgb : IFormattable {
}
Collapse Expand NRgb Methods
Name | Description
ToArray | Retrieves a byte array representation of NRgb object.
ToString | Retrieves a string representation of NRgb object.
Collapse Expand NRgb Properties
Name | Description
Blue | Gets the blue component value of this NRgb structure.
Green | Gets the green component value of this NRgb structure.
Red | Gets the red component value of this NRgb structure.
Container

File: NRgb.cs

Namespace: Neurotec.Images

Module: .NET Reference


NRgb.NRgb Constructor (byte, byte, byte)

NRgb.NRgb Constructor (byte, byte, byte)
NRgb Structure Neurotec.Images Namespace

Initializes a new instance of the NRgb structure.

C#
public NRgb(byte red, byte green, byte blue);
Collapse Expand Parameters
Parameters | Description
byte red | The blue component value of this NRGB.
byte green | The green component value of this NRGB.
byte blue | The red component value of this NRGB.


NRgb.NRgb Constructor (byte[])

NRgb.NRgb Constructor (byte[])
NRgb Structure Neurotec.Images Namespace

Initializes a new instance of NRGB class.

C#
public NRgb(byte[] value);
Collapse Expand Parameters
Parameters | Description
byte[] value | RGB value array.


NRgb.ToArray Method

NRgb.ToArray Method
NRgb Structure Neurotec.Images Namespace

Retrieves a byte array representation of NRgb object.

C#
public byte[] ToArray();
Collapse Expand Returns

Byte array representing NRgb object.


NRgb.ToString Method ()

NRgb.ToString Method ()
NRgb Structure Neurotec.Images Namespace

Retrieves a string representation of NRgb object.

C#
public override string ToString();
Collapse Expand Returns

String representation of NRgb object.


NRgb.ToString Method (string)

NRgb.ToString Method (string)
NRgb Structure Neurotec.Images Namespace

Retrieves string representation of NRgb object.

C#
public string ToString(string format);
Collapse Expand Parameters
Parameters | Description
string format | Reserved.
Collapse Expand Returns

String representation of NRgb object.


NRgb.Blue Property

NRgb.Blue Property
NRgb Structure Neurotec.Images Namespace

Gets the blue component value of this NRgb structure.

C#
public byte Blue;
Property value

The blue component value of this NRgb.


NRgb.Green Property

NRgb.Green Property
NRgb Structure Neurotec.Images Namespace

Gets the green component value of this NRgb structure.

C#
public byte Green;
Property value

The green component value of this NRgb.


NRgb.Red Property

NRgb.Red Property
NRgb Structure Neurotec.Images Namespace

Gets the red component value of this NRgb structure.

C#
public byte Red;
Property value

The red component value of this NRgb.


PngInfo Class

PngInfo Class
NObject Delegates NObject Events NObject Fields Legend Members Methods NDisposable Methods NDisposable Properties

Provides information about PNG format images.

C#
public sealed class PngInfo : NImageInfo;
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
PngInfo Class
Name | Description
DefaultCompressionLevel | Specifies default Png compression level.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NExpandableObject Class
Show:
No members matching the current filter
Name | Description
NativeType | Defines the native type of the object.
Properties | Gets the property bag of the expandable object.
NImageInfo Class
Show:
No members matching the current filter
Name | Description
Format | Gets or sets the image format.
Height | Gets image height.
NImageRotateFlipTypeNativeType | Defines the native type of the image rotation.
NativeType | Defines the native type of the object.
Transform | Gets or sets the transformation of the image.
Width | Gets image height.
PngInfo Class
Name | Description
CompressionLevel | Gets or sets compression level of a PNG image.
NativeType | Gets or sets
Container

File: Png.cs

Namespace: Neurotec.Images

Module: .NET Reference


PngInfo.DefaultCompressionLevel Field

PngInfo.DefaultCompressionLevel Field
PngInfo Class Neurotec.Images Namespace

Specifies default Png compression level.

C#
public const int DefaultCompressionLevel = 6;


PngInfo.CompressionLevel Property

PngInfo.CompressionLevel Property
PngInfo Class Neurotec.Images Namespace

Gets or sets compression level of a PNG image.

C#
public int CompressionLevel;
Property value

NInt value defining the compression level.


PngInfo.NativeType Property

PngInfo.NativeType Property
PngInfo Class Neurotec.Images Namespace

Gets or sets

C#
public static new NType NativeType;
Property value

The function that retrieves NType object for the enclosing type.


TiffInfo Class

TiffInfo Class
NObject Delegates NObject Events NObject Fields Legend Members Methods NDisposable Methods NDisposable Properties

Provides information about TIFF format images.

C#
public sealed class TiffInfo : NImageInfo;
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NExpandableObject Class
Show:
No members matching the current filter
Name | Description
NativeType | Defines the native type of the object.
Properties | Gets the property bag of the expandable object.
NImageInfo Class
Show:
No members matching the current filter
Name | Description
Format | Gets or sets the image format.
Height | Gets image height.
NImageRotateFlipTypeNativeType | Defines the native type of the image rotation.
NativeType | Defines the native type of the object.
Transform | Gets or sets the transformation of the image.
Width | Gets image height.
TiffInfo Class
Name | Description
NativeType | Gets or sets
Container

File: Tiff.cs

Namespace: Neurotec.Images

Module: .NET Reference


TiffInfo.NativeType Property

TiffInfo.NativeType Property
TiffInfo Class Neurotec.Images Namespace

Gets or sets

C#
public static new NType NativeType;
Property value

The function that retrieves NType object for the enclosing type.


Neurotec.Images.Jpeg2KProfile Enumeration

Neurotec.Images.Jpeg2KProfile Enumeration

Enumerates JPEG2000 image types.

C#
public enum Jpeg2KProfile {
  None = 0,
  Fingerprint1000Ppi = 1000,
  FingerprintLossless = 1001,
  FaceLossy = 2000,
  FaceLossless = 2001
}
Collapse Expand Members
Members | Description
None = 0 | None.
Fingerprint1000Ppi = 1000 | Fingerprint scan at 1000ppi.
FingerprintLossless = 1001 | Fingerprint image, lossless.
FaceLossy = 2000 | Face image, with loss.
FaceLossless = 2001 | Face image, lossless.
Container

File: Jpeg2K.cs

Namespace: Neurotec.Images

Module: .NET Reference


Neurotec.Images.NImageRotateFlipType Enumeration

Neurotec.Images.NImageRotateFlipType Enumeration

Enumerates NImage rotation and flip values.

C#
[Serializable]
[Flags]
public enum NImageRotateFlipType {
  RotateNone = 0,
  Rotate90 = 1,
  Rotate180 = 2,
  Rotate270 = 3,
  FlipNone = 0,
  FlipX = 4,
  FlipY = 8,
  FlipXY = FlipX|FlipY,
  None = RotateNone|FlipNone,
  Unspecified = -1
}
Collapse Expand Members
Members | Description
RotateNone = 0 | Indicates that image should not be rotated.
Rotate90 = 1 | Rotates image by 90 degrees.
Rotate180 = 2 | Rotates image by 180 degrees.
Rotate270 = 3 | Rotates image by 270 degrees.
FlipNone = 0 | No flip.
FlipX = 4 | Flips the image's orientation of the X coordinates.
FlipY = 8 | Flips the image's orientation of the Y coordinates.
FlipXY = FlipX|FlipY | Flips the image's orientation of the X or Y coordinates.
None = RotateNone|FlipNone | No flip or rotation.
Unspecified = -1 | Rotation and flip unspecified.
Container

File: NImageInfo.cs

Namespace: Neurotec.Images

Module: .NET Reference


Neurotec.Images.NPixelType Enumeration

Neurotec.Images.NPixelType Enumeration

Enumerates the pixel types.

C#
public enum NPixelType {
  Undefined = 0,
  Grayscale = 1,
  Rgb = 3
}
Collapse Expand Members
Members | Description
Undefined = 0 | Undefined pixel type.
Grayscale = 1 | Grayscale pixel type.
Rgb = 3 | RGB pixel type.
Container

File: NPixelFormat.cs

Namespace: Neurotec.Images

Module: .NET Reference


Neurotec.Interop Namespace

Neurotec.Interop Namespace
Classes Legend
Collapse Expand Classes
Name | Description
NKeyValuePair_ | Represents a key value pair structure.
NNameStringPair_ | Represents a pair of name strings.
NNameValuePair_ | Represents a name value pair structure.


NKeyValuePair_ Structure

NKeyValuePair_ Structure
NKeyValuePair_ Fields Legend Members NKeyValuePair_ Methods

Represents a key value pair structure.

C#
[StructLayout(LayoutKind.Sequential)]
public struct NKeyValuePair_ {
  public IntPtr hKey;
  public IntPtr hValue;
}
Collapse Expand NKeyValuePair_ Fields
Name | Description
hKey | Handle to the key part of the key value pair.
hValue | Handle to the value part of the key value pair.
Collapse Expand NKeyValuePair_ Methods
Name | Description
Create | Creates a new key value pair from the specified key value pair structure.
Dispose | Disposes of the specified key value pair.
ToStruct | Creates a new key value pair structure from the specified key value pair.
Container

File: NValue.cs

Namespace: Neurotec.Interop

Module: .NET Reference


NKeyValuePair_.hKey Field

NKeyValuePair_.hKey Field
NKeyValuePair_ Structure Neurotec.Interop Namespace

Handle to the key part of the key value pair.

C#
public IntPtr hKey;


NKeyValuePair_.hValue Field

NKeyValuePair_.hValue Field
NKeyValuePair_ Structure Neurotec.Interop Namespace

Handle to the value part of the key value pair.

C#
public IntPtr hValue;


NKeyValuePair_.Create Method

NKeyValuePair_.Create Method
NKeyValuePair_ Structure Neurotec.Interop Namespace

Creates a new key value pair from the specified key value pair structure.

C#
public static void Create(KeyValuePair<object, object> value, out NKeyValuePair_ v);
Collapse Expand Parameters
Parameters | Description
KeyValuePair<object, object> value | Key value pair structure.
out NKeyValuePair_ v | [out] Pointer to the key value pair.


NKeyValuePair_.Dispose Method

NKeyValuePair_.Dispose Method
NKeyValuePair_ Structure Neurotec.Interop Namespace

Disposes of the specified key value pair.

C#
public static void Dispose(ref NKeyValuePair_ value);
Collapse Expand Parameters
Parameters | Description
ref NKeyValuePair_ value | Pointer to the key value pair to be disposed of.


NKeyValuePair_.ToStruct Method

NKeyValuePair_.ToStruct Method
NKeyValuePair_ Structure Neurotec.Interop Namespace

Creates a new key value pair structure from the specified key value pair.

C#
public static KeyValuePair<object, object> ToStruct(ref NKeyValuePair_ value);
Collapse Expand Parameters
Parameters | Description
ref NKeyValuePair_ value | Pointer to the key value pair.
Collapse Expand Returns

Key value pair structure.


NNameStringPair_ Structure

NNameStringPair_ Structure
NNameStringPair_ Fields Legend Members NNameStringPair_ Methods

Represents a pair of name strings.

C#
[StructLayout(LayoutKind.Sequential)]
public struct NNameStringPair_ {
  public IntPtr hKey;
  public IntPtr hValue;
}
Collapse Expand NNameStringPair_ Fields
Name | Description
hKey | Key string of the name string pair.
hValue | Value string of the name string pair.
Collapse Expand NNameStringPair_ Methods
Name | Description
Create | Creates a name value pair from the specified key value pair.
Dispose | Disposes of the specified name string pair.
ToStruct | Converts a name string pair into a key value pair.
Container

File: NTypes.cs

Namespace: Neurotec.Interop

Module: .NET Reference


NNameStringPair_.hKey Field

NNameStringPair_.hKey Field
NNameStringPair_ Structure Neurotec.Interop Namespace

Key string of the name string pair.

C#
public IntPtr hKey;


NNameStringPair_.hValue Field

NNameStringPair_.hValue Field
NNameStringPair_ Structure Neurotec.Interop Namespace

Value string of the name string pair.

C#
public IntPtr hValue;


NNameStringPair_.Create Method

NNameStringPair_.Create Method
NNameStringPair_ Structure Neurotec.Interop Namespace

Creates a name value pair from the specified key value pair.

C#
public static void Create(KeyValuePair<string, string> value, out NNameStringPair_ v);
Collapse Expand Parameters
Parameters | Description
KeyValuePair<string, string> value | The key value pair.
out NNameStringPair_ v | [out] The new name string pair.


NNameStringPair_.Dispose Method

NNameStringPair_.Dispose Method
NNameStringPair_ Structure Neurotec.Interop Namespace

Disposes of the specified name string pair.

C#
public static void Dispose(ref NNameStringPair_ value);
Collapse Expand Parameters
Parameters | Description
ref NNameStringPair_ value | Name string pair to dispose of.


NNameStringPair_.ToStruct Method

NNameStringPair_.ToStruct Method
NNameStringPair_ Structure Neurotec.Interop Namespace

Converts a name string pair into a key value pair.

C#
public static KeyValuePair<string, string> ToStruct(ref NNameStringPair_ value);
Collapse Expand Parameters
Parameters | Description
ref NNameStringPair_ value | The name string pair.
Collapse Expand Returns

The key value pair.


NNameValuePair_ Structure

NNameValuePair_ Structure
NNameValuePair_ Fields Legend Members NNameValuePair_ Methods

Represents a name value pair structure.

C#
[StructLayout(LayoutKind.Sequential)]
public struct NNameValuePair_ {
  public IntPtr hKey;
  public IntPtr hValue;
}
Collapse Expand NNameValuePair_ Fields
Name | Description
hKey | Handle to the key part of the name value pair.
hValue | Handle to the value part of the name value pair.
Collapse Expand NNameValuePair_ Methods
Name | Description
Create | Creates a new name value pair from the specified key value pair structure.
Dispose | Disposes of the specified name value pair.
ToStruct | Creates a new key value pair structure from the specified name value pair.
Container

File: NValue.cs

Namespace: Neurotec.Interop

Module: .NET Reference


NNameValuePair_.hKey Field

NNameValuePair_.hKey Field
NNameValuePair_ Structure Neurotec.Interop Namespace

Handle to the key part of the name value pair.

C#
public IntPtr hKey;


NNameValuePair_.hValue Field

NNameValuePair_.hValue Field
NNameValuePair_ Structure Neurotec.Interop Namespace

Handle to the value part of the name value pair.

C#
public IntPtr hValue;


NNameValuePair_.Create Method

NNameValuePair_.Create Method
NNameValuePair_ Structure Neurotec.Interop Namespace

Creates a new name value pair from the specified key value pair structure.

C#
public static void Create(KeyValuePair<string, object> value, out NNameValuePair_ v);
Collapse Expand Parameters
Parameters | Description
KeyValuePair<string, object> value | Key value pair structure.
out NNameValuePair_ v | [out] Pointer to the name value pair.


NNameValuePair_.Dispose Method

NNameValuePair_.Dispose Method
NNameValuePair_ Structure Neurotec.Interop Namespace

Disposes of the specified name value pair.

C#
public static void Dispose(ref NNameValuePair_ value);
Collapse Expand Parameters
Parameters | Description
ref NNameValuePair_ value | Pointer to the name value pair to be disposed of.


NNameValuePair_.ToStruct Method

NNameValuePair_.ToStruct Method
NNameValuePair_ Structure Neurotec.Interop Namespace

Creates a new key value pair structure from the specified name value pair.

C#
public static KeyValuePair<string, object> ToStruct(ref NNameValuePair_ value);
Collapse Expand Parameters
Parameters | Description
ref NNameValuePair_ value | Pointer to the name value pair.
Collapse Expand Returns

Key value pair structure.


Neurotec.Licensing Namespace

Neurotec.Licensing Namespace
Classes Legend Structs, Records, Enums

Provides functionality for getting, releasing licenses.

Collapse Expand Classes
Name | Description
NLicense | Provides functionality for getting, releasing licenses.
NLicenseInfo | Provides functionality for license info retrieval.
NLicenseManager | Provides functionality for licenses management.
NLicenseProductInfo | Provides functionality for product info retrieval.
NLicensing | Provides methods for retrieving information about the NLicensing library.
NLicensingService | Manages licensing services.
Collapse Expand Structs, Records, Enums
Name | Description
NLicenseInfoSourceType | Specifies license source type.
NLicenseInfoStatus | Specifies license status.
NLicenseInfoType | Specifies licensing type.
NLicenseType | Enumerates license type.
NLicensingServiceStatus | Enumerates licensing service status values.


NLicense Class

NLicense Class
Legend Members NLicense Methods NLicense Properties

Provides functionality for getting, releasing licenses.

C#
public static class NLicense;
Collapse Expand NLicense Methods
Name | Description
ActivateOnline | Activates specified Id (that was obtained through calling GenerateId method or using ActivationWizardDotNet) and obtains license file for this Id via Internet.
Add | Adds the activated license content (the content of *.lic file) to be used in application.
DeactivateOnline | Deactivates specified license via Internet.
DeactivateOnlineWithId | Deactivates specified license via Internet using specified deactivation Id.
GenerateDeactivationId | Generates deactivation Id for specified provided product on current computer.
GenerateDeactivationIdForLicense | Generates deactivation Id for specified license on current computer.
GenerateId | Generates Id for activation from serial number for a particular machine.
GetLicenseInfoOnline | Retrieves license information via internet.
GetObtainedLicenseInfo | Retrieves license information of specified product.
GetObtainedLicenseInfoForComponent | Retrieves license information of specified component.
GetObtainedStatus | Since license was obtained, it is possible that it became not available or remote server disconnected. Use this function to get current obtained status. Note: NLicensing automatically tries to reobtain license in case of failure, so failure status may change to LicenseObtained.
IsComponentActivated | Checks if component specified by name is activated.
Obtain | Obtains license.
ObtainComponents | Obtains component license from the specified server.
Release | Releases license.
ReleaseComponents | Releases component license.
Collapse Expand NLicense Properties
Name | Description
NativeType | Defines the native type of the object.
Container

File: NLicense.cs

Namespace: Neurotec.Licensing

Module: .NET Reference


NLicense.ActivateOnline Method

NLicense.ActivateOnline Method
NLicense Class Neurotec.Licensing Namespace

Activates specified Id (that was obtained through calling GenerateId method or using ActivationWizardDotNet) and obtains license file for this Id via Internet.

C#
public static string ActivateOnline(string id);
Collapse Expand Parameters
Parameters | Description
string id | Id generated from serial number.
Collapse Expand Returns

String containing activated license data.


NLicense.Add Method (NBuffer)

NLicense.Add Method (NBuffer)
NLicense Class Neurotec.Licensing Namespace

Adds the activated license content (the content of *.lic file) to be used in application.

C#
public static void Add(NBuffer buffer);
Collapse Expand Parameters
Parameters | Description
NBuffer buffer | NBuffer containing license content.


NLicense.Add Method (byte[])

NLicense.Add Method (byte[])
NLicense Class Neurotec.Licensing Namespace

Adds the activated license content (the content of *.lic file) to be used in application.

C#
public static void Add(byte[] buffer);
Collapse Expand Parameters
Parameters | Description
byte[] buffer | Byte array containing license content.


NLicense.Add Method (string)

NLicense.Add Method (string)
NLicense Class Neurotec.Licensing Namespace

Adds the activated license content (the content of *.lic file) to be used in application.

C#
public static void Add(string license);
Collapse Expand Parameters
Parameters | Description
string license | String containing activated license content.


NLicense.DeactivateOnline Method (string)

NLicense.DeactivateOnline Method (string)
NLicense Class Neurotec.Licensing Namespace

Deactivates specified license via Internet.

C#
public static void DeactivateOnline(string license);
Collapse Expand Parameters
Parameters | Description
string license | String that contains activated license's full product name OR license file content.


NLicense.DeactivateOnline Method (string, string)

NLicense.DeactivateOnline Method (string, string)
NLicense Class Neurotec.Licensing Namespace

Deactivates specified license via Internet using specified Id generator.

C#
public static void DeactivateOnline(string idGenPath, string license);
Collapse Expand Parameters
Parameters | Description
string idGenPath | Reserved, must be null.
string license | String that contains activated license name.


NLicense.DeactivateOnlineWithId Method

NLicense.DeactivateOnlineWithId Method
NLicense Class Neurotec.Licensing Namespace

Deactivates specified license via Internet using specified deactivation Id.

C#
public static void DeactivateOnlineWithId(string license, string deactivationId);
Collapse Expand Parameters
Parameters | Description
string license | String that contains activated license name.
string deactivationId | Deactivation Id.
Collapse Expand Remarks

Important! Both license and generated deactivation Id should be sent to support@neurotechnology.com in order to complete deactivation process. Deactivation on Neurotechnology side is done manually.

Deactivation must be performed on the same computer supplied license was generated for. If license is deactivated on another computer, although call to this function will succeed, but deactivation might be refused by support@neurotechnology.com.

If method succeeds - license will be deactivated on this computer and will not be usable.


NLicense.GenerateDeactivationId Method (string)

NLicense.GenerateDeactivationId Method (string)
NLicense Class Neurotec.Licensing Namespace

Generates deactivation Id for specified provided product on current computer.

C#
public static string GenerateDeactivationId(string productName);
Collapse Expand Parameters
Parameters | Description
string productName | Long product name (i.e. Face Extractor, Finger Matcher and etc.).
Collapse Expand Returns

Generated deactivation Id.

Collapse Expand Remarks

Important! Both license and generated deactivation Id should be sent to support@neurotechnology.com in order to complete deactivation process. Deactivation on Neurotechnology side is done manually.

Important! Deactivation must be performed on the same computer supplied license was generated for. If license is deactivated on another computer, although call to this function will succeed, but deactivation might be refused by support@neurotechnology.com.

Important! If method succeeds - license will be deactivated on this computer and will not be usable.


NLicense.GenerateDeactivationId Method (string, string)

NLicense.GenerateDeactivationId Method (string, string)
NLicense Class Neurotec.Licensing Namespace

Generates deactivation Id for specified provided product on current computer.

C#
public static string GenerateDeactivationId(string idGenPath, string productName);
Collapse Expand Parameters
Parameters | Description
string idGenPath | Reserved, must be null.
string productName | Long product name (i.e. Face Extractor, Finger Matcher and etc.).
Collapse Expand Returns

Generated deactivation Id.

Collapse Expand Remarks

Important! Both license and generated deactivation Id should be sent to support@neurotechnology.com in order to complete deactivation process. Deactivation on Neurotechnology side is done manually.

Important! Deactivation must be performed on the same computer supplied license was generated for. If license is deactivated on another computer, although call to this function will succeed, but deactivation might be refused by support@neurotechnology.com.

Important! If method succeeds - license will be deactivated on this computer and will not be usable.


NLicense.GenerateDeactivationIdForLicense Method (string)

NLicense.GenerateDeactivationIdForLicense Method (string)
NLicense Class Neurotec.Licensing Namespace

Generates deactivation Id for specified license on current computer.

C#
public static string GenerateDeactivationIdForLicense(string license);
Collapse Expand Parameters
Parameters | Description
string license | License to be deactivated.
Collapse Expand Returns

Generated deactivation Id.

Collapse Expand Remarks

Important! Internet connection is required for this function to succeed.

Important! Both license and generated deactivation Id should be sent to support@neurotechnology.com in order to complete deactivation process. Deactivation on Neurotechnology side is done manually.

Important! Deactivation must be performed on the same computer supplied license was generated for. If license is deactivated on another computer, although call to this function will succeed, but deactivation might be refused by support@neurotechnology.com.


NLicense.GenerateDeactivationIdForLicense Method (string, string)

NLicense.GenerateDeactivationIdForLicense Method (string, string)
NLicense Class Neurotec.Licensing Namespace

Generates deactivation Id for specified license on current computer.

C#
public static string GenerateDeactivationIdForLicense(string idGenPath, string license);
Collapse Expand Parameters
Parameters | Description
string idGenPath | Reserved, must be null.
string license | License to be deactivated.
Collapse Expand Returns

Generated deactivation Id.

Collapse Expand Remarks

Important! Internet connection is required for this function to succeed.

Important! Both license and generated deactivation Id should be sent to support@neurotechnology.com in order to complete deactivation process. Deactivation on Neurotechnology side is done manually.

Important! Deactivation must be performed on the same computer supplied license was generated for. If license is deactivated on another computer, although call to this function will succeed, but deactivation might be refused by support@neurotechnology.com.


NLicense.GenerateId Method (string)

NLicense.GenerateId Method (string)
NLicense Class Neurotec.Licensing Namespace

Generates Id for activation from serial number for a particular machine.

C#
public static string GenerateId(string serialNumber);
Collapse Expand Parameters
Parameters | Description
string serialNumber | Serial number used for generating Id.
Collapse Expand Returns

Generated Id.


NLicense.GenerateId Method (string, string)

NLicense.GenerateId Method (string, string)
NLicense Class Neurotec.Licensing Namespace

Generates Id for activation from serial number for a particular machine.

C#
public static string GenerateId(string idGenPath, string serialNumber);
Collapse Expand Parameters
Parameters | Description
string idGenPath | Reserved, must be null.
string serialNumber | Serial number used for generating Id.
Collapse Expand Returns

Generated Id.


NLicense.GetLicenseInfoOnline Method

NLicense.GetLicenseInfoOnline Method
NLicense Class Neurotec.Licensing Namespace

Retrieves license information via internet.

C#
public static NLicenseInfo GetLicenseInfoOnline(string license);
Collapse Expand Parameters
Parameters | Description
string license | String which contains license content.
Collapse Expand Returns

NLicenseInfo object that contains properties for retrieving license information.


NLicense.GetObtainedLicenseInfo Method

NLicense.GetObtainedLicenseInfo Method
NLicense Class Neurotec.Licensing Namespace

Retrieves license information of specified product.

C#
public static NLicenseInfo GetObtainedLicenseInfo(string product);
Collapse Expand Parameters
Parameters | Description
string product | String that contains name of a product to retrieve license information.
Collapse Expand Returns

NLicenseInfo object that contains properties for retrieving license information.


NLicense.GetObtainedLicenseInfoForComponent Method

NLicense.GetObtainedLicenseInfoForComponent Method
NLicense Class Neurotec.Licensing Namespace

Retrieves license information of specified component.

C#
public static NLicenseInfo GetObtainedLicenseInfoForComponent(string component);
Collapse Expand Parameters
Parameters | Description
string component | String that contains name of a component to retrieve license information. See ObtainComponents method remarks for the list of supported component names for this parameter.
Collapse Expand Returns

NLicenseInfo object that contains properties for retrieving license information.


NLicense.GetObtainedStatus Method

NLicense.GetObtainedStatus Method
NLicense Class Neurotec.Licensing Namespace

Since license was obtained, it is possible that it became not available or remote server disconnected. Use this function to get current obtained status. Note: NLicensing automatically tries to reobtain license in case of failure, so failure status may change to LicenseObtained.

C#
public static NLicenseObtainedStatus GetObtainedStatus(string address, string port, string product);
Collapse Expand Parameters
Parameters | Description
string address |
string port |
string product |
Collapse Expand Returns

status value


NLicense.IsComponentActivated Method

NLicense.IsComponentActivated Method
NLicense Class Neurotec.Licensing Namespace

Checks if component specified by name is activated.

C#
public static bool IsComponentActivated(string component);
Collapse Expand Parameters
Parameters | Description
string component | String which contains component name. See ObtainComponents method remarks for the list of supported component names for this parameter.
Collapse Expand Returns

Boolean value indicating if the specified component was activated.


NLicense.Obtain Method (string, int, string)

NLicense.Obtain Method (string, int, string)
NLicense Class Neurotec.Licensing Namespace

Obtains license.

C#
public static bool Obtain(string address, int port, string products);
Collapse Expand Parameters
Parameters | Description
string address | Server address where license manager is installed as a server. "/local" is used for this parameter when license is tied with the computer using serial number.
int port | License manager server port.
string products | String which contains license name.
Collapse Expand Returns

Returns true if license available; otherwise, false.


NLicense.Obtain Method (string, string, string)

NLicense.Obtain Method (string, string, string)
NLicense Class Neurotec.Licensing Namespace

Obtains license.

C#
public static bool Obtain(string address, string port, string products);
Collapse Expand Parameters
Parameters | Description
string address | Server address where license manager is installed as a server. "/local" is used for this parameter when license is tied with the computer using serial number.
string port | License manager server port.
string products | String which contains license name.
Collapse Expand Returns

Returns true if license available; otherwise, false.


NLicense.ObtainComponents Method (string, int, string)

NLicense.ObtainComponents Method (string, int, string)
NLicense Class Neurotec.Licensing Namespace

Obtains component license from the specified server.

C#
public static bool ObtainComponents(string address, int port, string components);
Collapse Expand Parameters
Parameters | Description
string address | Server address where license manager is installed as a server. "/local" is used for this parameter when license is tied with the computer using serial number.
int port | License manager server port (integer value).
string components | String which contains component license name.
Collapse Expand Returns

Returns true if component license available; otherwise, false.


NLicense.ObtainComponents Method (string, string, string)

NLicense.ObtainComponents Method (string, string, string)
NLicense Class Neurotec.Licensing Namespace

Obtains component license from the specified server.

C#
public static bool ObtainComponents(string address, string port, string components);
Collapse Expand Parameters
Parameters | Description
string address | Server address where license manager is installed as a server. "/local" is used for this parameter when license is tied with the computer using serial number.
string port | License manager server port (string value).
string components | String which contains component license name.
Collapse Expand Returns

Returns true if component license available; otherwise, false.


NLicense.Release Method

NLicense.Release Method
NLicense Class Neurotec.Licensing Namespace

Releases license.

C#
public static void Release(string products);
Collapse Expand Parameters
Parameters | Description
string products | Name of a product to release its license.


NLicense.ReleaseComponents Method

NLicense.ReleaseComponents Method
NLicense Class Neurotec.Licensing Namespace

Releases component license.

C#
public static void ReleaseComponents(string components);
Collapse Expand Parameters
Parameters | Description
string components | Name of a component to release its license. See ObtainComponents method remarks for the list of supported component names for this parameter.
Collapse Expand Remarks

This method should be called as many times as method ObtainComponents was called.


NLicense.NativeType Property

NLicense.NativeType Property
NLicense Class Neurotec.Licensing Namespace

Defines the native type of the object.

C#
public static NType NativeType;


NLicenseInfo Class

NLicenseInfo Class
NObject Delegates NObject Events NObject Fields Legend Members NDisposable Methods NDisposable Properties

Provides functionality for license info retrieval.

C#
public class NLicenseInfo : NObject;
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NLicenseInfo Class
Name | Description
GetLicenses | Gets all licenses from specified NLicenseInfo.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NLicenseInfo Class
Name | Description
DistributorId | Gets distributor id.
LicenseId | Gets license Id.
NativeType | Defines the native type of the object.
SequenceNumber | Gets license sequence number.
SourceType | Gets license source type.
Status | Gets license status.
Type | Gets license type.
Container

File: NLicenseInfo.cs

Namespace: Neurotec.Licensing

Module: .NET Reference


NLicenseInfo.GetLicenses Method

NLicenseInfo.GetLicenses Method
NLicenseInfo Class Neurotec.Licensing Namespace

Gets all licenses from specified NLicenseInfo.

C#
public NLicenseProductInfo[] GetLicenses();
Collapse Expand Returns

Array containing licenses.


NLicenseInfo.DistributorId Property

NLicenseInfo.DistributorId Property
NLicenseInfo Class Neurotec.Licensing Namespace

Gets distributor id.

C#
public int DistributorId;
Property value

Id of a distributor.


NLicenseInfo.LicenseId Property

NLicenseInfo.LicenseId Property
NLicenseInfo Class Neurotec.Licensing Namespace

Gets license Id.

C#
public string LicenseId;
Property value

String which contains license Id.


NLicenseInfo.NativeType Property

NLicenseInfo.NativeType Property
NLicenseInfo Class Neurotec.Licensing Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NLicenseInfo.SequenceNumber Property

NLicenseInfo.SequenceNumber Property
NLicenseInfo Class Neurotec.Licensing Namespace

Gets license sequence number.

C#
public int SequenceNumber;
Property value

License sequence number.


NLicenseInfo.SourceType Property

NLicenseInfo.SourceType Property
NLicenseInfo Class Neurotec.Licensing Namespace

Gets license source type.

C#
public NLicenseInfoSourceType SourceType;
Property value

One of license source values.


NLicenseInfo.Status Property

NLicenseInfo.Status Property
NLicenseInfo Class Neurotec.Licensing Namespace

Gets license status.

C#
public NLicenseInfoStatus Status;
Property value

One of license status values.


NLicenseInfo.Type Property

NLicenseInfo.Type Property
NLicenseInfo Class Neurotec.Licensing Namespace

Gets license type.

C#
public NLicenseInfoType Type;
Property value

One of license type values.


NLicenseManager Class

NLicenseManager Class
Legend Members NLicenseManager Methods NLicenseManager Properties

Provides functionality for licenses management.

C#
public static class NLicenseManager;
Collapse Expand NLicenseManager Methods
Name | Description
FindFirstDongle | Retrieves handle to the first attached dongle.
FindNextDongle | ... more
GenerateLicense | Generates product license from computer Id.
GenerateLicenseEx | Generates product license from computer Id.
GenerateSerial | Generates serial number for a specified product.
GenerateSerialEx | Generates serial number for a specified product from the specified dongle.
GetDongles | Retrieves all Neurotec dongles
GetLicenseData | Retrieves license data for a specified product license.
GetLicenseDataEx | Retrieves license data for a specified product license.
GetLongProductName | Retrieves full name of a product specified by product info.
GetProductIds | Retrieves a list of all Neurotechnology products Ids.
GetShortProductName | Retrieves short name of a product from specified NLicenseProductInfo.
GetUpdateTicketInfo | Gets specified ticket number update info.
IsLicenseTypeSupported | Checks whether the specified license type is supported.
Collapse Expand NLicenseManager Properties
Name | Description
ClientId | Gets or sets application identifier to identify application if more than one appolication is used.
NLicenseTypeNativeType | Defines the native type of the license type.
NativeType | Defines the native type of the object.
ProxyHost | Gets or sets proxy server host name.
ProxyPort | Gets or sets proxy port number of licensing server.
TrialMode | Enables or disables trial mode of SDK (trial mode flag is set in Bin/Licenses/TrialFlag.txt).
UseHttps | Enables or disables https/SSL (port 443) protocol between application and remote Neurotechnology server. This feature is used only with trial or Internet License for nopg mode (when Neurotechnology Licensing Service is not used).
WritableStoragePath | Gets or sets the path of writable storage.
Container

File: NLicenseManager.cs

Namespace: Neurotec.Licensing

Module: .NET Reference


NLicenseManager.FindFirstDongle Method

NLicenseManager.FindFirstDongle Method
NLicenseManager Class Neurotec.Licensing Namespace

Retrieves handle to the first attached dongle.

C#
[Obsolete("Use GetDongles instead")]
public static NLicManDongle FindFirstDongle();
Collapse Expand Returns

If the method succeeds the return value is handle to attached dongle. Otherwise, the return value is null.

Collapse Expand Remarks

FindNextDongle and FindFirstDongle methods can be used to iterate through all attached dongles. FindNextDongle is used to get handles of all the subsequent dongles attached.


NLicenseManager.FindNextDongle Method

NLicenseManager.FindNextDongle Method
NLicenseManager Class Neurotec.Licensing Namespace

Finds next attached dongle. This method is used together with FindFirstDongle method.

C#
[Obsolete("Use GetDongles instead")]
public static NLicManDongle FindNextDongle();
Collapse Expand Returns

If the function succeeds the return value is a handle to found dongle. Otherwise, the return value is null.


NLicenseManager.GenerateLicense Method

NLicenseManager.GenerateLicense Method
NLicenseManager Class Neurotec.Licensing Namespace

Generates product license from computer Id.

C#
public static string GenerateLicense(string id, out int sequenceNumber, out uint productId);
Collapse Expand Parameters
Parameters | Description
string id | String that contains computer Id file data. You should read computer ID file to this string.
out int sequenceNumber | Sequence number used for licenses accounting.
out uint productId | ID of a product for which license was generated.
Collapse Expand Returns

If the method succeeds the return value is a string that contains generated license data.

Collapse Expand Remarks

For every generated license count of licenses in a dongle will be decreased by 1.

When generating licenses these constraints should be considered:

  1. Only one instance of license generating process should be present.
  2. pg.exe can not be started.


NLicenseManager.GenerateLicenseEx Method

NLicenseManager.GenerateLicenseEx Method
NLicenseManager Class Neurotec.Licensing Namespace

Generates product license from computer Id.

C#
public static string GenerateLicenseEx(NLicManDongle dongle, string id, out int sequenceNumber, out uint productId);
Collapse Expand Parameters
Parameters | Description
NLicManDongle dongle | dongle to generate license from
string id | String that contains computer Id file data. You should read computer ID file to this string.
out int sequenceNumber | Sequence number used for licenses accounting.
out uint productId | ID of a product for which license was generated.
Collapse Expand Returns

If the method succeeds the return value is a string that contains generated license data.

Collapse Expand Remarks

For every generated license count of licenses in a dongle will be decreased by 1.

When generating licenses these constraints should be considered:

  1. Only one instance of license generating process should be present.
  2. pg.exe can not be started.


NLicenseManager.GenerateSerial Method

NLicenseManager.GenerateSerial Method
NLicenseManager Class Neurotec.Licensing Namespace

Generates serial number for a specified product.

C#
public static string GenerateSerial(uint productId, int sequenceNumber, out int distributorId);
Collapse Expand Parameters
Parameters | Description
uint productId | Id of a product to generate serial number.
int sequenceNumber | Sequence number used for licenses accounting. User must store sequence number in own database.
out int distributorId | Id of a distributor for which serial number should be generated.
Collapse Expand Returns

If the method succeeds a string which contains generated serial number is returned.


NLicenseManager.GenerateSerialEx Method

NLicenseManager.GenerateSerialEx Method
NLicenseManager Class Neurotec.Licensing Namespace

Generates serial number for a specified product from the specified dongle.

C#
public static string GenerateSerialEx(NLicManDongle dongle, uint productId, int sequenceNumber, out int distributorId);
Collapse Expand Parameters
Parameters | Description
NLicManDongle dongle | dongle to generate serial from
uint productId | Id of a product to generate serial number.
int sequenceNumber | Sequence number used for licenses accounting. User must store sequence number in own database.
out int distributorId | Id of a distributor for which serial number should be generated.
Collapse Expand Returns

If the method succeeds a string which contains generated serial number is returned.


NLicenseManager.GetDongles Method

NLicenseManager.GetDongles Method
NLicenseManager Class Neurotec.Licensing Namespace

Retrieves all Neurotec dongles

C#
public static NLicManDongle[] GetDongles();
Collapse Expand Returns

If the method succeeds the return value is array of dongles. Otherwise exception will be thrown.


NLicenseManager.GetLicenseData Method

NLicenseManager.GetLicenseData Method
NLicenseManager Class Neurotec.Licensing Namespace

Retrieves license data for a specified product license.

C#
public static void GetLicenseData(string id, out int sequenceNumber, out uint productId, out int distributorId);
Collapse Expand Parameters
Parameters | Description
string id | A string that contains computer Id file data. Computer Id file should be scanned before passing it to method. String passed to method should contain null terminating character.
out int sequenceNumber | Sequence number used for licenses accounting.
out uint productId | Product Id.
out int distributorId | Distributor Id.


NLicenseManager.GetLicenseDataEx Method

NLicenseManager.GetLicenseDataEx Method
NLicenseManager Class Neurotec.Licensing Namespace

Retrieves license data for a specified product license.

C#
public static void GetLicenseDataEx(NLicManDongle dongle, string id, out int sequenceNumber, out uint productId, out int distributorId);
Collapse Expand Parameters
Parameters | Description
NLicManDongle dongle | dongle to get license data from
string id | A string that contains computer Id file data. Computer Id file should be scanned before passing it to method. String passed to method should contain null terminating character.
out int sequenceNumber | Sequence number used for licenses accounting.
out uint productId | Product Id.
out int distributorId | Distributor Id.


NLicenseManager.GetLongProductName Method (NLicenseProductInfo)

NLicenseManager.GetLongProductName Method (NLicenseProductInfo)
NLicenseManager Class Neurotec.Licensing Namespace

Retrieves full name of a product specified by product info.

C#
public static string GetLongProductName(NLicenseProductInfo productInfo);
Collapse Expand Parameters
Parameters | Description
NLicenseProductInfo productInfo | NLicenseProductInfo object to retrieve info.
Collapse Expand Returns

A string which contains full product name.


NLicenseManager.GetLongProductName Method (uint, NLicenseType)

NLicenseManager.GetLongProductName Method (uint, NLicenseType)
NLicenseManager Class Neurotec.Licensing Namespace

Retrieves full name of a product specified by product Id.

C#
public static string GetLongProductName(uint productId, NLicenseType licenseType);
Collapse Expand Parameters
Parameters | Description
uint productId | Id of a product to retrieve full name.
NLicenseType licenseType | Type of the licenses.
Collapse Expand Returns

A string that contains full product name specified by productID.


NLicenseManager.GetProductIds Method

NLicenseManager.GetProductIds Method
NLicenseManager Class Neurotec.Licensing Namespace

Retrieves a list of all Neurotechnology products Ids.

C#
public static uint[] GetProductIds();
Collapse Expand Returns

An UInt array that contains all products Ids.


NLicenseManager.GetShortProductName Method (NLicenseProductInfo)

NLicenseManager.GetShortProductName Method (NLicenseProductInfo)
NLicenseManager Class Neurotec.Licensing Namespace

Retrieves short name of a product from specified NLicenseProductInfo.

C#
public static string GetShortProductName(NLicenseProductInfo productInfo);
Collapse Expand Parameters
Parameters | Description
NLicenseProductInfo productInfo | NLicenseProductInfo object to retrieve short info.
Collapse Expand Returns

A string which contains a short product name.


NLicenseManager.GetShortProductName Method (uint, NLicenseType)

NLicenseManager.GetShortProductName Method (uint, NLicenseType)
NLicenseManager Class Neurotec.Licensing Namespace

Retrieves short name of a product specified by product Id.

C#
public static string GetShortProductName(uint productId, NLicenseType licenseType);
Collapse Expand Parameters
Parameters | Description
uint productId | Id of a product to retrieve short name.
NLicenseType licenseType | Type of the licenses.
Collapse Expand Returns

A string that contains short product name.


NLicenseManager.GetUpdateTicketInfo Method

NLicenseManager.GetUpdateTicketInfo Method
NLicenseManager Class Neurotec.Licensing Namespace

Gets specified ticket number update info.

C#
public static NLicManDongleUpdateTicketInfo GetUpdateTicketInfo(string ticketNumber);
Collapse Expand Parameters
Parameters | Description
string ticketNumber | Zero terminated string containing ticket number.
Collapse Expand Returns

NLicManDongleUpdateTicketInfo object.


NLicenseManager.IsLicenseTypeSupported Method

NLicenseManager.IsLicenseTypeSupported Method
NLicenseManager Class Neurotec.Licensing Namespace

Checks whether the specified license type is supported.

C#
public static bool IsLicenseTypeSupported(uint productId, NLicenseType licenseType);
Collapse Expand Parameters
Parameters | Description
uint productId | Id of a product.
NLicenseType licenseType | Type of the license.
Collapse Expand Returns

true if the license type is supported, else false.


NLicenseManager.ClientId Property

NLicenseManager.ClientId Property
NLicenseManager Class Neurotec.Licensing Namespace

Gets or sets application identifier to identify application if more than one appolication is used.

C#
public static string ClientId;
Property value

A string that contains application identifier.


NLicenseManager.NLicenseTypeNativeType Property

NLicenseManager.NLicenseTypeNativeType Property
NLicenseManager Class Neurotec.Licensing Namespace

Defines the native type of the license type.

C#
public static NType NLicenseTypeNativeType;


NLicenseManager.NativeType Property

NLicenseManager.NativeType Property
NLicenseManager Class Neurotec.Licensing Namespace

Defines the native type of the object.

C#
public static NType NativeType;


NLicenseManager.ProxyHost Property

NLicenseManager.ProxyHost Property
NLicenseManager Class Neurotec.Licensing Namespace

Gets or sets proxy server host name.

C#
public static string ProxyHost;
Property value

Host name of proxy server.


NLicenseManager.ProxyPort Property

NLicenseManager.ProxyPort Property
NLicenseManager Class Neurotec.Licensing Namespace

Gets or sets proxy port number of licensing server.

C#
public static int ProxyPort;
Property value

Proxy port number of licensing server.


NLicenseManager.TrialMode Property

NLicenseManager.TrialMode Property
NLicenseManager Class Neurotec.Licensing Namespace

Enables or disables trial mode of SDK (trial mode flag is set in Bin/Licenses/TrialFlag.txt).

C#
public static bool TrialMode;
Property value

true if trial mode is enabled; otherwise - false.


NLicenseManager.UseHttps Property

NLicenseManager.UseHttps Property
NLicenseManager Class Neurotec.Licensing Namespace

Enables or disables https/SSL (port 443) protocol between application and remote Neurotechnology server. This feature is used only with trial or Internet License for nopg mode (when Neurotechnology Licensing Service is not used).

C#
public static bool UseHttps;
Property value

true if https is enabled; otherwise - false.


NLicenseManager.WritableStoragePath Property

NLicenseManager.WritableStoragePath Property
NLicenseManager Class Neurotec.Licensing Namespace

Gets or sets the path of writable storage.

C#
public static string WritableStoragePath;
Property value

Path of writable storage.


NLicenseProductInfo Class

NLicenseProductInfo Class
NObject Delegates NObject Events NObject Fields Legend Members NDisposable Methods NDisposable Properties

Provides functionality for product info retrieval.

C#
public class NLicenseProductInfo : NObject;
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NLicenseProductInfo Class
Name | Description
Id | Gets the product ID number.
LicenseCount | Gets the product license count.
LicenseType | Gets the product license type.
NativeType | Defines the native type of the object.
OSFamily | Gets the product operating system family.
Parameters | Gets the product parameters.
Container

File: NLicenseProductInfo.cs

Namespace: Neurotec.Licensing

Module: .NET Reference


NLicenseProductInfo.Id Property

NLicenseProductInfo.Id Property
NLicenseProductInfo Class Neurotec.Licensing Namespace

Gets the product ID number.

C#
public uint Id;
Property value

Product Id number.


NLicenseProductInfo.LicenseCount Property

NLicenseProductInfo.LicenseCount Property
NLicenseProductInfo Class Neurotec.Licensing Namespace

Gets the product license count.

C#
public int LicenseCount;
Property value

License count.


NLicenseProductInfo.LicenseType Property

NLicenseProductInfo.LicenseType Property
NLicenseProductInfo Class Neurotec.Licensing Namespace

Gets the product license type.

C#
public NLicenseType LicenseType;
Property value

One of product license type values.


NLicenseProductInfo.NativeType Property

NLicenseProductInfo.NativeType Property
NLicenseProductInfo Class Neurotec.Licensing Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NLicenseProductInfo.OSFamily Property

NLicenseProductInfo.OSFamily Property
NLicenseProductInfo Class Neurotec.Licensing Namespace

Gets the product operating system family.

C#
public NOSFamily OSFamily;
Property value

One of NOSFamily values.


NLicenseProductInfo.Parameters Property

NLicenseProductInfo.Parameters Property
NLicenseProductInfo Class Neurotec.Licensing Namespace

Gets the product parameters.

C#
public NPropertyBag Parameters;
Property value

Parameters.


NLicensing Class

NLicensing Class
NLicensing Fields Legend Members NLicensing Properties

Provides methods for retrieving information about the NLicensing library.

C#
public static class NLicensing;
Collapse Expand NLicensing Fields
Name | Description
DllName | Name of DLL containing unmanaged part of this class.
Collapse Expand NLicensing Properties
Name | Description
NativeModule | Defines the native module of the object.
Container

File: NLicensing.cs

Namespace: Neurotec.Licensing

Module: .NET Reference


NLicensing.DllName Field

NLicensing.DllName Field
NLicensing Class Neurotec.Licensing Namespace

Name of DLL containing unmanaged part of this class.

C#
public const string DllName = NVersionInfo.LicensingDllName;


NLicensing.NativeModule Property

NLicensing.NativeModule Property
NLicensing Class Neurotec.Licensing Namespace

Defines the native module of the object.

C#
public static NModule NativeModule;


NLicensingService Class

NLicensingService Class
Legend Members NLicensingService Methods NLicensingService Properties

Manages licensing services.

C#
public class NLicensingService;
Collapse Expand NLicensingService Methods
Name | Description
GetBinPath | Gets the binary path (path to pg.exe) to the license.
GetConfPath | Gets path to licensing service configuration file (pgd.conf).
GetStatus | Gets the status of the licensing service.
Install | Installs licensing service.
IsTrial | Checks whether the licensing service is trial.
Start | Starts licensing service.
Stop | Stops licensing service.
Uninstall | Uninstalls licensing service.
Collapse Expand NLicensingService Properties
Name | Description
NLicensingServiceStatusNativeType | Defines the native type of the licensing service status.
NativeType | Defines the native type of the object.
Container

File: NLicensingService.cs

Namespace: Neurotec.Licensing

Module: .NET Reference


NLicensingService.GetBinPath Method

NLicensingService.GetBinPath Method
NLicensingService Class Neurotec.Licensing Namespace

Gets the binary path (path to pg.exe) to the license.

C#
public static string GetBinPath();
Collapse Expand Returns

Path to licensing service.


NLicensingService.GetConfPath Method

NLicensingService.GetConfPath Method
NLicensingService Class Neurotec.Licensing Namespace

Gets path to licensing service configuration file (pgd.conf).

C#
public static string GetConfPath();
Collapse Expand Returns

Path to licensing service configuration file.


NLicensingService.GetStatus Method

NLicensingService.GetStatus Method
NLicensingService Class Neurotec.Licensing Namespace

Gets the status of the licensing service.

C#
public static NLicensingServiceStatus GetStatus();
Collapse Expand Returns

Licensing service status value.


NLicensingService.Install Method (string)

NLicensingService.Install Method (string)
NLicensingService Class Neurotec.Licensing Namespace

Installs licensing service.

C#
public static void Install(string binPath);
Collapse Expand Parameters
Parameters | Description
string binPath | Path to licensing service file (pg.exe).


NLicensingService.Install Method (string, string)

NLicensingService.Install Method (string, string)
NLicensingService Class Neurotec.Licensing Namespace

Installs licensing service.

C#
public static void Install(string binPath, string confPath);
Collapse Expand Parameters
Parameters | Description
string binPath | Path to licensing service file (pg.exe).
string confPath | Path to licensing service configuration file (pgd.conf).


NLicensingService.IsTrial Method

NLicensingService.IsTrial Method
NLicensingService Class Neurotec.Licensing Namespace

Checks whether the licensing service is trial.

C#
public static bool IsTrial();
Collapse Expand Returns

true if the licensing service is trial; otherwise false.


NLicensingService.Start Method

NLicensingService.Start Method
NLicensingService Class Neurotec.Licensing Namespace

Starts licensing service.

C#
public static void Start();


NLicensingService.Stop Method

NLicensingService.Stop Method
NLicensingService Class Neurotec.Licensing Namespace

Stops licensing service.

C#
public static void Stop();


NLicensingService.Uninstall Method

NLicensingService.Uninstall Method
NLicensingService Class Neurotec.Licensing Namespace

Uninstalls licensing service.

C#
public static void Uninstall();


NLicensingService.NLicensingServiceStatusNativeType Property

NLicensingService.NLicensingServiceStatusNativeType Property
NLicensingService Class Neurotec.Licensing Namespace

Defines the native type of the licensing service status.

C#
public static NType NLicensingServiceStatusNativeType;


NLicensingService.NativeType Property

NLicensingService.NativeType Property
NLicensingService Class Neurotec.Licensing Namespace

Defines the native type of the object.

C#
public static NType NativeType;


Neurotec.Licensing.NLicenseInfoSourceType Enumeration

Neurotec.Licensing.NLicenseInfoSourceType Enumeration

Specifies license source type.

C#
[Serializable]
public enum NLicenseInfoSourceType {
  Unknown = 0,
  File = 1,
  Dongle = 2,
  Internet = 3
}
Collapse Expand Members
Members | Description
Unknown = 0 | License source type is unknown.
File = 1 | License source type is file.
Dongle = 2 | License source type is dongle.
Internet = 3 | License source type is internet.
Container

File: NLicenseInfo.cs

Namespace: Neurotec.Licensing

Module: .NET Reference


Neurotec.Licensing.NLicenseInfoStatus Enumeration

Neurotec.Licensing.NLicenseInfoStatus Enumeration

Specifies license status.

C#
[Serializable]
public enum NLicenseInfoStatus {
  Unknown = 0,
  Valid = 1,
  Invalid = 2
}
Collapse Expand Members
Members | Description
Unknown = 0 | License status is unknown.
Valid = 1 | License status is valid.
Invalid = 2 | License status is invalid.
Container

File: NLicenseInfo.cs

Namespace: Neurotec.Licensing

Module: .NET Reference


Neurotec.Licensing.NLicenseInfoType Enumeration

Neurotec.Licensing.NLicenseInfoType Enumeration

Specifies licensing type.

C#
[Serializable]
public enum NLicenseInfoType {
  Unknown = 0,
  SerialNumber = 1,
  HardwareId = 2,
  License = 3,
  CompanyFileLicense = 4,
  InternetLicense = 5,
  ParametricLicense = 6
}
Collapse Expand Members
Members | Description
Unknown = 0 | Licensing type is unknown.
SerialNumber = 1 | Licensing is based on a serial number.
HardwareId = 2 | Licensing is based on a hardware Id.
License = 3 | Licensing is based on a license.
CompanyFileLicense = 4 | Licensing is based on a company file license.
InternetLicense = 5 | Licensing is based on a internet license.
ParametricLicense = 6 | Licensing is based on a parametric license.
Container

File: NLicenseInfo.cs

Namespace: Neurotec.Licensing

Module: .NET Reference


Neurotec.Licensing.NLicenseType Enumeration

Neurotec.Licensing.NLicenseType Enumeration

Enumerates license type.

C#
[Serializable]
public enum NLicenseType {
  SingleComputer = 0,
  Concurrent = 1,
  Signed = 2
}
Collapse Expand Members
Members | Description
SingleComputer = 0 | Single license.
Concurrent = 1 | Concurrent license.
Signed = 2 | Signed license.
Container

File: NLicenseManager.cs

Namespace: Neurotec.Licensing

Module: .NET Reference


Neurotec.Licensing.NLicensingServiceStatus Enumeration

Neurotec.Licensing.NLicensingServiceStatus Enumeration

Enumerates licensing service status values.

C#
[Serializable]
public enum NLicensingServiceStatus {
  NotInstalled = 0,
  Stopped = 0x00000001,
  StartPending = 0x00000002,
  StopPending = 0x00000003,
  Running = 0x00000004,
  ContinuePending = 0x00000005,
  PausePending = 0x00000006,
  Paused = 0x00000007
}
Collapse Expand Members
Members | Description
NotInstalled = 0 | Indicates that licensing service is nor installed.
Stopped = 0x00000001 | Indicates that licensing service is stopped.
StartPending = 0x00000002 | Indicates that licensing service is pending to be started.
StopPending = 0x00000003 | Indicates that licensing service is pending to be stopped.
Running = 0x00000004 | Indicates that licensing service is running.
ContinuePending = 0x00000005 | Indicates that licensing service was continued after pause.
PausePending = 0x00000006 | Indicates that licensing service is pending to be paused.
Paused = 0x00000007 | Indicates that licensing service is paused.
Container

File: NLicensingService.cs

Namespace: Neurotec.Licensing

Module: .NET Reference


Neurotec.Media Namespace

Neurotec.Media Namespace
Classes Legend Structs, Records, Enums

Provides functionality for working with various type of media items: images, audio and video.

Collapse Expand Classes
Name | Description
NMedia | Provides information about NMedia library.
NMediaFormat | Provides methods to retrieve information about media formats.
NMediaReader | Provides methods which can be used to read media data.
NMediaSource | Provides methods for working with media source.
NMediaTypes | Provides methods to check if media type is valid.
NVideoFormat | Class represents video format. Each video source supports one or more video formats. Video format is used to decode (encode) video stream and extract (encode) each video frame.
Collapse Expand Structs, Records, Enums
Name | Description
NMediaState | Enumerates media state values.
NMediaType | Enumerates media type values.
NVideoInterlaceMode | Represents video interlace mode.


NMedia Class

NMedia Class
NMedia Fields Legend Members NMedia Properties

Provides information about NMedia library.

C#
public static class NMedia;
Collapse Expand NMedia Fields
Name | Description
DllName | Name of DLL containing unmanaged part of this class.
Collapse Expand NMedia Properties
Name | Description
NativeModule | Defines the native module of the object.
Container

File: NMedia.cs

Namespace: Neurotec.Media

Module: .NET Reference


NMedia.DllName Field

NMedia.DllName Field
NMedia Class Neurotec.Media Namespace

Name of DLL containing unmanaged part of this class.

C#
public const string DllName = NVersionInfo.MediaDllName;


NMedia.NativeModule Property

NMedia.NativeModule Property
NMedia Class Neurotec.Media Namespace

Defines the native module of the object.

C#
public static NModule NativeModule;


NMediaFormat Class

NMediaFormat Class
NObject Delegates NObject Events NObject Fields Legend Members NDisposable Methods NMediaFormat Operators NDisposable Properties

Provides methods to retrieve information about media formats.

C#
public class NMediaFormat : NExpandableObject, IEquatable<NMediaFormat>;
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NMediaFormat Class
Name | Description
Equals | Checks whether the current media format equal the other media format.
GetHashCode | Gets the hash code.
IsCompatibleWith | Checks if media format is compatible with other media format.
Collapse Expand NMediaFormat Operators
NMediaFormat Class
Name | Description
!= | The inequality operator used to check if specified operands are not equal.
== | Equality operator used to check if specified operands are equal.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NExpandableObject Class
Show:
No members matching the current filter
Name | Description
NativeType | Defines the native type of the object.
Properties | Gets the property bag of the expandable object.
NMediaFormat Class
Name | Description
MediaSubtype | Gets or sets media subtype from/for specified media format.
MediaType | Gets or sets media type from/for specified NMediaFormat.
NativeType | Defines the native type of the object.
Container

File: NMediaFormat.cs

Namespace: Neurotec.Media

Module: .NET Reference


NMediaFormat.Equals Method (NMediaFormat)

NMediaFormat.Equals Method (NMediaFormat)
NMediaFormat Class Neurotec.Media Namespace

Checks whether the current media format equal the other media format.

C#
public bool Equals(NMediaFormat other);
Collapse Expand Parameters
Parameters | Description
NMediaFormat other | The other media format.
Collapse Expand Returns

NTrue if the formats are equal; else NFalse.


NMediaFormat.Equals Method (object)

NMediaFormat.Equals Method (object)
NMediaFormat Class Neurotec.Media Namespace

Checks whether the current media format equals the specified media format object.

C#
public override bool Equals(object obj);
Collapse Expand Parameters
Parameters | Description
object obj | Media format object.
Collapse Expand Returns

NTrue if the media formats are equal; else NFalse.


NMediaFormat.GetHashCode Method

NMediaFormat.GetHashCode Method
NMediaFormat Class Neurotec.Media Namespace

Gets the hash code.

C#
public override int GetHashCode();
Collapse Expand Returns

The hash code.


NMediaFormat.IsCompatibleWith Method

NMediaFormat.IsCompatibleWith Method
NMediaFormat Class Neurotec.Media Namespace

Checks if media format is compatible with other media format.

C#
public bool IsCompatibleWith(NMediaFormat other);
Collapse Expand Parameters
Parameters | Description
NMediaFormat other | Other media format to check if it is compatible with the first one.
Collapse Expand Returns

true, if both media formats are compatible; false, otherwise.


NMediaFormat.!= Operator

NMediaFormat.!= Operator
NMediaFormat Class Neurotec.Media Namespace

The inequality operator used to check if specified operands are not equal.

C#
public static bool operator !=(NMediaFormat value1, NMediaFormat value2);
Collapse Expand Parameters
Parameters | Description
NMediaFormat value1 | The first value to check.
NMediaFormat value2 | The second value to check.
Collapse Expand Returns

true if the values of its operands are different, false otherwise.


NMediaFormat.== Operator

NMediaFormat.== Operator
NMediaFormat Class Neurotec.Media Namespace

Equality operator used to check if specified operands are equal.

C#
public static bool operator ==(NMediaFormat value1, NMediaFormat value2);
Collapse Expand Parameters
Parameters | Description
NMediaFormat value1 | The first value to check.
NMediaFormat value2 | The second value to check.
Collapse Expand Returns

true if the values of its operands are equal, false otherwise.


NMediaFormat.MediaSubtype Property

NMediaFormat.MediaSubtype Property
NMediaFormat Class Neurotec.Media Namespace

Gets or sets media subtype from/for specified media format.

C#
public int MediaSubtype;
Property value

Subtype constant to set.


NMediaFormat.MediaType Property

NMediaFormat.MediaType Property
NMediaFormat Class Neurotec.Media Namespace

Gets or sets media type from/for specified NMediaFormat.

C#
public NMediaType MediaType;
Property value

One of media type values. At the moment only Audio and Video can be used.


NMediaFormat.NativeType Property

NMediaFormat.NativeType Property
NMediaFormat Class Neurotec.Media Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NMediaReader Class

NMediaReader Class
NObject Delegates NObject Events NObject Fields Legend Members Methods NDisposable Methods NDisposable Properties

Provides methods which can be used to read media data.

C#
public sealed class NMediaReader : NObject;
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NMediaReader Class
Name | Description
Pause | Pauses specified NMediaReader.
ReadAudioSample | Reads audio sample to NSoundBuffer
ReadVideoSample | Reads video sample using NMediaReader.
ReadVideoSampleData | Reads video sample using NMediaReader.
Start | Starts NMediaReader.
Stop | Stops NMediaReader.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NMediaReader Class
Name | Description
IsLive | Checks if media source which is used by NMediaReader is live.
Length | Gets file length when NMediaReader source is file.
NativeType | Defines the native type of the object.
Position | Gets or sets NMediaReader position in media source (file).
Source | Gets media source (file or device) of the NMediaReader.
State | Gets NMediaReader state.
Container

File: NMediaReader.cs

Namespace: Neurotec.Media

Module: .NET Reference


NMediaReader.NMediaReader Constructor (NMediaSource, NMediaType, bool)

NMediaReader.NMediaReader Constructor (NMediaSource, NMediaType, bool)
NMediaReader Class Neurotec.Media Namespace

Creates new instance of NMediaReader.

C#
public NMediaReader(NMediaSource source, NMediaType mediaTypes, bool isLive);
Collapse Expand Parameters
Parameters | Description
NMediaSource source | Media source from which NMediaReader will be created.
NMediaType mediaTypes | Media types supported by NMediaReader. Can be Audio and Video (only one at a time or both).
bool isLive | Flag indicating if media source is live. If set to true media from source will be read in real time (from devices). In this case video or audio samples will be dropped until user calls ReadAudioSample or ReadVideoSample functions. If user calls these functions too quickly they are blocked until new video frame or audio sample appears. If set to false video frames or audio samples are not dropped and user can read them in any speed (gets all samples/frames). When set to false, NMediaReader works only with video/audio data saved in files.


NMediaReader.NMediaReader Constructor (NMediaSource, NMediaType, bool, uint)

NMediaReader.NMediaReader Constructor (NMediaSource, NMediaType, bool, uint)
NMediaReader Class Neurotec.Media Namespace

Creates new instance of NMediaReader.

C#
public NMediaReader(NMediaSource source, NMediaType mediaTypes, bool isLive, uint flags);
Collapse Expand Parameters
Parameters | Description
NMediaSource source | Media source from which NMediaReader will be created.
NMediaType mediaTypes | Media types supported by NMediaReader. Can be Audio and Video (only one at a time or both).
bool isLive | Flag indicating if media source is live. If set to true media from source will be read in real time (from devices). In this case video or audio samples will be dropped until user calls ReadAudioSample or ReadVideoSample functions. If user calls these functions too quickly they are blocked until new video frame or audio sample appears. If set to false video frames or audio samples are not dropped and user can read them in any speed (gets all samples/frames). When set to false, NMediaReader works only with video/audio data saved in files.
uint flags | Flags controlling NMediaReader.
Collapse Expand Remarks

These flags can be used (for flags parameter):

  • FlagDoNotUseDirectShow
  • FlagDoNotUseWindowsMediaFoundation
  • FlagPreferDirectShow

These flags work only on Windows OS.


NMediaReader.NMediaReader Constructor (Uri, NMediaType, bool)

NMediaReader.NMediaReader Constructor (Uri, NMediaType, bool)
NMediaReader Class Neurotec.Media Namespace

Creates new instance of NMediaReader from specified Url.

C#
public NMediaReader(Uri url, NMediaType mediaTypes, bool isLive);
Collapse Expand Parameters
Parameters | Description
Uri url | Uniform resource identifier (URI) which contains URL address (address of IP camera).
NMediaType mediaTypes | Media types supported by NMediaReader. Can be Audio and Video (only one at a time or both).
bool isLive | Flag indicating if media source is live. If set to true media from source will be read in real time (from devices). In this case video or audio samples will be dropped until user calls ReadAudioSample or ReadVideoSample functions. If user calls these functions too quickly they are blocked until new video frame or audio sample appears. If set to false video frames or audio samples are not dropped and user can read them in any speed (gets all samples/frames). When set to false, NMediaReader works only with video/audio data saved in files.


NMediaReader.NMediaReader Constructor (Uri, NMediaType, bool, uint)

NMediaReader.NMediaReader Constructor (Uri, NMediaType, bool, uint)
NMediaReader Class Neurotec.Media Namespace

Creates new instance of NMediaReader from specified Url.

C#
public NMediaReader(Uri url, NMediaType mediaTypes, bool isLive, uint flags);
Collapse Expand Parameters
Parameters | Description
Uri url | Uniform resource identifier (URI) which contains URL address (address of IP camera).
NMediaType mediaTypes | Media types supported by NMediaReader. Can be Audio and Video (only one at a time or both).
bool isLive | Flag indicating if media source is live. If set to true media from source will be read in real time (from devices). In this case video or audio samples will be dropped until user calls ReadAudioSample or ReadVideoSample functions. If user calls these functions too quickly they are blocked until new video frame or audio sample appears. If set to false video frames or audio samples are not dropped and user can read them in any speed (gets all samples/frames). When set to false, NMediaReader works only with video/audio data saved in files.
uint flags | Flags controlling NMediaReader.
Collapse Expand Remarks

These flags can be used (for flags parameter):

  • FlagDoNotUseDirectShow
  • FlagDoNotUseWindowsMediaFoundation
  • FlagPreferDirectShow

These flags work only on Windows OS.


NMediaReader.NMediaReader Constructor (string, NMediaType, bool)

NMediaReader.NMediaReader Constructor (string, NMediaType, bool)
NMediaReader Class Neurotec.Media Namespace

Creates new instance of NMediaReader from specified file.

C#
public NMediaReader(string fileName, NMediaType mediaTypes, bool isLive);
Collapse Expand Parameters
Parameters | Description
string fileName | File name. The specified file should contain media source.
NMediaType mediaTypes | Media types supported by NMediaReader. Can be Audio and Video (only one at a time or both).
bool isLive | Flag indicating if media source is live. If set to true media from source will be read in real time (from devices). In this case video or audio samples will be dropped until user calls ReadAudioSample or ReadVideoSample functions. If user calls these functions too quickly they are blocked until new video frame or audio sample appears. If set to false video frames or audio samples are not dropped and user can read them in any speed (gets all samples/frames). When set to false, NMediaReader works only with video/audio data saved in files.


NMediaReader.NMediaReader Constructor (string, NMediaType, bool, bool)

NMediaReader.NMediaReader Constructor (string, NMediaType, bool, bool)
NMediaReader Class Neurotec.Media Namespace

Creates new instance of NMediaReader from specified file or Url.

C#
public NMediaReader(string fileNameOrUrl, NMediaType mediaTypes, bool isLive, bool isUrl);
Collapse Expand Parameters
Parameters | Description
string fileNameOrUrl | String representation of file name or URL. The specified file should contain media source.
NMediaType mediaTypes | Media types supported by NMediaReader. Can be Audio and Video (only one at a time or both).
bool isLive | Flag indicating if media source is live. If set to true media from source will be read in real time (from devices). In this case video or audio samples will be dropped until user calls ReadAudioSample or ReadVideoSample functions. If user calls these functions too quickly they are blocked until new video frame or audio sample appears. If set to false video frames or audio samples are not dropped and user can read them in any speed (gets all samples/frames). When set to false, NMediaReader works only with video/audio data saved in files.
bool isUrl | Flag indicating if media source is from Url (IP camera).


NMediaReader.NMediaReader Constructor (string, NMediaType, bool, bool, uint)

NMediaReader.NMediaReader Constructor (string, NMediaType, bool, bool, uint)
NMediaReader Class Neurotec.Media Namespace

Creates new instance of NMediaReader from specified file or Url.

C#
public NMediaReader(string fileNameOrUrl, NMediaType mediaTypes, bool isLive, bool isUrl, uint flags);
Collapse Expand Parameters
Parameters | Description
string fileNameOrUrl | String representation of file name or URL. The specified file should contain media source.
NMediaType mediaTypes | Media types supported by NMediaReader. Can be Audio and Video (only one at a time or both).
bool isLive | Flag indicating if media source is live. If set to true media from source will be read in real time (from devices). In this case video or audio samples will be dropped until user calls ReadAudioSample or ReadVideoSample functions. If user calls these functions too quickly they are blocked until new video frame or audio sample appears. If set to false video frames or audio samples are not dropped and user can read them in any speed (gets all samples/frames). When set to false, NMediaReader works only with video/audio data saved in files.
bool isUrl | Flag indicating if media source is from Url (IP camera).
uint flags | Flags controlling NMediaReader.
Collapse Expand Remarks

These flags can be used (for flags parameter):

  • FlagDoNotUseDirectShow
  • FlagDoNotUseWindowsMediaFoundation
  • FlagPreferDirectShow

These flags work only on Windows OS.


NMediaReader.NMediaReader Constructor (string, NMediaType, bool, uint)

NMediaReader.NMediaReader Constructor (string, NMediaType, bool, uint)
NMediaReader Class Neurotec.Media Namespace

Creates new instance of NMediaReader from specified file.

C#
public NMediaReader(string fileName, NMediaType mediaTypes, bool isLive, uint flags);
Collapse Expand Parameters
Parameters | Description
string fileName | File name. The specified file should contain media source.
NMediaType mediaTypes | Media types supported by NMediaReader. Can be Audio and Video (only one at a time or both).
bool isLive | Flag indicating if media source is live. If set to true media from source will be read in real time (from devices). In this case video or audio samples will be dropped until user calls ReadAudioSample or ReadVideoSample functions. If user calls these functions too quickly they are blocked until new video frame or audio sample appears. If set to false video frames or audio samples are not dropped and user can read them in any speed (gets all samples/frames). When set to false, NMediaReader works only with video/audio data saved in files.
uint flags | Flags controlling NMediaReader.
Collapse Expand Remarks

These flags can be used (for flags parameter):

  • FlagDoNotUseDirectShow
  • FlagDoNotUseWindowsMediaFoundation
  • FlagPreferDirectShow

These flags work only on Windows OS.


NMediaReader.Pause Method

NMediaReader.Pause Method
NMediaReader Class Neurotec.Media Namespace

Pauses specified NMediaReader.

C#
public void Pause();


NMediaReader.ReadAudioSample Method ()

NMediaReader.ReadAudioSample Method ()
NMediaReader Class Neurotec.Media Namespace

Reads audio sample to NSoundBuffer

C#
public NSoundBuffer ReadAudioSample();
Collapse Expand Returns

NSoundBuffer which contains audio sample

Collapse Expand Remarks

Before using this method user should start NMediaReader using Neurotec.Media.NMediaReader.Start method.

For more information on how to use this method see ReadAudio and ReadAudioFromDevice tutorials.


NMediaReader.ReadAudioSample Method (out TimeSpan, out TimeSpan)

NMediaReader.ReadAudioSample Method (out TimeSpan, out TimeSpan)
NMediaReader Class Neurotec.Media Namespace

Reads audio sample to NSoundBuffer

C#
public NSoundBuffer ReadAudioSample(out TimeSpan timeStamp, out TimeSpan duration);
Collapse Expand Parameters
Parameters | Description
out TimeSpan timeStamp | Time stamp (from the beginning). 100ns units.
out TimeSpan duration | Audio sample duration (100ns units).
Collapse Expand Returns

NSoundBuffer which contains audio sample

Collapse Expand Remarks

Before using this method user should start NMediaReader using Neurotec.Media.NMediaReader.Start method.

For more information on how to use this method see ReadAudio and ReadAudioFromDevice tutorials.


NMediaReader.ReadVideoSample Method ()

NMediaReader.ReadVideoSample Method ()
NMediaReader Class Neurotec.Media Namespace

Reads video sample using NMediaReader.

C#
public NImage ReadVideoSample();
Collapse Expand Returns

NImage which contains video sample (frame).

Collapse Expand Remarks

Before using this method user should start NMediaReader using Neurotec.Media.NMediaReader.Start.

For more information on how to use this method see ReadVideo and ReadVideoFromDevice tutorials.


NMediaReader.ReadVideoSample Method (out TimeSpan, out TimeSpan)

NMediaReader.ReadVideoSample Method (out TimeSpan, out TimeSpan)
NMediaReader Class Neurotec.Media Namespace

Reads video sample using NMediaReader.

C#
public NImage ReadVideoSample(out TimeSpan timeStamp, out TimeSpan duration);
Collapse Expand Parameters
Parameters | Description
out TimeSpan timeStamp | Time stamp (from the beginning). 100ns units.
out TimeSpan duration | Video sample duration (100ns units).
Collapse Expand Returns

NImage which contains video sample (frame).

Collapse Expand Remarks

Before using this method user should start NMediaReader using Neurotec.Media.NMediaReader.Start.

For more information on how to use this method see ReadVideo and ReadVideoFromDevice tutorials.


NMediaReader.ReadVideoSampleData Method

NMediaReader.ReadVideoSampleData Method
NMediaReader Class Neurotec.Media Namespace

Reads video sample using NMediaReader.

C#
public NVideoSample ReadVideoSampleData();
Collapse Expand Returns

NVideoSample which contains video sample (frame).

Collapse Expand Remarks

Before using this method user should start NMediaReader using Neurotec.Media.NMediaReader.Start.

For more information on how to use this method see ReadVideo and ReadVideoFromDevice tutorials.


NMediaReader.Start Method

NMediaReader.Start Method
NMediaReader Class Neurotec.Media Namespace

Starts NMediaReader.

C#
public void Start();


NMediaReader.Stop Method

NMediaReader.Stop Method
NMediaReader Class Neurotec.Media Namespace

Stops NMediaReader.

C#
public void Stop();


NMediaReader.IsLive Property

NMediaReader.IsLive Property
NMediaReader Class Neurotec.Media Namespace

Checks if media source which is used by NMediaReader is live.

C#
public bool IsLive;
Property value

true if media source is live; false otherwise.


NMediaReader.Length Property

NMediaReader.Length Property
NMediaReader Class Neurotec.Media Namespace

Gets file length when NMediaReader source is file.

C#
public TimeSpan Length;
Property value

Time interval (TimeSpan) representing file length.


NMediaReader.NativeType Property

NMediaReader.NativeType Property
NMediaReader Class Neurotec.Media Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NMediaReader.Position Property

NMediaReader.Position Property
NMediaReader Class Neurotec.Media Namespace

Gets or sets NMediaReader position in media source (file).

C#
public TimeSpan Position;
Property value

Time interval (TimeSpan) representing NMediaReader position in media source.


NMediaReader.Source Property

NMediaReader.Source Property
NMediaReader Class Neurotec.Media Namespace

Gets media source (file or device) of the NMediaReader.

C#
public NMediaSource Source;
Property value

Media source which type is NMediaSource.


NMediaReader.State Property

NMediaReader.State Property
NMediaReader Class Neurotec.Media Namespace

Gets NMediaReader state.

C#
public NMediaState State;
Property value

One of NMediaState values.


NMediaSource Class

NMediaSource Class
NObject Delegates NObject Events NObject Fields Legend Members NDisposable Methods NMediaSource Operators NDisposable Properties

Provides methods for working with media source.

C#
public sealed class NMediaSource : NObject, IEquatable<NMediaSource>, ICloneable;
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NMediaSource Class
Name | Description
FlagAllowDuplicateDevices | This field is used to allow enumerating duplicate devices. If this field was set and the same device is accessible through DirectShow and Windows Media Foundation (Windows 7) then this device will be enumerated twice.
FlagDoNotUseDirectShow | Used when user prefers not to use DirecShow for NMediaSource.
FlagDoNotUseVlc | Used when user prefers not to use VLC for NMediaSource.
FlagDoNotUseWindowsMedia | Used when user prefers not to use Windows Media for NMediaSource.
FlagDoNotUseWindowsMediaFoundation | Used when user prefers not to use Windows Media Foundation for NMediaSource.
FlagPreferDirectShow | Used when user prefers to use DirectShow for NMediaSource.
FlagPreferVlc | Used when user prefers to use VLC for NMediaSource.
FlagPreferWindowsMedia | Used when user prefers to use Windows Media for NMediaSource.
FlagPreferWindowsMediaFoundation | Used when user prefers to use Media Foundation for NMediaSource.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NMediaSource Class
Name | Description
EnumDevices | Enumerates all source devices by specified media type.
Equals | Determines whether the specified NMediaSource is equal to the current NMediaSource.
FromFile | Creates NMediaSource from specified file.
FromUrl | Gets the media source from specified URL.
GetCurrentFormat | Gets the current media format of the specified media type.
GetFormats | Gets the media formats of specified media type.
GetHashCode | Gets the hash code.
SetCurrentFormat | Sets the current media format of the specified media type to specified value.
Collapse Expand NMediaSource Operators
NMediaSource Class
Name | Description
!= | Checks whether two NMediaSource values are not equal.
== | Checks whether two NMediaSource values are equal.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NMediaSource Class
Name | Description
DisplayName | Gets the display name of the current media source.
Id | Gets the ID of the current media source.
MediaType | Gets the media type of the current media source.
NativeType | Defines the native type of the object.
Container

File: NMediaSource.cs

Namespace: Neurotec.Media

Module: .NET Reference


NMediaSource.FlagAllowDuplicateDevices Field

NMediaSource.FlagAllowDuplicateDevices Field
NMediaSource Class Neurotec.Media Namespace

This field is used to allow enumerating duplicate devices. If this field was set and the same device is accessible through DirectShow and Windows Media Foundation (Windows 7) then this device will be enumerated twice.

C#
public const uint FlagAllowDuplicateDevices = 0x00000008;


NMediaSource.FlagDoNotUseDirectShow Field

NMediaSource.FlagDoNotUseDirectShow Field
NMediaSource Class Neurotec.Media Namespace

Used when user prefers not to use DirecShow for NMediaSource.

C#
public const uint FlagDoNotUseDirectShow = 0x00000001;


NMediaSource.FlagDoNotUseVlc Field

NMediaSource.FlagDoNotUseVlc Field
NMediaSource Class Neurotec.Media Namespace

Used when user prefers not to use VLC for NMediaSource.

C#
public const uint FlagDoNotUseVlc = 0x00000020;


NMediaSource.FlagDoNotUseWindowsMedia Field

NMediaSource.FlagDoNotUseWindowsMedia Field
NMediaSource Class Neurotec.Media Namespace

Used when user prefers not to use Windows Media for NMediaSource.

C#
public const uint FlagDoNotUseWindowsMedia = 0x00000010;


NMediaSource.FlagDoNotUseWindowsMediaFoundation Field

NMediaSource.FlagDoNotUseWindowsMediaFoundation Field
NMediaSource Class Neurotec.Media Namespace

Used when user prefers not to use Windows Media Foundation for NMediaSource.

C#
public const uint FlagDoNotUseWindowsMediaFoundation = 0x00000002;


NMediaSource.FlagPreferDirectShow Field

NMediaSource.FlagPreferDirectShow Field
NMediaSource Class Neurotec.Media Namespace

Used when user prefers to use DirectShow for NMediaSource.

C#
public const uint FlagPreferDirectShow = 0x00000004;


NMediaSource.FlagPreferVlc Field

NMediaSource.FlagPreferVlc Field
NMediaSource Class Neurotec.Media Namespace

Used when user prefers to use VLC for NMediaSource.

C#
public const uint FlagPreferVlc = 0x00000100;


NMediaSource.FlagPreferWindowsMedia Field

NMediaSource.FlagPreferWindowsMedia Field
NMediaSource Class Neurotec.Media Namespace

Used when user prefers to use Windows Media for NMediaSource.

C#
public const uint FlagPreferWindowsMedia = 0x00000080;


NMediaSource.FlagPreferWindowsMediaFoundation Field

NMediaSource.FlagPreferWindowsMediaFoundation Field
NMediaSource Class Neurotec.Media Namespace

Used when user prefers to use Media Foundation for NMediaSource.

C#
public const uint FlagPreferWindowsMediaFoundation = 0x00000040;


NMediaSource.EnumDevices Method (NMediaType)

NMediaSource.EnumDevices Method (NMediaType)
NMediaSource Class Neurotec.Media Namespace

Enumerates all source devices by specified media type.

C#
public static NMediaSource[] EnumDevices(NMediaType mediaType);
Collapse Expand Parameters
Parameters | Description
NMediaType mediaType | Device media type.
Collapse Expand Returns

Devices array of NMediaSource type.


NMediaSource.EnumDevices Method (NMediaType, uint)

NMediaSource.EnumDevices Method (NMediaType, uint)
NMediaSource Class Neurotec.Media Namespace

Enumerates all source devices by specified media type.

C#
public static NMediaSource[] EnumDevices(NMediaType mediaType, uint flags);
Collapse Expand Parameters
Parameters | Description
NMediaType mediaType | Device media type.
uint flags | Flags controlling NMediaSource.
Collapse Expand Returns

Devices array of NMediaSource type.


NMediaSource.Equals Method (NMediaSource)

NMediaSource.Equals Method (NMediaSource)
NMediaSource Class Neurotec.Media Namespace

Determines whether the specified NMediaSource is equal to the current NMediaSource.

C#
public bool Equals(NMediaSource other);
Collapse Expand Parameters
Parameters | Description
NMediaSource other | The NMediaSource object to compare with the current NMediaSource.
Collapse Expand Returns

true if the specified NMediaSource is equal to the current NMediaSource; otherwise, false.


NMediaSource.Equals Method (object)

NMediaSource.Equals Method (object)
NMediaSource Class Neurotec.Media Namespace

Checks whether the current NMediaSource equals the specified object.

C#
public override bool Equals(object obj);
Collapse Expand Parameters
Parameters | Description
object obj | The specified object.
Collapse Expand Returns

NTrue, if objects are equal; else NFalse.


NMediaSource.FromFile Method (string)

NMediaSource.FromFile Method (string)
NMediaSource Class Neurotec.Media Namespace

Creates NMediaSource from specified file.

C#
public static NMediaSource FromFile(string fileName);
Collapse Expand Parameters
Parameters | Description
string fileName | String containing file name.
Collapse Expand Returns

Media source from file.


NMediaSource.FromFile Method (string, uint)

NMediaSource.FromFile Method (string, uint)
NMediaSource Class Neurotec.Media Namespace

Creates NMediaSource from specified file.

C#
public static NMediaSource FromFile(string fileName, uint flags);
Collapse Expand Parameters
Parameters | Description
string fileName | String containing file name.
uint flags | Flags controlling NMediaSource.
Collapse Expand Returns

Media source from file.

Collapse Expand Remarks

Created NMediaSource is used by NMediaReader to read data.

These flags can be used (for flags parameter):

  • FlagDoNotUseDirectShow
  • FlagDoNotUseWindowsMediaFoundation
  • FlagPreferDirectShow

Note: these flags work only on Windows OS.


NMediaSource.FromUrl Method (Uri)

NMediaSource.FromUrl Method (Uri)
NMediaSource Class Neurotec.Media Namespace

Gets the media source from specified URL.

C#
public static NMediaSource FromUrl(Uri url);
Collapse Expand Parameters
Parameters | Description
Uri url | The URL containing the media source.
Collapse Expand Returns

The media source.


NMediaSource.FromUrl Method (Uri, uint)

NMediaSource.FromUrl Method (Uri, uint)
NMediaSource Class Neurotec.Media Namespace

Gets the media source from specified URL.

C#
public static NMediaSource FromUrl(Uri url, uint flags);
Collapse Expand Parameters
Parameters | Description
Uri url | The URL containing the media source.
uint flags | Flags controlling NMediaSource.
Collapse Expand Returns

The media source.


NMediaSource.FromUrl Method (string)

NMediaSource.FromUrl Method (string)
NMediaSource Class Neurotec.Media Namespace

Gets the media source from specified URL.

C#
public static NMediaSource FromUrl(string url);
Collapse Expand Parameters
Parameters | Description
string url | The URL containing the media source.
Collapse Expand Returns

The media source.


NMediaSource.FromUrl Method (string, uint)

NMediaSource.FromUrl Method (string, uint)
NMediaSource Class Neurotec.Media Namespace

Gets the media source from specified URL.

C#
public static NMediaSource FromUrl(string url, uint flags);
Collapse Expand Parameters
Parameters | Description
string url | The URL containing the media source.
uint flags | Flags controlling NMediaSource.
Collapse Expand Returns

The media source.


NMediaSource.GetCurrentFormat Method

NMediaSource.GetCurrentFormat Method
NMediaSource Class Neurotec.Media Namespace

Gets the current media format of the specified media type.

C#
public NMediaFormat GetCurrentFormat(NMediaType mediaType);
Collapse Expand Parameters
Parameters | Description
NMediaType mediaType | The specified media type.
Collapse Expand Returns

The current media format.


NMediaSource.GetFormats Method

NMediaSource.GetFormats Method
NMediaSource Class Neurotec.Media Namespace

Gets the media formats of specified media type.

C#
public NMediaFormat[] GetFormats(NMediaType mediaType);
Collapse Expand Parameters
Parameters | Description
NMediaType mediaType | The specified media type.
Collapse Expand Returns

Array of media formats.


NMediaSource.GetHashCode Method

NMediaSource.GetHashCode Method
NMediaSource Class Neurotec.Media Namespace

Gets the hash code.

C#
public override int GetHashCode();
Collapse Expand Returns

The hash code.


NMediaSource.SetCurrentFormat Method

NMediaSource.SetCurrentFormat Method
NMediaSource Class Neurotec.Media Namespace

Sets the current media format of the specified media type to specified value.

C#
public void SetCurrentFormat(NMediaType mediaType, NMediaFormat format);
Collapse Expand Parameters
Parameters | Description
NMediaType mediaType | The specified media type.
NMediaFormat format | New media format value.


NMediaSource.!= Operator

NMediaSource.!= Operator
NMediaSource Class Neurotec.Media Namespace

Checks whether two NMediaSource values are not equal.

C#
public static bool operator !=(NMediaSource value1, NMediaSource value2);
Collapse Expand Parameters
Parameters | Description
NMediaSource value1 | First NMediaSource value.
NMediaSource value2 | Second NMediaSource value.
Collapse Expand Returns

NTrue, if NMediaSource values are not equal; else NFalse.


NMediaSource.== Operator

NMediaSource.== Operator
NMediaSource Class Neurotec.Media Namespace

Checks whether two NMediaSource values are equal.

C#
public static bool operator ==(NMediaSource value1, NMediaSource value2);
Collapse Expand Parameters
Parameters | Description
NMediaSource value1 | First NMediaSource value.
NMediaSource value2 | Second NMediaSource value.
Collapse Expand Returns

NTrue, if NMediaSource values are equal; else NFalse.


NMediaSource.DisplayName Property

NMediaSource.DisplayName Property
NMediaSource Class Neurotec.Media Namespace

Gets the display name of the current media source.

C#
public string DisplayName;


NMediaSource.Id Property

NMediaSource.Id Property
NMediaSource Class Neurotec.Media Namespace

Gets the ID of the current media source.

C#
public string Id;


NMediaSource.MediaType Property

NMediaSource.MediaType Property
NMediaSource Class Neurotec.Media Namespace

Gets the media type of the current media source.

C#
public NMediaType MediaType;


NMediaSource.NativeType Property

NMediaSource.NativeType Property
NMediaSource Class Neurotec.Media Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NMediaTypes Class

NMediaTypes Class
Legend Members NMediaTypes Methods NMediaTypes Properties

Provides methods to check if media type is valid.

C#
public static class NMediaTypes;
Collapse Expand NMediaTypes Methods
Name | Description
IsMediaTypeValid | Checks whether the specified media type is valid.
IsMediaTypeValidSingle | Checks if the single value passed to a method is a valid media type.
IsVideoInterlaceModeValid | Checks whether the video interlace mode is valid.
Collapse Expand NMediaTypes Properties
Name | Description
NMediaStateNativeType | Defines the native type of the media state.
NMediaTypeNativeType | Defines the native type of the media type.
NVideoInterlaceModeNativeType | Defines the native type of the video interlace mode.
NativeType | Defines the native type of the object.
Container

File: NMediaTypes.cs

Namespace: Neurotec.Media

Module: .NET Reference


NMediaTypes.IsMediaTypeValid Method

NMediaTypes.IsMediaTypeValid Method
NMediaTypes Class Neurotec.Media Namespace

Checks whether the specified media type is valid.

C#
public static bool IsMediaTypeValid(NMediaType value);
Collapse Expand Parameters
Parameters | Description
NMediaType value | The media type.
Collapse Expand Returns

NTrue if the media type is valid; else NFalse.


NMediaTypes.IsMediaTypeValidSingle Method

NMediaTypes.IsMediaTypeValidSingle Method
NMediaTypes Class Neurotec.Media Namespace

Checks if the single value passed to a method is a valid media type.

C#
public static bool IsMediaTypeValidSingle(NMediaType value);
Collapse Expand Parameters
Parameters | Description
NMediaType value | One of NMediaTypes values to check.
Collapse Expand Returns

true if specified value is valid; false, otherwise.


NMediaTypes.IsVideoInterlaceModeValid Method

NMediaTypes.IsVideoInterlaceModeValid Method
NMediaTypes Class Neurotec.Media Namespace

Checks whether the video interlace mode is valid.

C#
public static bool IsVideoInterlaceModeValid(NVideoInterlaceMode value);
Collapse Expand Parameters
Parameters | Description
NVideoInterlaceMode value | The video interlace mode.
Collapse Expand Returns

NTrue, if the video interlace mode is valid; else NFalse.


NMediaTypes.NMediaStateNativeType Property

NMediaTypes.NMediaStateNativeType Property
NMediaTypes Class Neurotec.Media Namespace

Defines the native type of the media state.

C#
public static NType NMediaStateNativeType;


NMediaTypes.NMediaTypeNativeType Property

NMediaTypes.NMediaTypeNativeType Property
NMediaTypes Class Neurotec.Media Namespace

Defines the native type of the media type.

C#
public static NType NMediaTypeNativeType;


NMediaTypes.NVideoInterlaceModeNativeType Property

NMediaTypes.NVideoInterlaceModeNativeType Property
NMediaTypes Class Neurotec.Media Namespace

Defines the native type of the video interlace mode.

C#
public static NType NVideoInterlaceModeNativeType;


NMediaTypes.NativeType Property

NMediaTypes.NativeType Property
NMediaTypes Class Neurotec.Media Namespace

Defines the native type of the object.

C#
public static NType NativeType;


NVideoFormat Class

NVideoFormat Class
NObject Delegates NObject Events NObject Fields Legend Members Methods NDisposable Methods NMediaFormat Operators NDisposable Properties

Class represents video format. Each video source supports one or more video formats. Video format is used to decode (encode) video stream and extract (encode) each video frame.

C#
public sealed class NVideoFormat : NMediaFormat;
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NVideoFormat Class
Name | Description
AI44 | Value for video format AI44.
Argb32 | Value for video format RGB, 32 bpp with alpha channel.
Ayuv | Value for video format AYUV.
DV25 | Value for video format DVCPRO 25 (525-60 or 625-50).
DV50 | Value for video format DVCPRO 50 (525-60 or 625-50).
DX50 | Value for video format DX50.
Dvc | Value for video format DVC/DV Video.
Dvh1 | Value for video format DVC/DV Video.
Dvhd | Value for video format HD-DVCR (1125-60 or 1250-50).
Dvsd | Value for video format SDL-DVCR (525-60 or 625-50).
Dvsl | Value for video format SD-DVCR (525-60 or 625-50).
H264 | Value for video format H.264.
I420 | Value for video format I420.
Iyuv | Value for video format IYUV.
L16 | Value for video format L16.
L8 | Value for video format L8.
M4S2 | Value for video format MPEG-4 part 2 video.
MP43 | Value for video format Microsoft MPEG 4 codec version 3.
MP4S | Value for video format ISO MPEG 4 codec version 1.
MP4V | Value for video format MPEG-4 part 2 video.
Mjpg | Value for video format Motion JPEG.
Mpg1 | Value for video format MPEG-1 video.
Mss1 | Value for video format Windows Media Screen codec version 1.
Mss2 | Value for video format Windows Media Video 9 Screen codec.
NV11 | Value for video format NV11.
NV12 | Value for video format NV12.
NV21 | Value for video format NV21.
P010 | Value for video format P010.
P016 | Value for video format P016.
P210 | Value for video format P210.
P216 | Value for video format P216.
Rgb24 | Value for video format RGB, 24 bpp.
Rgb32 | Value for video format RGB, 32 bpp.
Rgb555 | Value for video format RGB 555, 16 bpp.
Rgb565 | Value for video format RGB 565, 16 bpp.
Rgb8 | Value for video format RGB, 8bpp.
Unknown | Value for unknown video format.
Uyvy | Value for video format UYVY.
V210 | Value for video format V210.
V216 | Value for video format V216.
V410 | Value for video format V40.
Wmv1 | Value for video format Windows Media Video codec version 7.
Wmv2 | Value for video format Windows Media Video 8 codec.
Wmv3 | Value for video format Windows Media Video 9 codec.
Wvc1 | Value for video format SMPTE 421M ("VC-1").
Y210 | Value for video format Y210.
Y216 | Value for video format Y216.
Y410 | Value for video format Y40.
Y416 | Value for video format Y416.
Y41P | Value for video format Y41P.
Y41T | Value for video format Y41T.
Y42T | Value for video format Y42T.
YV12 | Value for video format YV12.
Yuy2 | Value for video format YUY2.
Yvu9 | Value for video format YVU9.
Yvyu | Value for video format YVYU.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NMediaFormat Class
Show:
No members matching the current filter
Name | Description
Equals | Checks whether the current media format equal the other media format.
GetHashCode | Gets the hash code.
IsCompatibleWith | Checks if media format is compatible with other media format.
NVideoFormat Class
Name | Description
MediaSubtypeToString | Creates media subtype representing string.
Collapse Expand NMediaFormat Operators
NMediaFormat Class
Show:
No members matching the current filter
Name | Description
!= | The inequality operator used to check if specified operands are not equal.
== | Equality operator used to check if specified operands are equal.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NExpandableObject Class
Show:
No members matching the current filter
Name | Description
NativeType | Defines the native type of the object.
Properties | Gets the property bag of the expandable object.
NMediaFormat Class
Show:
No members matching the current filter
Name | Description
MediaSubtype | Gets or sets media subtype from/for specified media format.
MediaType | Gets or sets media type from/for specified NMediaFormat.
NativeType | Defines the native type of the object.
NVideoFormat Class
Name | Description
FrameRate | Gets or sets video format frame rate.
Height | Gets or sets video format frame height.
InterlaceMode | Gets or sets video format interlace mode.
LongStride | Gets or sets stride for specified video format.
NativeStide | Gets or sets pointer to native stride of video.
NativeType | Defines the native type of the object.
PixelAspectRatio | Gets or sets video format pixel aspect ratio.
Stride | Gets or sets stride for specified video format.
Width | Gets or sets video format frame width.
Container

File: NVideoFormat.cs

Namespace: Neurotec.Media

Module: .NET Reference


NVideoFormat.NVideoFormat Constructor

NVideoFormat.NVideoFormat Constructor
NVideoFormat Class Neurotec.Media Namespace

Default NVideoFormat constructor. NVideoFormat object can be constructed to setup video device in user defined format.

C#
public NVideoFormat();


NVideoFormat.AI44 Field

NVideoFormat.AI44 Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format AI44.

C#
public const int AI44 = 0x34344941;


NVideoFormat.Argb32 Field

NVideoFormat.Argb32 Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format RGB, 32 bpp with alpha channel.

C#
public const int Argb32 = 21;


NVideoFormat.Ayuv Field

NVideoFormat.Ayuv Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format AYUV.

C#
public const int Ayuv = 0x56555941;


NVideoFormat.DV25 Field

NVideoFormat.DV25 Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format DVCPRO 25 (525-60 or 625-50).

C#
public const int DV25 = 0x35327664;


NVideoFormat.DV50 Field

NVideoFormat.DV50 Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format DVCPRO 50 (525-60 or 625-50).

C#
public const int DV50 = 0x30357664;


NVideoFormat.DX50 Field

NVideoFormat.DX50 Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format DX50.

C#
public const int DX50 = 0x30355844;


NVideoFormat.Dvc Field

NVideoFormat.Dvc Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format DVC/DV Video.

C#
public const int Dvc = 0x20637664;


NVideoFormat.Dvh1 Field

NVideoFormat.Dvh1 Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format DVC/DV Video.

C#
public const int Dvh1 = 0x31687664;


NVideoFormat.Dvhd Field

NVideoFormat.Dvhd Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format HD-DVCR (1125-60 or 1250-50).

C#
public const int Dvhd = 0x64687664;


NVideoFormat.Dvsd Field

NVideoFormat.Dvsd Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format SDL-DVCR (525-60 or 625-50).

C#
public const int Dvsd = 0x64737664;


NVideoFormat.Dvsl Field

NVideoFormat.Dvsl Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format SD-DVCR (525-60 or 625-50).

C#
public const int Dvsl = 0x6C737664;


NVideoFormat.H264 Field

NVideoFormat.H264 Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format H.264.

C#
public const int H264 = 0x34363248;


NVideoFormat.I420 Field

NVideoFormat.I420 Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format I420.

C#
public const int I420 = 0x30323449;


NVideoFormat.Iyuv Field

NVideoFormat.Iyuv Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format IYUV.

C#
public const int Iyuv = 0x56555949;


NVideoFormat.L16 Field

NVideoFormat.L16 Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format L16.

C#
public const int L16 = 81;


NVideoFormat.L8 Field

NVideoFormat.L8 Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format L8.

C#
public const int L8 = 50;


NVideoFormat.M4S2 Field

NVideoFormat.M4S2 Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format MPEG-4 part 2 video.

C#
public const int M4S2 = 0x3253344D;


NVideoFormat.MP43 Field

NVideoFormat.MP43 Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format Microsoft MPEG 4 codec version 3.

C#
public const int MP43 = 0x3334504D;


NVideoFormat.MP4S Field

NVideoFormat.MP4S Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format ISO MPEG 4 codec version 1.

C#
public const int MP4S = 0x5334504D;


NVideoFormat.MP4V Field

NVideoFormat.MP4V Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format MPEG-4 part 2 video.

C#
public const int MP4V = 0x5634504D;


NVideoFormat.Mjpg Field

NVideoFormat.Mjpg Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format Motion JPEG.

C#
public const int Mjpg = 0x47504A4D;


NVideoFormat.Mpg1 Field

NVideoFormat.Mpg1 Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format MPEG-1 video.

C#
public const int Mpg1 = 0x3147504D;


NVideoFormat.Mss1 Field

NVideoFormat.Mss1 Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format Windows Media Screen codec version 1.

C#
public const int Mss1 = 0x3153534D;


NVideoFormat.Mss2 Field

NVideoFormat.Mss2 Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format Windows Media Video 9 Screen codec.

C#
public const int Mss2 = 0x3253534D;


NVideoFormat.NV11 Field

NVideoFormat.NV11 Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format NV11.

C#
public const int NV11 = 0x3131564E;


NVideoFormat.NV12 Field

NVideoFormat.NV12 Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format NV12.

C#
public const int NV12 = 0x3231564E;


NVideoFormat.NV21 Field

NVideoFormat.NV21 Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format NV21.

C#
public const int NV21 = 0x3132564E;


NVideoFormat.P010 Field

NVideoFormat.P010 Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format P010.

C#
public const int P010 = 0x30313050;


NVideoFormat.P016 Field

NVideoFormat.P016 Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format P016.

C#
public const int P016 = 0x36313050;


NVideoFormat.P210 Field

NVideoFormat.P210 Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format P210.

C#
public const int P210 = 0x30313250;


NVideoFormat.P216 Field

NVideoFormat.P216 Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format P216.

C#
public const int P216 = 0x36313250;


NVideoFormat.Rgb24 Field

NVideoFormat.Rgb24 Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format RGB, 24 bpp.

C#
public const int Rgb24 = 20;


NVideoFormat.Rgb32 Field

NVideoFormat.Rgb32 Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format RGB, 32 bpp.

C#
public const int Rgb32 = 22;


NVideoFormat.Rgb555 Field

NVideoFormat.Rgb555 Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format RGB 555, 16 bpp.

C#
public const int Rgb555 = 24;


NVideoFormat.Rgb565 Field

NVideoFormat.Rgb565 Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format RGB 565, 16 bpp.

C#
public const int Rgb565 = 23;


NVideoFormat.Rgb8 Field

NVideoFormat.Rgb8 Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format RGB, 8bpp.

C#
public const int Rgb8 = 41;


NVideoFormat.Unknown Field

NVideoFormat.Unknown Field
NVideoFormat Class Neurotec.Media Namespace

Value for unknown video format.

C#
public const int Unknown = 0;


NVideoFormat.Uyvy Field

NVideoFormat.Uyvy Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format UYVY.

C#
public const int Uyvy = 0x59565955;


NVideoFormat.V210 Field

NVideoFormat.V210 Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format V210.

C#
public const int V210 = 0x30313276;


NVideoFormat.V216 Field

NVideoFormat.V216 Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format V216.

C#
public const int V216 = 0x36313276;


NVideoFormat.V410 Field

NVideoFormat.V410 Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format V40.

C#
public const int V410 = 0x30313476;


NVideoFormat.Wmv1 Field

NVideoFormat.Wmv1 Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format Windows Media Video codec version 7.

C#
public const int Wmv1 = 0x31564D57;


NVideoFormat.Wmv2 Field

NVideoFormat.Wmv2 Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format Windows Media Video 8 codec.

C#
public const int Wmv2 = 0x32564D57;


NVideoFormat.Wmv3 Field

NVideoFormat.Wmv3 Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format Windows Media Video 9 codec.

C#
public const int Wmv3 = 0x33564D57;


NVideoFormat.Wvc1 Field

NVideoFormat.Wvc1 Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format SMPTE 421M ("VC-1").

C#
public const int Wvc1 = 0x31435657;


NVideoFormat.Y210 Field

NVideoFormat.Y210 Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format Y210.

C#
public const int Y210 = 0x30313259;


NVideoFormat.Y216 Field

NVideoFormat.Y216 Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format Y216.

C#
public const int Y216 = 0x36313259;


NVideoFormat.Y410 Field

NVideoFormat.Y410 Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format Y40.

C#
public const int Y410 = 0x30313459;


NVideoFormat.Y416 Field

NVideoFormat.Y416 Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format Y416.

C#
public const int Y416 = 0x36313459;


NVideoFormat.Y41P Field

NVideoFormat.Y41P Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format Y41P.

C#
public const int Y41P = 0x50313459;


NVideoFormat.Y41T Field

NVideoFormat.Y41T Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format Y41T.

C#
public const int Y41T = 0x54313459;


NVideoFormat.Y42T Field

NVideoFormat.Y42T Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format Y42T.

C#
public const int Y42T = 0x54323459;


NVideoFormat.YV12 Field

NVideoFormat.YV12 Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format YV12.

C#
public const int YV12 = 0x32315659;


NVideoFormat.Yuy2 Field

NVideoFormat.Yuy2 Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format YUY2.

C#
public const int Yuy2 = 0x32595559;


NVideoFormat.Yvu9 Field

NVideoFormat.Yvu9 Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format YVU9.

C#
public const int Yvu9 = 0x39555659;


NVideoFormat.Yvyu Field

NVideoFormat.Yvyu Field
NVideoFormat Class Neurotec.Media Namespace

Value for video format YVYU.

C#
public const int Yvyu = 0x55595659;


NVideoFormat.MediaSubtypeToString Method (int)

NVideoFormat.MediaSubtypeToString Method (int)
NVideoFormat Class Neurotec.Media Namespace

Creates media subtype representing string.

C#
public static string MediaSubtypeToString(int value);
Collapse Expand Parameters
Parameters | Description
int value | Video format value.
Collapse Expand Returns

Media subtype representing string.


NVideoFormat.MediaSubtypeToString Method (int, string)

NVideoFormat.MediaSubtypeToString Method (int, string)
NVideoFormat Class Neurotec.Media Namespace

Creates media subtype representing string.

C#
public static string MediaSubtypeToString(int value, string format);
Collapse Expand Parameters
Parameters | Description
int value | Video format value.
string format | Reserved.
Collapse Expand Returns

Media subtype representing string.


NVideoFormat.FrameRate Property

NVideoFormat.FrameRate Property
NVideoFormat Class Neurotec.Media Namespace

Gets or sets video format frame rate.

C#
public NURational FrameRate;
Property value

Value represents video frames per second rate.


NVideoFormat.Height Property

NVideoFormat.Height Property
NVideoFormat Class Neurotec.Media Namespace

Gets or sets video format frame height.

C#
public uint Height;
Property value

Value represents video frame height in pixels.


NVideoFormat.InterlaceMode Property

NVideoFormat.InterlaceMode Property
NVideoFormat Class Neurotec.Media Namespace

Gets or sets video format interlace mode.

C#
public NVideoInterlaceMode InterlaceMode;
Property value

Value represents video interlace mode.


NVideoFormat.LongStride Property

NVideoFormat.LongStride Property
NVideoFormat Class Neurotec.Media Namespace

Gets or sets stride for specified video format.

C#
public long LongStride;
Property value

Video stride value (type long).


NVideoFormat.NativeStide Property

NVideoFormat.NativeStide Property
NVideoFormat Class Neurotec.Media Namespace

Gets or sets pointer to native stride of video.

C#
public IntPtr NativeStide;
Property value

IntPtr object.


NVideoFormat.NativeType Property

NVideoFormat.NativeType Property
NVideoFormat Class Neurotec.Media Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NVideoFormat.PixelAspectRatio Property

NVideoFormat.PixelAspectRatio Property
NVideoFormat Class Neurotec.Media Namespace

Gets or sets video format pixel aspect ratio.

C#
public NURational PixelAspectRatio;
Property value

Value represents pixel aspect ratio.


NVideoFormat.Stride Property

NVideoFormat.Stride Property
NVideoFormat Class Neurotec.Media Namespace

Gets or sets stride for specified video format.

C#
public int Stride;
Property value

Video stride value.


NVideoFormat.Width Property

NVideoFormat.Width Property
NVideoFormat Class Neurotec.Media Namespace

Gets or sets video format frame width.

C#
public uint Width;
Property value

Value represents video frame width in pixels.


Neurotec.Media.NMediaState Enumeration

Neurotec.Media.NMediaState Enumeration

Enumerates media state values.

C#
public enum NMediaState {
  Stopped = 0,
  Paused = 1,
  Running = 2
}
Collapse Expand Members
Members | Description
Stopped = 0 | Indicates stopped media stream.
Paused = 1 | Indicates paused media stream.
Running = 2 | Indicates running media stream.
Container

File: NMediaTypes.cs

Namespace: Neurotec.Media

Module: .NET Reference


Neurotec.Media.NMediaType Enumeration

Neurotec.Media.NMediaType Enumeration

Enumerates media type values.

C#
[Flags]
public enum NMediaType {
  None = 0,
  Audio = 1,
  Video = 2
}
Collapse Expand Members
Members | Description
None = 0 | Media type was not recognized.
Audio = 1 | Indicates that media type is audio.
Video = 2 | Indicates that media type is video.
Container

File: NMediaTypes.cs

Namespace: Neurotec.Media

Module: .NET Reference


Neurotec.Media.NVideoInterlaceMode Enumeration

Neurotec.Media.NVideoInterlaceMode Enumeration

Represents video interlace mode.

C#
public enum NVideoInterlaceMode {
  Unknown = 0,
  Interlaced = 1,
  Progressive = 2
}
Collapse Expand Members
Members | Description
Unknown = 0 | Unknown video mode.
Interlaced = 1 | Interlaced video mode.
Progressive = 2 | Progressive video mode.
Container

File: NMediaTypes.cs

Namespace: Neurotec.Media

Module: .NET Reference


Neurotec.Plugins Namespace

Neurotec.Plugins Namespace
Classes Legend Structs, Records, Enums

Classes under this namespace provide plugins management framework for use in other Neurotechnology components.

Collapse Expand Classes
Name | Description
NPlugin | Plug-in management framework for use in other Neurotechnology components.
NPluginManager | Provides functions for working with plugins.
NPluginManagerPluginEventArgs | Base class for holding NPluginManager events data.
NPluginModule | The module providing one or more plugins. Provides methods to retrieve information about plugins.
Collapse Expand Structs, Records, Enums
Name | Description
NPluginState | Enumerates NPlugin state values. The plugin state show how much of initialization the plugin has performed and can be used to identify common problems of plugin loading.


NPlugin Class

NPlugin Class
NObject Delegates NObject Events NObject Fields Legend Members NDisposable Methods NDisposable Properties

Plug-in management framework for use in other Neurotechnology components.

C#
public sealed class NPlugin : NObject;
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NPlugin Class
Name | Description
Disable | Disables NPlugin
Enable | Enables NPlugin.
Plug | Plugs specified plug-in to the system.
Unplug | Unplugs specified plug-in from the system.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NPlugin Class
Name | Description
Error | Gets NPlugin error.
FileName | Gets plug-in library name.
LoadTime | Gets plug-in load time.
Module | Gets NPluginModule object.
NPluginStateNativeType | Defines the native type of the plugin state.
NativeType | Defines the native type of the object.
Owner | Gets the manager of the plugin.
PlugTime | Gets plug-in plug time.
SelectedInterfaceVersion | Gets current version of plugin interface.
State | Gets the state of specified plugin.
Container

File: NPlugin.cs

Namespace: Neurotec.Plugins

Module: .NET Reference


NPlugin.Disable Method

NPlugin.Disable Method
NPlugin Class Neurotec.Plugins Namespace

Disables NPlugin

C#
public void Disable();


NPlugin.Enable Method

NPlugin.Enable Method
NPlugin Class Neurotec.Plugins Namespace

Enables NPlugin.

C#
public void Enable();


NPlugin.Plug Method

NPlugin.Plug Method
NPlugin Class Neurotec.Plugins Namespace

Plugs specified plug-in to the system.

C#
public void Plug();
Collapse Expand Remarks

The requested plugin might not be plugged into the system immediately. If there is no potential users (device managers) for provided device types, the plugin's state will be set to Unused. The plugin will be automatically plugged later, once device manager of appropriate type is created.


NPlugin.Unplug Method

NPlugin.Unplug Method
NPlugin Class Neurotec.Plugins Namespace

Unplugs specified plug-in from the system.

C#
public void Unplug();
Collapse Expand Remarks
  • The function is not mandatory as plugin will be unplugged automatically when it becomes unused. Not calling a function would have effect that plugin would be later plugged automatically when needed.
  • If the function is called the plugin's state will be set to Unplugged and plugin will not be automatically plugged later.
  • The function can be used to force unplug even if devices provided by the plugin are still in use.


NPlugin.Error Property

NPlugin.Error Property
NPlugin Class Neurotec.Plugins Namespace

Gets NPlugin error.

C#
public Exception Error;
Property value

NPlugin exception.


NPlugin.FileName Property

NPlugin.FileName Property
NPlugin Class Neurotec.Plugins Namespace

Gets plug-in library name.

C#
public string FileName;
Property value

String which contains plug-in file name.


NPlugin.LoadTime Property

NPlugin.LoadTime Property
NPlugin Class Neurotec.Plugins Namespace

Gets plug-in load time.

C#
public TimeSpan LoadTime;
Property value

TimeSpan structure with plugin load time.


NPlugin.Module Property

NPlugin.Module Property
NPlugin Class Neurotec.Plugins Namespace

Gets NPluginModule object.

C#
public NPluginModule Module;


NPlugin.NPluginStateNativeType Property

NPlugin.NPluginStateNativeType Property
NPlugin Class Neurotec.Plugins Namespace

Defines the native type of the plugin state.

C#
public static NType NPluginStateNativeType;


NPlugin.NativeType Property

NPlugin.NativeType Property
NPlugin Class Neurotec.Plugins Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NPlugin.Owner Property

NPlugin.Owner Property
NPlugin Class Neurotec.Plugins Namespace

Gets the manager of the plugin.

C#
[Browsable(false)]
public new NPluginManager Owner;
Property value

Reference to NPluginManager


NPlugin.PlugTime Property

NPlugin.PlugTime Property
NPlugin Class Neurotec.Plugins Namespace

Gets plug-in plug time.

C#
public TimeSpan PlugTime;
Property value

TimeSpan structure with plugin load time.


NPlugin.SelectedInterfaceVersion Property

NPlugin.SelectedInterfaceVersion Property
NPlugin Class Neurotec.Plugins Namespace

Gets current version of plugin interface.

C#
public NVersion SelectedInterfaceVersion;
Property value

NVersion value.


NPlugin.State Property

NPlugin.State Property
NPlugin Class Neurotec.Plugins Namespace

Gets the state of specified plugin.

C#
public NPluginState State;
Property value

NPluginState object.


NPluginManager Class

NPluginManager Class
NPluginManager Classes NObject Delegates NObject Events NObject Fields Legend Members NDisposable Methods NDisposable Properties

Provides functions for working with plugins.

C#
public sealed class NPluginManager : NObject;
Collapse Expand NPluginManager Classes
NPluginManager Class
Name | Description
DisabledPluginCollection | Represents collection of plugin names for plugins that will be disabled.
PluginCollection | Represents collection of plugins.
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NPluginManager Class
Name | Description
EnsurePluginSearchPerformed | Checks if initial plugin search was performed and if not calls Refresh
GetInstances | Gets instance of the objects.
GetInterfaceVersions | Returns the range of supported interface versions by specified NPluginManager.
PlugAll | Plugs all plugins into the system.
Refresh | Refreshes plugins list
UnplugAll | Unplugs all plugins.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NPluginManager Class
Name | Description
AllowsUnplug | Checks whether PlugAll and UnplugAll methods work
DisabledPlugins | Gets disabled plugins collection.
InterfaceType | Gets NPluginManager interface type name.
NativeType | Defines the native type of the object.
PluginSearchPath | Gets or sets plugins and its dependencies search path.
Plugins | Gets collection of all plugins in NPluginManager.
Container

File: NPluginManager.cs

Namespace: Neurotec.Plugins

Module: .NET Reference


NPluginManager.DisabledPluginCollection Class

NPluginManager.DisabledPluginCollection Class

Represents collection of plugin names for plugins that will be disabled.

C#
public class DisabledPluginCollection : StringCollection;
Collapse Expand Remarks

To view or modify the collection use the methods from the base class: StringCollection.

Container

File: NPluginManager.cs

Namespace: Neurotec.Plugins

Module: .NET Reference


NPluginManager.PluginCollection Class

NPluginManager.PluginCollection Class
Legend Members PluginCollection Methods

Represents collection of plugins.

C#
public sealed class PluginCollection : NObjectReadOnlyCollection<NPlugin>;
Collapse Expand Remarks

To iterate over the collection use the interfaces supported by the base class: NObjectReadOnlyCollection.

Collapse Expand PluginCollection Methods
Name | Description
Add | Adds plugin and its dependencies (if exist) from specified directory.
Contains | Checks if plugins collection contains a specified plugin.
IndexOf | Retrieves the index of the plugin specified by name.
this | Retrieves a plugin specified by name.
Container

File: NPluginManager.cs

Namespace: Neurotec.Plugins

Module: .NET Reference


NPluginManager.PluginCollection.Add Method (NPluginModule, string)

NPluginManager.PluginCollection.Add Method (NPluginModule, string)
NPluginManager.PluginCollection Class Neurotec.Plugins Namespace

Adds plugin and its dependencies (if exist) from specified directory.

C#
public NPlugin Add(NPluginModule module, string directory);
Collapse Expand Parameters
Parameters | Description
NPluginModule module | Plugin module.
string directory | Directory where plugin and its dependencies (if exist) are saved.
Collapse Expand Returns

Added plugin.


NPluginManager.PluginCollection.Add Method (string)

NPluginManager.PluginCollection.Add Method (string)
NPluginManager.PluginCollection Class Neurotec.Plugins Namespace

Adds plugin from user specified file.

C#
public NPlugin Add(string fileName);
Collapse Expand Parameters
Parameters | Description
string fileName | File name where plugin is saved.
Collapse Expand Returns

Added plugin.

Collapse Expand Remarks

This method automatically searches for library dependencies in the directory of the plugin library (specified in fileName).


NPluginManager.PluginCollection.Contains Method

NPluginManager.PluginCollection.Contains Method
NPluginManager.PluginCollection Class Neurotec.Plugins Namespace

Checks if plugins collection contains a specified plugin.

C#
public bool Contains(string name);
Collapse Expand Parameters
Parameters | Description
string name | Plugin name.
Collapse Expand Returns

true if plugin collection contains specified plugin; otherwise false.


NPluginManager.PluginCollection.IndexOf Method

NPluginManager.PluginCollection.IndexOf Method
NPluginManager.PluginCollection Class Neurotec.Plugins Namespace

Retrieves the index of the plugin specified by name.

C#
public int IndexOf(string name);
Collapse Expand Parameters
Parameters | Description
string name | The name of the plugin.
Collapse Expand Returns

The index of the plugin.


NPluginManager.PluginCollection.this Indexer

NPluginManager.PluginCollection.this Indexer
NPluginManager.PluginCollection Class Neurotec.Plugins Namespace

Retrieves a plugin specified by name.

C#
public NPlugin this[string name];
Collapse Expand Parameters
Parameters | Description
string name | Plugin name.
Collapse Expand Returns

NPlugin object.


NPluginManager.EnsurePluginSearchPerformed Method

NPluginManager.EnsurePluginSearchPerformed Method
NPluginManager Class Neurotec.Plugins Namespace

Checks if initial plugin search was performed and if not calls Refresh

C#
public void EnsurePluginSearchPerformed();


NPluginManager.GetInstances Method

NPluginManager.GetInstances Method
NPluginManager Class Neurotec.Plugins Namespace

Gets instance of the objects.

C#
public static NPluginManager[] GetInstances();
Collapse Expand Returns

Array of object instances.


NPluginManager.GetInterfaceVersions Method

NPluginManager.GetInterfaceVersions Method
NPluginManager Class Neurotec.Plugins Namespace

Returns the range of supported interface versions by specified NPluginManager.

C#
public NVersionRange[] GetInterfaceVersions();
Collapse Expand Returns

NVersionRange array with all supported interface version values.


NPluginManager.PlugAll Method

NPluginManager.PlugAll Method
NPluginManager Class Neurotec.Plugins Namespace

Plugs all plugins into the system.

C#
public void PlugAll();


NPluginManager.Refresh Method

NPluginManager.Refresh Method
NPluginManager Class Neurotec.Plugins Namespace

Refreshes plugins list

C#
public void Refresh();


NPluginManager.UnplugAll Method

NPluginManager.UnplugAll Method
NPluginManager Class Neurotec.Plugins Namespace

Unplugs all plugins.

C#
public void UnplugAll();


NPluginManager.AllowsUnplug Property

NPluginManager.AllowsUnplug Property
NPluginManager Class Neurotec.Plugins Namespace

Checks whether PlugAll and UnplugAll methods work

C#
public bool AllowsUnplug;
Property value

Bool value.


NPluginManager.DisabledPlugins Property

NPluginManager.DisabledPlugins Property
NPluginManager Class Neurotec.Plugins Namespace

Gets disabled plugins collection.

C#
public DisabledPluginCollection DisabledPlugins;
Property value

Collection of names of plugins that are disabled.


NPluginManager.InterfaceType Property

NPluginManager.InterfaceType Property
NPluginManager Class Neurotec.Plugins Namespace

Gets NPluginManager interface type name.

C#
public string InterfaceType;
Property value

String with NPluginManager interface name.


NPluginManager.NativeType Property

NPluginManager.NativeType Property
NPluginManager Class Neurotec.Plugins Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NPluginManager.PluginSearchPath Property

NPluginManager.PluginSearchPath Property
NPluginManager Class Neurotec.Plugins Namespace

Gets or sets plugins and its dependencies search path.

C#
public string PluginSearchPath;
Property value

Plugin search path.


NPluginManager.Plugins Property

NPluginManager.Plugins Property
NPluginManager Class Neurotec.Plugins Namespace

Gets collection of all plugins in NPluginManager.

C#
public PluginCollection Plugins;
Property value

Plugins collection.


NPluginManagerPluginEventArgs Class

NPluginManagerPluginEventArgs Class
Legend Members Methods NPluginManagerPluginEventArgs Properties

Base class for holding NPluginManager events data.

C#
[Serializable]
public class NPluginManagerPluginEventArgs : EventArgs;
Collapse Expand NPluginManagerPluginEventArgs Properties
Name | Description
Plugin | Gets Plugin associated with event raised by PluginManager.
Container

File: NPluginManager.cs

Namespace: Neurotec.Plugins

Module: .NET Reference


NPluginManagerPluginEventArgs.NPluginManagerPluginEventArgs Constructor

NPluginManagerPluginEventArgs.NPluginManagerPluginEventArgs Constructor
NPluginManagerPluginEventArgs Class Neurotec.Plugins Namespace

Plugin constructor.

C#
public NPluginManagerPluginEventArgs(NPlugin plugin);
Collapse Expand Parameters
Parameters | Description
NPlugin plugin | The plugin associated with event.


NPluginManagerPluginEventArgs.Plugin Property

NPluginManagerPluginEventArgs.Plugin Property
NPluginManagerPluginEventArgs Class Neurotec.Plugins Namespace

Gets Plugin associated with event raised by PluginManager.

C#
public NPlugin Plugin;
Property value

NPlugin object.


NPluginModule Class

NPluginModule Class
NObject Delegates NObject Events NObject Fields Legend Members Methods NDisposable Methods NDisposable Properties

The module providing one or more plugins.

Provides methods to retrieve information about plugins.

C#
public sealed class NPluginModule : NModule;
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NModule Class
Show:
No members matching the current filter
Name | Description
CheckInit | Checks whether the current module is initialized and throws and exception if it is not.
CreateInstance | Creates a new instance of the specified module.
GetDependences | Retrieves dependencies of the module.
GetLoadedModules | Gets all the loaded modules that are part of this assembly.
GetType | Retrieves the NType object from module specified by name.
LoadFromFile | Loads module from the specified file.
NPluginModule Class
Name | Description
GetInterfaceVersions | Returns the range of supported interface versions by current NPluginModule object.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NModule Class
Show:
No members matching the current filter
Name | Description
Activated | Checks if the module is registered.
Company | Retrieves company name.
Copyright | Retrieves copyright notice of this module.
DefinedTypes | Retrieves all defined types from the specified module.
FileName | Retrieves the name of the file the specified module was created from.
Id | Gets or sets the ID of the module.
NModuleOptionsNativeType | Defines the native type of the module options.
Name | Retrieves module name.
NativeId | Gets or sets the native ID of the specified module.
NativeType | Defines the native type of the object.
Options | Retrieves module options.
Product | Retrieves product name.
Title | Retrieves module's title.
Version | Retrieves module version number.
VersionBuild | Retrieves the build of the current version.
VersionMajor | Retrieves the major version value.
VersionMinor | Retrieves the minor version value.
VersionRevision | Retrieves revision of the current version.
NPluginModule Class
Name | Description
IncompatiblePlugins | Gets the list of incompatible plugins.
InterfaceType | Gets plugin interface type name.
NativeType | Defines the native type of the object.
PluginName | Gets plugin name.
Priority | Gets plugin priority over other plugins.
Container

File: NPluginModule.cs

Namespace: Neurotec.Plugins

Module: .NET Reference


NPluginModule.NPluginModule Constructor

NPluginModule.NPluginModule Constructor
NPluginModule Class Neurotec.Plugins Namespace

Creates a new instance of NPluginModule class.

C#
public NPluginModule();


NPluginModule.GetInterfaceVersions Method

NPluginModule.GetInterfaceVersions Method
NPluginModule Class Neurotec.Plugins Namespace

Returns the range of supported interface versions by current NPluginModule object.

C#
public NVersionRange[] GetInterfaceVersions();
Collapse Expand Returns

NVersionRange array with all supported interface version values.

Collapse Expand Notes

NVersionRange* and NVersion* macros can be used to parse version range.


NPluginModule.IncompatiblePlugins Property

NPluginModule.IncompatiblePlugins Property
NPluginModule Class Neurotec.Plugins Namespace

Gets the list of incompatible plugins.

C#
public string IncompatiblePlugins;
Property value

String with incompatible plugin names. Plugin names are separated by semicolons (;).

Collapse Expand Remarks

This property retrieves only the list of incompatible plug-in names. Plug-in file names can be retrieved using FileName property.


NPluginModule.InterfaceType Property

NPluginModule.InterfaceType Property
NPluginModule Class Neurotec.Plugins Namespace

Gets plugin interface type name.

C#
public string InterfaceType;
Property value

String with plugin interface type name.


NPluginModule.NativeType Property

NPluginModule.NativeType Property
NPluginModule Class Neurotec.Plugins Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NPluginModule.PluginName Property

NPluginModule.PluginName Property
NPluginModule Class Neurotec.Plugins Namespace

Gets plugin name.

C#
public string PluginName;
Property value

String with plugin name.


NPluginModule.Priority Property

NPluginModule.Priority Property
NPluginModule Class Neurotec.Plugins Namespace

Gets plugin priority over other plugins.

C#
public int Priority;
Property value

Plugin priority over other plugins.

Collapse Expand Remarks

Priority influences plugins adding to the system. If two or more plugins are incompatible or duplicate plugins exist plugin with higher priority will be added to the system. Priority is set during plugin compilation.

Default plugin priority is 0.


Neurotec.Plugins.NPluginState Enumeration

Neurotec.Plugins.NPluginState Enumeration

Enumerates NPlugin state values. The plugin state show how much of initialization the plugin has performed and can be used to identify common problems of plugin loading.

C#
public enum NPluginState {
  None = 0,
  LoadError = 1,
  NotRecognized = 2,
  InvalidModule = 3,
  InterfaceTypeMismatch = 4,
  InterfaceVersionMismatch = 5,
  InvalidInterface = 6,
  Unplugged = 64,
  Unused = 65,
  Disabled = 66,
  Duplicate = 67,
  IncompatibleWithOtherPlugins = 68,
  PluggingError = 69,
  Plugged = 128
}
Collapse Expand Members
Members | Description
None = 0 | Indicates uninitialized variable. This value should never be observed by the API user.
LoadError = 1 | Indicates that plugin's dynamic library (dll) failed to load.
NotRecognized = 2 | Indicates that function returning plugin module handle was not found. If the file name of plugin library is "<Name>.dll", the expected name of the function is "<Name>ModuleOf".
InvalidModule = 3 | Indicates invalid plugin module. The plugin's ModuleOf function (see: NotRecognized) was found, but the returned handle was wrong.
InterfaceTypeMismatch = 4 | Indicates that plugin's interface type differs from expected type. This means that the plugin is for other product/application. Interface type can be retrieved using NPluginModule.InterfaceType property.
InterfaceVersionMismatch = 5 | Indicates that plug-in interface version mismatches. This means that plugin is of the right type, but has version incompatible with versions supported by current plugin loader. Interface version can be retrieved using NPlugin.SelectedInterfaceVersion property.
InvalidInterface = 6 | Indicates that the plugin's interface didn't pass the validation check. This happens when some mandatory functions required for plugin are missing or return wrong value.
Unplugged = 64 | Indicates that plugin is not connected into the system. The plugin will not be used by the system unless activated with NPlugin.Plug or NPluginManager.PlugAll/NPluginManager.Refresh methods.
Unused = 65 | Indicates that plugin is activated (with NPlugin.Plug or NPluginManager.PlugAll/NPluginManager.Refresh methods) but not currently used (not plugged into the system because there are no potential users of the plugin). The plugin will be automatically plugged once device manager of appropriate type is created (see: Plugged).
Disabled = 66 | Indicates that plugin is disabled.
Duplicate = 67 | Indicates that NPluginManager already contains plug-in with the same name.
IncompatibleWithOtherPlugins = 68 | Indicates that the current plugin is incompatible with other plugin in the system. Each plugin has a priority value which determines which of the incompatible plugins will be loaded. The plugin with the highest priority will be loaded, and other plugins will fail with npsIncompatibleWithOtherPlugins state.
PluggingError = 69 | Indicates that an error occurred when plugging the plug-in. NPlugin.Rrror property can be used to retrieve exception.
Plugged = 128 | Indicates that plugin is activated and the provided functionality can be used by the system. If all the device managers enumerating the devices provided by the current plugin are terminated, the plugin will be automatically unplugged and it's state changed to Unused.
Container

File: NPlugin.cs

Namespace: Neurotec.Plugins

Module: .NET Reference


Neurotec.Plugins.ComponentModel Namespace

Neurotec.Plugins.ComponentModel Namespace
Classes Legend

Classes under this namespace provide plugins component model.

Collapse Expand Classes
Name | Description
NPluginEventDescriptor | Provides functionality for creating plugin event descriptors.
NPluginMethodDescriptor | Provides functionality for creating plugin method descriptors.
NPluginPropertyDescriptor | Provides functionality for creating plugin property descriptors.


NPluginEventDescriptor Class

NPluginEventDescriptor Class
Legend Members NPluginEventDescriptor Properties

Provides functionality for creating plugin event descriptors.

C#
public sealed class NPluginEventDescriptor : NCustomEventDescriptor;
Collapse Expand NPluginEventDescriptor Properties
Name | Description
NativeType | Defines the native type of the object.
Container

File: NPluginEventDescriptor.cs

Namespace: Neurotec.Plugins.ComponentModel

Module: .NET Reference


NPluginEventDescriptor.NativeType Property

NPluginEventDescriptor.NativeType Property
NPluginEventDescriptor Class Neurotec.Plugins.ComponentModel Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NPluginMethodDescriptor Class

NPluginMethodDescriptor Class
Legend Members NPluginMethodDescriptor Properties

Provides functionality for creating plugin method descriptors.

C#
public sealed class NPluginMethodDescriptor : NCustomMethodDescriptor;
Collapse Expand NPluginMethodDescriptor Properties
Name | Description
NativeType | Defines the native type of the object.
Container

File: NPluginMethodDescriptor.cs

Namespace: Neurotec.Plugins.ComponentModel

Module: .NET Reference


NPluginMethodDescriptor.NativeType Property

NPluginMethodDescriptor.NativeType Property
NPluginMethodDescriptor Class Neurotec.Plugins.ComponentModel Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NPluginPropertyDescriptor Class

NPluginPropertyDescriptor Class
Legend Members NPluginPropertyDescriptor Properties

Provides functionality for creating plugin property descriptors.

C#
public sealed class NPluginPropertyDescriptor : NCustomPropertyDescriptor;
Collapse Expand NPluginPropertyDescriptor Properties
Name | Description
NativeType | Defines the native type of the object.
Container

File: NPluginPropertyDescriptor.cs

Namespace: Neurotec.Plugins.ComponentModel

Module: .NET Reference


NPluginPropertyDescriptor.NativeType Property

NPluginPropertyDescriptor.NativeType Property
NPluginPropertyDescriptor Class Neurotec.Plugins.ComponentModel Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


Neurotec.Reflection Namespace

Neurotec.Reflection Namespace
Classes Legend

Classes under this namespace retrieve information about various core components.

Collapse Expand Classes
Name | Description
NArrayCollectionInfo | Provides functionality to retrieve information about array collections.
NCollectionInfo | Provides functionality to retrieve information about collections.
NConstantInfo | Provides functionality to retrieve information about constants.
NDictionaryInfo | Provides functionality to retrieve information about dictionaries.
NEnumConstantInfo | Provides functionality to retrieve information about enumeration constants.
NEventInfo | Provides functionality to retrieve information about events.
NMemberInfo | Provides functionality to retrieve information about class members.
NMethodInfo | Provides functions for getting information about property.
NObjectPartInfo | Provides functionality to retrieve information about object parts.
NParameterInfo | Provides functions for getting information about parameter.
NPropertyInfo | Provides functionality to retrieve and change information about properties.


NArrayCollectionInfo Class

NArrayCollectionInfo Class
NObjectPartInfo Classes NObject Delegates NObject Events NObject Fields Legend Members NDisposable Methods NDisposable Properties

Provides functionality to retrieve information about array collections.

C#
public sealed class NArrayCollectionInfo : NObjectPartInfo;
Collapse Expand NObjectPartInfo Classes
NObjectPartInfo Class
Name | Description
DeclaredConstantCollection | Collection of declared constants.
DeclaredEventCollection | Collection of declared events.
DeclaredMethodCollection | Collection of declared methods.
DeclaredPropertyCollection | Collection of declared properties.
NArrayCollectionInfo Class
Name | Description
ItemStdValueCollection | A collection of standard item values.
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NObjectPartInfo Class
Show:
No members matching the current filter
Name | Description
GetDeclaredConstant | Retrieves the specified declared constant.
GetDeclaredEvent | Retrieves the specified declared event.
GetDeclaredMethod | Retrieves the specified declared method.
GetDeclaredMethods | Retrieves the specified declared methods.
GetDeclaredProperty | Retrieves the specified declared property.
GetObjectPart | Retrieves the part of the specified object.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NMemberInfo Class
Show:
No members matching the current filter
Name | Description
Attributes | Gets member attributes.
DeclaringType | Gets the declaring type of the member.
Name | Gets member name.
NativeType | Defines the native type of the object.
NObjectPartInfo Class
Show:
No members matching the current filter
Name | Description
DeclaredConstants | Retrieves the collection of declared constants.
DeclaredEvents | Retrieves the collection of declared events.
DeclaredMethods | Retrieves the collection of declared methods.
DeclaredProperties | Retrieves the collection of declared proeprties.
NativeType | Defines the native type of the object.
PropertyName | Retrieves the name of an object part property.
NArrayCollectionInfo Class
Name | Description
AddMethod | Retrieves the method which adds an item to an array collection.
AddRangeMethod | Retrieves the method which adds a range of items to an array collection.
BaseCollection | Retrieves the base collection of the array collection.
ClearMethod | Retrieves the method which clears the array collection.
GetCountMethod | Retrieves the method which gets the number of items in the array collection.
GetMethod | Retrieves the method which gets an item in the array collection.
IndexOfMethod | Retrieves the method which gets an index of an item in the array collection.
InsertMethod | Retrieves the method which adds an item to an array collection at a specific index.
InsertRangeMethod | Retrieves the method which adds a range of items to an array collection at a specific index.
ItemAttributes | Retrieves the attributes of items in the array collection.
ItemFormat | Retrieves the type of items in the array collection.
ItemMaxValue | Retrieves the maximal item value.
ItemMinValue | Retrieves the minimal item value.
ItemStdValues | Retrieves the collection of standard item values.
ItemType | Retrieves the type of items in the array collection.
NativeType | Defines the native type of the object.
RemoveAtMethod | Retrieves the method which removes an item with specific index from an array collection.
RemoveMethod | Retrieves the method which removes an item from an array collection.
RemoveRangeMethod | Retrieves the method which removes a range of items from an array collection.
SetMethod | Retrieves the method which sets an item of the array collection.
ToArrayMethod | Retrieves the method which converts the array collection into a regular array.
Container

File: NArrayCollectionInfo.cs

Namespace: Neurotec.Reflection

Module: .NET Reference


NArrayCollectionInfo.ItemStdValueCollection Class

NArrayCollectionInfo.ItemStdValueCollection Class

A collection of standard item values.

C#
public sealed class ItemStdValueCollection : DisposableStructReadOnlyCollection<KeyValuePair<string, object>, NNameValuePair_>;
Container

File: NArrayCollectionInfo.cs

Namespace: Neurotec.Reflection

Module: .NET Reference


NArrayCollectionInfo.AddMethod Property

NArrayCollectionInfo.AddMethod Property
NArrayCollectionInfo Class Neurotec.Reflection Namespace

Retrieves the method which adds an item to an array collection.

C#
public NMethodInfo AddMethod;


NArrayCollectionInfo.AddRangeMethod Property

NArrayCollectionInfo.AddRangeMethod Property
NArrayCollectionInfo Class Neurotec.Reflection Namespace

Retrieves the method which adds a range of items to an array collection.

C#
public NMethodInfo AddRangeMethod;


NArrayCollectionInfo.BaseCollection Property

NArrayCollectionInfo.BaseCollection Property
NArrayCollectionInfo Class Neurotec.Reflection Namespace

Retrieves the base collection of the array collection.

C#
public NCollectionInfo BaseCollection;


NArrayCollectionInfo.ClearMethod Property

NArrayCollectionInfo.ClearMethod Property
NArrayCollectionInfo Class Neurotec.Reflection Namespace

Retrieves the method which clears the array collection.

C#
public NMethodInfo ClearMethod;


NArrayCollectionInfo.GetCountMethod Property

NArrayCollectionInfo.GetCountMethod Property
NArrayCollectionInfo Class Neurotec.Reflection Namespace

Retrieves the method which gets the number of items in the array collection.

C#
public NMethodInfo GetCountMethod;


NArrayCollectionInfo.GetMethod Property

NArrayCollectionInfo.GetMethod Property
NArrayCollectionInfo Class Neurotec.Reflection Namespace

Retrieves the method which gets an item in the array collection.

C#
public NMethodInfo GetMethod;


NArrayCollectionInfo.IndexOfMethod Property

NArrayCollectionInfo.IndexOfMethod Property
NArrayCollectionInfo Class Neurotec.Reflection Namespace

Retrieves the method which gets an index of an item in the array collection.

C#
public NMethodInfo IndexOfMethod;


NArrayCollectionInfo.InsertMethod Property

NArrayCollectionInfo.InsertMethod Property
NArrayCollectionInfo Class Neurotec.Reflection Namespace

Retrieves the method which adds an item to an array collection at a specific index.

C#
public NMethodInfo InsertMethod;


NArrayCollectionInfo.InsertRangeMethod Property

NArrayCollectionInfo.InsertRangeMethod Property
NArrayCollectionInfo Class Neurotec.Reflection Namespace

Retrieves the method which adds a range of items to an array collection at a specific index.

C#
public NMethodInfo InsertRangeMethod;


NArrayCollectionInfo.ItemAttributes Property

NArrayCollectionInfo.ItemAttributes Property
NArrayCollectionInfo Class Neurotec.Reflection Namespace

Retrieves the attributes of items in the array collection.

C#
public NAttributes ItemAttributes;


NArrayCollectionInfo.ItemFormat Property

NArrayCollectionInfo.ItemFormat Property
NArrayCollectionInfo Class Neurotec.Reflection Namespace

Retrieves the type of items in the array collection.

C#
public string ItemFormat;


NArrayCollectionInfo.ItemMaxValue Property

NArrayCollectionInfo.ItemMaxValue Property
NArrayCollectionInfo Class Neurotec.Reflection Namespace

Retrieves the maximal item value.

C#
public object ItemMaxValue;


NArrayCollectionInfo.ItemMinValue Property

NArrayCollectionInfo.ItemMinValue Property
NArrayCollectionInfo Class Neurotec.Reflection Namespace

Retrieves the minimal item value.

C#
public object ItemMinValue;


NArrayCollectionInfo.ItemStdValues Property

NArrayCollectionInfo.ItemStdValues Property
NArrayCollectionInfo Class Neurotec.Reflection Namespace

Retrieves the collection of standard item values.

C#
public ItemStdValueCollection ItemStdValues;


NArrayCollectionInfo.ItemType Property

NArrayCollectionInfo.ItemType Property
NArrayCollectionInfo Class Neurotec.Reflection Namespace

Retrieves the type of items in the array collection.

C#
public NType ItemType;


NArrayCollectionInfo.NativeType Property

NArrayCollectionInfo.NativeType Property
NArrayCollectionInfo Class Neurotec.Reflection Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NArrayCollectionInfo.RemoveAtMethod Property

NArrayCollectionInfo.RemoveAtMethod Property
NArrayCollectionInfo Class Neurotec.Reflection Namespace

Retrieves the method which removes an item with specific index from an array collection.

C#
public NMethodInfo RemoveAtMethod;


NArrayCollectionInfo.RemoveMethod Property

NArrayCollectionInfo.RemoveMethod Property
NArrayCollectionInfo Class Neurotec.Reflection Namespace

Retrieves the method which removes an item from an array collection.

C#
public NMethodInfo RemoveMethod;


NArrayCollectionInfo.RemoveRangeMethod Property

NArrayCollectionInfo.RemoveRangeMethod Property
NArrayCollectionInfo Class Neurotec.Reflection Namespace

Retrieves the method which removes a range of items from an array collection.

C#
public NMethodInfo RemoveRangeMethod;


NArrayCollectionInfo.SetMethod Property

NArrayCollectionInfo.SetMethod Property
NArrayCollectionInfo Class Neurotec.Reflection Namespace

Retrieves the method which sets an item of the array collection.

C#
public NMethodInfo SetMethod;


NArrayCollectionInfo.ToArrayMethod Property

NArrayCollectionInfo.ToArrayMethod Property
NArrayCollectionInfo Class Neurotec.Reflection Namespace

Retrieves the method which converts the array collection into a regular array.

C#
public NMethodInfo ToArrayMethod;


NCollectionInfo Class

NCollectionInfo Class
NObjectPartInfo Classes NObject Delegates NObject Events NObject Fields Legend Members NDisposable Methods NDisposable Properties

Provides functionality to retrieve information about collections.

C#
public sealed class NCollectionInfo : NObjectPartInfo;
Collapse Expand NObjectPartInfo Classes
NObjectPartInfo Class
Name | Description
DeclaredConstantCollection | Collection of declared constants.
DeclaredEventCollection | Collection of declared events.
DeclaredMethodCollection | Collection of declared methods.
DeclaredPropertyCollection | Collection of declared properties.
NCollectionInfo Class
Name | Description
ItemStdValueCollection | A collection of standard item values.
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NObjectPartInfo Class
Show:
No members matching the current filter
Name | Description
GetDeclaredConstant | Retrieves the specified declared constant.
GetDeclaredEvent | Retrieves the specified declared event.
GetDeclaredMethod | Retrieves the specified declared method.
GetDeclaredMethods | Retrieves the specified declared methods.
GetDeclaredProperty | Retrieves the specified declared property.
GetObjectPart | Retrieves the part of the specified object.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NMemberInfo Class
Show:
No members matching the current filter
Name | Description
Attributes | Gets member attributes.
DeclaringType | Gets the declaring type of the member.
Name | Gets member name.
NativeType | Defines the native type of the object.
NObjectPartInfo Class
Show:
No members matching the current filter
Name | Description
DeclaredConstants | Retrieves the collection of declared constants.
DeclaredEvents | Retrieves the collection of declared events.
DeclaredMethods | Retrieves the collection of declared methods.
DeclaredProperties | Retrieves the collection of declared proeprties.
NativeType | Defines the native type of the object.
PropertyName | Retrieves the name of an object part property.
NCollectionInfo Class
Name | Description
AddCollectionChangedCallbackMethod | Retrieves the method which adds a "collection changed" event callback to a collection.
AddCollectionChangedMethod | Retrieves the method which adds a "collection changed" event to a collection.
AddMethod | Retrieves the method which adds an item to a collection.
AddRangeMethod | Retrieves the method which adds a range of items to a collection.
ClearMethod | Retrieves the method which clears the collection.
GetCapacityMethod | Retrieves the method which gets the maximum number of items in the collection.
GetCountMethod | Retrieves the method which gets the number of items in the collection.
GetMethod | Retrieves the method which gets an item in the collection.
IndexOfMethod | Retrieves the method which gets an index of an item in the collection.
InsertMethod | Retrieves the method which adds an item to a collection at a specific index.
InsertRangeMethod | Retrieves the method which adds a range of items to a collection at a specific index.
ItemAttributes | Retrieves the attributes of items in the collection.
ItemFormat | Retrieves the type of items in the collection.
ItemMaxValue | Retrieves the maximal item value.
ItemMinValue | Retrieves the minimal item value.
ItemStdValues | Retrieves the collection of standard item values.
ItemType | Retrieves the type of items in the collection.
NativeType | Defines the native type of the object.
RemoveAtMethod | Retrieves the method which removes an item with specific index from a collection.
RemoveCollectionChangedCallbackMethod | Retrieves the method which removes a "collection changed" event callback from a collection.
RemoveCollectionChangedMethod | Retrieves the method which removes a "collection changed" event from a collection.
RemoveMethod | Retrieves the method which removes an item from a collection.
RemoveRangeMethod | Retrieves the method which removes a range of items from a collection.
SetCapacityMethod | Retrieves the method which sets the maximum number of items in the collection.
SetMethod | Retrieves the method which sets an item of the collection.
ToArrayMethod | Retrieves the method which converts the collection into a regular array.
Container

File: NCollectionInfo.cs

Namespace: Neurotec.Reflection

Module: .NET Reference


NCollectionInfo.ItemStdValueCollection Class

NCollectionInfo.ItemStdValueCollection Class

A collection of standard item values.

C#
public sealed class ItemStdValueCollection : DisposableStructReadOnlyCollection<KeyValuePair<string, object>, NNameValuePair_>;
Container

File: NCollectionInfo.cs

Namespace: Neurotec.Reflection

Module: .NET Reference


NCollectionInfo.AddCollectionChangedCallbackMethod Property

NCollectionInfo.AddCollectionChangedCallbackMethod Property
NCollectionInfo Class Neurotec.Reflection Namespace

Retrieves the method which adds a "collection changed" event callback to a collection.

C#
public NMethodInfo AddCollectionChangedCallbackMethod;


NCollectionInfo.AddCollectionChangedMethod Property

NCollectionInfo.AddCollectionChangedMethod Property
NCollectionInfo Class Neurotec.Reflection Namespace

Retrieves the method which adds a "collection changed" event to a collection.

C#
public NMethodInfo AddCollectionChangedMethod;


NCollectionInfo.AddMethod Property

NCollectionInfo.AddMethod Property
NCollectionInfo Class Neurotec.Reflection Namespace

Retrieves the method which adds an item to a collection.

C#
public NMethodInfo AddMethod;


NCollectionInfo.AddRangeMethod Property

NCollectionInfo.AddRangeMethod Property
NCollectionInfo Class Neurotec.Reflection Namespace

Retrieves the method which adds a range of items to a collection.

C#
public NMethodInfo AddRangeMethod;


NCollectionInfo.ClearMethod Property

NCollectionInfo.ClearMethod Property
NCollectionInfo Class Neurotec.Reflection Namespace

Retrieves the method which clears the collection.

C#
public NMethodInfo ClearMethod;


NCollectionInfo.GetCapacityMethod Property

NCollectionInfo.GetCapacityMethod Property
NCollectionInfo Class Neurotec.Reflection Namespace

Retrieves the method which gets the maximum number of items in the collection.

C#
public NMethodInfo GetCapacityMethod;


NCollectionInfo.GetCountMethod Property

NCollectionInfo.GetCountMethod Property
NCollectionInfo Class Neurotec.Reflection Namespace

Retrieves the method which gets the number of items in the collection.

C#
public NMethodInfo GetCountMethod;


NCollectionInfo.GetMethod Property

NCollectionInfo.GetMethod Property
NCollectionInfo Class Neurotec.Reflection Namespace

Retrieves the method which gets an item in the collection.

C#
public NMethodInfo GetMethod;


NCollectionInfo.IndexOfMethod Property

NCollectionInfo.IndexOfMethod Property
NCollectionInfo Class Neurotec.Reflection Namespace

Retrieves the method which gets an index of an item in the collection.

C#
public NMethodInfo IndexOfMethod;


NCollectionInfo.InsertMethod Property

NCollectionInfo.InsertMethod Property
NCollectionInfo Class Neurotec.Reflection Namespace

Retrieves the method which adds an item to a collection at a specific index.

C#
public NMethodInfo InsertMethod;


NCollectionInfo.InsertRangeMethod Property

NCollectionInfo.InsertRangeMethod Property
NCollectionInfo Class Neurotec.Reflection Namespace

Retrieves the method which adds a range of items to a collection at a specific index.

C#
public NMethodInfo InsertRangeMethod;


NCollectionInfo.ItemAttributes Property

NCollectionInfo.ItemAttributes Property
NCollectionInfo Class Neurotec.Reflection Namespace

Retrieves the attributes of items in the collection.

C#
public NAttributes ItemAttributes;


NCollectionInfo.ItemFormat Property

NCollectionInfo.ItemFormat Property
NCollectionInfo Class Neurotec.Reflection Namespace

Retrieves the type of items in the collection.

C#
public string ItemFormat;


NCollectionInfo.ItemMaxValue Property

NCollectionInfo.ItemMaxValue Property
NCollectionInfo Class Neurotec.Reflection Namespace

Retrieves the maximal item value.

C#
public object ItemMaxValue;


NCollectionInfo.ItemMinValue Property

NCollectionInfo.ItemMinValue Property
NCollectionInfo Class Neurotec.Reflection Namespace

Retrieves the minimal item value.

C#
public object ItemMinValue;


NCollectionInfo.ItemStdValues Property

NCollectionInfo.ItemStdValues Property
NCollectionInfo Class Neurotec.Reflection Namespace

Retrieves the collection of standard item values.

C#
public ItemStdValueCollection ItemStdValues;


NCollectionInfo.ItemType Property

NCollectionInfo.ItemType Property
NCollectionInfo Class Neurotec.Reflection Namespace

Retrieves the type of items in the collection.

C#
public NType ItemType;


NCollectionInfo.NativeType Property

NCollectionInfo.NativeType Property
NCollectionInfo Class Neurotec.Reflection Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NCollectionInfo.RemoveAtMethod Property

NCollectionInfo.RemoveAtMethod Property
NCollectionInfo Class Neurotec.Reflection Namespace

Retrieves the method which removes an item with specific index from a collection.

C#
public NMethodInfo RemoveAtMethod;


NCollectionInfo.RemoveCollectionChangedCallbackMethod Property

NCollectionInfo.RemoveCollectionChangedCallbackMethod Property
NCollectionInfo Class Neurotec.Reflection Namespace

Retrieves the method which removes a "collection changed" event callback from a collection.

C#
public NMethodInfo RemoveCollectionChangedCallbackMethod;


NCollectionInfo.RemoveCollectionChangedMethod Property

NCollectionInfo.RemoveCollectionChangedMethod Property
NCollectionInfo Class Neurotec.Reflection Namespace

Retrieves the method which removes a "collection changed" event from a collection.

C#
public NMethodInfo RemoveCollectionChangedMethod;


NCollectionInfo.RemoveMethod Property

NCollectionInfo.RemoveMethod Property
NCollectionInfo Class Neurotec.Reflection Namespace

Retrieves the method which removes an item from a collection.

C#
public NMethodInfo RemoveMethod;


NCollectionInfo.RemoveRangeMethod Property

NCollectionInfo.RemoveRangeMethod Property
NCollectionInfo Class Neurotec.Reflection Namespace

Retrieves the method which removes a range of items from a collection.

C#
public NMethodInfo RemoveRangeMethod;


NCollectionInfo.SetCapacityMethod Property

NCollectionInfo.SetCapacityMethod Property
NCollectionInfo Class Neurotec.Reflection Namespace

Retrieves the method which sets the maximum number of items in the collection.

C#
public NMethodInfo SetCapacityMethod;


NCollectionInfo.SetMethod Property

NCollectionInfo.SetMethod Property
NCollectionInfo Class Neurotec.Reflection Namespace

Retrieves the method which sets an item of the collection.

C#
public NMethodInfo SetMethod;


NCollectionInfo.ToArrayMethod Property

NCollectionInfo.ToArrayMethod Property
NCollectionInfo Class Neurotec.Reflection Namespace

Retrieves the method which converts the collection into a regular array.

C#
public NMethodInfo ToArrayMethod;


NConstantInfo Class

NConstantInfo Class
NObject Delegates NObject Events NObject Fields Legend Members NDisposable Methods NDisposable Properties

Provides functionality to retrieve information about constants.

C#
public sealed class NConstantInfo : NMemberInfo;
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NMemberInfo Class
Show:
No members matching the current filter
Name | Description
Attributes | Gets member attributes.
DeclaringType | Gets the declaring type of the member.
Name | Gets member name.
NativeType | Defines the native type of the object.
NConstantInfo Class
Name | Description
ConstantType | Gets the type of the constant.
NativeType | Defines the native type of the object.
Value | Gets the value of the current constant.
Container

File: NConstantInfo.cs

Namespace: Neurotec.Reflection

Module: .NET Reference


NConstantInfo.ConstantType Property

NConstantInfo.ConstantType Property
NConstantInfo Class Neurotec.Reflection Namespace

Gets the type of the constant.

C#
public NType ConstantType;


NConstantInfo.NativeType Property

NConstantInfo.NativeType Property
NConstantInfo Class Neurotec.Reflection Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NConstantInfo.Value Property

NConstantInfo.Value Property
NConstantInfo Class Neurotec.Reflection Namespace

Gets the value of the current constant.

C#
public object Value;


NDictionaryInfo Class

NDictionaryInfo Class
NObjectPartInfo Classes NObject Delegates NObject Events NObject Fields Legend Members NDisposable Methods NDisposable Properties

Provides functionality to retrieve information about dictionaries.

C#
public sealed class NDictionaryInfo : NObjectPartInfo;
Collapse Expand NObjectPartInfo Classes
NObjectPartInfo Class
Name | Description
DeclaredConstantCollection | Collection of declared constants.
DeclaredEventCollection | Collection of declared events.
DeclaredMethodCollection | Collection of declared methods.
DeclaredPropertyCollection | Collection of declared properties.
NDictionaryInfo Class
Name | Description
KeyStdValueCollection | A collection of standard item key values.
ValueStdValueCollection | A collection of standard item values.
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NObjectPartInfo Class
Show:
No members matching the current filter
Name | Description
GetDeclaredConstant | Retrieves the specified declared constant.
GetDeclaredEvent | Retrieves the specified declared event.
GetDeclaredMethod | Retrieves the specified declared method.
GetDeclaredMethods | Retrieves the specified declared methods.
GetDeclaredProperty | Retrieves the specified declared property.
GetObjectPart | Retrieves the part of the specified object.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NMemberInfo Class
Show:
No members matching the current filter
Name | Description
Attributes | Gets member attributes.
DeclaringType | Gets the declaring type of the member.
Name | Gets member name.
NativeType | Defines the native type of the object.
NObjectPartInfo Class
Show:
No members matching the current filter
Name | Description
DeclaredConstants | Retrieves the collection of declared constants.
DeclaredEvents | Retrieves the collection of declared events.
DeclaredMethods | Retrieves the collection of declared methods.
DeclaredProperties | Retrieves the collection of declared proeprties.
NativeType | Defines the native type of the object.
PropertyName | Retrieves the name of an object part property.
NDictionaryInfo Class
Name | Description
AddCollectionChangedCallbackMethod | Retrieves the method which adds a "collection changed" event callback to a dictionary.
AddCollectionChangedMethod | Retrieves the method which adds a "collection changed" event to a dictionary.
AddMethod | Retrieves the method which adds an item to a dictionary.
AddPairMethod | Retrieves the method which adds a key-value pair to a dictionary.
ClearMethod | Retrieves the method which clears the dictionary.
ContainsMethod | Retrieves the method which checks whether a dictionary contains a specific value.
GetAtMethod | Retrieves the method which gets an item in the dictionary specified by index.
GetCountMethod | Retrieves the method which gets the number of items in the dictionary.
GetKeyMethod | Retrieves the method which gets a key of an item in the dictionary.
GetMethod | Retrieves the method which gets an item in the dictionary.
GetValueMethod | Retrieves the method which gets a value of an item in the dictionary.
ItemAttributes | Retrieves the attributes of items in the dictionary.
ItemType | Retrieves the type of items in the dictionary.
KeyAttributes | Retrieves the attributes of item keys in the dictionary.
KeyFormat | Retrieves the type of item keys in the dictionary.
KeyMaxValue | Retrieves the maximal item key value.
KeyMinValue | Retrieves the minimal item key value.
KeyStdValues | Retrieves the collection of standard item keys.
KeyType | Retrieves the type of item keys in the dictionary.
NativeType | Defines the native type of the object.
RemoveAtMethod | Retrieves the method which removes an item with specific index from the dictionary.
RemoveCollectionChangedCallbackMethod | Retrieves the method which removes a "collection changed" event callback from a dictionary.
RemoveCollectionChangedMethod | Retrieves the method which removes a "collection changed" event from a dictionary.
RemoveMethod | Retrieves the method which removes an item from a dictionary.
SetMethod | Retrieves the method which sets a value of an item in the dictionary.
ToArrayMethod | Retrieves the method which converts the dictionary into an array.
ToKeyArrayMethod | Retrieves the method which converts the dictionary into an array of item keys.
ToValueArrayMethod | Retrieves the method which converts the dictionary into an array of item values.
TryGetMethod | Retrieves the method which gets an item in the dictionary and returns a Boolean value indicating success.
ValueAttributes | Retrieves the attributes of item values in the dictionary.
ValueFormat | Retrieves the type of item values in the dictionary.
ValueMaxValue | Retrieves the maximal item value.
ValueMinValue | Retrieves the minimal item value.
ValueStdValues | Retrieves the collection of standard item values.
ValueType | Retrieves the type of item values in the dictionary.
Container

File: NDictionaryInfo.cs

Namespace: Neurotec.Reflection

Module: .NET Reference


NDictionaryInfo.KeyStdValueCollection Class

NDictionaryInfo.KeyStdValueCollection Class

A collection of standard item key values.

C#
public sealed class KeyStdValueCollection : DisposableStructReadOnlyCollection<KeyValuePair<string, object>, NNameValuePair_>;
Container

File: NDictionaryInfo.cs

Namespace: Neurotec.Reflection

Module: .NET Reference


NDictionaryInfo.ValueStdValueCollection Class

NDictionaryInfo.ValueStdValueCollection Class

A collection of standard item values.

C#
public sealed class ValueStdValueCollection : DisposableStructReadOnlyCollection<KeyValuePair<string, object>, NNameValuePair_>;
Container

File: NDictionaryInfo.cs

Namespace: Neurotec.Reflection

Module: .NET Reference


NDictionaryInfo.AddCollectionChangedCallbackMethod Property

NDictionaryInfo.AddCollectionChangedCallbackMethod Property
NDictionaryInfo Class Neurotec.Reflection Namespace

Retrieves the method which adds a "collection changed" event callback to a dictionary.

C#
public NMethodInfo AddCollectionChangedCallbackMethod;


NDictionaryInfo.AddCollectionChangedMethod Property

NDictionaryInfo.AddCollectionChangedMethod Property
NDictionaryInfo Class Neurotec.Reflection Namespace

Retrieves the method which adds a "collection changed" event to a dictionary.

C#
public NMethodInfo AddCollectionChangedMethod;


NDictionaryInfo.AddMethod Property

NDictionaryInfo.AddMethod Property
NDictionaryInfo Class Neurotec.Reflection Namespace

Retrieves the method which adds an item to a dictionary.

C#
public NMethodInfo AddMethod;


NDictionaryInfo.AddPairMethod Property

NDictionaryInfo.AddPairMethod Property
NDictionaryInfo Class Neurotec.Reflection Namespace

Retrieves the method which adds a key-value pair to a dictionary.

C#
public NMethodInfo AddPairMethod;


NDictionaryInfo.ClearMethod Property

NDictionaryInfo.ClearMethod Property
NDictionaryInfo Class Neurotec.Reflection Namespace

Retrieves the method which clears the dictionary.

C#
public NMethodInfo ClearMethod;


NDictionaryInfo.ContainsMethod Property

NDictionaryInfo.ContainsMethod Property
NDictionaryInfo Class Neurotec.Reflection Namespace

Retrieves the method which checks whether a dictionary contains a specific value.

C#
public NMethodInfo ContainsMethod;


NDictionaryInfo.GetAtMethod Property

NDictionaryInfo.GetAtMethod Property
NDictionaryInfo Class Neurotec.Reflection Namespace

Retrieves the method which gets an item in the dictionary specified by index.

C#
public NMethodInfo GetAtMethod;


NDictionaryInfo.GetCountMethod Property

NDictionaryInfo.GetCountMethod Property
NDictionaryInfo Class Neurotec.Reflection Namespace

Retrieves the method which gets the number of items in the dictionary.

C#
public NMethodInfo GetCountMethod;


NDictionaryInfo.GetKeyMethod Property

NDictionaryInfo.GetKeyMethod Property
NDictionaryInfo Class Neurotec.Reflection Namespace

Retrieves the method which gets a key of an item in the dictionary.

C#
public NMethodInfo GetKeyMethod;


NDictionaryInfo.GetMethod Property

NDictionaryInfo.GetMethod Property
NDictionaryInfo Class Neurotec.Reflection Namespace

Retrieves the method which gets an item in the dictionary.

C#
public NMethodInfo GetMethod;


NDictionaryInfo.GetValueMethod Property

NDictionaryInfo.GetValueMethod Property
NDictionaryInfo Class Neurotec.Reflection Namespace

Retrieves the method which gets a value of an item in the dictionary.

C#
public NMethodInfo GetValueMethod;


NDictionaryInfo.ItemAttributes Property

NDictionaryInfo.ItemAttributes Property
NDictionaryInfo Class Neurotec.Reflection Namespace

Retrieves the attributes of items in the dictionary.

C#
public NAttributes ItemAttributes;


NDictionaryInfo.ItemType Property

NDictionaryInfo.ItemType Property
NDictionaryInfo Class Neurotec.Reflection Namespace

Retrieves the type of items in the dictionary.

C#
public NType ItemType;


NDictionaryInfo.KeyAttributes Property

NDictionaryInfo.KeyAttributes Property
NDictionaryInfo Class Neurotec.Reflection Namespace

Retrieves the attributes of item keys in the dictionary.

C#
public NAttributes KeyAttributes;


NDictionaryInfo.KeyFormat Property

NDictionaryInfo.KeyFormat Property
NDictionaryInfo Class Neurotec.Reflection Namespace

Retrieves the type of item keys in the dictionary.

C#
public string KeyFormat;


NDictionaryInfo.KeyMaxValue Property

NDictionaryInfo.KeyMaxValue Property
NDictionaryInfo Class Neurotec.Reflection Namespace

Retrieves the maximal item key value.

C#
public object KeyMaxValue;


NDictionaryInfo.KeyMinValue Property

NDictionaryInfo.KeyMinValue Property
NDictionaryInfo Class Neurotec.Reflection Namespace

Retrieves the minimal item key value.

C#
public object KeyMinValue;


NDictionaryInfo.KeyStdValues Property

NDictionaryInfo.KeyStdValues Property
NDictionaryInfo Class Neurotec.Reflection Namespace

Retrieves the collection of standard item keys.

C#
public KeyStdValueCollection KeyStdValues;


NDictionaryInfo.KeyType Property

NDictionaryInfo.KeyType Property
NDictionaryInfo Class Neurotec.Reflection Namespace

Retrieves the type of item keys in the dictionary.

C#
public NType KeyType;


NDictionaryInfo.NativeType Property

NDictionaryInfo.NativeType Property
NDictionaryInfo Class Neurotec.Reflection Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NDictionaryInfo.RemoveAtMethod Property

NDictionaryInfo.RemoveAtMethod Property
NDictionaryInfo Class Neurotec.Reflection Namespace

Retrieves the method which removes an item with specific index from the dictionary.

C#
public NMethodInfo RemoveAtMethod;


NDictionaryInfo.RemoveCollectionChangedCallbackMethod Property

NDictionaryInfo.RemoveCollectionChangedCallbackMethod Property
NDictionaryInfo Class Neurotec.Reflection Namespace

Retrieves the method which removes a "collection changed" event callback from a dictionary.

C#
public NMethodInfo RemoveCollectionChangedCallbackMethod;


NDictionaryInfo.RemoveCollectionChangedMethod Property

NDictionaryInfo.RemoveCollectionChangedMethod Property
NDictionaryInfo Class Neurotec.Reflection Namespace

Retrieves the method which removes a "collection changed" event from a dictionary.

C#
public NMethodInfo RemoveCollectionChangedMethod;


NDictionaryInfo.RemoveMethod Property

NDictionaryInfo.RemoveMethod Property
NDictionaryInfo Class Neurotec.Reflection Namespace

Retrieves the method which removes an item from a dictionary.

C#
public NMethodInfo RemoveMethod;


NDictionaryInfo.SetMethod Property

NDictionaryInfo.SetMethod Property
NDictionaryInfo Class Neurotec.Reflection Namespace

Retrieves the method which sets a value of an item in the dictionary.

C#
public NMethodInfo SetMethod;


NDictionaryInfo.ToArrayMethod Property

NDictionaryInfo.ToArrayMethod Property
NDictionaryInfo Class Neurotec.Reflection Namespace

Retrieves the method which converts the dictionary into an array.

C#
public NMethodInfo ToArrayMethod;


NDictionaryInfo.ToKeyArrayMethod Property

NDictionaryInfo.ToKeyArrayMethod Property
NDictionaryInfo Class Neurotec.Reflection Namespace

Retrieves the method which converts the dictionary into an array of item keys.

C#
public NMethodInfo ToKeyArrayMethod;


NDictionaryInfo.ToValueArrayMethod Property

NDictionaryInfo.ToValueArrayMethod Property
NDictionaryInfo Class Neurotec.Reflection Namespace

Retrieves the method which converts the dictionary into an array of item values.

C#
public NMethodInfo ToValueArrayMethod;


NDictionaryInfo.TryGetMethod Property

NDictionaryInfo.TryGetMethod Property
NDictionaryInfo Class Neurotec.Reflection Namespace

Retrieves the method which gets an item in the dictionary and returns a Boolean value indicating success.

C#
public NMethodInfo TryGetMethod;


NDictionaryInfo.ValueAttributes Property

NDictionaryInfo.ValueAttributes Property
NDictionaryInfo Class Neurotec.Reflection Namespace

Retrieves the attributes of item values in the dictionary.

C#
public NAttributes ValueAttributes;


NDictionaryInfo.ValueFormat Property

NDictionaryInfo.ValueFormat Property
NDictionaryInfo Class Neurotec.Reflection Namespace

Retrieves the type of item values in the dictionary.

C#
public string ValueFormat;


NDictionaryInfo.ValueMaxValue Property

NDictionaryInfo.ValueMaxValue Property
NDictionaryInfo Class Neurotec.Reflection Namespace

Retrieves the maximal item value.

C#
public object ValueMaxValue;


NDictionaryInfo.ValueMinValue Property

NDictionaryInfo.ValueMinValue Property
NDictionaryInfo Class Neurotec.Reflection Namespace

Retrieves the minimal item value.

C#
public object ValueMinValue;


NDictionaryInfo.ValueStdValues Property

NDictionaryInfo.ValueStdValues Property
NDictionaryInfo Class Neurotec.Reflection Namespace

Retrieves the collection of standard item values.

C#
public ValueStdValueCollection ValueStdValues;


NDictionaryInfo.ValueType Property

NDictionaryInfo.ValueType Property
NDictionaryInfo Class Neurotec.Reflection Namespace

Retrieves the type of item values in the dictionary.

C#
public NType ValueType;


NEnumConstantInfo Class

NEnumConstantInfo Class
NObject Delegates NObject Events NObject Fields Legend Members NDisposable Methods NDisposable Properties

Provides functionality to retrieve information about enumeration constants.

C#
public sealed class NEnumConstantInfo : NMemberInfo;
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NMemberInfo Class
Show:
No members matching the current filter
Name | Description
Attributes | Gets member attributes.
DeclaringType | Gets the declaring type of the member.
Name | Gets member name.
NativeType | Defines the native type of the object.
NEnumConstantInfo Class
Name | Description
NativeType | Defines the native type of the object.
Value | Gets the value of the current enum constant.
Container

File: NEnumConstantInfo.cs

Namespace: Neurotec.Reflection

Module: .NET Reference


NEnumConstantInfo.NativeType Property

NEnumConstantInfo.NativeType Property
NEnumConstantInfo Class Neurotec.Reflection Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NEnumConstantInfo.Value Property

NEnumConstantInfo.Value Property
NEnumConstantInfo Class Neurotec.Reflection Namespace

Gets the value of the current enum constant.

C#
public object Value;


NEventInfo Class

NEventInfo Class
NObject Delegates NObject Events NObject Fields Legend Members NDisposable Methods NDisposable Properties

Provides functionality to retrieve information about events.

C#
public sealed class NEventInfo : NMemberInfo;
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NEventInfo Class
Name | Description
AddHandler | Binds the event to the object.
RemoveHandler | Unbinds the delegate from the object so that the delegate will no longer receive events from the object.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NMemberInfo Class
Show:
No members matching the current filter
Name | Description
Attributes | Gets member attributes.
DeclaringType | Gets the declaring type of the member.
Name | Gets member name.
NativeType | Defines the native type of the object.
NEventInfo Class
Name | Description
AddCallbackMethod | Retrieves the method which adds a callback to the event.
AddMethod | Retrieves a method which adds an event.
EventType | Gets the type of the event.
NativeType | Defines the native type of the object.
RemoveCallbackMethod | Retrieves the method which removes a callback from the event.
RemoveMethod | Retrieves a method which removes an event.
Container

File: NEventInfo.cs

Namespace: Neurotec.Reflection

Module: .NET Reference


NEventInfo.AddHandler Method

NEventInfo.AddHandler Method
NEventInfo Class Neurotec.Reflection Namespace

Binds the event to the object.

C#
public void AddHandler(NObject @object, Delegate value);
Collapse Expand Parameters
Parameters | Description
NObject @object | The object the event binds to.
Delegate value | The event delegate.


NEventInfo.RemoveHandler Method

NEventInfo.RemoveHandler Method
NEventInfo Class Neurotec.Reflection Namespace

Unbinds the delegate from the object so that the delegate will no longer receive events from the object.

C#
public void RemoveHandler(NObject @object, Delegate value);
Collapse Expand Parameters
Parameters | Description
NObject @object | The object the event binds to.
Delegate value | The event delegate.


NEventInfo.AddCallbackMethod Property

NEventInfo.AddCallbackMethod Property
NEventInfo Class Neurotec.Reflection Namespace

Retrieves the method which adds a callback to the event.

C#
public NMethodInfo AddCallbackMethod;


NEventInfo.AddMethod Property

NEventInfo.AddMethod Property
NEventInfo Class Neurotec.Reflection Namespace

Retrieves a method which adds an event.

C#
public NMethodInfo AddMethod;


NEventInfo.EventType Property

NEventInfo.EventType Property
NEventInfo Class Neurotec.Reflection Namespace

Gets the type of the event.

C#
public NType EventType;


NEventInfo.NativeType Property

NEventInfo.NativeType Property
NEventInfo Class Neurotec.Reflection Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NEventInfo.RemoveCallbackMethod Property

NEventInfo.RemoveCallbackMethod Property
NEventInfo Class Neurotec.Reflection Namespace

Retrieves the method which removes a callback from the event.

C#
public NMethodInfo RemoveCallbackMethod;


NEventInfo.RemoveMethod Property

NEventInfo.RemoveMethod Property
NEventInfo Class Neurotec.Reflection Namespace

Retrieves a method which removes an event.

C#
public NMethodInfo RemoveMethod;


NMemberInfo Class

NMemberInfo Class
NObject Delegates NObject Events NObject Fields Legend Members NDisposable Methods NDisposable Properties

Provides functionality to retrieve information about class members.

C#
public class NMemberInfo : NObject;
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NMemberInfo Class
Name | Description
Attributes | Gets member attributes.
DeclaringType | Gets the declaring type of the member.
Name | Gets member name.
NativeType | Defines the native type of the object.
Container

File: NMemberInfo.cs

Namespace: Neurotec.Reflection

Module: .NET Reference


NMemberInfo.Attributes Property

NMemberInfo.Attributes Property
NMemberInfo Class Neurotec.Reflection Namespace

Gets member attributes.

C#
public NAttributes Attributes;


NMemberInfo.DeclaringType Property

NMemberInfo.DeclaringType Property
NMemberInfo Class Neurotec.Reflection Namespace

Gets the declaring type of the member.

C#
public NType DeclaringType;


NMemberInfo.Name Property

NMemberInfo.Name Property
NMemberInfo Class Neurotec.Reflection Namespace

Gets member name.

C#
public string Name;


NMemberInfo.NativeType Property

NMemberInfo.NativeType Property
NMemberInfo Class Neurotec.Reflection Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NMethodInfo Class

NMethodInfo Class
NMethodInfo Classes NObject Delegates NObject Events NObject Fields Legend Members NDisposable Methods NDisposable Properties

Provides functions for getting information about property.

C#
public sealed class NMethodInfo : NMemberInfo;
Collapse Expand NMethodInfo Classes
NMethodInfo Class
Name | Description
ParameterCollection | Parameters collection of the invoked method.
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NMethodInfo Class
Name | Description
Invoke | Invokes the specified object with property bag.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NMemberInfo Class
Show:
No members matching the current filter
Name | Description
Attributes | Gets member attributes.
DeclaringType | Gets the declaring type of the member.
Name | Gets member name.
NativeType | Defines the native type of the object.
NMethodInfo Class
Name | Description
NativeName | Gets the native name of the specified method.
NativeType | Defines the native type of the object.
Parameters | Gets all parameters of the specified method.
ReturnParameter | Gets the return parameter of the invoked method.
Container

File: NMethodInfo.cs

Namespace: Neurotec.Reflection

Module: .NET Reference


NMethodInfo.ParameterCollection Class

NMethodInfo.ParameterCollection Class

Parameters collection of the invoked method.

C#
public sealed class ParameterCollection : NObjectReadOnlyCollection<NParameterInfo>;
Container

File: NMethodInfo.cs

Namespace: Neurotec.Reflection

Module: .NET Reference


NMethodInfo.Invoke Method (NObject, NPropertyBag)

NMethodInfo.Invoke Method (NObject, NPropertyBag)
NMethodInfo Class Neurotec.Reflection Namespace

Invokes the specified object with property bag.

C#
public object Invoke(NObject @object, NPropertyBag parameters);
Collapse Expand Parameters
Parameters | Description
NObject @object | Object on which the method will be invoked.
NPropertyBag parameters | Property bag containing values with the same number, order, and type as the parameters of the method or constructor to be invoked.
Collapse Expand Returns

Object returned by the invoked method.


NMethodInfo.Invoke Method (NObject, object[])

NMethodInfo.Invoke Method (NObject, object[])
NMethodInfo Class Neurotec.Reflection Namespace

Invokes the specified object with parameters.

C#
public object Invoke(NObject @object, object[] parameters);
Collapse Expand Parameters
Parameters | Description
NObject @object | Object on which the method will be invoked.
object[] parameters | Parameters of the method.
Collapse Expand Returns

Object returned by the invoked method.


NMethodInfo.Invoke Method (NObject, string)

NMethodInfo.Invoke Method (NObject, string)
NMethodInfo Class Neurotec.Reflection Namespace

Invokes the specified object with string parameters.

C#
public object Invoke(NObject @object, string parameters);
Collapse Expand Parameters
Parameters | Description
NObject @object | Object on which the method will be invoked.
string parameters | String representing the parameters of the method
Collapse Expand Returns

Object returned by the invoked method.


NMethodInfo.NativeName Property

NMethodInfo.NativeName Property
NMethodInfo Class Neurotec.Reflection Namespace

Gets the native name of the specified method.

C#
public string NativeName;
Property value

Native name of the method.


NMethodInfo.NativeType Property

NMethodInfo.NativeType Property
NMethodInfo Class Neurotec.Reflection Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NMethodInfo.Parameters Property

NMethodInfo.Parameters Property
NMethodInfo Class Neurotec.Reflection Namespace

Gets all parameters of the specified method.

C#
public ParameterCollection Parameters;
Property value

Parameters collection.


NMethodInfo.ReturnParameter Property

NMethodInfo.ReturnParameter Property
NMethodInfo Class Neurotec.Reflection Namespace

Gets the return parameter of the invoked method.

C#
public NParameterInfo ReturnParameter;
Property value

Parameter info object.


NObjectPartInfo Class

NObjectPartInfo Class
NObjectPartInfo Classes NObject Delegates NObject Events NObject Fields Legend Members NDisposable Methods NDisposable Properties

Provides functionality to retrieve information about object parts.

C#
public class NObjectPartInfo : NMemberInfo;
Collapse Expand NObjectPartInfo Classes
NObjectPartInfo Class
Name | Description
DeclaredConstantCollection | Collection of declared constants.
DeclaredEventCollection | Collection of declared events.
DeclaredMethodCollection | Collection of declared methods.
DeclaredPropertyCollection | Collection of declared properties.
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NObjectPartInfo Class
Name | Description
GetDeclaredConstant | Retrieves the specified declared constant.
GetDeclaredEvent | Retrieves the specified declared event.
GetDeclaredMethod | Retrieves the specified declared method.
GetDeclaredMethods | Retrieves the specified declared methods.
GetDeclaredProperty | Retrieves the specified declared property.
GetObjectPart | Retrieves the part of the specified object.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NMemberInfo Class
Show:
No members matching the current filter
Name | Description
Attributes | Gets member attributes.
DeclaringType | Gets the declaring type of the member.
Name | Gets member name.
NativeType | Defines the native type of the object.
NObjectPartInfo Class
Name | Description
DeclaredConstants | Retrieves the collection of declared constants.
DeclaredEvents | Retrieves the collection of declared events.
DeclaredMethods | Retrieves the collection of declared methods.
DeclaredProperties | Retrieves the collection of declared proeprties.
NativeType | Defines the native type of the object.
PropertyName | Retrieves the name of an object part property.
Container

File: NObjectPartInfo.cs

Namespace: Neurotec.Reflection

Module: .NET Reference


NObjectPartInfo.DeclaredConstantCollection Class

NObjectPartInfo.DeclaredConstantCollection Class

Collection of declared constants.

C#
public sealed class DeclaredConstantCollection : NObjectReadOnlyCollection<NConstantInfo>;
Container

File: NObjectPartInfo.cs

Namespace: Neurotec.Reflection

Module: .NET Reference


NObjectPartInfo.DeclaredEventCollection Class

NObjectPartInfo.DeclaredEventCollection Class

Collection of declared events.

C#
public sealed class DeclaredEventCollection : NObjectReadOnlyCollection<NEventInfo>;
Container

File: NObjectPartInfo.cs

Namespace: Neurotec.Reflection

Module: .NET Reference


NObjectPartInfo.DeclaredMethodCollection Class

NObjectPartInfo.DeclaredMethodCollection Class

Collection of declared methods.

C#
public sealed class DeclaredMethodCollection : NObjectReadOnlyCollection<NMethodInfo>;
Container

File: NObjectPartInfo.cs

Namespace: Neurotec.Reflection

Module: .NET Reference


NObjectPartInfo.DeclaredPropertyCollection Class

NObjectPartInfo.DeclaredPropertyCollection Class

Collection of declared properties.

C#
public sealed class DeclaredPropertyCollection : NObjectReadOnlyCollection<NPropertyInfo>;
Container

File: NObjectPartInfo.cs

Namespace: Neurotec.Reflection

Module: .NET Reference


NObjectPartInfo.GetDeclaredConstant Method

NObjectPartInfo.GetDeclaredConstant Method
NObjectPartInfo Class Neurotec.Reflection Namespace

Retrieves the specified declared constant.

C#
public NConstantInfo GetDeclaredConstant(string name);
Collapse Expand Parameters
Parameters | Description
string name | Name of the constant.
Collapse Expand Returns

The declared constant.


NObjectPartInfo.GetDeclaredEvent Method

NObjectPartInfo.GetDeclaredEvent Method
NObjectPartInfo Class Neurotec.Reflection Namespace

Retrieves the specified declared event.

C#
public NEventInfo GetDeclaredEvent(string name);
Collapse Expand Parameters
Parameters | Description
string name | Name of the event.
Collapse Expand Returns

The declared event.


NObjectPartInfo.GetDeclaredMethod Method

NObjectPartInfo.GetDeclaredMethod Method
NObjectPartInfo Class Neurotec.Reflection Namespace

Retrieves the specified declared method.

C#
public NMethodInfo GetDeclaredMethod(string name);
Collapse Expand Parameters
Parameters | Description
string name | Name of the method.
Collapse Expand Returns

The declared method.


NObjectPartInfo.GetDeclaredMethods Method

NObjectPartInfo.GetDeclaredMethods Method
NObjectPartInfo Class Neurotec.Reflection Namespace

Retrieves the specified declared methods.

C#
public NMethodInfo[] GetDeclaredMethods(string name);
Collapse Expand Parameters
Parameters | Description
string name | Names of the methods.
Collapse Expand Returns

An array of declared methods.


NObjectPartInfo.GetDeclaredProperty Method

NObjectPartInfo.GetDeclaredProperty Method
NObjectPartInfo Class Neurotec.Reflection Namespace

Retrieves the specified declared property.

C#
public NPropertyInfo GetDeclaredProperty(string name);
Collapse Expand Parameters
Parameters | Description
string name | Name of the property.
Collapse Expand Returns

The declared property.


NObjectPartInfo.GetObjectPart Method

NObjectPartInfo.GetObjectPart Method
NObjectPartInfo Class Neurotec.Reflection Namespace

Retrieves the part of the specified object.

C#
public NObjectPart GetObjectPart(NObject @object);
Collapse Expand Parameters
Parameters | Description
NObject @object | The object to retrieve a part of.
Collapse Expand Returns

The object part.


NObjectPartInfo.DeclaredConstants Property

NObjectPartInfo.DeclaredConstants Property
NObjectPartInfo Class Neurotec.Reflection Namespace

Retrieves the collection of declared constants.

C#
public DeclaredConstantCollection DeclaredConstants;


NObjectPartInfo.DeclaredEvents Property

NObjectPartInfo.DeclaredEvents Property
NObjectPartInfo Class Neurotec.Reflection Namespace

Retrieves the collection of declared events.

C#
public DeclaredEventCollection DeclaredEvents;


NObjectPartInfo.DeclaredMethods Property

NObjectPartInfo.DeclaredMethods Property
NObjectPartInfo Class Neurotec.Reflection Namespace

Retrieves the collection of declared methods.

C#
public DeclaredMethodCollection DeclaredMethods;


NObjectPartInfo.DeclaredProperties Property

NObjectPartInfo.DeclaredProperties Property
NObjectPartInfo Class Neurotec.Reflection Namespace

Retrieves the collection of declared proeprties.

C#
public DeclaredPropertyCollection DeclaredProperties;


NObjectPartInfo.NativeType Property

NObjectPartInfo.NativeType Property
NObjectPartInfo Class Neurotec.Reflection Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NObjectPartInfo.PropertyName Property

NObjectPartInfo.PropertyName Property
NObjectPartInfo Class Neurotec.Reflection Namespace

Retrieves the name of an object part property.

C#
public string PropertyName;


NParameterInfo Class

NParameterInfo Class
NParameterInfo Classes NObject Delegates NObject Events NObject Fields Legend Members NDisposable Methods NDisposable Properties

Provides functions for getting information about parameter.

C#
public sealed class NParameterInfo : NObject;
Collapse Expand NParameterInfo Classes
NParameterInfo Class
Name | Description
StdValueCollection | Represents an array of standard parameter values.
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NParameterInfo Class
Name | Description
Attributes | Gets parameter attributes.
DefaultValue | Gets the default value of the current parameter.
Format | Gets the format of the current parameter.
MaxValue | Gets the maximum value of the current parameter.
MinValue | Gets the minimum value of the current parameter.
Name | Gets parameter name.
NativeType | Defines the native type of the object.
ParameterType | Gets the type of the parameter.
StdValues | Gets the collection of standard values for the current parameter.
Container

File: NParameterInfo.cs

Namespace: Neurotec.Reflection

Module: .NET Reference


NParameterInfo.StdValueCollection Class

NParameterInfo.StdValueCollection Class

Represents an array of standard parameter values.

C#
public sealed class StdValueCollection : DisposableStructReadOnlyCollection<KeyValuePair<string, object>, NNameValuePair_>;
Container

File: NParameterInfo.cs

Namespace: Neurotec.Reflection

Module: .NET Reference


NParameterInfo.Attributes Property

NParameterInfo.Attributes Property
NParameterInfo Class Neurotec.Reflection Namespace

Gets parameter attributes.

C#
public NAttributes Attributes;


NParameterInfo.DefaultValue Property

NParameterInfo.DefaultValue Property
NParameterInfo Class Neurotec.Reflection Namespace

Gets the default value of the current parameter.

C#
public object DefaultValue;


NParameterInfo.Format Property

NParameterInfo.Format Property
NParameterInfo Class Neurotec.Reflection Namespace

Gets the format of the current parameter.

C#
public string Format;


NParameterInfo.MaxValue Property

NParameterInfo.MaxValue Property
NParameterInfo Class Neurotec.Reflection Namespace

Gets the maximum value of the current parameter.

C#
public object MaxValue;


NParameterInfo.MinValue Property

NParameterInfo.MinValue Property
NParameterInfo Class Neurotec.Reflection Namespace

Gets the minimum value of the current parameter.

C#
public object MinValue;


NParameterInfo.Name Property

NParameterInfo.Name Property
NParameterInfo Class Neurotec.Reflection Namespace

Gets parameter name.

C#
public string Name;


NParameterInfo.NativeType Property

NParameterInfo.NativeType Property
NParameterInfo Class Neurotec.Reflection Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NParameterInfo.ParameterType Property

NParameterInfo.ParameterType Property
NParameterInfo Class Neurotec.Reflection Namespace

Gets the type of the parameter.

C#
public NType ParameterType;


NParameterInfo.StdValues Property

NParameterInfo.StdValues Property
NParameterInfo Class Neurotec.Reflection Namespace

Gets the collection of standard values for the current parameter.

C#
public StdValueCollection StdValues;


NPropertyInfo Class

NPropertyInfo Class
NPropertyInfo Classes NObject Delegates NObject Events NObject Fields Legend Members NDisposable Methods NDisposable Properties

Provides functionality to retrieve and change information about properties.

C#
public sealed class NPropertyInfo : NMemberInfo;
Collapse Expand NPropertyInfo Classes
NPropertyInfo Class
Name | Description
StdValueCollection | Represents an array of standard property values.
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NPropertyInfo Class
Name | Description
CanResetValue | Checks whether the value of the property can be reset.
GetValue | Retrieves the value of the component.
ResetValue | Resets the value of the specified property.
SetValue | Sets the value of the specified component.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NMemberInfo Class
Show:
No members matching the current filter
Name | Description
Attributes | Gets member attributes.
DeclaringType | Gets the declaring type of the member.
Name | Gets member name.
NativeType | Defines the native type of the object.
NPropertyInfo Class
Name | Description
DefaultValue | Gets the default value of the property.
Format | Gets the format of the property.
GetMethod | Retrieves the method which gets the value of the property.
MaxValue | Gets the maximum value of the property.
MinValue | Gets the minimum value of the property.
NativeType | Defines the native type of the object.
PropertyType | Gets the type of the property.
SetMethod | Retrieves the method which sets the value of the property.
StdValues | Gets the collection of standard values for the property.
Container

File: NPropertyInfo.cs

Namespace: Neurotec.Reflection

Module: .NET Reference


NPropertyInfo.StdValueCollection Class

NPropertyInfo.StdValueCollection Class

Represents an array of standard property values.

C#
public sealed class StdValueCollection : DisposableStructReadOnlyCollection<KeyValuePair<string, object>, NNameValuePair_>;
Container

File: NPropertyInfo.cs

Namespace: Neurotec.Reflection

Module: .NET Reference


NPropertyInfo.CanResetValue Method

NPropertyInfo.CanResetValue Method
NPropertyInfo Class Neurotec.Reflection Namespace

Checks whether the value of the property can be reset.

C#
public bool CanResetValue();
Collapse Expand Returns

true if the property's value can be reset; else false.


NPropertyInfo.GetValue Method

NPropertyInfo.GetValue Method
NPropertyInfo Class Neurotec.Reflection Namespace

Retrieves the value of the component.

C#
public object GetValue(NObject @object);
Collapse Expand Parameters
Parameters | Description
NObject @object | The object to get value of.
Collapse Expand Returns

The value of the property.


NPropertyInfo.ResetValue Method

NPropertyInfo.ResetValue Method
NPropertyInfo Class Neurotec.Reflection Namespace

Resets the value of the specified property.

C#
public void ResetValue(NObject @object);
Collapse Expand Parameters
Parameters | Description
NObject @object | The object to reset property for.


NPropertyInfo.SetValue Method

NPropertyInfo.SetValue Method
NPropertyInfo Class Neurotec.Reflection Namespace

Sets the value of the specified component.

C#
public void SetValue(NObject @object, object value);
Collapse Expand Parameters
Parameters | Description
NObject @object | The object to set value of.
object value | The new value of the property.


NPropertyInfo.DefaultValue Property

NPropertyInfo.DefaultValue Property
NPropertyInfo Class Neurotec.Reflection Namespace

Gets the default value of the property.

C#
public object DefaultValue;


NPropertyInfo.Format Property

NPropertyInfo.Format Property
NPropertyInfo Class Neurotec.Reflection Namespace

Gets the format of the property.

C#
public string Format;


NPropertyInfo.GetMethod Property

NPropertyInfo.GetMethod Property
NPropertyInfo Class Neurotec.Reflection Namespace

Retrieves the method which gets the value of the property.

C#
public NMethodInfo GetMethod;


NPropertyInfo.MaxValue Property

NPropertyInfo.MaxValue Property
NPropertyInfo Class Neurotec.Reflection Namespace

Gets the maximum value of the property.

C#
public object MaxValue;


NPropertyInfo.MinValue Property

NPropertyInfo.MinValue Property
NPropertyInfo Class Neurotec.Reflection Namespace

Gets the minimum value of the property.

C#
public object MinValue;


NPropertyInfo.NativeType Property

NPropertyInfo.NativeType Property
NPropertyInfo Class Neurotec.Reflection Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NPropertyInfo.PropertyType Property

NPropertyInfo.PropertyType Property
NPropertyInfo Class Neurotec.Reflection Namespace

Gets the type of the property.

C#
public NType PropertyType;


NPropertyInfo.SetMethod Property

NPropertyInfo.SetMethod Property
NPropertyInfo Class Neurotec.Reflection Namespace

Retrieves the method which sets the value of the property.

C#
public NMethodInfo SetMethod;


NPropertyInfo.StdValues Property

NPropertyInfo.StdValues Property
NPropertyInfo Class Neurotec.Reflection Namespace

Gets the collection of standard values for the property.

C#
public StdValueCollection StdValues;


Neurotec.Surveillance Namespace

Neurotec.Surveillance Namespace
Classes Legend Structs, Records, Enums

Provides functionality for biometric face identification, detection of moving pedestrians or vehicles or other objects and performs automatic license plate recognition using live video streams from digital surveillance cameras.

Collapse Expand Classes
Name | Description
NClothingDetails | Represents subject's clothing and gender details.
NLicensePlate | Provides car's license plate recognition functionality.
NLicensePlateDetails | Represents car's license plate details.
NNameConfidencePair | Structure containing name and/or confidence values.
NSurveillance | Base Surveillance class.
NSurveillanceDetectionDetails | Represents surveillance detection details.
NSurveillanceDetectionResult | Represents object's detection result.
NSurveillanceEngine | Provides functionality for Surveillance engine.
NSurveillanceEventArgs | A class that is passed to event handler and through which event data can be accessed.
NSurveillanceEventDetails | A class that provides access to event details data.
NSurveillanceObjectColorDetails | Represents surveillance object color details.
NSurveillanceObjectDirectionDetails | Represents detected object direction details.
NSurveillanceObjectTypeDetails | Represents detected object type details.
NSurveillanceProgressEventArgs | Event arguments for progress callback.
NSurveillanceSource | Provides functions for managing Surveillance sources - cameras and video files.
NTrackingDetails | Represents objects tracking details.
NVehicleDetails | Represents vehicle details.
NsedMatchResult | Represents matching result.
Collapse Expand Structs, Records, Enums
Name | Description
NDetectorScaleCount | Enumerates detector scale count. Bigger values improves quality, but requires more processing power.
NGpuIndex | Enumerates GPU units by index.
NSurveillanceEventType | Enumeration type for different Surveillance events. Different information is available inside EventDetails field of NSurveillanceEventArgs. Events are asynchronous, so no assumption on the order of events should be made.
NSurveillanceModalityType | Enumerates surveillance modality types.
NSurveillanceObjectColor | Enumerates tracked object color values.
NSurveillanceObjectDirection | Represents detected or tracked object direction values.
NSurveillanceObjectType | Enumerates surveillance objects.
NSurveillanceSourceType | Enumerates surveillance source types.
NVehicleOrientation | Enumerates vehicle orientation values.


NClothingDetails Class

NClothingDetails Class
NClothingDetails Classes NObject Delegates NObject Events NObject Fields Legend Members NDisposable Methods NDisposable Properties

Represents subject's clothing and gender details.

C#
public class NClothingDetails : NObject;
Collapse Expand NClothingDetails Classes
NClothingDetails Class
Name | Description
ValueCollection | Values collection.
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NClothingDetails Class
Name | Description
GetKnownValues | Returns known values from NClothingDetails.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NClothingDetails Class
Name | Description
Gender | Gets subject's gender.
GenderConfidence | Gets subject's gender confidence value.
NativeType | Neurotechnology framework type of the object.
Values | Gets ValueCollection object.
Container

File: NClothingDetails.cs

Namespace: Neurotec.Surveillance

Module: .NET Reference


NClothingDetails.ValueCollection Class

NClothingDetails.ValueCollection Class

Values collection.

C#
public class ValueCollection : DisposableStructReadOnlyCollection<NNameConfidencePair, NNameConfidencePair_>;
Container

File: NClothingDetails.cs

Namespace: Neurotec.Surveillance

Module: .NET Reference


NClothingDetails.GetKnownValues Method

NClothingDetails.GetKnownValues Method
NClothingDetails Class Neurotec.Surveillance Namespace

Returns known values from NClothingDetails.

C#
public static string[] GetKnownValues();
Collapse Expand Returns

String array containing known values.


NClothingDetails.Gender Property

NClothingDetails.Gender Property
NClothingDetails Class Neurotec.Surveillance Namespace

Gets subject's gender.

C#
public NGender Gender;
Property value

NGender object containing subject's gender.


NClothingDetails.GenderConfidence Property

NClothingDetails.GenderConfidence Property
NClothingDetails Class Neurotec.Surveillance Namespace

Gets subject's gender confidence value.

C#
public byte GenderConfidence;
Property value

GenderConfidence object containing subject's gender confidence value.


NClothingDetails.NativeType Property

NClothingDetails.NativeType Property
NClothingDetails Class Neurotec.Surveillance Namespace

Neurotechnology framework type of the object.

C#
public static new NType NativeType;


NClothingDetails.Values Property

NClothingDetails.Values Property
NClothingDetails Class Neurotec.Surveillance Namespace

Gets ValueCollection object.

C#
public ValueCollection Values;
Property value

ValueCollection object.


NLicensePlate Class

NLicensePlate Class
NObject Delegates NObject Events NObject Fields Legend Members NDisposable Methods NDisposable Properties

Provides car's license plate recognition functionality.

C#
public class NLicensePlate : NObject;
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NLicensePlate Class
Name | Description
BoundingBox | Gets license plate's bounding box rectangle.
CharacterHeight | Get average height of 3 largest characters.
DetectionConfidence | Gets license plate detection confidence value.
FrameIndex | Gets index of a frame where license plate was found.
NativeType | Neurotechnology framework type of the object.
OcrConfidence | Gets license plate's characters recognition confidence value.
Origin | Gets license plate country code value (3 characters).
Rectangle | Gets license plate's bounding box rectangle.
Region | Get license plate region.
Rotation | Gets rotation of the Rectangle.
Type | Gets license plate's type value (general, taxi, military, etc.).
Value | Gets vehicle's number from a license plate.
Container

File: NLicensePlate.cs

Namespace: Neurotec.Surveillance

Module: .NET Reference


NLicensePlate.BoundingBox Property

NLicensePlate.BoundingBox Property
NLicensePlate Class Neurotec.Surveillance Namespace

Gets license plate's bounding box rectangle.

C#
public Rectangle BoundingBox;
Property value

Rectangle object containing coordinates, width and height of license plate's bounding box.


NLicensePlate.CharacterHeight Property

NLicensePlate.CharacterHeight Property
NLicensePlate Class Neurotec.Surveillance Namespace

Get average height of 3 largest characters.

C#
public float CharacterHeight;


NLicensePlate.DetectionConfidence Property

NLicensePlate.DetectionConfidence Property
NLicensePlate Class Neurotec.Surveillance Namespace

Gets license plate detection confidence value.

C#
public float DetectionConfidence;
Property value

License plate detection confidence float value.


NLicensePlate.FrameIndex Property

NLicensePlate.FrameIndex Property
NLicensePlate Class Neurotec.Surveillance Namespace

Gets index of a frame where license plate was found.

C#
public ulong FrameIndex;
Property value

Index of a frame where license plate was found.


NLicensePlate.NativeType Property

NLicensePlate.NativeType Property
NLicensePlate Class Neurotec.Surveillance Namespace

Neurotechnology framework type of the object.

C#
public static new NType NativeType;


NLicensePlate.OcrConfidence Property

NLicensePlate.OcrConfidence Property
NLicensePlate Class Neurotec.Surveillance Namespace

Gets license plate's characters recognition confidence value.

C#
public float OcrConfidence;
Property value

License plate's characters recognition confidence float value.


NLicensePlate.Origin Property

NLicensePlate.Origin Property
NLicensePlate Class Neurotec.Surveillance Namespace

Gets license plate country code value (3 characters).

C#
public string Origin;
Property value

License plate country code value (3 characters).


NLicensePlate.Rectangle Property

NLicensePlate.Rectangle Property
NLicensePlate Class Neurotec.Surveillance Namespace See Also

Gets license plate's bounding box rectangle.

C#
public Rectangle Rectangle;
Property value

Rectangle object containing coordinates, width and height of license plate's bounding box.

Collapse Expand See Also

BoundingBox


NLicensePlate.Region Property

NLicensePlate.Region Property
NLicensePlate Class Neurotec.Surveillance Namespace

Get license plate region.

C#
public string Region;
Property value

String value containing license plate's region.


NLicensePlate.Rotation Property

NLicensePlate.Rotation Property
NLicensePlate Class Neurotec.Surveillance Namespace

Gets rotation of the Rectangle.

C#
public float Rotation;
Property value

Rectangle rotation value.


NLicensePlate.Type Property

NLicensePlate.Type Property
NLicensePlate Class Neurotec.Surveillance Namespace

Gets license plate's type value (general, taxi, military, etc.).

C#
public string Type;
Property value

String value containing license plate's type (general, taxi, military, etc.).


NLicensePlate.Value Property

NLicensePlate.Value Property
NLicensePlate Class Neurotec.Surveillance Namespace

Gets vehicle's number from a license plate.

C#
public string Value;
Property value

String containing vehicle's number from a license plate.


NLicensePlateDetails Class

NLicensePlateDetails Class
NLicensePlateDetails Classes NObject Delegates NObject Events NObject Fields Legend Members NDisposable Methods NDisposable Properties

Represents car's license plate details.

C#
public class NLicensePlateDetails : NObject;
Collapse Expand NLicensePlateDetails Classes
NLicensePlateDetails Class
Name | Description
BestLicensePlateCollection | Provides the collection of best license plates during tracking.
CurrentLicensePlateCollection | Provides the collection of all license plates within current frame or object.
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NLicensePlateDetails Class
Name | Description
Best | Gets the collection of best license plates during license plates tracking.
Current | Gets the collection of all license plates within current frame or object.
NativeType | Neurotechnology framework type of the object.
Container

File: NLicensePlateDetails.cs

Namespace: Neurotec.Surveillance

Module: .NET Reference


NLicensePlateDetails.BestLicensePlateCollection Class

NLicensePlateDetails.BestLicensePlateCollection Class

Provides the collection of best license plates during tracking.

C#
public sealed class BestLicensePlateCollection : NObjectCollection<NLicensePlate>;
Container

File: NLicensePlateDetails.cs

Namespace: Neurotec.Surveillance

Module: .NET Reference


NLicensePlateDetails.CurrentLicensePlateCollection Class

NLicensePlateDetails.CurrentLicensePlateCollection Class

Provides the collection of all license plates within current frame or object.

C#
public sealed class CurrentLicensePlateCollection : NObjectCollection<NLicensePlate>;
Container

File: NLicensePlateDetails.cs

Namespace: Neurotec.Surveillance

Module: .NET Reference


NLicensePlateDetails.Best Property

NLicensePlateDetails.Best Property
NLicensePlateDetails Class Neurotec.Surveillance Namespace

Gets the collection of best license plates during license plates tracking.

C#
public BestLicensePlateCollection Best;
Property value

BestLicensePlateCollection object containing best license plates.


NLicensePlateDetails.Current Property

NLicensePlateDetails.Current Property
NLicensePlateDetails Class Neurotec.Surveillance Namespace

Gets the collection of all license plates within current frame or object.

C#
public CurrentLicensePlateCollection Current;
Property value

CurrentLicensePlateCollection object containing all license plates within current frame or object.


NLicensePlateDetails.NativeType Property

NLicensePlateDetails.NativeType Property
NLicensePlateDetails Class Neurotec.Surveillance Namespace

Neurotechnology framework type of the object.

C#
public static new NType NativeType;


NNameConfidencePair Structure

NNameConfidencePair Structure
Legend Members NNameConfidencePair Properties

Structure containing name and/or confidence values.

C#
[Serializable]
public struct NNameConfidencePair {
}
Collapse Expand NNameConfidencePair Properties
Name | Description
Confidence | Gets or sets confidence value.
Name | Gets or sets name value.
NativeType | Defines the native type of the object.
Container

File: NNameConfidencePair.cs

Namespace: Neurotec.Surveillance

Module: .NET Reference


NNameConfidencePair.Confidence Property

NNameConfidencePair.Confidence Property
NNameConfidencePair Structure Neurotec.Surveillance Namespace

Gets or sets confidence value.

C#
public float Confidence;
Property value

Confidence value.


NNameConfidencePair.Name Property

NNameConfidencePair.Name Property
NNameConfidencePair Structure Neurotec.Surveillance Namespace

Gets or sets name value.

C#
public string Name;
Property value

Name value as a string.


NNameConfidencePair.NativeType Property

NNameConfidencePair.NativeType Property
NNameConfidencePair Structure Neurotec.Surveillance Namespace

Defines the native type of the object.

C#
public static NType NativeType;


NSurveillance Class

NSurveillance Class
NSurveillance Classes NObject Delegates NObject Events NObject Fields Legend Members Methods NDisposable Methods NDisposable Properties

Base Surveillance class.

C#
public sealed class NSurveillance : NObject;
Collapse Expand NSurveillance Classes
NSurveillance Class
Name | Description
SourceCollection | Contains new Surveillance sources.
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
NSurveillance Class
Name | Description
Any | This callback is called on every event.
FacesDetected | This callback is called when faces are detected.
ImageCaptured | This event is fired when a new image is captured.
IsRunningChanged | This event is called when Surveillance "running" task changed.
SubjectAppeared | This event is fired when a new subject appears in the field of view of the camera.
SubjectDisappeared | This event is fired when a subject being tracked leaves the field of view of the camera.
SubjectMerged | This event is fired when two subjects are merged together, for example face subject with person subject.
SubjectSplit | This event is fired when one subject is split into two.
SubjectTrack | This event is fired when successful identification is performed on a tracked subject.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NSurveillance Class
Name | Description
DllName | Name of the library containing unmanaged part of this class.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NSurveillance Class
Name | Description
AddEvent | Adds event to class.
AddTemplate | Adds a template to the internal database.
GetTemplateIds | Returns array of template Ids that internal database contains.
OptimizeModelsAsync | Optimizes NSurveillance models by specified modalities (asynchronous operation).
RemoveAllTemplates | Clears internal template database.
RemoveEvent | Removes the event from Surveillance framework.
RemoveTemplate | Removes a template with specified Id from internal database.
Start | Starts surveillance and all sources.
StartAsync | Starts surveillance and all sources (asynchronous operation).
StartSource | Starts specified surveillance source.
StartSourceAsync | Starts specified surveillance source (asynchronous operation).
Stop | Stops surveillance and all sources.
StopAsync | Stops surveillance and all sources (asynchronous operation).
StopSource | Stops specified surveillance source.
StopSourceAsync | Stops specified surveillance source (asynchronous operation).
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NSurveillance Class
Name | Description
DetectorScaling | Determines detection model input resolution, lower value increases performance but reduces accuracy.
DeviceManager | Gets Device Manager.
EnableGpuLowMemoryMode | Enables or disable GPU VRAM conservation. When enabled, minimum required GPU video memory amount is used at the expense of processing speed.
FacesConfidenceThreshold | Gets or sets faces confidence threshold value. This threshold is considered is considered when looking for faces in an image. For each face candidate confidence parameter is calculated. With higher threshold value faces are selected more strictly by the face detection routines.
FacesDetectMasks | Gets or sets whether partially occluded faces (i.e. face mask or respirator) should be recognized.
FacesMinimalInterOcularDistance | Gets or sets minimal inter ocular distance (i.e. the distance between eyes).
FacesQualityThreshold | ... more
FacesTemplateSize | ... more
FacesWithDetailsOnly | Gets or sets whether only events with extracted face (when face modality is used) are returned.
GPUIndices | Get or Set GPU indices to be used for acceleration.
IsRunning | Checks if Surveillance is running (performing operations).
LicensePlateDetectorScaling | Gets or sets detection model input resolution. Note, that lower value increases performance but reduces accuracy.
LicensePlateDetectorThreshold | Gets or sets license plate detection threshold (license plate with lower confidence threshold are discarded).
LicensePlateEnableTemplateMatching | Enables or disables LicensePlatePriorityCountries.
LicensePlateInterpretOAsZero | Changes any predicted o letter to 0, because in many cases there is no real difference between o and 0 fonts so prediction can be wrong.
LicensePlateMinimalCharacterCount | Gets or sets minimal character count in a license plate.
LicensePlateOcrThreshold | Gets or sets license plate's characters recognition confidence value.
LicensePlatePriorityCountries | Gets or sets which countries in license plate formats should be evaluated to reduce mistakes. Use three letter ISO country codes separated with spaces, for example: "LTU LVA EST". If no codes are set, license plate is matched to available formats only if country of origin is determined.
MaskDetectionThreshold | Gets or sets mask detection threshold when FaceDetectMasks is set to true. When mask detection confidence value is lower than specified with this threshold, detected face with a mask is rejected.
MatchingMaximalResultCount | Gets or sets maximum length of the list which is returned by each identification.
MatchingThreshold | ... more
MatchingWithDetails | Checks or sets whether the matching results include matching details.
NSurveillanceEventCallbackNativeType | Defines the native type of the NSurveillanceEventCallback
NSurveillanceEventTypeNativeType | Defines the native type of the NSureveillanceEventType.
NativeModule | Defines the native module of the object.
NativeType | Defines the native type of the object.
Sources | Gets the collection of Surveillance sources.
UseGPU | Get or Set whether surveillance should use GPU to accelerate processing.
VehicleHumanDetectorThreshold | Gets or sets confidence threshold value for vehicle and human detector. Objects detection with a lower confidence than threshold are discarded.
Container

File: NSurveillance.cs

Namespace: Neurotec.Surveillance

Module: .NET Reference


NSurveillance.NSurveillance Constructor

NSurveillance.NSurveillance Constructor
NSurveillance Class Neurotec.Surveillance Namespace

Initializes a new instance the Surveillance class.

C#
public NSurveillance();


NSurveillance.SourceCollection Class

NSurveillance.SourceCollection Class

Contains new Surveillance sources.

C#
public sealed class SourceCollection : NObjectCollection<NSurveillanceSource>;
Container

File: NSurveillance.cs

Namespace: Neurotec.Surveillance

Module: .NET Reference


NSurveillance.DllName Field

NSurveillance.DllName Field
NSurveillance Class Neurotec.Surveillance Namespace

Name of the library containing unmanaged part of this class.

C#
public const string DllName = NVersionInfo.SurveillanceDllName;


NSurveillance.AddEvent Method

NSurveillance.AddEvent Method
NSurveillance Class Neurotec.Surveillance Namespace

Adds event to class.

C#
public void AddEvent(NSurveillanceEventType eventType, EventHandler<NSurveillanceEventArgs> handler);
Collapse Expand Parameters
Parameters | Description
NSurveillanceEventType eventType | Type of event to add.
EventHandler<NSurveillanceEventArgs> handler | Events handler.


NSurveillance.AddTemplate Method (string, NBuffer)

NSurveillance.AddTemplate Method (string, NBuffer)
NSurveillance Class Neurotec.Surveillance Namespace

Adds a template to the internal database.

C#
public void AddTemplate(string templateId, NBuffer template);
Collapse Expand Parameters
Parameters | Description
string templateId | Id of template to add.
NBuffer template | Bytes array which contains template to add.


NSurveillance.AddTemplate Method (string, byte[])

NSurveillance.AddTemplate Method (string, byte[])
NSurveillance Class Neurotec.Surveillance Namespace

Adds a template to the internal database.

C#
public void AddTemplate(string templateId, byte[] template);
Collapse Expand Parameters
Parameters | Description
string templateId | Id of template to add.
byte[] template | Bytes array which contains template to add.


NSurveillance.GetTemplateIds Method

NSurveillance.GetTemplateIds Method
NSurveillance Class Neurotec.Surveillance Namespace

Returns array of template Ids that internal database contains.

C#
public string[] GetTemplateIds();
Collapse Expand Returns

Array which contains Ids of all templates.


NSurveillance.OptimizeModelsAsync Method (NSurveillanceModalityType, NSurveillanceProgressCallback)

NSurveillance.OptimizeModelsAsync Method (NSurveillanceModalityType, NSurveillanceProgressCallback)
NSurveillance Class Neurotec.Surveillance Namespace

Optimizes NSurveillance models by specified modalities (asynchronous operation).

C#
public NAsyncOperation OptimizeModelsAsync(NSurveillanceModalityType modalities, NSurveillanceProgressCallback progressCallback = null);
Collapse Expand Parameters
Parameters | Description
NSurveillanceModalityType modalities | Surveillance modalities to optimize.
NSurveillanceProgressCallback progressCallback = null | Progress callback.


NSurveillance.OptimizeModelsAsync Method (NSurveillanceModalityType, bool, NGpuIndex, NSurveillanceProgressCallback)

NSurveillance.OptimizeModelsAsync Method (NSurveillanceModalityType, bool, NGpuIndex, NSurveillanceProgressCallback)
NSurveillance Class Neurotec.Surveillance Namespace

Optimizes NSureveillance models by specified modalities and GPU indices (asynchronous operation).

C#
public static NAsyncOperation OptimizeModelsAsync(NSurveillanceModalityType modalities, bool lowGpuMemoryMode, NGpuIndex indices = NGpuIndex.All, NSurveillanceProgressCallback progressCallback = null);
Collapse Expand Parameters
Parameters | Description
NSurveillanceModalityType modalities | Surveillance modalities to optimize.
bool lowGpuMemoryMode | true if low GPU memory mode is used.
NGpuIndex indices = NGpuIndex.All | GPU indices.
NSurveillanceProgressCallback progressCallback = null | Progress callback.


NSurveillance.RemoveAllTemplates Method

NSurveillance.RemoveAllTemplates Method
NSurveillance Class Neurotec.Surveillance Namespace

Clears internal template database.

C#
public void RemoveAllTemplates();


NSurveillance.RemoveEvent Method

NSurveillance.RemoveEvent Method
NSurveillance Class Neurotec.Surveillance Namespace

Removes the event from Surveillance framework.

C#
public void RemoveEvent(NSurveillanceEventType eventType, EventHandler<NSurveillanceEventArgs> handler);
Collapse Expand Parameters
Parameters | Description
NSurveillanceEventType eventType | Event Type which will be removed.
EventHandler<NSurveillanceEventArgs> handler | EventHandler which has the event to be removed


NSurveillance.RemoveTemplate Method

NSurveillance.RemoveTemplate Method
NSurveillance Class Neurotec.Surveillance Namespace

Removes a template with specified Id from internal database.

C#
public void RemoveTemplate(string templateId);
Collapse Expand Parameters
Parameters | Description
string templateId | Id of template to remove.


NSurveillance.Start Method

NSurveillance.Start Method
NSurveillance Class Neurotec.Surveillance Namespace

Starts surveillance and all sources.

C#
public void Start();


NSurveillance.StartAsync Method

NSurveillance.StartAsync Method
NSurveillance Class Neurotec.Surveillance Namespace

Starts surveillance and all sources (asynchronous operation).

C#
public NAsyncOperation StartAsync();
Collapse Expand Returns

NAsyncOperation object which can be used to wait for an actual result.

Collapse Expand Remarks

It performs the same operation as synchronous method Start but returns immediately, without blocking the caller.


NSurveillance.StartSource Method

NSurveillance.StartSource Method
NSurveillance Class Neurotec.Surveillance Namespace

Starts specified surveillance source.

C#
public void StartSource(NSurveillanceSource source);
Collapse Expand Parameters
Parameters | Description
NSurveillanceSource source | NSurveillanceSource object to start.


NSurveillance.StartSourceAsync Method

NSurveillance.StartSourceAsync Method
NSurveillance Class Neurotec.Surveillance Namespace

Starts specified surveillance source (asynchronous operation).

C#
public NAsyncOperation StartSourceAsync(NSurveillanceSource source);
Collapse Expand Parameters
Parameters | Description
NSurveillanceSource source | NSurveillanceSource object to start.
Collapse Expand Returns

NAsyncOperation object which can be used to wait for an actual result.


NSurveillance.Stop Method

NSurveillance.Stop Method
NSurveillance Class Neurotec.Surveillance Namespace

Stops surveillance and all sources.

C#
public void Stop();


NSurveillance.StopAsync Method

NSurveillance.StopAsync Method
NSurveillance Class Neurotec.Surveillance Namespace

Stops surveillance and all sources (asynchronous operation).

C#
public NAsyncOperation StopAsync();
Collapse Expand Returns

NAsyncOperation object which can be used to wait for an actual result.


NSurveillance.StopSource Method

NSurveillance.StopSource Method
NSurveillance Class Neurotec.Surveillance Namespace

Stops specified surveillance source.

C#
public void StopSource(NSurveillanceSource source);
Collapse Expand Parameters
Parameters | Description
NSurveillanceSource source | NSurveillanceSource object to stop.


NSurveillance.StopSourceAsync Method

NSurveillance.StopSourceAsync Method
NSurveillance Class Neurotec.Surveillance Namespace

Stops specified surveillance source (asynchronous operation).

C#
public NAsyncOperation StopSourceAsync(NSurveillanceSource source);
Collapse Expand Parameters
Parameters | Description
NSurveillanceSource source | NSurveillanceSource object to stop.
Collapse Expand Returns

NAsyncOperation object.


NSurveillance.DetectorScaling Property

NSurveillance.DetectorScaling Property
NSurveillance Class Neurotec.Surveillance Namespace

Determines detection model input resolution, lower value increases performance but reduces accuracy.

C#
public NDetectorScaleCount DetectorScaling;


NSurveillance.DeviceManager Property

NSurveillance.DeviceManager Property
NSurveillance Class Neurotec.Surveillance Namespace

Gets Device Manager.

C#
public NDeviceManager DeviceManager;


NSurveillance.EnableGpuLowMemoryMode Property

NSurveillance.EnableGpuLowMemoryMode Property
NSurveillance Class Neurotec.Surveillance Namespace

Enables or disable GPU VRAM conservation. When enabled, minimum required GPU video memory amount is used at the expense of processing speed.

C#
public bool EnableGpuLowMemoryMode;


NSurveillance.FacesConfidenceThreshold Property

NSurveillance.FacesConfidenceThreshold Property
NSurveillance Class Neurotec.Surveillance Namespace

Gets or sets faces confidence threshold value. This threshold is considered is considered when looking for faces in an image. For each face candidate confidence parameter is calculated. With higher threshold value faces are selected more strictly by the face detection routines.

C#
public byte FacesConfidenceThreshold;
Property value

Face confidence threshold value.


NSurveillance.FacesDetectMasks Property

NSurveillance.FacesDetectMasks Property
NSurveillance Class Neurotec.Surveillance Namespace

Gets or sets whether partially occluded faces (i.e. face mask or respirator) should be recognized.

C#
public bool FacesDetectMasks;
Property value

true if partially occluded faces (i.e. face mask or respirator) should be recognized; otherwise, false.


NSurveillance.FacesMinimalInterOcularDistance Property

NSurveillance.FacesMinimalInterOcularDistance Property
NSurveillance Class Neurotec.Surveillance Namespace

Gets or sets minimal inter ocular distance (i.e. the distance between eyes).

C#
public int FacesMinimalInterOcularDistance;
Property value

Minimal inter ocular distance (i.e. the distance between eyes).


NSurveillance.FacesQualityThreshold Property

NSurveillance.FacesQualityThreshold Property
NSurveillance Class Neurotec.Surveillance Namespace

Gets or sets the threshold which is considered when extracting facial features from the image. With higher threshold better quality of face image is required to successfully extract facial features. The value of this parameter can be in range [0..100]. The default value is 50.

C#
public byte FacesQualityThreshold;


NSurveillance.FacesTemplateSize Property

NSurveillance.FacesTemplateSize Property
NSurveillance Class Neurotec.Surveillance Namespace

Gets or sets template size parameter.

C#
public NTemplateSize FacesTemplateSize;


NSurveillance.FacesWithDetailsOnly Property

NSurveillance.FacesWithDetailsOnly Property
NSurveillance Class Neurotec.Surveillance Namespace

Gets or sets whether only events with extracted face (when face modality is used) are returned.

C#
[Obsolete("Do not use")]
public bool FacesWithDetailsOnly;
Property value

true if only events with extracted face (when face modality is used) are returned; otherwise, false.


NSurveillance.GPUIndices Property

NSurveillance.GPUIndices Property
NSurveillance Class Neurotec.Surveillance Namespace

Get or Set GPU indices to be used for acceleration.

C#
public NGpuIndex GPUIndices;


NSurveillance.IsRunning Property

NSurveillance.IsRunning Property
NSurveillance Class Neurotec.Surveillance Namespace

Checks if Surveillance is running (performing operations).

C#
public bool IsRunning;
Property value

bool type value which indicates if Surveillance is running.


NSurveillance.LicensePlateDetectorScaling Property

NSurveillance.LicensePlateDetectorScaling Property
NSurveillance Class Neurotec.Surveillance Namespace

Gets or sets detection model input resolution. Note, that lower value increases performance but reduces accuracy.

C#
public NDetectorScaleCount LicensePlateDetectorScaling;
Property value

Detection model input resolution.


NSurveillance.LicensePlateDetectorThreshold Property

NSurveillance.LicensePlateDetectorThreshold Property
NSurveillance Class Neurotec.Surveillance Namespace

Gets or sets license plate detection threshold (license plate with lower confidence threshold are discarded).

C#
public int LicensePlateDetectorThreshold;
Property value

License plate detection threshold.


NSurveillance.LicensePlateEnableTemplateMatching Property

NSurveillance.LicensePlateEnableTemplateMatching Property
NSurveillance Class Neurotec.Surveillance Namespace

Enables or disables LicensePlatePriorityCountries.

C#
public bool LicensePlateEnableTemplateMatching;
Property value

Set to true to enable LicensePlatePriorityCountries.


NSurveillance.LicensePlateInterpretOAsZero Property

NSurveillance.LicensePlateInterpretOAsZero Property
NSurveillance Class Neurotec.Surveillance Namespace

Changes any predicted o letter to 0, because in many cases there is no real difference between o and 0 fonts so prediction can be wrong.

C#
public bool LicensePlateInterpretOAsZero;
Property value

true, if predicted o letter should be changed to 0 (zero); otherwise, false.


NSurveillance.LicensePlateMinimalCharacterCount Property

NSurveillance.LicensePlateMinimalCharacterCount Property
NSurveillance Class Neurotec.Surveillance Namespace

Gets or sets minimal character count in a license plate.

C#
public int LicensePlateMinimalCharacterCount;
Property value

Minimal character count in a license plate.


NSurveillance.LicensePlateOcrThreshold Property

NSurveillance.LicensePlateOcrThreshold Property
NSurveillance Class Neurotec.Surveillance Namespace

Gets or sets license plate's characters recognition confidence value.

C#
public int LicensePlateOcrThreshold;
Property value

License plate's characters recognition confidence value.


NSurveillance.LicensePlatePriorityCountries Property

NSurveillance.LicensePlatePriorityCountries Property
NSurveillance Class Neurotec.Surveillance Namespace

Gets or sets which countries in license plate formats should be evaluated to reduce mistakes. Use three letter ISO country codes separated with spaces, for example: "LTU LVA EST". If no codes are set, license plate is matched to available formats only if country of origin is determined.

C#
public string LicensePlatePriorityCountries;
Property value

Three letter ISO country codes separated with spaces.


NSurveillance.MaskDetectionThreshold Property

NSurveillance.MaskDetectionThreshold Property
NSurveillance Class Neurotec.Surveillance Namespace

Gets or sets mask detection threshold when FaceDetectMasks is set to true. When mask detection confidence value is lower than specified with this threshold, detected face with a mask is rejected.

C#
[Obsolete("Do not use")]
public byte MaskDetectionThreshold;
Property value

Mask detection threshold. Available values are [0, 100], default value is 50.


NSurveillance.MatchingMaximalResultCount Property

NSurveillance.MatchingMaximalResultCount Property
NSurveillance Class Neurotec.Surveillance Namespace

Gets or sets maximum length of the list which is returned by each identification.

C#
public int MatchingMaximalResultCount;


NSurveillance.MatchingThreshold Property

NSurveillance.MatchingThreshold Property
NSurveillance Class Neurotec.Surveillance Namespace

Gets or sets matching threshold (biggest allowed FAR) parameter of type UShort. Parameter value is equal to -12 * log10(FAR) and must be not less than zero (for example, 48 for FAR = 0.01%).

C#
public int MatchingThreshold;


NSurveillance.MatchingWithDetails Property

NSurveillance.MatchingWithDetails Property
NSurveillance Class Neurotec.Surveillance Namespace

Checks or sets whether the matching results include matching details.

C#
public bool MatchingWithDetails;


NSurveillance.NSurveillanceEventCallbackNativeType Property

NSurveillance.NSurveillanceEventCallbackNativeType Property
NSurveillance Class Neurotec.Surveillance Namespace

Defines the native type of the NSurveillanceEventCallback

C#
public static NType NSurveillanceEventCallbackNativeType;


NSurveillance.NSurveillanceEventTypeNativeType Property

NSurveillance.NSurveillanceEventTypeNativeType Property
NSurveillance Class Neurotec.Surveillance Namespace

Defines the native type of the NSureveillanceEventType.

C#
public static NType NSurveillanceEventTypeNativeType;


NSurveillance.NativeModule Property

NSurveillance.NativeModule Property
NSurveillance Class Neurotec.Surveillance Namespace

Defines the native module of the object.

C#
public static NModule NativeModule;


NSurveillance.NativeType Property

NSurveillance.NativeType Property
NSurveillance Class Neurotec.Surveillance Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NSurveillance.Sources Property

NSurveillance.Sources Property
NSurveillance Class Neurotec.Surveillance Namespace

Gets the collection of Surveillance sources.

C#
public SourceCollection Sources;


NSurveillance.UseGPU Property

NSurveillance.UseGPU Property
NSurveillance Class Neurotec.Surveillance Namespace

Get or Set whether surveillance should use GPU to accelerate processing.

C#
public bool UseGPU;


NSurveillance.VehicleHumanDetectorThreshold Property

NSurveillance.VehicleHumanDetectorThreshold Property
NSurveillance Class Neurotec.Surveillance Namespace

Gets or sets confidence threshold value for vehicle and human detector. Objects detection with a lower confidence than threshold are discarded.

C#
public int VehicleHumanDetectorThreshold;
Property value

Vehicle and human detector confidence threshold value.


NSurveillance.Any Event

NSurveillance.Any Event
NSurveillance Class Neurotec.Surveillance Namespace

This callback is called on every event.

C#
public event EventHandler<NSurveillanceEventArgs> Any;


NSurveillance.FacesDetected Event

NSurveillance.FacesDetected Event
NSurveillance Class Neurotec.Surveillance Namespace

This callback is called when faces are detected.

C#
public event EventHandler<NSurveillanceEventArgs> FacesDetected;


NSurveillance.ImageCaptured Event

NSurveillance.ImageCaptured Event
NSurveillance Class Neurotec.Surveillance Namespace

This event is fired when a new image is captured.

C#
public event EventHandler<NSurveillanceEventArgs> ImageCaptured;


NSurveillance.IsRunningChanged Event

NSurveillance.IsRunningChanged Event
NSurveillance Class Neurotec.Surveillance Namespace

This event is called when Surveillance "running" task changed.

C#
public event EventHandler<EventArgs> IsRunningChanged;


NSurveillance.SubjectAppeared Event

NSurveillance.SubjectAppeared Event
NSurveillance Class Neurotec.Surveillance Namespace

This event is fired when a new subject appears in the field of view of the camera.

C#
public event EventHandler<NSurveillanceEventArgs> SubjectAppeared;


NSurveillance.SubjectDisappeared Event

NSurveillance.SubjectDisappeared Event
NSurveillance Class Neurotec.Surveillance Namespace

This event is fired when a subject being tracked leaves the field of view of the camera.

C#
public event EventHandler<NSurveillanceEventArgs> SubjectDisappeared;


NSurveillance.SubjectMerged Event

NSurveillance.SubjectMerged Event
NSurveillance Class Neurotec.Surveillance Namespace

This event is fired when two subjects are merged together, for example face subject with person subject.

C#
public event EventHandler<NSurveillanceEventArgs> SubjectMerged;


NSurveillance.SubjectSplit Event

NSurveillance.SubjectSplit Event
NSurveillance Class Neurotec.Surveillance Namespace

This event is fired when one subject is split into two.

C#
public event EventHandler<NSurveillanceEventArgs> SubjectSplit;


NSurveillance.SubjectTrack Event

NSurveillance.SubjectTrack Event
NSurveillance Class Neurotec.Surveillance Namespace

This event is fired when successful identification is performed on a tracked subject.

C#
public event EventHandler<NSurveillanceEventArgs> SubjectTrack;


NSurveillanceDetectionDetails Class

NSurveillanceDetectionDetails Class
NObject Delegates NObject Events NObject Fields Legend Members Methods NDisposable Methods NDisposable Properties

Represents surveillance detection details.

C#
public class NSurveillanceDetectionDetails : NObject;
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NSurveillanceDetectionDetails Class
Name | Description
ClothingDetails | Gets or sets NClothingDetails object representing subject's clothing details.
DetectionConfidence | Gets or sets detection confidence value.
Face | Gets or sets detected face object.
FaceRectangle | Gets or sets bounding box rectangle of a detected subject's face.
LicensePlateDetails | Gets or sets vehicle's license plate details.
NativeType | Neurotechnology framework type of the object.
ObjectColor | Gets or sets color of a detected surveillance object.
ObjectType | Gets or sets type of a detected surveillance object.
Rectangle | Gets or sets bounding box rectangle of a detected object.
SubjectType | Gets or sets NSurveillanceModalityType object containing one of surveillance modality values (None, Faces, Vehicles and Humans or License Plate Recognition).
VehicleDetails | Gets or sets vehicle details.
Container

File: NSurveillanceDetectionDetails.cs

Namespace: Neurotec.Surveillance

Module: .NET Reference


NSurveillanceDetectionDetails.NSurveillanceDetectionDetails Constructor

NSurveillanceDetectionDetails.NSurveillanceDetectionDetails Constructor
NSurveillanceDetectionDetails Class Neurotec.Surveillance Namespace

Creates a new instance of NSurveillanceDetectionDetails.

C#
public NSurveillanceDetectionDetails();


NSurveillanceDetectionDetails.ClothingDetails Property

NSurveillanceDetectionDetails.ClothingDetails Property
NSurveillanceDetectionDetails Class Neurotec.Surveillance Namespace

Gets or sets NClothingDetails object representing subject's clothing details.

C#
public NClothingDetails ClothingDetails;
Property value

NClothingDetails object.


NSurveillanceDetectionDetails.DetectionConfidence Property

NSurveillanceDetectionDetails.DetectionConfidence Property
NSurveillanceDetectionDetails Class Neurotec.Surveillance Namespace

Gets or sets detection confidence value.

C#
public float DetectionConfidence;
Property value

Detection confidence value (float type).


NSurveillanceDetectionDetails.Face Property

NSurveillanceDetectionDetails.Face Property
NSurveillanceDetectionDetails Class Neurotec.Surveillance Namespace

Gets or sets detected face object.

C#
public NFace Face;
Property value

NFace object.


NSurveillanceDetectionDetails.FaceRectangle Property

NSurveillanceDetectionDetails.FaceRectangle Property
NSurveillanceDetectionDetails Class Neurotec.Surveillance Namespace

Gets or sets bounding box rectangle of a detected subject's face.

C#
public Rectangle FaceRectangle;
Property value

Rectangle object containing coordinates, width and height of subject face's bounding box rectangle.


NSurveillanceDetectionDetails.LicensePlateDetails Property

NSurveillanceDetectionDetails.LicensePlateDetails Property
NSurveillanceDetectionDetails Class Neurotec.Surveillance Namespace

Gets or sets vehicle's license plate details.

C#
public NLicensePlateDetails LicensePlateDetails;
Property value

NLicensePlateDetails object.


NSurveillanceDetectionDetails.NativeType Property

NSurveillanceDetectionDetails.NativeType Property
NSurveillanceDetectionDetails Class Neurotec.Surveillance Namespace

Neurotechnology framework type of the object.

C#
public static new NType NativeType;


NSurveillanceDetectionDetails.ObjectColor Property

NSurveillanceDetectionDetails.ObjectColor Property
NSurveillanceDetectionDetails Class Neurotec.Surveillance Namespace

Gets or sets color of a detected surveillance object.

C#
public NSurveillanceObjectColorDetails ObjectColor;
Property value

NSurveillanceObjectColorDetails object containing color and color confidence values.


NSurveillanceDetectionDetails.ObjectType Property

NSurveillanceDetectionDetails.ObjectType Property
NSurveillanceDetectionDetails Class Neurotec.Surveillance Namespace

Gets or sets type of a detected surveillance object.

C#
public NSurveillanceObjectTypeDetails ObjectType;
Property value

NSurveillanceObjectTypeDetails object.


NSurveillanceDetectionDetails.Rectangle Property

NSurveillanceDetectionDetails.Rectangle Property
NSurveillanceDetectionDetails Class Neurotec.Surveillance Namespace

Gets or sets bounding box rectangle of a detected object.

C#
public Rectangle Rectangle;
Property value

Rectangle object containing coordinates, width and height of object's bounding box rectangle.


NSurveillanceDetectionDetails.SubjectType Property

NSurveillanceDetectionDetails.SubjectType Property
NSurveillanceDetectionDetails Class Neurotec.Surveillance Namespace

Gets or sets NSurveillanceModalityType object containing one of surveillance modality values (None, Faces, Vehicles and Humans or License Plate Recognition).

C#
public NSurveillanceModalityType SubjectType;
Property value

NSurveillanceModalityType object containing one of surveillance modality values.


NSurveillanceDetectionDetails.VehicleDetails Property

NSurveillanceDetectionDetails.VehicleDetails Property
NSurveillanceDetectionDetails Class Neurotec.Surveillance Namespace

Gets or sets vehicle details.

C#
public NVehicleDetails VehicleDetails;
Property value

NVehicleDetails object.


NSurveillanceDetectionResult Class

NSurveillanceDetectionResult Class
NSurveillanceDetectionResult Classes NObject Delegates NObject Events NObject Fields Legend Members NDisposable Methods NDisposable Properties

Represents object's detection result.

C#
public class NSurveillanceDetectionResult : NObject;
Collapse Expand NSurveillanceDetectionResult Classes
NSurveillanceDetectionResult Class
Name | Description
DetailsCollection | Detection details collection.
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NSurveillanceDetectionResult Class
Name | Description
Details | Gets DetailsCollection object.
Image | Gets an image containing a detected surveillance object.
ModalityType | Gets a type of modality used for surveillance and objects detection.
NativeType | Neurotechnology framework type of the object.
Container

File: NSurveillanceDetectionResult.cs

Namespace: Neurotec.Surveillance

Module: .NET Reference


NSurveillanceDetectionResult.DetailsCollection Class

NSurveillanceDetectionResult.DetailsCollection Class

Detection details collection.

C#
public class DetailsCollection : NObjectCollection<NSurveillanceDetectionDetails>;
Container

File: NSurveillanceDetectionResult.cs

Namespace: Neurotec.Surveillance

Module: .NET Reference


NSurveillanceDetectionResult.Details Property

NSurveillanceDetectionResult.Details Property
NSurveillanceDetectionResult Class Neurotec.Surveillance Namespace

Gets DetailsCollection object.

C#
public DetailsCollection Details;
Property value

DetailsCollection object.


NSurveillanceDetectionResult.Image Property

NSurveillanceDetectionResult.Image Property
NSurveillanceDetectionResult Class Neurotec.Surveillance Namespace

Gets an image containing a detected surveillance object.

C#
public NImage Image;
Property value

NImage object containing a detected surveillance object.


NSurveillanceDetectionResult.ModalityType Property

NSurveillanceDetectionResult.ModalityType Property
NSurveillanceDetectionResult Class Neurotec.Surveillance Namespace

Gets a type of modality used for surveillance and objects detection.

C#
public NSurveillanceModalityType ModalityType;
Property value

NSurveillanceModalityType object containing modality type.


NSurveillanceDetectionResult.NativeType Property

NSurveillanceDetectionResult.NativeType Property
NSurveillanceDetectionResult Class Neurotec.Surveillance Namespace

Neurotechnology framework type of the object.

C#
public static new NType NativeType;


NSurveillanceEngine Class

NSurveillanceEngine Class
NObject Delegates NObject Events NObject Fields Legend Members Methods NDisposable Methods NDisposable Properties

Provides functionality for Surveillance engine.

C#
public class NSurveillanceEngine : NObject;
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NSurveillanceEngine Class
Name | Description
Detect | Detects Surveillance object from the specified image.
DetectAsync | Detects object from the specified image (asynchronous operation).
DetectWithParameters | Detects Surveillance object from the specified image with detection parameters.
DetectWithParametersAsync | Detects object from the specified image with detection parameters(asynchronous operation).
Initialize | Initializes NSurveillanceEngine.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NSurveillanceEngine Class
Name | Description
DetectorScaling | Determines detection model input resolution, lower value increases performance but reduces accuracy.
EnableGpuLowMemoryMode | Enables or disable GPU VRAM conservation. When enabled, minimum required GPU video memory amount is used at the expense of processing speed.
FacesConfidenceThreshold | Gets or sets face confidence threshold value.
FacesDetectMasks | Gets or sets whether partially occluded faces (i.e. face mask or respirator) should be recognized.
FacesMinimalInterOcularDistance | Gets or sets minimal inter ocular distance (i.e. the distance between eyes).
FacesQualityThreshold | ... more
FacesTemplateSize | ... more
GPUIndices | Get or Set GPU indices to be used for acceleration.
LicensePlateDetectorScaling | Gets or sets detection model input resolution. Note, that lower value increases performance but reduces accuracy.
LicensePlateDetectorThreshold | Gets or sets license plate detection threshold (license plate with lower confidence threshold are discarded).
LicensePlateEnableTemplateMatching | Enables or disables LicensePlatePriorityCountries.
LicensePlateInterpretOAsZero | Changes any predicted o letter to 0, because in many cases there is no real difference between o and 0 fonts so prediction can be wrong.
LicensePlateMinimalCharacterCount | Gets or sets minimal character count in a license plate.
LicensePlateOcrThreshold | Gets or sets license plate's characters recognition confidence value.
LicensePlatePriorityCountries | Gets or sets which countries in license plate formats should be evaluated to reduce mistakes. Use three letter ISO country codes separated with spaces, for example: "LTU LVA EST". If no codes are set, license plate is matched to available formats only if country of origin is determined.
ModalityType | Gets a type of modality used for surveillance and objects detection.
NativeType | Neurotechnology framework type of the object.
ThreadCount | Gets or sets thread count used by Surveillance engine.
UseGPU | Get or Set whether surveillance should use GPU to accelerate processing.
VehicleHumanDetectorThreshold | Gets or sets confidence threshold value for vehicle and human detector. Objects detection with a lower confidence than threshold are discarded.
Container

File: NSurveillanceEngine.cs

Namespace: Neurotec.Surveillance

Module: .NET Reference


NSurveillanceEngine.NSurveillanceEngine Constructor

NSurveillanceEngine.NSurveillanceEngine Constructor
NSurveillanceEngine Class Neurotec.Surveillance Namespace

Creates a new instance of NSurveillanceEngine.

C#
public NSurveillanceEngine();


NSurveillanceEngine.Detect Method

NSurveillanceEngine.Detect Method
NSurveillanceEngine Class Neurotec.Surveillance Namespace

Detects Surveillance object from the specified image.

C#
public NSurveillanceDetectionResult Detect(NImage image);
Collapse Expand Parameters
Parameters | Description
NImage image | NImage object containing an image for detection by Surveillance engine.
Collapse Expand Returns

NSurveillanceDetectionResult object containing detection result from a specified image.


NSurveillanceEngine.DetectAsync Method

NSurveillanceEngine.DetectAsync Method
NSurveillanceEngine Class Neurotec.Surveillance Namespace

Detects object from the specified image (asynchronous operation).

C#
public NAsyncOperation<NSurveillanceDetectionResult> DetectAsync(NImage image);
Collapse Expand Parameters
Parameters | Description
NImage image | NImage object containing an image for detection by Surveillance engine.
Collapse Expand Returns

NSurveillanceDetectionResult object containing detection result from a specified image.


NSurveillanceEngine.DetectWithParameters Method

NSurveillanceEngine.DetectWithParameters Method
NSurveillanceEngine Class Neurotec.Surveillance Namespace

Detects Surveillance object from the specified image with detection parameters.

C#
public NSurveillanceDetectionResult DetectWithParameters(NImage image, string parameters, NSurveillanceModalityType modalityOverride = NSurveillanceModalityType.None);
Collapse Expand Parameters
Parameters | Description
NImage image | NImage object containing an image for detection by Surveillance engine.
string parameters | PropertyBag string containing detection parameters.
NSurveillanceModalityType modalityOverride = NSurveillanceModalityType.None | Modality overriding parameter.
Collapse Expand Returns

NSurveillanceDetectionResult object containing detection result from a specified image.


NSurveillanceEngine.DetectWithParametersAsync Method

NSurveillanceEngine.DetectWithParametersAsync Method
NSurveillanceEngine Class Neurotec.Surveillance Namespace

Detects object from the specified image with detection parameters(asynchronous operation).

C#
public NAsyncOperation<NSurveillanceDetectionResult> DetectWithParametersAsync(NImage image, string parameters, NSurveillanceModalityType modalityOverride = NSurveillanceModalityType.None);
Collapse Expand Parameters
Parameters | Description
NImage image | NImage object containing an image for detection by Surveillance engine.
string parameters | PropertyBag string containing detection parameters.
NSurveillanceModalityType modalityOverride = NSurveillanceModalityType.None | Modality overriding parameter.
Collapse Expand Returns

NSurveillanceDetectionResult object containing detection result from a specified image.


NSurveillanceEngine.Initialize Method

NSurveillanceEngine.Initialize Method
NSurveillanceEngine Class Neurotec.Surveillance Namespace

Initializes NSurveillanceEngine.

C#
public void Initialize(NSurveillanceProgressCallback progressCallback = null);


NSurveillanceEngine.DetectorScaling Property

NSurveillanceEngine.DetectorScaling Property
NSurveillanceEngine Class Neurotec.Surveillance Namespace

Determines detection model input resolution, lower value increases performance but reduces accuracy.

C#
public NDetectorScaleCount DetectorScaling;


NSurveillanceEngine.EnableGpuLowMemoryMode Property

NSurveillanceEngine.EnableGpuLowMemoryMode Property
NSurveillanceEngine Class Neurotec.Surveillance Namespace

Enables or disable GPU VRAM conservation. When enabled, minimum required GPU video memory amount is used at the expense of processing speed.

C#
public bool EnableGpuLowMemoryMode;
Property value

true, when GPU VRAM conservation is enabled; otherwise, false.


NSurveillanceEngine.FacesConfidenceThreshold Property

NSurveillanceEngine.FacesConfidenceThreshold Property
NSurveillanceEngine Class Neurotec.Surveillance Namespace

Gets or sets face confidence threshold value.

C#
public byte FacesConfidenceThreshold;
Property value

Face confidence threshold value in range [0,100], default value - 20. Faces with a lower value than specified with the threshold are rejected.


NSurveillanceEngine.FacesDetectMasks Property

NSurveillanceEngine.FacesDetectMasks Property
NSurveillanceEngine Class Neurotec.Surveillance Namespace

Gets or sets whether partially occluded faces (i.e. face mask or respirator) should be recognized.

C#
public bool FacesDetectMasks;
Property value

true if partially occluded faces (i.e. face mask or respirator) should be recognized; otherwise, false.


NSurveillanceEngine.FacesMinimalInterOcularDistance Property

NSurveillanceEngine.FacesMinimalInterOcularDistance Property
NSurveillanceEngine Class Neurotec.Surveillance Namespace

Gets or sets minimal inter ocular distance (i.e. the distance between eyes).

C#
public int FacesMinimalInterOcularDistance;
Property value

Minimal inter ocular distance (i.e. the distance between eyes).


NSurveillanceEngine.FacesQualityThreshold Property

NSurveillanceEngine.FacesQualityThreshold Property
NSurveillanceEngine Class Neurotec.Surveillance Namespace

Gets or sets the threshold which is considered when extracting facial features from the image. With higher threshold better quality of face image is required to successfully extract facial features. The value of this parameter can be in range [0..100]. The default value is 50.

C#
public byte FacesQualityThreshold;


NSurveillanceEngine.FacesTemplateSize Property

NSurveillanceEngine.FacesTemplateSize Property
NSurveillanceEngine Class Neurotec.Surveillance Namespace

Gets or sets template size parameter.

C#
public NTemplateSize FacesTemplateSize;


NSurveillanceEngine.GPUIndices Property

NSurveillanceEngine.GPUIndices Property
NSurveillanceEngine Class Neurotec.Surveillance Namespace

Get or Set GPU indices to be used for acceleration.

C#
public NGpuIndex GPUIndices;


NSurveillanceEngine.LicensePlateDetectorScaling Property

NSurveillanceEngine.LicensePlateDetectorScaling Property
NSurveillanceEngine Class Neurotec.Surveillance Namespace

Gets or sets detection model input resolution. Note, that lower value increases performance but reduces accuracy.

C#
public NDetectorScaleCount LicensePlateDetectorScaling;
Property value

Detection model input resolution.


NSurveillanceEngine.LicensePlateDetectorThreshold Property

NSurveillanceEngine.LicensePlateDetectorThreshold Property
NSurveillanceEngine Class Neurotec.Surveillance Namespace

Gets or sets license plate detection threshold (license plate with lower confidence threshold are discarded).

C#
public int LicensePlateDetectorThreshold;
Property value

License plate detection threshold.


NSurveillanceEngine.LicensePlateEnableTemplateMatching Property

NSurveillanceEngine.LicensePlateEnableTemplateMatching Property
NSurveillanceEngine Class Neurotec.Surveillance Namespace

Enables or disables LicensePlatePriorityCountries.

C#
public bool LicensePlateEnableTemplateMatching;
Property value

Set to true to enable LicensePlatePriorityCountries.


NSurveillanceEngine.LicensePlateInterpretOAsZero Property

NSurveillanceEngine.LicensePlateInterpretOAsZero Property
NSurveillanceEngine Class Neurotec.Surveillance Namespace

Changes any predicted o letter to 0, because in many cases there is no real difference between o and 0 fonts so prediction can be wrong.

C#
public bool LicensePlateInterpretOAsZero;
Property value

true, if predicted o letter should be changed to 0 (zero); otherwise, false.


NSurveillanceEngine.LicensePlateMinimalCharacterCount Property

NSurveillanceEngine.LicensePlateMinimalCharacterCount Property
NSurveillanceEngine Class Neurotec.Surveillance Namespace

Gets or sets minimal character count in a license plate.

C#
public int LicensePlateMinimalCharacterCount;
Property value

Minimal character count in a license plate.


NSurveillanceEngine.LicensePlateOcrThreshold Property

NSurveillanceEngine.LicensePlateOcrThreshold Property
NSurveillanceEngine Class Neurotec.Surveillance Namespace

Gets or sets license plate's characters recognition confidence value.

C#
public int LicensePlateOcrThreshold;
Property value

License plate's characters recognition confidence value.


NSurveillanceEngine.LicensePlatePriorityCountries Property

NSurveillanceEngine.LicensePlatePriorityCountries Property
NSurveillanceEngine Class Neurotec.Surveillance Namespace

Gets or sets which countries in license plate formats should be evaluated to reduce mistakes. Use three letter ISO country codes separated with spaces, for example: "LTU LVA EST". If no codes are set, license plate is matched to available formats only if country of origin is determined.

C#
public string LicensePlatePriorityCountries;
Property value

Three letter ISO country codes separated with spaces.


NSurveillanceEngine.ModalityType Property

NSurveillanceEngine.ModalityType Property
NSurveillanceEngine Class Neurotec.Surveillance Namespace

Gets a type of modality used for surveillance and objects detection.

C#
public NSurveillanceModalityType ModalityType;
Property value

NSurveillanceModalityType object containing modality type.


NSurveillanceEngine.NativeType Property

NSurveillanceEngine.NativeType Property
NSurveillanceEngine Class Neurotec.Surveillance Namespace

Neurotechnology framework type of the object.

C#
public static new NType NativeType;


NSurveillanceEngine.ThreadCount Property

NSurveillanceEngine.ThreadCount Property
NSurveillanceEngine Class Neurotec.Surveillance Namespace

Gets or sets thread count used by Surveillance engine.

C#
public int ThreadCount;
Property value

Thread count.


NSurveillanceEngine.UseGPU Property

NSurveillanceEngine.UseGPU Property
NSurveillanceEngine Class Neurotec.Surveillance Namespace

Get or Set whether surveillance should use GPU to accelerate processing.

C#
public bool UseGPU;


NSurveillanceEngine.VehicleHumanDetectorThreshold Property

NSurveillanceEngine.VehicleHumanDetectorThreshold Property
NSurveillanceEngine Class Neurotec.Surveillance Namespace

Gets or sets confidence threshold value for vehicle and human detector. Objects detection with a lower confidence than threshold are discarded.

C#
public int VehicleHumanDetectorThreshold;
Property value

Vehicle and human detector confidence threshold value.


NSurveillanceEventArgs Class

NSurveillanceEventArgs Class
Legend Members Methods NSurveillanceEventArgs Properties

A class that is passed to event handler and through which event data can be accessed.

C#
public class NSurveillanceEventArgs : EventArgs;
Collapse Expand NSurveillanceEventArgs Properties
Name | Description
EventDetailsArray | Gets event details object array.
EventType | Gets event type.
Container

File: NSurveillance.cs

Namespace: Neurotec.Surveillance

Module: .NET Reference


NSurveillanceEventArgs.NSurveillanceEventArgs Constructor

NSurveillanceEventArgs.NSurveillanceEventArgs Constructor
NSurveillanceEventArgs Class Neurotec.Surveillance Namespace

Creates a new instance of NSurveillanceEventArgs class.

C#
public NSurveillanceEventArgs(NSurveillanceEventType eventType, NSurveillanceEventDetails[] eventDetails);
Collapse Expand Parameters
Parameters | Description
NSurveillanceEventType eventType | Type of the event.
NSurveillanceEventDetails[] eventDetails | Event details array.


NSurveillanceEventArgs.EventDetailsArray Property

NSurveillanceEventArgs.EventDetailsArray Property
NSurveillanceEventArgs Class Neurotec.Surveillance Namespace

Gets event details object array.

C#
public NSurveillanceEventDetails[] EventDetailsArray;
Property value

NSurveillanceEventDetails object array which contains events aarguments.


NSurveillanceEventArgs.EventType Property

NSurveillanceEventArgs.EventType Property
NSurveillanceEventArgs Class Neurotec.Surveillance Namespace

Gets event type.

C#
public NSurveillanceEventType EventType;
Property value

NSurveillanceEventType object which contains event types.


NSurveillanceEventDetails Class

NSurveillanceEventDetails Class
NSurveillanceEventDetails Classes NObject Delegates NObject Events NObject Fields Legend Members NDisposable Methods NDisposable Properties

A class that provides access to event details data.

C#
public sealed class NSurveillanceEventDetails : NObject;
Collapse Expand NSurveillanceEventDetails Classes
NSurveillanceEventDetails Class
Name | Description
BestMatchCollection | Contains best matching items.
CurrentMatchCollection | Contains current matching items.
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NSurveillanceEventDetails Class
Name | Description
GetAttribtues | Gets face attributes from specified surveillance event details.
GetDetectedFaces | Gets the list of detected faces attributes.
GetFace | Gets face of the specified event.
GetOriginalImage | Retrieves the originally captured image.
GetSubjectTemplate | Retrieves generalized Subject template.
GetVideoSample | Retrieves captured video sample.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NSurveillanceEventDetails Class
Name | Description
Attributes | Gets face attributes from surveillance event details.
AttributesContainsDetails | Checks whether surveillance event contains extraction details.
BestDetails | Get event containing best details for tracked subject.
BestMatches | Retrieves BestMatchesCollection.
CurrentMatches | Retrieves CurrentMatchesCollection.
Error | Gets the most recent error for the specified surveillance event.
Face | Gets face of the specified event.
FaceConfidence | A property that returns confidence of tracked face if any.
FrameIndex | A property that returns the number of captured images prior to this event.
MergedSubject | Get subject that was merged with current subject. Only applicable during SubjectMerged event.
ModalityType | A property that returns type of the subject event.
NativeType | Defines the native type of the object.
OriginalImage | A property that returns originally captured image.
Owner | Gets NSurveillance owner.
Rectangle | A property that returns bounding rectangle of a subject being processed.
SplitFromSubject | Get subject from which current subject was split. Only applicable during SubjectSplit event.
SubjectType | A property that returns subject type for current event
Template | A property that returns extracted serialized template.
TimeStamp | A property that returns the date and time of the captured image.
TraceIndex | A property that returns an index of the current subject being tracked. The index is zero-based and represents unique id of subject being tracked at the current moment. After subject disappears this index becomes invalid.
VideoTimeStamp | A property that returns time in video of the captured image.
Container

File: NSurveillanceEventDetails.cs

Namespace: Neurotec.Surveillance

Module: .NET Reference


NSurveillanceEventDetails.BestMatchCollection Class

NSurveillanceEventDetails.BestMatchCollection Class

Contains best matching items.

C#
public sealed class BestMatchCollection : NObjectReadOnlyCollection<NsedMatchResult>;
Container

File: NSurveillanceEventDetails.cs

Namespace: Neurotec.Surveillance

Module: .NET Reference


NSurveillanceEventDetails.CurrentMatchCollection Class

NSurveillanceEventDetails.CurrentMatchCollection Class

Contains current matching items.

C#
public sealed class CurrentMatchCollection : NObjectReadOnlyCollection<NsedMatchResult>;
Container

File: NSurveillanceEventDetails.cs

Namespace: Neurotec.Surveillance

Module: .NET Reference


NSurveillanceEventDetails.GetAttribtues Method

NSurveillanceEventDetails.GetAttribtues Method
NSurveillanceEventDetails Class Neurotec.Surveillance Namespace

Gets face attributes from specified surveillance event details.

C#
public NLAttributes GetAttribtues(bool cache);
Collapse Expand Parameters
Parameters | Description
bool cache | If true, object will be cached; otherwise - false.
Collapse Expand Returns

NLAttributes object.


NSurveillanceEventDetails.GetDetectedFaces Method

NSurveillanceEventDetails.GetDetectedFaces Method
NSurveillanceEventDetails Class Neurotec.Surveillance Namespace

Gets the list of detected faces attributes.

C#
public NLAttributes[] GetDetectedFaces();
Collapse Expand Returns

Array of NLAttributes objects.


NSurveillanceEventDetails.GetFace Method

NSurveillanceEventDetails.GetFace Method
NSurveillanceEventDetails Class Neurotec.Surveillance Namespace

Gets face of the specified event.

C#
public NFace GetFace(bool cache);
Collapse Expand Parameters
Parameters | Description
bool cache | If true, object will be cached; otherwise - false.
Collapse Expand Returns

NFace object.


NSurveillanceEventDetails.GetOriginalImage Method

NSurveillanceEventDetails.GetOriginalImage Method
NSurveillanceEventDetails Class Neurotec.Surveillance Namespace

Retrieves the originally captured image.

C#
public NImage GetOriginalImage(bool cache);
Collapse Expand Parameters
Parameters | Description
bool cache | If true, object will be cached; otherwise - false.
Collapse Expand Returns

NImage object containing original image.


NSurveillanceEventDetails.GetSubjectTemplate Method

NSurveillanceEventDetails.GetSubjectTemplate Method
NSurveillanceEventDetails Class Neurotec.Surveillance Namespace

Retrieves generalized Subject template.

C#
public NLTemplate GetSubjectTemplate();
Collapse Expand Returns

Subject template is a compressed generalized template of all extracted faces during subject tracking whose Id matches that of the best matched Id. If there is no best match, then it includes all templates into generalization.

The template is updated every time a new face is determined to belong to the tracked subject.

Returned template must be cloned before using it.


NSurveillanceEventDetails.GetVideoSample Method

NSurveillanceEventDetails.GetVideoSample Method
NSurveillanceEventDetails Class Neurotec.Surveillance Namespace

Retrieves captured video sample.

C#
public NVideoSample GetVideoSample(bool cache);
Collapse Expand Parameters
Parameters | Description
bool cache | If true, object will be cached; otherwise - false.
Collapse Expand Returns

NVideoSample object containing video sample.


NSurveillanceEventDetails.Attributes Property

NSurveillanceEventDetails.Attributes Property
NSurveillanceEventDetails Class Neurotec.Surveillance Namespace

Gets face attributes from surveillance event details.

C#
public NLAttributes Attributes;
Property value

NLAttributes object.


NSurveillanceEventDetails.AttributesContainsDetails Property

NSurveillanceEventDetails.AttributesContainsDetails Property
NSurveillanceEventDetails Class Neurotec.Surveillance Namespace

Checks whether surveillance event contains extraction details.

C#
public bool AttributesContainsDetails;
Property value

If true, an event contains extraction details (object was extracted); if false, object was not extracted yet and extraction details are not available (but still object tracking rectangle can be drawn).


NSurveillanceEventDetails.BestDetails Property

NSurveillanceEventDetails.BestDetails Property
NSurveillanceEventDetails Class Neurotec.Surveillance Namespace

Get event containing best details for tracked subject.

C#
public NSurveillanceEventDetails BestDetails;


NSurveillanceEventDetails.BestMatches Property

NSurveillanceEventDetails.BestMatches Property
NSurveillanceEventDetails Class Neurotec.Surveillance Namespace

Retrieves BestMatchesCollection.

C#
public BestMatchCollection BestMatches;


NSurveillanceEventDetails.CurrentMatches Property

NSurveillanceEventDetails.CurrentMatches Property
NSurveillanceEventDetails Class Neurotec.Surveillance Namespace

Retrieves CurrentMatchesCollection.

C#
public CurrentMatchCollection CurrentMatches;


NSurveillanceEventDetails.Error Property

NSurveillanceEventDetails.Error Property
NSurveillanceEventDetails Class Neurotec.Surveillance Namespace

Gets the most recent error for the specified surveillance event.

C#
public Exception Error;
Property value

Exception object.


NSurveillanceEventDetails.Face Property

NSurveillanceEventDetails.Face Property
NSurveillanceEventDetails Class Neurotec.Surveillance Namespace

Gets face of the specified event.

C#
public NFace Face;
Property value

NFace object.


NSurveillanceEventDetails.FaceConfidence Property

NSurveillanceEventDetails.FaceConfidence Property
NSurveillanceEventDetails Class Neurotec.Surveillance Namespace

A property that returns confidence of tracked face if any.

C#
public byte FaceConfidence;


NSurveillanceEventDetails.FrameIndex Property

NSurveillanceEventDetails.FrameIndex Property
NSurveillanceEventDetails Class Neurotec.Surveillance Namespace

A property that returns the number of captured images prior to this event.

C#
public ulong FrameIndex;


NSurveillanceEventDetails.MergedSubject Property

NSurveillanceEventDetails.MergedSubject Property
NSurveillanceEventDetails Class Neurotec.Surveillance Namespace

Get subject that was merged with current subject. Only applicable during SubjectMerged event.

C#
public NSurveillanceEventDetails MergedSubject;


NSurveillanceEventDetails.ModalityType Property

NSurveillanceEventDetails.ModalityType Property
NSurveillanceEventDetails Class Neurotec.Surveillance Namespace

A property that returns type of the subject event.

C#
public NSurveillanceModalityType ModalityType;


NSurveillanceEventDetails.NativeType Property

NSurveillanceEventDetails.NativeType Property
NSurveillanceEventDetails Class Neurotec.Surveillance Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NSurveillanceEventDetails.OriginalImage Property

NSurveillanceEventDetails.OriginalImage Property
NSurveillanceEventDetails Class Neurotec.Surveillance Namespace

A property that returns originally captured image.

C#
public NImage OriginalImage;


NSurveillanceEventDetails.Owner Property

NSurveillanceEventDetails.Owner Property
NSurveillanceEventDetails Class Neurotec.Surveillance Namespace

Gets NSurveillance owner.

C#
public new NSurveillance Owner;


NSurveillanceEventDetails.Rectangle Property

NSurveillanceEventDetails.Rectangle Property
NSurveillanceEventDetails Class Neurotec.Surveillance Namespace

A property that returns bounding rectangle of a subject being processed.

C#
public Rectangle Rectangle;


NSurveillanceEventDetails.SplitFromSubject Property

NSurveillanceEventDetails.SplitFromSubject Property
NSurveillanceEventDetails Class Neurotec.Surveillance Namespace

Get subject from which current subject was split. Only applicable during SubjectSplit event.

C#
public NSurveillanceEventDetails SplitFromSubject;


NSurveillanceEventDetails.SubjectType Property

NSurveillanceEventDetails.SubjectType Property
NSurveillanceEventDetails Class Neurotec.Surveillance Namespace

A property that returns subject type for current event

C#
public NSurveillanceModalityType SubjectType;


NSurveillanceEventDetails.Template Property

NSurveillanceEventDetails.Template Property
NSurveillanceEventDetails Class Neurotec.Surveillance Namespace

A property that returns extracted serialized template.

C#
public NLTemplate Template;


NSurveillanceEventDetails.TimeStamp Property

NSurveillanceEventDetails.TimeStamp Property
NSurveillanceEventDetails Class Neurotec.Surveillance Namespace

A property that returns the date and time of the captured image.

C#
public DateTime TimeStamp;


NSurveillanceEventDetails.TraceIndex Property

NSurveillanceEventDetails.TraceIndex Property
NSurveillanceEventDetails Class Neurotec.Surveillance Namespace

A property that returns an index of the current subject being tracked. The index is zero-based and represents unique id of subject being tracked at the current moment. After subject disappears this index becomes invalid.

C#
public int TraceIndex;


NSurveillanceEventDetails.VideoTimeStamp Property

NSurveillanceEventDetails.VideoTimeStamp Property
NSurveillanceEventDetails Class Neurotec.Surveillance Namespace

A property that returns time in video of the captured image.

C#
public TimeSpan VideoTimeStamp;


NSurveillanceObjectColorDetails Structure

NSurveillanceObjectColorDetails Structure
Legend Members NSurveillanceObjectColorDetails Properties

Represents surveillance object color details.

C#
[StructLayout(LayoutKind.Sequential)]
public struct NSurveillanceObjectColorDetails {
}
Collapse Expand NSurveillanceObjectColorDetails Properties
Name | Description
BlackColorConfidence | Gets or sets black color confidence value.
BlueColorConfidence | Gets or sets blue color confidence value.
BrownColorConfidence | Gets or sets brown color confidence value.
Color | Gets or sets color of a detected object.
GrayColorConfidence | Gets or sets gray color confidence value.
GreenColorConfidence | Gets or sets green color confidence value.
OrangeColorConfidence | Gets or sets orange color confidence value.
RedColorConfidence | Gets or sets red color confidence value.
SilverColorConfidence | Gets or sets silver color confidence value.
WhiteColorConfidence | Gets or sets white color confidence value.
YellowColorConfidence | Gets or sets yellow color confidence value.
Container

File: NSurveillanceEventDetails.cs

Namespace: Neurotec.Surveillance

Module: .NET Reference


NSurveillanceObjectColorDetails.BlackColorConfidence Property

NSurveillanceObjectColorDetails.BlackColorConfidence Property
NSurveillanceObjectColorDetails Structure Neurotec.Surveillance Namespace

Gets or sets black color confidence value.

C#
public float BlackColorConfidence;
Property value

Black color confidence value.


NSurveillanceObjectColorDetails.BlueColorConfidence Property

NSurveillanceObjectColorDetails.BlueColorConfidence Property
NSurveillanceObjectColorDetails Structure Neurotec.Surveillance Namespace

Gets or sets blue color confidence value.

C#
public float BlueColorConfidence;
Property value

Blue color confidence value.


NSurveillanceObjectColorDetails.BrownColorConfidence Property

NSurveillanceObjectColorDetails.BrownColorConfidence Property
NSurveillanceObjectColorDetails Structure Neurotec.Surveillance Namespace

Gets or sets brown color confidence value.

C#
public float BrownColorConfidence;
Property value

Brown color confidence value.


NSurveillanceObjectColorDetails.Color Property

NSurveillanceObjectColorDetails.Color Property
NSurveillanceObjectColorDetails Structure Neurotec.Surveillance Namespace

Gets or sets color of a detected object.

C#
public NSurveillanceObjectColor Color;
Property value

NSurveillanceObjectColor containing object color.


NSurveillanceObjectColorDetails.GrayColorConfidence Property

NSurveillanceObjectColorDetails.GrayColorConfidence Property
NSurveillanceObjectColorDetails Structure Neurotec.Surveillance Namespace

Gets or sets gray color confidence value.

C#
public float GrayColorConfidence;
Property value

Gray color confidence value.


NSurveillanceObjectColorDetails.GreenColorConfidence Property

NSurveillanceObjectColorDetails.GreenColorConfidence Property
NSurveillanceObjectColorDetails Structure Neurotec.Surveillance Namespace

Gets or sets green color confidence value.

C#
public float GreenColorConfidence;
Property value

Green color confidence value.


NSurveillanceObjectColorDetails.OrangeColorConfidence Property

NSurveillanceObjectColorDetails.OrangeColorConfidence Property
NSurveillanceObjectColorDetails Structure Neurotec.Surveillance Namespace

Gets or sets orange color confidence value.

C#
public float OrangeColorConfidence;
Property value

Orange color confidence value.


NSurveillanceObjectColorDetails.RedColorConfidence Property

NSurveillanceObjectColorDetails.RedColorConfidence Property
NSurveillanceObjectColorDetails Structure Neurotec.Surveillance Namespace

Gets or sets red color confidence value.

C#
public float RedColorConfidence;
Property value

Red color confidence value.


NSurveillanceObjectColorDetails.SilverColorConfidence Property

NSurveillanceObjectColorDetails.SilverColorConfidence Property
NSurveillanceObjectColorDetails Structure Neurotec.Surveillance Namespace

Gets or sets silver color confidence value.

C#
public float SilverColorConfidence;
Property value

Silver color confidence value.


NSurveillanceObjectColorDetails.WhiteColorConfidence Property

NSurveillanceObjectColorDetails.WhiteColorConfidence Property
NSurveillanceObjectColorDetails Structure Neurotec.Surveillance Namespace

Gets or sets white color confidence value.

C#
public float WhiteColorConfidence;
Property value

White color confidence value.


NSurveillanceObjectColorDetails.YellowColorConfidence Property

NSurveillanceObjectColorDetails.YellowColorConfidence Property
NSurveillanceObjectColorDetails Structure Neurotec.Surveillance Namespace

Gets or sets yellow color confidence value.

C#
public float YellowColorConfidence;
Property value

Yellow color confidence value.


NSurveillanceObjectDirectionDetails Structure

NSurveillanceObjectDirectionDetails Structure
Legend Members NSurveillanceObjectDirectionDetails Properties

Represents detected object direction details.

C#
[StructLayout(LayoutKind.Sequential)]
public struct NSurveillanceObjectDirectionDetails {
}
Collapse Expand NSurveillanceObjectDirectionDetails Properties
Name | Description
Direction | Gets or sets NSurveillanceObjectDirection object.
EastConfidence | Gets or sets east confidence value.
NorthConfidence | Gets or sets north confidence value.
NorthEastConfidence | Gets or sets north east confidence value.
NorthWestConfidence | Gets or sets north west confidence value.
SouthConfidence | Gets or sets south confidence value.
SouthEastConfidence | Gets or sets south east confidence value.
SouthWestConfidence | Gets or sets south west confidence value.
WestConfidence | Gets or sets west confidence value.
Container

File: NSurveillanceEventDetails.cs

Namespace: Neurotec.Surveillance

Module: .NET Reference


NSurveillanceObjectDirectionDetails.Direction Property

NSurveillanceObjectDirectionDetails.Direction Property
NSurveillanceObjectDirectionDetails Structure Neurotec.Surveillance Namespace

Gets or sets NSurveillanceObjectDirection object.

C#
public NSurveillanceObjectDirection Direction;
Property value

NSurveillanceObjectDirection object.


NSurveillanceObjectDirectionDetails.EastConfidence Property

NSurveillanceObjectDirectionDetails.EastConfidence Property
NSurveillanceObjectDirectionDetails Structure Neurotec.Surveillance Namespace

Gets or sets east confidence value.

C#
public float EastConfidence;
Property value

East confidence value.


NSurveillanceObjectDirectionDetails.NorthConfidence Property

NSurveillanceObjectDirectionDetails.NorthConfidence Property
NSurveillanceObjectDirectionDetails Structure Neurotec.Surveillance Namespace

Gets or sets north confidence value.

C#
public float NorthConfidence;
Property value

North confidence value.


NSurveillanceObjectDirectionDetails.NorthEastConfidence Property

NSurveillanceObjectDirectionDetails.NorthEastConfidence Property
NSurveillanceObjectDirectionDetails Structure Neurotec.Surveillance Namespace

Gets or sets north east confidence value.

C#
public float NorthEastConfidence;
Property value

North east confidence value.


NSurveillanceObjectDirectionDetails.NorthWestConfidence Property

NSurveillanceObjectDirectionDetails.NorthWestConfidence Property
NSurveillanceObjectDirectionDetails Structure Neurotec.Surveillance Namespace

Gets or sets north west confidence value.

C#
public float NorthWestConfidence;
Property value

North west confidence value.


NSurveillanceObjectDirectionDetails.SouthConfidence Property

NSurveillanceObjectDirectionDetails.SouthConfidence Property
NSurveillanceObjectDirectionDetails Structure Neurotec.Surveillance Namespace

Gets or sets south confidence value.

C#
public float SouthConfidence;
Property value

South confidence value.


NSurveillanceObjectDirectionDetails.SouthEastConfidence Property

NSurveillanceObjectDirectionDetails.SouthEastConfidence Property
NSurveillanceObjectDirectionDetails Structure Neurotec.Surveillance Namespace

Gets or sets south east confidence value.

C#
public float SouthEastConfidence;
Property value

South east confidence value.


NSurveillanceObjectDirectionDetails.SouthWestConfidence Property

NSurveillanceObjectDirectionDetails.SouthWestConfidence Property
NSurveillanceObjectDirectionDetails Structure Neurotec.Surveillance Namespace

Gets or sets south west confidence value.

C#
public float SouthWestConfidence;
Property value

South west confidence value.


NSurveillanceObjectDirectionDetails.WestConfidence Property

NSurveillanceObjectDirectionDetails.WestConfidence Property
NSurveillanceObjectDirectionDetails Structure Neurotec.Surveillance Namespace

Gets or sets west confidence value.

C#
public float WestConfidence;
Property value

West confidence value.


NSurveillanceObjectTypeDetails Structure

NSurveillanceObjectTypeDetails Structure
Legend Members NSurveillanceObjectTypeDetails Properties

Represents detected object type details.

C#
[StructLayout(LayoutKind.Sequential)]
public struct NSurveillanceObjectTypeDetails {
}
Collapse Expand NSurveillanceObjectTypeDetails Properties
Name | Description
BikeConfidence | Gets or sets confidence value if detected object is a bike.
BusConfidence | Gets or sets confidence value if detected object is a bus.
CarConfidence | Gets or sets confidence value if detected object is a car.
PersonConfidence | Gets or sets confidence value if detected object is a person.
TruckConfidence | Gets or sets confidence value if detected object is a truck.
Type | Gets or sets NSurveillanceObjectType object.
Container

File: NSurveillanceEventDetails.cs

Namespace: Neurotec.Surveillance

Module: .NET Reference


NSurveillanceObjectTypeDetails.BikeConfidence Property

NSurveillanceObjectTypeDetails.BikeConfidence Property
NSurveillanceObjectTypeDetails Structure Neurotec.Surveillance Namespace

Gets or sets confidence value if detected object is a bike.

C#
public float BikeConfidence;
Property value

Confidence value if detected object is a bike.


NSurveillanceObjectTypeDetails.BusConfidence Property

NSurveillanceObjectTypeDetails.BusConfidence Property
NSurveillanceObjectTypeDetails Structure Neurotec.Surveillance Namespace

Gets or sets confidence value if detected object is a bus.

C#
public float BusConfidence;
Property value

Confidence value if detected object is a bus.


NSurveillanceObjectTypeDetails.CarConfidence Property

NSurveillanceObjectTypeDetails.CarConfidence Property
NSurveillanceObjectTypeDetails Structure Neurotec.Surveillance Namespace

Gets or sets confidence value if detected object is a car.

C#
public float CarConfidence;
Property value

Confidence value if detected object is a car.


NSurveillanceObjectTypeDetails.PersonConfidence Property

NSurveillanceObjectTypeDetails.PersonConfidence Property
NSurveillanceObjectTypeDetails Structure Neurotec.Surveillance Namespace

Gets or sets confidence value if detected object is a person.

C#
public float PersonConfidence;
Property value

Confidence value if detected object is a person.


NSurveillanceObjectTypeDetails.TruckConfidence Property

NSurveillanceObjectTypeDetails.TruckConfidence Property
NSurveillanceObjectTypeDetails Structure Neurotec.Surveillance Namespace

Gets or sets confidence value if detected object is a truck.

C#
public float TruckConfidence;
Property value

Confidence value if detected object is a truck.


NSurveillanceObjectTypeDetails.Type Property

NSurveillanceObjectTypeDetails.Type Property
NSurveillanceObjectTypeDetails Structure Neurotec.Surveillance Namespace

Gets or sets NSurveillanceObjectType object.

C#
public NSurveillanceObjectType Type;
Property value

NSurveillanceObjectType object.


NSurveillanceProgressEventArgs Class

NSurveillanceProgressEventArgs Class

Event arguments for progress callback.

C#
public class NSurveillanceProgressEventArgs : EventArgs;
Container

File: NSurveillance.cs

Namespace: Neurotec.Surveillance

Module: .NET Reference


NSurveillanceSource Class

NSurveillanceSource Class
NObject Delegates NObject Events NObject Fields Legend Members Methods NDisposable Methods NDisposable Properties

Provides functions for managing Surveillance sources - cameras and video files.

C#
public sealed class NSurveillanceSource : NExpandableObject;
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
NSurveillanceSource Class
Name | Description
IsCapturingChanged | This event is called when Surveillance Source "capturing" state changed.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NSurveillanceSource Class
Name | Description
GetCurrentFormat | Gets current media format used in surveillance.
GetFormats | Gets all formats supported by camera or video.
SetCurrentFormat | Sets current media format used in surveillance.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NExpandableObject Class
Show:
No members matching the current filter
Name | Description
NativeType | Defines the native type of the object.
Properties | Gets the property bag of the expandable object.
NSurveillanceSource Class
Name | Description
Camera | Gets or sets the camera for the current NSurveillanceSource.
Error | Gets the exception thrown internally by processing NSurveillanceSource.
Length | Gets the TimeSpan structure representing the length of NSurveillanceSource.
ModalityType | Gets a type of modality used for surveillance source.
NativeType | Defines the native type of the object.
Owner | Gets NSurveillance owner.
Position | Gets or sets the TimeSpan structure representing the position of NSurveillanceSource.
RegionOfInterest | Gets or sets rectangle coordinates for region of interest frame.
State | Gets the NSurveillanceSource state.
Type | Gets the NSurveillanceSource type.
Video | Gets or sets the media reader containing the video for the current NSurveillanceSource.
Warning | Gets the warning set internally by processing NSurveillanceSource.
Container

File: NSurveillanceSource.cs

Namespace: Neurotec.Surveillance

Module: .NET Reference


NSurveillanceSource.NSurveillanceSource Constructor ()

NSurveillanceSource.NSurveillanceSource Constructor ()
NSurveillanceSource Class Neurotec.Surveillance Namespace

Creates a new instance of NSurveillanceSource class.

C#
public NSurveillanceSource();


NSurveillanceSource.NSurveillanceSource Constructor (NSurveillanceModalityType, NCamera)

NSurveillanceSource.NSurveillanceSource Constructor (NSurveillanceModalityType, NCamera)
NSurveillanceSource Class Neurotec.Surveillance Namespace

Creates a new instance of NSurveillanceSource class.

C#
public NSurveillanceSource(NSurveillanceModalityType modalities, NCamera camera);
Collapse Expand Parameters
Parameters | Description
NSurveillanceModalityType modalities | Surveillance modalites type.
NCamera camera | NCamera object.


NSurveillanceSource.NSurveillanceSource Constructor (NSurveillanceModalityType, NMediaReader)

NSurveillanceSource.NSurveillanceSource Constructor (NSurveillanceModalityType, NMediaReader)
NSurveillanceSource Class Neurotec.Surveillance Namespace

Creates a new instance of NSurveillanceSource class.

C#
public NSurveillanceSource(NSurveillanceModalityType modalities, NMediaReader reader);
Collapse Expand Parameters
Parameters | Description
NSurveillanceModalityType modalities | Surveillance modalites type.
NMediaReader reader | NMediaReader object.


NSurveillanceSource.GetCurrentFormat Method

NSurveillanceSource.GetCurrentFormat Method
NSurveillanceSource Class Neurotec.Surveillance Namespace

Gets current media format used in surveillance.

C#
public NMediaFormat GetCurrentFormat();
Collapse Expand Returns

NMediaFormat object.


NSurveillanceSource.GetFormats Method

NSurveillanceSource.GetFormats Method
NSurveillanceSource Class Neurotec.Surveillance Namespace

Gets all formats supported by camera or video.

C#
public NMediaFormat[] GetFormats();
Collapse Expand Returns

An array of media formats supported by a camera or video.


NSurveillanceSource.SetCurrentFormat Method

NSurveillanceSource.SetCurrentFormat Method
NSurveillanceSource Class Neurotec.Surveillance Namespace

Sets current media format used in surveillance.

C#
public void SetCurrentFormat(NMediaFormat value);
Collapse Expand Parameters
Parameters | Description
NMediaFormat value | NMediaFormat object.


NSurveillanceSource.Camera Property

NSurveillanceSource.Camera Property
NSurveillanceSource Class Neurotec.Surveillance Namespace

Gets or sets the camera for the current NSurveillanceSource.

C#
public NCamera Camera;


NSurveillanceSource.Error Property

NSurveillanceSource.Error Property
NSurveillanceSource Class Neurotec.Surveillance Namespace

Gets the exception thrown internally by processing NSurveillanceSource.

C#
public Exception Error;


NSurveillanceSource.Length Property

NSurveillanceSource.Length Property
NSurveillanceSource Class Neurotec.Surveillance Namespace

Gets the TimeSpan structure representing the length of NSurveillanceSource.

C#
public TimeSpan Length;


NSurveillanceSource.ModalityType Property

NSurveillanceSource.ModalityType Property
NSurveillanceSource Class Neurotec.Surveillance Namespace

Gets a type of modality used for surveillance source.

C#
public NSurveillanceModalityType ModalityType;
Property value

NSurveillanceModalityType object containing modality type.


NSurveillanceSource.NativeType Property

NSurveillanceSource.NativeType Property
NSurveillanceSource Class Neurotec.Surveillance Namespace

Defines the native type of the object.

C#
public static new NType NativeType;


NSurveillanceSource.Owner Property

NSurveillanceSource.Owner Property
NSurveillanceSource Class Neurotec.Surveillance Namespace

Gets NSurveillance owner.

C#
public new NSurveillance Owner;


NSurveillanceSource.Position Property

NSurveillanceSource.Position Property
NSurveillanceSource Class Neurotec.Surveillance Namespace

Gets or sets the TimeSpan structure representing the position of NSurveillanceSource.

C#
public TimeSpan Position;


NSurveillanceSource.RegionOfInterest Property

NSurveillanceSource.RegionOfInterest Property
NSurveillanceSource Class Neurotec.Surveillance Namespace

Gets or sets rectangle coordinates for region of interest frame.

C#
[Obsolete("Use SearchArea instead.")]
public RectangleF RegionOfInterest;
Property value

RectangleF containing coordinates for region of interest frame.


NSurveillanceSource.State Property

NSurveillanceSource.State Property
NSurveillanceSource Class Neurotec.Surveillance Namespace

Gets the NSurveillanceSource state.

C#
public NMediaState State;


NSurveillanceSource.Type Property

NSurveillanceSource.Type Property
NSurveillanceSource Class Neurotec.Surveillance Namespace

Gets the NSurveillanceSource type.

C#
public NSurveillanceSourceType Type;


NSurveillanceSource.Video Property

NSurveillanceSource.Video Property
NSurveillanceSource Class Neurotec.Surveillance Namespace

Gets or sets the media reader containing the video for the current NSurveillanceSource.

C#
public NMediaReader Video;


NSurveillanceSource.Warning Property

NSurveillanceSource.Warning Property
NSurveillanceSource Class Neurotec.Surveillance Namespace

Gets the warning set internally by processing NSurveillanceSource.

C#
public string Warning;


NSurveillanceSource.IsCapturingChanged Event

NSurveillanceSource.IsCapturingChanged Event
NSurveillanceSource Class Neurotec.Surveillance Namespace

This event is called when Surveillance Source "capturing" state changed.

C#
public event EventHandler<EventArgs> IsCapturingChanged;


NTrackingDetails Class

NTrackingDetails Class
NTrackingDetails Classes NObject Delegates NObject Events NObject Fields Legend Members NDisposable Methods NDisposable Properties

Represents objects tracking details.

C#
public class NTrackingDetails : NObject;
Collapse Expand NTrackingDetails Classes
NTrackingDetails Class
Name | Description
LicensePlateCollection | Collection of detected license plates.
MatchResultCollection | Collection of match results.
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NTrackingDetails Class
Name | Description
Attributes | Gets face attributes (like age, gender, emotions and other) of a detected face.
AttributesContainsDetails | Gets whether face template was extracted and contains faces attributes such as gender or face expression.
FrameIndex | Gets frame index.
LicensePlates | Gets license plates collection.
MatchResults | Gets match results collection containing subject's matching results.
NativeType | Neurotechnology framework type of the object.
Rectangle | Gets rectangle of bounding box of a tracked object.
SubjectType | Gets which surveillance modalities was detected for a subject.
TimeStamp | Gets time stamp from tracking details.
Container

File: NTrackingDetails.cs

Namespace: Neurotec.Surveillance

Module: .NET Reference


NTrackingDetails.LicensePlateCollection Class

NTrackingDetails.LicensePlateCollection Class

Collection of detected license plates.

C#
public sealed class LicensePlateCollection : NObjectCollection<NLicensePlate>;
Container

File: NTrackingDetails.cs

Namespace: Neurotec.Surveillance

Module: .NET Reference


NTrackingDetails.MatchResultCollection Class

NTrackingDetails.MatchResultCollection Class

Collection of match results.

C#
public sealed class MatchResultCollection : NObjectCollection<NsedMatchResult>;
Container

File: NTrackingDetails.cs

Namespace: Neurotec.Surveillance

Module: .NET Reference


NTrackingDetails.Attributes Property

NTrackingDetails.Attributes Property
NTrackingDetails Class Neurotec.Surveillance Namespace

Gets face attributes (like age, gender, emotions and other) of a detected face.

C#
public NLAttributes Attributes;
Property value

NLAttributes object containing face attributes of a detected face.


NTrackingDetails.AttributesContainsDetails Property

NTrackingDetails.AttributesContainsDetails Property
NTrackingDetails Class Neurotec.Surveillance Namespace

Gets whether face template was extracted and contains faces attributes such as gender or face expression.

C#
public bool AttributesContainsDetails;
Property value

true, if extracted face template contains face attributes.


NTrackingDetails.FrameIndex Property

NTrackingDetails.FrameIndex Property
NTrackingDetails Class Neurotec.Surveillance Namespace

Gets frame index.

C#
public ulong FrameIndex;
Property value

Frame index.


NTrackingDetails.LicensePlates Property

NTrackingDetails.LicensePlates Property
NTrackingDetails Class Neurotec.Surveillance Namespace

Gets license plates collection.

C#
public LicensePlateCollection LicensePlates;
Property value

LicensePlateCollection object.


NTrackingDetails.MatchResults Property

NTrackingDetails.MatchResults Property
NTrackingDetails Class Neurotec.Surveillance Namespace

Gets match results collection containing subject's matching results.

C#
public MatchResultCollection MatchResults;
Property value

MatchResultCollection object containing subject's matching results.


NTrackingDetails.NativeType Property

NTrackingDetails.NativeType Property
NTrackingDetails Class Neurotec.Surveillance Namespace

Neurotechnology framework type of the object.

C#
public static new NType NativeType;


NTrackingDetails.Rectangle Property

NTrackingDetails.Rectangle Property
NTrackingDetails Class Neurotec.Surveillance Namespace

Gets rectangle of bounding box of a tracked object.

C#
public Rectangle Rectangle;
Property value

Rectangle object containing coordinates, width and height.


NTrackingDetails.SubjectType Property

NTrackingDetails.SubjectType Property
NTrackingDetails Class Neurotec.Surveillance Namespace

Gets which surveillance modalities was detected for a subject.

C#
public NSurveillanceModalityType SubjectType;
Property value

NSurveillanceModalityType object containing subject modality type.

Collapse Expand Remarks

E.g., when vehicle and human detector is enabled and subject is turned away, only vehicle type is returned. Or when a face and a vehicle is detected, vehicle + human type is returned.

These surveilance subject modalities are available: None, Faces, VehiclesAndHumans.


NTrackingDetails.TimeStamp Property

NTrackingDetails.TimeStamp Property
NTrackingDetails Class Neurotec.Surveillance Namespace

Gets time stamp from tracking details.

C#
public DateTime TimeStamp;
Property value

Time stamp value.


NVehicleDetails Class

NVehicleDetails Class
NVehicleDetails Classes NObject Delegates NObject Events NObject Fields Legend Members NDisposable Methods NDisposable Properties

Represents vehicle details.

C#
public class NVehicleDetails : NObject;
Collapse Expand NVehicleDetails Classes
NVehicleDetails Class
Name | Description
ModelCollection | Vehicle model collection.
TagCollection | Vehicle body type collection (sedan, coupe, bus, tractor, etc.).
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NVehicleDetails Class
Name | Description
GetKnownMakes | Gets the array of known vehicle makes (names of vehicle manufacturers).
GetKnownModels | Gets the array of all known vehicle models.
GetKnownTags | Gets all known vehicle body types (like sedan, coupe, bus, tractor, etc.).
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NVehicleDetails Class
Name | Description
Models | Gets ModelCollection object containing vehicle models.
NVehicleOrientationNativeType | Gets NVehicleOrientation native type.
NativeType | Neurotechnology framework type of the object.
Orientation | Gets vehicle orientation value (Front, Back, Left, FrontLeft, etc.).
OrientationAngle | Gets an angle of vehicle orientation.
OrientationConfidence | Gets confidence value of vehicle's orientation.
Tags | Gets TagCollection object containing vehicle body types.
Container

File: NVehicleDetails.cs

Namespace: Neurotec.Surveillance

Module: .NET Reference


NVehicleDetails.ModelCollection Class

NVehicleDetails.ModelCollection Class

Vehicle model collection.

C#
public class ModelCollection : NObjectReadOnlyCollection<NVehicleModel>;
Container

File: NVehicleDetails.cs

Namespace: Neurotec.Surveillance

Module: .NET Reference


NVehicleDetails.TagCollection Class

NVehicleDetails.TagCollection Class

Vehicle body type collection (sedan, coupe, bus, tractor, etc.).

C#
public class TagCollection : DisposableStructReadOnlyCollection<NNameConfidencePair, NNameConfidencePair_>;
Container

File: NVehicleDetails.cs

Namespace: Neurotec.Surveillance

Module: .NET Reference


NVehicleDetails.GetKnownMakes Method

NVehicleDetails.GetKnownMakes Method
NVehicleDetails Class Neurotec.Surveillance Namespace

Gets the array of known vehicle makes (names of vehicle manufacturers).

C#
public static string[] GetKnownMakes();
Collapse Expand Returns

String array containing known vehicle makes.


NVehicleDetails.GetKnownModels Method ()

NVehicleDetails.GetKnownModels Method ()
NVehicleDetails Class Neurotec.Surveillance Namespace

Gets the array of all known vehicle models.

C#
public static string[] GetKnownModels();
Collapse Expand Returns

String array containing known vehicle models.


NVehicleDetails.GetKnownModels Method (string)

NVehicleDetails.GetKnownModels Method (string)
NVehicleDetails Class Neurotec.Surveillance Namespace See Also

Gets the array of known vehicle models of the specified vehicle make.

C#
public static string[] GetKnownModels(string make);
Collapse Expand Parameters
Parameters | Description
string make | Vehicle make (manufacturer) to retrieve its all known models.
Collapse Expand Returns

String array containing known vehicle models.

Collapse Expand See Also

GetKnownMakes


NVehicleDetails.GetKnownTags Method

NVehicleDetails.GetKnownTags Method
NVehicleDetails Class Neurotec.Surveillance Namespace

Gets all known vehicle body types (like sedan, coupe, bus, tractor, etc.).

C#
public static string[] GetKnownTags();
Collapse Expand Returns

String array containing known vehicle body types.


NVehicleDetails.Models Property

NVehicleDetails.Models Property
NVehicleDetails Class Neurotec.Surveillance Namespace

Gets ModelCollection object containing vehicle models.

C#
public ModelCollection Models;
Property value

ModelCollection object containing vehicle models.


NVehicleDetails.NVehicleOrientationNativeType Property

NVehicleDetails.NVehicleOrientationNativeType Property
NVehicleDetails Class Neurotec.Surveillance Namespace

Gets NVehicleOrientation native type.

C#
public static NType NVehicleOrientationNativeType;
Property value

NVehicleOrientation native type.


NVehicleDetails.NativeType Property

NVehicleDetails.NativeType Property
NVehicleDetails Class Neurotec.Surveillance Namespace

Neurotechnology framework type of the object.

C#
public static new NType NativeType;


NVehicleDetails.Orientation Property

NVehicleDetails.Orientation Property
NVehicleDetails Class Neurotec.Surveillance Namespace

Gets vehicle orientation value (Front, Back, Left, FrontLeft, etc.).

C#
public NVehicleOrientation Orientation;
Property value

Vehicle orientation value.


NVehicleDetails.OrientationAngle Property

NVehicleDetails.OrientationAngle Property
NVehicleDetails Class Neurotec.Surveillance Namespace

Gets an angle of vehicle orientation.

C#
public float OrientationAngle;
Property value

Vehicle orientation angle.


NVehicleDetails.OrientationConfidence Property

NVehicleDetails.OrientationConfidence Property
NVehicleDetails Class Neurotec.Surveillance Namespace

Gets confidence value of vehicle's orientation.

C#
public float OrientationConfidence;
Property value

Confidence value of vehicle's orientation.


NVehicleDetails.Tags Property

NVehicleDetails.Tags Property
NVehicleDetails Class Neurotec.Surveillance Namespace

Gets TagCollection object containing vehicle body types.

C#
public TagCollection Tags;
Property value

TagCollection object containing vehicle body types.


NsedMatchResult Class

NsedMatchResult Class
NObject Delegates NObject Events NObject Fields Legend Members NDisposable Methods NDisposable Properties

Represents matching result.

C#
public class NsedMatchResult : NObject;
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NsedMatchResult Class
Name | Description
Id | Gets Id of a matching result.
MatchingDetails | Gets matching detail;s object.
NativeType | Neurotechnology framework type of the object.
Score | Gets matching score.
Container

File: NsedMatchResult.cs

Namespace: Neurotec.Surveillance

Module: .NET Reference


NsedMatchResult.Id Property

NsedMatchResult.Id Property
NsedMatchResult Class Neurotec.Surveillance Namespace

Gets Id of a matching result.

C#
public string Id;
Property value

Id of a matching result.


NsedMatchResult.MatchingDetails Property

NsedMatchResult.MatchingDetails Property
NsedMatchResult Class Neurotec.Surveillance Namespace

Gets matching detail;s object.

C#
public NMatchingDetails MatchingDetails;
Property value

NMatchingDetails object.


NsedMatchResult.NativeType Property

NsedMatchResult.NativeType Property
NsedMatchResult Class Neurotec.Surveillance Namespace

Neurotechnology framework type of the object.

C#
public static new NType NativeType;


NsedMatchResult.Score Property

NsedMatchResult.Score Property
NsedMatchResult Class Neurotec.Surveillance Namespace

Gets matching score.

C#
public int Score;
Property value

Matching score.


Neurotec.Surveillance.NDetectorScaleCount Enumeration

Neurotec.Surveillance.NDetectorScaleCount Enumeration

Enumerates detector scale count. Bigger values improves quality, but requires more processing power.

C#
[Serializable]
public enum NDetectorScaleCount {
}
Container

File: NSurveillance.cs

Namespace: Neurotec.Surveillance

Module: .NET Reference


Neurotec.Surveillance.NGpuIndex Enumeration

Neurotec.Surveillance.NGpuIndex Enumeration

Enumerates GPU units by index.

C#
[Serializable]
[Flags]
public enum NGpuIndex {
  All = -1,
  None = 0,
  Gpu0 = 1,
  Gpu1 = 2,
  Gpu2 = 4,
  Gpu3 = 8,
  Gpu4 = 16,
  Gpu5 = 32,
  Gpu6 = 64,
  Gpu7 = 128
}
Collapse Expand Members
Members | Description
All = -1 | All GPU units.
None = 0 | No GPU index was specified.
Gpu0 = 1 | GPU index 0.
Gpu1 = 2 | GPU index 1.
Gpu2 = 4 | GPU index 2.
Gpu3 = 8 | GPU index 3.
Gpu4 = 16 | GPU index 4.
Gpu5 = 32 | GPU index 5.
Gpu6 = 64 | GPU index 6.
Gpu7 = 128 | GPU index 7.
Container

File: NSurveillance.cs

Namespace: Neurotec.Surveillance

Module: .NET Reference


Neurotec.Surveillance.NSurveillanceEventType Enumeration

Neurotec.Surveillance.NSurveillanceEventType Enumeration

Enumeration type for different Surveillance events. Different information is available inside EventDetails field of NSurveillanceEventArgs. Events are asynchronous, so no assumption on the order of events should be made.

C#
[Serializable]
public enum NSurveillanceEventType {
  Unknown = 0,
  ImageCaptured = 1,
  FacesDetected = 2,
  SubjectAppeared = 3,
  SubjectTrack = 4,
  SubjectDisappeared = 5,
  SubjectMerged = 12,
  SubjectSplit = 13,
  Any = -1
}
Collapse Expand Remarks

The table below explains what data is available during different events:

 | ImageCaptured | FacesDetected | SubjectAppeared | SubjectTrack | SubjectDisappeared
Source | + | + | + | + | +
OriginalImage | + | + | + | + |
FrameIndex | + | + | + | + |
TimeStamp | + | + | + | + | +
GetDetectedFaces() |  | + |  |  |
Status |  | + | + |  |
Template |  |  | + | + |
TraceIndex |  |  | + | + | +
GetBestMatches() |  |  | + | + | +
GetSubjectTemplate() |  |  |  |  | +
Collapse Expand Members
Members | Description
Unknown = 0 | Indicates that Surveillance event type is unknown.
ImageCaptured = 1 | Indicates that a new image was captured from capturing source.
FacesDetected = 2 | Indicates that at least one face was successfully detected in the captured image.
SubjectAppeared = 3 | Indicates that a new subject appeared in the field of view of the capturing device.
SubjectTrack = 4 | Indicates that previously appeared subject is being tracked logging it's activity.
SubjectDisappeared = 5 | Indicates that a previously tracked subject disappeared from the field of view of the capturing device.
SubjectMerged = 12 | Indicates that subject was merged with another subject.
SubjectSplit = 13 | Indicates that subject was split into two.
Any = -1 | Indicates that any event can be captured by supplied callback function.
Container

File: NSurveillance.cs

Namespace: Neurotec.Surveillance

Module: .NET Reference


Neurotec.Surveillance.NSurveillanceModalityType Enumeration

Neurotec.Surveillance.NSurveillanceModalityType Enumeration

Enumerates surveillance modality types.

C#
[Flags]
public enum NSurveillanceModalityType {
  None = 0,
  Faces = 1,
  VehiclesAndHumans = 2,
  LicensePlateRecognition = 4
}
Collapse Expand Members
Members | Description
None = 0 | None of these modalities were selected.
Faces = 1 | Indicates that faces should be processed.
VehiclesAndHumans = 2 | Indicates that vehicles and humans should be processed.
LicensePlateRecognition = 4 | Indicates that license plates should be processed.
Container

File: NSurveillanceSource.cs

Namespace: Neurotec.Surveillance

Module: .NET Reference


Neurotec.Surveillance.NSurveillanceObjectColor Enumeration

Neurotec.Surveillance.NSurveillanceObjectColor Enumeration

Enumerates tracked object color values.

C#
public enum NSurveillanceObjectColor {
  Any = -1,
  Red = 1,
  Orange = 2,
  Yellow = 4,
  Green = 8,
  Blue = 16,
  Silver = 32,
  White = 64,
  Black = 128,
  Brown = 256,
  Gray = 512
}
Collapse Expand Members
Members | Description
Any = -1 | Any color.
Red = 1 | Red color.
Orange = 2 | Orange color.
Yellow = 4 | Yellow color.
Green = 8 | Green color.
Blue = 16 | Blue color.
Silver = 32 | Silver color.
White = 64 | White color.
Black = 128 | Black color.
Brown = 256 | Brown color.
Gray = 512 | Gray color.
Container

File: NSurveillanceEventDetails.cs

Namespace: Neurotec.Surveillance

Module: .NET Reference


Neurotec.Surveillance.NSurveillanceObjectDirection Enumeration

Neurotec.Surveillance.NSurveillanceObjectDirection Enumeration

Represents detected or tracked object direction values.

C#
public enum NSurveillanceObjectDirection {
  Any = -1,
  North = 1,
  NorthEast = 2,
  East = 4,
  SouthEast = 8,
  South = 16,
  SouthWest = 32,
  West = 64,
  NorthWest = 128
}
Collapse Expand Members
Members | Description
Any = -1 | Any direction.
North = 1 | Object was/is moving north.
NorthEast = 2 | Object was/is moving north east.
East = 4 | Object was/is moving east.
SouthEast = 8 | Object was/is moving south east.
South = 16 | Object was/is moving south.
SouthWest = 32 | Object was/is moving south west.
West = 64 | Object was/is moving west.
NorthWest = 128 | Object was/is moving north west.
Container

File: NSurveillanceEventDetails.cs

Namespace: Neurotec.Surveillance

Module: .NET Reference


Neurotec.Surveillance.NSurveillanceObjectType Enumeration

Neurotec.Surveillance.NSurveillanceObjectType Enumeration

Enumerates surveillance objects.

C#
public enum NSurveillanceObjectType {
  Any = -1,
  Car = 1,
  Person = 2,
  Bus = 4,
  Truck = 8,
  Bike = 16
}
Collapse Expand Members
Members | Description
Any = -1 | Any object.
Car = 1 | Object is a car.
Person = 2 | Object is a person.
Bus = 4 | Object is a bus.
Truck = 8 | Object is a truck.
Bike = 16 | Object is a bike.
Container

File: NSurveillanceEventDetails.cs

Namespace: Neurotec.Surveillance

Module: .NET Reference


Neurotec.Surveillance.NSurveillanceSourceType Enumeration

Neurotec.Surveillance.NSurveillanceSourceType Enumeration

Enumerates surveillance source types.

C#
public enum NSurveillanceSourceType {
  Camera = 1,
  Video = 2,
  Unknown = -1
}
Collapse Expand Members
Members | Description
Camera = 1 | Indicates a camera.
Video = 2 | Indicates a video.
Unknown = -1 | Indicates an unknown source type.
Container

File: NSurveillanceSource.cs

Namespace: Neurotec.Surveillance

Module: .NET Reference


Neurotec.Surveillance.NVehicleOrientation Enumeration

Neurotec.Surveillance.NVehicleOrientation Enumeration

Enumerates vehicle orientation values.

C#
public enum NVehicleOrientation {
  Right = 0,
  RearRight = 45,
  Rear = 90,
  RearLeft = 135,
  Left = 180,
  FrontLeft = 225,
  Front = 270,
  FrontRight = 315
}
Collapse Expand Members
Members | Description
Right = 0 | Right side of a vehicle is visible.
RearRight = 45 | Rear right side of a vehicle is visible.
Rear = 90 | Rear side of a vehicle is visible.
RearLeft = 135 | Rear left side of a vehicle is visible.
Left = 180 | Left side of a vehicle is visible.
FrontLeft = 225 | Front left side of a vehicle is visible.
Front = 270 | Front side of a vehicle is visible.
FrontRight = 315 | Front right side of a vehicle is visible.
Container

File: NVehicleDetails.cs

Namespace: Neurotec.Surveillance

Module: .NET Reference


Neurotec.Surveillance.Encoding Namespace

Neurotec.Surveillance.Encoding Namespace
Classes Legend Structs, Records, Enums

Provides functionality for GPU encoding.

Collapse Expand Classes
Name | Description
NGpuJpegEncoder | Provides functionality for converting NImage to Jpeg using GPU.
Collapse Expand Structs, Records, Enums
Name | Description
NScaleMethod | Image rescale algorithm.


NGpuJpegEncoder Class

NGpuJpegEncoder Class
NObject Delegates NObject Events NObject Fields Legend Members NDisposable Methods NDisposable Properties

Provides functionality for converting NImage to Jpeg using GPU.

C#
public class NGpuJpegEncoder : NObject;
Collapse Expand NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
Collapse Expand NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Collapse Expand NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Collapse Expand NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NGpuJpegEncoder Class
Name | Description
Encode | Converts provided NImage object to Jpeg using GPU and returns as NBuffer object.
ScaleAndEncode | Rescales and converts provided NImage object to Jpeg using GPU and returns as NBuffer object.
Collapse Expand NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NGpuJpegEncoder Class
Name | Description
CompressionQuality | Gets or sets Jpeg image compression quality.
GpuIndex | Gets an index of GPU unit which is used to convert NImage to Jpeg.
NativeType | Neurotechnology framework type of the object.
Container

File: NGpuJpegEncoder.cs

Namespace: Neurotec.Surveillance.Encoding

Module: .NET Reference


NGpuJpegEncoder.Encode Method

NGpuJpegEncoder.Encode Method
NGpuJpegEncoder Class Neurotec.Surveillance.Encoding Namespace

Converts provided NImage object to Jpeg using GPU and returns as NBuffer object.

C#
public NBuffer Encode(NImage image);
Collapse Expand Parameters
Parameters | Description
NImage image | NImage object containing image to conver to Jpeg.
Collapse Expand Returns

NBuffer object containing a converted Jpeg image.


NGpuJpegEncoder.ScaleAndEncode Method

NGpuJpegEncoder.ScaleAndEncode Method
NGpuJpegEncoder Class Neurotec.Surveillance.Encoding Namespace

Rescales and converts provided NImage object to Jpeg using GPU and returns as NBuffer object.

C#
public NBuffer ScaleAndEncode(NImage image, uint outputWidth, uint outputHeight, NScaleMethod scaleMethod = NScaleMethod.Lanczos);
Collapse Expand Parameters
Parameters | Description
NImage image | NImage object containing image to conver to to Jpeg.
uint outputWidth | Width of an output Jpeg image.
uint outputHeight | Height of an output Jpeg image.
NScaleMethod scaleMethod = NScaleMethod.Lanczos | Rescale method.
Collapse Expand Returns

NBuffer object containing a converted Jpeg image.


NGpuJpegEncoder.CompressionQuality Property

NGpuJpegEncoder.CompressionQuality Property
NGpuJpegEncoder Class Neurotec.Surveillance.Encoding Namespace

Gets or sets Jpeg image compression quality.

C#
public int CompressionQuality;
Property value

Int value of compression quality. Value is in range [1, 100], default value - 85.


NGpuJpegEncoder.GpuIndex Property

NGpuJpegEncoder.GpuIndex Property
NGpuJpegEncoder Class Neurotec.Surveillance.Encoding Namespace

Gets an index of GPU unit which is used to convert NImage to Jpeg.

C#
public int GpuIndex;
Property value

GPU index value.


NGpuJpegEncoder.NativeType Property

NGpuJpegEncoder.NativeType Property
NGpuJpegEncoder Class Neurotec.Surveillance.Encoding Namespace

Neurotechnology framework type of the object.

C#
public static new NType NativeType;


Neurotec.Surveillance.Encoding.NScaleMethod Enumeration

Neurotec.Surveillance.Encoding.NScaleMethod Enumeration

Image rescale algorithm.

C#
[Serializable]
public enum NScaleMethod {
  NearestNeighbor = 1,
  Linear = 2,
  Cubic = 3,
  CubicSpline = 4,
  CubicCatmullRom = 5,
  CubicB05C03 = 6,
  SuperSampling = 7,
  Lanczos = 8,
  LanczosAdvanced = 9,
  SmoothEdge = 10
}
Collapse Expand Members
Members | Description
NearestNeighbor = 1 | Nearest Neighbor algorithm.
Linear = 2 | Linear algorithm.
Cubic = 3 | Cubic algorithm.
CubicSpline = 4 | Cubic Spline algorithm.
CubicCatmullRom = 5 | Cubic Catmull Rom algorithm.
CubicB05C03 = 6 | Cubic B05C03 algorithm.
SuperSampling = 7 | Super resampling algorithm.
Lanczos = 8 | Lanczos resampling.
LanczosAdvanced = 9 | Lanczos advanced resampling.
SmoothEdge = 10 | Smooth edge algorithm.
Container

File: NGpuJpegEncoder.cs

Namespace: Neurotec.Surveillance.Encoding

Module: .NET Reference


NLicensingServiceGetBinPath Function

NLicensingServiceGetBinPath Function

Gets the binary path (path to pg.exe/pgd) to the license.

C++
NResult N_API NLicensingServiceGetBinPath(HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNString * phValue | [out] Binary path to the license.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicensingService.h

Module: .NET Reference


NLicensingServiceGetConfPath Function

NLicensingServiceGetConfPath Function

Gets path to licensing service configuration file (pgd.conf).

C++
NResult N_API NLicensingServiceGetConfPath(HNString * phValue);
Collapse Expand Parameters
Parameters | Description
HNString * phValue | [out] Path to the licensing service configuration file.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicensingService.h

Module: .NET Reference


NLicensingServiceGetStatus Function

NLicensingServiceGetStatus Function

Gets the status of the licensing service.

C++
NResult N_API NLicensingServiceGetStatus(NLicensingServiceStatus * pValue);
Collapse Expand Parameters
Parameters | Description
NLicensingServiceStatus * pValue | [out] Pointer to NLicensingServiceStatus.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicensingService.h

Module: .NET Reference


NLicensingServiceInstall Function

NLicensingServiceInstall Function

Installs licensing service.

C++
NResult N_API NLicensingServiceInstall(const NChar * szBinPath, const NChar * szConf);
Collapse Expand Parameters
Parameters | Description
const NChar * szBinPath | [in] Path to the licensing service (pg.exe/pgd).
const NChar * szConf | [in] Path to licensing service configuration file (pgd.conf).
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicensingService.h

Module: .NET Reference


NLicensingServiceIsTrial Function

NLicensingServiceIsTrial Function

Checks whether the licensing service is trial.

C++
NResult N_API NLicensingServiceIsTrial(NBool * pValue);
Collapse Expand Parameters
Parameters | Description
NBool * pValue | [out] Pointer to NBool that receives NTrue value if licensing service is trial; otherwise, NFalse.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicensingService.h

Module: .NET Reference


NLicensingServiceStart Function

NLicensingServiceStart Function

Starts licensing service.

C++
NResult N_API NLicensingServiceStart();
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicensingService.h

Module: .NET Reference


NLicensingServiceStop Function

NLicensingServiceStop Function

Stops licensing service.

C++
NResult N_API NLicensingServiceStop();
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicensingService.h

Module: .NET Reference


NLicensingServiceUninstall Function

NLicensingServiceUninstall Function

Uninstalls licensing service.

C++
NResult N_API NLicensingServiceUninstall();
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.

Container

File: NLicensingService.h

Module: .NET Reference


NLicensingServiceStatus Enumeration

NLicensingServiceStatus Enumeration

Enumerates licensing service status values.

C++
typedef enum NLicensingServiceStatus_ {
  nlssNotInstalled = 0,
  nlssStopped = 0x00000001,
  nlssStartPending = 0x00000002,
  nlssStopPending = 0x00000003,
  nlssRunning = 0x00000004,
  nlssContinuePending = 0x00000005,
  nlssPausePending = 0x00000006,
  nlssPaused = 0x00000007
} NLicensingServiceStatus;
Collapse Expand Members
Members | Description
nlssNotInstalled = 0 | Indicates that licensing service is nor installed.
nlssStopped = 0x00000001 | Indicates that licensing service is stopped.
nlssStartPending = 0x00000002 | Indicates that licensing service is pending to be started.
nlssStopPending = 0x00000003 | Indicates that licensing service is pending to be stopped.
nlssRunning = 0x00000004 | Indicates that licensing service is running.
nlssContinuePending = 0x00000005 | Indicates that licensing service was continued after pause.
nlssPausePending = 0x00000006 | Indicates that licensing service is pending to be paused.
nlssPaused = 0x00000007 | Indicates that licensing service is paused.
Container

File: NLicensingService.h

Module: .NET Reference


NLicensingServiceInstall Macro

NLicensingServiceInstall Macro

Picks a Unicode (W) or ANSCII (A) version of the NLicensingServiceInstall function.

C++
#define NLicensingServiceInstall N_FUNC_AW(NLicensingServiceInstall)
Container

File: NLicensingService.h

Module: .NET Reference


C++ Reference

C++ Reference

C++ wrapper is based on RAII (Resource Acquisition Is Initialization) idiom which is commonly used in C++ programs. Also, some of C++11 features, such as lambda functions and move constructors, are enabled if supported by compiler.

Dependency configuration

In order to use the library, the appropriate header files needs to be included. In this example we are going to use NBiometricClient library, so we:

Copy Code
#include <NBiometricClient.hpp>

There is an .hpp header file for every library in SDK. It includes all header files from the library and also all the headers files of dependent libraries.

For executable to link, the dependencies on the following libraries are required (file extensions .dll.lib are show for Windows, for other OS other extensions have to be used):

Copy Code
NBiometricClient.dll.lib NBiometrics.dll.lib NDevices.dll.lib NMedia.dll.lib NCore.dll.lib NLicensing.dll.lib

Note, that all we specify not only the library we want to use (NBiometricClient), but also all of its dependencies.

Namespaces

All objects, structures, enums, etc. provided by SDK are put into namespaces to prevent clashing with your application or other library names. Some of commonly used namespaces are:

Copy Code
using namespace Neurotec;
using namespace Neurotec::Images;
using namespace Neurotec::Biometrics;
using namespace Neurotec::Biometrics::Client;
NObjects

In previous version of C++ wrapper, all objects had to be allocated explicitly using new and delete operators, which was tedious and error prone. In this version we have completely reworked object lifetime management based on RAII idiom (similar to std::vector). In the following code block object is created by constructor and automatically destroyed by destructor when leaving scope:

Copy Code
NBiometricClient biometricClient;

Internally the object only stores a reference-counted handle to a resource, so assigning an object to a class field, returning by value, storing in a container, etc. only increases or decreases reference count. In other words, it behaves similar to std::shared_ptr: object is deleted when last of the references is released. Not only this is convenient to use with standard STL containers and algorithms, but also greatly reduces risk of freeing object too early (causing a crash), or forgetting to free (causing a memory leak).

In the example above, the no argument constructor creates an NBiometricClient handle and stores a reference to it. Instead, every object can be initialized with a NULL handle initially and assigned an actual handle later (this is often useful for constructors):

Copy Code
class MyClass
{
    NBiometricClient mBiometricClient;
    MyClass()
        : mBiometricClient(NULL)
    {
    }
};

When function arguments expect a NObject, NULL can be passed instead where necessary (an object with NULL handle is created implicitly).

NStrings

NString is a representation of a string in Neurotechnology API, which can be converted to and from C style null-terminated strings, or framework specific strings: MFC, wxWidgets, Qt, std::string.

Null-terminated string can be retrieved by using GetBuffer() method. For some methods, including GetBuffer(), there are versions with A and W postfix (they correspond to ANSI and Wide-character UTF-16 Unicode versions, respectively).

Framework-specific strings can be retrieved by casting the NString to a corresponding framework class (for example, wxString in wxWidgets).

Where NStrings need to be passed as function arguments, it is often not needed to pass NString object directly. Instead, null-terminated, framework-specific can be passed directly. A helper object NStringWrapper is created implicitly to support this.

Error handling

In case of runtime error, and NError object is thrown which contains an error message, code and any other details available. It can be caught using C++ try/catch block:

Copy Code
try
{
    NBiometricStatus status = biometricClient.Identify(subject);
    // do something with identification results
}
catch (const NError & error)
{
    // handle error
}

NError is a NObject and has the same features as any other NObject. For example, error can be put to container and later accessed outside the catch block. Please note that NError does not derive from std::exception.

In order to get all the information contained in NError as human readable text, ToString() method can be used. The resulting string also includes inner errors, if any. There are also getters for each piece of information available, such as GetCode(), GetMessage(), etc.

Object properties

Object properties are represented as getter and setter methods. They can be easily used like this:

Copy Code
NInt value = biometricClient.GetMatchingThreshold();
biometricClient.SetMatchingThreshold(48);

In addition to this, there is also a generic property getter and setter mechanism (which can be useful to store properties to a file, etc.):

Copy Code
NInt value = biometricClient.GetProperty<NInt>(N_T("Matching.Threshold"));
biometricClient.SetProperty(N_T("Matching.Threshold"), 48);

Please note, that when using generic property interface, types do not have to match exactly. For example, we could have specified “48” as string and the necessary conversion would be performed automatically.

Events and callbacks

Some objects in Neurotechnology API notify when events happen, such as property of an object has changed, capturing task finished processing, etc. Events can be subscribed and unsubscribed from using Add/Remove{EventName}Callback methods. There are some event handler types supported.

Firstly, a static method can be provided which would be called when some event happens:

Copy Code
static void CompletedHandler(EventArgs & e)
{
    // handle event
}
// ...
void * pParam = NULL; // Any user-defined data
operation.AddCompletedCallback(&CompletedHandler, pParam);

The handler takes a single parameter. In this case it is of type EventArgs, but for other events it may be of derived type. The EventArgs is a base class for all events and allows to access the calling object (via GetObject() method), and user provided parameter (via GetParam() method). User provided parameter is optional and can be passed when subscribing to event. In the example, pParam is NULL, but for some use cases it may need to contain pointer to an object or data. Please note that event handlers are usually called not from GUI thread which might not allow to modify GUI elements directly from the callback.

Secondly, a function objects can be used to handle events:

Copy Code
class MyFunctionObject
{
public:
    void operator()(EventArgs & e)
    {
        // handle event
    }
};
// ...
NCallback callback = operation.AddCompletedCallback(MyFunctionObject());

And finally, in C++11 only, it is possible to add lambda function as event handler:

Copy Code
NCallback callback = operation.AddCompletedCallback([](EventArgs & e) { });

Lambda function offers the most convenient event handling and is recommended if compiler supports C++11 features.

For unsubscribing from events there is a symmetric method starting with Remove instead of Add. When static method is used as callback handler, the same arguments can be passed as when adding callback:

Copy Code
operation.RemoveCompletedCallback(&CompletedHandler, pParam);

For functional object or lambda function it is needed to save a NCallback handle when subscribing to event, which can be later to unsubscribe:

Copy Code
NCallback callback = operation.AddCompletedCallback(MyFunctionObject());
operation.RemoveCompletedCallback(callback);
Asynchronous operations

NBiometricEngine and NBiometricClient parallelize executing tasks internally on multiple worker threads and there is no need to wait for task result synchronously. The application can do other useful tasks, such as updating user interface or scheduling other tasks, instead.

For every operation which supports asynchronous processing, there is a method with Async postfix. It performs the same operation as synchronous one, but returns immediately, without blocking the caller. Instead of result it returns an NAsyncOperation object, which can be used to wait for an actual result:

Copy Code
NAsyncOperation operation = biometricClient.IdentifyAsync(subject);

When the calling thread needs the operation result, it may call the Wait method (possibly with timeout value), to wait for the operation to complete:

Copy Code
operation.Wait();

Alternatively, it is possible to subscribe to Completed event using AddCompletedCallback() method. This way, an event will fire on task completion. Note that the event fires even when callback is added later than task has completed so such case does need special handling.


Support

Support

Neurotechnology provides customer support during the entire period, while the customer develops and uses his own system using our products. If you face problems using our products, have any questions or suggestions, you can reach us by email: support@neurotechnology.com.


NsedGetMaskConfidence@HNSurveillanceEventDetails@NByte *

NsedGetMaskConfidence@HNSurveillanceEventDetails@NByte *

Gets confidence value that person is wearing a mask.

Collapse Expand Parameters
Parameters | Description
hDetails | [in] Handle to NSurveillanceEventDetails.
pValue | [out] Confidence value that person is wearing a mask.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.


NsedGetStatus@HNSurveillanceEventDetails@NBiometricStatus *

NsedGetStatus@HNSurveillanceEventDetails@NBiometricStatus *

Gets the biometric status of the specified surveillance event.

Collapse Expand Parameters
Parameters | Description
hDetails | [in] Handle to NSurveillanceEventDetails.
pValue | [out] Pointer to the biometric status value.
Collapse Expand Returns

NResult which value can be checked using NFailed and NSucceeded macros.


See Also

See Also
See Also

Constraints for SentiVeillance


NBiometric Unit Files

NBiometric Unit Files
Files
Name | Description
NBiometric.h | Header file for the NBiometric module.


NBiometric Unit Functions

NBiometric Unit Functions
Legend
Functions
Name | Description
NBiometricCaptureOptionsIsValid | Checks whether the specified biometric capture options are valid.
NBiometricGetBiometricType | Retrieves the biometric type of the specified NBiometric object.
NBiometricGetCaptureOptions | Retrieves the capture options of the specified NBiometric object.
NBiometricGetError | Retrieves the last exception of the specified NBiometric object.
NBiometricGetFileName | Retrieves the file name of the specified NBiometric object.
NBiometricGetHasMoreSamples | Checks whether the specified NBiometric object has more samples.
NBiometricGetParentObject | Retrieves the parent object of the specified NBiometric object.
NBiometricGetSampleBuffer | ... more
NBiometricGetSessionId | Retrieves the session ID of the specified NBiometric object.
NBiometricGetStatus | Retrieves the biometric status of the specified NBiometric object.
NBiometricSetCaptureOptions | Sets the capture options of the specified NBiometric object.
NBiometricSetFileName | Sets the file name of the specified NBiometric object.
NBiometricSetHasMoreSamples | Sets whether the specified NBiometric object has more samples.
NBiometricSetSampleBuffer | ... more
NBiometricSetSessionId | Sets the session ID of the specified NBiometric object.
NBiometricSetStatus | Sets the biometric status of the specified NBiometric object.


Legend

Legend
Legend
Method
Enumeration


NBiometric Unit Macros

NBiometric Unit Macros
Macros
Name | Description
NBiometricSetFileName | Picks a Unicode (W) or ANSCII (A) version of the NBiometricSetFileName function.


NBiometric Unit Structs, Records, Enums

NBiometric Unit Structs, Records, Enums
Legend
Structs, Records, Enums
Name | Description
NBiometricCaptureOptions_ | Enumerates biometric capture options.
NBiometricCaptureOptions | Enumerates biometric capture options.


NBiometric.h Enumerations

NBiometric.h Enumerations
Legend
Enumerations
Name | Description
NBiometricCaptureOptions_ | Enumerates biometric capture options.
NBiometricCaptureOptions | Enumerates biometric capture options.


NBiometric.h Functions

NBiometric.h Functions
Legend
Functions
Name | Description
NBiometricCaptureOptionsIsValid | Checks whether the specified biometric capture options are valid.
NBiometricGetBiometricType | Retrieves the biometric type of the specified NBiometric object.
NBiometricGetCaptureOptions | Retrieves the capture options of the specified NBiometric object.
NBiometricGetError | Retrieves the last exception of the specified NBiometric object.
NBiometricGetFileName | Retrieves the file name of the specified NBiometric object.
NBiometricGetHasMoreSamples | Checks whether the specified NBiometric object has more samples.
NBiometricGetParentObject | Retrieves the parent object of the specified NBiometric object.
NBiometricGetSampleBuffer | ... more
NBiometricGetSessionId | Retrieves the session ID of the specified NBiometric object.
NBiometricGetStatus | Retrieves the biometric status of the specified NBiometric object.
NBiometricSetCaptureOptions | Sets the capture options of the specified NBiometric object.
NBiometricSetFileName | Sets the file name of the specified NBiometric object.
NBiometricSetHasMoreSamples | Sets whether the specified NBiometric object has more samples.
NBiometricSetSampleBuffer | ... more
NBiometricSetSessionId | Sets the session ID of the specified NBiometric object.
NBiometricSetStatus | Sets the biometric status of the specified NBiometric object.


Legend

Legend
Legend
Enumeration
Method


NBiometric.h Macros

NBiometric.h Macros
Macros
Name | Description
NBiometricSetFileName | Picks a Unicode (W) or ANSCII (A) version of the NBiometricSetFileName function.


NBiometricAttributes Unit Files

NBiometricAttributes Unit Files
Files
Name | Description
NBiometricAttributes.h | Header file for NBiometricAttributes module.


NBiometricAttributes Unit Functions

NBiometricAttributes Unit Functions
Legend
Functions
Name | Description
NBiometricAttributesGetBiometricType | Retrieves the biometric type of the specified biometric attributes.
NBiometricAttributesGetChild | Retrieves a child object of the specified NBiometricAttributes object.
NBiometricAttributesGetChildSubject | Gets child NSubject of the current NBiometricAttributes.
NBiometricAttributesGetDetectionConfidence | Gets detection confidence.
NBiometricAttributesGetQuality | Retrieves the quality value of the specified biometric attributes.
NBiometricAttributesGetStatus | Retrieves the biometric status of the specified biometric attributes.
NBiometricAttributesSetDetectionConfidence | Sets detection confidence.
NBiometricAttributesSetQuality | Sets the quality value of the specified biometric attributes.
NBiometricAttributesSetStatus | Sets the biometric status of the specified biometric attributes.


Legend

Legend
Legend
Method


NBiometricAttributes.h Functions

NBiometricAttributes.h Functions
Legend
Functions
Name | Description
NBiometricAttributesGetBiometricType | Retrieves the biometric type of the specified biometric attributes.
NBiometricAttributesGetChild | Retrieves a child object of the specified NBiometricAttributes object.
NBiometricAttributesGetChildSubject | Gets child NSubject of the current NBiometricAttributes.
NBiometricAttributesGetDetectionConfidence | Gets detection confidence.
NBiometricAttributesGetQuality | Retrieves the quality value of the specified biometric attributes.
NBiometricAttributesGetStatus | Retrieves the biometric status of the specified biometric attributes.
NBiometricAttributesSetDetectionConfidence | Sets detection confidence.
NBiometricAttributesSetQuality | Sets the quality value of the specified biometric attributes.
NBiometricAttributesSetStatus | Sets the biometric status of the specified biometric attributes.


NBiometricTypes Unit Files

NBiometricTypes Unit Files
Files
Name | Description
NBiometricTypes.h | Header file for NBiometricType module.


NBiometricTypes Unit Functions

NBiometricTypes Unit Functions
Legend
Functions
Name | Description
NBiometricAngleFromDegrees | Converts the specified angle from degrees to radians.
NBiometricAngleFromRadians | Converts the specified angle from radians to degrees.
NBiometricAngleToDegrees | Converts the specified angle from radians to degrees.
NBiometricAngleToRadians | Converts the specified angle from degrees to radians.
NBiometricAngleToString | Gets a string representation of the specified angle.
NBiometricNfiq1ToNfiqQuality | Converts specified NFIQ 1.0 (NIST Fingerprint Image Quality) value to NfiqQuality value.
NBiometricNfiqQualityToNfiq1 | Converts specified NfiqQuality value to NFIQ 1.0 (NIST Fingerprint Image Quality) value.
NBiometricQualityBlockIsValid | Checks if specified NBiometricQualityBlock is valid.
NBiometricQualityBlockToString | Gets a string representation of the specified quality block.
NBiometricQualityIsValid | Checks whether the specified quality is valid.
NBiometricQualityToString | Gets a string representation of the specified quality.
NBiometricStatusIsFinal | Checks if the value passed as a parameter is denotes completed biometric operation rather then intermediate status of operation in progress.
NBiometricStatusIsValid | Checks if the value passed as a parameter is defined in NBiometricStatus.
NBiometricSubtypeIsValid | Checks if the value passed as a parameter is a valid NBiometricSubtype value.
NBiometricTypeIsValid | Checks if the value passed as a parameter is a valid NBiometricType value.
NEPositionGetAvailableParts | Determines available iris positions based on specified missing iris positions and base position.
NEPositionIsKnown | Checks whether the specified position is known.
NEPositionIsLeft | Checks whether the specified position is left.
NEPositionIsOneOf | Checks if specified NEPosition value matches one in an array.
NEPositionIsRight | Checks whether the specified position is right.
NEPositionIsRightAndLeft | Checks whether the specified position is both left and right.
NEPositionIsSingleEye | Checks whether the specified position represents a single eye.
NEPositionIsTheEye | Checks whether the specified position represents a separate eye.
NEPositionIsTwoEyes | Checks whether the specified position represents two eyes.
NEPositionIsValid | Checks if the value passed as a parameter is a valid NEPosition value.
NEPositionIsValidTheEye | Checks if the specified value is a valid NEPosition value.
NFCoreToString | Gets a string representation of the core.
NFDeltaToString | Gets a string representation of the delta.
NFDoubleCoreToString | Gets a string representation of the double core.
NFImpressionTypeIsCompatibleWith | Checks if two specified values are compatible.
NFImpressionTypeIsContact | ... more
NFImpressionTypeIsContactless | ... more
NFImpressionTypeIsFinger | Checks whether the specified value is fingerprint.
NFImpressionTypeIsGeneric | Checks whether the specified impression type is generic.
NFImpressionTypeIsLatent | Checks if the specified value is latent fingerprint or palmprint.
NFImpressionTypeIsLiveScan | Checks if the specified value is a live scan.
NFImpressionTypeIsNonOptical | ... more
NFImpressionTypeIsNonliveScan | Checks if the specified value is a non-live scan.
NFImpressionTypeIsOneOf | Checks if specified NFImpressionType value matches one in an array.
NFImpressionTypeIsOptical | ... more
NFImpressionTypeIsPalm | Checks if the specified value is a palmprint.
NFImpressionTypeIsPlain | Checks if the specified value is a plain scan or optical contact/contactless.
NFImpressionTypeIsRolled | Checks if the specified value is one of rolled biometric types.
NFImpressionTypeIsSwipe | ... more
NFImpressionTypeIsValid | Checks if the value passed as a parameter is a valid NFImpressionType value.
NFImpressionTypeIsValidFinger | Checks if the specified value is a valid fingerprint.
NFImpressionTypeIsValidPalm | Checks if the specified value is a valid palmprint.
NFImpressionTypeToFinger | Converts an impression type object into finger impression type object.
NFMinutiaNeighborToString | Gets a string representation of the minutia neighbor.
NFMinutiaToString | Gets a string representation of the minutia.
NFPatternClassIsValid | Checks whether a fingerprint pattern class is valid.
NFPatternClassIsValidForPosition | Checks whether a fingerprint pattern class is valid for the specified position.
NFPositionGetAvailableParts | Determines available finger positions based on specified missing finger positions and base position.
NFPositionIsCompatibleWith | Checks if two specified values are compatible.
NFPositionIsCompatibleWithImpressionType | Checks whether the specified position is compatible with the specified impression type.
NFPositionIsFinger | Checks if the specified value is fingerprint.
NFPositionIsFourFingers | Checks if the specified value is a type of 4 fingerprints data.
NFPositionIsKnown | ... more
NFPositionIsLeft | Checks if the specified position is left fingerprint.
NFPositionIsLeftAndRight | Checks if the specified position is left and right fingerprint.
NFPositionIsOneOf | Checks if specified NFPosition value matches one in an array.
NFPositionIsPalm | Checks if the specified value is a palmprint.
NFPositionIsRight | Checks if the specified position is right fingerprint.
NFPositionIsSingleFinger | Checks if the specified value is a single fingerprint.
NFPositionIsTheFinger | Checks if the specified value is the fingerprint.
NFPositionIsThePalm | Checks whether the specified position represents a separate palm.
NFPositionIsThreeFingers | Checks if the specified value is a type of 3 fingerprints data.
NFPositionIsTwoFingers | Checks if the specified value is a type of 2 fingerprints data.
NFPositionIsValid | Checks if the value passed as a parameter is a valid NFPosition value.
NFPositionIsValidFinger | Checks if the specified value is a valid fingerprint.
NFPositionIsValidPalm | Checks if the specified value is a valid palmprint.
NFPositionIsValidTheFinger | Checks if the specified value is a valid fingerprint.
NLFeaturePointToString | Gets a string representation of the feature point.
NfiqQualityIsValid | Checks whether a fingerprint quality value is valid.


Legend

Legend
Legend
Method
Structure
Enumeration


NBiometricTypes Unit Macros

NBiometricTypes Unit Macros
Macros
Name | Description
NBiometricAngleToString | Picks a Unicode (W) or ANSCII (A) version of the NBiometricAngleToString function.
NBiometricQualityBlockToString | Picks a Unicode (W) or ANSCII (A) version of the NBiometricQualityBlockToString function.
NBiometricQualityToString | Picks a Unicode (W) or ANSCII (A) version of the NBiometricQualityToString function.
NFCoreToString | Picks a Unicode (W) or ANSCII (A) version of the NFCoreToString function.
NFDeltaToString | Picks a Unicode (W) or ANSCII (A) version of the NFDeltaToString function.
NFDoubleCoreToString | Picks a Unicode (W) or ANSCII (A) version of the NFDoubleCoreToString function.
NFMinutiaNeighborToString | Picks a Unicode (W) or ANSCII (A) version of the NFMinutiaNeighborToString function.
NFMinutiaToString | Picks a Unicode (W) or ANSCII (A) version of the NFMinutiaToString function.
NLFeaturePointToString | Picks a Unicode (W) or ANSCII (A) version of the NLFeaturePointToString function.
N_BIOMETRIC_QUALITY_FAILED | Failed or unspecified quality.
N_BIOMETRIC_QUALITY_MAX | Maximal quality.
N_BIOMETRIC_QUALITY_MIN | Minimal quality.
N_BIOMETRIC_QUALITY_UNKNOWN | Unknown quality.
N_PHRASE_ID_UNKNOWN | Unknown phrase ID.


NBiometricTypes Unit Structs, Records, Enums

NBiometricTypes Unit Structs, Records, Enums
Legend
Structs, Records, Enums
Name | Description
NBiometricQualityBlock_ | Enumerates a biometric quality block values.
NBiometricStatus_ | Enumerates biometric status values. These values are returned by NBiometricDevice.
NBiometricSubtype_ | Enumerates values which define the type of biometric data in the record. The values in this enumeration more specifically define the type of biometric data (NBiometricType) in the record.
NBiometricType_ | Enumerates types of biometric technology used in a record.
NEImageType_ | Enumerates iris image types.
NEPosition_ | Enumerates eye position values.
NFImpressionType_ | Specifies the impression type.
NFPosition_ | Specifies the finger position.
NGender_ | Specifies the gender.
NIcaoWarnings_ | Enumerates face Icao check warnings constants.
NLExpression_ | Specifies the facial expression.
NLFeaturePoint_ | ... more
NLProperties_ | Specified the facial properties.
NLivenessAction_ | Enumerates face liveness challenge action constants.
NLivenessMode_ | Enumerates face liveness mode constants.
NfiqQuality_ | Specifies the quality of a fingerprint image.
NBiometricStatus | Enumerates biometric status values. These values are returned by NBiometricDevice.
NBiometricSubtype | Enumerates values which define the type of biometric data in the record. The values in this enumeration more specifically define the type of biometric data (NBiometricType) in the record.
NBiometricType | Enumerates types of biometric technology used in a record.
NEImageType | Enumerates iris image types.
NEPosition | Enumerates eye position values.
NFImpressionType | Specifies the impression type.
NFPosition | Specifies the finger position.
NGender | Specifies the gender.
NIcaoWarnings | Enumerates face Icao check warnings constants.
NLExpression | Specifies the facial expression.
NLProperties | Specified the facial properties.
NLivenessAction | Enumerates face liveness challenge action constants.
NLivenessMode | Enumerates face liveness mode constants.
NfiqQuality | Specifies the quality of a fingerprint image.


NBiometricTypes Unit Types

NBiometricTypes Unit Types
Types
Name | Description
NBiometricQualityBlock | Represents the biometric quality block.
NLFeaturePoint | Represents a facial feature point in a NLRecord.


NBiometricTypes.h Enumerations

NBiometricTypes.h Enumerations
Legend
Enumerations
Name | Description
NBiometricStatus_ | Enumerates biometric status values. These values are returned by NBiometricDevice.
NBiometricSubtype_ | Enumerates values which define the type of biometric data in the record. The values in this enumeration more specifically define the type of biometric data (NBiometricType) in the record.
NBiometricType_ | Enumerates types of biometric technology used in a record.
NEImageType_ | Enumerates iris image types.
NEPosition_ | Enumerates eye position values.
NFImpressionType_ | Specifies the impression type.
NFPosition_ | Specifies the finger position.
NGender_ | Specifies the gender.
NIcaoWarnings_ | Enumerates face Icao check warnings constants.
NLExpression_ | Specifies the facial expression.
NLProperties_ | Specified the facial properties.
NLivenessAction_ | Enumerates face liveness challenge action constants.
NLivenessMode_ | Enumerates face liveness mode constants.
NfiqQuality_ | Specifies the quality of a fingerprint image.
NBiometricStatus | Enumerates biometric status values. These values are returned by NBiometricDevice.
NBiometricSubtype | Enumerates values which define the type of biometric data in the record. The values in this enumeration more specifically define the type of biometric data (NBiometricType) in the record.
NBiometricType | Enumerates types of biometric technology used in a record.
NEImageType | Enumerates iris image types.
NEPosition | Enumerates eye position values.
NFImpressionType | Specifies the impression type.
NFPosition | Specifies the finger position.
NGender | Specifies the gender.
NIcaoWarnings | Enumerates face Icao check warnings constants.
NLExpression | Specifies the facial expression.
NLProperties | Specified the facial properties.
NLivenessAction | Enumerates face liveness challenge action constants.
NLivenessMode | Enumerates face liveness mode constants.
NfiqQuality | Specifies the quality of a fingerprint image.


NBiometricTypes.h Functions

NBiometricTypes.h Functions
Legend
Functions
Name | Description
NBiometricAngleFromDegrees | Converts the specified angle from degrees to radians.
NBiometricAngleFromRadians | Converts the specified angle from radians to degrees.
NBiometricAngleToDegrees | Converts the specified angle from radians to degrees.
NBiometricAngleToRadians | Converts the specified angle from degrees to radians.
NBiometricAngleToString | Gets a string representation of the specified angle.
NBiometricNfiq1ToNfiqQuality | Converts specified NFIQ 1.0 (NIST Fingerprint Image Quality) value to NfiqQuality value.
NBiometricNfiqQualityToNfiq1 | Converts specified NfiqQuality value to NFIQ 1.0 (NIST Fingerprint Image Quality) value.
NBiometricQualityBlockIsValid | Checks if specified NBiometricQualityBlock is valid.
NBiometricQualityBlockToString | Gets a string representation of the specified quality block.
NBiometricQualityIsValid | Checks whether the specified quality is valid.
NBiometricQualityToString | Gets a string representation of the specified quality.
NBiometricStatusIsFinal | Checks if the value passed as a parameter is denotes completed biometric operation rather then intermediate status of operation in progress.
NBiometricStatusIsValid | Checks if the value passed as a parameter is defined in NBiometricStatus.
NBiometricSubtypeIsValid | Checks if the value passed as a parameter is a valid NBiometricSubtype value.
NBiometricTypeIsValid | Checks if the value passed as a parameter is a valid NBiometricType value.
NEPositionGetAvailableParts | Determines available iris positions based on specified missing iris positions and base position.
NEPositionIsKnown | Checks whether the specified position is known.
NEPositionIsLeft | Checks whether the specified position is left.
NEPositionIsOneOf | Checks if specified NEPosition value matches one in an array.
NEPositionIsRight | Checks whether the specified position is right.
NEPositionIsRightAndLeft | Checks whether the specified position is both left and right.
NEPositionIsSingleEye | Checks whether the specified position represents a single eye.
NEPositionIsTheEye | Checks whether the specified position represents a separate eye.
NEPositionIsTwoEyes | Checks whether the specified position represents two eyes.
NEPositionIsValid | Checks if the value passed as a parameter is a valid NEPosition value.
NEPositionIsValidTheEye | Checks if the specified value is a valid NEPosition value.
NFCoreToString | Gets a string representation of the core.
NFDeltaToString | Gets a string representation of the delta.
NFDoubleCoreToString | Gets a string representation of the double core.
NFImpressionTypeIsCompatibleWith | Checks if two specified values are compatible.
NFImpressionTypeIsContact | ... more
NFImpressionTypeIsContactless | ... more
NFImpressionTypeIsFinger | Checks whether the specified value is fingerprint.
NFImpressionTypeIsGeneric | Checks whether the specified impression type is generic.
NFImpressionTypeIsLatent | Checks if the specified value is latent fingerprint or palmprint.
NFImpressionTypeIsLiveScan | Checks if the specified value is a live scan.
NFImpressionTypeIsNonOptical | ... more
NFImpressionTypeIsNonliveScan | Checks if the specified value is a non-live scan.
NFImpressionTypeIsOneOf | Checks if specified NFImpressionType value matches one in an array.
NFImpressionTypeIsOptical | ... more
NFImpressionTypeIsPalm | Checks if the specified value is a palmprint.
NFImpressionTypeIsPlain | Checks if the specified value is a plain scan or optical contact/contactless.
NFImpressionTypeIsRolled | Checks if the specified value is one of rolled biometric types.
NFImpressionTypeIsSwipe | ... more
NFImpressionTypeIsValid | Checks if the value passed as a parameter is a valid NFImpressionType value.
NFImpressionTypeIsValidFinger | Checks if the specified value is a valid fingerprint.
NFImpressionTypeIsValidPalm | Checks if the specified value is a valid palmprint.
NFImpressionTypeToFinger | Converts an impression type object into finger impression type object.
NFMinutiaNeighborToString | Gets a string representation of the minutia neighbor.
NFMinutiaToString | Gets a string representation of the minutia.
NFPatternClassIsValid | Checks whether a fingerprint pattern class is valid.
NFPatternClassIsValidForPosition | Checks whether a fingerprint pattern class is valid for the specified position.
NFPositionGetAvailableParts | Determines available finger positions based on specified missing finger positions and base position.
NFPositionIsCompatibleWith | Checks if two specified values are compatible.
NFPositionIsCompatibleWithImpressionType | Checks whether the specified position is compatible with the specified impression type.
NFPositionIsFinger | Checks if the specified value is fingerprint.
NFPositionIsFourFingers | Checks if the specified value is a type of 4 fingerprints data.
NFPositionIsKnown | ... more
NFPositionIsLeft | Checks if the specified position is left fingerprint.
NFPositionIsLeftAndRight | Checks if the specified position is left and right fingerprint.
NFPositionIsOneOf | Checks if specified NFPosition value matches one in an array.
NFPositionIsPalm | Checks if the specified value is a palmprint.
NFPositionIsRight | Checks if the specified position is right fingerprint.
NFPositionIsSingleFinger | Checks if the specified value is a single fingerprint.
NFPositionIsTheFinger | Checks if the specified value is the fingerprint.
NFPositionIsThePalm | Checks whether the specified position represents a separate palm.
NFPositionIsThreeFingers | Checks if the specified value is a type of 3 fingerprints data.
NFPositionIsTwoFingers | Checks if the specified value is a type of 2 fingerprints data.
NFPositionIsValid | Checks if the value passed as a parameter is a valid NFPosition value.
NFPositionIsValidFinger | Checks if the specified value is a valid fingerprint.
NFPositionIsValidPalm | Checks if the specified value is a valid palmprint.
NFPositionIsValidTheFinger | Checks if the specified value is a valid fingerprint.
NLFeaturePointToString | Gets a string representation of the feature point.
NfiqQualityIsValid | Checks whether a fingerprint quality value is valid.


Legend

Legend
Legend
Structure
Enumeration
Method


NBiometricTypes.h Macros

NBiometricTypes.h Macros
Macros
Name | Description
NBiometricAngleToString | Picks a Unicode (W) or ANSCII (A) version of the NBiometricAngleToString function.
NBiometricQualityBlockToString | Picks a Unicode (W) or ANSCII (A) version of the NBiometricQualityBlockToString function.
NBiometricQualityToString | Picks a Unicode (W) or ANSCII (A) version of the NBiometricQualityToString function.
NFCoreToString | Picks a Unicode (W) or ANSCII (A) version of the NFCoreToString function.
NFDeltaToString | Picks a Unicode (W) or ANSCII (A) version of the NFDeltaToString function.
NFDoubleCoreToString | Picks a Unicode (W) or ANSCII (A) version of the NFDoubleCoreToString function.
NFMinutiaNeighborToString | Picks a Unicode (W) or ANSCII (A) version of the NFMinutiaNeighborToString function.
NFMinutiaToString | Picks a Unicode (W) or ANSCII (A) version of the NFMinutiaToString function.
NLFeaturePointToString | Picks a Unicode (W) or ANSCII (A) version of the NLFeaturePointToString function.
N_BIOMETRIC_QUALITY_FAILED | Failed or unspecified quality.
N_BIOMETRIC_QUALITY_MAX | Maximal quality.
N_BIOMETRIC_QUALITY_MIN | Minimal quality.
N_BIOMETRIC_QUALITY_UNKNOWN | Unknown quality.
N_PHRASE_ID_UNKNOWN | Unknown phrase ID.


NBiometricTypes.h Structures

NBiometricTypes.h Structures
Legend
Structures
Name | Description
NBiometricQualityBlock_ | Enumerates a biometric quality block values.
NLFeaturePoint_ | ... more


NBiometricTypes.h Types

NBiometricTypes.h Types
Types
Name | Description
NBiometricQualityBlock | Represents the biometric quality block.
NLFeaturePoint | Represents a facial feature point in a NLRecord.


NFace Unit Files

NFace Unit Files
Files
Name | Description
NFace.h | Header file for the NFace unit.


NFace Unit Functions

NFace Unit Functions
Legend
Functions
Name | Description
NFaceAddObjectsCollectionChanged | Adds user specified callback for "objects collection changed" event.
NFaceAddObjectsCollectionChangedCallback | Adds user specified callback for "objects collection changed" event.
NFaceCreate | Creates a new NFace object.
NFaceFromImageAndAttributes | Creates a new NFace object from face image and attributes.
NFaceGetImage | Retrieves the face image of the specified NFace object.
NFaceGetObject | Retrieves the specified NLAttributes object for the specified NFace object.
NFaceGetObjectCount | Retrieves the number of NLAttribute objects in the specified NFace object.
NFaceGetObjects | Retrieves all NLAttributes objects from the specified NFace object.
NFaceRemoveObjectsCollectionChanged | Removes user specified callback for "objects collection changed" event.
NFaceRemoveObjectsCollectionChangedCallback | Removes user specified callback for "objects collection changed" event.
NFaceSetImage | Sets the face image for the specified NFace object.


NFace.h Functions

NFace.h Functions
Legend
Functions
Name | Description
NFaceAddObjectsCollectionChanged | Adds user specified callback for "objects collection changed" event.
NFaceAddObjectsCollectionChangedCallback | Adds user specified callback for "objects collection changed" event.
NFaceCreate | Creates a new NFace object.
NFaceFromImageAndAttributes | Creates a new NFace object from face image and attributes.
NFaceGetImage | Retrieves the face image of the specified NFace object.
NFaceGetObject | Retrieves the specified NLAttributes object for the specified NFace object.
NFaceGetObjectCount | Retrieves the number of NLAttribute objects in the specified NFace object.
NFaceGetObjects | Retrieves all NLAttributes objects from the specified NFace object.
NFaceRemoveObjectsCollectionChanged | Removes user specified callback for "objects collection changed" event.
NFaceRemoveObjectsCollectionChangedCallback | Removes user specified callback for "objects collection changed" event.
NFaceSetImage | Sets the face image for the specified NFace object.


NLAttributes Unit Files

NLAttributes Unit Files
Files
Name | Description
NLAttributes.h | ... more


NLAttributes Unit Functions

NLAttributes Unit Functions
Legend
Functions
Name | Description
NLAttributesAddFeaturePoint | Adds a feature point to the specified NLAttributes.
NLAttributesClearFeaturePoints | Removes all feature points from the specified NLAttributes.
NLAttributesCreate | Creates NLAttributes.
NLAttributesGetAdditionalFacesDetected | Gets if any additional faces were detected.
NLAttributesGetAge | Gets age value.
NLAttributesGetBackgroundUniformity | Retrieves the background uniformity value of the specified NLAttributes.
NLAttributesGetBaseFrameIndex | Gets the base frame index of the specified NLAttributes.
NLAttributesGetBeardConfidence | Gets the beard confidence value.
NLAttributesGetBlinkConfidence | Retrieves the blink confidence value of the specified NLAttributes.
NLAttributesGetBoundingRect | ... more
NLAttributesGetContrast | Gets contrast value.
NLAttributesGetDarkGlassesConfidence | Retrieves the dark glasses confidence value of the specified NLAttributes.
NLAttributesGetEmotionAngerConfidence | Retrieves anger confidence value of the specified NLAttributes.
NLAttributesGetEmotionContemptConfidence | Gets emotion contempt confidence value.
NLAttributesGetEmotionDisgustConfidence | Retrieves disgust confidence value of the specified NLAttributes.
NLAttributesGetEmotionFearConfidence | Retrieves fear confidence value of the specified NLAttributes.
NLAttributesGetEmotionHappinessConfidence | Retrieves happiness confidence value of the specified NLAttributes.
NLAttributesGetEmotionNeutralConfidence | Retrieves neutral emotion confidence value of the specified NLAttributes.
NLAttributesGetEmotionSadnessConfidence | Retrieves sadness confidence value of the specified NLAttributes.
NLAttributesGetEmotionSurpriseConfidence | Retrieves surprise confidence value of the specified NLAttributes.
NLAttributesGetEthnicityArabianConfidence | Gets the ethnicity Arabian confidence value.
NLAttributesGetEthnicityAsianConfidence | Gets the ethnicity Asian confidence value.
NLAttributesGetEthnicityBlackConfidence | Gets the ethnicity Black confidence value.
NLAttributesGetEthnicityHispanicConfidence | Gets the ethnicity Hispanic confidence value.
NLAttributesGetEthnicityIndianConfidence | Gets the ethnicity Indian confidence value.
NLAttributesGetEthnicityWhiteConfidence | Gets the ethnicity White confidence value.
NLAttributesGetExpression | Gets the expression value of the specified NLAttributes.
NLAttributesGetExpressionConfidence | Retrieves expression confidence value of the specified NLAttributes.
NLAttributesGetFaceDarknessConfidence | Gets the face darkness confidence value.
NLAttributesGetFaceMaskConfidence | Gets the face mask confidence value.
NLAttributesGetFeaturePoint | Retrieves the feature point specified by index.
NLAttributesGetFeaturePointCapacity | Retrieves the feature point capacity of the specified NLAttributes.
NLAttributesGetFeaturePointCount | Retrieves the number of feature points in the specified NLAttributes.
NLAttributesGetFeaturePoints | Retrieves the feature points of the specified NLAttributes.
NLAttributesGetGender | Retrieves the gender value of the specified NLAttributes.
NLAttributesGetGenderConfidence | Retrieves the gender confidence value of the specified NLAttributes.
NLAttributesGetGlassesConfidence | Retrieves the glasses confidence value of the specified NLAttributes.
NLAttributesGetGlassesReflectionConfidence | Gets the glasses reflection confidence value.
NLAttributesGetGrayscaleDensity | Retrieves the grayscale density value of the specified NLAttributes.
NLAttributesGetHatConfidence | Gets the hat confidence value.
NLAttributesGetHeavyFrameConfidence | Gets the heavy frame eyeglasses confidence value.
NLAttributesGetIcaoWarnings | Gets Icao warnings.
NLAttributesGetLeftEyeCenter | Retrieves the center of the left eye of the specified NLAttributes.
NLAttributesGetLivenessAction | Retrieves a liveness detection action.
NLAttributesGetLivenessScore | Retrieves the liveness score of the face.
NLAttributesGetLivenessTargetPitch | Gets liveness target pitch angle.
NLAttributesGetLivenessTargetYaw | Retrieves liveness detection yaw rotation angle.
NLAttributesGetLookingAwayConfidence | Gets the looking away confidence value.
NLAttributesGetMocTemplate | Gets Match-on-Card face template, if engine was configured to extract it.
NLAttributesGetMouthCenter | Retrieves the center of the mouth of the specified NLAttributes.
NLAttributesGetMouthOpenConfidence | Retrieves the mouth open confidence value of the specified NLAttributes.
NLAttributesGetMustacheConfidence | Gets the mustache confidence value.
NLAttributesGetNoise | Gets image noise value.
NLAttributesGetNoseTip | Retrieves the center of the nose tip of the specified NLAttributes.
NLAttributesGetPitch | ... more
NLAttributesGetPixelationConfidence | Gets the pixelation confidence value.
NLAttributesGetProperties | Retrieves the properties of the specified NLAttributes.
NLAttributesGetRedEyeConfidence | Gets the red eye confidence value.
NLAttributesGetRightEyeCenter | Retrieves the center of the right eye of the specified NLAttributes.
NLAttributesGetRoll | ... more
NLAttributesGetSaturation | Gets the saturation value of the specified NLAttributes.
NLAttributesGetSharpness | Retrieves the sharpness value of the specified NLAttributes.
NLAttributesGetSkinReflectionConfidence | Gets the skin reflection confidence value.
NLAttributesGetTemplate | Retrieves the biometric template of the specified NLAttributes.
NLAttributesGetThumbnail | Gets the thumbnail image of the specified NLAttributes.
NLAttributesGetTokenImageRect | Gets rectangle of token face image.
NLAttributesGetUnnaturalSkinToneConfidence | Gets the unnatural skin tone confidence value.
NLAttributesGetWashedOutConfidence | Gets the washed out confidence value.
NLAttributesGetYaw | ... more
NLAttributesInsertFeaturePoint | Adds a feature point to the specified NLAttributes at the specified index.
NLAttributesRemoveFeaturePointAt | Removes the specified feature point from the specified NLAttributes.
NLAttributesSetAdditionalFacesDetected | Sets if any additional faces were detected.
NLAttributesSetAge | Sets age value.
NLAttributesSetBackgroundUniformity | Sets the background uniformity value for the specified NLAttributes.
NLAttributesSetBaseFrameIndex | Sets the base frame index for the specified NLAttributes.
NLAttributesSetBeardConfidence | Sets the beard confidence value.
NLAttributesSetBlinkConfidence | Sets the blink confidence value for the specified NLAttributes.
NLAttributesSetBoundingRect | Sets the bounding rectangle that completely encloses the face in the image.
NLAttributesSetContrast | Sets contrast value.
NLAttributesSetDarkGlassesConfidence | Sets the dark glasses confidence value for the specified NLAttributes.
NLAttributesSetEmotionAngerConfidence | Sets anger confidence value for the specified NLAttributes.
NLAttributesSetEmotionContemptConfidence | Sets emotion contempt confidence value.
NLAttributesSetEmotionDisgustConfidence | Sets disgust confidence value for the specified NLAttributes.
NLAttributesSetEmotionFearConfidence | Sets fear confidence value for the specified NLAttributes.
NLAttributesSetEmotionHappinessConfidence | Sets happiness confidence value for the specified NLAttributes.
NLAttributesSetEmotionNeutralConfidence | Sets neutral emotion confidence value for the specified NLAttributes.
NLAttributesSetEmotionSadnessConfidence | Sets sadness confidence value for the specified NLAttributes.
NLAttributesSetEmotionSurpriseConfidence | Sets surprise emotion confidence value for the specified NLAttributes.
NLAttributesSetEthnicityArabianConfidence | Sets the ethnicity Arabian confidence value.
NLAttributesSetEthnicityAsianConfidence | Sets the ethnicity Asian confidence value.
NLAttributesSetEthnicityBlackConfidence | Sets the ethnicity Black confidence value.
NLAttributesSetEthnicityHispanicConfidence | Sets the ethnicity Hispanic confidence value.
NLAttributesSetEthnicityIndianConfidence | Sets the ethnicity Indian confidence value.
NLAttributesSetEthnicityWhiteConfidence | Sets the ethnicity White confidence value.
NLAttributesSetExpression | Sets the expression value of the specified NLAttributes.
NLAttributesSetExpressionConfidence | Sets expression confidence value for the specified NLAttributes.
NLAttributesSetFaceDarknessConfidence | Sets the face darkness confidence value.
NLAttributesSetFaceMaskConfidence | Sets the face mask confidence value.
NLAttributesSetFeaturePoint | Sets the value of the specified feature point for the specified NLAttributes.
NLAttributesSetFeaturePointCapacity | Sets feature point capacity for the specified NLAttributes.
NLAttributesSetGender | Sets the gender value for the specified NLAttributes.
NLAttributesSetGenderConfidence | Sets the gender confidence value for the specified NLAttributes.
NLAttributesSetGlassesConfidence | Sets the glasses confidence value for the specified NLAttributes.
NLAttributesSetGlassesReflectionConfidence | Sets the glasses reflection confidence value.
NLAttributesSetGrayscaleDensity | Sets the grayscale density value for the specified NLAttributes.
NLAttributesSetHatConfidence | Sets the hat confidence value for the specified NLAttributes.
NLAttributesSetHeavyFrameConfidence | Sets the heavy frame eyeglasses confidence value.
NLAttributesSetIcaoWarnings | Sets Icao warnings.
NLAttributesSetLeftEyeCenter | Sets the center of the left eye for the specified NLAttributes.
NLAttributesSetLookingAwayConfidence | Sets the looking away confidence value.
NLAttributesSetMouthCenter | Sets the center of the mouth for the specified NLAttributes.
NLAttributesSetMouthOpenConfidence | Sets the confidence value of mouth opened for the specified NLAttributes.
NLAttributesSetMustacheConfidence | Sets the mustache confidence value for the specified NLAttributes.
NLAttributesSetNoise | Sets image noise value.
NLAttributesSetNoseTip | Sets the center of the nose tip for the specified NLAttributes.
NLAttributesSetPitch | Sets the pitch value for the specified NLAttributes.
NLAttributesSetPixelationConfidence | Sets the pixelation confidence value.
NLAttributesSetProperties | Sets the properties of the specified NLAttributes.
NLAttributesSetRedEyeConfidence | Sets the red eye confidence value.
NLAttributesSetRightEyeCenter | Sets the center of the right eye for the specified NLAttributes.
NLAttributesSetRoll | Sets the roll value for the specified NLAttributes.
NLAttributesSetSaturation | Sets the saturation value of the specified NLAttributes.
NLAttributesSetSharpness | Sets the sharpness value of the specified NLAttributes.
NLAttributesSetSkinReflectionConfidence | Sets the skin reflection confidence value.
NLAttributesSetTemplate | Sets the biometric template of the specified NLAttributes.
NLAttributesSetThumbnail | Sets the thumbnail image for the specified NLAttributes.
NLAttributesSetTokenImageRect | Sets rectangle of token face image.
NLAttributesSetUnnaturalSkinToneConfidence | Sets the unnatural skin tone confidence value.
NLAttributesSetWashedOutConfidence | Sets the washed out confidence value.
NLAttributesSetYaw | Sets the yaw value for the specified NLAttributes.


NLAttributes.h Functions

NLAttributes.h Functions
Legend
Functions
Name | Description
NLAttributesAddFeaturePoint | Adds a feature point to the specified NLAttributes.
NLAttributesClearFeaturePoints | Removes all feature points from the specified NLAttributes.
NLAttributesCreate | Creates NLAttributes.
NLAttributesGetAdditionalFacesDetected | Gets if any additional faces were detected.
NLAttributesGetAge | Gets age value.
NLAttributesGetBackgroundUniformity | Retrieves the background uniformity value of the specified NLAttributes.
NLAttributesGetBaseFrameIndex | Gets the base frame index of the specified NLAttributes.
NLAttributesGetBeardConfidence | Gets the beard confidence value.
NLAttributesGetBlinkConfidence | Retrieves the blink confidence value of the specified NLAttributes.
NLAttributesGetBoundingRect | ... more
NLAttributesGetContrast | Gets contrast value.
NLAttributesGetDarkGlassesConfidence | Retrieves the dark glasses confidence value of the specified NLAttributes.
NLAttributesGetEmotionAngerConfidence | Retrieves anger confidence value of the specified NLAttributes.
NLAttributesGetEmotionContemptConfidence | Gets emotion contempt confidence value.
NLAttributesGetEmotionDisgustConfidence | Retrieves disgust confidence value of the specified NLAttributes.
NLAttributesGetEmotionFearConfidence | Retrieves fear confidence value of the specified NLAttributes.
NLAttributesGetEmotionHappinessConfidence | Retrieves happiness confidence value of the specified NLAttributes.
NLAttributesGetEmotionNeutralConfidence | Retrieves neutral emotion confidence value of the specified NLAttributes.
NLAttributesGetEmotionSadnessConfidence | Retrieves sadness confidence value of the specified NLAttributes.
NLAttributesGetEmotionSurpriseConfidence | Retrieves surprise confidence value of the specified NLAttributes.
NLAttributesGetEthnicityArabianConfidence | Gets the ethnicity Arabian confidence value.
NLAttributesGetEthnicityAsianConfidence | Gets the ethnicity Asian confidence value.
NLAttributesGetEthnicityBlackConfidence | Gets the ethnicity Black confidence value.
NLAttributesGetEthnicityHispanicConfidence | Gets the ethnicity Hispanic confidence value.
NLAttributesGetEthnicityIndianConfidence | Gets the ethnicity Indian confidence value.
NLAttributesGetEthnicityWhiteConfidence | Gets the ethnicity White confidence value.
NLAttributesGetExpression | Gets the expression value of the specified NLAttributes.
NLAttributesGetExpressionConfidence | Retrieves expression confidence value of the specified NLAttributes.
NLAttributesGetFaceDarknessConfidence | Gets the face darkness confidence value.
NLAttributesGetFaceMaskConfidence | Gets the face mask confidence value.
NLAttributesGetFeaturePoint | Retrieves the feature point specified by index.
NLAttributesGetFeaturePointCapacity | Retrieves the feature point capacity of the specified NLAttributes.
NLAttributesGetFeaturePointCount | Retrieves the number of feature points in the specified NLAttributes.
NLAttributesGetFeaturePoints | Retrieves the feature points of the specified NLAttributes.
NLAttributesGetGender | Retrieves the gender value of the specified NLAttributes.
NLAttributesGetGenderConfidence | Retrieves the gender confidence value of the specified NLAttributes.
NLAttributesGetGlassesConfidence | Retrieves the glasses confidence value of the specified NLAttributes.
NLAttributesGetGlassesReflectionConfidence | Gets the glasses reflection confidence value.
NLAttributesGetGrayscaleDensity | Retrieves the grayscale density value of the specified NLAttributes.
NLAttributesGetHatConfidence | Gets the hat confidence value.
NLAttributesGetHeavyFrameConfidence | Gets the heavy frame eyeglasses confidence value.
NLAttributesGetIcaoWarnings | Gets Icao warnings.
NLAttributesGetLeftEyeCenter | Retrieves the center of the left eye of the specified NLAttributes.
NLAttributesGetLivenessAction | Retrieves a liveness detection action.
NLAttributesGetLivenessScore | Retrieves the liveness score of the face.
NLAttributesGetLivenessTargetPitch | Gets liveness target pitch angle.
NLAttributesGetLivenessTargetYaw | Retrieves liveness detection yaw rotation angle.
NLAttributesGetLookingAwayConfidence | Gets the looking away confidence value.
NLAttributesGetMocTemplate | Gets Match-on-Card face template, if engine was configured to extract it.
NLAttributesGetMouthCenter | Retrieves the center of the mouth of the specified NLAttributes.
NLAttributesGetMouthOpenConfidence | Retrieves the mouth open confidence value of the specified NLAttributes.
NLAttributesGetMustacheConfidence | Gets the mustache confidence value.
NLAttributesGetNoise | Gets image noise value.
NLAttributesGetNoseTip | Retrieves the center of the nose tip of the specified NLAttributes.
NLAttributesGetPitch | ... more
NLAttributesGetPixelationConfidence | Gets the pixelation confidence value.
NLAttributesGetProperties | Retrieves the properties of the specified NLAttributes.
NLAttributesGetRedEyeConfidence | Gets the red eye confidence value.
NLAttributesGetRightEyeCenter | Retrieves the center of the right eye of the specified NLAttributes.
NLAttributesGetRoll | ... more
NLAttributesGetSaturation | Gets the saturation value of the specified NLAttributes.
NLAttributesGetSharpness | Retrieves the sharpness value of the specified NLAttributes.
NLAttributesGetSkinReflectionConfidence | Gets the skin reflection confidence value.
NLAttributesGetTemplate | Retrieves the biometric template of the specified NLAttributes.
NLAttributesGetThumbnail | Gets the thumbnail image of the specified NLAttributes.
NLAttributesGetTokenImageRect | Gets rectangle of token face image.
NLAttributesGetUnnaturalSkinToneConfidence | Gets the unnatural skin tone confidence value.
NLAttributesGetWashedOutConfidence | Gets the washed out confidence value.
NLAttributesGetYaw | ... more
NLAttributesInsertFeaturePoint | Adds a feature point to the specified NLAttributes at the specified index.
NLAttributesRemoveFeaturePointAt | Removes the specified feature point from the specified NLAttributes.
NLAttributesSetAdditionalFacesDetected | Sets if any additional faces were detected.
NLAttributesSetAge | Sets age value.
NLAttributesSetBackgroundUniformity | Sets the background uniformity value for the specified NLAttributes.
NLAttributesSetBaseFrameIndex | Sets the base frame index for the specified NLAttributes.
NLAttributesSetBeardConfidence | Sets the beard confidence value.
NLAttributesSetBlinkConfidence | Sets the blink confidence value for the specified NLAttributes.
NLAttributesSetBoundingRect | Sets the bounding rectangle that completely encloses the face in the image.
NLAttributesSetContrast | Sets contrast value.
NLAttributesSetDarkGlassesConfidence | Sets the dark glasses confidence value for the specified NLAttributes.
NLAttributesSetEmotionAngerConfidence | Sets anger confidence value for the specified NLAttributes.
NLAttributesSetEmotionContemptConfidence | Sets emotion contempt confidence value.
NLAttributesSetEmotionDisgustConfidence | Sets disgust confidence value for the specified NLAttributes.
NLAttributesSetEmotionFearConfidence | Sets fear confidence value for the specified NLAttributes.
NLAttributesSetEmotionHappinessConfidence | Sets happiness confidence value for the specified NLAttributes.
NLAttributesSetEmotionNeutralConfidence | Sets neutral emotion confidence value for the specified NLAttributes.
NLAttributesSetEmotionSadnessConfidence | Sets sadness confidence value for the specified NLAttributes.
NLAttributesSetEmotionSurpriseConfidence | Sets surprise emotion confidence value for the specified NLAttributes.
NLAttributesSetEthnicityArabianConfidence | Sets the ethnicity Arabian confidence value.
NLAttributesSetEthnicityAsianConfidence | Sets the ethnicity Asian confidence value.
NLAttributesSetEthnicityBlackConfidence | Sets the ethnicity Black confidence value.
NLAttributesSetEthnicityHispanicConfidence | Sets the ethnicity Hispanic confidence value.
NLAttributesSetEthnicityIndianConfidence | Sets the ethnicity Indian confidence value.
NLAttributesSetEthnicityWhiteConfidence | Sets the ethnicity White confidence value.
NLAttributesSetExpression | Sets the expression value of the specified NLAttributes.
NLAttributesSetExpressionConfidence | Sets expression confidence value for the specified NLAttributes.
NLAttributesSetFaceDarknessConfidence | Sets the face darkness confidence value.
NLAttributesSetFaceMaskConfidence | Sets the face mask confidence value.
NLAttributesSetFeaturePoint | Sets the value of the specified feature point for the specified NLAttributes.
NLAttributesSetFeaturePointCapacity | Sets feature point capacity for the specified NLAttributes.
NLAttributesSetGender | Sets the gender value for the specified NLAttributes.
NLAttributesSetGenderConfidence | Sets the gender confidence value for the specified NLAttributes.
NLAttributesSetGlassesConfidence | Sets the glasses confidence value for the specified NLAttributes.
NLAttributesSetGlassesReflectionConfidence | Sets the glasses reflection confidence value.
NLAttributesSetGrayscaleDensity | Sets the grayscale density value for the specified NLAttributes.
NLAttributesSetHatConfidence | Sets the hat confidence value for the specified NLAttributes.
NLAttributesSetHeavyFrameConfidence | Sets the heavy frame eyeglasses confidence value.
NLAttributesSetIcaoWarnings | Sets Icao warnings.
NLAttributesSetLeftEyeCenter | Sets the center of the left eye for the specified NLAttributes.
NLAttributesSetLookingAwayConfidence | Sets the looking away confidence value.
NLAttributesSetMouthCenter | Sets the center of the mouth for the specified NLAttributes.
NLAttributesSetMouthOpenConfidence | Sets the confidence value of mouth opened for the specified NLAttributes.
NLAttributesSetMustacheConfidence | Sets the mustache confidence value for the specified NLAttributes.
NLAttributesSetNoise | Sets image noise value.
NLAttributesSetNoseTip | Sets the center of the nose tip for the specified NLAttributes.
NLAttributesSetPitch | Sets the pitch value for the specified NLAttributes.
NLAttributesSetPixelationConfidence | Sets the pixelation confidence value.
NLAttributesSetProperties | Sets the properties of the specified NLAttributes.
NLAttributesSetRedEyeConfidence | Sets the red eye confidence value.
NLAttributesSetRightEyeCenter | Sets the center of the right eye for the specified NLAttributes.
NLAttributesSetRoll | Sets the roll value for the specified NLAttributes.
NLAttributesSetSaturation | Sets the saturation value of the specified NLAttributes.
NLAttributesSetSharpness | Sets the sharpness value of the specified NLAttributes.
NLAttributesSetSkinReflectionConfidence | Sets the skin reflection confidence value.
NLAttributesSetTemplate | Sets the biometric template of the specified NLAttributes.
NLAttributesSetThumbnail | Sets the thumbnail image for the specified NLAttributes.
NLAttributesSetTokenImageRect | Sets rectangle of token face image.
NLAttributesSetUnnaturalSkinToneConfidence | Sets the unnatural skin tone confidence value.
NLAttributesSetWashedOutConfidence | Sets the washed out confidence value.
NLAttributesSetYaw | Sets the yaw value for the specified NLAttributes.


NLMatchingDetails Unit Files

NLMatchingDetails Unit Files
Files
Name | Description
NLMatchingDetails.h | Header file of NLMatchingDetails.


NLRecord Unit Files

NLRecord Unit Files
Files
Name | Description
NLRecord.h | ... more


NLRecord Unit Functions

NLRecord Unit Functions
Legend
Functions
Name | Description
NLRecordCheck | Checks whether packed NLRecord is valid.
NLRecordCreate | Creates an empty NLRecord.
NLRecordCreateFromMemory | Unpacks NLRecord from the specified memory buffer.
NLRecordGetCbeffProductType | Retrieves the Cbeff product type of the NLRecord.
NLRecordCreateFromNLRecord | Creates NLRecord from other NLRecord object.
NLRecordGetQuality | Retrieves the quality of the NLRecord.
NLRecordGetCbeffProductTypeMem | Retrieves the Cbeff product type of the packed NLRecord.
NLRecordGetQualityMem | Retrieves the quality of the packed NLRecord.
NLRecordSetCbeffProductType | Sets the Cbeff product type.
NLRecordGetSizeMem | Retrieves the image size of the packed NLRecord.
NLRecordSetQuality | Sets the quality of the NLRecord.
HNLRecord | Handle to NERecord object.


NLRecord.h Functions

NLRecord.h Functions
Legend
Functions
Name | Description
NLRecordCheck | Checks whether packed NLRecord is valid.
NLRecordCreate | Creates an empty NLRecord.
NLRecordCreateFromMemory | Unpacks NLRecord from the specified memory buffer.
NLRecordCreateFromNLRecord | Creates NLRecord from other NLRecord object.
NLRecordGetCbeffProductType | Retrieves the Cbeff product type of the NLRecord.
NLRecordGetCbeffProductTypeMem | Retrieves the Cbeff product type of the packed NLRecord.
NLRecordGetQuality | Retrieves the quality of the NLRecord.
NLRecordGetQualityMem | Retrieves the quality of the packed NLRecord.
NLRecordGetSizeMem | Retrieves the image size of the packed NLRecord.
NLRecordSetCbeffProductType | Sets the Cbeff product type.
NLRecordSetQuality | Sets the quality of the NLRecord.


NLTemplate Unit Files

NLTemplate Unit Files
Files
Name | Description
NLTemplate.h | ... more


NLTemplate Unit Functions

NLTemplate Unit Functions
Legend
Functions
Name | Description
NLTemplateAddRecordEx | Adds a face record to the NLTemplate.
NLTemplateCalculateSize | Calculates the size of a packed NLTemplate containing the specified number of face records of specified size.
NLTemplateCheck | Checks if format of the packed NLTemplate is correct.
NLTemplateClearRecords | Removes all face records from the NLTemplate.
NLTemplateCreateFromMemory | Unpacks a NLTemplate from the specified memory buffer.
NLTemplateCreateEx | Creates an empty NLTemplate.
NLTemplateGetRecordCountMem | Retrieves the number of face records in the packed NLTemplate.
NLTemplateGetRecordCapacity | Retrieves the number of face records that the NLTemplate can contain..
NLTemplateGetRecordEx | Retrieves the face record at the specified index of the NLTemplate.
NLTemplateGetRecordCount | Retrieves the number of face records in the NLTemplate.
NLTemplateGetSizeMem | Retrieves the image size of the packed NLTemplate.
NLTemplateInsertRecord | Inserts the specified NLRecord to the specified NLTemplate at the specified index.
NLTemplatePack | Packs packed face records as NLTemplate into the specified memory buffer.
NLTemplateRemoveRecordAt | Removed record at specified index.
NLTemplateSetRecord | Sets the value of the specified NLRecord to the specified value.
NLTemplateUnpack | Unpacks packed face records from the packed NLTemplate.
NLTemplateSetRecordCapacity | Sets the number of face records that the NLTemplate can contain.
HNLTemplate | Handle to the NLTemplate object.


NLTemplate Unit Macros

NLTemplate Unit Macros
Macros
Name | Description
NLT_MAX_RECORD_COUNT | The maximum number of face records NLTemplate can contain.
NLT_PROCESS_FIRST_RECORD_ONLY | ... more


NLTemplate.h Functions

NLTemplate.h Functions
Legend
Functions
Name | Description
NLTemplateAddRecordEx | Adds a face record to the NLTemplate.
NLTemplateCalculateSize | Calculates the size of a packed NLTemplate containing the specified number of face records of specified size.
NLTemplateCheck | Checks if format of the packed NLTemplate is correct.
NLTemplateClearRecords | Removes all face records from the NLTemplate.
NLTemplateCreateEx | Creates an empty NLTemplate.
NLTemplateCreateFromMemory | Unpacks a NLTemplate from the specified memory buffer.
NLTemplateGetRecordCapacity | Retrieves the number of face records that the NLTemplate can contain..
NLTemplateGetRecordCount | Retrieves the number of face records in the NLTemplate.
NLTemplateGetRecordCountMem | Retrieves the number of face records in the packed NLTemplate.
NLTemplateGetRecordEx | Retrieves the face record at the specified index of the NLTemplate.
NLTemplateGetSizeMem | Retrieves the image size of the packed NLTemplate.
NLTemplateInsertRecord | Inserts the specified NLRecord to the specified NLTemplate at the specified index.
NLTemplatePack | Packs packed face records as NLTemplate into the specified memory buffer.
NLTemplateRemoveRecordAt | Removed record at specified index.
NLTemplateSetRecord | Sets the value of the specified NLRecord to the specified value.
NLTemplateSetRecordCapacity | Sets the number of face records that the NLTemplate can contain.
NLTemplateUnpack | Unpacks packed face records from the packed NLTemplate.


NLTemplate.h Macros

NLTemplate.h Macros
Macros
Name | Description
NLT_MAX_RECORD_COUNT | The maximum number of face records NLTemplate can contain.
NLT_PROCESS_FIRST_RECORD_ONLY | ... more


NMatchingDetails Unit Files

NMatchingDetails Unit Files
Files
Name | Description
NMatchingDetails.h | ... more


NMatchingDetails Unit Functions

NMatchingDetails Unit Functions
Legend
Functions
Name | Description
NMatchingDetailsCreateFromMemory | Creates NMatchingDetails from specified memory buffer.
NMatchingDetailsCreateFromMemoryN | Creates NMatchingDetails from specified memory buffer.
NMatchingDetailsCreateFromStream | Creates NMatchingDetails from specified stream.
NMatchingDetailsGetFaceCount | Gets face templates count in NMatchingDetails.
NMatchingDetailsGetFaceEx | Gets face matching details (NLMatchingDetails) from specified NMatchingDetails.
NMatchingDetailsGetFacesMatchedIndex | Gets index of matched face in the second matched NLTemplate (or NTemplate))
NMatchingDetailsGetFacesScore | Gets similarity score of two matched face templates (NLTemplate).
NMatchingDetailsGetFingerCount | Gets fingerprint templates count in NMatchingDetails.
NMatchingDetailsGetFingerEx | Gets fingerprint matching details (NFMatchingDetails) from specified NMatchingDetails.
NMatchingDetailsGetFingersScore | Gets similarity score of two matched fingerprint templates (NFTemplate).
NMatchingDetailsGetIrisCount | Gets iris templates count in NMatchingDetails.
NMatchingDetailsGetIrisEx | Gets iris matching details (NEMatchingDetails) from specified NMatchingDetails.
NMatchingDetailsGetIrisesScore | Gets similarity score of two matched iris templates (NETemplate).
NMatchingDetailsGetPalmCount | Gets palmprint templates count in NMatchingDetails.
NMatchingDetailsGetPalmEx | Gets palmprint matching details (NFMatchingDetails) from specified NMatchingDetails.
NMatchingDetailsGetPalmsScore | Gets similarity score of two matched palmprint templates (NFTemplate).
NMatchingDetailsGetVoiceCount | Gets voice templates count in NMatchingDetails.
NMatchingDetailsGetVoiceEx | Gets voice matching details (NSMatchingDetails) from specified NMatchingDetails.
NMatchingDetailsGetVoicesScore | Gets similarity score of two matched voice templates (NSTemplate).


See Also

See Also
See Also

NMatchingDetailsCreateFromMemory


See Also

See Also
See Also

NMatchingDetailsGetFacesScore


Example

Example

Function for printing matching details (face index and score):

Copy Code
//Prints faces similarity score and index from specified handle
static NResult PrintMatchingDetails(HNMatchingDetails hMatchingDetails)
{
  NResult nr;
  NBiometricType biometricType;
  NInt i, count, index, score;

  //Retrieves biometric type of specified NMatchingDetails (which template type matching details are saved)
  nr = NMatchingDetailsBaseGetBiometricType(hMatchingDetails, &biometricType);
  //If NMatchingDetails type detection failed an error code is returned. This value is less than 0.
  //To find more about error codes, read NResult Type
  if (NFailed(nr)) return nr;
  //Checks if NMatchingDetails saves data about faces matching
  if ((biometricType & nbtFace) == nbtFace)
  {
    //Trying to retrieve face templates similarity score
    nr = NMatchingDetailsGetFacesScore(hMatchingDetails, &score);
    //If failed to retrieve similarity score, an error code is returned
    if (NFailed(nr)) return nr;
    //Prints on a screen similarity score
    printf(N_T("    Faces match details:"));
    printf(N_T(" score = %d\n"), score);

    //Retrieving face count in specified NMatchingDetails
    nr = NMatchingDetailsGetFaceCount(hMatchingDetails, &count);
    if (NFailed(nr)) return nr;
    //Trying to get index of second matched face template
    for (i = 0; i < count; i++)
    {
      HNLMatchingDetails hFaceMatchingDetails;
      //Gets face matching details (NLMatchingDetails)
Copy Code
      nr = NMatchingDetailsGetFace(hMatchingDetails, i, &hFaceMatchingDetails);
      if (NFailed(nr)) return nr;
      //Using face matching details gets index
      nr = NXMatchingDetailsGetMatchedIndex(hFaceMatchingDetails, &index);
      if (NFailed(nr)) return nr;
      //Gets faces similarity score by calling base function for retrieving similarity score
      //Note: If handle to NMatchingDetails is specified, similarity score for all modalities is returned
      nr = NMatchingDetailsBaseGetScore(hFaceMatchingDetails, &score);
      if (NFailed(nr)) return nr;
      printf(N_T("    face index: %d; score: %d;\n"), index, score);
Copy Code
    }
  }

  return nr;
}

Note: This function should be called after templates identification (NMIdentifyNextEx and NMIdentifyNextEx) or verification (NMVerifyEx).


See Also

See Also
See Also

NMatchingDetailsGetFingerScore


Example

Example

Function for printing matching details (fingerprint index and score):

Copy Code
//Prints fingerprints similarity score and index from specified handle
static NResult PrintMatchingDetails(HNMatchingDetails hMatchingDetails)
{
  NResult nr;
  NBiometricType biometricType;
  NInt i, count, index, score;

  //Retrieves biometric type of specified NMatchingDetails (which template type matching details are saved)
  nr = NMatchingDetailsBaseGetBiometricType(hMatchingDetails, &biometricType);
  //If NMatchingDetails type detection failed an error code is returned. This value is less than 0.
  //To find more about error codes, read NResult Type
  if (NFailed(nr)) return nr;
  //Checks if NMatchingDetails saves data about fingerprints matching
  if ((biometricType & nbtFinger) == nbtFinger)
  {
    //Trying to retrieve fingerprint templates similarity score
    nr = NMatchingDetailsGetFingersScore(hMatchingDetails, &score);
    //If failed to retrieve similarity score, an error code is returned
    if (NFailed(nr)) return nr;
    //Prints on a screen similarity score
    printf(N_T("    Fingerprint match details:"));
    printf(N_T(" score = %d\n"), score);

    //Retrieving fingerprint count in specified NMatchingDetails
    nr = NMatchingDetailsGetFingerCount(hMatchingDetails, &count);
    if (NFailed(nr)) return nr;
    //Trying to get index of second matched fingerprint template
    for (i = 0; i < count; i++)
    {
      HNFMatchingDetails hFingerMatchingDetails;
      //Gets face matching details (NLMatchingDetails)
      nr = NMatchingDetailsGetFinger(hMatchingDetails, i, &hFingerMatchingDetails);
      if (NFailed(nr)) return nr;
      //Using fingerprint matching details gets index
      nr = NXMatchingDetailsGetMatchedIndex(hFingerMatchingDetails, &index);
      if (NFailed(nr)) return nr;
      //Gets fingerprints similarity score by calling base function for retrieving similarity score
      //Note: If handle to NMatchingDetails is specified, similarity score for all modalities is returned
      nr = NMatchingDetailsBaseGetScore(hFingerMatchingDetails, &score);
      if (NFailed(nr)) return nr;
      printf(N_T("    fingerprint index: %d; score: %d;\n"), index, score);
    }
  }

  return nr;
}

Note: This function should be called after templates identification (NMIdentifyNextEx and NMIdentifyNextEx) or verification (NMVerifyEx).


See Also

See Also
See Also

NMatchingDetailsGetIrisesScore


Example

Example

Function for printing matching details (iris index and score):

Copy Code
//Prints irises similarity score and index from specified handle
static NResult PrintMatchingDetails(HNMatchingDetails hMatchingDetails)
{
  NResult nr;
  NBiometricType biometricType;
  NInt i, count, index, score;

  //Retrieves biometric type of specified NMatchingDetails (which template type matching details are saved)
  nr = NMatchingDetailsBaseGetBiometricType(hMatchingDetails, &biometricType);
  //If NMatchingDetails type detection failed an error code is returned. This value is less than 0.
  //To find more about error codes, read NResult Type
  if (NFailed(nr)) return nr;
  //Checks if NMatchingDetails saves data about irises matching
  if ((biometricType & nbtIris) == nbtIris)
  {
    //Trying to retrieve iris templates similarity score
    nr = NMatchingDetailsGetIrisesScore(hMatchingDetails, &score);
    //If failed to retrieve similarity score, an error code is returned
    if (NFailed(nr)) return nr;
    //Prints on a screen similarity score
    printf(N_T("    Irises match details:"));
    printf(N_T(" score = %d\n"), score);

    //Retrieving irises count in specified NMatchingDetails
    nr = NMatchingDetailsGetIrisCount(hMatchingDetails, &count);
    if (NFailed(nr)) return nr;
    //Trying to get index of second matched iris template
    for (i = 0; i < count; i++)
     {
      HNEMatchingDetails hIrisMatchingDetails;
      //Gets iris matching details (NEMatchingDetails)
      nr = NMatchingDetailsGetIris(hMatchingDetails, i, &hIrisMatchingDetails);
      if (NFailed(nr)) return nr;
      //Using iris matching details gets index
      nr = NXMatchingDetailsGetMatchedIndex(hIrisMatchingDetails, &index);
      if (NFailed(nr)) return nr;
      //Gets irises similarity score by calling base function for retrieving similarity score
      //Note: If handle to NMatchingDetails is specified, similarity score for all modalities is returned
      nr = NMatchingDetailsBaseGetScore(hIrisMatchingDetails, &score);
      if (NFailed(nr)) return nr;
      printf(N_T("    iris index: %d; score: %d;\n"), index, score);
    }
  }

  return nr;
}

Note: This function should be called after templates identification (NMIdentifyNextEx and NMIdentifyNextEx) or verification (NMVerifyEx).


See Also

See Also
See Also

NMatchingDetailsGetPalmsScore


Example

Example

Function for printing matching details (palmprint index and score):

Copy Code
//Prints palmprints similarity score and index from specified handle
static NResult PrintMatchingDetails(HNMatchingDetails hMatchingDetails)
{
  NResult nr;
  NBiometricType biometricType;
  NInt i, count, index, score;

  //Retrieves biometric type of specified NMatchingDetails (which template type matching details are saved)
  nr = NMatchingDetailsBaseGetBiometricType(hMatchingDetails, &biometricType);
  //If NMatchingDetails type detection failed an error code is returned. This value is less than 0.
  //To find more about error codes, read NResult Type
  if (NFailed(nr)) return nr;
  //Checks if NMatchingDetails saves data about palmprints matching
  if ((biometricType & nbtPalm) == nbtPalm)
  {
    //Trying to retrieve palmprint templates similarity score
    nr = NMatchingDetailsGetPalmsScore(hMatchingDetails, &score);
    //If failed to retrieve similarity score, an error code is returned
    if (NFailed(nr)) return nr;
    //Prints on a screen similarity score
    printf(N_T("    Palms match details:"));
    printf(N_T(" score = %d\n"), score);

    //Retrieving palmprints count in specified NMatchingDetails
    nr = NMatchingDetailsGetPalmCount(hMatchingDetails, &count);
    if (NFailed(nr)) return nr;
    //Trying to get index of second matched palmprint template
    for (i = 0; i < count; i++)
     {
      HNFMatchingDetails hPalmMatchingDetails;
      //Gets palmprint matching details (NFMatchingDetails)
      nr = NMatchingDetailsGetPalm(hMatchingDetails, i, &hPalmMatchingDetails);
      if (NFailed(nr)) return nr;
      //Using palmprint matching details gets index
      nr = NXMatchingDetailsGetMatchedIndex(hPalmMatchingDetails, &index);
      if (NFailed(nr)) return nr;
      //Gets palmprints similarity score by calling base function for retrieving similarity score
      //Note: If handle to NMatchingDetails is specified, similarity score for all modalities is returned
      nr = NMatchingDetailsBaseGetScore(hPalmMatchingDetails, &score);
      if (NFailed(nr)) return nr;
      printf(N_T("    palm index: %d; score: %d;\n"), index, score);
    }
  }

  return nr;
}

Note: This function should be called after templates identification (NMIdentifyNextEx and NMIdentifyNextEx) or verification (NMVerifyEx).


See Also

See Also
See Also

NMatchingDetailsGetVoicesScore


Example

Example

Function for printing matching details (voice index and score):

Copy Code
//Prints voices similarity score and index from specified handle
static NResult PrintMatchingDetails(HNMatchingDetails hMatchingDetails)
{
  NResult nr;
  NBiometricType biometricType;
  NInt i, count, index, score;

  //Retrieves biometric type of specified NMatchingDetails (which template type matching details are saved)
  nr = NMatchingDetailsBaseGetBiometricType(hMatchingDetails, &biometricType);
  //If NMatchingDetails type detection failed an error code is returned. This value is less than 0.
  //To find more about error codes, read NResult Type
  if (NFailed(nr)) return nr;
  //Checks if NMatchingDetails saves data about voices matching
  if ((biometricType & nbtVoice) == nbtVoice)
  {
    //Trying to retrieve voice templates similarity score
    nr = NMatchingDetailsGetVoicesScore(hMatchingDetails, &score);
    //If failed to retrieve similarity score, an error code is returned
    if (NFailed(nr)) return nr;
    //Prints on a screen similarity score
    printf(N_T("    Voices match details:"));
    printf(N_T(" score = %d\n"), score);

    //Retrieving voices count in specified NMatchingDetails
    nr = NMatchingDetailsGetVoiceCount(hMatchingDetails, &count);
    if (NFailed(nr)) return nr;
    //Trying to get index of second matched voice template
    for (i = 0; i < count; i++)
     {
      HNSMatchingDetails hVoiceMatchingDetails;
      //Gets voice matching details (NSMatchingDetails)
      nr = NMatchingDetailsGetVoice(hMatchingDetails, i, &hVoiceMatchingDetails);
      if (NFailed(nr)) return nr;
      //Using voice matching details gets index
      nr = NXMatchingDetailsGetMatchedIndex(hVoiceMatchingDetails, &index);
      if (NFailed(nr)) return nr;
      //Gets voices similarity score by calling base function for retrieving similarity score
      //Note: If handle to NMatchingDetails is specified, similarity score for all modalities is returned
      nr = NMatchingDetailsBaseGetScore(hVoiceMatchingDetails, &score);
      if (NFailed(nr)) return nr;
      printf(N_T("    voice index: %d; score: %d;\n"), index, score);
    }
  }

  return nr;
}

Note: This function should be called after templates identification (NMIdentifyNextEx and NMIdentifyNextEx) or verification (NMVerifyEx).


NMatchingDetails.h Functions

NMatchingDetails.h Functions
Legend
Functions
Name | Description
NMatchingDetailsCreateFromMemory | Creates NMatchingDetails from specified memory buffer.
NMatchingDetailsCreateFromMemoryN | Creates NMatchingDetails from specified memory buffer.
NMatchingDetailsCreateFromStream | Creates NMatchingDetails from specified stream.
NMatchingDetailsGetFaceCount | Gets face templates count in NMatchingDetails.
NMatchingDetailsGetFaceEx | Gets face matching details (NLMatchingDetails) from specified NMatchingDetails.
NMatchingDetailsGetFacesMatchedIndex | Gets index of matched face in the second matched NLTemplate (or NTemplate))
NMatchingDetailsGetFacesScore | Gets similarity score of two matched face templates (NLTemplate).
NMatchingDetailsGetFingerCount | Gets fingerprint templates count in NMatchingDetails.
NMatchingDetailsGetFingerEx | Gets fingerprint matching details (NFMatchingDetails) from specified NMatchingDetails.
NMatchingDetailsGetFingersScore | Gets similarity score of two matched fingerprint templates (NFTemplate).
NMatchingDetailsGetIrisCount | Gets iris templates count in NMatchingDetails.
NMatchingDetailsGetIrisEx | Gets iris matching details (NEMatchingDetails) from specified NMatchingDetails.
NMatchingDetailsGetIrisesScore | Gets similarity score of two matched iris templates (NETemplate).
NMatchingDetailsGetPalmCount | Gets palmprint templates count in NMatchingDetails.
NMatchingDetailsGetPalmEx | Gets palmprint matching details (NFMatchingDetails) from specified NMatchingDetails.
NMatchingDetailsGetPalmsScore | Gets similarity score of two matched palmprint templates (NFTemplate).
NMatchingDetailsGetVoiceCount | Gets voice templates count in NMatchingDetails.
NMatchingDetailsGetVoiceEx | Gets voice matching details (NSMatchingDetails) from specified NMatchingDetails.
NMatchingDetailsGetVoicesScore | Gets similarity score of two matched voice templates (NSTemplate).


NMatchingDetailsBase Unit Files

NMatchingDetailsBase Unit Files
Files
Name | Description
NMatchingDetailsBase.h | Header file for NMatchingDetailsBase.


NMatchingDetailsBase Unit Functions

NMatchingDetailsBase Unit Functions
Legend
Functions
Name | Description
NMatchingDetailsBaseGetBiometricType | Gets type of biometric modality saved in specified matching details.
NMatchingDetailsBaseGetScore | Gets similarity score of two matched templates.


See Also

See Also
See Also

NMatchingDetailsGetFacesScore

NMatchingDetailsGetFingersScore

NMatchingDetailsGetIrisesScore

NMatchingDetailsGetPalmsScore

NMatchingDetailsGetVoicesScore


NMatchingDetailsBase.h Functions

NMatchingDetailsBase.h Functions
Legend
Functions
Name | Description
NMatchingDetailsBaseGetBiometricType | Gets type of biometric modality saved in specified matching details.
NMatchingDetailsBaseGetScore | Gets similarity score of two matched templates.


NMatchingResult Unit Files

NMatchingResult Unit Files
Files
Name | Description
NMatchingResult.h | Header file for the NMatchingResult unit.


NMatchingResult Unit Functions

NMatchingResult Unit Functions
Legend
Functions
Name | Description
NMatchingResultGetConnection | Retrieves the biometric connection of the specified matching result.
NMatchingResultGetId | Retrieves the ID of the specified matching result.
NMatchingResultGetMatchingDetails | Retrieves the matching details of the specified matching result.
NMatchingResultGetMatchingDetailsBuffer | Retrieves the matching details buffer of the specified matching result.
NMatchingResultGetScore | Retrieves the matching score of the specified matching result.
NMatchingResultGetSubject | Retrieves the subject of the specified matching result.


NMatchingResult.h Functions

NMatchingResult.h Functions
Legend
Functions
Name | Description
NMatchingResultGetConnection | Retrieves the biometric connection of the specified matching result.
NMatchingResultGetId | Retrieves the ID of the specified matching result.
NMatchingResultGetMatchingDetails | Retrieves the matching details of the specified matching result.
NMatchingResultGetMatchingDetailsBuffer | Retrieves the matching details buffer of the specified matching result.
NMatchingResultGetScore | Retrieves the matching score of the specified matching result.
NMatchingResultGetSubject | Retrieves the subject of the specified matching result.


NSubject Unit Files

NSubject Unit Files
Files
Name | Description
NSubject.h | Header file for the NSubject unit.


NSubject Unit Functions

NSubject Unit Functions
Legend
Functions
Name | Description
NSubjectAddFace | Adds a NFace object to the specified NSubject.
NSubjectAddFacesCollectionChanged | Adds a FacesCollectionChanged event to the specified NSubject.
NSubjectAddFacesCollectionChangedCallback | Adds a FacesCollectionChanged event callback to the specified NSubject.
NSubjectAddFinger | Adds a NFinger object to the specified NSubject.
NSubjectAddFingersCollectionChanged | Adds a FingersCollectionChanged event to the specified NSubject.
NSubjectAddFingersCollectionChangedCallback | Adds a FingersCollectionChanged event callback to the specified NSubject.
NSubjectAddIris | Adds a NIris object to the specified NSubject.
NSubjectAddIrisesCollectionChanged | Adds a IrisesCollectionChanged event to the specified NSubject.
NSubjectAddIrisesCollectionChangedCallback | Adds a IrisesCollectionChanged event callback to the specified NSubject.
NSubjectAddMissingEye | Adds a NEPosition object representing a missing eye to the specified NSubject.
NSubjectAddMissingFinger | Adds a NFPosition object representing a missing finger(s) to the specified NSubject.
NSubjectAddPalm | Adds a NPalm object to the specified NSubject.
NSubjectAddPalmsCollectionChanged | Adds a PalmsCollectionChanged event to the specified NSubject.
NSubjectAddPalmsCollectionChangedCallback | Adds a PalmsCollectionChanged event callback to the specified NSubject.
NSubjectAddRelatedSubject | Adds a related NSubject object to the specified NSubject.
NSubjectAddRelatedSubjectsCollectionChanged | Adds a RelatedSubjectsCollectionChanged event to the specified NSubject.
NSubjectAddRelatedSubjectsCollectionChangedCallback | Adds a RelatedSubjectsCollectionChanged event callback to the specified NSubject.
NSubjectAddSignature | Adds a signature of the specified subject.
NSubjectAddSignaturesCollectionChanged | Adds the SignaturesCollectionChanged event to the specified NSubject.
NSubjectAddSignaturesCollectionChangedCallback | Adds the SignaturesCollectionChanged user's specified callback to the NSubject.
NSubjectAddVoice | Adds a NVoice object to the specified NSubject.
NSubjectAddVoicesCollectionChanged | Adds a VoicesCollectionChanged event to the specified NSubject.
NSubjectAddVoicesCollectionChangedCallback | Adds a VoicesCollectionChanged event callback to the specified NSubject.
NSubjectClear | Clears the specified NSubject of all data.
NSubjectClearFaces | Clears all NFace objects from the specified NSubject.
NSubjectClearFingers | Clears all NFinger objects from the specified NSubject.
NSubjectClearIrises | Clears all NIris objects from the specified NSubject.
NSubjectClearMissingEyes | Clears all NEPosition objects representing missing eyes from the specified NSubject.
NSubjectClearMissingFingers | Clears all NFPosition objects representing missing fingers from the specified NSubject.
NSubjectClearPalms | Clears all NPalm objects from the specified NSubject.
NSubjectClearRelatedSubjects | Clears all related NSubject objects from the specified NSubject.
NSubjectClearSignatures | Clears all signatures from the specified NSubject.
NSubjectClearVoices | Clears all NVoice objects from the specified NSubject.
NSubjectCreate | Creates a new NSubject object.
NSubjectCreateFromFile | Creates a new NSubject object from the specified file.
NSubjectCreateFromFileWithFormat | Creates a new NSubject object from the specified file with specified format.
NSubjectCreateFromMemory | Creates a new NSubject object from the specified buffer.
NSubjectCreateFromMemoryWithFormat | Creates a new NSubject object from the specified buffer with the specified format.
NSubjectCreateFromStream | Creates a new NSubject object from the specified memory stream.
NSubjectCreateFromStreamWithFormat | Creates a new NSubject object from the specified memory stream with the specified format.
NSubjectGetError | Retrieves the last exception of the specified NSubject.
NSubjectGetFace | Retrieves the specified NFace object from the specified NSubject.
NSubjectGetFaceCapacity | Retrieves the maximum number of NFace objects in the specified NSubject.
NSubjectGetFaceCount | Retrieves the number of NFace objects in the specified NSubject.
NSubjectGetFaces | Retrieves all NFace objects from the specified NSubject.
NSubjectGetFinger | Retrieves the specified NFinger object from the specified NSubject.
NSubjectGetFingerCapacity | Retrieves the maximum number of NFinger objects in the specified NSubject.
NSubjectGetFingerCount | Retrieves the number of NFinger objects in the specified NSubject.
NSubjectGetFingers | Retrieves all NFinger objects from the specified NSubject.
NSubjectGetGender | Gets the gender value of the specified NSubject.
NSubjectGetId | Retrieves the specified NSubject's ID.
NSubjectGetIris | Retrieves the specified NIris object from the specified NSubject.
NSubjectGetIrisCapacity | Retrieves the maximum number of NIris objects in the specified NSubject.
NSubjectGetIrisCount | Retrieves the number of NIris objects in the specified NSubject.
NSubjectGetIrises | Retrieves all NIris objects from the specified NSubject.
NSubjectGetMatchingResult | Retrieves the specified matching result from the specified NSubject.
NSubjectGetMatchingResultCount | Retrieves the number of matching results in the specified NSubject.
NSubjectGetMatchingResults | Retrieves all matching results from the specified NSubject.
NSubjectGetMissingEye | Retrieves the specified NEPosition object representing a missing eye from the specified NSubject.
NSubjectGetMissingEyeCapacity | Retrieves the maximum number of NEPosition objects in the specified NSubject.
NSubjectGetMissingEyeCount | Retrieves the number of NEPosition objects in the specified NSubject.
NSubjectGetMissingEyes | Retrieves all NEPosition objects representing missing eyes from the specified NSubject.
NSubjectGetMissingFinger | Retrieves the specified NFPosition object representing a missing finger from the specified NSubject.
NSubjectGetMissingFingerCapacity | Retrieves the maximum number of NFPosition objects in the specified NSubject.
NSubjectGetMissingFingerCount | Retrieves the number of NFPosition objects in the specified NSubject.
NSubjectGetMissingFingers | Retrieves all NFPosition objects representing missing fingers from the specified NSubject.
NSubjectGetPalm | Retrieves the specified NPalm object from the specified NSubject.
NSubjectGetPalmCapacity | Retrieves the maximum number of NPalm objects in the specified NSubject.
NSubjectGetPalmCount | Retrieves the number of NPalm objects in the specified NSubject.
NSubjectGetPalms | Retrieves all NPalm objects from the specified NSubject.
NSubjectGetQueryString | Gets the specified NSubject's query string. Query string is a string which can be invoked to retrieve a corresponding NSubject.
NSubjectGetRelatedSubject | Retrieves the specified related NSubject from the specified NSubject.
NSubjectGetRelatedSubjectCapacity | Retrieves the maximum number of related NSubjects in the specified NSubject.
NSubjectGetRelatedSubjectCount | Retrieves the number of related NSubjects in the specified NSubject.
NSubjectGetRelatedSubjects | Retrieves all related NSubjects from the specified NSubject.
NSubjectGetSignature | Gets signature by index from the specified NSubject object.
NSubjectGetSignatureCapacity | Gets the signatures capacity within the specified NSubject object.
NSubjectGetSignatureCount | Gets signatures count within the specified NSubject object.
NSubjectGetSignatures | Gets all signatures from the specified NSubject.
NSubjectGetStatistics | Retrieves the statistics (diagnostic information) of the specified NSubject.
NSubjectGetStatus | Retrieves the biometric status of the specified NSubject. Possible biometric status values can be found here.
NSubjectGetTemplate | Gets the template used by the specified NSubject.
NSubjectGetTemplateBuffer | Gets the buffer which contains templates for the specified NSubject.
NSubjectGetTemplateBufferWithFormatEx | Gets the buffer which contains templates with specified format for the specified NSubject.
NSubjectGetVoice | Retrieves the specified NVoice object from the specified NSubject.
NSubjectGetVoiceCapacity | Retrieves the maximum number of NVoice objects in the specified NSubject.
NSubjectGetVoiceCount | Retrieves the number of NVoice objects in the specified NSubject.
NSubjectGetVoices | Retrieves all NVoice objects from the specified NSubject.
NSubjectInsertFace | Adds a NFace object to the specified NSubject at the specified index.
NSubjectInsertFinger | Adds a NFinger object to the specified NSubject at the specified index.
NSubjectInsertIris | Adds a NIris object to the specified NSubject at the specified index.
NSubjectInsertMissingEye | Adds a NEPosition object representing a missing eye to the specified NSubject at the specified index.
NSubjectInsertMissingFinger | Adds a NFPosition object representing a missing eye to the specified NSubject at the specified index.
NSubjectInsertPalm | Adds a NPalm object to the specified NSubject at the specified index.
NSubjectInsertRelatedSubject | Adds a related NSubject to the specified NSubject at the specified index.
NSubjectInsertSignature | Inserts the NSignature object to the specified NSubject at the specified index.
NSubjectInsertVoice | Adds a NVoice object to the specified NSubject at the specified index.
NSubjectIsMultipleSubjects | Checks whether the specified NSubject consists of multiple NSubjects.
NSubjectRemoveFaceAt | Removes the specified NFace object from the specified NSubject.
NSubjectRemoveFacesCollectionChanged | Removes a FacesCollectionChanged event from the specified NSubject.
NSubjectRemoveFacesCollectionChangedCallback | Removes a FacesCollectionChanged event callback from the specified NSubject.
NSubjectRemoveFingerAt | Removes the specified NFinger object from the specified NSubject.
NSubjectRemoveFingersCollectionChanged | Removes a FingersCollectionChanged event from the specified NSubject.
NSubjectRemoveFingersCollectionChangedCallback | Removes a FingersCollectionChanged event callback from the specified NSubject.
NSubjectRemoveIrisAt | Removes the specified NIris object from the specified NSubject.
NSubjectRemoveIrisesCollectionChanged | Removes a IrisesCollectionChanged event from the specified NSubject.
NSubjectRemoveIrisesCollectionChangedCallback | Removes a IrisesCollectionChanged event callback from the specified NSubject.
NSubjectRemoveMissingEyeAt | Removes the specified NEPosition object representing a missing eye from the specified NSubject.
NSubjectRemoveMissingFingerAt | Removes the specified NFPosition object representing a missing finger from the specified NSubject.
NSubjectRemovePalmAt | Removes the specified NPalm object from the specified NSubject.
NSubjectRemovePalmsCollectionChanged | Removes a PalmsCollectionChanged event from the specified NSubject.
NSubjectRemovePalmsCollectionChangedCallback | Removes a PalmsCollectionChanged event callback from the specified NSubject.
NSubjectRemoveRelatedSubjectAt | Removes the specified related NSubject from the specified NSubject.
NSubjectRemoveRelatedSubjectsCollectionChanged | Removes a RelatedSubjectsCollectionChanged event from the specified NSubject.
NSubjectRemoveRelatedSubjectsCollectionChangedCallback | Removes a RelatedSubjectsCollectionChanged event callback from the specified NSubject.
NSubjectRemoveSignatureAt | Removes the signature specified by an index.
NSubjectRemoveSignaturesCollectionChanged | Removes the SignaturesCollectionChanged event from the specified NSubject.
NSubjectRemoveSignaturesCollectionChangedCallback | Removes the SignaturesCollectionChanged user's specified callback from the NSubject.
NSubjectRemoveVoiceAt | Removes the specified NVoice object from the specified NSubject.
NSubjectRemoveVoicesCollectionChanged | Removes a VoicesCollectionChanged event from the specified NSubject.
NSubjectRemoveVoicesCollectionChangedCallback | Removes a VoicesCollectionChanged event callback from the specified NSubject.
NSubjectSetFace | Sets the value of the specified NFace object in the specified NSubject.
NSubjectSetFaceCapacity | Sets the maximum number of NFace objects for the specified NSubject.
NSubjectSetFinger | Sets the value of the specified NFinger object in the specified NSubject.
NSubjectSetFingerCapacity | Sets the maximum number of NFinger objects for the specified NSubject.
NSubjectSetGender | Sets the gender value of the specified NSubject.
NSubjectSetId | Sets the specified NSubject's ID.
NSubjectSetIris | Sets the value of the specified NIris object in the specified NSubject.
NSubjectSetIrisCapacity | Sets the maximum number of NIris objects for the specified NSubject.
NSubjectSetMissingEye | Sets the value of the specified NEPosition object representing a missing eye in the specified NSubject.
NSubjectSetMissingEyeCapacity | Sets the maximum number of NEPosition objects for the specified NSubject.
NSubjectSetMissingFinger | Sets the value of the specified NFPosition object representing a missing finger in the specified NSubject.
NSubjectSetMissingFingerCapacity | Sets the maximum number of NFPosition objects for the specified NSubject.
NSubjectSetMultipleSubjects | Sets whether the specified NSubject consists of multiple NSubjects.
NSubjectSetPalm | Sets the value of the specified NPalm object in the specified NSubject.
NSubjectSetPalmCapacity | Sets the maximum number of NPalm objects for the specified NSubject.
NSubjectSetQueryString | Sets the specified NSubject's query string.
NSubjectSetRelatedSubject | Sets the value of the specified related NSubject in the specified NSubject.
NSubjectSetRelatedSubjectCapacity | Sets the maximum number of related NSubjects for the specified NSubject.
NSubjectSetSignature | Sets signature value (by index) for the NSubject object.
NSubjectSetSignatureCapacity | Sets the signatures capacity for the specified NSubject object.
NSubjectSetTemplate | Sets the template to be used by the specified NSubject.
NSubjectSetTemplateAN | Sets the ANTemplate to be used by the specified NSubject.
NSubjectSetTemplateBuffer | Sets the buffer to contain templates for the specified NSubject.
NSubjectSetTemplateBufferWithFormat | Sets the buffer to contain templates with specified format for the specified NSubject.
NSubjectSetTemplateCbeff | Sets the CbeffRecord to be used by the specified NSubject.
NSubjectSetTemplateFC | Sets the FCRecord to be used by the specified NSubject.
NSubjectSetTemplateFI | Sets the FIRecord to be used by the specified NSubject.
NSubjectSetTemplateFM | Sets the FMRecord to be used by the specified NSubject.
NSubjectSetTemplateFMC | Sets the FMCRecord to be used by the specified NSubject.
NSubjectSetTemplateII | Sets the IIRecord to be used by the specified NSubject.
NSubjectSetVoice | Sets the value of the specified NVoice object in the specified NSubject.
NSubjectSetVoiceCapacity | Sets the maximum number of NVoice objects for the specified NSubject.
NSubjectToANTemplate | Converts the biometric subject into a ANTemplate.
NSubjectToFCRecord | Converts the biometric subject into a FCRecord.
NSubjectToFIRecord | Converts the biometric subject into a FIRecord.
NSubjectToFMCRecord | Converts the biometric subject into a FMCRecord.
NSubjectToFMRecord | Converts the biometric subject into a FMRecord.
NSubjectToFMRecordEx | Converts the biometric subject into a FMRecord.
NSubjectToIIRecord | Converts the biometric subject into a IIRecord.


NSubject Unit Macros

NSubject Unit Macros
Macros
Name | Description
NSubjectCreateFromFile | Picks a Unicode (W) or ANSCII (A) version of the NSubjectCreateFromFile function.
NSubjectCreateFromFileWithFormat | Picks a Unicode (W) or ANSCII (A) version of the NSubjectCreateFromFileWithFormat function.
NSubjectSetId | Picks a Unicode (W) or ANSCII (A) version of the NSubjectSetId function.
NSubjectSetQueryString | Picks a Unicode (W) or ANSCII (A) version of the NSubjectSetQueryString function.


NSubject.h Functions

NSubject.h Functions
Legend
Functions
Name | Description
NSubjectAddFace | Adds a NFace object to the specified NSubject.
NSubjectAddFacesCollectionChanged | Adds a FacesCollectionChanged event to the specified NSubject.
NSubjectAddFacesCollectionChangedCallback | Adds a FacesCollectionChanged event callback to the specified NSubject.
NSubjectAddFinger | Adds a NFinger object to the specified NSubject.
NSubjectAddFingersCollectionChanged | Adds a FingersCollectionChanged event to the specified NSubject.
NSubjectAddFingersCollectionChangedCallback | Adds a FingersCollectionChanged event callback to the specified NSubject.
NSubjectAddIris | Adds a NIris object to the specified NSubject.
NSubjectAddIrisesCollectionChanged | Adds a IrisesCollectionChanged event to the specified NSubject.
NSubjectAddIrisesCollectionChangedCallback | Adds a IrisesCollectionChanged event callback to the specified NSubject.
NSubjectAddMissingEye | Adds a NEPosition object representing a missing eye to the specified NSubject.
NSubjectAddMissingFinger | Adds a NFPosition object representing a missing finger(s) to the specified NSubject.
NSubjectAddPalm | Adds a NPalm object to the specified NSubject.
NSubjectAddPalmsCollectionChanged | Adds a PalmsCollectionChanged event to the specified NSubject.
NSubjectAddPalmsCollectionChangedCallback | Adds a PalmsCollectionChanged event callback to the specified NSubject.
NSubjectAddRelatedSubject | Adds a related NSubject object to the specified NSubject.
NSubjectAddRelatedSubjectsCollectionChanged | Adds a RelatedSubjectsCollectionChanged event to the specified NSubject.
NSubjectAddRelatedSubjectsCollectionChangedCallback | Adds a RelatedSubjectsCollectionChanged event callback to the specified NSubject.
NSubjectAddSignature | Adds a signature of the specified subject.
NSubjectAddSignaturesCollectionChanged | Adds the SignaturesCollectionChanged event to the specified NSubject.
NSubjectAddSignaturesCollectionChangedCallback | Adds the SignaturesCollectionChanged user's specified callback to the NSubject.
NSubjectAddVoice | Adds a NVoice object to the specified NSubject.
NSubjectAddVoicesCollectionChanged | Adds a VoicesCollectionChanged event to the specified NSubject.
NSubjectAddVoicesCollectionChangedCallback | Adds a VoicesCollectionChanged event callback to the specified NSubject.
NSubjectClear | Clears the specified NSubject of all data.
NSubjectClearFaces | Clears all NFace objects from the specified NSubject.
NSubjectClearFingers | Clears all NFinger objects from the specified NSubject.
NSubjectClearIrises | Clears all NIris objects from the specified NSubject.
NSubjectClearMissingEyes | Clears all NEPosition objects representing missing eyes from the specified NSubject.
NSubjectClearMissingFingers | Clears all NFPosition objects representing missing fingers from the specified NSubject.
NSubjectClearPalms | Clears all NPalm objects from the specified NSubject.
NSubjectClearRelatedSubjects | Clears all related NSubject objects from the specified NSubject.
NSubjectClearSignatures | Clears all signatures from the specified NSubject.
NSubjectClearVoices | Clears all NVoice objects from the specified NSubject.
NSubjectCreate | Creates a new NSubject object.
NSubjectCreateFromFile | Creates a new NSubject object from the specified file.
NSubjectCreateFromFileWithFormat | Creates a new NSubject object from the specified file with specified format.
NSubjectCreateFromMemory | Creates a new NSubject object from the specified buffer.
NSubjectCreateFromMemoryWithFormat | Creates a new NSubject object from the specified buffer with the specified format.
NSubjectCreateFromStream | Creates a new NSubject object from the specified memory stream.
NSubjectCreateFromStreamWithFormat | Creates a new NSubject object from the specified memory stream with the specified format.
NSubjectGetError | Retrieves the last exception of the specified NSubject.
NSubjectGetFace | Retrieves the specified NFace object from the specified NSubject.
NSubjectGetFaceCapacity | Retrieves the maximum number of NFace objects in the specified NSubject.
NSubjectGetFaceCount | Retrieves the number of NFace objects in the specified NSubject.
NSubjectGetFaces | Retrieves all NFace objects from the specified NSubject.
NSubjectGetFinger | Retrieves the specified NFinger object from the specified NSubject.
NSubjectGetFingerCapacity | Retrieves the maximum number of NFinger objects in the specified NSubject.
NSubjectGetFingerCount | Retrieves the number of NFinger objects in the specified NSubject.
NSubjectGetFingers | Retrieves all NFinger objects from the specified NSubject.
NSubjectGetGender | Gets the gender value of the specified NSubject.
NSubjectGetId | Retrieves the specified NSubject's ID.
NSubjectGetIris | Retrieves the specified NIris object from the specified NSubject.
NSubjectGetIrisCapacity | Retrieves the maximum number of NIris objects in the specified NSubject.
NSubjectGetIrisCount | Retrieves the number of NIris objects in the specified NSubject.
NSubjectGetIrises | Retrieves all NIris objects from the specified NSubject.
NSubjectGetMatchingResult | Retrieves the specified matching result from the specified NSubject.
NSubjectGetMatchingResultCount | Retrieves the number of matching results in the specified NSubject.
NSubjectGetMatchingResults | Retrieves all matching results from the specified NSubject.
NSubjectGetMissingEye | Retrieves the specified NEPosition object representing a missing eye from the specified NSubject.
NSubjectGetMissingEyeCapacity | Retrieves the maximum number of NEPosition objects in the specified NSubject.
NSubjectGetMissingEyeCount | Retrieves the number of NEPosition objects in the specified NSubject.
NSubjectGetMissingEyes | Retrieves all NEPosition objects representing missing eyes from the specified NSubject.
NSubjectGetMissingFinger | Retrieves the specified NFPosition object representing a missing finger from the specified NSubject.
NSubjectGetMissingFingerCapacity | Retrieves the maximum number of NFPosition objects in the specified NSubject.
NSubjectGetMissingFingerCount | Retrieves the number of NFPosition objects in the specified NSubject.
NSubjectGetMissingFingers | Retrieves all NFPosition objects representing missing fingers from the specified NSubject.
NSubjectGetPalm | Retrieves the specified NPalm object from the specified NSubject.
NSubjectGetPalmCapacity | Retrieves the maximum number of NPalm objects in the specified NSubject.
NSubjectGetPalmCount | Retrieves the number of NPalm objects in the specified NSubject.
NSubjectGetPalms | Retrieves all NPalm objects from the specified NSubject.
NSubjectGetQueryString | Gets the specified NSubject's query string. Query string is a string which can be invoked to retrieve a corresponding NSubject.
NSubjectGetRelatedSubject | Retrieves the specified related NSubject from the specified NSubject.
NSubjectGetRelatedSubjectCapacity | Retrieves the maximum number of related NSubjects in the specified NSubject.
NSubjectGetRelatedSubjectCount | Retrieves the number of related NSubjects in the specified NSubject.
NSubjectGetRelatedSubjects | Retrieves all related NSubjects from the specified NSubject.
NSubjectGetSignature | Gets signature by index from the specified NSubject object.
NSubjectGetSignatureCapacity | Gets the signatures capacity within the specified NSubject object.
NSubjectGetSignatureCount | Gets signatures count within the specified NSubject object.
NSubjectGetSignatures | Gets all signatures from the specified NSubject.
NSubjectGetStatistics | Retrieves the statistics (diagnostic information) of the specified NSubject.
NSubjectGetStatus | Retrieves the biometric status of the specified NSubject. Possible biometric status values can be found here.
NSubjectGetTemplate | Gets the template used by the specified NSubject.
NSubjectGetTemplateBuffer | Gets the buffer which contains templates for the specified NSubject.
NSubjectGetTemplateBufferWithFormatEx | Gets the buffer which contains templates with specified format for the specified NSubject.
NSubjectGetVoice | Retrieves the specified NVoice object from the specified NSubject.
NSubjectGetVoiceCapacity | Retrieves the maximum number of NVoice objects in the specified NSubject.
NSubjectGetVoiceCount | Retrieves the number of NVoice objects in the specified NSubject.
NSubjectGetVoices | Retrieves all NVoice objects from the specified NSubject.
NSubjectInsertFace | Adds a NFace object to the specified NSubject at the specified index.
NSubjectInsertFinger | Adds a NFinger object to the specified NSubject at the specified index.
NSubjectInsertIris | Adds a NIris object to the specified NSubject at the specified index.
NSubjectInsertMissingEye | Adds a NEPosition object representing a missing eye to the specified NSubject at the specified index.
NSubjectInsertMissingFinger | Adds a NFPosition object representing a missing eye to the specified NSubject at the specified index.
NSubjectInsertPalm | Adds a NPalm object to the specified NSubject at the specified index.
NSubjectInsertRelatedSubject | Adds a related NSubject to the specified NSubject at the specified index.
NSubjectInsertSignature | Inserts the NSignature object to the specified NSubject at the specified index.
NSubjectInsertVoice | Adds a NVoice object to the specified NSubject at the specified index.
NSubjectIsMultipleSubjects | Checks whether the specified NSubject consists of multiple NSubjects.
NSubjectRemoveFaceAt | Removes the specified NFace object from the specified NSubject.
NSubjectRemoveFacesCollectionChanged | Removes a FacesCollectionChanged event from the specified NSubject.
NSubjectRemoveFacesCollectionChangedCallback | Removes a FacesCollectionChanged event callback from the specified NSubject.
NSubjectRemoveFingerAt | Removes the specified NFinger object from the specified NSubject.
NSubjectRemoveFingersCollectionChanged | Removes a FingersCollectionChanged event from the specified NSubject.
NSubjectRemoveFingersCollectionChangedCallback | Removes a FingersCollectionChanged event callback from the specified NSubject.
NSubjectRemoveIrisAt | Removes the specified NIris object from the specified NSubject.
NSubjectRemoveIrisesCollectionChanged | Removes a IrisesCollectionChanged event from the specified NSubject.
NSubjectRemoveIrisesCollectionChangedCallback | Removes a IrisesCollectionChanged event callback from the specified NSubject.
NSubjectRemoveMissingEyeAt | Removes the specified NEPosition object representing a missing eye from the specified NSubject.
NSubjectRemoveMissingFingerAt | Removes the specified NFPosition object representing a missing finger from the specified NSubject.
NSubjectRemovePalmAt | Removes the specified NPalm object from the specified NSubject.
NSubjectRemovePalmsCollectionChanged | Removes a PalmsCollectionChanged event from the specified NSubject.
NSubjectRemovePalmsCollectionChangedCallback | Removes a PalmsCollectionChanged event callback from the specified NSubject.
NSubjectRemoveRelatedSubjectAt | Removes the specified related NSubject from the specified NSubject.
NSubjectRemoveRelatedSubjectsCollectionChanged | Removes a RelatedSubjectsCollectionChanged event from the specified NSubject.
NSubjectRemoveRelatedSubjectsCollectionChangedCallback | Removes a RelatedSubjectsCollectionChanged event callback from the specified NSubject.
NSubjectRemoveSignatureAt | Removes the signature specified by an index.
NSubjectRemoveSignaturesCollectionChanged | Removes the SignaturesCollectionChanged event from the specified NSubject.
NSubjectRemoveSignaturesCollectionChangedCallback | Removes the SignaturesCollectionChanged user's specified callback from the NSubject.
NSubjectRemoveVoiceAt | Removes the specified NVoice object from the specified NSubject.
NSubjectRemoveVoicesCollectionChanged | Removes a VoicesCollectionChanged event from the specified NSubject.
NSubjectRemoveVoicesCollectionChangedCallback | Removes a VoicesCollectionChanged event callback from the specified NSubject.
NSubjectSetFace | Sets the value of the specified NFace object in the specified NSubject.
NSubjectSetFaceCapacity | Sets the maximum number of NFace objects for the specified NSubject.
NSubjectSetFinger | Sets the value of the specified NFinger object in the specified NSubject.
NSubjectSetFingerCapacity | Sets the maximum number of NFinger objects for the specified NSubject.
NSubjectSetGender | Sets the gender value of the specified NSubject.
NSubjectSetId | Sets the specified NSubject's ID.
NSubjectSetIris | Sets the value of the specified NIris object in the specified NSubject.
NSubjectSetIrisCapacity | Sets the maximum number of NIris objects for the specified NSubject.
NSubjectSetMissingEye | Sets the value of the specified NEPosition object representing a missing eye in the specified NSubject.
NSubjectSetMissingEyeCapacity | Sets the maximum number of NEPosition objects for the specified NSubject.
NSubjectSetMissingFinger | Sets the value of the specified NFPosition object representing a missing finger in the specified NSubject.
NSubjectSetMissingFingerCapacity | Sets the maximum number of NFPosition objects for the specified NSubject.
NSubjectSetMultipleSubjects | Sets whether the specified NSubject consists of multiple NSubjects.
NSubjectSetPalm | Sets the value of the specified NPalm object in the specified NSubject.
NSubjectSetPalmCapacity | Sets the maximum number of NPalm objects for the specified NSubject.
NSubjectSetQueryString | Sets the specified NSubject's query string.
NSubjectSetRelatedSubject | Sets the value of the specified related NSubject in the specified NSubject.
NSubjectSetRelatedSubjectCapacity | Sets the maximum number of related NSubjects for the specified NSubject.
NSubjectSetSignature | Sets signature value (by index) for the NSubject object.
NSubjectSetSignatureCapacity | Sets the signatures capacity for the specified NSubject object.
NSubjectSetTemplate | Sets the template to be used by the specified NSubject.
NSubjectSetTemplateAN | Sets the ANTemplate to be used by the specified NSubject.
NSubjectSetTemplateBuffer | Sets the buffer to contain templates for the specified NSubject.
NSubjectSetTemplateBufferWithFormat | Sets the buffer to contain templates with specified format for the specified NSubject.
NSubjectSetTemplateCbeff | Sets the CbeffRecord to be used by the specified NSubject.
NSubjectSetTemplateFC | Sets the FCRecord to be used by the specified NSubject.
NSubjectSetTemplateFI | Sets the FIRecord to be used by the specified NSubject.
NSubjectSetTemplateFM | Sets the FMRecord to be used by the specified NSubject.
NSubjectSetTemplateFMC | Sets the FMCRecord to be used by the specified NSubject.
NSubjectSetTemplateII | Sets the IIRecord to be used by the specified NSubject.
NSubjectSetVoice | Sets the value of the specified NVoice object in the specified NSubject.
NSubjectSetVoiceCapacity | Sets the maximum number of NVoice objects for the specified NSubject.
NSubjectToANTemplate | Converts the biometric subject into a ANTemplate.
NSubjectToFCRecord | Converts the biometric subject into a FCRecord.
NSubjectToFIRecord | Converts the biometric subject into a FIRecord.
NSubjectToFMCRecord | Converts the biometric subject into a FMCRecord.
NSubjectToFMRecord | Converts the biometric subject into a FMRecord.
NSubjectToFMRecordEx | Converts the biometric subject into a FMRecord.
NSubjectToIIRecord | Converts the biometric subject into a IIRecord.


NSubject.h Macros

NSubject.h Macros
Macros
Name | Description
NSubjectCreateFromFile | Picks a Unicode (W) or ANSCII (A) version of the NSubjectCreateFromFile function.
NSubjectCreateFromFileWithFormat | Picks a Unicode (W) or ANSCII (A) version of the NSubjectCreateFromFileWithFormat function.
NSubjectSetId | Picks a Unicode (W) or ANSCII (A) version of the NSubjectSetId function.
NSubjectSetQueryString | Picks a Unicode (W) or ANSCII (A) version of the NSubjectSetQueryString function.


NTemplate Unit Files

NTemplate Unit Files
Files
Name | Description
NTemplate.h | ... more


NTemplate Unit Functions

NTemplate Unit Functions
Legend
Functions
Name | Description
NTemplateCheck | Checks if format of the packed NTemplate is correct.
NTemplateCheckN | Checks if format of the NTemplate is correct.
NTemplateCreateFromMemory | Unpacks a NTemplate from the specified memory buffer.
NTemplateCreateFromMemoryN | Creates NTemplate from the specified memory buffer.
NTemplateGetFacesEx | Retrieves the faces template of the NTemplate.
NTemplateGetFingersEx | Retrieves the fingers template of the NTemplate.
NTemplateGetIrisesEx | Retrieves the irises template of the NTemplate.
NTemplateGetPalmsEx | Retrieves the palms template of the NTemplate.
NTemplateGetSizeMem | Retrieves the size of the packed NTemplate.
NTemplateGetVoicesEx | Retrieves the voices template of the NTemplate.
NTemplateMerge | Merges several NTemplates from buffer array into a single NTemplate.
NTemplatePack | Packs specified templates as NTemplate into the specified memory buffer.
NTemplateSetFaces | Sets the faces template of the NTemplate to the specified value.
NTemplateSetFingers | Sets the fingers template of the NTemplate to the specified value.
NTemplateSetIrises | Sets the itises template of the NTemplate to the specified value.
NTemplateClear | Removes all templates from the NTemplate.
NTemplateSetPalms | Sets the palms template of the NTemplate to the specified value.
NTemplateSetVoices | Sets the voices template of the NTemplate to the specified value.
NTemplateCalculateSize | Calculates the size of a packed NTemplate containing fingers, palms, irises or faces templates of the specified size.
NTemplateUnpack | Unpacks packed fingers, palms, iris, face or voice template from the packed NTemplate.
NTemplateCreateEx | Creates an empty NTemplate with specified flags.
HNTemplate | Handle to NTemplate object.


NTemplate.h Functions

NTemplate.h Functions
Legend
Functions
Name | Description
NTemplateCalculateSize | Calculates the size of a packed NTemplate containing fingers, palms, irises or faces templates of the specified size.
NTemplateCheck | Checks if format of the packed NTemplate is correct.
NTemplateCheckN | Checks if format of the NTemplate is correct.
NTemplateClear | Removes all templates from the NTemplate.
NTemplateCreateEx | Creates an empty NTemplate with specified flags.
NTemplateCreateFromMemory | Unpacks a NTemplate from the specified memory buffer.
NTemplateCreateFromMemoryN | Creates NTemplate from the specified memory buffer.
NTemplateGetFacesEx | Retrieves the faces template of the NTemplate.
NTemplateGetFingersEx | Retrieves the fingers template of the NTemplate.
NTemplateGetIrisesEx | Retrieves the irises template of the NTemplate.
NTemplateGetPalmsEx | Retrieves the palms template of the NTemplate.
NTemplateGetSizeMem | Retrieves the size of the packed NTemplate.
NTemplateGetVoicesEx | Retrieves the voices template of the NTemplate.
NTemplateMerge | Merges several NTemplates from buffer array into a single NTemplate.
NTemplatePack | Packs specified templates as NTemplate into the specified memory buffer.
NTemplateSetFaces | Sets the faces template of the NTemplate to the specified value.
NTemplateSetFingers | Sets the fingers template of the NTemplate to the specified value.
NTemplateSetIrises | Sets the itises template of the NTemplate to the specified value.
NTemplateSetPalms | Sets the palms template of the NTemplate to the specified value.
NTemplateSetVoices | Sets the voices template of the NTemplate to the specified value.
NTemplateUnpack | Unpacks packed fingers, palms, iris, face or voice template from the packed NTemplate.


NCore Library Enumerations

NCore Library Enumerations
Enumerations
Name | Description
NEncoding | Represents a character encoding.


NCore Library Types

NCore Library Types
Types
Name | Description
NDateTime | Represents an instant in time, typically expressed as a date and time of day.
NTimeSpan | Represents a time interval.


NArray Unit Files

NArray Unit Files
Files
Name | Description
NArray.h | Header file for the NArray unit.


NArray Unit Functions

NArray Unit Functions
Legend
Functions
Name | Description
NArrayCopyTo | Copies the specified array into another array.
NArrayCopyToBooleanArray | Copies the specified Boolean array into another array.
NArrayCopyToByteArray | Copies the specified byte array into another array.
NArrayCopyToCharArray | Copies the specified char array into another array.
NArrayCopyToDoubleArray | Copies the specified double value array into another array.
NArrayCopyToInt16Array | Copies the specified short integer array into another array.
NArrayCopyToInt32Array | Copies the specified integer array into another array.
NArrayCopyToInt64Array | Copies the specified long integer array into another array.
NArrayCopyToObjectArray | Copies the specified object array into another array.
NArrayCopyToObjectArrayP | Copies the specified object array into another array.
NArrayCopyToP | Copies the specified array into another array.
NArrayCopyToPointerArray | Copies the specified pointer array into another array.
NArrayCopyToResultArray | Copies the specified NResult value array into another array.
NArrayCopyToSByteArray | Copies the specified signed byte array into another array.
NArrayCopyToSSizeTypeArray | Copies the specified NSSizeType value array into another array.
NArrayCopyToSingleArray | Copies the specified floating point value array into another array.
NArrayCopyToSizeTypeArray | Copies the specified NSizeType value array into another array.
NArrayCopyToStringArray | Copies the specified string array into another array.
NArrayCopyToUInt16Array | Copies the specified unsigned short integer array into another array.
NArrayCopyToUInt32Array | Copies the specified unsigned integer array into another array.
NArrayCopyToUInt64Array | Copies the specified unsigned long integer array into another array.
NArrayCreate | Creates an array of specified type populated by specified values.
NArrayCreateCustom | Creates an array of specified type with additional options populated by specified values.
NArrayCreateFromBooleanArray | Creates an array from an array of Boolean values.
NArrayCreateFromByteArray | Creates an array from an array of bytes.
NArrayCreateFromCharArray | Creates an array from an array of chars.
NArrayCreateFromDoubleArray | Creates an array from an array of double values.
NArrayCreateFromInt16Array | Creates an array from an array of short integer values.
NArrayCreateFromInt32Array | Creates an array from an array of integer values.
NArrayCreateFromInt64Array | Creates an array from an array of long integer values.
NArrayCreateFromObjectArray | Creates an array from an array of object values.
NArrayCreateFromObjectArrayP | Creates an array from an array of object values.
NArrayCreateFromPointerArray | Creates an array from an array of pointer values.
NArrayCreateFromResultArray | Creates an array from an array of NResult values.
NArrayCreateFromSByteArray | Creates an array from an array of signed byte values.
NArrayCreateFromSSizeTypeArray | Creates an array from an array of NSSizeType values.
NArrayCreateFromSingleArray | Creates an array from an array of floating point values.
NArrayCreateFromSizeTypeArray | Creates an array from an array of NSizeType values.
NArrayCreateFromStringArray | Creates an array from an array of string values.
NArrayCreateFromUInt16Array | Creates an array from an array of unsinged short integer values.
NArrayCreateFromUInt32Array | Creates an array from an array of unsinged integer values.
NArrayCreateFromUInt64Array | Creates an array from an array of unsinged long integer values.
NArrayCreateP | Creates an array of specified type populated by specified values.
NArrayGetLength | Retrieves the length of the array.
NArrayGetValue | Retrieves the specified value in the array.
NArrayGetValueAs | Retrieves the of the specified value of the specified type in the array.
NArrayGetValueAsBoolean | Retrieves the of the specified Boolean value in the array.
NArrayGetValueAsByte | Retrieves the of the specified byte value in the array.
NArrayGetValueAsChar | Retrieves the of the specified char value in the array.
NArrayGetValueAsDouble | Retrieves the of the specified double value in the array.
NArrayGetValueAsInt16 | Retrieves the of the specified short integer value in the array.
NArrayGetValueAsInt32 | Retrieves the of the specified integer value in the array.
NArrayGetValueAsInt64 | Retrieves the of the specified long integer value in the array.
NArrayGetValueAsObject | Retrieves the of the specified object value in the array.
NArrayGetValueAsObjectP | Retrieves the of the specified object value in the array.
NArrayGetValueAsP | Retrieves the of the specified value of the specified type in the array.
NArrayGetValueAsPointer | Retrieves the of the specified pointer value in the array.
NArrayGetValueAsResult | Retrieves the of the specified NResult value in the array.
NArrayGetValueAsSByte | Retrieves the of the specified signed byte value in the array.
NArrayGetValueAsSSizeType | Retrieves the of the specified NSSizeType value in the array.
NArrayGetValueAsSingle | Retrieves the of the specified floating point integer value in the array.
NArrayGetValueAsSizeType | Retrieves the of the specified NSizeType value in the array.
NArrayGetValueAsString | Retrieves the of the specified string value in the array.
NArrayGetValueAsUInt16 | Retrieves the of the specified unsigned short integer value in the array.
NArrayGetValueAsUInt32 | Retrieves the of the specified unsigned integer value in the array.
NArrayGetValueAsUInt64 | Retrieves the of the specified unsigned long integer value in the array.


NArray Unit Macros

NArray Unit Macros
Macros
Name | Description
NArrayCopyToCharArray | Picks a Unicode (W) or ANSCII (A) version of the NArrayCopyToCharArray function.
NArrayCreateFromCharArray | Picks a Unicode (W) or ANSCII (A) version of the NArrayCreateFromCharArray function.
NArrayCreateFromStringArray | Picks a Unicode (W) or ANSCII (A) version of the NArrayCreateFromStringArray function.
NArrayGetValueAsChar | Picks a Unicode (W) or ANSCII (A) version of the NArrayGetValueAsChar function.


NArray.h Functions

NArray.h Functions
Legend
Functions
Name | Description
NArrayCopyTo | Copies the specified array into another array.
NArrayCopyToBooleanArray | Copies the specified Boolean array into another array.
NArrayCopyToByteArray | Copies the specified byte array into another array.
NArrayCopyToCharArray | Copies the specified char array into another array.
NArrayCopyToDoubleArray | Copies the specified double value array into another array.
NArrayCopyToInt16Array | Copies the specified short integer array into another array.
NArrayCopyToInt32Array | Copies the specified integer array into another array.
NArrayCopyToInt64Array | Copies the specified long integer array into another array.
NArrayCopyToObjectArray | Copies the specified object array into another array.
NArrayCopyToObjectArrayP | Copies the specified object array into another array.
NArrayCopyToP | Copies the specified array into another array.
NArrayCopyToPointerArray | Copies the specified pointer array into another array.
NArrayCopyToResultArray | Copies the specified NResult value array into another array.
NArrayCopyToSByteArray | Copies the specified signed byte array into another array.
NArrayCopyToSSizeTypeArray | Copies the specified NSSizeType value array into another array.
NArrayCopyToSingleArray | Copies the specified floating point value array into another array.
NArrayCopyToSizeTypeArray | Copies the specified NSizeType value array into another array.
NArrayCopyToStringArray | Copies the specified string array into another array.
NArrayCopyToUInt16Array | Copies the specified unsigned short integer array into another array.
NArrayCopyToUInt32Array | Copies the specified unsigned integer array into another array.
NArrayCopyToUInt64Array | Copies the specified unsigned long integer array into another array.
NArrayCreate | Creates an array of specified type populated by specified values.
NArrayCreateCustom | Creates an array of specified type with additional options populated by specified values.
NArrayCreateFromBooleanArray | Creates an array from an array of Boolean values.
NArrayCreateFromByteArray | Creates an array from an array of bytes.
NArrayCreateFromCharArray | Creates an array from an array of chars.
NArrayCreateFromDoubleArray | Creates an array from an array of double values.
NArrayCreateFromInt16Array | Creates an array from an array of short integer values.
NArrayCreateFromInt32Array | Creates an array from an array of integer values.
NArrayCreateFromInt64Array | Creates an array from an array of long integer values.
NArrayCreateFromObjectArray | Creates an array from an array of object values.
NArrayCreateFromObjectArrayP | Creates an array from an array of object values.
NArrayCreateFromPointerArray | Creates an array from an array of pointer values.
NArrayCreateFromResultArray | Creates an array from an array of NResult values.
NArrayCreateFromSByteArray | Creates an array from an array of signed byte values.
NArrayCreateFromSSizeTypeArray | Creates an array from an array of NSSizeType values.
NArrayCreateFromSingleArray | Creates an array from an array of floating point values.
NArrayCreateFromSizeTypeArray | Creates an array from an array of NSizeType values.
NArrayCreateFromStringArray | Creates an array from an array of string values.
NArrayCreateFromUInt16Array | Creates an array from an array of unsinged short integer values.
NArrayCreateFromUInt32Array | Creates an array from an array of unsinged integer values.
NArrayCreateFromUInt64Array | Creates an array from an array of unsinged long integer values.
NArrayCreateP | Creates an array of specified type populated by specified values.
NArrayGetLength | Retrieves the length of the array.
NArrayGetValue | Retrieves the specified value in the array.
NArrayGetValueAs | Retrieves the of the specified value of the specified type in the array.
NArrayGetValueAsBoolean | Retrieves the of the specified Boolean value in the array.
NArrayGetValueAsByte | Retrieves the of the specified byte value in the array.
NArrayGetValueAsChar | Retrieves the of the specified char value in the array.
NArrayGetValueAsDouble | Retrieves the of the specified double value in the array.
NArrayGetValueAsInt16 | Retrieves the of the specified short integer value in the array.
NArrayGetValueAsInt32 | Retrieves the of the specified integer value in the array.
NArrayGetValueAsInt64 | Retrieves the of the specified long integer value in the array.
NArrayGetValueAsObject | Retrieves the of the specified object value in the array.
NArrayGetValueAsObjectP | Retrieves the of the specified object value in the array.
NArrayGetValueAsP | Retrieves the of the specified value of the specified type in the array.
NArrayGetValueAsPointer | Retrieves the of the specified pointer value in the array.
NArrayGetValueAsResult | Retrieves the of the specified NResult value in the array.
NArrayGetValueAsSByte | Retrieves the of the specified signed byte value in the array.
NArrayGetValueAsSSizeType | Retrieves the of the specified NSSizeType value in the array.
NArrayGetValueAsSingle | Retrieves the of the specified floating point integer value in the array.
NArrayGetValueAsSizeType | Retrieves the of the specified NSizeType value in the array.
NArrayGetValueAsString | Retrieves the of the specified string value in the array.
NArrayGetValueAsUInt16 | Retrieves the of the specified unsigned short integer value in the array.
NArrayGetValueAsUInt32 | Retrieves the of the specified unsigned integer value in the array.
NArrayGetValueAsUInt64 | Retrieves the of the specified unsigned long integer value in the array.


NArray.h Macros

NArray.h Macros
Macros
Name | Description
NArrayCopyToCharArray | Picks a Unicode (W) or ANSCII (A) version of the NArrayCopyToCharArray function.
NArrayCreateFromCharArray | Picks a Unicode (W) or ANSCII (A) version of the NArrayCreateFromCharArray function.
NArrayCreateFromStringArray | Picks a Unicode (W) or ANSCII (A) version of the NArrayCreateFromStringArray function.
NArrayGetValueAsChar | Picks a Unicode (W) or ANSCII (A) version of the NArrayGetValueAsChar function.


NArrayCollection Unit Files

NArrayCollection Unit Files
Files
Name | Description
NArrayCollection.h | Header file for the NArrayCollection module.


NArrayCollection Unit Functions

NArrayCollection Unit Functions
Legend
Functions
Name | Description
NArrayCollectionAdd | Adds a value to the specified array collection.
NArrayCollectionAddItemRange | Adds an array of values to the specified array collection.
NArrayCollectionAddRange | Adds an array of values to the specified array collection.
NArrayCollectionClear | Clears the specified array in the collection.
NArrayCollectionContains | Checks whether the specified array collection contains the specified value.
NArrayCollectionGet | Retrieves the specified value from the array collection.
NArrayCollectionGetBaseCount | Retrieves the number of arrays in the array collection.
NArrayCollectionGetCount | Retrieves the number of values in the specified array.
NArrayCollectionIndexOf | Retrieves the index of the specified value in the array collection.
NArrayCollectionInsert | Adds a value to the specified array collection at the specified index.
NArrayCollectionInsertItemRange | Adds an array of values to the specified array collection at the specified index.
NArrayCollectionInsertRange | Adds an array of values to the specified array collection at the specified index.
NArrayCollectionIsReadOnly | Checks whether the specified array collection is read-only.
NArrayCollectionRemove | Removes a value from the specified array collection.
NArrayCollectionRemoveAt | Removes a value from the specified array collection.
NArrayCollectionRemoveRange | Removes a range of values from the specified array collection.
NArrayCollectionSet | Sets the specified value in the array collection.
NArrayCollectionToArray | Converts the specified array of the array collection into an independent array.
NArrayCollectionToItemArray | Converts the specified array of the array collection into an independent array.


NArrayCollection.h Functions

NArrayCollection.h Functions
Legend
Functions
Name | Description
NArrayCollectionAdd | Adds a value to the specified array collection.
NArrayCollectionAddItemRange | Adds an array of values to the specified array collection.
NArrayCollectionAddRange | Adds an array of values to the specified array collection.
NArrayCollectionClear | Clears the specified array in the collection.
NArrayCollectionContains | Checks whether the specified array collection contains the specified value.
NArrayCollectionGet | Retrieves the specified value from the array collection.
NArrayCollectionGetBaseCount | Retrieves the number of arrays in the array collection.
NArrayCollectionGetCount | Retrieves the number of values in the specified array.
NArrayCollectionIndexOf | Retrieves the index of the specified value in the array collection.
NArrayCollectionInsert | Adds a value to the specified array collection at the specified index.
NArrayCollectionInsertItemRange | Adds an array of values to the specified array collection at the specified index.
NArrayCollectionInsertRange | Adds an array of values to the specified array collection at the specified index.
NArrayCollectionIsReadOnly | Checks whether the specified array collection is read-only.
NArrayCollectionRemove | Removes a value from the specified array collection.
NArrayCollectionRemoveAt | Removes a value from the specified array collection.
NArrayCollectionRemoveRange | Removes a range of values from the specified array collection.
NArrayCollectionSet | Sets the specified value in the array collection.
NArrayCollectionToArray | Converts the specified array of the array collection into an independent array.
NArrayCollectionToItemArray | Converts the specified array of the array collection into an independent array.


NArrayCollectionInfo Unit Files

NArrayCollectionInfo Unit Files
Files
Name | Description
NArrayCollectionInfo.h | Header file for the NArrayCollectionInfo unit.


NArrayCollectionInfo Unit Functions

NArrayCollectionInfo Unit Functions
Legend
Functions
Name | Description
NArrayCollectionInfoGetAddMethod | Retrieves the method which adds an item to an array collection.
NArrayCollectionInfoGetAddRangeMethod | Retrieves the method which adds a range of items to an array collection.
NArrayCollectionInfoGetBaseCollection | Retrieves the base collection of the array collection.
NArrayCollectionInfoGetClearMethod | Retrieves the method which clears the array collection.
NArrayCollectionInfoGetGetCountMethod | Retrieves the method which gets the number of items in the array collection.
NArrayCollectionInfoGetGetMethod | Retrieves the method which gets an item in the array collection.
NArrayCollectionInfoGetIndexOfMethod | Retrieves the method which gets an index of an item in the array collection.
NArrayCollectionInfoGetInsertMethod | Retrieves the method which adds an item to an array collection at a specific index.
NArrayCollectionInfoGetInsertRangeMethod | Retrieves the method which adds a range of items to an array collection at a specific index.
NArrayCollectionInfoGetItemAttributes | Retrieves the attributes of the items in the array collection.
NArrayCollectionInfoGetItemFormat | Retrieves the format of the items in the array collection.
NArrayCollectionInfoGetItemMaxValue | Retrieves the maximal item value of the array collection.
NArrayCollectionInfoGetItemMinValue | Retrieves the minimal item value of the array collection.
NArrayCollectionInfoGetItemStdValue | Retrieves the specified standard value of the array collection.
NArrayCollectionInfoGetItemStdValueCount | Retrieves the number of standard item values of the array collection.
NArrayCollectionInfoGetItemStdValues | Retrieves all standard item values of the array collection.
NArrayCollectionInfoGetItemType | Retrieves the type of the items in the array collection.
NArrayCollectionInfoGetRemoveAtMethod | Retrieves the method which removes an item with specific index from an array collection.
NArrayCollectionInfoGetRemoveMethod | Retrieves the method which removes an item from an array collection.
NArrayCollectionInfoGetRemoveRangeMethod | Retrieves the method which removes a range of items from an array collection.
NArrayCollectionInfoGetSetMethod | Retrieves the method which sets an item of the array collection.
NArrayCollectionInfoGetToArrayMethod | Retrieves the method which converts the array collection into a regular array.


NArrayCollectionInfo.h Functions

NArrayCollectionInfo.h Functions
Legend
Functions
Name | Description
NArrayCollectionInfoGetAddMethod | Retrieves the method which adds an item to an array collection.
NArrayCollectionInfoGetAddRangeMethod | Retrieves the method which adds a range of items to an array collection.
NArrayCollectionInfoGetBaseCollection | Retrieves the base collection of the array collection.
NArrayCollectionInfoGetClearMethod | Retrieves the method which clears the array collection.
NArrayCollectionInfoGetGetCountMethod | Retrieves the method which gets the number of items in the array collection.
NArrayCollectionInfoGetGetMethod | Retrieves the method which gets an item in the array collection.
NArrayCollectionInfoGetIndexOfMethod | Retrieves the method which gets an index of an item in the array collection.
NArrayCollectionInfoGetInsertMethod | Retrieves the method which adds an item to an array collection at a specific index.
NArrayCollectionInfoGetInsertRangeMethod | Retrieves the method which adds a range of items to an array collection at a specific index.
NArrayCollectionInfoGetItemAttributes | Retrieves the attributes of the items in the array collection.
NArrayCollectionInfoGetItemFormat | Retrieves the format of the items in the array collection.
NArrayCollectionInfoGetItemMaxValue | Retrieves the maximal item value of the array collection.
NArrayCollectionInfoGetItemMinValue | Retrieves the minimal item value of the array collection.
NArrayCollectionInfoGetItemStdValue | Retrieves the specified standard value of the array collection.
NArrayCollectionInfoGetItemStdValueCount | Retrieves the number of standard item values of the array collection.
NArrayCollectionInfoGetItemStdValues | Retrieves all standard item values of the array collection.
NArrayCollectionInfoGetItemType | Retrieves the type of the items in the array collection.
NArrayCollectionInfoGetRemoveAtMethod | Retrieves the method which removes an item with specific index from an array collection.
NArrayCollectionInfoGetRemoveMethod | Retrieves the method which removes an item from an array collection.
NArrayCollectionInfoGetRemoveRangeMethod | Retrieves the method which removes a range of items from an array collection.
NArrayCollectionInfoGetSetMethod | Retrieves the method which sets an item of the array collection.
NArrayCollectionInfoGetToArrayMethod | Retrieves the method which converts the array collection into a regular array.


NAsyncOperation Unit Files

NAsyncOperation Unit Files
Files
Name | Description
NAsyncOperation.h | Header file for the NAsyncOperation unit.


NAsyncOperation Unit Functions

NAsyncOperation Unit Functions
Legend
Functions
Name | Description
NAsyncOperationAddCompleted | Adds a user-specified "completed" event to the specified asynchronous operation.
NAsyncOperationAddCompletedCallback | Adds a user-specified "completed" event callback to the specified asynchronous operation.
NAsyncOperationCancel | Cancels the specified asynchronous operation.
NAsyncOperationGetError | Retrieves the exception thrown by the specified asynchronous operation.
NAsyncOperationGetResult | Retrieves the value returned by the specified asynchronous operation.
NAsyncOperationGetStatus | Retrieves the status of the specified asynchronous operation.
NAsyncOperationIsCanceled | Checks whether the specified asynchronous operation has been canceled.
NAsyncOperationIsCompleted | Checks whether the specified asynchronous operation has been completed.
NAsyncOperationIsFaulted | Checks whether the specified asynchronous operation is faulted.
NAsyncOperationRemoveCompleted | Removes a user-specified "completed" event from the specified asynchronous operation.
NAsyncOperationRemoveCompletedCallback | Removes a user-specified "completed" event callback from the specified asynchronous operation.
NAsyncOperationWait | Waits until the specified asynchronous operation completes.
NAsyncOperationWaitAll | Waits until all asynchronous operations in the specified array complete.
NAsyncOperationWaitAllTimed | Waits until all asynchronous operations in the specified array complete or until the wait period times out.
NAsyncOperationWaitAny | Waits until at least one asynchronous operation in the specified array complete.
NAsyncOperationWaitAnyTimed | Waits until at least one asynchronous operation in the specified array complete or until the wait period times out.
NAsyncOperationWaitTimed | Waits until the specified asynchronous operation completes or until the wait period times out.


NAsyncOperation Unit Structs, Records, Enums

NAsyncOperation Unit Structs, Records, Enums
Legend
Structs, Records, Enums
Name | Description
NAsyncStatus_ | Enumerates asynchronous operation statuses.
NAsyncStatus | Enumerates asynchronous operation statuses.


NAsyncOperation.h Enumerations

NAsyncOperation.h Enumerations
Legend
Enumerations
Name | Description
NAsyncStatus_ | Enumerates asynchronous operation statuses.
NAsyncStatus | Enumerates asynchronous operation statuses.


NAsyncOperation.h Functions

NAsyncOperation.h Functions
Legend
Functions
Name | Description
NAsyncOperationAddCompleted | Adds a user-specified "completed" event to the specified asynchronous operation.
NAsyncOperationAddCompletedCallback | Adds a user-specified "completed" event callback to the specified asynchronous operation.
NAsyncOperationCancel | Cancels the specified asynchronous operation.
NAsyncOperationGetError | Retrieves the exception thrown by the specified asynchronous operation.
NAsyncOperationGetResult | Retrieves the value returned by the specified asynchronous operation.
NAsyncOperationGetStatus | Retrieves the status of the specified asynchronous operation.
NAsyncOperationIsCanceled | Checks whether the specified asynchronous operation has been canceled.
NAsyncOperationIsCompleted | Checks whether the specified asynchronous operation has been completed.
NAsyncOperationIsFaulted | Checks whether the specified asynchronous operation is faulted.
NAsyncOperationRemoveCompleted | Removes a user-specified "completed" event from the specified asynchronous operation.
NAsyncOperationRemoveCompletedCallback | Removes a user-specified "completed" event callback from the specified asynchronous operation.
NAsyncOperationWait | Waits until the specified asynchronous operation completes.
NAsyncOperationWaitAll | Waits until all asynchronous operations in the specified array complete.
NAsyncOperationWaitAllTimed | Waits until all asynchronous operations in the specified array complete or until the wait period times out.
NAsyncOperationWaitAny | Waits until at least one asynchronous operation in the specified array complete.
NAsyncOperationWaitAnyTimed | Waits until at least one asynchronous operation in the specified array complete or until the wait period times out.
NAsyncOperationWaitTimed | Waits until the specified asynchronous operation completes or until the wait period times out.


NBinaryReader Unit Functions

NBinaryReader Unit Functions
Legend
Functions
Name | Description
NBinaryReaderCreate | Creates binary reader based on the specified stream and byte order.
NBinaryReaderCreateWithEncoding | Creates binary reader based on the specified stream, byte order and encoding.
NBinaryReaderGetBaseStream | Gets base stream (the one which was used to create NBinaryReader).
NBinaryReaderGetByteOrder | Gets byte order in specified NBinaryReader.
NBinaryReaderGetNull | Returns empty (null) NBinaryReader which can not be used for stream reading.
NBinaryReaderGetPosition | Gets position in base stream.
NBinaryReaderPeekChar | Returns the next available character in the NBinaryReader.
NBinaryReaderRead | Reads characters from base stream specified by NBinaryReader
NBinaryReaderReadBoolean | Reads NBoolean value from the stream and advances the current position of the stream by one byte.
NBinaryReaderReadByte | Reads one byte from the stream starting from the current position.
NBinaryReaderReadBytesDst | Reads bytes from the stream to memory buffer.
NBinaryReaderReadBytesDstN | Reads bytes from the stream to specified NBuffer.
NBinaryReaderReadBytesN | Reads bytes from the stream to specified NBuffer.
NBinaryReaderReadChar | Reads the next character from the stream and advances the current position of the stream.
NBinaryReaderReadChars | ... more
NBinaryReaderReadCharsDst | ... more
NBinaryReaderReadDouble | Reads an 8 byte floating point value (NDouble) from the stream and advances the current position of the stream.
NBinaryReaderReadInt16 | Reads a 2-byte signed integer from the stream and advances the current position of the stream.
NBinaryReaderReadInt32 | ... more
NBinaryReaderReadInt64 | ... more
NBinaryReaderReadSByte | Reads a signed byte from the stream and advances the current position of the stream by one byte.
NBinaryReaderReadSingle | Reads a 4-byte floating point value from the stream and advances the current position of the stream by four bytes.
NBinaryReaderReadUInt16 | ... more
NBinaryReaderReadUInt32 | Reads a 4-byte unsigned integer from the stream and advances the position of the stream by four bytes.
NBinaryReaderReadUInt64 | Reads an 8-byte unsigned integer from the stream and advances the position of the stream by eight bytes.
NBinaryReaderSeek | Sets the position in the stream.
NBinaryReaderSetPosition | Sets position in the base stream.


NBinaryReader Unit Macros

NBinaryReader Unit Macros
Macros
Name | Description
NBinaryReaderPeekChar | Picks a Unicode (W) or ASCII (A) version of the NBinaryReaderPeekChar function.
NBinaryReaderRead | Picks a Unicode (W) or ASCII (A) version of the NBinaryReaderRead function.
NBinaryReaderReadChar | Picks a Unicode (W) or ASCII (A) version of the NBinaryReaderReadChar function.
NBinaryReaderReadChars | Picks a Unicode (W) or ASCII (A) version of the NBinaryReaderReadChars function.
NBinaryReaderReadCharsDst | Picks a Unicode (W) or ASCII (A) version of the NBinaryReaderReadCharsDst function.


NBinaryWriter Unit Functions

NBinaryWriter Unit Functions
Legend
Functions
Name | Description
NBinaryWriterCreate | Creates binary writer based on the specified stream and byte order.
NBinaryWriterCreateWithEncoding | Creates binary writer based on the specified stream, byte order and encoding.
NBinaryWriterFlush | Clears all buffers for the current writer.
NBinaryWriterGetBaseStream | Gets the base stream of the NBinaryWriter.
NBinaryWriterGetByteOrder | Gets byte order in specified NBinaryWriter.
NBinaryWriterGetNull | Returns empty (null) NBinaryWriter which can not be used for stream reading.
NBinaryWriterGetPosition | Gets position in base stream.
NBinaryWriterSeek | Sets the position in the stream.
NBinaryWriterSetPosition | Sets position in the base stream.
NBinaryWriterWriteBoolean | Writes NBoolean value into the stream.
NBinaryWriterWriteByte | Writes one byte into the stream starting from the current position.
NBinaryWriterWriteBytes | Writes bytes into the stream from specified memory buffer.
NBinaryWriterWriteBytesN | Writes bytes into the stream from specified NBuffer.
NBinaryWriterWriteChar | Writes specified character into the stream and advances the current position of the stream.
NBinaryWriterWriteChars | Writes the specified number of characters into the stream, and advances the current position in accordance with specific character being written into the stream.
NBinaryWriterWriteDouble | ... more
NBinaryWriterWriteInt16 | Writes 2-byte signed integer to the stream and advances the current position of the stream by two bytes.
NBinaryWriterWriteInt32 | Writes a 4-byte signed integer to the stream and advances the position of the stream by four bytes.
NBinaryWriterWriteInt64 | Writes a 8-byte signed integer to the stream and advances the position of the stream by eight bytes.
NBinaryWriterWriteSByte | Writes a signed byte into the stream and advances the position of the stream by one byte.
NBinaryWriterWriteSingle | Writes a 4-byte floating point value into the stream and advances the current position of the stream by four bytes.
NBinaryWriterWriteUInt16 | Writes a 2-byte unsigned integer to the stream and advances the position of the stream by two bytes.
NBinaryWriterWriteUInt32 | Writes a 4-byte unsigned integer to the stream and advances the position of the stream by four bytes.
NBinaryWriterWriteUInt64 | Writes a 8-byte unsigned integer to the stream and advances the position of the stream by eight bytes.


NBinaryWriter Unit Macros

NBinaryWriter Unit Macros
Macros
Name | Description
NBinaryWriterWriteChar | Picks a Unicode (W) or ASCII (A) version of the NBinaryWriterWriteChar function.
NBinaryWriterWriteChars | Picks a Unicode (W) or ASCII (A) version of the NBinaryWriterWriteChars function.


NBuffer Unit Files

NBuffer Unit Files
Files
Name | Description
NBuffer.h | Header file for the NBuffer unit.


NBuffer Unit Functions

NBuffer Unit Functions
Legend
Functions
Name | Description
NBufferCopy | Copies data into current NBuffer from a different NBuffer with specified offsets into both buffers and specified size.
NBufferCopyFromPtr | Copies data into current NBuffer from a different NBuffer with specified offsets into current NBuffer and specified size of the source NBuffer.
NBufferCopyTo | Reads the bytes from the current NBuffer and writes them to another buffer, using a specified offset.
NBufferCopyToPtr | ... more
NBufferCopyToPtrRange | Reads the bytes from the current NBuffer and writes them to another buffer, using a specified offset and buffer size.
NBufferCreate | Creates a new NBuffer using the specified memory location and size.
NBufferCreateFromBuffer | Creates a new NBuffer based on the specified byte array, with specified offset and size.
NBufferCreateFromPtr | Creates a new NBuffer using the specified memory location and size.
NBufferCreateFromPtrEx | Creates a new NBuffer using the specified size and a specified location of specified type.
NBufferCreateFromPtrWithFree | ... more
NBufferCreateFromPtrWithFreeProc | Creates a new NBuffer using the specified memory location and size; frees the memory in the source location.
NBufferGetEmpty | Returns an empty buffer.
NBufferGetPtr | Reads the bytes from the NBuffer and returns them as a pointer.
NBufferGetSize | Returns the size of the NBuffer in bytes.
NBufferToPtr | Copies the memory contained in NBuffer and returns it as a pointer.


NBuffer Unit Macros

NBuffer Unit Macros
Macros
Name | Description
NBufferCreateFromConstPtr | Creates a new NBuffer using the specified memory location and size.


NBuffer.h Functions

NBuffer.h Functions
Legend
Functions
Name | Description
NBufferCopy | Copies data into current NBuffer from a different NBuffer with specified offsets into both buffers and specified size.
NBufferCopyFromPtr | Copies data into current NBuffer from a different NBuffer with specified offsets into current NBuffer and specified size of the source NBuffer.
NBufferCopyTo | Reads the bytes from the current NBuffer and writes them to another buffer, using a specified offset.
NBufferCopyToPtr | ... more
NBufferCopyToPtrRange | Reads the bytes from the current NBuffer and writes them to another buffer, using a specified offset and buffer size.
NBufferCreate | Creates a new NBuffer using the specified memory location and size.
NBufferCreateFromBuffer | Creates a new NBuffer based on the specified byte array, with specified offset and size.
NBufferCreateFromPtr | Creates a new NBuffer using the specified memory location and size.
NBufferCreateFromPtrEx | Creates a new NBuffer using the specified size and a specified location of specified type.
NBufferCreateFromPtrWithFree | ... more
NBufferCreateFromPtrWithFreeProc | Creates a new NBuffer using the specified memory location and size; frees the memory in the source location.
NBufferGetEmpty | Returns an empty buffer.
NBufferGetPtr | Reads the bytes from the NBuffer and returns them as a pointer.
NBufferGetSize | Returns the size of the NBuffer in bytes.
NBufferToPtr | Copies the memory contained in NBuffer and returns it as a pointer.


NBuffer.h Macros

NBuffer.h Macros
Macros
Name | Description
NBufferCreateFromConstPtr | Creates a new NBuffer using the specified memory location and size.


NBufferedStream Unit Files

NBufferedStream Unit Files
Files
Name | Description
NBufferedStream.h | Header file for the NBufferedStream unit.


NBufferedStream Unit Functions

NBufferedStream Unit Functions
Legend
Functions
Name | Description
NBufferedStreamCreate | Creates a new NBufferedStream with a default buffer size of 4096 bytes.
NBufferedStreamCreateWithBufferSize | Creates a new NBufferedStream with the specified buffer size.


NBufferedStream.h Functions

NBufferedStream.h Functions
Legend
Functions
Name | Description
NBufferedStreamCreate | Creates a new NBufferedStream with a default buffer size of 4096 bytes.
NBufferedStreamCreateWithBufferSize | Creates a new NBufferedStream with the specified buffer size.


NCallback Unit Files

NCallback Unit Files
Files
Name | Description
NCallback.h | Header file for the NCallback unit.


NCallback Unit Functions

NCallback Unit Functions
Legend
Functions
Name | Description
NCallbackClone | Creates a copy of the specified callback.
NCallbackCreateCustomRaw | Creates a callback for the specified process with additional parameters.
NCallbackCreateRaw | Creates a callback for the specified process.
NCallbackCreateWithObjectRaw | Creates a callback for the specified process.
NCallbackEquals | Checks whether the specified callback equals the other specified callback.
NCallbackFree | Frees the specified callback.
NCallbackGetHashCode | Retrieves the hash code of the specified callback.
NCallbackGetParam | Retrieves the parameters of the specified callback.
NCallbackGetProcRaw | Retrieves the process that invokes the specified callback.
NCallbackSet | Sets the value of the specified variable to the value of the specified callback.


NCallback Unit Macros

NCallback Unit Macros
Macros
Name | Description
NCallbackCreate | Creates a callback for the specified process.
NCallbackCreateCustom | Creates a callback for the specified process with additional parameters.
NCallbackGetProc | Retrieves the process that invokes the specified callback.
NCallbackInvoke0 | Invokes the specified callback.
NCallbackInvoke1 | Invokes the specified callback with specified arguments.
NCallbackInvoke2 | Invokes the specified callback with specified arguments.
NCallbackInvoke3 | Invokes the specified callback with specified arguments.
NCallbackInvoke4 | Invokes the specified callback with specified arguments.
NCallbackInvoke5 | Invokes the specified callback with specified arguments.
NCallbackInvoke6 | Invokes the specified callback with specified arguments.
NCallbackInvoke7 | Invokes the specified callback with specified arguments.
NCallbackInvoke8 | Invokes the specified callback with specified arguments.
NCallbackInvoke9 | Invokes the specified callback with specified arguments.
NCallbackInvokeRaw | Invokes the specified callback with specified arguments.


NCallback.h Functions

NCallback.h Functions
Legend
Functions
Name | Description
NCallbackClone | Creates a copy of the specified callback.
NCallbackCreateCustomRaw | Creates a callback for the specified process with additional parameters.
NCallbackCreateRaw | Creates a callback for the specified process.
NCallbackCreateWithObjectRaw | Creates a callback for the specified process.
NCallbackEquals | Checks whether the specified callback equals the other specified callback.
NCallbackFree | Frees the specified callback.
NCallbackGetHashCode | Retrieves the hash code of the specified callback.
NCallbackGetParam | Retrieves the parameters of the specified callback.
NCallbackGetProcRaw | Retrieves the process that invokes the specified callback.
NCallbackSet | Sets the value of the specified variable to the value of the specified callback.


NCallback.h Macros

NCallback.h Macros
Macros
Name | Description
NCallbackCreate | Creates a callback for the specified process.
NCallbackCreateCustom | Creates a callback for the specified process with additional parameters.
NCallbackGetProc | Retrieves the process that invokes the specified callback.
NCallbackInvoke0 | Invokes the specified callback.
NCallbackInvoke1 | Invokes the specified callback with specified arguments.
NCallbackInvoke2 | Invokes the specified callback with specified arguments.
NCallbackInvoke3 | Invokes the specified callback with specified arguments.
NCallbackInvoke4 | Invokes the specified callback with specified arguments.
NCallbackInvoke5 | Invokes the specified callback with specified arguments.
NCallbackInvoke6 | Invokes the specified callback with specified arguments.
NCallbackInvoke7 | Invokes the specified callback with specified arguments.
NCallbackInvoke8 | Invokes the specified callback with specified arguments.
NCallbackInvoke9 | Invokes the specified callback with specified arguments.
NCallbackInvokeRaw | Invokes the specified callback with specified arguments.


NCollection Unit Files

NCollection Unit Files
Files
Name | Description
NCollection.h | Header file for the NCollection module.


NCollection Unit Functions

NCollection Unit Functions
Legend
Functions
Name | Description
NCollectionAdd | Adds the specified value to the specified collection.
NCollectionAddCollectionChanged | Adds a user-specified "collection changed" event to the specified collection.
NCollectionAddCollectionChangedCallback | Adds a user-specified "collection changed" event callback to the specified collection.
NCollectionAddItemCollectionChanged | Adds a user-specified "item collection changed" event to the specified collection.
NCollectionAddItemCollectionChangedCallback | Adds a user-specified "item collection changed" event callback to the specified collection.
NCollectionAddItemRange | Adds an array of values to the specified collection.
NCollectionAddRange | Adds an array of values to the specified collection.
NCollectionClear | Clears the specified collection.
NCollectionContains | Checks whether the specified collection contains the specified value.
NCollectionGet | Retrieves the item specified by index from the specified collection.
NCollectionGetCapacity | Retrieves the capacity of the collection.
NCollectionGetCount | Retrieves the number of items in the collection.
NCollectionIndexOf | Retrieves the index of the specified value in the specified collection.
NCollectionInsert | Adds the specified value to the specified collection at the specified index.
NCollectionInsertItemRange | Adds an array of values to the specified collection at the specified index.
NCollectionInsertRange | Adds an array of values to the specified collection at the specified index.
NCollectionIsReadOnly | Checks whether the specified collection is read-only.
NCollectionRemove | Removes the specified value from the specified collection.
NCollectionRemoveAt | Removes the specified value from the specified collection.
NCollectionRemoveCollectionChanged | Removes a user-specified "collection changed" event from the specified collection.
NCollectionRemoveCollectionChangedCallback | Removes a user-specified "collection changed" event callback from the specified collection.
NCollectionRemoveItemCollectionChanged | Removes a user-specified "item collection changed" event from the specified collection.
NCollectionRemoveItemCollectionChangedCallback | Removes a user-specified "item collection changed" event callback from the specified collection.
NCollectionRemoveRange | Removes a range of values from the specified collection.
NCollectionSet | Sets the specified value in the specified collection.
NCollectionSetCapacity | Sets the capacity of the collection.
NCollectionToArray | Converts the specified collection to an array.
NCollectionToItemArray | Converts the specified collection to an item array.
N_DECLARE_TYPE | Declares type with specified name.


NCollection Unit Structs, Records, Enums

NCollection Unit Structs, Records, Enums
Legend
Structs, Records, Enums
Name | Description
NCollectionChangedAction_ | Enumerates collection-changing actions.
NCollectionChangedAction | Enumerates collection-changing actions.


NCollection.h Enumerations

NCollection.h Enumerations
Legend
Enumerations
Name | Description
NCollectionChangedAction_ | Enumerates collection-changing actions.
NCollectionChangedAction | Enumerates collection-changing actions.


NCollection.h Functions

NCollection.h Functions
Legend
Functions
Name | Description
NCollectionAdd | Adds the specified value to the specified collection.
NCollectionAddCollectionChanged | Adds a user-specified "collection changed" event to the specified collection.
NCollectionAddCollectionChangedCallback | Adds a user-specified "collection changed" event callback to the specified collection.
NCollectionAddItemCollectionChanged | Adds a user-specified "item collection changed" event to the specified collection.
NCollectionAddItemCollectionChangedCallback | Adds a user-specified "item collection changed" event callback to the specified collection.
NCollectionAddItemRange | Adds an array of values to the specified collection.
NCollectionAddRange | Adds an array of values to the specified collection.
NCollectionClear | Clears the specified collection.
NCollectionContains | Checks whether the specified collection contains the specified value.
NCollectionGet | Retrieves the item specified by index from the specified collection.
NCollectionGetCapacity | Retrieves the capacity of the collection.
NCollectionGetCount | Retrieves the number of items in the collection.
NCollectionIndexOf | Retrieves the index of the specified value in the specified collection.
NCollectionInsert | Adds the specified value to the specified collection at the specified index.
NCollectionInsertItemRange | Adds an array of values to the specified collection at the specified index.
NCollectionInsertRange | Adds an array of values to the specified collection at the specified index.
NCollectionIsReadOnly | Checks whether the specified collection is read-only.
NCollectionRemove | Removes the specified value from the specified collection.
NCollectionRemoveAt | Removes the specified value from the specified collection.
NCollectionRemoveCollectionChanged | Removes a user-specified "collection changed" event from the specified collection.
NCollectionRemoveCollectionChangedCallback | Removes a user-specified "collection changed" event callback from the specified collection.
NCollectionRemoveItemCollectionChanged | Removes a user-specified "item collection changed" event from the specified collection.
NCollectionRemoveItemCollectionChangedCallback | Removes a user-specified "item collection changed" event callback from the specified collection.
NCollectionRemoveRange | Removes a range of values from the specified collection.
NCollectionSet | Sets the specified value in the specified collection.
NCollectionSetCapacity | Sets the capacity of the collection.
NCollectionToArray | Converts the specified collection to an array.
NCollectionToItemArray | Converts the specified collection to an item array.
N_DECLARE_TYPE | Declares type with specified name.


NCollectionInfo Unit Files

NCollectionInfo Unit Files
Files
Name | Description
NCollectionInfo.h | Header file for the NCollectionInfo unit.


NCollectionInfo Unit Functions

NCollectionInfo Unit Functions
Legend
Functions
Name | Description
NCollectionInfoGetAddCollectionChangedCallbackMethod | Retrieves the method which adds a "collection changed" event callback to a collection.
NCollectionInfoGetAddCollectionChangedMethod | Retrieves the method which adds a "collection changed" event to a collection.
NCollectionInfoGetAddMethod | Retrieves the method which adds an item to a collection.
NCollectionInfoGetAddRangeMethod | Retrieves the method which adds a range of items to a collection.
NCollectionInfoGetClearMethod | Retrieves the method which clears the collection.
NCollectionInfoGetGetCapacityMethod | Retrieves the method which gets the maximum number of items in the collection.
NCollectionInfoGetGetCountMethod | Retrieves the method which gets the number of items in the collection.
NCollectionInfoGetGetMethod | Retrieves the method which gets an item in the collection.
NCollectionInfoGetIndexOfMethod | Retrieves the method which gets an index of an item in the collection.
NCollectionInfoGetInsertMethod | Retrieves the method which adds an item to the collection at a specific index.
NCollectionInfoGetInsertRangeMethod | Retrieves the method which adds a range of items to the collection at a specific index.
NCollectionInfoGetItemAttributes | Retrieves the attributes of the items in the collection.
NCollectionInfoGetItemFormat | Retrieves the format of the items in the collection.
NCollectionInfoGetItemMaxValue | Retrieves the maximal item value of the collection.
NCollectionInfoGetItemMinValue | Retrieves the minimal item value of the collection.
NCollectionInfoGetItemStdValue | Retrieves the specified standard value of the collection.
NCollectionInfoGetItemStdValueCount | Retrieves the number of standard item values of the collection.
NCollectionInfoGetItemStdValues | Retrieves all standard item values of the collection.
NCollectionInfoGetItemType | Retrieves the type of the items in the collection.
NCollectionInfoGetRemoveAtMethod | Retrieves the method which removes an item with specific index from the collection.
NCollectionInfoGetRemoveCollectionChangedCallbackMethod | Retrieves the method which removes a "collection changed" event callback from a collection.
NCollectionInfoGetRemoveCollectionChangedMethod | Retrieves the method which removes a "collection changed" event from a collection.
NCollectionInfoGetRemoveMethod | Retrieves the method which removes an item from the collection.
NCollectionInfoGetRemoveRangeMethod | Retrieves the method which removes a range of items from the collection.
NCollectionInfoGetSetCapacityMethod | Retrieves the method which sets the maximum number of items in the collection.
NCollectionInfoGetSetMethod | Retrieves the method which sets a value of an item in the collection.
NCollectionInfoGetToArrayMethod | Retrieves the method which converts the collection into an array.


NCollectionInfo.h Functions

NCollectionInfo.h Functions
Legend
Functions
Name | Description
NCollectionInfoGetAddCollectionChangedCallbackMethod | Retrieves the method which adds a "collection changed" event callback to a collection.
NCollectionInfoGetAddCollectionChangedMethod | Retrieves the method which adds a "collection changed" event to a collection.
NCollectionInfoGetAddMethod | Retrieves the method which adds an item to a collection.
NCollectionInfoGetAddRangeMethod | Retrieves the method which adds a range of items to a collection.
NCollectionInfoGetClearMethod | Retrieves the method which clears the collection.
NCollectionInfoGetGetCapacityMethod | Retrieves the method which gets the maximum number of items in the collection.
NCollectionInfoGetGetCountMethod | Retrieves the method which gets the number of items in the collection.
NCollectionInfoGetGetMethod | Retrieves the method which gets an item in the collection.
NCollectionInfoGetIndexOfMethod | Retrieves the method which gets an index of an item in the collection.
NCollectionInfoGetInsertMethod | Retrieves the method which adds an item to the collection at a specific index.
NCollectionInfoGetInsertRangeMethod | Retrieves the method which adds a range of items to the collection at a specific index.
NCollectionInfoGetItemAttributes | Retrieves the attributes of the items in the collection.
NCollectionInfoGetItemFormat | Retrieves the format of the items in the collection.
NCollectionInfoGetItemMaxValue | Retrieves the maximal item value of the collection.
NCollectionInfoGetItemMinValue | Retrieves the minimal item value of the collection.
NCollectionInfoGetItemStdValue | Retrieves the specified standard value of the collection.
NCollectionInfoGetItemStdValueCount | Retrieves the number of standard item values of the collection.
NCollectionInfoGetItemStdValues | Retrieves all standard item values of the collection.
NCollectionInfoGetItemType | Retrieves the type of the items in the collection.
NCollectionInfoGetRemoveAtMethod | Retrieves the method which removes an item with specific index from the collection.
NCollectionInfoGetRemoveCollectionChangedCallbackMethod | Retrieves the method which removes a "collection changed" event callback from a collection.
NCollectionInfoGetRemoveCollectionChangedMethod | Retrieves the method which removes a "collection changed" event from a collection.
NCollectionInfoGetRemoveMethod | Retrieves the method which removes an item from the collection.
NCollectionInfoGetRemoveRangeMethod | Retrieves the method which removes a range of items from the collection.
NCollectionInfoGetSetCapacityMethod | Retrieves the method which sets the maximum number of items in the collection.
NCollectionInfoGetSetMethod | Retrieves the method which sets a value of an item in the collection.
NCollectionInfoGetToArrayMethod | Retrieves the method which converts the collection into an array.


NConsole Unit Functions

NConsole Unit Functions
Legend
Functions
Name | Description
NConsoleGetError | Gets the standard error output stream.
NConsoleGetIn | Gets the standard input stream.
NConsoleGetOut | Gets the standard output stream.
NConsoleReadChar | Reads the next character from the standard input stream.
NConsoleReadLine | Reads the next line from the standard input stream.
NConsoleSetError | Sets the standard error output stream.
NConsoleSetIn | Sets the standard input stream.
NConsoleSetOut | Sets the standard output stream.
NConsoleWrite | Writes the specified character to the standard output stream.
NConsoleWriteBoolean | Writes the specified boolean value to the standard output stream.
NConsoleWriteBooleanLine | Writes the specified boolean value, followed by the current line terminator, to the standard output stream.
NConsoleWriteChar | Writes the specified char value to the standard output stream.
NConsoleWriteCharLine | Writes the specified char value, followed by the current line terminator, to the standard output stream.
NConsoleWriteChars | Writes the specified char array value to the standard output stream.
NConsoleWriteCharsLine | Writes the specified char array value, followed by the current line terminator, to the standard output stream.
NConsoleWriteDouble | Writes the specified double value to the standard output stream.
NConsoleWriteDoubleLine | Writes the specified double value, followed by the current line terminator, to the standard output stream.
NConsoleWriteEmptyLine | Writes an empty line to the standard output stream.
NConsoleWriteFormat | Writes the specified format string to the standard output stream.
NConsoleWriteFormatLine | Writes the specified format string, followed by the current line terminator, to the standard output stream.
NConsoleWriteFormatLineVA | Writes the specified format string, followed by the current line terminator, to the standard output stream.
NConsoleWriteFormatVA | Writes the specified format string to the standard output stream.
NConsoleWriteInt32 | Writes the specified Int32 value to the standard output stream.
NConsoleWriteInt32Line | Writes the specified Int32 value, followed by the current line terminator, to the standard output stream.
NConsoleWriteInt64 | Writes the specified Int64 value to the standard output stream.
NConsoleWriteInt64Line | Writes the specified Int64 value, followed by the current line terminator, to the standard output stream.
NConsoleWriteLine | Writes the specified character to the standard output stream.
NConsoleWriteObject | Writes the specified object to the standard output stream.
NConsoleWriteObjectLine | Writes the specified object, followed by the current line terminator, to the standard output stream.
NConsoleWritePointer | Writes the specified pointer value to the standard output stream.
NConsoleWritePointerLine | Writes the specified pointer value, followed by the current line terminator, to the standard output stream.
NConsoleWriteResult | Writes the specified NResult value to the standard output stream.
NConsoleWriteResultLine | Writes the specified NResult value, followed by the current line terminator, to the standard output stream.
NConsoleWriteSSizeType | Writes the specified SSizeType value to the standard output stream.
NConsoleWriteSSizeTypeLine | Writes the specified SSizeType value, followed by the current line terminator, to the standard output stream.
NConsoleWriteSingle | Writes the specified single value to the standard output stream.
NConsoleWriteSingleLine | Writes the specified single value, followed by the current line terminator, to the standard output stream.
NConsoleWriteSizeType | Writes the specified SizeType value to the standard output stream.
NConsoleWriteSizeTypeLine | Writes the specified SizeType value, followed by the current line terminator, to the standard output stream.
NConsoleWriteUInt32 | Writes the specified UInt32 value to the standard output stream.
NConsoleWriteUInt32Line | Writes the specified UInt32 value, followed by the current line terminator, to the standard output stream.
NConsoleWriteUInt64 | Writes the specified UInt64 value to the standard output stream.
NConsoleWriteUInt64Line | Writes the specified UInt64 value, followed by the current line terminator, to the standard output stream.
NConsoleWriteValue | Writes the specified value to the standard output stream.
NConsoleWriteValueLine | Writes the specified value, followed by the current line terminator, to the standard output stream.
NConsoleWriteValueLineP | Writes the specified value, followed by the current line terminator, to the standard output stream.
NConsoleWriteValueP | Writes the specified value to the standard output stream.


NConsole Unit Macros

NConsole Unit Macros
Macros
Name | Description
NConsoleReadChar | Picks a Unicode (W) or ASCII (A) version of the NConsoleReadChar function.
NConsoleWrite | Picks a Unicode (W) or ASCII (A) version of the NConsoleWrite function.
NConsoleWriteChar | Picks a Unicode (W) or ASCII (A) version of the NConsoleWriteChar function.
NConsoleWriteCharLine | Picks a Unicode (W) or ASCII (A) version of the NConsoleWriteCharLine function.
NConsoleWriteChars | Picks a Unicode (W) or ASCII (A) version of the NConsoleWriteChars function.
NConsoleWriteCharsLine | Picks a Unicode (W) or ASCII (A) version of the NConsoleWriteCharsLine function.
NConsoleWriteFormat | Picks a Unicode (W) or ASCII (A) version of the NConsoleWriteFormat function.
NConsoleWriteFormatLine | Picks a Unicode (W) or ASCII (A) version of the NConsoleWriteFormatLine function.
NConsoleWriteFormatLineVA | Picks a Unicode (W) or ASCII (A) version of the NConsoleWriteFormatLineVA function.
NConsoleWriteFormatVA | Picks a Unicode (W) or ASCII (A) version of the NConsoleWriteFormatVA function.
NConsoleWriteLine | Picks a Unicode (W) or ASCII (A) version of the NConsoleWriteLine function.


NConstantInfo Unit Files

NConstantInfo Unit Files
Files
Name | Description
NConstantInfo.h | Header file for the NConstantInfo unit.


NConstantInfo Unit Functions

NConstantInfo Unit Functions
Legend
Functions
Name | Description
NConstantInfoGetConstantType | Retrieves the type of the specified constant.
NConstantInfoGetValue | Retrieves the value of the specified constant.


NConstantInfo.h Functions

NConstantInfo.h Functions
Legend
Functions
Name | Description
NConstantInfoGetConstantType | Retrieves the type of the specified constant.
NConstantInfoGetValue | Retrieves the value of the specified constant.


NCore Unit Files

NCore Unit Files
Files
Name | Description
NCore.h | Header file for the NCore module. Provides infrastructure/basic functionality for Neurotechnology components.


NCore Unit Functions

NCore Unit Functions
Legend
Functions
Name | Description
NCoreAddErrorSuppressedCallback | Adds a suppressed error callback to NCore.
NCoreAddErrorSuppressed | Adds a suppressed error event to NCore.
NCoreOnExitEx | This function should be called on program's exit.
NCoreOnStart | This function should be called on program's start.
NCoreRemoveErrorSuppressed | Removes a suppressed error event from NCore.
NCoreOnThreadExit | This function should be called when program's thread finished its task.
NCoreOnThreadStart | This function should be called when new thread is created.
NCoreRemoveErrorSuppressedCallback | Removes a suppressed error callback from NCore.


NCore.h Functions

NCore.h Functions
Legend
Functions
Name | Description
NCoreAddErrorSuppressed | Adds a suppressed error event to NCore.
NCoreAddErrorSuppressedCallback | Adds a suppressed error callback to NCore.
NCoreOnExitEx | This function should be called on program's exit.
NCoreOnStart | This function should be called on program's start.
NCoreOnThreadExit | This function should be called when program's thread finished its task.
NCoreOnThreadStart | This function should be called when new thread is created.
NCoreRemoveErrorSuppressed | Removes a suppressed error event from NCore.
NCoreRemoveErrorSuppressedCallback | Removes a suppressed error callback from NCore.


NCustomEventDescriptor Unit Files

NCustomEventDescriptor Unit Files
Files
Name | Description
NCustomEventDescriptor.h | Header file for the NCustomEventDescriptor unit.


NCustomEventDescriptor Unit Functions

NCustomEventDescriptor Unit Functions
Legend
Functions
Name | Description
NCustomEventDescriptorGetData | Retrieves the data of the specified descriptor.


NCustomEventDescriptor.h Functions

NCustomEventDescriptor.h Functions
Legend
Functions
Name | Description
NCustomEventDescriptorGetData | Retrieves the data of the specified descriptor.


NCustomMethodDescriptor Unit Files

NCustomMethodDescriptor Unit Files
Files
Name | Description
NCustomMethodDescriptor.h | Header file for the NCustomMethodDescriptor unit.


NCustomMethodDescriptor Unit Functions

NCustomMethodDescriptor Unit Functions
Legend
Functions
Name | Description
NCustomMethodDescriptorGetData | Retrieves the data of the specified descriptor.


NCustomMethodDescriptor.h Functions

NCustomMethodDescriptor.h Functions
Legend
Functions
Name | Description
NCustomMethodDescriptorGetData | Retrieves the data of the specified descriptor.


NCustomParameterDescriptor Unit Files

NCustomParameterDescriptor Unit Files
Files
Name | Description
NCustomParameterDescriptor.h | Header file for the NCustomParameterDescriptor unit.


NCustomParameterDescriptor Unit Functions

NCustomParameterDescriptor Unit Functions
Legend
Functions
Name | Description
NCustomParameterDescriptorCreate | Creates a new custom parameter descriptor.
NCustomParameterDescriptorGetData | Retrieves the data of the specified descriptor.


NCustomParameterDescriptor.h Functions

NCustomParameterDescriptor.h Functions
Legend
Functions
Name | Description
NCustomParameterDescriptorCreate | Creates a new custom parameter descriptor.
NCustomParameterDescriptorGetData | Retrieves the data of the specified descriptor.


NCustomPropertyDescriptor Unit Files

NCustomPropertyDescriptor Unit Files
Files
Name | Description
NCustomPropertyDescriptor.h | Header file for the NCustomPropertyDescriptor unit.


NCustomPropertyDescriptor Unit Functions

NCustomPropertyDescriptor Unit Functions
Legend
Functions
Name | Description
NCustomPropertyDescriptorGetData | Retrieves the data of the specified descriptor.


NCustomPropertyDescriptor.h Functions

NCustomPropertyDescriptor.h Functions
Legend
Functions
Name | Description
NCustomPropertyDescriptorGetData | Retrieves the data of the specified descriptor.


NCustomStream Unit Functions

NCustomStream Unit Functions
Legend
Functions
Name | Description
NCustomStreamCreate | Creates a custom stream.


NDateTime Unit Functions

NDateTime Unit Functions
Legend
Functions
Name | Description
NDateTimeAddDays | Adds the specified number of days to the value of the specified instance.
NDateTimeAddHours | Adds the specified number of hours to the value of the specified instance.
NDateTimeAddMilliseconds | Adds the specified number of milliseconds to the value of the specified instance.
NDateTimeAddMinutes | Adds the specified number of minutes to the value of the specified instance.
NDateTimeAddMonths | Adds the specified number of months to the value of the specified instance.
NDateTimeAddSeconds | Adds the specified number of seconds to the value of the specified instance.
NDateTimeAddTicks | Adds the specified number of ticks to the value of the specified instance.
NDateTimeAddTimeSpan | Adds the specified TimeSpan to the value of the specified instance.
NDateTimeAddYears | Adds the specified number of years to the value of the specified instance.
NDateTimeCompare | Compares two instances of DateTime and returns an indication of their relative values.
NDateTimeCreate | Initializes a new instance of the DateTime structure to the specified year, month, day, hour, minute, second and millisecond.
NDateTimeCreateDate | Initializes a new instance of the DateTime structure to the specified year, month and day.
NDateTimeCreateFromTicks | Initializes a new instance of the DateTime structure from the specified number of ticks.
NDateTimeDaysInMonth | Gets the number of days the specified month of the specified year.
NDateTimeDecode | Decodes the specified DateTime instance.
NDateTimeGetDate | Gets the date (year, month and day) represented by the specified DateTime instance.
NDateTimeGetDay | Gets the day represented by the specified DateTime instance.
NDateTimeGetDayOfWeek | Gets the day of the week represented by the specified DateTime instance.
NDateTimeGetDayOfYear | Gets the day of the year represented by the specified DateTime instance.
NDateTimeGetHour | Gets the hour represented by the specified DateTime instance.
NDateTimeGetMillisecond | Gets the millisecond represented by the specified DateTime instance.
NDateTimeGetMinute | Gets the minute represented by the specified DateTime instance.
NDateTimeGetMonth | Gets the month represented by the specified DateTime instance.
NDateTimeGetNow | Gets current time of day.
NDateTimeGetSecond | Gets the second represented by the specified DateTime instance.
NDateTimeGetTicks | Gets the number of ticks that represent the specified DateTime instance.
NDateTimeGetTimeOfDay | Gets the time of the day (hour, minute and second) represented by the specified DateTime instance.
NDateTimeGetToday | Gets today's date.
NDateTimeGetUtcNow | Gets the current Coordinated Universal Time.
NDateTimeGetYear | Gets the year represented by the specified DateTime instance.
NDateTimeIsDateTimeValid | Checks whether the specified date and time are valid.
NDateTimeIsDateValid | Checks whether the specified date is valid.
NDateTimeIsLeapYear | Checks whether the specified year is a leap year (366 days).
NDateTimeIsValid | Checks whether the specified DateTime instance is valid.
NDateTimeSubtract | Subtracts a DateTime instance from another DateTime instance.
NDateTimeSubtractTimeSpan | Subtracts the specified TimeSpan from the specified DateTime.
NDateTimeToLocalTime | Converts the specified DateTime to local time.
NDateTimeToString | Gets a string representation of the specified DateTime.
NDateTimeToUniversalTime | Converts the specified DateTime to Coordinated Universal Time.


NDateTime Unit Macros

NDateTime Unit Macros
Macros
Name | Description
NDateTimeToString | Picks a Unicode (W) or ASCII (A) version of the NDateTimeToString function.
N_DATE_TIME_MAX | Maximum DateTime value.
N_DATE_TIME_MIN | Minimum DateTime value.


NDateTime Unit Structs, Records, Enums

NDateTime Unit Structs, Records, Enums
Legend
Structs, Records, Enums
Name | Description
NDayOfWeek_ | Enumerates the days of the week.
NDayOfWeek | Enumerates the days of the week.


NDateTime Unit Types

NDateTime Unit Types
Types
Name | Description
NDateTime_ | The DateTime instance.


NDefs Unit Macros

NDefs Unit Macros
Macros
Name | Description
N_64 | Defined if compiling for 64-bit architecture.
N_ALIGN | Controls the alignment of user-defined data
N_ANSI_C | Defined if ANSI C language compliance is enabled in compiler.
N_API | Defines calling conventions for functions. Tells the compiler that the declared function and the functions it calls never throw an exception.
N_API_PTR_RET | Defines calling conventions for functions. Tells the compiler that the declared function and the functions it calls never throw an exception. Used for functions that return a pointer.
N_AW | Picks either ANSI or Unicode (if N_UNICODE is defined) version in a macro (with either 'A' or 'W' suffix accordingly).
N_BIG_ENDIAN | Defined if compiling for big-endian processor architecture.
N_CALLBACK | Callback.
N_CALLBACK_AW | Picks either ANSI or Unicode (if N_UNICODE is defined) version of the callback (with either 'A' or 'W' suffix accordingly).
N_CALL_CONV | Defines calling conventions for functions.
N_CPP | Defined if compiling as C++ code.
N_DEBUG | Defined if compiling in debug mode.
N_DEPRECATED | Indicates that a function, type, or any other identifier may no longer be supported in a future release or should no longer be used.
N_EMPTY_STRING | ANSI or Unicode (if N_UNICODE is defined) string, representing empty string value.
N_EMPTY_STRINGA | ANSI string, representing empty string value.
N_EMPTY_STRINGW | Unicode (if N_UNICODE is defined) string, representing empty string value.
N_FIELD_AW | Picks either ANSI or Unicode (if N_UNICODE is defined) version of the field (with either 'A' or 'W' suffix accordingly).
N_FUNC_AW | Picks either ANSI or Unicode (if N_UNICODE is defined) version of the function (with either 'A' or 'W' suffix accordingly).
N_GCC | Defined if compiling with GCC.
N_JOIN_SYMBOLS | Concatenates two symbols, yielding a single concatenated symbol.
N_JOIN_SYMBOLS2 | Concatenates two symbols, yielding a single concatenated symbol.
N_JOIN_SYMBOLS2_ | Concatenates two symbols, yielding a single concatenated symbol. Can serve as a macro argument.
N_JOIN_SYMBOLS_ | Concatenates two symbols, yielding a single concatenated symbol. Can serve as a macro argument.
N_LIB | Defined if compiling static library.
N_LIKELY | Used for Linux branching optimization.
N_LINUX | Defined if compiling for Linux.
N_MAC | Defined if compiling for Mac OS.
N_MACRO_AW | Picks either ANSI or Unicode (if N_UNICODE is defined) version of the macro (with either 'A' or 'W' suffix accordingly).
N_MSVC | Defined if compiling with Microsoft Visual C++.
N_NEW_LINE | Picks a Unicode (W) or ASCII (A) version of the N_NEW_LINE macro.
N_NO_ANSI_FUNC | Defined if compiling for platform without ANSI versions of the functions support.
N_NO_INLINE | Tells the compiler to never inline a particular member function (function in a class).
N_NO_INT_64 | Defined if compiling for platform without 64-bit integer types support.
N_NO_RETURN | Tells the compiler that a function does not return.
N_NO_THROW | Tells the compiler that the declared function and the functions it calls never throw an exception.
N_NO_UNICODE | Defined if compiling for platform without Unicode versions of the functions support.
N_PACKED | Struct packing/alignment.
N_RETURN_ADDRESS | The memory address a return statement hands control of a computer program to.
N_STATIC_ASSERT | Evaluate an expression at compile time and generate an error when the result is NFalse.
N_STRINGIZE | Defines the size of ANSI or Unicode (if N_UNICODE is defined) string.
N_STRINGIZEA | Defines the size of ANSI string.
N_STRINGIZEW | Defines the size of Unicode (if N_UNICODE is defined) string.
N_STRINGIZE_ | Defines the size of ANSI or Unicode (if N_UNICODE is defined) string. Can serve as a macro argument.
N_STRINGIZE_A | Defines the size of ANSI string. Can serve as a macro argument.
N_STRINGIZE_W | Defines the size of Unicode (if N_UNICODE is defined) string. Can serve as a macro argument.
N_STRUCT_AW | Picks either ANSI or Unicode (if N_UNICODE is defined) version of the struct (with either 'A' or 'W' suffix accordingly).
N_SYMBOL_AW | Picks either ANSI or Unicode (if N_UNICODE is defined) version of the symbol (with either 'A' or 'W' suffix accordingly).
N_T | Makes either ANSI or Unicode (if N_UNICODE is defined) string or character constant.
N_TA | Makes ANSI string or character constant.
N_TRACE | Defined if trace output is enabled during compilation.
N_TW | Makes Unicode (if N_UNICODE is defined) string or character constant.
N_TYPE_AW | Picks either ANSI or Unicode (if N_UNICODE is defined) version of the type (with either 'A' or 'W' suffix accordingly).
N_T_A | Makes ANSI string or character constant. Can serve as a macro argument.
N_T_W | Makes Unicode (if N_UNICODE is defined) string or character constant. Can serve as a macro argument.
N_UNICODE | Defined if compiling with Unicode character set (affects NChar type).
N_UNLIKELY | Used for Linux branching optimization.
N_VAR_AW | Picks either ANSI or Unicode (if N_UNICODE is defined) version of the variable (with either 'A' or 'W' suffix accordingly).
N_WINDOWS | Defined if compiling for Windows.


NDescriptor Unit Files

NDescriptor Unit Files
Files
Name | Description
NDescriptor.h | Header file for the NDescriptor unit.


NDescriptor Unit Functions

NDescriptor Unit Functions
Legend
Functions
Name | Description
NDescriptorGetAttributes | Retrieves the attributes of the specified descriptor.
NDescriptorGetName | Retrieves the name of the specified descriptor.


NDescriptor.h Functions

NDescriptor.h Functions
Legend
Functions
Name | Description
NDescriptorGetAttributes | Retrieves the attributes of the specified descriptor.
NDescriptorGetName | Retrieves the name of the specified descriptor.


NDictionary Unit Files

NDictionary Unit Files
Files
Name | Description
NDictionary.h | Header file for the NDictionary module.


NDictionary Unit Functions

NDictionary Unit Functions
Legend
Functions
Name | Description
NDictionaryAdd | Adds a value to the specified dictionary.
NDictionaryAddCollectionChanged | Adds a user-specified "collection changed" event to the specified dictionary.
NDictionaryAddCollectionChangedCallback | Adds a user-specified "collection changed" event callback to the specified dictionary.
NDictionaryAddItemCollectionChanged | Adds a user-specified "item collection changed" event to the specified dictionary.
NDictionaryAddItemCollectionChangedCallback | Adds a user-specified "item collection changed" event callback to the specified dictionary.
NDictionaryAddItemPair | Adds a pair item to the specified dictionary.
NDictionaryAddPair | Adds a pair item to the specified dictionary.
NDictionaryClear | Clears the specified dictionary.
NDictionaryContains | Checks whether the specified dictionary contains a value specified by its key.
NDictionaryGet | Retrieves the value specified by key from the specified dictionary.
NDictionaryGetAt | Retrieves the item specified by index from the specified dictionary.
NDictionaryGetCount | Retrieves the number of items in the specified dictionary.
NDictionaryGetItemAt | Retrieves the item specified by index from the specified dictionary.
NDictionaryGetKey | Retrieves the key of an item specified by index from the specified dictionary.
NDictionaryGetKeys | Retrieves all keys from the specified dictionary.
NDictionaryGetValue | Retrieves the value of an item specified by index from the specified dictionary.
NDictionaryGetValues | Retrieves all values from the specified dictionary.
NDictionaryIsReadOnly | Checks whether the specified dictionary is read-only.
NDictionaryRemove | Removes the value specified by key from the specified dictionary.
NDictionaryRemoveAt | Removes an item specified by index from the specified dictionary.
NDictionaryRemoveCollectionChanged | Removes a user-specified "collection changed" event from the specified dictionary.
NDictionaryRemoveCollectionChangedCallback |
NDictionaryRemoveItemCollectionChanged | Removes a user-specified "item collection changed" event from the specified dictionary.
NDictionaryRemoveItemCollectionChangedCallback |
NDictionarySet | Sets the value specified by key in the specified dictionary.
NDictionaryToArray | Converts the specified dictionary to an array.
NDictionaryToItemArray | Converts the specified dictionary to an array of items.
NDictionaryToKeyArray | Converts the specified dictionary to an array of keys.
NDictionaryToValueArray | Converts the specified dictionary to an array of values.
NDictionaryTryGet | Attempts to retrieve the value specified by key from the specified dictionary and returns a Boolean value indicating the success.


NDictionary.h Functions

NDictionary.h Functions
Legend
Functions
Name | Description
NDictionaryAdd | Adds a value to the specified dictionary.
NDictionaryAddCollectionChanged | Adds a user-specified "collection changed" event to the specified dictionary.
NDictionaryAddCollectionChangedCallback | Adds a user-specified "collection changed" event callback to the specified dictionary.
NDictionaryAddItemCollectionChanged | Adds a user-specified "item collection changed" event to the specified dictionary.
NDictionaryAddItemCollectionChangedCallback | Adds a user-specified "item collection changed" event callback to the specified dictionary.
NDictionaryAddItemPair | Adds a pair item to the specified dictionary.
NDictionaryAddPair | Adds a pair item to the specified dictionary.
NDictionaryClear | Clears the specified dictionary.
NDictionaryContains | Checks whether the specified dictionary contains a value specified by its key.
NDictionaryGet | Retrieves the value specified by key from the specified dictionary.
NDictionaryGetAt | Retrieves the item specified by index from the specified dictionary.
NDictionaryGetCount | Retrieves the number of items in the specified dictionary.
NDictionaryGetItemAt | Retrieves the item specified by index from the specified dictionary.
NDictionaryGetKey | Retrieves the key of an item specified by index from the specified dictionary.
NDictionaryGetKeys | Retrieves all keys from the specified dictionary.
NDictionaryGetValue | Retrieves the value of an item specified by index from the specified dictionary.
NDictionaryGetValues | Retrieves all values from the specified dictionary.
NDictionaryIsReadOnly | Checks whether the specified dictionary is read-only.
NDictionaryRemove | Removes the value specified by key from the specified dictionary.
NDictionaryRemoveAt | Removes an item specified by index from the specified dictionary.
NDictionaryRemoveCollectionChanged | Removes a user-specified "collection changed" event from the specified dictionary.
NDictionaryRemoveCollectionChangedCallback |
NDictionaryRemoveItemCollectionChanged | Removes a user-specified "item collection changed" event from the specified dictionary.
NDictionaryRemoveItemCollectionChangedCallback |
NDictionarySet | Sets the value specified by key in the specified dictionary.
NDictionaryToArray | Converts the specified dictionary to an array.
NDictionaryToItemArray | Converts the specified dictionary to an array of items.
NDictionaryToKeyArray | Converts the specified dictionary to an array of keys.
NDictionaryToValueArray | Converts the specified dictionary to an array of values.
NDictionaryTryGet | Attempts to retrieve the value specified by key from the specified dictionary and returns a Boolean value indicating the success.


NDictionaryInfo Unit Files

NDictionaryInfo Unit Files
Files
Name | Description
NDictionaryInfo.h | Header file for the NDictionaryInfo unit.


NDictionaryInfo Unit Functions

NDictionaryInfo Unit Functions
Legend
Functions
Name | Description
NDictionaryInfoGetAddCollectionChangedCallbackMethod | Retrieves the method which adds a "collection changed" event callback to a dictionary.
NDictionaryInfoGetAddCollectionChangedMethod | Retrieves the method which adds a "collection changed" event to a dictionary.
NDictionaryInfoGetAddMethod | Retrieves the method which adds an item to a dictionary.
NDictionaryInfoGetAddPairMethod | Retrieves the method which adds a key-value pair to a dictionary.
NDictionaryInfoGetClearMethod | Retrieves the method which clears the dictionary.
NDictionaryInfoGetContainsMethod | Retrieves the method which checks whether a dictionary contains a specific value.
NDictionaryInfoGetGetAtMethod | Retrieves the method which gets an item in the dictionary specified by index.
NDictionaryInfoGetGetCountMethod | Retrieves the method which gets the number of items in the dictionary.
NDictionaryInfoGetGetKeyMethod | Retrieves the method which gets a key of an item in the dictionary.
NDictionaryInfoGetGetMethod | Retrieves the method which gets an item in the dictionary.
NDictionaryInfoGetGetValueMethod | Retrieves the method which gets a value of an item in the dictionary.
NDictionaryInfoGetItemAttributes | Retrieves the attributes of the items in the dictionary.
NDictionaryInfoGetItemType | Retrieves the type of the items in the dictionary.
NDictionaryInfoGetKeyAttributes | Retrieves the attributes of the item keys in the dictionary.
NDictionaryInfoGetKeyFormat | Retrieves the format of the item keys in the dictionary.
NDictionaryInfoGetKeyMaxValue | Retrieves the maximal item key value of the dictionary.
NDictionaryInfoGetKeyMinValue | Retrieves the minimal item key value of the dictionary.
NDictionaryInfoGetKeyStdValue | Retrieves the specified standard item key value of the dictionary.
NDictionaryInfoGetKeyStdValueCount | Retrieves the number of standard item key values of the dictionary.
NDictionaryInfoGetKeyStdValues | Retrieves all standard item key values of the dictionary.
NDictionaryInfoGetKeyType | Retrieves the type of the item keys in the dictionary.
NDictionaryInfoGetRemoveAtMethod | Retrieves the method which removes an item with specific index from the dictionary.
NDictionaryInfoGetRemoveCollectionChangedCallbackMethod | Retrieves the method which removes a "collection changed" event callback from a dictionary.
NDictionaryInfoGetRemoveCollectionChangedMethod | Retrieves the method which removes a "collection changed" event from a dictionary.
NDictionaryInfoGetRemoveMethod | Retrieves the method which removes an item from the dictionary.
NDictionaryInfoGetSetMethod | Retrieves the method which sets a value of an item in the dictionary.
NDictionaryInfoGetToArrayMethod | Retrieves the method which converts the dictionary into an array.
NDictionaryInfoGetToKeyArrayMethod | Retrieves the method which converts the dictionary into an array of item keys.
NDictionaryInfoGetToValueArrayMethod | Retrieves the method which converts the dictionary into an array of item values.
NDictionaryInfoGetTryGetMethod | Retrieves the method which gets an item in the dictionary and returns a Boolean value indicating success.
NDictionaryInfoGetValueAttributes | Retrieves the attributes of the item values in the dictionary.
NDictionaryInfoGetValueFormat | Retrieves the format of the item values in the dictionary.
NDictionaryInfoGetValueMaxValue | Retrieves the maximal item value of the dictionary.
NDictionaryInfoGetValueMinValue | Retrieves the minimal item value of the dictionary.
NDictionaryInfoGetValueStdValue | Retrieves the specified standard item value of the dictionary.
NDictionaryInfoGetValueStdValueCount | Retrieves the number of standard item values of the dictionary.
NDictionaryInfoGetValueStdValues | Retrieves all standard item values of the dictionary.
NDictionaryInfoGetValueType | Retrieves the type of the item values in the dictionary.


NDictionaryInfo.h Functions

NDictionaryInfo.h Functions
Legend
Functions
Name | Description
NDictionaryInfoGetAddCollectionChangedCallbackMethod | Retrieves the method which adds a "collection changed" event callback to a dictionary.
NDictionaryInfoGetAddCollectionChangedMethod | Retrieves the method which adds a "collection changed" event to a dictionary.
NDictionaryInfoGetAddMethod | Retrieves the method which adds an item to a dictionary.
NDictionaryInfoGetAddPairMethod | Retrieves the method which adds a key-value pair to a dictionary.
NDictionaryInfoGetClearMethod | Retrieves the method which clears the dictionary.
NDictionaryInfoGetContainsMethod | Retrieves the method which checks whether a dictionary contains a specific value.
NDictionaryInfoGetGetAtMethod | Retrieves the method which gets an item in the dictionary specified by index.
NDictionaryInfoGetGetCountMethod | Retrieves the method which gets the number of items in the dictionary.
NDictionaryInfoGetGetKeyMethod | Retrieves the method which gets a key of an item in the dictionary.
NDictionaryInfoGetGetMethod | Retrieves the method which gets an item in the dictionary.
NDictionaryInfoGetGetValueMethod | Retrieves the method which gets a value of an item in the dictionary.
NDictionaryInfoGetItemAttributes | Retrieves the attributes of the items in the dictionary.
NDictionaryInfoGetItemType | Retrieves the type of the items in the dictionary.
NDictionaryInfoGetKeyAttributes | Retrieves the attributes of the item keys in the dictionary.
NDictionaryInfoGetKeyFormat | Retrieves the format of the item keys in the dictionary.
NDictionaryInfoGetKeyMaxValue | Retrieves the maximal item key value of the dictionary.
NDictionaryInfoGetKeyMinValue | Retrieves the minimal item key value of the dictionary.
NDictionaryInfoGetKeyStdValue | Retrieves the specified standard item key value of the dictionary.
NDictionaryInfoGetKeyStdValueCount | Retrieves the number of standard item key values of the dictionary.
NDictionaryInfoGetKeyStdValues | Retrieves all standard item key values of the dictionary.
NDictionaryInfoGetKeyType | Retrieves the type of the item keys in the dictionary.
NDictionaryInfoGetRemoveAtMethod | Retrieves the method which removes an item with specific index from the dictionary.
NDictionaryInfoGetRemoveCollectionChangedCallbackMethod | Retrieves the method which removes a "collection changed" event callback from a dictionary.
NDictionaryInfoGetRemoveCollectionChangedMethod | Retrieves the method which removes a "collection changed" event from a dictionary.
NDictionaryInfoGetRemoveMethod | Retrieves the method which removes an item from the dictionary.
NDictionaryInfoGetSetMethod | Retrieves the method which sets a value of an item in the dictionary.
NDictionaryInfoGetToArrayMethod | Retrieves the method which converts the dictionary into an array.
NDictionaryInfoGetToKeyArrayMethod | Retrieves the method which converts the dictionary into an array of item keys.
NDictionaryInfoGetToValueArrayMethod | Retrieves the method which converts the dictionary into an array of item values.
NDictionaryInfoGetTryGetMethod | Retrieves the method which gets an item in the dictionary and returns a Boolean value indicating success.
NDictionaryInfoGetValueAttributes | Retrieves the attributes of the item values in the dictionary.
NDictionaryInfoGetValueFormat | Retrieves the format of the item values in the dictionary.
NDictionaryInfoGetValueMaxValue | Retrieves the maximal item value of the dictionary.
NDictionaryInfoGetValueMinValue | Retrieves the minimal item value of the dictionary.
NDictionaryInfoGetValueStdValue | Retrieves the specified standard item value of the dictionary.
NDictionaryInfoGetValueStdValueCount | Retrieves the number of standard item values of the dictionary.
NDictionaryInfoGetValueStdValues | Retrieves all standard item values of the dictionary.
NDictionaryInfoGetValueType | Retrieves the type of the item values in the dictionary.


NDirectory Unit Functions

NDirectory Unit Functions
Legend
Functions
Name | Description
NDirectoryExists | Checks whether the specified directory exists.


NDirectory Unit Macros

NDirectory Unit Macros
Macros
Name | Description
NDirectoryExists | Picks a Unicode (W) or ASCII (A) version of the NDirectoryExists function.


NEncoding Unit Functions

NEncoding Unit Functions
Legend
Functions
Name | Description
NEncodingConvert | Converts a range of bytes in a byte array from one encoding to another and writes the converted data to a new buffer.
NEncodingDetect | Detects the encoding of the specified data.
NEncodingGetBytes | Encodes a character into the specified byte array.
NEncodingGetBytesForChars | Encodes a set of characters from the specified character array into the specified byte array.
NEncodingGetChars | Decodes all the bytes in the specified byte array into a set of characters.
NEncodingGetMaxByteCount | Calculates the maximum number of bytes produced by encoding the specified number of characters.
NEncodingGetMaxCharCount | Calculates the maximum number of characters produced by decoding the specified number of bytes.
NEncodingGetMinBytesPerChar | Gets the minimum number of bytes used to encode one character.
NEncodingGetPreamble | Returns a sequence of bytes that specifies the encoding used.
NEncodingGetPreambleLength | Gets the length of the preamble of the specified encoding.
NEncodingGetStringN | Decodes all the bytes in the specified byte array into a string.
NEncodingIsSingleByte | Gets a value indicating whether the specified encoding uses single-byte code points.
NEncodingIsValid | Checks whether the specified encoding is valid.


NEncoding Unit Macros

NEncoding Unit Macros
Macros
Name | Description
NEncodingGetBytes | Picks a Unicode (W) or ASCII (A) version of the NEncodingGetBytes function.
NEncodingGetBytesForChars | Picks a Unicode (W) or ASCII (A) version of the NEncodingGetBytesForChars function.
NEncodingGetChars | Picks a Unicode (W) or ASCII (A) version of the NEncodingGetChars function.
NEncodingGetMaxByteCount | Picks a Unicode (W) or ASCII (A) version of the NEncodingGetMaxByteCount function.
NEncodingGetMaxCharCount | Picks a Unicode (W) or ASCII (A) version of the NEncodingGetMaxCharCount function.
N_ACHAR_ENCODING | Specifies AChar encoding.
N_CHAR_ENCODING | Specifies Char encoding.
N_WCHAR_ENCODING | Specifies WChar encoding.


NEncoding Unit Structs, Records, Enums

NEncoding Unit Structs, Records, Enums
Legend
Structs, Records, Enums
Name | Description
NEncoding_ | Enumerates encoding types.


NEnum Unit Functions

NEnum Unit Functions
Legend
Functions
Name | Description
NEnumGetValues | Gets NEnum values as an array.
NEnumParseN | ... more
NEnumParseP | ... more
NEnumToStringN | Converts NEnum value specified as NInt to string.
NEnumToStringP | Converts NEnum value specified as NInt to string.
NEnumTryParseN | Converts the string representation of the name of enumerated constant to an equivalent NInt.
NEnumTryParseP | Converts the string representation of the name of enumerated constant to an equivalent NInt.


NEnumConstantInfo Unit Files

NEnumConstantInfo Unit Files
Files
Name | Description
NEnumConstantInfo.h | Header file for the NEnumConstantInfo unit.


NEnumConstantInfo Unit Functions

NEnumConstantInfo Unit Functions
Legend
Functions
Name | Description
NEnumConstantInfoGetValue | Retrieves the value of the specified enumeration constant.


NEnumConstantInfo.h Functions

NEnumConstantInfo.h Functions
Legend
Functions
Name | Description
NEnumConstantInfoGetValue | Retrieves the value of the specified enumeration constant.


NEnvironment Unit Files

NEnvironment Unit Files
Files
Name | Description
NEnvironment.h | Header file for the NEnvironment unit.


NEnvironment Unit Functions

NEnvironment Unit Functions
Legend
Functions
Name | Description
NEnvironmentGetCallStack | Retrieves the call stack information.
NEnvironmentGetCurrentDirectory | Retrieves the path of the current working directory.
NEnvironmentGetSystemDirectory | Retrieves the path of the system directory.


NEnvironment.h Functions

NEnvironment.h Functions
Legend
Functions
Name | Description
NEnvironmentGetCallStack | Retrieves the call stack information.
NEnvironmentGetCurrentDirectory | Retrieves the path of the current working directory.
NEnvironmentGetSystemDirectory | Retrieves the path of the system directory.


NError Unit Files

NError Unit Files
Files
Name | Description
NError.h | ... more


NError Unit Functions

NError Unit Functions
Legend
Functions
Name | Description
NCallStackEntryCopy |
NCallStackEntryCreate | Creates a line and adds it to NCallStack.
NCallStackEntryDispose | Frees the specified call stack entry.
NCallStackEntrySet | Copies a call stack entry and returns a pointer to the new copy. Frees the source stack entry.
NErrorAppend | Adds a line to NCallStack.
NErrorCapture | Captures an exception thrown by the specified result.
NErrorCreate | Creates a new exception.
NErrorGetCallStackCount | Retrieves the count of call stack entries.
NErrorGetCallStackEntry | Retrieves a certain call stack entry.
NErrorGetCallStackN | Retrieves the last entry of the call stack.
NErrorGetCodeEx | Retrieves the code of the error.
NErrorGetDefaultMessageN | Retrieves the default error message.
NErrorGetExternalCallStackN | Retrieves an external call stack entry with specified size.
NErrorGetExternalErrorEx | Retrieves an external error.
NErrorGetInnerErrorAt | Retrieves the specified inner error from the specified exception.
NErrorGetInnerErrorCount | Retrieves the number of inner errors in the specified exception.
NErrorGetInnerErrorEx | Retrieves an inner error.
NErrorGetLastEx | Retrieves the error information pointer set by the previous call to NErrorSetLastEx
NErrorGetLastSysError | Retrieves the last system error.
NErrorGetLastWin32Error | Retrieves the last Win32 error.
NErrorGetMacErrorMessageN | Retrieves the message of the a specific Mac error.
NErrorGetMachErrorMessageN | Retrieves the message of the a specific Mach error.
NErrorGetMessageN | Retrieves the message of the a specific error.
NErrorGetParamN | Retrieves the parameters of an error.
NErrorGetSysErrorMessageN | Retrieves the message of the a specific system error.
NErrorGetWin32ErrorMessageN | Retrieves the message of the a specific Win32 error.
NErrorRaise | Raises the specified error.
NErrorReport | Prints the last error out in stderr or debugger output.
NErrorReportEx | Prints the specified error out in stderr or debugger output.
NErrorSetCom | Creates the error information object for the current logical thread of execution (COM error only).
NErrorSetComMPN | Creates the error information object for the current logical thread of execution (COM error only).
NErrorSetComN | Creates the error information object for the current logical thread of execution (COM error only).
NErrorSetComPN | Creates the error information object for the current logical thread of execution (COM error only).
NErrorSetLast | Creates the error information object for the current logical thread of execution.
NErrorSetLastEx | Sets the error information object for the current logical thread of execution.
NErrorSetLastMPN | Creates the error information object for the current logical thread of execution.
NErrorSetLastN | Creates the error information object for the current logical thread of execution.
NErrorSetLastPN | Creates the error information object for the current logical thread of execution.
NErrorSetMac | Creates the error information object for the current logical thread of execution (Mac only).
NErrorSetMacMPN | Creates the error information object for the current logical thread of execution (Mac only).
NErrorSetMacN | Creates the error information object for the current logical thread of execution (Mac only).
NErrorSetMacPN | Creates the error information object for the current logical thread of execution (Mac only).
NErrorSetMach | Creates the error information object for the current logical thread of execution (Mach only).
NErrorSetMachMPN | Creates the error information object for the current logical thread of execution (Mach only).
NErrorSetMachN | Creates the error information object for the current logical thread of execution (Mach only).
NErrorSetMachPN | Creates the error information object for the current logical thread of execution (Mach only).
NErrorSetSys | Creates the error information object for the current logical thread of execution (System errors only).
NErrorSetSysMPN | Creates the error information object for the current logical thread of execution (System errors only).
NErrorSetSysN | Creates the error information object for the current logical thread of execution (System errors only).
NErrorSetSysPN | Creates the error information object for the current logical thread of execution (System errors only).
NErrorSetWin32 | Creates the error information object for the current logical thread of execution (Win32 only).
NErrorSetWin32MPN | Creates the error information object for the current logical thread of execution (Win32 only).
NErrorSetWin32N | Creates the error information object for the current logical thread of execution (Win32 only).
NErrorSetWin32PN | Creates the error information object for the current logical thread of execution (Win32 only).
NErrorSuppress | Calls NCoreErrorSuppressed event with the error of the current thread.


Legend

Legend
Legend
Method
Structure


NError Unit Macros

NError Unit Macros
Macros
Name | Description
N_E_ARGUMENT | This error occurs when argument value is invalid.
NCallStackEntryCreate | Picks a Unicode (W) or ANSCII (A) version of the NCallStackEntryCreate function.
N_E_ARGUMENT_NULL | When argument value is NULL where non-NULL value was expected this error occurs.
NE_IS_DIRECTORY_ACCESS | ... more
N_E_ARGUMENT_OUT_OF_RANGE | Argument value is out of range.
NE_MERGE_CALL_STACK | Indicates that the current error's call stack must not be overridden, but merged with the current backtrace.
N_E_CLR | The Common language runtime (CLR) exception has occurred.
NE_NO_CALL_STACK | Indicates that the error's call stack does not get overridden when set (normally it gets overridden with the current backtrace).
N_E_COM | COM error has occurred.
NE_PRESERVE_INNER_ERROR | Indicates that the current error must not be overridden and that an InenrError must be created.
N_E_CORE | Standard error has occurred (for internal use).
NE_SKIP_ONE_FRAME | Indicates that additional frame(s) must be skipped.
N_E_END_OF_STREAM | This error occurs when is attempted to read file or buffer after its end.
NErrorAppend | Picks a Unicode (W) or ASCII (A) version of the NErrorAppend function.
N_E_EXTERNAL | Error in external code has occurred (for internal use).
NErrorSetCom | Picks a Unicode (W) or ASCII (A) version of the NErrorSetCom function.
N_E_FAILED | Unspecified error has occurred.
NErrorSetComMPN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetComMPN function.
N_E_FORMAT | This error occurs when format of argument value is invalid.
NErrorSetComPN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetComPN function.
N_E_INDEX_OUT_OF_RANGE | This error occurs when index is out of range (for internal use).
NErrorSetLast | Picks a Unicode (W) or ASCII (A) version of the NErrorSetLast function.
N_E_INVALID_OPERATION | Attempted to perform invalid operation.
NErrorSetLastMPN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetLastMPN function.
N_E_IO | Input/output error has occurred.
NErrorSetLastPN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetLastPN function.
N_E_NOT_ACTIVATED | Product not activated.
NErrorSetMac | Picks a Unicode (W) or ASCII (A) version of the NErrorSetMac function.
N_E_NOT_IMPLEMENTED | This error occurs when trying to use functionality which is not implemented yet.
NErrorSetMacMPN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetMacMPN function.
NErrorSetMacPN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetMacPN function.
N_E_NOT_SUPPORTED | This error occurs when trying to use functionality which is not supported.
NErrorSetMach | Picks a Unicode (W) or ASCII (A) version of the NErrorSetMach function.
N_E_NULL_REFERENCE | Null reference has occurred (for internal use).
NErrorSetMachMPN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetMachMPN function.
N_E_OUT_OF_MEMORY | This error occurs when there were not enough memory to proceed task.
NErrorSetMachPN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetMachPN function.
N_E_OVERFLOW | Arithmetic overflow has occurred.
NErrorSetSys | Picks a Unicode (W) or ASCII (A) version of the NErrorSetSys function.
NErrorSetSysMPN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetSysMPN function.
NErrorSetSysPN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetSysPN function.
N_E_SYS | System error.
NErrorSetWin32 | Picks a Unicode (W) or ASCII (A) version of the NErrorSetWin32 function.
N_E_WIN32 | Win32 error has occurred.
NErrorSetWin32MPN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetWin32MPN function.
NErrorSetWin32PN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetWin32PN function.
N_OK | This value is returned when no error has occurred.
N_E_ABANDONED_MUTEX | ... more
N_E_AGGREGATE | ... more
NFailed | Determines whether function result indicates error.
NSucceeded | Determines whether function result indicates success.
N_E_ARITHMETIC | The exception that is thrown for errors in an arithmetic, casting, or conversion operation.
N_E_BAD_IMAGE_FORMAT | The file image of a dynamic link library (DLL) or an executable program is invalid.
N_E_CPP | CPP error has occurred.
N_E_DIRECTORY_NOT_FOUND | A part of a file or directory cannot be found.
N_E_DLL_NOT_FOUND | The exception that is thrown when a DLL specified in a DLL import cannot be found.
N_E_DRIVE_NOT_FOUND | Trying to access a drive or share that is not available.
N_E_ENTRY_POINT_NOT_FOUND | An attempt to load a class failed due to the absence of an entry method.
N_E_FILE_FORMAT | This error occurs when an input file or a data stream that is supposed to conform to a certain file format specification is malformed.
N_E_FILE_LOAD | A managed assembly is found but cannot be loaded.
N_E_FILE_NOT_FOUND | The error that occurs when an attempt to access a file that does not exist on disk fails.
N_E_INVALID_CAST | The exception that is thrown for invalid casting or explicit conversion.
N_E_INVALID_ENUM_ARGUMENT | This error occurs when using invalid arguments that are enumerators.
N_E_JVM | JVM error has occurred.
N_E_KEY_NOT_FOUND | This error occurs when key was not found.
N_E_MAC | MAC error has occurred.
N_E_OPERATION_CANCELED | This error occurs when user operation was canceled.
N_E_PATH_TOO_LONG | A path or file name is longer than the system-defined maximum length.
N_E_SECURITY | The exception that is thrown when a security error is detected.
N_E_SOCKET | The exception that is thrown when a socket error occurs.
N_E_TIMEOUT | The time allotted for a process or operation has expired.


NError Unit Structs, Records, Enums

NError Unit Structs, Records, Enums
Legend
Structs, Records, Enums
Name | Description
NCallStackEntry_ | Represents NCallStackEntry properties. Properties consist of address, function, file and line.


See Also

See Also
See Also

For more information about product activation see Activation.pdf within documentation folder of SDK.


NError.h Functions

NError.h Functions
Legend
Functions
Name | Description
NCallStackEntryCopy |
NCallStackEntryCreate | Creates a line and adds it to NCallStack.
NCallStackEntryDispose | Frees the specified call stack entry.
NCallStackEntrySet | Copies a call stack entry and returns a pointer to the new copy. Frees the source stack entry.
NErrorAppend | Adds a line to NCallStack.
NErrorCapture | Captures an exception thrown by the specified result.
NErrorCreate | Creates a new exception.
NErrorGetCallStackCount | Retrieves the count of call stack entries.
NErrorGetCallStackEntry | Retrieves a certain call stack entry.
NErrorGetCallStackN | Retrieves the last entry of the call stack.
NErrorGetCodeEx | Retrieves the code of the error.
NErrorGetDefaultMessageN | Retrieves the default error message.
NErrorGetExternalCallStackN | Retrieves an external call stack entry with specified size.
NErrorGetExternalErrorEx | Retrieves an external error.
NErrorGetInnerErrorAt | Retrieves the specified inner error from the specified exception.
NErrorGetInnerErrorCount | Retrieves the number of inner errors in the specified exception.
NErrorGetInnerErrorEx | Retrieves an inner error.
NErrorGetLastEx | Retrieves the error information pointer set by the previous call to NErrorSetLastEx
NErrorGetLastSysError | Retrieves the last system error.
NErrorGetLastWin32Error | Retrieves the last Win32 error.
NErrorGetMacErrorMessageN | Retrieves the message of the a specific Mac error.
NErrorGetMachErrorMessageN | Retrieves the message of the a specific Mach error.
NErrorGetMessageN | Retrieves the message of the a specific error.
NErrorGetParamN | Retrieves the parameters of an error.
NErrorGetSysErrorMessageN | Retrieves the message of the a specific system error.
NErrorGetWin32ErrorMessageN | Retrieves the message of the a specific Win32 error.
NErrorRaise | Raises the specified error.
NErrorReport | Prints the last error out in stderr or debugger output.
NErrorReportEx | Prints the specified error out in stderr or debugger output.
NErrorSetCom | Creates the error information object for the current logical thread of execution (COM error only).
NErrorSetComMPN | Creates the error information object for the current logical thread of execution (COM error only).
NErrorSetComN | Creates the error information object for the current logical thread of execution (COM error only).
NErrorSetComPN | Creates the error information object for the current logical thread of execution (COM error only).
NErrorSetLast | Creates the error information object for the current logical thread of execution.
NErrorSetLastEx | Sets the error information object for the current logical thread of execution.
NErrorSetLastMPN | Creates the error information object for the current logical thread of execution.
NErrorSetLastN | Creates the error information object for the current logical thread of execution.
NErrorSetLastPN | Creates the error information object for the current logical thread of execution.
NErrorSetMac | Creates the error information object for the current logical thread of execution (Mac only).
NErrorSetMacMPN | Creates the error information object for the current logical thread of execution (Mac only).
NErrorSetMacN | Creates the error information object for the current logical thread of execution (Mac only).
NErrorSetMacPN | Creates the error information object for the current logical thread of execution (Mac only).
NErrorSetMach | Creates the error information object for the current logical thread of execution (Mach only).
NErrorSetMachMPN | Creates the error information object for the current logical thread of execution (Mach only).
NErrorSetMachN | Creates the error information object for the current logical thread of execution (Mach only).
NErrorSetMachPN | Creates the error information object for the current logical thread of execution (Mach only).
NErrorSetSys | Creates the error information object for the current logical thread of execution (System errors only).
NErrorSetSysMPN | Creates the error information object for the current logical thread of execution (System errors only).
NErrorSetSysN | Creates the error information object for the current logical thread of execution (System errors only).
NErrorSetSysPN | Creates the error information object for the current logical thread of execution (System errors only).
NErrorSetWin32 | Creates the error information object for the current logical thread of execution (Win32 only).
NErrorSetWin32MPN | Creates the error information object for the current logical thread of execution (Win32 only).
NErrorSetWin32N | Creates the error information object for the current logical thread of execution (Win32 only).
NErrorSetWin32PN | Creates the error information object for the current logical thread of execution (Win32 only).
NErrorSuppress | Calls NCoreErrorSuppressed event with the error of the current thread.


Legend

Legend
Legend
Structure
Method


NError.h Macros

NError.h Macros
Macros
Name | Description
NCallStackEntryCreate | Picks a Unicode (W) or ANSCII (A) version of the NCallStackEntryCreate function.
NE_IS_DIRECTORY_ACCESS | ... more
NE_MERGE_CALL_STACK | Indicates that the current error's call stack must not be overridden, but merged with the current backtrace.
NE_NO_CALL_STACK | Indicates that the error's call stack does not get overridden when set (normally it gets overridden with the current backtrace).
NE_PRESERVE_INNER_ERROR | Indicates that the current error must not be overridden and that an InenrError must be created.
NE_SKIP_ONE_FRAME | Indicates that additional frame(s) must be skipped.
NErrorAppend | Picks a Unicode (W) or ASCII (A) version of the NErrorAppend function.
NErrorSetCom | Picks a Unicode (W) or ASCII (A) version of the NErrorSetCom function.
NErrorSetComMPN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetComMPN function.
NErrorSetComPN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetComPN function.
NErrorSetLast | Picks a Unicode (W) or ASCII (A) version of the NErrorSetLast function.
NErrorSetLastMPN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetLastMPN function.
NErrorSetLastPN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetLastPN function.
NErrorSetMac | Picks a Unicode (W) or ASCII (A) version of the NErrorSetMac function.
NErrorSetMacMPN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetMacMPN function.
NErrorSetMacPN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetMacPN function.
NErrorSetMach | Picks a Unicode (W) or ASCII (A) version of the NErrorSetMach function.
NErrorSetMachMPN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetMachMPN function.
NErrorSetMachPN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetMachPN function.
NErrorSetSys | Picks a Unicode (W) or ASCII (A) version of the NErrorSetSys function.
NErrorSetSysMPN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetSysMPN function.
NErrorSetSysPN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetSysPN function.
NErrorSetWin32 | Picks a Unicode (W) or ASCII (A) version of the NErrorSetWin32 function.
NErrorSetWin32MPN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetWin32MPN function.
NErrorSetWin32PN | Picks a Unicode (W) or ASCII (A) version of the NErrorSetWin32PN function.
NFailed | Determines whether function result indicates error.
NSucceeded | Determines whether function result indicates success.
N_E_ABANDONED_MUTEX | ... more
N_E_AGGREGATE | ... more
N_E_ARGUMENT | This error occurs when argument value is invalid.
N_E_ARGUMENT_NULL | When argument value is NULL where non-NULL value was expected this error occurs.
N_E_ARGUMENT_OUT_OF_RANGE | Argument value is out of range.
N_E_ARITHMETIC | The exception that is thrown for errors in an arithmetic, casting, or conversion operation.
N_E_BAD_IMAGE_FORMAT | The file image of a dynamic link library (DLL) or an executable program is invalid.
N_E_CLR | The Common language runtime (CLR) exception has occurred.
N_E_COM | COM error has occurred.
N_E_CORE | Standard error has occurred (for internal use).
N_E_CPP | CPP error has occurred.
N_E_DIRECTORY_NOT_FOUND | A part of a file or directory cannot be found.
N_E_DLL_NOT_FOUND | The exception that is thrown when a DLL specified in a DLL import cannot be found.
N_E_DRIVE_NOT_FOUND | Trying to access a drive or share that is not available.
N_E_END_OF_STREAM | This error occurs when is attempted to read file or buffer after its end.
N_E_ENTRY_POINT_NOT_FOUND | An attempt to load a class failed due to the absence of an entry method.
N_E_EXTERNAL | Error in external code has occurred (for internal use).
N_E_FAILED | Unspecified error has occurred.
N_E_FILE_FORMAT | This error occurs when an input file or a data stream that is supposed to conform to a certain file format specification is malformed.
N_E_FILE_LOAD | A managed assembly is found but cannot be loaded.
N_E_FILE_NOT_FOUND | The error that occurs when an attempt to access a file that does not exist on disk fails.
N_E_FORMAT | This error occurs when format of argument value is invalid.
N_E_INDEX_OUT_OF_RANGE | This error occurs when index is out of range (for internal use).
N_E_INVALID_CAST | The exception that is thrown for invalid casting or explicit conversion.
N_E_INVALID_ENUM_ARGUMENT | This error occurs when using invalid arguments that are enumerators.
N_E_INVALID_OPERATION | Attempted to perform invalid operation.
N_E_IO | Input/output error has occurred.
N_E_JVM | JVM error has occurred.
N_E_KEY_NOT_FOUND | This error occurs when key was not found.
N_E_MAC | MAC error has occurred.
N_E_NOT_ACTIVATED | Product not activated.
N_E_NOT_IMPLEMENTED | This error occurs when trying to use functionality which is not implemented yet.
N_E_NOT_SUPPORTED | This error occurs when trying to use functionality which is not supported.
N_E_NULL_REFERENCE | Null reference has occurred (for internal use).
N_E_OPERATION_CANCELED | This error occurs when user operation was canceled.
N_E_OUT_OF_MEMORY | This error occurs when there were not enough memory to proceed task.
N_E_OVERFLOW | Arithmetic overflow has occurred.
N_E_PATH_TOO_LONG | A path or file name is longer than the system-defined maximum length.
N_E_SECURITY | The exception that is thrown when a security error is detected.
N_E_SOCKET | The exception that is thrown when a socket error occurs.
N_E_SYS | System error.
N_E_TIMEOUT | The time allotted for a process or operation has expired.
N_E_WIN32 | Win32 error has occurred.
N_OK | This value is returned when no error has occurred.


NError.h Structures

NError.h Structures
Legend
Structures
Name | Description
NCallStackEntry_ | Represents NCallStackEntry properties. Properties consist of address, function, file and line.


NEvent Unit Files

NEvent Unit Files
Files
Name | Description
NEvent.h | Header file for the NEvent unit.


NEvent Unit Functions

NEvent Unit Functions
Legend
Functions
Name | Description
NEventAddN | Adds a new event with the specified callback.
NEventAddRaw | Adds a new event.
NEventDispose | Disposes of the specified event.
NEventGetCallbacks | Retrieves all callbacks associated with the event.
NEventInit | Initializes the specified event.
NEventIsEmpty |
NEventReleaseCallbacks | Releases all callbacks associated with the event.
NEventRemoveN | Removes the specified event with the specified callback.
NEventRemoveRaw | Removes the specified event.


NEvent Unit Macros

NEvent Unit Macros
Macros
Name | Description
NEventAdd | Adds a new event.
NEventRemove | Removes the specified event.
N_EVENT_RAISE_1 | Raises the specified event with specified arguments.
N_EVENT_RAISE_2 | Raises the specified event with specified arguments.
N_EVENT_RAISE_3 | Raises the specified event with specified arguments.
N_EVENT_RAISE_4 | Raises the specified event with specified arguments.
N_EVENT_RAISE_5 | Raises the specified event with specified arguments.
N_EVENT_RAISE_6 | Raises the specified event with specified arguments.
N_EVENT_RAISE_RAW | Raises the specified event with specified arguments.
N_EVENT_SIZE | Defines the size of the event.


NEvent.h Functions

NEvent.h Functions
Legend
Functions
Name | Description
NEventAddN | Adds a new event with the specified callback.
NEventAddRaw | Adds a new event.
NEventDispose | Disposes of the specified event.
NEventGetCallbacks | Retrieves all callbacks associated with the event.
NEventInit | Initializes the specified event.
NEventIsEmpty |
NEventReleaseCallbacks | Releases all callbacks associated with the event.
NEventRemoveN | Removes the specified event with the specified callback.
NEventRemoveRaw | Removes the specified event.


NEvent.h Macros

NEvent.h Macros
Macros
Name | Description
NEventAdd | Adds a new event.
NEventRemove | Removes the specified event.
N_EVENT_RAISE_1 | Raises the specified event with specified arguments.
N_EVENT_RAISE_2 | Raises the specified event with specified arguments.
N_EVENT_RAISE_3 | Raises the specified event with specified arguments.
N_EVENT_RAISE_4 | Raises the specified event with specified arguments.
N_EVENT_RAISE_5 | Raises the specified event with specified arguments.
N_EVENT_RAISE_6 | Raises the specified event with specified arguments.
N_EVENT_RAISE_RAW | Raises the specified event with specified arguments.
N_EVENT_SIZE | Defines the size of the event.


NEventDescriptor Unit Files

NEventDescriptor Unit Files
Files
Name | Description
NEventDescriptor.h | Header file for the NEventDescriptor unit.


NEventDescriptor Unit Functions

NEventDescriptor Unit Functions
Legend
Functions
Name | Description
NEventDescriptorAddHandler | Binds the event to the component.
NEventDescriptorGetEventType | Retrieves the event type of the specified event.
NEventDescriptorRemoveHandler | Unbinds the delegate from the component so that the delegate will no longer receive events from the component.


NEventDescriptor.h Functions

NEventDescriptor.h Functions
Legend
Functions
Name | Description
NEventDescriptorAddHandler | Binds the event to the component.
NEventDescriptorGetEventType | Retrieves the event type of the specified event.
NEventDescriptorRemoveHandler | Unbinds the delegate from the component so that the delegate will no longer receive events from the component.


NEventInfo Unit Files

NEventInfo Unit Files
Files
Name | Description
NEventInfo.h | Header file for the NEventInfo unit.


NEventInfo Unit Functions

NEventInfo Unit Functions
Legend
Functions
Name | Description
NEventInfoAddHandler | Binds the event to the object.
NEventInfoGetAddCallbackMethod | Retrieves the method which adds a callback to the event.
NEventInfoGetAddMethod | Retrieves a method which adds an event.
NEventInfoGetEventType | Retrieves the event type of the specified event.
NEventInfoGetRemoveCallbackMethod | Retrieves the method which removes a callback from the event.
NEventInfoGetRemoveMethod | Retrieves a method which removes an event.
NEventInfoRemoveHandler | Unbinds the delegate from the object so that the delegate will no longer receive events from the object.


NEventInfo.h Functions

NEventInfo.h Functions
Legend
Functions
Name | Description
NEventInfoAddHandler | Binds the event to the object.
NEventInfoGetAddCallbackMethod | Retrieves the method which adds a callback to the event.
NEventInfoGetAddMethod | Retrieves a method which adds an event.
NEventInfoGetEventType | Retrieves the event type of the specified event.
NEventInfoGetRemoveCallbackMethod | Retrieves the method which removes a callback from the event.
NEventInfoGetRemoveMethod | Retrieves a method which removes an event.
NEventInfoRemoveHandler | Unbinds the delegate from the object so that the delegate will no longer receive events from the object.


NExpandableObject Unit Files

NExpandableObject Unit Files
Files
Name | Description
NExpandableObject.h | Header file for the NExpandableObject module.


NExpandableObject Unit Functions

NExpandableObject Unit Functions
Legend
Functions
Name | Description
NExpandableObjectGetProperties | Retrieves the properties of the specified expandable object.


NExpandableObject.h Functions

NExpandableObject.h Functions
Legend
Functions
Name | Description
NExpandableObjectGetProperties | Retrieves the properties of the specified expandable object.


NFile Unit Functions

NFile Unit Functions
Legend
Functions
Name | Description
NFileAppendAllLines | Picks a Unicode (W) or ANSCII (A) version of the NFileAppendAllLines function.
NFileAppendAllLinesPN | Picks a Unicode (W) or ANSCII (A) version of the NFileAppendAllLinesPN function.
NFileAppendAllLinesWithEncoding | Picks a Unicode (W) or ANSCII (A) version of the NFileAppendAllLinesWithEncoding function.
NFileAppendAllLinesWithEncodingPN | Picks a Unicode (W) or ANSCII (A) version of the NFileAppendAllLinesWithEncodingPN function.
NFileAppendAllText | Opens a file, appends the specified string to the file, and then closes the file.
NFileAppendAllTextPN | Opens a file, appends the specified string to the file, and then closes the file.
NFileAppendAllTextWithEncoding | Opens a file, appends the specified string to the file, and then closes the file.
NFileAppendAllTextWithEncodingPN | Opens a file, appends the specified string to the file, and then closes the file.
NFileAppendText | Creates a StreamWriter that appends UTF-8 encoded text to an existing file.
NFileCreate | Creates a file in the specified path.
NFileCreateText | Creates or opens a file for writing UTF-8 encoded text.
NFileCreateWithBufferSize | Creates a file in the specified path with the specified buffer size.
NFileDelete | Deletes the specified file. An exception is not thrown if the specified file does not exist.
NFileExists | Determines whether the file with the specified path exists.
NFileGetAttributes | Gets the attributes of the file on the path.
NFileOpen | Opens a NFileStream on the specified path with read/write access.
NFileOpenRead | Opens an existing file for reading.
NFileOpenText | Opens an existing UTF-8 encoded text file for reading.
NFileOpenWithAccess | Opens a NFileStream on the specified path, with the specified mode and access.
NFileOpenWithAccessAndShare | Opens a NFileStream on the specified path, having the specified mode with read, write, or read/write access and the specified sharing option.
NFileOpenWrite | Opens an existing file for writing.
NFileReadAllBytesCN | Opens a binary file, reads the contents of the file into a byte array, and then closes the file.
NFileReadAllBytesN | Opens a binary file, reads the contents of the file into a byte array, and then closes the file.
NFileReadAllLinesCN | Opens a text file, reads all lines of the file, and then closes the file.
NFileReadAllLinesN | Opens a text file, reads all lines of the file, and then closes the file.
NFileReadAllLinesWithEncodingCN | Opens a file, reads all lines of the file with the specified encoding, and then closes the file.
NFileReadAllLinesWithEncodingN | Opens a file, reads all lines of the file with the specified encoding, and then closes the file.
NFileReadAllTextCN | Opens a text file, reads all lines of the file, and then closes the file.
NFileReadAllTextN | Opens a text file, reads all lines of the file, and then closes the file.
NFileReadAllTextWithEncodingCN | Opens a file, reads all lines of the file with the specified encoding, and then closes the file.
NFileReadAllTextWithEncodingN | Opens a file, reads all lines of the file with the specified encoding, and then closes the file.
NFileWriteAllBytes | Creates a new file, writes the specified byte array to the file, and then closes the file.
NFileWriteAllBytesCN | Creates a new file, writes the specified buffer to the file, and then closes the file.
NFileWriteAllBytesPN | Creates a new file, writes the specified byte array to the file, and then closes the file.
NFileWriteAllLines | Creates a new file, write the specified char array to the file, and then closes the file.
NFileWriteAllLinesPN | Creates a new file, write the specified char array to the file, and then closes the file.
NFileWriteAllLinesWithEncoding | Creates a new file, writes the specified char array to the file using the specified encoding, and then closes the file.
NFileWriteAllLinesWithEncodingPN | Creates a new file, writes the specified char array to the file using the specified encoding, and then closes the file.
NFileWriteAllText | Creates a new file, writes the specified char to the file, and then closes the file.
NFileWriteAllTextCN | Picks a Unicode (W) or ASCII (A) version of the NFileWriteAllTextCN function.
NFileWriteAllTextPN | Creates a new file, writes the specified string array to the file, and then closes the file.
NFileWriteAllTextWithEncoding | Creates a new file, writes the specified string array to the file using the specified encoding, and then closes the file.
NFileWriteAllTextWithEncodingPN | Creates a new file, writes the specified string array to the file using the specified encoding, and then closes the file.


NFile Unit Macros

NFile Unit Macros
Macros
Name | Description
NFileAppendAllText | Picks a Unicode (W) or ASCII (A) version of the NFileAppendAllText function.
NFileAppendAllTextPN | Picks a Unicode (W) or ASCII (A) version of the NFileAppendAllTextPN function.
NFileAppendAllTextWithEncoding | Picks a Unicode (W) or ASCII (A) version of the NFileAppendAllTextWithEncoding function.
NFileAppendAllTextWithEncodingPN | Picks a Unicode (W) or ASCII (A) version of the NFileAppendAllTextWithEncodingPN function.
NFileAppendText | Picks a Unicode (W) or ASCII (A) version of the NFileAppendText function.
NFileCreate | Picks a Unicode (W) or ASCII (A) version of the NFileCreate function.
NFileCreateText | Picks a Unicode (W) or ASCII (A) version of the NFileAppendCreateText function.
NFileCreateWithBufferSize | Picks a Unicode (W) or ASCII (A) version of the NFileAppendCreateWithBufferSize function.
NFileDelete | Picks a Unicode (W) or ASCII (A) version of the NFileDelete function.
NFileExists | Picks a Unicode (W) or ASCII (A) version of the NFileExists function.
NFileGetAttributes | Picks a Unicode (W) or ASCII (A) version of the NFileGetAttributes function.
NFileOpen | Picks a Unicode (W) or ASCII (A) version of the NFileOpen function.
NFileOpenRead | Picks a Unicode (W) or ASCII (A) version of the NFileOpenRead function.
NFileOpenText | Picks a Unicode (W) or ASCII (A) version of the NFileOpenText function.
NFileOpenWithAccess | Picks a Unicode (W) or ASCII (A) version of the NFileOpenWithAccess function.
NFileOpenWithAccessAndShare | Picks a Unicode (W) or ASCII (A) version of the NFileOpenWithAccessAndShare function.
NFileOpenWrite | Picks a Unicode (W) or ASCII (A) version of the NFileOpenWrite function.
NFileReadAllBytesCN | Picks a Unicode (W) or ASCII (A) version of the NFileReadAllBytesCN function.
NFileReadAllLinesCN | Picks a Unicode (W) or ASCII (A) version of the NFileReadAllLinesCN function.
NFileReadAllLinesWithEncodingCN | Picks a Unicode (W) or ASCII (A) version of the NFileReadAllLinesWithEncodingCN function.
NFileReadAllTextCN | Picks a Unicode (W) or ASCII (A) version of the NFileReadAllTextCN function.
NFileReadAllTextWithEncodingCN | Picks a Unicode (W) or ASCII (A) version of the NFileReadAllTextWithEncodingCN function.
NFileWriteAllBytes | Picks a Unicode (W) or ASCII (A) version of the NFileWriteAllBytes function.
NFileWriteAllBytesCN | Picks a Unicode (W) or ASCII (A) version of the NFileWriteAllBytesCN function.
NFileWriteAllLines | Picks a Unicode (W) or ASCII (A) version of the NFileWriteAllLines function.
NFileWriteAllLinesPN | Picks a Unicode (W) or ASCII (A) version of the NFileWriteAllLinesPN function.
NFileWriteAllLinesWithEncoding | Picks a Unicode (W) or ASCII (A) version of the NFileWriteAllLinesWithEncoding function.
NFileWriteAllLinesWithEncodingPN | Picks a Unicode (W) or ASCII (A) version of the NFileWriteAllLinesWithEncodingPN function.
NFileWriteAllText | Picks a Unicode (W) or ASCII (A) version of the NFileWriteAllText function.
NFileWriteAllTextPN | Picks a Unicode (W) or ASCII (A) version of the NFileWriteAllTextPN function.
NFileWriteAllTextWithEncoding | Picks a Unicode (W) or ASCII (A) version of the NFileWriteAllTextWithEncoding function.
NFileWriteAllTextWithEncodingPN | Picks a Unicode (W) or ASCII (A) version of the NFileWriteAllTextWithEncodingPN function.


NFile Unit Structs, Records, Enums

NFile Unit Structs, Records, Enums
Legend
Structs, Records, Enums
Name | Description
NFileAttributes_ | Enumerates file attributes.
NFileAttributes | Enumerates file attributes.


NFileStream Unit Functions

NFileStream Unit Functions
Legend
Functions
Name | Description
NFileStreamCreate | Creates file stream with the specified path and creation mode.
NFileStreamCreateFromOSHandle | Creates a new NFileStream for the specified file handle, with the specified read/write permission.
NFileStreamCreateFromOSHandleWithBufferSize | Creates a new NFileStream for the specified file handle, with the specified read/write permission, and buffer size.
NFileStreamCreateWithAccess | Creates a new NFileStream with the specified path, creation mode, and read/write permission.
NFileStreamCreateWithAccessAndShare | Creates a new NFileStream with the specified path, creation mode, read/write permission, and sharing permission.
NFileStreamCreateWithAccessShareAndBufferSize | ... more
NFileStreamGetOSHandle | Gets OS handle for the specified file.


NFileStream Unit Macros

NFileStream Unit Macros
Macros
Name | Description
NFileStreamCreate | Picks a Unicode (W) or ASCII (A) version of the NFileStreamCreate function.
NFileStreamCreateWithAccess | Picks a Unicode (W) or ASCII (A) version of the NFileStreamCreateWithAccess function.
NFileStreamCreateWithAccessAndShare | Picks a Unicode (W) or ASCII (A) version of the NFileStreamCreateWithAccessAndShare function.
NFileStreamCreateWithAccessShareAndBufferSize | Picks a Unicode (W) or ASCII (A) version of the NFileStreamCreateWithAccessShareAndBufferSize function.


NInterlocked Unit Macros

NInterlocked Unit Macros
Macros
Name | Description
N_SLOW_INTERLOCKED | Determines whether the current platform has built-in interlocked functions. If the platform has inbuilt interlocked functions, it will use macros, which will directly map to the platform's interlocked functions. If the platform has no inbuilt interlocked functions, it will use the functions from the NInterlocked.


NIOTypes Unit Files

NIOTypes Unit Files
Files
Name | Description
NIOTypes.h | Header file for NIOTypes Unit.


NIOTypes Unit Functions

NIOTypes Unit Functions
Legend
Functions
Name | Description
NByteOrderGetSystem | Gets system byte order.
NByteOrderIsReverse | Checks if specified byte order is reverse.
NByteOrderIsValid | Checks whether enumeration value is valid.
NFileAccessIsValid | Checks whether enumeration value is valid.
NFileModeIsValid | Checks whether enumeration value is valid.
NFileShareIsValid | Checks whether enumeration value is valid.
NSeekOriginIsValid | Checks whether enumeration value is valid.


NIOTypes Unit Structs, Records, Enums

NIOTypes Unit Structs, Records, Enums
Legend
Structs, Records, Enums
Name | Description
NByteOrder_ | Specifies byte order.
NFileAccess_ | Specifies access to a file.
NFileMode_ | Specifies how the operating system should open a file.
NFileShare_ | Specifies values for controlling the kind of access to a file.
NSeekOrigin_ | Specifies values that represent reference points in streams for seeking.
NByteOrder | Specifies byte order.
NFileAccess | Specifies access to a file.
NFileMode | Specifies how the operating system should open a file.
NFileShare | Specifies values for controlling the kind of access to a file.
NSeekOrigin | Specifies values that represent reference points in streams for seeking.


See Also

See Also
See Also

NByteOrder


NIOTypes.h Enumerations

NIOTypes.h Enumerations
Legend
Enumerations
Name | Description
NByteOrder_ | Specifies byte order.
NFileAccess_ | Specifies access to a file.
NFileMode_ | Specifies how the operating system should open a file.
NFileShare_ | Specifies values for controlling the kind of access to a file.
NSeekOrigin_ | Specifies values that represent reference points in streams for seeking.
NByteOrder | Specifies byte order.
NFileAccess | Specifies access to a file.
NFileMode | Specifies how the operating system should open a file.
NFileShare | Specifies values for controlling the kind of access to a file.
NSeekOrigin | Specifies values that represent reference points in streams for seeking.


NIOTypes.h Functions

NIOTypes.h Functions
Legend
Functions
Name | Description
NByteOrderGetSystem | Gets system byte order.
NByteOrderIsReverse | Checks if specified byte order is reverse.
NByteOrderIsValid | Checks whether enumeration value is valid.
NFileAccessIsValid | Checks whether enumeration value is valid.
NFileModeIsValid | Checks whether enumeration value is valid.
NFileShareIsValid | Checks whether enumeration value is valid.
NSeekOriginIsValid | Checks whether enumeration value is valid.


NList Unit Files

NList Unit Files
Files
Name | Description
NList.h | Header file for the NList module.


NList Unit Functions

NList Unit Functions
Legend
Functions
Name | Description
NListAdd | Adds a new value to the specified list.
NListAddList | Adds a list to another list.
NListAddRange | Adds an array of values to the specified list.
NListClear | Clears the specified list.
NListContains | Checks whether the specified list contains the specified value.
NListCopyTo | Copies the specified list to an array.
NListCopyToRange | Copies a part of the specified list to an array.
NListDetachArray | Detaches an inner array from the specified list.
NListDispose | Disposes of the specified list.
NListGet | Retrieves the specified value from the specified list.
NListGetCapacity | Gets the capacity of the specified list.
NListGetCount | Gets the number of values in the list.
NListGetEnd | Retrieves the last value in the specified list.
NListGetPtr | Retrieves a pointer to the specified value from the specified list.
NListGetStart | Retrieves the first value in the specified list.
NListIndexOf | Searches for the specified value and returns the index of the first occurrence within the specified list.
NListIndexOfFrom | Searches for the specified value and returns the index of the first occurrence within the specified part of the list. The part is limited by an index and the list's end.
NListIndexOfInRange | Searches for the specified value and returns the index of the first occurrence within the specified part of the list. The part is limited by an index and length.
NListInit | Initializes a new list.
NListInitEx | Initializes a new list.
NListInitWithCapacity | Initializes a new list.
NListInsert | Adds a new value to the specified list at the specified index.
NListInsertList | Adds a list to another list at the specified index.
NListInsertRange | Adds an array of values to the specified list at the specified index.
NListLastIndexOf | Searches for the specified object and returns the index of the last occurrence within the specified list
NListLastIndexOfFrom | Searches for the specified value and returns the index of the last occurrence within the specified part of the list. The part is limited by an index and the list's end.
NListLastIndexOfInRange | Searches for the specified value and returns the index of the last occurrence within the specified part of the list. The part is limited by an index and length.
NListRemove | Removes the specified value from the specified list.
NListRemoveAt | Removes the specified value from the specified list.
NListRemoveRange | Removes a range of values from the specified list.
NListSet | Sets the specified value in the specified list.
NListSetCapacity | Sets the capacity of the specified list.
NListSetCount | Sets the number of values in the list.
NListToArray | Converts the specified list to an array.
NListToArrayRange | Converts a part of the specified list to an array.


NList Unit Macros

NList Unit Macros
Macros
Name | Description
N_LIST_SIZE | Defines the size of the list (default value 32).


NList.h Functions

NList.h Functions
Legend
Functions
Name | Description
NListAdd | Adds a new value to the specified list.
NListAddList | Adds a list to another list.
NListAddRange | Adds an array of values to the specified list.
NListClear | Clears the specified list.
NListContains | Checks whether the specified list contains the specified value.
NListCopyTo | Copies the specified list to an array.
NListCopyToRange | Copies a part of the specified list to an array.
NListDetachArray | Detaches an inner array from the specified list.
NListDispose | Disposes of the specified list.
NListGet | Retrieves the specified value from the specified list.
NListGetCapacity | Gets the capacity of the specified list.
NListGetCount | Gets the number of values in the list.
NListGetEnd | Retrieves the last value in the specified list.
NListGetPtr | Retrieves a pointer to the specified value from the specified list.
NListGetStart | Retrieves the first value in the specified list.
NListIndexOf | Searches for the specified value and returns the index of the first occurrence within the specified list.
NListIndexOfFrom | Searches for the specified value and returns the index of the first occurrence within the specified part of the list. The part is limited by an index and the list's end.
NListIndexOfInRange | Searches for the specified value and returns the index of the first occurrence within the specified part of the list. The part is limited by an index and length.
NListInit | Initializes a new list.
NListInitEx | Initializes a new list.
NListInitWithCapacity | Initializes a new list.
NListInsert | Adds a new value to the specified list at the specified index.
NListInsertList | Adds a list to another list at the specified index.
NListInsertRange | Adds an array of values to the specified list at the specified index.
NListLastIndexOf | Searches for the specified object and returns the index of the last occurrence within the specified list
NListLastIndexOfFrom | Searches for the specified value and returns the index of the last occurrence within the specified part of the list. The part is limited by an index and the list's end.
NListLastIndexOfInRange | Searches for the specified value and returns the index of the last occurrence within the specified part of the list. The part is limited by an index and length.
NListRemove | Removes the specified value from the specified list.
NListRemoveAt | Removes the specified value from the specified list.
NListRemoveRange | Removes a range of values from the specified list.
NListSet | Sets the specified value in the specified list.
NListSetCapacity | Sets the capacity of the specified list.
NListSetCount | Sets the number of values in the list.
NListToArray | Converts the specified list to an array.
NListToArrayRange | Converts a part of the specified list to an array.


NList.h Macros

NList.h Macros
Macros
Name | Description
N_LIST_SIZE | Defines the size of the list (default value 32).


NListList Unit Files

NListList Unit Files
Files
Name | Description
NListList.h | Header file for the NListList module.


NListList Unit Functions

NListList Unit Functions
Legend
Functions
Name | Description
NListListAdd | Adds a regular list to the 2D list.
NListListAddItem | Adds an item to the 2D list.
NListListAddItemRange | Adds an array of items to the 2D list.
NListListAddListList | Adds the the specified 2D list to another specified 2D list.
NListListAddListListItems | Adds the contents of the specified 2D list to another specified 2D list.
NListListAddRange | Adds a number of regular lists to the 2D list.
NListListClear | Clears the specified 2D list.
NListListClearItems | Clears all items from the specified list.
NListListContainsItem | Checks whether the specified list contains the specified item.
NListListCopyItemsTo | Copies the specified list to an array.
NListListCopyItemsToRange | Copies a part of the specified list to an array.
NListListDetachItemsArray | Detaches an inner array from the specified array.
NListListDispose | Disposes of the specified 2D list.
NListListGetCapacity | Retrieves the maximum number of 1D lists in the specified 2D list.
NListListGetCount | Retrieves the number of 1D lists in the specified 2D list.
NListListGetItem | Retrieves the specified item from the specified 2D list.
NListListGetItemCapacity | Retrieves the maximum number of item in the specified list.
NListListGetItemCount | Retrieves the number of items in the specified list.
NListListGetItemPtr | Retrieves a pointer to the specified item from the specified 2D list.
NListListGetItemsEnd | Retrieves a pointer to the end of the inner array of the specified list.
NListListGetItemsStart | Retrieves a pointer to the start of the inner array of the specified list.
NListListIndexOfItem | Searches for the specified value and returns the index of the first occurrence within the specified list.
NListListIndexOfItemFrom | Searches for the specified value and returns the index of the first occurrence within the specified part of the list. The part is limited by an index and the list's end.
NListListIndexOfItemInRange | Searches for the specified value and returns the index of the first occurrence within the specified part of the list. The part is limited by an index and length.
NListListInit | Initializes the the specified 2D list.
NListListInitEx | Initializes the the specified 2D list.
NListListInitWithCapacity | Initializes the the specified 2D list.
NListListInsert | Adds a regular list to the 2D list at the specified index.
NListListInsertItem | Adds an item to the 2D list at the specified index.
NListListInsertItemRange | Adds an array of items to the 2D list at the specified index.
NListListInsertListList | Adds the the specified 2D list to another specified 2D list at the specified index..
NListListInsertListListItems | Adds the contents of the specified 2D list to another specified 2D list at the specified index.
NListListInsertRange | Adds a number of regular lists to the 2D list at the specified index.
NListListItemsToArray | Converts the specified list to an array.
NListListItemsToArrayRange | Converts a part of the specified list to an array.
NListListLastIndexOfItem | Searches for the specified value and returns the index of the last occurrence within the specified list.
NListListLastIndexOfItemFrom | Searches for the specified value and returns the index of the last occurrence within the specified part of the list. The part is limited by an index and the list's end.
NListListLastIndexOfItemInRange | Searches for the specified value and returns the index of the last occurrence within the specified part of the list. The part is limited by an index and length.
NListListRemoveAt | Removes a regular list from the 2D list.
NListListRemoveItem | Removes an item from the 2D list.
NListListRemoveItemAt | Removes an item from the 2D list.
NListListRemoveItemRange | Removes a range item from the 2D list.
NListListRemoveRange | Removes a number of regular lists from the 2D list.
NListListSetCapacity | Sets the maximum number of 1D lists in the specified 2D list.
NListListSetCount | Sets the number of 1D lists in the specified 2D list.
NListListSetItem | Sets the value of the specified item in the specified 2D list.
NListListSetItemCapacity |
NListListSetItemCount | Sets the number of items in the specified list.


NListList Unit Macros

NListList Unit Macros
Macros
Name | Description
N_LIST_LIST_SIZE | Defines the size of the two-dimensional list (default value 4).


NListList.h Functions

NListList.h Functions
Legend
Functions
Name | Description
NListListAdd | Adds a regular list to the 2D list.
NListListAddItem | Adds an item to the 2D list.
NListListAddItemRange | Adds an array of items to the 2D list.
NListListAddListList | Adds the the specified 2D list to another specified 2D list.
NListListAddListListItems | Adds the contents of the specified 2D list to another specified 2D list.
NListListAddRange | Adds a number of regular lists to the 2D list.
NListListClear | Clears the specified 2D list.
NListListClearItems | Clears all items from the specified list.
NListListContainsItem | Checks whether the specified list contains the specified item.
NListListCopyItemsTo | Copies the specified list to an array.
NListListCopyItemsToRange | Copies a part of the specified list to an array.
NListListDetachItemsArray | Detaches an inner array from the specified array.
NListListDispose | Disposes of the specified 2D list.
NListListGetCapacity | Retrieves the maximum number of 1D lists in the specified 2D list.
NListListGetCount | Retrieves the number of 1D lists in the specified 2D list.
NListListGetItem | Retrieves the specified item from the specified 2D list.
NListListGetItemCapacity | Retrieves the maximum number of item in the specified list.
NListListGetItemCount | Retrieves the number of items in the specified list.
NListListGetItemPtr | Retrieves a pointer to the specified item from the specified 2D list.
NListListGetItemsEnd | Retrieves a pointer to the end of the inner array of the specified list.
NListListGetItemsStart | Retrieves a pointer to the start of the inner array of the specified list.
NListListIndexOfItem | Searches for the specified value and returns the index of the first occurrence within the specified list.
NListListIndexOfItemFrom | Searches for the specified value and returns the index of the first occurrence within the specified part of the list. The part is limited by an index and the list's end.
NListListIndexOfItemInRange | Searches for the specified value and returns the index of the first occurrence within the specified part of the list. The part is limited by an index and length.
NListListInit | Initializes the the specified 2D list.
NListListInitEx | Initializes the the specified 2D list.
NListListInitWithCapacity | Initializes the the specified 2D list.
NListListInsert | Adds a regular list to the 2D list at the specified index.
NListListInsertItem | Adds an item to the 2D list at the specified index.
NListListInsertItemRange | Adds an array of items to the 2D list at the specified index.
NListListInsertListList | Adds the the specified 2D list to another specified 2D list at the specified index..
NListListInsertListListItems | Adds the contents of the specified 2D list to another specified 2D list at the specified index.
NListListInsertRange | Adds a number of regular lists to the 2D list at the specified index.
NListListItemsToArray | Converts the specified list to an array.
NListListItemsToArrayRange | Converts a part of the specified list to an array.
NListListLastIndexOfItem | Searches for the specified value and returns the index of the last occurrence within the specified list.
NListListLastIndexOfItemFrom | Searches for the specified value and returns the index of the last occurrence within the specified part of the list. The part is limited by an index and the list's end.
NListListLastIndexOfItemInRange | Searches for the specified value and returns the index of the last occurrence within the specified part of the list. The part is limited by an index and length.
NListListRemoveAt | Removes a regular list from the 2D list.
NListListRemoveItem | Removes an item from the 2D list.
NListListRemoveItemAt | Removes an item from the 2D list.
NListListRemoveItemRange | Removes a range item from the 2D list.
NListListRemoveRange | Removes a number of regular lists from the 2D list.
NListListSetCapacity | Sets the maximum number of 1D lists in the specified 2D list.
NListListSetCount | Sets the number of 1D lists in the specified 2D list.
NListListSetItem | Sets the value of the specified item in the specified 2D list.
NListListSetItemCapacity |
NListListSetItemCount | Sets the number of items in the specified list.


NListList.h Macros

NListList.h Macros
Macros
Name | Description
N_LIST_LIST_SIZE | Defines the size of the two-dimensional list (default value 4).


NMemberDescriptor Unit Files

NMemberDescriptor Unit Files
Files
Name | Description
NMemberDescriptor.h | Header file for the NMemberDescriptor unit.


NMemberDescriptor Unit Functions

NMemberDescriptor Unit Functions
Legend
Functions
Name | Description
NMemberDescriptorGetComponentType | Retrieves the component type of the specified member descriptor.


NMemberDescriptor.h Functions

NMemberDescriptor.h Functions
Legend
Functions
Name | Description
NMemberDescriptorGetComponentType | Retrieves the component type of the specified member descriptor.


NMemberInfo Unit Files

NMemberInfo Unit Files
Files
Name | Description
NMemberInfo.h | Header file for the NMemberInfo unit.


NMemberInfo Unit Functions

NMemberInfo Unit Functions
Legend
Functions
Name | Description
NMemberInfoGetAttributes | Retrieves the attributes of the specified member.
NMemberInfoGetDeclaringType | Retrieves the declaring type of the specified member.
NMemberInfoGetId | Retrieves the ID of the specified member.
NMemberInfoGetName | Retrieves the name of the specified member.


NMemberInfo.h Functions

NMemberInfo.h Functions
Legend
Functions
Name | Description
NMemberInfoGetAttributes | Retrieves the attributes of the specified member.
NMemberInfoGetDeclaringType | Retrieves the declaring type of the specified member.
NMemberInfoGetId | Retrieves the ID of the specified member.
NMemberInfoGetName | Retrieves the name of the specified member.


NMemory Unit Files

NMemory Unit Files
Files
Name | Description
NMemory.h | ... more


NMemory Unit Functions

NMemory Unit Functions
Legend
Functions
Name | Description
NAlignedFree | Frees an aligned memory resources.
NAlignedOffsetAlloc | Allocates an aligned memory block.
NAlignedOffsetAllocArray | Allocates an aligned memory block for array.
NAlignedOffsetCAlloc | Allocates an aligned memory block with all bytes set to zero.
NAlignedOffsetCAllocArray | Allocates an aligned array with all bytes set to zero.
NAlignedOffsetReAlloc | Reallocates an aligned memory block.
NAlignedOffsetReAllocArray | Reallocates an aligned array.
NAlloc | Allocates memory block.
NAllocArray | Allocates array.
NCAlloc | Allocates memory block with all bytes set to zero.
NCAllocArray | Allocates array with all bytes set to zero.
NClearArray | Clears array items.
NCompare | Compares bytes in two memory blocks.
NCopy | Copies data between memory blocks.
NCopyArray | Copies data between arrays.
NFill | Sets bytes of memory block to specified value.
NFree | Deallocates memory block.
NFreeEx | Deallocates memory block of a specified type.
NMemoryTypeIsValid | Checks if enumeration value is correct.
NMemoryTypeIsValidForFree | Checks if enumeration value for NFreeEx is correct.
NMove | Move data from one memory block to another.
NMoveArray | Move data from one array to another.
NPageAlloc | Allocates page.
NPageFree | Deallocates page memory.
NReAlloc | Reallocates memory block.
NReAllocArray | Reallocates array.


NMemory Unit Macros

NMemory Unit Macros
Macros
Name | Description
NClear | Clears memory block.


NMemory Unit Structs, Records, Enums

NMemory Unit Structs, Records, Enums
Legend
Structs, Records, Enums
Name | Description
NMemoryType_ | Enumerates memory types.
NMemoryType | Enumerates memory types.


NMemory.h Enumerations

NMemory.h Enumerations
Legend
Enumerations
Name | Description
NMemoryType_ | Enumerates memory types.
NMemoryType | Enumerates memory types.


NMemory.h Functions

NMemory.h Functions
Legend
Functions
Name | Description
NAlignedFree | Frees an aligned memory resources.
NAlignedOffsetAlloc | Allocates an aligned memory block.
NAlignedOffsetAllocArray | Allocates an aligned memory block for array.
NAlignedOffsetCAlloc | Allocates an aligned memory block with all bytes set to zero.
NAlignedOffsetCAllocArray | Allocates an aligned array with all bytes set to zero.
NAlignedOffsetReAlloc | Reallocates an aligned memory block.
NAlignedOffsetReAllocArray | Reallocates an aligned array.
NAlloc | Allocates memory block.
NAllocArray | Allocates array.
NCAlloc | Allocates memory block with all bytes set to zero.
NCAllocArray | Allocates array with all bytes set to zero.
NClearArray | Clears array items.
NCompare | Compares bytes in two memory blocks.
NCopy | Copies data between memory blocks.
NCopyArray | Copies data between arrays.
NFill | Sets bytes of memory block to specified value.
NFree | Deallocates memory block.
NFreeEx | Deallocates memory block of a specified type.
NMemoryTypeIsValid | Checks if enumeration value is correct.
NMemoryTypeIsValidForFree | Checks if enumeration value for NFreeEx is correct.
NMove | Move data from one memory block to another.
NMoveArray | Move data from one array to another.
NPageAlloc | Allocates page.
NPageFree | Deallocates page memory.
NReAlloc | Reallocates memory block.
NReAllocArray | Reallocates array.


NMemory.h Macros

NMemory.h Macros
Macros
Name | Description
NClear | Clears memory block.


NMemoryStream Unit Functions

NMemoryStream Unit Functions
Legend
Functions
Name | Description
NMemoryStreamCreate | Creates a stream with an expandable capacity initialized to zero
NMemoryStreamCreateFromBuffer | ... more
NMemoryStreamCreateFromBufferN | ... more
NMemoryStreamCreateWithCapacity | ... more
NMemoryStreamGetBuffer | Returns NBuffer from which this stream was created.
NMemoryStreamGetCapacity | Returns the number of bytes allocated for this stream.
NMemoryStreamGetPositionPtr | Returns the current position within the stream.
NMemoryStreamSetCapacity | ... more
NMemoryStreamSetPositionPtr | Sets the current position within the stream.
NMemoryStreamToPtr | Copies the memory contained in the buffer and returns it as a pointer.
NMemoryStreamWriteTo | Writes the entire contents of NMemoryStream to another stream.


NMemoryStream Unit Macros

NMemoryStream Unit Macros
Macros
Name | Description
NMemoryStreamCreateFromBufferForRead | Creates a new NMemoryStream based on the specified byte array.


NMethodDescriptor Unit Files

NMethodDescriptor Unit Files
Files
Name | Description
NMethodDescriptor.h | Header file for the NMethodDescriptor unit.


NMethodDescriptor Unit Functions

NMethodDescriptor Unit Functions
Legend
Functions
Name | Description
NMethodDescriptorGetParameter | Retrieves the specified parameter of the method associated with the specified descriptor.
NMethodDescriptorGetParameterCount | Retrieves the number of parameters possessed by the method associated with the specified descriptor.
NMethodDescriptorGetParameters | Retrieves all parameters possessed by the method associated with the specified descriptor.
NMethodDescriptorGetReturnParameter | Retrieves the parameter returned by the method associated with the specified descriptor.
NMethodDescriptorInvoke | Invokes the method associated with the specified descriptor.
NMethodDescriptorInvokeWithPropertyBag | Invokes the method associated with the specified descriptor.
NMethodDescriptorInvokeWithString | Invokes the method associated with the specified descriptor.


NMethodDescriptor Unit Macros

NMethodDescriptor Unit Macros
Macros
Name | Description
NMethodDescriptorInvokeWithString | Picks a Unicode (W) or ASCII (A) version of the NMethodDescriptorInvokeWithString function.


NMethodDescriptor.h Functions

NMethodDescriptor.h Functions
Legend
Functions
Name | Description
NMethodDescriptorGetParameter | Retrieves the specified parameter of the method associated with the specified descriptor.
NMethodDescriptorGetParameterCount | Retrieves the number of parameters possessed by the method associated with the specified descriptor.
NMethodDescriptorGetParameters | Retrieves all parameters possessed by the method associated with the specified descriptor.
NMethodDescriptorGetReturnParameter | Retrieves the parameter returned by the method associated with the specified descriptor.
NMethodDescriptorInvoke | Invokes the method associated with the specified descriptor.
NMethodDescriptorInvokeWithPropertyBag | Invokes the method associated with the specified descriptor.
NMethodDescriptorInvokeWithString | Invokes the method associated with the specified descriptor.


NMethodDescriptor.h Macros

NMethodDescriptor.h Macros
Macros
Name | Description
NMethodDescriptorInvokeWithString | Picks a Unicode (W) or ASCII (A) version of the NMethodDescriptorInvokeWithString function.


NMethodInfo Unit Files

NMethodInfo Unit Files
Files
Name | Description
NMethodInfo.h | Header file for the NMethodInfo unit.


NMethodInfo Unit Functions

NMethodInfo Unit Functions
Legend
Functions
Name | Description
NMethodInfoGetNativeName | Retrieves the native name of the specified method.
NMethodInfoGetParameter | Retrieves the specified parameter of the specified method.
NMethodInfoGetParameterCount | Retrieves the number of parameters of the specified method.
NMethodInfoGetParameters | Retrieves all parameters of the specified method.
NMethodInfoGetReturnParameter | Retrieves the return parameter of the specified method.
NMethodInfoInvoke | Invokes the specified method.
NMethodInfoInvokeWithPropertyBag | Invokes the specified method.
NMethodInfoInvokeWithString | Invokes the specified method.


NMethodInfo Unit Macros

NMethodInfo Unit Macros
Macros
Name | Description
NMethodInfoInvokeWithString | Picks a Unicode (W) or ASCII (A) version of the NMethodInfoInvokeWithString function.


NMethodInfo.h Functions

NMethodInfo.h Functions
Legend
Functions
Name | Description
NMethodInfoGetNativeName | Retrieves the native name of the specified method.
NMethodInfoGetParameter | Retrieves the specified parameter of the specified method.
NMethodInfoGetParameterCount | Retrieves the number of parameters of the specified method.
NMethodInfoGetParameters | Retrieves all parameters of the specified method.
NMethodInfoGetReturnParameter | Retrieves the return parameter of the specified method.
NMethodInfoInvoke | Invokes the specified method.
NMethodInfoInvokeWithPropertyBag | Invokes the specified method.
NMethodInfoInvokeWithString | Invokes the specified method.


NMethodInfo.h Macros

NMethodInfo.h Macros
Macros
Name | Description
NMethodInfoInvokeWithString | Picks a Unicode (W) or ASCII (A) version of the NMethodInfoInvokeWithString function.


NModule Unit Files

NModule Unit Files
Files
Name | Description
NModule.h | Header file for the NModule unit.


NModule Unit Functions

NModule Unit Functions
Legend
Functions
Name | Description
NModuleCheckInit | Checks whether the module is initialized and throws and exception if it is not.
NModuleCreate | Creates a new NModule.
NModuleCreateInstance | Creates a new instance of the specified module.
NModuleGetActivatedN | Get the activation status of a protected module.
NModuleGetCompanyN | Get the company name providing the component.
NModuleGetCopyrightN | Get the copyright string for the module.
NModuleGetDefinedType | Retrieves the defined type specified by index from the specified module.
NModuleGetDefinedTypeCount | Retrieves the number of defined types in the specified module.
NModuleGetDefinedTypes | Retrieves all defined types from the specified module.
NModuleGetDependences | Retrieves the module's dependencies.
NModuleGetFileName | Retrieves the name of the file the specified module was created from.
NModuleGetId | Retrieves the ID of the module.
NModuleGetLoadedModules | Get a list of loaded modules.
NModuleGetNameN | Get the short name of the given module.
NModuleGetNativeId | Retrieves the native ID of the specified module.
NModuleGetOptions | Get the set of component's flags.
NModuleGetProductN | Get the product name of the given module.
NModuleGetTitleN | Get the title string (long name with version) for the given module.
NModuleGetTypeWithName | Get the type with the specified name for the given module.
NModuleGetVersionBuild | Get the build number part of the version (Major.Minor.Revision.Build).
NModuleGetVersionMajor | Get the major number part of the version (Major.Minor.Revision.Build).
NModuleGetVersionMinor | Get the minor number part of the version (Major.Minor.Revision.Build).
NModuleGetVersionRevision | Get the revision number part of the version (Major.Minor.Revision.Build).
NModuleLoadFromFile | Loads a module from the specified file.
NModuleSetCompany | Sets company.
NModuleSetCompanyN | Sets the company for the specified NModule.
NModuleSetCopyright | Sets copyright string.
NModuleSetCopyrightN | Sets the copyright for the specified NModule.
NModuleSetId | Sets the ID of the specified module.
NModuleSetNameN | Sets the name for the specified NModule.
NModuleSetNativeId | Sets the native ID of the specified module.
NModuleSetOptions | Sets the options for the specified module.
NModuleSetProduct | Sets product name.
NModuleSetProductN | Sets the product of the specified module.
NModuleSetTitle | Sets NModule title.
NModuleSetTitleN | Sets the title for the specified NModule.
NModuleSetVersionBuild | Sets the version build value for the specified module.
NModuleSetVersionMajor | Sets the version major value for the specified module.
NModuleSetVersionMinor | Sets the version minor value for the specified module.
NModuleSetVersionRevision | Sets the version revision value for the specified module.


NModule Unit Macros

NModule Unit Macros
Macros
Name | Description
NModuleCreateInstance | Picks a Unicode (W) or ASCII (A) version of the NModuleCreateInstance function.
NModuleGetTypeWithName | Picks a Unicode (W) or ASCII (A) version of the NModuleGetTypeWithName function.
NModuleLoadFromFile | Picks a Unicode (W) or ASCII (A) version of the NModuleLoadFromFile function.
NModuleSetId | Picks a Unicode (W) or ASCII (A) version of the NModuleSetId function.
NModuleSetName | Picks a Unicode (W) or ASCII (A) version of the NModuleSetName function.
NModuleSetNativeId | Picks a Unicode (W) or ASCII (A) version of the NModuleSetNativeId function.
N_DECLARE_MODULE | Declares the module.
N_MODULE_OF | Used to obtain a pointer to the function that retrieves NModule object for the specified module name.


NModule Unit Structs, Records, Enums

NModule Unit Structs, Records, Enums
Legend
Structs, Records, Enums
Name | Description
NModuleOptions_ | Enumeration of possible module flags giving additional information about the module.
NModuleOptions | Enumeration of possible module flags giving additional information about the module.


NModule.h Enumerations

NModule.h Enumerations
Legend
Enumerations
Name | Description
NModuleOptions_ | Enumeration of possible module flags giving additional information about the module.
NModuleOptions | Enumeration of possible module flags giving additional information about the module.


NModule.h Functions

NModule.h Functions
Legend
Functions
Name | Description
NModuleCheckInit | Checks whether the module is initialized and throws and exception if it is not.
NModuleCreate | Creates a new NModule.
NModuleCreateInstance | Creates a new instance of the specified module.
NModuleGetActivatedN | Get the activation status of a protected module.
NModuleGetCompanyN | Get the company name providing the component.
NModuleGetCopyrightN | Get the copyright string for the module.
NModuleGetDefinedType | Retrieves the defined type specified by index from the specified module.
NModuleGetDefinedTypeCount | Retrieves the number of defined types in the specified module.
NModuleGetDefinedTypes | Retrieves all defined types from the specified module.
NModuleGetDependences | Retrieves the module's dependencies.
NModuleGetFileName | Retrieves the name of the file the specified module was created from.
NModuleGetId | Retrieves the ID of the module.
NModuleGetLoadedModules | Get a list of loaded modules.
NModuleGetNameN | Get the short name of the given module.
NModuleGetNativeId | Retrieves the native ID of the specified module.
NModuleGetOptions | Get the set of component's flags.
NModuleGetProductN | Get the product name of the given module.
NModuleGetTitleN | Get the title string (long name with version) for the given module.
NModuleGetTypeWithName | Get the type with the specified name for the given module.
NModuleGetVersionBuild | Get the build number part of the version (Major.Minor.Revision.Build).
NModuleGetVersionMajor | Get the major number part of the version (Major.Minor.Revision.Build).
NModuleGetVersionMinor | Get the minor number part of the version (Major.Minor.Revision.Build).
NModuleGetVersionRevision | Get the revision number part of the version (Major.Minor.Revision.Build).
NModuleLoadFromFile | Loads a module from the specified file.
NModuleSetCompany | Sets company.
NModuleSetCompanyN | Sets the company for the specified NModule.
NModuleSetCopyright | Sets copyright string.
NModuleSetCopyrightN | Sets the copyright for the specified NModule.
NModuleSetId | Sets the ID of the specified module.
NModuleSetNameN | Sets the name for the specified NModule.
NModuleSetNativeId | Sets the native ID of the specified module.
NModuleSetOptions | Sets the options for the specified module.
NModuleSetProduct | Sets product name.
NModuleSetProductN | Sets the product of the specified module.
NModuleSetTitle | Sets NModule title.
NModuleSetTitleN | Sets the title for the specified NModule.
NModuleSetVersionBuild | Sets the version build value for the specified module.
NModuleSetVersionMajor | Sets the version major value for the specified module.
NModuleSetVersionMinor | Sets the version minor value for the specified module.
NModuleSetVersionRevision | Sets the version revision value for the specified module.


NModule.h Macros

NModule.h Macros
Macros
Name | Description
NModuleCreateInstance | Picks a Unicode (W) or ASCII (A) version of the NModuleCreateInstance function.
NModuleGetTypeWithName | Picks a Unicode (W) or ASCII (A) version of the NModuleGetTypeWithName function.
NModuleLoadFromFile | Picks a Unicode (W) or ASCII (A) version of the NModuleLoadFromFile function.
NModuleSetId | Picks a Unicode (W) or ASCII (A) version of the NModuleSetId function.
NModuleSetName | Picks a Unicode (W) or ASCII (A) version of the NModuleSetName function.
NModuleSetNativeId | Picks a Unicode (W) or ASCII (A) version of the NModuleSetNativeId function.
N_DECLARE_MODULE | Declares the module.
N_MODULE_OF | Used to obtain a pointer to the function that retrieves NModule object for the specified module name.


NModuleInternal Unit Functions

NModuleInternal Unit Functions
Legend
Functions
Name | Description
NModuleRegister | Register a created NModule.
NModuleSetActivatedProc | Sets the activated procedure for the specified module.
NModuleSetDependences | Sets the dependencies for the specified module.
NModuleSetInit | Sets the initialization procedure for the specified module.
NModuleSetLazyInit | Sets the lazy initialization procedure for the specified module.
NModuleSetThreadInit | Sets the thread initialization procedure for the specified module.
NModuleSetThreadUninit | Sets the thread uninitialization procedure for the specified module.
NModuleSetUninit | Sets the uninitialization procedure for the specified module.
NModuleUnregister | Unregisters a module.


NMonitor Unit Functions

NMonitor Unit Functions
Legend
Functions
Name | Description
NMonitorDispose | Releases all resources used by a monitor.
NMonitorEnter | Waits for ownership of the specified monitor. The function returns when the calling thread is granted ownership (after thread currently owning the monitor calls NMonitorExit).
NMonitorExit | Releases ownership of the specified monitor.
NMonitorInit | Initializes a monitor.
NMonitorTryEnter | Gets ownership of the specified monitor without waiting if possible.


NMonitor Unit Macros

NMonitor Unit Macros
Macros
Name | Description
N_MONITOR_SIZE | Defines the monitor size.


See Also

See Also
See Also

NMutex for alternative implementation.


NMutex Unit Functions

NMutex Unit Functions
Legend
Functions
Name | Description
NMutexCreate | Creates and initializes a mutex object.
NMutexCreateFromOSHandle | Creates and initializes a mutex object with an OS handle.
NMutexGetOSHandle | Gets an OS handle to the specified mutex.
NMutexRelease | Releases ownership of the specified mutex.


See Also

See Also
See Also
  • NWaitObject for NMutex functionality shared with other synchronization objects.
  • NMonitor for alternative, more lightweight implementation.


NObject Unit Files

NObject Unit Files
Files
Name | Description
NObject.h | Header file for NObject module. Provides functionality for retrieving information about specified object.


NObject Unit Functions

NObject Unit Functions
Legend
Functions
Name | Description
NObjectAddDisposed | Adds a "Disposed" callback to NObject.
NObjectAddDisposedCallback | Adds a "Disposed" callback to NObject.
NObjectAddHandlerP | Picks a Unicode (W) or ASCII (A) version of the NObjectAddHandlerP function.
NObjectAddOwnerChanged | Adds an "Owner changed" callback to NObject.
NObjectAddOwnerChangedCallback | Adds an "Owner changed" callback to NObject.
NObjectAddPropertyChanged | Adds a "Property changed" callback to NObject.
NObjectAddPropertyChangedCallback | Adds a "Property changed" callback to NObject.
NObjectCaptureProperties | Adds the properties of the specified object to the specified property bag.
NObjectClone | Creates a copy of specified object.
NObjectCompareTo | Compares the specified object with another specified object and returns an indication of their relative values.
NObjectCopyProperties | Copies property values from one object to another.
NObjectEquals | Compares the objects.
NObjectGet | Retrieves the value of NObject.
NObjectGetArray | Retrieves an array of values of an array of objects.
NObjectGetConcurrent | Retrieves the value of NObject. This function is thread-safe.
NObjectGetElements | Retrieves all elements of the specified object array.
NObjectGetFlags | Gets any flags of specified object.
NObjectGetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
NObjectGetOwnerEx | Gets owner of specified object.
NObjectGetPropertyN | Retrieves the value of the specified property of the specified object.
NObjectGetPropertyNN | Retrieves the value of the specified property of the specified object.
NObjectGetPropertyP | Retrieves the value of the specified property of the specified object.
NObjectGetSize | Retrieves the size of specified object.
NObjectGetSizeMany | Retrieves the size of the array of objects.
NObjectGetType | Retrieves type of specified object.
NObjectInvoke | Invokes the specified method or constructor, using the specified parameters.
NObjectInvokeWithPropertyBag | Invokes the specified method or constructor, using the specified parameters.
NObjectInvokeWithString | Invokes the specified method or constructor, using the specified parameters.
NObjectRef | ... more
NObjectRemoveDisposed | Removes the "Disposed" callback from NObject.
NObjectRemoveDisposedCallback | Removes the "Disposed" callback from NObject.
NObjectRemoveHandlerP | Picks a Unicode (W) or ASCII (A) version of the NObjectRemoveHandlerP function.
NObjectRemoveOwnerChanged | Removes the "Owner changed" callback from NObject.
NObjectRemoveOwnerChangedCallback | Removes the "Owner changed" callback from NObject.
NObjectRemovePropertyChanged | Removes the "Property changed" callback from NObject.
NObjectRemovePropertyChangedCallback | Removes the "Property changed" callback from NObject.
NObjectReset | Sets default values for all parameters of the specified object.
NObjectResetProperty | Sets default values for the specified property of the specified object.
NObjectSaveManyToMemoryDst | Saves an array of objects to a memory location with a specified size.
NObjectSaveManyToMemoryDstN | Saves an array of objects to a specified memory location.
NObjectSaveManyToMemoryN | Saves an array of objects to a memory location.
NObjectSaveManyToStream | Saves a NObject array in a stream.
NObjectSaveToMemoryDst | Saves an objects to a memory location with specified size.
NObjectSaveToMemoryDstN | Save an object to a specified memory location.
NObjectSaveToMemoryN | Saves an object to a memory location.
NObjectSaveToStream | Saves NObject to a stream.
NObjectSet | Set the value of NObject.
NObjectSetConcurrent | Set the value of NObject. This function is tread-safe.
NObjectSetFlags | Sets the flags for the specified object.
NObjectSetPropertyN | Sets the specified property of the specified object to the specified value.
NObjectSetPropertyNN | Sets the specified property of the specified object to the specified value.
NObjectSetPropertyP | Sets the specified property of the specified object to the specified value.
NObjectToString | Returns string representation of the object.
NObjectUnref | ... more
NObjectUnrefArray | ... more
NObjectUnrefElements | ... more


NObject Unit Macros

NObject Unit Macros
Macros
Name | Description
NObjectGetPropertyP | Picks a Unicode (W) or ASCII (A) version of the NObjectGetPropertyP function.
NObjectInvoke | Picks a Unicode (W) or ASCII (A) version of the NObjectInvoke function.
NObjectInvokeWithPropertyBag | Picks a Unicode (W) or ASCII (A) version of the NObjectInvokeWithPropertyBag function.
NObjectInvokeWithString | Picks a Unicode (W) or ASCII (A) version of the NObjectInvokeWithString function.
NObjectResetProperty | Picks a Unicode (W) or ASCII (A) version of the NObjectResetProperty function.
NObjectSetPropertyP | Picks a Unicode (W) or ASCII (A) version of the NObjectSetPropertyP function.
NObjectToString | Picks a Unicode (W) or ASCII (A) version of the NObjectToString function.
N_OBJECT_REF_RET | ... more


NObject.h Functions

NObject.h Functions
Legend
Functions
Name | Description
NObjectAddDisposed | Adds a "Disposed" callback to NObject.
NObjectAddDisposedCallback | Adds a "Disposed" callback to NObject.
NObjectAddHandlerP | Picks a Unicode (W) or ASCII (A) version of the NObjectAddHandlerP function.
NObjectAddOwnerChanged | Adds an "Owner changed" callback to NObject.
NObjectAddOwnerChangedCallback | Adds an "Owner changed" callback to NObject.
NObjectAddPropertyChanged | Adds a "Property changed" callback to NObject.
NObjectAddPropertyChangedCallback | Adds a "Property changed" callback to NObject.
NObjectCaptureProperties | Adds the properties of the specified object to the specified property bag.
NObjectClone | Creates a copy of specified object.
NObjectCompareTo | Compares the specified object with another specified object and returns an indication of their relative values.
NObjectCopyProperties | Copies property values from one object to another.
NObjectEquals | Compares the objects.
NObjectGet | Retrieves the value of NObject.
NObjectGetArray | Retrieves an array of values of an array of objects.
NObjectGetConcurrent | Retrieves the value of NObject. This function is thread-safe.
NObjectGetElements | Retrieves all elements of the specified object array.
NObjectGetFlags | Gets any flags of specified object.
NObjectGetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
NObjectGetOwnerEx | Gets owner of specified object.
NObjectGetPropertyN | Retrieves the value of the specified property of the specified object.
NObjectGetPropertyNN | Retrieves the value of the specified property of the specified object.
NObjectGetPropertyP | Retrieves the value of the specified property of the specified object.
NObjectGetSize | Retrieves the size of specified object.
NObjectGetSizeMany | Retrieves the size of the array of objects.
NObjectGetType | Retrieves type of specified object.
NObjectInvoke | Invokes the specified method or constructor, using the specified parameters.
NObjectInvokeWithPropertyBag | Invokes the specified method or constructor, using the specified parameters.
NObjectInvokeWithString | Invokes the specified method or constructor, using the specified parameters.
NObjectRef | ... more
NObjectRemoveDisposed | Removes the "Disposed" callback from NObject.
NObjectRemoveDisposedCallback | Removes the "Disposed" callback from NObject.
NObjectRemoveHandlerP | Picks a Unicode (W) or ASCII (A) version of the NObjectRemoveHandlerP function.
NObjectRemoveOwnerChanged | Removes the "Owner changed" callback from NObject.
NObjectRemoveOwnerChangedCallback | Removes the "Owner changed" callback from NObject.
NObjectRemovePropertyChanged | Removes the "Property changed" callback from NObject.
NObjectRemovePropertyChangedCallback | Removes the "Property changed" callback from NObject.
NObjectReset | Sets default values for all parameters of the specified object.
NObjectResetProperty | Sets default values for the specified property of the specified object.
NObjectSaveManyToMemoryDst | Saves an array of objects to a memory location with a specified size.
NObjectSaveManyToMemoryDstN | Saves an array of objects to a specified memory location.
NObjectSaveManyToMemoryN | Saves an array of objects to a memory location.
NObjectSaveManyToStream | Saves a NObject array in a stream.
NObjectSaveToMemoryDst | Saves an objects to a memory location with specified size.
NObjectSaveToMemoryDstN | Save an object to a specified memory location.
NObjectSaveToMemoryN | Saves an object to a memory location.
NObjectSaveToStream | Saves NObject to a stream.
NObjectSet | Set the value of NObject.
NObjectSetConcurrent | Set the value of NObject. This function is tread-safe.
NObjectSetFlags | Sets the flags for the specified object.
NObjectSetPropertyN | Sets the specified property of the specified object to the specified value.
NObjectSetPropertyNN | Sets the specified property of the specified object to the specified value.
NObjectSetPropertyP | Sets the specified property of the specified object to the specified value.
NObjectToString | Returns string representation of the object.
NObjectUnref | ... more
NObjectUnrefArray | ... more
NObjectUnrefElements | ... more


NObject.h Macros

NObject.h Macros
Macros
Name | Description
NObjectGetPropertyP | Picks a Unicode (W) or ASCII (A) version of the NObjectGetPropertyP function.
NObjectInvoke | Picks a Unicode (W) or ASCII (A) version of the NObjectInvoke function.
NObjectInvokeWithPropertyBag | Picks a Unicode (W) or ASCII (A) version of the NObjectInvokeWithPropertyBag function.
NObjectInvokeWithString | Picks a Unicode (W) or ASCII (A) version of the NObjectInvokeWithString function.
NObjectResetProperty | Picks a Unicode (W) or ASCII (A) version of the NObjectResetProperty function.
NObjectSetPropertyP | Picks a Unicode (W) or ASCII (A) version of the NObjectSetPropertyP function.
NObjectToString | Picks a Unicode (W) or ASCII (A) version of the NObjectToString function.
N_OBJECT_REF_RET | ... more


NObjectPartInfo Unit Files

NObjectPartInfo Unit Files
Files
Name | Description
NObjectPartInfo.h | Header file for the NObjectPartInfo unit.


NObjectPartInfo Unit Functions

NObjectPartInfo Unit Functions
Legend
Functions
Name | Description
NObjectPartInfoGetDeclaredConstant | Retrieves the specified declared constant of the object part.
NObjectPartInfoGetDeclaredConstantCount | Retrieves the number of declared constants in the object part.
NObjectPartInfoGetDeclaredConstantWithName | Retrieves the specified declared constant of the object part.
NObjectPartInfoGetDeclaredConstants | Retrieves all declared constants in the object part.
NObjectPartInfoGetDeclaredEvent | Retrieves the specified declared event of the object part.
NObjectPartInfoGetDeclaredEventCount | Retrieves the number of declared events in the object part.
NObjectPartInfoGetDeclaredEventWithName | Retrieves the specified declared event of the object part.
NObjectPartInfoGetDeclaredEvents | Retrieves all declared events in the object part.
NObjectPartInfoGetDeclaredMethod | Retrieves the specified declared method of the object part.
NObjectPartInfoGetDeclaredMethodCount | Retrieves the number of declared methods in the object part.
NObjectPartInfoGetDeclaredMethodWithName | Retrieves the specified declared method of the object part.
NObjectPartInfoGetDeclaredMethods | Retrieves all declared methods in the object part.
NObjectPartInfoGetDeclaredMethodsWithName | Retrieves all declared methods in the object part.
NObjectPartInfoGetDeclaredProperties | Retrieves all declared properties in the object part.
NObjectPartInfoGetDeclaredProperty | Retrieves the specified declared property of the object part.
NObjectPartInfoGetDeclaredPropertyCount | Retrieves the number of declared properties in the object part.
NObjectPartInfoGetDeclaredPropertyWithName | Retrieves the specified declared property of the object part.
NObjectPartInfoGetObjectPart | Retrieves the specified object part.
NObjectPartInfoGetPropertyName | Retrieves the name of an object part property.


NObjectPartInfo Unit Macros

NObjectPartInfo Unit Macros
Macros
Name | Description
NObjectPartInfoGetDeclaredConstantWithName | Picks a Unicode (W) or ASCII (A) version of the NObjectPartInfoGetDeclaredConstantWithName function.
NObjectPartInfoGetDeclaredEventWithName | Picks a Unicode (W) or ASCII (A) version of the NObjectPartInfoGetDeclaredEventWithName function.
NObjectPartInfoGetDeclaredMethodWithName | Picks a Unicode (W) or ASCII (A) version of the NObjectPartInfoGetDeclaredMethodWithName function.
NObjectPartInfoGetDeclaredMethodsWithName | Picks a Unicode (W) or ASCII (A) version of the NObjectPartInfoGetDeclaredMethodsWithName function.
NObjectPartInfoGetDeclaredPropertyWithName | Picks a Unicode (W) or ASCII (A) version of the NObjectPartInfoGetDeclaredPropertyWithName function.


NObjectPartInfo.h Functions

NObjectPartInfo.h Functions
Legend
Functions
Name | Description
NObjectPartInfoGetDeclaredConstant | Retrieves the specified declared constant of the object part.
NObjectPartInfoGetDeclaredConstantCount | Retrieves the number of declared constants in the object part.
NObjectPartInfoGetDeclaredConstantWithName | Retrieves the specified declared constant of the object part.
NObjectPartInfoGetDeclaredConstants | Retrieves all declared constants in the object part.
NObjectPartInfoGetDeclaredEvent | Retrieves the specified declared event of the object part.
NObjectPartInfoGetDeclaredEventCount | Retrieves the number of declared events in the object part.
NObjectPartInfoGetDeclaredEventWithName | Retrieves the specified declared event of the object part.
NObjectPartInfoGetDeclaredEvents | Retrieves all declared events in the object part.
NObjectPartInfoGetDeclaredMethod | Retrieves the specified declared method of the object part.
NObjectPartInfoGetDeclaredMethodCount | Retrieves the number of declared methods in the object part.
NObjectPartInfoGetDeclaredMethodWithName | Retrieves the specified declared method of the object part.
NObjectPartInfoGetDeclaredMethods | Retrieves all declared methods in the object part.
NObjectPartInfoGetDeclaredMethodsWithName | Retrieves all declared methods in the object part.
NObjectPartInfoGetDeclaredProperties | Retrieves all declared properties in the object part.
NObjectPartInfoGetDeclaredProperty | Retrieves the specified declared property of the object part.
NObjectPartInfoGetDeclaredPropertyCount | Retrieves the number of declared properties in the object part.
NObjectPartInfoGetDeclaredPropertyWithName | Retrieves the specified declared property of the object part.
NObjectPartInfoGetObjectPart | Retrieves the specified object part.
NObjectPartInfoGetPropertyName | Retrieves the name of an object part property.


NObjectPartInfo.h Macros

NObjectPartInfo.h Macros
Macros
Name | Description
NObjectPartInfoGetDeclaredConstantWithName | Picks a Unicode (W) or ASCII (A) version of the NObjectPartInfoGetDeclaredConstantWithName function.
NObjectPartInfoGetDeclaredEventWithName | Picks a Unicode (W) or ASCII (A) version of the NObjectPartInfoGetDeclaredEventWithName function.
NObjectPartInfoGetDeclaredMethodWithName | Picks a Unicode (W) or ASCII (A) version of the NObjectPartInfoGetDeclaredMethodWithName function.
NObjectPartInfoGetDeclaredMethodsWithName | Picks a Unicode (W) or ASCII (A) version of the NObjectPartInfoGetDeclaredMethodsWithName function.
NObjectPartInfoGetDeclaredPropertyWithName | Picks a Unicode (W) or ASCII (A) version of the NObjectPartInfoGetDeclaredPropertyWithName function.


NParameterBag Unit Files

NParameterBag Unit Files
Files
Name | Description
NParameterBag.h | Header file for the NParameterBag unit.


NParameterBag Unit Functions

NParameterBag Unit Functions
Legend
Functions
Name | Description
NParameterBagApplyPropertyBag | Applies the specified parameter bag to the specified property bag.
NParameterBagContains | Checks whether the specified parameter bag contains the parameter with specified key.
NParameterBagCreate | Creates a new parameter bag from an array of parameters.
NParameterBagGet | Retrieves the parameter specified by the key.
NParameterBagGetAt | Retrieves the parameter specified by an index.
NParameterBagGetCount | Retrieves the number of parameters in the specified parameter bag.
NParameterBagGetKey | Retrieves the key to the parameter specified by index.
NParameterBagGetKeys | Retrieves keys of all parameters in the bag.
NParameterBagGetValue | Retrieves the value of the parameter specified by an index.
NParameterBagGetValues | Retrieves values of all parameters in the bag.
NParameterBagSet | Sets the value of the parameter specified by the key.
NParameterBagSetValue | Sets the value of the parameter specified by an index.
NParameterBagToArray | Converts the specified parameter bag into a name-value pair array.
NParameterBagToPropertyBag | Converts a parameter bag to a property bag.
NParameterBagTryGet | Retrieves the parameter specified by the key. Returns a Boolean value indicating whether the operation succeeded.


NParameterBag Unit Macros

NParameterBag Unit Macros
Macros
Name | Description
NParameterBagContains | Picks a Unicode (W) or ASCII (A) version of the NParameterBagContains function.
NParameterBagGet | Picks a Unicode (W) or ASCII (A) version of the NParameterBagGet function.
NParameterBagSet | Picks a Unicode (W) or ASCII (A) version of the NParameterBag function.
NParameterBagTryGet | Picks a Unicode (W) or ASCII (A) version of the NParameterBagTryGet function.


NParameterBag.h Functions

NParameterBag.h Functions
Legend
Functions
Name | Description
NParameterBagApplyPropertyBag | Applies the specified parameter bag to the specified property bag.
NParameterBagContains | Checks whether the specified parameter bag contains the parameter with specified key.
NParameterBagCreate | Creates a new parameter bag from an array of parameters.
NParameterBagGet | Retrieves the parameter specified by the key.
NParameterBagGetAt | Retrieves the parameter specified by an index.
NParameterBagGetCount | Retrieves the number of parameters in the specified parameter bag.
NParameterBagGetKey | Retrieves the key to the parameter specified by index.
NParameterBagGetKeys | Retrieves keys of all parameters in the bag.
NParameterBagGetValue | Retrieves the value of the parameter specified by an index.
NParameterBagGetValues | Retrieves values of all parameters in the bag.
NParameterBagSet | Sets the value of the parameter specified by the key.
NParameterBagSetValue | Sets the value of the parameter specified by an index.
NParameterBagToArray | Converts the specified parameter bag into a name-value pair array.
NParameterBagToPropertyBag | Converts a parameter bag to a property bag.
NParameterBagTryGet | Retrieves the parameter specified by the key. Returns a Boolean value indicating whether the operation succeeded.


NParameterBag.h Macros

NParameterBag.h Macros
Macros
Name | Description
NParameterBagContains | Picks a Unicode (W) or ASCII (A) version of the NParameterBagContains function.
NParameterBagGet | Picks a Unicode (W) or ASCII (A) version of the NParameterBagGet function.
NParameterBagSet | Picks a Unicode (W) or ASCII (A) version of the NParameterBag function.
NParameterBagTryGet | Picks a Unicode (W) or ASCII (A) version of the NParameterBagTryGet function.


NParameterDescriptor Unit Files

NParameterDescriptor Unit Files
Files
Name | Description
NParameterDescriptor.h | Header file for the NParameterDescriptor module.


NParameterDescriptor Unit Functions

NParameterDescriptor Unit Functions
Legend
Functions
Name | Description
NParameterDescriptorGetDefaultValue | Retrieves the default value of the specified parameter descriptor.
NParameterDescriptorGetFormat | Retrieves the format value of the specified parameter descriptor.
NParameterDescriptorGetMaxValue | Retrieves the maximum value of the specified parameter descriptor.
NParameterDescriptorGetMinValue | Retrieves the minimum value of the specified parameter descriptor.
NParameterDescriptorGetParameterType | Retrieves the parameter type of the specified parameter descriptor.
NParameterDescriptorGetStdValue | Retrieves the specified standard value of the specified parameter descriptor.
NParameterDescriptorGetStdValueCount | Retrieves the number of standard parameter descriptor values.
NParameterDescriptorGetStdValues | Gets all standard values of the specified parameter descriptor.


NParameterDescriptor.h Functions

NParameterDescriptor.h Functions
Legend
Functions
Name | Description
NParameterDescriptorGetDefaultValue | Retrieves the default value of the specified parameter descriptor.
NParameterDescriptorGetFormat | Retrieves the format value of the specified parameter descriptor.
NParameterDescriptorGetMaxValue | Retrieves the maximum value of the specified parameter descriptor.
NParameterDescriptorGetMinValue | Retrieves the minimum value of the specified parameter descriptor.
NParameterDescriptorGetParameterType | Retrieves the parameter type of the specified parameter descriptor.
NParameterDescriptorGetStdValue | Retrieves the specified standard value of the specified parameter descriptor.
NParameterDescriptorGetStdValueCount | Retrieves the number of standard parameter descriptor values.
NParameterDescriptorGetStdValues | Gets all standard values of the specified parameter descriptor.


NParameterInfo Unit Files

NParameterInfo Unit Files
Files
Name | Description
NParameterInfo.h | Header file for the NParameterInfo unit.


NParameterInfo Unit Functions

NParameterInfo Unit Functions
Legend
Functions
Name | Description
NParameterInfoGetAttributes | Retrieves the attributes of the specified parameter.
NParameterInfoGetDefaultValue | Retrieves the default value of the specified parameter.
NParameterInfoGetFormat | Retrieves the format of the specified parameter.
NParameterInfoGetMaxValue | Retrieves the maximal value of the specified parameter.
NParameterInfoGetMinValue | Retrieves the minimal value of the specified parameter.
NParameterInfoGetName | Retrieves the name of the specified parameter.
NParameterInfoGetParameterType | Retrieves the type of the parameter.
NParameterInfoGetStdValue | Retrieves the specified standard value of the specified parameter.
NParameterInfoGetStdValueCount | Retrieves the number of standard values of the specified parameter.
NParameterInfoGetStdValues | Retrieves all standard values of the specified parameter.


NParameterInfo.h Functions

NParameterInfo.h Functions
Legend
Functions
Name | Description
NParameterInfoGetAttributes | Retrieves the attributes of the specified parameter.
NParameterInfoGetDefaultValue | Retrieves the default value of the specified parameter.
NParameterInfoGetFormat | Retrieves the format of the specified parameter.
NParameterInfoGetMaxValue | Retrieves the maximal value of the specified parameter.
NParameterInfoGetMinValue | Retrieves the minimal value of the specified parameter.
NParameterInfoGetName | Retrieves the name of the specified parameter.
NParameterInfoGetParameterType | Retrieves the type of the parameter.
NParameterInfoGetStdValue | Retrieves the specified standard value of the specified parameter.
NParameterInfoGetStdValueCount | Retrieves the number of standard values of the specified parameter.
NParameterInfoGetStdValues | Retrieves all standard values of the specified parameter.


NPath Unit Files

NPath Unit Files
Files
Name | Description
NPath.h | Header file for the NPath unit.


NPath Unit Functions

NPath Unit Functions
Legend
Functions
Name | Description
NPathChangeExtension | Changes the extension of a path string.
NPathChangeExtensionPN | Changes the extension of a path string.
NPathCheck | Checks whether the specified path is valid and throws an exception if the path is not valid.
NPathCheckN | Checks whether the specified path is valid and throws an exception if the path is not valid.
NPathCombine | Combines two strings into a path.
NPathCombineP1N | Combines two strings into a path.
NPathCombineP2N | Combines two strings into a path.
NPathGetDirectoryName | Returns the directory information for the specified path string.
NPathGetExtension | Returns the extension of the specified path string.
NPathGetFileName | Returns the file name and extension of the specified path string.
NPathGetFileNameWithoutExtension | Returns the file name of the specified path string without the extension.
NPathGetTempFileName | Creates a uniquely named, zero-byte temporary file on disk and returns the full path of that file.
NPathGetTempPath | Returns the path of the current user's temporary folder.
NPathHasExtension | Determines whether a path includes a file name extension.
NPathIsRooted | Gets a value indicating whether the specified path string contains a root.


NPath Unit Macros

NPath Unit Macros
Macros
Name | Description
NPathChangeExtension | Picks a Unicode (W) or ASCII (A) version of the NPathChangeExtension function.
NPathChangeExtensionPN | Picks a Unicode (W) or ASCII (A) version of the NPathChangeExtensionPN function.
NPathCheck | Picks a Unicode (W) or ASCII (A) version of the NPathCheck function.
NPathCombine | Picks a Unicode (W) or ASCII (A) version of the NPathCombine function.
NPathCombineP1N | Picks a Unicode (W) or ASCII (A) version of the NPathCombineP1N function.
NPathCombineP2N | Picks a Unicode (W) or ASCII (A) version of the NPathCombineP2N function.
NPathGetDirectoryName | Picks a Unicode (W) or ASCII (A) version of the NPathGetDirectoryName function.
NPathGetExtension | Picks a Unicode (W) or ASCII (A) version of the NPathGetExtension function.
NPathGetFileName | Picks a Unicode (W) or ASCII (A) version of the NPathGetFileName function.
NPathGetFileNameWithoutExtension | Picks a Unicode (W) or ASCII (A) version of the NPathGetFileNameWithoutExtension function.
NPathHasExtension | Picks a Unicode (W) or ASCII (A) version of the NPathHasExtension function.
NPathIsRooted | Picks a Unicode (W) or ASCII (A) version of the NPathIsRooted function.
N_MAX_FILE_NAME | Specifies the maximum file name length.
N_PATH_ALT_DIRECTORY_SEPARATOR | Picks a Unicode (W) or ANSCII (A) version of the N_PATH_PATH_SEPARATOR macro which specifies an alternate character used to separate directory levels in a path string that reflects a hierarchical file system organization.
N_PATH_DIRECTORY_SEPARATOR | Picks a Unicode (W) or ANSCII (A) version of the N_PATH_PATH_SEPARATOR macro which specifies a character used to separate directory levels in a path string that reflects a hierarchical file system organization.
N_PATH_IS_CASE_SENSITIVE | Specifies whether the path is case sensitive.
N_PATH_PATH_SEPARATOR | Picks a Unicode (W) or ANSCII (A) version of the N_PATH_PATH_SEPARATOR macro which specifies a separator character used to separate path strings in environment variables.
N_PATH_VOLUME_SEPARATOR | Picks a Unicode (W) or ANSCII (A) version of the N_PATH_PATH_SEPARATOR macro which specifies a volume separator character.


NPath.h Functions

NPath.h Functions
Legend
Functions
Name | Description
NPathChangeExtension | Changes the extension of a path string.
NPathChangeExtensionPN | Changes the extension of a path string.
NPathCheck | Checks whether the specified path is valid and throws an exception if the path is not valid.
NPathCheckN | Checks whether the specified path is valid and throws an exception if the path is not valid.
NPathCombine | Combines two strings into a path.
NPathCombineP1N | Combines two strings into a path.
NPathCombineP2N | Combines two strings into a path.
NPathGetDirectoryName | Returns the directory information for the specified path string.
NPathGetExtension | Returns the extension of the specified path string.
NPathGetFileName | Returns the file name and extension of the specified path string.
NPathGetFileNameWithoutExtension | Returns the file name of the specified path string without the extension.
NPathGetTempFileName | Creates a uniquely named, zero-byte temporary file on disk and returns the full path of that file.
NPathGetTempPath | Returns the path of the current user's temporary folder.
NPathHasExtension | Determines whether a path includes a file name extension.
NPathIsRooted | Gets a value indicating whether the specified path string contains a root.


NPath.h Macros

NPath.h Macros
Macros
Name | Description
NPathChangeExtension | Picks a Unicode (W) or ASCII (A) version of the NPathChangeExtension function.
NPathChangeExtensionPN | Picks a Unicode (W) or ASCII (A) version of the NPathChangeExtensionPN function.
NPathCheck | Picks a Unicode (W) or ASCII (A) version of the NPathCheck function.
NPathCombine | Picks a Unicode (W) or ASCII (A) version of the NPathCombine function.
NPathCombineP1N | Picks a Unicode (W) or ASCII (A) version of the NPathCombineP1N function.
NPathCombineP2N | Picks a Unicode (W) or ASCII (A) version of the NPathCombineP2N function.
NPathGetDirectoryName | Picks a Unicode (W) or ASCII (A) version of the NPathGetDirectoryName function.
NPathGetExtension | Picks a Unicode (W) or ASCII (A) version of the NPathGetExtension function.
NPathGetFileName | Picks a Unicode (W) or ASCII (A) version of the NPathGetFileName function.
NPathGetFileNameWithoutExtension | Picks a Unicode (W) or ASCII (A) version of the NPathGetFileNameWithoutExtension function.
NPathHasExtension | Picks a Unicode (W) or ASCII (A) version of the NPathHasExtension function.
NPathIsRooted | Picks a Unicode (W) or ASCII (A) version of the NPathIsRooted function.
N_MAX_FILE_NAME | Specifies the maximum file name length.
N_PATH_ALT_DIRECTORY_SEPARATOR | Picks a Unicode (W) or ANSCII (A) version of the N_PATH_PATH_SEPARATOR macro which specifies an alternate character used to separate directory levels in a path string that reflects a hierarchical file system organization.
N_PATH_DIRECTORY_SEPARATOR | Picks a Unicode (W) or ANSCII (A) version of the N_PATH_PATH_SEPARATOR macro which specifies a character used to separate directory levels in a path string that reflects a hierarchical file system organization.
N_PATH_IS_CASE_SENSITIVE | Specifies whether the path is case sensitive.
N_PATH_PATH_SEPARATOR | Picks a Unicode (W) or ANSCII (A) version of the N_PATH_PATH_SEPARATOR macro which specifies a separator character used to separate path strings in environment variables.
N_PATH_VOLUME_SEPARATOR | Picks a Unicode (W) or ANSCII (A) version of the N_PATH_PATH_SEPARATOR macro which specifies a volume separator character.


NPlugin Unit Files

NPlugin Unit Files
Files
Name | Description
NPlugin.h | Header file for plugins management framework.


NPlugin Unit Functions

NPlugin Unit Functions
Legend
Functions
Name | Description
NPluginDisable | Adds plugin's name to disabled plugins collection.
NPluginEnable | Removes plugin's name from disabled plugins collection.
NPluginGetError | Returns the most recent error for the specified NPlugin.
NPluginGetFileNameN | Returns plug-in library name.
NPluginGetLoadTime | Returns plug-in load time.
NPluginGetModule | Gets module for specified NPlugin.
NPluginGetPlugTime | Returns plug-in plug time (nanoseconds).
NPluginGetSelectedInterfaceVersion | Returns current version of selected plugin interface.
NPluginGetState | Returns the state of specified plugin.
NPluginPlug | Plugs specified plug-in to the system.
NPluginUnplug | Unplugs specified plug-in from the system.


NPlugin Unit Structs, Records, Enums

NPlugin Unit Structs, Records, Enums
Legend
Structs, Records, Enums
Name | Description
NPluginState_ | Enumerates NPlugin state values.
NPluginState | Enumerates NPlugin state values.


NPlugin.h Enumerations

NPlugin.h Enumerations
Legend
Enumerations
Name | Description
NPluginState_ | Enumerates NPlugin state values.
NPluginState | Enumerates NPlugin state values.


NPlugin.h Functions

NPlugin.h Functions
Legend
Functions
Name | Description
NPluginDisable | Adds plugin's name to disabled plugins collection.
NPluginEnable | Removes plugin's name from disabled plugins collection.
NPluginGetError | Returns the most recent error for the specified NPlugin.
NPluginGetFileNameN | Returns plug-in library name.
NPluginGetLoadTime | Returns plug-in load time.
NPluginGetModule | Gets module for specified NPlugin.
NPluginGetPlugTime | Returns plug-in plug time (nanoseconds).
NPluginGetSelectedInterfaceVersion | Returns current version of selected plugin interface.
NPluginGetState | Returns the state of specified plugin.
NPluginPlug | Plugs specified plug-in to the system.
NPluginUnplug | Unplugs specified plug-in from the system.


NPluginEventDescriptor Unit Files

NPluginEventDescriptor Unit Files
Files
Name | Description
NPluginEventDescriptor.h | Header file for the NPluginEventDescriptor unit.


NPluginEventDescriptor Unit Functions

NPluginEventDescriptor Unit Functions
Legend
Functions
Name | Description
NPluginEventDescriptorCreate | Creates a new plugin event descriptor.


NPluginEventDescriptor.h Functions

NPluginEventDescriptor.h Functions
Legend
Functions
Name | Description
NPluginEventDescriptorCreate | Creates a new plugin event descriptor.


NPluginInternal Unit Functions

NPluginInternal Unit Functions
Legend
Functions
Name | Description
NPluginGetSelectedInterface | Retrieves the selected plugin interface.


NPluginInternal Unit Macros

NPluginInternal Unit Macros
Macros
Name | Description
NPluginInterfaceVersionInfoConst | Defines the plugin interface info constant.


NPluginInternal Unit Structs, Records, Enums

NPluginInternal Unit Structs, Records, Enums
Legend
Structs, Records, Enums
Name | Description
NPluginInterfaceVersionInfo_ | Provides plugin interface version information.
NPluginInterfaceVersionInfo | Provides plugin interface version information.


NPluginManager Unit Files

NPluginManager Unit Files
Files
Name | Description
NPluginManager.h | Header file for NPluginManager. Provides functions for working with NPlugin.


NPluginManager Unit Functions

NPluginManager Unit Functions
Legend
Functions
Name | Description
NPluginManagerAddDisabledPlugin | Disables plugin specified by name and adds to disabled plugins collection.
NPluginManagerAddDisabledPluginsCollectionChanged | Adds user specified callback for "disabled plugins collection changed" event. This callback is called when disabled plugins collection was changed.
NPluginManagerAddDisabledPluginsCollectionChangedCallback | Adds user specified callback for "disabled plugins collection changed" event. This callback is called when disabled plugins collection was changed.
NPluginManagerAddPlugin | Loads plugin. It's dependencies are searched relative to specified directory.
NPluginManagerAddPluginFromFile | Loads plugin from user specified file.
NPluginManagerAllowsUnplug | Checks whether NPluginPlug and NPluginUnplug functions work
NPluginManagerClearDisabledPlugins | Clears the collection of disabled plugins.
NPluginManagerEnsurePluginSearchPerformed | Trigger plugin search in plugin directory if search hasn't been performed yet.
NPluginManagerGetDisabledPluginCount | Gets disabled plugins count.
NPluginManagerGetDisabledPlugins | Retrieves all disabled plugins in a plugin manager.
NPluginManagerGetInstances | Retrieves the instances of the plugin manager.
NPluginManagerGetInterfaceTypeN | Returns NPluginManager interface type name.
NPluginManagerGetInterfaceVersions | Returns the range of supported interface versions by specified NPluginManager.
NPluginManagerGetPlugin | Returns NPlugin specified by index.
NPluginManagerGetPluginByName | Gets plugin by specified name.
NPluginManagerGetPluginCount | Returns plugins count in specified NPluginManager.
NPluginManagerGetPluginSearchPathN | Gets plugin dependencies search path.
NPluginManagerGetPlugins | Retrieves all plugins in the plugin manager.
NPluginManagerPlugAll | Plugs all enabled plugins into the system.
NPluginManagerRefresh | Refreshes plugins list (search for added/removed plugin files).
NPluginManagerRemoveDisabledPlugin | Removes plugin specified by name from disabled plugins collection.
NPluginManagerRemoveDisabledPluginAt | Removes plugin specified by index from disabled plugins collection.
NPluginManagerRemoveDisabledPluginsCollectionChanged | Removes user specified "disabled plugins collection changed" event.
NPluginManagerRemoveDisabledPluginsCollectionChangedCallback | Removes user specified callback for "disabled plugins collection changed" event.
NPluginManagerRemovePluginsCollectionChanged | Removes user specified "plugins collection changed" event.
NPluginManagerRemovePluginsCollectionChangedCallback | Removes user specified callback for "plugins collection changed" event.
NPluginManagerSetPluginSearchPath | Sets directory which will be automatically searched for plugins.
NPluginManagerUnplugAll | Unplugs all plugins.


NPluginManager Unit Macros

NPluginManager Unit Macros
Macros
Name | Description
NPluginManagerAddDisabledPlugin | Picks a Unicode (W) or ASCII (A) version of the NPluginManagerAddDisabledPlugin function.
NPluginManagerAddPlugin | Picks a Unicode (W) or ASCII (A) version of the NPluginManagerAddPlugin function.
NPluginManagerAddPluginFromFile | Picks a Unicode (W) or ASCII (A) version of the NPluginManagerAddPluginFromFile function.
NPluginManagerGetPluginByName | Picks a Unicode (W) or ASCII (A) version of the NPluginManagerGetPluginByName function.
NPluginManagerRemoveDisabledPlugin | Picks a Unicode (W) or ASCII (A) version of the NPluginManagerRemoveDisabledPlugin function.
NPluginManagerSetPluginSearchPath | Picks a Unicode (W) or ASCII (A) version of the NPluginManagerSetPluginSearchPath function.


See Also

See Also
See Also

NPluginManagerPlugAll

NPluginManagerClearDisabledPlugin

NPluginManagerGetDisabledPluginCount

NPluginManagerGetDisabledPlugin


See Also

See Also
See Also

NPluginManagerPlugAll

NPluginManagerAddDisabledPlugin

NPluginManagerGetDisabledPluginCount

NPluginManagerGetDisabledPlugin


See Also

See Also
See Also

NPluginManagerGetDisabledPlugin

NPluginManagerPlugAll


NPluginManager.h Functions

NPluginManager.h Functions
Legend
Functions
Name | Description
NPluginManagerAddDisabledPlugin | Disables plugin specified by name and adds to disabled plugins collection.
NPluginManagerAddDisabledPluginsCollectionChanged | Adds user specified callback for "disabled plugins collection changed" event. This callback is called when disabled plugins collection was changed.
NPluginManagerAddDisabledPluginsCollectionChangedCallback | Adds user specified callback for "disabled plugins collection changed" event. This callback is called when disabled plugins collection was changed.
NPluginManagerAddPlugin | Loads plugin. It's dependencies are searched relative to specified directory.
NPluginManagerAddPluginFromFile | Loads plugin from user specified file.
NPluginManagerAllowsUnplug | Checks whether NPluginPlug and NPluginUnplug functions work
NPluginManagerClearDisabledPlugins | Clears the collection of disabled plugins.
NPluginManagerEnsurePluginSearchPerformed | Trigger plugin search in plugin directory if search hasn't been performed yet.
NPluginManagerGetDisabledPluginCount | Gets disabled plugins count.
NPluginManagerGetDisabledPlugins | Retrieves all disabled plugins in a plugin manager.
NPluginManagerGetInstances | Retrieves the instances of the plugin manager.
NPluginManagerGetInterfaceTypeN | Returns NPluginManager interface type name.
NPluginManagerGetInterfaceVersions | Returns the range of supported interface versions by specified NPluginManager.
NPluginManagerGetPlugin | Returns NPlugin specified by index.
NPluginManagerGetPluginByName | Gets plugin by specified name.
NPluginManagerGetPluginCount | Returns plugins count in specified NPluginManager.
NPluginManagerGetPluginSearchPathN | Gets plugin dependencies search path.
NPluginManagerGetPlugins | Retrieves all plugins in the plugin manager.
NPluginManagerPlugAll | Plugs all enabled plugins into the system.
NPluginManagerRefresh | Refreshes plugins list (search for added/removed plugin files).
NPluginManagerRemoveDisabledPlugin | Removes plugin specified by name from disabled plugins collection.
NPluginManagerRemoveDisabledPluginAt | Removes plugin specified by index from disabled plugins collection.
NPluginManagerRemoveDisabledPluginsCollectionChanged | Removes user specified "disabled plugins collection changed" event.
NPluginManagerRemoveDisabledPluginsCollectionChangedCallback | Removes user specified callback for "disabled plugins collection changed" event.
NPluginManagerRemovePluginsCollectionChanged | Removes user specified "plugins collection changed" event.
NPluginManagerRemovePluginsCollectionChangedCallback | Removes user specified callback for "plugins collection changed" event.
NPluginManagerSetPluginSearchPath | Sets directory which will be automatically searched for plugins.
NPluginManagerUnplugAll | Unplugs all plugins.


NPluginManager.h Macros

NPluginManager.h Macros
Macros
Name | Description
NPluginManagerAddDisabledPlugin | Picks a Unicode (W) or ASCII (A) version of the NPluginManagerAddDisabledPlugin function.
NPluginManagerAddPlugin | Picks a Unicode (W) or ASCII (A) version of the NPluginManagerAddPlugin function.
NPluginManagerAddPluginFromFile | Picks a Unicode (W) or ASCII (A) version of the NPluginManagerAddPluginFromFile function.
NPluginManagerGetPluginByName | Picks a Unicode (W) or ASCII (A) version of the NPluginManagerGetPluginByName function.
NPluginManagerRemoveDisabledPlugin | Picks a Unicode (W) or ASCII (A) version of the NPluginManagerRemoveDisabledPlugin function.
NPluginManagerSetPluginSearchPath | Picks a Unicode (W) or ASCII (A) version of the NPluginManagerSetPluginSearchPath function.


NPluginMethodDescriptor Unit Files

NPluginMethodDescriptor Unit Files
Files
Name | Description
NPluginMethodDescriptor.h | Header file for the NPluginMethodDescriptor unit.


NPluginMethodDescriptor Unit Functions

NPluginMethodDescriptor Unit Functions
Legend
Functions
Name | Description
NPluginMethodDescriptorCreate | Creates a new plugin method descriptor.


NPluginMethodDescriptor.h Functions

NPluginMethodDescriptor.h Functions
Legend
Functions
Name | Description
NPluginMethodDescriptorCreate | Creates a new plugin method descriptor.


NPluginModule Unit Functions

NPluginModule Unit Functions
Legend
Functions
Name | Description
NPluginModuleCreate | Creates a new NPluginModule.
NPluginModuleGetIncompatiblePluginsN | Gets incompatible plugins list.
NPluginModuleGetInterfaceTypeN | Gets plugin interface type name.
NPluginModuleGetInterfaceVersions | Returns the range of supported interface versions by specified NPluginModule.
NPluginModuleGetPluginNameN | Gets plugin name.
NPluginModuleSetIncompatiblePluginsN | Sets the list of incompatible plugins for the specified plugin module.
NPluginModuleSetInterfaceTypeN | Sets a new interface type for the specified plugin module.
NPluginModuleSetPluginNameN | Sets the name of the plugin for the specified plugin module.
NPluginModuleSetPriority | Sets the priority of the specified plugin module.
NPluginModuleGetPriority | Gets plugin priority over other plugins.
HNPluginModule | Handle to NPluginModule.


NPluginModule Unit Macros

NPluginModule Unit Macros
Macros
Name | Description
NPluginModuleSetIncompatiblePlugins | Picks a Unicode (W) or ANSCII (A) version of the NPluginModuleSetIncompatiblePlugins function.
NPluginModuleSetInterfaceType | Picks a Unicode (W) or ANSCII (A) version of the NPluginModuleSetInterfaceTypes function.
NPluginModuleSetPluginName | Picks a Unicode (W) or ANSCII (A) version of the NPluginModuleSetPluginType function.


NPluginModuleInternal Unit Functions

NPluginModuleInternal Unit Functions
Legend
Functions
Name | Description
NPluginModuleSetGetEvents | Sets the process that retrieves events for the specified module.
NPluginModuleSetGetMethods | Sets the process that retrieves methods for the specified module.
NPluginModuleSetGetProperties | Sets the process that retrieves properties for the specified module.
NPluginModuleSetInterfaceVersions | Sets plugin interface versions for the specified plugin manager.
NPluginModuleSetPlug | Sets the plug process for the specified plugin module.
NPluginModuleSetUnplug | Sets the unplug process for the specified plugin module.


NPluginPropertyDescriptor Unit Files

NPluginPropertyDescriptor Unit Files
Files
Name | Description
NPluginPropertyDescriptor.h | Header file for the NPluginPropertyDescriptor unit.


NPluginPropertyDescriptor Unit Functions

NPluginPropertyDescriptor Unit Functions
Legend
Functions
Name | Description
NPluginPropertyDescriptorCreate | Creates a new plugin property descriptor.


NPluginPropertyDescriptor.h Functions

NPluginPropertyDescriptor.h Functions
Legend
Functions
Name | Description
NPluginPropertyDescriptorCreate | Creates a new plugin property descriptor.


NProcess Unit Files

NProcess Unit Files
Files
Name | Description
NProcess.h | Header file for the NProcess unit.


NProcess Unit Functions

NProcess Unit Functions
Legend
Functions
Name | Description
NProcessCreateFromOSHandle | Creates a new process from the specified operating system handle.
NProcessGetCurrent | Retrieves the current process.
NProcessGetFileName | Retrieves the file name of the specified process.
NProcessGetId | Retrieves the IDs of the specified process.
NProcessGetName | Retrieves the name of the specified process.
NProcessGetOSHandle | Retrieves the operating system handle used by the specified process.


NProcess.h Functions

NProcess.h Functions
Legend
Functions
Name | Description
NProcessCreateFromOSHandle | Creates a new process from the specified operating system handle.
NProcessGetCurrent | Retrieves the current process.
NProcessGetFileName | Retrieves the file name of the specified process.
NProcessGetId | Retrieves the IDs of the specified process.
NProcessGetName | Retrieves the name of the specified process.
NProcessGetOSHandle | Retrieves the operating system handle used by the specified process.


NProcessorInfo Unit Files

NProcessorInfo Unit Files
Files
Name | Description
NProcessorInfo.h | Header file for the NProcessorInfo. Provides functionality for getting processor information.


NProcessorInfo Unit Functions

NProcessorInfo Unit Functions
Legend
Functions
Name | Description
NProcessorInfoGetCount | Retrieves the number of logical processors in the current group.
NProcessorInfoGetModelInfo | Retrieves processor model information.
NProcessorInfoGetModelNameN | Retrieves processor model name.
NProcessorInfoGetVendor | Retrieves a pointer to enumeration that contains information about processor's vendor.
NProcessorInfoGetVendorNameN | Retrieves processor's vendor name.
NProcessorInfoIsFeatureSupported | Checks if current CPU supports the specified feature.


NProcessorInfo Unit Structs, Records, Enums

NProcessorInfo Unit Structs, Records, Enums
Legend
Structs, Records, Enums
Name | Description
NProcessorVendor_ | Enumerates different processor vendors.
NProcessorVendor | Enumerates different processor vendors.


NProcessorInfo.h Enumerations

NProcessorInfo.h Enumerations
Legend
Enumerations
Name | Description
NProcessorVendor_ | Enumerates different processor vendors.
NProcessorVendor | Enumerates different processor vendors.


NProcessorInfo.h Functions

NProcessorInfo.h Functions
Legend
Functions
Name | Description
NProcessorInfoGetCount | Retrieves the number of logical processors in the current group.
NProcessorInfoGetModelInfo | Retrieves processor model information.
NProcessorInfoGetModelNameN | Retrieves processor model name.
NProcessorInfoGetVendor | Retrieves a pointer to enumeration that contains information about processor's vendor.
NProcessorInfoGetVendorNameN | Retrieves processor's vendor name.
NProcessorInfoIsFeatureSupported | Checks if current CPU supports the specified feature.


NPropertyInfo Unit Files

NPropertyInfo Unit Files
Files
Name | Description
NPropertyInfo.h | Header file for the NPropertyInfo unit.


NPropertyInfo Unit Functions

NPropertyInfo Unit Functions
Legend
Functions
Name | Description
NPropertyInfoCanResetValue | Checks whether the specified property can reset its value to default value.
NPropertyInfoGetDefaultValue | Retrieves the default value of the specified property.
NPropertyInfoGetFormat | Retrieves the format of the specified property.
NPropertyInfoGetGetMethod | Retrieves the method which gets the value of the property.
NPropertyInfoGetMaxValue | Retrieves the maximal value of the specified property.
NPropertyInfoGetMinValue | Retrieves the minimal value of the specified property.
NPropertyInfoGetPropertyType | Retrieves the type of the property.
NPropertyInfoGetSetMethod | Retrieves the method which sets the value of the property.
NPropertyInfoGetStdValue | Retrieves the specified standard value of the specified property.
NPropertyInfoGetStdValueCount | Retrieves the number of standard values of the specified property.
NPropertyInfoGetStdValues | Retrieves all standard values of the specified property.
NPropertyInfoGetValue | Retrieves the value of the property.
NPropertyInfoResetValue | Resets the value of the property.
NPropertyInfoSetValue | Sets the value of the property.


NPropertyInfo.h Functions

NPropertyInfo.h Functions
Legend
Functions
Name | Description
NPropertyInfoCanResetValue | Checks whether the specified property can reset its value to default value.
NPropertyInfoGetDefaultValue | Retrieves the default value of the specified property.
NPropertyInfoGetFormat | Retrieves the format of the specified property.
NPropertyInfoGetGetMethod | Retrieves the method which gets the value of the property.
NPropertyInfoGetMaxValue | Retrieves the maximal value of the specified property.
NPropertyInfoGetMinValue | Retrieves the minimal value of the specified property.
NPropertyInfoGetPropertyType | Retrieves the type of the property.
NPropertyInfoGetSetMethod | Retrieves the method which sets the value of the property.
NPropertyInfoGetStdValue | Retrieves the specified standard value of the specified property.
NPropertyInfoGetStdValueCount | Retrieves the number of standard values of the specified property.
NPropertyInfoGetStdValues | Retrieves all standard values of the specified property.
NPropertyInfoGetValue | Retrieves the value of the property.
NPropertyInfoResetValue | Resets the value of the property.
NPropertyInfoSetValue | Sets the value of the property.


NQueue Unit Files

NQueue Unit Files
Files
Name | Description
NQueue.h | Header file for the NQueue module.


NQueue Unit Functions

NQueue Unit Functions
Legend
Functions
Name | Description
NQueueClear | Clears the specified queue.
NQueueContains | Checks whether the specified queue contains the specified value.
NQueueCopyTo | Copies the specified queue to an array.
NQueueDequeue | Retrieves and removes the front element of the specified queue.
NQueueDispose | Disposes of the specified queue.
NQueueEnqueue | Adds the specified value to the end of the specified queue.
NQueueGetCapacity | Retrieves the capacity of the specified queue.
NQueueGetCount | Retrieves the number of values in the specified queue.
NQueueGetFront | Retrieves the front element of the queue.
NQueueInit | Initializes the specified queue.
NQueueInitEx | Initializes the specified queue.
NQueueInitWithCapacity | Initializes the specified queue.
NQueuePeek | Retrieves the front element of the specified queue without removing it.
NQueueSetCapacity | Sets the capacity of the specified queue.
NQueueToArray | Converts the specified queue into an array.


NQueue Unit Macros

NQueue Unit Macros
Macros
Name | Description
N_QUEUE_SIZE | Defines the size of the queue (default value 36).


NQueue.h Functions

NQueue.h Functions
Legend
Functions
Name | Description
NQueueClear | Clears the specified queue.
NQueueContains | Checks whether the specified queue contains the specified value.
NQueueCopyTo | Copies the specified queue to an array.
NQueueDequeue | Retrieves and removes the front element of the specified queue.
NQueueDispose | Disposes of the specified queue.
NQueueEnqueue | Adds the specified value to the end of the specified queue.
NQueueGetCapacity | Retrieves the capacity of the specified queue.
NQueueGetCount | Retrieves the number of values in the specified queue.
NQueueGetFront | Retrieves the front element of the queue.
NQueueInit | Initializes the specified queue.
NQueueInitEx | Initializes the specified queue.
NQueueInitWithCapacity | Initializes the specified queue.
NQueuePeek | Retrieves the front element of the specified queue without removing it.
NQueueSetCapacity | Sets the capacity of the specified queue.
NQueueToArray | Converts the specified queue into an array.


NQueue.h Macros

NQueue.h Macros
Macros
Name | Description
N_QUEUE_SIZE | Defines the size of the queue (default value 36).


NRWLock Unit Functions

NRWLock Unit Functions
Legend
Functions
Name | Description
NRWLockDispose | Disposes a reader/writer lock.
NRWLockEnterRead | Acquires a reader/writer lock in shared mode.
NRWLockEnterWrite | Acquires a reader/writer lock in exclusive mode.
NRWLockExitRead | Releases a reader/writer lock that was acquired in shared mode.
NRWLockExitWrite | Releases a reader/writer lock that was acquired in exclusive mode.
NRWLockInit | Initializes a reader/writer lock.
NRWLockTryEnterRead | Acquires a reader/writer lock in shared mode. A NBool value indicates whether the function succeeded.
NRWLockTryEnterWrite | Acquires a reader/writer lock in exclusive mode. A NBool value indicates whether the function succeeded.


NSemaphore Unit Functions

NSemaphore Unit Functions
Legend
Functions
Name | Description
NSemaphoreCreate | Creates and initializes a semaphore object.
NSemaphoreCreateFromOSHandle | Creates a new NSemaphore for the specified semaphore handle.
NSemaphoreGetOSHandle | Gets OS handle for the specified semaphore.
NSemaphoreRelease | Increments the value of the semaphore by one.


See Also

See Also
See Also
  • NWaitObject for NSemaphore functionality shared with other synchronization objects.


NStack Unit Files

NStack Unit Files
Files
Name | Description
NStack.h | Header file for the NStack module.


NStack Unit Functions

NStack Unit Functions
Legend
Functions
Name | Description
NStackClear | Clears the specified stack.
NStackContains | Checks whether the specified stack contains the specified value.
NStackCopyTo | Copies the specified stack to an array.
NStackDispose | Disposes of the specified stack.
NStackGetCapacity | Retrieves the capacity of the specified stack.
NStackGetCount | Retrieves the number of values in the specified stack.
NStackGetTop | Retrieves the top element of the stack.
NStackInit | Initializes the specified stack.
NStackInitEx | Initializes the specified stack.
NStackInitWithCapacity | Initializes the specified stack.
NStackPeek | Retrieves the top element of the specified stack without removing it.
NStackPop | Retrieves and removes the top element of the specified stack.
NStackPush | Inserts an object at the top of the specified stack.
NStackSetCapacity | Sets the capacity of the specified stack.
NStackToArray | Converts the specified stack into an array.


NStack Unit Macros

NStack Unit Macros
Macros
Name | Description
N_STACK_SIZE | Defines the size of the stack (default value 32).


NStack.h Functions

NStack.h Functions
Legend
Functions
Name | Description
NStackClear | Clears the specified stack.
NStackContains | Checks whether the specified stack contains the specified value.
NStackCopyTo | Copies the specified stack to an array.
NStackDispose | Disposes of the specified stack.
NStackGetCapacity | Retrieves the capacity of the specified stack.
NStackGetCount | Retrieves the number of values in the specified stack.
NStackGetTop | Retrieves the top element of the stack.
NStackInit | Initializes the specified stack.
NStackInitEx | Initializes the specified stack.
NStackInitWithCapacity | Initializes the specified stack.
NStackPeek | Retrieves the top element of the specified stack without removing it.
NStackPop | Retrieves and removes the top element of the specified stack.
NStackPush | Inserts an object at the top of the specified stack.
NStackSetCapacity | Sets the capacity of the specified stack.
NStackToArray | Converts the specified stack into an array.


NStack.h Macros

NStack.h Macros
Macros
Name | Description
N_STACK_SIZE | Defines the size of the stack (default value 32).


NStopwatch Unit Functions

NStopwatch Unit Functions
Legend
Functions
Name | Description
NStopwatchCreate | Creates a new NStopwatch object.
NStopwatchGetElapsed | Gets the total elapsed time measured by the specified NStopwatch.
NStopwatchGetElapsedMilliseconds | Gets the total elapsed time measured by the specified NStopwatch, in milliseconds.
NStopwatchGetElapsedTicks | Gets the total elapsed time measured by the specified NStopwatch, in timer ticks.
NStopwatchGetFrequency | Gets the frequency of the timer as the number of ticks per second.
NStopwatchGetTimestamp | Gets the current number of ticks in the timer mechanism.
NStopwatchIsHighResolution | Indicates whether the timer is based on a high-resolution performance counter.
NStopwatchIsRunning | Gets a value indicating whether the NStopwatch timer is running.
NStopwatchReset | Stops time interval measurement and resets the elapsed time to zero.
NStopwatchRestart | Stops time interval measurement, resets the elapsed time to zero, and starts measuring elapsed time.
NStopwatchStart | Starts, or resumes, measuring elapsed time for an interval.
NStopwatchStartNew | Creates a new NStopwatch object, sets the elapsed time property to zero, and starts measuring elapsed time.
NStopwatchStop | Stops measuring elapsed time for an interval.
NStopwatchTicksToMilliseconds | Converts elapsed time in ticks to milliseconds.


NStream Unit Functions

NStream Unit Functions
Legend
Functions
Name | Description
NStreamCanRead | Gets a value indicating whether the current stream supports reading.
NStreamCanSeek | Gets a value indicating whether the current stream supports seeking.
NStreamCanWrite | Gets a value indicating whether the current stream supports writing.
NStreamCopyTo | Reads the bytes from the current NStream and writes them to another NStream.
NStreamCopyToWithBufferSize | Reads the bytes from the current NStream and writes them to another NStream, using a specified buffer size.
NStreamFlush | Clears all buffers for this stream and causes any buffered data to be written to the underlying device.
NStreamGetLength | Gets the length in bytes of the NStream.
NStreamGetNull | Returns NStream with no backing store.
NStreamGetPosition | Gets the position within the current NStream.
NStreamRead | Reads a sequence of bytes from the NStream and advances the position within the stream by the number of bytes read.
NStreamReadByte | Reads a byte from NStream and advances the position within NStream by one byte, or returns -1 if at the end of NStream.
NStreamReadN | ... more
NStreamSeek | Sets the position within NStream.
NStreamSetLength | Sets the length in bytes of the NStream.
NStreamSetPosition | Sets the position within the current NStream.
NStreamSynchronized | Creates a thread-safe (synchronized) wrapper around the NStream.
NStreamWrite | Writes a sequence of bytes from an array to NStream and advances the current position within NStream by the number of bytes written.
NStreamWriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte.
NStreamWriteN | Writes a sequence of bytes from NBuffer to NStream and advances the current position within NStream by the number of bytes written.


NStreamReader Unit Functions

NStreamReader Unit Functions
Legend
Functions
Name | Description
NStreamReaderCreate | Creates a new NStreamReader class for the specified NStream.
NStreamReaderCreateFromFile | Creates a new NStreamReader for the specified file.
NStreamReaderCreateFromFileWithEncoding | Creates a new NStreamReader for the specified file with specified encoding.
NStreamReaderCreateFromFileWithEncodingAndBufferSize | Creates a new NStreamReader for the specified file with specified encoding and buffer size.
NStreamReaderCreateWithEncoding | Creates a new NStreamReader for the specified NStream with specified encoding.
NStreamReaderCreateWithEncodingAndBufferSize | Creates a new NStreamReader for the specified NStream with specified encoding and buffer size.
NStreamReaderGetBaseStream | Returns the underlying stream of the specified stream reader.
NStreamReaderGetCurrentEncoding | Gets the current encoding of the specified stream reader.
NStreamReaderGetNull | Creates a NStreamReader object around an empty stream.
NStreamReaderIsEndOfStream | Checks whether the current stream position is at the end of the stream.


NStreamReader Unit Macros

NStreamReader Unit Macros
Macros
Name | Description
NStreamReaderCreateFromFile | Picks a Unicode (W) or ASCII (A) version of the NStreamReaderCreateFromFile function.
NStreamReaderCreateFromFileWithEncoding | Picks a Unicode (W) or ASCII (A) version of the NStreamReaderCreateFromFileWithEncoding function.
NStreamReaderCreateFromFileWithEncodingAndBufferSize | Picks a Unicode (W) or ASCII (A) version of the NStreamReaderCreateFromFileWithEncodingAndBufferSize function.


NStreamWriter Unit Functions

NStreamWriter Unit Functions
Legend
Functions
Name | Description
NStreamWriterCreate | Creates a new NStreamWriter for the specified NStream.
NStreamWriterCreateFromFile | Creates a new NStreamWriter for the specified file.
NStreamWriterCreateFromFileWithEncoding | Creates a new NStreamWriter for the specified file with specified encoding.
NStreamWriterCreateFromFileWithEncodingAndBufferSize | Creates a new NStreamWriter for the specified file with specified encoding and buffer size.
NStreamWriterCreateWithEncoding | Creates a new NStreamWriter for the specified NStream with specified encoding.
NStreamWriterCreateWithEncodingAndBufferSize | Creates a new NStreamWriter for the specified NStream with specified encoding and buffer size.
NStreamWriterGetAutoFlush | Gets a value indicating whether the StreamWriter will flush its buffer to the underlying stream after every call to StreamWriter.Write.
NStreamWriterGetBaseStream | Returns the underlying stream of the specified stream writer.
NStreamWriterGetNull | Creates a NStreamWriter object around an empty stream.
NStreamWriterSetAutoFlush | Sets a value indicating whether the StreamWriter will flush its buffer to the underlying stream after every call to StreamWriter.Write.


NStreamWriter Unit Macros

NStreamWriter Unit Macros
Macros
Name | Description
NStreamWriterCreateFromFile | Picks a Unicode (W) or ASCII (A) version of the NStreamWriterCreateFromFile function.
NStreamWriterCreateFromFileWithEncoding | Picks a Unicode (W) or ASCII (A) version of the NStreamWriterCreateFromFileWithEncoding function.
NStreamWriterCreateFromFileWithEncodingAndBufferSize | Picks a Unicode (W) or ASCII (A) version of the NStreamWriterCreateFromFileWithEncodingAndBufferSize function.


NString Unit Files

NString Unit Files
Files
Name | Description
NString.h | Header file for the NString unit.


NString Unit Functions

NString Unit Functions
Legend
Functions
Name | Description
NStringAppendStrOrChars | Extends specified string content by adding an additional string or chars at its end.
NStringClone | Clones specified NString.
NStringCompareRangeNA | Compares substrings of the two specified strings and retrieves their relative position in the sort order.
NStringCompareRangeNW | Compares substrings of the two specified strings and retrieves their relative position in the sort order.
NStringCompareRangeStrOrCharsA | Compares substrings of a string and a string or a charset and retrieves their relative position in the sort order.
NStringCompareRangeStrOrCharsW | Compares substrings of a string and a string or a charset and retrieves their relative position in the sort order.
NStringConcatArray | Concatenates specified string.
NStringConcatMany | Concatenates specified strings.
NStringConcatManyVA | Concatenates specified strings.
NStringConcatN | Concatenates strings specified by handles.
NStringConcatStrOrChars | Concatenates strings or charsets specified by handles.
NStringContainsStrN | Checks whether specified string occurs within other string.
NStringContainsStrOrChars | Returns a value indicating whether specified chars or string occurs within string specified by handle.
NStringCopyToStrOrChars | Copies a specified number of characters from a specified position in handle to a specified array.
NStringCreateFromChar | Creates string from specified character.
NStringCreateFromStrOrChars | Creates string from specified array of characters.
NStringCreateWrapper | Creates a new string handle based on the specified string.
NStringEndsWithN | Checks whether the end of the string matches the specified string.
NStringEndsWithStrOrCharsA | Checks whether the end of the string matches the specified string or charset.
NStringEndsWithStrOrCharsW | Checks whether the end of the string matches the specified string or charset.
NStringEqualsN | Checks whether two specified strings have the same value.
NStringEqualsStrOrCharsA | Checks whether two specified strings or charsets have the same value.
NStringEqualsStrOrCharsW | Checks whether two specified strings or charsets have the same value.
NStringFormat | Returns a string representing the specified format and parameters.
NStringFormatVA | Returns a string representing the specified format and arguments.
NStringFree | Deletes the string specified by handle. After the string is deleted the specified handle is no longer valid.
NStringFreeArray | Deletes array of strings specified by handles. After the strings is deleted the specified object handles are no longer valid.
NStringFreeElements | ... more
NStringGetBuffer | Gets characters buffer (string) from specified handle to NString.
NStringGetConcurrent | Retrieves the string concurrent to the specified string.
NStringGetElements | Retrieves the elements of the specified string array.
NStringGetEmpty | Gets empty string.
NStringGetHashCode | Gets the hash code
NStringGetLength | Gets length of specified string.
NStringHasEmbeddedNull | Checked whether the specified string has an embedded null value.
NStringIndexOf | Returns the zero-based index of the first occurrence of the specified character in the string.
NStringIndexOfAny | ... more
NStringIndexOfAnyFrom | ... more
NStringIndexOfAnyInRange | ... more
NStringIndexOfFrom | Returns the zero-based index of the first occurrence of the specified character in the string starting from specified index.
NStringIndexOfInRange | ... more
NStringIndexOfStrFromN | ... more
NStringIndexOfStrInRangeN | ... more
NStringIndexOfStrN | Returns the zero-based index of the first occurrence of the specified NString in the string.
NStringIndexOfStrOrChars | Returns the zero-based index of the first occurrence of the specified string or character in the string.
NStringIndexOfStrOrCharsFrom | Returns the zero-based index of the first occurrence of the specified string or character in the string.
NStringIndexOfStrOrCharsInRange | Returns the zero-based index of the first occurrence of the specified string or character in the string.
NStringInsertN | Returns a new string in which a specified string is inserted at a specified index position.
NStringInsertStrOrChars | Returns a new string in which a specified string or characters is inserted at a specified index position.
NStringIsA | Checks whether specified string contains ANSI characters.
NStringIsEmpty | Checks whether specified string is empty string.
NStringIsW | Checks whether specified string contains Unicode characters.
NStringIsWhiteSpace | Checks whether specified string consists only of white-space characters.
NStringJoinArray | Concatenates all the elements of a string array, using the specified separator between each element.
NStringJoinArrayVN | Concatenates all the elements of a string array, using the specified separator between each element.
NStringJoinMany | Concatenates all the elements of a string arrays, using the specified separator between each element.
NStringJoinManyVA | Concatenates all the elements of a string arrays, using the specified separator between each element.
NStringJoinManyVAVN | Concatenates all the elements of a string arrays, using the specified separator between each element.
NStringJoinManyVN | Concatenates all the elements of a string arrays, using the specified separator between each element.
NStringLastIndexOf | Returns the zero-based index position of the last occurrence of a specified character within string.
NStringLastIndexOfAny | ... more
NStringLastIndexOfAnyFrom | ... more
NStringLastIndexOfAnyInRange | ... more
NStringLastIndexOfFrom | ... more
NStringLastIndexOfInRange | ... more
NStringLastIndexOfStrFromN | ... more
NStringLastIndexOfStrInRangeN | Returns the zero-based index of the last occurrence of the specified string in the NString in specified range.
NStringLastIndexOfStrN | Returns the zero-based index of the last occurrence of the specified NString in the string.
NStringLastIndexOfStrOrChars | Returns the zero-based index of the last occurrence of the specified string or character in the string.
NStringLastIndexOfStrOrCharsFrom | Returns the zero-based index of the last occurrence of the specified string or character in the string.
NStringLastIndexOfStrOrCharsInRange | Returns the zero-based index of the last occurrence of the specified string or character in the string.
NStringPadLeft | ... more
NStringPadLeftWith | ... more
NStringPadRight | ... more
NStringPadRightWith | ... more
NStringPrependStrOrChars | Prepends a string or a charset to another string.
NStringPromoteBuffer | Creates a new NString which takes ownership of the memory buffer.
NStringRemove | ... more
NStringRemoveFrom | ... more
NStringReplace | ... more
NStringReplaceStrOrChars | Replaces a part of a string or a char array with new values.
NStringSet | Sets the value of the specified string.
NStringSplitWithCount | ... more
NStringSplitWithStrsAndCount | Returns a string array that contains the substrings that are delimited by elements of a specified character array. A parameter specifies the maximum number of substrings to return.
NStringSplitWithStrsAndCountN | Returns a string array that contains the substrings that are delimited by elements of a specified string array. A parameter specifies the maximum number of substrings to return.
NStringStartsWithN | ... more
NStringStartsWithStrOrCharsA | Checks whether the beginning of hString matches the specified string or chars.
NStringStartsWithStrOrCharsW | Checks whether the beginning of hString matches the specified string or chars.
NStringSubstring | Gets a substring from hString. The substring starts at a specified character position.
NStringSubstringFrom | Gets a substring from hString. The substring starts at a specified character position.
NStringToLower | Converts specified string to lowercase.
NStringToStrOrCharArray | Converts a string to another string or a character array.
NStringToStrOrCharArrayRange | Converts a string to another string or a part of character array.
NStringToString | Converts the specified string to another string with specified format.
NStringToUpper | Converts specified string to uppercase.
NStringTrim | Removes all leading and trailing white-space characters from specified string.
NStringTrimAny | Removes all leading and trailing occurrences of a sets of characters from specified string.
NStringTrimEnd | Removes all trailing characters from hString.
NStringTrimEndAny | Removes all trailing occurrences of a set of characters specified in an array from hString.
NStringTrimStart | Removes all trailing characters from hString.
NStringTrimStartAny | Removes all leading occurrences of a set of characters specified in an array from hString.


NString Unit Macros

NString Unit Macros
Macros
Name | Description
NStringAppend | Extends specified string content by adding an additional string at its end.
NStringAppendChars | Extends specified string content by adding additional chars at its end.
NStringAppendStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringAppendStrOrChars function.
NStringCompare | Compares two strings and retrieves their relative position in the sort order.
NStringCompareChars | Compares a string with a char array and retrieves their relative position in the sort order.
NStringCompareN | Compares two strings and retrieves their relative position in the sort order.
NStringCompareRange | Compares substrings of the two specified strings and retrieves their relative position in the sort order.
NStringCompareRangeChars | Compares substrings of a string and a charset and retrieves their relative position in the sort order.
NStringCompareRangeN | Picks a Unicode (W) or ASCII (A) version of the NStringCompareRangeN function.
NStringCompareRangeStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringCompareRangeStrOrChars function.
NStringCompareStrOrChars | Compares a string with a string or char array and retrieves their relative position in the sort order.
NStringConcat | Concatenates strings specified by handles.
NStringConcatChars | Concatenates charsets specified by handles.
NStringConcatMany | Picks a Unicode (W) or ASCII (A) version of the NStringConcatMany function.
NStringConcatManyVA | Picks a Unicode (W) or ASCII (A) version of the NStringConcatManyVA function.
NStringConcatStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringConcatStrOrChars function.
NStringContainsChars | Returns a value indicating whether specified chars occur within string specified by handle.
NStringContainsStr | Returns a value indicating whether specified string occurs within string specified by handle.
NStringContainsStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringContainsStrOrChars function.
NStringCopyTo | Copies a specified number of characters from a specified position in handle to a specified array.
NStringCopyToStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringCopyToStrOrChars function.
NStringCopyToString | Copies a specified number of characters from a specified position in handle to a specified string.
NStringCreate | Creates a string with the specified value.
NStringCreateFromChar | Picks a Unicode (W) or ASCII (A) version of the NStringCreateFromChar function.
NStringCreateFromChars | Creates a string from the specified array of characters.
NStringCreateFromStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringCreateFromStrOrChars function.
NStringCreateWrapper | Picks a Unicode (W) or ASCII (A) version of the NStringCreateWrapper function.
NStringEndsWith | Checks whether the end of the string matches the specified string.
NStringEndsWithChars | Checks whether the end of the string matches the specified string or charset.
NStringEndsWithStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringEndsWithStrOrChars function.
NStringEquals | Checks whether two specified stings have the same value.
NStringEqualsChars | Checks whether the specified string and the specified charset have the same value.
NStringEqualsStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringEqualsStrOrChars function.
NStringFormat | Picks a Unicode (W) or ASCII (A) version of the NStringFormat function.
NStringFormatVA | Picks a Unicode (W) or ASCII (A) version of the NStringFormatVA function.
NStringGetBuffer | Picks a Unicode (W) or ASCII (A) version of the NStringGetBuffer function.
NStringGetChar | Picks a Unicode (W) or ASCII (A) version of the NStringGetChar function.
NStringGetLength | Picks a Unicode (W) or ASCII (A) version of the NStringGetLength function.
NStringIndexOf | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOf function.
NStringIndexOfAny | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfAny function.
NStringIndexOfAnyFrom | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfAnyFrom function.
NStringIndexOfAnyInRange | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfAnyInRange function.
NStringIndexOfChars | Returns the zero-based index of the first occurrence of the specified character in the string.
NStringIndexOfCharsFrom | Returns the zero-based index of the first occurrence of the specified character in the string.
NStringIndexOfCharsInRange | Returns the zero-based index of the first occurrence of the specified character in the string.
NStringIndexOfFrom | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfFrom function.
NStringIndexOfInRange | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfInRange function.
NStringIndexOfStr | Returns the zero-based index of the first occurrence of the specified string in the string.
NStringIndexOfStrFrom | Returns the zero-based index of the first occurrence of the specified string in the string.
NStringIndexOfStrFromN | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfStrFromN function.
NStringIndexOfStrInRange | Returns the zero-based index of the first occurrence of the specified string in the string.
NStringIndexOfStrInRangeN | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfStrInRangeN function.
NStringIndexOfStrN | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfStrN function.
NStringIndexOfStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfStrOrChars function.
NStringIndexOfStrOrCharsFrom | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfStrOrCharsFrom function.
NStringIndexOfStrOrCharsInRange | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfStrOrCharsInRange function.
NStringInsert | Returns a new string in which a specified string is inserted at a specified index position.
NStringInsertChars | Returns a new string in which a specified characters are inserted at a specified index position.
NStringInsertN | Picks a Unicode (W) or ASCII (A) version of the NStringInsertN function.
NStringInsertStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringInsertStrOrChars function.
NStringJoinArray | Picks a Unicode (W) or ASCII (A) version of the NStringJoinArray function.
NStringJoinArrayVN | Picks a Unicode (W) or ASCII (A) version of the NStringJoinArrayVN function.
NStringJoinMany | Picks a Unicode (W) or ASCII (A) version of the NStringJoinMany function.
NStringJoinManyVAVN | Picks a Unicode (W) or ASCII (A) version of the NStringJoinManyVAVN function.
NStringJoinManyVN | Picks a Unicode (W) or ASCII (A) version of the NStringJoinManyVN function.
NStringLastIndexOf | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOf function.
NStringLastIndexOfAny | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfAny function.
NStringLastIndexOfAnyFrom | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfAnyFrom function.
NStringLastIndexOfAnyInRange | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfAnyInRange function.
NStringLastIndexOfChars | Returns the zero-based index of the last occurrence of the specified character in the string.
NStringLastIndexOfCharsFrom | Returns the zero-based index of the last occurrence of the specified character in the string.
NStringLastIndexOfCharsInRange | Returns the zero-based index of the last occurrence of the specified character in the string.
NStringLastIndexOfFrom | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfFrom function.
NStringLastIndexOfInRange | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfInRange function.
NStringLastIndexOfStr | Returns the zero-based index of the last occurrence of the specified string in the string.
NStringLastIndexOfStrFrom | Returns the zero-based index of the last occurrence of the specified string in the string.
NStringLastIndexOfStrFromN | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfStrFromN function.
NStringLastIndexOfStrInRange | Returns the zero-based index of the last occurrence of the specified string in the string.
NStringLastIndexOfStrInRangeN | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfStrInRangeN function.
NStringLastIndexOfStrN | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfStrN function.
NStringLastIndexOfStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfStrOrChars function.
NStringLastIndexOfStrOrCharsFrom | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfStrOrCharsFrom function.
NStringLastIndexOfStrOrCharsInRange | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfStrOrCharsInRange function.
NStringPadLeft | Picks a Unicode (W) or ASCII (A) version of the NStringPadLeft function.
NStringPadLeftWith | Picks a Unicode (W) or ASCII (A) version of the NStringPadLeftWith function.
NStringPadRight | Picks a Unicode (W) or ASCII (A) version of the NStringPadRight function.
NStringPadRightWith | Picks a Unicode (W) or ASCII (A) version of the NStringPadRightWith function.
NStringPrepend | Prepends a string to another string.
NStringPrependChars | Prepends a charset to another string.
NStringPrependStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringPrependStrOrChars function.
NStringPromoteBuffer | Picks a Unicode (W) or ASCII (A) version of the NStringPromoteBuffer function.
NStringRemove | Picks a Unicode (W) or ASCII (A) version of the NStringRemove function.
NStringRemoveFrom | Picks a Unicode (W) or ASCII (A) version of the NStringRemoveFrom function.
NStringReplace | Picks a Unicode (W) or ASCII (A) version of the NStringReplace function.
NStringReplaceChars | Replaces a part of a char array with new values.
NStringReplaceStr | Replaces a part of a string with new values.
NStringReplaceStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringReplaceStrOrChars function.
NStringSplit | ... more
NStringSplitWithCount | Picks a Unicode (W) or ASCII (A) version of the NStringSplitWithCount function.
NStringSplitWithStrs | Returns a string array that contains the substrings that are delimited by elements of a specified character array.
NStringSplitWithStrsAndCount | Picks a Unicode (W) or ASCII (A) version of the NStringSplitWithStrsAndCount function.
NStringSplitWithStrsN | Returns a string array that contains the substrings that are delimited by elements of a specified string array.
NStringStartsWith | Checks whether the beginning of hString matches the specified string.
NStringStartsWithChars | Checks whether the beginning of hString matches the specified charset.
NStringStartsWithStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringStartsWithStrOrChars function.
NStringSubstring | Picks a Unicode (W) or ASCII (A) version of the NStringSubstring function.
NStringSubstringFrom | Picks a Unicode (W) or ASCII (A) version of the NStringSubstringFrom function.
NStringToCharArray | Converts a string to character array.
NStringToCharArrayRange | Converts a string to a part of character array.
NStringToNewString | Converts a string to another string.
NStringToNewStringRange | Converts a string to another string or a part of character array.
NStringToStrOrCharArray | Picks a Unicode (W) or ASCII (A) version of the NStringToStrOrCharArray function.
NStringToStrOrCharArrayRange | Picks a Unicode (W) or ASCII (A) version of the NStringToStrOrCharArrayRange function.
NStringToString | Picks a Unicode (W) or ASCII (A) version of the NStringToString function.
NStringTrimAny | Picks a Unicode (W) or ASCII (A) version of the NStringTrimAny function.
NStringTrimEndAny | Picks a Unicode (W) or ASCII (A) version of the NStringTrimEndAny function.
NStringTrimStartAny | Picks a Unicode (W) or ASCII (A) version of the NStringTrimStartAny function.
N_STRING_SIZE | Defines the string size.


NString.h Functions

NString.h Functions
Legend
Functions
Name | Description
NStringAppendStrOrChars | Extends specified string content by adding an additional string or chars at its end.
NStringClone | Clones specified NString.
NStringCompareRangeNA | Compares substrings of the two specified strings and retrieves their relative position in the sort order.
NStringCompareRangeNW | Compares substrings of the two specified strings and retrieves their relative position in the sort order.
NStringCompareRangeStrOrCharsA | Compares substrings of a string and a string or a charset and retrieves their relative position in the sort order.
NStringCompareRangeStrOrCharsW | Compares substrings of a string and a string or a charset and retrieves their relative position in the sort order.
NStringConcatArray | Concatenates specified string.
NStringConcatMany | Concatenates specified strings.
NStringConcatManyVA | Concatenates specified strings.
NStringConcatN | Concatenates strings specified by handles.
NStringConcatStrOrChars | Concatenates strings or charsets specified by handles.
NStringContainsStrN | Checks whether specified string occurs within other string.
NStringContainsStrOrChars | Returns a value indicating whether specified chars or string occurs within string specified by handle.
NStringCopyToStrOrChars | Copies a specified number of characters from a specified position in handle to a specified array.
NStringCreateFromChar | Creates string from specified character.
NStringCreateFromStrOrChars | Creates string from specified array of characters.
NStringCreateWrapper | Creates a new string handle based on the specified string.
NStringEndsWithN | Checks whether the end of the string matches the specified string.
NStringEndsWithStrOrCharsA | Checks whether the end of the string matches the specified string or charset.
NStringEndsWithStrOrCharsW | Checks whether the end of the string matches the specified string or charset.
NStringEqualsN | Checks whether two specified strings have the same value.
NStringEqualsStrOrCharsA | Checks whether two specified strings or charsets have the same value.
NStringEqualsStrOrCharsW | Checks whether two specified strings or charsets have the same value.
NStringFormat | Returns a string representing the specified format and parameters.
NStringFormatVA | Returns a string representing the specified format and arguments.
NStringFree | Deletes the string specified by handle. After the string is deleted the specified handle is no longer valid.
NStringFreeArray | Deletes array of strings specified by handles. After the strings is deleted the specified object handles are no longer valid.
NStringFreeElements | ... more
NStringGetBuffer | Gets characters buffer (string) from specified handle to NString.
NStringGetConcurrent | Retrieves the string concurrent to the specified string.
NStringGetElements | Retrieves the elements of the specified string array.
NStringGetEmpty | Gets empty string.
NStringGetHashCode | Gets the hash code
NStringGetLength | Gets length of specified string.
NStringHasEmbeddedNull | Checked whether the specified string has an embedded null value.
NStringIndexOf | Returns the zero-based index of the first occurrence of the specified character in the string.
NStringIndexOfAny | ... more
NStringIndexOfAnyFrom | ... more
NStringIndexOfAnyInRange | ... more
NStringIndexOfFrom | Returns the zero-based index of the first occurrence of the specified character in the string starting from specified index.
NStringIndexOfInRange | ... more
NStringIndexOfStrFromN | ... more
NStringIndexOfStrInRangeN | ... more
NStringIndexOfStrN | Returns the zero-based index of the first occurrence of the specified NString in the string.
NStringIndexOfStrOrChars | Returns the zero-based index of the first occurrence of the specified string or character in the string.
NStringIndexOfStrOrCharsFrom | Returns the zero-based index of the first occurrence of the specified string or character in the string.
NStringIndexOfStrOrCharsInRange | Returns the zero-based index of the first occurrence of the specified string or character in the string.
NStringInsertN | Returns a new string in which a specified string is inserted at a specified index position.
NStringInsertStrOrChars | Returns a new string in which a specified string or characters is inserted at a specified index position.
NStringIsA | Checks whether specified string contains ANSI characters.
NStringIsEmpty | Checks whether specified string is empty string.
NStringIsW | Checks whether specified string contains Unicode characters.
NStringIsWhiteSpace | Checks whether specified string consists only of white-space characters.
NStringJoinArray | Concatenates all the elements of a string array, using the specified separator between each element.
NStringJoinArrayVN | Concatenates all the elements of a string array, using the specified separator between each element.
NStringJoinMany | Concatenates all the elements of a string arrays, using the specified separator between each element.
NStringJoinManyVA | Concatenates all the elements of a string arrays, using the specified separator between each element.
NStringJoinManyVAVN | Concatenates all the elements of a string arrays, using the specified separator between each element.
NStringJoinManyVN | Concatenates all the elements of a string arrays, using the specified separator between each element.
NStringLastIndexOf | Returns the zero-based index position of the last occurrence of a specified character within string.
NStringLastIndexOfAny | ... more
NStringLastIndexOfAnyFrom | ... more
NStringLastIndexOfAnyInRange | ... more
NStringLastIndexOfFrom | ... more
NStringLastIndexOfInRange | ... more
NStringLastIndexOfStrFromN | ... more
NStringLastIndexOfStrInRangeN | Returns the zero-based index of the last occurrence of the specified string in the NString in specified range.
NStringLastIndexOfStrN | Returns the zero-based index of the last occurrence of the specified NString in the string.
NStringLastIndexOfStrOrChars | Returns the zero-based index of the last occurrence of the specified string or character in the string.
NStringLastIndexOfStrOrCharsFrom | Returns the zero-based index of the last occurrence of the specified string or character in the string.
NStringLastIndexOfStrOrCharsInRange | Returns the zero-based index of the last occurrence of the specified string or character in the string.
NStringPadLeft | ... more
NStringPadLeftWith | ... more
NStringPadRight | ... more
NStringPadRightWith | ... more
NStringPrependStrOrChars | Prepends a string or a charset to another string.
NStringPromoteBuffer | Creates a new NString which takes ownership of the memory buffer.
NStringRemove | ... more
NStringRemoveFrom | ... more
NStringReplace | ... more
NStringReplaceStrOrChars | Replaces a part of a string or a char array with new values.
NStringSet | Sets the value of the specified string.
NStringSplitWithCount | ... more
NStringSplitWithStrsAndCount | Returns a string array that contains the substrings that are delimited by elements of a specified character array. A parameter specifies the maximum number of substrings to return.
NStringSplitWithStrsAndCountN | Returns a string array that contains the substrings that are delimited by elements of a specified string array. A parameter specifies the maximum number of substrings to return.
NStringStartsWithN | ... more
NStringStartsWithStrOrCharsA | Checks whether the beginning of hString matches the specified string or chars.
NStringStartsWithStrOrCharsW | Checks whether the beginning of hString matches the specified string or chars.
NStringSubstring | Gets a substring from hString. The substring starts at a specified character position.
NStringSubstringFrom | Gets a substring from hString. The substring starts at a specified character position.
NStringToLower | Converts specified string to lowercase.
NStringToStrOrCharArray | Converts a string to another string or a character array.
NStringToStrOrCharArrayRange | Converts a string to another string or a part of character array.
NStringToString | Converts the specified string to another string with specified format.
NStringToUpper | Converts specified string to uppercase.
NStringTrim | Removes all leading and trailing white-space characters from specified string.
NStringTrimAny | Removes all leading and trailing occurrences of a sets of characters from specified string.
NStringTrimEnd | Removes all trailing characters from hString.
NStringTrimEndAny | Removes all trailing occurrences of a set of characters specified in an array from hString.
NStringTrimStart | Removes all trailing characters from hString.
NStringTrimStartAny | Removes all leading occurrences of a set of characters specified in an array from hString.


NString.h Macros

NString.h Macros
Macros
Name | Description
NStringAppend | Extends specified string content by adding an additional string at its end.
NStringAppendChars | Extends specified string content by adding additional chars at its end.
NStringAppendStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringAppendStrOrChars function.
NStringCompare | Compares two strings and retrieves their relative position in the sort order.
NStringCompareChars | Compares a string with a char array and retrieves their relative position in the sort order.
NStringCompareN | Compares two strings and retrieves their relative position in the sort order.
NStringCompareRange | Compares substrings of the two specified strings and retrieves their relative position in the sort order.
NStringCompareRangeChars | Compares substrings of a string and a charset and retrieves their relative position in the sort order.
NStringCompareRangeN | Picks a Unicode (W) or ASCII (A) version of the NStringCompareRangeN function.
NStringCompareRangeStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringCompareRangeStrOrChars function.
NStringCompareStrOrChars | Compares a string with a string or char array and retrieves their relative position in the sort order.
NStringConcat | Concatenates strings specified by handles.
NStringConcatChars | Concatenates charsets specified by handles.
NStringConcatMany | Picks a Unicode (W) or ASCII (A) version of the NStringConcatMany function.
NStringConcatManyVA | Picks a Unicode (W) or ASCII (A) version of the NStringConcatManyVA function.
NStringConcatStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringConcatStrOrChars function.
NStringContainsChars | Returns a value indicating whether specified chars occur within string specified by handle.
NStringContainsStr | Returns a value indicating whether specified string occurs within string specified by handle.
NStringContainsStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringContainsStrOrChars function.
NStringCopyTo | Copies a specified number of characters from a specified position in handle to a specified array.
NStringCopyToStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringCopyToStrOrChars function.
NStringCopyToString | Copies a specified number of characters from a specified position in handle to a specified string.
NStringCreate | Creates a string with the specified value.
NStringCreateFromChar | Picks a Unicode (W) or ASCII (A) version of the NStringCreateFromChar function.
NStringCreateFromChars | Creates a string from the specified array of characters.
NStringCreateFromStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringCreateFromStrOrChars function.
NStringCreateWrapper | Picks a Unicode (W) or ASCII (A) version of the NStringCreateWrapper function.
NStringEndsWith | Checks whether the end of the string matches the specified string.
NStringEndsWithChars | Checks whether the end of the string matches the specified string or charset.
NStringEndsWithStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringEndsWithStrOrChars function.
NStringEquals | Checks whether two specified stings have the same value.
NStringEqualsChars | Checks whether the specified string and the specified charset have the same value.
NStringEqualsStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringEqualsStrOrChars function.
NStringFormat | Picks a Unicode (W) or ASCII (A) version of the NStringFormat function.
NStringFormatVA | Picks a Unicode (W) or ASCII (A) version of the NStringFormatVA function.
NStringGetBuffer | Picks a Unicode (W) or ASCII (A) version of the NStringGetBuffer function.
NStringGetChar | Picks a Unicode (W) or ASCII (A) version of the NStringGetChar function.
NStringGetLength | Picks a Unicode (W) or ASCII (A) version of the NStringGetLength function.
NStringIndexOf | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOf function.
NStringIndexOfAny | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfAny function.
NStringIndexOfAnyFrom | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfAnyFrom function.
NStringIndexOfAnyInRange | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfAnyInRange function.
NStringIndexOfChars | Returns the zero-based index of the first occurrence of the specified character in the string.
NStringIndexOfCharsFrom | Returns the zero-based index of the first occurrence of the specified character in the string.
NStringIndexOfCharsInRange | Returns the zero-based index of the first occurrence of the specified character in the string.
NStringIndexOfFrom | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfFrom function.
NStringIndexOfInRange | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfInRange function.
NStringIndexOfStr | Returns the zero-based index of the first occurrence of the specified string in the string.
NStringIndexOfStrFrom | Returns the zero-based index of the first occurrence of the specified string in the string.
NStringIndexOfStrFromN | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfStrFromN function.
NStringIndexOfStrInRange | Returns the zero-based index of the first occurrence of the specified string in the string.
NStringIndexOfStrInRangeN | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfStrInRangeN function.
NStringIndexOfStrN | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfStrN function.
NStringIndexOfStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfStrOrChars function.
NStringIndexOfStrOrCharsFrom | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfStrOrCharsFrom function.
NStringIndexOfStrOrCharsInRange | Picks a Unicode (W) or ASCII (A) version of the NStringIndexOfStrOrCharsInRange function.
NStringInsert | Returns a new string in which a specified string is inserted at a specified index position.
NStringInsertChars | Returns a new string in which a specified characters are inserted at a specified index position.
NStringInsertN | Picks a Unicode (W) or ASCII (A) version of the NStringInsertN function.
NStringInsertStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringInsertStrOrChars function.
NStringJoinArray | Picks a Unicode (W) or ASCII (A) version of the NStringJoinArray function.
NStringJoinArrayVN | Picks a Unicode (W) or ASCII (A) version of the NStringJoinArrayVN function.
NStringJoinMany | Picks a Unicode (W) or ASCII (A) version of the NStringJoinMany function.
NStringJoinManyVAVN | Picks a Unicode (W) or ASCII (A) version of the NStringJoinManyVAVN function.
NStringJoinManyVN | Picks a Unicode (W) or ASCII (A) version of the NStringJoinManyVN function.
NStringLastIndexOf | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOf function.
NStringLastIndexOfAny | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfAny function.
NStringLastIndexOfAnyFrom | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfAnyFrom function.
NStringLastIndexOfAnyInRange | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfAnyInRange function.
NStringLastIndexOfChars | Returns the zero-based index of the last occurrence of the specified character in the string.
NStringLastIndexOfCharsFrom | Returns the zero-based index of the last occurrence of the specified character in the string.
NStringLastIndexOfCharsInRange | Returns the zero-based index of the last occurrence of the specified character in the string.
NStringLastIndexOfFrom | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfFrom function.
NStringLastIndexOfInRange | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfInRange function.
NStringLastIndexOfStr | Returns the zero-based index of the last occurrence of the specified string in the string.
NStringLastIndexOfStrFrom | Returns the zero-based index of the last occurrence of the specified string in the string.
NStringLastIndexOfStrFromN | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfStrFromN function.
NStringLastIndexOfStrInRange | Returns the zero-based index of the last occurrence of the specified string in the string.
NStringLastIndexOfStrInRangeN | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfStrInRangeN function.
NStringLastIndexOfStrN | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfStrN function.
NStringLastIndexOfStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfStrOrChars function.
NStringLastIndexOfStrOrCharsFrom | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfStrOrCharsFrom function.
NStringLastIndexOfStrOrCharsInRange | Picks a Unicode (W) or ASCII (A) version of the NStringLastIndexOfStrOrCharsInRange function.
NStringPadLeft | Picks a Unicode (W) or ASCII (A) version of the NStringPadLeft function.
NStringPadLeftWith | Picks a Unicode (W) or ASCII (A) version of the NStringPadLeftWith function.
NStringPadRight | Picks a Unicode (W) or ASCII (A) version of the NStringPadRight function.
NStringPadRightWith | Picks a Unicode (W) or ASCII (A) version of the NStringPadRightWith function.
NStringPrepend | Prepends a string to another string.
NStringPrependChars | Prepends a charset to another string.
NStringPrependStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringPrependStrOrChars function.
NStringPromoteBuffer | Picks a Unicode (W) or ASCII (A) version of the NStringPromoteBuffer function.
NStringRemove | Picks a Unicode (W) or ASCII (A) version of the NStringRemove function.
NStringRemoveFrom | Picks a Unicode (W) or ASCII (A) version of the NStringRemoveFrom function.
NStringReplace | Picks a Unicode (W) or ASCII (A) version of the NStringReplace function.
NStringReplaceChars | Replaces a part of a char array with new values.
NStringReplaceStr | Replaces a part of a string with new values.
NStringReplaceStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringReplaceStrOrChars function.
NStringSplit | ... more
NStringSplitWithCount | Picks a Unicode (W) or ASCII (A) version of the NStringSplitWithCount function.
NStringSplitWithStrs | Returns a string array that contains the substrings that are delimited by elements of a specified character array.
NStringSplitWithStrsAndCount | Picks a Unicode (W) or ASCII (A) version of the NStringSplitWithStrsAndCount function.
NStringSplitWithStrsN | Returns a string array that contains the substrings that are delimited by elements of a specified string array.
NStringStartsWith | Checks whether the beginning of hString matches the specified string.
NStringStartsWithChars | Checks whether the beginning of hString matches the specified charset.
NStringStartsWithStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringStartsWithStrOrChars function.
NStringSubstring | Picks a Unicode (W) or ASCII (A) version of the NStringSubstring function.
NStringSubstringFrom | Picks a Unicode (W) or ASCII (A) version of the NStringSubstringFrom function.
NStringToCharArray | Converts a string to character array.
NStringToCharArrayRange | Converts a string to a part of character array.
NStringToNewString | Converts a string to another string.
NStringToNewStringRange | Converts a string to another string or a part of character array.
NStringToStrOrCharArray | Picks a Unicode (W) or ASCII (A) version of the NStringToStrOrCharArray function.
NStringToStrOrCharArrayRange | Picks a Unicode (W) or ASCII (A) version of the NStringToStrOrCharArrayRange function.
NStringToString | Picks a Unicode (W) or ASCII (A) version of the NStringToString function.
NStringTrimAny | Picks a Unicode (W) or ASCII (A) version of the NStringTrimAny function.
NStringTrimEndAny | Picks a Unicode (W) or ASCII (A) version of the NStringTrimEndAny function.
NStringTrimStartAny | Picks a Unicode (W) or ASCII (A) version of the NStringTrimStartAny function.
N_STRING_SIZE | Defines the string size.


NStringBuilder Unit Functions

NStringBuilder Unit Functions
Legend
Functions
Name | Description
NStringBuilderAppend | Appends a the copy of the specified string to the specified string builder.
NStringBuilderAppendBoolean | Appends a the string representation of specified Boolean value to the specified string builder.
NStringBuilderAppendByte | Appends a the string representation of specified unsigned byte integer to the specified string builder.
NStringBuilderAppendChar | Appends a the string representation of specified char to the specified string builder.
NStringBuilderAppendCharRepeat | Appends a the string representation of specified char to the specified string builder a set amount of times.
NStringBuilderAppendChars | Appends a the string representation of specified char arry to the specified string builder.
NStringBuilderAppendDouble | Appends a the string representation of specified double integer to the specified string builder.
NStringBuilderAppendEmptyLine | Appends the default line terminator to the end of the specified NStringBuilder object.
NStringBuilderAppendFormat | Appends a format string with specified parameters to the specified string builder.
NStringBuilderAppendFormatN | Appends a format string with specified parameters to the specified string builder.
NStringBuilderAppendFormatVA | Appends a format string with specified arguments to the specified string builder.
NStringBuilderAppendFormatVAN | Appends a format string with specified arguments to the specified string builder.
NStringBuilderAppendInt16 | Appends a the string representation of specified short integer to the specified string builder.
NStringBuilderAppendInt32 | Appends a the string representation of specified integer to the specified string builder.
NStringBuilderAppendInt64 | Appends a the string representation of specified long integer to the specified string builder.
NStringBuilderAppendLine | Appends a the copy of the specified string followed by the default line terminator to the end of the specified string builder.
NStringBuilderAppendLineN | Appends a the copy of the specified string followed by the default line terminator to the end of the specified string builder.
NStringBuilderAppendN | Appends a the copy of the specified string to the specified string builder.
NStringBuilderAppendObject | Appends a the string representation of specified object to the specified string builder.
NStringBuilderAppendPointer | Appends a the string representation of specified pointer to the specified string builder.
NStringBuilderAppendResult | Appends a string representation of a NResult value to the specified string builder.
NStringBuilderAppendSByte | Appends a the string representation of specified integer to the specified string builder.
NStringBuilderAppendSSizeType | Appends a the string representation of specified SSizeType to the specified string builder.
NStringBuilderAppendSingle | Appends a the string representation of specified floating point number to the specified string builder.
NStringBuilderAppendSizeType | Appends a the string representation of specified SizeType to the specified string builder.
NStringBuilderAppendUInt16 | Appends a the string representation of specified unsigned short integer to the specified string builder.
NStringBuilderAppendUInt32 | Appends a the string representation of specified unsigned integer to the specified string builder.
NStringBuilderAppendUInt64 | Appends a the string representation of specified unsigned long integer to the specified string builder.
NStringBuilderAppendValue | Appends a string representation of a value of specified type to the specified string builder.
NStringBuilderAppendValueP | Appends a the string representation of specified value to the specified string builder.
NStringBuilderClear | Removes all characters from the specified NStringBuilder.
NStringBuilderCopyToStrOrChars | Copies the characters from a specified segment of the NStringBuilder to a specified segment of a destination Char array.
NStringBuilderDetachStrOrChars | Detaches a string or a char array from the NStringBuilder.
NStringBuilderDetachStringN | Detaches a string from the NStringBuilder.
NStringBuilderDispose | Releases the unused resources of the specified NStringBuilder.
NStringBuilderGetCapacity | Gets the capacity of the specified NStringBuilder.
NStringBuilderGetChar | Gets the character at the specified position in the specified NStringBuilder.
NStringBuilderGetLength | Gets the length of the specified NStringBuilder.
NStringBuilderGetStrOrCharsBuffer | Gets the string or character array buffer of the specified NStringBuilder.
NStringBuilderGetStringWrapper | Gets the string wrapper of the specified NStringBuilder.
NStringBuilderInit | Creates a new NStringBuilder.
NStringBuilderInitEx | Creates a new NStringBuilder with specified capacity, maximum capacity and growth delta.
NStringBuilderInitWithCapacity | Creates a new NStringBuilder using the specified capacity.
NStringBuilderInitWithStrOrChars | Creates a new NStringBuilder using the specified string or char array.
NStringBuilderInitWithStringN | Creates a new NStringBuilder using the specified string.
NStringBuilderInsert | Inserts a string into the specified NStringBuilder at the specified character position.
NStringBuilderInsertBoolean |
NStringBuilderInsertByte | Inserts a string representation of the specified unsigned byte integer into the specified NStringBuilder at the specified character position.
NStringBuilderInsertChar | Inserts a string representation of the specified char into the specified NStringBuilder at the specified character position.
NStringBuilderInsertChars | Inserts a string representation of the specified char array into the specified NStringBuilder at the specified character position.
NStringBuilderInsertDouble | Inserts a string representation of the specified double integer into the specified NStringBuilder at the specified character position.
NStringBuilderInsertInt16 | Inserts a string representation of the specified short integer into the specified NStringBuilder at the specified character position.
NStringBuilderInsertInt32 | Inserts a string representation of the specified integer into the specified NStringBuilder at the specified character position.
NStringBuilderInsertInt64 | Inserts a string representation of the specified long integer into the specified NStringBuilder at the specified character position.
NStringBuilderInsertN | Inserts a string into the specified NStringBuilder at the specified character position.
NStringBuilderInsertObject | Inserts a string representation of the specified object into the specified NStringBuilder at the specified character position.
NStringBuilderInsertPointer | Inserts a string representation of the specified pointer into the specified NStringBuilder at the specified character position.
NStringBuilderInsertResult | Inserts a string representation of a NResult value into the specified NStringBuilder at the specified character position.
NStringBuilderInsertSByte | Inserts a string representation of the specified byte integer into the specified NStringBuilder at the specified character position.
NStringBuilderInsertSSizeType | Inserts a string representation of the specified SSizeType into the specified NStringBuilder at the specified character position.
NStringBuilderInsertSingle | Inserts a string representation of the specified floating point number into the specified NStringBuilder at the specified character position.
NStringBuilderInsertSizeType | Inserts a string representation of the specified SizeType into the specified NStringBuilder at the specified character position.
NStringBuilderInsertUInt16 | Inserts a string representation of the specified unsigned short integer into the specified NStringBuilder at the specified character position.
NStringBuilderInsertUInt32 | Inserts a string representation of the specified unsigned integer into the specified NStringBuilder at the specified character position.
NStringBuilderInsertUInt64 | Inserts a string representation of the specified long integer into the specified NStringBuilder at the specified character position.
NStringBuilderInsertValue | Inserts a string representation of a value of specified type into the specified NStringBuilder at the specified character position.
NStringBuilderInsertValueP | Inserts a string representation of the specified value into the specified NStringBuilder at the specified character position.
NStringBuilderRemove | Removes the specified range of characters from the specified NStringBuilder.
NStringBuilderReplace | Replaces all occurrences of a specified character in the specified NStringBuilder with another specified character.
NStringBuilderReplaceInRange | Replaces, within a substring of the specified NStringBuilder, all occurrences of a specified character with another specified character.
NStringBuilderReplaceStrOrChars | Replaces all occurrences of a specified string or char array in the specified NStringBuilder with another specified string or char array.
NStringBuilderReplaceStrOrCharsInRange | Replaces, within a substring of the specified NStringBuilder, all occurrences of a specified string or char array with another specified string or char array.
NStringBuilderReplaceStringInRangeN | Replaces, within a substring of the specified NStringBuilder, all occurrences of a specified string with another specified string.
NStringBuilderReplaceStringN | Replaces all occurrences of a specified string in the specified NStringBuilder with another specified character.
NStringBuilderSetCapacity | Sets the capacity of the specified NStringBuilder.
NStringBuilderSetChar | Sets the value of the character at the specified position in the specified NStringBuilder.
NStringBuilderSetLength | Sets the length of the specified NStringBuilder.
NStringBuilderToString | Converts the specified NStringBuilder to a string.
NStringBuilderToStringRange | Converts the specified NStringBuilder to a string range.


NStringBuilder Unit Macros

NStringBuilder Unit Macros
Macros
Name | Description
NStringBuilderAppend | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppend function.
NStringBuilderAppendBoolean | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendBoolean function.
NStringBuilderAppendByte | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendByte function.
NStringBuilderAppendChar | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendChar function.
NStringBuilderAppendCharRepeat | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendCharRepeat function.
NStringBuilderAppendChars | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendChars function.
NStringBuilderAppendDouble | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendDouble function.
NStringBuilderAppendEmptyLine | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendEmptyLine function.
NStringBuilderAppendFormat | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendFormat function.
NStringBuilderAppendFormatN | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendFormatN function.
NStringBuilderAppendFormatVA | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendFormatVA function.
NStringBuilderAppendFormatVAN | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendFormatVAN function.
NStringBuilderAppendInt16 | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendInt16 function.
NStringBuilderAppendInt32 | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendInt32 function.
NStringBuilderAppendInt64 | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendInt64 function.
NStringBuilderAppendLine | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendLine function.
NStringBuilderAppendLineN | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendLineN function.
NStringBuilderAppendN | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendN function.
NStringBuilderAppendObject | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendObject function.
NStringBuilderAppendPointer | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendPointer function.
NStringBuilderAppendResult | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendResult function.
NStringBuilderAppendSByte | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendSByte function.
NStringBuilderAppendSSizeType | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendSSizeType function.
NStringBuilderAppendSingle | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendSingle function.
NStringBuilderAppendSizeType | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendSizeType function.
NStringBuilderAppendUInt16 | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendUInt16 function.
NStringBuilderAppendUInt32 | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendUInt32 function.
NStringBuilderAppendUInt64 | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendUInt64 function.
NStringBuilderAppendValue | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendValue function.
NStringBuilderAppendValueP | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderAppendValueP function.
NStringBuilderClear | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderClear function.
NStringBuilderCopyTo | Copies the characters from a specified segment of the NStringBuilder to a specified segment of a destination Char array.
NStringBuilderCopyToStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringCopyToStrOrChars function.
NStringBuilderCopyToString | Copies the characters from a specified segment of the NStringBuilder to a specified segment of a destination string.
NStringBuilderDetachCharArray | Detaches a char array from the NStringBuilder.
NStringBuilderDetachStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderDetachStrOrChars function.
NStringBuilderDetachString | Detaches a string from the NStringBuilder.
NStringBuilderDispose | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderDispose function.
NStringBuilderGetBuffer | Gets the string buffer of the specified NStringBuilder.
NStringBuilderGetCapacity | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderGetCapacity function.
NStringBuilderGetChar | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderGetChar function.
NStringBuilderGetCharsBuffer | Gets the character array buffer of the specified NStringBuilder.
NStringBuilderGetLength | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderGetLength function.
NStringBuilderGetStrOrCharsBuffer | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderGetStrOrCharsBuffer function.
NStringBuilderGetStringWrapper | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderGetStringWrapper function.
NStringBuilderInit | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInit function.
NStringBuilderInitEx | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInitEx function.
NStringBuilderInitWithCapacity | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInitWithCapacity function.
NStringBuilderInitWithChars | Creates a new NStringBuilder using the specified char array.
NStringBuilderInitWithStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInitWithStrOrChars function.
NStringBuilderInitWithString | Creates a new NStringBuilder using the specified string.
NStringBuilderInitWithStringN | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInitWithStringN function.
NStringBuilderInsert | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsert function.
NStringBuilderInsertBoolean | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertBoolean function.
NStringBuilderInsertByte | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertByte function.
NStringBuilderInsertChar | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertChar function.
NStringBuilderInsertChars | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertChars function.
NStringBuilderInsertDouble | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertDouble function.
NStringBuilderInsertInt16 | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertInsertInt16 function.
NStringBuilderInsertInt32 | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertInt32 function.
NStringBuilderInsertInt64 | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertInt64 function.
NStringBuilderInsertN | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertN function.
NStringBuilderInsertObject | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertObject function.
NStringBuilderInsertPointer | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertPointer function.
NStringBuilderInsertResult | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertResult function.
NStringBuilderInsertSByte | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertSByte function.
NStringBuilderInsertSSizeType | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertSSizeType function.
NStringBuilderInsertSingle | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertSingle function.
NStringBuilderInsertSizeType | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertSizeType function.
NStringBuilderInsertUInt16 | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertUInt16 function.
NStringBuilderInsertUInt32 | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertUInt32 function.
NStringBuilderInsertUInt64 | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertUInt64 function.
NStringBuilderInsertValue | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertValue function.
NStringBuilderInsertValueP | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderInsertValueP function.
NStringBuilderRemove | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderRemove function.
NStringBuilderReplace | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderReplace function.
NStringBuilderReplaceChars | Replaces all occurrences of a specified char array in the specified NStringBuilder with another specified char array.
NStringBuilderReplaceCharsInRange | Replaces, within a substring of the specified NStringBuilder, all occurrences of a specified char array with another specified char array.
NStringBuilderReplaceInRange | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderReplaceInRange function.
NStringBuilderReplaceStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderReplaceStrOrChars function.
NStringBuilderReplaceStrOrCharsInRange | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderReplaceStrOrCharsInRange function.
NStringBuilderReplaceString | Replaces all occurrences of a specified string in the specified NStringBuilder with another specified character.
NStringBuilderReplaceStringInRange | Replaces, within a substring of the specified NStringBuilder, all occurrences of a specified string with another specified string.
NStringBuilderReplaceStringN | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderReplaceStringN function.
NStringBuilderSetCapacity | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderSetCapacity function.
NStringBuilderSetChar | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderSetChar function.
NStringBuilderSetLength | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderSetLength function.
NStringBuilderToString | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderToString function.
NStringBuilderToStringRange | Picks a Unicode (W) or ASCII (A) version of the NStringBuilderToStringRange function.
N_STRING_BUILDER_SIZE | Defines the NStringBuilder size.


NStringReader Unit Functions

NStringReader Unit Functions
Legend
Functions
Name | Description
NStringReaderCreateFromStrOrChars | Creates a new NStringReader that reads from the specified string or char array.
NStringReaderCreateN | Creates a new NStringReader that reads from the specified NString.


NStringReader Unit Macros

NStringReader Unit Macros
Macros
Name | Description
NStringReaderCreate | Creates a new NStringReader that reads from the specified string.
NStringReaderCreateFromChars | Creates a new NStringReader that reads from the specified char array.
NStringReaderCreateFromStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NStringReaderCreateFromStrOrChars function.


NStringWriter Unit Files

NStringWriter Unit Files
Files
Name | Description
NStringWriter.h | Header file for the NStringWriter module.


NStringWriter Unit Functions

NStringWriter Unit Functions
Legend
Functions
Name | Description
NStringWriterCreate | Creates a new NStringWriter.
NStringWriterCreateEx | Creates a new NStringWriter with specified capacity and growth delta.
NStringWriterCreateWithCapacity | Creates a new NStringWriter with specified capacity.
NStringWriterDetachString | Detaches the specified string from the specified string writer.


NStringWriter.h Functions

NStringWriter.h Functions
Legend
Functions
Name | Description
NStringWriterCreate | Creates a new NStringWriter.
NStringWriterCreateEx | Creates a new NStringWriter with specified capacity and growth delta.
NStringWriterCreateWithCapacity | Creates a new NStringWriter with specified capacity.
NStringWriterDetachString | Detaches the specified string from the specified string writer.


NSyncEvent Unit Functions

NSyncEvent Unit Functions
Legend
Functions
Name | Description
NSyncEventCreate | Creates and initializes a sync event object.
NSyncEventCreateFromOSHandle | Creates a new NSyncEvent for the specified sync event handle.
NSyncEventGetOSHandle | Gets OS handle for the specified sync event.
NSyncEventSet | Post event to the waiting thread(s), i.e. make the event object signalled.


NSyncEvent Unit Macros

NSyncEvent Unit Macros
Macros
Name | Description
NSyncEventReset | Resets the specified sync event.


See Also

See Also
See Also

NSyncEventGetOSHandle


NTextReader Unit Functions

NTextReader Unit Functions
Legend
Functions
Name | Description
NTextReaderGetNull | Retrieves a NTextReader with no data to read from.
NTextReaderPeekChar | Reads the next character without changing the state of the reader or the character source. Returns the next available character without actually reading it from the reader.
NTextReaderReadChar | Reads the next character from the text reader and advances the character position by one character.
NTextReaderReadChars | Reads a specified maximum number of characters from the current reader and writes the data to a buffer.
NTextReaderReadLine | Reads a line of characters from the text reader and returns the data as NString.
NTextReaderReadToEnd | Reads all characters from the current position to the end of the text reader and returns them as NString.
NTextReaderSynchronized | Creates a thread-safe wrapper around the specified NTextReader.


NTextReader Unit Macros

NTextReader Unit Macros
Macros
Name | Description
NTextReaderPeekChar | Picks a Unicode (W) or ASCII (A) version of the NTextReaderPeekChar function.
NTextReaderReadChar | Picks a Unicode (W) or ASCII (A) version of the NTextReaderReadChar function.
NTextReaderReadChars | Picks a Unicode (W) or ASCII (A) version of the NTextReaderReadChars function.


NTextWriter Unit Functions

NTextWriter Unit Functions
Legend
Functions
Name | Description
NTextWriterFlush | Clears all buffers for the specified writer and causes any buffered data to be written to the underlying device.
NTextWriterGetEncoding | Retrieves the encoding of the specified NTextWriter.
NTextWriterGetNewLine | Sets the line terminator string used by the current NTextWriter.
NTextWriterGetNull | Creates a NTextWriter with no backing store that can be written to, but not read from.
NTextWriterSetNewLine | Sets the line terminator string used by the current NTextWriter.
NTextWriterSynchronized | Creates a thread-safe wrapper around the specified NTextWriter.
NTextWriterWrite | Writes a character to the text string or stream.
NTextWriterWriteBoolean | Writes a Boolean to the text string or stream.
NTextWriterWriteBooleanLine | Writes a Boolean followed by a line terminator to the text string or stream.
NTextWriterWriteChar | Writes a character to the text string or stream.
NTextWriterWriteCharLine | Writes a character followed by a line terminator to the text string or stream.
NTextWriterWriteChars | Writes a character array to the text string or stream.
NTextWriterWriteCharsLine | Writes a character array followed by a line terminator to the text string or stream.
NTextWriterWriteDouble | Writes a double to the text string or stream.
NTextWriterWriteDoubleLine | Writes a double followed by a line terminator to the text string or stream.
NTextWriterWriteEmptyLine | Writes a line terminator to the text string or stream.
NTextWriterWriteFormat | Creates a format string with the specified parameters and writes it to the text string or stream.
NTextWriterWriteFormatLine | Creates a format string with the specified parameters and writes it followed by a line terminator to the text string or stream.
NTextWriterWriteFormatLineVA | Creates a format string with the specified arguments and writes it followed by a line terminator to the text string or stream.
NTextWriterWriteFormatVA | Creates a format string with the specified arguments and writes it to the text string or stream.
NTextWriterWriteInt32 | Writes a Int32 to the text string or stream.
NTextWriterWriteInt32Line | Writes a Int32 followed by a line terminator to the text string or stream.
NTextWriterWriteInt64 | Writes a Int64 to the text string or stream.
NTextWriterWriteInt64Line | Writes a Int64 followed by a line terminator to the text string or stream.
NTextWriterWriteLine | Writes a character followed by a line terminator to the text string or stream.
NTextWriterWriteObject | Writes an object to the text string or stream.
NTextWriterWriteObjectLine | Writes an object followed by a line terminator to the text string or stream.
NTextWriterWritePointer | Writes a pointer to the text string or stream.
NTextWriterWritePointerLine | Writes a pointer followed by a line terminator to the text string or stream.
NTextWriterWriteResult | Writes a NResult value to the text string or stream.
NTextWriterWriteResultLine | Writes a NResult value followed by a line terminator to the text string or stream.
NTextWriterWriteSSizeType | Writes a SSizeType to the text string or stream.
NTextWriterWriteSSizeTypeLine | Writes a SSizeType followed by a line terminator to the text string or stream.
NTextWriterWriteSingle | Writes a single to the text string or stream.
NTextWriterWriteSingleLine | Writes a single followed by a line terminator to the text string or stream.
NTextWriterWriteSizeType | Writes a SizeType to the text string or stream.
NTextWriterWriteSizeTypeLine | Writes a SizeType followed by a line terminator to the text string or stream.
NTextWriterWriteUInt32 | Writes a UInt32 to the text string or stream.
NTextWriterWriteUInt32Line | Writes a UInt32 followed by a line terminator to the text string or stream.
NTextWriterWriteUInt64 | Writes a UInt64 to the text string or stream.
NTextWriterWriteUInt64Line | Writes a UInt64 followed by a line terminator to the text string or stream.
NTextWriterWriteValue | Writes a value of specified type to the text string or stream.
NTextWriterWriteValueLine | Writes a value of specified type followed by a line terminator to the text string or stream.
NTextWriterWriteValueLineP | Writes a specified value followed by a line terminator to the text string or stream.
NTextWriterWriteValueP | Writes a specified value to the text string or stream.


NTextWriter Unit Macros

NTextWriter Unit Macros
Macros
Name | Description
NTextWriterSetNewLine | Picks a Unicode (W) or ASCII (A) version of the NTextWriterSetNewLine function.
NTextWriterWrite | Picks a Unicode (W) or ASCII (A) version of the NTextWriterWrite function.
NTextWriterWriteChar | Picks a Unicode (W) or ASCII (A) version of the NTextWriterWriteChar function.
NTextWriterWriteCharLine | Picks a Unicode (W) or ASCII (A) version of the NTextWriterWriteCharLine function.
NTextWriterWriteChars | Picks a Unicode (W) or ASCII (A) version of the NTextWriterWriteChars function.
NTextWriterWriteCharsLine | Picks a Unicode (W) or ASCII (A) version of the NTextWriterWriteCharsLine function.
NTextWriterWriteFormat | Picks a Unicode (W) or ASCII (A) version of the NTextWriterWriteFormat function.
NTextWriterWriteFormatLine | Picks a Unicode (W) or ASCII (A) version of the NTextWriterWriteFormatLine function.
NTextWriterWriteFormatLineVA | Picks a Unicode (W) or ASCII (A) version of the NTextWriterWriteFormatLineVA function.
NTextWriterWriteFormatVA | Picks a Unicode (W) or ASCII (A) version of the NTextWriterWriteFormatVA function.
NTextWriterWriteLine | Picks a Unicode (W) or ASCII (A) version of the NTextWriterWriteLine function.


NThread Unit Files

NThread Unit Files
Files
Name | Description
NThread.h | Header file for the NThread unit.


NThread Unit Functions

NThread Unit Functions
Legend
Functions
Name | Description
NThreadCreate | Execute function in parallel in new thread.
NThreadCreateFromOSHandle | Creates a new NThread for the specified thread handle.
NThreadCreateParameterized | Execute function in parallel in new thread with specified additional parameters.
NThreadGetCurrent | Gets the currently running thread.
NThreadGetCurrentId | Gets the identifier of the currently running thread.
NThreadGetId | Gets the identifier of a specified NThread.
NThreadGetOSHandle | Gets OS handle for the specified thread.
NThreadJoin | Suspend the execution of current thread until the given thread terminates.
NThreadSleep | Suspend the execution of current thread for some time.


See Also

See Also
See Also

NThreadGetOSHandle


NThread.h Functions

NThread.h Functions
Legend
Functions
Name | Description
NThreadCreate | Execute function in parallel in new thread.
NThreadCreateFromOSHandle | Creates a new NThread for the specified thread handle.
NThreadCreateParameterized | Execute function in parallel in new thread with specified additional parameters.
NThreadGetCurrent | Gets the currently running thread.
NThreadGetCurrentId | Gets the identifier of the currently running thread.
NThreadGetId | Gets the identifier of a specified NThread.
NThreadGetOSHandle | Gets OS handle for the specified thread.
NThreadJoin | Suspend the execution of current thread until the given thread terminates.
NThreadSleep | Suspend the execution of current thread for some time.


NTimeSpan Unit Functions

NTimeSpan Unit Functions
Legend
Functions
Name | Description
NTimeSpanAdd | Adds two TimeSpan instances.
NTimeSpanCompare | Compares two instances of TimeSpan and returns an indication of their relative values.
NTimeSpanCreate | Initializes a new instance of NTimeSpan structure.
NTimeSpanCreateFromDays | Initializes a new instance of NTimeSpan structure with the number of days only specified.
NTimeSpanCreateFromHours | Initializes a new instance of NTimeSpan structure with the number of hours only specified.
NTimeSpanCreateFromMilliseconds | Initializes a new instance of NTimeSpan structure with the number of milliseconds only specified.
NTimeSpanCreateFromMinutes | Initializes a new instance of NTimeSpan structure with the number of minutes only specified.
NTimeSpanCreateFromSeconds | Initializes a new instance of NTimeSpan structure with the number of seconds only specified.
NTimeSpanCreateFromTicks | Initializes a new instance of NTimeSpan structure with the specified number of timer ticks.
NTimeSpanDecode | Decodes the specified TimeSpan instance.
NTimeSpanDuration | Returns a new TimeSpan object whose value is the absolute value of the current TimeSpan object.
NTimeSpanGetDays | Gets the days component of the specified TimeSpan.
NTimeSpanGetHours | Gets the hours component of the specified TimeSpan.
NTimeSpanGetMilliseconds | Gets the milliseconds component of the specified TimeSpan.
NTimeSpanGetMinutes | Gets the minutes component of the specified TimeSpan.
NTimeSpanGetSeconds | Gets the seconds component of the specified TimeSpan.
NTimeSpanGetTicks | Gets the number of ticks that represent the value of the specified TimeSpan instance.
NTimeSpanGetTotalDays | Gets the value of the specified TimeSpan instance expressed in whole and fractional days.
NTimeSpanGetTotalHours | Gets the value of the specified TimeSpan instance expressed in whole and fractional hours.
NTimeSpanGetTotalMilliseconds | Gets the value of the specified TimeSpan instance expressed in whole and fractional milliseconds.
NTimeSpanGetTotalMinutes | Gets the value of the specified TimeSpan instance expressed in whole and fractional minutes.
NTimeSpanGetTotalSeconds | Gets the value of the specified TimeSpan instance expressed in whole and fractional seconds.
NTimeSpanIsTimeValid | Checks whether the specified time values are valid.
NTimeSpanIsValid | Checks whether the specified TimeSpan values are valid.
NTimeSpanNegate | Returns a new TimeSpan object whose value is the negated value of the specified instance.
NTimeSpanSubtract | Subtracts one TimeSpan instance from another.
NTimeSpanToString | Gets a string representation of the specified TimeSpan instance.


NTimeSpan Unit Macros

NTimeSpan Unit Macros
Macros
Name | Description
NTimeSpanToString | Picks a Unicode (W) or ASCII (A) version of the NTimeSpanToString function.
N_TIME_SPAN_MAX | Maximum TimeSpan value.
N_TIME_SPAN_MIN | Minimum TimeSpan value.
N_TIME_SPAN_TICKS_PER_DAY | Number of timer ticks in one day.
N_TIME_SPAN_TICKS_PER_HOUR | Number of timer ticks in one hour.
N_TIME_SPAN_TICKS_PER_MILLISECOND | Number of timer ticks in one millisecond.
N_TIME_SPAN_TICKS_PER_MINUTE | Number of timer ticks in one minute.
N_TIME_SPAN_TICKS_PER_SECOND | Number of timer ticks in one second.


NTimeSpan Unit Types

NTimeSpan Unit Types
Types
Name | Description
NTimeSpan_ | The TimeSpan instance.


NTls Unit Functions

NTls Unit Functions
Legend
Functions
Name | Description
NTlsCreate | Creates a new Thread Local Storage.
NTlsCreateForObject | Creates a new Thread Local Storage for the current object.
NTlsFree | Release the dynamic memory before the thread returns.
NTlsGetObject | Retrieves the object associated with the specified Thread Local Storage.
NTlsGetValue | Retrieves the value of the specified Thread Local Storage.
NTlsSetObject | Sets the object for the specified Thread Local Storage.
NTlsSetValue | Sets the Thread Local Storage value.


NType Unit Files

NType Unit Files
Files
Name | Description
NType.h | Header file for the NType module.


NType Unit Functions

NType Unit Functions
Legend
Functions
Name | Description
NTypeAddEventHandlerN | Adds a handler for the specified event to the specified object.
NTypeAddEventHandlerP | Adds a handler for the specified event to the specified object.
NTypeAreValuesEqual | Checks whether the values of the specified type are equal.
NTypeCapturePropertyValues | Captures property values of the specified object.
NTypeCompareValues | Compares two values of the specified type and returns an integer that indicates their relative position in the sort order.
NTypeCopyPropertyValues | Copies property values of the specified object to another object.
NTypeCopyValue | Copies the specified value.
NTypeCreateInstance | Creates an instance of the specified type.
NTypeCreateInstanceWithName | Creates an instance of the type specified by name.
NTypeDisposeValue | Disposes the specified value.
NTypeDisposeValues | Disposes the specified value.
NTypeFreeValues | Frees the specified values.
NTypeGetAttributes | Retrieves the attributes of the specified type.
NTypeGetBaseType | Gets the base type of the specified type.
NTypeGetDeclaredConstant | Retrieves the declared constant specified by index.
NTypeGetDeclaredConstantCount | Retrieves the number of declared constants of the specified type.
NTypeGetDeclaredConstantWithName | Retrieves the declared constant specified by name.
NTypeGetDeclaredConstants | Retrieves all declared constants of the specified type.
NTypeGetDeclaredConstructor | Retrieves the declared constructor specified by index.
NTypeGetDeclaredConstructorCount | Retrieves the number of declared constructors of the specified type.
NTypeGetDeclaredConstructors | Retrieves all declared constructors of the specified type.
NTypeGetDeclaredEnumConstant | Retrieves the declared enumeration constant specified by index.
NTypeGetDeclaredEnumConstantCount | Retrieves the number of declared enumeration constants of the specified type.
NTypeGetDeclaredEnumConstantWithName | Retrieves the declared enumeration constant specified by name.
NTypeGetDeclaredEnumConstants | Retrieves all declared enumeration constants of the specified type.
NTypeGetDeclaredEvent | Retrieves the declared event specified by index.
NTypeGetDeclaredEventCount | Retrieves the number of declared events of the specified type.
NTypeGetDeclaredEventWithName | Retrieves the declared event specified by name.
NTypeGetDeclaredEvents | Retrieves all declared events of the specified type.
NTypeGetDeclaredField | Retrieves the declared field specified by index.
NTypeGetDeclaredFieldCount | Retrieves the number of declared fields of the specified type.
NTypeGetDeclaredFieldWithName | Retrieves the declared field specified by name.
NTypeGetDeclaredFields | Retrieves all declared fields of the specified type.
NTypeGetDeclaredMethod | Retrieves the declared method specified by index.
NTypeGetDeclaredMethodCount | Retrieves the number of declared methods of the specified type.
NTypeGetDeclaredMethodWithName | Retrieves the declared method specified by name.
NTypeGetDeclaredMethods | Retrieves all declared methods of the specified type.
NTypeGetDeclaredMethodsWithName | Retrieves a number of declared methods specified by names.
NTypeGetDeclaredPart | Retrieves the declared part specified by index.
NTypeGetDeclaredPartCount | Retrieves the number of declared part of the specified type.
NTypeGetDeclaredPartWithName | Retrieves the declared part specified by name.
NTypeGetDeclaredParts | Retrieves all declared parts of the specified type.
NTypeGetDeclaredProperties | Retrieves all declared properties of the specified type.
NTypeGetDeclaredProperty | Retrieves the declared property specified by index.
NTypeGetDeclaredPropertyCount | Retrieves the number of declared property of the specified type.
NTypeGetDeclaredPropertyWithName | Retrieves the declared property specified by name.
NTypeGetEnumAlternative | Retrieves alternative enumeration for the specified type.
NTypeGetModule | Gets the module of the specified type.
NTypeGetNameN | Gets the name of the specified type.
NTypeGetOwnerType | Gets the owner type of the specified type.
NTypeGetPropertyValueN | Retrieves the value of the specified property of the specified object.
NTypeGetPropertyValueP | Retrieves the value of the specified property of the specified object.
NTypeGetRootType | Retrieves the root type of the specified type.
NTypeGetRootTypeCode | Retrieves the code of the root type of the specified type.
NTypeGetTypeCode | Retrieves the type code for the specified type.
NTypeGetTypeWithName | Retrieves the type specified by name.
NTypeGetUseInsteadType | Gets the use-instead type of the specified type.
NTypeGetValueHashCode | Gets the hash code of the specified value.
NTypeGetValueSize | Gets the size of the specified value type.
NTypeHasOwnerType | Checks whether the specified type has an owner type.
NTypeIdentifierToString | Converts the specified type identifier into a string.
NTypeIdentifierToStringFN | Converts the specified type identifier into a string.
NTypeIdentifierToStringVN | Converts the specified type identifier into a string.
NTypeInvokeMethod | Invokes the specified method on the specified object.
NTypeInvokeMethodWithPropertyBag | Invokes the specified method on the specified object.
NTypeInvokeMethodWithString | Invokes the specified method on the specified object.
NTypeIsAbstract | Checks whether the specified type is abstract.
NTypeIsAssignableFrom | Checks whether the specified type is abstract from another type.
NTypeIsBasic | Checks whether the specified value is basic.
NTypeIsCallback | Checks whether the specified value is a callback.
NTypeIsCloneable | Checks whether the specified type is cloneable.
NTypeIsComparable | Checks whether the specified type is comparable.
NTypeIsDeprecated | Checks whether the specified type is deprecated.
NTypeIsDisposable | Checks whether the specified type is disposable.
NTypeIsEnum | Checks whether the specified type is an enumeration.
NTypeIsEquatable | Checks whether the specified type is equatable.
NTypeIsFlagsEnum | Checks whether the specified value is flag enumerated.
NTypeIsHandle | Checks whether the specified type is a handle.
NTypeIsInstanceOfType | Checks whether the specified object is an instance of the specified type.
NTypeIsInstanceOfTypeP | Checks whether the specified object is an instance of the specified type.
NTypeIsMemorySerializable | Checks whether the specified type is memory serializable.
NTypeIsObject | Checks whether the specified type is an object.
NTypeIsParsable | Checks whether the specified type is parsable.
NTypeIsPrimitive | Checks whether the specified type is primitive.
NTypeIsPublic | Checks whether the specified type is public.
NTypeIsSealed | Checks whether the specified type is sealed.
NTypeIsSerializable | Checks whether the specified type is serializable.
NTypeIsSignNeutral | Checks whether the specified type is sign neutral.
NTypeIsStatic | Checks whether the specified type is static.
NTypeIsStruct | Checks whether the specified type is a structure.
NTypeIsSubclassOf | Checks whether the specified type is a subclass of another type.
NTypeParseValue | Converts the specified string to a value of the specified type.
NTypeParseValueVN | Converts the specified string to a value of the specified type.
NTypeRemoveEventHandlerN | Removes an event handler from the specified object.
NTypeRemoveEventHandlerP | Removes an event handler from the specified object.
NTypeReset | Resets the type of the specified object.
NTypeResetPropertyValue | Resets the value of the specified property of the specified object.
NTypeSetPropertyValueN | Sets the value of the specified property of the specified object.
NTypeSetPropertyValueP | Sets the value of the specified property of the specified object.
NTypeSetValue | Sets the specified value.
NTypeTryParseValue | Converts the specified string to a value of the specified type. Returns a Boolean value indicating whether the conversion succeeded.
NTypeTryParseValueVN | Converts the specified string to a value of the specified type. Returns a Boolean value indicating whether the conversion succeeded.
NTypeValueToString | Converts the specified value to string.
NTypeValueToStringN | Converts the specified value to string.


NType Unit Macros

NType Unit Macros
Macros
Name | Description
NTypeAddEventHandlerP | Picks a Unicode (W) or ASCII (A) version of the NTypeAddEventHandlerP function.
NTypeCreateInstanceWithName | Picks a Unicode (W) or ASCII (A) version of the NTypeCreateInstanceWithName function.
NTypeGetDeclaredConstantWithName | Picks a Unicode (W) or ASCII (A) version of the NTypeGetDeclaredConstantWithName function.
NTypeGetDeclaredEnumConstantWithName | Picks a Unicode (W) or ASCII (A) version of the NTypeGetDeclaredEnumConstantWithName function.
NTypeGetDeclaredEventWithName | Picks a Unicode (W) or ASCII (A) version of the NTypeGetDeclaredEventWithName function.
NTypeGetDeclaredFieldWithName | Picks a Unicode (W) or ASCII (A) version of the NTypeGetDeclaredFieldWithName function.
NTypeGetDeclaredMethodWithName | Picks a Unicode (W) or ASCII (A) version of the NTypeGetDeclaredMethodWithName function.
NTypeGetDeclaredMethodsWithName | Picks a Unicode (W) or ASCII (A) version of the NTypeGetDeclaredMethodsWithName function.
NTypeGetDeclaredPartWithName | Picks a Unicode (W) or ASCII (A) version of the NTypeGetDeclaredPartWithName function.
NTypeGetDeclaredPropertyWithName | Picks a Unicode (W) or ASCII (A) version of the NTypeGetDeclaredPropertyWithName function.
NTypeGetPropertyValueP | Picks a Unicode (W) or ASCII (A) version of the NTypeGetPropertyValueP function.
NTypeGetTypeWithName | Picks a Unicode (W) or ASCII (A) version of the NTypeGetTypeWithName function.
NTypeIdentifierToString | Picks a Unicode (W) or ASCII (A) version of the NTypeIdentifierToString function.
NTypeIdentifierToStringFN | Picks a Unicode (W) or ASCII (A) version of the NTypeIdentifierToStringFN function.
NTypeIdentifierToStringVN | Picks a Unicode (W) or ASCII (A) version of the NTypeIdentifierToStringVN function.
NTypeInvokeMethod | Picks a Unicode (W) or ASCII (A) version of the NTypeInvokeMethod function.
NTypeInvokeMethodWithPropertyBag | Picks a Unicode (W) or ASCII (A) version of the NTypeInvokeMethodWithPropertyBag function.
NTypeInvokeMethodWithString | Picks a Unicode (W) or ASCII (A) version of the NTypeInvokeMethodWithString function.
NTypeParseValue | Picks a Unicode (W) or ASCII (A) version of the NTypeParseValue function.
NTypeParseValueVN | Picks a Unicode (W) or ASCII (A) version of the NTypeParseValueVN function.
NTypeRemoveEventHandlerP | Picks a Unicode (W) or ASCII (A) version of the NTypeRemoveEventHandlerP function.
NTypeResetPropertyValueP | Picks a Unicode (W) or ASCII (A) version of the NTypeResetPropertyValue function.
NTypeSetPropertyValueP | Picks a Unicode (W) or ASCII (A) version of the NTypeSetPropertyValueP function.
NTypeTryParseValue | Picks a Unicode (W) or ASCII (A) version of the NTypeTryParseValue function.
NTypeTryParseValueVN | Picks a Unicode (W) or ASCII (A) version of the NTypeTryParseValueVN function.
NTypeValueToString | Picks a Unicode (W) or ASCII (A) version of the NTypeValueToString function.


NType Unit Structs, Records, Enums

NType Unit Structs, Records, Enums
Legend
Structs, Records, Enums
Name | Description
NTypeCode_ | Enumerates type codes.
NTypeCode | Enumerates type codes.


NType.h Enumerations

NType.h Enumerations
Legend
Enumerations
Name | Description
NTypeCode_ | Enumerates type codes.
NTypeCode | Enumerates type codes.


NType.h Functions

NType.h Functions
Legend
Functions
Name | Description
NTypeAddEventHandlerN | Adds a handler for the specified event to the specified object.
NTypeAddEventHandlerP | Adds a handler for the specified event to the specified object.
NTypeAreValuesEqual | Checks whether the values of the specified type are equal.
NTypeCapturePropertyValues | Captures property values of the specified object.
NTypeCompareValues | Compares two values of the specified type and returns an integer that indicates their relative position in the sort order.
NTypeCopyPropertyValues | Copies property values of the specified object to another object.
NTypeCopyValue | Copies the specified value.
NTypeCreateInstance | Creates an instance of the specified type.
NTypeCreateInstanceWithName | Creates an instance of the type specified by name.
NTypeDisposeValue | Disposes the specified value.
NTypeDisposeValues | Disposes the specified value.
NTypeFreeValues | Frees the specified values.
NTypeGetAttributes | Retrieves the attributes of the specified type.
NTypeGetBaseType | Gets the base type of the specified type.
NTypeGetDeclaredConstant | Retrieves the declared constant specified by index.
NTypeGetDeclaredConstantCount | Retrieves the number of declared constants of the specified type.
NTypeGetDeclaredConstantWithName | Retrieves the declared constant specified by name.
NTypeGetDeclaredConstants | Retrieves all declared constants of the specified type.
NTypeGetDeclaredConstructor | Retrieves the declared constructor specified by index.
NTypeGetDeclaredConstructorCount | Retrieves the number of declared constructors of the specified type.
NTypeGetDeclaredConstructors | Retrieves all declared constructors of the specified type.
NTypeGetDeclaredEnumConstant | Retrieves the declared enumeration constant specified by index.
NTypeGetDeclaredEnumConstantCount | Retrieves the number of declared enumeration constants of the specified type.
NTypeGetDeclaredEnumConstantWithName | Retrieves the declared enumeration constant specified by name.
NTypeGetDeclaredEnumConstants | Retrieves all declared enumeration constants of the specified type.
NTypeGetDeclaredEvent | Retrieves the declared event specified by index.
NTypeGetDeclaredEventCount | Retrieves the number of declared events of the specified type.
NTypeGetDeclaredEventWithName | Retrieves the declared event specified by name.
NTypeGetDeclaredEvents | Retrieves all declared events of the specified type.
NTypeGetDeclaredField | Retrieves the declared field specified by index.
NTypeGetDeclaredFieldCount | Retrieves the number of declared fields of the specified type.
NTypeGetDeclaredFieldWithName | Retrieves the declared field specified by name.
NTypeGetDeclaredFields | Retrieves all declared fields of the specified type.
NTypeGetDeclaredMethod | Retrieves the declared method specified by index.
NTypeGetDeclaredMethodCount | Retrieves the number of declared methods of the specified type.
NTypeGetDeclaredMethodWithName | Retrieves the declared method specified by name.
NTypeGetDeclaredMethods | Retrieves all declared methods of the specified type.
NTypeGetDeclaredMethodsWithName | Retrieves a number of declared methods specified by names.
NTypeGetDeclaredPart | Retrieves the declared part specified by index.
NTypeGetDeclaredPartCount | Retrieves the number of declared part of the specified type.
NTypeGetDeclaredPartWithName | Retrieves the declared part specified by name.
NTypeGetDeclaredParts | Retrieves all declared parts of the specified type.
NTypeGetDeclaredProperties | Retrieves all declared properties of the specified type.
NTypeGetDeclaredProperty | Retrieves the declared property specified by index.
NTypeGetDeclaredPropertyCount | Retrieves the number of declared property of the specified type.
NTypeGetDeclaredPropertyWithName | Retrieves the declared property specified by name.
NTypeGetEnumAlternative | Retrieves alternative enumeration for the specified type.
NTypeGetModule | Gets the module of the specified type.
NTypeGetNameN | Gets the name of the specified type.
NTypeGetOwnerType | Gets the owner type of the specified type.
NTypeGetPropertyValueN | Retrieves the value of the specified property of the specified object.
NTypeGetPropertyValueP | Retrieves the value of the specified property of the specified object.
NTypeGetRootType | Retrieves the root type of the specified type.
NTypeGetRootTypeCode | Retrieves the code of the root type of the specified type.
NTypeGetTypeCode | Retrieves the type code for the specified type.
NTypeGetTypeWithName | Retrieves the type specified by name.
NTypeGetUseInsteadType | Gets the use-instead type of the specified type.
NTypeGetValueHashCode | Gets the hash code of the specified value.
NTypeGetValueSize | Gets the size of the specified value type.
NTypeHasOwnerType | Checks whether the specified type has an owner type.
NTypeIdentifierToString | Converts the specified type identifier into a string.
NTypeIdentifierToStringFN | Converts the specified type identifier into a string.
NTypeIdentifierToStringVN | Converts the specified type identifier into a string.
NTypeInvokeMethod | Invokes the specified method on the specified object.
NTypeInvokeMethodWithPropertyBag | Invokes the specified method on the specified object.
NTypeInvokeMethodWithString | Invokes the specified method on the specified object.
NTypeIsAbstract | Checks whether the specified type is abstract.
NTypeIsAssignableFrom | Checks whether the specified type is abstract from another type.
NTypeIsBasic | Checks whether the specified value is basic.
NTypeIsCallback | Checks whether the specified value is a callback.
NTypeIsCloneable | Checks whether the specified type is cloneable.
NTypeIsComparable | Checks whether the specified type is comparable.
NTypeIsDeprecated | Checks whether the specified type is deprecated.
NTypeIsDisposable | Checks whether the specified type is disposable.
NTypeIsEnum | Checks whether the specified type is an enumeration.
NTypeIsEquatable | Checks whether the specified type is equatable.
NTypeIsFlagsEnum | Checks whether the specified value is flag enumerated.
NTypeIsHandle | Checks whether the specified type is a handle.
NTypeIsInstanceOfType | Checks whether the specified object is an instance of the specified type.
NTypeIsInstanceOfTypeP | Checks whether the specified object is an instance of the specified type.
NTypeIsMemorySerializable | Checks whether the specified type is memory serializable.
NTypeIsObject | Checks whether the specified type is an object.
NTypeIsParsable | Checks whether the specified type is parsable.
NTypeIsPrimitive | Checks whether the specified type is primitive.
NTypeIsPublic | Checks whether the specified type is public.
NTypeIsSealed | Checks whether the specified type is sealed.
NTypeIsSerializable | Checks whether the specified type is serializable.
NTypeIsSignNeutral | Checks whether the specified type is sign neutral.
NTypeIsStatic | Checks whether the specified type is static.
NTypeIsStruct | Checks whether the specified type is a structure.
NTypeIsSubclassOf | Checks whether the specified type is a subclass of another type.
NTypeParseValue | Converts the specified string to a value of the specified type.
NTypeParseValueVN | Converts the specified string to a value of the specified type.
NTypeRemoveEventHandlerN | Removes an event handler from the specified object.
NTypeRemoveEventHandlerP | Removes an event handler from the specified object.
NTypeReset | Resets the type of the specified object.
NTypeResetPropertyValue | Resets the value of the specified property of the specified object.
NTypeSetPropertyValueN | Sets the value of the specified property of the specified object.
NTypeSetPropertyValueP | Sets the value of the specified property of the specified object.
NTypeSetValue | Sets the specified value.
NTypeTryParseValue | Converts the specified string to a value of the specified type. Returns a Boolean value indicating whether the conversion succeeded.
NTypeTryParseValueVN | Converts the specified string to a value of the specified type. Returns a Boolean value indicating whether the conversion succeeded.
NTypeValueToString | Converts the specified value to string.
NTypeValueToStringN | Converts the specified value to string.


NType.h Macros

NType.h Macros
Macros
Name | Description
NTypeAddEventHandlerP | Picks a Unicode (W) or ASCII (A) version of the NTypeAddEventHandlerP function.
NTypeCreateInstanceWithName | Picks a Unicode (W) or ASCII (A) version of the NTypeCreateInstanceWithName function.
NTypeGetDeclaredConstantWithName | Picks a Unicode (W) or ASCII (A) version of the NTypeGetDeclaredConstantWithName function.
NTypeGetDeclaredEnumConstantWithName | Picks a Unicode (W) or ASCII (A) version of the NTypeGetDeclaredEnumConstantWithName function.
NTypeGetDeclaredEventWithName | Picks a Unicode (W) or ASCII (A) version of the NTypeGetDeclaredEventWithName function.
NTypeGetDeclaredFieldWithName | Picks a Unicode (W) or ASCII (A) version of the NTypeGetDeclaredFieldWithName function.
NTypeGetDeclaredMethodWithName | Picks a Unicode (W) or ASCII (A) version of the NTypeGetDeclaredMethodWithName function.
NTypeGetDeclaredMethodsWithName | Picks a Unicode (W) or ASCII (A) version of the NTypeGetDeclaredMethodsWithName function.
NTypeGetDeclaredPartWithName | Picks a Unicode (W) or ASCII (A) version of the NTypeGetDeclaredPartWithName function.
NTypeGetDeclaredPropertyWithName | Picks a Unicode (W) or ASCII (A) version of the NTypeGetDeclaredPropertyWithName function.
NTypeGetPropertyValueP | Picks a Unicode (W) or ASCII (A) version of the NTypeGetPropertyValueP function.
NTypeGetTypeWithName | Picks a Unicode (W) or ASCII (A) version of the NTypeGetTypeWithName function.
NTypeIdentifierToString | Picks a Unicode (W) or ASCII (A) version of the NTypeIdentifierToString function.
NTypeIdentifierToStringFN | Picks a Unicode (W) or ASCII (A) version of the NTypeIdentifierToStringFN function.
NTypeIdentifierToStringVN | Picks a Unicode (W) or ASCII (A) version of the NTypeIdentifierToStringVN function.
NTypeInvokeMethod | Picks a Unicode (W) or ASCII (A) version of the NTypeInvokeMethod function.
NTypeInvokeMethodWithPropertyBag | Picks a Unicode (W) or ASCII (A) version of the NTypeInvokeMethodWithPropertyBag function.
NTypeInvokeMethodWithString | Picks a Unicode (W) or ASCII (A) version of the NTypeInvokeMethodWithString function.
NTypeParseValue | Picks a Unicode (W) or ASCII (A) version of the NTypeParseValue function.
NTypeParseValueVN | Picks a Unicode (W) or ASCII (A) version of the NTypeParseValueVN function.
NTypeRemoveEventHandlerP | Picks a Unicode (W) or ASCII (A) version of the NTypeRemoveEventHandlerP function.
NTypeResetPropertyValueP | Picks a Unicode (W) or ASCII (A) version of the NTypeResetPropertyValue function.
NTypeSetPropertyValueP | Picks a Unicode (W) or ASCII (A) version of the NTypeSetPropertyValueP function.
NTypeTryParseValue | Picks a Unicode (W) or ASCII (A) version of the NTypeTryParseValue function.
NTypeTryParseValueVN | Picks a Unicode (W) or ASCII (A) version of the NTypeTryParseValueVN function.
NTypeValueToString | Picks a Unicode (W) or ASCII (A) version of the NTypeValueToString function.


NTypeDescriptor Unit Files

NTypeDescriptor Unit Files
Files
Name | Description
NTypeDescriptor.h | Header file for the NTypeDescriptor module.


NTypeDescriptor Unit Functions

NTypeDescriptor Unit Functions
Legend
Functions
Name | Description
NTypeDescriptorGetDefaultPropertyName | Retrieves the default property name of the specified object.
NTypeDescriptorGetDefaultPropertyNameForType | Retrieves the default property name of the specified type.
NTypeDescriptorGetEvents | Retrieves the events of the specified object.
NTypeDescriptorGetEventsForType | Retrieves the events of the specified type.
NTypeDescriptorGetMethods | Retrieves the methods of the specified object.
NTypeDescriptorGetMethodsForType | Retrieves the methods of the specified type.
NTypeDescriptorGetProperties | Retrieves the properties of the specified object.
NTypeDescriptorGetPropertiesForType | Retrieves the properties of the specified type.


NTypeDescriptor.h Functions

NTypeDescriptor.h Functions
Legend
Functions
Name | Description
NTypeDescriptorGetDefaultPropertyName | Retrieves the default property name of the specified object.
NTypeDescriptorGetDefaultPropertyNameForType | Retrieves the default property name of the specified type.
NTypeDescriptorGetEvents | Retrieves the events of the specified object.
NTypeDescriptorGetEventsForType | Retrieves the events of the specified type.
NTypeDescriptorGetMethods | Retrieves the methods of the specified object.
NTypeDescriptorGetMethodsForType | Retrieves the methods of the specified type.
NTypeDescriptorGetProperties | Retrieves the properties of the specified object.
NTypeDescriptorGetPropertiesForType | Retrieves the properties of the specified type.


NTypes Unit Files

NTypes Unit Files
Files
Name | Description
NTypes.h | Header file for NTypes module. Defines types and macros used in Neurotechnology components.


NTypes Unit Functions

NTypes Unit Functions
Legend
Functions
Name | Description
NACharParseN | Converts a NString to NAChar.
NACharParseStrOrChars | Converts an array of NChars to NAChar.
NACharParseVN | Converts a NString to NAChar.
NACharToChars | Converts NAChar to an array of NAChars.
NACharToString | Converts NAChar to NString
NACharTryParseN | Converts NString to NAChar. A NBool value indicates whether the conversion succeeded.
NACharTryParseStrOrChars | Converts an array of NChars to NAChar. A NBool value indicates whether the conversion succeeded.
NACharTryParseVN | Converts NString to NAChar. A NBool value indicates whether the conversion succeeded.
NBooleanParseN | Converts NString to NBoolean.
NBooleanParseStrOrChars | Converts an array of NChars to NBoolean.
NBooleanParseVN | Converts NString to NBoolean.
NBooleanToChars | Converts NBoolean to an array of NChars.
NBooleanToString | Converts NBoolean to NString.
NBooleanTryParseN | Converts a NString to NBoolean. A NBool value indicates whether the conversion succeeded.
NBooleanTryParseStrOrChars | Converts an array of NStrings or NChars into NBoolean. A NBool value indicates whether the conversion succeeded.
NBooleanTryParseVN | Converts a NString to NBoolean. A NBool value indicates whether the conversion succeeded.
NCharFromBinDigit | Converts a binary digit to NChar.
NCharFromDigit | Converts a digit to NChar.
NCharFromHexDigit | Converts a hexadecimal digit to NChar.
NCharFromOctDigit | Converts an octal digit to NChar.
NCharIsAscii | Checks whether the specified char is ASCII.
NCharIsBinDigit | Checks whether the specified character is a binary digit.
NCharIsDigit | Checks whether the specified character is a digit.
NCharIsHexDigit | Checks whether the specified character is a hexadecimal digit.
NCharIsLetter | Checks whether the specified character is a letter.
NCharIsLower | Checks whether the specified character is a lower value.
NCharIsOctDigit | Checks whether the specified character is an octal digit.
NCharIsUpper | Checks whether the specified character is an upper value.
NCharIsWhiteSpace | Checks whether the specified character is a whitespace.
NCharParseN | Converts a NString to a NChar.
NCharParseStrOrChars | Converts an array of NStrings or NChars into NChar.
NCharParseVN | Converts a NString to a NChar.
NCharToBinDigit | Converts a NChar to a binary digit.
NCharToChars | Converts a NChar into an array of NChars.
NCharToDigit | Converts a NChar to a digit.
NCharToHexDigit | Converts a NChar to a hexadecimal digit.
NCharToLower | Converts a NChar to lowercase.
NCharToOctDigit | Converts a NChar to an octal digit.
NCharToString | Converts NChar to NString.
NCharToUpper | Converts NChar to uppercase.
NCharTryParseN | Converts a NString to a NChar. A NBool value indicates whether the conversion succeeded.
NCharTryParseStrOrChars | Converts an array of NChars into NChar. A NBool value indicates whether the conversion succeeded.
NCharTryParseVN | Converts a NString to a NChar. A NBool value indicates whether the conversion succeeded.
NComplexToString | Converts NComplex to NString.
NDoubleGetNaN | Retrieves a NDouble that is Not a Number (NaN).
NDoubleGetNegativeInfinity | Retrieves a NDouble that is NegativeInfinity.
NDoubleGetPositiveInfinity | Retrieves a NDouble that is PositiveInfinity.
NDoubleIsInfinity | Checks if NDouble evaluates to NegativeInfinity or PositiveInfinity.
NDoubleIsNaN | Checks if NDouble is Not a Number (NaN).
NDoubleIsNegativeInfinity | Checks if NDouble evaluates to NegativeInfinity.
NDoubleIsPositiveInfinity | Checks if NDouble evaluates to PositiveInfinity
NDoubleParseN | Converts a NString into NDouble.
NDoubleParseStrOrChars | Converted an array of NChars to NDouble.
NDoubleParseVN | Converts a NString into NDouble.
NDoubleToChars | Converts NDouble to an array of NChars.
NDoubleToString | Converts NDouble to NString.
NDoubleTryParseN | Converts a NString to NDouble. A NBool value indicates whether the conversion succeeded.
NDoubleTryParseStrOrChars | Converts an array of NChars to NDouble. A NBool value indicates whether the conversion succeeded.
NDoubleTryParseVN | Converts a NString to NDouble. A NBool value indicates whether the conversion succeeded.
NGuidParse | Converts a NChar to NGuid.
NGuidParseVN | Converts a NString to NGuid.
NGuidToString | Converts a NGuid to NString.
NGuidTryParse | Converts a NChar to NGuid. A NBool value indicates whether the conversion succeeded.
NGuidTryParseVN | Converts a NString to NGuid. A NBool value indicates whether the conversion succeeded.
NIndexPairToString | Convertes NIndexPair to NString.
NInt16ParseN | Convertes NString to NInt16.
NInt16ParseStrOrChars | Converts an array of NChars to NInt16.
NInt16ParseVN | Convertes NString to NInt16.
NInt16ToChars | Converts NInt16 to an array of NChars.
NInt16ToString | Converts NInt16 to NString.
NInt16TryParseN | Converts NString to NInt16. A NBool value indicates whether the conversion succeeded.
NInt16TryParseStrOrChars | Converts an array of NChars to NInt16. A NBool value indicates whether the conversion succeeded.
NInt16TryParseVN | Converts NString to NInt16. A NBool value indicates whether the conversion succeeded.
NInt32ParseN | Converts NString to NInt32.
NInt32ParseStrOrChars | Converts an array of NChars to NInt32.
NInt32ParseVN | Converts NString to NInt32.
NInt32ToChars | Converts NInt32 to an array of NChars.
NInt32ToString | Converts NInt32 to NString.
NInt32TryParseN | Converts NString to NInt32. A NBool value indicates whether the conversion succeeded.
NInt32TryParseStrOrChars | Converts an array of NChars to NInt32. A NBool value indicates whether the conversion succeeded.
NInt32TryParseVN | Converts NString to NInt32. A NBool value indicates whether the conversion succeeded.
NInt64ParseN | Converts NString to NInt64.
NInt64ParseStrOrChars | Converts an array of NChars to NInt64.
NInt64ParseVN | Converts NString to NInt64.
NInt64ToChars | Converts NInt64 to an array of NChars.
NInt64ToString | Converts NInt64 to NString.
NInt64TryParseN | Converts NString to NInt64. A NBool value indicates whether the conversion succeeded.
NInt64TryParseStrOrChars | Converts an array of NChars to NInt64. A NBool value indicates whether the conversion succeeded.
NInt64TryParseVN | Converts NString to NInt64. A NBool value indicates whether the conversion succeeded.
NInt8ParseN | Converts NString to NInt8.
NInt8ParseStrOrChars | Converts an array of NChars to NInt8.
NInt8ParseVN | Converts NString to NInt8.
NInt8ToChars | Converts NInt8 to an array of NChars.
NInt8ToString | Converts NInt8 to NString.
NInt8TryParseN | Converts NString to NInt8. A NBool value indicates whether the conversion succeeded.
NInt8TryParseStrOrChars | Converts an array of NChars to NInt8. A NBool value indicates whether the conversion succeeded.
NInt8TryParseVN | Converts NString to NInt8. A NBool value indicates whether the conversion succeeded.
NNameStringPairCopy | Creates a copy of string pair structure.
NNameStringPairCreate | Creates a new string pair structure.
NNameStringPairDispose | Disposes of the specified string pair structure.
NNameStringPairSet | Sets the value of the specified string pair structure.
NOSFamilyGetCurrent | Retrieves the current operating system family.
NPointerParseN | Converts NString to NPointer.
NPointerParseStrOrChars | Converts an array of NChars to NPointer.
NPointerParseVN | Converts NString to NPointer.
NPointerToChars | Converts NPointer to an array of NChars.
NPointerToString | Converts NPointer to NString.
NPointerTryParseN | Converts NString to NPointer. A NBool value indicates whether the conversion succeeded.
NPointerTryParseStrOrChars | Converts an array of NChars to NPointer. A NBool value indicates whether the conversion succeeded.
NPointerTryParseVN | Converts NString to NPointer. A NBool value indicates whether the conversion succeeded.
NRangeToString | Converts NRange to NString.
NRationalToString | Converts NRational to NString.
NResultParseN | Converts NString to NResult.
NResultParseStrOrChars | Converts an array of NChars to NResult.
NResultParseVN | Converts NString to NResult.
NResultToChars | Converts NResult to an array of NChars.
NResultToString | Converts NResult to NString.
NResultTryParseN | Converts NString to NResult. A NBool value indicates whether the conversion succeeded.
NResultTryParseStrOrChars | Converts an array of NChars to NResult. A NBool value indicates whether the conversion succeeded.
NResultTryParseVN | Converts NString to NResult. A NBool value indicates whether the conversion succeeded.
NSSizeTypeParseN | Converts NString to NSSizeType.
NSSizeTypeParseStrOrChars | Converts an array of NChars to NSSizeType.
NSSizeTypeParseVN | Converts NString to NSSizeType.
NSSizeTypeToChars | Converts NSSizeType to an array of NChars.
NSSizeTypeToString | Converts NSSizeType to NString.
NSSizeTypeTryParseN | Converts NString to NSSizeType. A NBool value indicates whether the conversion succeeded.
NSSizeTypeTryParseStrOrChars | Converts an array of NChars to NSSizeType. A NBool value indicates whether the conversion succeeded.
NSSizeTypeTryParseVN | Converts NString to NSSizeType. A NBool value indicates whether the conversion succeeded.
NSingleGetNaN | Retrieves a NSingle that is Not a Number (NaN).
NSingleGetNegativeInfinity | Retrieves a NSingle that is NegativeInfinity.
NSingleGetPositiveInfinity | Retrieves a NSingle that is PositiveInfinity.
NSingleIsInfinity | Checks if NSingle evaluates to NegativeInfinity or PositiveInfinity.
NSingleIsNaN | Checks if NSingle Not a Number (NaN).
NSingleIsNegativeInfinity | Checks if NSingle evaluates to NegativeInfinity.
NSingleIsPositiveInfinity | Checks if NSingle evaluates to PositiveInfinity.
NSingleParseN | Converts NString to NSingle.
NSingleParseStrOrChars | Converts an array of NChars to NSingle.
NSingleParseVN | Converts NString to NSingle.
NSingleToChars | Converts NSingle to an array of NChars.
NSingleToString | Converts NSingle to NString.
NSingleTryParseN | Converts NString to NSingle. A NBool value indicates whether the conversion succeeded.
NSingleTryParseStrOrChars | Converts an array of NChars to NSingle. A NBool value indicates whether the conversion succeeded.
NSingleTryParseVN | Converts NString to NSingle. A NBool value indicates whether the conversion succeeded.
NSizeTypeParseN | Converts NString to NSizeType.
NSizeTypeParseStrOrChars | Converts an array of NChars to NSizeType.
NSizeTypeParseVN | Converts NString to NSizeType.
NSizeTypeToChars | Converts NSizeType to an array of NChars.
NSizeTypeToString | Converts NSizeType to NString.
NSizeTypeTryParseN | Converts NString to NSizeType. A NBool value indicates whether the conversion succeeded.
NSizeTypeTryParseStrOrChars | Converts an array of NChars to NSizeType. A NBool value indicates whether the conversion succeeded.
NSizeTypeTryParseVN | Converts NString to NSizeType. A NBool value indicates whether the conversion succeeded.
NSwapDWordArray | Swaps the element order of the specified array of unsigned integers from little Endian to big Endian, or vice-versa.
NSwapDouble | Swaps the byte order of the specified double value from little Endian to big Endian, or vice-versa.
NSwapDoubleArray | Swaps the element order of the specified array of single values from little Endian to big Endian, or vice-versa.
NSwapQWordArray | Swaps the element order of the specified array of unsigned long integers from little Endian to big Endian, or vice-versa.
NSwapSingle | Swaps the byte order of the specified single value from little Endian to big Endian, or vice-versa.
NSwapSingleArray | Swaps the element order of the specified array of single values from little Endian to big Endian, or vice-versa.
NSwapWordArray | Swaps the element order of the specified array of unsigned short integers from little Endian to big Endian, or vice-versa.
NTypesGetPointer | Retrieves a pointer to object.
NUInt16ParseN | Converts NString to NUInt16.
NUInt16ParseStrOrChars | Converts an array of NChars to NUInt16.
NUInt16ParseVN | Converts NString to NUInt16.
NUInt16ToChars | Converts NUInt16 to an array of NChars.
NUInt16ToString | Converts NUInt16 to NString.
NUInt16TryParseN | Converts NString to NUInt16. A NBool value indicates whether the conversion succeeded.
NUInt16TryParseStrOrChars | Converts an array of NChars to NUInt16. A NBool value indicates whether the conversion succeeded.
NUInt16TryParseVN | Converts NString to NUInt16. A NBool value indicates whether the conversion succeeded.
NUInt32ParseN | Converts NString to NUInt32.
NUInt32ParseStrOrChars | Converts an array of NChars to NUInt32.
NUInt32ParseVN | Converts NString to NUInt32.
NUInt32ToChars | Converts NUInt32 to an array of NChars.
NUInt32ToString | Converts NUInt32 to NString.
NUInt32TryParseN | Converts NString to NUInt32. A NBool value indicates whether the conversion succeeded.
NUInt32TryParseStrOrChars | Converts an array of NChars to NUInt32. A NBool value indicates whether the conversion succeeded.
NUInt32TryParseVN | Converts NString to NUInt32. A NBool value indicates whether the conversion succeeded.
NUInt64ParseN | Converts NString to NUInt64.
NUInt64ParseStrOrChars | Converts an array of NChars to NUInt64.
NUInt64ParseVN | Converts NString to NUInt64.
NUInt64ToChars | Converts NUInt64 to an array of NChars.
NUInt64ToString | Converts NUInt64 to NString.
NUInt64TryParseN | Converts NString to NUInt64. A NBool value indicates whether the conversion succeeded.
NUInt64TryParseStrOrChars | Converts an array of NChars to NUInt64. A NBool value indicates whether the conversion succeeded.
NUInt64TryParseVN | Converts NString to NUInt64. A NBool value indicates whether the conversion succeeded.
NUInt8ParseN | Converts NString to NUInt8.
NUInt8ParseStrOrChars | Converts an array of NChars to NUInt8.
NUInt8ParseVN | Converts NString to NUInt8.
NUInt8ToChars | Converts NUInt8 to an array of NChars.
NUInt8ToString | Converts NUInt8 to NString.
NUInt8TryParseN | Converts NString to NUInt8. A NBool value indicates whether the conversion succeeded.
NUInt8TryParseStrOrChars | Converts an array of NChars to NUInt8. A NBool value indicates whether the conversion succeeded.
NUInt8TryParseVN | Converts NString to NUInt8. A NBool value indicates whether the conversion succeeded.
NURationalToString | Converts NURational to NString.
NVersionRangeContains | Checks if NVersionRange contains a certain version.
NVersionRangeContainsRange | Checks if NVersionRange contains a certain version range.
NVersionRangeIntersect | Replaces NVersionRange with the intersection of itself and another NVersionRange.
NVersionRangeIntersectsWith | Returns third NVersionRange that represents the intersection of two other NVersionRanges. If there is no intersection, an empty NVersionRange is returned.
NVersionRangeToString | Converts NVersionRange to NString.
NVersionToString | Converts NVersion to NString.
NWCharParseN | Converts NString to NWChar.
NWCharParseStrOrChars | Converts an array of NChars to NWChar.
NWCharParseVN | Converts NString to NWChar.
NWCharToChars | Converts NWChar to an array of NChars.
NWCharToString | Converts NWChar to NString.
NWCharTryParseN | Converts NString to NWChar. A NBool value indicates whether the conversion succeeded.
NWCharTryParseStrOrChars | Converts an array of NChars to NWChar. A NBool value indicates whether the conversion succeeded.
NWCharTryParseVN | Converts NString to NWChar. A NBool value indicates whether the conversion succeeded.


Legend

Legend
Legend
Method
Enumeration
Structure


NTypes Unit Macros

NTypes Unit Macros
Macros
Name | Description
N_DECLARE_HANDLE | Declares handle with specified name.
NACharParse | Converts a NString to NAChar.
NACharParseChars | Converts an array of NChars to NAChar.
NACharParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NACharParseStrOrChars function.
NACharParseVN | Picks a Unicode (W) or ASCII (A) version of the NACharParseVN function.
NACharToChars | Picks a Unicode (W) or ASCII (A) version of the NACharToChars function.
NACharToString | Picks a Unicode (W) or ASCII (A) version of the NACharToString function.
NACharTryParse | Converts NString to NAChar. A NBool value indicates whether the conversion succeeded.
NACharTryParseChars | Converts an array of NChars to NAChar. A NBool value indicates whether the conversion succeeded.
NACharTryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NACharTryParseStrOrChars function.
NACharTryParseVN | Picks a Unicode (W) or ASCII (A) version of the NACharTryParseVN function.
NBooleanParse | Converts NString to NBoolean.
NBooleanParseChars | Converts an array of NChars to NBoolean.
NBooleanParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NBooleanParseStrOrChars function.
NBooleanParseVN | Picks a Unicode (W) or ASCII (A) version of the NBooleanParseVN function.
NBooleanToChars | Picks a Unicode (W) or ASCII (A) version of the NBooleanToChars function.
NBooleanToString | Picks a Unicode (W) or ASCII (A) version of the NBooleanToString function.
NBooleanTryParse | Converts NString to NBoolean. A NBool value indicates whether the conversion succeeded.
NBooleanTryParseChars | Converts an array of NChars to NBoolean. A NBool value indicates whether the conversion succeeded.
NBooleanTryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NBooleanTryParseStrOrChars function.
NBooleanTryParseVN | Picks a Unicode (W) or ASCII (A) version of the NBooleanTryParseVN function.
NCharFromBinDigit | Picks a Unicode (W) or ASCII (A) version of the NCharFromBinDigit function.
NCharFromDigit | Picks a Unicode (W) or ASCII (A) version of the NCharFromDigit function.
NCharFromHexDigit | Picks a Unicode (W) or ASCII (A) version of the NCharFromHexDigit function.
NCharFromOctDigit | Picks a Unicode (W) or ASCII (A) version of the NCharFromOctDigit function.
NCharIsAscii | Picks a Unicode (W) or ASCII (A) version of the NCharIsAscii function.
NCharIsBinDigit | Picks a Unicode (W) or ASCII (A) version of the NCharIsBinDigit function.
NCharIsDigit | Picks a Unicode (W) or ASCII (A) version of the NCharIsDigit function.
NCharIsHexDigit | Picks a Unicode (W) or ASCII (A) version of the NCharIsHexDigit function.
NCharIsLetter | Picks a Unicode (W) or ASCII (A) version of the NCharIsLetter function.
NCharIsLower | Picks a Unicode (W) or ASCII (A) version of the NCharIsLower function.
NCharIsOctDigit | Picks a Unicode (W) or ASCII (A) version of the NCharIsOctDigit function.
NCharIsUpper | Picks a Unicode (W) or ASCII (A) version of the NCharIsUpper function.
NCharIsWhiteSpace | Picks a Unicode (W) or ASCII (A) version of the NCharIsWhiteSpace function.
NCharParse | Converts NString to NChar.
NCharParseChars | Converts an array of NChars to NBoolean.
NCharToBinDigit | Picks a Unicode (W) or ASCII (A) version of the NCharToBinDigit function.
NCharToDigit | Picks a Unicode (W) or ASCII (A) version of the NCharToDigit function.
NCharToHexDigit | Picks a Unicode (W) or ASCII (A) version of the NCharToHexDigit function.
NCharToLower | Picks a Unicode (W) or ASCII (A) version of the NCharToLower function.
NCharToOctDigit | Picks a Unicode (W) or ASCII (A) version of the NCharToOctDigit function.
NCharToUpper | Picks a Unicode (W) or ASCII (A) version of the NCharToUpper function.
NCharTryParse | Converts NString to NChar. A NBool value indicates whether the conversion succeeded.
NCharTryParseChars | Converts an array of NChars to NChar. A NBool value indicates whether the conversion succeeded.
NDoubleParse | Converts NString to NDouble.
NDoubleParseChars | Converts an array of NChars to NChar.
NDoubleParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NDoubleParseStrOrChars function.
NDoubleParseVN | Picks a Unicode (W) or ASCII (A) version of the NDoubleParseVN function.
NDoubleToChars | Picks a Unicode (W) or ASCII (A) version of the NDoubleToChars function.
NDoubleToString | Picks a Unicode (W) or ASCII (A) version of the NDoubleToString function.
NDoubleTryParse | Converts NString to NDouble. A NBool value indicates whether the conversion succeeded.
NDoubleTryParseChars | Converts an array of NChars to NDouble. A NBool value indicates whether the conversion succeeded.
NDoubleTryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NDoubleTryParseStrOrChars function.
NDoubleTryParseVN | Picks a Unicode (W) or ASCII (A) version of the NDoubleTryParseVN function.
NFalse | False value for NBoolean.
NGuidParse | Picks a Unicode (W) or ASCII (A) version of the NGuidParse function.
NGuidParseVN | Picks a Unicode (W) or ASCII (A) version of the NGuidParseVN function.
NGuidToString | Picks a Unicode (W) or ASCII (A) version of the NGuidToString function.
NGuidTryParse | Picks a Unicode (W) or ASCII (A) version of the NGuidTryParse function.
NGuidTryParseVN | Picks a Unicode (W) or ASCII (A) version of the NGuidTryParseVN function.
NIndexPairToString | Picks a Unicode (W) or ASCII (A) version of the NIndexPairToString function.
NInt16Parse | Converts NString to NInt16.
NInt16ParseChars | Converts an array of NChars to NInt16.
NInt16ParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NInt16ParseStrOrChars function.
NInt16ParseVN | Picks a Unicode (W) or ASCII (A) version of the NInt16ParseVN function.
NInt16ToChars | Picks a Unicode (W) or ASCII (A) version of the NInt16ToChars function.
NInt16ToString | Picks a Unicode (W) or ASCII (A) version of the NInt16ToString function.
NInt16TryParse | Converts NString to NInt16. A NBool value indicates whether the conversion succeeded.
NInt16TryParseChars | Converts an array of NChars to NInt16. A NBool value indicates whether the conversion succeeded.
NInt16TryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NInt16TryParseStrOrChars function.
NInt16TryParseVN | Picks a Unicode (W) or ASCII (A) version of the NInt16TryParseVN function.
NInt32Parse | Converts NString to NInt32.
NInt32ParseChars | Converts an array of NChars to NInt32.
NInt32ParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NInt32ParseStrOrChars function.
NInt32ParseVN | Picks a Unicode (W) or ASCII (A) version of the NInt32ParseVN function.
NInt32ToChars | Picks a Unicode (W) or ASCII (A) version of the NInt32ToChars function.
NInt32ToString | Picks a Unicode (W) or ASCII (A) version of the NInt32ToString function.
NInt32TryParse | Converts NString to NInt32. A NBool value indicates whether the conversion succeeded.
NInt32TryParseChars | Converts an array of NChars to NInt32. A NBool value indicates whether the conversion succeeded.
NInt32TryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NInt32TryParseStrOrChars function.
NInt32TryParseVN | Picks a Unicode (W) or ASCII (A) version of the NInt32tryParseVN function.
NInt64Parse | Converts NString to NInt64.
NInt64ParseChars | Converts an array of NChars to NInt64.
NInt64ParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NInt64ParseStrOrChars function.
NInt64ParseVN | Picks a Unicode (W) or ASCII (A) version of the NInt64ParseVN function.
NInt64ToChars | Picks a Unicode (W) or ASCII (A) version of the NInt64ToChars function.
NInt64ToString | Picks a Unicode (W) or ASCII (A) version of the NInt64ToString function.
NInt64TryParse | Converts NString to NInt64. A NBool value indicates whether the conversion succeeded.
NInt64TryParseChars | Converts an array of NChars to NInt64. A NBool value indicates whether the conversion succeeded.
NInt64TryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NInt64TryParseStrOrChars function.
NInt64TryParseVN | Picks a Unicode (W) or ASCII (A) version of the NInt64TryParseVN function.
NInt8Parse | Converts NString to NInt8.
NInt8ParseChars | Converts an array of NChars to NInt8.
NInt8ParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NInt8ParseStrOrChars function.
NInt8ParseVN | Picks a Unicode (W) or ASCII (A) version of the NInt8ParseVN function.
NInt8ToChars | Picks a Unicode (W) or ASCII (A) version of the NInt8ToChars function.
NInt8ToString | Picks a Unicode (W) or ASCII (A) version of the NInt8ToString function.
NInt8TryParse | Converts NString to NInt8. A NBool value indicates whether the conversion succeeded.
NInt8TryParseChars | Converts an array of NChars to NInt8. A NBool value indicates whether the conversion succeeded.
NInt8TryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NInt8TryParseStrOrChars function.
NInt8TryParseVN | Picks a Unicode (W) or ASCII (A) version of the NInt8TryParseVN function.
NPointerParse | Converts NString to NPointer.
NPointerParseChars | Converts an array of NChars to NPointer.
NPointerParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NPointerParseStrOrChars function.
NPointerParseVN | Picks a Unicode (W) or ASCII (A) version of the NPointerParseVN function.
NPointerToChars | Picks a Unicode (W) or ASCII (A) version of the NPointerToChars function.
NPointerToString | Picks a Unicode (W) or ASCII (A) version of the NPointerToString function.
NPointerTryParse | Converts NString to NInt8. A NBool value indicates whether the conversion succeeded.
NPointerTryParseChars | Converts an array of NChars to NPointer. A NBool value indicates whether the conversion succeeded.
NPointerTryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NPointerTryParseStrOrChars function.
NPointerTryParseVN | Picks a Unicode (W) or ASCII (A) version of the NPointerTryParseVN function.
NRangeToString | Picks a Unicode (W) or ASCII (A) version of the NRangeToString function.
NRationalToString | Picks a Unicode (W) or ASCII (A) version of the NRationalToString function.
NResultParseVN | Picks a Unicode (W) or ASCII (A) version of the NResultParseVN function.
NResultToChars | Picks a Unicode (W) or ASCII (A) version of the NResultToChars function.
NResultToString | Picks a Unicode (W) or ASCII (A) version of the ResultToString function.
NResultTryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NResultTryParseStrOrChars function.
NResultTryParseVN | Picks a Unicode (W) or ASCII (A) version of the NResultTryParseVN function.
NSSizeTypeParse | Converts NString to NSSizeType.
NSSizeTypeParseChars | Converts an array of NChars to NSSizeType.
NSSizeTypeParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NSSizeTypeParseStrOrChars function.
NSSizeTypeParseVN | Picks a Unicode (W) or ASCII (A) version of the NSSizeTypeParseVN function.
NSSizeTypeToChars | Picks a Unicode (W) or ASCII (A) version of the NSSizeTypeToChars function.
NSSizeTypeToString | Picks a Unicode (W) or ASCII (A) version of the NSSizeTypeToString function.
NSSizeTypeTryParse | Converts NString to NSSizeType. A NBool value indicates whether the conversion succeeded.
NSSizeTypeTryParseChars | Converts an array of NChars to NSSizeType. A NBool value indicates whether the conversion succeeded.
NSSizeTypeTryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NSSizeTypeTryParseStrOrChars function.
NSSizeTypeTryParseVN | Picks a Unicode (W) or ASCII (A) version of the NSSizeTypeTryParseVN function.
NSingleParse | Converts NString to NSingle.
NSingleParseChars | Converts an array of NChars to NSingle.
NSingleParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NSingleParseStrOrChars function.
NSingleParseVN | Picks a Unicode (W) or ASCII (A) version of the NSingleParseVN function.
NSingleToChars | Picks a Unicode (W) or ASCII (A) version of the NSingleToChars function.
NSingleToString | Picks a Unicode (W) or ASCII (A) version of the NSingleToString function.
NSingleTryParse | Converts NString to NSingle. A NBool value indicates whether the conversion succeeded.
NSingleTryParseChars | Converts an array of NChars to NSingle. A NBool value indicates whether the conversion succeeded.
NSingleTryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NSingleTryParseStrOrChars function.
NSingleTryParseVN | Picks a Unicode (W) or ASCII (A) version of the NSingleTryParseVN function.
NSizeTypeParse | Converts NString to NSizeType.
NSizeTypeParseChars | Converts an array of NChars to NSizeType.
NSizeTypeParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NSizeTypeParseStrOrChars function.
NSizeTypeParseVN | Picks a Unicode (W) or ASCII (A) version of the NSizeTypeParseVN function.
NSizeTypeToChars | Picks a Unicode (W) or ASCII (A) version of the NSizeTypeToChars function.
NSizeTypeToString | Picks a Unicode (W) or ASCII (A) version of the NSizeTypeToString function.
NSizeTypeTryParse | Converts NString to NSizeType. A NBool value indicates whether the conversion succeeded.
NSizeTypeTryParseChars | Converts an array of NChars to NSizeType. A NBool value indicates whether the conversion succeeded.
NSizeTypeTryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NSizeTypeTryParseStrOrChars function.
NSizeTypeTryParseVN | Picks a Unicode (W) or ASCII (A) version of the NSizeTypeTryParseVN function.
NTrue | True value for NBoolean.
NUInt16Parse | Converts NString to NUInt16.
NUInt16ParseChars | Converts an array of NChars to NUInt16.
NUInt16ParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NUInt16ParseStrOrChars function.
NUInt16ParseVN | Picks a Unicode (W) or ASCII (A) version of the NUInt16ParseVN function.
NUInt16ToChars | Picks a Unicode (W) or ASCII (A) version of the NUInt16ToChars function.
NUInt16ToString | Picks a Unicode (W) or ASCII (A) version of the NUInt16ParseToString function.
NUInt16TryParse | Converts NString to NUInt16. A NBool value indicates whether the conversion succeeded.
NUInt16TryParseChars | Converts an array of NChars to NUInt16. A NBool value indicates whether the conversion succeeded.
NUInt16TryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NUInt16TryParseStrOrChars function.
NUInt16TryParseVN | Picks a Unicode (W) or ASCII (A) version of the NUInt16TryParseVN function.
NUInt32Parse | Converts NString to NUInt32.
NUInt32ParseChars | Converts an array of NChars to NUInt32.
NUInt32ParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NUInt32ParseStrOrChars function.
NUInt32ParseVN | Picks a Unicode (W) or ASCII (A) version of the NUInt32ParseVN function.
NUInt32ToChars | Picks a Unicode (W) or ASCII (A) version of the NUInt32ToChars function.
NUInt32ToString | Picks a Unicode (W) or ASCII (A) version of the NUInt32ToString function.
NUInt32TryParse | Converts NString to NUInt32. A NBool value indicates whether the conversion succeeded.
NUInt32TryParseChars | Converts an array of NChars to NUInt32. A NBool value indicates whether the conversion succeeded.
NUInt32TryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NUInt32TryParseStrOrChars function.
NUInt32TryParseVN | Picks a Unicode (W) or ASCII (A) version of the NUInt32TryParseVN function.
NUInt64Parse | Converts NString to NUInt64.
NUInt64ParseChars | Converts an array of NChars to NUInt64.
NUInt64ParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NUInt64ParseStrOrChars function.
NUInt64ParseVN | Picks a Unicode (W) or ASCII (A) version of the NUInt64ParseVN function.
NUInt64ToChars | Picks a Unicode (W) or ASCII (A) version of the NUInt64ToChars function.
NUInt64ToString | Picks a Unicode (W) or ASCII (A) version of the NUInt64ToString function.
NUInt64TryParse | Converts NString to NUInt64. A NBool value indicates whether the conversion succeeded.
NUInt64TryParseChars | Converts an array of NChars to NUInt64. A NBool value indicates whether the conversion succeeded.
NUInt64TryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NUInt64TryParseStrOrChars function.
NUInt64TryParseVN | Picks a Unicode (W) or ASCII (A) version of the NUInt64TryParseVN function.
NUInt8Parse | Converts NString to NUInt8.
NUInt8ParseChars | Converts an array of NChars to NUInt8.
NUInt8ParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NUInt8ParseStrOrChars function.
NUInt8ParseVN | Picks a Unicode (W) or ASCII (A) version of the NUInt8ParseVN function.
NUInt8ToChars | Picks a Unicode (W) or ASCII (A) version of the NUInt8ToChars function.
NUInt8ToString | Picks a Unicode (W) or ASCII (A) version of the NUInt8ToString function.
NUInt8TryParse | Converts NString to NUInt8. A NBool value indicates whether the conversion succeeded.
NUInt8TryParseChars | Converts an array of NChars to NUInt8. A NBool value indicates whether the conversion succeeded.
NUInt8TryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NUInt8TryParseStrOrChars function.
NUInt8TryParseVN | Picks a Unicode (W) or ASCII (A) version of the NUInt8TryParseVN function.
NULL | Null value for pointer.
NURationalToString | Picks a Unicode (W) or ASCII (A) version of the NURationalToString function.
NVersionRangeToString | Picks a Unicode (W) or ASCII (A) version of the NVersionRangeToString function.
NVersionToString | Picks a Unicode (W) or ASCII (A) version of the NVersionToString function.
NWCharParse | Converts NString to NWChar.
NWCharParseChars | Converts an array of NChars to NWChar.
NWCharParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NWCharParseStrOrChars function.
NWCharParseVN | Picks a Unicode (W) or ASCII (A) version of the NWCharParseVN function.
NWCharToChars | Picks a Unicode (W) or ASCII (A) version of the NWCharToChars function.
NWCharToString | Picks a Unicode (W) or ASCII (A) version of the NWCharToString function.
NWCharTryParse | Converts NString to NWChar. A NBool value indicates whether the conversion succeeded.
NWCharTryParseChars | Converts an array of NChars to NWChar. A NBool value indicates whether the conversion succeeded.
NWCharTryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NWCharTryParseStrOrChars function.
NWCharTryParseVN | Picks a Unicode (W) or ASCII (A) version of the NWCharTryParseVN function.
N_BOOLEAN_FALSE_STRING | ANSI or Unicode (if N_UNICODE is defined) string, representing NFalse Boolean value.
N_BOOLEAN_FALSE_STRINGA | ANSI string, representing NFalse Boolean value.
N_BOOLEAN_FALSE_STRINGW | Unicode (if N_UNICODE is defined) string, representing NFalse Boolean value.
N_BOOLEAN_TRUE_STRING | ANSI or Unicode (if N_UNICODE is defined) string, representing NTrue Boolean value.
N_BOOLEAN_TRUE_STRINGA | ANSI string, representing NTrue Boolean value.
N_BOOLEAN_TRUE_STRINGW | Unicode (if N_UNICODE is defined) string, representing NTrue Boolean value.
N_BYTE_MAX | Maximum value for NByte.
N_BYTE_MIN | Minimum value for NByte.
N_DECLARE_HANDLE_TYPE | Declares handle type with specified name.
N_DECLARE_OBJECT_TYPE | Declares object type with specified name.
N_DECLARE_STATIC_OBJECT_TYPE | Declares static object type with specified name.
N_DECLARE_TYPE | Declares type with specified name.
N_DECLATE_PRIMITIVE | Declares primitive with specified name.
N_DOUBLE_EPSILON | Epsilon value for NDouble.
N_DOUBLE_MAX | Maximum value for NDouble.
N_DOUBLE_MIN | Minimum value for NDouble.
N_FLOAT_EPSILON | Epsilon value for NFloat.
N_FLOAT_INFINITY_STRING | ANSI or Unicode (if N_UNICODE is defined) string, representing "Infinity" floating-point value.
N_FLOAT_INFINITY_STRINGA | ANSI string, representing "Infinity" floating-point value.
N_FLOAT_INFINITY_STRINGW | Unicode (if N_UNICODE is defined) string, representing "Infinity" floating-point value.
N_FLOAT_MAX | Maximum value for NFloat.
N_FLOAT_MIN | Minimum value for NFloat.
N_FLOAT_NAN_STRING | ANSI or Unicode (if N_UNICODE is defined) string, representing "NaN" floating-point value.
N_FLOAT_NAN_STRINGA | ANSI string, representing "NaN" floating-point value.
N_FLOAT_NAN_STRINGW | Unicode (if N_UNICODE is defined) string, representing "NaN" floating-point value.
N_INT16_MAX | Maximum value for NShort.
N_INT16_MIN | Minimum value for NShort.
N_INT32_MAX | Maximum value for NInt.
N_INT32_MIN | Minimum value for NInt.
N_INT64_MAX | Maximum value for NInt64.
N_INT64_MIN | Minimum value for NInt64.
N_INT8_MAX | Maximum value for NSByte.
N_INT8_MIN | Minimum value for NSByte.
N_INT_MAX | Maximum value for NInt.
N_INT_MIN | Minimum value for NInt.
N_LONG_MAX | Maximum value for NLong.
N_LONG_MIN | Minimum value for NLong.
N_PTR_SIZE | Defines pointer size.
N_SBYTE_MAX | Maximum value for NSByte.
N_SBYTE_MIN | Minimum value for NSByte.
N_SHORT_MAX | Maximum value for NShort.
N_SHORT_MIN | Minimum value for NShort.
N_SINGLE_EPSILON | Epsilon value for NSingle.
N_SINGLE_MAX | Maximum value for NSingle.
N_SINGLE_MIN | Minimum value for NSingle.
N_SIZE_TYPE_MAX | Maximum value for NSizeType.
N_SIZE_TYPE_MIN | Minimum value for NSizeType.
N_SSIZE_TYPE_MAX | Maximum value for NSSizeType.
N_SSIZE_TYPE_MIN | Minimum value for NSSizeType.
N_TYPE_OF | Used to obtain a pointer to the function that retrieves NType object for the specified type name.",
N_UINT16_MAX | Maximum value for NUShort.
N_UINT16_MIN | Minimum value for NUShort.
N_UINT32_MAX | Maximum value for NUInt.
N_UINT32_MIN | Minimum value for NUInt.
N_UINT64_MAX | Maximum value for NULong.
N_UINT64_MIN | Minimum value for NULong.
N_UINT8_MAX | Maximum value for NUInt8.
N_UINT8_MIN | Minimum value for NUInt8.
N_UINT_MAX | Maximum value for NUInt.
N_UINT_MIN | Minimum value for NUInt.
N_ULONG_MAX | Maximum value for NULong.
N_ULONG_MIN | Minimum value for NULong.
N_UNREFERENCED_PARAMETER | Suppresses the warning "unreferenced parameter".
N_UNUSED_VARIABLE | Suppresses the warning "unused variable".
N_USHORT_MAX | Maximum value for NUShort.
N_USHORT_MIN | Minimum value for NUShort.
N_WCHAR_SIZE | Defines the size of Unicode char.


NTypes Unit Structs, Records, Enums

NTypes Unit Structs, Records, Enums
Legend
Structs, Records, Enums
Name | Description
NAttributes_ | Enumerates value attributes.
NComplex_ | Represents a complex number value.
NIndexPair_ | Represents a pair of indexes.
NNameStringPair_ | Represents a pair of name strings.
NOSFamily_ | Enumerates OS families.
NRational_ | Represents a signed rational number.
NURational_ | Represents an unsigned rational number.
NAttributes | Enumerates value attributes.
NOSFamily | Enumerates OS families.


NTypes Unit Types

NTypes Unit Types
Types
Name | Description
NAChar | ANSI character (8-bit).
NBool | Same as NBoolean.
NBoolean | 32-bit boolean value. See also NTrue and NFalse.
NByte | Same as NUInt8.
NChar | ANSI character (8-bit). See also NAChar.
NComplex | Complex number.
NDouble | Double precision floating point number.
NFloat | Same as NSingle.
NHandle | Pointer to unspecified data (same as void *).
NIndexPair | Represents a pair of indexes.
NInt | Same as NInt32.
NInt16 | 16-bit signed integer (short).
NInt32 | 32-bit signed integer (int).
NInt64 | 64-bit signed integer (long). Not available on some 32-bit platforms.
NInt8 | 8-bit signed integer (signed byte).
NLong | Same as NInt64.
NNameStringPair | Two linked strings.
NRational | Represents a signed rational number.
NResult | Result of a function (same as NInt). See also NErrors module.
NSByte | Same as NInt8.
NSSizeType | Platform dependent size type. Signed 32-bit integer on 32-bit platform, signed 64-bit integer on 64-bit platform.
NShort | Same as NInt16.
NSingle | Single precision floating point number.
NSizeType | Platform dependent size type. Unsigned 32-bit integer on 32-bit platform, unsigned 64-bit integer on 64-bit platform.
NUInt | Same as NUInt32.
NUInt16 | 16-bit unsigned integer (unsigned short).
NUInt32 | 32-bit unsigned integer (unsigned int).
NUInt64 | 64-bit unsigned integer (unsigned long). Not available on some 32-bit platforms.
NUInt8 | 8-bit unsigned integer (byte).
NULong | Same as NUInt64.
NURational | Represents an unsigned rational number.
NUShort | Same as NUInt16.
NVersion | Two NInt32 values defining a version.
NVersionRange | Four NInt32 values defining a version range.
NVersionRange_ | A NUInt typedef defining a version range.
NVersion_ | A NUShort typedef defining a version.


NTypes.h Enumerations

NTypes.h Enumerations
Legend
Enumerations
Name | Description
NAttributes_ | Enumerates value attributes.
NOSFamily_ | Enumerates OS families.
NAttributes | Enumerates value attributes.
NOSFamily | Enumerates OS families.


NTypes.h Functions

NTypes.h Functions
Legend
Functions
Name | Description
NACharParseN | Converts a NString to NAChar.
NACharParseStrOrChars | Converts an array of NChars to NAChar.
NACharParseVN | Converts a NString to NAChar.
NACharToChars | Converts NAChar to an array of NAChars.
NACharToString | Converts NAChar to NString
NACharTryParseN | Converts NString to NAChar. A NBool value indicates whether the conversion succeeded.
NACharTryParseStrOrChars | Converts an array of NChars to NAChar. A NBool value indicates whether the conversion succeeded.
NACharTryParseVN | Converts NString to NAChar. A NBool value indicates whether the conversion succeeded.
NBooleanParseN | Converts NString to NBoolean.
NBooleanParseStrOrChars | Converts an array of NChars to NBoolean.
NBooleanParseVN | Converts NString to NBoolean.
NBooleanToChars | Converts NBoolean to an array of NChars.
NBooleanToString | Converts NBoolean to NString.
NBooleanTryParseN | Converts a NString to NBoolean. A NBool value indicates whether the conversion succeeded.
NBooleanTryParseStrOrChars | Converts an array of NStrings or NChars into NBoolean. A NBool value indicates whether the conversion succeeded.
NBooleanTryParseVN | Converts a NString to NBoolean. A NBool value indicates whether the conversion succeeded.
NCharFromBinDigit | Converts a binary digit to NChar.
NCharFromDigit | Converts a digit to NChar.
NCharFromHexDigit | Converts a hexadecimal digit to NChar.
NCharFromOctDigit | Converts an octal digit to NChar.
NCharIsAscii | Checks whether the specified char is ASCII.
NCharIsBinDigit | Checks whether the specified character is a binary digit.
NCharIsDigit | Checks whether the specified character is a digit.
NCharIsHexDigit | Checks whether the specified character is a hexadecimal digit.
NCharIsLetter | Checks whether the specified character is a letter.
NCharIsLower | Checks whether the specified character is a lower value.
NCharIsOctDigit | Checks whether the specified character is an octal digit.
NCharIsUpper | Checks whether the specified character is an upper value.
NCharIsWhiteSpace | Checks whether the specified character is a whitespace.
NCharParseN | Converts a NString to a NChar.
NCharParseStrOrChars | Converts an array of NStrings or NChars into NChar.
NCharParseVN | Converts a NString to a NChar.
NCharToBinDigit | Converts a NChar to a binary digit.
NCharToChars | Converts a NChar into an array of NChars.
NCharToDigit | Converts a NChar to a digit.
NCharToHexDigit | Converts a NChar to a hexadecimal digit.
NCharToLower | Converts a NChar to lowercase.
NCharToOctDigit | Converts a NChar to an octal digit.
NCharToString | Converts NChar to NString.
NCharToUpper | Converts NChar to uppercase.
NCharTryParseN | Converts a NString to a NChar. A NBool value indicates whether the conversion succeeded.
NCharTryParseStrOrChars | Converts an array of NChars into NChar. A NBool value indicates whether the conversion succeeded.
NCharTryParseVN | Converts a NString to a NChar. A NBool value indicates whether the conversion succeeded.
NComplexToString | Converts NComplex to NString.
NDoubleGetNaN | Retrieves a NDouble that is Not a Number (NaN).
NDoubleGetNegativeInfinity | Retrieves a NDouble that is NegativeInfinity.
NDoubleGetPositiveInfinity | Retrieves a NDouble that is PositiveInfinity.
NDoubleIsInfinity | Checks if NDouble evaluates to NegativeInfinity or PositiveInfinity.
NDoubleIsNaN | Checks if NDouble is Not a Number (NaN).
NDoubleIsNegativeInfinity | Checks if NDouble evaluates to NegativeInfinity.
NDoubleIsPositiveInfinity | Checks if NDouble evaluates to PositiveInfinity
NDoubleParseN | Converts a NString into NDouble.
NDoubleParseStrOrChars | Converted an array of NChars to NDouble.
NDoubleParseVN | Converts a NString into NDouble.
NDoubleToChars | Converts NDouble to an array of NChars.
NDoubleToString | Converts NDouble to NString.
NDoubleTryParseN | Converts a NString to NDouble. A NBool value indicates whether the conversion succeeded.
NDoubleTryParseStrOrChars | Converts an array of NChars to NDouble. A NBool value indicates whether the conversion succeeded.
NDoubleTryParseVN | Converts a NString to NDouble. A NBool value indicates whether the conversion succeeded.
NGuidParse | Converts a NChar to NGuid.
NGuidParseVN | Converts a NString to NGuid.
NGuidToString | Converts a NGuid to NString.
NGuidTryParse | Converts a NChar to NGuid. A NBool value indicates whether the conversion succeeded.
NGuidTryParseVN | Converts a NString to NGuid. A NBool value indicates whether the conversion succeeded.
NIndexPairToString | Convertes NIndexPair to NString.
NInt16ParseN | Convertes NString to NInt16.
NInt16ParseStrOrChars | Converts an array of NChars to NInt16.
NInt16ParseVN | Convertes NString to NInt16.
NInt16ToChars | Converts NInt16 to an array of NChars.
NInt16ToString | Converts NInt16 to NString.
NInt16TryParseN | Converts NString to NInt16. A NBool value indicates whether the conversion succeeded.
NInt16TryParseStrOrChars | Converts an array of NChars to NInt16. A NBool value indicates whether the conversion succeeded.
NInt16TryParseVN | Converts NString to NInt16. A NBool value indicates whether the conversion succeeded.
NInt32ParseN | Converts NString to NInt32.
NInt32ParseStrOrChars | Converts an array of NChars to NInt32.
NInt32ParseVN | Converts NString to NInt32.
NInt32ToChars | Converts NInt32 to an array of NChars.
NInt32ToString | Converts NInt32 to NString.
NInt32TryParseN | Converts NString to NInt32. A NBool value indicates whether the conversion succeeded.
NInt32TryParseStrOrChars | Converts an array of NChars to NInt32. A NBool value indicates whether the conversion succeeded.
NInt32TryParseVN | Converts NString to NInt32. A NBool value indicates whether the conversion succeeded.
NInt64ParseN | Converts NString to NInt64.
NInt64ParseStrOrChars | Converts an array of NChars to NInt64.
NInt64ParseVN | Converts NString to NInt64.
NInt64ToChars | Converts NInt64 to an array of NChars.
NInt64ToString | Converts NInt64 to NString.
NInt64TryParseN | Converts NString to NInt64. A NBool value indicates whether the conversion succeeded.
NInt64TryParseStrOrChars | Converts an array of NChars to NInt64. A NBool value indicates whether the conversion succeeded.
NInt64TryParseVN | Converts NString to NInt64. A NBool value indicates whether the conversion succeeded.
NInt8ParseN | Converts NString to NInt8.
NInt8ParseStrOrChars | Converts an array of NChars to NInt8.
NInt8ParseVN | Converts NString to NInt8.
NInt8ToChars | Converts NInt8 to an array of NChars.
NInt8ToString | Converts NInt8 to NString.
NInt8TryParseN | Converts NString to NInt8. A NBool value indicates whether the conversion succeeded.
NInt8TryParseStrOrChars | Converts an array of NChars to NInt8. A NBool value indicates whether the conversion succeeded.
NInt8TryParseVN | Converts NString to NInt8. A NBool value indicates whether the conversion succeeded.
NNameStringPairCopy | Creates a copy of string pair structure.
NNameStringPairCreate | Creates a new string pair structure.
NNameStringPairDispose | Disposes of the specified string pair structure.
NNameStringPairSet | Sets the value of the specified string pair structure.
NOSFamilyGetCurrent | Retrieves the current operating system family.
NPointerParseN | Converts NString to NPointer.
NPointerParseStrOrChars | Converts an array of NChars to NPointer.
NPointerParseVN | Converts NString to NPointer.
NPointerToChars | Converts NPointer to an array of NChars.
NPointerToString | Converts NPointer to NString.
NPointerTryParseN | Converts NString to NPointer. A NBool value indicates whether the conversion succeeded.
NPointerTryParseStrOrChars | Converts an array of NChars to NPointer. A NBool value indicates whether the conversion succeeded.
NPointerTryParseVN | Converts NString to NPointer. A NBool value indicates whether the conversion succeeded.
NRangeToString | Converts NRange to NString.
NRationalToString | Converts NRational to NString.
NResultParseN | Converts NString to NResult.
NResultParseStrOrChars | Converts an array of NChars to NResult.
NResultParseVN | Converts NString to NResult.
NResultToChars | Converts NResult to an array of NChars.
NResultToString | Converts NResult to NString.
NResultTryParseN | Converts NString to NResult. A NBool value indicates whether the conversion succeeded.
NResultTryParseStrOrChars | Converts an array of NChars to NResult. A NBool value indicates whether the conversion succeeded.
NResultTryParseVN | Converts NString to NResult. A NBool value indicates whether the conversion succeeded.
NSSizeTypeParseN | Converts NString to NSSizeType.
NSSizeTypeParseStrOrChars | Converts an array of NChars to NSSizeType.
NSSizeTypeParseVN | Converts NString to NSSizeType.
NSSizeTypeToChars | Converts NSSizeType to an array of NChars.
NSSizeTypeToString | Converts NSSizeType to NString.
NSSizeTypeTryParseN | Converts NString to NSSizeType. A NBool value indicates whether the conversion succeeded.
NSSizeTypeTryParseStrOrChars | Converts an array of NChars to NSSizeType. A NBool value indicates whether the conversion succeeded.
NSSizeTypeTryParseVN | Converts NString to NSSizeType. A NBool value indicates whether the conversion succeeded.
NSingleGetNaN | Retrieves a NSingle that is Not a Number (NaN).
NSingleGetNegativeInfinity | Retrieves a NSingle that is NegativeInfinity.
NSingleGetPositiveInfinity | Retrieves a NSingle that is PositiveInfinity.
NSingleIsInfinity | Checks if NSingle evaluates to NegativeInfinity or PositiveInfinity.
NSingleIsNaN | Checks if NSingle Not a Number (NaN).
NSingleIsNegativeInfinity | Checks if NSingle evaluates to NegativeInfinity.
NSingleIsPositiveInfinity | Checks if NSingle evaluates to PositiveInfinity.
NSingleParseN | Converts NString to NSingle.
NSingleParseStrOrChars | Converts an array of NChars to NSingle.
NSingleParseVN | Converts NString to NSingle.
NSingleToChars | Converts NSingle to an array of NChars.
NSingleToString | Converts NSingle to NString.
NSingleTryParseN | Converts NString to NSingle. A NBool value indicates whether the conversion succeeded.
NSingleTryParseStrOrChars | Converts an array of NChars to NSingle. A NBool value indicates whether the conversion succeeded.
NSingleTryParseVN | Converts NString to NSingle. A NBool value indicates whether the conversion succeeded.
NSizeTypeParseN | Converts NString to NSizeType.
NSizeTypeParseStrOrChars | Converts an array of NChars to NSizeType.
NSizeTypeParseVN | Converts NString to NSizeType.
NSizeTypeToChars | Converts NSizeType to an array of NChars.
NSizeTypeToString | Converts NSizeType to NString.
NSizeTypeTryParseN | Converts NString to NSizeType. A NBool value indicates whether the conversion succeeded.
NSizeTypeTryParseStrOrChars | Converts an array of NChars to NSizeType. A NBool value indicates whether the conversion succeeded.
NSizeTypeTryParseVN | Converts NString to NSizeType. A NBool value indicates whether the conversion succeeded.
NSwapDWordArray | Swaps the element order of the specified array of unsigned integers from little Endian to big Endian, or vice-versa.
NSwapDouble | Swaps the byte order of the specified double value from little Endian to big Endian, or vice-versa.
NSwapDoubleArray | Swaps the element order of the specified array of single values from little Endian to big Endian, or vice-versa.
NSwapQWordArray | Swaps the element order of the specified array of unsigned long integers from little Endian to big Endian, or vice-versa.
NSwapSingle | Swaps the byte order of the specified single value from little Endian to big Endian, or vice-versa.
NSwapSingleArray | Swaps the element order of the specified array of single values from little Endian to big Endian, or vice-versa.
NSwapWordArray | Swaps the element order of the specified array of unsigned short integers from little Endian to big Endian, or vice-versa.
NTypesGetPointer | Retrieves a pointer to object.
NUInt16ParseN | Converts NString to NUInt16.
NUInt16ParseStrOrChars | Converts an array of NChars to NUInt16.
NUInt16ParseVN | Converts NString to NUInt16.
NUInt16ToChars | Converts NUInt16 to an array of NChars.
NUInt16ToString | Converts NUInt16 to NString.
NUInt16TryParseN | Converts NString to NUInt16. A NBool value indicates whether the conversion succeeded.
NUInt16TryParseStrOrChars | Converts an array of NChars to NUInt16. A NBool value indicates whether the conversion succeeded.
NUInt16TryParseVN | Converts NString to NUInt16. A NBool value indicates whether the conversion succeeded.
NUInt32ParseN | Converts NString to NUInt32.
NUInt32ParseStrOrChars | Converts an array of NChars to NUInt32.
NUInt32ParseVN | Converts NString to NUInt32.
NUInt32ToChars | Converts NUInt32 to an array of NChars.
NUInt32ToString | Converts NUInt32 to NString.
NUInt32TryParseN | Converts NString to NUInt32. A NBool value indicates whether the conversion succeeded.
NUInt32TryParseStrOrChars | Converts an array of NChars to NUInt32. A NBool value indicates whether the conversion succeeded.
NUInt32TryParseVN | Converts NString to NUInt32. A NBool value indicates whether the conversion succeeded.
NUInt64ParseN | Converts NString to NUInt64.
NUInt64ParseStrOrChars | Converts an array of NChars to NUInt64.
NUInt64ParseVN | Converts NString to NUInt64.
NUInt64ToChars | Converts NUInt64 to an array of NChars.
NUInt64ToString | Converts NUInt64 to NString.
NUInt64TryParseN | Converts NString to NUInt64. A NBool value indicates whether the conversion succeeded.
NUInt64TryParseStrOrChars | Converts an array of NChars to NUInt64. A NBool value indicates whether the conversion succeeded.
NUInt64TryParseVN | Converts NString to NUInt64. A NBool value indicates whether the conversion succeeded.
NUInt8ParseN | Converts NString to NUInt8.
NUInt8ParseStrOrChars | Converts an array of NChars to NUInt8.
NUInt8ParseVN | Converts NString to NUInt8.
NUInt8ToChars | Converts NUInt8 to an array of NChars.
NUInt8ToString | Converts NUInt8 to NString.
NUInt8TryParseN | Converts NString to NUInt8. A NBool value indicates whether the conversion succeeded.
NUInt8TryParseStrOrChars | Converts an array of NChars to NUInt8. A NBool value indicates whether the conversion succeeded.
NUInt8TryParseVN | Converts NString to NUInt8. A NBool value indicates whether the conversion succeeded.
NURationalToString | Converts NURational to NString.
NVersionRangeContains | Checks if NVersionRange contains a certain version.
NVersionRangeContainsRange | Checks if NVersionRange contains a certain version range.
NVersionRangeIntersect | Replaces NVersionRange with the intersection of itself and another NVersionRange.
NVersionRangeIntersectsWith | Returns third NVersionRange that represents the intersection of two other NVersionRanges. If there is no intersection, an empty NVersionRange is returned.
NVersionRangeToString | Converts NVersionRange to NString.
NVersionToString | Converts NVersion to NString.
NWCharParseN | Converts NString to NWChar.
NWCharParseStrOrChars | Converts an array of NChars to NWChar.
NWCharParseVN | Converts NString to NWChar.
NWCharToChars | Converts NWChar to an array of NChars.
NWCharToString | Converts NWChar to NString.
NWCharTryParseN | Converts NString to NWChar. A NBool value indicates whether the conversion succeeded.
NWCharTryParseStrOrChars | Converts an array of NChars to NWChar. A NBool value indicates whether the conversion succeeded.
NWCharTryParseVN | Converts NString to NWChar. A NBool value indicates whether the conversion succeeded.


Legend

Legend
Legend
Enumeration
Structure
Method


NTypes.h Macros

NTypes.h Macros
Macros
Name | Description
NACharParse | Converts a NString to NAChar.
NACharParseChars | Converts an array of NChars to NAChar.
NACharParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NACharParseStrOrChars function.
NACharParseVN | Picks a Unicode (W) or ASCII (A) version of the NACharParseVN function.
NACharToChars | Picks a Unicode (W) or ASCII (A) version of the NACharToChars function.
NACharToString | Picks a Unicode (W) or ASCII (A) version of the NACharToString function.
NACharTryParse | Converts NString to NAChar. A NBool value indicates whether the conversion succeeded.
NACharTryParseChars | Converts an array of NChars to NAChar. A NBool value indicates whether the conversion succeeded.
NACharTryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NACharTryParseStrOrChars function.
NACharTryParseVN | Picks a Unicode (W) or ASCII (A) version of the NACharTryParseVN function.
NBooleanParse | Converts NString to NBoolean.
NBooleanParseChars | Converts an array of NChars to NBoolean.
NBooleanParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NBooleanParseStrOrChars function.
NBooleanParseVN | Picks a Unicode (W) or ASCII (A) version of the NBooleanParseVN function.
NBooleanToChars | Picks a Unicode (W) or ASCII (A) version of the NBooleanToChars function.
NBooleanToString | Picks a Unicode (W) or ASCII (A) version of the NBooleanToString function.
NBooleanTryParse | Converts NString to NBoolean. A NBool value indicates whether the conversion succeeded.
NBooleanTryParseChars | Converts an array of NChars to NBoolean. A NBool value indicates whether the conversion succeeded.
NBooleanTryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NBooleanTryParseStrOrChars function.
NBooleanTryParseVN | Picks a Unicode (W) or ASCII (A) version of the NBooleanTryParseVN function.
NCharFromBinDigit | Picks a Unicode (W) or ASCII (A) version of the NCharFromBinDigit function.
NCharFromDigit | Picks a Unicode (W) or ASCII (A) version of the NCharFromDigit function.
NCharFromHexDigit | Picks a Unicode (W) or ASCII (A) version of the NCharFromHexDigit function.
NCharFromOctDigit | Picks a Unicode (W) or ASCII (A) version of the NCharFromOctDigit function.
NCharIsAscii | Picks a Unicode (W) or ASCII (A) version of the NCharIsAscii function.
NCharIsBinDigit | Picks a Unicode (W) or ASCII (A) version of the NCharIsBinDigit function.
NCharIsDigit | Picks a Unicode (W) or ASCII (A) version of the NCharIsDigit function.
NCharIsHexDigit | Picks a Unicode (W) or ASCII (A) version of the NCharIsHexDigit function.
NCharIsLetter | Picks a Unicode (W) or ASCII (A) version of the NCharIsLetter function.
NCharIsLower | Picks a Unicode (W) or ASCII (A) version of the NCharIsLower function.
NCharIsOctDigit | Picks a Unicode (W) or ASCII (A) version of the NCharIsOctDigit function.
NCharIsUpper | Picks a Unicode (W) or ASCII (A) version of the NCharIsUpper function.
NCharIsWhiteSpace | Picks a Unicode (W) or ASCII (A) version of the NCharIsWhiteSpace function.
NCharParse | Converts NString to NChar.
NCharParseChars | Converts an array of NChars to NBoolean.
NCharToBinDigit | Picks a Unicode (W) or ASCII (A) version of the NCharToBinDigit function.
NCharToDigit | Picks a Unicode (W) or ASCII (A) version of the NCharToDigit function.
NCharToHexDigit | Picks a Unicode (W) or ASCII (A) version of the NCharToHexDigit function.
NCharToLower | Picks a Unicode (W) or ASCII (A) version of the NCharToLower function.
NCharToOctDigit | Picks a Unicode (W) or ASCII (A) version of the NCharToOctDigit function.
NCharToUpper | Picks a Unicode (W) or ASCII (A) version of the NCharToUpper function.
NCharTryParse | Converts NString to NChar. A NBool value indicates whether the conversion succeeded.
NCharTryParseChars | Converts an array of NChars to NChar. A NBool value indicates whether the conversion succeeded.
NDoubleParse | Converts NString to NDouble.
NDoubleParseChars | Converts an array of NChars to NChar.
NDoubleParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NDoubleParseStrOrChars function.
NDoubleParseVN | Picks a Unicode (W) or ASCII (A) version of the NDoubleParseVN function.
NDoubleToChars | Picks a Unicode (W) or ASCII (A) version of the NDoubleToChars function.
NDoubleToString | Picks a Unicode (W) or ASCII (A) version of the NDoubleToString function.
NDoubleTryParse | Converts NString to NDouble. A NBool value indicates whether the conversion succeeded.
NDoubleTryParseChars | Converts an array of NChars to NDouble. A NBool value indicates whether the conversion succeeded.
NDoubleTryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NDoubleTryParseStrOrChars function.
NDoubleTryParseVN | Picks a Unicode (W) or ASCII (A) version of the NDoubleTryParseVN function.
NFalse | False value for NBoolean.
NGuidParse | Picks a Unicode (W) or ASCII (A) version of the NGuidParse function.
NGuidParseVN | Picks a Unicode (W) or ASCII (A) version of the NGuidParseVN function.
NGuidToString | Picks a Unicode (W) or ASCII (A) version of the NGuidToString function.
NGuidTryParse | Picks a Unicode (W) or ASCII (A) version of the NGuidTryParse function.
NGuidTryParseVN | Picks a Unicode (W) or ASCII (A) version of the NGuidTryParseVN function.
NIndexPairToString | Picks a Unicode (W) or ASCII (A) version of the NIndexPairToString function.
NInt16Parse | Converts NString to NInt16.
NInt16ParseChars | Converts an array of NChars to NInt16.
NInt16ParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NInt16ParseStrOrChars function.
NInt16ParseVN | Picks a Unicode (W) or ASCII (A) version of the NInt16ParseVN function.
NInt16ToChars | Picks a Unicode (W) or ASCII (A) version of the NInt16ToChars function.
NInt16ToString | Picks a Unicode (W) or ASCII (A) version of the NInt16ToString function.
NInt16TryParse | Converts NString to NInt16. A NBool value indicates whether the conversion succeeded.
NInt16TryParseChars | Converts an array of NChars to NInt16. A NBool value indicates whether the conversion succeeded.
NInt16TryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NInt16TryParseStrOrChars function.
NInt16TryParseVN | Picks a Unicode (W) or ASCII (A) version of the NInt16TryParseVN function.
NInt32Parse | Converts NString to NInt32.
NInt32ParseChars | Converts an array of NChars to NInt32.
NInt32ParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NInt32ParseStrOrChars function.
NInt32ParseVN | Picks a Unicode (W) or ASCII (A) version of the NInt32ParseVN function.
NInt32ToChars | Picks a Unicode (W) or ASCII (A) version of the NInt32ToChars function.
NInt32ToString | Picks a Unicode (W) or ASCII (A) version of the NInt32ToString function.
NInt32TryParse | Converts NString to NInt32. A NBool value indicates whether the conversion succeeded.
NInt32TryParseChars | Converts an array of NChars to NInt32. A NBool value indicates whether the conversion succeeded.
NInt32TryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NInt32TryParseStrOrChars function.
NInt32TryParseVN | Picks a Unicode (W) or ASCII (A) version of the NInt32tryParseVN function.
NInt64Parse | Converts NString to NInt64.
NInt64ParseChars | Converts an array of NChars to NInt64.
NInt64ParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NInt64ParseStrOrChars function.
NInt64ParseVN | Picks a Unicode (W) or ASCII (A) version of the NInt64ParseVN function.
NInt64ToChars | Picks a Unicode (W) or ASCII (A) version of the NInt64ToChars function.
NInt64ToString | Picks a Unicode (W) or ASCII (A) version of the NInt64ToString function.
NInt64TryParse | Converts NString to NInt64. A NBool value indicates whether the conversion succeeded.
NInt64TryParseChars | Converts an array of NChars to NInt64. A NBool value indicates whether the conversion succeeded.
NInt64TryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NInt64TryParseStrOrChars function.
NInt64TryParseVN | Picks a Unicode (W) or ASCII (A) version of the NInt64TryParseVN function.
NInt8Parse | Converts NString to NInt8.
NInt8ParseChars | Converts an array of NChars to NInt8.
NInt8ParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NInt8ParseStrOrChars function.
NInt8ParseVN | Picks a Unicode (W) or ASCII (A) version of the NInt8ParseVN function.
NInt8ToChars | Picks a Unicode (W) or ASCII (A) version of the NInt8ToChars function.
NInt8ToString | Picks a Unicode (W) or ASCII (A) version of the NInt8ToString function.
NInt8TryParse | Converts NString to NInt8. A NBool value indicates whether the conversion succeeded.
NInt8TryParseChars | Converts an array of NChars to NInt8. A NBool value indicates whether the conversion succeeded.
NInt8TryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NInt8TryParseStrOrChars function.
NInt8TryParseVN | Picks a Unicode (W) or ASCII (A) version of the NInt8TryParseVN function.
NPointerParse | Converts NString to NPointer.
NPointerParseChars | Converts an array of NChars to NPointer.
NPointerParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NPointerParseStrOrChars function.
NPointerParseVN | Picks a Unicode (W) or ASCII (A) version of the NPointerParseVN function.
NPointerToChars | Picks a Unicode (W) or ASCII (A) version of the NPointerToChars function.
NPointerToString | Picks a Unicode (W) or ASCII (A) version of the NPointerToString function.
NPointerTryParse | Converts NString to NInt8. A NBool value indicates whether the conversion succeeded.
NPointerTryParseChars | Converts an array of NChars to NPointer. A NBool value indicates whether the conversion succeeded.
NPointerTryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NPointerTryParseStrOrChars function.
NPointerTryParseVN | Picks a Unicode (W) or ASCII (A) version of the NPointerTryParseVN function.
NRangeToString | Picks a Unicode (W) or ASCII (A) version of the NRangeToString function.
NRationalToString | Picks a Unicode (W) or ASCII (A) version of the NRationalToString function.
NResultParseVN | Picks a Unicode (W) or ASCII (A) version of the NResultParseVN function.
NResultToChars | Picks a Unicode (W) or ASCII (A) version of the NResultToChars function.
NResultToString | Picks a Unicode (W) or ASCII (A) version of the ResultToString function.
NResultTryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NResultTryParseStrOrChars function.
NResultTryParseVN | Picks a Unicode (W) or ASCII (A) version of the NResultTryParseVN function.
NSSizeTypeParse | Converts NString to NSSizeType.
NSSizeTypeParseChars | Converts an array of NChars to NSSizeType.
NSSizeTypeParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NSSizeTypeParseStrOrChars function.
NSSizeTypeParseVN | Picks a Unicode (W) or ASCII (A) version of the NSSizeTypeParseVN function.
NSSizeTypeToChars | Picks a Unicode (W) or ASCII (A) version of the NSSizeTypeToChars function.
NSSizeTypeToString | Picks a Unicode (W) or ASCII (A) version of the NSSizeTypeToString function.
NSSizeTypeTryParse | Converts NString to NSSizeType. A NBool value indicates whether the conversion succeeded.
NSSizeTypeTryParseChars | Converts an array of NChars to NSSizeType. A NBool value indicates whether the conversion succeeded.
NSSizeTypeTryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NSSizeTypeTryParseStrOrChars function.
NSSizeTypeTryParseVN | Picks a Unicode (W) or ASCII (A) version of the NSSizeTypeTryParseVN function.
NSingleParse | Converts NString to NSingle.
NSingleParseChars | Converts an array of NChars to NSingle.
NSingleParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NSingleParseStrOrChars function.
NSingleParseVN | Picks a Unicode (W) or ASCII (A) version of the NSingleParseVN function.
NSingleToChars | Picks a Unicode (W) or ASCII (A) version of the NSingleToChars function.
NSingleToString | Picks a Unicode (W) or ASCII (A) version of the NSingleToString function.
NSingleTryParse | Converts NString to NSingle. A NBool value indicates whether the conversion succeeded.
NSingleTryParseChars | Converts an array of NChars to NSingle. A NBool value indicates whether the conversion succeeded.
NSingleTryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NSingleTryParseStrOrChars function.
NSingleTryParseVN | Picks a Unicode (W) or ASCII (A) version of the NSingleTryParseVN function.
NSizeTypeParse | Converts NString to NSizeType.
NSizeTypeParseChars | Converts an array of NChars to NSizeType.
NSizeTypeParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NSizeTypeParseStrOrChars function.
NSizeTypeParseVN | Picks a Unicode (W) or ASCII (A) version of the NSizeTypeParseVN function.
NSizeTypeToChars | Picks a Unicode (W) or ASCII (A) version of the NSizeTypeToChars function.
NSizeTypeToString | Picks a Unicode (W) or ASCII (A) version of the NSizeTypeToString function.
NSizeTypeTryParse | Converts NString to NSizeType. A NBool value indicates whether the conversion succeeded.
NSizeTypeTryParseChars | Converts an array of NChars to NSizeType. A NBool value indicates whether the conversion succeeded.
NSizeTypeTryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NSizeTypeTryParseStrOrChars function.
NSizeTypeTryParseVN | Picks a Unicode (W) or ASCII (A) version of the NSizeTypeTryParseVN function.
NTrue | True value for NBoolean.
NUInt16Parse | Converts NString to NUInt16.
NUInt16ParseChars | Converts an array of NChars to NUInt16.
NUInt16ParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NUInt16ParseStrOrChars function.
NUInt16ParseVN | Picks a Unicode (W) or ASCII (A) version of the NUInt16ParseVN function.
NUInt16ToChars | Picks a Unicode (W) or ASCII (A) version of the NUInt16ToChars function.
NUInt16ToString | Picks a Unicode (W) or ASCII (A) version of the NUInt16ParseToString function.
NUInt16TryParse | Converts NString to NUInt16. A NBool value indicates whether the conversion succeeded.
NUInt16TryParseChars | Converts an array of NChars to NUInt16. A NBool value indicates whether the conversion succeeded.
NUInt16TryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NUInt16TryParseStrOrChars function.
NUInt16TryParseVN | Picks a Unicode (W) or ASCII (A) version of the NUInt16TryParseVN function.
NUInt32Parse | Converts NString to NUInt32.
NUInt32ParseChars | Converts an array of NChars to NUInt32.
NUInt32ParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NUInt32ParseStrOrChars function.
NUInt32ParseVN | Picks a Unicode (W) or ASCII (A) version of the NUInt32ParseVN function.
NUInt32ToChars | Picks a Unicode (W) or ASCII (A) version of the NUInt32ToChars function.
NUInt32ToString | Picks a Unicode (W) or ASCII (A) version of the NUInt32ToString function.
NUInt32TryParse | Converts NString to NUInt32. A NBool value indicates whether the conversion succeeded.
NUInt32TryParseChars | Converts an array of NChars to NUInt32. A NBool value indicates whether the conversion succeeded.
NUInt32TryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NUInt32TryParseStrOrChars function.
NUInt32TryParseVN | Picks a Unicode (W) or ASCII (A) version of the NUInt32TryParseVN function.
NUInt64Parse | Converts NString to NUInt64.
NUInt64ParseChars | Converts an array of NChars to NUInt64.
NUInt64ParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NUInt64ParseStrOrChars function.
NUInt64ParseVN | Picks a Unicode (W) or ASCII (A) version of the NUInt64ParseVN function.
NUInt64ToChars | Picks a Unicode (W) or ASCII (A) version of the NUInt64ToChars function.
NUInt64ToString | Picks a Unicode (W) or ASCII (A) version of the NUInt64ToString function.
NUInt64TryParse | Converts NString to NUInt64. A NBool value indicates whether the conversion succeeded.
NUInt64TryParseChars | Converts an array of NChars to NUInt64. A NBool value indicates whether the conversion succeeded.
NUInt64TryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NUInt64TryParseStrOrChars function.
NUInt64TryParseVN | Picks a Unicode (W) or ASCII (A) version of the NUInt64TryParseVN function.
NUInt8Parse | Converts NString to NUInt8.
NUInt8ParseChars | Converts an array of NChars to NUInt8.
NUInt8ParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NUInt8ParseStrOrChars function.
NUInt8ParseVN | Picks a Unicode (W) or ASCII (A) version of the NUInt8ParseVN function.
NUInt8ToChars | Picks a Unicode (W) or ASCII (A) version of the NUInt8ToChars function.
NUInt8ToString | Picks a Unicode (W) or ASCII (A) version of the NUInt8ToString function.
NUInt8TryParse | Converts NString to NUInt8. A NBool value indicates whether the conversion succeeded.
NUInt8TryParseChars | Converts an array of NChars to NUInt8. A NBool value indicates whether the conversion succeeded.
NUInt8TryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NUInt8TryParseStrOrChars function.
NUInt8TryParseVN | Picks a Unicode (W) or ASCII (A) version of the NUInt8TryParseVN function.
NULL | Null value for pointer.
NURationalToString | Picks a Unicode (W) or ASCII (A) version of the NURationalToString function.
NVersionRangeToString | Picks a Unicode (W) or ASCII (A) version of the NVersionRangeToString function.
NVersionToString | Picks a Unicode (W) or ASCII (A) version of the NVersionToString function.
NWCharParse | Converts NString to NWChar.
NWCharParseChars | Converts an array of NChars to NWChar.
NWCharParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NWCharParseStrOrChars function.
NWCharParseVN | Picks a Unicode (W) or ASCII (A) version of the NWCharParseVN function.
NWCharToChars | Picks a Unicode (W) or ASCII (A) version of the NWCharToChars function.
NWCharToString | Picks a Unicode (W) or ASCII (A) version of the NWCharToString function.
NWCharTryParse | Converts NString to NWChar. A NBool value indicates whether the conversion succeeded.
NWCharTryParseChars | Converts an array of NChars to NWChar. A NBool value indicates whether the conversion succeeded.
NWCharTryParseStrOrChars | Picks a Unicode (W) or ASCII (A) version of the NWCharTryParseStrOrChars function.
NWCharTryParseVN | Picks a Unicode (W) or ASCII (A) version of the NWCharTryParseVN function.
N_BOOLEAN_FALSE_STRING | ANSI or Unicode (if N_UNICODE is defined) string, representing NFalse Boolean value.
N_BOOLEAN_FALSE_STRINGA | ANSI string, representing NFalse Boolean value.
N_BOOLEAN_FALSE_STRINGW | Unicode (if N_UNICODE is defined) string, representing NFalse Boolean value.
N_BOOLEAN_TRUE_STRING | ANSI or Unicode (if N_UNICODE is defined) string, representing NTrue Boolean value.
N_BOOLEAN_TRUE_STRINGA | ANSI string, representing NTrue Boolean value.
N_BOOLEAN_TRUE_STRINGW | Unicode (if N_UNICODE is defined) string, representing NTrue Boolean value.
N_BYTE_MAX | Maximum value for NByte.
N_BYTE_MIN | Minimum value for NByte.
N_DECLARE_HANDLE | Declares handle with specified name.
N_DECLARE_HANDLE_TYPE | Declares handle type with specified name.
N_DECLARE_OBJECT_TYPE | Declares object type with specified name.
N_DECLARE_STATIC_OBJECT_TYPE | Declares static object type with specified name.
N_DECLARE_TYPE | Declares type with specified name.
N_DECLATE_PRIMITIVE | Declares primitive with specified name.
N_DOUBLE_EPSILON | Epsilon value for NDouble.
N_DOUBLE_MAX | Maximum value for NDouble.
N_DOUBLE_MIN | Minimum value for NDouble.
N_FLOAT_EPSILON | Epsilon value for NFloat.
N_FLOAT_INFINITY_STRING | ANSI or Unicode (if N_UNICODE is defined) string, representing "Infinity" floating-point value.
N_FLOAT_INFINITY_STRINGA | ANSI string, representing "Infinity" floating-point value.
N_FLOAT_INFINITY_STRINGW | Unicode (if N_UNICODE is defined) string, representing "Infinity" floating-point value.
N_FLOAT_MAX | Maximum value for NFloat.
N_FLOAT_MIN | Minimum value for NFloat.
N_FLOAT_NAN_STRING | ANSI or Unicode (if N_UNICODE is defined) string, representing "NaN" floating-point value.
N_FLOAT_NAN_STRINGA | ANSI string, representing "NaN" floating-point value.
N_FLOAT_NAN_STRINGW | Unicode (if N_UNICODE is defined) string, representing "NaN" floating-point value.
N_INT16_MAX | Maximum value for NShort.
N_INT16_MIN | Minimum value for NShort.
N_INT32_MAX | Maximum value for NInt.
N_INT32_MIN | Minimum value for NInt.
N_INT64_MAX | Maximum value for NInt64.
N_INT64_MIN | Minimum value for NInt64.
N_INT8_MAX | Maximum value for NSByte.
N_INT8_MIN | Minimum value for NSByte.
N_INT_MAX | Maximum value for NInt.
N_INT_MIN | Minimum value for NInt.
N_LONG_MAX | Maximum value for NLong.
N_LONG_MIN | Minimum value for NLong.
N_PTR_SIZE | Defines pointer size.
N_SBYTE_MAX | Maximum value for NSByte.
N_SBYTE_MIN | Minimum value for NSByte.
N_SHORT_MAX | Maximum value for NShort.
N_SHORT_MIN | Minimum value for NShort.
N_SINGLE_EPSILON | Epsilon value for NSingle.
N_SINGLE_MAX | Maximum value for NSingle.
N_SINGLE_MIN | Minimum value for NSingle.
N_SIZE_TYPE_MAX | Maximum value for NSizeType.
N_SIZE_TYPE_MIN | Minimum value for NSizeType.
N_SSIZE_TYPE_MAX | Maximum value for NSSizeType.
N_SSIZE_TYPE_MIN | Minimum value for NSSizeType.
N_TYPE_OF | Used to obtain a pointer to the function that retrieves NType object for the specified type name.",
N_UINT16_MAX | Maximum value for NUShort.
N_UINT16_MIN | Minimum value for NUShort.
N_UINT32_MAX | Maximum value for NUInt.
N_UINT32_MIN | Minimum value for NUInt.
N_UINT64_MAX | Maximum value for NULong.
N_UINT64_MIN | Minimum value for NULong.
N_UINT8_MAX | Maximum value for NUInt8.
N_UINT8_MIN | Minimum value for NUInt8.
N_UINT_MAX | Maximum value for NUInt.
N_UINT_MIN | Minimum value for NUInt.
N_ULONG_MAX | Maximum value for NULong.
N_ULONG_MIN | Minimum value for NULong.
N_UNREFERENCED_PARAMETER | Suppresses the warning "unreferenced parameter".
N_UNUSED_VARIABLE | Suppresses the warning "unused variable".
N_USHORT_MAX | Maximum value for NUShort.
N_USHORT_MIN | Minimum value for NUShort.
N_WCHAR_SIZE | Defines the size of Unicode char.


NTypes.h Structures

NTypes.h Structures
Legend
Structures
Name | Description
NComplex_ | Represents a complex number value.
NIndexPair_ | Represents a pair of indexes.
NNameStringPair_ | Represents a pair of name strings.
NRational_ | Represents a signed rational number.
NURational_ | Represents an unsigned rational number.


NTypes.h Types

NTypes.h Types
Types
Name | Description
NAChar | ANSI character (8-bit).
NBool | Same as NBoolean.
NBoolean | 32-bit boolean value. See also NTrue and NFalse.
NByte | Same as NUInt8.
NChar | ANSI character (8-bit). See also NAChar.
NComplex | Complex number.
NDouble | Double precision floating point number.
NFloat | Same as NSingle.
NHandle | Pointer to unspecified data (same as void *).
NIndexPair | Represents a pair of indexes.
NInt | Same as NInt32.
NInt16 | 16-bit signed integer (short).
NInt32 | 32-bit signed integer (int).
NInt64 | 64-bit signed integer (long). Not available on some 32-bit platforms.
NInt8 | 8-bit signed integer (signed byte).
NLong | Same as NInt64.
NNameStringPair | Two linked strings.
NRational | Represents a signed rational number.
NResult | Result of a function (same as NInt). See also NErrors module.
NSByte | Same as NInt8.
NSSizeType | Platform dependent size type. Signed 32-bit integer on 32-bit platform, signed 64-bit integer on 64-bit platform.
NShort | Same as NInt16.
NSingle | Single precision floating point number.
NSizeType | Platform dependent size type. Unsigned 32-bit integer on 32-bit platform, unsigned 64-bit integer on 64-bit platform.
NUInt | Same as NUInt32.
NUInt16 | 16-bit unsigned integer (unsigned short).
NUInt32 | 32-bit unsigned integer (unsigned int).
NUInt64 | 64-bit unsigned integer (unsigned long). Not available on some 32-bit platforms.
NUInt8 | 8-bit unsigned integer (byte).
NULong | Same as NUInt64.
NURational | Represents an unsigned rational number.
NUShort | Same as NUInt16.
NVersion | Two NInt32 values defining a version.
NVersionRange | Four NInt32 values defining a version range.
NVersionRange_ | A NUInt typedef defining a version range.
NVersion_ | A NUShort typedef defining a version.


NValue Unit Files

NValue Unit Files
Files
Name | Description
NValue.h | Header file for the NValue unit.


NValue Unit Functions

NValue Unit Functions
Legend
Functions
Name | Description
NKeyValuePairCopy | Creates a copy of the specified key value pair structure.
NKeyValuePairCreate | Creates a new key value pair structure.
NKeyValuePairDispose | Disposes of the specified key value pair structure.
NKeyValuePairSet | Sets the value of the specified key value pair structure.
NNameValuePairCopy | Creates a copy of the specified name value pair structure.
NNameValuePairCreate | Creates a new name value pair structure.
NNameValuePairDispose | Disposes of the specified name value pair structure.
NNameValuePairSet | Sets the value of the specified name value pair structure.
NValueChangeType | Changes the type of the specified value to the new type.
NValueChangeTypeP | Changes the type of the specified value to the new type.
NValueCreate | Creates a new value of the specified type.
NValueCreateCustom | Creates a new value with specified callbacks.
NValueCreateCustomN | Creates a new value with specified callbacks.
NValueCreateFromBoolean | Creates a new value from the specified Boolean value.
NValueCreateFromByte | Creates a new value from the specified byte.
NValueCreateFromCallback | Creates a new value from specified callback.
NValueCreateFromChar | Creates a new value from the specified char.
NValueCreateFromDouble | Creates a new value from the specified double value.
NValueCreateFromInt16 | Creates a new value from the specified short integer.
NValueCreateFromInt32 | Creates a new value from the specified integer.
NValueCreateFromInt64 | Creates a new value from the specified long integer.
NValueCreateFromObject | Creates a new value from the specified object.
NValueCreateFromObjectP | Creates a new value from the specified object.
NValueCreateFromPointer | Creates a new value from the specified pointer.
NValueCreateFromResult | Creates a new value from the specified NResult value.
NValueCreateFromSByte | Creates a new value from the specified signed byte.
NValueCreateFromSSizeType | Creates a new value from the specified NSSizeType value.
NValueCreateFromSingle | Creates a new value from the specified floating point value.
NValueCreateFromSizeType | Creates a new value from the specified NSizeType value.
NValueCreateFromString | Creates a new value from the specified string.
NValueCreateFromUInt16 | Creates a new value from the specified unsigned short integer.
NValueCreateFromUInt32 | Creates a new value from the specified unsigned integer.
NValueCreateFromUInt64 | Creates a new value from the specified unsigned long integer.
NValueCreateP | Creates a new value of the specified type.
NValueGetAttributes | Retrieves the attributes of the specified value.
NValueGetFree | Frees the specified value.
NValueGetPtr | Retrieves a pointer to the specified value.
NValueGetSize | Retrieves the size of the specified value.
NValueGetTypeCode | Retrieves the type code of the specified value.
NValueGetValueType | Retrieves the type of the specified value.
NValueSet | Sets the specified value.
NValueSetP | Sets the specified value.
NValueToBoolean | Converts the specified value into a Boolean value.
NValueToByte | Converts the specified value into a byte.
NValueToCallback | Converts the specified value into a callback.
NValueToChar | Converts the specified value into a char.
NValueToDouble | Converts the specified value into a double value.
NValueToInt16 | Converts the specified value into a short integer.
NValueToInt32 | Converts the specified value to into integer.
NValueToInt64 | Converts the specified value into a long value.
NValueToObject | Converts the specified value into an object.
NValueToObjectP | Converts the specified value into an object.
NValueToPointer | Converts the specified value into a pointer.
NValueToResult | Converts the specified value into a NResult value.
NValueToSByte | Converts the specified value into a signed byte.
NValueToSSizeType | Converts the specified value into a NSSizeType value.
NValueToSingle | Converts the specified value into a floating point value.
NValueToSizeType | Converts the specified value into a NSizeType value.
NValueToString | Converts the specified value into a string.
NValueToUInt16 | Converts the specified value into an unsigned short integer.
NValueToUInt32 | Converts the specified value into an unsigned integer.
NValueToUInt64 | Converts the specified value into an unsigned long integer.
NValueToValue | Converts the specified value into a value of the specified type.
NValueToValueP | Converts the specified value into a value of the specified type.


NValue Unit Macros

NValue Unit Macros
Macros
Name | Description
NNameValuePairCreate | Picks a Unicode (W) or ASCII (A) version of the NNameValuePairCreate function.
NValueCreateFromChar | Picks a Unicode (W) or ASCII (A) version of the NValueCreateFromChar function.
NValueCreateFromString | Picks a Unicode (W) or ASCII (A) version of the NValueCreateFromString function.
NValueToChar | Picks a Unicode (W) or ASCII (A) version of the NValueToChar function.


NValue Unit Structs, Records, Enums

NValue Unit Structs, Records, Enums
Legend
Structs, Records, Enums
Name | Description
NKeyValuePair_ | Represents the key value pair structure.
NNameValuePair_ | Represents the name key value pair structure.


NValue.h Functions

NValue.h Functions
Legend
Functions
Name | Description
NKeyValuePairCopy | Creates a copy of the specified key value pair structure.
NKeyValuePairCreate | Creates a new key value pair structure.
NKeyValuePairDispose | Disposes of the specified key value pair structure.
NKeyValuePairSet | Sets the value of the specified key value pair structure.
NNameValuePairCopy | Creates a copy of the specified name value pair structure.
NNameValuePairCreate | Creates a new name value pair structure.
NNameValuePairDispose | Disposes of the specified name value pair structure.
NNameValuePairSet | Sets the value of the specified name value pair structure.
NValueChangeType | Changes the type of the specified value to the new type.
NValueChangeTypeP | Changes the type of the specified value to the new type.
NValueCreate | Creates a new value of the specified type.
NValueCreateCustom | Creates a new value with specified callbacks.
NValueCreateCustomN | Creates a new value with specified callbacks.
NValueCreateFromBoolean | Creates a new value from the specified Boolean value.
NValueCreateFromByte | Creates a new value from the specified byte.
NValueCreateFromCallback | Creates a new value from specified callback.
NValueCreateFromChar | Creates a new value from the specified char.
NValueCreateFromDouble | Creates a new value from the specified double value.
NValueCreateFromInt16 | Creates a new value from the specified short integer.
NValueCreateFromInt32 | Creates a new value from the specified integer.
NValueCreateFromInt64 | Creates a new value from the specified long integer.
NValueCreateFromObject | Creates a new value from the specified object.
NValueCreateFromObjectP | Creates a new value from the specified object.
NValueCreateFromPointer | Creates a new value from the specified pointer.
NValueCreateFromResult | Creates a new value from the specified NResult value.
NValueCreateFromSByte | Creates a new value from the specified signed byte.
NValueCreateFromSSizeType | Creates a new value from the specified NSSizeType value.
NValueCreateFromSingle | Creates a new value from the specified floating point value.
NValueCreateFromSizeType | Creates a new value from the specified NSizeType value.
NValueCreateFromString | Creates a new value from the specified string.
NValueCreateFromUInt16 | Creates a new value from the specified unsigned short integer.
NValueCreateFromUInt32 | Creates a new value from the specified unsigned integer.
NValueCreateFromUInt64 | Creates a new value from the specified unsigned long integer.
NValueCreateP | Creates a new value of the specified type.
NValueGetAttributes | Retrieves the attributes of the specified value.
NValueGetFree | Frees the specified value.
NValueGetPtr | Retrieves a pointer to the specified value.
NValueGetSize | Retrieves the size of the specified value.
NValueGetTypeCode | Retrieves the type code of the specified value.
NValueGetValueType | Retrieves the type of the specified value.
NValueSet | Sets the specified value.
NValueSetP | Sets the specified value.
NValueToBoolean | Converts the specified value into a Boolean value.
NValueToByte | Converts the specified value into a byte.
NValueToCallback | Converts the specified value into a callback.
NValueToChar | Converts the specified value into a char.
NValueToDouble | Converts the specified value into a double value.
NValueToInt16 | Converts the specified value into a short integer.
NValueToInt32 | Converts the specified value to into integer.
NValueToInt64 | Converts the specified value into a long value.
NValueToObject | Converts the specified value into an object.
NValueToObjectP | Converts the specified value into an object.
NValueToPointer | Converts the specified value into a pointer.
NValueToResult | Converts the specified value into a NResult value.
NValueToSByte | Converts the specified value into a signed byte.
NValueToSSizeType | Converts the specified value into a NSSizeType value.
NValueToSingle | Converts the specified value into a floating point value.
NValueToSizeType | Converts the specified value into a NSizeType value.
NValueToString | Converts the specified value into a string.
NValueToUInt16 | Converts the specified value into an unsigned short integer.
NValueToUInt32 | Converts the specified value into an unsigned integer.
NValueToUInt64 | Converts the specified value into an unsigned long integer.
NValueToValue | Converts the specified value into a value of the specified type.
NValueToValueP | Converts the specified value into a value of the specified type.


NValue.h Macros

NValue.h Macros
Macros
Name | Description
NNameValuePairCreate | Picks a Unicode (W) or ASCII (A) version of the NNameValuePairCreate function.
NValueCreateFromChar | Picks a Unicode (W) or ASCII (A) version of the NValueCreateFromChar function.
NValueCreateFromString | Picks a Unicode (W) or ASCII (A) version of the NValueCreateFromString function.
NValueToChar | Picks a Unicode (W) or ASCII (A) version of the NValueToChar function.


NValue.h Structures

NValue.h Structures
Legend
Structures
Name | Description
NKeyValuePair_ | Represents the key value pair structure.
NNameValuePair_ | Represents the name key value pair structure.


NWaitObject Unit Functions

NWaitObject Unit Functions
Legend
Functions
Name | Description
NWaitObjectWaitFor | Waits (blocks the calling thread) until the specified object is in signalled state (for example NMutex is not owned by any threads).
NWaitObjectWaitForTimed | Waits (blocks the calling thread) until the specified object is in signalled state or timeout expires.


NWaitObject Unit Macros

NWaitObject Unit Macros
Macros
Name | Description
N_INFINITE | Constant to be used as infinite time value (for example in NWaitObjectTimedWaitFor function).


NWindows Unit Files

NWindows Unit Files
Files
Name | Description
NWindows.h | Header file for the NWindows unit.


NBiometricDevice Unit Files

NBiometricDevice Unit Files
Files
Name | Description
NBiometricDevice.h | Header file for the NBiometricDevice module.


NBiometricDevice Unit Functions

NBiometricDevice Unit Functions
Legend
Functions
Name | Description
NBiometricDeviceAddCapturePreview | Adds a "capture preview" event to the specified biometric device.
NBiometricDeviceAddCapturePreviewCallback | Adds a "capture preview" event callback to the specified biometric device.
NBiometricDeviceCancel | Cancels (stops) current capture operation of NBiometricDevice (NFScanner or NIrisScanner).
NBiometricDeviceCapture | The biometric devices starts capturing biometric data.
NBiometricDeviceEndSequence | Ends multiple images capturing sequence.
NBiometricDeviceGetBiometricType | Gets biometric types supported by specified device.
NBiometricDeviceGetProductId | Gets device Id.
NBiometricDeviceGetSpoofDetection | Checks if the device is set to detect spoof objects.
NBiometricDeviceGetVendorId | Gets device vendor Id.
NBiometricDeviceIsSpoofDetectionSupported | Checks if the device is capable to detect spoof objects.
NBiometricDeviceRemoveCapturePreview | Removes a "capture preview" event from the specified biometric device.
NBiometricDeviceRemoveCapturePreviewCallback | Removes a "capture preview" event callback from the specified biometric device.
NBiometricDeviceSetSpoofDetection | Sets the device to detect spoof objects.
NBiometricDeviceStartSequence | Starts sequence which prepares device for multiple capture operations.


See Also

See Also
See Also

NBiometricDeviceStartSequence


NBiometricDevice.h Functions

NBiometricDevice.h Functions
Legend
Functions
Name | Description
NBiometricDeviceAddCapturePreview | Adds a "capture preview" event to the specified biometric device.
NBiometricDeviceAddCapturePreviewCallback | Adds a "capture preview" event callback to the specified biometric device.
NBiometricDeviceCancel | Cancels (stops) current capture operation of NBiometricDevice (NFScanner or NIrisScanner).
NBiometricDeviceCapture | The biometric devices starts capturing biometric data.
NBiometricDeviceEndSequence | Ends multiple images capturing sequence.
NBiometricDeviceGetBiometricType | Gets biometric types supported by specified device.
NBiometricDeviceGetProductId | Gets device Id.
NBiometricDeviceGetSpoofDetection | Checks if the device is set to detect spoof objects.
NBiometricDeviceGetVendorId | Gets device vendor Id.
NBiometricDeviceIsSpoofDetectionSupported | Checks if the device is capable to detect spoof objects.
NBiometricDeviceRemoveCapturePreview | Removes a "capture preview" event from the specified biometric device.
NBiometricDeviceRemoveCapturePreviewCallback | Removes a "capture preview" event callback from the specified biometric device.
NBiometricDeviceSetSpoofDetection | Sets the device to detect spoof objects.
NBiometricDeviceStartSequence | Starts sequence which prepares device for multiple capture operations.


NCamera Unit Functions

NCamera Unit Functions
Legend
Functions
Name | Description
NCameraAddStillCaptured | Adds user specified callback (controlling captured still image event) to NCamera.
NCameraAddStillCapturedCallback | ... more
NCameraCaptureStill | Gets still image from capture device (camera).
NCameraFocus | Adjusts camera focus.
NCameraGetCurrentStillFormat | Gets current still image format.
NCameraGetFocusRegion | Gets coordinates of rectangular camera focus area.
NCameraGetFrame | Gets current frame from the capture device.
NCameraGetFrameEx | Gets current frame from the capture device.
NCameraGetStillFormats | Gets still image formats supported by specified camera.
NCameraGetVideoSample | Gets video sample from the capture device.
NCameraIsFocusRegionSupported | Checks if focus region is supported on specified camera.
NCameraIsFocusSupported | Checks if specified camera supports autofocus.
NCameraIsStillCaptureSupported | Checks if still image obtain from camera is supported.
NCameraIsVideoSampleSupported | Checks whether video sample is supported.
NCameraRemoveStillCaptured | Removed user specified callback (controlling captured still image event) to NCamera.
NCameraRemoveStillCapturedCallback | ... more
NCameraResetFocus | Resets camera focus.
NCameraSetCurrentStillFormat | Sets current still image format.
NCameraSetFocusRegion | Sets coordinates of rectangular camera focus area.


NCamera Unit Structs, Records, Enums

NCamera Unit Structs, Records, Enums
Legend
Structs, Records, Enums
Name | Description
NCameraStatus_ | Enumerates camera status values.
NCameraStatus | Enumerates camera status values.


See Also

See Also
See Also

NCameraRemoveStillCapturedCallback


NCaptureDevice Unit Functions

NCaptureDevice Unit Functions
Legend
Functions
Name | Description
NCaptureDeviceAddIsCapturingChanged | Adds user specified callback (controlling capturing changed event) to NCaptureDevice.
NCaptureDeviceAddIsCapturingChangedCallback | Adds user specified callback (controlling capturing changed event) to NCaptureDevice.
NCaptureDeviceGetCurrentFormat | Gets current media format of the capture device.
NCaptureDeviceGetFormats | Gets all supported formats by the capture device.
NCaptureDeviceGetMediaType | Gets device media type.
NCaptureDeviceIsCapturing | Checks if the device is capturing.
NCaptureDeviceRemoveIsCapturingChanged | Removes user specified callback (controlling capturing changed event) from NCaptureDevice.
NCaptureDeviceRemoveIsCapturingChangedCallback | Removes user specified callback (controlling capturing changed event) from NCaptureDevice.
NCaptureDeviceSetCurrentFormat | Sets current media format for the capture device.
NCaptureDeviceStartCapturing | Starts capturing.
NCaptureDeviceStopCapturing | Stops capturing.


See Also

See Also
See Also

See NMediaFormat unit for more information on how to retrieve information about media format from handle.


NDevice Unit Files

NDevice Unit Files
Files
Name | Description
NDevice.h | Header file for NDevice Module.


NDevice Unit Functions

NDevice Unit Functions
Legend
Functions
Name | Description
NDeviceGetChild | Returns the child of the specified multimodal device.
NDeviceGetChildCount | Returns the child count of specified multimodal device.
NDeviceGetChildren | Gets all children of the specified multimodal device.
NDeviceGetDeviceType | Returns the type of specified multimodal device.
NDeviceGetDisplayNameN | Returns device name.
NDeviceGetIdN | Returns device Id,
NDeviceGetMakeN | Returns the manufacturer of the specified device.
NDeviceGetModelN | Returns model of current biometric device..
NDeviceGetParent | Returns the parent of specified multimodal device module.
NDeviceGetPlugin | Returns handle to device plugin.
NDeviceGetSerialNumberN | Returns serial number of current biometric device..
NDeviceIsAvailable | Checks if the device is available.
NDeviceIsDisconnectable | Checks if specified device can be disconnected.
NDeviceIsPrivate | Checks whether the specified device is private.


NDevice Unit Structs, Records, Enums

NDevice Unit Structs, Records, Enums
Legend
Structs, Records, Enums
Name | Description
NDeviceType_ | Enumerates device type values.
NDeviceType | Enumerates device type values.


NDevice.h Enumerations

NDevice.h Enumerations
Legend
Enumerations
Name | Description
NDeviceType_ | Enumerates device type values.
NDeviceType | Enumerates device type values.


NDevice.h Functions

NDevice.h Functions
Legend
Functions
Name | Description
NDeviceGetChild | Returns the child of the specified multimodal device.
NDeviceGetChildCount | Returns the child count of specified multimodal device.
NDeviceGetChildren | Gets all children of the specified multimodal device.
NDeviceGetDeviceType | Returns the type of specified multimodal device.
NDeviceGetDisplayNameN | Returns device name.
NDeviceGetIdN | Returns device Id,
NDeviceGetMakeN | Returns the manufacturer of the specified device.
NDeviceGetModelN | Returns model of current biometric device..
NDeviceGetParent | Returns the parent of specified multimodal device module.
NDeviceGetPlugin | Returns handle to device plugin.
NDeviceGetSerialNumberN | Returns serial number of current biometric device..
NDeviceIsAvailable | Checks if the device is available.
NDeviceIsDisconnectable | Checks if specified device can be disconnected.
NDeviceIsPrivate | Checks whether the specified device is private.


NDeviceEventDescriptor Unit Files

NDeviceEventDescriptor Unit Files
Files
Name | Description
NDeviceEventDescriptor.h | Header file for the NDeviceEventDescriptor module.


NDeviceEventDescriptor Unit Functions

NDeviceEventDescriptor Unit Functions
Legend
Functions
Name | Description
NDeviceEventDescriptorCreate | Creates a new device event descriptor.


NDeviceEventDescriptor.h Functions

NDeviceEventDescriptor.h Functions
Legend
Functions
Name | Description
NDeviceEventDescriptorCreate | Creates a new device event descriptor.


NDeviceManager Unit Files

NDeviceManager Unit Files
Files
Name | Description
NDeviceManager.h | Header file for NDeviceManager library. Provides general functions for working with devices.


NDeviceManager Unit Functions

NDeviceManager Unit Functions
Legend
Functions
Name | Description
NDeviceManagerAddDevicesCollectionChanged | Adds a user specified "collection changed" event to NDeviceManager.
NDeviceManagerAddDevicesCollectionChangedCallback | Adds a user specified "collection changed" event callback to NDeviceManager.
NDeviceManagerConnectToDevice | Connects the device manager to a device.
NDeviceManagerConnectToDeviceWithString | Connects the device manager to a device.
NDeviceManagerCreateEx | Creates a new NDeviceManager.
NDeviceManagerDisconnectFromDevice | Disconnects the device manager from the specified device.
NDeviceManagerGetAutoPlug | Checks if a device can be auto-plugged to device manager.
NDeviceManagerGetBiometricEngine | Retrieves the biometric engine used by the specified device manager.
NDeviceManagerGetConnectToDeviceParameters | Retrieves device connection parameters.
NDeviceManagerGetDevice | Retrieves device by specified index.
NDeviceManagerGetDeviceById | Retrieves device by specified Id.
NDeviceManagerGetDeviceCount | Retrieves the count of connected devices.
NDeviceManagerGetDeviceTypes | Returns supported device types by specified NDeviceManager.
NDeviceManagerGetDevices | Retrieves all devices connected to the device manager.
NDeviceManagerGetPluginManager | Returns handle to NPluginManager.
NDeviceManagerInitialize | Initializes the specified device manager.
NDeviceManagerIsConnectToDeviceSupported | Checks whether specified device connection is supported.
NDeviceManagerIsInitialized | Checks whether the specialized device manager is initialized.
NDeviceManagerRemoveDevicesCollectionChanged | Removes a user specified "collection changed" event to NDeviceManager.
NDeviceManagerRemoveDevicesCollectionChangedCallback | Removes a user specified "collection changed" event callback to NDeviceManager.
NDeviceManagerSetAutoPlug | Sets if a device can be auto-plugged to device manager.
NDeviceManagerSetBiometricEngine | Sets the biometric engine used by the specified manager.
NDeviceManagerSetDeviceTypes | Sets the device type for the specified device manager.


NDeviceManager Unit Macros

NDeviceManager Unit Macros
Macros
Name | Description
NDeviceManagerGetDeviceById | Picks a Unicode (W) or ANSCII (A) version of the NDeviceManagerGetDeviceById function.


NDeviceManager.h Functions

NDeviceManager.h Functions
Legend
Functions
Name | Description
NDeviceManagerAddDevicesCollectionChanged | Adds a user specified "collection changed" event to NDeviceManager.
NDeviceManagerAddDevicesCollectionChangedCallback | Adds a user specified "collection changed" event callback to NDeviceManager.
NDeviceManagerConnectToDevice | Connects the device manager to a device.
NDeviceManagerConnectToDeviceWithString | Connects the device manager to a device.
NDeviceManagerCreateEx | Creates a new NDeviceManager.
NDeviceManagerDisconnectFromDevice | Disconnects the device manager from the specified device.
NDeviceManagerGetAutoPlug | Checks if a device can be auto-plugged to device manager.
NDeviceManagerGetBiometricEngine | Retrieves the biometric engine used by the specified device manager.
NDeviceManagerGetConnectToDeviceParameters | Retrieves device connection parameters.
NDeviceManagerGetDevice | Retrieves device by specified index.
NDeviceManagerGetDeviceById | Retrieves device by specified Id.
NDeviceManagerGetDeviceCount | Retrieves the count of connected devices.
NDeviceManagerGetDeviceTypes | Returns supported device types by specified NDeviceManager.
NDeviceManagerGetDevices | Retrieves all devices connected to the device manager.
NDeviceManagerGetPluginManager | Returns handle to NPluginManager.
NDeviceManagerInitialize | Initializes the specified device manager.
NDeviceManagerIsConnectToDeviceSupported | Checks whether specified device connection is supported.
NDeviceManagerIsInitialized | Checks whether the specialized device manager is initialized.
NDeviceManagerRemoveDevicesCollectionChanged | Removes a user specified "collection changed" event to NDeviceManager.
NDeviceManagerRemoveDevicesCollectionChangedCallback | Removes a user specified "collection changed" event callback to NDeviceManager.
NDeviceManagerSetAutoPlug | Sets if a device can be auto-plugged to device manager.
NDeviceManagerSetBiometricEngine | Sets the biometric engine used by the specified manager.
NDeviceManagerSetDeviceTypes | Sets the device type for the specified device manager.


NDeviceManager.h Macros

NDeviceManager.h Macros
Macros
Name | Description
NDeviceManagerGetDeviceById | Picks a Unicode (W) or ANSCII (A) version of the NDeviceManagerGetDeviceById function.


NDeviceMethodDescriptor Unit Files

NDeviceMethodDescriptor Unit Files
Files
Name | Description
NDeviceMethodDescriptor.h | Header file for the NDeviceMethodDescriptor module.


NDeviceMethodDescriptor Unit Functions

NDeviceMethodDescriptor Unit Functions
Legend
Functions
Name | Description
NDeviceMethodDescriptorCreate | Creates a new device method descriptor.


NDeviceMethodDescriptor.h Functions

NDeviceMethodDescriptor.h Functions
Legend
Functions
Name | Description
NDeviceMethodDescriptorCreate | Creates a new device method descriptor.


NDevicePropertyDescriptor Unit Files

NDevicePropertyDescriptor Unit Files
Files
Name | Description
NDevicePropertyDescriptor.h | Header file for the NDevicePropertyDescriptor module.


NDevicePropertyDescriptor Unit Functions

NDevicePropertyDescriptor Unit Functions
Legend
Functions
Name | Description
NDevicePropertyDescriptorCreate | Creates a new device property descriptor.


NDevicePropertyDescriptor.h Functions

NDevicePropertyDescriptor.h Functions
Legend
Functions
Name | Description
NDevicePropertyDescriptorCreate | Creates a new device property descriptor.


NLicense Unit Files

NLicense Unit Files
Files
Name | Description
NLicense.h | Header file for the NLicense library. Provides internal license functionality.


NLicense Unit Functions

NLicense Unit Functions
Legend
Functions
Name | Description
NLicenseActivateOnline | ... more
NLicenseAdd | Adds the activated license content (the content of *.lic file) to be used in application.
NLicenseDeactivateOnline | ... more
NLicenseDeactivateOnlineWithId | ... more
NLicenseGenerateDeactivationId | Generates deactivation Id for specified provided product on current computer.
NLicenseGenerateDeactivationIdForLicense | Generates deactivation Id for specified license on current computer.
NLicenseGenerateId | Generates Id for activation from serial number for a particular machine.
NLicenseGetLicenseInfoOnline | Retrieves info online about specified license.
NLicenseGetObtainedComponentStatus | Gets licensing status for obtained component.
NLicenseGetObtainedLicenseInfo | Retrieves information about obtained license.
NLicenseGetObtainedLicenseInfoForComponent | Retrieves information about obtained license for component.
NLicenseGetObtainedStatus | Gets licensing status for the specified product.
NLicenseIsComponentActivated | Checks if component specified by name is activated.
NLicenseObtain | Obtains product license from the specified server.
NLicenseObtainComponents | Obtains component license from the specified server.
NLicenseRelease | Releases license.
NLicenseReleaseComponents | Releases component license.


NLicense Unit Macros

NLicense Unit Macros
Macros
Name | Description
NLicenseActivateOnline | Picks a Unicode (W) or ANSCII (A) version of the NLicenseActivateOnline function.
NLicenseAdd | Picks a Unicode (W) or ANSCII (A) version of the NLicenseAdd function.
NLicenseDeactivateOnline | Picks a Unicode (W) or ANSCII (A) version of the NLicenseDeactivateOnline function.
NLicenseDeactivateOnlineWithId | Picks a Unicode (W) or ANSCII (A) version of the NLicenseDeactivateOnlineWithId function.
NLicenseGenerateDeactivationId | Picks a Unicode (W) or ANSCII (A) version of the NLicenseGenerateDeactivationId function.
NLicenseGenerateDeactivationIdForLicense | Picks a Unicode (W) or ANSCII (A) version of the NLicenseGenerateDeactivationIdForLicense function.
NLicenseGenerateId | Picks a Unicode (W) or ANSCII (A) version of the NLicenseGenerateId function.
NLicenseGetLicenseInfoOnline | Picks a Unicode (W) or ANSCII (A) version of the NLicenseGetLicenseInfoOnline function.
NLicenseGetObtainedComponentStatus | Picks a Unicode (W) or ANSCII (A) version of the NLicenseGetObtainedComponentStatus function.
NLicenseGetObtainedLicenseInfo | Picks a Unicode (W) or ANSCII (A) version of the NLicenseGetObtainedLicenseInfo function.
NLicenseGetObtainedLicenseInfoForComponent | Picks a Unicode (W) or ANSCII (A) version of the NLicenseGetObtainedLicenseInfoForComponent function.
NLicenseGetObtainedStatus | Picks a Unicode (W) or ANSCII (A) version of the NLicenseGetObtainedStatus function.
NLicenseIsComponentActivated | Picks a Unicode (W) or ANSCII (A) version of the NLicenseIsComponentActivated function.
NLicenseObtainComponents | Picks a Unicode (W) or ANSCII (A) version of the NLicenseObtainComponents function.
NLicenseReleaseComponents | Picks a Unicode (W) or ANSCII (A) version of the NLicenseReleaseComponents function.


NLicense Unit Structs, Records, Enums

NLicense Unit Structs, Records, Enums
Legend
Structs, Records, Enums
Name | Description
NLicenseObtainedStatus_ | Enumerates licensing status values.
NLicenseObtainedStatus | Enumerates licensing status values.


Example

Example
Copy Code
NChar * szSerial = N_T("3502-266E-60C6-6738-7D1C-3872-5AD8-3C42");
NChar * szId = NULL;
NGenerateId(N_T("d:\\Activation\\id_gen.exe"), szSerial, &szId);


NLicense.h Enumerations

NLicense.h Enumerations
Legend
Enumerations
Name | Description
NLicenseObtainedStatus_ | Enumerates licensing status values.
NLicenseObtainedStatus | Enumerates licensing status values.


NLicense.h Functions

NLicense.h Functions
Legend
Functions
Name | Description
NLicenseActivateOnline | ... more
NLicenseAdd | Adds the activated license content (the content of *.lic file) to be used in application.
NLicenseDeactivateOnline | ... more
NLicenseDeactivateOnlineWithId | ... more
NLicenseGenerateDeactivationId | Generates deactivation Id for specified provided product on current computer.
NLicenseGenerateDeactivationIdForLicense | Generates deactivation Id for specified license on current computer.
NLicenseGenerateId | Generates Id for activation from serial number for a particular machine.
NLicenseGetLicenseInfoOnline | Retrieves info online about specified license.
NLicenseGetObtainedComponentStatus | Gets licensing status for obtained component.
NLicenseGetObtainedLicenseInfo | Retrieves information about obtained license.
NLicenseGetObtainedLicenseInfoForComponent | Retrieves information about obtained license for component.
NLicenseGetObtainedStatus | Gets licensing status for the specified product.
NLicenseIsComponentActivated | Checks if component specified by name is activated.
NLicenseObtain | Obtains product license from the specified server.
NLicenseObtainComponents | Obtains component license from the specified server.
NLicenseRelease | Releases license.
NLicenseReleaseComponents | Releases component license.


NLicense.h Macros

NLicense.h Macros
Macros
Name | Description
NLicenseActivateOnline | Picks a Unicode (W) or ANSCII (A) version of the NLicenseActivateOnline function.
NLicenseAdd | Picks a Unicode (W) or ANSCII (A) version of the NLicenseAdd function.
NLicenseDeactivateOnline | Picks a Unicode (W) or ANSCII (A) version of the NLicenseDeactivateOnline function.
NLicenseDeactivateOnlineWithId | Picks a Unicode (W) or ANSCII (A) version of the NLicenseDeactivateOnlineWithId function.
NLicenseGenerateDeactivationId | Picks a Unicode (W) or ANSCII (A) version of the NLicenseGenerateDeactivationId function.
NLicenseGenerateDeactivationIdForLicense | Picks a Unicode (W) or ANSCII (A) version of the NLicenseGenerateDeactivationIdForLicense function.
NLicenseGenerateId | Picks a Unicode (W) or ANSCII (A) version of the NLicenseGenerateId function.
NLicenseGetLicenseInfoOnline | Picks a Unicode (W) or ANSCII (A) version of the NLicenseGetLicenseInfoOnline function.
NLicenseGetObtainedComponentStatus | Picks a Unicode (W) or ANSCII (A) version of the NLicenseGetObtainedComponentStatus function.
NLicenseGetObtainedLicenseInfo | Picks a Unicode (W) or ANSCII (A) version of the NLicenseGetObtainedLicenseInfo function.
NLicenseGetObtainedLicenseInfoForComponent | Picks a Unicode (W) or ANSCII (A) version of the NLicenseGetObtainedLicenseInfoForComponent function.
NLicenseGetObtainedStatus | Picks a Unicode (W) or ANSCII (A) version of the NLicenseGetObtainedStatus function.
NLicenseIsComponentActivated | Picks a Unicode (W) or ANSCII (A) version of the NLicenseIsComponentActivated function.
NLicenseObtainComponents | Picks a Unicode (W) or ANSCII (A) version of the NLicenseObtainComponents function.
NLicenseReleaseComponents | Picks a Unicode (W) or ANSCII (A) version of the NLicenseReleaseComponents function.


NLicenseInfo Unit Functions

NLicenseInfo Unit Functions
Legend
Functions
Name | Description
NLicenseInfoGetDistributorId | Gets distributor id.
NLicenseInfoGetLicenseId | Gets license Id.
NLicenseInfoGetLicenses | Gets all licenses from specified NLicenseInfo.
NLicenseInfoGetSequenceNumber | Gets sequence number of specified HNLicenseInfo.
NLicenseInfoGetSourceType | Gets license source type.
NLicenseInfoGetStatus | Gets license status value.
NLicenseInfoGetType | Gets license type.
NLicenseProductInfoGetId | Gets product Id.
NLicenseProductInfoGetLicenseCount | Gets license count in specified NLicenseProductInfo.
NLicenseProductInfoGetLicenseType | Gets license type of specified NLicenseProductInfo.
NLicenseProductInfoGetOSFamily | Gets OS family of specified NLicenseProductInfo.
NLicenseProductInfoGetParameters | Gets the product parameters of specified NLicenseProductInfo.


NLicenseInfo Unit Structs, Records, Enums

NLicenseInfo Unit Structs, Records, Enums
Legend
Structs, Records, Enums
Name | Description
NLicenseInfoSourceType_ | Specifies license source.
NLicenseInfoStatus_ | Enumerates license status values.
NLicenseInfoType_ | Specifies licensing type.
NLicenseType_ | Specifies license type.
NLicenseInfoSourceType | Specifies license source.
NLicenseInfoStatus | Enumerates license status values.
NLicenseInfoType | Specifies licensing type.
NLicenseType | Specifies license type.


NLicenseManager Unit Functions

NLicenseManager Unit Functions
Legend
Functions
Name | Description
NLicManFindFirstDongle | Retrieves handle to the first attached dongle.
NLicManFindNextDongle | Retrieves next attached dongle.
NLicManGenerateLicenseExN | Generates product license using the specified computer Id from a dongle.
NLicManGenerateLicenseN | Generates product license from computer Id.
NLicManGenerateSerialExN | Generates serial number from a dongle.
NLicManGenerateSerialN | Generates serial number for a specified product.
NLicManGetClientId | Gets application identifier (Id) if more than one application is used.
NLicManGetDongles | Retrieves an array of connected dongles containing licenses for Neurotechnology products.
NLicManGetLicenseData | Retrieves license data for a specified product license.
NLicManGetLicenseDataEx | Retrieves license data for a specified product license.
NLicManGetLongProductNameForProductInfoN | Retrieves full name of a product specified by product info.
NLicManGetLongProductNameN | Retrieves full name of a product specified by product Id.
NLicManGetProductIds | Retrieves a list of all Neurotechnology products Ids.
NLicManGetProxyHost | Retrieves proxy server host name.
NLicManGetProxyPassword | Retrieves proxy server password.
NLicManGetProxyPort | Retrieves proxy port number of licensing server.
NLicManGetProxyUsername | Retrieves proxy server username.
NLicManGetShortProductNameForProductInfoN | Retrieves short name of a product from NLicenseProductInfo.
NLicManGetShortProductNameN | Retrieves short name of a product specified by product Id.
NLicManGetTrialMode | Gets trial mode value.
NLicManGetUpdateTicketInfo | Updates specified ticket info.
NLicManGetUseHttps | ... more
NLicManGetWritableStoragePath | Gets writeable storage path.
NLicManInitialize | Initializes NLicenseManager.
NLicManIsLicenseTypeSupported | Checks whether the specified license type is supported.
NLicManSetClientIdN | Sets application identifier (Id) if more than one application is used.
NLicManSetProxyHostN | Sets proxy server host name.
NLicManSetProxyPasswordN | Sets password to use for proxy server authentication.
NLicManSetProxyPort | Sets proxy port number of licensing server.
NLicManSetProxyUsernameN | Sets username to use for proxy server authentication.
NLicManSetTrialMode | Sets trial mode value.
NLicManSetUseHttps | Enables or disables use of HTTPS protocol.
NLicManSetWritableStoragePathN | Sets writeable storage path value.


NLicenseManager Unit Macros

NLicenseManager Unit Macros
Macros
Name | Description
NLicManGetLicenseData | Picks a Unicode (W) or ANSCII (A) version of the NLicManGetLicenseData function.
NLicManGetLicenseDataEx | Picks a Unicode (W) or ANSCII (A) version of the NLicManGetLicenseDataEx function.
NLicManGetUpdateTicketInfo | Picks a Unicode (W) or ANSCII (A) version of the NLicManGetUpdateTicketInfo function.
N_LIC_MAN_MAX_LICENSE_LENGTH | Defines maximal length of generated license.
N_LIC_MAN_MAX_SERIAL_LENGTH | Defines maximal length of serial number.


NLicensing Unit Files

NLicensing Unit Files
Files
Name | Description
NLicensing.h | Header file for the NLicensing library. Provides functionality for getting and releasing licenses.


Bmp Unit Files

Bmp Unit Files
Files
Name | Description
Bmp.h | Header file for Bmp module. Provides functionality for loading and saving images in BMP format.


IHead Unit Files

IHead Unit Files
Files
Name | Description
IHead.h | Header file for IHead Module. Provides functionality for loading and saving images in NIST IHead format.


Jpeg Unit Files

Jpeg Unit Files
Files
Name | Description
Jpeg.h | Header file for Jpeg module. Provides functionality for loading and saving images in JPEG format.


Jpeg Unit Functions

Jpeg Unit Functions
Legend
Functions
Name | Description
JpegInfoGetQuality | Retrieves a NInt value which defines the quality of a specified JPEG image.
JpegInfoIsLossless | Checks if a JPEG image is lossless.
JpegInfoSetLossless | Defines if a JPEG image is lossless.
JpegInfoSetQuality | Sets the quality value for a JPEG image.


Jpeg Unit Macros

Jpeg Unit Macros
Macros
Name | Description
JPEG_DEFAULT_QUALITY | Specifies default JPEG quality.


Jpeg.h Functions

Jpeg.h Functions
Legend
Functions
Name | Description
JpegInfoGetQuality | Retrieves a NInt value which defines the quality of a specified JPEG image.
JpegInfoIsLossless | Checks if a JPEG image is lossless.
JpegInfoSetLossless | Defines if a JPEG image is lossless.
JpegInfoSetQuality | Sets the quality value for a JPEG image.


Jpeg.h Macros

Jpeg.h Macros
Macros
Name | Description
JPEG_DEFAULT_QUALITY | Specifies default JPEG quality.


Jpeg2K Unit Files

Jpeg2K Unit Files
Files
Name | Description
Jpeg2K.h | Header file for Jpeg2K Module. Provides functionality for loading and saving images in JPEG 2000 format.


Jpeg2K Unit Functions

Jpeg2K Unit Functions
Legend
Functions
Name | Description
Jpeg2KInfoGetProfile | Returns Jpeg 2000 profile.
Jpeg2KInfoGetRatio | Returns Jpeg 2000 image compression ration.
Jpeg2KInfoSetProfile | Sets Jpeg 2000 profile value.
Jpeg2KInfoSetRatio | Sets Jpeg 2000 image compression ration.


Jpeg2K Unit Macros

Jpeg2K Unit Macros
Macros
Name | Description
JPEG_2K_DEFAULT_RATIO | Specifies default JPEG 2000 quality.


Jpeg2K Unit Structs, Records, Enums

Jpeg2K Unit Structs, Records, Enums
Legend
Structs, Records, Enums
Name | Description
Jpeg2KProfile_ | Enumerates Jpeg 2000 Profile values.
Jpeg2KProfile | Enumerates Jpeg 2000 Profile values.


Jpeg2K.h Enumerations

Jpeg2K.h Enumerations
Legend
Enumerations
Name | Description
Jpeg2KProfile_ | Enumerates Jpeg 2000 Profile values.
Jpeg2KProfile | Enumerates Jpeg 2000 Profile values.


Jpeg2K.h Functions

Jpeg2K.h Functions
Legend
Functions
Name | Description
Jpeg2KInfoGetProfile | Returns Jpeg 2000 profile.
Jpeg2KInfoGetRatio | Returns Jpeg 2000 image compression ration.
Jpeg2KInfoSetProfile | Sets Jpeg 2000 profile value.
Jpeg2KInfoSetRatio | Sets Jpeg 2000 image compression ration.


Jpeg2K.h Macros

Jpeg2K.h Macros
Macros
Name | Description
JPEG_2K_DEFAULT_RATIO | Specifies default JPEG 2000 quality.


NGeometry Unit Files

NGeometry Unit Files
Files
Name | Description
NGeometry.h | Header file for the NGeometry module. Provides definitions of geometrical structures types.


Legend

Legend
Legend
Enumeration
Structure


NGeometry Unit Structs, Records, Enums

NGeometry Unit Structs, Records, Enums
Legend
Structs, Records, Enums
Name | Description
NInterpolationMode_ | Enumerates interpolation modes.
NPoint3F_ | Structure defining point coordinates in 3D space.
NRect_ | Structure defining a rectangle figure in 2D space.
NPoint_ | Structure defining point coordinates in 2D space.
NSize_ | Structure defining rectangle size.
NInterpolationMode | Enumerates interpolation modes.
NPointD_ | Structure defining point coordinates in 2D space.
NPointF_ | Structure defining point coordinates in 2D space.
NRectD_ | Structure defining a rectangle figure in 2D space.
NRectF_ | Structure defining a rectangle figure in 2D space.
NSizeD_ | Structure defining rectangle size.
NSizeF_ | Structure defining rectangle size.


NGeometry Unit Types

NGeometry Unit Types
Types
Name | Description
NPoint | Structure defining point coordinates in 2D space.
NPoint3F | Structure defining point coordinates in 3D space.
NRect | Structure defining a rectangle figure in 2D space.
NSize | Structure defining rectangle size.
NPointD | Structure defining point coordinates in 2D space.
NPointF | Structure defining point coordinates in 2D space.
NRectD | Structure defining a rectangle figure in 2D space.
NRectF | Structure defining a rectangle figure in 2D space.
NSizeD | Structure defining rectangle size.
NSizeF | Structure defining rectangle size.


NGeometry.h Enumerations

NGeometry.h Enumerations
Legend
Enumerations
Name | Description
NInterpolationMode_ | Enumerates interpolation modes.
NInterpolationMode | Enumerates interpolation modes.


NGeometry.h Structures

NGeometry.h Structures
Legend
Structures
Name | Description
NPoint3F_ | Structure defining point coordinates in 3D space.
NPointD_ | Structure defining point coordinates in 2D space.
NPointF_ | Structure defining point coordinates in 2D space.
NPoint_ | Structure defining point coordinates in 2D space.
NRectD_ | Structure defining a rectangle figure in 2D space.
NRectF_ | Structure defining a rectangle figure in 2D space.
NRect_ | Structure defining a rectangle figure in 2D space.
NSizeD_ | Structure defining rectangle size.
NSizeF_ | Structure defining rectangle size.
NSize_ | Structure defining rectangle size.


NGeometry.h Types

NGeometry.h Types
Types
Name | Description
NPoint | Structure defining point coordinates in 2D space.
NPoint3F | Structure defining point coordinates in 3D space.
NPointD | Structure defining point coordinates in 2D space.
NPointF | Structure defining point coordinates in 2D space.
NRect | Structure defining a rectangle figure in 2D space.
NRectD | Structure defining a rectangle figure in 2D space.
NRectF | Structure defining a rectangle figure in 2D space.
NSize | Structure defining rectangle size.
NSizeD | Structure defining rectangle size.
NSizeF | Structure defining rectangle size.


NImageInfo Unit Files

NImageInfo Unit Files
Files
Name | Description
NImageInfo.h | Header file for the NImageInfo module.


NImageInfo Unit Functions

NImageInfo Unit Functions
Legend
Functions
Name | Description
NImageInfoCreate | Creates a new image information object.
NImageInfoGetFormatEx | Retrieves the format of the image.
NImageInfoGetHeight | Retrieves the height of the image.
NImageInfoGetTransform | Retrieves the transformation of the image.
NImageInfoGetWidth | Retrieves the width of the image.
NImageInfoSetTransform | Sets the transformation of the image.
NImageRotateFlipTypeCreate | Creates a new object which holds image transformation information.
NImageRotateFlipTypeFlipTypeIsValid | Checks whether the specified image flip value is valid.
NImageRotateFlipTypeGetFlipType | Retrieves the image rotation value from the image transformation information.
NImageRotateFlipTypeGetRotateType | Retrieves the image rotation value from the image transformation information.
NImageRotateFlipTypeIsValid | Checks whether the image transformation information is valid.
NImageRotateFlipTypeMinimizeFlip | Minimizes the specified image flip value.
NImageRotateFlipTypeMinimizeRotation | Minimizes the specified image rotation value.
NImageRotateFlipTypeRotateTypeIsValid | Checks whether the specified image rotation value is valid.


NImageInfo Unit Structs, Records, Enums

NImageInfo Unit Structs, Records, Enums
Legend
Structs, Records, Enums
Name | Description
NImageRotateFlipType_ | Enumerates image transformations.
NImageCompressionAlgorithm_ | Enumerates image compression algorithms.
NImageRotateFlipType | Enumerates image transformations.
NImageCompressionAlgorithm | Enumerates image compression algorithms.


NImageInfo.h Enumerations

NImageInfo.h Enumerations
Legend
Enumerations
Name | Description
NImageCompressionAlgorithm_ | Enumerates image compression algorithms.
NImageRotateFlipType_ | Enumerates image transformations.
NImageCompressionAlgorithm | Enumerates image compression algorithms.
NImageRotateFlipType | Enumerates image transformations.


NImageInfo.h Functions

NImageInfo.h Functions
Legend
Functions
Name | Description
NImageInfoCreate | Creates a new image information object.
NImageInfoGetFormatEx | Retrieves the format of the image.
NImageInfoGetHeight | Retrieves the height of the image.
NImageInfoGetTransform | Retrieves the transformation of the image.
NImageInfoGetWidth | Retrieves the width of the image.
NImageInfoSetTransform | Sets the transformation of the image.
NImageRotateFlipTypeCreate | Creates a new object which holds image transformation information.
NImageRotateFlipTypeFlipTypeIsValid | Checks whether the specified image flip value is valid.
NImageRotateFlipTypeGetFlipType | Retrieves the image rotation value from the image transformation information.
NImageRotateFlipTypeGetRotateType | Retrieves the image rotation value from the image transformation information.
NImageRotateFlipTypeIsValid | Checks whether the image transformation information is valid.
NImageRotateFlipTypeMinimizeFlip | Minimizes the specified image flip value.
NImageRotateFlipTypeMinimizeRotation | Minimizes the specified image rotation value.
NImageRotateFlipTypeRotateTypeIsValid | Checks whether the specified image rotation value is valid.


NImageReader Unit Files

NImageReader Unit Files
Files
Name | Description
NImageReader.h | Header file for the NImageReader module.


NImageReader Unit Functions

NImageReader Unit Functions
Legend
Functions
Name | Description
NImageReaderGetFormatEx | Retrieves the format of the image read by the image reader.
NImageReaderGetReadSize | Retrieves the size of the image read by the image reader.
NImageReaderRead | Reads the image and image information.
NImageReaderReadInfo | Reads the information of an image.


NImageReader.h Functions

NImageReader.h Functions
Legend
Functions
Name | Description
NImageReaderGetFormatEx | Retrieves the format of the image read by the image reader.
NImageReaderGetReadSize | Retrieves the size of the image read by the image reader.
NImageReaderRead | Reads the image and image information.
NImageReaderReadInfo | Reads the information of an image.


NImages Unit Files

NImages Unit Files
Files
Name | Description
NImages.h | Header file for NImages module. Provides library registration and other additional functionality.


NImages Unit Functions

NImages Unit Functions
Legend
Functions
Name | Description
NImagesGetGrayscaleColorWrapperEx | Creates color wrapper for a grayscale image.
NImagesRecolorImage | Recolors the specified image.


NImages.h Functions

NImages.h Functions
Legend
Functions
Name | Description
NImagesGetGrayscaleColorWrapperEx | Creates color wrapper for a grayscale image.
NImagesRecolorImage | Recolors the specified image.


NImageWriter Unit Files

NImageWriter Unit Files
Files
Name | Description
NImageWriter.h | Header file for the NImageWriter module.


NImageWriter Unit Functions

NImageWriter Unit Functions
Legend
Functions
Name | Description
NImageWriterGetBuffer | Gets a memory buffer to write data from.
NImageWriterGetFormatEx | Retrieves the format of the image written by the image writer.
NImageWriterWrite | Writes image information to an image.


NImageWriter.h Functions

NImageWriter.h Functions
Legend
Functions
Name | Description
NImageWriterGetBuffer | Gets a memory buffer to write data from.
NImageWriterGetFormatEx | Retrieves the format of the image written by the image writer.
NImageWriterWrite | Writes image information to an image.


NMediaFormat Unit Files

NMediaFormat Unit Files
Files
Name | Description
NMediaFormat.h | Header file for NMediaFormat Unit.


NMediaFormat Unit Functions

NMediaFormat Unit Functions
Legend
Functions
Name | Description
NMediaFormatGetMediaSubtype | Gets media subtype from specified media format.
NMediaFormatGetMediaType | Gets media type from specified NMediaFormat.
NMediaFormatIsCompatibleWith | Checks if specified media format is compatible with other media format.
NMediaFormatSetMediaSubtype | Sets media subtype for specified media format.
HNMediaFormat | Handle to HNMediaFormat.


NMediaFormat.h Functions

NMediaFormat.h Functions
Legend
Functions
Name | Description
NMediaFormatGetMediaSubtype | Gets media subtype from specified media format.
NMediaFormatGetMediaType | Gets media type from specified NMediaFormat.
NMediaFormatIsCompatibleWith | Checks if specified media format is compatible with other media format.
NMediaFormatSetMediaSubtype | Sets media subtype for specified media format.


NMediaReader Unit Files

NMediaReader Unit Files
Files
Name | Description
NMediaReader.h | Header file for NMediaReader Unit.


NMediaReader Unit Functions

NMediaReader Unit Functions
Legend
Functions
Name | Description
NMediaReaderCreate | Creates media reader object.
NMediaReaderCreateFromFile | Creates NMediaReader from file.
NMediaReaderCreateFromUrl | Creates NMediaReader from URL.
NMediaReaderGetLength | Gets file length (100 ns units) when NMediaReader source is file.
NMediaReaderGetPosition | Gets NMediaReader position in media source (file).
NMediaReaderGetSource | Gets media source (file or device) of the specified NMediaReader.
NMediaReaderGetState | Gets NMediaReader state.
NMediaReaderReadAudioSample | Reads audio sample using specified NMediaReader.
NMediaReaderIsLive | Checks if media source which is used by specified NMediaReader is live.
NMediaReaderReadVideoSample | Reads video sample using specified NMediaReader.
NMediaReaderPause | Pauses specified NMediaReader.
NMediaReaderReadVideoSampleData | Reads video sample data using specified NMediaReader.
NMediaReaderSetPosition | Sets NMediaReader position in media source (file).
NMediaReaderStart | Starts NMediaReader.
NMediaReaderStop | Stops NMediaReader.
HNMediaReader | Handle to NMediaReader


NMediaReader Unit Macros

NMediaReader Unit Macros
Macros
Name | Description
NMediaReaderCreateFromFile | Picks a Unicode (W) or ANSCII (A) version of the NMediaReaderFromFile function.
NMediaReaderCreateFromUrl | Picks a Unicode (W) or ANSCII (A) version of the NMediaReaderFromUrl function.


NMediaReader.h Functions

NMediaReader.h Functions
Legend
Functions
Name | Description
NMediaReaderCreate | Creates media reader object.
NMediaReaderCreateFromFile | Creates NMediaReader from file.
NMediaReaderCreateFromUrl | Creates NMediaReader from URL.
NMediaReaderGetLength | Gets file length (100 ns units) when NMediaReader source is file.
NMediaReaderGetPosition | Gets NMediaReader position in media source (file).
NMediaReaderGetSource | Gets media source (file or device) of the specified NMediaReader.
NMediaReaderGetState | Gets NMediaReader state.
NMediaReaderIsLive | Checks if media source which is used by specified NMediaReader is live.
NMediaReaderPause | Pauses specified NMediaReader.
NMediaReaderReadAudioSample | Reads audio sample using specified NMediaReader.
NMediaReaderReadVideoSample | Reads video sample using specified NMediaReader.
NMediaReaderReadVideoSampleData | Reads video sample data using specified NMediaReader.
NMediaReaderSetPosition | Sets NMediaReader position in media source (file).
NMediaReaderStart | Starts NMediaReader.
NMediaReaderStop | Stops NMediaReader.


NMediaReader.h Macros

NMediaReader.h Macros
Macros
Name | Description
NMediaReaderCreateFromFile | Picks a Unicode (W) or ANSCII (A) version of the NMediaReaderFromFile function.
NMediaReaderCreateFromUrl | Picks a Unicode (W) or ANSCII (A) version of the NMediaReaderFromUrl function.


NMediaSource Unit Files

NMediaSource Unit Files
Files
Name | Description
NMediaSource.h | Header file for NMediaSource Unit.


NMediaSource Unit Functions

NMediaSource Unit Functions
Legend
Functions
Name | Description
NMediaSourceCreateFromFile | Creates NMediaSource from specified file.
NMediaSourceCreateFromUrl | Creates media source from URL.
NMediaSourceGetDisplayNameN | Gets display name of specified media source.
NMediaSourceEnumDevices | Enumerates all source devices by specified media type.
NMediaSourceGetCurrentFormat | Gets media source format for specified media type.
NMediaSourceGetIdN | Gets media source Id.
NMediaSourceGetFormats | Gets media source formats.
NMediaSourceGetMediaType | Gets media type of specified media source.
NMediaSourceSetCurrentFormat | Sets media source format for specified media type.
HNmediaSource | Handle to NMediaSource unit.


NMediaSource Unit Macros

NMediaSource Unit Macros
Macros
Name | Description
NMS_ALLOW_DUPLICATE_DEVICES | ... more
NMS_DO_NOT_USE_DIRECT_SHOW | Used when user prefers not to use DirecShow for NMediaSource.
NMS_DO_NOT_USE_VLC | Used when user prefers not to use VLC for NMediaSource.
NMS_DO_NOT_USE_WINDOWS_MEDIA | Used when user prefers not to use Windows Media for NMediaSource.
NMS_DO_NOT_USE_WINDOWS_MEDIA_FOUNDATION | Used when user prefers not to use Windows Media Foundation for NMediaSource.
NMS_PREFER_DIRECT_SHOW | Used when user prefers to use DirectShow for NMediaSource.
NMS_PREFER_VLC | Used when user prefers to use VLC for NMediaSource.
NMS_PREFER_WINDOWS_MEDIA | Used when user prefers to use Windows Media for NMediaSource.
NMS_PREFER_WINDOWS_MEDIA_FOUNDATION | Used when user prefers to use Media Foundation for NMediaSource.


NMediaSource.h Functions

NMediaSource.h Functions
Legend
Functions
Name | Description
NMediaSourceCreateFromFile | Creates NMediaSource from specified file.
NMediaSourceCreateFromUrl | Creates media source from URL.
NMediaSourceEnumDevices | Enumerates all source devices by specified media type.
NMediaSourceGetCurrentFormat | Gets media source format for specified media type.
NMediaSourceGetDisplayNameN | Gets display name of specified media source.
NMediaSourceGetFormats | Gets media source formats.
NMediaSourceGetIdN | Gets media source Id.
NMediaSourceGetMediaType | Gets media type of specified media source.
NMediaSourceSetCurrentFormat | Sets media source format for specified media type.


NMediaSource.h Macros

NMediaSource.h Macros
Macros
Name | Description
NMS_ALLOW_DUPLICATE_DEVICES | ... more
NMS_DO_NOT_USE_DIRECT_SHOW | Used when user prefers not to use DirecShow for NMediaSource.
NMS_DO_NOT_USE_VLC | Used when user prefers not to use VLC for NMediaSource.
NMS_DO_NOT_USE_WINDOWS_MEDIA | Used when user prefers not to use Windows Media for NMediaSource.
NMS_DO_NOT_USE_WINDOWS_MEDIA_FOUNDATION | Used when user prefers not to use Windows Media Foundation for NMediaSource.
NMS_PREFER_DIRECT_SHOW | Used when user prefers to use DirectShow for NMediaSource.
NMS_PREFER_VLC | Used when user prefers to use VLC for NMediaSource.
NMS_PREFER_WINDOWS_MEDIA | Used when user prefers to use Windows Media for NMediaSource.
NMS_PREFER_WINDOWS_MEDIA_FOUNDATION | Used when user prefers to use Media Foundation for NMediaSource.


NMediaTypes Unit Files

NMediaTypes Unit Files
Files
Name | Description
NMediaTypes.h | Header file for NMediaTypes unit.


NMediaTypes Unit Functions

NMediaTypes Unit Functions
Legend
Functions
Name | Description
NMediaTypeIsValid | Checks if the value passed to a function is a valid media type.
NMediaTypeIsValidSingle | Checks if the single value passed to a function is a valid media type.
NVideoInterlaceModeIsValid | Checks if video interlace mode is valid.


NMediaTypes Unit Structs, Records, Enums

NMediaTypes Unit Structs, Records, Enums
Legend
Structs, Records, Enums
Name | Description
NMediaState_ | Enumerates media state values.
NMediaType_ | Enumerates media type values.
NVideoInterlaceMode_ | Enumerates video scan mode values.
NMediaState | Enumerates media state values.
NMediaType | Enumerates media type values.
NVideoInterlaceMode | Enumerates video scan mode values.


NMediaTypes.h Enumerations

NMediaTypes.h Enumerations
Legend
Enumerations
Name | Description
NMediaState_ | Enumerates media state values.
NMediaType_ | Enumerates media type values.
NVideoInterlaceMode_ | Enumerates video scan mode values.
NMediaState | Enumerates media state values.
NMediaType | Enumerates media type values.
NVideoInterlaceMode | Enumerates video scan mode values.


NMediaTypes.h Functions

NMediaTypes.h Functions
Legend
Functions
Name | Description
NMediaTypeIsValid | Checks if the value passed to a function is a valid media type.
NMediaTypeIsValidSingle | Checks if the single value passed to a function is a valid media type.
NVideoInterlaceModeIsValid | Checks if video interlace mode is valid.


NPixelFormat Unit Files

NPixelFormat Unit Files
Files
Name | Description
NPixelFormat.h | Header file for NPixelFormat module. Provides functionality for working with image pixel format.


NPixelFormat Unit Functions

NPixelFormat Unit Functions
Legend
Functions
Name | Description
NPixelFormatCalcRowSize | Calculates number of bytes needed to store line of specified length of pixels with specified NPixelFormat.
NPixelFormatCreate | Creates a new NPixelFormat.
NPixelFormatGetBitsPerPixel | Retrieves number of bits used to store a pixel from NPixelFormat.
NPixelFormatGetBytesPerPixel | Retrieves number of bytes used to store a pixel from NPixelFormat.
NPixelFormatGetIndexed | Retrieves an indexed version of the NPixelFormat.
NPixelFormatGetNonIndexed | Retrieves a non-indexed version of the NPixelFormat.
NPixelFormatGetNonSeparated | Retrieves a non-separated version of the NPixelFormat.
NPixelFormatGetPaletteSize | Retrieves the palette size for the pixel format.
NPixelFormatGetPixelType | Retrieves the pixel type for the specified pixel format.
NPixelFormatGetRowSize | Calculates number of bytes needed to store line of specified length of pixels with specified NPixelFormat.
NPixelFormatGetSeparated | Retrieves a separated version of the NPixelFormat.
NPixelFormatGetWithExtraChannel | Retrieves a version of the NPixelFormat with an extra channel.
NPixelFormatIsValid | Checks if specified pixel format is valid.
NPixelFormatToString | Converts a pixel format into a string.
NPixelTypeCanBeIndexed | Checks if specified pixel type can be indexed.
NPixelTypeIsValid | Checks if specified pixel type is valid.


NPixelFormat Unit Macros

NPixelFormat Unit Macros
Macros
Name | Description
NPF_GRAYSCALE_16S | ... more
NPF_GRAYSCALE_16U | ... more
NPF_GRAYSCALE_1U | ... more
NPF_GRAYSCALE_2U | ... more
NPF_GRAYSCALE_32F | ... more
NPF_GRAYSCALE_32S | ... more
NPF_GRAYSCALE_32U | ... more
NPF_GRAYSCALE_4U | ... more
NPF_GRAYSCALE_64F | ... more
NPF_GRAYSCALE_64S | ... more
NPF_GRAYSCALE_64U | ... more
NPF_GRAYSCALE_8S | ... more
NPF_GRAYSCALE_8U | ... more
NPF_GRAYSCALE_A_16S | ... more
NPF_GRAYSCALE_A_16U | ... more
NPF_GRAYSCALE_A_32F | ... more
NPF_GRAYSCALE_A_32S | ... more
NPF_GRAYSCALE_A_32U | ... more
NPF_GRAYSCALE_A_64F | ... more
NPF_GRAYSCALE_A_64S | ... more
NPF_GRAYSCALE_A_64U | ... more
NPF_GRAYSCALE_A_8S | ... more
NPF_GRAYSCALE_A_8U | ... more
NPF_GRAYSCALE_PA_16S | ... more
NPF_GRAYSCALE_PA_16U | ... more
NPF_GRAYSCALE_PA_32F | ... more
NPF_GRAYSCALE_PA_32S | ... more
NPF_GRAYSCALE_PA_32U | ... more
NPF_GRAYSCALE_PA_64F | ... more
NPF_GRAYSCALE_PA_64S | ... more
NPF_GRAYSCALE_PA_64U | ... more
NPF_GRAYSCALE_PA_8S | ... more
NPF_GRAYSCALE_PA_8U | ... more
NPF_RGB_16S | ... more
NPF_RGB_16U | ... more
NPF_RGB_32F | ... more
NPF_RGB_32S | ... more
NPF_RGB_32U | ... more
NPF_RGB_64F | ... more
NPF_RGB_64S | ... more
NPF_RGB_64U | ... more
NPF_RGB_8S | ... more
NPF_RGB_8U | ... more
NPF_RGB_8U_INDEXED_1 | ... more
NPF_RGB_8U_INDEXED_2 | ... more
NPF_RGB_8U_INDEXED_4 | ... more
NPF_RGB_8U_INDEXED_8 | ... more
NPF_RGB_A_16S | ... more
NPF_RGB_A_16U | ... more
NPF_RGB_A_32F | ... more
NPF_RGB_A_32S | ... more
NPF_RGB_A_32U | ... more
NPF_RGB_A_64F | ... more
NPF_RGB_A_64S | ... more
NPF_RGB_A_64U | ... more
NPF_RGB_A_8S | ... more
NPF_RGB_A_8U | ... more
NPF_RGB_A_8U_INDEXED_1 | ... more
NPF_RGB_A_8U_INDEXED_2 | ... more
NPF_RGB_A_8U_INDEXED_4 | ... more
NPF_RGB_A_8U_INDEXED_8 | ... more
NPF_RGB_PA_16S | ... more
NPF_RGB_PA_16U | ... more
NPF_RGB_PA_32F | ... more
NPF_RGB_PA_32S | ... more
NPF_RGB_PA_32U | ... more
NPF_RGB_PA_64F | ... more
NPF_RGB_PA_64S | ... more
NPF_RGB_PA_64U | ... more
NPF_RGB_PA_8S | ... more
NPF_RGB_PA_8U | ... more
NPF_UNDEFINED | Indicates undefined pixel format.
NPixelFormatToString | Picks a Unicode (W) or ANSCII (A) version of the NPixelFormatToString function.


NPixelFormat Unit Structs, Records, Enums

NPixelFormat Unit Structs, Records, Enums
Legend
Structs, Records, Enums
Name | Description
NPixelType_ | Specifies pixel type of each pixel in the image.
NPixelType | Specifies pixel type of each pixel in the image.


NPixelFormat Unit Types

NPixelFormat Unit Types
Types
Name | Description
NPixelFormat | Specifies pixel format of each pixel in the image.
NPixelFormat_ | Specifies pixel format of each pixel in the image.


NPixelFormat.h Enumerations

NPixelFormat.h Enumerations
Legend
Enumerations
Name | Description
NPixelType_ | Specifies pixel type of each pixel in the image.
NPixelType | Specifies pixel type of each pixel in the image.


NPixelFormat.h Functions

NPixelFormat.h Functions
Legend
Functions
Name | Description
NPixelFormatCalcRowSize | Calculates number of bytes needed to store line of specified length of pixels with specified NPixelFormat.
NPixelFormatCreate | Creates a new NPixelFormat.
NPixelFormatGetBitsPerPixel | Retrieves number of bits used to store a pixel from NPixelFormat.
NPixelFormatGetBytesPerPixel | Retrieves number of bytes used to store a pixel from NPixelFormat.
NPixelFormatGetIndexed | Retrieves an indexed version of the NPixelFormat.
NPixelFormatGetNonIndexed | Retrieves a non-indexed version of the NPixelFormat.
NPixelFormatGetNonSeparated | Retrieves a non-separated version of the NPixelFormat.
NPixelFormatGetPaletteSize | Retrieves the palette size for the pixel format.
NPixelFormatGetPixelType | Retrieves the pixel type for the specified pixel format.
NPixelFormatGetRowSize | Calculates number of bytes needed to store line of specified length of pixels with specified NPixelFormat.
NPixelFormatGetSeparated | Retrieves a separated version of the NPixelFormat.
NPixelFormatGetWithExtraChannel | Retrieves a version of the NPixelFormat with an extra channel.
NPixelFormatIsValid | Checks if specified pixel format is valid.
NPixelFormatToString | Converts a pixel format into a string.
NPixelTypeCanBeIndexed | Checks if specified pixel type can be indexed.
NPixelTypeIsValid | Checks if specified pixel type is valid.


NPixelFormat.h Macros

NPixelFormat.h Macros
Macros
Name | Description
NPF_GRAYSCALE_16S | ... more
NPF_GRAYSCALE_16U | ... more
NPF_GRAYSCALE_1U | ... more
NPF_GRAYSCALE_2U | ... more
NPF_GRAYSCALE_32F | ... more
NPF_GRAYSCALE_32S | ... more
NPF_GRAYSCALE_32U | ... more
NPF_GRAYSCALE_4U | ... more
NPF_GRAYSCALE_64F | ... more
NPF_GRAYSCALE_64S | ... more
NPF_GRAYSCALE_64U | ... more
NPF_GRAYSCALE_8S | ... more
NPF_GRAYSCALE_8U | ... more
NPF_GRAYSCALE_A_16S | ... more
NPF_GRAYSCALE_A_16U | ... more
NPF_GRAYSCALE_A_32F | ... more
NPF_GRAYSCALE_A_32S | ... more
NPF_GRAYSCALE_A_32U | ... more
NPF_GRAYSCALE_A_64F | ... more
NPF_GRAYSCALE_A_64S | ... more
NPF_GRAYSCALE_A_64U | ... more
NPF_GRAYSCALE_A_8S | ... more
NPF_GRAYSCALE_A_8U | ... more
NPF_GRAYSCALE_PA_16S | ... more
NPF_GRAYSCALE_PA_16U | ... more
NPF_GRAYSCALE_PA_32F | ... more
NPF_GRAYSCALE_PA_32S | ... more
NPF_GRAYSCALE_PA_32U | ... more
NPF_GRAYSCALE_PA_64F | ... more
NPF_GRAYSCALE_PA_64S | ... more
NPF_GRAYSCALE_PA_64U | ... more
NPF_GRAYSCALE_PA_8S | ... more
NPF_GRAYSCALE_PA_8U | ... more
NPF_RGB_16S | ... more
NPF_RGB_16U | ... more
NPF_RGB_32F | ... more
NPF_RGB_32S | ... more
NPF_RGB_32U | ... more
NPF_RGB_64F | ... more
NPF_RGB_64S | ... more
NPF_RGB_64U | ... more
NPF_RGB_8S | ... more
NPF_RGB_8U | ... more
NPF_RGB_8U_INDEXED_1 | ... more
NPF_RGB_8U_INDEXED_2 | ... more
NPF_RGB_8U_INDEXED_4 | ... more
NPF_RGB_8U_INDEXED_8 | ... more
NPF_RGB_A_16S | ... more
NPF_RGB_A_16U | ... more
NPF_RGB_A_32F | ... more
NPF_RGB_A_32S | ... more
NPF_RGB_A_32U | ... more
NPF_RGB_A_64F | ... more
NPF_RGB_A_64S | ... more
NPF_RGB_A_64U | ... more
NPF_RGB_A_8S | ... more
NPF_RGB_A_8U | ... more
NPF_RGB_A_8U_INDEXED_1 | ... more
NPF_RGB_A_8U_INDEXED_2 | ... more
NPF_RGB_A_8U_INDEXED_4 | ... more
NPF_RGB_A_8U_INDEXED_8 | ... more
NPF_RGB_PA_16S | ... more
NPF_RGB_PA_16U | ... more
NPF_RGB_PA_32F | ... more
NPF_RGB_PA_32S | ... more
NPF_RGB_PA_32U | ... more
NPF_RGB_PA_64F | ... more
NPF_RGB_PA_64S | ... more
NPF_RGB_PA_64U | ... more
NPF_RGB_PA_8S | ... more
NPF_RGB_PA_8U | ... more
NPF_UNDEFINED | Indicates undefined pixel format.
NPixelFormatToString | Picks a Unicode (W) or ANSCII (A) version of the NPixelFormatToString function.


NPixelFormat.h Types

NPixelFormat.h Types
Types
Name | Description
NPixelFormat | Specifies pixel format of each pixel in the image.
NPixelFormat_ | Specifies pixel format of each pixel in the image.


NRgb Unit Files

NRgb Unit Files
Files
Name | Description
NRgb.h | Header file for NRgb Unit.


NRgb Unit Functions

NRgb Unit Functions
Legend
Functions
Name | Description
NRgbToString | Converts RGB value into NString.


NRgb Unit Macros

NRgb Unit Macros
Macros
Name | Description
NRgbToString | Picks a Unicode (W) or ANSCII (A) version of the NRgbToString function.


NRgb Unit Structs, Records, Enums

NRgb Unit Structs, Records, Enums
Legend
Structs, Records, Enums
Name | Description
NRgb_ | Represents an RGB color.


NRgb Unit Types

NRgb Unit Types
Types
Name | Description
NRgb | Defines the RGB color.


NRgb.h Functions

NRgb.h Functions
Legend
Functions
Name | Description
NRgbToString | Converts RGB value into NString.


NRgb.h Macros

NRgb.h Macros
Macros
Name | Description
NRgbToString | Picks a Unicode (W) or ANSCII (A) version of the NRgbToString function.


NRgb.h Structures

NRgb.h Structures
Legend
Structures
Name | Description
NRgb_ | Represents an RGB color.


NRgb.h Types

NRgb.h Types
Types
Name | Description
NRgb | Defines the RGB color.


NVideoFormat Unit Files

NVideoFormat Unit Files
Files
Name | Description
NVideoFormat.h | Header file for NVideoFormat module. Provides functionality for managing video formats.


NVideoFormat Unit Functions

NVideoFormat Unit Functions
Legend
Functions
Name | Description
NVideoFormatCreate | Creates default video format. Video format properties can be modified and retrieved using following functions:... more
NVideoFormatGetFrameRate | Gets frame rate of video format.
NVideoFormatGetHeight | Gets frame height in pixels for specified video format.
NVideoFormatGetInterlaceMode | Gets interlace mode for specified video format.
NVideoFormatGetPixelAspectRatio | Gets frame aspect ratio for specified video format.
NVideoFormatGetStride | Gets stride for specified video format.
NVideoFormatGetWidth | Gets frame width of specified video format.
NVideoFormatMediaSubtypeToString | Writes video format string into memory buffer.
NVideoFormatSetFrameRate | Sets video format frame rate.
NVideoFormatSetHeight | Sets video format frame height (in pixels).
NVideoFormatSetInterlaceMode | Sets video format interlace mode.
NVideoFormatSetPixelAspectRatio | Sets video format aspect ratio.
NVideoFormatSetStride | Sets stride for specified video format.
NVideoFormatSetWidth | Sets video format frame width (in pixels).


NVideoFormat Unit Macros

NVideoFormat Unit Macros
Macros
Name | Description
NVideoFormatMediaSubtypeToString | Picks a Unicode (W) or ANSCII (A) version of the NVideoFormatMediaSubtype function.
N_VIDEO_FORMAT_AI44 | Video format AI44
N_VIDEO_FORMAT_ARGB32 | Video format ARGB32.
N_VIDEO_FORMAT_AVC1 | Video format AVC1.
N_VIDEO_FORMAT_AYUV | Video format AYUV.
N_VIDEO_FORMAT_DV25 | Video format DVCPRO 25 (525-60 or 625-50).
N_VIDEO_FORMAT_DV50 | Video format DVCPRO 50 (525-60 or 625-50).
N_VIDEO_FORMAT_DVC | Video format DVC/DV Video.
N_VIDEO_FORMAT_DVH1 | Video format DVCPRO 100 (1080/60i, 1080/50i, or 720/60P).
N_VIDEO_FORMAT_DVHD | Video format HD-DVCR (1125-60 or 1250-50).
N_VIDEO_FORMAT_DVSD | Video format SDL-DVCR (525-60 or 625-50).
N_VIDEO_FORMAT_DVSL | Video format SD-DVCR (525-60 or 625-50).
N_VIDEO_FORMAT_DX50 | Video format DX50.
N_VIDEO_FORMAT_H264 | Video format H.264.
N_VIDEO_FORMAT_I420 | Video format I420.
N_VIDEO_FORMAT_IYUV | Video format IYUV.
N_VIDEO_FORMAT_L16 | Video format L16.
N_VIDEO_FORMAT_L8 | Video format L8.
N_VIDEO_FORMAT_M4S2 | Video format MPEG-4 part 2.
N_VIDEO_FORMAT_MJPG | Video format Motion JPEG.
N_VIDEO_FORMAT_MP43 | Video format Microsoft MPEG 4 codec version 3.
N_VIDEO_FORMAT_MP4S | Video format ISO MPEG 4 codec version 1.
N_VIDEO_FORMAT_MP4V | Video format MPEG-4 part 2 video.
N_VIDEO_FORMAT_MPG1 | Video format MPEG-1.
N_VIDEO_FORMAT_MSS1 | Video format Windows Media Screen codec version 1.
N_VIDEO_FORMAT_MSS2 | Video format Windows Media Video 9 Screen codec.
N_VIDEO_FORMAT_NV11 | Video format NV11.
N_VIDEO_FORMAT_NV12 | Video format NV12.
N_VIDEO_FORMAT_NV21 | Video format NV21.
N_VIDEO_FORMAT_P010 | Video format P010.
N_VIDEO_FORMAT_P016 | Video format P016.
N_VIDEO_FORMAT_P210 | Video format P210.
N_VIDEO_FORMAT_P216 | Video format P216.
N_VIDEO_FORMAT_RGB24 | Video format RGB, 24 bpp.
N_VIDEO_FORMAT_RGB32 | Video format RGB, 32 bpp.
N_VIDEO_FORMAT_RGB555 | Video format RGB 555, 16 bpp.
N_VIDEO_FORMAT_RGB565 | Video format RGB 565, 16 bpp.
N_VIDEO_FORMAT_RGB8 | Video format RGB, 8 bits per pixel.
N_VIDEO_FORMAT_UNKNOWN | Unknown video format.
N_VIDEO_FORMAT_UYVY | Video format UYVY.
N_VIDEO_FORMAT_V210 | Video format V210.
N_VIDEO_FORMAT_V216 | Video format V216.
N_VIDEO_FORMAT_V410 | Video format V40.
N_VIDEO_FORMAT_WMV1 | Video format Windows Media Video codec version 7.
N_VIDEO_FORMAT_WMV2 | Video format Windows Media Video 8 codec.
N_VIDEO_FORMAT_WMV3 | Video format Windows Media Video 9 codec.
N_VIDEO_FORMAT_WVC1 | Video format SMPTE 421M ("VC-1").
N_VIDEO_FORMAT_Y210 | Video format Y210.
N_VIDEO_FORMAT_Y216 | Video format Y216.
N_VIDEO_FORMAT_Y410 | Video format Y40.
N_VIDEO_FORMAT_Y416 | Video format Y416.
N_VIDEO_FORMAT_Y41P | Video format Y41P.
N_VIDEO_FORMAT_Y41T | Video format Y41T.
N_VIDEO_FORMAT_Y42T | Video format Y42T.
N_VIDEO_FORMAT_YUY2 | Video format YUY2.
N_VIDEO_FORMAT_YV12 | Video format YV12.
N_VIDEO_FORMAT_YVU9 | Video format YVU9.
N_VIDEO_FORMAT_YVYU | Video format YVYU.


NVideoFormat.h Functions

NVideoFormat.h Functions
Legend
Functions
Name | Description
NVideoFormatCreate | Creates default video format. Video format properties can be modified and retrieved using following functions:... more
NVideoFormatGetFrameRate | Gets frame rate of video format.
NVideoFormatGetHeight | Gets frame height in pixels for specified video format.
NVideoFormatGetInterlaceMode | Gets interlace mode for specified video format.
NVideoFormatGetPixelAspectRatio | Gets frame aspect ratio for specified video format.
NVideoFormatGetStride | Gets stride for specified video format.
NVideoFormatGetWidth | Gets frame width of specified video format.
NVideoFormatMediaSubtypeToString | Writes video format string into memory buffer.
NVideoFormatSetFrameRate | Sets video format frame rate.
NVideoFormatSetHeight | Sets video format frame height (in pixels).
NVideoFormatSetInterlaceMode | Sets video format interlace mode.
NVideoFormatSetPixelAspectRatio | Sets video format aspect ratio.
NVideoFormatSetStride | Sets stride for specified video format.
NVideoFormatSetWidth | Sets video format frame width (in pixels).


NVideoFormat.h Macros

NVideoFormat.h Macros
Macros
Name | Description
NVideoFormatMediaSubtypeToString | Picks a Unicode (W) or ANSCII (A) version of the NVideoFormatMediaSubtype function.
N_VIDEO_FORMAT_AI44 | Video format AI44
N_VIDEO_FORMAT_ARGB32 | Video format ARGB32.
N_VIDEO_FORMAT_AVC1 | Video format AVC1.
N_VIDEO_FORMAT_AYUV | Video format AYUV.
N_VIDEO_FORMAT_DV25 | Video format DVCPRO 25 (525-60 or 625-50).
N_VIDEO_FORMAT_DV50 | Video format DVCPRO 50 (525-60 or 625-50).
N_VIDEO_FORMAT_DVC | Video format DVC/DV Video.
N_VIDEO_FORMAT_DVH1 | Video format DVCPRO 100 (1080/60i, 1080/50i, or 720/60P).
N_VIDEO_FORMAT_DVHD | Video format HD-DVCR (1125-60 or 1250-50).
N_VIDEO_FORMAT_DVSD | Video format SDL-DVCR (525-60 or 625-50).
N_VIDEO_FORMAT_DVSL | Video format SD-DVCR (525-60 or 625-50).
N_VIDEO_FORMAT_DX50 | Video format DX50.
N_VIDEO_FORMAT_H264 | Video format H.264.
N_VIDEO_FORMAT_I420 | Video format I420.
N_VIDEO_FORMAT_IYUV | Video format IYUV.
N_VIDEO_FORMAT_L16 | Video format L16.
N_VIDEO_FORMAT_L8 | Video format L8.
N_VIDEO_FORMAT_M4S2 | Video format MPEG-4 part 2.
N_VIDEO_FORMAT_MJPG | Video format Motion JPEG.
N_VIDEO_FORMAT_MP43 | Video format Microsoft MPEG 4 codec version 3.
N_VIDEO_FORMAT_MP4S | Video format ISO MPEG 4 codec version 1.
N_VIDEO_FORMAT_MP4V | Video format MPEG-4 part 2 video.
N_VIDEO_FORMAT_MPG1 | Video format MPEG-1.
N_VIDEO_FORMAT_MSS1 | Video format Windows Media Screen codec version 1.
N_VIDEO_FORMAT_MSS2 | Video format Windows Media Video 9 Screen codec.
N_VIDEO_FORMAT_NV11 | Video format NV11.
N_VIDEO_FORMAT_NV12 | Video format NV12.
N_VIDEO_FORMAT_NV21 | Video format NV21.
N_VIDEO_FORMAT_P010 | Video format P010.
N_VIDEO_FORMAT_P016 | Video format P016.
N_VIDEO_FORMAT_P210 | Video format P210.
N_VIDEO_FORMAT_P216 | Video format P216.
N_VIDEO_FORMAT_RGB24 | Video format RGB, 24 bpp.
N_VIDEO_FORMAT_RGB32 | Video format RGB, 32 bpp.
N_VIDEO_FORMAT_RGB555 | Video format RGB 555, 16 bpp.
N_VIDEO_FORMAT_RGB565 | Video format RGB 565, 16 bpp.
N_VIDEO_FORMAT_RGB8 | Video format RGB, 8 bits per pixel.
N_VIDEO_FORMAT_UNKNOWN | Unknown video format.
N_VIDEO_FORMAT_UYVY | Video format UYVY.
N_VIDEO_FORMAT_V210 | Video format V210.
N_VIDEO_FORMAT_V216 | Video format V216.
N_VIDEO_FORMAT_V410 | Video format V40.
N_VIDEO_FORMAT_WMV1 | Video format Windows Media Video codec version 7.
N_VIDEO_FORMAT_WMV2 | Video format Windows Media Video 8 codec.
N_VIDEO_FORMAT_WMV3 | Video format Windows Media Video 9 codec.
N_VIDEO_FORMAT_WVC1 | Video format SMPTE 421M ("VC-1").
N_VIDEO_FORMAT_Y210 | Video format Y210.
N_VIDEO_FORMAT_Y216 | Video format Y216.
N_VIDEO_FORMAT_Y410 | Video format Y40.
N_VIDEO_FORMAT_Y416 | Video format Y416.
N_VIDEO_FORMAT_Y41P | Video format Y41P.
N_VIDEO_FORMAT_Y41T | Video format Y41T.
N_VIDEO_FORMAT_Y42T | Video format Y42T.
N_VIDEO_FORMAT_YUY2 | Video format YUY2.
N_VIDEO_FORMAT_YV12 | Video format YV12.
N_VIDEO_FORMAT_YVU9 | Video format YVU9.
N_VIDEO_FORMAT_YVYU | Video format YVYU.


Png Unit Files

Png Unit Files
Files
Name | Description
Png.h | Header file for Png module. Provides functionality for loading and saving images in PNG format.


Png Unit Functions

Png Unit Functions
Legend
Functions
Name | Description
PngInfoGetCompressionLevel | Retrieves compression level of a PNG image.
PngInfoSetCompressionLevel | Sets compression level of a PNG image.


Png Unit Macros

Png Unit Macros
Macros
Name | Description
PNG_DEFAULT_COMPRESSION_LEVEL | Specifies default PNG compression level.


Png.h Functions

Png.h Functions
Legend
Functions
Name | Description
PngInfoGetCompressionLevel | Retrieves compression level of a PNG image.
PngInfoSetCompressionLevel | Sets compression level of a PNG image.


Png.h Macros

Png.h Macros
Macros
Name | Description
PNG_DEFAULT_COMPRESSION_LEVEL | Specifies default PNG compression level.


Tiff Unit Files

Tiff Unit Files
Files
Name | Description
Tiff.h | Header file for Tiff module. Provides functionality for loading images in TIFF format.


Wsq Unit Files

Wsq Unit Files
Files
Name | Description
Wsq.h | Header file for Wsq module. Provides functionality for loading and saving images in WSQ format.


Wsq Unit Functions

Wsq Unit Functions
Legend
Functions
Name | Description
WsqInfoGetBitRate | Gets WSQ image bit rate (compression level)
WsqInfoGetImplementationNumber | Gets WSQ image implementation number.
WsqInfoGetNistCom | Retrieves the NIST comment of the specified WSQ info file.
WsqInfoHasNistCom | Checks whether the WSQ info file has a NIST comment.
WsqInfoSetBitRate | Sets WSQ image bit rate (compression level)
WsqInfoSetHasNistCom | Sets whether the WSQ info file has a NIST comment.


Wsq Unit Macros

Wsq Unit Macros
Macros
Name | Description
WSQ_DEFAULT_BIT_RATE | Specifies default bit rate (compression level).
WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_DEBIAN_AMD64_LEGACY | Represents Neurotechnology Debian AMD64 (Legacy version) implementation.
WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_DEBIAN_I386_LEGACY | Represents Neurotechnology Debian I386 (Legacy version) implementation.
WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_MACOSX_INTEL64 | Represents Neurotechnology MacOS X Intel 64 implementation.
WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_MACOSX_INTEL_LEGACY | Represents Neurotechnology MacOS X Intel (Legacy version) implementation.
WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_MACOSX_POWERPC_LEGACY | Represents Neurotechnology MacOS X PowerPC (Legacy version) implementation.
WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_WIN32_X86 | Represents Neurotechnology Windows 32 x86 implementation.
WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_WIN64_X64 | Represents Neurotechnology Windows 64 x64 implementation.
WSQ_RECOVER_CORRUPT_FILE | Image loading flag which attempts to load an image even if it cannot be fully read.


Wsq.h Functions

Wsq.h Functions
Legend
Functions
Name | Description
WsqInfoGetBitRate | Gets WSQ image bit rate (compression level)
WsqInfoGetImplementationNumber | Gets WSQ image implementation number.
WsqInfoGetNistCom | Retrieves the NIST comment of the specified WSQ info file.
WsqInfoHasNistCom | Checks whether the WSQ info file has a NIST comment.
WsqInfoSetBitRate | Sets WSQ image bit rate (compression level)
WsqInfoSetHasNistCom | Sets whether the WSQ info file has a NIST comment.


Wsq.h Macros

Wsq.h Macros
Macros
Name | Description
WSQ_DEFAULT_BIT_RATE | Specifies default bit rate (compression level).
WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_DEBIAN_AMD64_LEGACY | Represents Neurotechnology Debian AMD64 (Legacy version) implementation.
WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_DEBIAN_I386_LEGACY | Represents Neurotechnology Debian I386 (Legacy version) implementation.
WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_MACOSX_INTEL64 | Represents Neurotechnology MacOS X Intel 64 implementation.
WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_MACOSX_INTEL_LEGACY | Represents Neurotechnology MacOS X Intel (Legacy version) implementation.
WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_MACOSX_POWERPC_LEGACY | Represents Neurotechnology MacOS X PowerPC (Legacy version) implementation.
WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_WIN32_X86 | Represents Neurotechnology Windows 32 x86 implementation.
WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_WIN64_X64 | Represents Neurotechnology Windows 64 x64 implementation.
WSQ_RECOVER_CORRUPT_FILE | Image loading flag which attempts to load an image even if it cannot be fully read.


NClothingDetails Unit Functions

NClothingDetails Unit Functions
Legend
Functions
Name | Description
NClothingDetailsGetGender | Gets subject's gender.
NClothingDetailsGetGenderConfidence | Gets subject's gender confidence value.
NClothingDetailsGetKnownValues | Gets known values from NClothingDetails.
NClothingDetailsGetValue | Gets a value specified by index from NClothingDetails.
NClothingDetailsGetValueCount | Gets count of values in NClothingDetails.
NClothingDetailsGetValues | Gets all values from NClothingDetails.
N_DECLARE_OBJECT_TYPE | Declares object type with specified name.


NLicensePlate Unit Functions

NLicensePlate Unit Functions
Legend
Functions
Name | Description
NLicensePlateDetailsGetBestLicensePlate | Gets the best license plate specified by an index.
NLicensePlateDetailsGetBestLicensePlateCount | Gets the best license plates count in NLicensePlateDetails.
NLicensePlateDetailsGetBestLicensePlates | Gets all best license plates.
NLicensePlateDetailsGetCurrentLicensePlate | Gets the current license plate specified by an index.
NLicensePlateDetailsGetCurrentLicensePlateCount | Gets the current license plates count in NLicensePlateDetails.
NLicensePlateDetailsGetCurrentLicensePlates | Gets all current license plates.
NLicensePlateGetBoundingBox | Gets license plate's bounding box rectangle.
NLicensePlateGetDetectionConfidence | Gets license plate detection confidence value.
NLicensePlateGetFrameIndex | Gets index of a frame where license plate was found.
NLicensePlateGetOcrConfidence | Gets license plate's characters recognition confidence value.
NLicensePlateGetOrigin | Gets licence plate country code value (3 characters).
NLicensePlateGetRectangle | Gets license plate's bounding box rectangle.
NLicensePlateGetRotation | Gets rotation of the Rectangle.
NLicensePlateGetType | Gets license plate's type value (general, taxi, military, etc.).
NLicensePlateGetValue | Gets vehicle's number from a license plate.


See Also

See Also
See Also

NLicensePlateGetBoundingBox Function


NNameConfidencePair Unit Functions

NNameConfidencePair Unit Functions
Legend
Functions
Name | Description
NNameConfidencePairCopy | Copies one NNameConfidencePair structure to another.
NNameConfidencePairCreate | Creates a new instance of NNameConfidencePair.
NNameConfidencePairDispose | Disposes specified NNameConfidencePair object.
NNameConfidencePairSet | Sets NNameConfidencePair value.


NNameConfidencePair Unit Structs, Records, Enums

NNameConfidencePair Unit Structs, Records, Enums
Legend
Structs, Records, Enums
Name | Description
NNameConfidencePair_ | Structure containing name and/or confidence values.


NSurveillance Unit Files

NSurveillance Unit Files
Files
Name | Description
NSurveillanceEventDetails.h | A header file containing containing EventDetails functions.
NsedMatchResult.h | A header file containing containing functions for surveillance matching results.
NSurveillance.h | Main NSurveillance library C header file containing function declaration and event type declarations.


NSurveillance Unit Functions

NSurveillance Unit Functions
Legend
Functions
Name | Description
NSurveillanceAddEventCallbackEx | ... more
NSurveillanceAddEventEx | Adds an event to Surveillance framework.
NSurveillanceAddIsRunningChanged | Adds user specified event for managing Surveillance changed events.
NSurveillanceAddIsRunningChangedCallback | Adds user specified callback for managing Surveillance changed events.
NSurveillanceAddSource | Adds capturing source to the Surveillance framework. The capturing source must not be capturing or being already in use by other library.
NSurveillanceAddSourceCollectionChanged | Adds user specified event for managing source collection changed events.
NSurveillanceAddSourceCollectionChangedCallback | Adds user specified callback for managing source collection events.
NSurveillanceAddTemplate | ... more
NSurveillanceClearSources | ... more
NSurveillanceCreate | Creates NSurveillance object.
NSurveillanceDetectionDetailsCreate | Creates a new instance of surveillance detection details object.
NSurveillanceDetectionDetailsGetClothingDetails | Gets subject's clothing details.
NSurveillanceDetectionDetailsGetDetectionConfidence | Gets detection confidence value.
NSurveillanceDetectionDetailsGetFace | Gets detected face object.
NSurveillanceDetectionDetailsGetFaceRectangle | Gets bounding box rectangle of a detected subject's face.
NSurveillanceDetectionDetailsGetLicensePlateDetails | Gets vehicle's license plate details.
NSurveillanceDetectionDetailsGetObjectColor | Gets color of a detected surveillance object.
NSurveillanceDetectionDetailsGetObjectType | Gets type of a detected surveillance object.
NSurveillanceDetectionDetailsGetRectangle | Gets bounding box rectangle of a detected object.
NSurveillanceDetectionDetailsGetSubjectType | ... more
NSurveillanceDetectionDetailsGetVehicleDetails | Gets vehicle details.
NSurveillanceDetectionDetailsSetClothingDetails | Sets subject's clothing details.
NSurveillanceDetectionDetailsSetDetectionConfidence | Sets detection confidence value.
NSurveillanceDetectionDetailsSetFace | Sets face object.
NSurveillanceDetectionDetailsSetFaceRectangle | Sets bounding box rectangle of a detected subject's face.
NSurveillanceDetectionDetailsSetLicensePlateDetails | Sets vehicle's license plate details.
NSurveillanceDetectionDetailsSetObjectColor | Sets color of a detected surveillance object.
NSurveillanceDetectionDetailsSetObjectType | Sets type of a detected surveillance object.
NSurveillanceDetectionDetailsSetRectangle | Sets bounding box rectangle of a detected object.
NSurveillanceDetectionDetailsSetSubjectType | ... more
NSurveillanceDetectionDetailsSetVehicleDetails | Sets vehicle details.
NSurveillanceDetectionResultGetDetails | Gets an array of all detection results.
NSurveillanceDetectionResultGetDetailsAt | Gets surveillance detection result by an index.
NSurveillanceDetectionResultGetDetailsCount | Gets detection results count.
NSurveillanceDetectionResultGetImage | Gets an image containing a detected surveillance object.
NSurveillanceDetectionResultGetModalityType | Gets a type of modality used for surveillance and objects detection.
NSurveillanceEngineCreate | Creates a new instance of NSurveillanceEngine.
NSurveillanceEngineDetect | Detects Surveillance object from the specified image.
NSurveillanceEngineDetectAsync | Detects Surveillance object from the specified image (asynchronous operation).
NSurveillanceEngineInit | Initializes specified NSurveillanceEngine.
NSurveillanceGetDeviceManager | Gets NDeviceManager associated with specified NSurveillance handle.
NSurveillanceGetSource | Retrieves a handle for previously added capturing source.
NSurveillanceGetSourceCount | ... more
NSurveillanceGetSources | Retrieves the surveillance sources of the specified NSurveillance object.
NSurveillanceGetTemplateIdsN | ... more
NSurveillanceIsRunning | Checks if NSurveillance object is running.
NSurveillanceOptimizeAllModelsAsync | Optimizes specified NSureveillance models by specified modalities (asynchronous operation).
NSurveillanceOptimizeModelsAsync | Optimizes all NSureveillance models by specified modalities (asynchronous operation).
NSurveillanceRemoveAllTemplates | Removed templates from internal Surveillance database.
NSurveillanceRemoveEventCallbackEx | ... more
NSurveillanceRemoveEventEx | Removes an event from Surveillance framework.
NSurveillanceRemoveIsRunningChanged | Removes user specified event for managing Surveillance changed events.
NSurveillanceRemoveIsRunningChangedCallback | Removes user specified callback for managing Surveillance changed events.
NSurveillanceRemoveSourceAt | ... more
NSurveillanceRemoveSourceCollectionChanged | Removes user specified event for managing source collection changed events.
NSurveillanceRemoveSourceCollectionChangedCallback | Removes user specified callback for managing source collection changed events.
NSurveillanceRemoveTemplateN | Removes a template from Surveillance internal database.
NSurveillanceStart | ... more
NSurveillanceStartAsync | Enables callbacks and starts Surveillance (asynchronous operation). After surveillance is no longer needed NSurveillanceStop should be called.
NSurveillanceStartSource | Starts specified surveillance source.
NSurveillanceStartSourceAsync | Starts specified surveillance source (asynchronous operation).
NSurveillanceStop | ... more
NSurveillanceStopAsync | Stops surveillance and all sources (asynchronous operation).
NSurveillanceStopSource | Stops specified surveillance source.
NSurveillanceStopSourceAsync | Stops specified surveillance source (asynchronous operation).
NsedGetAttributes | Gets face attributes from specified surveillance event details.
NsedGetAttributesContainsDetails | Checks whether specified surveillance event contains extraction details.
NsedGetBestDetails | Gets an event containing best details for a tracked subject.
NsedGetBestMatchResult | Gets best face match results from the specified frame.
NsedGetBestMatchResultCount | Gets best face match results count from the specified frame.
NsedGetBestMatchResults | Gets best face match results from the specified frame.
NsedGetClothingDetails | Gets ClothingDetails object containing subject's clothing details and gender.
NsedGetCurrentMatchResult | Gets match result by an index.
NsedGetCurrentMatchResultCount | Gets match results count.
NsedGetCurrentMatchResults | Gets all current match results.
NsedGetDetectedFaces | Gets the list of detected faces attributes.
NsedGetDetectionConfidence | Gets detection confidence value (NFloat type).
NsedGetError | Returns the most recent error for the specified surveillance event.
NsedGetFace | Gets face of the specified event.
NsedGetFaceConfidence | Retrieves face confidence value of the specified event. Indicates whether the event object is a face.
NsedGetFaceRectangle | Gets bounding box rectangle of a detected subject's face.
NsedGetFrameIndex | Gets frame index (the number of captured images prior to this event).
NsedGetLicensePlateDetails | Gets vehicle's license plate details.
NsedGetMergedSubject | Gets a subject that was merged with current subject. Only applicable during SubjectMerged event.
NsedGetModalityType | ... more
NsedGetObjectColor | Gets color of a detected surveillance object.
NsedGetObjectDirection | Gets NSurveillanceObjectDirection object.
NsedGetObjectType | Gets type of a detected surveillance object.
NsedGetOriginalImageEx | Retrieves the originally captured image.
NsedGetRectangle | Retrieves the rectangle selection of the original image.
NsedGetSource | Gets Surveillance source.
NsedGetSplitFromSubject | ... more
NsedGetSubjectTemplate | Gets generalized Subject template.
NsedGetSubjectType | ... more
NsedGetTemplateEx | Retrieves the extracted face template.
NsedGetTimeStamp | Gets the date and time of the captured image.
NsedGetTraceIndex | Gets an index of the current subject being tracked. The index is zero-based and represents unique id of subject being tracked at the current moment. After subject disappears this index becomes invalid.
NsedGetVehicleDetails | Gets vehicle details.
NsedMatchResultCreate | Creates a new instance of NsedMatchResult.
NsedMatchResultCreateEx | Creates a new instance of NsedMatchResult.
NsedMatchResultGetId | Gets the Id (string) of matched object.
NsedMatchResultGetMatchingDetails | Gets matching details from NsedMatchResult.
NsedMatchResultGetScore | Gets surveillance matching score.


NSurveillance Unit Structs, Records, Enums

NSurveillance Unit Structs, Records, Enums
Legend
Structs, Records, Enums
Name | Description
NDetectorScaleCount_ | Enumerates detector scale count. Bigger values improves quality, but requires more processing power.
NGpuIndex_ | Enumerates GPU units by index.
NSurveillanceEventType_ | ... more
NSurveillanceObjectColorDetails_ | Enumerates object color and color confidence values.
NSurveillanceObjectColor_ | Enumerates tracked object color values.
NSurveillanceObjectDirectionDetails_ | Represents detected or tracked object direction confidence values.
NSurveillanceObjectDirection_ | Represents detected or tracked object direction values.
NSurveillanceObjectTypeDetails_ | Enumerates surveillance object type confidence values.
NSurveillanceObjectType_ | Enumerates surveillance objects.
NDetectorScaleCount | Enumerates detector scale count. Bigger values improves quality, but requires more processing power.
NGpuIndex | Enumerates GPU units by index.
NSurveillanceObjectColor | Enumerates tracked object color values.
NSurveillanceObjectDirection | Represents detected or tracked object direction values.
NSurveillanceObjectType | Enumerates surveillance objects.
NSurveillanceEventType | ... more


NSurveillanceEventDetails.h Enumerations

NSurveillanceEventDetails.h Enumerations
Legend
Enumerations
Name | Description
NSurveillanceObjectColor_ | Enumerates tracked object color values.
NSurveillanceObjectDirection_ | Represents detected or tracked object direction values.
NSurveillanceObjectType_ | Enumerates surveillance objects.
NSurveillanceObjectColor | Enumerates tracked object color values.
NSurveillanceObjectDirection | Represents detected or tracked object direction values.
NSurveillanceObjectType | Enumerates surveillance objects.


NSurveillanceEventDetails.h Functions

NSurveillanceEventDetails.h Functions
Legend
Functions
Name | Description
NsedGetAttributes | Gets face attributes from specified surveillance event details.
NsedGetAttributesContainsDetails | Checks whether specified surveillance event contains extraction details.
NsedGetBestDetails | Gets an event containing best details for a tracked subject.
NsedGetBestMatchResult | Gets best face match results from the specified frame.
NsedGetBestMatchResultCount | Gets best face match results count from the specified frame.
NsedGetBestMatchResults | Gets best face match results from the specified frame.
NsedGetClothingDetails | Gets ClothingDetails object containing subject's clothing details and gender.
NsedGetCurrentMatchResult | Gets match result by an index.
NsedGetCurrentMatchResultCount | Gets match results count.
NsedGetCurrentMatchResults | Gets all current match results.
NsedGetDetectedFaces | Gets the list of detected faces attributes.
NsedGetDetectionConfidence | Gets detection confidence value (NFloat type).
NsedGetError | Returns the most recent error for the specified surveillance event.
NsedGetFace | Gets face of the specified event.
NsedGetFaceConfidence | Retrieves face confidence value of the specified event. Indicates whether the event object is a face.
NsedGetFaceRectangle | Gets bounding box rectangle of a detected subject's face.
NsedGetFrameIndex | Gets frame index (the number of captured images prior to this event).
NsedGetLicensePlateDetails | Gets vehicle's license plate details.
NsedGetMergedSubject | Gets a subject that was merged with current subject. Only applicable during SubjectMerged event.
NsedGetModalityType | ... more
NsedGetObjectColor | Gets color of a detected surveillance object.
NsedGetObjectDirection | Gets NSurveillanceObjectDirection object.
NsedGetObjectType | Gets type of a detected surveillance object.
NsedGetOriginalImageEx | Retrieves the originally captured image.
NsedGetRectangle | Retrieves the rectangle selection of the original image.
NsedGetSource | Gets Surveillance source.
NsedGetSplitFromSubject | ... more
NsedGetSubjectTemplate | Gets generalized Subject template.
NsedGetSubjectType | ... more
NsedGetTemplateEx | Retrieves the extracted face template.
NsedGetTimeStamp | Gets the date and time of the captured image.
NsedGetTraceIndex | Gets an index of the current subject being tracked. The index is zero-based and represents unique id of subject being tracked at the current moment. After subject disappears this index becomes invalid.
NsedGetVehicleDetails | Gets vehicle details.


NSurveillanceEventDetails.h Structures

NSurveillanceEventDetails.h Structures
Legend
Structures
Name | Description
NSurveillanceObjectColorDetails_ | Enumerates object color and color confidence values.
NSurveillanceObjectDirectionDetails_ | Represents detected or tracked object direction confidence values.
NSurveillanceObjectTypeDetails_ | Enumerates surveillance object type confidence values.


NsedMatchResult.h Functions

NsedMatchResult.h Functions
Legend
Functions
Name | Description
NsedMatchResultCreate | Creates a new instance of NsedMatchResult.
NsedMatchResultCreateEx | Creates a new instance of NsedMatchResult.
NsedMatchResultGetId | Gets the Id (string) of matched object.
NsedMatchResultGetMatchingDetails | Gets matching details from NsedMatchResult.
NsedMatchResultGetScore | Gets surveillance matching score.


NSurveillance.h Enumerations

NSurveillance.h Enumerations
Legend
Enumerations
Name | Description
NDetectorScaleCount_ | Enumerates detector scale count. Bigger values improves quality, but requires more processing power.
NGpuIndex_ | Enumerates GPU units by index.
NSurveillanceEventType_ | ... more
NDetectorScaleCount | Enumerates detector scale count. Bigger values improves quality, but requires more processing power.
NGpuIndex | Enumerates GPU units by index.
NSurveillanceEventType | ... more


NSurveillance.h Functions

NSurveillance.h Functions
Legend
Functions
Name | Description
NSurveillanceAddEventCallbackEx | ... more
NSurveillanceAddEventEx | Adds an event to Surveillance framework.
NSurveillanceAddIsRunningChanged | Adds user specified event for managing Surveillance changed events.
NSurveillanceAddIsRunningChangedCallback | Adds user specified callback for managing Surveillance changed events.
NSurveillanceAddSource | Adds capturing source to the Surveillance framework. The capturing source must not be capturing or being already in use by other library.
NSurveillanceAddSourceCollectionChanged | Adds user specified event for managing source collection changed events.
NSurveillanceAddSourceCollectionChangedCallback | Adds user specified callback for managing source collection events.
NSurveillanceAddTemplate | ... more
NSurveillanceClearSources | ... more
NSurveillanceCreate | Creates NSurveillance object.
NSurveillanceGetDeviceManager | Gets NDeviceManager associated with specified NSurveillance handle.
NSurveillanceGetSource | Retrieves a handle for previously added capturing source.
NSurveillanceGetSourceCount | ... more
NSurveillanceGetSources | Retrieves the surveillance sources of the specified NSurveillance object.
NSurveillanceGetTemplateIdsN | ... more
NSurveillanceIsRunning | Checks if NSurveillance object is running.
NSurveillanceOptimizeAllModelsAsync | Optimizes specified NSureveillance models by specified modalities (asynchronous operation).
NSurveillanceOptimizeModelsAsync | Optimizes all NSureveillance models by specified modalities (asynchronous operation).
NSurveillanceRemoveAllTemplates | Removed templates from internal Surveillance database.
NSurveillanceRemoveEventCallbackEx | ... more
NSurveillanceRemoveEventEx | Removes an event from Surveillance framework.
NSurveillanceRemoveIsRunningChanged | Removes user specified event for managing Surveillance changed events.
NSurveillanceRemoveIsRunningChangedCallback | Removes user specified callback for managing Surveillance changed events.
NSurveillanceRemoveSourceAt | ... more
NSurveillanceRemoveSourceCollectionChanged | Removes user specified event for managing source collection changed events.
NSurveillanceRemoveSourceCollectionChangedCallback | Removes user specified callback for managing source collection changed events.
NSurveillanceRemoveTemplateN | Removes a template from Surveillance internal database.
NSurveillanceStart | ... more
NSurveillanceStartAsync | Enables callbacks and starts Surveillance (asynchronous operation). After surveillance is no longer needed NSurveillanceStop should be called.
NSurveillanceStartSource | Starts specified surveillance source.
NSurveillanceStartSourceAsync | Starts specified surveillance source (asynchronous operation).
NSurveillanceStop | ... more
NSurveillanceStopAsync | Stops surveillance and all sources (asynchronous operation).
NSurveillanceStopSource | Stops specified surveillance source.
NSurveillanceStopSourceAsync | Stops specified surveillance source (asynchronous operation).


NSurveillanceSource Unit Files

NSurveillanceSource Unit Files
Files
Name | Description
NSurveillanceSource.h | A header file containing containing functions operating NSurveillanceSource objects.


NSurveillanceSource Unit Functions

NSurveillanceSource Unit Functions
Legend
Functions
Name | Description
NSurveillanceSourceAddIsCapturingChanged | Adds user specified event for managing Surveillance capturing changed events.
NSurveillanceSourceAddIsCapturingChangedCallback | Adds user specified callback for managing Surveillance changed events.
NSurveillanceSourceCreate | Creates a new NSurveillanceSource object.
NSurveillanceSourceCreateFromCameraEx | Creates a new NSurveillanceSource object from the specified camera.
NSurveillanceSourceCreateFromMediaReaderEx | Creates a new NSurveillanceSource object from the specified media reader.
NSurveillanceSourceGetCamera | Gets a camera associated with the specified NSurveillanceSource.
NSurveillanceSourceGetCurrentFormat | Gets current media format used in surveillance.
NSurveillanceSourceGetError | Retrieves the exception thrown by the specified NSurveillanceSource.
NSurveillanceSourceGetFormats | Gets all formats supported by camera or video.
NSurveillanceSourceGetLength | Retrieves the length of the specified NSurveillanceSource.
NSurveillanceSourceGetModalityType | Gets a type of modality used for surveillance source.
NSurveillanceSourceGetPosition | Retrieves the position in the specified NSurveillanceSource.
NSurveillanceSourceGetRegionOfInterest | Gets region of interest rectangle.
NSurveillanceSourceGetState | Gets the state of the specified NSurveillanceSource object.
NSurveillanceSourceGetType | Gets the type of the specified NSurveillanceSource object.
NSurveillanceSourceGetVideo | Gets the video associated with specified NSurveillanceSource.
NSurveillanceSourceGetWarning | Gets the warning set internally by processing NSurveillanceSource.
NSurveillanceSourceRemoveIsCapturingChanged | Adds user specified event for managing Surveillance changed events.
NSurveillanceSourceRemoveIsCapturingChangedCallback | Adds user specified callback for managing Surveillance changed events.
NSurveillanceSourceSetCamera | Sets the camera associated with the specified NSurveillanceSource.
NSurveillanceSourceSetCurrentFormat | Sets current media format used in surveillance.
NSurveillanceSourceSetModalityType | Sets a type of modality used for surveillance source.
NSurveillanceSourceSetRegionOfInterest | Sets region of interest rectangle.
NSurveillanceSourceSetVideo | Sets the video associated with the specified NSurveillanceSource.


NSurveillanceSource Unit Structs, Records, Enums

NSurveillanceSource Unit Structs, Records, Enums
Legend
Structs, Records, Enums
Name | Description
NSurveillanceModalityType_ | Enumerates surveillance modality types.
NSurveillanceSourceType_ | Enumerates NSurveillanceSource types.
NSurveillanceModalityType | Enumerates surveillance modality types.
NSurveillanceSourceType | Enumerates NSurveillanceSource types.


NSurveillanceSource.h Enumerations

NSurveillanceSource.h Enumerations
Legend
Enumerations
Name | Description
NSurveillanceModalityType_ | Enumerates surveillance modality types.
NSurveillanceSourceType_ | Enumerates NSurveillanceSource types.
NSurveillanceModalityType | Enumerates surveillance modality types.
NSurveillanceSourceType | Enumerates NSurveillanceSource types.


NSurveillanceSource.h Functions

NSurveillanceSource.h Functions
Legend
Functions
Name | Description
NSurveillanceSourceAddIsCapturingChanged | Adds user specified event for managing Surveillance capturing changed events.
NSurveillanceSourceAddIsCapturingChangedCallback | Adds user specified callback for managing Surveillance changed events.
NSurveillanceSourceCreate | Creates a new NSurveillanceSource object.
NSurveillanceSourceCreateFromCameraEx | Creates a new NSurveillanceSource object from the specified camera.
NSurveillanceSourceCreateFromMediaReaderEx | Creates a new NSurveillanceSource object from the specified media reader.
NSurveillanceSourceGetCamera | Gets a camera associated with the specified NSurveillanceSource.
NSurveillanceSourceGetCurrentFormat | Gets current media format used in surveillance.
NSurveillanceSourceGetError | Retrieves the exception thrown by the specified NSurveillanceSource.
NSurveillanceSourceGetFormats | Gets all formats supported by camera or video.
NSurveillanceSourceGetLength | Retrieves the length of the specified NSurveillanceSource.
NSurveillanceSourceGetModalityType | Gets a type of modality used for surveillance source.
NSurveillanceSourceGetPosition | Retrieves the position in the specified NSurveillanceSource.
NSurveillanceSourceGetRegionOfInterest | Gets region of interest rectangle.
NSurveillanceSourceGetState | Gets the state of the specified NSurveillanceSource object.
NSurveillanceSourceGetType | Gets the type of the specified NSurveillanceSource object.
NSurveillanceSourceGetVideo | Gets the video associated with specified NSurveillanceSource.
NSurveillanceSourceGetWarning | Gets the warning set internally by processing NSurveillanceSource.
NSurveillanceSourceRemoveIsCapturingChanged | Adds user specified event for managing Surveillance changed events.
NSurveillanceSourceRemoveIsCapturingChangedCallback | Adds user specified callback for managing Surveillance changed events.
NSurveillanceSourceSetCamera | Sets the camera associated with the specified NSurveillanceSource.
NSurveillanceSourceSetCurrentFormat | Sets current media format used in surveillance.
NSurveillanceSourceSetModalityType | Sets a type of modality used for surveillance source.
NSurveillanceSourceSetRegionOfInterest | Sets region of interest rectangle.
NSurveillanceSourceSetVideo | Sets the video associated with the specified NSurveillanceSource.


NTrackingDetails Unit Functions

NTrackingDetails Unit Functions
Legend
Functions
Name | Description
NTrackingDetailsGetAttributes | Gets face attributes (like age, gender, emotions and other) of a detected face.
NTrackingDetailsGetAttributesContainsDetails | ... more
NTrackingDetailsGetFrameIndex | Gets frame index.
NTrackingDetailsGetLicensePlate | Gets license plate specified by an index.
NTrackingDetailsGetLicensePlateCount | Gets license plates count in license plates collection.
NTrackingDetailsGetLicensePlates | Gets all license plates.
NTrackingDetailsGetMatchResult | Gets subject's matching result specified by an index.
NTrackingDetailsGetMatchResultCount | Gets subject's matching result count.
NTrackingDetailsGetMatchResults | Gets all subject's matching results.
NTrackingDetailsGetRectangle | Gets rectangle of bounding box of a tracked object.
NTrackingDetailsGetSubjectType | Gets which surveillance modalities was detected for a subject.
NTrackingDetailsGetTimeStamp | Gets time stamp from tracking details.


NVehicleDetails Unit Functions

NVehicleDetails Unit Functions
Legend
Functions
Name | Description
NVehicleDetailsGetKnownMakes | Gets the array of known vehicle makes (names of vehicle manufacturers).
NVehicleDetailsGetKnownModels | Gets the array of all known vehicle models.
NVehicleDetailsGetKnownModelsByMake | Gets the array of known vehicle models of the specified vehicle make.
NVehicleDetailsGetKnownTags | Gets all known vehicle body types (like sedan, coupe, bus, tractor, etc.).
NVehicleDetailsGetModel | Gets vehicle model specified by an index.
NVehicleDetailsGetModelCount | Gets vehicle models count.
NVehicleDetailsGetModels | Gets all vehicle models.
NVehicleDetailsGetOrientation | Gets vehicle orientation value (Front, Back, Left, FrontLeft, etc.).
NVehicleDetailsGetOrientationAngle | Gets an angle of vehicle orientation.
NVehicleDetailsGetOrientationConfidence | Gets confidence value of vehicle's orientation.
NVehicleDetailsGetTag | Gets vehicle body type (tag).
NVehicleDetailsGetTagCount | Gets vehicle body types count.
NVehicleDetailsGetTags | Gets vehicle body types (tags).
NVehicleModelGetMake | Gets vehicle's make by vehicle model.


NVehicleDetails Unit Structs, Records, Enums

NVehicleDetails Unit Structs, Records, Enums
Legend
Structs, Records, Enums
Name | Description
NVehicleOrientation_ | Enumerates vehicle orientation values.
NVehicleOrientation | Enumerates vehicle orientation values.


NGpuJpegEncoder Unit Functions

NGpuJpegEncoder Unit Functions
Legend
Functions
Name | Description
NGpuJpegEncoderCreate | Creates a new instance NGpuJpegEncoder by specified index.
NGpuJpegEncoderEncode | Converts provided NImage object to Jpeg using GPU and returns as NBuffer object.
NGpuJpegEncoderScaleAndEncode | Rescales and converts provided NImage object to Jpeg using GPU and returns as NBuffer object.


NGpuJpegEncoder Unit Structs, Records, Enums

NGpuJpegEncoder Unit Structs, Records, Enums
Legend
Structs, Records, Enums
Name | Description
NScaleMethod_ | Image rescale algorithm.
NScaleMethod | Image rescale algorithm.


.NET Reference Functions

.NET Reference Functions
Legend
Functions
Name | Description
NLicensingServiceGetBinPath | Gets the binary path (path to pg.exe/pgd) to the license.
NLicensingServiceGetConfPath | Gets path to licensing service configuration file (pgd.conf).
NLicensingServiceGetStatus | Gets the status of the licensing service.
NLicensingServiceInstall | Installs licensing service.
NLicensingServiceIsTrial | Checks whether the licensing service is trial.
NLicensingServiceStart | Starts licensing service.
NLicensingServiceStop | Stops licensing service.
NLicensingServiceUninstall | Uninstalls licensing service.


.NET Reference Macros

.NET Reference Macros
Macros
Name | Description
NLicensingServiceInstall | Picks a Unicode (W) or ANSCII (A) version of the NLicensingServiceInstall function.


.NET Reference Structs, Records, Enums

.NET Reference Structs, Records, Enums
Legend
Structs, Records, Enums
Name | Description
NLicensingServiceStatus_ | Enumerates licensing service status values.
NLicensingServiceStatus | Enumerates licensing service status values.


Neurotec Namespace Classes

Neurotec Namespace Classes
Legend
Classes
Name | Description
ErrorSuppressedEventArgs | Provides functionality for a suppressed error.
NArray | Provides functionality for working with arrays.
NAsyncOperation | Provides functionality for working with asynchronous operations. Asynchronous operations are functions and methods which return instantly, providing an object which can be used for operation's proper completion.
NComplex | Represents a complex number.
NCore | This class supports internal Neurotechnology libraries infrastructure and should not be used directly in your code.
NDisposable | Provides a method to release allocated resources.
NError | Defines error codes used in Neurotechnology components.
NExpandableObject | Provides functionality for retrieving information about specified object.
NIndexPair | Represents pair of indexes.
NModule | Performs reflection on a module.
NObject | Provides functionality for retrieving information about specified object.
NProcessorInfo | Provides functionality for getting processor information.
NPropertyBag | Represents a property bag in which the object can persistently save its properties.
NRange | Represents range.
NRational | Represents a signed rational number.
NType | Manages object types.
NTypes | Manages object types.
NURational | Represents an unsigned rational number.
NValue | Provides functionality for management and conversion of values of different types.
NVersion | Manages version information.
NVersionRange | Manages version ranges.


Legend

Legend
Legend
Class
Structure
static
abstract
Enumeration


Neurotec Namespace Structs, Records, Enums

Neurotec Namespace Structs, Records, Enums
Legend
Structs, Records, Enums
Name | Description
NAsyncStatus | Enumerates asynchronous operation statuses.
NAttributes | Enumerates value attributes.
NMemoryType | Enumerates memory type options.
NModuleOptions | Enumerates module options.
NOSFamily | Enumerates operating system families.
NProcessorFeature | Specifies the processor's feature flag.
NProcessorVendor | Specifies the processor's vendor name.
NTypeCode | Enumerates type codes.


Legend

Legend
Legend
Constructor
Property


ErrorSuppressedEventArgs Class Members

ErrorSuppressedEventArgs Class Members
Legend
Members
Methods
Name | Description
ErrorSuppressedEventArgs | Initializes a new instance of ErrorSuppressedEventArgs class.
ErrorSuppressedEventArgs Properties
Name | Description
Error | Gets the suppressed error.


ErrorSuppressedEventArgs Class Methods

ErrorSuppressedEventArgs Class Methods
Legend
Methods
Name | Description
ErrorSuppressedEventArgs | Initializes a new instance of ErrorSuppressedEventArgs class.


ErrorSuppressedEventArgs Properties

ErrorSuppressedEventArgs Properties
Legend
ErrorSuppressedEventArgs Properties
Name | Description
Error | Gets the suppressed error.


NObject Delegates

NObject Delegates
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.


NObject Events

NObject Events
Legend
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.


NObject Fields

NObject Fields
Legend
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.


Legend

Legend
Legend
Method
virtual
static
Property
read only
Data Member
Event


NArray Class Members

NArray Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NValue Class
Show:
No members matching the current filter
Name | Description
ChangeType | Changes the type of the specified value to the new type.
FromDelegate | Creates a new value from the specified delegate.
FromObject | Creates a new value from the specified object.
FromPointer | Creates a new value from the specified pointer.
FromResult | Creates a new value from the specified result.
FromString | Creates a new value from the specified string.
FromType<T> | Creates a new value from the specified type.
ToBoolean | Converts the specified value into a Boolean value.
ToByte | Converts the specified value into a byte.
ToChar | Converts the specified value into a char.
ToDouble | Converts the specified value into a double number.
ToInt16 | Converts the specified value into a short integer.
ToInt32 | Converts the specified value into an integer.
ToInt64 | Converts the specified value into a long integer.
ToIntPtr | Converts the specified value into a pointer.
ToObject | Converts the specified value into an object.
ToPointer | Converts the specified value into a pointer.
ToResult | Converts the specified value into a result.
ToSByte | Converts the specified value into a signed byte.
ToSingle | Converts the specified value into a floating point value.
ToString | Converts the specified value into a string.
ToType<T> | Converts the specified value into a value of specified type.
ToUInt16 | Converts the specified value into an unsigned short integer.
ToUInt32 | Converts the specified value into an unsigned integer.
ToUInt64 | Converts the specified value into an unsigned long integer.
ToUIntPtr | Converts the specified value into a pointer.
NArray Class
Name | Description
FromArray | Creates a new array from the specified array.
FromPointerArray | Creates a new array from the specified integer pointer value array.
FromResultArray | Creates a new array from the specified result array.
GetEnumerator | Retrieves an enumerator for the current array.
GetValueAs<T> | Retrieves the of the specified value of the specified type in the array.
GetValueAsBoolean | Retrieves the specified Boolean value in the array.
GetValueAsByte | Retrieves the specified byte value in the array.
GetValueAsChar | Retrieves the specified char value in the array.
GetValueAsDouble | Retrieves the specified double value in the array.
GetValueAsInt16 | Retrieves the specified short integer value in the array.
GetValueAsInt32 | Retrieves the specified integer value in the array.
GetValueAsInt64 | Retrieves the specified long integer value in the array.
GetValueAsIntPtr | Retrieves the specified integer pointer value in the array.
GetValueAsObject | Retrieves the specified object in the array.
GetValueAsPointer | Retrieves the specified integer pointer value in the array.
GetValueAsResult | Retrieves the specified result value in the array.
GetValueAsSByte | Retrieves the specified signed byte value in the array.
GetValueAsSingle | Retrieves the specified floating point value in the array.
GetValueAsString | Retrieves the specified string value in the array.
GetValueAsUInt16 | Retrieves the specified unsigned short integer value in the array.
GetValueAsUInt32 | Retrieves the specified unsigned integer value in the array.
GetValueAsUInt64 | Retrieves the specified unsigned long integer value in the array.
GetValueAsUIntPtr | Retrieves the specified unsigned integer pointer value in the array.
ToArray<T> | Copies the current array into another array of the specified type.
ToBooleanArray | Copies the current array into a Boolean value array.
ToByteArray | Copies the current array into a byte array.
ToCharArray | Copies the current array into a char array.
ToDoubleArray | Copies the current array into a double value array.
ToInt16Array | Copies the current array into a short integer array.
ToInt32Array | Copies the current array into an integer array.
ToInt64Array | Copies the current array into a long integer array.
ToIntPtrArray | Copies the current array into an integer pointer array.
ToObjectArray | Copies the current array into an object array.
ToPointerArray | Copies the current array into a pointer array.
ToResultArray | Copies the current array into a result array.
ToSByteArray | Copies the current array into a signed byte array.
ToSingleArray | Copies the current array into a floating point value array.
ToStringArray | Copies the current array into a string array.
ToUInt16Array | Copies the current array into an unsigned short integer array.
ToUInt32Array | Copies the current array into an unsigned integer array.
ToUInt64Array | Copies the current unsigned long integer array into another array.
ToUIntPtrArray | Copies the current array into an unsigned integer pointer array.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NValue Class
Show:
No members matching the current filter
Name | Description
Attributes | Gets the value attributes.
IsWrapper | Checks whether the value is a wrapper.
KeyValuePairNativeType | Defines the native type of the key value pair structure.
LongSize | Gets the size of the value (64-bit).
NameValuePairNativeType | Defines the native type of the name value pair structure.
NativeSize | Gets the native size of the value.
NativeType | Defines the native type of the object.
Ptr | Gets a pointer to the value.
Size | Gets the size of the value.
TypeCode | Gets the type code of the value.
ValueType | Gets the type of the value.
NArray Class
Name | Description
Length | Retrieves the length of the array.
NativeType | Defines the native type of the object.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Methods
NValue Class
Show:
No members matching the current filter
Name | Description
NValue | Initializes a new instance of the NValue class.


NArray Class Methods

NArray Class Methods
Legend
Methods
NValue Class
Show:
No members matching the current filter
Name | Description
NValue | Initializes a new instance of the NValue class.


NDisposable Methods

NDisposable Methods
Legend
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NValue Class
Show:
No members matching the current filter
Name | Description
ChangeType | Changes the type of the specified value to the new type.
FromDelegate | Creates a new value from the specified delegate.
FromObject | Creates a new value from the specified object.
FromPointer | Creates a new value from the specified pointer.
FromResult | Creates a new value from the specified result.
FromString | Creates a new value from the specified string.
FromType<T> | Creates a new value from the specified type.
ToBoolean | Converts the specified value into a Boolean value.
ToByte | Converts the specified value into a byte.
ToChar | Converts the specified value into a char.
ToDouble | Converts the specified value into a double number.
ToInt16 | Converts the specified value into a short integer.
ToInt32 | Converts the specified value into an integer.
ToInt64 | Converts the specified value into a long integer.
ToIntPtr | Converts the specified value into a pointer.
ToObject | Converts the specified value into an object.
ToPointer | Converts the specified value into a pointer.
ToResult | Converts the specified value into a result.
ToSByte | Converts the specified value into a signed byte.
ToSingle | Converts the specified value into a floating point value.
ToString | Converts the specified value into a string.
ToType<T> | Converts the specified value into a value of specified type.
ToUInt16 | Converts the specified value into an unsigned short integer.
ToUInt32 | Converts the specified value into an unsigned integer.
ToUInt64 | Converts the specified value into an unsigned long integer.
ToUIntPtr | Converts the specified value into a pointer.
NArray Class
Name | Description
FromArray | Creates a new array from the specified array.
FromPointerArray | Creates a new array from the specified integer pointer value array.
FromResultArray | Creates a new array from the specified result array.
GetEnumerator | Retrieves an enumerator for the current array.
GetValueAs<T> | Retrieves the of the specified value of the specified type in the array.
GetValueAsBoolean | Retrieves the specified Boolean value in the array.
GetValueAsByte | Retrieves the specified byte value in the array.
GetValueAsChar | Retrieves the specified char value in the array.
GetValueAsDouble | Retrieves the specified double value in the array.
GetValueAsInt16 | Retrieves the specified short integer value in the array.
GetValueAsInt32 | Retrieves the specified integer value in the array.
GetValueAsInt64 | Retrieves the specified long integer value in the array.
GetValueAsIntPtr | Retrieves the specified integer pointer value in the array.
GetValueAsObject | Retrieves the specified object in the array.
GetValueAsPointer | Retrieves the specified integer pointer value in the array.
GetValueAsResult | Retrieves the specified result value in the array.
GetValueAsSByte | Retrieves the specified signed byte value in the array.
GetValueAsSingle | Retrieves the specified floating point value in the array.
GetValueAsString | Retrieves the specified string value in the array.
GetValueAsUInt16 | Retrieves the specified unsigned short integer value in the array.
GetValueAsUInt32 | Retrieves the specified unsigned integer value in the array.
GetValueAsUInt64 | Retrieves the specified unsigned long integer value in the array.
GetValueAsUIntPtr | Retrieves the specified unsigned integer pointer value in the array.
ToArray<T> | Copies the current array into another array of the specified type.
ToBooleanArray | Copies the current array into a Boolean value array.
ToByteArray | Copies the current array into a byte array.
ToCharArray | Copies the current array into a char array.
ToDoubleArray | Copies the current array into a double value array.
ToInt16Array | Copies the current array into a short integer array.
ToInt32Array | Copies the current array into an integer array.
ToInt64Array | Copies the current array into a long integer array.
ToIntPtrArray | Copies the current array into an integer pointer array.
ToObjectArray | Copies the current array into an object array.
ToPointerArray | Copies the current array into a pointer array.
ToResultArray | Copies the current array into a result array.
ToSByteArray | Copies the current array into a signed byte array.
ToSingleArray | Copies the current array into a floating point value array.
ToStringArray | Copies the current array into a string array.
ToUInt16Array | Copies the current array into an unsigned short integer array.
ToUInt32Array | Copies the current array into an unsigned integer array.
ToUInt64Array | Copies the current unsigned long integer array into another array.
ToUIntPtrArray | Copies the current array into an unsigned integer pointer array.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NValue Class
Show:
No members matching the current filter
Name | Description
Attributes | Gets the value attributes.
IsWrapper | Checks whether the value is a wrapper.
KeyValuePairNativeType | Defines the native type of the key value pair structure.
LongSize | Gets the size of the value (64-bit).
NameValuePairNativeType | Defines the native type of the name value pair structure.
NativeSize | Gets the native size of the value.
NativeType | Defines the native type of the object.
Ptr | Gets a pointer to the value.
Size | Gets the size of the value.
TypeCode | Gets the type code of the value.
ValueType | Gets the type of the value.
NArray Class
Name | Description
Length | Retrieves the length of the array.
NativeType | Defines the native type of the object.


NObject Events

NObject Events
Legend
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
NAsyncOperation Class
Name | Description
Completed | Adds or removes a user-specified "asynchronous operation completed" event callback.


NAsyncOperation Class Members

NAsyncOperation Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NAsyncOperation Class
Name | Description
AsTyped<T> | Creates a new async operation with the specified return value type.
Cancel | Cancels the asynchronous operation.
GetAwaiter | Returns TaskAwaiter object.
Wait | Waits until the asynchronous operation completes.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NAsyncOperation Class
Name | Description
Error | Retrieves the exception thrown by the async operation.
IsCanceled | Checks whether the async operation has been canceled.
IsCompleted | Checks whether the async operation has been completed.
IsFaulted | Checks whether the async operation has been faulted.
NAsyncStatusNativeType | Defines the native type of the async operation status.
NativeType | Defines the native type of the object.
Result | Retireves the value returned by the async operation.
Status | Retrieves the status of the async operation.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
NAsyncOperation Class
Name | Description
Completed | Adds or removes a user-specified "asynchronous operation completed" event callback.


NDisposable Methods

NDisposable Methods
Legend
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NAsyncOperation Class
Name | Description
AsTyped<T> | Creates a new async operation with the specified return value type.
Cancel | Cancels the asynchronous operation.
GetAwaiter | Returns TaskAwaiter object.
Wait | Waits until the asynchronous operation completes.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NAsyncOperation Class
Name | Description
Error | Retrieves the exception thrown by the async operation.
IsCanceled | Checks whether the async operation has been canceled.
IsCompleted | Checks whether the async operation has been completed.
IsFaulted | Checks whether the async operation has been faulted.
NAsyncStatusNativeType | Defines the native type of the async operation status.
NativeType | Defines the native type of the object.
Result | Retireves the value returned by the async operation.
Status | Retrieves the status of the async operation.


NComplex Fields

NComplex Fields
Legend
NComplex Fields
Name | Description
ImaginaryOne | Represents a NComplex with real part equal to zero and imaginary part equal to one.
One | Represents NComplex with real part equal to one and imaginary part equal to zero.
Zero | Represents a NComplex with real part equal to zero and imaginary part equal to zero.


Legend

Legend
Legend
Constructor
Data Member
static
read only
Property


NComplex Structure Members

NComplex Structure Members
Legend
Members
Methods
Name | Description
NComplex | Initializes a new instance of the NComplex structure.
NComplex Fields
Name | Description
ImaginaryOne | Represents a NComplex with real part equal to zero and imaginary part equal to one.
One | Represents NComplex with real part equal to one and imaginary part equal to zero.
Zero | Represents a NComplex with real part equal to zero and imaginary part equal to zero.
NComplex Methods
Name | Description
ToString | Retrieves a string representation of the object.
NComplex Properties
Name | Description
Imaginary | Sets or retrieves the imaginary part of NComplex value.
NativeType | Defines the native type of the type.
Real | Sets or retrieves the real part of NComplex value.


NComplex Structure Methods

NComplex Structure Methods
Legend
Methods
Name | Description
NComplex | Initializes a new instance of the NComplex structure.


NComplex Methods

NComplex Methods
Legend
NComplex Methods
Name | Description
ToString | Retrieves a string representation of the object.


NComplex Properties

NComplex Properties
Legend
NComplex Properties
Name | Description
Imaginary | Sets or retrieves the imaginary part of NComplex value.
NativeType | Defines the native type of the type.
Real | Sets or retrieves the real part of NComplex value.


NCore Events

NCore Events
Legend
NCore Events
Name | Description
ErrorSuppressed | Occurs when an error is suppressed.


NCore Fields

NCore Fields
Legend
NCore Fields
Name | Description
DllName | NCore library name.


Legend

Legend
Legend
Data Member
Method
static
Property
read only
Event


NCore Class Members

NCore Class Members
Legend
Members
NCore Fields
Name | Description
DllName | NCore library name.
NCore Methods
Name | Description
AlignedAlloc | Allocates a block of memory and makes sure that the returned pointer can be divided evenly by alignment.
AlignedCAlloc | Allocates an array in memory with elements initialized to 0 and makes sure that the returned pointer can be divided evenly by alignment.
AlignedFree | Frees a specified aligned memory block.
AlignedReAlloc | Reallocate memory blocks, represented by a pointer that can be divided evenly by the alignment.
Alloc | Allocates a block of memory.
CAlloc | Allocates an array in memory with elements initialized to 0.
Clear | Clears all elements in the specified array.
Compare | Compares two memory blocks.
Copy | Copies data from one memory block to other.
Fill | Sets memory block to a specified value.
Free | Frees a specified memory block.
Move | Moves one memory block to another.
ReAlloc | Reallocate memory blocks.
Shutdown | Disables sends and receives on a socket.
ShutdownThread | Disables sends and receives on a thread.
NCore Properties
Name | Description
NativeModule | Defines the native module of the object.
NativeType | Defines the native type of the object.
NCore Events
Name | Description
ErrorSuppressed | Occurs when an error is suppressed.


NCore Methods

NCore Methods
Legend
NCore Methods
Name | Description
AlignedAlloc | Allocates a block of memory and makes sure that the returned pointer can be divided evenly by alignment.
AlignedCAlloc | Allocates an array in memory with elements initialized to 0 and makes sure that the returned pointer can be divided evenly by alignment.
AlignedFree | Frees a specified aligned memory block.
AlignedReAlloc | Reallocate memory blocks, represented by a pointer that can be divided evenly by the alignment.
Alloc | Allocates a block of memory.
CAlloc | Allocates an array in memory with elements initialized to 0.
Clear | Clears all elements in the specified array.
Compare | Compares two memory blocks.
Copy | Copies data from one memory block to other.
Fill | Sets memory block to a specified value.
Free | Frees a specified memory block.
Move | Moves one memory block to another.
ReAlloc | Reallocate memory blocks.
Shutdown | Disables sends and receives on a socket.
ShutdownThread | Disables sends and receives on a thread.


NCore Properties

NCore Properties
Legend
NCore Properties
Name | Description
NativeModule | Defines the native module of the object.
NativeType | Defines the native type of the object.


Legend

Legend
Legend
Method
virtual
Property
read only


NDisposable Class Members

NDisposable Class Members
Legend
Members
NDisposable Methods
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NDisposable Properties
Name | Description
IsDisposed | Gets whether allocated resources were released previously.


NDisposable Methods

NDisposable Methods
Legend
NDisposable Methods
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Name | Description
IsDisposed | Gets whether allocated resources were released previously.


Legend

Legend
Legend
Method
static


NError Class Members

NError Class Members
Legend
Members
NError Methods
Name | Description
Get | Gets the specified exception.
GetDefaultMessage | Gets the default error message.
GetLast | Gets the last exception.
GetMacErrorMessage | Gets Mac OS X error message.
GetMessage | Retrieves an exception message.
GetSysErrorMessage | Gets system error message.
SetLast | Sets the last exception.
Suppress | Suppressed the specified exception.
ToString | Retrieves a string representation of the specified exception.


NError Methods

NError Methods
Legend
NError Methods
Name | Description
Get | Gets the specified exception.
GetDefaultMessage | Gets the default error message.
GetLast | Gets the last exception.
GetMacErrorMessage | Gets Mac OS X error message.
GetMessage | Retrieves an exception message.
GetSysErrorMessage | Gets system error message.
SetLast | Sets the last exception.
Suppress | Suppressed the specified exception.
ToString | Retrieves a string representation of the specified exception.


NExpandableObject Class Members

NExpandableObject Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NExpandableObject Class
Name | Description
NativeType | Defines the native type of the object.
Properties | Gets the property bag of the expandable object.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.


NDisposable Methods

NDisposable Methods
Legend
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NExpandableObject Class
Name | Description
NativeType | Defines the native type of the object.
Properties | Gets the property bag of the expandable object.


Legend

Legend
Legend
Constructor
Property
read only
static


NIndexPair Structure Members

NIndexPair Structure Members
Legend
Members
Methods
Name | Description
NIndexPair | Initializes a new instance of the NIndexPair structure.
NIndexPair Methods
Name | Description
ToString | Retrieves a string representation of the object.
NIndexPair Properties
Name | Description
Index1 | Gets or sets first index of this NIndexPair.
Index2 | Gets or sets second index of this NIndexPair.
NativeType | Defines the native type of the type.


NIndexPair Structure Methods

NIndexPair Structure Methods
Legend
Methods
Name | Description
NIndexPair | Initializes a new instance of the NIndexPair structure.


NIndexPair Methods

NIndexPair Methods
Legend
NIndexPair Methods
Name | Description
ToString | Retrieves a string representation of the object.


NIndexPair Properties

NIndexPair Properties
Legend
NIndexPair Properties
Name | Description
Index1 | Gets or sets first index of this NIndexPair.
Index2 | Gets or sets second index of this NIndexPair.
NativeType | Defines the native type of the type.


NModule Class Members

NModule Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NModule Class
Name | Description
CheckInit | Checks whether the current module is initialized and throws and exception if it is not.
CreateInstance | Creates a new instance of the specified module.
GetDependences | Retrieves dependencies of the module.
GetLoadedModules | Gets all the loaded modules that are part of this assembly.
GetType | Retrieves the NType object from module specified by name.
LoadFromFile | Loads module from the specified file.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NModule Class
Name | Description
Activated | Checks if the module is registered.
Company | Retrieves company name.
Copyright | Retrieves copyright notice of this module.
DefinedTypes | Retrieves all defined types from the specified module.
FileName | Retrieves the name of the file the specified module was created from.
Id | Gets or sets the ID of the module.
NModuleOptionsNativeType | Defines the native type of the module options.
Name | Retrieves module name.
NativeId | Gets or sets the native ID of the specified module.
NativeType | Defines the native type of the object.
Options | Retrieves module options.
Product | Retrieves product name.
Title | Retrieves module's title.
Version | Retrieves module version number.
VersionBuild | Retrieves the build of the current version.
VersionMajor | Retrieves the major version value.
VersionMinor | Retrieves the minor version value.
VersionRevision | Retrieves revision of the current version.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Methods
NModule Class
Name | Description
NModule | Initializes a new instance of NModule class.


NModule Class Methods

NModule Class Methods
Legend
Methods
NModule Class
Name | Description
NModule | Initializes a new instance of NModule class.


NDisposable Methods

NDisposable Methods
Legend
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NModule Class
Name | Description
CheckInit | Checks whether the current module is initialized and throws and exception if it is not.
CreateInstance | Creates a new instance of the specified module.
GetDependences | Retrieves dependencies of the module.
GetLoadedModules | Gets all the loaded modules that are part of this assembly.
GetType | Retrieves the NType object from module specified by name.
LoadFromFile | Loads module from the specified file.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NModule Class
Name | Description
Activated | Checks if the module is registered.
Company | Retrieves company name.
Copyright | Retrieves copyright notice of this module.
DefinedTypes | Retrieves all defined types from the specified module.
FileName | Retrieves the name of the file the specified module was created from.
Id | Gets or sets the ID of the module.
NModuleOptionsNativeType | Defines the native type of the module options.
Name | Retrieves module name.
NativeId | Gets or sets the native ID of the specified module.
NativeType | Defines the native type of the object.
Options | Retrieves module options.
Product | Retrieves product name.
Title | Retrieves module's title.
Version | Retrieves module version number.
VersionBuild | Retrieves the build of the current version.
VersionMajor | Retrieves the major version value.
VersionMinor | Retrieves the minor version value.
VersionRevision | Retrieves revision of the current version.


NObject Delegates

NObject Delegates
NObject Delegates
NObject Class
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.


NObject Events

NObject Events
Legend
NObject Events
NObject Class
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.


NObject Fields

NObject Fields
Legend
NObject Fields
NObject Class
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.


NObject Class Members

NObject Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NObject Fields
NObject Class
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.


NDisposable Methods

NDisposable Methods
Legend
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.


Legend

Legend
Legend
Method
static
Property
read only


NProcessorInfo Class Members

NProcessorInfo Class Members
Legend
Members
NProcessorInfo Methods
Name | Description
GetModelInfo | Retrieves processor model information.
IsFeatureSupported | Checks if current CPU supports the specified feature.
NProcessorInfo Properties
Name | Description
Count | Retrieves the number of logical processors in the current group.
ModelName | Gets a string representing processor model's name.
NProcessorVendorNativeType | Defines the native type of the processor vendor.
NativeType | Defines the native type of the object.
Vendor | Gets current processor's vendor value in vendor's enumeration.
VendorName | Gets a string representing processor vendor's name.


NProcessorInfo Methods

NProcessorInfo Methods
Legend
NProcessorInfo Methods
Name | Description
GetModelInfo | Retrieves processor model information.
IsFeatureSupported | Checks if current CPU supports the specified feature.


NProcessorInfo Properties

NProcessorInfo Properties
Legend
NProcessorInfo Properties
Name | Description
Count | Retrieves the number of logical processors in the current group.
ModelName | Gets a string representing processor model's name.
NProcessorVendorNativeType | Defines the native type of the processor vendor.
NativeType | Defines the native type of the object.
Vendor | Gets current processor's vendor value in vendor's enumeration.
VendorName | Gets a string representing processor vendor's name.


NPropertyBag Classes

NPropertyBag Classes
Legend
NPropertyBag Classes
NPropertyBag Class
Name | Description
KeyCollection | Represents the collection of key parts of the key value pair.
ValueCollection | Represents the collection of value parts of the key value pair.


NObject Events

NObject Events
Legend
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
NPropertyBag Class
Name | Description
CollectionChanged | Adds or removes a handler for an event which occurs when collection is changed.


Legend

Legend
Legend
Method
virtual
static
Property
read only
Data Member
Event
Class


NPropertyBag Class Members

NPropertyBag Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NPropertyBag Class
Name | Description
Add | Adds a key value pair to the current property bag.
AddRange | Adds a range of key value pair values to the current property bag.
ApplyTo | Applies the current property bag to the specified object.
Clear | Clears the current property bag.
Contains | Checks whether the current property bag contains the specified key value pair.
ContainsKey | Checks whether the property bag contains a property specified by key.
CopyTo | Copies the current property bag into a key value pair array.
GetEnumerator | Gets the enumerator for the current key value pair.
Parse | Converts the specified string to a property bag.
Remove | Removes the specified key value pair from the current property bag.
RemoveAt | Removes the property specified by index.
TryGetValue | Retrieves the value of a property specified by the key. Returns a Boolean value indicating whether the operation succeeded.
TryParse | Converts the specified string to a property bag. Returns a Boolean value indicating whether the conversion succeeded.
this | Gets the specified key vale pair.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NPropertyBag Class
Name | Description
Count | Retrieves the number of properties in the property bag.
IsReadOnly | Checks whether the property bag is read-only.
Keys | Gets the collection of key values.
NativeType | Defines the native type of the object.
Values | Gets the collection of values.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
NPropertyBag Class
Name | Description
CollectionChanged | Adds or removes a handler for an event which occurs when collection is changed.
Methods
NPropertyBag Class
Name | Description
NPropertyBag | Creates a new instance of NPropertyBag class.
NPropertyBag Classes
NPropertyBag Class
Name | Description
KeyCollection | Represents the collection of key parts of the key value pair.
ValueCollection | Represents the collection of value parts of the key value pair.


NPropertyBag Class Methods

NPropertyBag Class Methods
Legend
Methods
NPropertyBag Class
Name | Description
NPropertyBag | Creates a new instance of NPropertyBag class.


NDisposable Methods

NDisposable Methods
Legend
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NPropertyBag Class
Name | Description
Add | Adds a key value pair to the current property bag.
AddRange | Adds a range of key value pair values to the current property bag.
ApplyTo | Applies the current property bag to the specified object.
Clear | Clears the current property bag.
Contains | Checks whether the current property bag contains the specified key value pair.
ContainsKey | Checks whether the property bag contains a property specified by key.
CopyTo | Copies the current property bag into a key value pair array.
GetEnumerator | Gets the enumerator for the current key value pair.
Parse | Converts the specified string to a property bag.
Remove | Removes the specified key value pair from the current property bag.
RemoveAt | Removes the property specified by index.
TryGetValue | Retrieves the value of a property specified by the key. Returns a Boolean value indicating whether the operation succeeded.
TryParse | Converts the specified string to a property bag. Returns a Boolean value indicating whether the conversion succeeded.
this | Gets the specified key vale pair.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NPropertyBag Class
Name | Description
Count | Retrieves the number of properties in the property bag.
IsReadOnly | Checks whether the property bag is read-only.
Keys | Gets the collection of key values.
NativeType | Defines the native type of the object.
Values | Gets the collection of values.


NPropertyBag.KeyCollection Class Members

NPropertyBag.KeyCollection Class Members
Legend
Members
KeyCollection Methods
Name | Description
Contains | Checks whether the key collection contains the specified key.


KeyCollection Methods

KeyCollection Methods
Legend
KeyCollection Methods
Name | Description
Contains | Checks whether the key collection contains the specified key.


NRange Structure Members

NRange Structure Members
Legend
Members
Methods
Name | Description
NRange | Initializes a new instance of the NRange structure.
NRange Methods
Name | Description
ToString | Retrieves a string representation of the range object.
NRange Properties
Name | Description
From | Gets or sets lower bound of a range.
NativeType | Defines the native type of the type.
To | Gets or sets upper bound of a range.


NRange Structure Methods

NRange Structure Methods
Legend
Methods
Name | Description
NRange | Initializes a new instance of the NRange structure.


NRange Methods

NRange Methods
Legend
NRange Methods
Name | Description
ToString | Retrieves a string representation of the range object.


NRange Properties

NRange Properties
Legend
NRange Properties
Name | Description
From | Gets or sets lower bound of a range.
NativeType | Defines the native type of the type.
To | Gets or sets upper bound of a range.


NRational Fields

NRational Fields
Legend
NRational Fields
Name | Description
Empty | Represents that NRational is a null reference.


NRational Structure Members

NRational Structure Members
Legend
Members
Methods
Name | Description
NRational | Initializes a new instance of the NRational structure.
NRational Fields
Name | Description
Empty | Represents that NRational is a null reference.
NRational Methods
Name | Description
ToString | Retrieves a string representation of the object.
NRational Properties
Name | Description
Denominator | Sets or retrieves the NRational value Denominator.
NativeType | Defines the native type of the type.
Numerator | Sets or retrieves the NRational value Numerator.


NRational Structure Methods

NRational Structure Methods
Legend
Methods
Name | Description
NRational | Initializes a new instance of the NRational structure.


NRational Methods

NRational Methods
Legend
NRational Methods
Name | Description
ToString | Retrieves a string representation of the object.


NRational Properties

NRational Properties
Legend
NRational Properties
Name | Description
Denominator | Sets or retrieves the NRational value Denominator.
NativeType | Defines the native type of the type.
Numerator | Sets or retrieves the NRational value Numerator.


NType Class Members

NType Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NType Class
Name | Description
AddEventHandler | Adds a handler for the specified event to the specified object.
CapturePropertyValues | Captures property values of the specified object.
CopyPropertyValues | Copies properties from one object to another object.
CreateInstance | Creates an instance of the specified type.
GetDeclaredConstant | Retrieves the declared constant specified by name.
GetDeclaredEnumConstant | Retrieves the declared enumeration constant specified by name.
GetDeclaredEvent | Retrieves the declared event specified by name.
GetDeclaredField | Retrieves the declared field specified by name.
GetDeclaredMethod | Retrieves the declared method specified by index.
GetDeclaredMethods | Retrieves all declared methods of the specified type.
GetDeclaredPart | Retrieves the declared part specified by name.
GetDeclaredProperty | Retrieves the declared property specified by name.
GetPropertyValue<T> | Retrieves the specified property of the specified object.
GetType | Retrieves the type specified by name.
IdentifierToString | Converts the specified identifier into a string.
InvokeMethod | Invokes the specified method on the specified object.
IsAssignableFrom | Checks whether the current type is assignable from the specified type.
IsInstanceOfType | Checks whether the current type is an instance of the specified object.
IsSubclassOf | Checks whether the current type is a subclass of the specified type.
RemoveEventHandler | Removes a handler for the specified event to the specified object.
Reset | Resets the specified object.
ResetPropertyValue | Resets the specified property.
SetPropertyValue<T> | Sets the value of the specified property.
ToNativeType | Converts the specified type to a native type.
ToType | Converts the current value into a type.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NType Class
Name | Description
Attributes | Gets attributes of the specified type.
BaseType | Gets the base type of the current type.
DeclaredConstants | Gets all declared constants of the specified type.
DeclaredConstructors | Gets all declared constructors of the specified type.
DeclaredEnumConstants | Retrieves all declared enumeration constants of the specified type.
DeclaredEvents | Retrieves all declared events of the specified type.
DeclaredFields | Retrieves all declared fields of the specified type.
DeclaredMethods | Retrieves all declared methods of the specified type.
DeclaredParts | Retrieves all declared parts of the specified type.
DeclaredProperties | Retrieves all declared properties of the specified type.
EnumAlternative | Retrieves alternative enumeration for the specified type.
HasOwnerType | Checks whether the current type has an owner type.
IsAbstract | Checks whether the current type is abstract.
IsBasic | Checks whether the current type is a basic type.
IsCallback | Checks whether the current type is a callback type.
IsCloneable | Checks whether the current type is cloneable.
IsComparable | Checks whether the current type is comparable.
IsDeprecated | Checks whether the current type is deprecated.
IsDisposable | Checks whether the current type is disposable.
IsEnum | Checks whether the current type is an enum type.
IsEquatable | Checks whether the current type is equatable.
IsFlagsEnum | Checks whether the current type is a flags enum.
IsHandle | Checks whether the current type is a handle type.
IsMemorySerializable | Checks whether the current type is memory serializable.
IsObject | Checks whether the current type is an object type.
IsParsable | Checks whether the current type is parsable.
IsPrimitive | Checks whether the current type is a primitive type.
IsPublic | Checks whether the current type is public.
IsSealed | Checks whether the current type is sealed.
IsSerializable | Checks whether the current type is serializable.
IsSignNeutral | Checks whether the current type is sign-neutral.
IsStatic | Checks whether the current type is static.
IsStruct | Checks whether the current type is a struct type.
Module | Gets the module of the current type.
NTypeCodeNativeType | Defines the native type of the type code.
Name | Gets the name of the current type.
NativeType | Defines the native type of the object.
OwnerType | Gets the owner type of the current type.
RootType | Gets the root type of the current type.
RootTypeCode | Returns NTypeCode for the root type of the current type.
TypeCode | Returns NTypeCode for the current type.
UseInsteadType | Gets the type to be used instead of current type.
ValueSize | Gets the size of the current value.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.


NDisposable Methods

NDisposable Methods
Legend
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NType Class
Name | Description
AddEventHandler | Adds a handler for the specified event to the specified object.
CapturePropertyValues | Captures property values of the specified object.
CopyPropertyValues | Copies properties from one object to another object.
CreateInstance | Creates an instance of the specified type.
GetDeclaredConstant | Retrieves the declared constant specified by name.
GetDeclaredEnumConstant | Retrieves the declared enumeration constant specified by name.
GetDeclaredEvent | Retrieves the declared event specified by name.
GetDeclaredField | Retrieves the declared field specified by name.
GetDeclaredMethod | Retrieves the declared method specified by index.
GetDeclaredMethods | Retrieves all declared methods of the specified type.
GetDeclaredPart | Retrieves the declared part specified by name.
GetDeclaredProperty | Retrieves the declared property specified by name.
GetPropertyValue<T> | Retrieves the specified property of the specified object.
GetType | Retrieves the type specified by name.
IdentifierToString | Converts the specified identifier into a string.
InvokeMethod | Invokes the specified method on the specified object.
IsAssignableFrom | Checks whether the current type is assignable from the specified type.
IsInstanceOfType | Checks whether the current type is an instance of the specified object.
IsSubclassOf | Checks whether the current type is a subclass of the specified type.
RemoveEventHandler | Removes a handler for the specified event to the specified object.
Reset | Resets the specified object.
ResetPropertyValue | Resets the specified property.
SetPropertyValue<T> | Sets the value of the specified property.
ToNativeType | Converts the specified type to a native type.
ToType | Converts the current value into a type.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NType Class
Name | Description
Attributes | Gets attributes of the specified type.
BaseType | Gets the base type of the current type.
DeclaredConstants | Gets all declared constants of the specified type.
DeclaredConstructors | Gets all declared constructors of the specified type.
DeclaredEnumConstants | Retrieves all declared enumeration constants of the specified type.
DeclaredEvents | Retrieves all declared events of the specified type.
DeclaredFields | Retrieves all declared fields of the specified type.
DeclaredMethods | Retrieves all declared methods of the specified type.
DeclaredParts | Retrieves all declared parts of the specified type.
DeclaredProperties | Retrieves all declared properties of the specified type.
EnumAlternative | Retrieves alternative enumeration for the specified type.
HasOwnerType | Checks whether the current type has an owner type.
IsAbstract | Checks whether the current type is abstract.
IsBasic | Checks whether the current type is a basic type.
IsCallback | Checks whether the current type is a callback type.
IsCloneable | Checks whether the current type is cloneable.
IsComparable | Checks whether the current type is comparable.
IsDeprecated | Checks whether the current type is deprecated.
IsDisposable | Checks whether the current type is disposable.
IsEnum | Checks whether the current type is an enum type.
IsEquatable | Checks whether the current type is equatable.
IsFlagsEnum | Checks whether the current type is a flags enum.
IsHandle | Checks whether the current type is a handle type.
IsMemorySerializable | Checks whether the current type is memory serializable.
IsObject | Checks whether the current type is an object type.
IsParsable | Checks whether the current type is parsable.
IsPrimitive | Checks whether the current type is a primitive type.
IsPublic | Checks whether the current type is public.
IsSealed | Checks whether the current type is sealed.
IsSerializable | Checks whether the current type is serializable.
IsSignNeutral | Checks whether the current type is sign-neutral.
IsStatic | Checks whether the current type is static.
IsStruct | Checks whether the current type is a struct type.
Module | Gets the module of the current type.
NTypeCodeNativeType | Defines the native type of the type code.
Name | Gets the name of the current type.
NativeType | Defines the native type of the object.
OwnerType | Gets the owner type of the current type.
RootType | Gets the root type of the current type.
RootTypeCode | Returns NTypeCode for the root type of the current type.
TypeCode | Returns NTypeCode for the current type.
UseInsteadType | Gets the type to be used instead of current type.
ValueSize | Gets the size of the current value.


NTypes Fields

NTypes Fields
Legend
NTypes Fields
Name | Description
StringEncoding | The string encoding.
WCharApi | Whether the Unicode char API is supported.


Legend

Legend
Legend
Data Member
static
read only
Method
Property


NTypes Class Members

NTypes Class Members
Legend
Members
NTypes Fields
Name | Description
StringEncoding | The string encoding.
WCharApi | Whether the Unicode char API is supported.
NTypes Methods
Name | Description
CreateCallback | Creates a new callback.
FreeObjectPointer | Decrements the reference count for a specified pointer.
FreeStringArray | Frees specified strings.
FreeStringElements | Frees specified string elements.
GetObjectFromPointer | Retrieves an object from a pointer.
GetPointerForObject | Increments the reference count for a pointer to a specified object.
IsMemoryTypeValid | Checks whether the memory type is valid.
IsMemoryTypeValidForFree | Checks whether the memory type is valid for freeing.
NTypes Properties
Name | Description
NACharNativeType | Gets the native type of the ASCII char.
NAttributesNativeType | Gets the native type of the NAttributes value.
NBooleanNativeType | Gets the native type of the Boolean value.
NCallbackNativeType | Gets the native type of the callback.
NCharNativeType | Gets the native type of the char.
NDateTimeNativeType | Gets the native type of the NDateTime object.
NDoubleNativeType | Gets the native type of the double number.
NGuidNativeType | Gets the native type of the global unique identifier.
NInt16NativeType | Gets the native type of the 16-bit integer.
NInt32NativeType | Gets the native type of the 32-bit integer.
NInt64NativeType | Gets the native type of the 64-bit integer.
NInt8NativeType | Gets the native type of the 8-bit integer.
NMemoryTypeNativeType | Gets the native type of the memory type.
NOSFamilyNativeType | Gets the native type of the OS family.
NPointerNativeType | Gets the native type of the pointer.
NResultNativeType | Gets the native type of the NResult value.
NSSizeTypeNativeType | Gets the native type of the integer pointer.
NSingleNativeType | Gets the native type of the floating point value.
NSizeTypeNativeType | Gets the native type of the unsigned integer pointer.
NStringNativeType | Gets the native type of the string.
NTimeSpanNativeType | Gets the native type of the NTimeSpan value.
NUInt16NativeType | Gets the native type of the unsigned 16-bit integer.
NUInt32NativeType | Gets the native type of the unsigned 32-bit integer.
NUInt64NativeType | Gets the native type of the unsigned 64-bit integer.
NUInt8NativeType | Gets the native type of the unsigned 8-bit integer.
NWCharNativeType | Gets the native type of the Unicode char.
NameStringPairNativeType | Gets the native type of the name string pair.
NativeType | Gets the native type of the object.
OSFamilyCurrent | Gets the current OS family.


NTypes Methods

NTypes Methods
Legend
NTypes Methods
Name | Description
CreateCallback | Creates a new callback.
FreeObjectPointer | Decrements the reference count for a specified pointer.
FreeStringArray | Frees specified strings.
FreeStringElements | Frees specified string elements.
GetObjectFromPointer | Retrieves an object from a pointer.
GetPointerForObject | Increments the reference count for a pointer to a specified object.
IsMemoryTypeValid | Checks whether the memory type is valid.
IsMemoryTypeValidForFree | Checks whether the memory type is valid for freeing.


NTypes Properties

NTypes Properties
Legend
NTypes Properties
Name | Description
NACharNativeType | Gets the native type of the ASCII char.
NAttributesNativeType | Gets the native type of the NAttributes value.
NBooleanNativeType | Gets the native type of the Boolean value.
NCallbackNativeType | Gets the native type of the callback.
NCharNativeType | Gets the native type of the char.
NDateTimeNativeType | Gets the native type of the NDateTime object.
NDoubleNativeType | Gets the native type of the double number.
NGuidNativeType | Gets the native type of the global unique identifier.
NInt16NativeType | Gets the native type of the 16-bit integer.
NInt32NativeType | Gets the native type of the 32-bit integer.
NInt64NativeType | Gets the native type of the 64-bit integer.
NInt8NativeType | Gets the native type of the 8-bit integer.
NMemoryTypeNativeType | Gets the native type of the memory type.
NOSFamilyNativeType | Gets the native type of the OS family.
NPointerNativeType | Gets the native type of the pointer.
NResultNativeType | Gets the native type of the NResult value.
NSSizeTypeNativeType | Gets the native type of the integer pointer.
NSingleNativeType | Gets the native type of the floating point value.
NSizeTypeNativeType | Gets the native type of the unsigned integer pointer.
NStringNativeType | Gets the native type of the string.
NTimeSpanNativeType | Gets the native type of the NTimeSpan value.
NUInt16NativeType | Gets the native type of the unsigned 16-bit integer.
NUInt32NativeType | Gets the native type of the unsigned 32-bit integer.
NUInt64NativeType | Gets the native type of the unsigned 64-bit integer.
NUInt8NativeType | Gets the native type of the unsigned 8-bit integer.
NWCharNativeType | Gets the native type of the Unicode char.
NameStringPairNativeType | Gets the native type of the name string pair.
NativeType | Gets the native type of the object.
OSFamilyCurrent | Gets the current OS family.


NURational Fields

NURational Fields
Legend
NURational Fields
Name | Description
Empty | Represents a NURational that is a null reference.


NURational Structure Members

NURational Structure Members
Legend
Members
Methods
Name | Description
NURational | Initializes a new instance of the NURational structure.
NURational Fields
Name | Description
Empty | Represents a NURational that is a null reference.
NURational Methods
Name | Description
ToString | Retrieves a string representation of the object.
NURational Properties
Name | Description
Denominator | Sets or retrieves the NRational value Denominator.
NativeType | Defines the native type of the type.
Numerator | Sets or retrieves the NRational value Numerator.


NURational Structure Methods

NURational Structure Methods
Legend
Methods
Name | Description
NURational | Initializes a new instance of the NURational structure.


NURational Methods

NURational Methods
Legend
NURational Methods
Name | Description
ToString | Retrieves a string representation of the object.


NURational Properties

NURational Properties
Legend
NURational Properties
Name | Description
Denominator | Sets or retrieves the NRational value Denominator.
NativeType | Defines the native type of the type.
Numerator | Sets or retrieves the NRational value Numerator.


NValue Class Members

NValue Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NValue Class
Name | Description
ChangeType | Changes the type of the specified value to the new type.
FromDelegate | Creates a new value from the specified delegate.
FromObject | Creates a new value from the specified object.
FromPointer | Creates a new value from the specified pointer.
FromResult | Creates a new value from the specified result.
FromString | Creates a new value from the specified string.
FromType<T> | Creates a new value from the specified type.
ToBoolean | Converts the specified value into a Boolean value.
ToByte | Converts the specified value into a byte.
ToChar | Converts the specified value into a char.
ToDouble | Converts the specified value into a double number.
ToInt16 | Converts the specified value into a short integer.
ToInt32 | Converts the specified value into an integer.
ToInt64 | Converts the specified value into a long integer.
ToIntPtr | Converts the specified value into a pointer.
ToObject | Converts the specified value into an object.
ToPointer | Converts the specified value into a pointer.
ToResult | Converts the specified value into a result.
ToSByte | Converts the specified value into a signed byte.
ToSingle | Converts the specified value into a floating point value.
ToString | Converts the specified value into a string.
ToType<T> | Converts the specified value into a value of specified type.
ToUInt16 | Converts the specified value into an unsigned short integer.
ToUInt32 | Converts the specified value into an unsigned integer.
ToUInt64 | Converts the specified value into an unsigned long integer.
ToUIntPtr | Converts the specified value into a pointer.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NValue Class
Name | Description
Attributes | Gets the value attributes.
IsWrapper | Checks whether the value is a wrapper.
KeyValuePairNativeType | Defines the native type of the key value pair structure.
LongSize | Gets the size of the value (64-bit).
NameValuePairNativeType | Defines the native type of the name value pair structure.
NativeSize | Gets the native size of the value.
NativeType | Defines the native type of the object.
Ptr | Gets a pointer to the value.
Size | Gets the size of the value.
TypeCode | Gets the type code of the value.
ValueType | Gets the type of the value.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Methods
NValue Class
Name | Description
NValue | Initializes a new instance of the NValue class.


NValue Class Methods

NValue Class Methods
Legend
Methods
NValue Class
Name | Description
NValue | Initializes a new instance of the NValue class.


NDisposable Methods

NDisposable Methods
Legend
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NValue Class
Name | Description
ChangeType | Changes the type of the specified value to the new type.
FromDelegate | Creates a new value from the specified delegate.
FromObject | Creates a new value from the specified object.
FromPointer | Creates a new value from the specified pointer.
FromResult | Creates a new value from the specified result.
FromString | Creates a new value from the specified string.
FromType<T> | Creates a new value from the specified type.
ToBoolean | Converts the specified value into a Boolean value.
ToByte | Converts the specified value into a byte.
ToChar | Converts the specified value into a char.
ToDouble | Converts the specified value into a double number.
ToInt16 | Converts the specified value into a short integer.
ToInt32 | Converts the specified value into an integer.
ToInt64 | Converts the specified value into a long integer.
ToIntPtr | Converts the specified value into a pointer.
ToObject | Converts the specified value into an object.
ToPointer | Converts the specified value into a pointer.
ToResult | Converts the specified value into a result.
ToSByte | Converts the specified value into a signed byte.
ToSingle | Converts the specified value into a floating point value.
ToString | Converts the specified value into a string.
ToType<T> | Converts the specified value into a value of specified type.
ToUInt16 | Converts the specified value into an unsigned short integer.
ToUInt32 | Converts the specified value into an unsigned integer.
ToUInt64 | Converts the specified value into an unsigned long integer.
ToUIntPtr | Converts the specified value into a pointer.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NValue Class
Name | Description
Attributes | Gets the value attributes.
IsWrapper | Checks whether the value is a wrapper.
KeyValuePairNativeType | Defines the native type of the key value pair structure.
LongSize | Gets the size of the value (64-bit).
NameValuePairNativeType | Defines the native type of the name value pair structure.
NativeSize | Gets the native size of the value.
NativeType | Defines the native type of the object.
Ptr | Gets a pointer to the value.
Size | Gets the size of the value.
TypeCode | Gets the type code of the value.
ValueType | Gets the type of the value.


NVersion Fields

NVersion Fields
Legend
NVersion Fields
Name | Description
Empty | New NVersion object.


Legend

Legend
Legend
Constructor
Data Member
static
read only
Operator
Property


NVersion Structure Members

NVersion Structure Members
Legend
Members
Methods
Name | Description
NVersion | Initializes a new instance of NVersion structure.
NVersion Fields
Name | Description
Empty | New NVersion object.
NVersion Methods
Name | Description
CompareTo | Compares the current version with the specified version and returns an integer that indicates their relative position in the sort order.
Equals | Checks whether the current version equals the specified version.
GetHashCode | Gets the hash code.
ToString | Gets the string representation of the current version.
NVersion Operators
Name | Description
!= | Checks whether the two NVersion values are not equal.
< | Checks whether the first NVersion value is smaller than the second NVersion value.
<= | Checks whether the first NVersion value is smaller than or equal to the second NVersion value.
== | Checks whether the two NVersion values are equal.
> | Checks whether the first NVersion value is larger than the second NVersion value.
>= | Checks whether the first NVersion value is larger than or equal to the second NVersion value.
NVersion | Converts an unsigned short value to NVersion value.
ushort | Converts NVersion value to an unsigned short value.
NVersion Properties
Name | Description
Major | Gets the major version value.
Minor | Gets the minor version value.
NativeType | Defines the native type of the type.


NVersion Structure Methods

NVersion Structure Methods
Legend
Methods
Name | Description
NVersion | Initializes a new instance of NVersion structure.


NVersion Methods

NVersion Methods
Legend
NVersion Methods
Name | Description
CompareTo | Compares the current version with the specified version and returns an integer that indicates their relative position in the sort order.
Equals | Checks whether the current version equals the specified version.
GetHashCode | Gets the hash code.
ToString | Gets the string representation of the current version.


NVersion Operators

NVersion Operators
Legend
NVersion Operators
Name | Description
!= | Checks whether the two NVersion values are not equal.
< | Checks whether the first NVersion value is smaller than the second NVersion value.
<= | Checks whether the first NVersion value is smaller than or equal to the second NVersion value.
== | Checks whether the two NVersion values are equal.
> | Checks whether the first NVersion value is larger than the second NVersion value.
>= | Checks whether the first NVersion value is larger than or equal to the second NVersion value.
NVersion | Converts an unsigned short value to NVersion value.
ushort | Converts NVersion value to an unsigned short value.


NVersion Properties

NVersion Properties
Legend
NVersion Properties
Name | Description
Major | Gets the major version value.
Minor | Gets the minor version value.
NativeType | Defines the native type of the type.


NVersionRange Fields

NVersionRange Fields
Legend
NVersionRange Fields
Name | Description
Empty | New version range object.


NVersionRange Structure Members

NVersionRange Structure Members
Legend
Members
Methods
Name | Description
NVersionRange | Initializes a new instance of NVersionRange structure.
NVersionRange Fields
Name | Description
Empty | New version range object.
NVersionRange Methods
Name | Description
Contains | Checks whether the current version range contain the specified version.
Equals | Checks whether the current version range equals the specified version range.
GetHashCode | Gets the hash code.
Intersect | Gets the intersection of the current version range and specified version range.
IntersectsWith | Checks whether the current version range intersects with the specified version range.
ToString | Gets a string representation of the version range.
NVersionRange Operators
Name | Description
!= | Checks whether the two NVersionRange values are not equal.
== | Checks whether the two NVersionRange values are equal.
NVersionRange | Converts an unsigned short value to NVersionRange value.
uint | Converts NVersionRange value to an unsigned short value.
NVersionRange Properties
Name | Description
From | Lower NVersion value.
NativeType | Defines the native type of the type.
To | Upper NVersion value.


NVersionRange Structure Methods

NVersionRange Structure Methods
Legend
Methods
Name | Description
NVersionRange | Initializes a new instance of NVersionRange structure.


NVersionRange Methods

NVersionRange Methods
Legend
NVersionRange Methods
Name | Description
Contains | Checks whether the current version range contain the specified version.
Equals | Checks whether the current version range equals the specified version range.
GetHashCode | Gets the hash code.
Intersect | Gets the intersection of the current version range and specified version range.
IntersectsWith | Checks whether the current version range intersects with the specified version range.
ToString | Gets a string representation of the version range.


NVersionRange Operators

NVersionRange Operators
Legend
NVersionRange Operators
Name | Description
!= | Checks whether the two NVersionRange values are not equal.
== | Checks whether the two NVersionRange values are equal.
NVersionRange | Converts an unsigned short value to NVersionRange value.
uint | Converts NVersionRange value to an unsigned short value.


NVersionRange Properties

NVersionRange Properties
Legend
NVersionRange Properties
Name | Description
From | Lower NVersion value.
NativeType | Defines the native type of the type.
To | Upper NVersion value.


Neurotec.Biometrics Namespace Classes

Neurotec.Biometrics Namespace Classes
Legend
Classes
Name | Description
NBiometric | Provides general biometric methods.
NBiometricAttributes | Represents the biometric attributes.
NBiometricQualityBlock | Provides properties for getting and setting a biometric quality block.
NBiometricTypes | Defines biometric types used by Neurotechnology components.
NBiometrics | Provides methods for retrieving NBiometrics Library information.
NFCore | The structure contains information of core.
NFDelta | The structure contains information of delta.
NFDoubleCore | The structure contains information of double core.
NFMinutia | The structure contains information of minutia.
NFMinutiaNeighbor | The structure contains information of minutia neighbor.
NFace | Provides methods for biometric engine to deal with face templates.
NLAttributes | Provides methods to retrieve face template attributes.
NLFeaturePoint | Structure defining facial feature point.
NLMatchingDetails | Provides functionality to retrieve face templates matching details.
NLRecord | Provides functionality for packing, unpacking and editing Neurotechnology Face Records (NLRecords).
NLTemplate | Provides functionality for packing, unpacking and editing Neurotechnology Faces Templates (NLTemplates).
NMatchingDetails | Provides functionality for retrieving Neurotechnology templates matching details.
NMatchingDetailsBase | Base class for NMatchingDetails.
NMatchingResult | Provides methods to retrieve information about matching results.
NSubject | Represents a person (or, potentially, any living creature) and contains biometric information related that person, including templates, biometric operation (matching) results and objects like NFace, which contain biometric data of specific kinds.
NTemplate | Provides functionality for packing, unpacking and editing Neurotechnology Templates (NTemplates).


Legend

Legend
Legend
Class
Structure
static
Enumeration


Neurotec.Biometrics Namespace Structs, Records, Enums

Neurotec.Biometrics Namespace Structs, Records, Enums
Legend
Structs, Records, Enums
Name | Description
NBiometricCaptureOptions | Enumerates biometric capture options.
NBiometricStatus | Enumerates biometric status values. These values are returned by NBiometricDevice.
NBiometricSubtype | Specifies the subtype of biometric data.
NBiometricType | Specifies the type of biometric data.
NEImageType | Enumerates iris image types.
NEPosition | Holds information on iris image position.
NFImpressionType | Specifies the impression types.
NFMinutiaFormat | Specifies minutia format.
NFMinutiaType | Specifies types of minutia.
NFPatternClass | Specifies pattern class of the fingerprint.
NFPosition | Specifies finger position.
NFRidgeCountsType | Specifies type of ridge counts contained in NFRecord.
NGender | Enumerates gender constants.
NIcaoWarnings | Enumerates face Icao check warnings constants.
NLExpression | Enumerates facial expression constants.
NLProperties | Enumerates basic face properties constants
NLivenessAction | Enumerates face liveness challenge action constants.
NLivenessMode | Enumerates face liveness mode constants.
NfiqQuality | Specifies the quality of a fingerprint image.


NBiometric Class Members

NBiometric Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NBiometric Class
Name | Description
IsBiometricCaptureOptionsValid | Checks whether the specified biometric capture options are valid.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NBiometric Class
Name | Description
BiometricType | Gets the biometric type.
CaptureOptions | Gets or sets the biometric capture options.
Error | Gets the last exception.
FileName | Gets or sets the file name.
HasMoreSamples | Gets or sets whether the NBioemtric object has more samples.
NBiometricCaptureOptionsNativeType | Defines the native type of the capture options.
NativeType | Defines the native type of the object.
Owner | Gets owner of the object.
ParentObject | Gets the parent object.
SampleBuffer | Gets or sets sample buffer. Use similar to FileName property, but this is more efficient if file contents are already loaded to memory.
SessionId | Gets or sets the session ID.
Status | Gets or sets the biometric status.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.


NDisposable Methods

NDisposable Methods
Legend
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NBiometric Class
Name | Description
IsBiometricCaptureOptionsValid | Checks whether the specified biometric capture options are valid.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NBiometric Class
Name | Description
BiometricType | Gets the biometric type.
CaptureOptions | Gets or sets the biometric capture options.
Error | Gets the last exception.
FileName | Gets or sets the file name.
HasMoreSamples | Gets or sets whether the NBioemtric object has more samples.
NBiometricCaptureOptionsNativeType | Defines the native type of the capture options.
NativeType | Defines the native type of the object.
Owner | Gets owner of the object.
ParentObject | Gets the parent object.
SampleBuffer | Gets or sets sample buffer. Use similar to FileName property, but this is more efficient if file contents are already loaded to memory.
SessionId | Gets or sets the session ID.
Status | Gets or sets the biometric status.


NBiometricAttributes Class Members

NBiometricAttributes Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NBiometricAttributes Class
Name | Description
BiometricType | Gets the biometric type.
Child | Gets child NBiometric object of the current NBiometricAttributes.
ChildSubject | Gets child NSubject of the current NBiometricAttributes.
DetectionConfidence | Gets or sets the detection confidence.
LivenessConfidence | Gets or sets presentation attack detection confidence value.
NativeType | Defines the native type of the object.
Quality | Gets or sets the quality.
Status | Gets or sets the biometric status.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NBiometricAttributes Class
Name | Description
BiometricType | Gets the biometric type.
Child | Gets child NBiometric object of the current NBiometricAttributes.
ChildSubject | Gets child NSubject of the current NBiometricAttributes.
DetectionConfidence | Gets or sets the detection confidence.
LivenessConfidence | Gets or sets presentation attack detection confidence value.
NativeType | Defines the native type of the object.
Quality | Gets or sets the quality.
Status | Gets or sets the biometric status.


NBiometricQualityBlock Structure Members

NBiometricQualityBlock Structure Members
Legend
Members
Methods
Name | Description
NBiometricQualityBlock | Initializes a new instance of the NBiometricQualityBlock class.
NBiometricQualityBlock Methods
Name | Description
ToString | Returns a string that represents the current structure.
NBiometricQualityBlock Properties
Name | Description
NativeType | Defines the native type of the object.
QualityAlgorithmId | Gets or sets the CBEFF Quality Algorithm Identifier.
QualityAlgorithmVendorId | Gets or sets the CBEFF Biometric Quality Algorithm Vendor Identifier (CBEFF Biometric Organization Identifier).
QualityScore | Gets or sets the quality score.


NBiometricQualityBlock Structure Methods

NBiometricQualityBlock Structure Methods
Legend
Methods
Name | Description
NBiometricQualityBlock | Initializes a new instance of the NBiometricQualityBlock class.


NBiometricQualityBlock Methods

NBiometricQualityBlock Methods
Legend
NBiometricQualityBlock Methods
Name | Description
ToString | Returns a string that represents the current structure.


NBiometricQualityBlock Properties

NBiometricQualityBlock Properties
Legend
NBiometricQualityBlock Properties
Name | Description
NativeType | Defines the native type of the object.
QualityAlgorithmId | Gets or sets the CBEFF Quality Algorithm Identifier.
QualityAlgorithmVendorId | Gets or sets the CBEFF Biometric Quality Algorithm Vendor Identifier (CBEFF Biometric Organization Identifier).
QualityScore | Gets or sets the quality score.


NBiometricTypes Fields

NBiometricTypes Fields
Legend
NBiometricTypes Fields
Name | Description
PhraseIdUnknown | Unknown phrase ID.
QualityFailed | Failed or unspecified quality.
QualityMax | Maximal quality.
QualityMin | Minimal quality.
QualityUnknown | Unknown quality.


Legend

Legend
Legend
Data Member
Method
static
Property
read only


NBiometricTypes Class Members

NBiometricTypes Class Members
Legend
Members
NBiometricTypes Fields
Name | Description
PhraseIdUnknown | Unknown phrase ID.
QualityFailed | Failed or unspecified quality.
QualityMax | Maximal quality.
QualityMin | Minimal quality.
QualityUnknown | Unknown quality.
NBiometricTypes Methods
Name | Description
AngleFromDegrees | Converts the specified degrees top angle.
AngleFromRadians | Converts the specified angle from radians to degrees.
AngleToDegrees | Converts the specified angle from degrees.
AngleToRadians | Converts the specified angle from degrees to radians.
AngleToString | Gets a string representation of the specified angle.
GetPositionAvailableParts | Determines available iris positions based on specified missing iris positions and base position.
IsBiometricStatusFinal | Checks whether the biometric status is final.
IsBiometricStatusValid | Checks whether the value passed as a parameter is defined in NBiometricStatus.
IsBiometricSubtypeValid | Checks whether the value passed as a parameter is defined in NBiometricSubtype.
IsBiometricTypeValid | Checks whether the value passed as a parameter is defined in NBiometricType.
IsImpressionTypeCompatibleWith | Gets the Bool value that specify whether two values are compatible.
IsImpressionTypeContact | ... more
IsImpressionTypeContactless | Checks if the specified NFImpressionType value is one of the following: nfitLiveScanContactless, nfitLiveScanOpticalContactlessPlain, nfitLiveScanOpticalContactlessRolled, nfitLiveScanNonOpticalContactlessPlain, nfitLiveScanNonOpticalContactlessRolled.
IsImpressionTypeFinger | Checks whether the specified value is fingerprint.
IsImpressionTypeGeneric | Checks whether the impression type is generic.
IsImpressionTypeLatent | Checks whether the specified value is a latent scan.
IsImpressionTypeLiveScan | Checks whether the specified value is a live scan.
IsImpressionTypeNonOptical | ... more
IsImpressionTypeNonliveScan | Checks whether the specified value is a non-live scan.
IsImpressionTypeOneOf | Checks whether specified NFImpressionType value matches one in an array.
IsImpressionTypeOptical | ... more
IsImpressionTypePalm | Checks whether the specified value is a palmprint.
IsImpressionTypePlain | Checks whether the specified value is a plain scan or optical contact/contactless.
IsImpressionTypeRolled | Checks whether the specified value is one of rolled biometric types.
IsImpressionTypeSwipe | ... more
IsImpressionTypeValid | Checks whether the value passed as a parameter is a valid NFImpressionType value.
IsImpressionTypeValidFinger | Checks whether the specified value is a valid fingerprint.
IsImpressionTypeValidPalm | Checks whether the specified value is a valid palmprint.
IsNfiqQualityValid | Checks whether the specified value is a valid NfiqQuality value.
IsNfiqValid | Checks whether the specified value is a valid NIST Fingerprint Image Quality (NFIQ 1.0 or NFIQ 2.0) value. NFIQ 1.0 valid byte value can be 20 (poor), 40 (fair), 60 (good), 80 (very good), 100 (excellent), 254 (NFIQ 1.0 was not calculated) and 255 (failed to calculate NFIQ 1.0 value). NFIQ 2.0 valid byte value can be from interval [0; 100], 254 (NFIQ 2.0 was not calculated) and 255 (failed to calculate NFIQ 2.0 value).
IsPatternClassValid | Checks whether the specified value is a valid NFPatternClass value.
IsPatternClassValidFor | Checks whether the specified NFPatternClass value is valid for specified NFPosition.
IsPositionCompatibleWith | Gets the Bool value that specify whether two values are compatible.
IsPositionFinger | Checks whether the specified value is fingerprint.
IsPositionFourFingers | Checks if the specified value is a type of 4 fingerprints data.
IsPositionKnown | Checks whether the specified position is known.
IsPositionLeft | Checks whether the specified position is left.
IsPositionLeftAndRight | Checks whether the specified position is left and right fingerprint.
IsPositionOneOf | Checks whether specified NEPosition value matches one in an array.
IsPositionPalm | Checks whether the specified value is a palmprint.
IsPositionRight | Checks whether the specified position is right.
IsPositionRightAndLeft | Checks whether the specified position is both right and left.
IsPositionSingleEye | Checks whether the specified position represents a single eye.
IsPositionSingleFinger | Checks whether the specified value is a single fingerprint.
IsPositionTheEye | Checks whether the specified position represents an eye.
IsPositionTheFinger | Checks whether the specified value is the fingerprint.
IsPositionThePalm | Checks whether the specified value is a palmprint.
IsPositionThreeFingers | Checks whether the specified value is a type of 3 fingerprints data.
IsPositionTwoEyes | Checks whether the specified position represents two eyes.
IsPositionTwoFingers | Checks whether the specified value is a type of 2 fingerprints data.
IsPositionValid | Checks whether the value passed as a parameter is a valid NEPosition value.
IsPositionValidFinger | Checks whether the specified value is a valid fingerprint.
IsPositionValidPalm | Checks whether the specified value is a valid palmprint.
IsPositionValidTheEye | Checks whether the specified value is a valid NEPosition value.
IsPositionValidTheFinger | Checks whether the specified value is a valid fingerprint.
IsQualityValid | Checks whether the quality value is valid.
Nfiq1ToNfiqQuality | Converts specified NFIQ 1.0 (NIST Fingerprint Image Quality) value to NfiqQuality value.
NfiqQualityToNfiq1 | Converts specified NfiqQuality value to NFIQ 1.0 (NIST Fingerprint Image Quality) value.
QualityToString | Gets a string representation of the specified quality value.
ToImpressionTypeFinger | Converts an impression type to finger impression type.
NBiometricTypes Properties
Name | Description
NBiometricStatusNativeType | Defines the native type of the biometric status.
NBiometricSubtypeNativeType | Defines the native type of the biometric subtype.
NBiometricTypeNativeType | Defines the native type of the biometric type.
NEImageTypeNativeType | Defines the native type of the iris image type.
NEPositionNativeType | Defines the native type of the iris position.
NFImpressionTypeNativeType | Defines the native type of the finger impression type.
NFMinutiaFormatNativeType | Defines the native type of the fingerprint minutia format.
NFMinutiaTypeNativeType | Defines the native type of the fingerprint minutia type.
NFPatternClassNativeType | Defines the native type of the pattern class.
NFPositionNativeType | Defines the native type of the finger position.
NFRidgeCountsTypeNativeType | Defines the native type of the fingerprint ridge count.
NGenderNativeType | Defines the native type of the gender.
NIcaoWarningsNativeType | Defines the native type of the icao warnings.
NLExpressionNativeType | Defines the native type of the face expression.
NLPropertiesNativeType | Defines the native type of the face properties.
NLivenessActionNativeType | Defines the native type of the liveness action.
NLivenessModeNativeType | Defines the native type of the liveness mode.
NTemplateSizeNativeType | Defines the native type of the template size.
NativeType | Defines the native type of the object.
NfiqQualityNativeType | Defines the native type of the fingerprint image quality.


NBiometricTypes Methods

NBiometricTypes Methods
Legend
NBiometricTypes Methods
Name | Description
AngleFromDegrees | Converts the specified degrees top angle.
AngleFromRadians | Converts the specified angle from radians to degrees.
AngleToDegrees | Converts the specified angle from degrees.
AngleToRadians | Converts the specified angle from degrees to radians.
AngleToString | Gets a string representation of the specified angle.
GetPositionAvailableParts | Determines available iris positions based on specified missing iris positions and base position.
IsBiometricStatusFinal | Checks whether the biometric status is final.
IsBiometricStatusValid | Checks whether the value passed as a parameter is defined in NBiometricStatus.
IsBiometricSubtypeValid | Checks whether the value passed as a parameter is defined in NBiometricSubtype.
IsBiometricTypeValid | Checks whether the value passed as a parameter is defined in NBiometricType.
IsImpressionTypeCompatibleWith | Gets the Bool value that specify whether two values are compatible.
IsImpressionTypeContact | ... more
IsImpressionTypeContactless | Checks if the specified NFImpressionType value is one of the following: nfitLiveScanContactless, nfitLiveScanOpticalContactlessPlain, nfitLiveScanOpticalContactlessRolled, nfitLiveScanNonOpticalContactlessPlain, nfitLiveScanNonOpticalContactlessRolled.
IsImpressionTypeFinger | Checks whether the specified value is fingerprint.
IsImpressionTypeGeneric | Checks whether the impression type is generic.
IsImpressionTypeLatent | Checks whether the specified value is a latent scan.
IsImpressionTypeLiveScan | Checks whether the specified value is a live scan.
IsImpressionTypeNonOptical | ... more
IsImpressionTypeNonliveScan | Checks whether the specified value is a non-live scan.
IsImpressionTypeOneOf | Checks whether specified NFImpressionType value matches one in an array.
IsImpressionTypeOptical | ... more
IsImpressionTypePalm | Checks whether the specified value is a palmprint.
IsImpressionTypePlain | Checks whether the specified value is a plain scan or optical contact/contactless.
IsImpressionTypeRolled | Checks whether the specified value is one of rolled biometric types.
IsImpressionTypeSwipe | ... more
IsImpressionTypeValid | Checks whether the value passed as a parameter is a valid NFImpressionType value.
IsImpressionTypeValidFinger | Checks whether the specified value is a valid fingerprint.
IsImpressionTypeValidPalm | Checks whether the specified value is a valid palmprint.
IsNfiqQualityValid | Checks whether the specified value is a valid NfiqQuality value.
IsNfiqValid | Checks whether the specified value is a valid NIST Fingerprint Image Quality (NFIQ 1.0 or NFIQ 2.0) value. NFIQ 1.0 valid byte value can be 20 (poor), 40 (fair), 60 (good), 80 (very good), 100 (excellent), 254 (NFIQ 1.0 was not calculated) and 255 (failed to calculate NFIQ 1.0 value). NFIQ 2.0 valid byte value can be from interval [0; 100], 254 (NFIQ 2.0 was not calculated) and 255 (failed to calculate NFIQ 2.0 value).
IsPatternClassValid | Checks whether the specified value is a valid NFPatternClass value.
IsPatternClassValidFor | Checks whether the specified NFPatternClass value is valid for specified NFPosition.
IsPositionCompatibleWith | Gets the Bool value that specify whether two values are compatible.
IsPositionFinger | Checks whether the specified value is fingerprint.
IsPositionFourFingers | Checks if the specified value is a type of 4 fingerprints data.
IsPositionKnown | Checks whether the specified position is known.
IsPositionLeft | Checks whether the specified position is left.
IsPositionLeftAndRight | Checks whether the specified position is left and right fingerprint.
IsPositionOneOf | Checks whether specified NEPosition value matches one in an array.
IsPositionPalm | Checks whether the specified value is a palmprint.
IsPositionRight | Checks whether the specified position is right.
IsPositionRightAndLeft | Checks whether the specified position is both right and left.
IsPositionSingleEye | Checks whether the specified position represents a single eye.
IsPositionSingleFinger | Checks whether the specified value is a single fingerprint.
IsPositionTheEye | Checks whether the specified position represents an eye.
IsPositionTheFinger | Checks whether the specified value is the fingerprint.
IsPositionThePalm | Checks whether the specified value is a palmprint.
IsPositionThreeFingers | Checks whether the specified value is a type of 3 fingerprints data.
IsPositionTwoEyes | Checks whether the specified position represents two eyes.
IsPositionTwoFingers | Checks whether the specified value is a type of 2 fingerprints data.
IsPositionValid | Checks whether the value passed as a parameter is a valid NEPosition value.
IsPositionValidFinger | Checks whether the specified value is a valid fingerprint.
IsPositionValidPalm | Checks whether the specified value is a valid palmprint.
IsPositionValidTheEye | Checks whether the specified value is a valid NEPosition value.
IsPositionValidTheFinger | Checks whether the specified value is a valid fingerprint.
IsQualityValid | Checks whether the quality value is valid.
Nfiq1ToNfiqQuality | Converts specified NFIQ 1.0 (NIST Fingerprint Image Quality) value to NfiqQuality value.
NfiqQualityToNfiq1 | Converts specified NfiqQuality value to NFIQ 1.0 (NIST Fingerprint Image Quality) value.
QualityToString | Gets a string representation of the specified quality value.
ToImpressionTypeFinger | Converts an impression type to finger impression type.


NBiometricTypes Properties

NBiometricTypes Properties
Legend
NBiometricTypes Properties
Name | Description
NBiometricStatusNativeType | Defines the native type of the biometric status.
NBiometricSubtypeNativeType | Defines the native type of the biometric subtype.
NBiometricTypeNativeType | Defines the native type of the biometric type.
NEImageTypeNativeType | Defines the native type of the iris image type.
NEPositionNativeType | Defines the native type of the iris position.
NFImpressionTypeNativeType | Defines the native type of the finger impression type.
NFMinutiaFormatNativeType | Defines the native type of the fingerprint minutia format.
NFMinutiaTypeNativeType | Defines the native type of the fingerprint minutia type.
NFPatternClassNativeType | Defines the native type of the pattern class.
NFPositionNativeType | Defines the native type of the finger position.
NFRidgeCountsTypeNativeType | Defines the native type of the fingerprint ridge count.
NGenderNativeType | Defines the native type of the gender.
NIcaoWarningsNativeType | Defines the native type of the icao warnings.
NLExpressionNativeType | Defines the native type of the face expression.
NLPropertiesNativeType | Defines the native type of the face properties.
NLivenessActionNativeType | Defines the native type of the liveness action.
NLivenessModeNativeType | Defines the native type of the liveness mode.
NTemplateSizeNativeType | Defines the native type of the template size.
NativeType | Defines the native type of the object.
NfiqQualityNativeType | Defines the native type of the fingerprint image quality.


NBiometrics Fields

NBiometrics Fields
Legend
NBiometrics Fields
Name | Description
DllName | Name of DLL containing unmanaged part of this class.


Legend

Legend
Legend
Data Member
Property
read only
static


NBiometrics Class Members

NBiometrics Class Members
Legend
Members
NBiometrics Fields
Name | Description
DllName | Name of DLL containing unmanaged part of this class.
NBiometrics Properties
Name | Description
NativeModule | Gets or sets a pointer to the function that retrieves NModule object for the specified module name.


NBiometrics Properties

NBiometrics Properties
Legend
NBiometrics Properties
Name | Description
NativeModule | Gets or sets a pointer to the function that retrieves NModule object for the specified module name.


NFCore Structure Members

NFCore Structure Members
Legend
Members
Methods
Name | Description
NFCore | Initializes a new instance of the NFCore structure.
NFCore Methods
Name | Description
ToString | Retrieves string representation of the specified object.
NFCore Properties
Name | Description
Angle | Gets or sets Angle of core.
AngleDeg | Gets or sets angle in degrees.
NativeType | Defines the native type of the object.
RawAngle | Gets or sets raw angle of core
X | Gets or sets x coordinate of core.
Y | Gets or sets y coordinate of core.


NFCore Structure Methods

NFCore Structure Methods
Legend
Methods
Name | Description
NFCore | Initializes a new instance of the NFCore structure.


NFCore Methods

NFCore Methods
Legend
NFCore Methods
Name | Description
ToString | Retrieves string representation of the specified object.


NFCore Properties

NFCore Properties
Legend
NFCore Properties
Name | Description
Angle | Gets or sets Angle of core.
AngleDeg | Gets or sets angle in degrees.
NativeType | Defines the native type of the object.
RawAngle | Gets or sets raw angle of core
X | Gets or sets x coordinate of core.
Y | Gets or sets y coordinate of core.


NFDelta Structure Members

NFDelta Structure Members
Legend
Members
Methods
Name | Description
NFDelta | Initializes a new instance of the NFDelta structure.
NFDelta Methods
Name | Description
ToString | Returns a string that represents the current NFDelta object.
NFDelta Properties
Name | Description
Angle1 | Gets or sets the first angle of delta.
Angle2 | Gets or sets the second angle of delta.
Angle3 | Gets or sets the third angle of delta.
AngleDeg1 | Gets or sets the first angle of delta in degrees.
AngleDeg2 | Gets or sets the second angle of delta in degrees.
AngleDeg3 | Gets or sets the third angle of delta in degrees.
NativeType | Defines the native type of the object.
RawAngle1 | Gets or sets the first row angle of the delta.
RawAngle2 | Gets or sets the second row angle of the delta.
RawAngle3 | Gets or sets the third row angle of the delta.
X | Gets or sets x coordinate of delta.
Y | Gets or sets y coordinate of delta.


NFDelta Structure Methods

NFDelta Structure Methods
Legend
Methods
Name | Description
NFDelta | Initializes a new instance of the NFDelta structure.


NFDelta Methods

NFDelta Methods
Legend
NFDelta Methods
Name | Description
ToString | Returns a string that represents the current NFDelta object.


NFDelta Properties

NFDelta Properties
Legend
NFDelta Properties
Name | Description
Angle1 | Gets or sets the first angle of delta.
Angle2 | Gets or sets the second angle of delta.
Angle3 | Gets or sets the third angle of delta.
AngleDeg1 | Gets or sets the first angle of delta in degrees.
AngleDeg2 | Gets or sets the second angle of delta in degrees.
AngleDeg3 | Gets or sets the third angle of delta in degrees.
NativeType | Defines the native type of the object.
RawAngle1 | Gets or sets the first row angle of the delta.
RawAngle2 | Gets or sets the second row angle of the delta.
RawAngle3 | Gets or sets the third row angle of the delta.
X | Gets or sets x coordinate of delta.
Y | Gets or sets y coordinate of delta.


NFDoubleCore Structure Members

NFDoubleCore Structure Members
Legend
Members
Methods
Name | Description
NFDoubleCore | Initializes a new instance of the NFDoubleCore class.
NFDoubleCore Methods
Name | Description
ToString | Returns a string that represents the current NFDoubleCore object.
NFDoubleCore Properties
Name | Description
NativeType | Defines the native type of the object.
X | Gets or sets x coordinate of the double core.
Y | Gets or sets y coordinate of the double core.


NFDoubleCore Structure Methods

NFDoubleCore Structure Methods
Legend
Methods
Name | Description
NFDoubleCore | Initializes a new instance of the NFDoubleCore class.


NFDoubleCore Methods

NFDoubleCore Methods
Legend
NFDoubleCore Methods
Name | Description
ToString | Returns a string that represents the current NFDoubleCore object.


NFDoubleCore Properties

NFDoubleCore Properties
Legend
NFDoubleCore Properties
Name | Description
NativeType | Defines the native type of the object.
X | Gets or sets x coordinate of the double core.
Y | Gets or sets y coordinate of the double core.


NFMinutia Structure Members

NFMinutia Structure Members
Legend
Members
Methods
Name | Description
NFMinutia | Initializes a new instance of the NFMinutia class.
NFMinutia Methods
Name | Description
ToString | Returns a string that represents the current NFMinutia object.
NFMinutia Properties
Name | Description
Angle | Gets or sets the angle of the minutia.
AngleDeg | Gets or sets the angle in degrees of the minutia.
Curvature | Gets or sets the ridge curvature near minutia.
G | Gets or sets the G (ridge density) near minutia.
NativeType | Defines the native type of the object.
Quality | Gets or sets quality of the minutia.
RawAngle | Gets or sets the raw angle of the minutia.
Type | Gets or sets the type of the minutia.
X | Gets or sets x coordinate of the minutia.
Y | Gets or sets y coordinate of the minutia.


NFMinutia Structure Methods

NFMinutia Structure Methods
Legend
Methods
Name | Description
NFMinutia | Initializes a new instance of the NFMinutia class.


NFMinutia Methods

NFMinutia Methods
Legend
NFMinutia Methods
Name | Description
ToString | Returns a string that represents the current NFMinutia object.


NFMinutia Properties

NFMinutia Properties
Legend
NFMinutia Properties
Name | Description
Angle | Gets or sets the angle of the minutia.
AngleDeg | Gets or sets the angle in degrees of the minutia.
Curvature | Gets or sets the ridge curvature near minutia.
G | Gets or sets the G (ridge density) near minutia.
NativeType | Defines the native type of the object.
Quality | Gets or sets quality of the minutia.
RawAngle | Gets or sets the raw angle of the minutia.
Type | Gets or sets the type of the minutia.
X | Gets or sets x coordinate of the minutia.
Y | Gets or sets y coordinate of the minutia.


NFMinutiaNeighbor Fields

NFMinutiaNeighbor Fields
Legend
NFMinutiaNeighbor Fields
Name | Description
Empty | Represents a NFMinutiaNeighbor that is a null reference.


NFMinutiaNeighbor Structure Members

NFMinutiaNeighbor Structure Members
Legend
Members
Methods
Name | Description
NFMinutiaNeighbor | Initializes a new instance of the NFMinutiaNeighbor class.
NFMinutiaNeighbor Fields
Name | Description
Empty | Represents a NFMinutiaNeighbor that is a null reference.
NFMinutiaNeighbor Methods
Name | Description
ToString | Returns a string that represents the current NFMinutiaNeighbor object.
NFMinutiaNeighbor Properties
Name | Description
Index | Gets or sets the index of minutia neighbor.
NativeType | Defines the native type of the object.
RidgeCount | Gets or sets the ridge count between the minutia and minutia neighbor.


NFMinutiaNeighbor Structure Methods

NFMinutiaNeighbor Structure Methods
Legend
Methods
Name | Description
NFMinutiaNeighbor | Initializes a new instance of the NFMinutiaNeighbor class.


NFMinutiaNeighbor Methods

NFMinutiaNeighbor Methods
Legend
NFMinutiaNeighbor Methods
Name | Description
ToString | Returns a string that represents the current NFMinutiaNeighbor object.


NFMinutiaNeighbor Properties

NFMinutiaNeighbor Properties
Legend
NFMinutiaNeighbor Properties
Name | Description
Index | Gets or sets the index of minutia neighbor.
NativeType | Defines the native type of the object.
RidgeCount | Gets or sets the ridge count between the minutia and minutia neighbor.


NFace Classes

NFace Classes
Legend
NFace Classes
NFace Class
Name | Description
ObjectCollection | Collection of NLAttributes objects.


NFace Class Members

NFace Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NBiometric Class
Show:
No members matching the current filter
Name | Description
IsBiometricCaptureOptionsValid | Checks whether the specified biometric capture options are valid.
NFace Class
Name | Description
FromImageAndAttributes | Creates NFace object from specified face image and attributes.
GetImage | Retrieves the face image of the specified NFace object.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NBiometric Class
Show:
No members matching the current filter
Name | Description
BiometricType | Gets the biometric type.
CaptureOptions | Gets or sets the biometric capture options.
Error | Gets the last exception.
FileName | Gets or sets the file name.
HasMoreSamples | Gets or sets whether the NBioemtric object has more samples.
NBiometricCaptureOptionsNativeType | Defines the native type of the capture options.
NativeType | Defines the native type of the object.
Owner | Gets owner of the object.
ParentObject | Gets the parent object.
SampleBuffer | Gets or sets sample buffer. Use similar to FileName property, but this is more efficient if file contents are already loaded to memory.
SessionId | Gets or sets the session ID.
Status | Gets or sets the biometric status.
NFace Class
Name | Description
Image | Gets or sets the face image of the NFace object.
NativeType | Defines the native type of the object.
Objects | Retrieves the collection of NLAttributes of the NFace object.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Methods
NFace Class
Name | Description
NFace | Creates a new NFace object.
NFace Classes
NFace Class
Name | Description
ObjectCollection | Collection of NLAttributes objects.


NFace Class Methods

NFace Class Methods
Legend
Methods
NFace Class
Name | Description
NFace | Creates a new NFace object.


NDisposable Methods

NDisposable Methods
Legend
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NBiometric Class
Show:
No members matching the current filter
Name | Description
IsBiometricCaptureOptionsValid | Checks whether the specified biometric capture options are valid.
NFace Class
Name | Description
FromImageAndAttributes | Creates NFace object from specified face image and attributes.
GetImage | Retrieves the face image of the specified NFace object.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NBiometric Class
Show:
No members matching the current filter
Name | Description
BiometricType | Gets the biometric type.
CaptureOptions | Gets or sets the biometric capture options.
Error | Gets the last exception.
FileName | Gets or sets the file name.
HasMoreSamples | Gets or sets whether the NBioemtric object has more samples.
NBiometricCaptureOptionsNativeType | Defines the native type of the capture options.
NativeType | Defines the native type of the object.
Owner | Gets owner of the object.
ParentObject | Gets the parent object.
SampleBuffer | Gets or sets sample buffer. Use similar to FileName property, but this is more efficient if file contents are already loaded to memory.
SessionId | Gets or sets the session ID.
Status | Gets or sets the biometric status.
NFace Class
Name | Description
Image | Gets or sets the face image of the NFace object.
NativeType | Defines the native type of the object.
Objects | Retrieves the collection of NLAttributes of the NFace object.


NLAttributes Classes

NLAttributes Classes
Legend
NLAttributes Classes
NLAttributes Class
Name | Description
FeaturePointCollection | Collection of feature points.


NLAttributes Class Members

NLAttributes Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NBiometricAttributes Class
Show:
No members matching the current filter
Name | Description
BiometricType | Gets the biometric type.
Child | Gets child NBiometric object of the current NBiometricAttributes.
ChildSubject | Gets child NSubject of the current NBiometricAttributes.
DetectionConfidence | Gets or sets the detection confidence.
LivenessConfidence | Gets or sets presentation attack detection confidence value.
NativeType | Defines the native type of the object.
Quality | Gets or sets the quality.
Status | Gets or sets the biometric status.
NLAttributes Class
Name | Description
AdditionalFacesDetected | Gets or sets if any additioanl faces were detected.
Age | Gets or sets age value.
BackgroundUniformity | Gets or sets the image background uniformity value.
BaseFrameIndex | Gets or sets base frame index value.
BeardConfidence | Gets or sets the beard confidence value.
BlinkConfidence | Gets or sets the blink confidence value.
BoundingRect | Gets or sets the bounding rectangle that completely encloses face.
Contrast | Gets or sets the contrast value.
DarkGlassesConfidence | Gets or sets the dark glasses confidence value.
EmotionAngerConfidence | Gets or sets anger confidence value.
EmotionContemptConfidence | Gets or sets anger confidence value.
EmotionDisgustConfidence | Gets or sets disgust confidence value.
EmotionFearConfidence | Gets or sets fear confidence value.
EmotionHappinessConfidence | Gets or sets happiness confidence value.
EmotionNeutralConfidence | Gets or sets the neutral emotion confidence value.
EmotionSadnessConfidence | Gets or sets sadness confidence value.
EmotionSurpriseConfidence | Gets or sets surprise confidence value.
EthnicityArabianConfidence | Gets or sets ethnicity Arabian confidence value.
EthnicityAsianConfidence | Gets or sets ethnicity Asian confidence value.
EthnicityBlackConfidence | Gets or sets ethnicity Black confidence value.
EthnicityHispanicConfidence | Gets or sets ethnicity Hispanic confidence value.
EthnicityIndianConfidence | Gets or sets ethnicity Indian confidence value.
EthnicityWhiteConfidence | Gets or sets ethnicity White confidence value.
Expression | Gets or sets the expression value.
ExpressionConfidence | Gets or sets the expression confidence value.
FaceDarknessConfidence | Gets the face darkness confidence value.
FaceMaskConfidence | Gets or sets the face mask confidence value.
FeaturePoints | Retrieves the feature point collection.
Gender | Gets or set the gender value.
GenderConfidence | Gets the gender confidence value. Setter is deprecated.
GlassesConfidence | Gets or sets the glasses confidence value.
GlassesReflectionConfidence | Gets the glasses reflection confidence value.
GrayscaleDensity | Gets or sets the image grayscale density value.
HatConfidence | Gets or sets the hat confidence value.
HeavyFrameConfidence | Gets or sets the heavy frame confidence value.
IcaoWarnings | Gets or sets one of NIcaoWarnings values.
LeftEyeCenter | Gets or sets the center of the left eye.
LivenessAction | Gets or sets face liveness action value.
LivenessScore | Gets or sets face liveness score value.
LivenessTargetPitch | Gets liveness detection pitch angle.
LivenessTargetYaw | Gets or sets liveness detection yaw rotation angle.
LookingAwayConfidence | Gets the eye look confidence value.
MocTemplate | Gets Match-on-Card face template, if engine was configured to extract it.
MouthCenter | Gets or sets the center of the mouth.
MouthOpenConfidence | Gets or sets the mouth open confidence value.
MustacheConfidence | Gets or sets the mustache confidence value.
NativeType | Defines the native type of the object.
Noise | Gets or sets the noise value.
NoseTip | Gets or sets the tip of the nose.
Owner | Gets the owner object.
Pitch | Gets or sets the image pitch value in degrees. The calculation of this value is not implemented.
PixelationConfidence | Gets the pixelation confidence value.
Properties | Gets or sets NLAttributes properties.
RedEyeConfidence | Gets the red eye confidence value.
RightEyeCenter | Gets or sets the center of the right eye.
Roll | Gets or sets the image roll value in degrees. Positive angles represent faces tilted toward their left shoulder (a clockwise rotation around the z-axis).
Saturation | Gets or sets the saturation value.
Sharpness | Gets or sets the image sharpness value.
SkinReflectionConfidence | Gets the skin reflection confidence value.
Template | Gets a face template contained in a NLTemplate object.
Thumbnail | Gets or sets the thumbnail image.
TokenImageRect | Gets or sets face token image rectangle.
UnnaturalSkinToneConfidence | Gets the skin tone confidence value.
WashedOutConfidence | Gets the washed out confidence value.
Yaw | Gets or sets the image yaw value in degrees. Positive angles represent faces looking to their right (a clockwise rotation around the y-axis).
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Methods
NLAttributes Class
Name | Description
NLAttributes | Initializes a new instance of NLAttributes class.
NLAttributes Classes
NLAttributes Class
Name | Description
FeaturePointCollection | Collection of feature points.


NLAttributes Class Methods

NLAttributes Class Methods
Legend
Methods
NLAttributes Class
Name | Description
NLAttributes | Initializes a new instance of NLAttributes class.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NBiometricAttributes Class
Show:
No members matching the current filter
Name | Description
BiometricType | Gets the biometric type.
Child | Gets child NBiometric object of the current NBiometricAttributes.
ChildSubject | Gets child NSubject of the current NBiometricAttributes.
DetectionConfidence | Gets or sets the detection confidence.
LivenessConfidence | Gets or sets presentation attack detection confidence value.
NativeType | Defines the native type of the object.
Quality | Gets or sets the quality.
Status | Gets or sets the biometric status.
NLAttributes Class
Name | Description
AdditionalFacesDetected | Gets or sets if any additioanl faces were detected.
Age | Gets or sets age value.
BackgroundUniformity | Gets or sets the image background uniformity value.
BaseFrameIndex | Gets or sets base frame index value.
BeardConfidence | Gets or sets the beard confidence value.
BlinkConfidence | Gets or sets the blink confidence value.
BoundingRect | Gets or sets the bounding rectangle that completely encloses face.
Contrast | Gets or sets the contrast value.
DarkGlassesConfidence | Gets or sets the dark glasses confidence value.
EmotionAngerConfidence | Gets or sets anger confidence value.
EmotionContemptConfidence | Gets or sets anger confidence value.
EmotionDisgustConfidence | Gets or sets disgust confidence value.
EmotionFearConfidence | Gets or sets fear confidence value.
EmotionHappinessConfidence | Gets or sets happiness confidence value.
EmotionNeutralConfidence | Gets or sets the neutral emotion confidence value.
EmotionSadnessConfidence | Gets or sets sadness confidence value.
EmotionSurpriseConfidence | Gets or sets surprise confidence value.
EthnicityArabianConfidence | Gets or sets ethnicity Arabian confidence value.
EthnicityAsianConfidence | Gets or sets ethnicity Asian confidence value.
EthnicityBlackConfidence | Gets or sets ethnicity Black confidence value.
EthnicityHispanicConfidence | Gets or sets ethnicity Hispanic confidence value.
EthnicityIndianConfidence | Gets or sets ethnicity Indian confidence value.
EthnicityWhiteConfidence | Gets or sets ethnicity White confidence value.
Expression | Gets or sets the expression value.
ExpressionConfidence | Gets or sets the expression confidence value.
FaceDarknessConfidence | Gets the face darkness confidence value.
FaceMaskConfidence | Gets or sets the face mask confidence value.
FeaturePoints | Retrieves the feature point collection.
Gender | Gets or set the gender value.
GenderConfidence | Gets the gender confidence value. Setter is deprecated.
GlassesConfidence | Gets or sets the glasses confidence value.
GlassesReflectionConfidence | Gets the glasses reflection confidence value.
GrayscaleDensity | Gets or sets the image grayscale density value.
HatConfidence | Gets or sets the hat confidence value.
HeavyFrameConfidence | Gets or sets the heavy frame confidence value.
IcaoWarnings | Gets or sets one of NIcaoWarnings values.
LeftEyeCenter | Gets or sets the center of the left eye.
LivenessAction | Gets or sets face liveness action value.
LivenessScore | Gets or sets face liveness score value.
LivenessTargetPitch | Gets liveness detection pitch angle.
LivenessTargetYaw | Gets or sets liveness detection yaw rotation angle.
LookingAwayConfidence | Gets the eye look confidence value.
MocTemplate | Gets Match-on-Card face template, if engine was configured to extract it.
MouthCenter | Gets or sets the center of the mouth.
MouthOpenConfidence | Gets or sets the mouth open confidence value.
MustacheConfidence | Gets or sets the mustache confidence value.
NativeType | Defines the native type of the object.
Noise | Gets or sets the noise value.
NoseTip | Gets or sets the tip of the nose.
Owner | Gets the owner object.
Pitch | Gets or sets the image pitch value in degrees. The calculation of this value is not implemented.
PixelationConfidence | Gets the pixelation confidence value.
Properties | Gets or sets NLAttributes properties.
RedEyeConfidence | Gets the red eye confidence value.
RightEyeCenter | Gets or sets the center of the right eye.
Roll | Gets or sets the image roll value in degrees. Positive angles represent faces tilted toward their left shoulder (a clockwise rotation around the z-axis).
Saturation | Gets or sets the saturation value.
Sharpness | Gets or sets the image sharpness value.
SkinReflectionConfidence | Gets the skin reflection confidence value.
Template | Gets a face template contained in a NLTemplate object.
Thumbnail | Gets or sets the thumbnail image.
TokenImageRect | Gets or sets face token image rectangle.
UnnaturalSkinToneConfidence | Gets the skin tone confidence value.
WashedOutConfidence | Gets the washed out confidence value.
Yaw | Gets or sets the image yaw value in degrees. Positive angles represent faces looking to their right (a clockwise rotation around the y-axis).


NLFeaturePoint Structure Members

NLFeaturePoint Structure Members
Legend
Members
Methods
Name | Description
NLFeaturePoint | Initializes a new instance of NLFeaturePoint structure.
NLFeaturePoint Methods
Name | Description
ToString | Retrieves a string representation of the object.
NLFeaturePoint Properties
Name | Description
Code | Gets or sets the feature code.
Confidence | Gets or sets the feature confidence.
NativeType | Defines the native type of the object.
X | Gets or sets the X-coordinate of the feature point.
Y | Gets or sets the Y-coordinate of the feature point.


NLFeaturePoint Structure Methods

NLFeaturePoint Structure Methods
Legend
Methods
Name | Description
NLFeaturePoint | Initializes a new instance of NLFeaturePoint structure.


NLFeaturePoint Methods

NLFeaturePoint Methods
Legend
NLFeaturePoint Methods
Name | Description
ToString | Retrieves a string representation of the object.


NLFeaturePoint Properties

NLFeaturePoint Properties
Legend
NLFeaturePoint Properties
Name | Description
Code | Gets or sets the feature code.
Confidence | Gets or sets the feature confidence.
NativeType | Defines the native type of the object.
X | Gets or sets the X-coordinate of the feature point.
Y | Gets or sets the Y-coordinate of the feature point.


Legend

Legend
Legend
Property
read only
static


NLMatchingDetails Class Members

NLMatchingDetails Class Members
Legend
Members
NLMatchingDetails Properties
Name | Description
NativeType | Defines the native type of the object.


NLMatchingDetails Properties

NLMatchingDetails Properties
Legend
NLMatchingDetails Properties
Name | Description
NativeType | Defines the native type of the object.


NLRecord Class Members

NLRecord Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NLRecord Class
Name | Description
Check | Checks if format of packed NLRecord is correct. Checks if format of packed NLRecord is correct.
GetQuality | Retrieves face quality from packed NLRecord.
GetSize | Gets the size of packed NLRecord.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NLRecord Class
Name | Description
CbeffProductType | Gets or sets the Cbeff product type of the NLRecord.
NativeType | Defines the native type of the object.
Quality | Gets or sets face quality.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Methods
NLRecord Class
Name | Description
NLRecord | Initializes a new instance of the NLRecord class.


NLRecord Class Methods

NLRecord Class Methods
Legend
Methods
NLRecord Class
Name | Description
NLRecord | Initializes a new instance of the NLRecord class.


NDisposable Methods

NDisposable Methods
Legend
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NLRecord Class
Name | Description
Check | Checks if format of packed NLRecord is correct. Checks if format of packed NLRecord is correct.
GetQuality | Retrieves face quality from packed NLRecord.
GetSize | Gets the size of packed NLRecord.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NLRecord Class
Name | Description
CbeffProductType | Gets or sets the Cbeff product type of the NLRecord.
NativeType | Defines the native type of the object.
Quality | Gets or sets face quality.


NLTemplate Classes

NLTemplate Classes
Legend
NLTemplate Classes
NLTemplate Class
Name | Description
RecordCollection | Collection of NLRecords.


NObject Fields

NObject Fields
Legend
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NLTemplate Class
Name | Description
FlagProcessFirstRecordOnly | The flag indicating whether only the first face record should be unpacked or packed while unpacking or packing NLTemplate.
MaxRecordCount | The maximum number of face records NLTemplate can contain.


NLTemplate Class Members

NLTemplate Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NLTemplate Class
Name | Description
CalculateSize | Calculates NLTemplate size.
Check | Checks if format of packed NLTemplate format is correct.
GetRecordCount | Retrieves records count.
GetSize | Gets the size of packed NLTemplate.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NLTemplate Class
Name | Description
NativeType | Defines the native type of the object.
Records | Gets Records collection.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NLTemplate Class
Name | Description
FlagProcessFirstRecordOnly | The flag indicating whether only the first face record should be unpacked or packed while unpacking or packing NLTemplate.
MaxRecordCount | The maximum number of face records NLTemplate can contain.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Methods
NLTemplate Class
Name | Description
NLTemplate | Initializes a new instance of the NLTemplate class.
NLTemplate Classes
NLTemplate Class
Name | Description
RecordCollection | Collection of NLRecords.


NLTemplate Class Methods

NLTemplate Class Methods
Legend
Methods
NLTemplate Class
Name | Description
NLTemplate | Initializes a new instance of the NLTemplate class.


NDisposable Methods

NDisposable Methods
Legend
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NLTemplate Class
Name | Description
CalculateSize | Calculates NLTemplate size.
Check | Checks if format of packed NLTemplate format is correct.
GetRecordCount | Retrieves records count.
GetSize | Gets the size of packed NLTemplate.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NLTemplate Class
Name | Description
NativeType | Defines the native type of the object.
Records | Gets Records collection.


NMatchingDetails Classes

NMatchingDetails Classes
Legend
NMatchingDetails Classes
NMatchingDetails Class
Name | Description
FaceCollection | Face templates matching details collection.
FingerCollection | Finger templates matching details collection.
IrisCollection | Iris templates matching details collection.
PalmCollection | Palm templates matching details collection.
VoiceCollection | Voice templates matching details collection.


NObject Fields

NObject Fields
Legend
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NMatchingDetails Class
Name | Description
FlagSaveCompatible12Line | This flag results in output compatible with 12.X line. Not all fields can be preserved when this flag is used.


NMatchingDetails Class Members

NMatchingDetails Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NMatchingDetailsBase Class
Show:
No members matching the current filter
Name | Description
BiometricType | Gets type of biometric modality saved in specified matching details.
NativeType | Defines the native type of the object.
Score | Gets similarity score of two matched templates.
NMatchingDetails Class
Name | Description
Faces | Gets collection of faces matching details.
FacesMatchedIndex | Gets index of matched face in the second matched NLTemplate (or NTemplate)).
FacesScore | Gets similarity score of two matched face templates (NLTemplate).
Fingers | Gets collection of fingers matching details.
FingersScore | Gets similarity score of two matched finger templates (NFTemplate).
Irises | Gets collection of irises matching details.
IrisesScore | Gets similarity score of two matched iris templates (NETemplate).
NativeType | Defines the native type of the object.
Palms | Gets collection of palms matching details.
PalmsScore | Gets similarity score of two matched palm templates (NFTemplate).
Voices | Gets collection of voices matching details.
VoicesScore | Gets similarity score of two matched voice templates (NSTemplate).
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NMatchingDetails Class
Name | Description
FlagSaveCompatible12Line | This flag results in output compatible with 12.X line. Not all fields can be preserved when this flag is used.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Methods
NMatchingDetails Class
Name | Description
NMatchingDetails | Creates new instance of NMatchingDetails class.
NMatchingDetails Classes
NMatchingDetails Class
Name | Description
FaceCollection | Face templates matching details collection.
FingerCollection | Finger templates matching details collection.
IrisCollection | Iris templates matching details collection.
PalmCollection | Palm templates matching details collection.
VoiceCollection | Voice templates matching details collection.


NMatchingDetails Class Methods

NMatchingDetails Class Methods
Legend
Methods
NMatchingDetails Class
Name | Description
NMatchingDetails | Creates new instance of NMatchingDetails class.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NMatchingDetailsBase Class
Show:
No members matching the current filter
Name | Description
BiometricType | Gets type of biometric modality saved in specified matching details.
NativeType | Defines the native type of the object.
Score | Gets similarity score of two matched templates.
NMatchingDetails Class
Name | Description
Faces | Gets collection of faces matching details.
FacesMatchedIndex | Gets index of matched face in the second matched NLTemplate (or NTemplate)).
FacesScore | Gets similarity score of two matched face templates (NLTemplate).
Fingers | Gets collection of fingers matching details.
FingersScore | Gets similarity score of two matched finger templates (NFTemplate).
Irises | Gets collection of irises matching details.
IrisesScore | Gets similarity score of two matched iris templates (NETemplate).
NativeType | Defines the native type of the object.
Palms | Gets collection of palms matching details.
PalmsScore | Gets similarity score of two matched palm templates (NFTemplate).
Voices | Gets collection of voices matching details.
VoicesScore | Gets similarity score of two matched voice templates (NSTemplate).


NMatchingDetailsBase Class Members

NMatchingDetailsBase Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NMatchingDetailsBase Class
Name | Description
BiometricType | Gets type of biometric modality saved in specified matching details.
NativeType | Defines the native type of the object.
Score | Gets similarity score of two matched templates.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NMatchingDetailsBase Class
Name | Description
BiometricType | Gets type of biometric modality saved in specified matching details.
NativeType | Defines the native type of the object.
Score | Gets similarity score of two matched templates.


NMatchingResult Class Members

NMatchingResult Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NMatchingResult Class
Name | Description
Connection | Retrieves the biometric connection of the matching result.
Id | Retrieves the ID of the matching result.
MatchingDetails | Retrieves the matching details of the matching result.
MatchingDetailsBuffer | Retrieves the matching details buffer of the matching result.
NativeType | Defines the native type of the object.
Owner | Retrieves the owner object of the matching result.
Score | Retrieves the matching score of the matching result.
Subject | Retrieves the subject of the matching result.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NMatchingResult Class
Name | Description
Connection | Retrieves the biometric connection of the matching result.
Id | Retrieves the ID of the matching result.
MatchingDetails | Retrieves the matching details of the matching result.
MatchingDetailsBuffer | Retrieves the matching details buffer of the matching result.
NativeType | Defines the native type of the object.
Owner | Retrieves the owner object of the matching result.
Score | Retrieves the matching score of the matching result.
Subject | Retrieves the subject of the matching result.


NSubject Classes

NSubject Classes
Legend
NSubject Classes
NSubject Class
Name | Description
FaceCollection | Collection of NFace objects containing face image data.
FingerCollection | Collection of NFinger objects containing fingerprint data.
IrisCollection | Collection of NIris objects containing iris image data.
MatchingResultCollection | Collection of NMatchingResult objects containing the results of matching operations involving the subject.
MissingEyeCollection | Collection of NEPosition objects containing data about missing eye positions.
MissingFingerCollection | Collection of NFPosition objects containing data about missing finger positions.
PalmCollection | Collection of NPalm objects containing palmprint data.
RelatedSubjectCollection | Collection of NSubject objects representing related subjects.
SignatureCollection | Collection of NSignature objects containing signature image data.
VoiceCollection | Collection of NVoice objects containing voice sample data.


NSubject Class Members

NSubject Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NSubject Class
Name | Description
Clear | Clears the NSubject of all data.
FromFile | Creates a new NSubject object from the specified file.
FromMemory | Creates a new NSubject object from the specified buffer.
FromStream | Creates a new NSubject object from the specified memory stream.
GetTemplate | Gets the template used by the NSubject.
GetTemplateBuffer | Gets the buffer which contains templates for the NSubject.
SetTemplate | Sets ANTemplate to be used by the NSubject.
SetTemplateBuffer | Sets the buffer to contain templates for the NSubject.
ToANTemplate | Converts NSubject to ANTemplate.
ToFCRecord | Converts NSubject to FCRecord.
ToFIRecord | Converts NSubject to FIRecord.
ToFMCRecord | Converts NSubject to FMCRecord.
ToFMRecord | Converts NSubject to FMRecord.
ToIIRecord | Converts NSubject to IIRecord.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NExpandableObject Class
Show:
No members matching the current filter
Name | Description
NativeType | Defines the native type of the object.
Properties | Gets the property bag of the expandable object.
NSubject Class
Name | Description
Error | Gets the exception thrown by the subject.
Faces | Retrieves the collection of NFace objects.
Fingers | Retrieves the collection of NFinger objects.
Gender | Gets or sets the gender value of the subject.
Id | Gets or sets the ID of the subject.
Irises | Retrieves the collection of NIris objects.
IsMultipleSubjects | Gets or sets whether the subject consists of multiple NSubjects.
MatchingResults | Retrieves the collection of subject's matching results.
MissingEyes | Retrieves the collection of NEPosition objects representing missing eye positions.
MissingFingers | Retrieves the collection of NFPosition objects representing missing finger positions.
NativeType | Defines the native type of the object.
Palms | Retrieves the collection of NPalm objects.
QueryString | Gets or sets the query string for the subject.
RelatedSubjects | Retrieves the collection of related NSubject objects.
Signatures | Retrieves the collection of NSignature objects.
Statistics | Gets the property bag containing the subject's statistics (diagnostic information).
Status | Gets or sets the biometric status of the subject.
Voices | Retrieves the collection of NVoice objects.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Methods
NSubject Class
Name | Description
NSubject | Creates a new NSubject object.
NSubject Classes
NSubject Class
Name | Description
FaceCollection | Collection of NFace objects containing face image data.
FingerCollection | Collection of NFinger objects containing fingerprint data.
IrisCollection | Collection of NIris objects containing iris image data.
MatchingResultCollection | Collection of NMatchingResult objects containing the results of matching operations involving the subject.
MissingEyeCollection | Collection of NEPosition objects containing data about missing eye positions.
MissingFingerCollection | Collection of NFPosition objects containing data about missing finger positions.
PalmCollection | Collection of NPalm objects containing palmprint data.
RelatedSubjectCollection | Collection of NSubject objects representing related subjects.
SignatureCollection | Collection of NSignature objects containing signature image data.
VoiceCollection | Collection of NVoice objects containing voice sample data.


NSubject Class Methods

NSubject Class Methods
Legend
Methods
NSubject Class
Name | Description
NSubject | Creates a new NSubject object.


NDisposable Methods

NDisposable Methods
Legend
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NSubject Class
Name | Description
Clear | Clears the NSubject of all data.
FromFile | Creates a new NSubject object from the specified file.
FromMemory | Creates a new NSubject object from the specified buffer.
FromStream | Creates a new NSubject object from the specified memory stream.
GetTemplate | Gets the template used by the NSubject.
GetTemplateBuffer | Gets the buffer which contains templates for the NSubject.
SetTemplate | Sets ANTemplate to be used by the NSubject.
SetTemplateBuffer | Sets the buffer to contain templates for the NSubject.
ToANTemplate | Converts NSubject to ANTemplate.
ToFCRecord | Converts NSubject to FCRecord.
ToFIRecord | Converts NSubject to FIRecord.
ToFMCRecord | Converts NSubject to FMCRecord.
ToFMRecord | Converts NSubject to FMRecord.
ToIIRecord | Converts NSubject to IIRecord.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NExpandableObject Class
Show:
No members matching the current filter
Name | Description
NativeType | Defines the native type of the object.
Properties | Gets the property bag of the expandable object.
NSubject Class
Name | Description
Error | Gets the exception thrown by the subject.
Faces | Retrieves the collection of NFace objects.
Fingers | Retrieves the collection of NFinger objects.
Gender | Gets or sets the gender value of the subject.
Id | Gets or sets the ID of the subject.
Irises | Retrieves the collection of NIris objects.
IsMultipleSubjects | Gets or sets whether the subject consists of multiple NSubjects.
MatchingResults | Retrieves the collection of subject's matching results.
MissingEyes | Retrieves the collection of NEPosition objects representing missing eye positions.
MissingFingers | Retrieves the collection of NFPosition objects representing missing finger positions.
NativeType | Defines the native type of the object.
Palms | Retrieves the collection of NPalm objects.
QueryString | Gets or sets the query string for the subject.
RelatedSubjects | Retrieves the collection of related NSubject objects.
Signatures | Retrieves the collection of NSignature objects.
Statistics | Gets the property bag containing the subject's statistics (diagnostic information).
Status | Gets or sets the biometric status of the subject.
Voices | Retrieves the collection of NVoice objects.


NTemplate Class Members

NTemplate Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NTemplate Class
Name | Description
CalculateSize | Calculates the size of a packed NTemplate containing fingers, faces. irises and palms templates of the specified size.
Check | Checks if format of packed NTemplate format is correct.
Clear | Removes all NFRecord objects.
GetSize | Gets the size of packed NTemplate.
Merge | Merges several NXTemplates from buffer array.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NTemplate Class
Name | Description
Faces | Gets NLTemplate object.
Fingers | Gets NFTemplate object.
Irises | Gets NETemplate object.
NativeType | Defines the native type of the object.
Palms | Gets NFTemplate object.
Voices | Gets NSTemplate object.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Methods
NTemplate Class
Name | Description
NTemplate | Initializes a new instance of the NTemplate class.


NTemplate Class Methods

NTemplate Class Methods
Legend
Methods
NTemplate Class
Name | Description
NTemplate | Initializes a new instance of the NTemplate class.


NDisposable Methods

NDisposable Methods
Legend
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NTemplate Class
Name | Description
CalculateSize | Calculates the size of a packed NTemplate containing fingers, faces. irises and palms templates of the specified size.
Check | Checks if format of packed NTemplate format is correct.
Clear | Removes all NFRecord objects.
GetSize | Gets the size of packed NTemplate.
Merge | Merges several NXTemplates from buffer array.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NTemplate Class
Name | Description
Faces | Gets NLTemplate object.
Fingers | Gets NFTemplate object.
Irises | Gets NETemplate object.
NativeType | Defines the native type of the object.
Palms | Gets NFTemplate object.
Voices | Gets NSTemplate object.


Neurotec.Collections.ObjectModel Namespace Classes

Neurotec.Collections.ObjectModel Namespace Classes
Legend
Classes
Name | Description
NArrayCollection | Provides functionality for working with collections of arrays.
NCollection | Provides functionality for working with collections.
NDictionary | Provides information about tables, classes, extended data types, and other items in the Application Object Tree.


Legend

Legend
Legend
Class
Enumeration


Neurotec.Collections.ObjectModel Namespace Structs, Records, Enums

Neurotec.Collections.ObjectModel Namespace Structs, Records, Enums
Legend
Structs, Records, Enums
Name | Description
NCollectionChangedAction | Enumerates collection-changing actions.


Legend

Legend
Legend
Method
Property
read only
static


NArrayCollection Class Members

NArrayCollection Class Members
Legend
Members
NArrayCollection Methods
Name | Description
Add | Adds an item to the array.
AddRange | Adds an array of item to the array.
Clear | Clears the specified array.
Contains | Checks whether the array contains the specified item.
CopyTo | Copies the array into an array object.
GetCount | Gets the number of items in the array.
GetEnumerator | Retrieves the enumerator of the collection.
IndexOf | Retrieves the index of the specified item in the array.
Insert | Inserts a value in the array.
InsertRange | Inserts an array of values in the array.
Remove | Removes the specified item from the array.
RemoveAt | Removes the specified value from the array.
RemoveRange | Removes a range of values from the array.
ToArray | Converts the array into an independent array.
ToItemArray | Converts the array into an independent array.
this | Gets or sets the item specified by index.
NArrayCollection Properties
Name | Description
Count | Gets the number of items in the collection.
IsReadOnly | Checks whether the collection is read-only.
NativeType | Defines the native type of the object.
this | Gets the array specified by index.


NArrayCollection Methods

NArrayCollection Methods
Legend
NArrayCollection Methods
Name | Description
Add | Adds an item to the array.
AddRange | Adds an array of item to the array.
Clear | Clears the specified array.
Contains | Checks whether the array contains the specified item.
CopyTo | Copies the array into an array object.
GetCount | Gets the number of items in the array.
GetEnumerator | Retrieves the enumerator of the collection.
IndexOf | Retrieves the index of the specified item in the array.
Insert | Inserts a value in the array.
InsertRange | Inserts an array of values in the array.
Remove | Removes the specified item from the array.
RemoveAt | Removes the specified value from the array.
RemoveRange | Removes a range of values from the array.
ToArray | Converts the array into an independent array.
ToItemArray | Converts the array into an independent array.
this | Gets or sets the item specified by index.


NArrayCollection Properties

NArrayCollection Properties
Legend
NArrayCollection Properties
Name | Description
Count | Gets the number of items in the collection.
IsReadOnly | Checks whether the collection is read-only.
NativeType | Defines the native type of the object.
this | Gets the array specified by index.


NCollection Events

NCollection Events
Legend
NCollection Events
Name | Description
CollectionChanged | Adds or removes a handler for an event which occurs when collection is changed.


Legend

Legend
Legend
Method
Property
read only
static
Event


NCollection Class Members

NCollection Class Members
Legend
Members
NCollection Methods
Name | Description
Add | Adds an item to the collection.
AddRange | Adds an array of items to the collection.
Clear | Clears the current collection.
Contains | Checks whether the collection contains the specified item.
CopyTo | Copies the collection to the specified array.
GetEnumerator | Retrieves the enumerator of the collection.
IndexOf | Retrieves the index of the specified item.
Insert | Adds an item to the collection at specified index.
InsertRange | Adds an array of items to the collection at specified index.
Remove | Removes the specified value from the collection.
RemoveAt | Removes the specified item from the collection.
RemoveRange | Removes the specified items from the collection.
ToArray | Converts the collection to an array.
ToItemArray | Converts the collection to an array.
this | Gets or sets the item specified by index.
NCollection Properties
Name | Description
Capacity | Gets or sets the maximum number of items in the collection.
Count | Gets the number of items in the collection.
IsReadOnly | Checks whether the collection is read-only.
NCollectionChangedActionNativeType | Defines the native type of the "collection changed" action.
NCollectionCollectionChangedCallbackNativeType | Defines the native type of the "collection changed" callback.
NativeType | Defines the native type of the object.
NCollection Events
Name | Description
CollectionChanged | Adds or removes a handler for an event which occurs when collection is changed.


NCollection Methods

NCollection Methods
Legend
NCollection Methods
Name | Description
Add | Adds an item to the collection.
AddRange | Adds an array of items to the collection.
Clear | Clears the current collection.
Contains | Checks whether the collection contains the specified item.
CopyTo | Copies the collection to the specified array.
GetEnumerator | Retrieves the enumerator of the collection.
IndexOf | Retrieves the index of the specified item.
Insert | Adds an item to the collection at specified index.
InsertRange | Adds an array of items to the collection at specified index.
Remove | Removes the specified value from the collection.
RemoveAt | Removes the specified item from the collection.
RemoveRange | Removes the specified items from the collection.
ToArray | Converts the collection to an array.
ToItemArray | Converts the collection to an array.
this | Gets or sets the item specified by index.


NCollection Properties

NCollection Properties
Legend
NCollection Properties
Name | Description
Capacity | Gets or sets the maximum number of items in the collection.
Count | Gets the number of items in the collection.
IsReadOnly | Checks whether the collection is read-only.
NCollectionChangedActionNativeType | Defines the native type of the "collection changed" action.
NCollectionCollectionChangedCallbackNativeType | Defines the native type of the "collection changed" callback.
NativeType | Defines the native type of the object.


NDictionary Classes

NDictionary Classes
Legend
NDictionary Classes
Name | Description
KeyCollection | Represents a collection of value keys.
ValueCollection | Represents a collection of values.


NDictionary Events

NDictionary Events
Legend
NDictionary Events
Name | Description
CollectionChanged | Adds or removes a handler for an event which occurs when collection is changed.


Legend

Legend
Legend
Class
Method
Property
read only
static
Event


NDictionary Class Members

NDictionary Class Members
Legend
Members
NDictionary Classes
Name | Description
KeyCollection | Represents a collection of value keys.
ValueCollection | Represents a collection of values.
NDictionary Methods
Name | Description
Add | Adds the specified item to the dictionary.
Clear | Clears the dictionary.
ContainsKey | Checks whether the dictionary contains the specified key.
CopyTo | Copies the dictionary to an array.
GetEnumerator | Retrieves the enumerator of the collection.
GetItemAt | Retrieves the specified item.
Remove | Removes a value specified by key from the dictionary.
RemoveAt | Removes the specified item from the dictionary.
ToArray | Converts the dictionary to an array.
ToItemArray | Converts the dictionary to an array.
TryGetValue | Attempts to retrieve a value specified by key. Return a Boolean value indicating success.
this | Gets or sets the item specified by index.
NDictionary Properties
Name | Description
Count | Gets the number of items in the dictionary.
IsReadOnly | Checks whether the collection is read-only.
Keys | Gets the collection of value keys.
NativeType | Defines the native type of the object.
Values | Gets the collection of values.
NDictionary Events
Name | Description
CollectionChanged | Adds or removes a handler for an event which occurs when collection is changed.


NDictionary Methods

NDictionary Methods
Legend
NDictionary Methods
Name | Description
Add | Adds the specified item to the dictionary.
Clear | Clears the dictionary.
ContainsKey | Checks whether the dictionary contains the specified key.
CopyTo | Copies the dictionary to an array.
GetEnumerator | Retrieves the enumerator of the collection.
GetItemAt | Retrieves the specified item.
Remove | Removes a value specified by key from the dictionary.
RemoveAt | Removes the specified item from the dictionary.
ToArray | Converts the dictionary to an array.
ToItemArray | Converts the dictionary to an array.
TryGetValue | Attempts to retrieve a value specified by key. Return a Boolean value indicating success.
this | Gets or sets the item specified by index.


NDictionary Properties

NDictionary Properties
Legend
NDictionary Properties
Name | Description
Count | Gets the number of items in the dictionary.
IsReadOnly | Checks whether the collection is read-only.
Keys | Gets the collection of value keys.
NativeType | Defines the native type of the object.
Values | Gets the collection of values.


NDictionary.KeyCollection Class Members

NDictionary.KeyCollection Class Members
Legend
Members
KeyCollection Methods
Name | Description
ToItemArray | Converts the key collection to an item array.


KeyCollection Methods

KeyCollection Methods
Legend
KeyCollection Methods
Name | Description
ToItemArray | Converts the key collection to an item array.


NDictionary.ValueCollection Class Members

NDictionary.ValueCollection Class Members
Legend
Members
ValueCollection Methods
Name | Description
ToItemArray | Converts the value collection to an item array.


ValueCollection Methods

ValueCollection Methods
Legend
ValueCollection Methods
Name | Description
ToItemArray | Converts the value collection to an item array.


Neurotec.Devices Namespace Classes

Neurotec.Devices Namespace Classes
Legend
Classes
Name | Description
NBiometricDevice | Provides methods to retrieve information about biometric device.
NBiometricDeviceCapturePreviewEventArgs | Contains NBiometricDevice capture preview event arguments.
NCamera | Provides methods for working with cameras.
NCameraStillCapturedEventArgs | Contains NCamera still image capture event arguments.
NCaptureDevice | Provides methods for working with capture devices.
NDevice | Provides functionality for retrieving device information.
NDeviceManager | Provides functionality for managing devices.
NDeviceManagerDeviceEventArgs | Contains device manager device event arguments.
NDevices | Provides functionality for retrieving information about NDevices library.


Legend

Legend
Legend
Class
static
Enumeration


Neurotec.Devices Namespace Structs, Records, Enums

Neurotec.Devices Namespace Structs, Records, Enums
Legend
Structs, Records, Enums
Name | Description
NCameraStatus | Enumerates camera status values.
NDeviceType | Enumerates device type values.


NDevice Classes

NDevice Classes
Legend
NDevice Classes
NDevice Class
Name | Description
ChildCollection | Children collection of specified multimodal device.


NObject Events

NObject Events
Legend
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
NBiometricDevice Class
Name | Description
CapturePreview | Adds or removes capture preview event to the specified biometric device.


NBiometricDevice Class Members

NBiometricDevice Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NBiometricDevice Class
Name | Description
Cancel | Stops capturing and cancels NBiometricDevice (NFScanner or NIrisScanner)
Capture | Starts capturing biometric data.
EndSequence | Ends multiple images capturing sequence.
StartSequence | Starts sequence which prepares device for multiple capture operations.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NDevice Class
Show:
No members matching the current filter
Name | Description
Children | Gets children collections of specified multimodal device.
DeviceType | Gets the type of multimodal device.
DisplayName | Gets device name
Id | Gets device Id.
IsAvailable | Checks if the device is available.
IsDisconnectable | Checks whether the device is disconnectable.
IsPrivate | Checks if the device is private.
Make | Gets device manufacturer.
Model | Gets model of current biometric device.
NDeviceTypeNativeType | Defines the native type of the device type.
NativeType | Defines the native type of the object.
Owner | Gets the owner of the device manager.
Parent | Gets the parent of specified multimodal device module.
Plugin | Gets device plugin.
SerialNumber | Gets serial number of current biometric device.
NBiometricDevice Class
Name | Description
BiometricType | Gets the type of biometric device.
IsSpoofDetectionSupported | Checks if the device is capable to detect spoof objects.
NativeType | Defines the native type of the object.
ProductId | Gets product device Id.
SpoofDetection | Gets or sets spoof detection value for biometric device.
VendorId | Gets device vendor Id.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
NBiometricDevice Class
Name | Description
CapturePreview | Adds or removes capture preview event to the specified biometric device.
NDevice Classes
NDevice Class
Name | Description
ChildCollection | Children collection of specified multimodal device.


NDisposable Methods

NDisposable Methods
Legend
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NBiometricDevice Class
Name | Description
Cancel | Stops capturing and cancels NBiometricDevice (NFScanner or NIrisScanner)
Capture | Starts capturing biometric data.
EndSequence | Ends multiple images capturing sequence.
StartSequence | Starts sequence which prepares device for multiple capture operations.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NDevice Class
Show:
No members matching the current filter
Name | Description
Children | Gets children collections of specified multimodal device.
DeviceType | Gets the type of multimodal device.
DisplayName | Gets device name
Id | Gets device Id.
IsAvailable | Checks if the device is available.
IsDisconnectable | Checks whether the device is disconnectable.
IsPrivate | Checks if the device is private.
Make | Gets device manufacturer.
Model | Gets model of current biometric device.
NDeviceTypeNativeType | Defines the native type of the device type.
NativeType | Defines the native type of the object.
Owner | Gets the owner of the device manager.
Parent | Gets the parent of specified multimodal device module.
Plugin | Gets device plugin.
SerialNumber | Gets serial number of current biometric device.
NBiometricDevice Class
Name | Description
BiometricType | Gets the type of biometric device.
IsSpoofDetectionSupported | Checks if the device is capable to detect spoof objects.
NativeType | Defines the native type of the object.
ProductId | Gets product device Id.
SpoofDetection | Gets or sets spoof detection value for biometric device.
VendorId | Gets device vendor Id.


NBiometricDeviceCapturePreviewEventArgs Class Members

NBiometricDeviceCapturePreviewEventArgs Class Members
Legend
Members
Methods
Name | Description
NBiometricDeviceCapturePreviewEventArgs | Creates a new instance of NBiometricDeviceCapturePreviewEventArgs class.
NBiometricDeviceCapturePreviewEventArgs Properties
Name | Description
Biometric | Gets NBiometric object.


NBiometricDeviceCapturePreviewEventArgs Class Methods

NBiometricDeviceCapturePreviewEventArgs Class Methods
Legend
Methods
Name | Description
NBiometricDeviceCapturePreviewEventArgs | Creates a new instance of NBiometricDeviceCapturePreviewEventArgs class.


NBiometricDeviceCapturePreviewEventArgs Properties

NBiometricDeviceCapturePreviewEventArgs Properties
Legend
NBiometricDeviceCapturePreviewEventArgs Properties
Name | Description
Biometric | Gets NBiometric object.


NObject Events

NObject Events
Legend
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
NCaptureDevice Class
Show:
No members matching the current filter
Name | Description
IsCapturingChanged | Gets or sets
NCamera Class
Name | Description
StillCaptured | Adds or removes user specified event handler (controlling captured still image event) to NCamera.


NCamera Class Members

NCamera Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NCaptureDevice Class
Show:
No members matching the current filter
Name | Description
GetCurrentFormat | Gets current media format of the capture device.
GetFormats | Gets all supported formats by the capture device.
SetCurrentFormat | Sets current media format for the capture device.
StartCapturing | Starts capturing.
StopCapturing | Stops capturing.
NCamera Class
Name | Description
CaptureStill | Gets a still image from capture device (camera).
Focus | Adjusts camera focus.
GetCurrentStillFormat | Gets the current still image format.
GetFrame | Gets current frame from the capture device.
GetStillFormats | Gets still image formats supported by specified camera.
GetVideoSample | Gets video sample from the capture device.
ResetFocus | Resets camera focus.
SetCurrentStillFormat | Sets the current still image format.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NDevice Class
Show:
No members matching the current filter
Name | Description
Children | Gets children collections of specified multimodal device.
DeviceType | Gets the type of multimodal device.
DisplayName | Gets device name
Id | Gets device Id.
IsAvailable | Checks if the device is available.
IsDisconnectable | Checks whether the device is disconnectable.
IsPrivate | Checks if the device is private.
Make | Gets device manufacturer.
Model | Gets model of current biometric device.
NDeviceTypeNativeType | Defines the native type of the device type.
NativeType | Defines the native type of the object.
Owner | Gets the owner of the device manager.
Parent | Gets the parent of specified multimodal device module.
Plugin | Gets device plugin.
SerialNumber | Gets serial number of current biometric device.
NCaptureDevice Class
Show:
No members matching the current filter
Name | Description
IsCapturing | Checks if the device is capturing.
MediaType | Gets the media type.
NativeType | Defines the native type of the object.
NCamera Class
Name | Description
FocusRegion | Gets or sets the focus region.
IsFocusRegionSupported | Checks whether the focus region is supported.
IsFocusSupported | Checks whether the focus is supported.
IsStillCaptureSupported | Checks whether still capture is supported.
IsVideoSampleSupported | Checks whether video sample captre is supported.
NCameraStatusNativeType | Defines the native type of the camera status.
NativeType | Defines the native type of the object.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
NCaptureDevice Class
Show:
No members matching the current filter
Name | Description
IsCapturingChanged | Gets or sets
NCamera Class
Name | Description
StillCaptured | Adds or removes user specified event handler (controlling captured still image event) to NCamera.
NDevice Classes
NDevice Class
Name | Description
ChildCollection | Children collection of specified multimodal device.


NDisposable Methods

NDisposable Methods
Legend
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NCaptureDevice Class
Show:
No members matching the current filter
Name | Description
GetCurrentFormat | Gets current media format of the capture device.
GetFormats | Gets all supported formats by the capture device.
SetCurrentFormat | Sets current media format for the capture device.
StartCapturing | Starts capturing.
StopCapturing | Stops capturing.
NCamera Class
Name | Description
CaptureStill | Gets a still image from capture device (camera).
Focus | Adjusts camera focus.
GetCurrentStillFormat | Gets the current still image format.
GetFrame | Gets current frame from the capture device.
GetStillFormats | Gets still image formats supported by specified camera.
GetVideoSample | Gets video sample from the capture device.
ResetFocus | Resets camera focus.
SetCurrentStillFormat | Sets the current still image format.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NDevice Class
Show:
No members matching the current filter
Name | Description
Children | Gets children collections of specified multimodal device.
DeviceType | Gets the type of multimodal device.
DisplayName | Gets device name
Id | Gets device Id.
IsAvailable | Checks if the device is available.
IsDisconnectable | Checks whether the device is disconnectable.
IsPrivate | Checks if the device is private.
Make | Gets device manufacturer.
Model | Gets model of current biometric device.
NDeviceTypeNativeType | Defines the native type of the device type.
NativeType | Defines the native type of the object.
Owner | Gets the owner of the device manager.
Parent | Gets the parent of specified multimodal device module.
Plugin | Gets device plugin.
SerialNumber | Gets serial number of current biometric device.
NCaptureDevice Class
Show:
No members matching the current filter
Name | Description
IsCapturing | Checks if the device is capturing.
MediaType | Gets the media type.
NativeType | Defines the native type of the object.
NCamera Class
Name | Description
FocusRegion | Gets or sets the focus region.
IsFocusRegionSupported | Checks whether the focus region is supported.
IsFocusSupported | Checks whether the focus is supported.
IsStillCaptureSupported | Checks whether still capture is supported.
IsVideoSampleSupported | Checks whether video sample captre is supported.
NCameraStatusNativeType | Defines the native type of the camera status.
NativeType | Defines the native type of the object.


NCameraStillCapturedEventArgs Class Members

NCameraStillCapturedEventArgs Class Members
Legend
Members
Methods
Name | Description
NCameraStillCapturedEventArgs | Creates a new instance of NCameraStillCapturedEventArgs class.
NCameraStillCapturedEventArgs Properties
Name | Description
Id | Retrieves the camera ID.
Properties | Retrieves the event properties.
Stream | Retrieves the data stream.


NCameraStillCapturedEventArgs Class Methods

NCameraStillCapturedEventArgs Class Methods
Legend
Methods
Name | Description
NCameraStillCapturedEventArgs | Creates a new instance of NCameraStillCapturedEventArgs class.


NCameraStillCapturedEventArgs Properties

NCameraStillCapturedEventArgs Properties
Legend
NCameraStillCapturedEventArgs Properties
Name | Description
Id | Retrieves the camera ID.
Properties | Retrieves the event properties.
Stream | Retrieves the data stream.


NObject Events

NObject Events
Legend
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
NCaptureDevice Class
Name | Description
IsCapturingChanged | Gets or sets


NCaptureDevice Class Members

NCaptureDevice Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NCaptureDevice Class
Name | Description
GetCurrentFormat | Gets current media format of the capture device.
GetFormats | Gets all supported formats by the capture device.
SetCurrentFormat | Sets current media format for the capture device.
StartCapturing | Starts capturing.
StopCapturing | Stops capturing.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NDevice Class
Show:
No members matching the current filter
Name | Description
Children | Gets children collections of specified multimodal device.
DeviceType | Gets the type of multimodal device.
DisplayName | Gets device name
Id | Gets device Id.
IsAvailable | Checks if the device is available.
IsDisconnectable | Checks whether the device is disconnectable.
IsPrivate | Checks if the device is private.
Make | Gets device manufacturer.
Model | Gets model of current biometric device.
NDeviceTypeNativeType | Defines the native type of the device type.
NativeType | Defines the native type of the object.
Owner | Gets the owner of the device manager.
Parent | Gets the parent of specified multimodal device module.
Plugin | Gets device plugin.
SerialNumber | Gets serial number of current biometric device.
NCaptureDevice Class
Name | Description
IsCapturing | Checks if the device is capturing.
MediaType | Gets the media type.
NativeType | Defines the native type of the object.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
NCaptureDevice Class
Name | Description
IsCapturingChanged | Gets or sets
NDevice Classes
NDevice Class
Name | Description
ChildCollection | Children collection of specified multimodal device.


NDisposable Methods

NDisposable Methods
Legend
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NCaptureDevice Class
Name | Description
GetCurrentFormat | Gets current media format of the capture device.
GetFormats | Gets all supported formats by the capture device.
SetCurrentFormat | Sets current media format for the capture device.
StartCapturing | Starts capturing.
StopCapturing | Stops capturing.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NDevice Class
Show:
No members matching the current filter
Name | Description
Children | Gets children collections of specified multimodal device.
DeviceType | Gets the type of multimodal device.
DisplayName | Gets device name
Id | Gets device Id.
IsAvailable | Checks if the device is available.
IsDisconnectable | Checks whether the device is disconnectable.
IsPrivate | Checks if the device is private.
Make | Gets device manufacturer.
Model | Gets model of current biometric device.
NDeviceTypeNativeType | Defines the native type of the device type.
NativeType | Defines the native type of the object.
Owner | Gets the owner of the device manager.
Parent | Gets the parent of specified multimodal device module.
Plugin | Gets device plugin.
SerialNumber | Gets serial number of current biometric device.
NCaptureDevice Class
Name | Description
IsCapturing | Checks if the device is capturing.
MediaType | Gets the media type.
NativeType | Defines the native type of the object.


NDevice Class Members

NDevice Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NDevice Class
Name | Description
Children | Gets children collections of specified multimodal device.
DeviceType | Gets the type of multimodal device.
DisplayName | Gets device name
Id | Gets device Id.
IsAvailable | Checks if the device is available.
IsDisconnectable | Checks whether the device is disconnectable.
IsPrivate | Checks if the device is private.
Make | Gets device manufacturer.
Model | Gets model of current biometric device.
NDeviceTypeNativeType | Defines the native type of the device type.
NativeType | Defines the native type of the object.
Owner | Gets the owner of the device manager.
Parent | Gets the parent of specified multimodal device module.
Plugin | Gets device plugin.
SerialNumber | Gets serial number of current biometric device.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
NDevice Classes
NDevice Class
Name | Description
ChildCollection | Children collection of specified multimodal device.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NDevice Class
Name | Description
Children | Gets children collections of specified multimodal device.
DeviceType | Gets the type of multimodal device.
DisplayName | Gets device name
Id | Gets device Id.
IsAvailable | Checks if the device is available.
IsDisconnectable | Checks whether the device is disconnectable.
IsPrivate | Checks if the device is private.
Make | Gets device manufacturer.
Model | Gets model of current biometric device.
NDeviceTypeNativeType | Defines the native type of the device type.
NativeType | Defines the native type of the object.
Owner | Gets the owner of the device manager.
Parent | Gets the parent of specified multimodal device module.
Plugin | Gets device plugin.
SerialNumber | Gets serial number of current biometric device.


NDeviceManager Classes

NDeviceManager Classes
Legend
NDeviceManager Classes
NDeviceManager Class
Name | Description
DeviceCollection | Holds all devices data of the current NDeviceManager object.


NDeviceManager Class Members

NDeviceManager Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NDeviceManager Class
Name | Description
ConnectToDevice | Connects to specified device using NPlugin and NPropertyBag parameters.
DisconnectFromDevice | Disconnects from specified device.
GetConnectToDeviceParameters | Gets connection parameters for a device from a specified plugin.
Initialize | Initializes a device manager.
IsConnectToDeviceSupported | Checks whether the specified plugin supports connection to device.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NDeviceManager Class
Name | Description
AutoPlug | Gets or sets if a device can be auto-plugged to device manager.
BiometricEngine | Gets or sets the biometric engine used by the device manager.
DeviceTypes | Gets supported device types by NDeviceManager.
Devices | Gets devices collection of the current NDeviceManager object.
IsInitialized | Checks whether the specialized device manager is initialized.
NativeType | Defines the native type of the object.
PluginManager | Gets the plugin manager of the current object.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Methods
NDeviceManager Class
Name | Description
NDeviceManager | Initializes a new instance of the NDeviceManager class.
NDeviceManager Classes
NDeviceManager Class
Name | Description
DeviceCollection | Holds all devices data of the current NDeviceManager object.


NDeviceManager Class Methods

NDeviceManager Class Methods
Legend
Methods
NDeviceManager Class
Name | Description
NDeviceManager | Initializes a new instance of the NDeviceManager class.


NDisposable Methods

NDisposable Methods
Legend
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NDeviceManager Class
Name | Description
ConnectToDevice | Connects to specified device using NPlugin and NPropertyBag parameters.
DisconnectFromDevice | Disconnects from specified device.
GetConnectToDeviceParameters | Gets connection parameters for a device from a specified plugin.
Initialize | Initializes a device manager.
IsConnectToDeviceSupported | Checks whether the specified plugin supports connection to device.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NDeviceManager Class
Name | Description
AutoPlug | Gets or sets if a device can be auto-plugged to device manager.
BiometricEngine | Gets or sets the biometric engine used by the device manager.
DeviceTypes | Gets supported device types by NDeviceManager.
Devices | Gets devices collection of the current NDeviceManager object.
IsInitialized | Checks whether the specialized device manager is initialized.
NativeType | Defines the native type of the object.
PluginManager | Gets the plugin manager of the current object.


NDeviceManager.DeviceCollection Class Members

NDeviceManager.DeviceCollection Class Members
Legend
Members
DeviceCollection Methods
Name | Description
IndexOf | Retrieves device's index in a collection by specified device Id.
this | Gets NDevice object specified by Id.


DeviceCollection Methods

DeviceCollection Methods
Legend
DeviceCollection Methods
Name | Description
IndexOf | Retrieves device's index in a collection by specified device Id.
this | Gets NDevice object specified by Id.


Legend

Legend
Legend
Constructor
Property
read only


NDeviceManagerDeviceEventArgs Class Members

NDeviceManagerDeviceEventArgs Class Members
Legend
Members
Methods
Name | Description
NDeviceManagerDeviceEventArgs | Initializes a new instance of NDeviceManagerDeviceEventArgs class.
NDeviceManagerDeviceEventArgs Properties
Name | Description
Device | Gets the device.


NDeviceManagerDeviceEventArgs Class Methods

NDeviceManagerDeviceEventArgs Class Methods
Legend
Methods
Name | Description
NDeviceManagerDeviceEventArgs | Initializes a new instance of NDeviceManagerDeviceEventArgs class.


NDeviceManagerDeviceEventArgs Properties

NDeviceManagerDeviceEventArgs Properties
Legend
NDeviceManagerDeviceEventArgs Properties
Name | Description
Device | Gets the device.


NDevices Fields

NDevices Fields
Legend
NDevices Fields
Name | Description
DllName | NDevices library's Dll name.


NDevices Class Members

NDevices Class Members
Legend
Members
NDevices Fields
Name | Description
DllName | NDevices library's Dll name.
NDevices Properties
Name | Description
NativeModule | Defines the native module of the object.


NDevices Properties

NDevices Properties
Legend
NDevices Properties
Name | Description
NativeModule | Defines the native module of the object.


Neurotec.Devices.ComponentModel Namespace Classes

Neurotec.Devices.ComponentModel Namespace Classes
Legend
Classes
Name | Description
NDeviceEventDescriptor | Provides functionality for creating device event descriptors.
NDeviceMethodDescriptor | Provides functionality for creating device method descriptors.
NDevicePropertyDescriptor | Provides functionality for creating device property descriptors.


Legend

Legend
Legend
Class


NDeviceEventDescriptor Class Members

NDeviceEventDescriptor Class Members
Legend
Members
NDeviceEventDescriptor Properties
Name | Description
NativeType | Defines the native type of the object.


NDeviceEventDescriptor Properties

NDeviceEventDescriptor Properties
Legend
NDeviceEventDescriptor Properties
Name | Description
NativeType | Defines the native type of the object.


NDeviceMethodDescriptor Class Members

NDeviceMethodDescriptor Class Members
Legend
Members
NDeviceMethodDescriptor Properties
Name | Description
NativeType | Defines the native type of the object.


NDeviceMethodDescriptor Properties

NDeviceMethodDescriptor Properties
Legend
NDeviceMethodDescriptor Properties
Name | Description
NativeType | Defines the native type of the object.


NDevicePropertyDescriptor Class Members

NDevicePropertyDescriptor Class Members
Legend
Members
NDevicePropertyDescriptor Properties
Name | Description
NativeType | Defines the native type of the object.


NDevicePropertyDescriptor Properties

NDevicePropertyDescriptor Properties
Legend
NDevicePropertyDescriptor Properties
Name | Description
NativeType | Defines the native type of the object.


Neurotec.Geometry Namespace Classes

Neurotec.Geometry Namespace Classes
Legend
Classes
Name | Description
NGeometry | Provides definitions of geometrical structures types.


Legend

Legend
Legend
Class
static


NGeometry Class Members

NGeometry Class Members
Legend
Members
NGeometry Properties
Name | Description
InterpolationModeNativeType | Defines the native type of the interpolation mode.
NativeType | Defines the native type of the object.
PointDNativeType | Defines the native type of the point D.
PointFNativeType | Defines the native type of the point F.
PointNativeType | Defines the native type of the point.
RectangleDNativeType | Defines the native type of the rectangle D.
RectangleFNativeType | Defines the native type of the rectangle F.
RectangleNativeType | Defines the native type of the rectangle.
SizeDNativeType | Defines the native type of the size D.
SizeFNativeType | Defines the native type of the size F.
SizeNativeType | Defines the native type of the size.


NGeometry Properties

NGeometry Properties
Legend
NGeometry Properties
Name | Description
InterpolationModeNativeType | Defines the native type of the interpolation mode.
NativeType | Defines the native type of the object.
PointDNativeType | Defines the native type of the point D.
PointFNativeType | Defines the native type of the point F.
PointNativeType | Defines the native type of the point.
RectangleDNativeType | Defines the native type of the rectangle D.
RectangleFNativeType | Defines the native type of the rectangle F.
RectangleNativeType | Defines the native type of the rectangle.
SizeDNativeType | Defines the native type of the size D.
SizeFNativeType | Defines the native type of the size F.
SizeNativeType | Defines the native type of the size.


Neurotec.IO Namespace Classes

Neurotec.IO Namespace Classes
Legend
Classes
Name | Description
NBuffer | Provides buffer management functionality.
NMemoryStream | Provides access to unmanaged blocks of memory from managed code.
NStream | This class supports internal Neurotechnology libraries infrastructure and should not be used directly in your code.


NBuffer Class Members

NBuffer Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NBuffer Class
Name | Description
Copy | Copies bytes from one buffer into another with specified offsets into both buffers and size.
CopyFrom | Copies bytes from the specified buffer into the current buffer.
CopyTo | Copies bytes from the current buffer into the buffer specified by pointer with specified size.
ToArray | Copies the elements of the NBuffer to a new byte array.
WriteTo | Writes the contents of NBuffer to memory stream.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NBuffer Class
Name | Description
Empty | Gets or sets an empty NBuffer.
LongSize | Gets a 64-bit integer that represents the length of NBuffer.
NativeSize | Gets UIntPtr that represents the length of NBuffer.
NativeType | Defines the native type of the object.
Ptr | Gets a representation of NBuffer pointer.
Size | Gets the length of NBuffer.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Methods
NBuffer Class
Name | Description
NBuffer |


NBuffer Class Methods

NBuffer Class Methods
Legend
Methods
NBuffer Class
Name | Description
NBuffer |


NDisposable Methods

NDisposable Methods
Legend
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NBuffer Class
Name | Description
Copy | Copies bytes from one buffer into another with specified offsets into both buffers and size.
CopyFrom | Copies bytes from the specified buffer into the current buffer.
CopyTo | Copies bytes from the current buffer into the buffer specified by pointer with specified size.
ToArray | Copies the elements of the NBuffer to a new byte array.
WriteTo | Writes the contents of NBuffer to memory stream.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NBuffer Class
Name | Description
Empty | Gets or sets an empty NBuffer.
LongSize | Gets a 64-bit integer that represents the length of NBuffer.
NativeSize | Gets UIntPtr that represents the length of NBuffer.
NativeType | Defines the native type of the object.
Ptr | Gets a representation of NBuffer pointer.
Size | Gets the length of NBuffer.


NMemoryStream Class Members

NMemoryStream Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NStream Class
Show:
No members matching the current filter
Name | Description
AsStream | Converts the current NStream into a data stream.
CopyTo | Copies the current stream to another stream.
Flush | Clears all buffers for this stream and causes any buffered data to be written to the underlying device.
FromStream | Creates new NStream from Stream object.
Read | Reads a sequence of bytes from the current stream.
ReadByte | Reads a byte from the stream.
Seek | Sets the position within the current stream.
SetLength | Sets the length of the current stream.
Synchronized | Creates a synchronized NStream from a Stream object.
Write | Writes a content of a buffer to the current stream.
WriteByte | Writes a byte to the current position in the stream.
NMemoryStream Class
Name | Description
GetBuffer | Retrieves the buffer.
ToArray | Saves stream to byte array.
WriteTo | Writes NMemoryStream to Stream.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NStream Class
Show:
No members matching the current filter
Name | Description
CanRead | Gets a value indicating whether the current stream supports reading.
CanSeek | Gets a value indicating whether the current stream supports seeking.
CanWrite | Gets a value indicating whether the current stream supports writing.
Length | Gets size of a stream in bytes.
NativeType | Defines the native type of the object.
Null | Gets an empty NStream.
Position | Gets number of bytes from the start of the data to the current position in a stream.
NMemoryStream Class
Name | Description
Capacity | Gets the stream size of memory assigned to a stream (capacity).
LongCapacity | Gets the stream size of memory assigned to a stream (capacity), as a long number.
NativeCapacity | Gets the stream size of memory assigned to a stream (capacity), as an unsigned integer.
NativeType | Defines the native type of the object.
PositionPtr | Gets the pointer to a certain position.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Methods
NMemoryStream Class
Name | Description
NMemoryStream | Initializes a new, empty instance of the NMemoryStream class.


NMemoryStream Class Methods

NMemoryStream Class Methods
Legend
Methods
NMemoryStream Class
Name | Description
NMemoryStream | Initializes a new, empty instance of the NMemoryStream class.


NDisposable Methods

NDisposable Methods
Legend
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NStream Class
Show:
No members matching the current filter
Name | Description
AsStream | Converts the current NStream into a data stream.
CopyTo | Copies the current stream to another stream.
Flush | Clears all buffers for this stream and causes any buffered data to be written to the underlying device.
FromStream | Creates new NStream from Stream object.
Read | Reads a sequence of bytes from the current stream.
ReadByte | Reads a byte from the stream.
Seek | Sets the position within the current stream.
SetLength | Sets the length of the current stream.
Synchronized | Creates a synchronized NStream from a Stream object.
Write | Writes a content of a buffer to the current stream.
WriteByte | Writes a byte to the current position in the stream.
NMemoryStream Class
Name | Description
GetBuffer | Retrieves the buffer.
ToArray | Saves stream to byte array.
WriteTo | Writes NMemoryStream to Stream.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NStream Class
Show:
No members matching the current filter
Name | Description
CanRead | Gets a value indicating whether the current stream supports reading.
CanSeek | Gets a value indicating whether the current stream supports seeking.
CanWrite | Gets a value indicating whether the current stream supports writing.
Length | Gets size of a stream in bytes.
NativeType | Defines the native type of the object.
Null | Gets an empty NStream.
Position | Gets number of bytes from the start of the data to the current position in a stream.
NMemoryStream Class
Name | Description
Capacity | Gets the stream size of memory assigned to a stream (capacity).
LongCapacity | Gets the stream size of memory assigned to a stream (capacity), as a long number.
NativeCapacity | Gets the stream size of memory assigned to a stream (capacity), as an unsigned integer.
NativeType | Defines the native type of the object.
PositionPtr | Gets the pointer to a certain position.


NStream Class Members

NStream Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NStream Class
Name | Description
AsStream | Converts the current NStream into a data stream.
CopyTo | Copies the current stream to another stream.
Flush | Clears all buffers for this stream and causes any buffered data to be written to the underlying device.
FromStream | Creates new NStream from Stream object.
Read | Reads a sequence of bytes from the current stream.
ReadByte | Reads a byte from the stream.
Seek | Sets the position within the current stream.
SetLength | Sets the length of the current stream.
Synchronized | Creates a synchronized NStream from a Stream object.
Write | Writes a content of a buffer to the current stream.
WriteByte | Writes a byte to the current position in the stream.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NStream Class
Name | Description
CanRead | Gets a value indicating whether the current stream supports reading.
CanSeek | Gets a value indicating whether the current stream supports seeking.
CanWrite | Gets a value indicating whether the current stream supports writing.
Length | Gets size of a stream in bytes.
NativeType | Defines the native type of the object.
Null | Gets an empty NStream.
Position | Gets number of bytes from the start of the data to the current position in a stream.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.


NDisposable Methods

NDisposable Methods
Legend
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NStream Class
Name | Description
AsStream | Converts the current NStream into a data stream.
CopyTo | Copies the current stream to another stream.
Flush | Clears all buffers for this stream and causes any buffered data to be written to the underlying device.
FromStream | Creates new NStream from Stream object.
Read | Reads a sequence of bytes from the current stream.
ReadByte | Reads a byte from the stream.
Seek | Sets the position within the current stream.
SetLength | Sets the length of the current stream.
Synchronized | Creates a synchronized NStream from a Stream object.
Write | Writes a content of a buffer to the current stream.
WriteByte | Writes a byte to the current position in the stream.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NStream Class
Name | Description
CanRead | Gets a value indicating whether the current stream supports reading.
CanSeek | Gets a value indicating whether the current stream supports seeking.
CanWrite | Gets a value indicating whether the current stream supports writing.
Length | Gets size of a stream in bytes.
NativeType | Defines the native type of the object.
Null | Gets an empty NStream.
Position | Gets number of bytes from the start of the data to the current position in a stream.


Neurotec.Images Namespace Classes

Neurotec.Images Namespace Classes
Legend
Classes
Name | Description
BmpInfo | Provides information about BMP format images.
IHeadInfo | Provides information about NIST IHead format images.
Jpeg2KInfo | Provides information about Jpeg 2000 images.
JpegInfo | Provides information about JPEG images.
NImage | Provides functionality for managing images.
NImageFormat | Provides functionality for loading and saving images in format-neutral style.
NImageInfo | Retrieves the object information.
NImageReader | Provides methods which can be used to read image data.
NImageWriter | Provides methods which can be used to write image data.
NImages | Provides library registration and other additional functionality.
NPixelFormat | Provides functionality for working with pixel format.
NRgb | Represents an RGB color.
PngInfo | Provides information about PNG format images.
TiffInfo | Provides information about TIFF format images.


Legend

Legend
Legend
Class
static
Structure
Enumeration


Neurotec.Images Namespace Structs, Records, Enums

Neurotec.Images Namespace Structs, Records, Enums
Legend
Structs, Records, Enums
Name | Description
Jpeg2KProfile | Enumerates JPEG2000 image types.
NImageRotateFlipType | Enumerates NImage rotation and flip values.
NPixelType | Enumerates the pixel types.


BmpInfo Class Members

BmpInfo Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NExpandableObject Class
Show:
No members matching the current filter
Name | Description
NativeType | Defines the native type of the object.
Properties | Gets the property bag of the expandable object.
NImageInfo Class
Show:
No members matching the current filter
Name | Description
Format | Gets or sets the image format.
Height | Gets image height.
NImageRotateFlipTypeNativeType | Defines the native type of the image rotation.
NativeType | Defines the native type of the object.
Transform | Gets or sets the transformation of the image.
Width | Gets image height.
BmpInfo Class
Name | Description
NativeType | Gets or sets a function that retrieves NType object for the enclosing type.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Methods
NImageInfo Class
Show:
No members matching the current filter
Name | Description
NImageInfo | Creates a new instance of NImageInfo class.


BmpInfo Class Methods

BmpInfo Class Methods
Legend
Methods
NImageInfo Class
Show:
No members matching the current filter
Name | Description
NImageInfo | Creates a new instance of NImageInfo class.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NExpandableObject Class
Show:
No members matching the current filter
Name | Description
NativeType | Defines the native type of the object.
Properties | Gets the property bag of the expandable object.
NImageInfo Class
Show:
No members matching the current filter
Name | Description
Format | Gets or sets the image format.
Height | Gets image height.
NImageRotateFlipTypeNativeType | Defines the native type of the image rotation.
NativeType | Defines the native type of the object.
Transform | Gets or sets the transformation of the image.
Width | Gets image height.
BmpInfo Class
Name | Description
NativeType | Gets or sets a function that retrieves NType object for the enclosing type.


IHeadInfo Class Members

IHeadInfo Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NExpandableObject Class
Show:
No members matching the current filter
Name | Description
NativeType | Defines the native type of the object.
Properties | Gets the property bag of the expandable object.
NImageInfo Class
Show:
No members matching the current filter
Name | Description
Format | Gets or sets the image format.
Height | Gets image height.
NImageRotateFlipTypeNativeType | Defines the native type of the image rotation.
NativeType | Defines the native type of the object.
Transform | Gets or sets the transformation of the image.
Width | Gets image height.
IHeadInfo Class
Name | Description
NativeType | Gets or sets
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Methods
NImageInfo Class
Show:
No members matching the current filter
Name | Description
NImageInfo | Creates a new instance of NImageInfo class.


IHeadInfo Class Methods

IHeadInfo Class Methods
Legend
Methods
NImageInfo Class
Show:
No members matching the current filter
Name | Description
NImageInfo | Creates a new instance of NImageInfo class.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NExpandableObject Class
Show:
No members matching the current filter
Name | Description
NativeType | Defines the native type of the object.
Properties | Gets the property bag of the expandable object.
NImageInfo Class
Show:
No members matching the current filter
Name | Description
Format | Gets or sets the image format.
Height | Gets image height.
NImageRotateFlipTypeNativeType | Defines the native type of the image rotation.
NativeType | Defines the native type of the object.
Transform | Gets or sets the transformation of the image.
Width | Gets image height.
IHeadInfo Class
Name | Description
NativeType | Gets or sets


NObject Fields

NObject Fields
Legend
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Jpeg2KInfo Class
Name | Description
DefaultRatio | Specifies default JPEG 2000 quality.


Jpeg2KInfo Class Members

Jpeg2KInfo Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NExpandableObject Class
Show:
No members matching the current filter
Name | Description
NativeType | Defines the native type of the object.
Properties | Gets the property bag of the expandable object.
NImageInfo Class
Show:
No members matching the current filter
Name | Description
Format | Gets or sets the image format.
Height | Gets image height.
NImageRotateFlipTypeNativeType | Defines the native type of the image rotation.
NativeType | Defines the native type of the object.
Transform | Gets or sets the transformation of the image.
Width | Gets image height.
Jpeg2KInfo Class
Name | Description
Jpeg2KProfileNativeType | Defines the native type of the JPEG2000 profile.
NativeType | Gets or sets Gets or sets
Profile | Gets or sets Jpeg 2000 profile value.
Ratio | Gets or sets Jpeg 2000 compression ration.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
Jpeg2KInfo Class
Name | Description
DefaultRatio | Specifies default JPEG 2000 quality.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Methods
NImageInfo Class
Show:
No members matching the current filter
Name | Description
NImageInfo | Creates a new instance of NImageInfo class.


Jpeg2KInfo Class Methods

Jpeg2KInfo Class Methods
Legend
Methods
NImageInfo Class
Show:
No members matching the current filter
Name | Description
NImageInfo | Creates a new instance of NImageInfo class.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NExpandableObject Class
Show:
No members matching the current filter
Name | Description
NativeType | Defines the native type of the object.
Properties | Gets the property bag of the expandable object.
NImageInfo Class
Show:
No members matching the current filter
Name | Description
Format | Gets or sets the image format.
Height | Gets image height.
NImageRotateFlipTypeNativeType | Defines the native type of the image rotation.
NativeType | Defines the native type of the object.
Transform | Gets or sets the transformation of the image.
Width | Gets image height.
Jpeg2KInfo Class
Name | Description
Jpeg2KProfileNativeType | Defines the native type of the JPEG2000 profile.
NativeType | Gets or sets Gets or sets
Profile | Gets or sets Jpeg 2000 profile value.
Ratio | Gets or sets Jpeg 2000 compression ration.


See Also

See Also
See Also

DefaultRatio


NObject Fields

NObject Fields
Legend
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
JpegInfo Class
Name | Description
DefaultQuality | Specifies default JPEG quality.


JpegInfo Class Members

JpegInfo Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NExpandableObject Class
Show:
No members matching the current filter
Name | Description
NativeType | Defines the native type of the object.
Properties | Gets the property bag of the expandable object.
NImageInfo Class
Show:
No members matching the current filter
Name | Description
Format | Gets or sets the image format.
Height | Gets image height.
NImageRotateFlipTypeNativeType | Defines the native type of the image rotation.
NativeType | Defines the native type of the object.
Transform | Gets or sets the transformation of the image.
Width | Gets image height.
JpegInfo Class
Name | Description
IsLossless | Check or sets whether a JPEG image is lossless.
NativeType | Gets or sets
Quality | Gets or sets JPEG image quality
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
JpegInfo Class
Name | Description
DefaultQuality | Specifies default JPEG quality.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Methods
NImageInfo Class
Show:
No members matching the current filter
Name | Description
NImageInfo | Creates a new instance of NImageInfo class.


JpegInfo Class Methods

JpegInfo Class Methods
Legend
Methods
NImageInfo Class
Show:
No members matching the current filter
Name | Description
NImageInfo | Creates a new instance of NImageInfo class.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NExpandableObject Class
Show:
No members matching the current filter
Name | Description
NativeType | Defines the native type of the object.
Properties | Gets the property bag of the expandable object.
NImageInfo Class
Show:
No members matching the current filter
Name | Description
Format | Gets or sets the image format.
Height | Gets image height.
NImageRotateFlipTypeNativeType | Defines the native type of the image rotation.
NativeType | Defines the native type of the object.
Transform | Gets or sets the transformation of the image.
Width | Gets image height.
JpegInfo Class
Name | Description
IsLossless | Check or sets whether a JPEG image is lossless.
NativeType | Gets or sets
Quality | Gets or sets JPEG image quality


NImage Classes

NImage Classes
Legend
NImage Classes
NImage Class
Name | Description
ImagePalette | Represents an image palette.
PlaneCollection | Represents a collection of image data planes.


NObject Fields

NObject Fields
Legend
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NImage Class
Name | Description
FlagAllDst | For internal use.
FlagAllDstAndSrc | For internal use.
FlagAllSrc | For internal use.
FlagDstAlphaChannelFirst | This flag is used when NImage should be copied using Rgb Alpha channel first method (ARGB color space).
FlagDstBottomToTop | This flag is used when NImage should be copied changing pixels order bottom to top (bottom lines become top and vice versa).
FlagDstSwapChannels | This flag is used when NImage should be copied swapping RGB channels (Ex. RGB to BRG).
FlagReadUnknownImage | Flag specifying whether unknown images should be read.
FlagSrcAlphaChannelFirst | This flag is used when NImage should be copied using Rgb Alpha channel first method (ARGB color space).
FlagSrcBottomToTop | This flag is used when NImage should be copied changing pixels order bottom to top (bottom lines become top and vice versa).
FlagSrcSwapChannels | This flag is used when NImage should be copied swapping RGB channels (Ex. RGB to BRG).
FlagWriteUnknownImage | Flag specifying whether unknown images should be written.


NImage Class Members

NImage Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NImage Class
Name | Description
Copy | Copies specified rectangular area of the NImage to other NImage object.
CopyFrom | Copies planes from memory buffer.
CopyFromYCbCrData | Copies NImage data using YCbCr color space.
CopyTo | Copies specified rectangular area of the NImage to other NImage object.
Create | Creates NImage with specified pixel format, size and stride.
Crop | Crops an image.
ExportPalette | Exports the palette from the current image.
FlipDiagonally | Flips image diagonally.
FlipHorizontally | Flips image horizontally.
FlipVertically | Flips image vertically.
FromData | Creates NImage object from data with specified parameters.
FromFile | Creates NImage object from file.
FromImage | Creates NImage object from another NImage object.
FromMemory | Creates NImage object from another memory buffer.
FromStream | Reads NImage from the specified stream
FromVideoSample | Creates NImage object from specified video sample.
GetIndex | Retrieves the palette entry index of the specified pixel.
GetPixel | Retrieves the specified pixel.
GetPixels | Gets buffer which contains image pixels.
GetSupportedVideoSubtypes | Gets supported videos subtypes.
GetWrapper | Creates NImage object wrapper.
IsVideoFormatSupported | Checks if specified video format is supported.
IsVideoSubtypeSupported | Checks if specified video subtype is supported.
RotateFlip | Rotates image using rotation type.
Save | Saves image to memory buffer using specified format.
SetIndex | Sets the palette entry index for the specified pixel.
SetPixel | Sets specified pixel's value to the specified value.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NImage Class
Name | Description
Height | Gets height of image from NImage object.
HorzResolution | Gets horizontal resolution in pixels per inch of image.
ImageSize | Gets size of NImage object.
Info | Retrieves a NImageInfo object for the current image.
LongImageSize | Gets size of NImage object.
LongPlaneSize | Gets the plane size.
LongStride | Gets stride of image from NImage object.
MaxValue | Gets or sets the maximum value of a pixel.
MinValue | Gets or sets the minimum value of a pixel.
NativeImageSize | Gets size of NImage object.
NativePlaneSize | Gets the native plane size.
NativeStride | Gets stride of image from NImage object.
NativeType | Defines the native type of the object.
Palette | Retrieves the palette of the current image.
PixelFormat | Gets NPixelFormat of NImage object.
PlaneSize | Gets the plane size.
Planes | Gets the collection of planes.
ResolutionIsAspectRatio | Gets or sets NImage resolution aspect ratio.
Stride | Gets stride of image from NImage object.
VertResolution | Gets vertical resolution in pixels per inch of image.
Width | Gets width of image from NImage object.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NImage Class
Name | Description
FlagAllDst | For internal use.
FlagAllDstAndSrc | For internal use.
FlagAllSrc | For internal use.
FlagDstAlphaChannelFirst | This flag is used when NImage should be copied using Rgb Alpha channel first method (ARGB color space).
FlagDstBottomToTop | This flag is used when NImage should be copied changing pixels order bottom to top (bottom lines become top and vice versa).
FlagDstSwapChannels | This flag is used when NImage should be copied swapping RGB channels (Ex. RGB to BRG).
FlagReadUnknownImage | Flag specifying whether unknown images should be read.
FlagSrcAlphaChannelFirst | This flag is used when NImage should be copied using Rgb Alpha channel first method (ARGB color space).
FlagSrcBottomToTop | This flag is used when NImage should be copied changing pixels order bottom to top (bottom lines become top and vice versa).
FlagSrcSwapChannels | This flag is used when NImage should be copied swapping RGB channels (Ex. RGB to BRG).
FlagWriteUnknownImage | Flag specifying whether unknown images should be written.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
NImage Classes
NImage Class
Name | Description
ImagePalette | Represents an image palette.
PlaneCollection | Represents a collection of image data planes.


NDisposable Methods

NDisposable Methods
Legend
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NImage Class
Name | Description
Copy | Copies specified rectangular area of the NImage to other NImage object.
CopyFrom | Copies planes from memory buffer.
CopyFromYCbCrData | Copies NImage data using YCbCr color space.
CopyTo | Copies specified rectangular area of the NImage to other NImage object.
Create | Creates NImage with specified pixel format, size and stride.
Crop | Crops an image.
ExportPalette | Exports the palette from the current image.
FlipDiagonally | Flips image diagonally.
FlipHorizontally | Flips image horizontally.
FlipVertically | Flips image vertically.
FromData | Creates NImage object from data with specified parameters.
FromFile | Creates NImage object from file.
FromImage | Creates NImage object from another NImage object.
FromMemory | Creates NImage object from another memory buffer.
FromStream | Reads NImage from the specified stream
FromVideoSample | Creates NImage object from specified video sample.
GetIndex | Retrieves the palette entry index of the specified pixel.
GetPixel | Retrieves the specified pixel.
GetPixels | Gets buffer which contains image pixels.
GetSupportedVideoSubtypes | Gets supported videos subtypes.
GetWrapper | Creates NImage object wrapper.
IsVideoFormatSupported | Checks if specified video format is supported.
IsVideoSubtypeSupported | Checks if specified video subtype is supported.
RotateFlip | Rotates image using rotation type.
Save | Saves image to memory buffer using specified format.
SetIndex | Sets the palette entry index for the specified pixel.
SetPixel | Sets specified pixel's value to the specified value.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NImage Class
Name | Description
Height | Gets height of image from NImage object.
HorzResolution | Gets horizontal resolution in pixels per inch of image.
ImageSize | Gets size of NImage object.
Info | Retrieves a NImageInfo object for the current image.
LongImageSize | Gets size of NImage object.
LongPlaneSize | Gets the plane size.
LongStride | Gets stride of image from NImage object.
MaxValue | Gets or sets the maximum value of a pixel.
MinValue | Gets or sets the minimum value of a pixel.
NativeImageSize | Gets size of NImage object.
NativePlaneSize | Gets the native plane size.
NativeStride | Gets stride of image from NImage object.
NativeType | Defines the native type of the object.
Palette | Retrieves the palette of the current image.
PixelFormat | Gets NPixelFormat of NImage object.
PlaneSize | Gets the plane size.
Planes | Gets the collection of planes.
ResolutionIsAspectRatio | Gets or sets NImage resolution aspect ratio.
Stride | Gets stride of image from NImage object.
VertResolution | Gets vertical resolution in pixels per inch of image.
Width | Gets width of image from NImage object.


Legend

Legend
Legend
Method
Property
read only


NImage.ImagePalette Class Members

NImage.ImagePalette Class Members
Legend
Members
ImagePalette Methods
Name | Description
GetEntries | Gets the palette entries.
SetEntries | Sets palette entries.
ImagePalette Properties
Name | Description
EntriesSize | Gets the palette size.
NativeEntriesSize | Gets the native palette size.


ImagePalette Methods

ImagePalette Methods
Legend
ImagePalette Methods
Name | Description
GetEntries | Gets the palette entries.
SetEntries | Sets palette entries.


ImagePalette Properties

ImagePalette Properties
Legend
ImagePalette Properties
Name | Description
EntriesSize | Gets the palette size.
NativeEntriesSize | Gets the native palette size.


NImageFormat Classes

NImageFormat Classes
Legend
NImageFormat Classes
NImageFormat Class
Name | Description
ImageFormatCollection | Represents the collection of formats in a NImageFormat.


NImageFormat Class Members

NImageFormat Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NImageFormat Class
Name | Description
CreateInfo | Creates image info object for the specified image.
OpenReader | Opens an image reader from a specified buffer.
OpenWriter | Opens an image writer.
Select | Retrieves supported image format registered with file extension of specified file name and supporting reading/writing as specified.
SelectByInternetMediaType | Retrieves supported image format by specified internet media type and supporting specified file access.
SelectReader | Retrieves an image reader from a specified buffer.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NImageFormat Class
Name | Description
Bmp | Specifies the BMP image format.
CanRead | Gets a value indicating whether the current image format supports reading.
CanWrite | Gets a value indicating whether the current image format supports writing.
CanWriteMultiple | Retrieves a value indicating whether the image format supports writing of multiple images.
DefaultFileExtension | Gets default file extension of the current image format.
DefaultInternetMediaType | Gets Default Internet media type of the current image format.
FileFilter | Gets file filter of the current image format.
Formats | Specifies collection of supported image formats.
Gif | Specifies the GIF image format.
IHead | Specifies the NIST IHead image format.
InternetMediaType | Gets Internet media type of the current image format.
Jpeg | Specifies the JPEG image format.
Jpeg2K | Specifies the JPEG2000 image format.
Name | Gets name of the current image format.
NativeType | Defines the native type of the object.
Png | Specifies the PNG image format.
Tiff | Specifies the TIFF image format.
WebP | Specifies the WEBP image format.
Wsq | Specifies the WSQ image format.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
NImageFormat Classes
NImageFormat Class
Name | Description
ImageFormatCollection | Represents the collection of formats in a NImageFormat.


NDisposable Methods

NDisposable Methods
Legend
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NImageFormat Class
Name | Description
CreateInfo | Creates image info object for the specified image.
OpenReader | Opens an image reader from a specified buffer.
OpenWriter | Opens an image writer.
Select | Retrieves supported image format registered with file extension of specified file name and supporting reading/writing as specified.
SelectByInternetMediaType | Retrieves supported image format by specified internet media type and supporting specified file access.
SelectReader | Retrieves an image reader from a specified buffer.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NImageFormat Class
Name | Description
Bmp | Specifies the BMP image format.
CanRead | Gets a value indicating whether the current image format supports reading.
CanWrite | Gets a value indicating whether the current image format supports writing.
CanWriteMultiple | Retrieves a value indicating whether the image format supports writing of multiple images.
DefaultFileExtension | Gets default file extension of the current image format.
DefaultInternetMediaType | Gets Default Internet media type of the current image format.
FileFilter | Gets file filter of the current image format.
Formats | Specifies collection of supported image formats.
Gif | Specifies the GIF image format.
IHead | Specifies the NIST IHead image format.
InternetMediaType | Gets Internet media type of the current image format.
Jpeg | Specifies the JPEG image format.
Jpeg2K | Specifies the JPEG2000 image format.
Name | Gets name of the current image format.
NativeType | Defines the native type of the object.
Png | Specifies the PNG image format.
Tiff | Specifies the TIFF image format.
WebP | Specifies the WEBP image format.
Wsq | Specifies the WSQ image format.


NImageInfo Class Members

NImageInfo Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NExpandableObject Class
Show:
No members matching the current filter
Name | Description
NativeType | Defines the native type of the object.
Properties | Gets the property bag of the expandable object.
NImageInfo Class
Name | Description
Format | Gets or sets the image format.
Height | Gets image height.
NImageRotateFlipTypeNativeType | Defines the native type of the image rotation.
NativeType | Defines the native type of the object.
Transform | Gets or sets the transformation of the image.
Width | Gets image height.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Methods
NImageInfo Class
Name | Description
NImageInfo | Creates a new instance of NImageInfo class.


NImageInfo Class Methods

NImageInfo Class Methods
Legend
Methods
NImageInfo Class
Name | Description
NImageInfo | Creates a new instance of NImageInfo class.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NExpandableObject Class
Show:
No members matching the current filter
Name | Description
NativeType | Defines the native type of the object.
Properties | Gets the property bag of the expandable object.
NImageInfo Class
Name | Description
Format | Gets or sets the image format.
Height | Gets image height.
NImageRotateFlipTypeNativeType | Defines the native type of the image rotation.
NativeType | Defines the native type of the object.
Transform | Gets or sets the transformation of the image.
Width | Gets image height.


NImageReader Class Members

NImageReader Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NImageReader Class
Name | Description
Read | Reads an image.
ReadInfo | Retrieves image info.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NImageReader Class
Name | Description
Format | Gets or sets the image format.
NativeType | Defines the native type of the object.
ReadSize | Gets or sets the size of read image info.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.


NDisposable Methods

NDisposable Methods
Legend
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NImageReader Class
Name | Description
Read | Reads an image.
ReadInfo | Retrieves image info.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NImageReader Class
Name | Description
Format | Gets or sets the image format.
NativeType | Defines the native type of the object.
ReadSize | Gets or sets the size of read image info.


NImageWriter Class Members

NImageWriter Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NImageWriter Class
Name | Description
GetBuffer | Gets a memory buffer to write data from.
Write | Writes data into a specified image.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NImageWriter Class
Name | Description
Format | Gets or sets the image format.
NativeType | Defines the native type of the object.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.


NDisposable Methods

NDisposable Methods
Legend
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NImageWriter Class
Name | Description
GetBuffer | Gets a memory buffer to write data from.
Write | Writes data into a specified image.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NImageWriter Class
Name | Description
Format | Gets or sets the image format.
NativeType | Defines the native type of the object.


NImages Class Members

NImages Class Members
Legend
Members
NImages Methods
Name | Description
GetGrayscaleColorWrapper | Creates NImage object wrapper.
GetOpenFileFilter | Gets a list with names of all NImageFormats, which support reading. Names in the list are separated by semicolon.
GetOpenFileFilterString | Gets a list with names of all NImageFormats, which support reading. Names in the list are separated by semicolon.
GetSaveFileFilter | Gets a list with names of all NImageFormats, which support writing. Names in the list are separated by semicolon.
GetSaveFileFilterString | Gets a list with names of all NImageFormats, which support writing. Names in the list are separated by semicolon.
RecolorImage | Recolors the specified image.
NImages Properties
Name | Description
NativeType | Defines the native type of the object.


NImages Methods

NImages Methods
Legend
NImages Methods
Name | Description
GetGrayscaleColorWrapper | Creates NImage object wrapper.
GetOpenFileFilter | Gets a list with names of all NImageFormats, which support reading. Names in the list are separated by semicolon.
GetOpenFileFilterString | Gets a list with names of all NImageFormats, which support reading. Names in the list are separated by semicolon.
GetSaveFileFilter | Gets a list with names of all NImageFormats, which support writing. Names in the list are separated by semicolon.
GetSaveFileFilterString | Gets a list with names of all NImageFormats, which support writing. Names in the list are separated by semicolon.
RecolorImage | Recolors the specified image.


NImages Properties

NImages Properties
Legend
NImages Properties
Name | Description
NativeType | Defines the native type of the object.


NPixelFormat Fields

NPixelFormat Fields
Legend
NPixelFormat Fields
Name | Description
Grayscale16S | ... more
Grayscale16U | ... more
Grayscale1U | ... more
Grayscale2U | ... more
Grayscale32F | ... more
Grayscale32S | ... more
Grayscale32U | ... more
Grayscale4U | ... more
Grayscale64F | ... more
Grayscale64S | ... more
Grayscale64U | ... more
Grayscale8S | ... more
Grayscale8U | ... more
GrayscaleA16S | ... more
GrayscaleA16U | ... more
GrayscaleA32F | ... more
GrayscaleA32S | ... more
GrayscaleA32U | ... more
GrayscaleA64F | ... more
GrayscaleA64S | ... more
GrayscaleA64U | ... more
GrayscaleA8S | ... more
GrayscaleA8U | ... more
GrayscalePA16S | ... more
GrayscalePA16U | ... more
GrayscalePA32F | ... more
GrayscalePA32S | ... more
GrayscalePA32U | ... more
GrayscalePA64F | ... more
GrayscalePA64S | ... more
GrayscalePA64U | ... more
GrayscalePA8S | ... more
GrayscalePA8U | ... more
Rgb16S | ... more
Rgb16U | ... more
Rgb32F | ... more
Rgb32S | ... more
Rgb32U | ... more
Rgb64F | ... more
Rgb64S | ... more
Rgb64U | ... more
Rgb8S | ... more
Rgb8U | ... more
Rgb8UIndexed1 | ... more
Rgb8UIndexed2 | ... more
Rgb8UIndexed4 | ... more
Rgb8UIndexed8 | ... more
RgbA16S | ... more
RgbA16U | ... more
RgbA32F | ... more
RgbA32S | ... more
RgbA32U | ... more
RgbA64F | ... more
RgbA64S | ... more
RgbA64U | ... more
RgbA8S | ... more
RgbA8U | ... more
RgbA8UIndexed1 | ... more
RgbA8UIndexed2 | ... more
RgbA8UIndexed4 | ... more
RgbA8UIndexed8 | ... more
RgbPA16S | ... more
RgbPA16U | ... more
RgbPA32F | ... more
RgbPA32S | ... more
RgbPA32U | ... more
RgbPA64F | ... more
RgbPA64S | ... more
RgbPA64U | ... more
RgbPA8S | ... more
RgbPA8U | ... more
Undefined | Indicates undefined pixel format.


NPixelFormat Structure Members

NPixelFormat Structure Members
Legend
Members
Methods
Name | Description
NPixelFormat | Initializes a new instance of NPixelFormat class.
NPixelFormat Fields
Name | Description
Grayscale16S | ... more
Grayscale16U | ... more
Grayscale1U | ... more
Grayscale2U | ... more
Grayscale32F | ... more
Grayscale32S | ... more
Grayscale32U | ... more
Grayscale4U | ... more
Grayscale64F | ... more
Grayscale64S | ... more
Grayscale64U | ... more
Grayscale8S | ... more
Grayscale8U | ... more
GrayscaleA16S | ... more
GrayscaleA16U | ... more
GrayscaleA32F | ... more
GrayscaleA32S | ... more
GrayscaleA32U | ... more
GrayscaleA64F | ... more
GrayscaleA64S | ... more
GrayscaleA64U | ... more
GrayscaleA8S | ... more
GrayscaleA8U | ... more
GrayscalePA16S | ... more
GrayscalePA16U | ... more
GrayscalePA32F | ... more
GrayscalePA32S | ... more
GrayscalePA32U | ... more
GrayscalePA64F | ... more
GrayscalePA64S | ... more
GrayscalePA64U | ... more
GrayscalePA8S | ... more
GrayscalePA8U | ... more
Rgb16S | ... more
Rgb16U | ... more
Rgb32F | ... more
Rgb32S | ... more
Rgb32U | ... more
Rgb64F | ... more
Rgb64S | ... more
Rgb64U | ... more
Rgb8S | ... more
Rgb8U | ... more
Rgb8UIndexed1 | ... more
Rgb8UIndexed2 | ... more
Rgb8UIndexed4 | ... more
Rgb8UIndexed8 | ... more
RgbA16S | ... more
RgbA16U | ... more
RgbA32F | ... more
RgbA32S | ... more
RgbA32U | ... more
RgbA64F | ... more
RgbA64S | ... more
RgbA64U | ... more
RgbA8S | ... more
RgbA8U | ... more
RgbA8UIndexed1 | ... more
RgbA8UIndexed2 | ... more
RgbA8UIndexed4 | ... more
RgbA8UIndexed8 | ... more
RgbPA16S | ... more
RgbPA16U | ... more
RgbPA32F | ... more
RgbPA32S | ... more
RgbPA32U | ... more
RgbPA64F | ... more
RgbPA64S | ... more
RgbPA64U | ... more
RgbPA8S | ... more
RgbPA8U | ... more
Undefined | Indicates undefined pixel format.
NPixelFormat Methods
Name | Description
CalcRowLongSize | Calculates number of bytes needed to store line of specified length of pixels with specified bits per pixel.
CalcRowNativeSize | Calculates number of bytes needed to store line of specified length of pixels with specified bits per pixel.
CalcRowSize | Calculates number of bytes needed to store line of specified length of pixels with specified bits per pixel.
CanPixelTypeBeIndexed | Checks whether the specified pixel type can be indexed.
Equals | Checks whether the current pixel format equals the other pixel format.
GetChannelType | Retrieves the current channel type.
GetHashCode | Gets the hash code. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetIndexed | Retrieves an indexed version of the NPixelFormat.
GetNonIndexed | Retrieves a non-indexed version of the NPixelFormat.
GetNonSeparated | Retrieves a non-separated version of the NPixelFormat.
GetPaletteSize | Retrieves the palette size.
GetRowLongSize | Calculates number of bytes needed to store line of specified length of pixels with specified NPixelFormat.
GetRowNativeSize | Calculates number of bytes needed to store line of specified length of pixels with specified NPixelFormat and alignment.
GetRowSize | Calculates number of bytes needed to store line of specified length of pixels with specified NPixelFormat.
GetSeparated | Retrieves a separated version of the NPixelFormat.
GetWithExtraChannel | Retrieves a version of the NPixelFormat with an extra channel.
IsPixelTypeValid | Checks whether current NPixelType value is valid.
ToString | Retrieves string representation of NPixelFormat object.
NPixelFormat Operators
Name | Description
!= | Checks if two pixelFormats are not equal.
== | Checks if two pixelFormats are equal.
NPixelFormat | This conversion operator converts from a uint type to a NPixelFormat type
uint | Gets value field of NPixelFormat object.
NPixelFormat Properties
Name | Description
BitsPerChannel | Gets or sets the number of bits per channel.
BitsPerIndex | Gets or sets the number of bits per index.
BitsPerPaletteEntry | Gets or sets the number of bits per palette entry.
BitsPerPixel | Each pixel value is stored in 24 bits consisting of three 8-bit values representing red, green and blue color components.
BitsPerValue | Gets or sets the number of bits per value.
BytesPerChannel | Gets or sets the number of bytes per channel.
BytesPerPaletteEntry | Gets or sets the number of bytes per palette entry.
BytesPerPixel | Gets or sets the number of bytes per pixel.
BytesPerValue | Gets or sets the number of bytes per value.
ChannelCount | Gets or sets the number of channels.
ChannelFormat | Gets or sets the format of the channel.
ExtraChannel | Gets or sets the extra channel.
IsIndexed | Checks whether current NPixelFormat value is indexed.
IsSeparated | Checks whether current NPixelFormat value is separated.
IsValid | Checks whether current NPixelFormat value is valid.
MaxPaletteLength | Gets or sets the maximum palette length.
NPixelTypeNativeType | Defines the native type of the pixel type.
NativeType | Defines the native type of the object.
PixelType | Gets or sets the type of the pixel.
PlaneCount | Gets or sets the number of the planes.


NPixelFormat Structure Methods

NPixelFormat Structure Methods
Legend
Methods
Name | Description
NPixelFormat | Initializes a new instance of NPixelFormat class.


NPixelFormat Methods

NPixelFormat Methods
Legend
NPixelFormat Methods
Name | Description
CalcRowLongSize | Calculates number of bytes needed to store line of specified length of pixels with specified bits per pixel.
CalcRowNativeSize | Calculates number of bytes needed to store line of specified length of pixels with specified bits per pixel.
CalcRowSize | Calculates number of bytes needed to store line of specified length of pixels with specified bits per pixel.
CanPixelTypeBeIndexed | Checks whether the specified pixel type can be indexed.
Equals | Checks whether the current pixel format equals the other pixel format.
GetChannelType | Retrieves the current channel type.
GetHashCode | Gets the hash code. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetIndexed | Retrieves an indexed version of the NPixelFormat.
GetNonIndexed | Retrieves a non-indexed version of the NPixelFormat.
GetNonSeparated | Retrieves a non-separated version of the NPixelFormat.
GetPaletteSize | Retrieves the palette size.
GetRowLongSize | Calculates number of bytes needed to store line of specified length of pixels with specified NPixelFormat.
GetRowNativeSize | Calculates number of bytes needed to store line of specified length of pixels with specified NPixelFormat and alignment.
GetRowSize | Calculates number of bytes needed to store line of specified length of pixels with specified NPixelFormat.
GetSeparated | Retrieves a separated version of the NPixelFormat.
GetWithExtraChannel | Retrieves a version of the NPixelFormat with an extra channel.
IsPixelTypeValid | Checks whether current NPixelType value is valid.
ToString | Retrieves string representation of NPixelFormat object.


NPixelFormat Operators

NPixelFormat Operators
Legend
NPixelFormat Operators
Name | Description
!= | Checks if two pixelFormats are not equal.
== | Checks if two pixelFormats are equal.
NPixelFormat | This conversion operator converts from a uint type to a NPixelFormat type
uint | Gets value field of NPixelFormat object.


NPixelFormat Properties

NPixelFormat Properties
Legend
NPixelFormat Properties
Name | Description
BitsPerChannel | Gets or sets the number of bits per channel.
BitsPerIndex | Gets or sets the number of bits per index.
BitsPerPaletteEntry | Gets or sets the number of bits per palette entry.
BitsPerPixel | Each pixel value is stored in 24 bits consisting of three 8-bit values representing red, green and blue color components.
BitsPerValue | Gets or sets the number of bits per value.
BytesPerChannel | Gets or sets the number of bytes per channel.
BytesPerPaletteEntry | Gets or sets the number of bytes per palette entry.
BytesPerPixel | Gets or sets the number of bytes per pixel.
BytesPerValue | Gets or sets the number of bytes per value.
ChannelCount | Gets or sets the number of channels.
ChannelFormat | Gets or sets the format of the channel.
ExtraChannel | Gets or sets the extra channel.
IsIndexed | Checks whether current NPixelFormat value is indexed.
IsSeparated | Checks whether current NPixelFormat value is separated.
IsValid | Checks whether current NPixelFormat value is valid.
MaxPaletteLength | Gets or sets the maximum palette length.
NPixelTypeNativeType | Defines the native type of the pixel type.
NativeType | Defines the native type of the object.
PixelType | Gets or sets the type of the pixel.
PlaneCount | Gets or sets the number of the planes.


NRgb Structure Members

NRgb Structure Members
Legend
Members
Methods
Name | Description
NRgb | Initializes a new instance of the NRgb structure.
NRgb Methods
Name | Description
ToArray | Retrieves a byte array representation of NRgb object.
ToString | Retrieves a string representation of NRgb object.
NRgb Properties
Name | Description
Blue | Gets the blue component value of this NRgb structure.
Green | Gets the green component value of this NRgb structure.
Red | Gets the red component value of this NRgb structure.


NRgb Structure Methods

NRgb Structure Methods
Legend
Methods
Name | Description
NRgb | Initializes a new instance of the NRgb structure.


NRgb Methods

NRgb Methods
Legend
NRgb Methods
Name | Description
ToArray | Retrieves a byte array representation of NRgb object.
ToString | Retrieves a string representation of NRgb object.


NRgb Properties

NRgb Properties
Legend
NRgb Properties
Name | Description
Blue | Gets the blue component value of this NRgb structure.
Green | Gets the green component value of this NRgb structure.
Red | Gets the red component value of this NRgb structure.


NObject Fields

NObject Fields
Legend
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
PngInfo Class
Name | Description
DefaultCompressionLevel | Specifies default Png compression level.


PngInfo Class Members

PngInfo Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NExpandableObject Class
Show:
No members matching the current filter
Name | Description
NativeType | Defines the native type of the object.
Properties | Gets the property bag of the expandable object.
NImageInfo Class
Show:
No members matching the current filter
Name | Description
Format | Gets or sets the image format.
Height | Gets image height.
NImageRotateFlipTypeNativeType | Defines the native type of the image rotation.
NativeType | Defines the native type of the object.
Transform | Gets or sets the transformation of the image.
Width | Gets image height.
PngInfo Class
Name | Description
CompressionLevel | Gets or sets compression level of a PNG image.
NativeType | Gets or sets
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
PngInfo Class
Name | Description
DefaultCompressionLevel | Specifies default Png compression level.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Methods
NImageInfo Class
Show:
No members matching the current filter
Name | Description
NImageInfo | Creates a new instance of NImageInfo class.


PngInfo Class Methods

PngInfo Class Methods
Legend
Methods
NImageInfo Class
Show:
No members matching the current filter
Name | Description
NImageInfo | Creates a new instance of NImageInfo class.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NExpandableObject Class
Show:
No members matching the current filter
Name | Description
NativeType | Defines the native type of the object.
Properties | Gets the property bag of the expandable object.
NImageInfo Class
Show:
No members matching the current filter
Name | Description
Format | Gets or sets the image format.
Height | Gets image height.
NImageRotateFlipTypeNativeType | Defines the native type of the image rotation.
NativeType | Defines the native type of the object.
Transform | Gets or sets the transformation of the image.
Width | Gets image height.
PngInfo Class
Name | Description
CompressionLevel | Gets or sets compression level of a PNG image.
NativeType | Gets or sets


TiffInfo Class Members

TiffInfo Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NExpandableObject Class
Show:
No members matching the current filter
Name | Description
NativeType | Defines the native type of the object.
Properties | Gets the property bag of the expandable object.
NImageInfo Class
Show:
No members matching the current filter
Name | Description
Format | Gets or sets the image format.
Height | Gets image height.
NImageRotateFlipTypeNativeType | Defines the native type of the image rotation.
NativeType | Defines the native type of the object.
Transform | Gets or sets the transformation of the image.
Width | Gets image height.
TiffInfo Class
Name | Description
NativeType | Gets or sets
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Methods
NImageInfo Class
Show:
No members matching the current filter
Name | Description
NImageInfo | Creates a new instance of NImageInfo class.


TiffInfo Class Methods

TiffInfo Class Methods
Legend
Methods
NImageInfo Class
Show:
No members matching the current filter
Name | Description
NImageInfo | Creates a new instance of NImageInfo class.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NExpandableObject Class
Show:
No members matching the current filter
Name | Description
NativeType | Defines the native type of the object.
Properties | Gets the property bag of the expandable object.
NImageInfo Class
Show:
No members matching the current filter
Name | Description
Format | Gets or sets the image format.
Height | Gets image height.
NImageRotateFlipTypeNativeType | Defines the native type of the image rotation.
NativeType | Defines the native type of the object.
Transform | Gets or sets the transformation of the image.
Width | Gets image height.
TiffInfo Class
Name | Description
NativeType | Gets or sets


Neurotec.Interop Namespace Classes

Neurotec.Interop Namespace Classes
Legend
Classes
Name | Description
NKeyValuePair_ | Represents a key value pair structure.
NNameStringPair_ | Represents a pair of name strings.
NNameValuePair_ | Represents a name value pair structure.


Legend

Legend
Legend
Structure


NKeyValuePair_ Fields

NKeyValuePair_ Fields
Legend
NKeyValuePair_ Fields
Name | Description
hKey | Handle to the key part of the key value pair.
hValue | Handle to the value part of the key value pair.


Legend

Legend
Legend
Data Member
Method
static


NKeyValuePair_ Structure Members

NKeyValuePair_ Structure Members
Legend
Members
NKeyValuePair_ Fields
Name | Description
hKey | Handle to the key part of the key value pair.
hValue | Handle to the value part of the key value pair.
NKeyValuePair_ Methods
Name | Description
Create | Creates a new key value pair from the specified key value pair structure.
Dispose | Disposes of the specified key value pair.
ToStruct | Creates a new key value pair structure from the specified key value pair.


NKeyValuePair_ Methods

NKeyValuePair_ Methods
Legend
NKeyValuePair_ Methods
Name | Description
Create | Creates a new key value pair from the specified key value pair structure.
Dispose | Disposes of the specified key value pair.
ToStruct | Creates a new key value pair structure from the specified key value pair.


NNameStringPair_ Fields

NNameStringPair_ Fields
Legend
NNameStringPair_ Fields
Name | Description
hKey | Key string of the name string pair.
hValue | Value string of the name string pair.


NNameStringPair_ Structure Members

NNameStringPair_ Structure Members
Legend
Members
NNameStringPair_ Fields
Name | Description
hKey | Key string of the name string pair.
hValue | Value string of the name string pair.
NNameStringPair_ Methods
Name | Description
Create | Creates a name value pair from the specified key value pair.
Dispose | Disposes of the specified name string pair.
ToStruct | Converts a name string pair into a key value pair.


NNameStringPair_ Methods

NNameStringPair_ Methods
Legend
NNameStringPair_ Methods
Name | Description
Create | Creates a name value pair from the specified key value pair.
Dispose | Disposes of the specified name string pair.
ToStruct | Converts a name string pair into a key value pair.


NNameValuePair_ Fields

NNameValuePair_ Fields
Legend
NNameValuePair_ Fields
Name | Description
hKey | Handle to the key part of the name value pair.
hValue | Handle to the value part of the name value pair.


NNameValuePair_ Structure Members

NNameValuePair_ Structure Members
Legend
Members
NNameValuePair_ Fields
Name | Description
hKey | Handle to the key part of the name value pair.
hValue | Handle to the value part of the name value pair.
NNameValuePair_ Methods
Name | Description
Create | Creates a new name value pair from the specified key value pair structure.
Dispose | Disposes of the specified name value pair.
ToStruct | Creates a new key value pair structure from the specified name value pair.


NNameValuePair_ Methods

NNameValuePair_ Methods
Legend
NNameValuePair_ Methods
Name | Description
Create | Creates a new name value pair from the specified key value pair structure.
Dispose | Disposes of the specified name value pair.
ToStruct | Creates a new key value pair structure from the specified name value pair.


Neurotec.Licensing Namespace Classes

Neurotec.Licensing Namespace Classes
Legend
Classes
Name | Description
NLicense | Provides functionality for getting, releasing licenses.
NLicenseInfo | Provides functionality for license info retrieval.
NLicenseManager | Provides functionality for licenses management.
NLicenseProductInfo | Provides functionality for product info retrieval.
NLicensing | Provides methods for retrieving information about the NLicensing library.
NLicensingService | Manages licensing services.


Neurotec.Licensing Namespace Structs, Records, Enums

Neurotec.Licensing Namespace Structs, Records, Enums
Legend
Structs, Records, Enums
Name | Description
NLicenseInfoSourceType | Specifies license source type.
NLicenseInfoStatus | Specifies license status.
NLicenseInfoType | Specifies licensing type.
NLicenseType | Enumerates license type.
NLicensingServiceStatus | Enumerates licensing service status values.


NLicense Class Members

NLicense Class Members
Legend
Members
NLicense Methods
Name | Description
ActivateOnline | Activates specified Id (that was obtained through calling GenerateId method or using ActivationWizardDotNet) and obtains license file for this Id via Internet.
Add | Adds the activated license content (the content of *.lic file) to be used in application.
DeactivateOnline | Deactivates specified license via Internet.
DeactivateOnlineWithId | Deactivates specified license via Internet using specified deactivation Id.
GenerateDeactivationId | Generates deactivation Id for specified provided product on current computer.
GenerateDeactivationIdForLicense | Generates deactivation Id for specified license on current computer.
GenerateId | Generates Id for activation from serial number for a particular machine.
GetLicenseInfoOnline | Retrieves license information via internet.
GetObtainedLicenseInfo | Retrieves license information of specified product.
GetObtainedLicenseInfoForComponent | Retrieves license information of specified component.
GetObtainedStatus | Since license was obtained, it is possible that it became not available or remote server disconnected. Use this function to get current obtained status. Note: NLicensing automatically tries to reobtain license in case of failure, so failure status may change to LicenseObtained.
IsComponentActivated | Checks if component specified by name is activated.
Obtain | Obtains license.
ObtainComponents | Obtains component license from the specified server.
Release | Releases license.
ReleaseComponents | Releases component license.
NLicense Properties
Name | Description
NativeType | Defines the native type of the object.


NLicense Methods

NLicense Methods
Legend
NLicense Methods
Name | Description
ActivateOnline | Activates specified Id (that was obtained through calling GenerateId method or using ActivationWizardDotNet) and obtains license file for this Id via Internet.
Add | Adds the activated license content (the content of *.lic file) to be used in application.
DeactivateOnline | Deactivates specified license via Internet.
DeactivateOnlineWithId | Deactivates specified license via Internet using specified deactivation Id.
GenerateDeactivationId | Generates deactivation Id for specified provided product on current computer.
GenerateDeactivationIdForLicense | Generates deactivation Id for specified license on current computer.
GenerateId | Generates Id for activation from serial number for a particular machine.
GetLicenseInfoOnline | Retrieves license information via internet.
GetObtainedLicenseInfo | Retrieves license information of specified product.
GetObtainedLicenseInfoForComponent | Retrieves license information of specified component.
GetObtainedStatus | Since license was obtained, it is possible that it became not available or remote server disconnected. Use this function to get current obtained status. Note: NLicensing automatically tries to reobtain license in case of failure, so failure status may change to LicenseObtained.
IsComponentActivated | Checks if component specified by name is activated.
Obtain | Obtains license.
ObtainComponents | Obtains component license from the specified server.
Release | Releases license.
ReleaseComponents | Releases component license.


NLicense Properties

NLicense Properties
Legend
NLicense Properties
Name | Description
NativeType | Defines the native type of the object.


NLicenseInfo Class Members

NLicenseInfo Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NLicenseInfo Class
Name | Description
GetLicenses | Gets all licenses from specified NLicenseInfo.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NLicenseInfo Class
Name | Description
DistributorId | Gets distributor id.
LicenseId | Gets license Id.
NativeType | Defines the native type of the object.
SequenceNumber | Gets license sequence number.
SourceType | Gets license source type.
Status | Gets license status.
Type | Gets license type.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.


NDisposable Methods

NDisposable Methods
Legend
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NLicenseInfo Class
Name | Description
GetLicenses | Gets all licenses from specified NLicenseInfo.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NLicenseInfo Class
Name | Description
DistributorId | Gets distributor id.
LicenseId | Gets license Id.
NativeType | Defines the native type of the object.
SequenceNumber | Gets license sequence number.
SourceType | Gets license source type.
Status | Gets license status.
Type | Gets license type.


NLicenseManager Class Members

NLicenseManager Class Members
Legend
Members
NLicenseManager Methods
Name | Description
FindFirstDongle | Retrieves handle to the first attached dongle.
FindNextDongle | ... more
GenerateLicense | Generates product license from computer Id.
GenerateLicenseEx | Generates product license from computer Id.
GenerateSerial | Generates serial number for a specified product.
GenerateSerialEx | Generates serial number for a specified product from the specified dongle.
GetDongles | Retrieves all Neurotec dongles
GetLicenseData | Retrieves license data for a specified product license.
GetLicenseDataEx | Retrieves license data for a specified product license.
GetLongProductName | Retrieves full name of a product specified by product info.
GetProductIds | Retrieves a list of all Neurotechnology products Ids.
GetShortProductName | Retrieves short name of a product from specified NLicenseProductInfo.
GetUpdateTicketInfo | Gets specified ticket number update info.
IsLicenseTypeSupported | Checks whether the specified license type is supported.
NLicenseManager Properties
Name | Description
ClientId | Gets or sets application identifier to identify application if more than one appolication is used.
NLicenseTypeNativeType | Defines the native type of the license type.
NativeType | Defines the native type of the object.
ProxyHost | Gets or sets proxy server host name.
ProxyPort | Gets or sets proxy port number of licensing server.
TrialMode | Enables or disables trial mode of SDK (trial mode flag is set in Bin/Licenses/TrialFlag.txt).
UseHttps | Enables or disables https/SSL (port 443) protocol between application and remote Neurotechnology server. This feature is used only with trial or Internet License for nopg mode (when Neurotechnology Licensing Service is not used).
WritableStoragePath | Gets or sets the path of writable storage.


NLicenseManager Methods

NLicenseManager Methods
Legend
NLicenseManager Methods
Name | Description
FindFirstDongle | Retrieves handle to the first attached dongle.
FindNextDongle | ... more
GenerateLicense | Generates product license from computer Id.
GenerateLicenseEx | Generates product license from computer Id.
GenerateSerial | Generates serial number for a specified product.
GenerateSerialEx | Generates serial number for a specified product from the specified dongle.
GetDongles | Retrieves all Neurotec dongles
GetLicenseData | Retrieves license data for a specified product license.
GetLicenseDataEx | Retrieves license data for a specified product license.
GetLongProductName | Retrieves full name of a product specified by product info.
GetProductIds | Retrieves a list of all Neurotechnology products Ids.
GetShortProductName | Retrieves short name of a product from specified NLicenseProductInfo.
GetUpdateTicketInfo | Gets specified ticket number update info.
IsLicenseTypeSupported | Checks whether the specified license type is supported.


NLicenseManager Properties

NLicenseManager Properties
Legend
NLicenseManager Properties
Name | Description
ClientId | Gets or sets application identifier to identify application if more than one appolication is used.
NLicenseTypeNativeType | Defines the native type of the license type.
NativeType | Defines the native type of the object.
ProxyHost | Gets or sets proxy server host name.
ProxyPort | Gets or sets proxy port number of licensing server.
TrialMode | Enables or disables trial mode of SDK (trial mode flag is set in Bin/Licenses/TrialFlag.txt).
UseHttps | Enables or disables https/SSL (port 443) protocol between application and remote Neurotechnology server. This feature is used only with trial or Internet License for nopg mode (when Neurotechnology Licensing Service is not used).
WritableStoragePath | Gets or sets the path of writable storage.


NLicenseProductInfo Class Members

NLicenseProductInfo Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NLicenseProductInfo Class
Name | Description
Id | Gets the product ID number.
LicenseCount | Gets the product license count.
LicenseType | Gets the product license type.
NativeType | Defines the native type of the object.
OSFamily | Gets the product operating system family.
Parameters | Gets the product parameters.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NLicenseProductInfo Class
Name | Description
Id | Gets the product ID number.
LicenseCount | Gets the product license count.
LicenseType | Gets the product license type.
NativeType | Defines the native type of the object.
OSFamily | Gets the product operating system family.
Parameters | Gets the product parameters.


NLicensing Fields

NLicensing Fields
Legend
NLicensing Fields
Name | Description
DllName | Name of DLL containing unmanaged part of this class.


NLicensing Class Members

NLicensing Class Members
Legend
Members
NLicensing Fields
Name | Description
DllName | Name of DLL containing unmanaged part of this class.
NLicensing Properties
Name | Description
NativeModule | Defines the native module of the object.


NLicensing Properties

NLicensing Properties
Legend
NLicensing Properties
Name | Description
NativeModule | Defines the native module of the object.


NLicensingService Class Members

NLicensingService Class Members
Legend
Members
NLicensingService Methods
Name | Description
GetBinPath | Gets the binary path (path to pg.exe) to the license.
GetConfPath | Gets path to licensing service configuration file (pgd.conf).
GetStatus | Gets the status of the licensing service.
Install | Installs licensing service.
IsTrial | Checks whether the licensing service is trial.
Start | Starts licensing service.
Stop | Stops licensing service.
Uninstall | Uninstalls licensing service.
NLicensingService Properties
Name | Description
NLicensingServiceStatusNativeType | Defines the native type of the licensing service status.
NativeType | Defines the native type of the object.


NLicensingService Methods

NLicensingService Methods
Legend
NLicensingService Methods
Name | Description
GetBinPath | Gets the binary path (path to pg.exe) to the license.
GetConfPath | Gets path to licensing service configuration file (pgd.conf).
GetStatus | Gets the status of the licensing service.
Install | Installs licensing service.
IsTrial | Checks whether the licensing service is trial.
Start | Starts licensing service.
Stop | Stops licensing service.
Uninstall | Uninstalls licensing service.


NLicensingService Properties

NLicensingService Properties
Legend
NLicensingService Properties
Name | Description
NLicensingServiceStatusNativeType | Defines the native type of the licensing service status.
NativeType | Defines the native type of the object.


Neurotec.Media Namespace Classes

Neurotec.Media Namespace Classes
Legend
Classes
Name | Description
NMedia | Provides information about NMedia library.
NMediaFormat | Provides methods to retrieve information about media formats.
NMediaReader | Provides methods which can be used to read media data.
NMediaSource | Provides methods for working with media source.
NMediaTypes | Provides methods to check if media type is valid.
NVideoFormat | Class represents video format. Each video source supports one or more video formats. Video format is used to decode (encode) video stream and extract (encode) each video frame.


Neurotec.Media Namespace Structs, Records, Enums

Neurotec.Media Namespace Structs, Records, Enums
Legend
Structs, Records, Enums
Name | Description
NMediaState | Enumerates media state values.
NMediaType | Enumerates media type values.
NVideoInterlaceMode | Represents video interlace mode.


NMedia Fields

NMedia Fields
Legend
NMedia Fields
Name | Description
DllName | Name of DLL containing unmanaged part of this class.


NMedia Class Members

NMedia Class Members
Legend
Members
NMedia Fields
Name | Description
DllName | Name of DLL containing unmanaged part of this class.
NMedia Properties
Name | Description
NativeModule | Defines the native module of the object.


NMedia Properties

NMedia Properties
Legend
NMedia Properties
Name | Description
NativeModule | Defines the native module of the object.


Legend

Legend
Legend
Method
virtual
static
Property
read only
Data Member
Event
Operator


NMediaFormat Class Members

NMediaFormat Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NMediaFormat Class
Name | Description
Equals | Checks whether the current media format equal the other media format.
GetHashCode | Gets the hash code.
IsCompatibleWith | Checks if media format is compatible with other media format.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NExpandableObject Class
Show:
No members matching the current filter
Name | Description
NativeType | Defines the native type of the object.
Properties | Gets the property bag of the expandable object.
NMediaFormat Class
Name | Description
MediaSubtype | Gets or sets media subtype from/for specified media format.
MediaType | Gets or sets media type from/for specified NMediaFormat.
NativeType | Defines the native type of the object.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
NMediaFormat Operators
NMediaFormat Class
Name | Description
!= | The inequality operator used to check if specified operands are not equal.
== | Equality operator used to check if specified operands are equal.


NDisposable Methods

NDisposable Methods
Legend
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NMediaFormat Class
Name | Description
Equals | Checks whether the current media format equal the other media format.
GetHashCode | Gets the hash code.
IsCompatibleWith | Checks if media format is compatible with other media format.


NMediaFormat Operators

NMediaFormat Operators
Legend
NMediaFormat Operators
NMediaFormat Class
Name | Description
!= | The inequality operator used to check if specified operands are not equal.
== | Equality operator used to check if specified operands are equal.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NExpandableObject Class
Show:
No members matching the current filter
Name | Description
NativeType | Defines the native type of the object.
Properties | Gets the property bag of the expandable object.
NMediaFormat Class
Name | Description
MediaSubtype | Gets or sets media subtype from/for specified media format.
MediaType | Gets or sets media type from/for specified NMediaFormat.
NativeType | Defines the native type of the object.


NMediaReader Class Members

NMediaReader Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NMediaReader Class
Name | Description
Pause | Pauses specified NMediaReader.
ReadAudioSample | Reads audio sample to NSoundBuffer
ReadVideoSample | Reads video sample using NMediaReader.
ReadVideoSampleData | Reads video sample using NMediaReader.
Start | Starts NMediaReader.
Stop | Stops NMediaReader.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NMediaReader Class
Name | Description
IsLive | Checks if media source which is used by NMediaReader is live.
Length | Gets file length when NMediaReader source is file.
NativeType | Defines the native type of the object.
Position | Gets or sets NMediaReader position in media source (file).
Source | Gets media source (file or device) of the NMediaReader.
State | Gets NMediaReader state.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Methods
NMediaReader Class
Name | Description
NMediaReader | Creates new instance of NMediaReader.


NMediaReader Class Methods

NMediaReader Class Methods
Legend
Methods
NMediaReader Class
Name | Description
NMediaReader | Creates new instance of NMediaReader.


NDisposable Methods

NDisposable Methods
Legend
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NMediaReader Class
Name | Description
Pause | Pauses specified NMediaReader.
ReadAudioSample | Reads audio sample to NSoundBuffer
ReadVideoSample | Reads video sample using NMediaReader.
ReadVideoSampleData | Reads video sample using NMediaReader.
Start | Starts NMediaReader.
Stop | Stops NMediaReader.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NMediaReader Class
Name | Description
IsLive | Checks if media source which is used by NMediaReader is live.
Length | Gets file length when NMediaReader source is file.
NativeType | Defines the native type of the object.
Position | Gets or sets NMediaReader position in media source (file).
Source | Gets media source (file or device) of the NMediaReader.
State | Gets NMediaReader state.


NObject Fields

NObject Fields
Legend
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NMediaSource Class
Name | Description
FlagAllowDuplicateDevices | This field is used to allow enumerating duplicate devices. If this field was set and the same device is accessible through DirectShow and Windows Media Foundation (Windows 7) then this device will be enumerated twice.
FlagDoNotUseDirectShow | Used when user prefers not to use DirecShow for NMediaSource.
FlagDoNotUseVlc | Used when user prefers not to use VLC for NMediaSource.
FlagDoNotUseWindowsMedia | Used when user prefers not to use Windows Media for NMediaSource.
FlagDoNotUseWindowsMediaFoundation | Used when user prefers not to use Windows Media Foundation for NMediaSource.
FlagPreferDirectShow | Used when user prefers to use DirectShow for NMediaSource.
FlagPreferVlc | Used when user prefers to use VLC for NMediaSource.
FlagPreferWindowsMedia | Used when user prefers to use Windows Media for NMediaSource.
FlagPreferWindowsMediaFoundation | Used when user prefers to use Media Foundation for NMediaSource.


NMediaSource Class Members

NMediaSource Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NMediaSource Class
Name | Description
EnumDevices | Enumerates all source devices by specified media type.
Equals | Determines whether the specified NMediaSource is equal to the current NMediaSource.
FromFile | Creates NMediaSource from specified file.
FromUrl | Gets the media source from specified URL.
GetCurrentFormat | Gets the current media format of the specified media type.
GetFormats | Gets the media formats of specified media type.
GetHashCode | Gets the hash code.
SetCurrentFormat | Sets the current media format of the specified media type to specified value.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NMediaSource Class
Name | Description
DisplayName | Gets the display name of the current media source.
Id | Gets the ID of the current media source.
MediaType | Gets the media type of the current media source.
NativeType | Defines the native type of the object.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NMediaSource Class
Name | Description
FlagAllowDuplicateDevices | This field is used to allow enumerating duplicate devices. If this field was set and the same device is accessible through DirectShow and Windows Media Foundation (Windows 7) then this device will be enumerated twice.
FlagDoNotUseDirectShow | Used when user prefers not to use DirecShow for NMediaSource.
FlagDoNotUseVlc | Used when user prefers not to use VLC for NMediaSource.
FlagDoNotUseWindowsMedia | Used when user prefers not to use Windows Media for NMediaSource.
FlagDoNotUseWindowsMediaFoundation | Used when user prefers not to use Windows Media Foundation for NMediaSource.
FlagPreferDirectShow | Used when user prefers to use DirectShow for NMediaSource.
FlagPreferVlc | Used when user prefers to use VLC for NMediaSource.
FlagPreferWindowsMedia | Used when user prefers to use Windows Media for NMediaSource.
FlagPreferWindowsMediaFoundation | Used when user prefers to use Media Foundation for NMediaSource.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
NMediaSource Operators
NMediaSource Class
Name | Description
!= | Checks whether two NMediaSource values are not equal.
== | Checks whether two NMediaSource values are equal.


NDisposable Methods

NDisposable Methods
Legend
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NMediaSource Class
Name | Description
EnumDevices | Enumerates all source devices by specified media type.
Equals | Determines whether the specified NMediaSource is equal to the current NMediaSource.
FromFile | Creates NMediaSource from specified file.
FromUrl | Gets the media source from specified URL.
GetCurrentFormat | Gets the current media format of the specified media type.
GetFormats | Gets the media formats of specified media type.
GetHashCode | Gets the hash code.
SetCurrentFormat | Sets the current media format of the specified media type to specified value.


NMediaSource Operators

NMediaSource Operators
Legend
NMediaSource Operators
NMediaSource Class
Name | Description
!= | Checks whether two NMediaSource values are not equal.
== | Checks whether two NMediaSource values are equal.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NMediaSource Class
Name | Description
DisplayName | Gets the display name of the current media source.
Id | Gets the ID of the current media source.
MediaType | Gets the media type of the current media source.
NativeType | Defines the native type of the object.


NMediaTypes Class Members

NMediaTypes Class Members
Legend
Members
NMediaTypes Methods
Name | Description
IsMediaTypeValid | Checks whether the specified media type is valid.
IsMediaTypeValidSingle | Checks if the single value passed to a method is a valid media type.
IsVideoInterlaceModeValid | Checks whether the video interlace mode is valid.
NMediaTypes Properties
Name | Description
NMediaStateNativeType | Defines the native type of the media state.
NMediaTypeNativeType | Defines the native type of the media type.
NVideoInterlaceModeNativeType | Defines the native type of the video interlace mode.
NativeType | Defines the native type of the object.


NMediaTypes Methods

NMediaTypes Methods
Legend
NMediaTypes Methods
Name | Description
IsMediaTypeValid | Checks whether the specified media type is valid.
IsMediaTypeValidSingle | Checks if the single value passed to a method is a valid media type.
IsVideoInterlaceModeValid | Checks whether the video interlace mode is valid.


NMediaTypes Properties

NMediaTypes Properties
Legend
NMediaTypes Properties
Name | Description
NMediaStateNativeType | Defines the native type of the media state.
NMediaTypeNativeType | Defines the native type of the media type.
NVideoInterlaceModeNativeType | Defines the native type of the video interlace mode.
NativeType | Defines the native type of the object.


NObject Fields

NObject Fields
Legend
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NVideoFormat Class
Name | Description
AI44 | Value for video format AI44.
Argb32 | Value for video format RGB, 32 bpp with alpha channel.
Ayuv | Value for video format AYUV.
DV25 | Value for video format DVCPRO 25 (525-60 or 625-50).
DV50 | Value for video format DVCPRO 50 (525-60 or 625-50).
DX50 | Value for video format DX50.
Dvc | Value for video format DVC/DV Video.
Dvh1 | Value for video format DVC/DV Video.
Dvhd | Value for video format HD-DVCR (1125-60 or 1250-50).
Dvsd | Value for video format SDL-DVCR (525-60 or 625-50).
Dvsl | Value for video format SD-DVCR (525-60 or 625-50).
H264 | Value for video format H.264.
I420 | Value for video format I420.
Iyuv | Value for video format IYUV.
L16 | Value for video format L16.
L8 | Value for video format L8.
M4S2 | Value for video format MPEG-4 part 2 video.
MP43 | Value for video format Microsoft MPEG 4 codec version 3.
MP4S | Value for video format ISO MPEG 4 codec version 1.
MP4V | Value for video format MPEG-4 part 2 video.
Mjpg | Value for video format Motion JPEG.
Mpg1 | Value for video format MPEG-1 video.
Mss1 | Value for video format Windows Media Screen codec version 1.
Mss2 | Value for video format Windows Media Video 9 Screen codec.
NV11 | Value for video format NV11.
NV12 | Value for video format NV12.
NV21 | Value for video format NV21.
P010 | Value for video format P010.
P016 | Value for video format P016.
P210 | Value for video format P210.
P216 | Value for video format P216.
Rgb24 | Value for video format RGB, 24 bpp.
Rgb32 | Value for video format RGB, 32 bpp.
Rgb555 | Value for video format RGB 555, 16 bpp.
Rgb565 | Value for video format RGB 565, 16 bpp.
Rgb8 | Value for video format RGB, 8bpp.
Unknown | Value for unknown video format.
Uyvy | Value for video format UYVY.
V210 | Value for video format V210.
V216 | Value for video format V216.
V410 | Value for video format V40.
Wmv1 | Value for video format Windows Media Video codec version 7.
Wmv2 | Value for video format Windows Media Video 8 codec.
Wmv3 | Value for video format Windows Media Video 9 codec.
Wvc1 | Value for video format SMPTE 421M ("VC-1").
Y210 | Value for video format Y210.
Y216 | Value for video format Y216.
Y410 | Value for video format Y40.
Y416 | Value for video format Y416.
Y41P | Value for video format Y41P.
Y41T | Value for video format Y41T.
Y42T | Value for video format Y42T.
YV12 | Value for video format YV12.
Yuy2 | Value for video format YUY2.
Yvu9 | Value for video format YVU9.
Yvyu | Value for video format YVYU.


NVideoFormat Class Members

NVideoFormat Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NMediaFormat Class
Show:
No members matching the current filter
Name | Description
Equals | Checks whether the current media format equal the other media format.
GetHashCode | Gets the hash code.
IsCompatibleWith | Checks if media format is compatible with other media format.
NVideoFormat Class
Name | Description
MediaSubtypeToString | Creates media subtype representing string.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NExpandableObject Class
Show:
No members matching the current filter
Name | Description
NativeType | Defines the native type of the object.
Properties | Gets the property bag of the expandable object.
NMediaFormat Class
Show:
No members matching the current filter
Name | Description
MediaSubtype | Gets or sets media subtype from/for specified media format.
MediaType | Gets or sets media type from/for specified NMediaFormat.
NativeType | Defines the native type of the object.
NVideoFormat Class
Name | Description
FrameRate | Gets or sets video format frame rate.
Height | Gets or sets video format frame height.
InterlaceMode | Gets or sets video format interlace mode.
LongStride | Gets or sets stride for specified video format.
NativeStide | Gets or sets pointer to native stride of video.
NativeType | Defines the native type of the object.
PixelAspectRatio | Gets or sets video format pixel aspect ratio.
Stride | Gets or sets stride for specified video format.
Width | Gets or sets video format frame width.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NVideoFormat Class
Name | Description
AI44 | Value for video format AI44.
Argb32 | Value for video format RGB, 32 bpp with alpha channel.
Ayuv | Value for video format AYUV.
DV25 | Value for video format DVCPRO 25 (525-60 or 625-50).
DV50 | Value for video format DVCPRO 50 (525-60 or 625-50).
DX50 | Value for video format DX50.
Dvc | Value for video format DVC/DV Video.
Dvh1 | Value for video format DVC/DV Video.
Dvhd | Value for video format HD-DVCR (1125-60 or 1250-50).
Dvsd | Value for video format SDL-DVCR (525-60 or 625-50).
Dvsl | Value for video format SD-DVCR (525-60 or 625-50).
H264 | Value for video format H.264.
I420 | Value for video format I420.
Iyuv | Value for video format IYUV.
L16 | Value for video format L16.
L8 | Value for video format L8.
M4S2 | Value for video format MPEG-4 part 2 video.
MP43 | Value for video format Microsoft MPEG 4 codec version 3.
MP4S | Value for video format ISO MPEG 4 codec version 1.
MP4V | Value for video format MPEG-4 part 2 video.
Mjpg | Value for video format Motion JPEG.
Mpg1 | Value for video format MPEG-1 video.
Mss1 | Value for video format Windows Media Screen codec version 1.
Mss2 | Value for video format Windows Media Video 9 Screen codec.
NV11 | Value for video format NV11.
NV12 | Value for video format NV12.
NV21 | Value for video format NV21.
P010 | Value for video format P010.
P016 | Value for video format P016.
P210 | Value for video format P210.
P216 | Value for video format P216.
Rgb24 | Value for video format RGB, 24 bpp.
Rgb32 | Value for video format RGB, 32 bpp.
Rgb555 | Value for video format RGB 555, 16 bpp.
Rgb565 | Value for video format RGB 565, 16 bpp.
Rgb8 | Value for video format RGB, 8bpp.
Unknown | Value for unknown video format.
Uyvy | Value for video format UYVY.
V210 | Value for video format V210.
V216 | Value for video format V216.
V410 | Value for video format V40.
Wmv1 | Value for video format Windows Media Video codec version 7.
Wmv2 | Value for video format Windows Media Video 8 codec.
Wmv3 | Value for video format Windows Media Video 9 codec.
Wvc1 | Value for video format SMPTE 421M ("VC-1").
Y210 | Value for video format Y210.
Y216 | Value for video format Y216.
Y410 | Value for video format Y40.
Y416 | Value for video format Y416.
Y41P | Value for video format Y41P.
Y41T | Value for video format Y41T.
Y42T | Value for video format Y42T.
YV12 | Value for video format YV12.
Yuy2 | Value for video format YUY2.
Yvu9 | Value for video format YVU9.
Yvyu | Value for video format YVYU.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
NMediaFormat Operators
NMediaFormat Class
Show:
No members matching the current filter
Name | Description
!= | The inequality operator used to check if specified operands are not equal.
== | Equality operator used to check if specified operands are equal.
Methods
NVideoFormat Class
Name | Description
NVideoFormat | Default NVideoFormat constructor. NVideoFormat object can be constructed to setup video device in user defined format.


NVideoFormat Class Methods

NVideoFormat Class Methods
Legend
Methods
NVideoFormat Class
Name | Description
NVideoFormat | Default NVideoFormat constructor. NVideoFormat object can be constructed to setup video device in user defined format.


NDisposable Methods

NDisposable Methods
Legend
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NMediaFormat Class
Show:
No members matching the current filter
Name | Description
Equals | Checks whether the current media format equal the other media format.
GetHashCode | Gets the hash code.
IsCompatibleWith | Checks if media format is compatible with other media format.
NVideoFormat Class
Name | Description
MediaSubtypeToString | Creates media subtype representing string.


NMediaFormat Operators

NMediaFormat Operators
Legend
NMediaFormat Operators
NMediaFormat Class
Show:
No members matching the current filter
Name | Description
!= | The inequality operator used to check if specified operands are not equal.
== | Equality operator used to check if specified operands are equal.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NExpandableObject Class
Show:
No members matching the current filter
Name | Description
NativeType | Defines the native type of the object.
Properties | Gets the property bag of the expandable object.
NMediaFormat Class
Show:
No members matching the current filter
Name | Description
MediaSubtype | Gets or sets media subtype from/for specified media format.
MediaType | Gets or sets media type from/for specified NMediaFormat.
NativeType | Defines the native type of the object.
NVideoFormat Class
Name | Description
FrameRate | Gets or sets video format frame rate.
Height | Gets or sets video format frame height.
InterlaceMode | Gets or sets video format interlace mode.
LongStride | Gets or sets stride for specified video format.
NativeStide | Gets or sets pointer to native stride of video.
NativeType | Defines the native type of the object.
PixelAspectRatio | Gets or sets video format pixel aspect ratio.
Stride | Gets or sets stride for specified video format.
Width | Gets or sets video format frame width.


Neurotec.Plugins Namespace Classes

Neurotec.Plugins Namespace Classes
Legend
Classes
Name | Description
NPlugin | Plug-in management framework for use in other Neurotechnology components.
NPluginManager | Provides functions for working with plugins.
NPluginManagerPluginEventArgs | Base class for holding NPluginManager events data.
NPluginModule | The module providing one or more plugins. Provides methods to retrieve information about plugins.


Neurotec.Plugins Namespace Structs, Records, Enums

Neurotec.Plugins Namespace Structs, Records, Enums
Legend
Structs, Records, Enums
Name | Description
NPluginState | Enumerates NPlugin state values. The plugin state show how much of initialization the plugin has performed and can be used to identify common problems of plugin loading.


NPlugin Class Members

NPlugin Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NPlugin Class
Name | Description
Disable | Disables NPlugin
Enable | Enables NPlugin.
Plug | Plugs specified plug-in to the system.
Unplug | Unplugs specified plug-in from the system.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NPlugin Class
Name | Description
Error | Gets NPlugin error.
FileName | Gets plug-in library name.
LoadTime | Gets plug-in load time.
Module | Gets NPluginModule object.
NPluginStateNativeType | Defines the native type of the plugin state.
NativeType | Defines the native type of the object.
Owner | Gets the manager of the plugin.
PlugTime | Gets plug-in plug time.
SelectedInterfaceVersion | Gets current version of plugin interface.
State | Gets the state of specified plugin.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.


NDisposable Methods

NDisposable Methods
Legend
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NPlugin Class
Name | Description
Disable | Disables NPlugin
Enable | Enables NPlugin.
Plug | Plugs specified plug-in to the system.
Unplug | Unplugs specified plug-in from the system.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NPlugin Class
Name | Description
Error | Gets NPlugin error.
FileName | Gets plug-in library name.
LoadTime | Gets plug-in load time.
Module | Gets NPluginModule object.
NPluginStateNativeType | Defines the native type of the plugin state.
NativeType | Defines the native type of the object.
Owner | Gets the manager of the plugin.
PlugTime | Gets plug-in plug time.
SelectedInterfaceVersion | Gets current version of plugin interface.
State | Gets the state of specified plugin.


NPluginManager Classes

NPluginManager Classes
Legend
NPluginManager Classes
NPluginManager Class
Name | Description
DisabledPluginCollection | Represents collection of plugin names for plugins that will be disabled.
PluginCollection | Represents collection of plugins.


NPluginManager Class Members

NPluginManager Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NPluginManager Class
Name | Description
EnsurePluginSearchPerformed | Checks if initial plugin search was performed and if not calls Refresh
GetInstances | Gets instance of the objects.
GetInterfaceVersions | Returns the range of supported interface versions by specified NPluginManager.
PlugAll | Plugs all plugins into the system.
Refresh | Refreshes plugins list
UnplugAll | Unplugs all plugins.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NPluginManager Class
Name | Description
AllowsUnplug | Checks whether PlugAll and UnplugAll methods work
DisabledPlugins | Gets disabled plugins collection.
InterfaceType | Gets NPluginManager interface type name.
NativeType | Defines the native type of the object.
PluginSearchPath | Gets or sets plugins and its dependencies search path.
Plugins | Gets collection of all plugins in NPluginManager.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
NPluginManager Classes
NPluginManager Class
Name | Description
DisabledPluginCollection | Represents collection of plugin names for plugins that will be disabled.
PluginCollection | Represents collection of plugins.


NDisposable Methods

NDisposable Methods
Legend
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NPluginManager Class
Name | Description
EnsurePluginSearchPerformed | Checks if initial plugin search was performed and if not calls Refresh
GetInstances | Gets instance of the objects.
GetInterfaceVersions | Returns the range of supported interface versions by specified NPluginManager.
PlugAll | Plugs all plugins into the system.
Refresh | Refreshes plugins list
UnplugAll | Unplugs all plugins.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NPluginManager Class
Name | Description
AllowsUnplug | Checks whether PlugAll and UnplugAll methods work
DisabledPlugins | Gets disabled plugins collection.
InterfaceType | Gets NPluginManager interface type name.
NativeType | Defines the native type of the object.
PluginSearchPath | Gets or sets plugins and its dependencies search path.
Plugins | Gets collection of all plugins in NPluginManager.


NPluginManager.PluginCollection Class Members

NPluginManager.PluginCollection Class Members
Legend
Members
PluginCollection Methods
Name | Description
Add | Adds plugin and its dependencies (if exist) from specified directory.
Contains | Checks if plugins collection contains a specified plugin.
IndexOf | Retrieves the index of the plugin specified by name.
this | Retrieves a plugin specified by name.


PluginCollection Methods

PluginCollection Methods
Legend
PluginCollection Methods
Name | Description
Add | Adds plugin and its dependencies (if exist) from specified directory.
Contains | Checks if plugins collection contains a specified plugin.
IndexOf | Retrieves the index of the plugin specified by name.
this | Retrieves a plugin specified by name.


NPluginManagerPluginEventArgs Class Members

NPluginManagerPluginEventArgs Class Members
Legend
Members
Methods
Name | Description
NPluginManagerPluginEventArgs | Plugin constructor.
NPluginManagerPluginEventArgs Properties
Name | Description
Plugin | Gets Plugin associated with event raised by PluginManager.


NPluginManagerPluginEventArgs Class Methods

NPluginManagerPluginEventArgs Class Methods
Legend
Methods
Name | Description
NPluginManagerPluginEventArgs | Plugin constructor.


NPluginManagerPluginEventArgs Properties

NPluginManagerPluginEventArgs Properties
Legend
NPluginManagerPluginEventArgs Properties
Name | Description
Plugin | Gets Plugin associated with event raised by PluginManager.


NPluginModule Class Members

NPluginModule Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NModule Class
Show:
No members matching the current filter
Name | Description
CheckInit | Checks whether the current module is initialized and throws and exception if it is not.
CreateInstance | Creates a new instance of the specified module.
GetDependences | Retrieves dependencies of the module.
GetLoadedModules | Gets all the loaded modules that are part of this assembly.
GetType | Retrieves the NType object from module specified by name.
LoadFromFile | Loads module from the specified file.
NPluginModule Class
Name | Description
GetInterfaceVersions | Returns the range of supported interface versions by current NPluginModule object.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NModule Class
Show:
No members matching the current filter
Name | Description
Activated | Checks if the module is registered.
Company | Retrieves company name.
Copyright | Retrieves copyright notice of this module.
DefinedTypes | Retrieves all defined types from the specified module.
FileName | Retrieves the name of the file the specified module was created from.
Id | Gets or sets the ID of the module.
NModuleOptionsNativeType | Defines the native type of the module options.
Name | Retrieves module name.
NativeId | Gets or sets the native ID of the specified module.
NativeType | Defines the native type of the object.
Options | Retrieves module options.
Product | Retrieves product name.
Title | Retrieves module's title.
Version | Retrieves module version number.
VersionBuild | Retrieves the build of the current version.
VersionMajor | Retrieves the major version value.
VersionMinor | Retrieves the minor version value.
VersionRevision | Retrieves revision of the current version.
NPluginModule Class
Name | Description
IncompatiblePlugins | Gets the list of incompatible plugins.
InterfaceType | Gets plugin interface type name.
NativeType | Defines the native type of the object.
PluginName | Gets plugin name.
Priority | Gets plugin priority over other plugins.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Methods
NModule Class
Show:
No members matching the current filter
Name | Description
NModule | Initializes a new instance of NModule class.
NPluginModule Class
Name | Description
NPluginModule | Creates a new instance of NPluginModule class.


NPluginModule Class Methods

NPluginModule Class Methods
Legend
Methods
NModule Class
Show:
No members matching the current filter
Name | Description
NModule | Initializes a new instance of NModule class.
NPluginModule Class
Name | Description
NPluginModule | Creates a new instance of NPluginModule class.


NDisposable Methods

NDisposable Methods
Legend
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NModule Class
Show:
No members matching the current filter
Name | Description
CheckInit | Checks whether the current module is initialized and throws and exception if it is not.
CreateInstance | Creates a new instance of the specified module.
GetDependences | Retrieves dependencies of the module.
GetLoadedModules | Gets all the loaded modules that are part of this assembly.
GetType | Retrieves the NType object from module specified by name.
LoadFromFile | Loads module from the specified file.
NPluginModule Class
Name | Description
GetInterfaceVersions | Returns the range of supported interface versions by current NPluginModule object.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NModule Class
Show:
No members matching the current filter
Name | Description
Activated | Checks if the module is registered.
Company | Retrieves company name.
Copyright | Retrieves copyright notice of this module.
DefinedTypes | Retrieves all defined types from the specified module.
FileName | Retrieves the name of the file the specified module was created from.
Id | Gets or sets the ID of the module.
NModuleOptionsNativeType | Defines the native type of the module options.
Name | Retrieves module name.
NativeId | Gets or sets the native ID of the specified module.
NativeType | Defines the native type of the object.
Options | Retrieves module options.
Product | Retrieves product name.
Title | Retrieves module's title.
Version | Retrieves module version number.
VersionBuild | Retrieves the build of the current version.
VersionMajor | Retrieves the major version value.
VersionMinor | Retrieves the minor version value.
VersionRevision | Retrieves revision of the current version.
NPluginModule Class
Name | Description
IncompatiblePlugins | Gets the list of incompatible plugins.
InterfaceType | Gets plugin interface type name.
NativeType | Defines the native type of the object.
PluginName | Gets plugin name.
Priority | Gets plugin priority over other plugins.


Neurotec.Plugins.ComponentModel Namespace Classes

Neurotec.Plugins.ComponentModel Namespace Classes
Legend
Classes
Name | Description
NPluginEventDescriptor | Provides functionality for creating plugin event descriptors.
NPluginMethodDescriptor | Provides functionality for creating plugin method descriptors.
NPluginPropertyDescriptor | Provides functionality for creating plugin property descriptors.


NPluginEventDescriptor Class Members

NPluginEventDescriptor Class Members
Legend
Members
NPluginEventDescriptor Properties
Name | Description
NativeType | Defines the native type of the object.


NPluginEventDescriptor Properties

NPluginEventDescriptor Properties
Legend
NPluginEventDescriptor Properties
Name | Description
NativeType | Defines the native type of the object.


NPluginMethodDescriptor Class Members

NPluginMethodDescriptor Class Members
Legend
Members
NPluginMethodDescriptor Properties
Name | Description
NativeType | Defines the native type of the object.


NPluginMethodDescriptor Properties

NPluginMethodDescriptor Properties
Legend
NPluginMethodDescriptor Properties
Name | Description
NativeType | Defines the native type of the object.


NPluginPropertyDescriptor Class Members

NPluginPropertyDescriptor Class Members
Legend
Members
NPluginPropertyDescriptor Properties
Name | Description
NativeType | Defines the native type of the object.


NPluginPropertyDescriptor Properties

NPluginPropertyDescriptor Properties
Legend
NPluginPropertyDescriptor Properties
Name | Description
NativeType | Defines the native type of the object.


Neurotec.Reflection Namespace Classes

Neurotec.Reflection Namespace Classes
Legend
Classes
Name | Description
NArrayCollectionInfo | Provides functionality to retrieve information about array collections.
NCollectionInfo | Provides functionality to retrieve information about collections.
NConstantInfo | Provides functionality to retrieve information about constants.
NDictionaryInfo | Provides functionality to retrieve information about dictionaries.
NEnumConstantInfo | Provides functionality to retrieve information about enumeration constants.
NEventInfo | Provides functionality to retrieve information about events.
NMemberInfo | Provides functionality to retrieve information about class members.
NMethodInfo | Provides functions for getting information about property.
NObjectPartInfo | Provides functionality to retrieve information about object parts.
NParameterInfo | Provides functions for getting information about parameter.
NPropertyInfo | Provides functionality to retrieve and change information about properties.


NObjectPartInfo Classes

NObjectPartInfo Classes
Legend
NObjectPartInfo Classes
NObjectPartInfo Class
Name | Description
DeclaredConstantCollection | Collection of declared constants.
DeclaredEventCollection | Collection of declared events.
DeclaredMethodCollection | Collection of declared methods.
DeclaredPropertyCollection | Collection of declared properties.
NArrayCollectionInfo Class
Name | Description
ItemStdValueCollection | A collection of standard item values.


NArrayCollectionInfo Class Members

NArrayCollectionInfo Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NObjectPartInfo Class
Show:
No members matching the current filter
Name | Description
GetDeclaredConstant | Retrieves the specified declared constant.
GetDeclaredEvent | Retrieves the specified declared event.
GetDeclaredMethod | Retrieves the specified declared method.
GetDeclaredMethods | Retrieves the specified declared methods.
GetDeclaredProperty | Retrieves the specified declared property.
GetObjectPart | Retrieves the part of the specified object.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NMemberInfo Class
Show:
No members matching the current filter
Name | Description
Attributes | Gets member attributes.
DeclaringType | Gets the declaring type of the member.
Name | Gets member name.
NativeType | Defines the native type of the object.
NObjectPartInfo Class
Show:
No members matching the current filter
Name | Description
DeclaredConstants | Retrieves the collection of declared constants.
DeclaredEvents | Retrieves the collection of declared events.
DeclaredMethods | Retrieves the collection of declared methods.
DeclaredProperties | Retrieves the collection of declared proeprties.
NativeType | Defines the native type of the object.
PropertyName | Retrieves the name of an object part property.
NArrayCollectionInfo Class
Name | Description
AddMethod | Retrieves the method which adds an item to an array collection.
AddRangeMethod | Retrieves the method which adds a range of items to an array collection.
BaseCollection | Retrieves the base collection of the array collection.
ClearMethod | Retrieves the method which clears the array collection.
GetCountMethod | Retrieves the method which gets the number of items in the array collection.
GetMethod | Retrieves the method which gets an item in the array collection.
IndexOfMethod | Retrieves the method which gets an index of an item in the array collection.
InsertMethod | Retrieves the method which adds an item to an array collection at a specific index.
InsertRangeMethod | Retrieves the method which adds a range of items to an array collection at a specific index.
ItemAttributes | Retrieves the attributes of items in the array collection.
ItemFormat | Retrieves the type of items in the array collection.
ItemMaxValue | Retrieves the maximal item value.
ItemMinValue | Retrieves the minimal item value.
ItemStdValues | Retrieves the collection of standard item values.
ItemType | Retrieves the type of items in the array collection.
NativeType | Defines the native type of the object.
RemoveAtMethod | Retrieves the method which removes an item with specific index from an array collection.
RemoveMethod | Retrieves the method which removes an item from an array collection.
RemoveRangeMethod | Retrieves the method which removes a range of items from an array collection.
SetMethod | Retrieves the method which sets an item of the array collection.
ToArrayMethod | Retrieves the method which converts the array collection into a regular array.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
NObjectPartInfo Classes
NObjectPartInfo Class
Name | Description
DeclaredConstantCollection | Collection of declared constants.
DeclaredEventCollection | Collection of declared events.
DeclaredMethodCollection | Collection of declared methods.
DeclaredPropertyCollection | Collection of declared properties.
NArrayCollectionInfo Class
Name | Description
ItemStdValueCollection | A collection of standard item values.


NDisposable Methods

NDisposable Methods
Legend
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NObjectPartInfo Class
Show:
No members matching the current filter
Name | Description
GetDeclaredConstant | Retrieves the specified declared constant.
GetDeclaredEvent | Retrieves the specified declared event.
GetDeclaredMethod | Retrieves the specified declared method.
GetDeclaredMethods | Retrieves the specified declared methods.
GetDeclaredProperty | Retrieves the specified declared property.
GetObjectPart | Retrieves the part of the specified object.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NMemberInfo Class
Show:
No members matching the current filter
Name | Description
Attributes | Gets member attributes.
DeclaringType | Gets the declaring type of the member.
Name | Gets member name.
NativeType | Defines the native type of the object.
NObjectPartInfo Class
Show:
No members matching the current filter
Name | Description
DeclaredConstants | Retrieves the collection of declared constants.
DeclaredEvents | Retrieves the collection of declared events.
DeclaredMethods | Retrieves the collection of declared methods.
DeclaredProperties | Retrieves the collection of declared proeprties.
NativeType | Defines the native type of the object.
PropertyName | Retrieves the name of an object part property.
NArrayCollectionInfo Class
Name | Description
AddMethod | Retrieves the method which adds an item to an array collection.
AddRangeMethod | Retrieves the method which adds a range of items to an array collection.
BaseCollection | Retrieves the base collection of the array collection.
ClearMethod | Retrieves the method which clears the array collection.
GetCountMethod | Retrieves the method which gets the number of items in the array collection.
GetMethod | Retrieves the method which gets an item in the array collection.
IndexOfMethod | Retrieves the method which gets an index of an item in the array collection.
InsertMethod | Retrieves the method which adds an item to an array collection at a specific index.
InsertRangeMethod | Retrieves the method which adds a range of items to an array collection at a specific index.
ItemAttributes | Retrieves the attributes of items in the array collection.
ItemFormat | Retrieves the type of items in the array collection.
ItemMaxValue | Retrieves the maximal item value.
ItemMinValue | Retrieves the minimal item value.
ItemStdValues | Retrieves the collection of standard item values.
ItemType | Retrieves the type of items in the array collection.
NativeType | Defines the native type of the object.
RemoveAtMethod | Retrieves the method which removes an item with specific index from an array collection.
RemoveMethod | Retrieves the method which removes an item from an array collection.
RemoveRangeMethod | Retrieves the method which removes a range of items from an array collection.
SetMethod | Retrieves the method which sets an item of the array collection.
ToArrayMethod | Retrieves the method which converts the array collection into a regular array.


NObjectPartInfo Classes

NObjectPartInfo Classes
Legend
NObjectPartInfo Classes
NObjectPartInfo Class
Name | Description
DeclaredConstantCollection | Collection of declared constants.
DeclaredEventCollection | Collection of declared events.
DeclaredMethodCollection | Collection of declared methods.
DeclaredPropertyCollection | Collection of declared properties.
NCollectionInfo Class
Name | Description
ItemStdValueCollection | A collection of standard item values.


NCollectionInfo Class Members

NCollectionInfo Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NObjectPartInfo Class
Show:
No members matching the current filter
Name | Description
GetDeclaredConstant | Retrieves the specified declared constant.
GetDeclaredEvent | Retrieves the specified declared event.
GetDeclaredMethod | Retrieves the specified declared method.
GetDeclaredMethods | Retrieves the specified declared methods.
GetDeclaredProperty | Retrieves the specified declared property.
GetObjectPart | Retrieves the part of the specified object.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NMemberInfo Class
Show:
No members matching the current filter
Name | Description
Attributes | Gets member attributes.
DeclaringType | Gets the declaring type of the member.
Name | Gets member name.
NativeType | Defines the native type of the object.
NObjectPartInfo Class
Show:
No members matching the current filter
Name | Description
DeclaredConstants | Retrieves the collection of declared constants.
DeclaredEvents | Retrieves the collection of declared events.
DeclaredMethods | Retrieves the collection of declared methods.
DeclaredProperties | Retrieves the collection of declared proeprties.
NativeType | Defines the native type of the object.
PropertyName | Retrieves the name of an object part property.
NCollectionInfo Class
Name | Description
AddCollectionChangedCallbackMethod | Retrieves the method which adds a "collection changed" event callback to a collection.
AddCollectionChangedMethod | Retrieves the method which adds a "collection changed" event to a collection.
AddMethod | Retrieves the method which adds an item to a collection.
AddRangeMethod | Retrieves the method which adds a range of items to a collection.
ClearMethod | Retrieves the method which clears the collection.
GetCapacityMethod | Retrieves the method which gets the maximum number of items in the collection.
GetCountMethod | Retrieves the method which gets the number of items in the collection.
GetMethod | Retrieves the method which gets an item in the collection.
IndexOfMethod | Retrieves the method which gets an index of an item in the collection.
InsertMethod | Retrieves the method which adds an item to a collection at a specific index.
InsertRangeMethod | Retrieves the method which adds a range of items to a collection at a specific index.
ItemAttributes | Retrieves the attributes of items in the collection.
ItemFormat | Retrieves the type of items in the collection.
ItemMaxValue | Retrieves the maximal item value.
ItemMinValue | Retrieves the minimal item value.
ItemStdValues | Retrieves the collection of standard item values.
ItemType | Retrieves the type of items in the collection.
NativeType | Defines the native type of the object.
RemoveAtMethod | Retrieves the method which removes an item with specific index from a collection.
RemoveCollectionChangedCallbackMethod | Retrieves the method which removes a "collection changed" event callback from a collection.
RemoveCollectionChangedMethod | Retrieves the method which removes a "collection changed" event from a collection.
RemoveMethod | Retrieves the method which removes an item from a collection.
RemoveRangeMethod | Retrieves the method which removes a range of items from a collection.
SetCapacityMethod | Retrieves the method which sets the maximum number of items in the collection.
SetMethod | Retrieves the method which sets an item of the collection.
ToArrayMethod | Retrieves the method which converts the collection into a regular array.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
NObjectPartInfo Classes
NObjectPartInfo Class
Name | Description
DeclaredConstantCollection | Collection of declared constants.
DeclaredEventCollection | Collection of declared events.
DeclaredMethodCollection | Collection of declared methods.
DeclaredPropertyCollection | Collection of declared properties.
NCollectionInfo Class
Name | Description
ItemStdValueCollection | A collection of standard item values.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NMemberInfo Class
Show:
No members matching the current filter
Name | Description
Attributes | Gets member attributes.
DeclaringType | Gets the declaring type of the member.
Name | Gets member name.
NativeType | Defines the native type of the object.
NObjectPartInfo Class
Show:
No members matching the current filter
Name | Description
DeclaredConstants | Retrieves the collection of declared constants.
DeclaredEvents | Retrieves the collection of declared events.
DeclaredMethods | Retrieves the collection of declared methods.
DeclaredProperties | Retrieves the collection of declared proeprties.
NativeType | Defines the native type of the object.
PropertyName | Retrieves the name of an object part property.
NCollectionInfo Class
Name | Description
AddCollectionChangedCallbackMethod | Retrieves the method which adds a "collection changed" event callback to a collection.
AddCollectionChangedMethod | Retrieves the method which adds a "collection changed" event to a collection.
AddMethod | Retrieves the method which adds an item to a collection.
AddRangeMethod | Retrieves the method which adds a range of items to a collection.
ClearMethod | Retrieves the method which clears the collection.
GetCapacityMethod | Retrieves the method which gets the maximum number of items in the collection.
GetCountMethod | Retrieves the method which gets the number of items in the collection.
GetMethod | Retrieves the method which gets an item in the collection.
IndexOfMethod | Retrieves the method which gets an index of an item in the collection.
InsertMethod | Retrieves the method which adds an item to a collection at a specific index.
InsertRangeMethod | Retrieves the method which adds a range of items to a collection at a specific index.
ItemAttributes | Retrieves the attributes of items in the collection.
ItemFormat | Retrieves the type of items in the collection.
ItemMaxValue | Retrieves the maximal item value.
ItemMinValue | Retrieves the minimal item value.
ItemStdValues | Retrieves the collection of standard item values.
ItemType | Retrieves the type of items in the collection.
NativeType | Defines the native type of the object.
RemoveAtMethod | Retrieves the method which removes an item with specific index from a collection.
RemoveCollectionChangedCallbackMethod | Retrieves the method which removes a "collection changed" event callback from a collection.
RemoveCollectionChangedMethod | Retrieves the method which removes a "collection changed" event from a collection.
RemoveMethod | Retrieves the method which removes an item from a collection.
RemoveRangeMethod | Retrieves the method which removes a range of items from a collection.
SetCapacityMethod | Retrieves the method which sets the maximum number of items in the collection.
SetMethod | Retrieves the method which sets an item of the collection.
ToArrayMethod | Retrieves the method which converts the collection into a regular array.


NConstantInfo Class Members

NConstantInfo Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NMemberInfo Class
Show:
No members matching the current filter
Name | Description
Attributes | Gets member attributes.
DeclaringType | Gets the declaring type of the member.
Name | Gets member name.
NativeType | Defines the native type of the object.
NConstantInfo Class
Name | Description
ConstantType | Gets the type of the constant.
NativeType | Defines the native type of the object.
Value | Gets the value of the current constant.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NMemberInfo Class
Show:
No members matching the current filter
Name | Description
Attributes | Gets member attributes.
DeclaringType | Gets the declaring type of the member.
Name | Gets member name.
NativeType | Defines the native type of the object.
NConstantInfo Class
Name | Description
ConstantType | Gets the type of the constant.
NativeType | Defines the native type of the object.
Value | Gets the value of the current constant.


NObjectPartInfo Classes

NObjectPartInfo Classes
Legend
NObjectPartInfo Classes
NObjectPartInfo Class
Name | Description
DeclaredConstantCollection | Collection of declared constants.
DeclaredEventCollection | Collection of declared events.
DeclaredMethodCollection | Collection of declared methods.
DeclaredPropertyCollection | Collection of declared properties.
NDictionaryInfo Class
Name | Description
KeyStdValueCollection | A collection of standard item key values.
ValueStdValueCollection | A collection of standard item values.


NDictionaryInfo Class Members

NDictionaryInfo Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NObjectPartInfo Class
Show:
No members matching the current filter
Name | Description
GetDeclaredConstant | Retrieves the specified declared constant.
GetDeclaredEvent | Retrieves the specified declared event.
GetDeclaredMethod | Retrieves the specified declared method.
GetDeclaredMethods | Retrieves the specified declared methods.
GetDeclaredProperty | Retrieves the specified declared property.
GetObjectPart | Retrieves the part of the specified object.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NMemberInfo Class
Show:
No members matching the current filter
Name | Description
Attributes | Gets member attributes.
DeclaringType | Gets the declaring type of the member.
Name | Gets member name.
NativeType | Defines the native type of the object.
NObjectPartInfo Class
Show:
No members matching the current filter
Name | Description
DeclaredConstants | Retrieves the collection of declared constants.
DeclaredEvents | Retrieves the collection of declared events.
DeclaredMethods | Retrieves the collection of declared methods.
DeclaredProperties | Retrieves the collection of declared proeprties.
NativeType | Defines the native type of the object.
PropertyName | Retrieves the name of an object part property.
NDictionaryInfo Class
Name | Description
AddCollectionChangedCallbackMethod | Retrieves the method which adds a "collection changed" event callback to a dictionary.
AddCollectionChangedMethod | Retrieves the method which adds a "collection changed" event to a dictionary.
AddMethod | Retrieves the method which adds an item to a dictionary.
AddPairMethod | Retrieves the method which adds a key-value pair to a dictionary.
ClearMethod | Retrieves the method which clears the dictionary.
ContainsMethod | Retrieves the method which checks whether a dictionary contains a specific value.
GetAtMethod | Retrieves the method which gets an item in the dictionary specified by index.
GetCountMethod | Retrieves the method which gets the number of items in the dictionary.
GetKeyMethod | Retrieves the method which gets a key of an item in the dictionary.
GetMethod | Retrieves the method which gets an item in the dictionary.
GetValueMethod | Retrieves the method which gets a value of an item in the dictionary.
ItemAttributes | Retrieves the attributes of items in the dictionary.
ItemType | Retrieves the type of items in the dictionary.
KeyAttributes | Retrieves the attributes of item keys in the dictionary.
KeyFormat | Retrieves the type of item keys in the dictionary.
KeyMaxValue | Retrieves the maximal item key value.
KeyMinValue | Retrieves the minimal item key value.
KeyStdValues | Retrieves the collection of standard item keys.
KeyType | Retrieves the type of item keys in the dictionary.
NativeType | Defines the native type of the object.
RemoveAtMethod | Retrieves the method which removes an item with specific index from the dictionary.
RemoveCollectionChangedCallbackMethod | Retrieves the method which removes a "collection changed" event callback from a dictionary.
RemoveCollectionChangedMethod | Retrieves the method which removes a "collection changed" event from a dictionary.
RemoveMethod | Retrieves the method which removes an item from a dictionary.
SetMethod | Retrieves the method which sets a value of an item in the dictionary.
ToArrayMethod | Retrieves the method which converts the dictionary into an array.
ToKeyArrayMethod | Retrieves the method which converts the dictionary into an array of item keys.
ToValueArrayMethod | Retrieves the method which converts the dictionary into an array of item values.
TryGetMethod | Retrieves the method which gets an item in the dictionary and returns a Boolean value indicating success.
ValueAttributes | Retrieves the attributes of item values in the dictionary.
ValueFormat | Retrieves the type of item values in the dictionary.
ValueMaxValue | Retrieves the maximal item value.
ValueMinValue | Retrieves the minimal item value.
ValueStdValues | Retrieves the collection of standard item values.
ValueType | Retrieves the type of item values in the dictionary.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
NObjectPartInfo Classes
NObjectPartInfo Class
Name | Description
DeclaredConstantCollection | Collection of declared constants.
DeclaredEventCollection | Collection of declared events.
DeclaredMethodCollection | Collection of declared methods.
DeclaredPropertyCollection | Collection of declared properties.
NDictionaryInfo Class
Name | Description
KeyStdValueCollection | A collection of standard item key values.
ValueStdValueCollection | A collection of standard item values.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NMemberInfo Class
Show:
No members matching the current filter
Name | Description
Attributes | Gets member attributes.
DeclaringType | Gets the declaring type of the member.
Name | Gets member name.
NativeType | Defines the native type of the object.
NObjectPartInfo Class
Show:
No members matching the current filter
Name | Description
DeclaredConstants | Retrieves the collection of declared constants.
DeclaredEvents | Retrieves the collection of declared events.
DeclaredMethods | Retrieves the collection of declared methods.
DeclaredProperties | Retrieves the collection of declared proeprties.
NativeType | Defines the native type of the object.
PropertyName | Retrieves the name of an object part property.
NDictionaryInfo Class
Name | Description
AddCollectionChangedCallbackMethod | Retrieves the method which adds a "collection changed" event callback to a dictionary.
AddCollectionChangedMethod | Retrieves the method which adds a "collection changed" event to a dictionary.
AddMethod | Retrieves the method which adds an item to a dictionary.
AddPairMethod | Retrieves the method which adds a key-value pair to a dictionary.
ClearMethod | Retrieves the method which clears the dictionary.
ContainsMethod | Retrieves the method which checks whether a dictionary contains a specific value.
GetAtMethod | Retrieves the method which gets an item in the dictionary specified by index.
GetCountMethod | Retrieves the method which gets the number of items in the dictionary.
GetKeyMethod | Retrieves the method which gets a key of an item in the dictionary.
GetMethod | Retrieves the method which gets an item in the dictionary.
GetValueMethod | Retrieves the method which gets a value of an item in the dictionary.
ItemAttributes | Retrieves the attributes of items in the dictionary.
ItemType | Retrieves the type of items in the dictionary.
KeyAttributes | Retrieves the attributes of item keys in the dictionary.
KeyFormat | Retrieves the type of item keys in the dictionary.
KeyMaxValue | Retrieves the maximal item key value.
KeyMinValue | Retrieves the minimal item key value.
KeyStdValues | Retrieves the collection of standard item keys.
KeyType | Retrieves the type of item keys in the dictionary.
NativeType | Defines the native type of the object.
RemoveAtMethod | Retrieves the method which removes an item with specific index from the dictionary.
RemoveCollectionChangedCallbackMethod | Retrieves the method which removes a "collection changed" event callback from a dictionary.
RemoveCollectionChangedMethod | Retrieves the method which removes a "collection changed" event from a dictionary.
RemoveMethod | Retrieves the method which removes an item from a dictionary.
SetMethod | Retrieves the method which sets a value of an item in the dictionary.
ToArrayMethod | Retrieves the method which converts the dictionary into an array.
ToKeyArrayMethod | Retrieves the method which converts the dictionary into an array of item keys.
ToValueArrayMethod | Retrieves the method which converts the dictionary into an array of item values.
TryGetMethod | Retrieves the method which gets an item in the dictionary and returns a Boolean value indicating success.
ValueAttributes | Retrieves the attributes of item values in the dictionary.
ValueFormat | Retrieves the type of item values in the dictionary.
ValueMaxValue | Retrieves the maximal item value.
ValueMinValue | Retrieves the minimal item value.
ValueStdValues | Retrieves the collection of standard item values.
ValueType | Retrieves the type of item values in the dictionary.


NEnumConstantInfo Class Members

NEnumConstantInfo Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NMemberInfo Class
Show:
No members matching the current filter
Name | Description
Attributes | Gets member attributes.
DeclaringType | Gets the declaring type of the member.
Name | Gets member name.
NativeType | Defines the native type of the object.
NEnumConstantInfo Class
Name | Description
NativeType | Defines the native type of the object.
Value | Gets the value of the current enum constant.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NMemberInfo Class
Show:
No members matching the current filter
Name | Description
Attributes | Gets member attributes.
DeclaringType | Gets the declaring type of the member.
Name | Gets member name.
NativeType | Defines the native type of the object.
NEnumConstantInfo Class
Name | Description
NativeType | Defines the native type of the object.
Value | Gets the value of the current enum constant.


NEventInfo Class Members

NEventInfo Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NEventInfo Class
Name | Description
AddHandler | Binds the event to the object.
RemoveHandler | Unbinds the delegate from the object so that the delegate will no longer receive events from the object.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NMemberInfo Class
Show:
No members matching the current filter
Name | Description
Attributes | Gets member attributes.
DeclaringType | Gets the declaring type of the member.
Name | Gets member name.
NativeType | Defines the native type of the object.
NEventInfo Class
Name | Description
AddCallbackMethod | Retrieves the method which adds a callback to the event.
AddMethod | Retrieves a method which adds an event.
EventType | Gets the type of the event.
NativeType | Defines the native type of the object.
RemoveCallbackMethod | Retrieves the method which removes a callback from the event.
RemoveMethod | Retrieves a method which removes an event.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.


NDisposable Methods

NDisposable Methods
Legend
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NEventInfo Class
Name | Description
AddHandler | Binds the event to the object.
RemoveHandler | Unbinds the delegate from the object so that the delegate will no longer receive events from the object.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NMemberInfo Class
Show:
No members matching the current filter
Name | Description
Attributes | Gets member attributes.
DeclaringType | Gets the declaring type of the member.
Name | Gets member name.
NativeType | Defines the native type of the object.
NEventInfo Class
Name | Description
AddCallbackMethod | Retrieves the method which adds a callback to the event.
AddMethod | Retrieves a method which adds an event.
EventType | Gets the type of the event.
NativeType | Defines the native type of the object.
RemoveCallbackMethod | Retrieves the method which removes a callback from the event.
RemoveMethod | Retrieves a method which removes an event.


NMemberInfo Class Members

NMemberInfo Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NMemberInfo Class
Name | Description
Attributes | Gets member attributes.
DeclaringType | Gets the declaring type of the member.
Name | Gets member name.
NativeType | Defines the native type of the object.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NMemberInfo Class
Name | Description
Attributes | Gets member attributes.
DeclaringType | Gets the declaring type of the member.
Name | Gets member name.
NativeType | Defines the native type of the object.


NMethodInfo Classes

NMethodInfo Classes
Legend
NMethodInfo Classes
NMethodInfo Class
Name | Description
ParameterCollection | Parameters collection of the invoked method.


NMethodInfo Class Members

NMethodInfo Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NMethodInfo Class
Name | Description
Invoke | Invokes the specified object with property bag.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NMemberInfo Class
Show:
No members matching the current filter
Name | Description
Attributes | Gets member attributes.
DeclaringType | Gets the declaring type of the member.
Name | Gets member name.
NativeType | Defines the native type of the object.
NMethodInfo Class
Name | Description
NativeName | Gets the native name of the specified method.
NativeType | Defines the native type of the object.
Parameters | Gets all parameters of the specified method.
ReturnParameter | Gets the return parameter of the invoked method.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
NMethodInfo Classes
NMethodInfo Class
Name | Description
ParameterCollection | Parameters collection of the invoked method.


NDisposable Methods

NDisposable Methods
Legend
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NMethodInfo Class
Name | Description
Invoke | Invokes the specified object with property bag.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NMemberInfo Class
Show:
No members matching the current filter
Name | Description
Attributes | Gets member attributes.
DeclaringType | Gets the declaring type of the member.
Name | Gets member name.
NativeType | Defines the native type of the object.
NMethodInfo Class
Name | Description
NativeName | Gets the native name of the specified method.
NativeType | Defines the native type of the object.
Parameters | Gets all parameters of the specified method.
ReturnParameter | Gets the return parameter of the invoked method.


NObjectPartInfo Classes

NObjectPartInfo Classes
Legend
NObjectPartInfo Classes
NObjectPartInfo Class
Name | Description
DeclaredConstantCollection | Collection of declared constants.
DeclaredEventCollection | Collection of declared events.
DeclaredMethodCollection | Collection of declared methods.
DeclaredPropertyCollection | Collection of declared properties.


NObjectPartInfo Class Members

NObjectPartInfo Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NObjectPartInfo Class
Name | Description
GetDeclaredConstant | Retrieves the specified declared constant.
GetDeclaredEvent | Retrieves the specified declared event.
GetDeclaredMethod | Retrieves the specified declared method.
GetDeclaredMethods | Retrieves the specified declared methods.
GetDeclaredProperty | Retrieves the specified declared property.
GetObjectPart | Retrieves the part of the specified object.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NMemberInfo Class
Show:
No members matching the current filter
Name | Description
Attributes | Gets member attributes.
DeclaringType | Gets the declaring type of the member.
Name | Gets member name.
NativeType | Defines the native type of the object.
NObjectPartInfo Class
Name | Description
DeclaredConstants | Retrieves the collection of declared constants.
DeclaredEvents | Retrieves the collection of declared events.
DeclaredMethods | Retrieves the collection of declared methods.
DeclaredProperties | Retrieves the collection of declared proeprties.
NativeType | Defines the native type of the object.
PropertyName | Retrieves the name of an object part property.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
NObjectPartInfo Classes
NObjectPartInfo Class
Name | Description
DeclaredConstantCollection | Collection of declared constants.
DeclaredEventCollection | Collection of declared events.
DeclaredMethodCollection | Collection of declared methods.
DeclaredPropertyCollection | Collection of declared properties.


NDisposable Methods

NDisposable Methods
Legend
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NObjectPartInfo Class
Name | Description
GetDeclaredConstant | Retrieves the specified declared constant.
GetDeclaredEvent | Retrieves the specified declared event.
GetDeclaredMethod | Retrieves the specified declared method.
GetDeclaredMethods | Retrieves the specified declared methods.
GetDeclaredProperty | Retrieves the specified declared property.
GetObjectPart | Retrieves the part of the specified object.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NMemberInfo Class
Show:
No members matching the current filter
Name | Description
Attributes | Gets member attributes.
DeclaringType | Gets the declaring type of the member.
Name | Gets member name.
NativeType | Defines the native type of the object.
NObjectPartInfo Class
Name | Description
DeclaredConstants | Retrieves the collection of declared constants.
DeclaredEvents | Retrieves the collection of declared events.
DeclaredMethods | Retrieves the collection of declared methods.
DeclaredProperties | Retrieves the collection of declared proeprties.
NativeType | Defines the native type of the object.
PropertyName | Retrieves the name of an object part property.


NParameterInfo Classes

NParameterInfo Classes
Legend
NParameterInfo Classes
NParameterInfo Class
Name | Description
StdValueCollection | Represents an array of standard parameter values.


NParameterInfo Class Members

NParameterInfo Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NParameterInfo Class
Name | Description
Attributes | Gets parameter attributes.
DefaultValue | Gets the default value of the current parameter.
Format | Gets the format of the current parameter.
MaxValue | Gets the maximum value of the current parameter.
MinValue | Gets the minimum value of the current parameter.
Name | Gets parameter name.
NativeType | Defines the native type of the object.
ParameterType | Gets the type of the parameter.
StdValues | Gets the collection of standard values for the current parameter.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
NParameterInfo Classes
NParameterInfo Class
Name | Description
StdValueCollection | Represents an array of standard parameter values.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NParameterInfo Class
Name | Description
Attributes | Gets parameter attributes.
DefaultValue | Gets the default value of the current parameter.
Format | Gets the format of the current parameter.
MaxValue | Gets the maximum value of the current parameter.
MinValue | Gets the minimum value of the current parameter.
Name | Gets parameter name.
NativeType | Defines the native type of the object.
ParameterType | Gets the type of the parameter.
StdValues | Gets the collection of standard values for the current parameter.


NPropertyInfo Classes

NPropertyInfo Classes
Legend
NPropertyInfo Classes
NPropertyInfo Class
Name | Description
StdValueCollection | Represents an array of standard property values.


NPropertyInfo Class Members

NPropertyInfo Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NPropertyInfo Class
Name | Description
CanResetValue | Checks whether the value of the property can be reset.
GetValue | Retrieves the value of the component.
ResetValue | Resets the value of the specified property.
SetValue | Sets the value of the specified component.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NMemberInfo Class
Show:
No members matching the current filter
Name | Description
Attributes | Gets member attributes.
DeclaringType | Gets the declaring type of the member.
Name | Gets member name.
NativeType | Defines the native type of the object.
NPropertyInfo Class
Name | Description
DefaultValue | Gets the default value of the property.
Format | Gets the format of the property.
GetMethod | Retrieves the method which gets the value of the property.
MaxValue | Gets the maximum value of the property.
MinValue | Gets the minimum value of the property.
NativeType | Defines the native type of the object.
PropertyType | Gets the type of the property.
SetMethod | Retrieves the method which sets the value of the property.
StdValues | Gets the collection of standard values for the property.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
NPropertyInfo Classes
NPropertyInfo Class
Name | Description
StdValueCollection | Represents an array of standard property values.


NDisposable Methods

NDisposable Methods
Legend
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NPropertyInfo Class
Name | Description
CanResetValue | Checks whether the value of the property can be reset.
GetValue | Retrieves the value of the component.
ResetValue | Resets the value of the specified property.
SetValue | Sets the value of the specified component.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NMemberInfo Class
Show:
No members matching the current filter
Name | Description
Attributes | Gets member attributes.
DeclaringType | Gets the declaring type of the member.
Name | Gets member name.
NativeType | Defines the native type of the object.
NPropertyInfo Class
Name | Description
DefaultValue | Gets the default value of the property.
Format | Gets the format of the property.
GetMethod | Retrieves the method which gets the value of the property.
MaxValue | Gets the maximum value of the property.
MinValue | Gets the minimum value of the property.
NativeType | Defines the native type of the object.
PropertyType | Gets the type of the property.
SetMethod | Retrieves the method which sets the value of the property.
StdValues | Gets the collection of standard values for the property.


Neurotec.Surveillance Namespace Classes

Neurotec.Surveillance Namespace Classes
Legend
Classes
Name | Description
NClothingDetails | Represents subject's clothing and gender details.
NLicensePlate | Provides car's license plate recognition functionality.
NLicensePlateDetails | Represents car's license plate details.
NNameConfidencePair | Structure containing name and/or confidence values.
NSurveillance | Base Surveillance class.
NSurveillanceDetectionDetails | Represents surveillance detection details.
NSurveillanceDetectionResult | Represents object's detection result.
NSurveillanceEngine | Provides functionality for Surveillance engine.
NSurveillanceEventArgs | A class that is passed to event handler and through which event data can be accessed.
NSurveillanceEventDetails | A class that provides access to event details data.
NSurveillanceObjectColorDetails | Represents surveillance object color details.
NSurveillanceObjectDirectionDetails | Represents detected object direction details.
NSurveillanceObjectTypeDetails | Represents detected object type details.
NSurveillanceProgressEventArgs | Event arguments for progress callback.
NSurveillanceSource | Provides functions for managing Surveillance sources - cameras and video files.
NTrackingDetails | Represents objects tracking details.
NVehicleDetails | Represents vehicle details.
NsedMatchResult | Represents matching result.


Legend

Legend
Legend
Class
Structure
Enumeration


Neurotec.Surveillance Namespace Structs, Records, Enums

Neurotec.Surveillance Namespace Structs, Records, Enums
Legend
Structs, Records, Enums
Name | Description
NDetectorScaleCount | Enumerates detector scale count. Bigger values improves quality, but requires more processing power.
NGpuIndex | Enumerates GPU units by index.
NSurveillanceEventType | Enumeration type for different Surveillance events. Different information is available inside EventDetails field of NSurveillanceEventArgs. Events are asynchronous, so no assumption on the order of events should be made.
NSurveillanceModalityType | Enumerates surveillance modality types.
NSurveillanceObjectColor | Enumerates tracked object color values.
NSurveillanceObjectDirection | Represents detected or tracked object direction values.
NSurveillanceObjectType | Enumerates surveillance objects.
NSurveillanceSourceType | Enumerates surveillance source types.
NVehicleOrientation | Enumerates vehicle orientation values.


NClothingDetails Classes

NClothingDetails Classes
Legend
NClothingDetails Classes
NClothingDetails Class
Name | Description
ValueCollection | Values collection.


NClothingDetails Class Members

NClothingDetails Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NClothingDetails Class
Name | Description
GetKnownValues | Returns known values from NClothingDetails.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NClothingDetails Class
Name | Description
Gender | Gets subject's gender.
GenderConfidence | Gets subject's gender confidence value.
NativeType | Neurotechnology framework type of the object.
Values | Gets ValueCollection object.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
NClothingDetails Classes
NClothingDetails Class
Name | Description
ValueCollection | Values collection.


NDisposable Methods

NDisposable Methods
Legend
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NClothingDetails Class
Name | Description
GetKnownValues | Returns known values from NClothingDetails.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NClothingDetails Class
Name | Description
Gender | Gets subject's gender.
GenderConfidence | Gets subject's gender confidence value.
NativeType | Neurotechnology framework type of the object.
Values | Gets ValueCollection object.


NLicensePlate Class Members

NLicensePlate Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NLicensePlate Class
Name | Description
BoundingBox | Gets license plate's bounding box rectangle.
CharacterHeight | Get average height of 3 largest characters.
DetectionConfidence | Gets license plate detection confidence value.
FrameIndex | Gets index of a frame where license plate was found.
NativeType | Neurotechnology framework type of the object.
OcrConfidence | Gets license plate's characters recognition confidence value.
Origin | Gets license plate country code value (3 characters).
Rectangle | Gets license plate's bounding box rectangle.
Region | Get license plate region.
Rotation | Gets rotation of the Rectangle.
Type | Gets license plate's type value (general, taxi, military, etc.).
Value | Gets vehicle's number from a license plate.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NLicensePlate Class
Name | Description
BoundingBox | Gets license plate's bounding box rectangle.
CharacterHeight | Get average height of 3 largest characters.
DetectionConfidence | Gets license plate detection confidence value.
FrameIndex | Gets index of a frame where license plate was found.
NativeType | Neurotechnology framework type of the object.
OcrConfidence | Gets license plate's characters recognition confidence value.
Origin | Gets license plate country code value (3 characters).
Rectangle | Gets license plate's bounding box rectangle.
Region | Get license plate region.
Rotation | Gets rotation of the Rectangle.
Type | Gets license plate's type value (general, taxi, military, etc.).
Value | Gets vehicle's number from a license plate.


See Also

See Also
See Also

BoundingBox


NLicensePlateDetails Classes

NLicensePlateDetails Classes
Legend
NLicensePlateDetails Classes
NLicensePlateDetails Class
Name | Description
BestLicensePlateCollection | Provides the collection of best license plates during tracking.
CurrentLicensePlateCollection | Provides the collection of all license plates within current frame or object.


NLicensePlateDetails Class Members

NLicensePlateDetails Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NLicensePlateDetails Class
Name | Description
Best | Gets the collection of best license plates during license plates tracking.
Current | Gets the collection of all license plates within current frame or object.
NativeType | Neurotechnology framework type of the object.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
NLicensePlateDetails Classes
NLicensePlateDetails Class
Name | Description
BestLicensePlateCollection | Provides the collection of best license plates during tracking.
CurrentLicensePlateCollection | Provides the collection of all license plates within current frame or object.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NLicensePlateDetails Class
Name | Description
Best | Gets the collection of best license plates during license plates tracking.
Current | Gets the collection of all license plates within current frame or object.
NativeType | Neurotechnology framework type of the object.


NNameConfidencePair Structure Members

NNameConfidencePair Structure Members
Legend
Members
NNameConfidencePair Properties
Name | Description
Confidence | Gets or sets confidence value.
Name | Gets or sets name value.
NativeType | Defines the native type of the object.


NNameConfidencePair Properties

NNameConfidencePair Properties
Legend
NNameConfidencePair Properties
Name | Description
Confidence | Gets or sets confidence value.
Name | Gets or sets name value.
NativeType | Defines the native type of the object.


NSurveillance Classes

NSurveillance Classes
Legend
NSurveillance Classes
NSurveillance Class
Name | Description
SourceCollection | Contains new Surveillance sources.


NObject Events

NObject Events
Legend
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
NSurveillance Class
Name | Description
Any | This callback is called on every event.
FacesDetected | This callback is called when faces are detected.
ImageCaptured | This event is fired when a new image is captured.
IsRunningChanged | This event is called when Surveillance "running" task changed.
SubjectAppeared | This event is fired when a new subject appears in the field of view of the camera.
SubjectDisappeared | This event is fired when a subject being tracked leaves the field of view of the camera.
SubjectMerged | This event is fired when two subjects are merged together, for example face subject with person subject.
SubjectSplit | This event is fired when one subject is split into two.
SubjectTrack | This event is fired when successful identification is performed on a tracked subject.


NObject Fields

NObject Fields
Legend
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NSurveillance Class
Name | Description
DllName | Name of the library containing unmanaged part of this class.


NSurveillance Class Members

NSurveillance Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NSurveillance Class
Name | Description
AddEvent | Adds event to class.
AddTemplate | Adds a template to the internal database.
GetTemplateIds | Returns array of template Ids that internal database contains.
OptimizeModelsAsync | Optimizes NSurveillance models by specified modalities (asynchronous operation).
RemoveAllTemplates | Clears internal template database.
RemoveEvent | Removes the event from Surveillance framework.
RemoveTemplate | Removes a template with specified Id from internal database.
Start | Starts surveillance and all sources.
StartAsync | Starts surveillance and all sources (asynchronous operation).
StartSource | Starts specified surveillance source.
StartSourceAsync | Starts specified surveillance source (asynchronous operation).
Stop | Stops surveillance and all sources.
StopAsync | Stops surveillance and all sources (asynchronous operation).
StopSource | Stops specified surveillance source.
StopSourceAsync | Stops specified surveillance source (asynchronous operation).
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NSurveillance Class
Name | Description
DetectorScaling | Determines detection model input resolution, lower value increases performance but reduces accuracy.
DeviceManager | Gets Device Manager.
EnableGpuLowMemoryMode | Enables or disable GPU VRAM conservation. When enabled, minimum required GPU video memory amount is used at the expense of processing speed.
FacesConfidenceThreshold | Gets or sets faces confidence threshold value. This threshold is considered is considered when looking for faces in an image. For each face candidate confidence parameter is calculated. With higher threshold value faces are selected more strictly by the face detection routines.
FacesDetectMasks | Gets or sets whether partially occluded faces (i.e. face mask or respirator) should be recognized.
FacesMinimalInterOcularDistance | Gets or sets minimal inter ocular distance (i.e. the distance between eyes).
FacesQualityThreshold | ... more
FacesTemplateSize | ... more
FacesWithDetailsOnly | Gets or sets whether only events with extracted face (when face modality is used) are returned.
GPUIndices | Get or Set GPU indices to be used for acceleration.
IsRunning | Checks if Surveillance is running (performing operations).
LicensePlateDetectorScaling | Gets or sets detection model input resolution. Note, that lower value increases performance but reduces accuracy.
LicensePlateDetectorThreshold | Gets or sets license plate detection threshold (license plate with lower confidence threshold are discarded).
LicensePlateEnableTemplateMatching | Enables or disables LicensePlatePriorityCountries.
LicensePlateInterpretOAsZero | Changes any predicted o letter to 0, because in many cases there is no real difference between o and 0 fonts so prediction can be wrong.
LicensePlateMinimalCharacterCount | Gets or sets minimal character count in a license plate.
LicensePlateOcrThreshold | Gets or sets license plate's characters recognition confidence value.
LicensePlatePriorityCountries | Gets or sets which countries in license plate formats should be evaluated to reduce mistakes. Use three letter ISO country codes separated with spaces, for example: "LTU LVA EST". If no codes are set, license plate is matched to available formats only if country of origin is determined.
MaskDetectionThreshold | Gets or sets mask detection threshold when FaceDetectMasks is set to true. When mask detection confidence value is lower than specified with this threshold, detected face with a mask is rejected.
MatchingMaximalResultCount | Gets or sets maximum length of the list which is returned by each identification.
MatchingThreshold | ... more
MatchingWithDetails | Checks or sets whether the matching results include matching details.
NSurveillanceEventCallbackNativeType | Defines the native type of the NSurveillanceEventCallback
NSurveillanceEventTypeNativeType | Defines the native type of the NSureveillanceEventType.
NativeModule | Defines the native module of the object.
NativeType | Defines the native type of the object.
Sources | Gets the collection of Surveillance sources.
UseGPU | Get or Set whether surveillance should use GPU to accelerate processing.
VehicleHumanDetectorThreshold | Gets or sets confidence threshold value for vehicle and human detector. Objects detection with a lower confidence than threshold are discarded.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NSurveillance Class
Name | Description
DllName | Name of the library containing unmanaged part of this class.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
NSurveillance Class
Name | Description
Any | This callback is called on every event.
FacesDetected | This callback is called when faces are detected.
ImageCaptured | This event is fired when a new image is captured.
IsRunningChanged | This event is called when Surveillance "running" task changed.
SubjectAppeared | This event is fired when a new subject appears in the field of view of the camera.
SubjectDisappeared | This event is fired when a subject being tracked leaves the field of view of the camera.
SubjectMerged | This event is fired when two subjects are merged together, for example face subject with person subject.
SubjectSplit | This event is fired when one subject is split into two.
SubjectTrack | This event is fired when successful identification is performed on a tracked subject.
Methods
NSurveillance Class
Name | Description
NSurveillance | Initializes a new instance the Surveillance class.
NSurveillance Classes
NSurveillance Class
Name | Description
SourceCollection | Contains new Surveillance sources.


NSurveillance Class Methods

NSurveillance Class Methods
Legend
Methods
NSurveillance Class
Name | Description
NSurveillance | Initializes a new instance the Surveillance class.


NDisposable Methods

NDisposable Methods
Legend
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NSurveillance Class
Name | Description
AddEvent | Adds event to class.
AddTemplate | Adds a template to the internal database.
GetTemplateIds | Returns array of template Ids that internal database contains.
OptimizeModelsAsync | Optimizes NSurveillance models by specified modalities (asynchronous operation).
RemoveAllTemplates | Clears internal template database.
RemoveEvent | Removes the event from Surveillance framework.
RemoveTemplate | Removes a template with specified Id from internal database.
Start | Starts surveillance and all sources.
StartAsync | Starts surveillance and all sources (asynchronous operation).
StartSource | Starts specified surveillance source.
StartSourceAsync | Starts specified surveillance source (asynchronous operation).
Stop | Stops surveillance and all sources.
StopAsync | Stops surveillance and all sources (asynchronous operation).
StopSource | Stops specified surveillance source.
StopSourceAsync | Stops specified surveillance source (asynchronous operation).


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NSurveillance Class
Name | Description
DetectorScaling | Determines detection model input resolution, lower value increases performance but reduces accuracy.
DeviceManager | Gets Device Manager.
EnableGpuLowMemoryMode | Enables or disable GPU VRAM conservation. When enabled, minimum required GPU video memory amount is used at the expense of processing speed.
FacesConfidenceThreshold | Gets or sets faces confidence threshold value. This threshold is considered is considered when looking for faces in an image. For each face candidate confidence parameter is calculated. With higher threshold value faces are selected more strictly by the face detection routines.
FacesDetectMasks | Gets or sets whether partially occluded faces (i.e. face mask or respirator) should be recognized.
FacesMinimalInterOcularDistance | Gets or sets minimal inter ocular distance (i.e. the distance between eyes).
FacesQualityThreshold | ... more
FacesTemplateSize | ... more
FacesWithDetailsOnly | Gets or sets whether only events with extracted face (when face modality is used) are returned.
GPUIndices | Get or Set GPU indices to be used for acceleration.
IsRunning | Checks if Surveillance is running (performing operations).
LicensePlateDetectorScaling | Gets or sets detection model input resolution. Note, that lower value increases performance but reduces accuracy.
LicensePlateDetectorThreshold | Gets or sets license plate detection threshold (license plate with lower confidence threshold are discarded).
LicensePlateEnableTemplateMatching | Enables or disables LicensePlatePriorityCountries.
LicensePlateInterpretOAsZero | Changes any predicted o letter to 0, because in many cases there is no real difference between o and 0 fonts so prediction can be wrong.
LicensePlateMinimalCharacterCount | Gets or sets minimal character count in a license plate.
LicensePlateOcrThreshold | Gets or sets license plate's characters recognition confidence value.
LicensePlatePriorityCountries | Gets or sets which countries in license plate formats should be evaluated to reduce mistakes. Use three letter ISO country codes separated with spaces, for example: "LTU LVA EST". If no codes are set, license plate is matched to available formats only if country of origin is determined.
MaskDetectionThreshold | Gets or sets mask detection threshold when FaceDetectMasks is set to true. When mask detection confidence value is lower than specified with this threshold, detected face with a mask is rejected.
MatchingMaximalResultCount | Gets or sets maximum length of the list which is returned by each identification.
MatchingThreshold | ... more
MatchingWithDetails | Checks or sets whether the matching results include matching details.
NSurveillanceEventCallbackNativeType | Defines the native type of the NSurveillanceEventCallback
NSurveillanceEventTypeNativeType | Defines the native type of the NSureveillanceEventType.
NativeModule | Defines the native module of the object.
NativeType | Defines the native type of the object.
Sources | Gets the collection of Surveillance sources.
UseGPU | Get or Set whether surveillance should use GPU to accelerate processing.
VehicleHumanDetectorThreshold | Gets or sets confidence threshold value for vehicle and human detector. Objects detection with a lower confidence than threshold are discarded.


NSurveillanceDetectionDetails Class Members

NSurveillanceDetectionDetails Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NSurveillanceDetectionDetails Class
Name | Description
ClothingDetails | Gets or sets NClothingDetails object representing subject's clothing details.
DetectionConfidence | Gets or sets detection confidence value.
Face | Gets or sets detected face object.
FaceRectangle | Gets or sets bounding box rectangle of a detected subject's face.
LicensePlateDetails | Gets or sets vehicle's license plate details.
NativeType | Neurotechnology framework type of the object.
ObjectColor | Gets or sets color of a detected surveillance object.
ObjectType | Gets or sets type of a detected surveillance object.
Rectangle | Gets or sets bounding box rectangle of a detected object.
SubjectType | Gets or sets NSurveillanceModalityType object containing one of surveillance modality values (None, Faces, Vehicles and Humans or License Plate Recognition).
VehicleDetails | Gets or sets vehicle details.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Methods
NSurveillanceDetectionDetails Class
Name | Description
NSurveillanceDetectionDetails | Creates a new instance of NSurveillanceDetectionDetails.


NSurveillanceDetectionDetails Class Methods

NSurveillanceDetectionDetails Class Methods
Legend
Methods
NSurveillanceDetectionDetails Class
Name | Description
NSurveillanceDetectionDetails | Creates a new instance of NSurveillanceDetectionDetails.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NSurveillanceDetectionDetails Class
Name | Description
ClothingDetails | Gets or sets NClothingDetails object representing subject's clothing details.
DetectionConfidence | Gets or sets detection confidence value.
Face | Gets or sets detected face object.
FaceRectangle | Gets or sets bounding box rectangle of a detected subject's face.
LicensePlateDetails | Gets or sets vehicle's license plate details.
NativeType | Neurotechnology framework type of the object.
ObjectColor | Gets or sets color of a detected surveillance object.
ObjectType | Gets or sets type of a detected surveillance object.
Rectangle | Gets or sets bounding box rectangle of a detected object.
SubjectType | Gets or sets NSurveillanceModalityType object containing one of surveillance modality values (None, Faces, Vehicles and Humans or License Plate Recognition).
VehicleDetails | Gets or sets vehicle details.


NSurveillanceDetectionResult Classes

NSurveillanceDetectionResult Classes
Legend
NSurveillanceDetectionResult Classes
NSurveillanceDetectionResult Class
Name | Description
DetailsCollection | Detection details collection.


NSurveillanceDetectionResult Class Members

NSurveillanceDetectionResult Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NSurveillanceDetectionResult Class
Name | Description
Details | Gets DetailsCollection object.
Image | Gets an image containing a detected surveillance object.
ModalityType | Gets a type of modality used for surveillance and objects detection.
NativeType | Neurotechnology framework type of the object.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
NSurveillanceDetectionResult Classes
NSurveillanceDetectionResult Class
Name | Description
DetailsCollection | Detection details collection.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NSurveillanceDetectionResult Class
Name | Description
Details | Gets DetailsCollection object.
Image | Gets an image containing a detected surveillance object.
ModalityType | Gets a type of modality used for surveillance and objects detection.
NativeType | Neurotechnology framework type of the object.


NSurveillanceEngine Class Members

NSurveillanceEngine Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NSurveillanceEngine Class
Name | Description
Detect | Detects Surveillance object from the specified image.
DetectAsync | Detects object from the specified image (asynchronous operation).
DetectWithParameters | Detects Surveillance object from the specified image with detection parameters.
DetectWithParametersAsync | Detects object from the specified image with detection parameters(asynchronous operation).
Initialize | Initializes NSurveillanceEngine.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NSurveillanceEngine Class
Name | Description
DetectorScaling | Determines detection model input resolution, lower value increases performance but reduces accuracy.
EnableGpuLowMemoryMode | Enables or disable GPU VRAM conservation. When enabled, minimum required GPU video memory amount is used at the expense of processing speed.
FacesConfidenceThreshold | Gets or sets face confidence threshold value.
FacesDetectMasks | Gets or sets whether partially occluded faces (i.e. face mask or respirator) should be recognized.
FacesMinimalInterOcularDistance | Gets or sets minimal inter ocular distance (i.e. the distance between eyes).
FacesQualityThreshold | ... more
FacesTemplateSize | ... more
GPUIndices | Get or Set GPU indices to be used for acceleration.
LicensePlateDetectorScaling | Gets or sets detection model input resolution. Note, that lower value increases performance but reduces accuracy.
LicensePlateDetectorThreshold | Gets or sets license plate detection threshold (license plate with lower confidence threshold are discarded).
LicensePlateEnableTemplateMatching | Enables or disables LicensePlatePriorityCountries.
LicensePlateInterpretOAsZero | Changes any predicted o letter to 0, because in many cases there is no real difference between o and 0 fonts so prediction can be wrong.
LicensePlateMinimalCharacterCount | Gets or sets minimal character count in a license plate.
LicensePlateOcrThreshold | Gets or sets license plate's characters recognition confidence value.
LicensePlatePriorityCountries | Gets or sets which countries in license plate formats should be evaluated to reduce mistakes. Use three letter ISO country codes separated with spaces, for example: "LTU LVA EST". If no codes are set, license plate is matched to available formats only if country of origin is determined.
ModalityType | Gets a type of modality used for surveillance and objects detection.
NativeType | Neurotechnology framework type of the object.
ThreadCount | Gets or sets thread count used by Surveillance engine.
UseGPU | Get or Set whether surveillance should use GPU to accelerate processing.
VehicleHumanDetectorThreshold | Gets or sets confidence threshold value for vehicle and human detector. Objects detection with a lower confidence than threshold are discarded.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
Methods
NSurveillanceEngine Class
Name | Description
NSurveillanceEngine | Creates a new instance of NSurveillanceEngine.


NSurveillanceEngine Class Methods

NSurveillanceEngine Class Methods
Legend
Methods
NSurveillanceEngine Class
Name | Description
NSurveillanceEngine | Creates a new instance of NSurveillanceEngine.


NDisposable Methods

NDisposable Methods
Legend
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NSurveillanceEngine Class
Name | Description
Detect | Detects Surveillance object from the specified image.
DetectAsync | Detects object from the specified image (asynchronous operation).
DetectWithParameters | Detects Surveillance object from the specified image with detection parameters.
DetectWithParametersAsync | Detects object from the specified image with detection parameters(asynchronous operation).
Initialize | Initializes NSurveillanceEngine.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NSurveillanceEngine Class
Name | Description
DetectorScaling | Determines detection model input resolution, lower value increases performance but reduces accuracy.
EnableGpuLowMemoryMode | Enables or disable GPU VRAM conservation. When enabled, minimum required GPU video memory amount is used at the expense of processing speed.
FacesConfidenceThreshold | Gets or sets face confidence threshold value.
FacesDetectMasks | Gets or sets whether partially occluded faces (i.e. face mask or respirator) should be recognized.
FacesMinimalInterOcularDistance | Gets or sets minimal inter ocular distance (i.e. the distance between eyes).
FacesQualityThreshold | ... more
FacesTemplateSize | ... more
GPUIndices | Get or Set GPU indices to be used for acceleration.
LicensePlateDetectorScaling | Gets or sets detection model input resolution. Note, that lower value increases performance but reduces accuracy.
LicensePlateDetectorThreshold | Gets or sets license plate detection threshold (license plate with lower confidence threshold are discarded).
LicensePlateEnableTemplateMatching | Enables or disables LicensePlatePriorityCountries.
LicensePlateInterpretOAsZero | Changes any predicted o letter to 0, because in many cases there is no real difference between o and 0 fonts so prediction can be wrong.
LicensePlateMinimalCharacterCount | Gets or sets minimal character count in a license plate.
LicensePlateOcrThreshold | Gets or sets license plate's characters recognition confidence value.
LicensePlatePriorityCountries | Gets or sets which countries in license plate formats should be evaluated to reduce mistakes. Use three letter ISO country codes separated with spaces, for example: "LTU LVA EST". If no codes are set, license plate is matched to available formats only if country of origin is determined.
ModalityType | Gets a type of modality used for surveillance and objects detection.
NativeType | Neurotechnology framework type of the object.
ThreadCount | Gets or sets thread count used by Surveillance engine.
UseGPU | Get or Set whether surveillance should use GPU to accelerate processing.
VehicleHumanDetectorThreshold | Gets or sets confidence threshold value for vehicle and human detector. Objects detection with a lower confidence than threshold are discarded.


NSurveillanceEventArgs Class Members

NSurveillanceEventArgs Class Members
Legend
Members
Methods
Name | Description
NSurveillanceEventArgs | Creates a new instance of NSurveillanceEventArgs class.
NSurveillanceEventArgs Properties
Name | Description
EventDetailsArray | Gets event details object array.
EventType | Gets event type.


NSurveillanceEventArgs Class Methods

NSurveillanceEventArgs Class Methods
Legend
Methods
Name | Description
NSurveillanceEventArgs | Creates a new instance of NSurveillanceEventArgs class.


NSurveillanceEventArgs Properties

NSurveillanceEventArgs Properties
Legend
NSurveillanceEventArgs Properties
Name | Description
EventDetailsArray | Gets event details object array.
EventType | Gets event type.


NSurveillanceEventDetails Classes

NSurveillanceEventDetails Classes
Legend
NSurveillanceEventDetails Classes
NSurveillanceEventDetails Class
Name | Description
BestMatchCollection | Contains best matching items.
CurrentMatchCollection | Contains current matching items.


NSurveillanceEventDetails Class Members

NSurveillanceEventDetails Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NSurveillanceEventDetails Class
Name | Description
GetAttribtues | Gets face attributes from specified surveillance event details.
GetDetectedFaces | Gets the list of detected faces attributes.
GetFace | Gets face of the specified event.
GetOriginalImage | Retrieves the originally captured image.
GetSubjectTemplate | Retrieves generalized Subject template.
GetVideoSample | Retrieves captured video sample.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NSurveillanceEventDetails Class
Name | Description
Attributes | Gets face attributes from surveillance event details.
AttributesContainsDetails | Checks whether surveillance event contains extraction details.
BestDetails | Get event containing best details for tracked subject.
BestMatches | Retrieves BestMatchesCollection.
CurrentMatches | Retrieves CurrentMatchesCollection.
Error | Gets the most recent error for the specified surveillance event.
Face | Gets face of the specified event.
FaceConfidence | A property that returns confidence of tracked face if any.
FrameIndex | A property that returns the number of captured images prior to this event.
MergedSubject | Get subject that was merged with current subject. Only applicable during SubjectMerged event.
ModalityType | A property that returns type of the subject event.
NativeType | Defines the native type of the object.
OriginalImage | A property that returns originally captured image.
Owner | Gets NSurveillance owner.
Rectangle | A property that returns bounding rectangle of a subject being processed.
SplitFromSubject | Get subject from which current subject was split. Only applicable during SubjectSplit event.
SubjectType | A property that returns subject type for current event
Template | A property that returns extracted serialized template.
TimeStamp | A property that returns the date and time of the captured image.
TraceIndex | A property that returns an index of the current subject being tracked. The index is zero-based and represents unique id of subject being tracked at the current moment. After subject disappears this index becomes invalid.
VideoTimeStamp | A property that returns time in video of the captured image.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
NSurveillanceEventDetails Classes
NSurveillanceEventDetails Class
Name | Description
BestMatchCollection | Contains best matching items.
CurrentMatchCollection | Contains current matching items.


NDisposable Methods

NDisposable Methods
Legend
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NSurveillanceEventDetails Class
Name | Description
GetAttribtues | Gets face attributes from specified surveillance event details.
GetDetectedFaces | Gets the list of detected faces attributes.
GetFace | Gets face of the specified event.
GetOriginalImage | Retrieves the originally captured image.
GetSubjectTemplate | Retrieves generalized Subject template.
GetVideoSample | Retrieves captured video sample.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NSurveillanceEventDetails Class
Name | Description
Attributes | Gets face attributes from surveillance event details.
AttributesContainsDetails | Checks whether surveillance event contains extraction details.
BestDetails | Get event containing best details for tracked subject.
BestMatches | Retrieves BestMatchesCollection.
CurrentMatches | Retrieves CurrentMatchesCollection.
Error | Gets the most recent error for the specified surveillance event.
Face | Gets face of the specified event.
FaceConfidence | A property that returns confidence of tracked face if any.
FrameIndex | A property that returns the number of captured images prior to this event.
MergedSubject | Get subject that was merged with current subject. Only applicable during SubjectMerged event.
ModalityType | A property that returns type of the subject event.
NativeType | Defines the native type of the object.
OriginalImage | A property that returns originally captured image.
Owner | Gets NSurveillance owner.
Rectangle | A property that returns bounding rectangle of a subject being processed.
SplitFromSubject | Get subject from which current subject was split. Only applicable during SubjectSplit event.
SubjectType | A property that returns subject type for current event
Template | A property that returns extracted serialized template.
TimeStamp | A property that returns the date and time of the captured image.
TraceIndex | A property that returns an index of the current subject being tracked. The index is zero-based and represents unique id of subject being tracked at the current moment. After subject disappears this index becomes invalid.
VideoTimeStamp | A property that returns time in video of the captured image.


Legend

Legend
Legend
Property


NSurveillanceObjectColorDetails Structure Members

NSurveillanceObjectColorDetails Structure Members
Legend
Members
NSurveillanceObjectColorDetails Properties
Name | Description
BlackColorConfidence | Gets or sets black color confidence value.
BlueColorConfidence | Gets or sets blue color confidence value.
BrownColorConfidence | Gets or sets brown color confidence value.
Color | Gets or sets color of a detected object.
GrayColorConfidence | Gets or sets gray color confidence value.
GreenColorConfidence | Gets or sets green color confidence value.
OrangeColorConfidence | Gets or sets orange color confidence value.
RedColorConfidence | Gets or sets red color confidence value.
SilverColorConfidence | Gets or sets silver color confidence value.
WhiteColorConfidence | Gets or sets white color confidence value.
YellowColorConfidence | Gets or sets yellow color confidence value.


NSurveillanceObjectColorDetails Properties

NSurveillanceObjectColorDetails Properties
Legend
NSurveillanceObjectColorDetails Properties
Name | Description
BlackColorConfidence | Gets or sets black color confidence value.
BlueColorConfidence | Gets or sets blue color confidence value.
BrownColorConfidence | Gets or sets brown color confidence value.
Color | Gets or sets color of a detected object.
GrayColorConfidence | Gets or sets gray color confidence value.
GreenColorConfidence | Gets or sets green color confidence value.
OrangeColorConfidence | Gets or sets orange color confidence value.
RedColorConfidence | Gets or sets red color confidence value.
SilverColorConfidence | Gets or sets silver color confidence value.
WhiteColorConfidence | Gets or sets white color confidence value.
YellowColorConfidence | Gets or sets yellow color confidence value.


NSurveillanceObjectDirectionDetails Structure Members

NSurveillanceObjectDirectionDetails Structure Members
Legend
Members
NSurveillanceObjectDirectionDetails Properties
Name | Description
Direction | Gets or sets NSurveillanceObjectDirection object.
EastConfidence | Gets or sets east confidence value.
NorthConfidence | Gets or sets north confidence value.
NorthEastConfidence | Gets or sets north east confidence value.
NorthWestConfidence | Gets or sets north west confidence value.
SouthConfidence | Gets or sets south confidence value.
SouthEastConfidence | Gets or sets south east confidence value.
SouthWestConfidence | Gets or sets south west confidence value.
WestConfidence | Gets or sets west confidence value.


NSurveillanceObjectDirectionDetails Properties

NSurveillanceObjectDirectionDetails Properties
Legend
NSurveillanceObjectDirectionDetails Properties
Name | Description
Direction | Gets or sets NSurveillanceObjectDirection object.
EastConfidence | Gets or sets east confidence value.
NorthConfidence | Gets or sets north confidence value.
NorthEastConfidence | Gets or sets north east confidence value.
NorthWestConfidence | Gets or sets north west confidence value.
SouthConfidence | Gets or sets south confidence value.
SouthEastConfidence | Gets or sets south east confidence value.
SouthWestConfidence | Gets or sets south west confidence value.
WestConfidence | Gets or sets west confidence value.


NSurveillanceObjectTypeDetails Structure Members

NSurveillanceObjectTypeDetails Structure Members
Legend
Members
NSurveillanceObjectTypeDetails Properties
Name | Description
BikeConfidence | Gets or sets confidence value if detected object is a bike.
BusConfidence | Gets or sets confidence value if detected object is a bus.
CarConfidence | Gets or sets confidence value if detected object is a car.
PersonConfidence | Gets or sets confidence value if detected object is a person.
TruckConfidence | Gets or sets confidence value if detected object is a truck.
Type | Gets or sets NSurveillanceObjectType object.


NSurveillanceObjectTypeDetails Properties

NSurveillanceObjectTypeDetails Properties
Legend
NSurveillanceObjectTypeDetails Properties
Name | Description
BikeConfidence | Gets or sets confidence value if detected object is a bike.
BusConfidence | Gets or sets confidence value if detected object is a bus.
CarConfidence | Gets or sets confidence value if detected object is a car.
PersonConfidence | Gets or sets confidence value if detected object is a person.
TruckConfidence | Gets or sets confidence value if detected object is a truck.
Type | Gets or sets NSurveillanceObjectType object.


NObject Events

NObject Events
Legend
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
NSurveillanceSource Class
Name | Description
IsCapturingChanged | This event is called when Surveillance Source "capturing" state changed.


NSurveillanceSource Class Members

NSurveillanceSource Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NSurveillanceSource Class
Name | Description
GetCurrentFormat | Gets current media format used in surveillance.
GetFormats | Gets all formats supported by camera or video.
SetCurrentFormat | Sets current media format used in surveillance.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NExpandableObject Class
Show:
No members matching the current filter
Name | Description
NativeType | Defines the native type of the object.
Properties | Gets the property bag of the expandable object.
NSurveillanceSource Class
Name | Description
Camera | Gets or sets the camera for the current NSurveillanceSource.
Error | Gets the exception thrown internally by processing NSurveillanceSource.
Length | Gets the TimeSpan structure representing the length of NSurveillanceSource.
ModalityType | Gets a type of modality used for surveillance source.
NativeType | Defines the native type of the object.
Owner | Gets NSurveillance owner.
Position | Gets or sets the TimeSpan structure representing the position of NSurveillanceSource.
RegionOfInterest | Gets or sets rectangle coordinates for region of interest frame.
State | Gets the NSurveillanceSource state.
Type | Gets the NSurveillanceSource type.
Video | Gets or sets the media reader containing the video for the current NSurveillanceSource.
Warning | Gets the warning set internally by processing NSurveillanceSource.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
NSurveillanceSource Class
Name | Description
IsCapturingChanged | This event is called when Surveillance Source "capturing" state changed.
Methods
NSurveillanceSource Class
Name | Description
NSurveillanceSource | Creates a new instance of NSurveillanceSource class.


NSurveillanceSource Class Methods

NSurveillanceSource Class Methods
Legend
Methods
NSurveillanceSource Class
Name | Description
NSurveillanceSource | Creates a new instance of NSurveillanceSource class.


NDisposable Methods

NDisposable Methods
Legend
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NSurveillanceSource Class
Name | Description
GetCurrentFormat | Gets current media format used in surveillance.
GetFormats | Gets all formats supported by camera or video.
SetCurrentFormat | Sets current media format used in surveillance.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NExpandableObject Class
Show:
No members matching the current filter
Name | Description
NativeType | Defines the native type of the object.
Properties | Gets the property bag of the expandable object.
NSurveillanceSource Class
Name | Description
Camera | Gets or sets the camera for the current NSurveillanceSource.
Error | Gets the exception thrown internally by processing NSurveillanceSource.
Length | Gets the TimeSpan structure representing the length of NSurveillanceSource.
ModalityType | Gets a type of modality used for surveillance source.
NativeType | Defines the native type of the object.
Owner | Gets NSurveillance owner.
Position | Gets or sets the TimeSpan structure representing the position of NSurveillanceSource.
RegionOfInterest | Gets or sets rectangle coordinates for region of interest frame.
State | Gets the NSurveillanceSource state.
Type | Gets the NSurveillanceSource type.
Video | Gets or sets the media reader containing the video for the current NSurveillanceSource.
Warning | Gets the warning set internally by processing NSurveillanceSource.


NTrackingDetails Classes

NTrackingDetails Classes
Legend
NTrackingDetails Classes
NTrackingDetails Class
Name | Description
LicensePlateCollection | Collection of detected license plates.
MatchResultCollection | Collection of match results.


NTrackingDetails Class Members

NTrackingDetails Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NTrackingDetails Class
Name | Description
Attributes | Gets face attributes (like age, gender, emotions and other) of a detected face.
AttributesContainsDetails | Gets whether face template was extracted and contains faces attributes such as gender or face expression.
FrameIndex | Gets frame index.
LicensePlates | Gets license plates collection.
MatchResults | Gets match results collection containing subject's matching results.
NativeType | Neurotechnology framework type of the object.
Rectangle | Gets rectangle of bounding box of a tracked object.
SubjectType | Gets which surveillance modalities was detected for a subject.
TimeStamp | Gets time stamp from tracking details.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
NTrackingDetails Classes
NTrackingDetails Class
Name | Description
LicensePlateCollection | Collection of detected license plates.
MatchResultCollection | Collection of match results.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NTrackingDetails Class
Name | Description
Attributes | Gets face attributes (like age, gender, emotions and other) of a detected face.
AttributesContainsDetails | Gets whether face template was extracted and contains faces attributes such as gender or face expression.
FrameIndex | Gets frame index.
LicensePlates | Gets license plates collection.
MatchResults | Gets match results collection containing subject's matching results.
NativeType | Neurotechnology framework type of the object.
Rectangle | Gets rectangle of bounding box of a tracked object.
SubjectType | Gets which surveillance modalities was detected for a subject.
TimeStamp | Gets time stamp from tracking details.


NVehicleDetails Classes

NVehicleDetails Classes
Legend
NVehicleDetails Classes
NVehicleDetails Class
Name | Description
ModelCollection | Vehicle model collection.
TagCollection | Vehicle body type collection (sedan, coupe, bus, tractor, etc.).


NVehicleDetails Class Members

NVehicleDetails Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NVehicleDetails Class
Name | Description
GetKnownMakes | Gets the array of known vehicle makes (names of vehicle manufacturers).
GetKnownModels | Gets the array of all known vehicle models.
GetKnownTags | Gets all known vehicle body types (like sedan, coupe, bus, tractor, etc.).
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NVehicleDetails Class
Name | Description
Models | Gets ModelCollection object containing vehicle models.
NVehicleOrientationNativeType | Gets NVehicleOrientation native type.
NativeType | Neurotechnology framework type of the object.
Orientation | Gets vehicle orientation value (Front, Back, Left, FrontLeft, etc.).
OrientationAngle | Gets an angle of vehicle orientation.
OrientationConfidence | Gets confidence value of vehicle's orientation.
Tags | Gets TagCollection object containing vehicle body types.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.
NVehicleDetails Classes
NVehicleDetails Class
Name | Description
ModelCollection | Vehicle model collection.
TagCollection | Vehicle body type collection (sedan, coupe, bus, tractor, etc.).


NDisposable Methods

NDisposable Methods
Legend
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NVehicleDetails Class
Name | Description
GetKnownMakes | Gets the array of known vehicle makes (names of vehicle manufacturers).
GetKnownModels | Gets the array of all known vehicle models.
GetKnownTags | Gets all known vehicle body types (like sedan, coupe, bus, tractor, etc.).


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NVehicleDetails Class
Name | Description
Models | Gets ModelCollection object containing vehicle models.
NVehicleOrientationNativeType | Gets NVehicleOrientation native type.
NativeType | Neurotechnology framework type of the object.
Orientation | Gets vehicle orientation value (Front, Back, Left, FrontLeft, etc.).
OrientationAngle | Gets an angle of vehicle orientation.
OrientationConfidence | Gets confidence value of vehicle's orientation.
Tags | Gets TagCollection object containing vehicle body types.


See Also

See Also
See Also

GetKnownMakes


NsedMatchResult Class Members

NsedMatchResult Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NsedMatchResult Class
Name | Description
Id | Gets Id of a matching result.
MatchingDetails | Gets matching detail;s object.
NativeType | Neurotechnology framework type of the object.
Score | Gets matching score.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NsedMatchResult Class
Name | Description
Id | Gets Id of a matching result.
MatchingDetails | Gets matching detail;s object.
NativeType | Neurotechnology framework type of the object.
Score | Gets matching score.


Neurotec.Surveillance.Encoding Namespace Classes

Neurotec.Surveillance.Encoding Namespace Classes
Legend
Classes
Name | Description
NGpuJpegEncoder | Provides functionality for converting NImage to Jpeg using GPU.


Neurotec.Surveillance.Encoding Namespace Structs, Records, Enums

Neurotec.Surveillance.Encoding Namespace Structs, Records, Enums
Legend
Structs, Records, Enums
Name | Description
NScaleMethod | Image rescale algorithm.


NGpuJpegEncoder Class Members

NGpuJpegEncoder Class Members
Legend
Members
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NGpuJpegEncoder Class
Name | Description
Encode | Converts provided NImage object to Jpeg using GPU and returns as NBuffer object.
ScaleAndEncode | Rescales and converts provided NImage object to Jpeg using GPU and returns as NBuffer object.
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NGpuJpegEncoder Class
Name | Description
CompressionQuality | Gets or sets Jpeg image compression quality.
GpuIndex | Gets an index of GPU unit which is used to convert NImage to Jpeg.
NativeType | Neurotechnology framework type of the object.
NObject Fields
NObject Class
Show:
No members matching the current filter
Name | Description
FlagRefRet | This flag indicates that an object should be returned with incremented ref count.
NObject Delegates
NObject Class
Show:
No members matching the current filter
Name | Description
EventInvoker | Creates a delegate to an event invoker function.
FromHandlePlain | Creates a delegate to FromHandlePlain function.
GetArrayPlain | Creates a delegate to a function, which gets a plain array.
GetArrayWithHandle | Creates a delegate to a function, which gets an array with handle.
GetObjectPlain | Creates a delegate to a function which returns a plain object.
GetObjectWithHandle | Creates a delegate to a function, which returns an object with handle.
GetOutArrayPlain | Creates a delegate to a function, which gets a plain out array.
GetOutArrayWithHandle | Creates a delegate to a function, which gets an out array with a handle.
GetStringPlainN | Creates a delegate to a function, which gets a plain string.
GetStringWithHandleN | Creates a delegate to a function, which gets a string with handle.
SetArrayPlain | Creates a delegate to a function, which sets values of a plain array.
SetArrayWithHandle | Creates a delegate to a function, which sets values of an array with handle.
SetObjectPlain | Creates a delegate to a function, which sets a value of a plain object.
SetObjectWithHandle | Creates a delegate to a function, which sets a value of an object with handle.
SetStringPlainN | Creates a delegate to a function, which sets a plain string.
SetStringWithHandleN | Creates a delegate to a function, which sets a string with handle.
NObject Events
NObject Class
Show:
No members matching the current filter
Name | Description
PropertyChanged | Adds or removes a "Property Changed" event.


NDisposable Methods

NDisposable Methods
Legend
NDisposable Methods
Show:
No members matching the current filter
Name | Description
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
NObject Class
Show:
No members matching the current filter
Name | Description
CaptureProperties | Adds the properties of the specified object to the specified property bag.
Clone | Creates a copy of specified object.
CompareTo | Compares the current object with the specified version and returns an integer that indicates their relative position in the sort order.
CopyProperties | Copies property values from one NObject object to another.
DisposeArray<T> | Frees an array of objects.
Equals | Compares the objects.
FromHandle<T> | Create C# object from native API objects handle. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
FromObject | Creates a new NObject from the specified object.
GetArray<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetHashCode | Gets hash code (numeric value) representing the object. Is intended for a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNativeType | Retrieves native type of object.
GetObject<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetObjects<T> | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
GetProperty<T> | Retrieves the specified property of the current object.
GetSize | Returns the size of the current object.
GetSizeMany<T> | Returns the size of objects in the array.
GetString | Helper function for getting data from the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
Ref | Increments the reference count for an interface on a specified object. This function should be called for every new copy of a pointer to an interface of HNObject.
Reset | Resets all NObject parameters to default values.
ResetProperty | Resets the value of the specified property.
Save | Saves the current object into a buffer.
SaveMany<T> | Saves an array of objects into a buffer.
SetArray<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetObject<T> | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
SetProperty<T> | Sets the value of the specified property.
SetString | Helper function for setting data of the native object. This method supports the .NET Framework infrastructure and is not intended to be used directly from your code.
ToHandle | Gets the representation of native API handle corresponding to the C# object.
ToObject | Creates a new object from the specified NObject.
ToString | Returns string representation of the object.
Unref | Decrements the reference count for an interface on a specified object. This function should be called on returned objects when they are no longer used to prevent memory leaks.
UnrefArray | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
UnrefElements | Decrements the reference count for an interface on specified array of objects. This function should be called on returned objects array when they are no longer used to prevent memory leaks.
NGpuJpegEncoder Class
Name | Description
Encode | Converts provided NImage object to Jpeg using GPU and returns as NBuffer object.
ScaleAndEncode | Rescales and converts provided NImage object to Jpeg using GPU and returns as NBuffer object.


NDisposable Properties

NDisposable Properties
Legend
NDisposable Properties
Show:
No members matching the current filter
Name | Description
IsDisposed | Gets whether allocated resources were released previously.
NObject Class
Show:
No members matching the current filter
Name | Description
Flags | Gets flags from object.
IsDisposed | Gets whether allocated resources were released previously.
NativeType | Neurotechnology framework type of the object.
Owner | Gets owner of the object.
NGpuJpegEncoder Class
Name | Description
CompressionQuality | Gets or sets Jpeg image compression quality.
GpuIndex | Gets an index of GPU unit which is used to convert NImage to Jpeg.
NativeType | Neurotechnology framework type of the object.


Functions (AutoDoc Folder)

Legend
Legend
Method


Structs, Records, Enums (AutoDoc Folder)

Legend
Legend
Enumeration


Functions

Legend
Legend
Method


Enumerations

Legend
Legend
Enumeration


Structs, Records, Enums (AutoDoc Folder)

Legend
Legend
Structure
Enumeration


Structures

Legend
Legend
Structure


Structs, Records, Enums (AutoDoc Folder)

Legend
Legend
Structure


Structs, Records, Enums (AutoDoc Folder)

Legend
Legend
Enumeration
Structure


Classes (AutoDoc Folder)

Legend
Legend
Class
Structure
static
abstract


Classes (AutoDoc Folder)

Legend
Legend
Class
Structure
static


Methods (AutoDoc Folder)

Legend
Legend
Method
virtual
static


Properties (AutoDoc Folder)

Legend
Legend
Property
read only
virtual
static


Fields (AutoDoc Folder)

Legend
Legend
Data Member


Events (AutoDoc Folder)

Legend
Legend
Event


Members

Legend
Legend
Method
virtual
static
Property
read only
Data Member
Event


Methods

Legend
Legend
Constructor


Methods (AutoDoc Folder)

Legend
Legend
Method


Properties (AutoDoc Folder)

Legend
Legend
Property
read only
static


Members

Legend
Legend
Constructor
Property
read only
static


Methods (AutoDoc Folder)

Legend
Legend
Method
static


Members

Legend
Legend
Data Member
Method
static
Property
read only


Members

Legend
Legend
Data Member
Property
read only
static


Fields (AutoDoc Folder)

Legend
Legend
Data Member
static
read only


Members

Legend
Legend
Constructor
Data Member
static
read only
Property


Classes (AutoDoc Folder)

Legend
Legend
Class


Members

Legend
Legend
Method
virtual
static
Property
read only
Data Member
Event
Class


Members

Legend
Legend
Property
read only
static


Members

Legend
Legend
Method
Property
read only
static


Members

Legend
Legend
Method
Property
read only
static
Event


Members

Legend
Legend
Class
Method
Property
read only
static
Event


Members

Legend
Legend
Method


Classes (AutoDoc Folder)

Legend
Legend
Class
static


Properties (AutoDoc Folder)

Legend
Legend
Property


Members

Legend
Legend
Constructor
Property


Properties (AutoDoc Folder)

Legend
Legend
Property
read only


Members

Legend
Legend
Constructor
Property
read only


Classes (AutoDoc Folder)

Legend
Legend
Class
static
Structure


Members

Legend
Legend
Method
Property
read only


Members

Legend
Legend
Method
static
Property
read only


Operators (AutoDoc Folder)

Legend
Legend
Operator
static


Members

Legend
Legend
Constructor
Data Member
static
read only
Operator
Property


Classes (AutoDoc Folder)

Legend
Legend
Structure


Members

Legend
Legend
Data Member
Method
static


Properties (AutoDoc Folder)

Legend
Legend
Property
static
read only


Members

Legend
Legend
Method
virtual
static
Property
read only
Data Member
Event
Operator


Events (AutoDoc Folder)

Legend
Legend
Event
static


Members

Legend
Legend
Data Member
Method
static
Property
read only
Event


Methods (AutoDoc Folder)

Legend
Legend
Method
virtual


Properties (AutoDoc Folder)

Legend
Legend
Property
read only
virtual


Members

Legend
Legend
Method
virtual
Property
read only


Members

Legend
Legend
Method
static


Members

Legend
Legend
Data Member
static
read only
Method
Property


Classes (AutoDoc Folder)

Legend
Legend
Class
Structure


Members

Legend
Legend
Property


Contents

Collapse Expand Introduction
Features
Face Modality
VH (vehicle-human) Modality
ALPR Modality
System Requirements
Licensing
What's new
Collapse Expand Overview
Required Libraries
Licensed API functionality
Matching Threshold and FAR/FRR
Cameras
Error codes
Tutorials
Collapse Expand Samples
Faces Sample (C#)
Collapse Expand Devices
NdmSample - Adding support of custom device to NDeviceManager
wxWidgets Compilation
Collapse Expand API Reference
Collapse Expand C Reference
Collapse Expand NBiometrics Library
Collapse Expand NBiometric Unit
Collapse Expand Functions
NBiometricCaptureOptionsIsValid Function
NBiometricGetBiometricType Function
NBiometricGetCaptureOptions Function
NBiometricGetError Function
NBiometricGetFileName Function
NBiometricGetHasMoreSamples Function
NBiometricGetParentObject Function
NBiometricGetSampleBuffer Function
NBiometricGetSessionId Function
NBiometricGetStatus Function
NBiometricSetCaptureOptions Function
NBiometricSetFileName Function
NBiometricSetHasMoreSamples Function
NBiometricSetSampleBuffer Function
NBiometricSetSessionId Function
NBiometricSetStatus Function
Collapse Expand Structs, Records, Enums
NBiometricCaptureOptions Enumeration
Collapse Expand Macros
NBiometricSetFileName Macro
Collapse Expand Files
NBiometric.h
Collapse Expand NBiometricAttributes Unit
Collapse Expand Functions
NBiometricAttributesGetBiometricType Function
NBiometricAttributesGetChild Function
NBiometricAttributesGetChildSubject Function
NBiometricAttributesGetDetectionConfidence Function
NBiometricAttributesGetQuality Function
NBiometricAttributesGetStatus Function
NBiometricAttributesSetDetectionConfidence Function
NBiometricAttributesSetQuality Function
NBiometricAttributesSetStatus Function
Collapse Expand Files
NBiometricAttributes.h
Collapse Expand NBiometricTypes Unit
Collapse Expand Functions
NBiometricAngleFromDegrees Function
NBiometricAngleFromRadians Function
NBiometricAngleToDegrees Function
NBiometricAngleToRadians Function
NBiometricAngleToString Function
NBiometricNfiq1ToNfiqQuality Function
NBiometricNfiqQualityToNfiq1 Function
NBiometricQualityBlockIsValid Function
NBiometricQualityBlockToString Function
NBiometricQualityIsValid Function
NBiometricQualityToString Function
NBiometricStatusIsFinal Function
NBiometricStatusIsValid Function
NBiometricSubtypeIsValid Function
NBiometricTypeIsValid Function
NEPositionGetAvailableParts Function
NEPositionIsKnown Function
NEPositionIsLeft Function
NEPositionIsOneOf Function
NEPositionIsRight Function
NEPositionIsRightAndLeft Function
NEPositionIsSingleEye Function
NEPositionIsTheEye Function
NEPositionIsTwoEyes Function
NEPositionIsValid Function
NEPositionIsValidTheEye Function
NFCoreToString Function
NFDeltaToString Function
NFDoubleCoreToString Function
NFImpressionTypeIsCompatibleWith Function
NFImpressionTypeIsContact Function
NFImpressionTypeIsContactless Function
NFImpressionTypeIsFinger Function
NFImpressionTypeIsGeneric Function
NFImpressionTypeIsLatent Function
NFImpressionTypeIsLiveScan Function
NFImpressionTypeIsNonOptical Function
NFImpressionTypeIsNonliveScan Function
NFImpressionTypeIsOneOf Function
NFImpressionTypeIsOptical Function
NFImpressionTypeIsPalm Function
NFImpressionTypeIsPlain Function
NFImpressionTypeIsRolled Function
NFImpressionTypeIsSwipe Function
NFImpressionTypeIsValid Function
NFImpressionTypeIsValidFinger Function
NFImpressionTypeIsValidPalm Function
NFImpressionTypeToFinger Function
NFMinutiaNeighborToString Function
NFMinutiaToString Function
NFPatternClassIsValid Function
NFPatternClassIsValidForPosition Function
NFPositionGetAvailableParts Function
NFPositionIsCompatibleWith Function
NFPositionIsCompatibleWithImpressionType Function
NFPositionIsFinger Function
NFPositionIsFourFingers Function
NFPositionIsKnown Function
NFPositionIsLeft Function
NFPositionIsLeftAndRight Function
NFPositionIsOneOf Function
NFPositionIsPalm Function
NFPositionIsRight Function
NFPositionIsSingleFinger Function
NFPositionIsTheFinger Function
NFPositionIsThePalm Function
NFPositionIsThreeFingers Function
NFPositionIsTwoFingers Function
NFPositionIsValid Function
NFPositionIsValidFinger Function
NFPositionIsValidPalm Function
NFPositionIsValidTheFinger Function
NLFeaturePointToString Function
NfiqQualityIsValid Function
Collapse Expand Structs, Records, Enums
NBiometricQualityBlock_ Structure
NLFeaturePoint_ Structure
NBiometricStatus Enumeration
NBiometricSubtype Enumeration
NBiometricType Enumeration
NEImageType Enumeration
NEPosition Enumeration
NFImpressionType Enumeration
NFPosition Enumeration
NGender Enumeration
NIcaoWarnings Enumeration
NLExpression Enumeration
NLProperties Enumeration
NLivenessAction Enumeration
NLivenessMode Enumeration
NfiqQuality Enumeration
Collapse Expand Types
NBiometricQualityBlock Type
NLFeaturePoint Type
Collapse Expand Macros
NBiometricAngleToString Macro
NBiometricQualityBlockToString Macro
NBiometricQualityToString Macro
NFCoreToString Macro
NFDeltaToString Macro
NFDoubleCoreToString Macro
NFMinutiaNeighborToString Macro
NFMinutiaToString Macro
NLFeaturePointToString Macro
N_BIOMETRIC_QUALITY_FAILED Macro
N_BIOMETRIC_QUALITY_MAX Macro
N_BIOMETRIC_QUALITY_MIN Macro
N_BIOMETRIC_QUALITY_UNKNOWN Macro
N_PHRASE_ID_UNKNOWN Macro
Collapse Expand Files
NBiometricTypes.h
Collapse Expand NFace Unit
Collapse Expand Functions
NFaceAddObjectsCollectionChanged Function
NFaceAddObjectsCollectionChangedCallback Function
NFaceCreate Function
NFaceFromImageAndAttributes Function
NFaceGetImage Function
NFaceGetObject Function
NFaceGetObjectCount Function
NFaceGetObjects Function
NFaceRemoveObjectsCollectionChanged Function
NFaceRemoveObjectsCollectionChangedCallback Function
NFaceSetImage Function
Collapse Expand Files
NFace.h
Collapse Expand NLAttributes Unit
Collapse Expand Functions
NLAttributesAddFeaturePoint Function
NLAttributesClearFeaturePoints Function
NLAttributesCreate Function
NLAttributesGetAdditionalFacesDetected Function
NLAttributesGetAge Function
NLAttributesGetBackgroundUniformity Function
NLAttributesGetBaseFrameIndex Function
NLAttributesGetBeardConfidence Function
NLAttributesGetBlinkConfidence Function
NLAttributesGetBoundingRect Function
NLAttributesGetContrast Function
NLAttributesGetDarkGlassesConfidence Function
NLAttributesGetEmotionAngerConfidence Function
NLAttributesGetEmotionContemptConfidence Function
NLAttributesGetEmotionDisgustConfidence Function
NLAttributesGetEmotionFearConfidence Function
NLAttributesGetEmotionHappinessConfidence Function
NLAttributesGetEmotionNeutralConfidence Function
NLAttributesGetEmotionSadnessConfidence Function
NLAttributesGetEmotionSurpriseConfidence Function
NLAttributesGetEthnicityArabianConfidence Function
NLAttributesGetEthnicityAsianConfidence Function
NLAttributesGetEthnicityBlackConfidence Function
NLAttributesGetEthnicityHispanicConfidence Function
NLAttributesGetEthnicityIndianConfidence Function
NLAttributesGetEthnicityWhiteConfidence Function
NLAttributesGetExpression Function
NLAttributesGetExpressionConfidence Function
NLAttributesGetFaceDarknessConfidence Function
NLAttributesGetFaceMaskConfidence Function
NLAttributesGetFeaturePoint Function
NLAttributesGetFeaturePointCapacity Function
NLAttributesGetFeaturePointCount Function
NLAttributesGetFeaturePoints Function
NLAttributesGetGender Function
NLAttributesGetGenderConfidence Function
NLAttributesGetGlassesConfidence Function
NLAttributesGetGlassesReflectionConfidence Function
NLAttributesGetGrayscaleDensity Function
NLAttributesGetHatConfidence Function
NLAttributesGetHeavyFrameConfidence Function
NLAttributesGetIcaoWarnings Function
NLAttributesGetLeftEyeCenter Function
NLAttributesGetLivenessAction Function
NLAttributesGetLivenessScore Function
NLAttributesGetLivenessTargetPitch Function
NLAttributesGetLivenessTargetYaw Function
NLAttributesGetLookingAwayConfidence Function
NLAttributesGetMocTemplate Function
NLAttributesGetMouthCenter Function
NLAttributesGetMouthOpenConfidence Function
NLAttributesGetMustacheConfidence Function
NLAttributesGetNoise Function
NLAttributesGetNoseTip Function
NLAttributesGetPitch Function
NLAttributesGetPixelationConfidence Function
NLAttributesGetProperties Function
NLAttributesGetRedEyeConfidence Function
NLAttributesGetRightEyeCenter Function
NLAttributesGetRoll Function
NLAttributesGetSaturation Function
NLAttributesGetSharpness Function
NLAttributesGetSkinReflectionConfidence Function
NLAttributesGetTemplate Function
NLAttributesGetThumbnail Function
NLAttributesGetTokenImageRect Function
NLAttributesGetUnnaturalSkinToneConfidence Function
NLAttributesGetWashedOutConfidence Function
NLAttributesGetYaw Function
NLAttributesInsertFeaturePoint Function
NLAttributesRemoveFeaturePointAt Function
NLAttributesSetAdditionalFacesDetected Function
NLAttributesSetAge Function
NLAttributesSetBackgroundUniformity Function
NLAttributesSetBaseFrameIndex Function
NLAttributesSetBeardConfidence Function
NLAttributesSetBlinkConfidence Function
NLAttributesSetBoundingRect Function
NLAttributesSetContrast Function
NLAttributesSetDarkGlassesConfidence Function
NLAttributesSetEmotionAngerConfidence Function
NLAttributesSetEmotionContemptConfidence Function
NLAttributesSetEmotionDisgustConfidence Function
NLAttributesSetEmotionFearConfidence Function
NLAttributesSetEmotionHappinessConfidence Function
NLAttributesSetEmotionNeutralConfidence Function
NLAttributesSetEmotionSadnessConfidence Function
NLAttributesSetEmotionSurpriseConfidence Function
NLAttributesSetEthnicityArabianConfidence Function
NLAttributesSetEthnicityAsianConfidence Function
NLAttributesSetEthnicityBlackConfidence Function
NLAttributesSetEthnicityHispanicConfidence Function
NLAttributesSetEthnicityIndianConfidence Function
NLAttributesSetEthnicityWhiteConfidence Function
NLAttributesSetExpression Function
NLAttributesSetExpressionConfidence Function
NLAttributesSetFaceDarknessConfidence Function
NLAttributesSetFaceMaskConfidence Function
NLAttributesSetFeaturePoint Function
NLAttributesSetFeaturePointCapacity Function
NLAttributesSetGender Function
NLAttributesSetGenderConfidence Function
NLAttributesSetGlassesConfidence Function
NLAttributesSetGlassesReflectionConfidence Function
NLAttributesSetGrayscaleDensity Function
NLAttributesSetHatConfidence Function
NLAttributesSetHeavyFrameConfidence Function
NLAttributesSetIcaoWarnings Function
NLAttributesSetLeftEyeCenter Function
NLAttributesSetLookingAwayConfidence Function
NLAttributesSetMouthCenter Function
NLAttributesSetMouthOpenConfidence Function
NLAttributesSetMustacheConfidence Function
NLAttributesSetNoise Function
NLAttributesSetNoseTip Function
NLAttributesSetPitch Function
NLAttributesSetPixelationConfidence Function
NLAttributesSetProperties Function
NLAttributesSetRedEyeConfidence Function
NLAttributesSetRightEyeCenter Function
NLAttributesSetRoll Function
NLAttributesSetSaturation Function
NLAttributesSetSharpness Function
NLAttributesSetSkinReflectionConfidence Function
NLAttributesSetTemplate Function
NLAttributesSetThumbnail Function
NLAttributesSetTokenImageRect Function
NLAttributesSetUnnaturalSkinToneConfidence Function
NLAttributesSetWashedOutConfidence Function
NLAttributesSetYaw Function
Collapse Expand Files
NLAttributes.h
Collapse Expand NLMatchingDetails Unit
Collapse Expand Files
NLMatchingDetails.h
Collapse Expand NLRecord Unit
Collapse Expand Functions
NLRecordCheck Function
NLRecordCreate Function
NLRecordCreateFromMemory Function
NLRecordGetCbeffProductType Function
NLRecordCreateFromNLRecord Function
NLRecordGetQuality Function
NLRecordGetCbeffProductTypeMem Function
NLRecordGetQualityMem Function
NLRecordSetCbeffProductType Function
NLRecordGetSizeMem Function
NLRecordSetQuality Function
HNLRecord
Collapse Expand Files
NLRecord.h
Collapse Expand NLTemplate Unit
Collapse Expand Functions
NLTemplateAddRecordEx Function
NLTemplateCalculateSize Function
NLTemplateCheck Function
NLTemplateClearRecords Function
NLTemplateCreateFromMemory Function
NLTemplateCreateEx Function
NLTemplateGetRecordCountMem Function
NLTemplateGetRecordCapacity Function
NLTemplateGetRecordEx Function
NLTemplateGetRecordCount Function
NLTemplateGetSizeMem Function
NLTemplateInsertRecord Function
NLTemplatePack Function
NLTemplateRemoveRecordAt Function
NLTemplateSetRecord Function
NLTemplateUnpack Function
NLTemplateSetRecordCapacity Function
HNLTemplate
Collapse Expand Macros
NLT_MAX_RECORD_COUNT Macro
NLT_PROCESS_FIRST_RECORD_ONLY Macro
Collapse Expand Files
NLTemplate.h
Collapse Expand NMatchingDetails Unit
Collapse Expand Functions
NMatchingDetailsCreateFromMemory Function
NMatchingDetailsCreateFromMemoryN Function
NMatchingDetailsCreateFromStream Function
NMatchingDetailsGetFaceCount Function
NMatchingDetailsGetFaceEx Function
NMatchingDetailsGetFacesMatchedIndex Function
NMatchingDetailsGetFacesScore Function
NMatchingDetailsGetFingerCount Function
NMatchingDetailsGetFingerEx Function
NMatchingDetailsGetFingersScore Function
NMatchingDetailsGetIrisCount Function
NMatchingDetailsGetIrisEx Function
NMatchingDetailsGetIrisesScore Function
NMatchingDetailsGetPalmCount Function
NMatchingDetailsGetPalmEx Function
NMatchingDetailsGetPalmsScore Function
NMatchingDetailsGetVoiceCount Function
NMatchingDetailsGetVoiceEx Function
NMatchingDetailsGetVoicesScore Function
Collapse Expand Files
NMatchingDetails.h
Collapse Expand NMatchingDetailsBase Unit
Collapse Expand Functions
NMatchingDetailsBaseGetBiometricType Function
NMatchingDetailsBaseGetScore Function
Collapse Expand Files
NMatchingDetailsBase.h
Collapse Expand NMatchingResult Unit
Collapse Expand Functions
NMatchingResultGetConnection Function
NMatchingResultGetId Function
NMatchingResultGetMatchingDetails Function
NMatchingResultGetMatchingDetailsBuffer Function
NMatchingResultGetScore Function
NMatchingResultGetSubject Function
Collapse Expand Files
NMatchingResult.h
Collapse Expand NSubject Unit
Collapse Expand Functions
NSubjectAddFace Function
NSubjectAddFacesCollectionChanged Function
NSubjectAddFacesCollectionChangedCallback Function
NSubjectAddFinger Function
NSubjectAddFingersCollectionChanged Function
NSubjectAddFingersCollectionChangedCallback Function
NSubjectAddIris Function
NSubjectAddIrisesCollectionChanged Function
NSubjectAddIrisesCollectionChangedCallback Function
NSubjectAddMissingEye Function
NSubjectAddMissingFinger Function
NSubjectAddPalm Function
NSubjectAddPalmsCollectionChanged Function
NSubjectAddPalmsCollectionChangedCallback Function
NSubjectAddRelatedSubject Function
NSubjectAddRelatedSubjectsCollectionChanged Function
NSubjectAddRelatedSubjectsCollectionChangedCallback Function
NSubjectAddSignature Function
NSubjectAddSignaturesCollectionChanged Function
NSubjectAddSignaturesCollectionChangedCallback Function
NSubjectAddVoice Function
NSubjectAddVoicesCollectionChanged Function
NSubjectAddVoicesCollectionChangedCallback Function
NSubjectClear Function
NSubjectClearFaces Function
NSubjectClearFingers Function
NSubjectClearIrises Function
NSubjectClearMissingEyes Function
NSubjectClearMissingFingers Function
NSubjectClearPalms Function
NSubjectClearRelatedSubjects Function
NSubjectClearSignatures Function
NSubjectClearVoices Function
NSubjectCreate Function
NSubjectCreateFromFile Function
NSubjectCreateFromFileWithFormat Function
NSubjectCreateFromMemory Function
NSubjectCreateFromMemoryWithFormat Function
NSubjectCreateFromStream Function
NSubjectCreateFromStreamWithFormat Function
NSubjectGetError Function
NSubjectGetFace Function
NSubjectGetFaceCapacity Function
NSubjectGetFaceCount Function
NSubjectGetFaces Function
NSubjectGetFinger Function
NSubjectGetFingerCapacity Function
NSubjectGetFingerCount Function
NSubjectGetFingers Function
NSubjectGetGender Function
NSubjectGetId Function
NSubjectGetIris Function
NSubjectGetIrisCapacity Function
NSubjectGetIrisCount Function
NSubjectGetIrises Function
NSubjectGetMatchingResult Function
NSubjectGetMatchingResultCount Function
NSubjectGetMatchingResults Function
NSubjectGetMissingEye Function
NSubjectGetMissingEyeCapacity Function
NSubjectGetMissingEyeCount Function
NSubjectGetMissingEyes Function
NSubjectGetMissingFinger Function
NSubjectGetMissingFingerCapacity Function
NSubjectGetMissingFingerCount Function
NSubjectGetMissingFingers Function
NSubjectGetPalm Function
NSubjectGetPalmCapacity Function
NSubjectGetPalmCount Function
NSubjectGetPalms Function
NSubjectGetQueryString Function
NSubjectGetRelatedSubject Function
NSubjectGetRelatedSubjectCapacity Function
NSubjectGetRelatedSubjectCount Function
NSubjectGetRelatedSubjects Function
NSubjectGetSignature Function
NSubjectGetSignatureCapacity Function
NSubjectGetSignatureCount Function
NSubjectGetSignatures Function
NSubjectGetStatistics Function
NSubjectGetStatus Function
NSubjectGetTemplate Function
NSubjectGetTemplateBuffer Function
NSubjectGetTemplateBufferWithFormatEx Function
NSubjectGetVoice Function
NSubjectGetVoiceCapacity Function
NSubjectGetVoiceCount Function
NSubjectGetVoices Function
NSubjectInsertFace Function
NSubjectInsertFinger Function
NSubjectInsertIris Function
NSubjectInsertMissingEye Function
NSubjectInsertMissingFinger Function
NSubjectInsertPalm Function
NSubjectInsertRelatedSubject Function
NSubjectInsertSignature Function
NSubjectInsertVoice Function
NSubjectIsMultipleSubjects Function
NSubjectRemoveFaceAt Function
NSubjectRemoveFacesCollectionChanged Function
NSubjectRemoveFacesCollectionChangedCallback Function
NSubjectRemoveFingerAt Function
NSubjectRemoveFingersCollectionChanged Function
NSubjectRemoveFingersCollectionChangedCallback Function
NSubjectRemoveIrisAt Function
NSubjectRemoveIrisesCollectionChanged Function
NSubjectRemoveIrisesCollectionChangedCallback Function
NSubjectRemoveMissingEyeAt Function
NSubjectRemoveMissingFingerAt Function
NSubjectRemovePalmAt Function
NSubjectRemovePalmsCollectionChanged Function
NSubjectRemovePalmsCollectionChangedCallback Function
NSubjectRemoveRelatedSubjectAt Function
NSubjectRemoveRelatedSubjectsCollectionChanged Function
NSubjectRemoveRelatedSubjectsCollectionChangedCallback Function
NSubjectRemoveSignatureAt Function
NSubjectRemoveSignaturesCollectionChanged Function
NSubjectRemoveSignaturesCollectionChangedCallback Function
NSubjectRemoveVoiceAt Function
NSubjectRemoveVoicesCollectionChanged Function
NSubjectRemoveVoicesCollectionChangedCallback Function
NSubjectSetFace Function
NSubjectSetFaceCapacity Function
NSubjectSetFinger Function
NSubjectSetFingerCapacity Function
NSubjectSetGender Function
NSubjectSetId Function
NSubjectSetIris Function
NSubjectSetIrisCapacity Function
NSubjectSetMissingEye Function
NSubjectSetMissingEyeCapacity Function
NSubjectSetMissingFinger Function
NSubjectSetMissingFingerCapacity Function
NSubjectSetMultipleSubjects Function
NSubjectSetPalm Function
NSubjectSetPalmCapacity Function
NSubjectSetQueryString Function
NSubjectSetRelatedSubject Function
NSubjectSetRelatedSubjectCapacity Function
NSubjectSetSignature Function
NSubjectSetSignatureCapacity Function
NSubjectSetTemplate Function
NSubjectSetTemplateAN Function
NSubjectSetTemplateBuffer Function
NSubjectSetTemplateBufferWithFormat Function
NSubjectSetTemplateCbeff Function
NSubjectSetTemplateFC Function
NSubjectSetTemplateFI Function
NSubjectSetTemplateFM Function
NSubjectSetTemplateFMC Function
NSubjectSetTemplateII Function
NSubjectSetVoice Function
NSubjectSetVoiceCapacity Function
NSubjectToANTemplate Function
NSubjectToFCRecord Function
NSubjectToFIRecord Function
NSubjectToFMCRecord Function
NSubjectToFMRecord Function
NSubjectToFMRecordEx Function
NSubjectToIIRecord Function
Collapse Expand Macros
NSubjectCreateFromFile Macro
NSubjectCreateFromFileWithFormat Macro
NSubjectSetId Macro
NSubjectSetQueryString Macro
Collapse Expand Files
NSubject.h
Collapse Expand NTemplate Unit
Collapse Expand Functions
NTemplateCheck Function
NTemplateCheckN Function
NTemplateCreateFromMemory Function
NTemplateCreateFromMemoryN Function
NTemplateGetFacesEx Function
NTemplateGetFingersEx Function
NTemplateGetIrisesEx Function
NTemplateGetPalmsEx Function
NTemplateGetSizeMem Function
NTemplateGetVoicesEx Function
NTemplateMerge Function
NTemplatePack Function
NTemplateSetFaces Function
NTemplateSetFingers Function
NTemplateSetIrises Function
NTemplateClear Function
NTemplateSetPalms Function
NTemplateSetVoices Function
NTemplateCalculateSize Function
NTemplateUnpack Function
NTemplateCreateEx Function
HNTemplate
Collapse Expand Files
NTemplate.h
Collapse Expand NCore Library
Collapse Expand NArray Unit
Collapse Expand Functions
NArrayCopyTo Function
NArrayCopyToBooleanArray Function
NArrayCopyToByteArray Function
NArrayCopyToCharArray Function
NArrayCopyToDoubleArray Function
NArrayCopyToInt16Array Function
NArrayCopyToInt32Array Function
NArrayCopyToInt64Array Function
NArrayCopyToObjectArray Function
NArrayCopyToObjectArrayP Function
NArrayCopyToP Function
NArrayCopyToPointerArray Function
NArrayCopyToResultArray Function
NArrayCopyToSByteArray Function
NArrayCopyToSSizeTypeArray Function
NArrayCopyToSingleArray Function
NArrayCopyToSizeTypeArray Function
NArrayCopyToStringArray Function
NArrayCopyToUInt16Array Function
NArrayCopyToUInt32Array Function
NArrayCopyToUInt64Array Function
NArrayCreate Function
NArrayCreateCustom Function
NArrayCreateFromBooleanArray Function
NArrayCreateFromByteArray Function
NArrayCreateFromCharArray Function
NArrayCreateFromDoubleArray Function
NArrayCreateFromInt16Array Function
NArrayCreateFromInt32Array Function
NArrayCreateFromInt64Array Function
NArrayCreateFromObjectArray Function
NArrayCreateFromObjectArrayP Function
NArrayCreateFromPointerArray Function
NArrayCreateFromResultArray Function
NArrayCreateFromSByteArray Function
NArrayCreateFromSSizeTypeArray Function
NArrayCreateFromSingleArray Function
NArrayCreateFromSizeTypeArray Function
NArrayCreateFromStringArray Function
NArrayCreateFromUInt16Array Function
NArrayCreateFromUInt32Array Function
NArrayCreateFromUInt64Array Function
NArrayCreateP Function
NArrayGetLength Function
NArrayGetValue Function
NArrayGetValueAs Function
NArrayGetValueAsBoolean Function
NArrayGetValueAsByte Function
NArrayGetValueAsChar Function
NArrayGetValueAsDouble Function
NArrayGetValueAsInt16 Function
NArrayGetValueAsInt32 Function
NArrayGetValueAsInt64 Function
NArrayGetValueAsObject Function
NArrayGetValueAsObjectP Function
NArrayGetValueAsP Function
NArrayGetValueAsPointer Function
NArrayGetValueAsResult Function
NArrayGetValueAsSByte Function
NArrayGetValueAsSSizeType Function
NArrayGetValueAsSingle Function
NArrayGetValueAsSizeType Function
NArrayGetValueAsString Function
NArrayGetValueAsUInt16 Function
NArrayGetValueAsUInt32 Function
NArrayGetValueAsUInt64 Function
Collapse Expand Macros
NArrayCopyToCharArray Macro
NArrayCreateFromCharArray Macro
NArrayCreateFromStringArray Macro
NArrayGetValueAsChar Macro
Collapse Expand Files
NArray.h
Collapse Expand NArrayCollection Unit
Collapse Expand Functions
NArrayCollectionAdd Function
NArrayCollectionAddItemRange Function
NArrayCollectionAddRange Function
NArrayCollectionClear Function
NArrayCollectionContains Function
NArrayCollectionGet Function
NArrayCollectionGetBaseCount Function
NArrayCollectionGetCount Function
NArrayCollectionIndexOf Function
NArrayCollectionInsert Function
NArrayCollectionInsertItemRange Function
NArrayCollectionInsertRange Function
NArrayCollectionIsReadOnly Function
NArrayCollectionRemove Function
NArrayCollectionRemoveAt Function
NArrayCollectionRemoveRange Function
NArrayCollectionSet Function
NArrayCollectionToArray Function
NArrayCollectionToItemArray Function
Collapse Expand Files
NArrayCollection.h
Collapse Expand NArrayCollectionInfo Unit
Collapse Expand Functions
NArrayCollectionInfoGetAddMethod Function
NArrayCollectionInfoGetAddRangeMethod Function
NArrayCollectionInfoGetBaseCollection Function
NArrayCollectionInfoGetClearMethod Function
NArrayCollectionInfoGetGetCountMethod Function
NArrayCollectionInfoGetGetMethod Function
NArrayCollectionInfoGetIndexOfMethod Function
NArrayCollectionInfoGetInsertMethod Function
NArrayCollectionInfoGetInsertRangeMethod Function
NArrayCollectionInfoGetItemAttributes Function
NArrayCollectionInfoGetItemFormat Function
NArrayCollectionInfoGetItemMaxValue Function
NArrayCollectionInfoGetItemMinValue Function
NArrayCollectionInfoGetItemStdValue Function
NArrayCollectionInfoGetItemStdValueCount Function
NArrayCollectionInfoGetItemStdValues Function
NArrayCollectionInfoGetItemType Function
NArrayCollectionInfoGetRemoveAtMethod Function
NArrayCollectionInfoGetRemoveMethod Function
NArrayCollectionInfoGetRemoveRangeMethod Function
NArrayCollectionInfoGetSetMethod Function
NArrayCollectionInfoGetToArrayMethod Function
Collapse Expand Files
NArrayCollectionInfo.h
Collapse Expand NAsyncOperation Unit
Collapse Expand Functions
NAsyncOperationAddCompleted Function
NAsyncOperationAddCompletedCallback Function
NAsyncOperationCancel Function
NAsyncOperationGetError Function
NAsyncOperationGetResult Function
NAsyncOperationGetStatus Function
NAsyncOperationIsCanceled Function
NAsyncOperationIsCompleted Function
NAsyncOperationIsFaulted Function
NAsyncOperationRemoveCompleted Function
NAsyncOperationRemoveCompletedCallback Function
NAsyncOperationWait Function
NAsyncOperationWaitAll Function
NAsyncOperationWaitAllTimed Function
NAsyncOperationWaitAny Function
NAsyncOperationWaitAnyTimed Function
NAsyncOperationWaitTimed Function
Collapse Expand Structs, Records, Enums
NAsyncStatus Enumeration
Collapse Expand Files
NAsyncOperation.h
Collapse Expand NBinaryReader Unit
Collapse Expand Functions
NBinaryReaderCreate Function
NBinaryReaderCreateWithEncoding Function
NBinaryReaderGetBaseStream Function
NBinaryReaderGetByteOrder Function
NBinaryReaderGetNull Function
NBinaryReaderGetPosition Function
NBinaryReaderPeekChar Function
NBinaryReaderRead Function
NBinaryReaderReadBoolean Function
NBinaryReaderReadByte Function
NBinaryReaderReadBytesDst Function
NBinaryReaderReadBytesDstN Function
NBinaryReaderReadBytesN Function
NBinaryReaderReadChar Function
NBinaryReaderReadChars Function
NBinaryReaderReadCharsDst Function
NBinaryReaderReadDouble Function
NBinaryReaderReadInt16 Function
NBinaryReaderReadInt32 Function
NBinaryReaderReadInt64 Function
NBinaryReaderReadSByte Function
NBinaryReaderReadSingle Function
NBinaryReaderReadUInt16 Function
NBinaryReaderReadUInt32 Function
NBinaryReaderReadUInt64 Function
NBinaryReaderSeek Function
NBinaryReaderSetPosition Function
Collapse Expand Macros
NBinaryReaderPeekChar Macro
NBinaryReaderRead Macro
NBinaryReaderReadChar Macro
NBinaryReaderReadChars Macro
NBinaryReaderReadCharsDst Macro
Collapse Expand NBinaryWriter Unit
Collapse Expand Functions
NBinaryWriterCreate Function
NBinaryWriterCreateWithEncoding Function
NBinaryWriterFlush Function
NBinaryWriterGetBaseStream Function
NBinaryWriterGetByteOrder Function
NBinaryWriterGetNull Function
NBinaryWriterGetPosition Function
NBinaryWriterSeek Function
NBinaryWriterSetPosition Function
NBinaryWriterWriteBoolean Function
NBinaryWriterWriteByte Function
NBinaryWriterWriteBytes Function
NBinaryWriterWriteBytesN Function
NBinaryWriterWriteChar Function
NBinaryWriterWriteChars Function
NBinaryWriterWriteDouble Function
NBinaryWriterWriteInt16 Function
NBinaryWriterWriteInt32 Function
NBinaryWriterWriteInt64 Function
NBinaryWriterWriteSByte Function
NBinaryWriterWriteSingle Function
NBinaryWriterWriteUInt16 Function
NBinaryWriterWriteUInt32 Function
NBinaryWriterWriteUInt64 Function
Collapse Expand Macros
NBinaryWriterWriteChar Macro
NBinaryWriterWriteChars Macro
Collapse Expand NBuffer Unit
Collapse Expand Functions
NBufferCopy Function
NBufferCopyFromPtr Function
NBufferCopyTo Function
NBufferCopyToPtr Function
NBufferCopyToPtrRange Function
NBufferCreate Function
NBufferCreateFromBuffer Function
NBufferCreateFromPtr Function
NBufferCreateFromPtrEx Function
NBufferCreateFromPtrWithFree Function
NBufferCreateFromPtrWithFreeProc Function
NBufferGetEmpty Function
NBufferGetPtr Function
NBufferGetSize Function
NBufferToPtr Function
Collapse Expand Macros
NBufferCreateFromConstPtr Macro
Collapse Expand Files
NBuffer.h
Collapse Expand NBufferedStream Unit
Collapse Expand Functions
NBufferedStreamCreate Function
NBufferedStreamCreateWithBufferSize Function
Collapse Expand Files
NBufferedStream.h
Collapse Expand NCallback Unit
Collapse Expand Functions
NCallbackClone Function
NCallbackCreateCustomRaw Function
NCallbackCreateRaw Function
NCallbackCreateWithObjectRaw Function
NCallbackEquals Function
NCallbackFree Function
NCallbackGetHashCode Function
NCallbackGetParam Function
NCallbackGetProcRaw Function
NCallbackSet Function
Collapse Expand Macros
NCallbackCreate Macro
NCallbackCreateCustom Macro
NCallbackGetProc Macro
NCallbackInvoke0 Macro
NCallbackInvoke1 Macro
NCallbackInvoke2 Macro
NCallbackInvoke3 Macro
NCallbackInvoke4 Macro
NCallbackInvoke5 Macro
NCallbackInvoke6 Macro
NCallbackInvoke7 Macro
NCallbackInvoke8 Macro
NCallbackInvoke9 Macro
NCallbackInvokeRaw Macro
Collapse Expand Files
NCallback.h
Collapse Expand NCollection Unit
Collapse Expand Functions
NCollectionAdd Function
NCollectionAddCollectionChanged Function
NCollectionAddCollectionChangedCallback Function
NCollectionAddItemCollectionChanged Function
NCollectionAddItemCollectionChangedCallback Function
NCollectionAddItemRange Function
NCollectionAddRange Function
NCollectionClear Function
NCollectionContains Function
NCollectionGet Function
NCollectionGetCapacity Function
NCollectionGetCount Function
NCollectionIndexOf Function
NCollectionInsert Function
NCollectionInsertItemRange Function
NCollectionInsertRange Function
NCollectionIsReadOnly Function
NCollectionRemove Function
NCollectionRemoveAt Function
NCollectionRemoveCollectionChanged Function
NCollectionRemoveCollectionChangedCallback Function
NCollectionRemoveItemCollectionChanged Function
NCollectionRemoveItemCollectionChangedCallback Function
NCollectionRemoveRange Function
NCollectionSet Function
NCollectionSetCapacity Function
NCollectionToArray Function
NCollectionToItemArray Function
N_DECLARE_TYPE Function
Collapse Expand Structs, Records, Enums
NCollectionChangedAction Enumeration
Collapse Expand Files
NCollection.h
Collapse Expand NCollectionInfo Unit
Collapse Expand Functions
NCollectionInfoGetAddCollectionChangedCallbackMethod Function
NCollectionInfoGetAddCollectionChangedMethod Function
NCollectionInfoGetAddMethod Function
NCollectionInfoGetAddRangeMethod Function
NCollectionInfoGetClearMethod Function
NCollectionInfoGetGetCapacityMethod Function
NCollectionInfoGetGetCountMethod Function
NCollectionInfoGetGetMethod Function
NCollectionInfoGetIndexOfMethod Function
NCollectionInfoGetInsertMethod Function
NCollectionInfoGetInsertRangeMethod Function
NCollectionInfoGetItemAttributes Function
NCollectionInfoGetItemFormat Function
NCollectionInfoGetItemMaxValue Function
NCollectionInfoGetItemMinValue Function
NCollectionInfoGetItemStdValue Function
NCollectionInfoGetItemStdValueCount Function
NCollectionInfoGetItemStdValues Function
NCollectionInfoGetItemType Function
NCollectionInfoGetRemoveAtMethod Function
NCollectionInfoGetRemoveCollectionChangedCallbackMethod Function
NCollectionInfoGetRemoveCollectionChangedMethod Function
NCollectionInfoGetRemoveMethod Function
NCollectionInfoGetRemoveRangeMethod Function
NCollectionInfoGetSetCapacityMethod Function
NCollectionInfoGetSetMethod Function
NCollectionInfoGetToArrayMethod Function
Collapse Expand Files
NCollectionInfo.h
Collapse Expand NConsole Unit
Collapse Expand Functions
NConsoleGetError Function
NConsoleGetIn Function
NConsoleGetOut Function
NConsoleReadChar Function
NConsoleReadLine Function
NConsoleSetError Function
NConsoleSetIn Function
NConsoleSetOut Function
NConsoleWrite Function
NConsoleWriteBoolean Function
NConsoleWriteBooleanLine Function
NConsoleWriteChar Function
NConsoleWriteCharLine Function
NConsoleWriteChars Function
NConsoleWriteCharsLine Function
NConsoleWriteDouble Function
NConsoleWriteDoubleLine Function
NConsoleWriteEmptyLine Function
NConsoleWriteFormat Function
NConsoleWriteFormatLine Function
NConsoleWriteFormatLineVA Function
NConsoleWriteFormatVA Function
NConsoleWriteInt32 Function
NConsoleWriteInt32Line Function
NConsoleWriteInt64 Function
NConsoleWriteInt64Line Function
NConsoleWriteLine Function
NConsoleWriteObject Function
NConsoleWriteObjectLine Function
NConsoleWritePointer Function
NConsoleWritePointerLine Function
NConsoleWriteResult Function
NConsoleWriteResultLine Function
NConsoleWriteSSizeType Function
NConsoleWriteSSizeTypeLine Function
NConsoleWriteSingle Function
NConsoleWriteSingleLine Function
NConsoleWriteSizeType Function
NConsoleWriteSizeTypeLine Function
NConsoleWriteUInt32 Function
NConsoleWriteUInt32Line Function
NConsoleWriteUInt64 Function
NConsoleWriteUInt64Line Function
NConsoleWriteValue Function
NConsoleWriteValueLine Function
NConsoleWriteValueLineP Function
NConsoleWriteValueP Function
Collapse Expand Macros
NConsoleReadChar Macro
NConsoleWrite Macro
NConsoleWriteChar Macro
NConsoleWriteCharLine Macro
NConsoleWriteChars Macro
NConsoleWriteCharsLine Macro
NConsoleWriteFormat Macro
NConsoleWriteFormatLine Macro
NConsoleWriteFormatLineVA Macro
NConsoleWriteFormatVA Macro
NConsoleWriteLine Macro
Collapse Expand NConstantInfo Unit
Collapse Expand Functions
NConstantInfoGetConstantType Function
NConstantInfoGetValue Function
Collapse Expand Files
NConstantInfo.h
Collapse Expand NCore Unit
Collapse Expand Functions
NCoreAddErrorSuppressedCallback Function
NCoreAddErrorSuppressed Function
NCoreOnExitEx Function
NCoreOnStart Function
NCoreRemoveErrorSuppressed Function
NCoreOnThreadExit Function
NCoreOnThreadStart Function
NCoreRemoveErrorSuppressedCallback Function
Collapse Expand Files
NCore.h
Collapse Expand NCustomEventDescriptor Unit
Collapse Expand Functions
NCustomEventDescriptorGetData Function
Collapse Expand Files
NCustomEventDescriptor.h
Collapse Expand NCustomMethodDescriptor Unit
Collapse Expand Functions
NCustomMethodDescriptorGetData Function
Collapse Expand Files
NCustomMethodDescriptor.h
Collapse Expand NCustomParameterDescriptor Unit
Collapse Expand Functions
NCustomParameterDescriptorCreate Function
NCustomParameterDescriptorGetData Function
Collapse Expand Files
NCustomParameterDescriptor.h
Collapse Expand NCustomPropertyDescriptor Unit
Collapse Expand Functions
NCustomPropertyDescriptorGetData Function
Collapse Expand Files
NCustomPropertyDescriptor.h
Collapse Expand NCustomStream Unit
Collapse Expand Functions
NCustomStreamCreate Function
Collapse Expand NDateTime Type
Collapse Expand Functions
NDateTimeAddDays Function
NDateTimeAddHours Function
NDateTimeAddMilliseconds Function
NDateTimeAddMinutes Function
NDateTimeAddMonths Function
NDateTimeAddSeconds Function
NDateTimeAddTicks Function
NDateTimeAddTimeSpan Function
NDateTimeAddYears Function
NDateTimeCompare Function
NDateTimeCreate Function
NDateTimeCreateDate Function
NDateTimeCreateFromTicks Function
NDateTimeDaysInMonth Function
NDateTimeDecode Function
NDateTimeGetDate Function
NDateTimeGetDay Function
NDateTimeGetDayOfWeek Function
NDateTimeGetDayOfYear Function
NDateTimeGetHour Function
NDateTimeGetMillisecond Function
NDateTimeGetMinute Function
NDateTimeGetMonth Function
NDateTimeGetNow Function
NDateTimeGetSecond Function
NDateTimeGetTicks Function
NDateTimeGetTimeOfDay Function
NDateTimeGetToday Function
NDateTimeGetUtcNow Function
NDateTimeGetYear Function
NDateTimeIsDateTimeValid Function
NDateTimeIsDateValid Function
NDateTimeIsLeapYear Function
NDateTimeIsValid Function
NDateTimeSubtract Function
NDateTimeSubtractTimeSpan Function
NDateTimeToLocalTime Function
NDateTimeToString Function
NDateTimeToUniversalTime Function
Collapse Expand Structs, Records, Enums
NDayOfWeek Enumeration
Collapse Expand Types
NDateTime_ Type
Collapse Expand Macros
NDateTimeToString Macro
N_DATE_TIME_MAX Macro
N_DATE_TIME_MIN Macro
Collapse Expand NDefs Unit
Collapse Expand Macros
N_64 Macro
N_ALIGN Macro
N_ANSI_C Macro
N_API Macro
N_API_PTR_RET Macro
N_AW Macro
N_BIG_ENDIAN Macro
N_CALLBACK Macro
N_CALLBACK_AW Macro
N_CALL_CONV Macro
N_CPP Macro
N_DEBUG Macro
N_DEPRECATED Macro
N_EMPTY_STRING Macro
N_EMPTY_STRINGA Macro
N_EMPTY_STRINGW Macro
N_FIELD_AW Macro
N_FUNC_AW Macro
N_GCC Macro
N_JOIN_SYMBOLS Macro
N_JOIN_SYMBOLS2 Macro
N_JOIN_SYMBOLS2_ Macro
N_JOIN_SYMBOLS_ Macro
N_LIB Macro
N_LIKELY Macro
N_LINUX Macro
N_MAC Macro
N_MACRO_AW Macro
N_MSVC Macro
N_NEW_LINE Macro
N_NO_ANSI_FUNC Macro
N_NO_INLINE Macro
N_NO_INT_64 Macro
N_NO_RETURN Macro
N_NO_THROW Macro
N_NO_UNICODE Macro
N_PACKED Macro
N_RETURN_ADDRESS Macro
N_STATIC_ASSERT Macro
N_STRINGIZE Macro
N_STRINGIZEA Macro
N_STRINGIZEW Macro
N_STRINGIZE_ Macro
N_STRINGIZE_A Macro
N_STRINGIZE_W Macro
N_STRUCT_AW Macro
N_SYMBOL_AW Macro
N_T Macro
N_TA Macro
N_TRACE Macro
N_TW Macro
N_TYPE_AW Macro
N_T_A Macro
N_T_W Macro
N_UNICODE Macro
N_UNLIKELY Macro
N_VAR_AW Macro
N_WINDOWS Macro
Collapse Expand NDescriptor Unit
Collapse Expand Functions
NDescriptorGetAttributes Function
NDescriptorGetName Function
Collapse Expand Files
NDescriptor.h
Collapse Expand NDictionary Unit
Collapse Expand Functions
NDictionaryAdd Function
NDictionaryAddCollectionChanged Function
NDictionaryAddCollectionChangedCallback Function
NDictionaryAddItemCollectionChanged Function
NDictionaryAddItemCollectionChangedCallback Function
NDictionaryAddItemPair Function
NDictionaryAddPair Function
NDictionaryClear Function
NDictionaryContains Function
NDictionaryGet Function
NDictionaryGetAt Function
NDictionaryGetCount Function
NDictionaryGetItemAt Function
NDictionaryGetKey Function
NDictionaryGetKeys Function
NDictionaryGetValue Function
NDictionaryGetValues Function
NDictionaryIsReadOnly Function
NDictionaryRemove Function
NDictionaryRemoveAt Function
NDictionaryRemoveCollectionChanged Function
NDictionaryRemoveCollectionChangedCallback Function
NDictionaryRemoveItemCollectionChanged Function
NDictionaryRemoveItemCollectionChangedCallback Function
NDictionarySet Function
NDictionaryToArray Function
NDictionaryToItemArray Function
NDictionaryToKeyArray Function
NDictionaryToValueArray Function
NDictionaryTryGet Function
Collapse Expand Files
NDictionary.h
Collapse Expand NDictionaryInfo Unit
Collapse Expand Functions
NDictionaryInfoGetAddCollectionChangedCallbackMethod Function
NDictionaryInfoGetAddCollectionChangedMethod Function
NDictionaryInfoGetAddMethod Function
NDictionaryInfoGetAddPairMethod Function
NDictionaryInfoGetClearMethod Function
NDictionaryInfoGetContainsMethod Function
NDictionaryInfoGetGetAtMethod Function
NDictionaryInfoGetGetCountMethod Function
NDictionaryInfoGetGetKeyMethod Function
NDictionaryInfoGetGetMethod Function
NDictionaryInfoGetGetValueMethod Function
NDictionaryInfoGetItemAttributes Function
NDictionaryInfoGetItemType Function
NDictionaryInfoGetKeyAttributes Function
NDictionaryInfoGetKeyFormat Function
NDictionaryInfoGetKeyMaxValue Function
NDictionaryInfoGetKeyMinValue Function
NDictionaryInfoGetKeyStdValue Function
NDictionaryInfoGetKeyStdValueCount Function
NDictionaryInfoGetKeyStdValues Function
NDictionaryInfoGetKeyType Function
NDictionaryInfoGetRemoveAtMethod Function
NDictionaryInfoGetRemoveCollectionChangedCallbackMethod Function
NDictionaryInfoGetRemoveCollectionChangedMethod Function
NDictionaryInfoGetRemoveMethod Function
NDictionaryInfoGetSetMethod Function
NDictionaryInfoGetToArrayMethod Function
NDictionaryInfoGetToKeyArrayMethod Function
NDictionaryInfoGetToValueArrayMethod Function
NDictionaryInfoGetTryGetMethod Function
NDictionaryInfoGetValueAttributes Function
NDictionaryInfoGetValueFormat Function
NDictionaryInfoGetValueMaxValue Function
NDictionaryInfoGetValueMinValue Function
NDictionaryInfoGetValueStdValue Function
NDictionaryInfoGetValueStdValueCount Function
NDictionaryInfoGetValueStdValues Function
NDictionaryInfoGetValueType Function
Collapse Expand Files
NDictionaryInfo.h
Collapse Expand NDirectory Unit
Collapse Expand Functions
NDirectoryExists Function
Collapse Expand Macros
NDirectoryExists Macro
Collapse Expand NEncoding Enumeration
Collapse Expand Functions
NEncodingConvert Function
NEncodingDetect Function
NEncodingGetBytes Function
NEncodingGetBytesForChars Function
NEncodingGetChars Function
NEncodingGetMaxByteCount Function
NEncodingGetMaxCharCount Function
NEncodingGetMinBytesPerChar Function
NEncodingGetPreamble Function
NEncodingGetPreambleLength Function
NEncodingGetStringN Function
NEncodingIsSingleByte Function
NEncodingIsValid Function
Collapse Expand Structs, Records, Enums
NEncoding_ Enumeration
Collapse Expand Macros
NEncodingGetBytes Macro
NEncodingGetBytesForChars Macro
NEncodingGetChars Macro
NEncodingGetMaxByteCount Macro
NEncodingGetMaxCharCount Macro
N_ACHAR_ENCODING Macro
N_CHAR_ENCODING Macro
N_WCHAR_ENCODING Macro
Collapse Expand NEnum Unit
Collapse Expand Functions
NEnumGetValues Function
NEnumParseN Function
NEnumParseP Function
NEnumToStringN Function
NEnumToStringP Function
NEnumTryParseN Function
NEnumTryParseP Function
Collapse Expand NEnumConstantInfo Unit
Collapse Expand Functions
NEnumConstantInfoGetValue Function
Collapse Expand Files
NEnumConstantInfo.h
Collapse Expand NEnvironment Unit
Collapse Expand Functions
NEnvironmentGetCallStack Function
NEnvironmentGetCurrentDirectory Function
NEnvironmentGetSystemDirectory Function
Collapse Expand Files
NEnvironment.h
Collapse Expand NError Unit
Collapse Expand Functions
NCallStackEntryCopy Function
NCallStackEntryCreate Function
NCallStackEntryDispose Function
NCallStackEntrySet Function
NErrorAppend Function
NErrorCapture Function
NErrorCreate Function
NErrorGetCallStackCount Function
NErrorGetCallStackEntry Function
NErrorGetCallStackN Function
NErrorGetCodeEx Function
NErrorGetDefaultMessageN Function
NErrorGetExternalCallStackN Function
NErrorGetExternalErrorEx Function
NErrorGetInnerErrorAt Function
NErrorGetInnerErrorCount Function
NErrorGetInnerErrorEx Function
NErrorGetLastEx Function
NErrorGetLastSysError Function
NErrorGetLastWin32Error Function
NErrorGetMacErrorMessageN Function
NErrorGetMachErrorMessageN Function
NErrorGetMessageN Function
NErrorGetParamN Function
NErrorGetSysErrorMessageN Function
NErrorGetWin32ErrorMessageN Function
NErrorRaise Function
NErrorReport Function
NErrorReportEx Function
NErrorSetCom Function
NErrorSetComMPN Function
NErrorSetComN Function
NErrorSetComPN Function
NErrorSetLast Function
NErrorSetLastEx Function
NErrorSetLastMPN Function
NErrorSetLastN Function
NErrorSetLastPN Function
NErrorSetMac Function
NErrorSetMacMPN Function
NErrorSetMacN Function
NErrorSetMacPN Function
NErrorSetMach Function
NErrorSetMachMPN Function
NErrorSetMachN Function
NErrorSetMachPN Function
NErrorSetSys Function
NErrorSetSysMPN Function
NErrorSetSysN Function
NErrorSetSysPN Function
NErrorSetWin32 Function
NErrorSetWin32MPN Function
NErrorSetWin32N Function
NErrorSetWin32PN Function
NErrorSuppress Function
Collapse Expand Structs, Records, Enums
NCallStackEntry_ Structure
Collapse Expand Macros
N_E_ARGUMENT Macro
NCallStackEntryCreate Macro
N_E_ARGUMENT_NULL Macro
NE_IS_DIRECTORY_ACCESS Macro
N_E_ARGUMENT_OUT_OF_RANGE Macro
NE_MERGE_CALL_STACK Macro
N_E_CLR Macro
NE_NO_CALL_STACK Macro
N_E_COM Macro
NE_PRESERVE_INNER_ERROR Macro
N_E_CORE Macro
NE_SKIP_ONE_FRAME Macro
N_E_END_OF_STREAM Macro
NErrorAppend Macro
N_E_EXTERNAL Macro
NErrorSetCom Macro
N_E_FAILED Macro
NErrorSetComMPN Macro
N_E_FORMAT Macro
NErrorSetComPN Macro
N_E_INDEX_OUT_OF_RANGE Macro
NErrorSetLast Macro
N_E_INVALID_OPERATION Macro
NErrorSetLastMPN Macro
N_E_IO Macro
NErrorSetLastPN Macro
N_E_NOT_ACTIVATED Macro
NErrorSetMac Macro
N_E_NOT_IMPLEMENTED Macro
NErrorSetMacMPN Macro
NErrorSetMacPN Macro
N_E_NOT_SUPPORTED Macro
NErrorSetMach Macro
N_E_NULL_REFERENCE Macro
NErrorSetMachMPN Macro
N_E_OUT_OF_MEMORY Macro
NErrorSetMachPN Macro
N_E_OVERFLOW Macro
NErrorSetSys Macro
NErrorSetSysMPN Macro
NErrorSetSysPN Macro
N_E_SYS Macro
NErrorSetWin32 Macro
N_E_WIN32 Macro
NErrorSetWin32MPN Macro
NErrorSetWin32PN Macro
N_OK Macro
N_E_ABANDONED_MUTEX Macro
N_E_AGGREGATE Macro
NFailed Macro
NSucceeded Macro
N_E_ARITHMETIC Macro
N_E_BAD_IMAGE_FORMAT Macro
N_E_CPP Macro
N_E_DIRECTORY_NOT_FOUND Macro
N_E_DLL_NOT_FOUND Macro
N_E_DRIVE_NOT_FOUND Macro
N_E_ENTRY_POINT_NOT_FOUND Macro
N_E_FILE_FORMAT Macro
N_E_FILE_LOAD Macro
N_E_FILE_NOT_FOUND Macro
N_E_INVALID_CAST Macro
N_E_INVALID_ENUM_ARGUMENT Macro
N_E_JVM Macro
N_E_KEY_NOT_FOUND Macro
N_E_MAC Macro
N_E_OPERATION_CANCELED Macro
N_E_PATH_TOO_LONG Macro
N_E_SECURITY Macro
N_E_SOCKET Macro
N_E_TIMEOUT Macro
Collapse Expand Files
NError.h
Collapse Expand NEvent Unit
Collapse Expand Functions
NEventAddN Function
NEventAddRaw Function
NEventDispose Function
NEventGetCallbacks Function
NEventInit Function
NEventIsEmpty Function
NEventReleaseCallbacks Function
NEventRemoveN Function
NEventRemoveRaw Function
Collapse Expand Macros
NEventAdd Macro
NEventRemove Macro
N_EVENT_RAISE_1 Macro
N_EVENT_RAISE_2 Macro
N_EVENT_RAISE_3 Macro
N_EVENT_RAISE_4 Macro
N_EVENT_RAISE_5 Macro
N_EVENT_RAISE_6 Macro
N_EVENT_RAISE_RAW Macro
N_EVENT_SIZE Macro
Collapse Expand Files
NEvent.h
Collapse Expand NEventDescriptor Unit
Collapse Expand Functions
NEventDescriptorAddHandler Function
NEventDescriptorGetEventType Function
NEventDescriptorRemoveHandler Function
Collapse Expand Files
NEventDescriptor.h
Collapse Expand NEventInfo Unit
Collapse Expand Functions
NEventInfoAddHandler Function
NEventInfoGetAddCallbackMethod Function
NEventInfoGetAddMethod Function
NEventInfoGetEventType Function
NEventInfoGetRemoveCallbackMethod Function
NEventInfoGetRemoveMethod Function
NEventInfoRemoveHandler Function
Collapse Expand Files
NEventInfo.h
Collapse Expand NExpandableObject Unit
Collapse Expand Functions
NExpandableObjectGetProperties Function
Collapse Expand Files
NExpandableObject.h
Collapse Expand NFile Unit
Collapse Expand Functions
NFileAppendAllLines Function
NFileAppendAllLinesPN Function
NFileAppendAllLinesWithEncoding Function
NFileAppendAllLinesWithEncodingPN Function
NFileAppendAllText Function
NFileAppendAllTextPN Function
NFileAppendAllTextWithEncoding Function
NFileAppendAllTextWithEncodingPN Function
NFileAppendText Function
NFileCreate Function
NFileCreateText Function
NFileCreateWithBufferSize Function
NFileDelete Function
NFileExists Function
NFileGetAttributes Function
NFileOpen Function
NFileOpenRead Function
NFileOpenText Function
NFileOpenWithAccess Function
NFileOpenWithAccessAndShare Function
NFileOpenWrite Function
NFileReadAllBytesCN Function
NFileReadAllBytesN Function
NFileReadAllLinesCN Function
NFileReadAllLinesN Function
NFileReadAllLinesWithEncodingCN Function
NFileReadAllLinesWithEncodingN Function
NFileReadAllTextCN Function
NFileReadAllTextN Function
NFileReadAllTextWithEncodingCN Function
NFileReadAllTextWithEncodingN Function
NFileWriteAllBytes Function
NFileWriteAllBytesCN Function
NFileWriteAllBytesPN Function
NFileWriteAllLines Function
NFileWriteAllLinesPN Function
NFileWriteAllLinesWithEncoding Function
NFileWriteAllLinesWithEncodingPN Function
NFileWriteAllText Function
NFileWriteAllTextCN Function
NFileWriteAllTextPN Function
NFileWriteAllTextWithEncoding Function
NFileWriteAllTextWithEncodingPN Function
Collapse Expand Structs, Records, Enums
NFileAttributes Enumeration
Collapse Expand Macros
NFileAppendAllText Macro
NFileAppendAllTextPN Macro
NFileAppendAllTextWithEncoding Macro
NFileAppendAllTextWithEncodingPN Macro
NFileAppendText Macro
NFileCreate Macro
NFileCreateText Macro
NFileCreateWithBufferSize Macro
NFileDelete Macro
NFileExists Macro
NFileGetAttributes Macro
NFileOpen Macro
NFileOpenRead Macro
NFileOpenText Macro
NFileOpenWithAccess Macro
NFileOpenWithAccessAndShare Macro
NFileOpenWrite Macro
NFileReadAllBytesCN Macro
NFileReadAllLinesCN Macro
NFileReadAllLinesWithEncodingCN Macro
NFileReadAllTextCN Macro
NFileReadAllTextWithEncodingCN Macro
NFileWriteAllBytes Macro
NFileWriteAllBytesCN Macro
NFileWriteAllLines Macro
NFileWriteAllLinesPN Macro
NFileWriteAllLinesWithEncoding Macro
NFileWriteAllLinesWithEncodingPN Macro
NFileWriteAllText Macro
NFileWriteAllTextPN Macro
NFileWriteAllTextWithEncoding Macro
NFileWriteAllTextWithEncodingPN Macro
Collapse Expand NFileStream Unit
Collapse Expand Functions
NFileStreamCreate Function
NFileStreamCreateFromOSHandle Function
NFileStreamCreateFromOSHandleWithBufferSize Function
NFileStreamCreateWithAccess Function
NFileStreamCreateWithAccessAndShare Function
NFileStreamCreateWithAccessShareAndBufferSize Function
NFileStreamGetOSHandle Function
Collapse Expand Macros
NFileStreamCreate Macro
NFileStreamCreateWithAccess Macro
NFileStreamCreateWithAccessAndShare Macro
NFileStreamCreateWithAccessShareAndBufferSize Macro
Collapse Expand NInterlocked Unit
Collapse Expand Macros
N_SLOW_INTERLOCKED Macro
Collapse Expand NIOTypes Unit
Collapse Expand Functions
NByteOrderGetSystem Function
NByteOrderIsReverse Function
NByteOrderIsValid Function
NFileAccessIsValid Function
NFileModeIsValid Function
NFileShareIsValid Function
NSeekOriginIsValid Function
Collapse Expand Structs, Records, Enums
NByteOrder Enumeration
NFileAccess Enumeration
NFileMode Enumeration
NFileShare Enumeration
NSeekOrigin Enumeration
Collapse Expand Files
NIOTypes.h
Collapse Expand NList Unit
Collapse Expand Functions
NListAdd Function
NListAddList Function
NListAddRange Function
NListClear Function
NListContains Function
NListCopyTo Function
NListCopyToRange Function
NListDetachArray Function
NListDispose Function
NListGet Function
NListGetCapacity Function
NListGetCount Function
NListGetEnd Function
NListGetPtr Function
NListGetStart Function
NListIndexOf Function
NListIndexOfFrom Function
NListIndexOfInRange Function
NListInit Function
NListInitEx Function
NListInitWithCapacity Function
NListInsert Function
NListInsertList Function
NListInsertRange Function
NListLastIndexOf Function
NListLastIndexOfFrom Function
NListLastIndexOfInRange Function
NListRemove Function
NListRemoveAt Function
NListRemoveRange Function
NListSet Function
NListSetCapacity Function
NListSetCount Function
NListToArray Function
NListToArrayRange Function
Collapse Expand Macros
N_LIST_SIZE Macro
Collapse Expand Files
NList.h
Collapse Expand NListList Unit
Collapse Expand Functions
NListListAdd Function
NListListAddItem Function
NListListAddItemRange Function
NListListAddListList Function
NListListAddListListItems Function
NListListAddRange Function
NListListClear Function
NListListClearItems Function
NListListContainsItem Function
NListListCopyItemsTo Function
NListListCopyItemsToRange Function
NListListDetachItemsArray Function
NListListDispose Function
NListListGetCapacity Function
NListListGetCount Function
NListListGetItem Function
NListListGetItemCapacity Function
NListListGetItemCount Function
NListListGetItemPtr Function
NListListGetItemsEnd Function
NListListGetItemsStart Function
NListListIndexOfItem Function
NListListIndexOfItemFrom Function
NListListIndexOfItemInRange Function
NListListInit Function
NListListInitEx Function
NListListInitWithCapacity Function
NListListInsert Function
NListListInsertItem Function
NListListInsertItemRange Function
NListListInsertListList Function
NListListInsertListListItems Function
NListListInsertRange Function
NListListItemsToArray Function
NListListItemsToArrayRange Function
NListListLastIndexOfItem Function
NListListLastIndexOfItemFrom Function
NListListLastIndexOfItemInRange Function
NListListRemoveAt Function
NListListRemoveItem Function
NListListRemoveItemAt Function
NListListRemoveItemRange Function
NListListRemoveRange Function
NListListSetCapacity Function
NListListSetCount Function
NListListSetItem Function
NListListSetItemCapacity Function
NListListSetItemCount Function
Collapse Expand Macros
N_LIST_LIST_SIZE Macro
Collapse Expand Files
NListList.h
Collapse Expand NMemberDescriptor Unit
Collapse Expand Functions
NMemberDescriptorGetComponentType Function
Collapse Expand Files
NMemberDescriptor.h
Collapse Expand NMemberInfo Unit
Collapse Expand Functions
NMemberInfoGetAttributes Function
NMemberInfoGetDeclaringType Function
NMemberInfoGetId Function
NMemberInfoGetName Function
Collapse Expand Files
NMemberInfo.h
Collapse Expand NMemory Unit
Collapse Expand Functions
NAlignedFree Function
NAlignedOffsetAlloc Function
NAlignedOffsetAllocArray Function
NAlignedOffsetCAlloc Function
NAlignedOffsetCAllocArray Function
NAlignedOffsetReAlloc Function
NAlignedOffsetReAllocArray Function
NAlloc Function
NAllocArray Function
NCAlloc Function
NCAllocArray Function
NClearArray Function
NCompare Function
NCopy Function
NCopyArray Function
NFill Function
NFree Function
NFreeEx Function
NMemoryTypeIsValid Function
NMemoryTypeIsValidForFree Function
NMove Function
NMoveArray Function
NPageAlloc Function
NPageFree Function
NReAlloc Function
NReAllocArray Function
Collapse Expand Structs, Records, Enums
NMemoryType Enumeration
Collapse Expand Macros
NClear Macro
Collapse Expand Files
NMemory.h
Collapse Expand NMemoryStream Unit
Collapse Expand Functions
NMemoryStreamCreate Function
NMemoryStreamCreateFromBuffer Function
NMemoryStreamCreateFromBufferN Function
NMemoryStreamCreateWithCapacity Function
NMemoryStreamGetBuffer Function
NMemoryStreamGetCapacity Function
NMemoryStreamGetPositionPtr Function
NMemoryStreamSetCapacity Function
NMemoryStreamSetPositionPtr Function
NMemoryStreamToPtr Function
NMemoryStreamWriteTo Function
Collapse Expand Macros
NMemoryStreamCreateFromBufferForRead Macro
Collapse Expand NMethodDescriptor Unit
Collapse Expand Functions
NMethodDescriptorGetParameter Function
NMethodDescriptorGetParameterCount Function
NMethodDescriptorGetParameters Function
NMethodDescriptorGetReturnParameter Function
NMethodDescriptorInvoke Function
NMethodDescriptorInvokeWithPropertyBag Function
NMethodDescriptorInvokeWithString Function
Collapse Expand Macros
NMethodDescriptorInvokeWithString Macro
Collapse Expand Files
NMethodDescriptor.h
Collapse Expand NMethodInfo Unit
Collapse Expand Functions
NMethodInfoGetNativeName Function
NMethodInfoGetParameter Function
NMethodInfoGetParameterCount Function
NMethodInfoGetParameters Function
NMethodInfoGetReturnParameter Function
NMethodInfoInvoke Function
NMethodInfoInvokeWithPropertyBag Function
NMethodInfoInvokeWithString Function
Collapse Expand Macros
NMethodInfoInvokeWithString Macro
Collapse Expand Files
NMethodInfo.h
Collapse Expand NModule Unit
Collapse Expand Functions
NModuleCheckInit Function
NModuleCreate Function
NModuleCreateInstance Function
NModuleGetActivatedN Function
NModuleGetCompanyN Function
NModuleGetCopyrightN Function
NModuleGetDefinedType Function
NModuleGetDefinedTypeCount Function
NModuleGetDefinedTypes Function
NModuleGetDependences Function
NModuleGetFileName Function
NModuleGetId Function
NModuleGetLoadedModules Function
NModuleGetNameN Function
NModuleGetNativeId Function
NModuleGetOptions Function
NModuleGetProductN Function
NModuleGetTitleN Function
NModuleGetTypeWithName Function
NModuleGetVersionBuild Function
NModuleGetVersionMajor Function
NModuleGetVersionMinor Function
NModuleGetVersionRevision Function
NModuleLoadFromFile Function
NModuleSetCompany Function
NModuleSetCompanyN Function
NModuleSetCopyright Function
NModuleSetCopyrightN Function
NModuleSetId Function
NModuleSetNameN Function
NModuleSetNativeId Function
NModuleSetOptions Function
NModuleSetProduct Function
NModuleSetProductN Function
NModuleSetTitle Function
NModuleSetTitleN Function
NModuleSetVersionBuild Function
NModuleSetVersionMajor Function
NModuleSetVersionMinor Function
NModuleSetVersionRevision Function
Collapse Expand Structs, Records, Enums
NModuleOptions Enumeration
Collapse Expand Macros
NModuleCreateInstance Macro
NModuleGetTypeWithName Macro
NModuleLoadFromFile Macro
NModuleSetId Macro
NModuleSetName Macro
NModuleSetNativeId Macro
N_DECLARE_MODULE Macro
N_MODULE_OF Macro
Collapse Expand Files
NModule.h
Collapse Expand NModuleInternal Unit
Collapse Expand Functions
NModuleRegister Function
NModuleSetActivatedProc Function
NModuleSetDependences Function
NModuleSetInit Function
NModuleSetLazyInit Function
NModuleSetThreadInit Function
NModuleSetThreadUninit Function
NModuleSetUninit Function
NModuleUnregister Function
Collapse Expand NMonitor Unit
Collapse Expand Functions
NMonitorDispose Function
NMonitorEnter Function
NMonitorExit Function
NMonitorInit Function
NMonitorTryEnter Function
Collapse Expand Macros
N_MONITOR_SIZE Macro
Collapse Expand NMutex Unit
Collapse Expand Functions
NMutexCreate Function
NMutexCreateFromOSHandle Function
NMutexGetOSHandle Function
NMutexRelease Function
NNoDeprecate Unit
Collapse Expand NObject Unit
Collapse Expand Functions
NObjectAddDisposed Function
NObjectAddDisposedCallback Function
NObjectAddHandlerP Function
NObjectAddOwnerChanged Function
NObjectAddOwnerChangedCallback Function
NObjectAddPropertyChanged Function
NObjectAddPropertyChangedCallback Function
NObjectCaptureProperties Function
NObjectClone Function
NObjectCompareTo Function
NObjectCopyProperties Function
NObjectEquals Function
NObjectGet Function
NObjectGetArray Function
NObjectGetConcurrent Function
NObjectGetElements Function
NObjectGetFlags Function
NObjectGetHashCode Function
NObjectGetOwnerEx Function
NObjectGetPropertyN Function
NObjectGetPropertyNN Function
NObjectGetPropertyP Function
NObjectGetSize Function
NObjectGetSizeMany Function
NObjectGetType Function
NObjectInvoke Function
NObjectInvokeWithPropertyBag Function
NObjectInvokeWithString Function
NObjectRef Function
NObjectRemoveDisposed Function
NObjectRemoveDisposedCallback Function
NObjectRemoveHandlerP Function
NObjectRemoveOwnerChanged Function
NObjectRemoveOwnerChangedCallback Function
NObjectRemovePropertyChanged Function
NObjectRemovePropertyChangedCallback Function
NObjectReset Function
NObjectResetProperty Function
NObjectSaveManyToMemoryDst Function
NObjectSaveManyToMemoryDstN Function
NObjectSaveManyToMemoryN Function
NObjectSaveManyToStream Function
NObjectSaveToMemoryDst Function
NObjectSaveToMemoryDstN Function
NObjectSaveToMemoryN Function
NObjectSaveToStream Function
NObjectSet Function
NObjectSetConcurrent Function
NObjectSetFlags Function
NObjectSetPropertyN Function
NObjectSetPropertyNN Function
NObjectSetPropertyP Function
NObjectToString Function
NObjectUnref Function
NObjectUnrefArray Function
NObjectUnrefElements Function
Collapse Expand Macros
NObjectGetPropertyP Macro
NObjectInvoke Macro
NObjectInvokeWithPropertyBag Macro
NObjectInvokeWithString Macro
NObjectResetProperty Macro
NObjectSetPropertyP Macro
NObjectToString Macro
N_OBJECT_REF_RET Macro
Collapse Expand Files
NObject.h
Collapse Expand NObjectPartInfo Unit
Collapse Expand Functions
NObjectPartInfoGetDeclaredConstant Function
NObjectPartInfoGetDeclaredConstantCount Function
NObjectPartInfoGetDeclaredConstantWithName Function
NObjectPartInfoGetDeclaredConstants Function
NObjectPartInfoGetDeclaredEvent Function
NObjectPartInfoGetDeclaredEventCount Function
NObjectPartInfoGetDeclaredEventWithName Function
NObjectPartInfoGetDeclaredEvents Function
NObjectPartInfoGetDeclaredMethod Function
NObjectPartInfoGetDeclaredMethodCount Function
NObjectPartInfoGetDeclaredMethodWithName Function
NObjectPartInfoGetDeclaredMethods Function
NObjectPartInfoGetDeclaredMethodsWithName Function
NObjectPartInfoGetDeclaredProperties Function
NObjectPartInfoGetDeclaredProperty Function
NObjectPartInfoGetDeclaredPropertyCount Function
NObjectPartInfoGetDeclaredPropertyWithName Function
NObjectPartInfoGetObjectPart Function
NObjectPartInfoGetPropertyName Function
Collapse Expand Macros
NObjectPartInfoGetDeclaredConstantWithName Macro
NObjectPartInfoGetDeclaredEventWithName Macro
NObjectPartInfoGetDeclaredMethodWithName Macro
NObjectPartInfoGetDeclaredMethodsWithName Macro
NObjectPartInfoGetDeclaredPropertyWithName Macro
Collapse Expand Files
NObjectPartInfo.h
Collapse Expand NParameterBag Unit
Collapse Expand Functions
NParameterBagApplyPropertyBag Function
NParameterBagContains Function
NParameterBagCreate Function
NParameterBagGet Function
NParameterBagGetAt Function
NParameterBagGetCount Function
NParameterBagGetKey Function
NParameterBagGetKeys Function
NParameterBagGetValue Function
NParameterBagGetValues Function
NParameterBagSet Function
NParameterBagSetValue Function
NParameterBagToArray Function
NParameterBagToPropertyBag Function
NParameterBagTryGet Function
Collapse Expand Macros
NParameterBagContains Macro
NParameterBagGet Macro
NParameterBagSet Macro
NParameterBagTryGet Macro
Collapse Expand Files
NParameterBag.h
Collapse Expand NParameterDescriptor Unit
Collapse Expand Functions
NParameterDescriptorGetDefaultValue Function
NParameterDescriptorGetFormat Function
NParameterDescriptorGetMaxValue Function
NParameterDescriptorGetMinValue Function
NParameterDescriptorGetParameterType Function
NParameterDescriptorGetStdValue Function
NParameterDescriptorGetStdValueCount Function
NParameterDescriptorGetStdValues Function
Collapse Expand Files
NParameterDescriptor.h
Collapse Expand NParameterInfo Unit
Collapse Expand Functions
NParameterInfoGetAttributes Function
NParameterInfoGetDefaultValue Function
NParameterInfoGetFormat Function
NParameterInfoGetMaxValue Function
NParameterInfoGetMinValue Function
NParameterInfoGetName Function
NParameterInfoGetParameterType Function
NParameterInfoGetStdValue Function
NParameterInfoGetStdValueCount Function
NParameterInfoGetStdValues Function
Collapse Expand Files
NParameterInfo.h
Collapse Expand NPath Unit
Collapse Expand Functions
NPathChangeExtension Function
NPathChangeExtensionPN Function
NPathCheck Function
NPathCheckN Function
NPathCombine Function
NPathCombineP1N Function
NPathCombineP2N Function
NPathGetDirectoryName Function
NPathGetExtension Function
NPathGetFileName Function
NPathGetFileNameWithoutExtension Function
NPathGetTempFileName Function
NPathGetTempPath Function
NPathHasExtension Function
NPathIsRooted Function
Collapse Expand Macros
NPathChangeExtension Macro
NPathChangeExtensionPN Macro
NPathCheck Macro
NPathCombine Macro
NPathCombineP1N Macro
NPathCombineP2N Macro
NPathGetDirectoryName Macro
NPathGetExtension Macro
NPathGetFileName Macro
NPathGetFileNameWithoutExtension Macro
NPathHasExtension Macro
NPathIsRooted Macro
N_MAX_FILE_NAME Macro
N_PATH_ALT_DIRECTORY_SEPARATOR Macro
N_PATH_DIRECTORY_SEPARATOR Macro
N_PATH_IS_CASE_SENSITIVE Macro
N_PATH_PATH_SEPARATOR Macro
N_PATH_VOLUME_SEPARATOR Macro
Collapse Expand Files
NPath.h
Collapse Expand NPlugin Unit
Collapse Expand Functions
NPluginDisable Function
NPluginEnable Function
NPluginGetError Function
NPluginGetFileNameN Function
NPluginGetLoadTime Function
NPluginGetModule Function
NPluginGetPlugTime Function
NPluginGetSelectedInterfaceVersion Function
NPluginGetState Function
NPluginPlug Function
NPluginUnplug Function
Collapse Expand Structs, Records, Enums
NPluginState Enumeration
Collapse Expand Files
NPlugin.h
Collapse Expand NPluginEventDescriptor Unit
Collapse Expand Functions
NPluginEventDescriptorCreate Function
Collapse Expand Files
NPluginEventDescriptor.h
Collapse Expand NPluginInternal Unit
Collapse Expand Functions
NPluginGetSelectedInterface Function
Collapse Expand Structs, Records, Enums
NPluginInterfaceVersionInfo Structure
Collapse Expand Macros
NPluginInterfaceVersionInfoConst Macro
Collapse Expand NPluginManager Unit
Collapse Expand Functions
NPluginManagerAddDisabledPlugin Function
NPluginManagerAddDisabledPluginsCollectionChanged Function
NPluginManagerAddDisabledPluginsCollectionChangedCallback Function
NPluginManagerAddPlugin Function
NPluginManagerAddPluginFromFile Function
NPluginManagerAllowsUnplug Function
NPluginManagerClearDisabledPlugins Function
NPluginManagerEnsurePluginSearchPerformed Function
NPluginManagerGetDisabledPluginCount Function
NPluginManagerGetDisabledPlugins Function
NPluginManagerGetInstances Function
NPluginManagerGetInterfaceTypeN Function
NPluginManagerGetInterfaceVersions Function
NPluginManagerGetPlugin Function
NPluginManagerGetPluginByName Function
NPluginManagerGetPluginCount Function
NPluginManagerGetPluginSearchPathN Function
NPluginManagerGetPlugins Function
NPluginManagerPlugAll Function
NPluginManagerRefresh Function
NPluginManagerRemoveDisabledPlugin Function
NPluginManagerRemoveDisabledPluginAt Function
NPluginManagerRemoveDisabledPluginsCollectionChanged Function
NPluginManagerRemoveDisabledPluginsCollectionChangedCallback Function
NPluginManagerRemovePluginsCollectionChanged Function
NPluginManagerRemovePluginsCollectionChangedCallback Function
NPluginManagerSetPluginSearchPath Function
NPluginManagerUnplugAll Function
Collapse Expand Macros
NPluginManagerAddDisabledPlugin Macro
NPluginManagerAddPlugin Macro
NPluginManagerAddPluginFromFile Macro
NPluginManagerGetPluginByName Macro
NPluginManagerRemoveDisabledPlugin Macro
NPluginManagerSetPluginSearchPath Macro
Collapse Expand Files
NPluginManager.h
Collapse Expand NPluginMethodDescriptor Unit
Collapse Expand Functions
NPluginMethodDescriptorCreate Function
Collapse Expand Files
NPluginMethodDescriptor.h
Collapse Expand NPluginModule Unit
Collapse Expand Functions
NPluginModuleCreate Function
NPluginModuleGetIncompatiblePluginsN Function
NPluginModuleGetInterfaceTypeN Function
NPluginModuleGetInterfaceVersions Function
NPluginModuleGetPluginNameN Function
NPluginModuleSetIncompatiblePluginsN Function
NPluginModuleSetInterfaceTypeN Function
NPluginModuleSetPluginNameN Function
NPluginModuleSetPriority Function
NPluginModuleGetPriority Function
HNPluginModule
Collapse Expand Macros
NPluginModuleSetIncompatiblePlugins Macro
NPluginModuleSetInterfaceType Macro
NPluginModuleSetPluginName Macro
Collapse Expand NPluginModuleInternal Unit
Collapse Expand Functions
NPluginModuleSetGetEvents Function
NPluginModuleSetGetMethods Function
NPluginModuleSetGetProperties Function
NPluginModuleSetInterfaceVersions Function
NPluginModuleSetPlug Function
NPluginModuleSetUnplug Function
Collapse Expand NPluginPropertyDescriptor Unit
Collapse Expand Functions
NPluginPropertyDescriptorCreate Function
Collapse Expand Files
NPluginPropertyDescriptor.h
Collapse Expand NProcess Unit
Collapse Expand Functions
NProcessCreateFromOSHandle Function
NProcessGetCurrent Function
NProcessGetFileName Function
NProcessGetId Function
NProcessGetName Function
NProcessGetOSHandle Function
Collapse Expand Files
NProcess.h
Collapse Expand NProcessorInfo Unit
Collapse Expand Functions
NProcessorInfoGetCount Function
NProcessorInfoGetModelInfo Function
NProcessorInfoGetModelNameN Function
NProcessorInfoGetVendor Function
NProcessorInfoGetVendorNameN Function
NProcessorInfoIsFeatureSupported Function
Collapse Expand Structs, Records, Enums
NProcessorVendor Enumeration
Collapse Expand Files
NProcessorInfo.h
Collapse Expand NPropertyInfo Unit
Collapse Expand Functions
NPropertyInfoCanResetValue Function
NPropertyInfoGetDefaultValue Function
NPropertyInfoGetFormat Function
NPropertyInfoGetGetMethod Function
NPropertyInfoGetMaxValue Function
NPropertyInfoGetMinValue Function
NPropertyInfoGetPropertyType Function
NPropertyInfoGetSetMethod Function
NPropertyInfoGetStdValue Function
NPropertyInfoGetStdValueCount Function
NPropertyInfoGetStdValues Function
NPropertyInfoGetValue Function
NPropertyInfoResetValue Function
NPropertyInfoSetValue Function
Collapse Expand Files
NPropertyInfo.h
Collapse Expand NQueue Unit
Collapse Expand Functions
NQueueClear Function
NQueueContains Function
NQueueCopyTo Function
NQueueDequeue Function
NQueueDispose Function
NQueueEnqueue Function
NQueueGetCapacity Function
NQueueGetCount Function
NQueueGetFront Function
NQueueInit Function
NQueueInitEx Function
NQueueInitWithCapacity Function
NQueuePeek Function
NQueueSetCapacity Function
NQueueToArray Function
Collapse Expand Macros
N_QUEUE_SIZE Macro
Collapse Expand Files
NQueue.h
NReDeprecate Unit
Collapse Expand NRWLock Unit
Collapse Expand Functions
NRWLockDispose Function
NRWLockEnterRead Function
NRWLockEnterWrite Function
NRWLockExitRead Function
NRWLockExitWrite Function
NRWLockInit Function
NRWLockTryEnterRead Function
NRWLockTryEnterWrite Function
Collapse Expand NSemaphore Unit
Collapse Expand Functions
NSemaphoreCreate Function
NSemaphoreCreateFromOSHandle Function
NSemaphoreGetOSHandle Function
NSemaphoreRelease Function
Collapse Expand NStack Unit
Collapse Expand Functions
NStackClear Function
NStackContains Function
NStackCopyTo Function
NStackDispose Function
NStackGetCapacity Function
NStackGetCount Function
NStackGetTop Function
NStackInit Function
NStackInitEx Function
NStackInitWithCapacity Function
NStackPeek Function
NStackPop Function
NStackPush Function
NStackSetCapacity Function
NStackToArray Function
Collapse Expand Macros
N_STACK_SIZE Macro
Collapse Expand Files
NStack.h
Collapse Expand NStopwatch Unit
Collapse Expand Functions
NStopwatchCreate Function
NStopwatchGetElapsed Function
NStopwatchGetElapsedMilliseconds Function
NStopwatchGetElapsedTicks Function
NStopwatchGetFrequency Function
NStopwatchGetTimestamp Function
NStopwatchIsHighResolution Function
NStopwatchIsRunning Function
NStopwatchReset Function
NStopwatchRestart Function
NStopwatchStart Function
NStopwatchStartNew Function
NStopwatchStop Function
NStopwatchTicksToMilliseconds Function
Collapse Expand NStream Unit
Collapse Expand Functions
NStreamCanRead Function
NStreamCanSeek Function
NStreamCanWrite Function
NStreamCopyTo Function
NStreamCopyToWithBufferSize Function
NStreamFlush Function
NStreamGetLength Function
NStreamGetNull Function
NStreamGetPosition Function
NStreamRead Function
NStreamReadByte Function
NStreamReadN Function
NStreamSeek Function
NStreamSetLength Function
NStreamSetPosition Function
NStreamSynchronized Function
NStreamWrite Function
NStreamWriteByte Function
NStreamWriteN Function
Collapse Expand NStreamReader Unit
Collapse Expand Functions
NStreamReaderCreate Function
NStreamReaderCreateFromFile Function
NStreamReaderCreateFromFileWithEncoding Function
NStreamReaderCreateFromFileWithEncodingAndBufferSize Function
NStreamReaderCreateWithEncoding Function
NStreamReaderCreateWithEncodingAndBufferSize Function
NStreamReaderGetBaseStream Function
NStreamReaderGetCurrentEncoding Function
NStreamReaderGetNull Function
NStreamReaderIsEndOfStream Function
Collapse Expand Macros
NStreamReaderCreateFromFile Macro
NStreamReaderCreateFromFileWithEncoding Macro
NStreamReaderCreateFromFileWithEncodingAndBufferSize Macro
Collapse Expand NStreamWriter Unit
Collapse Expand Functions
NStreamWriterCreate Function
NStreamWriterCreateFromFile Function
NStreamWriterCreateFromFileWithEncoding Function
NStreamWriterCreateFromFileWithEncodingAndBufferSize Function
NStreamWriterCreateWithEncoding Function
NStreamWriterCreateWithEncodingAndBufferSize Function
NStreamWriterGetAutoFlush Function
NStreamWriterGetBaseStream Function
NStreamWriterGetNull Function
NStreamWriterSetAutoFlush Function
Collapse Expand Macros
NStreamWriterCreateFromFile Macro
NStreamWriterCreateFromFileWithEncoding Macro
NStreamWriterCreateFromFileWithEncodingAndBufferSize Macro
Collapse Expand NString Unit
Format Specifications
Collapse Expand Functions
NStringAppendStrOrChars Function
NStringClone Function
NStringCompareRangeNA Function
NStringCompareRangeNW Function
NStringCompareRangeStrOrCharsA Function
NStringCompareRangeStrOrCharsW Function
NStringConcatArray Function
NStringConcatMany Function
NStringConcatManyVA Function
NStringConcatN Function
NStringConcatStrOrChars Function
NStringContainsStrN Function
NStringContainsStrOrChars Function
NStringCopyToStrOrChars Function
NStringCreateFromChar Function
NStringCreateFromStrOrChars Function
NStringCreateWrapper Function
NStringEndsWithN Function
NStringEndsWithStrOrCharsA Function
NStringEndsWithStrOrCharsW Function
NStringEqualsN Function
NStringEqualsStrOrCharsA Function
NStringEqualsStrOrCharsW Function
NStringFormat Function
NStringFormatVA Function
NStringFree Function
NStringFreeArray Function
NStringFreeElements Function
NStringGetBuffer Function
NStringGetConcurrent Function
NStringGetElements Function
NStringGetEmpty Function
NStringGetHashCode Function
NStringGetLength Function
NStringHasEmbeddedNull Function
NStringIndexOf Function
NStringIndexOfAny Function
NStringIndexOfAnyFrom Function
NStringIndexOfAnyInRange Function
NStringIndexOfFrom Function
NStringIndexOfInRange Function
NStringIndexOfStrFromN Function
NStringIndexOfStrInRangeN Function
NStringIndexOfStrN Function
NStringIndexOfStrOrChars Function
NStringIndexOfStrOrCharsFrom Function
NStringIndexOfStrOrCharsInRange Function
NStringInsertN Function
NStringInsertStrOrChars Function
NStringIsA Function
NStringIsEmpty Function
NStringIsW Function
NStringIsWhiteSpace Function
NStringJoinArray Function
NStringJoinArrayVN Function
NStringJoinMany Function
NStringJoinManyVA Function
NStringJoinManyVAVN Function
NStringJoinManyVN Function
NStringLastIndexOf Function
NStringLastIndexOfAny Function
NStringLastIndexOfAnyFrom Function
NStringLastIndexOfAnyInRange Function
NStringLastIndexOfFrom Function
NStringLastIndexOfInRange Function
NStringLastIndexOfStrFromN Function
NStringLastIndexOfStrInRangeN Function
NStringLastIndexOfStrN Function
NStringLastIndexOfStrOrChars Function
NStringLastIndexOfStrOrCharsFrom Function
NStringLastIndexOfStrOrCharsInRange Function
NStringPadLeft Function
NStringPadLeftWith Function
NStringPadRight Function
NStringPadRightWith Function
NStringPrependStrOrChars Function
NStringPromoteBuffer Function
NStringRemove Function
NStringRemoveFrom Function
NStringReplace Function
NStringReplaceStrOrChars Function
NStringSet Function
NStringSplitWithCount Function
NStringSplitWithStrsAndCount Function
NStringSplitWithStrsAndCountN Function
NStringStartsWithN Function
NStringStartsWithStrOrCharsA Function
NStringStartsWithStrOrCharsW Function
NStringSubstring Function
NStringSubstringFrom Function
NStringToLower Function
NStringToStrOrCharArray Function
NStringToStrOrCharArrayRange Function
NStringToString Function
NStringToUpper Function
NStringTrim Function
NStringTrimAny Function
NStringTrimEnd Function
NStringTrimEndAny Function
NStringTrimStart Function
NStringTrimStartAny Function
Collapse Expand Macros
NStringAppend Macro
NStringAppendChars Macro
NStringAppendStrOrChars Macro
NStringCompare Macro
NStringCompareChars Macro
NStringCompareN Macro
NStringCompareRange Macro
NStringCompareRangeChars Macro
NStringCompareRangeN Macro
NStringCompareRangeStrOrChars Macro
NStringCompareStrOrChars Macro
NStringConcat Macro
NStringConcatChars Macro
NStringConcatMany Macro
NStringConcatManyVA Macro
NStringConcatStrOrChars Macro
NStringContainsChars Macro
NStringContainsStr Macro
NStringContainsStrOrChars Macro
NStringCopyTo Macro
NStringCopyToStrOrChars Macro
NStringCopyToString Macro
NStringCreate Macro
NStringCreateFromChar Macro
NStringCreateFromChars Macro
NStringCreateFromStrOrChars Macro
NStringCreateWrapper Macro
NStringEndsWith Macro
NStringEndsWithChars Macro
NStringEndsWithStrOrChars Macro
NStringEquals Macro
NStringEqualsChars Macro
NStringEqualsStrOrChars Macro
NStringFormat Macro
NStringFormatVA Macro
NStringGetBuffer Macro
NStringGetChar Macro
NStringGetLength Macro
NStringIndexOf Macro
NStringIndexOfAny Macro
NStringIndexOfAnyFrom Macro
NStringIndexOfAnyInRange Macro
NStringIndexOfChars Macro
NStringIndexOfCharsFrom Macro
NStringIndexOfCharsInRange Macro
NStringIndexOfFrom Macro
NStringIndexOfInRange Macro
NStringIndexOfStr Macro
NStringIndexOfStrFrom Macro
NStringIndexOfStrFromN Macro
NStringIndexOfStrInRange Macro
NStringIndexOfStrInRangeN Macro
NStringIndexOfStrN Macro
NStringIndexOfStrOrChars Macro
NStringIndexOfStrOrCharsFrom Macro
NStringIndexOfStrOrCharsInRange Macro
NStringInsert Macro
NStringInsertChars Macro
NStringInsertN Macro
NStringInsertStrOrChars Macro
NStringJoinArray Macro
NStringJoinArrayVN Macro
NStringJoinMany Macro
NStringJoinManyVAVN Macro
NStringJoinManyVN Macro
NStringLastIndexOf Macro
NStringLastIndexOfAny Macro
NStringLastIndexOfAnyFrom Macro
NStringLastIndexOfAnyInRange Macro
NStringLastIndexOfChars Macro
NStringLastIndexOfCharsFrom Macro
NStringLastIndexOfCharsInRange Macro
NStringLastIndexOfFrom Macro
NStringLastIndexOfInRange Macro
NStringLastIndexOfStr Macro
NStringLastIndexOfStrFrom Macro
NStringLastIndexOfStrFromN Macro
NStringLastIndexOfStrInRange Macro
NStringLastIndexOfStrInRangeN Macro
NStringLastIndexOfStrN Macro
NStringLastIndexOfStrOrChars Macro
NStringLastIndexOfStrOrCharsFrom Macro
NStringLastIndexOfStrOrCharsInRange Macro
NStringPadLeft Macro
NStringPadLeftWith Macro
NStringPadRight Macro
NStringPadRightWith Macro
NStringPrepend Macro
NStringPrependChars Macro
NStringPrependStrOrChars Macro
NStringPromoteBuffer Macro
NStringRemove Macro
NStringRemoveFrom Macro
NStringReplace Macro
NStringReplaceChars Macro
NStringReplaceStr Macro
NStringReplaceStrOrChars Macro
NStringSplit Macro
NStringSplitWithCount Macro
NStringSplitWithStrs Macro
NStringSplitWithStrsAndCount Macro
NStringSplitWithStrsN Macro
NStringStartsWith Macro
NStringStartsWithChars Macro
NStringStartsWithStrOrChars Macro
NStringSubstring Macro
NStringSubstringFrom Macro
NStringToCharArray Macro
NStringToCharArrayRange Macro
NStringToNewString Macro
NStringToNewStringRange Macro
NStringToStrOrCharArray Macro
NStringToStrOrCharArrayRange Macro
NStringToString Macro
NStringTrimAny Macro
NStringTrimEndAny Macro
NStringTrimStartAny Macro
N_STRING_SIZE Macro
Collapse Expand Files
NString.h
Collapse Expand NStringBuilder Unit
Collapse Expand Functions
NStringBuilderAppend Function
NStringBuilderAppendBoolean Function
NStringBuilderAppendByte Function
NStringBuilderAppendChar Function
NStringBuilderAppendCharRepeat Function
NStringBuilderAppendChars Function
NStringBuilderAppendDouble Function
NStringBuilderAppendEmptyLine Function
NStringBuilderAppendFormat Function
NStringBuilderAppendFormatN Function
NStringBuilderAppendFormatVA Function
NStringBuilderAppendFormatVAN Function
NStringBuilderAppendInt16 Function
NStringBuilderAppendInt32 Function
NStringBuilderAppendInt64 Function
NStringBuilderAppendLine Function
NStringBuilderAppendLineN Function
NStringBuilderAppendN Function
NStringBuilderAppendObject Function
NStringBuilderAppendPointer Function
NStringBuilderAppendResult Function
NStringBuilderAppendSByte Function
NStringBuilderAppendSSizeType Function
NStringBuilderAppendSingle Function
NStringBuilderAppendSizeType Function
NStringBuilderAppendUInt16 Function
NStringBuilderAppendUInt32 Function
NStringBuilderAppendUInt64 Function
NStringBuilderAppendValue Function
NStringBuilderAppendValueP Function
NStringBuilderClear Function
NStringBuilderCopyToStrOrChars Function
NStringBuilderDetachStrOrChars Function
NStringBuilderDetachStringN Function
NStringBuilderDispose Function
NStringBuilderGetCapacity Function
NStringBuilderGetChar Function
NStringBuilderGetLength Function
NStringBuilderGetStrOrCharsBuffer Function
NStringBuilderGetStringWrapper Function
NStringBuilderInit Function
NStringBuilderInitEx Function
NStringBuilderInitWithCapacity Function
NStringBuilderInitWithStrOrChars Function
NStringBuilderInitWithStringN Function
NStringBuilderInsert Function
NStringBuilderInsertBoolean Function
NStringBuilderInsertByte Function
NStringBuilderInsertChar Function
NStringBuilderInsertChars Function
NStringBuilderInsertDouble Function
NStringBuilderInsertInt16 Function
NStringBuilderInsertInt32 Function
NStringBuilderInsertInt64 Function
NStringBuilderInsertN Function
NStringBuilderInsertObject Function
NStringBuilderInsertPointer Function
NStringBuilderInsertResult Function
NStringBuilderInsertSByte Function
NStringBuilderInsertSSizeType Function
NStringBuilderInsertSingle Function
NStringBuilderInsertSizeType Function
NStringBuilderInsertUInt16 Function
NStringBuilderInsertUInt32 Function
NStringBuilderInsertUInt64 Function
NStringBuilderInsertValue Function
NStringBuilderInsertValueP Function
NStringBuilderRemove Function
NStringBuilderReplace Function
NStringBuilderReplaceInRange Function
NStringBuilderReplaceStrOrChars Function
NStringBuilderReplaceStrOrCharsInRange Function
NStringBuilderReplaceStringInRangeN Function
NStringBuilderReplaceStringN Function
NStringBuilderSetCapacity Function
NStringBuilderSetChar Function
NStringBuilderSetLength Function
NStringBuilderToString Function
NStringBuilderToStringRange Function
Collapse Expand Macros
NStringBuilderAppend Macro
NStringBuilderAppendBoolean Macro
NStringBuilderAppendByte Macro
NStringBuilderAppendChar Macro
NStringBuilderAppendCharRepeat Macro
NStringBuilderAppendChars Macro
NStringBuilderAppendDouble Macro
NStringBuilderAppendEmptyLine Macro
NStringBuilderAppendFormat Macro
NStringBuilderAppendFormatN Macro
NStringBuilderAppendFormatVA Macro
NStringBuilderAppendFormatVAN Macro
NStringBuilderAppendInt16 Macro
NStringBuilderAppendInt32 Macro
NStringBuilderAppendInt64 Macro
NStringBuilderAppendLine Macro
NStringBuilderAppendLineN Macro
NStringBuilderAppendN Macro
NStringBuilderAppendObject Macro
NStringBuilderAppendPointer Macro
NStringBuilderAppendResult Macro
NStringBuilderAppendSByte Macro
NStringBuilderAppendSSizeType Macro
NStringBuilderAppendSingle Macro
NStringBuilderAppendSizeType Macro
NStringBuilderAppendUInt16 Macro
NStringBuilderAppendUInt32 Macro
NStringBuilderAppendUInt64 Macro
NStringBuilderAppendValue Macro
NStringBuilderAppendValueP Macro
NStringBuilderClear Macro
NStringBuilderCopyTo Macro
NStringBuilderCopyToStrOrChars Macro
NStringBuilderCopyToString Macro
NStringBuilderDetachCharArray Macro
NStringBuilderDetachStrOrChars Macro
NStringBuilderDetachString Macro
NStringBuilderDispose Macro
NStringBuilderGetBuffer Macro
NStringBuilderGetCapacity Macro
NStringBuilderGetChar Macro
NStringBuilderGetCharsBuffer Macro
NStringBuilderGetLength Macro
NStringBuilderGetStrOrCharsBuffer Macro
NStringBuilderGetStringWrapper Macro
NStringBuilderInit Macro
NStringBuilderInitEx Macro
NStringBuilderInitWithCapacity Macro
NStringBuilderInitWithChars Macro
NStringBuilderInitWithStrOrChars Macro
NStringBuilderInitWithString Macro
NStringBuilderInitWithStringN Macro
NStringBuilderInsert Macro
NStringBuilderInsertBoolean Macro
NStringBuilderInsertByte Macro
NStringBuilderInsertChar Macro
NStringBuilderInsertChars Macro
NStringBuilderInsertDouble Macro
NStringBuilderInsertInt16 Macro
NStringBuilderInsertInt32 Macro
NStringBuilderInsertInt64 Macro
NStringBuilderInsertN Macro
NStringBuilderInsertObject Macro
NStringBuilderInsertPointer Macro
NStringBuilderInsertResult Macro
NStringBuilderInsertSByte Macro
NStringBuilderInsertSSizeType Macro
NStringBuilderInsertSingle Macro
NStringBuilderInsertSizeType Macro
NStringBuilderInsertUInt16 Macro
NStringBuilderInsertUInt32 Macro
NStringBuilderInsertUInt64 Macro
NStringBuilderInsertValue Macro
NStringBuilderInsertValueP Macro
NStringBuilderRemove Macro
NStringBuilderReplace Macro
NStringBuilderReplaceChars Macro
NStringBuilderReplaceCharsInRange Macro
NStringBuilderReplaceInRange Macro
NStringBuilderReplaceStrOrChars Macro
NStringBuilderReplaceStrOrCharsInRange Macro
NStringBuilderReplaceString Macro
NStringBuilderReplaceStringInRange Macro
NStringBuilderReplaceStringN Macro
NStringBuilderSetCapacity Macro
NStringBuilderSetChar Macro
NStringBuilderSetLength Macro
NStringBuilderToString Macro
NStringBuilderToStringRange Macro
N_STRING_BUILDER_SIZE Macro
Collapse Expand NStringReader Unit
Collapse Expand Functions
NStringReaderCreateFromStrOrChars Function
NStringReaderCreateN Function
Collapse Expand Macros
NStringReaderCreate Macro
NStringReaderCreateFromChars Macro
NStringReaderCreateFromStrOrChars Macro
Collapse Expand NStringWriter Unit
Collapse Expand Functions
NStringWriterCreate Function
NStringWriterCreateEx Function
NStringWriterCreateWithCapacity Function
NStringWriterDetachString Function
Collapse Expand Files
NStringWriter.h
Collapse Expand NSyncEvent Unit
Collapse Expand Functions
NSyncEventCreate Function
NSyncEventCreateFromOSHandle Function
NSyncEventGetOSHandle Function
NSyncEventSet Function
Collapse Expand Macros
NSyncEventReset Macro
Collapse Expand NTextReader Unit
Collapse Expand Functions
NTextReaderGetNull Function
NTextReaderPeekChar Function
NTextReaderReadChar Function
NTextReaderReadChars Function
NTextReaderReadLine Function
NTextReaderReadToEnd Function
NTextReaderSynchronized Function
Collapse Expand Macros
NTextReaderPeekChar Macro
NTextReaderReadChar Macro
NTextReaderReadChars Macro
Collapse Expand NTextWriter Unit
Collapse Expand Functions
NTextWriterFlush Function
NTextWriterGetEncoding Function
NTextWriterGetNewLine Function
NTextWriterGetNull Function
NTextWriterSetNewLine Function
NTextWriterSynchronized Function
NTextWriterWrite Function
NTextWriterWriteBoolean Function
NTextWriterWriteBooleanLine Function
NTextWriterWriteChar Function
NTextWriterWriteCharLine Function
NTextWriterWriteChars Function
NTextWriterWriteCharsLine Function
NTextWriterWriteDouble Function
NTextWriterWriteDoubleLine Function
NTextWriterWriteEmptyLine Function
NTextWriterWriteFormat Function
NTextWriterWriteFormatLine Function
NTextWriterWriteFormatLineVA Function
NTextWriterWriteFormatVA Function
NTextWriterWriteInt32 Function
NTextWriterWriteInt32Line Function
NTextWriterWriteInt64 Function
NTextWriterWriteInt64Line Function
NTextWriterWriteLine Function
NTextWriterWriteObject Function
NTextWriterWriteObjectLine Function
NTextWriterWritePointer Function
NTextWriterWritePointerLine Function
NTextWriterWriteResult Function
NTextWriterWriteResultLine Function
NTextWriterWriteSSizeType Function
NTextWriterWriteSSizeTypeLine Function
NTextWriterWriteSingle Function
NTextWriterWriteSingleLine Function
NTextWriterWriteSizeType Function
NTextWriterWriteSizeTypeLine Function
NTextWriterWriteUInt32 Function
NTextWriterWriteUInt32Line Function
NTextWriterWriteUInt64 Function
NTextWriterWriteUInt64Line Function
NTextWriterWriteValue Function
NTextWriterWriteValueLine Function
NTextWriterWriteValueLineP Function
NTextWriterWriteValueP Function
Collapse Expand Macros
NTextWriterSetNewLine Macro
NTextWriterWrite Macro
NTextWriterWriteChar Macro
NTextWriterWriteCharLine Macro
NTextWriterWriteChars Macro
NTextWriterWriteCharsLine Macro
NTextWriterWriteFormat Macro
NTextWriterWriteFormatLine Macro
NTextWriterWriteFormatLineVA Macro
NTextWriterWriteFormatVA Macro
NTextWriterWriteLine Macro
Collapse Expand NThread Unit
Collapse Expand Functions
NThreadCreate Function
NThreadCreateFromOSHandle Function
NThreadCreateParameterized Function
NThreadGetCurrent Function
NThreadGetCurrentId Function
NThreadGetId Function
NThreadGetOSHandle Function
NThreadJoin Function
NThreadSleep Function
Collapse Expand Files
NThread.h
Collapse Expand NTimeSpan Type
Collapse Expand Functions
NTimeSpanAdd Function
NTimeSpanCompare Function
NTimeSpanCreate Function
NTimeSpanCreateFromDays Function
NTimeSpanCreateFromHours Function
NTimeSpanCreateFromMilliseconds Function
NTimeSpanCreateFromMinutes Function
NTimeSpanCreateFromSeconds Function
NTimeSpanCreateFromTicks Function
NTimeSpanDecode Function
NTimeSpanDuration Function
NTimeSpanGetDays Function
NTimeSpanGetHours Function
NTimeSpanGetMilliseconds Function
NTimeSpanGetMinutes Function
NTimeSpanGetSeconds Function
NTimeSpanGetTicks Function
NTimeSpanGetTotalDays Function
NTimeSpanGetTotalHours Function
NTimeSpanGetTotalMilliseconds Function
NTimeSpanGetTotalMinutes Function
NTimeSpanGetTotalSeconds Function
NTimeSpanIsTimeValid Function
NTimeSpanIsValid Function
NTimeSpanNegate Function
NTimeSpanSubtract Function
NTimeSpanToString Function
Collapse Expand Types
NTimeSpan_ Type
Collapse Expand Macros
NTimeSpanToString Macro
N_TIME_SPAN_MAX Macro
N_TIME_SPAN_MIN Macro
N_TIME_SPAN_TICKS_PER_DAY Macro
N_TIME_SPAN_TICKS_PER_HOUR Macro
N_TIME_SPAN_TICKS_PER_MILLISECOND Macro
N_TIME_SPAN_TICKS_PER_MINUTE Macro
N_TIME_SPAN_TICKS_PER_SECOND Macro
Collapse Expand NTls Unit
Collapse Expand Functions
NTlsCreate Function
NTlsCreateForObject Function
NTlsFree Function
NTlsGetObject Function
NTlsGetValue Function
NTlsSetObject Function
NTlsSetValue Function
Collapse Expand Variables
pValue Variable
Collapse Expand NType Unit
Collapse Expand Functions
NTypeAddEventHandlerN Function
NTypeAddEventHandlerP Function
NTypeAreValuesEqual Function
NTypeCapturePropertyValues Function
NTypeCompareValues Function
NTypeCopyPropertyValues Function
NTypeCopyValue Function
NTypeCreateInstance Function
NTypeCreateInstanceWithName Function
NTypeDisposeValue Function
NTypeDisposeValues Function
NTypeFreeValues Function
NTypeGetAttributes Function
NTypeGetBaseType Function
NTypeGetDeclaredConstant Function
NTypeGetDeclaredConstantCount Function
NTypeGetDeclaredConstantWithName Function
NTypeGetDeclaredConstants Function
NTypeGetDeclaredConstructor Function
NTypeGetDeclaredConstructorCount Function
NTypeGetDeclaredConstructors Function
NTypeGetDeclaredEnumConstant Function
NTypeGetDeclaredEnumConstantCount Function
NTypeGetDeclaredEnumConstantWithName Function
NTypeGetDeclaredEnumConstants Function
NTypeGetDeclaredEvent Function
NTypeGetDeclaredEventCount Function
NTypeGetDeclaredEventWithName Function
NTypeGetDeclaredEvents Function
NTypeGetDeclaredField Function
NTypeGetDeclaredFieldCount Function
NTypeGetDeclaredFieldWithName Function
NTypeGetDeclaredFields Function
NTypeGetDeclaredMethod Function
NTypeGetDeclaredMethodCount Function
NTypeGetDeclaredMethodWithName Function
NTypeGetDeclaredMethods Function
NTypeGetDeclaredMethodsWithName Function
NTypeGetDeclaredPart Function
NTypeGetDeclaredPartCount Function
NTypeGetDeclaredPartWithName Function
NTypeGetDeclaredParts Function
NTypeGetDeclaredProperties Function
NTypeGetDeclaredProperty Function
NTypeGetDeclaredPropertyCount Function
NTypeGetDeclaredPropertyWithName Function
NTypeGetEnumAlternative Function
NTypeGetModule Function
NTypeGetNameN Function
NTypeGetOwnerType Function
NTypeGetPropertyValueN Function
NTypeGetPropertyValueP Function
NTypeGetRootType Function
NTypeGetRootTypeCode Function
NTypeGetTypeCode Function
NTypeGetTypeWithName Function
NTypeGetUseInsteadType Function
NTypeGetValueHashCode Function
NTypeGetValueSize Function
NTypeHasOwnerType Function
NTypeIdentifierToString Function
NTypeIdentifierToStringFN Function
NTypeIdentifierToStringVN Function
NTypeInvokeMethod Function
NTypeInvokeMethodWithPropertyBag Function
NTypeInvokeMethodWithString Function
NTypeIsAbstract Function
NTypeIsAssignableFrom Function
NTypeIsBasic Function
NTypeIsCallback Function
NTypeIsCloneable Function
NTypeIsComparable Function
NTypeIsDeprecated Function
NTypeIsDisposable Function
NTypeIsEnum Function
NTypeIsEquatable Function
NTypeIsFlagsEnum Function
NTypeIsHandle Function
NTypeIsInstanceOfType Function
NTypeIsInstanceOfTypeP Function
NTypeIsMemorySerializable Function
NTypeIsObject Function
NTypeIsParsable Function
NTypeIsPrimitive Function
NTypeIsPublic Function
NTypeIsSealed Function
NTypeIsSerializable Function
NTypeIsSignNeutral Function
NTypeIsStatic Function
NTypeIsStruct Function
NTypeIsSubclassOf Function
NTypeParseValue Function
NTypeParseValueVN Function
NTypeRemoveEventHandlerN Function
NTypeRemoveEventHandlerP Function
NTypeReset Function
NTypeResetPropertyValue Function
NTypeSetPropertyValueN Function
NTypeSetPropertyValueP Function
NTypeSetValue Function
NTypeTryParseValue Function
NTypeTryParseValueVN Function
NTypeValueToString Function
NTypeValueToStringN Function
Collapse Expand Structs, Records, Enums
NTypeCode Enumeration
Collapse Expand Macros
NTypeAddEventHandlerP Macro
NTypeCreateInstanceWithName Macro
NTypeGetDeclaredConstantWithName Macro
NTypeGetDeclaredEnumConstantWithName Macro
NTypeGetDeclaredEventWithName Macro
NTypeGetDeclaredFieldWithName Macro
NTypeGetDeclaredMethodWithName Macro
NTypeGetDeclaredMethodsWithName Macro
NTypeGetDeclaredPartWithName Macro
NTypeGetDeclaredPropertyWithName Macro
NTypeGetPropertyValueP Macro
NTypeGetTypeWithName Macro
NTypeIdentifierToString Macro
NTypeIdentifierToStringFN Macro
NTypeIdentifierToStringVN Macro
NTypeInvokeMethod Macro
NTypeInvokeMethodWithPropertyBag Macro
NTypeInvokeMethodWithString Macro
NTypeParseValue Macro
NTypeParseValueVN Macro
NTypeRemoveEventHandlerP Macro
NTypeResetPropertyValueP Macro
NTypeSetPropertyValueP Macro
NTypeTryParseValue Macro
NTypeTryParseValueVN Macro
NTypeValueToString Macro
Collapse Expand Files
NType.h
Collapse Expand NTypeDescriptor Unit
Collapse Expand Functions
NTypeDescriptorGetDefaultPropertyName Function
NTypeDescriptorGetDefaultPropertyNameForType Function
NTypeDescriptorGetEvents Function
NTypeDescriptorGetEventsForType Function
NTypeDescriptorGetMethods Function
NTypeDescriptorGetMethodsForType Function
NTypeDescriptorGetProperties Function
NTypeDescriptorGetPropertiesForType Function
Collapse Expand Files
NTypeDescriptor.h
Collapse Expand NTypes Unit
Collapse Expand Functions
NACharParseN Function
NACharParseStrOrChars Function
NACharParseVN Function
NACharToChars Function
NACharToString Function
NACharTryParseN Function
NACharTryParseStrOrChars Function
NACharTryParseVN Function
NBooleanParseN Function
NBooleanParseStrOrChars Function
NBooleanParseVN Function
NBooleanToChars Function
NBooleanToString Function
NBooleanTryParseN Function
NBooleanTryParseStrOrChars Function
NBooleanTryParseVN Function
NCharFromBinDigit Function
NCharFromDigit Function
NCharFromHexDigit Function
NCharFromOctDigit Function
NCharIsAscii Function
NCharIsBinDigit Function
NCharIsDigit Function
NCharIsHexDigit Function
NCharIsLetter Function
NCharIsLower Function
NCharIsOctDigit Function
NCharIsUpper Function
NCharIsWhiteSpace Function
NCharParseN Function
NCharParseStrOrChars Function
NCharParseVN Function
NCharToBinDigit Function
NCharToChars Function
NCharToDigit Function
NCharToHexDigit Function
NCharToLower Function
NCharToOctDigit Function
NCharToString Function
NCharToUpper Function
NCharTryParseN Function
NCharTryParseStrOrChars Function
NCharTryParseVN Function
NComplexToString Function
NDoubleGetNaN Function
NDoubleGetNegativeInfinity Function
NDoubleGetPositiveInfinity Function
NDoubleIsInfinity Function
NDoubleIsNaN Function
NDoubleIsNegativeInfinity Function
NDoubleIsPositiveInfinity Function
NDoubleParseN Function
NDoubleParseStrOrChars Function
NDoubleParseVN Function
NDoubleToChars Function
NDoubleToString Function
NDoubleTryParseN Function
NDoubleTryParseStrOrChars Function
NDoubleTryParseVN Function
NGuidParse Function
NGuidParseVN Function
NGuidToString Function
NGuidTryParse Function
NGuidTryParseVN Function
NIndexPairToString Function
NInt16ParseN Function
NInt16ParseStrOrChars Function
NInt16ParseVN Function
NInt16ToChars Function
NInt16ToString Function
NInt16TryParseN Function
NInt16TryParseStrOrChars Function
NInt16TryParseVN Function
NInt32ParseN Function
NInt32ParseStrOrChars Function
NInt32ParseVN Function
NInt32ToChars Function
NInt32ToString Function
NInt32TryParseN Function
NInt32TryParseStrOrChars Function
NInt32TryParseVN Function
NInt64ParseN Function
NInt64ParseStrOrChars Function
NInt64ParseVN Function
NInt64ToChars Function
NInt64ToString Function
NInt64TryParseN Function
NInt64TryParseStrOrChars Function
NInt64TryParseVN Function
NInt8ParseN Function
NInt8ParseStrOrChars Function
NInt8ParseVN Function
NInt8ToChars Function
NInt8ToString Function
NInt8TryParseN Function
NInt8TryParseStrOrChars Function
NInt8TryParseVN Function
NNameStringPairCopy Function
NNameStringPairCreate Function
NNameStringPairDispose Function
NNameStringPairSet Function
NOSFamilyGetCurrent Function
NPointerParseN Function
NPointerParseStrOrChars Function
NPointerParseVN Function
NPointerToChars Function
NPointerToString Function
NPointerTryParseN Function
NPointerTryParseStrOrChars Function
NPointerTryParseVN Function
NRangeToString Function
NRationalToString Function
NResultParseN Function
NResultParseStrOrChars Function
NResultParseVN Function
NResultToChars Function
NResultToString Function
NResultTryParseN Function
NResultTryParseStrOrChars Function
NResultTryParseVN Function
NSSizeTypeParseN Function
NSSizeTypeParseStrOrChars Function
NSSizeTypeParseVN Function
NSSizeTypeToChars Function
NSSizeTypeToString Function
NSSizeTypeTryParseN Function
NSSizeTypeTryParseStrOrChars Function
NSSizeTypeTryParseVN Function
NSingleGetNaN Function
NSingleGetNegativeInfinity Function
NSingleGetPositiveInfinity Function
NSingleIsInfinity Function
NSingleIsNaN Function
NSingleIsNegativeInfinity Function
NSingleIsPositiveInfinity Function
NSingleParseN Function
NSingleParseStrOrChars Function
NSingleParseVN Function
NSingleToChars Function
NSingleToString Function
NSingleTryParseN Function
NSingleTryParseStrOrChars Function
NSingleTryParseVN Function
NSizeTypeParseN Function
NSizeTypeParseStrOrChars Function
NSizeTypeParseVN Function
NSizeTypeToChars Function
NSizeTypeToString Function
NSizeTypeTryParseN Function
NSizeTypeTryParseStrOrChars Function
NSizeTypeTryParseVN Function
NSwapDWordArray Function
NSwapDouble Function
NSwapDoubleArray Function
NSwapQWordArray Function
NSwapSingle Function
NSwapSingleArray Function
NSwapWordArray Function
NTypesGetPointer Function
NUInt16ParseN Function
NUInt16ParseStrOrChars Function
NUInt16ParseVN Function
NUInt16ToChars Function
NUInt16ToString Function
NUInt16TryParseN Function
NUInt16TryParseStrOrChars Function
NUInt16TryParseVN Function
NUInt32ParseN Function
NUInt32ParseStrOrChars Function
NUInt32ParseVN Function
NUInt32ToChars Function
NUInt32ToString Function
NUInt32TryParseN Function
NUInt32TryParseStrOrChars Function
NUInt32TryParseVN Function
NUInt64ParseN Function
NUInt64ParseStrOrChars Function
NUInt64ParseVN Function
NUInt64ToChars Function
NUInt64ToString Function
NUInt64TryParseN Function
NUInt64TryParseStrOrChars Function
NUInt64TryParseVN Function
NUInt8ParseN Function
NUInt8ParseStrOrChars Function
NUInt8ParseVN Function
NUInt8ToChars Function
NUInt8ToString Function
NUInt8TryParseN Function
NUInt8TryParseStrOrChars Function
NUInt8TryParseVN Function
NURationalToString Function
NVersionRangeContains Function
NVersionRangeContainsRange Function
NVersionRangeIntersect Function
NVersionRangeIntersectsWith Function
NVersionRangeToString Function
NVersionToString Function
NWCharParseN Function
NWCharParseStrOrChars Function
NWCharParseVN Function
NWCharToChars Function
NWCharToString Function
NWCharTryParseN Function
NWCharTryParseStrOrChars Function
NWCharTryParseVN Function
Collapse Expand Structs, Records, Enums
NComplex_ Structure
NIndexPair_ Structure
NNameStringPair_ Structure
NRational_ Structure
NURational_ Structure
NAttributes Enumeration
NOSFamily Enumeration
Collapse Expand Types
NAChar Type
NBool Type
NBoolean Type
NByte Type
NChar Type
NComplex Type
NDouble Type
NFloat Type
NHandle Type
NIndexPair Type
NInt Type
NInt16 Type
NInt32 Type
NInt64 Type
NInt8 Type
NLong Type
NNameStringPair Type
NRational Type
NResult Type
NSByte Type
NSSizeType Type
NShort Type
NSingle Type
NSizeType Type
NUInt Type
NUInt16 Type
NUInt32 Type
NUInt64 Type
NUInt8 Type
NULong Type
NURational Type
NUShort Type
NVersion Type
NVersionRange Type
NVersionRange_ Type
NVersion_ Type
Collapse Expand Macros
N_DECLARE_HANDLE Macro
NACharParse Macro
NACharParseChars Macro
NACharParseStrOrChars Macro
NACharParseVN Macro
NACharToChars Macro
NACharToString Macro
NACharTryParse Macro
NACharTryParseChars Macro
NACharTryParseStrOrChars Macro
NACharTryParseVN Macro
NBooleanParse Macro
NBooleanParseChars Macro
NBooleanParseStrOrChars Macro
NBooleanParseVN Macro
NBooleanToChars Macro
NBooleanToString Macro
NBooleanTryParse Macro
NBooleanTryParseChars Macro
NBooleanTryParseStrOrChars Macro
NBooleanTryParseVN Macro
NCharFromBinDigit Macro
NCharFromDigit Macro
NCharFromHexDigit Macro
NCharFromOctDigit Macro
NCharIsAscii Macro
NCharIsBinDigit Macro
NCharIsDigit Macro
NCharIsHexDigit Macro
NCharIsLetter Macro
NCharIsLower Macro
NCharIsOctDigit Macro
NCharIsUpper Macro
NCharIsWhiteSpace Macro
NCharParse Macro
NCharParseChars Macro
NCharToBinDigit Macro
NCharToDigit Macro
NCharToHexDigit Macro
NCharToLower Macro
NCharToOctDigit Macro
NCharToUpper Macro
NCharTryParse Macro
NCharTryParseChars Macro
NDoubleParse Macro
NDoubleParseChars Macro
NDoubleParseStrOrChars Macro
NDoubleParseVN Macro
NDoubleToChars Macro
NDoubleToString Macro
NDoubleTryParse Macro
NDoubleTryParseChars Macro
NDoubleTryParseStrOrChars Macro
NDoubleTryParseVN Macro
NFalse Macro
NGuidParse Macro
NGuidParseVN Macro
NGuidToString Macro
NGuidTryParse Macro
NGuidTryParseVN Macro
NIndexPairToString Macro
NInt16Parse Macro
NInt16ParseChars Macro
NInt16ParseStrOrChars Macro
NInt16ParseVN Macro
NInt16ToChars Macro
NInt16ToString Macro
NInt16TryParse Macro
NInt16TryParseChars Macro
NInt16TryParseStrOrChars Macro
NInt16TryParseVN Macro
NInt32Parse Macro
NInt32ParseChars Macro
NInt32ParseStrOrChars Macro
NInt32ParseVN Macro
NInt32ToChars Macro
NInt32ToString Macro
NInt32TryParse Macro
NInt32TryParseChars Macro
NInt32TryParseStrOrChars Macro
NInt32TryParseVN Macro
NInt64Parse Macro
NInt64ParseChars Macro
NInt64ParseStrOrChars Macro
NInt64ParseVN Macro
NInt64ToChars Macro
NInt64ToString Macro
NInt64TryParse Macro
NInt64TryParseChars Macro
NInt64TryParseStrOrChars Macro
NInt64TryParseVN Macro
NInt8Parse Macro
NInt8ParseChars Macro
NInt8ParseStrOrChars Macro
NInt8ParseVN Macro
NInt8ToChars Macro
NInt8ToString Macro
NInt8TryParse Macro
NInt8TryParseChars Macro
NInt8TryParseStrOrChars Macro
NInt8TryParseVN Macro
NPointerParse Macro
NPointerParseChars Macro
NPointerParseStrOrChars Macro
NPointerParseVN Macro
NPointerToChars Macro
NPointerToString Macro
NPointerTryParse Macro
NPointerTryParseChars Macro
NPointerTryParseStrOrChars Macro
NPointerTryParseVN Macro
NRangeToString Macro
NRationalToString Macro
NResultParseVN Macro
NResultToChars Macro
NResultToString Macro
NResultTryParseStrOrChars Macro
NResultTryParseVN Macro
NSSizeTypeParse Macro
NSSizeTypeParseChars Macro
NSSizeTypeParseStrOrChars Macro
NSSizeTypeParseVN Macro
NSSizeTypeToChars Macro
NSSizeTypeToString Macro
NSSizeTypeTryParse Macro
NSSizeTypeTryParseChars Macro
NSSizeTypeTryParseStrOrChars Macro
NSSizeTypeTryParseVN Macro
NSingleParse Macro
NSingleParseChars Macro
NSingleParseStrOrChars Macro
NSingleParseVN Macro
NSingleToChars Macro
NSingleToString Macro
NSingleTryParse Macro
NSingleTryParseChars Macro
NSingleTryParseStrOrChars Macro
NSingleTryParseVN Macro
NSizeTypeParse Macro
NSizeTypeParseChars Macro
NSizeTypeParseStrOrChars Macro
NSizeTypeParseVN Macro
NSizeTypeToChars Macro
NSizeTypeToString Macro
NSizeTypeTryParse Macro
NSizeTypeTryParseChars Macro
NSizeTypeTryParseStrOrChars Macro
NSizeTypeTryParseVN Macro
NTrue Macro
NUInt16Parse Macro
NUInt16ParseChars Macro
NUInt16ParseStrOrChars Macro
NUInt16ParseVN Macro
NUInt16ToChars Macro
NUInt16ToString Macro
NUInt16TryParse Macro
NUInt16TryParseChars Macro
NUInt16TryParseStrOrChars Macro
NUInt16TryParseVN Macro
NUInt32Parse Macro
NUInt32ParseChars Macro
NUInt32ParseStrOrChars Macro
NUInt32ParseVN Macro
NUInt32ToChars Macro
NUInt32ToString Macro
NUInt32TryParse Macro
NUInt32TryParseChars Macro
NUInt32TryParseStrOrChars Macro
NUInt32TryParseVN Macro
NUInt64Parse Macro
NUInt64ParseChars Macro
NUInt64ParseStrOrChars Macro
NUInt64ParseVN Macro
NUInt64ToChars Macro
NUInt64ToString Macro
NUInt64TryParse Macro
NUInt64TryParseChars Macro
NUInt64TryParseStrOrChars Macro
NUInt64TryParseVN Macro
NUInt8Parse Macro
NUInt8ParseChars Macro
NUInt8ParseStrOrChars Macro
NUInt8ParseVN Macro
NUInt8ToChars Macro
NUInt8ToString Macro
NUInt8TryParse Macro
NUInt8TryParseChars Macro
NUInt8TryParseStrOrChars Macro
NUInt8TryParseVN Macro
NULL Macro
NURationalToString Macro
NVersionRangeToString Macro
NVersionToString Macro
NWCharParse Macro
NWCharParseChars Macro
NWCharParseStrOrChars Macro
NWCharParseVN Macro
NWCharToChars Macro
NWCharToString Macro
NWCharTryParse Macro
NWCharTryParseChars Macro
NWCharTryParseStrOrChars Macro
NWCharTryParseVN Macro
N_BOOLEAN_FALSE_STRING Macro
N_BOOLEAN_FALSE_STRINGA Macro
N_BOOLEAN_FALSE_STRINGW Macro
N_BOOLEAN_TRUE_STRING Macro
N_BOOLEAN_TRUE_STRINGA Macro
N_BOOLEAN_TRUE_STRINGW Macro
N_BYTE_MAX Macro
N_BYTE_MIN Macro
N_DECLARE_HANDLE_TYPE Macro
N_DECLARE_OBJECT_TYPE Macro
N_DECLARE_STATIC_OBJECT_TYPE Macro
N_DECLARE_TYPE Macro
N_DECLATE_PRIMITIVE Macro
N_DOUBLE_EPSILON Macro
N_DOUBLE_MAX Macro
N_DOUBLE_MIN Macro
N_FLOAT_EPSILON Macro
N_FLOAT_INFINITY_STRING Macro
N_FLOAT_INFINITY_STRINGA Macro
N_FLOAT_INFINITY_STRINGW Macro
N_FLOAT_MAX Macro
N_FLOAT_MIN Macro
N_FLOAT_NAN_STRING Macro
N_FLOAT_NAN_STRINGA Macro
N_FLOAT_NAN_STRINGW Macro
N_INT16_MAX Macro
N_INT16_MIN Macro
N_INT32_MAX Macro
N_INT32_MIN Macro
N_INT64_MAX Macro
N_INT64_MIN Macro
N_INT8_MAX Macro
N_INT8_MIN Macro
N_INT_MAX Macro
N_INT_MIN Macro
N_LONG_MAX Macro
N_LONG_MIN Macro
N_PTR_SIZE Macro
N_SBYTE_MAX Macro
N_SBYTE_MIN Macro
N_SHORT_MAX Macro
N_SHORT_MIN Macro
N_SINGLE_EPSILON Macro
N_SINGLE_MAX Macro
N_SINGLE_MIN Macro
N_SIZE_TYPE_MAX Macro
N_SIZE_TYPE_MIN Macro
N_SSIZE_TYPE_MAX Macro
N_SSIZE_TYPE_MIN Macro
N_TYPE_OF Macro
N_UINT16_MAX Macro
N_UINT16_MIN Macro
N_UINT32_MAX Macro
N_UINT32_MIN Macro
N_UINT64_MAX Macro
N_UINT64_MIN Macro
N_UINT8_MAX Macro
N_UINT8_MIN Macro
N_UINT_MAX Macro
N_UINT_MIN Macro
N_ULONG_MAX Macro
N_ULONG_MIN Macro
N_UNREFERENCED_PARAMETER Macro
N_UNUSED_VARIABLE Macro
N_USHORT_MAX Macro
N_USHORT_MIN Macro
N_WCHAR_SIZE Macro
Collapse Expand Files
NTypes.h
Collapse Expand NValue Unit
Collapse Expand Functions
NKeyValuePairCopy Function
NKeyValuePairCreate Function
NKeyValuePairDispose Function
NKeyValuePairSet Function
NNameValuePairCopy Function
NNameValuePairCreate Function
NNameValuePairDispose Function
NNameValuePairSet Function
NValueChangeType Function
NValueChangeTypeP Function
NValueCreate Function
NValueCreateCustom Function
NValueCreateCustomN Function
NValueCreateFromBoolean Function
NValueCreateFromByte Function
NValueCreateFromCallback Function
NValueCreateFromChar Function
NValueCreateFromDouble Function
NValueCreateFromInt16 Function
NValueCreateFromInt32 Function
NValueCreateFromInt64 Function
NValueCreateFromObject Function
NValueCreateFromObjectP Function
NValueCreateFromPointer Function
NValueCreateFromResult Function
NValueCreateFromSByte Function
NValueCreateFromSSizeType Function
NValueCreateFromSingle Function
NValueCreateFromSizeType Function
NValueCreateFromString Function
NValueCreateFromUInt16 Function
NValueCreateFromUInt32 Function
NValueCreateFromUInt64 Function
NValueCreateP Function
NValueGetAttributes Function
NValueGetFree Function
NValueGetPtr Function
NValueGetSize Function
NValueGetTypeCode Function
NValueGetValueType Function
NValueSet Function
NValueSetP Function
NValueToBoolean Function
NValueToByte Function
NValueToCallback Function
NValueToChar Function
NValueToDouble Function
NValueToInt16 Function
NValueToInt32 Function
NValueToInt64 Function
NValueToObject Function
NValueToObjectP Function
NValueToPointer Function
NValueToResult Function
NValueToSByte Function
NValueToSSizeType Function
NValueToSingle Function
NValueToSizeType Function
NValueToString Function
NValueToUInt16 Function
NValueToUInt32 Function
NValueToUInt64 Function
NValueToValue Function
NValueToValueP Function
Collapse Expand Structs, Records, Enums
NKeyValuePair_ Structure
NNameValuePair_ Structure
Collapse Expand Macros
NNameValuePairCreate Macro
NValueCreateFromChar Macro
NValueCreateFromString Macro
NValueToChar Macro
Collapse Expand Files
NValue.h
Collapse Expand NWaitObject Unit
Collapse Expand Functions
NWaitObjectWaitFor Function
NWaitObjectWaitForTimed Function
Collapse Expand Macros
N_INFINITE Macro
Collapse Expand NWindows Unit
Collapse Expand Files
NWindows.h
Collapse Expand NDevices Library
Collapse Expand NBiometricDevice Unit
Collapse Expand Functions
NBiometricDeviceAddCapturePreview Function
NBiometricDeviceAddCapturePreviewCallback Function
NBiometricDeviceCancel Function
NBiometricDeviceCapture Function
NBiometricDeviceEndSequence Function
NBiometricDeviceGetBiometricType Function
NBiometricDeviceGetProductId Function
NBiometricDeviceGetSpoofDetection Function
NBiometricDeviceGetVendorId Function
NBiometricDeviceIsSpoofDetectionSupported Function
NBiometricDeviceRemoveCapturePreview Function
NBiometricDeviceRemoveCapturePreviewCallback Function
NBiometricDeviceSetSpoofDetection Function
NBiometricDeviceStartSequence Function
Collapse Expand Files
NBiometricDevice.h
Collapse Expand NCamera Unit
Collapse Expand Functions
NCameraAddStillCaptured Function
NCameraAddStillCapturedCallback Function
NCameraCaptureStill Function
NCameraFocus Function
NCameraGetCurrentStillFormat Function
NCameraGetFocusRegion Function
NCameraGetFrame Function
NCameraGetFrameEx Function
NCameraGetStillFormats Function
NCameraGetVideoSample Function
NCameraIsFocusRegionSupported Function
NCameraIsFocusSupported Function
NCameraIsStillCaptureSupported Function
NCameraIsVideoSampleSupported Function
NCameraRemoveStillCaptured Function
NCameraRemoveStillCapturedCallback Function
NCameraResetFocus Function
NCameraSetCurrentStillFormat Function
NCameraSetFocusRegion Function
Collapse Expand Structs, Records, Enums
NCameraStatus Enumeration
Collapse Expand NCaptureDevice Unit
Collapse Expand Functions
NCaptureDeviceAddIsCapturingChanged Function
NCaptureDeviceAddIsCapturingChangedCallback Function
NCaptureDeviceGetCurrentFormat Function
NCaptureDeviceGetFormats Function
NCaptureDeviceGetMediaType Function
NCaptureDeviceIsCapturing Function
NCaptureDeviceRemoveIsCapturingChanged Function
NCaptureDeviceRemoveIsCapturingChangedCallback Function
NCaptureDeviceSetCurrentFormat Function
NCaptureDeviceStartCapturing Function
NCaptureDeviceStopCapturing Function
Collapse Expand NDevice Unit
Collapse Expand Functions
NDeviceGetChild Function
NDeviceGetChildCount Function
NDeviceGetChildren Function
NDeviceGetDeviceType Function
NDeviceGetDisplayNameN Function
NDeviceGetIdN Function
NDeviceGetMakeN Function
NDeviceGetModelN Function
NDeviceGetParent Function
NDeviceGetPlugin Function
NDeviceGetSerialNumberN Function
NDeviceIsAvailable Function
NDeviceIsDisconnectable Function
NDeviceIsPrivate Function
Collapse Expand Structs, Records, Enums
NDeviceType Enumeration
Collapse Expand Files
NDevice.h
Collapse Expand NDeviceEventDescriptor Unit
Collapse Expand Functions
NDeviceEventDescriptorCreate Function
Collapse Expand Files
NDeviceEventDescriptor.h
Collapse Expand NDeviceManager Unit
Collapse Expand Functions
NDeviceManagerAddDevicesCollectionChanged Function
NDeviceManagerAddDevicesCollectionChangedCallback Function
NDeviceManagerConnectToDevice Function
NDeviceManagerConnectToDeviceWithString Function
NDeviceManagerCreateEx Function
NDeviceManagerDisconnectFromDevice Function
NDeviceManagerGetAutoPlug Function
NDeviceManagerGetBiometricEngine Function
NDeviceManagerGetConnectToDeviceParameters Function
NDeviceManagerGetDevice Function
NDeviceManagerGetDeviceById Function
NDeviceManagerGetDeviceCount Function
NDeviceManagerGetDeviceTypes Function
NDeviceManagerGetDevices Function
NDeviceManagerGetPluginManager Function
NDeviceManagerInitialize Function
NDeviceManagerIsConnectToDeviceSupported Function
NDeviceManagerIsInitialized Function
NDeviceManagerRemoveDevicesCollectionChanged Function
NDeviceManagerRemoveDevicesCollectionChangedCallback Function
NDeviceManagerSetAutoPlug Function
NDeviceManagerSetBiometricEngine Function
NDeviceManagerSetDeviceTypes Function
Collapse Expand Macros
NDeviceManagerGetDeviceById Macro
Collapse Expand Files
NDeviceManager.h
Collapse Expand NDeviceMethodDescriptor Unit
Collapse Expand Functions
NDeviceMethodDescriptorCreate Function
Collapse Expand Files
NDeviceMethodDescriptor.h
Collapse Expand NDevicePropertyDescriptor Unit
Collapse Expand Functions
NDevicePropertyDescriptorCreate Function
Collapse Expand Files
NDevicePropertyDescriptor.h
NDevices Unit
Collapse Expand NLicensing Library
Collapse Expand NLicense Unit
Collapse Expand Functions
NLicenseActivateOnline Function
NLicenseAdd Function
NLicenseDeactivateOnline Function
NLicenseDeactivateOnlineWithId Function
NLicenseGenerateDeactivationId Function
NLicenseGenerateDeactivationIdForLicense Function
NLicenseGenerateId Function
NLicenseGetLicenseInfoOnline Function
NLicenseGetObtainedComponentStatus Function
NLicenseGetObtainedLicenseInfo Function
NLicenseGetObtainedLicenseInfoForComponent Function
NLicenseGetObtainedStatus Function
NLicenseIsComponentActivated Function
NLicenseObtain Function
NLicenseObtainComponents Function
NLicenseRelease Function
NLicenseReleaseComponents Function
Collapse Expand Structs, Records, Enums
NLicenseObtainedStatus Enumeration
Collapse Expand Macros
NLicenseActivateOnline Macro
NLicenseAdd Macro
NLicenseDeactivateOnline Macro
NLicenseDeactivateOnlineWithId Macro
NLicenseGenerateDeactivationId Macro
NLicenseGenerateDeactivationIdForLicense Macro
NLicenseGenerateId Macro
NLicenseGetLicenseInfoOnline Macro
NLicenseGetObtainedComponentStatus Macro
NLicenseGetObtainedLicenseInfo Macro
NLicenseGetObtainedLicenseInfoForComponent Macro
NLicenseGetObtainedStatus Macro
NLicenseIsComponentActivated Macro
NLicenseObtainComponents Macro
NLicenseReleaseComponents Macro
Collapse Expand Files
NLicense.h
Collapse Expand NLicenseInfo Unit
Collapse Expand Functions
NLicenseInfoGetDistributorId Function
NLicenseInfoGetLicenseId Function
NLicenseInfoGetLicenses Function
NLicenseInfoGetSequenceNumber Function
NLicenseInfoGetSourceType Function
NLicenseInfoGetStatus Function
NLicenseInfoGetType Function
NLicenseProductInfoGetId Function
NLicenseProductInfoGetLicenseCount Function
NLicenseProductInfoGetLicenseType Function
NLicenseProductInfoGetOSFamily Function
NLicenseProductInfoGetParameters Function
Collapse Expand Structs, Records, Enums
NLicenseInfoSourceType Enumeration
NLicenseInfoStatus Enumeration
NLicenseInfoType Enumeration
NLicenseType Enumeration
Collapse Expand NLicenseManager Unit
Collapse Expand Functions
NLicManFindFirstDongle Function
NLicManFindNextDongle Function
NLicManGenerateLicenseExN Function
NLicManGenerateLicenseN Function
NLicManGenerateSerialExN Function
NLicManGenerateSerialN Function
NLicManGetClientId Function
NLicManGetDongles Function
NLicManGetLicenseData Function
NLicManGetLicenseDataEx Function
NLicManGetLongProductNameForProductInfoN Function
NLicManGetLongProductNameN Function
NLicManGetProductIds Function
NLicManGetProxyHost Function
NLicManGetProxyPassword Function
NLicManGetProxyPort Function
NLicManGetProxyUsername Function
NLicManGetShortProductNameForProductInfoN Function
NLicManGetShortProductNameN Function
NLicManGetTrialMode Function
NLicManGetUpdateTicketInfo Function
NLicManGetUseHttps Function
NLicManGetWritableStoragePath Function
NLicManInitialize Function
NLicManIsLicenseTypeSupported Function
NLicManSetClientIdN Function
NLicManSetProxyHostN Function
NLicManSetProxyPasswordN Function
NLicManSetProxyPort Function
NLicManSetProxyUsernameN Function
NLicManSetTrialMode Function
NLicManSetUseHttps Function
NLicManSetWritableStoragePathN Function
Collapse Expand Macros
NLicManGetLicenseData Macro
NLicManGetLicenseDataEx Macro
NLicManGetUpdateTicketInfo Macro
N_LIC_MAN_MAX_LICENSE_LENGTH Macro
N_LIC_MAN_MAX_SERIAL_LENGTH Macro
Collapse Expand NLicensing Unit
Collapse Expand Files
NLicensing.h
NLicensingService Unit
Collapse Expand NMedia Library
Collapse Expand Bmp Unit
Collapse Expand Files
Bmp.h
Collapse Expand IHead Unit
Collapse Expand Files
IHead.h
Collapse Expand Jpeg Unit
Collapse Expand Functions
JpegInfoGetQuality Function
JpegInfoIsLossless Function
JpegInfoSetLossless Function
JpegInfoSetQuality Function
Collapse Expand Macros
JPEG_DEFAULT_QUALITY Macro
Collapse Expand Files
Jpeg.h
Collapse Expand Jpeg2K Unit
Collapse Expand Functions
Jpeg2KInfoGetProfile Function
Jpeg2KInfoGetRatio Function
Jpeg2KInfoSetProfile Function
Jpeg2KInfoSetRatio Function
Collapse Expand Structs, Records, Enums
Jpeg2KProfile Enumeration
Collapse Expand Macros
JPEG_2K_DEFAULT_RATIO Macro
Collapse Expand Files
Jpeg2K.h
Collapse Expand NGeometry Unit
Collapse Expand Structs, Records, Enums
NPoint3F_ Structure
NRect_ Structure
NPoint_ Structure
NSize_ Structure
NInterpolationMode Enumeration
NPointD_ Structure
NPointF_ Structure
NRectD_ Structure
NRectF_ Structure
NSizeD_ Structure
NSizeF_ Structure
Collapse Expand Types
NPoint Type
NPoint3F Type
NRect Type
NSize Type
NPointD Type
NPointF Type
NRectD Type
NRectF Type
NSizeD Type
NSizeF Type
Collapse Expand Files
NGeometry.h
Collapse Expand NImageInfo Unit
Collapse Expand Functions
NImageInfoCreate Function
NImageInfoGetFormatEx Function
NImageInfoGetHeight Function
NImageInfoGetTransform Function
NImageInfoGetWidth Function
NImageInfoSetTransform Function
NImageRotateFlipTypeCreate Function
NImageRotateFlipTypeFlipTypeIsValid Function
NImageRotateFlipTypeGetFlipType Function
NImageRotateFlipTypeGetRotateType Function
NImageRotateFlipTypeIsValid Function
NImageRotateFlipTypeMinimizeFlip Function
NImageRotateFlipTypeMinimizeRotation Function
NImageRotateFlipTypeRotateTypeIsValid Function
Collapse Expand Structs, Records, Enums
NImageRotateFlipType Enumeration
NImageCompressionAlgorithm Enumeration
Collapse Expand Files
NImageInfo.h
Collapse Expand NImageReader Unit
Collapse Expand Functions
NImageReaderGetFormatEx Function
NImageReaderGetReadSize Function
NImageReaderRead Function
NImageReaderReadInfo Function
Collapse Expand Files
NImageReader.h
Collapse Expand NImages Unit
Collapse Expand Functions
NImagesGetGrayscaleColorWrapperEx Function
NImagesRecolorImage Function
Collapse Expand Files
NImages.h
Collapse Expand NImageWriter Unit
Collapse Expand Functions
NImageWriterGetBuffer Function
NImageWriterGetFormatEx Function
NImageWriterWrite Function
Collapse Expand Files
NImageWriter.h
Collapse Expand NMediaFormat Unit
Collapse Expand Functions
NMediaFormatGetMediaSubtype Function
NMediaFormatGetMediaType Function
NMediaFormatIsCompatibleWith Function
NMediaFormatSetMediaSubtype Function
HNMediaFormat
Collapse Expand Files
NMediaFormat.h
Collapse Expand NMediaReader Unit
Collapse Expand Functions
NMediaReaderCreate Function
NMediaReaderCreateFromFile Function
NMediaReaderCreateFromUrl Function
NMediaReaderGetLength Function
NMediaReaderGetPosition Function
NMediaReaderGetSource Function
NMediaReaderGetState Function
NMediaReaderReadAudioSample Function
NMediaReaderIsLive Function
NMediaReaderReadVideoSample Function
NMediaReaderPause Function
NMediaReaderReadVideoSampleData Function
NMediaReaderSetPosition Function
NMediaReaderStart Function
NMediaReaderStop Function
HNMediaReader
Collapse Expand Macros
NMediaReaderCreateFromFile Macro
NMediaReaderCreateFromUrl Macro
Collapse Expand Files
NMediaReader.h
Collapse Expand NMediaSource Unit
Collapse Expand Functions
NMediaSourceCreateFromFile Function
NMediaSourceCreateFromUrl Function
NMediaSourceGetDisplayNameN Function
NMediaSourceEnumDevices Function
NMediaSourceGetCurrentFormat Function
NMediaSourceGetIdN Function
NMediaSourceGetFormats Function
NMediaSourceGetMediaType Function
NMediaSourceSetCurrentFormat Function
HNmediaSource
Collapse Expand Macros
NMS_ALLOW_DUPLICATE_DEVICES Macro
NMS_DO_NOT_USE_DIRECT_SHOW Macro
NMS_DO_NOT_USE_VLC Macro
NMS_DO_NOT_USE_WINDOWS_MEDIA Macro
NMS_DO_NOT_USE_WINDOWS_MEDIA_FOUNDATION Macro
NMS_PREFER_DIRECT_SHOW Macro
NMS_PREFER_VLC Macro
NMS_PREFER_WINDOWS_MEDIA Macro
NMS_PREFER_WINDOWS_MEDIA_FOUNDATION Macro
Collapse Expand Files
NMediaSource.h
Collapse Expand NMediaTypes Unit
Collapse Expand Functions
NMediaTypeIsValid Function
NMediaTypeIsValidSingle Function
NVideoInterlaceModeIsValid Function
Collapse Expand Structs, Records, Enums
NMediaState Enumeration
NMediaType Enumeration
NVideoInterlaceMode Enumeration
Collapse Expand Files
NMediaTypes.h
Collapse Expand NPixelFormat Unit
Collapse Expand Functions
NPixelFormatCalcRowSize Function
NPixelFormatCreate Function
NPixelFormatGetBitsPerPixel Function
NPixelFormatGetBytesPerPixel Function
NPixelFormatGetIndexed Function
NPixelFormatGetNonIndexed Function
NPixelFormatGetNonSeparated Function
NPixelFormatGetPaletteSize Function
NPixelFormatGetPixelType Function
NPixelFormatGetRowSize Function
NPixelFormatGetSeparated Function
NPixelFormatGetWithExtraChannel Function
NPixelFormatIsValid Function
NPixelFormatToString Function
NPixelTypeCanBeIndexed Function
NPixelTypeIsValid Function
Collapse Expand Structs, Records, Enums
NPixelType Enumeration
Collapse Expand Types
NPixelFormat Type
NPixelFormat_ Type
Collapse Expand Macros
NPF_GRAYSCALE_16S Macro
NPF_GRAYSCALE_16U Macro
NPF_GRAYSCALE_1U Macro
NPF_GRAYSCALE_2U Macro
NPF_GRAYSCALE_32F Macro
NPF_GRAYSCALE_32S Macro
NPF_GRAYSCALE_32U Macro
NPF_GRAYSCALE_4U Macro
NPF_GRAYSCALE_64F Macro
NPF_GRAYSCALE_64S Macro
NPF_GRAYSCALE_64U Macro
NPF_GRAYSCALE_8S Macro
NPF_GRAYSCALE_8U Macro
NPF_GRAYSCALE_A_16S Macro
NPF_GRAYSCALE_A_16U Macro
NPF_GRAYSCALE_A_32F Macro
NPF_GRAYSCALE_A_32S Macro
NPF_GRAYSCALE_A_32U Macro
NPF_GRAYSCALE_A_64F Macro
NPF_GRAYSCALE_A_64S Macro
NPF_GRAYSCALE_A_64U Macro
NPF_GRAYSCALE_A_8S Macro
NPF_GRAYSCALE_A_8U Macro
NPF_GRAYSCALE_PA_16S Macro
NPF_GRAYSCALE_PA_16U Macro
NPF_GRAYSCALE_PA_32F Macro
NPF_GRAYSCALE_PA_32S Macro
NPF_GRAYSCALE_PA_32U Macro
NPF_GRAYSCALE_PA_64F Macro
NPF_GRAYSCALE_PA_64S Macro
NPF_GRAYSCALE_PA_64U Macro
NPF_GRAYSCALE_PA_8S Macro
NPF_GRAYSCALE_PA_8U Macro
NPF_RGB_16S Macro
NPF_RGB_16U Macro
NPF_RGB_32F Macro
NPF_RGB_32S Macro
NPF_RGB_32U Macro
NPF_RGB_64F Macro
NPF_RGB_64S Macro
NPF_RGB_64U Macro
NPF_RGB_8S Macro
NPF_RGB_8U Macro
NPF_RGB_8U_INDEXED_1 Macro
NPF_RGB_8U_INDEXED_2 Macro
NPF_RGB_8U_INDEXED_4 Macro
NPF_RGB_8U_INDEXED_8 Macro
NPF_RGB_A_16S Macro
NPF_RGB_A_16U Macro
NPF_RGB_A_32F Macro
NPF_RGB_A_32S Macro
NPF_RGB_A_32U Macro
NPF_RGB_A_64F Macro
NPF_RGB_A_64S Macro
NPF_RGB_A_64U Macro
NPF_RGB_A_8S Macro
NPF_RGB_A_8U Macro
NPF_RGB_A_8U_INDEXED_1 Macro
NPF_RGB_A_8U_INDEXED_2 Macro
NPF_RGB_A_8U_INDEXED_4 Macro
NPF_RGB_A_8U_INDEXED_8 Macro
NPF_RGB_PA_16S Macro
NPF_RGB_PA_16U Macro
NPF_RGB_PA_32F Macro
NPF_RGB_PA_32S Macro
NPF_RGB_PA_32U Macro
NPF_RGB_PA_64F Macro
NPF_RGB_PA_64S Macro
NPF_RGB_PA_64U Macro
NPF_RGB_PA_8S Macro
NPF_RGB_PA_8U Macro
NPF_UNDEFINED Macro
NPixelFormatToString Macro
Collapse Expand Files
NPixelFormat.h
Collapse Expand NRgb Unit
Collapse Expand Functions
NRgbToString Function
Collapse Expand Structs, Records, Enums
NRgb_ Structure
Collapse Expand Types
NRgb Type
Collapse Expand Macros
NRgbToString Macro
Collapse Expand Files
NRgb.h
Collapse Expand NVideoFormat Unit
Collapse Expand Functions
NVideoFormatCreate Function
NVideoFormatGetFrameRate Function
NVideoFormatGetHeight Function
NVideoFormatGetInterlaceMode Function
NVideoFormatGetPixelAspectRatio Function
NVideoFormatGetStride Function
NVideoFormatGetWidth Function
NVideoFormatMediaSubtypeToString Function
NVideoFormatSetFrameRate Function
NVideoFormatSetHeight Function
NVideoFormatSetInterlaceMode Function
NVideoFormatSetPixelAspectRatio Function
NVideoFormatSetStride Function
NVideoFormatSetWidth Function
Collapse Expand Macros
NVideoFormatMediaSubtypeToString Macro
N_VIDEO_FORMAT_AI44 Macro
N_VIDEO_FORMAT_ARGB32 Macro
N_VIDEO_FORMAT_AVC1 Macro
N_VIDEO_FORMAT_AYUV Macro
N_VIDEO_FORMAT_DV25 Macro
N_VIDEO_FORMAT_DV50 Macro
N_VIDEO_FORMAT_DVC Macro
N_VIDEO_FORMAT_DVH1 Macro
N_VIDEO_FORMAT_DVHD Macro
N_VIDEO_FORMAT_DVSD Macro
N_VIDEO_FORMAT_DVSL Macro
N_VIDEO_FORMAT_DX50 Macro
N_VIDEO_FORMAT_H264 Macro
N_VIDEO_FORMAT_I420 Macro
N_VIDEO_FORMAT_IYUV Macro
N_VIDEO_FORMAT_L16 Macro
N_VIDEO_FORMAT_L8 Macro
N_VIDEO_FORMAT_M4S2 Macro
N_VIDEO_FORMAT_MJPG Macro
N_VIDEO_FORMAT_MP43 Macro
N_VIDEO_FORMAT_MP4S Macro
N_VIDEO_FORMAT_MP4V Macro
N_VIDEO_FORMAT_MPG1 Macro
N_VIDEO_FORMAT_MSS1 Macro
N_VIDEO_FORMAT_MSS2 Macro
N_VIDEO_FORMAT_NV11 Macro
N_VIDEO_FORMAT_NV12 Macro
N_VIDEO_FORMAT_NV21 Macro
N_VIDEO_FORMAT_P010 Macro
N_VIDEO_FORMAT_P016 Macro
N_VIDEO_FORMAT_P210 Macro
N_VIDEO_FORMAT_P216 Macro
N_VIDEO_FORMAT_RGB24 Macro
N_VIDEO_FORMAT_RGB32 Macro
N_VIDEO_FORMAT_RGB555 Macro
N_VIDEO_FORMAT_RGB565 Macro
N_VIDEO_FORMAT_RGB8 Macro
N_VIDEO_FORMAT_UNKNOWN Macro
N_VIDEO_FORMAT_UYVY Macro
N_VIDEO_FORMAT_V210 Macro
N_VIDEO_FORMAT_V216 Macro
N_VIDEO_FORMAT_V410 Macro
N_VIDEO_FORMAT_WMV1 Macro
N_VIDEO_FORMAT_WMV2 Macro
N_VIDEO_FORMAT_WMV3 Macro
N_VIDEO_FORMAT_WVC1 Macro
N_VIDEO_FORMAT_Y210 Macro
N_VIDEO_FORMAT_Y216 Macro
N_VIDEO_FORMAT_Y410 Macro
N_VIDEO_FORMAT_Y416 Macro
N_VIDEO_FORMAT_Y41P Macro
N_VIDEO_FORMAT_Y41T Macro
N_VIDEO_FORMAT_Y42T Macro
N_VIDEO_FORMAT_YUY2 Macro
N_VIDEO_FORMAT_YV12 Macro
N_VIDEO_FORMAT_YVU9 Macro
N_VIDEO_FORMAT_YVYU Macro
Collapse Expand Files
NVideoFormat.h
Collapse Expand Png Unit
Collapse Expand Functions
PngInfoGetCompressionLevel Function
PngInfoSetCompressionLevel Function
Collapse Expand Macros
PNG_DEFAULT_COMPRESSION_LEVEL Macro
Collapse Expand Files
Png.h
Collapse Expand Tiff Unit
Collapse Expand Files
Tiff.h
Collapse Expand Wsq Unit
Collapse Expand Functions
WsqInfoGetBitRate Function
WsqInfoGetImplementationNumber Function
WsqInfoGetNistCom Function
WsqInfoHasNistCom Function
WsqInfoSetBitRate Function
WsqInfoSetHasNistCom Function
Collapse Expand Macros
WSQ_DEFAULT_BIT_RATE Macro
WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_DEBIAN_AMD64_LEGACY Macro
WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_DEBIAN_I386_LEGACY Macro
WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_MACOSX_INTEL64 Macro
WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_MACOSX_INTEL_LEGACY Macro
WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_MACOSX_POWERPC_LEGACY Macro
WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_WIN32_X86 Macro
WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_WIN64_X64 Macro
WSQ_RECOVER_CORRUPT_FILE Macro
Collapse Expand Files
Wsq.h
Collapse Expand NSurveillance Library
Collapse Expand NClothingDetails Unit
Collapse Expand Functions
NClothingDetailsGetGender Function
NClothingDetailsGetGenderConfidence Function
NClothingDetailsGetKnownValues Function
NClothingDetailsGetValue Function
NClothingDetailsGetValueCount Function
NClothingDetailsGetValues Function
N_DECLARE_OBJECT_TYPE Function
Collapse Expand NLicensePlate Unit
Collapse Expand Functions
NLicensePlateDetailsGetBestLicensePlate Function
NLicensePlateDetailsGetBestLicensePlateCount Function
NLicensePlateDetailsGetBestLicensePlates Function
NLicensePlateDetailsGetCurrentLicensePlate Function
NLicensePlateDetailsGetCurrentLicensePlateCount Function
NLicensePlateDetailsGetCurrentLicensePlates Function
NLicensePlateGetBoundingBox Function
NLicensePlateGetDetectionConfidence Function
NLicensePlateGetFrameIndex Function
NLicensePlateGetOcrConfidence Function
NLicensePlateGetOrigin Function
NLicensePlateGetRectangle Function
NLicensePlateGetRotation Function
NLicensePlateGetType Function
NLicensePlateGetValue Function
Collapse Expand NNameConfidencePair Unit
Collapse Expand Functions
NNameConfidencePairCopy Function
NNameConfidencePairCreate Function
NNameConfidencePairDispose Function
NNameConfidencePairSet Function
Collapse Expand Structs, Records, Enums
NNameConfidencePair_ Structure
Collapse Expand NSurveillance Unit
Collapse Expand Functions
NSurveillanceAddEventCallbackEx Function
NSurveillanceAddEventEx Function
NSurveillanceAddIsRunningChanged Function
NSurveillanceAddIsRunningChangedCallback Function
NSurveillanceAddSource Function
NSurveillanceAddSourceCollectionChanged Function
NSurveillanceAddSourceCollectionChangedCallback Function
NSurveillanceAddTemplate Function
NSurveillanceClearSources Function
NSurveillanceCreate Function
NSurveillanceDetectionDetailsCreate Function
NSurveillanceDetectionDetailsGetClothingDetails Function
NSurveillanceDetectionDetailsGetDetectionConfidence Function
NSurveillanceDetectionDetailsGetFace Function
NSurveillanceDetectionDetailsGetFaceRectangle Function
NSurveillanceDetectionDetailsGetLicensePlateDetails Function
NSurveillanceDetectionDetailsGetObjectColor Function
NSurveillanceDetectionDetailsGetObjectType Function
NSurveillanceDetectionDetailsGetRectangle Function
NSurveillanceDetectionDetailsGetSubjectType Function
NSurveillanceDetectionDetailsGetVehicleDetails Function
NSurveillanceDetectionDetailsSetClothingDetails Function
NSurveillanceDetectionDetailsSetDetectionConfidence Function
NSurveillanceDetectionDetailsSetFace Function
NSurveillanceDetectionDetailsSetFaceRectangle Function
NSurveillanceDetectionDetailsSetLicensePlateDetails Function
NSurveillanceDetectionDetailsSetObjectColor Function
NSurveillanceDetectionDetailsSetObjectType Function
NSurveillanceDetectionDetailsSetRectangle Function
NSurveillanceDetectionDetailsSetSubjectType Function
NSurveillanceDetectionDetailsSetVehicleDetails Function
NSurveillanceDetectionResultGetDetails Function
NSurveillanceDetectionResultGetDetailsAt Function
NSurveillanceDetectionResultGetDetailsCount Function
NSurveillanceDetectionResultGetImage Function
NSurveillanceDetectionResultGetModalityType Function
NSurveillanceEngineCreate Function
NSurveillanceEngineDetect Function
NSurveillanceEngineDetectAsync Function
NSurveillanceEngineInit Function
NSurveillanceGetDeviceManager Function
NSurveillanceGetSource Function
NSurveillanceGetSourceCount Function
NSurveillanceGetSources Function
NSurveillanceGetTemplateIdsN Function
NSurveillanceIsRunning Function
NSurveillanceOptimizeAllModelsAsync Function
NSurveillanceOptimizeModelsAsync Function
NSurveillanceRemoveAllTemplates Function
NSurveillanceRemoveEventCallbackEx Function
NSurveillanceRemoveEventEx Function
NSurveillanceRemoveIsRunningChanged Function
NSurveillanceRemoveIsRunningChangedCallback Function
NSurveillanceRemoveSourceAt Function
NSurveillanceRemoveSourceCollectionChanged Function
NSurveillanceRemoveSourceCollectionChangedCallback Function
NSurveillanceRemoveTemplateN Function
NSurveillanceStart Function
NSurveillanceStartAsync Function
NSurveillanceStartSource Function
NSurveillanceStartSourceAsync Function
NSurveillanceStop Function
NSurveillanceStopAsync Function
NSurveillanceStopSource Function
NSurveillanceStopSourceAsync Function
NsedGetAttributes Function
NsedGetAttributesContainsDetails Function
NsedGetBestDetails Function
NsedGetBestMatchResult Function
NsedGetBestMatchResultCount Function
NsedGetBestMatchResults Function
NsedGetClothingDetails Function
NsedGetCurrentMatchResult Function
NsedGetCurrentMatchResultCount Function
NsedGetCurrentMatchResults Function
NsedGetDetectedFaces Function
NsedGetDetectionConfidence Function
NsedGetError Function
NsedGetFace Function
NsedGetFaceConfidence Function
NsedGetFaceRectangle Function
NsedGetFrameIndex Function
NsedGetLicensePlateDetails Function
NsedGetMergedSubject Function
NsedGetModalityType Function
NsedGetObjectColor Function
NsedGetObjectDirection Function
NsedGetObjectType Function
NsedGetOriginalImageEx Function
NsedGetRectangle Function
NsedGetSource Function
NsedGetSplitFromSubject Function
NsedGetSubjectTemplate Function
NsedGetSubjectType Function
NsedGetTemplateEx Function
NsedGetTimeStamp Function
NsedGetTraceIndex Function
NsedGetVehicleDetails Function
NsedMatchResultCreate Function
NsedMatchResultCreateEx Function
NsedMatchResultGetId Function
NsedMatchResultGetMatchingDetails Function
NsedMatchResultGetScore Function
Collapse Expand Structs, Records, Enums
NSurveillanceObjectColorDetails_ Structure
NSurveillanceObjectDirectionDetails_ Structure
NSurveillanceObjectTypeDetails_ Structure
NDetectorScaleCount Enumeration
NGpuIndex Enumeration
NSurveillanceObjectColor Enumeration
NSurveillanceObjectDirection Enumeration
NSurveillanceObjectType Enumeration
NSurveillanceEventType Enumeration
Collapse Expand Files
NSurveillanceEventDetails.h
NsedMatchResult.h
NSurveillance.h
Collapse Expand NSurveillanceSource Unit
Collapse Expand Functions
NSurveillanceSourceAddIsCapturingChanged Function
NSurveillanceSourceAddIsCapturingChangedCallback Function
NSurveillanceSourceCreate Function
NSurveillanceSourceCreateFromCameraEx Function
NSurveillanceSourceCreateFromMediaReaderEx Function
NSurveillanceSourceGetCamera Function
NSurveillanceSourceGetCurrentFormat Function
NSurveillanceSourceGetError Function
NSurveillanceSourceGetFormats Function
NSurveillanceSourceGetLength Function
NSurveillanceSourceGetModalityType Function
NSurveillanceSourceGetPosition Function
NSurveillanceSourceGetRegionOfInterest Function
NSurveillanceSourceGetState Function
NSurveillanceSourceGetType Function
NSurveillanceSourceGetVideo Function
NSurveillanceSourceGetWarning Function
NSurveillanceSourceRemoveIsCapturingChanged Function
NSurveillanceSourceRemoveIsCapturingChangedCallback Function
NSurveillanceSourceSetCamera Function
NSurveillanceSourceSetCurrentFormat Function
NSurveillanceSourceSetModalityType Function
NSurveillanceSourceSetRegionOfInterest Function
NSurveillanceSourceSetVideo Function
Collapse Expand Structs, Records, Enums
NSurveillanceModalityType Enumeration
NSurveillanceSourceType Enumeration
Collapse Expand Files
NSurveillanceSource.h
Collapse Expand NTrackingDetails Unit
Collapse Expand Functions
NTrackingDetailsGetAttributes Function
NTrackingDetailsGetAttributesContainsDetails Function
NTrackingDetailsGetFrameIndex Function
NTrackingDetailsGetLicensePlate Function
NTrackingDetailsGetLicensePlateCount Function
NTrackingDetailsGetLicensePlates Function
NTrackingDetailsGetMatchResult Function
NTrackingDetailsGetMatchResultCount Function
NTrackingDetailsGetMatchResults Function
NTrackingDetailsGetRectangle Function
NTrackingDetailsGetSubjectType Function
NTrackingDetailsGetTimeStamp Function
Collapse Expand NVehicleDetails Unit
Collapse Expand Functions
NVehicleDetailsGetKnownMakes Function
NVehicleDetailsGetKnownModels Function
NVehicleDetailsGetKnownModelsByMake Function
NVehicleDetailsGetKnownTags Function
NVehicleDetailsGetModel Function
NVehicleDetailsGetModelCount Function
NVehicleDetailsGetModels Function
NVehicleDetailsGetOrientation Function
NVehicleDetailsGetOrientationAngle Function
NVehicleDetailsGetOrientationConfidence Function
NVehicleDetailsGetTag Function
NVehicleDetailsGetTagCount Function
NVehicleDetailsGetTags Function
NVehicleModelGetMake Function
Collapse Expand Structs, Records, Enums
NVehicleOrientation Enumeration
Collapse Expand NGpuJpegEncoder Unit
Collapse Expand Functions
NGpuJpegEncoderCreate Function
NGpuJpegEncoderEncode Function
NGpuJpegEncoderScaleAndEncode Function
Collapse Expand Structs, Records, Enums
NScaleMethod Enumeration
Collapse Expand .NET Reference
Collapse Expand Neurotec Namespace
Collapse Expand Classes
Collapse Expand ErrorSuppressedEventArgs Class
ErrorSuppressedEventArgs.ErrorSuppressedEventArgs Constructor
Collapse Expand ErrorSuppressedEventArgs Properties
ErrorSuppressedEventArgs.Error Property
Collapse Expand NArray Class
Collapse Expand NArray Methods
Collapse Expand FromArray Method
NArray.FromArray Method (Array)
NArray.FromArray Method (Array, NAttributes)
NArray.FromArray Method (IntPtr[])
NArray.FromArray Method (IntPtr[], NAttributes)
NArray.FromArray Method (NType, NObject[])
NArray.FromArray Method (NType, NObject[], NAttributes)
NArray.FromArray<T> Method (T[])
NArray.FromArray<T> Method (T[], NAttributes)
NArray.FromArray Method (UIntPtr[])
NArray.FromArray Method (UIntPtr[], NAttributes)
NArray.FromArray Method (bool[])
NArray.FromArray Method (bool[], NAttributes)
NArray.FromArray Method (byte[])
NArray.FromArray Method (byte[], NAttributes)
NArray.FromArray Method (char[])
NArray.FromArray Method (char[], NAttributes)
NArray.FromArray Method (double[])
NArray.FromArray Method (double[], NAttributes)
NArray.FromArray Method (float[])
NArray.FromArray Method (float[], NAttributes)
NArray.FromArray Method (int[])
NArray.FromArray Method (int[], NAttributes)
NArray.FromArray Method (long[])
NArray.FromArray Method (long[], NAttributes)
NArray.FromArray Method (sbyte[])
NArray.FromArray Method (sbyte[], NAttributes)
NArray.FromArray Method (short[])
NArray.FromArray Method (short[], NAttributes)
NArray.FromArray Method (string[])
NArray.FromArray Method (string[], NAttributes)
NArray.FromArray Method (uint[])
NArray.FromArray Method (uint[], NAttributes)
NArray.FromArray Method (ulong[])
NArray.FromArray Method (ulong[], NAttributes)
NArray.FromArray Method (ushort[])
NArray.FromArray Method (ushort[], NAttributes)
Collapse Expand FromPointerArray Method
NArray.FromPointerArray Method (IntPtr[])
NArray.FromPointerArray Method (IntPtr[], NAttributes)
Collapse Expand FromResultArray Method
NArray.FromResultArray Method (int[])
NArray.FromResultArray Method (int[], NAttributes)
NArray.GetEnumerator Method
Collapse Expand GetValueAs Method
NArray.GetValueAs<T> Method (int)
NArray.GetValueAs<T> Method (int, NAttributes)
NArray.GetValueAs<T> Method (int, NAttributes, string)
NArray.GetValueAs Method (int, Type)
NArray.GetValueAs Method (int, Type, NAttributes)
NArray.GetValueAs Method (int, Type, NAttributes, string)
Collapse Expand GetValueAsBoolean Method
NArray.GetValueAsBoolean Method (int)
NArray.GetValueAsBoolean Method (int, NAttributes)
NArray.GetValueAsBoolean Method (int, NAttributes, string)
Collapse Expand GetValueAsByte Method
NArray.GetValueAsByte Method (int)
NArray.GetValueAsByte Method (int, NAttributes)
NArray.GetValueAsByte Method (int, NAttributes, string)
Collapse Expand GetValueAsChar Method
NArray.GetValueAsChar Method (int)
NArray.GetValueAsChar Method (int, NAttributes)
NArray.GetValueAsChar Method (int, NAttributes, string)
Collapse Expand GetValueAsDouble Method
NArray.GetValueAsDouble Method (int)
NArray.GetValueAsDouble Method (int, NAttributes)
NArray.GetValueAsDouble Method (int, NAttributes, string)
Collapse Expand GetValueAsInt16 Method
NArray.GetValueAsInt16 Method (int)
NArray.GetValueAsInt16 Method (int, NAttributes)
NArray.GetValueAsInt16 Method (int, NAttributes, string)
Collapse Expand GetValueAsInt32 Method
NArray.GetValueAsInt32 Method (int)
NArray.GetValueAsInt32 Method (int, NAttributes)
NArray.GetValueAsInt32 Method (int, NAttributes, string)
Collapse Expand GetValueAsInt64 Method
NArray.GetValueAsInt64 Method (int)
NArray.GetValueAsInt64 Method (int, NAttributes)
NArray.GetValueAsInt64 Method (int, NAttributes, string)
Collapse Expand GetValueAsIntPtr Method
NArray.GetValueAsIntPtr Method (int)
NArray.GetValueAsIntPtr Method (int, NAttributes)
NArray.GetValueAsIntPtr Method (int, NAttributes, string)
Collapse Expand GetValueAsObject Method
NArray.GetValueAsObject Method (int, NType)
NArray.GetValueAsObject Method (int, NType, NAttributes)
NArray.GetValueAsObject Method (int, NType, NAttributes, string)
Collapse Expand GetValueAsPointer Method
NArray.GetValueAsPointer Method (int)
NArray.GetValueAsPointer Method (int, NAttributes)
NArray.GetValueAsPointer Method (int, NAttributes, string)
Collapse Expand GetValueAsResult Method
NArray.GetValueAsResult Method (int)
NArray.GetValueAsResult Method (int, NAttributes)
NArray.GetValueAsResult Method (int, NAttributes, string)
Collapse Expand GetValueAsSByte Method
NArray.GetValueAsSByte Method (int)
NArray.GetValueAsSByte Method (int, NAttributes)
NArray.GetValueAsSByte Method (int, NAttributes, string)
Collapse Expand GetValueAsSingle Method
NArray.GetValueAsSingle Method (int)
NArray.GetValueAsSingle Method (int, NAttributes)
NArray.GetValueAsSingle Method (int, NAttributes, string)
Collapse Expand GetValueAsString Method
NArray.GetValueAsString Method (int)
NArray.GetValueAsString Method (int, NAttributes)
NArray.GetValueAsString Method (int, NAttributes, string)
Collapse Expand GetValueAsUInt16 Method
NArray.GetValueAsUInt16 Method (int)
NArray.GetValueAsUInt16 Method (int, NAttributes)
NArray.GetValueAsUInt16 Method (int, NAttributes, string)
Collapse Expand GetValueAsUInt32 Method
NArray.GetValueAsUInt32 Method (int)
NArray.GetValueAsUInt32 Method (int, NAttributes)
NArray.GetValueAsUInt32 Method (int, NAttributes, string)
Collapse Expand GetValueAsUInt64 Method
NArray.GetValueAsUInt64 Method (int)
NArray.GetValueAsUInt64 Method (int, NAttributes)
NArray.GetValueAsUInt64 Method (int, NAttributes, string)
Collapse Expand GetValueAsUIntPtr Method
NArray.GetValueAsUIntPtr Method (int)
NArray.GetValueAsUIntPtr Method (int, NAttributes)
NArray.GetValueAsUIntPtr Method (int, NAttributes, string)
Collapse Expand ToArray Method
NArray.ToArray<T> Method ()
NArray.ToArray Method (NArray)
NArray.ToArray<T> Method (NAttributes)
NArray.ToArray<T> Method (NAttributes, string)
NArray.ToArray Method (Type)
NArray.ToArray Method (Type, NAttributes)
NArray.ToArray Method (Type, NAttributes, string)
Collapse Expand ToBooleanArray Method
NArray.ToBooleanArray Method ()
NArray.ToBooleanArray Method (NAttributes)
NArray.ToBooleanArray Method (NAttributes, string)
Collapse Expand ToByteArray Method
NArray.ToByteArray Method ()
NArray.ToByteArray Method (NAttributes)
NArray.ToByteArray Method (NAttributes, string)
Collapse Expand ToCharArray Method
NArray.ToCharArray Method ()
NArray.ToCharArray Method (NAttributes)
NArray.ToCharArray Method (NAttributes, string)
Collapse Expand ToDoubleArray Method
NArray.ToDoubleArray Method ()
NArray.ToDoubleArray Method (NAttributes)
NArray.ToDoubleArray Method (NAttributes, string)
Collapse Expand ToInt16Array Method
NArray.ToInt16Array Method ()
NArray.ToInt16Array Method (NAttributes)
NArray.ToInt16Array Method (NAttributes, string)
Collapse Expand ToInt32Array Method
NArray.ToInt32Array Method ()
NArray.ToInt32Array Method (NAttributes)
NArray.ToInt32Array Method (NAttributes, string)
Collapse Expand ToInt64Array Method
NArray.ToInt64Array Method ()
NArray.ToInt64Array Method (NAttributes)
NArray.ToInt64Array Method (NAttributes, string)
Collapse Expand ToIntPtrArray Method
NArray.ToIntPtrArray Method ()
NArray.ToIntPtrArray Method (NAttributes)
NArray.ToIntPtrArray Method (NAttributes, string)
Collapse Expand ToObjectArray Method
NArray.ToObjectArray Method (NType)
NArray.ToObjectArray Method (NType, NAttributes)
NArray.ToObjectArray Method (NType, NAttributes, string)
Collapse Expand ToPointerArray Method
NArray.ToPointerArray Method ()
NArray.ToPointerArray Method (NAttributes)
NArray.ToPointerArray Method (NAttributes, string)
Collapse Expand ToResultArray Method
NArray.ToResultArray Method ()
NArray.ToResultArray Method (NAttributes)
NArray.ToResultArray Method (NAttributes, string)
Collapse Expand ToSByteArray Method
NArray.ToSByteArray Method ()
NArray.ToSByteArray Method (NAttributes)
NArray.ToSByteArray Method (NAttributes, string)
Collapse Expand ToSingleArray Method
NArray.ToSingleArray Method ()
NArray.ToSingleArray Method (NAttributes)
NArray.ToSingleArray Method (NAttributes, string)
Collapse Expand ToStringArray Method
NArray.ToStringArray Method ()
NArray.ToStringArray Method (NAttributes)
NArray.ToStringArray Method (NAttributes, string)
Collapse Expand ToUInt16Array Method
NArray.ToUInt16Array Method ()
NArray.ToUInt16Array Method (NAttributes)
NArray.ToUInt16Array Method (NAttributes, string)
Collapse Expand ToUInt32Array Method
NArray.ToUInt32Array Method ()
NArray.ToUInt32Array Method (NAttributes)
NArray.ToUInt32Array Method (NAttributes, string)
Collapse Expand ToUInt64Array Method
NArray.ToUInt64Array Method ()
NArray.ToUInt64Array Method (NAttributes)
NArray.ToUInt64Array Method (NAttributes, string)
Collapse Expand ToUIntPtrArray Method
NArray.ToUIntPtrArray Method ()
NArray.ToUIntPtrArray Method (NAttributes)
NArray.ToUIntPtrArray Method (NAttributes, string)
Collapse Expand NArray Properties
NArray.Length Property
NArray.NativeType Property
Collapse Expand NAsyncOperation Class
Collapse Expand NAsyncOperation Methods
NAsyncOperation.AsTyped<T> Method
NAsyncOperation.Cancel Method
NAsyncOperation.GetAwaiter Method
Collapse Expand Wait Method
NAsyncOperation.Wait Method ()
NAsyncOperation.Wait Method (int)
Collapse Expand NAsyncOperation Properties
NAsyncOperation.Error Property
NAsyncOperation.IsCanceled Property
NAsyncOperation.IsCompleted Property
NAsyncOperation.IsFaulted Property
NAsyncOperation.NAsyncStatusNativeType Property
NAsyncOperation.NativeType Property
NAsyncOperation.Result Property
NAsyncOperation.Status Property
Collapse Expand NAsyncOperation Events
NAsyncOperation.Completed Event
Collapse Expand NComplex Structure
NComplex.NComplex Constructor
Collapse Expand NComplex Fields
NComplex.ImaginaryOne Field
NComplex.One Field
NComplex.Zero Field
Collapse Expand NComplex Methods
Collapse Expand ToString Method
NComplex.ToString Method ()
NComplex.ToString Method (string)
Collapse Expand NComplex Properties
NComplex.Imaginary Property
NComplex.NativeType Property
NComplex.Real Property
Collapse Expand NCore Class
Collapse Expand NCore Fields
NCore.DllName Field
Collapse Expand NCore Methods
Collapse Expand AlignedAlloc Method
NCore.AlignedAlloc Method (UIntPtr, UIntPtr)
NCore.AlignedAlloc Method (UIntPtr, UIntPtr, UIntPtr)
NCore.AlignedAlloc Method (int, int)
NCore.AlignedAlloc Method (int, int, int)
NCore.AlignedAlloc Method (long, long)
NCore.AlignedAlloc Method (long, long, long)
Collapse Expand AlignedCAlloc Method
NCore.AlignedCAlloc Method (UIntPtr, UIntPtr)
NCore.AlignedCAlloc Method (UIntPtr, UIntPtr, UIntPtr)
NCore.AlignedCAlloc Method (int, int)
NCore.AlignedCAlloc Method (int, int, int)
NCore.AlignedCAlloc Method (long, long)
NCore.AlignedCAlloc Method (long, long, long)
NCore.AlignedFree Method
Collapse Expand AlignedReAlloc Method
NCore.AlignedReAlloc Method (IntPtr, UIntPtr, UIntPtr)
NCore.AlignedReAlloc Method (IntPtr, UIntPtr, UIntPtr, UIntPtr)
NCore.AlignedReAlloc Method (IntPtr, int, int)
NCore.AlignedReAlloc Method (IntPtr, int, int, int)
NCore.AlignedReAlloc Method (IntPtr, long, long)
NCore.AlignedReAlloc Method (IntPtr, long, long, long)
Collapse Expand Alloc Method
NCore.Alloc Method (UIntPtr)
NCore.Alloc Method (int)
NCore.Alloc Method (long)
Collapse Expand CAlloc Method
NCore.CAlloc Method (UIntPtr)
NCore.CAlloc Method (int)
NCore.CAlloc Method (long)
Collapse Expand Clear Method
NCore.Clear Method (IntPtr, UIntPtr)
NCore.Clear Method (IntPtr, int)
NCore.Clear Method (IntPtr, long)
Collapse Expand Compare Method
NCore.Compare Method (IntPtr, IntPtr, UIntPtr)
NCore.Compare Method (IntPtr, IntPtr, int)
NCore.Compare Method (IntPtr, IntPtr, long)
Collapse Expand Copy Method
NCore.Copy Method (IntPtr, IntPtr, UIntPtr)
NCore.Copy Method (IntPtr, IntPtr, int)
NCore.Copy Method (IntPtr, IntPtr, long)
Collapse Expand Fill Method
NCore.Fill Method (IntPtr, byte, UIntPtr)
NCore.Fill Method (IntPtr, byte, int)
NCore.Fill Method (IntPtr, byte, long)
Collapse Expand Free Method
NCore.Free Method (IntPtr)
NCore.Free Method (IntPtr, NMemoryType)
Collapse Expand Move Method
NCore.Move Method (IntPtr, IntPtr, UIntPtr)
NCore.Move Method (IntPtr, IntPtr, int)
NCore.Move Method (IntPtr, IntPtr, long)
Collapse Expand ReAlloc Method
NCore.ReAlloc Method (IntPtr, UIntPtr)
NCore.ReAlloc Method (IntPtr, int)
NCore.ReAlloc Method (IntPtr, long)
NCore.Shutdown Method
NCore.ShutdownThread Method
Collapse Expand NCore Properties
NCore.NativeModule Property
NCore.NativeType Property
Collapse Expand NCore Events
NCore.ErrorSuppressed Event
Collapse Expand NDisposable Class
Collapse Expand NDisposable Methods
NDisposable.Dispose Method
Collapse Expand NDisposable Properties
NDisposable.IsDisposed Property
Collapse Expand NError Class
Collapse Expand NError Methods
Collapse Expand Get Method
NError.Get Method (HNObject)
NError.Get Method (int, HNObject)
NError.GetDefaultMessage Method
NError.GetLast Method
NError.GetMacErrorMessage Method
NError.GetMessage Method
NError.GetSysErrorMessage Method
NError.SetLast Method
NError.Suppress Method
NError.ToString Method
Collapse Expand NExpandableObject Class
Collapse Expand NExpandableObject Properties
NExpandableObject.NativeType Property
NExpandableObject.Properties Property
Collapse Expand NIndexPair Structure
NIndexPair.NIndexPair Constructor
Collapse Expand NIndexPair Methods
Collapse Expand ToString Method
NIndexPair.ToString Method ()
NIndexPair.ToString Method (string)
Collapse Expand NIndexPair Properties
NIndexPair.Index1 Property
NIndexPair.Index2 Property
NIndexPair.NativeType Property
Collapse Expand NModule Class
NModule.NModule Constructor
Collapse Expand NModule Methods
NModule.CheckInit Method
Collapse Expand CreateInstance Method
NModule.CreateInstance Method (string)
NModule.CreateInstance Method (string, NAttributes)
NModule.GetDependences Method
NModule.GetLoadedModules Method
Collapse Expand GetType Method
NModule.GetType Method (string)
NModule.GetType Method (string, bool)
NModule.LoadFromFile Method
Collapse Expand NModule Properties
NModule.Activated Property
NModule.Company Property
NModule.Copyright Property
NModule.DefinedTypes Property
NModule.FileName Property
NModule.Id Property
NModule.NModuleOptionsNativeType Property
NModule.Name Property
NModule.NativeId Property
NModule.NativeType Property
NModule.Options Property
NModule.Product Property
NModule.Title Property
NModule.Version Property
NModule.VersionBuild Property
NModule.VersionMajor Property
NModule.VersionMinor Property
NModule.VersionRevision Property
Collapse Expand NObject Class
Collapse Expand NObject Fields
NObject.FlagRefRet Field
Collapse Expand NObject Methods
NObject.CaptureProperties Method
NObject.Clone Method
NObject.CompareTo Method
NObject.CopyProperties Method
NObject.DisposeArray<T> Method
NObject.Equals Method
Collapse Expand FromHandle<T> Method
NObject.FromHandle<T> Method (HNObject)
NObject.FromHandle<T> Method (HNObject, bool)
NObject.FromHandle<T> Method (HNObject, bool, object)
NObject.FromHandle<T> Method (IntPtr)
NObject.FromHandle<T> Method (IntPtr, bool, bool)
NObject.FromObject Method
Collapse Expand GetArray<T> Method
NObject.GetArray<T> Method (GetArrayPlain)
NObject.GetArray<T> Method (GetOutArrayPlain)
NObject.GetHashCode Method
NObject.GetNativeType Method
Collapse Expand GetObject<T> Method
NObject.GetObject<T> Method (GetObjectPlain)
NObject.GetObject<T> Method (GetObjectPlain, bool)
Collapse Expand GetObjects<T> Method
NObject.GetObjects<T> Method (GetArrayPlain)
NObject.GetObjects<T> Method (GetArrayPlain, bool, bool)
NObject.GetObjects<T> Method (GetOutArrayPlain)
NObject.GetObjects<T> Method (GetOutArrayPlain, bool, bool)
NObject.GetProperty<T> Method
Collapse Expand GetSize Method
NObject.GetSize Method ()
NObject.GetSize Method (uint)
Collapse Expand GetSizeMany<T> Method
NObject.GetSizeMany<T> Method (T[])
NObject.GetSizeMany<T> Method (T[], uint)
NObject.GetString Method
NObject.Ref Method
NObject.Reset Method
NObject.ResetProperty Method
Collapse Expand Save Method
NObject.Save Method ()
NObject.Save Method (NBuffer)
NObject.Save Method (NBuffer, uint)
NObject.Save Method (NStream)
NObject.Save Method (NStream, uint)
NObject.Save Method (uint)
Collapse Expand SaveMany<T> Method
NObject.SaveMany<T> Method (T[])
NObject.SaveMany<T> Method (T[], NBuffer)
NObject.SaveMany<T> Method (T[], NBuffer, uint)
NObject.SaveMany<T> Method (T[], NStream)
NObject.SaveMany<T> Method (T[], NStream, uint)
NObject.SaveMany<T> Method (T[], uint)
NObject.SetArray<T> Method
NObject.SetObject<T> Method
Collapse Expand SetProperty Method
NObject.SetProperty<T> Method (string, T)
NObject.SetProperty Method (string, object)
NObject.SetString Method
NObject.ToHandle Method
NObject.ToObject Method
Collapse Expand ToString Method
NObject.ToString Method ()
NObject.ToString Method (string)
NObject.Unref Method
NObject.UnrefArray Method
NObject.UnrefElements Method
Collapse Expand NObject Properties
NObject.Flags Property
NObject.IsDisposed Property
NObject.NativeType Property
NObject.Owner Property
Collapse Expand NObject Delegates
NObject.EventInvoker Delegate
NObject.FromHandlePlain Delegate
NObject.GetArrayPlain Delegate
NObject.GetArrayWithHandle Delegate
NObject.GetObjectPlain Delegate
NObject.GetObjectWithHandle Delegate
NObject.GetOutArrayPlain Delegate
NObject.GetOutArrayWithHandle Delegate
NObject.GetStringPlainN Delegate
NObject.GetStringWithHandleN Delegate
NObject.SetArrayPlain Delegate
NObject.SetArrayWithHandle Delegate
NObject.SetObjectPlain Delegate
NObject.SetObjectWithHandle Delegate
NObject.SetStringPlainN Delegate
NObject.SetStringWithHandleN Delegate
Collapse Expand NObject Events
NObject.PropertyChanged Event
Collapse Expand NProcessorInfo Class
Collapse Expand NProcessorInfo Methods
NProcessorInfo.GetModelInfo Method
NProcessorInfo.IsFeatureSupported Method
Collapse Expand NProcessorInfo Properties
NProcessorInfo.Count Property
NProcessorInfo.ModelName Property
NProcessorInfo.NProcessorVendorNativeType Property
NProcessorInfo.NativeType Property
NProcessorInfo.Vendor Property
NProcessorInfo.VendorName Property
Collapse Expand NPropertyBag Class
Collapse Expand NPropertyBag Constructor
NPropertyBag.NPropertyBag Constructor ()
NPropertyBag.NPropertyBag Constructor (IEnumerable<KeyValuePair<string, object>>)
Collapse Expand NPropertyBag Classes
Collapse Expand NPropertyBag.KeyCollection Class
Collapse Expand KeyCollection Methods
NPropertyBag.KeyCollection.Contains Method
NPropertyBag.ValueCollection Class
Collapse Expand NPropertyBag Methods
Collapse Expand Add Method
NPropertyBag.Add Method (KeyValuePair<string, object>)
NPropertyBag.Add Method (string, object)
NPropertyBag.AddRange Method
NPropertyBag.ApplyTo Method
NPropertyBag.Clear Method
NPropertyBag.Contains Method
NPropertyBag.ContainsKey Method
Collapse Expand CopyTo Method
NPropertyBag.CopyTo Method (Array, int)
NPropertyBag.CopyTo Method (KeyValuePair<string, object>[], int)
NPropertyBag.CopyTo Method (NObject)
NPropertyBag.GetEnumerator Method
Collapse Expand Parse Method
NPropertyBag.Parse Method (string)
NPropertyBag.Parse Method (string, string)
Collapse Expand Remove Method
NPropertyBag.Remove Method (KeyValuePair<string, object>)
NPropertyBag.Remove Method (string)
NPropertyBag.RemoveAt Method
NPropertyBag.TryGetValue Method
Collapse Expand TryParse Method
NPropertyBag.TryParse Method (string, out NPropertyBag)
NPropertyBag.TryParse Method (string, string, out NPropertyBag)
Collapse Expand this Indexer
NPropertyBag.this Indexer (int)
NPropertyBag.this Indexer (string)
Collapse Expand NPropertyBag Properties
NPropertyBag.Count Property
NPropertyBag.IsReadOnly Property
NPropertyBag.Keys Property
NPropertyBag.NativeType Property
NPropertyBag.Values Property
Collapse Expand NPropertyBag Events
NPropertyBag.CollectionChanged Event
Collapse Expand NRange Structure
NRange.NRange Constructor
Collapse Expand NRange Methods
Collapse Expand ToString Method
NRange.ToString Method ()
NRange.ToString Method (string)
Collapse Expand NRange Properties
NRange.From Property
NRange.NativeType Property
NRange.To Property
Collapse Expand NRational Structure
NRational.NRational Constructor
Collapse Expand NRational Fields
NRational.Empty Field
Collapse Expand NRational Methods
Collapse Expand ToString Method
NRational.ToString Method ()
NRational.ToString Method (string)
Collapse Expand NRational Properties
NRational.Denominator Property
NRational.NativeType Property
NRational.Numerator Property
Collapse Expand NType Class
Collapse Expand NType Methods
NType.AddEventHandler Method
NType.CapturePropertyValues Method
NType.CopyPropertyValues Method
Collapse Expand CreateInstance Method
NType.CreateInstance Method ()
NType.CreateInstance Method (NAttributes)
NType.CreateInstance Method (string)
NType.CreateInstance Method (string, NAttributes)
NType.GetDeclaredConstant Method
NType.GetDeclaredEnumConstant Method
NType.GetDeclaredEvent Method
NType.GetDeclaredField Method
NType.GetDeclaredMethod Method
NType.GetDeclaredMethods Method
NType.GetDeclaredPart Method
NType.GetDeclaredProperty Method
NType.GetPropertyValue<T> Method
Collapse Expand GetType Method
NType.GetType Method (string)
NType.GetType Method (string, bool)
Collapse Expand IdentifierToString Method
NType.IdentifierToString Method (string)
NType.IdentifierToString Method (string, string)
Collapse Expand InvokeMethod Method
NType.InvokeMethod Method (NObject, string, NPropertyBag)
NType.InvokeMethod Method (NObject, string, object[])
NType.InvokeMethod Method (NObject, string, string)
NType.IsAssignableFrom Method
NType.IsInstanceOfType Method
NType.IsSubclassOf Method
NType.RemoveEventHandler Method
NType.Reset Method
NType.ResetPropertyValue Method
Collapse Expand SetPropertyValue Method
NType.SetPropertyValue<T> Method (NObject, string, T)
NType.SetPropertyValue Method (NObject, string, object)
NType.ToNativeType Method
Collapse Expand ToType Method
NType.ToType Method ()
NType.ToType Method (NAttributes, bool)
NType.ToType Method (NType, NAttributes, bool)
Collapse Expand NType Properties
NType.Attributes Property
NType.BaseType Property
NType.DeclaredConstants Property
NType.DeclaredConstructors Property
NType.DeclaredEnumConstants Property
NType.DeclaredEvents Property
NType.DeclaredFields Property
NType.DeclaredMethods Property
NType.DeclaredParts Property
NType.DeclaredProperties Property
NType.EnumAlternative Property
NType.HasOwnerType Property
NType.IsAbstract Property
NType.IsBasic Property
NType.IsCallback Property
NType.IsCloneable Property
NType.IsComparable Property
NType.IsDeprecated Property
NType.IsDisposable Property
NType.IsEnum Property
NType.IsEquatable Property
NType.IsFlagsEnum Property
NType.IsHandle Property
NType.IsMemorySerializable Property
NType.IsObject Property
NType.IsParsable Property
NType.IsPrimitive Property
NType.IsPublic Property
NType.IsSealed Property
NType.IsSerializable Property
NType.IsSignNeutral Property
NType.IsStatic Property
NType.IsStruct Property
NType.Module Property
NType.NTypeCodeNativeType Property
NType.Name Property
NType.NativeType Property
NType.OwnerType Property
NType.RootType Property
NType.RootTypeCode Property
NType.TypeCode Property
NType.UseInsteadType Property
NType.ValueSize Property
Collapse Expand NTypes Class
Collapse Expand NTypes Fields
NTypes.StringEncoding Field
NTypes.WCharApi Field
Collapse Expand NTypes Methods
Collapse Expand CreateCallback Method
NTypes.CreateCallback Method (Delegate, Delegate)
NTypes.CreateCallback Method (Delegate, NObject, Delegate)
NTypes.CreateCallback Method (Delegate, NObject, Func<NObject, object>, object, Delegate)
NTypes.CreateCallback Method (Delegate, object)
NTypes.FreeObjectPointer Method
NTypes.FreeStringArray Method
NTypes.FreeStringElements Method
NTypes.GetObjectFromPointer Method
NTypes.GetPointerForObject Method
NTypes.IsMemoryTypeValid Method
NTypes.IsMemoryTypeValidForFree Method
Collapse Expand NTypes Properties
NTypes.NACharNativeType Property
NTypes.NAttributesNativeType Property
NTypes.NBooleanNativeType Property
NTypes.NCallbackNativeType Property
NTypes.NCharNativeType Property
NTypes.NDateTimeNativeType Property
NTypes.NDoubleNativeType Property
NTypes.NGuidNativeType Property
NTypes.NInt16NativeType Property
NTypes.NInt32NativeType Property
NTypes.NInt64NativeType Property
NTypes.NInt8NativeType Property
NTypes.NMemoryTypeNativeType Property
NTypes.NOSFamilyNativeType Property
NTypes.NPointerNativeType Property
NTypes.NResultNativeType Property
NTypes.NSSizeTypeNativeType Property
NTypes.NSingleNativeType Property
NTypes.NSizeTypeNativeType Property
NTypes.NStringNativeType Property
NTypes.NTimeSpanNativeType Property
NTypes.NUInt16NativeType Property
NTypes.NUInt32NativeType Property
NTypes.NUInt64NativeType Property
NTypes.NUInt8NativeType Property
NTypes.NWCharNativeType Property
NTypes.NameStringPairNativeType Property
NTypes.NativeType Property
NTypes.OSFamilyCurrent Property
Collapse Expand NURational Structure
NURational.NURational Constructor
Collapse Expand NURational Fields
NURational.Empty Field
Collapse Expand NURational Methods
Collapse Expand ToString Method
NURational.ToString Method ()
NURational.ToString Method (string)
Collapse Expand NURational Properties
NURational.Denominator Property
NURational.NativeType Property
NURational.Numerator Property
Collapse Expand NValue Class
Collapse Expand NValue Constructor
NValue.NValue Constructor (IntPtr)
NValue.NValue Constructor (IntPtr, NAttributes)
NValue.NValue Constructor (UIntPtr)
NValue.NValue Constructor (UIntPtr, NAttributes)
NValue.NValue Constructor (bool)
NValue.NValue Constructor (bool, NAttributes)
NValue.NValue Constructor (byte)
NValue.NValue Constructor (byte, NAttributes)
NValue.NValue Constructor (char)
NValue.NValue Constructor (char, NAttributes)
NValue.NValue Constructor (double)
NValue.NValue Constructor (double, NAttributes)
NValue.NValue Constructor (float)
NValue.NValue Constructor (float, NAttributes)
NValue.NValue Constructor (int)
NValue.NValue Constructor (int, NAttributes)
NValue.NValue Constructor (long)
NValue.NValue Constructor (long, NAttributes)
NValue.NValue Constructor (sbyte)
NValue.NValue Constructor (sbyte, NAttributes)
NValue.NValue Constructor (short)
NValue.NValue Constructor (short, NAttributes)
NValue.NValue Constructor (uint)
NValue.NValue Constructor (uint, NAttributes)
NValue.NValue Constructor (ulong)
NValue.NValue Constructor (ulong, NAttributes)
NValue.NValue Constructor (ushort)
NValue.NValue Constructor (ushort, NAttributes)
Collapse Expand NValue Methods
Collapse Expand ChangeType Method
NValue.ChangeType Method (NValue, NType)
NValue.ChangeType Method (NValue, NType, NAttributes)
NValue.ChangeType Method (NValue, NType, NAttributes, string)
Collapse Expand FromDelegate Method
NValue.FromDelegate Method (Delegate)
NValue.FromDelegate Method (Delegate, NAttributes)
NValue.FromDelegate Method (Delegate, NAttributes, NObject)
NValue.FromDelegate Method (Delegate, NObject)
Collapse Expand FromObject Method
NValue.FromObject Method (NType, NObject)
NValue.FromObject Method (NType, NObject, NAttributes)
NValue.FromObject Method (object)
NValue.FromObject Method (object, NAttributes)
Collapse Expand FromPointer Method
NValue.FromPointer Method (IntPtr)
NValue.FromPointer Method (IntPtr, NAttributes)
Collapse Expand FromResult Method
NValue.FromResult Method (int)
NValue.FromResult Method (int, NAttributes)
Collapse Expand FromString Method
NValue.FromString Method (string)
NValue.FromString Method (string, NAttributes)
Collapse Expand FromType<T> Method
NValue.FromType<T> Method (T)
NValue.FromType<T> Method (T, NAttributes)
Collapse Expand ToBoolean Method
NValue.ToBoolean Method ()
NValue.ToBoolean Method (NAttributes)
NValue.ToBoolean Method (NAttributes, string)
Collapse Expand ToByte Method
NValue.ToByte Method ()
NValue.ToByte Method (NAttributes)
NValue.ToByte Method (NAttributes, string)
Collapse Expand ToChar Method
NValue.ToChar Method ()
NValue.ToChar Method (NAttributes)
NValue.ToChar Method (NAttributes, string)
Collapse Expand ToDouble Method
NValue.ToDouble Method ()
NValue.ToDouble Method (NAttributes)
NValue.ToDouble Method (NAttributes, string)
Collapse Expand ToInt16 Method
NValue.ToInt16 Method ()
NValue.ToInt16 Method (NAttributes)
NValue.ToInt16 Method (NAttributes, string)
Collapse Expand ToInt32 Method
NValue.ToInt32 Method ()
NValue.ToInt32 Method (NAttributes)
NValue.ToInt32 Method (NAttributes, string)
Collapse Expand ToInt64 Method
NValue.ToInt64 Method ()
NValue.ToInt64 Method (NAttributes)
NValue.ToInt64 Method (NAttributes, string)
Collapse Expand ToIntPtr Method
NValue.ToIntPtr Method ()
NValue.ToIntPtr Method (NAttributes)
NValue.ToIntPtr Method (NAttributes, string)
Collapse Expand ToObject Method
NValue.ToObject Method ()
NValue.ToObject Method (NType)
NValue.ToObject Method (NType, NAttributes)
NValue.ToObject Method (NType, NAttributes, string)
NValue.ToObject Method (NValue)
Collapse Expand ToPointer Method
NValue.ToPointer Method ()
NValue.ToPointer Method (NAttributes)
NValue.ToPointer Method (NAttributes, string)
Collapse Expand ToResult Method
NValue.ToResult Method ()
NValue.ToResult Method (NAttributes)
NValue.ToResult Method (NAttributes, string)
Collapse Expand ToSByte Method
NValue.ToSByte Method ()
NValue.ToSByte Method (NAttributes)
NValue.ToSByte Method (NAttributes, string)
Collapse Expand ToSingle Method
NValue.ToSingle Method ()
NValue.ToSingle Method (NAttributes)
NValue.ToSingle Method (NAttributes, string)
Collapse Expand ToString Method
NValue.ToString Method (NAttributes)
NValue.ToString Method (NAttributes, string)
Collapse Expand ToType Method
NValue.ToType<T> Method ()
NValue.ToType<T> Method (NAttributes)
NValue.ToType<T> Method (NAttributes, string)
NValue.ToType Method (Type)
NValue.ToType Method (Type, NAttributes)
NValue.ToType Method (Type, NAttributes, string)
Collapse Expand ToUInt16 Method
NValue.ToUInt16 Method ()
NValue.ToUInt16 Method (NAttributes)
NValue.ToUInt16 Method (NAttributes, string)
Collapse Expand ToUInt32 Method
NValue.ToUInt32 Method ()
NValue.ToUInt32 Method (NAttributes)
NValue.ToUInt32 Method (NAttributes, string)
Collapse Expand ToUInt64 Method
NValue.ToUInt64 Method ()
NValue.ToUInt64 Method (NAttributes)
NValue.ToUInt64 Method (NAttributes, string)
Collapse Expand ToUIntPtr Method
NValue.ToUIntPtr Method ()
NValue.ToUIntPtr Method (NAttributes)
NValue.ToUIntPtr Method (NAttributes, string)
Collapse Expand NValue Properties
NValue.Attributes Property
NValue.IsWrapper Property
NValue.KeyValuePairNativeType Property
NValue.LongSize Property
NValue.NameValuePairNativeType Property
NValue.NativeSize Property
NValue.NativeType Property
NValue.Ptr Property
NValue.Size Property
NValue.TypeCode Property
NValue.ValueType Property
Collapse Expand NVersion Structure
Collapse Expand NVersion Constructor
NVersion.NVersion Constructor (int, int)
NVersion.NVersion Constructor (ushort)
Collapse Expand NVersion Fields
NVersion.Empty Field
Collapse Expand NVersion Methods
NVersion.CompareTo Method
Collapse Expand Equals Method
NVersion.Equals Method (NVersion)
NVersion.Equals Method (object)
NVersion.GetHashCode Method
Collapse Expand ToString Method
NVersion.ToString Method ()
NVersion.ToString Method (string)
Collapse Expand NVersion Operators
NVersion.!= Operator
NVersion.< Operator
NVersion.<= Operator
NVersion.== Operator
NVersion.> Operator
NVersion.>= Operator
Collapse Expand NVersion Operator
NVersion.NVersion Operator (ushort)
NVersion.ushort Operator
Collapse Expand NVersion Properties
NVersion.Major Property
NVersion.Minor Property
NVersion.NativeType Property
Collapse Expand NVersionRange Structure
Collapse Expand NVersionRange Constructor
NVersionRange.NVersionRange Constructor (NVersion, NVersion)
NVersionRange.NVersionRange Constructor (uint)
Collapse Expand NVersionRange Fields
NVersionRange.Empty Field
Collapse Expand NVersionRange Methods
Collapse Expand Contains Method
NVersionRange.Contains Method (NVersion)
NVersionRange.Contains Method (NVersionRange)
Collapse Expand Equals Method
NVersionRange.Equals Method (NVersionRange)
NVersionRange.Equals Method (object)
NVersionRange.GetHashCode Method
Collapse Expand Intersect Method
NVersionRange.Intersect Method (NVersionRange)
NVersionRange.Intersect Method (NVersionRange, NVersionRange)
NVersionRange.IntersectsWith Method
Collapse Expand ToString Method
NVersionRange.ToString Method ()
NVersionRange.ToString Method (string)
Collapse Expand NVersionRange Operators
NVersionRange.!= Operator
NVersionRange.== Operator
Collapse Expand NVersionRange Operator
NVersionRange.NVersionRange Operator (uint)
NVersionRange.uint Operator
Collapse Expand NVersionRange Properties
NVersionRange.From Property
NVersionRange.NativeType Property
NVersionRange.To Property
Collapse Expand Structs, Records, Enums
Neurotec.NAsyncStatus Enumeration
Neurotec.NAttributes Enumeration
Neurotec.NMemoryType Enumeration
Neurotec.NModuleOptions Enumeration
Neurotec.NOSFamily Enumeration
Neurotec.NProcessorFeature Enumeration
Collapse Expand Neurotec.NProcessorVendor Enumeration
NProcessorVendor.NationalSemiconductor Field
Neurotec.NTypeCode Enumeration
Collapse Expand Neurotec.Biometrics Namespace
Collapse Expand Classes
Collapse Expand NBiometric Class
Collapse Expand NBiometric Methods
NBiometric.IsBiometricCaptureOptionsValid Method
Collapse Expand NBiometric Properties
NBiometric.BiometricType Property
NBiometric.CaptureOptions Property
NBiometric.Error Property
NBiometric.FileName Property
NBiometric.HasMoreSamples Property
NBiometric.NBiometricCaptureOptionsNativeType Property
NBiometric.NativeType Property
NBiometric.Owner Property
NBiometric.ParentObject Property
NBiometric.SampleBuffer Property
NBiometric.SessionId Property
NBiometric.Status Property
Collapse Expand NBiometricAttributes Class
Collapse Expand NBiometricAttributes Properties
NBiometricAttributes.BiometricType Property
NBiometricAttributes.Child Property
NBiometricAttributes.ChildSubject Property
NBiometricAttributes.DetectionConfidence Property
NBiometricAttributes.LivenessConfidence Property
NBiometricAttributes.NativeType Property
NBiometricAttributes.Quality Property
NBiometricAttributes.Status Property
Collapse Expand NBiometricQualityBlock Structure
NBiometricQualityBlock.NBiometricQualityBlock Constructor
Collapse Expand NBiometricQualityBlock Methods
Collapse Expand ToString Method
NBiometricQualityBlock.ToString Method ()
NBiometricQualityBlock.ToString Method (string)
Collapse Expand NBiometricQualityBlock Properties
NBiometricQualityBlock.NativeType Property
NBiometricQualityBlock.QualityAlgorithmId Property
NBiometricQualityBlock.QualityAlgorithmVendorId Property
NBiometricQualityBlock.QualityScore Property
Collapse Expand NBiometricTypes Class
Collapse Expand NBiometricTypes Fields
NBiometricTypes.PhraseIdUnknown Field
NBiometricTypes.QualityFailed Field
NBiometricTypes.QualityMax Field
NBiometricTypes.QualityMin Field
NBiometricTypes.QualityUnknown Field
Collapse Expand NBiometricTypes Methods
NBiometricTypes.AngleFromDegrees Method
NBiometricTypes.AngleFromRadians Method
NBiometricTypes.AngleToDegrees Method
NBiometricTypes.AngleToRadians Method
Collapse Expand AngleToString Method
NBiometricTypes.AngleToString Method (int)
NBiometricTypes.AngleToString Method (int, string)
Collapse Expand GetPositionAvailableParts Method
NBiometricTypes.GetPositionAvailableParts Method (NEPosition, NEPosition[])
NBiometricTypes.GetPositionAvailableParts Method (NFPosition, NFPosition[])
NBiometricTypes.IsBiometricStatusFinal Method
NBiometricTypes.IsBiometricStatusValid Method
NBiometricTypes.IsBiometricSubtypeValid Method
NBiometricTypes.IsBiometricTypeValid Method
NBiometricTypes.IsImpressionTypeCompatibleWith Method
NBiometricTypes.IsImpressionTypeContact Method
NBiometricTypes.IsImpressionTypeContactless Method
NBiometricTypes.IsImpressionTypeFinger Method
NBiometricTypes.IsImpressionTypeGeneric Method
NBiometricTypes.IsImpressionTypeLatent Method
NBiometricTypes.IsImpressionTypeLiveScan Method
NBiometricTypes.IsImpressionTypeNonOptical Method
NBiometricTypes.IsImpressionTypeNonliveScan Method
NBiometricTypes.IsImpressionTypeOneOf Method
NBiometricTypes.IsImpressionTypeOptical Method
NBiometricTypes.IsImpressionTypePalm Method
NBiometricTypes.IsImpressionTypePlain Method
NBiometricTypes.IsImpressionTypeRolled Method
NBiometricTypes.IsImpressionTypeSwipe Method
NBiometricTypes.IsImpressionTypeValid Method
NBiometricTypes.IsImpressionTypeValidFinger Method
NBiometricTypes.IsImpressionTypeValidPalm Method
NBiometricTypes.IsNfiqQualityValid Method
NBiometricTypes.IsNfiqValid Method
NBiometricTypes.IsPatternClassValid Method
NBiometricTypes.IsPatternClassValidFor Method
Collapse Expand IsPositionCompatibleWith Method
NBiometricTypes.IsPositionCompatibleWith Method (NFPosition, NFImpressionType)
NBiometricTypes.IsPositionCompatibleWith Method (NFPosition, NFPosition)
NBiometricTypes.IsPositionFinger Method
NBiometricTypes.IsPositionFourFingers Method
Collapse Expand IsPositionKnown Method
NBiometricTypes.IsPositionKnown Method (NEPosition)
NBiometricTypes.IsPositionKnown Method (NFPosition)
Collapse Expand IsPositionLeft Method
NBiometricTypes.IsPositionLeft Method (NEPosition)
NBiometricTypes.IsPositionLeft Method (NFPosition)
NBiometricTypes.IsPositionLeftAndRight Method
Collapse Expand IsPositionOneOf Method
NBiometricTypes.IsPositionOneOf Method (NEPosition, NEPosition[])
NBiometricTypes.IsPositionOneOf Method (NFPosition, NFPosition[])
NBiometricTypes.IsPositionPalm Method
Collapse Expand IsPositionRight Method
NBiometricTypes.IsPositionRight Method (NEPosition)
NBiometricTypes.IsPositionRight Method (NFPosition)
NBiometricTypes.IsPositionRightAndLeft Method
NBiometricTypes.IsPositionSingleEye Method
NBiometricTypes.IsPositionSingleFinger Method
NBiometricTypes.IsPositionTheEye Method
NBiometricTypes.IsPositionTheFinger Method
NBiometricTypes.IsPositionThePalm Method
NBiometricTypes.IsPositionThreeFingers Method
NBiometricTypes.IsPositionTwoEyes Method
NBiometricTypes.IsPositionTwoFingers Method
Collapse Expand IsPositionValid Method
NBiometricTypes.IsPositionValid Method (NEPosition)
NBiometricTypes.IsPositionValid Method (NFPosition)
NBiometricTypes.IsPositionValidFinger Method
NBiometricTypes.IsPositionValidPalm Method
NBiometricTypes.IsPositionValidTheEye Method
NBiometricTypes.IsPositionValidTheFinger Method
NBiometricTypes.IsQualityValid Method
NBiometricTypes.Nfiq1ToNfiqQuality Method
NBiometricTypes.NfiqQualityToNfiq1 Method
Collapse Expand QualityToString Method
NBiometricTypes.QualityToString Method (byte)
NBiometricTypes.QualityToString Method (byte, string)
NBiometricTypes.ToImpressionTypeFinger Method
Collapse Expand NBiometricTypes Properties
NBiometricTypes.NBiometricStatusNativeType Property
NBiometricTypes.NBiometricSubtypeNativeType Property
NBiometricTypes.NBiometricTypeNativeType Property
NBiometricTypes.NEImageTypeNativeType Property
NBiometricTypes.NEPositionNativeType Property
NBiometricTypes.NFImpressionTypeNativeType Property
NBiometricTypes.NFMinutiaFormatNativeType Property
NBiometricTypes.NFMinutiaTypeNativeType Property
NBiometricTypes.NFPatternClassNativeType Property
NBiometricTypes.NFPositionNativeType Property
NBiometricTypes.NFRidgeCountsTypeNativeType Property
NBiometricTypes.NGenderNativeType Property
NBiometricTypes.NIcaoWarningsNativeType Property
NBiometricTypes.NLExpressionNativeType Property
NBiometricTypes.NLPropertiesNativeType Property
NBiometricTypes.NLivenessActionNativeType Property
NBiometricTypes.NLivenessModeNativeType Property
NBiometricTypes.NTemplateSizeNativeType Property
NBiometricTypes.NativeType Property
NBiometricTypes.NfiqQualityNativeType Property
Collapse Expand NBiometrics Class
Collapse Expand NBiometrics Fields
NBiometrics.DllName Field
Collapse Expand NBiometrics Properties
NBiometrics.NativeModule Property
Collapse Expand NFCore Structure
Collapse Expand NFCore Constructor
NFCore.NFCore Constructor (ushort, ushort)
NFCore.NFCore Constructor (ushort, ushort, double)
NFCore.NFCore Constructor (ushort, ushort, int)
Collapse Expand NFCore Methods
Collapse Expand ToString Method
NFCore.ToString Method ()
NFCore.ToString Method (string)
Collapse Expand NFCore Properties
NFCore.Angle Property
NFCore.AngleDeg Property
NFCore.NativeType Property
NFCore.RawAngle Property
NFCore.X Property
NFCore.Y Property
Collapse Expand NFDelta Structure
Collapse Expand NFDelta Constructor
NFDelta.NFDelta Constructor (ushort, ushort)
NFDelta.NFDelta Constructor (ushort, ushort, double, double, double)
NFDelta.NFDelta Constructor (ushort, ushort, int, int, int)
Collapse Expand NFDelta Methods
Collapse Expand ToString Method
NFDelta.ToString Method ()
NFDelta.ToString Method (string)
Collapse Expand NFDelta Properties
NFDelta.Angle1 Property
NFDelta.Angle2 Property
NFDelta.Angle3 Property
NFDelta.AngleDeg1 Property
NFDelta.AngleDeg2 Property
NFDelta.AngleDeg3 Property
NFDelta.NativeType Property
NFDelta.RawAngle1 Property
NFDelta.RawAngle2 Property
NFDelta.RawAngle3 Property
NFDelta.X Property
NFDelta.Y Property
Collapse Expand NFDoubleCore Structure
NFDoubleCore.NFDoubleCore Constructor
Collapse Expand NFDoubleCore Methods
Collapse Expand ToString Method
NFDoubleCore.ToString Method ()
NFDoubleCore.ToString Method (string)
Collapse Expand NFDoubleCore Properties
NFDoubleCore.NativeType Property
NFDoubleCore.X Property
NFDoubleCore.Y Property
Collapse Expand NFMinutia Structure
Collapse Expand NFMinutia Constructor
NFMinutia.NFMinutia Constructor (ushort, ushort, NFMinutiaType, byte)
NFMinutia.NFMinutia Constructor (ushort, ushort, NFMinutiaType, byte, byte, byte, byte)
NFMinutia.NFMinutia Constructor (ushort, ushort, NFMinutiaType, double)
NFMinutia.NFMinutia Constructor (ushort, ushort, NFMinutiaType, double, byte, byte, byte)
Collapse Expand NFMinutia Methods
Collapse Expand ToString Method
NFMinutia.ToString Method ()
NFMinutia.ToString Method (string)
Collapse Expand NFMinutia Properties
NFMinutia.Angle Property
NFMinutia.AngleDeg Property
NFMinutia.Curvature Property
NFMinutia.G Property
NFMinutia.NativeType Property
NFMinutia.Quality Property
NFMinutia.RawAngle Property
NFMinutia.Type Property
NFMinutia.X Property
NFMinutia.Y Property
Collapse Expand NFMinutiaNeighbor Structure
NFMinutiaNeighbor.NFMinutiaNeighbor Constructor
Collapse Expand NFMinutiaNeighbor Fields
NFMinutiaNeighbor.Empty Field
Collapse Expand NFMinutiaNeighbor Methods
Collapse Expand ToString Method
NFMinutiaNeighbor.ToString Method ()
NFMinutiaNeighbor.ToString Method (string)
Collapse Expand NFMinutiaNeighbor Properties
NFMinutiaNeighbor.Index Property
NFMinutiaNeighbor.NativeType Property
NFMinutiaNeighbor.RidgeCount Property
Collapse Expand NFace Class
NFace.NFace Constructor
Collapse Expand NFace Classes
NFace.ObjectCollection Class
Collapse Expand NFace Methods
NFace.FromImageAndAttributes Method
NFace.GetImage Method
Collapse Expand NFace Properties
NFace.Image Property
NFace.NativeType Property
NFace.Objects Property
Collapse Expand NLAttributes Class
NLAttributes.NLAttributes Constructor
Collapse Expand NLAttributes Classes
NLAttributes.FeaturePointCollection Class
Collapse Expand NLAttributes Properties
NLAttributes.AdditionalFacesDetected Property
NLAttributes.Age Property
NLAttributes.BackgroundUniformity Property
NLAttributes.BaseFrameIndex Property
NLAttributes.BeardConfidence Property
NLAttributes.BlinkConfidence Property
NLAttributes.BoundingRect Property
NLAttributes.Contrast Property
NLAttributes.DarkGlassesConfidence Property
NLAttributes.EmotionAngerConfidence Property
NLAttributes.EmotionContemptConfidence Property
NLAttributes.EmotionDisgustConfidence Property
NLAttributes.EmotionFearConfidence Property
NLAttributes.EmotionHappinessConfidence Property
NLAttributes.EmotionNeutralConfidence Property
NLAttributes.EmotionSadnessConfidence Property
NLAttributes.EmotionSurpriseConfidence Property
NLAttributes.EthnicityArabianConfidence Property
NLAttributes.EthnicityAsianConfidence Property
NLAttributes.EthnicityBlackConfidence Property
NLAttributes.EthnicityHispanicConfidence Property
NLAttributes.EthnicityIndianConfidence Property
NLAttributes.EthnicityWhiteConfidence Property
NLAttributes.Expression Property
NLAttributes.ExpressionConfidence Property
NLAttributes.FaceDarknessConfidence Property
NLAttributes.FaceMaskConfidence Property
NLAttributes.FeaturePoints Property
NLAttributes.Gender Property
NLAttributes.GenderConfidence Property
NLAttributes.GlassesConfidence Property
NLAttributes.GlassesReflectionConfidence Property
NLAttributes.GrayscaleDensity Property
NLAttributes.HatConfidence Property
NLAttributes.HeavyFrameConfidence Property
NLAttributes.IcaoWarnings Property
NLAttributes.LeftEyeCenter Property
NLAttributes.LivenessAction Property
NLAttributes.LivenessScore Property
NLAttributes.LivenessTargetPitch Property
NLAttributes.LivenessTargetYaw Property
NLAttributes.LookingAwayConfidence Property
NLAttributes.MocTemplate Property
NLAttributes.MouthCenter Property
NLAttributes.MouthOpenConfidence Property
NLAttributes.MustacheConfidence Property
NLAttributes.NativeType Property
NLAttributes.Noise Property
NLAttributes.NoseTip Property
NLAttributes.Owner Property
NLAttributes.Pitch Property
NLAttributes.PixelationConfidence Property
NLAttributes.Properties Property
NLAttributes.RedEyeConfidence Property
NLAttributes.RightEyeCenter Property
NLAttributes.Roll Property
NLAttributes.Saturation Property
NLAttributes.Sharpness Property
NLAttributes.SkinReflectionConfidence Property
NLAttributes.Template Property
NLAttributes.Thumbnail Property
NLAttributes.TokenImageRect Property
NLAttributes.UnnaturalSkinToneConfidence Property
NLAttributes.WashedOutConfidence Property
NLAttributes.Yaw Property
Collapse Expand NLFeaturePoint Structure
Collapse Expand NLFeaturePoint Constructor
NLFeaturePoint.NLFeaturePoint Constructor (ushort, ushort, ushort)
NLFeaturePoint.NLFeaturePoint Constructor (ushort, ushort, ushort, byte)
Collapse Expand NLFeaturePoint Methods
Collapse Expand ToString Method
NLFeaturePoint.ToString Method ()
NLFeaturePoint.ToString Method (string)
Collapse Expand NLFeaturePoint Properties
NLFeaturePoint.Code Property
NLFeaturePoint.Confidence Property
NLFeaturePoint.NativeType Property
NLFeaturePoint.X Property
NLFeaturePoint.Y Property
Collapse Expand NLMatchingDetails Class
Collapse Expand NLMatchingDetails Properties
NLMatchingDetails.NativeType Property
Collapse Expand NLRecord Class
Collapse Expand NLRecord Constructor
NLRecord.NLRecord Constructor ()
NLRecord.NLRecord Constructor (NBuffer)
NLRecord.NLRecord Constructor (NBuffer, uint)
NLRecord.NLRecord Constructor (NBuffer, uint, out int)
NLRecord.NLRecord Constructor (NLRecord, NTemplateSize)
NLRecord.NLRecord Constructor (NLRecord, NTemplateSize, uint)
NLRecord.NLRecord Constructor (byte[])
NLRecord.NLRecord Constructor (uint)
Collapse Expand NLRecord Methods
Collapse Expand Check Method
NLRecord.Check Method (NBuffer)
NLRecord.Check Method (byte[])
Collapse Expand GetQuality Method
NLRecord.GetQuality Method (NBuffer)
NLRecord.GetQuality Method (byte[])
Collapse Expand GetSize Method
NLRecord.GetSize Method (NBuffer)
NLRecord.GetSize Method (byte[])
Collapse Expand NLRecord Properties
NLRecord.CbeffProductType Property
NLRecord.NativeType Property
NLRecord.Quality Property
Collapse Expand NLTemplate Class
Collapse Expand NLTemplate Constructor
NLTemplate.NLTemplate Constructor ()
NLTemplate.NLTemplate Constructor (NBuffer)
NLTemplate.NLTemplate Constructor (NBuffer, uint)
NLTemplate.NLTemplate Constructor (NBuffer, uint, out int)
NLTemplate.NLTemplate Constructor (byte[])
NLTemplate.NLTemplate Constructor (uint)
Collapse Expand NLTemplate Classes
NLTemplate.RecordCollection Class
Collapse Expand NLTemplate Fields
NLTemplate.FlagProcessFirstRecordOnly Field
NLTemplate.MaxRecordCount Field
Collapse Expand NLTemplate Methods
NLTemplate.CalculateSize Method
Collapse Expand Check Method
NLTemplate.Check Method (NBuffer)
NLTemplate.Check Method (byte[])
Collapse Expand GetRecordCount Method
NLTemplate.GetRecordCount Method (NBuffer)
NLTemplate.GetRecordCount Method (byte[])
Collapse Expand GetSize Method
NLTemplate.GetSize Method (NBuffer)
NLTemplate.GetSize Method (byte[])
Collapse Expand NLTemplate Properties
NLTemplate.NativeType Property
NLTemplate.Records Property
Collapse Expand NMatchingDetails Class
Collapse Expand NMatchingDetails Constructor
NMatchingDetails.NMatchingDetails Constructor (NBuffer)
NMatchingDetails.NMatchingDetails Constructor (NBuffer, uint)
NMatchingDetails.NMatchingDetails Constructor (NBuffer, uint, out int)
NMatchingDetails.NMatchingDetails Constructor (NStream)
NMatchingDetails.NMatchingDetails Constructor (NStream, uint)
NMatchingDetails.NMatchingDetails Constructor (byte[])
Collapse Expand NMatchingDetails Classes
NMatchingDetails.FaceCollection Class
NMatchingDetails.FingerCollection Class
NMatchingDetails.IrisCollection Class
NMatchingDetails.PalmCollection Class
NMatchingDetails.VoiceCollection Class
Collapse Expand NMatchingDetails Fields
NMatchingDetails.FlagSaveCompatible12Line Field
Collapse Expand NMatchingDetails Properties
NMatchingDetails.Faces Property
NMatchingDetails.FacesMatchedIndex Property
NMatchingDetails.FacesScore Property
NMatchingDetails.Fingers Property
NMatchingDetails.FingersScore Property
NMatchingDetails.Irises Property
NMatchingDetails.IrisesScore Property
NMatchingDetails.NativeType Property
NMatchingDetails.Palms Property
NMatchingDetails.PalmsScore Property
NMatchingDetails.Voices Property
NMatchingDetails.VoicesScore Property
Collapse Expand NMatchingDetailsBase Class
Collapse Expand NMatchingDetailsBase Properties
NMatchingDetailsBase.BiometricType Property
NMatchingDetailsBase.NativeType Property
NMatchingDetailsBase.Score Property
Collapse Expand NMatchingResult Class
Collapse Expand NMatchingResult Properties
NMatchingResult.Connection Property
NMatchingResult.Id Property
NMatchingResult.MatchingDetails Property
NMatchingResult.MatchingDetailsBuffer Property
NMatchingResult.NativeType Property
NMatchingResult.Owner Property
NMatchingResult.Score Property
NMatchingResult.Subject Property
Collapse Expand NSubject Class
NSubject.NSubject Constructor
Collapse Expand NSubject Classes
NSubject.FaceCollection Class
NSubject.FingerCollection Class
NSubject.IrisCollection Class
NSubject.MatchingResultCollection Class
NSubject.MissingEyeCollection Class
NSubject.MissingFingerCollection Class
NSubject.PalmCollection Class
NSubject.RelatedSubjectCollection Class
NSubject.SignatureCollection Class
NSubject.VoiceCollection Class
Collapse Expand NSubject Methods
NSubject.Clear Method
Collapse Expand FromFile Method
NSubject.FromFile Method (string)
NSubject.FromFile Method (string, uint)
NSubject.FromFile Method (string, ushort, ushort)
NSubject.FromFile Method (string, ushort, ushort, uint)
Collapse Expand FromMemory Method
NSubject.FromMemory Method (NBuffer)
NSubject.FromMemory Method (NBuffer, uint)
NSubject.FromMemory Method (NBuffer, uint, out int)
NSubject.FromMemory Method (NBuffer, ushort, ushort)
NSubject.FromMemory Method (NBuffer, ushort, ushort, uint)
NSubject.FromMemory Method (NBuffer, ushort, ushort, uint, out int)
NSubject.FromMemory Method (byte[])
NSubject.FromMemory Method (byte[], ushort, ushort)
Collapse Expand FromStream Method
NSubject.FromStream Method (NStream)
NSubject.FromStream Method (NStream, uint)
NSubject.FromStream Method (NStream, ushort, ushort)
NSubject.FromStream Method (NStream, ushort, ushort, uint)
NSubject.GetTemplate Method
Collapse Expand GetTemplateBuffer Method
NSubject.GetTemplateBuffer Method ()
NSubject.GetTemplateBuffer Method (ushort, ushort, NVersion)
Collapse Expand SetTemplate Method
NSubject.SetTemplate Method (ANTemplate)
NSubject.SetTemplate Method (CbeffRecord)
NSubject.SetTemplate Method (FCRecord)
NSubject.SetTemplate Method (FIRecord)
NSubject.SetTemplate Method (FMCRecord)
NSubject.SetTemplate Method (FMRecord)
NSubject.SetTemplate Method (IIRecord)
NSubject.SetTemplate Method (NTemplate)
Collapse Expand SetTemplateBuffer Method
NSubject.SetTemplateBuffer Method (NBuffer)
NSubject.SetTemplateBuffer Method (NBuffer, ushort, ushort)
NSubject.ToANTemplate Method
NSubject.ToFCRecord Method
NSubject.ToFIRecord Method
NSubject.ToFMCRecord Method
Collapse Expand ToFMRecord Method
NSubject.ToFMRecord Method (BdifStandard, NVersion)
NSubject.ToFMRecord Method (BdifStandard, NVersion, uint)
NSubject.ToIIRecord Method
Collapse Expand NSubject Properties
NSubject.Error Property
NSubject.Faces Property
NSubject.Fingers Property
NSubject.Gender Property
NSubject.Id Property
NSubject.Irises Property
NSubject.IsMultipleSubjects Property
NSubject.MatchingResults Property
NSubject.MissingEyes Property
NSubject.MissingFingers Property
NSubject.NativeType Property
NSubject.Palms Property
NSubject.QueryString Property
NSubject.RelatedSubjects Property
NSubject.Signatures Property
NSubject.Statistics Property
NSubject.Status Property
NSubject.Voices Property
Collapse Expand NTemplate Class
Collapse Expand NTemplate Constructor
NTemplate.NTemplate Constructor ()
NTemplate.NTemplate Constructor (NBuffer)
NTemplate.NTemplate Constructor (NBuffer, uint)
NTemplate.NTemplate Constructor (NBuffer, uint, out int)
NTemplate.NTemplate Constructor (byte[])
NTemplate.NTemplate Constructor (uint)
Collapse Expand NTemplate Methods
NTemplate.CalculateSize Method
Collapse Expand Check Method
NTemplate.Check Method (NBuffer)
NTemplate.Check Method (byte[])
NTemplate.Clear Method
Collapse Expand GetSize Method
NTemplate.GetSize Method (NBuffer)
NTemplate.GetSize Method (byte[])
Collapse Expand Merge Method
NTemplate.Merge Method (NBuffer[])
NTemplate.Merge Method (NBuffer[], uint)
Collapse Expand NTemplate Properties
NTemplate.Faces Property
NTemplate.Fingers Property
NTemplate.Irises Property
NTemplate.NativeType Property
NTemplate.Palms Property
NTemplate.Voices Property
Collapse Expand Structs, Records, Enums
Neurotec.Biometrics.NBiometricCaptureOptions Enumeration
Neurotec.Biometrics.NBiometricStatus Enumeration
Neurotec.Biometrics.NBiometricSubtype Enumeration
Neurotec.Biometrics.NBiometricType Enumeration
Neurotec.Biometrics.NEImageType Enumeration
Neurotec.Biometrics.NEPosition Enumeration
Neurotec.Biometrics.NFImpressionType Enumeration
Neurotec.Biometrics.NFMinutiaFormat Enumeration
Neurotec.Biometrics.NFMinutiaType Enumeration
Neurotec.Biometrics.NFPatternClass Enumeration
Neurotec.Biometrics.NFPosition Enumeration
Neurotec.Biometrics.NFRidgeCountsType Enumeration
Neurotec.Biometrics.NGender Enumeration
Neurotec.Biometrics.NIcaoWarnings Enumeration
Neurotec.Biometrics.NLExpression Enumeration
Neurotec.Biometrics.NLProperties Enumeration
Neurotec.Biometrics.NLivenessAction Enumeration
Neurotec.Biometrics.NLivenessMode Enumeration
Neurotec.Biometrics.NfiqQuality Enumeration
Collapse Expand Neurotec.Collections.ObjectModel Namespace
Collapse Expand Classes
Collapse Expand NArrayCollection Class
Collapse Expand NArrayCollection Methods
NArrayCollection.Add Method
Collapse Expand AddRange Method
NArrayCollection.AddRange Method (int, Array)
NArrayCollection.AddRange Method (int, object[])
NArrayCollection.Clear Method
NArrayCollection.Contains Method
Collapse Expand CopyTo Method
NArrayCollection.CopyTo Method (Array, int)
NArrayCollection.CopyTo Method (int, Array, int)
NArrayCollection.CopyTo Method (int, object[], int)
NArrayCollection.CopyTo Method (object[], int)
NArrayCollection.GetCount Method
NArrayCollection.GetEnumerator Method
NArrayCollection.IndexOf Method
NArrayCollection.Insert Method
Collapse Expand InsertRange Method
NArrayCollection.InsertRange Method (int, int, Array)
NArrayCollection.InsertRange Method (int, int, object[])
NArrayCollection.Remove Method
NArrayCollection.RemoveAt Method
NArrayCollection.RemoveRange Method
NArrayCollection.ToArray Method
NArrayCollection.ToItemArray Method
NArrayCollection.this Indexer
Collapse Expand NArrayCollection Properties
NArrayCollection.Count Property
NArrayCollection.IsReadOnly Property
NArrayCollection.NativeType Property
NArrayCollection.this Property
Collapse Expand NCollection Class
Collapse Expand NCollection Methods
NCollection.Add Method
Collapse Expand AddRange Method
NCollection.AddRange Method (Array)
NCollection.AddRange Method (object[])
NCollection.Clear Method
NCollection.Contains Method
Collapse Expand CopyTo Method
NCollection.CopyTo Method (Array, int)
NCollection.CopyTo Method (object[], int)
NCollection.GetEnumerator Method
NCollection.IndexOf Method
NCollection.Insert Method
Collapse Expand InsertRange Method
NCollection.InsertRange Method (int, Array)
NCollection.InsertRange Method (int, object[])
NCollection.Remove Method
NCollection.RemoveAt Method
NCollection.RemoveRange Method
NCollection.ToArray Method
NCollection.ToItemArray Method
NCollection.this Indexer
Collapse Expand NCollection Properties
NCollection.Capacity Property
NCollection.Count Property
NCollection.IsReadOnly Property
NCollection.NCollectionChangedActionNativeType Property
NCollection.NCollectionCollectionChangedCallbackNativeType Property
NCollection.NativeType Property
Collapse Expand NCollection Events
NCollection.CollectionChanged Event
Collapse Expand NDictionary Class
Collapse Expand NDictionary Classes
Collapse Expand NDictionary.KeyCollection Class
Collapse Expand KeyCollection Methods
NDictionary.KeyCollection.ToItemArray Method
Collapse Expand NDictionary.ValueCollection Class
Collapse Expand ValueCollection Methods
NDictionary.ValueCollection.ToItemArray Method
Collapse Expand NDictionary Methods
Collapse Expand Add Method
NDictionary.Add Method (KeyValuePair<object, object>)
NDictionary.Add Method (object)
NDictionary.Add Method (object, object)
NDictionary.Clear Method
NDictionary.ContainsKey Method
Collapse Expand CopyTo Method
NDictionary.CopyTo Method (Array, int)
NDictionary.CopyTo Method (KeyValuePair<object, object>[], int)
NDictionary.GetEnumerator Method
NDictionary.GetItemAt Method
NDictionary.Remove Method
NDictionary.RemoveAt Method
NDictionary.ToArray Method
NDictionary.ToItemArray Method
NDictionary.TryGetValue Method
Collapse Expand this Indexer
NDictionary.this Indexer (int)
NDictionary.this Indexer (object)
Collapse Expand NDictionary Properties
NDictionary.Count Property
NDictionary.IsReadOnly Property
NDictionary.Keys Property
NDictionary.NativeType Property
NDictionary.Values Property
Collapse Expand NDictionary Events
NDictionary.CollectionChanged Event
Collapse Expand Structs, Records, Enums
Neurotec.Collections.ObjectModel.NCollectionChangedAction Enumeration
Collapse Expand Neurotec.Devices Namespace
Collapse Expand Classes
Collapse Expand NBiometricDevice Class
Collapse Expand NBiometricDevice Methods
NBiometricDevice.Cancel Method
Collapse Expand Capture Method
NBiometricDevice.Capture Method (NBiometric)
NBiometricDevice.Capture Method (NBiometric, TimeSpan)
NBiometricDevice.Capture Method (NBiometric, int)
NBiometricDevice.EndSequence Method
NBiometricDevice.StartSequence Method
Collapse Expand NBiometricDevice Properties
NBiometricDevice.BiometricType Property
NBiometricDevice.IsSpoofDetectionSupported Property
NBiometricDevice.NativeType Property
NBiometricDevice.ProductId Property
NBiometricDevice.SpoofDetection Property
NBiometricDevice.VendorId Property
Collapse Expand NBiometricDevice Events
NBiometricDevice.CapturePreview Event
Collapse Expand NBiometricDeviceCapturePreviewEventArgs Class
NBiometricDeviceCapturePreviewEventArgs.NBiometricDeviceCapturePreviewEventArgs Constructor
Collapse Expand NBiometricDeviceCapturePreviewEventArgs Properties
NBiometricDeviceCapturePreviewEventArgs.Biometric Property
Collapse Expand NCamera Class
Collapse Expand NCamera Methods
NCamera.CaptureStill Method
NCamera.Focus Method
NCamera.GetCurrentStillFormat Method
Collapse Expand GetFrame Method
NCamera.GetFrame Method ()
NCamera.GetFrame Method (out TimeSpan, out TimeSpan)
NCamera.GetStillFormats Method
NCamera.GetVideoSample Method
NCamera.ResetFocus Method
NCamera.SetCurrentStillFormat Method
Collapse Expand NCamera Properties
NCamera.FocusRegion Property
NCamera.IsFocusRegionSupported Property
NCamera.IsFocusSupported Property
NCamera.IsStillCaptureSupported Property
NCamera.IsVideoSampleSupported Property
NCamera.NCameraStatusNativeType Property
NCamera.NativeType Property
Collapse Expand NCamera Events
NCamera.StillCaptured Event
Collapse Expand NCameraStillCapturedEventArgs Class
NCameraStillCapturedEventArgs.NCameraStillCapturedEventArgs Constructor
Collapse Expand NCameraStillCapturedEventArgs Properties
NCameraStillCapturedEventArgs.Id Property
NCameraStillCapturedEventArgs.Properties Property
NCameraStillCapturedEventArgs.Stream Property
Collapse Expand NCaptureDevice Class
Collapse Expand NCaptureDevice Methods
NCaptureDevice.GetCurrentFormat Method
NCaptureDevice.GetFormats Method
NCaptureDevice.SetCurrentFormat Method
NCaptureDevice.StartCapturing Method
NCaptureDevice.StopCapturing Method
Collapse Expand NCaptureDevice Properties
NCaptureDevice.IsCapturing Property
NCaptureDevice.MediaType Property
NCaptureDevice.NativeType Property
Collapse Expand NCaptureDevice Events
NCaptureDevice.IsCapturingChanged Event
Collapse Expand NDevice Class
Collapse Expand NDevice Classes
NDevice.ChildCollection Class
Collapse Expand NDevice Properties
NDevice.Children Property
NDevice.DeviceType Property
NDevice.DisplayName Property
NDevice.Id Property
NDevice.IsAvailable Property
NDevice.IsDisconnectable Property
NDevice.IsPrivate Property
NDevice.Make Property
NDevice.Model Property
NDevice.NDeviceTypeNativeType Property
NDevice.NativeType Property
NDevice.Owner Property
NDevice.Parent Property
NDevice.Plugin Property
NDevice.SerialNumber Property
Collapse Expand NDeviceManager Class
NDeviceManager.NDeviceManager Constructor
Collapse Expand NDeviceManager Classes
Collapse Expand NDeviceManager.DeviceCollection Class
Collapse Expand DeviceCollection Methods
NDeviceManager.DeviceCollection.IndexOf Method
NDeviceManager.DeviceCollection.this Indexer
Collapse Expand NDeviceManager Methods
Collapse Expand ConnectToDevice Method
NDeviceManager.ConnectToDevice Method (NPlugin, NPropertyBag)
NDeviceManager.ConnectToDevice Method (string, string)
NDeviceManager.DisconnectFromDevice Method
NDeviceManager.GetConnectToDeviceParameters Method
NDeviceManager.Initialize Method
NDeviceManager.IsConnectToDeviceSupported Method
Collapse Expand NDeviceManager Properties
NDeviceManager.AutoPlug Property
NDeviceManager.BiometricEngine Property
NDeviceManager.DeviceTypes Property
NDeviceManager.Devices Property
NDeviceManager.IsInitialized Property
NDeviceManager.NativeType Property
NDeviceManager.PluginManager Property
Collapse Expand NDeviceManagerDeviceEventArgs Class
NDeviceManagerDeviceEventArgs.NDeviceManagerDeviceEventArgs Constructor
Collapse Expand NDeviceManagerDeviceEventArgs Properties
NDeviceManagerDeviceEventArgs.Device Property
Collapse Expand NDevices Class
Collapse Expand NDevices Fields
NDevices.DllName Field
Collapse Expand NDevices Properties
NDevices.NativeModule Property
Collapse Expand Structs, Records, Enums
Neurotec.Devices.NCameraStatus Enumeration
Neurotec.Devices.NDeviceType Enumeration
Collapse Expand Neurotec.Devices.ComponentModel Namespace
Collapse Expand Classes
Collapse Expand NDeviceEventDescriptor Class
Collapse Expand NDeviceEventDescriptor Properties
NDeviceEventDescriptor.NativeType Property
Collapse Expand NDeviceMethodDescriptor Class
Collapse Expand NDeviceMethodDescriptor Properties
NDeviceMethodDescriptor.NativeType Property
Collapse Expand NDevicePropertyDescriptor Class
Collapse Expand NDevicePropertyDescriptor Properties
NDevicePropertyDescriptor.NativeType Property
Collapse Expand Neurotec.Geometry Namespace
Collapse Expand Classes
Collapse Expand NGeometry Class
Collapse Expand NGeometry Properties
NGeometry.InterpolationModeNativeType Property
NGeometry.NativeType Property
NGeometry.PointDNativeType Property
NGeometry.PointFNativeType Property
NGeometry.PointNativeType Property
NGeometry.RectangleDNativeType Property
NGeometry.RectangleFNativeType Property
NGeometry.RectangleNativeType Property
NGeometry.SizeDNativeType Property
NGeometry.SizeFNativeType Property
NGeometry.SizeNativeType Property
Collapse Expand Neurotec.IO Namespace
Collapse Expand Classes
Collapse Expand NBuffer Class
Collapse Expand NBuffer Constructor
NBuffer.NBuffer Constructor (IntPtr, UIntPtr)
NBuffer.NBuffer Constructor (IntPtr, UIntPtr, NMemoryType)
NBuffer.NBuffer Constructor (IntPtr, UIntPtr, bool)
NBuffer.NBuffer Constructor (IntPtr, int)
NBuffer.NBuffer Constructor (IntPtr, int, NMemoryType)
NBuffer.NBuffer Constructor (IntPtr, int, bool)
NBuffer.NBuffer Constructor (IntPtr, long)
NBuffer.NBuffer Constructor (IntPtr, long, NMemoryType)
NBuffer.NBuffer Constructor (IntPtr, long, bool)
NBuffer.NBuffer Constructor (NBuffer, UIntPtr, UIntPtr)
NBuffer.NBuffer Constructor (NBuffer, int, int)
NBuffer.NBuffer Constructor (NBuffer, long, long)
NBuffer.NBuffer Constructor (UIntPtr)
NBuffer.NBuffer Constructor (byte[])
NBuffer.NBuffer Constructor (byte[], int, int)
NBuffer.NBuffer Constructor (int)
NBuffer.NBuffer Constructor (long)
Collapse Expand NBuffer Methods
Collapse Expand Copy Method
NBuffer.Copy Method (NBuffer, UIntPtr, NBuffer, UIntPtr, UIntPtr)
NBuffer.Copy Method (NBuffer, int, NBuffer, int, int)
NBuffer.Copy Method (NBuffer, long, NBuffer, long, long)
Collapse Expand CopyFrom Method
NBuffer.CopyFrom Method (IntPtr, UIntPtr, UIntPtr)
NBuffer.CopyFrom Method (IntPtr, int, int)
NBuffer.CopyFrom Method (IntPtr, long, long)
NBuffer.CopyFrom Method (byte[], int, int, int)
Collapse Expand CopyTo Method
NBuffer.CopyTo Method (IntPtr, UIntPtr)
NBuffer.CopyTo Method (IntPtr, int)
NBuffer.CopyTo Method (IntPtr, long)
NBuffer.CopyTo Method (NBuffer, UIntPtr)
NBuffer.CopyTo Method (NBuffer, int)
NBuffer.CopyTo Method (NBuffer, long)
NBuffer.CopyTo Method (UIntPtr, IntPtr, UIntPtr, UIntPtr)
NBuffer.CopyTo Method (byte[], int)
NBuffer.CopyTo Method (int, IntPtr, int, int)
NBuffer.CopyTo Method (int, byte[], int, int)
NBuffer.CopyTo Method (long, IntPtr, long, long)
NBuffer.ToArray Method
NBuffer.WriteTo Method
Collapse Expand NBuffer Properties
NBuffer.Empty Property
NBuffer.LongSize Property
NBuffer.NativeSize Property
NBuffer.NativeType Property
NBuffer.Ptr Property
NBuffer.Size Property
Collapse Expand NMemoryStream Class
Collapse Expand NMemoryStream Constructor
NMemoryStream.NMemoryStream Constructor ()
NMemoryStream.NMemoryStream Constructor (NBuffer)
NMemoryStream.NMemoryStream Constructor (NBuffer, FileAccess, bool)
NMemoryStream.NMemoryStream Constructor (NBuffer, bool)
NMemoryStream.NMemoryStream Constructor (UIntPtr)
NMemoryStream.NMemoryStream Constructor (byte[])
NMemoryStream.NMemoryStream Constructor (byte[], bool)
NMemoryStream.NMemoryStream Constructor (int)
NMemoryStream.NMemoryStream Constructor (long)
Collapse Expand NMemoryStream Methods
NMemoryStream.GetBuffer Method
NMemoryStream.ToArray Method
NMemoryStream.WriteTo Method
Collapse Expand NMemoryStream Properties
NMemoryStream.Capacity Property
NMemoryStream.LongCapacity Property
NMemoryStream.NativeCapacity Property
NMemoryStream.NativeType Property
NMemoryStream.PositionPtr Property
Collapse Expand NStream Class
Collapse Expand NStream Methods
NStream.AsStream Method
Collapse Expand CopyTo Method
NStream.CopyTo Method (NStream)
NStream.CopyTo Method (NStream, int)
NStream.Flush Method
NStream.FromStream Method
Collapse Expand Read Method
NStream.Read Method (NBuffer)
NStream.Read Method (byte[], int, int)
NStream.ReadByte Method
NStream.Seek Method
NStream.SetLength Method
NStream.Synchronized Method
Collapse Expand Write Method
NStream.Write Method (NBuffer)
NStream.Write Method (byte[], int, int)
NStream.WriteByte Method
Collapse Expand NStream Properties
NStream.CanRead Property
NStream.CanSeek Property
NStream.CanWrite Property
NStream.Length Property
NStream.NativeType Property
NStream.Null Property
NStream.Position Property
Collapse Expand Neurotec.Images Namespace
Collapse Expand Classes
Collapse Expand BmpInfo Class
Collapse Expand BmpInfo Properties
BmpInfo.NativeType Property
Collapse Expand IHeadInfo Class
Collapse Expand IHeadInfo Properties
IHeadInfo.NativeType Property
Collapse Expand Jpeg2KInfo Class
Collapse Expand Jpeg2KInfo Fields
Jpeg2KInfo.DefaultRatio Field
Collapse Expand Jpeg2KInfo Properties
Jpeg2KInfo.Jpeg2KProfileNativeType Property
Jpeg2KInfo.NativeType Property
Jpeg2KInfo.Profile Property
Jpeg2KInfo.Ratio Property
Collapse Expand JpegInfo Class
Collapse Expand JpegInfo Fields
JpegInfo.DefaultQuality Field
Collapse Expand JpegInfo Properties
JpegInfo.IsLossless Property
JpegInfo.NativeType Property
JpegInfo.Quality Property
Collapse Expand NImage Class
Collapse Expand NImage Classes
Collapse Expand NImage.ImagePalette Class
Collapse Expand ImagePalette Methods
NImage.ImagePalette.GetEntries Method
NImage.ImagePalette.SetEntries Method
Collapse Expand ImagePalette Properties
NImage.ImagePalette.EntriesSize Property
NImage.ImagePalette.NativeEntriesSize Property
NImage.PlaneCollection Class
Collapse Expand NImage Fields
NImage.FlagAllDst Field
NImage.FlagAllDstAndSrc Field
NImage.FlagAllSrc Field
NImage.FlagDstAlphaChannelFirst Field
NImage.FlagDstBottomToTop Field
NImage.FlagDstSwapChannels Field
NImage.FlagReadUnknownImage Field
NImage.FlagSrcAlphaChannelFirst Field
NImage.FlagSrcBottomToTop Field
NImage.FlagSrcSwapChannels Field
NImage.FlagWriteUnknownImage Field
Collapse Expand NImage Methods
Collapse Expand Copy Method
NImage.Copy Method (NImage, uint, uint, uint, uint, NImage, uint, uint)
NImage.Copy Method (NPixelFormat, Array, Array, NBuffer, int, uint, uint, long, NBuffer[], uint, uint, NPixelFormat, Array, Array, NBuffer, int, uint, uint, long, NBuffer[], uint, uint, uint, uint, uint)
NImage.Copy Method (NPixelFormat, uint, uint, int, NBuffer, uint, uint, NPixelFormat, uint, uint, int, NBuffer, uint, uint, uint, uint)
NImage.Copy Method (NPixelFormat, uint, uint, long, NBuffer, uint, uint, NPixelFormat, uint, uint, long, NBuffer, uint, uint, uint, uint, uint)
NImage.Copy Method (NPixelFormat, uint, uint, long, NBuffer[], uint, uint, NPixelFormat, uint, uint, long, NBuffer[], uint, uint, uint, uint, uint)
Collapse Expand CopyFrom Method
NImage.CopyFrom Method (NPixelFormat, Array, Array, NBuffer, int, uint, uint, long, NBuffer[], uint, uint, uint, uint, uint, uint, uint)
NImage.CopyFrom Method (NPixelFormat, uint, uint, int, NBuffer, uint, uint)
NImage.CopyFrom Method (NPixelFormat, uint, uint, long, NBuffer, uint, uint, uint)
NImage.CopyFrom Method (NPixelFormat, uint, uint, long, NBuffer, uint, uint, uint, uint, uint, uint, uint)
NImage.CopyFrom Method (NPixelFormat, uint, uint, long, NBuffer[], uint, uint, uint, uint, uint, uint, uint)
NImage.CopyFromYCbCrData Method
Collapse Expand CopyTo Method
NImage.CopyTo Method (NImage, uint, uint)
NImage.CopyTo Method (NPixelFormat, uint, uint, int, NBuffer, uint, uint)
NImage.CopyTo Method (NPixelFormat, uint, uint, long, NBuffer, uint, uint, uint)
NImage.CopyTo Method (uint, uint, NPixelFormat, Array, Array, NBuffer, int, uint, uint, long, NBuffer[], uint, uint, uint, uint, uint)
NImage.CopyTo Method (uint, uint, NPixelFormat, uint, uint, long, NBuffer, uint, uint, uint, uint, uint)
NImage.CopyTo Method (uint, uint, NPixelFormat, uint, uint, long, NBuffer[], uint, uint, uint, uint, uint)
Collapse Expand Create Method
NImage.Create Method (NPixelFormat, uint, uint, int)
NImage.Create Method (NPixelFormat, uint, uint, long, uint)
NImage.Crop Method
NImage.ExportPalette Method
NImage.FlipDiagonally Method
NImage.FlipHorizontally Method
NImage.FlipVertically Method
Collapse Expand FromData Method
NImage.FromData Method (NPixelFormat, int, uint, uint, int, NBuffer, uint, uint, uint, uint)
NImage.FromData Method (NPixelFormat, long, uint, uint, long, NBuffer, uint, uint, uint, uint, uint)
NImage.FromData Method (NPixelFormat, long, uint, uint, long, NBuffer[], uint, uint, uint, uint, uint)
NImage.FromData Method (NPixelFormat, uint, uint, int, uint, NBuffer)
NImage.FromData Method (NPixelFormat, uint, uint, long, long, NBuffer, uint)
Collapse Expand FromFile Method
NImage.FromFile Method (string)
NImage.FromFile Method (string, NImageFormat)
NImage.FromFile Method (string, NImageFormat, uint)
Collapse Expand FromImage Method
NImage.FromImage Method (NPixelFormat, int, NImage)
NImage.FromImage Method (NPixelFormat, int, NImage, uint, uint, uint, uint)
NImage.FromImage Method (NPixelFormat, long, NImage, uint)
NImage.FromImage Method (NPixelFormat, long, NImage, uint, uint, uint, uint, uint)
Collapse Expand FromMemory Method
NImage.FromMemory Method (NBuffer)
NImage.FromMemory Method (NBuffer, NImageFormat)
NImage.FromMemory Method (NBuffer, NImageFormat, uint)
NImage.FromMemory Method (byte[])
NImage.FromMemory Method (byte[], NImageFormat)
Collapse Expand FromStream Method
NImage.FromStream Method (NStream)
NImage.FromStream Method (NStream, NImageFormat)
NImage.FromStream Method (NStream, NImageFormat, uint)
Collapse Expand FromVideoSample Method
NImage.FromVideoSample Method (NVideoFormat, NBuffer)
NImage.FromVideoSample Method (NVideoFormat, byte[])
NImage.GetIndex Method
NImage.GetPixel Method
NImage.GetPixels Method
NImage.GetSupportedVideoSubtypes Method
Collapse Expand GetWrapper Method
NImage.GetWrapper Method (NImage, uint, uint, uint, uint)
NImage.GetWrapper Method (NImage, uint, uint, uint, uint, uint)
NImage.GetWrapper Method (NPixelFormat, uint, uint, int, NBuffer)
NImage.GetWrapper Method (NPixelFormat, uint, uint, int, NBuffer, uint, uint, uint, uint)
NImage.GetWrapper Method (NPixelFormat, uint, uint, long, NBuffer, uint)
NImage.GetWrapper Method (NPixelFormat, uint, uint, long, NBuffer, uint, uint, uint, uint, uint)
NImage.GetWrapper Method (NPixelFormat, uint, uint, long, NBuffer[], uint, uint, uint, uint, uint)
NImage.IsVideoFormatSupported Method
NImage.IsVideoSubtypeSupported Method
NImage.RotateFlip Method
Collapse Expand Save Method
NImage.Save Method (NImageFormat)
NImage.Save Method (NImageFormat, NImageInfo, uint)
NImage.Save Method (NImageInfo)
NImage.Save Method (NStream, NImageFormat)
NImage.Save Method (NStream, NImageFormat, NImageInfo, uint)
NImage.Save Method (NStream, NImageInfo)
NImage.Save Method (string)
NImage.Save Method (string, NImageFormat)
NImage.Save Method (string, NImageFormat, NImageInfo, uint)
NImage.Save Method (string, NImageInfo)
NImage.SetIndex Method
NImage.SetPixel Method
Collapse Expand NImage Properties
NImage.Height Property
NImage.HorzResolution Property
NImage.ImageSize Property
NImage.Info Property
NImage.LongImageSize Property
NImage.LongPlaneSize Property
NImage.LongStride Property
NImage.MaxValue Property
NImage.MinValue Property
NImage.NativeImageSize Property
NImage.NativePlaneSize Property
NImage.NativeStride Property
NImage.NativeType Property
NImage.Palette Property
NImage.PixelFormat Property
NImage.PlaneSize Property
NImage.Planes Property
NImage.ResolutionIsAspectRatio Property
NImage.Stride Property
NImage.VertResolution Property
NImage.Width Property
Collapse Expand NImageFormat Class
Collapse Expand NImageFormat Classes
NImageFormat.ImageFormatCollection Class
Collapse Expand NImageFormat Methods
Collapse Expand CreateInfo Method
NImageFormat.CreateInfo Method (NImage)
NImageFormat.CreateInfo Method (NImage, uint)
Collapse Expand OpenReader Method
NImageFormat.OpenReader Method (NBuffer)
NImageFormat.OpenReader Method (NBuffer, uint)
NImageFormat.OpenReader Method (NStream)
NImageFormat.OpenReader Method (NStream, uint)
NImageFormat.OpenReader Method (string)
NImageFormat.OpenReader Method (string, uint)
Collapse Expand OpenWriter Method
NImageFormat.OpenWriter Method ()
NImageFormat.OpenWriter Method (NStream)
NImageFormat.OpenWriter Method (NStream, uint)
NImageFormat.OpenWriter Method (string)
NImageFormat.OpenWriter Method (string, uint)
NImageFormat.OpenWriter Method (uint)
NImageFormat.Select Method
NImageFormat.SelectByInternetMediaType Method
Collapse Expand SelectReader Method
NImageFormat.SelectReader Method (NBuffer)
NImageFormat.SelectReader Method (NBuffer, uint)
NImageFormat.SelectReader Method (NStream)
NImageFormat.SelectReader Method (NStream, uint)
NImageFormat.SelectReader Method (string)
NImageFormat.SelectReader Method (string, uint)
Collapse Expand NImageFormat Properties
NImageFormat.Bmp Property
NImageFormat.CanRead Property
NImageFormat.CanWrite Property
NImageFormat.CanWriteMultiple Property
NImageFormat.DefaultFileExtension Property
NImageFormat.DefaultInternetMediaType Property
NImageFormat.FileFilter Property
NImageFormat.Formats Property
NImageFormat.Gif Property
NImageFormat.IHead Property
NImageFormat.InternetMediaType Property
NImageFormat.Jpeg Property
NImageFormat.Jpeg2K Property
NImageFormat.Name Property
NImageFormat.NativeType Property
NImageFormat.Png Property
NImageFormat.Tiff Property
NImageFormat.WebP Property
NImageFormat.Wsq Property
Collapse Expand NImageInfo Class
NImageInfo.NImageInfo Constructor
Collapse Expand NImageInfo Properties
NImageInfo.Format Property
NImageInfo.Height Property
NImageInfo.NImageRotateFlipTypeNativeType Property
NImageInfo.NativeType Property
NImageInfo.Transform Property
NImageInfo.Width Property
Collapse Expand NImageReader Class
Collapse Expand NImageReader Methods
Collapse Expand Read Method
NImageReader.Read Method ()
NImageReader.Read Method (uint)
Collapse Expand ReadInfo Method
NImageReader.ReadInfo Method ()
NImageReader.ReadInfo Method (uint)
Collapse Expand NImageReader Properties
NImageReader.Format Property
NImageReader.NativeType Property
NImageReader.ReadSize Property
Collapse Expand NImageWriter Class
Collapse Expand NImageWriter Methods
NImageWriter.GetBuffer Method
NImageWriter.Write Method
Collapse Expand NImageWriter Properties
NImageWriter.Format Property
NImageWriter.NativeType Property
Collapse Expand NImages Class
Collapse Expand NImages Methods
NImages.GetGrayscaleColorWrapper Method
NImages.GetOpenFileFilter Method
NImages.GetOpenFileFilterString Method
NImages.GetSaveFileFilter Method
NImages.GetSaveFileFilterString Method
NImages.RecolorImage Method
Collapse Expand NImages Properties
NImages.NativeType Property
Collapse Expand NPixelFormat Structure
Collapse Expand NPixelFormat Constructor
NPixelFormat.NPixelFormat Constructor (NPixelType, NExtraChannel, int, NChannelFormat, int, int, bool)
NPixelFormat.NPixelFormat Constructor (uint)
Collapse Expand NPixelFormat Fields
NPixelFormat.Grayscale16S Field
NPixelFormat.Grayscale16U Field
NPixelFormat.Grayscale1U Field
NPixelFormat.Grayscale2U Field
NPixelFormat.Grayscale32F Field
NPixelFormat.Grayscale32S Field
NPixelFormat.Grayscale32U Field
NPixelFormat.Grayscale4U Field
NPixelFormat.Grayscale64F Field
NPixelFormat.Grayscale64S Field
NPixelFormat.Grayscale64U Field
NPixelFormat.Grayscale8S Field
NPixelFormat.Grayscale8U Field
NPixelFormat.GrayscaleA16S Field
NPixelFormat.GrayscaleA16U Field
NPixelFormat.GrayscaleA32F Field
NPixelFormat.GrayscaleA32S Field
NPixelFormat.GrayscaleA32U Field
NPixelFormat.GrayscaleA64F Field
NPixelFormat.GrayscaleA64S Field
NPixelFormat.GrayscaleA64U Field
NPixelFormat.GrayscaleA8S Field
NPixelFormat.GrayscaleA8U Field
NPixelFormat.GrayscalePA16S Field
NPixelFormat.GrayscalePA16U Field
NPixelFormat.GrayscalePA32F Field
NPixelFormat.GrayscalePA32S Field
NPixelFormat.GrayscalePA32U Field
NPixelFormat.GrayscalePA64F Field
NPixelFormat.GrayscalePA64S Field
NPixelFormat.GrayscalePA64U Field
NPixelFormat.GrayscalePA8S Field
NPixelFormat.GrayscalePA8U Field
NPixelFormat.Rgb16S Field
NPixelFormat.Rgb16U Field
NPixelFormat.Rgb32F Field
NPixelFormat.Rgb32S Field
NPixelFormat.Rgb32U Field
NPixelFormat.Rgb64F Field
NPixelFormat.Rgb64S Field
NPixelFormat.Rgb64U Field
NPixelFormat.Rgb8S Field
NPixelFormat.Rgb8U Field
NPixelFormat.Rgb8UIndexed1 Field
NPixelFormat.Rgb8UIndexed2 Field
NPixelFormat.Rgb8UIndexed4 Field
NPixelFormat.Rgb8UIndexed8 Field
NPixelFormat.RgbA16S Field
NPixelFormat.RgbA16U Field
NPixelFormat.RgbA32F Field
NPixelFormat.RgbA32S Field
NPixelFormat.RgbA32U Field
NPixelFormat.RgbA64F Field
NPixelFormat.RgbA64S Field
NPixelFormat.RgbA64U Field
NPixelFormat.RgbA8S Field
NPixelFormat.RgbA8U Field
NPixelFormat.RgbA8UIndexed1 Field
NPixelFormat.RgbA8UIndexed2 Field
NPixelFormat.RgbA8UIndexed4 Field
NPixelFormat.RgbA8UIndexed8 Field
NPixelFormat.RgbPA16S Field
NPixelFormat.RgbPA16U Field
NPixelFormat.RgbPA32F Field
NPixelFormat.RgbPA32S Field
NPixelFormat.RgbPA32U Field
NPixelFormat.RgbPA64F Field
NPixelFormat.RgbPA64S Field
NPixelFormat.RgbPA64U Field
NPixelFormat.RgbPA8S Field
NPixelFormat.RgbPA8U Field
NPixelFormat.Undefined Field
Collapse Expand NPixelFormat Methods
Collapse Expand CalcRowLongSize Method
NPixelFormat.CalcRowLongSize Method (int, uint)
NPixelFormat.CalcRowLongSize Method (int, uint, int)
Collapse Expand CalcRowNativeSize Method
NPixelFormat.CalcRowNativeSize Method (int, uint)
NPixelFormat.CalcRowNativeSize Method (int, uint, int)
Collapse Expand CalcRowSize Method
NPixelFormat.CalcRowSize Method (int, uint)
NPixelFormat.CalcRowSize Method (int, uint, int)
NPixelFormat.CanPixelTypeBeIndexed Method
Collapse Expand Equals Method
NPixelFormat.Equals Method (NPixelFormat)
NPixelFormat.Equals Method (object)
NPixelFormat.GetChannelType Method
NPixelFormat.GetHashCode Method
NPixelFormat.GetIndexed Method
NPixelFormat.GetNonIndexed Method
NPixelFormat.GetNonSeparated Method
NPixelFormat.GetPaletteSize Method
Collapse Expand GetRowLongSize Method
NPixelFormat.GetRowLongSize Method (uint)
NPixelFormat.GetRowLongSize Method (uint, int)
Collapse Expand GetRowNativeSize Method
NPixelFormat.GetRowNativeSize Method (uint)
NPixelFormat.GetRowNativeSize Method (uint, int)
Collapse Expand GetRowSize Method
NPixelFormat.GetRowSize Method (uint)
NPixelFormat.GetRowSize Method (uint, int)
NPixelFormat.GetSeparated Method
NPixelFormat.GetWithExtraChannel Method
NPixelFormat.IsPixelTypeValid Method
Collapse Expand ToString Method
NPixelFormat.ToString Method ()
NPixelFormat.ToString Method (string)
Collapse Expand NPixelFormat Operators
NPixelFormat.!= Operator
NPixelFormat.== Operator
Collapse Expand NPixelFormat Operator
NPixelFormat.NPixelFormat Operator (uint)
NPixelFormat.uint Operator
Collapse Expand NPixelFormat Properties
NPixelFormat.BitsPerChannel Property
NPixelFormat.BitsPerIndex Property
NPixelFormat.BitsPerPaletteEntry Property
NPixelFormat.BitsPerPixel Property
NPixelFormat.BitsPerValue Property
NPixelFormat.BytesPerChannel Property
NPixelFormat.BytesPerPaletteEntry Property
NPixelFormat.BytesPerPixel Property
NPixelFormat.BytesPerValue Property
NPixelFormat.ChannelCount Property
NPixelFormat.ChannelFormat Property
NPixelFormat.ExtraChannel Property
NPixelFormat.IsIndexed Property
NPixelFormat.IsSeparated Property
NPixelFormat.IsValid Property
NPixelFormat.MaxPaletteLength Property
NPixelFormat.NPixelTypeNativeType Property
NPixelFormat.NativeType Property
NPixelFormat.PixelType Property
NPixelFormat.PlaneCount Property
Collapse Expand NRgb Structure
Collapse Expand NRgb Constructor
NRgb.NRgb Constructor (byte, byte, byte)
NRgb.NRgb Constructor (byte[])
Collapse Expand NRgb Methods
NRgb.ToArray Method
Collapse Expand ToString Method
NRgb.ToString Method ()
NRgb.ToString Method (string)
Collapse Expand NRgb Properties
NRgb.Blue Property
NRgb.Green Property
NRgb.Red Property
Collapse Expand PngInfo Class
Collapse Expand PngInfo Fields
PngInfo.DefaultCompressionLevel Field
Collapse Expand PngInfo Properties
PngInfo.CompressionLevel Property
PngInfo.NativeType Property
Collapse Expand TiffInfo Class
Collapse Expand TiffInfo Properties
TiffInfo.NativeType Property
Collapse Expand Structs, Records, Enums
Neurotec.Images.Jpeg2KProfile Enumeration
Neurotec.Images.NImageRotateFlipType Enumeration
Neurotec.Images.NPixelType Enumeration
Collapse Expand Neurotec.Interop Namespace
Collapse Expand Classes
Collapse Expand NKeyValuePair_ Structure
Collapse Expand NKeyValuePair_ Fields
NKeyValuePair_.hKey Field
NKeyValuePair_.hValue Field
Collapse Expand NKeyValuePair_ Methods
NKeyValuePair_.Create Method
NKeyValuePair_.Dispose Method
NKeyValuePair_.ToStruct Method
Collapse Expand NNameStringPair_ Structure
Collapse Expand NNameStringPair_ Fields
NNameStringPair_.hKey Field
NNameStringPair_.hValue Field
Collapse Expand NNameStringPair_ Methods
NNameStringPair_.Create Method
NNameStringPair_.Dispose Method
NNameStringPair_.ToStruct Method
Collapse Expand NNameValuePair_ Structure
Collapse Expand NNameValuePair_ Fields
NNameValuePair_.hKey Field
NNameValuePair_.hValue Field
Collapse Expand NNameValuePair_ Methods
NNameValuePair_.Create Method
NNameValuePair_.Dispose Method
NNameValuePair_.ToStruct Method
Collapse Expand Neurotec.Licensing Namespace
Collapse Expand Classes
Collapse Expand NLicense Class
Collapse Expand NLicense Methods
NLicense.ActivateOnline Method
Collapse Expand Add Method
NLicense.Add Method (NBuffer)
NLicense.Add Method (byte[])
NLicense.Add Method (string)
Collapse Expand DeactivateOnline Method
NLicense.DeactivateOnline Method (string)
NLicense.DeactivateOnline Method (string, string)
NLicense.DeactivateOnlineWithId Method
Collapse Expand GenerateDeactivationId Method
NLicense.GenerateDeactivationId Method (string)
NLicense.GenerateDeactivationId Method (string, string)
Collapse Expand GenerateDeactivationIdForLicense Method
NLicense.GenerateDeactivationIdForLicense Method (string)
NLicense.GenerateDeactivationIdForLicense Method (string, string)
Collapse Expand GenerateId Method
NLicense.GenerateId Method (string)
NLicense.GenerateId Method (string, string)
NLicense.GetLicenseInfoOnline Method
NLicense.GetObtainedLicenseInfo Method
NLicense.GetObtainedLicenseInfoForComponent Method
NLicense.GetObtainedStatus Method
NLicense.IsComponentActivated Method
Collapse Expand Obtain Method
NLicense.Obtain Method (string, int, string)
NLicense.Obtain Method (string, string, string)
Collapse Expand ObtainComponents Method
NLicense.ObtainComponents Method (string, int, string)
NLicense.ObtainComponents Method (string, string, string)
NLicense.Release Method
NLicense.ReleaseComponents Method
Collapse Expand NLicense Properties
NLicense.NativeType Property
Collapse Expand NLicenseInfo Class
Collapse Expand NLicenseInfo Methods
NLicenseInfo.GetLicenses Method
Collapse Expand NLicenseInfo Properties
NLicenseInfo.DistributorId Property
NLicenseInfo.LicenseId Property
NLicenseInfo.NativeType Property
NLicenseInfo.SequenceNumber Property
NLicenseInfo.SourceType Property
NLicenseInfo.Status Property
NLicenseInfo.Type Property
Collapse Expand NLicenseManager Class
Collapse Expand NLicenseManager Methods
NLicenseManager.FindFirstDongle Method
NLicenseManager.FindNextDongle Method
NLicenseManager.GenerateLicense Method
NLicenseManager.GenerateLicenseEx Method
NLicenseManager.GenerateSerial Method
NLicenseManager.GenerateSerialEx Method
NLicenseManager.GetDongles Method
NLicenseManager.GetLicenseData Method
NLicenseManager.GetLicenseDataEx Method
Collapse Expand GetLongProductName Method
NLicenseManager.GetLongProductName Method (NLicenseProductInfo)
NLicenseManager.GetLongProductName Method (uint, NLicenseType)
NLicenseManager.GetProductIds Method
Collapse Expand GetShortProductName Method
NLicenseManager.GetShortProductName Method (NLicenseProductInfo)
NLicenseManager.GetShortProductName Method (uint, NLicenseType)
NLicenseManager.GetUpdateTicketInfo Method
NLicenseManager.IsLicenseTypeSupported Method
Collapse Expand NLicenseManager Properties
NLicenseManager.ClientId Property
NLicenseManager.NLicenseTypeNativeType Property
NLicenseManager.NativeType Property
NLicenseManager.ProxyHost Property
NLicenseManager.ProxyPort Property
NLicenseManager.TrialMode Property
NLicenseManager.UseHttps Property
NLicenseManager.WritableStoragePath Property
Collapse Expand NLicenseProductInfo Class
Collapse Expand NLicenseProductInfo Properties
NLicenseProductInfo.Id Property
NLicenseProductInfo.LicenseCount Property
NLicenseProductInfo.LicenseType Property
NLicenseProductInfo.NativeType Property
NLicenseProductInfo.OSFamily Property
NLicenseProductInfo.Parameters Property
Collapse Expand NLicensing Class
Collapse Expand NLicensing Fields
NLicensing.DllName Field
Collapse Expand NLicensing Properties
NLicensing.NativeModule Property
Collapse Expand NLicensingService Class
Collapse Expand NLicensingService Methods
NLicensingService.GetBinPath Method
NLicensingService.GetConfPath Method
NLicensingService.GetStatus Method
Collapse Expand Install Method
NLicensingService.Install Method (string)
NLicensingService.Install Method (string, string)
NLicensingService.IsTrial Method
NLicensingService.Start Method
NLicensingService.Stop Method
NLicensingService.Uninstall Method
Collapse Expand NLicensingService Properties
NLicensingService.NLicensingServiceStatusNativeType Property
NLicensingService.NativeType Property
Collapse Expand Structs, Records, Enums
Neurotec.Licensing.NLicenseInfoSourceType Enumeration
Neurotec.Licensing.NLicenseInfoStatus Enumeration
Neurotec.Licensing.NLicenseInfoType Enumeration
Neurotec.Licensing.NLicenseType Enumeration
Neurotec.Licensing.NLicensingServiceStatus Enumeration
Collapse Expand Neurotec.Media Namespace
Collapse Expand Classes
Collapse Expand NMedia Class
Collapse Expand NMedia Fields
NMedia.DllName Field
Collapse Expand NMedia Properties
NMedia.NativeModule Property
Collapse Expand NMediaFormat Class
Collapse Expand NMediaFormat Methods
Collapse Expand Equals Method
NMediaFormat.Equals Method (NMediaFormat)
NMediaFormat.Equals Method (object)
NMediaFormat.GetHashCode Method
NMediaFormat.IsCompatibleWith Method
Collapse Expand NMediaFormat Operators
NMediaFormat.!= Operator
NMediaFormat.== Operator
Collapse Expand NMediaFormat Properties
NMediaFormat.MediaSubtype Property
NMediaFormat.MediaType Property
NMediaFormat.NativeType Property
Collapse Expand NMediaReader Class
Collapse Expand NMediaReader Constructor
NMediaReader.NMediaReader Constructor (NMediaSource, NMediaType, bool)
NMediaReader.NMediaReader Constructor (NMediaSource, NMediaType, bool, uint)
NMediaReader.NMediaReader Constructor (Uri, NMediaType, bool)
NMediaReader.NMediaReader Constructor (Uri, NMediaType, bool, uint)
NMediaReader.NMediaReader Constructor (string, NMediaType, bool)
NMediaReader.NMediaReader Constructor (string, NMediaType, bool, bool)
NMediaReader.NMediaReader Constructor (string, NMediaType, bool, bool, uint)
NMediaReader.NMediaReader Constructor (string, NMediaType, bool, uint)
Collapse Expand NMediaReader Methods
NMediaReader.Pause Method
Collapse Expand ReadAudioSample Method
NMediaReader.ReadAudioSample Method ()
NMediaReader.ReadAudioSample Method (out TimeSpan, out TimeSpan)
Collapse Expand ReadVideoSample Method
NMediaReader.ReadVideoSample Method ()
NMediaReader.ReadVideoSample Method (out TimeSpan, out TimeSpan)
NMediaReader.ReadVideoSampleData Method
NMediaReader.Start Method
NMediaReader.Stop Method
Collapse Expand NMediaReader Properties
NMediaReader.IsLive Property
NMediaReader.Length Property
NMediaReader.NativeType Property
NMediaReader.Position Property
NMediaReader.Source Property
NMediaReader.State Property
Collapse Expand NMediaSource Class
Collapse Expand NMediaSource Fields
NMediaSource.FlagAllowDuplicateDevices Field
NMediaSource.FlagDoNotUseDirectShow Field
NMediaSource.FlagDoNotUseVlc Field
NMediaSource.FlagDoNotUseWindowsMedia Field
NMediaSource.FlagDoNotUseWindowsMediaFoundation Field
NMediaSource.FlagPreferDirectShow Field
NMediaSource.FlagPreferVlc Field
NMediaSource.FlagPreferWindowsMedia Field
NMediaSource.FlagPreferWindowsMediaFoundation Field
Collapse Expand NMediaSource Methods
Collapse Expand EnumDevices Method
NMediaSource.EnumDevices Method (NMediaType)
NMediaSource.EnumDevices Method (NMediaType, uint)
Collapse Expand Equals Method
NMediaSource.Equals Method (NMediaSource)
NMediaSource.Equals Method (object)
Collapse Expand FromFile Method
NMediaSource.FromFile Method (string)
NMediaSource.FromFile Method (string, uint)
Collapse Expand FromUrl Method
NMediaSource.FromUrl Method (Uri)
NMediaSource.FromUrl Method (Uri, uint)
NMediaSource.FromUrl Method (string)
NMediaSource.FromUrl Method (string, uint)
NMediaSource.GetCurrentFormat Method
NMediaSource.GetFormats Method
NMediaSource.GetHashCode Method
NMediaSource.SetCurrentFormat Method
Collapse Expand NMediaSource Operators
NMediaSource.!= Operator
NMediaSource.== Operator
Collapse Expand NMediaSource Properties
NMediaSource.DisplayName Property
NMediaSource.Id Property
NMediaSource.MediaType Property
NMediaSource.NativeType Property
Collapse Expand NMediaTypes Class
Collapse Expand NMediaTypes Methods
NMediaTypes.IsMediaTypeValid Method
NMediaTypes.IsMediaTypeValidSingle Method
NMediaTypes.IsVideoInterlaceModeValid Method
Collapse Expand NMediaTypes Properties
NMediaTypes.NMediaStateNativeType Property
NMediaTypes.NMediaTypeNativeType Property
NMediaTypes.NVideoInterlaceModeNativeType Property
NMediaTypes.NativeType Property
Collapse Expand NVideoFormat Class
NVideoFormat.NVideoFormat Constructor
Collapse Expand NVideoFormat Fields
NVideoFormat.AI44 Field
NVideoFormat.Argb32 Field
NVideoFormat.Ayuv Field
NVideoFormat.DV25 Field
NVideoFormat.DV50 Field
NVideoFormat.DX50 Field
NVideoFormat.Dvc Field
NVideoFormat.Dvh1 Field
NVideoFormat.Dvhd Field
NVideoFormat.Dvsd Field
NVideoFormat.Dvsl Field
NVideoFormat.H264 Field
NVideoFormat.I420 Field
NVideoFormat.Iyuv Field
NVideoFormat.L16 Field
NVideoFormat.L8 Field
NVideoFormat.M4S2 Field
NVideoFormat.MP43 Field
NVideoFormat.MP4S Field
NVideoFormat.MP4V Field
NVideoFormat.Mjpg Field
NVideoFormat.Mpg1 Field
NVideoFormat.Mss1 Field
NVideoFormat.Mss2 Field
NVideoFormat.NV11 Field
NVideoFormat.NV12 Field
NVideoFormat.NV21 Field
NVideoFormat.P010 Field
NVideoFormat.P016 Field
NVideoFormat.P210 Field
NVideoFormat.P216 Field
NVideoFormat.Rgb24 Field
NVideoFormat.Rgb32 Field
NVideoFormat.Rgb555 Field
NVideoFormat.Rgb565 Field
NVideoFormat.Rgb8 Field
NVideoFormat.Unknown Field
NVideoFormat.Uyvy Field
NVideoFormat.V210 Field
NVideoFormat.V216 Field
NVideoFormat.V410 Field
NVideoFormat.Wmv1 Field
NVideoFormat.Wmv2 Field
NVideoFormat.Wmv3 Field
NVideoFormat.Wvc1 Field
NVideoFormat.Y210 Field
NVideoFormat.Y216 Field
NVideoFormat.Y410 Field
NVideoFormat.Y416 Field
NVideoFormat.Y41P Field
NVideoFormat.Y41T Field
NVideoFormat.Y42T Field
NVideoFormat.YV12 Field
NVideoFormat.Yuy2 Field
NVideoFormat.Yvu9 Field
NVideoFormat.Yvyu Field
Collapse Expand NVideoFormat Methods
Collapse Expand MediaSubtypeToString Method
NVideoFormat.MediaSubtypeToString Method (int)
NVideoFormat.MediaSubtypeToString Method (int, string)
Collapse Expand NVideoFormat Properties
NVideoFormat.FrameRate Property
NVideoFormat.Height Property
NVideoFormat.InterlaceMode Property
NVideoFormat.LongStride Property
NVideoFormat.NativeStide Property
NVideoFormat.NativeType Property
NVideoFormat.PixelAspectRatio Property
NVideoFormat.Stride Property
NVideoFormat.Width Property
Collapse Expand Structs, Records, Enums
Neurotec.Media.NMediaState Enumeration
Neurotec.Media.NMediaType Enumeration
Neurotec.Media.NVideoInterlaceMode Enumeration
Collapse Expand Neurotec.Plugins Namespace
Collapse Expand Classes
Collapse Expand NPlugin Class
Collapse Expand NPlugin Methods
NPlugin.Disable Method
NPlugin.Enable Method
NPlugin.Plug Method
NPlugin.Unplug Method
Collapse Expand NPlugin Properties
NPlugin.Error Property
NPlugin.FileName Property
NPlugin.LoadTime Property
NPlugin.Module Property
NPlugin.NPluginStateNativeType Property
NPlugin.NativeType Property
NPlugin.Owner Property
NPlugin.PlugTime Property
NPlugin.SelectedInterfaceVersion Property
NPlugin.State Property
Collapse Expand NPluginManager Class
Collapse Expand NPluginManager Classes
NPluginManager.DisabledPluginCollection Class
Collapse Expand NPluginManager.PluginCollection Class
Collapse Expand PluginCollection Methods
Collapse Expand Add Method
NPluginManager.PluginCollection.Add Method (NPluginModule, string)
NPluginManager.PluginCollection.Add Method (string)
NPluginManager.PluginCollection.Contains Method
NPluginManager.PluginCollection.IndexOf Method
NPluginManager.PluginCollection.this Indexer
Collapse Expand NPluginManager Methods
NPluginManager.EnsurePluginSearchPerformed Method
NPluginManager.GetInstances Method
NPluginManager.GetInterfaceVersions Method
NPluginManager.PlugAll Method
NPluginManager.Refresh Method
NPluginManager.UnplugAll Method
Collapse Expand NPluginManager Properties
NPluginManager.AllowsUnplug Property
NPluginManager.DisabledPlugins Property
NPluginManager.InterfaceType Property
NPluginManager.NativeType Property
NPluginManager.PluginSearchPath Property
NPluginManager.Plugins Property
Collapse Expand NPluginManagerPluginEventArgs Class
NPluginManagerPluginEventArgs.NPluginManagerPluginEventArgs Constructor
Collapse Expand NPluginManagerPluginEventArgs Properties
NPluginManagerPluginEventArgs.Plugin Property
Collapse Expand NPluginModule Class
NPluginModule.NPluginModule Constructor
Collapse Expand NPluginModule Methods
NPluginModule.GetInterfaceVersions Method
Collapse Expand NPluginModule Properties
NPluginModule.IncompatiblePlugins Property
NPluginModule.InterfaceType Property
NPluginModule.NativeType Property
NPluginModule.PluginName Property
NPluginModule.Priority Property
Collapse Expand Structs, Records, Enums
Neurotec.Plugins.NPluginState Enumeration
Collapse Expand Neurotec.Plugins.ComponentModel Namespace
Collapse Expand Classes
Collapse Expand NPluginEventDescriptor Class
Collapse Expand NPluginEventDescriptor Properties
NPluginEventDescriptor.NativeType Property
Collapse Expand NPluginMethodDescriptor Class
Collapse Expand NPluginMethodDescriptor Properties
NPluginMethodDescriptor.NativeType Property
Collapse Expand NPluginPropertyDescriptor Class
Collapse Expand NPluginPropertyDescriptor Properties
NPluginPropertyDescriptor.NativeType Property
Collapse Expand Neurotec.Reflection Namespace
Collapse Expand Classes
Collapse Expand NArrayCollectionInfo Class
Collapse Expand NArrayCollectionInfo Classes
NArrayCollectionInfo.ItemStdValueCollection Class
Collapse Expand NArrayCollectionInfo Properties
NArrayCollectionInfo.AddMethod Property
NArrayCollectionInfo.AddRangeMethod Property
NArrayCollectionInfo.BaseCollection Property
NArrayCollectionInfo.ClearMethod Property
NArrayCollectionInfo.GetCountMethod Property
NArrayCollectionInfo.GetMethod Property
NArrayCollectionInfo.IndexOfMethod Property
NArrayCollectionInfo.InsertMethod Property
NArrayCollectionInfo.InsertRangeMethod Property
NArrayCollectionInfo.ItemAttributes Property
NArrayCollectionInfo.ItemFormat Property
NArrayCollectionInfo.ItemMaxValue Property
NArrayCollectionInfo.ItemMinValue Property
NArrayCollectionInfo.ItemStdValues Property
NArrayCollectionInfo.ItemType Property
NArrayCollectionInfo.NativeType Property
NArrayCollectionInfo.RemoveAtMethod Property
NArrayCollectionInfo.RemoveMethod Property
NArrayCollectionInfo.RemoveRangeMethod Property
NArrayCollectionInfo.SetMethod Property
NArrayCollectionInfo.ToArrayMethod Property
Collapse Expand NCollectionInfo Class
Collapse Expand NCollectionInfo Classes
NCollectionInfo.ItemStdValueCollection Class
Collapse Expand NCollectionInfo Properties
NCollectionInfo.AddCollectionChangedCallbackMethod Property
NCollectionInfo.AddCollectionChangedMethod Property
NCollectionInfo.AddMethod Property
NCollectionInfo.AddRangeMethod Property
NCollectionInfo.ClearMethod Property
NCollectionInfo.GetCapacityMethod Property
NCollectionInfo.GetCountMethod Property
NCollectionInfo.GetMethod Property
NCollectionInfo.IndexOfMethod Property
NCollectionInfo.InsertMethod Property
NCollectionInfo.InsertRangeMethod Property
NCollectionInfo.ItemAttributes Property
NCollectionInfo.ItemFormat Property
NCollectionInfo.ItemMaxValue Property
NCollectionInfo.ItemMinValue Property
NCollectionInfo.ItemStdValues Property
NCollectionInfo.ItemType Property
NCollectionInfo.NativeType Property
NCollectionInfo.RemoveAtMethod Property
NCollectionInfo.RemoveCollectionChangedCallbackMethod Property
NCollectionInfo.RemoveCollectionChangedMethod Property
NCollectionInfo.RemoveMethod Property
NCollectionInfo.RemoveRangeMethod Property
NCollectionInfo.SetCapacityMethod Property
NCollectionInfo.SetMethod Property
NCollectionInfo.ToArrayMethod Property
Collapse Expand NConstantInfo Class
Collapse Expand NConstantInfo Properties
NConstantInfo.ConstantType Property
NConstantInfo.NativeType Property
NConstantInfo.Value Property
Collapse Expand NDictionaryInfo Class
Collapse Expand NDictionaryInfo Classes
NDictionaryInfo.KeyStdValueCollection Class
NDictionaryInfo.ValueStdValueCollection Class
Collapse Expand NDictionaryInfo Properties
NDictionaryInfo.AddCollectionChangedCallbackMethod Property
NDictionaryInfo.AddCollectionChangedMethod Property
NDictionaryInfo.AddMethod Property
NDictionaryInfo.AddPairMethod Property
NDictionaryInfo.ClearMethod Property
NDictionaryInfo.ContainsMethod Property
NDictionaryInfo.GetAtMethod Property
NDictionaryInfo.GetCountMethod Property
NDictionaryInfo.GetKeyMethod Property
NDictionaryInfo.GetMethod Property
NDictionaryInfo.GetValueMethod Property
NDictionaryInfo.ItemAttributes Property
NDictionaryInfo.ItemType Property
NDictionaryInfo.KeyAttributes Property
NDictionaryInfo.KeyFormat Property
NDictionaryInfo.KeyMaxValue Property
NDictionaryInfo.KeyMinValue Property
NDictionaryInfo.KeyStdValues Property
NDictionaryInfo.KeyType Property
NDictionaryInfo.NativeType Property
NDictionaryInfo.RemoveAtMethod Property
NDictionaryInfo.RemoveCollectionChangedCallbackMethod Property
NDictionaryInfo.RemoveCollectionChangedMethod Property
NDictionaryInfo.RemoveMethod Property
NDictionaryInfo.SetMethod Property
NDictionaryInfo.ToArrayMethod Property
NDictionaryInfo.ToKeyArrayMethod Property
NDictionaryInfo.ToValueArrayMethod Property
NDictionaryInfo.TryGetMethod Property
NDictionaryInfo.ValueAttributes Property
NDictionaryInfo.ValueFormat Property
NDictionaryInfo.ValueMaxValue Property
NDictionaryInfo.ValueMinValue Property
NDictionaryInfo.ValueStdValues Property
NDictionaryInfo.ValueType Property
Collapse Expand NEnumConstantInfo Class
Collapse Expand NEnumConstantInfo Properties
NEnumConstantInfo.NativeType Property
NEnumConstantInfo.Value Property
Collapse Expand NEventInfo Class
Collapse Expand NEventInfo Methods
NEventInfo.AddHandler Method
NEventInfo.RemoveHandler Method
Collapse Expand NEventInfo Properties
NEventInfo.AddCallbackMethod Property
NEventInfo.AddMethod Property
NEventInfo.EventType Property
NEventInfo.NativeType Property
NEventInfo.RemoveCallbackMethod Property
NEventInfo.RemoveMethod Property
Collapse Expand NMemberInfo Class
Collapse Expand NMemberInfo Properties
NMemberInfo.Attributes Property
NMemberInfo.DeclaringType Property
NMemberInfo.Name Property
NMemberInfo.NativeType Property
Collapse Expand NMethodInfo Class
Collapse Expand NMethodInfo Classes
NMethodInfo.ParameterCollection Class
Collapse Expand NMethodInfo Methods
Collapse Expand Invoke Method
NMethodInfo.Invoke Method (NObject, NPropertyBag)
NMethodInfo.Invoke Method (NObject, object[])
NMethodInfo.Invoke Method (NObject, string)
Collapse Expand NMethodInfo Properties
NMethodInfo.NativeName Property
NMethodInfo.NativeType Property
NMethodInfo.Parameters Property
NMethodInfo.ReturnParameter Property
Collapse Expand NObjectPartInfo Class
Collapse Expand NObjectPartInfo Classes
NObjectPartInfo.DeclaredConstantCollection Class
NObjectPartInfo.DeclaredEventCollection Class
NObjectPartInfo.DeclaredMethodCollection Class
NObjectPartInfo.DeclaredPropertyCollection Class
Collapse Expand NObjectPartInfo Methods
NObjectPartInfo.GetDeclaredConstant Method
NObjectPartInfo.GetDeclaredEvent Method
NObjectPartInfo.GetDeclaredMethod Method
NObjectPartInfo.GetDeclaredMethods Method
NObjectPartInfo.GetDeclaredProperty Method
NObjectPartInfo.GetObjectPart Method
Collapse Expand NObjectPartInfo Properties
NObjectPartInfo.DeclaredConstants Property
NObjectPartInfo.DeclaredEvents Property
NObjectPartInfo.DeclaredMethods Property
NObjectPartInfo.DeclaredProperties Property
NObjectPartInfo.NativeType Property
NObjectPartInfo.PropertyName Property
Collapse Expand NParameterInfo Class
Collapse Expand NParameterInfo Classes
NParameterInfo.StdValueCollection Class
Collapse Expand NParameterInfo Properties
NParameterInfo.Attributes Property
NParameterInfo.DefaultValue Property
NParameterInfo.Format Property
NParameterInfo.MaxValue Property
NParameterInfo.MinValue Property
NParameterInfo.Name Property
NParameterInfo.NativeType Property
NParameterInfo.ParameterType Property
NParameterInfo.StdValues Property
Collapse Expand NPropertyInfo Class
Collapse Expand NPropertyInfo Classes
NPropertyInfo.StdValueCollection Class
Collapse Expand NPropertyInfo Methods
NPropertyInfo.CanResetValue Method
NPropertyInfo.GetValue Method
NPropertyInfo.ResetValue Method
NPropertyInfo.SetValue Method
Collapse Expand NPropertyInfo Properties
NPropertyInfo.DefaultValue Property
NPropertyInfo.Format Property
NPropertyInfo.GetMethod Property
NPropertyInfo.MaxValue Property
NPropertyInfo.MinValue Property
NPropertyInfo.NativeType Property
NPropertyInfo.PropertyType Property
NPropertyInfo.SetMethod Property
NPropertyInfo.StdValues Property
Collapse Expand Neurotec.Surveillance Namespace
Collapse Expand Classes
Collapse Expand NClothingDetails Class
Collapse Expand NClothingDetails Classes
NClothingDetails.ValueCollection Class
Collapse Expand NClothingDetails Methods
NClothingDetails.GetKnownValues Method
Collapse Expand NClothingDetails Properties
NClothingDetails.Gender Property
NClothingDetails.GenderConfidence Property
NClothingDetails.NativeType Property
NClothingDetails.Values Property
Collapse Expand NLicensePlate Class
Collapse Expand NLicensePlate Properties
NLicensePlate.BoundingBox Property
NLicensePlate.CharacterHeight Property
NLicensePlate.DetectionConfidence Property
NLicensePlate.FrameIndex Property
NLicensePlate.NativeType Property
NLicensePlate.OcrConfidence Property
NLicensePlate.Origin Property
NLicensePlate.Rectangle Property
NLicensePlate.Region Property
NLicensePlate.Rotation Property
NLicensePlate.Type Property
NLicensePlate.Value Property
Collapse Expand NLicensePlateDetails Class
Collapse Expand NLicensePlateDetails Classes
NLicensePlateDetails.BestLicensePlateCollection Class
NLicensePlateDetails.CurrentLicensePlateCollection Class
Collapse Expand NLicensePlateDetails Properties
NLicensePlateDetails.Best Property
NLicensePlateDetails.Current Property
NLicensePlateDetails.NativeType Property
Collapse Expand NNameConfidencePair Structure
Collapse Expand NNameConfidencePair Properties
NNameConfidencePair.Confidence Property
NNameConfidencePair.Name Property
NNameConfidencePair.NativeType Property
Collapse Expand NSurveillance Class
NSurveillance.NSurveillance Constructor
Collapse Expand NSurveillance Classes
NSurveillance.SourceCollection Class
Collapse Expand NSurveillance Fields
NSurveillance.DllName Field
Collapse Expand NSurveillance Methods
NSurveillance.AddEvent Method
Collapse Expand AddTemplate Method
NSurveillance.AddTemplate Method (string, NBuffer)
NSurveillance.AddTemplate Method (string, byte[])
NSurveillance.GetTemplateIds Method
Collapse Expand OptimizeModelsAsync Method
NSurveillance.OptimizeModelsAsync Method (NSurveillanceModalityType, NSurveillanceProgressCallback)
NSurveillance.OptimizeModelsAsync Method (NSurveillanceModalityType, bool, NGpuIndex, NSurveillanceProgressCallback)
NSurveillance.RemoveAllTemplates Method
NSurveillance.RemoveEvent Method
NSurveillance.RemoveTemplate Method
NSurveillance.Start Method
NSurveillance.StartAsync Method
NSurveillance.StartSource Method
NSurveillance.StartSourceAsync Method
NSurveillance.Stop Method
NSurveillance.StopAsync Method
NSurveillance.StopSource Method
NSurveillance.StopSourceAsync Method
Collapse Expand NSurveillance Properties
NSurveillance.DetectorScaling Property
NSurveillance.DeviceManager Property
NSurveillance.EnableGpuLowMemoryMode Property
NSurveillance.FacesConfidenceThreshold Property
NSurveillance.FacesDetectMasks Property
NSurveillance.FacesMinimalInterOcularDistance Property
NSurveillance.FacesQualityThreshold Property
NSurveillance.FacesTemplateSize Property
NSurveillance.FacesWithDetailsOnly Property
NSurveillance.GPUIndices Property
NSurveillance.IsRunning Property
NSurveillance.LicensePlateDetectorScaling Property
NSurveillance.LicensePlateDetectorThreshold Property
NSurveillance.LicensePlateEnableTemplateMatching Property
NSurveillance.LicensePlateInterpretOAsZero Property
NSurveillance.LicensePlateMinimalCharacterCount Property
NSurveillance.LicensePlateOcrThreshold Property
NSurveillance.LicensePlatePriorityCountries Property
NSurveillance.MaskDetectionThreshold Property
NSurveillance.MatchingMaximalResultCount Property
NSurveillance.MatchingThreshold Property
NSurveillance.MatchingWithDetails Property
NSurveillance.NSurveillanceEventCallbackNativeType Property
NSurveillance.NSurveillanceEventTypeNativeType Property
NSurveillance.NativeModule Property
NSurveillance.NativeType Property
NSurveillance.Sources Property
NSurveillance.UseGPU Property
NSurveillance.VehicleHumanDetectorThreshold Property
Collapse Expand NSurveillance Events
NSurveillance.Any Event
NSurveillance.FacesDetected Event
NSurveillance.ImageCaptured Event
NSurveillance.IsRunningChanged Event
NSurveillance.SubjectAppeared Event
NSurveillance.SubjectDisappeared Event
NSurveillance.SubjectMerged Event
NSurveillance.SubjectSplit Event
NSurveillance.SubjectTrack Event
Collapse Expand NSurveillanceDetectionDetails Class
NSurveillanceDetectionDetails.NSurveillanceDetectionDetails Constructor
Collapse Expand NSurveillanceDetectionDetails Properties
NSurveillanceDetectionDetails.ClothingDetails Property
NSurveillanceDetectionDetails.DetectionConfidence Property
NSurveillanceDetectionDetails.Face Property
NSurveillanceDetectionDetails.FaceRectangle Property
NSurveillanceDetectionDetails.LicensePlateDetails Property
NSurveillanceDetectionDetails.NativeType Property
NSurveillanceDetectionDetails.ObjectColor Property
NSurveillanceDetectionDetails.ObjectType Property
NSurveillanceDetectionDetails.Rectangle Property
NSurveillanceDetectionDetails.SubjectType Property
NSurveillanceDetectionDetails.VehicleDetails Property
Collapse Expand NSurveillanceDetectionResult Class
Collapse Expand NSurveillanceDetectionResult Classes
NSurveillanceDetectionResult.DetailsCollection Class
Collapse Expand NSurveillanceDetectionResult Properties
NSurveillanceDetectionResult.Details Property
NSurveillanceDetectionResult.Image Property
NSurveillanceDetectionResult.ModalityType Property
NSurveillanceDetectionResult.NativeType Property
Collapse Expand NSurveillanceEngine Class
NSurveillanceEngine.NSurveillanceEngine Constructor
Collapse Expand NSurveillanceEngine Methods
NSurveillanceEngine.Detect Method
NSurveillanceEngine.DetectAsync Method
NSurveillanceEngine.DetectWithParameters Method
NSurveillanceEngine.DetectWithParametersAsync Method
NSurveillanceEngine.Initialize Method
Collapse Expand NSurveillanceEngine Properties
NSurveillanceEngine.DetectorScaling Property
NSurveillanceEngine.EnableGpuLowMemoryMode Property
NSurveillanceEngine.FacesConfidenceThreshold Property
NSurveillanceEngine.FacesDetectMasks Property
NSurveillanceEngine.FacesMinimalInterOcularDistance Property
NSurveillanceEngine.FacesQualityThreshold Property
NSurveillanceEngine.FacesTemplateSize Property
NSurveillanceEngine.GPUIndices Property
NSurveillanceEngine.LicensePlateDetectorScaling Property
NSurveillanceEngine.LicensePlateDetectorThreshold Property
NSurveillanceEngine.LicensePlateEnableTemplateMatching Property
NSurveillanceEngine.LicensePlateInterpretOAsZero Property
NSurveillanceEngine.LicensePlateMinimalCharacterCount Property
NSurveillanceEngine.LicensePlateOcrThreshold Property
NSurveillanceEngine.LicensePlatePriorityCountries Property
NSurveillanceEngine.ModalityType Property
NSurveillanceEngine.NativeType Property
NSurveillanceEngine.ThreadCount Property
NSurveillanceEngine.UseGPU Property
NSurveillanceEngine.VehicleHumanDetectorThreshold Property
Collapse Expand NSurveillanceEventArgs Class
NSurveillanceEventArgs.NSurveillanceEventArgs Constructor
Collapse Expand NSurveillanceEventArgs Properties
NSurveillanceEventArgs.EventDetailsArray Property
NSurveillanceEventArgs.EventType Property
Collapse Expand NSurveillanceEventDetails Class
Collapse Expand NSurveillanceEventDetails Classes
NSurveillanceEventDetails.BestMatchCollection Class
NSurveillanceEventDetails.CurrentMatchCollection Class
Collapse Expand NSurveillanceEventDetails Methods
NSurveillanceEventDetails.GetAttribtues Method
NSurveillanceEventDetails.GetDetectedFaces Method
NSurveillanceEventDetails.GetFace Method
NSurveillanceEventDetails.GetOriginalImage Method
NSurveillanceEventDetails.GetSubjectTemplate Method
NSurveillanceEventDetails.GetVideoSample Method
Collapse Expand NSurveillanceEventDetails Properties
NSurveillanceEventDetails.Attributes Property
NSurveillanceEventDetails.AttributesContainsDetails Property
NSurveillanceEventDetails.BestDetails Property
NSurveillanceEventDetails.BestMatches Property
NSurveillanceEventDetails.CurrentMatches Property
NSurveillanceEventDetails.Error Property
NSurveillanceEventDetails.Face Property
NSurveillanceEventDetails.FaceConfidence Property
NSurveillanceEventDetails.FrameIndex Property
NSurveillanceEventDetails.MergedSubject Property
NSurveillanceEventDetails.ModalityType Property
NSurveillanceEventDetails.NativeType Property
NSurveillanceEventDetails.OriginalImage Property
NSurveillanceEventDetails.Owner Property
NSurveillanceEventDetails.Rectangle Property
NSurveillanceEventDetails.SplitFromSubject Property
NSurveillanceEventDetails.SubjectType Property
NSurveillanceEventDetails.Template Property
NSurveillanceEventDetails.TimeStamp Property
NSurveillanceEventDetails.TraceIndex Property
NSurveillanceEventDetails.VideoTimeStamp Property
Collapse Expand NSurveillanceObjectColorDetails Structure
Collapse Expand NSurveillanceObjectColorDetails Properties
NSurveillanceObjectColorDetails.BlackColorConfidence Property
NSurveillanceObjectColorDetails.BlueColorConfidence Property
NSurveillanceObjectColorDetails.BrownColorConfidence Property
NSurveillanceObjectColorDetails.Color Property
NSurveillanceObjectColorDetails.GrayColorConfidence Property
NSurveillanceObjectColorDetails.GreenColorConfidence Property
NSurveillanceObjectColorDetails.OrangeColorConfidence Property
NSurveillanceObjectColorDetails.RedColorConfidence Property
NSurveillanceObjectColorDetails.SilverColorConfidence Property
NSurveillanceObjectColorDetails.WhiteColorConfidence Property
NSurveillanceObjectColorDetails.YellowColorConfidence Property
Collapse Expand NSurveillanceObjectDirectionDetails Structure
Collapse Expand NSurveillanceObjectDirectionDetails Properties
NSurveillanceObjectDirectionDetails.Direction Property
NSurveillanceObjectDirectionDetails.EastConfidence Property
NSurveillanceObjectDirectionDetails.NorthConfidence Property
NSurveillanceObjectDirectionDetails.NorthEastConfidence Property
NSurveillanceObjectDirectionDetails.NorthWestConfidence Property
NSurveillanceObjectDirectionDetails.SouthConfidence Property
NSurveillanceObjectDirectionDetails.SouthEastConfidence Property
NSurveillanceObjectDirectionDetails.SouthWestConfidence Property
NSurveillanceObjectDirectionDetails.WestConfidence Property
Collapse Expand NSurveillanceObjectTypeDetails Structure
Collapse Expand NSurveillanceObjectTypeDetails Properties
NSurveillanceObjectTypeDetails.BikeConfidence Property
NSurveillanceObjectTypeDetails.BusConfidence Property
NSurveillanceObjectTypeDetails.CarConfidence Property
NSurveillanceObjectTypeDetails.PersonConfidence Property
NSurveillanceObjectTypeDetails.TruckConfidence Property
NSurveillanceObjectTypeDetails.Type Property
NSurveillanceProgressEventArgs Class
Collapse Expand NSurveillanceSource Class
Collapse Expand NSurveillanceSource Constructor
NSurveillanceSource.NSurveillanceSource Constructor ()
NSurveillanceSource.NSurveillanceSource Constructor (NSurveillanceModalityType, NCamera)
NSurveillanceSource.NSurveillanceSource Constructor (NSurveillanceModalityType, NMediaReader)
Collapse Expand NSurveillanceSource Methods
NSurveillanceSource.GetCurrentFormat Method
NSurveillanceSource.GetFormats Method
NSurveillanceSource.SetCurrentFormat Method
Collapse Expand NSurveillanceSource Properties
NSurveillanceSource.Camera Property
NSurveillanceSource.Error Property
NSurveillanceSource.Length Property
NSurveillanceSource.ModalityType Property
NSurveillanceSource.NativeType Property
NSurveillanceSource.Owner Property
NSurveillanceSource.Position Property
NSurveillanceSource.RegionOfInterest Property
NSurveillanceSource.State Property
NSurveillanceSource.Type Property
NSurveillanceSource.Video Property
NSurveillanceSource.Warning Property
Collapse Expand NSurveillanceSource Events
NSurveillanceSource.IsCapturingChanged Event
Collapse Expand NTrackingDetails Class
Collapse Expand NTrackingDetails Classes
NTrackingDetails.LicensePlateCollection Class
NTrackingDetails.MatchResultCollection Class
Collapse Expand NTrackingDetails Properties
NTrackingDetails.Attributes Property
NTrackingDetails.AttributesContainsDetails Property
NTrackingDetails.FrameIndex Property
NTrackingDetails.LicensePlates Property
NTrackingDetails.MatchResults Property
NTrackingDetails.NativeType Property
NTrackingDetails.Rectangle Property
NTrackingDetails.SubjectType Property
NTrackingDetails.TimeStamp Property
Collapse Expand NVehicleDetails Class
Collapse Expand NVehicleDetails Classes
NVehicleDetails.ModelCollection Class
NVehicleDetails.TagCollection Class
Collapse Expand NVehicleDetails Methods
NVehicleDetails.GetKnownMakes Method
Collapse Expand GetKnownModels Method
NVehicleDetails.GetKnownModels Method ()
NVehicleDetails.GetKnownModels Method (string)
NVehicleDetails.GetKnownTags Method
Collapse Expand NVehicleDetails Properties
NVehicleDetails.Models Property
NVehicleDetails.NVehicleOrientationNativeType Property
NVehicleDetails.NativeType Property
NVehicleDetails.Orientation Property
NVehicleDetails.OrientationAngle Property
NVehicleDetails.OrientationConfidence Property
NVehicleDetails.Tags Property
Collapse Expand NsedMatchResult Class
Collapse Expand NsedMatchResult Properties
NsedMatchResult.Id Property
NsedMatchResult.MatchingDetails Property
NsedMatchResult.NativeType Property
NsedMatchResult.Score Property
Collapse Expand Structs, Records, Enums
Neurotec.Surveillance.NDetectorScaleCount Enumeration
Neurotec.Surveillance.NGpuIndex Enumeration
Neurotec.Surveillance.NSurveillanceEventType Enumeration
Neurotec.Surveillance.NSurveillanceModalityType Enumeration
Neurotec.Surveillance.NSurveillanceObjectColor Enumeration
Neurotec.Surveillance.NSurveillanceObjectDirection Enumeration
Neurotec.Surveillance.NSurveillanceObjectType Enumeration
Neurotec.Surveillance.NSurveillanceSourceType Enumeration
Neurotec.Surveillance.NVehicleOrientation Enumeration
Collapse Expand Neurotec.Surveillance.Encoding Namespace
Collapse Expand Classes
Collapse Expand NGpuJpegEncoder Class
Collapse Expand NGpuJpegEncoder Methods
NGpuJpegEncoder.Encode Method
NGpuJpegEncoder.ScaleAndEncode Method
Collapse Expand NGpuJpegEncoder Properties
NGpuJpegEncoder.CompressionQuality Property
NGpuJpegEncoder.GpuIndex Property
NGpuJpegEncoder.NativeType Property
Collapse Expand Structs, Records, Enums
Neurotec.Surveillance.Encoding.NScaleMethod Enumeration
Collapse Expand Functions
NLicensingServiceGetBinPath Function
NLicensingServiceGetConfPath Function
NLicensingServiceGetStatus Function
NLicensingServiceInstall Function
NLicensingServiceIsTrial Function
NLicensingServiceStart Function
NLicensingServiceStop Function
NLicensingServiceUninstall Function
Collapse Expand Structs, Records, Enums
NLicensingServiceStatus Enumeration
Collapse Expand Macros
NLicensingServiceInstall Macro
C++ Reference
Support
NsedGetMaskConfidence@HNSurveillanceEventDetails@NByte *
NsedGetStatus@HNSurveillanceEventDetails@NBiometricStatus *


Index

Index
Search Result
. | A | B | C | D | E | F | G | H | I | J | N | P | W
.
.NET Reference
A
AChar enumeration member
ALPR Modality
API Reference
Abstract enumeration member
AccidentalWhorl enumeration member
Active enumeration member
Add enumeration member
Aligned enumeration member
All enumeration member
Amd enumeration member
Amputation enumeration member
Android enumeration member
Any enumeration member
Array enumeration member
ArrayCollection enumeration member
AsyncOperation enumeration member
Audio enumeration member
AutoFocusFailure enumeration member
B
BackgroundUniformity enumeration member
BadContrast enumeration member
BadDynamicRange enumeration member
BadExposure enumeration member
BadLighting enumeration member
BadObject enumeration member
BadObjectSequence enumeration member
BadPose enumeration member
BadPosition enumeration member
BadSharpness enumeration member
BadSize enumeration member
BadSpeed enumeration member
Beard enumeration member
Bifurcation enumeration member
Bike enumeration member
BiometricDevice enumeration member
Black enumeration member
Blink enumeration member
Blue enumeration member
Bmp Unit
Bmp.h
BmpInfo class
NativeType
about BmpInfo class
BodyOdor enumeration member
Boolean enumeration member
Both enumeration member
BothEyePatch enumeration member
Brown enumeration member
Buffer enumeration member
Bus enumeration member
ByRef enumeration member
Byte enumeration member
C
C Reference
C++ Reference
Cache enumeration member
Callback enumeration member
Camera enumeration member
Cameras
Canceled enumeration member
CaptureDevice enumeration member
CaptureError enumeration member
Car enumeration member
Centaur enumeration member
CentralPocketLoop enumeration member
CleaningNeeded enumeration member
Collection enumeration member
CommunicationError enumeration member
CompanyFileLicense enumeration member
Completed enumeration member
Complex enumeration member
CompressionArtifacts enumeration member
Concurrent enumeration member
Conflict enumeration member
ContinuePending enumeration member
Cropped enumeration member
CroppedAndMasked enumeration member
Cubic enumeration member
CubicB05C03 enumeration member
CubicCatmullRom enumeration member
CubicSpline enumeration member
Custom enumeration member
Cyrix enumeration member
D
DarkGlasses enumeration member
DateTime enumeration member
Debug enumeration member
Default enumeration member
DefaultValue enumeration member
Deprecated enumeration member
Devices
Dictionary enumeration member
Disabled enumeration member
DistortingCondition enumeration member
Dna enumeration member
Dongle enumeration member
Double enumeration member
DoubleLoop enumeration member
Duplicate enumeration member
DuplicateFound enumeration member
DuplicateId enumeration member
E
Ear enumeration member
EarShape enumeration member
East enumeration member
EightNeighbors enumeration member
EightNeighborsWithIndexes enumeration member
EmbeddedLinux enumeration member
End enumeration member
Error codes
ErrorSuppressedEventArgs class
Error
ErrorSuppressedEventArgs
about ErrorSuppressedEventArgs class
Excellent enumeration member
Exe enumeration member
Expression enumeration member
EyesAway enumeration member
F
FScanner enumeration member
Face Modality
Face enumeration member
FaceDarkness enumeration member
FaceLossless enumeration member
FaceLossy enumeration member
FaceMask enumeration member
FaceNotDetected enumeration member
Faces Sample (C#)
Faces enumeration member
FacesDetected enumeration member
FacialFeatures enumeration member
Fair enumeration member
Faulted enumeration member
Features
Female enumeration member
File enumeration member
Finger enumeration member
FingerGeometry enumeration member
FingerScanner enumeration member
Fingerprint enumeration member
Fingerprint1000Ppi enumeration member
FingerprintLossless enumeration member
FlipNone enumeration member
FlipX enumeration member
FlipXY enumeration member
FlipY enumeration member
Foot enumeration member
FootPrint enumeration member
Format Specifications
FourNeighbors enumeration member
FourNeighborsWithIndexes enumeration member
Front enumeration member
FrontLeft enumeration member
FrontRight enumeration member
Frowning enumeration member
G
Gait enumeration member
Glasses enumeration member
GlassesReflection enumeration member
Global enumeration member
Good enumeration member
Gpu0 enumeration member
Gpu1 enumeration member
Gpu2 enumeration member
Gpu3 enumeration member
Gpu4 enumeration member
Gpu5 enumeration member
Gpu6 enumeration member
Gpu7 enumeration member
Gray enumeration member
Grayscale enumeration member
GrayscaleDensity enumeration member
Green enumeration member
Guid enumeration member
H
HNLRecord
HNLTemplate
HNMediaFormat
HNMediaReader
HNPluginModule
HNTemplate
HNmediaSource
HandGeometry enumeration member
HardwareId enumeration member
HasCurvature enumeration member
HasG enumeration member
HasQuality enumeration member
Hat enumeration member
HeavyFrame enumeration member
I
IHead Unit
IHead.h
IHeadInfo class
NativeType
about IHeadInfo class
IOS enumeration member
IdNotFound enumeration member
ImageCaptured enumeration member
IncompatibleSamples enumeration member
IncompatibleSource enumeration member
IncompatibleWithOtherPlugins enumeration member
Int16 enumeration member
Int32 enumeration member
Int64 enumeration member
Intel enumeration member
InterfaceTypeMismatch enumeration member
InterfaceVersionMismatch enumeration member
Interlaced enumeration member
InternalError enumeration member
Internet enumeration member
InternetLicense enumeration member
Introduction
Invalid enumeration member
InvalidFieldValue enumeration member
InvalidId enumeration member
InvalidInterface enumeration member
InvalidModule enumeration member
InvalidOperations enumeration member
InvalidPropertyValue enumeration member
InvalidQuery enumeration member
InvalidSampleResolution enumeration member
Iris enumeration member
IrisScanner enumeration member
J
JPEG_2K_DEFAULT_RATIO macro
JPEG_DEFAULT_QUALITY macro
Jpeg Unit
Jpeg.h
Jpeg2K Unit
Jpeg2K.h
Jpeg2KInfo class
DefaultRatio
Jpeg2KProfileNativeType
NativeType
Profile
Ratio
about Jpeg2KInfo class
Jpeg2KInfoGetProfile function
Jpeg2KInfoGetRatio function
Jpeg2KInfoSetProfile function
Jpeg2KInfoSetRatio function
Jpeg2KProfile enumeration
Jpeg2KProfile_ enumeration
JpegInfo class
DefaultQuality
IsLossless
NativeType
Quality
about JpegInfo class
JpegInfoGetQuality function
JpegInfoIsLossless function
JpegInfoSetLossless function
JpegInfoSetQuality function
KeepRotatingYaw enumeration member
KeepStill enumeration member
Keystroke enumeration member
KeystrokeDynamics enumeration member
Lanczos enumeration member
LanczosAdvanced enumeration member
LatentImpression enumeration member
LatentLift enumeration member
LatentPalmImpression enumeration member
LatentPalmLift enumeration member
LatentPalmPhoto enumeration member
LatentPalmTracing enumeration member
LatentPhoto enumeration member
LatentTracing enumeration member
Left enumeration member
LeftBackOfHand enumeration member
LeftEyePatch enumeration member
LeftFullPalm enumeration member
LeftHypothenar enumeration member
LeftIndex enumeration member
LeftIndexFinger enumeration member
LeftIndexMiddleFingers enumeration member
LeftIndexMiddleRingFingers enumeration member
LeftInterdigital enumeration member
LeftLittle enumeration member
LeftLittleFinger enumeration member
LeftLowerPalm enumeration member
LeftMiddle enumeration member
LeftMiddleFinger enumeration member
LeftMiddleRingFingers enumeration member
LeftMiddleRingLittleFingers enumeration member
LeftOther enumeration member
LeftPalm enumeration member
LeftPointerFinger enumeration member
LeftRing enumeration member
LeftRingFinger enumeration member
LeftRingLittleFingers enumeration member
LeftSlantLoop enumeration member
LeftThenar enumeration member
LeftThumb enumeration member
LeftUpperPalm enumeration member
LeftWrist enumeration member
LeftWritersPalm enumeration member
LensClosed enumeration member
Lib enumeration member
License enumeration member
LicensePlateRecognition enumeration member
Licensed API functionality
Licensing
Linear enumeration member
Linux enumeration member
LipMovement enumeration member
LiveScanContactless enumeration member
LiveScanNonOpticalContactPlain enumeration member
LiveScanNonOpticalContactRolled enumeration member
LiveScanNonOpticalContactlessPlain enumeration member
LiveScanNonOpticalContactlessRolled enumeration member
LiveScanOpticalContactPlain enumeration member
LiveScanOpticalContactRolled enumeration member
LiveScanOpticalContactlessPlain enumeration member
LiveScanOpticalContactlessRolled enumeration member
LiveScanPalm enumeration member
LiveScanPlain enumeration member
LiveScanRolled enumeration member
LiveScanVerticalSwipe enumeration member
Liveness enumeration member
LoadError enumeration member
Local enumeration member
LookingAway enumeration member
MacOSX enumeration member
Male enumeration member
Manual enumeration member
MaskDetected enumeration member
MatchNotFound enumeration member
Matching Threshold and FAR/FRR
MaxValue enumeration member
Microphone enumeration member
MinValue enumeration member
MirrorUp enumeration member
Mobile enumeration member
MotionBlur enumeration member
MouthOpen enumeration member
Move enumeration member
MoveBack enumeration member
MoveCloser enumeration member
MultipleBiometrics enumeration member
Mustache enumeration member
NAChar type
NACharParse macro
NACharParseChars macro
NACharParseN function
NACharParseStrOrChars function
NACharParseStrOrChars macro
NACharParseVN function
NACharParseVN macro
NACharToChars function
NACharToChars macro
NACharToString function
NACharToString macro
NACharTryParse macro
NACharTryParseChars macro
NACharTryParseN function
NACharTryParseStrOrChars function
NACharTryParseStrOrChars macro
NACharTryParseVN function
NACharTryParseVN macro
NAlignedFree function
NAlignedOffsetAlloc function
NAlignedOffsetAllocArray function
NAlignedOffsetCAlloc function
NAlignedOffsetCAllocArray function
NAlignedOffsetReAlloc function
NAlignedOffsetReAllocArray function
NAlloc function
NAllocArray function
NArray Unit
NArray class
FromArray
FromArray
FromArray
FromArray
FromArray
FromArray
FromArray
FromArray
FromArray
FromArray
FromArray
FromArray
FromArray
FromArray
FromArray
FromArray
FromArray
FromArray
FromArray
FromArray
FromArray
FromArray
FromArray
FromArray
FromArray
FromArray
FromArray
FromArray
FromArray
FromArray
FromArray
FromArray
FromArray
FromArray
FromArray<T>
FromArray<T>
FromPointerArray
FromPointerArray
FromResultArray
FromResultArray
GetEnumerator
GetValueAs
GetValueAs
GetValueAs
GetValueAs<T>
GetValueAs<T>
GetValueAs<T>
GetValueAsBoolean
GetValueAsBoolean
GetValueAsBoolean
GetValueAsByte
GetValueAsByte
GetValueAsByte
GetValueAsChar
GetValueAsChar
GetValueAsChar
GetValueAsDouble
GetValueAsDouble
GetValueAsDouble
GetValueAsInt16
GetValueAsInt16
GetValueAsInt16
GetValueAsInt32
GetValueAsInt32
GetValueAsInt32
GetValueAsInt64
GetValueAsInt64
GetValueAsInt64
GetValueAsIntPtr
GetValueAsIntPtr
GetValueAsIntPtr
GetValueAsObject
GetValueAsObject
GetValueAsObject
GetValueAsPointer
GetValueAsPointer
GetValueAsPointer
GetValueAsResult
GetValueAsResult
GetValueAsResult
GetValueAsSByte
GetValueAsSByte
GetValueAsSByte
GetValueAsSingle
GetValueAsSingle
GetValueAsSingle
GetValueAsString
GetValueAsString
GetValueAsString
GetValueAsUInt16
GetValueAsUInt16
GetValueAsUInt16
GetValueAsUInt32
GetValueAsUInt32
GetValueAsUInt32
GetValueAsUInt64
GetValueAsUInt64
GetValueAsUInt64
GetValueAsUIntPtr
GetValueAsUIntPtr
GetValueAsUIntPtr
Length
NativeType
ToArray
ToArray
ToArray
ToArray
ToArray<T>
ToArray<T>
ToArray<T>
ToBooleanArray
ToBooleanArray
ToBooleanArray
ToByteArray
ToByteArray
ToByteArray
ToCharArray
ToCharArray
ToCharArray
ToDoubleArray
ToDoubleArray
ToDoubleArray
ToInt16Array
ToInt16Array
ToInt16Array
ToInt32Array
ToInt32Array
ToInt32Array
ToInt64Array
ToInt64Array
ToInt64Array
ToIntPtrArray
ToIntPtrArray
ToIntPtrArray
ToObjectArray
ToObjectArray
ToObjectArray
ToPointerArray
ToPointerArray
ToPointerArray
ToResultArray
ToResultArray
ToResultArray
ToSByteArray
ToSByteArray
ToSByteArray
ToSingleArray
ToSingleArray
ToSingleArray
ToStringArray
ToStringArray
ToStringArray
ToUInt16Array
ToUInt16Array
ToUInt16Array
ToUInt32Array
ToUInt32Array
ToUInt32Array
ToUInt64Array
ToUInt64Array
ToUInt64Array
ToUIntPtrArray
ToUIntPtrArray
ToUIntPtrArray
about NArray class
NArray.h
NArrayCollection Unit
NArrayCollection class
Add
AddRange
AddRange
Clear
Contains
CopyTo
CopyTo
CopyTo
CopyTo
Count
GetCount
GetEnumerator
IndexOf
Insert
InsertRange
InsertRange
IsReadOnly
NativeType
Remove
RemoveAt
RemoveRange
ToArray
ToItemArray
about NArrayCollection class
this
this
NArrayCollection.h
NArrayCollectionAdd function
NArrayCollectionAddItemRange function
NArrayCollectionAddRange function
NArrayCollectionClear function
NArrayCollectionContains function
NArrayCollectionGet function
NArrayCollectionGetBaseCount function
NArrayCollectionGetCount function
NArrayCollectionIndexOf function
NArrayCollectionInfo Unit
NArrayCollectionInfo class
AddMethod
AddRangeMethod
BaseCollection
ClearMethod
GetCountMethod
GetMethod
IndexOfMethod
InsertMethod
InsertRangeMethod
ItemAttributes
ItemFormat
ItemMaxValue
ItemMinValue
ItemStdValues
ItemType
NativeType
RemoveAtMethod
RemoveMethod
RemoveRangeMethod
SetMethod
ToArrayMethod
about NArrayCollectionInfo class
NArrayCollectionInfo.ItemStdValueCollection class
about NArrayCollectionInfo.ItemStdValueCollection class
NArrayCollectionInfo.h
NArrayCollectionInfoGetAddMethod function
NArrayCollectionInfoGetAddRangeMethod function
NArrayCollectionInfoGetBaseCollection function
NArrayCollectionInfoGetClearMethod function
NArrayCollectionInfoGetGetCountMethod function
NArrayCollectionInfoGetGetMethod function
NArrayCollectionInfoGetIndexOfMethod function
NArrayCollectionInfoGetInsertMethod function
NArrayCollectionInfoGetInsertRangeMethod function
NArrayCollectionInfoGetItemAttributes function
NArrayCollectionInfoGetItemFormat function
NArrayCollectionInfoGetItemMaxValue function
NArrayCollectionInfoGetItemMinValue function
NArrayCollectionInfoGetItemStdValue function
NArrayCollectionInfoGetItemStdValueCount function
NArrayCollectionInfoGetItemStdValues function
NArrayCollectionInfoGetItemType function
NArrayCollectionInfoGetRemoveAtMethod function
NArrayCollectionInfoGetRemoveMethod function
NArrayCollectionInfoGetRemoveRangeMethod function
NArrayCollectionInfoGetSetMethod function
NArrayCollectionInfoGetToArrayMethod function
NArrayCollectionInsert function
NArrayCollectionInsertItemRange function
NArrayCollectionInsertRange function
NArrayCollectionIsReadOnly function
NArrayCollectionRemove function
NArrayCollectionRemoveAt function
NArrayCollectionRemoveRange function
NArrayCollectionSet function
NArrayCollectionToArray function
NArrayCollectionToItemArray function
NArrayCopyTo function
NArrayCopyToBooleanArray function
NArrayCopyToByteArray function
NArrayCopyToCharArray function
NArrayCopyToCharArray macro
NArrayCopyToDoubleArray function
NArrayCopyToInt16Array function
NArrayCopyToInt32Array function
NArrayCopyToInt64Array function
NArrayCopyToObjectArray function
NArrayCopyToObjectArrayP function
NArrayCopyToP function
NArrayCopyToPointerArray function
NArrayCopyToResultArray function
NArrayCopyToSByteArray function
NArrayCopyToSSizeTypeArray function
NArrayCopyToSingleArray function
NArrayCopyToSizeTypeArray function
NArrayCopyToStringArray function
NArrayCopyToUInt16Array function
NArrayCopyToUInt32Array function
NArrayCopyToUInt64Array function
NArrayCreate function
NArrayCreateCustom function
NArrayCreateFromBooleanArray function
NArrayCreateFromByteArray function
NArrayCreateFromCharArray function
NArrayCreateFromCharArray macro
NArrayCreateFromDoubleArray function
NArrayCreateFromInt16Array function
NArrayCreateFromInt32Array function
NArrayCreateFromInt64Array function
NArrayCreateFromObjectArray function
NArrayCreateFromObjectArrayP function
NArrayCreateFromPointerArray function
NArrayCreateFromResultArray function
NArrayCreateFromSByteArray function
NArrayCreateFromSSizeTypeArray function
NArrayCreateFromSingleArray function
NArrayCreateFromSizeTypeArray function
NArrayCreateFromStringArray function
NArrayCreateFromStringArray macro
NArrayCreateFromUInt16Array function
NArrayCreateFromUInt32Array function
NArrayCreateFromUInt64Array function
NArrayCreateP function
NArrayGetLength function
NArrayGetValue function
NArrayGetValueAs function
NArrayGetValueAsBoolean function
NArrayGetValueAsByte function
NArrayGetValueAsChar function
NArrayGetValueAsChar macro
NArrayGetValueAsDouble function
NArrayGetValueAsInt16 function
NArrayGetValueAsInt32 function
NArrayGetValueAsInt64 function
NArrayGetValueAsObject function
NArrayGetValueAsObjectP function
NArrayGetValueAsP function
NArrayGetValueAsPointer function
NArrayGetValueAsResult function
NArrayGetValueAsSByte function
NArrayGetValueAsSSizeType function
NArrayGetValueAsSingle function
NArrayGetValueAsSizeType function
NArrayGetValueAsString function
NArrayGetValueAsUInt16 function
NArrayGetValueAsUInt32 function
NArrayGetValueAsUInt64 function
NAsyncOperation Unit
NAsyncOperation class
AsTyped<T>
Cancel
Completed
Error
GetAwaiter
IsCanceled
IsCompleted
IsFaulted
NAsyncStatusNativeType
NativeType
Result
Status
Wait
Wait
about NAsyncOperation class
NAsyncOperation.h
NAsyncOperationAddCompleted function
NAsyncOperationAddCompletedCallback function
NAsyncOperationCancel function
NAsyncOperationGetError function
NAsyncOperationGetResult function
NAsyncOperationGetStatus function
NAsyncOperationIsCanceled function
NAsyncOperationIsCompleted function
NAsyncOperationIsFaulted function
NAsyncOperationRemoveCompleted function
NAsyncOperationRemoveCompletedCallback function
NAsyncOperationWait function
NAsyncOperationWaitAll function
NAsyncOperationWaitAllTimed function
NAsyncOperationWaitAny function
NAsyncOperationWaitAnyTimed function
NAsyncOperationWaitTimed function
NAsyncStatus enumeration
NAsyncStatus_ enumeration
NAttributes enumeration
NAttributes_ enumeration
NBinaryReader Unit
NBinaryReaderCreate function
NBinaryReaderCreateWithEncoding function
NBinaryReaderGetBaseStream function
NBinaryReaderGetByteOrder function
NBinaryReaderGetNull function
NBinaryReaderGetPosition function
NBinaryReaderPeekChar function
NBinaryReaderPeekChar macro
NBinaryReaderRead function
NBinaryReaderRead macro
NBinaryReaderReadBoolean function
NBinaryReaderReadByte function
NBinaryReaderReadBytesDst function
NBinaryReaderReadBytesDstN function
NBinaryReaderReadBytesN function
NBinaryReaderReadChar function
NBinaryReaderReadChar macro
NBinaryReaderReadChars function
NBinaryReaderReadChars macro
NBinaryReaderReadCharsDst function
NBinaryReaderReadCharsDst macro
NBinaryReaderReadDouble function
NBinaryReaderReadInt16 function
NBinaryReaderReadInt32 function
NBinaryReaderReadInt64 function
NBinaryReaderReadSByte function
NBinaryReaderReadSingle function
NBinaryReaderReadUInt16 function
NBinaryReaderReadUInt32 function
NBinaryReaderReadUInt64 function
NBinaryReaderSeek function
NBinaryReaderSetPosition function
NBinaryWriter Unit
NBinaryWriterCreate function
NBinaryWriterCreateWithEncoding function
NBinaryWriterFlush function
NBinaryWriterGetBaseStream function
NBinaryWriterGetByteOrder function
NBinaryWriterGetNull function
NBinaryWriterGetPosition function
NBinaryWriterSeek function
NBinaryWriterSetPosition function
NBinaryWriterWriteBoolean function
NBinaryWriterWriteByte function
NBinaryWriterWriteBytes function
NBinaryWriterWriteBytesN function
NBinaryWriterWriteChar function
NBinaryWriterWriteChar macro
NBinaryWriterWriteChars function
NBinaryWriterWriteChars macro
NBinaryWriterWriteDouble function
NBinaryWriterWriteInt16 function
NBinaryWriterWriteInt32 function
NBinaryWriterWriteInt64 function
NBinaryWriterWriteSByte function
NBinaryWriterWriteSingle function
NBinaryWriterWriteUInt16 function
NBinaryWriterWriteUInt32 function
NBinaryWriterWriteUInt64 function
NBiometric Unit
NBiometric class
BiometricType
CaptureOptions
Error
FileName
HasMoreSamples
IsBiometricCaptureOptionsValid
NBiometricCaptureOptionsNativeType
NativeType
Owner
ParentObject
SampleBuffer
SessionId
Status
about NBiometric class
NBiometric.h
NBiometricAngleFromDegrees function
NBiometricAngleFromRadians function
NBiometricAngleToDegrees function
NBiometricAngleToRadians function
NBiometricAngleToString function
NBiometricAngleToString macro
NBiometricAttributes Unit
NBiometricAttributes class
BiometricType
Child
ChildSubject
DetectionConfidence
LivenessConfidence
NativeType
Quality
Status
about NBiometricAttributes class
NBiometricAttributes.h
NBiometricAttributesGetBiometricType function
NBiometricAttributesGetChild function
NBiometricAttributesGetChildSubject function
NBiometricAttributesGetDetectionConfidence function
NBiometricAttributesGetQuality function
NBiometricAttributesGetStatus function
NBiometricAttributesSetDetectionConfidence function
NBiometricAttributesSetQuality function
NBiometricAttributesSetStatus function
NBiometricCaptureOptions enumeration
NBiometricCaptureOptionsIsValid function
NBiometricCaptureOptions_ enumeration
NBiometricDevice Unit
NBiometricDevice class
BiometricType
Cancel
Capture
Capture
Capture
CapturePreview
EndSequence
IsSpoofDetectionSupported
NativeType
ProductId
SpoofDetection
StartSequence
VendorId
about NBiometricDevice class
NBiometricDevice.h
NBiometricDeviceAddCapturePreview function
NBiometricDeviceAddCapturePreviewCallback function
NBiometricDeviceCancel function
NBiometricDeviceCapture function
NBiometricDeviceCapturePreviewEventArgs class
Biometric
NBiometricDeviceCapturePreviewEventArgs
about NBiometricDeviceCapturePreviewEventArgs class
NBiometricDeviceEndSequence function
NBiometricDeviceGetBiometricType function
NBiometricDeviceGetProductId function
NBiometricDeviceGetSpoofDetection function
NBiometricDeviceGetVendorId function
NBiometricDeviceIsSpoofDetectionSupported function
NBiometricDeviceRemoveCapturePreview function
NBiometricDeviceRemoveCapturePreviewCallback function
NBiometricDeviceSetSpoofDetection function
NBiometricDeviceStartSequence function
NBiometricGetBiometricType function
NBiometricGetCaptureOptions function
NBiometricGetError function
NBiometricGetFileName function
NBiometricGetHasMoreSamples function
NBiometricGetParentObject function
NBiometricGetSampleBuffer function
NBiometricGetSessionId function
NBiometricGetStatus function
NBiometricNfiq1ToNfiqQuality function
NBiometricNfiqQualityToNfiq1 function
NBiometricQualityBlock structure
NBiometricQualityBlock
NativeType
QualityAlgorithmId
QualityAlgorithmVendorId
QualityScore
ToString
ToString
about NBiometricQualityBlock structure
NBiometricQualityBlock type
NBiometricQualityBlockIsValid function
NBiometricQualityBlockToString function
NBiometricQualityBlockToString macro
NBiometricQualityBlock_ structure
NBiometricQualityIsValid function
NBiometricQualityToString function
NBiometricQualityToString macro
NBiometricSetCaptureOptions function
NBiometricSetFileName function
NBiometricSetFileName macro
NBiometricSetHasMoreSamples function
NBiometricSetSampleBuffer function
NBiometricSetSessionId function
NBiometricSetStatus function
NBiometricStatus enumeration
NBiometricStatusIsFinal function
NBiometricStatusIsValid function
NBiometricStatus_ enumeration
NBiometricSubtype enumeration
NBiometricSubtypeIsValid function
NBiometricSubtype_ enumeration
NBiometricType enumeration
NBiometricTypeIsValid function
NBiometricType_ enumeration
NBiometricTypes Unit
NBiometricTypes class
AngleFromDegrees
AngleFromRadians
AngleToDegrees
AngleToRadians
AngleToString
AngleToString
GetPositionAvailableParts
GetPositionAvailableParts
IsBiometricStatusFinal
IsBiometricStatusValid
IsBiometricSubtypeValid
IsBiometricTypeValid
IsImpressionTypeCompatibleWith
IsImpressionTypeContact
IsImpressionTypeContactless
IsImpressionTypeFinger
IsImpressionTypeGeneric
IsImpressionTypeLatent
IsImpressionTypeLiveScan
IsImpressionTypeNonOptical
IsImpressionTypeNonliveScan
IsImpressionTypeOneOf
IsImpressionTypeOptical
IsImpressionTypePalm
IsImpressionTypePlain
IsImpressionTypeRolled
IsImpressionTypeSwipe
IsImpressionTypeValid
IsImpressionTypeValidFinger
IsImpressionTypeValidPalm
IsNfiqQualityValid
IsNfiqValid
IsPatternClassValid
IsPatternClassValidFor
IsPositionCompatibleWith
IsPositionCompatibleWith
IsPositionFinger
IsPositionFourFingers
IsPositionKnown
IsPositionKnown
IsPositionLeft
IsPositionLeft
IsPositionLeftAndRight
IsPositionOneOf
IsPositionOneOf
IsPositionPalm
IsPositionRight
IsPositionRight
IsPositionRightAndLeft
IsPositionSingleEye
IsPositionSingleFinger
IsPositionTheEye
IsPositionTheFinger
IsPositionThePalm
IsPositionThreeFingers
IsPositionTwoEyes
IsPositionTwoFingers
IsPositionValid
IsPositionValid
IsPositionValidFinger
IsPositionValidPalm
IsPositionValidTheEye
IsPositionValidTheFinger
IsQualityValid
NBiometricStatusNativeType
NBiometricSubtypeNativeType
NBiometricTypeNativeType
NEImageTypeNativeType
NEPositionNativeType
NFImpressionTypeNativeType
NFMinutiaFormatNativeType
NFMinutiaTypeNativeType
NFPatternClassNativeType
NFPositionNativeType
NFRidgeCountsTypeNativeType
NGenderNativeType
NIcaoWarningsNativeType
NLExpressionNativeType
NLPropertiesNativeType
NLivenessActionNativeType
NLivenessModeNativeType
NTemplateSizeNativeType
NativeType
Nfiq1ToNfiqQuality
NfiqQualityNativeType
NfiqQualityToNfiq1
PhraseIdUnknown
QualityFailed
QualityMax
QualityMin
QualityToString
QualityToString
QualityUnknown
ToImpressionTypeFinger
about NBiometricTypes class
NBiometricTypes.h
NBiometrics Library
NBiometrics class
DllName
NativeModule
about NBiometrics class
NBool type
NBoolean type
NBooleanParse macro
NBooleanParseChars macro
NBooleanParseN function
NBooleanParseStrOrChars function
NBooleanParseStrOrChars macro
NBooleanParseVN function
NBooleanParseVN macro
NBooleanToChars function
NBooleanToChars macro
NBooleanToString function
NBooleanToString macro
NBooleanTryParse macro
NBooleanTryParseChars macro
NBooleanTryParseN function
NBooleanTryParseStrOrChars function
NBooleanTryParseStrOrChars macro
NBooleanTryParseVN function
NBooleanTryParseVN macro
NBuffer Unit
NBuffer class
Copy
Copy
Copy
CopyFrom
CopyFrom
CopyFrom
CopyFrom
CopyTo
CopyTo
CopyTo
CopyTo
CopyTo
CopyTo
CopyTo
CopyTo
CopyTo
CopyTo
CopyTo
Empty
LongSize
NBuffer
NBuffer
NBuffer
NBuffer
NBuffer
NBuffer
NBuffer
NBuffer
NBuffer
NBuffer
NBuffer
NBuffer
NBuffer
NBuffer
NBuffer
NBuffer
NBuffer
NativeSize
NativeType
Ptr
Size
ToArray
WriteTo
about NBuffer class
NBuffer.h
NBufferCopy function
NBufferCopyFromPtr function
NBufferCopyTo function
NBufferCopyToPtr function
NBufferCopyToPtrRange function
NBufferCreate function
NBufferCreateFromBuffer function
NBufferCreateFromConstPtr macro
NBufferCreateFromPtr function
NBufferCreateFromPtrEx function
NBufferCreateFromPtrWithFree function
NBufferCreateFromPtrWithFreeProc function
NBufferGetEmpty function
NBufferGetPtr function
NBufferGetSize function
NBufferToPtr function
NBufferedStream Unit
NBufferedStream.h
NBufferedStreamCreate function
NBufferedStreamCreateWithBufferSize function
NByte type
NByteOrder enumeration
NByteOrderGetSystem function
NByteOrderIsReverse function
NByteOrderIsValid function
NByteOrder_ enumeration
NCAlloc function
NCAllocArray function
NCallStackEntryCopy function
NCallStackEntryCreate function
NCallStackEntryCreate macro
NCallStackEntryDispose function
NCallStackEntrySet function
NCallStackEntry_ structure
NCallback Unit
NCallback.h
NCallbackClone function
NCallbackCreate macro
NCallbackCreateCustom macro
NCallbackCreateCustomRaw function
NCallbackCreateRaw function
NCallbackCreateWithObjectRaw function
NCallbackEquals function
NCallbackFree function
NCallbackGetHashCode function
NCallbackGetParam function
NCallbackGetProc macro
NCallbackGetProcRaw function
NCallbackInvoke0 macro
NCallbackInvoke1 macro
NCallbackInvoke2 macro
NCallbackInvoke3 macro
NCallbackInvoke4 macro
NCallbackInvoke5 macro
NCallbackInvoke6 macro
NCallbackInvoke7 macro
NCallbackInvoke8 macro
NCallbackInvoke9 macro
NCallbackInvokeRaw macro
NCallbackSet function
NCamera Unit
NCamera class
CaptureStill
Focus
FocusRegion
GetCurrentStillFormat
GetFrame
GetFrame
GetStillFormats
GetVideoSample
IsFocusRegionSupported
IsFocusSupported
IsStillCaptureSupported
IsVideoSampleSupported
NCameraStatusNativeType
NativeType
ResetFocus
SetCurrentStillFormat
StillCaptured
about NCamera class
NCameraAddStillCaptured function
NCameraAddStillCapturedCallback function
NCameraCaptureStill function
NCameraFocus function
NCameraGetCurrentStillFormat function
NCameraGetFocusRegion function
NCameraGetFrame function
NCameraGetFrameEx function
NCameraGetStillFormats function
NCameraGetVideoSample function
NCameraIsFocusRegionSupported function
NCameraIsFocusSupported function
NCameraIsStillCaptureSupported function
NCameraIsVideoSampleSupported function
NCameraRemoveStillCaptured function
NCameraRemoveStillCapturedCallback function
NCameraResetFocus function
NCameraSetCurrentStillFormat function
NCameraSetFocusRegion function
NCameraStatus enumeration
NCameraStatus_ enumeration
NCameraStillCapturedEventArgs class
Id
NCameraStillCapturedEventArgs
Properties
Stream
about NCameraStillCapturedEventArgs class
NCaptureDevice Unit
NCaptureDevice class
GetCurrentFormat
GetFormats
IsCapturing
IsCapturingChanged
MediaType
NativeType
SetCurrentFormat
StartCapturing
StopCapturing
about NCaptureDevice class
NCaptureDeviceAddIsCapturingChanged function
NCaptureDeviceAddIsCapturingChangedCallback function
NCaptureDeviceGetCurrentFormat function
NCaptureDeviceGetFormats function
NCaptureDeviceGetMediaType function
NCaptureDeviceIsCapturing function
NCaptureDeviceRemoveIsCapturingChanged function
NCaptureDeviceRemoveIsCapturingChangedCallback function
NCaptureDeviceSetCurrentFormat function
NCaptureDeviceStartCapturing function
NCaptureDeviceStopCapturing function
NChar type
NCharFromBinDigit function
NCharFromBinDigit macro
NCharFromDigit function
NCharFromDigit macro
NCharFromHexDigit function
NCharFromHexDigit macro
NCharFromOctDigit function
NCharFromOctDigit macro
NCharIsAscii function
NCharIsAscii macro
NCharIsBinDigit function
NCharIsBinDigit macro
NCharIsDigit function
NCharIsDigit macro
NCharIsHexDigit function
NCharIsHexDigit macro
NCharIsLetter function
NCharIsLetter macro
NCharIsLower function
NCharIsLower macro
NCharIsOctDigit function
NCharIsOctDigit macro
NCharIsUpper function
NCharIsUpper macro
NCharIsWhiteSpace function
NCharIsWhiteSpace macro
NCharParse macro
NCharParseChars macro
NCharParseN function
NCharParseStrOrChars function
NCharParseVN function
NCharToBinDigit function
NCharToBinDigit macro
NCharToChars function
NCharToDigit function
NCharToDigit macro
NCharToHexDigit function
NCharToHexDigit macro
NCharToLower function
NCharToLower macro
NCharToOctDigit function
NCharToOctDigit macro
NCharToString function
NCharToUpper function
NCharToUpper macro
NCharTryParse macro
NCharTryParseChars macro
NCharTryParseN function
NCharTryParseStrOrChars function
NCharTryParseVN function
NClear macro
NClearArray function
NClothingDetails Unit
NClothingDetails class
Gender
GenderConfidence
GetKnownValues
NativeType
Values
about NClothingDetails class
NClothingDetails.ValueCollection class
about NClothingDetails.ValueCollection class
NClothingDetailsGetGender function
NClothingDetailsGetGenderConfidence function
NClothingDetailsGetKnownValues function
NClothingDetailsGetValue function
NClothingDetailsGetValueCount function
NClothingDetailsGetValues function
NCollection Unit
NCollection class
Add
AddRange
AddRange
Capacity
Clear
CollectionChanged
Contains
CopyTo
CopyTo
Count
GetEnumerator
IndexOf
Insert
InsertRange
InsertRange
IsReadOnly
NCollectionChangedActionNativeType
NCollectionCollectionChangedCallbackNativeType
NativeType
Remove
RemoveAt
RemoveRange
ToArray
ToItemArray
about NCollection class
this
NCollection.h
NCollectionAdd function
NCollectionAddCollectionChanged function
NCollectionAddCollectionChangedCallback function
NCollectionAddItemCollectionChanged function
NCollectionAddItemCollectionChangedCallback function
NCollectionAddItemRange function
NCollectionAddRange function
NCollectionChangedAction enumeration
NCollectionChangedAction_ enumeration
NCollectionClear function
NCollectionContains function
NCollectionGet function
NCollectionGetCapacity function
NCollectionGetCount function
NCollectionIndexOf function
NCollectionInfo Unit
NCollectionInfo class
AddCollectionChangedCallbackMethod
AddCollectionChangedMethod
AddMethod
AddRangeMethod
ClearMethod
GetCapacityMethod
GetCountMethod
GetMethod
IndexOfMethod
InsertMethod
InsertRangeMethod
ItemAttributes
ItemFormat
ItemMaxValue
ItemMinValue
ItemStdValues
ItemType
NativeType
RemoveAtMethod
RemoveCollectionChangedCallbackMethod
RemoveCollectionChangedMethod
RemoveMethod
RemoveRangeMethod
SetCapacityMethod
SetMethod
ToArrayMethod
about NCollectionInfo class
NCollectionInfo.ItemStdValueCollection class
about NCollectionInfo.ItemStdValueCollection class
NCollectionInfo.h
NCollectionInfoGetAddCollectionChangedCallbackMethod function
NCollectionInfoGetAddCollectionChangedMethod function
NCollectionInfoGetAddMethod function
NCollectionInfoGetAddRangeMethod function
NCollectionInfoGetClearMethod function
NCollectionInfoGetGetCapacityMethod function
NCollectionInfoGetGetCountMethod function
NCollectionInfoGetGetMethod function
NCollectionInfoGetIndexOfMethod function
NCollectionInfoGetInsertMethod function
NCollectionInfoGetInsertRangeMethod function
NCollectionInfoGetItemAttributes function
NCollectionInfoGetItemFormat function
NCollectionInfoGetItemMaxValue function
NCollectionInfoGetItemMinValue function
NCollectionInfoGetItemStdValue function
NCollectionInfoGetItemStdValueCount function
NCollectionInfoGetItemStdValues function
NCollectionInfoGetItemType function
NCollectionInfoGetRemoveAtMethod function
NCollectionInfoGetRemoveCollectionChangedCallbackMethod function
NCollectionInfoGetRemoveCollectionChangedMethod function
NCollectionInfoGetRemoveMethod function
NCollectionInfoGetRemoveRangeMethod function
NCollectionInfoGetSetCapacityMethod function
NCollectionInfoGetSetMethod function
NCollectionInfoGetToArrayMethod function
NCollectionInsert function
NCollectionInsertItemRange function
NCollectionInsertRange function
NCollectionIsReadOnly function
NCollectionRemove function
NCollectionRemoveAt function
NCollectionRemoveCollectionChanged function
NCollectionRemoveCollectionChangedCallback function
NCollectionRemoveItemCollectionChanged function
NCollectionRemoveItemCollectionChangedCallback function
NCollectionRemoveRange function
NCollectionSet function
NCollectionSetCapacity function
NCollectionToArray function
NCollectionToItemArray function
NCompare function
NComplex structure
Imaginary
ImaginaryOne
NComplex
NativeType
One
Real
ToString
ToString
Zero
about NComplex structure
NComplex type
NComplexToString function
NComplex_ structure
NConsole Unit
NConsoleGetError function
NConsoleGetIn function
NConsoleGetOut function
NConsoleReadChar function
NConsoleReadChar macro
NConsoleReadLine function
NConsoleSetError function
NConsoleSetIn function
NConsoleSetOut function
NConsoleWrite function
NConsoleWrite macro
NConsoleWriteBoolean function
NConsoleWriteBooleanLine function
NConsoleWriteChar function
NConsoleWriteChar macro
NConsoleWriteCharLine function
NConsoleWriteCharLine macro
NConsoleWriteChars function
NConsoleWriteChars macro
NConsoleWriteCharsLine function
NConsoleWriteCharsLine macro
NConsoleWriteDouble function
NConsoleWriteDoubleLine function
NConsoleWriteEmptyLine function
NConsoleWriteFormat function
NConsoleWriteFormat macro
NConsoleWriteFormatLine function
NConsoleWriteFormatLine macro
NConsoleWriteFormatLineVA function
NConsoleWriteFormatLineVA macro
NConsoleWriteFormatVA function
NConsoleWriteFormatVA macro
NConsoleWriteInt32 function
NConsoleWriteInt32Line function
NConsoleWriteInt64 function
NConsoleWriteInt64Line function
NConsoleWriteLine function
NConsoleWriteLine macro
NConsoleWriteObject function
NConsoleWriteObjectLine function
NConsoleWritePointer function
NConsoleWritePointerLine function
NConsoleWriteResult function
NConsoleWriteResultLine function
NConsoleWriteSSizeType function
NConsoleWriteSSizeTypeLine function
NConsoleWriteSingle function
NConsoleWriteSingleLine function
NConsoleWriteSizeType function
NConsoleWriteSizeTypeLine function
NConsoleWriteUInt32 function
NConsoleWriteUInt32Line function
NConsoleWriteUInt64 function
NConsoleWriteUInt64Line function
NConsoleWriteValue function
NConsoleWriteValueLine function
NConsoleWriteValueLineP function
NConsoleWriteValueP function
NConstantInfo Unit
NConstantInfo class
ConstantType
NativeType
Value
about NConstantInfo class
NConstantInfo.h
NConstantInfoGetConstantType function
NConstantInfoGetValue function
NCopy function
NCopyArray function
NCore Library
NCore Unit
NCore class
AlignedAlloc
AlignedAlloc
AlignedAlloc
AlignedAlloc
AlignedAlloc
AlignedAlloc
AlignedCAlloc
AlignedCAlloc
AlignedCAlloc
AlignedCAlloc
AlignedCAlloc
AlignedCAlloc
AlignedFree
AlignedReAlloc
AlignedReAlloc
AlignedReAlloc
AlignedReAlloc
AlignedReAlloc
AlignedReAlloc
Alloc
Alloc
Alloc
CAlloc
CAlloc
CAlloc
Clear
Clear
Clear
Compare
Compare
Compare
Copy
Copy
Copy
DllName
ErrorSuppressed
Fill
Fill
Fill
Free
Free
Move
Move
Move
NativeModule
NativeType
ReAlloc
ReAlloc
ReAlloc
Shutdown
ShutdownThread
about NCore class
NCore.h
NCoreAddErrorSuppressed function
NCoreAddErrorSuppressedCallback function
NCoreOnExitEx function
NCoreOnStart function
NCoreOnThreadExit function
NCoreOnThreadStart function
NCoreRemoveErrorSuppressed function
NCoreRemoveErrorSuppressedCallback function
NCustomEventDescriptor Unit
NCustomEventDescriptor.h
NCustomEventDescriptorGetData function
NCustomMethodDescriptor Unit
NCustomMethodDescriptor.h
NCustomMethodDescriptorGetData function
NCustomParameterDescriptor Unit
NCustomParameterDescriptor.h
NCustomParameterDescriptorCreate function
NCustomParameterDescriptorGetData function
NCustomPropertyDescriptor Unit
NCustomPropertyDescriptor.h
NCustomPropertyDescriptorGetData function
NCustomStream Unit
NCustomStreamCreate function
NDateTime Unit
NDateTimeAddDays function
NDateTimeAddHours function
NDateTimeAddMilliseconds function
NDateTimeAddMinutes function
NDateTimeAddMonths function
NDateTimeAddSeconds function
NDateTimeAddTicks function
NDateTimeAddTimeSpan function
NDateTimeAddYears function
NDateTimeCompare function
NDateTimeCreate function
NDateTimeCreateDate function
NDateTimeCreateFromTicks function
NDateTimeDaysInMonth function
NDateTimeDecode function
NDateTimeGetDate function
NDateTimeGetDay function
NDateTimeGetDayOfWeek function
NDateTimeGetDayOfYear function
NDateTimeGetHour function
NDateTimeGetMillisecond function
NDateTimeGetMinute function
NDateTimeGetMonth function
NDateTimeGetNow function
NDateTimeGetSecond function
NDateTimeGetTicks function
NDateTimeGetTimeOfDay function
NDateTimeGetToday function
NDateTimeGetUtcNow function
NDateTimeGetYear function
NDateTimeIsDateTimeValid function
NDateTimeIsDateValid function
NDateTimeIsLeapYear function
NDateTimeIsValid function
NDateTimeSubtract function
NDateTimeSubtractTimeSpan function
NDateTimeToLocalTime function
NDateTimeToString function
NDateTimeToString macro
NDateTimeToUniversalTime function
NDateTime_ type
NDayOfWeek enumeration
NDayOfWeek_ enumeration
NDefs Unit
NDescriptor Unit
NDescriptor.h
NDescriptorGetAttributes function
NDescriptorGetName function
NDetectorScaleCount enumeration
NDetectorScaleCount_ enumeration
NDevice Unit
NDevice class
Children
DeviceType
DisplayName
Id
IsAvailable
IsDisconnectable
IsPrivate
Make
Model
NDeviceTypeNativeType
NativeType
Owner
Parent
Plugin
SerialNumber
about NDevice class
NDevice.ChildCollection class
about NDevice.ChildCollection class
NDevice.h
NDeviceEventDescriptor Unit
NDeviceEventDescriptor class
NativeType
about NDeviceEventDescriptor class
NDeviceEventDescriptor.h
NDeviceEventDescriptorCreate function
NDeviceGetChild function
NDeviceGetChildCount function
NDeviceGetChildren function
NDeviceGetDeviceType function
NDeviceGetDisplayNameN function
NDeviceGetIdN function
NDeviceGetMakeN function
NDeviceGetModelN function
NDeviceGetParent function
NDeviceGetPlugin function
NDeviceGetSerialNumberN function
NDeviceIsAvailable function
NDeviceIsDisconnectable function
NDeviceIsPrivate function
NDeviceManager Unit
NDeviceManager class
AutoPlug
BiometricEngine
ConnectToDevice
ConnectToDevice
DeviceTypes
Devices
DisconnectFromDevice
GetConnectToDeviceParameters
Initialize
IsConnectToDeviceSupported
IsInitialized
NDeviceManager
NativeType
PluginManager
about NDeviceManager class
NDeviceManager.DeviceCollection class
IndexOf
about NDeviceManager.DeviceCollection class
this
NDeviceManager.h
NDeviceManagerAddDevicesCollectionChanged function
NDeviceManagerAddDevicesCollectionChangedCallback function
NDeviceManagerConnectToDevice function
NDeviceManagerConnectToDeviceWithString function
NDeviceManagerCreateEx function
NDeviceManagerDeviceEventArgs class
Device
NDeviceManagerDeviceEventArgs
about NDeviceManagerDeviceEventArgs class
NDeviceManagerDisconnectFromDevice function
NDeviceManagerGetAutoPlug function
NDeviceManagerGetBiometricEngine function
NDeviceManagerGetConnectToDeviceParameters function
NDeviceManagerGetDevice function
NDeviceManagerGetDeviceById function
NDeviceManagerGetDeviceById macro
NDeviceManagerGetDeviceCount function
NDeviceManagerGetDeviceTypes function
NDeviceManagerGetDevices function
NDeviceManagerGetPluginManager function
NDeviceManagerInitialize function
NDeviceManagerIsConnectToDeviceSupported function
NDeviceManagerIsInitialized function
NDeviceManagerRemoveDevicesCollectionChanged function
NDeviceManagerRemoveDevicesCollectionChangedCallback function
NDeviceManagerSetAutoPlug function
NDeviceManagerSetBiometricEngine function
NDeviceManagerSetDeviceTypes function
NDeviceMethodDescriptor Unit
NDeviceMethodDescriptor class
NativeType
about NDeviceMethodDescriptor class
NDeviceMethodDescriptor.h
NDeviceMethodDescriptorCreate function
NDevicePropertyDescriptor Unit
NDevicePropertyDescriptor class
NativeType
about NDevicePropertyDescriptor class
NDevicePropertyDescriptor.h
NDevicePropertyDescriptorCreate function
NDeviceType enumeration
NDeviceType_ enumeration
NDevices Library
NDevices Unit
NDevices class
DllName
NativeModule
about NDevices class
NDictionary Unit
NDictionary class
Add
Add
Add
Clear
CollectionChanged
ContainsKey
CopyTo
CopyTo
Count
GetEnumerator
GetItemAt
IsReadOnly
Keys
NativeType
Remove
RemoveAt
ToArray
ToItemArray
TryGetValue
Values
about NDictionary class
this
this
NDictionary.KeyCollection class
ToItemArray
about NDictionary.KeyCollection class
NDictionary.ValueCollection class
ToItemArray
about NDictionary.ValueCollection class
NDictionary.h
NDictionaryAdd function
NDictionaryAddCollectionChanged function
NDictionaryAddCollectionChangedCallback function
NDictionaryAddItemCollectionChanged function
NDictionaryAddItemCollectionChangedCallback function
NDictionaryAddItemPair function
NDictionaryAddPair function
NDictionaryClear function
NDictionaryContains function
NDictionaryGet function
NDictionaryGetAt function
NDictionaryGetCount function
NDictionaryGetItemAt function
NDictionaryGetKey function
NDictionaryGetKeys function
NDictionaryGetValue function
NDictionaryGetValues function
NDictionaryInfo Unit
NDictionaryInfo class
AddCollectionChangedCallbackMethod
AddCollectionChangedMethod
AddMethod
AddPairMethod
ClearMethod
ContainsMethod
GetAtMethod
GetCountMethod
GetKeyMethod
GetMethod
GetValueMethod
ItemAttributes
ItemType
KeyAttributes
KeyFormat
KeyMaxValue
KeyMinValue
KeyStdValues
KeyType
NativeType
RemoveAtMethod
RemoveCollectionChangedCallbackMethod
RemoveCollectionChangedMethod
RemoveMethod
SetMethod
ToArrayMethod
ToKeyArrayMethod
ToValueArrayMethod
TryGetMethod
ValueAttributes
ValueFormat
ValueMaxValue
ValueMinValue
ValueStdValues
ValueType
about NDictionaryInfo class
NDictionaryInfo.KeyStdValueCollection class
about NDictionaryInfo.KeyStdValueCollection class
NDictionaryInfo.ValueStdValueCollection class
about NDictionaryInfo.ValueStdValueCollection class
NDictionaryInfo.h
NDictionaryInfoGetAddCollectionChangedCallbackMethod function
NDictionaryInfoGetAddCollectionChangedMethod function
NDictionaryInfoGetAddMethod function
NDictionaryInfoGetAddPairMethod function
NDictionaryInfoGetClearMethod function
NDictionaryInfoGetContainsMethod function
NDictionaryInfoGetGetAtMethod function
NDictionaryInfoGetGetCountMethod function
NDictionaryInfoGetGetKeyMethod function
NDictionaryInfoGetGetMethod function
NDictionaryInfoGetGetValueMethod function
NDictionaryInfoGetItemAttributes function
NDictionaryInfoGetItemType function
NDictionaryInfoGetKeyAttributes function
NDictionaryInfoGetKeyFormat function
NDictionaryInfoGetKeyMaxValue function
NDictionaryInfoGetKeyMinValue function
NDictionaryInfoGetKeyStdValue function
NDictionaryInfoGetKeyStdValueCount function
NDictionaryInfoGetKeyStdValues function
NDictionaryInfoGetKeyType function
NDictionaryInfoGetRemoveAtMethod function
NDictionaryInfoGetRemoveCollectionChangedCallbackMethod function
NDictionaryInfoGetRemoveCollectionChangedMethod function
NDictionaryInfoGetRemoveMethod function
NDictionaryInfoGetSetMethod function
NDictionaryInfoGetToArrayMethod function
NDictionaryInfoGetToKeyArrayMethod function
NDictionaryInfoGetToValueArrayMethod function
NDictionaryInfoGetTryGetMethod function
NDictionaryInfoGetValueAttributes function
NDictionaryInfoGetValueFormat function
NDictionaryInfoGetValueMaxValue function
NDictionaryInfoGetValueMinValue function
NDictionaryInfoGetValueStdValue function
NDictionaryInfoGetValueStdValueCount function
NDictionaryInfoGetValueStdValues function
NDictionaryInfoGetValueType function
NDictionaryIsReadOnly function
NDictionaryRemove function
NDictionaryRemoveAt function
NDictionaryRemoveCollectionChanged function
NDictionaryRemoveCollectionChangedCallback function
NDictionaryRemoveItemCollectionChanged function
NDictionaryRemoveItemCollectionChangedCallback function
NDictionarySet function
NDictionaryToArray function
NDictionaryToItemArray function
NDictionaryToKeyArray function
NDictionaryToValueArray function
NDictionaryTryGet function
NDirectory Unit
NDirectoryExists function
NDirectoryExists macro
NDisposable class
Dispose
IsDisposed
about NDisposable class
NDouble type
NDoubleGetNaN function
NDoubleGetNegativeInfinity function
NDoubleGetPositiveInfinity function
NDoubleIsInfinity function
NDoubleIsNaN function
NDoubleIsNegativeInfinity function
NDoubleIsPositiveInfinity function
NDoubleParse macro
NDoubleParseChars macro
NDoubleParseN function
NDoubleParseStrOrChars function
NDoubleParseStrOrChars macro
NDoubleParseVN function
NDoubleParseVN macro
NDoubleToChars function
NDoubleToChars macro
NDoubleToString function
NDoubleToString macro
NDoubleTryParse macro
NDoubleTryParseChars macro
NDoubleTryParseN function
NDoubleTryParseStrOrChars function
NDoubleTryParseStrOrChars macro
NDoubleTryParseVN function
NDoubleTryParseVN macro
NEImageType enumeration
NEImageType_ enumeration
NEPosition enumeration
NEPositionGetAvailableParts function
NEPositionIsKnown function
NEPositionIsLeft function
NEPositionIsOneOf function
NEPositionIsRight function
NEPositionIsRightAndLeft function
NEPositionIsSingleEye function
NEPositionIsTheEye function
NEPositionIsTwoEyes function
NEPositionIsValid function
NEPositionIsValidTheEye function
NEPosition_ enumeration
NE_IS_DIRECTORY_ACCESS macro
NE_MERGE_CALL_STACK macro
NE_NO_CALL_STACK macro
NE_PRESERVE_INNER_ERROR macro
NE_SKIP_ONE_FRAME macro
NEncoding Unit
NEncodingConvert function
NEncodingDetect function
NEncodingGetBytes function
NEncodingGetBytes macro
NEncodingGetBytesForChars function
NEncodingGetBytesForChars macro
NEncodingGetChars function
NEncodingGetChars macro
NEncodingGetMaxByteCount function
NEncodingGetMaxByteCount macro
NEncodingGetMaxCharCount function
NEncodingGetMaxCharCount macro
NEncodingGetMinBytesPerChar function
NEncodingGetPreamble function
NEncodingGetPreambleLength function
NEncodingGetStringN function
NEncodingIsSingleByte function
NEncodingIsValid function
NEncoding_ enumeration
NEnum Unit
NEnumConstantInfo Unit
NEnumConstantInfo class
NativeType
Value
about NEnumConstantInfo class
NEnumConstantInfo.h
NEnumConstantInfoGetValue function
NEnumGetValues function
NEnumParseN function
NEnumParseP function
NEnumToStringN function
NEnumToStringP function
NEnumTryParseN function
NEnumTryParseP function
NEnvironment Unit
NEnvironment.h
NEnvironmentGetCallStack function
NEnvironmentGetCurrentDirectory function
NEnvironmentGetSystemDirectory function
NError Unit
NError class
Get
Get
GetDefaultMessage
GetLast
GetMacErrorMessage
GetMessage
GetSysErrorMessage
SetLast
Suppress
ToString
about NError class
NError.h
NErrorAppend function
NErrorAppend macro
NErrorCapture function
NErrorCreate function
NErrorGetCallStackCount function
NErrorGetCallStackEntry function
NErrorGetCallStackN function
NErrorGetCodeEx function
NErrorGetDefaultMessageN function
NErrorGetExternalCallStackN function
NErrorGetExternalErrorEx function
NErrorGetInnerErrorAt function
NErrorGetInnerErrorCount function
NErrorGetInnerErrorEx function
NErrorGetLastEx function
NErrorGetLastSysError function
NErrorGetLastWin32Error function
NErrorGetMacErrorMessageN function
NErrorGetMachErrorMessageN function
NErrorGetMessageN function
NErrorGetParamN function
NErrorGetSysErrorMessageN function
NErrorGetWin32ErrorMessageN function
NErrorRaise function
NErrorReport function
NErrorReportEx function
NErrorSetCom function
NErrorSetCom macro
NErrorSetComMPN function
NErrorSetComMPN macro
NErrorSetComN function
NErrorSetComPN function
NErrorSetComPN macro
NErrorSetLast function
NErrorSetLast macro
NErrorSetLastEx function
NErrorSetLastMPN function
NErrorSetLastMPN macro
NErrorSetLastN function
NErrorSetLastPN function
NErrorSetLastPN macro
NErrorSetMac function
NErrorSetMac macro
NErrorSetMacMPN function
NErrorSetMacMPN macro
NErrorSetMacN function
NErrorSetMacPN function
NErrorSetMacPN macro
NErrorSetMach function
NErrorSetMach macro
NErrorSetMachMPN function
NErrorSetMachMPN macro
NErrorSetMachN function
NErrorSetMachPN function
NErrorSetMachPN macro
NErrorSetSys function
NErrorSetSys macro
NErrorSetSysMPN function
NErrorSetSysMPN macro
NErrorSetSysN function
NErrorSetSysPN function
NErrorSetSysPN macro
NErrorSetWin32 function
NErrorSetWin32 macro
NErrorSetWin32MPN function
NErrorSetWin32MPN macro
NErrorSetWin32N function
NErrorSetWin32PN function
NErrorSetWin32PN macro
NErrorSuppress function
NEvent Unit
NEvent.h
NEventAdd macro
NEventAddN function
NEventAddRaw function
NEventDescriptor Unit
NEventDescriptor.h
NEventDescriptorAddHandler function
NEventDescriptorGetEventType function
NEventDescriptorRemoveHandler function
NEventDispose function
NEventGetCallbacks function
NEventInfo Unit
NEventInfo class
AddCallbackMethod
AddHandler
AddMethod
EventType
NativeType
RemoveCallbackMethod
RemoveHandler
RemoveMethod
about NEventInfo class
NEventInfo.h
NEventInfoAddHandler function
NEventInfoGetAddCallbackMethod function
NEventInfoGetAddMethod function
NEventInfoGetEventType function
NEventInfoGetRemoveCallbackMethod function
NEventInfoGetRemoveMethod function
NEventInfoRemoveHandler function
NEventInit function
NEventIsEmpty function
NEventReleaseCallbacks function
NEventRemove macro
NEventRemoveN function
NEventRemoveRaw function
NExpandableObject Unit
NExpandableObject class
NativeType
Properties
about NExpandableObject class
NExpandableObject.h
NExpandableObjectGetProperties function
NFCore structure
Angle
AngleDeg
NFCore
NFCore
NFCore
NativeType
RawAngle
ToString
ToString
X
Y
about NFCore structure
NFCoreToString function
NFCoreToString macro
NFDelta structure
Angle1
Angle2
Angle3
AngleDeg1
AngleDeg2
AngleDeg3
NFDelta
NFDelta
NFDelta
NativeType
RawAngle1
RawAngle2
RawAngle3
ToString
ToString
X
Y
about NFDelta structure
NFDeltaToString function
NFDeltaToString macro
NFDoubleCore structure
NFDoubleCore
NativeType
ToString
ToString
X
Y
about NFDoubleCore structure
NFDoubleCoreToString function
NFDoubleCoreToString macro
NFImpressionType enumeration
NFImpressionTypeIsCompatibleWith function
NFImpressionTypeIsContact function
NFImpressionTypeIsContactless function
NFImpressionTypeIsFinger function
NFImpressionTypeIsGeneric function
NFImpressionTypeIsLatent function
NFImpressionTypeIsLiveScan function
NFImpressionTypeIsNonOptical function
NFImpressionTypeIsNonliveScan function
NFImpressionTypeIsOneOf function
NFImpressionTypeIsOptical function
NFImpressionTypeIsPalm function
NFImpressionTypeIsPlain function
NFImpressionTypeIsRolled function
NFImpressionTypeIsSwipe function
NFImpressionTypeIsValid function
NFImpressionTypeIsValidFinger function
NFImpressionTypeIsValidPalm function
NFImpressionTypeToFinger function
NFImpressionType_ enumeration
NFMinutia structure
Angle
AngleDeg
Curvature
G
NFMinutia
NFMinutia
NFMinutia
NFMinutia
NativeType
Quality
RawAngle
ToString
ToString
Type
X
Y
about NFMinutia structure
NFMinutiaNeighbor structure
Empty
Index
NFMinutiaNeighbor
NativeType
RidgeCount
ToString
ToString
about NFMinutiaNeighbor structure
NFMinutiaNeighborToString function
NFMinutiaNeighborToString macro
NFMinutiaToString function
NFMinutiaToString macro
NFPatternClassIsValid function
NFPatternClassIsValidForPosition function
NFPosition enumeration
NFPositionGetAvailableParts function
NFPositionIsCompatibleWith function
NFPositionIsCompatibleWithImpressionType function
NFPositionIsFinger function
NFPositionIsFourFingers function
NFPositionIsKnown function
NFPositionIsLeft function
NFPositionIsLeftAndRight function
NFPositionIsOneOf function
NFPositionIsPalm function
NFPositionIsRight function
NFPositionIsSingleFinger function
NFPositionIsTheFinger function
NFPositionIsThePalm function
NFPositionIsThreeFingers function
NFPositionIsTwoFingers function
NFPositionIsValid function
NFPositionIsValidFinger function
NFPositionIsValidPalm function
NFPositionIsValidTheFinger function
NFPosition_ enumeration
NFace Unit
NFace class
FromImageAndAttributes
GetImage
Image
NFace
NativeType
Objects
about NFace class
NFace.ObjectCollection class
about NFace.ObjectCollection class
NFace.h
NFaceAddObjectsCollectionChanged function
NFaceAddObjectsCollectionChangedCallback function
NFaceCreate function
NFaceFromImageAndAttributes function
NFaceGetImage function
NFaceGetObject function
NFaceGetObjectCount function
NFaceGetObjects function
NFaceRemoveObjectsCollectionChanged function
NFaceRemoveObjectsCollectionChangedCallback function
NFaceSetImage function
NFailed macro
NFalse macro
NFile Unit
NFileAccess enumeration
NFileAccessIsValid function
NFileAccess_ enumeration
NFileAppendAllLines function
NFileAppendAllLinesPN function
NFileAppendAllLinesWithEncoding function
NFileAppendAllLinesWithEncodingPN function
NFileAppendAllText function
NFileAppendAllText macro
NFileAppendAllTextPN function
NFileAppendAllTextPN macro
NFileAppendAllTextWithEncoding function
NFileAppendAllTextWithEncoding macro
NFileAppendAllTextWithEncodingPN function
NFileAppendAllTextWithEncodingPN macro
NFileAppendText function
NFileAppendText macro
NFileAttributes enumeration
NFileAttributes_ enumeration
NFileCreate function
NFileCreate macro
NFileCreateText function
NFileCreateText macro
NFileCreateWithBufferSize function
NFileCreateWithBufferSize macro
NFileDelete function
NFileDelete macro
NFileExists function
NFileExists macro
NFileGetAttributes function
NFileGetAttributes macro
NFileMode enumeration
NFileModeIsValid function
NFileMode_ enumeration
NFileOpen function
NFileOpen macro
NFileOpenRead function
NFileOpenRead macro
NFileOpenText function
NFileOpenText macro
NFileOpenWithAccess function
NFileOpenWithAccess macro
NFileOpenWithAccessAndShare function
NFileOpenWithAccessAndShare macro
NFileOpenWrite function
NFileOpenWrite macro
NFileReadAllBytesCN function
NFileReadAllBytesCN macro
NFileReadAllBytesN function
NFileReadAllLinesCN function
NFileReadAllLinesCN macro
NFileReadAllLinesN function
NFileReadAllLinesWithEncodingCN function
NFileReadAllLinesWithEncodingCN macro
NFileReadAllLinesWithEncodingN function
NFileReadAllTextCN function
NFileReadAllTextCN macro
NFileReadAllTextN function
NFileReadAllTextWithEncodingCN function
NFileReadAllTextWithEncodingCN macro
NFileReadAllTextWithEncodingN function
NFileShare enumeration
NFileShareIsValid function
NFileShare_ enumeration
NFileStream Unit
NFileStreamCreate function
NFileStreamCreate macro
NFileStreamCreateFromOSHandle function
NFileStreamCreateFromOSHandleWithBufferSize function
NFileStreamCreateWithAccess function
NFileStreamCreateWithAccess macro
NFileStreamCreateWithAccessAndShare function
NFileStreamCreateWithAccessAndShare macro
NFileStreamCreateWithAccessShareAndBufferSize function
NFileStreamCreateWithAccessShareAndBufferSize macro
NFileStreamGetOSHandle function
NFileWriteAllBytes function
NFileWriteAllBytes macro
NFileWriteAllBytesCN function
NFileWriteAllBytesCN macro
NFileWriteAllBytesPN function
NFileWriteAllLines function
NFileWriteAllLines macro
NFileWriteAllLinesPN function
NFileWriteAllLinesPN macro
NFileWriteAllLinesWithEncoding function
NFileWriteAllLinesWithEncoding macro
NFileWriteAllLinesWithEncodingPN function
NFileWriteAllLinesWithEncodingPN macro
NFileWriteAllText function
NFileWriteAllText macro
NFileWriteAllTextCN function
NFileWriteAllTextPN function
NFileWriteAllTextPN macro
NFileWriteAllTextWithEncoding function
NFileWriteAllTextWithEncoding macro
NFileWriteAllTextWithEncodingPN function
NFileWriteAllTextWithEncodingPN macro
NFill function
NFloat type
NFree function
NFreeEx function
NGender enumeration
NGender_ enumeration
NGeometry Unit
NGeometry class
InterpolationModeNativeType
NativeType
PointDNativeType
PointFNativeType
PointNativeType
RectangleDNativeType
RectangleFNativeType
RectangleNativeType
SizeDNativeType
SizeFNativeType
SizeNativeType
about NGeometry class
NGeometry.h
NGpuIndex enumeration
NGpuIndex_ enumeration
NGpuJpegEncoder Unit
NGpuJpegEncoder class
CompressionQuality
Encode
GpuIndex
NativeType
ScaleAndEncode
about NGpuJpegEncoder class
NGpuJpegEncoderCreate function
NGpuJpegEncoderEncode function
NGpuJpegEncoderScaleAndEncode function
NGuidParse function
NGuidParse macro
NGuidParseVN function
NGuidParseVN macro
NGuidToString function
NGuidToString macro
NGuidTryParse function
NGuidTryParse macro
NGuidTryParseVN function
NGuidTryParseVN macro
NHandle type
NIOTypes Unit
NIOTypes.h
NIcaoWarnings enumeration
NIcaoWarnings_ enumeration
NImage class
Copy
Copy
Copy
Copy
Copy
CopyFrom
CopyFrom
CopyFrom
CopyFrom
CopyFrom
CopyFromYCbCrData
CopyTo
CopyTo
CopyTo
CopyTo
CopyTo
CopyTo
Create
Create
Crop
ExportPalette
FlagAllDst
FlagAllDstAndSrc
FlagAllSrc
FlagDstAlphaChannelFirst
FlagDstBottomToTop
FlagDstSwapChannels
FlagReadUnknownImage
FlagSrcAlphaChannelFirst
FlagSrcBottomToTop
FlagSrcSwapChannels
FlagWriteUnknownImage
FlipDiagonally
FlipHorizontally
FlipVertically
FromData
FromData
FromData
FromData
FromData
FromFile
FromFile
FromFile
FromImage
FromImage
FromImage
FromImage
FromMemory
FromMemory
FromMemory
FromMemory
FromMemory
FromStream
FromStream
FromStream
FromVideoSample
FromVideoSample
GetIndex
GetPixel
GetPixels
GetSupportedVideoSubtypes
GetWrapper
GetWrapper
GetWrapper
GetWrapper
GetWrapper
GetWrapper
GetWrapper
Height
HorzResolution
ImageSize
Info
IsVideoFormatSupported
IsVideoSubtypeSupported
LongImageSize
LongPlaneSize
LongStride
MaxValue
MinValue
NativeImageSize
NativePlaneSize
NativeStride
NativeType
Palette
PixelFormat
PlaneSize
Planes
ResolutionIsAspectRatio
RotateFlip
Save
Save
Save
Save
Save
Save
Save
Save
Save
Save
SetIndex
SetPixel
Stride
VertResolution
Width
about NImage class
NImage.ImagePalette class
EntriesSize
GetEntries
NativeEntriesSize
SetEntries
about NImage.ImagePalette class
NImage.PlaneCollection class
about NImage.PlaneCollection class
NImageCompressionAlgorithm enumeration
NImageCompressionAlgorithm_ enumeration
NImageFormat class
Bmp
CanRead
CanWrite
CanWriteMultiple
CreateInfo
CreateInfo
DefaultFileExtension
DefaultInternetMediaType
FileFilter
Formats
Gif
IHead
InternetMediaType
Jpeg
Jpeg2K
Name
NativeType
OpenReader
OpenReader
OpenReader
OpenReader
OpenReader
OpenReader
OpenWriter
OpenWriter
OpenWriter
OpenWriter
OpenWriter
OpenWriter
Png
Select
SelectByInternetMediaType
SelectReader
SelectReader
SelectReader
SelectReader
SelectReader
SelectReader
Tiff
WebP
Wsq
about NImageFormat class
NImageFormat.ImageFormatCollection class
about NImageFormat.ImageFormatCollection class
NImageInfo Unit
NImageInfo class
Format
Height
NImageInfo
NImageRotateFlipTypeNativeType
NativeType
Transform
Width
about NImageInfo class
NImageInfo.h
NImageInfoCreate function
NImageInfoGetFormatEx function
NImageInfoGetHeight function
NImageInfoGetTransform function
NImageInfoGetWidth function
NImageInfoSetTransform function
NImageReader Unit
NImageReader class
Format
NativeType
Read
Read
ReadInfo
ReadInfo
ReadSize
about NImageReader class
NImageReader.h
NImageReaderGetFormatEx function
NImageReaderGetReadSize function
NImageReaderRead function
NImageReaderReadInfo function
NImageRotateFlipType enumeration
NImageRotateFlipTypeCreate function
NImageRotateFlipTypeFlipTypeIsValid function
NImageRotateFlipTypeGetFlipType function
NImageRotateFlipTypeGetRotateType function
NImageRotateFlipTypeIsValid function
NImageRotateFlipTypeMinimizeFlip function
NImageRotateFlipTypeMinimizeRotation function
NImageRotateFlipTypeRotateTypeIsValid function
NImageRotateFlipType_ enumeration
NImageWriter Unit
NImageWriter class
Format
GetBuffer
NativeType
Write
about NImageWriter class
NImageWriter.h
NImageWriterGetBuffer function
NImageWriterGetFormatEx function
NImageWriterWrite function
NImages Unit
NImages class
GetGrayscaleColorWrapper
GetOpenFileFilter
GetOpenFileFilterString
GetSaveFileFilter
GetSaveFileFilterString
NativeType
RecolorImage
about NImages class
NImages.h
NImagesGetGrayscaleColorWrapperEx function
NImagesRecolorImage function
NIndexPair structure
Index1
Index2
NIndexPair
NativeType
ToString
ToString
about NIndexPair structure
NIndexPair type
NIndexPairToString function
NIndexPairToString macro
NIndexPair_ structure
NInt type
NInt16 type
NInt16Parse macro
NInt16ParseChars macro
NInt16ParseN function
NInt16ParseStrOrChars function
NInt16ParseStrOrChars macro
NInt16ParseVN function
NInt16ParseVN macro
NInt16ToChars function
NInt16ToChars macro
NInt16ToString function
NInt16ToString macro
NInt16TryParse macro
NInt16TryParseChars macro
NInt16TryParseN function
NInt16TryParseStrOrChars function
NInt16TryParseStrOrChars macro
NInt16TryParseVN function
NInt16TryParseVN macro
NInt32 type
NInt32Parse macro
NInt32ParseChars macro
NInt32ParseN function
NInt32ParseStrOrChars function
NInt32ParseStrOrChars macro
NInt32ParseVN function
NInt32ParseVN macro
NInt32ToChars function
NInt32ToChars macro
NInt32ToString function
NInt32ToString macro
NInt32TryParse macro
NInt32TryParseChars macro
NInt32TryParseN function
NInt32TryParseStrOrChars function
NInt32TryParseStrOrChars macro
NInt32TryParseVN function
NInt32TryParseVN macro
NInt64 type
NInt64Parse macro
NInt64ParseChars macro
NInt64ParseN function
NInt64ParseStrOrChars function
NInt64ParseStrOrChars macro
NInt64ParseVN function
NInt64ParseVN macro
NInt64ToChars function
NInt64ToChars macro
NInt64ToString function
NInt64ToString macro
NInt64TryParse macro
NInt64TryParseChars macro
NInt64TryParseN function
NInt64TryParseStrOrChars function
NInt64TryParseStrOrChars macro
NInt64TryParseVN function
NInt64TryParseVN macro
NInt8 type
NInt8Parse macro
NInt8ParseChars macro
NInt8ParseN function
NInt8ParseStrOrChars function
NInt8ParseStrOrChars macro
NInt8ParseVN function
NInt8ParseVN macro
NInt8ToChars function
NInt8ToChars macro
NInt8ToString function
NInt8ToString macro
NInt8TryParse macro
NInt8TryParseChars macro
NInt8TryParseN function
NInt8TryParseStrOrChars function
NInt8TryParseStrOrChars macro
NInt8TryParseVN function
NInt8TryParseVN macro
NInterlocked Unit
NInterpolationMode enumeration
NInterpolationMode_ enumeration
NKeyValuePairCopy function
NKeyValuePairCreate function
NKeyValuePairDispose function
NKeyValuePairSet function
NKeyValuePair_ structure
Create
Dispose
ToStruct
about NKeyValuePair_ structure
hKey
hValue
NLAttributes Unit
NLAttributes class
AdditionalFacesDetected
Age
BackgroundUniformity
BaseFrameIndex
BeardConfidence
BlinkConfidence
BoundingRect
Contrast
DarkGlassesConfidence
EmotionAngerConfidence
EmotionContemptConfidence
EmotionDisgustConfidence
EmotionFearConfidence
EmotionHappinessConfidence
EmotionNeutralConfidence
EmotionSadnessConfidence
EmotionSurpriseConfidence
EthnicityArabianConfidence
EthnicityAsianConfidence
EthnicityBlackConfidence
EthnicityHispanicConfidence
EthnicityIndianConfidence
EthnicityWhiteConfidence
Expression
ExpressionConfidence
FaceDarknessConfidence
FaceMaskConfidence
FeaturePoints
Gender
GenderConfidence
GlassesConfidence
GlassesReflectionConfidence
GrayscaleDensity
HatConfidence
HeavyFrameConfidence
IcaoWarnings
LeftEyeCenter
LivenessAction
LivenessScore
LivenessTargetPitch
LivenessTargetYaw
LookingAwayConfidence
MocTemplate
MouthCenter
MouthOpenConfidence
MustacheConfidence
NLAttributes
NativeType
Noise
NoseTip
Owner
Pitch
PixelationConfidence
Properties
RedEyeConfidence
RightEyeCenter
Roll
Saturation
Sharpness
SkinReflectionConfidence
Template
Thumbnail
TokenImageRect
UnnaturalSkinToneConfidence
WashedOutConfidence
Yaw
about NLAttributes class
NLAttributes.FeaturePointCollection class
about NLAttributes.FeaturePointCollection class
NLAttributes.h
NLAttributesAddFeaturePoint function
NLAttributesClearFeaturePoints function
NLAttributesCreate function
NLAttributesGetAdditionalFacesDetected function
NLAttributesGetAge function
NLAttributesGetBackgroundUniformity function
NLAttributesGetBaseFrameIndex function
NLAttributesGetBeardConfidence function
NLAttributesGetBlinkConfidence function
NLAttributesGetBoundingRect function
NLAttributesGetContrast function
NLAttributesGetDarkGlassesConfidence function
NLAttributesGetEmotionAngerConfidence function
NLAttributesGetEmotionContemptConfidence function
NLAttributesGetEmotionDisgustConfidence function
NLAttributesGetEmotionFearConfidence function
NLAttributesGetEmotionHappinessConfidence function
NLAttributesGetEmotionNeutralConfidence function
NLAttributesGetEmotionSadnessConfidence function
NLAttributesGetEmotionSurpriseConfidence function
NLAttributesGetEthnicityArabianConfidence function
NLAttributesGetEthnicityAsianConfidence function
NLAttributesGetEthnicityBlackConfidence function
NLAttributesGetEthnicityHispanicConfidence function
NLAttributesGetEthnicityIndianConfidence function
NLAttributesGetEthnicityWhiteConfidence function
NLAttributesGetExpression function
NLAttributesGetExpressionConfidence function
NLAttributesGetFaceDarknessConfidence function
NLAttributesGetFaceMaskConfidence function
NLAttributesGetFeaturePoint function
NLAttributesGetFeaturePointCapacity function
NLAttributesGetFeaturePointCount function
NLAttributesGetFeaturePoints function
NLAttributesGetGender function
NLAttributesGetGenderConfidence function
NLAttributesGetGlassesConfidence function
NLAttributesGetGlassesReflectionConfidence function
NLAttributesGetGrayscaleDensity function
NLAttributesGetHatConfidence function
NLAttributesGetHeavyFrameConfidence function
NLAttributesGetIcaoWarnings function
NLAttributesGetLeftEyeCenter function
NLAttributesGetLivenessAction function
NLAttributesGetLivenessScore function
NLAttributesGetLivenessTargetPitch function
NLAttributesGetLivenessTargetYaw function
NLAttributesGetLookingAwayConfidence function
NLAttributesGetMocTemplate function
NLAttributesGetMouthCenter function
NLAttributesGetMouthOpenConfidence function
NLAttributesGetMustacheConfidence function
NLAttributesGetNoise function
NLAttributesGetNoseTip function
NLAttributesGetPitch function
NLAttributesGetPixelationConfidence function
NLAttributesGetProperties function
NLAttributesGetRedEyeConfidence function
NLAttributesGetRightEyeCenter function
NLAttributesGetRoll function
NLAttributesGetSaturation function
NLAttributesGetSharpness function
NLAttributesGetSkinReflectionConfidence function
NLAttributesGetTemplate function
NLAttributesGetThumbnail function
NLAttributesGetTokenImageRect function
NLAttributesGetUnnaturalSkinToneConfidence function
NLAttributesGetWashedOutConfidence function
NLAttributesGetYaw function
NLAttributesInsertFeaturePoint function
NLAttributesRemoveFeaturePointAt function
NLAttributesSetAdditionalFacesDetected function
NLAttributesSetAge function
NLAttributesSetBackgroundUniformity function
NLAttributesSetBaseFrameIndex function
NLAttributesSetBeardConfidence function
NLAttributesSetBlinkConfidence function
NLAttributesSetBoundingRect function
NLAttributesSetContrast function
NLAttributesSetDarkGlassesConfidence function
NLAttributesSetEmotionAngerConfidence function
NLAttributesSetEmotionContemptConfidence function
NLAttributesSetEmotionDisgustConfidence function
NLAttributesSetEmotionFearConfidence function
NLAttributesSetEmotionHappinessConfidence function
NLAttributesSetEmotionNeutralConfidence function
NLAttributesSetEmotionSadnessConfidence function
NLAttributesSetEmotionSurpriseConfidence function
NLAttributesSetEthnicityArabianConfidence function
NLAttributesSetEthnicityAsianConfidence function
NLAttributesSetEthnicityBlackConfidence function
NLAttributesSetEthnicityHispanicConfidence function
NLAttributesSetEthnicityIndianConfidence function
NLAttributesSetEthnicityWhiteConfidence function
NLAttributesSetExpression function
NLAttributesSetExpressionConfidence function
NLAttributesSetFaceDarknessConfidence function
NLAttributesSetFaceMaskConfidence function
NLAttributesSetFeaturePoint function
NLAttributesSetFeaturePointCapacity function
NLAttributesSetGender function
NLAttributesSetGenderConfidence function
NLAttributesSetGlassesConfidence function
NLAttributesSetGlassesReflectionConfidence function
NLAttributesSetGrayscaleDensity function
NLAttributesSetHatConfidence function
NLAttributesSetHeavyFrameConfidence function
NLAttributesSetIcaoWarnings function
NLAttributesSetLeftEyeCenter function
NLAttributesSetLookingAwayConfidence function
NLAttributesSetMouthCenter function
NLAttributesSetMouthOpenConfidence function
NLAttributesSetMustacheConfidence function
NLAttributesSetNoise function
NLAttributesSetNoseTip function
NLAttributesSetPitch function
NLAttributesSetPixelationConfidence function
NLAttributesSetProperties function
NLAttributesSetRedEyeConfidence function
NLAttributesSetRightEyeCenter function
NLAttributesSetRoll function
NLAttributesSetSaturation function
NLAttributesSetSharpness function
NLAttributesSetSkinReflectionConfidence function
NLAttributesSetTemplate function
NLAttributesSetThumbnail function
NLAttributesSetTokenImageRect function
NLAttributesSetUnnaturalSkinToneConfidence function
NLAttributesSetWashedOutConfidence function
NLAttributesSetYaw function
NLExpression enumeration
NLExpression_ enumeration
NLFeaturePoint structure
Code
Confidence
NLFeaturePoint
NLFeaturePoint
NativeType
ToString
ToString
X
Y
about NLFeaturePoint structure
NLFeaturePoint type
NLFeaturePointToString function
NLFeaturePointToString macro
NLFeaturePoint_ structure
NLMatchingDetails Unit
NLMatchingDetails class
NativeType
about NLMatchingDetails class
NLMatchingDetails.h
NLProperties enumeration
NLProperties_ enumeration
NLRecord Unit
NLRecord class
CbeffProductType
Check
Check
GetQuality
GetQuality
GetSize
GetSize
NLRecord
NLRecord
NLRecord
NLRecord
NLRecord
NLRecord
NLRecord
NLRecord
NativeType
Quality
about NLRecord class
NLRecord.h
NLRecordCheck function
NLRecordCreate function
NLRecordCreateFromMemory function
NLRecordCreateFromNLRecord function
NLRecordGetCbeffProductType function
NLRecordGetCbeffProductTypeMem function
NLRecordGetQuality function
NLRecordGetQualityMem function
NLRecordGetSizeMem function
NLRecordSetCbeffProductType function
NLRecordSetQuality function
NLT_MAX_RECORD_COUNT macro
NLT_PROCESS_FIRST_RECORD_ONLY macro
NLTemplate Unit
NLTemplate class
CalculateSize
Check
Check
FlagProcessFirstRecordOnly
GetRecordCount
GetRecordCount
GetSize
GetSize
MaxRecordCount
NLTemplate
NLTemplate
NLTemplate
NLTemplate
NLTemplate
NLTemplate
NativeType
Records
about NLTemplate class
NLTemplate.RecordCollection class
about NLTemplate.RecordCollection class
NLTemplate.h
NLTemplateAddRecordEx function
NLTemplateCalculateSize function
NLTemplateCheck function
NLTemplateClearRecords function
NLTemplateCreateEx function
NLTemplateCreateFromMemory function
NLTemplateGetRecordCapacity function
NLTemplateGetRecordCount function
NLTemplateGetRecordCountMem function
NLTemplateGetRecordEx function
NLTemplateGetSizeMem function
NLTemplateInsertRecord function
NLTemplatePack function
NLTemplateRemoveRecordAt function
NLTemplateSetRecord function
NLTemplateSetRecordCapacity function
NLTemplateUnpack function
NLicManFindFirstDongle function
NLicManFindNextDongle function
NLicManGenerateLicenseExN function
NLicManGenerateLicenseN function
NLicManGenerateSerialExN function
NLicManGenerateSerialN function
NLicManGetClientId function
NLicManGetDongles function
NLicManGetLicenseData function
NLicManGetLicenseData macro
NLicManGetLicenseDataEx function
NLicManGetLicenseDataEx macro
NLicManGetLongProductNameForProductInfoN function
NLicManGetLongProductNameN function
NLicManGetProductIds function
NLicManGetProxyHost function
NLicManGetProxyPassword function
NLicManGetProxyPort function
NLicManGetProxyUsername function
NLicManGetShortProductNameForProductInfoN function
NLicManGetShortProductNameN function
NLicManGetTrialMode function
NLicManGetUpdateTicketInfo function
NLicManGetUpdateTicketInfo macro
NLicManGetUseHttps function
NLicManGetWritableStoragePath function
NLicManInitialize function
NLicManIsLicenseTypeSupported function
NLicManSetClientIdN function
NLicManSetProxyHostN function
NLicManSetProxyPasswordN function
NLicManSetProxyPort function
NLicManSetProxyUsernameN function
NLicManSetTrialMode function
NLicManSetUseHttps function
NLicManSetWritableStoragePathN function
NLicense Unit
NLicense class
ActivateOnline
Add
Add
Add
DeactivateOnline
DeactivateOnline
DeactivateOnlineWithId
GenerateDeactivationId
GenerateDeactivationId
GenerateDeactivationIdForLicense
GenerateDeactivationIdForLicense
GenerateId
GenerateId
GetLicenseInfoOnline
GetObtainedLicenseInfo
GetObtainedLicenseInfoForComponent
GetObtainedStatus
IsComponentActivated
NativeType
Obtain
Obtain
ObtainComponents
ObtainComponents
Release
ReleaseComponents
about NLicense class
NLicense.h
NLicenseActivateOnline function
NLicenseActivateOnline macro
NLicenseAdd function
NLicenseAdd macro
NLicenseDeactivateOnline function
NLicenseDeactivateOnline macro
NLicenseDeactivateOnlineWithId function
NLicenseDeactivateOnlineWithId macro
NLicenseGenerateDeactivationId function
NLicenseGenerateDeactivationId macro
NLicenseGenerateDeactivationIdForLicense function
NLicenseGenerateDeactivationIdForLicense macro
NLicenseGenerateId function
NLicenseGenerateId macro
NLicenseGetLicenseInfoOnline function
NLicenseGetLicenseInfoOnline macro
NLicenseGetObtainedComponentStatus function
NLicenseGetObtainedComponentStatus macro
NLicenseGetObtainedLicenseInfo function
NLicenseGetObtainedLicenseInfo macro
NLicenseGetObtainedLicenseInfoForComponent function
NLicenseGetObtainedLicenseInfoForComponent macro
NLicenseGetObtainedStatus function
NLicenseGetObtainedStatus macro
NLicenseInfo Unit
NLicenseInfo class
DistributorId
GetLicenses
LicenseId
NativeType
SequenceNumber
SourceType
Status
Type
about NLicenseInfo class
NLicenseInfoGetDistributorId function
NLicenseInfoGetLicenseId function
NLicenseInfoGetLicenses function
NLicenseInfoGetSequenceNumber function
NLicenseInfoGetSourceType function
NLicenseInfoGetStatus function
NLicenseInfoGetType function
NLicenseInfoSourceType enumeration
NLicenseInfoSourceType_ enumeration
NLicenseInfoStatus enumeration
NLicenseInfoStatus_ enumeration
NLicenseInfoType enumeration
NLicenseInfoType_ enumeration
NLicenseIsComponentActivated function
NLicenseIsComponentActivated macro
NLicenseManager Unit
NLicenseManager class
ClientId
FindFirstDongle
FindNextDongle
GenerateLicense
GenerateLicenseEx
GenerateSerial
GenerateSerialEx
GetDongles
GetLicenseData
GetLicenseDataEx
GetLongProductName
GetLongProductName
GetProductIds
GetShortProductName
GetShortProductName
GetUpdateTicketInfo
IsLicenseTypeSupported
NLicenseTypeNativeType
NativeType
ProxyHost
ProxyPort
TrialMode
UseHttps
WritableStoragePath
about NLicenseManager class
NLicenseObtain function
NLicenseObtainComponents function
NLicenseObtainComponents macro
NLicenseObtainedStatus enumeration
NLicenseObtainedStatus_ enumeration
NLicensePlate Unit
NLicensePlate class
BoundingBox
CharacterHeight
DetectionConfidence
FrameIndex
NativeType
OcrConfidence
Origin
Rectangle
Region
Rotation
Type
Value
about NLicensePlate class
NLicensePlateDetails class
Best
Current
NativeType
about NLicensePlateDetails class
NLicensePlateDetails.BestLicensePlateCollection class
about NLicensePlateDetails.BestLicensePlateCollection class
NLicensePlateDetails.CurrentLicensePlateCollection class
about NLicensePlateDetails.CurrentLicensePlateCollection class
NLicensePlateDetailsGetBestLicensePlate function
NLicensePlateDetailsGetBestLicensePlateCount function
NLicensePlateDetailsGetBestLicensePlates function
NLicensePlateDetailsGetCurrentLicensePlate function
NLicensePlateDetailsGetCurrentLicensePlateCount function
NLicensePlateDetailsGetCurrentLicensePlates function
NLicensePlateGetBoundingBox function
NLicensePlateGetDetectionConfidence function
NLicensePlateGetFrameIndex function
NLicensePlateGetOcrConfidence function
NLicensePlateGetOrigin function
NLicensePlateGetRectangle function
NLicensePlateGetRotation function
NLicensePlateGetType function
NLicensePlateGetValue function
NLicenseProductInfo class
Id
LicenseCount
LicenseType
NativeType
OSFamily
Parameters
about NLicenseProductInfo class
NLicenseProductInfoGetId function
NLicenseProductInfoGetLicenseCount function
NLicenseProductInfoGetLicenseType function
NLicenseProductInfoGetOSFamily function
NLicenseProductInfoGetParameters function
NLicenseRelease function
NLicenseReleaseComponents function
NLicenseReleaseComponents macro
NLicenseType enumeration
NLicenseType_ enumeration
NLicensing Library
NLicensing Unit
NLicensing class
DllName
NativeModule
about NLicensing class
NLicensing.h
NLicensingService Unit
NLicensingService class
GetBinPath
GetConfPath
GetStatus
Install
Install
IsTrial
NLicensingServiceStatusNativeType
NativeType
Start
Stop
Uninstall
about NLicensingService class
NLicensingServiceGetBinPath function
NLicensingServiceGetConfPath function
NLicensingServiceGetStatus function
NLicensingServiceInstall function
NLicensingServiceInstall macro
NLicensingServiceIsTrial function
NLicensingServiceStart function
NLicensingServiceStatus enumeration
NLicensingServiceStatus_ enumeration
NLicensingServiceStop function
NLicensingServiceUninstall function
NList Unit
NList.h
NListAdd function
NListAddList function
NListAddRange function
NListClear function
NListContains function
NListCopyTo function
NListCopyToRange function
NListDetachArray function
NListDispose function
NListGet function
NListGetCapacity function
NListGetCount function
NListGetEnd function
NListGetPtr function
NListGetStart function
NListIndexOf function
NListIndexOfFrom function
NListIndexOfInRange function
NListInit function
NListInitEx function
NListInitWithCapacity function
NListInsert function
NListInsertList function
NListInsertRange function
NListLastIndexOf function
NListLastIndexOfFrom function
NListLastIndexOfInRange function
NListList Unit
NListList.h
NListListAdd function
NListListAddItem function
NListListAddItemRange function
NListListAddListList function
NListListAddListListItems function
NListListAddRange function
NListListClear function
NListListClearItems function
NListListContainsItem function
NListListCopyItemsTo function
NListListCopyItemsToRange function
NListListDetachItemsArray function
NListListDispose function
NListListGetCapacity function
NListListGetCount function
NListListGetItem function
NListListGetItemCapacity function
NListListGetItemCount function
NListListGetItemPtr function
NListListGetItemsEnd function
NListListGetItemsStart function
NListListIndexOfItem function
NListListIndexOfItemFrom function
NListListIndexOfItemInRange function
NListListInit function
NListListInitEx function
NListListInitWithCapacity function
NListListInsert function
NListListInsertItem function
NListListInsertItemRange function
NListListInsertListList function
NListListInsertListListItems function
NListListInsertRange function
NListListItemsToArray function
NListListItemsToArrayRange function
NListListLastIndexOfItem function
NListListLastIndexOfItemFrom function
NListListLastIndexOfItemInRange function
NListListRemoveAt function
NListListRemoveItem function
NListListRemoveItemAt function
NListListRemoveItemRange function
NListListRemoveRange function
NListListSetCapacity function
NListListSetCount function
NListListSetItem function
NListListSetItemCapacity function
NListListSetItemCount function
NListRemove function
NListRemoveAt function
NListRemoveRange function
NListSet function
NListSetCapacity function
NListSetCount function
NListToArray function
NListToArrayRange function
NLivenessAction enumeration
NLivenessAction_ enumeration
NLivenessMode enumeration
NLivenessMode_ enumeration
NLong type
NMS_ALLOW_DUPLICATE_DEVICES macro
NMS_DO_NOT_USE_DIRECT_SHOW macro
NMS_DO_NOT_USE_VLC macro
NMS_DO_NOT_USE_WINDOWS_MEDIA macro
NMS_DO_NOT_USE_WINDOWS_MEDIA_FOUNDATION macro
NMS_PREFER_DIRECT_SHOW macro
NMS_PREFER_VLC macro
NMS_PREFER_WINDOWS_MEDIA macro
NMS_PREFER_WINDOWS_MEDIA_FOUNDATION macro
NMatchingDetails Unit
NMatchingDetails class
Faces
FacesMatchedIndex
FacesScore
Fingers
FingersScore
FlagSaveCompatible12Line
Irises
IrisesScore
NMatchingDetails
NMatchingDetails
NMatchingDetails
NMatchingDetails
NMatchingDetails
NMatchingDetails
NativeType
Palms
PalmsScore
Voices
VoicesScore
about NMatchingDetails class
NMatchingDetails.FaceCollection class
about NMatchingDetails.FaceCollection class
NMatchingDetails.FingerCollection class
about NMatchingDetails.FingerCollection class
NMatchingDetails.IrisCollection class
about NMatchingDetails.IrisCollection class
NMatchingDetails.PalmCollection class
about NMatchingDetails.PalmCollection class
NMatchingDetails.VoiceCollection class
about NMatchingDetails.VoiceCollection class
NMatchingDetails.h
NMatchingDetailsBase Unit
NMatchingDetailsBase class
BiometricType
NativeType
Score
about NMatchingDetailsBase class
NMatchingDetailsBase.h
NMatchingDetailsBaseGetBiometricType function
NMatchingDetailsBaseGetScore function
NMatchingDetailsCreateFromMemory function
NMatchingDetailsCreateFromMemoryN function
NMatchingDetailsCreateFromStream function
NMatchingDetailsGetFaceCount function
NMatchingDetailsGetFaceEx function
NMatchingDetailsGetFacesMatchedIndex function
NMatchingDetailsGetFacesScore function
NMatchingDetailsGetFingerCount function
NMatchingDetailsGetFingerEx function
NMatchingDetailsGetFingersScore function
NMatchingDetailsGetIrisCount function
NMatchingDetailsGetIrisEx function
NMatchingDetailsGetIrisesScore function
NMatchingDetailsGetPalmCount function
NMatchingDetailsGetPalmEx function
NMatchingDetailsGetPalmsScore function
NMatchingDetailsGetVoiceCount function
NMatchingDetailsGetVoiceEx function
NMatchingDetailsGetVoicesScore function
NMatchingResult Unit
NMatchingResult class
Connection
Id
MatchingDetails
MatchingDetailsBuffer
NativeType
Owner
Score
Subject
about NMatchingResult class
NMatchingResult.h
NMatchingResultGetConnection function
NMatchingResultGetId function
NMatchingResultGetMatchingDetails function
NMatchingResultGetMatchingDetailsBuffer function
NMatchingResultGetScore function
NMatchingResultGetSubject function
NMedia Library
NMedia class
DllName
NativeModule
about NMedia class
NMediaFormat Unit
NMediaFormat class
!=
==
Equals
Equals
GetHashCode
IsCompatibleWith
MediaSubtype
MediaType
NativeType
about NMediaFormat class
NMediaFormat.h
NMediaFormatGetMediaSubtype function
NMediaFormatGetMediaType function
NMediaFormatIsCompatibleWith function
NMediaFormatSetMediaSubtype function
NMediaReader Unit
NMediaReader class
IsLive
Length
NMediaReader
NMediaReader
NMediaReader
NMediaReader
NMediaReader
NMediaReader
NMediaReader
NMediaReader
NativeType
Pause
Position
ReadAudioSample
ReadAudioSample
ReadVideoSample
ReadVideoSample
ReadVideoSampleData
Source
Start
State
Stop
about NMediaReader class
NMediaReader.h
NMediaReaderCreate function
NMediaReaderCreateFromFile function
NMediaReaderCreateFromFile macro
NMediaReaderCreateFromUrl function
NMediaReaderCreateFromUrl macro
NMediaReaderGetLength function
NMediaReaderGetPosition function
NMediaReaderGetSource function
NMediaReaderGetState function
NMediaReaderIsLive function
NMediaReaderPause function
NMediaReaderReadAudioSample function
NMediaReaderReadVideoSample function
NMediaReaderReadVideoSampleData function
NMediaReaderSetPosition function
NMediaReaderStart function
NMediaReaderStop function
NMediaSource Unit
NMediaSource class
!=
==
DisplayName
EnumDevices
EnumDevices
Equals
Equals
FlagAllowDuplicateDevices
FlagDoNotUseDirectShow
FlagDoNotUseVlc
FlagDoNotUseWindowsMedia
FlagDoNotUseWindowsMediaFoundation
FlagPreferDirectShow
FlagPreferVlc
FlagPreferWindowsMedia
FlagPreferWindowsMediaFoundation
FromFile
FromFile
FromUrl
FromUrl
FromUrl
FromUrl
GetCurrentFormat
GetFormats
GetHashCode
Id
MediaType
NativeType
SetCurrentFormat
about NMediaSource class
NMediaSource.h
NMediaSourceCreateFromFile function
NMediaSourceCreateFromUrl function
NMediaSourceEnumDevices function
NMediaSourceGetCurrentFormat function
NMediaSourceGetDisplayNameN function
NMediaSourceGetFormats function
NMediaSourceGetIdN function
NMediaSourceGetMediaType function
NMediaSourceSetCurrentFormat function
NMediaState enumeration
NMediaState_ enumeration
NMediaType enumeration
NMediaTypeIsValid function
NMediaTypeIsValidSingle function
NMediaType_ enumeration
NMediaTypes Unit
NMediaTypes class
IsMediaTypeValid
IsMediaTypeValidSingle
IsVideoInterlaceModeValid
NMediaStateNativeType
NMediaTypeNativeType
NVideoInterlaceModeNativeType
NativeType
about NMediaTypes class
NMediaTypes.h
NMemberDescriptor Unit
NMemberDescriptor.h
NMemberDescriptorGetComponentType function
NMemberInfo Unit
NMemberInfo class
Attributes
DeclaringType
Name
NativeType
about NMemberInfo class
NMemberInfo.h
NMemberInfoGetAttributes function
NMemberInfoGetDeclaringType function
NMemberInfoGetId function
NMemberInfoGetName function
NMemory Unit
NMemory.h
NMemoryStream Unit
NMemoryStream class
Capacity
GetBuffer
LongCapacity
NMemoryStream
NMemoryStream
NMemoryStream
NMemoryStream
NMemoryStream
NMemoryStream
NMemoryStream
NMemoryStream
NMemoryStream
NativeCapacity
NativeType
PositionPtr
ToArray
WriteTo
about NMemoryStream class
NMemoryStreamCreate function
NMemoryStreamCreateFromBuffer function
NMemoryStreamCreateFromBufferForRead macro
NMemoryStreamCreateFromBufferN function
NMemoryStreamCreateWithCapacity function
NMemoryStreamGetBuffer function
NMemoryStreamGetCapacity function
NMemoryStreamGetPositionPtr function
NMemoryStreamSetCapacity function
NMemoryStreamSetPositionPtr function
NMemoryStreamToPtr function
NMemoryStreamWriteTo function
NMemoryType enumeration
NMemoryTypeIsValid function
NMemoryTypeIsValidForFree function
NMemoryType_ enumeration
NMethodDescriptor Unit
NMethodDescriptor.h
NMethodDescriptorGetParameter function
NMethodDescriptorGetParameterCount function
NMethodDescriptorGetParameters function
NMethodDescriptorGetReturnParameter function
NMethodDescriptorInvoke function
NMethodDescriptorInvokeWithPropertyBag function
NMethodDescriptorInvokeWithString function
NMethodDescriptorInvokeWithString macro
NMethodInfo Unit
NMethodInfo class
Invoke
Invoke
Invoke
NativeName
NativeType
Parameters
ReturnParameter
about NMethodInfo class
NMethodInfo.ParameterCollection class
about NMethodInfo.ParameterCollection class
NMethodInfo.h
NMethodInfoGetNativeName function
NMethodInfoGetParameter function
NMethodInfoGetParameterCount function
NMethodInfoGetParameters function
NMethodInfoGetReturnParameter function
NMethodInfoInvoke function
NMethodInfoInvokeWithPropertyBag function
NMethodInfoInvokeWithString function
NMethodInfoInvokeWithString macro
NModule Unit
NModule class
Activated
CheckInit
Company
Copyright
CreateInstance
CreateInstance
DefinedTypes
FileName
GetDependences
GetLoadedModules
GetType
GetType
Id
LoadFromFile
NModule
NModuleOptionsNativeType
Name
NativeId
NativeType
Options
Product
Title
Version
VersionBuild
VersionMajor
VersionMinor
VersionRevision
about NModule class
NModule.h
NModuleCheckInit function
NModuleCreate function
NModuleCreateInstance function
NModuleCreateInstance macro
NModuleGetActivatedN function
NModuleGetCompanyN function
NModuleGetCopyrightN function
NModuleGetDefinedType function
NModuleGetDefinedTypeCount function
NModuleGetDefinedTypes function
NModuleGetDependences function
NModuleGetFileName function
NModuleGetId function
NModuleGetLoadedModules function
NModuleGetNameN function
NModuleGetNativeId function
NModuleGetOptions function
NModuleGetProductN function
NModuleGetTitleN function
NModuleGetTypeWithName function
NModuleGetTypeWithName macro
NModuleGetVersionBuild function
NModuleGetVersionMajor function
NModuleGetVersionMinor function
NModuleGetVersionRevision function
NModuleInternal Unit
NModuleLoadFromFile function
NModuleLoadFromFile macro
NModuleOptions enumeration
NModuleOptions_ enumeration
NModuleRegister function
NModuleSetActivatedProc function
NModuleSetCompany function
NModuleSetCompanyN function
NModuleSetCopyright function
NModuleSetCopyrightN function
NModuleSetDependences function
NModuleSetId function
NModuleSetId macro
NModuleSetInit function
NModuleSetLazyInit function
NModuleSetName macro
NModuleSetNameN function
NModuleSetNativeId function
NModuleSetNativeId macro
NModuleSetOptions function
NModuleSetProduct function
NModuleSetProductN function
NModuleSetThreadInit function
NModuleSetThreadUninit function
NModuleSetTitle function
NModuleSetTitleN function
NModuleSetUninit function
NModuleSetVersionBuild function
NModuleSetVersionMajor function
NModuleSetVersionMinor function
NModuleSetVersionRevision function
NModuleUnregister function
NMonitor Unit
NMonitorDispose function
NMonitorEnter function
NMonitorExit function
NMonitorInit function
NMonitorTryEnter function
NMove function
NMoveArray function
NMutex Unit
NMutexCreate function
NMutexCreateFromOSHandle function
NMutexGetOSHandle function
NMutexRelease function
NNameConfidencePair Unit
NNameConfidencePair structure
Confidence
Name
NativeType
about NNameConfidencePair structure
NNameConfidencePairCopy function
NNameConfidencePairCreate function
NNameConfidencePairDispose function
NNameConfidencePairSet function
NNameConfidencePair_ structure
NNameStringPair type
NNameStringPairCopy function
NNameStringPairCreate function
NNameStringPairDispose function
NNameStringPairSet function
NNameStringPair_ structure
Create
Dispose
ToStruct
about NNameStringPair_ structure
hKey
hValue
NNameValuePairCopy function
NNameValuePairCreate function
NNameValuePairCreate macro
NNameValuePairDispose function
NNameValuePairSet function
NNameValuePair_ structure
Create
Dispose
ToStruct
about NNameValuePair_ structure
hKey
hValue
NNoDeprecate Unit
NOSFamily enumeration
NOSFamilyGetCurrent function
NOSFamily_ enumeration
NObject Unit
NObject class
CaptureProperties
Clone
CompareTo
CopyProperties
DisposeArray<T>
Equals
EventInvoker
FlagRefRet
Flags
FromHandle<T>
FromHandle<T>
FromHandle<T>
FromHandle<T>
FromHandle<T>
FromHandlePlain
FromObject
GetArray<T>
GetArray<T>
GetArrayPlain
GetArrayWithHandle
GetHashCode
GetNativeType
GetObject<T>
GetObject<T>
GetObjectPlain
GetObjectWithHandle
GetObjects<T>
GetObjects<T>
GetObjects<T>
GetObjects<T>
GetOutArrayPlain
GetOutArrayWithHandle
GetProperty<T>
GetSize
GetSize
GetSizeMany<T>
GetSizeMany<T>
GetString
GetStringPlainN
GetStringWithHandleN
IsDisposed
NativeType
Owner
PropertyChanged
Ref
Reset
ResetProperty
Save
Save
Save
Save
Save
Save
SaveMany<T>
SaveMany<T>
SaveMany<T>
SaveMany<T>
SaveMany<T>
SaveMany<T>
SetArray<T>
SetArrayPlain
SetArrayWithHandle
SetObject<T>
SetObjectPlain
SetObjectWithHandle
SetProperty
SetProperty<T>
SetString
SetStringPlainN
SetStringWithHandleN
ToHandle
ToObject
ToString
ToString
Unref
UnrefArray
UnrefElements
about NObject class
NObject.h
NObjectAddDisposed function
NObjectAddDisposedCallback function
NObjectAddHandlerP function
NObjectAddOwnerChanged function
NObjectAddOwnerChangedCallback function
NObjectAddPropertyChanged function
NObjectAddPropertyChangedCallback function
NObjectCaptureProperties function
NObjectClone function
NObjectCompareTo function
NObjectCopyProperties function
NObjectEquals function
NObjectGet function
NObjectGetArray function
NObjectGetConcurrent function
NObjectGetElements function
NObjectGetFlags function
NObjectGetHashCode function
NObjectGetOwnerEx function
NObjectGetPropertyN function
NObjectGetPropertyNN function
NObjectGetPropertyP function
NObjectGetPropertyP macro
NObjectGetSize function
NObjectGetSizeMany function
NObjectGetType function
NObjectInvoke function
NObjectInvoke macro
NObjectInvokeWithPropertyBag function
NObjectInvokeWithPropertyBag macro
NObjectInvokeWithString function
NObjectInvokeWithString macro
NObjectPartInfo Unit
NObjectPartInfo class
DeclaredConstants
DeclaredEvents
DeclaredMethods
DeclaredProperties
GetDeclaredConstant
GetDeclaredEvent
GetDeclaredMethod
GetDeclaredMethods
GetDeclaredProperty
GetObjectPart
NativeType
PropertyName
about NObjectPartInfo class
NObjectPartInfo.DeclaredConstantCollection class
about NObjectPartInfo.DeclaredConstantCollection class
NObjectPartInfo.DeclaredEventCollection class
about NObjectPartInfo.DeclaredEventCollection class
NObjectPartInfo.DeclaredMethodCollection class
about NObjectPartInfo.DeclaredMethodCollection class
NObjectPartInfo.DeclaredPropertyCollection class
about NObjectPartInfo.DeclaredPropertyCollection class
NObjectPartInfo.h
NObjectPartInfoGetDeclaredConstant function
NObjectPartInfoGetDeclaredConstantCount function
NObjectPartInfoGetDeclaredConstantWithName function
NObjectPartInfoGetDeclaredConstantWithName macro
NObjectPartInfoGetDeclaredConstants function
NObjectPartInfoGetDeclaredEvent function
NObjectPartInfoGetDeclaredEventCount function
NObjectPartInfoGetDeclaredEventWithName function
NObjectPartInfoGetDeclaredEventWithName macro
NObjectPartInfoGetDeclaredEvents function
NObjectPartInfoGetDeclaredMethod function
NObjectPartInfoGetDeclaredMethodCount function
NObjectPartInfoGetDeclaredMethodWithName function
NObjectPartInfoGetDeclaredMethodWithName macro
NObjectPartInfoGetDeclaredMethods function
NObjectPartInfoGetDeclaredMethodsWithName function
NObjectPartInfoGetDeclaredMethodsWithName macro
NObjectPartInfoGetDeclaredProperties function
NObjectPartInfoGetDeclaredProperty function
NObjectPartInfoGetDeclaredPropertyCount function
NObjectPartInfoGetDeclaredPropertyWithName function
NObjectPartInfoGetDeclaredPropertyWithName macro
NObjectPartInfoGetObjectPart function
NObjectPartInfoGetPropertyName function
NObjectRef function
NObjectRemoveDisposed function
NObjectRemoveDisposedCallback function
NObjectRemoveHandlerP function
NObjectRemoveOwnerChanged function
NObjectRemoveOwnerChangedCallback function
NObjectRemovePropertyChanged function
NObjectRemovePropertyChangedCallback function
NObjectReset function
NObjectResetProperty function
NObjectResetProperty macro
NObjectSaveManyToMemoryDst function
NObjectSaveManyToMemoryDstN function
NObjectSaveManyToMemoryN function
NObjectSaveManyToStream function
NObjectSaveToMemoryDst function
NObjectSaveToMemoryDstN function
NObjectSaveToMemoryN function
NObjectSaveToStream function
NObjectSet function
NObjectSetConcurrent function
NObjectSetFlags function
NObjectSetPropertyN function
NObjectSetPropertyNN function
NObjectSetPropertyP function
NObjectSetPropertyP macro
NObjectToString function
NObjectToString macro
NObjectUnref function
NObjectUnrefArray function
NObjectUnrefElements function
NPF_GRAYSCALE_16S macro
NPF_GRAYSCALE_16U macro
NPF_GRAYSCALE_1U macro
NPF_GRAYSCALE_2U macro
NPF_GRAYSCALE_32F macro
NPF_GRAYSCALE_32S macro
NPF_GRAYSCALE_32U macro
NPF_GRAYSCALE_4U macro
NPF_GRAYSCALE_64F macro
NPF_GRAYSCALE_64S macro
NPF_GRAYSCALE_64U macro
NPF_GRAYSCALE_8S macro
NPF_GRAYSCALE_8U macro
NPF_GRAYSCALE_A_16S macro
NPF_GRAYSCALE_A_16U macro
NPF_GRAYSCALE_A_32F macro
NPF_GRAYSCALE_A_32S macro
NPF_GRAYSCALE_A_32U macro
NPF_GRAYSCALE_A_64F macro
NPF_GRAYSCALE_A_64S macro
NPF_GRAYSCALE_A_64U macro
NPF_GRAYSCALE_A_8S macro
NPF_GRAYSCALE_A_8U macro
NPF_GRAYSCALE_PA_16S macro
NPF_GRAYSCALE_PA_16U macro
NPF_GRAYSCALE_PA_32F macro
NPF_GRAYSCALE_PA_32S macro
NPF_GRAYSCALE_PA_32U macro
NPF_GRAYSCALE_PA_64F macro
NPF_GRAYSCALE_PA_64S macro
NPF_GRAYSCALE_PA_64U macro
NPF_GRAYSCALE_PA_8S macro
NPF_GRAYSCALE_PA_8U macro
NPF_RGB_16S macro
NPF_RGB_16U macro
NPF_RGB_32F macro
NPF_RGB_32S macro
NPF_RGB_32U macro
NPF_RGB_64F macro
NPF_RGB_64S macro
NPF_RGB_64U macro
NPF_RGB_8S macro
NPF_RGB_8U macro
NPF_RGB_8U_INDEXED_1 macro
NPF_RGB_8U_INDEXED_2 macro
NPF_RGB_8U_INDEXED_4 macro
NPF_RGB_8U_INDEXED_8 macro
NPF_RGB_A_16S macro
NPF_RGB_A_16U macro
NPF_RGB_A_32F macro
NPF_RGB_A_32S macro
NPF_RGB_A_32U macro
NPF_RGB_A_64F macro
NPF_RGB_A_64S macro
NPF_RGB_A_64U macro
NPF_RGB_A_8S macro
NPF_RGB_A_8U macro
NPF_RGB_A_8U_INDEXED_1 macro
NPF_RGB_A_8U_INDEXED_2 macro
NPF_RGB_A_8U_INDEXED_4 macro
NPF_RGB_A_8U_INDEXED_8 macro
NPF_RGB_PA_16S macro
NPF_RGB_PA_16U macro
NPF_RGB_PA_32F macro
NPF_RGB_PA_32S macro
NPF_RGB_PA_32U macro
NPF_RGB_PA_64F macro
NPF_RGB_PA_64S macro
NPF_RGB_PA_64U macro
NPF_RGB_PA_8S macro
NPF_RGB_PA_8U macro
NPF_UNDEFINED macro
NPageAlloc function
NPageFree function
NParameterBag Unit
NParameterBag.h
NParameterBagApplyPropertyBag function
NParameterBagContains function
NParameterBagContains macro
NParameterBagCreate function
NParameterBagGet function
NParameterBagGet macro
NParameterBagGetAt function
NParameterBagGetCount function
NParameterBagGetKey function
NParameterBagGetKeys function
NParameterBagGetValue function
NParameterBagGetValues function
NParameterBagSet function
NParameterBagSet macro
NParameterBagSetValue function
NParameterBagToArray function
NParameterBagToPropertyBag function
NParameterBagTryGet function
NParameterBagTryGet macro
NParameterDescriptor Unit
NParameterDescriptor.h
NParameterDescriptorGetDefaultValue function
NParameterDescriptorGetFormat function
NParameterDescriptorGetMaxValue function
NParameterDescriptorGetMinValue function
NParameterDescriptorGetParameterType function
NParameterDescriptorGetStdValue function
NParameterDescriptorGetStdValueCount function
NParameterDescriptorGetStdValues function
NParameterInfo Unit
NParameterInfo class
Attributes
DefaultValue
Format
MaxValue
MinValue
Name
NativeType
ParameterType
StdValues
about NParameterInfo class
NParameterInfo.StdValueCollection class
about NParameterInfo.StdValueCollection class
NParameterInfo.h
NParameterInfoGetAttributes function
NParameterInfoGetDefaultValue function
NParameterInfoGetFormat function
NParameterInfoGetMaxValue function
NParameterInfoGetMinValue function
NParameterInfoGetName function
NParameterInfoGetParameterType function
NParameterInfoGetStdValue function
NParameterInfoGetStdValueCount function
NParameterInfoGetStdValues function
NPath Unit
NPath.h
NPathChangeExtension function
NPathChangeExtension macro
NPathChangeExtensionPN function
NPathChangeExtensionPN macro
NPathCheck function
NPathCheck macro
NPathCheckN function
NPathCombine function
NPathCombine macro
NPathCombineP1N function
NPathCombineP1N macro
NPathCombineP2N function
NPathCombineP2N macro
NPathGetDirectoryName function
NPathGetDirectoryName macro
NPathGetExtension function
NPathGetExtension macro
NPathGetFileName function
NPathGetFileName macro
NPathGetFileNameWithoutExtension function
NPathGetFileNameWithoutExtension macro
NPathGetTempFileName function
NPathGetTempPath function
NPathHasExtension function
NPathHasExtension macro
NPathIsRooted function
NPathIsRooted macro
NPixelFormat Unit
NPixelFormat structure
!=
==
BitsPerChannel
BitsPerIndex
BitsPerPaletteEntry
BitsPerPixel
BitsPerValue
BytesPerChannel
BytesPerPaletteEntry
BytesPerPixel
BytesPerValue
CalcRowLongSize
CalcRowLongSize
CalcRowNativeSize
CalcRowNativeSize
CalcRowSize
CalcRowSize
CanPixelTypeBeIndexed
ChannelCount
ChannelFormat
Equals
Equals
ExtraChannel
GetChannelType
GetHashCode
GetIndexed
GetNonIndexed
GetNonSeparated
GetPaletteSize
GetRowLongSize
GetRowLongSize
GetRowNativeSize
GetRowNativeSize
GetRowSize
GetRowSize
GetSeparated
GetWithExtraChannel
Grayscale16S
Grayscale16U
Grayscale1U
Grayscale2U
Grayscale32F
Grayscale32S
Grayscale32U
Grayscale4U
Grayscale64F
Grayscale64S
Grayscale64U
Grayscale8S
Grayscale8U
GrayscaleA16S
GrayscaleA16U
GrayscaleA32F
GrayscaleA32S
GrayscaleA32U
GrayscaleA64F
GrayscaleA64S
GrayscaleA64U
GrayscaleA8S
GrayscaleA8U
GrayscalePA16S
GrayscalePA16U
GrayscalePA32F
GrayscalePA32S
GrayscalePA32U
GrayscalePA64F
GrayscalePA64S
GrayscalePA64U
GrayscalePA8S
GrayscalePA8U
IsIndexed
IsPixelTypeValid
IsSeparated
IsValid
MaxPaletteLength
NPixelFormat
NPixelFormat
NPixelFormat
NPixelTypeNativeType
NativeType
PixelType
PlaneCount
Rgb16S
Rgb16U
Rgb32F
Rgb32S
Rgb32U
Rgb64F
Rgb64S
Rgb64U
Rgb8S
Rgb8U
Rgb8UIndexed1
Rgb8UIndexed2
Rgb8UIndexed4
Rgb8UIndexed8
RgbA16S
RgbA16U
RgbA32F
RgbA32S
RgbA32U
RgbA64F
RgbA64S
RgbA64U
RgbA8S
RgbA8U
RgbA8UIndexed1
RgbA8UIndexed2
RgbA8UIndexed4
RgbA8UIndexed8
RgbPA16S
RgbPA16U
RgbPA32F
RgbPA32S
RgbPA32U
RgbPA64F
RgbPA64S
RgbPA64U
RgbPA8S
RgbPA8U
ToString
ToString
Undefined
about NPixelFormat structure
uint
NPixelFormat type
NPixelFormat.h
NPixelFormatCalcRowSize function
NPixelFormatCreate function
NPixelFormatGetBitsPerPixel function
NPixelFormatGetBytesPerPixel function
NPixelFormatGetIndexed function
NPixelFormatGetNonIndexed function
NPixelFormatGetNonSeparated function
NPixelFormatGetPaletteSize function
NPixelFormatGetPixelType function
NPixelFormatGetRowSize function
NPixelFormatGetSeparated function
NPixelFormatGetWithExtraChannel function
NPixelFormatIsValid function
NPixelFormatToString function
NPixelFormatToString macro
NPixelFormat_ type
NPixelType enumeration
NPixelTypeCanBeIndexed function
NPixelTypeIsValid function
NPixelType_ enumeration
NPlugin Unit
NPlugin class
Disable
Enable
Error
FileName
LoadTime
Module
NPluginStateNativeType
NativeType
Owner
Plug
PlugTime
SelectedInterfaceVersion
State
Unplug
about NPlugin class
NPlugin.h
NPluginDisable function
NPluginEnable function
NPluginEventDescriptor Unit
NPluginEventDescriptor class
NativeType
about NPluginEventDescriptor class
NPluginEventDescriptor.h
NPluginEventDescriptorCreate function
NPluginGetError function
NPluginGetFileNameN function
NPluginGetLoadTime function
NPluginGetModule function
NPluginGetPlugTime function
NPluginGetSelectedInterface function
NPluginGetSelectedInterfaceVersion function
NPluginGetState function
NPluginInterfaceVersionInfo structure
NPluginInterfaceVersionInfoConst macro
NPluginInterfaceVersionInfo_ structure
NPluginInternal Unit
NPluginManager Unit
NPluginManager class
AllowsUnplug
DisabledPlugins
EnsurePluginSearchPerformed
GetInstances
GetInterfaceVersions
InterfaceType
NativeType
PlugAll
PluginSearchPath
Plugins
Refresh
UnplugAll
about NPluginManager class
NPluginManager.DisabledPluginCollection class
about NPluginManager.DisabledPluginCollection class
NPluginManager.PluginCollection class
Add
Add
Contains
IndexOf
about NPluginManager.PluginCollection class
this
NPluginManager.h
NPluginManagerAddDisabledPlugin function
NPluginManagerAddDisabledPlugin macro
NPluginManagerAddDisabledPluginsCollectionChanged function
NPluginManagerAddDisabledPluginsCollectionChangedCallback function
NPluginManagerAddPlugin function
NPluginManagerAddPlugin macro
NPluginManagerAddPluginFromFile function
NPluginManagerAddPluginFromFile macro
NPluginManagerAllowsUnplug function
NPluginManagerClearDisabledPlugins function
NPluginManagerEnsurePluginSearchPerformed function
NPluginManagerGetDisabledPluginCount function
NPluginManagerGetDisabledPlugins function
NPluginManagerGetInstances function
NPluginManagerGetInterfaceTypeN function
NPluginManagerGetInterfaceVersions function
NPluginManagerGetPlugin function
NPluginManagerGetPluginByName function
NPluginManagerGetPluginByName macro
NPluginManagerGetPluginCount function
NPluginManagerGetPluginSearchPathN function
NPluginManagerGetPlugins function
NPluginManagerPlugAll function
NPluginManagerPluginEventArgs class
NPluginManagerPluginEventArgs
Plugin
about NPluginManagerPluginEventArgs class
NPluginManagerRefresh function
NPluginManagerRemoveDisabledPlugin function
NPluginManagerRemoveDisabledPlugin macro
NPluginManagerRemoveDisabledPluginAt function
NPluginManagerRemoveDisabledPluginsCollectionChanged function
NPluginManagerRemoveDisabledPluginsCollectionChangedCallback function
NPluginManagerRemovePluginsCollectionChanged function
NPluginManagerRemovePluginsCollectionChangedCallback function
NPluginManagerSetPluginSearchPath function
NPluginManagerSetPluginSearchPath macro
NPluginManagerUnplugAll function
NPluginMethodDescriptor Unit
NPluginMethodDescriptor class
NativeType
about NPluginMethodDescriptor class
NPluginMethodDescriptor.h
NPluginMethodDescriptorCreate function
NPluginModule Unit
NPluginModule class
GetInterfaceVersions
IncompatiblePlugins
InterfaceType
NPluginModule
NativeType
PluginName
Priority
about NPluginModule class
NPluginModuleCreate function
NPluginModuleGetIncompatiblePluginsN function
NPluginModuleGetInterfaceTypeN function
NPluginModuleGetInterfaceVersions function
NPluginModuleGetPluginNameN function
NPluginModuleGetPriority function
NPluginModuleInternal Unit
NPluginModuleSetGetEvents function
NPluginModuleSetGetMethods function
NPluginModuleSetGetProperties function
NPluginModuleSetIncompatiblePlugins macro
NPluginModuleSetIncompatiblePluginsN function
NPluginModuleSetInterfaceType macro
NPluginModuleSetInterfaceTypeN function
NPluginModuleSetInterfaceVersions function
NPluginModuleSetPlug function
NPluginModuleSetPluginName macro
NPluginModuleSetPluginNameN function
NPluginModuleSetPriority function
NPluginModuleSetUnplug function
NPluginPlug function
NPluginPropertyDescriptor Unit
NPluginPropertyDescriptor class
NativeType
about NPluginPropertyDescriptor class
NPluginPropertyDescriptor.h
NPluginPropertyDescriptorCreate function
NPluginState enumeration
NPluginState_ enumeration
NPluginUnplug function
NPoint type
NPoint3F type
NPoint3F_ structure
NPointD type
NPointD_ structure
NPointF type
NPointF_ structure
NPoint_ structure
NPointerParse macro
NPointerParseChars macro
NPointerParseN function
NPointerParseStrOrChars function
NPointerParseStrOrChars macro
NPointerParseVN function
NPointerParseVN macro
NPointerToChars function
NPointerToChars macro
NPointerToString function
NPointerToString macro
NPointerTryParse macro
NPointerTryParseChars macro
NPointerTryParseN function
NPointerTryParseStrOrChars function
NPointerTryParseStrOrChars macro
NPointerTryParseVN function
NPointerTryParseVN macro
NProcess Unit
NProcess.h
NProcessCreateFromOSHandle function
NProcessGetCurrent function
NProcessGetFileName function
NProcessGetId function
NProcessGetName function
NProcessGetOSHandle function
NProcessorInfo Unit
NProcessorInfo class
Count
GetModelInfo
IsFeatureSupported
ModelName
NProcessorVendorNativeType
NativeType
Vendor
VendorName
about NProcessorInfo class
NProcessorInfo.h
NProcessorInfoGetCount function
NProcessorInfoGetModelInfo function
NProcessorInfoGetModelNameN function
NProcessorInfoGetVendor function
NProcessorInfoGetVendorNameN function
NProcessorInfoIsFeatureSupported function
NProcessorVendor enumeration
NProcessorVendor_ enumeration
NPropertyBag class
Add
Add
AddRange
ApplyTo
Clear
CollectionChanged
Contains
ContainsKey
CopyTo
CopyTo
CopyTo
Count
GetEnumerator
IsReadOnly
Keys
NPropertyBag
NPropertyBag
NativeType
Parse
Parse
Remove
Remove
RemoveAt
TryGetValue
TryParse
TryParse
Values
about NPropertyBag class
this
this
NPropertyBag.KeyCollection class
Contains
about NPropertyBag.KeyCollection class
NPropertyBag.ValueCollection class
about NPropertyBag.ValueCollection class
NPropertyInfo Unit
NPropertyInfo class
CanResetValue
DefaultValue
Format
GetMethod
GetValue
MaxValue
MinValue
NativeType
PropertyType
ResetValue
SetMethod
SetValue
StdValues
about NPropertyInfo class
NPropertyInfo.StdValueCollection class
about NPropertyInfo.StdValueCollection class
NPropertyInfo.h
NPropertyInfoCanResetValue function
NPropertyInfoGetDefaultValue function
NPropertyInfoGetFormat function
NPropertyInfoGetGetMethod function
NPropertyInfoGetMaxValue function
NPropertyInfoGetMinValue function
NPropertyInfoGetPropertyType function
NPropertyInfoGetSetMethod function
NPropertyInfoGetStdValue function
NPropertyInfoGetStdValueCount function
NPropertyInfoGetStdValues function
NPropertyInfoGetValue function
NPropertyInfoResetValue function
NPropertyInfoSetValue function
NQueue Unit
NQueue.h
NQueueClear function
NQueueContains function
NQueueCopyTo function
NQueueDequeue function
NQueueDispose function
NQueueEnqueue function
NQueueGetCapacity function
NQueueGetCount function
NQueueGetFront function
NQueueInit function
NQueueInitEx function
NQueueInitWithCapacity function
NQueuePeek function
NQueueSetCapacity function
NQueueToArray function
NRWLock Unit
NRWLockDispose function
NRWLockEnterRead function
NRWLockEnterWrite function
NRWLockExitRead function
NRWLockExitWrite function
NRWLockInit function
NRWLockTryEnterRead function
NRWLockTryEnterWrite function
NRange structure
From
NRange
NativeType
To
ToString
ToString
about NRange structure
NRangeToString function
NRangeToString macro
NRational structure
Denominator
Empty
NRational
NativeType
Numerator
ToString
ToString
about NRational structure
NRational type
NRationalToString function
NRationalToString macro
NRational_ structure
NReAlloc function
NReAllocArray function
NReDeprecate Unit
NRect type
NRectD type
NRectD_ structure
NRectF type
NRectF_ structure
NRect_ structure
NResult type
NResultParseN function
NResultParseStrOrChars function
NResultParseVN function
NResultParseVN macro
NResultToChars function
NResultToChars macro
NResultToString function
NResultToString macro
NResultTryParseN function
NResultTryParseStrOrChars function
NResultTryParseStrOrChars macro
NResultTryParseVN function
NResultTryParseVN macro
NRgb Unit
NRgb structure
Blue
Green
NRgb
NRgb
Red
ToArray
ToString
ToString
about NRgb structure
NRgb type
NRgb.h
NRgbToString function
NRgbToString macro
NRgb_ structure
NSByte type
NSSizeType type
NSSizeTypeParse macro
NSSizeTypeParseChars macro
NSSizeTypeParseN function
NSSizeTypeParseStrOrChars function
NSSizeTypeParseStrOrChars macro
NSSizeTypeParseVN function
NSSizeTypeParseVN macro
NSSizeTypeToChars function
NSSizeTypeToChars macro
NSSizeTypeToString function
NSSizeTypeToString macro
NSSizeTypeTryParse macro
NSSizeTypeTryParseChars macro
NSSizeTypeTryParseN function
NSSizeTypeTryParseStrOrChars function
NSSizeTypeTryParseStrOrChars macro
NSSizeTypeTryParseVN function
NSSizeTypeTryParseVN macro
NScaleMethod enumeration
NScaleMethod_ enumeration
NSeekOrigin enumeration
NSeekOriginIsValid function
NSeekOrigin_ enumeration
NSemaphore Unit
NSemaphoreCreate function
NSemaphoreCreateFromOSHandle function
NSemaphoreGetOSHandle function
NSemaphoreRelease function
NShort type
NSingle type
NSingleGetNaN function
NSingleGetNegativeInfinity function
NSingleGetPositiveInfinity function
NSingleIsInfinity function
NSingleIsNaN function
NSingleIsNegativeInfinity function
NSingleIsPositiveInfinity function
NSingleParse macro
NSingleParseChars macro
NSingleParseN function
NSingleParseStrOrChars function
NSingleParseStrOrChars macro
NSingleParseVN function
NSingleParseVN macro
NSingleToChars function
NSingleToChars macro
NSingleToString function
NSingleToString macro
NSingleTryParse macro
NSingleTryParseChars macro
NSingleTryParseN function
NSingleTryParseStrOrChars function
NSingleTryParseStrOrChars macro
NSingleTryParseVN function
NSingleTryParseVN macro
NSize type
NSizeD type
NSizeD_ structure
NSizeF type
NSizeF_ structure
NSizeType type
NSizeTypeParse macro
NSizeTypeParseChars macro
NSizeTypeParseN function
NSizeTypeParseStrOrChars function
NSizeTypeParseStrOrChars macro
NSizeTypeParseVN function
NSizeTypeParseVN macro
NSizeTypeToChars function
NSizeTypeToChars macro
NSizeTypeToString function
NSizeTypeToString macro
NSizeTypeTryParse macro
NSizeTypeTryParseChars macro
NSizeTypeTryParseN function
NSizeTypeTryParseStrOrChars function
NSizeTypeTryParseStrOrChars macro
NSizeTypeTryParseVN function
NSizeTypeTryParseVN macro
NSize_ structure
NStack Unit
NStack.h
NStackClear function
NStackContains function
NStackCopyTo function
NStackDispose function
NStackGetCapacity function
NStackGetCount function
NStackGetTop function
NStackInit function
NStackInitEx function
NStackInitWithCapacity function
NStackPeek function
NStackPop function
NStackPush function
NStackSetCapacity function
NStackToArray function
NStopwatch Unit
NStopwatchCreate function
NStopwatchGetElapsed function
NStopwatchGetElapsedMilliseconds function
NStopwatchGetElapsedTicks function
NStopwatchGetFrequency function
NStopwatchGetTimestamp function
NStopwatchIsHighResolution function
NStopwatchIsRunning function
NStopwatchReset function
NStopwatchRestart function
NStopwatchStart function
NStopwatchStartNew function
NStopwatchStop function
NStopwatchTicksToMilliseconds function
NStream Unit
NStream class
AsStream
CanRead
CanSeek
CanWrite
CopyTo
CopyTo
Flush
FromStream
Length
NativeType
Null
Position
Read
Read
ReadByte
Seek
SetLength
Synchronized
Write
Write
WriteByte
about NStream class
NStreamCanRead function
NStreamCanSeek function
NStreamCanWrite function
NStreamCopyTo function
NStreamCopyToWithBufferSize function
NStreamFlush function
NStreamGetLength function
NStreamGetNull function
NStreamGetPosition function
NStreamRead function
NStreamReadByte function
NStreamReadN function
NStreamReader Unit
NStreamReaderCreate function
NStreamReaderCreateFromFile function
NStreamReaderCreateFromFile macro
NStreamReaderCreateFromFileWithEncoding function
NStreamReaderCreateFromFileWithEncoding macro
NStreamReaderCreateFromFileWithEncodingAndBufferSize function
NStreamReaderCreateFromFileWithEncodingAndBufferSize macro
NStreamReaderCreateWithEncoding function
NStreamReaderCreateWithEncodingAndBufferSize function
NStreamReaderGetBaseStream function
NStreamReaderGetCurrentEncoding function
NStreamReaderGetNull function
NStreamReaderIsEndOfStream function
NStreamSeek function
NStreamSetLength function
NStreamSetPosition function
NStreamSynchronized function
NStreamWrite function
NStreamWriteByte function
NStreamWriteN function
NStreamWriter Unit
NStreamWriterCreate function
NStreamWriterCreateFromFile function
NStreamWriterCreateFromFile macro
NStreamWriterCreateFromFileWithEncoding function
NStreamWriterCreateFromFileWithEncoding macro
NStreamWriterCreateFromFileWithEncodingAndBufferSize function
NStreamWriterCreateFromFileWithEncodingAndBufferSize macro
NStreamWriterCreateWithEncoding function
NStreamWriterCreateWithEncodingAndBufferSize function
NStreamWriterGetAutoFlush function
NStreamWriterGetBaseStream function
NStreamWriterGetNull function
NStreamWriterSetAutoFlush function
NString Unit
NString.h
NStringAppend macro
NStringAppendChars macro
NStringAppendStrOrChars function
NStringAppendStrOrChars macro
NStringBuilder Unit
NStringBuilderAppend function
NStringBuilderAppend macro
NStringBuilderAppendBoolean function
NStringBuilderAppendBoolean macro
NStringBuilderAppendByte function
NStringBuilderAppendByte macro
NStringBuilderAppendChar function
NStringBuilderAppendChar macro
NStringBuilderAppendCharRepeat function
NStringBuilderAppendCharRepeat macro
NStringBuilderAppendChars function
NStringBuilderAppendChars macro
NStringBuilderAppendDouble function
NStringBuilderAppendDouble macro
NStringBuilderAppendEmptyLine function
NStringBuilderAppendEmptyLine macro
NStringBuilderAppendFormat function
NStringBuilderAppendFormat macro
NStringBuilderAppendFormatN function
NStringBuilderAppendFormatN macro
NStringBuilderAppendFormatVA function
NStringBuilderAppendFormatVA macro
NStringBuilderAppendFormatVAN function
NStringBuilderAppendFormatVAN macro
NStringBuilderAppendInt16 function
NStringBuilderAppendInt16 macro
NStringBuilderAppendInt32 function
NStringBuilderAppendInt32 macro
NStringBuilderAppendInt64 function
NStringBuilderAppendInt64 macro
NStringBuilderAppendLine function
NStringBuilderAppendLine macro
NStringBuilderAppendLineN function
NStringBuilderAppendLineN macro
NStringBuilderAppendN function
NStringBuilderAppendN macro
NStringBuilderAppendObject function
NStringBuilderAppendObject macro
NStringBuilderAppendPointer function
NStringBuilderAppendPointer macro
NStringBuilderAppendResult function
NStringBuilderAppendResult macro
NStringBuilderAppendSByte function
NStringBuilderAppendSByte macro
NStringBuilderAppendSSizeType function
NStringBuilderAppendSSizeType macro
NStringBuilderAppendSingle function
NStringBuilderAppendSingle macro
NStringBuilderAppendSizeType function
NStringBuilderAppendSizeType macro
NStringBuilderAppendUInt16 function
NStringBuilderAppendUInt16 macro
NStringBuilderAppendUInt32 function
NStringBuilderAppendUInt32 macro
NStringBuilderAppendUInt64 function
NStringBuilderAppendUInt64 macro
NStringBuilderAppendValue function
NStringBuilderAppendValue macro
NStringBuilderAppendValueP function
NStringBuilderAppendValueP macro
NStringBuilderClear function
NStringBuilderClear macro
NStringBuilderCopyTo macro
NStringBuilderCopyToStrOrChars function
NStringBuilderCopyToStrOrChars macro
NStringBuilderCopyToString macro
NStringBuilderDetachCharArray macro
NStringBuilderDetachStrOrChars function
NStringBuilderDetachStrOrChars macro
NStringBuilderDetachString macro
NStringBuilderDetachStringN function
NStringBuilderDispose function
NStringBuilderDispose macro
NStringBuilderGetBuffer macro
NStringBuilderGetCapacity function
NStringBuilderGetCapacity macro
NStringBuilderGetChar function
NStringBuilderGetChar macro
NStringBuilderGetCharsBuffer macro
NStringBuilderGetLength function
NStringBuilderGetLength macro
NStringBuilderGetStrOrCharsBuffer function
NStringBuilderGetStrOrCharsBuffer macro
NStringBuilderGetStringWrapper function
NStringBuilderGetStringWrapper macro
NStringBuilderInit function
NStringBuilderInit macro
NStringBuilderInitEx function
NStringBuilderInitEx macro
NStringBuilderInitWithCapacity function
NStringBuilderInitWithCapacity macro
NStringBuilderInitWithChars macro
NStringBuilderInitWithStrOrChars function
NStringBuilderInitWithStrOrChars macro
NStringBuilderInitWithString macro
NStringBuilderInitWithStringN function
NStringBuilderInitWithStringN macro
NStringBuilderInsert function
NStringBuilderInsert macro
NStringBuilderInsertBoolean function
NStringBuilderInsertBoolean macro
NStringBuilderInsertByte function
NStringBuilderInsertByte macro
NStringBuilderInsertChar function
NStringBuilderInsertChar macro
NStringBuilderInsertChars function
NStringBuilderInsertChars macro
NStringBuilderInsertDouble function
NStringBuilderInsertDouble macro
NStringBuilderInsertInt16 function
NStringBuilderInsertInt16 macro
NStringBuilderInsertInt32 function
NStringBuilderInsertInt32 macro
NStringBuilderInsertInt64 function
NStringBuilderInsertInt64 macro
NStringBuilderInsertN function
NStringBuilderInsertN macro
NStringBuilderInsertObject function
NStringBuilderInsertObject macro
NStringBuilderInsertPointer function
NStringBuilderInsertPointer macro
NStringBuilderInsertResult function
NStringBuilderInsertResult macro
NStringBuilderInsertSByte function
NStringBuilderInsertSByte macro
NStringBuilderInsertSSizeType function
NStringBuilderInsertSSizeType macro
NStringBuilderInsertSingle function
NStringBuilderInsertSingle macro
NStringBuilderInsertSizeType function
NStringBuilderInsertSizeType macro
NStringBuilderInsertUInt16 function
NStringBuilderInsertUInt16 macro
NStringBuilderInsertUInt32 function
NStringBuilderInsertUInt32 macro
NStringBuilderInsertUInt64 function
NStringBuilderInsertUInt64 macro
NStringBuilderInsertValue function
NStringBuilderInsertValue macro
NStringBuilderInsertValueP function
NStringBuilderInsertValueP macro
NStringBuilderRemove function
NStringBuilderRemove macro
NStringBuilderReplace function
NStringBuilderReplace macro
NStringBuilderReplaceChars macro
NStringBuilderReplaceCharsInRange macro
NStringBuilderReplaceInRange function
NStringBuilderReplaceInRange macro
NStringBuilderReplaceStrOrChars function
NStringBuilderReplaceStrOrChars macro
NStringBuilderReplaceStrOrCharsInRange function
NStringBuilderReplaceStrOrCharsInRange macro
NStringBuilderReplaceString macro
NStringBuilderReplaceStringInRange macro
NStringBuilderReplaceStringInRangeN function
NStringBuilderReplaceStringN function
NStringBuilderReplaceStringN macro
NStringBuilderSetCapacity function
NStringBuilderSetCapacity macro
NStringBuilderSetChar function
NStringBuilderSetChar macro
NStringBuilderSetLength function
NStringBuilderSetLength macro
NStringBuilderToString function
NStringBuilderToString macro
NStringBuilderToStringRange function
NStringBuilderToStringRange macro
NStringClone function
NStringCompare macro
NStringCompareChars macro
NStringCompareN macro
NStringCompareRange macro
NStringCompareRangeChars macro
NStringCompareRangeN macro
NStringCompareRangeNA function
NStringCompareRangeNW function
NStringCompareRangeStrOrChars macro
NStringCompareRangeStrOrCharsA function
NStringCompareRangeStrOrCharsW function
NStringCompareStrOrChars macro
NStringConcat macro
NStringConcatArray function
NStringConcatChars macro
NStringConcatMany function
NStringConcatMany macro
NStringConcatManyVA function
NStringConcatManyVA macro
NStringConcatN function
NStringConcatStrOrChars function
NStringConcatStrOrChars macro
NStringContainsChars macro
NStringContainsStr macro
NStringContainsStrN function
NStringContainsStrOrChars function
NStringContainsStrOrChars macro
NStringCopyTo macro
NStringCopyToStrOrChars function
NStringCopyToStrOrChars macro
NStringCopyToString macro
NStringCreate macro
NStringCreateFromChar function
NStringCreateFromChar macro
NStringCreateFromChars macro
NStringCreateFromStrOrChars function
NStringCreateFromStrOrChars macro
NStringCreateWrapper function
NStringCreateWrapper macro
NStringEndsWith macro
NStringEndsWithChars macro
NStringEndsWithN function
NStringEndsWithStrOrChars macro
NStringEndsWithStrOrCharsA function
NStringEndsWithStrOrCharsW function
NStringEquals macro
NStringEqualsChars macro
NStringEqualsN function
NStringEqualsStrOrChars macro
NStringEqualsStrOrCharsA function
NStringEqualsStrOrCharsW function
NStringFormat function
NStringFormat macro
NStringFormatVA function
NStringFormatVA macro
NStringFree function
NStringFreeArray function
NStringFreeElements function
NStringGetBuffer function
NStringGetBuffer macro
NStringGetChar macro
NStringGetConcurrent function
NStringGetElements function
NStringGetEmpty function
NStringGetHashCode function
NStringGetLength function
NStringGetLength macro
NStringHasEmbeddedNull function
NStringIndexOf function
NStringIndexOf macro
NStringIndexOfAny function
NStringIndexOfAny macro
NStringIndexOfAnyFrom function
NStringIndexOfAnyFrom macro
NStringIndexOfAnyInRange function
NStringIndexOfAnyInRange macro
NStringIndexOfChars macro
NStringIndexOfCharsFrom macro
NStringIndexOfCharsInRange macro
NStringIndexOfFrom function
NStringIndexOfFrom macro
NStringIndexOfInRange function
NStringIndexOfInRange macro
NStringIndexOfStr macro
NStringIndexOfStrFrom macro
NStringIndexOfStrFromN function
NStringIndexOfStrFromN macro
NStringIndexOfStrInRange macro
NStringIndexOfStrInRangeN function
NStringIndexOfStrInRangeN macro
NStringIndexOfStrN function
NStringIndexOfStrN macro
NStringIndexOfStrOrChars function
NStringIndexOfStrOrChars macro
NStringIndexOfStrOrCharsFrom function
NStringIndexOfStrOrCharsFrom macro
NStringIndexOfStrOrCharsInRange function
NStringIndexOfStrOrCharsInRange macro
NStringInsert macro
NStringInsertChars macro
NStringInsertN function
NStringInsertN macro
NStringInsertStrOrChars function
NStringInsertStrOrChars macro
NStringIsA function
NStringIsEmpty function
NStringIsW function
NStringIsWhiteSpace function
NStringJoinArray function
NStringJoinArray macro
NStringJoinArrayVN function
NStringJoinArrayVN macro
NStringJoinMany function
NStringJoinMany macro
NStringJoinManyVA function
NStringJoinManyVAVN function
NStringJoinManyVAVN macro
NStringJoinManyVN function
NStringJoinManyVN macro
NStringLastIndexOf function
NStringLastIndexOf macro
NStringLastIndexOfAny function
NStringLastIndexOfAny macro
NStringLastIndexOfAnyFrom function
NStringLastIndexOfAnyFrom macro
NStringLastIndexOfAnyInRange function
NStringLastIndexOfAnyInRange macro
NStringLastIndexOfChars macro
NStringLastIndexOfCharsFrom macro
NStringLastIndexOfCharsInRange macro
NStringLastIndexOfFrom function
NStringLastIndexOfFrom macro
NStringLastIndexOfInRange function
NStringLastIndexOfInRange macro
NStringLastIndexOfStr macro
NStringLastIndexOfStrFrom macro
NStringLastIndexOfStrFromN function
NStringLastIndexOfStrFromN macro
NStringLastIndexOfStrInRange macro
NStringLastIndexOfStrInRangeN function
NStringLastIndexOfStrInRangeN macro
NStringLastIndexOfStrN function
NStringLastIndexOfStrN macro
NStringLastIndexOfStrOrChars function
NStringLastIndexOfStrOrChars macro
NStringLastIndexOfStrOrCharsFrom function
NStringLastIndexOfStrOrCharsFrom macro
NStringLastIndexOfStrOrCharsInRange function
NStringLastIndexOfStrOrCharsInRange macro
NStringPadLeft function
NStringPadLeft macro
NStringPadLeftWith function
NStringPadLeftWith macro
NStringPadRight function
NStringPadRight macro
NStringPadRightWith function
NStringPadRightWith macro
NStringPrepend macro
NStringPrependChars macro
NStringPrependStrOrChars function
NStringPrependStrOrChars macro
NStringPromoteBuffer function
NStringPromoteBuffer macro
NStringReader Unit
NStringReaderCreate macro
NStringReaderCreateFromChars macro
NStringReaderCreateFromStrOrChars function
NStringReaderCreateFromStrOrChars macro
NStringReaderCreateN function
NStringRemove function
NStringRemove macro
NStringRemoveFrom function
NStringRemoveFrom macro
NStringReplace function
NStringReplace macro
NStringReplaceChars macro
NStringReplaceStr macro
NStringReplaceStrOrChars function
NStringReplaceStrOrChars macro
NStringSet function
NStringSplit macro
NStringSplitWithCount function
NStringSplitWithCount macro
NStringSplitWithStrs macro
NStringSplitWithStrsAndCount function
NStringSplitWithStrsAndCount macro
NStringSplitWithStrsAndCountN function
NStringSplitWithStrsN macro
NStringStartsWith macro
NStringStartsWithChars macro
NStringStartsWithN function
NStringStartsWithStrOrChars macro
NStringStartsWithStrOrCharsA function
NStringStartsWithStrOrCharsW function
NStringSubstring function
NStringSubstring macro
NStringSubstringFrom function
NStringSubstringFrom macro
NStringToCharArray macro
NStringToCharArrayRange macro
NStringToLower function
NStringToNewString macro
NStringToNewStringRange macro
NStringToStrOrCharArray function
NStringToStrOrCharArray macro
NStringToStrOrCharArrayRange function
NStringToStrOrCharArrayRange macro
NStringToString function
NStringToString macro
NStringToUpper function
NStringTrim function
NStringTrimAny function
NStringTrimAny macro
NStringTrimEnd function
NStringTrimEndAny function
NStringTrimEndAny macro
NStringTrimStart function
NStringTrimStartAny function
NStringTrimStartAny macro
NStringWriter Unit
NStringWriter.h
NStringWriterCreate function
NStringWriterCreateEx function
NStringWriterCreateWithCapacity function
NStringWriterDetachString function
NSubject Unit
NSubject class
Clear
Error
Faces
Fingers
FromFile
FromFile
FromFile
FromFile
FromMemory
FromMemory
FromMemory
FromMemory
FromMemory
FromMemory
FromMemory
FromMemory
FromStream
FromStream
FromStream
FromStream
Gender
GetTemplate
GetTemplateBuffer
GetTemplateBuffer
Id
Irises
IsMultipleSubjects
MatchingResults
MissingEyes
MissingFingers
NSubject
NativeType
Palms
QueryString
RelatedSubjects
SetTemplate
SetTemplate
SetTemplate
SetTemplate
SetTemplate
SetTemplate
SetTemplate
SetTemplate
SetTemplateBuffer
SetTemplateBuffer
Signatures
Statistics
Status
ToANTemplate
ToFCRecord
ToFIRecord
ToFMCRecord
ToFMRecord
ToFMRecord
ToIIRecord
Voices
about NSubject class
NSubject.FaceCollection class
about NSubject.FaceCollection class
NSubject.FingerCollection class
about NSubject.FingerCollection class
NSubject.IrisCollection class
about NSubject.IrisCollection class
NSubject.MatchingResultCollection class
about NSubject.MatchingResultCollection class
NSubject.MissingEyeCollection class
about NSubject.MissingEyeCollection class
NSubject.MissingFingerCollection class
about NSubject.MissingFingerCollection class
NSubject.PalmCollection class
about NSubject.PalmCollection class
NSubject.RelatedSubjectCollection class
about NSubject.RelatedSubjectCollection class
NSubject.SignatureCollection class
about NSubject.SignatureCollection class
NSubject.VoiceCollection class
about NSubject.VoiceCollection class
NSubject.h
NSubjectAddFace function
NSubjectAddFacesCollectionChanged function
NSubjectAddFacesCollectionChangedCallback function
NSubjectAddFinger function
NSubjectAddFingersCollectionChanged function
NSubjectAddFingersCollectionChangedCallback function
NSubjectAddIris function
NSubjectAddIrisesCollectionChanged function
NSubjectAddIrisesCollectionChangedCallback function
NSubjectAddMissingEye function
NSubjectAddMissingFinger function
NSubjectAddPalm function
NSubjectAddPalmsCollectionChanged function
NSubjectAddPalmsCollectionChangedCallback function
NSubjectAddRelatedSubject function
NSubjectAddRelatedSubjectsCollectionChanged function
NSubjectAddRelatedSubjectsCollectionChangedCallback function
NSubjectAddSignature function
NSubjectAddSignaturesCollectionChanged function
NSubjectAddSignaturesCollectionChangedCallback function
NSubjectAddVoice function
NSubjectAddVoicesCollectionChanged function
NSubjectAddVoicesCollectionChangedCallback function
NSubjectClear function
NSubjectClearFaces function
NSubjectClearFingers function
NSubjectClearIrises function
NSubjectClearMissingEyes function
NSubjectClearMissingFingers function
NSubjectClearPalms function
NSubjectClearRelatedSubjects function
NSubjectClearSignatures function
NSubjectClearVoices function
NSubjectCreate function
NSubjectCreateFromFile function
NSubjectCreateFromFile macro
NSubjectCreateFromFileWithFormat function
NSubjectCreateFromFileWithFormat macro
NSubjectCreateFromMemory function
NSubjectCreateFromMemoryWithFormat function
NSubjectCreateFromStream function
NSubjectCreateFromStreamWithFormat function
NSubjectGetError function
NSubjectGetFace function
NSubjectGetFaceCapacity function
NSubjectGetFaceCount function
NSubjectGetFaces function
NSubjectGetFinger function
NSubjectGetFingerCapacity function
NSubjectGetFingerCount function
NSubjectGetFingers function
NSubjectGetGender function
NSubjectGetId function
NSubjectGetIris function
NSubjectGetIrisCapacity function
NSubjectGetIrisCount function
NSubjectGetIrises function
NSubjectGetMatchingResult function
NSubjectGetMatchingResultCount function
NSubjectGetMatchingResults function
NSubjectGetMissingEye function
NSubjectGetMissingEyeCapacity function
NSubjectGetMissingEyeCount function
NSubjectGetMissingEyes function
NSubjectGetMissingFinger function
NSubjectGetMissingFingerCapacity function
NSubjectGetMissingFingerCount function
NSubjectGetMissingFingers function
NSubjectGetPalm function
NSubjectGetPalmCapacity function
NSubjectGetPalmCount function
NSubjectGetPalms function
NSubjectGetQueryString function
NSubjectGetRelatedSubject function
NSubjectGetRelatedSubjectCapacity function
NSubjectGetRelatedSubjectCount function
NSubjectGetRelatedSubjects function
NSubjectGetSignature function
NSubjectGetSignatureCapacity function
NSubjectGetSignatureCount function
NSubjectGetSignatures function
NSubjectGetStatistics function
NSubjectGetStatus function
NSubjectGetTemplate function
NSubjectGetTemplateBuffer function
NSubjectGetTemplateBufferWithFormatEx function
NSubjectGetVoice function
NSubjectGetVoiceCapacity function
NSubjectGetVoiceCount function
NSubjectGetVoices function
NSubjectInsertFace function
NSubjectInsertFinger function
NSubjectInsertIris function
NSubjectInsertMissingEye function
NSubjectInsertMissingFinger function
NSubjectInsertPalm function
NSubjectInsertRelatedSubject function
NSubjectInsertSignature function
NSubjectInsertVoice function
NSubjectIsMultipleSubjects function
NSubjectRemoveFaceAt function
NSubjectRemoveFacesCollectionChanged function
NSubjectRemoveFacesCollectionChangedCallback function
NSubjectRemoveFingerAt function
NSubjectRemoveFingersCollectionChanged function
NSubjectRemoveFingersCollectionChangedCallback function
NSubjectRemoveIrisAt function
NSubjectRemoveIrisesCollectionChanged function
NSubjectRemoveIrisesCollectionChangedCallback function
NSubjectRemoveMissingEyeAt function
NSubjectRemoveMissingFingerAt function
NSubjectRemovePalmAt function
NSubjectRemovePalmsCollectionChanged function
NSubjectRemovePalmsCollectionChangedCallback function
NSubjectRemoveRelatedSubjectAt function
NSubjectRemoveRelatedSubjectsCollectionChanged function
NSubjectRemoveRelatedSubjectsCollectionChangedCallback function
NSubjectRemoveSignatureAt function
NSubjectRemoveSignaturesCollectionChanged function
NSubjectRemoveSignaturesCollectionChangedCallback function
NSubjectRemoveVoiceAt function
NSubjectRemoveVoicesCollectionChanged function
NSubjectRemoveVoicesCollectionChangedCallback function
NSubjectSetFace function
NSubjectSetFaceCapacity function
NSubjectSetFinger function
NSubjectSetFingerCapacity function
NSubjectSetGender function
NSubjectSetId function
NSubjectSetId macro
NSubjectSetIris function
NSubjectSetIrisCapacity function
NSubjectSetMissingEye function
NSubjectSetMissingEyeCapacity function
NSubjectSetMissingFinger function
NSubjectSetMissingFingerCapacity function
NSubjectSetMultipleSubjects function
NSubjectSetPalm function
NSubjectSetPalmCapacity function
NSubjectSetQueryString function
NSubjectSetQueryString macro
NSubjectSetRelatedSubject function
NSubjectSetRelatedSubjectCapacity function
NSubjectSetSignature function
NSubjectSetSignatureCapacity function
NSubjectSetTemplate function
NSubjectSetTemplateAN function
NSubjectSetTemplateBuffer function
NSubjectSetTemplateBufferWithFormat function
NSubjectSetTemplateCbeff function
NSubjectSetTemplateFC function
NSubjectSetTemplateFI function
NSubjectSetTemplateFM function
NSubjectSetTemplateFMC function
NSubjectSetTemplateII function
NSubjectSetVoice function
NSubjectSetVoiceCapacity function
NSubjectToANTemplate function
NSubjectToFCRecord function
NSubjectToFIRecord function
NSubjectToFMCRecord function
NSubjectToFMRecord function
NSubjectToFMRecordEx function
NSubjectToIIRecord function
NSucceeded macro
NSurveillance Library
NSurveillance Unit
NSurveillance class
AddEvent
AddTemplate
AddTemplate
Any
DetectorScaling
DeviceManager
DllName
EnableGpuLowMemoryMode
FacesConfidenceThreshold
FacesDetectMasks
FacesDetected
FacesMinimalInterOcularDistance
FacesQualityThreshold
FacesTemplateSize
FacesWithDetailsOnly
GPUIndices
GetTemplateIds
ImageCaptured
IsRunning
IsRunningChanged
LicensePlateDetectorScaling
LicensePlateDetectorThreshold
LicensePlateEnableTemplateMatching
LicensePlateInterpretOAsZero
LicensePlateMinimalCharacterCount
LicensePlateOcrThreshold
LicensePlatePriorityCountries
MaskDetectionThreshold
MatchingMaximalResultCount
MatchingThreshold
MatchingWithDetails
NSurveillance
NSurveillanceEventCallbackNativeType
NSurveillanceEventTypeNativeType
NativeModule
NativeType
OptimizeModelsAsync
OptimizeModelsAsync
RemoveAllTemplates
RemoveEvent
RemoveTemplate
Sources
Start
StartAsync
StartSource
StartSourceAsync
Stop
StopAsync
StopSource
StopSourceAsync
SubjectAppeared
SubjectDisappeared
SubjectMerged
SubjectSplit
SubjectTrack
UseGPU
VehicleHumanDetectorThreshold
about NSurveillance class
NSurveillance.SourceCollection class
about NSurveillance.SourceCollection class
NSurveillance.h
NSurveillanceAddEventCallbackEx function
NSurveillanceAddEventEx function
NSurveillanceAddIsRunningChanged function
NSurveillanceAddIsRunningChangedCallback function
NSurveillanceAddSource function
NSurveillanceAddSourceCollectionChanged function
NSurveillanceAddSourceCollectionChangedCallback function
NSurveillanceAddTemplate function
NSurveillanceClearSources function
NSurveillanceCreate function
NSurveillanceDetectionDetails class
ClothingDetails
DetectionConfidence
Face
FaceRectangle
LicensePlateDetails
NSurveillanceDetectionDetails
NativeType
ObjectColor
ObjectType
Rectangle
SubjectType
VehicleDetails
about NSurveillanceDetectionDetails class
NSurveillanceDetectionDetailsCreate function
NSurveillanceDetectionDetailsGetClothingDetails function
NSurveillanceDetectionDetailsGetDetectionConfidence function
NSurveillanceDetectionDetailsGetFace function
NSurveillanceDetectionDetailsGetFaceRectangle function
NSurveillanceDetectionDetailsGetLicensePlateDetails function
NSurveillanceDetectionDetailsGetObjectColor function
NSurveillanceDetectionDetailsGetObjectType function
NSurveillanceDetectionDetailsGetRectangle function
NSurveillanceDetectionDetailsGetSubjectType function
NSurveillanceDetectionDetailsGetVehicleDetails function
NSurveillanceDetectionDetailsSetClothingDetails function
NSurveillanceDetectionDetailsSetDetectionConfidence function
NSurveillanceDetectionDetailsSetFace function
NSurveillanceDetectionDetailsSetFaceRectangle function
NSurveillanceDetectionDetailsSetLicensePlateDetails function
NSurveillanceDetectionDetailsSetObjectColor function
NSurveillanceDetectionDetailsSetObjectType function
NSurveillanceDetectionDetailsSetRectangle function
NSurveillanceDetectionDetailsSetSubjectType function
NSurveillanceDetectionDetailsSetVehicleDetails function
NSurveillanceDetectionResult class
Details
Image
ModalityType
NativeType
about NSurveillanceDetectionResult class
NSurveillanceDetectionResult.DetailsCollection class
about NSurveillanceDetectionResult.DetailsCollection class
NSurveillanceDetectionResultGetDetails function
NSurveillanceDetectionResultGetDetailsAt function
NSurveillanceDetectionResultGetDetailsCount function
NSurveillanceDetectionResultGetImage function
NSurveillanceDetectionResultGetModalityType function
NSurveillanceEngine class
Detect
DetectAsync
DetectWithParameters
DetectWithParametersAsync
DetectorScaling
EnableGpuLowMemoryMode
FacesConfidenceThreshold
FacesDetectMasks
FacesMinimalInterOcularDistance
FacesQualityThreshold
FacesTemplateSize
GPUIndices
Initialize
LicensePlateDetectorScaling
LicensePlateDetectorThreshold
LicensePlateEnableTemplateMatching
LicensePlateInterpretOAsZero
LicensePlateMinimalCharacterCount
LicensePlateOcrThreshold
LicensePlatePriorityCountries
ModalityType
NSurveillanceEngine
NativeType
ThreadCount
UseGPU
VehicleHumanDetectorThreshold
about NSurveillanceEngine class
NSurveillanceEngineCreate function
NSurveillanceEngineDetect function
NSurveillanceEngineDetectAsync function
NSurveillanceEngineInit function
NSurveillanceEventArgs class
EventDetailsArray
EventType
NSurveillanceEventArgs
about NSurveillanceEventArgs class
NSurveillanceEventDetails class
Attributes
AttributesContainsDetails
BestDetails
BestMatches
CurrentMatches
Error
Face
FaceConfidence
FrameIndex
GetAttribtues
GetDetectedFaces
GetFace
GetOriginalImage
GetSubjectTemplate
GetVideoSample
MergedSubject
ModalityType
NativeType
OriginalImage
Owner
Rectangle
SplitFromSubject
SubjectType
Template
TimeStamp
TraceIndex
VideoTimeStamp
about NSurveillanceEventDetails class
NSurveillanceEventDetails.BestMatchCollection class
about NSurveillanceEventDetails.BestMatchCollection class
NSurveillanceEventDetails.CurrentMatchCollection class
about NSurveillanceEventDetails.CurrentMatchCollection class
NSurveillanceEventDetails.h
NSurveillanceEventType enumeration
NSurveillanceEventType_ enumeration
NSurveillanceGetDeviceManager function
NSurveillanceGetSource function
NSurveillanceGetSourceCount function
NSurveillanceGetSources function
NSurveillanceGetTemplateIdsN function
NSurveillanceIsRunning function
NSurveillanceModalityType enumeration
NSurveillanceModalityType_ enumeration
NSurveillanceObjectColor enumeration
NSurveillanceObjectColorDetails structure
BlackColorConfidence
BlueColorConfidence
BrownColorConfidence
Color
GrayColorConfidence
GreenColorConfidence
OrangeColorConfidence
RedColorConfidence
SilverColorConfidence
WhiteColorConfidence
YellowColorConfidence
about NSurveillanceObjectColorDetails structure
NSurveillanceObjectColorDetails_ structure
NSurveillanceObjectColor_ enumeration
NSurveillanceObjectDirection enumeration
NSurveillanceObjectDirectionDetails structure
Direction
EastConfidence
NorthConfidence
NorthEastConfidence
NorthWestConfidence
SouthConfidence
SouthEastConfidence
SouthWestConfidence
WestConfidence
about NSurveillanceObjectDirectionDetails structure
NSurveillanceObjectDirectionDetails_ structure
NSurveillanceObjectDirection_ enumeration
NSurveillanceObjectType enumeration
NSurveillanceObjectTypeDetails structure
BikeConfidence
BusConfidence
CarConfidence
PersonConfidence
TruckConfidence
Type
about NSurveillanceObjectTypeDetails structure
NSurveillanceObjectTypeDetails_ structure
NSurveillanceObjectType_ enumeration
NSurveillanceOptimizeAllModelsAsync function
NSurveillanceOptimizeModelsAsync function
NSurveillanceProgressEventArgs class
about NSurveillanceProgressEventArgs class
NSurveillanceRemoveAllTemplates function
NSurveillanceRemoveEventCallbackEx function
NSurveillanceRemoveEventEx function
NSurveillanceRemoveIsRunningChanged function
NSurveillanceRemoveIsRunningChangedCallback function
NSurveillanceRemoveSourceAt function
NSurveillanceRemoveSourceCollectionChanged function
NSurveillanceRemoveSourceCollectionChangedCallback function
NSurveillanceRemoveTemplateN function
NSurveillanceSource Unit
NSurveillanceSource class
Camera
Error
GetCurrentFormat
GetFormats
IsCapturingChanged
Length
ModalityType
NSurveillanceSource
NSurveillanceSource
NSurveillanceSource
NativeType
Owner
Position
RegionOfInterest
SetCurrentFormat
State
Type
Video
Warning
about NSurveillanceSource class
NSurveillanceSource.h
NSurveillanceSourceAddIsCapturingChanged function
NSurveillanceSourceAddIsCapturingChangedCallback function
NSurveillanceSourceCreate function
NSurveillanceSourceCreateFromCameraEx function
NSurveillanceSourceCreateFromMediaReaderEx function
NSurveillanceSourceGetCamera function
NSurveillanceSourceGetCurrentFormat function
NSurveillanceSourceGetError function
NSurveillanceSourceGetFormats function
NSurveillanceSourceGetLength function
NSurveillanceSourceGetModalityType function
NSurveillanceSourceGetPosition function
NSurveillanceSourceGetRegionOfInterest function
NSurveillanceSourceGetState function
NSurveillanceSourceGetType function
NSurveillanceSourceGetVideo function
NSurveillanceSourceGetWarning function
NSurveillanceSourceRemoveIsCapturingChanged function
NSurveillanceSourceRemoveIsCapturingChangedCallback function
NSurveillanceSourceSetCamera function
NSurveillanceSourceSetCurrentFormat function
NSurveillanceSourceSetModalityType function
NSurveillanceSourceSetRegionOfInterest function
NSurveillanceSourceSetVideo function
NSurveillanceSourceType enumeration
NSurveillanceSourceType_ enumeration
NSurveillanceStart function
NSurveillanceStartAsync function
NSurveillanceStartSource function
NSurveillanceStartSourceAsync function
NSurveillanceStop function
NSurveillanceStopAsync function
NSurveillanceStopSource function
NSurveillanceStopSourceAsync function
NSwapDWordArray function
NSwapDouble function
NSwapDoubleArray function
NSwapQWordArray function
NSwapSingle function
NSwapSingleArray function
NSwapWordArray function
NSyncEvent Unit
NSyncEventCreate function
NSyncEventCreateFromOSHandle function
NSyncEventGetOSHandle function
NSyncEventReset macro
NSyncEventSet function
NTemplate Unit
NTemplate class
CalculateSize
Check
Check
Clear
Faces
Fingers
GetSize
GetSize
Irises
Merge
Merge
NTemplate
NTemplate
NTemplate
NTemplate
NTemplate
NTemplate
NativeType
Palms
Voices
about NTemplate class
NTemplate.h
NTemplateCalculateSize function
NTemplateCheck function
NTemplateCheckN function
NTemplateClear function
NTemplateCreateEx function
NTemplateCreateFromMemory function
NTemplateCreateFromMemoryN function
NTemplateGetFacesEx function
NTemplateGetFingersEx function
NTemplateGetIrisesEx function
NTemplateGetPalmsEx function
NTemplateGetSizeMem function
NTemplateGetVoicesEx function
NTemplateMerge function
NTemplatePack function
NTemplateSetFaces function
NTemplateSetFingers function
NTemplateSetIrises function
NTemplateSetPalms function
NTemplateSetVoices function
NTemplateUnpack function
NTextReader Unit
NTextReaderGetNull function
NTextReaderPeekChar function
NTextReaderPeekChar macro
NTextReaderReadChar function
NTextReaderReadChar macro
NTextReaderReadChars function
NTextReaderReadChars macro
NTextReaderReadLine function
NTextReaderReadToEnd function
NTextReaderSynchronized function
NTextWriter Unit
NTextWriterFlush function
NTextWriterGetEncoding function
NTextWriterGetNewLine function
NTextWriterGetNull function
NTextWriterSetNewLine function
NTextWriterSetNewLine macro
NTextWriterSynchronized function
NTextWriterWrite function
NTextWriterWrite macro
NTextWriterWriteBoolean function
NTextWriterWriteBooleanLine function
NTextWriterWriteChar function
NTextWriterWriteChar macro
NTextWriterWriteCharLine function
NTextWriterWriteCharLine macro
NTextWriterWriteChars function
NTextWriterWriteChars macro
NTextWriterWriteCharsLine function
NTextWriterWriteCharsLine macro
NTextWriterWriteDouble function
NTextWriterWriteDoubleLine function
NTextWriterWriteEmptyLine function
NTextWriterWriteFormat function
NTextWriterWriteFormat macro
NTextWriterWriteFormatLine function
NTextWriterWriteFormatLine macro
NTextWriterWriteFormatLineVA function
NTextWriterWriteFormatLineVA macro
NTextWriterWriteFormatVA function
NTextWriterWriteFormatVA macro
NTextWriterWriteInt32 function
NTextWriterWriteInt32Line function
NTextWriterWriteInt64 function
NTextWriterWriteInt64Line function
NTextWriterWriteLine function
NTextWriterWriteLine macro
NTextWriterWriteObject function
NTextWriterWriteObjectLine function
NTextWriterWritePointer function
NTextWriterWritePointerLine function
NTextWriterWriteResult function
NTextWriterWriteResultLine function
NTextWriterWriteSSizeType function
NTextWriterWriteSSizeTypeLine function
NTextWriterWriteSingle function
NTextWriterWriteSingleLine function
NTextWriterWriteSizeType function
NTextWriterWriteSizeTypeLine function
NTextWriterWriteUInt32 function
NTextWriterWriteUInt32Line function
NTextWriterWriteUInt64 function
NTextWriterWriteUInt64Line function
NTextWriterWriteValue function
NTextWriterWriteValueLine function
NTextWriterWriteValueLineP function
NTextWriterWriteValueP function
NThread Unit
NThread.h
NThreadCreate function
NThreadCreateFromOSHandle function
NThreadCreateParameterized function
NThreadGetCurrent function
NThreadGetCurrentId function
NThreadGetId function
NThreadGetOSHandle function
NThreadJoin function
NThreadSleep function
NTimeSpan Unit
NTimeSpanAdd function
NTimeSpanCompare function
NTimeSpanCreate function
NTimeSpanCreateFromDays function
NTimeSpanCreateFromHours function
NTimeSpanCreateFromMilliseconds function
NTimeSpanCreateFromMinutes function
NTimeSpanCreateFromSeconds function
NTimeSpanCreateFromTicks function
NTimeSpanDecode function
NTimeSpanDuration function
NTimeSpanGetDays function
NTimeSpanGetHours function
NTimeSpanGetMilliseconds function
NTimeSpanGetMinutes function
NTimeSpanGetSeconds function
NTimeSpanGetTicks function
NTimeSpanGetTotalDays function
NTimeSpanGetTotalHours function
NTimeSpanGetTotalMilliseconds function
NTimeSpanGetTotalMinutes function
NTimeSpanGetTotalSeconds function
NTimeSpanIsTimeValid function
NTimeSpanIsValid function
NTimeSpanNegate function
NTimeSpanSubtract function
NTimeSpanToString function
NTimeSpanToString macro
NTimeSpan_ type
NTls Unit
NTlsCreate function
NTlsCreateForObject function
NTlsFree function
NTlsGetObject function
NTlsGetValue function
NTlsSetObject function
NTlsSetValue function
NTrackingDetails Unit
NTrackingDetails class
Attributes
AttributesContainsDetails
FrameIndex
LicensePlates
MatchResults
NativeType
Rectangle
SubjectType
TimeStamp
about NTrackingDetails class
NTrackingDetails.LicensePlateCollection class
about NTrackingDetails.LicensePlateCollection class
NTrackingDetails.MatchResultCollection class
about NTrackingDetails.MatchResultCollection class
NTrackingDetailsGetAttributes function
NTrackingDetailsGetAttributesContainsDetails function
NTrackingDetailsGetFrameIndex function
NTrackingDetailsGetLicensePlate function
NTrackingDetailsGetLicensePlateCount function
NTrackingDetailsGetLicensePlates function
NTrackingDetailsGetMatchResult function
NTrackingDetailsGetMatchResultCount function
NTrackingDetailsGetMatchResults function
NTrackingDetailsGetRectangle function
NTrackingDetailsGetSubjectType function
NTrackingDetailsGetTimeStamp function
NTrue macro
NType Unit
NType class
AddEventHandler
Attributes
BaseType
CapturePropertyValues
CopyPropertyValues
CreateInstance
CreateInstance
CreateInstance
CreateInstance
DeclaredConstants
DeclaredConstructors
DeclaredEnumConstants
DeclaredEvents
DeclaredFields
DeclaredMethods
DeclaredParts
DeclaredProperties
EnumAlternative
GetDeclaredConstant
GetDeclaredEnumConstant
GetDeclaredEvent
GetDeclaredField
GetDeclaredMethod
GetDeclaredMethods
GetDeclaredPart
GetDeclaredProperty
GetPropertyValue<T>
GetType
GetType
HasOwnerType
IdentifierToString
IdentifierToString
InvokeMethod
InvokeMethod
InvokeMethod
IsAbstract
IsAssignableFrom
IsBasic
IsCallback
IsCloneable
IsComparable
IsDeprecated
IsDisposable
IsEnum
IsEquatable
IsFlagsEnum
IsHandle
IsInstanceOfType
IsMemorySerializable
IsObject
IsParsable
IsPrimitive
IsPublic
IsSealed
IsSerializable
IsSignNeutral
IsStatic
IsStruct
IsSubclassOf
Module
NTypeCodeNativeType
Name
NativeType
OwnerType
RemoveEventHandler
Reset
ResetPropertyValue
RootType
RootTypeCode
SetPropertyValue
SetPropertyValue<T>
ToNativeType
ToType
ToType
ToType
TypeCode
UseInsteadType
ValueSize
about NType class
NType.h
NTypeAddEventHandlerN function
NTypeAddEventHandlerP function
NTypeAddEventHandlerP macro
NTypeAreValuesEqual function
NTypeCapturePropertyValues function
NTypeCode enumeration
NTypeCode_ enumeration
NTypeCompareValues function
NTypeCopyPropertyValues function
NTypeCopyValue function
NTypeCreateInstance function
NTypeCreateInstanceWithName function
NTypeCreateInstanceWithName macro
NTypeDescriptor Unit
NTypeDescriptor.h
NTypeDescriptorGetDefaultPropertyName function
NTypeDescriptorGetDefaultPropertyNameForType function
NTypeDescriptorGetEvents function
NTypeDescriptorGetEventsForType function
NTypeDescriptorGetMethods function
NTypeDescriptorGetMethodsForType function
NTypeDescriptorGetProperties function
NTypeDescriptorGetPropertiesForType function
NTypeDisposeValue function
NTypeDisposeValues function
NTypeFreeValues function
NTypeGetAttributes function
NTypeGetBaseType function
NTypeGetDeclaredConstant function
NTypeGetDeclaredConstantCount function
NTypeGetDeclaredConstantWithName function
NTypeGetDeclaredConstantWithName macro
NTypeGetDeclaredConstants function
NTypeGetDeclaredConstructor function
NTypeGetDeclaredConstructorCount function
NTypeGetDeclaredConstructors function
NTypeGetDeclaredEnumConstant function
NTypeGetDeclaredEnumConstantCount function
NTypeGetDeclaredEnumConstantWithName function
NTypeGetDeclaredEnumConstantWithName macro
NTypeGetDeclaredEnumConstants function
NTypeGetDeclaredEvent function
NTypeGetDeclaredEventCount function
NTypeGetDeclaredEventWithName function
NTypeGetDeclaredEventWithName macro
NTypeGetDeclaredEvents function
NTypeGetDeclaredField function
NTypeGetDeclaredFieldCount function
NTypeGetDeclaredFieldWithName function
NTypeGetDeclaredFieldWithName macro
NTypeGetDeclaredFields function
NTypeGetDeclaredMethod function
NTypeGetDeclaredMethodCount function
NTypeGetDeclaredMethodWithName function
NTypeGetDeclaredMethodWithName macro
NTypeGetDeclaredMethods function
NTypeGetDeclaredMethodsWithName function
NTypeGetDeclaredMethodsWithName macro
NTypeGetDeclaredPart function
NTypeGetDeclaredPartCount function
NTypeGetDeclaredPartWithName function
NTypeGetDeclaredPartWithName macro
NTypeGetDeclaredParts function
NTypeGetDeclaredProperties function
NTypeGetDeclaredProperty function
NTypeGetDeclaredPropertyCount function
NTypeGetDeclaredPropertyWithName function
NTypeGetDeclaredPropertyWithName macro
NTypeGetEnumAlternative function
NTypeGetModule function
NTypeGetNameN function
NTypeGetOwnerType function
NTypeGetPropertyValueN function
NTypeGetPropertyValueP function
NTypeGetPropertyValueP macro
NTypeGetRootType function
NTypeGetRootTypeCode function
NTypeGetTypeCode function
NTypeGetTypeWithName function
NTypeGetTypeWithName macro
NTypeGetUseInsteadType function
NTypeGetValueHashCode function
NTypeGetValueSize function
NTypeHasOwnerType function
NTypeIdentifierToString function
NTypeIdentifierToString macro
NTypeIdentifierToStringFN function
NTypeIdentifierToStringFN macro
NTypeIdentifierToStringVN function
NTypeIdentifierToStringVN macro
NTypeInvokeMethod function
NTypeInvokeMethod macro
NTypeInvokeMethodWithPropertyBag function
NTypeInvokeMethodWithPropertyBag macro
NTypeInvokeMethodWithString function
NTypeInvokeMethodWithString macro
NTypeIsAbstract function
NTypeIsAssignableFrom function
NTypeIsBasic function
NTypeIsCallback function
NTypeIsCloneable function
NTypeIsComparable function
NTypeIsDeprecated function
NTypeIsDisposable function
NTypeIsEnum function
NTypeIsEquatable function
NTypeIsFlagsEnum function
NTypeIsHandle function
NTypeIsInstanceOfType function
NTypeIsInstanceOfTypeP function
NTypeIsMemorySerializable function
NTypeIsObject function
NTypeIsParsable function
NTypeIsPrimitive function
NTypeIsPublic function
NTypeIsSealed function
NTypeIsSerializable function
NTypeIsSignNeutral function
NTypeIsStatic function
NTypeIsStruct function
NTypeIsSubclassOf function
NTypeParseValue function
NTypeParseValue macro
NTypeParseValueVN function
NTypeParseValueVN macro
NTypeRemoveEventHandlerN function
NTypeRemoveEventHandlerP function
NTypeRemoveEventHandlerP macro
NTypeReset function
NTypeResetPropertyValue function
NTypeResetPropertyValueP macro
NTypeSetPropertyValueN function
NTypeSetPropertyValueP function
NTypeSetPropertyValueP macro
NTypeSetValue function
NTypeTryParseValue function
NTypeTryParseValue macro
NTypeTryParseValueVN function
NTypeTryParseValueVN macro
NTypeValueToString function
NTypeValueToString macro
NTypeValueToStringN function
NTypes Unit
NTypes class
CreateCallback
CreateCallback
CreateCallback
CreateCallback
FreeObjectPointer
FreeStringArray
FreeStringElements
GetObjectFromPointer
GetPointerForObject
IsMemoryTypeValid
IsMemoryTypeValidForFree
NACharNativeType
NAttributesNativeType
NBooleanNativeType
NCallbackNativeType
NCharNativeType
NDateTimeNativeType
NDoubleNativeType
NGuidNativeType
NInt16NativeType
NInt32NativeType
NInt64NativeType
NInt8NativeType
NMemoryTypeNativeType
NOSFamilyNativeType
NPointerNativeType
NResultNativeType
NSSizeTypeNativeType
NSingleNativeType
NSizeTypeNativeType
NStringNativeType
NTimeSpanNativeType
NUInt16NativeType
NUInt32NativeType
NUInt64NativeType
NUInt8NativeType
NWCharNativeType
NameStringPairNativeType
NativeType
OSFamilyCurrent
StringEncoding
WCharApi
about NTypes class
NTypes.h
NTypesGetPointer function
NUInt type
NUInt16 type
NUInt16Parse macro
NUInt16ParseChars macro
NUInt16ParseN function
NUInt16ParseStrOrChars function
NUInt16ParseStrOrChars macro
NUInt16ParseVN function
NUInt16ParseVN macro
NUInt16ToChars function
NUInt16ToChars macro
NUInt16ToString function
NUInt16ToString macro
NUInt16TryParse macro
NUInt16TryParseChars macro
NUInt16TryParseN function
NUInt16TryParseStrOrChars function
NUInt16TryParseStrOrChars macro
NUInt16TryParseVN function
NUInt16TryParseVN macro
NUInt32 type
NUInt32Parse macro
NUInt32ParseChars macro
NUInt32ParseN function
NUInt32ParseStrOrChars function
NUInt32ParseStrOrChars macro
NUInt32ParseVN function
NUInt32ParseVN macro
NUInt32ToChars function
NUInt32ToChars macro
NUInt32ToString function
NUInt32ToString macro
NUInt32TryParse macro
NUInt32TryParseChars macro
NUInt32TryParseN function
NUInt32TryParseStrOrChars function
NUInt32TryParseStrOrChars macro
NUInt32TryParseVN function
NUInt32TryParseVN macro
NUInt64 type
NUInt64Parse macro
NUInt64ParseChars macro
NUInt64ParseN function
NUInt64ParseStrOrChars function
NUInt64ParseStrOrChars macro
NUInt64ParseVN function
NUInt64ParseVN macro
NUInt64ToChars function
NUInt64ToChars macro
NUInt64ToString function
NUInt64ToString macro
NUInt64TryParse macro
NUInt64TryParseChars macro
NUInt64TryParseN function
NUInt64TryParseStrOrChars function
NUInt64TryParseStrOrChars macro
NUInt64TryParseVN function
NUInt64TryParseVN macro
NUInt8 type
NUInt8Parse macro
NUInt8ParseChars macro
NUInt8ParseN function
NUInt8ParseStrOrChars function
NUInt8ParseStrOrChars macro
NUInt8ParseVN function
NUInt8ParseVN macro
NUInt8ToChars function
NUInt8ToChars macro
NUInt8ToString function
NUInt8ToString macro
NUInt8TryParse macro
NUInt8TryParseChars macro
NUInt8TryParseN function
NUInt8TryParseStrOrChars function
NUInt8TryParseStrOrChars macro
NUInt8TryParseVN function
NUInt8TryParseVN macro
NULL macro
NULong type
NURational structure
Denominator
Empty
NURational
NativeType
Numerator
ToString
ToString
about NURational structure
NURational type
NURationalToString function
NURationalToString macro
NURational_ structure
NUShort type
NValue Unit
NValue class
Attributes
ChangeType
ChangeType
ChangeType
FromDelegate
FromDelegate
FromDelegate
FromDelegate
FromObject
FromObject
FromObject
FromObject
FromPointer
FromPointer
FromResult
FromResult
FromString
FromString
FromType<T>
FromType<T>
IsWrapper
KeyValuePairNativeType
LongSize
NValue
NValue
NValue
NValue
NValue
NValue
NValue
NValue
NValue
NValue
NValue
NValue
NValue
NValue
NValue
NValue
NValue
NValue
NValue
NValue
NValue
NValue
NValue
NValue
NValue
NValue
NValue
NValue
NameValuePairNativeType
NativeSize
NativeType
Ptr
Size
ToBoolean
ToBoolean
ToBoolean
ToByte
ToByte
ToByte
ToChar
ToChar
ToChar
ToDouble
ToDouble
ToDouble
ToInt16
ToInt16
ToInt16
ToInt32
ToInt32
ToInt32
ToInt64
ToInt64
ToInt64
ToIntPtr
ToIntPtr
ToIntPtr
ToObject
ToObject
ToObject
ToObject
ToObject
ToPointer
ToPointer
ToPointer
ToResult
ToResult
ToResult
ToSByte
ToSByte
ToSByte
ToSingle
ToSingle
ToSingle
ToString
ToString
ToType
ToType
ToType
ToType<T>
ToType<T>
ToType<T>
ToUInt16
ToUInt16
ToUInt16
ToUInt32
ToUInt32
ToUInt32
ToUInt64
ToUInt64
ToUInt64
ToUIntPtr
ToUIntPtr
ToUIntPtr
TypeCode
ValueType
about NValue class
NValue.h
NValueChangeType function
NValueChangeTypeP function
NValueCreate function
NValueCreateCustom function
NValueCreateCustomN function
NValueCreateFromBoolean function
NValueCreateFromByte function
NValueCreateFromCallback function
NValueCreateFromChar function
NValueCreateFromChar macro
NValueCreateFromDouble function
NValueCreateFromInt16 function
NValueCreateFromInt32 function
NValueCreateFromInt64 function
NValueCreateFromObject function
NValueCreateFromObjectP function
NValueCreateFromPointer function
NValueCreateFromResult function
NValueCreateFromSByte function
NValueCreateFromSSizeType function
NValueCreateFromSingle function
NValueCreateFromSizeType function
NValueCreateFromString function
NValueCreateFromString macro
NValueCreateFromUInt16 function
NValueCreateFromUInt32 function
NValueCreateFromUInt64 function
NValueCreateP function
NValueGetAttributes function
NValueGetFree function
NValueGetPtr function
NValueGetSize function
NValueGetTypeCode function
NValueGetValueType function
NValueSet function
NValueSetP function
NValueToBoolean function
NValueToByte function
NValueToCallback function
NValueToChar function
NValueToChar macro
NValueToDouble function
NValueToInt16 function
NValueToInt32 function
NValueToInt64 function
NValueToObject function
NValueToObjectP function
NValueToPointer function
NValueToResult function
NValueToSByte function
NValueToSSizeType function
NValueToSingle function
NValueToSizeType function
NValueToString function
NValueToUInt16 function
NValueToUInt32 function
NValueToUInt64 function
NValueToValue function
NValueToValueP function
NVehicleDetails Unit
NVehicleDetails class
GetKnownMakes
GetKnownModels
GetKnownModels
GetKnownTags
Models
NVehicleOrientationNativeType
NativeType
Orientation
OrientationAngle
OrientationConfidence
Tags
about NVehicleDetails class
NVehicleDetails.ModelCollection class
about NVehicleDetails.ModelCollection class
NVehicleDetails.TagCollection class
about NVehicleDetails.TagCollection class
NVehicleDetailsGetKnownMakes function
NVehicleDetailsGetKnownModels function
NVehicleDetailsGetKnownModelsByMake function
NVehicleDetailsGetKnownTags function
NVehicleDetailsGetModel function
NVehicleDetailsGetModelCount function
NVehicleDetailsGetModels function
NVehicleDetailsGetOrientation function
NVehicleDetailsGetOrientationAngle function
NVehicleDetailsGetOrientationConfidence function
NVehicleDetailsGetTag function
NVehicleDetailsGetTagCount function
NVehicleDetailsGetTags function
NVehicleModelGetMake function
NVehicleOrientation enumeration
NVehicleOrientation_ enumeration
NVersion structure
!=
<
<=
==
>
>=
CompareTo
Empty
Equals
Equals
GetHashCode
Major
Minor
NVersion
NVersion
NVersion
NativeType
ToString
ToString
about NVersion structure
ushort
NVersion type
NVersionRange structure
!=
==
Contains
Contains
Empty
Equals
Equals
From
GetHashCode
Intersect
Intersect
IntersectsWith
NVersionRange
NVersionRange
NVersionRange
NativeType
To
ToString
ToString
about NVersionRange structure
uint
NVersionRange type
NVersionRangeContains function
NVersionRangeContainsRange function
NVersionRangeIntersect function
NVersionRangeIntersectsWith function
NVersionRangeToString function
NVersionRangeToString macro
NVersionRange_ type
NVersionToString function
NVersionToString macro
NVersion_ type
NVideoFormat Unit
NVideoFormat class
AI44
Argb32
Ayuv
DV25
DV50
DX50
Dvc
Dvh1
Dvhd
Dvsd
Dvsl
FrameRate
H264
Height
I420
InterlaceMode
Iyuv
L16
L8
LongStride
M4S2
MP43
MP4S
MP4V
MediaSubtypeToString
MediaSubtypeToString
Mjpg
Mpg1
Mss1
Mss2
NV11
NV12
NV21
NVideoFormat
NativeStide
NativeType
P010
P016
P210
P216
PixelAspectRatio
Rgb24
Rgb32
Rgb555
Rgb565
Rgb8
Stride
Unknown
Uyvy
V210
V216
V410
Width
Wmv1
Wmv2
Wmv3
Wvc1
Y210
Y216
Y410
Y416
Y41P
Y41T
Y42T
YV12
Yuy2
Yvu9
Yvyu
about NVideoFormat class
NVideoFormat.h
NVideoFormatCreate function
NVideoFormatGetFrameRate function
NVideoFormatGetHeight function
NVideoFormatGetInterlaceMode function
NVideoFormatGetPixelAspectRatio function
NVideoFormatGetStride function
NVideoFormatGetWidth function
NVideoFormatMediaSubtypeToString function
NVideoFormatMediaSubtypeToString macro
NVideoFormatSetFrameRate function
NVideoFormatSetHeight function
NVideoFormatSetInterlaceMode function
NVideoFormatSetPixelAspectRatio function
NVideoFormatSetStride function
NVideoFormatSetWidth function
NVideoInterlaceMode enumeration
NVideoInterlaceModeIsValid function
NVideoInterlaceMode_ enumeration
NWCharParse macro
NWCharParseChars macro
NWCharParseN function
NWCharParseStrOrChars function
NWCharParseStrOrChars macro
NWCharParseVN function
NWCharParseVN macro
NWCharToChars function
NWCharToChars macro
NWCharToString function
NWCharToString macro
NWCharTryParse macro
NWCharTryParseChars macro
NWCharTryParseN function
NWCharTryParseStrOrChars function
NWCharTryParseStrOrChars macro
NWCharTryParseVN function
NWCharTryParseVN macro
NWaitObject Unit
NWaitObjectWaitFor function
NWaitObjectWaitForTimed function
NWindows Unit
NWindows.h
N_64 macro
N_ACHAR_ENCODING macro
N_ALIGN macro
N_ANSI_C macro
N_API macro
N_API_PTR_RET macro
N_AW macro
N_BIG_ENDIAN macro
N_BIOMETRIC_QUALITY_FAILED macro
N_BIOMETRIC_QUALITY_MAX macro
N_BIOMETRIC_QUALITY_MIN macro
N_BIOMETRIC_QUALITY_UNKNOWN macro
N_BOOLEAN_FALSE_STRING macro
N_BOOLEAN_FALSE_STRINGA macro
N_BOOLEAN_FALSE_STRINGW macro
N_BOOLEAN_TRUE_STRING macro
N_BOOLEAN_TRUE_STRINGA macro
N_BOOLEAN_TRUE_STRINGW macro
N_BYTE_MAX macro
N_BYTE_MIN macro
N_CALLBACK macro
N_CALLBACK_AW macro
N_CALL_CONV macro
N_CHAR_ENCODING macro
N_CPP macro
N_DATE_TIME_MAX macro
N_DATE_TIME_MIN macro
N_DEBUG macro
N_DECLARE_HANDLE macro
N_DECLARE_HANDLE_TYPE macro
N_DECLARE_MODULE macro
N_DECLARE_OBJECT_TYPE function
N_DECLARE_OBJECT_TYPE macro
N_DECLARE_STATIC_OBJECT_TYPE macro
N_DECLARE_TYPE function
N_DECLARE_TYPE macro
N_DECLATE_PRIMITIVE macro
N_DEPRECATED macro
N_DOUBLE_EPSILON macro
N_DOUBLE_MAX macro
N_DOUBLE_MIN macro
N_EMPTY_STRING macro
N_EMPTY_STRINGA macro
N_EMPTY_STRINGW macro
N_EVENT_RAISE_1 macro
N_EVENT_RAISE_2 macro
N_EVENT_RAISE_3 macro
N_EVENT_RAISE_4 macro
N_EVENT_RAISE_5 macro
N_EVENT_RAISE_6 macro
N_EVENT_RAISE_RAW macro
N_EVENT_SIZE macro
N_E_ABANDONED_MUTEX macro
N_E_AGGREGATE macro
N_E_ARGUMENT macro
N_E_ARGUMENT_NULL macro
N_E_ARGUMENT_OUT_OF_RANGE macro
N_E_ARITHMETIC macro
N_E_BAD_IMAGE_FORMAT macro
N_E_CLR macro
N_E_COM macro
N_E_CORE macro
N_E_CPP macro
N_E_DIRECTORY_NOT_FOUND macro
N_E_DLL_NOT_FOUND macro
N_E_DRIVE_NOT_FOUND macro
N_E_END_OF_STREAM macro
N_E_ENTRY_POINT_NOT_FOUND macro
N_E_EXTERNAL macro
N_E_FAILED macro
N_E_FILE_FORMAT macro
N_E_FILE_LOAD macro
N_E_FILE_NOT_FOUND macro
N_E_FORMAT macro
N_E_INDEX_OUT_OF_RANGE macro
N_E_INVALID_CAST macro
N_E_INVALID_ENUM_ARGUMENT macro
N_E_INVALID_OPERATION macro
N_E_IO macro
N_E_JVM macro
N_E_KEY_NOT_FOUND macro
N_E_MAC macro
N_E_NOT_ACTIVATED macro
N_E_NOT_IMPLEMENTED macro
N_E_NOT_SUPPORTED macro
N_E_NULL_REFERENCE macro
N_E_OPERATION_CANCELED macro
N_E_OUT_OF_MEMORY macro
N_E_OVERFLOW macro
N_E_PATH_TOO_LONG macro
N_E_SECURITY macro
N_E_SOCKET macro
N_E_SYS macro
N_E_TIMEOUT macro
N_E_WIN32 macro
N_FIELD_AW macro
N_FLOAT_EPSILON macro
N_FLOAT_INFINITY_STRING macro
N_FLOAT_INFINITY_STRINGA macro
N_FLOAT_INFINITY_STRINGW macro
N_FLOAT_MAX macro
N_FLOAT_MIN macro
N_FLOAT_NAN_STRING macro
N_FLOAT_NAN_STRINGA macro
N_FLOAT_NAN_STRINGW macro
N_FUNC_AW macro
N_GCC macro
N_INFINITE macro
N_INT16_MAX macro
N_INT16_MIN macro
N_INT32_MAX macro
N_INT32_MIN macro
N_INT64_MAX macro
N_INT64_MIN macro
N_INT8_MAX macro
N_INT8_MIN macro
N_INT_MAX macro
N_INT_MIN macro
N_JOIN_SYMBOLS macro
N_JOIN_SYMBOLS2 macro
N_JOIN_SYMBOLS2_ macro
N_JOIN_SYMBOLS_ macro
N_LIB macro
N_LIC_MAN_MAX_LICENSE_LENGTH macro
N_LIC_MAN_MAX_SERIAL_LENGTH macro
N_LIKELY macro
N_LINUX macro
N_LIST_LIST_SIZE macro
N_LIST_SIZE macro
N_LONG_MAX macro
N_LONG_MIN macro
N_MAC macro
N_MACRO_AW macro
N_MAX_FILE_NAME macro
N_MODULE_OF macro
N_MONITOR_SIZE macro
N_MSVC macro
N_NEW_LINE macro
N_NO_ANSI_FUNC macro
N_NO_INLINE macro
N_NO_INT_64 macro
N_NO_RETURN macro
N_NO_THROW macro
N_NO_UNICODE macro
N_OBJECT_REF_RET macro
N_OK macro
N_PACKED macro
N_PATH_ALT_DIRECTORY_SEPARATOR macro
N_PATH_DIRECTORY_SEPARATOR macro
N_PATH_IS_CASE_SENSITIVE macro
N_PATH_PATH_SEPARATOR macro
N_PATH_VOLUME_SEPARATOR macro
N_PHRASE_ID_UNKNOWN macro
N_PTR_SIZE macro
N_QUEUE_SIZE macro
N_RETURN_ADDRESS macro
N_SBYTE_MAX macro
N_SBYTE_MIN macro
N_SHORT_MAX macro
N_SHORT_MIN macro
N_SINGLE_EPSILON macro
N_SINGLE_MAX macro
N_SINGLE_MIN macro
N_SIZE_TYPE_MAX macro
N_SIZE_TYPE_MIN macro
N_SLOW_INTERLOCKED macro
N_SSIZE_TYPE_MAX macro
N_SSIZE_TYPE_MIN macro
N_STACK_SIZE macro
N_STATIC_ASSERT macro
N_STRINGIZE macro
N_STRINGIZEA macro
N_STRINGIZEW macro
N_STRINGIZE_ macro
N_STRINGIZE_A macro
N_STRINGIZE_W macro
N_STRING_BUILDER_SIZE macro
N_STRING_SIZE macro
N_STRUCT_AW macro
N_SYMBOL_AW macro
N_T macro
N_TA macro
N_TIME_SPAN_MAX macro
N_TIME_SPAN_MIN macro
N_TIME_SPAN_TICKS_PER_DAY macro
N_TIME_SPAN_TICKS_PER_HOUR macro
N_TIME_SPAN_TICKS_PER_MILLISECOND macro
N_TIME_SPAN_TICKS_PER_MINUTE macro
N_TIME_SPAN_TICKS_PER_SECOND macro
N_TRACE macro
N_TW macro
N_TYPE_AW macro
N_TYPE_OF macro
N_T_A macro
N_T_W macro
N_UINT16_MAX macro
N_UINT16_MIN macro
N_UINT32_MAX macro
N_UINT32_MIN macro
N_UINT64_MAX macro
N_UINT64_MIN macro
N_UINT8_MAX macro
N_UINT8_MIN macro
N_UINT_MAX macro
N_UINT_MIN macro
N_ULONG_MAX macro
N_ULONG_MIN macro
N_UNICODE macro
N_UNLIKELY macro
N_UNREFERENCED_PARAMETER macro
N_UNUSED_VARIABLE macro
N_USHORT_MAX macro
N_USHORT_MIN macro
N_VAR_AW macro
N_VIDEO_FORMAT_AI44 macro
N_VIDEO_FORMAT_ARGB32 macro
N_VIDEO_FORMAT_AVC1 macro
N_VIDEO_FORMAT_AYUV macro
N_VIDEO_FORMAT_DV25 macro
N_VIDEO_FORMAT_DV50 macro
N_VIDEO_FORMAT_DVC macro
N_VIDEO_FORMAT_DVH1 macro
N_VIDEO_FORMAT_DVHD macro
N_VIDEO_FORMAT_DVSD macro
N_VIDEO_FORMAT_DVSL macro
N_VIDEO_FORMAT_DX50 macro
N_VIDEO_FORMAT_H264 macro
N_VIDEO_FORMAT_I420 macro
N_VIDEO_FORMAT_IYUV macro
N_VIDEO_FORMAT_L16 macro
N_VIDEO_FORMAT_L8 macro
N_VIDEO_FORMAT_M4S2 macro
N_VIDEO_FORMAT_MJPG macro
N_VIDEO_FORMAT_MP43 macro
N_VIDEO_FORMAT_MP4S macro
N_VIDEO_FORMAT_MP4V macro
N_VIDEO_FORMAT_MPG1 macro
N_VIDEO_FORMAT_MSS1 macro
N_VIDEO_FORMAT_MSS2 macro
N_VIDEO_FORMAT_NV11 macro
N_VIDEO_FORMAT_NV12 macro
N_VIDEO_FORMAT_NV21 macro
N_VIDEO_FORMAT_P010 macro
N_VIDEO_FORMAT_P016 macro
N_VIDEO_FORMAT_P210 macro
N_VIDEO_FORMAT_P216 macro
N_VIDEO_FORMAT_RGB24 macro
N_VIDEO_FORMAT_RGB32 macro
N_VIDEO_FORMAT_RGB555 macro
N_VIDEO_FORMAT_RGB565 macro
N_VIDEO_FORMAT_RGB8 macro
N_VIDEO_FORMAT_UNKNOWN macro
N_VIDEO_FORMAT_UYVY macro
N_VIDEO_FORMAT_V210 macro
N_VIDEO_FORMAT_V216 macro
N_VIDEO_FORMAT_V410 macro
N_VIDEO_FORMAT_WMV1 macro
N_VIDEO_FORMAT_WMV2 macro
N_VIDEO_FORMAT_WMV3 macro
N_VIDEO_FORMAT_WVC1 macro
N_VIDEO_FORMAT_Y210 macro
N_VIDEO_FORMAT_Y216 macro
N_VIDEO_FORMAT_Y410 macro
N_VIDEO_FORMAT_Y416 macro
N_VIDEO_FORMAT_Y41P macro
N_VIDEO_FORMAT_Y41T macro
N_VIDEO_FORMAT_Y42T macro
N_VIDEO_FORMAT_YUY2 macro
N_VIDEO_FORMAT_YV12 macro
N_VIDEO_FORMAT_YVU9 macro
N_VIDEO_FORMAT_YVYU macro
N_WCHAR_ENCODING macro
N_WCHAR_SIZE macro
N_WINDOWS macro
NationalSemiconductor enumeration member
NdmSample - Adding support of custom device to NDeviceManager
NearestNeighbor enumeration member
Neurotec namespace
Neurotec.Biometrics namespace
Neurotec.Biometrics.NBiometricCaptureOptions enumeration
Neurotec.Biometrics.NBiometricStatus enumeration
Neurotec.Biometrics.NBiometricSubtype enumeration
Neurotec.Biometrics.NBiometricType enumeration
Neurotec.Biometrics.NEImageType enumeration
Neurotec.Biometrics.NEPosition enumeration
Neurotec.Biometrics.NFImpressionType enumeration
Neurotec.Biometrics.NFMinutiaFormat enumeration
Neurotec.Biometrics.NFMinutiaType enumeration
Neurotec.Biometrics.NFPatternClass enumeration
Neurotec.Biometrics.NFPosition enumeration
Neurotec.Biometrics.NFRidgeCountsType enumeration
Neurotec.Biometrics.NGender enumeration
Neurotec.Biometrics.NIcaoWarnings enumeration
Neurotec.Biometrics.NLExpression enumeration
Neurotec.Biometrics.NLProperties enumeration
Neurotec.Biometrics.NLivenessAction enumeration
Neurotec.Biometrics.NLivenessMode enumeration
Neurotec.Biometrics.NfiqQuality enumeration
Neurotec.Collections.ObjectModel namespace
Neurotec.Collections.ObjectModel.NCollectionChangedAction enumeration
Neurotec.Devices namespace
Neurotec.Devices.ComponentModel namespace
Neurotec.Devices.NCameraStatus enumeration
Neurotec.Devices.NDeviceType enumeration
Neurotec.Geometry namespace
Neurotec.IO namespace
Neurotec.Images namespace
Neurotec.Images.Jpeg2KProfile enumeration
Neurotec.Images.NImageRotateFlipType enumeration
Neurotec.Images.NPixelType enumeration
Neurotec.Interop namespace
Neurotec.Licensing namespace
Neurotec.Licensing.NLicenseInfoSourceType enumeration
Neurotec.Licensing.NLicenseInfoStatus enumeration
Neurotec.Licensing.NLicenseInfoType enumeration
Neurotec.Licensing.NLicenseType enumeration
Neurotec.Licensing.NLicensingServiceStatus enumeration
Neurotec.Media namespace
Neurotec.Media.NMediaState enumeration
Neurotec.Media.NMediaType enumeration
Neurotec.Media.NVideoInterlaceMode enumeration
Neurotec.NAsyncStatus enumeration
Neurotec.NAttributes enumeration
Neurotec.NMemoryType enumeration
Neurotec.NModuleOptions enumeration
Neurotec.NOSFamily enumeration
Neurotec.NProcessorFeature enumeration
Neurotec.NProcessorVendor enumeration
Neurotec.NTypeCode enumeration
Neurotec.Plugins namespace
Neurotec.Plugins.ComponentModel namespace
Neurotec.Plugins.NPluginState enumeration
Neurotec.Reflection namespace
Neurotec.Surveillance namespace
Neurotec.Surveillance.Encoding namespace
Neurotec.Surveillance.Encoding.NScaleMethod enumeration
Neurotec.Surveillance.NDetectorScaleCount enumeration
Neurotec.Surveillance.NGpuIndex enumeration
Neurotec.Surveillance.NSurveillanceEventType enumeration
Neurotec.Surveillance.NSurveillanceModalityType enumeration
Neurotec.Surveillance.NSurveillanceObjectColor enumeration
Neurotec.Surveillance.NSurveillanceObjectDirection enumeration
Neurotec.Surveillance.NSurveillanceObjectType enumeration
Neurotec.Surveillance.NSurveillanceSourceType enumeration
Neurotec.Surveillance.NVehicleOrientation enumeration
Neutral enumeration member
NexGen enumeration member
NfiqQuality enumeration
NfiqQualityIsValid function
NfiqQuality_ enumeration
NoAnsiFunc enumeration member
NoEar enumeration member
NoLens enumeration member
NoRead enumeration member
NoUnicode enumeration member
NoWrite enumeration member
None enumeration member
NonliveScanPalm enumeration member
NonliveScanPlain enumeration member
NonliveScanRolled enumeration member
North enumeration member
NorthEast enumeration member
NorthWest enumeration member
NotInstalled enumeration member
NotRecognized enumeration member
NotSpecified enumeration member
NsedGetAttributes function
NsedGetAttributesContainsDetails function
NsedGetBestDetails function
NsedGetBestMatchResult function
NsedGetBestMatchResultCount function
NsedGetBestMatchResults function
NsedGetClothingDetails function
NsedGetCurrentMatchResult function
NsedGetCurrentMatchResultCount function
NsedGetCurrentMatchResults function
NsedGetDetectedFaces function
NsedGetDetectionConfidence function
NsedGetError function
NsedGetFace function
NsedGetFaceConfidence function
NsedGetFaceRectangle function
NsedGetFrameIndex function
NsedGetLicensePlateDetails function
NsedGetMaskConfidence@HNSurveillanceEventDetails@NByte *
NsedGetMergedSubject function
NsedGetModalityType function
NsedGetObjectColor function
NsedGetObjectDirection function
NsedGetObjectType function
NsedGetOriginalImageEx function
NsedGetRectangle function
NsedGetSource function
NsedGetSplitFromSubject function
NsedGetStatus@HNSurveillanceEventDetails@NBiometricStatus *
NsedGetSubjectTemplate function
NsedGetSubjectType function
NsedGetTemplateEx function
NsedGetTimeStamp function
NsedGetTraceIndex function
NsedGetVehicleDetails function
NsedMatchResult class
Id
MatchingDetails
NativeType
Score
about NsedMatchResult class
NsedMatchResult.h
NsedMatchResultCreate function
NsedMatchResultCreateEx function
NsedMatchResultGetId function
NsedMatchResultGetMatchingDetails function
NsedMatchResultGetScore function
Nullable enumeration member
Object enumeration member
ObjectMissing enumeration member
ObjectNotFound enumeration member
ObjectPart enumeration member
ObjectsNotRemoved enumeration member
Occlusion enumeration member
Ok enumeration member
OperationNotActivated enumeration member
OperationNotSupported enumeration member
Optional enumeration member
Orange enumeration member
Other enumeration member
Overview
PNG_DEFAULT_COMPRESSION_LEVEL macro
Palm enumeration member
PalmGeometry enumeration member
PalmPrint enumeration member
PalmScanner enumeration member
ParametricLicense enumeration member
Passive enumeration member
PassiveAndActive enumeration member
PassiveWithBlink enumeration member
PausePending enumeration member
Paused enumeration member
Person enumeration member
PitchDown enumeration member
PitchUp enumeration member
Pixelation enumeration member
PlainArch enumeration member
PlainLeftFourFingers enumeration member
PlainLeftThumb enumeration member
PlainRightFourFingers enumeration member
PlainRightThumb enumeration member
PlainThumbs enumeration member
PlainWhorl enumeration member
Plugged enumeration member
PluggingError enumeration member
Png Unit
Png.h
PngInfo class
CompressionLevel
DefaultCompressionLevel
NativeType
about PngInfo class
PngInfoGetCompressionLevel function
PngInfoSetCompressionLevel function
Pointer enumeration member
Poor enumeration member
Progressive enumeration member
PromoteValue enumeration member
Protected enumeration member
Public enumeration member
RadialLoop enumeration member
RaisedBrows enumeration member
Rational enumeration member
Rear enumeration member
RearLeft enumeration member
RearRight enumeration member
Red enumeration member
RedEye enumeration member
Reference
.NET
API
Remove enumeration member
Replace enumeration member
Required Libraries
Reset enumeration member
Result enumeration member
RetValue enumeration member
Retina enumeration member
Rgb enumeration member
Right enumeration member
RightBackOfHand enumeration member
RightEyePatch enumeration member
RightFullPalm enumeration member
RightHypothenar enumeration member
RightIndex enumeration member
RightIndexFinger enumeration member
RightIndexLeftIndexFingers enumeration member
RightIndexMiddleFingers enumeration member
RightIndexMiddleRingFingers enumeration member
RightInterdigital enumeration member
RightLittle enumeration member
RightLittleFinger enumeration member
RightLowerPalm enumeration member
RightMiddle enumeration member
RightMiddleFinger enumeration member
RightMiddleRingFingers enumeration member
RightMiddleRingLittleFingers enumeration member
RightOther enumeration member
RightPalm enumeration member
RightPointerFinger enumeration member
RightRing enumeration member
RightRingFinger enumeration member
RightRingLittleFingers enumeration member
RightSlantLoop enumeration member
RightThenar enumeration member
RightThumb enumeration member
RightUpperPalm enumeration member
RightWrist enumeration member
RightWritersPalm enumeration member
RiseTechnology enumeration member
RollLeft enumeration member
RollRight enumeration member
Rotate180 enumeration member
Rotate270 enumeration member
Rotate90 enumeration member
RotateNone enumeration member
RotateYaw enumeration member
Running enumeration member
SByte enumeration member
SSizeType enumeration member
Samples
Saturation enumeration member
Scar enumeration member
Scarf enumeration member
Scent enumeration member
Sealed enumeration member
SensorCleaning enumeration member
SerialNumber enumeration member
Set enumeration member
Sharpness enumeration member
SiS enumeration member
SignNeutral enumeration member
SignatureDynamics enumeration member
SignatureOrSign enumeration member
SignatureScanner enumeration member
Signed enumeration member
SilentOperation enumeration member
Silver enumeration member
Simple enumeration member
Single enumeration member
SingleComputer enumeration member
SingleValue enumeration member
SizeType enumeration member
SkinReflection enumeration member
Smile enumeration member
SmileOpenedJaw enumeration member
SmoothEdge enumeration member
SourceError enumeration member
SourceMissing enumeration member
SourceNotFound enumeration member
South enumeration member
SouthEast enumeration member
SouthWest enumeration member
Specified enumeration member
SpoofDetected enumeration member
Squinting enumeration member
Standard enumeration member
StartPending enumeration member
Started enumeration member
Static enumeration member
StdValues enumeration member
StdValuesExclusive enumeration member
StopPending enumeration member
Stopped enumeration member
Stream enumeration member
String enumeration member
StroboCharge enumeration member
SubjectAppeared enumeration member
SubjectDisappeared enumeration member
SubjectMerged enumeration member
SubjectSplit enumeration member
SubjectTrack enumeration member
SuperSampling enumeration member
Support
Swipe enumeration member
System Requirements
TeethVisible enumeration member
TentedArch enumeration member
ThermalFace enumeration member
ThermalFaceImage enumeration member
ThermalHand enumeration member
ThermalHandImage enumeration member
Tiff Unit
Tiff.h
TiffInfo class
NativeType
about TiffInfo class
TimeSpan enumeration member
Timeout enumeration member
Tips enumeration member
TooClose enumeration member
TooEast enumeration member
TooFar enumeration member
TooFast enumeration member
TooFewFeatures enumeration member
TooFewObjects enumeration member
TooFewSamples enumeration member
TooHard enumeration member
TooLong enumeration member
TooManyObjects enumeration member
TooNarrow enumeration member
TooNear enumeration member
TooNoisy enumeration member
TooNorth enumeration member
TooShort enumeration member
TooSkewed enumeration member
TooSlow enumeration member
TooSoft enumeration member
TooSouth enumeration member
TooWest enumeration member
TooWide enumeration member
Transmeta enumeration member
Truck enumeration member
TurnDown enumeration member
TurnLeft enumeration member
TurnRight enumeration member
TurnToCenter enumeration member
TurnUp enumeration member
Tutorials
UInt16 enumeration member
UInt32 enumeration member
UInt64 enumeration member
URational enumeration member
UlnarLoop enumeration member
Umc enumeration member
Uncropped enumeration member
Undefined enumeration member
Unicode enumeration member
Unix enumeration member
Unknown enumeration member
UnknownFourFingers enumeration member
UnknownLatentFingers enumeration member
UnknownPalm enumeration member
UnknownThreeFingers enumeration member
UnknownTwoFingers enumeration member
UnnaturalSkinTone enumeration member
Unplugged enumeration member
Unspecified enumeration member
Unused enumeration member
VH (vehicle-human) Modality
Valid enumeration member
Value enumeration member
VehiclesAndHumans enumeration member
Vein enumeration member
VeinPattern enumeration member
VeryGood enumeration member
Vga enumeration member
Via enumeration member
Video enumeration member
Voice enumeration member
WChar enumeration member
WSQ_DEFAULT_BIT_RATE macro
WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_DEBIAN_AMD64_LEGACY macro
WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_DEBIAN_I386_LEGACY macro
WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_MACOSX_INTEL64 macro
WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_MACOSX_INTEL_LEGACY macro
WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_MACOSX_POWERPC_LEGACY macro
WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_WIN32_X86 macro
WSQ_IMPLEMENTATION_NEUROTECHNOLOGY_WIN64_X64 macro
WSQ_RECOVER_CORRUPT_FILE macro
WashedOut enumeration member
West enumeration member
What's new
White enumeration member
Whorl enumeration member
Win32Global enumeration member
Win32Local enumeration member
Windows enumeration member
WindowsCE enumeration member
WindowsPhone enumeration member
WrongDirection enumeration member
WrongHand enumeration member
Wsq Unit
Wsq.h
WsqInfoGetBitRate function
WsqInfoGetImplementationNumber function
WsqInfoGetNistCom function
WsqInfoHasNistCom function
WsqInfoSetBitRate function
WsqInfoSetHasNistCom function
YawLeft enumeration member
YawRight enumeration member
Yellow enumeration member
jpeg2kpFaceLossless enumeration member
jpeg2kpFaceLossy enumeration member
jpeg2kpFingerprint1000Ppi enumeration member
jpeg2kpFingerprintLossless enumeration member
jpeg2kpNone enumeration member
N
naArray enumeration member
naByRef enumeration member
naCache enumeration member
naDefaultValue enumeration member
naDeprecated enumeration member
naGlobal enumeration member
naLocal enumeration member
naMaxValue enumeration member
naMinValue enumeration member
naNoRead enumeration member
naNoWrite enumeration member
naNone enumeration member
naNullable enumeration member
naOptional enumeration member
naPromoteValue enumeration member
naPublic enumeration member
naRetValue enumeration member
naSealed enumeration member
naSet enumeration member
naSignNeutral enumeration member
naSingleValue enumeration member
naStatic enumeration member
naStdValues enumeration member
naStdValuesExclusive enumeration member
nasCanceled enumeration member
nasCompleted enumeration member
nasFaulted enumeration member
nasNone enumeration member
nasStarted enumeration member
nbcoManual enumeration member
nbcoNone enumeration member
nbcoStream enumeration member
nboBigEndian enumeration member
nboLittleEndian enumeration member
nbsBadContrast enumeration member
nbsBadDynamicRange enumeration member
nbsBadExposure enumeration member
nbsBadLighting enumeration member
nbsBadObject enumeration member
nbsBadObjectSequence enumeration member
nbsBadPose enumeration member
nbsBadPosition enumeration member
nbsBadSharpness enumeration member
nbsBadSize enumeration member
nbsBadSpeed enumeration member
nbsCanceled enumeration member
nbsCaptureError enumeration member
nbsCleaningNeeded enumeration member
nbsCommunicationError enumeration member
nbsConflict enumeration member
nbsDuplicateFound enumeration member
nbsDuplicateId enumeration member
nbsIdNotFound enumeration member
nbsIncompatibleSamples enumeration member
nbsIncompatibleSource enumeration member
nbsInternalError enumeration member
nbsInvalidFieldValue enumeration member
nbsInvalidId enumeration member
nbsInvalidOperations enumeration member
nbsInvalidPropertyValue enumeration member
nbsInvalidQuery enumeration member
nbsInvalidSampleResolution enumeration member
nbsMaskDetected enumeration member
nbsMatchNotFound enumeration member
nbsNone enumeration member
nbsObjectMissing enumeration member
nbsObjectNotFound enumeration member
nbsObjectsNotRemoved enumeration member
nbsOcclusion enumeration member
nbsOk enumeration member
nbsOperationNotActivated enumeration member
nbsOperationNotSupported enumeration member
nbsSourceError enumeration member
nbsSourceMissing enumeration member
nbsSourceNotFound enumeration member
nbsSpoofDetected enumeration member
nbsTimeout enumeration member
nbsTips enumeration member
nbsTooClose enumeration member
nbsTooEast enumeration member
nbsTooFar enumeration member
nbsTooFast enumeration member
nbsTooFewFeatures enumeration member
nbsTooFewObjects enumeration member
nbsTooFewSamples enumeration member
nbsTooHard enumeration member
nbsTooLong enumeration member
nbsTooManyObjects enumeration member
nbsTooNarrow enumeration member
nbsTooNoisy enumeration member
nbsTooNorth enumeration member
nbsTooShort enumeration member
nbsTooSkewed enumeration member
nbsTooSlow enumeration member
nbsTooSoft enumeration member
nbsTooSouth enumeration member
nbsTooWest enumeration member
nbsTooWide enumeration member
nbsWrongDirection enumeration member
nbsWrongHand enumeration member
nbstLeft enumeration member
nbstLeftBackOfHand enumeration member
nbstLeftLittleFinger enumeration member
nbstLeftMiddleFinger enumeration member
nbstLeftPalm enumeration member
nbstLeftPointerFinger enumeration member
nbstLeftRingFinger enumeration member
nbstLeftThumb enumeration member
nbstLeftWrist enumeration member
nbstNone enumeration member
nbstRight enumeration member
nbstRightBackOfHand enumeration member
nbstRightLittleFinger enumeration member
nbstRightMiddleFinger enumeration member
nbstRightPalm enumeration member
nbstRightPointerFinger enumeration member
nbstRightRingFinger enumeration member
nbstRightThumb enumeration member
nbstRightWrist enumeration member
nbtAll enumeration member
nbtBodyOdor enumeration member
nbtDna enumeration member
nbtEar enumeration member
nbtEarShape enumeration member
nbtFace enumeration member
nbtFacialFeatures enumeration member
nbtFinger enumeration member
nbtFingerGeometry enumeration member
nbtFingerprint enumeration member
nbtFoot enumeration member
nbtFootPrint enumeration member
nbtGait enumeration member
nbtHandGeometry enumeration member
nbtIris enumeration member
nbtKeystroke enumeration member
nbtKeystrokeDynamics enumeration member
nbtLipMovement enumeration member
nbtMultipleBiometrics enumeration member
nbtNone enumeration member
nbtPalm enumeration member
nbtPalmGeometry enumeration member
nbtPalmPrint enumeration member
nbtRetina enumeration member
nbtScent enumeration member
nbtSignatureDynamics enumeration member
nbtSignatureOrSign enumeration member
nbtThermalFace enumeration member
nbtThermalFaceImage enumeration member
nbtThermalHand enumeration member
nbtThermalHandImage enumeration member
nbtVein enumeration member
nbtVeinPattern enumeration member
nbtVoice enumeration member
nccaAdd enumeration member
nccaMove enumeration member
nccaRemove enumeration member
nccaReplace enumeration member
nccaReset enumeration member
ncsAutoFocusFailure enumeration member
ncsLensClosed enumeration member
ncsMirrorUp enumeration member
ncsNoLens enumeration member
ncsNone enumeration member
ncsOk enumeration member
ncsSensorCleaning enumeration member
ncsSilentOperation enumeration member
ncsStroboCharge enumeration member
ndowFriday enumeration member
ndowMonday enumeration member
ndowSaturday enumeration member
ndowSunday enumeration member
ndowThursday enumeration member
ndowTuesday enumeration member
ndowWednesday enumeration member
ndtAny enumeration member
ndtBiometricDevice enumeration member
ndtCamera enumeration member
ndtCaptureDevice enumeration member
ndtFScanner enumeration member
ndtFingerScanner enumeration member
ndtIrisScanner enumeration member
ndtMicrophone enumeration member
ndtNone enumeration member
ndtPalmScanner enumeration member
ndtSignatureScanner enumeration member
neAscii enumeration member
neDefault enumeration member
neUtf16BE enumeration member
neUtf16LE enumeration member
neUtf32BE enumeration member
neUtf32LE enumeration member
neUtf7 enumeration member
neUtf8 enumeration member
neitCropped enumeration member
neitCroppedAndMasked enumeration member
neitUncropped enumeration member
neitVga enumeration member
nepBoth enumeration member
nepLeft enumeration member
nepRight enumeration member
nepUnknown enumeration member
nfaRead enumeration member
nfaReadWrite enumeration member
nfaWrite enumeration member
nfatDirectory enumeration member
nfatNone enumeration member
nfitLatentImpression enumeration member
nfitLatentLift enumeration member
nfitLatentPalmImpression enumeration member
nfitLatentPalmLift enumeration member
nfitLatentPalmPhoto enumeration member
nfitLatentPalmTracing enumeration member
nfitLatentPhoto enumeration member
nfitLatentTracing enumeration member
nfitLiveScanContactless enumeration member
nfitLiveScanNonOpticalContactPlain enumeration member
nfitLiveScanNonOpticalContactRolled enumeration member
nfitLiveScanNonOpticalContactlessPlain enumeration member
nfitLiveScanNonOpticalContactlessRolled enumeration member
nfitLiveScanOpticalContactPlain enumeration member
nfitLiveScanOpticalContactRolled enumeration member
nfitLiveScanOpticalContactlessPlain enumeration member
nfitLiveScanOpticalContactlessRolled enumeration member
nfitLiveScanPalm enumeration member
nfitLiveScanPlain enumeration member
nfitLiveScanRolled enumeration member
nfitLiveScanVerticalSwipe enumeration member
nfitNonliveScanPalm enumeration member
nfitNonliveScanPlain enumeration member
nfitNonliveScanRolled enumeration member
nfitOther enumeration member
nfitPlainContactlessMoving enumeration member
nfitRolledContactlessMoving enumeration member
nfitSwipe enumeration member
nfitUnknown enumeration member
nfmAppend enumeration member
nfmCreate enumeration member
nfmCreateNew enumeration member
nfmOpen enumeration member
nfmOpenOrCreate enumeration member
nfmTruncate enumeration member
nfpLeftFullPalm enumeration member
nfpLeftHypothenar enumeration member
nfpLeftIndex enumeration member
nfpLeftIndexFinger enumeration member
nfpLeftIndexMiddleFingers enumeration member
nfpLeftIndexMiddleRingFingers enumeration member
nfpLeftInterdigital enumeration member
nfpLeftLittle enumeration member
nfpLeftLittleFinger enumeration member
nfpLeftLowerPalm enumeration member
nfpLeftMiddle enumeration member
nfpLeftMiddleFinger enumeration member
nfpLeftMiddleRingFingers enumeration member
nfpLeftMiddleRingLittleFingers enumeration member
nfpLeftOther enumeration member
nfpLeftRing enumeration member
nfpLeftRingFinger enumeration member
nfpLeftRingLittleFingers enumeration member
nfpLeftThenar enumeration member
nfpLeftThumb enumeration member
nfpLeftUpperPalm enumeration member
nfpLeftWritersPalm enumeration member
nfpPlainLeftFourFingers enumeration member
nfpPlainLeftThumb enumeration member
nfpPlainRightFourFingers enumeration member
nfpPlainRightThumb enumeration member
nfpPlainThumbs enumeration member
nfpRightFullPalm enumeration member
nfpRightHypothenar enumeration member
nfpRightIndex enumeration member
nfpRightIndexFinger enumeration member
nfpRightIndexLeftIndexFingers enumeration member
nfpRightIndexMiddleFingers enumeration member
nfpRightIndexMiddleRingFingers enumeration member
nfpRightInterdigital enumeration member
nfpRightLittle enumeration member
nfpRightLittleFinger enumeration member
nfpRightLowerPalm enumeration member
nfpRightMiddle enumeration member
nfpRightMiddleFinger enumeration member
nfpRightMiddleRingFingers enumeration member
nfpRightMiddleRingLittleFingers enumeration member
nfpRightOther enumeration member
nfpRightRing enumeration member
nfpRightRingFinger enumeration member
nfpRightRingLittleFingers enumeration member
nfpRightThenar enumeration member
nfpRightThumb enumeration member
nfpRightUpperPalm enumeration member
nfpRightWritersPalm enumeration member
nfpUnknown enumeration member
nfpUnknownFourFingers enumeration member
nfpUnknownPalm enumeration member
nfpUnknownThreeFingers enumeration member
nfpUnknownTwoFingers enumeration member
nfqExcellent enumeration member
nfqFair enumeration member
nfqGood enumeration member
nfqPoor enumeration member
nfqUnknown enumeration member
nfqVeryGood enumeration member
nfsNone enumeration member
nfsRead enumeration member
nfsReadWrite enumeration member
nfsWrite enumeration member
ngFemale enumeration member
ngMale enumeration member
ngUnknown enumeration member
ngUnspecified enumeration member
ngiAll enumeration member
ngiGpu0 enumeration member
ngiGpu1 enumeration member
ngiGpu2 enumeration member
ngiGpu3 enumeration member
ngiGpu4 enumeration member
ngiGpu5 enumeration member
ngiGpu6 enumeration member
ngiGpu7 enumeration member
ngiNone enumeration member
nicaJP2 enumeration member
nicaJP2L enumeration member
nicaJpeg enumeration member
nicaJpegL enumeration member
nicaNone enumeration member
nicaPng enumeration member
nicaUnknown enumeration member
nicaUnspecified enumeration member
nicaWsq20 enumeration member
nimBicubic enumeration member
nimBilinear enumeration member
nimNearestNeighbor enumeration member
nirftFlipNone enumeration member
nirftFlipX enumeration member
nirftFlipXY enumeration member
nirftFlipY enumeration member
nirftNone enumeration member
nirftRotate180 enumeration member
nirftRotate270 enumeration member
nirftRotate90 enumeration member
nirftRotateNone enumeration member
nirftUnspecified enumeration member
niwBackgroundUniformity enumeration member
niwBlink enumeration member
niwDarkGlasses enumeration member
niwExpression enumeration member
niwFaceDarkness enumeration member
niwFaceNotDetected enumeration member
niwGlassesReflection enumeration member
niwGrayscaleDensity enumeration member
niwHeavyFrame enumeration member
niwLookingAway enumeration member
niwMouthOpen enumeration member
niwNone enumeration member
niwPitchDown enumeration member
niwPitchUp enumeration member
niwPixelation enumeration member
niwRedEye enumeration member
niwRollLeft enumeration member
niwRollRight enumeration member
niwSaturation enumeration member
niwSharpness enumeration member
niwSkinReflection enumeration member
niwTooEast enumeration member
niwTooFar enumeration member
niwTooNear enumeration member
niwTooNorth enumeration member
niwTooSouth enumeration member
niwTooWest enumeration member
niwUnnaturalSkinTone enumeration member
niwWashedOut enumeration member
niwYawLeft enumeration member
niwYawRight enumeration member
nlaBlink enumeration member
nlaKeepRotatingYaw enumeration member
nlaKeepStill enumeration member
nlaMoveBack enumeration member
nlaMoveCloser enumeration member
nlaNone enumeration member
nlaRotateYaw enumeration member
nlaTurnDown enumeration member
nlaTurnLeft enumeration member
nlaTurnRight enumeration member
nlaTurnToCenter enumeration member
nlaTurnUp enumeration member
nleEyesAway enumeration member
nleFrowning enumeration member
nleNeutral enumeration member
nleRaisedBrows enumeration member
nleSmile enumeration member
nleSmileOpenedJaw enumeration member
nleSquinting enumeration member
nleUnknown enumeration member
nleUnspecified enumeration member
nlisInvalid enumeration member
nlisUnknown enumeration member
nlisValid enumeration member
nlistDongle enumeration member
nlistFile enumeration member
nlistInternet enumeration member
nlistUnknown enumeration member
nlitHardwareId enumeration member
nlitLicense enumeration member
nlitParametricHardwareId enumeration member
nlitParametricLicense enumeration member
nlitParametricSerial enumeration member
nlitSerialNumber enumeration member
nlitUnknown enumeration member
nlmActive enumeration member
nlmCustom enumeration member
nlmNone enumeration member
nlmPassive enumeration member
nlmPassiveAndActive enumeration member
nlmPassiveWithBlink enumeration member
nlmSimple enumeration member
nlosLicenseNotObtained enumeration member
nlosLicenseObtained enumeration member
nlosServerOffline enumeration member
nlosUnknown enumeration member
nlpBeard enumeration member
nlpBlink enumeration member
nlpBothEyePatch enumeration member
nlpDarkGlasses enumeration member
nlpDistortingCondition enumeration member
nlpFaceMask enumeration member
nlpGlasses enumeration member
nlpHat enumeration member
nlpHeavyFrame enumeration member
nlpLeftEyePatch enumeration member
nlpMouthOpen enumeration member
nlpMustache enumeration member
nlpNoEar enumeration member
nlpNotSpecified enumeration member
nlpRightEyePatch enumeration member
nlpScarf enumeration member
nlpSpecified enumeration member
nlpTeethVisible enumeration member
nlssContinuePending enumeration member
nlssNotInstalled enumeration member
nlssPausePending enumeration member
nlssPaused enumeration member
nlssRunning enumeration member
nlssStartPending enumeration member
nlssStopPending enumeration member
nlssStopped enumeration member
nltConcurrent enumeration member
nltSigned enumeration member
nltSingleComputer enumeration member
nmmtAligned enumeration member
nmmtCustom enumeration member
nmmtDefault enumeration member
nmmtNone enumeration member
nmmtStandard enumeration member
nmmtWin32Global enumeration member
nmmtWin32Local enumeration member
nmoDebug enumeration member
nmoExe enumeration member
nmoLib enumeration member
nmoNoAnsiFunc enumeration member
nmoNoUnicode enumeration member
nmoNone enumeration member
nmoProtected enumeration member
nmoUnicode enumeration member
nmsPaused enumeration member
nmsRunning enumeration member
nmsStopped enumeration member
nmtAudio enumeration member
nmtNone enumeration member
nmtVideo enumeration member
nosfAndroid enumeration member
nosfEmbeddedLinux enumeration member
nosfIOS enumeration member
nosfLinux enumeration member
nosfMacOSX enumeration member
nosfNone enumeration member
nosfUnix enumeration member
nosfWindows enumeration member
nosfWindowsCE enumeration member
nosfWindowsPhone enumeration member
npsDisabled enumeration member
npsDuplicate enumeration member
npsIncompatibleWithOtherPlugins enumeration member
npsInterfaceTypeMismatch enumeration member
npsInterfaceVersionMismatch enumeration member
npsInvalidInterface enumeration member
npsInvalidModule enumeration member
npsLoadError enumeration member
npsNone enumeration member
npsNotRecognized enumeration member
npsPlugged enumeration member
npsPluggingError enumeration member
npsUnplugged enumeration member
npsUnused enumeration member
nptGrayscale enumeration member
nptRgb enumeration member
nptUndefined enumeration member
npvAmd enumeration member
npvCentaur enumeration member
npvCyrix enumeration member
npvIntel enumeration member
npvNationalSemiconductor enumeration member
npvNexGen enumeration member
npvRiseTechnology enumeration member
npvSiS enumeration member
npvTransmeta enumeration member
npvUmc enumeration member
npvUnknown enumeration member
nsetAny enumeration member
nsetFacesDetected enumeration member
nsetImageCaptured enumeration member
nsetSubjectAppeared enumeration member
nsetSubjectDisappeared enumeration member
nsetSubjectMerged enumeration member
nsetSubjectSplit enumeration member
nsetSubjectTrack enumeration member
nsmCubic enumeration member
nsmCubicB05C03 enumeration member
nsmCubicCatmullRom enumeration member
nsmCubicSpline enumeration member
nsmLanczos enumeration member
nsmLanczosAdvanced enumeration member
nsmLinear enumeration member
nsmNearestNeighbor enumeration member
nsmSmoothEdge enumeration member
nsmSuperSampling enumeration member
nsmtFaces enumeration member
nsmtLicensePlateRecognition enumeration member
nsmtNone enumeration member
nsmtVehiclesAndHumans enumeration member
nsoBegin enumeration member
nsoCurrent enumeration member
nsoEnd enumeration member
nsocAny enumeration member
nsocBlack enumeration member
nsocBlue enumeration member
nsocBrown enumeration member
nsocGray enumeration member
nsocGreen enumeration member
nsocNone enumeration member
nsocOrange enumeration member
nsocRed enumeration member
nsocSilver enumeration member
nsocWhite enumeration member
nsocYellow enumeration member
nsodAny enumeration member
nsodEast enumeration member
nsodNone enumeration member
nsodNorth enumeration member
nsodNorthEast enumeration member
nsodNorthWest enumeration member
nsodSouth enumeration member
nsodSouthEast enumeration member
nsodSouthWest enumeration member
nsodWest enumeration member
nsotAny enumeration member
nsotBike enumeration member
nsotBus enumeration member
nsotCar enumeration member
nsotNone enumeration member
nsotPerson enumeration member
nsotTruck enumeration member
nsstCamera enumeration member
nsstUnknown enumeration member
nsstVideo enumeration member
ntcAChar enumeration member
ntcArray enumeration member
ntcArrayCollection enumeration member
ntcAsyncOperation enumeration member
ntcBoolean enumeration member
ntcBuffer enumeration member
ntcByte enumeration member
ntcCallback enumeration member
ntcChar enumeration member
ntcCollection enumeration member
ntcComplex enumeration member
ntcDateTime enumeration member
ntcDictionary enumeration member
ntcDouble enumeration member
ntcGuid enumeration member
ntcInt16 enumeration member
ntcInt32 enumeration member
ntcInt64 enumeration member
ntcNone enumeration member
ntcObject enumeration member
ntcObjectPart enumeration member
ntcOther enumeration member
ntcPointer enumeration member
ntcRational enumeration member
ntcResult enumeration member
ntcSByte enumeration member
ntcSSizeType enumeration member
ntcSingle enumeration member
ntcSizeType enumeration member
ntcString enumeration member
ntcTimeSpan enumeration member
ntcUInt16 enumeration member
ntcUInt32 enumeration member
ntcUInt64 enumeration member
ntcURational enumeration member
ntcValue enumeration member
ntcWChar enumeration member
nvimInterlaced enumeration member
nvimProgressive enumeration member
nvimUnknown enumeration member
nvoFront enumeration member
nvoFrontLeft enumeration member
nvoFrontRight enumeration member
nvoLeft enumeration member
nvoRear enumeration member
nvoRearLeft enumeration member
nvoRearRight enumeration member
nvoRight enumeration member
P
pValue variable
W
wxWidgets Compilation


Welcome

User's guide

Copyright © 2009-2023 Neurotechnology. All rights reserved.